Welcome to ComponentOne Preview for .NET

ComponentOne Preview for .NET E-mail sent to documentation@componentone.com is for documentation feedback only. We welcome any suggestions to help improve our documentation.

Welcome to ComponentOne Preview for .NET

Previous Next

Welcome to ComponentOne Preview™ for .NET, a .NET control designed to support the creation and management of documents for printing and previewing.

If you like Preview for .NET, you can check out our other products by visiting our web site at http://www.componentone.com.

ComponentOne has a user-friendly distribution policy. We want every programmer to get copies of our products and try them for as long as they want. Those who like the tools and find them useful can buy licenses at reasonable prices. The only restriction is that unlicensed copies of the software will display a ComponentOne banner when they are loaded, as a friendly reminder that we do expect people to pay for the software if they use it on a regular basis.

We hope you'll like Preview for .NET. If you have suggestions or ideas for new features or new tools, please call us or write.

Corporate Headquarters

ComponentOne LLC
201 South Highland Avenue
3rd Floor
Pittsburgh, PA 15206 • USA
412.681.4343
412.681.4384 (Fax)

http://www.componentone.com

Overview

What's New in ComponentOne Preview for .NET

Installing Preview for .NET

END-USER LICENSE AGREEMENT FOR COMPONENTONE SOFTWARE

Licensing FAQs

Technical Support

Redistributable Files

Namespaces

Creating a .NET Project

Adding Preview for .NET Components to the Toolbox

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


Overview

Overview

This release of C1Preview for .NET is a completely reworked version of Preview for .NET (which consisted of C1PrintDocument and C1PrintPreview). Though providing similar functionality, this new release presents a new and improved object model, more robust and modular design, better performance, and many other improvements over the old version.

Please note that though the functionality is similar to the old version of the product, the object model of both the C1PrintDocument component and the print preview control has been significantly changed, so the new components are not binary- or code-compatible with the old components.

The new C1Preview for .NET consists of the following assemblies:

C1.C1Preview.2.dll

C1.C1Preview.2.dll provides the C1PrintDocument component and other public classes providing non-Windows Forms specific services, such as export and so on. This assembly does not reference other ComponentOne DLL files. Most of the classes in this assembly are in namespace C1.C1Preview.

C1.Win.C1Preview.2.dll

C1.Win.C1Preview.2.dll provides Windows Forms controls that can work with C1PrintDocument and other types of documents, including:

C1PreviewPane | The preview pane. This control shows the pages of the document being previewed, allows panning, zooming and other preview operations. In the forms designer, standard toolbars and status bar can be created on the current form via context menu items.
C1PrintPreviewControl | The integrated print preview control. Contains the preview pane, toolbars with the standard preview related operations, navigation panel with thumbnails and outline pages, and the collapsible text search panel.
C1PrintPreviewDialog | A dialog form with the nested print preview control.
C1PreviewThumbnails | Panel that can be attached to a preview pane (via the PreviewPane property) to show navigability page thumbnails.
C1PreviewOutline | Panel that can be attached to a preview pane (via the PreviewPane property) to show the document outline.
C1PreviewTextSearchPanel | Panel that can be attached to a preview pane (via the PreviewPane property) to perform text search in the document.

This assembly references the C1.C1PrintDocument DLL. Most of the classes in this assembly are in namespace C1.Win.C1Preview.

This product requires .NET version 2.0 or later.


What's New in ComponentOne Preview for .NET

What's New in ComponentOne Preview for .NET

This documentation was last revised for 2006 v1 on December 30, 2005.

Overview of What's New in ComponentOne Preview for .NET


Installing Preview for .NET

Installing Preview for .NET

This section describes the setup files and system requirements for Preview for .NET. It also explains how to install demonstration versions of ComponentOne products and uninstall Preview for .NET.

Preview for .NET Setup Files

System Requirements

Installing Demonstration Versions

Uninstalling Preview for .NET


Preview for .NET Setup Files

Preview for .NET Setup Files

The installation program will create the directory C:\Program Files\ComponentOne Studio.NET, which contains the following subdirectories:

bin | Contains copies of all binaries (DLLs, EXEs) in the ComponentOne Visual Studio.NET package.
Common | Contains support and data files that are used by many of the demo programs.
Help | Contains online documentation for all Studio components.
C1Preview | Contains samples and tutorials for Preview for .NET.

To install the Preview for .NET, run the C1Reporting.msi installation file provided in the distribution CD (or downloaded from the web). If the installation is being performed from the distribution CD, a menu should appear when it is placed in the computer. From the menu, click the Install Software link for the Reporting Components, and follow the instructions. It is important to note that selecting the Typical installation type will install all of the ComponentOne controls and components within the msi and their supporting files. If you wish to install only Preview for .NET, select the Custom installation type and remove any unwanted features.


System Requirements

System Requirements

· Operating Systems:

Windows 2000

Windows 2003 Server

Windows NT 4

Windows XP, SP1, SP2

· Environments:

.NET Framework 2.0 or later

C# .NET

Delphi

Visual Basic .NET

· Hard Disk Space: 25 MB of hard disk space for storage of the software

· Disc Drive: CD or DVD-ROM drive if installing from CD


Installing Demonstration Versions

Installing Demonstration Versions

If you wish to try Preview for .NET or any of our other products and do not have a registration key, follow the steps through the Installation wizard and use the default serial number.

The only difference between unregistered (demonstration) and registered (purchased) versions of our products is that registered versions will stamp every application you compile so a ComponentOne banner will not appear when your users run the applications.


Uninstalling Preview for .NET

Uninstalling Preview for .NET

To uninstall Preview for .NET, open the Control Panel and select the Add or Remove Programs. Select Preview for .NET and click the Remove button.


END-USER LICENSE AGREEMENT FOR COMPONENTONE SOFTWARE

END-USER LICENSE AGREEMENT FOR COMPONENTONE SOFTWARE

IMPORTANT-READ CAREFULLY: This End User License Agreement (this "EULA") contains the terms and conditions that govern your use of the SOFTWARE (as defined below) and imposes material limitations to your rights. You should read this EULA carefully and treat it as valuable property.

I. THIS EULA.

1. Software Covered by this EULA. This EULA governs your use of the ComponentOne, LLC ("C1") software product(s) enclosed or otherwise accompanied herewith (individually and collectively, the "SOFTWARE"). The term "SOFTWARE" includes, to the extent provided by C1: 1) any revisions, updates and/or upgrades thereto; 2) any data, image or executable files, databases, data engines, computer software, or similar items customarily used or distributed with computer software products; 3) anything in any form whatsoever intended to be used with or in conjunction with the SOFTWARE; and 4) any associated media, documentation (including physical, electronic and online) and printed materials (the "Documentation").

2. This EULA is a Legally Binding Agreement Between You and C1. If you are acting as an agent of a company or another legal person, such as an officer or other employee acting for your employer, then "you" and "your" mean your principal, the entity or other legal person for whom you are acting. However, importantly, even if you are acting as an agent for another, you may still be personally liable for violation of federal and State laws, such as copyright infringement.

By signifying your acceptance of the terms of this EULA, you intend to be, and hereby are, legally bound to this EULA to the same extent as if C1 and you physically signed this EULA. By installing, copying, or otherwise using the SOFTWARE, you agree to be bound by all the terms and conditions of this EULA. If you do not agree to all of such terms and conditions, you may not install or use the SOFTWARE. If you do not agree with any of the terms herewith and, for whatever reason, installation has begun or has been completed, you should cancel installation or un-install the SOFTWARE, as the case may be. Furthermore, you should promptly return the SOFTWARE to the place of business from which you obtained it in accordance with any return policies of such place of business. Return policies may vary among resellers; therefore you must comply with the return policies of your supplier as you agreed at the point of purchase. If the place of business from which you purchased the SOFTWARE does not honor a full refund for a period of thirty (30) days from the date of purchase, you may then return the SOFTWARE directly to C1 for a refund provided that such returns is authorized within the same thirty (30) days time period. To return the product directly to C1, you must first obtain a Return Authorization Number by contacting C1, and you must forward to C1 all items purchased, including the proof of purchase. The return must be postage-prepaid, and post-marked within thirty (30) days from the proof of purchase, time being of the essence. The return option to C1 is only available to the original purchaser of an unopened factory packaged item.

II. YOUR LICENSE TO DEVELOP AND TO DISTRIBUTE.

As provided in more detail below, this EULA grants you two licenses: 1) a license to use the SOFTWARE to develop other software products (the "Development License"); and 2) a license to use and/or distribute the Developed Software (the "Distribution License"). These licenses (individually and collectively, the "Licenses") are explained and defined in more detail below.

1. Definitions. The following terms have the respective meanings as used in this EULA:

"Network Server" means a computer with one or more computer central processing units (CPU's) that operates for the purpose of serving other computers logically or physically connected to it, including, but not limited to, other computers connected to it on an internal network, intranet or the Internet.

"Web Server" means a type of Network Server that serves other computers which, are specifically connected to it through either an intranet or the Internet.

"Developed Software" means those computer software products that are developed by or through the use of the SOFTWARE.

"Developed Web Server Software" means those Developed Software products that reside logically or physically on at least one Web Server and are operated (meaning the computer software instruction set is carried out) by the Web Server's central processing unit(s) (CPU).

"Redistributable Files" means the SOFTWARE files or other portions of the SOFTWARE that are provided by C1 and are identified as such in the Documentation for distribution by you with the Developed Software.

"Developer" means a human being or any other automated device using the SOFTWARE in accordance with the terms and conditions of this EULA.

"Developer Seat License" means that each Developer using or otherwise accessing the programmatic interface or the SOFTWARE must obtain the right to do so by purchasing a separate End User License.

"Source Code" shall mean computer software code or programs in human readable format, such as a printed listing of such a program written in a high-level computer language. The term "Source Code" includes, but is not limited to, documents and materials in support of the development effort of the SOFTWARE, such as flow charts, pseudo code and program notes.

2. Your Development License. You are hereby granted a limited, royalty-free, non-exclusive right to use the SOFTWARE to design, develop, and test Developed Software, on the express condition that, and only for so long as, you fully comply with all terms and conditions of this EULA.

The SOFTWARE is licensed to you on a Developer Seat License basis.

Developer Seat License basis means that you may perform an installation of the SOFTWARE for use in designing, testing and creating Developed Software by a single Developer on one or more computers, each with a single set of input devices, so long as 1) such computer/computers is/are used only by one single Developer at any given time and not concurrently and, 2) the user is the primary User to whom the license has been granted. Conversely, you may not install or use the SOFTWARE on a computer that is a network server or a computer at which the SOFTWARE is used by more than one Developer. You may not network the SOFTWARE or any component part of it, where it is or may be used by more than one Developer unless you purchase an additional Development License for each Developer. You must purchase another separate license to the SOFTWARE in order to add additional developer seats, whether the additional developers are accessing the SOFTWARE in a stand-alone environment or on a computer network.

The license rights granted under this Agreement may be limited to a specified number of days after you first install the SOFTWARE unless you supply information required to license or verify your licensed copy, as the case may be, within the time and the manner described during the SOFTWARE setup sequence and/or in the dialog boxes appearing during use of the SOFTWARE. You may need to verify the SOFTWARE through the use of the Internet, email or telephone; toll charges may apply. You may need to re-verify the SOFTWARE if you modify your computer hardware. Product verification is based on the exchange of information between your computer and C1. None of this information contains personally identifiable information nor can they be used to identify any personal information about you or any information you store in your computer. YOU ACKNOWLEDGE AND UNDERSTAND THAT THERE ARE TECHNOLOGICAL MEASURES IN THE SOFTWARE THAT ARE DESIGNED TO PREVENT UNLICENSED OR ILLEGAL USE OF THE SOFTWARE. YOU AGREE THAT C1 MAY USE SUCH MEASURES AND YOU AGREE TO FOLLOW ANY REQUIREMENTS REGARDING SUCH TECHNOLOGICAL MEASURES. YOU ACKNOWLEDGE AND AGREE THAT THE SOFTWARE WILL CEASE TO FUNCTION UNLESS AND UNTIL YOU VERIFY THE APPLICABLE SOFTWARE SERIAL KEY.

You agree that C1 may audit your use of the SOFTWARE for compliance with these terms at any time, upon reasonable notice. In the event that such audit reveals any use of the SOFTWARE other than in full compliance with the terms of this EULA, you shall reimburse C1 for all reasonable expenses related to such audit in addition to any other liabilities you may incur as a result of such non-compliance.

In all cases, (a) you may not use C1's name, logo, or trademarks to market your Developed Software without the express written consent of C1; (b) you must include the following C1 copyright notice in your Developed Software documentation and/or in the "About Box" of your Developed Software, and wherever the copyright/rights notice is located in the Developed Software (“Portions Copyright © ComponentOne, LLC 1991-2005. All Rights Reserved.”); (c) you agree to indemnify, hold harmless, and defend C1, its suppliers and resellers, from and against any claims or lawsuits, including attorney's fees that may arise from the use or distribution of your Developed Software; (d) you may use the SOFTWARE only to create Developed Software that is significantly different than the SOFTWARE.

3. Your Distribution License.

License to Distribute Developed Software. Subject to the terms and conditions in this EULA, you are granted the license to use and to distribute Developed Software on a royalty-free basis, provided that the Developed Software incorporates the SOFTWARE as an integral part of the Developed Software in machine-language compiled format (customarily an ".exe", or ".dll", etc.). You may not distribute, bundle, wrap or subclass the SOFTWARE as Developed Software which, when used in a "designtime" development environment, exposes the programmatic interface of the SOFTWARE. You may distribute, on a royalty-free basis, Redistributable Files with Developed Software only. You may not add or transfer the SOFTWARE license key to the computer where the Developed Software is installed. Users of the Developed Software may not use the SOFTWARE or the Redistributable Files, directly or indirectly, for development purposes. In particular, if you create a control (or user control) using the SOFTWARE as a constituent control, you are not licensed to distribute the control you created with the SOFTWARE to users for development purposes.

4. Specific Product Limitations. Notwithstanding anything in this EULA to the contrary, if the license you have purchased is for any of the following products, then the following additional limitations will apply:

a. ComponentOne Reports for .NET Designer Edition. ComponentOne Reports for .NET Designer Edition includes at least: 1) one dynamic link library file (c1.win.c1reportdesigner.dll) known as C1ReportDesigner Component, 2) one executable file (ReportDesigner.exe) known as C1ReportDesigner Application and, 3) the Source Code of the C1ReportDesigner Application. The C1ReportDesigner Component is subject to the general terms and restrictions set forth in this EULA. The C1ReportDesigner Application is an executable file used to design and prepare reports; the C1ReportDesigner Application may be distributed, free of royalties, only in conjunction with the Developed Software.

C1 hereby also grants you the right to use and to modify the C1ReportDesigner Application Source Code to create derivative works that are based on the licensed Source Code. You may distribute such derivative works, solely in object code format and exclusively in conjunction with and/or as a part of the Developed Software. You are expressly not granted the right to distribute, disclose or otherwise make available to any third party the licensed Source Code, any portion, modified version or derivative work thereof, in source code format.

C1 shall retain all right, title and interest in and to the licensed Source Code, and all C1 updates, modifications or enhancements thereof. Nothing herein shall be deemed to transfer any ownership or title rights in and to the licensed Source Code from C1 to you.

SOURCE CODE IS LICENSED TO YOU AS IS. C1 DOES NOT AND SHALL NOT PROVIDE YOU WITH ANY TECHNICAL SUPPORT FOR YOUR SOURCE CODE LICENSE.

b. VSView Reporting Edition (ActiveX). VSView Reporting Edition includes at least one executable file listed as “VSRptX.exe” (where X indicates the version number i.e.7,8, etc.), known as “Designer.” The file "VSRptX.exe”, or any upgrade or future versions of the Designer, are subject to the restrictions set forth in this EULA and may not be distributed with your Developed Software or in any other way.

c. Studio Products. You may not share the component parts of the Studio Products licensed to you with other Developers, nor may you allow the use and/or installation of such components by other Developers.

5. Updates/Upgrades; Studio Subscription. Subject to the terms and conditions of this EULA, the Licenses are perpetual. Updates and upgrades to the SOFTWARE may be provided by C1 from time-to-time, and, if so provided by C1, are provided upon the terms and conditions offered at that time by C1 in its sole discretion. C1 may provide updates and upgrades to the SOFTWARE for free or for any charge, at any time or never, and through its chosen manner of access and distribution, all in C1's sole discretion.

C1 licenses certain of its separately-licensed products bundled together in a product suite, called the C1 "Studio" product line (the "Studio Products"). The exact separately-licensed products that are bundled into the Studio Products may change from time-to-time in C1's sole discretion. If the SOFTWARE is identified as a C1 "Studio" product, then the SOFTWARE is one of the Studio Products. The SOFTWARE and the Studio Products are revised from time-to-time (meaning, for example, revised with updates, upgrades and, in the case of Studio products, some times changes to the mix of products included in the bundle). To receive any such revisions to the SOFTWARE or the Studio Products, as the case may be, you must have a valid SOFTWARE license or a valid Studio subscription. Together with the Licenses, the original purchaser is granted a one-year subscription from the date of purchase. Upon expiration, you must renew your license subscription to continue to be entitled to receive SOFTWARE and/or the Studio Products revisions as the case may be.

6. Serial Number. With your license, you will be issued a unique serial number (the "Serial Number") used for the activation of the SOFTWARE. The Serial Number is subject to the restrictions set forth in this EULA and may not be disclosed or distributed either with your Developed Software or in any other way. The disclosure or distribution of the Serial Number constitutes a breach of this EULA, the effect of which shall be the immediate termination and revocation of all the rights granted herein.

7. Evaluation Copy. If you are using an "evaluation copy", specifically designated as such by C1 on its website or elsewhere, then the Licenses are limited as follows: a) you are granted a license to use the SOFTWARE for a period of thirty (30) days counted from the day of installation (the "Evaluation Period"); b) upon completion of the Evaluation Period, you shall either i) delete the SOFTWARE from the computer containing the installation, or you may ii) obtain a paid license of the SOFTWARE from C1 or any of its resellers; and c) any Developed Software developed with the Evaluation Copy may not be distributed or used for any commercial purpose.

III. INTELLECTUAL PROPERTY.

1. Copyright. You agree that all right, title, and interest in and to the SOFTWARE (including, but not limited to, any images, photographs, animations, video, audio, music, text, and “applets” incorporated into the SOFTWARE), and any copies of the SOFTWARE, and any copyrights and other intellectual properties therein or related thereto are owned exclusively by C1, except to the limited extent that C1 may be the rightful license holder of certain third-party technologies incorporated into the SOFTWARE. The SOFTWARE is protected by copyright laws and international treaty provisions. The SOFTWARE is licensed to you, not sold to you. C1 reserves all rights not otherwise expressly and specifically granted to you in this EULA.

2. Backups. You may make a copy of the SOFTWARE solely for backup or archival purposes. Notwithstanding the foregoing, you may not copy the printed Documentation.

3. General Limitations. You may not reverse engineer, decompile, or disassemble the SOFTWARE, except and only to the extent that applicable law expressly permits such activity notwithstanding this limitation.

4. Software Transfers. You may not rent or lease the SOFTWARE. You may permanently transfer all of your rights under the EULA, provided that you retain no copies, that you transfer all the SOFTWARE (including all component parts, the media and printed materials, any updates, upgrades, this EULA and, if applicable, the Certificate of Authenticity), and that the transferee agrees to be bound by the terms of this EULA. If the SOFTWARE is an update or upgrade, any transfer must include all prior versions of the SOFTWARE.

5. Termination. Without prejudice to any other rights it may have, C1 may terminate this EULA and the Licenses if you fail to comply with the terms and conditions contained herein. In such an event, you must destroy all copies of the SOFTWARE and all of its component parts.

6. Export Restrictions. You acknowledge that the SOFTWARE is of U.S. origin. You acknowledge that the license and distribution of the SOFTWARE is subject to the export control laws and regulations of the United States of America, and any amendments thereof, which restrict exports and re-exports of software, technical data, and direct products of technical data, including services and Developed Software. You agree that you will not export or re-export the SOFTWARE or any Developed Software, or any information, documentation and/or printed materials related thereto, directly or indirectly, without first obtaining permission to do so as required from the United States of America Department of Commerce's Bureau of Export Administration ("BXA"), or other appropriate governmental agencies, to any countries, end-users, or for any end-uses that are restricted by U.S. export laws and regulations, and any amendments thereof, which include, but are not limited to: Restricted Countries, Restricted End-Users, and Restricted End-Uses.

These restrictions change from time to time. You represent and warrant that neither the BXA nor any other United States federal agency has suspended, revoked or denied your export privileges. C1 acknowledges that it shall use reasonable efforts to supply you with all reasonably necessary information regarding the SOFTWARE and its business to enable you to fully comply with the provisions of this Section. If you have any questions regarding your obligations under United States of America export regulations, you should contact the Bureau of Export Administration, United States Department of Commerce, Exporter Counseling Division, Washington DC. U.S.A. (202) 482-4811, http://www.bxa.doc.gov.

7. U.S. Government Restricted Rights. The SOFTWARE and documentation are provided with RESTRICTED RIGHTS. You will comply with any requirements of the Government to obtain such RESTRICTED RIGHTS protection, including without limitation, the placement of any restrictive legends on the SOFTWARE, and any license agreement used in connection with the distribution of the SOFTWARE. Manufacturer is ComponentOne, LLC, 201 South Highland Avenue , 3rd Floor, Pittsburgh, Pennsylvania 15206 USA. For solicitations issued by the Government on or after December 1, 1995 and the Department of Defense on or after September 29, 1995, the only rights provided in the software and documentation provided herein shall be those contained in this EULA. Under no circumstances shall C1 be obligated to comply with any Governmental requirements regarding the submission of or the request for exemption from submission of cost or pricing data or cost accounting requirements. For any distribution of the SOFTWARE that would require compliance by C1 with the Government's requirements relating to cost or pricing data or cost accounting requirements, you must obtain an appropriate waiver or exemption from such requirements for the benefit of C1 from the appropriate Government authority before the distribution and/or license of the SOFTWARE to the Government.

IV. WARRANTIES AND REMEDIES.

1. Limited Warranty. C1 warrants that the original media, if any, are free from defects for ninety (90) days from the date of delivery of the SOFTWARE. C1 also warrants that: (i) it has the full power to enter into this Agreement and grant the license rights set forth herein; (ii) it has not granted and will not grant any rights in the Software to any third party which grant is inconsistent with the rights granted to you in this Agreement; and (iii) the Software does not and will not infringe any trade secret, copyright, trademark or other proprietary right held by any third party and does not infringe any patent held by any third party. EXCEPT AS OTHERWISE PROVIDED IN THE PRECEDING SENTENCE, AND TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, C1 EXPRESSLY DISCLAIMS ANY WARRANTY FOR THE SOFTWARE, DOCUMENTATION AND ANYTHING ELSE PROVIDED BY C1 HEREBY AND C1 PROVIDES THE SAME IN “AS IS” CONDITION WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, THE IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK ARISING OUT OF USE OR PERFORMANCE OF THE SOFTWARE AND DOCUMENTATION REMAINS WITH YOU. THIS LIMITED WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS. YOU MAY HAVE OTHERS WHICH VARY FROM STATE TO STATE.

2. Limited Remedy. C1 PROVIDES NO REMEDIES OR WARRANTIES, WHETHER EXPRESS OR IMPLIED, FOR ANY SAMPLE APPLICATION CODE, REDISTRIBUTABLE FILES, TRIAL VERSION AND THE NOT FOR RESALE VERSION OF THE SOFTWARE. ANY SAMPLE APPLICATION CODE, TRIAL VERSION AND THE NOT FOR RESALE VERSION OF THE SOFTWARE ARE PROVIDED “AS IS”.

C1's entire liability and your exclusive remedy under this EULA shall be, at C1's sole option, either (a) return of the price paid for the SOFTWARE; (b) repair the SOFTWARE through updates distributed online or otherwise in C1's discretion; or (c) replace the SOFTWARE with SOFTWARE that substantially performs as described in the SOFTWARE documentation, provided that you return the SOFTWARE in the same manner as provided in Section I.2 for return of the SOFTWARE for non-acceptance of this EULA. Any media for any repaired or replacement SOFTWARE will be warranted for the remainder of the original warranty period or thirty (30) days, whichever is longer. THESE REMEDIES ARE NOT AVAILABLE OUTSIDE OF THE UNITED STATES OF AMERICA. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT SHALL C1 BE LIABLE FOR ANY DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS PROFIT, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, OR ANY OTHER PECUNIARY LOSS) ARISING OUT OF THE USE OR INABILITY TO USE THE SOFTWARE, EVEN IF C1 HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. BECAUSE SOME STATES/JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES IN CERTAIN CASES, THE ABOVE LIMITATION MAY NOT APPLY TO YOU.

V. MISCELLANEOUS.

1. This is the Entire Agreement. This EULA (including any addendum to this EULA included with the SOFTWARE) is the final, complete and exclusive statement of the entire agreement between you and C1 relating to the SOFTWARE. This EULA supersedes any prior and contemporaneous proposals, purchase orders, advertisements, and all other communications in relation to the subject matter of this EULA, whether oral or written. No terms or conditions, other than those contained herein, and no other understanding or agreement which in any way modifies these terms and conditions, shall be binding upon the parties unless entered into in writing executed between the parties, or by other non-oral manner of agreement whereby the parties objectively and definitively act in a manner to be bound (such as by continuing with an installation of the SOFTWARE, etc.). Employees, agents and other representatives of C1 are not permitted to orally modify this EULA.

2. You Indemnify C1. You agree to indemnify, hold harmless, and defend C1 and its suppliers and resellers from and against any and all claims or lawsuits, including attorney's fees, which arise out of or result from your distribution of your Developed Software, your Developed Web Server Software or from your breach of any of the terms and conditions of this EULA.

3. Interpretation of this EULA. If for any reason a court of competent jurisdiction finds any provision of this EULA, or any portion thereof, to be unenforceable, that provision of this EULA will be enforced to the maximum extent permissible so as to effect the intent of the parties, and the remainder of this EULA will continue in full force and effect. Formatives of defined terms shall have the same meaning of the defined term. Failure by either party to enforce any provision of this EULA will not be deemed a waiver of future enforcement of that or any other provision. Except as otherwise required or superseded by law, this EULA is governed by the laws of the Commonwealth of Pennsylvania, without regard to its conflict of laws principles. The parties consent to the personal jurisdiction and venue of the Commonwealth of Pennsylvania, in the County of Allegheny, and agree that any legal proceedings arising out of this EULA shall be conducted solely in such Commonwealth. If the SOFTWARE was acquired outside the United States, then local law may apply.


Licensing FAQs

Licensing FAQs

This section describes the main technical aspects of licensing. It may help the user to understand and resolve licensing problems he may experience when using ComponentOne .NET and ASP.NET products.

What is Licensing?

How does Licensing Work?

Common Scenarios

Troubleshooting


What is Licensing?

What is Licensing?

Previous Next

Licensing is a mechanism used to protect intellectual property by ensuring that users are authorized to use software products.

Licensing is not only used to prevent illegal distribution of software products. Many software vendors, including ComponentOne, use licensing to allow potential users to test products before they decide to purchase them.

Without licensing, this type of distribution would not be practical for the vendor or convenient for the user. Vendors would either have to distribute evaluation software with limited functionality, or shift the burden of managing software licenses to customers, who could easily forget that the software being used is an evaluation version and has not been purchased.


How does Licensing Work?

How does Licensing Work?

Previous Next

ComponentOne uses a licensing model based on the standard set by Microsoft, which works with all types of components.

Note: The Compact Framework Components use a slightly different mechanism for licensing than the other ComponentOne components due to platform differences.

When a user decides to purchase a product, he receives an installation program and a Serial Number. During the installation process, the user is prompted for the serial number that is saved on the system. (Users can also enter the serial number by clicking the "License" button on the About Box of any ComponentOne product.)

When a licensed component is added to a form or web page, Visual Studio asks the newly created component for licensing information. The component looks for licensing information stored in the system and generates a key, which Visual Studio saves in two files:

1. a "<projectName>.licenses" resource file which contains the actual key and

2. a "licenses.licx" file that contains references to those resources.

These files are automatically added to the project.

Note that the licenses.licx file is usually not shown in the Solution Explorer; it appears if you press the "Show All Files" button in the Solution Explorer's toolbox, or select "Project | Show All Files" from Visual Studio's main menu.

Later, when the component is created at run time, it gets passed the key that was created at design time and can decide whether to simply accept the key, to throw an exception and fail altogether, or to display some information reminding the user that the software has not been licensed.

All ComponentOne products are designed to display licensing information if the product is not licensed. None will throw licensing exceptions and prevent applications from running.


Common Scenarios

Common Scenarios

Creating components at design time

Creating components at run time

Inheriting from licensed components

Using licensed components in console applications

Using licensed components in Visual C++ applications


Creating components at design time

Creating components at design time

This is the most common scenario and also the simplest: the user adds one or more controls to the form, the licensing information is stored in the licenses.licx file, and the component works.

Note that the mechanism is exactly the same for Windows Forms and Web Forms (ASP.NET) projects.


Creating components at run time

Creating components at run time

This is also a fairly common scenario. You do not need an instance of the component on the form, but would like to create one or more instances at run time.

In this case, the project will not contain a licenses.licx file (or the file will not contain an appropriate key for the component) and therefore licensing will fail.

To fix this problem, add an instance of the component to a form in the project. This will create the licenses.licx file and things will then work as expected. (The component can be removed from the form after the licenses.licx file has been created).


Inheriting from licensed components

Inheriting from licensed components

If a component that inherits from a licensed component is created, the licensing information to be stored in the form is still needed. This can be done in two ways:

1. Add a LicenseProvider attribute to the component.

This will mark the component as licensed. When a component is added to a form, Visual Studio will create and manage the licenses.licx file, and the base class will handle the licensing process as usual. No additional work is needed. For example:

[LicenseProvider(typeof(LicenseProvider))]

class MyGrid: C1.Win.C1FlexGrid.C1FlexGrid

{

// ...

}

2. Add an instance of the base component to the form.

This will embed the licensing information into the licenses.licx file as in the previous scenario, and the base component will find it and use it. As before, the extra instance can be deleted after the licenses.licx file has been created.


Using licensed components in console applications

Using licensed components in console applications

When building console applications, there are no forms to add components to, and therefore Visual Studio won't create a licenses.licx file.

In these cases, create a temporary Windows Forms application and add all the desired licensed components to a form. Then close the Windows Forms application and copy the licenses.licx file into the console application project.

Make sure the licensex.licx file is configured as an embedded resource. To do this, right-click the licenses.licx file in the Solution Explorer window and select Properties. In the property window, set the "Build Action" property to "Embedded Resource".


Using licensed components in Visual C++ applications

Using licensed components in Visual C++ applications

There is an issue in VC++ 2003 where the licenses.licx is ignored during the build process; therefore, the licensing information is not included in VC++ applications.

To fix this problem, extra steps must be taken to compile the licensing resources and link them to the project. Note the following:

1. Build the C++ project as usual. This should create an exe file and also a licenses.licx file with licensing information in it.

2. Copy the licenses.licx file from the app directory to the target folder (Debug or Release).

3. Copy the C1Lc.exe utility and the licensed dlls to the target folder. (Don't use the standard lc.exe, it has bugs.)

4. Use C1Lc.exe to compile the licenses.licx file. The command line should look like this:

c1lc /target:MyApp.exe /complist:licenses.licx /i:C1.Win.C1FlexGrid.dll

5. Link the licenses into the project. To do this, go back to Visual Studio, right-click the project, select properties, and go to the Linker/Command Line option. Enter the following:

/ASSEMBLYRESOURCE:Debug\MyApp.exe.licenses

6. Rebuild the executable to include the licensing information in the application.


Troubleshooting

Troubleshooting

We try very hard to make the licensing mechanism as unobtrusive as possible, but problems may occur for a number of reasons.

Below is a description of the most common problems and their solutions.


I have a licensed version of a ComponentOne product but I still get the splash screen when I run my project.

I have a licensed version of a ComponentOne product but I still get the splash screen when I run my project.

Previous Next

If this happens, there must be a problem with the licenses.licx file in the project. It either doesn't exist, contains wrong information, or is not configured correctly.

First, try a full rebuild ("Rebuild All" from the Visual Studio Build menu). This will usually rebuild the correct licensing resources.

If that fails, follow these steps:

1. Open the project and go to the Solution Explorer window.

2. Click the "Show All Files" button on the top of the window.

3. Find the licenses.licx file and delete it.

4. Close the project and reopen it.

5. Open the main form and add an instance of each licensed control.

6. Check the Solution Explorer window, there should be a licenses.licx file there.

7. Rebuild the project using the "Rebuild All" option (not just "Rebuild").


I have a licensed version of a ComponentOne product on my web server but the components still behave as unlicensed.

I have a licensed version of a ComponentOne product on my web server but the components still behave as unlicensed.

Previous Next

There is no need to install any licenses on machines used as servers and not used for development.

The components must be licensed on the development machine, therefore the licensing information will be saved into the executable (exe or dll) when the project is built. After that, the application can be deployed on any machine, including web servers.


I downloaded a new build of a component that I have purchased, and now I'm getting the splash screen when I build my projects.

I downloaded a new build of a component that I have purchased, and now I'm getting the splash screen when I build my projects.

Previous Next

Make sure that the license key is still valid. If you licensed the component over a year ago, your subscription may have expired. In this case, you have two options:

Option 1 - Renew your subscription to get a new license key.

If you choose this option, you will receive a new key that you can use to license the new components (from the installation utility or directly from the About Box).

The new subscription will entitle you to a full year of upgrades and to download the latest maintenance builds directly from http://prerelease.componentone.com/.

Option 2 – Continue to use the components you have.

Subscriptions expire, products do not. You can continue to use the components you received or downloaded while your subscription was valid.


Technical Support

Technical Support

ComponentOne Preview for .NET is developed and supported by ComponentOne LLC, a company formed by the merger of APEX Software Corporation and VideoSoft. You can obtain technical support using any of the following methods:

ComponentOne Web site

ComponentOne HelpCentral

Internet e-mail

Peer-to-Peer newsgroup

Documentation


ComponentOne Web site

ComponentOne Web site

The ComponentOne Web site at www.componentone.com provides a wealth of information and software downloads for Preview for .NET users, including:

· Descriptions of the various support options available through the ComponentOne Service Team.

· Answers to frequently asked questions (FAQ's) about our products, organized by functionality. Please consult the FAQ's before contacting us directly, as this can save you time and also introduce you to other useful information pertaining to our products.

· Free product updates, which provide you with bug fixes and new features.


ComponentOne HelpCentral

ComponentOne HelpCentral

ComponentOne HelpCentral is the new online resource for Visual Studio developers and Help authors. Visit HelpCentral to get information on ComponentOne products, view online demos, get Tech Tips and answers to frequently asked questions (FAQ's), search the ComponentOne knowledgebase and more!


Internet e-mail

Internet e-mail

For technical support through the Internet, e-mail us at:

Support.Preview.NET@componentone.com

To help us provide you with the best support, please include the following information when contacting ComponentOne:

· Your ComponentOne product serial number.

· The version and name of your operating system.

· Your development environment and its version.

For more information on technical support, go to:

www.componentone.com/support


Peer-to-Peer newsgroup

Peer-to-Peer newsgroup

ComponentOne also sponsors peer-to-peer newsgroups for users. ComponentOne does not offer formal technical support in this newsgroup, but instead sponsors it as a forum for users to post and answer each other's questions regarding our products. However, ComponentOne may monitor the newsgroups to ensure accuracy of information and provide comments when necessary. You can access the newsgroup from the ComponentOne Web site at http://helpcentral.componentone.com/Newsgroups.aspx.


Documentation

Documentation

ComponentOne documentation is available with each of our products in HTML Help, Microsoft Help 2.0 (.NET, ASP.NET and Mobile Device products only), and PDF format. All of the PDFs are also available on HelpCentral. If you have suggestions on how we can improve our documentation, please email the Documentation team. Please note that e-mail sent to the Documentation team is for documentation feedback only. Technical Support and Sales issues should be sent directly to their respective departments.


Redistributable Files

Redistributable Files

ComponentOne Preview for .NET is developed and published by ComponentOne LLC. You may use it to develop applications in conjunction with Microsoft Visual Studio or any other programming environment that enables the user to use and integrate the control(s). You may also distribute, free of royalties, the following Redistributable Files with any such application you develop to the extent that they are used separately on a single CPU on the client/workstation side of the network:

· C1.Win.C1Preview.2.dll

· C1.C1Preview.2.dll

Site licenses are available for groups of multiple developers. Please contact Sales@ComponentOne.com for details.


Namespaces

Namespaces

Namespaces organize the objects defined in an assembly. Assemblies can contain multiple namespaces, which can in turn contain other namespaces. Namespaces prevent ambiguity and simplify references when using large groups of objects such as class libraries.

The general namespace for ComponentOne Windows' products is C1.Win. The namespace for the C1PrintPreview control is C1.Win.C1Preview. The following code fragment shows how to declare a C1PrintPreview control using the fully qualified name for this class:

· Visual Basic

· C#

· Delphi

Namespaces address a problem sometimes known as namespace pollution, in which the developer of a class library is hampered by the use of similar names in another library. These conflicts with existing components are sometimes called name collisions.

For example, if you create a new class named Pages, you can use it inside your project without qualification. However, the C1PrintPreview assembly also implements a class called Pages. So, if you want to use the C1PrintPreview class in the same project, you must use a fully qualified reference to make the reference unique. If the reference is not unique, Visual Studio .NET produces an error stating that the name is ambiguous. The following code snippet demonstrates how to declare these objects:

· Visual Basic

· C#

· Delphi

Fully qualified names are object references that are prefixed with the name of the namespace where the object is defined. You can use objects defined in other projects if you create a reference to the class (by choosing Add Reference from the Project menu) and then use the fully qualified name for the object in your code.

Fully qualified names prevent naming conflicts because the compiler can always determine which object is being used. However, the names themselves can get long and cumbersome. To get around this, you can use the Imports statement (using in C#) to define an alias — an abbreviated name you can use in place of a fully qualified name. For example, the following code snippet creates aliases for two fully qualified names, and uses these aliases to define two objects:

· Visual Basic

· C#

· Delphi

If you use the Imports statement without an alias, you can use all the names in that namespace without qualification provided they are unique to the project.


Creating a .NET Project

Creating a .NET Project

This topic demonstrates how to create a new NET project.

1. From the File menu in Visual Studio, select New Project. The New Project dialog box opens.

2. Under Project Types, choose either Visual Basic or Visual C#, and select Windows Application from the list of Templates in the right pane.

3. Enter a name for your new application in the Name field or you can use the default name, WindowsApplication1.

A new Microsoft Visual Studio .NET project is created and a new Form1 is displayed in the Designer view.

4. Double-click the desired C1PrintPreview components from the Toolbox to add them to Form1. For information on adding a component to the toolbox, see Adding Preview for .NET Components to the Toolbox.


Adding Preview for .NET Components to the Toolbox

Adding Preview for .NET Components to the Toolbox

When you install C1Preview, the following C1Preview components will appear in the Visual Studio Toolbox customization dialog box:

· C1PrintDocument

· C1PreviewPane

· C1PreviewTextSearchPanel

· C1PreviewThumbnailView

· C1PrintPreviewControl

· C1PrintPreviewDialog

· C1PreviewOutlineView

In order to use this component, you must add it to the Visual Studio Toolbox:

1. Open the Visual Studio IDE (Microsoft Development Environment). Make sure the Toolbox is visible (select Toolbox in the View menu if necessary) and right-click it to open the context menu.

2. To make C1Preview component appear on its own tab in the Toolbox, select Add Tab from the context menu and type in the tab name, C1Preview, for example.

3. Right-click the tab where the component is to appear and select Choose Items from the context menu.

The Choose Toolbox Items dialog box opens.

4. In the dialog box, select the .NET Framework Components tab. Sort the list by Namespace (click the Namespace column header) and check the check boxes for all components belonging to namespace C1.C1Preview. Note that there may be more than one component for each namespace.


Preview Samples

Preview Samples

Please be advised that this ComponentOne software title is accompanied by various sample projects and/or demos, which may or not make use of other ComponentOne development tools. While the sample projects and/or demos included with the software are used to demonstrate and highlight the product’s features, and how the control may be integrated with the rest of the ComponentOne product line, some of the controls used in the demo/sample project may not be included with the purchase of certain individual products.

The installation program installs the following samples in the C:\Program Files\ComponentOne Studio.NET\C1Preview directory.

The ComponentOne Samples are also available at http://helpcentral.componentone.com/ProductResources.aspx.


C# Samples

C# Samples

CoordinatesOfCharsInText | Shows how to use the GetCharRect() method (advanced). The sample shows how to use the GetCharRect() method available on RenderText and RenderParagraph classes, which allows to find out the position and size of individual characters in the text.In the sample, a red rectangle is drawn around each character.
Hyperlinks | Shows how to create various types of hyperlinks The sample demonstrates how to create and set up several types of hyperlinks supported by C1PrintDocument and the preview controls: hyperlinks to anchors within the same document, hyperlinks to anchors in other C1PrintDocument objects, hyperlinks to locations within the document (render objects, pages), hyperlinks to external files/URLs.
PageLayout1 | Shows how to use the PageLayouts property. The sample creates a document with different page layouts for the first page, even pages and odd pages. The different layouts are specified declaratively via the PageLayouts property of C1PrintDocument, no even handling is involved.
PageLayout2 | Shows how to use the LayoutChangeBefore property of RenderObject. The sample creates a document with an object that forces a page break, and a different page layout that is "nested" within the current layout, so that the current layout is automatically restored when the nested object is over.
RenderObjects | Introduces most of the RenderObject types provided by C1PrintDocument. The sample creates and previews a C1PrintDocument, in which most of the RenderObject types proided by C1PrintDocument are included: RenderArea, RenderText, RenderGraphics, RenderEmpty, RenderImage, RenderRichText, RenderPolygon, RenderTable, RenderParagraph.
RenderTOC | Shows how to use the RenderToc object. The sample demonstrates how to create the table of contents for a document using the dedicated RenderToc render object.
Stacking | Shows how to use stacking rules for render objects' positioning The sample demonstrates how to use the RenderObject.Stacking property to set stacking rules for block (top to bottom and left to right) and inline (left to right) positioning of objects. Relative positioning of objects is also demonstrated.
Tables1 | Shows how to create tables, set up table headers and footers. The sample creates and previews a C1PrintDocument with a table. Demonstrates how to set up table headers (including running headers) and footers. Shows how to add orphan control (the minimum rows printed on the same page before the footer is specified).
Tables2 | The sample shows the basic features of tables in C1PrintDocument. The following features of tables are demonstrated: · Table borders (Style.GridLines property, allowing to specify the 4 outer and 2 inner lines). · Borders around individual cells and groups of cells. · Style attributes (including borders) for groups of disconnected cells. · Cells spanning rows and columns. · Content alignment within the cells (spanned or otherwise). · Table headers and footers. · Tags (such as page number/total page count) in table footer. · Style attributes: borders, font and background images.
Tables3 | Shows multiple inheritance of styles in C1PrintDocument tables. The sample demonstrates multiple inheritance of styles in tables. A table with some test data is inserted into the document. Some style attributes are redefined for the styles of a row, a column, and a cell group. Cells at the intersections of the groups inherit styles for all, combining them.
TabPosition | Shows how to use the TabPosition property of text rendering objects. The sample creates a document with a RenderParagraph object, on which the TabPositions property is defined, specifying the tab positions calculated on document reflow depending on the current page width.
WideTables | Shows how to create wide tables spanning several pages. The sample demonstrates the feature of C1PrintDocument which allows to render wide objects spannig multiple pages horizontally. To enable this feature, the object's CanSplitHorz property should be set to True. The preview is also adjusted to better show wide objects (margins are hidden, the gap between pages set to zero, and the end user is prevented from showing the margins).


Visual Basic Samples

Visual Basic Samples

CoordinatesOfCharsInText | Shows how to use the GetCharRect() method (advanced). The sample shows how to use the GetCharRect() method available on RenderText and RenderParagraph classes, which allows to find out the position and size of individual characters in the text. In the sample, a red rectangle is drawn around each character.
Hyperlinks | Shows how to create various types of hyperlinks The sample demonstrates how to create and set up several types of hyperlinks supported by C1PrintDocument and the preview controls: hyperlinks to anchors within the same document, hyperlinks to anchors in other C1PrintDocument objects, hyperlinks to locations within the document (render objects, pages), hyperlinks to external files/URLs.
PageLayout1 | Shows how to use the PageLayouts property. The sample creates a document with different page layouts for the first page, even pages and odd pages. The different layouts are specified declaratively via the PageLayouts property of C1PrintDocument, no even handling is involved.
PageLayout2 | Shows how to use the LayoutChangeBefore property of RenderObject. The sample creates a document with an object that forces a page break, and a different page layout that is "nested" within the current layout, so that the current layout is automatically restored when the nested object is over.
RenderObjects | Introduces most of the RenderObject types provided by C1PrintDocument. The sample creates and previews a C1PrintDocument, in which most of the RenderObject types proided by C1PrintDocument are included: RenderArea, RenderText, RenderGraphics, RenderEmpty, RenderImage, RenderRichText, RenderPolygon, RenderTable, RenderParagraph.
RenderTOC | Shows how to use the RenderToc object. The sample demonstrates how to create the table of contents for a document using the dedicated RenderToc render object.
Stacking | Shows how to use stacking rules for render objects' positioning The sample demonstrates how to use the RenderObject.Stacking property to set stacking rules for block (top to bottom and left to right) and inline (left to right) positioning of objects. Relative positioning of objects is also demonstrated.
Tables1 | Shows how to create tables, set up table headers and footers. The sample creates and previews a C1PrintDocument with a table. Demonstrates how to set up table headers (including running headers) and footers. Shows how to add orphan control (the minimum rows printed on the same page before the footer is specified).
Tables2 | The sample shows the basic features of tables in C1PrintDocument. The following features of tables are demonstrated: · Table borders (Style.GridLines property, allowing to specify the 4 outer and 2 inner lines). · Borders around individual cells and groups of cells. · Style attributes (including borders) for groups of disconnected cells. · Cells spanning rows and columns. · Content alignment within the cells (spanned or otherwise). · Table headers and footers. · Tags (such as page number/total page count) in table footer. · Style attributes: borders, font and background images.
Tables3 | Shows multiple inheritance of styles in C1PrintDocument tables. The sample demonstrates multiple inheritance of styles in tables. A table with some test data is inserted into the document. Some style attributes are redefined for the styles of a row, a column, and a cell group. Cells at the intersections of the groups inherit styles for all, combining them.
TabPosition | Shows how to use the TabPosition property of text rendering objects. The sample creates a document with a RenderParagraph object, on which the TabPositions property is defined, specifying the tab positions calculated on document reflow depending on the current page width.
WideTables | Shows how to create wide tables spanning several pages The sample demonstrates the feature of C1PrintDocument which allows to render wide objects spannig multiple pages horizontally. To enable this feature, the object's CanSplitHorz property should be set to True. The preview is also adjusted to better show wide objects (margins are hidden, the gap between pages set to zero, and the end user is prevented from showing the margins).


C1PrintDocument

C1PrintDocument

Overview

Quick Start

Render objects

Using Styles

Tables

Generating Table of Contents

Outline

Embedded Fonts

Dictionary

Tags


Overview

Overview

C1PrintDocument is the component that allows you to create complex documents that can be printed, previewed, persisted in a disc file, or exported to a number of external formats such as PDF or RTF.

C1PrintDocument provides a number of unique features such as:

· Consistent transparent hierarchical document structure.

· Easy to use and efficient styles.

· Documents that can be changed and re-rendered to accommodate the changes and/or different page settings.

· Documents’ preview, printing, persisting, and export to external formats.

· Documents that are input forms (supported by the preview components).

· Complete tables support, including nested tables.

· Support for multi-style text, including inline images.

· True type fonts embedding.

· Hyperlinks.

· Auto-generated TOC.

· …and more.

The default namespace used by C1PrintDocument is C1.C1Preview (the WinForms part of the C1Preview product, providing Windows Forms controls for working with documents, uses the default namespace C1.Win.C1Preview).

The whole document is represented by the C1PrintDocument class, which inherits from Component.

The main parts comprising a C1PrintDocument are:

· Body

The actual content of the document – text, images and so on. The body represents the logical structure of the document (see also the page collection below).

· Pages

The collection of pages which were generated based on the content (body) and a particular page setup. Normally the page collection can be regenerated without loss of information (for example, for a different paper size).

· Style

The root style of the document. Styles control most of the visual properties of the document elements (such as fonts, colors, line styles and so on).

· Dictionary

Images used in multiple places in a document can be put in the dictionary and reused, to improve performance and reduce memory footprint.

· EmbeddedFonts

The collection of embedded true type fonts used by the document.

· Tags

The collection of user defined tags that can be inserted in the document to be replaced by their values when the document is generated.


Quick Start

Quick Start

In this section you will learn how to use the basic C1PrintDocument functionality to create simple documents. This section is not supposed to be a comprehensive tutorial on all features of C1PrintDocument, but rather provide a quick start and highlight some general approaches to using the product.

Making a "Hello, World!" document

Making a simple table

Adding paragraphs to the document

Anchors and hyperlinks


Making a "Hello, World!" document

Making a “Hello, World!” document

The simplest possible document is one that prints the sentence “Hello, World!”. Here are the steps needed to create such a document:

1. Create a new C# or VB.NET Windows application, call it HelloWorld.

2. Open the form designer of the main application's form.

3. Because the print preview is usually a quite large control, resize the form to make it larger, approx. 600 by 400 pixels.

4. Open the Visual Studio's toolbox, right click on it, and select Choose Items from the menu. Click Browse and navigate to the location where the C1Preview dlls are installed. Select each of the following dlls in turn:

· C1.C1Preview.2.dll

· C1.Win.C1Preview.2.dll

5. Click OK to add components in it to the toolbox. Click OK to close the dialog.

6. At this point, you should have the following new items in your toolbox:

· C1PrintDocument

· C1PreviewPane

· C1PrintPreviewControl

· C1PrintPreviewDialog

· C1PreviewThumbnailView

· C1PreviewOutlineView

· C1PreviewTextSearchPanel

7. Click on C1PrintPreviewControl and drop it onto your form. A print preview control (a composite control containing a preview pane, navigation and text search panels, and toolbars with the predefined buttons) should appear on your form, called "c1PrintPreviewControl1", showing a sample document. Go to the Properties browser, and set the new control’s Dock property to Fill.

Two additional entries will appear in the References part of your project: C1.C1Preview.2 and C1.Win.C1Preview.2.

8. The form designer should now look like this:

9. Back in the designer, drop a C1PrintDocument from the toolbox onto your form. The new component will by default be called “c1PrintDocument1”.

10. Now, go to the c1PrintPreviewControl1's properties, and set its Document property to the newly added c1PrintDocument1 (which should show up in the Document property's dropdown list). This will show that document in the preview at runtime.

11. In the designer, double click on the form's title bar, to create a handler for the Form Load event. In that event handler, write the following lines of code:

· Visual Basic

· C#

· Delphi

Note: all sample code fragments in this document assume that “using C1.C1Preview” directive (in C# syntax; or an equivalent for other languages) has been inserted into the file, so that instead of fully qualified type names (such as C1.C1Preview.RenderText) we can use just the class name part (RenderText).

12. Run your application. The preview should show the document consisting of one page, with the words "Hello World!”.

That’s it!


Making a simple table

Making a simple table

Tables provide one of the most useful features in documents. They can used both for table presentation of data, and for layout of other elements of a document. C1PrintDocument provides full-featured tables. In this section you will learn how to start using tables. We will use the “Hello, World!” sample application from the previous section as our base, and add a table to it.

1. Open the HelloWorld application from the previous section (alternatively, you can create a new WinForms application and add a C1PrintPreviewControl and a C1PrintDocument to the form, and attach the document to the preview control as described in the previous section).

2. In the Form Load event handler (create it if necessary) add the following code before the call to c1PrintDocument1.Generate():

· Visual Basic

· C#

· Delphi

3. Do not forget to call the Generate method on the document.

· Visual Basic

· C#

· Delphi

4. Build and run the application. The preview will show the document like the one in the following picture:

This simple example shows several important aspects of using tables in C1PrintDocument:

· Tables are represented by the RenderTable class, which inherits from RenderObject.

· Tables follow the model used in Microsoft Excel: their size is unlimited initially; the real size of the table when it is rendered is determined by the cell with the largest row and column numbers whose content was set. In our example, the table is 10 rows high and 6 columns wide, because the cell with the largest row and column indices that was set was the cell at position (9,5) (indices are zero-based). If you modify the code to set for example the text of the cell at position (10,7), the table will grow to 11 rows and 8 columns:

· Visual Basic

· C#

· Delphi

· By default, tables do not have visible grid lines (the “grid lines” term is used in C1Preview for lines used to draw tables, as opposed to borders which can be drawn around any render object). To add grid lines (drawn with a black 0.5pt pen), add the following line of code to the Form Load event handler:

· Visual Basic

· C#

· Delphi

· By default, a table is as wide as its parent’s client area (in this case, the whole page), with equally-sized columns. Rows’ heights are automatic, though. So, if you add a line setting the text of an arbitrary cell in a table to a long text, you will see that the row containing that cell will grow vertically to accommodate all text. For example, adding this code to our example:

· Visual Basic

· C#

· Delphi

will produce a table looking like this (this table includes both changes described above):

For your reference, here is the complete text of the form load event handler that produced the above document:

· Visual Basic

· C#

· Delphi


Adding paragraphs to the document

Adding paragraphs to the document

All content of a C1PrintDocument is represented by render objects. The C1Preview assembly provides a hierarchy of classes derived from RenderObject, designed to represent content of various types, such as text, images and so on. For instance, above we used the RenderText class to add a line of text to the document. In this section we will show how to create paragraphs of text (which may combine fragments of text drawn with different styles, inline images, and hyperlinks) using the RenderParagraph class.

A RenderParagraph can be created with the following line of code:

· Visual Basic

· C#

· Delphi

Paragraphs should be used rather than RenderText in any of the following cases:

· You need to show text in different styles within the same paragraph.

· Inline images (usually small icon-like images) must be inserted in the text flow.

· A hyperlink must be associated with a portion of the text (for example, a word) rather than with the whole text (please see the Anchors and hyperlinks section below).

The content of a paragraph is comprised of ParagraphObject objects. ParagraphObject is the abstract base class; the two inherited classes are ParagraphText and ParagraphImage, representing fragments of text and inline images, correspondingly. You can fill a paragraph with content by creating objects of those two types and adding them to the RenderParagraph.Content collection. Various constructor overloads and properties are provided for convenient creation/setup of those objects. In-paragraph hyperlinks can be created by specifying the Hyperlink property of the paragraph object which should be a hyperlink. An alternative approach is to use various overloads of the shortcut methods AddText, AddImage and AddHyperlink, as shown in the following example:

· Visual Basic

· C#

· Delphi

The following screenshot shows the document generated by this code:


Anchors and hyperlinks

Anchors and hyperlinks

C1Preview supports hyperlinks. Hyperlinks can be attached to render objects (RenderObject and derived classes), and paragraph objects (ParagraphObject and derived classes), and can be linked to:

· An anchor within the current document.

· An anchor within another C1PrintDocument.

· A location within the current document.

· An external file.

· A page within the current document.

· A user event.

Hyperlinks are supported by the preview controls included in C1.Win.C1Preview assembly (C1PreviewPane, C1PrintPreviewControl and C1PrintPreviewDialog). When a document with hyperlinks in it is previewed, and the mouse hovers over a hyperlink, the cursor changes to a hand. Clicking the hyperlink will, depending on the target of the link, either jump to another location within the document, open a different document and jump to a location in it, open an external file, or invoke the user event.

Adding a hyperlink to an anchor within the same document

Adding a hyperlink to an anchor in a different C1PrintDocument

Adding a hyperlink to a location within the current document

Adding a hyperlink to an external file

Adding a hyperlink to a page in the same document

Adding a hyperlink to a user event

Link target classes hierarchy


Adding a hyperlink to an anchor within the same document

Adding a hyperlink to an anchor within the same document

To link one part of your document to another, you have to do two things:

· Mark the location (called an anchor) where you want the link to point.

· Add a link to that location (a hyperlink) to another part of the document (you can have several hyperlinks pointing to the same anchor, of course).

To create an anchor on a render object, you can add an element (of the type C1Anchor) to the Anchors collection of that render object. For example, if rt is a RenderTable, then you can write:

· Visual Basic

· C#

· Delphi

This will define an anchor with the name “anchor1” (the name is used to reference the anchor) on the render table.

To link another render object, for example a RenderText, to that anchor, you can write:

· Visual Basic

· C#

· Delphi

Of course, you must add both involved render objects (the one containing the anchor, and the one with the hyperlink) to the document.

Hyperlink is a property of the RenderObject class, which is the base class for all render objects, so in exactly the same manner as shown above, any render object may be turned into a hyperlink by setting that property.


Adding a hyperlink to an anchor in a different C1PrintDocument

Adding a hyperlink to an anchor in a different C1PrintDocument

Previous Next

To link a location in one document to a location in another, you must do the following:

· As described above, add an anchor to the target document, generate that document and save it as a C1D file on your disk. You can save the document using the Save button of the preview control, or in code using the Save method on the document itself.

· Add a link pointing to that anchor to another document, in a way very similar to how an internal link is added. The only difference is that in addition to the target’ anchor name you must also provide the name of the file containing the document.

Here is the text of a complete program that creates a document with an anchor in it, and saves it in a disk file (myDocument1.c1d). It then creates another document, adds a link to the anchor in the first document to it, and shows the second document in a preview dialog:

· Visual Basic

· C#

· Delphi

Note the following:

· The anchor is created in exactly the same manner as for links within the same document. There in fact is no difference; the same anchor may be the target of links both from the same document and from other documents.

· To save the document, the Save method is used. This method saves the document in native C1PrintDocument format, the default extension for which is C1D. Files saved in that format can be later loaded into a C1PrintDocument object for further processing, or previewed using the C1 print preview control.

· Before creating the hyperlink, a link target object must be created which is then passed to the hyperlink constructor. Several link target types are provided, derived from the C1LinkTarget base class. For external anchors, the C1LinkTargetExternalAnchor type is used. The link target contains information needed to process the jump to the link, in this case the document filename and the name of the anchor in it.


Adding a hyperlink to a location within the current document

Adding a hyperlink to a location within the current document

You can add a link to an object within the current document without creating an anchor. Instead, you can use the C1LinkTargetDocumentLocation link target created directly on a render object, like this:

· Visual Basic

· C#

· Delphi

where ro1 is an arbitrary render object in the current document. Setting this link target on a hyperlink will make that hyperlink jump to the specified render object when the object owning the hyperlink is clicked. If, for example, ro2 is a render object that you want to turn into a hyperlink, the following code will link it to the location of ro1 on which the linkTarget was created as shown in the code snippet above:

· Visual Basic

· C#

· Delphi

· Note that in this example, the LinkTarget property of the hyperlink was set after the hyperlink has been created.


Adding a hyperlink to an external file

Adding a hyperlink to an external file

A hyperlink to an external file differs from a link to an external anchor by the link target. The link target class for an external file link is called C1LinkTargetFile. Click on such a link will use the Windows shell to open that file. For instance, if in the sample from the preceding section, you replace the line creating the external anchor link target with the following line:

· Visual Basic

· C#

· Delphi

Clicking on that link will open the Windows Explorer on the root directory of drive C:.

Again, here is a complete program:

· Visual Basic

· C#

· Delphi


Adding a hyperlink to a page in the same document

Adding a hyperlink to a page in the same document

You can add hyperlinks to other pages in the same document without defining anchors, using the C1LinkTargetPage link target. The following page jumps are supported:

· To the first page of the document.

· To the last page of the document.

· To the previous page.

· To the next page.

· To a page specified by its absolute page number.

· To a page specified by an offset relative to the current page.

For instance, to make a link target jumping to the first page in the document, the following line of code may be used:

· Visual Basic

· C#

· Delphi

Here, PageJumpTypeEnum specifies the type of the page jump (of course, for jumps requiring an absolute or a relative page number, you must use a variant of the constructor accepting that).

This feature allows you to provide simple means of navigating the document in the document itself. For example, you can add VCR-like controls (go to first page, go to previous page, go to next page, go to last page) to the document footer.


Adding a hyperlink to a user event

Adding a hyperlink to a user event

Finally, you may add a hyperlink that will fire an event on the C1PreviewPane, to be handled by your code. For this, C1LinkTargetUser should be used. Here is a complete example illustrating the concept:

· Visual Basic

· C#

· Delphi

This example will show the message box with the string that was assigned to the UserData property of the hyperlink when the hyperlink is clicked (in this case, “My hyperlink user data”).


Link target classes hierarchy

Link target classes hierarchy

To conclude the section on hyperlinks, here is the hierarchy of link target classes:

C1LinkTarget |  |  | The base class for the whole hierarchy.
 | C1LinkTargetAnchor |  | Describes a target which is an anchor in the current document.
 |  | C1LinkTargetExternalAnchor | Describes a target which is an anchor in a different document.
 | C1LinkTargetDocumentLocation |  | Describes a target which is a render object.
 | C1LinkTargetFile |  | Describes a target which is an external file to be opened by the OS shell.
 | C1LinkTargetPage |  | Describes a target which is a page in the current document.
 | C1LinkTargetUser |  | Describes a target which invokes a user event handler on the C1PreviewPane.


Render objects

ComponentOne Preview for .NET E-mail sent to documentation@componentone.com is for documentation feedback only. We welcome any suggestions to help improve our documentation.

Render objects


Render objects hierarchy

Render objects hierarchy

All content of a C1PrintDocument is represented by render objects. A rich hierarchy of render objects (based on the RenderObject class) is provided to represent different types of content. Here is the hierarchy of render object types, with a brief description for each class (in the table, italics indicate abstract classes):

RenderObject |  |  |  | The base class for the whole hierarchy.
 | RenderArea |  |  | A general-purpose container for other objects.
 |  | RenderToc |  | Represents the table of contents.
 |  | RenderC1Printable |  | Represents an external control that can be seamlessly inserted into a C1PrintDocument.
 | RenderEmpty |  |  | An empty render object. Provides a convenient placeholder for things like page breaks and so on where no content needs to be rendered.
 | RenderGraphics |  |  | Represents a drawing on the .NET Graphics object.
 | RenderImage |  |  | Represents an image.
 | RenderInputBase |  |  | The base class for input controls (controls that can be embedded in the document and shown/handled by the preview).
 |  | RenderInputButtonBase |  | The base class for button-like input controls.
 |  |  | RenderInputButton | Represents a pushbutton.
 |  |  | RenderInputCheckBox | Represents a checkbox.
 |  |  | RenderInputRadioButton | Represents a radio button.
 |  | RenderInputComboBox |  | Represents a combo box.
 |  | RenderInputText |  | Represents a textbox control.
 | RenderRichText |  |  | Represents a rich text.
 | RenderShapeBase |  |  | The base class for shapes (lines, polygons and so on).
 |  | RenderLineBase |  | The base class for lines and polygons.
 |  |  | RenderLine | Represents a line.
 |  |  | RenderPolygon | Represents a polygon.
 |  | RenderRectangle |  | Represents a rectangle.
 | RenderTable |  |  | Represents a table.
 | RenderTextBase |  |  | The base class for text and paragraph objects.
 |  | RenderParagraph |  | Represents a paragraph (a paragraph can contain text fragments in different styles, and inline images).
 |  |  | RenderTocItem | Represents a paragraph that is inserted into the TOC.
 |  | RenderText |  | Represents a simple, single-style text.
 | RenderTOC |  |  | Represents a table of contents (TOC).


Render objects containment, positioning, stacking rules

Render objects containment, positioning, stacking rules

A C1PrintDocument has a hierarchical structure. For a render object to become a part of the document, it must be added to the document’s hierarchy at some point. The main part of the document is called its body, and to add a render object to the body, it must be added to the Children collection of the Body property of the document, for example, like this:

· Visual Basic

· C#

· Delphi

A document’s Body.Children collection contains all top-level render objects of the document. Each render object in its turn also has a Children collection, which contains render objects within it, and so on. (This is very similar to the way Windows Forms’ controls can be nested inside each other – any control has the collection of contained controls, and so on.)


Render areas

Render areas

Although any render object can contain other render objects as its children, there is one render object designed specifically as a container for other objects – RenderArea. The primary difference between a render area and other render objects (such a render text) is that the size of the render area can be determined by the total size of its children, while for all other render objects it is determined by their own content (text size for a render text, image size for render image, and so on). More specifically, when a render area is created, its width is set to be equal to the width of the parent (for a top-level object, contained in the Body.Children collection, this is the width of the column, which in the case of 1 column per page is equal to the page width). The height of a render area is by default set to Unit.Auto, which is determined by the total height taken by the render area’s children.

Some items worth noting:

· A render area can be nested inside another render area.

· If you want the render area to adjust its width to the width of its children, set the Width property to Unit.Auto. But if you do this, keep in mind:

· The default width for many render object types (for example, RenderText) equals the width of their parent. Set it to a value independent of the parent width if you set the parent width of a render area to auto, otherwise an error will occur at runtime.

· If the total width of a render area’s children exceeds the width of the page, a new horizontal page break will occur. Set the CanSplitHorz property on the render area to false (it is true by default) if you wish to prevent that.


Stacking

Stacking

Within their container, render objects by default are placed according to staking rules, determined by the value of the Stacking property of the container. This value can be one of the following (the values are members of the StackingRulesEnum enumeration):

· BlockTopToBottom

Objects are placed one beneath the other within the container. When the bottom edge of the current page is reached, a new page is added. This is the default.

· BlockLeftToRight

Objects are placed one next to another, from left to right. When the right edge of the current page is reached, a new “horizontal” page is added (a horizontal page logically extends the preceding page to the right; C1PreviewPane respects this location by default, showing such pages in a row).

· InlineLeftToRight

Objects are placed inline, one next to another, from left to right. When the right edge of the current page is reached, the sequence wraps to the next line. A new page is added when the bottom of the current page is reached.

Stacking rules do not propagate down into the contained objects (children). In other words, if you define a render area and set its stacking to the (non-default) value BlockLeftToRight, and add another render area inside that – its stacking will be the default (BlockTopToBottom) unless you explicitly change it.

You may also use the X and Y properties of a render object to set its position explicitly (see the next section for details). In this case that render object does not participate in the stacking order at all – that is, its position neither affects the positioning of its siblings nor is affected by their positions.


Specifying render objects' size and location

Specifying render objects’ size and location

The four properties controlling the size and location of a render object are:

· X – specifies the X coordinate of the object.

· Y – specifies the Y coordinate of the object.

· Width – specifies the width of the object.

· Height – specifies the height of the object.

All those properties have the type Unit. The default value for X and Y is “auto” (the static field Unit.Auto), which means that the object is positioned according to the stacking rules provided by its parent (see Stacking for more information). Width and height have different defaults depending on the type of the render object.

Here are the default sizes for all render objects:

· RenderArea

Width is equal to the parent width.
Height is auto.
Auto size is calculates as the total size of the child objects.

· RenderEmpty

Width is auto.
Height is auto.
Auto size is 0.

· RenderGraphics

Width is auto.
Height is auto.
Auto size is determined by the size of the content.

· RenderImage

Width is auto.
Height is auto.
Auto size is determined by the size of the image.

· RenderInputButton
RenderInputCheckBox
RenderInputRadioButton
RenderInputComboBox
RenderInputText

Width is auto.
Height is auto.
Auto size is determined by the size of the content.

· RenderRichText

Width is equal to the parent width (auto width is not supported).
Height is auto (determined by the text size).

· RenderLine
RenderPolygon
RenderEllipse
RenderArc
RenderPie
RenderRoundRectangle

Width is auto.
Height is auto.
Auto size is determined by the size of the shape.

· RenderTable

Width is equal to the parent width (auto width is calculated as the sum of columns’ widths, in which case the widths of all columns must be specified as absolute values).
Height is auto (determined by the total height of all rows).

· RenderParagraph
RenderText
RenderTocItem

Width is equal to the parent width.
Height is auto.
Auto size is determined by the size of the text.

· RenderToc

Width is equal to the parent width.
Height is auto.
Auto size is determined by the size of the child objects.

· RenderC1Printable

Width is auto.
Height is auto.
Auto size is determined by the size of the content.

You can override the default values for any of those properties with custom values (as was noted in the Stacking section, specifying anything but “auto” as the X or Y coordinates excludes the object from the stacking flow). The size and location properties can be set in any of the following ways (“ro” in the samples below is a render object):

· As auto (semantics depend on the render object type):

ro.Width = Unit.Auto;

ro.Height = “auto”;

· As absolute value:

ro.X = new Unit(8, UnitTypeEnum.Mm);

ro.Y = 8; (C1PrintDocument.DefaultUnit is used for the units);

ro.Width = “28mm”;

· As percentage of a parent’s size (using this for coordinates is not meaningful and will yield 0):

ro.Height = new Unit(50, DimensionEnum.Width);

ro.Width = “100%”;

· As a reference to a size or position of another object. The object can be identified by any of the following key words:

self – the current object (the default value, may be omitted);

parent – the object’s parent;

prev – the previous sibling;

next – the next sibling;

page – the current page;

column – the current column;

page<N> – page with the specified number (note: the page must already exist, that is forward references to future pages are not supported);

column<M> – a column (specified by number) on the current page;

page<N>.column<N> – a column (specified by number) on the specified page;

<object name> – the object with the specified name (the value of the Name property; the object is searched first among the siblings of the current object, then among its children).

Sizes and locations of the referenced objects are identified by the following key words: left, top, right, bottom, width, height (coordinates are relative to the object’s parent).

Some examples:

ro.Height = “next.height”; – sets the object’s height to the height of its next sibling;

ro.Width = “page1.width”; – sets the object’s width to the width of the first page;

ro.Height = “width”; – sets the object’s height to its own width;

ro.Y = "prev.bottom"; – sets the object’s Y coordinate to the bottom of its previous sibling;

ro.Width = "prev.width"; – sets the object’s width to the width of its previous sibling.

· As an expression. Expressions can use any of the ways described above to reference size and position of another object, combined using the operators +, -, *, /, and %, and parentheses ( and ). For example:

ro.Width = “prev.width + 50%prev.width”; – sets the object’s width to the width and a half of its previous sibling;

ro.Width = “150%prev”; – same as above (when referencing the same dimension as the one being set, the dimension – “width” in this case – can be omitted).

In all of the above samples where a size or location is set to a string, the syntax using the Unit(string) constructor can also be used, for example:

· Visual Basic

· C#

· Delphi

Case is not important in strings, so “prev.width”, “PrEv.WidhT”, and “PREV.WIDTH” are equivalent.


Using Styles

Using Styles

A fundamental feature of C1PrintDocument is styles. Styles provide most of the visual attributes used to represent the content of the document. The main points that should be remembered about using styles are described below.

Classes that have the Style property

Inline and non-inline styles

Ambient and non-ambient style properties

Styles inheritance, Parent and AmbientParent

Style properties and their default values

Sub-properties of complex style properties


Classes that have the Style property

Classes that have the Style property

All objects having their own visual representation in the document have a style associated with them. Specifically, the following classes have the Style property:

· The whole document (C1PrintDocument).

· Render objects (RenderObject and all derived classes).

· Paragraph objects (ParagraphText and ParagraphImage, derived from ParagraphObject).

· Table cells (TableCell).

· User-defined groups of cells in tables (UserCellGroup).

· Table rows and columns (TableRow and TableCol, derived from TableVector).

· Groups of table rows and columns such as table headers/footers (TableVectorGroup).


Inline and non-inline styles

Inline and non-inline styles

In C1Preview, there are styles of two kinds – inline and non-inline. If an object has the Style property, that property refers to the inline style of the object, which is an integral part of the object itself. An inline style cannot be removed or set – it is a read-only property that refers to the style instance which always lives together with the object. Thus, style properties can be considered to be the properties of the object itself. But, due to inheritance, styles are much more flexible and memory-efficient.

Additionally, each Style contains a collection of styles (called Children) which are not directly attached to any objects. Instead, those (non-inline) styles can be used as parent styles (see style properties Parent and AmbientParent) to provide values for inherited properties of other styles (including, of course, inline styles).

A style object can not be created by itself – it is always either an inline style attached directly to a render object or other element of the document, or a member of the Children collection of another style.


Ambient and non-ambient style properties

Ambient and non-ambient style properties

All style properties (font, colors, borders and so on) can be classified into two groups according to their semantics: ambient and non-ambient. Ambient properties are those that affect the content of an object (for example, the text font) whereas non-ambient properties are those used to paint the object’s adornments (for example, the borders around the object). This distinction is natural and useful, as in most cases the desired behaviors (especially the inheritance rules) are different for the two groups. For ambient properties, it is usually desirable to propagate down the hierarchy of objects, so that setting of an ambient property on a container object affects all objects within that container (consider a table – if you set the font on the table itself, you would normally want that font to be applied to texts in all cells of that table). This is markedly different for non-ambient properties. For instance, if you wanted to add some white space before and after that table, you would set the Spacing property on that table – but you would not want that spacing to propagate to all cells. In C1Preview styles, this division of style properties into ambient and non-ambient groups is built it. Basically, this means that usually just setting the property on the style of an object (without thinking too much about ambience) will do the right thing.


Styles inheritance, Parent and AmbientParent

Styles inheritance, Parent and AmbientParent

All style properties affecting the appearance of the object to which the style is applied (such as Font, BackColor and so on) may be in one of two states: set or not set. Initially, all properties of a newly created style are not set. Their values can be queried, but are obtained from another style or object via inheritance (see below). If a property is set though, the set value is stored in the style itself, and is not any longer affected by other styles via inheritance.

A style has two special properties to support style inheritance: Parent and AmbientParent. Parent property gets or sets the style that provides values for non-ambient properties that are not set on the current style. AmbientParent property gets or sets the style that provides values for ambient properties that are not set on the current style. By default, both parents of a newly created inline style are empty (null values in C#, Nothing in VB), whereas for styles created on the Children collection of a style, the Parent is set to the style containing that collection, while the AmbientParent is empty.

If the Parent of a style is not specified, the values of non-ambient properties are taken from static defaults (see the table below). If the AmbientParent of a style is not specified, the values of ambient properties are taken from the object which contains the object the current style applies to.

For example, if a RenderText rt is contained in a RenderArea ra, then the following rules will be used to retrieve the font used to render the text:

· If rt.Style.Font is set, it will be used.

· Otherwise, if rt.Style.AmbientParent is not null, rt.Style.AmbientParent.Font will be used, because Font is an ambient property.

· Otherwise (if if rt.Style.AmbientParent is null, which is the default), the font of the containing object will be used, that is ra.Style.Font.

In the same example, the following rules will be used to retrieve the BackgroundImage for the RenderText object:

· If rt.Style.BackgroundImage is set, it will be used.

· Otherwise, if rt.Style.Parent is not null, rt.Style.Parent.BackgroundImage will be used.

· Otherwise the default value for background image (that is no image) will be used.

Please note that although by default styles in the Children collection of a style have their Parent set to the style which is the owner of that Children collection, this can be changed. For example, the parent of one style in the Children collection may be set to another style in the same collection. The Children collection is just a convenient place to group/store related styles, but does not really impose any limitations on the styles hierarchy.


Style properties and their default values

Style properties and their default values

Here is the table showing all style properties affecting the appearance of the object to which the style is applied, indicating whether the property is ambient or not, and the default value for that property:

Property name | Ambient | Default value
ActiveHyperlinkAttrs | Yes |
BackColor |  | Empty
BackgroundImage |  | None
BackgroundImageAlign |  | Align left/top, stretch horizontally/vertically, keep aspect ratio
BackgroundImageName |  | None
Borders |  | All empty
Brush |  | None
ClientAreaOnly |  | False
EolIsEndOfParagraph | Yes | False
Font | Yes | Arial, 10pt
GridLines |  | None
HighlightedHyperlinkAttrs |  | None
HoverHyperlinkAttrs | Yes |
HyperlinkAttrs | Yes | Blue
ImageAlign | Yes | Align left/top, stretch horizontally/vertically, keep aspect ratio
LineSpacing | Yes | 100%
MeasureTrailingSpaces | Yes | False
MinOrphanLines |  | 0
Padding |  | All zeroes
ShapeFillBrush |  | None
ShapeFillColor |  | Transparent
ShapeLine |  | Black, 0.5pt
Spacing |  | All zeroes
TextAlignHorz | Yes | Left
TextAlignVert | Yes | Top
TextAngle |  | 0
TextColor | Yes | Black
TextPosition |  | Normal
TreatLastLineNotEndOfParagraph | Yes | False
VisitedHyperlinkAttrs | Yes | Magenta
WordWrap | Yes | True


Sub-properties of complex style properties

Sub-properties of complex style properties

Some of the properties in the table above are complex classes that contain sub-properties which can be individually set. For instance, the BackgroundImageAlign property has AlignHorz, AlignVert, and several other sub-properties. With the exception of read-only sub-properties (as is the case with fonts, which are immutable and whose individual sub-properties can not be set), each sub-property can be set or inherited individually.


Styles in paragraph objects

Styles in paragraph objects

The RenderParagraph object (as all render objects) has the Style property, which can be used to set style properties applied to the paragraph as a whole. Individual paragraph objects (ParagraphText and ParagraphImage) also have styles, but the set of style properties that are applied to paragraph objects is limited to the following properties:

· BackColor

· Brush (only if it is a solid brush)

· Font

· Style.HighlightedHyperlinkAttrs

· TextColor

· TextPosition

· Style.VisitedHyperlinkAttrs


Tables

ComponentOne Preview for .NET E-mail sent to documentation@componentone.com is for documentation feedback only. We welcome any suggestions to help improve our documentation.

Tables


Table basics

Table basics

Tables are represented by instances of the RenderTable class. To create a table, just invoke its constructor, for example like this:

· Visual Basic

· C#

· Delphi

C1PrintDocument tables follow the model of MS Excel. Though a newly created table is physically empty (that is it does not take much space in memory), logically it is infinite: you can access any element (cell, row, or column) of a table without first adding rows or columns, and just accessing that element will create it and all necessary elements preceding it. For instance, accessing the cell of an empty table at row index 9 and column index 3 will make the table grow to 10 rows and 4 columns.

To actually add content to a table, you must fill the cells with data. This can be done in one of the following ways:

· By setting the cell’s RenderObject property to an arbitrary render object. This will insert the specified render object into that cell. Any render object can be added to a cell, including another table, thus allowing to nest tables.

· By setting the cell’s Text property to a string. This is actually a handy shortcut to create text-only tables, which internally creates a new RenderText object, sets the cell’s RenderObject property to that RenderText, and sets that object’s Text property to the specified string.

So, the following code snippet will create a table with 10 rows and 4 columns:

· Visual Basic

· C#

· Delphi

You can of course at any time find out the actual current size of a table by querying the values of properties Cols.Count (which returns the current number of columns) and Rows.Count (which returns the current number of rows).

Accessing cells, columns and rows

Table and column width, row height

Groups of rows and columns, headers and footers

User cell groups


Accessing cells, columns and rows

Accessing cells, columns and rows

As can be seen from the code above, all cells in a table are represented by the Cells collection, which has the type TableCellCollection. Elements in this collection representing individual cells have the type TableCell. To access any cell in the table, the Cells collection can be indexed by the cell’s row and column as shown in the code snippet above.

Table columns are accessed via the Cols collection, which has the type TableColCollection, and contains elements of the type TableCol. As with cells, just “touching” a column will create it. For instance, if you set a property of a column’s Style, that column will be created if did not exist already.

Table rows are accessed via the Rows collection, which has the type TableRowCollection, and contains elements of the type TableRow. As with cells and columns, just “touching” a row will create it. For instance, if you set the Height of a row it (and all rows before it) will be automatically created.

(Please note though that all table rows that do not contain cells with some actual content will have zero height, so will not be visible when the table is rendered.)

Though table cells, columns and rows are not render objects (that is they do not derive from the RenderObject class), they do have some properties similar to those of render objects. In particular, they all have the Style property. Manipulating styles affects the corresponding element and all its content. Setting the style of a row will affect all cells in that row. Setting the style of a column will affect all cells in that column. The style of the cell at the intersection of that row and column will be a combination of the styles specified for the row and the column. If the same style property is set on both the row and the column, the column will take precedence.


Table and column width, row height

Table and column width, row height

By default, the width of a table is equal to the width of its parent, with equally wide columns. Rows’ heights are calculated automatically based on the content of the cells contained in each row. You can override any of those defaults using the RenderTable.Width property of the table, the Width property of any column, and the Height property of any row.

You can set the width of a table to “auto”, which for tables means that the width of the table is calculated as the sum of the widths of all columns. But in this case you must explicitly set the widths of all columns to some values, otherwise a runtime error will occur due to the circular dependency (because the default width of a column is calculated as a fraction of the width of the table).


Groups of rows and columns, headers and footers

Groups of rows and columns, headers and footers

A very powerful feature of tables is groups of elements. Groups allow accessing several elements of a table as a whole (for example, the style can be set on a group as if it were a single element). Supported are groups of columns, groups of rows, and groups of cells.

To access a group of rows, use the collection RowGroups (which has the type TableVectorGroupCollection). Elements of that collection have the type TableVectorGroup, with some useful properties defined on that type. One of the more interesting of those properties is ColumnHeader. That property allows assigning a group of rows to be a table header, to be repeated at the top of each new page or page column. A related property is ColumnFooter, which allows to assign a group of rows to be a table footer, again repeated either at the end of each page or page column.

The following line of code shows how to assign the first 2 rows of a table to be the table header, repeated after each page or column break (rt1 here is a RenderTable object):

· Visual Basic

· C#

· Delphi

As seen above, the indexer on the TableVectorGroupCollection class accepts two integers. The first value is the index of the first row included in the group (0 in the sample above). The second value is the count of rows in the group (2 in the sample above).

To access a group of columns, the collection ColGroups should be used. It has the same type as the row groups’ collection (TableVectorGroupCollection), and provides the same functionality. Of particular interest is the ability to assign a group of columns to be a vertical table header or footer. C1PrintDocument supports “horizontal” (or “extension”) pages, which allow wide objects to span several pages horizontally. To allow an object (for example, a table) to span several pages horizontally, set its CanSplitHorz to true. If the object’s width is wider than the page width, it will be split into several horizontal pages. In particular, a wide table can be split in this way. To make a group of columns repeat along the left edge of each page, set the group’s ColumnHeader property to true. To make a group of columns repeat along the right edge of each page, set the group’s ColumnFooter property to true.

Note about footers: although any group of rows (or columns) of a table can be assigned to be the footer, normally you would want to include only the last rows (or columns) of the table into the footer group. This will ensure that the footer behaves as a normal footer – that is appears only at the bottom (or right edge) of pages, and also appears at the end of the table. (If, for example, you assign the first row of a table to be the footer, it will still appear at the beginning of the table, and also will not print at the end of the table.)

Here is an example of code that creates a table with 100 rows and 10 columns, sets the width of the table to auto, explicitly sets the width of each column to 1in, and also assigns horizontal and vertical table headers and footers:

· Visual Basic

· C#

· Delphi

In this sample, background color is used to highlight row and column groups.


User cell groups

User cell groups

Cells, even disconnected cells, can be united into groups. It is then easy to set styles on all cells in a group with a single command. To define a user cell group:

· Create an object of the type UserCellGroup. This class has several overloaded constructors which allow specifying the coordinates of cells to be included in the group (all cells must be added to the group in the constructor).

· Add the created UserCellGroup object to the UserCellGroups collection of the table.

· Now you can set the style on the group. This will affect all cells in the group.


Generating Table of Contents

Generating Table of Contents

C1PrintDocument supports automatic generation of table of contents (TOC). The table of contents itself is represented by a dedicated render object, RenderToc, which is derived from RenderArea and adds TOC-specific features. Individual items within the TOC are represented by RenderTocItem (derived from RenderParagraph). Each TOC item holds a hyperlink (the RenderTocItem.Hyperlink property) pointing to a location in the document (represented by an anchor). So, the same mechanism is used for connecting TOC items to document content as for hyperlinks. Convenient methods are provided to create the TOC, see below.

To add a table of contents to your document, do the following:

· Create an instance of the RenderToc class and add it to your document at the point where you want the TOC to appear.

· Add individual items (of the type RenderTocItem) to the RenderToc instance. Any of the following approaches (or a mix of them) may be used for this:

· You may add the TOC item to the TOC using any of the overloads of the RenderToc.AddItem method, providing the text of the item, the location it should point to, and optionally the level in the TOC.

· You may create an instance of the RenderTocItem class in your code, set properties on it, and add it to the Children collection of the TOC render object.

· An overload of the RenderTocItem constructor is provided which accepts an instance of the RenderToc as the argument. When that constructor is used, the newly created TOC item is added to the TOC within the constructor, so you do not need to add it to the Children collection of the TOC object manually.


Outline

Outline

C1PrintDocument supports outline. The document outline is a tree (specified by the Outlines property), with nodes (of the type OutlineNode) pointing to locations in the document. The outline is shown on a tab in the navigation panel of the preview, and allows navigating to locations corresponding to items by clicking on the items. Also, outlines are exported to formats supporting that notion (such as PDF).

To create an outline node, use any of the overloaded Outline constructors. You can specify the text of the outline, the location within the document (a render object or an anchor), and an icon to be shown in the outline tree panel in the preview. Top-level nodes should be added to the Outlines collection of the document. Each outline node may, in its turn, contain a collection of child nodes in the Children collection, and so on.


Embedded Fonts

Embedded Fonts

C1PrintDocument supports True Type font embedding. If a font is embedded, text drawn using that font is guaranteed to render correctly on any system, even if that font is unavailable on the system used to preview or print the document. You may not need to embed all commonly available fonts such as Arial or Times New Roman, but if your document uses a rare or specialized font (for example, a font drawing barcodes), embedding it may be a good idea. Please note that embedding a font does not mean that all glyphs in the font will be embedded. Rather, just the glyphs actually used by the document will be embedded. This greatly reduces the size of the document on disk or in memory.

To make the document automatically embed all fonts used in that document, set the AutoEmbedFonts property to true. That’s it, if that property is true all fonts used in the document will be embedded (as mentioned above, just the glyphs actually used in the document will be embedded).

To embed only some fonts, do not set the AutoEmbedFonts property to true (it is false by default). Instead, add the needed fonts to the EmbeddedFonts collection. That collection contains the list of fonts that will be embedded. The fonts in the collection are represented by the type EmbeddedFont. Overloaded constructors are provided to create an object of the type EmbeddedFont, using either a .NET Font object, or the name of a font. If you add a font to the EmbeddedFonts collection, only glyphs from that font actually used in the document will be embedded. You may want to make sure certain glyphs are embedded even if they are not used (for example, if the document may change in the future, and those glyphs may become used). To do that, you can use any of the EmbeddedFont.AddGlyphs method overloads, which will force the specified glyphs to be embedded. For example, you can add all glyphs from a certain Unicode range, or from a specified string.


Dictionary

Dictionary

If the same item (an image or an icon) is used in many places in the document, it is a good idea to store that item once in a location available from the whole document, and reference that instance, rather than inserting the same image or icon in all places it is used. For that, C1PrintDocument provides a dictionary. To access the dictionary, the property Dictionary is used. The dictionary contains items of the base type DictionaryItem, which is an abstract type. Two derived classes are provided, DictionaryImage and DictionaryIcon, to store images and icons correspondingly. Items in the dictionary are referenced by names. In order to use an item, you must assign a name to it. The name must be unique within the dictionary. Dictionary items may be used in the following places in the document:

· As the background image of a style, using the property BackgroundImageName.

· As the image in a RenderImage object, using the property ImageName.

So, if in your document the same image is used in several places, do the following:

· Add the image to the dictionary, for instance like this:

· Visual Basic

· C#

· Delphi

· Use that image by setting either the BackgroundImageName on styles, or the ImageName property on render images, for example, like this:

· Visual Basic

· C#

· Delphi


Tags

Tags

Tags allow you to use a placeholder where you want to insert a certain string but do not know the value of that string yet. The typical example of a tag is the page number – you want to print the page number here but you do not know yet what it is going to be, also it may change when the document is regenerated.

A tag has two main properties: Name and Value. The name is used to identify the tag, while the value is what the tag is replaced with.

C1PrintDocument provides two kinds of tags: predefined and custom. Predefined tags are:

· [PageNo] – replaced with the current page number.

· [PageCount] – replaced with the total number of pages.

· [PageX] – replaced with the current horizontal page number.

· [PageXCount] – replaced with the total number of horizontal pages.

· [PageY] – replaced with the current vertical page number (if there are no horizontal pages, this is equivalent to [PageNo]).

· [PageYCount] – replaced with the total number of vertical pages (if there are no horizontal pages, this is equivalent to [PageCount]).

Custom tags are stored in the Tags collection of the document. To add a tag to that collection, you may use a line like the following:

· Visual Basic

· C#

· Delphi

The value of the tag may be left unspecified when the tag is created, and may be specified at some point later (even after that tag was used in the document).

To use a tag, insert its name in square brackets in the text where you want the tag value to appear, for example, like this:

· Visual Basic

· C#

· Delphi

You may override the default tag opening and closing symbols (the chars [ and ]) with arbitrary strings, by setting the properties TagOpenParen and TagCloseParen on the document.


C1Preview Task-Based Help

C1Preview Task-Based Help

The task-based help assumes that you are familiar with programming in Visual Studio .NET. By following the steps outlined in the help, you will be able to create projects demonstrating a variety of C1Preview features and get a good sense of what C1Preview can do.

Each task-based help topic also assumes that you have created a new .NET project and have placed a C1PrintDocument and a C1PrintPreview component on the form. Also, you should have the following namespaces referenced to your project: C1.Win.C1Preview and C1.C1Preview. The C1.C1Preview namespace must be declared in your source file.

Creating Tables in C1PrintDocument

Using Different Text Styles in C1PrintDocument

Creating Page Headers in C1PrintDocument

Creating Page Footers in C1PrintDocument

Printing in Landscape


Creating Tables in C1PrintDocument

Creating Tables in C1PrintDocument

Creating a Table with Three Columns and Rows in C1PrintDocument

Adding Text to Table Cells

Adding Two Images to Specific Cells of the Table

Creating Borders Around Rows and Columns in Your Table

Creating a BackGround Color for Specific Cells in the Table

Adding Text Below the Table in Your Document


Creating a Table with Three Columns and Rows in C1PrintDocument

Creating a Table with Three Columns and Rows in C1PrintDocument

Previous Next

C1PrintDocument enables you to create tables by using the RenderTable class.

This topic illustrates the basics of setting up a table with three rows and three columns.

1. First, set up the basic framework for the sample that will allow generating and previewing the document. Create a new .NET Windows Application project. Drop a C1PrintPreview control and a C1PrintDocument component on the form.

2. Set the C1PrintPreview’s Dock property to Fill (the preview will be the only control on our form). Make the C1PrintPreview show the C1PrintDocument by setting the preview’s Document property to the C1PrintDocument as shown in the following picture:

3. Double click the empty form. This will automatically create a new handler for the form load event in the source code. The handler will look like the following:

· Visual Basic

· C#

· Delphi

4. Second, create a new C1.C1PrintDocument.RenderTable object and assign it to a variable using the following code:

· Visual Basic

· C#

· Delphi

Note: The code above will need to be in between the opening and closing brackets of the Form1_Load event.

5. Now, add 3 columns to the table and 3 rows to the table’s body:

· Visual Basic

· C#

· Delphi

Note: The code above should follow the code entered in step 3.

Note also that while we added columns “directly” to the table, rows were added to the table’s body. That is because a RenderTable always consists of 3 “bands”: Header, Body and Footer. Any of the three bands may be empty in the table. If you just want a simple table you can add rows to the body as we do in this example.

6. Make the columns’ width and rows’ height five centimeters long:

· Visual Basic

· C#

· Delphi

7. By default, tables have no borders. Add a dark gray gridlines to the table:

· Visual Basic

· C#

· Delphi

8. When you have created the render object(s), you need to add them to your document. The way to do it is to first call the Add method on the document to add the table to the body of the document, and then use the Generate method to create the document. Here is the code:

· Visual Basic

· C#

· Delphi

9. Save and run the application. Your application will appear similar to the image below at run-time:


Adding Text to Table Cells

Adding Text to Table Cells

This topic shows how to use the RenderText class to add text into specific cells of the table.

1. The following code to set up a table with dark gray gridlines should already exist in your source file:

· Visual Basic

· C#

· Delphi

2. Showing any kind of content in a table cell is done by assigning the render object representing that content to the cell’s RenderObject property. But, because showing text in table cells is such a common task, cells have an additional specialized property RenderText that we will use. In order to set the texts of all cells in the table, you need to loop over the table’s rows, and inside that loop do another loop over the row’s columns. In the body of the nested loop set the Text property to the desired text as follows (for the sake of this sample, we leave cells (1,1) and (1,2) empty):

· Visual Basic

· C#

· Delphi

3. Save and run the application. Your table should look similar to the table below:


Adding Two Images to Specific Cells of the Table

Adding Two Images to Specific Cells of the Table

This topic demonstrates how to add two different images to specific cells in an existing table by using the RenderImage class. It also shows how to align images in cells using the ImageAlignHorzEnum. The sample below uses the empty 3 by 3 table which was built in Creating a Table with Three Columns and Rows in C1PrintDocument.

1. The following code should already exist in your source file:

· Visual Basic

· C#

· Delphi

2. Add the following code after the line adding the rows (the new code will fix the center cell’s size in the table):

· Visual Basic

· C#

· Delphi

3. Create two JPEG or GIF images or use images that already exist.

4. Drop two PictureBox controls onto your form. Set their Image properties to the two images created in the previous step. Also, make the two picture boxes invisible (set Visible to False) so that they won’t clutter the form (those controls are used only as storage for the images. The images will be rendered into the C1PrintDocument).

5. Use the CellStyle property to modify the base styles for the cells’ content. In this sample we will modify the ImageAlign property for the cells. Enter the following code to set up the image alignment:

· Visual Basic

· C#

· Delphi

6. In C1PrintDocument, images are rendered using the RenderImage class (which subclasses the RenderObject). Create two new RenderImage objects for the two images as follows:

· Visual Basic

· C#

· Delphi

7. Now, set the RenderImage’s Image properties to the images stored in the picture boxes:

· Visual Basic

· C#

· Delphi

8. Assign the RenderImage objects to the RenderObject properties of the cells so that the images will render in those cells:

· Visual Basic

· C#

· Delphi

Note: The top left cell of the table is at row 0, column 0.

9. Save and run your application. Your table should look similar to the table below:


Creating Borders Around Rows and Columns in Your Table

Creating Borders Around Rows and Columns in Your Table

This topic demonstrates how to create distinct borders around a row and a column by using the LineDef class. This topic assumes you already have a table with three columns and three rows.

1. The following code should already exist in your source file:

· Visual Basic

· C#

· Delphi

2. Make the columns’ width and rows’ height five centimeters long:

· Visual Basic

· C#

· Delphi

3. Assign a new instance of the LineDef class to the borders of the third row as follows (note that the constructor we use specifies that the new border will be red and 2 points wide):

· Visual Basic

· C#

· Delphi

4. Assign a new instance of the LineDef class to the borders of the first column as follows (note that the constructor we use specifies that the new border will be blue and 6 points wide):

· Visual Basic

· C#

· Delphi

5. Save and run your application. Your borders will appear like this in your table at run-time:


Creating a BackGround Color for Specific Cells in the Table

Creating a BackGround Color for Specific Cells in the Table

This topic demonstrates how to create background colors for specific cells in the table. It also demonstrates how to use the CellStyle property to set the styles used in the table that will be rendered. This topic assumes you have a table with three columns and three rows.

1. The following code below should already exist in your source file:

· Visual Basic

· C#

· Delphi

2. Make the columns’ width and rows’ height five centimeters long:

· Visual Basic

· C#

· Delphi

3. Add the following code below the last line of code listed above. This code will create a crimson background color for row 1, column 2.

· Visual Basic

· C#

· Delphi

Note: The rows and columns begin with 0. The code above uses the CellStyle property to set the cell's style.

4. Create a blue-violet background color for row 0, column 1. Enter the following code:

· Visual Basic

· C#

· Delphi

5. Save and run the application. Your C1PrintDocument form will appear like this:


Adding Text Below the Table in Your Document

Adding Text Below the Table in Your Document

This topic shows how to use the C1.C1PrintDocument.RenderTable object to render the text into the block flow. It also demonstrates how to use the Padding property to advance the block position so that the next render object (in this case, text) is rendered there. In this topic we will use the Padding property to put the text 1 cm below the table in your document. This topic assumes you already have a table created.

1. Use the C1.C1PrintDocument.RenderTable object to create the text to be displayed:

· Visual Basic

· C#

· Delphi

2. Use the Padding property to position the text 1 cm below the table:

· Visual Basic

· C#

· Delphi

3. Add the text below the table using the Add method. Insert the Add method for the text below the Add method for the table, as shown in the following code:

· Visual Basic

· C#

· Delphi

Note: Placing the Add method for the text below the Add method for the table inserts the text below the table. If it is placed above the Add method for the table, the text will appear above the table.

4. Save and run your application. Your document will appear like this:


Using Different Text Styles in C1PrintDocument

ComponentOne Preview for .NET E-mail sent to documentation@componentone.com is for documentation feedback only. We welcome any suggestions to help improve our documentation.

Using Different Text Styles in C1PrintDocument


Modifying the font and style of the text in the C1PrintDocument

Modifying the font and style of the text in the C1PrintDocument

Previous Next

C1PrintDocument contains a RenderInLineText method that renders the specified string without starting a new paragraph into the block flow. The RenderInLineText method automatically wraps the text. This topic illustrates how to use the RenderInLineText method.

1. Create a new Windows Forms application. Add a C1PrintPreview control onto your form. Add a C1PrintDocument component onto your form – it will appear in the components’ tray below the form. The preview will have the default name c1PrintPreview1, the document c1PrintDocument1. Set the value of the Document property of c1PrintPreview1 control to c1PrintDocument1, so that the preview will show the document when the application runs.

2. Double click on the form to create a handler for the form load event – this is where all code shown below will be written.

3. Begin the document with the StartDoc method and create a line of text using the default font. For example:

· Visual Basic

· C#

· Delphi

4. Continue with a different font and color and then go back to the default font and color:

· Visual Basic

· C#

· Delphi

5. Make the last few words of the line a green color.

· Visual Basic

· C#

· Delphi

6. End the document with the EndDoc method.

· Visual Basic

· C#

· Delphi

7. Save and run your application. The text should look like this:


Creating Page Headers in C1PrintDocument

Creating Page Headers in C1PrintDocument

Creating a Page-Header with Three Parts

Creating a Background Color for your Page Header

Drawing a Horizontal Line in C1PrintDocument


Creating a Page-Header with Three Parts

Creating a Page-Header with Three Parts

This topic demonstrates how to create a header that is divided into three columns. The following key points are shown in this topic:

· Creating a table with one row and three columns in C1PrintDocument.

· Setting up the text alignment in each section of the page header.

· The TextAlignHorz property of the Style class is used to specify the horizontal alignment of the text. You can assign a member (left, right, justify or center) of the AlignHorzEnum to the TextAlignHorz property.

The following detailed steps demonstrate how to create a header with three parts.

1. Create a new Windows Forms application. Add a C1PrintPreview control onto your form. Add a C1PrintDocument component onto your form – it will appear in the components’ tray below the form. The preview will have the default name c1PrintPreview1, the document c1PrintDocument1.

2. Set the value of the Document property of c1PrintPreview1 control to c1PrintDocument1, so that the preview will show the document when the application runs.

3. Double click on the form to create a handler for the form load event – this is where all code shown below will be written. In the form load event, we will set up our document. Create a RenderTable for the page header:

· Visual Basic

· C#

· Delphi

4. Add one row to its body, and 3 columns for the left, middle, and right parts of the header. We will use the TextAlignHorz property to set the alignment of the text in each column of the page header. We will also assign a new font style for the text in our page header. Note, in this example the font type will be Arial and it will be 14 points in size.

· Visual Basic

· C#

· Delphi

5. We will draw the text into each column of the table for the page header. Set the RenderObject property of the document’s PageHeader to theader. Finish generating the document by calling the EndDoc method.

· Visual Basic

· C#

· Delphi

6. Save and run your application. Your new page header with three parts will appear like this at run-time:


Creating a Background Color for your Page Header

Creating a Background Color for your Page Header

This topic demonstrates how to create a background color for your page header.

This topic uses the following objects:

· C1PrintDocument

· C1DocStyle

· RenderTable

1. Create a new Windows Forms application. Add a C1PrintPreview control onto your form. Add a C1PrintDocument component onto your form – it will appear in the components’ tray below the form. The preview will have the default name c1PrintPreview1, the document c1PrintDocument1.

2. Set the value of the Document property of c1PrintPreview1 control to c1PrintDocument1, so that the preview will show the document when the application runs.

3. Double click on the form to create a handler for the form load event – this is where all code shown below will be written. Call the StartDoc method to start generating the document. We'll assign the table to the RenderTable class.

· Visual Basic

· C#

· Delphi

4. In this example, we will assign a gold color to our page header in our table. We will use the Style property of the TableRow class to apply the background color to the table, theader.

· Visual Basic

· C#

· Delphi

5. We'll need to create a table with one row and one column. We will draw some text onto our table for our page header. We will make our text right-aligned. We create a new font type of Arial and font size of 14 points, for our text.

· Visual Basic

· C#

· Delphi

6. Save and run your application. Your header should look similar to the following:


Drawing a Horizontal Line in C1PrintDocument

Drawing a Horizontal Line in C1PrintDocument

This topic shows how to draw a horizontal line in the C1PrintDocument.

1. Create a new Windows Forms application. Add a C1PrintPreview control onto your form. Add a C1PrintDocument component onto your form – it will appear in the components’ tray below the form. The preview will have the default name c1PrintPreview1, the document c1PrintDocument1.

2. Set the value of the Document property of c1PrintPreview1 control to c1PrintDocument1, so that the preview will show the document when the application runs.

3. Double click on the form to create a handler for the form load event – this is where all code shown below will be written.

4. A line can be drawn in C1PrintDocument using the RenderLine render object. Its two main properties are the two points – the start and the end of the line. Because we will render the line into the block flow, and want it to be horizontal, we leave the Y coordinates of the two points as default zeroes. The start X coordinate is also left at zero. The end coordinate is set to the page width. This will result in a RenderLine object that renders a horizontal line across the whole page at the current Y coordinate of the block flow:

· Visual Basic

· C#

· Delphi

5. Save and run your application. Your C1PrintDocument should appear like this:


Creating Page Footers in C1PrintDocument

ComponentOne Preview for .NET E-mail sent to documentation@componentone.com is for documentation feedback only. We welcome any suggestions to help improve our documentation.

Creating Page Footers in C1PrintDocument


Creating a Page-Footer with Two Parts

Creating a Page-Footer with Two Parts

This topic demonstrates how to create a table footer that is divided into two columns. The following key points are shown in this topic:

· Adding a footer to a table with multiple rows and columns in C1PrintDocument.

· Setting up the table footer at the end of each page.

The Count property of the TableVectorCollection class is used to insert the footer at the end of the table on each page.

· Setting up the row and column spans for each section of the page footer.

The SpanRows and SpanCols properties of the TableCell class are used to specify the row and column spans.

· Setting up the text alignment in each section of the page footer.

The TextAlignHorz and TextAlignVert properties of the Style class are used to specify the horizontal and vertical alignment of the text. You can assign a member (left, right, justify, or center) of the AlignHorzEnum to the TextAlignHorz property or a member (bottom, center, justify, or top) of the AlignVertEnum to the TextAlignVert property.

The following detailed steps demonstrate how to create a table footer with two parts.

1. Create a new Windows Forms application. Add a C1PrintPreview control onto your form. Add a C1PrintDocument component onto your form – it will appear in the components’ tray below the form. The preview will have the default name c1PrintPreview1, the document c1PrintDocument1.

2. Set the value of the Document property of c1PrintPreview1 control to c1PrintDocument1, so that the preview will show the document when the application runs.

3. Double click on the form to create a handler for the form load event – this is where all code shown below will be written. In the form load event, we will set up our document. Create a RenderTable for the page footer and add a table with 4 columns, 100 rows, and sample text:

· Visual Basic

· C#

· Delphi

4. Reserve the last two rows of the page for the footer using the Count property and group the rows together using the RowGroups property. We will assign a new font style for the text and a new background color for the cells in our page footer. Note, in this example the font type will be Arial and it will be 10 points in size and the background color will be lemon chiffon.

· Visual Basic

· C#

· Delphi

5. We will use the TextAlignHorz and TextAlignVert properties to set the alignment of the text in each column of the page footer. We will also use the SpanRows and SpanCols properties to span the footer over the last two rows and create two columns. We will draw the text into each column of the table for the page footer. Finish by using the Generate method to create the document.

· Visual Basic

· C#

· Delphi

6. Save and run your application. Your new page footer with two parts will appear like this at run-time:


Printing in Landscape

Printing in Landscape

C1PrintDocument allows to you to specify different printing options and page settings for your document. The page settings can be specified at design time or at run time.

At Design Time:

1. Select the C1PrintDocument control on your form. Its properties will appear in the right-pane of the visual studio interface.

2. Locate the PageSettings property for C1PrintDocument.

3. Locate the Landscape property and set it to True. Your C1PrintDocument will appear and print in the Landscape orientation.

At Run Time:

You can also change your page settings for your C1PrintDocument at run-time, by adding the following code to the Form_Load event:

· Visual Basic

· C#

· Delphi

Page Setup Dialog Box:

You can also change the page settings for your C1PrintDocument in the preview using the Page Setup dialog box.

1. Click on the Page Setup button located in the toolbar.

2. The Page Setup dialog box will open.

The Page Setup dialog box contains the following fields:

Field Name | Description
Paper | Select the size and the source of the paper. The available sizes and sources depend on the selected printer.
Orientation | Choose from Portrait or Landscape page orientation.
Margins | Customize the Left, Right, Top, and Bottom margins of your C1PrintDocument.

The Page Setup dialog box has the following Command Buttons:

Button Name | Description
OK | Apply the settings to your C1PrintDocument.
Cancel | Cancel the Page Settings for your document.
Printer | Modify or view the settings for your printer.

3. Locate the Orientation field and select the Landscape option. Your C1PrintDocument will appear and print in the Landscape orientation.


C1.C1Preview.2 Assembly

C1.C1Preview.2 Assembly

Namespaces

C1.C1Preview

C1.C1Preview.Export

C1.C1Preview.Forms

C1.C1Preview.Serialization

See Also

C1.Win.C1Preview.2 Assembly


C1.Win.C1Preview.2 Assembly

C1.Win.C1Preview.2 Assembly

Namespaces

C1.Win.C1Preview

See Also

C1.C1Preview.2 Assembly


C1.C1Preview Namespace

C1.C1Preview Namespace

C1.C1Preview Hierarchy

Classes

Class | Description
ActionHandlerBase | Describes an action that can be performed in response to a user action in a C1Preview form. This is an abstract base class for the specific action handlers.
ActionHandlerFile | The base class for action handlers performing an file operation: save, open, and so on.
ActionHandlerFileOpen | Describes the action handler that performs the loading of the document from file.
ActionHandlerFileSave | Describes the action handler that performs the saving of the document to file.
ActionHandlerHistoryNext | Describes the action handler that goes to next history entry.
ActionHandlerHistoryPrev | Describes the action handler that goes to previous history entry.
ActionHandlerLink | Describes an action handler that executes a hyperlink jump. All link types which are supported by the C1Preview hyperlinks are also supported by this action handler: - Jump to an anchor in the existing document. - Jump to an anchor in another document. - Open an external program or file. - Jump to another page of the same document.
ActionHandlerPageSetup | Describes the action handler that displays the page setup dialog to change the page properties of document.
ActionHandlerPageView | Describes the action handler that changes the view of document in the preview window.
ActionHandlerPrint | Describes the action handler that prints the document.
ActionHandlerReflow | Describes the action handler that reflows the document.
AreaResolvedInfo |
C1Anchor | Represents the anchor within document, this anchor can be associated with any RenderObject.
C1AnchorCollection | Collection of C1Anchor objects.
C1AnchorInfo | Auxiliary class, contains additional information about anchor within document.
C1AnchorInfoCollection | Collection of the C1AnchorInfo objects.
C1AnchorText | Represents the anchor within text object: RenderText, RenderParagraph, RenderRichText.
C1Hyperlink | Represents the hyperlink in document, can be associated with RenderObject or ParagraphObject.
C1HyperlinkAttrs | The visual style of hyperlink.
C1HyperlinkInfo | Auxiliary class, contains additional information about hyperlink: list of pages where hyperlink exists and area of hyperlink within each page.
C1HyperlinkInfo.Area | Describes the position of hyperlink within page.
C1HyperlinkInfo.AreaCollection | Collection of Area objects.
C1HyperlinkInfoCollection | Collection of the C1HyperlinkInfo objects.
C1HyperlinkTextAttrs | Determines the attributes used to highlight a hyperlink inside a text.
C1LinkTarget | Determines the target of the hyperlink. This is an abstract class, it cannot be used directly.
C1LinkTargetAnchor | Describes a link target inside the current document.
C1LinkTargetDocumentLocation | This class defines a link target to object within document supporting the IDocumentLocation interface, currently this document is supported by the: RenderObject, Page.
C1LinkTargetExternalAnchor | Jump to anchor within external C1Preview document.
C1LinkTargetFile | Describes a link to an external document, file or URL. The link is performed using the ShellExecute() API.
C1LinkTargetPage | This class defines a link target to another page in a some document.
C1LinkTargetUser | This class starts a new document when a hyperlink with this type of LinkTarget is clicked. When such a hyperlink is activated(clicked), the UserHyperlinkJump event is fired (regardless of the value of the FireDrawelEvents property). This class does not have any public properties or methods of its own.
C1PageSettings | Describes the page's properties of document.
C1PrintDocument | ComponentOne Document.
C1PrintOptions | Describes the set of options controlling how a document's content is to be printed (or previewed).
DictionaryIcon | Represents an icon in dictionary.
DictionaryImage | Represents an image in dictionary.
DictionaryItem | Base class for all dictionary items.
DocumentBody | Represents the body of document, manages the generating of the document.
DocumentInfo | Represents the common information about the C1Preview: author, subject, creation time and so on.
DocumentPageLayouts | Describes the page layouts used in document.
EllipsePartProps | Represents the properties of shape which is a part of ellipse - arc or pie.
EmbeddedFont | Represents the font embedded in the C1PrintDocument.
EmbeddedFontCollection | Collection of EmbeddedFont objects.
FragmentResolvedInfo | Represents the temporary info used during resolving, instance of this class, created for each object participating in resolving.
InputAction | Describes a single input action, and any handling associated with it.
InputActionCollection | Represents the collection of InputAction objects.
LayoutChangeBase | Represents the base class for actions which can be performed before or after rendering an object. Actions like: start new page, column, change columns layout.
LayoutChangeNewColumn | Describes the column break action.
LayoutChangeNewLine | Describes the line break action on inline flow.
LayoutChangeNewPage | Desribes the page break action.
LayoutChangeNoBreak | Describes the action that does no produce the page break, but changes the page layout for next page.
LengthAbs | Represents the dimension like: "5mm", "10in", "20" and so on.
LengthAbs.Predefined |
LengthAuto | Represents the "auto" size or coordinate, only one instance of this class can be created. Use property LengthBase.Auto to access to this instance.
LengthBase | Represents a simple coordinate or size of object. This is an abstract class.
LengthExp | Represents the unit which holds an expression using the LengthRef or LengthAbs classes like: "parent.width + 5mm", "80%parent.width" and so on
LineProps | Represents the geometric properties of the RenderLine object.
LinePropsBase | Base class for properties of the RenderLine and RenderPolygon objects.
LongOperationEventArgs | Describes arguments for the event fired periodically by a potentially long operation. Allows to provide feedback to the user and may also allow to cancel the operation.
OutlineNodeCollection |
OwnedCollection | Base class for RenderObjectCollection and ParagraphObjectCollection.
Page | Represents the generated page of document.
PageCollection | Represents the list of document's pages.
PageColumnDef | Defines parameters of a single page column.
PageColumnDefCollection | Represents the collection of page columns definitions which are items of type PageColumnDef.
PageLayout | Represents the page layout of C1PrintDocument.
PageNumberingChange | Describes the changing of the page numbering: to absolute number or increment from current value.
ParagraphImage | Represents an inline image which is a part of a RenderParagraph.
ParagraphObject | Represents a part of a RenderParagraph object - text, hyperlink or inline image.
ParagraphObjectCollection | Represents a collection of ParagraphObject objects, which comprise the content of a RenderParagraph objects.
ParagraphText | Represents a text which is a part of a RenderParagraph.
PolygonProps | Represents the geometric properties of the RenderPolygon object.
PrintingUtil |
RectangleProps | The base class of properties of all rectangle-based shapes like rectangle, ellipse, arc, pie.
RenderArc | Represents RO that renders ellipse-based wedge.
RenderArea |
RenderAreaFragment |
RenderC1Printable | Represents RO that renders the objects supporting the IC1Printable interface.
RenderC1PrintableFragment | Represents a fragment of the RenderC1Printable object.
RenderEllipse | Represents RO that renders ellipse.
RenderEmpty | Represents RO that renders images.
RenderEmptyFragment | Represents a fragment of the RenderEmpty object.
RenderFragment | Represents the fragment of RenderObject.
RenderFragmentCollection | Represents the collection of RenderFragment objects. All fragments in this collection sorted by ZOrder to perform drawing and search.
RenderGraphics | Represents RO that render images.
RenderGraphicsFragment | Represents a fragment of the RenderImage object.
RenderImage | Represents RO that renders images.
RenderImageFragment | Represents a fragment of the RenderImage object.
RenderInputBase | The base class for all C1Preview Forms' input render objects (which represent controls on C1Preview forms). Provides the basic functionality for all input controls - position, size, visual style, user actions, input options. Adds input-specific features to the display features provided by the base class (position, size, visual style and so on).
RenderInputButton | Input render object providing a push button.
RenderInputButtonBase | The abstract base class for the input info classes for all button-like controls (RenderInputButton, RenderInputCheckBox, and so on).
RenderInputCheckBox | Input render object providing a checkbox.
RenderInputComboBox | Input render object providing text input with dropdown list.
RenderInputComboBoxItem | Represents the separate item in the combobox collection.
RenderInputComboBoxItemCollection | Represents the collection of RenderInputComboBoxItem objects.
RenderInputFragment | Represents a fragment of the RenderImage object.
RenderInputRadioButton | Input render object providing a radio button.
RenderInputText | Input render object providing text input.
RenderLine | Represents render object that renders a line.
RenderLineBase | Represents the base class for all line-like shapes (RenderLine, RenderPolygon, and so on).
RenderLineFragment | Represents the fragment of the RenderLineBase object.
RenderObject | Base class for all render objects.
RenderParagraph | Describes a paragraph render object.
RenderParagraphFragment |
RenderPie | Represents RO that renders ellipse-based wedge.
RenderPolygon | Represents RO that renders polygon, if Closed is True then polygon will be filled.
RenderRectangle | Represents RO that renders a rectangle.
RenderRectangleFragment | Represents the fragment of the RenderRectangle object.
RenderRichText | Represents RO that renders RTF text.
RenderRichTextFragment |
RenderRoundRectangle | Represents RO that renders a rounded rectangle.
RenderRoundRectangleFragment | Represents the fragment of the RenderRectangle object.
RenderShapeBase | Base class for ROs that renders shapes.
RenderShapeFragment | Represents the fragment of RenderShape object.
RenderTable | Represents RenderObject that renders tables.
RenderTableFragment | Represents the fragment of RenderTable object.
RenderText |
RenderTextBase | Base class for RenderText and RenderParagraph
RenderTextFragment |
RenderTextFragmentBase | Base class for RenderTextFragment and RenderParagraphFragment.
RenderToc |
RenderTocItem | Represents the item of table of content.
RenderTocItemFragment |
RoundRectangleProps | Represents properties of the RenderRoundRectanlge object.
ScalableButton | Raises an event when the user clicks it.
ScalableCheckBox | Represents the "scalable" checkbox control.
ScalableComboBox | Represents the "scalable" combobox control.
ScalableRadioButton | Represents the "scalable" radio button control.
ScalableTextBox | Enables the user to enter text, and provides multiline editing and password character masking.
ShapeProps | Describes the geometric properties of the shape, this is a base class.
ShapeResolvedInfo |
Split | Represents the split within RenderObject.
SplitCollection | Represents the collection of Split objects.
SplitParams | The base class for split parameters that is used when object should be split.
Style | Represents the style for a user.
StyleCollection | Collection of Style objects.
TableCell | Represents cell of table.
TableCol | Represents column of table.
TableRow | Represents row of table.
TableSplitParams |
TableVector | Base class for columns and rows of table. One TableVector object can be used in many tables.
TableVectorGroup |
TabPosition | Represents the tab in paragraph of text.
TabPositionCollection | Collection of the TabPosition objects.
Tag | Represents the user-defined tag.
TagBase |
TagCollection | Collection of the Tag objects.
TagPageCount |
TagPageNo |
TagPageX |
TagPageXCount |
TagPageY |
TagPageYCount |
TagSys |
TextResolvedInfo |
TitleResolvedInfo | Represents the resolved information about header/footer in table.
UserCellGroup | Represents the cells group defined by the user. Each cell group is defined by the collection of rectangles.
UserCellGroupCollection | Represents the collection of UserCellGroup objects.
Utils | Contains common functions.

Interfaces

Interface | Description
IC1Printable | This interface should be implemented by a control to support its rendering through RenderC1Printable object in C1PrintDocument.
IDocumentLocation | Describes location within document. Each location is identified by page and rectangle on page. Units or rectangle depend on C1Preview.ResolvedUnit property. This interface implemented by: Page, RenderObject, C1Anchor.

Enumerations

Enumeration | Description
AlignHorzEnum | Defines modes of horizontal alignment of text.
AlignVertEnum | Defines modes of vertical alignment of text.
BreakEnum | Defines the various breaks which can be forced before or after render object.
C1HyperlinkStateEnum | Represents the state of hyperlink.
CellSplitBehaviorEnum | Defines various options for the splitting of content of cells.
CheckMarkStyleEnum | Describes the type of mark which is used in the ScalableCheckBox and RenderInputCheckBoxOptions.
DimensionEnum | Describes the possible dimensions of object.
DocumentActionEnum | Defines the actions which can be used in ActionHandlerPreviewAction object.
DocumentCreationMode |
DocumentInfoFields | Enumerates fields of DocumentInfo.
DrawingFlagsEnum | Defines flags which can be used by object for managing its painting.
FormsKeyActionEnterEnum | Describes the actions to be performed when a ENTER key is pressed in C1PrintPreview control which is connected to the doc engine.
FormsKeyActionTabEnum | Describes the actions to be performed when a TAB key is pressed in C1PrintPreview control which is connected to the doc engine.
GenerateErrorEnum | Represents the codes of possible errors, which can occur when document is being generated.
ImageAlignHorzEnum | Defines modes of horizontal alignment of image.
ImageAlignVertEnum | Defines modes of vertical alignment of image.
PageBreakBehaviorEnum | Defines various options for the insertion of page breaks.
PageDirectionEnum | Describes the direction in which the new page should be started.
PageJumpTypeEnum | Describes the supported modes of moving between pages.
PageNumberingChangeModeEnum | Describes the type of changing of the page numbering.
PageScalingEnum | Specifies the way pages are scaled during printing.
RefDim | Internal, describes the dimensions of object.
ReferenceEnum | Describes the types of references between objects.
ReresolvingModeEnum | Enumerates the situations when reresolving can occurs.
SplitTypeEnum | Specifies the type of split.
StackingRulesEnum | Defines the stacking rules: block flow or inline flow, LeftToRight or TopToBottom
StretchColumnEnum | Defines the modes of stretching of column.
StretchTableEnum | Defines the modes of stretching the columns of table.
TableFooterEnum |
TableHeaderEnum |
TextPositionEnum |
UnicodeRangeEnum | Defines all unicode ranges.
UnitTypeEnum | Specifies the unit of measure for the given data.
UserActionEnum | Identifies a single end-user input action which can be handled by a C1Preview form control.

Structures

Structure | Description
Borders | Describes borders around rectangular area.
GridLines | Describes the lines within of table's area.
ImageAlign | Describes the image alignment.
RectangleD | Stores a set of four double numbers that represent the location and size of a rectangle.
SizeD | Stores an ordered pair of double numbers, typically the width and height of a rectangle.
SplitPos | Describes the split position.
Unit | Auxiliary class, provides access to LengthBase object as string, number or directly LengthBase object.
UnitPoint | Defines a point represented by two Unit structures.

See Also

C1.C1Preview.2 Assembly


ActionHandlerBase Class

ActionHandlerBase Class

Describes an action that can be performed in response to a user action in a C1Preview form. This is an abstract base class for the specific action handlers.

For a list of all members of this type, see ActionHandlerBase Members.

System.Object

C1.C1Preview.ActionHandlerBase

C1.C1Preview.ActionHandlerFile

C1.C1Preview.ActionHandlerHistoryNext

C1.C1Preview.ActionHandlerHistoryPrev

C1.C1Preview.ActionHandlerLink

C1.C1Preview.ActionHandlerPageSetup

C1.C1Preview.ActionHandlerPageView

C1.C1Preview.ActionHandlerPrint

C1.C1Preview.ActionHandlerReflow

[Visual Basic]

MustInherit Public Class ActionHandlerBase

[C#]

public abstract class ActionHandlerBase

[Delphi]

type ActionHandlerBase = class abstract;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

See Also


ActionHandlerBase Members

ActionHandlerBase Members

ActionHandlerBase overview


ActionHandlerFile Class

ActionHandlerFile Class

The base class for action handlers performing an file operation: save, open, and so on.

For a list of all members of this type, see ActionHandlerFile Members.

System.Object

C1.C1Preview.ActionHandlerBase

C1.C1Preview.ActionHandlerFile

C1.C1Preview.ActionHandlerFileOpen

C1.C1Preview.ActionHandlerFileSave

[Visual Basic]

MustInherit Public Class ActionHandlerFile

Inherits ActionHandlerBase

[C#]

public abstract class ActionHandlerFile : ActionHandlerBase

[Delphi]

type ActionHandlerFile = class abstract (ActionHandlerBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ActionHandlerFile Members

ActionHandlerFile Members

ActionHandlerFile overview

Public Properties

FileName

The name of file used in operation.


ActionHandlerFile Properties

ActionHandlerFile Properties

The properties of the ActionHandlerFile class are listed here. For a complete list of ActionHandlerFile class members, see the ActionHandlerFile Members topic.

Public Properties

FileName

The name of file used in operation.


ActionHandlerFile.FileName Property

ActionHandlerFile.FileName Property

The name of file used in operation.

[Visual Basic]

Public Property FileName As String

[C#]

public string FileName {get;set;}

[Delphi]

public property FileName: String read get_FileName write set_FileName;


ActionHandlerFileOpen Class

ActionHandlerFileOpen Class

Describes the action handler that performs the loading of the document from file.

For a list of all members of this type, see ActionHandlerFileOpen Members.

System.Object

C1.C1Preview.ActionHandlerBase

C1.C1Preview.ActionHandlerFile

C1.C1Preview.ActionHandlerFileOpen

[Visual Basic]

Public Class ActionHandlerFileOpen

Inherits ActionHandlerFile

[C#]

public class ActionHandlerFileOpen : ActionHandlerFile

[Delphi]

type ActionHandlerFileOpen = class (ActionHandlerFile);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ActionHandlerFileOpen Members

ActionHandlerFileOpen Members

ActionHandlerFileOpen overview

Public Properties

FileName (inherited from ActionHandlerFile)

The name of file used in operation.


ActionHandlerFileOpen Properties

ActionHandlerFileOpen Properties

The properties of the ActionHandlerFileOpen class are listed here. For a complete list of ActionHandlerFileOpen class members, see the ActionHandlerFileOpen Members topic.

Public Properties

FileName (inherited from ActionHandlerFile)

The name of file used in operation.


ActionHandlerFileSave Class

ActionHandlerFileSave Class

Describes the action handler that performs the saving of the document to file.

For a list of all members of this type, see ActionHandlerFileSave Members.

System.Object

C1.C1Preview.ActionHandlerBase

C1.C1Preview.ActionHandlerFile

C1.C1Preview.ActionHandlerFileSave

[Visual Basic]

Public Class ActionHandlerFileSave

Inherits ActionHandlerFile

[C#]

public class ActionHandlerFileSave : ActionHandlerFile

[Delphi]

type ActionHandlerFileSave = class (ActionHandlerFile);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ActionHandlerFileSave Members

ActionHandlerFileSave Members

ActionHandlerFileSave overview

Public Properties

FileName (inherited from ActionHandlerFile)

The name of file used in operation.


ActionHandlerFileSave Properties

ActionHandlerFileSave Properties

The properties of the ActionHandlerFileSave class are listed here. For a complete list of ActionHandlerFileSave class members, see the ActionHandlerFileSave Members topic.

Public Properties

FileName (inherited from ActionHandlerFile)

The name of file used in operation.


ActionHandlerHistoryNext Class

ActionHandlerHistoryNext Class

Describes the action handler that goes to next history entry.

For a list of all members of this type, see ActionHandlerHistoryNext Members.

System.Object

C1.C1Preview.ActionHandlerBase

C1.C1Preview.ActionHandlerHistoryNext

[Visual Basic]

Public Class ActionHandlerHistoryNext

Inherits ActionHandlerBase

[C#]

public class ActionHandlerHistoryNext : ActionHandlerBase

[Delphi]

type ActionHandlerHistoryNext = class (ActionHandlerBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ActionHandlerHistoryNext Members

ActionHandlerHistoryNext Members

ActionHandlerHistoryNext overview


ActionHandlerHistoryPrev Class

ActionHandlerHistoryPrev Class

Describes the action handler that goes to previous history entry.

For a list of all members of this type, see ActionHandlerHistoryPrev Members.

System.Object

C1.C1Preview.ActionHandlerBase

C1.C1Preview.ActionHandlerHistoryPrev

[Visual Basic]

Public Class ActionHandlerHistoryPrev

Inherits ActionHandlerBase

[C#]

public class ActionHandlerHistoryPrev : ActionHandlerBase

[Delphi]

type ActionHandlerHistoryPrev = class (ActionHandlerBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ActionHandlerHistoryPrev Members

ActionHandlerHistoryPrev Members

ActionHandlerHistoryPrev overview


ActionHandlerLink Class

ActionHandlerLink Class

Describes an action handler that executes a hyperlink jump. All link types which are supported by the C1Preview hyperlinks are also supported by this action handler:
- Jump to an anchor in the existing document.
- Jump to an anchor in another document.
- Open an external program or file.
- Jump to another page of the same document.

For a list of all members of this type, see ActionHandlerLink Members.

System.Object

C1.C1Preview.ActionHandlerBase

C1.C1Preview.ActionHandlerLink

[Visual Basic]

Public Class ActionHandlerLink

Inherits ActionHandlerBase

[C#]

public class ActionHandlerLink : ActionHandlerBase

[Delphi]

type ActionHandlerLink = class (ActionHandlerBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ActionHandlerLink Members

ActionHandlerLink Members

ActionHandlerLink overview

Public Properties

LinkTarget

Gets or sets the link target. See C1LinkTarget for details.


ActionHandlerLink Properties

ActionHandlerLink Properties

The properties of the ActionHandlerLink class are listed here. For a complete list of ActionHandlerLink class members, see the ActionHandlerLink Members topic.

Public Properties

LinkTarget

Gets or sets the link target. See C1LinkTarget for details.


ActionHandlerLink.LinkTarget Property

ActionHandlerLink.LinkTarget Property

Gets or sets the link target. See C1LinkTarget for details.

[Visual Basic]

Public Property LinkTarget As C1LinkTarget

[C#]

public C1LinkTarget LinkTarget {get;set;}

[Delphi]

public property LinkTarget: C1LinkTarget read get_LinkTarget write set_LinkTarget;


ActionHandlerPageSetup Class

ActionHandlerPageSetup Class

Describes the action handler that displays the page setup dialog to change the page properties of document.

For a list of all members of this type, see ActionHandlerPageSetup Members.

System.Object

C1.C1Preview.ActionHandlerBase

C1.C1Preview.ActionHandlerPageSetup

[Visual Basic]

Public Class ActionHandlerPageSetup

Inherits ActionHandlerBase

[C#]

public class ActionHandlerPageSetup : ActionHandlerBase

[Delphi]

type ActionHandlerPageSetup = class (ActionHandlerBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ActionHandlerPageSetup Members

ActionHandlerPageSetup Members

ActionHandlerPageSetup overview


ActionHandlerPageView Class

ActionHandlerPageView Class

Describes the action handler that changes the view of document in the preview window.

For a list of all members of this type, see ActionHandlerPageView Members.

System.Object

C1.C1Preview.ActionHandlerBase

C1.C1Preview.ActionHandlerPageView

[Visual Basic]

Public Class ActionHandlerPageView

Inherits ActionHandlerBase

[C#]

public class ActionHandlerPageView : ActionHandlerBase

[Delphi]

type ActionHandlerPageView = class (ActionHandlerBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ActionHandlerPageView Members

ActionHandlerPageView Members

ActionHandlerPageView overview


ActionHandlerPrint Class

ActionHandlerPrint Class

Describes the action handler that prints the document.

For a list of all members of this type, see ActionHandlerPrint Members.

System.Object

C1.C1Preview.ActionHandlerBase

C1.C1Preview.ActionHandlerPrint

[Visual Basic]

Public Class ActionHandlerPrint

Inherits ActionHandlerBase

[C#]

public class ActionHandlerPrint : ActionHandlerBase

[Delphi]

type ActionHandlerPrint = class (ActionHandlerBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ActionHandlerPrint Members

ActionHandlerPrint Members

ActionHandlerPrint overview

Public Properties

PrinterName

The name of printer, if empty the dialog will be displayed to select a printer.


ActionHandlerPrint Properties

ActionHandlerPrint Properties

The properties of the ActionHandlerPrint class are listed here. For a complete list of ActionHandlerPrint class members, see the ActionHandlerPrint Members topic.

Public Properties

PrinterName

The name of printer, if empty the dialog will be displayed to select a printer.


ActionHandlerPrint.PrinterName Property

ActionHandlerPrint.PrinterName Property

The name of printer, if empty the dialog will be displayed to select a printer.

[Visual Basic]

Public Property PrinterName As String

[C#]

public string PrinterName {get;set;}

[Delphi]

public property PrinterName: String read get_PrinterName write set_PrinterName;


ActionHandlerReflow Class

ActionHandlerReflow Class

Describes the action handler that reflows the document.

For a list of all members of this type, see ActionHandlerReflow Members.

System.Object

C1.C1Preview.ActionHandlerBase

C1.C1Preview.ActionHandlerReflow

[Visual Basic]

Public Class ActionHandlerReflow

Inherits ActionHandlerBase

[C#]

public class ActionHandlerReflow : ActionHandlerBase

[Delphi]

type ActionHandlerReflow = class (ActionHandlerBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ActionHandlerReflow Members

ActionHandlerReflow Members

ActionHandlerReflow overview


AlignHorzEnum Enumeration

AlignHorzEnum Enumeration

Defines modes of horizontal alignment of text.

[Visual Basic]

Public Enum AlignHorzEnum

[C#]

public enum AlignHorzEnum

[Delphi]

type AlignHorzEnum = (Center, Justify, Left, Right);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
Center |
Justify |
Left |
Right |

See Also

C1.C1Preview Namespace


AlignVertEnum Enumeration

AlignVertEnum Enumeration

Defines modes of vertical alignment of text.

[Visual Basic]

Public Enum AlignVertEnum

[C#]

public enum AlignVertEnum

[Delphi]

type AlignVertEnum = (Bottom, Center, Justify, Top);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
Bottom |
Center |
Justify |
Top |

See Also

C1.C1Preview Namespace


AreaResolvedInfo Class

AreaResolvedInfo Class

For a list of all members of this type, see AreaResolvedInfo Members.

System.Object

C1.C1Preview.FragmentResolvedInfo

C1.C1Preview.AreaResolvedInfo

[Visual Basic]

Public Class AreaResolvedInfo

Inherits FragmentResolvedInfo

[C#]

public class AreaResolvedInfo : FragmentResolvedInfo

[Delphi]

type AreaResolvedInfo = class (FragmentResolvedInfo);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


AreaResolvedInfo Members

AreaResolvedInfo Members

AreaResolvedInfo overview

Public Properties

AvailHeight (inherited from FragmentResolvedInfo) | Returns the distance between Top and LeftTopPageArea.Bottom.
AvailWidth (inherited from FragmentResolvedInfo) | Returns the distance between Left and LeftTopPageArea.Right.
BottomOffset (inherited from FragmentResolvedInfo) | Returns a sum of Padding.Bottom, Spacing.Bottom, Borders.Bottom
IsAutoLeft (inherited from FragmentResolvedInfo) | Indicates that the Left coordinate of object was calculated as auto.
IsAutoPos (inherited from FragmentResolvedInfo) | Indicates that the Left-top position of object was calculated as auto.
IsAutoTop (inherited from FragmentResolvedInfo) | Indicates that the Top coordinate of object was calculated as auto.
LeftOffset (inherited from FragmentResolvedInfo) | Returns a sum of Padding.Left, Spacing.Left, Borders.Left
RightOffset (inherited from FragmentResolvedInfo) | Returns a sum of Padding.Right, Spacing.Right, Borders.Right
TopOffset (inherited from FragmentResolvedInfo) | Returns a sum of Padding.Top, Spacing.Top, Borders.Top


AreaResolvedInfo Properties

AreaResolvedInfo Properties

The properties of the AreaResolvedInfo class are listed here. For a complete list of AreaResolvedInfo class members, see the AreaResolvedInfo Members topic.

Public Properties

AvailHeight (inherited from FragmentResolvedInfo) | Returns the distance between Top and LeftTopPageArea.Bottom.
AvailWidth (inherited from FragmentResolvedInfo) | Returns the distance between Left and LeftTopPageArea.Right.
BottomOffset (inherited from FragmentResolvedInfo) | Returns a sum of Padding.Bottom, Spacing.Bottom, Borders.Bottom
IsAutoLeft (inherited from FragmentResolvedInfo) | Indicates that the Left coordinate of object was calculated as auto.
IsAutoPos (inherited from FragmentResolvedInfo) | Indicates that the Left-top position of object was calculated as auto.
IsAutoTop (inherited from FragmentResolvedInfo) | Indicates that the Top coordinate of object was calculated as auto.
LeftOffset (inherited from FragmentResolvedInfo) | Returns a sum of Padding.Left, Spacing.Left, Borders.Left
RightOffset (inherited from FragmentResolvedInfo) | Returns a sum of Padding.Right, Spacing.Right, Borders.Right
TopOffset (inherited from FragmentResolvedInfo) | Returns a sum of Padding.Top, Spacing.Top, Borders.Top


Borders Structure

Borders Structure

Describes borders around rectangular area.

For a list of all members of this type, see Borders Members.

System.Object

System.ValueType

C1.C1Preview.Borders

[Visual Basic]

Public Structure Borders

[C#]

public struct Borders

[Delphi]

type Borders = record;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


Borders Members

Borders Members

Borders overview

Public Properties

All | Sets the border for all edges of an object.
Bottom | Gets or sets bottom border.
Left | Gets or sets left border.
Right | Gets or sets right border.
Top | Gets or sets top border.


Borders Properties

Borders Properties

The properties of the Borders structure are listed here. For a complete list of Borders structure members, see the Borders Members topic.

All | Sets the border for all edges of an object.
Bottom | Gets or sets bottom border.
Left | Gets or sets left border.
Right | Gets or sets right border.
Top | Gets or sets top border.


Borders.All Property

Borders.All Property

Sets the border for all edges of an object.

[Visual Basic]

Overridable Public WriteOnly Property All As LineDef

[C#]

virtual public LineDef All {set;}

[Delphi]

public property All: LineDef write set_All;


Borders.Bottom Property

Borders.Bottom Property

Gets or sets bottom border.

[Visual Basic]

Overridable Public Property Bottom As LineDef

[C#]

virtual public LineDef Bottom {get;set;}

[Delphi]

public property Bottom: LineDef read get_Bottom write set_Bottom;


Borders.Left Property

Borders.Left Property

Gets or sets left border.

[Visual Basic]

Overridable Public Property Left As LineDef

[C#]

virtual public LineDef Left {get;set;}

[Delphi]

public property Left: LineDef read get_Left write set_Left;


Borders.Right Property

Borders.Right Property

Gets or sets right border.

[Visual Basic]

Overridable Public Property Right As LineDef

[C#]

virtual public LineDef Right {get;set;}

[Delphi]

public property Right: LineDef read get_Right write set_Right;


Borders.Top Property

Borders.Top Property

Gets or sets top border.

[Visual Basic]

Overridable Public Property Top As LineDef

[C#]

virtual public LineDef Top {get;set;}

[Delphi]

public property Top: LineDef read get_Top write set_Top;


BreakEnum Enumeration

BreakEnum Enumeration

Defines the various breaks which can be forced before or after render object.

[Visual Basic]

Public Enum BreakEnum

[C#]

public enum BreakEnum

[Delphi]

type BreakEnum = (Column, Line, None, Page);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
Column | New column should be started.
Line | New line on inline flow should be started.
None | No break.
Page | New page should be started.

See Also

C1.C1Preview Namespace


C1Anchor Class

C1Anchor Class

Represents the anchor within document, this anchor can be associated with any RenderObject.

For a list of all members of this type, see C1Anchor Members.

System.Object

C1.C1Preview.C1Anchor

C1.C1Preview.C1AnchorText

[Visual Basic]

Public Class C1Anchor

[C#]

public class C1Anchor

[Delphi]

type C1Anchor = class;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


C1Anchor Members

C1Anchor Members

C1Anchor overview

Public Properties

Description | Gets the description of anchor.
Name | Gets the name of anchor must be unique within document.
UserData | Gets the custom user's data associated with anchor.


C1Anchor Properties

C1Anchor Properties

The properties of the C1Anchor class are listed here. For a complete list of C1Anchor class members, see the C1Anchor Members topic.

Public Properties

Description | Gets the description of anchor.
Name | Gets the name of anchor must be unique within document.
UserData | Gets the custom user's data associated with anchor.


C1Anchor.Description Property

C1Anchor.Description Property

Gets the description of anchor.

[Visual Basic]

Public ReadOnly Property Description As String

[C#]

public string Description {get;}

[Delphi]

public property Description: String read get_Description;


C1Anchor.Name Property

C1Anchor.Name Property

Gets the name of anchor must be unique within document.

[Visual Basic]

Public ReadOnly Property Name As String

[C#]

public string Name {get;}

[Delphi]

public property Name: String read get_Name;


C1Anchor.UserData Property

C1Anchor.UserData Property

Gets the custom user's data associated with anchor.

[Visual Basic]

Public ReadOnly Property UserData As Object

[C#]

public object UserData {get;}

[Delphi]

public property UserData: Object read get_UserData;


C1AnchorCollection Class

C1AnchorCollection Class

Collection of C1Anchor objects.

For a list of all members of this type, see C1AnchorCollection Members.

System.Object

System.Collections.CollectionBase

C1.C1Preview.C1AnchorCollection

[Visual Basic]

Public Class C1AnchorCollection

Inherits CollectionBase

[C#]

public class C1AnchorCollection : CollectionBase

[Delphi]

type C1AnchorCollection = class (CollectionBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


C1AnchorCollection Members

C1AnchorCollection Members

C1AnchorCollection overview


C1AnchorInfo Class

C1AnchorInfo Class

Auxiliary class, contains additional information about anchor within document.

For a list of all members of this type, see C1AnchorInfo Members.

System.Object

C1.C1Preview.C1AnchorInfo

[Visual Basic]

Public Class C1AnchorInfo

[C#]

public class C1AnchorInfo

[Delphi]

type C1AnchorInfo = class;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


C1AnchorInfo Members

C1AnchorInfo Members

C1AnchorInfo overview

Public Properties

Anchor | Gets the C1Anchor object.
PageIndex | Gets the index of page where anchor is.
Point | Gets the position of anchor.


C1AnchorInfo Properties

C1AnchorInfo Properties

The properties of the C1AnchorInfo class are listed here. For a complete list of C1AnchorInfo class members, see the C1AnchorInfo Members topic.

Public Properties

Anchor | Gets the C1Anchor object.
PageIndex | Gets the index of page where anchor is.
Point | Gets the position of anchor.


C1AnchorInfo.Anchor Property

C1AnchorInfo.Anchor Property

Gets the C1Anchor object.

[Visual Basic]

Public ReadOnly Property Anchor As C1Anchor

[C#]

public C1Anchor Anchor {get;}

[Delphi]

public property Anchor: C1Anchor read get_Anchor;


C1AnchorInfo.PageIndex Property

C1AnchorInfo.PageIndex Property

Gets the index of page where anchor is.

[Visual Basic]

Public ReadOnly Property PageIndex As Int32*

[C#]

public Int32* PageIndex {get;}

[Delphi]

public property PageIndex: Int32* read get_PageIndex;


C1AnchorInfo.Point Property

C1AnchorInfo.Point Property

Gets the position of anchor.

[Visual Basic]

Public Property Point As PointD

[C#]

public PointD Point {get;set;}

[Delphi]

public property Point: PointD read get_Point write set_Point;


C1AnchorInfoCollection Class

C1AnchorInfoCollection Class

Collection of the C1AnchorInfo objects.

For a list of all members of this type, see C1AnchorInfoCollection Members.

System.Object

System.Collections.CollectionBase

C1.C1Preview.C1AnchorInfoCollection

[Visual Basic]

Public Class C1AnchorInfoCollection

Inherits CollectionBase

[C#]

public class C1AnchorInfoCollection : CollectionBase

[Delphi]

type C1AnchorInfoCollection = class (CollectionBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


C1AnchorInfoCollection Members

C1AnchorInfoCollection Members

C1AnchorInfoCollection overview


C1AnchorText Class

C1AnchorText Class

Represents the anchor within text object: RenderText, RenderParagraph, RenderRichText.

For a list of all members of this type, see C1AnchorText Members.

System.Object

C1.C1Preview.C1Anchor

C1.C1Preview.C1AnchorText

[Visual Basic]

Public Class C1AnchorText

Inherits C1Anchor

[C#]

public class C1AnchorText : C1Anchor

[Delphi]

type C1AnchorText = class (C1Anchor);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


C1AnchorText Members

C1AnchorText Members

C1AnchorText overview

Public Properties

Description (inherited from C1Anchor) | Gets the description of anchor.
Name (inherited from C1Anchor) | Gets the name of anchor must be unique within document.
Position | Gets the position of anchor within text, zero based.
UserData (inherited from C1Anchor) | Gets the custom user's data associated with anchor.


C1AnchorText Properties

C1AnchorText Properties

The properties of the C1AnchorText class are listed here. For a complete list of C1AnchorText class members, see the C1AnchorText Members topic.

Public Properties

Description (inherited from C1Anchor) | Gets the description of anchor.
Name (inherited from C1Anchor) | Gets the name of anchor must be unique within document.
Position | Gets the position of anchor within text, zero based.
UserData (inherited from C1Anchor) | Gets the custom user's data associated with anchor.


C1AnchorText.Position Property

C1AnchorText.Position Property

Gets the position of anchor within text, zero based.

[Visual Basic]

Public ReadOnly Property Position As Int32*

[C#]

public Int32* Position {get;}

[Delphi]

public property Position: Int32* read get_Position;


C1Hyperlink Class

C1Hyperlink Class

Represents the hyperlink in document, can be associated with RenderObject or ParagraphObject.

For a list of all members of this type, see C1Hyperlink Members.

System.Object

C1.C1Preview.C1Hyperlink

[Visual Basic]

Public Class C1Hyperlink

Implements ICloneable

[C#]

public class C1Hyperlink : ICloneable

[Delphi]

type C1Hyperlink = class (TObject, ICloneable);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


C1Hyperlink Members

C1Hyperlink Members

C1Hyperlink overview

Public Properties

LinkTarget | Determines where the hyperlink points to. Currently the target may be described by an object of one of the following classes: C1LinkTargetAnchor - anchor inside the current document. C1LinkTargetExternalAnchor - anchor inside a previously saved C1D document. C1LinkTargetFile - external document, program or URL (the ShellExecute API is used to invoke the link). C1LinkTargetPage - another page inside the current document.
PdfURL | Gets the destination URL of hyperlink in the Adobe PDF format.
State | The hyperlink's status.
StatusText | Text shown in the status line when the mouse is over the link (when the document is previewed by C1PrintPreview).
UserData | Arbitrary data associated with the hyperlink.


C1Hyperlink Properties

C1Hyperlink Properties

The properties of the C1Hyperlink class are listed here. For a complete list of C1Hyperlink class members, see the C1Hyperlink Members topic.

Public Properties

LinkTarget | Determines where the hyperlink points to. Currently the target may be described by an object of one of the following classes: C1LinkTargetAnchor - anchor inside the current document. C1LinkTargetExternalAnchor - anchor inside a previously saved C1D document. C1LinkTargetFile - external document, program or URL (the ShellExecute API is used to invoke the link). C1LinkTargetPage - another page inside the current document.
PdfURL | Gets the destination URL of hyperlink in the Adobe PDF format.
State | The hyperlink's status.
StatusText | Text shown in the status line when the mouse is over the link (when the document is previewed by C1PrintPreview).
UserData | Arbitrary data associated with the hyperlink.


C1Hyperlink.LinkTarget Property

C1Hyperlink.LinkTarget Property

Determines where the hyperlink points to. Currently the target may be described by an object of one of the following classes:
C1LinkTargetAnchor - anchor inside the current document.
C1LinkTargetExternalAnchor - anchor inside a previously saved C1D document.
C1LinkTargetFile - external document, program or URL (the ShellExecute API is used to invoke the link).
C1LinkTargetPage - another page inside the current document.

[Visual Basic]

Public Property LinkTarget As C1LinkTarget

[C#]

public C1LinkTarget LinkTarget {get;set;}

[Delphi]

public property LinkTarget: C1LinkTarget read get_LinkTarget write set_LinkTarget;


C1Hyperlink.PdfURL Property

C1Hyperlink.PdfURL Property

Gets the destination URL of hyperlink in the Adobe PDF format.

[Visual Basic]

Public ReadOnly Property PdfURL As String

[C#]

public string PdfURL {get;}

[Delphi]

public property PdfURL: String read get_PdfURL;


C1Hyperlink.State Property

C1Hyperlink.State Property

The hyperlink's status.

[Visual Basic]

Public Property State As C1HyperlinkStateEnum

[C#]

public C1HyperlinkStateEnum State {get;set;}

[Delphi]

public property State: C1HyperlinkStateEnum read get_State write set_State;


C1Hyperlink.StatusText Property

C1Hyperlink.StatusText Property

Text shown in the status line when the mouse is over the link (when the document is previewed by C1PrintPreview).

[Visual Basic]

Public Property StatusText As String

[C#]

public string StatusText {get;set;}

[Delphi]

public property StatusText: String read get_StatusText write set_StatusText;


C1Hyperlink.UserData Property

C1Hyperlink.UserData Property

Arbitrary data associated with the hyperlink.

[Visual Basic]

Public Property UserData As Object

[C#]

public object UserData {get;set;}

[Delphi]

public property UserData: Object read get_UserData write set_UserData;


C1HyperlinkAttrs Class

C1HyperlinkAttrs Class

The visual style of hyperlink.

For a list of all members of this type, see C1HyperlinkAttrs Members.

System.Object

C1.C1Preview.C1HyperlinkAttrs

C1.C1Preview.C1HyperlinkTextAttrs

[Visual Basic]

MustInherit Public Class C1HyperlinkAttrs

[C#]

public abstract class C1HyperlinkAttrs

[Delphi]

type C1HyperlinkAttrs = class abstract;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


C1HyperlinkAttrs Members

C1HyperlinkAttrs Members

C1HyperlinkAttrs overview


C1HyperlinkInfo Class

C1HyperlinkInfo Class

Auxiliary class, contains additional information about hyperlink: list of pages where hyperlink exists and area of hyperlink within each page.

For a list of all members of this type, see C1HyperlinkInfo Members.

System.Object

C1.C1Preview.C1HyperlinkInfo

[Visual Basic]

Public Class C1HyperlinkInfo

[C#]

public class C1HyperlinkInfo

[Delphi]

type C1HyperlinkInfo = class;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


C1HyperlinkInfo Members

C1HyperlinkInfo Members

C1HyperlinkInfo overview

Public Properties

Areas | Gets the AreaCollection object containing the hyperlink's areas on render fragments. Typically this collection contains one element, but if hyperlink splits between pages it contains one element for each page.
Hyperlink | Gets the C1Hyperlink object.


C1HyperlinkInfo Properties

C1HyperlinkInfo Properties

The properties of the C1HyperlinkInfo class are listed here. For a complete list of C1HyperlinkInfo class members, see the C1HyperlinkInfo Members topic.

Public Properties

Areas | Gets the AreaCollection object containing the hyperlink's areas on render fragments. Typically this collection contains one element, but if hyperlink splits between pages it contains one element for each page.
Hyperlink | Gets the C1Hyperlink object.


C1HyperlinkInfo.Areas Property

C1HyperlinkInfo.Areas Property

Gets the AreaCollection object containing the hyperlink's areas on render fragments. Typically this collection contains one element, but if hyperlink splits between pages it contains one element for each page.

[Visual Basic]

Public ReadOnly Property Areas As C1HyperlinkInfo+AreaCollection

[C#]

public C1HyperlinkInfo+AreaCollection Areas {get;}

[Delphi]

public property Areas: C1HyperlinkInfo+AreaCollection read get_Areas;


C1HyperlinkInfo.Hyperlink Property

C1HyperlinkInfo.Hyperlink Property

Gets the C1Hyperlink object.

[Visual Basic]

Public ReadOnly Property Hyperlink As C1Hyperlink

[C#]

public C1Hyperlink Hyperlink {get;}

[Delphi]

public property Hyperlink: C1Hyperlink read get_Hyperlink;


C1HyperlinkInfo.Area Class

C1HyperlinkInfo.Area Class

Describes the position of hyperlink within page.

For a list of all members of this type, see C1HyperlinkInfo.Area Members.

System.Object

C1.C1Preview.C1HyperlinkInfo.Area

[Visual Basic]

Public Class C1HyperlinkInfo.Area

Implements IDisposable

[C#]

public class C1HyperlinkInfo.Area : IDisposable

[Delphi]

type C1HyperlinkInfo.Area = class (TObject, IDisposable);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


C1HyperlinkInfo.Area Members

C1HyperlinkInfo.Area Members

C1HyperlinkInfo.Area overview

Public Properties

PageIndex | Gets the index of page where hyperlink is.
Region | Gets the region of hyperlink.


C1HyperlinkInfo.Area Properties

C1HyperlinkInfo.Area Properties

The properties of the C1HyperlinkInfo.Area class are listed here. For a complete list of C1HyperlinkInfo.Area class members, see the C1HyperlinkInfo+Area Members topic.

Public Properties

PageIndex | Gets the index of page where hyperlink is.
Region | Gets the region of hyperlink.


C1HyperlinkInfo.Area.PageIndex Property

C1HyperlinkInfo.Area.PageIndex Property

Gets the index of page where hyperlink is.

[Visual Basic]

Public ReadOnly Property PageIndex As Int32*

[C#]

public Int32* PageIndex {get;}

[Delphi]

public property PageIndex: Int32* read get_PageIndex;


C1HyperlinkInfo.Area.Region Property

C1HyperlinkInfo.Area.Region Property

Gets the region of hyperlink.

[Visual Basic]

Public ReadOnly Property Region As Region

[C#]

public Region Region {get;}

[Delphi]

public property Region: Region read get_Region;


C1HyperlinkInfo.AreaCollection Class

C1HyperlinkInfo.AreaCollection Class

Collection of Area objects.

For a list of all members of this type, see C1HyperlinkInfo.AreaCollection Members.

System.Object

System.Collections.CollectionBase

C1.C1Preview.C1HyperlinkInfo.AreaCollection

[Visual Basic]

Public Class C1HyperlinkInfo.AreaCollection

Inherits CollectionBase

[C#]

public class C1HyperlinkInfo.AreaCollection : CollectionBase

[Delphi]

type C1HyperlinkInfo.AreaCollection = class (CollectionBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


C1HyperlinkInfo.AreaCollection Members

C1HyperlinkInfo.AreaCollection Members

C1HyperlinkInfo.AreaCollection overview


C1HyperlinkInfoCollection Class

C1HyperlinkInfoCollection Class

Collection of the C1HyperlinkInfo objects.

For a list of all members of this type, see C1HyperlinkInfoCollection Members.

System.Object

System.Collections.CollectionBase

C1.C1Preview.C1HyperlinkInfoCollection

[Visual Basic]

Public Class C1HyperlinkInfoCollection

Inherits CollectionBase

[C#]

public class C1HyperlinkInfoCollection : CollectionBase

[Delphi]

type C1HyperlinkInfoCollection = class (CollectionBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


C1HyperlinkInfoCollection Members

C1HyperlinkInfoCollection Members

C1HyperlinkInfoCollection overview


C1HyperlinkStateEnum Enumeration

C1HyperlinkStateEnum Enumeration

Represents the state of hyperlink.

[Visual Basic]

Public Enum C1HyperlinkStateEnum

[C#]

public enum C1HyperlinkStateEnum

[Delphi]

type C1HyperlinkStateEnum = (Active, Hover, Normal, Visited);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
Active |
Hover |
Normal |
Visited |

See Also

C1.C1Preview Namespace


C1HyperlinkTextAttrs Class

C1HyperlinkTextAttrs Class

Determines the attributes used to highlight a hyperlink inside a text.

For a list of all members of this type, see C1HyperlinkTextAttrs Members.

System.Object

C1.C1Preview.C1HyperlinkAttrs

C1.C1Preview.C1HyperlinkTextAttrs

[Visual Basic]

Public Class C1HyperlinkTextAttrs

Inherits C1HyperlinkAttrs

[C#]

public class C1HyperlinkTextAttrs : C1HyperlinkAttrs

[Delphi]

type C1HyperlinkTextAttrs = class (C1HyperlinkAttrs);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


C1HyperlinkTextAttrs Members

C1HyperlinkTextAttrs Members

C1HyperlinkTextAttrs overview

Public Properties

BackColor | The background color. If the value is Color.Empty or Color.Transparent, the hyperlinks background color is not changed.
ForeColor | The foreground (text) color. If the value is Color.Empty or Color.Transparent, the hyperlinks text color is not changed.
HoverDefault | Gets the default attributes of highlighted hyperlinks.
NormalDefault | Gets the default attributes of "normal" (not visited and not highlighted) hyperlinks.
Underline | If the value is True, the hyperlinks text is underlined.
VisitedDefault | Gets the default attributes of visited hyperlinks.


C1HyperlinkTextAttrs Properties

C1HyperlinkTextAttrs Properties

The properties of the C1HyperlinkTextAttrs class are listed here. For a complete list of C1HyperlinkTextAttrs class members, see the C1HyperlinkTextAttrs Members topic.

Public Properties

BackColor | The background color. If the value is Color.Empty or Color.Transparent, the hyperlinks background color is not changed.
ForeColor | The foreground (text) color. If the value is Color.Empty or Color.Transparent, the hyperlinks text color is not changed.
HoverDefault | Gets the default attributes of highlighted hyperlinks.
NormalDefault | Gets the default attributes of "normal" (not visited and not highlighted) hyperlinks.
Underline | If the value is True, the hyperlinks text is underlined.
VisitedDefault | Gets the default attributes of visited hyperlinks.


C1HyperlinkTextAttrs.BackColor Property

C1HyperlinkTextAttrs.BackColor Property

The background color. If the value is Color.Empty or Color.Transparent, the hyperlinks background color is not changed.

[Visual Basic]

Public ReadOnly Property BackColor As Color

[C#]

public Color BackColor {get;}

[Delphi]

public property BackColor: Color read get_BackColor;


C1HyperlinkTextAttrs.ForeColor Property

C1HyperlinkTextAttrs.ForeColor Property

The foreground (text) color. If the value is Color.Empty or Color.Transparent, the hyperlinks text color is not changed.

[Visual Basic]

Public ReadOnly Property ForeColor As Color

[C#]

public Color ForeColor {get;}

[Delphi]

public property ForeColor: Color read get_ForeColor;


C1HyperlinkTextAttrs.HoverDefault Property

C1HyperlinkTextAttrs.HoverDefault Property

Gets the default attributes of highlighted hyperlinks.

[Visual Basic]

Public Shared ReadOnly Property HoverDefault As C1HyperlinkTextAttrs

[C#]

public static C1HyperlinkTextAttrs HoverDefault {get;}

[Delphi]

public class property HoverDefault: C1HyperlinkTextAttrs read get_HoverDefault;


C1HyperlinkTextAttrs.NormalDefault Property

C1HyperlinkTextAttrs.NormalDefault Property

Gets the default attributes of "normal" (not visited and not highlighted) hyperlinks.

[Visual Basic]

Public Shared ReadOnly Property NormalDefault As C1HyperlinkTextAttrs

[C#]

public static C1HyperlinkTextAttrs NormalDefault {get;}

[Delphi]

public class property NormalDefault: C1HyperlinkTextAttrs read get_NormalDefault;


C1HyperlinkTextAttrs.Underline Property

C1HyperlinkTextAttrs.Underline Property

If the value is True, the hyperlinks text is underlined.

[Visual Basic]

Public ReadOnly Property Underline As Boolean

[C#]

public bool Underline {get;}

[Delphi]

public property Underline: Boolean read get_Underline;


C1HyperlinkTextAttrs.VisitedDefault Property

C1HyperlinkTextAttrs.VisitedDefault Property

Gets the default attributes of visited hyperlinks.

[Visual Basic]

Public Shared ReadOnly Property VisitedDefault As C1HyperlinkTextAttrs

[C#]

public static C1HyperlinkTextAttrs VisitedDefault {get;}

[Delphi]

public class property VisitedDefault: C1HyperlinkTextAttrs read get_VisitedDefault;


C1LinkTarget Class

C1LinkTarget Class

Determines the target of the hyperlink. This is an abstract class, it cannot be used directly.

For a list of all members of this type, see C1LinkTarget Members.

System.Object

C1.C1Preview.C1LinkTarget

C1.C1Preview.C1LinkTargetAnchor

C1.C1Preview.C1LinkTargetDocumentLocation

C1.C1Preview.C1LinkTargetFile

C1.C1Preview.C1LinkTargetPage

C1.C1Preview.C1LinkTargetUser

[Visual Basic]

MustInherit Public Class C1LinkTarget

[C#]

public abstract class C1LinkTarget

[Delphi]

type C1LinkTarget = class abstract;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


C1LinkTarget Members

C1LinkTarget Members

C1LinkTarget overview

Public Methods

GetPageNoCaption

Returns the number of document's page that is pointed by this RenderTocItem object. This function may returns null if the page number can't be resolved at current stage (for example when the document is not generated).


C1LinkTarget Methods

C1LinkTarget Methods

The methods of the C1LinkTarget class are listed here. For a complete list of C1LinkTarget class members, see the C1LinkTarget Members topic.

Public Methods

GetPageNoCaption

Returns the number of document's page that is pointed by this RenderTocItem object. This function may returns null if the page number can't be resolved at current stage (for example when the document is not generated).


C1LinkTarget.GetPageNoCaption Method

C1LinkTarget.GetPageNoCaption Method

Returns the number of document's page that is pointed by this RenderTocItem object. This function may returns null if the page number can't be resolved at current stage (for example when the document is not generated).

[Visual Basic]

Overridable Public Function GetPageNoCaption( _

ByVal currentPage As Page, _

ByVal document As C1PrintDocument _

) As String

[C#]

virtual public string GetPageNoCaption(

Page currentPage,

C1PrintDocument document

);

[Delphi]

public function GetPageNoCaption(

currentPage: Page;

document: C1PrintDocument

): String; virtual;

Parameters

currentPage

The page object containing an object with this C1LinkTarget object.

document

The C1PrintDocument object containing this C1LinkTarget object.


C1LinkTargetAnchor Class

C1LinkTargetAnchor Class

Describes a link target inside the current document.

For a list of all members of this type, see C1LinkTargetAnchor Members.

System.Object

C1.C1Preview.C1LinkTarget

C1.C1Preview.C1LinkTargetAnchor

C1.C1Preview.C1LinkTargetExternalAnchor

[Visual Basic]

Public Class C1LinkTargetAnchor

Inherits C1LinkTarget

[C#]

public class C1LinkTargetAnchor : C1LinkTarget

[Delphi]

type C1LinkTargetAnchor = class (C1LinkTarget);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


C1LinkTargetAnchor Members

C1LinkTargetAnchor Members

C1LinkTargetAnchor overview

Public Properties

AnchorName

The name of the C1Anchor object.


C1LinkTargetAnchor Properties

C1LinkTargetAnchor Properties

The properties of the C1LinkTargetAnchor class are listed here. For a complete list of C1LinkTargetAnchor class members, see the C1LinkTargetAnchor Members topic.

Public Properties

AnchorName

The name of the C1Anchor object.


C1LinkTargetAnchor.AnchorName Property

C1LinkTargetAnchor.AnchorName Property

The name of the C1Anchor object.

[Visual Basic]

Public ReadOnly Property AnchorName As String

[C#]

public string AnchorName {get;}

[Delphi]

public property AnchorName: String read get_AnchorName;


C1LinkTargetDocumentLocation Class

C1LinkTargetDocumentLocation Class

This class defines a link target to object within document supporting the IDocumentLocation interface, currently this document is supported by the: RenderObject, Page.

For a list of all members of this type, see C1LinkTargetDocumentLocation Members.

System.Object

C1.C1Preview.C1LinkTarget

C1.C1Preview.C1LinkTargetDocumentLocation

[Visual Basic]

Public Class C1LinkTargetDocumentLocation

Inherits C1LinkTarget

[C#]

public class C1LinkTargetDocumentLocation : C1LinkTarget

[Delphi]

type C1LinkTargetDocumentLocation = class (C1LinkTarget);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


C1LinkTargetDocumentLocation Members

C1LinkTargetDocumentLocation Members

C1LinkTargetDocumentLocation overview

Public Properties

DocumentLocation

Gets the IDocumentLocation object identifying the place within document.


C1LinkTargetDocumentLocation Properties

C1LinkTargetDocumentLocation Properties

The properties of the C1LinkTargetDocumentLocation class are listed here. For a complete list of C1LinkTargetDocumentLocation class members, see the C1LinkTargetDocumentLocation Members topic.

Public Properties

DocumentLocation

Gets the IDocumentLocation object identifying the place within document.


C1LinkTargetDocumentLocation.DocumentLocation Property

C1LinkTargetDocumentLocation.DocumentLocation Property

Gets the IDocumentLocation object identifying the place within document.

[Visual Basic]

Public ReadOnly Property DocumentLocation As IDocumentLocation

[C#]

public IDocumentLocation DocumentLocation {get;}

[Delphi]

public property DocumentLocation: IDocumentLocation read get_DocumentLocation;


C1LinkTargetExternalAnchor Class

C1LinkTargetExternalAnchor Class

Jump to anchor within external C1Preview document.

For a list of all members of this type, see C1LinkTargetExternalAnchor Members.

System.Object

C1.C1Preview.C1LinkTarget

C1.C1Preview.C1LinkTargetAnchor

C1.C1Preview.C1LinkTargetExternalAnchor

[Visual Basic]

Public Class C1LinkTargetExternalAnchor

Inherits C1LinkTargetAnchor

[C#]

public class C1LinkTargetExternalAnchor : C1LinkTargetAnchor

[Delphi]

type C1LinkTargetExternalAnchor = class (C1LinkTargetAnchor);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


C1LinkTargetExternalAnchor Members

C1LinkTargetExternalAnchor Members

C1LinkTargetExternalAnchor overview

Public Properties

AnchorName (inherited from C1LinkTargetAnchor) | The name of the C1Anchor object.
DocumentFileName | Gets the name of file of external C1Preview document.


C1LinkTargetExternalAnchor Properties

C1LinkTargetExternalAnchor Properties

The properties of the C1LinkTargetExternalAnchor class are listed here. For a complete list of C1LinkTargetExternalAnchor class members, see the C1LinkTargetExternalAnchor Members topic.

Public Properties

AnchorName (inherited from C1LinkTargetAnchor) | The name of the C1Anchor object.
DocumentFileName | Gets the name of file of external C1Preview document.


C1LinkTargetExternalAnchor.DocumentFileName Property

C1LinkTargetExternalAnchor.DocumentFileName Property

Gets the name of file of external C1Preview document.

[Visual Basic]

Public ReadOnly Property DocumentFileName As String

[C#]

public string DocumentFileName {get;}

[Delphi]

public property DocumentFileName: String read get_DocumentFileName;


C1LinkTargetFile Class

C1LinkTargetFile Class

Describes a link to an external document, file or URL. The link is performed using the ShellExecute() API.

For a list of all members of this type, see C1LinkTargetFile Members.

System.Object

C1.C1Preview.C1LinkTarget

C1.C1Preview.C1LinkTargetFile

[Visual Basic]

Public Class C1LinkTargetFile

Inherits C1LinkTarget

[C#]

public class C1LinkTargetFile : C1LinkTarget

[Delphi]

type C1LinkTargetFile = class (C1LinkTarget);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


C1LinkTargetFile Members

C1LinkTargetFile Members

C1LinkTargetFile overview

Public Properties

Command | String, referred to in this case as a verb, that specifies the action to be performed.
Directory | String that specifies the default directory.
FileName | Specifies the file or object on which to execute the specified verb.
Parameters | If the FileName parameter specifies an executable file, Parameters is a string that specifies the parameters to be passed to the application. The format of this string is determined by the verb that is to be invoked. If FileName specifies a document file, Parameters should be an empty string.


C1LinkTargetFile Properties

C1LinkTargetFile Properties

The properties of the C1LinkTargetFile class are listed here. For a complete list of C1LinkTargetFile class members, see the C1LinkTargetFile Members topic.

Public Properties

Command | String, referred to in this case as a verb, that specifies the action to be performed.
Directory | String that specifies the default directory.
FileName | Specifies the file or object on which to execute the specified verb.
Parameters | If the FileName parameter specifies an executable file, Parameters is a string that specifies the parameters to be passed to the application. The format of this string is determined by the verb that is to be invoked. If FileName specifies a document file, Parameters should be an empty string.


C1LinkTargetFile.Command Property

C1LinkTargetFile.Command Property

String, referred to in this case as a verb, that specifies the action to be performed.

[Visual Basic]

Public ReadOnly Property Command As String

[C#]

public string Command {get;}

[Delphi]

public property Command: String read get_Command;

Property Value

Remarks

The set of available verbs depends on the particular file or folder. Generally, the actions available from an object's shortcut menu are available verbs. For more information about verbs and their availability, see Object Verbs. See Extending Shortcut Menus for further discussion of shortcut menus. The following verbs are commonly used. edit Launches an editor and opens the document for editing. If FileName is not a document file, the function will fail. explore Explores the folder specified by FileName. find Initiates a search starting from the specified directory. open Opens the file specified by the FileName parameter. The file can be an executable file, a document file, or a folder. print Prints the document file specified by FileName. If FileName is not a document file, the function will fail. Empty string For systems prior to Microsoft® Windows® 2000, the default verb is used if it is valid and available in the registry. If not, the "open" verb is used. For Windows 2000 and later systems, the default verb is used if available. If not, the "open" verb is used. If neither verb is available, the system uses the first verb listed in the registry.


C1LinkTargetFile.Directory Property

C1LinkTargetFile.Directory Property

String that specifies the default directory.

[Visual Basic]

Public ReadOnly Property Directory As String

[C#]

public string Directory {get;}

[Delphi]

public property Directory: String read get_Directory;


C1LinkTargetFile.FileName Property

C1LinkTargetFile.FileName Property

Specifies the file or object on which to execute the specified verb.

[Visual Basic]

Public ReadOnly Property FileName As String

[C#]

public string FileName {get;}

[Delphi]

public property FileName: String read get_FileName;

Remarks

To specify a Shell namespace object, pass the fully qualified parse name. Note that not all verbs are supported on all objects. For example, not all document types support the "print" verb.


C1LinkTargetFile.Parameters Property

C1LinkTargetFile.Parameters Property

If the FileName parameter specifies an executable file, Parameters is a string that specifies the parameters to be passed to the application. The format of this string is determined by the verb that is to be invoked. If FileName specifies a document file, Parameters should be an empty string.

[Visual Basic]

Public ReadOnly Property Parameters As String

[C#]

public string Parameters {get;}

[Delphi]

public property Parameters: String read get_Parameters;


C1LinkTargetPage Class

C1LinkTargetPage Class

This class defines a link target to another page in a some document.

For a list of all members of this type, see C1LinkTargetPage Members.

System.Object

C1.C1Preview.C1LinkTarget

C1.C1Preview.C1LinkTargetPage

[Visual Basic]

Public Class C1LinkTargetPage

Inherits C1LinkTarget

[C#]

public class C1LinkTargetPage : C1LinkTarget

[Delphi]

type C1LinkTargetPage = class (C1LinkTarget);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


C1LinkTargetPage Members

C1LinkTargetPage Members

C1LinkTargetPage overview

Public Properties

PageJumpType | Gets the type of jump between pages.
PageNo | Specifies the number of page to jump, depending on PageJumpType it specifies the absolute or relative jump.


C1LinkTargetPage Properties

C1LinkTargetPage Properties

The properties of the C1LinkTargetPage class are listed here. For a complete list of C1LinkTargetPage class members, see the C1LinkTargetPage Members topic.

Public Properties

PageJumpType | Gets the type of jump between pages.
PageNo | Specifies the number of page to jump, depending on PageJumpType it specifies the absolute or relative jump.


C1LinkTargetPage.PageJumpType Property

C1LinkTargetPage.PageJumpType Property

Gets the type of jump between pages.

[Visual Basic]

Public ReadOnly Property PageJumpType As PageJumpTypeEnum

[C#]

public PageJumpTypeEnum PageJumpType {get;}

[Delphi]

public property PageJumpType: PageJumpTypeEnum read get_PageJumpType;


C1LinkTargetPage.PageNo Property

C1LinkTargetPage.PageNo Property

Specifies the number of page to jump, depending on PageJumpType it specifies the absolute or relative jump.

[Visual Basic]

Public ReadOnly Property PageNo As Int32*

[C#]

public Int32* PageNo {get;}

[Delphi]

public property PageNo: Int32* read get_PageNo;


C1LinkTargetUser Class

C1LinkTargetUser Class

This class starts a new document when a hyperlink with this type of LinkTarget is clicked. When such a hyperlink is activated(clicked), the UserHyperlinkJump event is fired (regardless of the value of the FireDrawelEvents property). This class does not have any public properties or methods of its own.

For a list of all members of this type, see C1LinkTargetUser Members.

System.Object

C1.C1Preview.C1LinkTarget

C1.C1Preview.C1LinkTargetUser

[Visual Basic]

Public Class C1LinkTargetUser

Inherits C1LinkTarget

[C#]

public class C1LinkTargetUser : C1LinkTarget

[Delphi]

type C1LinkTargetUser = class (C1LinkTarget);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


C1LinkTargetUser Members

C1LinkTargetUser Members

C1LinkTargetUser overview


C1PageSettings Class

C1PageSettings Class

Describes the page's properties of document.

For a list of all members of this type, see C1PageSettings Members.

System.Object

C1.C1Preview.C1PageSettings

[Visual Basic]

Public Class C1PageSettings

[C#]

public class C1PageSettings

[Delphi]

type C1PageSettings = class;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


C1PageSettings Members

C1PageSettings Members

C1PageSettings overview

Public Properties

BottomMargin | Gets or sets the bottom margin width.
Color | Gets or sets a value indicating whether the page should be printed in color.
Height | Gets or sets the height of the paper.
Landscape | Gets or sets a value indicating whether the page is printed in landscape or portrait orientation. Changing this property causes swap the height and width.
LeftMargin | Gets or sets the left margin width.
PageLayout | Gets the PageLayout object containing this object, can be null if this object is not linked with PageLayout.
PaperKind | Gets the type of paper. Changing of this property causes change of Width and Height.
RightMargin | Gets or sets the right margin width.
TopMargin | Gets or sets the top margin width.
Width | Gets or sets the width of the paper.

Public Methods

Compare | Compares this C1PageSettings with other C1PageSettings object.
CreateDefaultPageSettings | Creates the C1PageSettings object with default settings, on the basis of the current printer or system locale.
GetCurrentLocaleDefaultPaperSize | Gets the default paper size for the current locale.
ToPageSettings | Creates and initializes the new instances of PageSettings class the properties of newly created object are initialized on the base of this object.


C1PageSettings Properties

C1PageSettings Properties

The properties of the C1PageSettings class are listed here. For a complete list of C1PageSettings class members, see the C1PageSettings Members topic.

Public Properties

BottomMargin | Gets or sets the bottom margin width.
Color | Gets or sets a value indicating whether the page should be printed in color.
Height | Gets or sets the height of the paper.
Landscape | Gets or sets a value indicating whether the page is printed in landscape or portrait orientation. Changing this property causes swap the height and width.
LeftMargin | Gets or sets the left margin width.
PageLayout | Gets the PageLayout object containing this object, can be null if this object is not linked with PageLayout.
PaperKind | Gets the type of paper. Changing of this property causes change of Width and Height.
RightMargin | Gets or sets the right margin width.
TopMargin | Gets or sets the top margin width.
Width | Gets or sets the width of the paper.


C1PageSettings.BottomMargin Property

C1PageSettings.BottomMargin Property

Gets or sets the bottom margin width.

[Visual Basic]

Public Property BottomMargin As Unit

[C#]

public Unit BottomMargin {get;set;}

[Delphi]

public property BottomMargin: Unit read get_BottomMargin write set_BottomMargin;


C1PageSettings.Color Property

C1PageSettings.Color Property

Gets or sets a value indicating whether the page should be printed in color.

[Visual Basic]

Public Property Color As Boolean

[C#]

public bool Color {get;set;}

[Delphi]

public property Color: Boolean read get_Color write set_Color;


C1PageSettings.Height Property

C1PageSettings.Height Property

Gets or sets the height of the paper.

[Visual Basic]

Public Property Height As Unit

[C#]

public Unit Height {get;set;}

[Delphi]

public property Height: Unit read get_Height write set_Height;


C1PageSettings.Landscape Property

C1PageSettings.Landscape Property

Gets or sets a value indicating whether the page is printed in landscape or portrait orientation. Changing this property causes swap the height and width.

[Visual Basic]

Public Property Landscape As Boolean

[C#]

public bool Landscape {get;set;}

[Delphi]

public property Landscape: Boolean read get_Landscape write set_Landscape;


C1PageSettings.LeftMargin Property

C1PageSettings.LeftMargin Property

Gets or sets the left margin width.

[Visual Basic]

Public Property LeftMargin As Unit

[C#]

public Unit LeftMargin {get;set;}

[Delphi]

public property LeftMargin: Unit read get_LeftMargin write set_LeftMargin;


C1PageSettings.PageLayout Property

C1PageSettings.PageLayout Property

Gets the PageLayout object containing this object, can be null if this object is not linked with PageLayout.

[Visual Basic]

Public ReadOnly Property PageLayout As PageLayout

[C#]

public PageLayout PageLayout {get;}

[Delphi]

public property PageLayout: PageLayout read get_PageLayout;


C1PageSettings.PaperKind Property

C1PageSettings.PaperKind Property

Gets the type of paper. Changing of this property causes change of Width and Height.

[Visual Basic]

Public Property PaperKind As PaperKind

[C#]

public PaperKind PaperKind {get;set;}

[Delphi]

public property PaperKind: PaperKind read get_PaperKind write set_PaperKind;


C1PageSettings.RightMargin Property

C1PageSettings.RightMargin Property

Gets or sets the right margin width.

[Visual Basic]

Public Property RightMargin As Unit

[C#]

public Unit RightMargin {get;set;}

[Delphi]

public property RightMargin: Unit read get_RightMargin write set_RightMargin;


C1PageSettings.TopMargin Property

C1PageSettings.TopMargin Property

Gets or sets the top margin width.

[Visual Basic]

Public Property TopMargin As Unit

[C#]

public Unit TopMargin {get;set;}

[Delphi]

public property TopMargin: Unit read get_TopMargin write set_TopMargin;


C1PageSettings.Width Property

C1PageSettings.Width Property

Gets or sets the width of the paper.

[Visual Basic]

Public Property Width As Unit

[C#]

public Unit Width {get;set;}

[Delphi]

public property Width: Unit read get_Width write set_Width;


C1PageSettings Methods

C1PageSettings Methods

The methods of the C1PageSettings class are listed here. For a complete list of C1PageSettings class members, see the C1PageSettings Members topic.

Public Methods

Compare | Compares this C1PageSettings with other C1PageSettings object.
CreateDefaultPageSettings | Creates the C1PageSettings object with default settings, on the basis of the current printer or system locale.
GetCurrentLocaleDefaultPaperSize | Gets the default paper size for the current locale.
ToPageSettings | Creates and initializes the new instances of PageSettings class the properties of newly created object are initialized on the base of this object.


C1PageSettings.Compare Method

C1PageSettings.Compare Method

Compares this C1PageSettings with other C1PageSettings object.

[Visual Basic]

Public Function Compare( _

ByVal other As C1PageSettings _

) As Boolean

[C#]

public bool Compare(

C1PageSettings other

);

[Delphi]

public function Compare(

other: C1PageSettings

): Boolean;

Parameters

other

C1PageSettings object to compare to.

Return Value

Returns True if this C1PageSettings object equals other C1PageSettings object.


C1PageSettings.CreateDefaultPageSettings Method

C1PageSettings.CreateDefaultPageSettings Method

Creates the C1PageSettings object with default settings, on the basis of the current printer or system locale.

[Visual Basic]

Public Shared Function CreateDefaultPageSettings() As C1PageSettings

[C#]

public static C1PageSettings CreateDefaultPageSettings()

[Delphi]

public class function CreateDefaultPageSettings(): C1PageSettings;

Return Value

The created C1PageSettings object.


C1PageSettings.GetCurrentLocaleDefaultPaperSize Method

C1PageSettings.GetCurrentLocaleDefaultPaperSize Method

Gets the default paper size for the current locale.

[Visual Basic]

Public Shared Sub GetCurrentLocaleDefaultPaperSize( _

ByRef width As Double, _

ByRef height As Double, _

ByRef margin As Double, _

ByRef units As UnitTypeEnum _

)

[C#]

public static void GetCurrentLocaleDefaultPaperSize(

out double width,

out double height,

out double margin,

out UnitTypeEnum units

);

[Delphi]

public class procedure GetCurrentLocaleDefaultPaperSize(

out width: Double;

out height: Double;

out margin: Double;

out units: UnitTypeEnum

);

Return Value

The default paper size for the current locale.


C1PageSettings.ToPageSettings Method

C1PageSettings.ToPageSettings Method

Creates and initializes the new instances of PageSettings class the properties of newly created object are initialized on the base of this object.

[Visual Basic]

Public Function ToPageSettings( _

ByVal document As C1PrintDocument _

) As PageSettings

[C#]

public PageSettings ToPageSettings(

C1PrintDocument document

);

[Delphi]

public function ToPageSettings(

document: C1PrintDocument

): PageSettings;

Parameters

document

The C1PrintDocument object providing the default units (if some sizes in this object specified in default units) and DPI (if some sizes specified in UnitTypeEnum.Pixel). Can be null, in this case exception occurs if this object contains sizes in UnitTypeEnum.Default or UnitTypeEnum.Pixel.

Return Value

The created PageSettings object.


C1PrintDocument Class

C1PrintDocument Class

ComponentOne Document.

For a list of all members of this type, see C1PrintDocument Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

C1.C1Preview.C1PrintDocument

[Visual Basic]

Public Class C1PrintDocument

Inherits Component

Implements IC1FormatVersionProvider, IC1SerializableObject, IDocumentLocation

[C#]

public class C1PrintDocument : Component, IC1FormatVersionProvider, IC1SerializableObject, IDocumentLocation

[Delphi]

type C1PrintDocument = class (Component, IC1FormatVersionProvider, IC1SerializableObject, IDocumentLocation);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


C1PrintDocument Members

C1PrintDocument Members

C1PrintDocument overview

Public Properties

AcceptButton | Gets the RenderInputButton object representing the accept button in document (the first RenderInputButton object with AcceptButton == True).
AllowNonReflowableDocs | Gets or sets the value indicating whether the user can create the non reflowable documents. If this flag is False (default) when exception occurs if user perform an action which cause the creation of non reflowable document.
AssemblyVersion | Gets the version of C1PrintDocument assembly.
AutoEmbedFonts | Gets or sets value indicating whether the EmbeddedFonts collection will be automatically filled during generation with used fonts.
Body | Gets the object representing the page body.
CreationDpi | Gets the dpi which is used during document creation.
CreationGraphics | Gets the Graphics object used to generate the document. This graphics used to calculate text sizes, measuring RTF text, and so on.
CreationMode | Gets the mode of document creation.
CurrentBlockGraphics | Gets the current Graphics object which was opened with RenderBlockGraphicsBegin method.
CurrentBlockRenderGraphics | Gets the current RenderGraphics object, which was opened with RenderBlockGraphicsBegin.
CurrentDirectGraphics | Gets the current Graphics object which was opened with RenderDirectGraphicsBegin method.
CurrentDirectRenderGraphics | Gets the current RenderGraphics object, which was opened with RenderDirectGraphicsBegin.
CurrentPageLayout | Gets the current page layout, this property available only during generating of document.
DefaultUnit | Defines the default unit of measurement. When lengths are set without specifying unit of measurement this unit is assumed.
Dictionary | Gets the document's dictionary.
DocumentFormatVersion | Gets the version of C1D format.
DocumentInfo | Gets or sets common info about document: author, caption and so on.
EmbeddedFonts | Gets the collection of embedded fonts.
EmfType | Gets or sets the type of metafiles created by this document.
ErrorCode | Gets the code of error occurs during document generating.
ErrorDesc | Gets the error details occurs during document generating.
FormatVersion | Gets the C1FormatVersion object describing the version of C1D format supported by this assembly.
FormsKeyActionEnter | Gets or sets the action to be performed when an ENTER key is pressed in C1PreviewPane control which is connected to this document.
FormsKeyActionTab | Gets or sets the action to be performed when a TAB key is pressed in C1PreviewPane control which is connected to this document.
IsGenerating | Indicates whether document is in generating of its content.
IsStartEndDocMode | Indicates whether document is generating with using of the StartDoc() / EndDoc() methods.
MeasurementDevice | Gets or sets the type of device providing the Graphics which is used for measuring the layout of document.
MeasurementDpi | Gets the DPI of MeasurementGraphics, if MeasurementGraphics is null then screen DPI will be returned.
MeasurementGraphics | Gets the Graphics object which is used for measuring the layout of document.
MeasurementPrinterName | Gets or sets the printer name providing the Graphics which is used for measuring the layout of document. This property is used only when MeasurementDevice is MeasurementDeviceEnum.Printer.
Outlines | Gets the document's outlines.
PageLayout | Gets or sets the page layout for the document, page layout includes: page settings (width, height, margins and so on), page header, page footer and columns definition.
PageLayouts | Gets the page layouts used in document. Each page layout includes: page settings (width, height, margins and so on), page header, page footer and columns definition.
Pages | Gets the collection of document's pages.
Reflowable | Gets value indicating whether the document is reflowable.
ResolvedUnit | Gets or sets the units of measurement in which bounds of objects' fragment will specified. This property can't be changed when document is in generating of its content.
Stacking | Gets or sets the stacking rules for the document.
Style | Main style of document.
Tags | Gets the collection of document's tags which are defined by user.
ThrowExceptionOnError | Indicates that the exception must be raised when error occurs during generating, if this flag is False then Generate method will return False and exception not will be raised. This property is True by default.

Public Methods

CanRenderBlock | Indicates whether rendering in the block flow is permitted now.
CanRenderDirect | Indicates whether direct rendering is permitted now.
Clear | Clears the document.
CreateGraphicsForDpi | Creates the Graphics object with specified dpi. Do NOT dispose this object, it can be equal the C1PrintDocument.MeasurementGraphics.
EndDoc | Finishes generation of a document.
FindAnchor | Searches the anchor in document.
FindInputFragment | Searches the first RenderInputFragment.
FromFile | Creates a new instance of C1PrintDocument from the specified file.
FromStream | Creates a new instance of C1PrintDocument from the specified data stream.
Generate | Generates a document.
IsInlineStarted | Indicates whether the inline rendering started.
NewColumn | Begins a new column, if current column is last on page then new page will be started.
NewLine | Begins a new line in inline flow, can be used only if current stacking is inline flow.
RenderBlock | Adds render object to the document and resolves it. This method can be used only if document is generated with using of the StartDoc() / EndDoc() methods.
RenderBlockImage | Overloaded. Renders the Image.
RenderBlockRichText | Overloaded. Renders the RTF text with parent width and autoheight.
RenderDirect | Overloaded. Addes render object to the document and resolves it in a specified position. This method can be used only if document is generated with using of the StartDoc() / EndDoc() methods.
RenderDirectImage | Overloaded. Renders an image in specified position.
RenderDirectRichText | Overloaded. Renders an rich text in specified position, the heigh of text will be calculated automatically.
RenderDirectText | Overloaded. Renders a text in specified position.
RenderInlineBegin | Begins the rendering of paragraph, you can omit this method and call RenderInlineTextXXX methods directly(), but this method allows to define the style of inline paragraph. If inline rendering already started the current paragraph will be closed and new will begin.
RenderInlineEnd | Finishes the inline rendering.
SelectBestMeasurementDevice | Selects the optimal device which can be used for MeasurementGraphics, it search for printer with "square" dpi (DpiX == DpiY) large or equal than 300, if such printer does not exist then screen Graphics is used. Parameters of selected device can be read from MeasurementXXX properties.
StartDoc | Starts a new document.
NewPage | Creates a new page.
FromRU | Converts a value in the "ResolvedUnitType" units to another units of measurement.
ToRU | Converts a value from specified units of measurement in the "ResolvedUnitType" units.

Public Events

BusyStateChanged | Occurs when the value of the BusyState was changed.
DefaultUnitChanged | Occurs when the value of the DefaultUnit was changed.
DocumentEnded | Occurs when the document building is ended.
DocumentStarting | Occurs when the document building is started.
GenerateDocument | Allows user to build document content in event handler.
InputValueChanged | Occurs when the value of RenderInputBase object within document is changed.
LongOperation | Indicate the progress of document generation.
PageAdded | Occurs only during generating of the document, when generating of page of document is finished, page is added to the Pages collection and switch to other page is occured.
PageChanged | Occurs only during generating of the document, when page of document which was added to document is changed, for example when page numbering is changed or PageCount property is updated for page.
PageConfigure | Occurs when a new empty page is created and added to the document, the page is added to the Pages collection but *not resolved*, use this method only for changing layout of page.
PageDeleted | Occurs when page is removed from document (from Pages collection). This event can't occurs during generating.
PagesClear | Occurs when pages' collection is cleared.
PageUpdated | Occurs when page of document is changed. This event occurs very often while document is generating, it is called each time when a fragment of object is added to page or removed from page.
ResolvedUnitChanged | Occurs when the value of the ResolvedUnit was changed.


C1PrintDocument Properties

C1PrintDocument Properties

The properties of the C1PrintDocument class are listed here. For a complete list of C1PrintDocument class members, see the C1PrintDocument Members topic.

Public Properties

AcceptButton | Gets the RenderInputButton object representing the accept button in document (the first RenderInputButton object with AcceptButton == True).
AllowNonReflowableDocs | Gets or sets the value indicating whether the user can create the non reflowable documents. If this flag is False (default) when exception occurs if user perform an action which cause the creation of non reflowable document.
AssemblyVersion | Gets the version of C1PrintDocument assembly.
AutoEmbedFonts | Gets or sets value indicating whether the EmbeddedFonts collection will be automatically filled during generation with used fonts.
Body | Gets the object representing the page body.
CreationDpi | Gets the dpi which is used during document creation.
CreationGraphics | Gets the Graphics object used to generate the document. This graphics used to calculate text sizes, measuring RTF text, and so on.
CreationMode | Gets the mode of document creation.
CurrentBlockGraphics | Gets the current Graphics object which was opened with RenderBlockGraphicsBegin method.
CurrentBlockRenderGraphics | Gets the current RenderGraphics object, which was opened with RenderBlockGraphicsBegin.
CurrentDirectGraphics | Gets the current Graphics object which was opened with RenderDirectGraphicsBegin method.
CurrentDirectRenderGraphics | Gets the current RenderGraphics object, which was opened with RenderDirectGraphicsBegin.
CurrentPageLayout | Gets the current page layout, this property available only during generating of document.
DefaultUnit | Defines the default unit of measurement. When lengths are set without specifying unit of measurement this unit is assumed.
Dictionary | Gets the document's dictionary.
DocumentFormatVersion | Gets the version of C1D format.
DocumentInfo | Gets or sets common info about document: author, caption and so on.
EmbeddedFonts | Gets the collection of embedded fonts.
EmfType | Gets or sets the type of metafiles created by this document.
ErrorCode | Gets the code of error occurs during document generating.
ErrorDesc | Gets the error details occurs during document generating.
FormatVersion | Gets the C1FormatVersion object describing the version of C1D format supported by this assembly.
FormsKeyActionEnter | Gets or sets the action to be performed when an ENTER key is pressed in C1PreviewPane control which is connected to this document.
FormsKeyActionTab | Gets or sets the action to be performed when a TAB key is pressed in C1PreviewPane control which is connected to this document.
IsGenerating | Indicates whether document is in generating of its content.
IsStartEndDocMode | Indicates whether document is generating with using of the StartDoc() / EndDoc() methods.
MeasurementDevice | Gets or sets the type of device providing the Graphics which is used for measuring the layout of document.
MeasurementDpi | Gets the DPI of MeasurementGraphics, if MeasurementGraphics is null then screen DPI will be returned.
MeasurementGraphics | Gets the Graphics object which is used for measuring the layout of document.
MeasurementPrinterName | Gets or sets the printer name providing the Graphics which is used for measuring the layout of document. This property is used only when MeasurementDevice is MeasurementDeviceEnum.Printer.
Outlines | Gets the document's outlines.
PageLayout | Gets or sets the page layout for the document, page layout includes: page settings (width, height, margins and so on), page header, page footer and columns definition.
PageLayouts | Gets the page layouts used in document. Each page layout includes: page settings (width, height, margins and so on), page header, page footer and columns definition.
Pages | Gets the collection of document's pages.
Reflowable | Gets value indicating whether the document is reflowable.
ResolvedUnit | Gets or sets the units of measurement in which bounds of objects' fragment will specified. This property can't be changed when document is in generating of its content.
Stacking | Gets or sets the stacking rules for the document.
Style | Main style of document.
Tags | Gets the collection of document's tags which are defined by user.
ThrowExceptionOnError | Indicates that the exception must be raised when error occurs during generating, if this flag is False then Generate method will return False and exception not will be raised. This property is True by default.


C1PrintDocument.AcceptButton Property

C1PrintDocument.AcceptButton Property

Gets the RenderInputButton object representing the accept button in document (the first RenderInputButton object with AcceptButton == True).

[Visual Basic]

Public ReadOnly Property AcceptButton As RenderInputButton

[C#]

public RenderInputButton AcceptButton {get;}

[Delphi]

public property AcceptButton: RenderInputButton read get_AcceptButton;


C1PrintDocument.AllowNonReflowableDocs Property

C1PrintDocument.AllowNonReflowableDocs Property

Gets or sets the value indicating whether the user can create the non reflowable documents. If this flag is False (default) when exception occurs if user perform an action which cause the creation of non reflowable document.

[Visual Basic]

Public Property AllowNonReflowableDocs As Boolean

[C#]

public bool AllowNonReflowableDocs {get;set;}

[Delphi]

public property AllowNonReflowableDocs: Boolean read get_AllowNonReflowableDocs write set_AllowNonReflowableDocs;


C1PrintDocument.AssemblyVersion Property

C1PrintDocument.AssemblyVersion Property

Gets the version of C1PrintDocument assembly.

[Visual Basic]

Public Shared ReadOnly Property AssemblyVersion As String

[C#]

public static string AssemblyVersion {get;}

[Delphi]

public class property AssemblyVersion: String read get_AssemblyVersion;


C1PrintDocument.AutoEmbedFonts Property

C1PrintDocument.AutoEmbedFonts Property

Gets or sets value indicating whether the EmbeddedFonts collection will be automatically filled during generation with used fonts.

[Visual Basic]

Public Property AutoEmbedFonts As Boolean

[C#]

public bool AutoEmbedFonts {get;set;}

[Delphi]

public property AutoEmbedFonts: Boolean read get_AutoEmbedFonts write set_AutoEmbedFonts;


C1PrintDocument.Body Property

C1PrintDocument.Body Property

Gets the object representing the page body.

[Visual Basic]

Public ReadOnly Property Body As DocumentBody

[C#]

public DocumentBody Body {get;}

[Delphi]

public property Body: DocumentBody read get_Body;


C1PrintDocument.CreationDpi Property

C1PrintDocument.CreationDpi Property

Gets the dpi which is used during document creation.

[Visual Basic]

Public Property CreationDpi As Single

[C#]

public float CreationDpi {get;set;}

[Delphi]

public property CreationDpi: Single read get_CreationDpi write set_CreationDpi;


C1PrintDocument.CreationGraphics Property

C1PrintDocument.CreationGraphics Property

Gets the Graphics object used to generate the document. This graphics used to calculate text sizes, measuring RTF text, and so on.

[Visual Basic]

Public Property CreationGraphics As Graphics

[C#]

public Graphics CreationGraphics {get;set;}

[Delphi]

public property CreationGraphics: Graphics read get_CreationGraphics write set_CreationGraphics;


C1PrintDocument.CreationMode Property

C1PrintDocument.CreationMode Property

Gets the mode of document creation.

[Visual Basic]

Public ReadOnly Property CreationMode As DocumentCreationMode

[C#]

public DocumentCreationMode CreationMode {get;}

[Delphi]

public property CreationMode: DocumentCreationMode read get_CreationMode;


C1PrintDocument.CurrentBlockGraphics Property

C1PrintDocument.CurrentBlockGraphics Property

Gets the current Graphics object which was opened with RenderBlockGraphicsBegin method.

[Visual Basic]

Public ReadOnly Property CurrentBlockGraphics As Graphics

[C#]

public Graphics CurrentBlockGraphics {get;}

[Delphi]

public property CurrentBlockGraphics: Graphics read get_CurrentBlockGraphics;


C1PrintDocument.CurrentBlockRenderGraphics Property

C1PrintDocument.CurrentBlockRenderGraphics Property

Gets the current RenderGraphics object, which was opened with RenderBlockGraphicsBegin.

[Visual Basic]

Public ReadOnly Property CurrentBlockRenderGraphics As RenderGraphics

[C#]

public RenderGraphics CurrentBlockRenderGraphics {get;}

[Delphi]

public property CurrentBlockRenderGraphics: RenderGraphics read get_CurrentBlockRenderGraphics;


C1PrintDocument.CurrentDirectGraphics Property

C1PrintDocument.CurrentDirectGraphics Property

Gets the current Graphics object which was opened with RenderDirectGraphicsBegin method.

[Visual Basic]

Public ReadOnly Property CurrentDirectGraphics As Graphics

[C#]

public Graphics CurrentDirectGraphics {get;}

[Delphi]

public property CurrentDirectGraphics: Graphics read get_CurrentDirectGraphics;


C1PrintDocument.CurrentDirectRenderGraphics Property

C1PrintDocument.CurrentDirectRenderGraphics Property

Gets the current RenderGraphics object, which was opened with RenderDirectGraphicsBegin.

[Visual Basic]

Public ReadOnly Property CurrentDirectRenderGraphics As RenderGraphics

[C#]

public RenderGraphics CurrentDirectRenderGraphics {get;}

[Delphi]

public property CurrentDirectRenderGraphics: RenderGraphics read get_CurrentDirectRenderGraphics;


C1PrintDocument.CurrentPageLayout Property

C1PrintDocument.CurrentPageLayout Property

Gets the current page layout, this property available only during generating of document.

[Visual Basic]

Public ReadOnly Property CurrentPageLayout As PageLayout

[C#]

public PageLayout CurrentPageLayout {get;}

[Delphi]

public property CurrentPageLayout: PageLayout read get_CurrentPageLayout;


C1PrintDocument.DefaultUnit Property

C1PrintDocument.DefaultUnit Property

Defines the default unit of measurement. When lengths are set without specifying unit of measurement this unit is assumed.

[Visual Basic]

Public Property DefaultUnit As UnitTypeEnum

[C#]

public UnitTypeEnum DefaultUnit {get;set;}

[Delphi]

public property DefaultUnit: UnitTypeEnum read get_DefaultUnit write set_DefaultUnit;


C1PrintDocument.Dictionary Property

C1PrintDocument.Dictionary Property

Gets the document's dictionary.

[Visual Basic]

Overridable Public ReadOnly Property Dictionary As Dictionary

[C#]

virtual public Dictionary Dictionary {get;}

[Delphi]

public property Dictionary: Dictionary read get_Dictionary;


C1PrintDocument.DocumentFormatVersion Property

C1PrintDocument.DocumentFormatVersion Property

Gets the version of C1D format.

[Visual Basic]

Public Shared ReadOnly Property DocumentFormatVersion As String

[C#]

public static string DocumentFormatVersion {get;}

[Delphi]

public class property DocumentFormatVersion: String read get_DocumentFormatVersion;


C1PrintDocument.DocumentInfo Property

C1PrintDocument.DocumentInfo Property

Gets or sets common info about document: author, caption and so on.

[Visual Basic]

Public Property DocumentInfo As DocumentInfo

[C#]

public DocumentInfo DocumentInfo {get;set;}

[Delphi]

public property DocumentInfo: DocumentInfo read get_DocumentInfo write set_DocumentInfo;


C1PrintDocument.EmbeddedFonts Property

C1PrintDocument.EmbeddedFonts Property

Gets the collection of embedded fonts.

[Visual Basic]

Overridable Public ReadOnly Property EmbeddedFonts As EmbeddedFontCollection

[C#]

virtual public EmbeddedFontCollection EmbeddedFonts {get;}

[Delphi]

public property EmbeddedFonts: EmbeddedFontCollection read get_EmbeddedFonts;


C1PrintDocument.EmfType Property

C1PrintDocument.EmfType Property

Gets or sets the type of metafiles created by this document.

[Visual Basic]

Public Property EmfType As EmfType

[C#]

public EmfType EmfType {get;set;}

[Delphi]

public property EmfType: EmfType read get_EmfType write set_EmfType;


C1PrintDocument.ErrorCode Property

C1PrintDocument.ErrorCode Property

Gets the code of error occurs during document generating.

[Visual Basic]

Public ReadOnly Property ErrorCode As GenerateErrorEnum

[C#]

public GenerateErrorEnum ErrorCode {get;}

[Delphi]

public property ErrorCode: GenerateErrorEnum read get_ErrorCode;


C1PrintDocument.ErrorDesc Property

C1PrintDocument.ErrorDesc Property

Gets the error details occurs during document generating.

[Visual Basic]

Public ReadOnly Property ErrorDesc As String

[C#]

public string ErrorDesc {get;}

[Delphi]

public property ErrorDesc: String read get_ErrorDesc;


C1PrintDocument.FormatVersion Property

C1PrintDocument.FormatVersion Property

Gets the C1FormatVersion object describing the version of C1D format supported by this assembly.

[Visual Basic]

Public Shared ReadOnly Property FormatVersion As C1FormatVersion

[C#]

public static C1FormatVersion FormatVersion {get;}

[Delphi]

public class property FormatVersion: C1FormatVersion read get_FormatVersion;


C1PrintDocument.FormsKeyActionEnter Property

C1PrintDocument.FormsKeyActionEnter Property

Gets or sets the action to be performed when an ENTER key is pressed in C1PreviewPane control which is connected to this document.

[Visual Basic]

Public Property FormsKeyActionEnter As FormsKeyActionEnterEnum

[C#]

public FormsKeyActionEnterEnum FormsKeyActionEnter {get;set;}

[Delphi]

public property FormsKeyActionEnter: FormsKeyActionEnterEnum read get_FormsKeyActionEnter write set_FormsKeyActionEnter;


C1PrintDocument.FormsKeyActionTab Property

C1PrintDocument.FormsKeyActionTab Property

Gets or sets the action to be performed when a TAB key is pressed in C1PreviewPane control which is connected to this document.

[Visual Basic]

Public Property FormsKeyActionTab As FormsKeyActionTabEnum

[C#]

public FormsKeyActionTabEnum FormsKeyActionTab {get;set;}

[Delphi]

public property FormsKeyActionTab: FormsKeyActionTabEnum read get_FormsKeyActionTab write set_FormsKeyActionTab;


C1PrintDocument.IsGenerating Property

C1PrintDocument.IsGenerating Property

Indicates whether document is in generating of its content.

[Visual Basic]

Public ReadOnly Property IsGenerating As Boolean

[C#]

public bool IsGenerating {get;}

[Delphi]

public property IsGenerating: Boolean read get_IsGenerating;


C1PrintDocument.IsStartEndDocMode Property

C1PrintDocument.IsStartEndDocMode Property

Indicates whether document is generating with using of the StartDoc() / EndDoc() methods.

[Visual Basic]

Public ReadOnly Property IsStartEndDocMode As Boolean

[C#]

public bool IsStartEndDocMode {get;}

[Delphi]

public property IsStartEndDocMode: Boolean read get_IsStartEndDocMode;


C1PrintDocument.MeasurementDevice Property

C1PrintDocument.MeasurementDevice Property

Gets or sets the type of device providing the Graphics which is used for measuring the layout of document.

[Visual Basic]

Public Shared Property MeasurementDevice As MeasurementDeviceEnum

[C#]

public static MeasurementDeviceEnum MeasurementDevice {get;set;}

[Delphi]

public class property MeasurementDevice: MeasurementDeviceEnum read get_MeasurementDevice write set_MeasurementDevice;


C1PrintDocument.MeasurementDpi Property

C1PrintDocument.MeasurementDpi Property

Gets the DPI of MeasurementGraphics, if MeasurementGraphics is null then screen DPI will be returned.

[Visual Basic]

Public Shared ReadOnly Property MeasurementDpi As Single

[C#]

public static float MeasurementDpi {get;}

[Delphi]

public class property MeasurementDpi: Single read get_MeasurementDpi;


C1PrintDocument.MeasurementGraphics Property

C1PrintDocument.MeasurementGraphics Property

Gets the Graphics object which is used for measuring the layout of document.

[Visual Basic]

Public Shared ReadOnly Property MeasurementGraphics As Graphics

[C#]

public static Graphics MeasurementGraphics {get;}

[Delphi]

public class property MeasurementGraphics: Graphics read get_MeasurementGraphics;


C1PrintDocument.MeasurementPrinterName Property

C1PrintDocument.MeasurementPrinterName Property

Gets or sets the printer name providing the Graphics which is used for measuring the layout of document. This property is used only when MeasurementDevice is MeasurementDeviceEnum.Printer.

[Visual Basic]

Public Shared Property MeasurementPrinterName As String

[C#]

public static string MeasurementPrinterName {get;set;}

[Delphi]

public class property MeasurementPrinterName: String read get_MeasurementPrinterName write set_MeasurementPrinterName;


C1PrintDocument.Outlines Property

C1PrintDocument.Outlines Property

Gets the document's outlines.

[Visual Basic]

Public ReadOnly Property Outlines As OutlineNodeCollection

[C#]

public OutlineNodeCollection Outlines {get;}

[Delphi]

public property Outlines: OutlineNodeCollection read get_Outlines;


C1PrintDocument.PageLayout Property

C1PrintDocument.PageLayout Property

Gets or sets the page layout for the document, page layout includes: page settings (width, height, margins and so on), page header, page footer and columns definition.

[Visual Basic]

Public Property PageLayout As PageLayout

[C#]

public PageLayout PageLayout {get;set;}

[Delphi]

public property PageLayout: PageLayout read get_PageLayout write set_PageLayout;


C1PrintDocument.PageLayouts Property

C1PrintDocument.PageLayouts Property

Gets the page layouts used in document. Each page layout includes: page settings (width, height, margins and so on), page header, page footer and columns definition.

[Visual Basic]

Public ReadOnly Property PageLayouts As DocumentPageLayouts

[C#]

public DocumentPageLayouts PageLayouts {get;}

[Delphi]

public property PageLayouts: DocumentPageLayouts read get_PageLayouts;


C1PrintDocument.Pages Property

C1PrintDocument.Pages Property

Gets the collection of document's pages.

[Visual Basic]

Public ReadOnly Property Pages As PageCollection

[C#]

public PageCollection Pages {get;}

[Delphi]

public property Pages: PageCollection read get_Pages;


C1PrintDocument.Reflowable Property

C1PrintDocument.Reflowable Property

Gets value indicating whether the document is reflowable.

[Visual Basic]

Public ReadOnly Property Reflowable As Boolean

[C#]

public bool Reflowable {get;}

[Delphi]

public property Reflowable: Boolean read get_Reflowable;


C1PrintDocument.ResolvedUnit Property

C1PrintDocument.ResolvedUnit Property

Gets or sets the units of measurement in which bounds of objects' fragment will specified. This property can't be changed when document is in generating of its content.

[Visual Basic]

Public Property ResolvedUnit As UnitTypeEnum

[C#]

public UnitTypeEnum ResolvedUnit {get;set;}

[Delphi]

public property ResolvedUnit: UnitTypeEnum read get_ResolvedUnit write set_ResolvedUnit;


C1PrintDocument.Stacking Property

C1PrintDocument.Stacking Property

Gets or sets the stacking rules for the document.

[Visual Basic]

Public Property Stacking As StackingRulesEnum

[C#]

public StackingRulesEnum Stacking {get;set;}

[Delphi]

public property Stacking: StackingRulesEnum read get_Stacking write set_Stacking;


C1PrintDocument.Style Property

C1PrintDocument.Style Property

Main style of document.

[Visual Basic]

Public ReadOnly Property Style As Style

[C#]

public Style Style {get;}

[Delphi]

public property Style: Style read get_Style;


C1PrintDocument.Tags Property

C1PrintDocument.Tags Property

Gets the collection of document's tags which are defined by user.

[Visual Basic]

Public ReadOnly Property Tags As TagCollection

[C#]

public TagCollection Tags {get;}

[Delphi]

public property Tags: TagCollection read get_Tags;


C1PrintDocument.ThrowExceptionOnError Property

C1PrintDocument.ThrowExceptionOnError Property

Indicates that the exception must be raised when error occurs during generating, if this flag is False then Generate method will return False and exception not will be raised. This property is True by default.

[Visual Basic]

Public Property ThrowExceptionOnError As Boolean

[C#]

public bool ThrowExceptionOnError {get;set;}

[Delphi]

public property ThrowExceptionOnError: Boolean read get_ThrowExceptionOnError write set_ThrowExceptionOnError;


C1PrintDocument Methods

C1PrintDocument Methods

The methods of the C1PrintDocument class are listed here. For a complete list of C1PrintDocument class members, see the C1PrintDocument Members topic.

Public Methods

CanRenderBlock | Indicates whether rendering in the block flow is permitted now.
CanRenderDirect | Indicates whether direct rendering is permitted now.
Clear | Clears the document.
CreateGraphicsForDpi | Creates the Graphics object with specified dpi. Do NOT dispose this object, it can be equal the C1PrintDocument.MeasurementGraphics.
EndDoc | Finishes generation of a document.
FindAnchor | Searches the anchor in document.
FindInputFragment | Searches the first RenderInputFragment.
FromFile | Creates a new instance of C1PrintDocument from the specified file.
FromStream | Creates a new instance of C1PrintDocument from the specified data stream.
Generate | Generates a document.
IsInlineStarted | Indicates whether the inline rendering started.
NewColumn | Begins a new column, if current column is last on page then new page will be started.
NewLine | Begins a new line in inline flow, can be used only if current stacking is inline flow.
RenderBlock | Adds render object to the document and resolves it. This method can be used only if document is generated with using of the StartDoc() / EndDoc() methods.
RenderBlockImage | Overloaded. Renders the Image.
RenderBlockRichText | Overloaded. Renders the RTF text with parent width and autoheight.
RenderDirect | Overloaded. Addes render object to the document and resolves it in a specified position. This method can be used only if document is generated with using of the StartDoc() / EndDoc() methods.
RenderDirectImage | Overloaded. Renders an image in specified position.
RenderDirectRichText | Overloaded. Renders an rich text in specified position, the heigh of text will be calculated automatically.
RenderDirectText | Overloaded. Renders a text in specified position.
RenderInlineBegin | Begins the rendering of paragraph, you can omit this method and call RenderInlineTextXXX methods directly(), but this method allows to define the style of inline paragraph. If inline rendering already started the current paragraph will be closed and new will begin.
RenderInlineEnd | Finishes the inline rendering.
SelectBestMeasurementDevice | Selects the optimal device which can be used for MeasurementGraphics, it search for printer with "square" dpi (DpiX == DpiY) large or equal than 300, if such printer does not exist then screen Graphics is used. Parameters of selected device can be read from MeasurementXXX properties.
StartDoc | Starts a new document.
NewPage | Creates a new page.
FromRU | Converts a value in the "ResolvedUnitType" units to another units of measurement.
ToRU | Converts a value from specified units of measurement in the "ResolvedUnitType" units.


C1PrintDocument.CanRenderBlock Method

C1PrintDocument.CanRenderBlock Method

Indicates whether rendering in the block flow is permitted now.

[Visual Basic]

Public Function CanRenderBlock() As Boolean

[C#]

public bool CanRenderBlock()

[Delphi]

public function CanRenderBlock(): Boolean;


C1PrintDocument.CanRenderDirect Method

C1PrintDocument.CanRenderDirect Method

Indicates whether direct rendering is permitted now.

[Visual Basic]

Public Function CanRenderDirect() As Boolean

[C#]

public bool CanRenderDirect()

[Delphi]

public function CanRenderDirect(): Boolean;


C1PrintDocument.Clear Method

C1PrintDocument.Clear Method

Clears the document.

[Visual Basic]

Public Sub Clear()

[C#]

public void Clear()

[Delphi]

public procedure Clear();


C1PrintDocument.CreateGraphicsForDpi Method

C1PrintDocument.CreateGraphicsForDpi Method

Creates the Graphics object with specified dpi. Do NOT dispose this object, it can be equal the C1PrintDocument.MeasurementGraphics.

[Visual Basic]

Public Shared Function CreateGraphicsForDpi( _

ByVal dpi As Single _

) As Graphics

[C#]

public static Graphics CreateGraphicsForDpi(

float dpi

);

[Delphi]

public class function CreateGraphicsForDpi(

dpi: Single

): Graphics;

Parameters

dpi

The requested dpi.

Return Value

Returns the created Graphics object or null, if it can't be created for specified dpi.


C1PrintDocument.EndDoc Method

C1PrintDocument.EndDoc Method

Finishes generation of a document.

[Visual Basic]

Public Function EndDoc() As Boolean

[C#]

public bool EndDoc()

[Delphi]

public function EndDoc(): Boolean;


C1PrintDocument.FindAnchor Method

C1PrintDocument.FindAnchor Method

Searches the anchor in document.

[Visual Basic]

Public Function FindAnchor( _

ByVal anchorName As String _

) As C1AnchorInfo

[C#]

public C1AnchorInfo FindAnchor(

string anchorName

);

[Delphi]

public function FindAnchor(

anchorName: String

): C1AnchorInfo;

Parameters

anchorName

The name of anchor to search.

Return Value

Returns the C1AnchorInfo object about searched anchor or null if not found.


C1PrintDocument.FindInputFragment Method

C1PrintDocument.FindInputFragment Method

Searches the first RenderInputFragment.

[Visual Basic]

Public Function FindInputFragment( _

ByVal startPageIndex As Int32*, _

ByVal toLastPage As Boolean _

) As RenderInputFragment

[C#]

public RenderInputFragment FindInputFragment(

Int32* startPageIndex,

bool toLastPage

);

[Delphi]

public function FindInputFragment(

startPageIndex: Int32*;

toLastPage: Boolean

): RenderInputFragment;

Parameters

startPageIndex

Index of the first page from which the search begins.

toLastPage

If True then the search goes from startPageIndex to last document's page.

Return Value

Returns the searched RenderInputFragment object or null.


C1PrintDocument.FromFile Method

C1PrintDocument.FromFile Method

Creates a new instance of C1PrintDocument from the specified file.

[Visual Basic]

Public Shared Function FromFile( _

ByVal fileName As String _

) As C1PrintDocument

[C#]

public static C1PrintDocument FromFile(

string fileName

);

[Delphi]

public class function FromFile(

fileName: String

): C1PrintDocument;

Parameters

fileName

A string that contains the name of the file from which to create the C1PrintDocument.

Return Value

The C1PrintDocument that was created.


C1PrintDocument.FromRU Method

C1PrintDocument.FromRU Method

Overload List

Converts a value in the "ResolvedUnitType" units to another units of measurement.

[Visual Basic] Overloads Public Function FromRU(Double, UnitTypeEnum, Single) As Double

[C#] public double FromRU(double, UnitTypeEnum, float);

[Delphi] public function FromRU(Double; UnitTypeEnum; Single) : Double; overload;

Converts rectangle in ResolvedUnitType to pixels.

[Visual Basic] Overloads Public Function FromRU(RectangleD, Single, Single, Boolean) As Rectangle

[C#] public Rectangle FromRU(RectangleD, float, float, bool);

[Delphi] public function FromRU(RectangleD; Single; Single; Boolean) : Rectangle; overload;


C1PrintDocument.FromRU Method (Double, UnitTypeEnum, Single)

C1PrintDocument.FromRU Method (Double, UnitTypeEnum, Single)

Previous Next

Converts a value in the "ResolvedUnitType" units to another units of measurement.

[Visual Basic]

Overloads Public Function FromRU( _

ByVal value As Double, _

ByVal destType As UnitTypeEnum, _

ByVal destDpi As Single _

) As Double

[C#]

public double FromRU(

double value,

UnitTypeEnum destType,

float destDpi

);

[Delphi]

public function FromRU(

value: Double;

destType: UnitTypeEnum;

destDpi: Single

): Double; overload;

Parameters

value

Value in the "ResolvedUnitType" units.

destType

Specifies the destination units.

destDpi

Specifies the DPI if destType is UnitTypeEnum.Pixel.

Return Value

Returns the converted value.


C1PrintDocument.FromRU Method (RectangleD, Single, Single, Boolean)

C1PrintDocument.FromRU Method (RectangleD, Single, Single, Boolean)

Previous Next

Converts rectangle in ResolvedUnitType to pixels.

[Visual Basic]

Overloads Public Function FromRU( _

ByVal value As RectangleD, _

ByVal destDpiX As Single, _

ByVal destDpiY As Single, _

ByVal truncate As Boolean _

) As Rectangle

[C#]

public Rectangle FromRU(

RectangleD value,

float destDpiX,

float destDpiY,

bool truncate

);

[Delphi]

public function FromRU(

value: RectangleD;

destDpiX: Single;

destDpiY: Single;

truncate: Boolean

): Rectangle; overload;


C1PrintDocument.FromStream Method

C1PrintDocument.FromStream Method

Creates a new instance of C1PrintDocument from the specified data stream.

[Visual Basic]

Public Shared Function FromStream( _

ByVal stream As Stream _

) As C1PrintDocument

[C#]

public static C1PrintDocument FromStream(

Stream stream

);

[Delphi]

public class function FromStream(

stream: Stream

): C1PrintDocument;

Parameters

stream

A Stream that contains the data for the C1PrintDocument.

Return Value

The C1PrintDocument that was created.


C1PrintDocument.Generate Method

C1PrintDocument.Generate Method

Generates a document.

[Visual Basic]

Public Function Generate() As Boolean

[C#]

public bool Generate()

[Delphi]

public function Generate(): Boolean;

Return Value

Returns True if no error occurs.


C1PrintDocument.IsInlineStarted Method

C1PrintDocument.IsInlineStarted Method

Indicates whether the inline rendering started.

[Visual Basic]

Public Function IsInlineStarted() As Boolean

[C#]

public bool IsInlineStarted()

[Delphi]

public function IsInlineStarted(): Boolean;


C1PrintDocument.NewColumn Method

C1PrintDocument.NewColumn Method

Begins a new column, if current column is last on page then new page will be started.

[Visual Basic]

Public Function NewColumn() As Boolean

[C#]

public bool NewColumn()

[Delphi]

public function NewColumn(): Boolean;

Return Value

Returns True if no error occurs.


C1PrintDocument.NewLine Method

C1PrintDocument.NewLine Method

Begins a new line in inline flow, can be used only if current stacking is inline flow.

[Visual Basic]

Public Function NewLine() As Boolean

[C#]

public bool NewLine()

[Delphi]

public function NewLine(): Boolean;

Return Value

Returns True if no error occurs.


C1PrintDocument.NewPage Method

C1PrintDocument.NewPage Method

Creates a new page.

[Visual Basic]

Public Function NewPage( _

ByVal pageLayout As PageLayout, _

ByVal direction As PageDirectionEnum _

) As Boolean

[C#]

public bool NewPage(

PageLayout pageLayout,

PageDirectionEnum direction

);

[Delphi]

public function NewPage(

pageLayout: PageLayout;

direction: PageDirectionEnum

): Boolean;

Parameters

pageLayout

Specifies a layout which will be used for all following pages.

direction

Indicates which page must be added - vertical or horizontal.

Return Value

Returns True if no error occurs.


C1PrintDocument.RenderBlock Method

C1PrintDocument.RenderBlock Method

Adds render object to the document and resolves it. This method can be used only if document is generated with using of the StartDoc() / EndDoc() methods.

[Visual Basic]

Public Function RenderBlock( _

ByVal ro As RenderObject _

) As Boolean

[C#]

public bool RenderBlock(

RenderObject ro

);

[Delphi]

public function RenderBlock(

ro: RenderObject

): Boolean;

Parameters

ro

RenderObject object to process.

Return Value

Returns True if no error occurs.


C1PrintDocument.RenderBlockImage Method

C1PrintDocument.RenderBlockImage Method

Overload List

Renders the Image.

[Visual Basic] Overloads Public Function RenderBlockImage(Image) As Boolean

[C#] public bool RenderBlockImage(Image);

[Delphi] public function RenderBlockImage(Image) : Boolean; overload;

Renders the Image.

[Visual Basic] Overloads Public Function RenderBlockImage(Image, Object, Object, ImageAlign) As Boolean

[C#] public bool RenderBlockImage(Image, object, object, ImageAlign);

[Delphi] public function RenderBlockImage(Image; Object; Object; ImageAlign) : Boolean; overload;

Renders the Image.

[Visual Basic] Overloads Public Function RenderBlockImage(Image, Object, Object, Style) As Boolean

[C#] public bool RenderBlockImage(Image, object, object, Style);

[Delphi] public function RenderBlockImage(Image; Object; Object; Style) : Boolean; overload;


C1PrintDocument.RenderBlockImage Method (Image)

C1PrintDocument.RenderBlockImage Method (Image)

Previous Next

Renders the Image.

[Visual Basic]

Overloads Public Function RenderBlockImage( _

ByVal image As Image _

) As Boolean

[C#]

public bool RenderBlockImage(

Image image

);

[Delphi]

public function RenderBlockImage(

image: Image

): Boolean; overload;

Parameters

image

Image to render.

Return Value

Returns True if no error occurs.


C1PrintDocument.RenderBlockImage Method (Image, Object, Object, ImageAlign)

C1PrintDocument.RenderBlockImage Method (Image, Object, Object, ImageAlign)

Previous Next

Renders the Image.

[Visual Basic]

Overloads Public Function RenderBlockImage( _

ByVal image As Image, _

ByVal width As Object, _

ByVal height As Object, _

ByVal imageAlign As ImageAlign _

) As Boolean

[C#]

public bool RenderBlockImage(

Image image,

object width,

object height,

ImageAlign imageAlign

);

[Delphi]

public function RenderBlockImage(

image: Image;

width: Object;

height: Object;

imageAlign: ImageAlign

): Boolean; overload;

Parameters

image

Image to render.

width

Width of an image box. If null then autowidth.

height

Height of an image box. If null then autoheight.

imageAlign

Alignment of an image.

Return Value

Returns True if no error occurs.


C1PrintDocument.RenderBlockImage Method (Image, Object, Object, Style)

C1PrintDocument.RenderBlockImage Method (Image, Object, Object, Style)

Previous Next

Renders the Image.

[Visual Basic]

Overloads Public Function RenderBlockImage( _

ByVal image As Image, _

ByVal width As Object, _

ByVal height As Object, _

ByVal style As Style _

) As Boolean

[C#]

public bool RenderBlockImage(

Image image,

object width,

object height,

Style style

);

[Delphi]

public function RenderBlockImage(

image: Image;

width: Object;

height: Object;

style: Style

): Boolean; overload;

Parameters

image

Image to render.

width

Width of an image box. If null then autowidth.

height

Height of an image box. If null then autoheight.

style

Style of the image. If null then the style for an image of document is used.

Return Value

Returns True if no error occurs.


C1PrintDocument.RenderBlockRichText Method

C1PrintDocument.RenderBlockRichText Method

Overload List

Renders the RTF text with parent width and autoheight.

[Visual Basic] Overloads Public Function RenderBlockRichText(String) As Boolean

[C#] public bool RenderBlockRichText(string);

[Delphi] public function RenderBlockRichText(String) : Boolean; overload;

Renders the RTF text with autoheight.

[Visual Basic] Overloads Public Function RenderBlockRichText(String, Object) As Boolean

[C#] public bool RenderBlockRichText(string, object);

[Delphi] public function RenderBlockRichText(String; Object) : Boolean; overload;

Renders the RTF text.

[Visual Basic] Overloads Public Function RenderBlockRichText(String, Object, Object, Style) As Boolean

[C#] public bool RenderBlockRichText(string, object, object, Style);

[Delphi] public function RenderBlockRichText(String; Object; Object; Style) : Boolean; overload;


C1PrintDocument.RenderBlockRichText Method (String)

C1PrintDocument.RenderBlockRichText Method (String)

Previous Next

Renders the RTF text with parent width and autoheight.

[Visual Basic]

Overloads Public Function RenderBlockRichText( _

ByVal rtf As String _

) As Boolean

[C#]

public bool RenderBlockRichText(

string rtf

);

[Delphi]

public function RenderBlockRichText(

rtf: String

): Boolean; overload;

Parameters

rtf

Text to render, can be plain text.

Return Value

Returns True if no error occurs.


C1PrintDocument.RenderBlockRichText Method (String, Object)

C1PrintDocument.RenderBlockRichText Method (String, Object)

Previous Next

Renders the RTF text with autoheight.

[Visual Basic]

Overloads Public Function RenderBlockRichText( _

ByVal rtf As String, _

ByVal width As Object _

) As Boolean

[C#]

public bool RenderBlockRichText(

string rtf,

object width

);

[Delphi]

public function RenderBlockRichText(

rtf: String;

width: Object

): Boolean; overload;

Parameters

rtf

Text to render, can be plain text.

width

If null then parent width will be used.

Return Value

Returns True if no error occurs.


C1PrintDocument.RenderBlockRichText Method (String, Object, Object, Style)

C1PrintDocument.RenderBlockRichText Method (String, Object, Object, Style)

Previous Next

Renders the RTF text.

[Visual Basic]

Overloads Public Function RenderBlockRichText( _

ByVal rtf As String, _

ByVal width As Object, _

ByVal height As Object, _

ByVal style As Style _

) As Boolean

[C#]

public bool RenderBlockRichText(

string rtf,

object width,

object height,

Style style

);

[Delphi]

public function RenderBlockRichText(

rtf: String;

width: Object;

height: Object;

style: Style

): Boolean; overload;

Parameters

rtf

Text to render, can be plain text.

width

If null then parent width will be used.

height

If null then autoheight will be used.

style

Style of object.

Return Value

Returns True if no error occurs.


C1PrintDocument.RenderDirect Method

C1PrintDocument.RenderDirect Method

Overload List

Addes render object to the document and resolves it in a specified position. This method can be used only if document is generated with using of the StartDoc() / EndDoc() methods.

[Visual Basic] Overloads Public Function RenderDirect(Unit, Unit, RenderObject) As Boolean

[C#] public bool RenderDirect(Unit, Unit, RenderObject);

[Delphi] public function RenderDirect(Unit; Unit; RenderObject) : Boolean; overload;

Addes render object to the document and resolves it in a specified position. This method can be used only if document is generated with using of the StartDoc() / EndDoc() methods.

[Visual Basic] Overloads Public Function RenderDirect(Unit, Unit, RenderObject, Object, Object) As Boolean

[C#] public bool RenderDirect(Unit, Unit, RenderObject, object, object);

[Delphi] public function RenderDirect(Unit; Unit; RenderObject; Object; Object) : Boolean; overload;


C1PrintDocument.RenderDirect Method (Unit, Unit, RenderObject)

C1PrintDocument.RenderDirect Method (Unit, Unit, RenderObject)

Previous Next

Addes render object to the document and resolves it in a specified position. This method can be used only if document is generated with using of the StartDoc() / EndDoc() methods.

[Visual Basic]

Overloads Public Function RenderDirect( _

ByVal x As Unit, _

ByVal y As Unit, _

ByVal ro As RenderObject _

) As Boolean

[C#]

public bool RenderDirect(

Unit x,

Unit y,

RenderObject ro

);

[Delphi]

public function RenderDirect(

x: Unit;

y: Unit;

ro: RenderObject

): Boolean; overload;

Parameters

x

X coordinate of object, can't be auto.

y

Y coordinate of object, can't be auto.

ro

RenderObject object to render.

Return Value

Returns True if no error occurs.


C1PrintDocument.RenderDirect Method (Unit, Unit, RenderObject, Object, Object)

C1PrintDocument.RenderDirect Method (Unit, Unit, RenderObject, Object, Object)

Previous Next

Addes render object to the document and resolves it in a specified position. This method can be used only if document is generated with using of the StartDoc() / EndDoc() methods.

[Visual Basic]

Overloads Public Function RenderDirect( _

ByVal x As Unit, _

ByVal y As Unit, _

ByVal ro As RenderObject, _

ByVal width As Object, _

ByVal height As Object _

) As Boolean

[C#]

public bool RenderDirect(

Unit x,

Unit y,

RenderObject ro,

object width,

object height

);

[Delphi]

public function RenderDirect(

x: Unit;

y: Unit;

ro: RenderObject;

width: Object;

height: Object

): Boolean; overload;

Parameters

x

X coordinate of object, can't be auto.

y

Y coordinate of object, can't be auto.

ro

RenderObject object to render.

width

Width of object, if null then autowidth.

height

Height of object, if null then autoheight.

Return Value

Returns True if no error occurs.


C1PrintDocument.RenderDirectImage Method

C1PrintDocument.RenderDirectImage Method

Overload List

Renders an image in specified position.

[Visual Basic] Overloads Public Function RenderDirectImage(Unit, Unit, Image) As Boolean

[C#] public bool RenderDirectImage(Unit, Unit, Image);

[Delphi] public function RenderDirectImage(Unit; Unit; Image) : Boolean; overload;

Renders an image in specified position.

[Visual Basic] Overloads Public Function RenderDirectImage(Unit, Unit, Image, Object, Object, ImageAlign) As Boolean

[C#] public bool RenderDirectImage(Unit, Unit, Image, object, object, ImageAlign);

[Delphi] public function RenderDirectImage(Unit; Unit; Image; Object; Object; ImageAlign) : Boolean; overload;

Renders an image in specified position.

[Visual Basic] Overloads Public Function RenderDirectImage(Unit, Unit, Image, Object, Object, Style) As Boolean

[C#] public bool RenderDirectImage(Unit, Unit, Image, object, object, Style);

[Delphi] public function RenderDirectImage(Unit; Unit; Image; Object; Object; Style) : Boolean; overload;


C1PrintDocument.RenderDirectImage Method (Unit, Unit, Image)

C1PrintDocument.RenderDirectImage Method (Unit, Unit, Image)

Previous Next

Renders an image in specified position.

[Visual Basic]

Overloads Public Function RenderDirectImage( _

ByVal x As Unit, _

ByVal y As Unit, _

ByVal image As Image _

) As Boolean

[C#]

public bool RenderDirectImage(

Unit x,

Unit y,

Image image

);

[Delphi]

public function RenderDirectImage(

x: Unit;

y: Unit;

image: Image

): Boolean; overload;

Parameters

x

X coordinate of image, can't be auto.

y

Y coordinate of image, can't be auto.

image

Image to render.

Return Value

Returns True if no error occurs.


C1PrintDocument.RenderDirectImage Method (Unit, Unit, Image, Object, Object, ImageAlign)

C1PrintDocument.RenderDirectImage Method (Unit, Unit, Image, Object, Object, ImageAlign)

Previous Next

Renders an image in specified position.

[Visual Basic]

Overloads Public Function RenderDirectImage( _

ByVal x As Unit, _

ByVal y As Unit, _

ByVal image As Image, _

ByVal width As Object, _

ByVal height As Object, _

ByVal imageAlign As ImageAlign _

) As Boolean

[C#]

public bool RenderDirectImage(

Unit x,

Unit y,

Image image,

object width,

object height,

ImageAlign imageAlign

);

[Delphi]

public function RenderDirectImage(

x: Unit;

y: Unit;

image: Image;

width: Object;

height: Object;

imageAlign: ImageAlign

): Boolean; overload;

Parameters

x

X coordinate of image, can't be auto.

y

Y coordinate of image, can't be auto.

image

Image to render.

width

Width of image, if null then autowidth.

height

Height of image, if null then autoheight.

imageAlign

Alignment of an image.

Return Value

Returns True if no error occurs.


C1PrintDocument.RenderDirectImage Method (Unit, Unit, Image, Object, Object, Style)

C1PrintDocument.RenderDirectImage Method (Unit, Unit, Image, Object, Object, Style)

Previous Next

Renders an image in specified position.

[Visual Basic]

Overloads Public Function RenderDirectImage( _

ByVal x As Unit, _

ByVal y As Unit, _

ByVal image As Image, _

ByVal width As Object, _

ByVal height As Object, _

ByVal style As Style _

) As Boolean

[C#]

public bool RenderDirectImage(

Unit x,

Unit y,

Image image,

object width,

object height,

Style style

);

[Delphi]

public function RenderDirectImage(

x: Unit;

y: Unit;

image: Image;

width: Object;

height: Object;

style: Style

): Boolean; overload;

Parameters

x

X coordinate of image, can't be auto.

y

Y coordinate of image, can't be auto.

image

Image to render.

width

Width of image, if null then autowidth.

height

Height of image, if null then autoheight.

style

Style of image, can be null.

Return Value

Returns True if no error occurs.


C1PrintDocument.RenderDirectRichText Method

C1PrintDocument.RenderDirectRichText Method

Overload List

Renders an rich text in specified position, the heigh of text will be calculated automatically.

[Visual Basic] Overloads Public Function RenderDirectRichText(Unit, Unit, String, Object) As Boolean

[C#] public bool RenderDirectRichText(Unit, Unit, string, object);

[Delphi] public function RenderDirectRichText(Unit; Unit; String; Object) : Boolean; overload;

Renders a rich text in specified position.

[Visual Basic] Overloads Public Function RenderDirectRichText(Unit, Unit, String, Object, Object, Style) As Boolean

[C#] public bool RenderDirectRichText(Unit, Unit, string, object, object, Style);

[Delphi] public function RenderDirectRichText(Unit; Unit; String; Object; Object; Style) : Boolean; overload;


C1PrintDocument.RenderDirectRichText Method (Unit, Unit, String, Object)

C1PrintDocument.RenderDirectRichText Method (Unit, Unit, String, Object)

Previous Next

Renders an rich text in specified position, the heigh of text will be calculated automatically.

[Visual Basic]

Overloads Public Function RenderDirectRichText( _

ByVal x As Unit, _

ByVal y As Unit, _

ByVal rtf As String, _

ByVal width As Object _

) As Boolean

[C#]

public bool RenderDirectRichText(

Unit x,

Unit y,

string rtf,

object width

);

[Delphi]

public function RenderDirectRichText(

x: Unit;

y: Unit;

rtf: String;

width: Object

): Boolean; overload;

Parameters

x

X coordinate of text area, can't be auto.

y

Y coordinate of text area, can't be auto.

rtf

Rich text to render.

width

Width of rich text, can't be null or auto because the RenderRichText does not support autowidth.

Return Value

Returns True if no error occurs.


C1PrintDocument.RenderDirectRichText Method (Unit, Unit, String, Object, Object, Style)

C1PrintDocument.RenderDirectRichText Method (Unit, Unit, String, Object, Object, Style)

Previous Next

Renders a rich text in specified position.

[Visual Basic]

Overloads Public Function RenderDirectRichText( _

ByVal x As Unit, _

ByVal y As Unit, _

ByVal rtf As String, _

ByVal width As Object, _

ByVal height As Object, _

ByVal style As Style _

) As Boolean

[C#]

public bool RenderDirectRichText(

Unit x,

Unit y,

string rtf,

object width,

object height,

Style style

);

[Delphi]

public function RenderDirectRichText(

x: Unit;

y: Unit;

rtf: String;

width: Object;

height: Object;

style: Style

): Boolean; overload;

Parameters

x

X coordinate of text area, can't be auto.

y

Y coordinate of text area, can't be auto.

rtf

Rich text to render.

width

Width of text area, can't be null or auto because the RenderRichText does not support autowidth.

height

Height of text area, if null then autoheight.

style

Style of rich text, can be null.

Return Value

Returns True if no error occurs.


C1PrintDocument.RenderDirectText Method

C1PrintDocument.RenderDirectText Method

Overload List

Renders a text in specified position.

[Visual Basic] Overloads Public Function RenderDirectText(Unit, Unit, String, Object, Font, Color, AlignHorzEnum) As Boolean

[C#] public bool RenderDirectText(Unit, Unit, string, object, Font, Color, AlignHorzEnum);

[Delphi] public function RenderDirectText(Unit; Unit; String; Object; Font; Color; AlignHorzEnum) : Boolean; overload;

Renders a text in specified position.

[Visual Basic] Overloads Public Function RenderDirectText(Unit, Unit, String, Object, Object, Style) As Boolean

[C#] public bool RenderDirectText(Unit, Unit, string, object, object, Style);

[Delphi] public function RenderDirectText(Unit; Unit; String; Object; Object; Style) : Boolean; overload;


C1PrintDocument.RenderDirectText Method (Unit, Unit, String, Object, Font, Color, AlignHorzEnum)

C1PrintDocument.RenderDirectText Method (Unit, Unit, String, Object, Font, Color, AlignHorzEnum)

Previous Next

Renders a text in specified position.

[Visual Basic]

Overloads Public Function RenderDirectText( _

ByVal x As Unit, _

ByVal y As Unit, _

ByVal text As String, _

ByVal width As Object, _

ByVal font As Font, _

ByVal textColor As Color, _

ByVal horzAlign As AlignHorzEnum _

) As Boolean

[C#]

public bool RenderDirectText(

Unit x,

Unit y,

string text,

object width,

Font font,

Color textColor,

AlignHorzEnum horzAlign

);

[Delphi]

public function RenderDirectText(

x: Unit;

y: Unit;

text: String;

width: Object;

font: Font;

textColor: Color;

horzAlign: AlignHorzEnum

): Boolean; overload;

Parameters

x

X coordinate of text area, can't be auto.

y

Y coordinate of text area, can't be auto.

text

Text to render.

width

Width of text area, if null then autowidth.

font

Font of text.

textColor

Color of text.

horzAlign

Horizontal alignment of text.

Return Value

Returns True if no error occurs.


C1PrintDocument.RenderDirectText Method (Unit, Unit, String, Object, Object, Style)

C1PrintDocument.RenderDirectText Method (Unit, Unit, String, Object, Object, Style)

Previous Next

Renders a text in specified position.

[Visual Basic]

Overloads Public Function RenderDirectText( _

ByVal x As Unit, _

ByVal y As Unit, _

ByVal text As String, _

ByVal width As Object, _

ByVal height As Object, _

ByVal style As Style _

) As Boolean

[C#]

public bool RenderDirectText(

Unit x,

Unit y,

string text,

object width,

object height,

Style style

);

[Delphi]

public function RenderDirectText(

x: Unit;

y: Unit;

text: String;

width: Object;

height: Object;

style: Style

): Boolean; overload;

Parameters

x

X coordinate of text area, can't be auto.

y

Y coordinate of text area, can't be auto.

text

Text to render.

width

Width of text area, if null then autowidth.

height

Height of text area, if null then autoheight.

style

Style of text, can be null.

Return Value

Returns True if no error occurs.


C1PrintDocument.RenderInlineBegin Method

C1PrintDocument.RenderInlineBegin Method

Begins the rendering of paragraph, you can omit this method and call RenderInlineTextXXX methods directly(), but this method allows to define the style of inline paragraph. If inline rendering already started the current paragraph will be closed and new will begin.

[Visual Basic]

Public Function RenderInlineBegin( _

ByVal style As Style, _

ByVal width As Object, _

ByVal height As Object _

) As Boolean

[C#]

public bool RenderInlineBegin(

Style style,

object width,

object height

);

[Delphi]

public function RenderInlineBegin(

style: Style;

width: Object;

height: Object

): Boolean;

Parameters

style

Style of beginnig paragraph.

width

Width of an image box. If null then autowidth.

height

Height of an image box. If null then autoheight.

Return Value

Returns True if no error occurs.


C1PrintDocument.RenderInlineEnd Method

C1PrintDocument.RenderInlineEnd Method

Finishes the inline rendering.

[Visual Basic]

Public Sub RenderInlineEnd()

[C#]

public void RenderInlineEnd()

[Delphi]

public procedure RenderInlineEnd();


C1PrintDocument.SelectBestMeasurementDevice Method

C1PrintDocument.SelectBestMeasurementDevice Method

Selects the optimal device which can be used for MeasurementGraphics, it search for printer with "square" dpi (DpiX == DpiY) large or equal than 300, if such printer does not exist then screen Graphics is used. Parameters of selected device can be read from MeasurementXXX properties.

[Visual Basic]

Public Shared Sub SelectBestMeasurementDevice()

[C#]

public static void SelectBestMeasurementDevice()

[Delphi]

public class procedure SelectBestMeasurementDevice();


C1PrintDocument.StartDoc Method

C1PrintDocument.StartDoc Method

Starts a new document.

[Visual Basic]

Public Function StartDoc() As Boolean

[C#]

public bool StartDoc()

[Delphi]

public function StartDoc(): Boolean;


C1PrintDocument.ToRU Method

C1PrintDocument.ToRU Method

Converts a value from specified units of measurement in the "ResolvedUnitType" units.

[Visual Basic]

Public Function ToRU( _

ByVal value As Double, _

ByVal srcType As UnitTypeEnum, _

ByVal srcDpi As Single _

) As Double

[C#]

public double ToRU(

double value,

UnitTypeEnum srcType,

float srcDpi

);

[Delphi]

public function ToRU(

value: Double;

srcType: UnitTypeEnum;

srcDpi: Single

): Double;

Parameters

value

The source value.

srcType

srcDpi

Return Value

Returns the converted value in "ResolvedUnitType" units.


C1PrintDocument Events

C1PrintDocument Events

The events of the C1PrintDocument class are listed here. For a complete list of C1PrintDocument class members, see the C1PrintDocument Members topic.

Public Events

BusyStateChanged | Occurs when the value of the BusyState was changed.
DefaultUnitChanged | Occurs when the value of the DefaultUnit was changed.
DocumentEnded | Occurs when the document building is ended.
DocumentStarting | Occurs when the document building is started.
GenerateDocument | Allows user to build document content in event handler.
InputValueChanged | Occurs when the value of RenderInputBase object within document is changed.
LongOperation | Indicate the progress of document generation.
PageAdded | Occurs only during generating of the document, when generating of page of document is finished, page is added to the Pages collection and switch to other page is occured.
PageChanged | Occurs only during generating of the document, when page of document which was added to document is changed, for example when page numbering is changed or PageCount property is updated for page.
PageConfigure | Occurs when a new empty page is created and added to the document, the page is added to the Pages collection but *not resolved*, use this method only for changing layout of page.
PageDeleted | Occurs when page is removed from document (from Pages collection). This event can't occurs during generating.
PagesClear | Occurs when pages' collection is cleared.
PageUpdated | Occurs when page of document is changed. This event occurs very often while document is generating, it is called each time when a fragment of object is added to page or removed from page.
ResolvedUnitChanged | Occurs when the value of the ResolvedUnit was changed.


C1PrintDocument.BusyStateChanged Event

C1PrintDocument.BusyStateChanged Event

Occurs when the value of the BusyState was changed.

[Visual Basic]

Public Event BusyStateChanged As EventHandler

[C#]

public event EventHandlerBusyStateChanged

[Delphi]

public property BusyStateChanged: EventHandler read remove_BusyStateChanged write add_BusyStateChanged;


C1PrintDocument.DefaultUnitChanged Event

C1PrintDocument.DefaultUnitChanged Event

Occurs when the value of the DefaultUnit was changed.

[Visual Basic]

Public Event DefaultUnitChanged As EventHandler

[C#]

public event EventHandlerDefaultUnitChanged

[Delphi]

public property DefaultUnitChanged: EventHandler read remove_DefaultUnitChanged write add_DefaultUnitChanged;


C1PrintDocument.DocumentEnded Event

C1PrintDocument.DocumentEnded Event

Occurs when the document building is ended.

[Visual Basic]

Public Event DocumentEnded As EventHandler

[C#]

public event EventHandlerDocumentEnded

[Delphi]

public property DocumentEnded: EventHandler read remove_DocumentEnded write add_DocumentEnded;


C1PrintDocument.DocumentStarting Event

C1PrintDocument.DocumentStarting Event

Occurs when the document building is started.

[Visual Basic]

Public Event DocumentStarting As EventHandler

[C#]

public event EventHandlerDocumentStarting

[Delphi]

public property DocumentStarting: EventHandler read remove_DocumentStarting write add_DocumentStarting;


C1PrintDocument.GenerateDocument Event

C1PrintDocument.GenerateDocument Event

Allows user to build document content in event handler.

[Visual Basic]

Public Event GenerateDocument As EventHandler

[C#]

public event EventHandlerGenerateDocument

[Delphi]

public property GenerateDocument: EventHandler read remove_GenerateDocument write add_GenerateDocument;


C1PrintDocument.InputValueChanged Event

C1PrintDocument.InputValueChanged Event

Occurs when the value of RenderInputBase object within document is changed.

[Visual Basic]

Public Event InputValueChanged As InputValueChangedEventHandler

[C#]

public event InputValueChangedEventHandlerInputValueChanged

[Delphi]

public property InputValueChanged: InputValueChangedEventHandler read remove_InputValueChanged write add_InputValueChanged;


C1PrintDocument.LongOperation Event

C1PrintDocument.LongOperation Event

Indicate the progress of document generation.

[Visual Basic]

Public Event LongOperation As LongOperationEventHandler

[C#]

public event LongOperationEventHandlerLongOperation

[Delphi]

public property LongOperation: LongOperationEventHandler read remove_LongOperation write add_LongOperation;


C1PrintDocument.PageAdded Event

C1PrintDocument.PageAdded Event

Occurs only during generating of the document, when generating of page of document is finished, page is added to the Pages collection and switch to other page is occured.

[Visual Basic]

Public Event PageAdded As PageEventHandler

[C#]

public event PageEventHandlerPageAdded

[Delphi]

public property PageAdded: PageEventHandler read remove_PageAdded write add_PageAdded;


C1PrintDocument.PageChanged Event

C1PrintDocument.PageChanged Event

Occurs only during generating of the document, when page of document which was added to document is changed, for example when page numbering is changed or PageCount property is updated for page.

[Visual Basic]

Public Event PageChanged As PageEventHandler

[C#]

public event PageEventHandlerPageChanged

[Delphi]

public property PageChanged: PageEventHandler read remove_PageChanged write add_PageChanged;


C1PrintDocument.PageConfigure Event

C1PrintDocument.PageConfigure Event

Occurs when a new empty page is created and added to the document, the page is added to the Pages collection but *not resolved*, use this method only for changing layout of page.

[Visual Basic]

Public Event PageConfigure As PageConfigureEventHandler

[C#]

public event PageConfigureEventHandlerPageConfigure

[Delphi]

public property PageConfigure: PageConfigureEventHandler read remove_PageConfigure write add_PageConfigure;


C1PrintDocument.PageDeleted Event

C1PrintDocument.PageDeleted Event

Occurs when page is removed from document (from Pages collection). This event can't occurs during generating.

[Visual Basic]

Public Event PageDeleted As PageEventHandler

[C#]

public event PageEventHandlerPageDeleted

[Delphi]

public property PageDeleted: PageEventHandler read remove_PageDeleted write add_PageDeleted;


C1PrintDocument.PagesClear Event

C1PrintDocument.PagesClear Event

Occurs when pages' collection is cleared.

[Visual Basic]

Public Event PagesClear As EventHandler

[C#]

public event EventHandlerPagesClear

[Delphi]

public property PagesClear: EventHandler read remove_PagesClear write add_PagesClear;


C1PrintDocument.PageUpdated Event

C1PrintDocument.PageUpdated Event

Occurs when page of document is changed. This event occurs very often while document is generating, it is called each time when a fragment of object is added to page or removed from page.

[Visual Basic]

Public Event PageUpdated As PageEventHandler

[C#]

public event PageEventHandlerPageUpdated

[Delphi]

public property PageUpdated: PageEventHandler read remove_PageUpdated write add_PageUpdated;


C1PrintDocument.ResolvedUnitChanged Event

C1PrintDocument.ResolvedUnitChanged Event

Occurs when the value of the ResolvedUnit was changed.

[Visual Basic]

Public Event ResolvedUnitChanged As EventHandler

[C#]

public event EventHandlerResolvedUnitChanged

[Delphi]

public property ResolvedUnitChanged: EventHandler read remove_ResolvedUnitChanged write add_ResolvedUnitChanged;


C1PrintOptions Class

C1PrintOptions Class

Describes the set of options controlling how a document's content is to be printed (or previewed).

For a list of all members of this type, see C1PrintOptions Members.

System.Object

C1.C1Preview.C1PrintOptions

[Visual Basic]

Public Class C1PrintOptions

Implements INotifyPropertyChanged

[C#]

public class C1PrintOptions : INotifyPropertyChanged

[Delphi]

type C1PrintOptions = class (TObject, INotifyPropertyChanged);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


C1PrintOptions Members

C1PrintOptions Members

C1PrintOptions overview

Public Properties

AutoPaperSource | Gets or sets the value indicating whether the paper source is selected automatically.
AutoRotate | Gets or sets the value indicating whether pages should be auto-rotated to better fit the paper during printing.
CenterPage | Gets or sets the value indicating whether the page should be centered on paper during printing.
PageScaling | Gets or sets the value indicating the manner in which pages are scaled during printing.


C1PrintOptions Properties

C1PrintOptions Properties

The properties of the C1PrintOptions class are listed here. For a complete list of C1PrintOptions class members, see the C1PrintOptions Members topic.

Public Properties

AutoPaperSource | Gets or sets the value indicating whether the paper source is selected automatically.
AutoRotate | Gets or sets the value indicating whether pages should be auto-rotated to better fit the paper during printing.
CenterPage | Gets or sets the value indicating whether the page should be centered on paper during printing.
PageScaling | Gets or sets the value indicating the manner in which pages are scaled during printing.


C1PrintOptions.AutoPaperSource Property

C1PrintOptions.AutoPaperSource Property

Gets or sets the value indicating whether the paper source is selected automatically.

[Visual Basic]

Public Property AutoPaperSource As Boolean

[C#]

public bool AutoPaperSource {get;set;}

[Delphi]

public property AutoPaperSource: Boolean read get_AutoPaperSource write set_AutoPaperSource;


C1PrintOptions.AutoRotate Property

C1PrintOptions.AutoRotate Property

Gets or sets the value indicating whether pages should be auto-rotated to better fit the paper during printing.

[Visual Basic]

Public Property AutoRotate As Boolean

[C#]

public bool AutoRotate {get;set;}

[Delphi]

public property AutoRotate: Boolean read get_AutoRotate write set_AutoRotate;


C1PrintOptions.CenterPage Property

C1PrintOptions.CenterPage Property

Gets or sets the value indicating whether the page should be centered on paper during printing.

[Visual Basic]

Public Property CenterPage As Boolean

[C#]

public bool CenterPage {get;set;}

[Delphi]

public property CenterPage: Boolean read get_CenterPage write set_CenterPage;


C1PrintOptions.PageScaling Property

C1PrintOptions.PageScaling Property

Gets or sets the value indicating the manner in which pages are scaled during printing.

[Visual Basic]

Public Property PageScaling As PageScalingEnum

[C#]

public PageScalingEnum PageScaling {get;set;}

[Delphi]

public property PageScaling: PageScalingEnum read get_PageScaling write set_PageScaling;


CellSplitBehaviorEnum Enumeration

CellSplitBehaviorEnum Enumeration

Defines various options for the splitting of content of cells.

[Visual Basic]

Public Enum CellSplitBehaviorEnum

[C#]

public enum CellSplitBehaviorEnum

[Delphi]

type CellSplitBehaviorEnum = (Copy, Cut, Split);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
Copy | The content of cell should be copied each time when it splits.
Cut | The content of cell should be cut on first time and displayed only once.
Split | The content of cell should be split.

See Also

C1.C1Preview Namespace


CheckMarkStyleEnum Enumeration

CheckMarkStyleEnum Enumeration

Describes the type of mark which is used in the ScalableCheckBox and RenderInputCheckBoxOptions.

[Visual Basic]

Public Enum CheckMarkStyleEnum

[C#]

public enum CheckMarkStyleEnum

[Delphi]

type CheckMarkStyleEnum = (Cross, Default);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
Default | The default style, like in Windows.
Cross | Like in Microsoft Word.

See Also

C1.C1Preview Namespace


DictionaryIcon Class

DictionaryIcon Class

Represents an icon in dictionary.

For a list of all members of this type, see DictionaryIcon Members.

System.Object

C1.C1Preview.DictionaryItem

C1.C1Preview.DictionaryIcon

[Visual Basic]

Public Class DictionaryIcon

Inherits DictionaryItem

[C#]

public class DictionaryIcon : DictionaryItem

[Delphi]

type DictionaryIcon = class (DictionaryItem);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


DictionaryIcon Members

DictionaryIcon Members

DictionaryIcon overview

Public Properties

Name (inherited from DictionaryItem)

Unique name of item.


DictionaryIcon Properties

DictionaryIcon Properties

The properties of the DictionaryIcon class are listed here. For a complete list of DictionaryIcon class members, see the DictionaryIcon Members topic.

Public Properties

Name (inherited from DictionaryItem)

Unique name of item.


DictionaryImage Class

DictionaryImage Class

Represents an image in dictionary.

For a list of all members of this type, see DictionaryImage Members.

System.Object

C1.C1Preview.DictionaryItem

C1.C1Preview.DictionaryImage

[Visual Basic]

Public Class DictionaryImage

Inherits DictionaryItem

[C#]

public class DictionaryImage : DictionaryItem

[Delphi]

type DictionaryImage = class (DictionaryItem);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


DictionaryImage Members

DictionaryImage Members

DictionaryImage overview

Public Properties

Name (inherited from DictionaryItem)

Unique name of item.


DictionaryImage Properties

DictionaryImage Properties

The properties of the DictionaryImage class are listed here. For a complete list of DictionaryImage class members, see the DictionaryImage Members topic.

Public Properties

Name (inherited from DictionaryItem)

Unique name of item.


DictionaryItem Class

DictionaryItem Class

Base class for all dictionary items.

For a list of all members of this type, see DictionaryItem Members.

System.Object

C1.C1Preview.DictionaryItem

C1.C1Preview.DictionaryIcon

C1.C1Preview.DictionaryImage

[Visual Basic]

MustInherit Public Class DictionaryItem

[C#]

public abstract class DictionaryItem

[Delphi]

type DictionaryItem = class abstract;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


DictionaryItem Members

DictionaryItem Members

DictionaryItem overview

Public Properties

Name

Unique name of item.


DictionaryItem Properties

DictionaryItem Properties

The properties of the DictionaryItem class are listed here. For a complete list of DictionaryItem class members, see the DictionaryItem Members topic.

Public Properties

Name

Unique name of item.


DictionaryItem.Name Property

DictionaryItem.Name Property

Unique name of item.

[Visual Basic]

Public Property Name As String

[C#]

public string Name {get;set;}

[Delphi]

public property Name: String read get_Name write set_Name;


DimensionEnum Enumeration

DimensionEnum Enumeration

Describes the possible dimensions of object.

[Visual Basic]

Public Enum DimensionEnum

[C#]

public enum DimensionEnum

[Delphi]

type DimensionEnum = (Bottom, Default, Height, Left, Right, Top, Width);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
Bottom |
Default |
Height |
Left |
Right |
Top |
Width |

See Also

C1.C1Preview Namespace


DocumentActionEnum Enumeration

DocumentActionEnum Enumeration

Defines the actions which can be used in ActionHandlerPreviewAction object.

[Visual Basic]

Public Enum DocumentActionEnum

[C#]

public enum DocumentActionEnum

[Delphi]

type DocumentActionEnum = (FileOpen, FileSave, GoFirst, GoLast, GoNext, GoPrev, HistoryNext, HistoryPrev, None, PageContinuous, PageFacing, PageFacingContinuous, PageSetup, PageSingle, Print, Reflow);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
FileOpen |
FileSave |
GoFirst |
GoLast |
GoNext |
GoPrev |
HistoryNext |
HistoryPrev |
None |
PageContinuous |
PageFacing |
PageFacingContinuous |
PageSetup |
PageSingle |
Print |
Reflow |

See Also

C1.C1Preview Namespace


DocumentBody Class

DocumentBody Class

Represents the body of document, manages the generating of the document.

For a list of all members of this type, see DocumentBody Members.

System.Object

C1.C1Preview.DocumentBody

[Visual Basic]

Public Class DocumentBody

[C#]

public class DocumentBody

[Delphi]

type DocumentBody = class;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


DocumentBody Members

DocumentBody Members

DocumentBody overview

Public Properties

Document | Returns the C1Preview object containing this object.
Stacking | Stacking rules.


DocumentBody Properties

DocumentBody Properties

The properties of the DocumentBody class are listed here. For a complete list of DocumentBody class members, see the DocumentBody Members topic.

Public Properties

Document | Returns the C1Preview object containing this object.
Stacking | Stacking rules.


DocumentBody.Document Property

DocumentBody.Document Property

Returns the C1Preview object containing this object.

[Visual Basic]

Public ReadOnly Property Document As C1PrintDocument

[C#]

public C1PrintDocument Document {get;}

[Delphi]

public property Document: C1PrintDocument read get_Document;


DocumentBody.Stacking Property

DocumentBody.Stacking Property

Stacking rules.

[Visual Basic]

Public ReadOnly Property Stacking As StackingRulesEnum

[C#]

public StackingRulesEnum Stacking {get;}

[Delphi]

public property Stacking: StackingRulesEnum read get_Stacking;


DocumentCreationMode Enumeration

DocumentCreationMode Enumeration

[Visual Basic]

Public Enum DocumentCreationMode

[C#]

public enum DocumentCreationMode

[Delphi]

type DocumentCreationMode = (Generate, StartEndDoc, Unknown);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
Generate | Document was created with using Generate() method.
StartEndDoc | Document was created with using StartDoc() / EndDoc() methods.
Unknown | Document was not generated, so its creation mode is unknown.

See Also

C1.C1Preview Namespace


DocumentInfo Class

DocumentInfo Class

Represents the common information about the C1Preview: author, subject, creation time and so on.

For a list of all members of this type, see DocumentInfo Members.

System.Object

C1.C1Preview.DocumentInfo

[Visual Basic]

Public Class DocumentInfo

Implements ICloneable

[C#]

public class DocumentInfo : ICloneable

[Delphi]

type DocumentInfo = class (TObject, ICloneable);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


DocumentInfo Members

DocumentInfo Members

DocumentInfo overview

Public Properties

Author | Gets or sets the author of the document.
Comment | Gets or sets the comment.
Company | Gets or sets the company of the author.
CreationTime | Gets or sets the date and time when the document was created.
Creator | Gets or sets the application that created the original document.
Keywords | Gets or sets the keywords for the document.
Manager | Gets or sets the manager of the author.
Operator | Gets or sets the person who last made changes to the document.
Producer | Gets or sets the application that created the document.
RevisionTime | Gets or sets the date and time when the document was last modified.
Subject | Gets or sets the subject of the document.
Title | Gets or sets the title of the document.


DocumentInfo Properties

DocumentInfo Properties

The properties of the DocumentInfo class are listed here. For a complete list of DocumentInfo class members, see the DocumentInfo Members topic.

Public Properties

Author | Gets or sets the author of the document.
Comment | Gets or sets the comment.
Company | Gets or sets the company of the author.
CreationTime | Gets or sets the date and time when the document was created.
Creator | Gets or sets the application that created the original document.
Keywords | Gets or sets the keywords for the document.
Manager | Gets or sets the manager of the author.
Operator | Gets or sets the person who last made changes to the document.
Producer | Gets or sets the application that created the document.
RevisionTime | Gets or sets the date and time when the document was last modified.
Subject | Gets or sets the subject of the document.
Title | Gets or sets the title of the document.


DocumentInfo.Author Property

DocumentInfo.Author Property

Gets or sets the author of the document.

[Visual Basic]

Public Property Author As String

[C#]

public string Author {get;set;}

[Delphi]

public property Author: String read get_Author write set_Author;


DocumentInfo.Comment Property

DocumentInfo.Comment Property

Gets or sets the comment.

[Visual Basic]

Public Property Comment As String

[C#]

public string Comment {get;set;}

[Delphi]

public property Comment: String read get_Comment write set_Comment;


DocumentInfo.Company Property

DocumentInfo.Company Property

Gets or sets the company of the author.

[Visual Basic]

Public Property Company As String

[C#]

public string Company {get;set;}

[Delphi]

public property Company: String read get_Company write set_Company;


DocumentInfo.CreationTime Property

DocumentInfo.CreationTime Property

Gets or sets the date and time when the document was created.

[Visual Basic]

Public Property CreationTime As Date

[C#]

public DateTime CreationTime {get;set;}

[Delphi]

public property CreationTime: DateTime read get_CreationTime write set_CreationTime;


DocumentInfo.Creator Property

DocumentInfo.Creator Property

Gets or sets the application that created the original document.

[Visual Basic]

Public Property Creator As String

[C#]

public string Creator {get;set;}

[Delphi]

public property Creator: String read get_Creator write set_Creator;


DocumentInfo.Keywords Property

DocumentInfo.Keywords Property

Gets or sets the keywords for the document.

[Visual Basic]

Public Property Keywords As String()

[C#]

public string[] Keywords {get;set;}

[Delphi]

public property Keywords: array of String read get_Keywords write set_Keywords;


DocumentInfo.Manager Property

DocumentInfo.Manager Property

Gets or sets the manager of the author.

[Visual Basic]

Public Property Manager As String

[C#]

public string Manager {get;set;}

[Delphi]

public property Manager: String read get_Manager write set_Manager;


DocumentInfo.Operator Property

DocumentInfo.Operator Property

Gets or sets the person who last made changes to the document.

[Visual Basic]

Public Property Operator As String

[C#]

public string Operator {get;set;}

[Delphi]

public property Operator: String read get_Operator write set_Operator;


DocumentInfo.Producer Property

DocumentInfo.Producer Property

Gets or sets the application that created the document.

[Visual Basic]

Public Property Producer As String

[C#]

public string Producer {get;set;}

[Delphi]

public property Producer: String read get_Producer write set_Producer;


DocumentInfo.RevisionTime Property

DocumentInfo.RevisionTime Property

Gets or sets the date and time when the document was last modified.

[Visual Basic]

Public Property RevisionTime As Date

[C#]

public DateTime RevisionTime {get;set;}

[Delphi]

public property RevisionTime: DateTime read get_RevisionTime write set_RevisionTime;


DocumentInfo.Subject Property

DocumentInfo.Subject Property

Gets or sets the subject of the document.

[Visual Basic]

Public Property Subject As String

[C#]

public string Subject {get;set;}

[Delphi]

public property Subject: String read get_Subject write set_Subject;


DocumentInfo.Title Property

DocumentInfo.Title Property

Gets or sets the title of the document.

[Visual Basic]

Public Property Title As String

[C#]

public string Title {get;set;}

[Delphi]

public property Title: String read get_Title write set_Title;


DocumentInfoFields Enumeration

DocumentInfoFields Enumeration

Enumerates fields of DocumentInfo.

[Visual Basic]

Public Enum DocumentInfoFields

[C#]

public enum DocumentInfoFields

[Delphi]

type DocumentInfoFields = (All, Author, Comment, Company, CreationTime, Creator, Keywords, Manager, None, Operator, Producer, RevisionTime, Subject, Title);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
All |
Author |
Comment |
Company |
CreationTime |
Creator |
Keywords |
Manager |
None |
Operator |
Producer |
RevisionTime |
Subject |
Title |

See Also

C1.C1Preview Namespace


DocumentPageLayouts Class

DocumentPageLayouts Class

Describes the page layouts used in document.

For a list of all members of this type, see DocumentPageLayouts Members.

System.Object

C1.C1Preview.DocumentPageLayouts

[Visual Basic]

Public Class DocumentPageLayouts

[C#]

public class DocumentPageLayouts

[Delphi]

type DocumentPageLayouts = class;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


DocumentPageLayouts Members

DocumentPageLayouts Members

DocumentPageLayouts overview

Public Properties

Default | Gets or sets the default page layot of document. This page layout can be overriden in the FirstPage, EventPages, OddPages properties.
EvenPages | Gets or sets the layout for even pages of document.
FirstPage | Gets or sets the layout for first page of document.
OddPages | Gets or sets the layout for odd pages of document.
PrintFooterOnLastPage | Gets or sets value indicating whether the page footer should be printed on last page of document.


DocumentPageLayouts Properties

DocumentPageLayouts Properties

The properties of the DocumentPageLayouts class are listed here. For a complete list of DocumentPageLayouts class members, see the DocumentPageLayouts Members topic.

Public Properties

Default | Gets or sets the default page layot of document. This page layout can be overriden in the FirstPage, EventPages, OddPages properties.
EvenPages | Gets or sets the layout for even pages of document.
FirstPage | Gets or sets the layout for first page of document.
OddPages | Gets or sets the layout for odd pages of document.
PrintFooterOnLastPage | Gets or sets value indicating whether the page footer should be printed on last page of document.


DocumentPageLayouts.Default Property

DocumentPageLayouts.Default Property

Gets or sets the default page layot of document. This page layout can be overriden in the FirstPage, EventPages, OddPages properties.

[Visual Basic]

Public Property Default As PageLayout

[C#]

public PageLayout Default {get;set;}

[Delphi]

public property Default: PageLayout read get_Default write set_Default;


DocumentPageLayouts.EvenPages Property

DocumentPageLayouts.EvenPages Property

Gets or sets the layout for even pages of document.

[Visual Basic]

Public Property EvenPages As PageLayout

[C#]

public PageLayout EvenPages {get;set;}

[Delphi]

public property EvenPages: PageLayout read get_EvenPages write set_EvenPages;


DocumentPageLayouts.FirstPage Property

DocumentPageLayouts.FirstPage Property

Gets or sets the layout for first page of document.

[Visual Basic]

Public Property FirstPage As PageLayout

[C#]

public PageLayout FirstPage {get;set;}

[Delphi]

public property FirstPage: PageLayout read get_FirstPage write set_FirstPage;


DocumentPageLayouts.OddPages Property

DocumentPageLayouts.OddPages Property

Gets or sets the layout for odd pages of document.

[Visual Basic]

Public Property OddPages As PageLayout

[C#]

public PageLayout OddPages {get;set;}

[Delphi]

public property OddPages: PageLayout read get_OddPages write set_OddPages;


DocumentPageLayouts.PrintFooterOnLastPage Property

DocumentPageLayouts.PrintFooterOnLastPage Property

Gets or sets value indicating whether the page footer should be printed on last page of document.

[Visual Basic]

Public Property PrintFooterOnLastPage As Boolean

[C#]

public bool PrintFooterOnLastPage {get;set;}

[Delphi]

public property PrintFooterOnLastPage: Boolean read get_PrintFooterOnLastPage write set_PrintFooterOnLastPage;


DrawingFlagsEnum Enumeration

DrawingFlagsEnum Enumeration

Defines flags which can be used by object for managing its painting.

[Visual Basic]

Public Enum DrawingFlagsEnum

[C#]

public enum DrawingFlagsEnum

[Delphi]

type DrawingFlagsEnum = (BeginHyperlink, ContentIsEmpty, None, OwnsChildDrawing, SetClipping, UseGdiDrawing);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name

Description

BeginHyperlink

ContentIsEmpty

If specified then the object will not be painted.

None

OwnsChildDrawing

SetClipping

Clipping will be defined before painting.

UseGdiDrawing

The GDI will be used for drawing, in this case the object must override method:

protected virtual void InternalDraw(GraphicsUtils.GdiDc dc, RectangleD boundsRect, RectangleD drawingBoundsRect);

If this flag not specified then the GDI+ will be used and object must override method:

protected virtual void InternalDraw(Graphics graphics, RectangleD boundsRect, RectangleD drawingBoundsRect);

See Also

C1.C1Preview Namespace


EllipsePartProps Class

EllipsePartProps Class

Represents the properties of shape which is a part of ellipse - arc or pie.

For a list of all members of this type, see EllipsePartProps Members.

System.Object

C1.C1Preview.ShapeProps

C1.C1Preview.RectangleProps

C1.C1Preview.EllipsePartProps

[Visual Basic]

Public Class EllipsePartProps

Inherits RectangleProps

[C#]

public class EllipsePartProps : RectangleProps

[Delphi]

type EllipsePartProps = class (RectangleProps);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


EllipsePartProps Members

EllipsePartProps Members

EllipsePartProps overview

Public Properties

StartAngle | Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
SweepAngle | Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.


EllipsePartProps Properties

EllipsePartProps Properties

The properties of the EllipsePartProps class are listed here. For a complete list of EllipsePartProps class members, see the EllipsePartProps Members topic.

Public Properties

StartAngle | Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.
SweepAngle | Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.


EllipsePartProps.StartAngle Property

EllipsePartProps.StartAngle Property

Angle measured in degrees clockwise from the x-axis to the first side of the pie shape.

[Visual Basic]

Public Property StartAngle As Single

[C#]

public float StartAngle {get;set;}

[Delphi]

public property StartAngle: Single read get_StartAngle write set_StartAngle;


EllipsePartProps.SweepAngle Property

EllipsePartProps.SweepAngle Property

Angle measured in degrees clockwise from the startAngle parameter to the second side of the pie shape.

[Visual Basic]

Public Property SweepAngle As Single

[C#]

public float SweepAngle {get;set;}

[Delphi]

public property SweepAngle: Single read get_SweepAngle write set_SweepAngle;


EmbeddedFont Class

EmbeddedFont Class

Represents the font embedded in the C1PrintDocument.

For a list of all members of this type, see EmbeddedFont Members.

System.Object

C1.C1Preview.EmbeddedFont

[Visual Basic]

Public Class EmbeddedFont

Implements IDisposable

[C#]

public class EmbeddedFont : IDisposable

[Delphi]

type EmbeddedFont = class (TObject, IDisposable);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


EmbeddedFont Members

EmbeddedFont Members

EmbeddedFont overview

Public Properties

FontName

Name of embedded font.

Public Methods

GetFontFamily

Get the FontFamily object for this embedded object.


EmbeddedFont Properties

EmbeddedFont Properties

The properties of the EmbeddedFont class are listed here. For a complete list of EmbeddedFont class members, see the EmbeddedFont Members topic.

Public Properties

FontName

Name of embedded font.


EmbeddedFont.FontName Property

EmbeddedFont.FontName Property

Name of embedded font.

[Visual Basic]

Public ReadOnly Property FontName As String

[C#]

public string FontName {get;}

[Delphi]

public property FontName: String read get_FontName;


EmbeddedFont Methods

EmbeddedFont Methods

The methods of the EmbeddedFont class are listed here. For a complete list of EmbeddedFont class members, see the EmbeddedFont Members topic.

Public Methods

GetFontFamily

Get the FontFamily object for this embedded object.


EmbeddedFont.GetFontFamily Method

EmbeddedFont.GetFontFamily Method

Get the FontFamily object for this embedded object.

[Visual Basic]

Public Function GetFontFamily() As FontFamily

[C#]

public FontFamily GetFontFamily()

[Delphi]

public function GetFontFamily(): FontFamily;

Return Value

Returns the created FontFamily object.


EmbeddedFontCollection Class

EmbeddedFontCollection Class

Collection of EmbeddedFont objects.

For a list of all members of this type, see EmbeddedFontCollection Members.

System.Object

System.Collections.CollectionBase

C1.C1Preview.EmbeddedFontCollection

[Visual Basic]

Public Class EmbeddedFontCollection

Inherits CollectionBase

[C#]

public class EmbeddedFontCollection : CollectionBase

[Delphi]

type EmbeddedFontCollection = class (CollectionBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


EmbeddedFontCollection Members

EmbeddedFontCollection Members

EmbeddedFontCollection overview

Public Methods

BuildFont

Builds the Font object from string.


EmbeddedFontCollection Methods

EmbeddedFontCollection Methods

The methods of the EmbeddedFontCollection class are listed here. For a complete list of EmbeddedFontCollection class members, see the EmbeddedFontCollection Members topic.

Public Methods

BuildFont

Builds the Font object from string.


EmbeddedFontCollection.BuildFont Method

EmbeddedFontCollection.BuildFont Method

Builds the Font object from string.

[Visual Basic]

Public Function BuildFont( _

ByVal s As String, _

ByVal context As ITypeDescriptorContext, _

ByVal culture As CultureInfo _

) As Font

[C#]

public Font BuildFont(

string s,

ITypeDescriptorContext context,

CultureInfo culture

);

[Delphi]

public function BuildFont(

s: String;

context: ITypeDescriptorContext;

culture: CultureInfo

): Font;


FormsKeyActionEnterEnum Enumeration

FormsKeyActionEnterEnum Enumeration

Describes the actions to be performed when a ENTER key is pressed in C1PrintPreview control which is connected to the doc engine.

[Visual Basic]

Public Enum FormsKeyActionEnterEnum

[C#]

public enum FormsKeyActionEnterEnum

[Delphi]

type FormsKeyActionEnterEnum = (InvokeAcceptButton, LikeTab, None);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
InvokeAcceptButton |
LikeTab |
None |

See Also

C1.C1Preview Namespace


FormsKeyActionTabEnum Enumeration

FormsKeyActionTabEnum Enumeration

Describes the actions to be performed when a TAB key is pressed in C1PrintPreview control which is connected to the doc engine.

[Visual Basic]

Public Enum FormsKeyActionTabEnum

[C#]

public enum FormsKeyActionTabEnum

[Delphi]

type FormsKeyActionTabEnum = (MoveAccrossDoc, MoveAccrossDocCycle, MoveAccrossDocOut, MoveAccrossPage, MoveAccrossPageCycle, MoveAccrossPageOut);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
MoveAccrossDoc |
MoveAccrossDocCycle |
MoveAccrossDocOut |
MoveAccrossPage |
MoveAccrossPageCycle |
MoveAccrossPageOut |

See Also

C1.C1Preview Namespace


FragmentResolvedInfo Class

FragmentResolvedInfo Class

Represents the temporary info used during resolving, instance of this class, created for each object participating in resolving.

For a list of all members of this type, see FragmentResolvedInfo Members.

System.Object

C1.C1Preview.FragmentResolvedInfo

C1.C1Preview.AreaResolvedInfo

C1.C1Preview.ShapeResolvedInfo

C1.C1Preview.TextResolvedInfo

[Visual Basic]

Public Class FragmentResolvedInfo

[C#]

public class FragmentResolvedInfo

[Delphi]

type FragmentResolvedInfo = class;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


FragmentResolvedInfo Members

FragmentResolvedInfo Members

FragmentResolvedInfo overview

Public Properties

AvailHeight | Returns the distance between Top and LeftTopPageArea.Bottom.
AvailWidth | Returns the distance between Left and LeftTopPageArea.Right.
BottomOffset | Returns a sum of Padding.Bottom, Spacing.Bottom, Borders.Bottom
IsAutoLeft | Indicates that the Left coordinate of object was calculated as auto.
IsAutoPos | Indicates that the Left-top position of object was calculated as auto.
IsAutoTop | Indicates that the Top coordinate of object was calculated as auto.
LeftOffset | Returns a sum of Padding.Left, Spacing.Left, Borders.Left
RightOffset | Returns a sum of Padding.Right, Spacing.Right, Borders.Right
TopOffset | Returns a sum of Padding.Top, Spacing.Top, Borders.Top


FragmentResolvedInfo Properties

FragmentResolvedInfo Properties

The properties of the FragmentResolvedInfo class are listed here. For a complete list of FragmentResolvedInfo class members, see the FragmentResolvedInfo Members topic.

Public Properties

AvailHeight | Returns the distance between Top and LeftTopPageArea.Bottom.
AvailWidth | Returns the distance between Left and LeftTopPageArea.Right.
BottomOffset | Returns a sum of Padding.Bottom, Spacing.Bottom, Borders.Bottom
IsAutoLeft | Indicates that the Left coordinate of object was calculated as auto.
IsAutoPos | Indicates that the Left-top position of object was calculated as auto.
IsAutoTop | Indicates that the Top coordinate of object was calculated as auto.
LeftOffset | Returns a sum of Padding.Left, Spacing.Left, Borders.Left
RightOffset | Returns a sum of Padding.Right, Spacing.Right, Borders.Right
TopOffset | Returns a sum of Padding.Top, Spacing.Top, Borders.Top


FragmentResolvedInfo.AvailHeight Property

FragmentResolvedInfo.AvailHeight Property

Returns the distance between Top and LeftTopPageArea.Bottom.

[Visual Basic]

Public ReadOnly Property AvailHeight As Double

[C#]

public double AvailHeight {get;}

[Delphi]

public property AvailHeight: Double read get_AvailHeight;


FragmentResolvedInfo.AvailWidth Property

FragmentResolvedInfo.AvailWidth Property

Returns the distance between Left and LeftTopPageArea.Right.

[Visual Basic]

Public ReadOnly Property AvailWidth As Double

[C#]

public double AvailWidth {get;}

[Delphi]

public property AvailWidth: Double read get_AvailWidth;


FragmentResolvedInfo.BottomOffset Property

FragmentResolvedInfo.BottomOffset Property

Returns a sum of Padding.Bottom, Spacing.Bottom, Borders.Bottom

[Visual Basic]

Public ReadOnly Property BottomOffset As Double

[C#]

public double BottomOffset {get;}

[Delphi]

public property BottomOffset: Double read get_BottomOffset;


FragmentResolvedInfo.IsAutoLeft Property

FragmentResolvedInfo.IsAutoLeft Property

Indicates that the Left coordinate of object was calculated as auto.

[Visual Basic]

Public Property IsAutoLeft As Boolean

[C#]

public bool IsAutoLeft {get;set;}

[Delphi]

public property IsAutoLeft: Boolean read get_IsAutoLeft write set_IsAutoLeft;


FragmentResolvedInfo.IsAutoPos Property

FragmentResolvedInfo.IsAutoPos Property

Indicates that the Left-top position of object was calculated as auto.

[Visual Basic]

Public ReadOnly Property IsAutoPos As Boolean

[C#]

public bool IsAutoPos {get;}

[Delphi]

public property IsAutoPos: Boolean read get_IsAutoPos;


FragmentResolvedInfo.IsAutoTop Property

FragmentResolvedInfo.IsAutoTop Property

Indicates that the Top coordinate of object was calculated as auto.

[Visual Basic]

Public Property IsAutoTop As Boolean

[C#]

public bool IsAutoTop {get;set;}

[Delphi]

public property IsAutoTop: Boolean read get_IsAutoTop write set_IsAutoTop;


FragmentResolvedInfo.LeftOffset Property

FragmentResolvedInfo.LeftOffset Property

Returns a sum of Padding.Left, Spacing.Left, Borders.Left

[Visual Basic]

Public ReadOnly Property LeftOffset As Double

[C#]

public double LeftOffset {get;}

[Delphi]

public property LeftOffset: Double read get_LeftOffset;


FragmentResolvedInfo.RightOffset Property

FragmentResolvedInfo.RightOffset Property

Returns a sum of Padding.Right, Spacing.Right, Borders.Right

[Visual Basic]

Public ReadOnly Property RightOffset As Double

[C#]

public double RightOffset {get;}

[Delphi]

public property RightOffset: Double read get_RightOffset;


FragmentResolvedInfo.TopOffset Property

FragmentResolvedInfo.TopOffset Property

Returns a sum of Padding.Top, Spacing.Top, Borders.Top

[Visual Basic]

Public ReadOnly Property TopOffset As Double

[C#]

public double TopOffset {get;}

[Delphi]

public property TopOffset: Double read get_TopOffset;


GenerateErrorEnum Enumeration

GenerateErrorEnum Enumeration

Represents the codes of possible errors, which can occur when document is being generated.

[Visual Basic]

Public Enum GenerateErrorEnum

[C#]

public enum GenerateErrorEnum

[Delphi]

type GenerateErrorEnum = (Abort, AutoHeightNotSupproted, AutoLeftNotSupproted, AutoSizeNotSupported, AutoTopNotSupproted, AutoWidthNotSupproted, BottomRightNotSupported, CyclicReference, GeneratingMode, InadmissibleAction, InternalError, LayoutChange, None, PageSettingsChanged, ResolvingDimension);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
Abort | Generation was canceled by user.
GeneratingMode | Indicates that the action can't be performed in the current mode of generating.
InadmissibleAction | Indicates that the user has performed an inadmissible operation during generating of the document with using StartDoc() / EndDoc() methods.

See Also

C1.C1Preview Namespace


GridLines Structure

GridLines Structure

Describes the lines within of table's area.

For a list of all members of this type, see GridLines Members.

System.Object

System.ValueType

C1.C1Preview.GridLines

[Visual Basic]

Public Structure GridLines

[C#]

public struct GridLines

[Delphi]

type GridLines = record;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


GridLines Members

GridLines Members

GridLines overview

Public Properties

All | Sets the all lines.
Bottom | Gets or sets bottom border.
Horz | Gets or sets horizontal lines within table's area.
Left | Gets or sets left border.
Right | Gets or sets right border.
Top | Gets or sets top border.
Vert | Gets or sets vertical lines within table's area.


GridLines Properties

GridLines Properties

The properties of the GridLines structure are listed here. For a complete list of GridLines structure members, see the GridLines Members topic.

All | Sets the all lines.
Bottom | Gets or sets bottom border.
Horz | Gets or sets horizontal lines within table's area.
Left | Gets or sets left border.
Right | Gets or sets right border.
Top | Gets or sets top border.
Vert | Gets or sets vertical lines within table's area.


GridLines.All Property

GridLines.All Property

Sets the all lines.

[Visual Basic]

Overridable Public WriteOnly Property All As LineDef

[C#]

virtual public LineDef All {set;}

[Delphi]

public property All: LineDef write set_All;


GridLines.Bottom Property

GridLines.Bottom Property

Gets or sets bottom border.

[Visual Basic]

Overridable Public Property Bottom As LineDef

[C#]

virtual public LineDef Bottom {get;set;}

[Delphi]

public property Bottom: LineDef read get_Bottom write set_Bottom;


GridLines.Horz Property

GridLines.Horz Property

Gets or sets horizontal lines within table's area.

[Visual Basic]

Overridable Public Property Horz As LineDef

[C#]

virtual public LineDef Horz {get;set;}

[Delphi]

public property Horz: LineDef read get_Horz write set_Horz;


GridLines.Left Property

GridLines.Left Property

Gets or sets left border.

[Visual Basic]

Overridable Public Property Left As LineDef

[C#]

virtual public LineDef Left {get;set;}

[Delphi]

public property Left: LineDef read get_Left write set_Left;


GridLines.Right Property

GridLines.Right Property

Gets or sets right border.

[Visual Basic]

Overridable Public Property Right As LineDef

[C#]

virtual public LineDef Right {get;set;}

[Delphi]

public property Right: LineDef read get_Right write set_Right;


GridLines.Top Property

GridLines.Top Property

Gets or sets top border.

[Visual Basic]

Overridable Public Property Top As LineDef

[C#]

virtual public LineDef Top {get;set;}

[Delphi]

public property Top: LineDef read get_Top write set_Top;


GridLines.Vert Property

GridLines.Vert Property

Gets or sets vertical lines within table's area.

[Visual Basic]

Overridable Public Property Vert As LineDef

[C#]

virtual public LineDef Vert {get;set;}

[Delphi]

public property Vert: LineDef read get_Vert write set_Vert;


IC1Printable Interface

IC1Printable Interface

This interface should be implemented by a control to support its rendering through RenderC1Printable object in C1PrintDocument.

For a list of all members of this type, see IC1Printable Members.

[Visual Basic]

Public Interface IC1Printable

[C#]

public interface IC1Printable

[Delphi]

type IC1Printable = interface;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


IC1Printable Members

IC1Printable Members

IC1Printable overview

Public Methods

C1PrintableGetImage | Gets the content of control as Image.
C1PrintableGetTree | Gets the content of control as C1 document that is serialized in stream. This document can be built with using C1PrintDocumentClient.


IC1Printable Methods

IC1Printable Methods

The methods of the IC1Printable interface are listed here. For a complete list of IC1Printable interface members, see the IC1Printable Members topic.

Public Methods

C1PrintableGetImage | Gets the content of control as Image.
C1PrintableGetTree | Gets the content of control as C1 document that is serialized in stream. This document can be built with using C1PrintDocumentClient.


IC1Printable.C1PrintableGetImage Method

IC1Printable.C1PrintableGetImage Method

Gets the content of control as Image.

[Visual Basic]

Function C1PrintableGetImage() As Image

[C#]

Image C1PrintableGetImage()

[Delphi]

function C1PrintableGetImage(): Image;

Return Value

The Image object representing a control content.


IC1Printable.C1PrintableGetTree Method

IC1Printable.C1PrintableGetTree Method

Gets the content of control as C1 document that is serialized in stream. This document can be built with using C1PrintDocumentClient.

[Visual Basic]

Function C1PrintableGetTree() As Stream

[C#]

Stream C1PrintableGetTree()

[Delphi]

function C1PrintableGetTree(): Stream;

Return Value

The stream object containing the document tree.


IDocumentLocation Interface

IDocumentLocation Interface

Describes location within document. Each location is identified by page and rectangle on page. Units or rectangle depend on C1Preview.ResolvedUnit property. This interface implemented by: Page, RenderObject, C1Anchor.

For a list of all members of this type, see IDocumentLocation Members.

[Visual Basic]

Public Interface IDocumentLocation

[C#]

public interface IDocumentLocation

[Delphi]

type IDocumentLocation = interface;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


IDocumentLocation Members

IDocumentLocation Members

IDocumentLocation overview


ImageAlign Structure

ImageAlign Structure

Describes the image alignment.

For a list of all members of this type, see ImageAlign Members.

System.Object

System.ValueType

C1.C1Preview.ImageAlign

[Visual Basic]

Public Structure ImageAlign

[C#]

public struct ImageAlign

[Delphi]

type ImageAlign = record;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ImageAlign Members

ImageAlign Members

ImageAlign overview

Public Properties

AlignHorz | Horizontal alignment of an image.
AlignVert | Vertical alignment of an image.
BestFit | This property is a composition (function) of the StretchHorz, StretchVert and KeepAspectRatio properties.
Default | Gets default image alignment.
KeepAspectRatio | Keeps aspect ratio. Useful when StretchHorz or StretchVert is True.
StretchHorz | Gets or sets the value indicating whether an image is stretched horizontally to fit layout rectangle or it has a natural width.
StretchVert | Gets or sets the value indicating whether an image is stretched vertically to fit layout rectangle or it has a natural height.
TileHorz | The image is tiled horizontally. If StretchHorz is True then this property is ignored.
TileVert | The image is tiled vertically. If StretchVert is True then this property is ignored.


ImageAlign Properties

ImageAlign Properties

The properties of the ImageAlign structure are listed here. For a complete list of ImageAlign structure members, see the ImageAlign Members topic.

AlignHorz | Horizontal alignment of an image.
AlignVert | Vertical alignment of an image.
BestFit | This property is a composition (function) of the StretchHorz, StretchVert and KeepAspectRatio properties.
Default | Gets default image alignment.
KeepAspectRatio | Keeps aspect ratio. Useful when StretchHorz or StretchVert is True.
StretchHorz | Gets or sets the value indicating whether an image is stretched horizontally to fit layout rectangle or it has a natural width.
StretchVert | Gets or sets the value indicating whether an image is stretched vertically to fit layout rectangle or it has a natural height.
TileHorz | The image is tiled horizontally. If StretchHorz is True then this property is ignored.
TileVert | The image is tiled vertically. If StretchVert is True then this property is ignored.


ImageAlign.AlignHorz Property

ImageAlign.AlignHorz Property

Horizontal alignment of an image.

[Visual Basic]

Overridable Public Property AlignHorz As ImageAlignHorzEnum

[C#]

virtual public ImageAlignHorzEnum AlignHorz {get;set;}

[Delphi]

public property AlignHorz: ImageAlignHorzEnum read get_AlignHorz write set_AlignHorz;


ImageAlign.AlignVert Property

ImageAlign.AlignVert Property

Vertical alignment of an image.

[Visual Basic]

Overridable Public Property AlignVert As ImageAlignVertEnum

[C#]

virtual public ImageAlignVertEnum AlignVert {get;set;}

[Delphi]

public property AlignVert: ImageAlignVertEnum read get_AlignVert write set_AlignVert;


ImageAlign.BestFit Property

ImageAlign.BestFit Property

This property is a composition (function) of the StretchHorz, StretchVert and KeepAspectRatio properties.

[Visual Basic]

Overridable Public Property BestFit As Boolean

[C#]

virtual public bool BestFit {get;set;}

[Delphi]

public property BestFit: Boolean read get_BestFit write set_BestFit;


ImageAlign.Default Property

ImageAlign.Default Property

Gets default image alignment.

[Visual Basic]

Public Shared ReadOnly Property Default As ImageAlign

[C#]

public static ImageAlign Default {get;}

[Delphi]

public class property Default: ImageAlign read get_Default;


ImageAlign.KeepAspectRatio Property

ImageAlign.KeepAspectRatio Property

Keeps aspect ratio. Useful when StretchHorz or StretchVert is True.

[Visual Basic]

Overridable Public Property KeepAspectRatio As Boolean

[C#]

virtual public bool KeepAspectRatio {get;set;}

[Delphi]

public property KeepAspectRatio: Boolean read get_KeepAspectRatio write set_KeepAspectRatio;


ImageAlign.StretchHorz Property

ImageAlign.StretchHorz Property

Gets or sets the value indicating whether an image is stretched horizontally to fit layout rectangle or it has a natural width.

[Visual Basic]

Overridable Public Property StretchHorz As Boolean

[C#]

virtual public bool StretchHorz {get;set;}

[Delphi]

public property StretchHorz: Boolean read get_StretchHorz write set_StretchHorz;


ImageAlign.StretchVert Property

ImageAlign.StretchVert Property

Gets or sets the value indicating whether an image is stretched vertically to fit layout rectangle or it has a natural height.

[Visual Basic]

Overridable Public Property StretchVert As Boolean

[C#]

virtual public bool StretchVert {get;set;}

[Delphi]

public property StretchVert: Boolean read get_StretchVert write set_StretchVert;


ImageAlign.TileHorz Property

ImageAlign.TileHorz Property

The image is tiled horizontally. If StretchHorz is True then this property is ignored.

[Visual Basic]

Overridable Public Property TileHorz As Boolean

[C#]

virtual public bool TileHorz {get;set;}

[Delphi]

public property TileHorz: Boolean read get_TileHorz write set_TileHorz;


ImageAlign.TileVert Property

ImageAlign.TileVert Property

The image is tiled vertically. If StretchVert is True then this property is ignored.

[Visual Basic]

Overridable Public Property TileVert As Boolean

[C#]

virtual public bool TileVert {get;set;}

[Delphi]

public property TileVert: Boolean read get_TileVert write set_TileVert;


ImageAlignHorzEnum Enumeration

ImageAlignHorzEnum Enumeration

Defines modes of horizontal alignment of image.

[Visual Basic]

Public Enum ImageAlignHorzEnum

[C#]

public enum ImageAlignHorzEnum

[Delphi]

type ImageAlignHorzEnum = (Center, Left, Right);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
Center |
Left |
Right |

See Also

C1.C1Preview Namespace


ImageAlignVertEnum Enumeration

ImageAlignVertEnum Enumeration

Defines modes of vertical alignment of image.

[Visual Basic]

Public Enum ImageAlignVertEnum

[C#]

public enum ImageAlignVertEnum

[Delphi]

type ImageAlignVertEnum = (Bottom, Center, Top);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
Bottom |
Center |
Top |

See Also

C1.C1Preview Namespace


InputAction Class

InputAction Class

Describes a single input action, and any handling associated with it.

For a list of all members of this type, see InputAction Members.

System.Object

C1.C1Preview.InputAction

[Visual Basic]

Public Class InputAction

[C#]

public class InputAction

[Delphi]

type InputAction = class;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


InputAction Members

InputAction Members

InputAction overview

Public Properties

ActionHandler | Gets or sets the object describing the handling associated with the action.
UserAction | Gets or sets the user action associated with this object.

Public Methods

AssignFrom

Copies the content of another InputAction object into the current object.


InputAction Properties

InputAction Properties

The properties of the InputAction class are listed here. For a complete list of InputAction class members, see the InputAction Members topic.

Public Properties

ActionHandler | Gets or sets the object describing the handling associated with the action.
UserAction | Gets or sets the user action associated with this object.


InputAction.ActionHandler Property

InputAction.ActionHandler Property

Gets or sets the object describing the handling associated with the action.

[Visual Basic]

Public Property ActionHandler As ActionHandlerBase

[C#]

public ActionHandlerBase ActionHandler {get;set;}

[Delphi]

public property ActionHandler: ActionHandlerBase read get_ActionHandler write set_ActionHandler;


InputAction.UserAction Property

InputAction.UserAction Property

Gets or sets the user action associated with this object.

[Visual Basic]

Public Property UserAction As UserActionEnum

[C#]

public UserActionEnum UserAction {get;set;}

[Delphi]

public property UserAction: UserActionEnum read get_UserAction write set_UserAction;


InputAction Methods

InputAction Methods

The methods of the InputAction class are listed here. For a complete list of InputAction class members, see the InputAction Members topic.

Public Methods

AssignFrom

Copies the content of another InputAction object into the current object.


InputAction.AssignFrom Method

InputAction.AssignFrom Method

Copies the content of another InputAction object into the current object.

[Visual Basic]

Overridable Public Sub AssignFrom( _

ByVal source As InputAction _

)

[C#]

virtual public void AssignFrom(

InputAction source

);

[Delphi]

public procedure AssignFrom(

source: InputAction

); virtual;

Parameters

source

The source object, whose properties are to be copied into this object.


InputActionCollection Class

InputActionCollection Class

Represents the collection of InputAction objects.

For a list of all members of this type, see InputActionCollection Members.

System.Object

System.Collections.CollectionBase

C1.C1Preview.InputActionCollection

[Visual Basic]

Public Class InputActionCollection

Inherits CollectionBase

[C#]

public class InputActionCollection : CollectionBase

[Delphi]

type InputActionCollection = class (CollectionBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


InputActionCollection Members

InputActionCollection Members

InputActionCollection overview


LayoutChangeBase Class

LayoutChangeBase Class

Represents the base class for actions which can be performed before or after rendering an object. Actions like: start new page, column, change columns layout.

For a list of all members of this type, see LayoutChangeBase Members.

System.Object

C1.C1Preview.LayoutChangeBase

C1.C1Preview.LayoutChangeNewColumn

C1.C1Preview.LayoutChangeNewLine

C1.C1Preview.LayoutChangeNewPage

C1.C1Preview.LayoutChangeNoBreak

[Visual Basic]

Public Class LayoutChangeBase

Implements ICloneable

[C#]

public class LayoutChangeBase : ICloneable

[Delphi]

type LayoutChangeBase = class (TObject, ICloneable);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


LayoutChangeBase Members

LayoutChangeBase Members

LayoutChangeBase overview


LayoutChangeNewColumn Class

LayoutChangeNewColumn Class

Describes the column break action.

For a list of all members of this type, see LayoutChangeNewColumn Members.

System.Object

C1.C1Preview.LayoutChangeBase

C1.C1Preview.LayoutChangeNewColumn

[Visual Basic]

Public Class LayoutChangeNewColumn

Inherits LayoutChangeBase

[C#]

public class LayoutChangeNewColumn : LayoutChangeBase

[Delphi]

type LayoutChangeNewColumn = class (LayoutChangeBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


LayoutChangeNewColumn Members

LayoutChangeNewColumn Members

LayoutChangeNewColumn overview


LayoutChangeNewLine Class

LayoutChangeNewLine Class

Describes the line break action on inline flow.

For a list of all members of this type, see LayoutChangeNewLine Members.

System.Object

C1.C1Preview.LayoutChangeBase

C1.C1Preview.LayoutChangeNewLine

[Visual Basic]

Public Class LayoutChangeNewLine

Inherits LayoutChangeBase

[C#]

public class LayoutChangeNewLine : LayoutChangeBase

[Delphi]

type LayoutChangeNewLine = class (LayoutChangeBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


LayoutChangeNewLine Members

LayoutChangeNewLine Members

LayoutChangeNewLine overview


LayoutChangeNewPage Class

LayoutChangeNewPage Class

Desribes the page break action.

For a list of all members of this type, see LayoutChangeNewPage Members.

System.Object

C1.C1Preview.LayoutChangeBase

C1.C1Preview.LayoutChangeNewPage

[Visual Basic]

Public Class LayoutChangeNewPage

Inherits LayoutChangeBase

[C#]

public class LayoutChangeNewPage : LayoutChangeBase

[Delphi]

type LayoutChangeNewPage = class (LayoutChangeBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


LayoutChangeNewPage Members

LayoutChangeNewPage Members

LayoutChangeNewPage overview


LayoutChangeNoBreak Class

LayoutChangeNoBreak Class

Describes the action that does no produce the page break, but changes the page layout for next page.

For a list of all members of this type, see LayoutChangeNoBreak Members.

System.Object

C1.C1Preview.LayoutChangeBase

C1.C1Preview.LayoutChangeNoBreak

[Visual Basic]

Public Class LayoutChangeNoBreak

Inherits LayoutChangeBase

[C#]

public class LayoutChangeNoBreak : LayoutChangeBase

[Delphi]

type LayoutChangeNoBreak = class (LayoutChangeBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


LayoutChangeNoBreak Members

LayoutChangeNoBreak Members

LayoutChangeNoBreak overview


LengthAbs Class

LengthAbs Class

Represents the dimension like: "5mm", "10in", "20" and so on.

For a list of all members of this type, see LengthAbs Members.

System.Object

C1.C1Preview.LengthBase

C1.C1Preview.LengthAbs

[Visual Basic]

Public Class LengthAbs

Inherits LengthBase

[C#]

public class LengthAbs : LengthBase

[Delphi]

type LengthAbs = class (LengthBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


LengthAbs Members

LengthAbs Members

LengthAbs overview

Public Properties

IsAuto (inherited from LengthBase) | Returns True if coordinate is auto.
IsEmpty (inherited from LengthBase) | Returns True if coordinate linked with empty (zero) coordinate.
Units | Gets the unit of measure of value.
Value | Gets the value.


LengthAbs Properties

LengthAbs Properties

The properties of the LengthAbs class are listed here. For a complete list of LengthAbs class members, see the LengthAbs Members topic.

Public Properties

IsAuto (inherited from LengthBase) | Returns True if coordinate is auto.
IsEmpty (inherited from LengthBase) | Returns True if coordinate linked with empty (zero) coordinate.
Units | Gets the unit of measure of value.
Value | Gets the value.


LengthAbs.Units Property

LengthAbs.Units Property

Gets the unit of measure of value.

[Visual Basic]

Public ReadOnly Property Units As UnitTypeEnum

[C#]

public UnitTypeEnum Units {get;}

[Delphi]

public property Units: UnitTypeEnum read get_Units;


LengthAbs.Value Property

LengthAbs.Value Property

Gets the value.

[Visual Basic]

Public ReadOnly Property Value As Double

[C#]

public double Value {get;}

[Delphi]

public property Value: Double read get_Value;


LengthAbs.Predefined Class

LengthAbs.Predefined Class

For a list of all members of this type, see LengthAbs.Predefined Members.

System.Object

C1.C1Preview.LengthAbs.Predefined

[Visual Basic]

NonInheritable Public Class LengthAbs.Predefined

[C#]

public sealed class LengthAbs.Predefined

[Delphi]

type LengthAbs.Predefined = class sealed;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


LengthAbs.Predefined Members

LengthAbs.Predefined Members

LengthAbs.Predefined overview

Public Properties

BoldLineWidth | Gets instance of the LengthAbs class (defined as new LengthAbs(2f, UnitTypeEnum.Point)) representing an default width of bold line (border, grid, and so on).
Empty | Gets instance of the LengthAbs class (defined as new LengthAbs(0, UnitTypeEnum.Mm)) representing an empty dimension.
LineWidth | Gets instance of the LengthAbs class (defined as new LengthAbs(1f, UnitTypeEnum.Point)) representing an default width of line (border, grid, and so on).


LengthAbs.Predefined Properties

LengthAbs.Predefined Properties

The properties of the LengthAbs.Predefined class are listed here. For a complete list of LengthAbs.Predefined class members, see the LengthAbs+Predefined Members topic.

Public Properties

BoldLineWidth | Gets instance of the LengthAbs class (defined as new LengthAbs(2f, UnitTypeEnum.Point)) representing an default width of bold line (border, grid, and so on).
Empty | Gets instance of the LengthAbs class (defined as new LengthAbs(0, UnitTypeEnum.Mm)) representing an empty dimension.
LineWidth | Gets instance of the LengthAbs class (defined as new LengthAbs(1f, UnitTypeEnum.Point)) representing an default width of line (border, grid, and so on).


LengthAbs.Predefined.BoldLineWidth Property

LengthAbs.Predefined.BoldLineWidth Property

Gets instance of the LengthAbs class (defined as new LengthAbs(2f, UnitTypeEnum.Point)) representing an default width of bold line (border, grid, and so on).

[Visual Basic]

Public Shared ReadOnly Property BoldLineWidth As LengthAbs

[C#]

public static LengthAbs BoldLineWidth {get;}

[Delphi]

public class property BoldLineWidth: LengthAbs read get_BoldLineWidth;


LengthAbs.Predefined.Empty Property

LengthAbs.Predefined.Empty Property

Gets instance of the LengthAbs class (defined as new LengthAbs(0, UnitTypeEnum.Mm)) representing an empty dimension.

[Visual Basic]

Public Shared ReadOnly Property Empty As LengthAbs

[C#]

public static LengthAbs Empty {get;}

[Delphi]

public class property Empty: LengthAbs read get_Empty;


LengthAbs.Predefined.LineWidth Property

LengthAbs.Predefined.LineWidth Property

Gets instance of the LengthAbs class (defined as new LengthAbs(1f, UnitTypeEnum.Point)) representing an default width of line (border, grid, and so on).

[Visual Basic]

Public Shared ReadOnly Property LineWidth As LengthAbs

[C#]

public static LengthAbs LineWidth {get;}

[Delphi]

public class property LineWidth: LengthAbs read get_LineWidth;


LengthAuto Class

LengthAuto Class

Represents the "auto" size or coordinate, only one instance of this class can be created. Use property LengthBase.Auto to access to this instance.

For a list of all members of this type, see LengthAuto Members.

System.Object

C1.C1Preview.LengthBase

C1.C1Preview.LengthAuto

[Visual Basic]

Public Class LengthAuto

Inherits LengthBase

[C#]

public class LengthAuto : LengthBase

[Delphi]

type LengthAuto = class (LengthBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


LengthAuto Members

LengthAuto Members

LengthAuto overview

Public Properties

IsAuto (inherited from LengthBase) | Returns True if coordinate is auto.
IsEmpty (inherited from LengthBase) | Returns True if coordinate linked with empty (zero) coordinate.


LengthAuto Properties

LengthAuto Properties

The properties of the LengthAuto class are listed here. For a complete list of LengthAuto class members, see the LengthAuto Members topic.

Public Properties

IsAuto (inherited from LengthBase) | Returns True if coordinate is auto.
IsEmpty (inherited from LengthBase) | Returns True if coordinate linked with empty (zero) coordinate.


LengthBase Class

LengthBase Class

Represents a simple coordinate or size of object. This is an abstract class.

For a list of all members of this type, see LengthBase Members.

System.Object

C1.C1Preview.LengthBase

C1.C1Preview.LengthAbs

C1.C1Preview.LengthAuto

C1.C1Preview.LengthExp

[Visual Basic]

MustInherit Public Class LengthBase

[C#]

public abstract class LengthBase

[Delphi]

type LengthBase = class abstract;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


LengthBase Members

LengthBase Members

LengthBase overview

Public Properties

Auto | Gets instance of the LengthAuto class representing an auto dimension.
IsAuto | Returns True if coordinate is auto.
IsEmpty | Returns True if coordinate linked with empty (zero) coordinate.

Public Methods

Parse | Analyzes a passed string and creates an instance of the LengthBase class on the basis of this string.
StringToDimension | Converts a string to DimensionEnum. String can have value from: ("left", "top", "right", "bottom", "width", "height", "relleft", "reltop", "relright", "relbottom"). Method is case insensitive.
StringToUnitType | Converts a string to UnitTypeEnum. String can have value from: ("def", "doc", "in", "mm", "pc", "pix", "pt", "tw", "inhs"). Method is can insensitive.


LengthBase Properties

LengthBase Properties

The properties of the LengthBase class are listed here. For a complete list of LengthBase class members, see the LengthBase Members topic.

Public Properties

Auto | Gets instance of the LengthAuto class representing an auto dimension.
IsAuto | Returns True if coordinate is auto.
IsEmpty | Returns True if coordinate linked with empty (zero) coordinate.


LengthBase.Auto Property

LengthBase.Auto Property

Gets instance of the LengthAuto class representing an auto dimension.

[Visual Basic]

Public Shared ReadOnly Property Auto As LengthAuto

[C#]

public static LengthAuto Auto {get;}

[Delphi]

public class property Auto: LengthAuto read get_Auto;


LengthBase.IsAuto Property

LengthBase.IsAuto Property

Returns True if coordinate is auto.

[Visual Basic]

Public ReadOnly Property IsAuto As Boolean

[C#]

public bool IsAuto {get;}

[Delphi]

public property IsAuto: Boolean read get_IsAuto;


LengthBase.IsEmpty Property

LengthBase.IsEmpty Property

Returns True if coordinate linked with empty (zero) coordinate.

[Visual Basic]

Public ReadOnly Property IsEmpty As Boolean

[C#]

public bool IsEmpty {get;}

[Delphi]

public property IsEmpty: Boolean read get_IsEmpty;


LengthBase Methods

LengthBase Methods

The methods of the LengthBase class are listed here. For a complete list of LengthBase class members, see the LengthBase Members topic.

Public Methods

Parse | Analyzes a passed string and creates an instance of the LengthBase class on the basis of this string.
StringToDimension | Converts a string to DimensionEnum. String can have value from: ("left", "top", "right", "bottom", "width", "height", "relleft", "reltop", "relright", "relbottom"). Method is case insensitive.
StringToUnitType | Converts a string to UnitTypeEnum. String can have value from: ("def", "doc", "in", "mm", "pc", "pix", "pt", "tw", "inhs"). Method is can insensitive.


LengthBase.Parse Method

LengthBase.Parse Method

Analyzes a passed string and creates an instance of the LengthBase class on the basis of this string.

[Visual Basic]

Public Shared Function Parse( _

ByVal s As String, _

ByVal throwException As Boolean _

) As LengthBase

[C#]

public static LengthBase Parse(

string s,

bool throwException

);

[Delphi]

public class function Parse(

s: String;

throwException: Boolean

): LengthBase;

Parameters

s

String to analyze.

throwException

Indicates whether an exception must be raised if string has an error and can't be converted to the LengthBase.

Return Value

Returns an instance LengthAbs or LengthRef or LengthExp or LengthAuto class, returns a null value if throwException equals False and s has an error.


LengthBase.StringToDimension Method

LengthBase.StringToDimension Method

Converts a string to DimensionEnum. String can have value from: ("left", "top", "right", "bottom", "width", "height", "relleft", "reltop", "relright", "relbottom"). Method is case insensitive.

[Visual Basic]

Public Shared Function StringToDimension( _

ByVal s As String, _

ByRef dimension As DimensionEnum _

) As Boolean

[C#]

public static bool StringToDimension(

string s,

ref DimensionEnum dimension

);

[Delphi]

public class function StringToDimension(

s: String;

var dimension: DimensionEnum

): Boolean;

Parameters

s

String to convert, if s is null or empty then units will be RefDim.Default.

dimension

Return Value

Returns True if no error occurs.


LengthBase.StringToUnitType Method

LengthBase.StringToUnitType Method

Converts a string to UnitTypeEnum. String can have value from: ("def", "doc", "in", "mm", "pc", "pix", "pt", "tw", "inhs"). Method is can insensitive.

[Visual Basic]

Public Shared Function StringToUnitType( _

ByVal s As String, _

ByRef units As UnitTypeEnum _

) As Boolean

[C#]

public static bool StringToUnitType(

string s,

ref UnitTypeEnum units

);

[Delphi]

public class function StringToUnitType(

s: String;

var units: UnitTypeEnum

): Boolean;

Parameters

s

String to convert, if s is null or empty then units will be UnitTypeEnum.Default.

units

Contains the unit of measure on exit.

Return Value

Returns True if no error occurs.


LengthExp Class

LengthExp Class

Represents the unit which holds an expression using the LengthRef or LengthAbs classes like: "parent.width + 5mm", "80%parent.width" and so on

For a list of all members of this type, see LengthExp Members.

System.Object

C1.C1Preview.LengthBase

C1.C1Preview.LengthExp

[Visual Basic]

Public Class LengthExp

Inherits LengthBase

[C#]

public class LengthExp : LengthBase

[Delphi]

type LengthExp = class (LengthBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


LengthExp Members

LengthExp Members

LengthExp overview

Public Properties

Elements | Represents an expression, expression may contains: LengthBase objects, Numbers (int, double, and so on) and objects derived from LengthExp.Op class.
Functions | The array of registered functions.
IsAuto (inherited from LengthBase) | Returns True if coordinate is auto.
IsEmpty (inherited from LengthBase) | Returns True if coordinate linked with empty (zero) coordinate.
Operations | The array of registered operations.
UnaryOperations | The array of registered unary operations.


LengthExp Properties

LengthExp Properties

The properties of the LengthExp class are listed here. For a complete list of LengthExp class members, see the LengthExp Members topic.

Public Properties

Elements | Represents an expression, expression may contains: LengthBase objects, Numbers (int, double, and so on) and objects derived from LengthExp.Op class.
Functions | The array of registered functions.
IsAuto (inherited from LengthBase) | Returns True if coordinate is auto.
IsEmpty (inherited from LengthBase) | Returns True if coordinate linked with empty (zero) coordinate.
Operations | The array of registered operations.
UnaryOperations | The array of registered unary operations.


LengthExp.Elements Property

LengthExp.Elements Property

Represents an expression, expression may contains: LengthBase objects, Numbers (int, double, and so on) and objects derived from LengthExp.Op class.

[Visual Basic]

Public ReadOnly Property Elements As Object

[C#]

public object Elements {get;}

[Delphi]

public property Elements: Object read get_Elements;


LengthExp.Functions Property

LengthExp.Functions Property

The array of registered functions.

[Visual Basic]

Public Shared ReadOnly Property Functions As LengthExp.FunctionAlg()

[C#]

public static LengthExp.FunctionAlg[] Functions {get;}

[Delphi]

public class property Functions: array of FunctionAlg read get_Functions;


LengthExp.Operations Property

LengthExp.Operations Property

The array of registered operations.

[Visual Basic]

Public Shared ReadOnly Property Operations As LengthExp.Operation()

[C#]

public static LengthExp.Operation[] Operations {get;}

[Delphi]

public class property Operations: array of Operation read get_Operations;


LengthExp.UnaryOperations Property

LengthExp.UnaryOperations Property

The array of registered unary operations.

[Visual Basic]

Public Shared ReadOnly Property UnaryOperations As LengthExp.Operation()

[C#]

public static LengthExp.Operation[] UnaryOperations {get;}

[Delphi]

public class property UnaryOperations: array of Operation read get_UnaryOperations;


LineProps Class

LineProps Class

Represents the geometric properties of the RenderLine object.

For a list of all members of this type, see LineProps Members.

System.Object

C1.C1Preview.ShapeProps

C1.C1Preview.LinePropsBase

C1.C1Preview.LineProps

[Visual Basic]

Public Class LineProps

Inherits LinePropsBase

[C#]

public class LineProps : LinePropsBase

[Delphi]

type LineProps = class (LinePropsBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


LineProps Members

LineProps Members

LineProps overview


LinePropsBase Class

LinePropsBase Class

Base class for properties of the RenderLine and RenderPolygon objects.

For a list of all members of this type, see LinePropsBase Members.

System.Object

C1.C1Preview.ShapeProps

C1.C1Preview.LinePropsBase

C1.C1Preview.LineProps

C1.C1Preview.PolygonProps

[Visual Basic]

MustInherit Public Class LinePropsBase

Inherits ShapeProps

[C#]

public abstract class LinePropsBase : ShapeProps

[Delphi]

type LinePropsBase = class abstract (ShapeProps);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


LinePropsBase Members

LinePropsBase Members

LinePropsBase overview


LongOperationEventArgs Class

LongOperationEventArgs Class

Describes arguments for the event fired periodically by a potentially long operation. Allows to provide feedback to the user and may also allow to cancel the operation.

For a list of all members of this type, see LongOperationEventArgs Members.

System.Object

System.EventArgs

C1.C1Preview.LongOperationEventArgs

[Visual Basic]

Public Class LongOperationEventArgs

Inherits EventArgs

[C#]

public class LongOperationEventArgs : EventArgs

[Delphi]

type LongOperationEventArgs = class (EventArgs);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


LongOperationEventArgs Members

LongOperationEventArgs Members

LongOperationEventArgs overview

Public Constructors

LongOperationEventArgs Constructor

Creates a new instance of LongOperationEventArgs with default properties (Complete=0, CanCancel=False).


LongOperationEventArgs Constructor

LongOperationEventArgs Constructor

Overload List

Creates a new instance of LongOperationEventArgs with default properties (Complete=0, CanCancel=False).

[Visual Basic] Public Function New()

[C#] public LongOperationEventArgs();

[Delphi] public constructor Create(); overload;

Creates a new instance of LongOperationEventArgs with the specified CanCancel value and Complete=0.

[Visual Basic] Public Function New(Boolean)

[C#] public LongOperationEventArgs(bool);

[Delphi] public constructor Create(Boolean); overload;

Creates a new instance of LongOperationEventArgs with the specified complete value and CanCancel=False.

[Visual Basic] Public Function New(Double)

[C#] public LongOperationEventArgs(double);

[Delphi] public constructor Create(Double); overload;

Creates a new instance of LongOperationEventArgs with the specified complete and CanCancel values.

[Visual Basic] Public Function New(Double, Boolean)

[C#] public LongOperationEventArgs(double, bool);

[Delphi] public constructor Create(Double; Boolean); overload;


LongOperationEventArgs Constructor ()

LongOperationEventArgs Constructor ()

Previous Next

Creates a new instance of LongOperationEventArgs with default properties (Complete=0, CanCancel=False).

[Visual Basic]

Public Function New()

[C#]

public LongOperationEventArgs()

[Delphi]

public constructor Create(); overload;


LongOperationEventArgs Constructor (Boolean)

LongOperationEventArgs Constructor (Boolean)

Previous Next

Creates a new instance of LongOperationEventArgs with the specified CanCancel value and Complete=0.

[Visual Basic]

Public Function New( _

ByVal canCancel As Boolean _

)

[C#]

public LongOperationEventArgs(

bool canCancel

);

[Delphi]

public constructor Create(

canCancel: Boolean

); overload;

Parameters

canCancel

Whether the operatioin can be cancelled.


LongOperationEventArgs Constructor (Double)

LongOperationEventArgs Constructor (Double)

Previous Next

Creates a new instance of LongOperationEventArgs with the specified complete value and CanCancel=False.

[Visual Basic]

Public Function New( _

ByVal complete As Double _

)

[C#]

public LongOperationEventArgs(

double complete

);

[Delphi]

public constructor Create(

complete: Double

); overload;

Parameters

complete

How much is complete (from 0 to 1).


LongOperationEventArgs Constructor (Double, Boolean)

LongOperationEventArgs Constructor (Double, Boolean)

Previous Next

Creates a new instance of LongOperationEventArgs with the specified complete and CanCancel values.

[Visual Basic]

Public Function New( _

ByVal complete As Double, _

ByVal canCancel As Boolean _

)

[C#]

public LongOperationEventArgs(

double complete,

bool canCancel

);

[Delphi]

public constructor Create(

complete: Double;

canCancel: Boolean

); overload;

Parameters

complete

How much is complete (from 0 to 1).

canCancel

Whether the operatioin can be cancelled.


OutlineNodeCollection Class

OutlineNodeCollection Class

For a list of all members of this type, see OutlineNodeCollection Members.

System.Object

System.Collections.CollectionBase

C1.C1Preview.OwnedCollection

C1.C1Preview.OutlineNodeCollection

[Visual Basic]

Public Class OutlineNodeCollection

Inherits OwnedCollection

[C#]

public class OutlineNodeCollection : OwnedCollection

[Delphi]

type OutlineNodeCollection = class (OwnedCollection);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


OutlineNodeCollection Members

OutlineNodeCollection Members

OutlineNodeCollection overview

Public Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Returns the RenderObject object by its index.
Owner (inherited from OwnedCollection) | Gets the owner of collection.

Public Methods

Add | Overloaded.
AssignFrom (inherited from OwnedCollection) |
Clear (inherited from CollectionBase) |
GetEnumerator (inherited from CollectionBase) |
IndexOf (inherited from OwnedCollection) | Searches for the specified Object and returns the zero-based index of the first occurrence within the entire collection.
Remove |
RemoveAt (inherited from CollectionBase) |


OutlineNodeCollection Properties

OutlineNodeCollection Properties

The properties of the OutlineNodeCollection class are listed here. For a complete list of OutlineNodeCollection class members, see the OutlineNodeCollection Members topic.

Public Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Item | Returns the RenderObject object by its index.
Owner (inherited from OwnedCollection) | Gets the owner of collection.


OutlineNodeCollection.Item Property

OutlineNodeCollection.Item Property

Returns the RenderObject object by its index.

[Visual Basic]

Public Default Property Item( _

ByVal index As Int32* _

) As OutlineNode

[C#]

public OutlineNode this[

Int32* index

] {get;set;}

[Delphi]

public property Item[

index: Int32*

]: OutlineNode read get_Item write set_Item;


OutlineNodeCollection Methods

OutlineNodeCollection Methods

The methods of the OutlineNodeCollection class are listed here. For a complete list of OutlineNodeCollection class members, see the OutlineNodeCollection Members topic.

Public Methods

Add | Overloaded.
AssignFrom (inherited from OwnedCollection) |
Clear (inherited from CollectionBase) |
GetEnumerator (inherited from CollectionBase) |
IndexOf (inherited from OwnedCollection) | Searches for the specified Object and returns the zero-based index of the first occurrence within the entire collection.
Remove |
RemoveAt (inherited from CollectionBase) |


OutlineNodeCollection.Add Method

OutlineNodeCollection.Add Method

Overload List

[Visual Basic] Overloads Public Function Add(OutlineNode) As Integer

[C#] public int Add(OutlineNode);

[Delphi] public function Add(OutlineNode) : Int32; overload;

[Visual Basic] Overloads Public Function Add(String, IDocumentLocation) As Integer

[C#] public int Add(string, IDocumentLocation);

[Delphi] public function Add(String; IDocumentLocation) : Int32; overload;

[Visual Basic] Overloads Public Function Add(String, IDocumentLocation, Icon) As Integer

[C#] public int Add(string, IDocumentLocation, Icon);

[Delphi] public function Add(String; IDocumentLocation; Icon) : Int32; overload;


OutlineNodeCollection.Add Method (OutlineNode)

OutlineNodeCollection.Add Method (OutlineNode)

Previous Next

[Visual Basic]

Overloads Public Function Add( _

ByVal node As OutlineNode _

) As Int32*

[C#]

public Int32* Add(

OutlineNode node

);

[Delphi]

public function Add(

node: OutlineNode

): Int32*; overload;


OutlineNodeCollection.Add Method (String, IDocumentLocation)

OutlineNodeCollection.Add Method (String, IDocumentLocation)

Previous Next

[Visual Basic]

Overloads Public Function Add( _

ByVal caption As String, _

ByVal location As IDocumentLocation _

) As Int32*

[C#]

public Int32* Add(

string caption,

IDocumentLocation location

);

[Delphi]

public function Add(

caption: String;

location: IDocumentLocation

): Int32*; overload;


OutlineNodeCollection.Add Method (String, IDocumentLocation, Icon)

OutlineNodeCollection.Add Method (String, IDocumentLocation, Icon)

Previous Next

[Visual Basic]

Overloads Public Function Add( _

ByVal caption As String, _

ByVal location As IDocumentLocation, _

ByVal icon As Icon _

) As Int32*

[C#]

public Int32* Add(

string caption,

IDocumentLocation location,

Icon icon

);

[Delphi]

public function Add(

caption: String;

location: IDocumentLocation;

icon: Icon

): Int32*; overload;


OutlineNodeCollection.Remove Method

OutlineNodeCollection.Remove Method

[Visual Basic]

Public Sub Remove( _

ByVal node As OutlineNode _

)

[C#]

public void Remove(

OutlineNode node

);

[Delphi]

public procedure Remove(

node: OutlineNode

);


OwnedCollection Class

OwnedCollection Class

Base class for RenderObjectCollection and ParagraphObjectCollection.

For a list of all members of this type, see OwnedCollection Members.

System.Object

System.Collections.CollectionBase

C1.C1Preview.OwnedCollection

C1.C1Preview.OutlineNodeCollection

C1.C1Preview.PageCollection

C1.C1Preview.ParagraphObjectCollection

[Visual Basic]

Public Class OwnedCollection

Inherits CollectionBase

[C#]

public class OwnedCollection : CollectionBase

[Delphi]

type OwnedCollection = class (CollectionBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


OwnedCollection Members

OwnedCollection Members

OwnedCollection overview

Public Constructors

OwnedCollection Constructor

Public Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Owner | Gets the owner of collection.

Public Methods

AssignFrom |
Clear (inherited from CollectionBase) |
GetEnumerator (inherited from CollectionBase) |
IndexOf | Searches for the specified Object and returns the zero-based index of the first occurrence within the entire collection.
RemoveAt (inherited from CollectionBase) |


OwnedCollection Constructor

OwnedCollection Constructor

Initializes a new instance of the OwnedCollection class.

[Visual Basic]

Public Function New( _

ByVal owner As ICollectionOwner _

)

[C#]

public OwnedCollection(

ICollectionOwner owner

);

[Delphi]

public constructor Create(

owner: ICollectionOwner

);


OwnedCollection Properties

OwnedCollection Properties

The properties of the OwnedCollection class are listed here. For a complete list of OwnedCollection class members, see the OwnedCollection Members topic.

Public Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Owner | Gets the owner of collection.


OwnedCollection.Owner Property

OwnedCollection.Owner Property

Gets the owner of collection.

[Visual Basic]

Public ReadOnly Property Owner As ICollectionOwner

[C#]

public ICollectionOwner Owner {get;}

[Delphi]

public property Owner: ICollectionOwner read get_Owner;


OwnedCollection Methods

OwnedCollection Methods

The methods of the OwnedCollection class are listed here. For a complete list of OwnedCollection class members, see the OwnedCollection Members topic.

Public Methods

AssignFrom |
Clear (inherited from CollectionBase) |
GetEnumerator (inherited from CollectionBase) |
IndexOf | Searches for the specified Object and returns the zero-based index of the first occurrence within the entire collection.
RemoveAt (inherited from CollectionBase) |


OwnedCollection.AssignFrom Method

OwnedCollection.AssignFrom Method

[Visual Basic]

Public Sub AssignFrom( _

ByVal source As OwnedCollection _

)

[C#]

public void AssignFrom(

OwnedCollection source

);

[Delphi]

public procedure AssignFrom(

source: OwnedCollection

);


OwnedCollection.IndexOf Method

OwnedCollection.IndexOf Method

Searches for the specified Object and returns the zero-based index of the first occurrence within the entire collection.

[Visual Basic]

Public Function IndexOf( _

ByVal obj As Object _

) As Int32*

[C#]

public Int32* IndexOf(

object obj

);

[Delphi]

public function IndexOf(

obj: Object

): Int32*;

Parameters

obj

The Object to locate in the collection. The value can be a null reference.

Return Value

The zero-based index of the first occurrence of value within the entire collection, if found; otherwise, -1.


Page Class

Page Class

Represents the generated page of document.

For a list of all members of this type, see Page Members.

System.Object

C1.C1Preview.Page

[Visual Basic]

Public Class Page

Implements IDocumentLocation

[C#]

public class Page : IDocumentLocation

[Delphi]

type Page = class (TObject, IDocumentLocation);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


Page Members

Page Members

Page overview

Public Properties

Index | Gets the index of page in collection.
IsEmpty | Gets the value indicating that the page is empty - it has no fragments from document.Body.
PageNo | Gets or sets the number of page, the numbering starts from 1.

Public Methods

FindFragment | Searches a RenderFragment object on page at specified position.
FindHyperlink | Searches a hyperlink on page at specified position.
GetHyperlinks | Gets the list of all hyperlinks on page.
GetInputFragments | Gets the list of RenderInputFragments objects on this page.


Page Properties

Page Properties

The properties of the Page class are listed here. For a complete list of Page class members, see the Page Members topic.

Public Properties

Index | Gets the index of page in collection.
IsEmpty | Gets the value indicating that the page is empty - it has no fragments from document.Body.
PageNo | Gets or sets the number of page, the numbering starts from 1.


Page.Index Property

Page.Index Property

Gets the index of page in collection.

[Visual Basic]

Public ReadOnly Property Index As Int32*

[C#]

public Int32* Index {get;}

[Delphi]

public property Index: Int32* read get_Index;


Page.IsEmpty Property

Page.IsEmpty Property

Gets the value indicating that the page is empty - it has no fragments from document.Body.

[Visual Basic]

Public ReadOnly Property IsEmpty As Boolean

[C#]

public bool IsEmpty {get;}

[Delphi]

public property IsEmpty: Boolean read get_IsEmpty;


Page.PageNo Property

Page.PageNo Property

Gets or sets the number of page, the numbering starts from 1.

[Visual Basic]

Public Property PageNo As Int32*

[C#]

public Int32* PageNo {get;set;}

[Delphi]

public property PageNo: Int32* read get_PageNo write set_PageNo;


Page Methods

Page Methods

The methods of the Page class are listed here. For a complete list of Page class members, see the Page Members topic.

Public Methods

FindFragment | Searches a RenderFragment object on page at specified position.
FindHyperlink | Searches a hyperlink on page at specified position.
GetHyperlinks | Gets the list of all hyperlinks on page.
GetInputFragments | Gets the list of RenderInputFragments objects on this page.


Page.FindFragment Method

Page.FindFragment Method

Searches a RenderFragment object on page at specified position.

[Visual Basic]

Public Function FindFragment( _

ByVal ptPage As PointD _

) As RenderFragment

[C#]

public RenderFragment FindFragment(

PointD ptPage

);

[Delphi]

public function FindFragment(

ptPage: PointD

): RenderFragment;

Parameters

ptPage

Point on page in resolved units.

Return Value

The found RenderFragment object or null if not found.


Page.FindHyperlink Method

Page.FindHyperlink Method

Searches a hyperlink on page at specified position.

[Visual Basic]

Public Function FindHyperlink( _

ByVal ptPage As PointD _

) As C1HyperlinkInfo

[C#]

public C1HyperlinkInfo FindHyperlink(

PointD ptPage

);

[Delphi]

public function FindHyperlink(

ptPage: PointD

): C1HyperlinkInfo;

Parameters

ptPage

Point on page in resolved units.

Return Value

The C1HyperlinkInfo object describing the searchd hyperlink or null if not found.


Page.GetHyperlinks Method

Page.GetHyperlinks Method

Gets the list of all hyperlinks on page.

[Visual Basic]

Public Function GetHyperlinks() As C1HyperlinkInfoCollection

[C#]

public C1HyperlinkInfoCollection GetHyperlinks()

[Delphi]

public function GetHyperlinks(): C1HyperlinkInfoCollection;

Return Value

The C1HyperlinkInfoCollection collection containing the page's hyperlinks.


Page.GetInputFragments Method

Page.GetInputFragments Method

Gets the list of RenderInputFragments objects on this page.

[Visual Basic]

Public Function GetInputFragments( _

ByVal sort As Boolean _

) As RenderInputFragment()

[C#]

public RenderInputFragment[] GetInputFragments(

bool sort

);

[Delphi]

public function GetInputFragments(

sort: Boolean

): array of RenderInputFragment;

Return Value

Returns the array containing the list of RenderInputFragment objects.


PageBreakBehaviorEnum Enumeration

PageBreakBehaviorEnum Enumeration

Defines various options for the insertion of page breaks.

[Visual Basic]

Public Enum PageBreakBehaviorEnum

[C#]

public enum PageBreakBehaviorEnum

[Delphi]

type PageBreakBehaviorEnum = (Default, MustBreak, NoBreak, PreferredBreak);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
Default | A page break may be inserted if needed.
MustBreak | A page break is always inserted.
NoBreak | A page break can not be inserted.
PreferredBreak | If a page break is needed it should be inserted here.

See Also

C1.C1Preview Namespace


PageCollection Class

PageCollection Class

Represents the list of document's pages.

For a list of all members of this type, see PageCollection Members.

System.Object

System.Collections.CollectionBase

C1.C1Preview.OwnedCollection

C1.C1Preview.PageCollection

[Visual Basic]

Public Class PageCollection

Inherits OwnedCollection

[C#]

public class PageCollection : OwnedCollection

[Delphi]

type PageCollection = class (OwnedCollection);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


PageCollection Members

PageCollection Members

PageCollection overview

Public Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Document | C1Preview object containing this collection of pages.
Item |
MaxPageNo |
MaxPageX |
MaxPageY |
Owner (inherited from OwnedCollection) | Gets the owner of collection.

Public Methods

AssignFrom (inherited from OwnedCollection) |
Clear (inherited from CollectionBase) |
Find | Overloaded. Searches a page with the specified page number.
GetEnumerator (inherited from CollectionBase) |
IndexOf (inherited from OwnedCollection) | Searches for the specified Object and returns the zero-based index of the first occurrence within the entire collection.
RemoveAt (inherited from CollectionBase) |


PageCollection Properties

PageCollection Properties

The properties of the PageCollection class are listed here. For a complete list of PageCollection class members, see the PageCollection Members topic.

Public Properties

Capacity (inherited from CollectionBase) |
Count (inherited from CollectionBase) |
Document | C1Preview object containing this collection of pages.
Item |
MaxPageNo |
MaxPageX |
MaxPageY |
Owner (inherited from OwnedCollection) | Gets the owner of collection.


PageCollection.Document Property

PageCollection.Document Property

C1Preview object containing this collection of pages.

[Visual Basic]

Public ReadOnly Property Document As C1PrintDocument

[C#]

public C1PrintDocument Document {get;}

[Delphi]

public property Document: C1PrintDocument read get_Document;


PageCollection.Item Property

PageCollection.Item Property

[Visual Basic]

Public Default Property Item( _

ByVal index As Int32* _

) As Page

[C#]

public Page this[

Int32* index

] {get;set;}

[Delphi]

public property Item[

index: Int32*

]: Page read get_Item write set_Item;


PageCollection.MaxPageNo Property

PageCollection.MaxPageNo Property

[Visual Basic]

Public ReadOnly Property MaxPageNo As Int32*

[C#]

public Int32* MaxPageNo {get;}

[Delphi]

public property MaxPageNo: Int32* read get_MaxPageNo;


PageCollection.MaxPageX Property

PageCollection.MaxPageX Property

[Visual Basic]

Public ReadOnly Property MaxPageX As Int32*

[C#]

public Int32* MaxPageX {get;}

[Delphi]

public property MaxPageX: Int32* read get_MaxPageX;


PageCollection.MaxPageY Property

PageCollection.MaxPageY Property

[Visual Basic]

Public ReadOnly Property MaxPageY As Int32*

[C#]

public Int32* MaxPageY {get;}

[Delphi]

public property MaxPageY: Int32* read get_MaxPageY;


PageCollection Methods

PageCollection Methods

The methods of the PageCollection class are listed here. For a complete list of PageCollection class members, see the PageCollection Members topic.

Public Methods

AssignFrom (inherited from OwnedCollection) |
Clear (inherited from CollectionBase) |
Find | Overloaded. Searches a page with the specified page number.
GetEnumerator (inherited from CollectionBase) |
IndexOf (inherited from OwnedCollection) | Searches for the specified Object and returns the zero-based index of the first occurrence within the entire collection.
RemoveAt (inherited from CollectionBase) |


PageCollection.Find Method

PageCollection.Find Method

Overload List

Searches a page with the specified page number.

[Visual Basic] Overloads Public Function Find(Integer) As Page

[C#] public Page Find(int);

[Delphi] public function Find(Int32) : Page; overload;

Searches a page with the specified logical coordinates.

[Visual Basic] Overloads Public Function Find(Integer, Integer) As Page

[C#] public Page Find(int, int);

[Delphi] public function Find(Int32; Int32) : Page; overload;


PageCollection.Find Method (Int32)

PageCollection.Find Method (Int32)

Previous Next

Searches a page with the specified page number.

[Visual Basic]

Overloads Public Function Find( _

ByVal pageNo As Int32* _

) As Page

[C#]

public Page Find(

Int32* pageNo

);

[Delphi]

public function Find(

pageNo: Int32*

): Page; overload;

Return Value

Returns the found Page object or null.


PageCollection.Find Method (Int32, Int32)

PageCollection.Find Method (Int32, Int32)

Previous Next

Searches a page with the specified logical coordinates.

[Visual Basic]

Overloads Public Function Find( _

ByVal pageX As Int32*, _

ByVal pageY As Int32* _

) As Page

[C#]

public Page Find(

Int32* pageX,

Int32* pageY

);

[Delphi]

public function Find(

pageX: Int32*;

pageY: Int32*

): Page; overload;

Parameters

pageX

Indicates the X logical coordinate of page.

pageY

Indicates the Y logical coordinate of page.

Return Value

Returns the found Page object or null.


PageColumnDef Class

PageColumnDef Class

Defines parameters of a single page column.

For a list of all members of this type, see PageColumnDef Members.

System.Object

C1.C1Preview.PageColumnDef

[Visual Basic]

Public Class PageColumnDef

Implements ICloneable

[C#]

public class PageColumnDef : ICloneable

[Delphi]

type PageColumnDef = class (TObject, ICloneable);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


PageColumnDef Members

PageColumnDef Members

PageColumnDef overview

Public Properties

Spacing | Spacing between current column and next column.
Width | Width of the column.


PageColumnDef Properties

PageColumnDef Properties

The properties of the PageColumnDef class are listed here. For a complete list of PageColumnDef class members, see the PageColumnDef Members topic.

Public Properties

Spacing | Spacing between current column and next column.
Width | Width of the column.


PageColumnDef.Spacing Property

PageColumnDef.Spacing Property

Spacing between current column and next column.

[Visual Basic]

Public Property Spacing As Unit

[C#]

public Unit Spacing {get;set;}

[Delphi]

public property Spacing: Unit read get_Spacing write set_Spacing;


PageColumnDef.Width Property

PageColumnDef.Width Property

Width of the column.

[Visual Basic]

Public Property Width As Unit

[C#]

public Unit Width {get;set;}

[Delphi]

public property Width: Unit read get_Width write set_Width;


PageColumnDefCollection Class

PageColumnDefCollection Class

Represents the collection of page columns definitions which are items of type PageColumnDef.

For a list of all members of this type, see PageColumnDefCollection Members.

System.Object

System.Collections.CollectionBase

C1.C1Preview.PageColumnDefCollection

[Visual Basic]

Public Class PageColumnDefCollection

Inherits CollectionBase

[C#]

public class PageColumnDefCollection : CollectionBase

[Delphi]

type PageColumnDefCollection = class (CollectionBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


PageColumnDefCollection Members

PageColumnDefCollection Members

PageColumnDefCollection overview

Public Methods

Add

Overloaded. Add column with default parameters, width is auto, spacing - 5mm.


PageColumnDefCollection Methods

PageColumnDefCollection Methods

The methods of the PageColumnDefCollection class are listed here. For a complete list of PageColumnDefCollection class members, see the PageColumnDefCollection Members topic.

Public Methods

Add

Overloaded. Add column with default parameters, width is auto, spacing - 5mm.


PageColumnDefCollection.Add Method

PageColumnDefCollection.Add Method

Add column with default parameters, width is auto, spacing - 5mm.

[Visual Basic]

Public Function Add() As Int32*

[C#]

public Int32* Add()

[Delphi]

public function Add(): Int32*; overload;

Return Value

Returns the index of added column in collection.


PageDirectionEnum Enumeration

PageDirectionEnum Enumeration

Describes the direction in which the new page should be started.

[Visual Basic]

Public Enum PageDirectionEnum

[C#]

public enum PageDirectionEnum

[Delphi]

type PageDirectionEnum = (Default, Horizontal, Vertical);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
Default | Type of page (vertical or horizontal) is determinated on the basis of the current stacking rules. Vertical page is added if Stacking is StackingRulesEnum.BlockTopToBottom.

See Also

C1.C1Preview Namespace


PageJumpTypeEnum Enumeration

PageJumpTypeEnum Enumeration

Describes the supported modes of moving between pages.

[Visual Basic]

Public Enum PageJumpTypeEnum

[C#]

public enum PageJumpTypeEnum

[Delphi]

type PageJumpTypeEnum = (Absolute, First, Last, Next, Previous, Relative);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
Absolute | Move directly to specified page.
First | Move to first page.
Last | Move to last page.
Next | Move to next page.
Previous | Move to previous page.
Relative | Move to the specified page relative to current page.

See Also

C1.C1Preview Namespace


PageLayout Class

PageLayout Class

Represents the page layout of C1PrintDocument.

For a list of all members of this type, see PageLayout Members.

System.Object

C1.C1Preview.PageLayout

[Visual Basic]

Public Class PageLayout

Implements ICloneable

[C#]

public class PageLayout : ICloneable

[Delphi]

type PageLayout = class (TObject, ICloneable);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


PageLayout Members

PageLayout Members

PageLayout overview

Public Properties

Document

Gets the C1PrintDocument object to which this object is connected.

Public Methods

AssignFrom | Copies properties from another PageLayout object. All nested objects (render objects, page settings) are copied *by reference*.
Clone | Creates a new PageLayout object that is a copy of the current instance. All nested objects (render objects, page settings) are copied *by reference*.
Compare | Compares this PageLayout with other PageLayout object.
GetOwnedObjectCount | Calculates the count of render objects used in this PageLayout object.


PageLayout Properties

PageLayout Properties

The properties of the PageLayout class are listed here. For a complete list of PageLayout class members, see the PageLayout Members topic.

Public Properties

Document

Gets the C1PrintDocument object to which this object is connected.


PageLayout.Document Property

PageLayout.Document Property

Gets the C1PrintDocument object to which this object is connected.

[Visual Basic]

Public ReadOnly Property Document As C1PrintDocument

[C#]

public C1PrintDocument Document {get;}

[Delphi]

public property Document: C1PrintDocument read get_Document;


PageLayout Methods

PageLayout Methods

The methods of the PageLayout class are listed here. For a complete list of PageLayout class members, see the PageLayout Members topic.

Public Methods

AssignFrom | Copies properties from another PageLayout object. All nested objects (render objects, page settings) are copied *by reference*.
Clone | Creates a new PageLayout object that is a copy of the current instance. All nested objects (render objects, page settings) are copied *by reference*.
Compare | Compares this PageLayout with other PageLayout object.
GetOwnedObjectCount | Calculates the count of render objects used in this PageLayout object.


PageLayout.AssignFrom Method

PageLayout.AssignFrom Method

Copies properties from another PageLayout object. All nested objects (render objects, page settings) are copied *by reference*.

[Visual Basic]

Public Sub AssignFrom( _

ByVal source As PageLayout _

)

[C#]

public void AssignFrom(

PageLayout source

);

[Delphi]

public procedure AssignFrom(

source: PageLayout

);

Parameters

source

The another PageLayout object.


PageLayout.Clone Method

PageLayout.Clone Method

Creates a new PageLayout object that is a copy of the current instance. All nested objects (render objects, page settings) are copied *by reference*.

[Visual Basic]

Public Function Clone() As PageLayout

[C#]

public PageLayout Clone()

[Delphi]

public function Clone(): PageLayout;

Return Value

A new object that is a copy of this instance.


PageLayout.Compare Method

PageLayout.Compare Method

Compares this PageLayout with other PageLayout object.

[Visual Basic]

Public Function Compare( _

ByVal other As PageLayout _

) As Boolean

[C#]

public bool Compare(

PageLayout other

);

[Delphi]

public function Compare(

other: PageLayout

): Boolean;

Parameters

other

PageLayout object to compare to.

Return Value

Returns True if this PageLayout object equals other PageLayout object.


PageLayout.GetOwnedObjectCount Method

PageLayout.GetOwnedObjectCount Method

Calculates the count of render objects used in this PageLayout object.

[Visual Basic]

Public Function GetOwnedObjectCount() As Int32*

[C#]

public Int32* GetOwnedObjectCount()

[Delphi]

public function GetOwnedObjectCount(): Int32*;

Return Value

Returns the count of render objects used in this PageLayout object.


PageNumberingChange Class

PageNumberingChange Class

Describes the changing of the page numbering: to absolute number or increment from current value.

For a list of all members of this type, see PageNumberingChange Members.

System.Object

C1.C1Preview.PageNumberingChange

[Visual Basic]

Public Class PageNumberingChange

[C#]

public class PageNumberingChange

[Delphi]

type PageNumberingChange = class;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


PageNumberingChange Members

PageNumberingChange Members

PageNumberingChange overview

Public Properties

Mode | Gets or sets value describing how the page number will be changed.
Value | Gets or sets the value used to change current page number, using of value depends on Mode property: set for Set, added for Increment.

Public Methods

Parse

Converts a string to the PageNumberingChange object.


PageNumberingChange Properties

PageNumberingChange Properties

The properties of the PageNumberingChange class are listed here. For a complete list of PageNumberingChange class members, see the PageNumberingChange Members topic.

Public Properties

Mode | Gets or sets value describing how the page number will be changed.
Value | Gets or sets the value used to change current page number, using of value depends on Mode property: set for Set, added for Increment.


PageNumberingChange.Mode Property

PageNumberingChange.Mode Property

Gets or sets value describing how the page number will be changed.

[Visual Basic]

Public ReadOnly Property Mode As PageNumberingChangeModeEnum

[C#]

public PageNumberingChangeModeEnum Mode {get;}

[Delphi]

public property Mode: PageNumberingChangeModeEnum read get_Mode;


PageNumberingChange.Value Property

PageNumberingChange.Value Property

Gets or sets the value used to change current page number, using of value depends on Mode property: set for Set, added for Increment.

[Visual Basic]

Public ReadOnly Property Value As Int32*

[C#]

public Int32* Value {get;}

[Delphi]

public property Value: Int32* read get_Value;


PageNumberingChange Methods

PageNumberingChange Methods

The methods of the PageNumberingChange class are listed here. For a complete list of PageNumberingChange class members, see the PageNumberingChange Members topic.

Public Methods

Parse

Converts a string to the PageNumberingChange object.


PageNumberingChange.Parse Method

PageNumberingChange.Parse Method

Converts a string to the PageNumberingChange object.

[Visual Basic]

Public Shared Function Parse( _

ByVal s As String, _

ByVal throwException As Boolean _

) As PageNumberingChange

[C#]

public static PageNumberingChange Parse(

string s,

bool throwException

);

[Delphi]

public class function Parse(

s: String;

throwException: Boolean

): PageNumberingChange;

Parameters

s

The string to convert.

throwException

Indicates the exception should be thrown if string can not be converted to PageNumberingChange.

Return Value

The PageNumberingChange object or null if string is invalid and throwException is False.


PageNumberingChangeModeEnum Enumeration

PageNumberingChangeModeEnum Enumeration

Describes the type of changing of the page numbering.

[Visual Basic]

Public Enum PageNumberingChangeModeEnum

[C#]

public enum PageNumberingChangeModeEnum

[Delphi]

type PageNumberingChangeModeEnum = (Increment, Set);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
Increment | Change the page number on specified value.
Set | Set page number to absolute value.

See Also

C1.C1Preview Namespace


PageScalingEnum Enumeration

PageScalingEnum Enumeration

Specifies the way pages are scaled during printing.

[Visual Basic]

Public Enum PageScalingEnum

[C#]

public enum PageScalingEnum

[Delphi]

type PageScalingEnum = (FitToPaper, None, ReduceToPaper);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
FitToPaper | Pages are enlarged or made smaller if needed to fit paper.
None | Pages are not scaled.
ReduceToPaper | Pages are made smaller if needed to fit paper.

See Also

C1.C1Preview Namespace


ParagraphImage Class

ParagraphImage Class

Represents an inline image which is a part of a RenderParagraph.

For a list of all members of this type, see ParagraphImage Members.

System.Object

C1.C1Preview.ParagraphObject

C1.C1Preview.ParagraphImage

[Visual Basic]

Public Class ParagraphImage

Inherits ParagraphObject

[C#]

public class ParagraphImage : ParagraphObject

[Delphi]

type ParagraphImage = class (ParagraphObject);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ParagraphImage Members

ParagraphImage Members

ParagraphImage overview

Public Constructors

ParagraphImage Constructor

Initializes a new instance of the ParagraphImage class.

Public Properties

FirstFragment (inherited from ParagraphObject) | Gets the first fragment of RenderParagraph object where this ParagraphObject exists.
Hyperlink (inherited from ParagraphObject) | Gets or sets the hyperlink associated with this object.
Image | Gets or sets the image represented by this ParagraphImage object.
ImageName | Gets or sets the dictionary name of the image represented by this ParagraphImage object.
IndexInOwner (inherited from ParagraphObject) | Gets the index of this object in the ParagraphObjectCollection.
LastFragment (inherited from ParagraphObject) | Gets the last fragment of RenderParagraph object where this ParagraphObject exists.
Owner (inherited from ParagraphObject) | Gets the ParagraphObjectCollection representing the content of the paragraph containing this object.
PositionInText (inherited from ParagraphObject) | Gets the position of this ParagraphObject in the text.
RenderParagraph (inherited from ParagraphObject) | Gets the RenderParagraph containing this object.
Style (inherited from ParagraphObject) | Gets the style associated with this object.
TextLength (inherited from ParagraphObject) | Gets the length of this ParagraphObject in chars.

Public Methods

AssignFrom | Overriden. Assigns the properties of the current object from the specified ParagraphImage object.
Clone (inherited from ParagraphObject) | Clones the current ParagraphObject.


ParagraphImage Constructor

ParagraphImage Constructor

Overload List

Initializes a new instance of the ParagraphImage class.

[Visual Basic] Public Function New()

[C#] public ParagraphImage();

[Delphi] public constructor Create(); overload;

Initializes a new instance of the ParagraphImage class.

[Visual Basic] Public Function New(Image)

[C#] public ParagraphImage(Image);

[Delphi] public constructor Create(Image); overload;

Initializes a new instance of the ParagraphImage class.

[Visual Basic] Public Function New(String)

[C#] public ParagraphImage(string);

[Delphi] public constructor Create(String); overload;

Initializes a new instance of the ParagraphImage class.

[Visual Basic] Public Function New(Image, Style)

[C#] public ParagraphImage(Image, Style);

[Delphi] public constructor Create(Image; Style); overload;


ParagraphImage Constructor ()

ParagraphImage Constructor ()

Previous Next

Initializes a new instance of the ParagraphImage class.

[Visual Basic]

Public Function New()

[C#]

public ParagraphImage()

[Delphi]

public constructor Create(); overload;


ParagraphImage Constructor (Image)

ParagraphImage Constructor (Image)

Previous Next

Initializes a new instance of the ParagraphImage class.

[Visual Basic]

Public Function New( _

ByVal image As Image _

)

[C#]

public ParagraphImage(

Image image

);

[Delphi]

public constructor Create(

image: Image

); overload;

Parameters

image

The image of this ParagraphImage object.


ParagraphImage Constructor (String)

ParagraphImage Constructor (String)

Previous Next

Initializes a new instance of the ParagraphImage class.

[Visual Basic]

Public Function New( _

ByVal imageName As String _

)

[C#]

public ParagraphImage(

string imageName

);

[Delphi]

public constructor Create(

imageName: String

); overload;

Parameters

imageName

The dictionary name of the image of this ParagraphImage object.


ParagraphImage Constructor (Image, Style)

ParagraphImage Constructor (Image, Style)

Previous Next

Initializes a new instance of the ParagraphImage class.

[Visual Basic]

Public Function New( _

ByVal image As Image, _

ByVal style As Style _

)

[C#]

public ParagraphImage(

Image image,

Style style

);

[Delphi]

public constructor Create(

image: Image;

style: Style

); overload;

Parameters

image

The image of this ParagraphImage object.

style

The style to use for this ParagraphImage object.


ParagraphImage Properties

ParagraphImage Properties

The properties of the ParagraphImage class are listed here. For a complete list of ParagraphImage class members, see the ParagraphImage Members topic.

Public Properties

FirstFragment (inherited from ParagraphObject) | Gets the first fragment of RenderParagraph object where this ParagraphObject exists.
Hyperlink (inherited from ParagraphObject) | Gets or sets the hyperlink associated with this object.
Image | Gets or sets the image represented by this ParagraphImage object.
ImageName | Gets or sets the dictionary name of the image represented by this ParagraphImage object.
IndexInOwner (inherited from ParagraphObject) | Gets the index of this object in the ParagraphObjectCollection.
LastFragment (inherited from ParagraphObject) | Gets the last fragment of RenderParagraph object where this ParagraphObject exists.
Owner (inherited from ParagraphObject) | Gets the ParagraphObjectCollection representing the content of the paragraph containing this object.
PositionInText (inherited from ParagraphObject) | Gets the position of this ParagraphObject in the text.
RenderParagraph (inherited from ParagraphObject) | Gets the RenderParagraph containing this object.
Style (inherited from ParagraphObject) | Gets the style associated with this object.
TextLength (inherited from ParagraphObject) | Gets the length of this ParagraphObject in chars.


ParagraphImage.Image Property

ParagraphImage.Image Property

Gets or sets the image represented by this ParagraphImage object.

[Visual Basic]

Public Property Image As Image

[C#]

public Image Image {get;set;}

[Delphi]

public property Image: Image read get_Image write set_Image;


ParagraphImage.ImageName Property

ParagraphImage.ImageName Property

Gets or sets the dictionary name of the image represented by this ParagraphImage object.

[Visual Basic]

Public Property ImageName As String

[C#]

public string ImageName {get;set;}

[Delphi]

public property ImageName: String read get_ImageName write set_ImageName;


ParagraphImage Methods

ParagraphImage Methods

The methods of the ParagraphImage class are listed here. For a complete list of ParagraphImage class members, see the ParagraphImage Members topic.

Public Methods

AssignFrom | Overriden. Assigns the properties of the current object from the specified ParagraphImage object.
Clone (inherited from ParagraphObject) | Clones the current ParagraphObject.


ParagraphImage.AssignFrom Method

ParagraphImage.AssignFrom Method

Assigns the properties of the current object from the specified ParagraphImage object.

[Visual Basic]

Overrides Public Sub AssignFrom( _

ByVal source As ParagraphObject _

)

[C#]

override public void AssignFrom(

ParagraphObject source

);

[Delphi]

public procedure AssignFrom(

source: ParagraphObject

); override;

Parameters

source

The object to copy the properties from.


ParagraphObject Class

ParagraphObject Class

Represents a part of a RenderParagraph object - text, hyperlink or inline image.

For a list of all members of this type, see ParagraphObject Members.

System.Object

C1.C1Preview.ParagraphObject

C1.C1Preview.ParagraphImage

C1.C1Preview.ParagraphText

[Visual Basic]

MustInherit Public Class ParagraphObject

Implements ICloneable, IDocumentLocation

[C#]

public abstract class ParagraphObject : ICloneable, IDocumentLocation

[Delphi]

type ParagraphObject = class abstract (TObject, ICloneable, IDocumentLocation);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ParagraphObject Members

ParagraphObject Members

ParagraphObject overview

Public Constructors

ParagraphObject Constructor

Initializes a new instance of the ParagraphObject class.

Public Properties

FirstFragment | Gets the first fragment of RenderParagraph object where this ParagraphObject exists.
Hyperlink | Gets or sets the hyperlink associated with this object.
IndexInOwner | Gets the index of this object in the ParagraphObjectCollection.
LastFragment | Gets the last fragment of RenderParagraph object where this ParagraphObject exists.
Owner | Gets the ParagraphObjectCollection representing the content of the paragraph containing this object.
PositionInText | Gets the position of this ParagraphObject in the text.
RenderParagraph | Gets the RenderParagraph containing this object.
Style | Gets the style associated with this object.
TextLength | Gets the length of this ParagraphObject in chars.

Public Methods

AssignFrom | Assigns the properties of the current object from the specified ParagraphObject.
Clone | Clones the current ParagraphObject.


ParagraphObject Constructor

ParagraphObject Constructor

Initializes a new instance of the ParagraphObject class.

[Visual Basic]

Public Function New()

[C#]

public ParagraphObject()

[Delphi]

public constructor Create();


ParagraphObject Properties

ParagraphObject Properties

The properties of the ParagraphObject class are listed here. For a complete list of ParagraphObject class members, see the ParagraphObject Members topic.

Public Properties

FirstFragment | Gets the first fragment of RenderParagraph object where this ParagraphObject exists.
Hyperlink | Gets or sets the hyperlink associated with this object.
IndexInOwner | Gets the index of this object in the ParagraphObjectCollection.
LastFragment | Gets the last fragment of RenderParagraph object where this ParagraphObject exists.
Owner | Gets the ParagraphObjectCollection representing the content of the paragraph containing this object.
PositionInText | Gets the position of this ParagraphObject in the text.
RenderParagraph | Gets the RenderParagraph containing this object.
Style | Gets the style associated with this object.
TextLength | Gets the length of this ParagraphObject in chars.


ParagraphObject.FirstFragment Property

ParagraphObject.FirstFragment Property

Gets the first fragment of RenderParagraph object where this ParagraphObject exists.

[Visual Basic]

Public ReadOnly Property FirstFragment As RenderParagraphFragment

[C#]

public RenderParagraphFragment FirstFragment {get;}

[Delphi]

public property FirstFragment: RenderParagraphFragment read get_FirstFragment;


ParagraphObject.Hyperlink Property

ParagraphObject.Hyperlink Property

Gets or sets the hyperlink associated with this object.

[Visual Basic]

Public Property Hyperlink As C1Hyperlink

[C#]

public C1Hyperlink Hyperlink {get;set;}

[Delphi]

public property Hyperlink: C1Hyperlink read get_Hyperlink write set_Hyperlink;


ParagraphObject.IndexInOwner Property

ParagraphObject.IndexInOwner Property

Gets the index of this object in the ParagraphObjectCollection.

[Visual Basic]

Public ReadOnly Property IndexInOwner As Int32*

[C#]

public Int32* IndexInOwner {get;}

[Delphi]

public property IndexInOwner: Int32* read get_IndexInOwner;


ParagraphObject.LastFragment Property

ParagraphObject.LastFragment Property

Gets the last fragment of RenderParagraph object where this ParagraphObject exists.

[Visual Basic]

Public ReadOnly Property LastFragment As RenderParagraphFragment

[C#]

public RenderParagraphFragment LastFragment {get;}

[Delphi]

public property LastFragment: RenderParagraphFragment read get_LastFragment;


ParagraphObject.Owner Property

ParagraphObject.Owner Property

Gets the ParagraphObjectCollection representing the content of the paragraph containing this object.

[Visual Basic]

Public ReadOnly Property Owner As ParagraphObjectCollection

[C#]

public ParagraphObjectCollection Owner {get;}

[Delphi]

public property Owner: ParagraphObjectCollection read get_Owner;


ParagraphObject.PositionInText Property

ParagraphObject.PositionInText Property

Gets the position of this ParagraphObject in the text.

[Visual Basic]

Public ReadOnly Property PositionInText As Int32*

[C#]

public Int32* PositionInText {get;}

[Delphi]

public property PositionInText: Int32* read get_PositionInText;


ParagraphObject.RenderParagraph Property

ParagraphObject.RenderParagraph Property

Gets the RenderParagraph containing this object.

[Visual Basic]

Public ReadOnly Property RenderParagraph As RenderParagraph

[C#]

public RenderParagraph RenderParagraph {get;}

[Delphi]

public property RenderParagraph: RenderParagraph read get_RenderParagraph;


ParagraphObject.Style Property

ParagraphObject.Style Property

Gets the style associated with this object.

[Visual Basic]

Public ReadOnly Property Style As Style

[C#]

public Style Style {get;}

[Delphi]

public property Style: Style read get_Style;


ParagraphObject.TextLength Property

ParagraphObject.TextLength Property

Gets the length of this ParagraphObject in chars.

[Visual Basic]

Public ReadOnly Property TextLength As Int32*

[C#]

public Int32* TextLength {get;}

[Delphi]

public property TextLength: Int32* read get_TextLength;


ParagraphObject Methods

ParagraphObject Methods

The methods of the ParagraphObject class are listed here. For a complete list of ParagraphObject class members, see the ParagraphObject Members topic.

Public Methods

AssignFrom | Assigns the properties of the current object from the specified ParagraphObject.
Clone | Clones the current ParagraphObject.


ParagraphObject.AssignFrom Method

ParagraphObject.AssignFrom Method

Assigns the properties of the current object from the specified ParagraphObject.

[Visual Basic]

Overridable Public Sub AssignFrom( _

ByVal source As ParagraphObject _

)

[C#]

virtual public void AssignFrom(

ParagraphObject source

);

[Delphi]

public procedure AssignFrom(

source: ParagraphObject

); virtual;

Parameters

source

The object to copy the properties from.


ParagraphObject.Clone Method

ParagraphObject.Clone Method

Clones the current ParagraphObject.

[Visual Basic]

Public Function Clone() As ParagraphObject

[C#]

public ParagraphObject Clone()

[Delphi]

public function Clone(): ParagraphObject;

Return Value

The newly created object.


ParagraphObjectCollection Class

ParagraphObjectCollection Class

Represents a collection of ParagraphObject objects, which comprise the content of a RenderParagraph objects.

For a list of all members of this type, see ParagraphObjectCollection Members.

System.Object

System.Collections.CollectionBase

C1.C1Preview.OwnedCollection

C1.C1Preview.ParagraphObjectCollection

[Visual Basic]

Public Class ParagraphObjectCollection

Inherits OwnedCollection

[C#]

public class ParagraphObjectCollection : OwnedCollection

[Delphi]

type ParagraphObjectCollection = class (OwnedCollection);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ParagraphObjectCollection Members

ParagraphObjectCollection Members

ParagraphObjectCollection overview

Public Properties

Item | Indicates the ParagraphObject at the specified indexed location in the collection.
RenderParagraph | Gets the RenderParagraph object containing this ParagraphObject.

Public Methods

Add | Adds ParagraphObject to this collection.
AddHyperlink | Overloaded. Adds a hyperlink to the current paragraph.
AddImage | Overloaded. Adds an inline image to the current paragraph.
AddText | Overloaded. Adds the specified text string to the current paragraph.
Remove | Removes the specified object from the collection.


ParagraphObjectCollection Properties

ParagraphObjectCollection Properties

The properties of the ParagraphObjectCollection class are listed here. For a complete list of ParagraphObjectCollection class members, see the ParagraphObjectCollection Members topic.

Public Properties

Item | Indicates the ParagraphObject at the specified indexed location in the collection.
RenderParagraph | Gets the RenderParagraph object containing this ParagraphObject.


ParagraphObjectCollection.Item Property

ParagraphObjectCollection.Item Property

Indicates the ParagraphObject at the specified indexed location in the collection.

[Visual Basic]

Public Default Property Item( _

ByVal index As Int32* _

) As ParagraphObject

[C#]

public ParagraphObject this[

Int32* index

] {get;set;}

[Delphi]

public property Item[

index: Int32*

]: ParagraphObject read get_Item write set_Item;

Parameters

index

The index of the ParagraphObject to retrieve from the collection.

Property Value

The ParagraphObject located at the specified index location within the collection.


ParagraphObjectCollection.RenderParagraph Property

ParagraphObjectCollection.RenderParagraph Property

Gets the RenderParagraph object containing this ParagraphObject.

[Visual Basic]

Public ReadOnly Property RenderParagraph As RenderParagraph

[C#]

public RenderParagraph RenderParagraph {get;}

[Delphi]

public property RenderParagraph: RenderParagraph read get_RenderParagraph;


ParagraphObjectCollection Methods

ParagraphObjectCollection Methods

The methods of the ParagraphObjectCollection class are listed here. For a complete list of ParagraphObjectCollection class members, see the ParagraphObjectCollection Members topic.

Public Methods

Add | Adds ParagraphObject to this collection.
AddHyperlink | Overloaded. Adds a hyperlink to the current paragraph.
AddImage | Overloaded. Adds an inline image to the current paragraph.
AddText | Overloaded. Adds the specified text string to the current paragraph.
Remove | Removes the specified object from the collection.


ParagraphObjectCollection.Add Method

ParagraphObjectCollection.Add Method

Adds ParagraphObject to this collection.

[Visual Basic]

Public Function Add( _

ByVal po As ParagraphObject _

) As Int32*

[C#]

public Int32* Add(

ParagraphObject po

);

[Delphi]

public function Add(

po: ParagraphObject

): Int32*;

Parameters

po

The ParagraphObject to add.

Return Value

The index of the newly added object in the collection.


ParagraphObjectCollection.AddHyperlink Method

ParagraphObjectCollection.AddHyperlink Method

Overload List

Adds a hyperlink to the current paragraph.

[Visual Basic] Overloads Public Function AddHyperlink(Image, C1LinkTarget) As ParagraphImage

[C#] public ParagraphImage AddHyperlink(Image, C1LinkTarget);

[Delphi] public function AddHyperlink(Image; C1LinkTarget) : ParagraphImage; overload;

Adds a hyperlink to the current paragraph.

[Visual Basic] Overloads Public Function AddHyperlink(Image, ParagraphObject) As ParagraphImage

[C#] public ParagraphImage AddHyperlink(Image, ParagraphObject);

[Delphi] public function AddHyperlink(Image; ParagraphObject) : ParagraphImage; overload;

Adds a hyperlink to the current paragraph.

[Visual Basic] Overloads Public Function AddHyperlink(Image, RenderObject) As ParagraphImage

[C#] public ParagraphImage AddHyperlink(Image, RenderObject);

[Delphi] public function AddHyperlink(Image; RenderObject) : ParagraphImage; overload;

Adds a hyperlink to the current paragraph.

[Visual Basic] Overloads Public Function AddHyperlink(Image, String) As ParagraphImage

[C#] public ParagraphImage AddHyperlink(Image, string);

[Delphi] public function AddHyperlink(Image; String) : ParagraphImage; overload;

Adds a hyperlink to the current paragraph.

[Visual Basic] Overloads Public Function AddHyperlink(String, C1LinkTarget) As ParagraphText

[C#] public ParagraphText AddHyperlink(string, C1LinkTarget);

[Delphi] public function AddHyperlink(String; C1LinkTarget) : ParagraphText; overload;

Adds a hyperlink to the current paragraph.

[Visual Basic] Overloads Public Function AddHyperlink(String, ParagraphObject) As ParagraphText

[C#] public ParagraphText AddHyperlink(string, ParagraphObject);

[Delphi] public function AddHyperlink(String; ParagraphObject) : ParagraphText; overload;

Adds a hyperlink to the current paragraph.

[Visual Basic] Overloads Public Function AddHyperlink(String, RenderObject) As ParagraphText

[C#] public ParagraphText AddHyperlink(string, RenderObject);

[Delphi] public function AddHyperlink(String; RenderObject) : ParagraphText; overload;

Adds a hyperlink to the current paragraph.

[Visual Basic] Overloads Public Function AddHyperlink(String, String) As ParagraphText

[C#] public ParagraphText AddHyperlink(string, string);

[Delphi] public function AddHyperlink(String; String) : ParagraphText; overload;

Adds a hyperlink to the current paragraph.

[Visual Basic] Overloads Public Function AddHyperlink(String, C1LinkTarget, Style) As ParagraphText

[C#] public ParagraphText AddHyperlink(string, C1LinkTarget, Style);

[Delphi] public function AddHyperlink(String; C1LinkTarget; Style) : ParagraphText; overload;

Adds a hyperlink to the current paragraph.

[Visual Basic] Overloads Public Function AddHyperlink(String, String, Style) As ParagraphText

[C#] public ParagraphText AddHyperlink(string, string, Style);

[Delphi] public function AddHyperlink(String; String; Style) : ParagraphText; overload;


ParagraphObjectCollection.AddHyperlink Method (Image, C1LinkTarget)

ParagraphObjectCollection.AddHyperlink Method (Image, C1LinkTarget)

Previous Next

Adds a hyperlink to the current paragraph.

[Visual Basic]

Overloads Public Function AddHyperlink( _

ByVal image As Image, _

ByVal target As C1LinkTarget _

) As ParagraphImage

[C#]

public ParagraphImage AddHyperlink(

Image image,

C1LinkTarget target

);

[Delphi]

public function AddHyperlink(

image: Image;

target: C1LinkTarget

): ParagraphImage; overload;

Parameters

image

The image representing the hyperlink.

target

The target of this hyperlink.

Return Value

The ParagraphImage object created to represent the hyperlink.


ParagraphObjectCollection.AddHyperlink Method (Image, ParagraphObject)

ParagraphObjectCollection.AddHyperlink Method (Image, ParagraphObject)

Previous Next

Adds a hyperlink to the current paragraph.

[Visual Basic]

Overloads Public Function AddHyperlink( _

ByVal image As Image, _

ByVal paragraphObject As ParagraphObject _

) As ParagraphImage

[C#]

public ParagraphImage AddHyperlink(

Image image,

ParagraphObject paragraphObject

);

[Delphi]

public function AddHyperlink(

image: Image;

paragraphObject: ParagraphObject

): ParagraphImage; overload;

Parameters

image

The image representing the hyperlink.

paragraphObject

The ParagraphObject which is the target of this hyperlink.

Return Value

The ParagraphImage object created to represent the hyperlink.


ParagraphObjectCollection.AddHyperlink Method (Image, RenderObject)

ParagraphObjectCollection.AddHyperlink Method (Image, RenderObject)

Previous Next

Adds a hyperlink to the current paragraph.

[Visual Basic]

Overloads Public Function AddHyperlink( _

ByVal image As Image, _

ByVal renderObject As RenderObject _

) As ParagraphImage

[C#]

public ParagraphImage AddHyperlink(

Image image,

RenderObject renderObject

);

[Delphi]

public function AddHyperlink(

image: Image;

renderObject: RenderObject

): ParagraphImage; overload;

Parameters

image

The image representing the hyperlink.

renderObject

The RenderObject which is the target of this hyperlink.

Return Value

The ParagraphImage object created to represent the hyperlink.


ParagraphObjectCollection.AddHyperlink Method (Image, String)

ParagraphObjectCollection.AddHyperlink Method (Image, String)

Previous Next

Adds a hyperlink to the current paragraph.

[Visual Basic]

Overloads Public Function AddHyperlink( _

ByVal image As Image, _

ByVal anchorName As String _

) As ParagraphImage

[C#]

public ParagraphImage AddHyperlink(

Image image,

string anchorName

);

[Delphi]

public function AddHyperlink(

image: Image;

anchorName: String

): ParagraphImage; overload;

Parameters

image

The image representing the hyperlink.

anchorName

The name of the anchor which is the target of this hyperlink.

Return Value

The ParagraphImage object created to represent the hyperlink.


ParagraphObjectCollection.AddHyperlink Method (String, C1LinkTarget)

ParagraphObjectCollection.AddHyperlink Method (String, C1LinkTarget)

Previous Next

Adds a hyperlink to the current paragraph.

[Visual Basic]

Overloads Public Function AddHyperlink( _

ByVal text As String, _

ByVal target As C1LinkTarget _

) As ParagraphText

[C#]

public ParagraphText AddHyperlink(

string text,

C1LinkTarget target

);

[Delphi]

public function AddHyperlink(

text: String;

target: C1LinkTarget

): ParagraphText; overload;

Parameters

text

The string representing the hyperlink.

target

The target of this hyperlink.

Return Value

The ParagraphText object created to represent the hyperlink.


ParagraphObjectCollection.AddHyperlink Method (String, ParagraphObject)

ParagraphObjectCollection.AddHyperlink Method (String, ParagraphObject)

Previous Next

Adds a hyperlink to the current paragraph.

[Visual Basic]

Overloads Public Function AddHyperlink( _

ByVal text As String, _

ByVal paragraphObject As ParagraphObject _

) As ParagraphText

[C#]

public ParagraphText AddHyperlink(

string text,

ParagraphObject paragraphObject

);

[Delphi]

public function AddHyperlink(

text: String;

paragraphObject: ParagraphObject

): ParagraphText; overload;

Parameters

text

The string representing the hyperlink.

paragraphObject

The ParagraphObject which is the target of this hyperlink.

Return Value

The ParagraphText object created to represent the hyperlink.


ParagraphObjectCollection.AddHyperlink Method (String, RenderObject)

ParagraphObjectCollection.AddHyperlink Method (String, RenderObject)

Previous Next

Adds a hyperlink to the current paragraph.

[Visual Basic]

Overloads Public Function AddHyperlink( _

ByVal text As String, _

ByVal renderObject As RenderObject _

) As ParagraphText

[C#]

public ParagraphText AddHyperlink(

string text,

RenderObject renderObject

);

[Delphi]

public function AddHyperlink(

text: String;

renderObject: RenderObject

): ParagraphText; overload;

Parameters

text

The string representing the hyperlink.

renderObject

The RenderObject which is the target of this hyperlink.

Return Value

The ParagraphText object created to represent the hyperlink.


ParagraphObjectCollection.AddHyperlink Method (String, String)

ParagraphObjectCollection.AddHyperlink Method (String, String)

Previous Next

Adds a hyperlink to the current paragraph.

[Visual Basic]

Overloads Public Function AddHyperlink( _

ByVal text As String, _

ByVal anchorName As String _

) As ParagraphText

[C#]

public ParagraphText AddHyperlink(

string text,

string anchorName

);

[Delphi]

public function AddHyperlink(

text: String;

anchorName: String

): ParagraphText; overload;

Parameters

text

The string representing the hyperlink.

anchorName

The name of the anchor which is the target of this hyperlink.

Return Value

The ParagraphText object created to represent the hyperlink.


ParagraphObjectCollection.AddHyperlink Method (String, C1LinkTarget, Style)

ParagraphObjectCollection.AddHyperlink Method (String, C1LinkTarget, Style)

Previous Next

Adds a hyperlink to the current paragraph.

[Visual Basic]

Overloads Public Function AddHyperlink( _

ByVal text As String, _

ByVal target As C1LinkTarget, _

ByVal style As Style _

) As ParagraphText

[C#]

public ParagraphText AddHyperlink(

string text,

C1LinkTarget target,

Style style

);

[Delphi]

public function AddHyperlink(

text: String;

target: C1LinkTarget;

style: Style

): ParagraphText; overload;

Parameters

text

The string representing the hyperlink.

target

The target of this hyperlink.

style

The style to use to render this hyperlink.

Return Value

The ParagraphText object created to represent the hyperlink.


ParagraphObjectCollection.AddHyperlink Method (String, String, Style)

ParagraphObjectCollection.AddHyperlink Method (String, String, Style)

Previous Next

Adds a hyperlink to the current paragraph.

[Visual Basic]

Overloads Public Function AddHyperlink( _

ByVal text As String, _

ByVal anchorName As String, _

ByVal style As Style _

) As ParagraphText

[C#]

public ParagraphText AddHyperlink(

string text,

string anchorName,

Style style

);

[Delphi]

public function AddHyperlink(

text: String;

anchorName: String;

style: Style

): ParagraphText; overload;

Parameters

text

The string representing the hyperlink.

anchorName

The name of the anchor which is the target of this hyperlink.

style

The style to use to render this hyperlink.

Return Value

The ParagraphText object created to represent the hyperlink.


ParagraphObjectCollection.AddImage Method

ParagraphObjectCollection.AddImage Method

Overload List

Adds an inline image to the current paragraph.

[Visual Basic] Overloads Public Function AddImage(Image) As ParagraphImage

[C#] public ParagraphImage AddImage(Image);

[Delphi] public function AddImage(Image) : ParagraphImage; overload;

Adds an inline image to the current paragraph.

[Visual Basic] Overloads Public Function AddImage(String) As ParagraphImage

[C#] public ParagraphImage AddImage(string);

[Delphi] public function AddImage(String) : ParagraphImage; overload;

Adds an inline image to the current paragraph.

[Visual Basic] Overloads Public Function AddImage(Image, Style) As ParagraphImage

[C#] public ParagraphImage AddImage(Image, Style);

[Delphi] public function AddImage(Image; Style) : ParagraphImage; overload;


ParagraphObjectCollection.AddImage Method (Image)

ParagraphObjectCollection.AddImage Method (Image)

Previous Next

Adds an inline image to the current paragraph.

[Visual Basic]

Overloads Public Function AddImage( _

ByVal image As Image _

) As ParagraphImage

[C#]

public ParagraphImage AddImage(

Image image

);

[Delphi]

public function AddImage(

image: Image

): ParagraphImage; overload;

Parameters

image

The image to add to the paragraph.

Return Value

The ParagraphImage object created to represent the image.


ParagraphObjectCollection.AddImage Method (String)

ParagraphObjectCollection.AddImage Method (String)

Previous Next

Adds an inline image to the current paragraph.

[Visual Basic]

Overloads Public Function AddImage( _

ByVal imageName As String _

) As ParagraphImage

[C#]

public ParagraphImage AddImage(

string imageName

);

[Delphi]

public function AddImage(

imageName: String

): ParagraphImage; overload;

Parameters

imageName

The dictionary name of the image to add to the paragraph.

Return Value

The ParagraphImage object created to represent the image.


ParagraphObjectCollection.AddImage Method (Image, Style)

ParagraphObjectCollection.AddImage Method (Image, Style)

Previous Next

Adds an inline image to the current paragraph.

[Visual Basic]

Overloads Public Function AddImage( _

ByVal image As Image, _

ByVal style As Style _

) As ParagraphImage

[C#]

public ParagraphImage AddImage(

Image image,

Style style

);

[Delphi]

public function AddImage(

image: Image;

style: Style

): ParagraphImage; overload;

Parameters

image

The image to add to the paragraph.

style

The style to use to render the image.

Return Value

The ParagraphImage object created to represent the image.


ParagraphObjectCollection.AddText Method

ParagraphObjectCollection.AddText Method

Overload List

Adds the specified text string to the current paragraph.

[Visual Basic] Overloads Public Function AddText(String) As ParagraphText

[C#] public ParagraphText AddText(string);

[Delphi] public function AddText(String) : ParagraphText; overload;

Adds the specified text string to the current paragraph.

[Visual Basic] Overloads Public Function AddText(String, Color) As ParagraphText

[C#] public ParagraphText AddText(string, Color);

[Delphi] public function AddText(String; Color) : ParagraphText; overload;

Adds the specified text string to the current paragraph.

[Visual Basic] Overloads Public Function AddText(String, Font) As ParagraphText

[C#] public ParagraphText AddText(string, Font);

[Delphi] public function AddText(String; Font) : ParagraphText; overload;

Adds the specified text string to the current paragraph.

[Visual Basic] Overloads Public Function AddText(String, Style) As ParagraphText

[C#] public ParagraphText AddText(string, Style);

[Delphi] public function AddText(String; Style) : ParagraphText; overload;

Adds the specified text string to the current paragraph.

[Visual Basic] Overloads Public Function AddText(String, TextPositionEnum) As ParagraphText

[C#] public ParagraphText AddText(string, TextPositionEnum);

[Delphi] public function AddText(String; TextPositionEnum) : ParagraphText; overload;

Adds the specified text string to the current paragraph.

[Visual Basic] Overloads Public Function AddText(String, Color, TextPositionEnum) As ParagraphText

[C#] public ParagraphText AddText(string, Color, TextPositionEnum);

[Delphi] public function AddText(String; Color; TextPositionEnum) : ParagraphText; overload;

Adds the specified text string to the current paragraph.

[Visual Basic] Overloads Public Function AddText(String, Font, Color) As ParagraphText

[C#] public ParagraphText AddText(string, Font, Color);

[Delphi] public function AddText(String; Font; Color) : ParagraphText; overload;

Adds the specified text string to the current paragraph.

[Visual Basic] Overloads Public Function AddText(String, Font, TextPositionEnum) As ParagraphText

[C#] public ParagraphText AddText(string, Font, TextPositionEnum);

[Delphi] public function AddText(String; Font; TextPositionEnum) : ParagraphText; overload;

Adds the specified text string to the current paragraph.

[Visual Basic] Overloads Public Function AddText(String, Font, Color, TextPositionEnum) As ParagraphText

[C#] public ParagraphText AddText(string, Font, Color, TextPositionEnum);

[Delphi] public function AddText(String; Font; Color; TextPositionEnum) : ParagraphText; overload;


ParagraphObjectCollection.AddText Method (String)

ParagraphObjectCollection.AddText Method (String)

Previous Next

Adds the specified text string to the current paragraph.

[Visual Basic]

Overloads Public Function AddText( _

ByVal text As String _

) As ParagraphText

[C#]

public ParagraphText AddText(

string text

);

[Delphi]

public function AddText(

text: String

): ParagraphText; overload;

Parameters

text

The string to add.

Return Value

The ParagraphText object created to represent the specified text string.


ParagraphObjectCollection.AddText Method (String, Color)

ParagraphObjectCollection.AddText Method (String, Color)

Previous Next

Adds the specified text string to the current paragraph.

[Visual Basic]

Overloads Public Function AddText( _

ByVal text As String, _

ByVal textColor As Color _

) As ParagraphText

[C#]

public ParagraphText AddText(

string text,

Color textColor

);

[Delphi]

public function AddText(

text: String;

textColor: Color

): ParagraphText; overload;

Parameters

text

The string to add.

textColor

The text color to use to render the string.

Return Value

The ParagraphText object created to represent the specified text string.


ParagraphObjectCollection.AddText Method (String, Font)

ParagraphObjectCollection.AddText Method (String, Font)

Previous Next

Adds the specified text string to the current paragraph.

[Visual Basic]

Overloads Public Function AddText( _

ByVal text As String, _

ByVal font As Font _

) As ParagraphText

[C#]

public ParagraphText AddText(

string text,

Font font

);

[Delphi]

public function AddText(

text: String;

font: Font

): ParagraphText; overload;

Parameters

text

The string to add.

font

The font to use to render the string.

Return Value

The ParagraphText object created to represent the specified text string.


ParagraphObjectCollection.AddText Method (String, Style)

ParagraphObjectCollection.AddText Method (String, Style)

Previous Next

Adds the specified text string to the current paragraph.

[Visual Basic]

Overloads Public Function AddText( _

ByVal text As String, _

ByVal style As Style _

) As ParagraphText

[C#]

public ParagraphText AddText(

string text,

Style style

);

[Delphi]

public function AddText(

text: String;

style: Style

): ParagraphText; overload;

Parameters

text

The string to add.

style

The style to use to render the string.

Return Value

The ParagraphText object created to represent the specified text string.


ParagraphObjectCollection.AddText Method (String, TextPositionEnum)

ParagraphObjectCollection.AddText Method (String, TextPositionEnum)

Previous Next

Adds the specified text string to the current paragraph.

[Visual Basic]

Overloads Public Function AddText( _

ByVal text As String, _

ByVal textPosition As TextPositionEnum _

) As ParagraphText

[C#]

public ParagraphText AddText(

string text,

TextPositionEnum textPosition

);

[Delphi]

public function AddText(

text: String;

textPosition: TextPositionEnum

): ParagraphText; overload;

Parameters

text

The string to add.

textPosition

The text position to use to render the string.

Return Value

The ParagraphText object created to represent the specified text string.


ParagraphObjectCollection.AddText Method (String, Color, TextPositionEnum)

ParagraphObjectCollection.AddText Method (String, Color, TextPositionEnum)

Previous Next

Adds the specified text string to the current paragraph.

[Visual Basic]

Overloads Public Function AddText( _

ByVal text As String, _

ByVal textColor As Color, _

ByVal textPosition As TextPositionEnum _

) As ParagraphText

[C#]

public ParagraphText AddText(

string text,

Color textColor,

TextPositionEnum textPosition

);

[Delphi]

public function AddText(

text: String;

textColor: Color;

textPosition: TextPositionEnum

): ParagraphText; overload;

Parameters

text

The string to add.

textColor

The text color to use to render the string.

textPosition

The text position to use to render the string.

Return Value

The ParagraphText object created to represent the specified text string.


ParagraphObjectCollection.AddText Method (String, Font, Color)

ParagraphObjectCollection.AddText Method (String, Font, Color)

Previous Next

Adds the specified text string to the current paragraph.

[Visual Basic]

Overloads Public Function AddText( _

ByVal text As String, _

ByVal font As Font, _

ByVal textColor As Color _

) As ParagraphText

[C#]

public ParagraphText AddText(

string text,

Font font,

Color textColor

);

[Delphi]

public function AddText(

text: String;

font: Font;

textColor: Color

): ParagraphText; overload;

Parameters

text

The string to add.

font

The font to use to render the string.

textColor

The text color to use to render the string.

Return Value

The ParagraphText object created to represent the specified text string.


ParagraphObjectCollection.AddText Method (String, Font, TextPositionEnum)

ParagraphObjectCollection.AddText Method (String, Font, TextPositionEnum)

Previous Next

Adds the specified text string to the current paragraph.

[Visual Basic]

Overloads Public Function AddText( _

ByVal text As String, _

ByVal font As Font, _

ByVal textPosition As TextPositionEnum _

) As ParagraphText

[C#]

public ParagraphText AddText(

string text,

Font font,

TextPositionEnum textPosition

);

[Delphi]

public function AddText(

text: String;

font: Font;

textPosition: TextPositionEnum

): ParagraphText; overload;

Parameters

text

The string to add.

font

The font to use to render the string.

textPosition

The text position to use to render the string.

Return Value

The ParagraphText object created to represent the specified text string.


ParagraphObjectCollection.AddText Method (String, Font, Color, TextPositionEnum)

ParagraphObjectCollection.AddText Method (String, Font, Color, TextPositionEnum)

Previous Next

Adds the specified text string to the current paragraph.

[Visual Basic]

Overloads Public Function AddText( _

ByVal text As String, _

ByVal font As Font, _

ByVal textColor As Color, _

ByVal textPosition As TextPositionEnum _

) As ParagraphText

[C#]

public ParagraphText AddText(

string text,

Font font,

Color textColor,

TextPositionEnum textPosition

);

[Delphi]

public function AddText(

text: String;

font: Font;

textColor: Color;

textPosition: TextPositionEnum

): ParagraphText; overload;

Parameters

text

The string to add.

font

The font to use to render the string.

textColor

The text color to use to render the string.

textPosition

The text position to use to render the string.

Return Value

The ParagraphText object created to represent the specified text string.


ParagraphObjectCollection.Remove Method

ParagraphObjectCollection.Remove Method

Removes the specified object from the collection.

[Visual Basic]

Public Sub Remove( _

ByVal po As ParagraphObject _

)

[C#]

public void Remove(

ParagraphObject po

);

[Delphi]

public procedure Remove(

po: ParagraphObject

);

Parameters

po

The object to remove.


ParagraphText Class

ParagraphText Class

Represents a text which is a part of a RenderParagraph.

For a list of all members of this type, see ParagraphText Members.

System.Object

C1.C1Preview.ParagraphObject

C1.C1Preview.ParagraphText

[Visual Basic]

Public Class ParagraphText

Inherits ParagraphObject

[C#]

public class ParagraphText : ParagraphObject

[Delphi]

type ParagraphText = class (ParagraphObject);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ParagraphText Members

ParagraphText Members

ParagraphText overview

Public Constructors

ParagraphText Constructor

Initializes a new instance of the ParagraphText class.

Public Properties

FirstFragment (inherited from ParagraphObject) | Gets the first fragment of RenderParagraph object where this ParagraphObject exists.
Hyperlink (inherited from ParagraphObject) | Gets or sets the hyperlink associated with this object.
IndexInOwner (inherited from ParagraphObject) | Gets the index of this object in the ParagraphObjectCollection.
LastFragment (inherited from ParagraphObject) | Gets the last fragment of RenderParagraph object where this ParagraphObject exists.
Owner (inherited from ParagraphObject) | Gets the ParagraphObjectCollection representing the content of the paragraph containing this object.
PositionInText (inherited from ParagraphObject) | Gets the position of this ParagraphObject in the text.
RenderParagraph (inherited from ParagraphObject) | Gets the RenderParagraph containing this object.
Style (inherited from ParagraphObject) | Gets the style associated with this object.
Text | Gets or sets the text represented by this ParagraphText.
TextLength (inherited from ParagraphObject) | Gets the length of this ParagraphObject in chars.

Public Methods

AssignFrom | Overriden. Assigns the properties of the current object from the specified ParagraphText object.
Clone (inherited from ParagraphObject) | Clones the current ParagraphObject.


ParagraphText Constructor

ParagraphText Constructor

Overload List

Initializes a new instance of the ParagraphText class.

[Visual Basic] Public Function New()

[C#] public ParagraphText();

[Delphi] public constructor Create(); overload;

Initializes a new instance of the ParagraphText class.

[Visual Basic] Public Function New(String)

[C#] public ParagraphText(string);

[Delphi] public constructor Create(String); overload;

Initializes a new instance of the ParagraphText class.

[Visual Basic] Public Function New(String, Color)

[C#] public ParagraphText(string, Color);

[Delphi] public constructor Create(String; Color); overload;

Initializes a new instance of the ParagraphText class.

[Visual Basic] Public Function New(String, Font)

[C#] public ParagraphText(string, Font);

[Delphi] public constructor Create(String; Font); overload;

Initializes a new instance of the ParagraphText class.

[Visual Basic] Public Function New(String, Style)

[C#] public ParagraphText(string, Style);

[Delphi] public constructor Create(String; Style); overload;

Initializes a new instance of the ParagraphText class.

[Visual Basic] Public Function New(String, TextPositionEnum)

[C#] public ParagraphText(string, TextPositionEnum);

[Delphi] public constructor Create(String; TextPositionEnum); overload;

Initializes a new instance of the ParagraphText class.

[Visual Basic] Public Function New(String, Color, TextPositionEnum)

[C#] public ParagraphText(string, Color, TextPositionEnum);

[Delphi] public constructor Create(String; Color; TextPositionEnum); overload;

Initializes a new instance of the ParagraphText class.

[Visual Basic] Public Function New(String, Font, Color)

[C#] public ParagraphText(string, Font, Color);

[Delphi] public constructor Create(String; Font; Color); overload;

Initializes a new instance of the ParagraphText class.

[Visual Basic] Public Function New(String, Font, TextPositionEnum)

[C#] public ParagraphText(string, Font, TextPositionEnum);

[Delphi] public constructor Create(String; Font; TextPositionEnum); overload;

Initializes a new instance of the ParagraphText class.

[Visual Basic] Public Function New(String, Font, Color, TextPositionEnum)

[C#] public ParagraphText(string, Font, Color, TextPositionEnum);

[Delphi] public constructor Create(String; Font; Color; TextPositionEnum); overload;


ParagraphText Constructor ()

ParagraphText Constructor ()

Previous Next

Initializes a new instance of the ParagraphText class.

[Visual Basic]

Public Function New()

[C#]

public ParagraphText()

[Delphi]

public constructor Create(); overload;


ParagraphText Constructor (String)

ParagraphText Constructor (String)

Previous Next

Initializes a new instance of the ParagraphText class.

[Visual Basic]

Public Function New( _

ByVal text As String _

)

[C#]

public ParagraphText(

string text

);

[Delphi]

public constructor Create(

text: String

); overload;

Parameters

text

The text of this ParagraphText object.


ParagraphText Constructor (String, Color)

ParagraphText Constructor (String, Color)

Previous Next

Initializes a new instance of the ParagraphText class.

[Visual Basic]

Public Function New( _

ByVal text As String, _

ByVal textColor As Color _

)

[C#]

public ParagraphText(

string text,

Color textColor

);

[Delphi]

public constructor Create(

text: String;

textColor: Color

); overload;

Parameters

text

The text of this ParagraphText object.

textColor

The text color to use for this ParagraphText object.


ParagraphText Constructor (String, Font)

ParagraphText Constructor (String, Font)

Previous Next

Initializes a new instance of the ParagraphText class.

[Visual Basic]

Public Function New( _

ByVal text As String, _

ByVal font As Font _

)

[C#]

public ParagraphText(

string text,

Font font

);

[Delphi]

public constructor Create(

text: String;

font: Font

); overload;

Parameters

text

The text of this ParagraphText object.

font

The font to use for this ParagraphText object.


ParagraphText Constructor (String, Style)

ParagraphText Constructor (String, Style)

Previous Next

Initializes a new instance of the ParagraphText class.

[Visual Basic]

Public Function New( _

ByVal text As String, _

ByVal style As Style _

)

[C#]

public ParagraphText(

string text,

Style style

);

[Delphi]

public constructor Create(

text: String;

style: Style

); overload;

Parameters

text

The text of this ParagraphText object.

style

The style to use for this ParagraphText object.


ParagraphText Constructor (String, TextPositionEnum)

ParagraphText Constructor (String, TextPositionEnum)

Previous Next

Initializes a new instance of the ParagraphText class.

[Visual Basic]

Public Function New( _

ByVal text As String, _

ByVal textPosition As TextPositionEnum _

)

[C#]

public ParagraphText(

string text,

TextPositionEnum textPosition

);

[Delphi]

public constructor Create(

text: String;

textPosition: TextPositionEnum

); overload;

Parameters

text

The text of this ParagraphText object.

textPosition

The text position to use for this ParagraphText object.


ParagraphText Constructor (String, Color, TextPositionEnum)

ParagraphText Constructor (String, Color, TextPositionEnum)

Previous Next

Initializes a new instance of the ParagraphText class.

[Visual Basic]

Public Function New( _

ByVal text As String, _

ByVal textColor As Color, _

ByVal textPosition As TextPositionEnum _

)

[C#]

public ParagraphText(

string text,

Color textColor,

TextPositionEnum textPosition

);

[Delphi]

public constructor Create(

text: String;

textColor: Color;

textPosition: TextPositionEnum

); overload;

Parameters

text

The text of this ParagraphText object.

textColor

The text color to use for this ParagraphText object.

textPosition

The text position to use for this ParagraphText object.


ParagraphText Constructor (String, Font, Color)

ParagraphText Constructor (String, Font, Color)

Previous Next

Initializes a new instance of the ParagraphText class.

[Visual Basic]

Public Function New( _

ByVal text As String, _

ByVal font As Font, _

ByVal textColor As Color _

)

[C#]

public ParagraphText(

string text,

Font font,

Color textColor

);

[Delphi]

public constructor Create(

text: String;

font: Font;

textColor: Color

); overload;

Parameters

text

The text of this ParagraphText object.

font

The font to use for this ParagraphText object.

textColor

The text color to use for this ParagraphText object.


ParagraphText Constructor (String, Font, TextPositionEnum)

ParagraphText Constructor (String, Font, TextPositionEnum)

Previous Next

Initializes a new instance of the ParagraphText class.

[Visual Basic]

Public Function New( _

ByVal text As String, _

ByVal font As Font, _

ByVal textPosition As TextPositionEnum _

)

[C#]

public ParagraphText(

string text,

Font font,

TextPositionEnum textPosition

);

[Delphi]

public constructor Create(

text: String;

font: Font;

textPosition: TextPositionEnum

); overload;

Parameters

text

The text of this ParagraphText object.

font

The font to use for this ParagraphText object.

textPosition

The text position to use for this ParagraphText object.


ParagraphText Constructor (String, Font, Color, TextPositionEnum)

ParagraphText Constructor (String, Font, Color, TextPositionEnum)

Previous Next

Initializes a new instance of the ParagraphText class.

[Visual Basic]

Public Function New( _

ByVal text As String, _

ByVal font As Font, _

ByVal textColor As Color, _

ByVal textPosition As TextPositionEnum _

)

[C#]

public ParagraphText(

string text,

Font font,

Color textColor,

TextPositionEnum textPosition

);

[Delphi]

public constructor Create(

text: String;

font: Font;

textColor: Color;

textPosition: TextPositionEnum

); overload;

Parameters

text

The text of this ParagraphText object.

font

The font to use for this ParagraphText object.

textColor

The text color to use for this ParagraphText object.

textPosition

The text position to use for this ParagraphText object.


ParagraphText Properties

ParagraphText Properties

The properties of the ParagraphText class are listed here. For a complete list of ParagraphText class members, see the ParagraphText Members topic.

Public Properties

FirstFragment (inherited from ParagraphObject) | Gets the first fragment of RenderParagraph object where this ParagraphObject exists.
Hyperlink (inherited from ParagraphObject) | Gets or sets the hyperlink associated with this object.
IndexInOwner (inherited from ParagraphObject) | Gets the index of this object in the ParagraphObjectCollection.
LastFragment (inherited from ParagraphObject) | Gets the last fragment of RenderParagraph object where this ParagraphObject exists.
Owner (inherited from ParagraphObject) | Gets the ParagraphObjectCollection representing the content of the paragraph containing this object.
PositionInText (inherited from ParagraphObject) | Gets the position of this ParagraphObject in the text.
RenderParagraph (inherited from ParagraphObject) | Gets the RenderParagraph containing this object.
Style (inherited from ParagraphObject) | Gets the style associated with this object.
Text | Gets or sets the text represented by this ParagraphText.
TextLength (inherited from ParagraphObject) | Gets the length of this ParagraphObject in chars.


ParagraphText.Text Property

ParagraphText.Text Property

Gets or sets the text represented by this ParagraphText.

[Visual Basic]

Public Property Text As String

[C#]

public string Text {get;set;}

[Delphi]

public property Text: String read get_Text write set_Text;


ParagraphText Methods

ParagraphText Methods

The methods of the ParagraphText class are listed here. For a complete list of ParagraphText class members, see the ParagraphText Members topic.

Public Methods

AssignFrom | Overriden. Assigns the properties of the current object from the specified ParagraphText object.
Clone (inherited from ParagraphObject) | Clones the current ParagraphObject.


ParagraphText.AssignFrom Method

ParagraphText.AssignFrom Method

Assigns the properties of the current object from the specified ParagraphText object.

[Visual Basic]

Overrides Public Sub AssignFrom( _

ByVal source As ParagraphObject _

)

[C#]

override public void AssignFrom(

ParagraphObject source

);

[Delphi]

public procedure AssignFrom(

source: ParagraphObject

); override;

Parameters

source

The object to copy the properties from.


PolygonProps Class

PolygonProps Class

Represents the geometric properties of the RenderPolygon object.

For a list of all members of this type, see PolygonProps Members.

System.Object

C1.C1Preview.ShapeProps

C1.C1Preview.LinePropsBase

C1.C1Preview.PolygonProps

[Visual Basic]

Public Class PolygonProps

Inherits LinePropsBase

[C#]

public class PolygonProps : LinePropsBase

[Delphi]

type PolygonProps = class (LinePropsBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


PolygonProps Members

PolygonProps Members

PolygonProps overview

Public Properties

Closed | Indicates whether a polyline is closed or opened.
Points | Points defining a polyline.


PolygonProps Properties

PolygonProps Properties

The properties of the PolygonProps class are listed here. For a complete list of PolygonProps class members, see the PolygonProps Members topic.

Public Properties

Closed | Indicates whether a polyline is closed or opened.
Points | Points defining a polyline.


PolygonProps.Closed Property

PolygonProps.Closed Property

Indicates whether a polyline is closed or opened.

[Visual Basic]

Public Property Closed As Boolean

[C#]

public bool Closed {get;set;}

[Delphi]

public property Closed: Boolean read get_Closed write set_Closed;


PolygonProps.Points Property

PolygonProps.Points Property

Points defining a polyline.

[Visual Basic]

Public Property Points As UnitPoint()

[C#]

new public UnitPoint[] Points {get;set;}

[Delphi]

public property Points: array of UnitPoint read get_Points write set_Points;


PrintingUtil Class

PrintingUtil Class

For a list of all members of this type, see PrintingUtil Members.

System.Object

C1.C1Preview.PrintingUtil

[Visual Basic]

Public Class PrintingUtil

[C#]

public class PrintingUtil

[Delphi]

type PrintingUtil = class;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


PrintingUtil Members

PrintingUtil Members

PrintingUtil overview

Public Methods

GetPhysOffset

Overloaded. Gets the physical offset of the printed page, in 100th of an inch.


PrintingUtil Methods

PrintingUtil Methods

The methods of the PrintingUtil class are listed here. For a complete list of PrintingUtil class members, see the PrintingUtil Members topic.

Public Methods

GetPhysOffset

Overloaded. Gets the physical offset of the printed page, in 100th of an inch.


PrintingUtil.GetPhysOffset Method

PrintingUtil.GetPhysOffset Method

Overload List

Gets the physical offset of the printed page, in 100th of an inch.

[Visual Basic] Overloads Public Shared Sub GetPhysOffset(Graphics, ByRef Double, ByRef Double)

[C#] public static void GetPhysOffset(Graphics, ref double, ref double);

[Delphi] public class procedure GetPhysOffset(Graphics; out Double; out Double); overload;

Gets the physical offset of the printed page, in 100th of an inch.

[Visual Basic] Overloads Public Shared Sub GetPhysOffset(IntPtr, ByRef Double, ByRef Double)

[C#] public static void GetPhysOffset(IntPtr, ref double, ref double);

[Delphi] public class procedure GetPhysOffset(IntPtr; out Double; out Double); overload;


PrintingUtil.GetPhysOffset Method (Graphics, ByRef Double, ByRef Double)

PrintingUtil.GetPhysOffset Method (Graphics, ByRef Double, ByRef Double)

Previous Next

Gets the physical offset of the printed page, in 100th of an inch.

[Visual Basic]

Overloads Public Shared Sub GetPhysOffset( _

ByVal g As Graphics, _

ByRef left As Double, _

ByRef top As Double _

)

[C#]

public static void GetPhysOffset(

Graphics g,

out double left,

out double top

);

[Delphi]

public class procedure GetPhysOffset(

g: Graphics;

out left: Double;

out top: Double

); overload;

Parameters

g

left

Left physical offset

top

Top physical offset


PrintingUtil.GetPhysOffset Method (IntPtr, ByRef Double, ByRef Double)

PrintingUtil.GetPhysOffset Method (IntPtr, ByRef Double, ByRef Double)

Previous Next

Gets the physical offset of the printed page, in 100th of an inch.

[Visual Basic]

Overloads Public Shared Sub GetPhysOffset( _

ByVal hdc As IntPtr, _

ByRef left As Double, _

ByRef top As Double _

)

[C#]

public static void GetPhysOffset(

IntPtr hdc,

out double left,

out double top

);

[Delphi]

public class procedure GetPhysOffset(

hdc: IntPtr;

out left: Double;

out top: Double

); overload;

Parameters

hdc

Handle to device context

left

Left physical offset

top

Top physical offset


RectangleD Structure

RectangleD Structure

Stores a set of four double numbers that represent the location and size of a rectangle.

For a list of all members of this type, see RectangleD Members.

System.Object

System.ValueType

C1.C1Preview.RectangleD

[Visual Basic]

Public Structure RectangleD

[C#]

public struct RectangleD

[Delphi]

type RectangleD = record;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RectangleD Members

RectangleD Members

RectangleD overview

Public Properties

Bottom | Gets the y-coordinate of the bottom edge of this RectangleD structure.
Empty | Represents an instance of the RectangleD class with its members uninitialized.
Height | Gets or sets the height of this RectangleD structure.
IsEmpty | Tests whether the Width or Height property of this RectangleD has a value of zero.
Left | Gets the x-coordinate of the left edge of this RectangleD structure.
Location | Gets or sets the coordinates of the upper-left corner of this RectangleD structure.
Right | Gets the x-coordinate of the right edge of this RectangleD structure.
Size | Gets or sets the size of this RectangleD.
Top | Gets the y-coordinate of the top edge of this RectangleD structure.
Width | Gets or sets the width of this RectangleD structure.
X | Gets or sets the x-coordinate of the upper-left corner of this RectangleD structure.
Y | Gets or sets the y-coordinate of the upper-left corner of this RectangleD structure.

Public Methods

Contains | Overloaded. Determines if the specified point is contained within this RectangleD structure.
FromLTRB | Creates a RectangleD structure with upper-left corner and lower-right corner at the specified locations.
Inflate | Overloaded. Creates and returns an inflated copy of the specified RectangleD structure. The copy is inflated by the specified amount. The original rectangle remains unmodified.
Intersect | Overloaded. Replaces this RectangleD structure with the intersection of itself and the specified RectangleD structure.
IntersectsWith | Determines if this rectangle intersects with rect.
Offset | Overloaded. Adjusts the location of this rectangle by the specified amount.
Parse | Converts a string to the RectangleD structure.
ToString | Overriden. Overridden. Converts the Location and Size of this RectangleD to a human-readable string.
Union | Creates the smallest possible third rectangle that can contain both of two rectangles that form a union.


RectangleD Properties

RectangleD Properties

The properties of the RectangleD structure are listed here. For a complete list of RectangleD structure members, see the RectangleD Members topic.

Public Properties

Bottom | Gets the y-coordinate of the bottom edge of this RectangleD structure.
Empty | Represents an instance of the RectangleD class with its members uninitialized.
Height | Gets or sets the height of this RectangleD structure.
IsEmpty | Tests whether the Width or Height property of this RectangleD has a value of zero.
Left | Gets the x-coordinate of the left edge of this RectangleD structure.
Location | Gets or sets the coordinates of the upper-left corner of this RectangleD structure.
Right | Gets the x-coordinate of the right edge of this RectangleD structure.
Size | Gets or sets the size of this RectangleD.
Top | Gets the y-coordinate of the top edge of this RectangleD structure.
Width | Gets or sets the width of this RectangleD structure.
X | Gets or sets the x-coordinate of the upper-left corner of this RectangleD structure.
Y | Gets or sets the y-coordinate of the upper-left corner of this RectangleD structure.


RectangleD.Bottom Property

RectangleD.Bottom Property

Gets the y-coordinate of the bottom edge of this RectangleD structure.

[Visual Basic]

Public ReadOnly Property Bottom As Double

[C#]

public double Bottom {get;}

[Delphi]

public property Bottom: Double read get_Bottom;


RectangleD.Empty Property

RectangleD.Empty Property

Represents an instance of the RectangleD class with its members uninitialized.

[Visual Basic]

Public Shared ReadOnly Property Empty As RectangleD

[C#]

public static RectangleD Empty {get;}

[Delphi]

public class property Empty: RectangleD read get_Empty;


RectangleD.Height Property

RectangleD.Height Property

Gets or sets the height of this RectangleD structure.

[Visual Basic]

Public Property Height As Double

[C#]

public double Height {get;set;}

[Delphi]

public property Height: Double read get_Height write set_Height;


RectangleD.IsEmpty Property

RectangleD.IsEmpty Property

Tests whether the Width or Height property of this RectangleD has a value of zero.

[Visual Basic]

Public ReadOnly Property IsEmpty As Boolean

[C#]

public bool IsEmpty {get;}

[Delphi]

public property IsEmpty: Boolean read get_IsEmpty;


RectangleD.Left Property

RectangleD.Left Property

Gets the x-coordinate of the left edge of this RectangleD structure.

[Visual Basic]

Public ReadOnly Property Left As Double

[C#]

public double Left {get;}

[Delphi]

public property Left: Double read get_Left;


RectangleD.Location Property

RectangleD.Location Property

Gets or sets the coordinates of the upper-left corner of this RectangleD structure.

[Visual Basic]

Public Property Location As PointD

[C#]

public PointD Location {get;set;}

[Delphi]

public property Location: PointD read get_Location write set_Location;


RectangleD.Right Property

RectangleD.Right Property

Gets the x-coordinate of the right edge of this RectangleD structure.

[Visual Basic]

Public ReadOnly Property Right As Double

[C#]

public double Right {get;}

[Delphi]

public property Right: Double read get_Right;


RectangleD.Size Property

RectangleD.Size Property

Gets or sets the size of this RectangleD.

[Visual Basic]

Public Property Size As SizeD

[C#]

public SizeD Size {get;set;}

[Delphi]

public property Size: SizeD read get_Size write set_Size;


RectangleD.Top Property

RectangleD.Top Property

Gets the y-coordinate of the top edge of this RectangleD structure.

[Visual Basic]

Public ReadOnly Property Top As Double

[C#]

public double Top {get;}

[Delphi]

public property Top: Double read get_Top;


RectangleD.Width Property

RectangleD.Width Property

Gets or sets the width of this RectangleD structure.

[Visual Basic]

Public Property Width As Double

[C#]

public double Width {get;set;}

[Delphi]

public property Width: Double read get_Width write set_Width;


RectangleD.X Property

RectangleD.X Property

Gets or sets the x-coordinate of the upper-left corner of this RectangleD structure.

[Visual Basic]

Public Property X As Double

[C#]

public double X {get;set;}

[Delphi]

public property X: Double read get_X write set_X;


RectangleD.Y Property

RectangleD.Y Property

Gets or sets the y-coordinate of the upper-left corner of this RectangleD structure.

[Visual Basic]

Public Property Y As Double

[C#]

public double Y {get;set;}

[Delphi]

public property Y: Double read get_Y write set_Y;


RectangleD Methods

RectangleD Methods

The methods of the RectangleD structure are listed here. For a complete list of RectangleD structure members, see the RectangleD Members topic.

Public Methods

Contains | Overloaded. Determines if the specified point is contained within this RectangleD structure.
FromLTRB | Creates a RectangleD structure with upper-left corner and lower-right corner at the specified locations.
Inflate | Overloaded. Creates and returns an inflated copy of the specified RectangleD structure. The copy is inflated by the specified amount. The original rectangle remains unmodified.
Intersect | Overloaded. Replaces this RectangleD structure with the intersection of itself and the specified RectangleD structure.
IntersectsWith | Determines if this rectangle intersects with rect.
Offset | Overloaded. Adjusts the location of this rectangle by the specified amount.
Parse | Converts a string to the RectangleD structure.
ToString | Overriden. Overridden. Converts the Location and Size of this RectangleD to a human-readable string.
Union | Creates the smallest possible third rectangle that can contain both of two rectangles that form a union.


RectangleD.Contains Method

RectangleD.Contains Method

Overload List

Determines if the specified point is contained within this RectangleD structure.

[Visual Basic] Overloads Public Function Contains(Double, Double) As Boolean

[C#] public bool Contains(double, double);

[Delphi] public function Contains(Double; Double) : Boolean; overload;

Determines if the specified point is contained within this RectangleD structure.

[Visual Basic] Overloads Public Function Contains(PointD) As Boolean

[C#] public bool Contains(PointD);

[Delphi] public function Contains(PointD) : Boolean; overload;

Determines if the rectangular region represented by rect is entirely contained within this RectangleD structure.

[Visual Basic] Overloads Public Function Contains(RectangleD) As Boolean

[C#] public bool Contains(RectangleD);

[Delphi] public function Contains(RectangleD) : Boolean; overload;


RectangleD.Contains Method (Double, Double)

RectangleD.Contains Method (Double, Double)

Previous Next

Determines if the specified point is contained within this RectangleD structure.

[Visual Basic]

Overloads Public Function Contains( _

ByVal x As Double, _

ByVal y As Double _

) As Boolean

[C#]

public bool Contains(

double x,

double y

);

[Delphi]

public function Contains(

x: Double;

y: Double

): Boolean; overload;

Parameters

x

The x-coordinate of the point to test.

y

The y-coordinate of the point to test.

Return Value

This method returns True if the point defined by x and y is contained within this RectangleD structure; otherwise False.


RectangleD.Contains Method (PointD)

RectangleD.Contains Method (PointD)

Previous Next

Determines if the specified point is contained within this RectangleD structure.

[Visual Basic]

Overloads Public Function Contains( _

ByVal pt As PointD _

) As Boolean

[C#]

public bool Contains(

PointD pt

);

[Delphi]

public function Contains(

pt: PointD

): Boolean; overload;

Parameters

pt

The PointD to test.

Return Value

This method returns True if the point represented by the pt parameter is contained within this RectangleD structure; otherwise False.


RectangleD.Contains Method (RectangleD)

RectangleD.Contains Method (RectangleD)

Previous Next

Determines if the rectangular region represented by rect is entirely contained within this RectangleD structure.

[Visual Basic]

Overloads Public Function Contains( _

ByVal rect As RectangleD _

) As Boolean

[C#]

public bool Contains(

RectangleD rect

);

[Delphi]

public function Contains(

rect: RectangleD

): Boolean; overload;

Parameters

rect

The RectangleD to test.

Return Value

This method returns True if the rectangular region represented by rect is entirely contained within the rectangular region represented by this RectangleD; otherwise False.


RectangleD.FromLTRB Method

RectangleD.FromLTRB Method

Creates a RectangleD structure with upper-left corner and lower-right corner at the specified locations.

[Visual Basic]

Public Shared Function FromLTRB( _

ByVal left As Double, _

ByVal top As Double, _

ByVal right As Double, _

ByVal bottom As Double _

) As RectangleD

[C#]

public static RectangleD FromLTRB(

double left,

double top,

double right,

double bottom

);

[Delphi]

public class function FromLTRB(

left: Double;

top: Double;

right: Double;

bottom: Double

): RectangleD;

Parameters

left

The x-coordinate of the upper-left corner of the rectangular region.

top

The y-coordinate of the upper-left corner of the rectangular region.

right

The x-coordinate of the lower-right corner of the rectangular region.

bottom

The y-coordinate of the lower-right corner of the rectangular region.

Return Value

The new RectangleD that this method creates.


RectangleD.Inflate Method

RectangleD.Inflate Method

Overload List

Inflates this RectangleD by the specified amount.

[Visual Basic] Overloads Public Sub Inflate(Double, Double)

[C#] public void Inflate(double, double);

[Delphi] public procedure Inflate(Double; Double); overload;

Inflates this RectangleD by the specified amount.

[Visual Basic] Overloads Public Sub Inflate(SizeD)

[C#] public void Inflate(SizeD);

[Delphi] public procedure Inflate(SizeD); overload;

Creates and returns an inflated copy of the specified RectangleD structure. The copy is inflated by the specified amount. The original rectangle remains unmodified.

[Visual Basic] Overloads Public Shared Function Inflate(RectangleD, Double, Double) As RectangleD

[C#] public static RectangleD Inflate(RectangleD, double, double);

[Delphi] public class function Inflate(RectangleD; Double; Double) : RectangleD; overload;

Inflates this RectangleD by the specified amount.

[Visual Basic] Overloads Public Sub Inflate(Double, Double, Double, Double)

[C#] public void Inflate(double, double, double, double);

[Delphi] public procedure Inflate(Double; Double; Double; Double); overload;


RectangleD.Inflate Method (Double, Double)

RectangleD.Inflate Method (Double, Double)

Previous Next

Inflates this RectangleD by the specified amount.

[Visual Basic]

Overloads Public Sub Inflate( _

ByVal x As Double, _

ByVal y As Double _

)

[C#]

public void Inflate(

double x,

double y

);

[Delphi]

public procedure Inflate(

x: Double;

y: Double

); overload;


RectangleD.Inflate Method (SizeD)

RectangleD.Inflate Method (SizeD)

Previous Next

Inflates this RectangleD by the specified amount.

[Visual Basic]

Overloads Public Sub Inflate( _

ByVal size As SizeD _

)

[C#]

public void Inflate(

SizeD size

);

[Delphi]

public procedure Inflate(

size: SizeD

); overload;


RectangleD.Inflate Method (RectangleD, Double, Double)

RectangleD.Inflate Method (RectangleD, Double, Double)

Previous Next

Creates and returns an inflated copy of the specified RectangleD structure. The copy is inflated by the specified amount. The original rectangle remains unmodified.

[Visual Basic]

Overloads Public Shared Function Inflate( _

ByVal rect As RectangleD, _

ByVal x As Double, _

ByVal y As Double _

) As RectangleD

[C#]

public static RectangleD Inflate(

RectangleD rect,

double x,

double y

);

[Delphi]

public class function Inflate(

rect: RectangleD;

x: Double;

y: Double

): RectangleD; overload;

Parameters

rect

The RectangleF to be copied. This rectangle is not modified.

x

The amount to inflate the copy of the rectangle horizontally.

y

The amount to inflate the copy of the rectangle vertically.

Return Value

The inflated RectangleD.


RectangleD.Inflate Method (Double, Double, Double, Double)

RectangleD.Inflate Method (Double, Double, Double, Double)

Previous Next

Inflates this RectangleD by the specified amount.

[Visual Basic]

Overloads Public Sub Inflate( _

ByVal left As Double, _

ByVal top As Double, _

ByVal right As Double, _

ByVal bottom As Double _

)

[C#]

public void Inflate(

double left,

double top,

double right,

double bottom

);

[Delphi]

public procedure Inflate(

left: Double;

top: Double;

right: Double;

bottom: Double

); overload;

Parameters

left

The amount to inflate this RectangleD structure from left.

top

The amount to inflate this RectangleD structure from top.

right

The amount to inflate this RectangleD structure from right.

bottom

The amount to inflate this RectangleD structure from bottom.


RectangleD.Intersect Method

RectangleD.Intersect Method

Overload List

Replaces this RectangleD structure with the intersection of itself and the specified RectangleD structure.

[Visual Basic] Overloads Public Sub Intersect(RectangleD)

[C#] public void Intersect(RectangleD);

[Delphi] public procedure Intersect(RectangleD); overload;

Returns a RectangleD structure that represents the intersection of two rectangles. If there is no intersection, and empty RectangleD is returned.

[Visual Basic] Overloads Public Shared Function Intersect(RectangleD, RectangleD) As RectangleD

[C#] public static RectangleD Intersect(RectangleD, RectangleD);

[Delphi] public class function Intersect(RectangleD; RectangleD) : RectangleD; overload;


RectangleD.Intersect Method (RectangleD)

RectangleD.Intersect Method (RectangleD)

Previous Next

Replaces this RectangleD structure with the intersection of itself and the specified RectangleD structure.

[Visual Basic]

Overloads Public Sub Intersect( _

ByVal rect As RectangleD _

)

[C#]

public void Intersect(

RectangleD rect

);

[Delphi]

public procedure Intersect(

rect: RectangleD

); overload;

Parameters

rect

The rectangle to intersect.


RectangleD.Intersect Method (RectangleD, RectangleD)

RectangleD.Intersect Method (RectangleD, RectangleD)

Previous Next

Returns a RectangleD structure that represents the intersection of two rectangles. If there is no intersection, and empty RectangleD is returned.

[Visual Basic]

Overloads Public Shared Function Intersect( _

ByVal a As RectangleD, _

ByVal b As RectangleD _

) As RectangleD

[C#]

public static RectangleD Intersect(

RectangleD a,

RectangleD b

);

[Delphi]

public class function Intersect(

a: RectangleD;

b: RectangleD

): RectangleD; overload;

Parameters

a

A rectangle to intersect.

b

A rectangle to intersect.

Return Value

A third RectangleD structure the size of which represents the overlapped area of the two specified rectangles.


RectangleD.IntersectsWith Method

RectangleD.IntersectsWith Method

Determines if this rectangle intersects with rect.

[Visual Basic]

Public Function IntersectsWith( _

ByVal rect As RectangleD _

) As Boolean

[C#]

public bool IntersectsWith(

RectangleD rect

);

[Delphi]

public function IntersectsWith(

rect: RectangleD

): Boolean;

Parameters

rect

The rectangle to test.

Return Value

This method returns True if there is any intersection.


RectangleD.Offset Method

RectangleD.Offset Method

Overload List

Adjusts the location of this rectangle by the specified amount.

[Visual Basic] Overloads Public Sub Offset(Double, Double)

[C#] public void Offset(double, double);

[Delphi] public procedure Offset(Double; Double); overload;

Adjusts the location of this rectangle by the specified amount.

[Visual Basic] Overloads Public Sub Offset(PointD)

[C#] public void Offset(PointD);

[Delphi] public procedure Offset(PointD); overload;


RectangleD.Offset Method (Double, Double)

RectangleD.Offset Method (Double, Double)

Previous Next

Adjusts the location of this rectangle by the specified amount.

[Visual Basic]

Overloads Public Sub Offset( _

ByVal x As Double, _

ByVal y As Double _

)

[C#]

public void Offset(

double x,

double y

);

[Delphi]

public procedure Offset(

x: Double;

y: Double

); overload;

Parameters

x

The amount to offset the location horizontally.

y

The amount to offset the location vertically.


RectangleD.Offset Method (PointD)

RectangleD.Offset Method (PointD)

Previous Next

Adjusts the location of this rectangle by the specified amount.

[Visual Basic]

Overloads Public Sub Offset( _

ByVal pt As PointD _

)

[C#]

public void Offset(

PointD pt

);

[Delphi]

public procedure Offset(

pt: PointD

); overload;

Parameters

pt

The amount to offset the location.


RectangleD.Parse Method

RectangleD.Parse Method

Converts a string to the RectangleD structure.

[Visual Basic]

Public Shared Function Parse( _

ByVal s As String, _

ByRef result As RectangleD, _

ByVal throwException As Boolean _

) As Boolean

[C#]

public static bool Parse(

string s,

out RectangleD result,

bool throwException

);

[Delphi]

public class function Parse(

s: String;

out result: RectangleD;

throwException: Boolean

): Boolean;

Parameters

s

The string to convert.

result

The RectangleD structure.

throwException

Indicates the exception should be thrown if string can not be converted to RectangleD.

Return Value

Returns True if no error occurs.


RectangleD.ToString Method

RectangleD.ToString Method

Overridden. Converts the Location and Size of this RectangleD to a human-readable string.

[Visual Basic]

Overrides Public Function ToString() As String

[C#]

override public string ToString()

[Delphi]

public function ToString(): String; override;

Return Value

A string that contains the position, width, and height of this RectangleD structure, for example, "{X=20, Y=20, Width=100, Height=50}".


RectangleD.Union Method

RectangleD.Union Method

Creates the smallest possible third rectangle that can contain both of two rectangles that form a union.

[Visual Basic]

Public Shared Function Union( _

ByVal a As RectangleD, _

ByVal b As RectangleD _

) As RectangleD

[C#]

public static RectangleD Union(

RectangleD a,

RectangleD b

);

[Delphi]

public class function Union(

a: RectangleD;

b: RectangleD

): RectangleD;

Parameters

a

A rectangle to union.

b

A rectangle to union.

Return Value

A third RectangleD structure that contains both of the two rectangles that form the union.


RectangleProps Class

RectangleProps Class

The base class of properties of all rectangle-based shapes like rectangle, ellipse, arc, pie.

For a list of all members of this type, see RectangleProps Members.

System.Object

C1.C1Preview.ShapeProps

C1.C1Preview.RectangleProps

C1.C1Preview.EllipsePartProps

C1.C1Preview.RoundRectangleProps

[Visual Basic]

Public Class RectangleProps

Inherits ShapeProps

[C#]

public class RectangleProps : ShapeProps

[Delphi]

type RectangleProps = class (ShapeProps);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RectangleProps Members

RectangleProps Members

RectangleProps overview


RefDim Enumeration

RefDim Enumeration

Internal, describes the dimensions of object.

[Visual Basic]

Public Enum RefDim

[C#]

public enum RefDim

[Delphi]

type RefDim = (AbsCoord, BorderBottom, BorderLeft, BorderRight, Borders, BorderTop, Bottom, BottomCoord, ChildBottom, ChildCoord, ChildHeight, ChildLeft, ChildRight, ChildTop, ChildWidth, Height, HeightDim, Left, LeftCoord, Offsets, Padding, PaddingBottom, PaddingLeft, PaddingRight, PaddingTop, RelBottom, RelCoord, RelLeft, RelRight, RelTop, Right, RightCoord, Size, Spacing, SpacingBottom, SpacingLeft, SpacingRight, SpacingTop, Top, TopCoord, Width, WidthDim);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
Left, Top, Right, Bottom | Absolute coordinates on page.
RelLeft, RelTop, RelRight, RelBottom | Relative coordinates in parent.
ChildLeft, ChildTop, ChildRight, ChildBottom | Relative coordinates for child objects, ChildLeft and ChildTop are always 0, ChildRight = Width - SpacingLeft - SpacingRight - PaddingLeft - PaddingRight - BordersLeft - BordersRight.
Width, Height | Sizes of object.
ChildWidth, ChildHeight | Sizes for child objects, for example, ChildWidth is Width - (SpacingLeft + BorderLeft + PaddingLeft) - (SpacingRight + BorderRight + PaddingRight).

See Also

C1.C1Preview Namespace


ReferenceEnum Enumeration

ReferenceEnum Enumeration

Describes the types of references between objects.

[Visual Basic]

Public Enum ReferenceEnum

[C#]

public enum ReferenceEnum

[Delphi]

type ReferenceEnum = (Column, Id, Name, Next, Page, Parent, Prev, Self);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
Column | Reference to the column on page.
Id | Reference to the object by its Id. This type of refernce used only for backward compatibility.
Name | Reference to the object by its name.
Next | Reference to the next object on the same level.
Page | Reference to the page.
Parent | Reference to the parent object.
Prev | Reference to the previous object on the same level.
Self | Reference to the current object.

See Also

C1.C1Preview Namespace


RenderArc Class

RenderArc Class

Represents RO that renders ellipse-based wedge.

For a list of all members of this type, see RenderArc Members.

System.Object

C1.C1Preview.RenderObject

C1.C1Preview.RenderShapeBase

C1.C1Preview.RenderRectangle

C1.C1Preview.RenderEllipse

C1.C1Preview.RenderArc

[Visual Basic]

Public Class RenderArc

Inherits RenderEllipse

[C#]

public class RenderArc : RenderEllipse

[Delphi]

type RenderArc = class (RenderEllipse);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderArc Members

RenderArc Members

RenderArc overview

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderArc Properties

RenderArc Properties

The properties of the RenderArc class are listed here. For a complete list of RenderArc class members, see the RenderArc Members topic.

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.


RenderArc Methods

RenderArc Methods

The methods of the RenderArc class are listed here. For a complete list of RenderArc class members, see the RenderArc Members topic.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderArea Class

RenderArea Class

For a list of all members of this type, see RenderArea Members.

System.Object

C1.C1Preview.RenderObject

C1.C1Preview.RenderArea

C1.C1Preview.RenderC1Printable

C1.C1Preview.RenderToc

[Visual Basic]

Public Class RenderArea

Inherits RenderObject

[C#]

public class RenderArea : RenderObject

[Delphi]

type RenderArea = class (RenderObject);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderArea Members

RenderArea Members

RenderArea overview

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderArea Properties

RenderArea Properties

The properties of the RenderArea class are listed here. For a complete list of RenderArea class members, see the RenderArea Members topic.

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.


RenderArea Methods

RenderArea Methods

The methods of the RenderArea class are listed here. For a complete list of RenderArea class members, see the RenderArea Members topic.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderAreaFragment Class

RenderAreaFragment Class

For a list of all members of this type, see RenderAreaFragment Members.

System.Object

C1.C1Preview.RenderFragment

C1.C1Preview.RenderAreaFragment

C1.C1Preview.RenderC1PrintableFragment

[Visual Basic]

Public Class RenderAreaFragment

Inherits RenderFragment

[C#]

public class RenderAreaFragment : RenderFragment

[Delphi]

type RenderAreaFragment = class (RenderFragment);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderAreaFragment Members

RenderAreaFragment Members

RenderAreaFragment overview

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.
ResolvingFinished (inherited from RenderFragment) | This method is called by the render engine after fully resolving of render fragment. Typically this method is used to clear temporary info used during resolving.


RenderAreaFragment Properties

RenderAreaFragment Properties

The properties of the RenderAreaFragment class are listed here. For a complete list of RenderAreaFragment class members, see the RenderAreaFragment Members topic.

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.


RenderAreaFragment Methods

RenderAreaFragment Methods

The methods of the RenderAreaFragment class are listed here. For a complete list of RenderAreaFragment class members, see the RenderAreaFragment Members topic.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.
ResolvingFinished (inherited from RenderFragment) | This method is called by the render engine after fully resolving of render fragment. Typically this method is used to clear temporary info used during resolving.


RenderC1Printable Class

RenderC1Printable Class

Represents RO that renders the objects supporting the IC1Printable interface.

For a list of all members of this type, see RenderC1Printable Members.

System.Object

C1.C1Preview.RenderObject

C1.C1Preview.RenderArea

C1.C1Preview.RenderC1Printable

[Visual Basic]

Public Class RenderC1Printable

Inherits RenderArea

[C#]

public class RenderC1Printable : RenderArea

[Delphi]

type RenderC1Printable = class (RenderArea);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderC1Printable Members

RenderC1Printable Members

RenderC1Printable overview

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IgnoreObjectPageLayout | Gets or sets value indicating whether the page layout defined by object should be ignored. This property is used only when object returns its content as document.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
Object | Object to render, it must supports the IC1Printable interface.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderC1Printable Properties

RenderC1Printable Properties

The properties of the RenderC1Printable class are listed here. For a complete list of RenderC1Printable class members, see the RenderC1Printable Members topic.

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IgnoreObjectPageLayout | Gets or sets value indicating whether the page layout defined by object should be ignored. This property is used only when object returns its content as document.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
Object | Object to render, it must supports the IC1Printable interface.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.


RenderC1Printable.IgnoreObjectPageLayout Property

RenderC1Printable.IgnoreObjectPageLayout Property

Gets or sets value indicating whether the page layout defined by object should be ignored. This property is used only when object returns its content as document.

[Visual Basic]

Public Property IgnoreObjectPageLayout As Boolean

[C#]

public bool IgnoreObjectPageLayout {get;set;}

[Delphi]

public property IgnoreObjectPageLayout: Boolean read get_IgnoreObjectPageLayout write set_IgnoreObjectPageLayout;


RenderC1Printable.Object Property

RenderC1Printable.Object Property

Object to render, it must supports the IC1Printable interface.

[Visual Basic]

Public Property Object As Object

[C#]

public object Object {get;set;}

[Delphi]

public property Object: Object read get_Object write set_Object;


RenderC1Printable Methods

RenderC1Printable Methods

The methods of the RenderC1Printable class are listed here. For a complete list of RenderC1Printable class members, see the RenderC1Printable Members topic.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderC1PrintableFragment Class

RenderC1PrintableFragment Class

Represents a fragment of the RenderC1Printable object.

For a list of all members of this type, see RenderC1PrintableFragment Members.

System.Object

C1.C1Preview.RenderFragment

C1.C1Preview.RenderAreaFragment

C1.C1Preview.RenderC1PrintableFragment

[Visual Basic]

Public Class RenderC1PrintableFragment

Inherits RenderAreaFragment

[C#]

public class RenderC1PrintableFragment : RenderAreaFragment

[Delphi]

type RenderC1PrintableFragment = class (RenderAreaFragment);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderC1PrintableFragment Members

RenderC1PrintableFragment Members

RenderC1PrintableFragment overview

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.
ResolvingFinished (inherited from RenderFragment) | This method is called by the render engine after fully resolving of render fragment. Typically this method is used to clear temporary info used during resolving.


RenderC1PrintableFragment Properties

RenderC1PrintableFragment Properties

The properties of the RenderC1PrintableFragment class are listed here. For a complete list of RenderC1PrintableFragment class members, see the RenderC1PrintableFragment Members topic.

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.


RenderC1PrintableFragment Methods

RenderC1PrintableFragment Methods

The methods of the RenderC1PrintableFragment class are listed here. For a complete list of RenderC1PrintableFragment class members, see the RenderC1PrintableFragment Members topic.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.
ResolvingFinished (inherited from RenderFragment) | This method is called by the render engine after fully resolving of render fragment. Typically this method is used to clear temporary info used during resolving.


RenderEllipse Class

RenderEllipse Class

Represents RO that renders ellipse.

For a list of all members of this type, see RenderEllipse Members.

System.Object

C1.C1Preview.RenderObject

C1.C1Preview.RenderShapeBase

C1.C1Preview.RenderRectangle

C1.C1Preview.RenderEllipse

C1.C1Preview.RenderArc

C1.C1Preview.RenderPie

[Visual Basic]

Public Class RenderEllipse

Inherits RenderRectangle

[C#]

public class RenderEllipse : RenderRectangle

[Delphi]

type RenderEllipse = class (RenderRectangle);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderEllipse Members

RenderEllipse Members

RenderEllipse overview

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderEllipse Properties

RenderEllipse Properties

The properties of the RenderEllipse class are listed here. For a complete list of RenderEllipse class members, see the RenderEllipse Members topic.

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.


RenderEllipse Methods

RenderEllipse Methods

The methods of the RenderEllipse class are listed here. For a complete list of RenderEllipse class members, see the RenderEllipse Members topic.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderEmpty Class

RenderEmpty Class

Represents RO that renders images.

For a list of all members of this type, see RenderEmpty Members.

System.Object

C1.C1Preview.RenderObject

C1.C1Preview.RenderEmpty

[Visual Basic]

Public Class RenderEmpty

Inherits RenderObject

[C#]

public class RenderEmpty : RenderObject

[Delphi]

type RenderEmpty = class (RenderObject);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderEmpty Members

RenderEmpty Members

RenderEmpty overview

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderEmpty Properties

RenderEmpty Properties

The properties of the RenderEmpty class are listed here. For a complete list of RenderEmpty class members, see the RenderEmpty Members topic.

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.


RenderEmpty Methods

RenderEmpty Methods

The methods of the RenderEmpty class are listed here. For a complete list of RenderEmpty class members, see the RenderEmpty Members topic.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderEmptyFragment Class

RenderEmptyFragment Class

Represents a fragment of the RenderEmpty object.

For a list of all members of this type, see RenderEmptyFragment Members.

System.Object

C1.C1Preview.RenderFragment

C1.C1Preview.RenderEmptyFragment

[Visual Basic]

Public Class RenderEmptyFragment

Inherits RenderFragment

[C#]

public class RenderEmptyFragment : RenderFragment

[Delphi]

type RenderEmptyFragment = class (RenderFragment);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderEmptyFragment Members

RenderEmptyFragment Members

RenderEmptyFragment overview

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.
ResolvingFinished (inherited from RenderFragment) | This method is called by the render engine after fully resolving of render fragment. Typically this method is used to clear temporary info used during resolving.


RenderEmptyFragment Properties

RenderEmptyFragment Properties

The properties of the RenderEmptyFragment class are listed here. For a complete list of RenderEmptyFragment class members, see the RenderEmptyFragment Members topic.

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.


RenderEmptyFragment Methods

RenderEmptyFragment Methods

The methods of the RenderEmptyFragment class are listed here. For a complete list of RenderEmptyFragment class members, see the RenderEmptyFragment Members topic.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.
ResolvingFinished (inherited from RenderFragment) | This method is called by the render engine after fully resolving of render fragment. Typically this method is used to clear temporary info used during resolving.


RenderFragment Class

RenderFragment Class

Represents the fragment of RenderObject.

For a list of all members of this type, see RenderFragment Members.

System.Object

C1.C1Preview.RenderFragment

C1.C1Preview.RenderAreaFragment

C1.C1Preview.RenderEmptyFragment

C1.C1Preview.RenderGraphicsFragment

C1.C1Preview.RenderImageFragment

C1.C1Preview.RenderInputFragment

C1.C1Preview.RenderRichTextFragment

C1.C1Preview.RenderShapeFragment

C1.C1Preview.RenderTableFragment

C1.C1Preview.RenderTextFragmentBase

[Visual Basic]

MustInherit Public Class RenderFragment

[C#]

public abstract class RenderFragment

[Delphi]

type RenderFragment = class abstract;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderFragment Members

RenderFragment Members

RenderFragment overview

Public Properties

Bounds | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage | Gets the bounds of object on page.
Children | Gets a collection of child objects.
Document | Gets C1PrintDocument object containing this object.
HasChildren | Returns True if fragment has child fragments.
IndexInParent | Gets index of fragment in its parent.
IndexInRenderObject | Gets index of fragment in its own RenderObject object.
InnerBounds | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage | Gets the bounds of inner area of object on page.
Level | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea | Gets the PageAreaBase object.
Parent | Gets the parent RenderFragment object.
RenderObject | Gets the RenderObject object which has produced this object.
TopParent | Gets the top-parent RenderFragment object.
Visible | Indicates whether the fragment is visible.

Public Methods

AssignFrom | Copies all properties from another RenderFragment object, the Children collection is copied also.
Clone | Creates and returns a copy of render fragment.
DetachFromRenderObject | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.
Draw | Overloaded. Paints fragment on specified graphics.
FindHyperlink | Searches the C1Hyperlink object in the render fragment at specified position.
GetAnchorRect | Calculates the information about specified anchor.
GetHyperlinks | Adds the fragment's hyperlinks in the passed collection.
ResolvingFinished | This method is called by the render engine after fully resolving of render fragment. Typically this method is used to clear temporary info used during resolving.


RenderFragment Properties

RenderFragment Properties

The properties of the RenderFragment class are listed here. For a complete list of RenderFragment class members, see the RenderFragment Members topic.

Public Properties

Bounds | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage | Gets the bounds of object on page.
Children | Gets a collection of child objects.
Document | Gets C1PrintDocument object containing this object.
HasChildren | Returns True if fragment has child fragments.
IndexInParent | Gets index of fragment in its parent.
IndexInRenderObject | Gets index of fragment in its own RenderObject object.
InnerBounds | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage | Gets the bounds of inner area of object on page.
Level | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea | Gets the PageAreaBase object.
Parent | Gets the parent RenderFragment object.
RenderObject | Gets the RenderObject object which has produced this object.
TopParent | Gets the top-parent RenderFragment object.
Visible | Indicates whether the fragment is visible.


RenderFragment.Bounds Property

RenderFragment.Bounds Property

Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.

[Visual Basic]

Public Property Bounds As RectangleD

[C#]

public RectangleD Bounds {get;set;}

[Delphi]

public property Bounds: RectangleD read get_Bounds write set_Bounds;


RenderFragment.BoundsOnPage Property

RenderFragment.BoundsOnPage Property

Gets the bounds of object on page.

[Visual Basic]

Public ReadOnly Property BoundsOnPage As RectangleD

[C#]

public RectangleD BoundsOnPage {get;}

[Delphi]

public property BoundsOnPage: RectangleD read get_BoundsOnPage;


RenderFragment.Children Property

RenderFragment.Children Property

Gets a collection of child objects.

[Visual Basic]

Public ReadOnly Property Children As RenderFragmentCollection

[C#]

public RenderFragmentCollection Children {get;}

[Delphi]

public property Children: RenderFragmentCollection read get_Children;


RenderFragment.Document Property

RenderFragment.Document Property

Gets C1PrintDocument object containing this object.

[Visual Basic]

Public ReadOnly Property Document As C1PrintDocument

[C#]

public C1PrintDocument Document {get;}

[Delphi]

public property Document: C1PrintDocument read get_Document;


RenderFragment.HasChildren Property

RenderFragment.HasChildren Property

Returns True if fragment has child fragments.

[Visual Basic]

Public ReadOnly Property HasChildren As Boolean

[C#]

public bool HasChildren {get;}

[Delphi]

public property HasChildren: Boolean read get_HasChildren;


RenderFragment.IndexInParent Property

RenderFragment.IndexInParent Property

Gets index of fragment in its parent.

[Visual Basic]

Public ReadOnly Property IndexInParent As Int32*

[C#]

public Int32* IndexInParent {get;}

[Delphi]

public property IndexInParent: Int32* read get_IndexInParent;


RenderFragment.IndexInRenderObject Property

RenderFragment.IndexInRenderObject Property

Gets index of fragment in its own RenderObject object.

[Visual Basic]

Public ReadOnly Property IndexInRenderObject As Int32*

[C#]

public Int32* IndexInRenderObject {get;}

[Delphi]

public property IndexInRenderObject: Int32* read get_IndexInRenderObject;


RenderFragment.InnerBounds Property

RenderFragment.InnerBounds Property

Gets the rectangle of content area of object, without spacing, border, padding.

[Visual Basic]

Public ReadOnly Property InnerBounds As RectangleD

[C#]

public RectangleD InnerBounds {get;}

[Delphi]

public property InnerBounds: RectangleD read get_InnerBounds;


RenderFragment.InnerBoundsOnPage Property

RenderFragment.InnerBoundsOnPage Property

Gets the bounds of inner area of object on page.

[Visual Basic]

Public ReadOnly Property InnerBoundsOnPage As RectangleD

[C#]

public RectangleD InnerBoundsOnPage {get;}

[Delphi]

public property InnerBoundsOnPage: RectangleD read get_InnerBoundsOnPage;

Property Value


RenderFragment.Level Property

RenderFragment.Level Property

Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.

[Visual Basic]

Public ReadOnly Property Level As Int32*

[C#]

public Int32* Level {get;}

[Delphi]

public property Level: Int32* read get_Level;


RenderFragment.PageArea Property

RenderFragment.PageArea Property

Gets the PageAreaBase object.

[Visual Basic]

Public Property PageArea As PageAreaBase

[C#]

public PageAreaBase PageArea {get;set;}

[Delphi]

public property PageArea: PageAreaBase read get_PageArea write set_PageArea;


RenderFragment.Parent Property

RenderFragment.Parent Property

Gets the parent RenderFragment object.

[Visual Basic]

Public ReadOnly Property Parent As RenderFragment

[C#]

public RenderFragment Parent {get;}

[Delphi]

public property Parent: RenderFragment read get_Parent;


RenderFragment.RenderObject Property

RenderFragment.RenderObject Property

Gets the RenderObject object which has produced this object.

[Visual Basic]

Public ReadOnly Property RenderObject As RenderObject

[C#]

public RenderObject RenderObject {get;}

[Delphi]

public property RenderObject: RenderObject read get_RenderObject;


RenderFragment.TopParent Property

RenderFragment.TopParent Property

Gets the top-parent RenderFragment object.

[Visual Basic]

Public ReadOnly Property TopParent As RenderFragment

[C#]

public RenderFragment TopParent {get;}

[Delphi]

public property TopParent: RenderFragment read get_TopParent;


RenderFragment.Visible Property

RenderFragment.Visible Property

Indicates whether the fragment is visible.

[Visual Basic]

Public Property Visible As Boolean

[C#]

public bool Visible {get;set;}

[Delphi]

public property Visible: Boolean read get_Visible write set_Visible;


RenderFragment Methods

RenderFragment Methods

The methods of the RenderFragment class are listed here. For a complete list of RenderFragment class members, see the RenderFragment Members topic.

Public Methods

AssignFrom | Copies all properties from another RenderFragment object, the Children collection is copied also.
Clone | Creates and returns a copy of render fragment.
DetachFromRenderObject | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.
Draw | Overloaded. Paints fragment on specified graphics.
FindHyperlink | Searches the C1Hyperlink object in the render fragment at specified position.
GetAnchorRect | Calculates the information about specified anchor.
GetHyperlinks | Adds the fragment's hyperlinks in the passed collection.
ResolvingFinished | This method is called by the render engine after fully resolving of render fragment. Typically this method is used to clear temporary info used during resolving.


RenderFragment.AssignFrom Method

RenderFragment.AssignFrom Method

Copies all properties from another RenderFragment object, the Children collection is copied also.

[Visual Basic]

Overridable Public Sub AssignFrom( _

ByVal source As RenderFragment _

)

[C#]

virtual public void AssignFrom(

RenderFragment source

);

[Delphi]

public procedure AssignFrom(

source: RenderFragment

); virtual;

Parameters

source

The source RenderFragment object.


RenderFragment.Clone Method

RenderFragment.Clone Method

Creates and returns a copy of render fragment.

[Visual Basic]

Public Function Clone() As Object

[C#]

public object Clone()

[Delphi]

public function Clone(): Object;


RenderFragment.DetachFromRenderObject Method

RenderFragment.DetachFromRenderObject Method

Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.

[Visual Basic]

Public Sub DetachFromRenderObject()

[C#]

public void DetachFromRenderObject()

[Delphi]

public procedure DetachFromRenderObject();


RenderFragment.Draw Method

RenderFragment.Draw Method

Paints fragment on specified graphics.

[Visual Basic]

Public Sub Draw( _

ByVal graphics As Graphics, _

ByVal page As Page, _

ByVal renderInputControls As Boolean _

)

[C#]

public void Draw(

Graphics graphics,

Page page,

bool renderInputControls

);

[Delphi]

public procedure Draw(

graphics: Graphics;

page: Page;

renderInputControls: Boolean

); overload;

Parameters

graphics

Graphics object on which fragment must be drawn.

page

renderInputControls


RenderFragment.FindHyperlink Method

RenderFragment.FindHyperlink Method

Searches the C1Hyperlink object in the render fragment at specified position.

[Visual Basic]

Overridable Public Function FindHyperlink( _

ByVal pt As PointD _

) As C1HyperlinkInfo

[C#]

virtual public C1HyperlinkInfo FindHyperlink(

PointD pt

);

[Delphi]

public function FindHyperlink(

pt: PointD

): C1HyperlinkInfo; virtual;

Parameters

pt

Specifies the point within object relative to top-left corner of fragment.

Return Value

The C1HyperlinkInfo object describing the searched hyperlink or null if not found.


RenderFragment.GetAnchorRect Method

RenderFragment.GetAnchorRect Method

Calculates the information about specified anchor.

[Visual Basic]

Overridable Public Sub GetAnchorRect( _

ByVal anchor As C1Anchor, _

ByRef anchorRect As RectangleD, _

ByRef anchorVisible As Boolean _

)

[C#]

virtual public void GetAnchorRect(

C1Anchor anchor,

ref RectangleD anchorRect,

ref bool anchorVisible

);

[Delphi]

public procedure GetAnchorRect(

anchor: C1Anchor;

var anchorRect: RectangleD;

var anchorVisible: Boolean

); virtual;

Parameters

anchor

The C1Anchor object from RenderObject.Anchors collection.

anchorRect

The bounds of anchor in fragment in resolved units (C1PrintDocument.ResolvedUnitType). This parameter contains valid value only if anchorVisible is True.

anchorVisible

The content of RenderObject can be split on some fragments this parameter contains True on exit if anchor is in this fragment.


RenderFragment.GetHyperlinks Method

RenderFragment.GetHyperlinks Method

Adds the fragment's hyperlinks in the passed collection.

[Visual Basic]

Overridable Public Sub GetHyperlinks( _

ByVal hyperlinks As C1HyperlinkInfoCollection _

)

[C#]

virtual public void GetHyperlinks(

C1HyperlinkInfoCollection hyperlinks

);

[Delphi]

public procedure GetHyperlinks(

hyperlinks: C1HyperlinkInfoCollection

); virtual;

Parameters

hyperlinks

The C1HyperlinkInfoCollection object in which the fragment's hyperlinks will be added.


RenderFragment.ResolvingFinished Method

RenderFragment.ResolvingFinished Method

This method is called by the render engine after fully resolving of render fragment. Typically this method is used to clear temporary info used during resolving.

[Visual Basic]

Overridable Public Sub ResolvingFinished()

[C#]

virtual public void ResolvingFinished()

[Delphi]

public procedure ResolvingFinished(); virtual;


RenderFragmentCollection Class

RenderFragmentCollection Class

Represents the collection of RenderFragment objects. All fragments in this collection sorted by ZOrder to perform drawing and search.

For a list of all members of this type, see RenderFragmentCollection Members.

System.Object

System.Collections.CollectionBase

C1.C1Preview.RenderFragmentCollection

[Visual Basic]

Public Class RenderFragmentCollection

Inherits CollectionBase

[C#]

public class RenderFragmentCollection : CollectionBase

[Delphi]

type RenderFragmentCollection = class (CollectionBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderFragmentCollection Members

RenderFragmentCollection Members

RenderFragmentCollection overview


RenderGraphics Class

RenderGraphics Class

Represents RO that render images.

For a list of all members of this type, see RenderGraphics Members.

System.Object

C1.C1Preview.RenderObject

C1.C1Preview.RenderGraphics

[Visual Basic]

Public Class RenderGraphics

Inherits RenderObject

[C#]

public class RenderGraphics : RenderObject

[Delphi]

type RenderGraphics = class (RenderObject);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderGraphics Members

RenderGraphics Members

RenderGraphics overview

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
EmfType | Gets or sets the type of metafile created by this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
Graphics | Graphics object to draw on.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
ReferenceGraphics | Gets the reference graphics used to create an underlying metafiles.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.

Public Methods

Clear | Clears the current graphics.
GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderGraphics Properties

RenderGraphics Properties

The properties of the RenderGraphics class are listed here. For a complete list of RenderGraphics class members, see the RenderGraphics Members topic.

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
EmfType | Gets or sets the type of metafile created by this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
Graphics | Graphics object to draw on.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
ReferenceGraphics | Gets the reference graphics used to create an underlying metafiles.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.


RenderGraphics.EmfType Property

RenderGraphics.EmfType Property

Gets or sets the type of metafile created by this object.

[Visual Basic]

Public Property EmfType As EmfType

[C#]

public EmfType EmfType {get;set;}

[Delphi]

public property EmfType: EmfType read get_EmfType write set_EmfType;


RenderGraphics.Graphics Property

RenderGraphics.Graphics Property

Graphics object to draw on.

[Visual Basic]

Public ReadOnly Property Graphics As Graphics

[C#]

public Graphics Graphics {get;}

[Delphi]

public property Graphics: Graphics read get_Graphics;


RenderGraphics.ReferenceGraphics Property

RenderGraphics.ReferenceGraphics Property

Gets the reference graphics used to create an underlying metafiles.

[Visual Basic]

Public ReadOnly Property ReferenceGraphics As Graphics

[C#]

public Graphics ReferenceGraphics {get;}

[Delphi]

public property ReferenceGraphics: Graphics read get_ReferenceGraphics;


RenderGraphics Methods

RenderGraphics Methods

The methods of the RenderGraphics class are listed here. For a complete list of RenderGraphics class members, see the RenderGraphics Members topic.

Public Methods

Clear | Clears the current graphics.
GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderGraphics.Clear Method

RenderGraphics.Clear Method

Clears the current graphics.

[Visual Basic]

Public Sub Clear()

[C#]

public void Clear()

[Delphi]

public procedure Clear();


RenderGraphicsFragment Class

RenderGraphicsFragment Class

Represents a fragment of the RenderImage object.

For a list of all members of this type, see RenderGraphicsFragment Members.

System.Object

C1.C1Preview.RenderFragment

C1.C1Preview.RenderGraphicsFragment

[Visual Basic]

Public Class RenderGraphicsFragment

Inherits RenderFragment

[C#]

public class RenderGraphicsFragment : RenderFragment

[Delphi]

type RenderGraphicsFragment = class (RenderFragment);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderGraphicsFragment Members

RenderGraphicsFragment Members

RenderGraphicsFragment overview

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.
ResolvingFinished (inherited from RenderFragment) | This method is called by the render engine after fully resolving of render fragment. Typically this method is used to clear temporary info used during resolving.


RenderGraphicsFragment Properties

RenderGraphicsFragment Properties

The properties of the RenderGraphicsFragment class are listed here. For a complete list of RenderGraphicsFragment class members, see the RenderGraphicsFragment Members topic.

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.


RenderGraphicsFragment Methods

RenderGraphicsFragment Methods

The methods of the RenderGraphicsFragment class are listed here. For a complete list of RenderGraphicsFragment class members, see the RenderGraphicsFragment Members topic.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.
ResolvingFinished (inherited from RenderFragment) | This method is called by the render engine after fully resolving of render fragment. Typically this method is used to clear temporary info used during resolving.


RenderImage Class

RenderImage Class

Represents RO that renders images.

For a list of all members of this type, see RenderImage Members.

System.Object

C1.C1Preview.RenderObject

C1.C1Preview.RenderImage

[Visual Basic]

Public Class RenderImage

Inherits RenderObject

[C#]

public class RenderImage : RenderObject

[Delphi]

type RenderImage = class (RenderObject);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderImage Members

RenderImage Members

RenderImage overview

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Control | Control to render.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
Image | Defines an image to render.
ImageName | Gets or sets the name of image in document's dictionary.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderImage Properties

RenderImage Properties

The properties of the RenderImage class are listed here. For a complete list of RenderImage class members, see the RenderImage Members topic.

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Control | Control to render.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
Image | Defines an image to render.
ImageName | Gets or sets the name of image in document's dictionary.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.


RenderImage.Control Property

RenderImage.Control Property

Control to render.

[Visual Basic]

Public Property Control As Control

[C#]

public Control Control {get;set;}

[Delphi]

public property Control: Control read get_Control write set_Control;


RenderImage.Image Property

RenderImage.Image Property

Defines an image to render.

[Visual Basic]

Public Property Image As Image

[C#]

public Image Image {get;set;}

[Delphi]

public property Image: Image read get_Image write set_Image;


RenderImage.ImageName Property

RenderImage.ImageName Property

Gets or sets the name of image in document's dictionary.

[Visual Basic]

Public Property ImageName As String

[C#]

public string ImageName {get;set;}

[Delphi]

public property ImageName: String read get_ImageName write set_ImageName;


RenderImage Methods

RenderImage Methods

The methods of the RenderImage class are listed here. For a complete list of RenderImage class members, see the RenderImage Members topic.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderImageFragment Class

RenderImageFragment Class

Represents a fragment of the RenderImage object.

For a list of all members of this type, see RenderImageFragment Members.

System.Object

C1.C1Preview.RenderFragment

C1.C1Preview.RenderImageFragment

[Visual Basic]

Public Class RenderImageFragment

Inherits RenderFragment

[C#]

public class RenderImageFragment : RenderFragment

[Delphi]

type RenderImageFragment = class (RenderFragment);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderImageFragment Members

RenderImageFragment Members

RenderImageFragment overview

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.
ResolvingFinished (inherited from RenderFragment) | This method is called by the render engine after fully resolving of render fragment. Typically this method is used to clear temporary info used during resolving.


RenderImageFragment Properties

RenderImageFragment Properties

The properties of the RenderImageFragment class are listed here. For a complete list of RenderImageFragment class members, see the RenderImageFragment Members topic.

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.


RenderImageFragment Methods

RenderImageFragment Methods

The methods of the RenderImageFragment class are listed here. For a complete list of RenderImageFragment class members, see the RenderImageFragment Members topic.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.
ResolvingFinished (inherited from RenderFragment) | This method is called by the render engine after fully resolving of render fragment. Typically this method is used to clear temporary info used during resolving.


RenderInputBase Class

RenderInputBase Class

The base class for all C1Preview Forms' input render objects (which represent controls on C1Preview forms). Provides the basic functionality for all input controls - position, size, visual style, user actions, input options. Adds input-specific features to the display features provided by the base class (position, size, visual style and so on).

For a list of all members of this type, see RenderInputBase Members.

System.Object

C1.C1Preview.RenderObject

C1.C1Preview.RenderInputBase

C1.C1Preview.RenderInputButtonBase

C1.C1Preview.RenderInputComboBox

C1.C1Preview.RenderInputText

[Visual Basic]

MustInherit Public Class RenderInputBase

Inherits RenderObject

[C#]

public abstract class RenderInputBase : RenderObject

[Delphi]

type RenderInputBase = class abstract (RenderObject);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderInputBase Members

RenderInputBase Members

RenderInputBase overview

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Cursor | Gets or sets the cursor used when the mouse is over the control.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
InputActions | Gets the collection of supported user actions and handlers associated with those actions. See help on InputActions class for details.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
Printable | Gets or sets the value indicating whether the control is printed. If True (default), the content of the control is printed normally. Otherwise, it is not printed or exported. This might be used for example to provide help for fields that are to be filled.
ReadOnly | Gets or sets the value indicating whether the control is read-only. For read-only controls, all input actions are still fired, but the control's value cannot be changed. The default is False.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
StatusText | Gets or sets the text that appears in the status line of the preview when the control has focus.
Style (inherited from RenderObject) | Style of this object.
ToolTip | Gets or sets the tooltip associated with the control.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.

Public Methods

CreateControl | Creates the underlying windows control object.
GetAutoMeasureParams | Returns the parameters for calculating the auto sizes of RenderInputBase object.
GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.
IsControlNeededParentForWmPrint | This method returns True if underlaying control of RenderInputBase object needs the parent to correctly process the WM_PRINT message. By default the RenderInputBase object returns False.
IsResetSelectionNeeded | Returns True if selection within parent control should be reset when the underlying control receives an input focus.


RenderInputBase Properties

RenderInputBase Properties

The properties of the RenderInputBase class are listed here. For a complete list of RenderInputBase class members, see the RenderInputBase Members topic.

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Cursor | Gets or sets the cursor used when the mouse is over the control.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
InputActions | Gets the collection of supported user actions and handlers associated with those actions. See help on InputActions class for details.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
Printable | Gets or sets the value indicating whether the control is printed. If True (default), the content of the control is printed normally. Otherwise, it is not printed or exported. This might be used for example to provide help for fields that are to be filled.
ReadOnly | Gets or sets the value indicating whether the control is read-only. For read-only controls, all input actions are still fired, but the control's value cannot be changed. The default is False.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
StatusText | Gets or sets the text that appears in the status line of the preview when the control has focus.
Style (inherited from RenderObject) | Style of this object.
ToolTip | Gets or sets the tooltip associated with the control.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.


RenderInputBase.Cursor Property

RenderInputBase.Cursor Property

Gets or sets the cursor used when the mouse is over the control.

[Visual Basic]

Public Property Cursor As Cursor

[C#]

public Cursor Cursor {get;set;}

[Delphi]

public property Cursor: Cursor read get_Cursor write set_Cursor;


RenderInputBase.InputActions Property

RenderInputBase.InputActions Property

Gets the collection of supported user actions and handlers associated with those actions. See help on InputActions class for details.

[Visual Basic]

Public ReadOnly Property InputActions As InputActionCollection

[C#]

public InputActionCollection InputActions {get;}

[Delphi]

public property InputActions: InputActionCollection read get_InputActions;


RenderInputBase.Printable Property

RenderInputBase.Printable Property

Gets or sets the value indicating whether the control is printed. If True (default), the content of the control is printed normally. Otherwise, it is not printed or exported. This might be used for example to provide help for fields that are to be filled.

[Visual Basic]

Public Property Printable As Boolean

[C#]

public bool Printable {get;set;}

[Delphi]

public property Printable: Boolean read get_Printable write set_Printable;


RenderInputBase.ReadOnly Property

RenderInputBase.ReadOnly Property

Gets or sets the value indicating whether the control is read-only. For read-only controls, all input actions are still fired, but the control's value cannot be changed. The default is False.

[Visual Basic]

Public Property ReadOnly As Boolean

[C#]

public bool ReadOnly {get;set;}

[Delphi]

public property ReadOnly: Boolean read get_ReadOnly write set_ReadOnly;


RenderInputBase.StatusText Property

RenderInputBase.StatusText Property

Gets or sets the text that appears in the status line of the preview when the control has focus.

[Visual Basic]

Public Property StatusText As String

[C#]

public string StatusText {get;set;}

[Delphi]

public property StatusText: String read get_StatusText write set_StatusText;


RenderInputBase.ToolTip Property

RenderInputBase.ToolTip Property

Gets or sets the tooltip associated with the control.

[Visual Basic]

Public Property ToolTip As String

[C#]

public string ToolTip {get;set;}

[Delphi]

public property ToolTip: String read get_ToolTip write set_ToolTip;


RenderInputBase Methods

RenderInputBase Methods

The methods of the RenderInputBase class are listed here. For a complete list of RenderInputBase class members, see the RenderInputBase Members topic.

Public Methods

CreateControl | Creates the underlying windows control object.
GetAutoMeasureParams | Returns the parameters for calculating the auto sizes of RenderInputBase object.
GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.
IsControlNeededParentForWmPrint | This method returns True if underlaying control of RenderInputBase object needs the parent to correctly process the WM_PRINT message. By default the RenderInputBase object returns False.
IsResetSelectionNeeded | Returns True if selection within parent control should be reset when the underlying control receives an input focus.


RenderInputBase.CreateControl Method

RenderInputBase.CreateControl Method

Creates the underlying windows control object.

[Visual Basic]

Public Function CreateControl() As Control

[C#]

public Control CreateControl()

[Delphi]

public function CreateControl(): Control;

Return Value

Returns the created window control object.


RenderInputBase.GetAutoMeasureParams Method

RenderInputBase.GetAutoMeasureParams Method

Returns the parameters for calculating the auto sizes of RenderInputBase object.

[Visual Basic]

Overridable Public Sub GetAutoMeasureParams( _

ByRef text As String, _

ByRef horzPadding As Int32*, _

ByRef vertPadding As Int32* _

)

[C#]

virtual public void GetAutoMeasureParams(

ref string text,

ref Int32* horzPadding,

ref Int32* vertPadding

);

[Delphi]

public procedure GetAutoMeasureParams(

var text: String;

var horzPadding: Int32*;

var vertPadding: Int32*

); virtual;

Parameters

text

Text on the base of which the auto sizes will be calculated.

horzPadding

The horizontal padding.

vertPadding

the vertical padding.


RenderInputBase.IsControlNeededParentForWmPrint Method

RenderInputBase.IsControlNeededParentForWmPrint Method

This method returns True if underlaying control of RenderInputBase object needs the parent to correctly process the WM_PRINT message. By default the RenderInputBase object returns False.

[Visual Basic]

Overridable Public Function IsControlNeededParentForWmPrint() As Boolean

[C#]

virtual public bool IsControlNeededParentForWmPrint()

[Delphi]

public function IsControlNeededParentForWmPrint(): Boolean; virtual;


RenderInputBase.IsResetSelectionNeeded Method

RenderInputBase.IsResetSelectionNeeded Method

Returns True if selection within parent control should be reset when the underlying control receives an input focus.

[Visual Basic]

Overridable Public Function IsResetSelectionNeeded() As Boolean

[C#]

virtual public bool IsResetSelectionNeeded()

[Delphi]

public function IsResetSelectionNeeded(): Boolean; virtual;


RenderInputButton Class

RenderInputButton Class

Input render object providing a push button.

For a list of all members of this type, see RenderInputButton Members.

System.Object

C1.C1Preview.RenderObject

C1.C1Preview.RenderInputBase

C1.C1Preview.RenderInputButtonBase

C1.C1Preview.RenderInputButton

[Visual Basic]

Public Class RenderInputButton

Inherits RenderInputButtonBase

[C#]

public class RenderInputButton : RenderInputButtonBase

[Delphi]

type RenderInputButton = class (RenderInputButtonBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderInputButton Members

RenderInputButton Members

RenderInputButton overview

Public Properties

AcceptButton | Gets or sets the value indicating whether the button is an "Accept button" and its action will be executed when user press ENTER in the C1PrintPreview control, which is lined to the document containing this button.
Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Cursor (inherited from RenderInputBase) | Gets or sets the cursor used when the mouse is over the control.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
InputActions (inherited from RenderInputBase) | Gets the collection of supported user actions and handlers associated with those actions. See help on InputActions class for details.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
Printable (inherited from RenderInputBase) | Gets or sets the value indicating whether the control is printed. If True (default), the content of the control is printed normally. Otherwise, it is not printed or exported. This might be used for example to provide help for fields that are to be filled.
ReadOnly (inherited from RenderInputBase) | Gets or sets the value indicating whether the control is read-only. For read-only controls, all input actions are still fired, but the control's value cannot be changed. The default is False.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
StatusText (inherited from RenderInputBase) | Gets or sets the text that appears in the status line of the preview when the control has focus.
Style (inherited from RenderObject) | Style of this object.
Text (inherited from RenderInputButtonBase) | Gets or sets the text of the button.
TextAlign (inherited from RenderInputButtonBase) | Gets or sets the alignment of the button text.
ToolTip (inherited from RenderInputBase) | Gets or sets the tooltip associated with the control.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.

Public Methods

CreateControl (inherited from RenderInputBase) | Creates the underlying windows control object.
GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.
IsControlNeededParentForWmPrint (inherited from RenderInputBase) | This method returns True if underlaying control of RenderInputBase object needs the parent to correctly process the WM_PRINT message. By default the RenderInputBase object returns False.
IsResetSelectionNeeded (inherited from RenderInputBase) | Returns True if selection within parent control should be reset when the underlying control receives an input focus.


RenderInputButton Properties

RenderInputButton Properties

The properties of the RenderInputButton class are listed here. For a complete list of RenderInputButton class members, see the RenderInputButton Members topic.

Public Properties

AcceptButton | Gets or sets the value indicating whether the button is an "Accept button" and its action will be executed when user press ENTER in the C1PrintPreview control, which is lined to the document containing this button.
Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Cursor (inherited from RenderInputBase) | Gets or sets the cursor used when the mouse is over the control.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
InputActions (inherited from RenderInputBase) | Gets the collection of supported user actions and handlers associated with those actions. See help on InputActions class for details.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
Printable (inherited from RenderInputBase) | Gets or sets the value indicating whether the control is printed. If True (default), the content of the control is printed normally. Otherwise, it is not printed or exported. This might be used for example to provide help for fields that are to be filled.
ReadOnly (inherited from RenderInputBase) | Gets or sets the value indicating whether the control is read-only. For read-only controls, all input actions are still fired, but the control's value cannot be changed. The default is False.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
StatusText (inherited from RenderInputBase) | Gets or sets the text that appears in the status line of the preview when the control has focus.
Style (inherited from RenderObject) | Style of this object.
Text (inherited from RenderInputButtonBase) | Gets or sets the text of the button.
TextAlign (inherited from RenderInputButtonBase) | Gets or sets the alignment of the button text.
ToolTip (inherited from RenderInputBase) | Gets or sets the tooltip associated with the control.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.


RenderInputButton.AcceptButton Property

RenderInputButton.AcceptButton Property

Gets or sets the value indicating whether the button is an "Accept button" and its action will be executed when user press ENTER in the C1PrintPreview control, which is lined to the document containing this button.

[Visual Basic]

Public Property AcceptButton As Boolean

[C#]

public bool AcceptButton {get;set;}

[Delphi]

public property AcceptButton: Boolean read get_AcceptButton write set_AcceptButton;


RenderInputButton Methods

RenderInputButton Methods

The methods of the RenderInputButton class are listed here. For a complete list of RenderInputButton class members, see the RenderInputButton Members topic.

Public Methods

CreateControl (inherited from RenderInputBase) | Creates the underlying windows control object.
GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.
IsControlNeededParentForWmPrint (inherited from RenderInputBase) | This method returns True if underlaying control of RenderInputBase object needs the parent to correctly process the WM_PRINT message. By default the RenderInputBase object returns False.
IsResetSelectionNeeded (inherited from RenderInputBase) | Returns True if selection within parent control should be reset when the underlying control receives an input focus.


RenderInputButtonBase Class

RenderInputButtonBase Class

The abstract base class for the input info classes for all button-like controls (RenderInputButton, RenderInputCheckBox, and so on).

For a list of all members of this type, see RenderInputButtonBase Members.

System.Object

C1.C1Preview.RenderObject

C1.C1Preview.RenderInputBase

C1.C1Preview.RenderInputButtonBase

C1.C1Preview.RenderInputButton

C1.C1Preview.RenderInputCheckBox

C1.C1Preview.RenderInputRadioButton

[Visual Basic]

MustInherit Public Class RenderInputButtonBase

Inherits RenderInputBase

[C#]

public abstract class RenderInputButtonBase : RenderInputBase

[Delphi]

type RenderInputButtonBase = class abstract (RenderInputBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderInputButtonBase Members

RenderInputButtonBase Members

RenderInputButtonBase overview

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Cursor (inherited from RenderInputBase) | Gets or sets the cursor used when the mouse is over the control.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
InputActions (inherited from RenderInputBase) | Gets the collection of supported user actions and handlers associated with those actions. See help on InputActions class for details.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
Printable (inherited from RenderInputBase) | Gets or sets the value indicating whether the control is printed. If True (default), the content of the control is printed normally. Otherwise, it is not printed or exported. This might be used for example to provide help for fields that are to be filled.
ReadOnly (inherited from RenderInputBase) | Gets or sets the value indicating whether the control is read-only. For read-only controls, all input actions are still fired, but the control's value cannot be changed. The default is False.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
StatusText (inherited from RenderInputBase) | Gets or sets the text that appears in the status line of the preview when the control has focus.
Style (inherited from RenderObject) | Style of this object.
Text | Gets or sets the text of the button.
TextAlign | Gets or sets the alignment of the button text.
ToolTip (inherited from RenderInputBase) | Gets or sets the tooltip associated with the control.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.

Public Methods

CreateControl (inherited from RenderInputBase) | Creates the underlying windows control object.
GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.
IsControlNeededParentForWmPrint (inherited from RenderInputBase) | This method returns True if underlaying control of RenderInputBase object needs the parent to correctly process the WM_PRINT message. By default the RenderInputBase object returns False.
IsResetSelectionNeeded (inherited from RenderInputBase) | Returns True if selection within parent control should be reset when the underlying control receives an input focus.


RenderInputButtonBase Properties

RenderInputButtonBase Properties

The properties of the RenderInputButtonBase class are listed here. For a complete list of RenderInputButtonBase class members, see the RenderInputButtonBase Members topic.

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Cursor (inherited from RenderInputBase) | Gets or sets the cursor used when the mouse is over the control.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
InputActions (inherited from RenderInputBase) | Gets the collection of supported user actions and handlers associated with those actions. See help on InputActions class for details.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
Printable (inherited from RenderInputBase) | Gets or sets the value indicating whether the control is printed. If True (default), the content of the control is printed normally. Otherwise, it is not printed or exported. This might be used for example to provide help for fields that are to be filled.
ReadOnly (inherited from RenderInputBase) | Gets or sets the value indicating whether the control is read-only. For read-only controls, all input actions are still fired, but the control's value cannot be changed. The default is False.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
StatusText (inherited from RenderInputBase) | Gets or sets the text that appears in the status line of the preview when the control has focus.
Style (inherited from RenderObject) | Style of this object.
Text | Gets or sets the text of the button.
TextAlign | Gets or sets the alignment of the button text.
ToolTip (inherited from RenderInputBase) | Gets or sets the tooltip associated with the control.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.


RenderInputButtonBase.Text Property

RenderInputButtonBase.Text Property

Gets or sets the text of the button.

[Visual Basic]

Public Property Text As String

[C#]

public string Text {get;set;}

[Delphi]

public property Text: String read get_Text write set_Text;


RenderInputButtonBase.TextAlign Property

RenderInputButtonBase.TextAlign Property

Gets or sets the alignment of the button text.

[Visual Basic]

Public Property TextAlign As ContentAlignment

[C#]

public ContentAlignment TextAlign {get;set;}

[Delphi]

public property TextAlign: ContentAlignment read get_TextAlign write set_TextAlign;


RenderInputButtonBase Methods

RenderInputButtonBase Methods

The methods of the RenderInputButtonBase class are listed here. For a complete list of RenderInputButtonBase class members, see the RenderInputButtonBase Members topic.

Public Methods

CreateControl (inherited from RenderInputBase) | Creates the underlying windows control object.
GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.
IsControlNeededParentForWmPrint (inherited from RenderInputBase) | This method returns True if underlaying control of RenderInputBase object needs the parent to correctly process the WM_PRINT message. By default the RenderInputBase object returns False.
IsResetSelectionNeeded (inherited from RenderInputBase) | Returns True if selection within parent control should be reset when the underlying control receives an input focus.


RenderInputCheckBox Class

RenderInputCheckBox Class

Input render object providing a checkbox.

For a list of all members of this type, see RenderInputCheckBox Members.

System.Object

C1.C1Preview.RenderObject

C1.C1Preview.RenderInputBase

C1.C1Preview.RenderInputButtonBase

C1.C1Preview.RenderInputCheckBox

[Visual Basic]

Public Class RenderInputCheckBox

Inherits RenderInputButtonBase

[C#]

public class RenderInputCheckBox : RenderInputButtonBase

[Delphi]

type RenderInputCheckBox = class (RenderInputButtonBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderInputCheckBox Members

RenderInputCheckBox Members

RenderInputCheckBox overview

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
CheckAlign | Gets or sets the horizontal and vertical alignment of the check box on the control.
Checked | Gets or sets the value indicating whether the check box is checked.
CheckMarkStyle | Gets or sets the visual style of the check mark used by the control.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Cursor (inherited from RenderInputBase) | Gets or sets the cursor used when the mouse is over the control.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
InputActions (inherited from RenderInputBase) | Gets the collection of supported user actions and handlers associated with those actions. See help on InputActions class for details.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
Printable (inherited from RenderInputBase) | Gets or sets the value indicating whether the control is printed. If True (default), the content of the control is printed normally. Otherwise, it is not printed or exported. This might be used for example to provide help for fields that are to be filled.
ReadOnly (inherited from RenderInputBase) | Gets or sets the value indicating whether the control is read-only. For read-only controls, all input actions are still fired, but the control's value cannot be changed. The default is False.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
StatusText (inherited from RenderInputBase) | Gets or sets the text that appears in the status line of the preview when the control has focus.
Style (inherited from RenderObject) | Style of this object.
Text (inherited from RenderInputButtonBase) | Gets or sets the text of the button.
TextAlign (inherited from RenderInputButtonBase) | Gets or sets the alignment of the button text.
ToolTip (inherited from RenderInputBase) | Gets or sets the tooltip associated with the control.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.

Public Methods

CreateControl (inherited from RenderInputBase) | Creates the underlying windows control object.
GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.
IsControlNeededParentForWmPrint (inherited from RenderInputBase) | This method returns True if underlaying control of RenderInputBase object needs the parent to correctly process the WM_PRINT message. By default the RenderInputBase object returns False.
IsResetSelectionNeeded (inherited from RenderInputBase) | Returns True if selection within parent control should be reset when the underlying control receives an input focus.


RenderInputCheckBox Properties

RenderInputCheckBox Properties

The properties of the RenderInputCheckBox class are listed here. For a complete list of RenderInputCheckBox class members, see the RenderInputCheckBox Members topic.

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
CheckAlign | Gets or sets the horizontal and vertical alignment of the check box on the control.
Checked | Gets or sets the value indicating whether the check box is checked.
CheckMarkStyle | Gets or sets the visual style of the check mark used by the control.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Cursor (inherited from RenderInputBase) | Gets or sets the cursor used when the mouse is over the control.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
InputActions (inherited from RenderInputBase) | Gets the collection of supported user actions and handlers associated with those actions. See help on InputActions class for details.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
Printable (inherited from RenderInputBase) | Gets or sets the value indicating whether the control is printed. If True (default), the content of the control is printed normally. Otherwise, it is not printed or exported. This might be used for example to provide help for fields that are to be filled.
ReadOnly (inherited from RenderInputBase) | Gets or sets the value indicating whether the control is read-only. For read-only controls, all input actions are still fired, but the control's value cannot be changed. The default is False.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
StatusText (inherited from RenderInputBase) | Gets or sets the text that appears in the status line of the preview when the control has focus.
Style (inherited from RenderObject) | Style of this object.
Text (inherited from RenderInputButtonBase) | Gets or sets the text of the button.
TextAlign (inherited from RenderInputButtonBase) | Gets or sets the alignment of the button text.
ToolTip (inherited from RenderInputBase) | Gets or sets the tooltip associated with the control.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.


RenderInputCheckBox.CheckAlign Property

RenderInputCheckBox.CheckAlign Property

Gets or sets the horizontal and vertical alignment of the check box on the control.

[Visual Basic]

Public Property CheckAlign As ContentAlignment

[C#]

public ContentAlignment CheckAlign {get;set;}

[Delphi]

public property CheckAlign: ContentAlignment read get_CheckAlign write set_CheckAlign;


RenderInputCheckBox.Checked Property

RenderInputCheckBox.Checked Property

Gets or sets the value indicating whether the check box is checked.

[Visual Basic]

Public Property Checked As Boolean

[C#]

public bool Checked {get;set;}

[Delphi]

public property Checked: Boolean read get_Checked write set_Checked;


RenderInputCheckBox.CheckMarkStyle Property

RenderInputCheckBox.CheckMarkStyle Property

Gets or sets the visual style of the check mark used by the control.

[Visual Basic]

Public Property CheckMarkStyle As CheckMarkStyleEnum

[C#]

public CheckMarkStyleEnum CheckMarkStyle {get;set;}

[Delphi]

public property CheckMarkStyle: CheckMarkStyleEnum read get_CheckMarkStyle write set_CheckMarkStyle;


RenderInputCheckBox Methods

RenderInputCheckBox Methods

The methods of the RenderInputCheckBox class are listed here. For a complete list of RenderInputCheckBox class members, see the RenderInputCheckBox Members topic.

Public Methods

CreateControl (inherited from RenderInputBase) | Creates the underlying windows control object.
GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.
IsControlNeededParentForWmPrint (inherited from RenderInputBase) | This method returns True if underlaying control of RenderInputBase object needs the parent to correctly process the WM_PRINT message. By default the RenderInputBase object returns False.
IsResetSelectionNeeded (inherited from RenderInputBase) | Returns True if selection within parent control should be reset when the underlying control receives an input focus.


RenderInputComboBox Class

RenderInputComboBox Class

Input render object providing text input with dropdown list.

For a list of all members of this type, see RenderInputComboBox Members.

System.Object

C1.C1Preview.RenderObject

C1.C1Preview.RenderInputBase

C1.C1Preview.RenderInputComboBox

[Visual Basic]

Public Class RenderInputComboBox

Inherits RenderInputBase

[C#]

public class RenderInputComboBox : RenderInputBase

[Delphi]

type RenderInputComboBox = class (RenderInputBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderInputComboBox Members

RenderInputComboBox Members

RenderInputComboBox overview

Public Properties

AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form. Default is True.
Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Cursor (inherited from RenderInputBase) | Gets or sets the cursor used when the mouse is over the control.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
DropDownStyle | Gets or sets a value specifying the style of the combo box.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
InputActions (inherited from RenderInputBase) | Gets the collection of supported user actions and handlers associated with those actions. See help on InputActions class for details.
Items | Gets an object representing the collection of the items contained in this ComboBox.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
PasswordChar | Gets or sets the char used to hide real characters when entering passwords. The default value of this property is ?\0? (no hiding takes place).
Printable (inherited from RenderInputBase) | Gets or sets the value indicating whether the control is printed. If True (default), the content of the control is printed normally. Otherwise, it is not printed or exported. This might be used for example to provide help for fields that are to be filled.
ReadOnly (inherited from RenderInputBase) | Gets or sets the value indicating whether the control is read-only. For read-only controls, all input actions are still fired, but the control's value cannot be changed. The default is False.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
StatusText (inherited from RenderInputBase) | Gets or sets the text that appears in the status line of the preview when the control has focus.
Style (inherited from RenderObject) | Style of this object.
Text | Gets or sets the text.
ToolTip (inherited from RenderInputBase) | Gets or sets the tooltip associated with the control.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.

Public Methods

CreateControl (inherited from RenderInputBase) | Creates the underlying windows control object.
GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.
IsControlNeededParentForWmPrint (inherited from RenderInputBase) | This method returns True if underlaying control of RenderInputBase object needs the parent to correctly process the WM_PRINT message. By default the RenderInputBase object returns False.


RenderInputComboBox Properties

RenderInputComboBox Properties

The properties of the RenderInputComboBox class are listed here. For a complete list of RenderInputComboBox class members, see the RenderInputComboBox Members topic.

Public Properties

AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form. Default is True.
Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Cursor (inherited from RenderInputBase) | Gets or sets the cursor used when the mouse is over the control.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
DropDownStyle | Gets or sets a value specifying the style of the combo box.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
InputActions (inherited from RenderInputBase) | Gets the collection of supported user actions and handlers associated with those actions. See help on InputActions class for details.
Items | Gets an object representing the collection of the items contained in this ComboBox.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
PasswordChar | Gets or sets the char used to hide real characters when entering passwords. The default value of this property is ?\0? (no hiding takes place).
Printable (inherited from RenderInputBase) | Gets or sets the value indicating whether the control is printed. If True (default), the content of the control is printed normally. Otherwise, it is not printed or exported. This might be used for example to provide help for fields that are to be filled.
ReadOnly (inherited from RenderInputBase) | Gets or sets the value indicating whether the control is read-only. For read-only controls, all input actions are still fired, but the control's value cannot be changed. The default is False.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
StatusText (inherited from RenderInputBase) | Gets or sets the text that appears in the status line of the preview when the control has focus.
Style (inherited from RenderObject) | Style of this object.
Text | Gets or sets the text.
ToolTip (inherited from RenderInputBase) | Gets or sets the tooltip associated with the control.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.


RenderInputComboBox.AcceptsReturn Property

RenderInputComboBox.AcceptsReturn Property

Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form. Default is True.

[Visual Basic]

Public Property AcceptsReturn As Boolean

[C#]

public bool AcceptsReturn {get;set;}

[Delphi]

public property AcceptsReturn: Boolean read get_AcceptsReturn write set_AcceptsReturn;


RenderInputComboBox.DropDownStyle Property

RenderInputComboBox.DropDownStyle Property

Gets or sets a value specifying the style of the combo box.

[Visual Basic]

Public Property DropDownStyle As ComboBoxStyle

[C#]

public ComboBoxStyle DropDownStyle {get;set;}

[Delphi]

public property DropDownStyle: ComboBoxStyle read get_DropDownStyle write set_DropDownStyle;


RenderInputComboBox.Items Property

RenderInputComboBox.Items Property

Gets an object representing the collection of the items contained in this ComboBox.

[Visual Basic]

Public ReadOnly Property Items As RenderInputComboBoxItemCollection

[C#]

public RenderInputComboBoxItemCollection Items {get;}

[Delphi]

public property Items: RenderInputComboBoxItemCollection read get_Items;


RenderInputComboBox.PasswordChar Property

RenderInputComboBox.PasswordChar Property

Gets or sets the char used to hide real characters when entering passwords. The default value of this property is ?\0? (no hiding takes place).

[Visual Basic]

Public Property PasswordChar As Char*

[C#]

public Char* PasswordChar {get;set;}

[Delphi]

public property PasswordChar: Char* read get_PasswordChar write set_PasswordChar;


RenderInputComboBox.Text Property

RenderInputComboBox.Text Property

Gets or sets the text.

[Visual Basic]

Public Property Text As String

[C#]

public string Text {get;set;}

[Delphi]

public property Text: String read get_Text write set_Text;


RenderInputComboBox Methods

RenderInputComboBox Methods

The methods of the RenderInputComboBox class are listed here. For a complete list of RenderInputComboBox class members, see the RenderInputComboBox Members topic.

Public Methods

CreateControl (inherited from RenderInputBase) | Creates the underlying windows control object.
GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.
IsControlNeededParentForWmPrint (inherited from RenderInputBase) | This method returns True if underlaying control of RenderInputBase object needs the parent to correctly process the WM_PRINT message. By default the RenderInputBase object returns False.


RenderInputComboBoxItem Class

RenderInputComboBoxItem Class

Represents the separate item in the combobox collection.

For a list of all members of this type, see RenderInputComboBoxItem Members.

System.Object

C1.C1Preview.RenderInputComboBoxItem

[Visual Basic]

Public Class RenderInputComboBoxItem

[C#]

public class RenderInputComboBoxItem

[Delphi]

type RenderInputComboBoxItem = class;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderInputComboBoxItem Members

RenderInputComboBoxItem Members

RenderInputComboBoxItem overview

Public Properties

Text | Gets or sets a text that will be displayed in the dropdown list.
UserData | Gets or sets a user's data.

Public Methods

AssignFrom

Copies the content of another RenderInputComboBoxItem object into the current object.


RenderInputComboBoxItem Properties

RenderInputComboBoxItem Properties

The properties of the RenderInputComboBoxItem class are listed here. For a complete list of RenderInputComboBoxItem class members, see the RenderInputComboBoxItem Members topic.

Public Properties

Text | Gets or sets a text that will be displayed in the dropdown list.
UserData | Gets or sets a user's data.


RenderInputComboBoxItem.Text Property

RenderInputComboBoxItem.Text Property

Gets or sets a text that will be displayed in the dropdown list.

[Visual Basic]

Public Property Text As String

[C#]

public string Text {get;set;}

[Delphi]

public property Text: String read get_Text write set_Text;


RenderInputComboBoxItem.UserData Property

RenderInputComboBoxItem.UserData Property

Gets or sets a user's data.

[Visual Basic]

Public Property UserData As Object

[C#]

public object UserData {get;set;}

[Delphi]

public property UserData: Object read get_UserData write set_UserData;


RenderInputComboBoxItem Methods

RenderInputComboBoxItem Methods

The methods of the RenderInputComboBoxItem class are listed here. For a complete list of RenderInputComboBoxItem class members, see the RenderInputComboBoxItem Members topic.

Public Methods

AssignFrom

Copies the content of another RenderInputComboBoxItem object into the current object.


RenderInputComboBoxItem.AssignFrom Method

RenderInputComboBoxItem.AssignFrom Method

Copies the content of another RenderInputComboBoxItem object into the current object.

[Visual Basic]

Public Sub AssignFrom( _

ByVal source As RenderInputComboBoxItem _

)

[C#]

public void AssignFrom(

RenderInputComboBoxItem source

);

[Delphi]

public procedure AssignFrom(

source: RenderInputComboBoxItem

);

Parameters

source

The source object, whose properties are to be copied into this object.


RenderInputComboBoxItemCollection Class

RenderInputComboBoxItemCollection Class

Represents the collection of RenderInputComboBoxItem objects.

For a list of all members of this type, see RenderInputComboBoxItemCollection Members.

System.Object

System.Collections.CollectionBase

C1.C1Preview.RenderInputComboBoxItemCollection

[Visual Basic]

Public Class RenderInputComboBoxItemCollection

Inherits CollectionBase

[C#]

public class RenderInputComboBoxItemCollection : CollectionBase

[Delphi]

type RenderInputComboBoxItemCollection = class (CollectionBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderInputComboBoxItemCollection Members

RenderInputComboBoxItemCollection Members

RenderInputComboBoxItemCollection overview


RenderInputFragment Class

RenderInputFragment Class

Represents a fragment of the RenderImage object.

For a list of all members of this type, see RenderInputFragment Members.

System.Object

C1.C1Preview.RenderFragment

C1.C1Preview.RenderInputFragment

[Visual Basic]

Public Class RenderInputFragment

Inherits RenderFragment

[C#]

public class RenderInputFragment : RenderFragment

[Delphi]

type RenderInputFragment = class (RenderFragment);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderInputFragment Members

RenderInputFragment Members

RenderInputFragment overview

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.
ResolvingFinished (inherited from RenderFragment) | This method is called by the render engine after fully resolving of render fragment. Typically this method is used to clear temporary info used during resolving.


RenderInputFragment Properties

RenderInputFragment Properties

The properties of the RenderInputFragment class are listed here. For a complete list of RenderInputFragment class members, see the RenderInputFragment Members topic.

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.


RenderInputFragment Methods

RenderInputFragment Methods

The methods of the RenderInputFragment class are listed here. For a complete list of RenderInputFragment class members, see the RenderInputFragment Members topic.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.
ResolvingFinished (inherited from RenderFragment) | This method is called by the render engine after fully resolving of render fragment. Typically this method is used to clear temporary info used during resolving.


RenderInputRadioButton Class

RenderInputRadioButton Class

Input render object providing a radio button.

For a list of all members of this type, see RenderInputRadioButton Members.

System.Object

C1.C1Preview.RenderObject

C1.C1Preview.RenderInputBase

C1.C1Preview.RenderInputButtonBase

C1.C1Preview.RenderInputRadioButton

[Visual Basic]

Public Class RenderInputRadioButton

Inherits RenderInputButtonBase

[C#]

public class RenderInputRadioButton : RenderInputButtonBase

[Delphi]

type RenderInputRadioButton = class (RenderInputButtonBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderInputRadioButton Members

RenderInputRadioButton Members

RenderInputRadioButton overview

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
CheckAlign | Gets or sets the horizontal and vertical alignment of the check box on the control.
Checked | Gets or sets the value indicating whether the check box is checked.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Cursor (inherited from RenderInputBase) | Gets or sets the cursor used when the mouse is over the control.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
GroupIndex | Gets or sets the group index for the radiobutton. Only one button in a group can be checked at any time.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
InputActions (inherited from RenderInputBase) | Gets the collection of supported user actions and handlers associated with those actions. See help on InputActions class for details.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
Printable (inherited from RenderInputBase) | Gets or sets the value indicating whether the control is printed. If True (default), the content of the control is printed normally. Otherwise, it is not printed or exported. This might be used for example to provide help for fields that are to be filled.
ReadOnly (inherited from RenderInputBase) | Gets or sets the value indicating whether the control is read-only. For read-only controls, all input actions are still fired, but the control's value cannot be changed. The default is False.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
StatusText (inherited from RenderInputBase) | Gets or sets the text that appears in the status line of the preview when the control has focus.
Style (inherited from RenderObject) | Style of this object.
Text (inherited from RenderInputButtonBase) | Gets or sets the text of the button.
TextAlign (inherited from RenderInputButtonBase) | Gets or sets the alignment of the button text.
ToolTip (inherited from RenderInputBase) | Gets or sets the tooltip associated with the control.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.

Public Methods

CreateControl (inherited from RenderInputBase) | Creates the underlying windows control object.
GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.
IsControlNeededParentForWmPrint (inherited from RenderInputBase) | This method returns True if underlaying control of RenderInputBase object needs the parent to correctly process the WM_PRINT message. By default the RenderInputBase object returns False.
IsResetSelectionNeeded (inherited from RenderInputBase) | Returns True if selection within parent control should be reset when the underlying control receives an input focus.


RenderInputRadioButton Properties

RenderInputRadioButton Properties

The properties of the RenderInputRadioButton class are listed here. For a complete list of RenderInputRadioButton class members, see the RenderInputRadioButton Members topic.

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
CheckAlign | Gets or sets the horizontal and vertical alignment of the check box on the control.
Checked | Gets or sets the value indicating whether the check box is checked.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Cursor (inherited from RenderInputBase) | Gets or sets the cursor used when the mouse is over the control.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
GroupIndex | Gets or sets the group index for the radiobutton. Only one button in a group can be checked at any time.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
InputActions (inherited from RenderInputBase) | Gets the collection of supported user actions and handlers associated with those actions. See help on InputActions class for details.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
Printable (inherited from RenderInputBase) | Gets or sets the value indicating whether the control is printed. If True (default), the content of the control is printed normally. Otherwise, it is not printed or exported. This might be used for example to provide help for fields that are to be filled.
ReadOnly (inherited from RenderInputBase) | Gets or sets the value indicating whether the control is read-only. For read-only controls, all input actions are still fired, but the control's value cannot be changed. The default is False.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
StatusText (inherited from RenderInputBase) | Gets or sets the text that appears in the status line of the preview when the control has focus.
Style (inherited from RenderObject) | Style of this object.
Text (inherited from RenderInputButtonBase) | Gets or sets the text of the button.
TextAlign (inherited from RenderInputButtonBase) | Gets or sets the alignment of the button text.
ToolTip (inherited from RenderInputBase) | Gets or sets the tooltip associated with the control.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.


RenderInputRadioButton.CheckAlign Property

RenderInputRadioButton.CheckAlign Property

Gets or sets the horizontal and vertical alignment of the check box on the control.

[Visual Basic]

Public Property CheckAlign As ContentAlignment

[C#]

public ContentAlignment CheckAlign {get;set;}

[Delphi]

public property CheckAlign: ContentAlignment read get_CheckAlign write set_CheckAlign;


RenderInputRadioButton.Checked Property

RenderInputRadioButton.Checked Property

Gets or sets the value indicating whether the check box is checked.

[Visual Basic]

Public Property Checked As Boolean

[C#]

public bool Checked {get;set;}

[Delphi]

public property Checked: Boolean read get_Checked write set_Checked;


RenderInputRadioButton.GroupIndex Property

RenderInputRadioButton.GroupIndex Property

Gets or sets the group index for the radiobutton. Only one button in a group can be checked at any time.

[Visual Basic]

Public Property GroupIndex As Int32*

[C#]

public Int32* GroupIndex {get;set;}

[Delphi]

public property GroupIndex: Int32* read get_GroupIndex write set_GroupIndex;


RenderInputRadioButton Methods

RenderInputRadioButton Methods

The methods of the RenderInputRadioButton class are listed here. For a complete list of RenderInputRadioButton class members, see the RenderInputRadioButton Members topic.

Public Methods

CreateControl (inherited from RenderInputBase) | Creates the underlying windows control object.
GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.
IsControlNeededParentForWmPrint (inherited from RenderInputBase) | This method returns True if underlaying control of RenderInputBase object needs the parent to correctly process the WM_PRINT message. By default the RenderInputBase object returns False.
IsResetSelectionNeeded (inherited from RenderInputBase) | Returns True if selection within parent control should be reset when the underlying control receives an input focus.


RenderInputText Class

RenderInputText Class

Input render object providing text input.

For a list of all members of this type, see RenderInputText Members.

System.Object

C1.C1Preview.RenderObject

C1.C1Preview.RenderInputBase

C1.C1Preview.RenderInputText

[Visual Basic]

Public Class RenderInputText

Inherits RenderInputBase

[C#]

public class RenderInputText : RenderInputBase

[Delphi]

type RenderInputText = class (RenderInputBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderInputText Members

RenderInputText Members

RenderInputText overview

Public Properties

AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form. Default is True.
Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Cursor (inherited from RenderInputBase) | Gets or sets the cursor used when the mouse is over the control.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
InputActions (inherited from RenderInputBase) | Gets the collection of supported user actions and handlers associated with those actions. See help on InputActions class for details.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
PasswordChar | Gets or sets the char used to hide real characters when entering passwords. The default value of this property is ?\0? (no hiding takes place).
Printable (inherited from RenderInputBase) | Gets or sets the value indicating whether the control is printed. If True (default), the content of the control is printed normally. Otherwise, it is not printed or exported. This might be used for example to provide help for fields that are to be filled.
ReadOnly (inherited from RenderInputBase) | Gets or sets the value indicating whether the control is read-only. For read-only controls, all input actions are still fired, but the control's value cannot be changed. The default is False.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
StatusText (inherited from RenderInputBase) | Gets or sets the text that appears in the status line of the preview when the control has focus.
Style (inherited from RenderObject) | Style of this object.
Text | Gets or sets the text.
ToolTip (inherited from RenderInputBase) | Gets or sets the tooltip associated with the control.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.

Public Methods

CreateControl (inherited from RenderInputBase) | Creates the underlying windows control object.
GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderInputText Properties

RenderInputText Properties

The properties of the RenderInputText class are listed here. For a complete list of RenderInputText class members, see the RenderInputText Members topic.

Public Properties

AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form. Default is True.
Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Cursor (inherited from RenderInputBase) | Gets or sets the cursor used when the mouse is over the control.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
InputActions (inherited from RenderInputBase) | Gets the collection of supported user actions and handlers associated with those actions. See help on InputActions class for details.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
PasswordChar | Gets or sets the char used to hide real characters when entering passwords. The default value of this property is ?\0? (no hiding takes place).
Printable (inherited from RenderInputBase) | Gets or sets the value indicating whether the control is printed. If True (default), the content of the control is printed normally. Otherwise, it is not printed or exported. This might be used for example to provide help for fields that are to be filled.
ReadOnly (inherited from RenderInputBase) | Gets or sets the value indicating whether the control is read-only. For read-only controls, all input actions are still fired, but the control's value cannot be changed. The default is False.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
StatusText (inherited from RenderInputBase) | Gets or sets the text that appears in the status line of the preview when the control has focus.
Style (inherited from RenderObject) | Style of this object.
Text | Gets or sets the text.
ToolTip (inherited from RenderInputBase) | Gets or sets the tooltip associated with the control.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.


RenderInputText.AcceptsReturn Property

RenderInputText.AcceptsReturn Property

Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form. Default is True.

[Visual Basic]

Public Property AcceptsReturn As Boolean

[C#]

public bool AcceptsReturn {get;set;}

[Delphi]

public property AcceptsReturn: Boolean read get_AcceptsReturn write set_AcceptsReturn;


RenderInputText.PasswordChar Property

RenderInputText.PasswordChar Property

Gets or sets the char used to hide real characters when entering passwords. The default value of this property is ?\0? (no hiding takes place).

[Visual Basic]

Public Property PasswordChar As Char*

[C#]

public Char* PasswordChar {get;set;}

[Delphi]

public property PasswordChar: Char* read get_PasswordChar write set_PasswordChar;


RenderInputText.Text Property

RenderInputText.Text Property

Gets or sets the text.

[Visual Basic]

Public Property Text As String

[C#]

public string Text {get;set;}

[Delphi]

public property Text: String read get_Text write set_Text;


RenderInputText Methods

RenderInputText Methods

The methods of the RenderInputText class are listed here. For a complete list of RenderInputText class members, see the RenderInputText Members topic.

Public Methods

CreateControl (inherited from RenderInputBase) | Creates the underlying windows control object.
GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderLine Class

RenderLine Class

Represents render object that renders a line.

For a list of all members of this type, see RenderLine Members.

System.Object

C1.C1Preview.RenderObject

C1.C1Preview.RenderShapeBase

C1.C1Preview.RenderLineBase

C1.C1Preview.RenderLine

[Visual Basic]

Public Class RenderLine

Inherits RenderLineBase

[C#]

public class RenderLine : RenderLineBase

[Delphi]

type RenderLine = class (RenderLineBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderLine Members

RenderLine Members

RenderLine overview

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderLine Properties

RenderLine Properties

The properties of the RenderLine class are listed here. For a complete list of RenderLine class members, see the RenderLine Members topic.

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.


RenderLine Methods

RenderLine Methods

The methods of the RenderLine class are listed here. For a complete list of RenderLine class members, see the RenderLine Members topic.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderLineBase Class

RenderLineBase Class

Represents the base class for all line-like shapes (RenderLine, RenderPolygon, and so on).

For a list of all members of this type, see RenderLineBase Members.

System.Object

C1.C1Preview.RenderObject

C1.C1Preview.RenderShapeBase

C1.C1Preview.RenderLineBase

C1.C1Preview.RenderLine

C1.C1Preview.RenderPolygon

[Visual Basic]

MustInherit Public Class RenderLineBase

Inherits RenderShapeBase

[C#]

public abstract class RenderLineBase : RenderShapeBase

[Delphi]

type RenderLineBase = class abstract (RenderShapeBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderLineBase Members

RenderLineBase Members

RenderLineBase overview

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderLineBase Properties

RenderLineBase Properties

The properties of the RenderLineBase class are listed here. For a complete list of RenderLineBase class members, see the RenderLineBase Members topic.

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.


RenderLineBase Methods

RenderLineBase Methods

The methods of the RenderLineBase class are listed here. For a complete list of RenderLineBase class members, see the RenderLineBase Members topic.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderLineFragment Class

RenderLineFragment Class

Represents the fragment of the RenderLineBase object.

For a list of all members of this type, see RenderLineFragment Members.

System.Object

C1.C1Preview.RenderFragment

C1.C1Preview.RenderShapeFragment

C1.C1Preview.RenderLineFragment

[Visual Basic]

Public Class RenderLineFragment

Inherits RenderShapeFragment

[C#]

public class RenderLineFragment : RenderShapeFragment

[Delphi]

type RenderLineFragment = class (RenderShapeFragment);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderLineFragment Members

RenderLineFragment Members

RenderLineFragment overview

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.
ResolvingFinished (inherited from RenderFragment) | This method is called by the render engine after fully resolving of render fragment. Typically this method is used to clear temporary info used during resolving.


RenderLineFragment Properties

RenderLineFragment Properties

The properties of the RenderLineFragment class are listed here. For a complete list of RenderLineFragment class members, see the RenderLineFragment Members topic.

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.


RenderLineFragment Methods

RenderLineFragment Methods

The methods of the RenderLineFragment class are listed here. For a complete list of RenderLineFragment class members, see the RenderLineFragment Members topic.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.
ResolvingFinished (inherited from RenderFragment) | This method is called by the render engine after fully resolving of render fragment. Typically this method is used to clear temporary info used during resolving.


RenderObject Class

RenderObject Class

Base class for all render objects.

For a list of all members of this type, see RenderObject Members.

System.Object

C1.C1Preview.RenderObject

C1.C1Preview.RenderArea

C1.C1Preview.RenderEmpty

C1.C1Preview.RenderGraphics

C1.C1Preview.RenderImage

C1.C1Preview.RenderInputBase

C1.C1Preview.RenderRichText

C1.C1Preview.RenderShapeBase

C1.C1Preview.RenderTable

C1.C1Preview.RenderTextBase

[Visual Basic]

MustInherit Public Class RenderObject

Implements IDocumentLocation

[C#]

public abstract class RenderObject : IDocumentLocation

[Delphi]

type RenderObject = class abstract (TObject, IDocumentLocation);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderObject Members

RenderObject Members

RenderObject overview

Public Properties

Anchors | Gets the collection of anchors within this render object.
BreakAfter | Gets or sets the type of break after this object.
BreakBefore | Gets or sets the type of break before this object.
CanSplitHorz | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert | Indicates whether the object can be split vertically if it falls on a page break.
Children | Returns collection of child objects.
Collection | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document | Gets the C1Preview object containing this object.
FirstFragment | Gets the first object's fragment.
Fragments | Returns the collection of the object's fragments.
HasChildren | Returns True if object has child objects.
HasFragments | Gets or sets value indicating whether the object has the built fragments.
Height | Height of object.
Hyperlink | Gets or sets the hyperlink associated with this render object.
IndexInOwner | Gets the index in owner object, returns the -1 if no owner.
LastFragment | Gets the last object's fragment.
LayoutChangeAfter | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange | Gets or sets the PageNumberingChange object describing the change of page number.
Parent | Gets the parent RenderObject object.
RepeatBordersHorz | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style | Style of this object.
UserData | Gets or sets some data associated with object by user.
Width | Width of object.
X | X coordinate of object.
Y | Y coordinate of object.
ZOrder | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.

Public Methods

AssignFrom | Copies properties of another object. The list of fragments is not copied and not changed (Fragments property). Properties UserData, Stacking, ActionBefore, ActionAfter, PageNumberingChange are copied by references.
GetNestedObjectCount | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.
IndexOfFragment | Returns the index of fragment of object.


RenderObject Properties

RenderObject Properties

The properties of the RenderObject class are listed here. For a complete list of RenderObject class members, see the RenderObject Members topic.

Public Properties

Anchors | Gets the collection of anchors within this render object.
BreakAfter | Gets or sets the type of break after this object.
BreakBefore | Gets or sets the type of break before this object.
CanSplitHorz | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert | Indicates whether the object can be split vertically if it falls on a page break.
Children | Returns collection of child objects.
Collection | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document | Gets the C1Preview object containing this object.
FirstFragment | Gets the first object's fragment.
Fragments | Returns the collection of the object's fragments.
HasChildren | Returns True if object has child objects.
HasFragments | Gets or sets value indicating whether the object has the built fragments.
Height | Height of object.
Hyperlink | Gets or sets the hyperlink associated with this render object.
IndexInOwner | Gets the index in owner object, returns the -1 if no owner.
LastFragment | Gets the last object's fragment.
LayoutChangeAfter | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange | Gets or sets the PageNumberingChange object describing the change of page number.
Parent | Gets the parent RenderObject object.
RepeatBordersHorz | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style | Style of this object.
UserData | Gets or sets some data associated with object by user.
Width | Width of object.
X | X coordinate of object.
Y | Y coordinate of object.
ZOrder | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.


RenderObject.Anchors Property

RenderObject.Anchors Property

Gets the collection of anchors within this render object.

[Visual Basic]

Public ReadOnly Property Anchors As C1AnchorCollection

[C#]

public C1AnchorCollection Anchors {get;}

[Delphi]

public property Anchors: C1AnchorCollection read get_Anchors;


RenderObject.BreakAfter Property

RenderObject.BreakAfter Property

Gets or sets the type of break after this object.

[Visual Basic]

Public Property BreakAfter As BreakEnum

[C#]

public BreakEnum BreakAfter {get;set;}

[Delphi]

public property BreakAfter: BreakEnum read get_BreakAfter write set_BreakAfter;


RenderObject.BreakBefore Property

RenderObject.BreakBefore Property

Gets or sets the type of break before this object.

[Visual Basic]

Public Property BreakBefore As BreakEnum

[C#]

public BreakEnum BreakBefore {get;set;}

[Delphi]

public property BreakBefore: BreakEnum read get_BreakBefore write set_BreakBefore;


RenderObject.CanSplitHorz Property

RenderObject.CanSplitHorz Property

Indicates whether the object can be split horizontally if it falls on a page break.

[Visual Basic]

Public Property CanSplitHorz As Boolean

[C#]

public bool CanSplitHorz {get;set;}

[Delphi]

public property CanSplitHorz: Boolean read get_CanSplitHorz write set_CanSplitHorz;


RenderObject.CanSplitVert Property

RenderObject.CanSplitVert Property

Indicates whether the object can be split vertically if it falls on a page break.

[Visual Basic]

Public Property CanSplitVert As Boolean

[C#]

public bool CanSplitVert {get;set;}

[Delphi]

public property CanSplitVert: Boolean read get_CanSplitVert write set_CanSplitVert;


RenderObject.Children Property

RenderObject.Children Property

Returns collection of child objects.

[Visual Basic]

Public ReadOnly Property Children As RenderObjectCollection

[C#]

public RenderObjectCollection Children {get;}

[Delphi]

public property Children: RenderObjectCollection read get_Children;


RenderObject.Collection Property

RenderObject.Collection Property

Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.

[Visual Basic]

Public ReadOnly Property Collection As RenderObjectCollection

[C#]

public RenderObjectCollection Collection {get;}

[Delphi]

public property Collection: RenderObjectCollection read get_Collection;


RenderObject.Document Property

RenderObject.Document Property

Gets the C1Preview object containing this object.

[Visual Basic]

Public ReadOnly Property Document As C1PrintDocument

[C#]

public C1PrintDocument Document {get;}

[Delphi]

public property Document: C1PrintDocument read get_Document;


RenderObject.FirstFragment Property

RenderObject.FirstFragment Property

Gets the first object's fragment.

[Visual Basic]

Public ReadOnly Property FirstFragment As RenderFragment

[C#]

public RenderFragment FirstFragment {get;}

[Delphi]

public property FirstFragment: RenderFragment read get_FirstFragment;


RenderObject.Fragments Property

RenderObject.Fragments Property

Returns the collection of the object's fragments.

[Visual Basic]

Public ReadOnly Property Fragments As RenderFragmentCollection

[C#]

public RenderFragmentCollection Fragments {get;}

[Delphi]

public property Fragments: RenderFragmentCollection read get_Fragments;


RenderObject.HasChildren Property

RenderObject.HasChildren Property

Returns True if object has child objects.

[Visual Basic]

Public ReadOnly Property HasChildren As Boolean

[C#]

public bool HasChildren {get;}

[Delphi]

public property HasChildren: Boolean read get_HasChildren;


RenderObject.HasFragments Property

RenderObject.HasFragments Property

Gets or sets value indicating whether the object has the built fragments.

[Visual Basic]

Public ReadOnly Property HasFragments As Boolean

[C#]

public bool HasFragments {get;}

[Delphi]

public property HasFragments: Boolean read get_HasFragments;


RenderObject.Height Property

RenderObject.Height Property

Height of object.

[Visual Basic]

Public Property Height As Unit

[C#]

public Unit Height {get;set;}

[Delphi]

public property Height: Unit read get_Height write set_Height;


RenderObject.Hyperlink Property

RenderObject.Hyperlink Property

Gets or sets the hyperlink associated with this render object.

[Visual Basic]

Public Property Hyperlink As C1Hyperlink

[C#]

public C1Hyperlink Hyperlink {get;set;}

[Delphi]

public property Hyperlink: C1Hyperlink read get_Hyperlink write set_Hyperlink;


RenderObject.IndexInOwner Property

RenderObject.IndexInOwner Property

Gets the index in owner object, returns the -1 if no owner.

[Visual Basic]

Public ReadOnly Property IndexInOwner As Int32*

[C#]

public Int32* IndexInOwner {get;}

[Delphi]

public property IndexInOwner: Int32* read get_IndexInOwner;


RenderObject.LastFragment Property

RenderObject.LastFragment Property

Gets the last object's fragment.

[Visual Basic]

Public ReadOnly Property LastFragment As RenderFragment

[C#]

public RenderFragment LastFragment {get;}

[Delphi]

public property LastFragment: RenderFragment read get_LastFragment;


RenderObject.LayoutChangeAfter Property

RenderObject.LayoutChangeAfter Property

Gets or sets the LayoutChangeBase object defining the change of page layout after object.

[Visual Basic]

Public Property LayoutChangeAfter As LayoutChangeBase

[C#]

public LayoutChangeBase LayoutChangeAfter {get;set;}

[Delphi]

public property LayoutChangeAfter: LayoutChangeBase read get_LayoutChangeAfter write set_LayoutChangeAfter;


RenderObject.LayoutChangeBefore Property

RenderObject.LayoutChangeBefore Property

Gets or sets the LayoutChangeBase object defining the change of page layout before object.

[Visual Basic]

Public Property LayoutChangeBefore As LayoutChangeBase

[C#]

public LayoutChangeBase LayoutChangeBefore {get;set;}

[Delphi]

public property LayoutChangeBefore: LayoutChangeBase read get_LayoutChangeBefore write set_LayoutChangeBefore;


RenderObject.Name Property

RenderObject.Name Property

Unique name of object, can be string.Empty or *unique* within of _owner.

[Visual Basic]

Public Property Name As String

[C#]

public string Name {get;set;}

[Delphi]

public property Name: String read get_Name write set_Name;


RenderObject.PageNumberingChange Property

RenderObject.PageNumberingChange Property

Gets or sets the PageNumberingChange object describing the change of page number.

[Visual Basic]

Public Property PageNumberingChange As PageNumberingChange

[C#]

public PageNumberingChange PageNumberingChange {get;set;}

[Delphi]

public property PageNumberingChange: PageNumberingChange read get_PageNumberingChange write set_PageNumberingChange;

Property Value


RenderObject.Parent Property

RenderObject.Parent Property

Gets the parent RenderObject object.

[Visual Basic]

Public ReadOnly Property Parent As RenderObject

[C#]

public RenderObject Parent {get;}

[Delphi]

public property Parent: RenderObject read get_Parent;


RenderObject.RepeatBordersHorz Property

RenderObject.RepeatBordersHorz Property

Indicates whether horizontal borders of object must be repeated when horizontal splitting.

[Visual Basic]

Public Property RepeatBordersHorz As Boolean

[C#]

public bool RepeatBordersHorz {get;set;}

[Delphi]

public property RepeatBordersHorz: Boolean read get_RepeatBordersHorz write set_RepeatBordersHorz;


RenderObject.RepeatBordersVert Property

RenderObject.RepeatBordersVert Property

Indicates whether vertical borders of object must be repeated when vertical splitting.

[Visual Basic]

Public Property RepeatBordersVert As Boolean

[C#]

public bool RepeatBordersVert {get;set;}

[Delphi]

public property RepeatBordersVert: Boolean read get_RepeatBordersVert write set_RepeatBordersVert;


RenderObject.Style Property

RenderObject.Style Property

Style of this object.

[Visual Basic]

Public ReadOnly Property Style As Style

[C#]

public Style Style {get;}

[Delphi]

public property Style: Style read get_Style;


RenderObject.UserData Property

RenderObject.UserData Property

Gets or sets some data associated with object by user.

[Visual Basic]

Public Property UserData As Object

[C#]

public object UserData {get;set;}

[Delphi]

public property UserData: Object read get_UserData write set_UserData;


RenderObject.Width Property

RenderObject.Width Property

Width of object.

[Visual Basic]

Public Property Width As Unit

[C#]

public Unit Width {get;set;}

[Delphi]

public property Width: Unit read get_Width write set_Width;


RenderObject.X Property

RenderObject.X Property

X coordinate of object.

[Visual Basic]

Public Property X As Unit

[C#]

public Unit X {get;set;}

[Delphi]

public property X: Unit read get_X write set_X;


RenderObject.Y Property

RenderObject.Y Property

Y coordinate of object.

[Visual Basic]

Public Property Y As Unit

[C#]

public Unit Y {get;set;}

[Delphi]

public property Y: Unit read get_Y write set_Y;


RenderObject.ZOrder Property

RenderObject.ZOrder Property

Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.

[Visual Basic]

Public Property ZOrder As Int32*

[C#]

public Int32* ZOrder {get;set;}

[Delphi]

public property ZOrder: Int32* read get_ZOrder write set_ZOrder;


RenderObject Methods

RenderObject Methods

The methods of the RenderObject class are listed here. For a complete list of RenderObject class members, see the RenderObject Members topic.

Public Methods

AssignFrom | Copies properties of another object. The list of fragments is not copied and not changed (Fragments property). Properties UserData, Stacking, ActionBefore, ActionAfter, PageNumberingChange are copied by references.
GetNestedObjectCount | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.
IndexOfFragment | Returns the index of fragment of object.


RenderObject.AssignFrom Method

RenderObject.AssignFrom Method

Copies properties of another object. The list of fragments is not copied and not changed (Fragments property). Properties UserData, Stacking, ActionBefore, ActionAfter, PageNumberingChange are copied by references.

[Visual Basic]

Overridable Public Sub AssignFrom( _

ByVal source As RenderObject _

)

[C#]

virtual public void AssignFrom(

RenderObject source

);

[Delphi]

public procedure AssignFrom(

source: RenderObject

); virtual;

Parameters

source

The source object, properties of which are copied.


RenderObject.GetNestedObjectCount Method

RenderObject.GetNestedObjectCount Method

Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.

[Visual Basic]

Public Function GetNestedObjectCount() As Int32*

[C#]

public Int32* GetNestedObjectCount()

[Delphi]

public function GetNestedObjectCount(): Int32*;

Return Value

Returns the count of nested objects.


RenderObject.GetOwnedObjectCount Method

RenderObject.GetOwnedObjectCount Method

Calculates the count of objects which are owned by this object. This method takes into account:
- Child objects (and their children).
- Objects which are specified in page layouts as PageHeader, PageFooter, and so on.

[Visual Basic]

Public Function GetOwnedObjectCount() As Int32*

[C#]

public Int32* GetOwnedObjectCount()

[Delphi]

public function GetOwnedObjectCount(): Int32*;

Return Value

Returns the count of owned objects.


RenderObject.IndexOfFragment Method

RenderObject.IndexOfFragment Method

Returns the index of fragment of object.

[Visual Basic]

Public Function IndexOfFragment( _

ByVal rf As RenderFragment _

) As Int32*

[C#]

public Int32* IndexOfFragment(

RenderFragment rf

);

[Delphi]

public function IndexOfFragment(

rf: RenderFragment

): Int32*;

Parameters

rf

RenderFragment object whose index must be returned.


RenderParagraph Class

RenderParagraph Class

Describes a paragraph render object.

For a list of all members of this type, see RenderParagraph Members.

System.Object

C1.C1Preview.RenderObject

C1.C1Preview.RenderTextBase

C1.C1Preview.RenderParagraph

C1.C1Preview.RenderTocItem

[Visual Basic]

Public Class RenderParagraph

Inherits RenderTextBase

[C#]

public class RenderParagraph : RenderTextBase

[Delphi]

type RenderParagraph = class (RenderTextBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderParagraph Members

RenderParagraph Members

RenderParagraph overview

Public Constructors

RenderParagraph Constructor

Initializes a new instance of the RenderParagraph class.

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Content | Gets the ParagraphObjectCollection representing the content of this RenderParagraph object,
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasContent | Gets the value indicating whether the current RenderParagraph object has any content.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
HasTabPositions (inherited from RenderTextBase) | Gets the value indicating whether the TabPositions collection is not empty.
HasText | Overriden. Overridden. Gets the value indicating whether the current RenderParagraph object has any content.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
TabPositions (inherited from RenderTextBase) | Collection of tabs in text.
TextLength | Overriden. Gets the length of text in paragraph each non text object has one char length.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.

Public Methods

AssignFrom | Overriden. Assigns the properties of the current object from the specified RenderParagraph object.
GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderParagraph Constructor

RenderParagraph Constructor

Overload List

Initializes a new instance of the RenderParagraph class.

[Visual Basic] Public Function New()

[C#] public RenderParagraph();

[Delphi] public constructor Create(); overload;

Initializes a new instance of the RenderParagraph class.

[Visual Basic] Public Function New(AlignHorzEnum)

[C#] public RenderParagraph(AlignHorzEnum);

[Delphi] public constructor Create(AlignHorzEnum); overload;

Initializes a new instance of the RenderParagraph class.

[Visual Basic] Public Function New(Font)

[C#] public RenderParagraph(Font);

[Delphi] public constructor Create(Font); overload;

Initializes a new instance of the RenderParagraph class.

[Visual Basic] Public Function New(Style)

[C#] public RenderParagraph(Style);

[Delphi] public constructor Create(Style); overload;

Initializes a new instance of the RenderParagraph class.

[Visual Basic] Public Function New(Font, AlignHorzEnum)

[C#] public RenderParagraph(Font, AlignHorzEnum);

[Delphi] public constructor Create(Font; AlignHorzEnum); overload;

Initializes a new instance of the RenderParagraph class.

[Visual Basic] Public Function New(Font, Color)

[C#] public RenderParagraph(Font, Color);

[Delphi] public constructor Create(Font; Color); overload;

Initializes a new instance of the RenderParagraph class.

[Visual Basic] Public Function New(Font, Color, AlignHorzEnum)

[C#] public RenderParagraph(Font, Color, AlignHorzEnum);

[Delphi] public constructor Create(Font; Color; AlignHorzEnum); overload;


RenderParagraph Constructor ()

RenderParagraph Constructor ()

Previous Next

Initializes a new instance of the RenderParagraph class.

[Visual Basic]

Public Function New()

[C#]

public RenderParagraph()

[Delphi]

public constructor Create(); overload;


RenderParagraph Constructor (AlignHorzEnum)

RenderParagraph Constructor (AlignHorzEnum)

Previous Next

Initializes a new instance of the RenderParagraph class.

[Visual Basic]

Public Function New( _

ByVal horzAlign As AlignHorzEnum _

)

[C#]

public RenderParagraph(

AlignHorzEnum horzAlign

);

[Delphi]

public constructor Create(

horzAlign: AlignHorzEnum

); overload;

Parameters

horzAlign

The horizontal alignment to use for this RenderParagraph object.


RenderParagraph Constructor (Font)

RenderParagraph Constructor (Font)

Previous Next

Initializes a new instance of the RenderParagraph class.

[Visual Basic]

Public Function New( _

ByVal font As Font _

)

[C#]

public RenderParagraph(

Font font

);

[Delphi]

public constructor Create(

font: Font

); overload;

Parameters

font

The font to use for this RenderParagraph object.


RenderParagraph Constructor (Style)

RenderParagraph Constructor (Style)

Previous Next

Initializes a new instance of the RenderParagraph class.

[Visual Basic]

Public Function New( _

ByVal style As Style _

)

[C#]

public RenderParagraph(

Style style

);

[Delphi]

public constructor Create(

style: Style

); overload;

Parameters

style

The style to use for this RenderParagraph object.


RenderParagraph Constructor (Font, AlignHorzEnum)

RenderParagraph Constructor (Font, AlignHorzEnum)

Previous Next

Initializes a new instance of the RenderParagraph class.

[Visual Basic]

Public Function New( _

ByVal font As Font, _

ByVal horzAlign As AlignHorzEnum _

)

[C#]

public RenderParagraph(

Font font,

AlignHorzEnum horzAlign

);

[Delphi]

public constructor Create(

font: Font;

horzAlign: AlignHorzEnum

); overload;

Parameters

font

The font to use for this RenderParagraph object.

horzAlign

The horizontal alignment to use for this RenderParagraph object.


RenderParagraph Constructor (Font, Color)

RenderParagraph Constructor (Font, Color)

Previous Next

Initializes a new instance of the RenderParagraph class.

[Visual Basic]

Public Function New( _

ByVal font As Font, _

ByVal textColor As Color _

)

[C#]

public RenderParagraph(

Font font,

Color textColor

);

[Delphi]

public constructor Create(

font: Font;

textColor: Color

); overload;

Parameters

font

The font to use for this RenderParagraph object.

textColor

The text color to use for this RenderParagraph object.


RenderParagraph Constructor (Font, Color, AlignHorzEnum)

RenderParagraph Constructor (Font, Color, AlignHorzEnum)

Previous Next

Initializes a new instance of the RenderParagraph class.

[Visual Basic]

Public Function New( _

ByVal font As Font, _

ByVal textColor As Color, _

ByVal horzAlign As AlignHorzEnum _

)

[C#]

public RenderParagraph(

Font font,

Color textColor,

AlignHorzEnum horzAlign

);

[Delphi]

public constructor Create(

font: Font;

textColor: Color;

horzAlign: AlignHorzEnum

); overload;

Parameters

font

The font to use for this RenderParagraph object.

textColor

The text color to use for this RenderParagraph object.

horzAlign

The horizontal alignment to use for this RenderParagraph object.


RenderParagraph Properties

RenderParagraph Properties

The properties of the RenderParagraph class are listed here. For a complete list of RenderParagraph class members, see the RenderParagraph Members topic.

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Content | Gets the ParagraphObjectCollection representing the content of this RenderParagraph object,
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasContent | Gets the value indicating whether the current RenderParagraph object has any content.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
HasTabPositions (inherited from RenderTextBase) | Gets the value indicating whether the TabPositions collection is not empty.
HasText | Overriden. Overridden. Gets the value indicating whether the current RenderParagraph object has any content.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
TabPositions (inherited from RenderTextBase) | Collection of tabs in text.
TextLength | Overriden. Gets the length of text in paragraph each non text object has one char length.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.


RenderParagraph.Content Property

RenderParagraph.Content Property

Gets the ParagraphObjectCollection representing the content of this RenderParagraph object,

[Visual Basic]

Public ReadOnly Property Content As ParagraphObjectCollection

[C#]

public ParagraphObjectCollection Content {get;}

[Delphi]

public property Content: ParagraphObjectCollection read get_Content;


RenderParagraph.HasContent Property

RenderParagraph.HasContent Property

Gets the value indicating whether the current RenderParagraph object has any content.

[Visual Basic]

Public ReadOnly Property HasContent As Boolean

[C#]

public bool HasContent {get;}

[Delphi]

public property HasContent: Boolean read get_HasContent;


RenderParagraph.HasText Property

RenderParagraph.HasText Property

Overridden. Gets the value indicating whether the current RenderParagraph object has any content.

[Visual Basic]

Overrides Public ReadOnly Property HasText As Boolean

[C#]

override public bool HasText {get;}

[Delphi]

public property HasText: Boolean read get_HasText;


RenderParagraph.TextLength Property

RenderParagraph.TextLength Property

Gets the length of text in paragraph each non text object has one char length.

[Visual Basic]

Overrides Public ReadOnly Property TextLength As Int32*

[C#]

override public Int32* TextLength {get;}

[Delphi]

public property TextLength: Int32* read get_TextLength;


RenderParagraph Methods

RenderParagraph Methods

The methods of the RenderParagraph class are listed here. For a complete list of RenderParagraph class members, see the RenderParagraph Members topic.

Public Methods

AssignFrom | Overriden. Assigns the properties of the current object from the specified RenderParagraph object.
GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderParagraph.AssignFrom Method

RenderParagraph.AssignFrom Method

Assigns the properties of the current object from the specified RenderParagraph object.

[Visual Basic]

Overrides Public Sub AssignFrom( _

ByVal source As RenderObject _

)

[C#]

override public void AssignFrom(

RenderObject source

);

[Delphi]

public procedure AssignFrom(

source: RenderObject

); override;

Parameters

source

The object to copy the properties from.


RenderParagraphFragment Class

RenderParagraphFragment Class

For a list of all members of this type, see RenderParagraphFragment Members.

System.Object

C1.C1Preview.RenderFragment

C1.C1Preview.RenderTextFragmentBase

C1.C1Preview.RenderParagraphFragment

C1.C1Preview.RenderTocItemFragment

[Visual Basic]

Public Class RenderParagraphFragment

Inherits RenderTextFragmentBase

[C#]

public class RenderParagraphFragment : RenderTextFragmentBase

[Delphi]

type RenderParagraphFragment = class (RenderTextFragmentBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderParagraphFragment Members

RenderParagraphFragment Members

RenderParagraphFragment overview

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.


RenderParagraphFragment Properties

RenderParagraphFragment Properties

The properties of the RenderParagraphFragment class are listed here. For a complete list of RenderParagraphFragment class members, see the RenderParagraphFragment Members topic.

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.


RenderParagraphFragment Methods

RenderParagraphFragment Methods

The methods of the RenderParagraphFragment class are listed here. For a complete list of RenderParagraphFragment class members, see the RenderParagraphFragment Members topic.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.


RenderPie Class

RenderPie Class

Represents RO that renders ellipse-based wedge.

For a list of all members of this type, see RenderPie Members.

System.Object

C1.C1Preview.RenderObject

C1.C1Preview.RenderShapeBase

C1.C1Preview.RenderRectangle

C1.C1Preview.RenderEllipse

C1.C1Preview.RenderPie

[Visual Basic]

Public Class RenderPie

Inherits RenderEllipse

[C#]

public class RenderPie : RenderEllipse

[Delphi]

type RenderPie = class (RenderEllipse);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderPie Members

RenderPie Members

RenderPie overview

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderPie Properties

RenderPie Properties

The properties of the RenderPie class are listed here. For a complete list of RenderPie class members, see the RenderPie Members topic.

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.


RenderPie Methods

RenderPie Methods

The methods of the RenderPie class are listed here. For a complete list of RenderPie class members, see the RenderPie Members topic.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderPolygon Class

RenderPolygon Class

Represents RO that renders polygon, if Closed is True then polygon will be filled.

For a list of all members of this type, see RenderPolygon Members.

System.Object

C1.C1Preview.RenderObject

C1.C1Preview.RenderShapeBase

C1.C1Preview.RenderLineBase

C1.C1Preview.RenderPolygon

[Visual Basic]

Public Class RenderPolygon

Inherits RenderLineBase

[C#]

public class RenderPolygon : RenderLineBase

[Delphi]

type RenderPolygon = class (RenderLineBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderPolygon Members

RenderPolygon Members

RenderPolygon overview

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderPolygon Properties

RenderPolygon Properties

The properties of the RenderPolygon class are listed here. For a complete list of RenderPolygon class members, see the RenderPolygon Members topic.

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.


RenderPolygon Methods

RenderPolygon Methods

The methods of the RenderPolygon class are listed here. For a complete list of RenderPolygon class members, see the RenderPolygon Members topic.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderRectangle Class

RenderRectangle Class

Represents RO that renders a rectangle.

For a list of all members of this type, see RenderRectangle Members.

System.Object

C1.C1Preview.RenderObject

C1.C1Preview.RenderShapeBase

C1.C1Preview.RenderRectangle

C1.C1Preview.RenderEllipse

C1.C1Preview.RenderRoundRectangle

[Visual Basic]

Public Class RenderRectangle

Inherits RenderShapeBase

[C#]

public class RenderRectangle : RenderShapeBase

[Delphi]

type RenderRectangle = class (RenderShapeBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderRectangle Members

RenderRectangle Members

RenderRectangle overview

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderRectangle Properties

RenderRectangle Properties

The properties of the RenderRectangle class are listed here. For a complete list of RenderRectangle class members, see the RenderRectangle Members topic.

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.


RenderRectangle Methods

RenderRectangle Methods

The methods of the RenderRectangle class are listed here. For a complete list of RenderRectangle class members, see the RenderRectangle Members topic.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderRectangleFragment Class

RenderRectangleFragment Class

Represents the fragment of the RenderRectangle object.

For a list of all members of this type, see RenderRectangleFragment Members.

System.Object

C1.C1Preview.RenderFragment

C1.C1Preview.RenderShapeFragment

C1.C1Preview.RenderRectangleFragment

C1.C1Preview.RenderRoundRectangleFragment

[Visual Basic]

Public Class RenderRectangleFragment

Inherits RenderShapeFragment

[C#]

public class RenderRectangleFragment : RenderShapeFragment

[Delphi]

type RenderRectangleFragment = class (RenderShapeFragment);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderRectangleFragment Members

RenderRectangleFragment Members

RenderRectangleFragment overview

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.
ResolvingFinished (inherited from RenderFragment) | This method is called by the render engine after fully resolving of render fragment. Typically this method is used to clear temporary info used during resolving.


RenderRectangleFragment Properties

RenderRectangleFragment Properties

The properties of the RenderRectangleFragment class are listed here. For a complete list of RenderRectangleFragment class members, see the RenderRectangleFragment Members topic.

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.


RenderRectangleFragment Methods

RenderRectangleFragment Methods

The methods of the RenderRectangleFragment class are listed here. For a complete list of RenderRectangleFragment class members, see the RenderRectangleFragment Members topic.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.
ResolvingFinished (inherited from RenderFragment) | This method is called by the render engine after fully resolving of render fragment. Typically this method is used to clear temporary info used during resolving.


RenderRichText Class

RenderRichText Class

Represents RO that renders RTF text.

For a list of all members of this type, see RenderRichText Members.

System.Object

C1.C1Preview.RenderObject

C1.C1Preview.RenderRichText

[Visual Basic]

Public Class RenderRichText

Inherits RenderObject

[C#]

public class RenderRichText : RenderObject

[Delphi]

type RenderRichText = class (RenderObject);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderRichText Members

RenderRichText Members

RenderRichText overview

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
DetectUrls | Gets or sets a value indicating whether or not the RenderRichText will automatically format a Uniform Resource Locator (URL) when it is found into the assigned RTF text.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
HasRtf | Returns True if object has a RTF text.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Rtf | RTF formatted text.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderRichText Properties

RenderRichText Properties

The properties of the RenderRichText class are listed here. For a complete list of RenderRichText class members, see the RenderRichText Members topic.

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
DetectUrls | Gets or sets a value indicating whether or not the RenderRichText will automatically format a Uniform Resource Locator (URL) when it is found into the assigned RTF text.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
HasRtf | Returns True if object has a RTF text.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Rtf | RTF formatted text.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.


RenderRichText.DetectUrls Property

RenderRichText.DetectUrls Property

Gets or sets a value indicating whether or not the RenderRichText will automatically format a Uniform Resource Locator (URL) when it is found into the assigned RTF text.

[Visual Basic]

Public Property DetectUrls As Boolean

[C#]

public bool DetectUrls {get;set;}

[Delphi]

public property DetectUrls: Boolean read get_DetectUrls write set_DetectUrls;


RenderRichText.HasRtf Property

RenderRichText.HasRtf Property

Returns True if object has a RTF text.

[Visual Basic]

Public ReadOnly Property HasRtf As Boolean

[C#]

public bool HasRtf {get;}

[Delphi]

public property HasRtf: Boolean read get_HasRtf;


RenderRichText.Rtf Property

RenderRichText.Rtf Property

RTF formatted text.

[Visual Basic]

Public Property Rtf As String

[C#]

public string Rtf {get;set;}

[Delphi]

public property Rtf: String read get_Rtf write set_Rtf;


RenderRichText Methods

RenderRichText Methods

The methods of the RenderRichText class are listed here. For a complete list of RenderRichText class members, see the RenderRichText Members topic.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderRichTextFragment Class

RenderRichTextFragment Class

For a list of all members of this type, see RenderRichTextFragment Members.

System.Object

C1.C1Preview.RenderFragment

C1.C1Preview.RenderRichTextFragment

[Visual Basic]

Public Class RenderRichTextFragment

Inherits RenderFragment

[C#]

public class RenderRichTextFragment : RenderFragment

[Delphi]

type RenderRichTextFragment = class (RenderFragment);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderRichTextFragment Members

RenderRichTextFragment Members

RenderRichTextFragment overview

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.
ResolvingFinished (inherited from RenderFragment) | This method is called by the render engine after fully resolving of render fragment. Typically this method is used to clear temporary info used during resolving.


RenderRichTextFragment Properties

RenderRichTextFragment Properties

The properties of the RenderRichTextFragment class are listed here. For a complete list of RenderRichTextFragment class members, see the RenderRichTextFragment Members topic.

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.


RenderRichTextFragment Methods

RenderRichTextFragment Methods

The methods of the RenderRichTextFragment class are listed here. For a complete list of RenderRichTextFragment class members, see the RenderRichTextFragment Members topic.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.
ResolvingFinished (inherited from RenderFragment) | This method is called by the render engine after fully resolving of render fragment. Typically this method is used to clear temporary info used during resolving.


RenderRoundRectangle Class

RenderRoundRectangle Class

Represents RO that renders a rounded rectangle.

For a list of all members of this type, see RenderRoundRectangle Members.

System.Object

C1.C1Preview.RenderObject

C1.C1Preview.RenderShapeBase

C1.C1Preview.RenderRectangle

C1.C1Preview.RenderRoundRectangle

[Visual Basic]

Public Class RenderRoundRectangle

Inherits RenderRectangle

[C#]

public class RenderRoundRectangle : RenderRectangle

[Delphi]

type RenderRoundRectangle = class (RenderRectangle);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderRoundRectangle Members

RenderRoundRectangle Members

RenderRoundRectangle overview

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderRoundRectangle Properties

RenderRoundRectangle Properties

The properties of the RenderRoundRectangle class are listed here. For a complete list of RenderRoundRectangle class members, see the RenderRoundRectangle Members topic.

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.


RenderRoundRectangle Methods

RenderRoundRectangle Methods

The methods of the RenderRoundRectangle class are listed here. For a complete list of RenderRoundRectangle class members, see the RenderRoundRectangle Members topic.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderRoundRectangleFragment Class

RenderRoundRectangleFragment Class

Represents the fragment of the RenderRectangle object.

For a list of all members of this type, see RenderRoundRectangleFragment Members.

System.Object

C1.C1Preview.RenderFragment

C1.C1Preview.RenderShapeFragment

C1.C1Preview.RenderRectangleFragment

C1.C1Preview.RenderRoundRectangleFragment

[Visual Basic]

Public Class RenderRoundRectangleFragment

Inherits RenderRectangleFragment

[C#]

public class RenderRoundRectangleFragment : RenderRectangleFragment

[Delphi]

type RenderRoundRectangleFragment = class (RenderRectangleFragment);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderRoundRectangleFragment Members

RenderRoundRectangleFragment Members

RenderRoundRectangleFragment overview

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.
ResolvingFinished (inherited from RenderFragment) | This method is called by the render engine after fully resolving of render fragment. Typically this method is used to clear temporary info used during resolving.


RenderRoundRectangleFragment Properties

RenderRoundRectangleFragment Properties

The properties of the RenderRoundRectangleFragment class are listed here. For a complete list of RenderRoundRectangleFragment class members, see the RenderRoundRectangleFragment Members topic.

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.


RenderRoundRectangleFragment Methods

RenderRoundRectangleFragment Methods

The methods of the RenderRoundRectangleFragment class are listed here. For a complete list of RenderRoundRectangleFragment class members, see the RenderRoundRectangleFragment Members topic.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.
ResolvingFinished (inherited from RenderFragment) | This method is called by the render engine after fully resolving of render fragment. Typically this method is used to clear temporary info used during resolving.


RenderShapeBase Class

RenderShapeBase Class

Base class for ROs that renders shapes.

For a list of all members of this type, see RenderShapeBase Members.

System.Object

C1.C1Preview.RenderObject

C1.C1Preview.RenderShapeBase

C1.C1Preview.RenderLineBase

C1.C1Preview.RenderRectangle

[Visual Basic]

MustInherit Public Class RenderShapeBase

Inherits RenderObject

[C#]

public abstract class RenderShapeBase : RenderObject

[Delphi]

type RenderShapeBase = class abstract (RenderObject);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderShapeBase Members

RenderShapeBase Members

RenderShapeBase overview

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderShapeBase Properties

RenderShapeBase Properties

The properties of the RenderShapeBase class are listed here. For a complete list of RenderShapeBase class members, see the RenderShapeBase Members topic.

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.


RenderShapeBase Methods

RenderShapeBase Methods

The methods of the RenderShapeBase class are listed here. For a complete list of RenderShapeBase class members, see the RenderShapeBase Members topic.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderShapeFragment Class

RenderShapeFragment Class

Represents the fragment of RenderShape object.

For a list of all members of this type, see RenderShapeFragment Members.

System.Object

C1.C1Preview.RenderFragment

C1.C1Preview.RenderShapeFragment

C1.C1Preview.RenderLineFragment

C1.C1Preview.RenderRectangleFragment

[Visual Basic]

MustInherit Public Class RenderShapeFragment

Inherits RenderFragment

[C#]

public abstract class RenderShapeFragment : RenderFragment

[Delphi]

type RenderShapeFragment = class abstract (RenderFragment);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderShapeFragment Members

RenderShapeFragment Members

RenderShapeFragment overview

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.
ResolvingFinished (inherited from RenderFragment) | This method is called by the render engine after fully resolving of render fragment. Typically this method is used to clear temporary info used during resolving.


RenderShapeFragment Properties

RenderShapeFragment Properties

The properties of the RenderShapeFragment class are listed here. For a complete list of RenderShapeFragment class members, see the RenderShapeFragment Members topic.

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.


RenderShapeFragment Methods

RenderShapeFragment Methods

The methods of the RenderShapeFragment class are listed here. For a complete list of RenderShapeFragment class members, see the RenderShapeFragment Members topic.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.
ResolvingFinished (inherited from RenderFragment) | This method is called by the render engine after fully resolving of render fragment. Typically this method is used to clear temporary info used during resolving.


RenderTable Class

RenderTable Class

Represents RenderObject that renders tables.

For a list of all members of this type, see RenderTable Members.

System.Object

C1.C1Preview.RenderObject

C1.C1Preview.RenderTable

[Visual Basic]

Public Class RenderTable

Inherits RenderObject

[C#]

public class RenderTable : RenderObject

[Delphi]

type RenderTable = class (RenderObject);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderTable Members

RenderTable Members

RenderTable overview

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Cells | Gets the collection of cells.
Children (inherited from RenderObject) | Returns collection of child objects.
ColGroups | Gets the TableVectorGroupCollection object representing the groups of columns.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Cols | Gets the collection of table's columns.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
HorzPageFooterOnLastPage | Gets or sets value indicating whether the horizontal page footer should be printed on first page.
HorzPageHeaderOnFirstPage | Gets or sets value indicating whether the horizontal page header should be printed on first page.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
RowGroups | Gets the TableVectorGroupCollection object representing the groups of rows.
Rows | Gets the collection of table's rows.
Stretch | Gets or sets the mode of stretching of table columns.
Style (inherited from RenderObject) | Style of this object.
UserCellGroups | Gets the collection of groups of cells defined by the user.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
VertPageFooterOnLastPage | Gets or sets value indicating whether the vertical page footer should be printed on first page.
VertPageHeaderOnFirstPage | Gets or sets value indicating whether the vertical page header should be printed on first page.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderTable Properties

RenderTable Properties

The properties of the RenderTable class are listed here. For a complete list of RenderTable class members, see the RenderTable Members topic.

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Cells | Gets the collection of cells.
Children (inherited from RenderObject) | Returns collection of child objects.
ColGroups | Gets the TableVectorGroupCollection object representing the groups of columns.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Cols | Gets the collection of table's columns.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
HorzPageFooterOnLastPage | Gets or sets value indicating whether the horizontal page footer should be printed on first page.
HorzPageHeaderOnFirstPage | Gets or sets value indicating whether the horizontal page header should be printed on first page.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
RowGroups | Gets the TableVectorGroupCollection object representing the groups of rows.
Rows | Gets the collection of table's rows.
Stretch | Gets or sets the mode of stretching of table columns.
Style (inherited from RenderObject) | Style of this object.
UserCellGroups | Gets the collection of groups of cells defined by the user.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
VertPageFooterOnLastPage | Gets or sets value indicating whether the vertical page footer should be printed on first page.
VertPageHeaderOnFirstPage | Gets or sets value indicating whether the vertical page header should be printed on first page.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.


RenderTable.Cells Property

RenderTable.Cells Property

Gets the collection of cells.

[Visual Basic]

Public ReadOnly Property Cells As TableCellCollection

[C#]

public TableCellCollection Cells {get;}

[Delphi]

public property Cells: TableCellCollection read get_Cells;


RenderTable.ColGroups Property

RenderTable.ColGroups Property

Gets the TableVectorGroupCollection object representing the groups of columns.

[Visual Basic]

Public ReadOnly Property ColGroups As TableVectorGroupCollection

[C#]

public TableVectorGroupCollection ColGroups {get;}

[Delphi]

public property ColGroups: TableVectorGroupCollection read get_ColGroups;


RenderTable.Cols Property

RenderTable.Cols Property

Gets the collection of table's columns.

[Visual Basic]

Public ReadOnly Property Cols As TableColCollection

[C#]

public TableColCollection Cols {get;}

[Delphi]

public property Cols: TableColCollection read get_Cols;


RenderTable.HorzPageFooterOnLastPage Property

RenderTable.HorzPageFooterOnLastPage Property

Gets or sets value indicating whether the horizontal page footer should be printed on first page.

[Visual Basic]

Public Property HorzPageFooterOnLastPage As Boolean

[C#]

public bool HorzPageFooterOnLastPage {get;set;}

[Delphi]

public property HorzPageFooterOnLastPage: Boolean read get_HorzPageFooterOnLastPage write set_HorzPageFooterOnLastPage;


RenderTable.HorzPageHeaderOnFirstPage Property

RenderTable.HorzPageHeaderOnFirstPage Property

Gets or sets value indicating whether the horizontal page header should be printed on first page.

[Visual Basic]

Public Property HorzPageHeaderOnFirstPage As Boolean

[C#]

public bool HorzPageHeaderOnFirstPage {get;set;}

[Delphi]

public property HorzPageHeaderOnFirstPage: Boolean read get_HorzPageHeaderOnFirstPage write set_HorzPageHeaderOnFirstPage;


RenderTable.RowGroups Property

RenderTable.RowGroups Property

Gets the TableVectorGroupCollection object representing the groups of rows.

[Visual Basic]

Public ReadOnly Property RowGroups As TableVectorGroupCollection

[C#]

public TableVectorGroupCollection RowGroups {get;}

[Delphi]

public property RowGroups: TableVectorGroupCollection read get_RowGroups;


RenderTable.Rows Property

RenderTable.Rows Property

Gets the collection of table's rows.

[Visual Basic]

Public ReadOnly Property Rows As TableRowCollection

[C#]

public TableRowCollection Rows {get;}

[Delphi]

public property Rows: TableRowCollection read get_Rows;


RenderTable.Stretch Property

RenderTable.Stretch Property

Gets or sets the mode of stretching of table columns.

[Visual Basic]

Public Property Stretch As StretchTableEnum

[C#]

public StretchTableEnum Stretch {get;set;}

[Delphi]

public property Stretch: StretchTableEnum read get_Stretch write set_Stretch;


RenderTable.UserCellGroups Property

RenderTable.UserCellGroups Property

Gets the collection of groups of cells defined by the user.

[Visual Basic]

Public ReadOnly Property UserCellGroups As UserCellGroupCollection

[C#]

public UserCellGroupCollection UserCellGroups {get;}

[Delphi]

public property UserCellGroups: UserCellGroupCollection read get_UserCellGroups;


RenderTable.VertPageFooterOnLastPage Property

RenderTable.VertPageFooterOnLastPage Property

Gets or sets value indicating whether the vertical page footer should be printed on first page.

[Visual Basic]

Public Property VertPageFooterOnLastPage As Boolean

[C#]

public bool VertPageFooterOnLastPage {get;set;}

[Delphi]

public property VertPageFooterOnLastPage: Boolean read get_VertPageFooterOnLastPage write set_VertPageFooterOnLastPage;


RenderTable.VertPageHeaderOnFirstPage Property

RenderTable.VertPageHeaderOnFirstPage Property

Gets or sets value indicating whether the vertical page header should be printed on first page.

[Visual Basic]

Public Property VertPageHeaderOnFirstPage As Boolean

[C#]

public bool VertPageHeaderOnFirstPage {get;set;}

[Delphi]

public property VertPageHeaderOnFirstPage: Boolean read get_VertPageHeaderOnFirstPage write set_VertPageHeaderOnFirstPage;


RenderTable Methods

RenderTable Methods

The methods of the RenderTable class are listed here. For a complete list of RenderTable class members, see the RenderTable Members topic.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderTableFragment Class

RenderTableFragment Class

Represents the fragment of RenderTable object.

For a list of all members of this type, see RenderTableFragment Members.

System.Object

C1.C1Preview.RenderFragment

C1.C1Preview.RenderTableFragment

[Visual Basic]

Public Class RenderTableFragment

Inherits RenderFragment

[C#]

public class RenderTableFragment : RenderFragment

[Delphi]

type RenderTableFragment = class (RenderFragment);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderTableFragment Members

RenderTableFragment Members

RenderTableFragment overview

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.
ResolvingFinished (inherited from RenderFragment) | This method is called by the render engine after fully resolving of render fragment. Typically this method is used to clear temporary info used during resolving.


RenderTableFragment Properties

RenderTableFragment Properties

The properties of the RenderTableFragment class are listed here. For a complete list of RenderTableFragment class members, see the RenderTableFragment Members topic.

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.


RenderTableFragment Methods

RenderTableFragment Methods

The methods of the RenderTableFragment class are listed here. For a complete list of RenderTableFragment class members, see the RenderTableFragment Members topic.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.
ResolvingFinished (inherited from RenderFragment) | This method is called by the render engine after fully resolving of render fragment. Typically this method is used to clear temporary info used during resolving.


RenderText Class

RenderText Class

For a list of all members of this type, see RenderText Members.

System.Object

C1.C1Preview.RenderObject

C1.C1Preview.RenderTextBase

C1.C1Preview.RenderText

[Visual Basic]

Public Class RenderText

Inherits RenderTextBase

[C#]

public class RenderText : RenderTextBase

[Delphi]

type RenderText = class (RenderTextBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderText Members

RenderText Members

RenderText overview

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
HasTabPositions (inherited from RenderTextBase) | Gets the value indicating whether the TabPositions collection is not empty.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
TabPositions (inherited from RenderTextBase) | Collection of tabs in text.
Text | Text to render
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderText Properties

RenderText Properties

The properties of the RenderText class are listed here. For a complete list of RenderText class members, see the RenderText Members topic.

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
HasTabPositions (inherited from RenderTextBase) | Gets the value indicating whether the TabPositions collection is not empty.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
TabPositions (inherited from RenderTextBase) | Collection of tabs in text.
Text | Text to render
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.


RenderText.Text Property

RenderText.Text Property

Text to render

[Visual Basic]

Public Property Text As String

[C#]

public string Text {get;set;}

[Delphi]

public property Text: String read get_Text write set_Text;


RenderText Methods

RenderText Methods

The methods of the RenderText class are listed here. For a complete list of RenderText class members, see the RenderText Members topic.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderTextBase Class

RenderTextBase Class

Base class for RenderText and RenderParagraph

For a list of all members of this type, see RenderTextBase Members.

System.Object

C1.C1Preview.RenderObject

C1.C1Preview.RenderTextBase

C1.C1Preview.RenderParagraph

C1.C1Preview.RenderText

[Visual Basic]

MustInherit Public Class RenderTextBase

Inherits RenderObject

[C#]

public abstract class RenderTextBase : RenderObject

[Delphi]

type RenderTextBase = class abstract (RenderObject);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderTextBase Members

RenderTextBase Members

RenderTextBase overview

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
HasTabPositions | Gets the value indicating whether the TabPositions collection is not empty.
HasText | Returns True if object has a text.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
TabPositions | Collection of tabs in text.
TextLength | Returns the length of text. Do not use this property to check exists text or not, use HasText instead.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderTextBase Properties

RenderTextBase Properties

The properties of the RenderTextBase class are listed here. For a complete list of RenderTextBase class members, see the RenderTextBase Members topic.

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
HasTabPositions | Gets the value indicating whether the TabPositions collection is not empty.
HasText | Returns True if object has a text.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
TabPositions | Collection of tabs in text.
TextLength | Returns the length of text. Do not use this property to check exists text or not, use HasText instead.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.


RenderTextBase.HasTabPositions Property

RenderTextBase.HasTabPositions Property

Gets the value indicating whether the TabPositions collection is not empty.

[Visual Basic]

Public ReadOnly Property HasTabPositions As Boolean

[C#]

public bool HasTabPositions {get;}

[Delphi]

public property HasTabPositions: Boolean read get_HasTabPositions;


RenderTextBase.HasText Property

RenderTextBase.HasText Property

Returns True if object has a text.

[Visual Basic]

Overridable MustInherit Public ReadOnly Property HasText As Boolean

[C#]

virtual abstract public bool HasText {get;}

[Delphi]

public property HasText: Boolean read get_HasText;


RenderTextBase.TabPositions Property

RenderTextBase.TabPositions Property

Collection of tabs in text.

[Visual Basic]

Public ReadOnly Property TabPositions As TabPositionCollection

[C#]

public TabPositionCollection TabPositions {get;}

[Delphi]

public property TabPositions: TabPositionCollection read get_TabPositions;


RenderTextBase.TextLength Property

RenderTextBase.TextLength Property

Returns the length of text. Do not use this property to check exists text or not, use HasText instead.

[Visual Basic]

Overridable MustInherit Public ReadOnly Property TextLength As Int32*

[C#]

virtual abstract public Int32* TextLength {get;}

[Delphi]

public property TextLength: Int32* read get_TextLength;


RenderTextBase Methods

RenderTextBase Methods

The methods of the RenderTextBase class are listed here. For a complete list of RenderTextBase class members, see the RenderTextBase Members topic.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderTextFragment Class

RenderTextFragment Class

For a list of all members of this type, see RenderTextFragment Members.

System.Object

C1.C1Preview.RenderFragment

C1.C1Preview.RenderTextFragmentBase

C1.C1Preview.RenderTextFragment

[Visual Basic]

Public Class RenderTextFragment

Inherits RenderTextFragmentBase

[C#]

public class RenderTextFragment : RenderTextFragmentBase

[Delphi]

type RenderTextFragment = class (RenderTextFragmentBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderTextFragment Members

RenderTextFragment Members

RenderTextFragment overview

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.


RenderTextFragment Properties

RenderTextFragment Properties

The properties of the RenderTextFragment class are listed here. For a complete list of RenderTextFragment class members, see the RenderTextFragment Members topic.

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.


RenderTextFragment Methods

RenderTextFragment Methods

The methods of the RenderTextFragment class are listed here. For a complete list of RenderTextFragment class members, see the RenderTextFragment Members topic.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.


RenderTextFragmentBase Class

RenderTextFragmentBase Class

Base class for RenderTextFragment and RenderParagraphFragment.

For a list of all members of this type, see RenderTextFragmentBase Members.

System.Object

C1.C1Preview.RenderFragment

C1.C1Preview.RenderTextFragmentBase

C1.C1Preview.RenderParagraphFragment

C1.C1Preview.RenderTextFragment

[Visual Basic]

MustInherit Public Class RenderTextFragmentBase

Inherits RenderFragment

[C#]

public abstract class RenderTextFragmentBase : RenderFragment

[Delphi]

type RenderTextFragmentBase = class abstract (RenderFragment);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderTextFragmentBase Members

RenderTextFragmentBase Members

RenderTextFragmentBase overview

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.
GetCharPoints | Gets the array of PointD which define the parallelogram of char's area.
GetCharRangeRects | Gets an array of rectanges of char range, this function returns an array in which each line corresponds to one array's element, like: +------------------+ | rect[0] | +----------------------| | rect[1] | | rect[2] | +----------------------+ | rect[3] | +---------------+
GetCharRangeRegion | Gets the region of char range. The region is relative to the top-left corner of inner area of fragment.
GetCharRect | Gets the area of char with specified index.


RenderTextFragmentBase Properties

RenderTextFragmentBase Properties

The properties of the RenderTextFragmentBase class are listed here. For a complete list of RenderTextFragmentBase class members, see the RenderTextFragmentBase Members topic.

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.


RenderTextFragmentBase Methods

RenderTextFragmentBase Methods

The methods of the RenderTextFragmentBase class are listed here. For a complete list of RenderTextFragmentBase class members, see the RenderTextFragmentBase Members topic.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.
GetCharPoints | Gets the array of PointD which define the parallelogram of char's area.
GetCharRangeRects | Gets an array of rectanges of char range, this function returns an array in which each line corresponds to one array's element, like: +------------------+ | rect[0] | +----------------------| | rect[1] | | rect[2] | +----------------------+ | rect[3] | +---------------+
GetCharRangeRegion | Gets the region of char range. The region is relative to the top-left corner of inner area of fragment.
GetCharRect | Gets the area of char with specified index.


RenderTextFragmentBase.GetCharPoints Method

RenderTextFragmentBase.GetCharPoints Method

Gets the array of PointD which define the parallelogram of char's area.

[Visual Basic]

Public Function GetCharPoints( _

ByVal charIndex As Int32* _

) As PointD()

[C#]

public PointD[] GetCharPoints(

Int32* charIndex

);

[Delphi]

public function GetCharPoints(

charIndex: Int32*

): array of PointD;

Parameters

charIndex

Index of first char of this text's fragment.

Return Value

Returns the array of four PointD structures.


RenderTextFragmentBase.GetCharRangeRects Method

RenderTextFragmentBase.GetCharRangeRects Method

Gets an array of rectanges of char range, this function returns an array in which each line corresponds to one array's element, like: +------------------+ | rect[0] | +----------------------| | rect[1] | | rect[2] | +----------------------+ | rect[3] | +---------------+

[Visual Basic]

Public Function GetCharRangeRects( _

ByVal startCharIndex As Int32*, _

ByVal length As Int32* _

) As RectangleD()

[C#]

public RectangleD[] GetCharRangeRects(

Int32* startCharIndex,

Int32* length

);

[Delphi]

public function GetCharRangeRects(

startCharIndex: Int32*;

length: Int32*

): array of RectangleD;

Parameters

startCharIndex

Index of first character of this text's fragment.

length

Count of characters.

Return Value

The array of Rectangle structures.


RenderTextFragmentBase.GetCharRangeRegion Method

RenderTextFragmentBase.GetCharRangeRegion Method

Gets the region of char range. The region is relative to the top-left corner of inner area of fragment.

[Visual Basic]

Public Function GetCharRangeRegion( _

ByVal startCharIndex As Int32*, _

ByVal length As Int32* _

) As Region

[C#]

public Region GetCharRangeRegion(

Int32* startCharIndex,

Int32* length

);

[Delphi]

public function GetCharRangeRegion(

startCharIndex: Int32*;

length: Int32*

): Region;

Parameters

startCharIndex

Index of first character of this text's fragment.

length

Count of characters.

Return Value

The Region object defining the region of char range or null if char range is invalid.


RenderTextFragmentBase.GetCharRect Method

RenderTextFragmentBase.GetCharRect Method

Gets the area of char with specified index.

[Visual Basic]

Public Function GetCharRect( _

ByVal charIndex As Int32* _

) As RectangleD

[C#]

public RectangleD GetCharRect(

Int32* charIndex

);

[Delphi]

public function GetCharRect(

charIndex: Int32*

): RectangleD;

Parameters

charIndex

Index of first char of this text's fragment.

Return Value

Returns the RectangleD structure describing the bounds of char relative to the content area of object (without spacing, borders, padding), may be RectangleD.Empty text is rotated use the GetCharPoints method in this case.


RenderToc Class

RenderToc Class

For a list of all members of this type, see RenderToc Members.

System.Object

C1.C1Preview.RenderObject

C1.C1Preview.RenderArea

C1.C1Preview.RenderToc

[Visual Basic]

Public Class RenderToc

Inherits RenderArea

[C#]

public class RenderToc : RenderArea

[Delphi]

type RenderToc = class (RenderArea);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderToc Members

RenderToc Members

RenderToc overview

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FillChar | Gets or sets the char used to fill the empty space between title and page number.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
PageNumbersAtRight | Gets or sets value indicating whether the page numbers should be aligned to right edge of TOC.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
ShowPageNumbers | Gets or sets value indicating whether the page numbers should be display in TOC.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderToc Properties

RenderToc Properties

The properties of the RenderToc class are listed here. For a complete list of RenderToc class members, see the RenderToc Members topic.

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FillChar | Gets or sets the char used to fill the empty space between title and page number.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
PageNumbersAtRight | Gets or sets value indicating whether the page numbers should be aligned to right edge of TOC.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
ShowPageNumbers | Gets or sets value indicating whether the page numbers should be display in TOC.
Style (inherited from RenderObject) | Style of this object.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.


RenderToc.FillChar Property

RenderToc.FillChar Property

Gets or sets the char used to fill the empty space between title and page number.

[Visual Basic]

Public Property FillChar As Char*

[C#]

public Char* FillChar {get;set;}

[Delphi]

public property FillChar: Char* read get_FillChar write set_FillChar;


RenderToc.PageNumbersAtRight Property

RenderToc.PageNumbersAtRight Property

Gets or sets value indicating whether the page numbers should be aligned to right edge of TOC.

[Visual Basic]

Public Property PageNumbersAtRight As Boolean

[C#]

public bool PageNumbersAtRight {get;set;}

[Delphi]

public property PageNumbersAtRight: Boolean read get_PageNumbersAtRight write set_PageNumbersAtRight;


RenderToc.ShowPageNumbers Property

RenderToc.ShowPageNumbers Property

Gets or sets value indicating whether the page numbers should be display in TOC.

[Visual Basic]

Public Property ShowPageNumbers As Boolean

[C#]

public bool ShowPageNumbers {get;set;}

[Delphi]

public property ShowPageNumbers: Boolean read get_ShowPageNumbers write set_ShowPageNumbers;


RenderToc Methods

RenderToc Methods

The methods of the RenderToc class are listed here. For a complete list of RenderToc class members, see the RenderToc Members topic.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderTocItem Class

RenderTocItem Class

Represents the item of table of content.

For a list of all members of this type, see RenderTocItem Members.

System.Object

C1.C1Preview.RenderObject

C1.C1Preview.RenderTextBase

C1.C1Preview.RenderParagraph

C1.C1Preview.RenderTocItem

[Visual Basic]

Public Class RenderTocItem

Inherits RenderParagraph

[C#]

public class RenderTocItem : RenderParagraph

[Delphi]

type RenderTocItem = class (RenderParagraph);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderTocItem Members

RenderTocItem Members

RenderTocItem overview

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Content (inherited from RenderParagraph) | Gets the ParagraphObjectCollection representing the content of this RenderParagraph object,
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasContent (inherited from RenderParagraph) | Gets the value indicating whether the current RenderParagraph object has any content.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
HasTabPositions (inherited from RenderTextBase) | Gets the value indicating whether the TabPositions collection is not empty.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Level | Gets or sets the level of item in the TOC. Level defines the indent of item from the left edge of object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
TabPositions (inherited from RenderTextBase) | Collection of tabs in text.
TextLength | Overriden. Gets the length of text in paragraph each non text object has one char length.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderTocItem Properties

RenderTocItem Properties

The properties of the RenderTocItem class are listed here. For a complete list of RenderTocItem class members, see the RenderTocItem Members topic.

Public Properties

Anchors (inherited from RenderObject) | Gets the collection of anchors within this render object.
BreakAfter (inherited from RenderObject) | Gets or sets the type of break after this object.
BreakBefore (inherited from RenderObject) | Gets or sets the type of break before this object.
CanSplitHorz (inherited from RenderObject) | Indicates whether the object can be split horizontally if it falls on a page break.
CanSplitVert (inherited from RenderObject) | Indicates whether the object can be split vertically if it falls on a page break.
Children (inherited from RenderObject) | Returns collection of child objects.
Collection (inherited from RenderObject) | Gets the RenderObjectCollection object containing this object, returns null if object has no Owner or its Owner is not RenderObjectCollection.
Content (inherited from RenderParagraph) | Gets the ParagraphObjectCollection representing the content of this RenderParagraph object,
Document (inherited from RenderObject) | Gets the C1Preview object containing this object.
FirstFragment (inherited from RenderObject) | Gets the first object's fragment.
Fragments (inherited from RenderObject) | Returns the collection of the object's fragments.
HasChildren (inherited from RenderObject) | Returns True if object has child objects.
HasContent (inherited from RenderParagraph) | Gets the value indicating whether the current RenderParagraph object has any content.
HasFragments (inherited from RenderObject) | Gets or sets value indicating whether the object has the built fragments.
HasTabPositions (inherited from RenderTextBase) | Gets the value indicating whether the TabPositions collection is not empty.
Height (inherited from RenderObject) | Height of object.
Hyperlink (inherited from RenderObject) | Gets or sets the hyperlink associated with this render object.
IndexInOwner (inherited from RenderObject) | Gets the index in owner object, returns the -1 if no owner.
LastFragment (inherited from RenderObject) | Gets the last object's fragment.
LayoutChangeAfter (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout after object.
LayoutChangeBefore (inherited from RenderObject) | Gets or sets the LayoutChangeBase object defining the change of page layout before object.
Level | Gets or sets the level of item in the TOC. Level defines the indent of item from the left edge of object.
Name (inherited from RenderObject) | Unique name of object, can be string.Empty or *unique* within of _owner.
PageNumberingChange (inherited from RenderObject) | Gets or sets the PageNumberingChange object describing the change of page number.
Parent (inherited from RenderObject) | Gets the parent RenderObject object.
RepeatBordersHorz (inherited from RenderObject) | Indicates whether horizontal borders of object must be repeated when horizontal splitting.
RepeatBordersVert (inherited from RenderObject) | Indicates whether vertical borders of object must be repeated when vertical splitting.
Style (inherited from RenderObject) | Style of this object.
TabPositions (inherited from RenderTextBase) | Collection of tabs in text.
TextLength | Overriden. Gets the length of text in paragraph each non text object has one char length.
UserData (inherited from RenderObject) | Gets or sets some data associated with object by user.
Width (inherited from RenderObject) | Width of object.
X (inherited from RenderObject) | X coordinate of object.
Y (inherited from RenderObject) | Y coordinate of object.
ZOrder (inherited from RenderObject) | Gets or sets the Z-order of object, the object with smaller ZOrder will be displayed other the object with larger ZOrder. By default ZOrder of all objects is zero.


RenderTocItem.Level Property

RenderTocItem.Level Property

Gets or sets the level of item in the TOC. Level defines the indent of item from the left edge of object.

[Visual Basic]

Public Property Level As Int32*

[C#]

public Int32* Level {get;set;}

[Delphi]

public property Level: Int32* read get_Level write set_Level;


RenderTocItem.TextLength Property

RenderTocItem.TextLength Property

Gets the length of text in paragraph each non text object has one char length.

[Visual Basic]

Overrides Public ReadOnly Property TextLength As Int32*

[C#]

override public Int32* TextLength {get;}

[Delphi]

public property TextLength: Int32* read get_TextLength;


RenderTocItem Methods

RenderTocItem Methods

The methods of the RenderTocItem class are listed here. For a complete list of RenderTocItem class members, see the RenderTocItem Members topic.

Public Methods

GetNestedObjectCount (inherited from RenderObject) | Calculates the count of objects which are nested within this object. This method takes into account child objects and their children.
GetOwnedObjectCount (inherited from RenderObject) | Calculates the count of objects which are owned by this object. This method takes into account: - Child objects (and their children). - Objects which are specified in page layouts as PageHeader, PageFooter, and so on.


RenderTocItemFragment Class

RenderTocItemFragment Class

For a list of all members of this type, see RenderTocItemFragment Members.

System.Object

C1.C1Preview.RenderFragment

C1.C1Preview.RenderTextFragmentBase

C1.C1Preview.RenderParagraphFragment

C1.C1Preview.RenderTocItemFragment

[Visual Basic]

Public Class RenderTocItemFragment

Inherits RenderParagraphFragment

[C#]

public class RenderTocItemFragment : RenderParagraphFragment

[Delphi]

type RenderTocItemFragment = class (RenderParagraphFragment);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RenderTocItemFragment Members

RenderTocItemFragment Members

RenderTocItemFragment overview

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.


RenderTocItemFragment Properties

RenderTocItemFragment Properties

The properties of the RenderTocItemFragment class are listed here. For a complete list of RenderTocItemFragment class members, see the RenderTocItemFragment Members topic.

Public Properties

Bounds (inherited from RenderFragment) | Gets the rectangle of object within its parent, if fragment is a top-parent fragment then this bounds is the bounds within Page.
BoundsOnPage (inherited from RenderFragment) | Gets the bounds of object on page.
Children (inherited from RenderFragment) | Gets a collection of child objects.
Document (inherited from RenderFragment) | Gets C1PrintDocument object containing this object.
HasChildren (inherited from RenderFragment) | Returns True if fragment has child fragments.
IndexInParent (inherited from RenderFragment) | Gets index of fragment in its parent.
IndexInRenderObject (inherited from RenderFragment) | Gets index of fragment in its own RenderObject object.
InnerBounds (inherited from RenderFragment) | Gets the rectangle of content area of object, without spacing, border, padding.
InnerBoundsOnPage (inherited from RenderFragment) | Gets the bounds of inner area of object on page.
Level (inherited from RenderFragment) | Gets the level of RenderFragment in its parent, the top most fragment (which has no parent) has a 1 level.
PageArea (inherited from RenderFragment) | Gets the PageAreaBase object.
Parent (inherited from RenderFragment) | Gets the parent RenderFragment object.
TopParent (inherited from RenderFragment) | Gets the top-parent RenderFragment object.
Visible (inherited from RenderFragment) | Indicates whether the fragment is visible.


RenderTocItemFragment Methods

RenderTocItemFragment Methods

The methods of the RenderTocItemFragment class are listed here. For a complete list of RenderTocItemFragment class members, see the RenderTocItemFragment Members topic.

Public Methods

Clone (inherited from RenderFragment) | Creates and returns a copy of render fragment.
DetachFromRenderObject (inherited from RenderFragment) | Detach this RenderFragment object from its RenderObject object, also all child fragments will be detached.


ReresolvingModeEnum Enumeration

ReresolvingModeEnum Enumeration

Enumerates the situations when reresolving can occurs.

[Visual Basic]

Public Enum ReresolvingModeEnum

[C#]

public enum ReresolvingModeEnum

[Delphi]

type ReresolvingModeEnum = (SplitHorz, SplitVert);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
SplitHorz | Reresolving occurs on horizontal split.
SplitVert | Reresolving occurs on vertical split.

See Also

C1.C1Preview Namespace


RoundRectangleProps Class

RoundRectangleProps Class

Represents properties of the RenderRoundRectanlge object.

For a list of all members of this type, see RoundRectangleProps Members.

System.Object

C1.C1Preview.ShapeProps

C1.C1Preview.RectangleProps

C1.C1Preview.RoundRectangleProps

[Visual Basic]

Public Class RoundRectangleProps

Inherits RectangleProps

[C#]

public class RoundRectangleProps : RectangleProps

[Delphi]

type RoundRectangleProps = class (RectangleProps);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RoundRectangleProps Members

RoundRectangleProps Members

RoundRectangleProps overview


ScalableButton Class

ScalableButton Class

Raises an event when the user clicks it.

For a list of all members of this type, see ScalableButton Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Windows.Forms.Control

System.Windows.Forms.ButtonBase

System.Windows.Forms.Button

C1.C1Preview.ScalableButton

[Visual Basic]

Public Class ScalableButton

Inherits Button

[C#]

public class ScalableButton : Button

[Delphi]

type ScalableButton = class (Button);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ScalableButton Members

ScalableButton Members

ScalableButton overview


ScalableCheckBox Class

ScalableCheckBox Class

Represents the "scalable" checkbox control.

For a list of all members of this type, see ScalableCheckBox Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Windows.Forms.Control

System.Windows.Forms.ButtonBase

System.Windows.Forms.CheckBox

C1.C1Preview.ScalableCheckBox

[Visual Basic]

Public Class ScalableCheckBox

Inherits CheckBox

[C#]

public class ScalableCheckBox : CheckBox

[Delphi]

type ScalableCheckBox = class (CheckBox);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ScalableCheckBox Members

ScalableCheckBox Members

ScalableCheckBox overview


ScalableComboBox Class

ScalableComboBox Class

Represents the "scalable" combobox control.

For a list of all members of this type, see ScalableComboBox Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Windows.Forms.Control

C1.C1Preview.ScalableComboBox

[Visual Basic]

Public Class ScalableComboBox

Inherits Control

[C#]

public class ScalableComboBox : Control

[Delphi]

type ScalableComboBox = class (Control);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ScalableComboBox Members

ScalableComboBox Members

ScalableComboBox overview

Public Properties

SelectedIndexText

Gets the text of selected item, if no item selected returns an empty string.


ScalableComboBox Properties

ScalableComboBox Properties

The properties of the ScalableComboBox class are listed here. For a complete list of ScalableComboBox class members, see the ScalableComboBox Members topic.

Public Properties

SelectedIndexText

Gets the text of selected item, if no item selected returns an empty string.


ScalableComboBox.SelectedIndexText Property

ScalableComboBox.SelectedIndexText Property

Gets the text of selected item, if no item selected returns an empty string.

[Visual Basic]

Public ReadOnly Property SelectedIndexText As String

[C#]

public string SelectedIndexText {get;}

[Delphi]

public property SelectedIndexText: String read get_SelectedIndexText;


ScalableRadioButton Class

ScalableRadioButton Class

Represents the "scalable" radio button control.

For a list of all members of this type, see ScalableRadioButton Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Windows.Forms.Control

System.Windows.Forms.ButtonBase

System.Windows.Forms.RadioButton

C1.C1Preview.ScalableRadioButton

[Visual Basic]

Public Class ScalableRadioButton

Inherits RadioButton

[C#]

public class ScalableRadioButton : RadioButton

[Delphi]

type ScalableRadioButton = class (RadioButton);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ScalableRadioButton Members

ScalableRadioButton Members

ScalableRadioButton overview

Public Properties

AutoCheck

Hides the base AutoCheck property.


ScalableRadioButton Properties

ScalableRadioButton Properties

The properties of the ScalableRadioButton class are listed here. For a complete list of ScalableRadioButton class members, see the ScalableRadioButton Members topic.

Public Properties

AutoCheck

Hides the base AutoCheck property.


ScalableRadioButton.AutoCheck Property

ScalableRadioButton.AutoCheck Property

Hides the base AutoCheck property.

[Visual Basic]

Public Property AutoCheck As Boolean

[C#]

new public bool AutoCheck {get;set;}

[Delphi]

public property AutoCheck: Boolean read get_AutoCheck write set_AutoCheck;


ScalableTextBox Class

ScalableTextBox Class

Enables the user to enter text, and provides multiline editing and password character masking.

For a list of all members of this type, see ScalableTextBox Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Windows.Forms.Control

System.Windows.Forms.TextBoxBase

System.Windows.Forms.TextBox

C1.C1Preview.ScalableTextBox

[Visual Basic]

Public Class ScalableTextBox

Inherits TextBox

[C#]

public class ScalableTextBox : TextBox

[Delphi]

type ScalableTextBox = class (TextBox);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ScalableTextBox Members

ScalableTextBox Members

ScalableTextBox overview


ShapeProps Class

ShapeProps Class

Describes the geometric properties of the shape, this is a base class.

For a list of all members of this type, see ShapeProps Members.

System.Object

C1.C1Preview.ShapeProps

C1.C1Preview.LinePropsBase

C1.C1Preview.RectangleProps

[Visual Basic]

MustInherit Public Class ShapeProps

[C#]

public abstract class ShapeProps

[Delphi]

type ShapeProps = class abstract;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ShapeProps Members

ShapeProps Members

ShapeProps overview


ShapeResolvedInfo Class

ShapeResolvedInfo Class

For a list of all members of this type, see ShapeResolvedInfo Members.

System.Object

C1.C1Preview.FragmentResolvedInfo

C1.C1Preview.ShapeResolvedInfo

[Visual Basic]

Public Class ShapeResolvedInfo

Inherits FragmentResolvedInfo

[C#]

public class ShapeResolvedInfo : FragmentResolvedInfo

[Delphi]

type ShapeResolvedInfo = class (FragmentResolvedInfo);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ShapeResolvedInfo Members

ShapeResolvedInfo Members

ShapeResolvedInfo overview

Public Properties

AvailHeight (inherited from FragmentResolvedInfo) | Returns the distance between Top and LeftTopPageArea.Bottom.
AvailWidth (inherited from FragmentResolvedInfo) | Returns the distance between Left and LeftTopPageArea.Right.
BottomOffset (inherited from FragmentResolvedInfo) | Returns a sum of Padding.Bottom, Spacing.Bottom, Borders.Bottom
IsAutoLeft (inherited from FragmentResolvedInfo) | Indicates that the Left coordinate of object was calculated as auto.
IsAutoPos (inherited from FragmentResolvedInfo) | Indicates that the Left-top position of object was calculated as auto.
IsAutoTop (inherited from FragmentResolvedInfo) | Indicates that the Top coordinate of object was calculated as auto.
LeftOffset (inherited from FragmentResolvedInfo) | Returns a sum of Padding.Left, Spacing.Left, Borders.Left
RightOffset (inherited from FragmentResolvedInfo) | Returns a sum of Padding.Right, Spacing.Right, Borders.Right
TopOffset (inherited from FragmentResolvedInfo) | Returns a sum of Padding.Top, Spacing.Top, Borders.Top


ShapeResolvedInfo Properties

ShapeResolvedInfo Properties

The properties of the ShapeResolvedInfo class are listed here. For a complete list of ShapeResolvedInfo class members, see the ShapeResolvedInfo Members topic.

Public Properties

AvailHeight (inherited from FragmentResolvedInfo) | Returns the distance between Top and LeftTopPageArea.Bottom.
AvailWidth (inherited from FragmentResolvedInfo) | Returns the distance between Left and LeftTopPageArea.Right.
BottomOffset (inherited from FragmentResolvedInfo) | Returns a sum of Padding.Bottom, Spacing.Bottom, Borders.Bottom
IsAutoLeft (inherited from FragmentResolvedInfo) | Indicates that the Left coordinate of object was calculated as auto.
IsAutoPos (inherited from FragmentResolvedInfo) | Indicates that the Left-top position of object was calculated as auto.
IsAutoTop (inherited from FragmentResolvedInfo) | Indicates that the Top coordinate of object was calculated as auto.
LeftOffset (inherited from FragmentResolvedInfo) | Returns a sum of Padding.Left, Spacing.Left, Borders.Left
RightOffset (inherited from FragmentResolvedInfo) | Returns a sum of Padding.Right, Spacing.Right, Borders.Right
TopOffset (inherited from FragmentResolvedInfo) | Returns a sum of Padding.Top, Spacing.Top, Borders.Top


SizeD Structure

SizeD Structure

Stores an ordered pair of double numbers, typically the width and height of a rectangle.

For a list of all members of this type, see SizeD Members.

System.Object

System.ValueType

C1.C1Preview.SizeD

[Visual Basic]

Public Structure SizeD

[C#]

public struct SizeD

[Delphi]

type SizeD = record;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


SizeD Members

SizeD Members

SizeD overview

Public Properties

Height | Gets or sets the vertical component of this SizeD.
IsEmpty | Gets a value indicating whether this SizeD has zero width and height.
Width | Gets or sets the horizontal component of this SizeD.

Public Methods

Ceiling | Converts this SizeD object to a Point object by rounding the values of the SizeD object to the next higher integer values.
ToString | Overriden. Overridden. Creates a human-readable string that represents this SizeD.
Truncate | Converts this SizeD object to a Size object by truncating the values of the Size object.


SizeD Properties

SizeD Properties

The properties of the SizeD structure are listed here. For a complete list of SizeD structure members, see the SizeD Members topic.

Public Properties

Height | Gets or sets the vertical component of this SizeD.
IsEmpty | Gets a value indicating whether this SizeD has zero width and height.
Width | Gets or sets the horizontal component of this SizeD.


SizeD.Height Property

SizeD.Height Property

Gets or sets the vertical component of this SizeD.

[Visual Basic]

Public Property Height As Double

[C#]

public double Height {get;set;}

[Delphi]

public property Height: Double read get_Height write set_Height;


SizeD.IsEmpty Property

SizeD.IsEmpty Property

Gets a value indicating whether this SizeD has zero width and height.

[Visual Basic]

Public ReadOnly Property IsEmpty As Boolean

[C#]

public bool IsEmpty {get;}

[Delphi]

public property IsEmpty: Boolean read get_IsEmpty;


SizeD.Width Property

SizeD.Width Property

Gets or sets the horizontal component of this SizeD.

[Visual Basic]

Public Property Width As Double

[C#]

public double Width {get;set;}

[Delphi]

public property Width: Double read get_Width write set_Width;


SizeD Methods

SizeD Methods

The methods of the SizeD structure are listed here. For a complete list of SizeD structure members, see the SizeD Members topic.

Public Methods

Ceiling | Converts this SizeD object to a Point object by rounding the values of the SizeD object to the next higher integer values.
ToString | Overriden. Overridden. Creates a human-readable string that represents this SizeD.
Truncate | Converts this SizeD object to a Size object by truncating the values of the Size object.


SizeD.Ceiling Method

SizeD.Ceiling Method

Converts this SizeD object to a Point object by rounding the values of the SizeD object to the next higher integer values.

[Visual Basic]

Public Function Ceiling() As Size

[C#]

public Size Ceiling()

[Delphi]

public function Ceiling(): Size;

Return Value

The Size object this method converts to.


SizeD.ToString Method

SizeD.ToString Method

Overridden. Creates a human-readable string that represents this SizeD.

[Visual Basic]

Overrides Public Function ToString() As String

[C#]

override public string ToString()

[Delphi]

public function ToString(): String; override;

Return Value

A string that represents this SizeD.


SizeD.Truncate Method

SizeD.Truncate Method

Converts this SizeD object to a Size object by truncating the values of the Size object.

[Visual Basic]

Public Function Truncate() As Size

[C#]

public Size Truncate()

[Delphi]

public function Truncate(): Size;

Return Value

The Size object this method converts to.


Split Class

Split Class

Represents the split within RenderObject.

For a list of all members of this type, see Split Members.

System.Object

C1.C1Preview.Split

[Visual Basic]

Public Class Split

[C#]

public class Split

[Delphi]

type Split = class;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


Split Members

Split Members

Split overview

Public Properties

Cause | Gets the RenderFragment object producing this split, typically this is a child fragment that has a LayoutChangeBefore or LayoutChangeAfter.
LayoutChange | Gets the LayoutChange object defining a change of page layout on split.
Owner | Gets the RenderFragment object in which split occurs, typically this is a parent of Cause.
Position | Gets the position of split relative to top/left edge of Parent of Owner object.
PositionInTopParent | Gets the position of split relative to top/left edge of top-parent fragment. This property equals Position if _fragment is a top-parent fragment.


Split Properties

Split Properties

The properties of the Split class are listed here. For a complete list of Split class members, see the Split Members topic.

Public Properties

Cause | Gets the RenderFragment object producing this split, typically this is a child fragment that has a LayoutChangeBefore or LayoutChangeAfter.
LayoutChange | Gets the LayoutChange object defining a change of page layout on split.
Owner | Gets the RenderFragment object in which split occurs, typically this is a parent of Cause.
Position | Gets the position of split relative to top/left edge of Parent of Owner object.
PositionInTopParent | Gets the position of split relative to top/left edge of top-parent fragment. This property equals Position if _fragment is a top-parent fragment.


Split.Cause Property

Split.Cause Property

Gets the RenderFragment object producing this split, typically this is a child fragment that has a LayoutChangeBefore or LayoutChangeAfter.

[Visual Basic]

Public ReadOnly Property Cause As RenderFragment

[C#]

public RenderFragment Cause {get;}

[Delphi]

public property Cause: RenderFragment read get_Cause;


Split.LayoutChange Property

Split.LayoutChange Property

Gets the LayoutChange object defining a change of page layout on split.

[Visual Basic]

Public ReadOnly Property LayoutChange As LayoutChangeBase

[C#]

public LayoutChangeBase LayoutChange {get;}

[Delphi]

public property LayoutChange: LayoutChangeBase read get_LayoutChange;


Split.Owner Property

Split.Owner Property

Gets the RenderFragment object in which split occurs, typically this is a parent of Cause.

[Visual Basic]

Public ReadOnly Property Owner As RenderFragment

[C#]

public RenderFragment Owner {get;}

[Delphi]

public property Owner: RenderFragment read get_Owner;


Split.Position Property

Split.Position Property

Gets the position of split relative to top/left edge of Parent of Owner object.

[Visual Basic]

Public ReadOnly Property Position As Double

[C#]

public double Position {get;}

[Delphi]

public property Position: Double read get_Position;


Split.PositionInTopParent Property

Split.PositionInTopParent Property

Gets the position of split relative to top/left edge of top-parent fragment. This property equals Position if _fragment is a top-parent fragment.

[Visual Basic]

Public ReadOnly Property PositionInTopParent As Double

[C#]

public double PositionInTopParent {get;}

[Delphi]

public property PositionInTopParent: Double read get_PositionInTopParent;


SplitCollection Class

SplitCollection Class

Represents the collection of Split objects.

For a list of all members of this type, see SplitCollection Members.

System.Object

System.Collections.CollectionBase

C1.C1Preview.SplitCollection

[Visual Basic]

Public Class SplitCollection

Inherits CollectionBase

[C#]

public class SplitCollection : CollectionBase

[Delphi]

type SplitCollection = class (CollectionBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


SplitCollection Members

SplitCollection Members

SplitCollection overview

Public Methods

Add

Adds the Split object into collection.


SplitCollection Methods

SplitCollection Methods

The methods of the SplitCollection class are listed here. For a complete list of SplitCollection class members, see the SplitCollection Members topic.

Public Methods

Add

Adds the Split object into collection.


SplitCollection.Add Method

SplitCollection.Add Method

Adds the Split object into collection.

[Visual Basic]

Public Function Add( _

ByVal split As Split _

) As Int32*

[C#]

public Int32* Add(

Split split

);

[Delphi]

public function Add(

split: Split

): Int32*;

Return Value

Index of added object in the collection.


SplitParams Class

SplitParams Class

The base class for split parameters that is used when object should be split.

For a list of all members of this type, see SplitParams Members.

System.Object

C1.C1Preview.SplitParams

C1.C1Preview.TableSplitParams

[Visual Basic]

Public Class SplitParams

[C#]

public class SplitParams

[Delphi]

type SplitParams = class;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


SplitParams Members

SplitParams Members

SplitParams overview

Public Fields

BorderMax | IN: Right / Bottom border.
BorderMin | IN: Left / Top border.
ChildrenAlwaysCanSplit | IN: ChildrenAlwaysCanSplitVert or ChildrenAlwaysCanSplitHorz, depends on type of splitting: vertical / horizontal.
ChildrenSplitParams | OUT (FindSplitPos): The collection of SplitParams objects from children.
ChildrenSplitPosOffset | OUT (FindSplitPos): Offset of children' splitting position from ContentSplitPos.
ContentRealSplitPos | OUT (FindSplitPos): The real split position within content area, calculated in the FindVertSplitPosContent / FindHorzSplitPosContent. ContentRealSplitPos = RealSplitPos - ContentSplitOffset. Also see comments to ReprintedFooterSize.
ContentSplitOffset | OUT (FindSplitPos): Offsets for split position within content area, the content area is split at position: RealSplitPos - ContentSplitOffset. ContentSplitOffset calculated on the base of padding / spacing / borders / RepeatBorders.
NeedReresolving | OUT (Split): Indicates that after splitting the fragment which was split must be reresolved. This field filled after RenderFragment.Split method.
NewFragmentSize | OUT (FindSplitPos): The size of new fragment, which is created at the split.
NonSplitDimensionContentSize | IN: The content size of non split dimension, on vertical split: Width - Inner.Left - Inner.Right on horizontal split: Height - Inner.Top - Inner.Bottom
PaddingMax | IN: Right / Bottom padding.
PaddingMin | IN: Left / Top padding.
RepeatBorders | IN: RepeatBordersVert or RepeatBordersHorz.
ReprintFooterSize | OUT (FindSplitPos): The size of reprinted footer at the bottom of object, filled in the FindXXXContent method, after calling this method the ContentRealSplitPos does not include this size, and real RealSplitPos is: ContentRealSplitPos + ContentSplitOffset + ReprintFooterSize.
ReprintHeaderSize | OUT (FindSplitPos): The size of reprinted header at the top of object which was split.
SpacingMax | IN: Right / Bottom spacing.
SpacingMin | IN: Left / Top spacing.
SplitDimensionSize | IN: Size of split dimension, on vertical split - height, on horizontal - width.
SplitPos | IN: Specifies the requested split position.
SplitVert | IN: Indicates the type of split: vertical / horizontal.

Public Properties

ExistSplittedChildren

Indicates that the object has the splitted child objects.

Public Methods

AssignFrom | Copies all properties from another SplitParams object, the ChildrenSplitParams property is copied by reference.
Clone | Creates and returns a copy of this object, the ChildrenSplitParams property is copied by reference.


SplitParams Fields

SplitParams Fields

The fields of the SplitParams class are listed here. For a complete list of SplitParams class members, see the SplitParams Members topic.

Public Fields

BorderMax | IN: Right / Bottom border.
BorderMin | IN: Left / Top border.
ChildrenAlwaysCanSplit | IN: ChildrenAlwaysCanSplitVert or ChildrenAlwaysCanSplitHorz, depends on type of splitting: vertical / horizontal.
ChildrenSplitParams | OUT (FindSplitPos): The collection of SplitParams objects from children.
ChildrenSplitPosOffset | OUT (FindSplitPos): Offset of children' splitting position from ContentSplitPos.
ContentRealSplitPos | OUT (FindSplitPos): The real split position within content area, calculated in the FindVertSplitPosContent / FindHorzSplitPosContent. ContentRealSplitPos = RealSplitPos - ContentSplitOffset. Also see comments to ReprintedFooterSize.
ContentSplitOffset | OUT (FindSplitPos): Offsets for split position within content area, the content area is split at position: RealSplitPos - ContentSplitOffset. ContentSplitOffset calculated on the base of padding / spacing / borders / RepeatBorders.
NeedReresolving | OUT (Split): Indicates that after splitting the fragment which was split must be reresolved. This field filled after RenderFragment.Split method.
NewFragmentSize | OUT (FindSplitPos): The size of new fragment, which is created at the split.
NonSplitDimensionContentSize | IN: The content size of non split dimension, on vertical split: Width - Inner.Left - Inner.Right on horizontal split: Height - Inner.Top - Inner.Bottom
PaddingMax | IN: Right / Bottom padding.
PaddingMin | IN: Left / Top padding.
RepeatBorders | IN: RepeatBordersVert or RepeatBordersHorz.
ReprintFooterSize | OUT (FindSplitPos): The size of reprinted footer at the bottom of object, filled in the FindXXXContent method, after calling this method the ContentRealSplitPos does not include this size, and real RealSplitPos is: ContentRealSplitPos + ContentSplitOffset + ReprintFooterSize.
ReprintHeaderSize | OUT (FindSplitPos): The size of reprinted header at the top of object which was split.
SpacingMax | IN: Right / Bottom spacing.
SpacingMin | IN: Left / Top spacing.
SplitDimensionSize | IN: Size of split dimension, on vertical split - height, on horizontal - width.
SplitPos | IN: Specifies the requested split position.
SplitVert | IN: Indicates the type of split: vertical / horizontal.


SplitParams.BorderMax Field

SplitParams.BorderMax Field

IN: Right / Bottom border.

[Visual Basic]

Public BorderMax As Double

[C#]

public double BorderMax

[Delphi]

public BorderMax: Double;


SplitParams.BorderMin Field

SplitParams.BorderMin Field

IN: Left / Top border.

[Visual Basic]

Public BorderMin As Double

[C#]

public double BorderMin

[Delphi]

public BorderMin: Double;


SplitParams.ChildrenAlwaysCanSplit Field

SplitParams.ChildrenAlwaysCanSplit Field

IN: ChildrenAlwaysCanSplitVert or ChildrenAlwaysCanSplitHorz, depends on type of splitting: vertical / horizontal.

[Visual Basic]

Public ChildrenAlwaysCanSplit As Boolean

[C#]

public bool ChildrenAlwaysCanSplit

[Delphi]

public ChildrenAlwaysCanSplit: Boolean;


SplitParams.ChildrenSplitParams Field

SplitParams.ChildrenSplitParams Field

OUT (FindSplitPos): The collection of SplitParams objects from children.

[Visual Basic]

Public ChildrenSplitParams As Hashtable

[C#]

public Hashtable ChildrenSplitParams

[Delphi]

public ChildrenSplitParams: Hashtable;


SplitParams.ChildrenSplitPosOffset Field

SplitParams.ChildrenSplitPosOffset Field

OUT (FindSplitPos): Offset of children' splitting position from ContentSplitPos.

[Visual Basic]

Public ChildrenSplitPosOffset As Double

[C#]

public double ChildrenSplitPosOffset

[Delphi]

public ChildrenSplitPosOffset: Double;


SplitParams.ContentRealSplitPos Field

SplitParams.ContentRealSplitPos Field

OUT (FindSplitPos): The real split position within content area, calculated in the FindVertSplitPosContent / FindHorzSplitPosContent. ContentRealSplitPos = RealSplitPos - ContentSplitOffset. Also see comments to ReprintedFooterSize.

[Visual Basic]

Public ContentRealSplitPos As Double

[C#]

public double ContentRealSplitPos

[Delphi]

public ContentRealSplitPos: Double;


SplitParams.ContentSplitOffset Field

SplitParams.ContentSplitOffset Field

OUT (FindSplitPos): Offsets for split position within content area, the content area is split at position: RealSplitPos - ContentSplitOffset. ContentSplitOffset calculated on the base of padding / spacing / borders / RepeatBorders.

[Visual Basic]

Public ContentSplitOffset As Double

[C#]

public double ContentSplitOffset

[Delphi]

public ContentSplitOffset: Double;


SplitParams.NeedReresolving Field

SplitParams.NeedReresolving Field

OUT (Split): Indicates that after splitting the fragment which was split must be reresolved. This field filled after RenderFragment.Split method.

[Visual Basic]

Public NeedReresolving As Boolean

[C#]

public bool NeedReresolving

[Delphi]

public NeedReresolving: Boolean;


SplitParams.NewFragmentSize Field

SplitParams.NewFragmentSize Field

OUT (FindSplitPos): The size of new fragment, which is created at the split.

[Visual Basic]

Public NewFragmentSize As Double

[C#]

public double NewFragmentSize

[Delphi]

public NewFragmentSize: Double;


SplitParams.NonSplitDimensionContentSize Field

SplitParams.NonSplitDimensionContentSize Field

IN: The content size of non split dimension, on vertical split: Width - Inner.Left - Inner.Right on horizontal split: Height - Inner.Top - Inner.Bottom

[Visual Basic]

Public NonSplitDimensionContentSize As Double

[C#]

public double NonSplitDimensionContentSize

[Delphi]

public NonSplitDimensionContentSize: Double;


SplitParams.PaddingMax Field

SplitParams.PaddingMax Field

IN: Right / Bottom padding.

[Visual Basic]

Public PaddingMax As Double

[C#]

public double PaddingMax

[Delphi]

public PaddingMax: Double;


SplitParams.PaddingMin Field

SplitParams.PaddingMin Field

IN: Left / Top padding.

[Visual Basic]

Public PaddingMin As Double

[C#]

public double PaddingMin

[Delphi]

public PaddingMin: Double;


SplitParams.RepeatBorders Field

SplitParams.RepeatBorders Field

IN: RepeatBordersVert or RepeatBordersHorz.

[Visual Basic]

Public RepeatBorders As Boolean

[C#]

public bool RepeatBorders

[Delphi]

public RepeatBorders: Boolean;


SplitParams.ReprintFooterSize Field

SplitParams.ReprintFooterSize Field

OUT (FindSplitPos): The size of reprinted footer at the bottom of object, filled in the FindXXXContent method, after calling this method the ContentRealSplitPos does not include this size, and real RealSplitPos is: ContentRealSplitPos + ContentSplitOffset + ReprintFooterSize.

[Visual Basic]

Public ReprintFooterSize As Double

[C#]

public double ReprintFooterSize

[Delphi]

public ReprintFooterSize: Double;


SplitParams.ReprintHeaderSize Field

SplitParams.ReprintHeaderSize Field

OUT (FindSplitPos): The size of reprinted header at the top of object which was split.

[Visual Basic]

Public ReprintHeaderSize As Double

[C#]

public double ReprintHeaderSize

[Delphi]

public ReprintHeaderSize: Double;


SplitParams.SpacingMax Field

SplitParams.SpacingMax Field

IN: Right / Bottom spacing.

[Visual Basic]

Public SpacingMax As Double

[C#]

public double SpacingMax

[Delphi]

public SpacingMax: Double;


SplitParams.SpacingMin Field

SplitParams.SpacingMin Field

IN: Left / Top spacing.

[Visual Basic]

Public SpacingMin As Double

[C#]

public double SpacingMin

[Delphi]

public SpacingMin: Double;


SplitParams.SplitDimensionSize Field

SplitParams.SplitDimensionSize Field

IN: Size of split dimension, on vertical split - height, on horizontal - width.

[Visual Basic]

Public SplitDimensionSize As Double

[C#]

public double SplitDimensionSize

[Delphi]

public SplitDimensionSize: Double;


SplitParams.SplitPos Field

SplitParams.SplitPos Field

IN: Specifies the requested split position.

[Visual Basic]

Public SplitPos As SplitPos

[C#]

public SplitPos SplitPos

[Delphi]

public SplitPos: SplitPos;


SplitParams.SplitVert Field

SplitParams.SplitVert Field

IN: Indicates the type of split: vertical / horizontal.

[Visual Basic]

Public SplitVert As Boolean

[C#]

public bool SplitVert

[Delphi]

public SplitVert: Boolean;


SplitParams Properties

SplitParams Properties

The properties of the SplitParams class are listed here. For a complete list of SplitParams class members, see the SplitParams Members topic.

Public Properties

ExistSplittedChildren

Indicates that the object has the splitted child objects.


SplitParams.ExistSplittedChildren Property

SplitParams.ExistSplittedChildren Property

Indicates that the object has the splitted child objects.

[Visual Basic]

Public ReadOnly Property ExistSplittedChildren As Boolean

[C#]

public bool ExistSplittedChildren {get;}

[Delphi]

public property ExistSplittedChildren: Boolean read get_ExistSplittedChildren;


SplitParams Methods

SplitParams Methods

The methods of the SplitParams class are listed here. For a complete list of SplitParams class members, see the SplitParams Members topic.

Public Methods

AssignFrom | Copies all properties from another SplitParams object, the ChildrenSplitParams property is copied by reference.
Clone | Creates and returns a copy of this object, the ChildrenSplitParams property is copied by reference.


SplitParams.AssignFrom Method

SplitParams.AssignFrom Method

Copies all properties from another SplitParams object, the ChildrenSplitParams property is copied by reference.

[Visual Basic]

Overridable Public Sub AssignFrom( _

ByVal source As SplitParams _

)

[C#]

virtual public void AssignFrom(

SplitParams source

);

[Delphi]

public procedure AssignFrom(

source: SplitParams

); virtual;

Parameters

source

Source SplitParams object.


SplitParams.Clone Method

SplitParams.Clone Method

Creates and returns a copy of this object, the ChildrenSplitParams property is copied by reference.

[Visual Basic]

Public Function Clone() As SplitParams

[C#]

public SplitParams Clone()

[Delphi]

public function Clone(): SplitParams;


SplitPos Structure

SplitPos Structure

Describes the split position.

For a list of all members of this type, see SplitPos Members.

System.Object

System.ValueType

C1.C1Preview.SplitPos

[Visual Basic]

Public Structure SplitPos

[C#]

public struct SplitPos

[Delphi]

type SplitPos = record;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


SplitPos Members

SplitPos Members

SplitPos overview

Public Fields

ColumnStarted | Indicates that the column is started on split.
HardBreak | Indicates that the break is a "hard", that is, the object must split exactly on Pos.
MaxAvailSpace | Indicates that the requested split position guarantees the maximum space for object.
Pos | Position in object relative to the top / left edge of object.
SpaceForHardBreak | Space *after* Pos available for object if HardBreak is True.


SplitPos Fields

SplitPos Fields

The fields of the SplitPos structure are listed here. For a complete list of SplitPos structure members, see the SplitPos Members topic.

Public Fields

ColumnStarted | Indicates that the column is started on split.
HardBreak | Indicates that the break is a "hard", that is, the object must split exactly on Pos.
MaxAvailSpace | Indicates that the requested split position guarantees the maximum space for object.
Pos | Position in object relative to the top / left edge of object.
SpaceForHardBreak | Space *after* Pos available for object if HardBreak is True.


SplitPos.ColumnStarted Field

SplitPos.ColumnStarted Field

Indicates that the column is started on split.

[Visual Basic]

Public ColumnStarted As Boolean

[C#]

public bool ColumnStarted

[Delphi]

public ColumnStarted: Boolean;


SplitPos.HardBreak Field

SplitPos.HardBreak Field

Indicates that the break is a "hard", that is, the object must split exactly on Pos.

[Visual Basic]

Public HardBreak As Boolean

[C#]

public bool HardBreak

[Delphi]

public HardBreak: Boolean;


SplitPos.MaxAvailSpace Field

SplitPos.MaxAvailSpace Field

Indicates that the requested split position guarantees the maximum space for object.

[Visual Basic]

Public MaxAvailSpace As Boolean

[C#]

public bool MaxAvailSpace

[Delphi]

public MaxAvailSpace: Boolean;


SplitPos.Pos Field

SplitPos.Pos Field

Position in object relative to the top / left edge of object.

[Visual Basic]

Public Pos As Double

[C#]

public double Pos

[Delphi]

public Pos: Double;


SplitPos.SpaceForHardBreak Field

SplitPos.SpaceForHardBreak Field

Space *after* Pos available for object if HardBreak is True.

[Visual Basic]

Public SpaceForHardBreak As Double

[C#]

public double SpaceForHardBreak

[Delphi]

public SpaceForHardBreak: Double;


SplitTypeEnum Enumeration

SplitTypeEnum Enumeration

Specifies the type of split.

[Visual Basic]

Public Enum SplitTypeEnum

[C#]

public enum SplitTypeEnum

[Delphi]

type SplitTypeEnum = (Column, Page);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
Column | The new column will be started when split occurs.
Page | The new page will be started when split occurs.

See Also

C1.C1Preview Namespace


StackingRulesEnum Enumeration

StackingRulesEnum Enumeration

Defines the stacking rules: block flow or inline flow, LeftToRight or TopToBottom

[Visual Basic]

Public Enum StackingRulesEnum

[C#]

public enum StackingRulesEnum

[Delphi]

type StackingRulesEnum = (BlockLeftToRight, BlockTopToBottom, InlineLeftToRight);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
BlockLeftToRight |
BlockTopToBottom |
InlineLeftToRight |

See Also

C1.C1Preview Namespace


StretchColumnEnum Enumeration

StretchColumnEnum Enumeration

Defines the modes of stretching of column.

[Visual Basic]

Public Enum StretchColumnEnum

[C#]

public enum StretchColumnEnum

[Delphi]

type StretchColumnEnum = (Default, IfLastOnPage, No, Yes);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
Default | The stretching of column depends on RenderTable.Stretch property.
IfLastOnPage | The column will be stretched if it is last on page.
No | The stretching of column is disabled.
Yes | The column will be stretched.

See Also

C1.C1Preview Namespace


StretchTableEnum Enumeration

StretchTableEnum Enumeration

Defines the modes of stretching the columns of table.

[Visual Basic]

Public Enum StretchTableEnum

[C#]

public enum StretchTableEnum

[Delphi]

type StretchTableEnum = (AllColumns, LastColumnOnPage, None);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
AllColumns | All columns of table are stretched to fill the whole page.
LastColumnOnPage | Only last column on each page is stretched to fill the whole page.
None | Columns of table do no stretch.

See Also

C1.C1Preview Namespace


Style Class

Style Class

Represents the style for a user.

For a list of all members of this type, see Style Members.

System.Object

C1.C1Preview.Style

[Visual Basic]

Public Class Style

[C#]

public class Style

[Delphi]

type Style = class;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


Style Members

Style Members

Style overview

Public Properties

ActiveHyperlinkAttrs | Gets or sets attributes of active hyperlink.
AmbientParent | Gets the ambient parent style.
BackColor | Gets or sets the background color. If for style both BackColor and Brush are specified then the BackColor will be used.
BackgroundImage | Gets or sets the background image.
BackgroundImageAlign | Gets or sets the alignment of the background picture.
BackgroundImageName | Gets or sets the name of background image in the document's dictionary.
Borders | Gets or sets the border around rendering.
Brush | Gets or sets brush used to fill object. If for style both BackColor and Brush are specified then the BackColor will be used.
Children | Gets collection of child styles.
ClientAreaOnly | Gets or sets the value indicating whether client area or whole area of control will be rendered.
Font | Gets or sets font.
GridLines | Gets or sets the lines in table's area.
HasChildren | Indicates that style has child styles.
HoverHyperlinkAttrs | Gets or sets attributes of highlighted hyperlink.
HyperlinkAttrs | Gets or sets attributes of "normal" (not visited and not highlighted) hyperlink.
ImageAlign | Gets or sets the alignment of the picture.
LineSpacing | Gets or sets the line spacing of a text in %, 100 means default line spacing.
MeasureTrailingSpaces | By default the boundary rectangle formed during text rendering excludes the space at the end of each line. Set this property to True to include that space in measurement.
MinOrphanLines | Gets or sets the minimal count of orphan lines in text.
Padding | Gets or sets padding widths.
Parent | Gets the parent style.
Parents | Sets both parents (Parent and AmbientParent) to the same value.
ShapeFillBrush | Gets or sets brush used to fill internal area of shape objects (RenderRectangle, RenderEllipse, and so on). If for style both ShapeFillColor and ShapeFillBrush are specified then the ShapeFillColor will be used.
ShapeFillColor | Gets or sets the color used to fill internal area of shape objects (RenderRectangle, RenderEllipse, and so on). If for style both ShapeFillColor and ShapeFillBrush are specified then the ShapeFillColor will be used.
ShapeLine | Gets or sets the style of line used to draw the shape objects (RenderLine, RenderRectangle, and so on).
Spacing | Gets or sets spacing widths.
TextAlignHorz | Gets or sets the horizontal alignment of text.
TextAlignVert | Gets or sets the vertical alignment of text.
TextAngle | Gets or sets the angle of a text, in degree.
TextColor | Gets or sets the color of a text.
TextPosition | Gets or sets the style of text: SuperScript, SubScript, Normal.
VisitedHyperlinkAttrs | Gets or sets attributes of visited hyperlink.
WordWrap | Indicates whether a render object automatically wraps words to the beginning of the next line when necessary.

Public Methods

AssignNonInheritedFrom

Copies all non inherited properties from another Style object.


Style Properties

Style Properties

The properties of the Style class are listed here. For a complete list of Style class members, see the Style Members topic.

Public Properties

ActiveHyperlinkAttrs | Gets or sets attributes of active hyperlink.
AmbientParent | Gets the ambient parent style.
BackColor | Gets or sets the background color. If for style both BackColor and Brush are specified then the BackColor will be used.
BackgroundImage | Gets or sets the background image.
BackgroundImageAlign | Gets or sets the alignment of the background picture.
BackgroundImageName | Gets or sets the name of background image in the document's dictionary.
Borders | Gets or sets the border around rendering.
Brush | Gets or sets brush used to fill object. If for style both BackColor and Brush are specified then the BackColor will be used.
Children | Gets collection of child styles.
ClientAreaOnly | Gets or sets the value indicating whether client area or whole area of control will be rendered.
Font | Gets or sets font.
GridLines | Gets or sets the lines in table's area.
HasChildren | Indicates that style has child styles.
HoverHyperlinkAttrs | Gets or sets attributes of highlighted hyperlink.
HyperlinkAttrs | Gets or sets attributes of "normal" (not visited and not highlighted) hyperlink.
ImageAlign | Gets or sets the alignment of the picture.
LineSpacing | Gets or sets the line spacing of a text in %, 100 means default line spacing.
MeasureTrailingSpaces | By default the boundary rectangle formed during text rendering excludes the space at the end of each line. Set this property to True to include that space in measurement.
MinOrphanLines | Gets or sets the minimal count of orphan lines in text.
Padding | Gets or sets padding widths.
Parent | Gets the parent style.
Parents | Sets both parents (Parent and AmbientParent) to the same value.
ShapeFillBrush | Gets or sets brush used to fill internal area of shape objects (RenderRectangle, RenderEllipse, and so on). If for style both ShapeFillColor and ShapeFillBrush are specified then the ShapeFillColor will be used.
ShapeFillColor | Gets or sets the color used to fill internal area of shape objects (RenderRectangle, RenderEllipse, and so on). If for style both ShapeFillColor and ShapeFillBrush are specified then the ShapeFillColor will be used.
ShapeLine | Gets or sets the style of line used to draw the shape objects (RenderLine, RenderRectangle, and so on).
Spacing | Gets or sets spacing widths.
TextAlignHorz | Gets or sets the horizontal alignment of text.
TextAlignVert | Gets or sets the vertical alignment of text.
TextAngle | Gets or sets the angle of a text, in degree.
TextColor | Gets or sets the color of a text.
TextPosition | Gets or sets the style of text: SuperScript, SubScript, Normal.
VisitedHyperlinkAttrs | Gets or sets attributes of visited hyperlink.
WordWrap | Indicates whether a render object automatically wraps words to the beginning of the next line when necessary.


Style.ActiveHyperlinkAttrs Property

Style.ActiveHyperlinkAttrs Property

Gets or sets attributes of active hyperlink.

[Visual Basic]

Public Property ActiveHyperlinkAttrs As C1HyperlinkAttrs

[C#]

public C1HyperlinkAttrs ActiveHyperlinkAttrs {get;set;}

[Delphi]

public property ActiveHyperlinkAttrs: C1HyperlinkAttrs read get_ActiveHyperlinkAttrs write set_ActiveHyperlinkAttrs;


Style.AmbientParent Property

Style.AmbientParent Property

Gets the ambient parent style.

[Visual Basic]

Public Property AmbientParent As Style

[C#]

public Style AmbientParent {get;set;}

[Delphi]

public property AmbientParent: Style read get_AmbientParent write set_AmbientParent;


Style.BackColor Property

Style.BackColor Property

Gets or sets the background color. If for style both BackColor and Brush are specified then the BackColor will be used.

[Visual Basic]

Public Property BackColor As Color

[C#]

public Color BackColor {get;set;}

[Delphi]

public property BackColor: Color read get_BackColor write set_BackColor;


Style.BackgroundImage Property

Style.BackgroundImage Property

Gets or sets the background image.

[Visual Basic]

Public Property BackgroundImage As Image

[C#]

public Image BackgroundImage {get;set;}

[Delphi]

public property BackgroundImage: Image read get_BackgroundImage write set_BackgroundImage;


Style.BackgroundImageAlign Property

Style.BackgroundImageAlign Property

Gets or sets the alignment of the background picture.

[Visual Basic]

Public Property BackgroundImageAlign As IImageAlign

[C#]

public IImageAlign BackgroundImageAlign {get;set;}

[Delphi]

public property BackgroundImageAlign: IImageAlign read get_BackgroundImageAlign write set_BackgroundImageAlign;


Style.BackgroundImageName Property

Style.BackgroundImageName Property

Gets or sets the name of background image in the document's dictionary.

[Visual Basic]

Public Property BackgroundImageName As String

[C#]

public string BackgroundImageName {get;set;}

[Delphi]

public property BackgroundImageName: String read get_BackgroundImageName write set_BackgroundImageName;


Style.Borders Property

Style.Borders Property

Gets or sets the border around rendering.

[Visual Basic]

Public Property Borders As IBorders

[C#]

public IBorders Borders {get;set;}

[Delphi]

public property Borders: IBorders read get_Borders write set_Borders;


Style.Brush Property

Style.Brush Property

Gets or sets brush used to fill object. If for style both BackColor and Brush are specified then the BackColor will be used.

[Visual Basic]

Public Property Brush As Brush

[C#]

public Brush Brush {get;set;}

[Delphi]

public property Brush: Brush read get_Brush write set_Brush;


Style.Children Property

Style.Children Property

Gets collection of child styles.

[Visual Basic]

Public ReadOnly Property Children As StyleCollection

[C#]

public StyleCollection Children {get;}

[Delphi]

public property Children: StyleCollection read get_Children;


Style.ClientAreaOnly Property

Style.ClientAreaOnly Property

Gets or sets the value indicating whether client area or whole area of control will be rendered.

[Visual Basic]

Public Property ClientAreaOnly As Boolean

[C#]

public bool ClientAreaOnly {get;set;}

[Delphi]

public property ClientAreaOnly: Boolean read get_ClientAreaOnly write set_ClientAreaOnly;


Style.Font Property

Style.Font Property

Gets or sets font.

[Visual Basic]

Public Property Font As Font

[C#]

public Font Font {get;set;}

[Delphi]

public property Font: Font read get_Font write set_Font;


Style.GridLines Property

Style.GridLines Property

Gets or sets the lines in table's area.

[Visual Basic]

Public Property GridLines As IGridLines

[C#]

public IGridLines GridLines {get;set;}

[Delphi]

public property GridLines: IGridLines read get_GridLines write set_GridLines;


Style.HasChildren Property

Style.HasChildren Property

Indicates that style has child styles.

[Visual Basic]

Public ReadOnly Property HasChildren As Boolean

[C#]

public bool HasChildren {get;}

[Delphi]

public property HasChildren: Boolean read get_HasChildren;


Style.HoverHyperlinkAttrs Property

Style.HoverHyperlinkAttrs Property

Gets or sets attributes of highlighted hyperlink.

[Visual Basic]

Public Property HoverHyperlinkAttrs As C1HyperlinkAttrs

[C#]

public C1HyperlinkAttrs HoverHyperlinkAttrs {get;set;}

[Delphi]

public property HoverHyperlinkAttrs: C1HyperlinkAttrs read get_HoverHyperlinkAttrs write set_HoverHyperlinkAttrs;


Style.HyperlinkAttrs Property

Style.HyperlinkAttrs Property

Gets or sets attributes of "normal" (not visited and not highlighted) hyperlink.

[Visual Basic]

Public Property HyperlinkAttrs As C1HyperlinkAttrs

[C#]

public C1HyperlinkAttrs HyperlinkAttrs {get;set;}

[Delphi]

public property HyperlinkAttrs: C1HyperlinkAttrs read get_HyperlinkAttrs write set_HyperlinkAttrs;


Style.ImageAlign Property

Style.ImageAlign Property

Gets or sets the alignment of the picture.

[Visual Basic]

Public Property ImageAlign As IImageAlign

[C#]

public IImageAlign ImageAlign {get;set;}

[Delphi]

public property ImageAlign: IImageAlign read get_ImageAlign write set_ImageAlign;


Style.LineSpacing Property

Style.LineSpacing Property

Gets or sets the line spacing of a text in %, 100 means default line spacing.

[Visual Basic]

Public Property LineSpacing As Single

[C#]

public float LineSpacing {get;set;}

[Delphi]

public property LineSpacing: Single read get_LineSpacing write set_LineSpacing;


Style.MeasureTrailingSpaces Property

Style.MeasureTrailingSpaces Property

By default the boundary rectangle formed during text rendering excludes the space at the end of each line. Set this property to True to include that space in measurement.

[Visual Basic]

Public Property MeasureTrailingSpaces As Boolean

[C#]

public bool MeasureTrailingSpaces {get;set;}

[Delphi]

public property MeasureTrailingSpaces: Boolean read get_MeasureTrailingSpaces write set_MeasureTrailingSpaces;


Style.MinOrphanLines Property

Style.MinOrphanLines Property

Gets or sets the minimal count of orphan lines in text.

[Visual Basic]

Public Property MinOrphanLines As Int32*

[C#]

public Int32* MinOrphanLines {get;set;}

[Delphi]

public property MinOrphanLines: Int32* read get_MinOrphanLines write set_MinOrphanLines;


Style.Padding Property

Style.Padding Property

Gets or sets padding widths.

[Visual Basic]

Public Property Padding As IOffsets

[C#]

public IOffsets Padding {get;set;}

[Delphi]

public property Padding: IOffsets read get_Padding write set_Padding;


Style.Parent Property

Style.Parent Property

Gets the parent style.

[Visual Basic]

Public Property Parent As Style

[C#]

public Style Parent {get;set;}

[Delphi]

public property Parent: Style read get_Parent write set_Parent;


Style.Parents Property

Style.Parents Property

Sets both parents (Parent and AmbientParent) to the same value.

[Visual Basic]

Public WriteOnly Property Parents As Style

[C#]

public Style Parents {set;}

[Delphi]

public property Parents: Style write set_Parents;


Style.ShapeFillBrush Property

Style.ShapeFillBrush Property

Gets or sets brush used to fill internal area of shape objects (RenderRectangle, RenderEllipse, and so on). If for style both ShapeFillColor and ShapeFillBrush are specified then the ShapeFillColor will be used.

[Visual Basic]

Public Property ShapeFillBrush As Brush

[C#]

public Brush ShapeFillBrush {get;set;}

[Delphi]

public property ShapeFillBrush: Brush read get_ShapeFillBrush write set_ShapeFillBrush;


Style.ShapeFillColor Property

Style.ShapeFillColor Property

Gets or sets the color used to fill internal area of shape objects (RenderRectangle, RenderEllipse, and so on). If for style both ShapeFillColor and ShapeFillBrush are specified then the ShapeFillColor will be used.

[Visual Basic]

Public Property ShapeFillColor As Color

[C#]

public Color ShapeFillColor {get;set;}

[Delphi]

public property ShapeFillColor: Color read get_ShapeFillColor write set_ShapeFillColor;


Style.ShapeLine Property

Style.ShapeLine Property

Gets or sets the style of line used to draw the shape objects (RenderLine, RenderRectangle, and so on).

[Visual Basic]

Public Property ShapeLine As LineDef

[C#]

public LineDef ShapeLine {get;set;}

[Delphi]

public property ShapeLine: LineDef read get_ShapeLine write set_ShapeLine;


Style.Spacing Property

Style.Spacing Property

Gets or sets spacing widths.

[Visual Basic]

Public Property Spacing As IOffsets

[C#]

public IOffsets Spacing {get;set;}

[Delphi]

public property Spacing: IOffsets read get_Spacing write set_Spacing;


Style.TextAlignHorz Property

Style.TextAlignHorz Property

Gets or sets the horizontal alignment of text.

[Visual Basic]

Public Property TextAlignHorz As AlignHorzEnum

[C#]

public AlignHorzEnum TextAlignHorz {get;set;}

[Delphi]

public property TextAlignHorz: AlignHorzEnum read get_TextAlignHorz write set_TextAlignHorz;


Style.TextAlignVert Property

Style.TextAlignVert Property

Gets or sets the vertical alignment of text.

[Visual Basic]

Public Property TextAlignVert As AlignVertEnum

[C#]

public AlignVertEnum TextAlignVert {get;set;}

[Delphi]

public property TextAlignVert: AlignVertEnum read get_TextAlignVert write set_TextAlignVert;


Style.TextAngle Property

Style.TextAngle Property

Gets or sets the angle of a text, in degree.

[Visual Basic]

Public Property TextAngle As Single

[C#]

public float TextAngle {get;set;}

[Delphi]

public property TextAngle: Single read get_TextAngle write set_TextAngle;


Style.TextColor Property

Style.TextColor Property

Gets or sets the color of a text.

[Visual Basic]

Public Property TextColor As Color

[C#]

public Color TextColor {get;set;}

[Delphi]

public property TextColor: Color read get_TextColor write set_TextColor;


Style.TextPosition Property

Style.TextPosition Property

Gets or sets the style of text: SuperScript, SubScript, Normal.

[Visual Basic]

Public Property TextPosition As TextPositionEnum

[C#]

public TextPositionEnum TextPosition {get;set;}

[Delphi]

public property TextPosition: TextPositionEnum read get_TextPosition write set_TextPosition;


Style.VisitedHyperlinkAttrs Property

Style.VisitedHyperlinkAttrs Property

Gets or sets attributes of visited hyperlink.

[Visual Basic]

Public Property VisitedHyperlinkAttrs As C1HyperlinkAttrs

[C#]

public C1HyperlinkAttrs VisitedHyperlinkAttrs {get;set;}

[Delphi]

public property VisitedHyperlinkAttrs: C1HyperlinkAttrs read get_VisitedHyperlinkAttrs write set_VisitedHyperlinkAttrs;


Style.WordWrap Property

Style.WordWrap Property

Indicates whether a render object automatically wraps words to the beginning of the next line when necessary.

[Visual Basic]

Public Property WordWrap As Boolean

[C#]

public bool WordWrap {get;set;}

[Delphi]

public property WordWrap: Boolean read get_WordWrap write set_WordWrap;


Style Methods

Style Methods

The methods of the Style class are listed here. For a complete list of Style class members, see the Style Members topic.

Public Methods

AssignNonInheritedFrom

Copies all non inherited properties from another Style object.


Style.AssignNonInheritedFrom Method

Style.AssignNonInheritedFrom Method

Copies all non inherited properties from another Style object.

[Visual Basic]

Public Sub AssignNonInheritedFrom( _

ByVal source As Style _

)

[C#]

public void AssignNonInheritedFrom(

Style source

);

[Delphi]

public procedure AssignNonInheritedFrom(

source: Style

);


StyleCollection Class

StyleCollection Class

Collection of Style objects.

For a list of all members of this type, see StyleCollection Members.

System.Object

System.Collections.CollectionBase

C1.C1Preview.StyleCollection

[Visual Basic]

Public Class StyleCollection

Inherits CollectionBase

[C#]

public class StyleCollection : CollectionBase

[Delphi]

type StyleCollection = class (CollectionBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


StyleCollection Members

StyleCollection Members

StyleCollection overview

Public Methods

Add

Creates new Style object and adds it to the collection.


StyleCollection Methods

StyleCollection Methods

The methods of the StyleCollection class are listed here. For a complete list of StyleCollection class members, see the StyleCollection Members topic.

Public Methods

Add

Creates new Style object and adds it to the collection.


StyleCollection.Add Method

StyleCollection.Add Method

Creates new Style object and adds it to the collection.

[Visual Basic]

Public Function Add() As Style

[C#]

public Style Add()

[Delphi]

public function Add(): Style;

Return Value

Created style object.


TableCell Class

TableCell Class

Represents cell of table.

For a list of all members of this type, see TableCell Members.

System.Object

C1.C1Preview.TableCell

[Visual Basic]

Public Class TableCell

Implements IComparable, IDocumentLocation

[C#]

public class TableCell : IComparable, IDocumentLocation

[Delphi]

type TableCell = class (TObject, IComparable, IDocumentLocation);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


TableCell Members

TableCell Members

TableCell overview

Public Properties

Col | Gets the index of column of cell.
Image | Gets or sets the image in cell if cell has not RenderImage object then null returned.
LastCol | Gets the number of last column in span, if SpanCols is 1 then LastColNo equals ColNo.
LastRow | Gets the number of last row in span, if SpanRows is 1 then LastRowsNo equals RowNo.
Owner | Gets the TableCellCollection object containing this object.
RenderObject | Gets or sets the RenderObject in cell.
Row | Gets the index of row of cell.
SpanCols | Count columns in cell span.
SpanRows | Count rows in cell span.
Style | Gets the style of cell.
Tag | Gets or sets the custom, user-defined data associated with a cell.
Text | Gets or sets the text in cell if cell has not RenderText object then string.Empty returned.

Public Methods

AssignFrom

Copies properties of anoter TableVector object. RowNo and ColNo properties are not copied. RenderObject property is copied *not as reference* - the new instance of RenderObject is created and assigned to this.RenderObject.


TableCell Properties

TableCell Properties

The properties of the TableCell class are listed here. For a complete list of TableCell class members, see the TableCell Members topic.

Public Properties

Col | Gets the index of column of cell.
Image | Gets or sets the image in cell if cell has not RenderImage object then null returned.
LastCol | Gets the number of last column in span, if SpanCols is 1 then LastColNo equals ColNo.
LastRow | Gets the number of last row in span, if SpanRows is 1 then LastRowsNo equals RowNo.
Owner | Gets the TableCellCollection object containing this object.
RenderObject | Gets or sets the RenderObject in cell.
Row | Gets the index of row of cell.
SpanCols | Count columns in cell span.
SpanRows | Count rows in cell span.
Style | Gets the style of cell.
Tag | Gets or sets the custom, user-defined data associated with a cell.
Text | Gets or sets the text in cell if cell has not RenderText object then string.Empty returned.


TableCell.Col Property

TableCell.Col Property

Gets the index of column of cell.

[Visual Basic]

Public ReadOnly Property Col As Int32*

[C#]

public Int32* Col {get;}

[Delphi]

public property Col: Int32* read get_Col;


TableCell.Image Property

TableCell.Image Property

Gets or sets the image in cell if cell has not RenderImage object then null returned.

[Visual Basic]

Public Property Image As Image

[C#]

public Image Image {get;set;}

[Delphi]

public property Image: Image read get_Image write set_Image;


TableCell.LastCol Property

TableCell.LastCol Property

Gets the number of last column in span, if SpanCols is 1 then LastColNo equals ColNo.

[Visual Basic]

Public ReadOnly Property LastCol As Int32*

[C#]

public Int32* LastCol {get;}

[Delphi]

public property LastCol: Int32* read get_LastCol;


TableCell.LastRow Property

TableCell.LastRow Property

Gets the number of last row in span, if SpanRows is 1 then LastRowsNo equals RowNo.

[Visual Basic]

Public ReadOnly Property LastRow As Int32*

[C#]

public Int32* LastRow {get;}

[Delphi]

public property LastRow: Int32* read get_LastRow;


TableCell.Owner Property

TableCell.Owner Property

Gets the TableCellCollection object containing this object.

[Visual Basic]

Public ReadOnly Property Owner As TableCellCollection

[C#]

public TableCellCollection Owner {get;}

[Delphi]

public property Owner: TableCellCollection read get_Owner;


TableCell.RenderObject Property

TableCell.RenderObject Property

Gets or sets the RenderObject in cell.

[Visual Basic]

Public Property RenderObject As RenderObject

[C#]

public RenderObject RenderObject {get;set;}

[Delphi]

public property RenderObject: RenderObject read get_RenderObject write set_RenderObject;


TableCell.Row Property

TableCell.Row Property

Gets the index of row of cell.

[Visual Basic]

Public ReadOnly Property Row As Int32*

[C#]

public Int32* Row {get;}

[Delphi]

public property Row: Int32* read get_Row;


TableCell.SpanCols Property

TableCell.SpanCols Property

Count columns in cell span.

[Visual Basic]

Public Property SpanCols As Int32*

[C#]

public Int32* SpanCols {get;set;}

[Delphi]

public property SpanCols: Int32* read get_SpanCols write set_SpanCols;


TableCell.SpanRows Property

TableCell.SpanRows Property

Count rows in cell span.

[Visual Basic]

Public Property SpanRows As Int32*

[C#]

public Int32* SpanRows {get;set;}

[Delphi]

public property SpanRows: Int32* read get_SpanRows write set_SpanRows;


TableCell.Style Property

TableCell.Style Property

Gets the style of cell.

[Visual Basic]

Public ReadOnly Property Style As Style

[C#]

public Style Style {get;}

[Delphi]

public property Style: Style read get_Style;


TableCell.Tag Property

TableCell.Tag Property

Gets or sets the custom, user-defined data associated with a cell.

[Visual Basic]

Public Property Tag As Object

[C#]

public object Tag {get;set;}

[Delphi]

public property Tag: Object read get_Tag write set_Tag;


TableCell.Text Property

TableCell.Text Property

Gets or sets the text in cell if cell has not RenderText object then string.Empty returned.

[Visual Basic]

Public Property Text As String

[C#]

public string Text {get;set;}

[Delphi]

public property Text: String read get_Text write set_Text;


TableCell Methods

TableCell Methods

The methods of the TableCell class are listed here. For a complete list of TableCell class members, see the TableCell Members topic.

Public Methods

AssignFrom

Copies properties of anoter TableVector object. RowNo and ColNo properties are not copied. RenderObject property is copied *not as reference* - the new instance of RenderObject is created and assigned to this.RenderObject.


TableCell.AssignFrom Method

TableCell.AssignFrom Method

Copies properties of anoter TableVector object. RowNo and ColNo properties are not copied. RenderObject property is copied *not as reference* - the new instance of RenderObject is created and assigned to this.RenderObject.

[Visual Basic]

Public Sub AssignFrom( _

ByVal source As TableCell _

)

[C#]

public void AssignFrom(

TableCell source

);

[Delphi]

public procedure AssignFrom(

source: TableCell

);

Parameters

source

The source object properties of which are copied.


TableCol Class

TableCol Class

Represents column of table.

For a list of all members of this type, see TableCol Members.

System.Object

C1.C1Preview.TableVector

C1.C1Preview.TableCol

[Visual Basic]

Public Class TableCol

Inherits TableVector

[C#]

public class TableCol : TableVector

[Delphi]

type TableCol = class (TableVector);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


TableCol Members

TableCol Members

TableCol overview

Public Properties

Ordinal (inherited from TableVector) | Gets the index of vector, it is zero-based.
Owner | Gets the TableColCollection object containing this object.
PageBreakBehavior (inherited from TableVector) | Gets or sets the value determining how page breaks are inserted before this column or row.
Size (inherited from TableVector) | Gets or sets the size of vector (width for column, height for row).
Stretch | Gets or sets the mode of stretching of column.
Style (inherited from TableVector) | Gets the style of vector.
Table (inherited from TableVector) | Gets the RenderTable object containing this vector.
Width | Gets or sets the width of column.


TableCol Properties

TableCol Properties

The properties of the TableCol class are listed here. For a complete list of TableCol class members, see the TableCol Members topic.

Public Properties

Ordinal (inherited from TableVector) | Gets the index of vector, it is zero-based.
Owner | Gets the TableColCollection object containing this object.
PageBreakBehavior (inherited from TableVector) | Gets or sets the value determining how page breaks are inserted before this column or row.
Size (inherited from TableVector) | Gets or sets the size of vector (width for column, height for row).
Stretch | Gets or sets the mode of stretching of column.
Style (inherited from TableVector) | Gets the style of vector.
Table (inherited from TableVector) | Gets the RenderTable object containing this vector.
Width | Gets or sets the width of column.


TableCol.Owner Property

TableCol.Owner Property

Gets the TableColCollection object containing this object.

[Visual Basic]

Public ReadOnly Property Owner As TableColCollection

[C#]

new public TableColCollection Owner {get;}

[Delphi]

public property Owner: TableColCollection read get_Owner;


TableCol.Stretch Property

TableCol.Stretch Property

Gets or sets the mode of stretching of column.

[Visual Basic]

Public Property Stretch As StretchColumnEnum

[C#]

public StretchColumnEnum Stretch {get;set;}

[Delphi]

public property Stretch: StretchColumnEnum read get_Stretch write set_Stretch;


TableCol.Width Property

TableCol.Width Property

Gets or sets the width of column.

[Visual Basic]

Public Property Width As Unit

[C#]

public Unit Width {get;set;}

[Delphi]

public property Width: Unit read get_Width write set_Width;


TableFooterEnum Enumeration

TableFooterEnum Enumeration

[Visual Basic]

Public Enum TableFooterEnum

[C#]

public enum TableFooterEnum

[Delphi]

type TableFooterEnum = (All, Column, None, Page);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
All |
Column |
None |
Page |

See Also

C1.C1Preview Namespace


TableHeaderEnum Enumeration

TableHeaderEnum Enumeration

[Visual Basic]

Public Enum TableHeaderEnum

[C#]

public enum TableHeaderEnum

[Delphi]

type TableHeaderEnum = (All, Column, None, Page);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
All |
Column |
None |
Page |

See Also

C1.C1Preview Namespace


TableRow Class

TableRow Class

Represents row of table.

For a list of all members of this type, see TableRow Members.

System.Object

C1.C1Preview.TableVector

C1.C1Preview.TableRow

[Visual Basic]

Public Class TableRow

Inherits TableVector

[C#]

public class TableRow : TableVector

[Delphi]

type TableRow = class (TableVector);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


TableRow Members

TableRow Members

TableRow overview

Public Properties

Height | Gets or sets the height of row.
Ordinal (inherited from TableVector) | Gets the index of vector, it is zero-based.
Owner | Gets the TableRowCollection object containing this object.
PageBreakBehavior (inherited from TableVector) | Gets or sets the value determining how page breaks are inserted before this column or row.
Size (inherited from TableVector) | Gets or sets the size of vector (width for column, height for row).
Style (inherited from TableVector) | Gets the style of vector.
Table (inherited from TableVector) | Gets the RenderTable object containing this vector.


TableRow Properties

TableRow Properties

The properties of the TableRow class are listed here. For a complete list of TableRow class members, see the TableRow Members topic.

Public Properties

Height | Gets or sets the height of row.
Ordinal (inherited from TableVector) | Gets the index of vector, it is zero-based.
Owner | Gets the TableRowCollection object containing this object.
PageBreakBehavior (inherited from TableVector) | Gets or sets the value determining how page breaks are inserted before this column or row.
Size (inherited from TableVector) | Gets or sets the size of vector (width for column, height for row).
Style (inherited from TableVector) | Gets the style of vector.
Table (inherited from TableVector) | Gets the RenderTable object containing this vector.


TableRow.Height Property

TableRow.Height Property

Gets or sets the height of row.

[Visual Basic]

Public Property Height As Unit

[C#]

public Unit Height {get;set;}

[Delphi]

public property Height: Unit read get_Height write set_Height;


TableRow.Owner Property

TableRow.Owner Property

Gets the TableRowCollection object containing this object.

[Visual Basic]

Public ReadOnly Property Owner As TableRowCollection

[C#]

new public TableRowCollection Owner {get;}

[Delphi]

public property Owner: TableRowCollection read get_Owner;


TableSplitParams Class

TableSplitParams Class

For a list of all members of this type, see TableSplitParams Members.

System.Object

C1.C1Preview.SplitParams

C1.C1Preview.TableSplitParams

[Visual Basic]

Public Class TableSplitParams

Inherits SplitParams

[C#]

public class TableSplitParams : SplitParams

[Delphi]

type TableSplitParams = class (SplitParams);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


TableSplitParams Members

TableSplitParams Members

TableSplitParams overview

Public Fields

BorderMax (inherited from SplitParams) | IN: Right / Bottom border.
BorderMin (inherited from SplitParams) | IN: Left / Top border.
ChildrenAlwaysCanSplit (inherited from SplitParams) | IN: ChildrenAlwaysCanSplitVert or ChildrenAlwaysCanSplitHorz, depends on type of splitting: vertical / horizontal.
ChildrenSplitParams (inherited from SplitParams) | OUT (FindSplitPos): The collection of SplitParams objects from children.
ChildrenSplitPosOffset (inherited from SplitParams) | OUT (FindSplitPos): Offset of children' splitting position from ContentSplitPos.
ContentRealSplitPos (inherited from SplitParams) | OUT (FindSplitPos): The real split position within content area, calculated in the FindVertSplitPosContent / FindHorzSplitPosContent. ContentRealSplitPos = RealSplitPos - ContentSplitOffset. Also see comments to ReprintedFooterSize.
ContentSplitOffset (inherited from SplitParams) | OUT (FindSplitPos): Offsets for split position within content area, the content area is split at position: RealSplitPos - ContentSplitOffset. ContentSplitOffset calculated on the base of padding / spacing / borders / RepeatBorders.
Footer | Resolved info of repeated footer.
Header | Resolved info of repeated header.
NeedReresolving (inherited from SplitParams) | OUT (Split): Indicates that after splitting the fragment which was split must be reresolved. This field filled after RenderFragment.Split method.
NewFragmentSize (inherited from SplitParams) | OUT (FindSplitPos): The size of new fragment, which is created at the split.
NonSplitDimensionContentSize (inherited from SplitParams) | IN: The content size of non split dimension, on vertical split: Width - Inner.Left - Inner.Right on horizontal split: Height - Inner.Top - Inner.Bottom
PaddingMax (inherited from SplitParams) | IN: Right / Bottom padding.
PaddingMin (inherited from SplitParams) | IN: Left / Top padding.
RepeatBorders (inherited from SplitParams) | IN: RepeatBordersVert or RepeatBordersHorz.
ReprintFooterSize (inherited from SplitParams) | OUT (FindSplitPos): The size of reprinted footer at the bottom of object, filled in the FindXXXContent method, after calling this method the ContentRealSplitPos does not include this size, and real RealSplitPos is: ContentRealSplitPos + ContentSplitOffset + ReprintFooterSize.
ReprintHeaderSize (inherited from SplitParams) | OUT (FindSplitPos): The size of reprinted header at the top of object which was split.
SpacingMax (inherited from SplitParams) | IN: Right / Bottom spacing.
SpacingMin (inherited from SplitParams) | IN: Left / Top spacing.
SplitDimensionSize (inherited from SplitParams) | IN: Size of split dimension, on vertical split - height, on horizontal - width.
SplitPos (inherited from SplitParams) | IN: Specifies the requested split position.
SplitPosWithinVector | Split position within vector it is zero if split position is between vectors.
SplitVectorIndex | Index of vector in the _colsOrdinals or _rowsOrdinals array.
SplitVert (inherited from SplitParams) | IN: Indicates the type of split: vertical / horizontal.

Public Properties

ExistSplittedChildren (inherited from SplitParams)

Indicates that the object has the splitted child objects.

Public Methods

Clone (inherited from SplitParams)

Creates and returns a copy of this object, the ChildrenSplitParams property is copied by reference.


TableSplitParams Fields

TableSplitParams Fields

The fields of the TableSplitParams class are listed here. For a complete list of TableSplitParams class members, see the TableSplitParams Members topic.

Public Fields

BorderMax (inherited from SplitParams) | IN: Right / Bottom border.
BorderMin (inherited from SplitParams) | IN: Left / Top border.
ChildrenAlwaysCanSplit (inherited from SplitParams) | IN: ChildrenAlwaysCanSplitVert or ChildrenAlwaysCanSplitHorz, depends on type of splitting: vertical / horizontal.
ChildrenSplitParams (inherited from SplitParams) | OUT (FindSplitPos): The collection of SplitParams objects from children.
ChildrenSplitPosOffset (inherited from SplitParams) | OUT (FindSplitPos): Offset of children' splitting position from ContentSplitPos.
ContentRealSplitPos (inherited from SplitParams) | OUT (FindSplitPos): The real split position within content area, calculated in the FindVertSplitPosContent / FindHorzSplitPosContent. ContentRealSplitPos = RealSplitPos - ContentSplitOffset. Also see comments to ReprintedFooterSize.
ContentSplitOffset (inherited from SplitParams) | OUT (FindSplitPos): Offsets for split position within content area, the content area is split at position: RealSplitPos - ContentSplitOffset. ContentSplitOffset calculated on the base of padding / spacing / borders / RepeatBorders.
Footer | Resolved info of repeated footer.
Header | Resolved info of repeated header.
NeedReresolving (inherited from SplitParams) | OUT (Split): Indicates that after splitting the fragment which was split must be reresolved. This field filled after RenderFragment.Split method.
NewFragmentSize (inherited from SplitParams) | OUT (FindSplitPos): The size of new fragment, which is created at the split.
NonSplitDimensionContentSize (inherited from SplitParams) | IN: The content size of non split dimension, on vertical split: Width - Inner.Left - Inner.Right on horizontal split: Height - Inner.Top - Inner.Bottom
PaddingMax (inherited from SplitParams) | IN: Right / Bottom padding.
PaddingMin (inherited from SplitParams) | IN: Left / Top padding.
RepeatBorders (inherited from SplitParams) | IN: RepeatBordersVert or RepeatBordersHorz.
ReprintFooterSize (inherited from SplitParams) | OUT (FindSplitPos): The size of reprinted footer at the bottom of object, filled in the FindXXXContent method, after calling this method the ContentRealSplitPos does not include this size, and real RealSplitPos is: ContentRealSplitPos + ContentSplitOffset + ReprintFooterSize.
ReprintHeaderSize (inherited from SplitParams) | OUT (FindSplitPos): The size of reprinted header at the top of object which was split.
SpacingMax (inherited from SplitParams) | IN: Right / Bottom spacing.
SpacingMin (inherited from SplitParams) | IN: Left / Top spacing.
SplitDimensionSize (inherited from SplitParams) | IN: Size of split dimension, on vertical split - height, on horizontal - width.
SplitPos (inherited from SplitParams) | IN: Specifies the requested split position.
SplitPosWithinVector | Split position within vector it is zero if split position is between vectors.
SplitVectorIndex | Index of vector in the _colsOrdinals or _rowsOrdinals array.
SplitVert (inherited from SplitParams) | IN: Indicates the type of split: vertical / horizontal.


TableSplitParams.Footer Field

TableSplitParams.Footer Field

Resolved info of repeated footer.

[Visual Basic]

Public Footer As TitleResolvedInfo

[C#]

public TitleResolvedInfo Footer

[Delphi]

public Footer: TitleResolvedInfo;


TableSplitParams.Header Field

TableSplitParams.Header Field

Resolved info of repeated header.

[Visual Basic]

Public Header As TitleResolvedInfo

[C#]

public TitleResolvedInfo Header

[Delphi]

public Header: TitleResolvedInfo;


TableSplitParams.SplitPosWithinVector Field

TableSplitParams.SplitPosWithinVector Field

Split position within vector it is zero if split position is between vectors.

[Visual Basic]

Public SplitPosWithinVector As Double

[C#]

public double SplitPosWithinVector

[Delphi]

public SplitPosWithinVector: Double;


TableSplitParams.SplitVectorIndex Field

TableSplitParams.SplitVectorIndex Field

Index of vector in the _colsOrdinals or _rowsOrdinals array.

[Visual Basic]

Public SplitVectorIndex As Int32*

[C#]

public Int32* SplitVectorIndex

[Delphi]

public SplitVectorIndex: Int32*;


TableSplitParams Properties

TableSplitParams Properties

The properties of the TableSplitParams class are listed here. For a complete list of TableSplitParams class members, see the TableSplitParams Members topic.

Public Properties

ExistSplittedChildren (inherited from SplitParams)

Indicates that the object has the splitted child objects.


TableSplitParams Methods

TableSplitParams Methods

The methods of the TableSplitParams class are listed here. For a complete list of TableSplitParams class members, see the TableSplitParams Members topic.

Public Methods

Clone (inherited from SplitParams)

Creates and returns a copy of this object, the ChildrenSplitParams property is copied by reference.


TableVector Class

TableVector Class

Base class for columns and rows of table. One TableVector object can be used in many tables.

For a list of all members of this type, see TableVector Members.

System.Object

C1.C1Preview.TableVector

C1.C1Preview.TableCol

C1.C1Preview.TableRow

[Visual Basic]

MustInherit Public Class TableVector

Implements IComparable, IDocumentLocation

[C#]

public abstract class TableVector : IComparable, IDocumentLocation

[Delphi]

type TableVector = class abstract (TObject, IComparable, IDocumentLocation);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


TableVector Members

TableVector Members

TableVector overview

Public Properties

Ordinal | Gets the index of vector, it is zero-based.
Owner | Gets the TableVectorCollection object containing this object.
PageBreakBehavior | Gets or sets the value determining how page breaks are inserted before this column or row.
Size | Gets or sets the size of vector (width for column, height for row).
Style | Gets the style of vector.
Table | Gets the RenderTable object containing this vector.

Public Methods

AssignFrom

Copies properties of anoter TableVector object. Number property is not copied.


TableVector Properties

TableVector Properties

The properties of the TableVector class are listed here. For a complete list of TableVector class members, see the TableVector Members topic.

Public Properties

Ordinal | Gets the index of vector, it is zero-based.
Owner | Gets the TableVectorCollection object containing this object.
PageBreakBehavior | Gets or sets the value determining how page breaks are inserted before this column or row.
Size | Gets or sets the size of vector (width for column, height for row).
Style | Gets the style of vector.
Table | Gets the RenderTable object containing this vector.


TableVector.Ordinal Property

TableVector.Ordinal Property

Gets the index of vector, it is zero-based.

[Visual Basic]

Public ReadOnly Property Ordinal As Int32*

[C#]

public Int32* Ordinal {get;}

[Delphi]

public property Ordinal: Int32* read get_Ordinal;


TableVector.Owner Property

TableVector.Owner Property

Gets the TableVectorCollection object containing this object.

[Visual Basic]

Public ReadOnly Property Owner As TableVectorCollection

[C#]

public TableVectorCollection Owner {get;}

[Delphi]

public property Owner: TableVectorCollection read get_Owner;


TableVector.PageBreakBehavior Property

TableVector.PageBreakBehavior Property

Gets or sets the value determining how page breaks are inserted before this column or row.

[Visual Basic]

Public Property PageBreakBehavior As PageBreakBehaviorEnum

[C#]

public PageBreakBehaviorEnum PageBreakBehavior {get;set;}

[Delphi]

public property PageBreakBehavior: PageBreakBehaviorEnum read get_PageBreakBehavior write set_PageBreakBehavior;


TableVector.Size Property

TableVector.Size Property

Gets or sets the size of vector (width for column, height for row).

[Visual Basic]

Public Property Size As Unit

[C#]

public Unit Size {get;set;}

[Delphi]

public property Size: Unit read get_Size write set_Size;


TableVector.Style Property

TableVector.Style Property

Gets the style of vector.

[Visual Basic]

Public ReadOnly Property Style As Style

[C#]

public Style Style {get;}

[Delphi]

public property Style: Style read get_Style;


TableVector.Table Property

TableVector.Table Property

Gets the RenderTable object containing this vector.

[Visual Basic]

Public ReadOnly Property Table As RenderTable

[C#]

public RenderTable Table {get;}

[Delphi]

public property Table: RenderTable read get_Table;


TableVector Methods

TableVector Methods

The methods of the TableVector class are listed here. For a complete list of TableVector class members, see the TableVector Members topic.

Public Methods

AssignFrom

Copies properties of anoter TableVector object. Number property is not copied.


TableVector.AssignFrom Method

TableVector.AssignFrom Method

Copies properties of anoter TableVector object. Number property is not copied.

[Visual Basic]

Overridable Public Sub AssignFrom( _

ByVal source As TableVector _

)

[C#]

virtual public void AssignFrom(

TableVector source

);

[Delphi]

public procedure AssignFrom(

source: TableVector

); virtual;

Parameters

source

The source object properties of which are copied.


TableVectorGroup Class

TableVectorGroup Class

For a list of all members of this type, see TableVectorGroup Members.

System.Object

C1.C1Preview.TableVectorGroup

[Visual Basic]

Public Class TableVectorGroup

Implements IComparable, IDocumentLocation

[C#]

public class TableVectorGroup : IComparable, IDocumentLocation

[Delphi]

type TableVectorGroup = class (TObject, IComparable, IDocumentLocation);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


TableVectorGroup Members

TableVectorGroup Members

TableVectorGroup overview

Public Properties

CanSplit | Indicates whether the group can be split between pages.
ColumnFooter | Indicates whether the group should be reprinted as footer on each column where table exists. Only one group in the table can has this flag.
ColumnHeader | Indicates whether the group should be reprinted as header on each column where table exists. Only one group in the table can has this flag.
Count | Gets count of rows or columns in the group.
LastPosition | Gets the number of column or row with which group ends.
Owner | Gets the TableVectorGroupCollection object containing this object.
PageFooter | Indicates whether the group should be reprinted as footer on each page where table exists. Only one group in the table can has this flag.
PageHeader | Indicates whether the group should be reprinted as header on each page where table exists. Only one group in the table can has this flag.
Position | Gets the index of column or row from which groups begins.
Style | Gets the Style of group.
Table | Gets the RenderTable object containing this object.


TableVectorGroup Properties

TableVectorGroup Properties

The properties of the TableVectorGroup class are listed here. For a complete list of TableVectorGroup class members, see the TableVectorGroup Members topic.

Public Properties

CanSplit | Indicates whether the group can be split between pages.
ColumnFooter | Indicates whether the group should be reprinted as footer on each column where table exists. Only one group in the table can has this flag.
ColumnHeader | Indicates whether the group should be reprinted as header on each column where table exists. Only one group in the table can has this flag.
Count | Gets count of rows or columns in the group.
LastPosition | Gets the number of column or row with which group ends.
Owner | Gets the TableVectorGroupCollection object containing this object.
PageFooter | Indicates whether the group should be reprinted as footer on each page where table exists. Only one group in the table can has this flag.
PageHeader | Indicates whether the group should be reprinted as header on each page where table exists. Only one group in the table can has this flag.
Position | Gets the index of column or row from which groups begins.
Style | Gets the Style of group.
Table | Gets the RenderTable object containing this object.


TableVectorGroup.CanSplit Property

TableVectorGroup.CanSplit Property

Indicates whether the group can be split between pages.

[Visual Basic]

Public Property CanSplit As Boolean

[C#]

public bool CanSplit {get;set;}

[Delphi]

public property CanSplit: Boolean read get_CanSplit write set_CanSplit;


TableVectorGroup.ColumnFooter Property

TableVectorGroup.ColumnFooter Property

Indicates whether the group should be reprinted as footer on each column where table exists. Only one group in the table can has this flag.

[Visual Basic]

Public Property ColumnFooter As Boolean

[C#]

public bool ColumnFooter {get;set;}

[Delphi]

public property ColumnFooter: Boolean read get_ColumnFooter write set_ColumnFooter;


TableVectorGroup.ColumnHeader Property

TableVectorGroup.ColumnHeader Property

Indicates whether the group should be reprinted as header on each column where table exists. Only one group in the table can has this flag.

[Visual Basic]

Public Property ColumnHeader As Boolean

[C#]

public bool ColumnHeader {get;set;}

[Delphi]

public property ColumnHeader: Boolean read get_ColumnHeader write set_ColumnHeader;


TableVectorGroup.Count Property

TableVectorGroup.Count Property

Gets count of rows or columns in the group.

[Visual Basic]

Public ReadOnly Property Count As Int32*

[C#]

public Int32* Count {get;}

[Delphi]

public property Count: Int32* read get_Count;


TableVectorGroup.LastPosition Property

TableVectorGroup.LastPosition Property

Gets the number of column or row with which group ends.

[Visual Basic]

Public ReadOnly Property LastPosition As Int32*

[C#]

public Int32* LastPosition {get;}

[Delphi]

public property LastPosition: Int32* read get_LastPosition;


TableVectorGroup.Owner Property

TableVectorGroup.Owner Property

Gets the TableVectorGroupCollection object containing this object.

[Visual Basic]

Public ReadOnly Property Owner As TableVectorGroupCollection

[C#]

public TableVectorGroupCollection Owner {get;}

[Delphi]

public property Owner: TableVectorGroupCollection read get_Owner;


TableVectorGroup.PageFooter Property

TableVectorGroup.PageFooter Property

Indicates whether the group should be reprinted as footer on each page where table exists. Only one group in the table can has this flag.

[Visual Basic]

Public Property PageFooter As Boolean

[C#]

public bool PageFooter {get;set;}

[Delphi]

public property PageFooter: Boolean read get_PageFooter write set_PageFooter;


TableVectorGroup.PageHeader Property

TableVectorGroup.PageHeader Property

Indicates whether the group should be reprinted as header on each page where table exists. Only one group in the table can has this flag.

[Visual Basic]

Public Property PageHeader As Boolean

[C#]

public bool PageHeader {get;set;}

[Delphi]

public property PageHeader: Boolean read get_PageHeader write set_PageHeader;


TableVectorGroup.Position Property

TableVectorGroup.Position Property

Gets the index of column or row from which groups begins.

[Visual Basic]

Public ReadOnly Property Position As Int32*

[C#]

public Int32* Position {get;}

[Delphi]

public property Position: Int32* read get_Position;


TableVectorGroup.Style Property

TableVectorGroup.Style Property

Gets the Style of group.

[Visual Basic]

Public ReadOnly Property Style As Style

[C#]

public Style Style {get;}

[Delphi]

public property Style: Style read get_Style;


TableVectorGroup.Table Property

TableVectorGroup.Table Property

Gets the RenderTable object containing this object.

[Visual Basic]

Public ReadOnly Property Table As RenderTable

[C#]

public RenderTable Table {get;}

[Delphi]

public property Table: RenderTable read get_Table;


TabPosition Class

TabPosition Class

Represents the tab in paragraph of text.

For a list of all members of this type, see TabPosition Members.

System.Object

C1.C1Preview.TabPosition

[Visual Basic]

Public Class TabPosition

[C#]

public class TabPosition

[Delphi]

type TabPosition = class;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


TabPosition Members

TabPosition Members

TabPosition overview

Public Properties

Alignment | Gets or sets the alignment of text at this tab.
FillChar | Gets or sets the char used to fill the tab space.
Position | Gets or sets the position of text.


TabPosition Properties

TabPosition Properties

The properties of the TabPosition class are listed here. For a complete list of TabPosition class members, see the TabPosition Members topic.

Public Properties

Alignment | Gets or sets the alignment of text at this tab.
FillChar | Gets or sets the char used to fill the tab space.
Position | Gets or sets the position of text.


TabPosition.Alignment Property

TabPosition.Alignment Property

Gets or sets the alignment of text at this tab.

[Visual Basic]

Public Property Alignment As TabAlignmentEnum

[C#]

public TabAlignmentEnum Alignment {get;set;}

[Delphi]

public property Alignment: TabAlignmentEnum read get_Alignment write set_Alignment;


TabPosition.FillChar Property

TabPosition.FillChar Property

Gets or sets the char used to fill the tab space.

[Visual Basic]

Public Property FillChar As Char*

[C#]

public Char* FillChar {get;set;}

[Delphi]

public property FillChar: Char* read get_FillChar write set_FillChar;


TabPosition.Position Property

TabPosition.Position Property

Gets or sets the position of text.

[Visual Basic]

Public Property Position As Unit

[C#]

public Unit Position {get;set;}

[Delphi]

public property Position: Unit read get_Position write set_Position;


TabPositionCollection Class

TabPositionCollection Class

Collection of the TabPosition objects.

For a list of all members of this type, see TabPositionCollection Members.

System.Object

System.Collections.CollectionBase

C1.C1Preview.TabPositionCollection

[Visual Basic]

Public Class TabPositionCollection

Inherits CollectionBase

[C#]

public class TabPositionCollection : CollectionBase

[Delphi]

type TabPositionCollection = class (CollectionBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


TabPositionCollection Members

TabPositionCollection Members

TabPositionCollection overview


Tag Class

Tag Class

Represents the user-defined tag.

For a list of all members of this type, see Tag Members.

System.Object

C1.C1Preview.TagBase

C1.C1Preview.Tag

[Visual Basic]

Public Class Tag

Inherits TagBase

[C#]

public class Tag : TagBase

[Delphi]

type Tag = class (TagBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


Tag Members

Tag Members

Tag overview

Public Constructors

Tag Constructor

Public Properties

Name | Overriden.
Value | Overriden.

Public Methods

GetPageValue

Overriden.


Tag Constructor

Tag Constructor

Overload List

[Visual Basic] Public Function New(String)

[C#] public Tag(string);

[Delphi] public constructor Create(String); overload;

[Visual Basic] Public Function New(String, Object)

[C#] public Tag(string, object);

[Delphi] public constructor Create(String; Object); overload;


Tag Constructor (String)

Tag Constructor (String)

Previous Next

[Visual Basic]

Public Function New( _

ByVal name As String _

)

[C#]

public Tag(

string name

);

[Delphi]

public constructor Create(

name: String

); overload;


Tag Constructor (String, Object)

Tag Constructor (String, Object)

Previous Next

[Visual Basic]

Public Function New( _

ByVal name As String, _

ByVal value As Object _

)

[C#]

public Tag(

string name,

object value

);

[Delphi]

public constructor Create(

name: String;

value: Object

); overload;


Tag Properties

Tag Properties

The properties of the Tag class are listed here. For a complete list of Tag class members, see the Tag Members topic.

Public Properties

Name | Overriden.
Value | Overriden.


Tag.Name Property

Tag.Name Property

[Visual Basic]

Overrides Public Property Name As String

[C#]

override public string Name {get;set;}

[Delphi]

public property Name: String read get_Name write set_Name;


Tag.Value Property

Tag.Value Property

[Visual Basic]

Overrides Public Property Value As Object

[C#]

override public object Value {get;set;}

[Delphi]

public property Value: Object read get_Value write set_Value;


Tag Methods

Tag Methods

The methods of the Tag class are listed here. For a complete list of Tag class members, see the Tag Members topic.

Public Methods

GetPageValue

Overriden.


Tag.GetPageValue Method

Tag.GetPageValue Method

[Visual Basic]

Overrides Public Function GetPageValue( _

ByVal page As Page _

) As String

[C#]

override public string GetPageValue(

Page page

);

[Delphi]

public function GetPageValue(

page: Page

): String; override;


TagBase Class

TagBase Class

For a list of all members of this type, see TagBase Members.

System.Object

C1.C1Preview.TagBase

C1.C1Preview.Tag

C1.C1Preview.TagSys

[Visual Basic]

MustInherit Public Class TagBase

[C#]

public abstract class TagBase

[Delphi]

type TagBase = class abstract;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


TagBase Members

TagBase Members

TagBase overview

Public Properties

Name

Value

Public Methods

GetPageValue


TagBase Properties

TagBase Properties

The properties of the TagBase class are listed here. For a complete list of TagBase class members, see the TagBase Members topic.

Public Properties

Name

Value


TagBase.Name Property

TagBase.Name Property

[Visual Basic]

Overridable MustInherit Public Property Name As String

[C#]

virtual abstract public string Name {get;set;}

[Delphi]

public property Name: String read get_Name write set_Name;


TagBase.Value Property

TagBase.Value Property

[Visual Basic]

Overridable MustInherit Public Property Value As Object

[C#]

virtual abstract public object Value {get;set;}

[Delphi]

public property Value: Object read get_Value write set_Value;


TagBase Methods

TagBase Methods

The methods of the TagBase class are listed here. For a complete list of TagBase class members, see the TagBase Members topic.

Public Methods

GetPageValue


TagBase.GetPageValue Method

TagBase.GetPageValue Method

[Visual Basic]

Overridable MustOverride Public Function GetPageValue( _

ByVal page As Page _

) As String

[C#]

virtual abstract public string GetPageValue(

Page page

);

[Delphi]

public function GetPageValue(

page: Page

): String; virtual; abstract;


TagCollection Class

TagCollection Class

Collection of the Tag objects.

For a list of all members of this type, see TagCollection Members.

System.Object

System.Collections.CollectionBase

C1.C1Preview.TagCollection

[Visual Basic]

Public Class TagCollection

Inherits CollectionBase

[C#]

public class TagCollection : CollectionBase

[Delphi]

type TagCollection = class (CollectionBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


TagCollection Members

TagCollection Members

TagCollection overview

Public Properties

Item


TagCollection Properties

TagCollection Properties

The properties of the TagCollection class are listed here. For a complete list of TagCollection class members, see the TagCollection Members topic.

Public Properties

Item


TagCollection.Item Property

TagCollection.Item Property

[Visual Basic]

Public Default ReadOnly Property Item( _

ByVal tagName As String _

) As Tag

[C#]

public Tag this[

string tagName

] {get;}

[Delphi]

public property Item[

tagName: String

]: Tag read get_Item;


TagPageCount Class

TagPageCount Class

For a list of all members of this type, see TagPageCount Members.

System.Object

C1.C1Preview.TagBase

C1.C1Preview.TagSys

C1.C1Preview.TagPageCount

[Visual Basic]

Public Class TagPageCount

Inherits TagSys

[C#]

public class TagPageCount : TagSys

[Delphi]

type TagPageCount = class (TagSys);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


TagPageCount Members

TagPageCount Members

TagPageCount overview

Public Properties

Name (inherited from TagSys)

Value (inherited from TagSys)

Public Methods

GetPageValue

Overriden.


TagPageCount Properties

TagPageCount Properties

The properties of the TagPageCount class are listed here. For a complete list of TagPageCount class members, see the TagPageCount Members topic.

Public Properties

Name (inherited from TagSys)

Value (inherited from TagSys)


TagPageCount Methods

TagPageCount Methods

The methods of the TagPageCount class are listed here. For a complete list of TagPageCount class members, see the TagPageCount Members topic.

Public Methods

GetPageValue

Overriden.


TagPageCount.GetPageValue Method

TagPageCount.GetPageValue Method

[Visual Basic]

Overrides Public Function GetPageValue( _

ByVal page As Page _

) As String

[C#]

override public string GetPageValue(

Page page

);

[Delphi]

public function GetPageValue(

page: Page

): String; override;


TagPageNo Class

TagPageNo Class

For a list of all members of this type, see TagPageNo Members.

System.Object

C1.C1Preview.TagBase

C1.C1Preview.TagSys

C1.C1Preview.TagPageNo

[Visual Basic]

Public Class TagPageNo

Inherits TagSys

[C#]

public class TagPageNo : TagSys

[Delphi]

type TagPageNo = class (TagSys);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


TagPageNo Members

TagPageNo Members

TagPageNo overview

Public Properties

Name (inherited from TagSys)

Value (inherited from TagSys)

Public Methods

GetPageValue

Overriden.


TagPageNo Properties

TagPageNo Properties

The properties of the TagPageNo class are listed here. For a complete list of TagPageNo class members, see the TagPageNo Members topic.

Public Properties

Name (inherited from TagSys)

Value (inherited from TagSys)


TagPageNo Methods

TagPageNo Methods

The methods of the TagPageNo class are listed here. For a complete list of TagPageNo class members, see the TagPageNo Members topic.

Public Methods

GetPageValue

Overriden.


TagPageNo.GetPageValue Method

TagPageNo.GetPageValue Method

[Visual Basic]

Overrides Public Function GetPageValue( _

ByVal page As Page _

) As String

[C#]

override public string GetPageValue(

Page page

);

[Delphi]

public function GetPageValue(

page: Page

): String; override;


TagPageX Class

TagPageX Class

For a list of all members of this type, see TagPageX Members.

System.Object

C1.C1Preview.TagBase

C1.C1Preview.TagSys

C1.C1Preview.TagPageX

[Visual Basic]

Public Class TagPageX

Inherits TagSys

[C#]

public class TagPageX : TagSys

[Delphi]

type TagPageX = class (TagSys);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


TagPageX Members

TagPageX Members

TagPageX overview

Public Properties

Name (inherited from TagSys)

Value (inherited from TagSys)

Public Methods

GetPageValue

Overriden.


TagPageX Properties

TagPageX Properties

The properties of the TagPageX class are listed here. For a complete list of TagPageX class members, see the TagPageX Members topic.

Public Properties

Name (inherited from TagSys)

Value (inherited from TagSys)


TagPageX Methods

TagPageX Methods

The methods of the TagPageX class are listed here. For a complete list of TagPageX class members, see the TagPageX Members topic.

Public Methods

GetPageValue

Overriden.


TagPageX.GetPageValue Method

TagPageX.GetPageValue Method

[Visual Basic]

Overrides Public Function GetPageValue( _

ByVal page As Page _

) As String

[C#]

override public string GetPageValue(

Page page

);

[Delphi]

public function GetPageValue(

page: Page

): String; override;


TagPageXCount Class

TagPageXCount Class

For a list of all members of this type, see TagPageXCount Members.

System.Object

C1.C1Preview.TagBase

C1.C1Preview.TagSys

C1.C1Preview.TagPageXCount

[Visual Basic]

Public Class TagPageXCount

Inherits TagSys

[C#]

public class TagPageXCount : TagSys

[Delphi]

type TagPageXCount = class (TagSys);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


TagPageXCount Members

TagPageXCount Members

TagPageXCount overview

Public Properties

Name (inherited from TagSys)

Value (inherited from TagSys)

Public Methods

GetPageValue

Overriden.


TagPageXCount Properties

TagPageXCount Properties

The properties of the TagPageXCount class are listed here. For a complete list of TagPageXCount class members, see the TagPageXCount Members topic.

Public Properties

Name (inherited from TagSys)

Value (inherited from TagSys)


TagPageXCount Methods

TagPageXCount Methods

The methods of the TagPageXCount class are listed here. For a complete list of TagPageXCount class members, see the TagPageXCount Members topic.

Public Methods

GetPageValue

Overriden.


TagPageXCount.GetPageValue Method

TagPageXCount.GetPageValue Method

[Visual Basic]

Overrides Public Function GetPageValue( _

ByVal page As Page _

) As String

[C#]

override public string GetPageValue(

Page page

);

[Delphi]

public function GetPageValue(

page: Page

): String; override;


TagPageY Class

TagPageY Class

For a list of all members of this type, see TagPageY Members.

System.Object

C1.C1Preview.TagBase

C1.C1Preview.TagSys

C1.C1Preview.TagPageY

[Visual Basic]

Public Class TagPageY

Inherits TagSys

[C#]

public class TagPageY : TagSys

[Delphi]

type TagPageY = class (TagSys);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


TagPageY Members

TagPageY Members

TagPageY overview

Public Properties

Name (inherited from TagSys)

Value (inherited from TagSys)

Public Methods

GetPageValue

Overriden.


TagPageY Properties

TagPageY Properties

The properties of the TagPageY class are listed here. For a complete list of TagPageY class members, see the TagPageY Members topic.

Public Properties

Name (inherited from TagSys)

Value (inherited from TagSys)


TagPageY Methods

TagPageY Methods

The methods of the TagPageY class are listed here. For a complete list of TagPageY class members, see the TagPageY Members topic.

Public Methods

GetPageValue

Overriden.


TagPageY.GetPageValue Method

TagPageY.GetPageValue Method

[Visual Basic]

Overrides Public Function GetPageValue( _

ByVal page As Page _

) As String

[C#]

override public string GetPageValue(

Page page

);

[Delphi]

public function GetPageValue(

page: Page

): String; override;


TagPageYCount Class

TagPageYCount Class

For a list of all members of this type, see TagPageYCount Members.

System.Object

C1.C1Preview.TagBase

C1.C1Preview.TagSys

C1.C1Preview.TagPageYCount

[Visual Basic]

Public Class TagPageYCount

Inherits TagSys

[C#]

public class TagPageYCount : TagSys

[Delphi]

type TagPageYCount = class (TagSys);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


TagPageYCount Members

TagPageYCount Members

TagPageYCount overview

Public Properties

Name (inherited from TagSys)

Value (inherited from TagSys)

Public Methods

GetPageValue

Overriden.


TagPageYCount Properties

TagPageYCount Properties

The properties of the TagPageYCount class are listed here. For a complete list of TagPageYCount class members, see the TagPageYCount Members topic.

Public Properties

Name (inherited from TagSys)

Value (inherited from TagSys)


TagPageYCount Methods

TagPageYCount Methods

The methods of the TagPageYCount class are listed here. For a complete list of TagPageYCount class members, see the TagPageYCount Members topic.

Public Methods

GetPageValue

Overriden.


TagPageYCount.GetPageValue Method

TagPageYCount.GetPageValue Method

[Visual Basic]

Overrides Public Function GetPageValue( _

ByVal page As Page _

) As String

[C#]

override public string GetPageValue(

Page page

);

[Delphi]

public function GetPageValue(

page: Page

): String; override;


TagSys Class

TagSys Class

For a list of all members of this type, see TagSys Members.

System.Object

C1.C1Preview.TagBase

C1.C1Preview.TagSys

C1.C1Preview.TagPageCount

C1.C1Preview.TagPageNo

C1.C1Preview.TagPageX

C1.C1Preview.TagPageXCount

C1.C1Preview.TagPageY

C1.C1Preview.TagPageYCount

[Visual Basic]

MustInherit Public Class TagSys

Inherits TagBase

[C#]

public abstract class TagSys : TagBase

[Delphi]

type TagSys = class abstract (TagBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


TagSys Members

TagSys Members

TagSys overview

Public Properties

Name | Overriden.
PageCount |
PageNo |
PageX |
PageXCount |
PageY |
PageYCount |
Value | Overriden.

Public Methods

GetPageValue (inherited from TagBase)


TagSys Properties

TagSys Properties

The properties of the TagSys class are listed here. For a complete list of TagSys class members, see the TagSys Members topic.

Public Properties

Name | Overriden.
PageCount |
PageNo |
PageX |
PageXCount |
PageY |
PageYCount |
Value | Overriden.


TagSys.Name Property

TagSys.Name Property

[Visual Basic]

Overrides Public Property Name As String

[C#]

override public string Name {get;set;}

[Delphi]

public property Name: String read get_Name write set_Name;


TagSys.PageCount Property

TagSys.PageCount Property

[Visual Basic]

Public Shared ReadOnly Property PageCount As TagPageCount

[C#]

public static TagPageCount PageCount {get;}

[Delphi]

public class property PageCount: TagPageCount read get_PageCount;


TagSys.PageNo Property

TagSys.PageNo Property

[Visual Basic]

Public Shared ReadOnly Property PageNo As TagPageNo

[C#]

public static TagPageNo PageNo {get;}

[Delphi]

public class property PageNo: TagPageNo read get_PageNo;


TagSys.PageX Property

TagSys.PageX Property

[Visual Basic]

Public Shared ReadOnly Property PageX As TagPageX

[C#]

public static TagPageX PageX {get;}

[Delphi]

public class property PageX: TagPageX read get_PageX;


TagSys.PageXCount Property

TagSys.PageXCount Property

[Visual Basic]

Public Shared ReadOnly Property PageXCount As TagPageXCount

[C#]

public static TagPageXCount PageXCount {get;}

[Delphi]

public class property PageXCount: TagPageXCount read get_PageXCount;


TagSys.PageY Property

TagSys.PageY Property

[Visual Basic]

Public Shared ReadOnly Property PageY As TagPageY

[C#]

public static TagPageY PageY {get;}

[Delphi]

public class property PageY: TagPageY read get_PageY;


TagSys.PageYCount Property

TagSys.PageYCount Property

[Visual Basic]

Public Shared ReadOnly Property PageYCount As TagPageYCount

[C#]

public static TagPageYCount PageYCount {get;}

[Delphi]

public class property PageYCount: TagPageYCount read get_PageYCount;


TagSys.Value Property

TagSys.Value Property

[Visual Basic]

Overrides Public Property Value As Object

[C#]

override public object Value {get;set;}

[Delphi]

public property Value: Object read get_Value write set_Value;


TagSys Methods

TagSys Methods

The methods of the TagSys class are listed here. For a complete list of TagSys class members, see the TagSys Members topic.

Public Methods

GetPageValue (inherited from TagBase)


TextPositionEnum Enumeration

TextPositionEnum Enumeration

[Visual Basic]

Public Enum TextPositionEnum

[C#]

public enum TextPositionEnum

[Delphi]

type TextPositionEnum = (Normal, Subscript, Superscript);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
Normal |
Subscript |
Superscript |

See Also

C1.C1Preview Namespace


TextResolvedInfo Class

TextResolvedInfo Class

For a list of all members of this type, see TextResolvedInfo Members.

System.Object

C1.C1Preview.FragmentResolvedInfo

C1.C1Preview.TextResolvedInfo

[Visual Basic]

Public Class TextResolvedInfo

Inherits FragmentResolvedInfo

[C#]

public class TextResolvedInfo : FragmentResolvedInfo

[Delphi]

type TextResolvedInfo = class (FragmentResolvedInfo);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


TextResolvedInfo Members

TextResolvedInfo Members

TextResolvedInfo overview

Public Properties

AvailHeight (inherited from FragmentResolvedInfo) | Returns the distance between Top and LeftTopPageArea.Bottom.
AvailWidth (inherited from FragmentResolvedInfo) | Returns the distance between Left and LeftTopPageArea.Right.
BottomOffset (inherited from FragmentResolvedInfo) | Returns a sum of Padding.Bottom, Spacing.Bottom, Borders.Bottom
IsAutoLeft (inherited from FragmentResolvedInfo) | Indicates that the Left coordinate of object was calculated as auto.
IsAutoPos (inherited from FragmentResolvedInfo) | Indicates that the Left-top position of object was calculated as auto.
IsAutoTop (inherited from FragmentResolvedInfo) | Indicates that the Top coordinate of object was calculated as auto.
LeftOffset (inherited from FragmentResolvedInfo) | Returns a sum of Padding.Left, Spacing.Left, Borders.Left
RightOffset (inherited from FragmentResolvedInfo) | Returns a sum of Padding.Right, Spacing.Right, Borders.Right
TopOffset (inherited from FragmentResolvedInfo) | Returns a sum of Padding.Top, Spacing.Top, Borders.Top


TextResolvedInfo Properties

TextResolvedInfo Properties

The properties of the TextResolvedInfo class are listed here. For a complete list of TextResolvedInfo class members, see the TextResolvedInfo Members topic.

Public Properties

AvailHeight (inherited from FragmentResolvedInfo) | Returns the distance between Top and LeftTopPageArea.Bottom.
AvailWidth (inherited from FragmentResolvedInfo) | Returns the distance between Left and LeftTopPageArea.Right.
BottomOffset (inherited from FragmentResolvedInfo) | Returns a sum of Padding.Bottom, Spacing.Bottom, Borders.Bottom
IsAutoLeft (inherited from FragmentResolvedInfo) | Indicates that the Left coordinate of object was calculated as auto.
IsAutoPos (inherited from FragmentResolvedInfo) | Indicates that the Left-top position of object was calculated as auto.
IsAutoTop (inherited from FragmentResolvedInfo) | Indicates that the Top coordinate of object was calculated as auto.
LeftOffset (inherited from FragmentResolvedInfo) | Returns a sum of Padding.Left, Spacing.Left, Borders.Left
RightOffset (inherited from FragmentResolvedInfo) | Returns a sum of Padding.Right, Spacing.Right, Borders.Right
TopOffset (inherited from FragmentResolvedInfo) | Returns a sum of Padding.Top, Spacing.Top, Borders.Top


TitleResolvedInfo Class

TitleResolvedInfo Class

Represents the resolved information about header/footer in table.

For a list of all members of this type, see TitleResolvedInfo Members.

System.Object

C1.C1Preview.TitleResolvedInfo

[Visual Basic]

Public Class TitleResolvedInfo

[C#]

public class TitleResolvedInfo

[Delphi]

type TitleResolvedInfo = class;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


TitleResolvedInfo Members

TitleResolvedInfo Members

TitleResolvedInfo overview

Public Fields

Group | The TableVectorGroup object representing the title.
IsAtEdge | Indicates whether the header/footer is at the edge of object (top / left / right / bottom).
Objects | RenderFragments in header/footer.
Ordinals | Ordinals of vectors in header/footer.
Size | The size of title, if title is at edge of object then this side does not include the additional space for gridline.
Sizes | Sizes of vectors in header/footer.


TitleResolvedInfo Fields

TitleResolvedInfo Fields

The fields of the TitleResolvedInfo class are listed here. For a complete list of TitleResolvedInfo class members, see the TitleResolvedInfo Members topic.

Public Fields

Group | The TableVectorGroup object representing the title.
IsAtEdge | Indicates whether the header/footer is at the edge of object (top / left / right / bottom).
Objects | RenderFragments in header/footer.
Ordinals | Ordinals of vectors in header/footer.
Size | The size of title, if title is at edge of object then this side does not include the additional space for gridline.
Sizes | Sizes of vectors in header/footer.


TitleResolvedInfo.Group Field

TitleResolvedInfo.Group Field

The TableVectorGroup object representing the title.

[Visual Basic]

Public Group As TableVectorGroup

[C#]

public TableVectorGroup Group

[Delphi]

public Group: TableVectorGroup;


TitleResolvedInfo.IsAtEdge Field

TitleResolvedInfo.IsAtEdge Field

Indicates whether the header/footer is at the edge of object (top / left / right / bottom).

[Visual Basic]

Public IsAtEdge As Boolean

[C#]

public bool IsAtEdge

[Delphi]

public IsAtEdge: Boolean;


TitleResolvedInfo.Objects Field

TitleResolvedInfo.Objects Field

RenderFragments in header/footer.

[Visual Basic]

Public Objects As ArrayList

[C#]

public ArrayList Objects

[Delphi]

public Objects: ArrayList;


TitleResolvedInfo.Ordinals Field

TitleResolvedInfo.Ordinals Field

Ordinals of vectors in header/footer.

[Visual Basic]

Public Ordinals As Integer()

[C#]

public int[] Ordinals

[Delphi]

public Ordinals: array of Int32;


TitleResolvedInfo.Size Field

TitleResolvedInfo.Size Field

The size of title, if title is at edge of object then this side does not include the additional space for gridline.

[Visual Basic]

Public Size As Double

[C#]

public double Size

[Delphi]

public Size: Double;


TitleResolvedInfo.Sizes Field

TitleResolvedInfo.Sizes Field

Sizes of vectors in header/footer.

[Visual Basic]

Public Sizes As Double

[C#]

public double Sizes

[Delphi]

public Sizes: Double;


UnicodeRangeEnum Enumeration

UnicodeRangeEnum Enumeration

Defines all unicode ranges.

[Visual Basic]

Public Enum UnicodeRangeEnum

[C#]

public enum UnicodeRangeEnum

[Delphi]

type UnicodeRangeEnum = (AlphabeticPresentationForms, ArabicPresentationFormsA, ArabicPresentationFormsB, Armenian, Arrows, BasicArabic, BasicGeorgian, BasicGreek, BasicHebrew, BasicLatin, Bengali, BlockElements, Bopomofo, BoxDrawing, Braille, CanadianAboriginalSyllabics, Cherokee, ChineseJapaneseAndKoreanSymbolsAndPunctuation, CJKCompatibility, CJKCompatibilityForms, CJKCompatibilityIdeographs, CJKMiscellaneous, CJKRadicalsSupplement, CJKUnifiedIdeographExtensionA, CJKUnifiedIdeographs, CombiningDiacriticalMarks, CombiningDiacriticalMarksForSymbols, CombiningHalfMarks, ControlPictures, CurrencySymbols, Cyrillic, Devanagari, Dingbats, EnclosedAlphanumerics, EnclosedCJKLettersAndMonths, Ethiopic, ExtendedBopomofo, GeneralPunctuation, GeometricShapes, GreekExtended, Gujarati, Gurmukhi, HalfwidthAndFullwidthForms, Hangul, HangulCompatibilityJamo, HangulJamo, Hiragana, IdeographicDescription, IPAExtensions, KangxiRadicals, Kannada, Katakana, Khmer, Lao, Latin1Supplement, LatinExtendedA, LatinExtendedAdditional, LatinExtendedB, LetterLikeSymbols, Malayalam, MathematicalOperators, MiscellaneousSymbols, MiscellaneousTechnical, Mongolian, Myanmar, NumberForms, Ogham, OpticalCharacterRecognition, Oriya, PrivateUseArea, Runic, Sinhala, SmallFormVariants, SpacingModifierLetters, Specials, SubscriptsAndSuperscripts, Surrogates, Syriac, Tamil, Telugu, Thaana, Thai, Tibetan, Yi);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

See Also

C1.C1Preview Namespace


Unit Structure

Unit Structure

Auxiliary class, provides access to LengthBase object as string, number or directly LengthBase object.

For a list of all members of this type, see Unit Members.

System.Object

System.ValueType

C1.C1Preview.Unit

[Visual Basic]

Public Structure Unit

[C#]

public struct Unit

[Delphi]

type Unit = record;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


Unit Members

Unit Members

Unit overview


UnitPoint Structure

UnitPoint Structure

Defines a point represented by two Unit structures.

For a list of all members of this type, see UnitPoint Members.

System.Object

System.ValueType

C1.C1Preview.UnitPoint

[Visual Basic]

Public Structure UnitPoint

[C#]

public struct UnitPoint

[Delphi]

type UnitPoint = record;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


UnitPoint Members

UnitPoint Members

UnitPoint overview

Public Properties

Empty | Represents a null Point.
X | Gets or sets the x-coordinate of this Point.
Y | Gets or sets the y-coordinate of this Point.

Public Methods

Parse

Converts a string to the UnitPoint structure.


UnitPoint Properties

UnitPoint Properties

The properties of the UnitPoint structure are listed here. For a complete list of UnitPoint structure members, see the UnitPoint Members topic.

Public Properties

Empty | Represents a null Point.
X | Gets or sets the x-coordinate of this Point.
Y | Gets or sets the y-coordinate of this Point.


UnitPoint.Empty Property

UnitPoint.Empty Property

Represents a null Point.

[Visual Basic]

Public Shared ReadOnly Property Empty As UnitPoint

[C#]

public static UnitPoint Empty {get;}

[Delphi]

public class property Empty: UnitPoint read get_Empty;


UnitPoint.X Property

UnitPoint.X Property

Gets or sets the x-coordinate of this Point.

[Visual Basic]

Public Property X As Unit

[C#]

public Unit X {get;set;}

[Delphi]

public property X: Unit read get_X write set_X;


UnitPoint.Y Property

UnitPoint.Y Property

Gets or sets the y-coordinate of this Point.

[Visual Basic]

Public Property Y As Unit

[C#]

public Unit Y {get;set;}

[Delphi]

public property Y: Unit read get_Y write set_Y;


UnitPoint Methods

UnitPoint Methods

The methods of the UnitPoint structure are listed here. For a complete list of UnitPoint structure members, see the UnitPoint Members topic.

Parse

Converts a string to the UnitPoint structure.


UnitPoint.Parse Method

UnitPoint.Parse Method

Converts a string to the UnitPoint structure.

[Visual Basic]

Public Shared Function Parse( _

ByVal s As String, _

ByRef result As UnitPoint, _

ByVal throwException As Boolean _

) As Boolean

[C#]

public static bool Parse(

string s,

out UnitPoint result,

bool throwException

);

[Delphi]

public class function Parse(

s: String;

out result: UnitPoint;

throwException: Boolean

): Boolean;

Parameters

s

The string to convert.

result

The UnitPoint structure.

throwException

Indicates the exception should be thrown if string can not be converted to UnitPoint.

Return Value

Returns True if no error occurs.


UnitTypeEnum Enumeration

UnitTypeEnum Enumeration

Specifies the unit of measure for the given data.

[Visual Basic]

Public Enum UnitTypeEnum

[C#]

public enum UnitTypeEnum

[Delphi]

type UnitTypeEnum = (Cm, Default, Display, Document, Inch, InHs, Mm, Pica, Pixel, Point, Twip);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
Cm | Specifies centimetre's as the unit of measure.
Display | Specifies 1/75 inch as the unit of measure.
Document | Specifies the document unit (1/300 inch) as the unit of measure.
Inch | Specifies the inch as the unit of measure.
InHs | Specifies a hundredths of an inch as the unit of measure.
Mm | Specifies the millimeter as the unit of measure.
Pica | Specifies the pica unit (1/6 inch) as the unit of measure.
Pixel | Specifies a device pixel as the unit of measure.
Point | Specifies a printer's point (1/72 inch) as the unit of measure.
Twip | Specifies a twip (1/1440 inch) as the unit of measure.

See Also

C1.C1Preview Namespace


UserActionEnum Enumeration

UserActionEnum Enumeration

Identifies a single end-user input action which can be handled by a C1Preview form control.

[Visual Basic]

Public Enum UserActionEnum

[C#]

public enum UserActionEnum

[Delphi]

type UserActionEnum = (Click, Enter, Leave, MouseDown, MouseEnter, MouseLeave, MouseUp);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
Click | The control is clicked.
Enter | The input focus enters the control.
Leave | The input focus leaves the control.
MouseDown | The mouse pointer is over the control and a mouse button is pressed.
MouseEnter | The mouse pointer enters the control.
MouseLeave | The mouse pointer leaves the control.
MouseUp | The mouse pointer is over the control and a mouse button is released.

See Also

C1.C1Preview Namespace


UserCellGroup Class

UserCellGroup Class

Represents the cells group defined by the user. Each cell group is defined by the collection of rectangles.

For a list of all members of this type, see UserCellGroup Members.

System.Object

C1.C1Preview.UserCellGroup

[Visual Basic]

Public Class UserCellGroup

Implements IDocumentLocation

[C#]

public class UserCellGroup : IDocumentLocation

[Delphi]

type UserCellGroup = class (TObject, IDocumentLocation);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


UserCellGroup Members

UserCellGroup Members

UserCellGroup overview

Public Properties

Owner | Gets the UserCellGroupCollection object containing this object.
Ranges | Gets the array of rectangles defining the cells in group.
Style | Gets the style of group of cells.
Table | Gets the RenderTable object containing this object.


UserCellGroup Properties

UserCellGroup Properties

The properties of the UserCellGroup class are listed here. For a complete list of UserCellGroup class members, see the UserCellGroup Members topic.

Public Properties

Owner | Gets the UserCellGroupCollection object containing this object.
Ranges | Gets the array of rectangles defining the cells in group.
Style | Gets the style of group of cells.
Table | Gets the RenderTable object containing this object.


UserCellGroup.Owner Property

UserCellGroup.Owner Property

Gets the UserCellGroupCollection object containing this object.

[Visual Basic]

Public ReadOnly Property Owner As UserCellGroupCollection

[C#]

public UserCellGroupCollection Owner {get;}

[Delphi]

public property Owner: UserCellGroupCollection read get_Owner;


UserCellGroup.Ranges Property

UserCellGroup.Ranges Property

Gets the array of rectangles defining the cells in group.

[Visual Basic]

Public ReadOnly Property Ranges As Rectangle()

[C#]

public Rectangle[] Ranges {get;}

[Delphi]

public property Ranges: array of Rectangle read get_Ranges;


UserCellGroup.Style Property

UserCellGroup.Style Property

Gets the style of group of cells.

[Visual Basic]

Public ReadOnly Property Style As Style

[C#]

public Style Style {get;}

[Delphi]

public property Style: Style read get_Style;


UserCellGroup.Table Property

UserCellGroup.Table Property

Gets the RenderTable object containing this object.

[Visual Basic]

Public ReadOnly Property Table As RenderTable

[C#]

public RenderTable Table {get;}

[Delphi]

public property Table: RenderTable read get_Table;


UserCellGroupCollection Class

UserCellGroupCollection Class

Represents the collection of UserCellGroup objects.

For a list of all members of this type, see UserCellGroupCollection Members.

System.Object

System.Collections.CollectionBase

C1.C1Preview.UserCellGroupCollection

[Visual Basic]

Public Class UserCellGroupCollection

Inherits CollectionBase

[C#]

public class UserCellGroupCollection : CollectionBase

[Delphi]

type UserCellGroupCollection = class (CollectionBase);

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


UserCellGroupCollection Members

UserCellGroupCollection Members

UserCellGroupCollection overview

Public Properties

Owner

Gets the RenderTable object containing this object.

Public Methods

GetRightBottomBounds

Gets the bounds of area of user groups.


UserCellGroupCollection Properties

UserCellGroupCollection Properties

The properties of the UserCellGroupCollection class are listed here. For a complete list of UserCellGroupCollection class members, see the UserCellGroupCollection Members topic.

Public Properties

Owner

Gets the RenderTable object containing this object.


UserCellGroupCollection.Owner Property

UserCellGroupCollection.Owner Property

Gets the RenderTable object containing this object.

[Visual Basic]

Public ReadOnly Property Owner As RenderTable

[C#]

public RenderTable Owner {get;}

[Delphi]

public property Owner: RenderTable read get_Owner;


UserCellGroupCollection Methods

UserCellGroupCollection Methods

The methods of the UserCellGroupCollection class are listed here. For a complete list of UserCellGroupCollection class members, see the UserCellGroupCollection Members topic.

Public Methods

GetRightBottomBounds

Gets the bounds of area of user groups.


UserCellGroupCollection.GetRightBottomBounds Method

UserCellGroupCollection.GetRightBottomBounds Method

Gets the bounds of area of user groups.

[Visual Basic]

Public Function GetRightBottomBounds() As Size

[C#]

public Size GetRightBottomBounds()

[Delphi]

public function GetRightBottomBounds(): Size;

Return Value

Size structure, field Width contains number of right-most column +1, field Height contains number of bottom-most row + 1.


Utils Class

Utils Class

Contains common functions.

For a list of all members of this type, see Utils Members.

System.Object

C1.C1Preview.Utils

[Visual Basic]

Public Class Utils

[C#]

public class Utils

[Delphi]

type Utils = class;

Namespace: C1.C1Preview

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


Utils Members

Utils Members

Utils overview

Public Methods

IndexInArray

Returns the index of string in array of strings. Search is case sensitive.


Utils Methods

Utils Methods

The methods of the Utils class are listed here. For a complete list of Utils class members, see the Utils Members topic.

Public Methods

IndexInArray

Returns the index of string in array of strings. Search is case sensitive.


Utils.IndexInArray Method

Utils.IndexInArray Method

Returns the index of string in array of strings. Search is case sensitive.

[Visual Basic]

Public Shared Function IndexInArray( _

ByVal a As String(), _

ByVal s As String _

) As Int32*

[C#]

public static Int32* IndexInArray(

string[] a,

string s

);

[Delphi]

public class function IndexInArray(

a: String();

s: String

): Int32*;

Parameters

a

Array of strings.

s

String to search.

Return Value

Index of string in array of -1.


C1.C1Preview.Export Namespace

C1.C1Preview.Export Namespace

C1.C1Preview.Export Hierarchy

Classes

Class | Description
BmpExportProvider |
C1dExporter |
C1dExportProvider |
ComplexExporter | Base class for all exporters working over list of pages. Derived classes must override ProcessPage method.
ComplexExporterOptionsForm |
ComplexExportProvider | Base class for all export provides working over list of pages, each page is represented as metafile.
EmfExporter | Exports the document to the metafile files. EmfExporter supports export to a stream in following format: - int - count of pages - int - length of data of first page in bytes - byte[] - data of first page - int - length of data of second page in bytes - byte[] - data of second page and so on
EmfExportProvider | Describes the export of document to the metafile files.
EmfOptionsForm |
Exporter | Base class for all exporters.
ExportOptionsFormBase |
ExportProvider | Describes the export format. Base class for all export providers.
ExportProviders | Represents the list of registered export providers.
GifExportProvider |
HtmlExporter | The HTML exporter.
HtmlExportProvider | The HTML export provider.
HtmlOptionsForm |
ImageExporter | Exports the document to the metafile files.
ImageExportProvider | Base abstract class for all image export providers. Descendant classes must override GetImageFormat() method.
ImagesOptionsForm |
JpegExportProvider |
PagesExporter | Base class for all exporters working over list of pages. Derived classes must override ProcessPage method.
PagesExportProvider | Base class for all export provides working over list of pages, each page is represented as metafile.
PdfExporter | The PDF exporter.
PdfExportProvider | The RTF export provider working over list of pages, each page is represented as metafile.
PdfOptionsForm |
PdfSecurity | Represents the security properties of PDF document.
PngExportProvider |
RtfExporter | The RTF exporter.
RtfExportProvider | The RTF export provider.
RtfOptionsForm |
TiffExportProvider |
XlsExporter | The Excel exporter.
XlsExportProvider | The Excel export provider.
XlsOptionsForm |

Enumerations

Enumeration | Description
LinksLocationsEnum | The links locations.
LinksModeEnum | The links mode.

See Also

C1.C1Preview.2 Assembly


BmpExportProvider Class

BmpExportProvider Class

For a list of all members of this type, see BmpExportProvider Members.

System.Object

C1.C1Preview.Export.ExportProvider

C1.C1Preview.Export.PagesExportProvider

C1.C1Preview.Export.ImageExportProvider

C1.C1Preview.Export.BmpExportProvider

[Visual Basic]

Public Class BmpExportProvider

Inherits ImageExportProvider

[C#]

public class BmpExportProvider : ImageExportProvider

[Delphi]

type BmpExportProvider = class (ImageExportProvider);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


BmpExportProvider Members

BmpExportProvider Members

BmpExportProvider overview

Public Properties

CanExportToStream (inherited from ExportProvider) | Gets the value indicating whether the exporter can save results to stream.
SupportedDocumentInfoFields (inherited from ExportProvider) | Gets the info about fields of DocumentInfo class which are supported by underlying exporter.


BmpExportProvider Properties

BmpExportProvider Properties

The properties of the BmpExportProvider class are listed here. For a complete list of BmpExportProvider class members, see the BmpExportProvider Members topic.

Public Properties

CanExportToStream (inherited from ExportProvider) | Gets the value indicating whether the exporter can save results to stream.
SupportedDocumentInfoFields (inherited from ExportProvider) | Gets the info about fields of DocumentInfo class which are supported by underlying exporter.


C1dExporter Class

C1dExporter Class

For a list of all members of this type, see C1dExporter Members.

System.Object

C1.C1Preview.Export.Exporter

C1.C1Preview.Export.C1dExporter

[Visual Basic]

Public Class C1dExporter

Inherits Exporter

[C#]

public class C1dExporter : Exporter

[Delphi]

type C1dExporter = class (Exporter);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


C1dExporter Members

C1dExporter Members

C1dExporter overview

Public Properties

Document (inherited from Exporter) | Gets or sets the document for export.
DocumentInfo (inherited from Exporter) | Gets or sets the DocumentInfo object.
DocumentInfoFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the fields of DocumentInfo class, this form is called from options form.
OptionsFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the options of exporter. This form will be displayed if ShowOptions is True.
Preview (inherited from Exporter) | Gets or sets value indicating whether the document must be opened after export.
Range (inherited from Exporter) | Gets or sets the range of pages that is to be exported.
RangeFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the range of document to export, this form is called from options form.
ReferenceGraphics (inherited from Exporter) | Specifies the Graphics object used in export, for example this object is used to convert EmfPlus metafiles to EmfOnly. If this property is null then the screen dc is used.
ShowOptions (inherited from Exporter) | Gets or sets value indicating whether the options dialog should be displayed before export.
UIStrings (inherited from Exporter) | Gets or sets the UIStrings object that is used to localize text messages displayed by exporter and its options form.

Public Methods

ShowOptionsDialog (inherited from Exporter)

Displays the dialog to edit options of export.


C1dExporter Properties

C1dExporter Properties

The properties of the C1dExporter class are listed here. For a complete list of C1dExporter class members, see the C1dExporter Members topic.

Public Properties

Document (inherited from Exporter) | Gets or sets the document for export.
DocumentInfo (inherited from Exporter) | Gets or sets the DocumentInfo object.
DocumentInfoFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the fields of DocumentInfo class, this form is called from options form.
OptionsFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the options of exporter. This form will be displayed if ShowOptions is True.
Preview (inherited from Exporter) | Gets or sets value indicating whether the document must be opened after export.
Range (inherited from Exporter) | Gets or sets the range of pages that is to be exported.
RangeFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the range of document to export, this form is called from options form.
ReferenceGraphics (inherited from Exporter) | Specifies the Graphics object used in export, for example this object is used to convert EmfPlus metafiles to EmfOnly. If this property is null then the screen dc is used.
ShowOptions (inherited from Exporter) | Gets or sets value indicating whether the options dialog should be displayed before export.
UIStrings (inherited from Exporter) | Gets or sets the UIStrings object that is used to localize text messages displayed by exporter and its options form.


C1dExporter Methods

C1dExporter Methods

The methods of the C1dExporter class are listed here. For a complete list of C1dExporter class members, see the C1dExporter Members topic.

Public Methods

ShowOptionsDialog (inherited from Exporter)

Displays the dialog to edit options of export.


C1dExportProvider Class

C1dExportProvider Class

For a list of all members of this type, see C1dExportProvider Members.

System.Object

C1.C1Preview.Export.ExportProvider

C1.C1Preview.Export.C1dExportProvider

[Visual Basic]

Public Class C1dExportProvider

Inherits ExportProvider

[C#]

public class C1dExportProvider : ExportProvider

[Delphi]

type C1dExportProvider = class (ExportProvider);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


C1dExportProvider Members

C1dExportProvider Members

C1dExportProvider overview

Public Properties

CanExportToStream (inherited from ExportProvider) | Gets the value indicating whether the exporter can save results to stream.
CanShowOptions (inherited from ExportProvider) | Gets the value indicating whether the exporter can show the options setup dialog.
DefaultOptionsFormClass (inherited from ExportProvider) | Gets the type of form which is used to edit export options by default.
SupportedDocumentInfoFields (inherited from ExportProvider) | Gets the info about fields of DocumentInfo class which are supported by underlying exporter.


C1dExportProvider Properties

C1dExportProvider Properties

The properties of the C1dExportProvider class are listed here. For a complete list of C1dExportProvider class members, see the C1dExportProvider Members topic.

Public Properties

CanExportToStream (inherited from ExportProvider) | Gets the value indicating whether the exporter can save results to stream.
CanShowOptions (inherited from ExportProvider) | Gets the value indicating whether the exporter can show the options setup dialog.
DefaultOptionsFormClass (inherited from ExportProvider) | Gets the type of form which is used to edit export options by default.
SupportedDocumentInfoFields (inherited from ExportProvider) | Gets the info about fields of DocumentInfo class which are supported by underlying exporter.


ComplexExporter Class

ComplexExporter Class

Base class for all exporters working over list of pages. Derived classes must override ProcessPage method.

For a list of all members of this type, see ComplexExporter Members.

System.Object

C1.C1Preview.Export.Exporter

C1.C1Preview.Export.ComplexExporter

C1.C1Preview.Export.HtmlExporter

C1.C1Preview.Export.RtfExporter

C1.C1Preview.Export.XlsExporter

[Visual Basic]

MustInherit Public Class ComplexExporter

Inherits Exporter

[C#]

public abstract class ComplexExporter : Exporter

[Delphi]

type ComplexExporter = class abstract (Exporter);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ComplexExporter Members

ComplexExporter Members

ComplexExporter overview

Public Properties

Document (inherited from Exporter) | Gets or sets the document for export.
DocumentInfo (inherited from Exporter) | Gets or sets the DocumentInfo object.
DocumentInfoFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the fields of DocumentInfo class, this form is called from options form.
ExportProvider (inherited from Exporter) | Gets the underlying ExportProvider object.
FixedPositioning | Gets or sets the value indicating whether the resulting document should match closely the exact appearance of the original document. This usually is done at the cost of preserving the original structure and/or the ease of handling of the resulting document.
OptionsFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the options of exporter. This form will be displayed if ShowOptions is True.
Paginated | Gets or sets the value indicating whether the resulting document should preserve the pagination of the original document.
Preview (inherited from Exporter) | Gets or sets value indicating whether the document must be opened after export.
Range (inherited from Exporter) | Gets or sets the range of pages that is to be exported.
RangeFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the range of document to export, this form is called from options form.
ReferenceGraphics (inherited from Exporter) | Specifies the Graphics object used in export, for example this object is used to convert EmfPlus metafiles to EmfOnly. If this property is null then the screen dc is used.
ShowOptions (inherited from Exporter) | Gets or sets value indicating whether the options dialog should be displayed before export.
UIStrings (inherited from Exporter) | Gets or sets the UIStrings object that is used to localize text messages displayed by exporter and its options form.

Public Methods

ShowOptionsDialog (inherited from Exporter)

Displays the dialog to edit options of export.


ComplexExporter Properties

ComplexExporter Properties

The properties of the ComplexExporter class are listed here. For a complete list of ComplexExporter class members, see the ComplexExporter Members topic.

Public Properties

Document (inherited from Exporter) | Gets or sets the document for export.
DocumentInfo (inherited from Exporter) | Gets or sets the DocumentInfo object.
DocumentInfoFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the fields of DocumentInfo class, this form is called from options form.
ExportProvider (inherited from Exporter) | Gets the underlying ExportProvider object.
FixedPositioning | Gets or sets the value indicating whether the resulting document should match closely the exact appearance of the original document. This usually is done at the cost of preserving the original structure and/or the ease of handling of the resulting document.
OptionsFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the options of exporter. This form will be displayed if ShowOptions is True.
Paginated | Gets or sets the value indicating whether the resulting document should preserve the pagination of the original document.
Preview (inherited from Exporter) | Gets or sets value indicating whether the document must be opened after export.
Range (inherited from Exporter) | Gets or sets the range of pages that is to be exported.
RangeFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the range of document to export, this form is called from options form.
ReferenceGraphics (inherited from Exporter) | Specifies the Graphics object used in export, for example this object is used to convert EmfPlus metafiles to EmfOnly. If this property is null then the screen dc is used.
ShowOptions (inherited from Exporter) | Gets or sets value indicating whether the options dialog should be displayed before export.
UIStrings (inherited from Exporter) | Gets or sets the UIStrings object that is used to localize text messages displayed by exporter and its options form.


ComplexExporter.FixedPositioning Property

ComplexExporter.FixedPositioning Property

Gets or sets the value indicating whether the resulting document should match closely the exact appearance of the original document. This usually is done at the cost of preserving the original structure and/or the ease of handling of the resulting document.

[Visual Basic]

Public Property FixedPositioning As Boolean

[C#]

public bool FixedPositioning {get;set;}

[Delphi]

public property FixedPositioning: Boolean read get_FixedPositioning write set_FixedPositioning;

Property Value

True if fixed positioning export, otherwise False.


ComplexExporter.Paginated Property

ComplexExporter.Paginated Property

Gets or sets the value indicating whether the resulting document should preserve the pagination of the original document.

[Visual Basic]

Public Property Paginated As Boolean

[C#]

public bool Paginated {get;set;}

[Delphi]

public property Paginated: Boolean read get_Paginated write set_Paginated;

Property Value

True if page by page export, otherwise False.


ComplexExporter Methods

ComplexExporter Methods

The methods of the ComplexExporter class are listed here. For a complete list of ComplexExporter class members, see the ComplexExporter Members topic.

Public Methods

ShowOptionsDialog (inherited from Exporter)

Displays the dialog to edit options of export.


ComplexExporterOptionsForm Class

ComplexExporterOptionsForm Class

For a list of all members of this type, see ComplexExporterOptionsForm Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Windows.Forms.Control

System.Windows.Forms.ScrollableControl

System.Windows.Forms.ContainerControl

System.Windows.Forms.Form

C1.C1Preview.Forms.BaseForm

C1.C1Preview.Export.ExportOptionsFormBase

C1.C1Preview.Export.ComplexExporterOptionsForm

C1.C1Preview.Export.HtmlOptionsForm

C1.C1Preview.Export.RtfOptionsForm

C1.C1Preview.Export.XlsOptionsForm

[Visual Basic]

Public Class ComplexExporterOptionsForm

Inherits ExportOptionsFormBase

[C#]

public class ComplexExporterOptionsForm : ExportOptionsFormBase

[Delphi]

type ComplexExporterOptionsForm = class (ExportOptionsFormBase);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ComplexExporterOptionsForm Members

ComplexExporterOptionsForm Members

ComplexExporterOptionsForm overview

Public Properties

AcceptButton (inherited from Form) | The accept button of the form. If this is set, the button is clicked whenever the user presses the ENTER key.
AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
ActiveControl (inherited from ContainerControl) | The currently active control.
ActiveMdiChild (inherited from Form) | The currently active MDI child form.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Indicates whether the opacity of the control can be adjusted.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
AutoScaleMode (inherited from ContainerControl) | Determines how the form or control will scale when screen resolution or fonts change.
AutoScrollMargin (inherited from ScrollableControl) | The margin around controls during auto scroll.
AutoScrollMinSize (inherited from ScrollableControl) | The minimum logical size for the auto scroll region.
AutoScrollPosition (inherited from ScrollableControl) | The current position of the auto-scrolling scroll bar.
AutoSizeMode (inherited from Form) | Specifies the mode by which the user interface element automatically resizes itself.
BackgroundImage (inherited from Control) | The background image used for the control.
BackgroundImageLayout (inherited from Control) | The background image layout used for the component.
BindingContext (inherited from ContainerControl) | The binding manager for the container control. This manages all bindings of child controls to lists.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CancelButton (inherited from Form) | The cancel button of the form. If this property is set, the button is clicked whenever the user presses the ESC key.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
CausesValidation (inherited from Control) | Indicates whether this component raises validation events.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ContextMenuStrip (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ControlBox (inherited from Form) | Determines whether a form has a Control/System menu box.
Controls (inherited from Control) | The collection of child controls within this control.
Created (inherited from Control) | Determines if the control has been fully created.
Cursor (inherited from Control) | The cursor that appears when the pointer moves over the control.
DataBindings (inherited from Control) | The data bindings for the control.
DesktopBounds (inherited from Form) | The bounds of this form in desktop coordinates.
DesktopLocation (inherited from Form) | The location of this form in desktop coordinates.
DialogResult (inherited from Form) | The value this form will return if displayed as a dialog box.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
Enabled (inherited from Control) | Indicates whether the control is enabled.
Focused (inherited from Control) | Determines if this control has focus.
Font (inherited from Control) | The font used to display text in the control.
ForeColor (inherited from Control) | The foreground color of this component, which is used to display text.
FormBorderStyle (inherited from Form) | Indicates the appearance and behavior of the border and title bar of the form.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HelpButton (inherited from Form) | Determines whether a form has a Help button on the caption bar.
HorizontalScroll (inherited from ScrollableControl) | Gets the horizontal scroll bar for this ScrollableControl.
Icon (inherited from Form) | Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Determines whether the form is a child of a MDI container.
IsMdiContainer (inherited from Form) | Determines whether the form is an MDI container.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
KeyPreview (inherited from Form) | Determines whether keyboard events for controls on the form are registered with the form.
Left (inherited from Control) | The upper left of the control, in container coordinates.
MainMenuStrip (inherited from Form) | Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.
MaximizeBox (inherited from Form) | Determines whether a form has a maximize box in the upper-right corner of its caption bar.
MaximumSize (inherited from Form) | The maximum size the form can be resized to.
MdiChildren (inherited from Form) | Retrieves the MDI children of this form.
MdiParent (inherited from Form) | Retrieves the MDI parent of this form.
Menu (inherited from Form) | The main menu of the form. This must be set to a component of type MainMenu.
MergedMenu (inherited from Form) | The merged menu of this form, which is used when displaying a single merged MDI menu.
MinimizeBox (inherited from Form) | Determines whether a form has a minimize box in the upper-right corner of its caption bar.
MinimumSize (inherited from Form) | The minimum size the form can be resized to.
Modal (inherited from Form) | Indicates if this form is currently being displayed as a modal dialog box.
Opacity (inherited from Form) | The opacity percentage of the control.
OwnedForms (inherited from Form) | Array of forms owned by this form.
Owner (inherited from Form) | The owner of this form.
Padding (inherited from Control) | Specifies the interior spacing of a control.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from ContainerControl) | The parent form of this container control.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
RightToLeftLayout (inherited from Form) | Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.
ShowIcon (inherited from Form) | Indicates whether an icon is displayed in the title bar of the form.
ShowInTaskbar (inherited from Form) | Determines whether the form appears in the Windows Taskbar.
SizeGripStyle (inherited from Form) | Determines when the SizeGrip will be displayed for the form.
StartPosition (inherited from Form) | Determines the position of a form when it first appears.
Tag (inherited from Control) | User-defined data associated with the object.
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
TopMost (inherited from Form) | Indicates whether the form always appears above all other forms that do not have this property set to True.
TransparencyKey (inherited from Form) | A color which will appear transparent when painted on the form.
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
VerticalScroll (inherited from ScrollableControl) | Gets the vertical scroll bar for this ScrollableControl.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
Width (inherited from Control) | The width of the control, in container coordinates.
WindowState (inherited from Form) | Determines the initial visual state of the form.

Public Events

Activated (inherited from Form) | Occurs whenever the form is activated.
AutoSizeChanged (inherited from Form) | Occurs when the AutoSize property has changed.
BackColorChanged (inherited from Control) | Event raised when the value of the BackColor property is changed on Control.
BackgroundImageChanged (inherited from Control) | Event raised when the value of the BackgroundImage property is changed on Control.
BackgroundImageLayoutChanged (inherited from Control) | Event raised when the value of the BackgroundImageLayout property is changed on Control.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
CausesValidationChanged (inherited from Control) | Event raised when the value of the CausesValidation property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
CursorChanged (inherited from Control) | Event raised when the value of the Cursor property is changed on Control.
Deactivate (inherited from Form) | Occurs whenever the form is deactivated.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
ForeColorChanged (inherited from Control) | Event raised when the value of the ForeColor property is changed on Control.
FormClosed (inherited from Form) | Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.
FormClosing (inherited from Form) | Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpButtonClicked (inherited from Form) | Event raised when the help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
InputLanguageChanged (inherited from Form) | Occurs whenever the language used for input for this form changes.
InputLanguageChanging (inherited from Form) | A request by the system to change the input language for this form. This request can be refused.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
Load (inherited from Form) | Occurs whenever the user loads the form.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Event raised when the value of the MaximizedBounds property is changed on Form.
MaximumSizeChanged (inherited from Form) | Event raised when the value of the MaximumSize property is changed on Form.
MdiChildActivate (inherited from Form) | Occurs when an MDI Child window is activated.
MenuComplete (inherited from Form) | Occurs when menu selection is completed and menu modal message loop has exited.
MenuStart (inherited from Form) | Occurs when any menu is displayed and menu modal message loop is entered.
MinimumSizeChanged (inherited from Form) | Event raised when the value of the MinimumSize property is changed on Form.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
PaddingChanged (inherited from Control) | Occurs when the Padding property has changed.
Paint (inherited from Control) | Occurs when a control needs repainting.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
ResizeBegin (inherited from Form) | Occurs when the form enters the sizing modal loop.
ResizeEnd (inherited from Form) | Occurs when the control exits the sizing modal loop.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs when the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user moves the scroll box.
Shown (inherited from Form) | Occurs whenever the form is first shown.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TextChanged (inherited from Control) | Event raised when the value of the Text property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


ComplexExporterOptionsForm Properties

ComplexExporterOptionsForm Properties

The properties of the ComplexExporterOptionsForm class are listed here. For a complete list of ComplexExporterOptionsForm class members, see the ComplexExporterOptionsForm Members topic.

Public Properties

AcceptButton (inherited from Form) | The accept button of the form. If this is set, the button is clicked whenever the user presses the ENTER key.
AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
ActiveControl (inherited from ContainerControl) | The currently active control.
ActiveMdiChild (inherited from Form) | The currently active MDI child form.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Indicates whether the opacity of the control can be adjusted.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
AutoScaleMode (inherited from ContainerControl) | Determines how the form or control will scale when screen resolution or fonts change.
AutoScrollMargin (inherited from ScrollableControl) | The margin around controls during auto scroll.
AutoScrollMinSize (inherited from ScrollableControl) | The minimum logical size for the auto scroll region.
AutoScrollPosition (inherited from ScrollableControl) | The current position of the auto-scrolling scroll bar.
AutoSizeMode (inherited from Form) | Specifies the mode by which the user interface element automatically resizes itself.
BackgroundImage (inherited from Control) | The background image used for the control.
BackgroundImageLayout (inherited from Control) | The background image layout used for the component.
BindingContext (inherited from ContainerControl) | The binding manager for the container control. This manages all bindings of child controls to lists.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CancelButton (inherited from Form) | The cancel button of the form. If this property is set, the button is clicked whenever the user presses the ESC key.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
CausesValidation (inherited from Control) | Indicates whether this component raises validation events.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ContextMenuStrip (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ControlBox (inherited from Form) | Determines whether a form has a Control/System menu box.
Controls (inherited from Control) | The collection of child controls within this control.
Created (inherited from Control) | Determines if the control has been fully created.
Cursor (inherited from Control) | The cursor that appears when the pointer moves over the control.
DataBindings (inherited from Control) | The data bindings for the control.
DesktopBounds (inherited from Form) | The bounds of this form in desktop coordinates.
DesktopLocation (inherited from Form) | The location of this form in desktop coordinates.
DialogResult (inherited from Form) | The value this form will return if displayed as a dialog box.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
Enabled (inherited from Control) | Indicates whether the control is enabled.
Focused (inherited from Control) | Determines if this control has focus.
Font (inherited from Control) | The font used to display text in the control.
ForeColor (inherited from Control) | The foreground color of this component, which is used to display text.
FormBorderStyle (inherited from Form) | Indicates the appearance and behavior of the border and title bar of the form.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HelpButton (inherited from Form) | Determines whether a form has a Help button on the caption bar.
HorizontalScroll (inherited from ScrollableControl) | Gets the horizontal scroll bar for this ScrollableControl.
Icon (inherited from Form) | Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Determines whether the form is a child of a MDI container.
IsMdiContainer (inherited from Form) | Determines whether the form is an MDI container.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
KeyPreview (inherited from Form) | Determines whether keyboard events for controls on the form are registered with the form.
Left (inherited from Control) | The upper left of the control, in container coordinates.
MainMenuStrip (inherited from Form) | Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.
MaximizeBox (inherited from Form) | Determines whether a form has a maximize box in the upper-right corner of its caption bar.
MaximumSize (inherited from Form) | The maximum size the form can be resized to.
MdiChildren (inherited from Form) | Retrieves the MDI children of this form.
MdiParent (inherited from Form) | Retrieves the MDI parent of this form.
Menu (inherited from Form) | The main menu of the form. This must be set to a component of type MainMenu.
MergedMenu (inherited from Form) | The merged menu of this form, which is used when displaying a single merged MDI menu.
MinimizeBox (inherited from Form) | Determines whether a form has a minimize box in the upper-right corner of its caption bar.
MinimumSize (inherited from Form) | The minimum size the form can be resized to.
Modal (inherited from Form) | Indicates if this form is currently being displayed as a modal dialog box.
Opacity (inherited from Form) | The opacity percentage of the control.
OwnedForms (inherited from Form) | Array of forms owned by this form.
Owner (inherited from Form) | The owner of this form.
Padding (inherited from Control) | Specifies the interior spacing of a control.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from ContainerControl) | The parent form of this container control.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
RightToLeftLayout (inherited from Form) | Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.
ShowIcon (inherited from Form) | Indicates whether an icon is displayed in the title bar of the form.
ShowInTaskbar (inherited from Form) | Determines whether the form appears in the Windows Taskbar.
SizeGripStyle (inherited from Form) | Determines when the SizeGrip will be displayed for the form.
StartPosition (inherited from Form) | Determines the position of a form when it first appears.
Tag (inherited from Control) | User-defined data associated with the object.
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
TopMost (inherited from Form) | Indicates whether the form always appears above all other forms that do not have this property set to True.
TransparencyKey (inherited from Form) | A color which will appear transparent when painted on the form.
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
VerticalScroll (inherited from ScrollableControl) | Gets the vertical scroll bar for this ScrollableControl.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
Width (inherited from Control) | The width of the control, in container coordinates.
WindowState (inherited from Form) | Determines the initial visual state of the form.


ComplexExporterOptionsForm Events

ComplexExporterOptionsForm Events

The events of the ComplexExporterOptionsForm class are listed here. For a complete list of ComplexExporterOptionsForm class members, see the ComplexExporterOptionsForm Members topic.

Public Events

Activated (inherited from Form) | Occurs whenever the form is activated.
AutoSizeChanged (inherited from Form) | Occurs when the AutoSize property has changed.
BackColorChanged (inherited from Control) | Event raised when the value of the BackColor property is changed on Control.
BackgroundImageChanged (inherited from Control) | Event raised when the value of the BackgroundImage property is changed on Control.
BackgroundImageLayoutChanged (inherited from Control) | Event raised when the value of the BackgroundImageLayout property is changed on Control.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
CausesValidationChanged (inherited from Control) | Event raised when the value of the CausesValidation property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
CursorChanged (inherited from Control) | Event raised when the value of the Cursor property is changed on Control.
Deactivate (inherited from Form) | Occurs whenever the form is deactivated.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
ForeColorChanged (inherited from Control) | Event raised when the value of the ForeColor property is changed on Control.
FormClosed (inherited from Form) | Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.
FormClosing (inherited from Form) | Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpButtonClicked (inherited from Form) | Event raised when the help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
InputLanguageChanged (inherited from Form) | Occurs whenever the language used for input for this form changes.
InputLanguageChanging (inherited from Form) | A request by the system to change the input language for this form. This request can be refused.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
Load (inherited from Form) | Occurs whenever the user loads the form.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Event raised when the value of the MaximizedBounds property is changed on Form.
MaximumSizeChanged (inherited from Form) | Event raised when the value of the MaximumSize property is changed on Form.
MdiChildActivate (inherited from Form) | Occurs when an MDI Child window is activated.
MenuComplete (inherited from Form) | Occurs when menu selection is completed and menu modal message loop has exited.
MenuStart (inherited from Form) | Occurs when any menu is displayed and menu modal message loop is entered.
MinimumSizeChanged (inherited from Form) | Event raised when the value of the MinimumSize property is changed on Form.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
PaddingChanged (inherited from Control) | Occurs when the Padding property has changed.
Paint (inherited from Control) | Occurs when a control needs repainting.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
ResizeBegin (inherited from Form) | Occurs when the form enters the sizing modal loop.
ResizeEnd (inherited from Form) | Occurs when the control exits the sizing modal loop.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs when the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user moves the scroll box.
Shown (inherited from Form) | Occurs whenever the form is first shown.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TextChanged (inherited from Control) | Event raised when the value of the Text property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


ComplexExportProvider Class

ComplexExportProvider Class

Base class for all export provides working over list of pages, each page is represented as metafile.

For a list of all members of this type, see ComplexExportProvider Members.

System.Object

C1.C1Preview.Export.ExportProvider

C1.C1Preview.Export.ComplexExportProvider

C1.C1Preview.Export.HtmlExportProvider

C1.C1Preview.Export.RtfExportProvider

C1.C1Preview.Export.XlsExportProvider

[Visual Basic]

MustInherit Public Class ComplexExportProvider

Inherits ExportProvider

[C#]

public abstract class ComplexExportProvider : ExportProvider

[Delphi]

type ComplexExportProvider = class abstract (ExportProvider);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ComplexExportProvider Members

ComplexExportProvider Members

ComplexExportProvider overview

Public Properties

CanExportToStream (inherited from ExportProvider) | Gets the value indicating whether the exporter can save results to stream.
CanShowOptions (inherited from ExportProvider) | Gets the value indicating whether the exporter can show the options setup dialog.
DefaultExtension (inherited from ExportProvider) | Default extension for output file.
DefaultOptionsFormClass (inherited from ExportProvider) | Gets the type of form which is used to edit export options by default.
FormatName (inherited from ExportProvider) | Description of format.
SupportedDocumentInfoFields (inherited from ExportProvider) | Gets the info about fields of DocumentInfo class which are supported by underlying exporter.

Public Methods

CanExportObject | Overriden. Returns True if exporter supports export of specified object.
NewExporter (inherited from ExportProvider) | Creates a new Exporter object.


ComplexExportProvider Properties

ComplexExportProvider Properties

The properties of the ComplexExportProvider class are listed here. For a complete list of ComplexExportProvider class members, see the ComplexExportProvider Members topic.

Public Properties

CanExportToStream (inherited from ExportProvider) | Gets the value indicating whether the exporter can save results to stream.
CanShowOptions (inherited from ExportProvider) | Gets the value indicating whether the exporter can show the options setup dialog.
DefaultExtension (inherited from ExportProvider) | Default extension for output file.
DefaultOptionsFormClass (inherited from ExportProvider) | Gets the type of form which is used to edit export options by default.
FormatName (inherited from ExportProvider) | Description of format.
SupportedDocumentInfoFields (inherited from ExportProvider) | Gets the info about fields of DocumentInfo class which are supported by underlying exporter.


ComplexExportProvider Methods

ComplexExportProvider Methods

The methods of the ComplexExportProvider class are listed here. For a complete list of ComplexExportProvider class members, see the ComplexExportProvider Members topic.

Public Methods

CanExportObject | Overriden. Returns True if exporter supports export of specified object.
NewExporter (inherited from ExportProvider) | Creates a new Exporter object.


ComplexExportProvider.CanExportObject Method

ComplexExportProvider.CanExportObject Method

Returns True if exporter supports export of specified object.

[Visual Basic]

Overrides Public Function CanExportObject( _

ByVal obj As Object _

) As Boolean

[C#]

override public bool CanExportObject(

object obj

);

[Delphi]

public function CanExportObject(

obj: Object

): Boolean; override;

Parameters

obj

Object to test.

Return Value

Returns True if corresponding exporter can export the specified object.


EmfExporter Class

EmfExporter Class

Exports the document to the metafile files. EmfExporter supports export to a stream in following format: - int - count of pages - int - length of data of first page in bytes - byte[] - data of first page - int - length of data of second page in bytes - byte[] - data of second page and so on

For a list of all members of this type, see EmfExporter Members.

System.Object

C1.C1Preview.Export.Exporter

C1.C1Preview.Export.PagesExporter

C1.C1Preview.Export.EmfExporter

[Visual Basic]

Public Class EmfExporter

Inherits PagesExporter

[C#]

public class EmfExporter : PagesExporter

[Delphi]

type EmfExporter = class (PagesExporter);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


EmfExporter Members

EmfExporter Members

EmfExporter overview

Public Properties

Document (inherited from Exporter) | Gets or sets the document for export.
DocumentInfo (inherited from Exporter) | Gets or sets the DocumentInfo object.
DocumentInfoFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the fields of DocumentInfo class, this form is called from options form.
EmfPlusToEmfOnly | Gets or sets value indicating whether the EmfPlus metafiles must be converted to EmfOnly.
OptionsFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the options of exporter. This form will be displayed if ShowOptions is True.
Preview (inherited from Exporter) | Gets or sets value indicating whether the document must be opened after export.
Range (inherited from Exporter) | Gets or sets the range of pages that is to be exported.
RangeFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the range of document to export, this form is called from options form.
ReferenceGraphics (inherited from Exporter) | Specifies the Graphics object used in export, for example this object is used to convert EmfPlus metafiles to EmfOnly. If this property is null then the screen dc is used.
ShowOptions (inherited from Exporter) | Gets or sets value indicating whether the options dialog should be displayed before export.
UIStrings (inherited from Exporter) | Gets or sets the UIStrings object that is used to localize text messages displayed by exporter and its options form.

Public Methods

ShowOptionsDialog (inherited from Exporter)

Displays the dialog to edit options of export.


EmfExporter Properties

EmfExporter Properties

The properties of the EmfExporter class are listed here. For a complete list of EmfExporter class members, see the EmfExporter Members topic.

Public Properties

Document (inherited from Exporter) | Gets or sets the document for export.
DocumentInfo (inherited from Exporter) | Gets or sets the DocumentInfo object.
DocumentInfoFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the fields of DocumentInfo class, this form is called from options form.
EmfPlusToEmfOnly | Gets or sets value indicating whether the EmfPlus metafiles must be converted to EmfOnly.
OptionsFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the options of exporter. This form will be displayed if ShowOptions is True.
Preview (inherited from Exporter) | Gets or sets value indicating whether the document must be opened after export.
Range (inherited from Exporter) | Gets or sets the range of pages that is to be exported.
RangeFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the range of document to export, this form is called from options form.
ReferenceGraphics (inherited from Exporter) | Specifies the Graphics object used in export, for example this object is used to convert EmfPlus metafiles to EmfOnly. If this property is null then the screen dc is used.
ShowOptions (inherited from Exporter) | Gets or sets value indicating whether the options dialog should be displayed before export.
UIStrings (inherited from Exporter) | Gets or sets the UIStrings object that is used to localize text messages displayed by exporter and its options form.


EmfExporter.EmfPlusToEmfOnly Property

EmfExporter.EmfPlusToEmfOnly Property

Gets or sets value indicating whether the EmfPlus metafiles must be converted to EmfOnly.

[Visual Basic]

Public Property EmfPlusToEmfOnly As Boolean

[C#]

public bool EmfPlusToEmfOnly {get;set;}

[Delphi]

public property EmfPlusToEmfOnly: Boolean read get_EmfPlusToEmfOnly write set_EmfPlusToEmfOnly;


EmfExporter Methods

EmfExporter Methods

The methods of the EmfExporter class are listed here. For a complete list of EmfExporter class members, see the EmfExporter Members topic.

Public Methods

ShowOptionsDialog (inherited from Exporter)

Displays the dialog to edit options of export.


EmfExportProvider Class

EmfExportProvider Class

Describes the export of document to the metafile files.

For a list of all members of this type, see EmfExportProvider Members.

System.Object

C1.C1Preview.Export.ExportProvider

C1.C1Preview.Export.PagesExportProvider

C1.C1Preview.Export.EmfExportProvider

[Visual Basic]

Public Class EmfExportProvider

Inherits PagesExportProvider

[C#]

public class EmfExportProvider : PagesExportProvider

[Delphi]

type EmfExportProvider = class (PagesExportProvider);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


EmfExportProvider Members

EmfExportProvider Members

EmfExportProvider overview

Public Properties

DefaultExtension | Overriden. Default extension for output file.
FormatName | Overriden. Description of format.
SupportedDocumentInfoFields (inherited from ExportProvider) | Gets the info about fields of DocumentInfo class which are supported by underlying exporter.


EmfExportProvider Properties

EmfExportProvider Properties

The properties of the EmfExportProvider class are listed here. For a complete list of EmfExportProvider class members, see the EmfExportProvider Members topic.

Public Properties

DefaultExtension | Overriden. Default extension for output file.
FormatName | Overriden. Description of format.
SupportedDocumentInfoFields (inherited from ExportProvider) | Gets the info about fields of DocumentInfo class which are supported by underlying exporter.


EmfExportProvider.DefaultExtension Property

EmfExportProvider.DefaultExtension Property

Default extension for output file.

[Visual Basic]

Overrides Public ReadOnly Property DefaultExtension As String

[C#]

override public string DefaultExtension {get;}

[Delphi]

public property DefaultExtension: String read get_DefaultExtension;


EmfExportProvider.FormatName Property

EmfExportProvider.FormatName Property

Description of format.

[Visual Basic]

Overrides Public ReadOnly Property FormatName As String

[C#]

override public string FormatName {get;}

[Delphi]

public property FormatName: String read get_FormatName;


EmfOptionsForm Class

EmfOptionsForm Class

For a list of all members of this type, see EmfOptionsForm Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Windows.Forms.Control

System.Windows.Forms.ScrollableControl

System.Windows.Forms.ContainerControl

System.Windows.Forms.Form

C1.C1Preview.Forms.BaseForm

C1.C1Preview.Export.ExportOptionsFormBase

C1.C1Preview.Export.EmfOptionsForm

[Visual Basic]

Public Class EmfOptionsForm

Inherits ExportOptionsFormBase

[C#]

public class EmfOptionsForm : ExportOptionsFormBase

[Delphi]

type EmfOptionsForm = class (ExportOptionsFormBase);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


EmfOptionsForm Members

EmfOptionsForm Members

EmfOptionsForm overview

Public Properties

AcceptButton (inherited from Form) | The accept button of the form. If this is set, the button is clicked whenever the user presses the ENTER key.
AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
ActiveControl (inherited from ContainerControl) | The currently active control.
ActiveMdiChild (inherited from Form) | The currently active MDI child form.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Indicates whether the opacity of the control can be adjusted.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
AutoScaleMode (inherited from ContainerControl) | Determines how the form or control will scale when screen resolution or fonts change.
AutoScrollMargin (inherited from ScrollableControl) | The margin around controls during auto scroll.
AutoScrollMinSize (inherited from ScrollableControl) | The minimum logical size for the auto scroll region.
AutoScrollPosition (inherited from ScrollableControl) | The current position of the auto-scrolling scroll bar.
AutoSizeMode (inherited from Form) | Specifies the mode by which the user interface element automatically resizes itself.
BackgroundImage (inherited from Control) | The background image used for the control.
BackgroundImageLayout (inherited from Control) | The background image layout used for the component.
BindingContext (inherited from ContainerControl) | The binding manager for the container control. This manages all bindings of child controls to lists.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CancelButton (inherited from Form) | The cancel button of the form. If this property is set, the button is clicked whenever the user presses the ESC key.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
CausesValidation (inherited from Control) | Indicates whether this component raises validation events.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ContextMenuStrip (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ControlBox (inherited from Form) | Determines whether a form has a Control/System menu box.
Controls (inherited from Control) | The collection of child controls within this control.
Created (inherited from Control) | Determines if the control has been fully created.
Cursor (inherited from Control) | The cursor that appears when the pointer moves over the control.
DataBindings (inherited from Control) | The data bindings for the control.
DesktopBounds (inherited from Form) | The bounds of this form in desktop coordinates.
DesktopLocation (inherited from Form) | The location of this form in desktop coordinates.
DialogResult (inherited from Form) | The value this form will return if displayed as a dialog box.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
Enabled (inherited from Control) | Indicates whether the control is enabled.
Focused (inherited from Control) | Determines if this control has focus.
Font (inherited from Control) | The font used to display text in the control.
ForeColor (inherited from Control) | The foreground color of this component, which is used to display text.
FormBorderStyle (inherited from Form) | Indicates the appearance and behavior of the border and title bar of the form.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HelpButton (inherited from Form) | Determines whether a form has a Help button on the caption bar.
HorizontalScroll (inherited from ScrollableControl) | Gets the horizontal scroll bar for this ScrollableControl.
Icon (inherited from Form) | Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Determines whether the form is a child of a MDI container.
IsMdiContainer (inherited from Form) | Determines whether the form is an MDI container.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
KeyPreview (inherited from Form) | Determines whether keyboard events for controls on the form are registered with the form.
Left (inherited from Control) | The upper left of the control, in container coordinates.
MainMenuStrip (inherited from Form) | Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.
MaximizeBox (inherited from Form) | Determines whether a form has a maximize box in the upper-right corner of its caption bar.
MaximumSize (inherited from Form) | The maximum size the form can be resized to.
MdiChildren (inherited from Form) | Retrieves the MDI children of this form.
MdiParent (inherited from Form) | Retrieves the MDI parent of this form.
Menu (inherited from Form) | The main menu of the form. This must be set to a component of type MainMenu.
MergedMenu (inherited from Form) | The merged menu of this form, which is used when displaying a single merged MDI menu.
MinimizeBox (inherited from Form) | Determines whether a form has a minimize box in the upper-right corner of its caption bar.
MinimumSize (inherited from Form) | The minimum size the form can be resized to.
Modal (inherited from Form) | Indicates if this form is currently being displayed as a modal dialog box.
Opacity (inherited from Form) | The opacity percentage of the control.
OwnedForms (inherited from Form) | Array of forms owned by this form.
Owner (inherited from Form) | The owner of this form.
Padding (inherited from Control) | Specifies the interior spacing of a control.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from ContainerControl) | The parent form of this container control.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
RightToLeftLayout (inherited from Form) | Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.
ShowIcon (inherited from Form) | Indicates whether an icon is displayed in the title bar of the form.
ShowInTaskbar (inherited from Form) | Determines whether the form appears in the Windows Taskbar.
SizeGripStyle (inherited from Form) | Determines when the SizeGrip will be displayed for the form.
StartPosition (inherited from Form) | Determines the position of a form when it first appears.
Tag (inherited from Control) | User-defined data associated with the object.
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
TopMost (inherited from Form) | Indicates whether the form always appears above all other forms that do not have this property set to True.
TransparencyKey (inherited from Form) | A color which will appear transparent when painted on the form.
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
VerticalScroll (inherited from ScrollableControl) | Gets the vertical scroll bar for this ScrollableControl.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
Width (inherited from Control) | The width of the control, in container coordinates.
WindowState (inherited from Form) | Determines the initial visual state of the form.

Public Events

Activated (inherited from Form) | Occurs whenever the form is activated.
AutoSizeChanged (inherited from Form) | Occurs when the AutoSize property has changed.
BackColorChanged (inherited from Control) | Event raised when the value of the BackColor property is changed on Control.
BackgroundImageChanged (inherited from Control) | Event raised when the value of the BackgroundImage property is changed on Control.
BackgroundImageLayoutChanged (inherited from Control) | Event raised when the value of the BackgroundImageLayout property is changed on Control.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
CausesValidationChanged (inherited from Control) | Event raised when the value of the CausesValidation property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
CursorChanged (inherited from Control) | Event raised when the value of the Cursor property is changed on Control.
Deactivate (inherited from Form) | Occurs whenever the form is deactivated.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
ForeColorChanged (inherited from Control) | Event raised when the value of the ForeColor property is changed on Control.
FormClosed (inherited from Form) | Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.
FormClosing (inherited from Form) | Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpButtonClicked (inherited from Form) | Event raised when the help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
InputLanguageChanged (inherited from Form) | Occurs whenever the language used for input for this form changes.
InputLanguageChanging (inherited from Form) | A request by the system to change the input language for this form. This request can be refused.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
Load (inherited from Form) | Occurs whenever the user loads the form.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Event raised when the value of the MaximizedBounds property is changed on Form.
MaximumSizeChanged (inherited from Form) | Event raised when the value of the MaximumSize property is changed on Form.
MdiChildActivate (inherited from Form) | Occurs when an MDI Child window is activated.
MenuComplete (inherited from Form) | Occurs when menu selection is completed and menu modal message loop has exited.
MenuStart (inherited from Form) | Occurs when any menu is displayed and menu modal message loop is entered.
MinimumSizeChanged (inherited from Form) | Event raised when the value of the MinimumSize property is changed on Form.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
PaddingChanged (inherited from Control) | Occurs when the Padding property has changed.
Paint (inherited from Control) | Occurs when a control needs repainting.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
ResizeBegin (inherited from Form) | Occurs when the form enters the sizing modal loop.
ResizeEnd (inherited from Form) | Occurs when the control exits the sizing modal loop.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs when the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user moves the scroll box.
Shown (inherited from Form) | Occurs whenever the form is first shown.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TextChanged (inherited from Control) | Event raised when the value of the Text property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


EmfOptionsForm Properties

EmfOptionsForm Properties

The properties of the EmfOptionsForm class are listed here. For a complete list of EmfOptionsForm class members, see the EmfOptionsForm Members topic.

Public Properties

AcceptButton (inherited from Form) | The accept button of the form. If this is set, the button is clicked whenever the user presses the ENTER key.
AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
ActiveControl (inherited from ContainerControl) | The currently active control.
ActiveMdiChild (inherited from Form) | The currently active MDI child form.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Indicates whether the opacity of the control can be adjusted.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
AutoScaleMode (inherited from ContainerControl) | Determines how the form or control will scale when screen resolution or fonts change.
AutoScrollMargin (inherited from ScrollableControl) | The margin around controls during auto scroll.
AutoScrollMinSize (inherited from ScrollableControl) | The minimum logical size for the auto scroll region.
AutoScrollPosition (inherited from ScrollableControl) | The current position of the auto-scrolling scroll bar.
AutoSizeMode (inherited from Form) | Specifies the mode by which the user interface element automatically resizes itself.
BackgroundImage (inherited from Control) | The background image used for the control.
BackgroundImageLayout (inherited from Control) | The background image layout used for the component.
BindingContext (inherited from ContainerControl) | The binding manager for the container control. This manages all bindings of child controls to lists.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CancelButton (inherited from Form) | The cancel button of the form. If this property is set, the button is clicked whenever the user presses the ESC key.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
CausesValidation (inherited from Control) | Indicates whether this component raises validation events.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ContextMenuStrip (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ControlBox (inherited from Form) | Determines whether a form has a Control/System menu box.
Controls (inherited from Control) | The collection of child controls within this control.
Created (inherited from Control) | Determines if the control has been fully created.
Cursor (inherited from Control) | The cursor that appears when the pointer moves over the control.
DataBindings (inherited from Control) | The data bindings for the control.
DesktopBounds (inherited from Form) | The bounds of this form in desktop coordinates.
DesktopLocation (inherited from Form) | The location of this form in desktop coordinates.
DialogResult (inherited from Form) | The value this form will return if displayed as a dialog box.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
Enabled (inherited from Control) | Indicates whether the control is enabled.
Focused (inherited from Control) | Determines if this control has focus.
Font (inherited from Control) | The font used to display text in the control.
ForeColor (inherited from Control) | The foreground color of this component, which is used to display text.
FormBorderStyle (inherited from Form) | Indicates the appearance and behavior of the border and title bar of the form.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HelpButton (inherited from Form) | Determines whether a form has a Help button on the caption bar.
HorizontalScroll (inherited from ScrollableControl) | Gets the horizontal scroll bar for this ScrollableControl.
Icon (inherited from Form) | Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Determines whether the form is a child of a MDI container.
IsMdiContainer (inherited from Form) | Determines whether the form is an MDI container.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
KeyPreview (inherited from Form) | Determines whether keyboard events for controls on the form are registered with the form.
Left (inherited from Control) | The upper left of the control, in container coordinates.
MainMenuStrip (inherited from Form) | Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.
MaximizeBox (inherited from Form) | Determines whether a form has a maximize box in the upper-right corner of its caption bar.
MaximumSize (inherited from Form) | The maximum size the form can be resized to.
MdiChildren (inherited from Form) | Retrieves the MDI children of this form.
MdiParent (inherited from Form) | Retrieves the MDI parent of this form.
Menu (inherited from Form) | The main menu of the form. This must be set to a component of type MainMenu.
MergedMenu (inherited from Form) | The merged menu of this form, which is used when displaying a single merged MDI menu.
MinimizeBox (inherited from Form) | Determines whether a form has a minimize box in the upper-right corner of its caption bar.
MinimumSize (inherited from Form) | The minimum size the form can be resized to.
Modal (inherited from Form) | Indicates if this form is currently being displayed as a modal dialog box.
Opacity (inherited from Form) | The opacity percentage of the control.
OwnedForms (inherited from Form) | Array of forms owned by this form.
Owner (inherited from Form) | The owner of this form.
Padding (inherited from Control) | Specifies the interior spacing of a control.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from ContainerControl) | The parent form of this container control.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
RightToLeftLayout (inherited from Form) | Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.
ShowIcon (inherited from Form) | Indicates whether an icon is displayed in the title bar of the form.
ShowInTaskbar (inherited from Form) | Determines whether the form appears in the Windows Taskbar.
SizeGripStyle (inherited from Form) | Determines when the SizeGrip will be displayed for the form.
StartPosition (inherited from Form) | Determines the position of a form when it first appears.
Tag (inherited from Control) | User-defined data associated with the object.
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
TopMost (inherited from Form) | Indicates whether the form always appears above all other forms that do not have this property set to True.
TransparencyKey (inherited from Form) | A color which will appear transparent when painted on the form.
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
VerticalScroll (inherited from ScrollableControl) | Gets the vertical scroll bar for this ScrollableControl.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
Width (inherited from Control) | The width of the control, in container coordinates.
WindowState (inherited from Form) | Determines the initial visual state of the form.


EmfOptionsForm Events

EmfOptionsForm Events

The events of the EmfOptionsForm class are listed here. For a complete list of EmfOptionsForm class members, see the EmfOptionsForm Members topic.

Public Events

Activated (inherited from Form) | Occurs whenever the form is activated.
AutoSizeChanged (inherited from Form) | Occurs when the AutoSize property has changed.
BackColorChanged (inherited from Control) | Event raised when the value of the BackColor property is changed on Control.
BackgroundImageChanged (inherited from Control) | Event raised when the value of the BackgroundImage property is changed on Control.
BackgroundImageLayoutChanged (inherited from Control) | Event raised when the value of the BackgroundImageLayout property is changed on Control.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
CausesValidationChanged (inherited from Control) | Event raised when the value of the CausesValidation property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
CursorChanged (inherited from Control) | Event raised when the value of the Cursor property is changed on Control.
Deactivate (inherited from Form) | Occurs whenever the form is deactivated.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
ForeColorChanged (inherited from Control) | Event raised when the value of the ForeColor property is changed on Control.
FormClosed (inherited from Form) | Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.
FormClosing (inherited from Form) | Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpButtonClicked (inherited from Form) | Event raised when the help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
InputLanguageChanged (inherited from Form) | Occurs whenever the language used for input for this form changes.
InputLanguageChanging (inherited from Form) | A request by the system to change the input language for this form. This request can be refused.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
Load (inherited from Form) | Occurs whenever the user loads the form.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Event raised when the value of the MaximizedBounds property is changed on Form.
MaximumSizeChanged (inherited from Form) | Event raised when the value of the MaximumSize property is changed on Form.
MdiChildActivate (inherited from Form) | Occurs when an MDI Child window is activated.
MenuComplete (inherited from Form) | Occurs when menu selection is completed and menu modal message loop has exited.
MenuStart (inherited from Form) | Occurs when any menu is displayed and menu modal message loop is entered.
MinimumSizeChanged (inherited from Form) | Event raised when the value of the MinimumSize property is changed on Form.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
PaddingChanged (inherited from Control) | Occurs when the Padding property has changed.
Paint (inherited from Control) | Occurs when a control needs repainting.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
ResizeBegin (inherited from Form) | Occurs when the form enters the sizing modal loop.
ResizeEnd (inherited from Form) | Occurs when the control exits the sizing modal loop.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs when the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user moves the scroll box.
Shown (inherited from Form) | Occurs whenever the form is first shown.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TextChanged (inherited from Control) | Event raised when the value of the Text property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


Exporter Class

Exporter Class

Base class for all exporters.

For a list of all members of this type, see Exporter Members.

System.Object

C1.C1Preview.Export.Exporter

C1.C1Preview.Export.C1dExporter

C1.C1Preview.Export.ComplexExporter

C1.C1Preview.Export.PagesExporter

[Visual Basic]

MustInherit Public Class Exporter

[C#]

public abstract class Exporter

[Delphi]

type Exporter = class abstract;

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


Exporter Members

Exporter Members

Exporter overview

Public Properties

Document | Gets or sets the document for export.
DocumentInfo | Gets or sets the DocumentInfo object.
DocumentInfoFormClass | Gets or sets the type of form which will be used to edit the fields of DocumentInfo class, this form is called from options form.
ExportProvider | Gets the underlying ExportProvider object.
OptionsFormClass | Gets or sets the type of form which will be used to edit the options of exporter. This form will be displayed if ShowOptions is True.
Preview | Gets or sets value indicating whether the document must be opened after export.
Range | Gets or sets the range of pages that is to be exported.
RangeFormClass | Gets or sets the type of form which will be used to edit the range of document to export, this form is called from options form.
ReferenceGraphics | Specifies the Graphics object used in export, for example this object is used to convert EmfPlus metafiles to EmfOnly. If this property is null then the screen dc is used.
ShowOptions | Gets or sets value indicating whether the options dialog should be displayed before export.
UIStrings | Gets or sets the UIStrings object that is used to localize text messages displayed by exporter and its options form.

Public Methods

Export | Overloaded. Performs export to stream. Not all exporters support export to stream to check this use property CanExportToStream of corresponding ExportProvider.
ShowOptionsDialog | Displays the dialog to edit options of export.


Exporter Properties

Exporter Properties

The properties of the Exporter class are listed here. For a complete list of Exporter class members, see the Exporter Members topic.

Public Properties

Document | Gets or sets the document for export.
DocumentInfo | Gets or sets the DocumentInfo object.
DocumentInfoFormClass | Gets or sets the type of form which will be used to edit the fields of DocumentInfo class, this form is called from options form.
ExportProvider | Gets the underlying ExportProvider object.
OptionsFormClass | Gets or sets the type of form which will be used to edit the options of exporter. This form will be displayed if ShowOptions is True.
Preview | Gets or sets value indicating whether the document must be opened after export.
Range | Gets or sets the range of pages that is to be exported.
RangeFormClass | Gets or sets the type of form which will be used to edit the range of document to export, this form is called from options form.
ReferenceGraphics | Specifies the Graphics object used in export, for example this object is used to convert EmfPlus metafiles to EmfOnly. If this property is null then the screen dc is used.
ShowOptions | Gets or sets value indicating whether the options dialog should be displayed before export.
UIStrings | Gets or sets the UIStrings object that is used to localize text messages displayed by exporter and its options form.


Exporter.Document Property

Exporter.Document Property

Gets or sets the document for export.

[Visual Basic]

Public Property Document As Object

[C#]

public object Document {get;set;}

[Delphi]

public property Document: Object read get_Document write set_Document;


Exporter.DocumentInfo Property

Exporter.DocumentInfo Property

Gets or sets the DocumentInfo object.

[Visual Basic]

Public Property DocumentInfo As DocumentInfo

[C#]

public DocumentInfo DocumentInfo {get;set;}

[Delphi]

public property DocumentInfo: DocumentInfo read get_DocumentInfo write set_DocumentInfo;


Exporter.DocumentInfoFormClass Property

Exporter.DocumentInfoFormClass Property

Gets or sets the type of form which will be used to edit the fields of DocumentInfo class, this form is called from options form.

[Visual Basic]

Public Property DocumentInfoFormClass As Type

[C#]

public Type DocumentInfoFormClass {get;set;}

[Delphi]

public property DocumentInfoFormClass: Type read get_DocumentInfoFormClass write set_DocumentInfoFormClass;


Exporter.ExportProvider Property

Exporter.ExportProvider Property

Gets the underlying ExportProvider object.

[Visual Basic]

Overridable MustInherit Public ReadOnly Property ExportProvider As ExportProvider

[C#]

virtual abstract public ExportProvider ExportProvider {get;}

[Delphi]

public property ExportProvider: ExportProvider read get_ExportProvider;


Exporter.OptionsFormClass Property

Exporter.OptionsFormClass Property

Gets or sets the type of form which will be used to edit the options of exporter. This form will be displayed if ShowOptions is True.

[Visual Basic]

Public Property OptionsFormClass As Type

[C#]

public Type OptionsFormClass {get;set;}

[Delphi]

public property OptionsFormClass: Type read get_OptionsFormClass write set_OptionsFormClass;


Exporter.Preview Property

Exporter.Preview Property

Gets or sets value indicating whether the document must be opened after export.

[Visual Basic]

Public Property Preview As Boolean

[C#]

public bool Preview {get;set;}

[Delphi]

public property Preview: Boolean read get_Preview write set_Preview;


Exporter.Range Property

Exporter.Range Property

Gets or sets the range of pages that is to be exported.

[Visual Basic]

Public Property Range As OutputRange

[C#]

public OutputRange Range {get;set;}

[Delphi]

public property Range: OutputRange read get_Range write set_Range;


Exporter.RangeFormClass Property

Exporter.RangeFormClass Property

Gets or sets the type of form which will be used to edit the range of document to export, this form is called from options form.

[Visual Basic]

Public Property RangeFormClass As Type

[C#]

public Type RangeFormClass {get;set;}

[Delphi]

public property RangeFormClass: Type read get_RangeFormClass write set_RangeFormClass;


Exporter.ReferenceGraphics Property

Exporter.ReferenceGraphics Property

Specifies the Graphics object used in export, for example this object is used to convert EmfPlus metafiles to EmfOnly. If this property is null then the screen dc is used.

[Visual Basic]

Public Property ReferenceGraphics As Graphics

[C#]

public Graphics ReferenceGraphics {get;set;}

[Delphi]

public property ReferenceGraphics: Graphics read get_ReferenceGraphics write set_ReferenceGraphics;


Exporter.ShowOptions Property

Exporter.ShowOptions Property

Gets or sets value indicating whether the options dialog should be displayed before export.

[Visual Basic]

Public Property ShowOptions As Boolean

[C#]

public bool ShowOptions {get;set;}

[Delphi]

public property ShowOptions: Boolean read get_ShowOptions write set_ShowOptions;


Exporter.UIStrings Property

Exporter.UIStrings Property

Gets or sets the UIStrings object that is used to localize text messages displayed by exporter and its options form.

[Visual Basic]

Public Property UIStrings As UIStrings

[C#]

public UIStrings UIStrings {get;set;}

[Delphi]

public property UIStrings: UIStrings read get_UIStrings write set_UIStrings;


Exporter Methods

Exporter Methods

The methods of the Exporter class are listed here. For a complete list of Exporter class members, see the Exporter Members topic.

Public Methods

Export | Overloaded. Performs export to stream. Not all exporters support export to stream to check this use property CanExportToStream of corresponding ExportProvider.
ShowOptionsDialog | Displays the dialog to edit options of export.


Exporter.Export Method

Exporter.Export Method

Overload List

Performs export to stream. Not all exporters support export to stream to check this use property CanExportToStream of corresponding ExportProvider.

[Visual Basic] Overloads Public Sub Export(Stream)

[C#] public void Export(Stream);

[Delphi] public procedure Export(Stream); overload;

Performs export.

[Visual Basic] Overloads Public Sub Export(String)

[C#] public void Export(string);

[Delphi] public procedure Export(String); overload;


Exporter.Export Method (Stream)

Exporter.Export Method (Stream)

Previous Next

Performs export to stream. Not all exporters support export to stream to check this use property CanExportToStream of corresponding ExportProvider.

[Visual Basic]

Overloads Public Sub Export( _

ByVal stream As Stream _

)

[C#]

public void Export(

Stream stream

);

[Delphi]

public procedure Export(

stream: Stream

); overload;

Parameters

stream

Stream object to store results of export.


Exporter.Export Method (String)

Exporter.Export Method (String)

Previous Next

Performs export.

[Visual Basic]

Overloads Public Sub Export( _

ByVal fileName As String _

)

[C#]

public void Export(

string fileName

);

[Delphi]

public procedure Export(

fileName: String

); overload;

Parameters

fileName

Name of output file.


Exporter.ShowOptionsDialog Method

Exporter.ShowOptionsDialog Method

Displays the dialog to edit options of export.

[Visual Basic]

Overridable Public Function ShowOptionsDialog() As Boolean

[C#]

virtual public bool ShowOptionsDialog()

[Delphi]

public function ShowOptionsDialog(): Boolean; virtual;

Return Value

Returns True if dialog was displayed successfully and user press OK.


ExportOptionsFormBase Class

ExportOptionsFormBase Class

For a list of all members of this type, see ExportOptionsFormBase Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Windows.Forms.Control

System.Windows.Forms.ScrollableControl

System.Windows.Forms.ContainerControl

System.Windows.Forms.Form

C1.C1Preview.Forms.BaseForm

C1.C1Preview.Export.ExportOptionsFormBase

C1.C1Preview.Export.ComplexExporterOptionsForm

C1.C1Preview.Export.EmfOptionsForm

C1.C1Preview.Export.ImagesOptionsForm

C1.C1Preview.Export.PdfOptionsForm

[Visual Basic]

Public Class ExportOptionsFormBase

Inherits BaseForm

[C#]

public class ExportOptionsFormBase : BaseForm

[Delphi]

type ExportOptionsFormBase = class (BaseForm);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ExportOptionsFormBase Members

ExportOptionsFormBase Members

ExportOptionsFormBase overview

Public Properties

AcceptButton (inherited from Form) | The accept button of the form. If this is set, the button is clicked whenever the user presses the ENTER key.
AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
ActiveControl (inherited from ContainerControl) | The currently active control.
ActiveMdiChild (inherited from Form) | The currently active MDI child form.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Indicates whether the opacity of the control can be adjusted.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
AutoScaleMode (inherited from ContainerControl) | Determines how the form or control will scale when screen resolution or fonts change.
AutoScrollMargin (inherited from ScrollableControl) | The margin around controls during auto scroll.
AutoScrollMinSize (inherited from ScrollableControl) | The minimum logical size for the auto scroll region.
AutoScrollPosition (inherited from ScrollableControl) | The current position of the auto-scrolling scroll bar.
AutoSizeMode (inherited from Form) | Specifies the mode by which the user interface element automatically resizes itself.
BackgroundImage (inherited from Control) | The background image used for the control.
BackgroundImageLayout (inherited from Control) | The background image layout used for the component.
BindingContext (inherited from ContainerControl) | The binding manager for the container control. This manages all bindings of child controls to lists.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CancelButton (inherited from Form) | The cancel button of the form. If this property is set, the button is clicked whenever the user presses the ESC key.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
CausesValidation (inherited from Control) | Indicates whether this component raises validation events.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ContextMenuStrip (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ControlBox (inherited from Form) | Determines whether a form has a Control/System menu box.
Controls (inherited from Control) | The collection of child controls within this control.
Created (inherited from Control) | Determines if the control has been fully created.
Cursor (inherited from Control) | The cursor that appears when the pointer moves over the control.
DataBindings (inherited from Control) | The data bindings for the control.
DesktopBounds (inherited from Form) | The bounds of this form in desktop coordinates.
DesktopLocation (inherited from Form) | The location of this form in desktop coordinates.
DialogResult (inherited from Form) | The value this form will return if displayed as a dialog box.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
Enabled (inherited from Control) | Indicates whether the control is enabled.
Focused (inherited from Control) | Determines if this control has focus.
Font (inherited from Control) | The font used to display text in the control.
ForeColor (inherited from Control) | The foreground color of this component, which is used to display text.
FormBorderStyle (inherited from Form) | Indicates the appearance and behavior of the border and title bar of the form.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HelpButton (inherited from Form) | Determines whether a form has a Help button on the caption bar.
HorizontalScroll (inherited from ScrollableControl) | Gets the horizontal scroll bar for this ScrollableControl.
Icon (inherited from Form) | Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Determines whether the form is a child of a MDI container.
IsMdiContainer (inherited from Form) | Determines whether the form is an MDI container.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
KeyPreview (inherited from Form) | Determines whether keyboard events for controls on the form are registered with the form.
Left (inherited from Control) | The upper left of the control, in container coordinates.
MainMenuStrip (inherited from Form) | Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.
MaximizeBox (inherited from Form) | Determines whether a form has a maximize box in the upper-right corner of its caption bar.
MaximumSize (inherited from Form) | The maximum size the form can be resized to.
MdiChildren (inherited from Form) | Retrieves the MDI children of this form.
MdiParent (inherited from Form) | Retrieves the MDI parent of this form.
Menu (inherited from Form) | The main menu of the form. This must be set to a component of type MainMenu.
MergedMenu (inherited from Form) | The merged menu of this form, which is used when displaying a single merged MDI menu.
MinimizeBox (inherited from Form) | Determines whether a form has a minimize box in the upper-right corner of its caption bar.
MinimumSize (inherited from Form) | The minimum size the form can be resized to.
Modal (inherited from Form) | Indicates if this form is currently being displayed as a modal dialog box.
Opacity (inherited from Form) | The opacity percentage of the control.
OwnedForms (inherited from Form) | Array of forms owned by this form.
Owner (inherited from Form) | The owner of this form.
Padding (inherited from Control) | Specifies the interior spacing of a control.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from ContainerControl) | The parent form of this container control.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
RightToLeftLayout (inherited from Form) | Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.
ShowIcon (inherited from Form) | Indicates whether an icon is displayed in the title bar of the form.
ShowInTaskbar (inherited from Form) | Determines whether the form appears in the Windows Taskbar.
SizeGripStyle (inherited from Form) | Determines when the SizeGrip will be displayed for the form.
StartPosition (inherited from Form) | Determines the position of a form when it first appears.
Tag (inherited from Control) | User-defined data associated with the object.
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
TopMost (inherited from Form) | Indicates whether the form always appears above all other forms that do not have this property set to True.
TransparencyKey (inherited from Form) | A color which will appear transparent when painted on the form.
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
VerticalScroll (inherited from ScrollableControl) | Gets the vertical scroll bar for this ScrollableControl.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
Width (inherited from Control) | The width of the control, in container coordinates.
WindowState (inherited from Form) | Determines the initial visual state of the form.

Public Events

Activated (inherited from Form) | Occurs whenever the form is activated.
AutoSizeChanged (inherited from Form) | Occurs when the AutoSize property has changed.
BackColorChanged (inherited from Control) | Event raised when the value of the BackColor property is changed on Control.
BackgroundImageChanged (inherited from Control) | Event raised when the value of the BackgroundImage property is changed on Control.
BackgroundImageLayoutChanged (inherited from Control) | Event raised when the value of the BackgroundImageLayout property is changed on Control.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
CausesValidationChanged (inherited from Control) | Event raised when the value of the CausesValidation property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
CursorChanged (inherited from Control) | Event raised when the value of the Cursor property is changed on Control.
Deactivate (inherited from Form) | Occurs whenever the form is deactivated.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
ForeColorChanged (inherited from Control) | Event raised when the value of the ForeColor property is changed on Control.
FormClosed (inherited from Form) | Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.
FormClosing (inherited from Form) | Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpButtonClicked (inherited from Form) | Event raised when the help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
InputLanguageChanged (inherited from Form) | Occurs whenever the language used for input for this form changes.
InputLanguageChanging (inherited from Form) | A request by the system to change the input language for this form. This request can be refused.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
Load (inherited from Form) | Occurs whenever the user loads the form.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Event raised when the value of the MaximizedBounds property is changed on Form.
MaximumSizeChanged (inherited from Form) | Event raised when the value of the MaximumSize property is changed on Form.
MdiChildActivate (inherited from Form) | Occurs when an MDI Child window is activated.
MenuComplete (inherited from Form) | Occurs when menu selection is completed and menu modal message loop has exited.
MenuStart (inherited from Form) | Occurs when any menu is displayed and menu modal message loop is entered.
MinimumSizeChanged (inherited from Form) | Event raised when the value of the MinimumSize property is changed on Form.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
PaddingChanged (inherited from Control) | Occurs when the Padding property has changed.
Paint (inherited from Control) | Occurs when a control needs repainting.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
ResizeBegin (inherited from Form) | Occurs when the form enters the sizing modal loop.
ResizeEnd (inherited from Form) | Occurs when the control exits the sizing modal loop.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs when the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user moves the scroll box.
Shown (inherited from Form) | Occurs whenever the form is first shown.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TextChanged (inherited from Control) | Event raised when the value of the Text property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


ExportOptionsFormBase Properties

ExportOptionsFormBase Properties

The properties of the ExportOptionsFormBase class are listed here. For a complete list of ExportOptionsFormBase class members, see the ExportOptionsFormBase Members topic.

Public Properties

AcceptButton (inherited from Form) | The accept button of the form. If this is set, the button is clicked whenever the user presses the ENTER key.
AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
ActiveControl (inherited from ContainerControl) | The currently active control.
ActiveMdiChild (inherited from Form) | The currently active MDI child form.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Indicates whether the opacity of the control can be adjusted.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
AutoScaleMode (inherited from ContainerControl) | Determines how the form or control will scale when screen resolution or fonts change.
AutoScrollMargin (inherited from ScrollableControl) | The margin around controls during auto scroll.
AutoScrollMinSize (inherited from ScrollableControl) | The minimum logical size for the auto scroll region.
AutoScrollPosition (inherited from ScrollableControl) | The current position of the auto-scrolling scroll bar.
AutoSizeMode (inherited from Form) | Specifies the mode by which the user interface element automatically resizes itself.
BackgroundImage (inherited from Control) | The background image used for the control.
BackgroundImageLayout (inherited from Control) | The background image layout used for the component.
BindingContext (inherited from ContainerControl) | The binding manager for the container control. This manages all bindings of child controls to lists.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CancelButton (inherited from Form) | The cancel button of the form. If this property is set, the button is clicked whenever the user presses the ESC key.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
CausesValidation (inherited from Control) | Indicates whether this component raises validation events.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ContextMenuStrip (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ControlBox (inherited from Form) | Determines whether a form has a Control/System menu box.
Controls (inherited from Control) | The collection of child controls within this control.
Created (inherited from Control) | Determines if the control has been fully created.
Cursor (inherited from Control) | The cursor that appears when the pointer moves over the control.
DataBindings (inherited from Control) | The data bindings for the control.
DesktopBounds (inherited from Form) | The bounds of this form in desktop coordinates.
DesktopLocation (inherited from Form) | The location of this form in desktop coordinates.
DialogResult (inherited from Form) | The value this form will return if displayed as a dialog box.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
Enabled (inherited from Control) | Indicates whether the control is enabled.
Focused (inherited from Control) | Determines if this control has focus.
Font (inherited from Control) | The font used to display text in the control.
ForeColor (inherited from Control) | The foreground color of this component, which is used to display text.
FormBorderStyle (inherited from Form) | Indicates the appearance and behavior of the border and title bar of the form.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HelpButton (inherited from Form) | Determines whether a form has a Help button on the caption bar.
HorizontalScroll (inherited from ScrollableControl) | Gets the horizontal scroll bar for this ScrollableControl.
Icon (inherited from Form) | Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Determines whether the form is a child of a MDI container.
IsMdiContainer (inherited from Form) | Determines whether the form is an MDI container.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
KeyPreview (inherited from Form) | Determines whether keyboard events for controls on the form are registered with the form.
Left (inherited from Control) | The upper left of the control, in container coordinates.
MainMenuStrip (inherited from Form) | Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.
MaximizeBox (inherited from Form) | Determines whether a form has a maximize box in the upper-right corner of its caption bar.
MaximumSize (inherited from Form) | The maximum size the form can be resized to.
MdiChildren (inherited from Form) | Retrieves the MDI children of this form.
MdiParent (inherited from Form) | Retrieves the MDI parent of this form.
Menu (inherited from Form) | The main menu of the form. This must be set to a component of type MainMenu.
MergedMenu (inherited from Form) | The merged menu of this form, which is used when displaying a single merged MDI menu.
MinimizeBox (inherited from Form) | Determines whether a form has a minimize box in the upper-right corner of its caption bar.
MinimumSize (inherited from Form) | The minimum size the form can be resized to.
Modal (inherited from Form) | Indicates if this form is currently being displayed as a modal dialog box.
Opacity (inherited from Form) | The opacity percentage of the control.
OwnedForms (inherited from Form) | Array of forms owned by this form.
Owner (inherited from Form) | The owner of this form.
Padding (inherited from Control) | Specifies the interior spacing of a control.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from ContainerControl) | The parent form of this container control.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
RightToLeftLayout (inherited from Form) | Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.
ShowIcon (inherited from Form) | Indicates whether an icon is displayed in the title bar of the form.
ShowInTaskbar (inherited from Form) | Determines whether the form appears in the Windows Taskbar.
SizeGripStyle (inherited from Form) | Determines when the SizeGrip will be displayed for the form.
StartPosition (inherited from Form) | Determines the position of a form when it first appears.
Tag (inherited from Control) | User-defined data associated with the object.
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
TopMost (inherited from Form) | Indicates whether the form always appears above all other forms that do not have this property set to True.
TransparencyKey (inherited from Form) | A color which will appear transparent when painted on the form.
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
VerticalScroll (inherited from ScrollableControl) | Gets the vertical scroll bar for this ScrollableControl.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
Width (inherited from Control) | The width of the control, in container coordinates.
WindowState (inherited from Form) | Determines the initial visual state of the form.


ExportOptionsFormBase Events

ExportOptionsFormBase Events

The events of the ExportOptionsFormBase class are listed here. For a complete list of ExportOptionsFormBase class members, see the ExportOptionsFormBase Members topic.

Public Events

Activated (inherited from Form) | Occurs whenever the form is activated.
AutoSizeChanged (inherited from Form) | Occurs when the AutoSize property has changed.
BackColorChanged (inherited from Control) | Event raised when the value of the BackColor property is changed on Control.
BackgroundImageChanged (inherited from Control) | Event raised when the value of the BackgroundImage property is changed on Control.
BackgroundImageLayoutChanged (inherited from Control) | Event raised when the value of the BackgroundImageLayout property is changed on Control.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
CausesValidationChanged (inherited from Control) | Event raised when the value of the CausesValidation property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
CursorChanged (inherited from Control) | Event raised when the value of the Cursor property is changed on Control.
Deactivate (inherited from Form) | Occurs whenever the form is deactivated.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
ForeColorChanged (inherited from Control) | Event raised when the value of the ForeColor property is changed on Control.
FormClosed (inherited from Form) | Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.
FormClosing (inherited from Form) | Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpButtonClicked (inherited from Form) | Event raised when the help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
InputLanguageChanged (inherited from Form) | Occurs whenever the language used for input for this form changes.
InputLanguageChanging (inherited from Form) | A request by the system to change the input language for this form. This request can be refused.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
Load (inherited from Form) | Occurs whenever the user loads the form.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Event raised when the value of the MaximizedBounds property is changed on Form.
MaximumSizeChanged (inherited from Form) | Event raised when the value of the MaximumSize property is changed on Form.
MdiChildActivate (inherited from Form) | Occurs when an MDI Child window is activated.
MenuComplete (inherited from Form) | Occurs when menu selection is completed and menu modal message loop has exited.
MenuStart (inherited from Form) | Occurs when any menu is displayed and menu modal message loop is entered.
MinimumSizeChanged (inherited from Form) | Event raised when the value of the MinimumSize property is changed on Form.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
PaddingChanged (inherited from Control) | Occurs when the Padding property has changed.
Paint (inherited from Control) | Occurs when a control needs repainting.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
ResizeBegin (inherited from Form) | Occurs when the form enters the sizing modal loop.
ResizeEnd (inherited from Form) | Occurs when the control exits the sizing modal loop.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs when the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user moves the scroll box.
Shown (inherited from Form) | Occurs whenever the form is first shown.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TextChanged (inherited from Control) | Event raised when the value of the Text property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


ExportProvider Class

ExportProvider Class

Describes the export format. Base class for all export providers.

For a list of all members of this type, see ExportProvider Members.

System.Object

C1.C1Preview.Export.ExportProvider

C1.C1Preview.Export.C1dExportProvider

C1.C1Preview.Export.ComplexExportProvider

C1.C1Preview.Export.PagesExportProvider

[Visual Basic]

MustInherit Public Class ExportProvider

[C#]

public abstract class ExportProvider

[Delphi]

type ExportProvider = class abstract;

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ExportProvider Members

ExportProvider Members

ExportProvider overview

Public Properties

CanExportToStream | Gets the value indicating whether the exporter can save results to stream.
CanShowOptions | Gets the value indicating whether the exporter can show the options setup dialog.
DefaultExtension | Default extension for output file.
DefaultOptionsFormClass | Gets the type of form which is used to edit export options by default.
FormatName | Description of format.
SupportedDocumentInfoFields | Gets the info about fields of DocumentInfo class which are supported by underlying exporter.

Public Methods

CanExportObject | Returns True if exporter supports export of specified object. By default this method returns False for all objects.
CanExportRange | Returns True if exporter supports export of specified range of document. By default this method returns True for DocumentRangeTypeEnum.All.
NewExporter | Creates a new Exporter object.


ExportProvider Properties

ExportProvider Properties

The properties of the ExportProvider class are listed here. For a complete list of ExportProvider class members, see the ExportProvider Members topic.

Public Properties

CanExportToStream | Gets the value indicating whether the exporter can save results to stream.
CanShowOptions | Gets the value indicating whether the exporter can show the options setup dialog.
DefaultExtension | Default extension for output file.
DefaultOptionsFormClass | Gets the type of form which is used to edit export options by default.
FormatName | Description of format.
SupportedDocumentInfoFields | Gets the info about fields of DocumentInfo class which are supported by underlying exporter.


ExportProvider.CanExportToStream Property

ExportProvider.CanExportToStream Property

Gets the value indicating whether the exporter can save results to stream.

[Visual Basic]

Overridable Public ReadOnly Property CanExportToStream As Boolean

[C#]

virtual public bool CanExportToStream {get;}

[Delphi]

public property CanExportToStream: Boolean read get_CanExportToStream;


ExportProvider.CanShowOptions Property

ExportProvider.CanShowOptions Property

Gets the value indicating whether the exporter can show the options setup dialog.

[Visual Basic]

Overridable Public ReadOnly Property CanShowOptions As Boolean

[C#]

virtual public bool CanShowOptions {get;}

[Delphi]

public property CanShowOptions: Boolean read get_CanShowOptions;


ExportProvider.DefaultExtension Property

ExportProvider.DefaultExtension Property

Default extension for output file.

[Visual Basic]

Overridable MustInherit Public ReadOnly Property DefaultExtension As String

[C#]

virtual abstract public string DefaultExtension {get;}

[Delphi]

public property DefaultExtension: String read get_DefaultExtension;


ExportProvider.DefaultOptionsFormClass Property

ExportProvider.DefaultOptionsFormClass Property

Gets the type of form which is used to edit export options by default.

[Visual Basic]

Overridable Public ReadOnly Property DefaultOptionsFormClass As Type

[C#]

virtual public Type DefaultOptionsFormClass {get;}

[Delphi]

public property DefaultOptionsFormClass: Type read get_DefaultOptionsFormClass;


ExportProvider.FormatName Property

ExportProvider.FormatName Property

Description of format.

[Visual Basic]

Overridable MustInherit Public ReadOnly Property FormatName As String

[C#]

virtual abstract public string FormatName {get;}

[Delphi]

public property FormatName: String read get_FormatName;


ExportProvider.SupportedDocumentInfoFields Property

ExportProvider.SupportedDocumentInfoFields Property

Gets the info about fields of DocumentInfo class which are supported by underlying exporter.

[Visual Basic]

Overridable Public ReadOnly Property SupportedDocumentInfoFields As DocumentInfoFields

[C#]

virtual public DocumentInfoFields SupportedDocumentInfoFields {get;}

[Delphi]

public property SupportedDocumentInfoFields: DocumentInfoFields read get_SupportedDocumentInfoFields;


ExportProvider Methods

ExportProvider Methods

The methods of the ExportProvider class are listed here. For a complete list of ExportProvider class members, see the ExportProvider Members topic.

Public Methods

CanExportObject | Returns True if exporter supports export of specified object. By default this method returns False for all objects.
CanExportRange | Returns True if exporter supports export of specified range of document. By default this method returns True for DocumentRangeTypeEnum.All.
NewExporter | Creates a new Exporter object.


ExportProvider.CanExportObject Method

ExportProvider.CanExportObject Method

Returns True if exporter supports export of specified object. By default this method returns False for all objects.

[Visual Basic]

Overridable MustOverride Public Function CanExportObject( _

ByVal obj As Object _

) As Boolean

[C#]

virtual abstract public bool CanExportObject(

object obj

);

[Delphi]

public function CanExportObject(

obj: Object

): Boolean; virtual; abstract;

Parameters

obj

Object to test.

Return Value

Returns True if corresponding exporter can export the specified object.


ExportProvider.CanExportRange Method

ExportProvider.CanExportRange Method

Returns True if exporter supports export of specified range of document. By default this method returns True for DocumentRangeTypeEnum.All.

[Visual Basic]

Overridable Public Function CanExportRange( _

ByVal range As OutputRangeTypeEnum _

) As Boolean

[C#]

virtual public bool CanExportRange(

OutputRangeTypeEnum range

);

[Delphi]

public function CanExportRange(

range: OutputRangeTypeEnum

): Boolean; virtual;

Parameters

range

Type of range to test.

Return Value

Returns True if corresponding exporter can export the specified output range.


ExportProvider.NewExporter Method

ExportProvider.NewExporter Method

Creates a new Exporter object.

[Visual Basic]

Overridable MustOverride Public Function NewExporter() As Exporter

[C#]

virtual abstract public Exporter NewExporter()

[Delphi]

public function NewExporter():
Exporter; virtual;
abstract;

Return Value

Returns the created object.


ExportProviders Class

ExportProviders Class

Represents the list of registered export providers.

For a list of all members of this type, see ExportProviders Members.

System.Object

C1.C1Preview.Export.ExportProviders

[Visual Basic]

Public Class ExportProviders

Implements IEnumerable

[C#]

public class ExportProviders : IEnumerable

[Delphi]

type ExportProviders = class (TObject, IEnumerable);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ExportProviders Members

ExportProviders Members

ExportProviders overview

Public Properties

Count | Gets the count of registed export providers.
Item | Enumerates the export providers by index.

Public Methods

Register

Registers the export provider.


ExportProviders Properties

ExportProviders Properties

The properties of the ExportProviders class are listed here. For a complete list of ExportProviders class members, see the ExportProviders Members topic.

Public Properties

Count | Gets the count of registed export providers.
Item | Enumerates the export providers by index.


ExportProviders.Count Property

ExportProviders.Count Property

Gets the count of registed export providers.

[Visual Basic]

Public ReadOnly Property Count As Int32*

[C#]

public Int32* Count {get;}

[Delphi]

public property Count: Int32* read get_Count;


ExportProviders.Item Property

ExportProviders.Item Property

Enumerates the export providers by index.

[Visual Basic]

Public Default ReadOnly Property Item( _

ByVal index As Int32* _

) As ExportProvider

[C#]

public ExportProvider this[

Int32* index

] {get;}

[Delphi]

public property Item[

index: Int32*

]: ExportProvider read get_Item;


ExportProviders Methods

ExportProviders Methods

The methods of the ExportProviders class are listed here. For a complete list of ExportProviders class members, see the ExportProviders Members topic.

Public Methods

Register

Registers the export provider.


ExportProviders.Register Method

ExportProviders.Register Method

Registers the export provider.

[Visual Basic]

Public Shared Sub Register( _

ByVal exportProvider As ExportProvider _

)

[C#]

public static void Register(

ExportProvider exportProvider

);

[Delphi]

public class procedure Register(

exportProvider: ExportProvider

);

Parameters

exportProvider

ExportProvider object to register.


GifExportProvider Class

GifExportProvider Class

For a list of all members of this type, see GifExportProvider Members.

System.Object

C1.C1Preview.Export.ExportProvider

C1.C1Preview.Export.PagesExportProvider

C1.C1Preview.Export.ImageExportProvider

C1.C1Preview.Export.GifExportProvider

[Visual Basic]

Public Class GifExportProvider

Inherits ImageExportProvider

[C#]

public class GifExportProvider : ImageExportProvider

[Delphi]

type GifExportProvider = class (ImageExportProvider);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


GifExportProvider Members

GifExportProvider Members

GifExportProvider overview

Public Properties

CanExportToStream (inherited from ExportProvider) | Gets the value indicating whether the exporter can save results to stream.
SupportedDocumentInfoFields (inherited from ExportProvider) | Gets the info about fields of DocumentInfo class which are supported by underlying exporter.


GifExportProvider Properties

GifExportProvider Properties

The properties of the GifExportProvider class are listed here. For a complete list of GifExportProvider class members, see the GifExportProvider Members topic.

Public Properties

CanExportToStream (inherited from ExportProvider) | Gets the value indicating whether the exporter can save results to stream.
SupportedDocumentInfoFields (inherited from ExportProvider) | Gets the info about fields of DocumentInfo class which are supported by underlying exporter.


HtmlExporter Class

HtmlExporter Class

The HTML exporter.

For a list of all members of this type, see HtmlExporter Members.

System.Object

C1.C1Preview.Export.Exporter

C1.C1Preview.Export.ComplexExporter

C1.C1Preview.Export.HtmlExporter

[Visual Basic]

Public Class HtmlExporter

Inherits ComplexExporter

[C#]

public class HtmlExporter : ComplexExporter

[Delphi]

type HtmlExporter = class (ComplexExporter);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


HtmlExporter Members

HtmlExporter Members

HtmlExporter overview

Public Properties

Document (inherited from Exporter) | Gets or sets the document for export.
DocumentInfo (inherited from Exporter) | Gets or sets the DocumentInfo object.
DocumentInfoFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the fields of DocumentInfo class, this form is called from options form.
ExportNavBar | Gets or sets the template used to create the navigation bar with page numbers.
FixedPositioning (inherited from ComplexExporter) | Gets or sets the value indicating whether the resulting document should match closely the exact appearance of the original document. This usually is done at the cost of preserving the original structure and/or the ease of handling of the resulting document.
GenerateOutline | Gets or sets generate or no contents on outline entries in frame.
GeneratePageLinks | Gets or sets the value indicating whether to generate links to individual pages.
GeneratePageSeparators | Gets or sets the value indicating whether to separate pages of the original document with horizontal lines.
ImageFolder | Gets or sets the path to the image folder.
LinksLocation | Gets or sets the location of the generated links (outline entries or page numbers).
MaxHorzPageLinks | Gets or sets the maximum number of page links in a row.
OptionsFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the options of exporter. This form will be displayed if ShowOptions is True.
PagePerFile | Gets or sets the value indicating whether to export each page of the document into a separate file.
Paginated (inherited from ComplexExporter) | Gets or sets the value indicating whether the resulting document should preserve the pagination of the original document.
PreserveExactHeight | Gets or sets the value indicating whether the export module should try to preserve the exact original height of all elements. Generally, setting this property to False makes the resulting document more flexible.
Preview (inherited from Exporter) | Gets or sets value indicating whether the document must be opened after export.
Range (inherited from Exporter) | Gets or sets the range of pages that is to be exported.
RangeFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the range of document to export, this form is called from options form.
ReferenceGraphics (inherited from Exporter) | Specifies the Graphics object used in export, for example this object is used to convert EmfPlus metafiles to EmfOnly. If this property is null then the screen dc is used.
Scaling | Gets or sets the scaling coefficient applied to all elements of the resulting document, in percent
ShowOptions (inherited from Exporter) | Gets or sets value indicating whether the options dialog should be displayed before export.
UIStrings (inherited from Exporter) | Gets or sets the UIStrings object that is used to localize text messages displayed by exporter and its options form.

Public Methods

ShowOptionsDialog (inherited from Exporter)

Displays the dialog to edit options of export.


HtmlExporter Properties

HtmlExporter Properties

The properties of the HtmlExporter class are listed here. For a complete list of HtmlExporter class members, see the HtmlExporter Members topic.

Public Properties

Document (inherited from Exporter) | Gets or sets the document for export.
DocumentInfo (inherited from Exporter) | Gets or sets the DocumentInfo object.
DocumentInfoFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the fields of DocumentInfo class, this form is called from options form.
ExportNavBar | Gets or sets the template used to create the navigation bar with page numbers.
FixedPositioning (inherited from ComplexExporter) | Gets or sets the value indicating whether the resulting document should match closely the exact appearance of the original document. This usually is done at the cost of preserving the original structure and/or the ease of handling of the resulting document.
GenerateOutline | Gets or sets generate or no contents on outline entries in frame.
GeneratePageLinks | Gets or sets the value indicating whether to generate links to individual pages.
GeneratePageSeparators | Gets or sets the value indicating whether to separate pages of the original document with horizontal lines.
ImageFolder | Gets or sets the path to the image folder.
LinksLocation | Gets or sets the location of the generated links (outline entries or page numbers).
MaxHorzPageLinks | Gets or sets the maximum number of page links in a row.
OptionsFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the options of exporter. This form will be displayed if ShowOptions is True.
PagePerFile | Gets or sets the value indicating whether to export each page of the document into a separate file.
Paginated (inherited from ComplexExporter) | Gets or sets the value indicating whether the resulting document should preserve the pagination of the original document.
PreserveExactHeight | Gets or sets the value indicating whether the export module should try to preserve the exact original height of all elements. Generally, setting this property to False makes the resulting document more flexible.
Preview (inherited from Exporter) | Gets or sets value indicating whether the document must be opened after export.
Range (inherited from Exporter) | Gets or sets the range of pages that is to be exported.
RangeFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the range of document to export, this form is called from options form.
ReferenceGraphics (inherited from Exporter) | Specifies the Graphics object used in export, for example this object is used to convert EmfPlus metafiles to EmfOnly. If this property is null then the screen dc is used.
Scaling | Gets or sets the scaling coefficient applied to all elements of the resulting document, in percent
ShowOptions (inherited from Exporter) | Gets or sets value indicating whether the options dialog should be displayed before export.
UIStrings (inherited from Exporter) | Gets or sets the UIStrings object that is used to localize text messages displayed by exporter and its options form.


HtmlExporter.ExportNavBar Property

HtmlExporter.ExportNavBar Property

Gets or sets the template used to create the navigation bar with page numbers.

[Visual Basic]

Public Property ExportNavBar As String

[C#]

public string ExportNavBar {get;set;}

[Delphi]

public property ExportNavBar: String read get_ExportNavBar write set_ExportNavBar;

Property Value

The template of navigation bar with page numbers.


HtmlExporter.GenerateOutline Property

HtmlExporter.GenerateOutline Property

Gets or sets generate or no contents on outline entries in frame.

[Visual Basic]

Public Property GenerateOutline As Boolean

[C#]

public bool GenerateOutline {get;set;}

[Delphi]

public property GenerateOutline: Boolean read get_GenerateOutline write set_GenerateOutline;

Property Value

True if generate contents on outline entries in frame, otherwise False.


HtmlExporter.GeneratePageLinks Property

HtmlExporter.GeneratePageLinks Property

Gets or sets the value indicating whether to generate links to individual pages.

[Visual Basic]

Public Property GeneratePageLinks As Boolean

[C#]

public bool GeneratePageLinks {get;set;}

[Delphi]

public property GeneratePageLinks: Boolean read get_GeneratePageLinks write set_GeneratePageLinks;

Property Value

True if generate contents on page links, otherwise False.


HtmlExporter.GeneratePageSeparators Property

HtmlExporter.GeneratePageSeparators Property

Gets or sets the value indicating whether to separate pages of the original document with horizontal lines.

[Visual Basic]

Public Property GeneratePageSeparators As Boolean

[C#]

public bool GeneratePageSeparators {get;set;}

[Delphi]

public property GeneratePageSeparators: Boolean read get_GeneratePageSeparators write set_GeneratePageSeparators;

Property Value

True if generate page separators, otherwise False.


HtmlExporter.ImageFolder Property

HtmlExporter.ImageFolder Property

Gets or sets the path to the image folder.

[Visual Basic]

Public Property ImageFolder As String

[C#]

public string ImageFolder {get;set;}

[Delphi]

public property ImageFolder: String read get_ImageFolder write set_ImageFolder;

Property Value

The folder name (path) for storage of images.


HtmlExporter.LinksLocation Property

HtmlExporter.LinksLocation Property

Gets or sets the location of the generated links (outline entries or page numbers).

[Visual Basic]

Public Property LinksLocation As HtmlExporter+LinksLocationsEnum

[C#]

public HtmlExporter+LinksLocationsEnum LinksLocation {get;set;}

[Delphi]

public property LinksLocation: HtmlExporter+LinksLocationsEnum read get_LinksLocation write set_LinksLocation;

Property Value

The links locations (where contents will be).


HtmlExporter.MaxHorzPageLinks Property

HtmlExporter.MaxHorzPageLinks Property

Gets or sets the maximum number of page links in a row.

[Visual Basic]

Public Property MaxHorzPageLinks As Int32*

[C#]

public Int32* MaxHorzPageLinks {get;set;}

[Delphi]

public property MaxHorzPageLinks: Int32* read get_MaxHorzPageLinks write set_MaxHorzPageLinks;

Property Value

The maximum number of page links in a row.


HtmlExporter.PagePerFile Property

HtmlExporter.PagePerFile Property

Gets or sets the value indicating whether to export each page of the document into a separate file.

[Visual Basic]

Public Property PagePerFile As Boolean

[C#]

public bool PagePerFile {get;set;}

[Delphi]

public property PagePerFile: Boolean read get_PagePerFile write set_PagePerFile;

Property Value

True if one file per page, otherwise False.


HtmlExporter.PreserveExactHeight Property

HtmlExporter.PreserveExactHeight Property

Gets or sets the value indicating whether the export module should try to preserve the exact original height of all elements. Generally, setting this property to False makes the resulting document more flexible.

[Visual Basic]

Public Property PreserveExactHeight As Boolean

[C#]

public bool PreserveExactHeight {get;set;}

[Delphi]

public property PreserveExactHeight: Boolean read get_PreserveExactHeight write set_PreserveExactHeight;

Property Value

True if preserve exact height, otherwise False.


HtmlExporter.Scaling Property

HtmlExporter.Scaling Property

Gets or sets the scaling coefficient applied to all elements of the resulting document, in percent

[Visual Basic]

Public Property Scaling As Single

[C#]

public float Scaling {get;set;}

[Delphi]

public property Scaling: Single read get_Scaling write set_Scaling;

Property Value

The scaling coefficient value in percents.


HtmlExporter Methods

HtmlExporter Methods

The methods of the HtmlExporter class are listed here. For a complete list of HtmlExporter class members, see the HtmlExporter Members topic.

Public Methods

ShowOptionsDialog (inherited from Exporter)

Displays the dialog to edit options of export.


HtmlExporter.LinksLocationsEnum Enumeration

HtmlExporter.LinksLocationsEnum Enumeration

The links locations.

[Visual Basic]

Public Enum HtmlExporter+LinksLocationsEnum

[C#]

public enum HtmlExporter+LinksLocationsEnum

[Delphi]

type HtmlExporter+LinksLocationsEnum = (BottomFrame, LeftFrame, None, RightFrame, TopFrame, TopPage);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
BottomFrame |
LeftFrame |
None |
RightFrame |
TopFrame |
TopPage |

See Also

C1.C1Preview.Export Namespace


HtmlExporter.LinksModeEnum Enumeration

HtmlExporter.LinksModeEnum Enumeration

The links mode.

[Visual Basic]

Public Enum HtmlExporter+LinksModeEnum

[C#]

public enum HtmlExporter+LinksModeEnum

[Delphi]

type HtmlExporter+LinksModeEnum = (DocumentOutline, None, PageNumbers);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)

Members

Member name | Description
DocumentOutline |
None |
PageNumbers |

See Also

C1.C1Preview.Export Namespace


HtmlExportProvider Class

HtmlExportProvider Class

The HTML export provider.

For a list of all members of this type, see HtmlExportProvider Members.

System.Object

C1.C1Preview.Export.ExportProvider

C1.C1Preview.Export.ComplexExportProvider

C1.C1Preview.Export.HtmlExportProvider

[Visual Basic]

Public Class HtmlExportProvider

Inherits ComplexExportProvider

[C#]

public class HtmlExportProvider : ComplexExportProvider

[Delphi]

type HtmlExportProvider = class (ComplexExportProvider);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


HtmlExportProvider Members

HtmlExportProvider Members

HtmlExportProvider overview

Public Properties

DefaultExtension | Overriden. Default extension for output file.
FormatName | Overriden. Description of format.
SupportedDocumentInfoFields (inherited from ExportProvider) | Gets the info about fields of DocumentInfo class which are supported by underlying exporter.

Public Methods

CanExportObject | Overriden. Returns True if exporter supports export of specified object.
NewExporter | Overriden. Creates a new Exporter object.


HtmlExportProvider Properties

HtmlExportProvider Properties

The properties of the HtmlExportProvider class are listed here. For a complete list of HtmlExportProvider class members, see the HtmlExportProvider Members topic.

Public Properties

DefaultExtension | Overriden. Default extension for output file.
FormatName | Overriden. Description of format.
SupportedDocumentInfoFields (inherited from ExportProvider) | Gets the info about fields of DocumentInfo class which are supported by underlying exporter.


HtmlExportProvider.DefaultExtension Property

HtmlExportProvider.DefaultExtension Property

Default extension for output file.

[Visual Basic]

Overrides Public ReadOnly Property DefaultExtension As String

[C#]

override public string DefaultExtension {get;}

[Delphi]

public property DefaultExtension: String read get_DefaultExtension;


HtmlExportProvider.FormatName Property

HtmlExportProvider.FormatName Property

Description of format.

[Visual Basic]

Overrides Public ReadOnly Property FormatName As String

[C#]

override public string FormatName {get;}

[Delphi]

public property FormatName: String read get_FormatName;


HtmlExportProvider Methods

HtmlExportProvider Methods

The methods of the HtmlExportProvider class are listed here. For a complete list of HtmlExportProvider class members, see the HtmlExportProvider Members topic.

Public Methods

CanExportObject | Overriden. Returns True if exporter supports export of specified object.
NewExporter | Overriden. Creates a new Exporter object.


HtmlExportProvider.CanExportObject Method

HtmlExportProvider.CanExportObject Method

Returns True if exporter supports export of specified object.

[Visual Basic]

Overrides Public Function CanExportObject( _

ByVal obj As Object _

) As Boolean

[C#]

override public bool CanExportObject(

object obj

);

[Delphi]

public function CanExportObject(

obj: Object

): Boolean; override;

Parameters

obj

Object to test.

Return Value

Returns True if corresponding exporter can export the specified object.


HtmlExportProvider.NewExporter Method

HtmlExportProvider.NewExporter Method

Creates a new Exporter object.

[Visual Basic]

Overrides Public Function NewExporter() As Exporter

[C#]

override public Exporter NewExporter()

[Delphi]

public function NewExporter():
Exporter;
override;

Return Value

Returns the created object.


HtmlOptionsForm Class

HtmlOptionsForm Class

For a list of all members of this type, see HtmlOptionsForm Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Windows.Forms.Control

System.Windows.Forms.ScrollableControl

System.Windows.Forms.ContainerControl

System.Windows.Forms.Form

C1.C1Preview.Forms.BaseForm

C1.C1Preview.Export.ExportOptionsFormBase

C1.C1Preview.Export.ComplexExporterOptionsForm

C1.C1Preview.Export.HtmlOptionsForm

[Visual Basic]

Public Class HtmlOptionsForm

Inherits ComplexExporterOptionsForm

[C#]

public class HtmlOptionsForm : ComplexExporterOptionsForm

[Delphi]

type HtmlOptionsForm = class (ComplexExporterOptionsForm);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


HtmlOptionsForm Members

HtmlOptionsForm Members

HtmlOptionsForm overview

Public Properties

AcceptButton (inherited from Form) | The accept button of the form. If this is set, the button is clicked whenever the user presses the ENTER key.
AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
ActiveControl (inherited from ContainerControl) | The currently active control.
ActiveMdiChild (inherited from Form) | The currently active MDI child form.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Indicates whether the opacity of the control can be adjusted.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
AutoScaleMode (inherited from ContainerControl) | Determines how the form or control will scale when screen resolution or fonts change.
AutoScrollMargin (inherited from ScrollableControl) | The margin around controls during auto scroll.
AutoScrollMinSize (inherited from ScrollableControl) | The minimum logical size for the auto scroll region.
AutoScrollPosition (inherited from ScrollableControl) | The current position of the auto-scrolling scroll bar.
AutoSizeMode (inherited from Form) | Specifies the mode by which the user interface element automatically resizes itself.
BackgroundImage (inherited from Control) | The background image used for the control.
BackgroundImageLayout (inherited from Control) | The background image layout used for the component.
BindingContext (inherited from ContainerControl) | The binding manager for the container control. This manages all bindings of child controls to lists.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CancelButton (inherited from Form) | The cancel button of the form. If this property is set, the button is clicked whenever the user presses the ESC key.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
CausesValidation (inherited from Control) | Indicates whether this component raises validation events.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ContextMenuStrip (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ControlBox (inherited from Form) | Determines whether a form has a Control/System menu box.
Controls (inherited from Control) | The collection of child controls within this control.
Created (inherited from Control) | Determines if the control has been fully created.
Cursor (inherited from Control) | The cursor that appears when the pointer moves over the control.
DataBindings (inherited from Control) | The data bindings for the control.
DesktopBounds (inherited from Form) | The bounds of this form in desktop coordinates.
DesktopLocation (inherited from Form) | The location of this form in desktop coordinates.
DialogResult (inherited from Form) | The value this form will return if displayed as a dialog box.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
Enabled (inherited from Control) | Indicates whether the control is enabled.
Focused (inherited from Control) | Determines if this control has focus.
Font (inherited from Control) | The font used to display text in the control.
ForeColor (inherited from Control) | The foreground color of this component, which is used to display text.
FormBorderStyle (inherited from Form) | Indicates the appearance and behavior of the border and title bar of the form.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HelpButton (inherited from Form) | Determines whether a form has a Help button on the caption bar.
HorizontalScroll (inherited from ScrollableControl) | Gets the horizontal scroll bar for this ScrollableControl.
Icon (inherited from Form) | Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Determines whether the form is a child of a MDI container.
IsMdiContainer (inherited from Form) | Determines whether the form is an MDI container.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
KeyPreview (inherited from Form) | Determines whether keyboard events for controls on the form are registered with the form.
Left (inherited from Control) | The upper left of the control, in container coordinates.
MainMenuStrip (inherited from Form) | Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.
MaximizeBox (inherited from Form) | Determines whether a form has a maximize box in the upper-right corner of its caption bar.
MaximumSize (inherited from Form) | The maximum size the form can be resized to.
MdiChildren (inherited from Form) | Retrieves the MDI children of this form.
MdiParent (inherited from Form) | Retrieves the MDI parent of this form.
Menu (inherited from Form) | The main menu of the form. This must be set to a component of type MainMenu.
MergedMenu (inherited from Form) | The merged menu of this form, which is used when displaying a single merged MDI menu.
MinimizeBox (inherited from Form) | Determines whether a form has a minimize box in the upper-right corner of its caption bar.
MinimumSize (inherited from Form) | The minimum size the form can be resized to.
Modal (inherited from Form) | Indicates if this form is currently being displayed as a modal dialog box.
Opacity (inherited from Form) | The opacity percentage of the control.
OwnedForms (inherited from Form) | Array of forms owned by this form.
Owner (inherited from Form) | The owner of this form.
Padding (inherited from Control) | Specifies the interior spacing of a control.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from ContainerControl) | The parent form of this container control.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
RightToLeftLayout (inherited from Form) | Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.
ShowIcon (inherited from Form) | Indicates whether an icon is displayed in the title bar of the form.
ShowInTaskbar (inherited from Form) | Determines whether the form appears in the Windows Taskbar.
SizeGripStyle (inherited from Form) | Determines when the SizeGrip will be displayed for the form.
StartPosition (inherited from Form) | Determines the position of a form when it first appears.
Tag (inherited from Control) | User-defined data associated with the object.
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
TopMost (inherited from Form) | Indicates whether the form always appears above all other forms that do not have this property set to True.
TransparencyKey (inherited from Form) | A color which will appear transparent when painted on the form.
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
VerticalScroll (inherited from ScrollableControl) | Gets the vertical scroll bar for this ScrollableControl.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
Width (inherited from Control) | The width of the control, in container coordinates.
WindowState (inherited from Form) | Determines the initial visual state of the form.

Public Events

Activated (inherited from Form) | Occurs whenever the form is activated.
AutoSizeChanged (inherited from Form) | Occurs when the AutoSize property has changed.
BackColorChanged (inherited from Control) | Event raised when the value of the BackColor property is changed on Control.
BackgroundImageChanged (inherited from Control) | Event raised when the value of the BackgroundImage property is changed on Control.
BackgroundImageLayoutChanged (inherited from Control) | Event raised when the value of the BackgroundImageLayout property is changed on Control.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
CausesValidationChanged (inherited from Control) | Event raised when the value of the CausesValidation property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
CursorChanged (inherited from Control) | Event raised when the value of the Cursor property is changed on Control.
Deactivate (inherited from Form) | Occurs whenever the form is deactivated.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
ForeColorChanged (inherited from Control) | Event raised when the value of the ForeColor property is changed on Control.
FormClosed (inherited from Form) | Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.
FormClosing (inherited from Form) | Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpButtonClicked (inherited from Form) | Event raised when the help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
InputLanguageChanged (inherited from Form) | Occurs whenever the language used for input for this form changes.
InputLanguageChanging (inherited from Form) | A request by the system to change the input language for this form. This request can be refused.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
Load (inherited from Form) | Occurs whenever the user loads the form.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Event raised when the value of the MaximizedBounds property is changed on Form.
MaximumSizeChanged (inherited from Form) | Event raised when the value of the MaximumSize property is changed on Form.
MdiChildActivate (inherited from Form) | Occurs when an MDI Child window is activated.
MenuComplete (inherited from Form) | Occurs when menu selection is completed and menu modal message loop has exited.
MenuStart (inherited from Form) | Occurs when any menu is displayed and menu modal message loop is entered.
MinimumSizeChanged (inherited from Form) | Event raised when the value of the MinimumSize property is changed on Form.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
PaddingChanged (inherited from Control) | Occurs when the Padding property has changed.
Paint (inherited from Control) | Occurs when a control needs repainting.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
ResizeBegin (inherited from Form) | Occurs when the form enters the sizing modal loop.
ResizeEnd (inherited from Form) | Occurs when the control exits the sizing modal loop.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs when the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user moves the scroll box.
Shown (inherited from Form) | Occurs whenever the form is first shown.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TextChanged (inherited from Control) | Event raised when the value of the Text property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


HtmlOptionsForm Properties

HtmlOptionsForm Properties

The properties of the HtmlOptionsForm class are listed here. For a complete list of HtmlOptionsForm class members, see the HtmlOptionsForm Members topic.

Public Properties

AcceptButton (inherited from Form) | The accept button of the form. If this is set, the button is clicked whenever the user presses the ENTER key.
AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
ActiveControl (inherited from ContainerControl) | The currently active control.
ActiveMdiChild (inherited from Form) | The currently active MDI child form.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Indicates whether the opacity of the control can be adjusted.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
AutoScaleMode (inherited from ContainerControl) | Determines how the form or control will scale when screen resolution or fonts change.
AutoScrollMargin (inherited from ScrollableControl) | The margin around controls during auto scroll.
AutoScrollMinSize (inherited from ScrollableControl) | The minimum logical size for the auto scroll region.
AutoScrollPosition (inherited from ScrollableControl) | The current position of the auto-scrolling scroll bar.
AutoSizeMode (inherited from Form) | Specifies the mode by which the user interface element automatically resizes itself.
BackgroundImage (inherited from Control) | The background image used for the control.
BackgroundImageLayout (inherited from Control) | The background image layout used for the component.
BindingContext (inherited from ContainerControl) | The binding manager for the container control. This manages all bindings of child controls to lists.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CancelButton (inherited from Form) | The cancel button of the form. If this property is set, the button is clicked whenever the user presses the ESC key.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
CausesValidation (inherited from Control) | Indicates whether this component raises validation events.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ContextMenuStrip (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ControlBox (inherited from Form) | Determines whether a form has a Control/System menu box.
Controls (inherited from Control) | The collection of child controls within this control.
Created (inherited from Control) | Determines if the control has been fully created.
Cursor (inherited from Control) | The cursor that appears when the pointer moves over the control.
DataBindings (inherited from Control) | The data bindings for the control.
DesktopBounds (inherited from Form) | The bounds of this form in desktop coordinates.
DesktopLocation (inherited from Form) | The location of this form in desktop coordinates.
DialogResult (inherited from Form) | The value this form will return if displayed as a dialog box.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
Enabled (inherited from Control) | Indicates whether the control is enabled.
Focused (inherited from Control) | Determines if this control has focus.
Font (inherited from Control) | The font used to display text in the control.
ForeColor (inherited from Control) | The foreground color of this component, which is used to display text.
FormBorderStyle (inherited from Form) | Indicates the appearance and behavior of the border and title bar of the form.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HelpButton (inherited from Form) | Determines whether a form has a Help button on the caption bar.
HorizontalScroll (inherited from ScrollableControl) | Gets the horizontal scroll bar for this ScrollableControl.
Icon (inherited from Form) | Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Determines whether the form is a child of a MDI container.
IsMdiContainer (inherited from Form) | Determines whether the form is an MDI container.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
KeyPreview (inherited from Form) | Determines whether keyboard events for controls on the form are registered with the form.
Left (inherited from Control) | The upper left of the control, in container coordinates.
MainMenuStrip (inherited from Form) | Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.
MaximizeBox (inherited from Form) | Determines whether a form has a maximize box in the upper-right corner of its caption bar.
MaximumSize (inherited from Form) | The maximum size the form can be resized to.
MdiChildren (inherited from Form) | Retrieves the MDI children of this form.
MdiParent (inherited from Form) | Retrieves the MDI parent of this form.
Menu (inherited from Form) | The main menu of the form. This must be set to a component of type MainMenu.
MergedMenu (inherited from Form) | The merged menu of this form, which is used when displaying a single merged MDI menu.
MinimizeBox (inherited from Form) | Determines whether a form has a minimize box in the upper-right corner of its caption bar.
MinimumSize (inherited from Form) | The minimum size the form can be resized to.
Modal (inherited from Form) | Indicates if this form is currently being displayed as a modal dialog box.
Opacity (inherited from Form) | The opacity percentage of the control.
OwnedForms (inherited from Form) | Array of forms owned by this form.
Owner (inherited from Form) | The owner of this form.
Padding (inherited from Control) | Specifies the interior spacing of a control.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from ContainerControl) | The parent form of this container control.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
RightToLeftLayout (inherited from Form) | Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.
ShowIcon (inherited from Form) | Indicates whether an icon is displayed in the title bar of the form.
ShowInTaskbar (inherited from Form) | Determines whether the form appears in the Windows Taskbar.
SizeGripStyle (inherited from Form) | Determines when the SizeGrip will be displayed for the form.
StartPosition (inherited from Form) | Determines the position of a form when it first appears.
Tag (inherited from Control) | User-defined data associated with the object.
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
TopMost (inherited from Form) | Indicates whether the form always appears above all other forms that do not have this property set to True.
TransparencyKey (inherited from Form) | A color which will appear transparent when painted on the form.
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
VerticalScroll (inherited from ScrollableControl) | Gets the vertical scroll bar for this ScrollableControl.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
Width (inherited from Control) | The width of the control, in container coordinates.
WindowState (inherited from Form) | Determines the initial visual state of the form.


HtmlOptionsForm Events

HtmlOptionsForm Events

The events of the HtmlOptionsForm class are listed here. For a complete list of HtmlOptionsForm class members, see the HtmlOptionsForm Members topic.

Public Events

Activated (inherited from Form) | Occurs whenever the form is activated.
AutoSizeChanged (inherited from Form) | Occurs when the AutoSize property has changed.
BackColorChanged (inherited from Control) | Event raised when the value of the BackColor property is changed on Control.
BackgroundImageChanged (inherited from Control) | Event raised when the value of the BackgroundImage property is changed on Control.
BackgroundImageLayoutChanged (inherited from Control) | Event raised when the value of the BackgroundImageLayout property is changed on Control.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
CausesValidationChanged (inherited from Control) | Event raised when the value of the CausesValidation property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
CursorChanged (inherited from Control) | Event raised when the value of the Cursor property is changed on Control.
Deactivate (inherited from Form) | Occurs whenever the form is deactivated.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
ForeColorChanged (inherited from Control) | Event raised when the value of the ForeColor property is changed on Control.
FormClosed (inherited from Form) | Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.
FormClosing (inherited from Form) | Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpButtonClicked (inherited from Form) | Event raised when the help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
InputLanguageChanged (inherited from Form) | Occurs whenever the language used for input for this form changes.
InputLanguageChanging (inherited from Form) | A request by the system to change the input language for this form. This request can be refused.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
Load (inherited from Form) | Occurs whenever the user loads the form.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Event raised when the value of the MaximizedBounds property is changed on Form.
MaximumSizeChanged (inherited from Form) | Event raised when the value of the MaximumSize property is changed on Form.
MdiChildActivate (inherited from Form) | Occurs when an MDI Child window is activated.
MenuComplete (inherited from Form) | Occurs when menu selection is completed and menu modal message loop has exited.
MenuStart (inherited from Form) | Occurs when any menu is displayed and menu modal message loop is entered.
MinimumSizeChanged (inherited from Form) | Event raised when the value of the MinimumSize property is changed on Form.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
PaddingChanged (inherited from Control) | Occurs when the Padding property has changed.
Paint (inherited from Control) | Occurs when a control needs repainting.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
ResizeBegin (inherited from Form) | Occurs when the form enters the sizing modal loop.
ResizeEnd (inherited from Form) | Occurs when the control exits the sizing modal loop.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs when the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user moves the scroll box.
Shown (inherited from Form) | Occurs whenever the form is first shown.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TextChanged (inherited from Control) | Event raised when the value of the Text property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


ImageExporter Class

ImageExporter Class

Exports the document to the metafile files.

For a list of all members of this type, see ImageExporter Members.

System.Object

C1.C1Preview.Export.Exporter

C1.C1Preview.Export.PagesExporter

C1.C1Preview.Export.ImageExporter

[Visual Basic]

Public Class ImageExporter

Inherits PagesExporter

[C#]

public class ImageExporter : PagesExporter

[Delphi]

type ImageExporter = class (PagesExporter);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ImageExporter Members

ImageExporter Members

ImageExporter overview

Public Properties

Document (inherited from Exporter) | Gets or sets the document for export.
DocumentInfo (inherited from Exporter) | Gets or sets the DocumentInfo object.
DocumentInfoFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the fields of DocumentInfo class, this form is called from options form.
ImageFormat | Gets or sets the ImageFormat object indicating the format of output image files. The ImageExporter supports formats: Bmp, Gif, Jpeg, Png, Tiff.
OptionsFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the options of exporter. This form will be displayed if ShowOptions is True.
Preview (inherited from Exporter) | Gets or sets value indicating whether the document must be opened after export.
Range (inherited from Exporter) | Gets or sets the range of pages that is to be exported.
RangeFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the range of document to export, this form is called from options form.
ReferenceGraphics (inherited from Exporter) | Specifies the Graphics object used in export, for example this object is used to convert EmfPlus metafiles to EmfOnly. If this property is null then the screen dc is used.
ShowOptions (inherited from Exporter) | Gets or sets value indicating whether the options dialog should be displayed before export.
UIStrings (inherited from Exporter) | Gets or sets the UIStrings object that is used to localize text messages displayed by exporter and its options form.

Public Methods

ShowOptionsDialog (inherited from Exporter)

Displays the dialog to edit options of export.


ImageExporter Properties

ImageExporter Properties

The properties of the ImageExporter class are listed here. For a complete list of ImageExporter class members, see the ImageExporter Members topic.

Public Properties

Document (inherited from Exporter) | Gets or sets the document for export.
DocumentInfo (inherited from Exporter) | Gets or sets the DocumentInfo object.
DocumentInfoFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the fields of DocumentInfo class, this form is called from options form.
ImageFormat | Gets or sets the ImageFormat object indicating the format of output image files. The ImageExporter supports formats: Bmp, Gif, Jpeg, Png, Tiff.
OptionsFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the options of exporter. This form will be displayed if ShowOptions is True.
Preview (inherited from Exporter) | Gets or sets value indicating whether the document must be opened after export.
Range (inherited from Exporter) | Gets or sets the range of pages that is to be exported.
RangeFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the range of document to export, this form is called from options form.
ReferenceGraphics (inherited from Exporter) | Specifies the Graphics object used in export, for example this object is used to convert EmfPlus metafiles to EmfOnly. If this property is null then the screen dc is used.
ShowOptions (inherited from Exporter) | Gets or sets value indicating whether the options dialog should be displayed before export.
UIStrings (inherited from Exporter) | Gets or sets the UIStrings object that is used to localize text messages displayed by exporter and its options form.


ImageExporter.ImageFormat Property

ImageExporter.ImageFormat Property

Gets or sets the ImageFormat object indicating the format of output image files. The ImageExporter supports formats: Bmp, Gif, Jpeg, Png, Tiff.

[Visual Basic]

Public Property ImageFormat As ImageFormat

[C#]

public ImageFormat ImageFormat {get;set;}

[Delphi]

public property ImageFormat: ImageFormat read get_ImageFormat write set_ImageFormat;


ImageExporter Methods

ImageExporter Methods

The methods of the ImageExporter class are listed here. For a complete list of ImageExporter class members, see the ImageExporter Members topic.

Public Methods

ShowOptionsDialog (inherited from Exporter)

Displays the dialog to edit options of export.


ImageExportProvider Class

ImageExportProvider Class

Base abstract class for all image export providers. Descendant classes must override GetImageFormat() method.

For a list of all members of this type, see ImageExportProvider Members.

System.Object

C1.C1Preview.Export.ExportProvider

C1.C1Preview.Export.PagesExportProvider

C1.C1Preview.Export.ImageExportProvider

C1.C1Preview.Export.BmpExportProvider

C1.C1Preview.Export.GifExportProvider

C1.C1Preview.Export.JpegExportProvider

C1.C1Preview.Export.PngExportProvider

C1.C1Preview.Export.TiffExportProvider

[Visual Basic]

MustInherit Public Class ImageExportProvider

Inherits PagesExportProvider

[C#]

public abstract class ImageExportProvider : PagesExportProvider

[Delphi]

type ImageExportProvider = class abstract (PagesExportProvider);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ImageExportProvider Members

ImageExportProvider Members

ImageExportProvider overview

Public Properties

CanExportToStream (inherited from ExportProvider) | Gets the value indicating whether the exporter can save results to stream.
SupportedDocumentInfoFields (inherited from ExportProvider) | Gets the info about fields of DocumentInfo class which are supported by underlying exporter.


ImageExportProvider Properties

ImageExportProvider Properties

The properties of the ImageExportProvider class are listed here. For a complete list of ImageExportProvider class members, see the ImageExportProvider Members topic.

Public Properties

CanExportToStream (inherited from ExportProvider) | Gets the value indicating whether the exporter can save results to stream.
SupportedDocumentInfoFields (inherited from ExportProvider) | Gets the info about fields of DocumentInfo class which are supported by underlying exporter.


ImagesOptionsForm Class

ImagesOptionsForm Class

For a list of all members of this type, see ImagesOptionsForm Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Windows.Forms.Control

System.Windows.Forms.ScrollableControl

System.Windows.Forms.ContainerControl

System.Windows.Forms.Form

C1.C1Preview.Forms.BaseForm

C1.C1Preview.Export.ExportOptionsFormBase

C1.C1Preview.Export.ImagesOptionsForm

[Visual Basic]

Public Class ImagesOptionsForm

Inherits ExportOptionsFormBase

[C#]

public class ImagesOptionsForm : ExportOptionsFormBase

[Delphi]

type ImagesOptionsForm = class (ExportOptionsFormBase);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


ImagesOptionsForm Members

ImagesOptionsForm Members

ImagesOptionsForm overview

Public Properties

AcceptButton (inherited from Form) | The accept button of the form. If this is set, the button is clicked whenever the user presses the ENTER key.
AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
ActiveControl (inherited from ContainerControl) | The currently active control.
ActiveMdiChild (inherited from Form) | The currently active MDI child form.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Indicates whether the opacity of the control can be adjusted.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
AutoScaleMode (inherited from ContainerControl) | Determines how the form or control will scale when screen resolution or fonts change.
AutoScrollMargin (inherited from ScrollableControl) | The margin around controls during auto scroll.
AutoScrollMinSize (inherited from ScrollableControl) | The minimum logical size for the auto scroll region.
AutoScrollPosition (inherited from ScrollableControl) | The current position of the auto-scrolling scroll bar.
AutoSizeMode (inherited from Form) | Specifies the mode by which the user interface element automatically resizes itself.
BackgroundImage (inherited from Control) | The background image used for the control.
BackgroundImageLayout (inherited from Control) | The background image layout used for the component.
BindingContext (inherited from ContainerControl) | The binding manager for the container control. This manages all bindings of child controls to lists.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CancelButton (inherited from Form) | The cancel button of the form. If this property is set, the button is clicked whenever the user presses the ESC key.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
CausesValidation (inherited from Control) | Indicates whether this component raises validation events.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ContextMenuStrip (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ControlBox (inherited from Form) | Determines whether a form has a Control/System menu box.
Controls (inherited from Control) | The collection of child controls within this control.
Created (inherited from Control) | Determines if the control has been fully created.
Cursor (inherited from Control) | The cursor that appears when the pointer moves over the control.
DataBindings (inherited from Control) | The data bindings for the control.
DesktopBounds (inherited from Form) | The bounds of this form in desktop coordinates.
DesktopLocation (inherited from Form) | The location of this form in desktop coordinates.
DialogResult (inherited from Form) | The value this form will return if displayed as a dialog box.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
Enabled (inherited from Control) | Indicates whether the control is enabled.
Focused (inherited from Control) | Determines if this control has focus.
Font (inherited from Control) | The font used to display text in the control.
ForeColor (inherited from Control) | The foreground color of this component, which is used to display text.
FormBorderStyle (inherited from Form) | Indicates the appearance and behavior of the border and title bar of the form.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HelpButton (inherited from Form) | Determines whether a form has a Help button on the caption bar.
HorizontalScroll (inherited from ScrollableControl) | Gets the horizontal scroll bar for this ScrollableControl.
Icon (inherited from Form) | Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Determines whether the form is a child of a MDI container.
IsMdiContainer (inherited from Form) | Determines whether the form is an MDI container.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
KeyPreview (inherited from Form) | Determines whether keyboard events for controls on the form are registered with the form.
Left (inherited from Control) | The upper left of the control, in container coordinates.
MainMenuStrip (inherited from Form) | Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.
MaximizeBox (inherited from Form) | Determines whether a form has a maximize box in the upper-right corner of its caption bar.
MaximumSize (inherited from Form) | The maximum size the form can be resized to.
MdiChildren (inherited from Form) | Retrieves the MDI children of this form.
MdiParent (inherited from Form) | Retrieves the MDI parent of this form.
Menu (inherited from Form) | The main menu of the form. This must be set to a component of type MainMenu.
MergedMenu (inherited from Form) | The merged menu of this form, which is used when displaying a single merged MDI menu.
MinimizeBox (inherited from Form) | Determines whether a form has a minimize box in the upper-right corner of its caption bar.
MinimumSize (inherited from Form) | The minimum size the form can be resized to.
Modal (inherited from Form) | Indicates if this form is currently being displayed as a modal dialog box.
Opacity (inherited from Form) | The opacity percentage of the control.
OwnedForms (inherited from Form) | Array of forms owned by this form.
Owner (inherited from Form) | The owner of this form.
Padding (inherited from Control) | Specifies the interior spacing of a control.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from ContainerControl) | The parent form of this container control.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
RightToLeftLayout (inherited from Form) | Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.
ShowIcon (inherited from Form) | Indicates whether an icon is displayed in the title bar of the form.
ShowInTaskbar (inherited from Form) | Determines whether the form appears in the Windows Taskbar.
SizeGripStyle (inherited from Form) | Determines when the SizeGrip will be displayed for the form.
StartPosition (inherited from Form) | Determines the position of a form when it first appears.
Tag (inherited from Control) | User-defined data associated with the object.
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
TopMost (inherited from Form) | Indicates whether the form always appears above all other forms that do not have this property set to True.
TransparencyKey (inherited from Form) | A color which will appear transparent when painted on the form.
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
VerticalScroll (inherited from ScrollableControl) | Gets the vertical scroll bar for this ScrollableControl.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
Width (inherited from Control) | The width of the control, in container coordinates.
WindowState (inherited from Form) | Determines the initial visual state of the form.

Public Events

Activated (inherited from Form) | Occurs whenever the form is activated.
AutoSizeChanged (inherited from Form) | Occurs when the AutoSize property has changed.
BackColorChanged (inherited from Control) | Event raised when the value of the BackColor property is changed on Control.
BackgroundImageChanged (inherited from Control) | Event raised when the value of the BackgroundImage property is changed on Control.
BackgroundImageLayoutChanged (inherited from Control) | Event raised when the value of the BackgroundImageLayout property is changed on Control.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
CausesValidationChanged (inherited from Control) | Event raised when the value of the CausesValidation property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
CursorChanged (inherited from Control) | Event raised when the value of the Cursor property is changed on Control.
Deactivate (inherited from Form) | Occurs whenever the form is deactivated.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
ForeColorChanged (inherited from Control) | Event raised when the value of the ForeColor property is changed on Control.
FormClosed (inherited from Form) | Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.
FormClosing (inherited from Form) | Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpButtonClicked (inherited from Form) | Event raised when the help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
InputLanguageChanged (inherited from Form) | Occurs whenever the language used for input for this form changes.
InputLanguageChanging (inherited from Form) | A request by the system to change the input language for this form. This request can be refused.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
Load (inherited from Form) | Occurs whenever the user loads the form.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Event raised when the value of the MaximizedBounds property is changed on Form.
MaximumSizeChanged (inherited from Form) | Event raised when the value of the MaximumSize property is changed on Form.
MdiChildActivate (inherited from Form) | Occurs when an MDI Child window is activated.
MenuComplete (inherited from Form) | Occurs when menu selection is completed and menu modal message loop has exited.
MenuStart (inherited from Form) | Occurs when any menu is displayed and menu modal message loop is entered.
MinimumSizeChanged (inherited from Form) | Event raised when the value of the MinimumSize property is changed on Form.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
PaddingChanged (inherited from Control) | Occurs when the Padding property has changed.
Paint (inherited from Control) | Occurs when a control needs repainting.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
ResizeBegin (inherited from Form) | Occurs when the form enters the sizing modal loop.
ResizeEnd (inherited from Form) | Occurs when the control exits the sizing modal loop.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs when the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user moves the scroll box.
Shown (inherited from Form) | Occurs whenever the form is first shown.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TextChanged (inherited from Control) | Event raised when the value of the Text property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


ImagesOptionsForm Properties

ImagesOptionsForm Properties

The properties of the ImagesOptionsForm class are listed here. For a complete list of ImagesOptionsForm class members, see the ImagesOptionsForm Members topic.

Public Properties

AcceptButton (inherited from Form) | The accept button of the form. If this is set, the button is clicked whenever the user presses the ENTER key.
AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
ActiveControl (inherited from ContainerControl) | The currently active control.
ActiveMdiChild (inherited from Form) | The currently active MDI child form.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Indicates whether the opacity of the control can be adjusted.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
AutoScaleMode (inherited from ContainerControl) | Determines how the form or control will scale when screen resolution or fonts change.
AutoScrollMargin (inherited from ScrollableControl) | The margin around controls during auto scroll.
AutoScrollMinSize (inherited from ScrollableControl) | The minimum logical size for the auto scroll region.
AutoScrollPosition (inherited from ScrollableControl) | The current position of the auto-scrolling scroll bar.
AutoSizeMode (inherited from Form) | Specifies the mode by which the user interface element automatically resizes itself.
BackgroundImage (inherited from Control) | The background image used for the control.
BackgroundImageLayout (inherited from Control) | The background image layout used for the component.
BindingContext (inherited from ContainerControl) | The binding manager for the container control. This manages all bindings of child controls to lists.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CancelButton (inherited from Form) | The cancel button of the form. If this property is set, the button is clicked whenever the user presses the ESC key.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
CausesValidation (inherited from Control) | Indicates whether this component raises validation events.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ContextMenuStrip (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ControlBox (inherited from Form) | Determines whether a form has a Control/System menu box.
Controls (inherited from Control) | The collection of child controls within this control.
Created (inherited from Control) | Determines if the control has been fully created.
Cursor (inherited from Control) | The cursor that appears when the pointer moves over the control.
DataBindings (inherited from Control) | The data bindings for the control.
DesktopBounds (inherited from Form) | The bounds of this form in desktop coordinates.
DesktopLocation (inherited from Form) | The location of this form in desktop coordinates.
DialogResult (inherited from Form) | The value this form will return if displayed as a dialog box.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
Enabled (inherited from Control) | Indicates whether the control is enabled.
Focused (inherited from Control) | Determines if this control has focus.
Font (inherited from Control) | The font used to display text in the control.
ForeColor (inherited from Control) | The foreground color of this component, which is used to display text.
FormBorderStyle (inherited from Form) | Indicates the appearance and behavior of the border and title bar of the form.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HelpButton (inherited from Form) | Determines whether a form has a Help button on the caption bar.
HorizontalScroll (inherited from ScrollableControl) | Gets the horizontal scroll bar for this ScrollableControl.
Icon (inherited from Form) | Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Determines whether the form is a child of a MDI container.
IsMdiContainer (inherited from Form) | Determines whether the form is an MDI container.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
KeyPreview (inherited from Form) | Determines whether keyboard events for controls on the form are registered with the form.
Left (inherited from Control) | The upper left of the control, in container coordinates.
MainMenuStrip (inherited from Form) | Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.
MaximizeBox (inherited from Form) | Determines whether a form has a maximize box in the upper-right corner of its caption bar.
MaximumSize (inherited from Form) | The maximum size the form can be resized to.
MdiChildren (inherited from Form) | Retrieves the MDI children of this form.
MdiParent (inherited from Form) | Retrieves the MDI parent of this form.
Menu (inherited from Form) | The main menu of the form. This must be set to a component of type MainMenu.
MergedMenu (inherited from Form) | The merged menu of this form, which is used when displaying a single merged MDI menu.
MinimizeBox (inherited from Form) | Determines whether a form has a minimize box in the upper-right corner of its caption bar.
MinimumSize (inherited from Form) | The minimum size the form can be resized to.
Modal (inherited from Form) | Indicates if this form is currently being displayed as a modal dialog box.
Opacity (inherited from Form) | The opacity percentage of the control.
OwnedForms (inherited from Form) | Array of forms owned by this form.
Owner (inherited from Form) | The owner of this form.
Padding (inherited from Control) | Specifies the interior spacing of a control.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from ContainerControl) | The parent form of this container control.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
RightToLeftLayout (inherited from Form) | Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.
ShowIcon (inherited from Form) | Indicates whether an icon is displayed in the title bar of the form.
ShowInTaskbar (inherited from Form) | Determines whether the form appears in the Windows Taskbar.
SizeGripStyle (inherited from Form) | Determines when the SizeGrip will be displayed for the form.
StartPosition (inherited from Form) | Determines the position of a form when it first appears.
Tag (inherited from Control) | User-defined data associated with the object.
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
TopMost (inherited from Form) | Indicates whether the form always appears above all other forms that do not have this property set to True.
TransparencyKey (inherited from Form) | A color which will appear transparent when painted on the form.
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
VerticalScroll (inherited from ScrollableControl) | Gets the vertical scroll bar for this ScrollableControl.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
Width (inherited from Control) | The width of the control, in container coordinates.
WindowState (inherited from Form) | Determines the initial visual state of the form.


ImagesOptionsForm Events

ImagesOptionsForm Events

The events of the ImagesOptionsForm class are listed here. For a complete list of ImagesOptionsForm class members, see the ImagesOptionsForm Members topic.

Public Events

Activated (inherited from Form) | Occurs whenever the form is activated.
AutoSizeChanged (inherited from Form) | Occurs when the AutoSize property has changed.
BackColorChanged (inherited from Control) | Event raised when the value of the BackColor property is changed on Control.
BackgroundImageChanged (inherited from Control) | Event raised when the value of the BackgroundImage property is changed on Control.
BackgroundImageLayoutChanged (inherited from Control) | Event raised when the value of the BackgroundImageLayout property is changed on Control.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
CausesValidationChanged (inherited from Control) | Event raised when the value of the CausesValidation property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
CursorChanged (inherited from Control) | Event raised when the value of the Cursor property is changed on Control.
Deactivate (inherited from Form) | Occurs whenever the form is deactivated.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
ForeColorChanged (inherited from Control) | Event raised when the value of the ForeColor property is changed on Control.
FormClosed (inherited from Form) | Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.
FormClosing (inherited from Form) | Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpButtonClicked (inherited from Form) | Event raised when the help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
InputLanguageChanged (inherited from Form) | Occurs whenever the language used for input for this form changes.
InputLanguageChanging (inherited from Form) | A request by the system to change the input language for this form. This request can be refused.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
Load (inherited from Form) | Occurs whenever the user loads the form.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Event raised when the value of the MaximizedBounds property is changed on Form.
MaximumSizeChanged (inherited from Form) | Event raised when the value of the MaximumSize property is changed on Form.
MdiChildActivate (inherited from Form) | Occurs when an MDI Child window is activated.
MenuComplete (inherited from Form) | Occurs when menu selection is completed and menu modal message loop has exited.
MenuStart (inherited from Form) | Occurs when any menu is displayed and menu modal message loop is entered.
MinimumSizeChanged (inherited from Form) | Event raised when the value of the MinimumSize property is changed on Form.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
PaddingChanged (inherited from Control) | Occurs when the Padding property has changed.
Paint (inherited from Control) | Occurs when a control needs repainting.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
ResizeBegin (inherited from Form) | Occurs when the form enters the sizing modal loop.
ResizeEnd (inherited from Form) | Occurs when the control exits the sizing modal loop.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs when the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user moves the scroll box.
Shown (inherited from Form) | Occurs whenever the form is first shown.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TextChanged (inherited from Control) | Event raised when the value of the Text property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


JpegExportProvider Class

JpegExportProvider Class

For a list of all members of this type, see JpegExportProvider Members.

System.Object

C1.C1Preview.Export.ExportProvider

C1.C1Preview.Export.PagesExportProvider

C1.C1Preview.Export.ImageExportProvider

C1.C1Preview.Export.JpegExportProvider

[Visual Basic]

Public Class JpegExportProvider

Inherits ImageExportProvider

[C#]

public class JpegExportProvider : ImageExportProvider

[Delphi]

type JpegExportProvider = class (ImageExportProvider);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


JpegExportProvider Members

JpegExportProvider Members

JpegExportProvider overview

Public Properties

CanExportToStream (inherited from ExportProvider) | Gets the value indicating whether the exporter can save results to stream.
SupportedDocumentInfoFields (inherited from ExportProvider) | Gets the info about fields of DocumentInfo class which are supported by underlying exporter.


JpegExportProvider Properties

JpegExportProvider Properties

The properties of the JpegExportProvider class are listed here. For a complete list of JpegExportProvider class members, see the JpegExportProvider Members topic.

Public Properties

CanExportToStream (inherited from ExportProvider) | Gets the value indicating whether the exporter can save results to stream.
SupportedDocumentInfoFields (inherited from ExportProvider) | Gets the info about fields of DocumentInfo class which are supported by underlying exporter.


PagesExporter Class

PagesExporter Class

Base class for all exporters working over list of pages. Derived classes must override ProcessPage method.

For a list of all members of this type, see PagesExporter Members.

System.Object

C1.C1Preview.Export.Exporter

C1.C1Preview.Export.PagesExporter

C1.C1Preview.Export.EmfExporter

C1.C1Preview.Export.ImageExporter

C1.C1Preview.Export.PdfExporter

[Visual Basic]

MustInherit Public Class PagesExporter

Inherits Exporter

[C#]

public abstract class PagesExporter : Exporter

[Delphi]

type PagesExporter = class abstract (Exporter);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


PagesExporter Members

PagesExporter Members

PagesExporter overview

Public Properties

Document (inherited from Exporter) | Gets or sets the document for export.
DocumentInfo (inherited from Exporter) | Gets or sets the DocumentInfo object.
DocumentInfoFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the fields of DocumentInfo class, this form is called from options form.
ExportProvider (inherited from Exporter) | Gets the underlying ExportProvider object.
OptionsFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the options of exporter. This form will be displayed if ShowOptions is True.
Preview (inherited from Exporter) | Gets or sets value indicating whether the document must be opened after export.
Range (inherited from Exporter) | Gets or sets the range of pages that is to be exported.
RangeFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the range of document to export, this form is called from options form.
ReferenceGraphics (inherited from Exporter) | Specifies the Graphics object used in export, for example this object is used to convert EmfPlus metafiles to EmfOnly. If this property is null then the screen dc is used.
ShowOptions (inherited from Exporter) | Gets or sets value indicating whether the options dialog should be displayed before export.
UIStrings (inherited from Exporter) | Gets or sets the UIStrings object that is used to localize text messages displayed by exporter and its options form.

Public Methods

ShowOptionsDialog (inherited from Exporter)

Displays the dialog to edit options of export.


PagesExporter Properties

PagesExporter Properties

The properties of the PagesExporter class are listed here. For a complete list of PagesExporter class members, see the PagesExporter Members topic.

Public Properties

Document (inherited from Exporter) | Gets or sets the document for export.
DocumentInfo (inherited from Exporter) | Gets or sets the DocumentInfo object.
DocumentInfoFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the fields of DocumentInfo class, this form is called from options form.
ExportProvider (inherited from Exporter) | Gets the underlying ExportProvider object.
OptionsFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the options of exporter. This form will be displayed if ShowOptions is True.
Preview (inherited from Exporter) | Gets or sets value indicating whether the document must be opened after export.
Range (inherited from Exporter) | Gets or sets the range of pages that is to be exported.
RangeFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the range of document to export, this form is called from options form.
ReferenceGraphics (inherited from Exporter) | Specifies the Graphics object used in export, for example this object is used to convert EmfPlus metafiles to EmfOnly. If this property is null then the screen dc is used.
ShowOptions (inherited from Exporter) | Gets or sets value indicating whether the options dialog should be displayed before export.
UIStrings (inherited from Exporter) | Gets or sets the UIStrings object that is used to localize text messages displayed by exporter and its options form.


PagesExporter Methods

PagesExporter Methods

The methods of the PagesExporter class are listed here. For a complete list of PagesExporter class members, see the PagesExporter Members topic.

Public Methods

ShowOptionsDialog (inherited from Exporter)

Displays the dialog to edit options of export.


PagesExportProvider Class

PagesExportProvider Class

Base class for all export provides working over list of pages, each page is represented as metafile.

For a list of all members of this type, see PagesExportProvider Members.

System.Object

C1.C1Preview.Export.ExportProvider

C1.C1Preview.Export.PagesExportProvider

C1.C1Preview.Export.EmfExportProvider

C1.C1Preview.Export.ImageExportProvider

C1.C1Preview.Export.PdfExportProvider

[Visual Basic]

MustInherit Public Class PagesExportProvider

Inherits ExportProvider

[C#]

public abstract class PagesExportProvider : ExportProvider

[Delphi]

type PagesExportProvider = class abstract (ExportProvider);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


PagesExportProvider Members

PagesExportProvider Members

PagesExportProvider overview

Public Properties

CanExportToStream (inherited from ExportProvider) | Gets the value indicating whether the exporter can save results to stream.
CanShowOptions (inherited from ExportProvider) | Gets the value indicating whether the exporter can show the options setup dialog.
DefaultExtension (inherited from ExportProvider) | Default extension for output file.
DefaultOptionsFormClass (inherited from ExportProvider) | Gets the type of form which is used to edit export options by default.
FormatName (inherited from ExportProvider) | Description of format.
SupportedDocumentInfoFields (inherited from ExportProvider) | Gets the info about fields of DocumentInfo class which are supported by underlying exporter.

Public Methods

NewExporter (inherited from ExportProvider)

Creates a new Exporter object.


PagesExportProvider Properties

PagesExportProvider Properties

The properties of the PagesExportProvider class are listed here. For a complete list of PagesExportProvider class members, see the PagesExportProvider Members topic.

Public Properties

CanExportToStream (inherited from ExportProvider) | Gets the value indicating whether the exporter can save results to stream.
CanShowOptions (inherited from ExportProvider) | Gets the value indicating whether the exporter can show the options setup dialog.
DefaultExtension (inherited from ExportProvider) | Default extension for output file.
DefaultOptionsFormClass (inherited from ExportProvider) | Gets the type of form which is used to edit export options by default.
FormatName (inherited from ExportProvider) | Description of format.
SupportedDocumentInfoFields (inherited from ExportProvider) | Gets the info about fields of DocumentInfo class which are supported by underlying exporter.


PagesExportProvider Methods

PagesExportProvider Methods

The methods of the PagesExportProvider class are listed here. For a complete list of PagesExportProvider class members, see the PagesExportProvider Members topic.

Public Methods

NewExporter (inherited from ExportProvider)

Creates a new Exporter object.


PdfExporter Class

PdfExporter Class

The PDF exporter.

For a list of all members of this type, see PdfExporter Members.

System.Object

C1.C1Preview.Export.Exporter

C1.C1Preview.Export.PagesExporter

C1.C1Preview.Export.PdfExporter

[Visual Basic]

Public Class PdfExporter

Inherits PagesExporter

[C#]

public class PdfExporter : PagesExporter

[Delphi]

type PdfExporter = class (PagesExporter);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


PdfExporter Members

PdfExporter Members

PdfExporter overview

Public Properties

Document (inherited from Exporter) | Gets or sets the document for export.
DocumentInfo (inherited from Exporter) | Gets or sets the DocumentInfo object.
DocumentInfoFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the fields of DocumentInfo class, this form is called from options form.
OptionsFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the options of exporter. This form will be displayed if ShowOptions is True.
Preview (inherited from Exporter) | Gets or sets value indicating whether the document must be opened after export.
Range (inherited from Exporter) | Gets or sets the range of pages that is to be exported.
RangeFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the range of document to export, this form is called from options form.
ReferenceGraphics (inherited from Exporter) | Specifies the Graphics object used in export, for example this object is used to convert EmfPlus metafiles to EmfOnly. If this property is null then the screen dc is used.
Security | Gets the PdfSecurity object describing the security properties of the generated PDF document.
ShowOptions (inherited from Exporter) | Gets or sets value indicating whether the options dialog should be displayed before export.
UIStrings (inherited from Exporter) | Gets or sets the UIStrings object that is used to localize text messages displayed by exporter and its options form.
UseCompression | Gets or sets the value indicating whether the compression must be used when saving the document.

Public Methods

ShowOptionsDialog (inherited from Exporter)

Displays the dialog to edit options of export.


PdfExporter Properties

PdfExporter Properties

The properties of the PdfExporter class are listed here. For a complete list of PdfExporter class members, see the PdfExporter Members topic.

Public Properties

Document (inherited from Exporter) | Gets or sets the document for export.
DocumentInfo (inherited from Exporter) | Gets or sets the DocumentInfo object.
DocumentInfoFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the fields of DocumentInfo class, this form is called from options form.
OptionsFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the options of exporter. This form will be displayed if ShowOptions is True.
Preview (inherited from Exporter) | Gets or sets value indicating whether the document must be opened after export.
Range (inherited from Exporter) | Gets or sets the range of pages that is to be exported.
RangeFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the range of document to export, this form is called from options form.
ReferenceGraphics (inherited from Exporter) | Specifies the Graphics object used in export, for example this object is used to convert EmfPlus metafiles to EmfOnly. If this property is null then the screen dc is used.
Security | Gets the PdfSecurity object describing the security properties of the generated PDF document.
ShowOptions (inherited from Exporter) | Gets or sets value indicating whether the options dialog should be displayed before export.
UIStrings (inherited from Exporter) | Gets or sets the UIStrings object that is used to localize text messages displayed by exporter and its options form.
UseCompression | Gets or sets the value indicating whether the compression must be used when saving the document.


PdfExporter.Security Property

PdfExporter.Security Property

Gets the PdfSecurity object describing the security properties of the generated PDF document.

[Visual Basic]

Public ReadOnly Property Security As PdfSecurity

[C#]

public PdfSecurity Security {get;}

[Delphi]

public property Security: PdfSecurity read get_Security;


PdfExporter.UseCompression Property

PdfExporter.UseCompression Property

Gets or sets the value indicating whether the compression must be used when saving the document.

[Visual Basic]

Public Property UseCompression As Boolean

[C#]

public bool UseCompression {get;set;}

[Delphi]

public property UseCompression: Boolean read get_UseCompression write set_UseCompression;


PdfExporter Methods

PdfExporter Methods

The methods of the PdfExporter class are listed here. For a complete list of PdfExporter class members, see the PdfExporter Members topic.

Public Methods

ShowOptionsDialog (inherited from Exporter)

Displays the dialog to edit options of export.


PdfExportProvider Class

PdfExportProvider Class

The RTF export provider working over list of pages, each page is represented as metafile.

For a list of all members of this type, see PdfExportProvider Members.

System.Object

C1.C1Preview.Export.ExportProvider

C1.C1Preview.Export.PagesExportProvider

C1.C1Preview.Export.PdfExportProvider

[Visual Basic]

Public Class PdfExportProvider

Inherits PagesExportProvider

[C#]

public class PdfExportProvider : PagesExportProvider

[Delphi]

type PdfExportProvider = class (PagesExportProvider);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


PdfExportProvider Members

PdfExportProvider Members

PdfExportProvider overview

Public Properties

DefaultExtension | Overriden. Default extension for output file.
FormatName | Overriden. Description of format.

Public Methods

NewExporter

Overriden. Creates a new Exporter object.


PdfExportProvider Properties

PdfExportProvider Properties

The properties of the PdfExportProvider class are listed here. For a complete list of PdfExportProvider class members, see the PdfExportProvider Members topic.

Public Properties

DefaultExtension | Overriden. Default extension for output file.
FormatName | Overriden. Description of format.


PdfExportProvider.DefaultExtension Property

PdfExportProvider.DefaultExtension Property

Default extension for output file.

[Visual Basic]

Overrides Public ReadOnly Property DefaultExtension As String

[C#]

override public string DefaultExtension {get;}

[Delphi]

public property DefaultExtension: String read get_DefaultExtension;


PdfExportProvider.FormatName Property

PdfExportProvider.FormatName Property

Description of format.

[Visual Basic]

Overrides Public ReadOnly Property FormatName As String

[C#]

override public string FormatName {get;}

[Delphi]

public property FormatName: String read get_FormatName;


PdfExportProvider Methods

PdfExportProvider Methods

The methods of the PdfExportProvider class are listed here. For a complete list of PdfExportProvider class members, see the PdfExportProvider Members topic.

Public Methods

NewExporter

Overriden. Creates a new Exporter object.


PdfExportProvider.NewExporter Method

PdfExportProvider.NewExporter Method

Creates a new Exporter object.

[Visual Basic]

Overrides Public Function NewExporter() As Exporter

[C#]

override public Exporter NewExporter()

[Delphi]

public function NewExporter():
Exporter;
override;

Return Value

Returns the created object.


PdfOptionsForm Class

PdfOptionsForm Class

For a list of all members of this type, see PdfOptionsForm Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Windows.Forms.Control

System.Windows.Forms.ScrollableControl

System.Windows.Forms.ContainerControl

System.Windows.Forms.Form

C1.C1Preview.Forms.BaseForm

C1.C1Preview.Export.ExportOptionsFormBase

C1.C1Preview.Export.PdfOptionsForm

[Visual Basic]

Public Class PdfOptionsForm

Inherits ExportOptionsFormBase

[C#]

public class PdfOptionsForm : ExportOptionsFormBase

[Delphi]

type PdfOptionsForm = class (ExportOptionsFormBase);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


PdfOptionsForm Members

PdfOptionsForm Members

PdfOptionsForm overview

Public Properties

AcceptButton (inherited from Form) | The accept button of the form. If this is set, the button is clicked whenever the user presses the ENTER key.
AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
ActiveControl (inherited from ContainerControl) | The currently active control.
ActiveMdiChild (inherited from Form) | The currently active MDI child form.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Indicates whether the opacity of the control can be adjusted.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
AutoScaleMode (inherited from ContainerControl) | Determines how the form or control will scale when screen resolution or fonts change.
AutoScrollMargin (inherited from ScrollableControl) | The margin around controls during auto scroll.
AutoScrollMinSize (inherited from ScrollableControl) | The minimum logical size for the auto scroll region.
AutoScrollPosition (inherited from ScrollableControl) | The current position of the auto-scrolling scroll bar.
AutoSizeMode (inherited from Form) | Specifies the mode by which the user interface element automatically resizes itself.
BackgroundImage (inherited from Control) | The background image used for the control.
BackgroundImageLayout (inherited from Control) | The background image layout used for the component.
BindingContext (inherited from ContainerControl) | The binding manager for the container control. This manages all bindings of child controls to lists.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CancelButton (inherited from Form) | The cancel button of the form. If this property is set, the button is clicked whenever the user presses the ESC key.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
CausesValidation (inherited from Control) | Indicates whether this component raises validation events.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ContextMenuStrip (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ControlBox (inherited from Form) | Determines whether a form has a Control/System menu box.
Controls (inherited from Control) | The collection of child controls within this control.
Created (inherited from Control) | Determines if the control has been fully created.
Cursor (inherited from Control) | The cursor that appears when the pointer moves over the control.
DataBindings (inherited from Control) | The data bindings for the control.
DesktopBounds (inherited from Form) | The bounds of this form in desktop coordinates.
DesktopLocation (inherited from Form) | The location of this form in desktop coordinates.
DialogResult (inherited from Form) | The value this form will return if displayed as a dialog box.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
Enabled (inherited from Control) | Indicates whether the control is enabled.
Focused (inherited from Control) | Determines if this control has focus.
Font (inherited from Control) | The font used to display text in the control.
ForeColor (inherited from Control) | The foreground color of this component, which is used to display text.
FormBorderStyle (inherited from Form) | Indicates the appearance and behavior of the border and title bar of the form.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HelpButton (inherited from Form) | Determines whether a form has a Help button on the caption bar.
HorizontalScroll (inherited from ScrollableControl) | Gets the horizontal scroll bar for this ScrollableControl.
Icon (inherited from Form) | Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Determines whether the form is a child of a MDI container.
IsMdiContainer (inherited from Form) | Determines whether the form is an MDI container.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
KeyPreview (inherited from Form) | Determines whether keyboard events for controls on the form are registered with the form.
Left (inherited from Control) | The upper left of the control, in container coordinates.
MainMenuStrip (inherited from Form) | Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.
MaximizeBox (inherited from Form) | Determines whether a form has a maximize box in the upper-right corner of its caption bar.
MaximumSize (inherited from Form) | The maximum size the form can be resized to.
MdiChildren (inherited from Form) | Retrieves the MDI children of this form.
MdiParent (inherited from Form) | Retrieves the MDI parent of this form.
Menu (inherited from Form) | The main menu of the form. This must be set to a component of type MainMenu.
MergedMenu (inherited from Form) | The merged menu of this form, which is used when displaying a single merged MDI menu.
MinimizeBox (inherited from Form) | Determines whether a form has a minimize box in the upper-right corner of its caption bar.
MinimumSize (inherited from Form) | The minimum size the form can be resized to.
Modal (inherited from Form) | Indicates if this form is currently being displayed as a modal dialog box.
Opacity (inherited from Form) | The opacity percentage of the control.
OwnedForms (inherited from Form) | Array of forms owned by this form.
Owner (inherited from Form) | The owner of this form.
Padding (inherited from Control) | Specifies the interior spacing of a control.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from ContainerControl) | The parent form of this container control.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
RightToLeftLayout (inherited from Form) | Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.
ShowIcon (inherited from Form) | Indicates whether an icon is displayed in the title bar of the form.
ShowInTaskbar (inherited from Form) | Determines whether the form appears in the Windows Taskbar.
SizeGripStyle (inherited from Form) | Determines when the SizeGrip will be displayed for the form.
StartPosition (inherited from Form) | Determines the position of a form when it first appears.
Tag (inherited from Control) | User-defined data associated with the object.
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
TopMost (inherited from Form) | Indicates whether the form always appears above all other forms that do not have this property set to True.
TransparencyKey (inherited from Form) | A color which will appear transparent when painted on the form.
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
VerticalScroll (inherited from ScrollableControl) | Gets the vertical scroll bar for this ScrollableControl.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
Width (inherited from Control) | The width of the control, in container coordinates.
WindowState (inherited from Form) | Determines the initial visual state of the form.

Public Events

Activated (inherited from Form) | Occurs whenever the form is activated.
AutoSizeChanged (inherited from Form) | Occurs when the AutoSize property has changed.
BackColorChanged (inherited from Control) | Event raised when the value of the BackColor property is changed on Control.
BackgroundImageChanged (inherited from Control) | Event raised when the value of the BackgroundImage property is changed on Control.
BackgroundImageLayoutChanged (inherited from Control) | Event raised when the value of the BackgroundImageLayout property is changed on Control.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
CausesValidationChanged (inherited from Control) | Event raised when the value of the CausesValidation property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
CursorChanged (inherited from Control) | Event raised when the value of the Cursor property is changed on Control.
Deactivate (inherited from Form) | Occurs whenever the form is deactivated.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
ForeColorChanged (inherited from Control) | Event raised when the value of the ForeColor property is changed on Control.
FormClosed (inherited from Form) | Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.
FormClosing (inherited from Form) | Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpButtonClicked (inherited from Form) | Event raised when the help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
InputLanguageChanged (inherited from Form) | Occurs whenever the language used for input for this form changes.
InputLanguageChanging (inherited from Form) | A request by the system to change the input language for this form. This request can be refused.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
Load (inherited from Form) | Occurs whenever the user loads the form.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Event raised when the value of the MaximizedBounds property is changed on Form.
MaximumSizeChanged (inherited from Form) | Event raised when the value of the MaximumSize property is changed on Form.
MdiChildActivate (inherited from Form) | Occurs when an MDI Child window is activated.
MenuComplete (inherited from Form) | Occurs when menu selection is completed and menu modal message loop has exited.
MenuStart (inherited from Form) | Occurs when any menu is displayed and menu modal message loop is entered.
MinimumSizeChanged (inherited from Form) | Event raised when the value of the MinimumSize property is changed on Form.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
PaddingChanged (inherited from Control) | Occurs when the Padding property has changed.
Paint (inherited from Control) | Occurs when a control needs repainting.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
ResizeBegin (inherited from Form) | Occurs when the form enters the sizing modal loop.
ResizeEnd (inherited from Form) | Occurs when the control exits the sizing modal loop.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs when the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user moves the scroll box.
Shown (inherited from Form) | Occurs whenever the form is first shown.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TextChanged (inherited from Control) | Event raised when the value of the Text property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


PdfOptionsForm Properties

PdfOptionsForm Properties

The properties of the PdfOptionsForm class are listed here. For a complete list of PdfOptionsForm class members, see the PdfOptionsForm Members topic.

Public Properties

AcceptButton (inherited from Form) | The accept button of the form. If this is set, the button is clicked whenever the user presses the ENTER key.
AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
ActiveControl (inherited from ContainerControl) | The currently active control.
ActiveMdiChild (inherited from Form) | The currently active MDI child form.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Indicates whether the opacity of the control can be adjusted.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
AutoScaleMode (inherited from ContainerControl) | Determines how the form or control will scale when screen resolution or fonts change.
AutoScrollMargin (inherited from ScrollableControl) | The margin around controls during auto scroll.
AutoScrollMinSize (inherited from ScrollableControl) | The minimum logical size for the auto scroll region.
AutoScrollPosition (inherited from ScrollableControl) | The current position of the auto-scrolling scroll bar.
AutoSizeMode (inherited from Form) | Specifies the mode by which the user interface element automatically resizes itself.
BackgroundImage (inherited from Control) | The background image used for the control.
BackgroundImageLayout (inherited from Control) | The background image layout used for the component.
BindingContext (inherited from ContainerControl) | The binding manager for the container control. This manages all bindings of child controls to lists.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CancelButton (inherited from Form) | The cancel button of the form. If this property is set, the button is clicked whenever the user presses the ESC key.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
CausesValidation (inherited from Control) | Indicates whether this component raises validation events.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ContextMenuStrip (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ControlBox (inherited from Form) | Determines whether a form has a Control/System menu box.
Controls (inherited from Control) | The collection of child controls within this control.
Created (inherited from Control) | Determines if the control has been fully created.
Cursor (inherited from Control) | The cursor that appears when the pointer moves over the control.
DataBindings (inherited from Control) | The data bindings for the control.
DesktopBounds (inherited from Form) | The bounds of this form in desktop coordinates.
DesktopLocation (inherited from Form) | The location of this form in desktop coordinates.
DialogResult (inherited from Form) | The value this form will return if displayed as a dialog box.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
Enabled (inherited from Control) | Indicates whether the control is enabled.
Focused (inherited from Control) | Determines if this control has focus.
Font (inherited from Control) | The font used to display text in the control.
ForeColor (inherited from Control) | The foreground color of this component, which is used to display text.
FormBorderStyle (inherited from Form) | Indicates the appearance and behavior of the border and title bar of the form.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HelpButton (inherited from Form) | Determines whether a form has a Help button on the caption bar.
HorizontalScroll (inherited from ScrollableControl) | Gets the horizontal scroll bar for this ScrollableControl.
Icon (inherited from Form) | Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Determines whether the form is a child of a MDI container.
IsMdiContainer (inherited from Form) | Determines whether the form is an MDI container.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
KeyPreview (inherited from Form) | Determines whether keyboard events for controls on the form are registered with the form.
Left (inherited from Control) | The upper left of the control, in container coordinates.
MainMenuStrip (inherited from Form) | Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.
MaximizeBox (inherited from Form) | Determines whether a form has a maximize box in the upper-right corner of its caption bar.
MaximumSize (inherited from Form) | The maximum size the form can be resized to.
MdiChildren (inherited from Form) | Retrieves the MDI children of this form.
MdiParent (inherited from Form) | Retrieves the MDI parent of this form.
Menu (inherited from Form) | The main menu of the form. This must be set to a component of type MainMenu.
MergedMenu (inherited from Form) | The merged menu of this form, which is used when displaying a single merged MDI menu.
MinimizeBox (inherited from Form) | Determines whether a form has a minimize box in the upper-right corner of its caption bar.
MinimumSize (inherited from Form) | The minimum size the form can be resized to.
Modal (inherited from Form) | Indicates if this form is currently being displayed as a modal dialog box.
Opacity (inherited from Form) | The opacity percentage of the control.
OwnedForms (inherited from Form) | Array of forms owned by this form.
Owner (inherited from Form) | The owner of this form.
Padding (inherited from Control) | Specifies the interior spacing of a control.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from ContainerControl) | The parent form of this container control.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
RightToLeftLayout (inherited from Form) | Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.
ShowIcon (inherited from Form) | Indicates whether an icon is displayed in the title bar of the form.
ShowInTaskbar (inherited from Form) | Determines whether the form appears in the Windows Taskbar.
SizeGripStyle (inherited from Form) | Determines when the SizeGrip will be displayed for the form.
StartPosition (inherited from Form) | Determines the position of a form when it first appears.
Tag (inherited from Control) | User-defined data associated with the object.
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
TopMost (inherited from Form) | Indicates whether the form always appears above all other forms that do not have this property set to True.
TransparencyKey (inherited from Form) | A color which will appear transparent when painted on the form.
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
VerticalScroll (inherited from ScrollableControl) | Gets the vertical scroll bar for this ScrollableControl.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
Width (inherited from Control) | The width of the control, in container coordinates.
WindowState (inherited from Form) | Determines the initial visual state of the form.


PdfOptionsForm Events

PdfOptionsForm Events

The events of the PdfOptionsForm class are listed here. For a complete list of PdfOptionsForm class members, see the PdfOptionsForm Members topic.

Public Events

Activated (inherited from Form) | Occurs whenever the form is activated.
AutoSizeChanged (inherited from Form) | Occurs when the AutoSize property has changed.
BackColorChanged (inherited from Control) | Event raised when the value of the BackColor property is changed on Control.
BackgroundImageChanged (inherited from Control) | Event raised when the value of the BackgroundImage property is changed on Control.
BackgroundImageLayoutChanged (inherited from Control) | Event raised when the value of the BackgroundImageLayout property is changed on Control.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
CausesValidationChanged (inherited from Control) | Event raised when the value of the CausesValidation property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
CursorChanged (inherited from Control) | Event raised when the value of the Cursor property is changed on Control.
Deactivate (inherited from Form) | Occurs whenever the form is deactivated.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
ForeColorChanged (inherited from Control) | Event raised when the value of the ForeColor property is changed on Control.
FormClosed (inherited from Form) | Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.
FormClosing (inherited from Form) | Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpButtonClicked (inherited from Form) | Event raised when the help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
InputLanguageChanged (inherited from Form) | Occurs whenever the language used for input for this form changes.
InputLanguageChanging (inherited from Form) | A request by the system to change the input language for this form. This request can be refused.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
Load (inherited from Form) | Occurs whenever the user loads the form.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Event raised when the value of the MaximizedBounds property is changed on Form.
MaximumSizeChanged (inherited from Form) | Event raised when the value of the MaximumSize property is changed on Form.
MdiChildActivate (inherited from Form) | Occurs when an MDI Child window is activated.
MenuComplete (inherited from Form) | Occurs when menu selection is completed and menu modal message loop has exited.
MenuStart (inherited from Form) | Occurs when any menu is displayed and menu modal message loop is entered.
MinimumSizeChanged (inherited from Form) | Event raised when the value of the MinimumSize property is changed on Form.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
PaddingChanged (inherited from Control) | Occurs when the Padding property has changed.
Paint (inherited from Control) | Occurs when a control needs repainting.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
ResizeBegin (inherited from Form) | Occurs when the form enters the sizing modal loop.
ResizeEnd (inherited from Form) | Occurs when the control exits the sizing modal loop.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs when the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user moves the scroll box.
Shown (inherited from Form) | Occurs whenever the form is first shown.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TextChanged (inherited from Control) | Event raised when the value of the Text property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


PdfSecurity Class

PdfSecurity Class

Represents the security properties of PDF document.

For a list of all members of this type, see PdfSecurity Members.

System.Object

C1.C1Preview.Export.PdfSecurity

[Visual Basic]

Public Class PdfSecurity

[C#]

public class PdfSecurity

[Delphi]

type PdfSecurity = class;

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


PdfSecurity Members

PdfSecurity Members

PdfSecurity overview

Public Properties

AllowCopyContent | Gets or sets whether the user can copy contents from the pdf document.
AllowEditAnnotations | Gets or sets whether the user can edit annotations in the pdf document.
AllowEditContent | Gets or sets whether the user can edit the contents of the pdf document.
AllowPrint | Gets or sets whether the user can print the pdf document.
OwnerPassword | Gets or sets the password required to change permissions for the pdf document.
UserPassword | Gets or sets the password required to open the pdf document.


PdfSecurity Properties

PdfSecurity Properties

The properties of the PdfSecurity class are listed here. For a complete list of PdfSecurity class members, see the PdfSecurity Members topic.

Public Properties

AllowCopyContent | Gets or sets whether the user can copy contents from the pdf document.
AllowEditAnnotations | Gets or sets whether the user can edit annotations in the pdf document.
AllowEditContent | Gets or sets whether the user can edit the contents of the pdf document.
AllowPrint | Gets or sets whether the user can print the pdf document.
OwnerPassword | Gets or sets the password required to change permissions for the pdf document.
UserPassword | Gets or sets the password required to open the pdf document.


PdfSecurity.AllowCopyContent Property

PdfSecurity.AllowCopyContent Property

Gets or sets whether the user can copy contents from the pdf document.

[Visual Basic]

Public Property AllowCopyContent As Boolean

[C#]

public bool AllowCopyContent {get;set;}

[Delphi]

public property AllowCopyContent: Boolean read get_AllowCopyContent write set_AllowCopyContent;


PdfSecurity.AllowEditAnnotations Property

PdfSecurity.AllowEditAnnotations Property

Gets or sets whether the user can edit annotations in the pdf document.

[Visual Basic]

Public Property AllowEditAnnotations As Boolean

[C#]

public bool AllowEditAnnotations {get;set;}

[Delphi]

public property AllowEditAnnotations: Boolean read get_AllowEditAnnotations write set_AllowEditAnnotations;


PdfSecurity.AllowEditContent Property

PdfSecurity.AllowEditContent Property

Gets or sets whether the user can edit the contents of the pdf document.

[Visual Basic]

Public Property AllowEditContent As Boolean

[C#]

public bool AllowEditContent {get;set;}

[Delphi]

public property AllowEditContent: Boolean read get_AllowEditContent write set_AllowEditContent;


PdfSecurity.AllowPrint Property

PdfSecurity.AllowPrint Property

Gets or sets whether the user can print the pdf document.

[Visual Basic]

Public Property AllowPrint As Boolean

[C#]

public bool AllowPrint {get;set;}

[Delphi]

public property AllowPrint: Boolean read get_AllowPrint write set_AllowPrint;


PdfSecurity.OwnerPassword Property

PdfSecurity.OwnerPassword Property

Gets or sets the password required to change permissions for the pdf document.

[Visual Basic]

Public Property OwnerPassword As String

[C#]

public string OwnerPassword {get;set;}

[Delphi]

public property OwnerPassword: String read get_OwnerPassword write set_OwnerPassword;


PdfSecurity.UserPassword Property

PdfSecurity.UserPassword Property

Gets or sets the password required to open the pdf document.

[Visual Basic]

Public Property UserPassword As String

[C#]

public string UserPassword {get;set;}

[Delphi]

public property UserPassword: String read get_UserPassword write set_UserPassword;


PngExportProvider Class

PngExportProvider Class

For a list of all members of this type, see PngExportProvider Members.

System.Object

C1.C1Preview.Export.ExportProvider

C1.C1Preview.Export.PagesExportProvider

C1.C1Preview.Export.ImageExportProvider

C1.C1Preview.Export.PngExportProvider

[Visual Basic]

Public Class PngExportProvider

Inherits ImageExportProvider

[C#]

public class PngExportProvider : ImageExportProvider

[Delphi]

type PngExportProvider = class (ImageExportProvider);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


PngExportProvider Members

PngExportProvider Members

PngExportProvider overview

Public Properties

CanExportToStream (inherited from ExportProvider) | Gets the value indicating whether the exporter can save results to stream.
SupportedDocumentInfoFields (inherited from ExportProvider) | Gets the info about fields of DocumentInfo class which are supported by underlying exporter.


PngExportProvider Properties

PngExportProvider Properties

The properties of the PngExportProvider class are listed here. For a complete list of PngExportProvider class members, see the PngExportProvider Members topic.

Public Properties

CanExportToStream (inherited from ExportProvider) | Gets the value indicating whether the exporter can save results to stream.
SupportedDocumentInfoFields (inherited from ExportProvider) | Gets the info about fields of DocumentInfo class which are supported by underlying exporter.


RtfExporter Class

RtfExporter Class

The RTF exporter.

For a list of all members of this type, see RtfExporter Members.

System.Object

C1.C1Preview.Export.Exporter

C1.C1Preview.Export.ComplexExporter

C1.C1Preview.Export.RtfExporter

[Visual Basic]

Public Class RtfExporter

Inherits ComplexExporter

[C#]

public class RtfExporter : ComplexExporter

[Delphi]

type RtfExporter = class (ComplexExporter);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RtfExporter Members

RtfExporter Members

RtfExporter overview

Public Properties

Document (inherited from Exporter) | Gets or sets the document for export.
DocumentInfo (inherited from Exporter) | Gets or sets the DocumentInfo object.
DocumentInfoFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the fields of DocumentInfo class, this form is called from options form.
FixedPositioning (inherited from ComplexExporter) | Gets or sets the value indicating whether the resulting document should match closely the exact appearance of the original document. This usually is done at the cost of preserving the original structure and/or the ease of handling of the resulting document.
OptionsFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the options of exporter. This form will be displayed if ShowOptions is True.
Paginated (inherited from ComplexExporter) | Gets or sets the value indicating whether the resulting document should preserve the pagination of the original document.
Preview (inherited from Exporter) | Gets or sets value indicating whether the document must be opened after export.
Range (inherited from Exporter) | Gets or sets the range of pages that is to be exported.
RangeFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the range of document to export, this form is called from options form.
ReferenceGraphics (inherited from Exporter) | Specifies the Graphics object used in export, for example this object is used to convert EmfPlus metafiles to EmfOnly. If this property is null then the screen dc is used.
ShowOptions (inherited from Exporter) | Gets or sets value indicating whether the options dialog should be displayed before export.
UIStrings (inherited from Exporter) | Gets or sets the UIStrings object that is used to localize text messages displayed by exporter and its options form.
UseDrawingCanvas | Gets or sets the value indicating whether to create drawing canvases in the resulting document.

Public Methods

ShowOptionsDialog (inherited from Exporter)

Displays the dialog to edit options of export.


RtfExporter Properties

RtfExporter Properties

The properties of the RtfExporter class are listed here. For a complete list of RtfExporter class members, see the RtfExporter Members topic.

Public Properties

Document (inherited from Exporter) | Gets or sets the document for export.
DocumentInfo (inherited from Exporter) | Gets or sets the DocumentInfo object.
DocumentInfoFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the fields of DocumentInfo class, this form is called from options form.
FixedPositioning (inherited from ComplexExporter) | Gets or sets the value indicating whether the resulting document should match closely the exact appearance of the original document. This usually is done at the cost of preserving the original structure and/or the ease of handling of the resulting document.
OptionsFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the options of exporter. This form will be displayed if ShowOptions is True.
Paginated (inherited from ComplexExporter) | Gets or sets the value indicating whether the resulting document should preserve the pagination of the original document.
Preview (inherited from Exporter) | Gets or sets value indicating whether the document must be opened after export.
Range (inherited from Exporter) | Gets or sets the range of pages that is to be exported.
RangeFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the range of document to export, this form is called from options form.
ReferenceGraphics (inherited from Exporter) | Specifies the Graphics object used in export, for example this object is used to convert EmfPlus metafiles to EmfOnly. If this property is null then the screen dc is used.
ShowOptions (inherited from Exporter) | Gets or sets value indicating whether the options dialog should be displayed before export.
UIStrings (inherited from Exporter) | Gets or sets the UIStrings object that is used to localize text messages displayed by exporter and its options form.
UseDrawingCanvas | Gets or sets the value indicating whether to create drawing canvases in the resulting document.


RtfExporter.UseDrawingCanvas Property

RtfExporter.UseDrawingCanvas Property

Gets or sets the value indicating whether to create drawing canvases in the resulting document.

[Visual Basic]

Public Property UseDrawingCanvas As Boolean

[C#]

public bool UseDrawingCanvas {get;set;}

[Delphi]

public property UseDrawingCanvas: Boolean read get_UseDrawingCanvas write set_UseDrawingCanvas;

Property Value

True if use drawing canvas, otherwise False.


RtfExporter Methods

RtfExporter Methods

The methods of the RtfExporter class are listed here. For a complete list of RtfExporter class members, see the RtfExporter Members topic.

Public Methods

ShowOptionsDialog (inherited from Exporter)

Displays the dialog to edit options of export.


RtfExportProvider Class

RtfExportProvider Class

The RTF export provider.

For a list of all members of this type, see RtfExportProvider Members.

System.Object

C1.C1Preview.Export.ExportProvider

C1.C1Preview.Export.ComplexExportProvider

C1.C1Preview.Export.RtfExportProvider

[Visual Basic]

Public Class RtfExportProvider

Inherits ComplexExportProvider

[C#]

public class RtfExportProvider : ComplexExportProvider

[Delphi]

type RtfExportProvider = class (ComplexExportProvider);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RtfExportProvider Members

RtfExportProvider Members

RtfExportProvider overview

Public Properties

DefaultExtension | Overriden. Default extension for output file.
FormatName | Overriden. Description of format.

Public Methods

NewExporter

Overriden. Creates a new Exporter object.


RtfExportProvider Properties

RtfExportProvider Properties

The properties of the RtfExportProvider class are listed here. For a complete list of RtfExportProvider class members, see the RtfExportProvider Members topic.

Public Properties

DefaultExtension | Overriden. Default extension for output file.
FormatName | Overriden. Description of format.


RtfExportProvider.DefaultExtension Property

RtfExportProvider.DefaultExtension Property

Default extension for output file.

[Visual Basic]

Overrides Public ReadOnly Property DefaultExtension As String

[C#]

override public string DefaultExtension {get;}

[Delphi]

public property DefaultExtension: String read get_DefaultExtension;


RtfExportProvider.FormatName Property

RtfExportProvider.FormatName Property

Description of format.

[Visual Basic]

Overrides Public ReadOnly Property FormatName As String

[C#]

override public string FormatName {get;}

[Delphi]

public property FormatName: String read get_FormatName;


RtfExportProvider Methods

RtfExportProvider Methods

The methods of the RtfExportProvider class are listed here. For a complete list of RtfExportProvider class members, see the RtfExportProvider Members topic.

Public Methods

NewExporter

Overriden. Creates a new Exporter object.


RtfExportProvider.NewExporter Method

RtfExportProvider.NewExporter Method

Creates a new Exporter object.

[Visual Basic]

Overrides Public Function NewExporter() As Exporter

[C#]

override public Exporter NewExporter()

[Delphi]

public function NewExporter():
Exporter;
override;

Return Value

Returns the created object.


RtfOptionsForm Class

RtfOptionsForm Class

For a list of all members of this type, see RtfOptionsForm Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Windows.Forms.Control

System.Windows.Forms.ScrollableControl

System.Windows.Forms.ContainerControl

System.Windows.Forms.Form

C1.C1Preview.Forms.BaseForm

C1.C1Preview.Export.ExportOptionsFormBase

C1.C1Preview.Export.ComplexExporterOptionsForm

C1.C1Preview.Export.RtfOptionsForm

[Visual Basic]

Public Class RtfOptionsForm

Inherits ComplexExporterOptionsForm

[C#]

public class RtfOptionsForm : ComplexExporterOptionsForm

[Delphi]

type RtfOptionsForm = class (ComplexExporterOptionsForm);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


RtfOptionsForm Members

RtfOptionsForm Members

RtfOptionsForm overview

Public Properties

AcceptButton (inherited from Form) | The accept button of the form. If this is set, the button is clicked whenever the user presses the ENTER key.
AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
ActiveControl (inherited from ContainerControl) | The currently active control.
ActiveMdiChild (inherited from Form) | The currently active MDI child form.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Indicates whether the opacity of the control can be adjusted.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
AutoScaleMode (inherited from ContainerControl) | Determines how the form or control will scale when screen resolution or fonts change.
AutoScrollMargin (inherited from ScrollableControl) | The margin around controls during auto scroll.
AutoScrollMinSize (inherited from ScrollableControl) | The minimum logical size for the auto scroll region.
AutoScrollPosition (inherited from ScrollableControl) | The current position of the auto-scrolling scroll bar.
AutoSizeMode (inherited from Form) | Specifies the mode by which the user interface element automatically resizes itself.
BackgroundImage (inherited from Control) | The background image used for the control.
BackgroundImageLayout (inherited from Control) | The background image layout used for the component.
BindingContext (inherited from ContainerControl) | The binding manager for the container control. This manages all bindings of child controls to lists.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CancelButton (inherited from Form) | The cancel button of the form. If this property is set, the button is clicked whenever the user presses the ESC key.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
CausesValidation (inherited from Control) | Indicates whether this component raises validation events.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ContextMenuStrip (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ControlBox (inherited from Form) | Determines whether a form has a Control/System menu box.
Controls (inherited from Control) | The collection of child controls within this control.
Created (inherited from Control) | Determines if the control has been fully created.
Cursor (inherited from Control) | The cursor that appears when the pointer moves over the control.
DataBindings (inherited from Control) | The data bindings for the control.
DesktopBounds (inherited from Form) | The bounds of this form in desktop coordinates.
DesktopLocation (inherited from Form) | The location of this form in desktop coordinates.
DialogResult (inherited from Form) | The value this form will return if displayed as a dialog box.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
Enabled (inherited from Control) | Indicates whether the control is enabled.
Focused (inherited from Control) | Determines if this control has focus.
Font (inherited from Control) | The font used to display text in the control.
ForeColor (inherited from Control) | The foreground color of this component, which is used to display text.
FormBorderStyle (inherited from Form) | Indicates the appearance and behavior of the border and title bar of the form.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HelpButton (inherited from Form) | Determines whether a form has a Help button on the caption bar.
HorizontalScroll (inherited from ScrollableControl) | Gets the horizontal scroll bar for this ScrollableControl.
Icon (inherited from Form) | Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Determines whether the form is a child of a MDI container.
IsMdiContainer (inherited from Form) | Determines whether the form is an MDI container.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
KeyPreview (inherited from Form) | Determines whether keyboard events for controls on the form are registered with the form.
Left (inherited from Control) | The upper left of the control, in container coordinates.
MainMenuStrip (inherited from Form) | Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.
MaximizeBox (inherited from Form) | Determines whether a form has a maximize box in the upper-right corner of its caption bar.
MaximumSize (inherited from Form) | The maximum size the form can be resized to.
MdiChildren (inherited from Form) | Retrieves the MDI children of this form.
MdiParent (inherited from Form) | Retrieves the MDI parent of this form.
Menu (inherited from Form) | The main menu of the form. This must be set to a component of type MainMenu.
MergedMenu (inherited from Form) | The merged menu of this form, which is used when displaying a single merged MDI menu.
MinimizeBox (inherited from Form) | Determines whether a form has a minimize box in the upper-right corner of its caption bar.
MinimumSize (inherited from Form) | The minimum size the form can be resized to.
Modal (inherited from Form) | Indicates if this form is currently being displayed as a modal dialog box.
Opacity (inherited from Form) | The opacity percentage of the control.
OwnedForms (inherited from Form) | Array of forms owned by this form.
Owner (inherited from Form) | The owner of this form.
Padding (inherited from Control) | Specifies the interior spacing of a control.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from ContainerControl) | The parent form of this container control.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
RightToLeftLayout (inherited from Form) | Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.
ShowIcon (inherited from Form) | Indicates whether an icon is displayed in the title bar of the form.
ShowInTaskbar (inherited from Form) | Determines whether the form appears in the Windows Taskbar.
SizeGripStyle (inherited from Form) | Determines when the SizeGrip will be displayed for the form.
StartPosition (inherited from Form) | Determines the position of a form when it first appears.
Tag (inherited from Control) | User-defined data associated with the object.
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
TopMost (inherited from Form) | Indicates whether the form always appears above all other forms that do not have this property set to True.
TransparencyKey (inherited from Form) | A color which will appear transparent when painted on the form.
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
VerticalScroll (inherited from ScrollableControl) | Gets the vertical scroll bar for this ScrollableControl.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
Width (inherited from Control) | The width of the control, in container coordinates.
WindowState (inherited from Form) | Determines the initial visual state of the form.

Public Events

Activated (inherited from Form) | Occurs whenever the form is activated.
AutoSizeChanged (inherited from Form) | Occurs when the AutoSize property has changed.
BackColorChanged (inherited from Control) | Event raised when the value of the BackColor property is changed on Control.
BackgroundImageChanged (inherited from Control) | Event raised when the value of the BackgroundImage property is changed on Control.
BackgroundImageLayoutChanged (inherited from Control) | Event raised when the value of the BackgroundImageLayout property is changed on Control.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
CausesValidationChanged (inherited from Control) | Event raised when the value of the CausesValidation property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
CursorChanged (inherited from Control) | Event raised when the value of the Cursor property is changed on Control.
Deactivate (inherited from Form) | Occurs whenever the form is deactivated.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
ForeColorChanged (inherited from Control) | Event raised when the value of the ForeColor property is changed on Control.
FormClosed (inherited from Form) | Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.
FormClosing (inherited from Form) | Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpButtonClicked (inherited from Form) | Event raised when the help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
InputLanguageChanged (inherited from Form) | Occurs whenever the language used for input for this form changes.
InputLanguageChanging (inherited from Form) | A request by the system to change the input language for this form. This request can be refused.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
Load (inherited from Form) | Occurs whenever the user loads the form.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Event raised when the value of the MaximizedBounds property is changed on Form.
MaximumSizeChanged (inherited from Form) | Event raised when the value of the MaximumSize property is changed on Form.
MdiChildActivate (inherited from Form) | Occurs when an MDI Child window is activated.
MenuComplete (inherited from Form) | Occurs when menu selection is completed and menu modal message loop has exited.
MenuStart (inherited from Form) | Occurs when any menu is displayed and menu modal message loop is entered.
MinimumSizeChanged (inherited from Form) | Event raised when the value of the MinimumSize property is changed on Form.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
PaddingChanged (inherited from Control) | Occurs when the Padding property has changed.
Paint (inherited from Control) | Occurs when a control needs repainting.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
ResizeBegin (inherited from Form) | Occurs when the form enters the sizing modal loop.
ResizeEnd (inherited from Form) | Occurs when the control exits the sizing modal loop.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs when the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user moves the scroll box.
Shown (inherited from Form) | Occurs whenever the form is first shown.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TextChanged (inherited from Control) | Event raised when the value of the Text property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


RtfOptionsForm Properties

RtfOptionsForm Properties

The properties of the RtfOptionsForm class are listed here. For a complete list of RtfOptionsForm class members, see the RtfOptionsForm Members topic.

Public Properties

AcceptButton (inherited from Form) | The accept button of the form. If this is set, the button is clicked whenever the user presses the ENTER key.
AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
ActiveControl (inherited from ContainerControl) | The currently active control.
ActiveMdiChild (inherited from Form) | The currently active MDI child form.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Indicates whether the opacity of the control can be adjusted.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
AutoScaleMode (inherited from ContainerControl) | Determines how the form or control will scale when screen resolution or fonts change.
AutoScrollMargin (inherited from ScrollableControl) | The margin around controls during auto scroll.
AutoScrollMinSize (inherited from ScrollableControl) | The minimum logical size for the auto scroll region.
AutoScrollPosition (inherited from ScrollableControl) | The current position of the auto-scrolling scroll bar.
AutoSizeMode (inherited from Form) | Specifies the mode by which the user interface element automatically resizes itself.
BackgroundImage (inherited from Control) | The background image used for the control.
BackgroundImageLayout (inherited from Control) | The background image layout used for the component.
BindingContext (inherited from ContainerControl) | The binding manager for the container control. This manages all bindings of child controls to lists.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CancelButton (inherited from Form) | The cancel button of the form. If this property is set, the button is clicked whenever the user presses the ESC key.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
CausesValidation (inherited from Control) | Indicates whether this component raises validation events.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ContextMenuStrip (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ControlBox (inherited from Form) | Determines whether a form has a Control/System menu box.
Controls (inherited from Control) | The collection of child controls within this control.
Created (inherited from Control) | Determines if the control has been fully created.
Cursor (inherited from Control) | The cursor that appears when the pointer moves over the control.
DataBindings (inherited from Control) | The data bindings for the control.
DesktopBounds (inherited from Form) | The bounds of this form in desktop coordinates.
DesktopLocation (inherited from Form) | The location of this form in desktop coordinates.
DialogResult (inherited from Form) | The value this form will return if displayed as a dialog box.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
Enabled (inherited from Control) | Indicates whether the control is enabled.
Focused (inherited from Control) | Determines if this control has focus.
Font (inherited from Control) | The font used to display text in the control.
ForeColor (inherited from Control) | The foreground color of this component, which is used to display text.
FormBorderStyle (inherited from Form) | Indicates the appearance and behavior of the border and title bar of the form.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HelpButton (inherited from Form) | Determines whether a form has a Help button on the caption bar.
HorizontalScroll (inherited from ScrollableControl) | Gets the horizontal scroll bar for this ScrollableControl.
Icon (inherited from Form) | Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Determines whether the form is a child of a MDI container.
IsMdiContainer (inherited from Form) | Determines whether the form is an MDI container.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
KeyPreview (inherited from Form) | Determines whether keyboard events for controls on the form are registered with the form.
Left (inherited from Control) | The upper left of the control, in container coordinates.
MainMenuStrip (inherited from Form) | Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.
MaximizeBox (inherited from Form) | Determines whether a form has a maximize box in the upper-right corner of its caption bar.
MaximumSize (inherited from Form) | The maximum size the form can be resized to.
MdiChildren (inherited from Form) | Retrieves the MDI children of this form.
MdiParent (inherited from Form) | Retrieves the MDI parent of this form.
Menu (inherited from Form) | The main menu of the form. This must be set to a component of type MainMenu.
MergedMenu (inherited from Form) | The merged menu of this form, which is used when displaying a single merged MDI menu.
MinimizeBox (inherited from Form) | Determines whether a form has a minimize box in the upper-right corner of its caption bar.
MinimumSize (inherited from Form) | The minimum size the form can be resized to.
Modal (inherited from Form) | Indicates if this form is currently being displayed as a modal dialog box.
Opacity (inherited from Form) | The opacity percentage of the control.
OwnedForms (inherited from Form) | Array of forms owned by this form.
Owner (inherited from Form) | The owner of this form.
Padding (inherited from Control) | Specifies the interior spacing of a control.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from ContainerControl) | The parent form of this container control.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
RightToLeftLayout (inherited from Form) | Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.
ShowIcon (inherited from Form) | Indicates whether an icon is displayed in the title bar of the form.
ShowInTaskbar (inherited from Form) | Determines whether the form appears in the Windows Taskbar.
SizeGripStyle (inherited from Form) | Determines when the SizeGrip will be displayed for the form.
StartPosition (inherited from Form) | Determines the position of a form when it first appears.
Tag (inherited from Control) | User-defined data associated with the object.
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
TopMost (inherited from Form) | Indicates whether the form always appears above all other forms that do not have this property set to True.
TransparencyKey (inherited from Form) | A color which will appear transparent when painted on the form.
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
VerticalScroll (inherited from ScrollableControl) | Gets the vertical scroll bar for this ScrollableControl.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
Width (inherited from Control) | The width of the control, in container coordinates.
WindowState (inherited from Form) | Determines the initial visual state of the form.


RtfOptionsForm Events

RtfOptionsForm Events

The events of the RtfOptionsForm class are listed here. For a complete list of RtfOptionsForm class members, see the RtfOptionsForm Members topic.

Public Events

Activated (inherited from Form) | Occurs whenever the form is activated.
AutoSizeChanged (inherited from Form) | Occurs when the AutoSize property has changed.
BackColorChanged (inherited from Control) | Event raised when the value of the BackColor property is changed on Control.
BackgroundImageChanged (inherited from Control) | Event raised when the value of the BackgroundImage property is changed on Control.
BackgroundImageLayoutChanged (inherited from Control) | Event raised when the value of the BackgroundImageLayout property is changed on Control.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
CausesValidationChanged (inherited from Control) | Event raised when the value of the CausesValidation property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
CursorChanged (inherited from Control) | Event raised when the value of the Cursor property is changed on Control.
Deactivate (inherited from Form) | Occurs whenever the form is deactivated.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
ForeColorChanged (inherited from Control) | Event raised when the value of the ForeColor property is changed on Control.
FormClosed (inherited from Form) | Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.
FormClosing (inherited from Form) | Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpButtonClicked (inherited from Form) | Event raised when the help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
InputLanguageChanged (inherited from Form) | Occurs whenever the language used for input for this form changes.
InputLanguageChanging (inherited from Form) | A request by the system to change the input language for this form. This request can be refused.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
Load (inherited from Form) | Occurs whenever the user loads the form.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Event raised when the value of the MaximizedBounds property is changed on Form.
MaximumSizeChanged (inherited from Form) | Event raised when the value of the MaximumSize property is changed on Form.
MdiChildActivate (inherited from Form) | Occurs when an MDI Child window is activated.
MenuComplete (inherited from Form) | Occurs when menu selection is completed and menu modal message loop has exited.
MenuStart (inherited from Form) | Occurs when any menu is displayed and menu modal message loop is entered.
MinimumSizeChanged (inherited from Form) | Event raised when the value of the MinimumSize property is changed on Form.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
PaddingChanged (inherited from Control) | Occurs when the Padding property has changed.
Paint (inherited from Control) | Occurs when a control needs repainting.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
ResizeBegin (inherited from Form) | Occurs when the form enters the sizing modal loop.
ResizeEnd (inherited from Form) | Occurs when the control exits the sizing modal loop.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs when the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user moves the scroll box.
Shown (inherited from Form) | Occurs whenever the form is first shown.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TextChanged (inherited from Control) | Event raised when the value of the Text property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


TiffExportProvider Class

TiffExportProvider Class

For a list of all members of this type, see TiffExportProvider Members.

System.Object

C1.C1Preview.Export.ExportProvider

C1.C1Preview.Export.PagesExportProvider

C1.C1Preview.Export.ImageExportProvider

C1.C1Preview.Export.TiffExportProvider

[Visual Basic]

Public Class TiffExportProvider

Inherits ImageExportProvider

[C#]

public class TiffExportProvider : ImageExportProvider

[Delphi]

type TiffExportProvider = class (ImageExportProvider);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


TiffExportProvider Members

TiffExportProvider Members

TiffExportProvider overview

Public Properties

CanExportToStream (inherited from ExportProvider) | Gets the value indicating whether the exporter can save results to stream.
SupportedDocumentInfoFields (inherited from ExportProvider) | Gets the info about fields of DocumentInfo class which are supported by underlying exporter.


TiffExportProvider Properties

TiffExportProvider Properties

The properties of the TiffExportProvider class are listed here. For a complete list of TiffExportProvider class members, see the TiffExportProvider Members topic.

Public Properties

CanExportToStream (inherited from ExportProvider) | Gets the value indicating whether the exporter can save results to stream.
SupportedDocumentInfoFields (inherited from ExportProvider) | Gets the info about fields of DocumentInfo class which are supported by underlying exporter.


XlsExporter Class

XlsExporter Class

The Excel exporter.

For a list of all members of this type, see XlsExporter Members.

System.Object

C1.C1Preview.Export.Exporter

C1.C1Preview.Export.ComplexExporter

C1.C1Preview.Export.XlsExporter

[Visual Basic]

Public Class XlsExporter

Inherits ComplexExporter

[C#]

public class XlsExporter : ComplexExporter

[Delphi]

type XlsExporter = class (ComplexExporter);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


XlsExporter Members

XlsExporter Members

XlsExporter overview

Public Properties

BookContent | Gets or sets the value indicating Excel book content.
DetectDataType | Gets or sets the value indicating whether the export module should try to auto detect the type of data (numeric, date) in the cells.
Document (inherited from Exporter) | Gets or sets the document for export.
DocumentInfo (inherited from Exporter) | Gets or sets the DocumentInfo object.
DocumentInfoFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the fields of DocumentInfo class, this form is called from options form.
FixedPositioning (inherited from ComplexExporter) | Gets or sets the value indicating whether the resulting document should match closely the exact appearance of the original document. This usually is done at the cost of preserving the original structure and/or the ease of handling of the resulting document.
FontScaling | Gets or sets the amount (in points) by which to change font sizes (may be used to better fit texts into available space).
OptionsFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the options of exporter. This form will be displayed if ShowOptions is True.
PagePerSheet | Gets or sets the value indicating whether to export each page of the document into a separate sheet.
Paginated (inherited from ComplexExporter) | Gets or sets the value indicating whether the resulting document should preserve the pagination of the original document.
Preview (inherited from Exporter) | Gets or sets value indicating whether the document must be opened after export.
Range (inherited from Exporter) | Gets or sets the range of pages that is to be exported.
RangeFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the range of document to export, this form is called from options form.
ReferenceGraphics (inherited from Exporter) | Specifies the Graphics object used in export, for example this object is used to convert EmfPlus metafiles to EmfOnly. If this property is null then the screen dc is used.
ShowOptions (inherited from Exporter) | Gets or sets value indicating whether the options dialog should be displayed before export.
Tolerance | Gets or sets the tolerance (in points) when auto-detecting the boundaries of rows and columns in the document. The smaller this amount, the greater the number of narrow rows and columns created for precise positioning of data.
UIStrings (inherited from Exporter) | Gets or sets the UIStrings object that is used to localize text messages displayed by exporter and its options form.

Public Methods

ShowOptionsDialog (inherited from Exporter)

Displays the dialog to edit options of export.


XlsExporter Properties

XlsExporter Properties

The properties of the XlsExporter class are listed here. For a complete list of XlsExporter class members, see the XlsExporter Members topic.

Public Properties

BookContent | Gets or sets the value indicating Excel book content.
DetectDataType | Gets or sets the value indicating whether the export module should try to auto detect the type of data (numeric, date) in the cells.
Document (inherited from Exporter) | Gets or sets the document for export.
DocumentInfo (inherited from Exporter) | Gets or sets the DocumentInfo object.
DocumentInfoFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the fields of DocumentInfo class, this form is called from options form.
FixedPositioning (inherited from ComplexExporter) | Gets or sets the value indicating whether the resulting document should match closely the exact appearance of the original document. This usually is done at the cost of preserving the original structure and/or the ease of handling of the resulting document.
FontScaling | Gets or sets the amount (in points) by which to change font sizes (may be used to better fit texts into available space).
OptionsFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the options of exporter. This form will be displayed if ShowOptions is True.
PagePerSheet | Gets or sets the value indicating whether to export each page of the document into a separate sheet.
Paginated (inherited from ComplexExporter) | Gets or sets the value indicating whether the resulting document should preserve the pagination of the original document.
Preview (inherited from Exporter) | Gets or sets value indicating whether the document must be opened after export.
Range (inherited from Exporter) | Gets or sets the range of pages that is to be exported.
RangeFormClass (inherited from Exporter) | Gets or sets the type of form which will be used to edit the range of document to export, this form is called from options form.
ReferenceGraphics (inherited from Exporter) | Specifies the Graphics object used in export, for example this object is used to convert EmfPlus metafiles to EmfOnly. If this property is null then the screen dc is used.
ShowOptions (inherited from Exporter) | Gets or sets value indicating whether the options dialog should be displayed before export.
Tolerance | Gets or sets the tolerance (in points) when auto-detecting the boundaries of rows and columns in the document. The smaller this amount, the greater the number of narrow rows and columns created for precise positioning of data.
UIStrings (inherited from Exporter) | Gets or sets the UIStrings object that is used to localize text messages displayed by exporter and its options form.


XlsExporter.BookContent Property

XlsExporter.BookContent Property

Gets or sets the value indicating Excel book content.

[Visual Basic]

Public Property BookContent As XlsBookContentEnum

[C#]

public XlsBookContentEnum BookContent {get;set;}

[Delphi]

public property BookContent: XlsBookContentEnum read get_BookContent write set_BookContent;

Property Value

The Excel book content.


XlsExporter.DetectDataType Property

XlsExporter.DetectDataType Property

Gets or sets the value indicating whether the export module should try to auto detect the type of data (numeric, date) in the cells.

[Visual Basic]

Public Property DetectDataType As Boolean

[C#]

public bool DetectDataType {get;set;}

[Delphi]

public property DetectDataType: Boolean read get_DetectDataType write set_DetectDataType;

Property Value

True if detect data type of the Excel cell, otherwise False.


XlsExporter.FontScaling Property

XlsExporter.FontScaling Property

Gets or sets the amount (in points) by which to change font sizes (may be used to better fit texts into available space).

[Visual Basic]

Public Property FontScaling As Single

[C#]

public float FontScaling {get;set;}

[Delphi]

public property FontScaling: Single read get_FontScaling write set_FontScaling;

Property Value

The amount (in points) by which to change font sizes.


XlsExporter.PagePerSheet Property

XlsExporter.PagePerSheet Property

Gets or sets the value indicating whether to export each page of the document into a separate sheet.

[Visual Basic]

Public Property PagePerSheet As Boolean

[C#]

public bool PagePerSheet {get;set;}

[Delphi]

public property PagePerSheet: Boolean read get_PagePerSheet write set_PagePerSheet;

Property Value

True if one page per Excel sheet, otherwise False.


XlsExporter.Tolerance Property

XlsExporter.Tolerance Property

Gets or sets the tolerance (in points) when auto-detecting the boundaries of rows and columns in the document. The smaller this amount, the greater the number of narrow rows and columns created for precise positioning of data.

[Visual Basic]

Public Property Tolerance As Int32*

[C#]

public Int32* Tolerance {get;set;}

[Delphi]

public property Tolerance: Int32* read get_Tolerance write set_Tolerance;

Property Value

The tolerance value.


XlsExporter Methods

XlsExporter Methods

The methods of the XlsExporter class are listed here. For a complete list of XlsExporter class members, see the XlsExporter Members topic.

Public Methods

ShowOptionsDialog (inherited from Exporter)

Displays the dialog to edit options of export.


XlsExportProvider Class

XlsExportProvider Class

The Excel export provider.

For a list of all members of this type, see XlsExportProvider Members.

System.Object

C1.C1Preview.Export.ExportProvider

C1.C1Preview.Export.ComplexExportProvider

C1.C1Preview.Export.XlsExportProvider

[Visual Basic]

Public Class XlsExportProvider

Inherits ComplexExportProvider

[C#]

public class XlsExportProvider : ComplexExportProvider

[Delphi]

type XlsExportProvider = class (ComplexExportProvider);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


XlsExportProvider Members

XlsExportProvider Members

XlsExportProvider overview

Public Properties

DefaultExtension | Overriden. Default extension for output file.
FormatName | Overriden. Description of format.

Public Methods

NewExporter

Overriden. Creates a new Exporter object.


XlsExportProvider Properties

XlsExportProvider Properties

The properties of the XlsExportProvider class are listed here. For a complete list of XlsExportProvider class members, see the XlsExportProvider Members topic.

Public Properties

DefaultExtension | Overriden. Default extension for output file.
FormatName | Overriden. Description of format.


XlsExportProvider.DefaultExtension Property

XlsExportProvider.DefaultExtension Property

Default extension for output file.

[Visual Basic]

Overrides Public ReadOnly Property DefaultExtension As String

[C#]

override public string DefaultExtension {get;}

[Delphi]

public property DefaultExtension: String read get_DefaultExtension;


XlsExportProvider.FormatName Property

XlsExportProvider.FormatName Property

Description of format.

[Visual Basic]

Overrides Public ReadOnly Property FormatName As String

[C#]

override public string FormatName {get;}

[Delphi]

public property FormatName: String read get_FormatName;


XlsExportProvider Methods

XlsExportProvider Methods

The methods of the XlsExportProvider class are listed here. For a complete list of XlsExportProvider class members, see the XlsExportProvider Members topic.

Public Methods

NewExporter

Overriden. Creates a new Exporter object.


XlsExportProvider.NewExporter Method

XlsExportProvider.NewExporter Method

Creates a new Exporter object.

[Visual Basic]

Overrides Public Function NewExporter() As Exporter

[C#]

override public Exporter NewExporter()

[Delphi]

public function NewExporter():
Exporter;
override;

Return Value

Returns the created object.


XlsOptionsForm Class

XlsOptionsForm Class

For a list of all members of this type, see XlsOptionsForm Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Windows.Forms.Control

System.Windows.Forms.ScrollableControl

System.Windows.Forms.ContainerControl

System.Windows.Forms.Form

C1.C1Preview.Forms.BaseForm

C1.C1Preview.Export.ExportOptionsFormBase

C1.C1Preview.Export.ComplexExporterOptionsForm

C1.C1Preview.Export.XlsOptionsForm

[Visual Basic]

Public Class XlsOptionsForm

Inherits ComplexExporterOptionsForm

[C#]

public class XlsOptionsForm : ComplexExporterOptionsForm

[Delphi]

type XlsOptionsForm = class (ComplexExporterOptionsForm);

Namespace: C1.C1Preview.Export

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


XlsOptionsForm Members

XlsOptionsForm Members

XlsOptionsForm overview

Public Properties

AcceptButton (inherited from Form) | The accept button of the form. If this is set, the button is clicked whenever the user presses the ENTER key.
AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
ActiveControl (inherited from ContainerControl) | The currently active control.
ActiveMdiChild (inherited from Form) | The currently active MDI child form.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Indicates whether the opacity of the control can be adjusted.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
AutoScaleMode (inherited from ContainerControl) | Determines how the form or control will scale when screen resolution or fonts change.
AutoScrollMargin (inherited from ScrollableControl) | The margin around controls during auto scroll.
AutoScrollMinSize (inherited from ScrollableControl) | The minimum logical size for the auto scroll region.
AutoScrollPosition (inherited from ScrollableControl) | The current position of the auto-scrolling scroll bar.
AutoSizeMode (inherited from Form) | Specifies the mode by which the user interface element automatically resizes itself.
BackgroundImage (inherited from Control) | The background image used for the control.
BackgroundImageLayout (inherited from Control) | The background image layout used for the component.
BindingContext (inherited from ContainerControl) | The binding manager for the container control. This manages all bindings of child controls to lists.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CancelButton (inherited from Form) | The cancel button of the form. If this property is set, the button is clicked whenever the user presses the ESC key.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
CausesValidation (inherited from Control) | Indicates whether this component raises validation events.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ContextMenuStrip (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ControlBox (inherited from Form) | Determines whether a form has a Control/System menu box.
Controls (inherited from Control) | The collection of child controls within this control.
Created (inherited from Control) | Determines if the control has been fully created.
Cursor (inherited from Control) | The cursor that appears when the pointer moves over the control.
DataBindings (inherited from Control) | The data bindings for the control.
DesktopBounds (inherited from Form) | The bounds of this form in desktop coordinates.
DesktopLocation (inherited from Form) | The location of this form in desktop coordinates.
DialogResult (inherited from Form) | The value this form will return if displayed as a dialog box.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
Enabled (inherited from Control) | Indicates whether the control is enabled.
Focused (inherited from Control) | Determines if this control has focus.
Font (inherited from Control) | The font used to display text in the control.
ForeColor (inherited from Control) | The foreground color of this component, which is used to display text.
FormBorderStyle (inherited from Form) | Indicates the appearance and behavior of the border and title bar of the form.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HelpButton (inherited from Form) | Determines whether a form has a Help button on the caption bar.
HorizontalScroll (inherited from ScrollableControl) | Gets the horizontal scroll bar for this ScrollableControl.
Icon (inherited from Form) | Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Determines whether the form is a child of a MDI container.
IsMdiContainer (inherited from Form) | Determines whether the form is an MDI container.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
KeyPreview (inherited from Form) | Determines whether keyboard events for controls on the form are registered with the form.
Left (inherited from Control) | The upper left of the control, in container coordinates.
MainMenuStrip (inherited from Form) | Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.
MaximizeBox (inherited from Form) | Determines whether a form has a maximize box in the upper-right corner of its caption bar.
MaximumSize (inherited from Form) | The maximum size the form can be resized to.
MdiChildren (inherited from Form) | Retrieves the MDI children of this form.
MdiParent (inherited from Form) | Retrieves the MDI parent of this form.
Menu (inherited from Form) | The main menu of the form. This must be set to a component of type MainMenu.
MergedMenu (inherited from Form) | The merged menu of this form, which is used when displaying a single merged MDI menu.
MinimizeBox (inherited from Form) | Determines whether a form has a minimize box in the upper-right corner of its caption bar.
MinimumSize (inherited from Form) | The minimum size the form can be resized to.
Modal (inherited from Form) | Indicates if this form is currently being displayed as a modal dialog box.
Opacity (inherited from Form) | The opacity percentage of the control.
OwnedForms (inherited from Form) | Array of forms owned by this form.
Owner (inherited from Form) | The owner of this form.
Padding (inherited from Control) | Specifies the interior spacing of a control.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from ContainerControl) | The parent form of this container control.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
RightToLeftLayout (inherited from Form) | Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.
ShowIcon (inherited from Form) | Indicates whether an icon is displayed in the title bar of the form.
ShowInTaskbar (inherited from Form) | Determines whether the form appears in the Windows Taskbar.
SizeGripStyle (inherited from Form) | Determines when the SizeGrip will be displayed for the form.
StartPosition (inherited from Form) | Determines the position of a form when it first appears.
Tag (inherited from Control) | User-defined data associated with the object.
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
TopMost (inherited from Form) | Indicates whether the form always appears above all other forms that do not have this property set to True.
TransparencyKey (inherited from Form) | A color which will appear transparent when painted on the form.
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
VerticalScroll (inherited from ScrollableControl) | Gets the vertical scroll bar for this ScrollableControl.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
Width (inherited from Control) | The width of the control, in container coordinates.
WindowState (inherited from Form) | Determines the initial visual state of the form.

Public Events

Activated (inherited from Form) | Occurs whenever the form is activated.
AutoSizeChanged (inherited from Form) | Occurs when the AutoSize property has changed.
BackColorChanged (inherited from Control) | Event raised when the value of the BackColor property is changed on Control.
BackgroundImageChanged (inherited from Control) | Event raised when the value of the BackgroundImage property is changed on Control.
BackgroundImageLayoutChanged (inherited from Control) | Event raised when the value of the BackgroundImageLayout property is changed on Control.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
CausesValidationChanged (inherited from Control) | Event raised when the value of the CausesValidation property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
CursorChanged (inherited from Control) | Event raised when the value of the Cursor property is changed on Control.
Deactivate (inherited from Form) | Occurs whenever the form is deactivated.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
ForeColorChanged (inherited from Control) | Event raised when the value of the ForeColor property is changed on Control.
FormClosed (inherited from Form) | Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.
FormClosing (inherited from Form) | Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpButtonClicked (inherited from Form) | Event raised when the help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
InputLanguageChanged (inherited from Form) | Occurs whenever the language used for input for this form changes.
InputLanguageChanging (inherited from Form) | A request by the system to change the input language for this form. This request can be refused.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
Load (inherited from Form) | Occurs whenever the user loads the form.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Event raised when the value of the MaximizedBounds property is changed on Form.
MaximumSizeChanged (inherited from Form) | Event raised when the value of the MaximumSize property is changed on Form.
MdiChildActivate (inherited from Form) | Occurs when an MDI Child window is activated.
MenuComplete (inherited from Form) | Occurs when menu selection is completed and menu modal message loop has exited.
MenuStart (inherited from Form) | Occurs when any menu is displayed and menu modal message loop is entered.
MinimumSizeChanged (inherited from Form) | Event raised when the value of the MinimumSize property is changed on Form.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
PaddingChanged (inherited from Control) | Occurs when the Padding property has changed.
Paint (inherited from Control) | Occurs when a control needs repainting.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
ResizeBegin (inherited from Form) | Occurs when the form enters the sizing modal loop.
ResizeEnd (inherited from Form) | Occurs when the control exits the sizing modal loop.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs when the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user moves the scroll box.
Shown (inherited from Form) | Occurs whenever the form is first shown.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TextChanged (inherited from Control) | Event raised when the value of the Text property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


XlsOptionsForm Properties

XlsOptionsForm Properties

The properties of the XlsOptionsForm class are listed here. For a complete list of XlsOptionsForm class members, see the XlsOptionsForm Members topic.

Public Properties

AcceptButton (inherited from Form) | The accept button of the form. If this is set, the button is clicked whenever the user presses the ENTER key.
AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
ActiveControl (inherited from ContainerControl) | The currently active control.
ActiveMdiChild (inherited from Form) | The currently active MDI child form.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Indicates whether the opacity of the control can be adjusted.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
AutoScaleMode (inherited from ContainerControl) | Determines how the form or control will scale when screen resolution or fonts change.
AutoScrollMargin (inherited from ScrollableControl) | The margin around controls during auto scroll.
AutoScrollMinSize (inherited from ScrollableControl) | The minimum logical size for the auto scroll region.
AutoScrollPosition (inherited from ScrollableControl) | The current position of the auto-scrolling scroll bar.
AutoSizeMode (inherited from Form) | Specifies the mode by which the user interface element automatically resizes itself.
BackgroundImage (inherited from Control) | The background image used for the control.
BackgroundImageLayout (inherited from Control) | The background image layout used for the component.
BindingContext (inherited from ContainerControl) | The binding manager for the container control. This manages all bindings of child controls to lists.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CancelButton (inherited from Form) | The cancel button of the form. If this property is set, the button is clicked whenever the user presses the ESC key.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
CausesValidation (inherited from Control) | Indicates whether this component raises validation events.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ContextMenuStrip (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ControlBox (inherited from Form) | Determines whether a form has a Control/System menu box.
Controls (inherited from Control) | The collection of child controls within this control.
Created (inherited from Control) | Determines if the control has been fully created.
Cursor (inherited from Control) | The cursor that appears when the pointer moves over the control.
DataBindings (inherited from Control) | The data bindings for the control.
DesktopBounds (inherited from Form) | The bounds of this form in desktop coordinates.
DesktopLocation (inherited from Form) | The location of this form in desktop coordinates.
DialogResult (inherited from Form) | The value this form will return if displayed as a dialog box.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
Enabled (inherited from Control) | Indicates whether the control is enabled.
Focused (inherited from Control) | Determines if this control has focus.
Font (inherited from Control) | The font used to display text in the control.
ForeColor (inherited from Control) | The foreground color of this component, which is used to display text.
FormBorderStyle (inherited from Form) | Indicates the appearance and behavior of the border and title bar of the form.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HelpButton (inherited from Form) | Determines whether a form has a Help button on the caption bar.
HorizontalScroll (inherited from ScrollableControl) | Gets the horizontal scroll bar for this ScrollableControl.
Icon (inherited from Form) | Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Determines whether the form is a child of a MDI container.
IsMdiContainer (inherited from Form) | Determines whether the form is an MDI container.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
KeyPreview (inherited from Form) | Determines whether keyboard events for controls on the form are registered with the form.
Left (inherited from Control) | The upper left of the control, in container coordinates.
MainMenuStrip (inherited from Form) | Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.
MaximizeBox (inherited from Form) | Determines whether a form has a maximize box in the upper-right corner of its caption bar.
MaximumSize (inherited from Form) | The maximum size the form can be resized to.
MdiChildren (inherited from Form) | Retrieves the MDI children of this form.
MdiParent (inherited from Form) | Retrieves the MDI parent of this form.
Menu (inherited from Form) | The main menu of the form. This must be set to a component of type MainMenu.
MergedMenu (inherited from Form) | The merged menu of this form, which is used when displaying a single merged MDI menu.
MinimizeBox (inherited from Form) | Determines whether a form has a minimize box in the upper-right corner of its caption bar.
MinimumSize (inherited from Form) | The minimum size the form can be resized to.
Modal (inherited from Form) | Indicates if this form is currently being displayed as a modal dialog box.
Opacity (inherited from Form) | The opacity percentage of the control.
OwnedForms (inherited from Form) | Array of forms owned by this form.
Owner (inherited from Form) | The owner of this form.
Padding (inherited from Control) | Specifies the interior spacing of a control.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from ContainerControl) | The parent form of this container control.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
RightToLeftLayout (inherited from Form) | Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.
ShowIcon (inherited from Form) | Indicates whether an icon is displayed in the title bar of the form.
ShowInTaskbar (inherited from Form) | Determines whether the form appears in the Windows Taskbar.
SizeGripStyle (inherited from Form) | Determines when the SizeGrip will be displayed for the form.
StartPosition (inherited from Form) | Determines the position of a form when it first appears.
Tag (inherited from Control) | User-defined data associated with the object.
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
TopMost (inherited from Form) | Indicates whether the form always appears above all other forms that do not have this property set to True.
TransparencyKey (inherited from Form) | A color which will appear transparent when painted on the form.
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
VerticalScroll (inherited from ScrollableControl) | Gets the vertical scroll bar for this ScrollableControl.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
Width (inherited from Control) | The width of the control, in container coordinates.
WindowState (inherited from Form) | Determines the initial visual state of the form.


XlsOptionsForm Events

XlsOptionsForm Events

The events of the XlsOptionsForm class are listed here. For a complete list of XlsOptionsForm class members, see the XlsOptionsForm Members topic.

Public Events

Activated (inherited from Form) | Occurs whenever the form is activated.
AutoSizeChanged (inherited from Form) | Occurs when the AutoSize property has changed.
BackColorChanged (inherited from Control) | Event raised when the value of the BackColor property is changed on Control.
BackgroundImageChanged (inherited from Control) | Event raised when the value of the BackgroundImage property is changed on Control.
BackgroundImageLayoutChanged (inherited from Control) | Event raised when the value of the BackgroundImageLayout property is changed on Control.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
CausesValidationChanged (inherited from Control) | Event raised when the value of the CausesValidation property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
CursorChanged (inherited from Control) | Event raised when the value of the Cursor property is changed on Control.
Deactivate (inherited from Form) | Occurs whenever the form is deactivated.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
ForeColorChanged (inherited from Control) | Event raised when the value of the ForeColor property is changed on Control.
FormClosed (inherited from Form) | Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.
FormClosing (inherited from Form) | Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpButtonClicked (inherited from Form) | Event raised when the help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
InputLanguageChanged (inherited from Form) | Occurs whenever the language used for input for this form changes.
InputLanguageChanging (inherited from Form) | A request by the system to change the input language for this form. This request can be refused.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
Load (inherited from Form) | Occurs whenever the user loads the form.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Event raised when the value of the MaximizedBounds property is changed on Form.
MaximumSizeChanged (inherited from Form) | Event raised when the value of the MaximumSize property is changed on Form.
MdiChildActivate (inherited from Form) | Occurs when an MDI Child window is activated.
MenuComplete (inherited from Form) | Occurs when menu selection is completed and menu modal message loop has exited.
MenuStart (inherited from Form) | Occurs when any menu is displayed and menu modal message loop is entered.
MinimumSizeChanged (inherited from Form) | Event raised when the value of the MinimumSize property is changed on Form.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
PaddingChanged (inherited from Control) | Occurs when the Padding property has changed.
Paint (inherited from Control) | Occurs when a control needs repainting.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
ResizeBegin (inherited from Form) | Occurs when the form enters the sizing modal loop.
ResizeEnd (inherited from Form) | Occurs when the control exits the sizing modal loop.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs when the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user moves the scroll box.
Shown (inherited from Form) | Occurs whenever the form is first shown.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TextChanged (inherited from Control) | Event raised when the value of the Text property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


C1.C1Preview.Forms Namespace

C1.C1Preview.Forms Namespace

C1.C1Preview.Forms Hierarchy

Classes

Class | Description
BaseForm | Base class for all custom forms in the C1Preview.
DocumentInfoForm |
OutputRangeForm |

See Also

C1.C1Preview.2 Assembly


BaseForm Class

BaseForm Class

Base class for all custom forms in the C1Preview.

For a list of all members of this type, see BaseForm Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Windows.Forms.Control

System.Windows.Forms.ScrollableControl

System.Windows.Forms.ContainerControl

System.Windows.Forms.Form

C1.C1Preview.Forms.BaseForm

C1.C1Preview.Export.ExportOptionsFormBase

C1.C1Preview.Forms.DocumentInfoForm

C1.C1Preview.Forms.OutputRangeForm

[Visual Basic]

Public Class BaseForm

Inherits Form

[C#]

public class BaseForm : Form

[Delphi]

type BaseForm = class (Form);

Namespace: C1.C1Preview.Forms

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


BaseForm Members

BaseForm Members

BaseForm overview

Public Properties

AcceptButton (inherited from Form) | The accept button of the form. If this is set, the button is clicked whenever the user presses the ENTER key.
AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
ActiveControl (inherited from ContainerControl) | The currently active control.
ActiveMdiChild (inherited from Form) | The currently active MDI child form.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Indicates whether the opacity of the control can be adjusted.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
AutoScaleMode (inherited from ContainerControl) | Determines how the form or control will scale when screen resolution or fonts change.
AutoScrollMargin (inherited from ScrollableControl) | The margin around controls during auto scroll.
AutoScrollMinSize (inherited from ScrollableControl) | The minimum logical size for the auto scroll region.
AutoScrollPosition (inherited from ScrollableControl) | The current position of the auto-scrolling scroll bar.
AutoSizeMode (inherited from Form) | Specifies the mode by which the user interface element automatically resizes itself.
BackgroundImage (inherited from Control) | The background image used for the control.
BackgroundImageLayout (inherited from Control) | The background image layout used for the component.
BindingContext (inherited from ContainerControl) | The binding manager for the container control. This manages all bindings of child controls to lists.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CancelButton (inherited from Form) | The cancel button of the form. If this property is set, the button is clicked whenever the user presses the ESC key.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
CausesValidation (inherited from Control) | Indicates whether this component raises validation events.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ContextMenuStrip (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ControlBox (inherited from Form) | Determines whether a form has a Control/System menu box.
Controls (inherited from Control) | The collection of child controls within this control.
Created (inherited from Control) | Determines if the control has been fully created.
Cursor (inherited from Control) | The cursor that appears when the pointer moves over the control.
DataBindings (inherited from Control) | The data bindings for the control.
DesktopBounds (inherited from Form) | The bounds of this form in desktop coordinates.
DesktopLocation (inherited from Form) | The location of this form in desktop coordinates.
DialogResult (inherited from Form) | The value this form will return if displayed as a dialog box.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
Enabled (inherited from Control) | Indicates whether the control is enabled.
Focused (inherited from Control) | Determines if this control has focus.
Font (inherited from Control) | The font used to display text in the control.
ForeColor (inherited from Control) | The foreground color of this component, which is used to display text.
FormBorderStyle (inherited from Form) | Indicates the appearance and behavior of the border and title bar of the form.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HelpButton (inherited from Form) | Determines whether a form has a Help button on the caption bar.
HorizontalScroll (inherited from ScrollableControl) | Gets the horizontal scroll bar for this ScrollableControl.
Icon (inherited from Form) | Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Determines whether the form is a child of a MDI container.
IsMdiContainer (inherited from Form) | Determines whether the form is an MDI container.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
KeyPreview (inherited from Form) | Determines whether keyboard events for controls on the form are registered with the form.
Left (inherited from Control) | The upper left of the control, in container coordinates.
MainMenuStrip (inherited from Form) | Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.
MaximizeBox (inherited from Form) | Determines whether a form has a maximize box in the upper-right corner of its caption bar.
MaximumSize (inherited from Form) | The maximum size the form can be resized to.
MdiChildren (inherited from Form) | Retrieves the MDI children of this form.
MdiParent (inherited from Form) | Retrieves the MDI parent of this form.
Menu (inherited from Form) | The main menu of the form. This must be set to a component of type MainMenu.
MergedMenu (inherited from Form) | The merged menu of this form, which is used when displaying a single merged MDI menu.
MinimizeBox (inherited from Form) | Determines whether a form has a minimize box in the upper-right corner of its caption bar.
MinimumSize (inherited from Form) | The minimum size the form can be resized to.
Modal (inherited from Form) | Indicates if this form is currently being displayed as a modal dialog box.
Opacity (inherited from Form) | The opacity percentage of the control.
OwnedForms (inherited from Form) | Array of forms owned by this form.
Owner (inherited from Form) | The owner of this form.
Padding (inherited from Control) | Specifies the interior spacing of a control.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from ContainerControl) | The parent form of this container control.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
RightToLeftLayout (inherited from Form) | Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.
ShowIcon (inherited from Form) | Indicates whether an icon is displayed in the title bar of the form.
ShowInTaskbar (inherited from Form) | Determines whether the form appears in the Windows Taskbar.
SizeGripStyle (inherited from Form) | Determines when the SizeGrip will be displayed for the form.
StartPosition (inherited from Form) | Determines the position of a form when it first appears.
Tag (inherited from Control) | User-defined data associated with the object.
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
TopMost (inherited from Form) | Indicates whether the form always appears above all other forms that do not have this property set to True.
TransparencyKey (inherited from Form) | A color which will appear transparent when painted on the form.
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
VerticalScroll (inherited from ScrollableControl) | Gets the vertical scroll bar for this ScrollableControl.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
Width (inherited from Control) | The width of the control, in container coordinates.
WindowState (inherited from Form) | Determines the initial visual state of the form.

Public Events

Activated (inherited from Form) | Occurs whenever the form is activated.
AutoSizeChanged (inherited from Form) | Occurs when the AutoSize property has changed.
BackColorChanged (inherited from Control) | Event raised when the value of the BackColor property is changed on Control.
BackgroundImageChanged (inherited from Control) | Event raised when the value of the BackgroundImage property is changed on Control.
BackgroundImageLayoutChanged (inherited from Control) | Event raised when the value of the BackgroundImageLayout property is changed on Control.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
CausesValidationChanged (inherited from Control) | Event raised when the value of the CausesValidation property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
CursorChanged (inherited from Control) | Event raised when the value of the Cursor property is changed on Control.
Deactivate (inherited from Form) | Occurs whenever the form is deactivated.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
ForeColorChanged (inherited from Control) | Event raised when the value of the ForeColor property is changed on Control.
FormClosed (inherited from Form) | Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.
FormClosing (inherited from Form) | Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpButtonClicked (inherited from Form) | Event raised when the help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
InputLanguageChanged (inherited from Form) | Occurs whenever the language used for input for this form changes.
InputLanguageChanging (inherited from Form) | A request by the system to change the input language for this form. This request can be refused.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
Load (inherited from Form) | Occurs whenever the user loads the form.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Event raised when the value of the MaximizedBounds property is changed on Form.
MaximumSizeChanged (inherited from Form) | Event raised when the value of the MaximumSize property is changed on Form.
MdiChildActivate (inherited from Form) | Occurs when an MDI Child window is activated.
MenuComplete (inherited from Form) | Occurs when menu selection is completed and menu modal message loop has exited.
MenuStart (inherited from Form) | Occurs when any menu is displayed and menu modal message loop is entered.
MinimumSizeChanged (inherited from Form) | Event raised when the value of the MinimumSize property is changed on Form.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
PaddingChanged (inherited from Control) | Occurs when the Padding property has changed.
Paint (inherited from Control) | Occurs when a control needs repainting.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
ResizeBegin (inherited from Form) | Occurs when the form enters the sizing modal loop.
ResizeEnd (inherited from Form) | Occurs when the control exits the sizing modal loop.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs when the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user moves the scroll box.
Shown (inherited from Form) | Occurs whenever the form is first shown.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TextChanged (inherited from Control) | Event raised when the value of the Text property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


BaseForm Properties

BaseForm Properties

The properties of the BaseForm class are listed here. For a complete list of BaseForm class members, see the BaseForm Members topic.

Public Properties

AcceptButton (inherited from Form) | The accept button of the form. If this is set, the button is clicked whenever the user presses the ENTER key.
AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
ActiveControl (inherited from ContainerControl) | The currently active control.
ActiveMdiChild (inherited from Form) | The currently active MDI child form.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Indicates whether the opacity of the control can be adjusted.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
AutoScaleMode (inherited from ContainerControl) | Determines how the form or control will scale when screen resolution or fonts change.
AutoScrollMargin (inherited from ScrollableControl) | The margin around controls during auto scroll.
AutoScrollMinSize (inherited from ScrollableControl) | The minimum logical size for the auto scroll region.
AutoScrollPosition (inherited from ScrollableControl) | The current position of the auto-scrolling scroll bar.
AutoSizeMode (inherited from Form) | Specifies the mode by which the user interface element automatically resizes itself.
BackgroundImage (inherited from Control) | The background image used for the control.
BackgroundImageLayout (inherited from Control) | The background image layout used for the component.
BindingContext (inherited from ContainerControl) | The binding manager for the container control. This manages all bindings of child controls to lists.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CancelButton (inherited from Form) | The cancel button of the form. If this property is set, the button is clicked whenever the user presses the ESC key.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
CausesValidation (inherited from Control) | Indicates whether this component raises validation events.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ContextMenuStrip (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ControlBox (inherited from Form) | Determines whether a form has a Control/System menu box.
Controls (inherited from Control) | The collection of child controls within this control.
Created (inherited from Control) | Determines if the control has been fully created.
Cursor (inherited from Control) | The cursor that appears when the pointer moves over the control.
DataBindings (inherited from Control) | The data bindings for the control.
DesktopBounds (inherited from Form) | The bounds of this form in desktop coordinates.
DesktopLocation (inherited from Form) | The location of this form in desktop coordinates.
DialogResult (inherited from Form) | The value this form will return if displayed as a dialog box.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
Enabled (inherited from Control) | Indicates whether the control is enabled.
Focused (inherited from Control) | Determines if this control has focus.
Font (inherited from Control) | The font used to display text in the control.
ForeColor (inherited from Control) | The foreground color of this component, which is used to display text.
FormBorderStyle (inherited from Form) | Indicates the appearance and behavior of the border and title bar of the form.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HelpButton (inherited from Form) | Determines whether a form has a Help button on the caption bar.
HorizontalScroll (inherited from ScrollableControl) | Gets the horizontal scroll bar for this ScrollableControl.
Icon (inherited from Form) | Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Determines whether the form is a child of a MDI container.
IsMdiContainer (inherited from Form) | Determines whether the form is an MDI container.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
KeyPreview (inherited from Form) | Determines whether keyboard events for controls on the form are registered with the form.
Left (inherited from Control) | The upper left of the control, in container coordinates.
MainMenuStrip (inherited from Form) | Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.
MaximizeBox (inherited from Form) | Determines whether a form has a maximize box in the upper-right corner of its caption bar.
MaximumSize (inherited from Form) | The maximum size the form can be resized to.
MdiChildren (inherited from Form) | Retrieves the MDI children of this form.
MdiParent (inherited from Form) | Retrieves the MDI parent of this form.
Menu (inherited from Form) | The main menu of the form. This must be set to a component of type MainMenu.
MergedMenu (inherited from Form) | The merged menu of this form, which is used when displaying a single merged MDI menu.
MinimizeBox (inherited from Form) | Determines whether a form has a minimize box in the upper-right corner of its caption bar.
MinimumSize (inherited from Form) | The minimum size the form can be resized to.
Modal (inherited from Form) | Indicates if this form is currently being displayed as a modal dialog box.
Opacity (inherited from Form) | The opacity percentage of the control.
OwnedForms (inherited from Form) | Array of forms owned by this form.
Owner (inherited from Form) | The owner of this form.
Padding (inherited from Control) | Specifies the interior spacing of a control.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from ContainerControl) | The parent form of this container control.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
RightToLeftLayout (inherited from Form) | Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.
ShowIcon (inherited from Form) | Indicates whether an icon is displayed in the title bar of the form.
ShowInTaskbar (inherited from Form) | Determines whether the form appears in the Windows Taskbar.
SizeGripStyle (inherited from Form) | Determines when the SizeGrip will be displayed for the form.
StartPosition (inherited from Form) | Determines the position of a form when it first appears.
Tag (inherited from Control) | User-defined data associated with the object.
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
TopMost (inherited from Form) | Indicates whether the form always appears above all other forms that do not have this property set to True.
TransparencyKey (inherited from Form) | A color which will appear transparent when painted on the form.
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
VerticalScroll (inherited from ScrollableControl) | Gets the vertical scroll bar for this ScrollableControl.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
Width (inherited from Control) | The width of the control, in container coordinates.
WindowState (inherited from Form) | Determines the initial visual state of the form.


BaseForm Events

BaseForm Events

The events of the BaseForm class are listed here. For a complete list of BaseForm class members, see the BaseForm Members topic.

Public Events

Activated (inherited from Form) | Occurs whenever the form is activated.
AutoSizeChanged (inherited from Form) | Occurs when the AutoSize property has changed.
BackColorChanged (inherited from Control) | Event raised when the value of the BackColor property is changed on Control.
BackgroundImageChanged (inherited from Control) | Event raised when the value of the BackgroundImage property is changed on Control.
BackgroundImageLayoutChanged (inherited from Control) | Event raised when the value of the BackgroundImageLayout property is changed on Control.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
CausesValidationChanged (inherited from Control) | Event raised when the value of the CausesValidation property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
CursorChanged (inherited from Control) | Event raised when the value of the Cursor property is changed on Control.
Deactivate (inherited from Form) | Occurs whenever the form is deactivated.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
ForeColorChanged (inherited from Control) | Event raised when the value of the ForeColor property is changed on Control.
FormClosed (inherited from Form) | Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.
FormClosing (inherited from Form) | Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpButtonClicked (inherited from Form) | Event raised when the help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
InputLanguageChanged (inherited from Form) | Occurs whenever the language used for input for this form changes.
InputLanguageChanging (inherited from Form) | A request by the system to change the input language for this form. This request can be refused.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
Load (inherited from Form) | Occurs whenever the user loads the form.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Event raised when the value of the MaximizedBounds property is changed on Form.
MaximumSizeChanged (inherited from Form) | Event raised when the value of the MaximumSize property is changed on Form.
MdiChildActivate (inherited from Form) | Occurs when an MDI Child window is activated.
MenuComplete (inherited from Form) | Occurs when menu selection is completed and menu modal message loop has exited.
MenuStart (inherited from Form) | Occurs when any menu is displayed and menu modal message loop is entered.
MinimumSizeChanged (inherited from Form) | Event raised when the value of the MinimumSize property is changed on Form.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
PaddingChanged (inherited from Control) | Occurs when the Padding property has changed.
Paint (inherited from Control) | Occurs when a control needs repainting.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
ResizeBegin (inherited from Form) | Occurs when the form enters the sizing modal loop.
ResizeEnd (inherited from Form) | Occurs when the control exits the sizing modal loop.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs when the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user moves the scroll box.
Shown (inherited from Form) | Occurs whenever the form is first shown.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TextChanged (inherited from Control) | Event raised when the value of the Text property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


DocumentInfoForm Class

DocumentInfoForm Class

For a list of all members of this type, see DocumentInfoForm Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Windows.Forms.Control

System.Windows.Forms.ScrollableControl

System.Windows.Forms.ContainerControl

System.Windows.Forms.Form

C1.C1Preview.Forms.BaseForm

C1.C1Preview.Forms.DocumentInfoForm

[Visual Basic]

Public Class DocumentInfoForm

Inherits BaseForm

[C#]

public class DocumentInfoForm : BaseForm

[Delphi]

type DocumentInfoForm = class (BaseForm);

Namespace: C1.C1Preview.Forms

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


DocumentInfoForm Members

DocumentInfoForm Members

DocumentInfoForm overview

Public Properties

AcceptButton (inherited from Form) | The accept button of the form. If this is set, the button is clicked whenever the user presses the ENTER key.
AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
ActiveControl (inherited from ContainerControl) | The currently active control.
ActiveMdiChild (inherited from Form) | The currently active MDI child form.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Indicates whether the opacity of the control can be adjusted.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
AutoScaleMode (inherited from ContainerControl) | Determines how the form or control will scale when screen resolution or fonts change.
AutoScrollMargin (inherited from ScrollableControl) | The margin around controls during auto scroll.
AutoScrollMinSize (inherited from ScrollableControl) | The minimum logical size for the auto scroll region.
AutoScrollPosition (inherited from ScrollableControl) | The current position of the auto-scrolling scroll bar.
AutoSizeMode (inherited from Form) | Specifies the mode by which the user interface element automatically resizes itself.
BackgroundImage (inherited from Control) | The background image used for the control.
BackgroundImageLayout (inherited from Control) | The background image layout used for the component.
BindingContext (inherited from ContainerControl) | The binding manager for the container control. This manages all bindings of child controls to lists.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CancelButton (inherited from Form) | The cancel button of the form. If this property is set, the button is clicked whenever the user presses the ESC key.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
CausesValidation (inherited from Control) | Indicates whether this component raises validation events.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ContextMenuStrip (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ControlBox (inherited from Form) | Determines whether a form has a Control/System menu box.
Controls (inherited from Control) | The collection of child controls within this control.
Created (inherited from Control) | Determines if the control has been fully created.
Cursor (inherited from Control) | The cursor that appears when the pointer moves over the control.
DataBindings (inherited from Control) | The data bindings for the control.
DesktopBounds (inherited from Form) | The bounds of this form in desktop coordinates.
DesktopLocation (inherited from Form) | The location of this form in desktop coordinates.
DialogResult (inherited from Form) | The value this form will return if displayed as a dialog box.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
Enabled (inherited from Control) | Indicates whether the control is enabled.
Focused (inherited from Control) | Determines if this control has focus.
Font (inherited from Control) | The font used to display text in the control.
ForeColor (inherited from Control) | The foreground color of this component, which is used to display text.
FormBorderStyle (inherited from Form) | Indicates the appearance and behavior of the border and title bar of the form.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HelpButton (inherited from Form) | Determines whether a form has a Help button on the caption bar.
HorizontalScroll (inherited from ScrollableControl) | Gets the horizontal scroll bar for this ScrollableControl.
Icon (inherited from Form) | Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Determines whether the form is a child of a MDI container.
IsMdiContainer (inherited from Form) | Determines whether the form is an MDI container.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
KeyPreview (inherited from Form) | Determines whether keyboard events for controls on the form are registered with the form.
Left (inherited from Control) | The upper left of the control, in container coordinates.
MainMenuStrip (inherited from Form) | Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.
MaximizeBox (inherited from Form) | Determines whether a form has a maximize box in the upper-right corner of its caption bar.
MaximumSize (inherited from Form) | The maximum size the form can be resized to.
MdiChildren (inherited from Form) | Retrieves the MDI children of this form.
MdiParent (inherited from Form) | Retrieves the MDI parent of this form.
Menu (inherited from Form) | The main menu of the form. This must be set to a component of type MainMenu.
MergedMenu (inherited from Form) | The merged menu of this form, which is used when displaying a single merged MDI menu.
MinimizeBox (inherited from Form) | Determines whether a form has a minimize box in the upper-right corner of its caption bar.
MinimumSize (inherited from Form) | The minimum size the form can be resized to.
Modal (inherited from Form) | Indicates if this form is currently being displayed as a modal dialog box.
Opacity (inherited from Form) | The opacity percentage of the control.
OwnedForms (inherited from Form) | Array of forms owned by this form.
Owner (inherited from Form) | The owner of this form.
Padding (inherited from Control) | Specifies the interior spacing of a control.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from ContainerControl) | The parent form of this container control.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
RightToLeftLayout (inherited from Form) | Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.
ShowIcon (inherited from Form) | Indicates whether an icon is displayed in the title bar of the form.
ShowInTaskbar (inherited from Form) | Determines whether the form appears in the Windows Taskbar.
SizeGripStyle (inherited from Form) | Determines when the SizeGrip will be displayed for the form.
StartPosition (inherited from Form) | Determines the position of a form when it first appears.
Tag (inherited from Control) | User-defined data associated with the object.
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
TopMost (inherited from Form) | Indicates whether the form always appears above all other forms that do not have this property set to True.
TransparencyKey (inherited from Form) | A color which will appear transparent when painted on the form.
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
VerticalScroll (inherited from ScrollableControl) | Gets the vertical scroll bar for this ScrollableControl.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
Width (inherited from Control) | The width of the control, in container coordinates.
WindowState (inherited from Form) | Determines the initial visual state of the form.

Public Events

Activated (inherited from Form) | Occurs whenever the form is activated.
AutoSizeChanged (inherited from Form) | Occurs when the AutoSize property has changed.
BackColorChanged (inherited from Control) | Event raised when the value of the BackColor property is changed on Control.
BackgroundImageChanged (inherited from Control) | Event raised when the value of the BackgroundImage property is changed on Control.
BackgroundImageLayoutChanged (inherited from Control) | Event raised when the value of the BackgroundImageLayout property is changed on Control.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
CausesValidationChanged (inherited from Control) | Event raised when the value of the CausesValidation property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
CursorChanged (inherited from Control) | Event raised when the value of the Cursor property is changed on Control.
Deactivate (inherited from Form) | Occurs whenever the form is deactivated.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
ForeColorChanged (inherited from Control) | Event raised when the value of the ForeColor property is changed on Control.
FormClosed (inherited from Form) | Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.
FormClosing (inherited from Form) | Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpButtonClicked (inherited from Form) | Event raised when the help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
InputLanguageChanged (inherited from Form) | Occurs whenever the language used for input for this form changes.
InputLanguageChanging (inherited from Form) | A request by the system to change the input language for this form. This request can be refused.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
Load (inherited from Form) | Occurs whenever the user loads the form.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Event raised when the value of the MaximizedBounds property is changed on Form.
MaximumSizeChanged (inherited from Form) | Event raised when the value of the MaximumSize property is changed on Form.
MdiChildActivate (inherited from Form) | Occurs when an MDI Child window is activated.
MenuComplete (inherited from Form) | Occurs when menu selection is completed and menu modal message loop has exited.
MenuStart (inherited from Form) | Occurs when any menu is displayed and menu modal message loop is entered.
MinimumSizeChanged (inherited from Form) | Event raised when the value of the MinimumSize property is changed on Form.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
PaddingChanged (inherited from Control) | Occurs when the Padding property has changed.
Paint (inherited from Control) | Occurs when a control needs repainting.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
ResizeBegin (inherited from Form) | Occurs when the form enters the sizing modal loop.
ResizeEnd (inherited from Form) | Occurs when the control exits the sizing modal loop.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs when the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user moves the scroll box.
Shown (inherited from Form) | Occurs whenever the form is first shown.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TextChanged (inherited from Control) | Event raised when the value of the Text property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


DocumentInfoForm Properties

DocumentInfoForm Properties

The properties of the DocumentInfoForm class are listed here. For a complete list of DocumentInfoForm class members, see the DocumentInfoForm Members topic.

Public Properties

AcceptButton (inherited from Form) | The accept button of the form. If this is set, the button is clicked whenever the user presses the ENTER key.
AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
ActiveControl (inherited from ContainerControl) | The currently active control.
ActiveMdiChild (inherited from Form) | The currently active MDI child form.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Indicates whether the opacity of the control can be adjusted.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
AutoScaleMode (inherited from ContainerControl) | Determines how the form or control will scale when screen resolution or fonts change.
AutoScrollMargin (inherited from ScrollableControl) | The margin around controls during auto scroll.
AutoScrollMinSize (inherited from ScrollableControl) | The minimum logical size for the auto scroll region.
AutoScrollPosition (inherited from ScrollableControl) | The current position of the auto-scrolling scroll bar.
AutoSizeMode (inherited from Form) | Specifies the mode by which the user interface element automatically resizes itself.
BackgroundImage (inherited from Control) | The background image used for the control.
BackgroundImageLayout (inherited from Control) | The background image layout used for the component.
BindingContext (inherited from ContainerControl) | The binding manager for the container control. This manages all bindings of child controls to lists.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CancelButton (inherited from Form) | The cancel button of the form. If this property is set, the button is clicked whenever the user presses the ESC key.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
CausesValidation (inherited from Control) | Indicates whether this component raises validation events.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ContextMenuStrip (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ControlBox (inherited from Form) | Determines whether a form has a Control/System menu box.
Controls (inherited from Control) | The collection of child controls within this control.
Created (inherited from Control) | Determines if the control has been fully created.
Cursor (inherited from Control) | The cursor that appears when the pointer moves over the control.
DataBindings (inherited from Control) | The data bindings for the control.
DesktopBounds (inherited from Form) | The bounds of this form in desktop coordinates.
DesktopLocation (inherited from Form) | The location of this form in desktop coordinates.
DialogResult (inherited from Form) | The value this form will return if displayed as a dialog box.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
Enabled (inherited from Control) | Indicates whether the control is enabled.
Focused (inherited from Control) | Determines if this control has focus.
Font (inherited from Control) | The font used to display text in the control.
ForeColor (inherited from Control) | The foreground color of this component, which is used to display text.
FormBorderStyle (inherited from Form) | Indicates the appearance and behavior of the border and title bar of the form.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HelpButton (inherited from Form) | Determines whether a form has a Help button on the caption bar.
HorizontalScroll (inherited from ScrollableControl) | Gets the horizontal scroll bar for this ScrollableControl.
Icon (inherited from Form) | Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Determines whether the form is a child of a MDI container.
IsMdiContainer (inherited from Form) | Determines whether the form is an MDI container.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
KeyPreview (inherited from Form) | Determines whether keyboard events for controls on the form are registered with the form.
Left (inherited from Control) | The upper left of the control, in container coordinates.
MainMenuStrip (inherited from Form) | Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.
MaximizeBox (inherited from Form) | Determines whether a form has a maximize box in the upper-right corner of its caption bar.
MaximumSize (inherited from Form) | The maximum size the form can be resized to.
MdiChildren (inherited from Form) | Retrieves the MDI children of this form.
MdiParent (inherited from Form) | Retrieves the MDI parent of this form.
Menu (inherited from Form) | The main menu of the form. This must be set to a component of type MainMenu.
MergedMenu (inherited from Form) | The merged menu of this form, which is used when displaying a single merged MDI menu.
MinimizeBox (inherited from Form) | Determines whether a form has a minimize box in the upper-right corner of its caption bar.
MinimumSize (inherited from Form) | The minimum size the form can be resized to.
Modal (inherited from Form) | Indicates if this form is currently being displayed as a modal dialog box.
Opacity (inherited from Form) | The opacity percentage of the control.
OwnedForms (inherited from Form) | Array of forms owned by this form.
Owner (inherited from Form) | The owner of this form.
Padding (inherited from Control) | Specifies the interior spacing of a control.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from ContainerControl) | The parent form of this container control.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
RightToLeftLayout (inherited from Form) | Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.
ShowIcon (inherited from Form) | Indicates whether an icon is displayed in the title bar of the form.
ShowInTaskbar (inherited from Form) | Determines whether the form appears in the Windows Taskbar.
SizeGripStyle (inherited from Form) | Determines when the SizeGrip will be displayed for the form.
StartPosition (inherited from Form) | Determines the position of a form when it first appears.
Tag (inherited from Control) | User-defined data associated with the object.
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
TopMost (inherited from Form) | Indicates whether the form always appears above all other forms that do not have this property set to True.
TransparencyKey (inherited from Form) | A color which will appear transparent when painted on the form.
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
VerticalScroll (inherited from ScrollableControl) | Gets the vertical scroll bar for this ScrollableControl.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
Width (inherited from Control) | The width of the control, in container coordinates.
WindowState (inherited from Form) | Determines the initial visual state of the form.


DocumentInfoForm Events

DocumentInfoForm Events

The events of the DocumentInfoForm class are listed here. For a complete list of DocumentInfoForm class members, see the DocumentInfoForm Members topic.

Public Events

Activated (inherited from Form) | Occurs whenever the form is activated.
AutoSizeChanged (inherited from Form) | Occurs when the AutoSize property has changed.
BackColorChanged (inherited from Control) | Event raised when the value of the BackColor property is changed on Control.
BackgroundImageChanged (inherited from Control) | Event raised when the value of the BackgroundImage property is changed on Control.
BackgroundImageLayoutChanged (inherited from Control) | Event raised when the value of the BackgroundImageLayout property is changed on Control.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
CausesValidationChanged (inherited from Control) | Event raised when the value of the CausesValidation property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
CursorChanged (inherited from Control) | Event raised when the value of the Cursor property is changed on Control.
Deactivate (inherited from Form) | Occurs whenever the form is deactivated.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
ForeColorChanged (inherited from Control) | Event raised when the value of the ForeColor property is changed on Control.
FormClosed (inherited from Form) | Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.
FormClosing (inherited from Form) | Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpButtonClicked (inherited from Form) | Event raised when the help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
InputLanguageChanged (inherited from Form) | Occurs whenever the language used for input for this form changes.
InputLanguageChanging (inherited from Form) | A request by the system to change the input language for this form. This request can be refused.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
Load (inherited from Form) | Occurs whenever the user loads the form.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Event raised when the value of the MaximizedBounds property is changed on Form.
MaximumSizeChanged (inherited from Form) | Event raised when the value of the MaximumSize property is changed on Form.
MdiChildActivate (inherited from Form) | Occurs when an MDI Child window is activated.
MenuComplete (inherited from Form) | Occurs when menu selection is completed and menu modal message loop has exited.
MenuStart (inherited from Form) | Occurs when any menu is displayed and menu modal message loop is entered.
MinimumSizeChanged (inherited from Form) | Event raised when the value of the MinimumSize property is changed on Form.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
PaddingChanged (inherited from Control) | Occurs when the Padding property has changed.
Paint (inherited from Control) | Occurs when a control needs repainting.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
ResizeBegin (inherited from Form) | Occurs when the form enters the sizing modal loop.
ResizeEnd (inherited from Form) | Occurs when the control exits the sizing modal loop.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs when the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user moves the scroll box.
Shown (inherited from Form) | Occurs whenever the form is first shown.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TextChanged (inherited from Control) | Event raised when the value of the Text property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


OutputRangeForm Class

OutputRangeForm Class

For a list of all members of this type, see OutputRangeForm Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Windows.Forms.Control

System.Windows.Forms.ScrollableControl

System.Windows.Forms.ContainerControl

System.Windows.Forms.Form

C1.C1Preview.Forms.BaseForm

C1.C1Preview.Forms.OutputRangeForm

[Visual Basic]

Public Class OutputRangeForm

Inherits BaseForm

[C#]

public class OutputRangeForm : BaseForm

[Delphi]

type OutputRangeForm = class (BaseForm);

Namespace: C1.C1Preview.Forms

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


OutputRangeForm Members

OutputRangeForm Members

OutputRangeForm overview

Public Properties

AcceptButton (inherited from Form) | The accept button of the form. If this is set, the button is clicked whenever the user presses the ENTER key.
AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
ActiveControl (inherited from ContainerControl) | The currently active control.
ActiveMdiChild (inherited from Form) | The currently active MDI child form.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Indicates whether the opacity of the control can be adjusted.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
AutoScaleMode (inherited from ContainerControl) | Determines how the form or control will scale when screen resolution or fonts change.
AutoScrollMargin (inherited from ScrollableControl) | The margin around controls during auto scroll.
AutoScrollMinSize (inherited from ScrollableControl) | The minimum logical size for the auto scroll region.
AutoScrollPosition (inherited from ScrollableControl) | The current position of the auto-scrolling scroll bar.
AutoSizeMode (inherited from Form) | Specifies the mode by which the user interface element automatically resizes itself.
BackgroundImage (inherited from Control) | The background image used for the control.
BackgroundImageLayout (inherited from Control) | The background image layout used for the component.
BindingContext (inherited from ContainerControl) | The binding manager for the container control. This manages all bindings of child controls to lists.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CancelButton (inherited from Form) | The cancel button of the form. If this property is set, the button is clicked whenever the user presses the ESC key.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
CausesValidation (inherited from Control) | Indicates whether this component raises validation events.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ContextMenuStrip (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ControlBox (inherited from Form) | Determines whether a form has a Control/System menu box.
Controls (inherited from Control) | The collection of child controls within this control.
Created (inherited from Control) | Determines if the control has been fully created.
Cursor (inherited from Control) | The cursor that appears when the pointer moves over the control.
DataBindings (inherited from Control) | The data bindings for the control.
DesktopBounds (inherited from Form) | The bounds of this form in desktop coordinates.
DesktopLocation (inherited from Form) | The location of this form in desktop coordinates.
DialogResult (inherited from Form) | The value this form will return if displayed as a dialog box.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
Enabled (inherited from Control) | Indicates whether the control is enabled.
Focused (inherited from Control) | Determines if this control has focus.
Font (inherited from Control) | The font used to display text in the control.
ForeColor (inherited from Control) | The foreground color of this component, which is used to display text.
FormBorderStyle (inherited from Form) | Indicates the appearance and behavior of the border and title bar of the form.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HelpButton (inherited from Form) | Determines whether a form has a Help button on the caption bar.
HorizontalScroll (inherited from ScrollableControl) | Gets the horizontal scroll bar for this ScrollableControl.
Icon (inherited from Form) | Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Determines whether the form is a child of a MDI container.
IsMdiContainer (inherited from Form) | Determines whether the form is an MDI container.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
KeyPreview (inherited from Form) | Determines whether keyboard events for controls on the form are registered with the form.
Left (inherited from Control) | The upper left of the control, in container coordinates.
MainMenuStrip (inherited from Form) | Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.
MaximizeBox (inherited from Form) | Determines whether a form has a maximize box in the upper-right corner of its caption bar.
MaximumSize (inherited from Form) | The maximum size the form can be resized to.
MdiChildren (inherited from Form) | Retrieves the MDI children of this form.
MdiParent (inherited from Form) | Retrieves the MDI parent of this form.
Menu (inherited from Form) | The main menu of the form. This must be set to a component of type MainMenu.
MergedMenu (inherited from Form) | The merged menu of this form, which is used when displaying a single merged MDI menu.
MinimizeBox (inherited from Form) | Determines whether a form has a minimize box in the upper-right corner of its caption bar.
MinimumSize (inherited from Form) | The minimum size the form can be resized to.
Modal (inherited from Form) | Indicates if this form is currently being displayed as a modal dialog box.
Opacity (inherited from Form) | The opacity percentage of the control.
OwnedForms (inherited from Form) | Array of forms owned by this form.
Owner (inherited from Form) | The owner of this form.
Padding (inherited from Control) | Specifies the interior spacing of a control.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from ContainerControl) | The parent form of this container control.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
RightToLeftLayout (inherited from Form) | Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.
ShowIcon (inherited from Form) | Indicates whether an icon is displayed in the title bar of the form.
ShowInTaskbar (inherited from Form) | Determines whether the form appears in the Windows Taskbar.
SizeGripStyle (inherited from Form) | Determines when the SizeGrip will be displayed for the form.
StartPosition (inherited from Form) | Determines the position of a form when it first appears.
Tag (inherited from Control) | User-defined data associated with the object.
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
TopMost (inherited from Form) | Indicates whether the form always appears above all other forms that do not have this property set to True.
TransparencyKey (inherited from Form) | A color which will appear transparent when painted on the form.
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
VerticalScroll (inherited from ScrollableControl) | Gets the vertical scroll bar for this ScrollableControl.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
Width (inherited from Control) | The width of the control, in container coordinates.
WindowState (inherited from Form) | Determines the initial visual state of the form.

Public Events

Activated (inherited from Form) | Occurs whenever the form is activated.
AutoSizeChanged (inherited from Form) | Occurs when the AutoSize property has changed.
BackColorChanged (inherited from Control) | Event raised when the value of the BackColor property is changed on Control.
BackgroundImageChanged (inherited from Control) | Event raised when the value of the BackgroundImage property is changed on Control.
BackgroundImageLayoutChanged (inherited from Control) | Event raised when the value of the BackgroundImageLayout property is changed on Control.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
CausesValidationChanged (inherited from Control) | Event raised when the value of the CausesValidation property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
CursorChanged (inherited from Control) | Event raised when the value of the Cursor property is changed on Control.
Deactivate (inherited from Form) | Occurs whenever the form is deactivated.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
ForeColorChanged (inherited from Control) | Event raised when the value of the ForeColor property is changed on Control.
FormClosed (inherited from Form) | Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.
FormClosing (inherited from Form) | Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpButtonClicked (inherited from Form) | Event raised when the help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
InputLanguageChanged (inherited from Form) | Occurs whenever the language used for input for this form changes.
InputLanguageChanging (inherited from Form) | A request by the system to change the input language for this form. This request can be refused.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
Load (inherited from Form) | Occurs whenever the user loads the form.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Event raised when the value of the MaximizedBounds property is changed on Form.
MaximumSizeChanged (inherited from Form) | Event raised when the value of the MaximumSize property is changed on Form.
MdiChildActivate (inherited from Form) | Occurs when an MDI Child window is activated.
MenuComplete (inherited from Form) | Occurs when menu selection is completed and menu modal message loop has exited.
MenuStart (inherited from Form) | Occurs when any menu is displayed and menu modal message loop is entered.
MinimumSizeChanged (inherited from Form) | Event raised when the value of the MinimumSize property is changed on Form.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
PaddingChanged (inherited from Control) | Occurs when the Padding property has changed.
Paint (inherited from Control) | Occurs when a control needs repainting.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
ResizeBegin (inherited from Form) | Occurs when the form enters the sizing modal loop.
ResizeEnd (inherited from Form) | Occurs when the control exits the sizing modal loop.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs when the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user moves the scroll box.
Shown (inherited from Form) | Occurs whenever the form is first shown.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TextChanged (inherited from Control) | Event raised when the value of the Text property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


OutputRangeForm Properties

OutputRangeForm Properties

The properties of the OutputRangeForm class are listed here. For a complete list of OutputRangeForm class members, see the OutputRangeForm Members topic.

Public Properties

AcceptButton (inherited from Form) | The accept button of the form. If this is set, the button is clicked whenever the user presses the ENTER key.
AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
ActiveControl (inherited from ContainerControl) | The currently active control.
ActiveMdiChild (inherited from Form) | The currently active MDI child form.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) | Indicates whether the opacity of the control can be adjusted.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
AutoScaleMode (inherited from ContainerControl) | Determines how the form or control will scale when screen resolution or fonts change.
AutoScrollMargin (inherited from ScrollableControl) | The margin around controls during auto scroll.
AutoScrollMinSize (inherited from ScrollableControl) | The minimum logical size for the auto scroll region.
AutoScrollPosition (inherited from ScrollableControl) | The current position of the auto-scrolling scroll bar.
AutoSizeMode (inherited from Form) | Specifies the mode by which the user interface element automatically resizes itself.
BackgroundImage (inherited from Control) | The background image used for the control.
BackgroundImageLayout (inherited from Control) | The background image layout used for the component.
BindingContext (inherited from ContainerControl) | The binding manager for the container control. This manages all bindings of child controls to lists.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CancelButton (inherited from Form) | The cancel button of the form. If this property is set, the button is clicked whenever the user presses the ESC key.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
CausesValidation (inherited from Control) | Indicates whether this component raises validation events.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ContextMenuStrip (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ControlBox (inherited from Form) | Determines whether a form has a Control/System menu box.
Controls (inherited from Control) | The collection of child controls within this control.
Created (inherited from Control) | Determines if the control has been fully created.
Cursor (inherited from Control) | The cursor that appears when the pointer moves over the control.
DataBindings (inherited from Control) | The data bindings for the control.
DesktopBounds (inherited from Form) | The bounds of this form in desktop coordinates.
DesktopLocation (inherited from Form) | The location of this form in desktop coordinates.
DialogResult (inherited from Form) | The value this form will return if displayed as a dialog box.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
Enabled (inherited from Control) | Indicates whether the control is enabled.
Focused (inherited from Control) | Determines if this control has focus.
Font (inherited from Control) | The font used to display text in the control.
ForeColor (inherited from Control) | The foreground color of this component, which is used to display text.
FormBorderStyle (inherited from Form) | Indicates the appearance and behavior of the border and title bar of the form.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HelpButton (inherited from Form) | Determines whether a form has a Help button on the caption bar.
HorizontalScroll (inherited from ScrollableControl) | Gets the horizontal scroll bar for this ScrollableControl.
Icon (inherited from Form) | Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Determines whether the form is a child of a MDI container.
IsMdiContainer (inherited from Form) | Determines whether the form is an MDI container.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
KeyPreview (inherited from Form) | Determines whether keyboard events for controls on the form are registered with the form.
Left (inherited from Control) | The upper left of the control, in container coordinates.
MainMenuStrip (inherited from Form) | Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.
MaximizeBox (inherited from Form) | Determines whether a form has a maximize box in the upper-right corner of its caption bar.
MaximumSize (inherited from Form) | The maximum size the form can be resized to.
MdiChildren (inherited from Form) | Retrieves the MDI children of this form.
MdiParent (inherited from Form) | Retrieves the MDI parent of this form.
Menu (inherited from Form) | The main menu of the form. This must be set to a component of type MainMenu.
MergedMenu (inherited from Form) | The merged menu of this form, which is used when displaying a single merged MDI menu.
MinimizeBox (inherited from Form) | Determines whether a form has a minimize box in the upper-right corner of its caption bar.
MinimumSize (inherited from Form) | The minimum size the form can be resized to.
Modal (inherited from Form) | Indicates if this form is currently being displayed as a modal dialog box.
Opacity (inherited from Form) | The opacity percentage of the control.
OwnedForms (inherited from Form) | Array of forms owned by this form.
Owner (inherited from Form) | The owner of this form.
Padding (inherited from Control) | Specifies the interior spacing of a control.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from ContainerControl) | The parent form of this container control.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
RightToLeftLayout (inherited from Form) | Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.
ShowIcon (inherited from Form) | Indicates whether an icon is displayed in the title bar of the form.
ShowInTaskbar (inherited from Form) | Determines whether the form appears in the Windows Taskbar.
SizeGripStyle (inherited from Form) | Determines when the SizeGrip will be displayed for the form.
StartPosition (inherited from Form) | Determines the position of a form when it first appears.
Tag (inherited from Control) | User-defined data associated with the object.
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
TopMost (inherited from Form) | Indicates whether the form always appears above all other forms that do not have this property set to True.
TransparencyKey (inherited from Form) | A color which will appear transparent when painted on the form.
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
VerticalScroll (inherited from ScrollableControl) | Gets the vertical scroll bar for this ScrollableControl.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
Width (inherited from Control) | The width of the control, in container coordinates.
WindowState (inherited from Form) | Determines the initial visual state of the form.


OutputRangeForm Events

OutputRangeForm Events

The events of the OutputRangeForm class are listed here. For a complete list of OutputRangeForm class members, see the OutputRangeForm Members topic.

Public Events

Activated (inherited from Form) | Occurs whenever the form is activated.
AutoSizeChanged (inherited from Form) | Occurs when the AutoSize property has changed.
BackColorChanged (inherited from Control) | Event raised when the value of the BackColor property is changed on Control.
BackgroundImageChanged (inherited from Control) | Event raised when the value of the BackgroundImage property is changed on Control.
BackgroundImageLayoutChanged (inherited from Control) | Event raised when the value of the BackgroundImageLayout property is changed on Control.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
CausesValidationChanged (inherited from Control) | Event raised when the value of the CausesValidation property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
CursorChanged (inherited from Control) | Event raised when the value of the Cursor property is changed on Control.
Deactivate (inherited from Form) | Occurs whenever the form is deactivated.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
ForeColorChanged (inherited from Control) | Event raised when the value of the ForeColor property is changed on Control.
FormClosed (inherited from Form) | Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.
FormClosing (inherited from Form) | Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpButtonClicked (inherited from Form) | Event raised when the help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
InputLanguageChanged (inherited from Form) | Occurs whenever the language used for input for this form changes.
InputLanguageChanging (inherited from Form) | A request by the system to change the input language for this form. This request can be refused.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
Load (inherited from Form) | Occurs whenever the user loads the form.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Event raised when the value of the MaximizedBounds property is changed on Form.
MaximumSizeChanged (inherited from Form) | Event raised when the value of the MaximumSize property is changed on Form.
MdiChildActivate (inherited from Form) | Occurs when an MDI Child window is activated.
MenuComplete (inherited from Form) | Occurs when menu selection is completed and menu modal message loop has exited.
MenuStart (inherited from Form) | Occurs when any menu is displayed and menu modal message loop is entered.
MinimumSizeChanged (inherited from Form) | Event raised when the value of the MinimumSize property is changed on Form.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
PaddingChanged (inherited from Control) | Occurs when the Padding property has changed.
Paint (inherited from Control) | Occurs when a control needs repainting.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
ResizeBegin (inherited from Form) | Occurs when the form enters the sizing modal loop.
ResizeEnd (inherited from Form) | Occurs when the control exits the sizing modal loop.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
RightToLeftLayoutChanged (inherited from Form) | Occurs when the value of the RightToLeftLayout property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user moves the scroll box.
Shown (inherited from Form) | Occurs whenever the form is first shown.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TextChanged (inherited from Control) | Event raised when the value of the Text property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


C1.C1Preview.Serialization Namespace

C1.C1Preview.Serialization Namespace

C1.C1Preview.Serialization Hierarchy

Classes

Class | Description
C1FormatVersion |
C1NameAlias | Allows to specify the alias for property or field. On deserialization the properties and fields are searched not only by name but also by alias.

See Also

C1.C1Preview.2 Assembly


C1FormatVersion Class

C1FormatVersion Class

For a list of all members of this type, see C1FormatVersion Members.

System.Object

C1.C1Preview.Serialization.C1FormatVersion

[Visual Basic]

Public Class C1FormatVersion

[C#]

public class C1FormatVersion

[Delphi]

type C1FormatVersion = class;

Namespace: C1.C1Preview.Serialization

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


C1FormatVersion Members

C1FormatVersion Members

C1FormatVersion overview

Public Properties

AssemblyVersion | Gets the AssemblyVersion of C1.C1Preview.2.dll assemly that supports this FormatVersion.
FormatVersion | Gets the version of C1D document format.

Public Methods

Parse

Converts a string to the C1FormatVersion object.


C1FormatVersion Properties

C1FormatVersion Properties

The properties of the C1FormatVersion class are listed here. For a complete list of C1FormatVersion class members, see the C1FormatVersion Members topic.

Public Properties

AssemblyVersion | Gets the AssemblyVersion of C1.C1Preview.2.dll assemly that supports this FormatVersion.
FormatVersion | Gets the version of C1D document format.


C1FormatVersion.AssemblyVersion Property

C1FormatVersion.AssemblyVersion Property

Gets the AssemblyVersion of C1.C1Preview.2.dll assemly that supports this FormatVersion.

[Visual Basic]

Public Property AssemblyVersion As Version

[C#]

public Version AssemblyVersion {get;set;}

[Delphi]

public property AssemblyVersion: Version read get_AssemblyVersion write set_AssemblyVersion;


C1FormatVersion.FormatVersion Property

C1FormatVersion.FormatVersion Property

Gets the version of C1D document format.

[Visual Basic]

Public Property FormatVersion As Version

[C#]

public Version FormatVersion {get;set;}

[Delphi]

public property FormatVersion: Version read get_FormatVersion write set_FormatVersion;


C1FormatVersion Methods

C1FormatVersion Methods

The methods of the C1FormatVersion class are listed here. For a complete list of C1FormatVersion class members, see the C1FormatVersion Members topic.

Public Methods

Parse

Converts a string to the C1FormatVersion object.


C1FormatVersion.Parse Method

C1FormatVersion.Parse Method

Converts a string to the C1FormatVersion object.

[Visual Basic]

Public Shared Function Parse( _

ByVal s As String, _

ByVal throwException As Boolean _

) As C1FormatVersion

[C#]

public static C1FormatVersion Parse(

string s,

bool throwException

);

[Delphi]

public class function Parse(

s: String;

throwException: Boolean

): C1FormatVersion;

Parameters

s

The string to convert.

throwException

Indicates the exception should be thrown if string can not be converted to C1FormatVersion.

Return Value

Returns instance of C1FormatVersion object or null.


C1NameAlias Class

C1NameAlias Class

Allows to specify the alias for property or field. On deserialization the properties and fields are searched not only by name but also by alias.

For a list of all members of this type, see C1NameAlias Members.

System.Object

System.Attribute

C1.C1Preview.Serialization.C1NameAlias

[Visual Basic]

NonInheritable Public Class C1NameAlias

Inherits Attribute

[C#]

public sealed class C1NameAlias : Attribute

[Delphi]

type C1NameAlias = class sealed (Attribute);

Namespace: C1.C1Preview.Serialization

Assembly: C1.C1Preview.2 (in C1.C1Preview.2.dll)


C1NameAlias Members

C1NameAlias Members

C1NameAlias overview

Public Properties

Alias

Gets the name of alias.


C1NameAlias Properties

C1NameAlias Properties

The properties of the C1NameAlias class are listed here. For a complete list of C1NameAlias class members, see the C1NameAlias Members topic.

Public Properties

Alias

Gets the name of alias.


C1NameAlias.Alias Property

C1NameAlias.Alias Property

Gets the name of alias.

[Visual Basic]

Public ReadOnly Property Alias As String

[C#]

public string Alias {get;}

[Delphi]

public property Alias: String read get_Alias;


C1.Win.C1Preview Namespace

C1.Win.C1Preview Namespace

C1.Win.C1Preview Hierarchy

Classes

Class | Description
C1PreviewCursors | Holds the cursors used by the preview pane.
C1PreviewOutlineView | Displays a tree representing the outline nodes of the connected preview pane.
C1PreviewPane | Represents the barebones control showing the preview of the associated document. To add functionality, other C1Preview components can be connected to this control.
C1PreviewPane.BusySection | Helper class providing a busy section. Usage: using (new busy = BusySection(previewPane)) { ..code... }.
C1PreviewPane.LayoutSection | Helper class providing a section inside which the preview layout is suspended. Should be used to enclose fragments of code where several properties on which the preview pages layout depends are changed. Layout updating is suspended between the construction and disposing of the class instance. Sample usage: using (LayoutSection ls = new LayoutSection(previewPane)) { ..code... }.
C1PreviewTextSearchPanel | Displays a text search panel allowing to find text in the connected preview pane.
C1PreviewThumbnailView | Displays a list of thumbnails representing the pages of the connected preview pane.
C1PrintPreviewControl | Represents an integrated preview control, containing a preview pane, a navigation panel, toolbars and a status bar.
C1PrintPreviewDialog | Displays a dialog box that shows the preview of the associated document. Includes toolbars, navigation panel and status bar.
DocumentActionEventArgs | Provides data for the PreviewAction event.
ExporterOptions | Represents the options of separate exporter, the ExportOptions class contains the list of such objects.
FormsUserActionEventArgs | Provides data for the FormsUserAction event.
HistoryItemAddingEventArgs | Contains the data for HistoryItemAdding event of C1PreviewPane.
HistoryOptions | Contains options for the preview history.
HyperlinkEventArgs | Provides a data for HyperlinkLeave and HyperlinkEnter events of C1PreviewPane.
HyperlinkJumpEventArgs | Provides a data for HyperlinkJump events of C1PreviewPane.
HyperlinkMouseEventArgs | Provides a data for HyperlinkMouseMove, HyperlinkMouseDown and HyperlinkMouseUp events of C1PreviewPane.
KeyMap | Represents a keymap used to map keystrokes to actions.
KeyMapStack | Represents a stack of keymaps used to handle keyboard.
LoadVisitedDocumentEventArgs | Contains the data for LoadVisitedDocument event of C1PreviewPane.
PreviewHistoryOptions | Defines the history related options of C1PrintPreview control.
PreviewPages | Collection of preview pages.
PreviewToolTip | Describes a tooltip that can be attached to a large control, and set (for example, from Cursor.get) depending on the current cursor location inside the control.
SaveVisitedDocumentEventArgs | Contains the data for SaveVisitedDocument event of C1PreviewPane.
ViewHistoryItem | Represents the separate item of the view history of the preview pane.
VisitedDocument | Represents the document in the collection of visited documents.
VisitedDocumentAddingEventArgs | Contains the data for VisitedDocumentAdding event of C1PreviewPane.
VisitedDocumentStorage | Contains the content of visited document, the format of content depends on the type of document (C1Doc, .NET PrintDocument, and so on).
VisitedDocumentStorageC1Doc |
VisitedDocumentStorageImages |

Delegates

Delegate | Description
HistoryItemAddingEventHandler | Represents the method that will handle an event occuring when new item adding to the ViewHistory collection.
KeyMap.DoAction | Describes an action that can be mapped to a keystroke.
LoadVisitedDocumentEventHandler | Represents the method that will handle an event occuring when visited document should be loaded from custom user-defined storage.
SaveVisitedDocumentEventHandler | Represents the method that will handle an event occuring when visited documeng should be saved to custom user-defined storage.
VisitedDocumentAddingEventHandler | Represents the method that will handle an event occuring when new item adding to the VisitedDocuments collection.

Enumerations

Enumeration | Description
C1PreviewActionEnum | Specifies the action that can be taken on the preview.
C1PreviewActionFlags | Specifies flags that can be used to group, enable and disable preview actions (see C1PreviewActionEnum).
HideMarginsFlags | Describes page margins hide/show modes (when the mouse is over the margins area).
HistorySavedActionsEnum | Defines the user actions which can be saved in the preview history.
ImageSetEnum | Describes the image set used for toolbar images of the preview actions.
MouseModeEnum | Describes the supported preview pane mouse behavior modes.
PageLayoutEnum | Describes the supported page view modes of the control.
ShowRulersFlags |
VisitedDocumentStorageEnum | Defines the modes of documents keeping in the preview history.
ZoomModeEnum | Describes the supported zoom modes of C1PrintPreview control.

Structures

Structure | Description
ViewState | Contains information about the state of C1PreviewPane: scrooling position, zoom factor, and so on.

See Also

C1.Win.C1Preview.2 Assembly


C1PreviewActionEnum Enumeration

C1PreviewActionEnum Enumeration

Specifies the action that can be taken on the preview.

[Visual Basic]

Public Enum C1PreviewActionEnum

[C#]

public enum C1PreviewActionEnum

[Delphi]

type C1PreviewActionEnum = (FileOpen, FileSave, Find, GoFirst, GoLast, GoNext, GoPageCount, GoPageLabel, GoPageNumber, GoPrev, HandTool, HistoryNext, HistoryPrev, None, PageContinuous, PageFacing, PageFacingContinuous, PageSetup, PageSingle, Print, Reflow, SelectTextTool, ZoomFactor, ZoomIn, ZoomInTool, ZoomOut, ZoomOutTool);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)

Members

Member name | Description
FileOpen |
FileSave |
Find |
GoFirst |
GoLast |
GoNext |
GoPageCount |
GoPageLabel |
GoPageNumber |
GoPrev |
HandTool |
HistoryNext |
HistoryPrev |
None |
PageContinuous |
PageFacing |
PageFacingContinuous |
PageSetup |
PageSingle |
Print |
Reflow |
SelectTextTool |
ZoomFactor |
ZoomIn |
ZoomInTool |
ZoomOut |
ZoomOutTool |

See Also

C1.Win.C1Preview Namespace


C1PreviewActionFlags Enumeration

C1PreviewActionFlags Enumeration

Specifies flags that can be used to group, enable and disable preview actions (see C1PreviewActionEnum).

[Visual Basic]

Public Enum C1PreviewActionFlags

[C#]

public enum C1PreviewActionFlags

[Delphi]

type C1PreviewActionFlags = (All, File, FileOpen, FileSave, Find, GoFirst, GoLast, GoNext, GoPage, GoPrev, HandTool, HistoryNext, HistoryPrev, Navigation, None, PageContinuous, PageFacing, PageFacingContinuous, PageSetup, PageSingle, PageView, Print, Reflow, SelectTextTool, Text, Zoom, ZoomFactor, ZoomIn, ZoomInTool, ZoomOut, ZoomOutTool);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)

Members

Member name | Description
All |
File |
FileOpen |
FileSave |
Find |
GoFirst |
GoLast |
GoNext |
GoPage |
GoPrev |
HandTool |
HistoryNext |
HistoryPrev |
Navigation |
None |
PageContinuous |
PageFacing |
PageFacingContinuous |
PageSetup |
PageSingle |
PageView |
Print |
Reflow |
SelectTextTool |
Text |
Zoom |
ZoomFactor |
ZoomIn |
ZoomInTool |
ZoomOut |
ZoomOutTool |

See Also

C1.Win.C1Preview Namespace


C1PreviewCursors Class

C1PreviewCursors Class

Holds the cursors used by the preview pane.

For a list of all members of this type, see C1PreviewCursors Members.

System.Object

C1.Win.C1Preview.C1PreviewCursors

[Visual Basic]

Public Class C1PreviewCursors

[C#]

public class C1PreviewCursors

[Delphi]

type C1PreviewCursors = class;

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


C1PreviewCursors Members

C1PreviewCursors Members

C1PreviewCursors overview

Public Properties

HandGrab | Gets or sets the hand grabbing cursor.
HandHover | Gets or sets the hand hovering cursor.
MarginsHide | Gets or sets the hide margins cursor.
MarginsHideH | Gets or sets the hide horizontal margins cursor.
MarginsHideV | Gets or sets the hide vertical margins cursor.
MarginsShow | Gets or sets the show margins cursor.
MarginsShowH | Gets or sets the show horizontal margins cursor.
MarginsShowV | Gets or sets the show vertical margins cursor.
PanMarker | Gets or sets the pan marker cursor.
PanMarkerE | Gets or sets the pan marker (east) cursor.
PanMarkerEW | Gets or sets the pan marker (east-west) cursor.
PanMarkerN | Gets or sets the pan marker (north) cursor.
PanMarkerNE | Gets or sets the pan marker (north-east) cursor.
PanMarkerNS | Gets or sets the pan marker (north-south) cursor.
PanMarkerNW | Gets or sets the pan marker (north-west) cursor.
PanMarkerS | Gets or sets the pan marker (south) cursor.
PanMarkerSE | Gets or sets the pan marker (south-east) cursor.
PanMarkerSW | Gets or sets the pan marker (south-west) cursor.
PanMarkerW | Gets or sets the pan marker (west) cursor.
ZoomIn | Gets or sets the zoom in cursor.
ZoomNone | Gets or sets the zoom disabled cursor.
ZoomOut | Gets or sets the zoom out cursor.

Public Methods

ResetHandGrab | Resets the HandGrab property to the default value.
ResetHandHover | Resets the HandHover property to the default value.
ResetMarginsHide | Resets the MarginsHide property to the default value.
ResetMarginsHideH | Resets the MarginsHideH property to the default value.
ResetMarginsHideV | Resets the MarginsHideV property to the default value.
ResetMarginsShow | Resets the MarginsShow property to the default value.
ResetMarginsShowH | Resets the MarginsShowH property to the default value.
ResetMarginsShowV | Resets the MarginsShowV property to the default value.
ResetPanMarker | Resets the PanMarker property to the default value.
ResetPanMarkerE | Resets the PanMarkerE property to the default value.
ResetPanMarkerEW | Resets the PanMarkerEW property to the default value.
ResetPanMarkerN | Resets the PanMarkerN property to the default value.
ResetPanMarkerNE | Resets the PanMarkerNE property to the default value.
ResetPanMarkerNS | Resets the PanMarkerNS property to the default value.
ResetPanMarkerNW | Resets the PanMarkerNW property to the default value.
ResetPanMarkerS | Resets the PanMarkerS property to the default value.
ResetPanMarkerSE | Resets the PanMarkerSE property to the default value.
ResetPanMarkerSW | Resets the PanMarkerSW property to the default value.
ResetPanMarkerW | Resets the PanMarkerW property to the default value.
ResetZoomIn | Resets the ZoomIn property to the default value.
ResetZoomNone | Resets the ZoomNone property to the default value.
ResetZoomOut | Resets the ZoomOut property to the default value.


C1PreviewCursors Properties

C1PreviewCursors Properties

The properties of the C1PreviewCursors class are listed here. For a complete list of C1PreviewCursors class members, see the C1PreviewCursors Members topic.

Public Properties

HandGrab | Gets or sets the hand grabbing cursor.
HandHover | Gets or sets the hand hovering cursor.
MarginsHide | Gets or sets the hide margins cursor.
MarginsHideH | Gets or sets the hide horizontal margins cursor.
MarginsHideV | Gets or sets the hide vertical margins cursor.
MarginsShow | Gets or sets the show margins cursor.
MarginsShowH | Gets or sets the show horizontal margins cursor.
MarginsShowV | Gets or sets the show vertical margins cursor.
PanMarker | Gets or sets the pan marker cursor.
PanMarkerE | Gets or sets the pan marker (east) cursor.
PanMarkerEW | Gets or sets the pan marker (east-west) cursor.
PanMarkerN | Gets or sets the pan marker (north) cursor.
PanMarkerNE | Gets or sets the pan marker (north-east) cursor.
PanMarkerNS | Gets or sets the pan marker (north-south) cursor.
PanMarkerNW | Gets or sets the pan marker (north-west) cursor.
PanMarkerS | Gets or sets the pan marker (south) cursor.
PanMarkerSE | Gets or sets the pan marker (south-east) cursor.
PanMarkerSW | Gets or sets the pan marker (south-west) cursor.
PanMarkerW | Gets or sets the pan marker (west) cursor.
ZoomIn | Gets or sets the zoom in cursor.
ZoomNone | Gets or sets the zoom disabled cursor.
ZoomOut | Gets or sets the zoom out cursor.


C1PreviewCursors.HandGrab Property

C1PreviewCursors.HandGrab Property

Gets or sets the hand grabbing cursor.

[Visual Basic]

Public Property HandGrab As Cursor

[C#]

public Cursor HandGrab {get;set;}

[Delphi]

public property HandGrab: Cursor read get_HandGrab write set_HandGrab;


C1PreviewCursors.HandHover Property

C1PreviewCursors.HandHover Property

Gets or sets the hand hovering cursor.

[Visual Basic]

Public Property HandHover As Cursor

[C#]

public Cursor HandHover {get;set;}

[Delphi]

public property HandHover: Cursor read get_HandHover write set_HandHover;


C1PreviewCursors.MarginsHide Property

C1PreviewCursors.MarginsHide Property

Gets or sets the hide margins cursor.

[Visual Basic]

Public Property MarginsHide As Cursor

[C#]

public Cursor MarginsHide {get;set;}

[Delphi]

public property MarginsHide: Cursor read get_MarginsHide write set_MarginsHide;


C1PreviewCursors.MarginsHideH Property

C1PreviewCursors.MarginsHideH Property

Gets or sets the hide horizontal margins cursor.

[Visual Basic]

Public Property MarginsHideH As Cursor

[C#]

public Cursor MarginsHideH {get;set;}

[Delphi]

public property MarginsHideH: Cursor read get_MarginsHideH write set_MarginsHideH;


C1PreviewCursors.MarginsHideV Property

C1PreviewCursors.MarginsHideV Property

Gets or sets the hide vertical margins cursor.

[Visual Basic]

Public Property MarginsHideV As Cursor

[C#]

public Cursor MarginsHideV {get;set;}

[Delphi]

public property MarginsHideV: Cursor read get_MarginsHideV write set_MarginsHideV;


C1PreviewCursors.MarginsShow Property

C1PreviewCursors.MarginsShow Property

Gets or sets the show margins cursor.

[Visual Basic]

Public Property MarginsShow As Cursor

[C#]

public Cursor MarginsShow {get;set;}

[Delphi]

public property MarginsShow: Cursor read get_MarginsShow write set_MarginsShow;


C1PreviewCursors.MarginsShowH Property

C1PreviewCursors.MarginsShowH Property

Gets or sets the show horizontal margins cursor.

[Visual Basic]

Public Property MarginsShowH As Cursor

[C#]

public Cursor MarginsShowH {get;set;}

[Delphi]

public property MarginsShowH: Cursor read get_MarginsShowH write set_MarginsShowH;


C1PreviewCursors.MarginsShowV Property

C1PreviewCursors.MarginsShowV Property

Gets or sets the show vertical margins cursor.

[Visual Basic]

Public Property MarginsShowV As Cursor

[C#]

public Cursor MarginsShowV {get;set;}

[Delphi]

public property MarginsShowV: Cursor read get_MarginsShowV write set_MarginsShowV;


C1PreviewCursors.PanMarker Property

C1PreviewCursors.PanMarker Property

Gets or sets the pan marker cursor.

[Visual Basic]

Public Property PanMarker As Cursor

[C#]

public Cursor PanMarker {get;set;}

[Delphi]

public property PanMarker: Cursor read get_PanMarker write set_PanMarker;


C1PreviewCursors.PanMarkerE Property

C1PreviewCursors.PanMarkerE Property

Gets or sets the pan marker (east) cursor.

[Visual Basic]

Public Property PanMarkerE As Cursor

[C#]

public Cursor PanMarkerE {get;set;}

[Delphi]

public property PanMarkerE: Cursor read get_PanMarkerE write set_PanMarkerE;


C1PreviewCursors.PanMarkerEW Property

C1PreviewCursors.PanMarkerEW Property

Gets or sets the pan marker (east-west) cursor.

[Visual Basic]

Public Property PanMarkerEW As Cursor

[C#]

public Cursor PanMarkerEW {get;set;}

[Delphi]

public property PanMarkerEW: Cursor read get_PanMarkerEW write set_PanMarkerEW;


C1PreviewCursors.PanMarkerN Property

C1PreviewCursors.PanMarkerN Property

Gets or sets the pan marker (north) cursor.

[Visual Basic]

Public Property PanMarkerN As Cursor

[C#]

public Cursor PanMarkerN {get;set;}

[Delphi]

public property PanMarkerN: Cursor read get_PanMarkerN write set_PanMarkerN;


C1PreviewCursors.PanMarkerNE Property

C1PreviewCursors.PanMarkerNE Property

Gets or sets the pan marker (north-east) cursor.

[Visual Basic]

Public Property PanMarkerNE As Cursor

[C#]

public Cursor PanMarkerNE {get;set;}

[Delphi]

public property PanMarkerNE: Cursor read get_PanMarkerNE write set_PanMarkerNE;


C1PreviewCursors.PanMarkerNS Property

C1PreviewCursors.PanMarkerNS Property

Gets or sets the pan marker (north-south) cursor.

[Visual Basic]

Public Property PanMarkerNS As Cursor

[C#]

public Cursor PanMarkerNS {get;set;}

[Delphi]

public property PanMarkerNS: Cursor read get_PanMarkerNS write set_PanMarkerNS;


C1PreviewCursors.PanMarkerNW Property

C1PreviewCursors.PanMarkerNW Property

Gets or sets the pan marker (north-west) cursor.

[Visual Basic]

Public Property PanMarkerNW As Cursor

[C#]

public Cursor PanMarkerNW {get;set;}

[Delphi]

public property PanMarkerNW: Cursor read get_PanMarkerNW write set_PanMarkerNW;


C1PreviewCursors.PanMarkerS Property

C1PreviewCursors.PanMarkerS Property

Gets or sets the pan marker (south) cursor.

[Visual Basic]

Public Property PanMarkerS As Cursor

[C#]

public Cursor PanMarkerS {get;set;}

[Delphi]

public property PanMarkerS: Cursor read get_PanMarkerS write set_PanMarkerS;


C1PreviewCursors.PanMarkerSE Property

C1PreviewCursors.PanMarkerSE Property

Gets or sets the pan marker (south-east) cursor.

[Visual Basic]

Public Property PanMarkerSE As Cursor

[C#]

public Cursor PanMarkerSE {get;set;}

[Delphi]

public property PanMarkerSE: Cursor read get_PanMarkerSE write set_PanMarkerSE;


C1PreviewCursors.PanMarkerSW Property

C1PreviewCursors.PanMarkerSW Property

Gets or sets the pan marker (south-west) cursor.

[Visual Basic]

Public Property PanMarkerSW As Cursor

[C#]

public Cursor PanMarkerSW {get;set;}

[Delphi]

public property PanMarkerSW: Cursor read get_PanMarkerSW write set_PanMarkerSW;


C1PreviewCursors.PanMarkerW Property

C1PreviewCursors.PanMarkerW Property

Gets or sets the pan marker (west) cursor.

[Visual Basic]

Public Property PanMarkerW As Cursor

[C#]

public Cursor PanMarkerW {get;set;}

[Delphi]

public property PanMarkerW: Cursor read get_PanMarkerW write set_PanMarkerW;


C1PreviewCursors.ZoomIn Property

C1PreviewCursors.ZoomIn Property

Gets or sets the zoom in cursor.

[Visual Basic]

Public Property ZoomIn As Cursor

[C#]

public Cursor ZoomIn {get;set;}

[Delphi]

public property ZoomIn: Cursor read get_ZoomIn write set_ZoomIn;


C1PreviewCursors.ZoomNone Property

C1PreviewCursors.ZoomNone Property

Gets or sets the zoom disabled cursor.

[Visual Basic]

Public Property ZoomNone As Cursor

[C#]

public Cursor ZoomNone {get;set;}

[Delphi]

public property ZoomNone: Cursor read get_ZoomNone write set_ZoomNone;


C1PreviewCursors.ZoomOut Property

C1PreviewCursors.ZoomOut Property

Gets or sets the zoom out cursor.

[Visual Basic]

Public Property ZoomOut As Cursor

[C#]

public Cursor ZoomOut {get;set;}

[Delphi]

public property ZoomOut: Cursor read get_ZoomOut write set_ZoomOut;


C1PreviewCursors Methods

C1PreviewCursors Methods

The methods of the C1PreviewCursors class are listed here. For a complete list of C1PreviewCursors class members, see the C1PreviewCursors Members topic.

Public Methods

ResetHandGrab | Resets the HandGrab property to the default value.
ResetHandHover | Resets the HandHover property to the default value.
ResetMarginsHide | Resets the MarginsHide property to the default value.
ResetMarginsHideH | Resets the MarginsHideH property to the default value.
ResetMarginsHideV | Resets the MarginsHideV property to the default value.
ResetMarginsShow | Resets the MarginsShow property to the default value.
ResetMarginsShowH | Resets the MarginsShowH property to the default value.
ResetMarginsShowV | Resets the MarginsShowV property to the default value.
ResetPanMarker | Resets the PanMarker property to the default value.
ResetPanMarkerE | Resets the PanMarkerE property to the default value.
ResetPanMarkerEW | Resets the PanMarkerEW property to the default value.
ResetPanMarkerN | Resets the PanMarkerN property to the default value.
ResetPanMarkerNE | Resets the PanMarkerNE property to the default value.
ResetPanMarkerNS | Resets the PanMarkerNS property to the default value.
ResetPanMarkerNW | Resets the PanMarkerNW property to the default value.
ResetPanMarkerS | Resets the PanMarkerS property to the default value.
ResetPanMarkerSE | Resets the PanMarkerSE property to the default value.
ResetPanMarkerSW | Resets the PanMarkerSW property to the default value.
ResetPanMarkerW | Resets the PanMarkerW property to the default value.
ResetZoomIn | Resets the ZoomIn property to the default value.
ResetZoomNone | Resets the ZoomNone property to the default value.
ResetZoomOut | Resets the ZoomOut property to the default value.


C1PreviewCursors.ResetHandGrab Method

C1PreviewCursors.ResetHandGrab Method

Resets the HandGrab property to the default value.

[Visual Basic]

Public Sub ResetHandGrab()

[C#]

public void ResetHandGrab()

[Delphi]

public procedure ResetHandGrab();


C1PreviewCursors.ResetHandHover Method

C1PreviewCursors.ResetHandHover Method

Resets the HandHover property to the default value.

[Visual Basic]

Public Sub ResetHandHover()

[C#]

public void ResetHandHover()

[Delphi]

public procedure ResetHandHover();


C1PreviewCursors.ResetMarginsHide Method

C1PreviewCursors.ResetMarginsHide Method

Resets the MarginsHide property to the default value.

[Visual Basic]

Public Sub ResetMarginsHide()

[C#]

public void ResetMarginsHide()

[Delphi]

public procedure ResetMarginsHide();


C1PreviewCursors.ResetMarginsHideH Method

C1PreviewCursors.ResetMarginsHideH Method

Resets the MarginsHideH property to the default value.

[Visual Basic]

Public Sub ResetMarginsHideH()

[C#]

public void ResetMarginsHideH()

[Delphi]

public procedure ResetMarginsHideH();


C1PreviewCursors.ResetMarginsHideV Method

C1PreviewCursors.ResetMarginsHideV Method

Resets the MarginsHideV property to the default value.

[Visual Basic]

Public Sub ResetMarginsHideV()

[C#]

public void ResetMarginsHideV()

[Delphi]

public procedure ResetMarginsHideV();


C1PreviewCursors.ResetMarginsShow Method

C1PreviewCursors.ResetMarginsShow Method

Resets the MarginsShow property to the default value.

[Visual Basic]

Public Sub ResetMarginsShow()

[C#]

public void ResetMarginsShow()

[Delphi]

public procedure ResetMarginsShow();


C1PreviewCursors.ResetMarginsShowH Method

C1PreviewCursors.ResetMarginsShowH Method

Resets the MarginsShowH property to the default value.

[Visual Basic]

Public Sub ResetMarginsShowH()

[C#]

public void ResetMarginsShowH()

[Delphi]

public procedure ResetMarginsShowH();


C1PreviewCursors.ResetMarginsShowV Method

C1PreviewCursors.ResetMarginsShowV Method

Resets the MarginsShowV property to the default value.

[Visual Basic]

Public Sub ResetMarginsShowV()

[C#]

public void ResetMarginsShowV()

[Delphi]

public procedure ResetMarginsShowV();


C1PreviewCursors.ResetPanMarker Method

C1PreviewCursors.ResetPanMarker Method

Resets the PanMarker property to the default value.

[Visual Basic]

Public Sub ResetPanMarker()

[C#]

public void ResetPanMarker()

[Delphi]

public procedure ResetPanMarker();


C1PreviewCursors.ResetPanMarkerE Method

C1PreviewCursors.ResetPanMarkerE Method

Resets the PanMarkerE property to the default value.

[Visual Basic]

Public Sub ResetPanMarkerE()

[C#]

public void ResetPanMarkerE()

[Delphi]

public procedure ResetPanMarkerE();


C1PreviewCursors.ResetPanMarkerEW Method

C1PreviewCursors.ResetPanMarkerEW Method

Resets the PanMarkerEW property to the default value.

[Visual Basic]

Public Sub ResetPanMarkerEW()

[C#]

public void ResetPanMarkerEW()

[Delphi]

public procedure ResetPanMarkerEW();


C1PreviewCursors.ResetPanMarkerN Method

C1PreviewCursors.ResetPanMarkerN Method

Resets the PanMarkerN property to the default value.

[Visual Basic]

Public Sub ResetPanMarkerN()

[C#]

public void ResetPanMarkerN()

[Delphi]

public procedure ResetPanMarkerN();


C1PreviewCursors.ResetPanMarkerNE Method

C1PreviewCursors.ResetPanMarkerNE Method

Resets the PanMarkerNE property to the default value.

[Visual Basic]

Public Sub ResetPanMarkerNE()

[C#]

public void ResetPanMarkerNE()

[Delphi]

public procedure ResetPanMarkerNE();


C1PreviewCursors.ResetPanMarkerNS Method

C1PreviewCursors.ResetPanMarkerNS Method

Resets the PanMarkerNS property to the default value.

[Visual Basic]

Public Sub ResetPanMarkerNS()

[C#]

public void ResetPanMarkerNS()

[Delphi]

public procedure ResetPanMarkerNS();


C1PreviewCursors.ResetPanMarkerNW Method

C1PreviewCursors.ResetPanMarkerNW Method

Resets the PanMarkerNW property to the default value.

[Visual Basic]

Public Sub ResetPanMarkerNW()

[C#]

public void ResetPanMarkerNW()

[Delphi]

public procedure ResetPanMarkerNW();


C1PreviewCursors.ResetPanMarkerS Method

C1PreviewCursors.ResetPanMarkerS Method

Resets the PanMarkerS property to the default value.

[Visual Basic]

Public Sub ResetPanMarkerS()

[C#]

public void ResetPanMarkerS()

[Delphi]

public procedure ResetPanMarkerS();


C1PreviewCursors.ResetPanMarkerSE Method

C1PreviewCursors.ResetPanMarkerSE Method

Resets the PanMarkerSE property to the default value.

[Visual Basic]

Public Sub ResetPanMarkerSE()

[C#]

public void ResetPanMarkerSE()

[Delphi]

public procedure ResetPanMarkerSE();


C1PreviewCursors.ResetPanMarkerSW Method

C1PreviewCursors.ResetPanMarkerSW Method

Resets the PanMarkerSW property to the default value.

[Visual Basic]

Public Sub ResetPanMarkerSW()

[C#]

public void ResetPanMarkerSW()

[Delphi]

public procedure ResetPanMarkerSW();


C1PreviewCursors.ResetPanMarkerW Method

C1PreviewCursors.ResetPanMarkerW Method

Resets the PanMarkerW property to the default value.

[Visual Basic]

Public Sub ResetPanMarkerW()

[C#]

public void ResetPanMarkerW()

[Delphi]

public procedure ResetPanMarkerW();


C1PreviewCursors.ResetZoomIn Method

C1PreviewCursors.ResetZoomIn Method

Resets the ZoomIn property to the default value.

[Visual Basic]

Public Sub ResetZoomIn()

[C#]

public void ResetZoomIn()

[Delphi]

public procedure ResetZoomIn();


C1PreviewCursors.ResetZoomNone Method

C1PreviewCursors.ResetZoomNone Method

Resets the ZoomNone property to the default value.

[Visual Basic]

Public Sub ResetZoomNone()

[C#]

public void ResetZoomNone()

[Delphi]

public procedure ResetZoomNone();


C1PreviewCursors.ResetZoomOut Method

C1PreviewCursors.ResetZoomOut Method

Resets the ZoomOut property to the default value.

[Visual Basic]

Public Sub ResetZoomOut()

[C#]

public void ResetZoomOut()

[Delphi]

public procedure ResetZoomOut();


C1PreviewOutlineView Class

C1PreviewOutlineView Class

Displays a tree representing the outline nodes of the connected preview pane.

For a list of all members of this type, see C1PreviewOutlineView Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Windows.Forms.Control

System.Windows.Forms.TreeView

C1.Win.C1Preview.C1PreviewOutlineView

[Visual Basic]

Public Class C1PreviewOutlineView

Inherits TreeView

Implements INotifyPropertyChanged

[C#]

public class C1PreviewOutlineView : TreeView, INotifyPropertyChanged

[Delphi]

type C1PreviewOutlineView = class (TreeView, INotifyPropertyChanged);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


C1PreviewOutlineView Members

C1PreviewOutlineView Members

C1PreviewOutlineView overview

Public Properties

AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
BindingContext (inherited from Control) | The binding context for the control.
BorderStyle (inherited from TreeView) | The border style of the control.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
CausesValidation (inherited from Control) | Indicates whether this component raises validation events.
CheckBoxes (inherited from TreeView) | Indicates whether check boxes are displayed beside nodes.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
ClientSize (inherited from Control) | Determines the size of the inner area of this control.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ContextMenuStrip (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
Controls (inherited from Control) | The collection of child controls within this control.
Created (inherited from Control) | Determines if the control has been fully created.
Cursor (inherited from Control) | The cursor that appears when the pointer moves over the control.
DataBindings (inherited from Control) | The data bindings for the control.
DisplayRectangle (inherited from Control) | Retrieves the display rectangle of this control.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
DrawMode (inherited from TreeView) | Controls whether the system or the user paints the nodes.
Enabled (inherited from Control) | Indicates whether the control is enabled.
Focused (inherited from Control) | Determines if this control has focus.
Font (inherited from Control) | The font used to display text in the control.
FullRowSelect (inherited from TreeView) | Indicates whether the highlight spans the width of the TreeView.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HideSelection (inherited from TreeView) | Removes highlight from the selected node when control does not have focus.
HotTracking (inherited from TreeView) | Indicates whether nodes give feedback when the mouse is moved over them.
ImageIndex (inherited from TreeView) | The default image index for nodes.
ImageKey (inherited from TreeView) | The default image key for nodes.
ImageList (inherited from TreeView) | The ImageList control from which node images are taken.
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
Indent (inherited from TreeView) | The indentation width of child nodes in pixels.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
ItemHeight (inherited from TreeView) | The height of every node in the TreeView.
LabelEdit (inherited from TreeView) | Indicates whether the user can edit the label text of nodes.
Left (inherited from Control) | The upper left of the control, in container coordinates.
LineColor (inherited from TreeView) | The color of the lines that connect the nodes of the TreeView.
Location (inherited from Control) | The coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Specifies space between this control and another control's margin.
MaximumSize (inherited from Control) | Specifies the maximum size of the control.
MinimumSize (inherited from Control) | Specifies the minimum size of the control.
Nodes | Gets the collection of tree nodes representing the outline entries of the document.
Parent (inherited from Control) | The parent of this control.
PathSeparator (inherited from TreeView) | The string delimiter used for the path returned by a node's FullPath property.
PreviewPane | Gets or sets the preview pane to which this outline view is connected.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
RightToLeftLayout (inherited from TreeView) | Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.
Scrollable (inherited from TreeView) | Indicates whether the control will display scroll bars if it contains more nodes than can fit in the visible area.
SelectedImageIndex (inherited from TreeView) | The default image index for selected nodes.
SelectedImageKey (inherited from TreeView) | The default image for selected nodes.
SelectedNode (inherited from TreeView) | The currently selected node, or null if no node is selected.
ShowLines (inherited from TreeView) | Indicates whether lines are displayed between sibling nodes and between parent and child nodes.
ShowNodeToolTips (inherited from TreeView) | Indicates whether ToolTips will be displayed on the nodes.
ShowPlusMinus (inherited from TreeView) | Indicates if plus/minus buttons are shown next to parent nodes.
ShowRootLines (inherited from TreeView) | Indicates whether lines are displayed between root nodes.
Size (inherited from Control) | The size of the control in pixels.
StateImageList (inherited from TreeView) | The ImageList control used by the TreeView for custom states.
TabIndex (inherited from Control) | Determines the index in the TAB order that this control will occupy.
TabStop (inherited from Control) | Indicates whether the user can use the TAB key to give focus to the control.
Tag (inherited from Control) | User-defined data associated with the object.
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
TopNode (inherited from TreeView) | The first visible node in the TreeView.
TreeViewNodeSorter (inherited from TreeView) | The sorting comparer for the TreeView.
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
VisibleCount (inherited from TreeView) | The number of visible nodes in the TreeView.
Width (inherited from Control) | The width of the control, in container coordinates.

Public Events

AfterCheck (inherited from TreeView) | Occurs when a check box on a tree node has been checked or unchecked.
AfterCollapse (inherited from TreeView) | Occurs when a node has been collapsed.
AfterExpand (inherited from TreeView) | Occurs when a node has been expanded.
AfterLabelEdit (inherited from TreeView) | Occurs when the text of a node has been edited by the user.
AfterSelect (inherited from TreeView) | Occurs when the selection has been changed.
BackColorChanged (inherited from Control) | Event raised when the value of the BackColor property is changed on Control.
BeforeCheck (inherited from TreeView) | Occurs when a check box on a tree node is about to be checked or unchecked.
BeforeCollapse (inherited from TreeView) | Occurs when a node is about to be collapsed.
BeforeExpand (inherited from TreeView) | Occurs when a node is about to be expanded.
BeforeLabelEdit (inherited from TreeView) | Occurs when the text of a node is about to be edited by the user.
BeforeSelect (inherited from TreeView) | Occurs when the selection is about to change.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
CausesValidationChanged (inherited from Control) | Event raised when the value of the CausesValidation property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
CursorChanged (inherited from Control) | Event raised when the value of the Cursor property is changed on Control.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
DrawNode (inherited from TreeView) | Occurs in owner-draw mode, when a node needs to be drawn.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
ForeColorChanged (inherited from Control) | Event raised when the value of the ForeColor property is changed on Control.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
ItemDrag (inherited from TreeView) | Occurs when the user begins dragging an item.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the Margin property has changed.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
NodeMouseClick (inherited from TreeView) | Occurs when a node is clicked with the mouse.
NodeMouseDoubleClick (inherited from TreeView) | Occurs when a node is double-clicked with the mouse.
NodeMouseHover (inherited from TreeView) | Occurs when the mouse hovers over a TreeNode.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
PropertyChanged | Occurs when a property of the outline view that is not inherited from the base class changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
RightToLeftLayoutChanged (inherited from TreeView) | Occurs when the value of the RightToLeftLayout property changes.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TabIndexChanged (inherited from Control) | Event raised when the value of the TabIndex property is changed.
TabStopChanged (inherited from Control) | Event raised when the value of the TabStop property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


C1PreviewOutlineView Properties

C1PreviewOutlineView Properties

The properties of the C1PreviewOutlineView class are listed here. For a complete list of C1PreviewOutlineView class members, see the C1PreviewOutlineView Members topic.

Public Properties

AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
BindingContext (inherited from Control) | The binding context for the control.
BorderStyle (inherited from TreeView) | The border style of the control.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
CausesValidation (inherited from Control) | Indicates whether this component raises validation events.
CheckBoxes (inherited from TreeView) | Indicates whether check boxes are displayed beside nodes.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
ClientSize (inherited from Control) | Determines the size of the inner area of this control.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ContextMenuStrip (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
Controls (inherited from Control) | The collection of child controls within this control.
Created (inherited from Control) | Determines if the control has been fully created.
Cursor (inherited from Control) | The cursor that appears when the pointer moves over the control.
DataBindings (inherited from Control) | The data bindings for the control.
DisplayRectangle (inherited from Control) | Retrieves the display rectangle of this control.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
DrawMode (inherited from TreeView) | Controls whether the system or the user paints the nodes.
Enabled (inherited from Control) | Indicates whether the control is enabled.
Focused (inherited from Control) | Determines if this control has focus.
Font (inherited from Control) | The font used to display text in the control.
FullRowSelect (inherited from TreeView) | Indicates whether the highlight spans the width of the TreeView.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HideSelection (inherited from TreeView) | Removes highlight from the selected node when control does not have focus.
HotTracking (inherited from TreeView) | Indicates whether nodes give feedback when the mouse is moved over them.
ImageIndex (inherited from TreeView) | The default image index for nodes.
ImageKey (inherited from TreeView) | The default image key for nodes.
ImageList (inherited from TreeView) | The ImageList control from which node images are taken.
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
Indent (inherited from TreeView) | The indentation width of child nodes in pixels.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
ItemHeight (inherited from TreeView) | The height of every node in the TreeView.
LabelEdit (inherited from TreeView) | Indicates whether the user can edit the label text of nodes.
Left (inherited from Control) | The upper left of the control, in container coordinates.
LineColor (inherited from TreeView) | The color of the lines that connect the nodes of the TreeView.
Location (inherited from Control) | The coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Specifies space between this control and another control's margin.
MaximumSize (inherited from Control) | Specifies the maximum size of the control.
MinimumSize (inherited from Control) | Specifies the minimum size of the control.
Nodes | Gets the collection of tree nodes representing the outline entries of the document.
Parent (inherited from Control) | The parent of this control.
PathSeparator (inherited from TreeView) | The string delimiter used for the path returned by a node's FullPath property.
PreviewPane | Gets or sets the preview pane to which this outline view is connected.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
RightToLeftLayout (inherited from TreeView) | Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.
Scrollable (inherited from TreeView) | Indicates whether the control will display scroll bars if it contains more nodes than can fit in the visible area.
SelectedImageIndex (inherited from TreeView) | The default image index for selected nodes.
SelectedImageKey (inherited from TreeView) | The default image for selected nodes.
SelectedNode (inherited from TreeView) | The currently selected node, or null if no node is selected.
ShowLines (inherited from TreeView) | Indicates whether lines are displayed between sibling nodes and between parent and child nodes.
ShowNodeToolTips (inherited from TreeView) | Indicates whether ToolTips will be displayed on the nodes.
ShowPlusMinus (inherited from TreeView) | Indicates if plus/minus buttons are shown next to parent nodes.
ShowRootLines (inherited from TreeView) | Indicates whether lines are displayed between root nodes.
Size (inherited from Control) | The size of the control in pixels.
StateImageList (inherited from TreeView) | The ImageList control used by the TreeView for custom states.
TabIndex (inherited from Control) | Determines the index in the TAB order that this control will occupy.
TabStop (inherited from Control) | Indicates whether the user can use the TAB key to give focus to the control.
Tag (inherited from Control) | User-defined data associated with the object.
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
TopNode (inherited from TreeView) | The first visible node in the TreeView.
TreeViewNodeSorter (inherited from TreeView) | The sorting comparer for the TreeView.
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
VisibleCount (inherited from TreeView) | The number of visible nodes in the TreeView.
Width (inherited from Control) | The width of the control, in container coordinates.


C1PreviewOutlineView.Nodes Property

C1PreviewOutlineView.Nodes Property

Gets the collection of tree nodes representing the outline entries of the document.

[Visual Basic]

Public ReadOnly Property Nodes As TreeNodeCollection

[C#]

new public TreeNodeCollection Nodes {get;}

[Delphi]

public property Nodes: TreeNodeCollection read get_Nodes;


C1PreviewOutlineView.PreviewPane Property

C1PreviewOutlineView.PreviewPane Property

Gets or sets the preview pane to which this outline view is connected.

[Visual Basic]

Public Property PreviewPane As C1PreviewPane

[C#]

public C1PreviewPane PreviewPane {get;set;}

[Delphi]

public property PreviewPane: C1PreviewPane read get_PreviewPane write set_PreviewPane;


C1PreviewOutlineView Events

C1PreviewOutlineView Events

The events of the C1PreviewOutlineView class are listed here. For a complete list of C1PreviewOutlineView class members, see the C1PreviewOutlineView Members topic.

Public Events

AfterCheck (inherited from TreeView) | Occurs when a check box on a tree node has been checked or unchecked.
AfterCollapse (inherited from TreeView) | Occurs when a node has been collapsed.
AfterExpand (inherited from TreeView) | Occurs when a node has been expanded.
AfterLabelEdit (inherited from TreeView) | Occurs when the text of a node has been edited by the user.
AfterSelect (inherited from TreeView) | Occurs when the selection has been changed.
BackColorChanged (inherited from Control) | Event raised when the value of the BackColor property is changed on Control.
BeforeCheck (inherited from TreeView) | Occurs when a check box on a tree node is about to be checked or unchecked.
BeforeCollapse (inherited from TreeView) | Occurs when a node is about to be collapsed.
BeforeExpand (inherited from TreeView) | Occurs when a node is about to be expanded.
BeforeLabelEdit (inherited from TreeView) | Occurs when the text of a node is about to be edited by the user.
BeforeSelect (inherited from TreeView) | Occurs when the selection is about to change.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
CausesValidationChanged (inherited from Control) | Event raised when the value of the CausesValidation property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
CursorChanged (inherited from Control) | Event raised when the value of the Cursor property is changed on Control.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
DrawNode (inherited from TreeView) | Occurs in owner-draw mode, when a node needs to be drawn.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
ForeColorChanged (inherited from Control) | Event raised when the value of the ForeColor property is changed on Control.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
ItemDrag (inherited from TreeView) | Occurs when the user begins dragging an item.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the Margin property has changed.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
NodeMouseClick (inherited from TreeView) | Occurs when a node is clicked with the mouse.
NodeMouseDoubleClick (inherited from TreeView) | Occurs when a node is double-clicked with the mouse.
NodeMouseHover (inherited from TreeView) | Occurs when the mouse hovers over a TreeNode.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
PropertyChanged | Occurs when a property of the outline view that is not inherited from the base class changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
RightToLeftLayoutChanged (inherited from TreeView) | Occurs when the value of the RightToLeftLayout property changes.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TabIndexChanged (inherited from Control) | Event raised when the value of the TabIndex property is changed.
TabStopChanged (inherited from Control) | Event raised when the value of the TabStop property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


C1PreviewOutlineView.PropertyChanged Event

C1PreviewOutlineView.PropertyChanged Event

Occurs when a property of the outline view that is not inherited from the base class changes.

[Visual Basic]

Public Event PropertyChanged As PropertyChangedEventHandler

[C#]

public event PropertyChangedEventHandlerPropertyChanged

[Delphi]

public property PropertyChanged: PropertyChangedEventHandler read remove_PropertyChanged write add_PropertyChanged;


C1PreviewPane Class

C1PreviewPane Class

Represents the barebones control showing the preview of the associated document. To add functionality, other C1Preview components can be connected to this control.

For a list of all members of this type, see C1PreviewPane Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Windows.Forms.Control

System.Windows.Forms.ScrollableControl

System.Windows.Forms.Panel

C1.Win.C1Preview.C1PreviewPane

[Visual Basic]

Public Class C1PreviewPane

Inherits Panel

Implements h, INotifyPropertyChanged, ISupportInitialize, q

[C#]

public class C1PreviewPane : Panel, h, INotifyPropertyChanged, ISupportInitialize, q

[Delphi]

type C1PreviewPane = class (Panel, h, INotifyPropertyChanged, ISupportInitialize, q);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


C1PreviewPane Members

C1PreviewPane Members

C1PreviewPane overview

Public Properties

AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
AutoScrollMargin (inherited from ScrollableControl) | The margin around controls during auto scroll.
AutoScrollMinSize (inherited from ScrollableControl) | The minimum logical size for the auto scroll region.
AutoScrollPosition (inherited from ScrollableControl) | The current position of the auto-scrolling scroll bar.
AutoSizeMode (inherited from Panel) | Specifies the mode by which the user interface element automatically resizes itself.
BackColor | Overriden. Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | The background image used for the control.
BackgroundImageLayout (inherited from Control) | The background image layout used for the component.
BindingContext (inherited from Control) | The binding context for the control.
BorderStyle (inherited from Panel) | Indicates whether the panel should have a border.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
Busy | Gets or sets the flag indicating whether the preview pane is currently busy. Some actions (especially those that could cause significant changes in the preview pane's state) raise this flag themselves, and cannot be performed when this flag was raised by another operation. This flag should be tested before attempting to change preview pane's properties or invoke methods on it.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
CausesValidation (inherited from Control) | Indicates whether this component raises validation events.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
ClientSize (inherited from Control) | Determines the size of the inner area of this control.
Cols | Gets or sets the number of page columns shown.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ContextMenuStrip (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
Continuous | Gets or sets the value indicating whether to show document pages continuously.
Controls (inherited from Control) | The collection of child controls within this control.
Created (inherited from Control) | Determines if the control has been fully created.
CurrentHistoryEntry | Gets or sets the current history entry. The value should be in the ViewHistory collection of this C1PreviewPane object, and can not be null. Note that in some situations the history entry can not be changed (for example, when the operation is attempted while the preview is changing its state). In those cases the set will be ignored.
CurrentHistoryEntryIndex | Gets or sets the index of current history entry. Note that in some situations the index can not be changed (for example, when the operation is attempted while the preview is changing its state). In those cases the set will be ignored.
CurrentVisitedDocument | Gets or sets the VisitedDocument object.
CurrentVisitedDocumentIndex | Gets or sets the index of current visited document. Assigning of this property causes the go to another document stored in the VisitedDocuments collection.
DataBindings (inherited from Control) | The data bindings for the control.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
Document | Gets or sets the document shown by the preview.
Enabled (inherited from Control) | Indicates whether the control is enabled.
ExportOptions | Gets the options controlling the behavior of export modules.
Focused (inherited from Control) | Determines if this control has focus.
Font (inherited from Control) | The font used to display text in the control.
ForeColor (inherited from Control) | The foreground color of this component, which is used to display text.
Handle (inherited from Control) | The native handle for this control.
HandleKeyboard | Gets or sets the value indicating whether the C1PreviewPane should handle the common preview keys.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HideMargins | Gets or sets the value indicating whether the user is allowed to hide/show margins by clicking the mouse in the gap between pages.
HideMarginsAvail | Gets the value indicating whether horizontal or vertical margins can be hidden on the current document. Margins can hide if all pages have the same size. Additionally, horizontal margins can also hide if the preview has one column.
HideMarginsState | Gets or sets the value indicating whether horizontal and/or vertical margins should be hidden.
HistoryOptions | Gets the HistoryOptions object defining the parameters of history in preview pane.
HorizontalScroll (inherited from ScrollableControl) | Gets the horizontal scroll bar for this ScrollableControl.
HorzPageRulerRectangle | Gets the rectangle for the horizontal ruler for the current page, in client coordinates. The actual visible ruler can be clipped by the HorzRulerArea.
HorzRulerArea | Gets the horizontal ruler area (the actual ruler is always contained within that area).
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
IntegrateExternalTools | Gets or sets the value indicating whether the current preview pane should integrate and handle external tools such as toolbars.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
KeyMapStack | Gets the KeyMapStack containing key maps for keyboard handling.
Left (inherited from Control) | The upper left of the control, in container coordinates.
Location (inherited from Control) | The coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Specifies space between this control and another control's margin.
MaximumSize (inherited from Control) | Specifies the maximum size of the control.
MaxZoomFactor | Gets or sets the maximum allowed zoom factor.
MinimumSize (inherited from Control) | Specifies the minimum size of the control.
MinZoomFactor | Gets or sets the minimum allowed zoom factor.
MouseMode | Gets or sets the mouse mode (zoom, selection, and so on.).
Padding (inherited from Control) | Specifies the interior spacing of a control.
PageLayout | Gets or sets the preview layout.
Pages | Gets the collection of the preview pages.
PageSettings | Gets or sets page settings associated with the current document.
PagesFillColor | Gets or sets the color used to fill the document pages in the preview before drawing the content.
PagesFitPaper | Gets the value indicating whether the document pages have the same size as the currently selected priinter paper.
PagesPadding | Gets or sets the padding between pages in the preview.
PagesPaddingCurr | Gets the current padding between pages in the preview.
PagesPaddingSmall | Gets or sets the padding between pages in the preview used when margins are hidden.
Parent (inherited from Control) | The parent of this control.
PreviewCursors | Gets the set of cursors used in the preview.
PreviewRectangle | Gets the preview rectangle (client are of the preview pane without the rulers and scrollbars).
PreviewScrollPosition | Gets or sets the location of the top left corner of the preview area (the scroll position) within the preview window. The value is relative to the PreviewRectangle, not to the ClientRectangle. The value is independent of the ZoomFactor (that is, setting the same values will scroll to the same logical position in the document at any zoom factor).
PrinterSettings | Gets or sets printer settings.
PrintingLayout | Gets or sets the value indicating whether to show the physical printing layout (printer page size and the location of the document pages' on the paper).
PrintOptions | Gets the print options.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Reflowable | Gets the value indicating whether the currently loaded document supports reflow.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
Rows | Gets or sets the number of page rows shown in non-continuous mode.
ShowPageOutline | Gets or sets the value indicating whether to show the original page outline (as a dashed line) when PrintingLayout is True and the printer paper does not match the original page size.
ShowPrintableArea | Gets or sets the value indicating whether to highlight the printable area of the current printer.
ShowRulers | Gets or sets the value indicating whether to show horizontal and/or vertical rulers.
ShowToolTips | Gets or sets the value indicating whether to show tooltips.
SidesPadding | Gets or sets the padding between pages and the preview window edges.
Size (inherited from Control) | The size of the control in pixels.
StartPageIdx | Gets or sets the 0-based index of the currently visible page. If several pages are visible, this property indicates the page with the most surface shown. When the property is set, the new start page's top left corner is aligned with the preview window's top left corner.
StatusText | Gets or sets the string that is interpreted by attached controls as the current status string.
TabIndex (inherited from Control) | Determines the index in the TAB order that this control will occupy.
Tag (inherited from Control) | User-defined data associated with the object.
ToolTip | Gets the ToolTip used to display tooltips in the preview. Change this to customize the way preview tooltips look (for example, change colors, and so on.).
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
TrackMousePosition | Gets or sets the value indicating whether the rulers should display marks showing the current cursor position.
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
VerticalScroll (inherited from ScrollableControl) | Gets the vertical scroll bar for this ScrollableControl.
VertPageRulerRectangle | Gets the rectangle for the vertical ruler for the current page, in client coordinates. The actual visible ruler can be clipped by the VertRulerArea.
VertRulerArea | Gets the vertical ruler area (the actual ruler is always contained within that area).
ViewHistory | Gets the collection of states of preview pane, the items in this collection (ViewHistoryItem objects) are added automatically when user scrolling, zooming, and so on the document in preview.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
VisitedDocuments | Gets the collection of visited documents, the items in this collection (VisitedDocument objects) are added automatically when user navigates between documents.
Width (inherited from Control) | The width of the control, in container coordinates.
ZoomFactor | Gets or sets the zoom factor (1 is actual size).
ZoomMode | Gets or sets the preview zoom mode.
ZoomSteps | Gets or sets the array of preset zoom factors.

Public Methods

ClientToDocument | Converts preview pane's client coordinates to document.
DoCopySelection | Copies the current selection to clipboard.
DoEscape | Handles the ESC key (clears selection, resets mouse mode).
DoGoHistoryBack | Goes back in history.
DoGoHistoryForward | Goes forward in history.
DoGoNextPage | Goes to next page.
DoGoPreviousPage | Goes to previous page.
DoScrollBottom | Scrolls to the end of the document.
DoScrollDown | Scrolls down.
DoScrollLeft | Scrolls left.
DoScrollPageDown | Scrolls one page down.
DoScrollPageUp | Scrolls one page up.
DoScrollRight | Scrolls right.
DoScrollTop | Scrolls to the top of the document.
DoScrollUp | Scrolls up.
DoSelectAll | Selects the whole document.
DoZoomIn | Zooms in.
DoZoomOut | Zooms out.
GetPageVisibility | Returns the percentage of the area of the specified page currently visible.
HistoryBack | Goes back in history.
HistoryForward | Goes forward in history.
LockHistory | Locks adding of new items to ViewHistory; a matching call to UnlockHistory() must be present.
ResetPagesFillColor | Resets the PagesFillColor to the default value.
ResetPagesPadding | Resets the PagesPadding to the default value.
ResetPagesPaddingSmall | Resets the PagesPaddingSmall to the default value.
ResetSidesPadding | Resets the SidesPadding to the default value.
ResetZoomSteps | Resets the ZoomSteps property to the default value.
SelectAll | Selects text in the whole document.
UnlockHistory | Unlocks adding of new items to ViewHistory; must match a previous call to LockHistory().
UpdatePreview | Forces the preview pane to update the preview.
OnLongOperation | Raises the LongOperation event on the preview pane.
DocumentToClient | Converts document coordinates to preview pane client coords.

Public Events

AutoSizeChanged (inherited from Panel) | Occurs when the AutoSize property has changed.
BackColorChanged (inherited from Control) | Event raised when the value of the BackColor property is changed on Control.
BackgroundImageChanged (inherited from Control) | Event raised when the value of the BackgroundImage property is changed on Control.
BackgroundImageLayoutChanged (inherited from Control) | Event raised when the value of the BackgroundImageLayout property is changed on Control.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
CausesValidationChanged (inherited from Control) | Event raised when the value of the CausesValidation property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
CursorChanged (inherited from Control) | Event raised when the value of the Cursor property is changed on Control.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
ForeColorChanged (inherited from Control) | Event raised when the value of the ForeColor property is changed on Control.
FormsUserAction | Occurs when user performs some action on RenderInputBase object within preview (Click, MouseDown, and so on).
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
HistoryItemAdding | Occurs when new ViewHistoryItem object adding to the ViewHistory collection, in this event you can cancel this adding.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
LoadVisitedDocument | Occurs the HistoryOptions.VisitedDocumentStorage is VisitedDocumentStorageEnum.User and visited document should be loaded.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LongOperation | Occurs periodically when a long operation is in progress.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the Margin property has changed.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
PaddingChanged (inherited from Control) | Occurs when the Padding property has changed.
Paint (inherited from Control) | Occurs when a control needs repainting.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewAction | Occurs when the document action from preview forms should be executed.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
PropertyChanged | Occurs when a property of the preview pane that is not inherited from the base class changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
SaveVisitedDocument | Occurs the HistoryOptions.VisitedDocumentStorage is VisitedDocumentStorageEnum.User and visited document should be saved.
Scroll (inherited from ScrollableControl) | Occurs when the user moves the scroll box.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TabIndexChanged (inherited from Control) | Event raised when the value of the TabIndex property is changed.
TabStopChanged (inherited from Control) | Event raised when the value of the TabStop property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.
VisitedDocumentAdding | Occurs when new VisitedDocument object adding to the VisitedDocuments collection, in this event you can cancel this adding.


C1PreviewPane Properties

C1PreviewPane Properties

The properties of the C1PreviewPane class are listed here. For a complete list of C1PreviewPane class members, see the C1PreviewPane Members topic.

Public Properties

AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
AutoScrollMargin (inherited from ScrollableControl) | The margin around controls during auto scroll.
AutoScrollMinSize (inherited from ScrollableControl) | The minimum logical size for the auto scroll region.
AutoScrollPosition (inherited from ScrollableControl) | The current position of the auto-scrolling scroll bar.
AutoSizeMode (inherited from Panel) | Specifies the mode by which the user interface element automatically resizes itself.
BackColor | Overriden. Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | The background image used for the control.
BackgroundImageLayout (inherited from Control) | The background image layout used for the component.
BindingContext (inherited from Control) | The binding context for the control.
BorderStyle (inherited from Panel) | Indicates whether the panel should have a border.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
Busy | Gets or sets the flag indicating whether the preview pane is currently busy. Some actions (especially those that could cause significant changes in the preview pane's state) raise this flag themselves, and cannot be performed when this flag was raised by another operation. This flag should be tested before attempting to change preview pane's properties or invoke methods on it.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
CausesValidation (inherited from Control) | Indicates whether this component raises validation events.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
ClientSize (inherited from Control) | Determines the size of the inner area of this control.
Cols | Gets or sets the number of page columns shown.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ContextMenuStrip (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
Continuous | Gets or sets the value indicating whether to show document pages continuously.
Controls (inherited from Control) | The collection of child controls within this control.
Created (inherited from Control) | Determines if the control has been fully created.
CurrentHistoryEntry | Gets or sets the current history entry. The value should be in the ViewHistory collection of this C1PreviewPane object, and can not be null. Note that in some situations the history entry can not be changed (for example, when the operation is attempted while the preview is changing its state). In those cases the set will be ignored.
CurrentHistoryEntryIndex | Gets or sets the index of current history entry. Note that in some situations the index can not be changed (for example, when the operation is attempted while the preview is changing its state). In those cases the set will be ignored.
CurrentVisitedDocument | Gets or sets the VisitedDocument object.
CurrentVisitedDocumentIndex | Gets or sets the index of current visited document. Assigning of this property causes the go to another document stored in the VisitedDocuments collection.
DataBindings (inherited from Control) | The data bindings for the control.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
Document | Gets or sets the document shown by the preview.
Enabled (inherited from Control) | Indicates whether the control is enabled.
ExportOptions | Gets the options controlling the behavior of export modules.
Focused (inherited from Control) | Determines if this control has focus.
Font (inherited from Control) | The font used to display text in the control.
ForeColor (inherited from Control) | The foreground color of this component, which is used to display text.
Handle (inherited from Control) | The native handle for this control.
HandleKeyboard | Gets or sets the value indicating whether the C1PreviewPane should handle the common preview keys.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HideMargins | Gets or sets the value indicating whether the user is allowed to hide/show margins by clicking the mouse in the gap between pages.
HideMarginsAvail | Gets the value indicating whether horizontal or vertical margins can be hidden on the current document. Margins can hide if all pages have the same size. Additionally, horizontal margins can also hide if the preview has one column.
HideMarginsState | Gets or sets the value indicating whether horizontal and/or vertical margins should be hidden.
HistoryOptions | Gets the HistoryOptions object defining the parameters of history in preview pane.
HorizontalScroll (inherited from ScrollableControl) | Gets the horizontal scroll bar for this ScrollableControl.
HorzPageRulerRectangle | Gets the rectangle for the horizontal ruler for the current page, in client coordinates. The actual visible ruler can be clipped by the HorzRulerArea.
HorzRulerArea | Gets the horizontal ruler area (the actual ruler is always contained within that area).
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
IntegrateExternalTools | Gets or sets the value indicating whether the current preview pane should integrate and handle external tools such as toolbars.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
KeyMapStack | Gets the KeyMapStack containing key maps for keyboard handling.
Left (inherited from Control) | The upper left of the control, in container coordinates.
Location (inherited from Control) | The coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Specifies space between this control and another control's margin.
MaximumSize (inherited from Control) | Specifies the maximum size of the control.
MaxZoomFactor | Gets or sets the maximum allowed zoom factor.
MinimumSize (inherited from Control) | Specifies the minimum size of the control.
MinZoomFactor | Gets or sets the minimum allowed zoom factor.
MouseMode | Gets or sets the mouse mode (zoom, selection, and so on.).
Padding (inherited from Control) | Specifies the interior spacing of a control.
PageLayout | Gets or sets the preview layout.
Pages | Gets the collection of the preview pages.
PageSettings | Gets or sets page settings associated with the current document.
PagesFillColor | Gets or sets the color used to fill the document pages in the preview before drawing the content.
PagesFitPaper | Gets the value indicating whether the document pages have the same size as the currently selected priinter paper.
PagesPadding | Gets or sets the padding between pages in the preview.
PagesPaddingCurr | Gets the current padding between pages in the preview.
PagesPaddingSmall | Gets or sets the padding between pages in the preview used when margins are hidden.
Parent (inherited from Control) | The parent of this control.
PreviewCursors | Gets the set of cursors used in the preview.
PreviewRectangle | Gets the preview rectangle (client are of the preview pane without the rulers and scrollbars).
PreviewScrollPosition | Gets or sets the location of the top left corner of the preview area (the scroll position) within the preview window. The value is relative to the PreviewRectangle, not to the ClientRectangle. The value is independent of the ZoomFactor (that is, setting the same values will scroll to the same logical position in the document at any zoom factor).
PrinterSettings | Gets or sets printer settings.
PrintingLayout | Gets or sets the value indicating whether to show the physical printing layout (printer page size and the location of the document pages' on the paper).
PrintOptions | Gets the print options.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Reflowable | Gets the value indicating whether the currently loaded document supports reflow.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
Rows | Gets or sets the number of page rows shown in non-continuous mode.
ShowPageOutline | Gets or sets the value indicating whether to show the original page outline (as a dashed line) when PrintingLayout is True and the printer paper does not match the original page size.
ShowPrintableArea | Gets or sets the value indicating whether to highlight the printable area of the current printer.
ShowRulers | Gets or sets the value indicating whether to show horizontal and/or vertical rulers.
ShowToolTips | Gets or sets the value indicating whether to show tooltips.
SidesPadding | Gets or sets the padding between pages and the preview window edges.
Size (inherited from Control) | The size of the control in pixels.
StartPageIdx | Gets or sets the 0-based index of the currently visible page. If several pages are visible, this property indicates the page with the most surface shown. When the property is set, the new start page's top left corner is aligned with the preview window's top left corner.
StatusText | Gets or sets the string that is interpreted by attached controls as the current status string.
TabIndex (inherited from Control) | Determines the index in the TAB order that this control will occupy.
Tag (inherited from Control) | User-defined data associated with the object.
ToolTip | Gets the ToolTip used to display tooltips in the preview. Change this to customize the way preview tooltips look (for example, change colors, and so on.).
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
TrackMousePosition | Gets or sets the value indicating whether the rulers should display marks showing the current cursor position.
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
VerticalScroll (inherited from ScrollableControl) | Gets the vertical scroll bar for this ScrollableControl.
VertPageRulerRectangle | Gets the rectangle for the vertical ruler for the current page, in client coordinates. The actual visible ruler can be clipped by the VertRulerArea.
VertRulerArea | Gets the vertical ruler area (the actual ruler is always contained within that area).
ViewHistory | Gets the collection of states of preview pane, the items in this collection (ViewHistoryItem objects) are added automatically when user scrolling, zooming, and so on the document in preview.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
VisitedDocuments | Gets the collection of visited documents, the items in this collection (VisitedDocument objects) are added automatically when user navigates between documents.
Width (inherited from Control) | The width of the control, in container coordinates.
ZoomFactor | Gets or sets the zoom factor (1 is actual size).
ZoomMode | Gets or sets the preview zoom mode.
ZoomSteps | Gets or sets the array of preset zoom factors.


C1PreviewPane.BackColor Property

C1PreviewPane.BackColor Property

Gets or sets the background color for the control.

[Visual Basic]

Overrides Public Property BackColor As Color

[C#]

override public Color BackColor {get;set;}

[Delphi]

public property BackColor: Color read get_BackColor write set_BackColor;


C1PreviewPane.Busy Property

C1PreviewPane.Busy Property

Gets or sets the flag indicating whether the preview pane is currently busy. Some actions (especially those that could cause significant changes in the preview pane's state) raise this flag themselves, and cannot be performed when this flag was raised by another operation. This flag should be tested before attempting to change preview pane's properties or invoke methods on it.

[Visual Basic]

Public Property Busy As Boolean

[C#]

public bool Busy {get;set;}

[Delphi]

public property Busy: Boolean read get_Busy write set_Busy;

Property Value

The value of the Busy flag.


C1PreviewPane.Cols Property

C1PreviewPane.Cols Property

Gets or sets the number of page columns shown.

[Visual Basic]

Public Property Cols As Int32*

[C#]

public Int32* Cols {get;set;}

[Delphi]

public property Cols: Int32* read get_Cols write set_Cols;


C1PreviewPane.Continuous Property

C1PreviewPane.Continuous Property

Gets or sets the value indicating whether to show document pages continuously.

[Visual Basic]

Public Property Continuous As Boolean

[C#]

public bool Continuous {get;set;}

[Delphi]

public property Continuous: Boolean read get_Continuous write set_Continuous;


C1PreviewPane.CurrentHistoryEntry Property

C1PreviewPane.CurrentHistoryEntry Property

Gets or sets the current history entry. The value should be in the ViewHistory collection of this C1PreviewPane object, and can not be null. Note that in some situations the history entry can not be changed (for example, when the operation is attempted while the preview is changing its state). In those cases the set will be ignored.

[Visual Basic]

Public Property CurrentHistoryEntry As ViewHistoryItem

[C#]

public ViewHistoryItem CurrentHistoryEntry {get;set;}

[Delphi]

public property CurrentHistoryEntry: ViewHistoryItem read get_CurrentHistoryEntry write set_CurrentHistoryEntry;


C1PreviewPane.CurrentHistoryEntryIndex Property

C1PreviewPane.CurrentHistoryEntryIndex Property

Gets or sets the index of current history entry. Note that in some situations the index can not be changed (for example, when the operation is attempted while the preview is changing its state). In those cases the set will be ignored.

[Visual Basic]

Public Property CurrentHistoryEntryIndex As Int32*

[C#]

public Int32* CurrentHistoryEntryIndex {get;set;}

[Delphi]

public property CurrentHistoryEntryIndex: Int32* read get_CurrentHistoryEntryIndex write set_CurrentHistoryEntryIndex;


C1PreviewPane.CurrentVisitedDocument Property

C1PreviewPane.CurrentVisitedDocument Property

Gets or sets the VisitedDocument object.

[Visual Basic]

Public Property CurrentVisitedDocument As VisitedDocument

[C#]

public VisitedDocument CurrentVisitedDocument {get;set;}

[Delphi]

public property CurrentVisitedDocument: VisitedDocument read get_CurrentVisitedDocument write set_CurrentVisitedDocument;


C1PreviewPane.CurrentVisitedDocumentIndex Property

C1PreviewPane.CurrentVisitedDocumentIndex Property

Gets or sets the index of current visited document. Assigning of this property causes the go to another document stored in the VisitedDocuments collection.

[Visual Basic]

Public Property CurrentVisitedDocumentIndex As Int32*

[C#]

public Int32* CurrentVisitedDocumentIndex {get;set;}

[Delphi]

public property CurrentVisitedDocumentIndex: Int32* read get_CurrentVisitedDocumentIndex write set_CurrentVisitedDocumentIndex;


C1PreviewPane.Document Property

C1PreviewPane.Document Property

Gets or sets the document shown by the preview.

[Visual Basic]

Public Property Document As Object

[C#]

public object Document {get;set;}

[Delphi]

public property Document: Object read get_Document write set_Document;


C1PreviewPane.ExportOptions Property

C1PreviewPane.ExportOptions Property

Gets the options controlling the behavior of export modules.

[Visual Basic]

Public ReadOnly Property ExportOptions As ExportOptions

[C#]

public ExportOptions ExportOptions {get;}

[Delphi]

public property ExportOptions: ExportOptions read get_ExportOptions;


C1PreviewPane.HandleKeyboard Property

C1PreviewPane.HandleKeyboard Property

Gets or sets the value indicating whether the C1PreviewPane should handle the common preview keys.

[Visual Basic]

Public Property HandleKeyboard As Boolean

[C#]

public bool HandleKeyboard {get;set;}

[Delphi]

public property HandleKeyboard: Boolean read get_HandleKeyboard write set_HandleKeyboard;

Property Value

True to turn keyboard handling on, False to turn it off.


C1PreviewPane.HideMargins Property

C1PreviewPane.HideMargins Property

Gets or sets the value indicating whether the user is allowed to hide/show margins by clicking the mouse in the gap between pages.

[Visual Basic]

Public Property HideMargins As HideMarginsFlags

[C#]

public HideMarginsFlags HideMargins {get;set;}

[Delphi]

public property HideMargins: HideMarginsFlags read get_HideMargins write set_HideMargins;


C1PreviewPane.HideMarginsAvail Property

C1PreviewPane.HideMarginsAvail Property

Gets the value indicating whether horizontal or vertical margins can be hidden on the current document. Margins can hide if all pages have the same size. Additionally, horizontal margins can also hide if the preview has one column.

[Visual Basic]

Public ReadOnly Property HideMarginsAvail As HideMarginsFlags

[C#]

public HideMarginsFlags HideMarginsAvail {get;}

[Delphi]

public property HideMarginsAvail: HideMarginsFlags read get_HideMarginsAvail;


C1PreviewPane.HideMarginsState Property

C1PreviewPane.HideMarginsState Property

Gets or sets the value indicating whether horizontal and/or vertical margins should be hidden.

[Visual Basic]

Public Property HideMarginsState As HideMarginsFlags

[C#]

public HideMarginsFlags HideMarginsState {get;set;}

[Delphi]

public property HideMarginsState: HideMarginsFlags read get_HideMarginsState write set_HideMarginsState;


C1PreviewPane.HistoryOptions Property

C1PreviewPane.HistoryOptions Property

Gets the HistoryOptions object defining the parameters of history in preview pane.

[Visual Basic]

Public ReadOnly Property HistoryOptions As HistoryOptions

[C#]

public HistoryOptions HistoryOptions {get;}

[Delphi]

public property HistoryOptions: HistoryOptions read get_HistoryOptions;


C1PreviewPane.HorzPageRulerRectangle Property

C1PreviewPane.HorzPageRulerRectangle Property

Gets the rectangle for the horizontal ruler for the current page, in client coordinates. The actual visible ruler can be clipped by the HorzRulerArea.

[Visual Basic]

Public ReadOnly Property HorzPageRulerRectangle As Rectangle

[C#]

public Rectangle HorzPageRulerRectangle {get;}

[Delphi]

public property HorzPageRulerRectangle: Rectangle read get_HorzPageRulerRectangle;


C1PreviewPane.HorzRulerArea Property

C1PreviewPane.HorzRulerArea Property

Gets the horizontal ruler area (the actual ruler is always contained within that area).

[Visual Basic]

Public ReadOnly Property HorzRulerArea As Rectangle

[C#]

public Rectangle HorzRulerArea {get;}

[Delphi]

public property HorzRulerArea: Rectangle read get_HorzRulerArea;


C1PreviewPane.IntegrateExternalTools Property

C1PreviewPane.IntegrateExternalTools Property

Gets or sets the value indicating whether the current preview pane should integrate and handle external tools such as toolbars.

[Visual Basic]

Public Property IntegrateExternalTools As Boolean

[C#]

public bool IntegrateExternalTools {get;set;}

[Delphi]

public property IntegrateExternalTools: Boolean read get_IntegrateExternalTools write set_IntegrateExternalTools;


C1PreviewPane.KeyMapStack Property

C1PreviewPane.KeyMapStack Property

Gets the KeyMapStack containing key maps for keyboard handling.

[Visual Basic]

Public ReadOnly Property KeyMapStack As KeyMapStack

[C#]

public KeyMapStack KeyMapStack {get;}

[Delphi]

public property KeyMapStack: KeyMapStack read get_KeyMapStack;


C1PreviewPane.MaxZoomFactor Property

C1PreviewPane.MaxZoomFactor Property

Gets or sets the maximum allowed zoom factor.

[Visual Basic]

Public Property MaxZoomFactor As Double

[C#]

public double MaxZoomFactor {get;set;}

[Delphi]

public property MaxZoomFactor: Double read get_MaxZoomFactor write set_MaxZoomFactor;


C1PreviewPane.MinZoomFactor Property

C1PreviewPane.MinZoomFactor Property

Gets or sets the minimum allowed zoom factor.

[Visual Basic]

Public Property MinZoomFactor As Double

[C#]

public double MinZoomFactor {get;set;}

[Delphi]

public property MinZoomFactor: Double read get_MinZoomFactor write set_MinZoomFactor;


C1PreviewPane.MouseMode Property

C1PreviewPane.MouseMode Property

Gets or sets the mouse mode (zoom, selection, and so on.).

[Visual Basic]

Public Property MouseMode As MouseModeEnum

[C#]

public MouseModeEnum MouseMode {get;set;}

[Delphi]

public property MouseMode: MouseModeEnum read get_MouseMode write set_MouseMode;


C1PreviewPane.PageLayout Property

C1PreviewPane.PageLayout Property

Gets or sets the preview layout.

[Visual Basic]

Public Property PageLayout As PageLayoutEnum

[C#]

public PageLayoutEnum PageLayout {get;set;}

[Delphi]

public property PageLayout: PageLayoutEnum read get_PageLayout write set_PageLayout;


C1PreviewPane.Pages Property

C1PreviewPane.Pages Property

Gets the collection of the preview pages.

[Visual Basic]

Public ReadOnly Property Pages As PreviewPages

[C#]

public PreviewPages Pages {get;}

[Delphi]

public property Pages: PreviewPages read get_Pages;


C1PreviewPane.PageSettings Property

C1PreviewPane.PageSettings Property

Gets or sets page settings associated with the current document.

[Visual Basic]

Public Property PageSettings As PageSettings

[C#]

public PageSettings PageSettings {get;set;}

[Delphi]

public property PageSettings: PageSettings read get_PageSettings write set_PageSettings;

Property Value

The page settings.


C1PreviewPane.PagesFillColor Property

C1PreviewPane.PagesFillColor Property

Gets or sets the color used to fill the document pages in the preview before drawing the content.

[Visual Basic]

Public Property PagesFillColor As Color

[C#]

public Color PagesFillColor {get;set;}

[Delphi]

public property PagesFillColor: Color read get_PagesFillColor write set_PagesFillColor;

Property Value

The fill color.


C1PreviewPane.PagesFitPaper Property

C1PreviewPane.PagesFitPaper Property

Gets the value indicating whether the document pages have the same size as the currently selected priinter paper.

[Visual Basic]

Public ReadOnly Property PagesFitPaper As Boolean

[C#]

public bool PagesFitPaper {get;}

[Delphi]

public property PagesFitPaper: Boolean read get_PagesFitPaper;


C1PreviewPane.PagesPadding Property

C1PreviewPane.PagesPadding Property

Gets or sets the padding between pages in the preview.

[Visual Basic]

Public Property PagesPadding As Size

[C#]

public Size PagesPadding {get;set;}

[Delphi]

public property PagesPadding: Size read get_PagesPadding write set_PagesPadding;


C1PreviewPane.PagesPaddingCurr Property

C1PreviewPane.PagesPaddingCurr Property

Gets the current padding between pages in the preview.

[Visual Basic]

Public ReadOnly Property PagesPaddingCurr As Size

[C#]

public Size PagesPaddingCurr {get;}

[Delphi]

public property PagesPaddingCurr: Size read get_PagesPaddingCurr;


C1PreviewPane.PagesPaddingSmall Property

C1PreviewPane.PagesPaddingSmall Property

Gets or sets the padding between pages in the preview used when margins are hidden.

[Visual Basic]

Public Property PagesPaddingSmall As Size

[C#]

public Size PagesPaddingSmall {get;set;}

[Delphi]

public property PagesPaddingSmall: Size read get_PagesPaddingSmall write set_PagesPaddingSmall;


C1PreviewPane.PreviewCursors Property

C1PreviewPane.PreviewCursors Property

Gets the set of cursors used in the preview.

[Visual Basic]

Public ReadOnly Property PreviewCursors As C1PreviewCursors

[C#]

public C1PreviewCursors PreviewCursors {get;}

[Delphi]

public property PreviewCursors: C1PreviewCursors read get_PreviewCursors;

Property Value

The cursors.


C1PreviewPane.PreviewRectangle Property

C1PreviewPane.PreviewRectangle Property

Gets the preview rectangle (client are of the preview pane without the rulers and scrollbars).

[Visual Basic]

Public ReadOnly Property PreviewRectangle As Rectangle

[C#]

public Rectangle PreviewRectangle {get;}

[Delphi]

public property PreviewRectangle: Rectangle read get_PreviewRectangle;


C1PreviewPane.PreviewScrollPosition Property

C1PreviewPane.PreviewScrollPosition Property

Gets or sets the location of the top left corner of the preview area (the scroll position) within the preview window. The value is relative to the PreviewRectangle, not to the ClientRectangle. The value is independent of the ZoomFactor (that is, setting the same values will scroll to the same logical position in the document at any zoom factor).

[Visual Basic]

Public Property PreviewScrollPosition As PointF

[C#]

public PointF PreviewScrollPosition {get;set;}

[Delphi]

public property PreviewScrollPosition: PointF read get_PreviewScrollPosition write set_PreviewScrollPosition;

Property Value

The scroll position (unzoomed).


C1PreviewPane.PrinterSettings Property

C1PreviewPane.PrinterSettings Property

Gets or sets printer settings.

[Visual Basic]

Public Property PrinterSettings As PrinterSettings

[C#]

public PrinterSettings PrinterSettings {get;set;}

[Delphi]

public property PrinterSettings: PrinterSettings read get_PrinterSettings write set_PrinterSettings;


C1PreviewPane.PrintingLayout Property

C1PreviewPane.PrintingLayout Property

Gets or sets the value indicating whether to show the physical printing layout (printer page size and the location of the document pages' on the paper).

[Visual Basic]

Public Property PrintingLayout As Boolean

[C#]

public bool PrintingLayout {get;set;}

[Delphi]

public property PrintingLayout: Boolean read get_PrintingLayout write set_PrintingLayout;


C1PreviewPane.PrintOptions Property

C1PreviewPane.PrintOptions Property

Gets the print options.

[Visual Basic]

Public ReadOnly Property PrintOptions As C1PrintOptions

[C#]

public C1PrintOptions PrintOptions {get;}

[Delphi]

public property PrintOptions: C1PrintOptions read get_PrintOptions;


C1PreviewPane.Reflowable Property

C1PreviewPane.Reflowable Property

Gets the value indicating whether the currently loaded document supports reflow.

[Visual Basic]

Public ReadOnly Property Reflowable As Boolean

[C#]

public bool Reflowable {get;}

[Delphi]

public property Reflowable: Boolean read get_Reflowable;

Property Value

True if the document can reflow, False otherwise.


C1PreviewPane.Rows Property

C1PreviewPane.Rows Property

Gets or sets the number of page rows shown in non-continuous mode.

[Visual Basic]

Public Property Rows As Int32*

[C#]

public Int32* Rows {get;set;}

[Delphi]

public property Rows: Int32* read get_Rows write set_Rows;


C1PreviewPane.ShowPageOutline Property

C1PreviewPane.ShowPageOutline Property

Gets or sets the value indicating whether to show the original page outline (as a dashed line) when PrintingLayout is True and the printer paper does not match the original page size.

[Visual Basic]

Public Property ShowPageOutline As Boolean

[C#]

public bool ShowPageOutline {get;set;}

[Delphi]

public property ShowPageOutline: Boolean read get_ShowPageOutline write set_ShowPageOutline;


C1PreviewPane.ShowPrintableArea Property

C1PreviewPane.ShowPrintableArea Property

Gets or sets the value indicating whether to highlight the printable area of the current printer.

[Visual Basic]

Public Property ShowPrintableArea As Boolean

[C#]

public bool ShowPrintableArea {get;set;}

[Delphi]

public property ShowPrintableArea: Boolean read get_ShowPrintableArea write set_ShowPrintableArea;


C1PreviewPane.ShowRulers Property

C1PreviewPane.ShowRulers Property

Gets or sets the value indicating whether to show horizontal and/or vertical rulers.

[Visual Basic]

Public Property ShowRulers As ShowRulersFlags

[C#]

public ShowRulersFlags ShowRulers {get;set;}

[Delphi]

public property ShowRulers: ShowRulersFlags read get_ShowRulers write set_ShowRulers;


C1PreviewPane.ShowToolTips Property

C1PreviewPane.ShowToolTips Property

Gets or sets the value indicating whether to show tooltips.

[Visual Basic]

Public Property ShowToolTips As Boolean

[C#]

public bool ShowToolTips {get;set;}

[Delphi]

public property ShowToolTips: Boolean read get_ShowToolTips write set_ShowToolTips;

Property Value

True to turn tooltips on, False to turn them off.


C1PreviewPane.SidesPadding Property

C1PreviewPane.SidesPadding Property

Gets or sets the padding between pages and the preview window edges.

[Visual Basic]

Public Property SidesPadding As Size

[C#]

public Size SidesPadding {get;set;}

[Delphi]

public property SidesPadding: Size read get_SidesPadding write set_SidesPadding;


C1PreviewPane.StartPageIdx Property

C1PreviewPane.StartPageIdx Property

Gets or sets the 0-based index of the currently visible page. If several pages are visible, this property indicates the page with the most surface shown. When the property is set, the new start page's top left corner is aligned with the preview window's top left corner.

[Visual Basic]

Public Property StartPageIdx As Int32*

[C#]

public Int32* StartPageIdx {get;set;}

[Delphi]

public property StartPageIdx: Int32* read get_StartPageIdx write set_StartPageIdx;


C1PreviewPane.StatusText Property

C1PreviewPane.StatusText Property

Gets or sets the string that is interpreted by attached controls as the current status string.

[Visual Basic]

Public Property StatusText As String

[C#]

public string StatusText {get;set;}

[Delphi]

public property StatusText: String read get_StatusText write set_StatusText;


C1PreviewPane.ToolTip Property

C1PreviewPane.ToolTip Property

Gets the ToolTip used to display tooltips in the preview. Change this to customize the way preview tooltips look (for example, change colors, and so on.).

[Visual Basic]

Public ReadOnly Property ToolTip As PreviewToolTip

[C#]

public PreviewToolTip ToolTip {get;}

[Delphi]

public property ToolTip: PreviewToolTip read get_ToolTip;


C1PreviewPane.TrackMousePosition Property

C1PreviewPane.TrackMousePosition Property

Gets or sets the value indicating whether the rulers should display marks showing the current cursor position.

[Visual Basic]

Public Property TrackMousePosition As Boolean

[C#]

public bool TrackMousePosition {get;set;}

[Delphi]

public property TrackMousePosition: Boolean read get_TrackMousePosition write set_TrackMousePosition;


C1PreviewPane.VertPageRulerRectangle Property

C1PreviewPane.VertPageRulerRectangle Property

Gets the rectangle for the vertical ruler for the current page, in client coordinates. The actual visible ruler can be clipped by the VertRulerArea.

[Visual Basic]

Public ReadOnly Property VertPageRulerRectangle As Rectangle

[C#]

public Rectangle VertPageRulerRectangle {get;}

[Delphi]

public property VertPageRulerRectangle: Rectangle read get_VertPageRulerRectangle;


C1PreviewPane.VertRulerArea Property

C1PreviewPane.VertRulerArea Property

Gets the vertical ruler area (the actual ruler is always contained within that area).

[Visual Basic]

Public ReadOnly Property VertRulerArea As Rectangle

[C#]

public Rectangle VertRulerArea {get;}

[Delphi]

public property VertRulerArea: Rectangle read get_VertRulerArea;


C1PreviewPane.ViewHistory Property

C1PreviewPane.ViewHistory Property

Gets the collection of states of preview pane, the items in this collection (ViewHistoryItem objects) are added automatically when user scrolling, zooming, and so on the document in preview.

[Visual Basic]

Public ReadOnly Property ViewHistory As ViewHistoryItemCollection

[C#]

public ViewHistoryItemCollection ViewHistory {get;}

[Delphi]

public property ViewHistory: ViewHistoryItemCollection read get_ViewHistory;


C1PreviewPane.VisitedDocuments Property

C1PreviewPane.VisitedDocuments Property

Gets the collection of visited documents, the items in this collection (VisitedDocument objects) are added automatically when user navigates between documents.

[Visual Basic]

Public ReadOnly Property VisitedDocuments As VisitedDocumentCollection

[C#]

public VisitedDocumentCollection VisitedDocuments {get;}

[Delphi]

public property VisitedDocuments: VisitedDocumentCollection read get_VisitedDocuments;


C1PreviewPane.ZoomFactor Property

C1PreviewPane.ZoomFactor Property

Gets or sets the zoom factor (1 is actual size).

[Visual Basic]

Public Property ZoomFactor As Double

[C#]

public double ZoomFactor {get;set;}

[Delphi]

public property ZoomFactor: Double read get_ZoomFactor write set_ZoomFactor;


C1PreviewPane.ZoomMode Property

C1PreviewPane.ZoomMode Property

Gets or sets the preview zoom mode.

[Visual Basic]

Public Property ZoomMode As ZoomModeEnum

[C#]

public ZoomModeEnum ZoomMode {get;set;}

[Delphi]

public property ZoomMode: ZoomModeEnum read get_ZoomMode write set_ZoomMode;


C1PreviewPane.ZoomSteps Property

C1PreviewPane.ZoomSteps Property

Gets or sets the array of preset zoom factors.

[Visual Basic]

Public Property ZoomSteps As Single()

[C#]

public float[] ZoomSteps {get;set;}

[Delphi]

public property ZoomSteps: array of Single read get_ZoomSteps write set_ZoomSteps;

Property Value

The array of float values used as preset zoom factors.


C1PreviewPane Methods

C1PreviewPane Methods

The methods of the C1PreviewPane class are listed here. For a complete list of C1PreviewPane class members, see the C1PreviewPane Members topic.

Public Methods

ClientToDocument | Converts preview pane's client coordinates to document.
DoCopySelection | Copies the current selection to clipboard.
DoEscape | Handles the ESC key (clears selection, resets mouse mode).
DoGoHistoryBack | Goes back in history.
DoGoHistoryForward | Goes forward in history.
DoGoNextPage | Goes to next page.
DoGoPreviousPage | Goes to previous page.
DoScrollBottom | Scrolls to the end of the document.
DoScrollDown | Scrolls down.
DoScrollLeft | Scrolls left.
DoScrollPageDown | Scrolls one page down.
DoScrollPageUp | Scrolls one page up.
DoScrollRight | Scrolls right.
DoScrollTop | Scrolls to the top of the document.
DoScrollUp | Scrolls up.
DoSelectAll | Selects the whole document.
DoZoomIn | Zooms in.
DoZoomOut | Zooms out.
GetPageVisibility | Returns the percentage of the area of the specified page currently visible.
HistoryBack | Goes back in history.
HistoryForward | Goes forward in history.
LockHistory | Locks adding of new items to ViewHistory; a matching call to UnlockHistory() must be present.
ResetPagesFillColor | Resets the PagesFillColor to the default value.
ResetPagesPadding | Resets the PagesPadding to the default value.
ResetPagesPaddingSmall | Resets the PagesPaddingSmall to the default value.
ResetSidesPadding | Resets the SidesPadding to the default value.
ResetZoomSteps | Resets the ZoomSteps property to the default value.
SelectAll | Selects text in the whole document.
UnlockHistory | Unlocks adding of new items to ViewHistory; must match a previous call to LockHistory().
UpdatePreview | Forces the preview pane to update the preview.
OnLongOperation | Raises the LongOperation event on the preview pane.
DocumentToClient | Converts document coordinates to preview pane client coords.


C1PreviewPane.ClientToDocument Method

C1PreviewPane.ClientToDocument Method

Converts preview pane's client coordinates to document.

[Visual Basic]

Public Function ClientToDocument( _

ByVal pt As Point, _

ByRef pageIdx As Int32*, _

ByRef ptPage As PointF _

) As Boolean

[C#]

public bool ClientToDocument(

Point pt,

out Int32* pageIdx,

out PointF ptPage

);

[Delphi]

public function ClientToDocument(

pt: Point;

out pageIdx: Int32*;

out ptPage: PointF

): Boolean;

Parameters

pt

Point in client coords.

pageIdx

Out: 0-based page index or -1.

ptPage

Out: page coordinates.

Return Value

True if the page has been found, False otherwise.


C1PreviewPane.DoCopySelection Method

C1PreviewPane.DoCopySelection Method

Copies the current selection to clipboard.

[Visual Basic]

Public Function DoCopySelection() As Boolean

[C#]

public bool DoCopySelection()

[Delphi]

public function DoCopySelection(): Boolean;

Return Value

True.


C1PreviewPane.DocumentToClient Method

C1PreviewPane.DocumentToClient Method

Overload List

Converts document coordinates to preview pane client coords.

[Visual Basic] Overloads Public Function DocumentToClient(Integer, PointF, ByRef Point) As Boolean

[C#] public bool DocumentToClient(int, PointF, ref Point);

[Delphi] public function DocumentToClient(Int32; PointF; out Point) : Boolean; overload;

Converts a rectangle on a page in document coordinates to preview pane client coords.

[Visual Basic] Overloads Public Function DocumentToClient(Integer, RectangleF, ByRef Rectangle) As Boolean

[C#] public bool DocumentToClient(int, RectangleF, ref Rectangle);

[Delphi] public function DocumentToClient(Int32; RectangleF; out Rectangle) : Boolean; overload;


C1PreviewPane.DocumentToClient Method (Int32, PointF, ByRef Point)

C1PreviewPane.DocumentToClient Method (Int32, PointF, ByRef Point)

Previous Next

Converts document coordinates to preview pane client coords.

[Visual Basic]

Overloads Public Function DocumentToClient( _

ByVal pageIdx As Int32*, _

ByVal ptPage As PointF, _

ByRef pt As Point _

) As Boolean

[C#]

public bool DocumentToClient(

Int32* pageIdx,

PointF ptPage,

out Point pt

);

[Delphi]

public function DocumentToClient(

pageIdx: Int32*;

ptPage: PointF;

out pt: Point

): Boolean; overload;

Parameters

pageIdx

0-based page index.

ptPage

Point on the page.

pt

Out: Preview pane client point.

Return Value

True if the client point belongs to a document page, False otherwise.


C1PreviewPane.DocumentToClient Method (Int32, RectangleF, ByRef Rectangle)

C1PreviewPane.DocumentToClient Method (Int32, RectangleF, ByRef Rectangle)

Previous Next

Converts a rectangle on a page in document coordinates to preview pane client coords.

[Visual Basic]

Overloads Public Function DocumentToClient( _

ByVal pageIdx As Int32*, _

ByVal rPage As RectangleF, _

ByRef r As Rectangle _

) As Boolean

[C#]

public bool DocumentToClient(

Int32* pageIdx,

RectangleF rPage,

out Rectangle r

);

[Delphi]

public function DocumentToClient(

pageIdx: Int32*;

rPage: RectangleF;

out r: Rectangle

): Boolean; overload;

Parameters

pageIdx

0-based page index.

rPage

Rectangle on the page.

r

Out: Preview pane client rectangle.

Return Value

True if the client rectangle's location belongs to a document page, False otherwise.


C1PreviewPane.DoEscape Method

C1PreviewPane.DoEscape Method

Handles the ESC key (clears selection, resets mouse mode).

[Visual Basic]

Public Function DoEscape() As Boolean

[C#]

public bool DoEscape()

[Delphi]

public function DoEscape(): Boolean;

Return Value

True.


C1PreviewPane.DoGoHistoryBack Method

C1PreviewPane.DoGoHistoryBack Method

Goes back in history.

[Visual Basic]

Public Function DoGoHistoryBack() As Boolean

[C#]

public bool DoGoHistoryBack()

[Delphi]

public function DoGoHistoryBack(): Boolean;

Return Value

True.


C1PreviewPane.DoGoHistoryForward Method

C1PreviewPane.DoGoHistoryForward Method

Goes forward in history.

[Visual Basic]

Public Function DoGoHistoryForward() As Boolean

[C#]

public bool DoGoHistoryForward()

[Delphi]

public function DoGoHistoryForward(): Boolean;

Return Value

True.


C1PreviewPane.DoGoNextPage Method

C1PreviewPane.DoGoNextPage Method

Goes to next page.

[Visual Basic]

Public Function DoGoNextPage() As Boolean

[C#]

public bool DoGoNextPage()

[Delphi]

public function DoGoNextPage(): Boolean;

Return Value

True.


C1PreviewPane.DoGoPreviousPage Method

C1PreviewPane.DoGoPreviousPage Method

Goes to previous page.

[Visual Basic]

Public Function DoGoPreviousPage() As Boolean

[C#]

public bool DoGoPreviousPage()

[Delphi]

public function DoGoPreviousPage(): Boolean;

Return Value

True.


C1PreviewPane.DoScrollBottom Method

C1PreviewPane.DoScrollBottom Method

Scrolls to the end of the document.

[Visual Basic]

Public Function DoScrollBottom() As Boolean

[C#]

public bool DoScrollBottom()

[Delphi]

public function DoScrollBottom(): Boolean;

Return Value

True.


C1PreviewPane.DoScrollDown Method

C1PreviewPane.DoScrollDown Method

Scrolls down.

[Visual Basic]

Public Function DoScrollDown() As Boolean

[C#]

public bool DoScrollDown()

[Delphi]

public function DoScrollDown(): Boolean;

Return Value

True.


C1PreviewPane.DoScrollLeft Method

C1PreviewPane.DoScrollLeft Method

Scrolls left.

[Visual Basic]

Public Function DoScrollLeft() As Boolean

[C#]

public bool DoScrollLeft()

[Delphi]

public function DoScrollLeft(): Boolean;

Return Value

True.


C1PreviewPane.DoScrollPageDown Method

C1PreviewPane.DoScrollPageDown Method

Scrolls one page down.

[Visual Basic]

Public Function DoScrollPageDown() As Boolean

[C#]

public bool DoScrollPageDown()

[Delphi]

public function DoScrollPageDown(): Boolean;

Return Value

True.


C1PreviewPane.DoScrollPageUp Method

C1PreviewPane.DoScrollPageUp Method

Scrolls one page up.

[Visual Basic]

Public Function DoScrollPageUp() As Boolean

[C#]

public bool DoScrollPageUp()

[Delphi]

public function DoScrollPageUp(): Boolean;

Return Value

True.


C1PreviewPane.DoScrollRight Method

C1PreviewPane.DoScrollRight Method

Scrolls right.

[Visual Basic]

Public Function DoScrollRight() As Boolean

[C#]

public bool DoScrollRight()

[Delphi]

public function DoScrollRight(): Boolean;

Return Value

True.


C1PreviewPane.DoScrollTop Method

C1PreviewPane.DoScrollTop Method

Scrolls to the top of the document.

[Visual Basic]

Public Function DoScrollTop() As Boolean

[C#]

public bool DoScrollTop()

[Delphi]

public function DoScrollTop(): Boolean;

Return Value

True.


C1PreviewPane.DoScrollUp Method

C1PreviewPane.DoScrollUp Method

Scrolls up.

[Visual Basic]

Public Function DoScrollUp() As Boolean

[C#]

public bool DoScrollUp()

[Delphi]

public function DoScrollUp(): Boolean;

Return Value

True.


C1PreviewPane.DoSelectAll Method

C1PreviewPane.DoSelectAll Method

Selects the whole document.

[Visual Basic]

Public Function DoSelectAll() As Boolean

[C#]

public bool DoSelectAll()

[Delphi]

public function DoSelectAll(): Boolean;

Return Value

True.


C1PreviewPane.DoZoomIn Method

C1PreviewPane.DoZoomIn Method

Zooms in.

[Visual Basic]

Public Function DoZoomIn() As Boolean

[C#]

public bool DoZoomIn()

[Delphi]

public function DoZoomIn(): Boolean;

Return Value

True.


C1PreviewPane.DoZoomOut Method

C1PreviewPane.DoZoomOut Method

Zooms out.

[Visual Basic]

Public Function DoZoomOut() As Boolean

[C#]

public bool DoZoomOut()

[Delphi]

public function DoZoomOut(): Boolean;

Return Value

True.


C1PreviewPane.GetPageVisibility Method

C1PreviewPane.GetPageVisibility Method

Returns the percentage of the area of the specified page currently visible.

[Visual Basic]

Public Function GetPageVisibility( _

ByVal pageIdx As Int32* _

) As Double

[C#]

public double GetPageVisibility(

Int32* pageIdx

);

[Delphi]

public function GetPageVisibility(

pageIdx: Int32*

): Double;

Parameters

pageIdx

0-based page index.

Return Value

Percentage of the page's surface visible.


C1PreviewPane.HistoryBack Method

C1PreviewPane.HistoryBack Method

Goes back in history.

[Visual Basic]

Public Sub HistoryBack()

[C#]

public void HistoryBack()

[Delphi]

public procedure HistoryBack();


C1PreviewPane.HistoryForward Method

C1PreviewPane.HistoryForward Method

Goes forward in history.

[Visual Basic]

Public Sub HistoryForward()

[C#]

public void HistoryForward()

[Delphi]

public procedure HistoryForward();


C1PreviewPane.LockHistory Method

C1PreviewPane.LockHistory Method

Locks adding of new items to ViewHistory; a matching call to UnlockHistory() must be present.

[Visual Basic]

Public Sub LockHistory()

[C#]

public void LockHistory()

[Delphi]

public procedure LockHistory();


C1PreviewPane.OnLongOperation Method

C1PreviewPane.OnLongOperation Method

Raises the LongOperation event on the preview pane.

[Visual Basic]

Public Function OnLongOperation( _

ByVal complete As Double, _

ByVal canCancel As Boolean _

) As Boolean

[C#]

public bool OnLongOperation(

double complete,

bool canCancel

);

[Delphi]

public function OnLongOperation(

complete: Double;

canCancel: Boolean

): Boolean;

Parameters

complete

How much is complete (from 0 to 1).

canCancel

Whether the operation can be cancelled.

Return Value

True if the operation should be cancelled.


C1PreviewPane.ResetPagesFillColor Method

C1PreviewPane.ResetPagesFillColor Method

Resets the PagesFillColor to the default value.

[Visual Basic]

Public Sub ResetPagesFillColor()

[C#]

public void ResetPagesFillColor()

[Delphi]

public procedure ResetPagesFillColor();


C1PreviewPane.ResetPagesPadding Method

C1PreviewPane.ResetPagesPadding Method

Resets the PagesPadding to the default value.

[Visual Basic]

Public Sub ResetPagesPadding()

[C#]

public void ResetPagesPadding()

[Delphi]

public procedure ResetPagesPadding();


C1PreviewPane.ResetPagesPaddingSmall Method

C1PreviewPane.ResetPagesPaddingSmall Method

Resets the PagesPaddingSmall to the default value.

[Visual Basic]

Public Sub ResetPagesPaddingSmall()

[C#]

public void ResetPagesPaddingSmall()

[Delphi]

public procedure ResetPagesPaddingSmall();


C1PreviewPane.ResetSidesPadding Method

C1PreviewPane.ResetSidesPadding Method

Resets the SidesPadding to the default value.

[Visual Basic]

Public Sub ResetSidesPadding()

[C#]

public void ResetSidesPadding()

[Delphi]

public procedure ResetSidesPadding();


C1PreviewPane.ResetZoomSteps Method

C1PreviewPane.ResetZoomSteps Method

Resets the ZoomSteps property to the default value.

[Visual Basic]

Public Sub ResetZoomSteps()

[C#]

public void ResetZoomSteps()

[Delphi]

public procedure ResetZoomSteps();


C1PreviewPane.SelectAll Method

C1PreviewPane.SelectAll Method

Selects text in the whole document.

[Visual Basic]

Public Sub SelectAll()

[C#]

public void SelectAll()

[Delphi]

public procedure SelectAll();


C1PreviewPane.UnlockHistory Method

C1PreviewPane.UnlockHistory Method

Unlocks adding of new items to ViewHistory; must match a previous call to LockHistory().

[Visual Basic]

Public Sub UnlockHistory( _

ByVal userAction As HistorySavedActionsEnum, _

ByVal historyItemCaption As String _

)

[C#]

public void UnlockHistory(

HistorySavedActionsEnum userAction,

string historyItemCaption

);

[Delphi]

public procedure UnlockHistory(

userAction: HistorySavedActionsEnum;

historyItemCaption: String

);

Parameters

userAction

User action which was performed between the calls to LockHistory() and UnlockHistory().

historyItemCaption

Caption for the user action history item.


C1PreviewPane.UpdatePreview Method

C1PreviewPane.UpdatePreview Method

Forces the preview pane to update the preview.

[Visual Basic]

Public Sub UpdatePreview()

[C#]

public void UpdatePreview()

[Delphi]

public procedure UpdatePreview();


C1PreviewPane Events

C1PreviewPane Events

The events of the C1PreviewPane class are listed here. For a complete list of C1PreviewPane class members, see the C1PreviewPane Members topic.

Public Events

AutoSizeChanged (inherited from Panel) | Occurs when the AutoSize property has changed.
BackColorChanged (inherited from Control) | Event raised when the value of the BackColor property is changed on Control.
BackgroundImageChanged (inherited from Control) | Event raised when the value of the BackgroundImage property is changed on Control.
BackgroundImageLayoutChanged (inherited from Control) | Event raised when the value of the BackgroundImageLayout property is changed on Control.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
CausesValidationChanged (inherited from Control) | Event raised when the value of the CausesValidation property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
CursorChanged (inherited from Control) | Event raised when the value of the Cursor property is changed on Control.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
ForeColorChanged (inherited from Control) | Event raised when the value of the ForeColor property is changed on Control.
FormsUserAction | Occurs when user performs some action on RenderInputBase object within preview (Click, MouseDown, and so on).
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
HistoryItemAdding | Occurs when new ViewHistoryItem object adding to the ViewHistory collection, in this event you can cancel this adding.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
LoadVisitedDocument | Occurs the HistoryOptions.VisitedDocumentStorage is VisitedDocumentStorageEnum.User and visited document should be loaded.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LongOperation | Occurs periodically when a long operation is in progress.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the Margin property has changed.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
PaddingChanged (inherited from Control) | Occurs when the Padding property has changed.
Paint (inherited from Control) | Occurs when a control needs repainting.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewAction | Occurs when the document action from preview forms should be executed.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
PropertyChanged | Occurs when a property of the preview pane that is not inherited from the base class changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
SaveVisitedDocument | Occurs the HistoryOptions.VisitedDocumentStorage is VisitedDocumentStorageEnum.User and visited document should be saved.
Scroll (inherited from ScrollableControl) | Occurs when the user moves the scroll box.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TabIndexChanged (inherited from Control) | Event raised when the value of the TabIndex property is changed.
TabStopChanged (inherited from Control) | Event raised when the value of the TabStop property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.
VisitedDocumentAdding | Occurs when new VisitedDocument object adding to the VisitedDocuments collection, in this event you can cancel this adding.


C1PreviewPane.FormsUserAction Event

C1PreviewPane.FormsUserAction Event

Occurs when user performs some action on RenderInputBase object within preview (Click, MouseDown, and so on).

[Visual Basic]

Public Event FormsUserAction As FormsUserActionEventHandler

[C#]

public event FormsUserActionEventHandlerFormsUserAction

[Delphi]

public property FormsUserAction: FormsUserActionEventHandler read remove_FormsUserAction write add_FormsUserAction;


C1PreviewPane.HistoryItemAdding Event

C1PreviewPane.HistoryItemAdding Event

Occurs when new ViewHistoryItem object adding to the ViewHistory collection, in this event you can cancel this adding.

[Visual Basic]

Public Event HistoryItemAdding As HistoryItemAddingEventHandler

[C#]

public event HistoryItemAddingEventHandler HistoryItemAdding

[Delphi]

public property HistoryItemAdding: HistoryItemAddingEventHandler read remove_HistoryItemAdding write add_HistoryItemAdding;


C1PreviewPane.LoadVisitedDocument Event

C1PreviewPane.LoadVisitedDocument Event

Occurs the HistoryOptions.VisitedDocumentStorage is VisitedDocumentStorageEnum.User and visited document should be loaded.

[Visual Basic]

Public Event LoadVisitedDocument As LoadVisitedDocumentEventHandler

[C#]

public event LoadVisitedDocumentEventHandler LoadVisitedDocument

[Delphi]

public property LoadVisitedDocument: LoadVisitedDocumentEventHandler read remove_LoadVisitedDocument write add_LoadVisitedDocument;


C1PreviewPane.LongOperation Event

C1PreviewPane.LongOperation Event

Occurs periodically when a long operation is in progress.

[Visual Basic]

Public Event LongOperation As LongOperationEventHandler

[C#]

public event LongOperationEventHandlerLongOperation

[Delphi]

public property LongOperation: LongOperationEventHandler read remove_LongOperation write add_LongOperation;


C1PreviewPane.PreviewAction Event

C1PreviewPane.PreviewAction Event

Occurs when the document action from preview forms should be executed.

[Visual Basic]

Public Event PreviewAction As DocumentActionEventHandler

[C#]

public event DocumentActionEventHandlerPreviewAction

[Delphi]

public property PreviewAction: DocumentActionEventHandler read remove_PreviewAction write add_PreviewAction;


C1PreviewPane.PropertyChanged Event

C1PreviewPane.PropertyChanged Event

Occurs when a property of the preview pane that is not inherited from the base class changes.

[Visual Basic]

Public Event PropertyChanged As PropertyChangedEventHandler

[C#]

public event PropertyChangedEventHandlerPropertyChanged

[Delphi]

public property PropertyChanged: PropertyChangedEventHandler read remove_PropertyChanged write add_PropertyChanged;


C1PreviewPane.SaveVisitedDocument Event

C1PreviewPane.SaveVisitedDocument Event

Occurs the HistoryOptions.VisitedDocumentStorage is VisitedDocumentStorageEnum.User and visited document should be saved.

[Visual Basic]

Public Event SaveVisitedDocument As SaveVisitedDocumentEventHandler

[C#]

public event SaveVisitedDocumentEventHandler SaveVisitedDocument

[Delphi]

public property SaveVisitedDocument: SaveVisitedDocumentEventHandler read remove_SaveVisitedDocument write add_SaveVisitedDocument;


C1PreviewPane.VisitedDocumentAdding Event

C1PreviewPane.VisitedDocumentAdding Event

Occurs when new VisitedDocument object adding to the VisitedDocuments collection, in this event you can cancel this adding.

[Visual Basic]

Public Event VisitedDocumentAdding As VisitedDocumentAddingEventHandler

[C#]

public event VisitedDocumentAddingEventHandler VisitedDocumentAdding

[Delphi]

public property VisitedDocumentAdding: VisitedDocumentAddingEventHandler read remove_VisitedDocumentAdding write add_VisitedDocumentAdding;


C1PreviewPane.BusySection Class

C1PreviewPane.BusySection Class

Helper class providing a busy section. Usage: using (new busy = BusySection(previewPane)) { ..code... }.

For a list of all members of this type, see C1PreviewPane.BusySection Members.

System.Object

C1.Win.C1Preview.C1PreviewPane.BusySection

[Visual Basic]

Public Class C1PreviewPane.BusySection

Implements IDisposable

[C#]

public class C1PreviewPane.BusySection : IDisposable

[Delphi]

type C1PreviewPane.BusySection = class (TObject, IDisposable);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


C1PreviewPane.BusySection Members

C1PreviewPane.BusySection Members

C1PreviewPane.BusySection overview


C1PreviewPane.LayoutSection Class

C1PreviewPane.LayoutSection Class

Helper class providing a section inside which the preview layout is suspended. Should be used to enclose fragments of code where several properties on which the preview pages layout depends are changed. Layout updating is suspended between the construction and disposing of the class instance. Sample usage: using (LayoutSection ls = new LayoutSection(previewPane)) { ..code... }.

For a list of all members of this type, see C1PreviewPane.LayoutSection Members.

System.Object

C1.Win.C1Preview.C1PreviewPane.LayoutSection

[Visual Basic]

Public Class C1PreviewPane.LayoutSection

Implements IDisposable

[C#]

public class C1PreviewPane.LayoutSection : IDisposable

[Delphi]

type C1PreviewPane.LayoutSection = class (TObject, IDisposable);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


C1PreviewPane.LayoutSection Members

C1PreviewPane.LayoutSection Members

C1PreviewPane.LayoutSection overview

Public Constructors

C1PreviewPane.LayoutSection Constructor

Initializes a new instance of the LayoutSection class.

Public Methods

Dispose

Releases the resources used by the layout section. Updates the preview pane layout.


C1PreviewPane.LayoutSection Constructor

C1PreviewPane.LayoutSection Constructor

Initializes a new instance of the LayoutSection class.

[Visual Basic]

Public Function New( _

ByVal pane As C1PreviewPane, _

ByVal historyItemAction As HistorySavedActionsEnum _

)

[C#]

public C1PreviewPane.LayoutSection(

C1PreviewPane pane,

HistorySavedActionsEnum historyItemAction

);

[Delphi]

public constructor Create(

pane: C1PreviewPane;

historyItemAction: HistorySavedActionsEnum

);

Parameters

pane

The preview pane which is the owner of this layout section.

historyItemAction

Action that caused this layout section (for history).


C1PreviewPane.LayoutSection Methods

C1PreviewPane.LayoutSection Methods

The methods of the C1PreviewPane.LayoutSection class are listed here. For a complete list of C1PreviewPane.LayoutSection class members, see the C1PreviewPane+LayoutSection Members topic.

Public Methods

Dispose

Releases the resources used by the layout section. Updates the preview pane layout.


C1PreviewPane.LayoutSection.Dispose Method

C1PreviewPane.LayoutSection.Dispose Method

Releases the resources used by the layout section. Updates the preview pane layout.

[Visual Basic]

Overridable Public Sub Dispose() Implements IDisposable.Dispose

[C#]

virtual public void Dispose()

[Delphi]

public procedure Dispose(); virtual;

Implements

IDisposable.Dispose


C1PreviewTextSearchPanel Class

C1PreviewTextSearchPanel Class

Displays a text search panel allowing to find text in the connected preview pane.

For a list of all members of this type, see C1PreviewTextSearchPanel Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Windows.Forms.Control

System.Windows.Forms.ScrollableControl

System.Windows.Forms.ContainerControl

System.Windows.Forms.UserControl

C1.Win.C1Preview.C1PreviewTextSearchPanel

[Visual Basic]

Public Class C1PreviewTextSearchPanel

Inherits UserControl

[C#]

public class C1PreviewTextSearchPanel : UserControl

[Delphi]

type C1PreviewTextSearchPanel = class (UserControl);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


C1PreviewTextSearchPanel Members

C1PreviewTextSearchPanel Members

C1PreviewTextSearchPanel overview

Public Properties

AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
ActiveControl (inherited from ContainerControl) | The currently active control.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
AutoScaleMode (inherited from ContainerControl) | Determines how the form or control will scale when screen resolution or fonts change.
AutoScroll (inherited from ScrollableControl) | Indicates whether scroll bars automatically appear when the control contents are larger than its visible area.
AutoScrollMargin (inherited from ScrollableControl) | The margin around controls during auto scroll.
AutoScrollMinSize (inherited from ScrollableControl) | The minimum logical size for the auto scroll region.
AutoScrollPosition (inherited from ScrollableControl) | The current position of the auto-scrolling scroll bar.
AutoSizeMode (inherited from UserControl) | Specifies the mode by which the user interface element automatically resizes itself.
BackColor (inherited from Control) | The background color of the component.
BackgroundImage (inherited from Control) | The background image used for the control.
BackgroundImageLayout (inherited from Control) | The background image layout used for the component.
BindingContext (inherited from ContainerControl) | The binding manager for the container control. This manages all bindings of child controls to lists.
BorderStyle (inherited from UserControl) | Indicates whether the panel should have a border.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
CausesValidation (inherited from Control) | Indicates whether this component raises validation events.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
ClientSize (inherited from Control) | Determines the size of the inner area of this control.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ContextMenuStrip (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
Controls (inherited from Control) | The collection of child controls within this control.
Created (inherited from Control) | Determines if the control has been fully created.
Cursor (inherited from Control) | The cursor that appears when the pointer moves over the control.
DataBindings (inherited from Control) | The data bindings for the control.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
Enabled (inherited from Control) | Indicates whether the control is enabled.
Focused (inherited from Control) | Determines if this control has focus.
Font (inherited from Control) | The font used to display text in the control.
ForeColor (inherited from Control) | The foreground color of this component, which is used to display text.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HorizontalScroll (inherited from ScrollableControl) | Gets the horizontal scroll bar for this ScrollableControl.
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
Left (inherited from Control) | The upper left of the control, in container coordinates.
Location (inherited from Control) | The coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Specifies space between this control and another control's margin.
MaximumSize (inherited from Control) | Specifies the maximum size of the control.
MinimumSize (inherited from Control) | Specifies the minimum size of the control.
Padding (inherited from Control) | Specifies the interior spacing of a control.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from ContainerControl) | The parent form of this container control.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
Size (inherited from Control) | The size of the control in pixels.
TabIndex (inherited from Control) | Determines the index in the TAB order that this control will occupy.
TabStop (inherited from Control) | Indicates whether the user can use the TAB key to give focus to the control.
Tag (inherited from Control) | User-defined data associated with the object.
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
VerticalScroll (inherited from ScrollableControl) | Gets the vertical scroll bar for this ScrollableControl.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
Width (inherited from Control) | The width of the control, in container coordinates.

Public Events

BackColorChanged (inherited from Control) | Event raised when the value of the BackColor property is changed on Control.
BackgroundImageChanged (inherited from Control) | Event raised when the value of the BackgroundImage property is changed on Control.
BackgroundImageLayoutChanged (inherited from Control) | Event raised when the value of the BackgroundImageLayout property is changed on Control.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
CausesValidationChanged (inherited from Control) | Event raised when the value of the CausesValidation property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
CursorChanged (inherited from Control) | Event raised when the value of the Cursor property is changed on Control.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
ForeColorChanged (inherited from Control) | Event raised when the value of the ForeColor property is changed on Control.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
Load (inherited from UserControl) | Occurs whenever the user control loads.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the Margin property has changed.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
PaddingChanged (inherited from Control) | Occurs when the Padding property has changed.
Paint (inherited from Control) | Occurs when a control needs repainting.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user moves the scroll box.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TabIndexChanged (inherited from Control) | Event raised when the value of the TabIndex property is changed.
TabStopChanged (inherited from Control) | Event raised when the value of the TabStop property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


C1PreviewTextSearchPanel Properties

C1PreviewTextSearchPanel Properties

The properties of the C1PreviewTextSearchPanel class are listed here. For a complete list of C1PreviewTextSearchPanel class members, see the C1PreviewTextSearchPanel Members topic.

Public Properties

AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
ActiveControl (inherited from ContainerControl) | The currently active control.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
AutoScaleMode (inherited from ContainerControl) | Determines how the form or control will scale when screen resolution or fonts change.
AutoScroll (inherited from ScrollableControl) | Indicates whether scroll bars automatically appear when the control contents are larger than its visible area.
AutoScrollMargin (inherited from ScrollableControl) | The margin around controls during auto scroll.
AutoScrollMinSize (inherited from ScrollableControl) | The minimum logical size for the auto scroll region.
AutoScrollPosition (inherited from ScrollableControl) | The current position of the auto-scrolling scroll bar.
AutoSizeMode (inherited from UserControl) | Specifies the mode by which the user interface element automatically resizes itself.
BackColor (inherited from Control) | The background color of the component.
BackgroundImage (inherited from Control) | The background image used for the control.
BackgroundImageLayout (inherited from Control) | The background image layout used for the component.
BindingContext (inherited from ContainerControl) | The binding manager for the container control. This manages all bindings of child controls to lists.
BorderStyle (inherited from UserControl) | Indicates whether the panel should have a border.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
CausesValidation (inherited from Control) | Indicates whether this component raises validation events.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
ClientSize (inherited from Control) | Determines the size of the inner area of this control.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ContextMenuStrip (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
Controls (inherited from Control) | The collection of child controls within this control.
Created (inherited from Control) | Determines if the control has been fully created.
Cursor (inherited from Control) | The cursor that appears when the pointer moves over the control.
DataBindings (inherited from Control) | The data bindings for the control.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
Enabled (inherited from Control) | Indicates whether the control is enabled.
Focused (inherited from Control) | Determines if this control has focus.
Font (inherited from Control) | The font used to display text in the control.
ForeColor (inherited from Control) | The foreground color of this component, which is used to display text.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HorizontalScroll (inherited from ScrollableControl) | Gets the horizontal scroll bar for this ScrollableControl.
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
Left (inherited from Control) | The upper left of the control, in container coordinates.
Location (inherited from Control) | The coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Specifies space between this control and another control's margin.
MaximumSize (inherited from Control) | Specifies the maximum size of the control.
MinimumSize (inherited from Control) | Specifies the minimum size of the control.
Padding (inherited from Control) | Specifies the interior spacing of a control.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from ContainerControl) | The parent form of this container control.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
Size (inherited from Control) | The size of the control in pixels.
TabIndex (inherited from Control) | Determines the index in the TAB order that this control will occupy.
TabStop (inherited from Control) | Indicates whether the user can use the TAB key to give focus to the control.
Tag (inherited from Control) | User-defined data associated with the object.
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
VerticalScroll (inherited from ScrollableControl) | Gets the vertical scroll bar for this ScrollableControl.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
Width (inherited from Control) | The width of the control, in container coordinates.


C1PreviewTextSearchPanel Events

C1PreviewTextSearchPanel Events

The events of the C1PreviewTextSearchPanel class are listed here. For a complete list of C1PreviewTextSearchPanel class members, see the C1PreviewTextSearchPanel Members topic.

Public Events

BackColorChanged (inherited from Control) | Event raised when the value of the BackColor property is changed on Control.
BackgroundImageChanged (inherited from Control) | Event raised when the value of the BackgroundImage property is changed on Control.
BackgroundImageLayoutChanged (inherited from Control) | Event raised when the value of the BackgroundImageLayout property is changed on Control.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
CausesValidationChanged (inherited from Control) | Event raised when the value of the CausesValidation property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
CursorChanged (inherited from Control) | Event raised when the value of the Cursor property is changed on Control.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
ForeColorChanged (inherited from Control) | Event raised when the value of the ForeColor property is changed on Control.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
Load (inherited from UserControl) | Occurs whenever the user control loads.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the Margin property has changed.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
PaddingChanged (inherited from Control) | Occurs when the Padding property has changed.
Paint (inherited from Control) | Occurs when a control needs repainting.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user moves the scroll box.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TabIndexChanged (inherited from Control) | Event raised when the value of the TabIndex property is changed.
TabStopChanged (inherited from Control) | Event raised when the value of the TabStop property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


C1PreviewThumbnailView Class

C1PreviewThumbnailView Class

Displays a list of thumbnails representing the pages of the connected preview pane.

For a list of all members of this type, see C1PreviewThumbnailView Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Windows.Forms.Control

System.Windows.Forms.ListView

C1.Win.C1Preview.C1PreviewThumbnailView

[Visual Basic]

Public Class C1PreviewThumbnailView

Inherits ListView

Implements INotifyPropertyChanged

[C#]

public class C1PreviewThumbnailView : ListView, INotifyPropertyChanged

[Delphi]

type C1PreviewThumbnailView = class (ListView, INotifyPropertyChanged);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


C1PreviewThumbnailView Members

C1PreviewThumbnailView Members

C1PreviewThumbnailView overview

Public Properties

AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
Activation (inherited from ListView) | Indicates the type of action required by the user to activate an item, and the feedback given.
Alignment (inherited from ListView) | Indicates how items are aligned within the ListView.
AllowColumnReorder (inherited from ListView) | Indicates whether the user can reorder columns in Details view.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
AutoArrange (inherited from ListView) | Indicates whether items are kept arranged automatically when in LargeIcon or SmallIcon view.
BackgroundImage (inherited from Control) | The background image used for the control.
BackgroundImageTiled (inherited from ListView) | Indicates whether the background image will be tiled to fill the entire background of the control.
BindingContext (inherited from Control) | The binding context for the control.
BorderStyle (inherited from ListView) | The border style of the control.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
CausesValidation (inherited from Control) | Indicates whether this component raises validation events.
CheckBoxes (inherited from ListView) | Indicates whether check boxes are displayed beside items.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
ClientSize (inherited from Control) | Determines the size of the inner area of this control.
Columns (inherited from ListView) | The columns shown in Details view.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ContextMenuStrip (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
Controls (inherited from Control) | The collection of child controls within this control.
Created (inherited from Control) | Determines if the control has been fully created.
DataBindings (inherited from Control) | The data bindings for the control.
DisplayRectangle (inherited from Control) | Retrieves the display rectangle of this control.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
Enabled (inherited from Control) | Indicates whether the control is enabled.
Focused (inherited from Control) | Determines if this control has focus.
FocusedItem (inherited from ListView) | The ListView item that currently has the user focus.
Font (inherited from Control) | The font used to display text in the control.
FullRowSelect (inherited from ListView) | Indicates whether all SubItems are highlighted along with the item when selected.
GridLines (inherited from ListView) | Displays grid lines around items and SubItems. Only shown when in Details view.
Groups (inherited from ListView) | The groups in the ListView.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
HeaderStyle (inherited from ListView) | The style of the column headers in Details view.
Height (inherited from Control) | The height of the user interface element, in pixels.
HideSelection (inherited from ListView) | Removes highlighting from the selected item when the control does not have focus.
HotTracking (inherited from ListView) | Allows items to appear as hyperlinks when the mouse hovers over them.
HoverSelection (inherited from ListView) | Allows items to be selected by hovering over them with the mouse.
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
InsertionMark (inherited from ListView) | Allows insertion mark attributes to be changed.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
LabelEdit (inherited from ListView) | Allows item labels to be edited in place by the user.
LabelWrap (inherited from ListView) | Determines whether label text can wrap to a new line.
Left (inherited from Control) | The upper left of the control, in container coordinates.
ListViewItemSorter (inherited from ListView) | The sorting comparer for this view.
Location (inherited from Control) | The coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Specifies space between this control and another control's margin.
MaximumSize (inherited from Control) | Specifies the maximum size of the control.
MinimumSize (inherited from Control) | Specifies the minimum size of the control.
MultiSelect (inherited from ListView) | Allows multiple items to be selected.
OwnerDraw (inherited from ListView) | Controls whether the system or the user paints items/SubItems.
PageNoFmt | Gets or sets the format used to display the page number below the page thumbnail.
Parent (inherited from Control) | The parent of this control.
PreviewPane | Gets or sets the preview pane to which this thumbnail view is connected.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
RightToLeftLayout (inherited from ListView) | Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.
Scrollable (inherited from ListView) | Indicates whether the control will display scroll bars if it contains more items than can fit in the client area.
SelectedItems (inherited from ListView) | A collection of items that are currently selected in the ListView.
ShowGroups (inherited from ListView) | Indicates whether the control will display the items in group form.
ShowItemToolTips (inherited from ListView) | Allows ListViewItems to display ToolTips.
Size (inherited from Control) | The size of the control in pixels.
Sorting (inherited from ListView) | Indicates the manner in which items are to be sorted.
TabIndex (inherited from Control) | Determines the index in the TAB order that this control will occupy.
TabStop (inherited from Control) | Indicates whether the user can use the TAB key to give focus to the control.
Tag (inherited from Control) | User-defined data associated with the object.
ThumbnailNavigation | Gets or sets the value indicating whether thumbnails should show the navigation rectangle which can be dragged or resized using the mouse.
ThumbnailSize | Gets or sets the size of page thumbnails.
TileSize (inherited from ListView) | The size of the tile in Tile view.
Top (inherited from Control) | The top of the control, in container coordinates.
TopItem (inherited from ListView) | The first item that is visible to the user.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
UseImageAsThumbnail | Gets or sets the value indicating whether the page image obtained from the preview pane should be used as the thumbnail (if this property is False, Image.GetThumbnailImage is called to obtain the thumbnail).
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
View (inherited from ListView) | Selects one of five different views that items can be shown in.
VirtualListSize (inherited from ListView) | Sets the count of the item collection when the ListView is in virtual mode.
VirtualMode (inherited from ListView) | Enables ListView virtual mode.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
Width (inherited from Control) | The width of the control, in container coordinates.

Public Events

AfterLabelEdit (inherited from ListView) | Occurs when the text of an item has been edited by the user.
BackColorChanged (inherited from Control) | Event raised when the value of the BackColor property is changed on Control.
BackgroundImageChanged (inherited from Control) | Event raised when the value of the BackgroundImage property is changed on Control.
BeforeLabelEdit (inherited from ListView) | Occurs when the text of an item is about to be edited by the user.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
CacheVirtualItems (inherited from ListView) | Notifies users of virtual ListView controls that they should prepare their cache.
CausesValidationChanged (inherited from Control) | Event raised when the value of the CausesValidation property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ColumnClick (inherited from ListView) | Occurs when a column header is clicked.
ColumnReordered (inherited from ListView) | Occurs when the ListView column header has been reordered.
ColumnWidthChanged (inherited from ListView) | Occurs when the user stops dragging the column header divider. Works only in Details mode.
ColumnWidthChanging (inherited from ListView) | Occurs when the user drags the column header divider. Works only in Details mode.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
CursorChanged (inherited from Control) | Event raised when the value of the Cursor property is changed on Control.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
DrawColumnHeader (inherited from ListView) | Occurs in owner draw mode, when a column header needs to be drawn.
DrawItem (inherited from ListView) | Occurs in owner-draw mode, when an item needs to be drawn.
DrawSubItem (inherited from ListView) | Occurs in owner-draw mode, when a SubItem (Details view only) needs to be drawn.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
ForeColorChanged (inherited from Control) | Event raised when the value of the ForeColor property is changed on Control.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
ItemActivate (inherited from ListView) | Occurs when an item is activated.
ItemCheck (inherited from ListView) | Indicates that an item is about to have its checked state changed. The value is not updated until after the event occurs.
ItemChecked (inherited from ListView) | Event raised when the checked property of a ListView item changes.
ItemDrag (inherited from ListView) | Occurs when the user begins dragging an item.
ItemMouseHover (inherited from ListView) | Occurs when the mouse hovers over an item.
ItemSelectionChanged (inherited from ListView) | Event raised when the selection state of an item has changed.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the Margin property has changed.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
PropertyChanged | Occurs when a property of the thumbnail view that is not inherited from the base class changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
RetrieveVirtualItem (inherited from ListView) | Retrieves the virtual item from the user.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
RightToLeftLayoutChanged (inherited from ListView) | Occurs when the value of the RightToLeftLayout property changes.
SearchForVirtualItem (inherited from ListView) | Notifies the user that a search is taking place on a virtual ListView.
SelectedIndexChanged (inherited from ListView) | Occurs whenever the 'SelectedIndex' property for this ListView changes.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TabIndexChanged (inherited from Control) | Event raised when the value of the TabIndex property is changed.
TabStopChanged (inherited from Control) | Event raised when the value of the TabStop property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VirtualItemsSelectionRangeChanged (inherited from ListView) | Event raised when the selection state of a range of items has changed. This event in raised only in virtual mode.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


C1PreviewThumbnailView Properties

C1PreviewThumbnailView Properties

The properties of the C1PreviewThumbnailView class are listed here. For a complete list of C1PreviewThumbnailView class members, see the C1PreviewThumbnailView Members topic.

Public Properties

AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
Activation (inherited from ListView) | Indicates the type of action required by the user to activate an item, and the feedback given.
Alignment (inherited from ListView) | Indicates how items are aligned within the ListView.
AllowColumnReorder (inherited from ListView) | Indicates whether the user can reorder columns in Details view.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
AutoArrange (inherited from ListView) | Indicates whether items are kept arranged automatically when in LargeIcon or SmallIcon view.
BackgroundImage (inherited from Control) | The background image used for the control.
BackgroundImageTiled (inherited from ListView) | Indicates whether the background image will be tiled to fill the entire background of the control.
BindingContext (inherited from Control) | The binding context for the control.
BorderStyle (inherited from ListView) | The border style of the control.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
CausesValidation (inherited from Control) | Indicates whether this component raises validation events.
CheckBoxes (inherited from ListView) | Indicates whether check boxes are displayed beside items.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
ClientSize (inherited from Control) | Determines the size of the inner area of this control.
Columns (inherited from ListView) | The columns shown in Details view.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
ContextMenuStrip (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
Controls (inherited from Control) | The collection of child controls within this control.
Created (inherited from Control) | Determines if the control has been fully created.
DataBindings (inherited from Control) | The data bindings for the control.
DisplayRectangle (inherited from Control) | Retrieves the display rectangle of this control.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
Enabled (inherited from Control) | Indicates whether the control is enabled.
Focused (inherited from Control) | Determines if this control has focus.
FocusedItem (inherited from ListView) | The ListView item that currently has the user focus.
Font (inherited from Control) | The font used to display text in the control.
FullRowSelect (inherited from ListView) | Indicates whether all SubItems are highlighted along with the item when selected.
GridLines (inherited from ListView) | Displays grid lines around items and SubItems. Only shown when in Details view.
Groups (inherited from ListView) | The groups in the ListView.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
HeaderStyle (inherited from ListView) | The style of the column headers in Details view.
Height (inherited from Control) | The height of the user interface element, in pixels.
HideSelection (inherited from ListView) | Removes highlighting from the selected item when the control does not have focus.
HotTracking (inherited from ListView) | Allows items to appear as hyperlinks when the mouse hovers over them.
HoverSelection (inherited from ListView) | Allows items to be selected by hovering over them with the mouse.
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
InsertionMark (inherited from ListView) | Allows insertion mark attributes to be changed.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
LabelEdit (inherited from ListView) | Allows item labels to be edited in place by the user.
LabelWrap (inherited from ListView) | Determines whether label text can wrap to a new line.
Left (inherited from Control) | The upper left of the control, in container coordinates.
ListViewItemSorter (inherited from ListView) | The sorting comparer for this view.
Location (inherited from Control) | The coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Specifies space between this control and another control's margin.
MaximumSize (inherited from Control) | Specifies the maximum size of the control.
MinimumSize (inherited from Control) | Specifies the minimum size of the control.
MultiSelect (inherited from ListView) | Allows multiple items to be selected.
OwnerDraw (inherited from ListView) | Controls whether the system or the user paints items/SubItems.
PageNoFmt | Gets or sets the format used to display the page number below the page thumbnail.
Parent (inherited from Control) | The parent of this control.
PreviewPane | Gets or sets the preview pane to which this thumbnail view is connected.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
RightToLeftLayout (inherited from ListView) | Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.
Scrollable (inherited from ListView) | Indicates whether the control will display scroll bars if it contains more items than can fit in the client area.
SelectedItems (inherited from ListView) | A collection of items that are currently selected in the ListView.
ShowGroups (inherited from ListView) | Indicates whether the control will display the items in group form.
ShowItemToolTips (inherited from ListView) | Allows ListViewItems to display ToolTips.
Size (inherited from Control) | The size of the control in pixels.
Sorting (inherited from ListView) | Indicates the manner in which items are to be sorted.
TabIndex (inherited from Control) | Determines the index in the TAB order that this control will occupy.
TabStop (inherited from Control) | Indicates whether the user can use the TAB key to give focus to the control.
Tag (inherited from Control) | User-defined data associated with the object.
ThumbnailNavigation | Gets or sets the value indicating whether thumbnails should show the navigation rectangle which can be dragged or resized using the mouse.
ThumbnailSize | Gets or sets the size of page thumbnails.
TileSize (inherited from ListView) | The size of the tile in Tile view.
Top (inherited from Control) | The top of the control, in container coordinates.
TopItem (inherited from ListView) | The first item that is visible to the user.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
UseImageAsThumbnail | Gets or sets the value indicating whether the page image obtained from the preview pane should be used as the thumbnail (if this property is False, Image.GetThumbnailImage is called to obtain the thumbnail).
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
View (inherited from ListView) | Selects one of five different views that items can be shown in.
VirtualListSize (inherited from ListView) | Sets the count of the item collection when the ListView is in virtual mode.
VirtualMode (inherited from ListView) | Enables ListView virtual mode.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
Width (inherited from Control) | The width of the control, in container coordinates.


C1PreviewThumbnailView.PageNoFmt Property

C1PreviewThumbnailView.PageNoFmt Property

Gets or sets the format used to display the page number below the page thumbnail.

[Visual Basic]

Public Property PageNoFmt As String

[C#]

public string PageNoFmt {get;set;}

[Delphi]

public property PageNoFmt: String read get_PageNoFmt write set_PageNoFmt;


C1PreviewThumbnailView.PreviewPane Property

C1PreviewThumbnailView.PreviewPane Property

Gets or sets the preview pane to which this thumbnail view is connected.

[Visual Basic]

Public Property PreviewPane As C1PreviewPane

[C#]

public C1PreviewPane PreviewPane {get;set;}

[Delphi]

public property PreviewPane: C1PreviewPane read get_PreviewPane write set_PreviewPane;


C1PreviewThumbnailView.ThumbnailNavigation Property

C1PreviewThumbnailView.ThumbnailNavigation Property

Gets or sets the value indicating whether thumbnails should show the navigation rectangle which can be dragged or resized using the mouse.

[Visual Basic]

Public Property ThumbnailNavigation As Boolean

[C#]

public bool ThumbnailNavigation {get;set;}

[Delphi]

public property ThumbnailNavigation: Boolean read get_ThumbnailNavigation write set_ThumbnailNavigation;


C1PreviewThumbnailView.ThumbnailSize Property

C1PreviewThumbnailView.ThumbnailSize Property

Gets or sets the size of page thumbnails.

[Visual Basic]

Public Property ThumbnailSize As Size

[C#]

public Size ThumbnailSize {get;set;}

[Delphi]

public property ThumbnailSize: Size read get_ThumbnailSize write set_ThumbnailSize;


C1PreviewThumbnailView.UseImageAsThumbnail Property

C1PreviewThumbnailView.UseImageAsThumbnail Property

Gets or sets the value indicating whether the page image obtained from the preview pane should be used as the thumbnail (if this property is False, Image.GetThumbnailImage is called to obtain the thumbnail).

[Visual Basic]

Public Property UseImageAsThumbnail As Boolean

[C#]

public bool UseImageAsThumbnail {get;set;}

[Delphi]

public property UseImageAsThumbnail: Boolean read get_UseImageAsThumbnail write set_UseImageAsThumbnail;


C1PreviewThumbnailView Events

C1PreviewThumbnailView Events

The events of the C1PreviewThumbnailView class are listed here. For a complete list of C1PreviewThumbnailView class members, see the C1PreviewThumbnailView Members topic.

Public Events

AfterLabelEdit (inherited from ListView) | Occurs when the text of an item has been edited by the user.
BackColorChanged (inherited from Control) | Event raised when the value of the BackColor property is changed on Control.
BackgroundImageChanged (inherited from Control) | Event raised when the value of the BackgroundImage property is changed on Control.
BeforeLabelEdit (inherited from ListView) | Occurs when the text of an item is about to be edited by the user.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
CacheVirtualItems (inherited from ListView) | Notifies users of virtual ListView controls that they should prepare their cache.
CausesValidationChanged (inherited from Control) | Event raised when the value of the CausesValidation property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ColumnClick (inherited from ListView) | Occurs when a column header is clicked.
ColumnReordered (inherited from ListView) | Occurs when the ListView column header has been reordered.
ColumnWidthChanged (inherited from ListView) | Occurs when the user stops dragging the column header divider. Works only in Details mode.
ColumnWidthChanging (inherited from ListView) | Occurs when the user drags the column header divider. Works only in Details mode.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
CursorChanged (inherited from Control) | Event raised when the value of the Cursor property is changed on Control.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
DrawColumnHeader (inherited from ListView) | Occurs in owner draw mode, when a column header needs to be drawn.
DrawItem (inherited from ListView) | Occurs in owner-draw mode, when an item needs to be drawn.
DrawSubItem (inherited from ListView) | Occurs in owner-draw mode, when a SubItem (Details view only) needs to be drawn.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
ForeColorChanged (inherited from Control) | Event raised when the value of the ForeColor property is changed on Control.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
ItemActivate (inherited from ListView) | Occurs when an item is activated.
ItemCheck (inherited from ListView) | Indicates that an item is about to have its checked state changed. The value is not updated until after the event occurs.
ItemChecked (inherited from ListView) | Event raised when the checked property of a ListView item changes.
ItemDrag (inherited from ListView) | Occurs when the user begins dragging an item.
ItemMouseHover (inherited from ListView) | Occurs when the mouse hovers over an item.
ItemSelectionChanged (inherited from ListView) | Event raised when the selection state of an item has changed.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the Margin property has changed.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
PropertyChanged | Occurs when a property of the thumbnail view that is not inherited from the base class changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
RetrieveVirtualItem (inherited from ListView) | Retrieves the virtual item from the user.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
RightToLeftLayoutChanged (inherited from ListView) | Occurs when the value of the RightToLeftLayout property changes.
SearchForVirtualItem (inherited from ListView) | Notifies the user that a search is taking place on a virtual ListView.
SelectedIndexChanged (inherited from ListView) | Occurs whenever the 'SelectedIndex' property for this ListView changes.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TabIndexChanged (inherited from Control) | Event raised when the value of the TabIndex property is changed.
TabStopChanged (inherited from Control) | Event raised when the value of the TabStop property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VirtualItemsSelectionRangeChanged (inherited from ListView) | Event raised when the selection state of a range of items has changed. This event in raised only in virtual mode.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


C1PreviewThumbnailView.PropertyChanged Event

C1PreviewThumbnailView.PropertyChanged Event

Occurs when a property of the thumbnail view that is not inherited from the base class changes.

[Visual Basic]

Public Event PropertyChanged As PropertyChangedEventHandler

[C#]

public event PropertyChangedEventHandlerPropertyChanged

[Delphi]

public property PropertyChanged: PropertyChangedEventHandler read remove_PropertyChanged write add_PropertyChanged;


C1PrintPreviewControl Class

C1PrintPreviewControl Class

Represents an integrated preview control, containing a preview pane, a navigation panel, toolbars and a status bar.

For a list of all members of this type, see C1PrintPreviewControl Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Windows.Forms.Control

System.Windows.Forms.ScrollableControl

System.Windows.Forms.ContainerControl

System.Windows.Forms.ToolStripContainer

C1.Win.C1Preview.C1PrintPreviewControl

[Visual Basic]

Public Class C1PrintPreviewControl

Inherits ToolStripContainer

[C#]

public class C1PrintPreviewControl : ToolStripContainer

[Delphi]

type C1PrintPreviewControl = class (ToolStripContainer);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


C1PrintPreviewControl Members

C1PrintPreviewControl Members

C1PrintPreviewControl overview

Public Constructors

C1PrintPreviewControl Constructor

Initializes a new instance of the C1PrintPreviewControl class.

Public Properties

AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
ActiveControl (inherited from ContainerControl) | The currently active control.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
AutoScaleMode (inherited from ContainerControl) | Determines how the form or control will scale when screen resolution or fonts change.
AutoScrollPosition (inherited from ScrollableControl) | The current position of the auto-scrolling scroll bar.
AvailablePreviewActions | Gets or sets the flags indicating which tools should be available in the preview.
BindingContext (inherited from ContainerControl) | The binding manager for the container control. This manages all bindings of child controls to lists.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
BottomToolStripPanel | Overridden.
BottomToolStripPanelVisible | Overridden.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
ClientSize (inherited from Control) | Determines the size of the inner area of this control.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContentPanel | Overridden.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
Created (inherited from Control) | Determines if the control has been fully created.
DataBindings (inherited from Control) | The data bindings for the control.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
Document | Gets or sets the document shown by the preview.
Enabled (inherited from Control) | Indicates whether the control is enabled.
ExportOptions | Gets the options controlling the behavior of export modules.
Focused (inherited from Control) | Determines if this control has focus.
Font (inherited from Control) | The font used to display text in the control.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HorizontalScroll (inherited from ScrollableControl) | Gets the horizontal scroll bar for this ScrollableControl.
ImageSet | Gets or sets the image set used by the preview.
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
Left (inherited from Control) | The upper left of the control, in container coordinates.
LeftToolStripPanel | Overridden.
LeftToolStripPanelVisible | Overridden.
Location (inherited from Control) | The coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Specifies space between this control and another control's margin.
MaximumSize (inherited from Control) | Specifies the maximum size of the control.
MinimumSize (inherited from Control) | Specifies the minimum size of the control.
NavigationPanelVisible | Gets or sets the value indicating whether the navigation panel should be visible in the preview.
Padding (inherited from Control) | Specifies the interior spacing of a control.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from ContainerControl) | The parent form of this container control.
PreviewNavigationPanel | Gets the preview navigation panel.
PreviewOutlineView | Gets the preview outline view.
PreviewPane | Gets the preview pane.
PreviewProgressBar | Gets the preview progress bar.
PreviewStatusBar | Gets the preview status bar.
PreviewStatusText | Gets the preview status.
PreviewTextSearchPanel | Gets the preview text search panel.
PreviewThumbnailView | Gets the preview thumbnails view.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
RightToolStripPanel | Overridden.
RightToolStripPanelVisible | Overridden.
Size (inherited from Control) | The size of the control in pixels.
StatusBarVisible | Gets or sets the value indicating whether the status bar should be visible in the preview.
TabIndex (inherited from Control) | Determines the index in the TAB order that this control will occupy.
TabStop (inherited from Control) | Indicates whether the user can use the TAB key to give focus to the control.
Tag (inherited from Control) | User-defined data associated with the object.
Text (inherited from Control) | The text associated with the control.
ToolBars | Gets the toolbars of the preview control.
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
TopToolStripPanel | Overridden.
TopToolStripPanelVisible | Overridden.
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
VerticalScroll (inherited from ScrollableControl) | Gets the vertical scroll bar for this ScrollableControl.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
Width (inherited from Control) | The width of the control, in container coordinates.

Public Events

BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the Margin property has changed.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
PaddingChanged (inherited from Control) | Occurs when the Padding property has changed.
Paint (inherited from Control) | Occurs when a control needs repainting.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user moves the scroll box.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TabIndexChanged (inherited from Control) | Event raised when the value of the TabIndex property is changed.
TabStopChanged (inherited from Control) | Event raised when the value of the TabStop property is changed on Control.
TextChanged (inherited from Control) | Event raised when the value of the Text property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


C1PrintPreviewControl Constructor

C1PrintPreviewControl Constructor

Initializes a new instance of the C1PrintPreviewControl class.

[Visual Basic]

Public Function New()

[C#]

public C1PrintPreviewControl()

[Delphi]

public constructor Create();


C1PrintPreviewControl Properties

C1PrintPreviewControl Properties

The properties of the C1PrintPreviewControl class are listed here. For a complete list of C1PrintPreviewControl class members, see the C1PrintPreviewControl Members topic.

Public Properties

AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
AccessibleDescription (inherited from Control) | The description that will be reported to accessibility clients.
AccessibleName (inherited from Control) | The name that will be reported to accessibility clients.
AccessibleRole (inherited from Control) | The role that will be reported to accessibility clients.
ActiveControl (inherited from ContainerControl) | The currently active control.
AllowDrop (inherited from Control) | Indicates whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant.
AutoScaleMode (inherited from ContainerControl) | Determines how the form or control will scale when screen resolution or fonts change.
AutoScrollPosition (inherited from ScrollableControl) | The current position of the auto-scrolling scroll bar.
AvailablePreviewActions | Gets or sets the flags indicating which tools should be available in the preview.
BindingContext (inherited from ContainerControl) | The binding manager for the container control. This manages all bindings of child controls to lists.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
BottomToolStripPanel | Overridden.
BottomToolStripPanelVisible | Overridden.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
ClientSize (inherited from Control) | Determines the size of the inner area of this control.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ContentPanel | Overridden.
ContextMenu (inherited from Control) | The shortcut menu to display when the user right-clicks the control.
Created (inherited from Control) | Determines if the control has been fully created.
DataBindings (inherited from Control) | The data bindings for the control.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Dock (inherited from Control) | Defines which borders of the control are bound to the container.
Document | Gets or sets the document shown by the preview.
Enabled (inherited from Control) | Indicates whether the control is enabled.
ExportOptions | Gets the options controlling the behavior of export modules.
Focused (inherited from Control) | Determines if this control has focus.
Font (inherited from Control) | The font used to display text in the control.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HorizontalScroll (inherited from ScrollableControl) | Gets the horizontal scroll bar for this ScrollableControl.
ImageSet | Gets or sets the image set used by the preview.
ImeMode (inherited from Control) | Determines the IME (Input Method Editor) status of the object when selected.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
Left (inherited from Control) | The upper left of the control, in container coordinates.
LeftToolStripPanel | Overridden.
LeftToolStripPanelVisible | Overridden.
Location (inherited from Control) | The coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Specifies space between this control and another control's margin.
MaximumSize (inherited from Control) | Specifies the maximum size of the control.
MinimumSize (inherited from Control) | Specifies the minimum size of the control.
NavigationPanelVisible | Gets or sets the value indicating whether the navigation panel should be visible in the preview.
Padding (inherited from Control) | Specifies the interior spacing of a control.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from ContainerControl) | The parent form of this container control.
PreviewNavigationPanel | Gets the preview navigation panel.
PreviewOutlineView | Gets the preview outline view.
PreviewPane | Gets the preview pane.
PreviewProgressBar | Gets the preview progress bar.
PreviewStatusBar | Gets the preview status bar.
PreviewStatusText | Gets the preview status.
PreviewTextSearchPanel | Gets the preview text search panel.
PreviewThumbnailView | Gets the preview thumbnails view.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Indicates whether the component should draw right-to-left for RTL languages.
RightToolStripPanel | Overridden.
RightToolStripPanelVisible | Overridden.
Size (inherited from Control) | The size of the control in pixels.
StatusBarVisible | Gets or sets the value indicating whether the status bar should be visible in the preview.
TabIndex (inherited from Control) | Determines the index in the TAB order that this control will occupy.
TabStop (inherited from Control) | Indicates whether the user can use the TAB key to give focus to the control.
Tag (inherited from Control) | User-defined data associated with the object.
Text (inherited from Control) | The text associated with the control.
ToolBars | Gets the toolbars of the preview control.
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
TopToolStripPanel | Overridden.
TopToolStripPanelVisible | Overridden.
UseWaitCursor (inherited from Control) | When this property is True, the Cursor property of the control and its child controls is set to WaitCursor.
VerticalScroll (inherited from ScrollableControl) | Gets the vertical scroll bar for this ScrollableControl.
Visible (inherited from Control) | Determines whether the control is visible or hidden.
Width (inherited from Control) | The width of the control, in container coordinates.


C1PrintPreviewControl.AvailablePreviewActions Property

C1PrintPreviewControl.AvailablePreviewActions Property

Gets or sets the flags indicating which tools should be available in the preview.

[Visual Basic]

Public Property AvailablePreviewActions As C1PreviewActionFlags

[C#]

public C1PreviewActionFlags AvailablePreviewActions {get;set;}

[Delphi]

public property AvailablePreviewActions: C1PreviewActionFlags read get_AvailablePreviewActions write set_AvailablePreviewActions;


C1PrintPreviewControl.BottomToolStripPanel Property

C1PrintPreviewControl.BottomToolStripPanel Property

Overridden.

[Visual Basic]

Public ReadOnly Property BottomToolStripPanel As ToolStripPanel

[C#]

new public ToolStripPanel BottomToolStripPanel {get;}

[Delphi]

public property BottomToolStripPanel: ToolStripPanel read get_BottomToolStripPanel;


C1PrintPreviewControl.BottomToolStripPanelVisible Property

C1PrintPreviewControl.BottomToolStripPanelVisible Property

Overridden.

[Visual Basic]

Public Property BottomToolStripPanelVisible As Boolean

[C#]

new public bool BottomToolStripPanelVisible {get;set;}

[Delphi]

public property BottomToolStripPanelVisible: Boolean read get_BottomToolStripPanelVisible write set_BottomToolStripPanelVisible;


C1PrintPreviewControl.ContentPanel Property

C1PrintPreviewControl.ContentPanel Property

Overridden.

[Visual Basic]

Public ReadOnly Property ContentPanel As ToolStripContentPanel

[C#]

new public ToolStripContentPanel ContentPanel {get;}

[Delphi]

public property ContentPanel: ToolStripContentPanel read get_ContentPanel;


C1PrintPreviewControl.Document Property

C1PrintPreviewControl.Document Property

Gets or sets the document shown by the preview.

[Visual Basic]

Public Property Document As Object

[C#]

public object Document {get;set;}

[Delphi]

public property Document: Object read get_Document write set_Document;


C1PrintPreviewControl.ExportOptions Property

C1PrintPreviewControl.ExportOptions Property

Gets the options controlling the behavior of export modules.

[Visual Basic]

Public ReadOnly Property ExportOptions As ExportOptions

[C#]

public ExportOptions ExportOptions {get;}

[Delphi]

public property ExportOptions: ExportOptions read get_ExportOptions;


C1PrintPreviewControl.ImageSet Property

C1PrintPreviewControl.ImageSet Property

Gets or sets the image set used by the preview.

[Visual Basic]

Public Property ImageSet As ImageSetEnum

[C#]

public ImageSetEnum ImageSet {get;set;}

[Delphi]

public property ImageSet: ImageSetEnum read get_ImageSet write set_ImageSet;


C1PrintPreviewControl.LeftToolStripPanel Property

C1PrintPreviewControl.LeftToolStripPanel Property

Overridden.

[Visual Basic]

Public ReadOnly Property LeftToolStripPanel As ToolStripPanel

[C#]

new public ToolStripPanel LeftToolStripPanel {get;}

[Delphi]

public property LeftToolStripPanel: ToolStripPanel read get_LeftToolStripPanel;


C1PrintPreviewControl.LeftToolStripPanelVisible Property

C1PrintPreviewControl.LeftToolStripPanelVisible Property

Overridden.

[Visual Basic]

Public Property LeftToolStripPanelVisible As Boolean

[C#]

new public bool LeftToolStripPanelVisible {get;set;}

[Delphi]

public property LeftToolStripPanelVisible: Boolean read get_LeftToolStripPanelVisible write set_LeftToolStripPanelVisible;


C1PrintPreviewControl.NavigationPanelVisible Property

C1PrintPreviewControl.NavigationPanelVisible Property

Gets or sets the value indicating whether the navigation panel should be visible in the preview.

[Visual Basic]

Public Property NavigationPanelVisible As Boolean

[C#]

public bool NavigationPanelVisible {get;set;}

[Delphi]

public property NavigationPanelVisible: Boolean read get_NavigationPanelVisible write set_NavigationPanelVisible;


C1PrintPreviewControl.PreviewNavigationPanel Property

C1PrintPreviewControl.PreviewNavigationPanel Property

Gets the preview navigation panel.

[Visual Basic]

Public ReadOnly Property PreviewNavigationPanel As Control

[C#]

public Control PreviewNavigationPanel {get;}

[Delphi]

public property PreviewNavigationPanel: Control read get_PreviewNavigationPanel;


C1PrintPreviewControl.PreviewOutlineView Property

C1PrintPreviewControl.PreviewOutlineView Property

Gets the preview outline view.

[Visual Basic]

Public ReadOnly Property PreviewOutlineView As C1PreviewOutlineView

[C#]

public C1PreviewOutlineView PreviewOutlineView {get;}

[Delphi]

public property PreviewOutlineView: C1PreviewOutlineView read get_PreviewOutlineView;


C1PrintPreviewControl.PreviewPane Property

C1PrintPreviewControl.PreviewPane Property

Gets the preview pane.

[Visual Basic]

Public ReadOnly Property PreviewPane As C1PreviewPane

[C#]

public C1PreviewPane PreviewPane {get;}

[Delphi]

public property PreviewPane: C1PreviewPane read get_PreviewPane;


C1PrintPreviewControl.PreviewProgressBar Property

C1PrintPreviewControl.PreviewProgressBar Property

Gets the preview progress bar.

[Visual Basic]

Public ReadOnly Property PreviewProgressBar As ToolStripProgressBar

[C#]

public ToolStripProgressBar PreviewProgressBar {get;}

[Delphi]

public property PreviewProgressBar: ToolStripProgressBar read get_PreviewProgressBar;


C1PrintPreviewControl.PreviewStatusBar Property

C1PrintPreviewControl.PreviewStatusBar Property

Gets the preview status bar.

[Visual Basic]

Public ReadOnly Property PreviewStatusBar As Control

[C#]

public Control PreviewStatusBar {get;}

[Delphi]

public property PreviewStatusBar: Control read get_PreviewStatusBar;


C1PrintPreviewControl.PreviewStatusText Property

C1PrintPreviewControl.PreviewStatusText Property

Gets the preview status.

[Visual Basic]

Public ReadOnly Property PreviewStatusText As ToolStripStatusLabel

[C#]

public ToolStripStatusLabel PreviewStatusText {get;}

[Delphi]

public property PreviewStatusText: ToolStripStatusLabel read get_PreviewStatusText;


C1PrintPreviewControl.PreviewTextSearchPanel Property

C1PrintPreviewControl.PreviewTextSearchPanel Property

Gets the preview text search panel.

[Visual Basic]

Public ReadOnly Property PreviewTextSearchPanel As C1PreviewTextSearchPanel

[C#]

public C1PreviewTextSearchPanel PreviewTextSearchPanel {get;}

[Delphi]

public property PreviewTextSearchPanel: C1PreviewTextSearchPanel read get_PreviewTextSearchPanel;


C1PrintPreviewControl.PreviewThumbnailView Property

C1PrintPreviewControl.PreviewThumbnailView Property

Gets the preview thumbnails view.

[Visual Basic]

Public ReadOnly Property PreviewThumbnailView As C1PreviewThumbnailView

[C#]

public C1PreviewThumbnailView PreviewThumbnailView {get;}

[Delphi]

public property PreviewThumbnailView: C1PreviewThumbnailView read get_PreviewThumbnailView;


C1PrintPreviewControl.RightToolStripPanel Property

C1PrintPreviewControl.RightToolStripPanel Property

Overridden.

[Visual Basic]

Public ReadOnly Property RightToolStripPanel As ToolStripPanel

[C#]

new public ToolStripPanel RightToolStripPanel {get;}

[Delphi]

public property RightToolStripPanel: ToolStripPanel read get_RightToolStripPanel;


C1PrintPreviewControl.RightToolStripPanelVisible Property

C1PrintPreviewControl.RightToolStripPanelVisible Property

Overridden.

[Visual Basic]

Public Property RightToolStripPanelVisible As Boolean

[C#]

new public bool RightToolStripPanelVisible {get;set;}

[Delphi]

public property RightToolStripPanelVisible: Boolean read get_RightToolStripPanelVisible write set_RightToolStripPanelVisible;


C1PrintPreviewControl.StatusBarVisible Property

C1PrintPreviewControl.StatusBarVisible Property

Gets or sets the value indicating whether the status bar should be visible in the preview.

[Visual Basic]

Public Property StatusBarVisible As Boolean

[C#]

public bool StatusBarVisible {get;set;}

[Delphi]

public property StatusBarVisible: Boolean read get_StatusBarVisible write set_StatusBarVisible;


C1PrintPreviewControl.ToolBars Property

C1PrintPreviewControl.ToolBars Property

Gets the toolbars of the preview control.

[Visual Basic]

Public ReadOnly Property ToolBars As C1PrintPreviewControl.PreviewToolBars

[C#]

public C1PrintPreviewControl.PreviewToolBars ToolBars {get;}

[Delphi]

public property ToolBars: PreviewToolBars read get_ToolBars;


C1PrintPreviewControl.TopToolStripPanel Property

C1PrintPreviewControl.TopToolStripPanel Property

Overridden.

[Visual Basic]

Public ReadOnly Property TopToolStripPanel As ToolStripPanel

[C#]

new public ToolStripPanel TopToolStripPanel {get;}

[Delphi]

public property TopToolStripPanel: ToolStripPanel read get_TopToolStripPanel;


C1PrintPreviewControl.TopToolStripPanelVisible Property

C1PrintPreviewControl.TopToolStripPanelVisible Property

Overridden.

[Visual Basic]

Public Property TopToolStripPanelVisible As Boolean

[C#]

new public bool TopToolStripPanelVisible {get;set;}

[Delphi]

public property TopToolStripPanelVisible: Boolean read get_TopToolStripPanelVisible write set_TopToolStripPanelVisible;


C1PrintPreviewControl Events

C1PrintPreviewControl Events

The events of the C1PrintPreviewControl class are listed here. For a complete list of C1PrintPreviewControl class members, see the C1PrintPreviewControl Members topic.

Public Events

BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
DockChanged (inherited from Control) | Event raised when the value of the Dock property is changed on Control.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the control's enabled state changes.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FontChanged (inherited from Control) | Event raised when the value of the Font property is changed on Control.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
ImeModeChanged (inherited from Control) | Occurs when the control's input method editor (IME) mode changes.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
LocationChanged (inherited from Control) | Event raised when the value of the Location property is changed on Control.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the Margin property has changed.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
PaddingChanged (inherited from Control) | Occurs when the Padding property has changed.
Paint (inherited from Control) | Occurs when a control needs repainting.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the value of the RightToLeft property changes.
Scroll (inherited from ScrollableControl) | Occurs when the user moves the scroll box.
SizeChanged (inherited from Control) | Event raised when the value of the Size property is changed on Control.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TabIndexChanged (inherited from Control) | Event raised when the value of the TabIndex property is changed.
TabStopChanged (inherited from Control) | Event raised when the value of the TabStop property is changed on Control.
TextChanged (inherited from Control) | Event raised when the value of the Text property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


C1PrintPreviewDialog Class

C1PrintPreviewDialog Class

Displays a dialog box that shows the preview of the associated document. Includes toolbars, navigation panel and status bar.

For a list of all members of this type, see C1PrintPreviewDialog Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Windows.Forms.Control

System.Windows.Forms.ScrollableControl

System.Windows.Forms.ContainerControl

System.Windows.Forms.Form

C1.Win.C1Preview.C1PrintPreviewDialog

[Visual Basic]

Public Class C1PrintPreviewDialog

Inherits Form

[C#]

public class C1PrintPreviewDialog : Form

[Delphi]

type C1PrintPreviewDialog = class (Form);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


C1PrintPreviewDialog Members

C1PrintPreviewDialog Members

C1PrintPreviewDialog overview

Public Constructors

C1PrintPreviewDialog Constructor

Initializes a new instance of the C1PrintPreviewDialog class.

Public Properties

AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
ActiveControl (inherited from ContainerControl) | The currently active control.
ActiveMdiChild (inherited from Form) | The currently active MDI child form.
AllowTransparency (inherited from Form) | Indicates whether the opacity of the control can be adjusted.
AutoScaleMode (inherited from ContainerControl) | Determines how the form or control will scale when screen resolution or fonts change.
AutoScrollPosition (inherited from ScrollableControl) | The current position of the auto-scrolling scroll bar.
AutoSizeMode (inherited from Form) | Specifies the mode by which the user interface element automatically resizes itself.
AvailablePreviewActions | Gets or sets flags indicating which tools should be available in the preview.
BindingContext (inherited from ContainerControl) | The binding manager for the container control. This manages all bindings of child controls to lists.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ControlBox (inherited from Form) | Determines whether a form has a Control/System menu box.
Created (inherited from Control) | Determines if the control has been fully created.
DesktopBounds (inherited from Form) | The bounds of this form in desktop coordinates.
DesktopLocation (inherited from Form) | The location of this form in desktop coordinates.
DialogResult (inherited from Form) | The value this form will return if displayed as a dialog box.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Document | Gets or sets the document shown by the dialog.
Focused (inherited from Control) | Determines if this control has focus.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HelpButton (inherited from Form) | Determines whether a form has a Help button on the caption bar.
HorizontalScroll (inherited from ScrollableControl) | Gets the horizontal scroll bar for this ScrollableControl.
Icon (inherited from Form) | Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Determines whether the form is a child of a MDI container.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
Left (inherited from Control) | The upper left of the control, in container coordinates.
MainMenuStrip (inherited from Form) | Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.
MaximizeBox (inherited from Form) | Determines whether a form has a maximize box in the upper-right corner of its caption bar.
MaximumSize (inherited from Form) | The maximum size the form can be resized to.
MdiChildren (inherited from Form) | Retrieves the MDI children of this form.
MdiParent (inherited from Form) | Retrieves the MDI parent of this form.
MergedMenu (inherited from Form) | The merged menu of this form, which is used when displaying a single merged MDI menu.
MinimizeBox (inherited from Form) | Determines whether a form has a minimize box in the upper-right corner of its caption bar.
Modal (inherited from Form) | Indicates if this form is currently being displayed as a modal dialog box.
NavigationPanelVisible | Gets or sets the value indicating whether the navigation panel should be visible.
Opacity | Overridden. Do not use.
OwnedForms (inherited from Form) | Array of forms owned by this form.
Owner (inherited from Form) | The owner of this form.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from ContainerControl) | The parent form of this container control.
PreviewOutlineView | Gets the preview outline tspanel.
PreviewPane | Gets the preview pane.
PreviewProgressBar | Gets the preview progress bar.
PreviewStatusText | Gets the preview progress bar.
PreviewTextSearchPanel | Gets the preview text search tspanel.
PreviewThumbnailView | Gets the preview thumbnails tspanel.
PrintPreviewControl | Gets the C1PrintPreviewControl shown by the current print preview dialog.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
ShowIcon (inherited from Form) | Indicates whether an icon is displayed in the title bar of the form.
ShowInTaskbar (inherited from Form) | Determines whether the form appears in the Windows Taskbar.
StartPosition (inherited from Form) | Determines the position of a form when it first appears.
StatusBarVisible | Gets or sets the value indicating whether the status bar should be visible.
Tag (inherited from Control) | User-defined data associated with the object.
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
TopMost (inherited from Form) | Indicates whether the form always appears above all other forms that do not have this property set to True.
VerticalScroll (inherited from ScrollableControl) | Gets the vertical scroll bar for this ScrollableControl.
Width (inherited from Control) | The width of the control, in container coordinates.
WindowState (inherited from Form) | Determines the initial visual state of the form.

Public Events

Activated (inherited from Form) | Occurs whenever the form is activated.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
Deactivate (inherited from Form) | Occurs whenever the form is deactivated.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FormClosed (inherited from Form) | Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.
FormClosing (inherited from Form) | Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpButtonClicked (inherited from Form) | Event raised when the help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
InputLanguageChanged (inherited from Form) | Occurs whenever the language used for input for this form changes.
InputLanguageChanging (inherited from Form) | A request by the system to change the input language for this form. This request can be refused.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
Load (inherited from Form) | Occurs whenever the user loads the form.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Event raised when the value of the MaximizedBounds property is changed on Form.
MdiChildActivate (inherited from Form) | Occurs when an MDI Child window is activated.
MenuComplete (inherited from Form) | Occurs when menu selection is completed and menu modal message loop has exited.
MenuStart (inherited from Form) | Occurs when any menu is displayed and menu modal message loop is entered.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
Paint (inherited from Control) | Occurs when a control needs repainting.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
ResizeBegin (inherited from Form) | Occurs when the form enters the sizing modal loop.
ResizeEnd (inherited from Form) | Occurs when the control exits the sizing modal loop.
Scroll (inherited from ScrollableControl) | Occurs when the user moves the scroll box.
Shown (inherited from Form) | Occurs whenever the form is first shown.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TextChanged (inherited from Control) | Event raised when the value of the Text property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


C1PrintPreviewDialog Constructor

C1PrintPreviewDialog Constructor

Initializes a new instance of the C1PrintPreviewDialog class.

[Visual Basic]

Public Function New()

[C#]

public C1PrintPreviewDialog()

[Delphi]

public constructor Create();


C1PrintPreviewDialog Properties

C1PrintPreviewDialog Properties

The properties of the C1PrintPreviewDialog class are listed here. For a complete list of C1PrintPreviewDialog class members, see the C1PrintPreviewDialog Members topic.

Public Properties

AccessibilityObject (inherited from Control) | The accessibility object for this control.
AccessibleDefaultActionDescription (inherited from Control) | The default action description of the control.
ActiveControl (inherited from ContainerControl) | The currently active control.
ActiveMdiChild (inherited from Form) | The currently active MDI child form.
AllowTransparency (inherited from Form) | Indicates whether the opacity of the control can be adjusted.
AutoScaleMode (inherited from ContainerControl) | Determines how the form or control will scale when screen resolution or fonts change.
AutoScrollPosition (inherited from ScrollableControl) | The current position of the auto-scrolling scroll bar.
AutoSizeMode (inherited from Form) | Specifies the mode by which the user interface element automatically resizes itself.
AvailablePreviewActions | Gets or sets flags indicating which tools should be available in the preview.
BindingContext (inherited from ContainerControl) | The binding manager for the container control. This manages all bindings of child controls to lists.
Bottom (inherited from Control) | The bottom of the control, in container coordinates.
Bounds (inherited from Control) | The bounds of the control, in container coordinates.
CanFocus (inherited from Control) | Checks if this control can receive the focus.
CanSelect (inherited from Control) | Checks if this control can be selected.
Capture (inherited from Control) | Determines if this control is currently capturing all mouse input.
ClientRectangle (inherited from Control) | Retrieves the rectangle of the inner area of this control.
CompanyName (inherited from Control) | ControlCompanyNameDescr
ContainsFocus (inherited from Control) | Determines if this control or one if its children currently has the focus.
ControlBox (inherited from Form) | Determines whether a form has a Control/System menu box.
Created (inherited from Control) | Determines if the control has been fully created.
DesktopBounds (inherited from Form) | The bounds of this form in desktop coordinates.
DesktopLocation (inherited from Form) | The location of this form in desktop coordinates.
DialogResult (inherited from Form) | The value this form will return if displayed as a dialog box.
Disposing (inherited from Control) | Determines whether this control is in the process of being disposed.
Document | Gets or sets the document shown by the dialog.
Focused (inherited from Control) | Determines if this control has focus.
Handle (inherited from Control) | The native handle for this control.
HasChildren (inherited from Control) | Indicates whether the control contains one or more child controls.
Height (inherited from Control) | The height of the user interface element, in pixels.
HelpButton (inherited from Form) | Determines whether a form has a Help button on the caption bar.
HorizontalScroll (inherited from ScrollableControl) | Gets the horizontal scroll bar for this ScrollableControl.
Icon (inherited from Form) | Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.
InvokeRequired (inherited from Control) | Determines if Invoke or BeginInvoke should be used to access this control cross-thread.
IsAccessible (inherited from Control) | Indicates whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Determines if this control has been disposed.
IsHandleCreated (inherited from Control) | Indicates whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Determines whether the form is a child of a MDI container.
IsMirrored (inherited from Control) | Indicates whether the control is mirrored.
Left (inherited from Control) | The upper left of the control, in container coordinates.
MainMenuStrip (inherited from Form) | Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.
MaximizeBox (inherited from Form) | Determines whether a form has a maximize box in the upper-right corner of its caption bar.
MaximumSize (inherited from Form) | The maximum size the form can be resized to.
MdiChildren (inherited from Form) | Retrieves the MDI children of this form.
MdiParent (inherited from Form) | Retrieves the MDI parent of this form.
MergedMenu (inherited from Form) | The merged menu of this form, which is used when displaying a single merged MDI menu.
MinimizeBox (inherited from Form) | Determines whether a form has a minimize box in the upper-right corner of its caption bar.
Modal (inherited from Form) | Indicates if this form is currently being displayed as a modal dialog box.
NavigationPanelVisible | Gets or sets the value indicating whether the navigation panel should be visible.
Opacity | Overridden. Do not use.
OwnedForms (inherited from Form) | Array of forms owned by this form.
Owner (inherited from Form) | The owner of this form.
Parent (inherited from Control) | The parent of this control.
ParentForm (inherited from ContainerControl) | The parent form of this container control.
PreviewOutlineView | Gets the preview outline tspanel.
PreviewPane | Gets the preview pane.
PreviewProgressBar | Gets the preview progress bar.
PreviewStatusText | Gets the preview progress bar.
PreviewTextSearchPanel | Gets the preview text search tspanel.
PreviewThumbnailView | Gets the preview thumbnails tspanel.
PrintPreviewControl | Gets the C1PrintPreviewControl shown by the current print preview dialog.
ProductName (inherited from Control) | Retrieves the name of the product associated with this component.
ProductVersion (inherited from Control) | Retrieves the version of the product associated with this component.
RecreatingHandle (inherited from Control) | Determines if this control is in the process of recreating its handle.
Region (inherited from Control) | The region, or shape, of this control.
Right (inherited from Control) | The distance, in pixels, between the right edge of the control and the left edge of its container's client area.
ShowIcon (inherited from Form) | Indicates whether an icon is displayed in the title bar of the form.
ShowInTaskbar (inherited from Form) | Determines whether the form appears in the Windows Taskbar.
StartPosition (inherited from Form) | Determines the position of a form when it first appears.
StatusBarVisible | Gets or sets the value indicating whether the status bar should be visible.
Tag (inherited from Control) | User-defined data associated with the object.
Top (inherited from Control) | The top of the control, in container coordinates.
TopLevelControl (inherited from Control) | Retrieves the top-level control that contains this control.
TopMost (inherited from Form) | Indicates whether the form always appears above all other forms that do not have this property set to True.
VerticalScroll (inherited from ScrollableControl) | Gets the vertical scroll bar for this ScrollableControl.
Width (inherited from Control) | The width of the control, in container coordinates.
WindowState (inherited from Form) | Determines the initial visual state of the form.


C1PrintPreviewDialog.AvailablePreviewActions Property

C1PrintPreviewDialog.AvailablePreviewActions Property

Gets or sets flags indicating which tools should be available in the preview.

[Visual Basic]

Public Property AvailablePreviewActions As C1PreviewActionFlags

[C#]

public C1PreviewActionFlags AvailablePreviewActions {get;set;}

[Delphi]

public property AvailablePreviewActions: C1PreviewActionFlags read get_AvailablePreviewActions write set_AvailablePreviewActions;


C1PrintPreviewDialog.Document Property

C1PrintPreviewDialog.Document Property

Gets or sets the document shown by the dialog.

[Visual Basic]

Public Property Document As Object

[C#]

public object Document {get;set;}

[Delphi]

public property Document: Object read get_Document write set_Document;


C1PrintPreviewDialog.NavigationPanelVisible Property

C1PrintPreviewDialog.NavigationPanelVisible Property

Gets or sets the value indicating whether the navigation panel should be visible.

[Visual Basic]

Public Property NavigationPanelVisible As Boolean

[C#]

public bool NavigationPanelVisible {get;set;}

[Delphi]

public property NavigationPanelVisible: Boolean read get_NavigationPanelVisible write set_NavigationPanelVisible;


C1PrintPreviewDialog.Opacity Property

C1PrintPreviewDialog.Opacity Property

Overridden. Do not use.

[Visual Basic]

Public Property Opacity As Double

[C#]

new public double Opacity {get;set;}

[Delphi]

public property Opacity: Double read get_Opacity write set_Opacity;


C1PrintPreviewDialog.PreviewOutlineView Property

C1PrintPreviewDialog.PreviewOutlineView Property

Gets the preview outline tspanel.

[Visual Basic]

Public ReadOnly Property PreviewOutlineView As C1PreviewOutlineView

[C#]

public C1PreviewOutlineView PreviewOutlineView {get;}

[Delphi]

public property PreviewOutlineView: C1PreviewOutlineView read get_PreviewOutlineView;


C1PrintPreviewDialog.PreviewPane Property

C1PrintPreviewDialog.PreviewPane Property

Gets the preview pane.

[Visual Basic]

Public ReadOnly Property PreviewPane As C1PreviewPane

[C#]

public C1PreviewPane PreviewPane {get;}

[Delphi]

public property PreviewPane: C1PreviewPane read get_PreviewPane;


C1PrintPreviewDialog.PreviewProgressBar Property

C1PrintPreviewDialog.PreviewProgressBar Property

Gets the preview progress bar.

[Visual Basic]

Public ReadOnly Property PreviewProgressBar As ToolStripProgressBar

[C#]

public ToolStripProgressBar PreviewProgressBar {get;}

[Delphi]

public property PreviewProgressBar: ToolStripProgressBar read get_PreviewProgressBar;


C1PrintPreviewDialog.PreviewStatusText Property

C1PrintPreviewDialog.PreviewStatusText Property

Gets the preview progress bar.

[Visual Basic]

Public ReadOnly Property PreviewStatusText As ToolStripStatusLabel

[C#]

public ToolStripStatusLabel PreviewStatusText {get;}

[Delphi]

public property PreviewStatusText: ToolStripStatusLabel read get_PreviewStatusText;


C1PrintPreviewDialog.PreviewTextSearchPanel Property

C1PrintPreviewDialog.PreviewTextSearchPanel Property

Gets the preview text search tspanel.

[Visual Basic]

Public ReadOnly Property PreviewTextSearchPanel As C1PreviewTextSearchPanel

[C#]

public C1PreviewTextSearchPanel PreviewTextSearchPanel {get;}

[Delphi]

public property PreviewTextSearchPanel: C1PreviewTextSearchPanel read get_PreviewTextSearchPanel;


C1PrintPreviewDialog.PreviewThumbnailView Property

C1PrintPreviewDialog.PreviewThumbnailView Property

Gets the preview thumbnails tspanel.

[Visual Basic]

Public ReadOnly Property PreviewThumbnailView As C1PreviewThumbnailView

[C#]

public C1PreviewThumbnailView PreviewThumbnailView {get;}

[Delphi]

public property PreviewThumbnailView: C1PreviewThumbnailView read get_PreviewThumbnailView;


C1PrintPreviewDialog.PrintPreviewControl Property

C1PrintPreviewDialog.PrintPreviewControl Property

Gets the C1PrintPreviewControl shown by the current print preview dialog.

[Visual Basic]

Public ReadOnly Property PrintPreviewControl As C1PrintPreviewControl

[C#]

public C1PrintPreviewControl PrintPreviewControl {get;}

[Delphi]

public property PrintPreviewControl: C1PrintPreviewControl read get_PrintPreviewControl;


C1PrintPreviewDialog.StatusBarVisible Property

C1PrintPreviewDialog.StatusBarVisible Property

Gets or sets the value indicating whether the status bar should be visible.

[Visual Basic]

Public Property StatusBarVisible As Boolean

[C#]

public bool StatusBarVisible {get;set;}

[Delphi]

public property StatusBarVisible: Boolean read get_StatusBarVisible write set_StatusBarVisible;


C1PrintPreviewDialog Events

C1PrintPreviewDialog Events

The events of the C1PrintPreviewDialog class are listed here. For a complete list of C1PrintPreviewDialog class members, see the C1PrintPreviewDialog Members topic.

Public Events

Activated (inherited from Form) | Occurs whenever the form is activated.
BindingContextChanged (inherited from Control) | Event raised when the value of the BindingContext property is changed on Control.
ChangeUICues (inherited from Control) | Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.
Click (inherited from Control) | Occurs when the component is clicked.
ClientSizeChanged (inherited from Control) | Event raised when the value of the ClientSize property is changed on Control.
ControlAdded (inherited from Control) | Occurs when a control is added to this control.
ControlRemoved (inherited from Control) | Occurs when a control is removed from this control.
Deactivate (inherited from Form) | Occurs whenever the form is deactivated.
DoubleClick (inherited from Control) | Occurs when the component is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when the mouse drags an item into the client area for this Control.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
Enter (inherited from Control) | Occurs when the control becomes the active control of the form.
FormClosed (inherited from Form) | Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.
FormClosing (inherited from Form) | Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.
GiveFeedback (inherited from Control) | Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.
GotFocus (inherited from Control) | Occurs when the control gets focus.
HandleCreated (inherited from Control) | Occurs when the control's native handle is created.
HandleDestroyed (inherited from Control) | Occurs when the control's native handle is destroyed.
HelpButtonClicked (inherited from Form) | Event raised when the help button is clicked.
HelpRequested (inherited from Control) | Occurs when the user invokes Help for the control.
InputLanguageChanged (inherited from Form) | Occurs whenever the language used for input for this form changes.
InputLanguageChanging (inherited from Form) | A request by the system to change the input language for this form. This request can be refused.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is first pressed.
KeyPress (inherited from Control) | Occurs when the control has focus and the user presses and releases a key.
KeyUp (inherited from Control) | Occurs when a key is released.
Layout (inherited from Control) | Occurs when the control is about to lay out its contents.
Leave (inherited from Control) | Occurs when the control is no longer the active control of the form.
Load (inherited from Form) | Occurs whenever the user loads the form.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Event raised when the value of the MaximizedBounds property is changed on Form.
MdiChildActivate (inherited from Form) | Occurs when an MDI Child window is activated.
MenuComplete (inherited from Form) | Occurs when menu selection is completed and menu modal message loop has exited.
MenuStart (inherited from Form) | Occurs when any menu is displayed and menu modal message loop is entered.
MouseCaptureChanged (inherited from Control) | Occurs after the mouse capture is changed.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse enters the visible part of the control.
MouseHover (inherited from Control) | Occurs when the mouse remains stationary inside of the control for an amount of time.
MouseLeave (inherited from Control) | Occurs when the mouse leaves the visible part of the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the component.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the component and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when a control is moved.
Paint (inherited from Control) | Occurs when a control needs repainting.
ParentChanged (inherited from Control) | Event raised when the value of the Parent property is changed on Control.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when an Accessibility client invokes Help for the control.
QueryContinueDrag (inherited from Control) | Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.
RegionChanged (inherited from Control) | Event raised when the value of Region property is changed on Control.
Resize (inherited from Control) | Occurs when a control is resized.
ResizeBegin (inherited from Form) | Occurs when the form enters the sizing modal loop.
ResizeEnd (inherited from Form) | Occurs when the control exits the sizing modal loop.
Scroll (inherited from ScrollableControl) | Occurs when the user moves the scroll box.
Shown (inherited from Form) | Occurs whenever the form is first shown.
StyleChanged (inherited from Control) | Event raised when the window style of a Control is changed.
SystemColorsChanged (inherited from Control) | Event raised when the system colors change.
TextChanged (inherited from Control) | Event raised when the value of the Text property is changed on Control.
Validated (inherited from Control) | Occurs after a control has been successfully validated.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the control's visibility changes.


DocumentActionEventArgs Class

DocumentActionEventArgs Class

Provides data for the PreviewAction event.

For a list of all members of this type, see DocumentActionEventArgs Members.

System.Object

System.EventArgs

C1.Win.C1Preview.DocumentActionEventArgs

[Visual Basic]

Public Class DocumentActionEventArgs

Inherits EventArgs

[C#]

public class DocumentActionEventArgs : EventArgs

[Delphi]

type DocumentActionEventArgs = class (EventArgs);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


DocumentActionEventArgs Members

DocumentActionEventArgs Members

DocumentActionEventArgs overview

Public Properties

ActionHandler | Gets the ActionHandlerBase object to execute.
Handled | Gets or sets a value that indicates whether the event handler has completely handled the event or whether the preview pane should continue its own processing.


DocumentActionEventArgs Properties

DocumentActionEventArgs Properties

The properties of the DocumentActionEventArgs class are listed here. For a complete list of DocumentActionEventArgs class members, see the DocumentActionEventArgs Members topic.

Public Properties

ActionHandler | Gets the ActionHandlerBase object to execute.
Handled | Gets or sets a value that indicates whether the event handler has completely handled the event or whether the preview pane should continue its own processing.


DocumentActionEventArgs.ActionHandler Property

DocumentActionEventArgs.ActionHandler Property

Gets the ActionHandlerBase object to execute.

[Visual Basic]

Public ReadOnly Property ActionHandler As ActionHandlerBase

[C#]

public ActionHandlerBase ActionHandler {get;}

[Delphi]

public property ActionHandler: ActionHandlerBase read get_ActionHandler;


DocumentActionEventArgs.Handled Property

DocumentActionEventArgs.Handled Property

Gets or sets a value that indicates whether the event handler has completely handled the event or whether the preview pane should continue its own processing.

[Visual Basic]

Public Property Handled As Boolean

[C#]

public bool Handled {get;set;}

[Delphi]

public property Handled: Boolean read get_Handled write set_Handled;


ExporterOptions Class

ExporterOptions Class

Represents the options of separate exporter, the ExportOptions class contains the list of such objects.

For a list of all members of this type, see ExporterOptions Members.

System.Object

C1.Win.C1Preview.ExporterOptions

[Visual Basic]

Public Class ExporterOptions

[C#]

public class ExporterOptions

[Delphi]

type ExporterOptions = class;

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


ExporterOptions Members

ExporterOptions Members

ExporterOptions overview

Public Properties

Enabled | Indicates whether the exporter appears in the default FileSave dialog of C1PrintPreview.
ExportProvider | Gets the ExportProvider object.
OptionsDialogClassName | Gets or sets the class name of the export options dialog form.
Preview | Gets or sets the value of Preview property of exporter.
ShowOptions | Gets or sets the value indicating whether to show the options dialog before export.


ExporterOptions Properties

ExporterOptions Properties

The properties of the ExporterOptions class are listed here. For a complete list of ExporterOptions class members, see the ExporterOptions Members topic.

Public Properties

Enabled | Indicates whether the exporter appears in the default FileSave dialog of C1PrintPreview.
ExportProvider | Gets the ExportProvider object.
OptionsDialogClassName | Gets or sets the class name of the export options dialog form.
Preview | Gets or sets the value of Preview property of exporter.
ShowOptions | Gets or sets the value indicating whether to show the options dialog before export.


ExporterOptions.Enabled Property

ExporterOptions.Enabled Property

Indicates whether the exporter appears in the default FileSave dialog of C1PrintPreview.

[Visual Basic]

Public Property Enabled As Boolean

[C#]

public bool Enabled {get;set;}

[Delphi]

public property Enabled: Boolean read get_Enabled write set_Enabled;


ExporterOptions.ExportProvider Property

ExporterOptions.ExportProvider Property

Gets the ExportProvider object.

[Visual Basic]

Public ReadOnly Property ExportProvider As ExportProvider

[C#]

public ExportProvider ExportProvider {get;}

[Delphi]

public property ExportProvider: ExportProvider read get_ExportProvider;


ExporterOptions.OptionsDialogClassName Property

ExporterOptions.OptionsDialogClassName Property

Gets or sets the class name of the export options dialog form.

[Visual Basic]

Public Property OptionsDialogClassName As String

[C#]

public string OptionsDialogClassName {get;set;}

[Delphi]

public property OptionsDialogClassName: String read get_OptionsDialogClassName write set_OptionsDialogClassName;


ExporterOptions.Preview Property

ExporterOptions.Preview Property

Gets or sets the value of Preview property of exporter.

[Visual Basic]

Public Property Preview As Boolean

[C#]

public bool Preview {get;set;}

[Delphi]

public property Preview: Boolean read get_Preview write set_Preview;


ExporterOptions.ShowOptions Property

ExporterOptions.ShowOptions Property

Gets or sets the value indicating whether to show the options dialog before export.

[Visual Basic]

Public Property ShowOptions As Boolean

[C#]

public bool ShowOptions {get;set;}

[Delphi]

public property ShowOptions: Boolean read get_ShowOptions write set_ShowOptions;


FormsUserActionEventArgs Class

FormsUserActionEventArgs Class

Provides data for the FormsUserAction event.

For a list of all members of this type, see FormsUserActionEventArgs Members.

System.Object

System.EventArgs

C1.Win.C1Preview.FormsUserActionEventArgs

[Visual Basic]

Public Class FormsUserActionEventArgs

Inherits EventArgs

[C#]

public class FormsUserActionEventArgs : EventArgs

[Delphi]

type FormsUserActionEventArgs = class (EventArgs);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


FormsUserActionEventArgs Members

FormsUserActionEventArgs Members

FormsUserActionEventArgs overview

Public Properties

Handled | Gets or sets the value indicating whether the default handling of the user action should take place. Set this property to True to cancel the default handling.
InputAction | Gets the InputAction object that will handle the user action by default. This parameter can be null if no action is associated with the specified user action.
RenderObject | Gets the RenderInputBase object corresponding to the input control which causes an event.
UserAction | Gets the user action (Click, MouseDown, MouseUp, and so on.).


FormsUserActionEventArgs Properties

FormsUserActionEventArgs Properties

The properties of the FormsUserActionEventArgs class are listed here. For a complete list of FormsUserActionEventArgs class members, see the FormsUserActionEventArgs Members topic.

Public Properties

Handled | Gets or sets the value indicating whether the default handling of the user action should take place. Set this property to True to cancel the default handling.
InputAction | Gets the InputAction object that will handle the user action by default. This parameter can be null if no action is associated with the specified user action.
RenderObject | Gets the RenderInputBase object corresponding to the input control which causes an event.
UserAction | Gets the user action (Click, MouseDown, MouseUp, and so on.).


FormsUserActionEventArgs.Handled Property

FormsUserActionEventArgs.Handled Property

Gets or sets the value indicating whether the default handling of the user action should take place. Set this property to True to cancel the default handling.

[Visual Basic]

Public Property Handled As Boolean

[C#]

public bool Handled {get;set;}

[Delphi]

public property Handled: Boolean read get_Handled write set_Handled;


FormsUserActionEventArgs.InputAction Property

FormsUserActionEventArgs.InputAction Property

Gets the InputAction object that will handle the user action by default. This parameter can be null if no action is associated with the specified user action.

[Visual Basic]

Public ReadOnly Property InputAction As InputAction

[C#]

public InputAction InputAction {get;}

[Delphi]

public property InputAction: InputAction read get_InputAction;


FormsUserActionEventArgs.RenderObject Property

FormsUserActionEventArgs.RenderObject Property

Gets the RenderInputBase object corresponding to the input control which causes an event.

[Visual Basic]

Public ReadOnly Property RenderObject As RenderInputBase

[C#]

public RenderInputBase RenderObject {get;}

[Delphi]

public property RenderObject: RenderInputBase read get_RenderObject;


FormsUserActionEventArgs.UserAction Property

FormsUserActionEventArgs.UserAction Property

Gets the user action (Click, MouseDown, MouseUp, and so on).

[Visual Basic]

Public ReadOnly Property UserAction As UserActionEnum

[C#]

public UserActionEnum UserAction {get;}

[Delphi]

public property UserAction: UserActionEnum read get_UserAction;


HideMarginsFlags Enumeration

HideMarginsFlags Enumeration

Describes page margins hide/show modes (when the mouse is over the margins area).

[Visual Basic]

Public Enum HideMarginsFlags

[C#]

public enum HideMarginsFlags

[Delphi]

type HideMarginsFlags = (All, Horizontal, None, Vertical);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)

Members

Member name | Description
All |
Horizontal |
None |
Vertical |

See Also

C1.Win.C1Preview Namespace


HistoryItemAddingEventArgs Class

HistoryItemAddingEventArgs Class

Contains the data for HistoryItemAdding event of C1PreviewPane.

For a list of all members of this type, see HistoryItemAddingEventArgs Members.

System.Object

System.EventArgs

System.ComponentModel.CancelEventArgs

C1.Win.C1Preview.HistoryItemAddingEventArgs

[Visual Basic]

Public Class HistoryItemAddingEventArgs

Inherits CancelEventArgs

[C#]

public class HistoryItemAddingEventArgs : CancelEventArgs

[Delphi]

type HistoryItemAddingEventArgs = class (CancelEventArgs);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


HistoryItemAddingEventArgs Members

HistoryItemAddingEventArgs Members

HistoryItemAddingEventArgs overview

Public Properties

HistoryItem

The adding ViewHistoryItem object.


HistoryItemAddingEventArgs Properties

HistoryItemAddingEventArgs Properties

The properties of the HistoryItemAddingEventArgs class are listed here. For a complete list of HistoryItemAddingEventArgs class members, see the HistoryItemAddingEventArgs Members topic.

Public Properties

HistoryItem

The adding ViewHistoryItem object.


HistoryItemAddingEventArgs.HistoryItem Property

HistoryItemAddingEventArgs.HistoryItem Property

The adding ViewHistoryItem object.

[Visual Basic]

Public ReadOnly Property HistoryItem As ViewHistoryItem

[C#]

public ViewHistoryItem HistoryItem {get;}

[Delphi]

public property HistoryItem: ViewHistoryItem read get_HistoryItem;


HistoryItemAddingEventHandler Delegate

HistoryItemAddingEventHandler Delegate

Represents the method that will handle an event occuring when new item adding to the ViewHistory collection.

[Visual Basic]

Public Delegate Sub HistoryItemAddingEventHandler( _

ByVal sender As Object, _

ByVal e As HistoryItemAddingEventArgs _

)

[C#]

public delegate void HistoryItemAddingEventHandler(

object sender,

HistoryItemAddingEventArgs e

);

[Delphi]

type HistoryItemAddingEventHandler = procedure (

sender: Object;

e: HistoryItemAddingEventArgs

) of object;

Parameters

sender

e

The HistoryItemAddingEventArgs object containing the event data.

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)

See Also

C1.Win.C1Preview Namespace


HistoryOptions Class

HistoryOptions Class

Contains options for the preview history.

For a list of all members of this type, see HistoryOptions Members.

System.Object

C1.Win.C1Preview.HistoryOptions

[Visual Basic]

Public Class HistoryOptions

Implements INotifyPropertyChanged

[C#]

public class HistoryOptions : INotifyPropertyChanged

[Delphi]

type HistoryOptions = class (TObject, INotifyPropertyChanged);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


HistoryOptions Members

HistoryOptions Members

HistoryOptions overview

Public Properties

MaxHistoryLength | Gets or sets the maximum number of items stored in the preview history.
MaxVisitedDocuments | Gets or sets the maximum number of stored visited documents.
SavedActions | Gets or sets the value indicating which kinds of actions are saved in the preview history.
VisitedDocumentStorage | Gets or sets the value indicating how to store documents in the preview history.

Public Events

PropertyChanged

Occurs then value of any property of HistoryOptions is changed.


HistoryOptions Properties

HistoryOptions Properties

The properties of the HistoryOptions class are listed here. For a complete list of HistoryOptions class members, see the HistoryOptions Members topic.

Public Properties

MaxHistoryLength | Gets or sets the maximum number of items stored in the preview history.
MaxVisitedDocuments | Gets or sets the maximum number of stored visited documents.
SavedActions | Gets or sets the value indicating which kinds of actions are saved in the preview history.
VisitedDocumentStorage | Gets or sets the value indicating how to store documents in the preview history.


HistoryOptions.MaxHistoryLength Property

HistoryOptions.MaxHistoryLength Property

Gets or sets the maximum number of items stored in the preview history.

[Visual Basic]

Public Property MaxHistoryLength As Int32*

[C#]

public Int32* MaxHistoryLength {get;set;}

[Delphi]

public property MaxHistoryLength: Int32* read get_MaxHistoryLength write set_MaxHistoryLength;


HistoryOptions.MaxVisitedDocuments Property

HistoryOptions.MaxVisitedDocuments Property

Gets or sets the maximum number of stored visited documents.

[Visual Basic]

Public Property MaxVisitedDocuments As Int32*

[C#]

public Int32* MaxVisitedDocuments {get;set;}

[Delphi]

public property MaxVisitedDocuments: Int32* read get_MaxVisitedDocuments write set_MaxVisitedDocuments;


HistoryOptions.SavedActions Property

HistoryOptions.SavedActions Property

Gets or sets the value indicating which kinds of actions are saved in the preview history.

[Visual Basic]

Public Property SavedActions As HistorySavedActionsEnum

[C#]

public HistorySavedActionsEnum SavedActions {get;set;}

[Delphi]

public property SavedActions: HistorySavedActionsEnum read get_SavedActions write set_SavedActions;


HistoryOptions.VisitedDocumentStorage Property

HistoryOptions.VisitedDocumentStorage Property

Gets or sets the value indicating how to store documents in the preview history.

[Visual Basic]

Public Property VisitedDocumentStorage As VisitedDocumentStorageEnum

[C#]

public VisitedDocumentStorageEnum VisitedDocumentStorage {get;set;}

[Delphi]

public property VisitedDocumentStorage: VisitedDocumentStorageEnum read get_VisitedDocumentStorage write set_VisitedDocumentStorage;


HistoryOptions Events

HistoryOptions Events

The events of the HistoryOptions class are listed here. For a complete list of HistoryOptions class members, see the HistoryOptions Members topic.

Public Events

PropertyChanged

Occurs then value of any property of HistoryOptions is changed.


HistoryOptions.PropertyChanged Event

HistoryOptions.PropertyChanged Event

Occurs then value of any property of HistoryOptions is changed.

[Visual Basic]

Public Event PropertyChanged As PropertyChangedEventHandler

[C#]

public event PropertyChangedEventHandlerPropertyChanged

[Delphi]

public property PropertyChanged: PropertyChangedEventHandler read remove_PropertyChanged write add_PropertyChanged;


HistorySavedActionsEnum Enumeration

HistorySavedActionsEnum Enumeration

Defines the user actions which can be saved in the preview history.

[Visual Basic]

Public Enum HistorySavedActionsEnum

[C#]

public enum HistorySavedActionsEnum

[Delphi]

type HistorySavedActionsEnum = (All, Cols, Continuous, DocumentAction, DocumentChangedAction, DocumentChangeMargins, DocumentChangePageSettings, DocumentOpen, DocumentReflow, DpiX, DpiY, HideMarginsState, HyperlinkJump, Layout, Location, None, PageLayout, PrinterSettings, PrintingLayout, Rows, Scroll, ShowPrintableArea, ShowRulers, StartPageChange, TextSearch, Zoom, ZoomFactor, ZoomMode);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)

Members

Member name | Description
All |
Cols |
Continuous |
DocumentAction |
DocumentChangedAction |
DocumentChangeMargins |
DocumentChangePageSettings |
DocumentOpen |
DocumentReflow |
DpiX |
DpiY |
HideMarginsState |
HyperlinkJump |
Layout |
Location |
None |
PageLayout |
PrinterSettings |
PrintingLayout |
Rows |
Scroll |
ShowPrintableArea |
ShowRulers |
StartPageChange |
TextSearch |
Zoom |
ZoomFactor |
ZoomMode |

See Also

C1.Win.C1Preview Namespace


HyperlinkEventArgs Class

HyperlinkEventArgs Class

Provides a data for HyperlinkLeave and HyperlinkEnter events of C1PreviewPane.

For a list of all members of this type, see HyperlinkEventArgs Members.

System.Object

System.EventArgs

C1.Win.C1Preview.HyperlinkEventArgs

C1.Win.C1Preview.HyperlinkJumpEventArgs

[Visual Basic]

Public Class HyperlinkEventArgs

Inherits EventArgs

[C#]

public class HyperlinkEventArgs : EventArgs

[Delphi]

type HyperlinkEventArgs = class (EventArgs);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


HyperlinkEventArgs Members

HyperlinkEventArgs Members

HyperlinkEventArgs overview

Public Properties

Hyperlink

Gets the hyperlink causing an event.


HyperlinkEventArgs Properties

HyperlinkEventArgs Properties

The properties of the HyperlinkEventArgs class are listed here. For a complete list of HyperlinkEventArgs class members, see the HyperlinkEventArgs Members topic.

Public Properties

Hyperlink

Gets the hyperlink causing an event.


HyperlinkEventArgs.Hyperlink Property

HyperlinkEventArgs.Hyperlink Property

Gets the hyperlink causing an event.

[Visual Basic]

Public ReadOnly Property Hyperlink As C1Hyperlink

[C#]

public C1Hyperlink Hyperlink {get;}

[Delphi]

public property Hyperlink: C1Hyperlink read get_Hyperlink;


HyperlinkJumpEventArgs Class

HyperlinkJumpEventArgs Class

Provides a data for HyperlinkJump events of C1PreviewPane.

For a list of all members of this type, see HyperlinkJumpEventArgs Members.

System.Object

System.EventArgs

C1.Win.C1Preview.HyperlinkEventArgs

C1.Win.C1Preview.HyperlinkJumpEventArgs

[Visual Basic]

Public Class HyperlinkJumpEventArgs

Inherits HyperlinkEventArgs

[C#]

public class HyperlinkJumpEventArgs : HyperlinkEventArgs

[Delphi]

type HyperlinkJumpEventArgs = class (HyperlinkEventArgs);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


HyperlinkJumpEventArgs Members

HyperlinkJumpEventArgs Members

HyperlinkJumpEventArgs overview

Public Properties

Cancel | Gets or sets a value indicating whether the hyperlink jump should be canceled.
Hyperlink (inherited from HyperlinkEventArgs) | Gets the hyperlink causing an event.


HyperlinkJumpEventArgs Properties

HyperlinkJumpEventArgs Properties

The properties of the HyperlinkJumpEventArgs class are listed here. For a complete list of HyperlinkJumpEventArgs class members, see the HyperlinkJumpEventArgs Members topic.

Public Properties

Cancel | Gets or sets a value indicating whether the hyperlink jump should be canceled.
Hyperlink (inherited from HyperlinkEventArgs) | Gets the hyperlink causing an event.


HyperlinkJumpEventArgs.Cancel Property

HyperlinkJumpEventArgs.Cancel Property

Gets or sets a value indicating whether the hyperlink jump should be canceled.

[Visual Basic]

Public Property Cancel As Boolean

[C#]

public bool Cancel {get;set;}

[Delphi]

public property Cancel: Boolean read get_Cancel write set_Cancel;


HyperlinkMouseEventArgs Class

HyperlinkMouseEventArgs Class

Provides a data for HyperlinkMouseMove, HyperlinkMouseDown and HyperlinkMouseUp events of C1PreviewPane.

For a list of all members of this type, see HyperlinkMouseEventArgs Members.

System.Object

System.EventArgs

System.Windows.Forms.MouseEventArgs

C1.Win.C1Preview.HyperlinkMouseEventArgs

[Visual Basic]

Public Class HyperlinkMouseEventArgs

Inherits MouseEventArgs

[C#]

public class HyperlinkMouseEventArgs : MouseEventArgs

[Delphi]

type HyperlinkMouseEventArgs = class (MouseEventArgs);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


HyperlinkMouseEventArgs Members

HyperlinkMouseEventArgs Members

HyperlinkMouseEventArgs overview

Public Properties

Hyperlink

Gets the hyperlink causing an event.


HyperlinkMouseEventArgs Properties

HyperlinkMouseEventArgs Properties

The properties of the HyperlinkMouseEventArgs class are listed here. For a complete list of HyperlinkMouseEventArgs class members, see the HyperlinkMouseEventArgs Members topic.

Public Properties

Hyperlink

Gets the hyperlink causing an event.


HyperlinkMouseEventArgs.Hyperlink Property

HyperlinkMouseEventArgs.Hyperlink Property

Gets the hyperlink causing an event.

[Visual Basic]

Public ReadOnly Property Hyperlink As C1Hyperlink

[C#]

public C1Hyperlink Hyperlink {get;}

[Delphi]

public property Hyperlink: C1Hyperlink read get_Hyperlink;


ImageSetEnum Enumeration

ImageSetEnum Enumeration

Describes the image set used for toolbar images of the preview actions.

[Visual Basic]

Public Enum ImageSetEnum

[C#]

public enum ImageSetEnum

[Delphi]

type ImageSetEnum = (Adobe, Classic, Original, OsX, XP, XP2, XP3);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)

Members

Member name | Description
Adobe |
Classic |
Original |
OsX |
XP |
XP2 |
XP3 |

See Also

C1.Win.C1Preview Namespace


KeyMap Class

KeyMap Class

Represents a keymap used to map keystrokes to actions.

For a list of all members of this type, see KeyMap Members.

System.Object

System.Collections.Hashtable

C1.Win.C1Preview.KeyMap

[Visual Basic]

Public Class KeyMap

Inherits Hashtable

[C#]

public class KeyMap : Hashtable

[Delphi]

type KeyMap = class (Hashtable);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


KeyMap Members

KeyMap Members

KeyMap overview

Public Properties

Tag

Gets or sets user data associated with the keymap.

Public Methods

CanHandle | Tests whether the current keymap can handle the keystroke.
ClearHandler | Removes the handler for the specified keystroke from the keymap.
HandleKey | Invokes the handler for the specified keystroke.


KeyMap Properties

KeyMap Properties

The properties of the KeyMap class are listed here. For a complete list of KeyMap class members, see the KeyMap Members topic.

Public Properties

Tag

Gets or sets user data associated with the keymap.


KeyMap.Tag Property

KeyMap.Tag Property

Gets or sets user data associated with the keymap.

[Visual Basic]

Public Property Tag As Object

[C#]

public object Tag {get;set;}

[Delphi]

public property Tag: Object read get_Tag write set_Tag;


KeyMap Methods

KeyMap Methods

The methods of the KeyMap class are listed here. For a complete list of KeyMap class members, see the KeyMap Members topic.

Public Methods

CanHandle | Tests whether the current keymap can handle the keystroke.
ClearHandler | Removes the handler for the specified keystroke from the keymap.
HandleKey | Invokes the handler for the specified keystroke.


KeyMap.CanHandle Method

KeyMap.CanHandle Method

Tests whether the current keymap can handle the keystroke.

[Visual Basic]

Public Function CanHandle( _

ByVal keyData As Keys _

) As Boolean

[C#]

public bool CanHandle(

Keys keyData

);

[Delphi]

public function CanHandle(

keyData: Keys

): Boolean;

Parameters

keyData

The keystroke to test.

Return Value

True if the current keymap contains a handler for the keystroke, False otherwise.


KeyMap.ClearHandler Method

KeyMap.ClearHandler Method

Removes the handler for the specified keystroke from the keymap.

[Visual Basic]

Public Sub ClearHandler( _

ByVal keyData As Keys _

)

[C#]

public void ClearHandler(

Keys keyData

);

[Delphi]

public procedure ClearHandler(

keyData: Keys

);

Parameters

keyData

The keystroke to remove.


KeyMap.HandleKey Method

KeyMap.HandleKey Method

Invokes the handler for the specified keystroke.

[Visual Basic]

Public Function HandleKey( _

ByVal keyData As Keys _

) As Boolean

[C#]

public bool HandleKey(

Keys keyData

);

[Delphi]

public function HandleKey(

keyData: Keys

): Boolean;

Parameters

keyData

The keystroke to handle.

Return Value

The return value of the handler, False if it is not found.


KeyMap.DoAction Delegate

KeyMap.DoAction Delegate

Describes an action that can be mapped to a keystroke.

[Visual Basic]

Public Delegate Function KeyMap.DoAction() As Boolean

[C#]

public delegate bool KeyMap.DoAction()

[Delphi]

type KeyMap.DoAction = function (): Boolean of object;

Return Value

True to indicate that the expected action was taken, False otherwise.

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)

See Also

C1.Win.C1Preview Namespace


KeyMapStack Class

KeyMapStack Class

Represents a stack of keymaps used to handle keyboard.

For a list of all members of this type, see KeyMapStack Members.

System.Object

System.Collections.Generic.40513, Culture=neutral, PublicKeyToken=594a0605db190bb9]]

C1.Win.C1Preview.KeyMapStack

[Visual Basic]

Public Class KeyMapStack

Inherits 40513, Culture=neutral, PublicKeyToken=594a0605db190bb9]](Of eo+b)

[C#]

public class KeyMapStack : 40513, Culture=neutral, PublicKeyToken=594a0605db190bb9]]<eo+b>

[Delphi]

type KeyMapStack = class (40513, Culture=neutral, PublicKeyToken=594a0605db190bb9]](Of eo+b));

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


KeyMapStack Members

KeyMapStack Members

KeyMapStack overview

Public Properties

IsEmpty

Gets the value indicating whether the stack is empty.

Public Methods

CanHandle | Overloaded. Tests whether the stack contains a keymap that can handle the keystroke.
FindByTag | Finds a keymap by its tag.
HandleKey | Handles a keystroke.
Pop | Pops the top keymap from the stack.
Push | Pushes a new keymap on the stack.
Top | Returns the top keymap.


KeyMapStack Properties

KeyMapStack Properties

The properties of the KeyMapStack class are listed here. For a complete list of KeyMapStack class members, see the KeyMapStack Members topic.

Public Properties

IsEmpty

Gets the value indicating whether the stack is empty.


KeyMapStack.IsEmpty Property

KeyMapStack.IsEmpty Property

Gets the value indicating whether the stack is empty.

[Visual Basic]

Public ReadOnly Property IsEmpty As Boolean

[C#]

public bool IsEmpty {get;}

[Delphi]

public property IsEmpty: Boolean read get_IsEmpty;


KeyMapStack Methods

KeyMapStack Methods

The methods of the KeyMapStack class are listed here. For a complete list of KeyMapStack class members, see the KeyMapStack Members topic.

Public Methods

CanHandle | Overloaded. Tests whether the stack contains a keymap that can handle the keystroke.
FindByTag | Finds a keymap by its tag.
HandleKey | Handles a keystroke.
Pop | Pops the top keymap from the stack.
Push | Pushes a new keymap on the stack.
Top | Returns the top keymap.


KeyMapStack.CanHandle Method

KeyMapStack.CanHandle Method

Overload List

Tests whether the stack contains a keymap that can handle the keystroke.

[Visual Basic] Overloads Public Function CanHandle(Keys) As Boolean

[C#] public bool CanHandle(Keys);

[Delphi] public function CanHandle(Keys) : Boolean; overload;

Tests whether the stack contains a keymap that can handle the keystroke.

[Visual Basic] Overloads Public Function CanHandle(Keys, ByRef KeyMap) As Boolean

[C#] public bool CanHandle(Keys, ref KeyMap);

[Delphi] public function CanHandle(Keys; out KeyMap) : Boolean; overload;


KeyMapStack.CanHandle Method (Keys)

KeyMapStack.CanHandle Method (Keys)

Previous Next

Tests whether the stack contains a keymap that can handle the keystroke.

[Visual Basic]

Overloads Public Function CanHandle( _

ByVal keyData As Keys _

) As Boolean

[C#]

public bool CanHandle(

Keys keyData

);

[Delphi]

public function CanHandle(

keyData: Keys

): Boolean; overload;

Parameters

keyData

The keystroke to test.

Return Value

True if a handler is found, False otherwise.


KeyMapStack.CanHandle Method (Keys, ByRef KeyMap)

KeyMapStack.CanHandle Method (Keys, ByRef KeyMap)

Previous Next

Tests whether the stack contains a keymap that can handle the keystroke.

[Visual Basic]

Overloads Public Function CanHandle( _

ByVal keyData As Keys, _

ByRef keyMap As KeyMap _

) As Boolean

[C#]

public bool CanHandle(

Keys keyData,

out KeyMap keyMap

);

[Delphi]

public function CanHandle(

keyData: Keys;

out keyMap: KeyMap

): Boolean; overload;

Parameters

keyData

The keystroke to test.

keyMap

The keymap that can handle the keystroke.

Return Value

True if a handler is found, False otherwise.


KeyMapStack.FindByTag Method

KeyMapStack.FindByTag Method

Finds a keymap by its tag.

[Visual Basic]

Public Function FindByTag( _

ByVal tag As Object _

) As KeyMap

[C#]

public KeyMap FindByTag(

object tag

);

[Delphi]

public function FindByTag(

tag: Object

): KeyMap;

Parameters

tag

The tag to search for.

Return Value

The keymap or null if none was found.


KeyMapStack.HandleKey Method

KeyMapStack.HandleKey Method

Handles a keystroke.

[Visual Basic]

Public Function HandleKey( _

ByVal keyData As Keys _

) As Boolean

[C#]

public bool HandleKey(

Keys keyData

);

[Delphi]

public function HandleKey(

keyData: Keys

): Boolean;

Parameters

keyData

The keystroke to handle.

Return Value

True if the keystroke was handled, False otherwise.


KeyMapStack.Pop Method

KeyMapStack.Pop Method

Pops the top keymap from the stack.

[Visual Basic]

Public Sub Pop()

[C#]

public void Pop()

[Delphi]

public procedure Pop();


KeyMapStack.Push Method

KeyMapStack.Push Method

Pushes a new keymap on the stack.

[Visual Basic]

Public Sub Push( _

ByVal keyMap As KeyMap _

)

[C#]

public void Push(

KeyMap keyMap

);

[Delphi]

public procedure Push(

keyMap: KeyMap

);

Parameters

keyMap

The keymap to push on the stack.


KeyMapStack.Top Method

KeyMapStack.Top Method

Returns the top keymap.

[Visual Basic]

Public Function Top() As KeyMap

[C#]

public KeyMap Top()

[Delphi]

public function Top(): KeyMap;

Return Value

The top keymap.


LoadVisitedDocumentEventArgs Class

LoadVisitedDocumentEventArgs Class

Contains the data for LoadVisitedDocument event of C1PreviewPane.

For a list of all members of this type, see LoadVisitedDocumentEventArgs Members.

System.Object

System.EventArgs

C1.Win.C1Preview.SaveVisitedDocumentEventArgs

C1.Win.C1Preview.LoadVisitedDocumentEventArgs

[Visual Basic]

Public Class LoadVisitedDocumentEventArgs

Inherits SaveVisitedDocumentEventArgs

[C#]

public class LoadVisitedDocumentEventArgs : SaveVisitedDocumentEventArgs

[Delphi]

type LoadVisitedDocumentEventArgs = class (SaveVisitedDocumentEventArgs);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


LoadVisitedDocumentEventArgs Members

LoadVisitedDocumentEventArgs Members

LoadVisitedDocumentEventArgs overview

Public Properties

Document | Gets or sets the loaded document.
UserData (inherited from SaveVisitedDocumentEventArgs) | Gets or sets the custom user-defined data. Typically this data is filled on saving and then can be used on loading.


LoadVisitedDocumentEventArgs Properties

LoadVisitedDocumentEventArgs Properties

The properties of the LoadVisitedDocumentEventArgs class are listed here. For a complete list of LoadVisitedDocumentEventArgs class members, see the LoadVisitedDocumentEventArgs Members topic.

Public Properties

Document | Gets or sets the loaded document.
UserData (inherited from SaveVisitedDocumentEventArgs) | Gets or sets the custom user-defined data. Typically this data is filled on saving and then can be used on loading.


LoadVisitedDocumentEventArgs.Document Property

LoadVisitedDocumentEventArgs.Document Property

Gets or sets the loaded document.

[Visual Basic]

Public Property Document As Object

[C#]

public object Document {get;set;}

[Delphi]

public property Document: Object read get_Document write set_Document;


LoadVisitedDocumentEventHandler Delegate

LoadVisitedDocumentEventHandler Delegate

Represents the method that will handle an event occuring when visited document should be loaded from custom user-defined storage.

[Visual Basic]

Public Delegate Sub LoadVisitedDocumentEventHandler( _

ByVal sender As Object, _

ByVal e As LoadVisitedDocumentEventArgs _

)

[C#]

public delegate void LoadVisitedDocumentEventHandler(

object sender,

LoadVisitedDocumentEventArgs e

);

[Delphi]

type LoadVisitedDocumentEventHandler = procedure (

sender: Object;

e: LoadVisitedDocumentEventArgs

) of object;

Parameters

sender

e

The LoadVisitedDocumentEventArgs object containing the event data.

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)

See Also

C1.Win.C1Preview Namespace


MouseModeEnum Enumeration

MouseModeEnum Enumeration

Describes the supported preview pane mouse behavior modes.

[Visual Basic]

Public Enum MouseModeEnum

[C#]

public enum MouseModeEnum

[Delphi]

type MouseModeEnum = (Hand, None, Select, Zoom, ZoomOut);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)

Members

Member name | Description
Hand |
None |
Select |
Zoom |
ZoomOut |

See Also

C1.Win.C1Preview Namespace


PageLayoutEnum Enumeration

PageLayoutEnum Enumeration

Describes the supported page view modes of the control.

[Visual Basic]

Public Enum PageLayoutEnum

[C#]

public enum PageLayoutEnum

[Delphi]

type PageLayoutEnum = (Custom, Facing, Normal);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)

Members

Member name | Description
Custom |
Facing |
Normal |

See Also

C1.Win.C1Preview Namespace


PreviewHistoryOptions Class

PreviewHistoryOptions Class

Defines the history related options of C1PrintPreview control.

For a list of all members of this type, see PreviewHistoryOptions Members.

System.Object

C1.Win.C1Preview.PreviewHistoryOptions

[Visual Basic]

Public Class PreviewHistoryOptions

[C#]

public class PreviewHistoryOptions

[Delphi]

type PreviewHistoryOptions = class;

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


PreviewHistoryOptions Members

PreviewHistoryOptions Members

PreviewHistoryOptions overview

Public Properties

MaxHistoryMenuSize | Gets or sets the maximum count of items in drop-down menus of HistoryNext and HistoryPrev buttons.
MaxVisitedDocumentsMenuSize | Gets or sets the maximum count of items in drop-down menus of FileOpen button.
Owner | Gets the C1PrintPreview object containing this object.


PreviewHistoryOptions Properties

PreviewHistoryOptions Properties

The properties of the PreviewHistoryOptions class are listed here. For a complete list of PreviewHistoryOptions class members, see the PreviewHistoryOptions Members topic.

Public Properties

MaxHistoryMenuSize | Gets or sets the maximum count of items in drop-down menus of HistoryNext and HistoryPrev buttons.
MaxVisitedDocumentsMenuSize | Gets or sets the maximum count of items in drop-down menus of FileOpen button.
Owner | Gets the C1PrintPreview object containing this object.


PreviewHistoryOptions.MaxHistoryMenuSize Property

PreviewHistoryOptions.MaxHistoryMenuSize Property

Gets or sets the maximum count of items in drop-down menus of HistoryNext and HistoryPrev buttons.

[Visual Basic]

Public Property MaxHistoryMenuSize As Int32*

[C#]

public Int32* MaxHistoryMenuSize {get;set;}

[Delphi]

public property MaxHistoryMenuSize: Int32* read get_MaxHistoryMenuSize write set_MaxHistoryMenuSize;


PreviewHistoryOptions.MaxVisitedDocumentsMenuSize Property

PreviewHistoryOptions.MaxVisitedDocumentsMenuSize Property

Gets or sets the maximum count of items in drop-down menus of FileOpen button.

[Visual Basic]

Public Property MaxVisitedDocumentsMenuSize As Int32*

[C#]

public Int32* MaxVisitedDocumentsMenuSize {get;set;}

[Delphi]

public property MaxVisitedDocumentsMenuSize: Int32* read get_MaxVisitedDocumentsMenuSize write set_MaxVisitedDocumentsMenuSize;


PreviewHistoryOptions.Owner Property

PreviewHistoryOptions.Owner Property

Gets the C1PrintPreview object containing this object.

[Visual Basic]

Public ReadOnly Property Owner As C1PrintPreviewControl

[C#]

public C1PrintPreviewControl Owner {get;}

[Delphi]

public property Owner: C1PrintPreviewControl read get_Owner;


PreviewPages Class

PreviewPages Class

Collection of preview pages.

For a list of all members of this type, see PreviewPages Members.

System.Object

System.Collections.CollectionBase

C1.Win.C1Preview.PreviewPages

[Visual Basic]

Public Class PreviewPages

Inherits CollectionBase

[C#]

public class PreviewPages : CollectionBase

[Delphi]

type PreviewPages = class (CollectionBase);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


PreviewPages Members

PreviewPages Members

PreviewPages overview

Public Properties

IsEmpty

Gets the value indicating whether the pages collection is empty.

Public Methods

BeginChanges | Overloaded. Begins a series of related changes to the pages collection. Should be followed by a call to EndChanges. Improves performance and provides consistency.
ClonePageImages | Returns an array of page image clones.
EndChanges | Ends a series of related changes to the pages collection. Should follow a call to BeginChanges. Improves performance and provides consistency.


PreviewPages Properties

PreviewPages Properties

The properties of the PreviewPages class are listed here. For a complete list of PreviewPages class members, see the PreviewPages Members topic.

Public Properties

IsEmpty

Gets the value indicating whether the pages collection is empty.


PreviewPages.IsEmpty Property

PreviewPages.IsEmpty Property

Gets the value indicating whether the pages collection is empty.

[Visual Basic]

Public ReadOnly Property IsEmpty As Boolean

[C#]

public bool IsEmpty {get;}

[Delphi]

public property IsEmpty: Boolean read get_IsEmpty;

Property Value


PreviewPages Methods

PreviewPages Methods

The methods of the PreviewPages class are listed here. For a complete list of PreviewPages class members, see the PreviewPages Members topic.

Public Methods

BeginChanges | Overloaded. Begins a series of related changes to the pages collection. Should be followed by a call to EndChanges. Improves performance and provides consistency.
ClonePageImages | Returns an array of page image clones.
EndChanges | Ends a series of related changes to the pages collection. Should follow a call to BeginChanges. Improves performance and provides consistency.


PreviewPages.BeginChanges Method

PreviewPages.BeginChanges Method

Overload List

Begins a series of related changes to the pages collection. Should be followed by a call to EndChanges. Improves performance and provides consistency.

[Visual Basic] Overloads Public Sub BeginChanges()

[C#] public void BeginChanges();

[Delphi] public procedure BeginChanges(); overload;

Begins a series of related changes to the pages collection, specifying the type of changes to occur. Should be followed by a call to EndChanges. Improves performance and provides consistency.

[Visual Basic] Overloads Public Sub BeginChanges(Boolean)

[C#] public void BeginChanges(bool);

[Delphi] public procedure BeginChanges(Boolean); overload;


PreviewPages.BeginChanges Method ()

PreviewPages.BeginChanges Method ()

Previous Next

Begins a series of related changes to the pages collection. Should be followed by a call to EndChanges. Improves performance and provides consistency.

[Visual Basic]

Overloads Public Sub BeginChanges()

[C#]

public void BeginChanges()

[Delphi]

public procedure BeginChanges(); overload;


PreviewPages.BeginChanges Method (Boolean)

PreviewPages.BeginChanges Method (Boolean)

Previous Next

Begins a series of related changes to the pages collection, specifying the type of changes to occur. Should be followed by a call to EndChanges. Improves performance and provides consistency.

[Visual Basic]

Overloads Public Sub BeginChanges( _

ByVal append As Boolean _

)

[C#]

public void BeginChanges(

bool append

);

[Delphi]

public procedure BeginChanges(

append: Boolean

); overload;

Parameters

append

If True, the changes are assumed to be limited to adding new pages to the end of the list. Specifying this parameter as True may increase performance when creating long documents. Note: it is the caller's responsibility to ensure that if this parameter is True, the changes are indeed limited to appending new pages only. Otherwise, unpredictable results may occur.


PreviewPages.ClonePageImages Method

PreviewPages.ClonePageImages Method

Returns an array of page image clones.

[Visual Basic]

Public Function ClonePageImages() As Image()

[C#]

public Image[] ClonePageImages()

[Delphi]

public function ClonePageImages(): array of Image;

Return Value

An array of page image clones.


PreviewPages.EndChanges Method

PreviewPages.EndChanges Method

Ends a series of related changes to the pages collection. Should follow a call to BeginChanges. Improves performance and provides consistency.

[Visual Basic]

Public Sub EndChanges()

[C#]

public void EndChanges()

[Delphi]

public procedure EndChanges();


PreviewToolTip Class

PreviewToolTip Class

Describes a tooltip that can be attached to a large control, and set (for example, from Cursor.get) depending on the current cursor location inside the control.

For a list of all members of this type, see PreviewToolTip Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Windows.Forms.ToolTip

C1.Win.C1Preview.PreviewToolTip

[Visual Basic]

Public Class PreviewToolTip

Inherits ToolTip

[C#]

public class PreviewToolTip : ToolTip

[Delphi]

type PreviewToolTip = class (ToolTip);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


PreviewToolTip Members

PreviewToolTip Members

PreviewToolTip overview

Public Properties

Active (inherited from ToolTip) | Determines if the ToolTip is active. A tip will only appear if the ToolTip has been activated.
AutomaticDelay (inherited from ToolTip) | Sets the values of AutoPopDelay, InitialDelay, and ReshowDelay to the appropriate values.
AutoPopDelay (inherited from ToolTip) | Determines the length of time the ToolTip window remains visible if the pointer is stationary inside a ToolTip region.
BackColor (inherited from ToolTip) | The background color of the ToolTip control.
ForeColor (inherited from ToolTip) | The foreground color of the ToolTip control.
InitialDelay (inherited from ToolTip) | Determines the length of time the pointer must remain stationary within a ToolTip region before the ToolTip window appears.
IsBalloon (inherited from ToolTip) | Indicates whether the ToolTip will take on a balloon form.
OwnerDraw (inherited from ToolTip) | Controls whether the system or the user paints items/sub items.
ReshowDelay (inherited from ToolTip) | Determines the length of time it takes for subsequent ToolTip windows to appear as the pointer moves from one ToolTip region to another.
ShowAlways (inherited from ToolTip) | Determines if the tool tip will be displayed always, even if the parent window is not active.
StripAmpersands (inherited from ToolTip) | When set to True, any ampersands (&) in the Text property are not displayed.
Tag (inherited from ToolTip) | User-defined data associated with the object.
ToolTipIcon (inherited from ToolTip) | Determines the icon that is shown on the ToolTip.
ToolTipTitle (inherited from ToolTip) | Determines the title of the ToolTip.
UseAnimation (inherited from ToolTip) | When set to True, animations are used when the ToolTip is shown or hidden.
UseFading (inherited from ToolTip) | When set to True, a fade effect is used when ToolTips are shown or hidden.

Public Methods

GetToolTip (inherited from ToolTip)

Determines the ToolTip shown when the mouse hovers over the control.

Public Events

Draw (inherited from ToolTip) | Occurs in OwnerDraw mode when the ToolTip needs to be drawn.
Popup (inherited from ToolTip) | Occurs whenever a ToolTip is about to be shown.


PreviewToolTip Properties

PreviewToolTip Properties

The properties of the PreviewToolTip class are listed here. For a complete list of PreviewToolTip class members, see the PreviewToolTip Members topic.

Public Properties

Active (inherited from ToolTip) | Determines if the ToolTip is active. A tip will only appear if the ToolTip has been activated.
AutomaticDelay (inherited from ToolTip) | Sets the values of AutoPopDelay, InitialDelay, and ReshowDelay to the appropriate values.
AutoPopDelay (inherited from ToolTip) | Determines the length of time the ToolTip window remains visible if the pointer is stationary inside a ToolTip region.
BackColor (inherited from ToolTip) | The background color of the ToolTip control.
ForeColor (inherited from ToolTip) | The foreground color of the ToolTip control.
InitialDelay (inherited from ToolTip) | Determines the length of time the pointer must remain stationary within a ToolTip region before the ToolTip window appears.
IsBalloon (inherited from ToolTip) | Indicates whether the ToolTip will take on a balloon form.
OwnerDraw (inherited from ToolTip) | Controls whether the system or the user paints items/sub items.
ReshowDelay (inherited from ToolTip) | Determines the length of time it takes for subsequent ToolTip windows to appear as the pointer moves from one ToolTip region to another.
ShowAlways (inherited from ToolTip) | Determines if the tool tip will be displayed always, even if the parent window is not active.
StripAmpersands (inherited from ToolTip) | When set to True, any ampersands (&) in the Text property are not displayed.
Tag (inherited from ToolTip) | User-defined data associated with the object.
ToolTipIcon (inherited from ToolTip) | Determines the icon that is shown on the ToolTip.
ToolTipTitle (inherited from ToolTip) | Determines the title of the ToolTip.
UseAnimation (inherited from ToolTip) | When set to True, animations are used when the ToolTip is shown or hidden.
UseFading (inherited from ToolTip) | When set to True, a fade effect is used when ToolTips are shown or hidden.


PreviewToolTip Methods

PreviewToolTip Methods

The methods of the PreviewToolTip class are listed here. For a complete list of PreviewToolTip class members, see the PreviewToolTip Members topic.

Public Methods

GetToolTip (inherited from ToolTip)

Determines the ToolTip shown when the mouse hovers over the control.


PreviewToolTip Events

PreviewToolTip Events

The events of the PreviewToolTip class are listed here. For a complete list of PreviewToolTip class members, see the PreviewToolTip Members topic.

Public Events

Draw (inherited from ToolTip) | Occurs in OwnerDraw mode when the ToolTip needs to be drawn.
Popup (inherited from ToolTip) | Occurs whenever a ToolTip is about to be shown.


SaveVisitedDocumentEventArgs Class

SaveVisitedDocumentEventArgs Class

Contains the data for SaveVisitedDocument event of C1PreviewPane.

For a list of all members of this type, see SaveVisitedDocumentEventArgs Members.

System.Object

System.EventArgs

C1.Win.C1Preview.SaveVisitedDocumentEventArgs

C1.Win.C1Preview.LoadVisitedDocumentEventArgs

[Visual Basic]

Public Class SaveVisitedDocumentEventArgs

Inherits EventArgs

[C#]

public class SaveVisitedDocumentEventArgs : EventArgs

[Delphi]

type SaveVisitedDocumentEventArgs = class (EventArgs);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


SaveVisitedDocumentEventArgs Members

SaveVisitedDocumentEventArgs Members

SaveVisitedDocumentEventArgs overview

Public Properties

UserData

Gets or sets the custom user-defined data. Typically this data is filled on saving and then can be used on loading.


SaveVisitedDocumentEventArgs Properties

SaveVisitedDocumentEventArgs Properties

The properties of the SaveVisitedDocumentEventArgs class are listed here. For a complete list of SaveVisitedDocumentEventArgs class members, see the SaveVisitedDocumentEventArgs Members topic.

Public Properties

UserData

Gets or sets the custom user-defined data. Typically this data is filled on saving and then can be used on loading.


SaveVisitedDocumentEventArgs.UserData Property

SaveVisitedDocumentEventArgs.UserData Property

Gets or sets the custom user-defined data. Typically this data is filled on saving and then can be used on loading.

[Visual Basic]

Public Property UserData As Object

[C#]

public object UserData {get;set;}

[Delphi]

public property UserData: Object read get_UserData write set_UserData;


SaveVisitedDocumentEventHandler Delegate

SaveVisitedDocumentEventHandler Delegate

Represents the method that will handle an event occuring when visited documeng should be saved to custom user-defined storage.

[Visual Basic]

Public Delegate Sub SaveVisitedDocumentEventHandler( _

ByVal sender As Object, _

ByVal e As SaveVisitedDocumentEventArgs _

)

[C#]

public delegate void SaveVisitedDocumentEventHandler(

object sender,

SaveVisitedDocumentEventArgs e

);

[Delphi]

type SaveVisitedDocumentEventHandler = procedure (

sender: Object;

e: SaveVisitedDocumentEventArgs

) of object;

Parameters

sender

e

The SaveVisitedDocumentEventArgs object containing the event data.

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)

See Also

C1.Win.C1Preview Namespace


ShowRulersFlags Enumeration

ShowRulersFlags Enumeration

[Visual Basic]

Public Enum ShowRulersFlags

[C#]

public enum ShowRulersFlags

[Delphi]

type ShowRulersFlags = (All, Horizontal, None, Vertical);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)

Members

Member name | Description
All |
Horizontal |
None |
Vertical |

See Also

C1.Win.C1Preview Namespace


ViewHistoryItem Class

ViewHistoryItem Class

Represents the separate item of the view history of the preview pane.

For a list of all members of this type, see ViewHistoryItem Members.

System.Object

C1.Win.C1Preview.ViewHistoryItem

[Visual Basic]

Public Class ViewHistoryItem

[C#]

public class ViewHistoryItem

[Delphi]

type ViewHistoryItem = class;

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


ViewHistoryItem Members

ViewHistoryItem Members

ViewHistoryItem overview

Public Properties

Owner | Gets the ViewHistoryItemCollection collection containing this object.
Pane | Gets the C1PreviewPane object containg this object.
VisitedDocument | The visited document that was opened when this history entry was created.


ViewHistoryItem Properties

ViewHistoryItem Properties

The properties of the ViewHistoryItem class are listed here. For a complete list of ViewHistoryItem class members, see the ViewHistoryItem Members topic.

Public Properties

Owner | Gets the ViewHistoryItemCollection collection containing this object.
Pane | Gets the C1PreviewPane object containg this object.
VisitedDocument | The visited document that was opened when this history entry was created.


ViewHistoryItem.Owner Property

ViewHistoryItem.Owner Property

Gets the ViewHistoryItemCollection collection containing this object.

[Visual Basic]

Public ReadOnly Property Owner As ViewHistoryItemCollection

[C#]

public ViewHistoryItemCollection Owner {get;}

[Delphi]

public property Owner: ViewHistoryItemCollection read get_Owner;


ViewHistoryItem.Pane Property

ViewHistoryItem.Pane Property

Gets the C1PreviewPane object containg this object.

[Visual Basic]

Public ReadOnly Property Pane As C1PreviewPane

[C#]

public C1PreviewPane Pane {get;}

[Delphi]

public property Pane: C1PreviewPane read get_Pane;


ViewHistoryItem.VisitedDocument Property

ViewHistoryItem.VisitedDocument Property

The visited document that was opened when this history entry was created.

[Visual Basic]

Public ReadOnly Property VisitedDocument As VisitedDocument

Friend WriteOnly Property VisitedDocument As VisitedDocument

[C#]

public VisitedDocument VisitedDocument {get;}

internal VisitedDocument VisitedDocument {set;}

[Delphi]

public property VisitedDocument: VisitedDocument read get_VisitedDocument write set_VisitedDocument;


ViewState Structure

ViewState Structure

Contains information about the state of C1PreviewPane: scrooling position, zoom factor, and so on.

For a list of all members of this type, see ViewState Members.

System.Object

System.ValueType

C1.Win.C1Preview.ViewState

[Visual Basic]

Public Structure ViewState

[C#]

public struct ViewState

[Delphi]

type ViewState = record;

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


ViewState Members

ViewState Members

ViewState overview


VisitedDocument Class

VisitedDocument Class

Represents the document in the collection of visited documents.

For a list of all members of this type, see VisitedDocument Members.

System.Object

C1.Win.C1Preview.VisitedDocument

[Visual Basic]

Public Class VisitedDocument

[C#]

public class VisitedDocument

[Delphi]

type VisitedDocument = class;

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


VisitedDocument Members

VisitedDocument Members

VisitedDocument overview

Public Properties

DocumentCaption | Caption of visited document.
HasAutoDocumentCaption | Gets the value indicating whether the visited document has an automatically generated name. This name will be changed when document is saved to file.
Index | Gets an index of this object in the owner collection.
Owner | Gets the VisitedDocumentCollection collection containing this object.
Pane | Gets the C1PreviewPane object containing this object.
Storage | Gets or sets the VisitedDocumentStorage object containing the data of visited document.
UserAction | Gets the user's action producing this document. This property is used to generate the FullDocumentCaption.

Public Methods

CreateDocument | Creates the document which is stored in this visited document, if this VisitedDocument object linked with currently opened document then this method returns this *currently opened* document.
GetFullDocumentCaption | Gets the full document caption it is DocumentCaption with suffix depending on UserAction, for example if document was created after changing the page settings then its name will: "Document1 (page settings changed)". If UserAction is DocumentOpen then simple DocumentCaption returned.


VisitedDocument Properties

VisitedDocument Properties

The properties of the VisitedDocument class are listed here. For a complete list of VisitedDocument class members, see the VisitedDocument Members topic.

Public Properties

DocumentCaption | Caption of visited document.
HasAutoDocumentCaption | Gets the value indicating whether the visited document has an automatically generated name. This name will be changed when document is saved to file.
Index | Gets an index of this object in the owner collection.
Owner | Gets the VisitedDocumentCollection collection containing this object.
Pane | Gets the C1PreviewPane object containing this object.
Storage | Gets or sets the VisitedDocumentStorage object containing the data of visited document.
UserAction | Gets the user's action producing this document. This property is used to generate the FullDocumentCaption.


VisitedDocument.DocumentCaption Property

VisitedDocument.DocumentCaption Property

Caption of visited document.

[Visual Basic]

Public Property DocumentCaption As String

[C#]

public string DocumentCaption {get;set;}

[Delphi]

public property DocumentCaption: String read get_DocumentCaption write set_DocumentCaption;


VisitedDocument.HasAutoDocumentCaption Property

VisitedDocument.HasAutoDocumentCaption Property

Gets the value indicating whether the visited document has an automatically generated name. This name will be changed when document is saved to file.

[Visual Basic]

Public Property HasAutoDocumentCaption As Boolean

[C#]

public bool HasAutoDocumentCaption {get;set;}

[Delphi]

public property HasAutoDocumentCaption: Boolean read get_HasAutoDocumentCaption write set_HasAutoDocumentCaption;


VisitedDocument.Index Property

VisitedDocument.Index Property

Gets an index of this object in the owner collection.

[Visual Basic]

Public ReadOnly Property Index As Int32*

[C#]

public Int32* Index {get;}

[Delphi]

public property Index: Int32* read get_Index;


VisitedDocument.Owner Property

VisitedDocument.Owner Property

Gets the VisitedDocumentCollection collection containing this object.

[Visual Basic]

Public ReadOnly Property Owner As VisitedDocumentCollection

[C#]

public VisitedDocumentCollection Owner {get;}

[Delphi]

public property Owner: VisitedDocumentCollection read get_Owner;


VisitedDocument.Pane Property

VisitedDocument.Pane Property

Gets the C1PreviewPane object containing this object.

[Visual Basic]

Public ReadOnly Property Pane As C1PreviewPane

[C#]

public C1PreviewPane Pane {get;}

[Delphi]

public property Pane: C1PreviewPane read get_Pane;


VisitedDocument.Storage Property

VisitedDocument.Storage Property

Gets or sets the VisitedDocumentStorage object containing the data of visited document.

[Visual Basic]

Public Property Storage As VisitedDocumentStorage

[C#]

public VisitedDocumentStorage Storage {get;set;}

[Delphi]

public property Storage: VisitedDocumentStorage read get_Storage write set_Storage;


VisitedDocument.UserAction Property

VisitedDocument.UserAction Property

Gets the user's action producing this document. This property is used to generate the FullDocumentCaption.

[Visual Basic]

Public Property UserAction As HistorySavedActionsEnum

[C#]

public HistorySavedActionsEnum UserAction {get;set;}

[Delphi]

public property UserAction: HistorySavedActionsEnum read get_UserAction write set_UserAction;


VisitedDocument Methods

VisitedDocument Methods

The methods of the VisitedDocument class are listed here. For a complete list of VisitedDocument class members, see the VisitedDocument Members topic.

Public Methods

CreateDocument | Creates the document which is stored in this visited document, if this VisitedDocument object linked with currently opened document then this method returns this *currently opened* document.
GetFullDocumentCaption | Gets the full document caption it is DocumentCaption with suffix depending on UserAction, for example if document was created after changing the page settings then its name will: "Document1 (page settings changed)". If UserAction is DocumentOpen then simple DocumentCaption returned.


VisitedDocument.CreateDocument Method

VisitedDocument.CreateDocument Method

Creates the document which is stored in this visited document, if this VisitedDocument object linked with currently opened document then this method returns this *currently opened* document.

[Visual Basic]

Public Function CreateDocument() As Object

[C#]

public object CreateDocument()

[Delphi]

public function CreateDocument(): Object;

Return Value

Returns the created document.


VisitedDocument.GetFullDocumentCaption Method

VisitedDocument.GetFullDocumentCaption Method

Gets the full document caption it is DocumentCaption with suffix depending on UserAction, for example if document was created after changing the page settings then its name will: "Document1 (page settings changed)". If UserAction is DocumentOpen then simple DocumentCaption returned.

[Visual Basic]

Public Function GetFullDocumentCaption() As String

[C#]

public string GetFullDocumentCaption()

[Delphi]

public function GetFullDocumentCaption(): String;


VisitedDocumentAddingEventArgs Class

VisitedDocumentAddingEventArgs Class

Contains the data for VisitedDocumentAdding event of C1PreviewPane.

For a list of all members of this type, see VisitedDocumentAddingEventArgs Members.

System.Object

System.EventArgs

System.ComponentModel.CancelEventArgs

C1.Win.C1Preview.VisitedDocumentAddingEventArgs

[Visual Basic]

Public Class VisitedDocumentAddingEventArgs

Inherits CancelEventArgs

[C#]

public class VisitedDocumentAddingEventArgs : CancelEventArgs

[Delphi]

type VisitedDocumentAddingEventArgs = class (CancelEventArgs);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


VisitedDocumentAddingEventArgs Members

VisitedDocumentAddingEventArgs Members

VisitedDocumentAddingEventArgs overview

Public Properties

VisitedDocument

The adding VisitedDocument object.


VisitedDocumentAddingEventArgs Properties

VisitedDocumentAddingEventArgs Properties

The properties of the VisitedDocumentAddingEventArgs class are listed here. For a complete list of VisitedDocumentAddingEventArgs class members, see the VisitedDocumentAddingEventArgs Members topic.

Public Properties

VisitedDocument

The adding VisitedDocument object.


VisitedDocumentAddingEventArgs.VisitedDocument Property

VisitedDocumentAddingEventArgs.VisitedDocument Property

The adding VisitedDocument object.

[Visual Basic]

Public ReadOnly Property VisitedDocument As VisitedDocument

[C#]

public VisitedDocument VisitedDocument {get;}

[Delphi]

public property VisitedDocument: VisitedDocument read get_VisitedDocument;


VisitedDocumentAddingEventHandler Delegate

VisitedDocumentAddingEventHandler Delegate

Represents the method that will handle an event occuring when new item adding to the VisitedDocuments collection.

[Visual Basic]

Public Delegate Sub VisitedDocumentAddingEventHandler( _

ByVal sender As Object, _

ByVal e As VisitedDocumentAddingEventArgs _

)

[C#]

public delegate void VisitedDocumentAddingEventHandler(

object sender,

VisitedDocumentAddingEventArgs e

);

[Delphi]

type VisitedDocumentAddingEventHandler = procedure (

sender: Object;

e: VisitedDocumentAddingEventArgs

) of object;

Parameters

sender

e

The VisitedDocumentAddingEventArgs object containing the event data.

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)

See Also

C1.Win.C1Preview Namespace


VisitedDocumentStorage Class

VisitedDocumentStorage Class

Contains the content of visited document, the format of content depends on the type of document (C1Doc, .NET PrintDocument, and so on).

For a list of all members of this type, see VisitedDocumentStorage Members.

System.Object

C1.Win.C1Preview.VisitedDocumentStorage

C1.Win.C1Preview.VisitedDocumentStorageC1Doc

C1.Win.C1Preview.VisitedDocumentStorageImages

[Visual Basic]

MustInherit Public Class VisitedDocumentStorage

Implements IDisposable

[C#]

public abstract class VisitedDocumentStorage : IDisposable

[Delphi]

type VisitedDocumentStorage = class abstract (TObject, IDisposable);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


VisitedDocumentStorage Members

VisitedDocumentStorage Members

VisitedDocumentStorage overview

Public Methods

CreateDocument

Overloaded. Creates an document on the basis of storage's data.


VisitedDocumentStorage Methods

VisitedDocumentStorage Methods

The methods of the VisitedDocumentStorage class are listed here. For a complete list of VisitedDocumentStorage class members, see the VisitedDocumentStorage Members topic.

Public Methods

CreateDocument

Overloaded. Creates an document on the basis of storage's data.


VisitedDocumentStorage.CreateDocument Method

VisitedDocumentStorage.CreateDocument Method

Creates an document on the basis of storage's data.

[Visual Basic]

Public Function CreateDocument() As Object

[C#]

public object CreateDocument()

[Delphi]

public function CreateDocument(): Object; overload;

Return Value

Returns the created document.


VisitedDocumentStorageC1Doc Class

VisitedDocumentStorageC1Doc Class

For a list of all members of this type, see VisitedDocumentStorageC1Doc Members.

System.Object

C1.Win.C1Preview.VisitedDocumentStorage

C1.Win.C1Preview.VisitedDocumentStorageC1Doc

[Visual Basic]

Public Class VisitedDocumentStorageC1Doc

Inherits VisitedDocumentStorage

[C#]

public class VisitedDocumentStorageC1Doc : VisitedDocumentStorage

[Delphi]

type VisitedDocumentStorageC1Doc = class (VisitedDocumentStorage);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


VisitedDocumentStorageC1Doc Members

VisitedDocumentStorageC1Doc Members

VisitedDocumentStorageC1Doc overview

Public Methods

CreateDocument (inherited from VisitedDocumentStorage)

Creates an document on the basis of storage's data.


VisitedDocumentStorageC1Doc Methods

VisitedDocumentStorageC1Doc Methods

The methods of the VisitedDocumentStorageC1Doc class are listed here. For a complete list of VisitedDocumentStorageC1Doc class members, see the VisitedDocumentStorageC1Doc Members topic.

Public Methods

CreateDocument (inherited from VisitedDocumentStorage)

Creates an document on the basis of storage's data.


VisitedDocumentStorageEnum Enumeration

VisitedDocumentStorageEnum Enumeration

Defines the modes of documents keeping in the preview history.

[Visual Basic]

Public Enum VisitedDocumentStorageEnum

[C#]

public enum VisitedDocumentStorageEnum

[Delphi]

type VisitedDocumentStorageEnum = (File, Memory, User);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)

Members

Member name | Description
File |
Memory |
User |

See Also

C1.Win.C1Preview Namespace


VisitedDocumentStorageImages Class

VisitedDocumentStorageImages Class

For a list of all members of this type, see VisitedDocumentStorageImages Members.

System.Object

C1.Win.C1Preview.VisitedDocumentStorage

C1.Win.C1Preview.VisitedDocumentStorageImages

[Visual Basic]

Public Class VisitedDocumentStorageImages

Inherits VisitedDocumentStorage

[C#]

public class VisitedDocumentStorageImages : VisitedDocumentStorage

[Delphi]

type VisitedDocumentStorageImages = class (VisitedDocumentStorage);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)


VisitedDocumentStorageImages Members

VisitedDocumentStorageImages Members

VisitedDocumentStorageImages overview

Public Methods

CreateDocument (inherited from VisitedDocumentStorage)

Creates an document on the basis of storage's data.


VisitedDocumentStorageImages Methods

VisitedDocumentStorageImages Methods

The methods of the VisitedDocumentStorageImages class are listed here. For a complete list of VisitedDocumentStorageImages class members, see the VisitedDocumentStorageImages Members topic.

Public Methods

CreateDocument (inherited from VisitedDocumentStorage)

Creates an document on the basis of storage's data.


ZoomModeEnum Enumeration

ZoomModeEnum Enumeration

Describes the supported zoom modes of C1PrintPreview control.

[Visual Basic]

Public Enum ZoomModeEnum

[C#]

public enum ZoomModeEnum

[Delphi]

type ZoomModeEnum = (ActualSize, Custom, PageWidth, TextWidth, WholePage);

Namespace: C1.Win.C1Preview

Assembly: C1.Win.C1Preview.2 (in C1.Win.C1Preview.2.dll)

Members

Member name | Description
ActualSize |
Custom |
PageWidth |
TextWidth |
WholePage |

See Also

C1.Win.C1Preview Namespace


Adding Images to Specific Cells - C#

C#

private void Form1_Load(object sender, System.EventArgs e)

{

// make a table

C1.C1Preview.RenderTable table = new C1.C1Preview.RenderTable(this.c1PrintDocument1);

table.Style.GridLines.All = new LineDef(Color.DarkGray);

const int r = 3;

const int c = 3;

for (int row = 0; row < r; ++row)

{

for (int col = 0; col < c; ++col)

{

C1.C1Preview.RenderText celltext = new C1.C1Preview.RenderText(this.c1PrintDocument1);

celltext.Text = string.Format("", row, col);

// Add empty cells

table.Cells[row, col].RenderObject = celltext;

}

}

// generate the document

this.C1PrintDocument1.Body.Children.Add(table);

this.c1PrintDocument1.Generate();

}


Adding Images to Specific Cells - C# 2

C#

// fix the center cell's size

table.Rows[1].Height = new C1.C1Preview.Unit(8, C1.C1Preview.UnitTypeEnum.Cm);

table.Cols[1].Width = new C1.C1Preview.Unit(8, C1.C1Preview.UnitTypeEnum.Cm);


Adding Images to Specific Cells - C# 3

C#

// set up image alignment

table.CellStyle.ImageAlign.StretchHorz = false;

table.CellStyle.ImageAlign.StretchVert = false;

table.CellStyle.ImageAlign.AlignHorz = C1.C1Preview.ImageAlignHorzEnum.Center;


Adding Images to Specific Cells - C# 4

C#

C1.C1Preview.RenderImage img1 =
new C1.C1Preview.RenderImage(this.c1PrintDocument1);
C1.C1Preview.RenderImage img2 =
new C1.C1Preview.RenderImage(this.c1PrintDocument1);


Adding Images to Specific Cells - C# 5

C#

Img1.Image = this.pictureBox1.Image;
img2.Image = this.pictureBox2.Image;


Adding Images to Specific Cells - C# 6

C#

table.Cells(1, 1).RenderObject = img1;
table.Cells(1, 2).RenderObject = img2;


Adding Images to Specific Cells - Delphi

Delphi

procedure MainForm.Form1_Load(sender: System.Object; e: System.EventArgs);

var

table : C1.C1PrintDocument.RenderTable

begin

// make a table

table := C1.C1Preview.RenderTable.Create(Self.c1PrintDocument1);

table.Style.GridLines.All := new LineDef(Color.DarkGray);

const r : Integer = 3;

const c : Integer = 3;

row := 0;

while (row < r) do

begin

col := 0;

while (col < c) do

begin

celltext := C1.C1Preview.RenderText.Create(Self.c1PrintDocument1);

celltext.Text := Format('', row, col);

// Add empty cells

table.Cells[row, col].RenderObject := celltext;

end;

end;

// generate the document

Self.C1PrintDocument1.Body.Children.Add(table);

Self.C1PrintDocument1.Generate;

end;


Adding Images to Specific Cells - Delphi 2

Delphi

// fix the center cell's size

table.Rows[1].Height := new C1.C1Preview.Unit(8, C1.C1Preview.UnitTypeEnum.Cm);

table.Cols[1].Width := new C1.C1Preview.Unit(8, C1.C1Preview.UnitTypeEnum.Cm);


Adding Images to Specific Cells - Delphi 3

Delphi

// set up image alignment

table.CellStyle.ImageAlign.StretchHorz := false;

table.CellStyle.ImageAlign.StretchVert := false;

table.CellStyle.ImageAlign.AlignHorz := C1.C1Preview.ImageAlignHorzEnum.Center;


Adding Images to Specific Cells - Delphi 4

Delphi

var

img1 : C1.C1Preview.RenderImage;

img2 : C1.C1Preview.RenderImage;

begin

img1 := C1.C1Preview.RenderImage.Create(Self.c1PrintDocument1)

img2 := C1.C1Preview.RenderImage.Create(Self.c1PrintDocument1)

end;


Adding Images to Specific Cells - Delphi 5

Delphi

Img1.Image := Self.pictureBox1.Image;
img2.Image := Self.pictureBox2.Image;


Adding Images to Specific Cells - Delphi 6

Delphi

table.Cells(1, 1).RenderObject := img1;
table.Cells(1, 2).RenderObject := img2;


Adding Images to Specific Cells - Visual Basic

Visual Basic

Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

' make a table

Dim table As C1.C1Preview.RenderTable = New C1.C1Preview.RenderTable(Me.C1PrintDocument1)

table.Style.GridLines.All = New C1.C1Preview.LineDef(Color.DarkGray)

Dim r As Integer = 3

Dim c As Integer = 3

Dim row As Integer

Dim col As Integer

For row = 0 To r - 1 Step +1

For col = 0 To c - 1 Step +1

Dim celltext As C1.C1Preview.RenderText = New C1.C1Preview.RenderText(Me.C1PrintDocument1)

' Add empty cells

celltext.Text = String.Format("", row, col)

table.Cells(row, col).RenderObject = celltext

Next

Next

' generate the document

Me.C1PrintDocument1.Body.Children.Add(table)

Me.C1PrintDocument1.Generate()

End Sub


Adding Images to Specific Cells - Visual Basic 2

Visual Basic

' fix the center cell's size

table.Rows(1).Height = New C1.C1Preview.Unit(8, C1.C1Preview.UnitTypeEnum.Cm)

table.Cols(1).Width = New C1.C1Preview.Unit(8, C1.C1Preview.UnitTypeEnum.Cm)


Adding Images to Specific Cells - Visual Basic 3

Visual Basic

' set up image alignment

table.CellStyle.ImageAlign.StretchHorz = False

table.CellStyle.ImageAlign.StretchVert = False

table.CellStyle.ImageAlign.AlignHorz = C1.C1Preview.ImageAlignHorzEnum.Center


Adding Images to Specific Cells - Visual Basic 4

Visual Basic

Dim img1 As C1.C1Preview.RenderImage = New C1.C1Preview.RenderImage(Me.C1PrintDocument1)

Dim img2 As C1.C1Preview.RenderImage = New C1.C1Preview.RenderImage(Me.C1PrintDocument1)


Adding Images to Specific Cells - Visual Basic 5

Visual Basic

Img1.Image = Me.pictureBox1.Image
img2.Image = Me.pictureBox2.Image


Adding Images to Specific Cells - Visual Basic 6

Visual Basic

table.Cells(1, 1).RenderObject = img1
table.Cells(1, 2).RenderObject = img2


Adding Paragraphs to the Document - C#

C#

RenderParagraph rp = new RenderParagraph();


Adding Paragraphs to the Document - C# 2

C#

private void Form1_Load(object sender, EventArgs e)

{

// Create paragraph

RenderParagraph rpar = new RenderParagraph();

Font f = new Font(rpar.Style.Font, FontStyle.Bold);

rpar.Content.AddText("This is a paragraph. This is normal text. ");

rpar.Content.AddText("This text is bold. ", f);

rpar.Content.AddText("This text is red. ", Color.Red);

rpar.Content.AddText("This text is superscript. ",
TextPositionEnum.Superscript);

rpar.Content.AddText("This text is bold and red. ", f, Color.Red);

rpar.Content.AddText("This text is bold and red and subscript. ",
f, Color.Red, TextPositionEnum.Subscript);

rpar.Content.AddText("This is normal text again. ");

rpar.Content.AddHyperlink(
"This is a link to the start of this paragraph.",
rpar.Content[0]);

rpar.Content.AddText("Finally, here is an inline image: ");

rpar.Content.AddImage(this.Icon.ToBitmap());

rpar.Content.AddText(".");

// Add paragraph to the document

c1PrintDocument1.Body.Children.Add(rpar);

c1PrintDocument1.Generate();

}


Adding Paragraphs to the Document - Delphi

Delphi

rp := RenderParagraph.Create;


Adding Paragraphs to the Document - Delphi 2

Delphi

procedure MainForm.Form1_Load(sender: System.Object; e: System.EventArgs);

begin

// Create paragraph

rpar := RenderParagraph.Create;

f := Font.Create(rpar.Style.Font, FontStyle.Bold);

rpar.Content.AddText('This is a paragraph. This is normal text. ');

rpar.Content.AddText('This text is bold. ', f);

rpar.Content.AddText('This text is red. ', Color.Red);

rpar.Content.AddText('This text is superscript. ',

TextPositionEnum.Superscript);

rpar.Content.AddText('This text is bold and red. ', f, Color.Red);

rpar.Content.AddText('This text is bold and red and subscript. ',

f, Color.Red, TextPositionEnum.Subscript);

rpar.Content.AddText('This is normal text again. ');

rpar.Content.AddHyperlink('This is a link to the start of this

paragraph.', rpar.Content[0]);

rpar.Content.AddText('Finally, here is an inline image: ');

rpar.Content.AddImage(Self.Icon.ToBitmap);

rpar.Content.AddText('.');

// Add paragraph to the document

c1PrintDocument1.Body.Children.Add(rpar);

c1PrintDocument1.Generate;

end;


Adding Paragraphs to the Document - Visual Basic

Visual Basic

Dim rp As New RenderParagraph()


Adding Paragraphs to the Document - Visual Basic 2

Visual Basic

Private Sub Form1_Load(sender As Object, e As EventArgs)

' Create paragraph

Dim rpar As New RenderParagraph()

Dim f As New Font(rpar.Style.Font, FontStyle.Bold)

rpar.Content.AddText("This is a paragraph. This is normal text. ")

rpar.Content.AddText("This text is bold. ", f)

rpar.Content.AddText("This text is red. ", Color.Red)

rpar.Content.AddText("This text is superscript. ",

TextPositionEnum.Superscript)

rpar.Content.AddText("This text is bold and red. ", f, Color.Red)

rpar.Content.AddText("This text is bold and red and subscript. ",

f, Color.Red, TextPositionEnum.Subscript)

rpar.Content.AddText("This is normal text again. ")

rpar.Content.AddHyperlink("This is a link to the start of this

paragraph.", rpar.Content(0))

rpar.Content.AddText("Finally, here is an inline image: ")

rpar.Content.AddImage(Me.Icon.ToBitmap())

rpar.Content.AddText(".")

' Add paragraph to the document

c1PrintDocument1.Body.Children.Add(rpar)

c1PrintDocument1.Generate()

End Sub


Adding Text Below the Table - C#

C#

C1.C1Preview.RenderText caption = new C1.C1Preview.RenderText(this.C1PrintDocument1);

caption.text = "In the table above, there are three rows and three columns.";


Adding Text Below the Table - C# 2

C#

caption.Style.Padding.Top = new C1.C1Preview.Unit(1, C1.C1Preview.UnitTypeEnum.Cm);


Adding Text Below the Table - C# 3

C#

Me.C1PrintDocument1.Body.Children.Add(table);

Me.C1PrintDocument1.Body.Children.Add(caption);


Adding Text Below the Table - Delphi

Delphi

var

table : RenderTable;

begin

table :=
C1.C1Preview.RenderTable.Create(Self.c1PrintDocument1);

caption.text := 'In the table above, there are three rows and three columns.';

end;


Adding Text Below the Table - Delphi 2

Delphi

caption.Style.Padding.Top := C1.C1Preview.Unit.Create(1, C1.C1Preview.UnitTypeEnum.Cm);


Adding Text Below the Table - Delphi 3

Delphi

Me.C1PrintDocument1.Body.Children.Add(table);

Me.C1PrintDocument1.Body.Children.Add(caption);


Adding Text Below the Table - Visual Basic

Visual Basic

Dim caption As C1.C1Preview.RenderText = New C1.C1Preview.RenderText(Me.C1PrintDocument1)

caption.Text = "In the table above, there are three rows and three columns."


Adding Text Below the Table - Visual Basic 2

Visual Basic

caption.Style.Padding.Top = New C1.C1Preview.Unit(1, C1.C1Preview.UnitTypeEnum.Cm)


Adding Text Below the Table - Visual Basic 3

Visual Basic

Me.C1PrintDocument1.Body.Children.Add(table)

Me.C1PrintDocument1.Body.Children.Add(caption)


Adding Text to Tables - C#

C#

private void Form1_Load(object sender, System.EventArgs e)

{

// make a table

C1.C1Preview.RenderTable table = new C1.C1Preview.RenderTable(this.c1PrintDocument1);

table.Style.GridLines.All = new LineDef(Color.DarkGray);

// generate the document

this.C1PrintDocument1.Body.Children.Add(table);

this.c1PrintDocument1.Generate();

}


Adding Text to Tables - C# 2

C#

// Add 3 rows

const int r = 3;

// Add 3 columns

const int c = 3;

for (int row = 0; row < r; ++row)

{

for (int col = 0; col < c; ++col)

{

if (!(i == 1 && j == 1) && !(i == 1 && j == 2))

C1.C1Preview.RenderText celltext = new C1.C1Preview.RenderText(this.c1PrintDocument1);

celltext.Text = string.Format("Cell ({0}, {1})", row, col);

// Add cells with text

table.Cells[row, col].RenderObject = celltext;

}

}


Adding Text to Tables - Delphi

Delphi

procedure MainForm.Form1_Load(sender: System.Object; e: System.EventArgs);

var

table : C1.C1PrintDocument.RenderTable

begin

// make a table

table := C1.C1Preview.RenderTable.Create(Self.c1PrintDocument1);

table.Style.GridLines.All := new LineDef(Color.DarkGray);

// generate the document

Self.C1PrintDocument1.Body.Children.Add(table);

Self.C1PrintDocument1.Generate;

end;


Adding Text to Tables - Delphi 2

Delphi

const r : Integer = 3;

const c : Integer = 3;

row := 0;

while (row < r) do

begin

col := 0;

while (col < c) do

begin

If Not ((i = 1) and (j = 1)) and (not ((i = 1) and (j = 2)) then
begin

celltext := C1.C1Preview.RenderText.Create(Self.c1PrintDocument1);

celltext.Text := Format('Cell ({0}, {1})', row, col);

// Add empty cells

table.Cells[row, col].RenderObject := celltext;

end;

end;

end;


Adding Text to Tables - Visual Basic

Visual Basic

Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

' make a table

Dim table As C1.C1Preview.RenderTable = New C1.C1Preview.RenderTable(Me.C1PrintDocument1)

table.Style.GridLines.All = New C1.C1Preview.LineDef(Color.DarkGray)

' generate the document

Me.C1PrintDocument1.Body.Children.Add(table)

Me.C1PrintDocument1.Generate()

End Sub


Adding Text to Tables - Visual Basic 2

Visual Basic

' Add 3 rows

Dim r As Integer = 3

' Add 3 columns

Dim c As Integer = 3

Dim row As Integer

Dim col As Integer

For row = 0 To r - 1 Step +1

For col = 0 To c - 1 Step +1

If (Not (row = 1 And col = 1)) And (Not (row = 1 And col = 2)) Then

Dim celltext As C1.C1Preview.RenderText = New C1.C1Preview.RenderText(Me.C1PrintDocument1)

celltext.Text = String.Format("Cell ({0},{1})", row, col)

table.Cells(row, col).RenderObject = celltext

End If

Next

Next


C1.C1Preview.Export Hierarchy

C1.C1Preview.Export Hierarchy

System.Object

C1.C1Preview.Export.ExportProvider

C1.C1Preview.Export.C1dExportProvider

C1.C1Preview.Export.ComplexExportProvider

C1.C1Preview.Export.HtmlExportProvider

C1.C1Preview.Export.RtfExportProvider

C1.C1Preview.Export.XlsExportProvider

C1.C1Preview.Export.PagesExportProvider

C1.C1Preview.Export.EmfExportProvider

C1.C1Preview.Export.ImageExportProvider

C1.C1Preview.Export.BmpExportProvider

C1.C1Preview.Export.GifExportProvider

C1.C1Preview.Export.JpegExportProvider

C1.C1Preview.Export.PngExportProvider

C1.C1Preview.Export.TiffExportProvider

C1.C1Preview.Export.PdfExportProvider

C1.C1Preview.Export.Exporter

C1.C1Preview.Export.C1dExporter

C1.C1Preview.Export.ComplexExporter

C1.C1Preview.Export.HtmlExporter

C1.C1Preview.Export.RtfExporter

C1.C1Preview.Export.XlsExporter

C1.C1Preview.Export.PagesExporter

C1.C1Preview.Export.EmfExporter

C1.C1Preview.Export.ImageExporter

C1.C1Preview.Export.PdfExporter

System.MarshalByRefObject

System.ComponentModel.Component

System.Windows.Forms.Control

System.Windows.Forms.ScrollableControl

System.Windows.Forms.ContainerControl

System.Windows.Forms.Form

C1.C1Preview.Forms.BaseForm

C1.C1Preview.Export.ExportOptionsFormBase

C1.C1Preview.Export.ComplexExporterOptionsForm

C1.C1Preview.Export.HtmlOptionsForm

C1.C1Preview.Export.RtfOptionsForm

C1.C1Preview.Export.XlsOptionsForm

C1.C1Preview.Export.EmfOptionsForm

C1.C1Preview.Export.ImagesOptionsForm

C1.C1Preview.Export.PdfOptionsForm

C1.C1Preview.Export.ExportProviders ---- System.Collections.IEnumerable

C1.C1Preview.Export.PdfSecurity

System.ValueType

System.[Enum]

C1.C1Preview.Export.HtmlExporter.LinksLocationsEnum

C1.C1Preview.Export.HtmlExporter.LinksModeEnum

See Also

C1.C1Preview.Export Namespace


C1.C1Preview.Forms Hierarchy

C1.C1Preview.Forms Hierarchy

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Windows.Forms.Control

System.Windows.Forms.ScrollableControl

System.Windows.Forms.ContainerControl

System.Windows.Forms.Form

C1.C1Preview.Forms.BaseForm

C1.C1Preview.Forms.DocumentInfoForm

C1.C1Preview.Forms.OutputRangeForm

See Also

C1.C1Preview.Forms Namespace


C1.C1Preview Hierarchy

C1.C1Preview Hierarchy

System.Object

C1.C1Preview.ActionHandlerBase

C1.C1Preview.ActionHandlerFile

C1.C1Preview.ActionHandlerFileOpen

C1.C1Preview.ActionHandlerFileSave

C1.C1Preview.ActionHandlerHistoryNext

C1.C1Preview.ActionHandlerHistoryPrev

C1.C1Preview.ActionHandlerLink

C1.C1Preview.ActionHandlerPageSetup

C1.C1Preview.ActionHandlerPageView

C1.C1Preview.ActionHandlerPrint

C1.C1Preview.ActionHandlerReflow

C1.C1Preview.FragmentResolvedInfo

C1.C1Preview.AreaResolvedInfo

C1.C1Preview.ShapeResolvedInfo

C1.C1Preview.TextResolvedInfo

C1.C1Preview.C1Anchor

C1.C1Preview.C1AnchorText

System.Collections.CollectionBase

C1.C1Preview.C1AnchorCollection

C1.C1Preview.C1AnchorInfoCollection

C1.C1Preview.C1HyperlinkInfo.AreaCollection

C1.C1Preview.C1HyperlinkInfoCollection

C1.C1Preview.EmbeddedFontCollection

C1.C1Preview.InputActionCollection

C1.C1Preview.OwnedCollection

C1.C1Preview.OutlineNodeCollection

C1.C1Preview.PageCollection

C1.C1Preview.ParagraphObjectCollection

C1.C1Preview.PageColumnDefCollection

C1.C1Preview.RenderFragmentCollection

C1.C1Preview.RenderInputComboBoxItemCollection

C1.C1Preview.SplitCollection

C1.C1Preview.StyleCollection

C1.C1Preview.TabPositionCollection

C1.C1Preview.TagCollection

C1.C1Preview.UserCellGroupCollection

C1.C1Preview.C1AnchorInfo

C1.C1Preview.C1Hyperlink ---- System.ICloneable

C1.C1Preview.C1HyperlinkAttrs

C1.C1Preview.C1HyperlinkTextAttrs

C1.C1Preview.C1HyperlinkInfo

C1.C1Preview.C1HyperlinkInfo.Area ---- System.IDisposable

C1.C1Preview.C1LinkTarget

C1.C1Preview.C1LinkTargetAnchor

C1.C1Preview.C1LinkTargetExternalAnchor

C1.C1Preview.C1LinkTargetDocumentLocation

C1.C1Preview.C1LinkTargetFile

C1.C1Preview.C1LinkTargetPage

C1.C1Preview.C1LinkTargetUser

C1.C1Preview.C1PageSettings

System.MarshalByRefObject

System.ComponentModel.Component

C1.C1Preview.C1PrintDocument ---- C1.C1Preview.Serialization.IC1FormatVersionProvider, C1.C1Preview.Serialization.IC1SerializableObject, C1.C1Preview.IDocumentLocation

System.Windows.Forms.Control

C1.C1Preview.ScalableComboBox

System.Windows.Forms.ButtonBase

System.Windows.Forms.Button

C1.C1Preview.ScalableButton

System.Windows.Forms.CheckBox

C1.C1Preview.ScalableCheckBox

System.Windows.Forms.RadioButton

C1.C1Preview.ScalableRadioButton

System.Windows.Forms.TextBoxBase

System.Windows.Forms.TextBox

C1.C1Preview.ScalableTextBox

C1.C1Preview.C1PrintOptions ---- System.ComponentModel.INotifyPropertyChanged

C1.C1Preview.DictionaryItem

C1.C1Preview.DictionaryIcon

C1.C1Preview.DictionaryImage

C1.C1Preview.DocumentBody

C1.C1Preview.DocumentInfo ---- System.ICloneable

C1.C1Preview.DocumentPageLayouts

C1.C1Preview.ShapeProps

C1.C1Preview.LinePropsBase

C1.C1Preview.LineProps

C1.C1Preview.PolygonProps

C1.C1Preview.RectangleProps

C1.C1Preview.EllipsePartProps

C1.C1Preview.RoundRectangleProps

C1.C1Preview.EmbeddedFont ---- System.IDisposable

System.EventArgs

C1.C1Preview.LongOperationEventArgs

C1.C1Preview.InputAction

C1.C1Preview.LayoutChangeBase ---- System.ICloneable

C1.C1Preview.LayoutChangeNewColumn

C1.C1Preview.LayoutChangeNewLine

C1.C1Preview.LayoutChangeNewPage

C1.C1Preview.LayoutChangeNoBreak

C1.C1Preview.LengthBase

C1.C1Preview.LengthAbs

C1.C1Preview.LengthAuto

C1.C1Preview.LengthExp

C1.C1Preview.LengthAbs.Predefined

C1.C1Preview.Page ---- C1.C1Preview.IDocumentLocation

C1.C1Preview.PageColumnDef ---- System.ICloneable

C1.C1Preview.PageLayout ---- System.ICloneable

C1.C1Preview.PageNumberingChange

C1.C1Preview.ParagraphObject ---- System.ICloneable, C1.C1Preview.IDocumentLocation

C1.C1Preview.ParagraphImage

C1.C1Preview.ParagraphText

C1.C1Preview.PrintingUtil

C1.C1Preview.RenderObject ---- C1.C1Preview.IDocumentLocation

C1.C1Preview.RenderArea

C1.C1Preview.RenderC1Printable

C1.C1Preview.RenderToc

C1.C1Preview.RenderEmpty

C1.C1Preview.RenderGraphics

C1.C1Preview.RenderImage

C1.C1Preview.RenderInputBase

C1.C1Preview.RenderInputButtonBase

C1.C1Preview.RenderInputButton

C1.C1Preview.RenderInputCheckBox

C1.C1Preview.RenderInputRadioButton

C1.C1Preview.RenderInputComboBox

C1.C1Preview.RenderInputText

C1.C1Preview.RenderRichText

C1.C1Preview.RenderShapeBase

C1.C1Preview.RenderLineBase

C1.C1Preview.RenderLine

C1.C1Preview.RenderPolygon

C1.C1Preview.RenderRectangle

C1.C1Preview.RenderEllipse

C1.C1Preview.RenderArc

C1.C1Preview.RenderPie

C1.C1Preview.RenderRoundRectangle

C1.C1Preview.RenderTable

C1.C1Preview.RenderTextBase

C1.C1Preview.RenderParagraph

C1.C1Preview.RenderTocItem

C1.C1Preview.RenderText

C1.C1Preview.RenderFragment

C1.C1Preview.RenderAreaFragment

C1.C1Preview.RenderC1PrintableFragment

C1.C1Preview.RenderEmptyFragment

C1.C1Preview.RenderGraphicsFragment

C1.C1Preview.RenderImageFragment

C1.C1Preview.RenderInputFragment

C1.C1Preview.RenderRichTextFragment

C1.C1Preview.RenderShapeFragment

C1.C1Preview.RenderLineFragment

C1.C1Preview.RenderRectangleFragment

C1.C1Preview.RenderRoundRectangleFragment

C1.C1Preview.RenderTableFragment

C1.C1Preview.RenderTextFragmentBase

C1.C1Preview.RenderParagraphFragment

C1.C1Preview.RenderTocItemFragment

C1.C1Preview.RenderTextFragment

C1.C1Preview.RenderInputComboBoxItem

C1.C1Preview.Split

C1.C1Preview.SplitParams

C1.C1Preview.TableSplitParams

C1.C1Preview.Style

C1.C1Preview.TableCell ---- System.IComparable, C1.C1Preview.IDocumentLocation

C1.C1Preview.TableVector ---- System.IComparable, C1.C1Preview.IDocumentLocation

C1.C1Preview.TableCol

C1.C1Preview.TableRow

C1.C1Preview.TableVectorGroup ---- System.IComparable, C1.C1Preview.IDocumentLocation

C1.C1Preview.TabPosition

C1.C1Preview.TagBase

C1.C1Preview.Tag

C1.C1Preview.TagSys

C1.C1Preview.TagPageCount

C1.C1Preview.TagPageNo

C1.C1Preview.TagPageX

C1.C1Preview.TagPageXCount

C1.C1Preview.TagPageY

C1.C1Preview.TagPageYCount

C1.C1Preview.TitleResolvedInfo

C1.C1Preview.UserCellGroup ---- C1.C1Preview.IDocumentLocation

C1.C1Preview.Utils

System.ValueType

C1.C1Preview.Borders

C1.C1Preview.GridLines

C1.C1Preview.ImageAlign

C1.C1Preview.RectangleD

C1.C1Preview.SizeD

C1.C1Preview.SplitPos

C1.C1Preview.Unit

C1.C1Preview.UnitPoint

System.[Enum]

C1.C1Preview.AlignHorzEnum

C1.C1Preview.AlignVertEnum

C1.C1Preview.BreakEnum

C1.C1Preview.C1HyperlinkStateEnum

C1.C1Preview.CellSplitBehaviorEnum

C1.C1Preview.CheckMarkStyleEnum

C1.C1Preview.DimensionEnum

C1.C1Preview.DocumentActionEnum

C1.C1Preview.DocumentCreationMode

C1.C1Preview.DocumentInfoFields

C1.C1Preview.DrawingFlagsEnum

C1.C1Preview.FormsKeyActionEnterEnum

C1.C1Preview.FormsKeyActionTabEnum

C1.C1Preview.GenerateErrorEnum

C1.C1Preview.ImageAlignHorzEnum

C1.C1Preview.ImageAlignVertEnum

C1.C1Preview.PageBreakBehaviorEnum

C1.C1Preview.PageDirectionEnum

C1.C1Preview.PageJumpTypeEnum

C1.C1Preview.PageNumberingChangeModeEnum

C1.C1Preview.PageScalingEnum

C1.C1Preview.RefDim

C1.C1Preview.ReferenceEnum

C1.C1Preview.ReresolvingModeEnum

C1.C1Preview.SplitTypeEnum

C1.C1Preview.StackingRulesEnum

C1.C1Preview.StretchColumnEnum

C1.C1Preview.StretchTableEnum

C1.C1Preview.TableFooterEnum

C1.C1Preview.TableHeaderEnum

C1.C1Preview.TextPositionEnum

C1.C1Preview.UnicodeRangeEnum

C1.C1Preview.UnitTypeEnum

C1.C1Preview.UserActionEnum

See Also

C1.C1Preview Namespace


C1.C1Preview.Serialization Hierarchy

C1.C1Preview.Serialization Hierarchy

System.Object

System.Attribute

C1.C1Preview.Serialization.C1NameAlias

C1.C1Preview.Serialization.C1FormatVersion

See Also

C1.C1Preview.Serialization Namespace


C1.Win.C1Preview Hierarchy

C1.Win.C1Preview Hierarchy

System.Object

C1.Win.C1Preview.C1PreviewCursors

System.MarshalByRefObject

System.ComponentModel.Component

System.Windows.Forms.Control

System.Windows.Forms.ListView

C1.Win.C1Preview.C1PreviewThumbnailView ---- System.ComponentModel.INotifyPropertyChanged

System.Windows.Forms.ScrollableControl

System.Windows.Forms.ContainerControl

System.Windows.Forms.Form

C1.Win.C1Preview.C1PrintPreviewDialog

System.Windows.Forms.ToolStripContainer

C1.Win.C1Preview.C1PrintPreviewControl

System.Windows.Forms.UserControl

C1.Win.C1Preview.C1PreviewTextSearchPanel

System.Windows.Forms.Panel

C1.Win.C1Preview.C1PreviewPane ---- h, System.ComponentModel.INotifyPropertyChanged, System.ComponentModel.ISupportInitialize, q

System.Windows.Forms.TreeView

C1.Win.C1Preview.C1PreviewOutlineView ---- System.ComponentModel.INotifyPropertyChanged

System.Windows.Forms.ToolTip

C1.Win.C1Preview.PreviewToolTip

C1.Win.C1Preview.C1PreviewPane.BusySection ---- System.IDisposable

C1.Win.C1Preview.C1PreviewPane.LayoutSection ---- System.IDisposable

System.Collections.CollectionBase

C1.Win.C1Preview.PreviewPages

System.EventArgs

C1.Win.C1Preview.DocumentActionEventArgs

C1.Win.C1Preview.FormsUserActionEventArgs

C1.Win.C1Preview.HyperlinkEventArgs

C1.Win.C1Preview.HyperlinkJumpEventArgs

C1.Win.C1Preview.SaveVisitedDocumentEventArgs

C1.Win.C1Preview.LoadVisitedDocumentEventArgs

System.ComponentModel.CancelEventArgs

C1.Win.C1Preview.HistoryItemAddingEventArgs

C1.Win.C1Preview.VisitedDocumentAddingEventArgs

System.Windows.Forms.MouseEventArgs

C1.Win.C1Preview.HyperlinkMouseEventArgs

C1.Win.C1Preview.ExporterOptions

C1.Win.C1Preview.HistoryOptions ---- System.ComponentModel.INotifyPropertyChanged

System.Collections.Hashtable

C1.Win.C1Preview.KeyMap

System.Collections.Generic.40513, Culture=neutral, PublicKeyToken=594a0605db190bb9]]

C1.Win.C1Preview.KeyMapStack

C1.Win.C1Preview.PreviewHistoryOptions

C1.Win.C1Preview.ViewHistoryItem

C1.Win.C1Preview.VisitedDocument

C1.Win.C1Preview.VisitedDocumentStorage ---- System.IDisposable

C1.Win.C1Preview.VisitedDocumentStorageC1Doc

C1.Win.C1Preview.VisitedDocumentStorageImages

System.ValueType

C1.Win.C1Preview.ViewState

System.[Enum]

C1.Win.C1Preview.C1PreviewActionEnum

C1.Win.C1Preview.C1PreviewActionFlags

C1.Win.C1Preview.HideMarginsFlags

C1.Win.C1Preview.HistorySavedActionsEnum

C1.Win.C1Preview.ImageSetEnum

C1.Win.C1Preview.MouseModeEnum

C1.Win.C1Preview.PageLayoutEnum

C1.Win.C1Preview.ShowRulersFlags

C1.Win.C1Preview.VisitedDocumentStorageEnum

C1.Win.C1Preview.ZoomModeEnum

System.[Delegate]

System.MulticastDelegate

C1.Win.C1Preview.HistoryItemAddingEventHandler

C1.Win.C1Preview.KeyMap.DoAction

C1.Win.C1Preview.LoadVisitedDocumentEventHandler

C1.Win.C1Preview.SaveVisitedDocumentEventHandler

C1.Win.C1Preview.VisitedDocumentAddingEventHandler

See Also

C1.Win.C1Preview Namespace


Creating a 3x3 Table - C#

C#

private void Form1_Load(object sender, System.EventArgs e)

{

}


Creating a 3x3 Table - C# 2

C#

C1.C1Preview.RenderTable table = new C1.C1Preview.RenderTable(this.c1PrintDocument1);


Creating a 3x3 Table - C# 3

C#

// Add 3 rows

const int r = 3;

// Add 3 columns

const int c = 3;

for (int row = 0; row < r; ++row)

{

for (int col = 0; col < c; ++col)

{

C1.C1Preview.RenderText celltext = new C1.C1Preview.RenderText(this.c1PrintDocument1);

celltext.Text = string.Format("", row, col);

// Add empty cells

table.Cells[row, col].RenderObject = celltext;

}

}


Creating a 3x3 Table - C# 4

C#

table.Rows[0].Height = new C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm);

table.Rows[1].Height = new C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm);

table.Rows[2].Height = new C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm);

table.Cols[0].Width = new C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm);

table.Cols[1].Width = new C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm);

table.Cols[2].Width = new C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm);


Creating a 3x3 Table - C# 5

C#

table.Style.GridLines.All = new LineDef(Color.DarkGray);


Creating a 3x3 Table - C# 6

C#

this.C1PrintDocument1.Body.Children.Add(table);

this.c1PrintDocument1.Generate();


Creating a 3x3 Table - Delphi

Delphi

procedure Form1.CreateForm(sender: System.Object; e: System.EventArgs);


Creating a 3x3 Table - Delphi 2

Delphi

var

table : RenderTable;

begin

table :=
C1.C1Preview.RenderTable.Create(Self.c1PrintDocument1);

end;


Creating a 3x3 Table - Delphi 3

Delphi

const r : Integer = 3;

const c : Integer = 3;

row := 0;

while (row < r) do

begin

col := 0;

while (col < c) do

begin

celltext := C1.C1Preview.RenderText.Create(Self.c1PrintDocument1);

celltext.Text := Format('', row, col);

// Add empty cells

table.Cells[row, col].RenderObject := celltext;

end;

end;


Creating a 3x3 Table - Delphi 4

Delphi

table.Rows[0].Height := C1.C1Preview.Unit.Create(5, C1.C1Preview.UnitTypeEnum.Cm);

table.Rows[1].Height := C1.C1Preview.Unit.Create(5, C1.C1Preview.UnitTypeEnum.Cm);

table.Rows[2].Height := C1.C1Preview.Unit.Create(5, C1.C1Preview.UnitTypeEnum.Cm);

table.Cols[0].Width := C1.C1Preview.Unit.Create(5, C1.C1Preview.UnitTypeEnum.Cm);

table.Cols[1].Width := C1.C1Preview.Unit.Create(5, C1.C1Preview.UnitTypeEnum.Cm);

table.Cols[2].Width := C1.C1Preview.Unit.Create(5, C1.C1Preview.UnitTypeEnum.Cm);


Creating a 3x3 Table - Delphi 5

Delphi

table.Style.GridLines.All := new LineDef(Color.DarkGray);


Creating a 3x3 Table - Delphi 6

Delphi

Self.C1PrintDocument1.Body.Children.Add(table);

Self.C1PrintDocument1.Generate;


Creating a 3x3 Table - Visual Basic

Visual Basic

Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

End Sub


Creating a 3x3 Table - Visual Basic 2

Visual Basic

Dim table As C1.C1Preview.RenderTable = New C1.C1Preview.RenderTable(Me.C1PrintDocument1)


Creating a 3x3 Table - Visual Basic 3

Visual Basic

' Add 3 rows

Dim r As Integer = 3

' Add 3 columns

Dim c As Integer = 3

Dim row As Integer

Dim col As Integer

For row = 0 To r - 1 Step +1

For col = 0 To c - 1 Step +1

Dim celltext As C1.C1Preview.RenderText = New C1.C1Preview.RenderText(Me.C1PrintDocument1)

' Add empty cells

celltext.Text = String.Format("", row, col)

table.Cells(row, col).RenderObject = celltext

Next

Next


Creating a 3x3 Table - Visual Basic 4

Visual Basic

table.Rows(0).Height = New C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm)

table.Rows(1).Height = New C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm)

table.Rows(2).Height = New C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm)

table.Cols(0).Width = New C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm)

table.Cols(1).Width = New C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm)

table.Cols(2).Width = New C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm)


Creating a 3x3 Table - Visual Basic 5

Visual Basic

table.Style.GridLines.All = New C1.C1Preview.LineDef(Color.DarkGray)


Creating a 3x3 Table - Visual Basic 6

Visual Basic

Me.C1PrintDocument1.Body.Children.Add(table)

Me.C1PrintDocument1.Generate()


Creating a Background Color for Specific Cells - C#

C#

private void Form1_Load(object sender, System.EventArgs e)

{

// make a table

C1.C1Preview.RenderTable table = new C1.C1Preview.RenderTable(this.c1PrintDocument1);

table.Style.GridLines.All = new LineDef(Color.DarkGray);

const int r = 3;

const int c = 3;

for (int row = 0; row < r; ++row)

{

for (int col = 0; col < c; ++col)

{

C1.C1Preview.RenderText celltext = new C1.C1Preview.RenderText(this.c1PrintDocument1);

celltext.Text = string.Format("", row, col);

// Add empty cells

table.Cells[row, col].RenderObject = celltext;

}

}

// generate the document

this.C1PrintDocument1.Body.Children.Add(table);

this.c1PrintDocument1.Generate();

}


Creating a Background Color for Specific Cells - C# 2

C#

table.Rows[0].Height = new C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm);

table.Rows[1].Height = new C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm);

table.Rows[2].Height = new C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm);

table.Cols[0].Width = new C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm);

table.Cols[1].Width = new C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm);

table.Cols[2].Width = new C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm);


Creating a Background Color for Specific Cells - C# 3

C#

table.Cells(1, 2).CellStyle.BackColor = Color.Crimson;


Creating a Background Color for Specific Cells - C# 4

C#

table.Cells(0, 1).CellStyle.BackColor = Color.BlueViolet;


Creating a Background Color for Specific Cells - Delphi

Delphi

procedure MainForm.Form1_Load(sender: System.Object; e: System.EventArgs);

var

table : C1.C1PrintDocument.RenderTable

begin

// make a table

table := C1.C1Preview.RenderTable.Create(Self.c1PrintDocument1);

table.Style.GridLines.All := new LineDef(Color.DarkGray);

const r : Integer = 3;

const c : Integer = 3;

row := 0;

while (row < r) do

begin

col := 0;

while (col < c) do

begin

celltext := C1.C1Preview.RenderText.Create(Self.c1PrintDocument1);

celltext.Text := Format('', row, col);

// Add empty cells

table.Cells[row, col].RenderObject := celltext;

end;

end;

// generate the document

Self.C1PrintDocument1.Body.Children.Add(table);

Self.C1PrintDocument1.Generate;

end;


Creating a Background Color for Specific Cells - Delphi 2

Delphi

table.Rows[0].Height := C1.C1Preview.Unit.Create(5, C1.C1Preview.UnitTypeEnum.Cm);

table.Rows[1].Height := C1.C1Preview.Unit.Create(5, C1.C1Preview.UnitTypeEnum.Cm);

table.Rows[2].Height := C1.C1Preview.Unit.Create(5, C1.C1Preview.UnitTypeEnum.Cm);

table.Cols[0].Width := C1.C1Preview.Unit.Create(5, C1.C1Preview.UnitTypeEnum.Cm);

table.Cols[1].Width := C1.C1Preview.Unit.Create(5, C1.C1Preview.UnitTypeEnum.Cm);

table.Cols[2].Width := C1.C1Preview.Unit.Create(5, C1.C1Preview.UnitTypeEnum.Cm);


Creating a Background Color for Specific Cells - Delphi 3

Delphi

table.Cells(1, 2).CellStyle.BackColor := Color.Crimson;


Creating a Background Color for Specific Cells - Delphi 4

Delphi

table.Cells(0, 1).CellStyle.BackColor := Color.BlueViolet;


Creating a Background Color for Specific Cells - Visual Basic

Visual Basic

Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

' make a table

Dim table As C1.C1Preview.RenderTable = New C1.C1Preview.RenderTable(Me.C1PrintDocument1)

table.Style.GridLines.All = New C1.C1Preview.LineDef(Color.DarkGray)

Dim r As Integer = 3

Dim c As Integer = 3

Dim row As Integer

Dim col As Integer

For row = 0 To r - 1 Step +1

For col = 0 To c - 1 Step +1

Dim celltext As C1.C1Preview.RenderText = New C1.C1Preview.RenderText(Me.C1PrintDocument1)

' Add empty cells

celltext.Text = String.Format("", row, col)

table.Cells(row, col).RenderObject = celltext

Next

Next

' generate the document

Me.C1PrintDocument1.Body.Children.Add(table)

Me.C1PrintDocument1.Generate()

End Sub


Creating a Background Color for Specific Cells - Visual Basic 2

Visual Basic

table.Rows(0).Height = New C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm)

table.Rows(1).Height = New C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm)

table.Rows(2).Height = New C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm)

table.Cols(0).Width = New C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm)

table.Cols(1).Width = New C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm)

table.Cols(2).Width = New C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm)


Creating a Background Color for Specific Cells - Visual Basic 3

Visual Basic

table.Cells(1, 2).CellStyle.BackColor = Color.Crimson


Creating a Background Color for Specific Cells - Visual Basic 4

Visual Basic

table.Cells(0, 1).CellStyle.BackColor = Color.BlueViolet


Creating a Background Color for the Page Header - C#

C#

private void Form1_Load(object sender, System.EventArgs e)

{

this.c1PrintDocument1.StartDoc();

C1.C1Preview.RenderTable theader = new
C1.C1Preview.RenderTable(this.c1PrintDocument1);


Creating a Background Color for the Page Header - C# 2

C#

theader.Style.BackColor = Color.Gold;


Creating a Background Color for the Page Header - C# 3

C#

theader.Cells(0, 0).Style.TextAlignHorz =
C1.C1Preview.AlignHorzEnum.Right;

//set up some styles

theader.CellStyle.Font = new Font("Arial", 14);

//assign text

theader.Cells(0, 0).Text = "Swim Team Practice Schedule";

//set the table as the page header

this.c1PrintDocument1.RenderBlock(theader);

this.c1PrintDocument1.EndDoc();

}


Creating a Background Color for the Page Header - Delphi

Delphi

procedure Form1.CreateForm(sender: System.Object; e: System.EventArgs);

var

theader : C1.C1PrintDocument.RenderTable;

begin

Self.c1PrintDocument1.StartDoc;

theader :=
C1.C1Preview.RenderTable.Create(Self.c1PrintDocument1);


Creating a Background Color for the Page Header - Delphi 2

Delphi

theader.Style.BackColor := Color.Gold;


Creating a Background Color for the Page Header - Delphi 3

Delphi

theader.Cells(0, 0).Style.TextAlignHorz =
C1.C1Preview.AlignHorzEnum.Right;

//set up some styles

theader.CellStyle.Font = new Font("Arial", 14);

//assign text

theader.Cells(0, 0).Text = "Swim Team Practice Schedule";

//set the table as the page header

this.c1PrintDocument1.RenderBlock(theader);

this.c1PrintDocument1.EndDoc();

}


Creating a Background Color for the Page Header - Visual Basic

Visual Basic

Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As
System.EventArgs) Handles MyBase.Load

Me.C1PrintDocument1.StartDoc()

Dim theader As New C1.C1Preview.RenderTable(Me.C1PrintDocument1)


Creating a Background Color for the Page Header - Visual Basic 2

Visual Basic

theader.Style.BackColor = Color.Gold


Creating a Background Color for the Page Header - Visual Basic 3

Visual Basic

theader.Cells(0, 0).Style.TextAlignHorz =
C1.C1Preview.AlignHorzEnum.Right

'set up some styles

theader.CellStyle.Font = New Font("Arial", 14)

'assign text

theader.Cells(0, 0).Text = "Swim Team Practice Schedule"

'set the table as the page header

Me.C1PrintDocument1.RenderBlock(theader)

Me.C1PrintDocument1.EndDoc()

End Sub

End Class


Creating a Page Footer - C#

C#

private void Form1_Load(object sender, System.EventArgs e)

{

C1.C1Preview.RenderTable rt1 = new
C1.C1Preview.RenderTable(c1PrintDocument1);

// create a table with 100 rows, 4 columns, and text

const int r = 100;

const int c = 4;

for (int row = 0; row < r; ++row)

{

for (int col = 0; col < c; ++col)

{

RenderText celltext = new RenderText(this.c1PrintDocument1);

celltext.Text = string.Format("Cell ({0},{1})", row, col);

rt1.Cells[row, col].RenderObject = celltext;

}

}

// add the table to the document

this.c1PrintDocument1.Body.Children.Add(rt1);


Creating a Page Footer - C# 2

C#

' set up the table footer

rt1.RowGroups(rt1.Rows.Count - 2, 2).PageFooter = True

rt1.RowGroups(rt1.Rows.Count - 2, 2).Style.BackColor = Color.LemonChiffon

rt1.RowGroups(rt1.Rows.Count - 2, 2).Style.Font = New Font("Arial", 10, FontStyle.Bold)


Creating a Page Footer - C# 3

C#

// add table footer text

rt1.Cells[rt1.Rows.Count - 2, 0].SpanRows = 2;

rt1.Cells[rt1.Rows.Count - 2, 0].SpanCols = rt1.Cols.Count - 1;

rt1.Cells[rt1.Rows.Count - 2, 0].Style.TextAlignHorz = AlignHorzEnum.Center;

rt1.Cells[rt1.Rows.Count - 2, 0].Style.TextAlignVert = AlignVertEnum.Center;

((RenderText)rt1.Cells[rt1.Rows.Count - 2, 0].RenderObject).Text = "This is a table footer.";

// add page numbers

rt1.Cells[rt1.Rows.Count - 2, 3].SpanRows = 2;

rt1.Cells[rt1.Rows.Count - 2, 3].Style.TextAlignHorz = AlignHorzEnum.Right;

rt1.Cells[rt1.Rows.Count – 2, 3].Style.TextAlignVert = AlignVertEnum.Center;

// tags (such as page no/page count) can be inserted anywhere in the document

((RenderText)rt1.Cells[rt1.Rows.Count - 2, 3].RenderObject).Text = "Page [PageNo] of [PageCount]";

this.c1PrintDocument1.Generate();


Creating a Page Footer - Delphi

Delphi

var

theader : C1.C1Preview.RenderTable;

r, c, row, col : Integer;

begin

theader := C1.C1Preview.RenderTable.Create(c1PrintDocument1)

r := 100;

c := 4;

for row := 0 to (r – 1) do

begin

for col := 0 to (c – 1) do

celltext := RenderText.Create(Self.c1PrintDocument1);

celltext.Text := Format('Cell ({0},{1})', row, col);

rt1.Cells[row, col].RenderObject := celltext;

end;

Self.c1PrintDocument1.Body.Children.Add(rt1);


Creating a Page Footer - Delphi 2

Delphi

// set up the table footer

rt1.RowGroups[(rt1.Rows.Count - 2)].PageFooter := True;

rt1.RowGroups[(rt1.Rows.Count - 2)].Style.BackColor := Color.LemonChiffon;

rt1.RowGroups[(rt1.Rows.Count - 2)].Style.font := Font.Create('Arial', 10, FontStyle.Bold);


Creating a Page Footer - Delphi 3

Delphi

// add table footer text

rt1.Cells[(rt1.Rows.Count - 2)].SpanRows := 2;

rt1.Cells[(rt1.Rows.Count - 2)].SpanCols := (rt1.Cols.Count - 1);

rt1.Cells[(rt1.Rows.Count - 2)].Style.TextAlignHorz := AlignHorzEnum.Center;

rt1.Cells[(rt1.Rows.Count - 2)].Style.TextAlignVert := AlignVertEnum.Center;

(RenderText(rt1.Cells[(rt1.Rows.Count - 2)].RenderObject)).Text := 'This is a table footer.';

// add page numbers

rt1.Cells[(rt1.Rows.Count - 2)].SpanRows := 2;

rt1.Cells[(rt1.Rows.Count - 2)].Style.TextAlignHorz := AlignHorzEnum.Right;

rt1.Cells[rt1.Rows.Count].Style.TextAlignVert := AlignVertEnum.Center;

(RenderText(rt1.Cells[(rt1.Rows.Count - 2)].RenderObject)).Text := 'Page [PageNo] of [PageCount]';

Self.c1PrintDocument1.Generate;


Creating a Page Footer - Visual Basic

Visual Basic

Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

Dim rt1 As New C1.C1Preview.RenderTable(Me.C1PrintDocument1)

' create a table with 100 rows, 4 columns, and text

Dim r As Integer = 100

Dim c As Integer = 4

Dim row As Integer

Dim col As Integer

For row = 0 To r - 1 Step +1

For col = 0 To c - 1 Step +1

Dim celltext As RenderText = New RenderText(Me.C1PrintDocument1)

celltext.Text = String.Format("Cell ({0},{1})", row, col)

rt1.Cells(row, col).RenderObject = celltext

Next

Next

' add the table to the document

Me.C1PrintDocument1.Body.Children.Add(rt1)


Creating a Page Footer - Visual Basic 2

Visual Basic

' set up the table footer

rt1.RowGroups(rt1.Rows.Count - 2, 2).PageFooter = True

rt1.RowGroups(rt1.Rows.Count - 2, 2).Style.BackColor = Color.LemonChiffon

rt1.RowGroups(rt1.Rows.Count - 2, 2).Style.Font = New Font("Arial", 10, FontStyle.Bold)


Creating a Page Footer - Visual Basic 3

Visual Basic

'Add table footer text

rt1.Cells(rt1.Rows.Count - 2, 0).SpanRows = 2

rt1.Cells(rt1.Rows.Count - 2, 0).SpanCols = rt1.Cols.Count - 1

rt1.Cells(rt1.Rows.Count - 2, 0).Style.TextAlignHorz = AlignHorzEnum.Left

rt1.Cells(rt1.Rows.Count - 2, 0).Style.TextAlignVert = AlignVertEnum.Center

Dim tf As RenderText = New RenderText(Me.C1PrintDocument1)

tf = CType(rt1.Cells(rt1.Rows.Count - 2, 0).RenderObject, RenderText)

tf.Text = "This is a table footer."

' Add page numbers

rt1.Cells(rt1.Rows.Count - 2, 3).SpanRows = 2

rt1.Cells(rt1.Rows.Count - 2, 3).Style.TextAlignHorz = AlignHorzEnum.Right

rt1.Cells(rt1.Rows.Count - 2, 3).Style.TextAlignVert = AlignVertEnum.Center

' tags (such as page no/page count) can be inserted anywhere in the document

Dim pn As RenderText = New RenderText(Me.C1PrintDocument1)

pn = CType(rt1.Cells(rt1.Rows.Count - 2, 3).RenderObject, RenderText)

pn.Text = "Page [PageNo] of [PageCount]"

Me.C1PrintDocument1.Generate()


Creating a Page Header - C#

C#

private void Form1_Load(object sender, System.EventArgs e)

{

this.c1PrintDocument1.StartDoc();

C1.C1Preview.RenderTable theader = new
C1.C1Preview.RenderTable(c1PrintDocument1);


Creating a Page Header - C# 2

C#

//set up alignment for the columns of the header

theader.Cells(0, 0).Style.TextAlignHorz = AlignHorzEnum.Left;

theader.Cells(0, 1).Style.TextAlignHorz = AlignHorzEnum.Center;

theader.Cells(0, 2).Style.TextAlignHorz = AlignHorzEnum.Right;

theader.CellStyle.Font = new Font("Arial", 14);


Creating a Page Header - C# 3

C#

theader.Cells(0, 0).Text = "Left part";

theader.Cells(0, 1).Text = "Center part";

theader.Cells(0, 2).Text = "Right part";

this.c1PrintDocument1.RenderBlock(theader);

this.c1PrintDocument1.EndDoc();


Creating a Page Header - Delphi

Delphi

var

theader : C1.C1Preview.RenderTable;

begin

Self.c1PrintDocument.StartDoc;

theader := C1.C1Preview.RenderTable.Create(c1PrintDocument1)


Creating a Page Header - Delphi 2

Delphi

//set up alignment for the columns of the header

theader.Cells(0, 0).Style.TextAlignHorz := AlignHorzEnum.Left;

theader.Cells(0, 1).Style.TextAlignHorz := AlignHorzEnum.Center;

theader.Cells(0, 2).Style.TextAlignHorz := AlignHorzEnum.Right;

theader.CellStyle.Font := Font.Create('Arial', 14);


Creating a Page Header - Delphi 3

Delphi

theader.Cells(0, 0).Text := 'Left part';

theader.Cells(0, 1).Text := 'Center part';

theader.Cells(0, 2).Text := 'Right part';

c1PrintDocument1.RenderBlock(theader);

c1PrintDocument1.EndDoc;


Creating a Page Header - Visual Basic

Visual Basic

Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

Me.C1PrintDocument1.StartDoc()

Dim theader As New C1.C1Preview.RenderTable(Me.C1PrintDocument1)


Creating a Page Header - Visual Basic 2

Visual Basic

'set up alignment for the parts of the header

theader.Cells(0, 0).Style.TextAlignHorz = AlignHorzEnum.Left

theader.Cells(0, 1).Style.TextAlignHorz = AlignHorzEnum.Center

theader.Cells(0, 2).Style.TextAlignHorz = AlignHorzEnum.Right

theader.CellStyle.Font = New Font("Arial", 14)


Creating a Page Header - Visual Basic 3

Visual Basic

theader.Cells(0, 0).Text = "Left part"

theader.Cells(0, 1).Text = "Center part"

theader.Cells(0, 2).Text = "Right part"

C1PrintDocument1.RenderBlock(theader)

C1PrintDocument1.EndDoc()


Creating Borders Around Rows and Columns - C#

C#

private void Form1_Load(object sender, System.EventArgs e)

{

// make a table

C1.C1Preview.RenderTable table = new C1.C1Preview.RenderTable(this.c1PrintDocument1);

table.Style.GridLines.All = new LineDef(Color.DarkGray);

const int r = 3;

const int c = 3;

for (int row = 0; row < r; ++row)

{

for (int col = 0; col < c; ++col)

{

C1.C1Preview.RenderText celltext = new C1.C1Preview.RenderText(this.c1PrintDocument1);

celltext.Text = string.Format("", row, col);

// Add empty cells

table.Cells[row, col].RenderObject = celltext;

}

}

// generate the document

this.C1PrintDocument1.Body.Children.Add(table);

this.c1PrintDocument1.Generate();

}


Creating Borders Around Rows and Columns - C# 2

C#

table.Rows[0].Height = new C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm);

table.Rows[1].Height = new C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm);

table.Rows[2].Height = new C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm);

table.Cols[0].Width = new C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm);

table.Cols[1].Width = new C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm);

table.Cols[2].Width = new C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm);


Creating Borders Around Rows and Columns - C# 3

C#

table.Rows[2].Style.Borders.All =
new C1.C1Preview.LineDef("2pt", Color.Red);


Creating Borders Around Rows and Columns - C# 4

C#

table.Cols[0].Style.Borders.All =
new C1.C1Preview.LineDef("6pt", Color.Blue);


Creating Borders Around Rows and Columns - Delphi

Delphi

procedure MainForm.Form1_Load(sender: System.Object; e: System.EventArgs);

var

table : C1.C1PrintDocument.RenderTable

begin

// make a table

table := C1.C1Preview.RenderTable.Create(Self.c1PrintDocument1);

table.Style.GridLines.All := new LineDef(Color.DarkGray);

const r : Integer = 3;

const c : Integer = 3;

row := 0;

while (row < r) do

begin

col := 0;

while (col < c) do

begin

celltext := C1.C1Preview.RenderText.Create(Self.c1PrintDocument1);

celltext.Text := Format('', row, col);

// Add empty cells

table.Cells[row, col].RenderObject := celltext;

end;

end;

// generate the document

Self.C1PrintDocument1.Body.Children.Add(table);

Self.C1PrintDocument1.Generate;

end;


Creating Borders Around Rows and Columns - Delphi 2

Delphi

table.Rows[0].Height := C1.C1Preview.Unit.Create(5, C1.C1Preview.UnitTypeEnum.Cm);

table.Rows[1].Height := C1.C1Preview.Unit.Create(5, C1.C1Preview.UnitTypeEnum.Cm);

table.Rows[2].Height := C1.C1Preview.Unit.Create(5, C1.C1Preview.UnitTypeEnum.Cm);

table.Cols[0].Width := C1.C1Preview.Unit.Create(5, C1.C1Preview.UnitTypeEnum.Cm);

table.Cols[1].Width := C1.C1Preview.Unit.Create(5, C1.C1Preview.UnitTypeEnum.Cm);

table.Cols[2].Width := C1.C1Preview.Unit.Create(5, C1.C1Preview.UnitTypeEnum.Cm);


Creating Borders Around Rows and Columns - Delphi 3

Delphi

table.Rows[2].Style.Borders.All :=
C1.C1Preview.LineDef.Create("2pt", Color.Red);


Creating Borders Around Rows and Columns - Delphi 4

Delphi

table.Cols[0].Style.Borders.All :=
C1.C1Preview.LineDef.Create("6pt", Color.Blue);


Creating Borders Around Rows and Columns - Visual Basic

Visual Basic

Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

' make a table

Dim table As C1.C1Preview.RenderTable = New C1.C1Preview.RenderTable(Me.C1PrintDocument1)

table.Style.GridLines.All = New C1.C1Preview.LineDef(Color.DarkGray)

Dim r As Integer = 3

Dim c As Integer = 3

Dim row As Integer

Dim col As Integer

For row = 0 To r - 1 Step +1

For col = 0 To c - 1 Step +1

Dim celltext As C1.C1Preview.RenderText = New C1.C1Preview.RenderText(Me.C1PrintDocument1)

' Add empty cells

celltext.Text = String.Format("", row, col)

table.Cells(row, col).RenderObject = celltext

Next

Next

' generate the document

Me.C1PrintDocument1.Body.Children.Add(table)

Me.C1PrintDocument1.Generate()

End Sub


Creating Borders Around Rows and Columns - Visual Basic 2

Visual Basic

table.Rows(0).Height = New C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm)

table.Rows(1).Height = New C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm)

table.Rows(2).Height = New C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm)

table.Cols(0).Width = New C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm)

table.Cols(1).Width = New C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm)

table.Cols(2).Width = New C1.C1Preview.Unit(5, C1.C1Preview.UnitTypeEnum.Cm)


Creating Borders Around Rows and Columns - Visual Basic 3

Visual Basic

table.Rows(2).Style.Borders.All = _
New C1.C1Preview.LineDef("2pt", Color.Red)


Creating Borders Around Rows and Columns - Visual Basic 4

Visual Basic

table.Cols(0).Style.Borders.All = _
New C1.C1Preview.LineDef("6pt", Color.Blue)


Dictionary - C#

C#

c1PrintDocument1.Dictionary.Add(
new DictionaryImage("image1", Image.FromFile("myImage.jpg")));


Dictionary - C# 2

C#

RenderImage ri = new RenderImage();
ri.ImageName = "image1";


Dictionary - Delphi

Delphi

c1PrintDocument1.Dictionary.Add(DictionaryImage.Create(
'image1', Image.FromFile('myImage.jpg')));


Dictionary - Delphi 2

Delphi

ri := RenderImage.Create;

ri.ImageName := 'image1';


Dictionary - Visual Basic

Visual Basic

c1PrintDocument1.Dictionary.Add(New DictionaryImage(
"image1", Image.FromFile("myImage.jpg")))


Dictionary - Visual Basic 2

Visual Basic

Dim ri As New RenderImage()

ri.ImageName = "image1"


Drawing a Horizontal Line - C#

C#

C1.C1PrintPreview.RenderLine rl = new
RenderLine(this.c1PrintDocument1);

rl.X = this.c1PrintDocument1.PageLayout.PageSettings.Width;

LineDef ld = new LineDef("4mm", Color.SteelBlue)

this.c1PrintDocument1.RenderBlockHorzLine(rl.X, ld);


Drawing a Horizontal Line - Delphi

Delphi

var

rl : C1.C1PrintDocument.RenderLine;

begin

rl := Create.RenderLine;

rl.X := Self.c1PrintDocument1.PageLayout.PageSetting.Width;

ld := LineDef.Create('4mm', Color.SteelBlue);

Self.c1PrintDocument1.RenderBlockHorzLine(rl.X, ld);

end;


Drawing a Horizontal Line - Visual Basic

Visual Basic

Dim rl As New C1.C1Preview.RenderLine(Me.C1PrintDocument1)

rl.X = Me.C1PrintDocument1.PageLayout.PageSettings.Width

Dim ld As New LineDef("4mm", Color.SteelBlue)

Me.C1PrintDocument1.RenderBlockHorzLine(rl.X, ld)


Groups of Rows and Columns - C#

C#

rt1.RowGroups[0, 2].Header = TableHeaderEnum.Page;


Groups of Rows and Columns - C# 2

C#

// create and fill the table

RenderTable rt1 = new RenderTable();

for (int row = 0; row < 100; ++row)

for (int col = 0; col < 10, ++col)

rt1.Cells[row, col].Text = string.Format(

"Text in cell({0}, {1})", row, col);

// set the table and columns’ widths

rt1.Width = Unit.Auto;

for (int col = 0; col < 10; ++col)

rt1.Cols[col].Width = "1in";

// assign first 2 rows as header, set background

rt1.RowGroups[0, 2].PageHeader = true;

rt1.RowGroups[0, 2].Style.BackColor = Color.Red;

// assign last 2 rows as footer, set background

rt1.RowGroups[98, 2].PageFooter = true;

rt1.RowGroups[98, 2]. Style.BackColor = Color.Blue;

// assign first column as header

rt1.ColGroups[0, 1].PageHeader = true;

rt1.ColGroups[0, 1].Style.BackColor = Color.BlueViolet;

// assign last column as footer

rt1.ColGroups[9, 1].PageFooter = true;

rt1.ColGroups[9, 1]. Style.BackColor = Color.BurlyWood;


Groups of Rows and Columns - Delphi

Delphi

rt1.RowGroups(0, 2).Header := TableHeaderEnum.Page;


Groups of Rows and Columns - Delphi 2

Delphi

// create and fill the table

rt1 := RenderTable.Create;

row := 0;

while (row < 100) do

begin

col := 0;

while (col < 10) do

begin

rt1.Cells[row].Text := Format('Text in cell({0}, {1})', row, col);

end;

end;

// set the table columns' widths

rt1.Width := &Unit.Auto;

col := 0;

while (col < 10) do

begin

rt1.Cols[col].Width := '1in';

end;

// assign first 2 rows as header, set background

rt1.RowGroups[0].PageHeader := True;

rt1.RowGroups[0].Style.BackColor := Color.Red;

// assign last 2 rows as footer, set background

rt1.RowGroups[98].PageFooter := True;

rt1.RowGroups[98].Style.BackColor := Color.Blue;

// assign first column as header

rt1.ColGroups[0].PageHeader := True;

rt1.ColGroups[0].Style.BackColor := Color.BlueViolet;

// assign last column as footer

rt1.ColGroups[9].PageFooter := True;

rt1.ColGroups[9].Style.BackColor := Color.BurlyWood;


Groups of Rows and Columns - Visual Basic

Visual Basic

rt1.RowGroups(0, 2).Header = TableHeaderEnum.Page


Groups of Rows and Columns - Visual Basic 2

Visual Basic

' create and fill the table

Dim rt1 As RenderTable = New RenderTable()

Dim row As Integer

For row = 0 To 100- 1 Step + 1

for(Integer col = 0 col < 10,++col)

Next

rt1.Cells(row, col).Text = String.Format(

"Text in cell({0}, {1})", row, col)

' set the table and columns’ widths

rt1.Width = Unit.Auto

Dim col As Integer

For col = 0 To 10- 1 Step + 1

rt1.Cols(col).Width = "1in"

Next

' assign first 2 rows as header, set background

rt1.RowGroups(0, 2).PageHeader = True

rt1.RowGroups(0, 2).Style.BackColor = Color.Red

' assign last 2 rows as footer, set background

rt1.RowGroups(98, 2).PageFooter = True

Dim Style.BackColor(98,2). As rt1.RowGroups = Color.Blue

' assign first column as header

rt1.ColGroups(0, 1).PageHeader = True

rt1.ColGroups(0, 1).Style.BackColor = Color.BlueViolet

' assign last column as footer

rt1.ColGroups(9, 1).PageFooter = True

Dim Style.BackColor(9,1). As rt1.ColGroups = Color.BurlyWood


Hyperlink to a Location in the Document - C#

C#

C1LinkTarget linkTarget = new C1LinkTargetDocumentLocation(ro1);


Hyperlink to a Location in the Document - C# 2

C#

rt2.Hyperlink = new C1Hyperlink();

rt2.Hyperlink.LinkTarget = linkTarget;


Hyperlink to a Location in the Document - Delphi

Delphi

linkTarget := C1LinkTargetDocumentLocation.Create(ro1);


Hyperlink to a Location in the Document - Delphi 2

Delphi

rt2.Hyperlink := C1Hyperlink.Create;

rt2.Hyperlink.LinkTarget := linkTarget;


Hyperlink to a Location in the Document - Visual Basic

Visual Basic

Dim linkTarget = New C1LinkTargetDocumentLocation(ro1)


Hyperlink to a Location in the Document - Visual Basic 2

Visual Basic

rt2.Hyperlink = New C1Hyperlink()

rt2.Hyperlink.LinkTarget = linkTarget


Hyperlink to an Anchor in a Different C1PrintDocument - C#

C#

// make target document with an anchor:

C1PrintDocument targetDoc = new C1PrintDocument();

RenderText rt1 = new RenderText("This is anchor1 in myDocument1.");

rt1.Anchors.Add(new C1Anchor("anchor1"));

targetDoc.Body.Children.Add(rt1);

targetDoc.Generate();

targetDoc.Save(@"c:\myDocument1.c1d");

// make document with a hyperlink to the anchor:

C1PrintDocument sourceDoc = new C1PrintDocument();

RenderText rt2 = new RenderText("This is hyperlink to myDocument1.");

C1LinkTarget linkTarget =
new C1LinkTargetExternalAnchor(@"c:\myDocument1.c1d", "anchor1");

rt2.Hyperlink = new C1Hyperlink(linkTarget);

sourceDoc.Body.Children.Add(rt2);

sourceDoc.Generate();

// show document with hyperlink in preview:

C1PrintPreviewDialog preview = new C1PrintPreviewDialog();

preview.Document = sourceDoc;

preview.ShowDialog();


Hyperlink to an Anchor in a Different C1PrintDocument - Delphi

Delphi

// make target document with an anchor:

targetDoc := C1PrintDocument.Create;

rt1 := RenderText.Create('This is anchor1 in myDocument1.');

rt1.Anchors.Add(C1Anchor.Create('anchor1'));

targetDoc.Body.Children.Add(rt1);

targetDoc.Generate;

targetDoc.Save('c:\myDocument1.c1d');

// make document with a hyperlink to the anchor:

sourceDoc := C1PrintDocument.Create;

rt2 := RenderText.Create('This is hyperlink to myDocument1.');

linkTarget := C1LinkTargetExternalAnchor.Create('c:\myDocument1.c1d', 'anchor1');

rt2.Hyperlink := C1Hyperlink.Create(linkTarget);

sourceDoc.Body.Children.Add(rt2);

sourceDoc.Generate;

// show document with hyperlink in preview:

preview := C1PrintPreviewDialog.Create;

preview.Document := sourceDoc;

preview.ShowDialog;


Hyperlink to an Anchor in a Different C1PrintDocument - Visual Basic

Visual Basic

' make target document with an anchor:

Dim targetDoc As New C1PrintDocument()

Dim rt1 As New RenderText("This is anchor1 in myDocument1.")

rt1.Anchors.Add(New C1Anchor("anchor1"))

targetDoc.Body.Children.Add(rt1)

targetDoc.Generate()

targetDoc.Save("c:\myDocument1.c1d")

' make document with a hyperlink to the anchor:

Dim sourceDoc As New C1PrintDocument()

Dim rt2 As New RenderText("This is hyperlink to myDocument1.")

Dim linkTarget = New C1LinkTargetExternalAnchor("c:\myDocument1.c1d", "anchor1")

rt2.Hyperlink = New C1Hyperlink(linkTarget)

sourceDoc.Body.Children.Add(rt2)

sourceDoc.Generate()

' show document with hyperlink in preview:

Dim preview As New C1PrintPreviewDialog()

preview.Document = sourceDoc

preview.ShowDialog()


Hyperlink to an Anchor in the Same Document - C#

C#

rt.Anchors.Add(new C1Anchor("anchor1");


Hyperlink to an Anchor in the Same Document - C# 2

C#

RenderText rtxt = new RenderText();

rtxt.Text = "Link to anchor1";

rtxt.Hyperlink = new C1Hyperlink("anchor1");


Hyperlink to an Anchor in the Same Document - Delphi

Delphi

rt.Anchors.Add(C1Anchor.Create);


Hyperlink to an Anchor in the Same Document - Delphi 2

Delphi

rtxt := RenderText.Create;

rtxt.Text := 'Link to anchor1';

rtxt.Hyperlink := C1Hyperlink.Create('anchor1');


Hyperlink to an Anchor in the Same Document - Visual Basic

Visual Basic

rt.Anchors.Add(New C1Anchor(anchor1))


Hyperlink to an Anchor in the Same Document - Visual Basic 2

Visual Basic

Dim rtxt As New RenderText()

rtxt.Text = "Link to anchor1"

rtxt.Hyperlink = New C1Hyperlink("anchor1")


Hyperlink to an External File - C#

C#

C1LinkTarget linkTarget = new C1LinkTargetFile(@"c:\");


Hyperlink to an External File - C# 2

C#

// make document with a hyperlink to external file:

C1PrintDocument doc = new C1PrintDocument();

RenderText rt = new RenderText("Explore drive C:...");

C1LinkTarget linkTarget = new
C1LinkTargetFile(@"c:\");
rt.Hyperlink = new C1Hyperlink(linkTarget);

doc.Body.Children.Add(rt);

doc.Generate();

// show document with hyperlink in preview:

C1PrintPreviewDialog preview = new C1PrintPreviewDialog();

preview.Document = doc;

preview.ShowDialog();


Hyperlink to an External File - Delphi

Delphi

linkTarget := C1LinkTargetFile.Create('c:\');


Hyperlink to an External File - Delphi 2

Delphi

// make document with a hyperlink to external file:

doc := C1PrintDocument.Create;

rt := RenderText.Create('Explore drive C:...');

linkTarget := C1LinkTargetFile.Create('c:\');

rt.Hyperlink := C1Hyperlink.Create(linkTarget);

doc.Body.Children.Add(rt);

doc.Generate;

// show document with hyperlink in preview:

preview := C1PrintPreviewDialog.Create;

preview.Document := doc;

preview.ShowDialog;


Hyperlink to an External File - Visual Basic

Visual Basic

Dim linkTarget = New C1LinkTargetFile("c:\")


Hyperlink to an External File - Visual Basic 2

Visual Basic

' make document with a hyperlink to external file:

Dim doc As New C1PrintDocument()

Dim rt As New RenderText("Explore drive C:...")

Dim linkTarget = New C1LinkTargetFile("c:\")

rt.Hyperlink = New C1Hyperlink(linkTarget)

doc.Body.Children.Add(rt)

doc.Generate()

' show document with hyperlink in preview:

Dim preview As New C1PrintPreviewDialog()

preview.Document = doc

preview.ShowDialog()


Hyperlink to a Page in the Same Document - C#

C#

C1LinkTarget linkTarget = new C1LinkTargetPage(PageJumpTypeEnum.First);


Hyperlink to a Page in the Same Document - Delphi

Delphi

linkTarget := C1LinkTargetPage.Create(PageJumpTypeEnum.First);


Hyperlink to a Page in the Same Document - Visual Basic

Visual Basic

Dim linkTarget = New C1LinkTargetPage(PageJumpTypeEnum.First)


Hyperlink to a User Event - C#

C#

private void UserLinkSetup()

{

// make document with a user hyperlink

C1PrintDocument doc = new C1PrintDocument();

RenderText rt = new RenderText("Click this to show message box...");

  C1LinkTarget linkTarget = new
C1LinkTargetUser();
rt.Hyperlink = new C1Hyperlink(linkTarget);

rt.Hyperlink.UserData = "My hyperlnk user data";

doc.Body.Children.Add(rt);

doc.Generate();

// create the preview

C1PrintPreviewDialog preview = new C1PrintPreviewDialog();

// attach an event handler to the UserHyperlinkJump event:

preview.PreviewPane.UserHyperlinkJump +=
new HyperlinkEventHandler(PreviewPane_UserHyperlinkJump);

// preview the document

preview.Document = doc;

preview.ShowDialog();

}

void PreviewPane_UserHyperlinkJump(object sender, HyperlinkEventArgs e)

{

MessageBox.Show(e.Hyperlink.UserData.ToString());

}


Hyperlink to a User Event - Delphi

Delphi

procedure UserLinkSetup;

begin

// make document with a user hyperlink

doc := C1PrintDocument.Create;

rt := RenderText.Create('Click this to show message box...');

linkTarget := C1LinkTargetUser.Create;

rt.Hyperlink := C1Hyperlink.Create(linkTarget);

rt.Hyperlink.UserData := 'My hyperlnk user data';

doc.Body.Children.Add(rt);

doc.Generate;

// create the preview

preview := C1PrintPreviewDialog.Create;

// attach an event handler to the UserHyperlinkJump event:

Include(preview.PreviewPane.UserHyperlinkJump, PreviewPane_UserHyperlinkJump);

// preview the document

preview.Document := doc;

preview.ShowDialog;

end;

procedure PreviewPane_UserHyperlinkJump(sender: System.Object, e: HyperlinkEventArgs);

begin

MessageBox.Show(e.Hyperlink.UserData.ToString);

end;


Hyperlink to a User Event - Visual Basic

Visual Basic

Private Sub UserLinkSetup()

' make document with a user hyperlink

Dim doc As New C1PrintDocument()

Dim rt As New RenderText("Click this to show message box...")

Dim linkTarget = New C1LinkTargetUser()

rt.Hyperlink = New C1Hyperlink(linkTarget)

rt.Hyperlink.UserData = "My hyperlnk user data"

doc.Body.Children.Add(rt)

doc.Generate()

' create the preview

Dim preview As New C1PrintPreviewDialog()

' attach an event handler to the UserHyperlinkJump event:

AddHandler preview.PreviewPane.UserHyperlinkJump, AddressOf PreviewPane_UserHyperlinkJump

' preview the document

preview.Document = doc

preview.ShowDialog()

End Sub

Sub PreviewPane_UserHyperlinkJump(sender As Object, e As HyperlinkEventArgs)

MessageBox.Show(e.Hyperlink.UserData.ToString())

End Sub


Making a Hello World Document - C#

C#

c1PrintDocument1.Body.Children.Add(new RenderText("Hello, World!"));

c1PrintDocument1.Generate();


Making a Hello World Document - Delphi

Delphi

c1PrintDocument1.Body.Children.Add(RenderText.Create(c1PrintDocument1, 'Hello, World!'));

c1PrintDocument1.Generate;


Making a Hello World Document - Visual Basic

Visual Basic

c1PrintDocument1.Body.Children.Add(New RenderText("Hello, World!"))

c1PrintDocument1.Generate()


Making a Simple Table - C#

C#

RenderTable rt = new RenderTable();

c1PrintDocument1.Body.Children.Add(rt);

for (int row = 0; row < 10; ++ row)

for (int col = 0; col < 6; ++ col)

rt.Cells[row, col].Text = string.Format("Cell ({0},{1})", row, col);


Making a Simple Table - C# 2

C#

c1PrintDocument1.Generate();


Making a Simple Table - C# 3

C#

rt.Cells[14, 7].Text = "text at row 10, column 7";


Making a Simple Table - C# 4

C#

rt.Style.GridLines.All = LineDef.Default;


Making a Simple Table - C# 5

C#

rt.Cells[3, 4].Text =
"A long line of text showing that table rows stretch " +
"to accommodate all content.";


Making a Simple Table - C# 6

C#

private void Form1_Load(object sender, EventArgs e)

{

c1PrintDocument1.Body.Children.Add(new RenderText("Hello, World!"));

RenderTable rt = new RenderTable();

c1PrintDocument1.Body.Children.Add(rt);

for (int row = 0; row < 10; ++row)

for (int col = 0; col < 6; ++col)

rt.Cells[row, col].Text = string.Format("Cell ({0},{1})", row, col);

rt.Cells[3, 4].Text = "A long line of text showing that table rows " + "stretch to accommodate all content.";

rt.Cells[10, 7].Text = "text at row 10, column 7";

rt.Style.GridLines.All = LineDef.Default;

c1PrintDocument1.Generate();

}


Making a Simple Table - Delphi

Delphi

rt := RenderTable.Create;

c1PrintDocument1.Body.Children.Add(rt);

row := 0;

while (row < 10) do

begin

col := 0;

while (col < 6) do

begin

rt.Cells[row].Text := Format('Cell ({0},{1})', row, col);

end;

end;


Making a Simple Table - Delphi 2

Delphi

c1PrintDocument1.Generate;


Making a Simple Table - Delphi 3

Delphi

rt.Cells[14].Text := 'text at row 10, column 7';


Making a Simple Table - Delphi 4

Delphi

rt.Style.GridLines.All := LineDef.Default;


Making a Simple Table - Delphi 5

Delphi

rt.Cells[3].Text :=
('A long line of text showing that table rows stretch ' +

'to accommodate all content.');


Making a Simple Table - Delphi 6

Delphi

procedure MainForm.Form1_Load(sender: System.Object; e: System.EventArgs);

var

rt := RenderTable.Create;

begin

c1PrintDocument1.Body.Children.Add(RenderText.Create('Hello, World!'));

c1PrintDocument1.Body.Children.Add(rt);

row := 0;

while (row < 10) do

begin

col := 0;

while (col < 6) do

begin

rt.Cells[row].Text := Format('Cell ({0},{1})', row, col);

end;

end;

rt.Cells[3].Text := ('A long line of text showing that table rows ' + 'stretch to accommodate all content.');

rt.Cells[10].Text := 'text at row 10, column 7';

rt.Style.GridLines.All := LineDef.Default;

c1PrintDocument1.Generate;

end;


Making a Simple Table - Visual Basic

Visual Basic

Dim rt As New RenderTable()

c1PrintDocument1.Body.Children.Add(rt)

Dim row As Integer

While row < 10

Dim col As Integer

While col < 6

rt.Cells(row, col).Text = String.Format("Cell ({0},{1})", row, col)

End While

End While


Making a Simple Table - Visual Basic 2

Visual Basic

c1PrintDocument1.Generate()


Making a Simple Table - Visual Basic 3

Visual Basic

rt.Cells(14, 7).Text = "text at row 10, column 7"


Making a Simple Table - Visual Basic 4

Visual Basic

rt.Style.GridLines.All = LineDef.Default


Making a Simple Table - Visual Basic 5

Visual Basic

rt.Cells(3, 4).Text =
"A long line of text showing that table rows stretch " +
"to accommodate all content."


Making a Simple Table - Visual Basic 6

Visual Basic

Private Sub Form1_Load(sender As Object, e As EventArgs)

c1PrintDocument1.Body.Children.Add(New RenderText("Hello, World!"))

Dim rt As New RenderTable()

c1PrintDocument1.Body.Children.Add(rt)

Dim row As Integer

While row < 10

Dim col As Integer

While col < 6

rt.Cells(row, col).Text = String.Format("Cell ({0},{1})", row, col)

End While

End While

rt.Cells(3, 4).Text = "A long line of text showing that table rows " + "stretch to accommodate all content."

rt.Cells(10, 7).Text = "text at row 10, column 7"

rt.Style.GridLines.All = LineDef.Default

c1PrintDocument1.Generate()

End Sub


Modifying the Font - C#

C#

c1PrintDocument1.StartDoc();

c1PrintDocument1.RenderInlineText("With C1PrintDocument you can print ");


Modifying the Font - C# 2

C#

c1PrintDocument1.RenderInlineText(
"Line by Line", new Font("Times New Roman", 30, FontStyle.Bold),
Color.FromArgb(0, 0, 125));

c1PrintDocument1.RenderInlineText(
" and modify text attributes as you go.");


Modifying the Font - C# 3

C#

c1PrintDocument1.RenderInlineText(
" The text wraps automatically, so your life becomes easier.",
Color.Green);


Modifying the Font - C# 4

C#

c1PrintDocument1.EndDoc();


Modifying the Font - Delphi

Delphi

var

c1PrintDocument1.StartDoc();

c1PrintDocument1.RenderInlineText('With C1PrintDocument you can print ');


Modifying the Font - Delphi 2

Delphi

c1PrintDocument1.RenderInlineText('Line by Line', Font.Create('Times New Roman', 30, FontStyle.Bold), Color.FromArgb(0, 0, 125));

c1PrintDocument1.RenderInlineText(‘ and modify text attributes as you go.’);


Modifying the Font - Delphi 3

Delphi

c1PrintDocument1.RenderInlineText(' The text wraps automatically, so your life becomes easier.', _Color.Green);


Modifying the Font - Delphi 4

Delphi

c1PrintDocument1.EndDoc;


Modifying the Font - Visual Basic

Visual Basic

c1PrintDocument1.StartDoc()

c1PrintDocument1.RenderInlineText("With C1PrintDocument you can print ")


Modifying the Font - Visual Basic 2

Visual Basic

c1PrintDocument1.RenderInlineText("Line by Line", _

New Font("Times New Roman", 30, FontStyle.Bold), _

Color.FromArgb(0, 0, 125))

c1PrintDocument1.RenderInlineText( _
" and modify text attributes as you go.")


Modifying the Font - Visual Basic 3

Visual Basic

c1PrintDocument1.RenderInlineText( _
" The text wraps automatically, so your life becomes easier.", _
_Color.Green)


Modifying the Font - Visual Basic 4

Visual Basic

c1PrintDocument1.EndDoc()


Namespaces - C#

C#

C1.Win.C1Preview.C1PrintPreview preview;


Namespaces - C# 2

C#

// Define a new object based on your Pages class.

MyPages as Pages;

// Define a new C1PrintPreview.Pages object.

PreviewPages as C1.Win.C1Preview.Pages;


Namespaces - C# 3

C#

using C1Pages = C1.Win.C1Preview.Pages;

using MyPages = MyProject.Objects.Pages;

C1Pages p1;

MyPages p2;


Namespaces - Delphi

Delphi

preview: C1.Win.C1Preview.C1PrintPreview;


Namespaces - Delphi 2

Delphi

// Define a new object based on your Pages class.

MyPages: Pages;

// Define a new C1PrintPreview.Pages object.

PreviewPages: C1.Win.C1Preview.Pages;


Namespaces - Delphi 3

Delphi

C1Pages := C1.Win.C1Preview.Pages;

MyPages := MyProject.Objects.Pages;

p1: C1Pages;

p2: MyPages;


Namespaces - Visual Basic

Visual Basic

Dim preview As C1.Win.C1Preview.C1PrintPreview


Namespaces - Visual Basic 2

Visual Basic

' Define a new object based on your Pages class.

Dim MyPages as Pages

' Define a new C1PrintPreview.Pages object.

Dim PreviewPages as C1.Win.C1Preview.Pages


Namespaces - Visual Basic 3

Visual Basic

Imports C1Pages = C1.Win.C1Preview.Pages

Imports MyPages = MyProject.Objects.Pages

Dim p1 As C1Pages

Dim p2 As MyPages


Printing in Landscape - C#

C#

this. C1PrintDocument1.PageLayout.PageSettings.Landscape = True;


Printing in Landscape - Delphi

Delphi

Self.C1PrintDocument1.PageLayout.PageSettings.Landscape := True;


Printing in Landscape - Visual Basic

Visual Basic

Me.C1PrintDocument1.PageLayout.PageSettings.Landscape = True


Render Objects - C#

C#

C1PrintDocument doc = new C1PrintDocument();

RenderText rt = new RenderText();

rt.Text = "This is a text.";

doc.Body.Children.Add(rt);


Render Objects - Delphi

Delphi

doc := C1PrintDocument.Create;

rt := RenderText.Create;

rt.Text := 'This is a text.';

doc.Body.Children.Add(rt);


Render Objects - Visual Basic

Visual Basic

Dim doc As New C1PrintDocument()

Dim rt As New RenderText()

rt.Text = "This is a text."

doc.Body.Children.Add(rt)


Specifying Render Objects' Size and Location - C#

C#

ro.Width = new Unit("150%prev");


Specifying Render Objects' Size and Location - Delphi

Delphi

ro.Width := &Unit.Create('150%prev');


Specifying Render Objects' Size and Location - Visual Basic

Visual Basic

ro.Width = New Unit("150%prev")


Table Basics - C#

C#

RenderTable rt1 = new RenderTable();


Table Basics - C# 2

C#

RenderTable rt1 = new RenderTable();

for (int row = 0; row < 10; ++row)

for (int col = 0; col < 4; ++col)

rt1.Cells[row, col].Text = string.Format(
"Text in cell({0}, {1})", row, col);


Table Basics - Delphi

Delphi

rt1 := RenderTable.Create;


Table Basics - Delphi 2

Delphi

while (row < 10) do

begin

col := 0;

while (col < 4) do

begin

rt1.Cells[row].Text := Format('Text in cell({0}, {1})', row, col);

end;

end;


Table Basics - Visual Basic

Visual Basic

Dim rt1 As New RenderTable()


Table Basics - Visual Basic 2

Visual Basic

Dim rt1 As New RenderTable()

Dim row As Integer

While row < 10

Dim col As Integer

While col < 4

rt1.Cells(row, col).Text = String.Format("Text in cell({0}, {1})", row, col)

End While

End While


Tags - C#

C#

c1PrintDocument1.Tags.Add(new Tag("tag1", "tag value"));


Tags - C# 2

C#

RenderText rt = new RenderText("Here the value of tag1 will appear: [tag1].");


Tags - Delphi

Delphi

c1PrintDocument1.Tags.Add(Tag.Create('tag1', 'tag value'));


Tags - Delphi 2

Delphi

rt := RenderText.Create('Here the value of tag1 will appear: [tag1].');


Tags - Visual Basic

Visual Basic

c1PrintDocument1.Tags.Add(New Tag("tag1", "tag value"))


Tags - Visual Basic 2

Visual Basic

Dim rt As New RenderText("Here the value of tag1 will appear: [tag1].")