ComponentOne Scheduler for LightSwitch Overview

ComponentOne Scheduler™ for LightSwitch provides a C1Scheduler LightSwitch control extension that consumes LightSwitch data sources to provide an interactive appointment calendar with Outlook-style scheduling functionality. It contains an integrated toolbar for import/export, view selection, and grouping.

Installing Scheduler for LightSwitch

Creating a ComponentOne Scheduler LightSwitch Project

Adding a Calendar Screen

About This Documentation


Installing Scheduler for LightSwitch

ComponentOne Scheduler for LightSwitch Overview

Installing Scheduler for LightSwitch

Before installing ComponentOne Scheduler for LightSwitch, make sure you have downloaded and installed Visual Studio LightSwitch at http://www.microsoft.com/visualstudio/en-us/lightswitch.

To install Scheduler for LightSwitch:

1. Double-click the C1.LightSwitch.Schedule.vsix.

2. In the Visual Studio Extension Installer window, make sure Microsoft LightSwitch is selected and click Install.

3. Once the installation is complete, click Close.


Creating a ComponentOne Scheduler LightSwitch Project

ComponentOne Scheduler for LightSwitch Overview

Creating a ComponentOne Scheduler LightSwitch Project

To create a new Scheduler for LightSwitch project, complete the following steps:

1. In Visual Studio, select File | New | Project.

2. Under Installed Templates, select LightSwitch. The .NET Framework 4 must be selected in order to create a LightSwitch application.

3. Choose LightSwitch Application for the preferred language, enter a name for the application, and click OK. Your LightSwitch project is created. You'll notice it contains the Data Sources and Screens folders.

4. In the Solution Explorer, right-click the project node and select Properties.

5. In the Properties window, select the Extensions tab and make sure the Microsoft LightSwitch Extensions and ComponentOne Scheduler for LightSwitch items are selected and have the Use in new projects fields selected.


Adding a Calendar Screen

ComponentOne Scheduler for LightSwitch Overview

Adding a Calendar Screen

You can use the ComponentOne Calendar Screen template to create a fully functional schedule.

To add a ComponentOne Calendar Screen template to your project, follow these steps:

1. In the Solution Explorer, right-click the Screens folder and select Add Screen.

2. In the list of screen templates, select ComponentOne Calendar Screen.

Note: If you do not see the ComponentOne Calendar Screen option, make sure you have installed Scheduler for LightSwitch and included the extension in the project.

3. Under Provide screen information, enter a Screen Name and select a data source from the list under Screen Data.

4. Click OK.


About This Documentation

ComponentOne Scheduler for LightSwitch Overview

About This Documentation

Acknowledgements

Microsoft, Windows, Visual Studio, LightSwitch, Silverlight, are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

ComponentOne

If you have any suggestions or ideas for new features or controls, please call us or write:

Corporate Headquarters

ComponentOne LLC
201 South Highland Avenue
3rd Floor
Pittsburgh, PA 15206 • USA
412.681.4343
412.681.4384 (Fax)

http://www.componentone.com

ComponentOne Doc-To-Help

This documentation was produced using ComponentOne Doc-To-Help® Enterprise.


Key Features

The following are some of the main features of ComponentOne Scheduler for LightSwitch that you may find useful:

· Complete Outlook-style Scheduling

Schedule one-time, all day, or recurring appointments with reminders, labels, and availability status just as in Microsoft Outlook. Stay organized with categories, resources, and contacts linked to each appointment.

· Five Built-in Default Views

The C1Scheduler control includes five built-in default views, allowing you to offer a variety of ways for users to view their schedules. View the schedule by day, week, work week, month, or time line. You can also create your own custom views. See Changing the View for more information.

· Reminders

Scheduler can display reminder dialogs at specified times before an appointment occurs. Users have the option to dismiss one or more appointments, open the appointment, or reset the reminder to appear again later (snooze). See the Reminders topic for more information.

· Resource Grouping

Group appointments by contacts, resources or categories to create a multi-column layout where each column corresponds to a different item. Navigate through any number of grouped items with ease. Simply drag an appointment to reassign it to a different resource, category or contact. Grouping is supported in all scheduler views. See the Grouping topic to learn more about this great feature.

· Time Line View

Give your users a Time Line view for displaying appointments in a horizontal layout. This view is useful when trying to see multiple groups at once to schedule a meeting. In this view the time is displayed horizontally and groups are arranged vertically, much like the 'Schedule' view in Microsoft Outlook 2010. See Changing the View for an example of the Time Line view.

· Pre-built Ribbon Toolbars

Choose from Data (Print, Import, Export), View (Day, Work Week, Week, Month, Time Line), and Group button groups to add to your application. They are already built and wired to the calendar. All you have to do is select a check box. See Changing the C1Scheduler Appearance for an overview of these button groups.

· Use Multiple Data Sources

In addition to selecting primary data source for the screen (appointment information), Scheduler for LightSwitch provides placeholders to connect to data sources for categories, contacts, and resources. These tables don’t even need to be related. Scheduler for LightSwitch handles associations for you. See Binding C1Scheduler to a Data Source for more information.

· Import and Export Data

Save or load data in supported formats: XML or iCalendar. See Printing, Importing, and Exporting for more information.


Scheduler for LightSwitch Quick Start

The following quick start guide is intended to get you up and running with Scheduler for LightSwitch. In this quick start you'll create a new LightSwitch project, add a primary data source, and bind the data source to a screen template to create the schedule UI.

Step 1: Creating a LightSwitch Project

Step 2: Defining the Data

Step 3: Creating a Screen

Step 4: Running the Application


Step 1: Creating a LightSwitch Project

Scheduler for LightSwitch Quick Start

Step 1: Creating a LightSwitch Project

Begin by creating a LightSwitch project.

1. In Visual Studio, select File | New | Project.

2. Under Installed Templates, select LightSwitch. The .NET Framework 4 must be selected in order to create a LightSwitch application.

3. Choose LightSwitch Application for the preferred language, enter a name for the application, and click OK. Your LightSwitch project is created. You'll notice it contains the Data Sources and Screens folders.

4. In the Solution Explorer, right-click the project node and select Properties.

5. In the Properties window, select the Extensions tab and make sure the Microsoft LightSwitch Extensions and ComponentOne Scheduler for LightSwitch items are selected and have the Use in new projects fields selected.


Step 2: Defining the Data

Scheduler for LightSwitch Quick Start

Step 2: Defining the Data

In this step, you will create a primary data source that will bind to the calendar screen to create a fully functional schedule.

1. In the Solution Explorer, right-click the Data Sources folder and select Add Table.

2. Set up the table as in the following example:

3. Select the table and then select the Properties row. In the Visual Studio Properties window, delete 255 for the MaximumLength property. This will allow the control to manage recurring appointments and maintain relationships with optional secondary tables.

In the next step, you will add a screen template to be associated with the table. This is necessary to create the UI for the schedule.


Step 3: Creating a Screen

Scheduler for LightSwitch Quick Start

Step 3: Creating a Screen

Once you have a data source, you can add a screen to bind to it. The ComponentOne Calendar Screen template will create the schedule for you, so you don't have to enter a single line code. It will be mapped to the Holiday table you created in step 2.

1. In the Solution Explorer, right-click the Screens folder and select Add Screen.

2. Select ComponentOne Calendar Screen in the list of screen templates.

3. Use the default name Calendar under Screen Name, select the Holidays data source from the Screen Data list, and click OK.

4. Select the Holiday item in the calendar designer, notice it is a C1AppointmentPlaceholder control, and set the properties as in the following image. These properties map to the properties you added in the Holiday table.

Now it's time to run the application and check out the schedule!


Step 4: Running the Application

Scheduler for LightSwitch Quick Start

Step 4: Running the Application

Press F5 to run the application. A fully functional schedule appears.

In the default Month view, double-click a date to add an event to the holiday schedule. In the Event dialog box, add a Subject, Location, Label, Start and End time, or anything else you would like to assign to the event.

Click Save and Close to close the Event dialog box and add the event to the schedule.


Binding C1Scheduler to a Data Source

ComponentOne Scheduler for LightSwitch allows you create a primary appointments data source to provide data for a schedule. Once you have a primary data source in your project, you can add a ComponentOne Calendar Screen, which is a screen template that includes a properly configured instance of the C1Scheduler control extension, and bind it to the data, creating a fully functional, ready-to-use schedule.

C1Scheduler also includes non-visual controls (C1Categories, C1Contacts, and C1Resources) for attaching additional data sources to the primary appointments data source. See Adding Other Data Sources for more information.

These controls provide the mapping between C1Schedulers internal storage model and the underlying LightSwitch data sources.

Adding a Primary Data Source

Adding a ComponentOne Calendar Screen

Mapping to the Primary Data Source

Adding Other Data Sources


Adding a Primary Data Source

Binding C1Scheduler to a Data Source

Adding a Primary Data Source

When binding C1Scheduler to the primary appointments data source, the data source must have at least seven specific properties set in order for the binding to work correctly. These properties include: Id, Subject, StartTime, EndTime, Body, Location, and Properties. The actual property names can be different, but the date/time and subject properties must be marked as required. The primary key property can be an integer, string, or GUID. The remaining string properties must be present, although they need not contain any data. The final property (Properties) is used to store internal data in XML format; therefore, its Maximum Length setting (default: 255) should be cleared.

To add a data source to bind to C1Scheduler, follow these steps:

1. Right-click the Data Sources folder in the Solution Explorer, and choose Add Table.

2. Enter Holiday in the table header to set the table name.

3. Under Name, enter Subject where it says <Add Property>.

4. Set the Type to String and make sure the Required checkbox is selected. Do the same for the remaining six properties, using the values in the following example:

5. Click the Properties row and in the Visual Studio Properties window, delete 255 for the MaximumLength property. This allows the property to hold unlimited text, so all necessary information can be stored by the control.


Adding a ComponentOne Calendar Screen

Binding C1Scheduler to a Data Source

Adding a ComponentOne Calendar Screen

ComponentOne Calendar Screen is a screen template that includes a properly configured instance of the C1Scheduler control extension. This is the easiest way to use the product.

Once you have created a table to hold the data for the C1Scheduler extension, you can add a screen template that will be bound to the table.

To do this, follow these steps:

1. In the Solution Explorer, right-click the Screens folder and select Add Screen.

2. Select ComponentOne Calendar Screen in the list of screen templates.

3. Enter a name for the screen under Screen Name, select the data source, Holidays in this example, from the Screen Data list, and click OK.

The screen is created. The table properties must be mapped to the storage model for the schedule to be properly displayed. See Mapping to the Primary Data Source.


Mapping to the Primary Data Source

Binding C1Scheduler to a Data Source

Mapping to the Primary Data Source

The mapping between the primary table properties and the C1Scheduler storage model is handled by the C1AppointmentPlaceholder element.

If you select the table in the screen designer and view the Visual Studio Properties window, you'll notice the Control Type for the primary table, Holidays in this example, is Default (C1AppointmentPlaceholder).

The Primary Key property must be set to the name of an integer, string, or GUID property that uniquely identifies an appointment record in the data source. The remaining drop-down controls let you specify date/time or string property names, as appropriate.

Set the properties as shown in the following image:

Once the property mappings are set up, the C1Scheduler control automatically handles all CRUD (Create, Read, Update, and Delete) operations on appointments. No coding is required to synchronize the model with the underlying data storage.


Adding Other Data Sources

Binding C1Scheduler to a Data Source

Adding Other Data Sources

You can easily associate additional, separate data sources, such as a contacts list, with a C1Scheduler control. In this example, we have already associated the Holidays data source with the Calendar screen, and now we are going to add a Contacts data source. To do this, follow these steps:

1. First, add the data source to the project as you did for the C1Scheduler data source, only you must set two required properties instead of seven. The Id and Text properties must be included and marked as required. You can also add other properties, if you like, but this is optional. Set the Id and Text properties as seen in the following image:

2. In the Solution Explorer, double-click the screen you are associating with the separate data source.

3. Select C1Scheduler and click Add Data Item to add the desired query, Contacts, to the screen.

4. In the Add Data Item dialog box, select Query, choose the new data source, and click OK. When selecting the data source, choose the TableName (All) return type to ensure the collection is returned.

5. Click Add drop-down list and select Contacts to add the collection to the end of the screen layout. Then change the default control name, Data Grid, to C1Contacts as shown in the following figure.

The mapping between the Contacts table properties and the C1Contacts storage model is handled by the C1ContactPlaceholder element, similar to the way the C1Scheduler storage model is handled by the C1AppointmentPlaceholder element.

If you select the table in the screen designer and view the Visual Studio Properties window, you'll notice the Control Type for the Contacts table is Default (C1ContactPlaceholder).

Just as you must do with the C1AppointmentPlaceholder, the Primary Key property must be set to the name of an integer, string, or GUID property that uniquely identifies a contact record in the data source. The remaining drop-down controls let you specify string property names, as appropriate.

6. Set the properties as shown in the following image:

Repeat this process for the C1Categories and C1Resources storage models, if desired. Mappings are handled by the C1CategoryPlaceholder and C1ResourcePlaceholder, respectively. The properties are the same as for the ContactsTemplate.


Changing the C1Scheduler Appearance

The C1Scheduler control exposes a small set of appearance properties that determine whether the attached data sources (if any) support editing and multiple selection. To set these properties, select C1Scheduler in the screen designer and view the Properties window.

The First Visible Time property specifies the initial time slot displayed for day and week views.

The remaining properties control which toolbar groups (Data, View, Group) are visible in the calendar.

Printing, Importing, and Exporting

Changing the View

Grouping


Printing, Importing, and Exporting

Changing the C1Scheduler Appearance

Printing, Importing, and Exporting

The Data group of the C1Scheduler toolbar allows you to print a calendar, import data from an iCal or XML file, or export data to an iCal or XML file.

To make the Data group visible in the toolbar at run time, check the Show Data Commands check box in the C1Scheduler Properties window.

Click the Print, Import, or Export button to perform each task.

· Clicking Print will print everything visible in the current view of the schedule, excluding the toolbar and calendars. See Printing a Schedule.

· When importing, select the desired iCal .ics or .xml file and click Open. The schedule is updated. Note that data can only be imported from an XML file if the XML file was previously exported from C1Scheduler. See Importing Data.

· When exporting, in the Save As dialog box, enter a name for the schedule in the File name text box, select either .ics or .xml in the Save as type text box, and click Save. See Exporting Data.


Changing the View

Changing the C1Scheduler Appearance

Changing the View

To make the View group visible in the toolbar at run time, check the Show View Commands check box in the C1Scheduler Properties window.

You can change the view of the calendar at run time by clicking one of the buttons in the View toolbar group. View options include the following:

Day

Work Week

Week

Month

Time Line


Grouping

Changing the C1Scheduler Appearance

Grouping

To make the Group items visible in the C1Scheduler toolbar at run time, check the Show Group Commands check box in the C1Scheduler Properties window.

At run time, grouping allows you to view multiple schedules, in any view, side-by-side. ComponentOne Scheduler for LightSwitch allows you to group schedules by category, contact, or resource.

For example, look at the Scheduler for LightSwitch demo at http://demo.componentone.com/LightSwitch/Scheduler/. The application shows the television broadcasting schedule for hockey games. The categories are regions (e.g., Northeast, Southeast, etc.), the contacts are teams (e.g., Anaheim Ducks, Boston Bruins, etc.), and the resources are the television stations on which the games are being aired (e.g., NBC, Versus).

If you wanted to see which games are on NBC and which are on the Versus station, you could Group By Resource to view the schedules side-by-side and compare.

You can also determine the number of schedules that appear at one time by setting the Page Size in the Group toolbar group. Use the forward and back buttons to page through the schedules.

You can even determine the background colors for each of the groups. See Adding Background Colors for Groups.


Appointments

An appointment represents a period of time and detailed information about events that will take place during that period of time. Appointments can span from a specified duration, such as 30 minutes, to multi-day events.

New appointments can be added or existing appointments can be edited by simply double-clicking the time of the appointment.

The Appointment dialog box is used to schedule new appointments, allowing you to set a subject, location, label, start and end time, reminder, availability status, and whether the appointment is an all day event and recurring over a specified period of time. You can also specify any resources, categories, and contacts here.

Labels

Availability Status

Reminders

Contacts

Categories

Resources


Labels

Appointments

Labels

A label is simply a color-coded marker that can be added to appointments so that you and others know what type of appointment it is without even having to view its details.

There are twelve predefined labels available in Scheduler for Silverlight. The color of the label is visible in every data view in the C1Scheduler control.

Predefined Labels

The predefined labels include the following:

Label | Color
None |
Important |
Business |
Personal |
Vacation |
Deadline |
Must Attend |
Travel Required |
Needs Preparation |
Birthday |
Anniversary |
Phone Call |


Availability Status

Appointments

Availability Status

The availability status lets everyone know if you will be available at the time when an appointment is scheduled. There are four predefined availability statuses available in Scheduler for Silverlight: Busy, Free, Out of Office, and Tentative. The status is specified by the following colors:

Status | Color
Busy |
Free |
Out of Office |
Tentative |

The status can be specified in the Appointment dialog box next to the Show time as drop-down list.

The color of the availability status is visible in all views of a schedule except month view. For appointments, the color appears in the area to the left of the appointment.


Reminders

Appointments

Reminders

Appointment reminders display a Reminder dialog box at a specified time before the appointment occurs. In the Reminder dialog box, you have the option of dismissing one or more appointments (if multiple appointments are due), opening the appointment, or resetting the reminder to appear again in a set amount of time.

Reminders can be set when creating an appointment by checking the Reminder check box and setting the amount of time before the appointment that you would like the reminder to appear in the Reminder drop-down list.


Contacts

Appointments

Contacts

A list of contacts usually includes all of the people with whom you frequently communicate. You might assign a contact to an appointment if this is the person you need to communicate with regarding the appointment. You can add contacts to the Contacts at run time. Contacts are optional, and an appointment can have one or more contacts assigned to it.

To assign a contact to an appointment at run time:

1. Click the Contacts button in the Appointment dialog box.

2. Select the check box next to the desired contact and click Ok.

The selected contact now appears in the Contacts text box. Note that you can add multiple contacts to an appointment.


Categories

Appointments

Categories

A category is a keyword or a phrase used to help you organize your appointments. There are 20 predefined categories available in Scheduler for Silverlight to assign to appointments. Categories are optional, and an appointment can have one or more categories assigned to it.

Predefined Categories

The predefined categories include the following:

· Business | · Key Customer
· Competition | · Miscellaneous
· Favorites | · Personal
· Gifts | · Phone Calls
· Goals/Objectives | · Status
· Holiday | · Strategies
· Holiday Cards | · Suppliers
· Hot Contacts | · Time&Expenses
· Ideas | · VIP
· International | · Waiting

To assign a category to an appointment at run time:

1. Click the Categories button in the Appointment dialog box.

2. Select the check box next to the desired category and click Ok. The category appears next to the Categories text box. Note that you can assign multiple categories to an appointment.


Resources

Appointments

Resources

A resource is a keyword or a phrase that defines a source of support for a particular task. Resources are optional and an appointment can have one or more resources assigned to it.

To assign a resource to an appointment at run time:

1. Click the Resources button in the Appointment dialog box.

2. Select the check box next to the desired resource and click Ok. The resource appears next to the Resources text box. Note that you can assign multiple resources to an appointment.


Working with Appointments at Run Time

Appointments can be created at run time by double-clicking the time for the appointment to begin, which will open the Appointment dialog box. For more information about appointments, see Appointments.

Pressing the following keys while in the Appointment dialog box will result in the following actions:

Key | Action
TAB or ENTER | Moves the cursor from one field to another according to the tab order.
ESC | Closes the Appointment dialog box without saving any changes.

Adding and Saving an Appointment

Editing an Appointment

Deleting an Appointment

Recurring Appointments


Adding and Saving an Appointment

Working with Appointments at Run Time

Adding and Saving an Appointment

Appointments can be added to the schedule using the Appointment dialog box.

1. Double-click the time of the appointment. The Appointment dialog box appears.

2. Specify a Subject, Location and any additional information you would like to assign to the appointment.

3. Click the Save and Close button to add the new appointment to the schedule.


Editing an Appointment

Working with Appointments at Run Time

Editing an Appointment

Appointments can be changed and updated through the Appointment dialog box.

1. Double-click an existing appointment to open the Appointment dialog box.

2. Edit any of the desired fields.

3. Click the Save and Close button to update the appointment in the schedule.


Deleting an Appointment

Working with Appointments at Run Time

Deleting an Appointment

Selected appointments can be easily removed from your schedule.

1. Select the appointment you would like to remove from the schedule.

2. Click the Delete key on your keyboard. The appointment is removed from the schedule.

You can also delete an appointment by clicking the Delete button [image] within the Appointment dialog box.


Recurring Appointments

Working with Appointments at Run Time

Recurring Appointments

Appointments can be set to recur at specified intervals. An appointment can recur daily, weekly, monthly, or yearly.

1. Double-click the time of an appointment to add a new one, or double-click an existing appointment. The Appointment dialog box appears.

2. Click the Recurrence button. The Appointment Recurrence dialog box appears.

3. Set the desired recurrence pattern:

When

The properties in the When group allow you to set the start time, end time, and duration of the appointment.

Repeats

The Repeats group settings change depending on whether the appointment recurs Daily, Weekly, Monthly, or Yearly.

Daily

The Daily settings allow you to repeat an appointment every specified number of days or only on working days.

For example, setting the appointment to every 2 day(s) will make the appointment appear every other day. Setting the appointment to on working days will make the appointment appear only Monday through Friday, by default.

Weekly

The Weekly settings allow you to repeat the appointment on every specified week on specified days.

For example, setting the appointment to every 2 week(s) on and selecting Tuesday and Thursday will repeat the appointment every other week on Tuesdays and Thursdays.

Monthly

The Monthly settings allow you to repeat an appointment on every specified date at a specified interval of months or on a specified day and week of the month at a specified interval of months.

For example, setting the appointment to on the 8 day of every 2 month will make the appointment appear on the 8th of every other month. Setting the appointment to on the third Monday of every 2 month will make the appointment appear on the third Monday of every other month.

Yearly

The Yearly setting allows you to repeat an appointment on a specified date or a specified day and week of a specified month.

For example, setting the appointment to on the 2 day of January will make the appointment appear on January 2nd every year. This setting is ideal for birthdays and anniversaries.

Setting the appointment to on the first Friday of January will make the appointment appear on the first Friday in January every year.

Range

The Range group allows you to set a time span for the recurrence.

The Start drop-down calendar allows you to select the date from which the recurrence will start. There are three options to choose from for an end date:

· No end date will make the appointment recur indefinitely.

· End after 0 occurrences will make the appointment recur a specified number of times. For example, if an appointment repeated every day, setting End after 25 occurrences would allow the appointment to repeat every day 25 times.

· End by will make the appointment recur until the date specified.

4. Click Ok to close the Appointment Recurrence dialog box.


Scheduler for LightSwitch Tutorial

In this tutorial, you will create a new LightSwitch project, add a primary data source that binds to a screen template to create the schedule UI, and create additional tables that will become contacts and resources that can be added to appointments in the schedule.

Step 1: Creating a LightSwitch Project

Step 2: Adding Data Sources

Step 3: Adding Screen Templates

Step 4: Mapping a Screen to the Primary Data Source

Step 5: Adding Contacts and Resources Data Sources

Step 6: Running the Application


Step 1: Creating a LightSwitch Project

Scheduler for LightSwitch Tutorial

Step 1: Creating a LightSwitch Project

Begin by creating a LightSwitch project.

1. In Visual Studio, select File | New | Project.

2. Under Installed Templates, select LightSwitch. The .NET Framework 4 must be selected in order to create a LightSwitch application.

3. Choose LightSwitch Application for the preferred language, enter a name for the application, and click OK. Your LightSwitch project is created. You'll notice it contains the Data Sources and Screens folders.

4. In the Solution Explorer, right-click the project node and select Properties.

5. In the Properties window, select the Extensions tab and make sure the Microsoft LightSwitch Extensions and ComponentOne Scheduler for LightSwitch items are selected and have the Use in new projects fields selected.


Step 2: Adding Data Sources

Scheduler for LightSwitch Tutorial

Step 2: Adding Data Sources

In this step, you will create a primary appointments data source that will be bound to the calendar screen to create a fully functional schedule. You will also create two additional tables: one to keep track of the sales people, who will become the contacts list, and one to keep track of information for the sales regions, which will become the resources list. Users will be able to use these lists to add contacts and resources to appointments in the schedule.

1. In the Solution Explorer, right-click the Data Sources folder and select Add Table. Repeat this step to create three tables in all.

2. Set up each table as in the following examples:

3. Select the Appointment table and click the Properties row. In the Visual Studio Properties window, delete 255 for the MaximumLength property. This will allow the control to maintain relationships between appointments, contacts, and resources.

In the next step, you will add a screen template to be associated with each of the tables. This is necessary to create the UI for the schedule and lists.


Step 3: Adding Screen Templates

Scheduler for LightSwitch Tutorial

Step 3: Adding Screen Templates

Once you have the data sources, you can add a screen template for each. The ComponentOne Calendar Screen template will create the schedule for you, so you don't have to enter a single line code. It will be mapped to the Appointments table you created in step 2. You'll use the List and Details Screen template for the SalesPerson and Resource tables so users can edit the contacts and resources lists as needed.

1. In the Solution Explorer, right-click the Screens folder and select Add Screen.

2. Select ComponentOne Calendar Screen in the list of screen templates.

3. Use the default name Calendar under Screen Name, select the Appointments data source from the Screen Data list, and click OK.

4. Repeat these three steps for the remaining two tables, only select the List and Details Screen template and use the SalesPerson and Resource tables for the Screen Data.

In the next step, you will map the primary appointments table to the ComponentOne Calendar Screen to create the schedule.


Step 4: Mapping a Screen to the Primary Data Source

Scheduler for LightSwitch Tutorial

Step 4: Mapping a Screen to the Primary Data Source

In this step, you will bind the primary appointments table to the ComponentOne Calendar Screen in order for the schedule to appear in your application.

1. In the Solution Explorer, double-click the Calendar screen to open the designer and view the screen properties. If you select the C1Scheduler control under Rows Layout, you'll notice the default properties are set to allow multiple selections for contacts and resources. Keep these default settings.

2. Select the Appointment item, notice it is a C1AppointmentPlaceholder control, and set the properties as in the following image. These properties map to the properties you added in the Appointment table.

In the next step, you will add the remaining tables to the C1Scheduler control.


Step 5: Adding Contacts and Resources Data Sources

Scheduler for LightSwitch Tutorial

Step 5: Adding Contacts and Resources Data Sources

Now you can map the SalesPerson and Resource tables to the C1Scheduler control, which will allow users to add contacts and resources to their appointments.

1. Click the Add Data Item button in the Calendar screen designer.

2. In the Add Data Item dialog box, select Query and choose SalesPersons, the Return Type SalesPerson (All) option, and click OK.

3. Under C1Scheduler, click Add | Sales Persons.

4. By default, Sales Persons is added as a Data Grid control. Change it to a C1Contacts control.

5. Select the C1ContactPlaceholder control and set the properties as in the following image:

Note that leaving the Color property unset causes it to default to the Text setting. We do not need to set it for this example.

6. Repeat steps 1-5 of this topic to add Resources to the screen, only make it a C1Resources control.

Now it's time to run the application and check out the schedule!


Step 6: Running the Application

Scheduler for LightSwitch Tutorial

Step 6: Running the Application

When you run the application, a fully functional schedule will appear. Users can double-click dates and/or times to create appointments, add resources and contacts to the appointments, change the calendar views, and more.

1. Press F5 to run the application. Notice you have a calendar, a Sales Persons list, and a Resources list.

2. Under Tasks, double-click Sales Persons List Detail and use the Add button to add new sales people to the list. Click the Save button in the LightSwitch ribbon to save the new contacts.

You can add resources to the Resources List Detail in the same way.

3. Go back to the calendar and double-click a day or time to open the Appointment or Event dialog box. If the Contacts and Resources buttons are not appearing in the dialog box, click the Refresh button and open the appointment again.

4. Create an appointment and click the Contacts button. You can select the necessary contacts and click Ok. They will appear in the Appointment or Event dialog box.


Scheduler for LightSwitch Sample

To view the online demo for ComponentOne Scheduler for LightSwitch, visit the following URL:

http://demo.componentone.com/LightSwitch/Scheduler

To download the full C# source code for the online demo, including sample data, click this link:

http://demo.componentone.com/LightSwitch/Scheduler/SchedulerLightSwitchDemo.zip


Scheduler for LightSwitch Task-Based Help

The topics in this section describe solutions for specific non-programming tasks using the ComponentOne Scheduler for LightSwitch product. By following the steps outlined in the help, you will be able to create and use projects demonstrating a variety of Scheduler for LightSwitch features.

Each task-based help topic assumes that you have created a LightSwitch project containing a ComponentOne Calendar Screen bound to a primary data source.

Adding Background Colors for Groups

Customizing a Calendar

Printing a Schedule

Importing Data

Exporting Data


Adding Background Colors for Groups

Scheduler for LightSwitch Task-Based Help

Adding Background Colors for Groups

You can apply background colors to items from a data source when using the Grouping feature. For example, suppose you want to color code sales regions in your resources list. Simply use the Choice List to determine available colors.

1. First, add a data source to the project as you did for the primarydata source, only you must set three required properties instead of seven. They can be set as follows:

2. For the Color property, you can specify the colors you would like to make available by adding them to the Choice List.

a. Select the Color property in the table, and in the Visual Studio Properties window, click Choice List.

b. Enter Values and Display Names as in the following image, for example, or add your own:

3. When you run the project and add a new item to the data source, you can specify a color.

The color will be used as the background color for the item when grouping.


Customizing a Calendar

Scheduler for LightSwitch Task-Based Help

Customizing a Calendar

The schedule screen UI can be customized and saved to the project at run time. You can change the C1Scheduler properties and the table-to-screen mappings at run time, if necessary. You can still access the schedule and make appointments while in customization mode.

1. Click the Design Screen button in the upper-right corner of the application.

2. In the Customization Mode window, select one of the controls and change the necessary properties in the lower-right pane of the window.


Printing a Schedule

Scheduler for LightSwitch Task-Based Help

Printing a Schedule

You can easily print the schedule(s) in your application.

1. Click the Print button in the Data toolbar group.

2. In the Print dialog box, set any necessary properties and click Print again. The schedule(s) will be printed, showing any appointments visible in the current view. Note that only what is on the screen, excluding the toolbar and calendars, will be printed.


Importing Data

Scheduler for LightSwitch Task-Based Help

Importing Data

Data can easily be imported from existing iCal or XML files into the schedule at run time. Note that data can only be imported from an XML file if the XML file was previously exported from C1Scheduler.

1. Click the Import button in the Data toolbar group.

2. In the Open dialog box, select the desired iCal .ics file and click Open. The schedule is updated.

3. Click the Save button to save the changes.


Exporting Data

Scheduler for LightSwitch Task-Based Help

Exporting Data

Just as easily as data can be imported from existing iCal and XML files, schedules can be saved and exported to iCal (*.ics) or XML (*.xml) files.

1. First, create a table, add a screen, and bind them in your project at design time.

2. Run the project and click the Export button in the Data toolbar group.

3. In the Save As dialog box, enter a name for the schedule in the File name text box and click Save. The schedule is saved.


C1.C1Schedule Namespace

[image]

.NET Framework Class Library
C1.C1Schedule Namespace

Classes

 | Class | Description
Public class | Action | Represents an action to take when the current system time reaches the start of the associated Appointment object.
Public class | ActionCollection | The ActionCollection is a collection of all Action objects that represents the reminders for all pending items.
Public class | AddingNewEventArgs |
Public class | Appointment | The Appointment object is a meeting, a one-time appointment, or a recurring appointment or meeting in the C1Schedule. The Appointment class includes properties that specify meeting details such as the location and time.
Public class | AppointmentCollection | The AppointmentCollection is a collection of all Appointment objects in the C1Schedule component.
Public class | AppointmentComparer | Compares Appointment objects by their start time.
Public class | AppointmentEventArgs | The AppointmentEventArgs class describes event data for Appointment events.
Public class | AppointmentList | The AppointmentList is a sortable collection of Appointment objects.
Public class | AppointmentMappingCollection | Represents a generic collection of mappings for properties of BaseObject derived objects to appropriate data fields.
Public class | AppointmentStorage | The AppointmentStorage is the storage for Appointment objects. It allows binding to the data source and mapping data source fields to the appointment properties.
Public class | BaseCollection<(Of <(<'T>)>)> | The BaseCollection<(Of <(<'T>)>)> is a base generic class for all collections in C1Schedule object model.
Public class | BaseList<(Of <(<'T>)>)> | The BaseList<(Of <(<'T>)>)> is a base generic class for all lists in C1Schedule's object model. Only objects existing in the owning collection can be added to this list.
Public class | BaseObject | The BaseObject is a base class for resources, labels, statuses, categories and contacts. It implements base UI properties and persistence.
Public class | BaseObjectMappingCollection<(Of <(<'T>)>)> | Represents a generic collection of mappings for properties of the BaseObject derived objects to appropriate data fields.
Public class | BasePersistableObject | The BasePersistableObject is a base class for persistable objects.
Public class | BaseStorage<(Of <(<'T, TMappingCollection>)>)> | The BaseStorage<(Of <(<'T, TMappingCollection>)>)> is the base generic component for all storages in C1Schedule object model. Represents a storage of objects derived from BasePersistableObject. This component implements methods of operations over the collections of objects. It allows the collection to be populated programmatically or automatically by retrieving data from the data source which is specified by the DataSource and DataMember properties. It allows mapping of data source fields to the object properties.
Public class | C1BindingSource | The C1BindingSource encapsulates the data source.
Public class | C1Brush | Wrapper class for brushes. Only for serialization/deserialization purposes.
Public class | C1ObservableCollection<(Of <(<'T>)>)> | The C1ObservableCollection<(Of <(<'T>)>)> is the base class for all Collection<(Of <(<'T>)>)> derived collections. Supports notification.
Public class | C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> | The C1ObservableCollection<(Of <(<'T>)>)> is the base class for all KeyedCollection<(Of <(<'TKey, TItem>)>)> derived collections. Supports notification.
Public class | C1ScheduleStorage | The C1ScheduleStorage component handles all data operations for the scheduler control and contains specific data storages for appointments, resources, contacts, owners, labels and statuses, which are used for binding different collections to the data. The C1ScheduleStorage component also handles data importing and exporting to other scheduling formats such as binary, iCal, and XML.
Public class | CalendarInfo | The CalendarInfo class manages and exposes all date-related data to C1Schedule controls.
Public class | CancelAppointmentEventArgs | The CancelAppointmentEventArgs class describes event data for Appointment events.
Public class | CancelReminderEventArgs | Describes event data for cancelable Reminder events.
Public class | Category | The Category class represents the category which can be associated with the Appointment object.
Public class | CategoryCollection | The CategoryCollection is a collection of Category objects which represents all available categories in C1Schedule object model. By default it contains the set of predefined categories.
Public class | CategoryList | The CategoryList is a list of Category objects. Only objects existing in the owning CategoryCollection object may be added to this list. Use the CategoryList to associate the set of Category objects with an Appointment object.
Public class | CategoryStorage | The CategoryStorage is the storage for Category objects. It allows binding to the data source and mapping data source fields to the category properties.
Public class | Contact | The Contact class represents the person information. Not real class just sample for prototyping.
Public class | ContactCollection | The ContactCollection is a collection of Contact objects which represents all available contacts in C1Schedule object model.
Public class | ContactList | The ContactList is a list of Contact objects. Only objects existing in the owning ContactCollection object may be added to this list. Use the ContactList to associate the set of Contact objects with an Appointment object.
Public class | ContactStorage | The ContactStorage is the storage for Contact objects. It allows binding to the data source and mapping data source fields to the contact properties.
Public class | DateList | The DateList class is a wrapper for the List<(Of <(<'T>)>)> instance. At addition of the new value, it cuts off the time part of the value and ensures that the value is not present in the list yet.
Public class | ItemSynchronizedEventArgs | Provides data for the DataSourceItemSynchronized event.
Public class | Label | The Label class represents the label which can be associated with the Appointment object.
Public class | LabelCollection | The LabelCollection is a collection of Label objects which represents all available labels in C1Schedule object model.
Public class | LabelList | The LabelList is a list of Label objects. Only objects existing in the owning LabelCollection object may be added to this list.
Public class | LabelStorage | The LabelStorage is the storage for Label objects. It allows binding to the data source and mapping data source fields to the label properties.
Public class | ListChangedEventArgs |
Public class | MappingCollectionBase<(Of <(<'T>)>)> | Represents a collection of mappings for properties of the BasePersistableObject object to the appropriate data fields. Names of properties are keys in this collection.
Public class | MappingInfo | This class provides information on the mapping of the single property of the object to the appropriate data field.
Public class | RecurrencePattern | The RecurrencePattern class contains information that describes the recurrence pattern and range of the associated Appointment object.
Public class | Reminder | The Reminder class represents an object which allows users to keep track of upcoming appointments by scheduling a pop-up dialog box to appear at a given time.
Public class | ReminderCollection | The ReminderCollection is a collection of all Reminder objects that represents the reminders for all pending items.
Public class | ReminderEventArgs | Describes event data for Reminder object events.
Public class | Resource | The Resource class represents the resource which can be associated with the Appointment object.
Public class | ResourceCollection | The ResourceCollection is a collection of Resource objects which represents all available resources in C1Schedule object model.
Public class | ResourceList | The ResourceList is a list of Resource objects. Only objects existing in the owning ResourceCollection object may be added to this list. Use the ResourceList to associate the set of Resource objects with an Appointment object.
Public class | ResourceStorage | The ResourceStorage is the storage for Resource objects. It allows binding to the data source and mapping data source fields to the resource properties.
Public class | Status | The Status class represents an availability status for the Appointment object.
Public class | StatusCollection | The StatusCollection is a collection of Status objects which represents all available statuses in C1Schedule object model. By default it contains the set of predefined statuses.
Public class | StatusList | The StatusList is a list of Status objects. Only objects existing in the owning StatusCollection object may be added to this list.
Public class | StatusStorage | The StatusStorage is the storage for Status objects. It allows binding to the data source and mapping data sources fields to the status properties.
Public class | WorkDays | The WorkDays class is a list of working days for the single week.

Interfaces

 | Interface | Description
Public interface | ISupportInitialize |
Public interface | ISupportInitializeNotification |

Delegates

 | Delegate | Description
Public delegate | AddingNewEventHandler |
Public delegate | CancelAppointmentEventHandler | Delegate for handling the cancelable event involving a single Appointment object.
Public delegate | CancelReminderEventHandler | Delegate for handling the cancelable event involving a single Reminder object.
Public delegate | DataSourceItemSynchronizedEventHandler | The delegate type for the event handlers of the DataSourceItemSynchronized event.
Public delegate | ListChangedEventHandler |

Enumerations

 | Enumeration | Description
Public enumeration | ActionTypeEnum | ActionTypeEnum determines the type of action.
Public enumeration | C1BrushStyleEnum | Specifies the different patterns available for brushes.
Public enumeration | FileFormatEnum | Specifies the format of the exported or imported file.
Public enumeration | ImportanceEnum | Determines the importance of the Appointment object.
Public enumeration | ListChangedType |
Public enumeration | RecurrenceStateEnum | Determines the type of the Appointment object.
Public enumeration | RecurrenceTypeEnum | Determines the types of recurrent appointments.
Public enumeration | SensitivityEnum | Determines the sensitivity of the Appointment object.
Public enumeration | StatusTypeEnum | Determines the type of status.
Public enumeration | SynchronizationActionEnum | Describes the version of data in a data storage.
Public enumeration | TimeScaleEnum | Determines the time interval which is used for displaying time slots in the DayView.
Public enumeration | WeekDaysEnum | Determines the set of days and groups of days for recurrence patterns.
Public enumeration | WeekOfMonthEnum | Determines the week in a month in which the appointment will occur.


Action Class

[image]

.NET Framework Class Library
Action Class
Members See Also
Represents an action to take when the current system time reaches the start of the associated Appointment object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class Action
Visual Basic
Public Class Action

Inheritance Hierarchy

System..::..Object
C1.C1Schedule..::..Action

See Also

Action Members
C1.C1Schedule Namespace


Action Members

[image] [image]

.NET Framework Class Library
Action Members
Action Class Constructors Methods Properties See Also

The Action type exposes the following members.

Constructors

 | Name | Description
Public method | Action()()()() | Initializes a new instance of the Action class.
Public method | Action(Appointment) | Initializes a new instance of the Action class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Command | Gets or sets the command string for the action.
Public property | Enabled | Gets or sets the Boolean value indicating whether the action is enabled. Default value is True.
Public property | Parameters | Gets or sets parameters used when the action is invoked.
Public property | ParentAppointment | Gets or sets the owning Appointment object.
Public property | Type | Gets or sets the ActionTypeEnum value determining the type of action that will occur. Default value is ActionTypeEnum.ExecuteApplication.

See Also

Action Class
C1.C1Schedule Namespace


Action Constructor

[image] [image]

.NET Framework Class Library
Action Constructor
Action Class See Also

Overload List

 | Name | Description
Public method | Action()()()() | Initializes a new instance of the Action class.
Public method | Action(Appointment) | Initializes a new instance of the Action class.

See Also

Action Class
Action Members
C1.C1Schedule Namespace


Action Constructor

[image]

.NET Framework Class Library
Action Constructor
Action Class See Also
Initializes a new instance of the Action class.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Action()
Visual Basic
Public Sub New

See Also

Action Class
Action Overload
C1.C1Schedule Namespace


Action Constructor (Appointment)

[image]

.NET Framework Class Library
Action Constructor (Appointment)
Action Class See Also
Initializes a new instance of the Action class.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Action(
    Appointment owner
)
Visual Basic
Public Sub New ( _
    owner As Appointment _
)

Parameters

owner
Type: C1.C1Schedule..::..Appointment
The Appointment object.

See Also

Action Class
Action Overload
C1.C1Schedule Namespace


Action Methods

[image] [image]

.NET Framework Class Library
Action Methods
Action Class See Also

The Action type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Action Class
C1.C1Schedule Namespace


Action Properties

[image] [image]

.NET Framework Class Library
Action Properties
Action Class See Also

The Action type exposes the following members.

Properties

 | Name | Description
Public property | Command | Gets or sets the command string for the action.
Public property | Enabled | Gets or sets the Boolean value indicating whether the action is enabled. Default value is True.
Public property | Parameters | Gets or sets parameters used when the action is invoked.
Public property | ParentAppointment | Gets or sets the owning Appointment object.
Public property | Type | Gets or sets the ActionTypeEnum value determining the type of action that will occur. Default value is ActionTypeEnum.ExecuteApplication.

See Also

Action Class
C1.C1Schedule Namespace


Command Property

[image]

.NET Framework Class Library
Action..::..Command Property
Action Class See Also
Gets or sets the command string for the action.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string Command { get; set; }
Visual Basic
Public Property Command As String
    Get
    Set

See Also

Action Class
C1.C1Schedule Namespace


Enabled Property

[image]

.NET Framework Class Library
Action..::..Enabled Property
Action Class See Also
Gets or sets the Boolean value indicating whether the action is enabled. Default value is True.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set

See Also

Action Class
C1.C1Schedule Namespace


Parameters Property

[image]

.NET Framework Class Library
Action..::..Parameters Property
Action Class See Also
Gets or sets parameters used when the action is invoked.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string Parameters { get; set; }
Visual Basic
Public Property Parameters As String
    Get
    Set

See Also

Action Class
C1.C1Schedule Namespace


ParentAppointment Property

[image]

.NET Framework Class Library
Action..::..ParentAppointment Property
Action Class See Also
Gets or sets the owning Appointment object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Appointment ParentAppointment { get; set; }
Visual Basic
Public Property ParentAppointment As Appointment
    Get
    Set

See Also

Action Class
C1.C1Schedule Namespace


Type Property

[image]

.NET Framework Class Library
Action..::..Type Property
Action Class See Also
Gets or sets the ActionTypeEnum value determining the type of action that will occur. Default value is ActionTypeEnum.ExecuteApplication.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ActionTypeEnum Type { get; set; }
Visual Basic
Public Property Type As ActionTypeEnum
    Get
    Set

See Also

Action Class
C1.C1Schedule Namespace


ActionCollection Class

[image]

.NET Framework Class Library
ActionCollection Class
Members See Also
The ActionCollection is a collection of all Action objects that represents the reminders for all pending items.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class ActionCollection : C1ObservableCollection<Action>,
    IDisposable
Visual Basic
Public Class ActionCollection _
    Inherits C1ObservableCollection(Of Action) _
    Implements IDisposable

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' Action >)>)>
C1.C1Schedule..::..C1ObservableCollection <(Of <(<' Action >)>)>
C1.C1Schedule..::..ActionCollection

See Also

ActionCollection Members
C1.C1Schedule Namespace


ActionCollection Members

[image] [image]

.NET Framework Class Library
ActionCollection Members
ActionCollection Class Methods Properties Explicit Interface Implementations See Also

The ActionCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Action >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Action >)>)>.)
Protected method | ClearItems | Overrides default behavior. (Overrides C1ObservableCollection<(Of <(<'T>)>)>..::..ClearItems()()()().)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Action >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Action >)>)>.)
Public method | Dispose | Releases all unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Action >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Action >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Action >)>)>.)
Protected method | InsertItem | Overrides default behavior. (Overrides C1ObservableCollection<(Of <(<'T>)>)>..::..InsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Action >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Action >)>)>.)
Protected method | RemoveItem | Overrides default behavior. (Overrides C1ObservableCollection<(Of <(<'T>)>)>..::..RemoveItem(Int32).)
Protected method | SetItem | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Action >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Action >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Action >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' Action >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' Action >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' Action >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' Action >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' Action >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' Action >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' Action >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' Action >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' Action >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' Action >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Action >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' Action >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' Action >)>)>.)

See Also

ActionCollection Class
C1.C1Schedule Namespace


ActionCollection Methods

[image] [image]

.NET Framework Class Library
ActionCollection Methods
ActionCollection Class See Also

The ActionCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Action >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Action >)>)>.)
Protected method | ClearItems | Overrides default behavior. (Overrides C1ObservableCollection<(Of <(<'T>)>)>..::..ClearItems()()()().)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Action >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Action >)>)>.)
Public method | Dispose | Releases all unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Action >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Action >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Action >)>)>.)
Protected method | InsertItem | Overrides default behavior. (Overrides C1ObservableCollection<(Of <(<'T>)>)>..::..InsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Action >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Action >)>)>.)
Protected method | RemoveItem | Overrides default behavior. (Overrides C1ObservableCollection<(Of <(<'T>)>)>..::..RemoveItem(Int32).)
Protected method | SetItem | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' Action >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' Action >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' Action >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' Action >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' Action >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' Action >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' Action >)>)>.)

See Also

ActionCollection Class
C1.C1Schedule Namespace


ClearItems Method

[image]

.NET Framework Class Library
ActionCollection..::..ClearItems Method
ActionCollection Class See Also
Overrides default behavior.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void ClearItems()
Visual Basic
Protected Overrides Sub ClearItems

See Also

ActionCollection Class
C1.C1Schedule Namespace


Dispose Method

[image]

.NET Framework Class Library
ActionCollection..::..Dispose Method
ActionCollection Class See Also
Releases all unmanaged resources.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

See Also

ActionCollection Class
C1.C1Schedule Namespace


InsertItem Method

[image]

.NET Framework Class Library
ActionCollection..::..InsertItem Method
ActionCollection Class See Also
Overrides default behavior.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void InsertItem(
    int index,
    Action item
)
Visual Basic
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As Action _
)

Parameters

index
Type: System..::..Int32
The zero-based index of the item.
item
Type: C1.C1Schedule..::..Action
The Action object to insert.

See Also

ActionCollection Class
C1.C1Schedule Namespace


RemoveItem Method

[image]

.NET Framework Class Library
ActionCollection..::..RemoveItem Method
ActionCollection Class See Also
Overrides default behavior.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void RemoveItem(
    int index
)
Visual Basic
Protected Overrides Sub RemoveItem ( _
    index As Integer _
)

Parameters

index
Type: System..::..Int32
The zero-based index of the item to remove.

See Also

ActionCollection Class
C1.C1Schedule Namespace


ActionCollection Properties

[image] [image]

.NET Framework Class Library
ActionCollection Properties
ActionCollection Class See Also

The ActionCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Action >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Action >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Action >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' Action >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' Action >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' Action >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' Action >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Action >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' Action >)>)>.)

See Also

ActionCollection Class
C1.C1Schedule Namespace


ActionCollection Events

[image] [image]

.NET Framework Class Library
ActionCollection Events
ActionCollection Class See Also

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)

See Also

ActionCollection Class
C1.C1Schedule Namespace


ActionTypeEnum Enumeration

[image]

.NET Framework Class Library
ActionTypeEnum Enumeration
See Also
ActionTypeEnum determines the type of action.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public enum ActionTypeEnum
Visual Basic
Public Enumeration ActionTypeEnum

Members

Member name | Description
ExecuteApplication | Execute local application with specified parameters.
NavigateToUrl | Open specified target in default browser.

See Also

C1.C1Schedule Namespace


AddingNewEventArgs Class

[image]

.NET Framework Class Library
AddingNewEventArgs Class
Members See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class AddingNewEventArgs : EventArgs
Visual Basic
Public Class AddingNewEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
C1.C1Schedule..::..AddingNewEventArgs

See Also

AddingNewEventArgs Members
C1.C1Schedule Namespace


AddingNewEventArgs Members

[image] [image]

.NET Framework Class Library
AddingNewEventArgs Members
AddingNewEventArgs Class Constructors Methods Properties See Also

The AddingNewEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | AddingNewEventArgs()()()() |
Public method | AddingNewEventArgs(Object) |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | NewObject |

See Also

AddingNewEventArgs Class
C1.C1Schedule Namespace


AddingNewEventArgs Constructor

[image] [image]

.NET Framework Class Library
AddingNewEventArgs Constructor
AddingNewEventArgs Class See Also

Overload List

 | Name | Description
Public method | AddingNewEventArgs()()()() |
Public method | AddingNewEventArgs(Object) |

See Also

AddingNewEventArgs Class
AddingNewEventArgs Members
C1.C1Schedule Namespace


AddingNewEventArgs Constructor

[image]

.NET Framework Class Library
AddingNewEventArgs Constructor
AddingNewEventArgs Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public AddingNewEventArgs()
Visual Basic
Public Sub New

See Also

AddingNewEventArgs Class
AddingNewEventArgs Overload
C1.C1Schedule Namespace


AddingNewEventArgs Constructor (Object)

[image]

.NET Framework Class Library
AddingNewEventArgs Constructor (Object)
AddingNewEventArgs Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public AddingNewEventArgs(
    Object newObject
)
Visual Basic
Public Sub New ( _
    newObject As Object _
)

Parameters

newObject
Type: System..::..Object

See Also

AddingNewEventArgs Class
AddingNewEventArgs Overload
C1.C1Schedule Namespace


AddingNewEventArgs Methods

[image] [image]

.NET Framework Class Library
AddingNewEventArgs Methods
AddingNewEventArgs Class See Also

The AddingNewEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddingNewEventArgs Class
C1.C1Schedule Namespace


AddingNewEventArgs Properties

[image] [image]

.NET Framework Class Library
AddingNewEventArgs Properties
AddingNewEventArgs Class See Also

The AddingNewEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | NewObject |

See Also

AddingNewEventArgs Class
C1.C1Schedule Namespace


NewObject Property

[image]

.NET Framework Class Library
AddingNewEventArgs..::..NewObject Property
AddingNewEventArgs Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object NewObject { get; set; }
Visual Basic
Public Property NewObject As Object
    Get
    Set

See Also

AddingNewEventArgs Class
C1.C1Schedule Namespace


AddingNewEventHandler Delegate

[image]

.NET Framework Class Library
AddingNewEventHandler Delegate
See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public delegate void AddingNewEventHandler(
    Object sender,
    AddingNewEventArgs e
)
Visual Basic
Public Delegate Sub AddingNewEventHandler ( _
    sender As Object, _
    e As AddingNewEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: C1.C1Schedule..::..AddingNewEventArgs

See Also

C1.C1Schedule Namespace


Appointment Class

[image]

.NET Framework Class Library
Appointment Class
Members See Also
The Appointment object is a meeting, a one-time appointment, or a recurring appointment or meeting in the C1Schedule. The Appointment class includes properties that specify meeting details such as the location and time.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class Appointment : BasePersistableObject
Visual Basic
Public Class Appointment _
    Inherits BasePersistableObject

Inheritance Hierarchy

System..::..Object
C1.C1Schedule..::..BasePersistableObject
C1.C1Schedule..::..Appointment

See Also

Appointment Members
C1.C1Schedule Namespace


Appointment Members

[image] [image]

.NET Framework Class Library
Appointment Members
Appointment Class Constructors Methods Properties Explicit Interface Implementations See Also

The Appointment type exposes the following members.

Constructors

 | Name | Description
Public method | Appointment()()()() | Initializes a new instance of the Appointment class.
Public method | Appointment(Guid) | Initializes a new instance of the Appointment class with the specified key.
Public method | Appointment(Int32) | Initializes a new instance of the Appointment class with the specified key.
Public method | Appointment(DateTime, DateTime) | Initializes a new instance of the Appointment class with the specified parameters.
Public method | Appointment(DateTime, TimeSpan) | Initializes a new instance of the Appointment class with the specified parameters.
Public method | Appointment(DateTime, DateTime, String) | Initializes a new instance of the Appointment class with the specified parameters.
Public method | Appointment(DateTime, TimeSpan, String) | Initializes a new instance of the Appointment class with the specified parameters.

Methods

 | Name | Description
Public method | BeginEdit | Prevents the Appointment object from being updated until the EndEdit(Boolean) method is called. (Overrides BasePersistableObject..::..BeginEdit()()()().)
Protected method | BeginEditInternal | (Inherited from BasePersistableObject.)
Public method | CancelEdit | Discards changes since the last BeginEdit()()()() call. (Inherited from BasePersistableObject.)
Public method | ClearRecurrencePattern | Removes the recurrence settings and restores the NotRecurring state for an appointment.
Public method | Copy | Creates the copy of the Appointment object.
Public method | CopyFrom | Copies properties from the specified Appointment object to this one.
Public method | Delete | Deletes an appointment and removes it from the owning AppointmentCollection collection.
Public method | EndEdit()()()() | Finishes edit mode started by the BeginEdit()()()() method and updates a corresponding data source item. (Inherited from BasePersistableObject.)
Protected method | EndEdit(Boolean) | Unlocks the Appointment object after a call to the BeginEdit()()()() method and causes an immediate update. (Overrides BasePersistableObject..::..EndEdit(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromXml(XmlReader) | Reconstructs appointment from an XmlReader. (Overrides BasePersistableObject..::..FromXml(XmlReader).)
Public method | FromXml(Stream) | Loads an object from the specified Stream. (Inherited from BasePersistableObject.)
Public method | GetAppointmentProperties | Returns XML encoding of appointment properties.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRecurrencePattern | Returns the RecurrencePattern object that represents the recurrence attributes of an appointment. If there is no existing recurrence pattern, a new empty RecurrencePattern object is returned.
Public method | GetTimeTillEvent | Returns a time term before the appointment start; a negative value means that appointment is expired.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsGroupMember | Returns True if the current Appointment object is a member of a group which is specified by the groupOwner and groupBy parameters; False otherwise.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Overrides default behavior. (Overrides BasePersistableObject..::..OnPropertyChanged(String).)
Public method | SetAppointmentProperties | Reconstructs appointment properties from the specified string.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToXml(XmlWriter) | Creates an XML encoding of the appointment. (Overrides BasePersistableObject..::..ToXml(XmlWriter).)
Public method | ToXml(Stream) | Saves an object to the specified Stream. (Inherited from BasePersistableObject.)

Properties

 | Name | Description
Public property | Action | Gets an Action object for the Appointment object. Once this property is first requested, a new Action object is created and assigned to the Action property.
Public property | AllDayEvent | Gets or sets the Boolean value indicating if the current appointment is an All-day appointment.
Public property | AutoResolvedWinner | Gets the Boolean value determining if the item is a winner of an automatic conflict resolution.
Public property | Body | Gets or sets the String value representing the body of the Appointment object.
Public property | BusyStatus | Gets or sets the Status object indicating the busy status of the user for the appointment.
Public property | Categories | Gets the CategoryList object which holds the set of categories assigned to the appointment. Categories may be associated with an appointment to effectively group appointments. An appointment may be associated with multiple categories.
Public property | Conflicts | Gets the AppointmentList object representing the list of Appointment objects which are in conflict with this particular appointment.
Public property | CustomData | Gets or sets custom text associated with this object.
Public property | Duration | Gets or sets the TimeSpan value indicating the duration of the appointment.
Public property | End | Gets or sets the DateTime value determining the end date and time of the appointment.
Public property | Importance | Gets or sets the ImportanceEnum value indicating the relative importance level for the appointment. Default value is Normal.
Public property | IsEdit | Indicates whether the object is in edit mode, which is started using the BeginEdit()()()() method. (Inherited from BasePersistableObject.)
Public property | IsOneDay | Gets a Boolean value indicating either it is a one day appointment or shares some days.
Public property | IsRecurring | Gets the Boolean value indicating if the appointment is recurring.
Public property | Key | Gets an array of objects representing the key of the BasePersistableObject. (Inherited from BasePersistableObject.)
Public property | Label | Gets or sets the Label object associated with this appointment.
Public property | Links | Gets the ContactList object which holds the set of Contact objects for this appointment. An appointment may be associated with multiple contacts.
Public property | Location | Gets or sets the String value specifying where the appointment is going to be.
Public property | Owner | Gets or sets the Contact object which owns current Appointment object.
Public property | ParentCollection | Gets the reference to the parent AppointmentCollection object.
Public property | ParentRecurrence | Gets the Appointment object that defines the recurrence criteria for this Appointment object. If this appointment is a not member of a recurrence, or is itself a root appointment, null is returned.
Public property | Private | Gets or sets the Boolean value determining whether the calendar owner intends to keep the Appointment object private.
Public property | RecurrenceState | Gets the RecurrenceStateEnum value indicating the recurrence state of the appointment.
Public property | Reminder | Gets the Reminder object which is associated with the appointment. To associate an appointment with the reminder, set its ReminderSet property to true. Once this property is set to true, a new Reminder object is created and assigned to the Reminder property.
Public property | ReminderOverrideDefault | Gets or sets the Boolean value indicating if the associated Reminder object has non-default settings. True if the reminder overrides the default reminder behavior for the appointment. You must set the ReminderOverrideDefault property to validate the ReminderPlaySound and the ReminderSoundFile properties.
Public property | ReminderPlaySound | Gets or sets the Boolean value indicating if the reminder should play a sound when it occurs for this appointment or task. The ReminderPlaySound property must be set in order to validate the ReminderSoundFile property. This property is only valid if the ReminderOverrideDefault property is set to true.
Public property | ReminderSet | Gets or sets the Boolean value indicating whether a reminder is associated with the appointment. Once this property is set to true, a new Reminder object is created and assigned to the Reminder property.
Public property | ReminderSoundFile | Gets or sets the String value indicating the path and file name of the sound file to play when the reminder occurs for the appointment. This property is only valid if the ReminderOverrideDefault and ReminderPlaySound properties are set to true.
Public property | ReminderTimeBeforeStart | Gets or sets the TimeSpan value indicating the interval of time the reminder should occur prior to the start of the appointment.
Public property | Resources | Gets the ResourceList object which holds the set of Resource objects for this appointment. An appointment may be associated with multiple resources.
Public property | Saved | Gets the Boolean value indicating if the appointment has not been modified since the last save.
Public property | Sensitivity | Gets or sets the SensitivityEnum value indicating the sensitivity level of the appointment.
Public property | Start | Gets or sets the DateTime value determining the start date and time of the appointment.
Public property | Subject | Gets or sets the String value representing the subject of the Appointment object.
Public property | Tag | Gets or sets custom information associated with this object.

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged | (Inherited from BasePersistableObject.)

See Also

Appointment Class
C1.C1Schedule Namespace


Appointment Constructor

[image] [image]

.NET Framework Class Library
Appointment Constructor
Appointment Class See Also

Overload List

 | Name | Description
Public method | Appointment()()()() | Initializes a new instance of the Appointment class.
Public method | Appointment(Guid) | Initializes a new instance of the Appointment class with the specified key.
Public method | Appointment(Int32) | Initializes a new instance of the Appointment class with the specified key.
Public method | Appointment(DateTime, DateTime) | Initializes a new instance of the Appointment class with the specified parameters.
Public method | Appointment(DateTime, TimeSpan) | Initializes a new instance of the Appointment class with the specified parameters.
Public method | Appointment(DateTime, DateTime, String) | Initializes a new instance of the Appointment class with the specified parameters.
Public method | Appointment(DateTime, TimeSpan, String) | Initializes a new instance of the Appointment class with the specified parameters.

See Also

Appointment Class
Appointment Members
C1.C1Schedule Namespace


Appointment Constructor

[image]

.NET Framework Class Library
Appointment Constructor
Appointment Class See Also
Initializes a new instance of the Appointment class.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Appointment()
Visual Basic
Public Sub New

Remarks

Creates an appointment with default properties.

See Also

Appointment Class
Appointment Overload
C1.C1Schedule Namespace


Appointment Constructor (Guid)

[image]

.NET Framework Class Library
Appointment Constructor (Guid)
Appointment Class See Also
Initializes a new instance of the Appointment class with the specified key.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Appointment(
    Guid key
)
Visual Basic
Public Sub New ( _
    key As Guid _
)

Parameters

key
Type: System..::..Guid
The Guid value which should be used as appointment key.

Remarks

Use this constructor if your business logic requires setting custom key value. Make sure that you use the correct constructor overload (with integer or Guid key value) and that key value is unique.

See Also

Appointment Class
Appointment Overload
C1.C1Schedule Namespace


Appointment Constructor (Int32)

[image]

.NET Framework Class Library
Appointment Constructor (Int32)
Appointment Class See Also
Initializes a new instance of the Appointment class with the specified key.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Appointment(
    int key
)
Visual Basic
Public Sub New ( _
    key As Integer _
)

Parameters

key
Type: System..::..Int32
The Int32 value which should be used as appointment key.

Remarks

Use this constructor if your business logic requires setting custom key value. Make sure that you use the correct constructor overload (with integer or Guid key value) and that key value is unique.

See Also

Appointment Class
Appointment Overload
C1.C1Schedule Namespace


Appointment Constructor (DateTime, DateTime)

[image]

.NET Framework Class Library
Appointment Constructor (DateTime, DateTime)
Appointment Class See Also
Initializes a new instance of the Appointment class with the specified parameters.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Appointment(
    DateTime start,
    DateTime end
)
Visual Basic
Public Sub New ( _
    start As DateTime, _
    end As DateTime _
)

Parameters

start
Type: System..::..DateTime
The DateTime value which specifies the start date and time of the appointment.
end
Type: System..::..DateTime
The DateTime value which specifies the end date and time of the appointment.

See Also

Appointment Class
Appointment Overload
C1.C1Schedule Namespace


Appointment Constructor (DateTime, TimeSpan)

[image]

.NET Framework Class Library
Appointment Constructor (DateTime, TimeSpan)
Appointment Class See Also
Initializes a new instance of the Appointment class with the specified parameters.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Appointment(
    DateTime start,
    TimeSpan duration
)
Visual Basic
Public Sub New ( _
    start As DateTime, _
    duration As TimeSpan _
)

Parameters

start
Type: System..::..DateTime
The DateTime value which specifies the start date and time of the appointment.
duration
Type: System..::..TimeSpan
The TimeSpan value which specifies the duration of the appointment.

See Also

Appointment Class
Appointment Overload
C1.C1Schedule Namespace


Appointment Constructor (DateTime, DateTime, String)

[image]

.NET Framework Class Library
Appointment Constructor (DateTime, DateTime, String)
Appointment Class See Also
Initializes a new instance of the Appointment class with the specified parameters.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Appointment(
    DateTime start,
    DateTime end,
    string subject
)
Visual Basic
Public Sub New ( _
    start As DateTime, _
    end As DateTime, _
    subject As String _
)

Parameters

start
Type: System..::..DateTime
The DateTime value which specifies the start date and time of the appointment.
end
Type: System..::..DateTime
The DateTime value which specifies the end date and time of the appointment.
subject
Type: System..::..String
The String value which contains the subject of the appointment.

See Also

Appointment Class
Appointment Overload
C1.C1Schedule Namespace


Appointment Constructor (DateTime, TimeSpan, String)

[image]

.NET Framework Class Library
Appointment Constructor (DateTime, TimeSpan, String)
Appointment Class See Also
Initializes a new instance of the Appointment class with the specified parameters.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Appointment(
    DateTime start,
    TimeSpan duration,
    string subject
)
Visual Basic
Public Sub New ( _
    start As DateTime, _
    duration As TimeSpan, _
    subject As String _
)

Parameters

start
Type: System..::..DateTime
The DateTime value which specifies the start date and time of the appointment.
duration
Type: System..::..TimeSpan
The TimeSpan value which specifies the duration of the appointment.
subject
Type: System..::..String
The String value which contains the subject of the appointment.

See Also

Appointment Class
Appointment Overload
C1.C1Schedule Namespace


Appointment Methods

[image] [image]

.NET Framework Class Library
Appointment Methods
Appointment Class See Also

The Appointment type exposes the following members.

Methods

 | Name | Description
Public method | BeginEdit | Prevents the Appointment object from being updated until the EndEdit(Boolean) method is called. (Overrides BasePersistableObject..::..BeginEdit()()()().)
Protected method | BeginEditInternal | (Inherited from BasePersistableObject.)
Public method | CancelEdit | Discards changes since the last BeginEdit()()()() call. (Inherited from BasePersistableObject.)
Public method | ClearRecurrencePattern | Removes the recurrence settings and restores the NotRecurring state for an appointment.
Public method | Copy | Creates the copy of the Appointment object.
Public method | CopyFrom | Copies properties from the specified Appointment object to this one.
Public method | Delete | Deletes an appointment and removes it from the owning AppointmentCollection collection.
Public method | EndEdit()()()() | Finishes edit mode started by the BeginEdit()()()() method and updates a corresponding data source item. (Inherited from BasePersistableObject.)
Protected method | EndEdit(Boolean) | Unlocks the Appointment object after a call to the BeginEdit()()()() method and causes an immediate update. (Overrides BasePersistableObject..::..EndEdit(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromXml(XmlReader) | Reconstructs appointment from an XmlReader. (Overrides BasePersistableObject..::..FromXml(XmlReader).)
Public method | FromXml(Stream) | Loads an object from the specified Stream. (Inherited from BasePersistableObject.)
Public method | GetAppointmentProperties | Returns XML encoding of appointment properties.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRecurrencePattern | Returns the RecurrencePattern object that represents the recurrence attributes of an appointment. If there is no existing recurrence pattern, a new empty RecurrencePattern object is returned.
Public method | GetTimeTillEvent | Returns a time term before the appointment start; a negative value means that appointment is expired.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsGroupMember | Returns True if the current Appointment object is a member of a group which is specified by the groupOwner and groupBy parameters; False otherwise.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Overrides default behavior. (Overrides BasePersistableObject..::..OnPropertyChanged(String).)
Public method | SetAppointmentProperties | Reconstructs appointment properties from the specified string.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToXml(XmlWriter) | Creates an XML encoding of the appointment. (Overrides BasePersistableObject..::..ToXml(XmlWriter).)
Public method | ToXml(Stream) | Saves an object to the specified Stream. (Inherited from BasePersistableObject.)

See Also

Appointment Class
C1.C1Schedule Namespace


BeginEdit Method

[image]

.NET Framework Class Library
Appointment..::..BeginEdit Method
Appointment Class See Also
Prevents the Appointment object from being updated until the EndEdit(Boolean) method is called.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override void BeginEdit()
Visual Basic
Public Overrides Sub BeginEdit

Remarks

The BeginEdit()()()() and EndEdit(Boolean) methods are designed to implement batch modifications. This allows you to prevent generation of change notifications when changing multiple settings at the same time. To do this enclose the code that changes the properties in calls to these methods. Each call to BeginEdit()()()() must be paired with a call to EndEdit(Boolean). To ensure that EndEdit(Boolean) is always called even if an exception occurs, wrap any calls to these methods in a try...finally statement.

See Also

Appointment Class
C1.C1Schedule Namespace


ClearRecurrencePattern Method

[image]

.NET Framework Class Library
Appointment..::..ClearRecurrencePattern Method
Appointment Class See Also
Removes the recurrence settings and restores the NotRecurring state for an appointment.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void ClearRecurrencePattern()
Visual Basic
Public Sub ClearRecurrencePattern

See Also

Appointment Class
C1.C1Schedule Namespace


Copy Method

[image]

.NET Framework Class Library
Appointment..::..Copy Method
Appointment Class See Also
Creates the copy of the Appointment object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Appointment Copy()
Visual Basic
Public Function Copy As Appointment

Return Value

The new Appointment instance.

See Also

Appointment Class
C1.C1Schedule Namespace


CopyFrom Method

[image]

.NET Framework Class Library
Appointment..::..CopyFrom Method
Appointment Class See Also
Copies properties from the specified Appointment object to this one.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void CopyFrom(
    Appointment app,
    bool includeKeys
)
Visual Basic
Public Sub CopyFrom ( _
    app As Appointment, _
    includeKeys As Boolean _
)

Parameters

app
Type: C1.C1Schedule..::..Appointment
The Appointment instance to copy.
includeKeys
Type: System..::..Boolean
Specifies whether to copy internal keys.

Remarks

Set includeKeys to true if you want to receive exact copy of the specified Appointment object.

Set includeKeys to false in order to copy only descriptive Appointment properties to other Appointment object (for example, if you want to duplicate appointment from one day to another).

See Also

Appointment Class
C1.C1Schedule Namespace


Delete Method

[image]

.NET Framework Class Library
Appointment..::..Delete Method
Appointment Class See Also
Deletes an appointment and removes it from the owning AppointmentCollection collection.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void Delete()
Visual Basic
Public Sub Delete

See Also

Appointment Class
C1.C1Schedule Namespace


EndEdit Method

[image] [image]

.NET Framework Class Library
Appointment..::..EndEdit Method
Appointment Class See Also

Overload List

 | Name | Description
Public method | EndEdit()()()() | Finishes edit mode started by the BeginEdit()()()() method and updates a corresponding data source item. (Inherited from BasePersistableObject.)
Protected method | EndEdit(Boolean) | Unlocks the Appointment object after a call to the BeginEdit()()()() method and causes an immediate update. (Overrides BasePersistableObject..::..EndEdit(Boolean).)

See Also

Appointment Class
Appointment Members
C1.C1Schedule Namespace


EndEdit Method (Boolean)

[image]

.NET Framework Class Library
Appointment..::..EndEdit Method (Boolean)
Appointment Class See Also
Unlocks the Appointment object after a call to the BeginEdit()()()() method and causes an immediate update.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void EndEdit(
    bool canRaiseChangeNotification
)
Visual Basic
Protected Overrides Sub EndEdit ( _
    canRaiseChangeNotification As Boolean _
)

Parameters

canRaiseChangeNotification
Type: System..::..Boolean
The Boolean value determining if change notifications can be generated when applying changes.

See Also

Appointment Class
EndEdit Overload
C1.C1Schedule Namespace


FromXml Method

[image] [image]

.NET Framework Class Library
Appointment..::..FromXml Method
Appointment Class See Also

Overload List

 | Name | Description
Public method | FromXml(XmlReader) | Reconstructs appointment from an XmlReader. (Overrides BasePersistableObject..::..FromXml(XmlReader).)
Public method | FromXml(Stream) | Loads an object from the specified Stream. (Inherited from BasePersistableObject.)

See Also

Appointment Class
Appointment Members
C1.C1Schedule Namespace


FromXml Method (XmlReader)

[image]

.NET Framework Class Library
Appointment..::..FromXml Method (XmlReader)
Appointment Class See Also
Reconstructs appointment from an XmlReader.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override bool FromXml(
    XmlReader reader
)
Visual Basic
Public Overrides Function FromXml ( _
    reader As XmlReader _
) As Boolean

Parameters

reader
Type: System.Xml..::..XmlReader
An XmlReader which contains the Appointment data.

Return Value

True if appointment has been changed.

See Also

Appointment Class
FromXml Overload
C1.C1Schedule Namespace


GetAppointmentProperties Method

[image]

.NET Framework Class Library
Appointment..::..GetAppointmentProperties Method
Appointment Class See Also
Returns XML encoding of appointment properties.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string GetAppointmentProperties()
Visual Basic
Public Function GetAppointmentProperties As String

Return Value

The String value containing XML encoding of appointment properties.

Remarks

Use this property to get the same string as serialized value of appointment properties, which you get when set mapping for AppointmentProperties.

See Also

Appointment Class
C1.C1Schedule Namespace


GetRecurrencePattern Method

[image]

.NET Framework Class Library
Appointment..::..GetRecurrencePattern Method
Appointment Class See Also
Returns the RecurrencePattern object that represents the recurrence attributes of an appointment. If there is no existing recurrence pattern, a new empty RecurrencePattern object is returned.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public RecurrencePattern GetRecurrencePattern()
Visual Basic
Public Function GetRecurrencePattern As RecurrencePattern

Return Value

The RecurrencePattern object.

See Also

Appointment Class
C1.C1Schedule Namespace


GetTimeTillEvent Method

[image]

.NET Framework Class Library
Appointment..::..GetTimeTillEvent Method
Appointment Class See Also
Returns a time term before the appointment start; a negative value means that appointment is expired.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public TimeSpan GetTimeTillEvent()
Visual Basic
Public Function GetTimeTillEvent As TimeSpan

Return Value

A time term before the appointment starts; a negative value means that the appointment has expired.

See Also

Appointment Class
C1.C1Schedule Namespace


IsGroupMember Method

[image]

.NET Framework Class Library
Appointment..::..IsGroupMember Method
Appointment Class See Also
Returns True if the current Appointment object is a member of a group which is specified by the groupOwner and groupBy parameters; False otherwise.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsGroupMember(
    BaseObject groupOwner,
    string groupBy
)
Visual Basic
Public Function IsGroupMember ( _
    groupOwner As BaseObject, _
    groupBy As String _
) As Boolean

Parameters

groupOwner
Type: C1.C1Schedule..::..BaseObject
The BaseObject object determining the appointment group.
groupBy
Type: System..::..String
The String value determining the type of grouping.

Return Value

See Also

Appointment Class
C1.C1Schedule Namespace


OnPropertyChanged Method

[image]

.NET Framework Class Library
Appointment..::..OnPropertyChanged Method
Appointment Class See Also
Overrides default behavior.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnPropertyChanged(
    string propertyName
)
Visual Basic
Protected Overrides Sub OnPropertyChanged ( _
    propertyName As String _
)

Parameters

propertyName
Type: System..::..String
The property name.

See Also

Appointment Class
C1.C1Schedule Namespace


SetAppointmentProperties Method

[image]

.NET Framework Class Library
Appointment..::..SetAppointmentProperties Method
Appointment Class See Also
Reconstructs appointment properties from the specified string.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool SetAppointmentProperties(
    string source
)
Visual Basic
Public Function SetAppointmentProperties ( _
    source As String _
) As Boolean

Parameters

source
Type: System..::..String
The String value containing XML encoding of appointment properties.

Return Value

True if appointment has been changed.

See Also

Appointment Class
C1.C1Schedule Namespace


ToXml Method

[image] [image]

.NET Framework Class Library
Appointment..::..ToXml Method
Appointment Class See Also

Overload List

 | Name | Description
Public method | ToXml(XmlWriter) | Creates an XML encoding of the appointment. (Overrides BasePersistableObject..::..ToXml(XmlWriter).)
Public method | ToXml(Stream) | Saves an object to the specified Stream. (Inherited from BasePersistableObject.)

See Also

Appointment Class
Appointment Members
C1.C1Schedule Namespace


ToXml Method (XmlWriter)

[image]

.NET Framework Class Library
Appointment..::..ToXml Method (XmlWriter)
Appointment Class See Also
Creates an XML encoding of the appointment.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override void ToXml(
    XmlWriter writer
)
Visual Basic
Public Overrides Sub ToXml ( _
    writer As XmlWriter _
)

Parameters

writer
Type: System.Xml..::..XmlWriter
The XmlWriter that will receive the object data.

See Also

Appointment Class
ToXml Overload
C1.C1Schedule Namespace


Appointment Properties

[image] [image]

.NET Framework Class Library
Appointment Properties
Appointment Class See Also

The Appointment type exposes the following members.

Properties

 | Name | Description
Public property | Action | Gets an Action object for the Appointment object. Once this property is first requested, a new Action object is created and assigned to the Action property.
Public property | AllDayEvent | Gets or sets the Boolean value indicating if the current appointment is an All-day appointment.
Public property | AutoResolvedWinner | Gets the Boolean value determining if the item is a winner of an automatic conflict resolution.
Public property | Body | Gets or sets the String value representing the body of the Appointment object.
Public property | BusyStatus | Gets or sets the Status object indicating the busy status of the user for the appointment.
Public property | Categories | Gets the CategoryList object which holds the set of categories assigned to the appointment. Categories may be associated with an appointment to effectively group appointments. An appointment may be associated with multiple categories.
Public property | Conflicts | Gets the AppointmentList object representing the list of Appointment objects which are in conflict with this particular appointment.
Public property | CustomData | Gets or sets custom text associated with this object.
Public property | Duration | Gets or sets the TimeSpan value indicating the duration of the appointment.
Public property | End | Gets or sets the DateTime value determining the end date and time of the appointment.
Public property | Importance | Gets or sets the ImportanceEnum value indicating the relative importance level for the appointment. Default value is Normal.
Public property | IsEdit | Indicates whether the object is in edit mode, which is started using the BeginEdit()()()() method. (Inherited from BasePersistableObject.)
Public property | IsOneDay | Gets a Boolean value indicating either it is a one day appointment or shares some days.
Public property | IsRecurring | Gets the Boolean value indicating if the appointment is recurring.
Public property | Key | Gets an array of objects representing the key of the BasePersistableObject. (Inherited from BasePersistableObject.)
Public property | Label | Gets or sets the Label object associated with this appointment.
Public property | Links | Gets the ContactList object which holds the set of Contact objects for this appointment. An appointment may be associated with multiple contacts.
Public property | Location | Gets or sets the String value specifying where the appointment is going to be.
Public property | Owner | Gets or sets the Contact object which owns current Appointment object.
Public property | ParentCollection | Gets the reference to the parent AppointmentCollection object.
Public property | ParentRecurrence | Gets the Appointment object that defines the recurrence criteria for this Appointment object. If this appointment is a not member of a recurrence, or is itself a root appointment, null is returned.
Public property | Private | Gets or sets the Boolean value determining whether the calendar owner intends to keep the Appointment object private.
Public property | RecurrenceState | Gets the RecurrenceStateEnum value indicating the recurrence state of the appointment.
Public property | Reminder | Gets the Reminder object which is associated with the appointment. To associate an appointment with the reminder, set its ReminderSet property to true. Once this property is set to true, a new Reminder object is created and assigned to the Reminder property.
Public property | ReminderOverrideDefault | Gets or sets the Boolean value indicating if the associated Reminder object has non-default settings. True if the reminder overrides the default reminder behavior for the appointment. You must set the ReminderOverrideDefault property to validate the ReminderPlaySound and the ReminderSoundFile properties.
Public property | ReminderPlaySound | Gets or sets the Boolean value indicating if the reminder should play a sound when it occurs for this appointment or task. The ReminderPlaySound property must be set in order to validate the ReminderSoundFile property. This property is only valid if the ReminderOverrideDefault property is set to true.
Public property | ReminderSet | Gets or sets the Boolean value indicating whether a reminder is associated with the appointment. Once this property is set to true, a new Reminder object is created and assigned to the Reminder property.
Public property | ReminderSoundFile | Gets or sets the String value indicating the path and file name of the sound file to play when the reminder occurs for the appointment. This property is only valid if the ReminderOverrideDefault and ReminderPlaySound properties are set to true.
Public property | ReminderTimeBeforeStart | Gets or sets the TimeSpan value indicating the interval of time the reminder should occur prior to the start of the appointment.
Public property | Resources | Gets the ResourceList object which holds the set of Resource objects for this appointment. An appointment may be associated with multiple resources.
Public property | Saved | Gets the Boolean value indicating if the appointment has not been modified since the last save.
Public property | Sensitivity | Gets or sets the SensitivityEnum value indicating the sensitivity level of the appointment.
Public property | Start | Gets or sets the DateTime value determining the start date and time of the appointment.
Public property | Subject | Gets or sets the String value representing the subject of the Appointment object.
Public property | Tag | Gets or sets custom information associated with this object.

See Also

Appointment Class
C1.C1Schedule Namespace


Action Property

[image]

.NET Framework Class Library
Appointment..::..Action Property
Appointment Class See Also
Gets an Action object for the Appointment object. Once this property is first requested, a new Action object is created and assigned to the Action property.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Action Action { get; set; }
Visual Basic
Public Property Action As Action
    Get
    Set

Remarks

The Action object contains information regarding the type of action to perform as well as the command and parameters to pass to the action. If the action object is enabled, the action will be invoked when the start date and time of the owning Appointment object has occurred.

See Also

Appointment Class
C1.C1Schedule Namespace


AllDayEvent Property

[image]

.NET Framework Class Library
Appointment..::..AllDayEvent Property
Appointment Class See Also
Gets or sets the Boolean value indicating if the current appointment is an All-day appointment.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(false)]
public bool AllDayEvent { get; set; }
Visual Basic
<DefaultValueAttribute(False)> _
Public Property AllDayEvent As Boolean
    Get
    Set

See Also

Appointment Class
C1.C1Schedule Namespace


AutoResolvedWinner Property

[image]

.NET Framework Class Library
Appointment..::..AutoResolvedWinner Property
Appointment Class See Also
Gets the Boolean value determining if the item is a winner of an automatic conflict resolution.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(false)]
public bool AutoResolvedWinner { get; }
Visual Basic
<DefaultValueAttribute(False)> _
Public ReadOnly Property AutoResolvedWinner As Boolean
    Get

Remarks

A value of false does not necessarily indicate that the item is a loser of an automatic conflict resolution. The item should be in conflict with another item. If an item has its Conflicts.Count property greater than zero and if its AutoResolvedWinner property is true, it is a winner of an automatic conflict resolution. On the other hand, if the item is in conflict and has its AutoResolvedWinner property as false, it is a loser in an automatic conflict resolution.

See Also

Appointment Class
C1.C1Schedule Namespace


Body Property

[image]

.NET Framework Class Library
Appointment..::..Body Property
Appointment Class See Also
Gets or sets the String value representing the body of the Appointment object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute("")]
public string Body { get; set; }
Visual Basic
<DefaultValueAttribute("")> _
Public Property Body As String
    Get
    Set

See Also

Appointment Class
C1.C1Schedule Namespace


BusyStatus Property

[image]

.NET Framework Class Library
Appointment..::..BusyStatus Property
Appointment Class See Also
Gets or sets the Status object indicating the busy status of the user for the appointment.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(typeof(Status), "Free")]
public Status BusyStatus { get; set; }
Visual Basic
<DefaultValueAttribute(GetType(Status), "Free")> _
Public Property BusyStatus As Status
    Get
    Set

Remarks

This property only accepts Status objects which are present in the C1ScheduleStorage.StatusStorage storage.

See Also

Appointment Class
C1.C1Schedule Namespace


Categories Property

[image]

.NET Framework Class Library
Appointment..::..Categories Property
Appointment Class See Also
Gets the CategoryList object which holds the set of categories assigned to the appointment. Categories may be associated with an appointment to effectively group appointments. An appointment may be associated with multiple categories.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public CategoryList Categories { get; internal set; }
Visual Basic
Public Property Categories As CategoryList
    Get
    Friend Set

Remarks

This property only accepts Category objects which are present in the C1ScheduleStorage.CategoryStorage storage.

See Also

Appointment Class
C1.C1Schedule Namespace


Conflicts Property

[image]

.NET Framework Class Library
Appointment..::..Conflicts Property
Appointment Class See Also
Gets the AppointmentList object representing the list of Appointment objects which are in conflict with this particular appointment.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public AppointmentList Conflicts { get; }
Visual Basic
Public ReadOnly Property Conflicts As AppointmentList
    Get

See Also

Appointment Class
C1.C1Schedule Namespace


CustomData Property

[image]

.NET Framework Class Library
Appointment..::..CustomData Property
Appointment Class See Also
Gets or sets custom text associated with this object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(null)]
public string CustomData { get; set; }
Visual Basic
<DefaultValueAttribute(Nothing)> _
Public Property CustomData As String
    Get
    Set

Remarks

This property is serialized with other appointment properties. It isn't used by the scheduler, use it to keep your data associated with appointment. This property is serialized into xml and binary formats and it is saved into underlying data source if mapping for Appointment Properties is set. It isn't retained at export/import to iCal format.

See Also

Appointment Class
C1.C1Schedule Namespace


Duration Property

[image]

.NET Framework Class Library
Appointment..::..Duration Property
Appointment Class See Also
Gets or sets the TimeSpan value indicating the duration of the appointment.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(typeof(TimeSpan), "1:00:00")]
public TimeSpan Duration { get; set; }
Visual Basic
<DefaultValueAttribute(GetType(TimeSpan), "1:00:00")> _
Public Property Duration As TimeSpan
    Get
    Set

Remarks

At setting this property, if it's value is not equal to the whole number of days, the AllDayEvent property will be set to false.

See Also

Appointment Class
C1.C1Schedule Namespace


End Property

[image]

.NET Framework Class Library
Appointment..::..End Property
Appointment Class See Also
Gets or sets the DateTime value determining the end date and time of the appointment.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTime End { get; set; }
Visual Basic
Public Property End As DateTime
    Get
    Set

Remarks

The End property is usually specified by the Start and Duration properties, and is always calculated as End = Start + Duration. When setting the End property, the Start property retains its value, and the Duration is changed according to the new value of the End property. If the new End property's value is less than the Start property's value, then an exception will be raised.

At setting this property, if it's time is not equal 0:00, or value is equal to the value of Start property, the AllDayEvent property will be set to false.

See Also

Appointment Class
C1.C1Schedule Namespace


Importance Property

[image]

.NET Framework Class Library
Appointment..::..Importance Property
Appointment Class See Also
Gets or sets the ImportanceEnum value indicating the relative importance level for the appointment. Default value is Normal.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(ImportanceEnum.Normal)]
public ImportanceEnum Importance { get; set; }
Visual Basic
<DefaultValueAttribute(ImportanceEnum.Normal)> _
Public Property Importance As ImportanceEnum
    Get
    Set

See Also

Appointment Class
C1.C1Schedule Namespace


IsOneDay Property

[image]

.NET Framework Class Library
Appointment..::..IsOneDay Property
Appointment Class See Also
Gets a Boolean value indicating either it is a one day appointment or shares some days.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsOneDay { get; }
Visual Basic
Public ReadOnly Property IsOneDay As Boolean
    Get

See Also

Appointment Class
C1.C1Schedule Namespace


IsRecurring Property

[image]

.NET Framework Class Library
Appointment..::..IsRecurring Property
Appointment Class See Also
Gets the Boolean value indicating if the appointment is recurring.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsRecurring { get; }
Visual Basic
Public ReadOnly Property IsRecurring As Boolean
    Get

See Also

Appointment Class
C1.C1Schedule Namespace


Label Property

[image]

.NET Framework Class Library
Appointment..::..Label Property
Appointment Class See Also
Gets or sets the Label object associated with this appointment.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Label Label { get; set; }
Visual Basic
Public Property Label As Label
    Get
    Set

Remarks

Labels may be associated with an appointment to effectively group appointments.

Remarks

This property only accepts Label objects which are present in the C1ScheduleStorage.LabelStorage storage.

See Also

Appointment Class
C1.C1Schedule Namespace


Links Property

[image]

.NET Framework Class Library
Appointment..::..Links Property
Appointment Class See Also
Gets the ContactList object which holds the set of Contact objects for this appointment. An appointment may be associated with multiple contacts.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ContactList Links { get; internal set; }
Visual Basic
Public Property Links As ContactList
    Get
    Friend Set

Remarks

This property only accepts Contact objects which are present in the C1ScheduleStorage.ContactStorage storage.

See Also

Appointment Class
C1.C1Schedule Namespace


Location Property

[image]

.NET Framework Class Library
Appointment..::..Location Property
Appointment Class See Also
Gets or sets the String value specifying where the appointment is going to be.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute("")]
public string Location { get; set; }
Visual Basic
<DefaultValueAttribute("")> _
Public Property Location As String
    Get
    Set

See Also

Appointment Class
C1.C1Schedule Namespace


Owner Property

[image]

.NET Framework Class Library
Appointment..::..Owner Property
Appointment Class See Also
Gets or sets the Contact object which owns current Appointment object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Contact Owner { get; set; }
Visual Basic
Public Property Owner As Contact
    Get
    Set

Field Value

The default value is null.

Remarks

This property only accepts Contact objects which are present in the C1ScheduleStorage.OwnerStorage storage.

See Also

Appointment Class
C1.C1Schedule Namespace


ParentCollection Property

[image]

.NET Framework Class Library
Appointment..::..ParentCollection Property
Appointment Class See Also
Gets the reference to the parent AppointmentCollection object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public AppointmentCollection ParentCollection { get; internal set; }
Visual Basic
Public Property ParentCollection As AppointmentCollection
    Get
    Friend Set

See Also

Appointment Class
C1.C1Schedule Namespace


ParentRecurrence Property

[image]

.NET Framework Class Library
Appointment..::..ParentRecurrence Property
Appointment Class See Also
Gets the Appointment object that defines the recurrence criteria for this Appointment object. If this appointment is a not member of a recurrence, or is itself a root appointment, null is returned.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Appointment ParentRecurrence { get; internal set; }
Visual Basic
Public Property ParentRecurrence As Appointment
    Get
    Friend Set

Remarks

If an appointment is recurring (see the IsRecurring property) it represents an occurrence in the series that is started and defined by a specific pattern appointment. Use the ParentRecurrence property to obtain the pattern of the current appointment. A pattern appointment can be recognized by its RecurrenceState property set to the Master value. The recurrence information defined by the pattern appointment can be accessed via the RecurrencePattern property of the appointment.

See Also

Appointment Class
C1.C1Schedule Namespace


Private Property

[image]

.NET Framework Class Library
Appointment..::..Private Property
Appointment Class See Also
Gets or sets the Boolean value determining whether the calendar owner intends to keep the Appointment object private.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(false)]
public bool Private { get; set; }
Visual Basic
<DefaultValueAttribute(False)> _
Public Property Private As Boolean
    Get
    Set

See Also

Appointment Class
C1.C1Schedule Namespace


RecurrenceState Property

[image]

.NET Framework Class Library
Appointment..::..RecurrenceState Property
Appointment Class See Also
Gets the RecurrenceStateEnum value indicating the recurrence state of the appointment.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public RecurrenceStateEnum RecurrenceState { get; internal set; }
Visual Basic
Public Property RecurrenceState As RecurrenceStateEnum
    Get
    Friend Set

See Also

Appointment Class
C1.C1Schedule Namespace


Reminder Property

[image]

.NET Framework Class Library
Appointment..::..Reminder Property
Appointment Class See Also
Gets the Reminder object which is associated with the appointment. To associate an appointment with the reminder, set its ReminderSet property to true. Once this property is set to true, a new Reminder object is created and assigned to the Reminder property.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Reminder Reminder { get; }
Visual Basic
Public ReadOnly Property Reminder As Reminder
    Get

See Also

Appointment Class
C1.C1Schedule Namespace


ReminderOverrideDefault Property

[image]

.NET Framework Class Library
Appointment..::..ReminderOverrideDefault Property
Appointment Class See Also
Gets or sets the Boolean value indicating if the associated Reminder object has non-default settings. True if the reminder overrides the default reminder behavior for the appointment. You must set the ReminderOverrideDefault property to validate the ReminderPlaySound and the ReminderSoundFile properties.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(false)]
public bool ReminderOverrideDefault { get; set; }
Visual Basic
<DefaultValueAttribute(False)> _
Public Property ReminderOverrideDefault As Boolean
    Get
    Set

See Also

Appointment Class
C1.C1Schedule Namespace


ReminderPlaySound Property

[image]

.NET Framework Class Library
Appointment..::..ReminderPlaySound Property
Appointment Class See Also
Gets or sets the Boolean value indicating if the reminder should play a sound when it occurs for this appointment or task. The ReminderPlaySound property must be set in order to validate the ReminderSoundFile property. This property is only valid if the ReminderOverrideDefault property is set to true.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(true)]
public bool ReminderPlaySound { get; set; }
Visual Basic
<DefaultValueAttribute(True)> _
Public Property ReminderPlaySound As Boolean
    Get
    Set

See Also

Appointment Class
C1.C1Schedule Namespace


ReminderSet Property

[image]

.NET Framework Class Library
Appointment..::..ReminderSet Property
Appointment Class See Also
Gets or sets the Boolean value indicating whether a reminder is associated with the appointment. Once this property is set to true, a new Reminder object is created and assigned to the Reminder property.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(false)]
public bool ReminderSet { get; set; }
Visual Basic
<DefaultValueAttribute(False)> _
Public Property ReminderSet As Boolean
    Get
    Set

See Also

Appointment Class
C1.C1Schedule Namespace


ReminderSoundFile Property

[image]

.NET Framework Class Library
Appointment..::..ReminderSoundFile Property
Appointment Class See Also
Gets or sets the String value indicating the path and file name of the sound file to play when the reminder occurs for the appointment. This property is only valid if the ReminderOverrideDefault and ReminderPlaySound properties are set to true.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute("")]
public string ReminderSoundFile { get; set; }
Visual Basic
<DefaultValueAttribute("")> _
Public Property ReminderSoundFile As String
    Get
    Set

Remarks

The default sound is the system Exclamation sound.

See Also

Appointment Class
C1.C1Schedule Namespace


ReminderTimeBeforeStart Property

[image]

.NET Framework Class Library
Appointment..::..ReminderTimeBeforeStart Property
Appointment Class See Also
Gets or sets the TimeSpan value indicating the interval of time the reminder should occur prior to the start of the appointment.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(typeof(TimeSpan), "0:15:00")]
public TimeSpan ReminderTimeBeforeStart { get; set; }
Visual Basic
<DefaultValueAttribute(GetType(TimeSpan), "0:15:00")> _
Public Property ReminderTimeBeforeStart As TimeSpan
    Get
    Set

See Also

Appointment Class
C1.C1Schedule Namespace


Resources Property

[image]

.NET Framework Class Library
Appointment..::..Resources Property
Appointment Class See Also
Gets the ResourceList object which holds the set of Resource objects for this appointment. An appointment may be associated with multiple resources.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ResourceList Resources { get; internal set; }
Visual Basic
Public Property Resources As ResourceList
    Get
    Friend Set

Remarks

This property only accepts Resource objects which are present in the C1ScheduleStorage.ResourceStorage storage.

See Also

Appointment Class
C1.C1Schedule Namespace


Saved Property

[image]

.NET Framework Class Library
Appointment..::..Saved Property
Appointment Class See Also
Gets the Boolean value indicating if the appointment has not been modified since the last save.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool Saved { get; }
Visual Basic
Public ReadOnly Property Saved As Boolean
    Get

See Also

Appointment Class
C1.C1Schedule Namespace


Sensitivity Property

[image]

.NET Framework Class Library
Appointment..::..Sensitivity Property
Appointment Class See Also
Gets or sets the SensitivityEnum value indicating the sensitivity level of the appointment.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(SensitivityEnum.Normal)]
public SensitivityEnum Sensitivity { get; set; }
Visual Basic
<DefaultValueAttribute(SensitivityEnum.Normal)> _
Public Property Sensitivity As SensitivityEnum
    Get
    Set

See Also

Appointment Class
C1.C1Schedule Namespace


Start Property

[image]

.NET Framework Class Library
Appointment..::..Start Property
Appointment Class See Also
Gets or sets the DateTime value determining the start date and time of the appointment.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTime Start { get; set; }
Visual Basic
Public Property Start As DateTime
    Get
    Set

Remarks

If the AllDayEvent property is set to true, then the start date of the appointment is the Date of the Start, and the start time of the appointment is 0:00.

At setting this property, if it's time is not equal 0:00, the AllDayEvent property will be set to false.

See Also

Appointment Class
C1.C1Schedule Namespace


Subject Property

[image]

.NET Framework Class Library
Appointment..::..Subject Property
Appointment Class See Also
Gets or sets the String value representing the subject of the Appointment object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute("")]
public string Subject { get; set; }
Visual Basic
<DefaultValueAttribute("")> _
Public Property Subject As String
    Get
    Set

See Also

Appointment Class
C1.C1Schedule Namespace


Tag Property

[image]

.NET Framework Class Library
Appointment..::..Tag Property
Appointment Class See Also
Gets or sets custom information associated with this object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(null)]
public Object Tag { get; set; }
Visual Basic
<DefaultValueAttribute(Nothing)> _
Public Property Tag As Object
    Get
    Set

Remarks

This property is valid only for the lifetime of the object.

See Also

Appointment Class
C1.C1Schedule Namespace


Appointment Events

[image] [image]

.NET Framework Class Library
Appointment Events
Appointment Class See Also

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged | (Inherited from BasePersistableObject.)

See Also

Appointment Class
C1.C1Schedule Namespace


AppointmentCollection Class

[image]

.NET Framework Class Library
AppointmentCollection Class
Members See Also
The AppointmentCollection is a collection of all Appointment objects in the C1Schedule component.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class AppointmentCollection : BaseCollection<Appointment>
Visual Basic
Public Class AppointmentCollection _
    Inherits BaseCollection(Of Appointment)

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' Appointment >)>)>
System.Collections.ObjectModel..::..KeyedCollection <(Of <(<' Guid, Appointment >)>)>
C1.C1Schedule..::..C1ObservableKeyedCollection <(Of <(<' Guid, Appointment >)>)>
C1.C1Schedule..::..BaseCollection <(Of <(<' Appointment >)>)>
C1.C1Schedule..::..AppointmentCollection

See Also

AppointmentCollection Members
C1.C1Schedule Namespace


AppointmentCollection Members

[image] [image]

.NET Framework Class Library
AppointmentCollection Members
AppointmentCollection Class Methods Properties Explicit Interface Implementations See Also

The AppointmentCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add()()()() | Creates the new Appointment object with default settings and adds it to the collection.
Public method | Add(T) | Adds a new custom object to the collection. If the item already exists in the collection, its index is returned. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | Add(DateTime, DateTime) | Creates the new Appointment object with specified parameters and adds it to the collection.
Public method | Add(DateTime, TimeSpan) | Creates the new Appointment object with specified parameters and adds it to the collection.
Public method | Add(DateTime, DateTime, String) | Creates the new Appointment object with specified parameters and adds it to the collection.
Public method | Add(DateTime, TimeSpan, String) | Creates the new Appointment object with specified parameters and adds it to the collection.
Public method | AddRange(array<T>[]()[][]) | Adds an array of objects to the collection. This methods clears the collection before adding new items. Don't use it if you want to keep preexisting items. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | AddRange(array<Appointment>[]()[][]) | Adds an array of Appointment objects to the collection. This methods clears collection before adding new items. Don't use it if you want to save previously existed items. (Overrides BaseCollection<(Of <(<'T>)>)>..::..AddRange(array<T>[]()[][]).)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection <(Of <(<' Guid, Appointment >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Protected method | ClearItems | Clears the collection. (Overrides C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>..::..ClearItems()()()().)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' Guid, Appointment >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(Int32) | Check if collection contains an item with specified index. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)> Collection<(Of <(<'T>)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConflicts | Retrieves the AppointmentList object which contains the list of occurrences of Appointment objects which are in conflict with the specified appointment.
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKeyForItem | Extracts the key from the specified element. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | GetOccurrences(DateTime, DateTime) | Retrieves the AppointmentList object which contains the full list of Appointment objects in the specified time interval.
Public method | GetOccurrences(Appointment, DateTime, DateTime) | Retrieves the AppointmentList object which contains the list of occurrences of the specified master appointment in the specified time interval.
Public method | GetOccurrences(BaseObject, String, DateTime, DateTime, Boolean) | Retrieves the AppointmentList object which contains the full list of Appointment objects in the specified time interval.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Protected method | InsertItem | Overrides the default behavior. (Overrides BaseCollection<(Of <(<'T>)>)>..::..InsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, Appointment >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)> Collection<(Of <(<'T>)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Protected method | RemoveItem | Overrides the default behavior. (Overrides BaseCollection<(Of <(<'T>)>)>..::..RemoveItem(Int32).)
Protected method | SetItem | Overrides the default behavior. (Overrides C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>..::..SetItem(Int32, TItem).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection <(Of <(<' Guid, Appointment >)>)>.)
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, Appointment >)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Appointment >)>)> Collection<(Of <(<'T>)>)>.)
Public property | Item[([( Guid])]) | Gets the element with the specified key if any. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Protected property | OwnerInternal | (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public property | ParentStorage | Gets the reference to the owning AppointmentStorage object.

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' Appointment >)>)>.)

See Also

AppointmentCollection Class
C1.C1Schedule Namespace


AppointmentCollection Methods

[image] [image]

.NET Framework Class Library
AppointmentCollection Methods
AppointmentCollection Class See Also

The AppointmentCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add()()()() | Creates the new Appointment object with default settings and adds it to the collection.
Public method | Add(T) | Adds a new custom object to the collection. If the item already exists in the collection, its index is returned. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | Add(DateTime, DateTime) | Creates the new Appointment object with specified parameters and adds it to the collection.
Public method | Add(DateTime, TimeSpan) | Creates the new Appointment object with specified parameters and adds it to the collection.
Public method | Add(DateTime, DateTime, String) | Creates the new Appointment object with specified parameters and adds it to the collection.
Public method | Add(DateTime, TimeSpan, String) | Creates the new Appointment object with specified parameters and adds it to the collection.
Public method | AddRange(array<T>[]()[][]) | Adds an array of objects to the collection. This methods clears the collection before adding new items. Don't use it if you want to keep preexisting items. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | AddRange(array<Appointment>[]()[][]) | Adds an array of Appointment objects to the collection. This methods clears collection before adding new items. Don't use it if you want to save previously existed items. (Overrides BaseCollection<(Of <(<'T>)>)>..::..AddRange(array<T>[]()[][]).)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection <(Of <(<' Guid, Appointment >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Protected method | ClearItems | Clears the collection. (Overrides C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>..::..ClearItems()()()().)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' Guid, Appointment >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(Int32) | Check if collection contains an item with specified index. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)> Collection<(Of <(<'T>)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConflicts | Retrieves the AppointmentList object which contains the list of occurrences of Appointment objects which are in conflict with the specified appointment.
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKeyForItem | Extracts the key from the specified element. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | GetOccurrences(DateTime, DateTime) | Retrieves the AppointmentList object which contains the full list of Appointment objects in the specified time interval.
Public method | GetOccurrences(Appointment, DateTime, DateTime) | Retrieves the AppointmentList object which contains the list of occurrences of the specified master appointment in the specified time interval.
Public method | GetOccurrences(BaseObject, String, DateTime, DateTime, Boolean) | Retrieves the AppointmentList object which contains the full list of Appointment objects in the specified time interval.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Protected method | InsertItem | Overrides the default behavior. (Overrides BaseCollection<(Of <(<'T>)>)>..::..InsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, Appointment >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)> Collection<(Of <(<'T>)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Protected method | RemoveItem | Overrides the default behavior. (Overrides BaseCollection<(Of <(<'T>)>)>..::..RemoveItem(Int32).)
Protected method | SetItem | Overrides the default behavior. (Overrides C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>..::..SetItem(Int32, TItem).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' Appointment >)>)>.)

See Also

AppointmentCollection Class
C1.C1Schedule Namespace


Add Method

[image] [image]

.NET Framework Class Library
AppointmentCollection..::..Add Method
AppointmentCollection Class See Also

Overload List

 | Name | Description
Public method | Add()()()() | Creates the new Appointment object with default settings and adds it to the collection.
Public method | Add(T) | Adds a new custom object to the collection. If the item already exists in the collection, its index is returned. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | Add(DateTime, DateTime) | Creates the new Appointment object with specified parameters and adds it to the collection.
Public method | Add(DateTime, TimeSpan) | Creates the new Appointment object with specified parameters and adds it to the collection.
Public method | Add(DateTime, DateTime, String) | Creates the new Appointment object with specified parameters and adds it to the collection.
Public method | Add(DateTime, TimeSpan, String) | Creates the new Appointment object with specified parameters and adds it to the collection.

See Also

AppointmentCollection Class
AppointmentCollection Members
C1.C1Schedule Namespace


Add Method

[image]

.NET Framework Class Library
AppointmentCollection..::..Add Method
AppointmentCollection Class See Also
Creates the new Appointment object with default settings and adds it to the collection.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Appointment Add()
Visual Basic
Public Function Add As Appointment

Return Value

The Appointment object.

See Also

AppointmentCollection Class
Add Overload
C1.C1Schedule Namespace


Add Method (DateTime, DateTime)

[image]

.NET Framework Class Library
AppointmentCollection..::..Add Method (DateTime, DateTime)
AppointmentCollection Class See Also
Creates the new Appointment object with specified parameters and adds it to the collection.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Appointment Add(
    DateTime start,
    DateTime end
)
Visual Basic
Public Function Add ( _
    start As DateTime, _
    end As DateTime _
) As Appointment

Parameters

start
Type: System..::..DateTime
The DateTime value which specifies the start date and time of the appointment.
end
Type: System..::..DateTime
The DateTime value which specifies the end date and time of the appointment.

Return Value

The Appointment object.

See Also

AppointmentCollection Class
Add Overload
C1.C1Schedule Namespace


Add Method (DateTime, TimeSpan)

[image]

.NET Framework Class Library
AppointmentCollection..::..Add Method (DateTime, TimeSpan)
AppointmentCollection Class See Also
Creates the new Appointment object with specified parameters and adds it to the collection.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Appointment Add(
    DateTime start,
    TimeSpan duration
)
Visual Basic
Public Function Add ( _
    start As DateTime, _
    duration As TimeSpan _
) As Appointment

Parameters

start
Type: System..::..DateTime
The DateTime value which specifies the start date and time of the appointment.
duration
Type: System..::..TimeSpan
The TimeSpan value which specifies the duration of the appointment.

Return Value

The Appointment object.

See Also

AppointmentCollection Class
Add Overload
C1.C1Schedule Namespace


Add Method (DateTime, DateTime, String)

[image]

.NET Framework Class Library
AppointmentCollection..::..Add Method (DateTime, DateTime, String)
AppointmentCollection Class See Also
Creates the new Appointment object with specified parameters and adds it to the collection.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Appointment Add(
    DateTime start,
    DateTime end,
    string subject
)
Visual Basic
Public Function Add ( _
    start As DateTime, _
    end As DateTime, _
    subject As String _
) As Appointment

Parameters

start
Type: System..::..DateTime
The DateTime value which specifies the start date and time of the appointment.
end
Type: System..::..DateTime
The DateTime value which specifies the end date and time of the appointment.
subject
Type: System..::..String
The String value which contains the subject of the appointment.

Return Value

The Appointment object.

See Also

AppointmentCollection Class
Add Overload
C1.C1Schedule Namespace


Add Method (DateTime, TimeSpan, String)

[image]

.NET Framework Class Library
AppointmentCollection..::..Add Method (DateTime, TimeSpan, String)
AppointmentCollection Class See Also
Creates the new Appointment object with specified parameters and adds it to the collection.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Appointment Add(
    DateTime start,
    TimeSpan duration,
    string subject
)
Visual Basic
Public Function Add ( _
    start As DateTime, _
    duration As TimeSpan, _
    subject As String _
) As Appointment

Parameters

start
Type: System..::..DateTime
The DateTime value which specifies the start date and time of the appointment.
duration
Type: System..::..TimeSpan
The TimeSpan value which specifies the duration of the appointment.
subject
Type: System..::..String
The String value which contains the subject of the appointment.

Return Value

The Appointment object.

See Also

AppointmentCollection Class
Add Overload
C1.C1Schedule Namespace


AddRange Method

[image] [image]

.NET Framework Class Library
AppointmentCollection..::..AddRange Method
AppointmentCollection Class See Also

Overload List

 | Name | Description
Public method | AddRange(array<T>[]()[][]) | Adds an array of objects to the collection. This methods clears the collection before adding new items. Don't use it if you want to keep preexisting items. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | AddRange(array<Appointment>[]()[][]) | Adds an array of Appointment objects to the collection. This methods clears collection before adding new items. Don't use it if you want to save previously existed items. (Overrides BaseCollection<(Of <(<'T>)>)>..::..AddRange(array<T>[]()[][]).)

See Also

AppointmentCollection Class
AppointmentCollection Members
C1.C1Schedule Namespace


AddRange Method (Appointment[])

[image]

.NET Framework Class Library
AppointmentCollection..::..AddRange Method (array<Appointment>[]()[][])
AppointmentCollection Class See Also
Adds an array of Appointment objects to the collection. This methods clears collection before adding new items. Don't use it if you want to save previously existed items.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override void AddRange(
    Appointment[] items
)
Visual Basic
Public Overrides Sub AddRange ( _
    items As Appointment() _
)

Parameters

items
Type: array< C1.C1Schedule..::..Appointment >[]()[][]
An array of Appointment objects.

See Also

AppointmentCollection Class
AddRange Overload
C1.C1Schedule Namespace


ClearItems Method

[image]

.NET Framework Class Library
AppointmentCollection..::..ClearItems Method
AppointmentCollection Class See Also
Clears the collection.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void ClearItems()
Visual Basic
Protected Overrides Sub ClearItems

See Also

AppointmentCollection Class
C1.C1Schedule Namespace


Contains Method

[image] [image]

.NET Framework Class Library
AppointmentCollection..::..Contains Method
AppointmentCollection Class See Also

Overload List

 | Name | Description
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' Guid, Appointment >)>)>.)
Public method | Contains(Int32) | Check if collection contains an item with specified index. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)

See Also

AppointmentCollection Class
AppointmentCollection Members
C1.C1Schedule Namespace


GetConflicts Method

[image]

.NET Framework Class Library
AppointmentCollection..::..GetConflicts Method
AppointmentCollection Class See Also
Retrieves the AppointmentList object which contains the list of occurrences of Appointment objects which are in conflict with the specified appointment.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public AppointmentList GetConflicts(
    Appointment appointment
)
Visual Basic
Public Function GetConflicts ( _
    appointment As Appointment _
) As AppointmentList

Parameters

appointment
Type: C1.C1Schedule..::..Appointment
The Appointment object.

Return Value

The AppointmentList object.

See Also

AppointmentCollection Class
C1.C1Schedule Namespace


GetOccurrences Method

[image] [image]

.NET Framework Class Library
AppointmentCollection..::..GetOccurrences Method
AppointmentCollection Class See Also

Overload List

 | Name | Description
Public method | GetOccurrences(DateTime, DateTime) | Retrieves the AppointmentList object which contains the full list of Appointment objects in the specified time interval.
Public method | GetOccurrences(Appointment, DateTime, DateTime) | Retrieves the AppointmentList object which contains the list of occurrences of the specified master appointment in the specified time interval.
Public method | GetOccurrences(BaseObject, String, DateTime, DateTime, Boolean) | Retrieves the AppointmentList object which contains the full list of Appointment objects in the specified time interval.

See Also

AppointmentCollection Class
AppointmentCollection Members
C1.C1Schedule Namespace


GetOccurrences Method (DateTime, DateTime)

[image]

.NET Framework Class Library
AppointmentCollection..::..GetOccurrences Method (DateTime, DateTime)
AppointmentCollection Class See Also
Retrieves the AppointmentList object which contains the full list of Appointment objects in the specified time interval.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public AppointmentList GetOccurrences(
    DateTime start,
    DateTime end
)
Visual Basic
Public Function GetOccurrences ( _
    start As DateTime, _
    end As DateTime _
) As AppointmentList

Parameters

start
Type: System..::..DateTime
The DateTime value which specifies the start date and time of the interval.
end
Type: System..::..DateTime
The DateTime value which specifies the end date and time of the interval.

Return Value

The AppointmentList object.

Remarks

This method will create instances of the Appointment object for recurring appointments if they haven't been created yet.

See Also

AppointmentCollection Class
GetOccurrences Overload
C1.C1Schedule Namespace


GetOccurrences Method (Appointment, DateTime, DateTime)

[image]

.NET Framework Class Library
AppointmentCollection..::..GetOccurrences Method (Appointment, DateTime, DateTime)
AppointmentCollection Class See Also
Retrieves the AppointmentList object which contains the list of occurrences of the specified master appointment in the specified time interval.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public AppointmentList GetOccurrences(
    Appointment appointment,
    DateTime start,
    DateTime end
)
Visual Basic
Public Function GetOccurrences ( _
    appointment As Appointment, _
    start As DateTime, _
    end As DateTime _
) As AppointmentList

Parameters

appointment
Type: C1.C1Schedule..::..Appointment
The Appointment object representing the master appointment.
start
Type: System..::..DateTime
The DateTime value which specifies the start date and time of the interval.
end
Type: System..::..DateTime
The DateTime value which specifies the end date and time of the interval.

Return Value

The AppointmentList object.

Remarks

This method will create instances of the Appointment object for recurring appointments if they haven't been created yet.

See Also

AppointmentCollection Class
GetOccurrences Overload
C1.C1Schedule Namespace


GetOccurrences Method (BaseObject, String, DateTime, DateTime, Boolean)

[image]

.NET Framework Class Library
AppointmentCollection..::..GetOccurrences Method (BaseObject, String, DateTime, DateTime, Boolean)
AppointmentCollection Class See Also
Retrieves the AppointmentList object which contains the full list of Appointment objects in the specified time interval.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public AppointmentList GetOccurrences(
    BaseObject groupOwner,
    string groupBy,
    DateTime start,
    DateTime end,
    bool includePrivateAppointments
)
Visual Basic
Public Function GetOccurrences ( _
    groupOwner As BaseObject, _
    groupBy As String, _
    start As DateTime, _
    end As DateTime, _
    includePrivateAppointments As Boolean _
) As AppointmentList

Parameters

groupOwner
Type: C1.C1Schedule..::..BaseObject
The BaseObject object determining the appointment group.
groupBy
Type: System..::..String
The String value determining the type of grouping.
start
Type: System..::..DateTime
The DateTime value which specifies the start date and time of the interval.
end
Type: System..::..DateTime
The DateTime value which specifies the end date and time of the interval.
includePrivateAppointments
Type: System..::..Boolean
The Boolean value determining whether to include private appointments.

Return Value

The AppointmentList object.

Remarks

This method will create instances of the Appointment object for recurring appointments if they haven't been created yet.

See Also

AppointmentCollection Class
GetOccurrences Overload
C1.C1Schedule Namespace


InsertItem Method

[image]

.NET Framework Class Library
AppointmentCollection..::..InsertItem Method
AppointmentCollection Class See Also
Overrides the default behavior.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void InsertItem(
    int index,
    Appointment item
)
Visual Basic
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As Appointment _
)

Parameters

index
Type: System..::..Int32
The zero-based index of the item.
item
Type: C1.C1Schedule..::..Appointment
The Appointment object to insert.

See Also

AppointmentCollection Class
C1.C1Schedule Namespace


Remove Method

[image] [image]

.NET Framework Class Library
AppointmentCollection..::..Remove Method
AppointmentCollection Class See Also

Overload List

 | Name | Description
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, Appointment >)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)

See Also

AppointmentCollection Class
AppointmentCollection Members
C1.C1Schedule Namespace


RemoveItem Method

[image]

.NET Framework Class Library
AppointmentCollection..::..RemoveItem Method
AppointmentCollection Class See Also
Overrides the default behavior.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void RemoveItem(
    int index
)
Visual Basic
Protected Overrides Sub RemoveItem ( _
    index As Integer _
)

Parameters

index
Type: System..::..Int32
The zero-based index of the item to remove.

See Also

AppointmentCollection Class
C1.C1Schedule Namespace


SetItem Method

[image]

.NET Framework Class Library
AppointmentCollection..::..SetItem Method
AppointmentCollection Class See Also
Overrides the default behavior.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void SetItem(
    int index,
    Appointment item
)
Visual Basic
Protected Overrides Sub SetItem ( _
    index As Integer, _
    item As Appointment _
)

Parameters

index
Type: System..::..Int32
The zero-based index of the item.
item
Type: C1.C1Schedule..::..Appointment
The Appointment object to set.

See Also

AppointmentCollection Class
C1.C1Schedule Namespace


AppointmentCollection Properties

[image] [image]

.NET Framework Class Library
AppointmentCollection Properties
AppointmentCollection Class See Also

The AppointmentCollection type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection <(Of <(<' Guid, Appointment >)>)>.)
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, Appointment >)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Appointment >)>)> Collection<(Of <(<'T>)>)>.)
Public property | Item[([( Guid])]) | Gets the element with the specified key if any. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Protected property | OwnerInternal | (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public property | ParentStorage | Gets the reference to the owning AppointmentStorage object.

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' Appointment >)>)>.)

See Also

AppointmentCollection Class
C1.C1Schedule Namespace


Item Property

[image] [image]

.NET Framework Class Library
AppointmentCollection..::..Item Property
AppointmentCollection Class See Also

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Public property | Item[([( Guid])]) | Gets the element with the specified key if any. (Inherited from BaseCollection<(Of <(<'T>)>)>.)

See Also

AppointmentCollection Class
AppointmentCollection Members
C1.C1Schedule Namespace


ParentStorage Property

[image]

.NET Framework Class Library
AppointmentCollection..::..ParentStorage Property
AppointmentCollection Class See Also
Gets the reference to the owning AppointmentStorage object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public AppointmentStorage ParentStorage { get; }
Visual Basic
Public ReadOnly Property ParentStorage As AppointmentStorage
    Get

See Also

AppointmentCollection Class
C1.C1Schedule Namespace


AppointmentCollection Events

[image] [image]

.NET Framework Class Library
AppointmentCollection Events
AppointmentCollection Class See Also

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)

See Also

AppointmentCollection Class
C1.C1Schedule Namespace


AppointmentComparer Class

[image]

.NET Framework Class Library
AppointmentComparer Class
Members See Also
Compares Appointment objects by their start time.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class AppointmentComparer : Comparer<Appointment>
Visual Basic
Public Class AppointmentComparer _
    Inherits Comparer(Of Appointment)

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..Comparer <(Of <(<' Appointment >)>)>
C1.C1Schedule..::..AppointmentComparer

See Also

AppointmentComparer Members
C1.C1Schedule Namespace


AppointmentComparer Members

[image] [image]

.NET Framework Class Library
AppointmentComparer Members
AppointmentComparer Class Constructors Methods Properties Explicit Interface Implementations See Also

The AppointmentComparer type exposes the following members.

Constructors

 | Name | Description
Public method | AppointmentComparer |

Methods

 | Name | Description
Public method | Compare | Performs a comparison of two Appointment objects and returns a value indicating whether the one Appointment starts earlier, at the same time, or later than the other. (Overrides Comparer<(Of <(<'T>)>)>..::..Compare(T, T).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Default | Returns an existing instance of AppointmentComparer class if any; or creates a new one.

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IComparer..::..Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from Comparer <(Of <(<' Appointment >)>)>.)

See Also

AppointmentComparer Class
C1.C1Schedule Namespace


AppointmentComparer Constructor

[image]

.NET Framework Class Library
AppointmentComparer Constructor
AppointmentComparer Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public AppointmentComparer()
Visual Basic
Public Sub New

See Also

AppointmentComparer Class
C1.C1Schedule Namespace


AppointmentComparer Methods

[image] [image]

.NET Framework Class Library
AppointmentComparer Methods
AppointmentComparer Class See Also

The AppointmentComparer type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Performs a comparison of two Appointment objects and returns a value indicating whether the one Appointment starts earlier, at the same time, or later than the other. (Overrides Comparer<(Of <(<'T>)>)>..::..Compare(T, T).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IComparer..::..Compare | Compares two objects and returns a value indicating whether one is less than, equal to, or greater than the other. (Inherited from Comparer <(Of <(<' Appointment >)>)>.)

See Also

AppointmentComparer Class
C1.C1Schedule Namespace


Compare Method

[image]

.NET Framework Class Library
AppointmentComparer..::..Compare Method
AppointmentComparer Class See Also
Performs a comparison of two Appointment objects and returns a value indicating whether the one Appointment starts earlier, at the same time, or later than the other.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override int Compare(
    Appointment x,
    Appointment y
)
Visual Basic
Public Overrides Function Compare ( _
    x As Appointment, _
    y As Appointment _
) As Integer

Parameters

x
Type: C1.C1Schedule..::..Appointment
The first Appointment to compare.
y
Type: C1.C1Schedule..::..Appointment
The second Appointment to compare.

Return Value

Less than zero - x occurs earlier than y. Zero - x and y occur at the same time. Greater than zero - x occurs later than y.

Implements

IComparer<(Of <(<'T>)>)>..::..Compare(T, T)

See Also

AppointmentComparer Class
C1.C1Schedule Namespace


AppointmentComparer Properties

[image] [image]

.NET Framework Class Library
AppointmentComparer Properties
AppointmentComparer Class See Also

The AppointmentComparer type exposes the following members.

Properties

Name | Description
Default | Returns an existing instance of AppointmentComparer class if any; or creates a new one.

See Also

AppointmentComparer Class
C1.C1Schedule Namespace


Default Property

[image]

.NET Framework Class Library
AppointmentComparer..::..Default Property
AppointmentComparer Class See Also
Returns an existing instance of AppointmentComparer class if any; or creates a new one.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static AppointmentComparer Default { get; }
Visual Basic
Public Shared ReadOnly Property Default As AppointmentComparer
    Get

See Also

AppointmentComparer Class
C1.C1Schedule Namespace


AppointmentEventArgs Class

[image]

.NET Framework Class Library
AppointmentEventArgs Class
Members See Also
The AppointmentEventArgs class describes event data for Appointment events.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class AppointmentEventArgs : EventArgs
Visual Basic
Public Class AppointmentEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
C1.C1Schedule..::..AppointmentEventArgs

See Also

AppointmentEventArgs Members
C1.C1Schedule Namespace


AppointmentEventArgs Members

[image] [image]

.NET Framework Class Library
AppointmentEventArgs Members
AppointmentEventArgs Class Constructors Methods Properties See Also

The AppointmentEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | AppointmentEventArgs | Initializes a new instance of the AppointmentEventArgs class with the specified appointment.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Appointment | Gets the appointment which the event was raised for.

See Also

AppointmentEventArgs Class
C1.C1Schedule Namespace


AppointmentEventArgs Constructor

[image]

.NET Framework Class Library
AppointmentEventArgs Constructor
AppointmentEventArgs Class See Also
Initializes a new instance of the AppointmentEventArgs class with the specified appointment.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public AppointmentEventArgs(
    Appointment appointment
)
Visual Basic
Public Sub New ( _
    appointment As Appointment _
)

Parameters

appointment
Type: C1.C1Schedule..::..Appointment
The Appointment object.

See Also

AppointmentEventArgs Class
C1.C1Schedule Namespace


AppointmentEventArgs Methods

[image] [image]

.NET Framework Class Library
AppointmentEventArgs Methods
AppointmentEventArgs Class See Also

The AppointmentEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AppointmentEventArgs Class
C1.C1Schedule Namespace


AppointmentEventArgs Properties

[image] [image]

.NET Framework Class Library
AppointmentEventArgs Properties
AppointmentEventArgs Class See Also

The AppointmentEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Appointment | Gets the appointment which the event was raised for.

See Also

AppointmentEventArgs Class
C1.C1Schedule Namespace


Appointment Property

[image]

.NET Framework Class Library
AppointmentEventArgs..::..Appointment Property
AppointmentEventArgs Class See Also
Gets the appointment which the event was raised for.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Appointment Appointment { get; }
Visual Basic
Public ReadOnly Property Appointment As Appointment
    Get

See Also

AppointmentEventArgs Class
C1.C1Schedule Namespace


AppointmentList Class

[image]

.NET Framework Class Library
AppointmentList Class
Members See Also
The AppointmentList is a sortable collection of Appointment objects.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class AppointmentList : Collection<Appointment>
Visual Basic
Public Class AppointmentList _
    Inherits Collection(Of Appointment)

Remarks

The AppointmentList is not guaranteed to be sorted. You must sort the AppointmentList before performing operations that require the AppointmentList to be sorted.

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' Appointment >)>)>
C1.C1Schedule..::..AppointmentList

See Also

AppointmentList Members
C1.C1Schedule Namespace


AppointmentList Members

[image] [image]

.NET Framework Class Library
AppointmentList Members
AppointmentList Class Methods Properties Explicit Interface Implementations See Also

The AppointmentList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Protected method | ClearItems | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Protected method | InsertItem | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire AppointmentList using the default comparer (by the Appointment.Start value).
Public method | Sort(IComparer<(Of <<'(Appointment>)>>)) | Sorts the elements in the entire AppointmentList using the specified comparer.
Public method | Sort(Comparison<(Of <<'(Appointment>)>>)) | Sorts the elements in the entire AppointmentList using the specified System.Comparison.
Public method | Sort(Int32, Int32, IComparer<(Of <<'(Appointment>)>>)) | Sorts the elements in a range of elements in AppointmentList using the specified comparer.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' Appointment >)>)>.)

See Also

AppointmentList Class
C1.C1Schedule Namespace


AppointmentList Methods

[image] [image]

.NET Framework Class Library
AppointmentList Methods
AppointmentList Class See Also

The AppointmentList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Protected method | ClearItems | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Protected method | InsertItem | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire AppointmentList using the default comparer (by the Appointment.Start value).
Public method | Sort(IComparer<(Of <<'(Appointment>)>>)) | Sorts the elements in the entire AppointmentList using the specified comparer.
Public method | Sort(Comparison<(Of <<'(Appointment>)>>)) | Sorts the elements in the entire AppointmentList using the specified System.Comparison.
Public method | Sort(Int32, Int32, IComparer<(Of <<'(Appointment>)>>)) | Sorts the elements in a range of elements in AppointmentList using the specified comparer.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' Appointment >)>)>.)

See Also

AppointmentList Class
C1.C1Schedule Namespace


Sort Method

[image] [image]

.NET Framework Class Library
AppointmentList..::..Sort Method
AppointmentList Class See Also

Overload List

 | Name | Description
Public method | Sort()()()() | Sorts the elements in the entire AppointmentList using the default comparer (by the Appointment.Start value).
Public method | Sort(IComparer<(Of <<'(Appointment>)>>)) | Sorts the elements in the entire AppointmentList using the specified comparer.
Public method | Sort(Comparison<(Of <<'(Appointment>)>>)) | Sorts the elements in the entire AppointmentList using the specified System.Comparison.
Public method | Sort(Int32, Int32, IComparer<(Of <<'(Appointment>)>>)) | Sorts the elements in a range of elements in AppointmentList using the specified comparer.

See Also

AppointmentList Class
AppointmentList Members
C1.C1Schedule Namespace


Sort Method

[image]

.NET Framework Class Library
AppointmentList..::..Sort Method
AppointmentList Class See Also
Sorts the elements in the entire AppointmentList using the default comparer (by the Appointment.Start value).

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void Sort()
Visual Basic
Public Sub Sort

See Also

AppointmentList Class
Sort Overload
C1.C1Schedule Namespace


Sort Method (IComparer(Appointment))

[image]

.NET Framework Class Library
AppointmentList..::..Sort Method (IComparer<(Of <(<'Appointment>)>)>)
AppointmentList Class See Also
Sorts the elements in the entire AppointmentList using the specified comparer.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void Sort(
    IComparer<Appointment> comparer
)
Visual Basic
Public Sub Sort ( _
    comparer As IComparer(Of Appointment) _
)

Parameters

comparer
Type: System.Collections.Generic..::..IComparer <(Of <(<' Appointment >)>)>
The IComparer{Appointment} implementation to use when comparing elements, or a null reference (Nothing in Visual Basic) to use the default comparer.

See Also

AppointmentList Class
Sort Overload
C1.C1Schedule Namespace


Sort Method (Comparison(Appointment))

[image]

.NET Framework Class Library
AppointmentList..::..Sort Method (Comparison<(Of <(<'Appointment>)>)>)
AppointmentList Class See Also
Sorts the elements in the entire AppointmentList using the specified System.Comparison.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void Sort(
    Comparison<Appointment> comparison
)
Visual Basic
Public Sub Sort ( _
    comparison As Comparison(Of Appointment) _
)

Parameters

comparison
Type: System..::..Comparison <(Of <(<' Appointment >)>)>
The Comparison<(Of <(<'T>)>)> to use when comparing elements.

See Also

AppointmentList Class
Sort Overload
C1.C1Schedule Namespace


Sort Method (Int32, Int32, IComparer(Appointment))

[image]

.NET Framework Class Library
AppointmentList..::..Sort Method (Int32, Int32, IComparer<(Of <(<'Appointment>)>)>)
AppointmentList Class See Also
Sorts the elements in a range of elements in AppointmentList using the specified comparer.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void Sort(
    int index,
    int count,
    IComparer<Appointment> comparer
)
Visual Basic
Public Sub Sort ( _
    index As Integer, _
    count As Integer, _
    comparer As IComparer(Of Appointment) _
)

Parameters

index
Type: System..::..Int32
The zero-based starting index of the range to sort.
count
Type: System..::..Int32
The length of the range to sort.
comparer
Type: System.Collections.Generic..::..IComparer <(Of <(<' Appointment >)>)>
The IComparer{Appointment} implementation to use when comparing elements, or a null reference (Nothing in Visual Basic) to use the default comparer.

See Also

AppointmentList Class
Sort Overload
C1.C1Schedule Namespace


AppointmentList Properties

[image] [image]

.NET Framework Class Library
AppointmentList Properties
AppointmentList Class See Also

The AppointmentList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Appointment >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Appointment >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' Appointment >)>)>.)

See Also

AppointmentList Class
C1.C1Schedule Namespace


AppointmentMappingCollection Class

[image]

.NET Framework Class Library
AppointmentMappingCollection Class
Members See Also
Represents a generic collection of mappings for properties of BaseObject derived objects to appropriate data fields.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class AppointmentMappingCollection : MappingCollectionBase<Appointment>
Visual Basic
Public Class AppointmentMappingCollection _
    Inherits MappingCollectionBase(Of Appointment)

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' MappingInfo >)>)>
System.Collections.ObjectModel..::..KeyedCollection <(Of <(<' String, MappingInfo >)>)>
C1.C1Schedule..::..MappingCollectionBase <(Of <(<' Appointment >)>)>
C1.C1Schedule..::..AppointmentMappingCollection

See Also

AppointmentMappingCollection Members
C1.C1Schedule Namespace


AppointmentMappingCollection Members

[image] [image]

.NET Framework Class Library
AppointmentMappingCollection Members
AppointmentMappingCollection Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The AppointmentMappingCollection type exposes the following members.

Constructors

 | Name | Description
Public method | AppointmentMappingCollection | Initializes a new instance of the AppointmentMappingCollection class.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Protected method | ClearItems | Removes all elements from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)> Collection<(Of <(<'T>)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKeyForItem | Returns property name as the key for collection. (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Protected method | InsertItem | (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)> Collection<(Of <(<'T>)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Protected method | SetItem | Replaces the item at the specified index with the specified item. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AppointmentProperties | Returns MappingInfo object for the memory field which is intended to store the other properties of the Appointment object. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the other properties of the Appointment object to be bound to the appropriate field in the data source.
Public property | Body | Returns MappingInfo object for the Body property of the Appointment object. If the storage object is bound to a data source via its DataSource property, the properties of the Body allow the Body property to be bound to the appropriate field in the data source.
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)
Public property | Count | Gets the number of elements actually contained in the MappingCollectionBase<(Of <(<'T>)>)> object. (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public property | End | Returns MappingInfo object for the End property of the Appointment object. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the End property to be bound to the appropriate field in the data source.
Public property | IdMapping | Returns MappingInfo object for the Id()()()() property. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Id()()()() property to be bound to the appropriate field in the data source. (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)
Public property | IndexMapping | Returns MappingInfo object for the Index()()()() property. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Index()()()() property to be bound to the appropriate field in the data source. (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)
Public property | Item[([( TKey])]) | Gets the element with the specified key. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' MappingInfo >)>)> Collection<(Of <(<'T>)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Public property | Location | Returns MappingInfo object for the Location property of the Appointment object. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Location property to be bound to the appropriate field in the data source.
Public property | OwnerIdMapping | Returns MappingInfo object for the Appointment.Owner.Id property of the Appointment object. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Owner property to be bound to the appropriate field in the data source.
Public property | OwnerIndexMapping | Returns MappingInfo object for the Appointment.Owner.Index property of the Appointment object. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Owner property to be bound to the appropriate field in the data source.
Public property | Start | Returns MappingInfo object for the Start property of the Appointment object. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Start property to be bound to the appropriate field in the data source.
Public property | Subject | Returns MappingInfo object for the Subject property of the Appointment object. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Subject property to be bound to the appropriate field in the data source.

Events

 | Name | Description
Public event | Disposed | Represents the method that handles the Disposed event of a component. (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)

See Also

AppointmentMappingCollection Class
C1.C1Schedule Namespace


AppointmentMappingCollection Constructor

[image]

.NET Framework Class Library
AppointmentMappingCollection Constructor
AppointmentMappingCollection Class See Also
Initializes a new instance of the AppointmentMappingCollection class.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public AppointmentMappingCollection()
Visual Basic
Public Sub New

See Also

AppointmentMappingCollection Class
C1.C1Schedule Namespace


AppointmentMappingCollection Methods

[image] [image]

.NET Framework Class Library
AppointmentMappingCollection Methods
AppointmentMappingCollection Class See Also

The AppointmentMappingCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Protected method | ClearItems | Removes all elements from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)> Collection<(Of <(<'T>)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKeyForItem | Returns property name as the key for collection. (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Protected method | InsertItem | (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)> Collection<(Of <(<'T>)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Protected method | SetItem | Replaces the item at the specified index with the specified item. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)

See Also

AppointmentMappingCollection Class
C1.C1Schedule Namespace


Contains Method

[image] [image]

.NET Framework Class Library
AppointmentMappingCollection..::..Contains Method
AppointmentMappingCollection Class See Also

Overload List

 | Name | Description
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)

See Also

AppointmentMappingCollection Class
AppointmentMappingCollection Members
C1.C1Schedule Namespace


Remove Method

[image] [image]

.NET Framework Class Library
AppointmentMappingCollection..::..Remove Method
AppointmentMappingCollection Class See Also

Overload List

 | Name | Description
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)

See Also

AppointmentMappingCollection Class
AppointmentMappingCollection Members
C1.C1Schedule Namespace


AppointmentMappingCollection Properties

[image] [image]

.NET Framework Class Library
AppointmentMappingCollection Properties
AppointmentMappingCollection Class See Also

The AppointmentMappingCollection type exposes the following members.

Properties

 | Name | Description
Public property | AppointmentProperties | Returns MappingInfo object for the memory field which is intended to store the other properties of the Appointment object. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the other properties of the Appointment object to be bound to the appropriate field in the data source.
Public property | Body | Returns MappingInfo object for the Body property of the Appointment object. If the storage object is bound to a data source via its DataSource property, the properties of the Body allow the Body property to be bound to the appropriate field in the data source.
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)
Public property | Count | Gets the number of elements actually contained in the MappingCollectionBase<(Of <(<'T>)>)> object. (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public property | End | Returns MappingInfo object for the End property of the Appointment object. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the End property to be bound to the appropriate field in the data source.
Public property | IdMapping | Returns MappingInfo object for the Id()()()() property. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Id()()()() property to be bound to the appropriate field in the data source. (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)
Public property | IndexMapping | Returns MappingInfo object for the Index()()()() property. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Index()()()() property to be bound to the appropriate field in the data source. (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)
Public property | Item[([( TKey])]) | Gets the element with the specified key. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' MappingInfo >)>)> Collection<(Of <(<'T>)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Public property | Location | Returns MappingInfo object for the Location property of the Appointment object. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Location property to be bound to the appropriate field in the data source.
Public property | OwnerIdMapping | Returns MappingInfo object for the Appointment.Owner.Id property of the Appointment object. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Owner property to be bound to the appropriate field in the data source.
Public property | OwnerIndexMapping | Returns MappingInfo object for the Appointment.Owner.Index property of the Appointment object. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Owner property to be bound to the appropriate field in the data source.
Public property | Start | Returns MappingInfo object for the Start property of the Appointment object. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Start property to be bound to the appropriate field in the data source.
Public property | Subject | Returns MappingInfo object for the Subject property of the Appointment object. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Subject property to be bound to the appropriate field in the data source.

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)

See Also

AppointmentMappingCollection Class
C1.C1Schedule Namespace


AppointmentProperties Property

[image]

.NET Framework Class Library
AppointmentMappingCollection..::..AppointmentProperties Property
AppointmentMappingCollection Class See Also
Returns MappingInfo object for the memory field which is intended to store the other properties of the Appointment object. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the other properties of the Appointment object to be bound to the appropriate field in the data source.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public MappingInfo AppointmentProperties { get; }
Visual Basic
Public ReadOnly Property AppointmentProperties As MappingInfo
    Get

See Also

AppointmentMappingCollection Class
C1.C1Schedule Namespace


Body Property

[image]

.NET Framework Class Library
AppointmentMappingCollection..::..Body Property
AppointmentMappingCollection Class See Also
Returns MappingInfo object for the Body property of the Appointment object. If the storage object is bound to a data source via its DataSource property, the properties of the Body allow the Body property to be bound to the appropriate field in the data source.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public MappingInfo Body { get; }
Visual Basic
Public ReadOnly Property Body As MappingInfo
    Get

See Also

AppointmentMappingCollection Class
C1.C1Schedule Namespace


End Property

[image]

.NET Framework Class Library
AppointmentMappingCollection..::..End Property
AppointmentMappingCollection Class See Also
Returns MappingInfo object for the End property of the Appointment object. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the End property to be bound to the appropriate field in the data source.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public MappingInfo End { get; }
Visual Basic
Public ReadOnly Property End As MappingInfo
    Get

See Also

AppointmentMappingCollection Class
C1.C1Schedule Namespace


Item Property

[image] [image]

.NET Framework Class Library
AppointmentMappingCollection..::..Item Property
AppointmentMappingCollection Class See Also

Overload List

 | Name | Description
Public property | Item[([( TKey])]) | Gets the element with the specified key. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)

See Also

AppointmentMappingCollection Class
AppointmentMappingCollection Members
C1.C1Schedule Namespace


Location Property

[image]

.NET Framework Class Library
AppointmentMappingCollection..::..Location Property
AppointmentMappingCollection Class See Also
Returns MappingInfo object for the Location property of the Appointment object. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Location property to be bound to the appropriate field in the data source.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public MappingInfo Location { get; }
Visual Basic
Public ReadOnly Property Location As MappingInfo
    Get

See Also

AppointmentMappingCollection Class
C1.C1Schedule Namespace


OwnerIdMapping Property

[image]

.NET Framework Class Library
AppointmentMappingCollection..::..OwnerIdMapping Property
AppointmentMappingCollection Class See Also
Returns MappingInfo object for the Appointment.Owner.Id property of the Appointment object. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Owner property to be bound to the appropriate field in the data source.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public MappingInfo OwnerIdMapping { get; }
Visual Basic
Public ReadOnly Property OwnerIdMapping As MappingInfo
    Get

See Also

AppointmentMappingCollection Class
C1.C1Schedule Namespace


OwnerIndexMapping Property

[image]

.NET Framework Class Library
AppointmentMappingCollection..::..OwnerIndexMapping Property
AppointmentMappingCollection Class See Also
Returns MappingInfo object for the Appointment.Owner.Index property of the Appointment object. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Owner property to be bound to the appropriate field in the data source.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public MappingInfo OwnerIndexMapping { get; }
Visual Basic
Public ReadOnly Property OwnerIndexMapping As MappingInfo
    Get

See Also

AppointmentMappingCollection Class
C1.C1Schedule Namespace


Start Property

[image]

.NET Framework Class Library
AppointmentMappingCollection..::..Start Property
AppointmentMappingCollection Class See Also
Returns MappingInfo object for the Start property of the Appointment object. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Start property to be bound to the appropriate field in the data source.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public MappingInfo Start { get; }
Visual Basic
Public ReadOnly Property Start As MappingInfo
    Get

See Also

AppointmentMappingCollection Class
C1.C1Schedule Namespace


Subject Property

[image]

.NET Framework Class Library
AppointmentMappingCollection..::..Subject Property
AppointmentMappingCollection Class See Also
Returns MappingInfo object for the Subject property of the Appointment object. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Subject property to be bound to the appropriate field in the data source.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public MappingInfo Subject { get; }
Visual Basic
Public ReadOnly Property Subject As MappingInfo
    Get

See Also

AppointmentMappingCollection Class
C1.C1Schedule Namespace


AppointmentMappingCollection Events

[image] [image]

.NET Framework Class Library
AppointmentMappingCollection Events
AppointmentMappingCollection Class See Also

The AppointmentMappingCollection type exposes the following members.

Events

 | Name | Description
Public event | Disposed | Represents the method that handles the Disposed event of a component. (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)

See Also

AppointmentMappingCollection Class
C1.C1Schedule Namespace


AppointmentStorage Class

[image]

.NET Framework Class Library
AppointmentStorage Class
Members See Also
The AppointmentStorage is the storage for Appointment objects. It allows binding to the data source and mapping data source fields to the appointment properties.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class AppointmentStorage : BaseStorage<Appointment, AppointmentMappingCollection>
Visual Basic
Public Class AppointmentStorage _
    Inherits BaseStorage(Of Appointment, AppointmentMappingCollection)

Inheritance Hierarchy

System..::..Object
C1.C1Schedule..::..C1BindingSource
C1.C1Schedule..::..BaseStorage <(Of <(<' Appointment, AppointmentMappingCollection >)>)>
C1.C1Schedule..::..AppointmentStorage

See Also

AppointmentStorage Members
C1.C1Schedule Namespace


AppointmentStorage Members

[image] [image]

.NET Framework Class Library
AppointmentStorage Members
AppointmentStorage Class Methods Properties Events Explicit Interface Implementations See Also

The AppointmentStorage type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an existing item to the internal list. (Inherited from C1BindingSource.)
Public method | AddNew | Adds a new item to the underlying list. (Inherited from C1BindingSource.)
Public method | BeginEdit | Starts an edit operation on the specified object. (Inherited from C1BindingSource.)
Public method | Clear | Removes all elements from the list. (Inherited from C1BindingSource.)
Public method | Contains | Determines whether an object is an item in the list. (Inherited from C1BindingSource.)
Public method | CopyTo | Copies the contents of the List to the specified array, starting at the specified index value. (Inherited from C1BindingSource.)
Public method | EndEdit | Applies pending changes to the underlying data source. (Inherited from C1BindingSource.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FinishAddNew | Commits a pending new item to the collection. (Inherited from C1BindingSource.)
Public method | GetEnumerator | Retrieves an enumerator for the List. (Inherited from C1BindingSource.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the index of the first occurrence within the entire list. (Inherited from C1BindingSource.)
Public method | Insert | Inserts an item into the list at the specified index. (Inherited from C1BindingSource.)
Protected method | IsSynchronizable | Indicates whether the specified collection item should be synchronized. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAddingNew | (Inherited from C1BindingSource.)
Protected method | OnDataMemberChanged | (Inherited from C1BindingSource.)
Protected method | OnDataSourceChanged | (Inherited from C1BindingSource.)
Protected method | OnDataSourceItemSynchronized | Raises the DataSourceItemSynchronized()()()() event. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Protected method | OnListChanged | Translates changes in the internal list to the Objects collection. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | RefreshData | Call this method each time after changing your data source if it doesn't implement IBindingList interface. Or use BaseStorage{T, TMappingCollection}.Add and BaseStorage{T, TMappingCollection}.Remove instead of corresponding methods of your data source class. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | Remove | Removes object from the Objects collection. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | RemoveAt | Removes the item at the specified index in the list. (Inherited from C1BindingSource.)
Public method | ResetBindings | Causes a control bound to the C1BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from C1BindingSource.)
Public method | ResetItem | Causes a control bound to the C1BindingSource to re-read the item at the specified index, and refresh its displayed value. (Inherited from C1BindingSource.)
Protected method | ShouldSerializeMappings | (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowEdit | Gets a value indicating whether items in the underlying list can be edited. (Inherited from C1BindingSource.)
Public property | AllowNew | Gets or sets a value indicating whether the AddNew()()()() method can be used to add items to the list. (Inherited from C1BindingSource.)
Public property | AllowRemove | Gets a value indicating whether items can be removed from the underlying list. (Inherited from C1BindingSource.)
Public property | Appointments | Gets an AppointmentCollection object that contains appointment related information.
Public property | BoundMode | Gets a value indicating if the collection is bound to data. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | Count | Gets the total number of items in the underlying list. (Inherited from C1BindingSource.)
Protected property | DataKeyNamesInternal | This property is for internal use only. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | DataMember | Gets or sets the specific list in the data source to which the connector currently binds to. (Inherited from C1BindingSource.)
Public property | DataSource | Gets or sets the data source that the connector binds to. (Inherited from C1BindingSource.)
Public property | IsFixedSize | Gets a value indicating whether the underlying list has a fixed size. (Inherited from C1BindingSource.)
Public property | IsReadOnly | Gets a value indicating whether the underlying list is read-only. (Inherited from C1BindingSource.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from C1BindingSource.)
Public property | Item | Gets or sets the list element at the specified index. (Inherited from C1BindingSource.)
Public property | List | Gets the list that the connector is bound to. (Inherited from C1BindingSource.)
Public property | Mappings | Gets or sets the MappingCollectionBase<(Of <(<'T>)>)> derived object that allows the properties of objects maintained by the current collection to be bound to the appropriate fields in the data source. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | ScheduleStorage | Gets the reference to the owning C1ScheduleStorage component. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | SupportsChangeNotification | Gets a value indicating whether the data source supports change notification. (Inherited from C1BindingSource.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the underlying list. (Inherited from C1BindingSource.)

Events

 | Name | Description
Public event | AddingNew | Occurs before an item is added to the underlying list. (Inherited from C1BindingSource.)
Public event | DataMemberChanged | Occurs when the DataMember property value has changed. (Inherited from C1BindingSource.)
Public event | DataSourceChanged | Occurs when the DataSource property value has changed. (Inherited from C1BindingSource.)
Public event | ListChanged | Occurs when the underlying list changes or an item in the list changes. (Inherited from C1BindingSource.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitialize..::..BeginInit | (Inherited from C1BindingSource.)
Explicit interface implemetation | ISupportInitialize..::..EndInit | (Inherited from C1BindingSource.)
Explicit interface implemetation | ISupportInitializeNotification..::..Initialized | (Inherited from C1BindingSource.)
Explicit interface implemetation | ISupportInitializeNotification..::..IsInitialized | (Inherited from C1BindingSource.)

See Also

AppointmentStorage Class
C1.C1Schedule Namespace


AppointmentStorage Methods

[image] [image]

.NET Framework Class Library
AppointmentStorage Methods
AppointmentStorage Class See Also

The AppointmentStorage type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an existing item to the internal list. (Inherited from C1BindingSource.)
Public method | AddNew | Adds a new item to the underlying list. (Inherited from C1BindingSource.)
Public method | BeginEdit | Starts an edit operation on the specified object. (Inherited from C1BindingSource.)
Public method | Clear | Removes all elements from the list. (Inherited from C1BindingSource.)
Public method | Contains | Determines whether an object is an item in the list. (Inherited from C1BindingSource.)
Public method | CopyTo | Copies the contents of the List to the specified array, starting at the specified index value. (Inherited from C1BindingSource.)
Public method | EndEdit | Applies pending changes to the underlying data source. (Inherited from C1BindingSource.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FinishAddNew | Commits a pending new item to the collection. (Inherited from C1BindingSource.)
Public method | GetEnumerator | Retrieves an enumerator for the List. (Inherited from C1BindingSource.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the index of the first occurrence within the entire list. (Inherited from C1BindingSource.)
Public method | Insert | Inserts an item into the list at the specified index. (Inherited from C1BindingSource.)
Protected method | IsSynchronizable | Indicates whether the specified collection item should be synchronized. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAddingNew | (Inherited from C1BindingSource.)
Protected method | OnDataMemberChanged | (Inherited from C1BindingSource.)
Protected method | OnDataSourceChanged | (Inherited from C1BindingSource.)
Protected method | OnDataSourceItemSynchronized | Raises the DataSourceItemSynchronized()()()() event. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Protected method | OnListChanged | Translates changes in the internal list to the Objects collection. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | RefreshData | Call this method each time after changing your data source if it doesn't implement IBindingList interface. Or use BaseStorage{T, TMappingCollection}.Add and BaseStorage{T, TMappingCollection}.Remove instead of corresponding methods of your data source class. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | Remove | Removes object from the Objects collection. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | RemoveAt | Removes the item at the specified index in the list. (Inherited from C1BindingSource.)
Public method | ResetBindings | Causes a control bound to the C1BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from C1BindingSource.)
Public method | ResetItem | Causes a control bound to the C1BindingSource to re-read the item at the specified index, and refresh its displayed value. (Inherited from C1BindingSource.)
Protected method | ShouldSerializeMappings | (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitialize..::..BeginInit | (Inherited from C1BindingSource.)
Explicit interface implemetation | ISupportInitialize..::..EndInit | (Inherited from C1BindingSource.)

See Also

AppointmentStorage Class
C1.C1Schedule Namespace


AppointmentStorage Properties

[image] [image]

.NET Framework Class Library
AppointmentStorage Properties
AppointmentStorage Class See Also

The AppointmentStorage type exposes the following members.

Properties

 | Name | Description
Public property | AllowEdit | Gets a value indicating whether items in the underlying list can be edited. (Inherited from C1BindingSource.)
Public property | AllowNew | Gets or sets a value indicating whether the AddNew()()()() method can be used to add items to the list. (Inherited from C1BindingSource.)
Public property | AllowRemove | Gets a value indicating whether items can be removed from the underlying list. (Inherited from C1BindingSource.)
Public property | Appointments | Gets an AppointmentCollection object that contains appointment related information.
Public property | BoundMode | Gets a value indicating if the collection is bound to data. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | Count | Gets the total number of items in the underlying list. (Inherited from C1BindingSource.)
Protected property | DataKeyNamesInternal | This property is for internal use only. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | DataMember | Gets or sets the specific list in the data source to which the connector currently binds to. (Inherited from C1BindingSource.)
Public property | DataSource | Gets or sets the data source that the connector binds to. (Inherited from C1BindingSource.)
Public property | IsFixedSize | Gets a value indicating whether the underlying list has a fixed size. (Inherited from C1BindingSource.)
Public property | IsReadOnly | Gets a value indicating whether the underlying list is read-only. (Inherited from C1BindingSource.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from C1BindingSource.)
Public property | Item | Gets or sets the list element at the specified index. (Inherited from C1BindingSource.)
Public property | List | Gets the list that the connector is bound to. (Inherited from C1BindingSource.)
Public property | Mappings | Gets or sets the MappingCollectionBase<(Of <(<'T>)>)> derived object that allows the properties of objects maintained by the current collection to be bound to the appropriate fields in the data source. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | ScheduleStorage | Gets the reference to the owning C1ScheduleStorage component. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | SupportsChangeNotification | Gets a value indicating whether the data source supports change notification. (Inherited from C1BindingSource.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the underlying list. (Inherited from C1BindingSource.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitializeNotification..::..IsInitialized | (Inherited from C1BindingSource.)

See Also

AppointmentStorage Class
C1.C1Schedule Namespace


Appointments Property

[image]

.NET Framework Class Library
AppointmentStorage..::..Appointments Property
AppointmentStorage Class See Also
Gets an AppointmentCollection object that contains appointment related information.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public AppointmentCollection Appointments { get; }
Visual Basic
Public ReadOnly Property Appointments As AppointmentCollection
    Get

See Also

AppointmentStorage Class
C1.C1Schedule Namespace


AppointmentStorage Events

[image] [image]

.NET Framework Class Library
AppointmentStorage Events
AppointmentStorage Class See Also

The AppointmentStorage type exposes the following members.

Events

 | Name | Description
Public event | AddingNew | Occurs before an item is added to the underlying list. (Inherited from C1BindingSource.)
Public event | DataMemberChanged | Occurs when the DataMember property value has changed. (Inherited from C1BindingSource.)
Public event | DataSourceChanged | Occurs when the DataSource property value has changed. (Inherited from C1BindingSource.)
Public event | ListChanged | Occurs when the underlying list changes or an item in the list changes. (Inherited from C1BindingSource.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitializeNotification..::..Initialized | (Inherited from C1BindingSource.)

See Also

AppointmentStorage Class
C1.C1Schedule Namespace


BaseCollection(T) Class

[image]

.NET Framework Class Library
BaseCollection<(Of <(<'T>)>)> Class
Members See Also
The BaseCollection<(Of <(<'T>)>)> is a base generic class for all collections in C1Schedule object model.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultMemberAttribute("Item")]
public class BaseCollection<T> : C1ObservableKeyedCollection<Guid, T>
where T : BasePersistableObject
Visual Basic
<DefaultMemberAttribute("Item")> _
Public Class BaseCollection(Of T As BasePersistableObject) _
    Inherits C1ObservableKeyedCollection(Of Guid, T)

Type Parameters

T
The type of the objects which will be stored in the collection. It should be derived from the BasePersistableObject class and have the default parameter-less constructor.

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<'T>)>)>
System.Collections.ObjectModel..::..KeyedCollection <(Of <(<' Guid, T>)>)>
C1.C1Schedule..::..C1ObservableKeyedCollection <(Of <(<' Guid, T>)>)>
C1.C1Schedule..::..BaseCollection<(Of <(<'T>)>)>
C1.C1Schedule..::..AppointmentCollection
C1.C1Schedule..::..CategoryCollection
C1.C1Schedule..::..ContactCollection
C1.C1Schedule..::..LabelCollection
C1.C1Schedule..::..ResourceCollection
C1.C1Schedule..::..StatusCollection

See Also

BaseCollection<(Of <(<'T>)>)> Members
C1.C1Schedule Namespace


BaseCollection(T) Members

[image] [image]

.NET Framework Class Library
BaseCollection<(Of <(<'T>)>)> Members
BaseCollection<(Of <(<'T>)>)> Class Constructors Methods Properties Explicit Interface Implementations See Also

The BaseCollection<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | BaseCollection<(Of <(<'T>)>)> | Initializes a new instance of the BaseCollection<(Of <(<'T>)>)> class.

Methods

 | Name | Description
Public method | Add | Adds a new custom object to the collection. If the item already exists in the collection, its index is returned.
Public method | AddRange(array<Object>[]()[][]) | Adds an array of objects to the collection. This methods clears the collection before adding new items. Don't use it if you want to keep preexisting items.
Public method | AddRange(array<T>[]()[][]) | Adds an array of objects to the collection. This methods clears the collection before adding new items. Don't use it if you want to keep preexisting items.
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection <(Of <(<' Guid, T >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected method | ClearItems | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' Guid, T >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)> Collection<(Of <(<'T>)>)>.)
Public method | Contains(Int32) | Check if collection contains an item with specified index.
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKeyForItem | Extracts the key from the specified element. (Overrides KeyedCollection<(Of <(<'TKey, TItem>)>)>..::..GetKeyForItem(TItem).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected method | InsertItem | Overrides default behavior of collection at inserting new items. (Overrides C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>..::..InsertItem(Int32, TItem).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, T >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)> Collection<(Of <(<'T>)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected method | RemoveItem | Overrides base class implementation. (Overrides C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>..::..RemoveItem(Int32).)
Protected method | SetItem | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection <(Of <(<' Guid, T >)>)>.)
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, T >)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' T >)>)> Collection<(Of <(<'T>)>)>.)
Public property | Item[([( Guid])]) | Gets the element with the specified key if any.
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected property | OwnerInternal |

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' T >)>)>.)

See Also

BaseCollection<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


BaseCollection(T) Constructor

[image]

.NET Framework Class Library
BaseCollection<(Of <(<'T>)>)> Constructor
BaseCollection<(Of <(<'T>)>)> Class See Also
Initializes a new instance of the BaseCollection<(Of <(<'T>)>)> class.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public BaseCollection(
    Object owner
)
Visual Basic
Public Sub New ( _
    owner As Object _
)

Parameters

owner
Type: System..::..Object
The owning storage.

See Also

BaseCollection<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


BaseCollection(T) Methods

[image] [image]

.NET Framework Class Library
BaseCollection<(Of <(<'T>)>)> Methods
BaseCollection<(Of <(<'T>)>)> Class See Also

The BaseCollection<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a new custom object to the collection. If the item already exists in the collection, its index is returned.
Public method | AddRange(array<Object>[]()[][]) | Adds an array of objects to the collection. This methods clears the collection before adding new items. Don't use it if you want to keep preexisting items.
Public method | AddRange(array<T>[]()[][]) | Adds an array of objects to the collection. This methods clears the collection before adding new items. Don't use it if you want to keep preexisting items.
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection <(Of <(<' Guid, T >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected method | ClearItems | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' Guid, T >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)> Collection<(Of <(<'T>)>)>.)
Public method | Contains(Int32) | Check if collection contains an item with specified index.
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKeyForItem | Extracts the key from the specified element. (Overrides KeyedCollection<(Of <(<'TKey, TItem>)>)>..::..GetKeyForItem(TItem).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected method | InsertItem | Overrides default behavior of collection at inserting new items. (Overrides C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>..::..InsertItem(Int32, TItem).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, T >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)> Collection<(Of <(<'T>)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected method | RemoveItem | Overrides base class implementation. (Overrides C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>..::..RemoveItem(Int32).)
Protected method | SetItem | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' T >)>)>.)

See Also

BaseCollection<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


Add Method

[image]

.NET Framework Class Library
BaseCollection<(Of <(<'T>)>)>..::..Add Method
BaseCollection<(Of <(<'T>)>)> Class See Also
Adds a new custom object to the collection. If the item already exists in the collection, its index is returned.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public int Add(
    T item
)
Visual Basic
Public Function Add ( _
    item As T _
) As Integer

Parameters

item
Type: T

Return Value

Returns the index of newly added custom object.

See Also

BaseCollection<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


AddRange Method

[image] [image]

.NET Framework Class Library
BaseCollection<(Of <(<'T>)>)>..::..AddRange Method
BaseCollection<(Of <(<'T>)>)> Class See Also

Overload List

 | Name | Description
Public method | AddRange(array<Object>[]()[][]) | Adds an array of objects to the collection. This methods clears the collection before adding new items. Don't use it if you want to keep preexisting items.
Public method | AddRange(array<T>[]()[][]) | Adds an array of objects to the collection. This methods clears the collection before adding new items. Don't use it if you want to keep preexisting items.

See Also

BaseCollection<(Of <(<'T>)>)> Class
BaseCollection<(Of <(<'T>)>)> Members
C1.C1Schedule Namespace


AddRange Method (Object[])

[image]

.NET Framework Class Library
BaseCollection<(Of <(<'T>)>)>..::..AddRange Method (array<Object>[]()[][])
BaseCollection<(Of <(<'T>)>)> Class See Also
Adds an array of objects to the collection. This methods clears the collection before adding new items. Don't use it if you want to keep preexisting items.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void AddRange(
    Object[] items
)
Visual Basic
Public Sub AddRange ( _
    items As Object() _
)

Parameters

items
Type: array< System..::..Object >[]()[][]
An array of items.

See Also

BaseCollection<(Of <(<'T>)>)> Class
AddRange Overload
C1.C1Schedule Namespace


AddRange Method (T[])

[image]

.NET Framework Class Library
BaseCollection<(Of <(<'T>)>)>..::..AddRange Method (array<T>[]()[][])
BaseCollection<(Of <(<'T>)>)> Class See Also
Adds an array of objects to the collection. This methods clears the collection before adding new items. Don't use it if you want to keep preexisting items.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual void AddRange(
    T[] items
)
Visual Basic
Public Overridable Sub AddRange ( _
    items As T() _
)

Parameters

items
Type: array< T >[]()[][]
An array of items.

See Also

BaseCollection<(Of <(<'T>)>)> Class
AddRange Overload
C1.C1Schedule Namespace


Contains Method

[image] [image]

.NET Framework Class Library
BaseCollection<(Of <(<'T>)>)>..::..Contains Method
BaseCollection<(Of <(<'T>)>)> Class See Also

Overload List

 | Name | Description
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' Guid, T >)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | Contains(Int32) | Check if collection contains an item with specified index.

See Also

BaseCollection<(Of <(<'T>)>)> Class
BaseCollection<(Of <(<'T>)>)> Members
C1.C1Schedule Namespace


Contains Method (Int32)

[image]

.NET Framework Class Library
BaseCollection<(Of <(<'T>)>)>..::..Contains Method (Int32)
BaseCollection<(Of <(<'T>)>)> Class See Also
Check if collection contains an item with specified index.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool Contains(
    int index
)
Visual Basic
Public Function Contains ( _
    index As Integer _
) As Boolean

Parameters

index
Type: System..::..Int32
The zero-based index of the item to locate.

Return Value

True if the item is found in the collection; otherwise, false.

See Also

BaseCollection<(Of <(<'T>)>)> Class
Contains Overload
C1.C1Schedule Namespace


GetKeyForItem Method

[image]

.NET Framework Class Library
BaseCollection<(Of <(<'T>)>)>..::..GetKeyForItem Method
BaseCollection<(Of <(<'T>)>)> Class See Also
Extracts the key from the specified element.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override Guid GetKeyForItem(
    T item
)
Visual Basic
Protected Overrides Function GetKeyForItem ( _
    item As T _
) As Guid

Parameters

item
Type: T
The element from which to extract the key.

Return Value

The key for the specified element.

See Also

BaseCollection<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


InsertItem Method

[image]

.NET Framework Class Library
BaseCollection<(Of <(<'T>)>)>..::..InsertItem Method
BaseCollection<(Of <(<'T>)>)> Class See Also
Overrides default behavior of collection at inserting new items.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void InsertItem(
    int index,
    T item
)
Visual Basic
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As T _
)

Parameters

index
Type: System..::..Int32
The zero-based index of the item to insert.
item
Type: T
The object to insert.

See Also

BaseCollection<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


Remove Method

[image] [image]

.NET Framework Class Library
BaseCollection<(Of <(<'T>)>)>..::..Remove Method
BaseCollection<(Of <(<'T>)>)> Class See Also

Overload List

 | Name | Description
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, T >)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)

See Also

BaseCollection<(Of <(<'T>)>)> Class
BaseCollection<(Of <(<'T>)>)> Members
C1.C1Schedule Namespace


RemoveItem Method

[image]

.NET Framework Class Library
BaseCollection<(Of <(<'T>)>)>..::..RemoveItem Method
BaseCollection<(Of <(<'T>)>)> Class See Also
Overrides base class implementation.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void RemoveItem(
    int index
)
Visual Basic
Protected Overrides Sub RemoveItem ( _
    index As Integer _
)

Parameters

index
Type: System..::..Int32
The zero-based index of the item to remove.

See Also

BaseCollection<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


BaseCollection(T) Properties

[image] [image]

.NET Framework Class Library
BaseCollection<(Of <(<'T>)>)> Properties
BaseCollection<(Of <(<'T>)>)> Class See Also

The BaseCollection<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection <(Of <(<' Guid, T >)>)>.)
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, T >)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' T >)>)> Collection<(Of <(<'T>)>)>.)
Public property | Item[([( Guid])]) | Gets the element with the specified key if any.
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected property | OwnerInternal |

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' T >)>)>.)

See Also

BaseCollection<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


Item Property

[image] [image]

.NET Framework Class Library
BaseCollection<(Of <(<'T>)>)>..::..Item Property
BaseCollection<(Of <(<'T>)>)> Class See Also

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Public property | Item[([( Guid])]) | Gets the element with the specified key if any.

See Also

BaseCollection<(Of <(<'T>)>)> Class
BaseCollection<(Of <(<'T>)>)> Members
C1.C1Schedule Namespace


Item Property (Guid)

[image]

.NET Framework Class Library
BaseCollection<(Of <(<'T>)>)>..::..Item Property (Guid)
BaseCollection<(Of <(<'T>)>)> Class See Also
Gets the element with the specified key if any.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public T this[
    Guid key
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    key As Guid _
) As T
    Get

Parameters

key
Type: System..::..Guid
The key of the element to get.

Return Value

The element with the specified key. If an element with the specified key is not found, return null.

See Also

BaseCollection<(Of <(<'T>)>)> Class
Item Overload
C1.C1Schedule Namespace


OwnerInternal Property

[image]

.NET Framework Class Library
BaseCollection<(Of <(<'T>)>)>..::..OwnerInternal Property
BaseCollection<(Of <(<'T>)>)> Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected internal Object OwnerInternal { get; }
Visual Basic
Protected Friend ReadOnly Property OwnerInternal As Object
    Get

See Also

BaseCollection<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


BaseCollection(T) Events

[image] [image]

.NET Framework Class Library
BaseCollection<(Of <(<'T>)>)> Events
BaseCollection<(Of <(<'T>)>)> Class See Also

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)

See Also

BaseCollection<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


BaseList(T) Class

[image]

.NET Framework Class Library
BaseList<(Of <(<'T>)>)> Class
Members See Also
The BaseList<(Of <(<'T>)>)> is a base generic class for all lists in C1Schedule's object model. Only objects existing in the owning collection can be added to this list.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class BaseList<T> : C1ObservableCollection<T>
where T : BasePersistableObject
Visual Basic
Public Class BaseList(Of T As BasePersistableObject) _
    Inherits C1ObservableCollection(Of T)

Type Parameters

T
The type of the objects which will be stored in the list. It should be derived from the BasePersistableObject class.

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<'T>)>)>
C1.C1Schedule..::..C1ObservableCollection <(Of <(<'T>)>)>
C1.C1Schedule..::..BaseList<(Of <(<'T>)>)>
C1.C1Schedule..::..CategoryList
C1.C1Schedule..::..ContactList
C1.C1Schedule..::..LabelList
C1.C1Schedule..::..ResourceList
C1.C1Schedule..::..StatusList

See Also

BaseList<(Of <(<'T>)>)> Members
C1.C1Schedule Namespace


BaseList(T) Members

[image] [image]

.NET Framework Class Library
BaseList<(Of <(<'T>)>)> Members
BaseList<(Of <(<'T>)>)> Class Methods Properties Explicit Interface Implementations See Also

The BaseList<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected method | ClearItems | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected method | InsertItem | Overrides default behavior of Collection. Prevents from adding items non-existent in the parent collection. (Overrides C1ObservableCollection<(Of <(<'T>)>)>..::..InsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected method | RemoveItem | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Protected method | SetItem | Overrides default behavior of Collection. Prevents from adding items non-existent in the parent collection. (Overrides C1ObservableCollection<(Of <(<'T>)>)>..::..SetItem(Int32, T).)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected property | Owner | Gets the reference to the owning collection.

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' T >)>)>.)

See Also

BaseList<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


BaseList(T) Methods

[image] [image]

.NET Framework Class Library
BaseList<(Of <(<'T>)>)> Methods
BaseList<(Of <(<'T>)>)> Class See Also

The BaseList<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected method | ClearItems | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected method | InsertItem | Overrides default behavior of Collection. Prevents from adding items non-existent in the parent collection. (Overrides C1ObservableCollection<(Of <(<'T>)>)>..::..InsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected method | RemoveItem | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Protected method | SetItem | Overrides default behavior of Collection. Prevents from adding items non-existent in the parent collection. (Overrides C1ObservableCollection<(Of <(<'T>)>)>..::..SetItem(Int32, T).)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' T >)>)>.)

See Also

BaseList<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


InsertItem Method

[image]

.NET Framework Class Library
BaseList<(Of <(<'T>)>)>..::..InsertItem Method
BaseList<(Of <(<'T>)>)> Class See Also
Overrides default behavior of Collection. Prevents from adding items non-existent in the parent collection.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void InsertItem(
    int index,
    T item
)
Visual Basic
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As T _
)

Parameters

index
Type: System..::..Int32
The zero-based index of the item to insert.
item
Type: T
The object to insert.

See Also

BaseList<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


SetItem Method

[image]

.NET Framework Class Library
BaseList<(Of <(<'T>)>)>..::..SetItem Method
BaseList<(Of <(<'T>)>)> Class See Also
Overrides default behavior of Collection. Prevents from adding items non-existent in the parent collection.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void SetItem(
    int index,
    T item
)
Visual Basic
Protected Overrides Sub SetItem ( _
    index As Integer, _
    item As T _
)

Parameters

index
Type: System..::..Int32
The zero-based index of the item.
item
Type: T
The object to set.

See Also

BaseList<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


ToString Method

[image]

.NET Framework Class Library
BaseList<(Of <(<'T>)>)>..::..ToString Method
BaseList<(Of <(<'T>)>)> Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

See Also

BaseList<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


BaseList(T) Properties

[image] [image]

.NET Framework Class Library
BaseList<(Of <(<'T>)>)> Properties
BaseList<(Of <(<'T>)>)> Class See Also

The BaseList<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected property | Owner | Gets the reference to the owning collection.

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' T >)>)>.)

See Also

BaseList<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


Owner Property

[image]

.NET Framework Class Library
BaseList<(Of <(<'T>)>)>..::..Owner Property
BaseList<(Of <(<'T>)>)> Class See Also
Gets the reference to the owning collection.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected BaseCollection<T> Owner { get; }
Visual Basic
Protected ReadOnly Property Owner As BaseCollection(Of T)
    Get

See Also

BaseList<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


BaseList(T) Events

[image] [image]

.NET Framework Class Library
BaseList<(Of <(<'T>)>)> Events
BaseList<(Of <(<'T>)>)> Class See Also

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)

See Also

BaseList<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


BaseObject Class

[image]

.NET Framework Class Library
BaseObject Class
Members See Also
The BaseObject is a base class for resources, labels, statuses, categories and contacts. It implements base UI properties and persistence.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class BaseObject : BasePersistableObject
Visual Basic
Public Class BaseObject _
    Inherits BasePersistableObject

Inheritance Hierarchy

System..::..Object
C1.C1Schedule..::..BasePersistableObject
C1.C1Schedule..::..BaseObject
C1.C1Schedule..::..Category
C1.C1Schedule..::..Contact
C1.C1Schedule..::..Label
C1.C1Schedule..::..Resource
C1.C1Schedule..::..Status

See Also

BaseObject Members
C1.C1Schedule Namespace


BaseObject Members

[image] [image]

.NET Framework Class Library
BaseObject Members
BaseObject Class Constructors Methods Properties Explicit Interface Implementations See Also

The BaseObject type exposes the following members.

Constructors

 | Name | Description
Public method | BaseObject()()()() | Creates the new BaseObject object with default settings.
Public method | BaseObject(String) | Creates the new BaseObject object with specified text.
Public method | BaseObject(String, String) | Creates the new BaseObject object with specified text and menu caption.
Public method | BaseObject(Color, String, String) | Creates the new BaseObject object with specified color, text and menu caption.
Public method | BaseObject(Color, String, String, C1Brush) | Creates the new BaseObject object with specified parameters.

Methods

 | Name | Description
Public method | BeginEdit | Brings the object in edit mode. (Inherited from BasePersistableObject.)
Protected method | BeginEditInternal | (Inherited from BasePersistableObject.)
Public method | CancelEdit | Discards changes since the last BeginEdit()()()() call. (Inherited from BasePersistableObject.)
Public method | EndEdit()()()() | Finishes edit mode started by the BeginEdit()()()() method and updates a corresponding data source item. (Inherited from BasePersistableObject.)
Protected method | EndEdit(Boolean) | (Inherited from BasePersistableObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromXml(XmlReader) | Loads an object from the specified XmlReader. (Overrides BasePersistableObject..::..FromXml(XmlReader).)
Public method | FromXml(Stream) | Loads an object from the specified Stream. (Inherited from BasePersistableObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Overrides the default behavior. (Inherited from BasePersistableObject.)
Public method | ToString | Overrides the default behavior. (Overrides Object..::..ToString()()()().)
Public method | ToXml(XmlWriter) | Saves an object into specified XmlWriter. (Overrides BasePersistableObject..::..ToXml(XmlWriter).)
Public method | ToXml(Stream) | Saves an object to the specified Stream. (Inherited from BasePersistableObject.)

Properties

 | Name | Description
Public property | Brush | Gets or sets the brush used to fill the user interface object's image.
Public property | Color | Gets or sets the color of the user interface object.
Public property | IsEdit | Indicates whether the object is in edit mode, which is started using the BeginEdit()()()() method. (Inherited from BasePersistableObject.)
Public property | Key | Gets an array of objects representing the key of the BasePersistableObject. (Inherited from BasePersistableObject.)
Public property | MenuCaption | Gets or sets the menu caption for the user interface object.
Public property | Text | Gets or sets the text which identifies a user interface object.

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged | (Inherited from BasePersistableObject.)

See Also

BaseObject Class
C1.C1Schedule Namespace


BaseObject Constructor

[image] [image]

.NET Framework Class Library
BaseObject Constructor
BaseObject Class See Also

Overload List

 | Name | Description
Public method | BaseObject()()()() | Creates the new BaseObject object with default settings.
Public method | BaseObject(String) | Creates the new BaseObject object with specified text.
Public method | BaseObject(String, String) | Creates the new BaseObject object with specified text and menu caption.
Public method | BaseObject(Color, String, String) | Creates the new BaseObject object with specified color, text and menu caption.
Public method | BaseObject(Color, String, String, C1Brush) | Creates the new BaseObject object with specified parameters.

See Also

BaseObject Class
BaseObject Members
C1.C1Schedule Namespace


BaseObject Constructor

[image]

.NET Framework Class Library
BaseObject Constructor
BaseObject Class See Also
Creates the new BaseObject object with default settings.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public BaseObject()
Visual Basic
Public Sub New

See Also

BaseObject Class
BaseObject Overload
C1.C1Schedule Namespace


BaseObject Constructor (String)

[image]

.NET Framework Class Library
BaseObject Constructor (String)
BaseObject Class See Also
Creates the new BaseObject object with specified text.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public BaseObject(
    string text
)
Visual Basic
Public Sub New ( _
    text As String _
)

Parameters

text
Type: System..::..String
The String value.

See Also

BaseObject Class
BaseObject Overload
C1.C1Schedule Namespace


BaseObject Constructor (String, String)

[image]

.NET Framework Class Library
BaseObject Constructor (String, String)
BaseObject Class See Also
Creates the new BaseObject object with specified text and menu caption.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public BaseObject(
    string text,
    string menuCaption
)
Visual Basic
Public Sub New ( _
    text As String, _
    menuCaption As String _
)

Parameters

text
Type: System..::..String
The String value.
menuCaption
Type: System..::..String
The String value.

See Also

BaseObject Class
BaseObject Overload
C1.C1Schedule Namespace


BaseObject Constructor (Color, String, String)

[image]

.NET Framework Class Library
BaseObject Constructor (Color, String, String)
BaseObject Class See Also
Creates the new BaseObject object with specified color, text and menu caption.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public BaseObject(
    Color color,
    string text,
    string menuCaption
)
Visual Basic
Public Sub New ( _
    color As Color, _
    text As String, _
    menuCaption As String _
)

Parameters

color
Type: System.Windows.Media..::..Color
The Color value.
text
Type: System..::..String
The String value.
menuCaption
Type: System..::..String
The String value.

See Also

BaseObject Class
BaseObject Overload
C1.C1Schedule Namespace


BaseObject Constructor (Color, String, String, C1Brush)

[image]

.NET Framework Class Library
BaseObject Constructor (Color, String, String, C1Brush)
BaseObject Class See Also
Creates the new BaseObject object with specified parameters.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public BaseObject(
    Color color,
    string text,
    string menuCaption,
    C1Brush brush
)
Visual Basic
Public Sub New ( _
    color As Color, _
    text As String, _
    menuCaption As String, _
    brush As C1Brush _
)

Parameters

color
Type: System.Windows.Media..::..Color
The Color value.
text
Type: System..::..String
The String value.
menuCaption
Type: System..::..String
The String value.
brush
Type: C1.C1Schedule..::..C1Brush
The Brush object.

See Also

BaseObject Class
BaseObject Overload
C1.C1Schedule Namespace


BaseObject Methods

[image] [image]

.NET Framework Class Library
BaseObject Methods
BaseObject Class See Also

The BaseObject type exposes the following members.

Methods

 | Name | Description
Public method | BeginEdit | Brings the object in edit mode. (Inherited from BasePersistableObject.)
Protected method | BeginEditInternal | (Inherited from BasePersistableObject.)
Public method | CancelEdit | Discards changes since the last BeginEdit()()()() call. (Inherited from BasePersistableObject.)
Public method | EndEdit()()()() | Finishes edit mode started by the BeginEdit()()()() method and updates a corresponding data source item. (Inherited from BasePersistableObject.)
Protected method | EndEdit(Boolean) | (Inherited from BasePersistableObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromXml(XmlReader) | Loads an object from the specified XmlReader. (Overrides BasePersistableObject..::..FromXml(XmlReader).)
Public method | FromXml(Stream) | Loads an object from the specified Stream. (Inherited from BasePersistableObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Overrides the default behavior. (Inherited from BasePersistableObject.)
Public method | ToString | Overrides the default behavior. (Overrides Object..::..ToString()()()().)
Public method | ToXml(XmlWriter) | Saves an object into specified XmlWriter. (Overrides BasePersistableObject..::..ToXml(XmlWriter).)
Public method | ToXml(Stream) | Saves an object to the specified Stream. (Inherited from BasePersistableObject.)

See Also

BaseObject Class
C1.C1Schedule Namespace


EndEdit Method

[image] [image]

.NET Framework Class Library
BaseObject..::..EndEdit Method
BaseObject Class See Also

Overload List

 | Name | Description
Public method | EndEdit()()()() | Finishes edit mode started by the BeginEdit()()()() method and updates a corresponding data source item. (Inherited from BasePersistableObject.)
Protected method | EndEdit(Boolean) | (Inherited from BasePersistableObject.)

See Also

BaseObject Class
BaseObject Members
C1.C1Schedule Namespace


FromXml Method

[image] [image]

.NET Framework Class Library
BaseObject..::..FromXml Method
BaseObject Class See Also

Overload List

 | Name | Description
Public method | FromXml(XmlReader) | Loads an object from the specified XmlReader. (Overrides BasePersistableObject..::..FromXml(XmlReader).)
Public method | FromXml(Stream) | Loads an object from the specified Stream. (Inherited from BasePersistableObject.)

See Also

BaseObject Class
BaseObject Members
C1.C1Schedule Namespace


FromXml Method (XmlReader)

[image]

.NET Framework Class Library
BaseObject..::..FromXml Method (XmlReader)
BaseObject Class See Also
Loads an object from the specified XmlReader.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override bool FromXml(
    XmlReader reader
)
Visual Basic
Public Overrides Function FromXml ( _
    reader As XmlReader _
) As Boolean

Parameters

reader
Type: System.Xml..::..XmlReader
An XmlReader which contains the object data.

Return Value

Returns true if object has been changed.

See Also

BaseObject Class
FromXml Overload
C1.C1Schedule Namespace


ToString Method

[image]

.NET Framework Class Library
BaseObject..::..ToString Method
BaseObject Class See Also
Overrides the default behavior.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

The text which identifies a user interface object.

See Also

BaseObject Class
C1.C1Schedule Namespace


ToXml Method

[image] [image]

.NET Framework Class Library
BaseObject..::..ToXml Method
BaseObject Class See Also

Overload List

 | Name | Description
Public method | ToXml(XmlWriter) | Saves an object into specified XmlWriter. (Overrides BasePersistableObject..::..ToXml(XmlWriter).)
Public method | ToXml(Stream) | Saves an object to the specified Stream. (Inherited from BasePersistableObject.)

See Also

BaseObject Class
BaseObject Members
C1.C1Schedule Namespace


ToXml Method (XmlWriter)

[image]

.NET Framework Class Library
BaseObject..::..ToXml Method (XmlWriter)
BaseObject Class See Also
Saves an object into specified XmlWriter.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override void ToXml(
    XmlWriter writer
)
Visual Basic
Public Overrides Sub ToXml ( _
    writer As XmlWriter _
)

Parameters

writer
Type: System.Xml..::..XmlWriter
The XmlWriter that will receive the object data.

See Also

BaseObject Class
ToXml Overload
C1.C1Schedule Namespace


BaseObject Properties

[image] [image]

.NET Framework Class Library
BaseObject Properties
BaseObject Class See Also

The BaseObject type exposes the following members.

Properties

 | Name | Description
Public property | Brush | Gets or sets the brush used to fill the user interface object's image.
Public property | Color | Gets or sets the color of the user interface object.
Public property | IsEdit | Indicates whether the object is in edit mode, which is started using the BeginEdit()()()() method. (Inherited from BasePersistableObject.)
Public property | Key | Gets an array of objects representing the key of the BasePersistableObject. (Inherited from BasePersistableObject.)
Public property | MenuCaption | Gets or sets the menu caption for the user interface object.
Public property | Text | Gets or sets the text which identifies a user interface object.

See Also

BaseObject Class
C1.C1Schedule Namespace


Brush Property

[image]

.NET Framework Class Library
BaseObject..::..Brush Property
BaseObject Class See Also
Gets or sets the brush used to fill the user interface object's image.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1Brush Brush { get; set; }
Visual Basic
Public Property Brush As C1Brush
    Get
    Set

Remarks

Supported persistence only for System.Drawing.Drawing2D.HatchBrush and System.Drawing.SolidBrush

See Also

BaseObject Class
C1.C1Schedule Namespace


Color Property

[image]

.NET Framework Class Library
BaseObject..::..Color Property
BaseObject Class See Also
Gets or sets the color of the user interface object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Color Color { get; set; }
Visual Basic
Public Property Color As Color
    Get
    Set

See Also

BaseObject Class
C1.C1Schedule Namespace


MenuCaption Property

[image]

.NET Framework Class Library
BaseObject..::..MenuCaption Property
BaseObject Class See Also
Gets or sets the menu caption for the user interface object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string MenuCaption { get; set; }
Visual Basic
Public Property MenuCaption As String
    Get
    Set

See Also

BaseObject Class
C1.C1Schedule Namespace


Text Property

[image]

.NET Framework Class Library
BaseObject..::..Text Property
BaseObject Class See Also
Gets or sets the text which identifies a user interface object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set

See Also

BaseObject Class
C1.C1Schedule Namespace


BaseObject Events

[image] [image]

.NET Framework Class Library
BaseObject Events
BaseObject Class See Also

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged | (Inherited from BasePersistableObject.)

See Also

BaseObject Class
C1.C1Schedule Namespace


BaseObjectMappingCollection(T) Class

[image]

.NET Framework Class Library
BaseObjectMappingCollection<(Of <(<'T>)>)> Class
Members See Also
Represents a generic collection of mappings for properties of the BaseObject derived objects to appropriate data fields.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class BaseObjectMappingCollection<T> : MappingCollectionBase<T>
where T : new(), BaseObject
Visual Basic
Public Class BaseObjectMappingCollection(Of T As {New, BaseObject}) _
    Inherits MappingCollectionBase(Of T)

Type Parameters

T
The type of the objects for mapping. It should be derived from the BaseObject class and have the default parameter-less constructor.

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' MappingInfo >)>)>
System.Collections.ObjectModel..::..KeyedCollection <(Of <(<' String, MappingInfo >)>)>
C1.C1Schedule..::..MappingCollectionBase <(Of <(<'T>)>)>
C1.C1Schedule..::..BaseObjectMappingCollection<(Of <(<'T>)>)>

See Also

BaseObjectMappingCollection<(Of <(<'T>)>)> Members
C1.C1Schedule Namespace


BaseObjectMappingCollection(T) Members

[image] [image]

.NET Framework Class Library
BaseObjectMappingCollection<(Of <(<'T>)>)> Members
BaseObjectMappingCollection<(Of <(<'T>)>)> Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The BaseObjectMappingCollection<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | BaseObjectMappingCollection<(Of <(<'T>)>)> | Initializes a new instance of the BaseObjectMappingCollection<(Of <(<'T>)>)> class.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Protected method | ClearItems | Removes all elements from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)> Collection<(Of <(<'T>)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKeyForItem | Returns property name as the key for collection. (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Protected method | InsertItem | (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)> Collection<(Of <(<'T>)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Protected method | SetItem | Replaces the item at the specified index with the specified item. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CaptionMapping | Returns MappingInfo object for MenuCaption property of the object. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the MenuCaption property of the object to be bound to the appropriate field in the data source.
Public property | ColorMapping | Returns MappingInfo object for the Color property of the object. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Color property of the object to be bound to the appropriate field in the data source.
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)
Public property | Count | Gets the number of elements actually contained in the MappingCollectionBase<(Of <(<'T>)>)> object. (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public property | IdMapping | Returns MappingInfo object for the Id()()()() property. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Id()()()() property to be bound to the appropriate field in the data source. (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)
Public property | IndexMapping | Returns MappingInfo object for the Index()()()() property. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Index()()()() property to be bound to the appropriate field in the data source. (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)
Public property | Item[([( TKey])]) | Gets the element with the specified key. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' MappingInfo >)>)> Collection<(Of <(<'T>)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Public property | TextMapping | Returns MappingInfo object for the Text property of the object. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Text property of the object to be bound to the appropriate field in the data source.

Events

 | Name | Description
Public event | Disposed | Represents the method that handles the Disposed event of a component. (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)

See Also

BaseObjectMappingCollection<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


BaseObjectMappingCollection(T) Constructor

[image]

.NET Framework Class Library
BaseObjectMappingCollection<(Of <(<'T>)>)> Constructor
BaseObjectMappingCollection<(Of <(<'T>)>)> Class See Also
Initializes a new instance of the BaseObjectMappingCollection<(Of <(<'T>)>)> class.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public BaseObjectMappingCollection()
Visual Basic
Public Sub New

See Also

BaseObjectMappingCollection<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


BaseObjectMappingCollection(T) Methods

[image] [image]

.NET Framework Class Library
BaseObjectMappingCollection<(Of <(<'T>)>)> Methods
BaseObjectMappingCollection<(Of <(<'T>)>)> Class See Also

The BaseObjectMappingCollection<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Protected method | ClearItems | Removes all elements from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)> Collection<(Of <(<'T>)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKeyForItem | Returns property name as the key for collection. (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Protected method | InsertItem | (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)> Collection<(Of <(<'T>)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Protected method | SetItem | Replaces the item at the specified index with the specified item. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)

See Also

BaseObjectMappingCollection<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


Contains Method

[image] [image]

.NET Framework Class Library
BaseObjectMappingCollection<(Of <(<'T>)>)>..::..Contains Method
BaseObjectMappingCollection<(Of <(<'T>)>)> Class See Also

Overload List

 | Name | Description
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)

See Also

BaseObjectMappingCollection<(Of <(<'T>)>)> Class
BaseObjectMappingCollection<(Of <(<'T>)>)> Members
C1.C1Schedule Namespace


Remove Method

[image] [image]

.NET Framework Class Library
BaseObjectMappingCollection<(Of <(<'T>)>)>..::..Remove Method
BaseObjectMappingCollection<(Of <(<'T>)>)> Class See Also

Overload List

 | Name | Description
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)

See Also

BaseObjectMappingCollection<(Of <(<'T>)>)> Class
BaseObjectMappingCollection<(Of <(<'T>)>)> Members
C1.C1Schedule Namespace


BaseObjectMappingCollection(T) Properties

[image] [image]

.NET Framework Class Library
BaseObjectMappingCollection<(Of <(<'T>)>)> Properties
BaseObjectMappingCollection<(Of <(<'T>)>)> Class See Also

The BaseObjectMappingCollection<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | CaptionMapping | Returns MappingInfo object for MenuCaption property of the object. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the MenuCaption property of the object to be bound to the appropriate field in the data source.
Public property | ColorMapping | Returns MappingInfo object for the Color property of the object. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Color property of the object to be bound to the appropriate field in the data source.
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)
Public property | Count | Gets the number of elements actually contained in the MappingCollectionBase<(Of <(<'T>)>)> object. (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public property | IdMapping | Returns MappingInfo object for the Id()()()() property. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Id()()()() property to be bound to the appropriate field in the data source. (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)
Public property | IndexMapping | Returns MappingInfo object for the Index()()()() property. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Index()()()() property to be bound to the appropriate field in the data source. (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)
Public property | Item[([( TKey])]) | Gets the element with the specified key. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' MappingInfo >)>)> Collection<(Of <(<'T>)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Public property | TextMapping | Returns MappingInfo object for the Text property of the object. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Text property of the object to be bound to the appropriate field in the data source.

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)

See Also

BaseObjectMappingCollection<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


CaptionMapping Property

[image]

.NET Framework Class Library
BaseObjectMappingCollection<(Of <(<'T>)>)>..::..CaptionMapping Property
BaseObjectMappingCollection<(Of <(<'T>)>)> Class See Also
Returns MappingInfo object for MenuCaption property of the object. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the MenuCaption property of the object to be bound to the appropriate field in the data source.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public MappingInfo CaptionMapping { get; }
Visual Basic
Public ReadOnly Property CaptionMapping As MappingInfo
    Get

See Also

BaseObjectMappingCollection<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


ColorMapping Property

[image]

.NET Framework Class Library
BaseObjectMappingCollection<(Of <(<'T>)>)>..::..ColorMapping Property
BaseObjectMappingCollection<(Of <(<'T>)>)> Class See Also
Returns MappingInfo object for the Color property of the object. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Color property of the object to be bound to the appropriate field in the data source.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public MappingInfo ColorMapping { get; }
Visual Basic
Public ReadOnly Property ColorMapping As MappingInfo
    Get

See Also

BaseObjectMappingCollection<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


Item Property

[image] [image]

.NET Framework Class Library
BaseObjectMappingCollection<(Of <(<'T>)>)>..::..Item Property
BaseObjectMappingCollection<(Of <(<'T>)>)> Class See Also

Overload List

 | Name | Description
Public property | Item[([( TKey])]) | Gets the element with the specified key. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)

See Also

BaseObjectMappingCollection<(Of <(<'T>)>)> Class
BaseObjectMappingCollection<(Of <(<'T>)>)> Members
C1.C1Schedule Namespace


TextMapping Property

[image]

.NET Framework Class Library
BaseObjectMappingCollection<(Of <(<'T>)>)>..::..TextMapping Property
BaseObjectMappingCollection<(Of <(<'T>)>)> Class See Also
Returns MappingInfo object for the Text property of the object. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Text property of the object to be bound to the appropriate field in the data source.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public MappingInfo TextMapping { get; }
Visual Basic
Public ReadOnly Property TextMapping As MappingInfo
    Get

See Also

BaseObjectMappingCollection<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


BaseObjectMappingCollection(T) Events

[image] [image]

.NET Framework Class Library
BaseObjectMappingCollection<(Of <(<'T>)>)> Events
BaseObjectMappingCollection<(Of <(<'T>)>)> Class See Also

The BaseObjectMappingCollection<(Of <(<'T>)>)> type exposes the following members.

Events

 | Name | Description
Public event | Disposed | Represents the method that handles the Disposed event of a component. (Inherited from MappingCollectionBase<(Of <(<'T>)>)>.)

See Also

BaseObjectMappingCollection<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


BasePersistableObject Class

[image]

.NET Framework Class Library
BasePersistableObject Class
Members See Also
The BasePersistableObject is a base class for persistable objects.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class BasePersistableObject : INotifyPropertyChanged
Visual Basic
Public Class BasePersistableObject _
    Implements INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
C1.C1Schedule..::..BasePersistableObject
C1.C1Schedule..::..Appointment
C1.C1Schedule..::..BaseObject

See Also

BasePersistableObject Members
C1.C1Schedule Namespace


BasePersistableObject Members

[image] [image]

.NET Framework Class Library
BasePersistableObject Members
BasePersistableObject Class Methods Properties Explicit Interface Implementations See Also

The BasePersistableObject type exposes the following members.

Methods

 | Name | Description
Public method | BeginEdit | Brings the object in edit mode.
Protected method | BeginEditInternal |
Public method | CancelEdit | Discards changes since the last BeginEdit()()()() call.
Public method | EndEdit()()()() | Finishes edit mode started by the BeginEdit()()()() method and updates a corresponding data source item.
Protected method | EndEdit(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromXml(Stream) | Loads an object from the specified Stream.
Public method | FromXml(XmlReader) | Loads an object from the specified XmlReader.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Overrides the default behavior.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToXml(Stream) | Saves an object to the specified Stream.
Public method | ToXml(XmlWriter) | Saves an object to the specified XmlWriter.

Properties

 | Name | Description
Public property | IsEdit | Indicates whether the object is in edit mode, which is started using the BeginEdit()()()() method.
Public property | Key | Gets an array of objects representing the key of the BasePersistableObject.

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged |

See Also

BasePersistableObject Class
C1.C1Schedule Namespace


BasePersistableObject Methods

[image] [image]

.NET Framework Class Library
BasePersistableObject Methods
BasePersistableObject Class See Also

The BasePersistableObject type exposes the following members.

Methods

 | Name | Description
Public method | BeginEdit | Brings the object in edit mode.
Protected method | BeginEditInternal |
Public method | CancelEdit | Discards changes since the last BeginEdit()()()() call.
Public method | EndEdit()()()() | Finishes edit mode started by the BeginEdit()()()() method and updates a corresponding data source item.
Protected method | EndEdit(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromXml(Stream) | Loads an object from the specified Stream.
Public method | FromXml(XmlReader) | Loads an object from the specified XmlReader.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Overrides the default behavior.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToXml(Stream) | Saves an object to the specified Stream.
Public method | ToXml(XmlWriter) | Saves an object to the specified XmlWriter.

See Also

BasePersistableObject Class
C1.C1Schedule Namespace


BeginEdit Method

[image]

.NET Framework Class Library
BasePersistableObject..::..BeginEdit Method
BasePersistableObject Class See Also
Brings the object in edit mode.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual void BeginEdit()
Visual Basic
Public Overridable Sub BeginEdit

Remarks

A corresponding item from a data source will not be updated on this object's property changes while the object is in edit mode. Data synchronization will be performed when the EndEdit()()()() method will be called.

See Also

BasePersistableObject Class
C1.C1Schedule Namespace


BeginEditInternal Method

[image]

.NET Framework Class Library
BasePersistableObject..::..BeginEditInternal Method
BasePersistableObject Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected internal void BeginEditInternal()
Visual Basic
Protected Friend Sub BeginEditInternal

See Also

BasePersistableObject Class
C1.C1Schedule Namespace


CancelEdit Method

[image]

.NET Framework Class Library
BasePersistableObject..::..CancelEdit Method
BasePersistableObject Class See Also
Discards changes since the last BeginEdit()()()() call.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual void CancelEdit()
Visual Basic
Public Overridable Sub CancelEdit

See Also

BasePersistableObject Class
C1.C1Schedule Namespace


EndEdit Method

[image] [image]

.NET Framework Class Library
BasePersistableObject..::..EndEdit Method
BasePersistableObject Class See Also

Overload List

 | Name | Description
Public method | EndEdit()()()() | Finishes edit mode started by the BeginEdit()()()() method and updates a corresponding data source item.
Protected method | EndEdit(Boolean) |

See Also

BasePersistableObject Class
BasePersistableObject Members
C1.C1Schedule Namespace


EndEdit Method

[image]

.NET Framework Class Library
BasePersistableObject..::..EndEdit Method
BasePersistableObject Class See Also
Finishes edit mode started by the BeginEdit()()()() method and updates a corresponding data source item.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void EndEdit()
Visual Basic
Public Sub EndEdit

See Also

BasePersistableObject Class
EndEdit Overload
C1.C1Schedule Namespace


EndEdit Method (Boolean)

[image]

.NET Framework Class Library
BasePersistableObject..::..EndEdit Method (Boolean)
BasePersistableObject Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void EndEdit(
    bool canRaiseChangeNotification
)
Visual Basic
Protected Overridable Sub EndEdit ( _
    canRaiseChangeNotification As Boolean _
)

Parameters

canRaiseChangeNotification
Type: System..::..Boolean

See Also

BasePersistableObject Class
EndEdit Overload
C1.C1Schedule Namespace


FromXml Method

[image] [image]

.NET Framework Class Library
BasePersistableObject..::..FromXml Method
BasePersistableObject Class See Also

Overload List

 | Name | Description
Public method | FromXml(Stream) | Loads an object from the specified Stream.
Public method | FromXml(XmlReader) | Loads an object from the specified XmlReader.

See Also

BasePersistableObject Class
BasePersistableObject Members
C1.C1Schedule Namespace


FromXml Method (Stream)

[image]

.NET Framework Class Library
BasePersistableObject..::..FromXml Method (Stream)
BasePersistableObject Class See Also
Loads an object from the specified Stream.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool FromXml(
    Stream stream
)
Visual Basic
Public Function FromXml ( _
    stream As Stream _
) As Boolean

Parameters

stream
Type: System.IO..::..Stream
The Stream that contains the object data.

Return Value

Returns true if object has been changed.

See Also

BasePersistableObject Class
FromXml Overload
C1.C1Schedule Namespace


FromXml Method (XmlReader)

[image]

.NET Framework Class Library
BasePersistableObject..::..FromXml Method (XmlReader)
BasePersistableObject Class See Also
Loads an object from the specified XmlReader.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual bool FromXml(
    XmlReader reader
)
Visual Basic
Public Overridable Function FromXml ( _
    reader As XmlReader _
) As Boolean

Parameters

reader
Type: System.Xml..::..XmlReader
An XmlReader which contains the object data.

Return Value

Returns true if object has been changed.

See Also

BasePersistableObject Class
FromXml Overload
C1.C1Schedule Namespace


OnPropertyChanged Method

[image]

.NET Framework Class Library
BasePersistableObject..::..OnPropertyChanged Method
BasePersistableObject Class See Also
Overrides the default behavior.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnPropertyChanged(
    string propertyName
)
Visual Basic
Protected Overridable Sub OnPropertyChanged ( _
    propertyName As String _
)

Parameters

propertyName
Type: System..::..String
The property name.

See Also

BasePersistableObject Class
C1.C1Schedule Namespace


ToXml Method

[image] [image]

.NET Framework Class Library
BasePersistableObject..::..ToXml Method
BasePersistableObject Class See Also

Overload List

 | Name | Description
Public method | ToXml(Stream) | Saves an object to the specified Stream.
Public method | ToXml(XmlWriter) | Saves an object to the specified XmlWriter.

See Also

BasePersistableObject Class
BasePersistableObject Members
C1.C1Schedule Namespace


ToXml Method (Stream)

[image]

.NET Framework Class Library
BasePersistableObject..::..ToXml Method (Stream)
BasePersistableObject Class See Also
Saves an object to the specified Stream.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void ToXml(
    Stream stream
)
Visual Basic
Public Sub ToXml ( _
    stream As Stream _
)

Parameters

stream
Type: System.IO..::..Stream
The Stream that contains the object data.

See Also

BasePersistableObject Class
ToXml Overload
C1.C1Schedule Namespace


ToXml Method (XmlWriter)

[image]

.NET Framework Class Library
BasePersistableObject..::..ToXml Method (XmlWriter)
BasePersistableObject Class See Also
Saves an object to the specified XmlWriter.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual void ToXml(
    XmlWriter writer
)
Visual Basic
Public Overridable Sub ToXml ( _
    writer As XmlWriter _
)

Parameters

writer
Type: System.Xml..::..XmlWriter
The XmlWriter that will receive the object data.

See Also

BasePersistableObject Class
ToXml Overload
C1.C1Schedule Namespace


BasePersistableObject Properties

[image] [image]

.NET Framework Class Library
BasePersistableObject Properties
BasePersistableObject Class See Also

The BasePersistableObject type exposes the following members.

Properties

 | Name | Description
Public property | IsEdit | Indicates whether the object is in edit mode, which is started using the BeginEdit()()()() method.
Public property | Key | Gets an array of objects representing the key of the BasePersistableObject.

See Also

BasePersistableObject Class
C1.C1Schedule Namespace


IsEdit Property

[image]

.NET Framework Class Library
BasePersistableObject..::..IsEdit Property
BasePersistableObject Class See Also
Indicates whether the object is in edit mode, which is started using the BeginEdit()()()() method.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsEdit { get; }
Visual Basic
Public ReadOnly Property IsEdit As Boolean
    Get

See Also

BasePersistableObject Class
C1.C1Schedule Namespace


Key Property

[image]

.NET Framework Class Library
BasePersistableObject..::..Key Property
BasePersistableObject Class See Also
Gets an array of objects representing the key of the BasePersistableObject.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object[] Key { get; }
Visual Basic
Public ReadOnly Property Key As Object()
    Get

Remarks

In the current version, the array always contains a single object. It can be either an Int32 or Guid value depending on which one is actually used for binding this data. For example, if you bind AppointmentStorage to the database and set IndexMapping, this property will return an Int32 value. If you set IdMapping, this property will return a Guid value.

In future versions working with compound keys might be implemented. In such case this property will return array of objects composing the key.

See Also

BasePersistableObject Class
C1.C1Schedule Namespace


BasePersistableObject Events

[image] [image]

.NET Framework Class Library
BasePersistableObject Events
BasePersistableObject Class See Also

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged |

See Also

BasePersistableObject Class
C1.C1Schedule Namespace


INotifyPropertyChanged.PropertyChanged Event

[image]

.NET Framework Class Library
BasePersistableObject..::..INotifyPropertyChanged..::..PropertyChanged Event
BasePersistableObject Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
event PropertyChangedEventHandler INotifyPropertyChanged.PropertyChanged
Visual Basic
Private Event PropertyChanged As PropertyChangedEventHandler
    Implements INotifyPropertyChanged.PropertyChanged

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

BasePersistableObject Class
C1.C1Schedule Namespace


BaseStorage(T, TMappingCollection) Class

[image]

.NET Framework Class Library
BaseStorage<(Of <(<'T, TMappingCollection>)>)> Class
Members See Also
The BaseStorage<(Of <(<'T, TMappingCollection>)>)> is the base generic component for all storages in C1Schedule object model. Represents a storage of objects derived from BasePersistableObject. This component implements methods of operations over the collections of objects. It allows the collection to be populated programmatically or automatically by retrieving data from the data source which is specified by the DataSource and DataMember properties. It allows mapping of data source fields to the object properties.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class BaseStorage<T, TMappingCollection> : C1BindingSource
where T : new(), BasePersistableObject
where TMappingCollection : new(), MappingCollectionBase<T>
Visual Basic
Public Class BaseStorage(Of T As {New, BasePersistableObject}, TMappingCollection As {New, MappingCollectionBase(Of T)}) _
    Inherits C1BindingSource

Type Parameters

T
The type of the objects which will be stored in the storage. It should be derived from the BasePersistableObject class and have the default parameter-less constructor.
TMappingCollection
The type of the collection which will be used for mapping. It should be derived from the MappingCollectionBase<(Of <(<'T>)>)> class and have the default parameter-less constructor.

Inheritance Hierarchy

System..::..Object
C1.C1Schedule..::..C1BindingSource
C1.C1Schedule..::..BaseStorage<(Of <(<'T, TMappingCollection>)>)>
C1.C1Schedule..::..AppointmentStorage
C1.C1Schedule..::..CategoryStorage
C1.C1Schedule..::..ContactStorage
C1.C1Schedule..::..LabelStorage
C1.C1Schedule..::..ResourceStorage
C1.C1Schedule..::..StatusStorage

See Also

BaseStorage<(Of <(<'T, TMappingCollection>)>)> Members
C1.C1Schedule Namespace


BaseStorage(T, TMappingCollection) Members

[image] [image]

.NET Framework Class Library
BaseStorage<(Of <(<'T, TMappingCollection>)>)> Members
BaseStorage<(Of <(<'T, TMappingCollection>)>)> Class Methods Properties Events Explicit Interface Implementations See Also

The BaseStorage<(Of <(<'T, TMappingCollection>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an existing item to the internal list. (Inherited from C1BindingSource.)
Public method | AddNew | Adds a new item to the underlying list. (Inherited from C1BindingSource.)
Public method | BeginEdit | Starts an edit operation on the specified object. (Inherited from C1BindingSource.)
Public method | Clear | Removes all elements from the list. (Inherited from C1BindingSource.)
Public method | Contains | Determines whether an object is an item in the list. (Inherited from C1BindingSource.)
Public method | CopyTo | Copies the contents of the List to the specified array, starting at the specified index value. (Inherited from C1BindingSource.)
Public method | EndEdit | Applies pending changes to the underlying data source. (Inherited from C1BindingSource.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FinishAddNew | Commits a pending new item to the collection. (Inherited from C1BindingSource.)
Public method | GetEnumerator | Retrieves an enumerator for the List. (Inherited from C1BindingSource.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the index of the first occurrence within the entire list. (Inherited from C1BindingSource.)
Public method | Insert | Inserts an item into the list at the specified index. (Inherited from C1BindingSource.)
Protected method | IsSynchronizable | Indicates whether the specified collection item should be synchronized.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAddingNew | (Inherited from C1BindingSource.)
Protected method | OnDataMemberChanged | (Inherited from C1BindingSource.)
Protected method | OnDataSourceChanged | (Inherited from C1BindingSource.)
Protected method | OnDataSourceItemSynchronized | Raises the DataSourceItemSynchronized()()()() event.
Protected method | OnListChanged | Translates changes in the internal list to the Objects collection. (Overrides C1BindingSource..::..OnListChanged(ListChangedEventArgs).)
Public method | RefreshData | Call this method each time after changing your data source if it doesn't implement IBindingList interface. Or use BaseStorage{T, TMappingCollection}.Add and BaseStorage{T, TMappingCollection}.Remove instead of corresponding methods of your data source class.
Public method | Remove | Removes object from the Objects collection. (Overrides C1BindingSource..::..Remove(Object).)
Public method | RemoveAt | Removes the item at the specified index in the list. (Inherited from C1BindingSource.)
Public method | ResetBindings | Causes a control bound to the C1BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from C1BindingSource.)
Public method | ResetItem | Causes a control bound to the C1BindingSource to re-read the item at the specified index, and refresh its displayed value. (Inherited from C1BindingSource.)
Protected method | ShouldSerializeMappings |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowEdit | Gets a value indicating whether items in the underlying list can be edited. (Inherited from C1BindingSource.)
Public property | AllowNew | Gets or sets a value indicating whether the AddNew()()()() method can be used to add items to the list. (Inherited from C1BindingSource.)
Public property | AllowRemove | Gets a value indicating whether items can be removed from the underlying list. (Inherited from C1BindingSource.)
Public property | BoundMode | Gets a value indicating if the collection is bound to data.
Public property | Count | Gets the total number of items in the underlying list. (Inherited from C1BindingSource.)
Protected property | DataKeyNamesInternal | This property is for internal use only. (Overrides C1BindingSource..::..DataKeyNamesInternal.)
Public property | DataMember | Gets or sets the specific list in the data source to which the connector currently binds to. (Inherited from C1BindingSource.)
Public property | DataSource | Gets or sets the data source that the connector binds to. (Inherited from C1BindingSource.)
Public property | IsFixedSize | Gets a value indicating whether the underlying list has a fixed size. (Inherited from C1BindingSource.)
Public property | IsReadOnly | Gets a value indicating whether the underlying list is read-only. (Inherited from C1BindingSource.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from C1BindingSource.)
Public property | Item | Gets or sets the list element at the specified index. (Inherited from C1BindingSource.)
Public property | List | Gets the list that the connector is bound to. (Inherited from C1BindingSource.)
Public property | Mappings | Gets or sets the MappingCollectionBase<(Of <(<'T>)>)> derived object that allows the properties of objects maintained by the current collection to be bound to the appropriate fields in the data source.
Public property | ScheduleStorage | Gets the reference to the owning C1ScheduleStorage component.
Public property | SupportsChangeNotification | Gets a value indicating whether the data source supports change notification. (Inherited from C1BindingSource.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the underlying list. (Inherited from C1BindingSource.)

Events

 | Name | Description
Public event | AddingNew | Occurs before an item is added to the underlying list. (Inherited from C1BindingSource.)
Public event | DataMemberChanged | Occurs when the DataMember property value has changed. (Inherited from C1BindingSource.)
Public event | DataSourceChanged | Occurs when the DataSource property value has changed. (Inherited from C1BindingSource.)
Public event | ListChanged | Occurs when the underlying list changes or an item in the list changes. (Inherited from C1BindingSource.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitialize..::..BeginInit | (Inherited from C1BindingSource.)
Explicit interface implemetation | ISupportInitialize..::..EndInit | (Inherited from C1BindingSource.)
Explicit interface implemetation | ISupportInitializeNotification..::..Initialized | (Inherited from C1BindingSource.)
Explicit interface implemetation | ISupportInitializeNotification..::..IsInitialized | (Inherited from C1BindingSource.)

See Also

BaseStorage<(Of <(<'T, TMappingCollection>)>)> Class
C1.C1Schedule Namespace


BaseStorage(T, TMappingCollection) Methods

[image] [image]

.NET Framework Class Library
BaseStorage<(Of <(<'T, TMappingCollection>)>)> Methods
BaseStorage<(Of <(<'T, TMappingCollection>)>)> Class See Also

The BaseStorage<(Of <(<'T, TMappingCollection>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an existing item to the internal list. (Inherited from C1BindingSource.)
Public method | AddNew | Adds a new item to the underlying list. (Inherited from C1BindingSource.)
Public method | BeginEdit | Starts an edit operation on the specified object. (Inherited from C1BindingSource.)
Public method | Clear | Removes all elements from the list. (Inherited from C1BindingSource.)
Public method | Contains | Determines whether an object is an item in the list. (Inherited from C1BindingSource.)
Public method | CopyTo | Copies the contents of the List to the specified array, starting at the specified index value. (Inherited from C1BindingSource.)
Public method | EndEdit | Applies pending changes to the underlying data source. (Inherited from C1BindingSource.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FinishAddNew | Commits a pending new item to the collection. (Inherited from C1BindingSource.)
Public method | GetEnumerator | Retrieves an enumerator for the List. (Inherited from C1BindingSource.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the index of the first occurrence within the entire list. (Inherited from C1BindingSource.)
Public method | Insert | Inserts an item into the list at the specified index. (Inherited from C1BindingSource.)
Protected method | IsSynchronizable | Indicates whether the specified collection item should be synchronized.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAddingNew | (Inherited from C1BindingSource.)
Protected method | OnDataMemberChanged | (Inherited from C1BindingSource.)
Protected method | OnDataSourceChanged | (Inherited from C1BindingSource.)
Protected method | OnDataSourceItemSynchronized | Raises the DataSourceItemSynchronized()()()() event.
Protected method | OnListChanged | Translates changes in the internal list to the Objects collection. (Overrides C1BindingSource..::..OnListChanged(ListChangedEventArgs).)
Public method | RefreshData | Call this method each time after changing your data source if it doesn't implement IBindingList interface. Or use BaseStorage{T, TMappingCollection}.Add and BaseStorage{T, TMappingCollection}.Remove instead of corresponding methods of your data source class.
Public method | Remove | Removes object from the Objects collection. (Overrides C1BindingSource..::..Remove(Object).)
Public method | RemoveAt | Removes the item at the specified index in the list. (Inherited from C1BindingSource.)
Public method | ResetBindings | Causes a control bound to the C1BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from C1BindingSource.)
Public method | ResetItem | Causes a control bound to the C1BindingSource to re-read the item at the specified index, and refresh its displayed value. (Inherited from C1BindingSource.)
Protected method | ShouldSerializeMappings |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitialize..::..BeginInit | (Inherited from C1BindingSource.)
Explicit interface implemetation | ISupportInitialize..::..EndInit | (Inherited from C1BindingSource.)

See Also

BaseStorage<(Of <(<'T, TMappingCollection>)>)> Class
C1.C1Schedule Namespace


IsSynchronizable Method

[image]

.NET Framework Class Library
BaseStorage<(Of <(<'T, TMappingCollection>)>)>..::..IsSynchronizable Method
BaseStorage<(Of <(<'T, TMappingCollection>)>)> Class See Also
Indicates whether the specified collection item should be synchronized.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual bool IsSynchronizable(
    BasePersistableObject collectionItem
)
Visual Basic
Protected Overridable Function IsSynchronizable ( _
    collectionItem As BasePersistableObject _
) As Boolean

Parameters

collectionItem
Type: C1.C1Schedule..::..BasePersistableObject
The BasePersistableObject object.

Return Value

True if item should be synchronized; false, otherwise.

See Also

BaseStorage<(Of <(<'T, TMappingCollection>)>)> Class
C1.C1Schedule Namespace


OnDataSourceItemSynchronized Method

[image]

.NET Framework Class Library
BaseStorage<(Of <(<'T, TMappingCollection>)>)>..::..OnDataSourceItemSynchronized Method
BaseStorage<(Of <(<'T, TMappingCollection>)>)> Class See Also
Raises the DataSourceItemSynchronized()()()() event.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnDataSourceItemSynchronized(
    ItemSynchronizedEventArgs e
)
Visual Basic
Protected Overridable Sub OnDataSourceItemSynchronized ( _
    e As ItemSynchronizedEventArgs _
)

Parameters

e
Type: C1.C1Schedule..::..ItemSynchronizedEventArgs
The ItemSynchronizedEventArgs that contains the event data.

See Also

BaseStorage<(Of <(<'T, TMappingCollection>)>)> Class
C1.C1Schedule Namespace


OnListChanged Method

[image]

.NET Framework Class Library
BaseStorage<(Of <(<'T, TMappingCollection>)>)>..::..OnListChanged Method
BaseStorage<(Of <(<'T, TMappingCollection>)>)> Class See Also
Translates changes in the internal list to the Objects collection.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnListChanged(
    ListChangedEventArgs e
)
Visual Basic
Protected Overrides Sub OnListChanged ( _
    e As ListChangedEventArgs _
)

Parameters

e
Type: C1.C1Schedule..::..ListChangedEventArgs
A System.ComponentModel.ListChangedEventArgs object that contains the event data.

See Also

BaseStorage<(Of <(<'T, TMappingCollection>)>)> Class
C1.C1Schedule Namespace


RefreshData Method

[image]

.NET Framework Class Library
BaseStorage<(Of <(<'T, TMappingCollection>)>)>..::..RefreshData Method
BaseStorage<(Of <(<'T, TMappingCollection>)>)> Class See Also
Call this method each time after changing your data source if it doesn't implement IBindingList interface. Or use BaseStorage{T, TMappingCollection}.Add and BaseStorage{T, TMappingCollection}.Remove instead of corresponding methods of your data source class.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void RefreshData()
Visual Basic
Public Sub RefreshData

See Also

BaseStorage<(Of <(<'T, TMappingCollection>)>)> Class
C1.C1Schedule Namespace


Remove Method

[image]

.NET Framework Class Library
BaseStorage<(Of <(<'T, TMappingCollection>)>)>..::..Remove Method
BaseStorage<(Of <(<'T, TMappingCollection>)>)> Class See Also
Removes object from the Objects collection.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override void Remove(
    Object value
)
Visual Basic
Public Overrides Sub Remove ( _
    value As Object _
)

Parameters

value
Type: System..::..Object
The Object to remove.

Implements

IList..::..Remove(Object)

See Also

BaseStorage<(Of <(<'T, TMappingCollection>)>)> Class
C1.C1Schedule Namespace


ShouldSerializeMappings Method

[image]

.NET Framework Class Library
BaseStorage<(Of <(<'T, TMappingCollection>)>)>..::..ShouldSerializeMappings Method
BaseStorage<(Of <(<'T, TMappingCollection>)>)> Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected internal bool ShouldSerializeMappings()
Visual Basic
Protected Friend Function ShouldSerializeMappings As Boolean

Return Value

See Also

BaseStorage<(Of <(<'T, TMappingCollection>)>)> Class
C1.C1Schedule Namespace


BaseStorage(T, TMappingCollection) Properties

[image] [image]

.NET Framework Class Library
BaseStorage<(Of <(<'T, TMappingCollection>)>)> Properties
BaseStorage<(Of <(<'T, TMappingCollection>)>)> Class See Also

The BaseStorage<(Of <(<'T, TMappingCollection>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | AllowEdit | Gets a value indicating whether items in the underlying list can be edited. (Inherited from C1BindingSource.)
Public property | AllowNew | Gets or sets a value indicating whether the AddNew()()()() method can be used to add items to the list. (Inherited from C1BindingSource.)
Public property | AllowRemove | Gets a value indicating whether items can be removed from the underlying list. (Inherited from C1BindingSource.)
Public property | BoundMode | Gets a value indicating if the collection is bound to data.
Public property | Count | Gets the total number of items in the underlying list. (Inherited from C1BindingSource.)
Protected property | DataKeyNamesInternal | This property is for internal use only. (Overrides C1BindingSource..::..DataKeyNamesInternal.)
Public property | DataMember | Gets or sets the specific list in the data source to which the connector currently binds to. (Inherited from C1BindingSource.)
Public property | DataSource | Gets or sets the data source that the connector binds to. (Inherited from C1BindingSource.)
Public property | IsFixedSize | Gets a value indicating whether the underlying list has a fixed size. (Inherited from C1BindingSource.)
Public property | IsReadOnly | Gets a value indicating whether the underlying list is read-only. (Inherited from C1BindingSource.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from C1BindingSource.)
Public property | Item | Gets or sets the list element at the specified index. (Inherited from C1BindingSource.)
Public property | List | Gets the list that the connector is bound to. (Inherited from C1BindingSource.)
Public property | Mappings | Gets or sets the MappingCollectionBase<(Of <(<'T>)>)> derived object that allows the properties of objects maintained by the current collection to be bound to the appropriate fields in the data source.
Public property | ScheduleStorage | Gets the reference to the owning C1ScheduleStorage component.
Public property | SupportsChangeNotification | Gets a value indicating whether the data source supports change notification. (Inherited from C1BindingSource.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the underlying list. (Inherited from C1BindingSource.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitializeNotification..::..IsInitialized | (Inherited from C1BindingSource.)

See Also

BaseStorage<(Of <(<'T, TMappingCollection>)>)> Class
C1.C1Schedule Namespace


BoundMode Property

[image]

.NET Framework Class Library
BaseStorage<(Of <(<'T, TMappingCollection>)>)>..::..BoundMode Property
BaseStorage<(Of <(<'T, TMappingCollection>)>)> Class See Also
Gets a value indicating if the collection is bound to data.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool BoundMode { get; }
Visual Basic
Public ReadOnly Property BoundMode As Boolean
    Get

See Also

BaseStorage<(Of <(<'T, TMappingCollection>)>)> Class
C1.C1Schedule Namespace


DataKeyNamesInternal Property

[image]

.NET Framework Class Library
BaseStorage<(Of <(<'T, TMappingCollection>)>)>..::..DataKeyNamesInternal Property
BaseStorage<(Of <(<'T, TMappingCollection>)>)> Class See Also
This property is for internal use only.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected internal override string[] DataKeyNamesInternal { get; set; }
Visual Basic
Protected Friend Overrides Property DataKeyNamesInternal As String()
    Get
    Set

See Also

BaseStorage<(Of <(<'T, TMappingCollection>)>)> Class
C1.C1Schedule Namespace


Mappings Property

[image]

.NET Framework Class Library
BaseStorage<(Of <(<'T, TMappingCollection>)>)>..::..Mappings Property
BaseStorage<(Of <(<'T, TMappingCollection>)>)> Class See Also
Gets or sets the MappingCollectionBase<(Of <(<'T>)>)> derived object that allows the properties of objects maintained by the current collection to be bound to the appropriate fields in the data source.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public TMappingCollection Mappings { get; set; }
Visual Basic
Public Property Mappings As TMappingCollection
    Get
    Set

See Also

BaseStorage<(Of <(<'T, TMappingCollection>)>)> Class
C1.C1Schedule Namespace


ScheduleStorage Property

[image]

.NET Framework Class Library
BaseStorage<(Of <(<'T, TMappingCollection>)>)>..::..ScheduleStorage Property
BaseStorage<(Of <(<'T, TMappingCollection>)>)> Class See Also
Gets the reference to the owning C1ScheduleStorage component.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1ScheduleStorage ScheduleStorage { get; }
Visual Basic
Public ReadOnly Property ScheduleStorage As C1ScheduleStorage
    Get

See Also

BaseStorage<(Of <(<'T, TMappingCollection>)>)> Class
C1.C1Schedule Namespace


BaseStorage(T, TMappingCollection) Events

[image] [image]

.NET Framework Class Library
BaseStorage<(Of <(<'T, TMappingCollection>)>)> Events
BaseStorage<(Of <(<'T, TMappingCollection>)>)> Class See Also

The BaseStorage<(Of <(<'T, TMappingCollection>)>)> type exposes the following members.

Events

 | Name | Description
Public event | AddingNew | Occurs before an item is added to the underlying list. (Inherited from C1BindingSource.)
Public event | DataMemberChanged | Occurs when the DataMember property value has changed. (Inherited from C1BindingSource.)
Public event | DataSourceChanged | Occurs when the DataSource property value has changed. (Inherited from C1BindingSource.)
Public event | ListChanged | Occurs when the underlying list changes or an item in the list changes. (Inherited from C1BindingSource.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitializeNotification..::..Initialized | (Inherited from C1BindingSource.)

See Also

BaseStorage<(Of <(<'T, TMappingCollection>)>)> Class
C1.C1Schedule Namespace


C1BindingSource Class

[image]

.NET Framework Class Library
C1BindingSource Class
Members See Also
The C1BindingSource encapsulates the data source.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultMemberAttribute("Item")]
public class C1BindingSource : IList,
    ICollection, IEnumerable, ISupportInitializeNotification, ISupportInitialize
Visual Basic
<DefaultMemberAttribute("Item")> _
Public Class C1BindingSource _
    Implements IList, ICollection, IEnumerable, ISupportInitializeNotification,  _
    ISupportInitialize

Inheritance Hierarchy

System..::..Object
C1.C1Schedule..::..C1BindingSource
C1.C1Schedule..::..BaseStorage<(Of <(<'T, TMappingCollection>)>)>

See Also

C1BindingSource Members
C1.C1Schedule Namespace


C1BindingSource Members

[image] [image]

.NET Framework Class Library
C1BindingSource Members
C1BindingSource Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The C1BindingSource type exposes the following members.

Constructors

 | Name | Description
Public method | C1BindingSource()()()() | Initializes a new instance of the C1BindingSource class.
Public method | C1BindingSource(Object, String) | Initializes a new instance of the C1BindingSource class with the specified data source and data member values.

Methods

 | Name | Description
Public method | Add | Adds an existing item to the internal list.
Public method | AddNew | Adds a new item to the underlying list.
Public method | BeginEdit | Starts an edit operation on the specified object.
Public method | Clear | Removes all elements from the list.
Public method | Contains | Determines whether an object is an item in the list.
Public method | CopyTo | Copies the contents of the List to the specified array, starting at the specified index value.
Public method | EndEdit | Applies pending changes to the underlying data source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FinishAddNew | Commits a pending new item to the collection.
Public method | GetEnumerator | Retrieves an enumerator for the List.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the index of the first occurrence within the entire list.
Public method | Insert | Inserts an item into the list at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAddingNew |
Protected method | OnDataMemberChanged |
Protected method | OnDataSourceChanged |
Protected method | OnListChanged |
Public method | Remove | Removes the specified item from the list.
Public method | RemoveAt | Removes the item at the specified index in the list.
Public method | ResetBindings | Causes a control bound to the C1BindingSource to reread all the items in the list and refresh their displayed values.
Public method | ResetItem | Causes a control bound to the C1BindingSource to re-read the item at the specified index, and refresh its displayed value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowEdit | Gets a value indicating whether items in the underlying list can be edited.
Public property | AllowNew | Gets or sets a value indicating whether the AddNew()()()() method can be used to add items to the list.
Public property | AllowRemove | Gets a value indicating whether items can be removed from the underlying list.
Public property | Count | Gets the total number of items in the underlying list.
Protected property | DataKeyNamesInternal |
Public property | DataMember | Gets or sets the specific list in the data source to which the connector currently binds to.
Public property | DataSource | Gets or sets the data source that the connector binds to.
Public property | IsFixedSize | Gets a value indicating whether the underlying list has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the underlying list is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
Public property | Item | Gets or sets the list element at the specified index.
Public property | List | Gets the list that the connector is bound to.
Public property | SupportsChangeNotification | Gets a value indicating whether the data source supports change notification.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the underlying list.

Events

 | Name | Description
Public event | AddingNew | Occurs before an item is added to the underlying list.
Public event | DataMemberChanged | Occurs when the DataMember property value has changed.
Public event | DataSourceChanged | Occurs when the DataSource property value has changed.
Public event | ListChanged | Occurs when the underlying list changes or an item in the list changes.

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitialize..::..BeginInit |
Explicit interface implemetation | ISupportInitialize..::..EndInit |
Explicit interface implemetation | ISupportInitializeNotification..::..Initialized |
Explicit interface implemetation | ISupportInitializeNotification..::..IsInitialized |

See Also

C1BindingSource Class
C1.C1Schedule Namespace


C1BindingSource Constructor

[image] [image]

.NET Framework Class Library
C1BindingSource Constructor
C1BindingSource Class See Also

Overload List

 | Name | Description
Public method | C1BindingSource()()()() | Initializes a new instance of the C1BindingSource class.
Public method | C1BindingSource(Object, String) | Initializes a new instance of the C1BindingSource class with the specified data source and data member values.

See Also

C1BindingSource Class
C1BindingSource Members
C1.C1Schedule Namespace


C1BindingSource Constructor

[image]

.NET Framework Class Library
C1BindingSource Constructor
C1BindingSource Class See Also
Initializes a new instance of the C1BindingSource class.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1BindingSource()
Visual Basic
Public Sub New

See Also

C1BindingSource Class
C1BindingSource Overload
C1.C1Schedule Namespace


C1BindingSource Constructor (Object, String)

[image]

.NET Framework Class Library
C1BindingSource Constructor (Object, String)
C1BindingSource Class See Also
Initializes a new instance of the C1BindingSource class with the specified data source and data member values.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1BindingSource(
    Object dataSource,
    string dataMember
)
Visual Basic
Public Sub New ( _
    dataSource As Object, _
    dataMember As String _
)

Parameters

dataSource
Type: System..::..Object
The Object object to use as data source.
dataMember
Type: System..::..String
The data member name.

See Also

C1BindingSource Class
C1BindingSource Overload
C1.C1Schedule Namespace


C1BindingSource Methods

[image] [image]

.NET Framework Class Library
C1BindingSource Methods
C1BindingSource Class See Also

The C1BindingSource type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an existing item to the internal list.
Public method | AddNew | Adds a new item to the underlying list.
Public method | BeginEdit | Starts an edit operation on the specified object.
Public method | Clear | Removes all elements from the list.
Public method | Contains | Determines whether an object is an item in the list.
Public method | CopyTo | Copies the contents of the List to the specified array, starting at the specified index value.
Public method | EndEdit | Applies pending changes to the underlying data source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FinishAddNew | Commits a pending new item to the collection.
Public method | GetEnumerator | Retrieves an enumerator for the List.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the index of the first occurrence within the entire list.
Public method | Insert | Inserts an item into the list at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAddingNew |
Protected method | OnDataMemberChanged |
Protected method | OnDataSourceChanged |
Protected method | OnListChanged |
Public method | Remove | Removes the specified item from the list.
Public method | RemoveAt | Removes the item at the specified index in the list.
Public method | ResetBindings | Causes a control bound to the C1BindingSource to reread all the items in the list and refresh their displayed values.
Public method | ResetItem | Causes a control bound to the C1BindingSource to re-read the item at the specified index, and refresh its displayed value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitialize..::..BeginInit |
Explicit interface implemetation | ISupportInitialize..::..EndInit |

See Also

C1BindingSource Class
C1.C1Schedule Namespace


Add Method

[image]

.NET Framework Class Library
C1BindingSource..::..Add Method
C1BindingSource Class See Also
Adds an existing item to the internal list.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual int Add(
    Object value
)
Visual Basic
Public Overridable Function Add ( _
    value As Object _
) As Integer

Parameters

value
Type: System..::..Object
The Object to add.

Return Value

The position into which the new element was inserted.

Implements

IList..::..Add(Object)

See Also

C1BindingSource Class
C1.C1Schedule Namespace


AddNew Method

[image]

.NET Framework Class Library
C1BindingSource..::..AddNew Method
C1BindingSource Class See Also
Adds a new item to the underlying list.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual Object AddNew()
Visual Basic
Public Overridable Function AddNew As Object

Return Value

The item added to the list.

See Also

C1BindingSource Class
C1.C1Schedule Namespace


BeginEdit Method

[image]

.NET Framework Class Library
C1BindingSource..::..BeginEdit Method
C1BindingSource Class See Also
Starts an edit operation on the specified object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void BeginEdit(
    Object item
)
Visual Basic
Public Sub BeginEdit ( _
    item As Object _
)

Parameters

item
Type: System..::..Object
The object on which to start operation.

See Also

C1BindingSource Class
C1.C1Schedule Namespace


Clear Method

[image]

.NET Framework Class Library
C1BindingSource..::..Clear Method
C1BindingSource Class See Also
Removes all elements from the list.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear

Implements

IList..::..Clear()()()()

See Also

C1BindingSource Class
C1.C1Schedule Namespace


Contains Method

[image]

.NET Framework Class Library
C1BindingSource..::..Contains Method
C1BindingSource Class See Also
Determines whether an object is an item in the list.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual bool Contains(
    Object value
)
Visual Basic
Public Overridable Function Contains ( _
    value As Object _
) As Boolean

Parameters

value
Type: System..::..Object
The Object to locate.

Return Value

True if the Object is found in the list; otherwise, false.

Implements

IList..::..Contains(Object)

See Also

C1BindingSource Class
C1.C1Schedule Namespace


CopyTo Method

[image]

.NET Framework Class Library
C1BindingSource..::..CopyTo Method
C1BindingSource Class See Also
Copies the contents of the List to the specified array, starting at the specified index value.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual void CopyTo(
    Array array,
    int index
)
Visual Basic
Public Overridable Sub CopyTo ( _
    array As Array, _
    index As Integer _
)

Parameters

array
Type: System..::..Array
The one-dimensional Array that is the destination of the elements copied from ICollection. The Array must have zero-based indexing.
index
Type: System..::..Int32
The zero-based index in the array at which the copying begins.

Implements

ICollection..::..CopyTo(Array, Int32)

See Also

C1BindingSource Class
C1.C1Schedule Namespace


EndEdit Method

[image]

.NET Framework Class Library
C1BindingSource..::..EndEdit Method
C1BindingSource Class See Also
Applies pending changes to the underlying data source.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void EndEdit(
    Object item
)
Visual Basic
Public Sub EndEdit ( _
    item As Object _
)

Parameters

item
Type: System..::..Object
The object on which to apply pending changes.

See Also

C1BindingSource Class
C1.C1Schedule Namespace


FinishAddNew Method

[image]

.NET Framework Class Library
C1BindingSource..::..FinishAddNew Method
C1BindingSource Class See Also
Commits a pending new item to the collection.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void FinishAddNew()
Visual Basic
Public Sub FinishAddNew

See Also

C1BindingSource Class
C1.C1Schedule Namespace


GetEnumerator Method

[image]

.NET Framework Class Library
C1BindingSource..::..GetEnumerator Method
C1BindingSource Class See Also
Retrieves an enumerator for the List.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator

Return Value

An IEnumerable object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

C1BindingSource Class
C1.C1Schedule Namespace


IndexOf Method

[image]

.NET Framework Class Library
C1BindingSource..::..IndexOf Method
C1BindingSource Class See Also
Searches for the specified object and returns the index of the first occurrence within the entire list.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual int IndexOf(
    Object value
)
Visual Basic
Public Overridable Function IndexOf ( _
    value As Object _
) As Integer

Parameters

value
Type: System..::..Object
The Object to index.

Return Value

The index of value if found in the list; otherwise, -1.

Implements

IList..::..IndexOf(Object)

See Also

C1BindingSource Class
C1.C1Schedule Namespace


Insert Method

[image]

.NET Framework Class Library
C1BindingSource..::..Insert Method
C1BindingSource Class See Also
Inserts an item into the list at the specified index.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual void Insert(
    int index,
    Object value
)
Visual Basic
Public Overridable Sub Insert ( _
    index As Integer, _
    value As Object _
)

Parameters

index
Type: System..::..Int32
The zero-based index at which value should be inserted.
value
Type: System..::..Object
The Object to insert.

Implements

IList..::..Insert(Int32, Object)

See Also

C1BindingSource Class
C1.C1Schedule Namespace


ISupportInitialize.BeginInit Method

[image]

.NET Framework Class Library
C1BindingSource..::..ISupportInitialize..::..BeginInit Method
C1BindingSource Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
void ISupportInitialize.BeginInit()
Visual Basic
Private Sub BeginInit Implements ISupportInitialize.BeginInit

Implements

ISupportInitialize..::..BeginInit()()()()

See Also

C1BindingSource Class
C1.C1Schedule Namespace


ISupportInitialize.EndInit Method

[image]

.NET Framework Class Library
C1BindingSource..::..ISupportInitialize..::..EndInit Method
C1BindingSource Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
void ISupportInitialize.EndInit()
Visual Basic
Private Sub EndInit Implements ISupportInitialize.EndInit

Implements

ISupportInitialize..::..EndInit()()()()

See Also

C1BindingSource Class
C1.C1Schedule Namespace


OnAddingNew Method

[image]

.NET Framework Class Library
C1BindingSource..::..OnAddingNew Method
C1BindingSource Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnAddingNew(
    AddingNewEventArgs e
)
Visual Basic
Protected Overridable Sub OnAddingNew ( _
    e As AddingNewEventArgs _
)

Parameters

e
Type: C1.C1Schedule..::..AddingNewEventArgs

See Also

C1BindingSource Class
C1.C1Schedule Namespace


OnDataMemberChanged Method

[image]

.NET Framework Class Library
C1BindingSource..::..OnDataMemberChanged Method
C1BindingSource Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnDataMemberChanged(
    EventArgs e
)
Visual Basic
Protected Overridable Sub OnDataMemberChanged ( _
    e As EventArgs _
)

Parameters

e
Type: System..::..EventArgs

See Also

C1BindingSource Class
C1.C1Schedule Namespace


OnDataSourceChanged Method

[image]

.NET Framework Class Library
C1BindingSource..::..OnDataSourceChanged Method
C1BindingSource Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnDataSourceChanged(
    EventArgs e
)
Visual Basic
Protected Overridable Sub OnDataSourceChanged ( _
    e As EventArgs _
)

Parameters

e
Type: System..::..EventArgs

See Also

C1BindingSource Class
C1.C1Schedule Namespace


OnListChanged Method

[image]

.NET Framework Class Library
C1BindingSource..::..OnListChanged Method
C1BindingSource Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnListChanged(
    ListChangedEventArgs e
)
Visual Basic
Protected Overridable Sub OnListChanged ( _
    e As ListChangedEventArgs _
)

Parameters

e
Type: C1.C1Schedule..::..ListChangedEventArgs

See Also

C1BindingSource Class
C1.C1Schedule Namespace


Remove Method

[image]

.NET Framework Class Library
C1BindingSource..::..Remove Method
C1BindingSource Class See Also
Removes the specified item from the list.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual void Remove(
    Object value
)
Visual Basic
Public Overridable Sub Remove ( _
    value As Object _
)

Parameters

value
Type: System..::..Object
The Object to remove.

Implements

IList..::..Remove(Object)

See Also

C1BindingSource Class
C1.C1Schedule Namespace


RemoveAt Method

[image]

.NET Framework Class Library
C1BindingSource..::..RemoveAt Method
C1BindingSource Class See Also
Removes the item at the specified index in the list.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual void RemoveAt(
    int index
)
Visual Basic
Public Overridable Sub RemoveAt ( _
    index As Integer _
)

Parameters

index
Type: System..::..Int32
The zero-based index of the item to remove.

Implements

IList..::..RemoveAt(Int32)

See Also

C1BindingSource Class
C1.C1Schedule Namespace


ResetBindings Method

[image]

.NET Framework Class Library
C1BindingSource..::..ResetBindings Method
C1BindingSource Class See Also
Causes a control bound to the C1BindingSource to reread all the items in the list and refresh their displayed values.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void ResetBindings(
    bool metadataChanged
)
Visual Basic
Public Sub ResetBindings ( _
    metadataChanged As Boolean _
)

Parameters

metadataChanged
Type: System..::..Boolean
The Boolean value specifying whether the metadata has been changed.

See Also

C1BindingSource Class
C1.C1Schedule Namespace


ResetItem Method

[image]

.NET Framework Class Library
C1BindingSource..::..ResetItem Method
C1BindingSource Class See Also
Causes a control bound to the C1BindingSource to re-read the item at the specified index, and refresh its displayed value.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void ResetItem(
    int itemIndex
)
Visual Basic
Public Sub ResetItem ( _
    itemIndex As Integer _
)

Parameters

itemIndex
Type: System..::..Int32
The zero-based index of item to re-read.

See Also

C1BindingSource Class
C1.C1Schedule Namespace


C1BindingSource Properties

[image] [image]

.NET Framework Class Library
C1BindingSource Properties
C1BindingSource Class See Also

The C1BindingSource type exposes the following members.

Properties

 | Name | Description
Public property | AllowEdit | Gets a value indicating whether items in the underlying list can be edited.
Public property | AllowNew | Gets or sets a value indicating whether the AddNew()()()() method can be used to add items to the list.
Public property | AllowRemove | Gets a value indicating whether items can be removed from the underlying list.
Public property | Count | Gets the total number of items in the underlying list.
Protected property | DataKeyNamesInternal |
Public property | DataMember | Gets or sets the specific list in the data source to which the connector currently binds to.
Public property | DataSource | Gets or sets the data source that the connector binds to.
Public property | IsFixedSize | Gets a value indicating whether the underlying list has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the underlying list is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
Public property | Item | Gets or sets the list element at the specified index.
Public property | List | Gets the list that the connector is bound to.
Public property | SupportsChangeNotification | Gets a value indicating whether the data source supports change notification.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the underlying list.

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitializeNotification..::..IsInitialized |

See Also

C1BindingSource Class
C1.C1Schedule Namespace


AllowEdit Property

[image]

.NET Framework Class Library
C1BindingSource..::..AllowEdit Property
C1BindingSource Class See Also
Gets a value indicating whether items in the underlying list can be edited.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual bool AllowEdit { get; }
Visual Basic
Public Overridable ReadOnly Property AllowEdit As Boolean
    Get

See Also

C1BindingSource Class
C1.C1Schedule Namespace


AllowNew Property

[image]

.NET Framework Class Library
C1BindingSource..::..AllowNew Property
C1BindingSource Class See Also
Gets or sets a value indicating whether the AddNew()()()() method can be used to add items to the list.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual bool AllowNew { get; }
Visual Basic
Public Overridable ReadOnly Property AllowNew As Boolean
    Get

See Also

C1BindingSource Class
C1.C1Schedule Namespace


AllowRemove Property

[image]

.NET Framework Class Library
C1BindingSource..::..AllowRemove Property
C1BindingSource Class See Also
Gets a value indicating whether items can be removed from the underlying list.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual bool AllowRemove { get; }
Visual Basic
Public Overridable ReadOnly Property AllowRemove As Boolean
    Get

See Also

C1BindingSource Class
C1.C1Schedule Namespace


Count Property

[image]

.NET Framework Class Library
C1BindingSource..::..Count Property
C1BindingSource Class See Also
Gets the total number of items in the underlying list.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get

Implements

ICollection..::..Count

See Also

C1BindingSource Class
C1.C1Schedule Namespace


DataKeyNamesInternal Property

[image]

.NET Framework Class Library
C1BindingSource..::..DataKeyNamesInternal Property
C1BindingSource Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected internal virtual string[] DataKeyNamesInternal { get; set; }
Visual Basic
Protected Friend Overridable Property DataKeyNamesInternal As String()
    Get
    Set

See Also

C1BindingSource Class
C1.C1Schedule Namespace


DataMember Property

[image]

.NET Framework Class Library
C1BindingSource..::..DataMember Property
C1BindingSource Class See Also
Gets or sets the specific list in the data source to which the connector currently binds to.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute("")]
public string DataMember { get; set; }
Visual Basic
<DefaultValueAttribute("")> _
Public Property DataMember As String
    Get
    Set

See Also

C1BindingSource Class
C1.C1Schedule Namespace


DataSource Property

[image]

.NET Framework Class Library
C1BindingSource..::..DataSource Property
C1BindingSource Class See Also
Gets or sets the data source that the connector binds to.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(null)]
public Object DataSource { get; set; }
Visual Basic
<DefaultValueAttribute(Nothing)> _
Public Property DataSource As Object
    Get
    Set

See Also

C1BindingSource Class
C1.C1Schedule Namespace


IsFixedSize Property

[image]

.NET Framework Class Library
C1BindingSource..::..IsFixedSize Property
C1BindingSource Class See Also
Gets a value indicating whether the underlying list has a fixed size.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual bool IsFixedSize { get; }
Visual Basic
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get

Implements

IList..::..IsFixedSize

See Also

C1BindingSource Class
C1.C1Schedule Namespace


IsReadOnly Property

[image]

.NET Framework Class Library
C1BindingSource..::..IsReadOnly Property
C1BindingSource Class See Also
Gets a value indicating whether the underlying list is read-only.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get

Implements

IList..::..IsReadOnly

See Also

C1BindingSource Class
C1.C1Schedule Namespace


IsSynchronized Property

[image]

.NET Framework Class Library
C1BindingSource..::..IsSynchronized Property
C1BindingSource Class See Also
Gets a value indicating whether access to the collection is synchronized (thread safe).

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual bool IsSynchronized { get; }
Visual Basic
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get

Implements

ICollection..::..IsSynchronized

See Also

C1BindingSource Class
C1.C1Schedule Namespace


ISupportInitializeNotification.IsInitialized Property

[image]

.NET Framework Class Library
C1BindingSource..::..ISupportInitializeNotification..::..IsInitialized Property
C1BindingSource Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
bool ISupportInitializeNotification.IsInitialized { get; }
Visual Basic
Private ReadOnly Property IsInitialized As Boolean
    Implements ISupportInitializeNotification.IsInitialized
    Get

Implements

ISupportInitializeNotification..::..IsInitialized

See Also

C1BindingSource Class
C1.C1Schedule Namespace


Item Property

[image]

.NET Framework Class Library
C1BindingSource..::..Item Property
C1BindingSource Class See Also
Gets or sets the list element at the specified index.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual Object this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As Object
    Get
    Set

Parameters

index
Type: System..::..Int32
The zero-based index of the element to get or set.

Implements

IList..::..Item[([( Int32])])

See Also

C1BindingSource Class
C1.C1Schedule Namespace


List Property

[image]

.NET Framework Class Library
C1BindingSource..::..List Property
C1BindingSource Class See Also
Gets the list that the connector is bound to.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public IList List { get; }
Visual Basic
Public ReadOnly Property List As IList
    Get

See Also

C1BindingSource Class
C1.C1Schedule Namespace


SupportsChangeNotification Property

[image]

.NET Framework Class Library
C1BindingSource..::..SupportsChangeNotification Property
C1BindingSource Class See Also
Gets a value indicating whether the data source supports change notification.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual bool SupportsChangeNotification { get; }
Visual Basic
Public Overridable ReadOnly Property SupportsChangeNotification As Boolean
    Get

See Also

C1BindingSource Class
C1.C1Schedule Namespace


SyncRoot Property

[image]

.NET Framework Class Library
C1BindingSource..::..SyncRoot Property
C1BindingSource Class See Also
Gets an object that can be used to synchronize access to the underlying list.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual Object SyncRoot { get; }
Visual Basic
Public Overridable ReadOnly Property SyncRoot As Object
    Get

Implements

ICollection..::..SyncRoot

See Also

C1BindingSource Class
C1.C1Schedule Namespace


C1BindingSource Events

[image] [image]

.NET Framework Class Library
C1BindingSource Events
C1BindingSource Class See Also

The C1BindingSource type exposes the following members.

Events

 | Name | Description
Public event | AddingNew | Occurs before an item is added to the underlying list.
Public event | DataMemberChanged | Occurs when the DataMember property value has changed.
Public event | DataSourceChanged | Occurs when the DataSource property value has changed.
Public event | ListChanged | Occurs when the underlying list changes or an item in the list changes.

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitializeNotification..::..Initialized |

See Also

C1BindingSource Class
C1.C1Schedule Namespace


AddingNew Event

[image]

.NET Framework Class Library
C1BindingSource..::..AddingNew Event
C1BindingSource Class See Also
Occurs before an item is added to the underlying list.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event AddingNewEventHandler AddingNew
Visual Basic
Public Event AddingNew As AddingNewEventHandler

See Also

C1BindingSource Class
C1.C1Schedule Namespace


DataMemberChanged Event

[image]

.NET Framework Class Library
C1BindingSource..::..DataMemberChanged Event
C1BindingSource Class See Also
Occurs when the DataMember property value has changed.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event EventHandler DataMemberChanged
Visual Basic
Public Event DataMemberChanged As EventHandler

See Also

C1BindingSource Class
C1.C1Schedule Namespace


DataSourceChanged Event

[image]

.NET Framework Class Library
C1BindingSource..::..DataSourceChanged Event
C1BindingSource Class See Also
Occurs when the DataSource property value has changed.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event EventHandler DataSourceChanged
Visual Basic
Public Event DataSourceChanged As EventHandler

See Also

C1BindingSource Class
C1.C1Schedule Namespace


ISupportInitializeNotification.Initialized Event

[image]

.NET Framework Class Library
C1BindingSource..::..ISupportInitializeNotification..::..Initialized Event
C1BindingSource Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
event EventHandler ISupportInitializeNotification.Initialized
Visual Basic
Private Event Initialized As EventHandler Implements ISupportInitializeNotification.Initialized

Implements

ISupportInitializeNotification..::..Initialized

See Also

C1BindingSource Class
C1.C1Schedule Namespace


ListChanged Event

[image]

.NET Framework Class Library
C1BindingSource..::..ListChanged Event
C1BindingSource Class See Also
Occurs when the underlying list changes or an item in the list changes.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event ListChangedEventHandler ListChanged
Visual Basic
Public Event ListChanged As ListChangedEventHandler

See Also

C1BindingSource Class
C1.C1Schedule Namespace


C1Brush Class

[image]

.NET Framework Class Library
C1Brush Class
Members See Also
Wrapper class for brushes. Only for serialization/deserialization purposes.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class C1Brush
Visual Basic
Public Class C1Brush

Inheritance Hierarchy

System..::..Object
C1.C1Schedule..::..C1Brush

See Also

C1Brush Members
C1.C1Schedule Namespace


C1Brush Members

[image] [image]

.NET Framework Class Library
C1Brush Members
C1Brush Class Constructors Methods Properties See Also

The C1Brush type exposes the following members.

Constructors

 | Name | Description
Public method | C1Brush()()()() | Creates the new C1Brush object.
Public method | C1Brush(Color) | Creates a new solid C1Brush object.
Public method | C1Brush(Color, Color, C1BrushStyleEnum) | Creates the new C1Brush object.

Methods

 | Name | Description
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetARGBstring | Returns string representation of color in ARGB format.
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BackColor |
Public property | Brush |
Public property | ForeColor |
Public property | Style |

See Also

C1Brush Class
C1.C1Schedule Namespace


C1Brush Constructor

[image] [image]

.NET Framework Class Library
C1Brush Constructor
C1Brush Class See Also

Overload List

 | Name | Description
Public method | C1Brush()()()() | Creates the new C1Brush object.
Public method | C1Brush(Color) | Creates a new solid C1Brush object.
Public method | C1Brush(Color, Color, C1BrushStyleEnum) | Creates the new C1Brush object.

See Also

C1Brush Class
C1Brush Members
C1.C1Schedule Namespace


C1Brush Constructor

[image]

.NET Framework Class Library
C1Brush Constructor
C1Brush Class See Also
Creates the new C1Brush object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1Brush()
Visual Basic
Public Sub New

See Also

C1Brush Class
C1Brush Overload
C1.C1Schedule Namespace


C1Brush Constructor (Color)

[image]

.NET Framework Class Library
C1Brush Constructor (Color)
C1Brush Class See Also
Creates a new solid C1Brush object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1Brush(
    Color backColor
)
Visual Basic
Public Sub New ( _
    backColor As Color _
)

Parameters

backColor
Type: System.Windows.Media..::..Color
The background Color value.

See Also

C1Brush Class
C1Brush Overload
C1.C1Schedule Namespace


C1Brush Constructor (Color, Color, C1BrushStyleEnum)

[image]

.NET Framework Class Library
C1Brush Constructor (Color, Color, C1BrushStyleEnum)
C1Brush Class See Also
Creates the new C1Brush object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1Brush(
    Color foreColor,
    Color backColor,
    C1BrushStyleEnum style
)
Visual Basic
Public Sub New ( _
    foreColor As Color, _
    backColor As Color, _
    style As C1BrushStyleEnum _
)

Parameters

foreColor
Type: System.Windows.Media..::..Color
The foreground Color value.
backColor
Type: System.Windows.Media..::..Color
The background Color value.
style
Type: C1.C1Schedule..::..C1BrushStyleEnum
The C1BrushStyleEnum value.

See Also

C1Brush Class
C1Brush Overload
C1.C1Schedule Namespace


C1Brush Methods

[image] [image]

.NET Framework Class Library
C1Brush Methods
C1Brush Class See Also

The C1Brush type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetARGBstring | Returns string representation of color in ARGB format.
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1Brush Class
C1.C1Schedule Namespace


Equals Method

[image]

.NET Framework Class Library
C1Brush..::..Equals Method
C1Brush Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object

Return Value

See Also

C1Brush Class
C1.C1Schedule Namespace


GetARGBstring Method

[image]

.NET Framework Class Library
C1Brush..::..GetARGBstring Method
C1Brush Class See Also
Returns string representation of color in ARGB format.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string GetARGBstring(
    Color color
)
Visual Basic
Public Shared Function GetARGBstring ( _
    color As Color _
) As String

Parameters

color
Type: System.Windows.Media..::..Color
The Colorvalue.

Return Value

The string representation of color in ARGB format

See Also

C1Brush Class
C1.C1Schedule Namespace


GetHashCode Method

[image]

.NET Framework Class Library
C1Brush..::..GetHashCode Method
C1Brush Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

See Also

C1Brush Class
C1.C1Schedule Namespace


C1Brush Properties

[image] [image]

.NET Framework Class Library
C1Brush Properties
C1Brush Class See Also

The C1Brush type exposes the following members.

Properties

 | Name | Description
Public property | BackColor |
Public property | Brush |
Public property | ForeColor |
Public property | Style |

See Also

C1Brush Class
C1.C1Schedule Namespace


BackColor Property

[image]

.NET Framework Class Library
C1Brush..::..BackColor Property
C1Brush Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Color BackColor { get; set; }
Visual Basic
Public Property BackColor As Color
    Get
    Set

See Also

C1Brush Class
C1.C1Schedule Namespace


Brush Property

[image]

.NET Framework Class Library
C1Brush..::..Brush Property
C1Brush Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Brush Brush { get; }
Visual Basic
Public ReadOnly Property Brush As Brush
    Get

See Also

C1Brush Class
C1.C1Schedule Namespace


ForeColor Property

[image]

.NET Framework Class Library
C1Brush..::..ForeColor Property
C1Brush Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Color ForeColor { get; set; }
Visual Basic
Public Property ForeColor As Color
    Get
    Set

See Also

C1Brush Class
C1.C1Schedule Namespace


Style Property

[image]

.NET Framework Class Library
C1Brush..::..Style Property
C1Brush Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1BrushStyleEnum Style { get; set; }
Visual Basic
Public Property Style As C1BrushStyleEnum
    Get
    Set

See Also

C1Brush Class
C1.C1Schedule Namespace


C1BrushStyleEnum Enumeration

[image]

.NET Framework Class Library
C1BrushStyleEnum Enumeration
See Also
Specifies the different patterns available for brushes.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public enum C1BrushStyleEnum
Visual Basic
Public Enumeration C1BrushStyleEnum

Members

Member name | Description
Transparent | Represents transparent brush.
Solid | Represents solid brush.
BackwardDiagonal | A pattern of lines on a diagonal from upper right to lower left.
ForwardDiagonal | A pattern of lines on a diagonal from upper left to lower right.
Horizontal | A pattern of horizontal lines.
Vertical | A pattern of vertical lines.

See Also

C1.C1Schedule Namespace


C1ObservableCollection(T) Class

[image]

.NET Framework Class Library
C1ObservableCollection<(Of <(<'T>)>)> Class
Members See Also
The C1ObservableCollection<(Of <(<'T>)>)> is the base class for all Collection<(Of <(<'T>)>)> derived collections. Supports notification.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class C1ObservableCollection<T> : Collection<T>,
    INotifyCollectionChanged
Visual Basic
Public Class C1ObservableCollection(Of T) _
    Inherits Collection(Of T) _
    Implements INotifyCollectionChanged

Type Parameters

T
The type of objects to keep in collection.

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<'T>)>)>
C1.C1Schedule..::..C1ObservableCollection<(Of <(<'T>)>)>
C1.C1Schedule..::..ActionCollection
C1.C1Schedule..::..BaseList<(Of <(<'T>)>)>
C1.C1Schedule..::..ReminderCollection
C1.Silverlight.Schedule..::..CoverElementChunkCollection

See Also

C1ObservableCollection<(Of <(<'T>)>)> Members
C1.C1Schedule Namespace


C1ObservableCollection(T) Members

[image] [image]

.NET Framework Class Library
C1ObservableCollection<(Of <(<'T>)>)> Members
C1ObservableCollection<(Of <(<'T>)>)> Class Constructors Methods Properties Explicit Interface Implementations See Also

The C1ObservableCollection<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | C1ObservableCollection<(Of <(<'T>)>)>()()()() | Initializes a new instance of the C1ObservableCollection<(Of <(<'T>)>)> class.
Public method | C1ObservableCollection<(Of <(<'T>)>)>(IList<(Of <<'(T>)>>)) | Initializes a new instance of the C1ObservableCollection<(Of <(<'T>)>)> class.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected method | ClearItems | (Overrides Collection<(Of <(<'T>)>)>..::..ClearItems()()()().)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected method | InsertItem | (Overrides Collection<(Of <(<'T>)>)>..::..InsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged |
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected method | RemoveItem | (Overrides Collection<(Of <(<'T>)>)>..::..RemoveItem(Int32).)
Protected method | SetItem | (Overrides Collection<(Of <(<'T>)>)>..::..SetItem(Int32, T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged |
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' T >)>)>.)

See Also

C1ObservableCollection<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


C1ObservableCollection(T) Constructor

[image] [image]

.NET Framework Class Library
C1ObservableCollection<(Of <(<'T>)>)> Constructor
C1ObservableCollection<(Of <(<'T>)>)> Class See Also

Overload List

 | Name | Description
Public method | C1ObservableCollection<(Of <(<'T>)>)>()()()() | Initializes a new instance of the C1ObservableCollection<(Of <(<'T>)>)> class.
Public method | C1ObservableCollection<(Of <(<'T>)>)>(IList<(Of <<'(T>)>>)) | Initializes a new instance of the C1ObservableCollection<(Of <(<'T>)>)> class.

See Also

C1ObservableCollection<(Of <(<'T>)>)> Class
C1ObservableCollection<(Of <(<'T>)>)> Members
C1.C1Schedule Namespace


C1ObservableCollection(T) Constructor

[image]

.NET Framework Class Library
C1ObservableCollection<(Of <(<'T>)>)> Constructor
C1ObservableCollection<(Of <(<'T>)>)> Class See Also
Initializes a new instance of the C1ObservableCollection<(Of <(<'T>)>)> class.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1ObservableCollection()
Visual Basic
Public Sub New

See Also

C1ObservableCollection<(Of <(<'T>)>)> Class
C1ObservableCollection<(Of <(<'T>)>)> Overload
C1.C1Schedule Namespace


C1ObservableCollection(T) Constructor (IList(T))

[image]

.NET Framework Class Library
C1ObservableCollection<(Of <(<'T>)>)> Constructor (IList<(Of <(<'T>)>)>)
C1ObservableCollection<(Of <(<'T>)>)> Class See Also
Initializes a new instance of the C1ObservableCollection<(Of <(<'T>)>)> class.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1ObservableCollection(
    IList<T> list
)
Visual Basic
Public Sub New ( _
    list As IList(Of T) _
)

Parameters

list
Type: System.Collections.Generic..::..IList <(Of <(<' T >)>)>
The IList<(Of <(<'T>)>)> list that is wrapped by the new collection.

See Also

C1ObservableCollection<(Of <(<'T>)>)> Class
C1ObservableCollection<(Of <(<'T>)>)> Overload
C1.C1Schedule Namespace


C1ObservableCollection(T) Methods

[image] [image]

.NET Framework Class Library
C1ObservableCollection<(Of <(<'T>)>)> Methods
C1ObservableCollection<(Of <(<'T>)>)> Class See Also

The C1ObservableCollection<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected method | ClearItems | (Overrides Collection<(Of <(<'T>)>)>..::..ClearItems()()()().)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected method | InsertItem | (Overrides Collection<(Of <(<'T>)>)>..::..InsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged |
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected method | RemoveItem | (Overrides Collection<(Of <(<'T>)>)>..::..RemoveItem(Int32).)
Protected method | SetItem | (Overrides Collection<(Of <(<'T>)>)>..::..SetItem(Int32, T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' T >)>)>.)

See Also

C1ObservableCollection<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


ClearItems Method

[image]

.NET Framework Class Library
C1ObservableCollection<(Of <(<'T>)>)>..::..ClearItems Method
C1ObservableCollection<(Of <(<'T>)>)> Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void ClearItems()
Visual Basic
Protected Overrides Sub ClearItems

See Also

C1ObservableCollection<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


InsertItem Method

[image]

.NET Framework Class Library
C1ObservableCollection<(Of <(<'T>)>)>..::..InsertItem Method
C1ObservableCollection<(Of <(<'T>)>)> Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void InsertItem(
    int index,
    T item
)
Visual Basic
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As T _
)

Parameters

index
Type: System..::..Int32
item
Type: T

See Also

C1ObservableCollection<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


OnCollectionChanged Method

[image]

.NET Framework Class Library
C1ObservableCollection<(Of <(<'T>)>)>..::..OnCollectionChanged Method
C1ObservableCollection<(Of <(<'T>)>)> Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnCollectionChanged(
    NotifyCollectionChangedEventArgs e
)
Visual Basic
Protected Overridable Sub OnCollectionChanged ( _
    e As NotifyCollectionChangedEventArgs _
)

Parameters

e
Type: System.Collections.Specialized..::..NotifyCollectionChangedEventArgs

See Also

C1ObservableCollection<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


RemoveItem Method

[image]

.NET Framework Class Library
C1ObservableCollection<(Of <(<'T>)>)>..::..RemoveItem Method
C1ObservableCollection<(Of <(<'T>)>)> Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void RemoveItem(
    int index
)
Visual Basic
Protected Overrides Sub RemoveItem ( _
    index As Integer _
)

Parameters

index
Type: System..::..Int32

See Also

C1ObservableCollection<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


SetItem Method

[image]

.NET Framework Class Library
C1ObservableCollection<(Of <(<'T>)>)>..::..SetItem Method
C1ObservableCollection<(Of <(<'T>)>)> Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void SetItem(
    int index,
    T item
)
Visual Basic
Protected Overrides Sub SetItem ( _
    index As Integer, _
    item As T _
)

Parameters

index
Type: System..::..Int32
item
Type: T

See Also

C1ObservableCollection<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


C1ObservableCollection(T) Properties

[image] [image]

.NET Framework Class Library
C1ObservableCollection<(Of <(<'T>)>)> Properties
C1ObservableCollection<(Of <(<'T>)>)> Class See Also

The C1ObservableCollection<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' T >)>)>.)

See Also

C1ObservableCollection<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


C1ObservableCollection(T) Events

[image] [image]

.NET Framework Class Library
C1ObservableCollection<(Of <(<'T>)>)> Events
C1ObservableCollection<(Of <(<'T>)>)> Class See Also

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged |

See Also

C1ObservableCollection<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


INotifyCollectionChanged.CollectionChanged Event

[image]

.NET Framework Class Library
C1ObservableCollection<(Of <(<'T>)>)>..::..INotifyCollectionChanged..::..CollectionChanged Event
C1ObservableCollection<(Of <(<'T>)>)> Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
event NotifyCollectionChangedEventHandler INotifyCollectionChanged.CollectionChanged
Visual Basic
Private Event CollectionChanged As NotifyCollectionChangedEventHandler
    Implements INotifyCollectionChanged.CollectionChanged

Implements

INotifyCollectionChanged..::..CollectionChanged

See Also

C1ObservableCollection<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


C1ObservableKeyedCollection(TKey, TItem) Class

[image]

.NET Framework Class Library
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class
Members See Also
The C1ObservableCollection<(Of <(<'T>)>)> is the base class for all KeyedCollection<(Of <(<'TKey, TItem>)>)> derived collections. Supports notification.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public abstract class C1ObservableKeyedCollection<TKey, TItem> : KeyedCollection<TKey, TItem>,
    INotifyCollectionChanged
Visual Basic
Public MustInherit Class C1ObservableKeyedCollection(Of TKey, TItem) _
    Inherits KeyedCollection(Of TKey, TItem) _
    Implements INotifyCollectionChanged

Type Parameters

TKey
The type of keys in the collection.
TItem
The type of objects to keep in the collection.

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<'TItem>)>)>
System.Collections.ObjectModel..::..KeyedCollection <(Of <(<'TKey, TItem>)>)>
C1.C1Schedule..::..C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>
C1.C1Schedule..::..BaseCollection<(Of <(<'T>)>)>
C1.Silverlight.Schedule..::..CoveredElementsCollection
C1.Silverlight.Schedule..::..CoverElementCollection

See Also

C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Members
C1.C1Schedule Namespace


C1ObservableKeyedCollection(TKey, TItem) Members

[image] [image]

.NET Framework Class Library
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Members
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class Constructors Methods Properties Explicit Interface Implementations See Also

The C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>()()()() | Initializes a new instance of the C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> class.
Protected method | C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>(IEqualityComparer<(Of <<'(TKey>)>>)) | Initializes a new instance of the C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> class.
Protected method | C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>(IEqualityComparer<(Of <<'(TKey>)>>), Int32) |

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection <(Of <(<' TKey, TItem >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Protected method | ClearItems | (Overrides KeyedCollection<(Of <(<'TKey, TItem>)>)>..::..ClearItems()()()().)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' TKey, TItem >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TItem >)>)> Collection<(Of <(<'T>)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKeyForItem | When implemented in a derived class, extracts the key from the specified element. (Inherited from KeyedCollection <(Of <(<' TKey, TItem >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Protected method | InsertItem | (Overrides KeyedCollection<(Of <(<'TKey, TItem>)>)>..::..InsertItem(Int32, TItem).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged |
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' TKey, TItem >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TItem >)>)> Collection<(Of <(<'T>)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Protected method | RemoveItem | (Overrides KeyedCollection<(Of <(<'TKey, TItem>)>)>..::..RemoveItem(Int32).)
Protected method | SetItem | (Overrides KeyedCollection<(Of <(<'TKey, TItem>)>)>..::..SetItem(Int32, TItem).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection <(Of <(<' TKey, TItem >)>)>.)
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' TKey, TItem >)>)>.)
Public property | Item[([( TKey])]) | Gets the element with the specified key. (Inherited from KeyedCollection <(Of <(<' TKey, TItem >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' TItem >)>)> Collection<(Of <(<'T>)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TItem >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged |
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' TItem >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' TItem >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' TItem >)>)>.)

See Also

C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class
C1.C1Schedule Namespace


C1ObservableKeyedCollection(TKey, TItem) Constructor

[image] [image]

.NET Framework Class Library
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Constructor
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class See Also

Overload List

 | Name | Description
Protected method | C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>()()()() | Initializes a new instance of the C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> class.
Protected method | C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>(IEqualityComparer<(Of <<'(TKey>)>>)) | Initializes a new instance of the C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> class.
Protected method | C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>(IEqualityComparer<(Of <<'(TKey>)>>), Int32) |

See Also

C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Members
C1.C1Schedule Namespace


C1ObservableKeyedCollection(TKey, TItem) Constructor

[image]

.NET Framework Class Library
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Constructor
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class See Also
Initializes a new instance of the C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> class.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected C1ObservableKeyedCollection()
Visual Basic
Protected Sub New

See Also

C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Overload
C1.C1Schedule Namespace


C1ObservableKeyedCollection(TKey, TItem) Constructor (IEqualityComparer(TKey))

[image]

.NET Framework Class Library
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Constructor (IEqualityComparer<(Of <(<'TKey>)>)>)
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class See Also
Initializes a new instance of the C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> class.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected C1ObservableKeyedCollection(
    IEqualityComparer<TKey> comparer
)
Visual Basic
Protected Sub New ( _
    comparer As IEqualityComparer(Of TKey) _
)

Parameters

comparer
Type: System.Collections.Generic..::..IEqualityComparer <(Of <(<' TKey >)>)>
The implementation of the IEqualityComparer generic interface to use when comparing keys, or a null reference (Nothing in Visual Basic) to use the default equality comparer for the type of the key, obtained from EqualityComparer.Default.

See Also

C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Overload
C1.C1Schedule Namespace


C1ObservableKeyedCollection(TKey, TItem) Constructor (IEqualityComparer(TKey), Int32)

[image]

.NET Framework Class Library
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Constructor (IEqualityComparer<(Of <(<'TKey>)>)>, Int32)
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected C1ObservableKeyedCollection(
    IEqualityComparer<TKey> comparer,
    int dictionaryCreationThreshold
)
Visual Basic
Protected Sub New ( _
    comparer As IEqualityComparer(Of TKey), _
    dictionaryCreationThreshold As Integer _
)

Parameters

comparer
Type: System.Collections.Generic..::..IEqualityComparer <(Of <(<' TKey >)>)>
dictionaryCreationThreshold
Type: System..::..Int32

See Also

C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Overload
C1.C1Schedule Namespace


C1ObservableKeyedCollection(TKey, TItem) Methods

[image] [image]

.NET Framework Class Library
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Methods
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class See Also

The C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection <(Of <(<' TKey, TItem >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Protected method | ClearItems | (Overrides KeyedCollection<(Of <(<'TKey, TItem>)>)>..::..ClearItems()()()().)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' TKey, TItem >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TItem >)>)> Collection<(Of <(<'T>)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKeyForItem | When implemented in a derived class, extracts the key from the specified element. (Inherited from KeyedCollection <(Of <(<' TKey, TItem >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Protected method | InsertItem | (Overrides KeyedCollection<(Of <(<'TKey, TItem>)>)>..::..InsertItem(Int32, TItem).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged |
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' TKey, TItem >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TItem >)>)> Collection<(Of <(<'T>)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Protected method | RemoveItem | (Overrides KeyedCollection<(Of <(<'TKey, TItem>)>)>..::..RemoveItem(Int32).)
Protected method | SetItem | (Overrides KeyedCollection<(Of <(<'TKey, TItem>)>)>..::..SetItem(Int32, TItem).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' TItem >)>)>.)

See Also

C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class
C1.C1Schedule Namespace


ClearItems Method

[image]

.NET Framework Class Library
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>..::..ClearItems Method
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void ClearItems()
Visual Basic
Protected Overrides Sub ClearItems

See Also

C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class
C1.C1Schedule Namespace


Contains Method

[image] [image]

.NET Framework Class Library
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>..::..Contains Method
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class See Also

Overload List

 | Name | Description
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' TKey, TItem >)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TItem >)>)>.)

See Also

C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Members
C1.C1Schedule Namespace


InsertItem Method

[image]

.NET Framework Class Library
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>..::..InsertItem Method
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void InsertItem(
    int index,
    TItem item
)
Visual Basic
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As TItem _
)

Parameters

index
Type: System..::..Int32
item
Type: TItem

See Also

C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class
C1.C1Schedule Namespace


OnCollectionChanged Method

[image]

.NET Framework Class Library
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>..::..OnCollectionChanged Method
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnCollectionChanged(
    NotifyCollectionChangedEventArgs e
)
Visual Basic
Protected Overridable Sub OnCollectionChanged ( _
    e As NotifyCollectionChangedEventArgs _
)

Parameters

e
Type: System.Collections.Specialized..::..NotifyCollectionChangedEventArgs

See Also

C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class
C1.C1Schedule Namespace


Remove Method

[image] [image]

.NET Framework Class Library
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>..::..Remove Method
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class See Also

Overload List

 | Name | Description
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' TKey, TItem >)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TItem >)>)>.)

See Also

C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Members
C1.C1Schedule Namespace


RemoveItem Method

[image]

.NET Framework Class Library
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>..::..RemoveItem Method
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void RemoveItem(
    int index
)
Visual Basic
Protected Overrides Sub RemoveItem ( _
    index As Integer _
)

Parameters

index
Type: System..::..Int32

See Also

C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class
C1.C1Schedule Namespace


SetItem Method

[image]

.NET Framework Class Library
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>..::..SetItem Method
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void SetItem(
    int index,
    TItem item
)
Visual Basic
Protected Overrides Sub SetItem ( _
    index As Integer, _
    item As TItem _
)

Parameters

index
Type: System..::..Int32
item
Type: TItem

See Also

C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class
C1.C1Schedule Namespace


C1ObservableKeyedCollection(TKey, TItem) Properties

[image] [image]

.NET Framework Class Library
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Properties
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class See Also

The C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection <(Of <(<' TKey, TItem >)>)>.)
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' TKey, TItem >)>)>.)
Public property | Item[([( TKey])]) | Gets the element with the specified key. (Inherited from KeyedCollection <(Of <(<' TKey, TItem >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' TItem >)>)> Collection<(Of <(<'T>)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TItem >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' TItem >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' TItem >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' TItem >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' TItem >)>)>.)

See Also

C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class
C1.C1Schedule Namespace


Item Property

[image] [image]

.NET Framework Class Library
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>..::..Item Property
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class See Also

Overload List

 | Name | Description
Public property | Item[([( TKey])]) | Gets the element with the specified key. (Inherited from KeyedCollection <(Of <(<' TKey, TItem >)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' TItem >)>)>.)

See Also

C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Members
C1.C1Schedule Namespace


C1ObservableKeyedCollection(TKey, TItem) Events

[image] [image]

.NET Framework Class Library
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Events
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class See Also

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged |

See Also

C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class
C1.C1Schedule Namespace


INotifyCollectionChanged.CollectionChanged Event

[image]

.NET Framework Class Library
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>..::..INotifyCollectionChanged..::..CollectionChanged Event
C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
event NotifyCollectionChangedEventHandler INotifyCollectionChanged.CollectionChanged
Visual Basic
Private Event CollectionChanged As NotifyCollectionChangedEventHandler
    Implements INotifyCollectionChanged.CollectionChanged

Implements

INotifyCollectionChanged..::..CollectionChanged

See Also

C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)> Class
C1.C1Schedule Namespace


C1ScheduleStorage Class

[image]

.NET Framework Class Library
C1ScheduleStorage Class
Members See Also
The C1ScheduleStorage component handles all data operations for the scheduler control and contains specific data storages for appointments, resources, contacts, owners, labels and statuses, which are used for binding different collections to the data. The C1ScheduleStorage component also handles data importing and exporting to other scheduling formats such as binary, iCal, and XML.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class C1ScheduleStorage
Visual Basic
Public Class C1ScheduleStorage

Inheritance Hierarchy

System..::..Object
C1.C1Schedule..::..C1ScheduleStorage

See Also

C1ScheduleStorage Members
C1.C1Schedule Namespace


C1ScheduleStorage Members

[image] [image]

.NET Framework Class Library
C1ScheduleStorage Members
C1ScheduleStorage Class Methods Properties See Also

The C1ScheduleStorage type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Clears all unbound storages. Loads default sets if any for unbound storages.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Export(Stream, FileFormatEnum) | Exports the scheduler's data to a stream in the specified format.
Public method | Export(Stream, IList<(Of <<'(Appointment>)>>), FileFormatEnum) | Exports the appointments' data to a stream in the specified format.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Import | Imports the scheduler's data from a stream whose data is in the specified format.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Actions | Gets the ActionCollection object.
Public property | AppointmentStorage | Gets the AppointmentStorage object.
Public property | CategoryStorage | Gets the CategoryStorage object.
Public property | ContactStorage | Gets the ContactStorage object.
Public property | LabelStorage | Gets the LabelStorage object.
Public property | OwnerStorage | Gets the ContactStorage object used to keep contacts which might be used as appointment owners.
Public property | Reminders | Gets the ReminderCollection object.
Public property | ResourceStorage | Gets the ResourceStorage object.
Public property | Scheduler | Gets the reference to the parent C1Scheduler control.
Public property | StatusStorage | Gets the StatusStorage object.

See Also

C1ScheduleStorage Class
C1.C1Schedule Namespace


C1ScheduleStorage Methods

[image] [image]

.NET Framework Class Library
C1ScheduleStorage Methods
C1ScheduleStorage Class See Also

The C1ScheduleStorage type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Clears all unbound storages. Loads default sets if any for unbound storages.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Export(Stream, FileFormatEnum) | Exports the scheduler's data to a stream in the specified format.
Public method | Export(Stream, IList<(Of <<'(Appointment>)>>), FileFormatEnum) | Exports the appointments' data to a stream in the specified format.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Import | Imports the scheduler's data from a stream whose data is in the specified format.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1ScheduleStorage Class
C1.C1Schedule Namespace


Clear Method

[image]

.NET Framework Class Library
C1ScheduleStorage..::..Clear Method
C1ScheduleStorage Class See Also
Clears all unbound storages. Loads default sets if any for unbound storages.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear

See Also

C1ScheduleStorage Class
C1.C1Schedule Namespace


Export Method

[image] [image]

.NET Framework Class Library
C1ScheduleStorage..::..Export Method
C1ScheduleStorage Class See Also

Overload List

 | Name | Description
Public method | Export(Stream, FileFormatEnum) | Exports the scheduler's data to a stream in the specified format.
Public method | Export(Stream, IList<(Of <<'(Appointment>)>>), FileFormatEnum) | Exports the appointments' data to a stream in the specified format.

See Also

C1ScheduleStorage Class
C1ScheduleStorage Members
C1.C1Schedule Namespace


Export Method (Stream, FileFormatEnum)

[image]

.NET Framework Class Library
C1ScheduleStorage..::..Export Method (Stream, FileFormatEnum)
C1ScheduleStorage Class See Also
Exports the scheduler's data to a stream in the specified format.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void Export(
    Stream stream,
    FileFormatEnum format
)
Visual Basic
Public Sub Export ( _
    stream As Stream, _
    format As FileFormatEnum _
)

Parameters

stream
Type: System.IO..::..Stream
A Stream object which specifies the stream into which the scheduler's data will be exported.
format
Type: C1.C1Schedule..::..FileFormatEnum
The FileFormatEnum value.

See Also

C1ScheduleStorage Class
Export Overload
C1.C1Schedule Namespace


Export Method (Stream, IList(Appointment), FileFormatEnum)

[image]

.NET Framework Class Library
C1ScheduleStorage..::..Export Method (Stream, IList<(Of <(<'Appointment>)>)>, FileFormatEnum)
C1ScheduleStorage Class See Also
Exports the appointments' data to a stream in the specified format.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void Export(
    Stream stream,
    IList<Appointment> appointments,
    FileFormatEnum format
)
Visual Basic
Public Sub Export ( _
    stream As Stream, _
    appointments As IList(Of Appointment), _
    format As FileFormatEnum _
)

Parameters

stream
Type: System.IO..::..Stream
A Stream object which specifies the stream into which the appointments's data will be exported.
appointments
Type: System.Collections.Generic..::..IList <(Of <(<' Appointment >)>)>
IList<(Of <(<'T>)>)> to be exported.
format
Type: C1.C1Schedule..::..FileFormatEnum
The FileFormatEnum value.

See Also

C1ScheduleStorage Class
Export Overload
C1.C1Schedule Namespace


Import Method

[image]

.NET Framework Class Library
C1ScheduleStorage..::..Import Method
C1ScheduleStorage Class See Also
Imports the scheduler's data from a stream whose data is in the specified format.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void Import(
    Stream stream,
    FileFormatEnum format
)
Visual Basic
Public Sub Import ( _
    stream As Stream, _
    format As FileFormatEnum _
)

Parameters

stream
Type: System.IO..::..Stream
A Stream object which specifies the stream that contains the data to import to the scheduler.
format
Type: C1.C1Schedule..::..FileFormatEnum
The FileFormatEnum value.

See Also

C1ScheduleStorage Class
C1.C1Schedule Namespace


C1ScheduleStorage Properties

[image] [image]

.NET Framework Class Library
C1ScheduleStorage Properties
C1ScheduleStorage Class See Also

The C1ScheduleStorage type exposes the following members.

Properties

 | Name | Description
Public property | Actions | Gets the ActionCollection object.
Public property | AppointmentStorage | Gets the AppointmentStorage object.
Public property | CategoryStorage | Gets the CategoryStorage object.
Public property | ContactStorage | Gets the ContactStorage object.
Public property | LabelStorage | Gets the LabelStorage object.
Public property | OwnerStorage | Gets the ContactStorage object used to keep contacts which might be used as appointment owners.
Public property | Reminders | Gets the ReminderCollection object.
Public property | ResourceStorage | Gets the ResourceStorage object.
Public property | Scheduler | Gets the reference to the parent C1Scheduler control.
Public property | StatusStorage | Gets the StatusStorage object.

See Also

C1ScheduleStorage Class
C1.C1Schedule Namespace


Actions Property

[image]

.NET Framework Class Library
C1ScheduleStorage..::..Actions Property
C1ScheduleStorage Class See Also
Gets the ActionCollection object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ActionCollection Actions { get; }
Visual Basic
Public ReadOnly Property Actions As ActionCollection
    Get

See Also

C1ScheduleStorage Class
C1.C1Schedule Namespace


AppointmentStorage Property

[image]

.NET Framework Class Library
C1ScheduleStorage..::..AppointmentStorage Property
C1ScheduleStorage Class See Also
Gets the AppointmentStorage object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public AppointmentStorage AppointmentStorage { get; }
Visual Basic
Public ReadOnly Property AppointmentStorage As AppointmentStorage
    Get

See Also

C1ScheduleStorage Class
C1.C1Schedule Namespace


CategoryStorage Property

[image]

.NET Framework Class Library
C1ScheduleStorage..::..CategoryStorage Property
C1ScheduleStorage Class See Also
Gets the CategoryStorage object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public CategoryStorage CategoryStorage { get; }
Visual Basic
Public ReadOnly Property CategoryStorage As CategoryStorage
    Get

See Also

C1ScheduleStorage Class
C1.C1Schedule Namespace


ContactStorage Property

[image]

.NET Framework Class Library
C1ScheduleStorage..::..ContactStorage Property
C1ScheduleStorage Class See Also
Gets the ContactStorage object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ContactStorage ContactStorage { get; }
Visual Basic
Public ReadOnly Property ContactStorage As ContactStorage
    Get

See Also

C1ScheduleStorage Class
C1.C1Schedule Namespace


LabelStorage Property

[image]

.NET Framework Class Library
C1ScheduleStorage..::..LabelStorage Property
C1ScheduleStorage Class See Also
Gets the LabelStorage object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public LabelStorage LabelStorage { get; }
Visual Basic
Public ReadOnly Property LabelStorage As LabelStorage
    Get

See Also

C1ScheduleStorage Class
C1.C1Schedule Namespace


OwnerStorage Property

[image]

.NET Framework Class Library
C1ScheduleStorage..::..OwnerStorage Property
C1ScheduleStorage Class See Also
Gets the ContactStorage object used to keep contacts which might be used as appointment owners.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ContactStorage OwnerStorage { get; }
Visual Basic
Public ReadOnly Property OwnerStorage As ContactStorage
    Get

Remarks

Owner property only accepts Contact objects which are present in this storage.

See Also

C1ScheduleStorage Class
C1.C1Schedule Namespace


Reminders Property

[image]

.NET Framework Class Library
C1ScheduleStorage..::..Reminders Property
C1ScheduleStorage Class See Also
Gets the ReminderCollection object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ReminderCollection Reminders { get; }
Visual Basic
Public ReadOnly Property Reminders As ReminderCollection
    Get

See Also

C1ScheduleStorage Class
C1.C1Schedule Namespace


ResourceStorage Property

[image]

.NET Framework Class Library
C1ScheduleStorage..::..ResourceStorage Property
C1ScheduleStorage Class See Also
Gets the ResourceStorage object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ResourceStorage ResourceStorage { get; }
Visual Basic
Public ReadOnly Property ResourceStorage As ResourceStorage
    Get

See Also

C1ScheduleStorage Class
C1.C1Schedule Namespace


Scheduler Property

[image]

.NET Framework Class Library
C1ScheduleStorage..::..Scheduler Property
C1ScheduleStorage Class See Also
Gets the reference to the parent C1Scheduler control.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1Scheduler Scheduler { get; }
Visual Basic
Public ReadOnly Property Scheduler As C1Scheduler
    Get

See Also

C1ScheduleStorage Class
C1.C1Schedule Namespace


StatusStorage Property

[image]

.NET Framework Class Library
C1ScheduleStorage..::..StatusStorage Property
C1ScheduleStorage Class See Also
Gets the StatusStorage object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public StatusStorage StatusStorage { get; }
Visual Basic
Public ReadOnly Property StatusStorage As StatusStorage
    Get

See Also

C1ScheduleStorage Class
C1.C1Schedule Namespace


CalendarInfo Class

[image]

.NET Framework Class Library
CalendarInfo Class
Members See Also
The CalendarInfo class manages and exposes all date-related data to C1Schedule controls.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class CalendarInfo : INotifyPropertyChanged
Visual Basic
Public Class CalendarInfo _
    Implements INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
C1.C1Schedule..::..CalendarInfo

See Also

CalendarInfo Members
C1.C1Schedule Namespace


CalendarInfo Members

[image] [image]

.NET Framework Class Library
CalendarInfo Members
CalendarInfo Class Methods Properties Events See Also

The CalendarInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ShouldSerializeFirstDate |
Protected method | ShouldSerializeLastDate |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
 | Culture | Gets or sets the CultureInfo object which holds culture-specific information used by C1Schedule components.
Public property | CultureInfo | Gets or sets the CultureInfo object which holds culture-specific information used by C1Schedule components.
Public property | DateFormatString | Gets or sets the String value determining display format of date values to use in appointments and built-in dialogs.
Public property | DateTimeKind | Gets or sets DateTimeKind specifying DateTime kind used for saving DateTime values.
Public property | EndDayTime | Gets or sets the TimeSpan value specifying the end of the working time.
Public property | FirstDate | Gets or sets the DateTime value specifying minimum date allowed.
Public property | Holidays | Gets the List<(Of <(<'T>)>)> object which holds the list of holidays (non-working days in addition to weekends).
Public property | LastDate | Gets or sets the DateTime value specifying maximum date allowed.
Public property | NoWorkingDays | Gets or sets the Boolean value determining whether the CalendarInfo object has any working days.
Public property | StartDayTime | Gets or sets the TimeSpan value specifying the beginning of the working time.
Public property | TimeFormatString | Gets or sets the String value determining display format of time values to use in appointments and built-in dialogs.
Public property | TimeInterval | Gets or sets the TimeScaleEnum value specifying the time interval which is used for displaying time slots in the DayView.
Public property | TimeScale | Gets or sets the TimeSpan value specifying the time interval which is used for displaying time slots in the DayView.
Public property | WeekendExceptions | Gets the List<(Of <(<'T>)>)> object which holds the list of weekend days which should be working.
Public property | WeekStart | Gets or sets the DayOfWeek value determining the first day of the week. Default is system settings.
Public property | WorkDays | Gets or sets the WorkDays object containing the set of working days in one week.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when the property of CalendarInfo object was changed.
Public event | SelectedDaysChanged | Occurs when the range of selected days was changed.

See Also

CalendarInfo Class
C1.C1Schedule Namespace


CalendarInfo Methods

[image] [image]

.NET Framework Class Library
CalendarInfo Methods
CalendarInfo Class See Also

The CalendarInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ShouldSerializeFirstDate |
Protected method | ShouldSerializeLastDate |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CalendarInfo Class
C1.C1Schedule Namespace


ShouldSerializeFirstDate Method

[image]

.NET Framework Class Library
CalendarInfo..::..ShouldSerializeFirstDate Method
CalendarInfo Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected internal bool ShouldSerializeFirstDate()
Visual Basic
Protected Friend Function ShouldSerializeFirstDate As Boolean

See Also

CalendarInfo Class
C1.C1Schedule Namespace


ShouldSerializeLastDate Method

[image]

.NET Framework Class Library
CalendarInfo..::..ShouldSerializeLastDate Method
CalendarInfo Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected internal bool ShouldSerializeLastDate()
Visual Basic
Protected Friend Function ShouldSerializeLastDate As Boolean

See Also

CalendarInfo Class
C1.C1Schedule Namespace


CalendarInfo Properties

[image] [image]

.NET Framework Class Library
CalendarInfo Properties
CalendarInfo Class See Also

The CalendarInfo type exposes the following members.

Properties

 | Name | Description
 | Culture | Gets or sets the CultureInfo object which holds culture-specific information used by C1Schedule components.
Public property | CultureInfo | Gets or sets the CultureInfo object which holds culture-specific information used by C1Schedule components.
Public property | DateFormatString | Gets or sets the String value determining display format of date values to use in appointments and built-in dialogs.
Public property | DateTimeKind | Gets or sets DateTimeKind specifying DateTime kind used for saving DateTime values.
Public property | EndDayTime | Gets or sets the TimeSpan value specifying the end of the working time.
Public property | FirstDate | Gets or sets the DateTime value specifying minimum date allowed.
Public property | Holidays | Gets the List<(Of <(<'T>)>)> object which holds the list of holidays (non-working days in addition to weekends).
Public property | LastDate | Gets or sets the DateTime value specifying maximum date allowed.
Public property | NoWorkingDays | Gets or sets the Boolean value determining whether the CalendarInfo object has any working days.
Public property | StartDayTime | Gets or sets the TimeSpan value specifying the beginning of the working time.
Public property | TimeFormatString | Gets or sets the String value determining display format of time values to use in appointments and built-in dialogs.
Public property | TimeInterval | Gets or sets the TimeScaleEnum value specifying the time interval which is used for displaying time slots in the DayView.
Public property | TimeScale | Gets or sets the TimeSpan value specifying the time interval which is used for displaying time slots in the DayView.
Public property | WeekendExceptions | Gets the List<(Of <(<'T>)>)> object which holds the list of weekend days which should be working.
Public property | WeekStart | Gets or sets the DayOfWeek value determining the first day of the week. Default is system settings.
Public property | WorkDays | Gets or sets the WorkDays object containing the set of working days in one week.

See Also

CalendarInfo Class
C1.C1Schedule Namespace


Culture Property

[image]

.NET Framework Class Library
CalendarInfo..::..Culture Property
CalendarInfo Class See Also
Gets or sets the CultureInfo object which holds culture-specific information used by C1Schedule components.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static CultureInfo Culture { get; set; }
Visual Basic
Public Shared Property Culture As CultureInfo
    Get
    Set

See Also

CalendarInfo Class
C1.C1Schedule Namespace


CultureInfo Property

[image]

.NET Framework Class Library
CalendarInfo..::..CultureInfo Property
CalendarInfo Class See Also
Gets or sets the CultureInfo object which holds culture-specific information used by C1Schedule components.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(typeof(CultureInfo), "")]
public CultureInfo CultureInfo { get; set; }
Visual Basic
<DefaultValueAttribute(GetType(CultureInfo), "")> _
Public Property CultureInfo As CultureInfo
    Get
    Set

See Also

CalendarInfo Class
C1.C1Schedule Namespace


DateFormatString Property

[image]

.NET Framework Class Library
CalendarInfo..::..DateFormatString Property
CalendarInfo Class See Also
Gets or sets the String value determining display format of date values to use in appointments and built-in dialogs.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute("d")]
public string DateFormatString { get; set; }
Visual Basic
<DefaultValueAttribute("d")> _
Public Property DateFormatString As String
    Get
    Set

Remarks

The actual representation depends on the value of the Culture property.

See Also

CalendarInfo Class
C1.C1Schedule Namespace


DateTimeKind Property

[image]

.NET Framework Class Library
CalendarInfo..::..DateTimeKind Property
CalendarInfo Class See Also
Gets or sets DateTimeKind specifying DateTime kind used for saving DateTime values.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(DateTimeKind.Unspecified)]
public DateTimeKind DateTimeKind { get; set; }
Visual Basic
<DefaultValueAttribute(DateTimeKind.Unspecified)> _
Public Property DateTimeKind As DateTimeKind
    Get
    Set

Remarks

This property only have an influence on the process of saving data to the AppointmentStorage.DataSource object and on export operations. All properties of the Appointment and RecurrencePattern objects represent current system local time values. Set this property to DateTimeLind.Utc if you need to save data with universal time. In such case the data will be converted to the local time and back at every read/write operation.

See Also

CalendarInfo Class
C1.C1Schedule Namespace


EndDayTime Property

[image]

.NET Framework Class Library
CalendarInfo..::..EndDayTime Property
CalendarInfo Class See Also
Gets or sets the TimeSpan value specifying the end of the working time.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public TimeSpan EndDayTime { get; set; }
Visual Basic
Public Property EndDayTime As TimeSpan
    Get
    Set

See Also

CalendarInfo Class
C1.C1Schedule Namespace


FirstDate Property

[image]

.NET Framework Class Library
CalendarInfo..::..FirstDate Property
CalendarInfo Class See Also
Gets or sets the DateTime value specifying minimum date allowed.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTime FirstDate { get; set; }
Visual Basic
Public Property FirstDate As DateTime
    Get
    Set

See Also

CalendarInfo Class
C1.C1Schedule Namespace


Holidays Property

[image]

.NET Framework Class Library
CalendarInfo..::..Holidays Property
CalendarInfo Class See Also
Gets the List<(Of <(<'T>)>)> object which holds the list of holidays (non-working days in addition to weekends).

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public List<DateTime> Holidays { get; }
Visual Basic
Public ReadOnly Property Holidays As List(Of DateTime)
    Get

See Also

CalendarInfo Class
C1.C1Schedule Namespace


LastDate Property

[image]

.NET Framework Class Library
CalendarInfo..::..LastDate Property
CalendarInfo Class See Also
Gets or sets the DateTime value specifying maximum date allowed.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTime LastDate { get; set; }
Visual Basic
Public Property LastDate As DateTime
    Get
    Set

See Also

CalendarInfo Class
C1.C1Schedule Namespace


NoWorkingDays Property

[image]

.NET Framework Class Library
CalendarInfo..::..NoWorkingDays Property
CalendarInfo Class See Also
Gets or sets the Boolean value determining whether the CalendarInfo object has any working days.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public bool NoWorkingDays { get; set; }
Visual Basic
<DefaultValueAttribute(False)> _
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Property NoWorkingDays As Boolean
    Get
    Set

See Also

CalendarInfo Class
C1.C1Schedule Namespace


StartDayTime Property

[image]

.NET Framework Class Library
CalendarInfo..::..StartDayTime Property
CalendarInfo Class See Also
Gets or sets the TimeSpan value specifying the beginning of the working time.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public TimeSpan StartDayTime { get; set; }
Visual Basic
Public Property StartDayTime As TimeSpan
    Get
    Set

See Also

CalendarInfo Class
C1.C1Schedule Namespace


TimeFormatString Property

[image]

.NET Framework Class Library
CalendarInfo..::..TimeFormatString Property
CalendarInfo Class See Also
Gets or sets the String value determining display format of time values to use in appointments and built-in dialogs.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute("t")]
public string TimeFormatString { get; set; }
Visual Basic
<DefaultValueAttribute("t")> _
Public Property TimeFormatString As String
    Get
    Set

Remarks

The actual representation depends on the value of the Culture property.

See Also

CalendarInfo Class
C1.C1Schedule Namespace


TimeInterval Property

[image]

.NET Framework Class Library
CalendarInfo..::..TimeInterval Property
CalendarInfo Class See Also
Gets or sets the TimeScaleEnum value specifying the time interval which is used for displaying time slots in the DayView.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(TimeScaleEnum.ThirtyMinutes)]
public TimeScaleEnum TimeInterval { get; set; }
Visual Basic
<DefaultValueAttribute(TimeScaleEnum.ThirtyMinutes)> _
Public Property TimeInterval As TimeScaleEnum
    Get
    Set

See Also

CalendarInfo Class
C1.C1Schedule Namespace


TimeScale Property

[image]

.NET Framework Class Library
CalendarInfo..::..TimeScale Property
CalendarInfo Class See Also
Gets or sets the TimeSpan value specifying the time interval which is used for displaying time slots in the DayView.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public TimeSpan TimeScale { get; set; }
Visual Basic
Public Property TimeScale As TimeSpan
    Get
    Set

Remarks

The TimeScale property cannot be set to any arbitrary value. When assigning a value to this property it is automatically calculated so as to be equal to the nearest TimeScaleEnum value.

See Also

CalendarInfo Class
C1.C1Schedule Namespace


WeekendExceptions Property

[image]

.NET Framework Class Library
CalendarInfo..::..WeekendExceptions Property
CalendarInfo Class See Also
Gets the List<(Of <(<'T>)>)> object which holds the list of weekend days which should be working.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public List<DateTime> WeekendExceptions { get; }
Visual Basic
Public ReadOnly Property WeekendExceptions As List(Of DateTime)
    Get

See Also

CalendarInfo Class
C1.C1Schedule Namespace


WeekStart Property

[image]

.NET Framework Class Library
CalendarInfo..::..WeekStart Property
CalendarInfo Class See Also
Gets or sets the DayOfWeek value determining the first day of the week. Default is system settings.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DayOfWeek WeekStart { get; set; }
Visual Basic
Public Property WeekStart As DayOfWeek
    Get
    Set

See Also

CalendarInfo Class
C1.C1Schedule Namespace


WorkDays Property

[image]

.NET Framework Class Library
CalendarInfo..::..WorkDays Property
CalendarInfo Class See Also
Gets or sets the WorkDays object containing the set of working days in one week.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public WorkDays WorkDays { get; set; }
Visual Basic
Public Property WorkDays As WorkDays
    Get
    Set

See Also

CalendarInfo Class
C1.C1Schedule Namespace


CalendarInfo Events

[image] [image]

.NET Framework Class Library
CalendarInfo Events
CalendarInfo Class See Also

The CalendarInfo type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when the property of CalendarInfo object was changed.
Public event | SelectedDaysChanged | Occurs when the range of selected days was changed.

See Also

CalendarInfo Class
C1.C1Schedule Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
CalendarInfo..::..PropertyChanged Event
CalendarInfo Class See Also
Occurs when the property of CalendarInfo object was changed.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

CalendarInfo Class
C1.C1Schedule Namespace


SelectedDaysChanged Event

[image]

.NET Framework Class Library
CalendarInfo..::..SelectedDaysChanged Event
CalendarInfo Class See Also
Occurs when the range of selected days was changed.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event EventHandler SelectedDaysChanged
Visual Basic
Public Event SelectedDaysChanged As EventHandler

See Also

CalendarInfo Class
C1.C1Schedule Namespace


CancelAppointmentEventArgs Class

[image]

.NET Framework Class Library
CancelAppointmentEventArgs Class
Members See Also
The CancelAppointmentEventArgs class describes event data for Appointment events.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class CancelAppointmentEventArgs : EventArgs
Visual Basic
Public Class CancelAppointmentEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
C1.C1Schedule..::..CancelAppointmentEventArgs

See Also

CancelAppointmentEventArgs Members
C1.C1Schedule Namespace


CancelAppointmentEventArgs Members

[image] [image]

.NET Framework Class Library
CancelAppointmentEventArgs Members
CancelAppointmentEventArgs Class Constructors Methods Properties See Also

The CancelAppointmentEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | CancelAppointmentEventArgs | Initializes a new instance of the CancelAppointmentEventArgs class with the specified appointment.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Appointment | Gets the Appointment object which the event was raised for.
Public property | Cancel | Set to true to cancel the operation.

See Also

CancelAppointmentEventArgs Class
C1.C1Schedule Namespace


CancelAppointmentEventArgs Constructor

[image]

.NET Framework Class Library
CancelAppointmentEventArgs Constructor
CancelAppointmentEventArgs Class See Also
Initializes a new instance of the CancelAppointmentEventArgs class with the specified appointment.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public CancelAppointmentEventArgs(
    Appointment appointment
)
Visual Basic
Public Sub New ( _
    appointment As Appointment _
)

Parameters

appointment
Type: C1.C1Schedule..::..Appointment
The Appointment object.

See Also

CancelAppointmentEventArgs Class
C1.C1Schedule Namespace


CancelAppointmentEventArgs Methods

[image] [image]

.NET Framework Class Library
CancelAppointmentEventArgs Methods
CancelAppointmentEventArgs Class See Also

The CancelAppointmentEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CancelAppointmentEventArgs Class
C1.C1Schedule Namespace


CancelAppointmentEventArgs Properties

[image] [image]

.NET Framework Class Library
CancelAppointmentEventArgs Properties
CancelAppointmentEventArgs Class See Also

The CancelAppointmentEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Appointment | Gets the Appointment object which the event was raised for.
Public property | Cancel | Set to true to cancel the operation.

See Also

CancelAppointmentEventArgs Class
C1.C1Schedule Namespace


Appointment Property

[image]

.NET Framework Class Library
CancelAppointmentEventArgs..::..Appointment Property
CancelAppointmentEventArgs Class See Also
Gets the Appointment object which the event was raised for.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Appointment Appointment { get; }
Visual Basic
Public ReadOnly Property Appointment As Appointment
    Get

See Also

CancelAppointmentEventArgs Class
C1.C1Schedule Namespace


Cancel Property

[image]

.NET Framework Class Library
CancelAppointmentEventArgs..::..Cancel Property
CancelAppointmentEventArgs Class See Also
Set to true to cancel the operation.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool Cancel { get; set; }
Visual Basic
Public Property Cancel As Boolean
    Get
    Set

See Also

CancelAppointmentEventArgs Class
C1.C1Schedule Namespace


CancelAppointmentEventHandler Delegate

[image]

.NET Framework Class Library
CancelAppointmentEventHandler Delegate
See Also
Delegate for handling the cancelable event involving a single Appointment object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public delegate void CancelAppointmentEventHandler(
    Object sender,
    CancelAppointmentEventArgs e
)
Visual Basic
Public Delegate Sub CancelAppointmentEventHandler ( _
    sender As Object, _
    e As CancelAppointmentEventArgs _
)

Parameters

sender
Type: System..::..Object
The source of the event.
e
Type: C1.C1Schedule..::..CancelAppointmentEventArgs
The CancelAppointmentEventArgs that contains the event data.

See Also

C1.C1Schedule Namespace


CancelReminderEventArgs Class

[image]

.NET Framework Class Library
CancelReminderEventArgs Class
Members See Also
Describes event data for cancelable Reminder events.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class CancelReminderEventArgs : EventArgs
Visual Basic
Public Class CancelReminderEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
C1.C1Schedule..::..CancelReminderEventArgs

See Also

CancelReminderEventArgs Members
C1.C1Schedule Namespace


CancelReminderEventArgs Members

[image] [image]

.NET Framework Class Library
CancelReminderEventArgs Members
CancelReminderEventArgs Class Constructors Methods Properties See Also

The CancelReminderEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | CancelReminderEventArgs | Initializes a new instance of the CancelReminderEventArgs class with the specified Reminder object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Set to true to cancel the operation.
Public property | Reminder | Gets the reminder which the event was raised for.

See Also

CancelReminderEventArgs Class
C1.C1Schedule Namespace


CancelReminderEventArgs Constructor

[image]

.NET Framework Class Library
CancelReminderEventArgs Constructor
CancelReminderEventArgs Class See Also
Initializes a new instance of the CancelReminderEventArgs class with the specified Reminder object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public CancelReminderEventArgs(
    Reminder reminder
)
Visual Basic
Public Sub New ( _
    reminder As Reminder _
)

Parameters

reminder
Type: C1.C1Schedule..::..Reminder
The Reminder object.

See Also

CancelReminderEventArgs Class
C1.C1Schedule Namespace


CancelReminderEventArgs Methods

[image] [image]

.NET Framework Class Library
CancelReminderEventArgs Methods
CancelReminderEventArgs Class See Also

The CancelReminderEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CancelReminderEventArgs Class
C1.C1Schedule Namespace


CancelReminderEventArgs Properties

[image] [image]

.NET Framework Class Library
CancelReminderEventArgs Properties
CancelReminderEventArgs Class See Also

The CancelReminderEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Set to true to cancel the operation.
Public property | Reminder | Gets the reminder which the event was raised for.

See Also

CancelReminderEventArgs Class
C1.C1Schedule Namespace


Cancel Property

[image]

.NET Framework Class Library
CancelReminderEventArgs..::..Cancel Property
CancelReminderEventArgs Class See Also
Set to true to cancel the operation.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool Cancel { get; set; }
Visual Basic
Public Property Cancel As Boolean
    Get
    Set

See Also

CancelReminderEventArgs Class
C1.C1Schedule Namespace


Reminder Property

[image]

.NET Framework Class Library
CancelReminderEventArgs..::..Reminder Property
CancelReminderEventArgs Class See Also
Gets the reminder which the event was raised for.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Reminder Reminder { get; }
Visual Basic
Public ReadOnly Property Reminder As Reminder
    Get

See Also

CancelReminderEventArgs Class
C1.C1Schedule Namespace


CancelReminderEventHandler Delegate

[image]

.NET Framework Class Library
CancelReminderEventHandler Delegate
See Also
Delegate for handling the cancelable event involving a single Reminder object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public delegate void CancelReminderEventHandler(
    Object sender,
    CancelReminderEventArgs e
)
Visual Basic
Public Delegate Sub CancelReminderEventHandler ( _
    sender As Object, _
    e As CancelReminderEventArgs _
)

Parameters

sender
Type: System..::..Object
The source of the event.
e
Type: C1.C1Schedule..::..CancelReminderEventArgs
The CancelReminderEventArgs that contains the event data.

See Also

C1.C1Schedule Namespace


Category Class

[image]

.NET Framework Class Library
Category Class
Members See Also
The Category class represents the category which can be associated with the Appointment object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class Category : BaseObject
Visual Basic
Public Class Category _
    Inherits BaseObject

Inheritance Hierarchy

System..::..Object
C1.C1Schedule..::..BasePersistableObject
C1.C1Schedule..::..BaseObject
C1.C1Schedule..::..Category

See Also

Category Members
C1.C1Schedule Namespace


Category Members

[image] [image]

.NET Framework Class Library
Category Members
Category Class Constructors Methods Properties Explicit Interface Implementations See Also

The Category type exposes the following members.

Constructors

 | Name | Description
Public method | Category()()()() | Creates the new Category object.
Public method | Category(Guid) | Initializes a new instance of the Category class with the specified key.
Public method | Category(Int32) | Initializes a new instance of the Category class with the specified key.
Public method | Category(String) | Creates custom Category object with specified text.

Methods

 | Name | Description
Public method | BeginEdit | Brings the object in edit mode. (Inherited from BasePersistableObject.)
Protected method | BeginEditInternal | (Inherited from BasePersistableObject.)
Public method | CancelEdit | Discards changes since the last BeginEdit()()()() call. (Inherited from BasePersistableObject.)
Public method | EndEdit()()()() | Finishes edit mode started by the BeginEdit()()()() method and updates a corresponding data source item. (Inherited from BasePersistableObject.)
Protected method | EndEdit(Boolean) | (Inherited from BasePersistableObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromXml(XmlReader) | Loads an object from the specified XmlReader. (Inherited from BaseObject.)
Public method | FromXml(Stream) | Loads an object from the specified Stream. (Inherited from BasePersistableObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Overrides the default behavior. (Inherited from BasePersistableObject.)
Public method | ToString | Overrides the default behavior. (Inherited from BaseObject.)
Public method | ToXml(XmlWriter) | Saves an object into specified XmlWriter. (Inherited from BaseObject.)
Public method | ToXml(Stream) | Saves an object to the specified Stream. (Inherited from BasePersistableObject.)

Properties

 | Name | Description
Public property | Brush | Gets or sets the brush used to fill the user interface object's image. (Inherited from BaseObject.)
Public property | Color | Gets or sets the color of the user interface object. (Inherited from BaseObject.)
Public property | IsEdit | Indicates whether the object is in edit mode, which is started using the BeginEdit()()()() method. (Inherited from BasePersistableObject.)
Public property | Key | Gets an array of objects representing the key of the BasePersistableObject. (Inherited from BasePersistableObject.)
Public property | MenuCaption | Gets or sets the menu caption for the user interface object. (Inherited from BaseObject.)
Public property | Text | Gets or sets the text which identifies a user interface object. (Inherited from BaseObject.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged | (Inherited from BasePersistableObject.)

See Also

Category Class
C1.C1Schedule Namespace


Category Constructor

[image] [image]

.NET Framework Class Library
Category Constructor
Category Class See Also

Overload List

 | Name | Description
Public method | Category()()()() | Creates the new Category object.
Public method | Category(Guid) | Initializes a new instance of the Category class with the specified key.
Public method | Category(Int32) | Initializes a new instance of the Category class with the specified key.
Public method | Category(String) | Creates custom Category object with specified text.

See Also

Category Class
Category Members
C1.C1Schedule Namespace


Category Constructor

[image]

.NET Framework Class Library
Category Constructor
Category Class See Also
Creates the new Category object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Category()
Visual Basic
Public Sub New

See Also

Category Class
Category Overload
C1.C1Schedule Namespace


Category Constructor (Guid)

[image]

.NET Framework Class Library
Category Constructor (Guid)
Category Class See Also
Initializes a new instance of the Category class with the specified key.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Category(
    Guid key
)
Visual Basic
Public Sub New ( _
    key As Guid _
)

Parameters

key
Type: System..::..Guid
The Guid value which should be used as category key.

Remarks

Use this constructor if your business logic requires setting custom key value. Make sure that you use the correct constructor overload (with integer or Guid key value) and that key value is unique.

See Also

Category Class
Category Overload
C1.C1Schedule Namespace


Category Constructor (Int32)

[image]

.NET Framework Class Library
Category Constructor (Int32)
Category Class See Also
Initializes a new instance of the Category class with the specified key.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Category(
    int key
)
Visual Basic
Public Sub New ( _
    key As Integer _
)

Parameters

key
Type: System..::..Int32
The Int32 value which should be used as category key.

Remarks

Use this constructor if your business logic requires setting custom key value. Make sure that you use the correct constructor overload (with integer or Guid key value) and that key value is unique.

See Also

Category Class
Category Overload
C1.C1Schedule Namespace


Category Constructor (String)

[image]

.NET Framework Class Library
Category Constructor (String)
Category Class See Also
Creates custom Category object with specified text.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Category(
    string text
)
Visual Basic
Public Sub New ( _
    text As String _
)

Parameters

text
Type: System..::..String
The text of category.

See Also

Category Class
Category Overload
C1.C1Schedule Namespace


Category Methods

[image] [image]

.NET Framework Class Library
Category Methods
Category Class See Also

The Category type exposes the following members.

Methods

 | Name | Description
Public method | BeginEdit | Brings the object in edit mode. (Inherited from BasePersistableObject.)
Protected method | BeginEditInternal | (Inherited from BasePersistableObject.)
Public method | CancelEdit | Discards changes since the last BeginEdit()()()() call. (Inherited from BasePersistableObject.)
Public method | EndEdit()()()() | Finishes edit mode started by the BeginEdit()()()() method and updates a corresponding data source item. (Inherited from BasePersistableObject.)
Protected method | EndEdit(Boolean) | (Inherited from BasePersistableObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromXml(XmlReader) | Loads an object from the specified XmlReader. (Inherited from BaseObject.)
Public method | FromXml(Stream) | Loads an object from the specified Stream. (Inherited from BasePersistableObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Overrides the default behavior. (Inherited from BasePersistableObject.)
Public method | ToString | Overrides the default behavior. (Inherited from BaseObject.)
Public method | ToXml(XmlWriter) | Saves an object into specified XmlWriter. (Inherited from BaseObject.)
Public method | ToXml(Stream) | Saves an object to the specified Stream. (Inherited from BasePersistableObject.)

See Also

Category Class
C1.C1Schedule Namespace


EndEdit Method

[image] [image]

.NET Framework Class Library
Category..::..EndEdit Method
Category Class See Also

Overload List

 | Name | Description
Public method | EndEdit()()()() | Finishes edit mode started by the BeginEdit()()()() method and updates a corresponding data source item. (Inherited from BasePersistableObject.)
Protected method | EndEdit(Boolean) | (Inherited from BasePersistableObject.)

See Also

Category Class
Category Members
C1.C1Schedule Namespace


FromXml Method

[image] [image]

.NET Framework Class Library
Category..::..FromXml Method
Category Class See Also

Overload List

 | Name | Description
Public method | FromXml(XmlReader) | Loads an object from the specified XmlReader. (Inherited from BaseObject.)
Public method | FromXml(Stream) | Loads an object from the specified Stream. (Inherited from BasePersistableObject.)

See Also

Category Class
Category Members
C1.C1Schedule Namespace


ToXml Method

[image] [image]

.NET Framework Class Library
Category..::..ToXml Method
Category Class See Also

Overload List

 | Name | Description
Public method | ToXml(XmlWriter) | Saves an object into specified XmlWriter. (Inherited from BaseObject.)
Public method | ToXml(Stream) | Saves an object to the specified Stream. (Inherited from BasePersistableObject.)

See Also

Category Class
Category Members
C1.C1Schedule Namespace


Category Properties

[image] [image]

.NET Framework Class Library
Category Properties
Category Class See Also

The Category type exposes the following members.

Properties

 | Name | Description
Public property | Brush | Gets or sets the brush used to fill the user interface object's image. (Inherited from BaseObject.)
Public property | Color | Gets or sets the color of the user interface object. (Inherited from BaseObject.)
Public property | IsEdit | Indicates whether the object is in edit mode, which is started using the BeginEdit()()()() method. (Inherited from BasePersistableObject.)
Public property | Key | Gets an array of objects representing the key of the BasePersistableObject. (Inherited from BasePersistableObject.)
Public property | MenuCaption | Gets or sets the menu caption for the user interface object. (Inherited from BaseObject.)
Public property | Text | Gets or sets the text which identifies a user interface object. (Inherited from BaseObject.)

See Also

Category Class
C1.C1Schedule Namespace


Category Events

[image] [image]

.NET Framework Class Library
Category Events
Category Class See Also

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged | (Inherited from BasePersistableObject.)

See Also

Category Class
C1.C1Schedule Namespace


CategoryCollection Class

[image]

.NET Framework Class Library
CategoryCollection Class
Members See Also
The CategoryCollection is a collection of Category objects which represents all available categories in C1Schedule object model. By default it contains the set of predefined categories.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class CategoryCollection : BaseCollection<Category>
Visual Basic
Public Class CategoryCollection _
    Inherits BaseCollection(Of Category)

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' Category >)>)>
System.Collections.ObjectModel..::..KeyedCollection <(Of <(<' Guid, Category >)>)>
C1.C1Schedule..::..C1ObservableKeyedCollection <(Of <(<' Guid, Category >)>)>
C1.C1Schedule..::..BaseCollection <(Of <(<' Category >)>)>
C1.C1Schedule..::..CategoryCollection

See Also

CategoryCollection Members
C1.C1Schedule Namespace


CategoryCollection Members

[image] [image]

.NET Framework Class Library
CategoryCollection Members
CategoryCollection Class Constructors Methods Properties Explicit Interface Implementations See Also

The CategoryCollection type exposes the following members.

Constructors

 | Name | Description
Public method | CategoryCollection | Initializes a new instance of the CategoryCollection class.

Methods

 | Name | Description
Public method | Add | Adds a new custom object to the collection. If the item already exists in the collection, its index is returned. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | AddRange(array<T>[]()[][]) | Adds an array of objects to the collection. This methods clears the collection before adding new items. Don't use it if you want to keep preexisting items. (Inherited from BaseCollection<(Of <(<'T>)>)> BaseCollection<(Of <(<'T>)>)>.)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection <(Of <(<' Guid, Category >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)
Protected method | ClearItems | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(Int32) | Check if collection contains an item with specified index. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' Guid, Category >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)> Collection<(Of <(<'T>)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Category >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDefaults | Returns the list of predefined categories.
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKeyForItem | Extracts the key from the specified element. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Category >)>)>.)
Protected method | InsertItem | Overrides default behavior of collection at inserting new items. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | LoadDefaults | Restores the collection to its default state.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, Category >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)> Collection<(Of <(<'T>)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)
Protected method | RemoveItem | Overrides base class implementation. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Protected method | SetItem | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection <(Of <(<' Guid, Category >)>)>.)
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, Category >)>)>.)
Public property | Item[([( Guid])]) | Gets the element with the specified key if any. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Category >)>)> Collection<(Of <(<'T>)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)
Protected property | OwnerInternal | (Inherited from BaseCollection<(Of <(<'T>)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' Category >)>)>.)

See Also

CategoryCollection Class
C1.C1Schedule Namespace


CategoryCollection Constructor

[image]

.NET Framework Class Library
CategoryCollection Constructor
CategoryCollection Class See Also
Initializes a new instance of the CategoryCollection class.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public CategoryCollection()
Visual Basic
Public Sub New

See Also

CategoryCollection Class
C1.C1Schedule Namespace


CategoryCollection Methods

[image] [image]

.NET Framework Class Library
CategoryCollection Methods
CategoryCollection Class See Also

The CategoryCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a new custom object to the collection. If the item already exists in the collection, its index is returned. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | AddRange(array<T>[]()[][]) | Adds an array of objects to the collection. This methods clears the collection before adding new items. Don't use it if you want to keep preexisting items. (Inherited from BaseCollection<(Of <(<'T>)>)> BaseCollection<(Of <(<'T>)>)>.)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection <(Of <(<' Guid, Category >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)
Protected method | ClearItems | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(Int32) | Check if collection contains an item with specified index. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' Guid, Category >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)> Collection<(Of <(<'T>)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Category >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDefaults | Returns the list of predefined categories.
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKeyForItem | Extracts the key from the specified element. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Category >)>)>.)
Protected method | InsertItem | Overrides default behavior of collection at inserting new items. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | LoadDefaults | Restores the collection to its default state.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, Category >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)> Collection<(Of <(<'T>)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)
Protected method | RemoveItem | Overrides base class implementation. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Protected method | SetItem | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' Category >)>)>.)

See Also

CategoryCollection Class
C1.C1Schedule Namespace


Contains Method

[image] [image]

.NET Framework Class Library
CategoryCollection..::..Contains Method
CategoryCollection Class See Also

Overload List

 | Name | Description
Public method | Contains(Int32) | Check if collection contains an item with specified index. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' Guid, Category >)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)

See Also

CategoryCollection Class
CategoryCollection Members
C1.C1Schedule Namespace


GetDefaults Method

[image]

.NET Framework Class Library
CategoryCollection..::..GetDefaults Method
CategoryCollection Class See Also
Returns the list of predefined categories.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public List<Category> GetDefaults()
Visual Basic
Public Function GetDefaults As List(Of Category)

Return Value

The List<(Of <(<'T>)>)> object.

See Also

CategoryCollection Class
C1.C1Schedule Namespace


LoadDefaults Method

[image]

.NET Framework Class Library
CategoryCollection..::..LoadDefaults Method
CategoryCollection Class See Also
Restores the collection to its default state.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void LoadDefaults()
Visual Basic
Public Sub LoadDefaults

Remarks

The LoadDefaults()()()() method removes all custom categories from the collection and leaves only the standard ones.

See Also

CategoryCollection Class
C1.C1Schedule Namespace


Remove Method

[image] [image]

.NET Framework Class Library
CategoryCollection..::..Remove Method
CategoryCollection Class See Also

Overload List

 | Name | Description
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, Category >)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)

See Also

CategoryCollection Class
CategoryCollection Members
C1.C1Schedule Namespace


CategoryCollection Properties

[image] [image]

.NET Framework Class Library
CategoryCollection Properties
CategoryCollection Class See Also

The CategoryCollection type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection <(Of <(<' Guid, Category >)>)>.)
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, Category >)>)>.)
Public property | Item[([( Guid])]) | Gets the element with the specified key if any. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Category >)>)> Collection<(Of <(<'T>)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)
Protected property | OwnerInternal | (Inherited from BaseCollection<(Of <(<'T>)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' Category >)>)>.)

See Also

CategoryCollection Class
C1.C1Schedule Namespace


Item Property

[image] [image]

.NET Framework Class Library
CategoryCollection..::..Item Property
CategoryCollection Class See Also

Overload List

 | Name | Description
Public property | Item[([( Guid])]) | Gets the element with the specified key if any. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Category >)>)>.)

See Also

CategoryCollection Class
CategoryCollection Members
C1.C1Schedule Namespace


CategoryCollection Events

[image] [image]

.NET Framework Class Library
CategoryCollection Events
CategoryCollection Class See Also

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)

See Also

CategoryCollection Class
C1.C1Schedule Namespace


CategoryList Class

[image]

.NET Framework Class Library
CategoryList Class
Members See Also
The CategoryList is a list of Category objects. Only objects existing in the owning CategoryCollection object may be added to this list. Use the CategoryList to associate the set of Category objects with an Appointment object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class CategoryList : BaseList<Category>
Visual Basic
Public Class CategoryList _
    Inherits BaseList(Of Category)

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' Category >)>)>
C1.C1Schedule..::..C1ObservableCollection <(Of <(<' Category >)>)>
C1.C1Schedule..::..BaseList <(Of <(<' Category >)>)>
C1.C1Schedule..::..CategoryList

See Also

CategoryList Members
C1.C1Schedule Namespace


CategoryList Members

[image] [image]

.NET Framework Class Library
CategoryList Members
CategoryList Class Methods Properties Explicit Interface Implementations See Also

The CategoryList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)
Protected method | ClearItems | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Category >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Category >)>)>.)
Protected method | InsertItem | Overrides default behavior of Collection. Prevents from adding items non-existent in the parent collection. (Inherited from BaseList<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)
Protected method | RemoveItem | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Protected method | SetItem | Overrides default behavior of Collection. Prevents from adding items non-existent in the parent collection. (Inherited from BaseList<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from BaseList<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Category >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)
Protected property | Owner | Gets the reference to the owning collection. (Inherited from BaseList<(Of <(<'T>)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' Category >)>)>.)

See Also

CategoryList Class
C1.C1Schedule Namespace


CategoryList Methods

[image] [image]

.NET Framework Class Library
CategoryList Methods
CategoryList Class See Also

The CategoryList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)
Protected method | ClearItems | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Category >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Category >)>)>.)
Protected method | InsertItem | Overrides default behavior of Collection. Prevents from adding items non-existent in the parent collection. (Inherited from BaseList<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)
Protected method | RemoveItem | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Protected method | SetItem | Overrides default behavior of Collection. Prevents from adding items non-existent in the parent collection. (Inherited from BaseList<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from BaseList<(Of <(<'T>)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' Category >)>)>.)

See Also

CategoryList Class
C1.C1Schedule Namespace


CategoryList Properties

[image] [image]

.NET Framework Class Library
CategoryList Properties
CategoryList Class See Also

The CategoryList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Category >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Category >)>)>.)
Protected property | Owner | Gets the reference to the owning collection. (Inherited from BaseList<(Of <(<'T>)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Category >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' Category >)>)>.)

See Also

CategoryList Class
C1.C1Schedule Namespace


CategoryList Events

[image] [image]

.NET Framework Class Library
CategoryList Events
CategoryList Class See Also

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)

See Also

CategoryList Class
C1.C1Schedule Namespace


CategoryStorage Class

[image]

.NET Framework Class Library
CategoryStorage Class
Members See Also
The CategoryStorage is the storage for Category objects. It allows binding to the data source and mapping data source fields to the category properties.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class CategoryStorage : BaseStorage<Category, BaseObjectMappingCollection<Category>>
Visual Basic
Public Class CategoryStorage _
    Inherits BaseStorage(Of Category, BaseObjectMappingCollection(Of Category))

Inheritance Hierarchy

System..::..Object
C1.C1Schedule..::..C1BindingSource
C1.C1Schedule..::..BaseStorage <(Of <(<' Category, BaseObjectMappingCollection <(Of <(<' Category >)>)>>)>)>
C1.C1Schedule..::..CategoryStorage

See Also

CategoryStorage Members
C1.C1Schedule Namespace


CategoryStorage Members

[image] [image]

.NET Framework Class Library
CategoryStorage Members
CategoryStorage Class Methods Properties Events Explicit Interface Implementations See Also

The CategoryStorage type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an existing item to the internal list. (Inherited from C1BindingSource.)
Public method | AddNew | Adds a new item to the underlying list. (Inherited from C1BindingSource.)
Public method | BeginEdit | Starts an edit operation on the specified object. (Inherited from C1BindingSource.)
Public method | Clear | Removes all elements from the list. (Inherited from C1BindingSource.)
Public method | Contains | Determines whether an object is an item in the list. (Inherited from C1BindingSource.)
Public method | CopyTo | Copies the contents of the List to the specified array, starting at the specified index value. (Inherited from C1BindingSource.)
Public method | EndEdit | Applies pending changes to the underlying data source. (Inherited from C1BindingSource.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FinishAddNew | Commits a pending new item to the collection. (Inherited from C1BindingSource.)
Public method | GetEnumerator | Retrieves an enumerator for the List. (Inherited from C1BindingSource.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the index of the first occurrence within the entire list. (Inherited from C1BindingSource.)
Public method | Insert | Inserts an item into the list at the specified index. (Inherited from C1BindingSource.)
Protected method | IsSynchronizable | Indicates whether the specified collection item should be synchronized. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAddingNew | (Inherited from C1BindingSource.)
Protected method | OnDataMemberChanged | (Inherited from C1BindingSource.)
Protected method | OnDataSourceChanged | (Inherited from C1BindingSource.)
Protected method | OnDataSourceItemSynchronized | Raises the DataSourceItemSynchronized()()()() event. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Protected method | OnListChanged | Translates changes in the internal list to the Objects collection. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | RefreshData | Call this method each time after changing your data source if it doesn't implement IBindingList interface. Or use BaseStorage{T, TMappingCollection}.Add and BaseStorage{T, TMappingCollection}.Remove instead of corresponding methods of your data source class. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | Remove | Removes object from the Objects collection. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | RemoveAt | Removes the item at the specified index in the list. (Inherited from C1BindingSource.)
Public method | ResetBindings | Causes a control bound to the C1BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from C1BindingSource.)
Public method | ResetItem | Causes a control bound to the C1BindingSource to re-read the item at the specified index, and refresh its displayed value. (Inherited from C1BindingSource.)
Protected method | ShouldSerializeMappings | (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowEdit | Gets a value indicating whether items in the underlying list can be edited. (Inherited from C1BindingSource.)
Public property | AllowNew | Gets or sets a value indicating whether the AddNew()()()() method can be used to add items to the list. (Inherited from C1BindingSource.)
Public property | AllowRemove | Gets a value indicating whether items can be removed from the underlying list. (Inherited from C1BindingSource.)
Public property | BoundMode | Gets a value indicating if the collection is bound to data. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | Categories | Gets the CategoryCollection object that contains category related information.
Public property | Count | Gets the total number of items in the underlying list. (Inherited from C1BindingSource.)
Protected property | DataKeyNamesInternal | This property is for internal use only. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | DataMember | Gets or sets the specific list in the data source to which the connector currently binds to. (Inherited from C1BindingSource.)
Public property | DataSource | Gets or sets the data source that the connector binds to. (Inherited from C1BindingSource.)
Public property | IsFixedSize | Gets a value indicating whether the underlying list has a fixed size. (Inherited from C1BindingSource.)
Public property | IsReadOnly | Gets a value indicating whether the underlying list is read-only. (Inherited from C1BindingSource.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from C1BindingSource.)
Public property | Item | Gets or sets the list element at the specified index. (Inherited from C1BindingSource.)
Public property | List | Gets the list that the connector is bound to. (Inherited from C1BindingSource.)
Public property | Mappings | Gets or sets the MappingCollectionBase<(Of <(<'T>)>)> derived object that allows the properties of objects maintained by the current collection to be bound to the appropriate fields in the data source. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | ScheduleStorage | Gets the reference to the owning C1ScheduleStorage component. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | SupportsChangeNotification | Gets a value indicating whether the data source supports change notification. (Inherited from C1BindingSource.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the underlying list. (Inherited from C1BindingSource.)

Events

 | Name | Description
Public event | AddingNew | Occurs before an item is added to the underlying list. (Inherited from C1BindingSource.)
Public event | DataMemberChanged | Occurs when the DataMember property value has changed. (Inherited from C1BindingSource.)
Public event | DataSourceChanged | Occurs when the DataSource property value has changed. (Inherited from C1BindingSource.)
Public event | ListChanged | Occurs when the underlying list changes or an item in the list changes. (Inherited from C1BindingSource.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitialize..::..BeginInit | (Inherited from C1BindingSource.)
Explicit interface implemetation | ISupportInitialize..::..EndInit | (Inherited from C1BindingSource.)
Explicit interface implemetation | ISupportInitializeNotification..::..Initialized | (Inherited from C1BindingSource.)
Explicit interface implemetation | ISupportInitializeNotification..::..IsInitialized | (Inherited from C1BindingSource.)

See Also

CategoryStorage Class
C1.C1Schedule Namespace


CategoryStorage Methods

[image] [image]

.NET Framework Class Library
CategoryStorage Methods
CategoryStorage Class See Also

The CategoryStorage type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an existing item to the internal list. (Inherited from C1BindingSource.)
Public method | AddNew | Adds a new item to the underlying list. (Inherited from C1BindingSource.)
Public method | BeginEdit | Starts an edit operation on the specified object. (Inherited from C1BindingSource.)
Public method | Clear | Removes all elements from the list. (Inherited from C1BindingSource.)
Public method | Contains | Determines whether an object is an item in the list. (Inherited from C1BindingSource.)
Public method | CopyTo | Copies the contents of the List to the specified array, starting at the specified index value. (Inherited from C1BindingSource.)
Public method | EndEdit | Applies pending changes to the underlying data source. (Inherited from C1BindingSource.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FinishAddNew | Commits a pending new item to the collection. (Inherited from C1BindingSource.)
Public method | GetEnumerator | Retrieves an enumerator for the List. (Inherited from C1BindingSource.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the index of the first occurrence within the entire list. (Inherited from C1BindingSource.)
Public method | Insert | Inserts an item into the list at the specified index. (Inherited from C1BindingSource.)
Protected method | IsSynchronizable | Indicates whether the specified collection item should be synchronized. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAddingNew | (Inherited from C1BindingSource.)
Protected method | OnDataMemberChanged | (Inherited from C1BindingSource.)
Protected method | OnDataSourceChanged | (Inherited from C1BindingSource.)
Protected method | OnDataSourceItemSynchronized | Raises the DataSourceItemSynchronized()()()() event. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Protected method | OnListChanged | Translates changes in the internal list to the Objects collection. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | RefreshData | Call this method each time after changing your data source if it doesn't implement IBindingList interface. Or use BaseStorage{T, TMappingCollection}.Add and BaseStorage{T, TMappingCollection}.Remove instead of corresponding methods of your data source class. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | Remove | Removes object from the Objects collection. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | RemoveAt | Removes the item at the specified index in the list. (Inherited from C1BindingSource.)
Public method | ResetBindings | Causes a control bound to the C1BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from C1BindingSource.)
Public method | ResetItem | Causes a control bound to the C1BindingSource to re-read the item at the specified index, and refresh its displayed value. (Inherited from C1BindingSource.)
Protected method | ShouldSerializeMappings | (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitialize..::..BeginInit | (Inherited from C1BindingSource.)
Explicit interface implemetation | ISupportInitialize..::..EndInit | (Inherited from C1BindingSource.)

See Also

CategoryStorage Class
C1.C1Schedule Namespace


CategoryStorage Properties

[image] [image]

.NET Framework Class Library
CategoryStorage Properties
CategoryStorage Class See Also

The CategoryStorage type exposes the following members.

Properties

 | Name | Description
Public property | AllowEdit | Gets a value indicating whether items in the underlying list can be edited. (Inherited from C1BindingSource.)
Public property | AllowNew | Gets or sets a value indicating whether the AddNew()()()() method can be used to add items to the list. (Inherited from C1BindingSource.)
Public property | AllowRemove | Gets a value indicating whether items can be removed from the underlying list. (Inherited from C1BindingSource.)
Public property | BoundMode | Gets a value indicating if the collection is bound to data. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | Categories | Gets the CategoryCollection object that contains category related information.
Public property | Count | Gets the total number of items in the underlying list. (Inherited from C1BindingSource.)
Protected property | DataKeyNamesInternal | This property is for internal use only. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | DataMember | Gets or sets the specific list in the data source to which the connector currently binds to. (Inherited from C1BindingSource.)
Public property | DataSource | Gets or sets the data source that the connector binds to. (Inherited from C1BindingSource.)
Public property | IsFixedSize | Gets a value indicating whether the underlying list has a fixed size. (Inherited from C1BindingSource.)
Public property | IsReadOnly | Gets a value indicating whether the underlying list is read-only. (Inherited from C1BindingSource.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from C1BindingSource.)
Public property | Item | Gets or sets the list element at the specified index. (Inherited from C1BindingSource.)
Public property | List | Gets the list that the connector is bound to. (Inherited from C1BindingSource.)
Public property | Mappings | Gets or sets the MappingCollectionBase<(Of <(<'T>)>)> derived object that allows the properties of objects maintained by the current collection to be bound to the appropriate fields in the data source. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | ScheduleStorage | Gets the reference to the owning C1ScheduleStorage component. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | SupportsChangeNotification | Gets a value indicating whether the data source supports change notification. (Inherited from C1BindingSource.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the underlying list. (Inherited from C1BindingSource.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitializeNotification..::..IsInitialized | (Inherited from C1BindingSource.)

See Also

CategoryStorage Class
C1.C1Schedule Namespace


Categories Property

[image]

.NET Framework Class Library
CategoryStorage..::..Categories Property
CategoryStorage Class See Also
Gets the CategoryCollection object that contains category related information.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public CategoryCollection Categories { get; }
Visual Basic
Public ReadOnly Property Categories As CategoryCollection
    Get

See Also

CategoryStorage Class
C1.C1Schedule Namespace


CategoryStorage Events

[image] [image]

.NET Framework Class Library
CategoryStorage Events
CategoryStorage Class See Also

The CategoryStorage type exposes the following members.

Events

 | Name | Description
Public event | AddingNew | Occurs before an item is added to the underlying list. (Inherited from C1BindingSource.)
Public event | DataMemberChanged | Occurs when the DataMember property value has changed. (Inherited from C1BindingSource.)
Public event | DataSourceChanged | Occurs when the DataSource property value has changed. (Inherited from C1BindingSource.)
Public event | ListChanged | Occurs when the underlying list changes or an item in the list changes. (Inherited from C1BindingSource.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitializeNotification..::..Initialized | (Inherited from C1BindingSource.)

See Also

CategoryStorage Class
C1.C1Schedule Namespace


Contact Class

[image]

.NET Framework Class Library
Contact Class
Members See Also
The Contact class represents the person information. Not real class just sample for prototyping.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class Contact : BaseObject
Visual Basic
Public Class Contact _
    Inherits BaseObject

Inheritance Hierarchy

System..::..Object
C1.C1Schedule..::..BasePersistableObject
C1.C1Schedule..::..BaseObject
C1.C1Schedule..::..Contact

See Also

Contact Members
C1.C1Schedule Namespace


Contact Members

[image] [image]

.NET Framework Class Library
Contact Members
Contact Class Constructors Methods Properties Explicit Interface Implementations See Also

The Contact type exposes the following members.

Constructors

 | Name | Description
Public method | Contact()()()() | Creates the new Contact object.
Public method | Contact(Guid) | Initializes a new instance of the Contact class with the specified key.
Public method | Contact(Int32) | Initializes a new instance of the Contact class with the specified key.

Methods

 | Name | Description
Public method | BeginEdit | Brings the object in edit mode. (Inherited from BasePersistableObject.)
Protected method | BeginEditInternal | (Inherited from BasePersistableObject.)
Public method | CancelEdit | Discards changes since the last BeginEdit()()()() call. (Inherited from BasePersistableObject.)
Public method | EndEdit()()()() | Finishes edit mode started by the BeginEdit()()()() method and updates a corresponding data source item. (Inherited from BasePersistableObject.)
Protected method | EndEdit(Boolean) | (Inherited from BasePersistableObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromXml(XmlReader) | Loads an object from the specified XmlReader. (Inherited from BaseObject.)
Public method | FromXml(Stream) | Loads an object from the specified Stream. (Inherited from BasePersistableObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Overrides the default behavior. (Inherited from BasePersistableObject.)
Public method | ToString | Overrides the default behavior. (Inherited from BaseObject.)
Public method | ToXml(XmlWriter) | Saves an object into specified XmlWriter. (Inherited from BaseObject.)
Public method | ToXml(Stream) | Saves an object to the specified Stream. (Inherited from BasePersistableObject.)

Properties

 | Name | Description
Public property | Brush | Gets or sets the brush used to fill the user interface object's image. (Inherited from BaseObject.)
Public property | Color | Gets or sets the color of the user interface object. (Inherited from BaseObject.)
Public property | IsEdit | Indicates whether the object is in edit mode, which is started using the BeginEdit()()()() method. (Inherited from BasePersistableObject.)
Public property | Key | Gets an array of objects representing the key of the BasePersistableObject. (Inherited from BasePersistableObject.)
Public property | MenuCaption | Gets or sets the menu caption for the user interface object. (Inherited from BaseObject.)
Public property | Text | Gets or sets the text which identifies a user interface object. (Inherited from BaseObject.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged | (Inherited from BasePersistableObject.)

See Also

Contact Class
C1.C1Schedule Namespace


Contact Constructor

[image] [image]

.NET Framework Class Library
Contact Constructor
Contact Class See Also

Overload List

 | Name | Description
Public method | Contact()()()() | Creates the new Contact object.
Public method | Contact(Guid) | Initializes a new instance of the Contact class with the specified key.
Public method | Contact(Int32) | Initializes a new instance of the Contact class with the specified key.

See Also

Contact Class
Contact Members
C1.C1Schedule Namespace


Contact Constructor

[image]

.NET Framework Class Library
Contact Constructor
Contact Class See Also
Creates the new Contact object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Contact()
Visual Basic
Public Sub New

See Also

Contact Class
Contact Overload
C1.C1Schedule Namespace


Contact Constructor (Guid)

[image]

.NET Framework Class Library
Contact Constructor (Guid)
Contact Class See Also
Initializes a new instance of the Contact class with the specified key.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Contact(
    Guid key
)
Visual Basic
Public Sub New ( _
    key As Guid _
)

Parameters

key
Type: System..::..Guid
The Guid value which should be used as contact key.

Remarks

Use this constructor if your business logic requires setting custom key value. Make sure that you use the correct constructor overload (with integer or Guid key value) and that key value is unique.

See Also

Contact Class
Contact Overload
C1.C1Schedule Namespace


Contact Constructor (Int32)

[image]

.NET Framework Class Library
Contact Constructor (Int32)
Contact Class See Also
Initializes a new instance of the Contact class with the specified key.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Contact(
    int key
)
Visual Basic
Public Sub New ( _
    key As Integer _
)

Parameters

key
Type: System..::..Int32
The Int32 value which should be used as contact key.

Remarks

Use this constructor if your business logic requires setting custom key value. Make sure that you use the correct constructor overload (with integer or Guid key value) and that key value is unique.

See Also

Contact Class
Contact Overload
C1.C1Schedule Namespace


Contact Methods

[image] [image]

.NET Framework Class Library
Contact Methods
Contact Class See Also

The Contact type exposes the following members.

Methods

 | Name | Description
Public method | BeginEdit | Brings the object in edit mode. (Inherited from BasePersistableObject.)
Protected method | BeginEditInternal | (Inherited from BasePersistableObject.)
Public method | CancelEdit | Discards changes since the last BeginEdit()()()() call. (Inherited from BasePersistableObject.)
Public method | EndEdit()()()() | Finishes edit mode started by the BeginEdit()()()() method and updates a corresponding data source item. (Inherited from BasePersistableObject.)
Protected method | EndEdit(Boolean) | (Inherited from BasePersistableObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromXml(XmlReader) | Loads an object from the specified XmlReader. (Inherited from BaseObject.)
Public method | FromXml(Stream) | Loads an object from the specified Stream. (Inherited from BasePersistableObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Overrides the default behavior. (Inherited from BasePersistableObject.)
Public method | ToString | Overrides the default behavior. (Inherited from BaseObject.)
Public method | ToXml(XmlWriter) | Saves an object into specified XmlWriter. (Inherited from BaseObject.)
Public method | ToXml(Stream) | Saves an object to the specified Stream. (Inherited from BasePersistableObject.)

See Also

Contact Class
C1.C1Schedule Namespace


EndEdit Method

[image] [image]

.NET Framework Class Library
Contact..::..EndEdit Method
Contact Class See Also

Overload List

 | Name | Description
Public method | EndEdit()()()() | Finishes edit mode started by the BeginEdit()()()() method and updates a corresponding data source item. (Inherited from BasePersistableObject.)
Protected method | EndEdit(Boolean) | (Inherited from BasePersistableObject.)

See Also

Contact Class
Contact Members
C1.C1Schedule Namespace


FromXml Method

[image] [image]

.NET Framework Class Library
Contact..::..FromXml Method
Contact Class See Also

Overload List

 | Name | Description
Public method | FromXml(XmlReader) | Loads an object from the specified XmlReader. (Inherited from BaseObject.)
Public method | FromXml(Stream) | Loads an object from the specified Stream. (Inherited from BasePersistableObject.)

See Also

Contact Class
Contact Members
C1.C1Schedule Namespace


ToXml Method

[image] [image]

.NET Framework Class Library
Contact..::..ToXml Method
Contact Class See Also

Overload List

 | Name | Description
Public method | ToXml(XmlWriter) | Saves an object into specified XmlWriter. (Inherited from BaseObject.)
Public method | ToXml(Stream) | Saves an object to the specified Stream. (Inherited from BasePersistableObject.)

See Also

Contact Class
Contact Members
C1.C1Schedule Namespace


Contact Properties

[image] [image]

.NET Framework Class Library
Contact Properties
Contact Class See Also

The Contact type exposes the following members.

Properties

 | Name | Description
Public property | Brush | Gets or sets the brush used to fill the user interface object's image. (Inherited from BaseObject.)
Public property | Color | Gets or sets the color of the user interface object. (Inherited from BaseObject.)
Public property | IsEdit | Indicates whether the object is in edit mode, which is started using the BeginEdit()()()() method. (Inherited from BasePersistableObject.)
Public property | Key | Gets an array of objects representing the key of the BasePersistableObject. (Inherited from BasePersistableObject.)
Public property | MenuCaption | Gets or sets the menu caption for the user interface object. (Inherited from BaseObject.)
Public property | Text | Gets or sets the text which identifies a user interface object. (Inherited from BaseObject.)

See Also

Contact Class
C1.C1Schedule Namespace


Contact Events

[image] [image]

.NET Framework Class Library
Contact Events
Contact Class See Also

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged | (Inherited from BasePersistableObject.)

See Also

Contact Class
C1.C1Schedule Namespace


ContactCollection Class

[image]

.NET Framework Class Library
ContactCollection Class
Members See Also
The ContactCollection is a collection of Contact objects which represents all available contacts in C1Schedule object model.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class ContactCollection : BaseCollection<Contact>
Visual Basic
Public Class ContactCollection _
    Inherits BaseCollection(Of Contact)

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' Contact >)>)>
System.Collections.ObjectModel..::..KeyedCollection <(Of <(<' Guid, Contact >)>)>
C1.C1Schedule..::..C1ObservableKeyedCollection <(Of <(<' Guid, Contact >)>)>
C1.C1Schedule..::..BaseCollection <(Of <(<' Contact >)>)>
C1.C1Schedule..::..ContactCollection

See Also

ContactCollection Members
C1.C1Schedule Namespace


ContactCollection Members

[image] [image]

.NET Framework Class Library
ContactCollection Members
ContactCollection Class Constructors Methods Properties Explicit Interface Implementations See Also

The ContactCollection type exposes the following members.

Constructors

 | Name | Description
Public method | ContactCollection | Initializes a new instance of the ContactCollection class.

Methods

 | Name | Description
Public method | Add | Adds a new custom object to the collection. If the item already exists in the collection, its index is returned. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | AddRange(array<T>[]()[][]) | Adds an array of objects to the collection. This methods clears the collection before adding new items. Don't use it if you want to keep preexisting items. (Inherited from BaseCollection<(Of <(<'T>)>)> BaseCollection<(Of <(<'T>)>)>.)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection <(Of <(<' Guid, Contact >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Protected method | ClearItems | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(Int32) | Check if collection contains an item with specified index. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' Guid, Contact >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)> Collection<(Of <(<'T>)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKeyForItem | Extracts the key from the specified element. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Protected method | InsertItem | Overrides default behavior of collection at inserting new items. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, Contact >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)> Collection<(Of <(<'T>)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Protected method | RemoveItem | Overrides base class implementation. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Protected method | SetItem | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection <(Of <(<' Guid, Contact >)>)>.)
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, Contact >)>)>.)
Public property | Item[([( Guid])]) | Gets the element with the specified key if any. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Contact >)>)> Collection<(Of <(<'T>)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Protected property | OwnerInternal | (Inherited from BaseCollection<(Of <(<'T>)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' Contact >)>)>.)

See Also

ContactCollection Class
C1.C1Schedule Namespace


ContactCollection Constructor

[image]

.NET Framework Class Library
ContactCollection Constructor
ContactCollection Class See Also
Initializes a new instance of the ContactCollection class.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ContactCollection()
Visual Basic
Public Sub New

See Also

ContactCollection Class
C1.C1Schedule Namespace


ContactCollection Methods

[image] [image]

.NET Framework Class Library
ContactCollection Methods
ContactCollection Class See Also

The ContactCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a new custom object to the collection. If the item already exists in the collection, its index is returned. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | AddRange(array<T>[]()[][]) | Adds an array of objects to the collection. This methods clears the collection before adding new items. Don't use it if you want to keep preexisting items. (Inherited from BaseCollection<(Of <(<'T>)>)> BaseCollection<(Of <(<'T>)>)>.)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection <(Of <(<' Guid, Contact >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Protected method | ClearItems | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(Int32) | Check if collection contains an item with specified index. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' Guid, Contact >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)> Collection<(Of <(<'T>)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKeyForItem | Extracts the key from the specified element. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Protected method | InsertItem | Overrides default behavior of collection at inserting new items. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, Contact >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)> Collection<(Of <(<'T>)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Protected method | RemoveItem | Overrides base class implementation. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Protected method | SetItem | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' Contact >)>)>.)

See Also

ContactCollection Class
C1.C1Schedule Namespace


Contains Method

[image] [image]

.NET Framework Class Library
ContactCollection..::..Contains Method
ContactCollection Class See Also

Overload List

 | Name | Description
Public method | Contains(Int32) | Check if collection contains an item with specified index. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' Guid, Contact >)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)

See Also

ContactCollection Class
ContactCollection Members
C1.C1Schedule Namespace


Remove Method

[image] [image]

.NET Framework Class Library
ContactCollection..::..Remove Method
ContactCollection Class See Also

Overload List

 | Name | Description
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, Contact >)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)

See Also

ContactCollection Class
ContactCollection Members
C1.C1Schedule Namespace


ContactCollection Properties

[image] [image]

.NET Framework Class Library
ContactCollection Properties
ContactCollection Class See Also

The ContactCollection type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection <(Of <(<' Guid, Contact >)>)>.)
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, Contact >)>)>.)
Public property | Item[([( Guid])]) | Gets the element with the specified key if any. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Contact >)>)> Collection<(Of <(<'T>)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Protected property | OwnerInternal | (Inherited from BaseCollection<(Of <(<'T>)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' Contact >)>)>.)

See Also

ContactCollection Class
C1.C1Schedule Namespace


Item Property

[image] [image]

.NET Framework Class Library
ContactCollection..::..Item Property
ContactCollection Class See Also

Overload List

 | Name | Description
Public property | Item[([( Guid])]) | Gets the element with the specified key if any. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Contact >)>)>.)

See Also

ContactCollection Class
ContactCollection Members
C1.C1Schedule Namespace


ContactCollection Events

[image] [image]

.NET Framework Class Library
ContactCollection Events
ContactCollection Class See Also

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)

See Also

ContactCollection Class
C1.C1Schedule Namespace


ContactList Class

[image]

.NET Framework Class Library
ContactList Class
Members See Also
The ContactList is a list of Contact objects. Only objects existing in the owning ContactCollection object may be added to this list. Use the ContactList to associate the set of Contact objects with an Appointment object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class ContactList : BaseList<Contact>
Visual Basic
Public Class ContactList _
    Inherits BaseList(Of Contact)

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' Contact >)>)>
C1.C1Schedule..::..C1ObservableCollection <(Of <(<' Contact >)>)>
C1.C1Schedule..::..BaseList <(Of <(<' Contact >)>)>
C1.C1Schedule..::..ContactList

See Also

ContactList Members
C1.C1Schedule Namespace


ContactList Members

[image] [image]

.NET Framework Class Library
ContactList Members
ContactList Class Methods Properties Explicit Interface Implementations See Also

The ContactList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Protected method | ClearItems | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Protected method | InsertItem | Overrides default behavior of Collection. Prevents from adding items non-existent in the parent collection. (Inherited from BaseList<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Protected method | RemoveItem | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Protected method | SetItem | Overrides default behavior of Collection. Prevents from adding items non-existent in the parent collection. (Inherited from BaseList<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from BaseList<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Protected property | Owner | Gets the reference to the owning collection. (Inherited from BaseList<(Of <(<'T>)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' Contact >)>)>.)

See Also

ContactList Class
C1.C1Schedule Namespace


ContactList Methods

[image] [image]

.NET Framework Class Library
ContactList Methods
ContactList Class See Also

The ContactList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Protected method | ClearItems | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Protected method | InsertItem | Overrides default behavior of Collection. Prevents from adding items non-existent in the parent collection. (Inherited from BaseList<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Protected method | RemoveItem | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Protected method | SetItem | Overrides default behavior of Collection. Prevents from adding items non-existent in the parent collection. (Inherited from BaseList<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from BaseList<(Of <(<'T>)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' Contact >)>)>.)

See Also

ContactList Class
C1.C1Schedule Namespace


ContactList Properties

[image] [image]

.NET Framework Class Library
ContactList Properties
ContactList Class See Also

The ContactList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Protected property | Owner | Gets the reference to the owning collection. (Inherited from BaseList<(Of <(<'T>)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Contact >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' Contact >)>)>.)

See Also

ContactList Class
C1.C1Schedule Namespace


ContactList Events

[image] [image]

.NET Framework Class Library
ContactList Events
ContactList Class See Also

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)

See Also

ContactList Class
C1.C1Schedule Namespace


ContactStorage Class

[image]

.NET Framework Class Library
ContactStorage Class
Members See Also
The ContactStorage is the storage for Contact objects. It allows binding to the data source and mapping data source fields to the contact properties.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class ContactStorage : BaseStorage<Contact, BaseObjectMappingCollection<Contact>>
Visual Basic
Public Class ContactStorage _
    Inherits BaseStorage(Of Contact, BaseObjectMappingCollection(Of Contact))

Inheritance Hierarchy

System..::..Object
C1.C1Schedule..::..C1BindingSource
C1.C1Schedule..::..BaseStorage <(Of <(<' Contact, BaseObjectMappingCollection <(Of <(<' Contact >)>)>>)>)>
C1.C1Schedule..::..ContactStorage

See Also

ContactStorage Members
C1.C1Schedule Namespace


ContactStorage Members

[image] [image]

.NET Framework Class Library
ContactStorage Members
ContactStorage Class Methods Properties Events Explicit Interface Implementations See Also

The ContactStorage type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an existing item to the internal list. (Inherited from C1BindingSource.)
Public method | AddNew | Adds a new item to the underlying list. (Inherited from C1BindingSource.)
Public method | BeginEdit | Starts an edit operation on the specified object. (Inherited from C1BindingSource.)
Public method | Clear | Removes all elements from the list. (Inherited from C1BindingSource.)
Public method | Contains | Determines whether an object is an item in the list. (Inherited from C1BindingSource.)
Public method | CopyTo | Copies the contents of the List to the specified array, starting at the specified index value. (Inherited from C1BindingSource.)
Public method | EndEdit | Applies pending changes to the underlying data source. (Inherited from C1BindingSource.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FinishAddNew | Commits a pending new item to the collection. (Inherited from C1BindingSource.)
Public method | GetEnumerator | Retrieves an enumerator for the List. (Inherited from C1BindingSource.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the index of the first occurrence within the entire list. (Inherited from C1BindingSource.)
Public method | Insert | Inserts an item into the list at the specified index. (Inherited from C1BindingSource.)
Protected method | IsSynchronizable | Indicates whether the specified collection item should be synchronized. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAddingNew | (Inherited from C1BindingSource.)
Protected method | OnDataMemberChanged | (Inherited from C1BindingSource.)
Protected method | OnDataSourceChanged | (Inherited from C1BindingSource.)
Protected method | OnDataSourceItemSynchronized | Raises the DataSourceItemSynchronized()()()() event. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Protected method | OnListChanged | Translates changes in the internal list to the Objects collection. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | RefreshData | Call this method each time after changing your data source if it doesn't implement IBindingList interface. Or use BaseStorage{T, TMappingCollection}.Add and BaseStorage{T, TMappingCollection}.Remove instead of corresponding methods of your data source class. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | Remove | Removes object from the Objects collection. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | RemoveAt | Removes the item at the specified index in the list. (Inherited from C1BindingSource.)
Public method | ResetBindings | Causes a control bound to the C1BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from C1BindingSource.)
Public method | ResetItem | Causes a control bound to the C1BindingSource to re-read the item at the specified index, and refresh its displayed value. (Inherited from C1BindingSource.)
Protected method | ShouldSerializeMappings | (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowEdit | Gets a value indicating whether items in the underlying list can be edited. (Inherited from C1BindingSource.)
Public property | AllowNew | Gets or sets a value indicating whether the AddNew()()()() method can be used to add items to the list. (Inherited from C1BindingSource.)
Public property | AllowRemove | Gets a value indicating whether items can be removed from the underlying list. (Inherited from C1BindingSource.)
Public property | BoundMode | Gets a value indicating if the collection is bound to data. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | Contacts | Gets the ContactCollection object that contains contact related information.
Public property | Count | Gets the total number of items in the underlying list. (Inherited from C1BindingSource.)
Protected property | DataKeyNamesInternal | This property is for internal use only. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | DataMember | Gets or sets the specific list in the data source to which the connector currently binds to. (Inherited from C1BindingSource.)
Public property | DataSource | Gets or sets the data source that the connector binds to. (Inherited from C1BindingSource.)
Public property | IsFixedSize | Gets a value indicating whether the underlying list has a fixed size. (Inherited from C1BindingSource.)
Public property | IsReadOnly | Gets a value indicating whether the underlying list is read-only. (Inherited from C1BindingSource.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from C1BindingSource.)
Public property | Item | Gets or sets the list element at the specified index. (Inherited from C1BindingSource.)
Public property | List | Gets the list that the connector is bound to. (Inherited from C1BindingSource.)
Public property | Mappings | Gets or sets the MappingCollectionBase<(Of <(<'T>)>)> derived object that allows the properties of objects maintained by the current collection to be bound to the appropriate fields in the data source. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | ScheduleStorage | Gets the reference to the owning C1ScheduleStorage component. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | SupportsChangeNotification | Gets a value indicating whether the data source supports change notification. (Inherited from C1BindingSource.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the underlying list. (Inherited from C1BindingSource.)

Events

 | Name | Description
Public event | AddingNew | Occurs before an item is added to the underlying list. (Inherited from C1BindingSource.)
Public event | DataMemberChanged | Occurs when the DataMember property value has changed. (Inherited from C1BindingSource.)
Public event | DataSourceChanged | Occurs when the DataSource property value has changed. (Inherited from C1BindingSource.)
Public event | ListChanged | Occurs when the underlying list changes or an item in the list changes. (Inherited from C1BindingSource.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitialize..::..BeginInit | (Inherited from C1BindingSource.)
Explicit interface implemetation | ISupportInitialize..::..EndInit | (Inherited from C1BindingSource.)
Explicit interface implemetation | ISupportInitializeNotification..::..Initialized | (Inherited from C1BindingSource.)
Explicit interface implemetation | ISupportInitializeNotification..::..IsInitialized | (Inherited from C1BindingSource.)

See Also

ContactStorage Class
C1.C1Schedule Namespace


ContactStorage Methods

[image] [image]

.NET Framework Class Library
ContactStorage Methods
ContactStorage Class See Also

The ContactStorage type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an existing item to the internal list. (Inherited from C1BindingSource.)
Public method | AddNew | Adds a new item to the underlying list. (Inherited from C1BindingSource.)
Public method | BeginEdit | Starts an edit operation on the specified object. (Inherited from C1BindingSource.)
Public method | Clear | Removes all elements from the list. (Inherited from C1BindingSource.)
Public method | Contains | Determines whether an object is an item in the list. (Inherited from C1BindingSource.)
Public method | CopyTo | Copies the contents of the List to the specified array, starting at the specified index value. (Inherited from C1BindingSource.)
Public method | EndEdit | Applies pending changes to the underlying data source. (Inherited from C1BindingSource.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FinishAddNew | Commits a pending new item to the collection. (Inherited from C1BindingSource.)
Public method | GetEnumerator | Retrieves an enumerator for the List. (Inherited from C1BindingSource.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the index of the first occurrence within the entire list. (Inherited from C1BindingSource.)
Public method | Insert | Inserts an item into the list at the specified index. (Inherited from C1BindingSource.)
Protected method | IsSynchronizable | Indicates whether the specified collection item should be synchronized. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAddingNew | (Inherited from C1BindingSource.)
Protected method | OnDataMemberChanged | (Inherited from C1BindingSource.)
Protected method | OnDataSourceChanged | (Inherited from C1BindingSource.)
Protected method | OnDataSourceItemSynchronized | Raises the DataSourceItemSynchronized()()()() event. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Protected method | OnListChanged | Translates changes in the internal list to the Objects collection. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | RefreshData | Call this method each time after changing your data source if it doesn't implement IBindingList interface. Or use BaseStorage{T, TMappingCollection}.Add and BaseStorage{T, TMappingCollection}.Remove instead of corresponding methods of your data source class. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | Remove | Removes object from the Objects collection. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | RemoveAt | Removes the item at the specified index in the list. (Inherited from C1BindingSource.)
Public method | ResetBindings | Causes a control bound to the C1BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from C1BindingSource.)
Public method | ResetItem | Causes a control bound to the C1BindingSource to re-read the item at the specified index, and refresh its displayed value. (Inherited from C1BindingSource.)
Protected method | ShouldSerializeMappings | (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitialize..::..BeginInit | (Inherited from C1BindingSource.)
Explicit interface implemetation | ISupportInitialize..::..EndInit | (Inherited from C1BindingSource.)

See Also

ContactStorage Class
C1.C1Schedule Namespace


ContactStorage Properties

[image] [image]

.NET Framework Class Library
ContactStorage Properties
ContactStorage Class See Also

The ContactStorage type exposes the following members.

Properties

 | Name | Description
Public property | AllowEdit | Gets a value indicating whether items in the underlying list can be edited. (Inherited from C1BindingSource.)
Public property | AllowNew | Gets or sets a value indicating whether the AddNew()()()() method can be used to add items to the list. (Inherited from C1BindingSource.)
Public property | AllowRemove | Gets a value indicating whether items can be removed from the underlying list. (Inherited from C1BindingSource.)
Public property | BoundMode | Gets a value indicating if the collection is bound to data. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | Contacts | Gets the ContactCollection object that contains contact related information.
Public property | Count | Gets the total number of items in the underlying list. (Inherited from C1BindingSource.)
Protected property | DataKeyNamesInternal | This property is for internal use only. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | DataMember | Gets or sets the specific list in the data source to which the connector currently binds to. (Inherited from C1BindingSource.)
Public property | DataSource | Gets or sets the data source that the connector binds to. (Inherited from C1BindingSource.)
Public property | IsFixedSize | Gets a value indicating whether the underlying list has a fixed size. (Inherited from C1BindingSource.)
Public property | IsReadOnly | Gets a value indicating whether the underlying list is read-only. (Inherited from C1BindingSource.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from C1BindingSource.)
Public property | Item | Gets or sets the list element at the specified index. (Inherited from C1BindingSource.)
Public property | List | Gets the list that the connector is bound to. (Inherited from C1BindingSource.)
Public property | Mappings | Gets or sets the MappingCollectionBase<(Of <(<'T>)>)> derived object that allows the properties of objects maintained by the current collection to be bound to the appropriate fields in the data source. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | ScheduleStorage | Gets the reference to the owning C1ScheduleStorage component. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | SupportsChangeNotification | Gets a value indicating whether the data source supports change notification. (Inherited from C1BindingSource.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the underlying list. (Inherited from C1BindingSource.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitializeNotification..::..IsInitialized | (Inherited from C1BindingSource.)

See Also

ContactStorage Class
C1.C1Schedule Namespace


Contacts Property

[image]

.NET Framework Class Library
ContactStorage..::..Contacts Property
ContactStorage Class See Also
Gets the ContactCollection object that contains contact related information.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ContactCollection Contacts { get; }
Visual Basic
Public ReadOnly Property Contacts As ContactCollection
    Get

See Also

ContactStorage Class
C1.C1Schedule Namespace


ContactStorage Events

[image] [image]

.NET Framework Class Library
ContactStorage Events
ContactStorage Class See Also

The ContactStorage type exposes the following members.

Events

 | Name | Description
Public event | AddingNew | Occurs before an item is added to the underlying list. (Inherited from C1BindingSource.)
Public event | DataMemberChanged | Occurs when the DataMember property value has changed. (Inherited from C1BindingSource.)
Public event | DataSourceChanged | Occurs when the DataSource property value has changed. (Inherited from C1BindingSource.)
Public event | ListChanged | Occurs when the underlying list changes or an item in the list changes. (Inherited from C1BindingSource.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitializeNotification..::..Initialized | (Inherited from C1BindingSource.)

See Also

ContactStorage Class
C1.C1Schedule Namespace


DataSourceItemSynchronizedEventHandler Delegate

[image]

.NET Framework Class Library
DataSourceItemSynchronizedEventHandler Delegate
See Also
The delegate type for the event handlers of the DataSourceItemSynchronized event.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public delegate void DataSourceItemSynchronizedEventHandler(
    Object sender,
    ItemSynchronizedEventArgs e
)
Visual Basic
Public Delegate Sub DataSourceItemSynchronizedEventHandler ( _
    sender As Object, _
    e As ItemSynchronizedEventArgs _
)

Parameters

sender
Type: System..::..Object
The source of the event.
e
Type: C1.C1Schedule..::..ItemSynchronizedEventArgs
The ItemSynchronizedEventArgs that contains the event data.

See Also

C1.C1Schedule Namespace


DateList Class

[image]

.NET Framework Class Library
DateList Class
Members See Also
The DateList class is a wrapper for the List<(Of <(<'T>)>)> instance. At addition of the new value, it cuts off the time part of the value and ensures that the value is not present in the list yet.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class DateList
Visual Basic
Public Class DateList

Remarks

This class uses binary search for all operations.

Inheritance Hierarchy

System..::..Object
C1.C1Schedule..::..DateList

See Also

DateList Members
C1.C1Schedule Namespace


DateList Members

[image] [image]

.NET Framework Class Library
DateList Members
DateList Class Constructors Methods Properties See Also

The DateList type exposes the following members.

Constructors

 | Name | Description
Public method | DateList | Initializes a new instance of DateList class.

Methods

 | Name | Description
Public method | Add | Adds new date to the list.
Public method | Clear | Clears all items from the wrapped list.
Public method | Contains(IList<(Of <<'(DateTime>)>>)) | Returns true if either of specified items exists in the wrapped list.
Public method | Contains(DateTime) | Returns true if specified item exists in the wrapped list.
Public method | Contains(array<DateTime>[]()[][]) | Returns true if either of specified items exists in the wrapped list.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNextDate | Returns the first item that is greater than specified one.
Public method | GetPreviousDate | Returns the first item that is less than specified one.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes specified item from the wrapped list.
Public method | RemoveAt | Removes item at the specified index.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Returns the number of items in the wrapped list.
Public property | Items | Returns the reference to the wrapped list.

See Also

DateList Class
C1.C1Schedule Namespace


DateList Constructor

[image]

.NET Framework Class Library
DateList Constructor
DateList Class See Also
Initializes a new instance of DateList class.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateList()
Visual Basic
Public Sub New

See Also

DateList Class
C1.C1Schedule Namespace


DateList Methods

[image] [image]

.NET Framework Class Library
DateList Methods
DateList Class See Also

The DateList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds new date to the list.
Public method | Clear | Clears all items from the wrapped list.
Public method | Contains(IList<(Of <<'(DateTime>)>>)) | Returns true if either of specified items exists in the wrapped list.
Public method | Contains(DateTime) | Returns true if specified item exists in the wrapped list.
Public method | Contains(array<DateTime>[]()[][]) | Returns true if either of specified items exists in the wrapped list.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNextDate | Returns the first item that is greater than specified one.
Public method | GetPreviousDate | Returns the first item that is less than specified one.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes specified item from the wrapped list.
Public method | RemoveAt | Removes item at the specified index.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DateList Class
C1.C1Schedule Namespace


Add Method

[image]

.NET Framework Class Library
DateList..::..Add Method
DateList Class See Also
Adds new date to the list.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void Add(
    DateTime item
)
Visual Basic
Public Sub Add ( _
    item As DateTime _
)

Parameters

item
Type: System..::..DateTime
The DateTime value to add.

See Also

DateList Class
C1.C1Schedule Namespace


Clear Method

[image]

.NET Framework Class Library
DateList..::..Clear Method
DateList Class See Also
Clears all items from the wrapped list.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear

See Also

DateList Class
C1.C1Schedule Namespace


Contains Method

[image] [image]

.NET Framework Class Library
DateList..::..Contains Method
DateList Class See Also

Overload List

 | Name | Description
Public method | Contains(IList<(Of <<'(DateTime>)>>)) | Returns true if either of specified items exists in the wrapped list.
Public method | Contains(DateTime) | Returns true if specified item exists in the wrapped list.
Public method | Contains(array<DateTime>[]()[][]) | Returns true if either of specified items exists in the wrapped list.

See Also

DateList Class
DateList Members
C1.C1Schedule Namespace


Contains Method (IList(DateTime))

[image]

.NET Framework Class Library
DateList..::..Contains Method (IList<(Of <(<'DateTime>)>)>)
DateList Class See Also
Returns true if either of specified items exists in the wrapped list.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool Contains(
    IList<DateTime> days
)
Visual Basic
Public Function Contains ( _
    days As IList(Of DateTime) _
) As Boolean

Parameters

days
Type: System.Collections.Generic..::..IList <(Of <(<' DateTime >)>)>
A list of DateTime values to search for.

Return Value

True if at least one of specified items exists in the wrapped list.

See Also

DateList Class
Contains Overload
C1.C1Schedule Namespace


Contains Method (DateTime)

[image]

.NET Framework Class Library
DateList..::..Contains Method (DateTime)
DateList Class See Also
Returns true if specified item exists in the wrapped list.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool Contains(
    DateTime item
)
Visual Basic
Public Function Contains ( _
    item As DateTime _
) As Boolean

Parameters

item
Type: System..::..DateTime
An item to search for.

Return Value

True if item exists in the wrapped list.

See Also

DateList Class
Contains Overload
C1.C1Schedule Namespace


Contains Method (DateTime[])

[image]

.NET Framework Class Library
DateList..::..Contains Method (array<DateTime>[]()[][])
DateList Class See Also
Returns true if either of specified items exists in the wrapped list.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool Contains(
    DateTime[] days
)
Visual Basic
Public Function Contains ( _
    days As DateTime() _
) As Boolean

Parameters

days
Type: array< System..::..DateTime >[]()[][]
An array of DateTime values to search for.

Return Value

True if at least one of specified items exists in the wrapped list.

See Also

DateList Class
Contains Overload
C1.C1Schedule Namespace


GetNextDate Method

[image]

.NET Framework Class Library
DateList..::..GetNextDate Method
DateList Class See Also
Returns the first item that is greater than specified one.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTime GetNextDate(
    DateTime item
)
Visual Basic
Public Function GetNextDate ( _
    item As DateTime _
) As DateTime

Parameters

item
Type: System..::..DateTime
An item to search for.

Return Value

The first item that is greater than specified one; or DateTime.MaxValue if such item is not found.

See Also

DateList Class
C1.C1Schedule Namespace


GetPreviousDate Method

[image]

.NET Framework Class Library
DateList..::..GetPreviousDate Method
DateList Class See Also
Returns the first item that is less than specified one.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTime GetPreviousDate(
    DateTime item
)
Visual Basic
Public Function GetPreviousDate ( _
    item As DateTime _
) As DateTime

Parameters

item
Type: System..::..DateTime
An item to search for.

Return Value

The first item that is less than specified one; or DateTime.MinValue if such item is not found.

See Also

DateList Class
C1.C1Schedule Namespace


Remove Method

[image]

.NET Framework Class Library
DateList..::..Remove Method
DateList Class See Also
Removes specified item from the wrapped list.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void Remove(
    DateTime item
)
Visual Basic
Public Sub Remove ( _
    item As DateTime _
)

Parameters

item
Type: System..::..DateTime
The DateTime value to remove.

See Also

DateList Class
C1.C1Schedule Namespace


RemoveAt Method

[image]

.NET Framework Class Library
DateList..::..RemoveAt Method
DateList Class See Also
Removes item at the specified index.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic
Public Sub RemoveAt ( _
    index As Integer _
)

Parameters

index
Type: System..::..Int32
The zero-based index of the item remove to.

See Also

DateList Class
C1.C1Schedule Namespace


DateList Properties

[image] [image]

.NET Framework Class Library
DateList Properties
DateList Class See Also

The DateList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Returns the number of items in the wrapped list.
Public property | Items | Returns the reference to the wrapped list.

See Also

DateList Class
C1.C1Schedule Namespace


Count Property

[image]

.NET Framework Class Library
DateList..::..Count Property
DateList Class See Also
Returns the number of items in the wrapped list.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get

See Also

DateList Class
C1.C1Schedule Namespace


Items Property

[image]

.NET Framework Class Library
DateList..::..Items Property
DateList Class See Also
Returns the reference to the wrapped list.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public List<DateTime> Items { get; }
Visual Basic
Public ReadOnly Property Items As List(Of DateTime)
    Get

See Also

DateList Class
C1.C1Schedule Namespace


FileFormatEnum Enumeration

[image]

.NET Framework Class Library
FileFormatEnum Enumeration
See Also
Specifies the format of the exported or imported file.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public enum FileFormatEnum
Visual Basic
Public Enumeration FileFormatEnum

Members

Member name | Description
XML | XML format (ComponentOne's own format).
iCal | iCal format according to RFC 2445. Format specification could be found here: http://tools.ietf.org/rfc/rfc2445.txt

See Also

C1.C1Schedule Namespace


ImportanceEnum Enumeration

[image]

.NET Framework Class Library
ImportanceEnum Enumeration
See Also
Determines the importance of the Appointment object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public enum ImportanceEnum
Visual Basic
Public Enumeration ImportanceEnum

Members

Member name | Description
Low | Low
Normal | Normal
High | High

See Also

C1.C1Schedule Namespace


ISupportInitialize Interface

[image]

.NET Framework Class Library
ISupportInitialize Interface
Members See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public interface ISupportInitialize
Visual Basic
Public Interface ISupportInitialize

See Also

ISupportInitialize Members
C1.C1Schedule Namespace


ISupportInitialize Members

[image] [image]

.NET Framework Class Library
ISupportInitialize Members
ISupportInitialize Interface Methods See Also

The ISupportInitialize type exposes the following members.

Methods

 | Name | Description
Public method | BeginInit |
Public method | EndInit |

See Also

ISupportInitialize Interface
C1.C1Schedule Namespace


ISupportInitialize Methods

[image] [image]

.NET Framework Class Library
ISupportInitialize Methods
ISupportInitialize Interface See Also

The ISupportInitialize type exposes the following members.

Methods

 | Name | Description
Public method | BeginInit |
Public method | EndInit |

See Also

ISupportInitialize Interface
C1.C1Schedule Namespace


BeginInit Method

[image]

.NET Framework Class Library
ISupportInitialize..::..BeginInit Method
ISupportInitialize Interface See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
void BeginInit()
Visual Basic
Sub BeginInit

See Also

ISupportInitialize Interface
C1.C1Schedule Namespace


EndInit Method

[image]

.NET Framework Class Library
ISupportInitialize..::..EndInit Method
ISupportInitialize Interface See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
void EndInit()
Visual Basic
Sub EndInit

See Also

ISupportInitialize Interface
C1.C1Schedule Namespace


ISupportInitializeNotification Interface

[image]

.NET Framework Class Library
ISupportInitializeNotification Interface
Members See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public interface ISupportInitializeNotification : ISupportInitialize
Visual Basic
Public Interface ISupportInitializeNotification _
    Inherits ISupportInitialize

See Also

ISupportInitializeNotification Members
C1.C1Schedule Namespace


ISupportInitializeNotification Members

[image] [image]

.NET Framework Class Library
ISupportInitializeNotification Members
ISupportInitializeNotification Interface Methods Properties Events See Also

The ISupportInitializeNotification type exposes the following members.

Methods

 | Name | Description
Public method | BeginInit | (Inherited from ISupportInitialize.)
Public method | EndInit | (Inherited from ISupportInitialize.)

Properties

 | Name | Description
Public property | IsInitialized |

Events

 | Name | Description
Public event | Initialized |

See Also

ISupportInitializeNotification Interface
C1.C1Schedule Namespace


ISupportInitializeNotification Methods

[image] [image]

.NET Framework Class Library
ISupportInitializeNotification Methods
ISupportInitializeNotification Interface See Also

The ISupportInitializeNotification type exposes the following members.

Methods

 | Name | Description
Public method | BeginInit | (Inherited from ISupportInitialize.)
Public method | EndInit | (Inherited from ISupportInitialize.)

See Also

ISupportInitializeNotification Interface
C1.C1Schedule Namespace


ISupportInitializeNotification Properties

[image] [image]

.NET Framework Class Library
ISupportInitializeNotification Properties
ISupportInitializeNotification Interface See Also

The ISupportInitializeNotification type exposes the following members.

Properties

 | Name | Description
Public property | IsInitialized |

See Also

ISupportInitializeNotification Interface
C1.C1Schedule Namespace


IsInitialized Property

[image]

.NET Framework Class Library
ISupportInitializeNotification..::..IsInitialized Property
ISupportInitializeNotification Interface See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
bool IsInitialized { get; }
Visual Basic
ReadOnly Property IsInitialized As Boolean
    Get

See Also

ISupportInitializeNotification Interface
C1.C1Schedule Namespace


ISupportInitializeNotification Events

[image] [image]

.NET Framework Class Library
ISupportInitializeNotification Events
ISupportInitializeNotification Interface See Also

The ISupportInitializeNotification type exposes the following members.

Events

 | Name | Description
Public event | Initialized |

See Also

ISupportInitializeNotification Interface
C1.C1Schedule Namespace


Initialized Event

[image]

.NET Framework Class Library
ISupportInitializeNotification..::..Initialized Event
ISupportInitializeNotification Interface See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
event EventHandler Initialized
Visual Basic
Event Initialized As EventHandler

See Also

ISupportInitializeNotification Interface
C1.C1Schedule Namespace


ItemSynchronizedEventArgs Class

[image]

.NET Framework Class Library
ItemSynchronizedEventArgs Class
Members See Also
Provides data for the DataSourceItemSynchronized event.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class ItemSynchronizedEventArgs : EventArgs
Visual Basic
Public Class ItemSynchronizedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
C1.C1Schedule..::..ItemSynchronizedEventArgs

See Also

ItemSynchronizedEventArgs Members
C1.C1Schedule Namespace


ItemSynchronizedEventArgs Members

[image] [image]

.NET Framework Class Library
ItemSynchronizedEventArgs Members
ItemSynchronizedEventArgs Class Constructors Methods Properties See Also

The ItemSynchronizedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ItemSynchronizedEventArgs | Initializes a new instance of the ItemSynchronizedEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Action | Gets the SynchronizationActionEnum value.
Public property | CollectionItem | Gets the reference to the BasePersistableObject derived object.
Public property | DataSourceItem | Gets the reference to the data source item.
Public property | Storage | Gets the reference to the changed C1BindingSource object.

See Also

ItemSynchronizedEventArgs Class
C1.C1Schedule Namespace


ItemSynchronizedEventArgs Constructor

[image]

.NET Framework Class Library
ItemSynchronizedEventArgs Constructor
ItemSynchronizedEventArgs Class See Also
Initializes a new instance of the ItemSynchronizedEventArgs class.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ItemSynchronizedEventArgs(
    C1BindingSource storage,
    BasePersistableObject collectionItem,
    Object dataSourceItem,
    SynchronizationActionEnum action
)
Visual Basic
Public Sub New ( _
    storage As C1BindingSource, _
    collectionItem As BasePersistableObject, _
    dataSourceItem As Object, _
    action As SynchronizationActionEnum _
)

Parameters

storage
Type: C1.C1Schedule..::..C1BindingSource
Reference to the changed C1BindingSource object.
collectionItem
Type: C1.C1Schedule..::..BasePersistableObject
Reference to the BasePersistableObject derived object.
dataSourceItem
Type: System..::..Object
Reference to the corresponding item in the data source.
action
Type: C1.C1Schedule..::..SynchronizationActionEnum
The SynchronizationActionEnum value.

See Also

ItemSynchronizedEventArgs Class
C1.C1Schedule Namespace


ItemSynchronizedEventArgs Methods

[image] [image]

.NET Framework Class Library
ItemSynchronizedEventArgs Methods
ItemSynchronizedEventArgs Class See Also

The ItemSynchronizedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemSynchronizedEventArgs Class
C1.C1Schedule Namespace


ItemSynchronizedEventArgs Properties

[image] [image]

.NET Framework Class Library
ItemSynchronizedEventArgs Properties
ItemSynchronizedEventArgs Class See Also

The ItemSynchronizedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Action | Gets the SynchronizationActionEnum value.
Public property | CollectionItem | Gets the reference to the BasePersistableObject derived object.
Public property | DataSourceItem | Gets the reference to the data source item.
Public property | Storage | Gets the reference to the changed C1BindingSource object.

See Also

ItemSynchronizedEventArgs Class
C1.C1Schedule Namespace


Action Property

[image]

.NET Framework Class Library
ItemSynchronizedEventArgs..::..Action Property
ItemSynchronizedEventArgs Class See Also
Gets the SynchronizationActionEnum value.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public SynchronizationActionEnum Action { get; }
Visual Basic
Public ReadOnly Property Action As SynchronizationActionEnum
    Get

See Also

ItemSynchronizedEventArgs Class
C1.C1Schedule Namespace


CollectionItem Property

[image]

.NET Framework Class Library
ItemSynchronizedEventArgs..::..CollectionItem Property
ItemSynchronizedEventArgs Class See Also
Gets the reference to the BasePersistableObject derived object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public BasePersistableObject CollectionItem { get; }
Visual Basic
Public ReadOnly Property CollectionItem As BasePersistableObject
    Get

See Also

ItemSynchronizedEventArgs Class
C1.C1Schedule Namespace


DataSourceItem Property

[image]

.NET Framework Class Library
ItemSynchronizedEventArgs..::..DataSourceItem Property
ItemSynchronizedEventArgs Class See Also
Gets the reference to the data source item.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object DataSourceItem { get; }
Visual Basic
Public ReadOnly Property DataSourceItem As Object
    Get

See Also

ItemSynchronizedEventArgs Class
C1.C1Schedule Namespace


Storage Property

[image]

.NET Framework Class Library
ItemSynchronizedEventArgs..::..Storage Property
ItemSynchronizedEventArgs Class See Also
Gets the reference to the changed C1BindingSource object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1BindingSource Storage { get; }
Visual Basic
Public ReadOnly Property Storage As C1BindingSource
    Get

See Also

ItemSynchronizedEventArgs Class
C1.C1Schedule Namespace


Label Class

[image]

.NET Framework Class Library
Label Class
Members See Also
The Label class represents the label which can be associated with the Appointment object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class Label : BaseObject
Visual Basic
Public Class Label _
    Inherits BaseObject

Inheritance Hierarchy

System..::..Object
C1.C1Schedule..::..BasePersistableObject
C1.C1Schedule..::..BaseObject
C1.C1Schedule..::..Label

See Also

Label Members
C1.C1Schedule Namespace


Label Members

[image] [image]

.NET Framework Class Library
Label Members
Label Class Constructors Methods Properties Explicit Interface Implementations See Also

The Label type exposes the following members.

Constructors

 | Name | Description
Public method | Label()()()() | Creates the new Label object with default parameters.
Public method | Label(Guid) | Initializes a new instance of the Label class with the specified key.
Public method | Label(Int32) | Initializes a new instance of the Label class with the specified key.
Public method | Label(String) | Creates custom Label object with specified text.
Public method | Label(String, String) | Creates custom Label object with specified text and menu caption.
Public method | Label(Color, String, String) | Creates custom Label object with specified color, text and menu caption.

Methods

 | Name | Description
Public method | BeginEdit | Brings the object in edit mode. (Inherited from BasePersistableObject.)
Protected method | BeginEditInternal | (Inherited from BasePersistableObject.)
Public method | CancelEdit | Discards changes since the last BeginEdit()()()() call. (Inherited from BasePersistableObject.)
Public method | EndEdit()()()() | Finishes edit mode started by the BeginEdit()()()() method and updates a corresponding data source item. (Inherited from BasePersistableObject.)
Protected method | EndEdit(Boolean) | (Inherited from BasePersistableObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromXml(XmlReader) | Loads an object from the specified XmlReader. (Inherited from BaseObject.)
Public method | FromXml(Stream) | Loads an object from the specified Stream. (Inherited from BasePersistableObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Overrides the default behavior. (Inherited from BasePersistableObject.)
Public method | ToString | Overrides the default behavior. (Inherited from BaseObject.)
Public method | ToXml(XmlWriter) | Saves an object into specified XmlWriter. (Inherited from BaseObject.)
Public method | ToXml(Stream) | Saves an object to the specified Stream. (Inherited from BasePersistableObject.)

Properties

 | Name | Description
Public property | Brush | Gets or sets the brush used to fill the user interface object's image. (Inherited from BaseObject.)
Public property | Color | Gets or sets the color of the user interface object. (Inherited from BaseObject.)
Public property | IsEdit | Indicates whether the object is in edit mode, which is started using the BeginEdit()()()() method. (Inherited from BasePersistableObject.)
Public property | Key | Gets an array of objects representing the key of the BasePersistableObject. (Inherited from BasePersistableObject.)
Public property | MenuCaption | Gets or sets the menu caption for the user interface object. (Inherited from BaseObject.)
Public property | Text | Gets or sets the text which identifies a user interface object. (Inherited from BaseObject.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged | (Inherited from BasePersistableObject.)

See Also

Label Class
C1.C1Schedule Namespace


Label Constructor

[image] [image]

.NET Framework Class Library
Label Constructor
Label Class See Also

Overload List

 | Name | Description
Public method | Label()()()() | Creates the new Label object with default parameters.
Public method | Label(Guid) | Initializes a new instance of the Label class with the specified key.
Public method | Label(Int32) | Initializes a new instance of the Label class with the specified key.
Public method | Label(String) | Creates custom Label object with specified text.
Public method | Label(String, String) | Creates custom Label object with specified text and menu caption.
Public method | Label(Color, String, String) | Creates custom Label object with specified color, text and menu caption.

See Also

Label Class
Label Members
C1.C1Schedule Namespace


Label Constructor

[image]

.NET Framework Class Library
Label Constructor
Label Class See Also
Creates the new Label object with default parameters.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Label()
Visual Basic
Public Sub New

See Also

Label Class
Label Overload
C1.C1Schedule Namespace


Label Constructor (Guid)

[image]

.NET Framework Class Library
Label Constructor (Guid)
Label Class See Also
Initializes a new instance of the Label class with the specified key.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Label(
    Guid key
)
Visual Basic
Public Sub New ( _
    key As Guid _
)

Parameters

key
Type: System..::..Guid
The Guid value which should be used as label key.

Remarks

Use this constructor if your business logic requires setting custom key value. Make sure that you use the correct constructor overload (with integer or Guid key value) and that key value is unique.

See Also

Label Class
Label Overload
C1.C1Schedule Namespace


Label Constructor (Int32)

[image]

.NET Framework Class Library
Label Constructor (Int32)
Label Class See Also
Initializes a new instance of the Label class with the specified key.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Label(
    int key
)
Visual Basic
Public Sub New ( _
    key As Integer _
)

Parameters

key
Type: System..::..Int32
The Int32 value which should be used as label key.

Remarks

Use this constructor if your business logic requires setting custom key value. Make sure that you use the correct constructor overload (with integer or Guid key value) and that key value is unique.

See Also

Label Class
Label Overload
C1.C1Schedule Namespace


Label Constructor (String)

[image]

.NET Framework Class Library
Label Constructor (String)
Label Class See Also
Creates custom Label object with specified text.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Label(
    string text
)
Visual Basic
Public Sub New ( _
    text As String _
)

Parameters

text
Type: System..::..String
The text of the label.

See Also

Label Class
Label Overload
C1.C1Schedule Namespace


Label Constructor (String, String)

[image]

.NET Framework Class Library
Label Constructor (String, String)
Label Class See Also
Creates custom Label object with specified text and menu caption.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Label(
    string text,
    string menuCaption
)
Visual Basic
Public Sub New ( _
    text As String, _
    menuCaption As String _
)

Parameters

text
Type: System..::..String
The text of the label.
menuCaption
Type: System..::..String
The menu caption for displaying label in dialogs.

See Also

Label Class
Label Overload
C1.C1Schedule Namespace


Label Constructor (Color, String, String)

[image]

.NET Framework Class Library
Label Constructor (Color, String, String)
Label Class See Also
Creates custom Label object with specified color, text and menu caption.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Label(
    Color color,
    string text,
    string menuCaption
)
Visual Basic
Public Sub New ( _
    color As Color, _
    text As String, _
    menuCaption As String _
)

Parameters

color
Type: System.Windows.Media..::..Color
The color of the label.
text
Type: System..::..String
The text of the label.
menuCaption
Type: System..::..String
The menu caption for displaying label in dialogs.

See Also

Label Class
Label Overload
C1.C1Schedule Namespace


Label Methods

[image] [image]

.NET Framework Class Library
Label Methods
Label Class See Also

The Label type exposes the following members.

Methods

 | Name | Description
Public method | BeginEdit | Brings the object in edit mode. (Inherited from BasePersistableObject.)
Protected method | BeginEditInternal | (Inherited from BasePersistableObject.)
Public method | CancelEdit | Discards changes since the last BeginEdit()()()() call. (Inherited from BasePersistableObject.)
Public method | EndEdit()()()() | Finishes edit mode started by the BeginEdit()()()() method and updates a corresponding data source item. (Inherited from BasePersistableObject.)
Protected method | EndEdit(Boolean) | (Inherited from BasePersistableObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromXml(XmlReader) | Loads an object from the specified XmlReader. (Inherited from BaseObject.)
Public method | FromXml(Stream) | Loads an object from the specified Stream. (Inherited from BasePersistableObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Overrides the default behavior. (Inherited from BasePersistableObject.)
Public method | ToString | Overrides the default behavior. (Inherited from BaseObject.)
Public method | ToXml(XmlWriter) | Saves an object into specified XmlWriter. (Inherited from BaseObject.)
Public method | ToXml(Stream) | Saves an object to the specified Stream. (Inherited from BasePersistableObject.)

See Also

Label Class
C1.C1Schedule Namespace


EndEdit Method

[image] [image]

.NET Framework Class Library
Label..::..EndEdit Method
Label Class See Also

Overload List

 | Name | Description
Public method | EndEdit()()()() | Finishes edit mode started by the BeginEdit()()()() method and updates a corresponding data source item. (Inherited from BasePersistableObject.)
Protected method | EndEdit(Boolean) | (Inherited from BasePersistableObject.)

See Also

Label Class
Label Members
C1.C1Schedule Namespace


FromXml Method

[image] [image]

.NET Framework Class Library
Label..::..FromXml Method
Label Class See Also

Overload List

 | Name | Description
Public method | FromXml(XmlReader) | Loads an object from the specified XmlReader. (Inherited from BaseObject.)
Public method | FromXml(Stream) | Loads an object from the specified Stream. (Inherited from BasePersistableObject.)

See Also

Label Class
Label Members
C1.C1Schedule Namespace


ToXml Method

[image] [image]

.NET Framework Class Library
Label..::..ToXml Method
Label Class See Also

Overload List

 | Name | Description
Public method | ToXml(XmlWriter) | Saves an object into specified XmlWriter. (Inherited from BaseObject.)
Public method | ToXml(Stream) | Saves an object to the specified Stream. (Inherited from BasePersistableObject.)

See Also

Label Class
Label Members
C1.C1Schedule Namespace


Label Properties

[image] [image]

.NET Framework Class Library
Label Properties
Label Class See Also

The Label type exposes the following members.

Properties

 | Name | Description
Public property | Brush | Gets or sets the brush used to fill the user interface object's image. (Inherited from BaseObject.)
Public property | Color | Gets or sets the color of the user interface object. (Inherited from BaseObject.)
Public property | IsEdit | Indicates whether the object is in edit mode, which is started using the BeginEdit()()()() method. (Inherited from BasePersistableObject.)
Public property | Key | Gets an array of objects representing the key of the BasePersistableObject. (Inherited from BasePersistableObject.)
Public property | MenuCaption | Gets or sets the menu caption for the user interface object. (Inherited from BaseObject.)
Public property | Text | Gets or sets the text which identifies a user interface object. (Inherited from BaseObject.)

See Also

Label Class
C1.C1Schedule Namespace


Label Events

[image] [image]

.NET Framework Class Library
Label Events
Label Class See Also

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged | (Inherited from BasePersistableObject.)

See Also

Label Class
C1.C1Schedule Namespace


LabelCollection Class

[image]

.NET Framework Class Library
LabelCollection Class
Members See Also
The LabelCollection is a collection of Label objects which represents all available labels in C1Schedule object model.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class LabelCollection : BaseCollection<Label>
Visual Basic
Public Class LabelCollection _
    Inherits BaseCollection(Of Label)

Remarks

By default it contains the following set of predefined labels:

  • None
  • Important
  • Business
  • Personal
  • Vacation
  • Must Attend
  • Deadline
  • Travel Required
  • Needs Preparation
  • Birthday
  • Anniversary
  • Phone Call

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' Label >)>)>
System.Collections.ObjectModel..::..KeyedCollection <(Of <(<' Guid, Label >)>)>
C1.C1Schedule..::..C1ObservableKeyedCollection <(Of <(<' Guid, Label >)>)>
C1.C1Schedule..::..BaseCollection <(Of <(<' Label >)>)>
C1.C1Schedule..::..LabelCollection

See Also

LabelCollection Members
C1.C1Schedule Namespace


LabelCollection Members

[image] [image]

.NET Framework Class Library
LabelCollection Members
LabelCollection Class Constructors Methods Fields Properties Explicit Interface Implementations See Also

The LabelCollection type exposes the following members.

Constructors

 | Name | Description
Public method | LabelCollection | Initializes a new instance of the LabelCollection class.

Methods

 | Name | Description
Public method | Add | Adds a new custom object to the collection. If the item already exists in the collection, its index is returned. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | AddRange(array<T>[]()[][]) | Adds an array of objects to the collection. This methods clears the collection before adding new items. Don't use it if you want to keep preexisting items. (Inherited from BaseCollection<(Of <(<'T>)>)> BaseCollection<(Of <(<'T>)>)>.)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection <(Of <(<' Guid, Label >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)
Protected method | ClearItems | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(Int32) | Check if collection contains an item with specified index. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' Guid, Label >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)> Collection<(Of <(<'T>)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Label >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKeyForItem | Extracts the key from the specified element. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Label >)>)>.)
Protected method | InsertItem | Overrides default behavior of collection at inserting new items. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | LoadDefaults | Restores the collection to its default state.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, Label >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)> Collection<(Of <(<'T>)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)
Protected method | RemoveItem | Overrides base class implementation. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Protected method | SetItem | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
NoneLabelId | Defines Id of the None label.

Properties

 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection <(Of <(<' Guid, Label >)>)>.)
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, Label >)>)>.)
Public property | Item[([( Guid])]) | Gets the element with the specified key if any. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Label >)>)> Collection<(Of <(<'T>)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)
Protected property | OwnerInternal | (Inherited from BaseCollection<(Of <(<'T>)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' Label >)>)>.)

See Also

LabelCollection Class
C1.C1Schedule Namespace


LabelCollection Constructor

[image]

.NET Framework Class Library
LabelCollection Constructor
LabelCollection Class See Also
Initializes a new instance of the LabelCollection class.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public LabelCollection()
Visual Basic
Public Sub New

See Also

LabelCollection Class
C1.C1Schedule Namespace


LabelCollection Fields

[image] [image]

.NET Framework Class Library
LabelCollection Fields
LabelCollection Class See Also

The LabelCollection type exposes the following members.

Fields

Name | Description
NoneLabelId | Defines Id of the None label.

See Also

LabelCollection Class
C1.C1Schedule Namespace


NoneLabelId Field

[image]

.NET Framework Class Library
LabelCollection..::..NoneLabelId Field
LabelCollection Class See Also
Defines Id of the None label.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly Guid NoneLabelId
Visual Basic
Public Shared ReadOnly NoneLabelId As Guid

See Also

LabelCollection Class
C1.C1Schedule Namespace


LabelCollection Methods

[image] [image]

.NET Framework Class Library
LabelCollection Methods
LabelCollection Class See Also

The LabelCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a new custom object to the collection. If the item already exists in the collection, its index is returned. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | AddRange(array<T>[]()[][]) | Adds an array of objects to the collection. This methods clears the collection before adding new items. Don't use it if you want to keep preexisting items. (Inherited from BaseCollection<(Of <(<'T>)>)> BaseCollection<(Of <(<'T>)>)>.)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection <(Of <(<' Guid, Label >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)
Protected method | ClearItems | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(Int32) | Check if collection contains an item with specified index. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' Guid, Label >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)> Collection<(Of <(<'T>)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Label >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKeyForItem | Extracts the key from the specified element. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Label >)>)>.)
Protected method | InsertItem | Overrides default behavior of collection at inserting new items. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | LoadDefaults | Restores the collection to its default state.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, Label >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)> Collection<(Of <(<'T>)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)
Protected method | RemoveItem | Overrides base class implementation. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Protected method | SetItem | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' Label >)>)>.)

See Also

LabelCollection Class
C1.C1Schedule Namespace


Contains Method

[image] [image]

.NET Framework Class Library
LabelCollection..::..Contains Method
LabelCollection Class See Also

Overload List

 | Name | Description
Public method | Contains(Int32) | Check if collection contains an item with specified index. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' Guid, Label >)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)

See Also

LabelCollection Class
LabelCollection Members
C1.C1Schedule Namespace


LoadDefaults Method

[image]

.NET Framework Class Library
LabelCollection..::..LoadDefaults Method
LabelCollection Class See Also
Restores the collection to its default state.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void LoadDefaults()
Visual Basic
Public Sub LoadDefaults

Remarks

The LoadDefaults()()()() method removes all custom labels from the collection and leaves only the standard ones.

See Also

LabelCollection Class
C1.C1Schedule Namespace


Remove Method

[image] [image]

.NET Framework Class Library
LabelCollection..::..Remove Method
LabelCollection Class See Also

Overload List

 | Name | Description
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, Label >)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)

See Also

LabelCollection Class
LabelCollection Members
C1.C1Schedule Namespace


LabelCollection Properties

[image] [image]

.NET Framework Class Library
LabelCollection Properties
LabelCollection Class See Also

The LabelCollection type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection <(Of <(<' Guid, Label >)>)>.)
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, Label >)>)>.)
Public property | Item[([( Guid])]) | Gets the element with the specified key if any. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Label >)>)> Collection<(Of <(<'T>)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)
Protected property | OwnerInternal | (Inherited from BaseCollection<(Of <(<'T>)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' Label >)>)>.)

See Also

LabelCollection Class
C1.C1Schedule Namespace


Item Property

[image] [image]

.NET Framework Class Library
LabelCollection..::..Item Property
LabelCollection Class See Also

Overload List

 | Name | Description
Public property | Item[([( Guid])]) | Gets the element with the specified key if any. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Label >)>)>.)

See Also

LabelCollection Class
LabelCollection Members
C1.C1Schedule Namespace


LabelCollection Events

[image] [image]

.NET Framework Class Library
LabelCollection Events
LabelCollection Class See Also

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)

See Also

LabelCollection Class
C1.C1Schedule Namespace


LabelList Class

[image]

.NET Framework Class Library
LabelList Class
Members See Also
The LabelList is a list of Label objects. Only objects existing in the owning LabelCollection object may be added to this list.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class LabelList : BaseList<Label>
Visual Basic
Public Class LabelList _
    Inherits BaseList(Of Label)

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' Label >)>)>
C1.C1Schedule..::..C1ObservableCollection <(Of <(<' Label >)>)>
C1.C1Schedule..::..BaseList <(Of <(<' Label >)>)>
C1.C1Schedule..::..LabelList

See Also

LabelList Members
C1.C1Schedule Namespace


LabelList Members

[image] [image]

.NET Framework Class Library
LabelList Members
LabelList Class Methods Properties Explicit Interface Implementations See Also

The LabelList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)
Protected method | ClearItems | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Label >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Label >)>)>.)
Protected method | InsertItem | Overrides default behavior of Collection. Prevents from adding items non-existent in the parent collection. (Inherited from BaseList<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)
Protected method | RemoveItem | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Protected method | SetItem | Overrides default behavior of Collection. Prevents from adding items non-existent in the parent collection. (Inherited from BaseList<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from BaseList<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Label >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)
Protected property | Owner | Gets the reference to the owning collection. (Inherited from BaseList<(Of <(<'T>)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' Label >)>)>.)

See Also

LabelList Class
C1.C1Schedule Namespace


LabelList Methods

[image] [image]

.NET Framework Class Library
LabelList Methods
LabelList Class See Also

The LabelList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)
Protected method | ClearItems | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Label >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Label >)>)>.)
Protected method | InsertItem | Overrides default behavior of Collection. Prevents from adding items non-existent in the parent collection. (Inherited from BaseList<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)
Protected method | RemoveItem | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Protected method | SetItem | Overrides default behavior of Collection. Prevents from adding items non-existent in the parent collection. (Inherited from BaseList<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from BaseList<(Of <(<'T>)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' Label >)>)>.)

See Also

LabelList Class
C1.C1Schedule Namespace


LabelList Properties

[image] [image]

.NET Framework Class Library
LabelList Properties
LabelList Class See Also

The LabelList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Label >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Label >)>)>.)
Protected property | Owner | Gets the reference to the owning collection. (Inherited from BaseList<(Of <(<'T>)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Label >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' Label >)>)>.)

See Also

LabelList Class
C1.C1Schedule Namespace


LabelList Events

[image] [image]

.NET Framework Class Library
LabelList Events
LabelList Class See Also

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)

See Also

LabelList Class
C1.C1Schedule Namespace


LabelStorage Class

[image]

.NET Framework Class Library
LabelStorage Class
Members See Also
The LabelStorage is the storage for Label objects. It allows binding to the data source and mapping data source fields to the label properties.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class LabelStorage : BaseStorage<Label, BaseObjectMappingCollection<Label>>
Visual Basic
Public Class LabelStorage _
    Inherits BaseStorage(Of Label, BaseObjectMappingCollection(Of Label))

Inheritance Hierarchy

System..::..Object
C1.C1Schedule..::..C1BindingSource
C1.C1Schedule..::..BaseStorage <(Of <(<' Label, BaseObjectMappingCollection <(Of <(<' Label >)>)>>)>)>
C1.C1Schedule..::..LabelStorage

See Also

LabelStorage Members
C1.C1Schedule Namespace


LabelStorage Members

[image] [image]

.NET Framework Class Library
LabelStorage Members
LabelStorage Class Methods Properties Events Explicit Interface Implementations See Also

The LabelStorage type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an existing item to the internal list. (Inherited from C1BindingSource.)
Public method | AddNew | Adds a new item to the underlying list. (Inherited from C1BindingSource.)
Public method | BeginEdit | Starts an edit operation on the specified object. (Inherited from C1BindingSource.)
Public method | Clear | Removes all elements from the list. (Inherited from C1BindingSource.)
Public method | Contains | Determines whether an object is an item in the list. (Inherited from C1BindingSource.)
Public method | CopyTo | Copies the contents of the List to the specified array, starting at the specified index value. (Inherited from C1BindingSource.)
Public method | EndEdit | Applies pending changes to the underlying data source. (Inherited from C1BindingSource.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FinishAddNew | Commits a pending new item to the collection. (Inherited from C1BindingSource.)
Public method | GetEnumerator | Retrieves an enumerator for the List. (Inherited from C1BindingSource.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the index of the first occurrence within the entire list. (Inherited from C1BindingSource.)
Public method | Insert | Inserts an item into the list at the specified index. (Inherited from C1BindingSource.)
Protected method | IsSynchronizable | Indicates whether the specified collection item should be synchronized. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAddingNew | (Inherited from C1BindingSource.)
Protected method | OnDataMemberChanged | (Inherited from C1BindingSource.)
Protected method | OnDataSourceChanged | (Inherited from C1BindingSource.)
Protected method | OnDataSourceItemSynchronized | Raises the DataSourceItemSynchronized()()()() event. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Protected method | OnListChanged | Translates changes in the internal list to the Objects collection. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | RefreshData | Call this method each time after changing your data source if it doesn't implement IBindingList interface. Or use BaseStorage{T, TMappingCollection}.Add and BaseStorage{T, TMappingCollection}.Remove instead of corresponding methods of your data source class. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | Remove | Removes object from the Objects collection. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | RemoveAt | Removes the item at the specified index in the list. (Inherited from C1BindingSource.)
Public method | ResetBindings | Causes a control bound to the C1BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from C1BindingSource.)
Public method | ResetItem | Causes a control bound to the C1BindingSource to re-read the item at the specified index, and refresh its displayed value. (Inherited from C1BindingSource.)
Protected method | ShouldSerializeMappings | (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowEdit | Gets a value indicating whether items in the underlying list can be edited. (Inherited from C1BindingSource.)
Public property | AllowNew | Gets or sets a value indicating whether the AddNew()()()() method can be used to add items to the list. (Inherited from C1BindingSource.)
Public property | AllowRemove | Gets a value indicating whether items can be removed from the underlying list. (Inherited from C1BindingSource.)
Public property | BoundMode | Gets a value indicating if the collection is bound to data. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | Count | Gets the total number of items in the underlying list. (Inherited from C1BindingSource.)
Protected property | DataKeyNamesInternal | This property is for internal use only. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | DataMember | Gets or sets the specific list in the data source to which the connector currently binds to. (Inherited from C1BindingSource.)
Public property | DataSource | Gets or sets the data source that the connector binds to. (Inherited from C1BindingSource.)
Public property | IsFixedSize | Gets a value indicating whether the underlying list has a fixed size. (Inherited from C1BindingSource.)
Public property | IsReadOnly | Gets a value indicating whether the underlying list is read-only. (Inherited from C1BindingSource.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from C1BindingSource.)
Public property | Item | Gets or sets the list element at the specified index. (Inherited from C1BindingSource.)
Public property | Labels | Gets the LabelCollection object that contains label related information.
Public property | List | Gets the list that the connector is bound to. (Inherited from C1BindingSource.)
Public property | Mappings | Gets or sets the MappingCollectionBase<(Of <(<'T>)>)> derived object that allows the properties of objects maintained by the current collection to be bound to the appropriate fields in the data source. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | ScheduleStorage | Gets the reference to the owning C1ScheduleStorage component. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | SupportsChangeNotification | Gets a value indicating whether the data source supports change notification. (Inherited from C1BindingSource.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the underlying list. (Inherited from C1BindingSource.)

Events

 | Name | Description
Public event | AddingNew | Occurs before an item is added to the underlying list. (Inherited from C1BindingSource.)
Public event | DataMemberChanged | Occurs when the DataMember property value has changed. (Inherited from C1BindingSource.)
Public event | DataSourceChanged | Occurs when the DataSource property value has changed. (Inherited from C1BindingSource.)
Public event | ListChanged | Occurs when the underlying list changes or an item in the list changes. (Inherited from C1BindingSource.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitialize..::..BeginInit | (Inherited from C1BindingSource.)
Explicit interface implemetation | ISupportInitialize..::..EndInit | (Inherited from C1BindingSource.)
Explicit interface implemetation | ISupportInitializeNotification..::..Initialized | (Inherited from C1BindingSource.)
Explicit interface implemetation | ISupportInitializeNotification..::..IsInitialized | (Inherited from C1BindingSource.)

See Also

LabelStorage Class
C1.C1Schedule Namespace


LabelStorage Methods

[image] [image]

.NET Framework Class Library
LabelStorage Methods
LabelStorage Class See Also

The LabelStorage type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an existing item to the internal list. (Inherited from C1BindingSource.)
Public method | AddNew | Adds a new item to the underlying list. (Inherited from C1BindingSource.)
Public method | BeginEdit | Starts an edit operation on the specified object. (Inherited from C1BindingSource.)
Public method | Clear | Removes all elements from the list. (Inherited from C1BindingSource.)
Public method | Contains | Determines whether an object is an item in the list. (Inherited from C1BindingSource.)
Public method | CopyTo | Copies the contents of the List to the specified array, starting at the specified index value. (Inherited from C1BindingSource.)
Public method | EndEdit | Applies pending changes to the underlying data source. (Inherited from C1BindingSource.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FinishAddNew | Commits a pending new item to the collection. (Inherited from C1BindingSource.)
Public method | GetEnumerator | Retrieves an enumerator for the List. (Inherited from C1BindingSource.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the index of the first occurrence within the entire list. (Inherited from C1BindingSource.)
Public method | Insert | Inserts an item into the list at the specified index. (Inherited from C1BindingSource.)
Protected method | IsSynchronizable | Indicates whether the specified collection item should be synchronized. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAddingNew | (Inherited from C1BindingSource.)
Protected method | OnDataMemberChanged | (Inherited from C1BindingSource.)
Protected method | OnDataSourceChanged | (Inherited from C1BindingSource.)
Protected method | OnDataSourceItemSynchronized | Raises the DataSourceItemSynchronized()()()() event. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Protected method | OnListChanged | Translates changes in the internal list to the Objects collection. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | RefreshData | Call this method each time after changing your data source if it doesn't implement IBindingList interface. Or use BaseStorage{T, TMappingCollection}.Add and BaseStorage{T, TMappingCollection}.Remove instead of corresponding methods of your data source class. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | Remove | Removes object from the Objects collection. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | RemoveAt | Removes the item at the specified index in the list. (Inherited from C1BindingSource.)
Public method | ResetBindings | Causes a control bound to the C1BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from C1BindingSource.)
Public method | ResetItem | Causes a control bound to the C1BindingSource to re-read the item at the specified index, and refresh its displayed value. (Inherited from C1BindingSource.)
Protected method | ShouldSerializeMappings | (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitialize..::..BeginInit | (Inherited from C1BindingSource.)
Explicit interface implemetation | ISupportInitialize..::..EndInit | (Inherited from C1BindingSource.)

See Also

LabelStorage Class
C1.C1Schedule Namespace


LabelStorage Properties

[image] [image]

.NET Framework Class Library
LabelStorage Properties
LabelStorage Class See Also

The LabelStorage type exposes the following members.

Properties

 | Name | Description
Public property | AllowEdit | Gets a value indicating whether items in the underlying list can be edited. (Inherited from C1BindingSource.)
Public property | AllowNew | Gets or sets a value indicating whether the AddNew()()()() method can be used to add items to the list. (Inherited from C1BindingSource.)
Public property | AllowRemove | Gets a value indicating whether items can be removed from the underlying list. (Inherited from C1BindingSource.)
Public property | BoundMode | Gets a value indicating if the collection is bound to data. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | Count | Gets the total number of items in the underlying list. (Inherited from C1BindingSource.)
Protected property | DataKeyNamesInternal | This property is for internal use only. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | DataMember | Gets or sets the specific list in the data source to which the connector currently binds to. (Inherited from C1BindingSource.)
Public property | DataSource | Gets or sets the data source that the connector binds to. (Inherited from C1BindingSource.)
Public property | IsFixedSize | Gets a value indicating whether the underlying list has a fixed size. (Inherited from C1BindingSource.)
Public property | IsReadOnly | Gets a value indicating whether the underlying list is read-only. (Inherited from C1BindingSource.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from C1BindingSource.)
Public property | Item | Gets or sets the list element at the specified index. (Inherited from C1BindingSource.)
Public property | Labels | Gets the LabelCollection object that contains label related information.
Public property | List | Gets the list that the connector is bound to. (Inherited from C1BindingSource.)
Public property | Mappings | Gets or sets the MappingCollectionBase<(Of <(<'T>)>)> derived object that allows the properties of objects maintained by the current collection to be bound to the appropriate fields in the data source. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | ScheduleStorage | Gets the reference to the owning C1ScheduleStorage component. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | SupportsChangeNotification | Gets a value indicating whether the data source supports change notification. (Inherited from C1BindingSource.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the underlying list. (Inherited from C1BindingSource.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitializeNotification..::..IsInitialized | (Inherited from C1BindingSource.)

See Also

LabelStorage Class
C1.C1Schedule Namespace


Labels Property

[image]

.NET Framework Class Library
LabelStorage..::..Labels Property
LabelStorage Class See Also
Gets the LabelCollection object that contains label related information.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public LabelCollection Labels { get; }
Visual Basic
Public ReadOnly Property Labels As LabelCollection
    Get

See Also

LabelStorage Class
C1.C1Schedule Namespace


LabelStorage Events

[image] [image]

.NET Framework Class Library
LabelStorage Events
LabelStorage Class See Also

The LabelStorage type exposes the following members.

Events

 | Name | Description
Public event | AddingNew | Occurs before an item is added to the underlying list. (Inherited from C1BindingSource.)
Public event | DataMemberChanged | Occurs when the DataMember property value has changed. (Inherited from C1BindingSource.)
Public event | DataSourceChanged | Occurs when the DataSource property value has changed. (Inherited from C1BindingSource.)
Public event | ListChanged | Occurs when the underlying list changes or an item in the list changes. (Inherited from C1BindingSource.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitializeNotification..::..Initialized | (Inherited from C1BindingSource.)

See Also

LabelStorage Class
C1.C1Schedule Namespace


ListChangedEventArgs Class

[image]

.NET Framework Class Library
ListChangedEventArgs Class
Members See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class ListChangedEventArgs : EventArgs
Visual Basic
Public Class ListChangedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
C1.C1Schedule..::..ListChangedEventArgs

See Also

ListChangedEventArgs Members
C1.C1Schedule Namespace


ListChangedEventArgs Members

[image] [image]

.NET Framework Class Library
ListChangedEventArgs Members
ListChangedEventArgs Class Constructors Methods Properties See Also

The ListChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ListChangedEventArgs(ListChangedType, PropertyDescriptor) |
Public method | ListChangedEventArgs(ListChangedType, Int32) |
Public method | ListChangedEventArgs(ListChangedType, Int32, PropertyDescriptor) |
Public method | ListChangedEventArgs(ListChangedType, Int32, Int32) |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ListChangedType |
Public property | NewIndex |
Public property | OldIndex |
Public property | PropertyDescriptor |

See Also

ListChangedEventArgs Class
C1.C1Schedule Namespace


ListChangedEventArgs Constructor

[image] [image]

.NET Framework Class Library
ListChangedEventArgs Constructor
ListChangedEventArgs Class See Also

Overload List

 | Name | Description
Public method | ListChangedEventArgs(ListChangedType, PropertyDescriptor) |
Public method | ListChangedEventArgs(ListChangedType, Int32) |
Public method | ListChangedEventArgs(ListChangedType, Int32, PropertyDescriptor) |
Public method | ListChangedEventArgs(ListChangedType, Int32, Int32) |

See Also

ListChangedEventArgs Class
ListChangedEventArgs Members
C1.C1Schedule Namespace


ListChangedEventArgs Constructor (ListChangedType, PropertyDescriptor)

[image]

.NET Framework Class Library
ListChangedEventArgs Constructor (ListChangedType, PropertyDescriptor)
ListChangedEventArgs Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ListChangedEventArgs(
    ListChangedType listChangedType,
    PropertyDescriptor propDesc
)
Visual Basic
Public Sub New ( _
    listChangedType As ListChangedType, _
    propDesc As PropertyDescriptor _
)

Parameters

listChangedType
Type: C1.C1Schedule..::..ListChangedType
propDesc
Type: System.ComponentModel..::..PropertyDescriptor

See Also

ListChangedEventArgs Class
ListChangedEventArgs Overload
C1.C1Schedule Namespace


ListChangedEventArgs Constructor (ListChangedType, Int32)

[image]

.NET Framework Class Library
ListChangedEventArgs Constructor (ListChangedType, Int32)
ListChangedEventArgs Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ListChangedEventArgs(
    ListChangedType listChangedType,
    int newIndex
)
Visual Basic
Public Sub New ( _
    listChangedType As ListChangedType, _
    newIndex As Integer _
)

Parameters

listChangedType
Type: C1.C1Schedule..::..ListChangedType
newIndex
Type: System..::..Int32

See Also

ListChangedEventArgs Class
ListChangedEventArgs Overload
C1.C1Schedule Namespace


ListChangedEventArgs Constructor (ListChangedType, Int32, PropertyDescriptor)

[image]

.NET Framework Class Library
ListChangedEventArgs Constructor (ListChangedType, Int32, PropertyDescriptor)
ListChangedEventArgs Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ListChangedEventArgs(
    ListChangedType listChangedType,
    int newIndex,
    PropertyDescriptor propDesc
)
Visual Basic
Public Sub New ( _
    listChangedType As ListChangedType, _
    newIndex As Integer, _
    propDesc As PropertyDescriptor _
)

Parameters

listChangedType
Type: C1.C1Schedule..::..ListChangedType
newIndex
Type: System..::..Int32
propDesc
Type: System.ComponentModel..::..PropertyDescriptor

See Also

ListChangedEventArgs Class
ListChangedEventArgs Overload
C1.C1Schedule Namespace


ListChangedEventArgs Constructor (ListChangedType, Int32, Int32)

[image]

.NET Framework Class Library
ListChangedEventArgs Constructor (ListChangedType, Int32, Int32)
ListChangedEventArgs Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ListChangedEventArgs(
    ListChangedType listChangedType,
    int newIndex,
    int oldIndex
)
Visual Basic
Public Sub New ( _
    listChangedType As ListChangedType, _
    newIndex As Integer, _
    oldIndex As Integer _
)

Parameters

listChangedType
Type: C1.C1Schedule..::..ListChangedType
newIndex
Type: System..::..Int32
oldIndex
Type: System..::..Int32

See Also

ListChangedEventArgs Class
ListChangedEventArgs Overload
C1.C1Schedule Namespace


ListChangedEventArgs Methods

[image] [image]

.NET Framework Class Library
ListChangedEventArgs Methods
ListChangedEventArgs Class See Also

The ListChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ListChangedEventArgs Class
C1.C1Schedule Namespace


ListChangedEventArgs Properties

[image] [image]

.NET Framework Class Library
ListChangedEventArgs Properties
ListChangedEventArgs Class See Also

The ListChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ListChangedType |
Public property | NewIndex |
Public property | OldIndex |
Public property | PropertyDescriptor |

See Also

ListChangedEventArgs Class
C1.C1Schedule Namespace


ListChangedType Property

[image]

.NET Framework Class Library
ListChangedEventArgs..::..ListChangedType Property
ListChangedEventArgs Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ListChangedType ListChangedType { get; }
Visual Basic
Public ReadOnly Property ListChangedType As ListChangedType
    Get

See Also

ListChangedEventArgs Class
C1.C1Schedule Namespace


NewIndex Property

[image]

.NET Framework Class Library
ListChangedEventArgs..::..NewIndex Property
ListChangedEventArgs Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public int NewIndex { get; }
Visual Basic
Public ReadOnly Property NewIndex As Integer
    Get

See Also

ListChangedEventArgs Class
C1.C1Schedule Namespace


OldIndex Property

[image]

.NET Framework Class Library
ListChangedEventArgs..::..OldIndex Property
ListChangedEventArgs Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public int OldIndex { get; }
Visual Basic
Public ReadOnly Property OldIndex As Integer
    Get

See Also

ListChangedEventArgs Class
C1.C1Schedule Namespace


PropertyDescriptor Property

[image]

.NET Framework Class Library
ListChangedEventArgs..::..PropertyDescriptor Property
ListChangedEventArgs Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public PropertyDescriptor PropertyDescriptor { get; }
Visual Basic
Public ReadOnly Property PropertyDescriptor As PropertyDescriptor
    Get

See Also

ListChangedEventArgs Class
C1.C1Schedule Namespace


ListChangedEventHandler Delegate

[image]

.NET Framework Class Library
ListChangedEventHandler Delegate
See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public delegate void ListChangedEventHandler(
    Object sender,
    ListChangedEventArgs e
)
Visual Basic
Public Delegate Sub ListChangedEventHandler ( _
    sender As Object, _
    e As ListChangedEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: C1.C1Schedule..::..ListChangedEventArgs

See Also

C1.C1Schedule Namespace


ListChangedType Enumeration

[image]

.NET Framework Class Library
ListChangedType Enumeration
See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public enum ListChangedType
Visual Basic
Public Enumeration ListChangedType

Members

Member name | Description
Reset |
ItemAdded |
ItemDeleted |
ItemMoved |
ItemChanged |
PropertyDescriptorAdded |
PropertyDescriptorDeleted |
PropertyDescriptorChanged |

See Also

C1.C1Schedule Namespace


MappingCollectionBase(T) Class

[image]

.NET Framework Class Library
MappingCollectionBase<(Of <(<'T>)>)> Class
Members See Also
Represents a collection of mappings for properties of the BasePersistableObject object to the appropriate data fields. Names of properties are keys in this collection.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class MappingCollectionBase<T> : KeyedCollection<string, MappingInfo>
where T : new(), BasePersistableObject
Visual Basic
Public Class MappingCollectionBase(Of T As {New, BasePersistableObject}) _
    Inherits KeyedCollection(Of String, MappingInfo)

Type Parameters

T
The type of the objects for mapping. It should be derived from the BasePersistableObjectclass and have the default parameter-less constructor.

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' MappingInfo >)>)>
System.Collections.ObjectModel..::..KeyedCollection <(Of <(<' String, MappingInfo >)>)>
C1.C1Schedule..::..MappingCollectionBase<(Of <(<'T>)>)>
C1.C1Schedule..::..AppointmentMappingCollection
C1.C1Schedule..::..BaseObjectMappingCollection<(Of <(<'T>)>)>

See Also

MappingCollectionBase<(Of <(<'T>)>)> Members
C1.C1Schedule Namespace


MappingCollectionBase(T) Members

[image] [image]

.NET Framework Class Library
MappingCollectionBase<(Of <(<'T>)>)> Members
MappingCollectionBase<(Of <(<'T>)>)> Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The MappingCollectionBase<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | MappingCollectionBase<(Of <(<'T>)>)> | Initializes a new instance of the MappingCollectionBase<(Of <(<'T>)>)> class.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Protected method | ClearItems | Removes all elements from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)> Collection<(Of <(<'T>)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKeyForItem | Returns property name as the key for collection. (Overrides KeyedCollection<(Of <(<'TKey, TItem>)>)>..::..GetKeyForItem(TItem).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Protected method | InsertItem | (Overrides KeyedCollection<(Of <(<'TKey, TItem>)>)>..::..InsertItem(Int32, TItem).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)> Collection<(Of <(<'T>)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Protected method | SetItem | Replaces the item at the specified index with the specified item. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection.
Public property | Count | Gets the number of elements actually contained in the MappingCollectionBase<(Of <(<'T>)>)> object.
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public property | IdMapping | Returns MappingInfo object for the Id()()()() property. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Id()()()() property to be bound to the appropriate field in the data source.
Public property | IndexMapping | Returns MappingInfo object for the Index()()()() property. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Index()()()() property to be bound to the appropriate field in the data source.
Public property | Item[([( TKey])]) | Gets the element with the specified key. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' MappingInfo >)>)> Collection<(Of <(<'T>)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)

Events

 | Name | Description
Public event | Disposed | Represents the method that handles the Disposed event of a component.

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)

See Also

MappingCollectionBase<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


MappingCollectionBase(T) Constructor

[image]

.NET Framework Class Library
MappingCollectionBase<(Of <(<'T>)>)> Constructor
MappingCollectionBase<(Of <(<'T>)>)> Class See Also
Initializes a new instance of the MappingCollectionBase<(Of <(<'T>)>)> class.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public MappingCollectionBase()
Visual Basic
Public Sub New

See Also

MappingCollectionBase<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


MappingCollectionBase(T) Methods

[image] [image]

.NET Framework Class Library
MappingCollectionBase<(Of <(<'T>)>)> Methods
MappingCollectionBase<(Of <(<'T>)>)> Class See Also

The MappingCollectionBase<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Protected method | ClearItems | Removes all elements from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)> Collection<(Of <(<'T>)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKeyForItem | Returns property name as the key for collection. (Overrides KeyedCollection<(Of <(<'TKey, TItem>)>)>..::..GetKeyForItem(TItem).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Protected method | InsertItem | (Overrides KeyedCollection<(Of <(<'TKey, TItem>)>)>..::..InsertItem(Int32, TItem).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)> Collection<(Of <(<'T>)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Protected method | SetItem | Replaces the item at the specified index with the specified item. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)

See Also

MappingCollectionBase<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


Contains Method

[image] [image]

.NET Framework Class Library
MappingCollectionBase<(Of <(<'T>)>)>..::..Contains Method
MappingCollectionBase<(Of <(<'T>)>)> Class See Also

Overload List

 | Name | Description
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)

See Also

MappingCollectionBase<(Of <(<'T>)>)> Class
MappingCollectionBase<(Of <(<'T>)>)> Members
C1.C1Schedule Namespace


Dispose Method

[image]

.NET Framework Class Library
MappingCollectionBase<(Of <(<'T>)>)>..::..Dispose Method
MappingCollectionBase<(Of <(<'T>)>)> Class See Also
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual void Dispose()
Visual Basic
Public Overridable Sub Dispose

See Also

MappingCollectionBase<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


GetKeyForItem Method

[image]

.NET Framework Class Library
MappingCollectionBase<(Of <(<'T>)>)>..::..GetKeyForItem Method
MappingCollectionBase<(Of <(<'T>)>)> Class See Also
Returns property name as the key for collection.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override string GetKeyForItem(
    MappingInfo item
)
Visual Basic
Protected Overrides Function GetKeyForItem ( _
    item As MappingInfo _
) As String

Parameters

item
Type: C1.C1Schedule..::..MappingInfo
The MappingInfo object.

Return Value

The property name.

See Also

MappingCollectionBase<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


InsertItem Method

[image]

.NET Framework Class Library
MappingCollectionBase<(Of <(<'T>)>)>..::..InsertItem Method
MappingCollectionBase<(Of <(<'T>)>)> Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void InsertItem(
    int index,
    MappingInfo item
)
Visual Basic
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As MappingInfo _
)

Parameters

index
Type: System..::..Int32
item
Type: C1.C1Schedule..::..MappingInfo

See Also

MappingCollectionBase<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


Remove Method

[image] [image]

.NET Framework Class Library
MappingCollectionBase<(Of <(<'T>)>)>..::..Remove Method
MappingCollectionBase<(Of <(<'T>)>)> Class See Also

Overload List

 | Name | Description
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)

See Also

MappingCollectionBase<(Of <(<'T>)>)> Class
MappingCollectionBase<(Of <(<'T>)>)> Members
C1.C1Schedule Namespace


MappingCollectionBase(T) Properties

[image] [image]

.NET Framework Class Library
MappingCollectionBase<(Of <(<'T>)>)> Properties
MappingCollectionBase<(Of <(<'T>)>)> Class See Also

The MappingCollectionBase<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection.
Public property | Count | Gets the number of elements actually contained in the MappingCollectionBase<(Of <(<'T>)>)> object.
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public property | IdMapping | Returns MappingInfo object for the Id()()()() property. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Id()()()() property to be bound to the appropriate field in the data source.
Public property | IndexMapping | Returns MappingInfo object for the Index()()()() property. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Index()()()() property to be bound to the appropriate field in the data source.
Public property | Item[([( TKey])]) | Gets the element with the specified key. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' MappingInfo >)>)> Collection<(Of <(<'T>)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)

See Also

MappingCollectionBase<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


Comparer Property

[image]

.NET Framework Class Library
MappingCollectionBase<(Of <(<'T>)>)>..::..Comparer Property
MappingCollectionBase<(Of <(<'T>)>)> Class See Also
Gets the generic equality comparer that is used to determine equality of keys in the collection.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public IEqualityComparer<string> Comparer { get; }
Visual Basic
Public ReadOnly Property Comparer As IEqualityComparer(Of String)
    Get

See Also

MappingCollectionBase<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


Count Property

[image]

.NET Framework Class Library
MappingCollectionBase<(Of <(<'T>)>)>..::..Count Property
MappingCollectionBase<(Of <(<'T>)>)> Class See Also
Gets the number of elements actually contained in the MappingCollectionBase<(Of <(<'T>)>)> object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get

See Also

MappingCollectionBase<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


IdMapping Property

[image]

.NET Framework Class Library
MappingCollectionBase<(Of <(<'T>)>)>..::..IdMapping Property
MappingCollectionBase<(Of <(<'T>)>)> Class See Also
Returns MappingInfo object for the Id()()()() property. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Id()()()() property to be bound to the appropriate field in the data source.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public MappingInfo IdMapping { get; set; }
Visual Basic
Public Property IdMapping As MappingInfo
    Get
    Set

Remarks

Each object derived from BasePersistableObject is identified by either Id or Index property. To allow data to be correctly restored from your data sources you should specify mapping either for the IdMapping or for the IndexMapping. It makes sense in case if you bind to your data storages of Resources, Labels, Contacts or Categories. C1Schedule saves only Ids or Indexes of these objects in AppointmentSorage. If there is no mapping for IdMapping or IndexMapping, C1Schedule won't be able to identify Appointment's properties correctly in storages initialized by your data.

See Also

MappingCollectionBase<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


IndexMapping Property

[image]

.NET Framework Class Library
MappingCollectionBase<(Of <(<'T>)>)>..::..IndexMapping Property
MappingCollectionBase<(Of <(<'T>)>)> Class See Also
Returns MappingInfo object for the Index()()()() property. If the storage object is bound to a data source via its DataSource property, the properties of this object allow the Index()()()() property to be bound to the appropriate field in the data source.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public MappingInfo IndexMapping { get; set; }
Visual Basic
Public Property IndexMapping As MappingInfo
    Get
    Set

Remarks

Each object derived from BasePersistableObject is identified by either Id or Index property. To allow data to be correctly restored from your data sources you should specify mapping either for the IdMapping or for the IndexMapping. It makes sense in case if you bind to your data storages of Resources, Labels, Contacts or Categories. C1Schedule saves only Ids or Indexes of these objects in AppointmentSorage. If there is no mapping for IdMapping or IndexMapping, C1Schedule won't be able to identify Appointment's properties correctly in storages initialized by your data.

See Also

MappingCollectionBase<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


Item Property

[image] [image]

.NET Framework Class Library
MappingCollectionBase<(Of <(<'T>)>)>..::..Item Property
MappingCollectionBase<(Of <(<'T>)>)> Class See Also

Overload List

 | Name | Description
Public property | Item[([( TKey])]) | Gets the element with the specified key. (Inherited from KeyedCollection <(Of <(<' String, MappingInfo >)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' MappingInfo >)>)>.)

See Also

MappingCollectionBase<(Of <(<'T>)>)> Class
MappingCollectionBase<(Of <(<'T>)>)> Members
C1.C1Schedule Namespace


MappingCollectionBase(T) Events

[image] [image]

.NET Framework Class Library
MappingCollectionBase<(Of <(<'T>)>)> Events
MappingCollectionBase<(Of <(<'T>)>)> Class See Also

The MappingCollectionBase<(Of <(<'T>)>)> type exposes the following members.

Events

 | Name | Description
Public event | Disposed | Represents the method that handles the Disposed event of a component.

See Also

MappingCollectionBase<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


Disposed Event

[image]

.NET Framework Class Library
MappingCollectionBase<(Of <(<'T>)>)>..::..Disposed Event
MappingCollectionBase<(Of <(<'T>)>)> Class See Also
Represents the method that handles the Disposed event of a component.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event EventHandler Disposed
Visual Basic
Public Event Disposed As EventHandler

See Also

MappingCollectionBase<(Of <(<'T>)>)> Class
C1.C1Schedule Namespace


MappingInfo Class

[image]

.NET Framework Class Library
MappingInfo Class
Members See Also
This class provides information on the mapping of the single property of the object to the appropriate data field.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class MappingInfo
Visual Basic
Public Class MappingInfo

Inheritance Hierarchy

System..::..Object
C1.C1Schedule..::..MappingInfo

See Also

MappingInfo Members
C1.C1Schedule Namespace


MappingInfo Members

[image] [image]

.NET Framework Class Library
MappingInfo Members
MappingInfo Class Methods Properties See Also

The MappingInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DataType | Gets the Type value determining the type of the data field or property which can be bound to this object.
Public property | IsMapped | Gets the Boolean value indicating if this objects is mapped to the data field or property.
Public property | MappingName | Gets or sets the String value determining the name of the data field or property to be bound to the object.
Public property | PropertyName | Gets the String value determining the name of the property which should be mapped.
Public property | Required | Gets the Boolean value indicating if mapping for this property is required or optional.

See Also

MappingInfo Class
C1.C1Schedule Namespace


MappingInfo Methods

[image] [image]

.NET Framework Class Library
MappingInfo Methods
MappingInfo Class See Also

The MappingInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MappingInfo Class
C1.C1Schedule Namespace


MappingInfo Properties

[image] [image]

.NET Framework Class Library
MappingInfo Properties
MappingInfo Class See Also

The MappingInfo type exposes the following members.

Properties

 | Name | Description
Public property | DataType | Gets the Type value determining the type of the data field or property which can be bound to this object.
Public property | IsMapped | Gets the Boolean value indicating if this objects is mapped to the data field or property.
Public property | MappingName | Gets or sets the String value determining the name of the data field or property to be bound to the object.
Public property | PropertyName | Gets the String value determining the name of the property which should be mapped.
Public property | Required | Gets the Boolean value indicating if mapping for this property is required or optional.

See Also

MappingInfo Class
C1.C1Schedule Namespace


DataType Property

[image]

.NET Framework Class Library
MappingInfo..::..DataType Property
MappingInfo Class See Also
Gets the Type value determining the type of the data field or property which can be bound to this object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Type DataType { get; }
Visual Basic
Public ReadOnly Property DataType As Type
    Get

See Also

MappingInfo Class
C1.C1Schedule Namespace


IsMapped Property

[image]

.NET Framework Class Library
MappingInfo..::..IsMapped Property
MappingInfo Class See Also
Gets the Boolean value indicating if this objects is mapped to the data field or property.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsMapped { get; }
Visual Basic
Public ReadOnly Property IsMapped As Boolean
    Get

See Also

MappingInfo Class
C1.C1Schedule Namespace


MappingName Property

[image]

.NET Framework Class Library
MappingInfo..::..MappingName Property
MappingInfo Class See Also
Gets or sets the String value determining the name of the data field or property to be bound to the object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute("")]
public string MappingName { get; set; }
Visual Basic
<DefaultValueAttribute("")> _
Public Property MappingName As String
    Get
    Set

See Also

MappingInfo Class
C1.C1Schedule Namespace


PropertyName Property

[image]

.NET Framework Class Library
MappingInfo..::..PropertyName Property
MappingInfo Class See Also
Gets the String value determining the name of the property which should be mapped.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string PropertyName { get; }
Visual Basic
Public ReadOnly Property PropertyName As String
    Get

See Also

MappingInfo Class
C1.C1Schedule Namespace


Required Property

[image]

.NET Framework Class Library
MappingInfo..::..Required Property
MappingInfo Class See Also
Gets the Boolean value indicating if mapping for this property is required or optional.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool Required { get; }
Visual Basic
Public ReadOnly Property Required As Boolean
    Get

See Also

MappingInfo Class
C1.C1Schedule Namespace


RecurrencePattern Class

[image]

.NET Framework Class Library
RecurrencePattern Class
Members See Also
The RecurrencePattern class contains information that describes the recurrence pattern and range of the associated Appointment object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class RecurrencePattern : INotifyPropertyChanged
Visual Basic
Public Class RecurrencePattern _
    Implements INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
C1.C1Schedule..::..RecurrencePattern

See Also

RecurrencePattern Members
C1.C1Schedule Namespace


RecurrencePattern Members

[image] [image]

.NET Framework Class Library
RecurrencePattern Members
RecurrencePattern Class Methods Properties Explicit Interface Implementations See Also

The RecurrencePattern type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDescription(CultureInfo) | Gets the human-readable description of the RecurrencePattern object according to the specified culture.
Public method | GetDescription(CalendarInfo) | Gets the human-readable description of the RecurrencePattern object according to the specified CalendarInfo object. Use this method instead of Description property if the RecurrencePattern object does not belong to any C1.C1Schedule control.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DayOfMonth | Gets or sets the number of the day in its respective month on which each occurrence will occur. Applicable only when the RecurrenceType property is set to Monthly or Yearly. The default value is 1.
Public property | DayOfWeekMask | Gets or sets the WeekDaysEnum value representing the mask for week days on which the recurring appointment occurs. Monthly and yearly patterns are only valid for a single day. Weekly patterns are only valid as the Or of the DayOfWeekMask. The default value is 0.
Public property | Description | Gets the human-readable description of the RecurrencePattern object.
Public property | Duration | Gets or sets the TimeSpan value indicating the duration of each occurrence in the recurrence pattern.
Public property | EndTime | Gets or sets the DateTime value indicating the end time for the given occurrence of the recurrence pattern.
Public property | Exceptions | Gets the AppointmentList object which holds the list of Appointment objects that define the exceptions to that series of appointments. Appointment objects are added to the Exceptions whenever a property in the corresponding Appointment object is altered.
Public property | Instance | Get or sets the WeekOfMonthEnum value specifying the count for which the recurrence pattern is valid for a given interval. This property is only valid for recurrences of the MonthlyNth and YearlyNth types and allows the definition of a recurrence pattern that is only valid for the Nth occurrence, such as "the 2nd Sunday in March" pattern. The default value is WeekOfMonthEnum.First.
Public property | Interval | Gets or sets the Int32 value specifying the interval between occurrences of the recurrence. The Interval property works in conjunction with the RecurrenceType property to determine the cycle of the recurrence. The maximum allowable value is 99 for weekly patterns and 999 for daily patterns. The default value is 1.
Public property | MonthOfYear | Gets or sets the value indicating which month of the year is valid for the specified recurrence pattern. Can be a number from 1 to 12. This property is only valid for recurrence patterns whose RecurrenceType property is set to YearlyNth or Yearly. The default value is 1.
Public property | NoEndDate | Gets or sets the Boolean value indicating if the recurrence pattern is endless. The default value is True.
Public property | Occurrences | Gets or sets the number of occurrences for the recurrence pattern. This property allows the definition of a recurrence pattern that is only valid for the specified number of subsequent occurrences. For example, you can set this property to 10 for a formal training course that will be held on the next ten Thursday evenings. The default value is 0.
Public property | ParentAppointment | Gets the Appointment object which represents the master appointment for this RecurrencePattern object.
Public property | PatternEndDate | Gets or sets the DateTime value indicating the end date of the recurrence pattern.
Public property | PatternStartDate | Gets or sets the DateTime value indicating the start date of the recurrence pattern.
Public property | RecurrenceType | Gets or sets the RecurrenceTypeEnum value determining the type of recurrence (daily, monthly, etc.). Default value is RecurrenceTypeEnum.Weekly.
Public property | RemovedOccurrences | Gets the AppointmentList object which holds the list of Appointment objects removed from that series of appointments.
Public property | StartTime | Gets or sets the DateTime value indicating the start time for the given occurrence of the recurrence pattern.

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged |

See Also

RecurrencePattern Class
C1.C1Schedule Namespace


RecurrencePattern Methods

[image] [image]

.NET Framework Class Library
RecurrencePattern Methods
RecurrencePattern Class See Also

The RecurrencePattern type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDescription(CultureInfo) | Gets the human-readable description of the RecurrencePattern object according to the specified culture.
Public method | GetDescription(CalendarInfo) | Gets the human-readable description of the RecurrencePattern object according to the specified CalendarInfo object. Use this method instead of Description property if the RecurrencePattern object does not belong to any C1.C1Schedule control.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RecurrencePattern Class
C1.C1Schedule Namespace


GetDescription Method

[image] [image]

.NET Framework Class Library
RecurrencePattern..::..GetDescription Method
RecurrencePattern Class See Also

Overload List

 | Name | Description
Public method | GetDescription(CultureInfo) | Gets the human-readable description of the RecurrencePattern object according to the specified culture.
Public method | GetDescription(CalendarInfo) | Gets the human-readable description of the RecurrencePattern object according to the specified CalendarInfo object. Use this method instead of Description property if the RecurrencePattern object does not belong to any C1.C1Schedule control.

See Also

RecurrencePattern Class
RecurrencePattern Members
C1.C1Schedule Namespace


GetDescription Method (CultureInfo)

[image]

.NET Framework Class Library
RecurrencePattern..::..GetDescription Method (CultureInfo)
RecurrencePattern Class See Also
Gets the human-readable description of the RecurrencePattern object according to the specified culture.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string GetDescription(
    CultureInfo culture
)
Visual Basic
Public Function GetDescription ( _
    culture As CultureInfo _
) As String

Parameters

culture
Type: System.Globalization..::..CultureInfo
The CultureInfo object used for getting calendar specific strings.

Return Value

The String value described the RecurrencePattern object.

See Also

RecurrencePattern Class
GetDescription Overload
C1.C1Schedule Namespace


GetDescription Method (CalendarInfo)

[image]

.NET Framework Class Library
RecurrencePattern..::..GetDescription Method (CalendarInfo)
RecurrencePattern Class See Also
Gets the human-readable description of the RecurrencePattern object according to the specified CalendarInfo object. Use this method instead of Description property if the RecurrencePattern object does not belong to any C1.C1Schedule control.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string GetDescription(
    CalendarInfo calendarInfo
)
Visual Basic
Public Function GetDescription ( _
    calendarInfo As CalendarInfo _
) As String

Parameters

calendarInfo
Type: C1.C1Schedule..::..CalendarInfo
The CalendarInfo object used for getting calendar specific strings.

Return Value

The String value described the RecurrencePattern object.

Remarks

If the RecurrencePattern object does not belong to the C1.C1Schedule control, its Description property will return the default description using current user culture and calendar settings.

See Also

RecurrencePattern Class
GetDescription Overload
C1.C1Schedule Namespace


OnPropertyChanged Method

[image]

.NET Framework Class Library
RecurrencePattern..::..OnPropertyChanged Method
RecurrencePattern Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnPropertyChanged(
    string propertyName
)
Visual Basic
Protected Overridable Sub OnPropertyChanged ( _
    propertyName As String _
)

Parameters

propertyName
Type: System..::..String

See Also

RecurrencePattern Class
C1.C1Schedule Namespace


RecurrencePattern Properties

[image] [image]

.NET Framework Class Library
RecurrencePattern Properties
RecurrencePattern Class See Also

The RecurrencePattern type exposes the following members.

Properties

 | Name | Description
Public property | DayOfMonth | Gets or sets the number of the day in its respective month on which each occurrence will occur. Applicable only when the RecurrenceType property is set to Monthly or Yearly. The default value is 1.
Public property | DayOfWeekMask | Gets or sets the WeekDaysEnum value representing the mask for week days on which the recurring appointment occurs. Monthly and yearly patterns are only valid for a single day. Weekly patterns are only valid as the Or of the DayOfWeekMask. The default value is 0.
Public property | Description | Gets the human-readable description of the RecurrencePattern object.
Public property | Duration | Gets or sets the TimeSpan value indicating the duration of each occurrence in the recurrence pattern.
Public property | EndTime | Gets or sets the DateTime value indicating the end time for the given occurrence of the recurrence pattern.
Public property | Exceptions | Gets the AppointmentList object which holds the list of Appointment objects that define the exceptions to that series of appointments. Appointment objects are added to the Exceptions whenever a property in the corresponding Appointment object is altered.
Public property | Instance | Get or sets the WeekOfMonthEnum value specifying the count for which the recurrence pattern is valid for a given interval. This property is only valid for recurrences of the MonthlyNth and YearlyNth types and allows the definition of a recurrence pattern that is only valid for the Nth occurrence, such as "the 2nd Sunday in March" pattern. The default value is WeekOfMonthEnum.First.
Public property | Interval | Gets or sets the Int32 value specifying the interval between occurrences of the recurrence. The Interval property works in conjunction with the RecurrenceType property to determine the cycle of the recurrence. The maximum allowable value is 99 for weekly patterns and 999 for daily patterns. The default value is 1.
Public property | MonthOfYear | Gets or sets the value indicating which month of the year is valid for the specified recurrence pattern. Can be a number from 1 to 12. This property is only valid for recurrence patterns whose RecurrenceType property is set to YearlyNth or Yearly. The default value is 1.
Public property | NoEndDate | Gets or sets the Boolean value indicating if the recurrence pattern is endless. The default value is True.
Public property | Occurrences | Gets or sets the number of occurrences for the recurrence pattern. This property allows the definition of a recurrence pattern that is only valid for the specified number of subsequent occurrences. For example, you can set this property to 10 for a formal training course that will be held on the next ten Thursday evenings. The default value is 0.
Public property | ParentAppointment | Gets the Appointment object which represents the master appointment for this RecurrencePattern object.
Public property | PatternEndDate | Gets or sets the DateTime value indicating the end date of the recurrence pattern.
Public property | PatternStartDate | Gets or sets the DateTime value indicating the start date of the recurrence pattern.
Public property | RecurrenceType | Gets or sets the RecurrenceTypeEnum value determining the type of recurrence (daily, monthly, etc.). Default value is RecurrenceTypeEnum.Weekly.
Public property | RemovedOccurrences | Gets the AppointmentList object which holds the list of Appointment objects removed from that series of appointments.
Public property | StartTime | Gets or sets the DateTime value indicating the start time for the given occurrence of the recurrence pattern.

See Also

RecurrencePattern Class
C1.C1Schedule Namespace


DayOfMonth Property

[image]

.NET Framework Class Library
RecurrencePattern..::..DayOfMonth Property
RecurrencePattern Class See Also
Gets or sets the number of the day in its respective month on which each occurrence will occur. Applicable only when the RecurrenceType property is set to Monthly or Yearly. The default value is 1.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public int DayOfMonth { get; set; }
Visual Basic
Public Property DayOfMonth As Integer
    Get
    Set

See Also

RecurrencePattern Class
C1.C1Schedule Namespace


DayOfWeekMask Property

[image]

.NET Framework Class Library
RecurrencePattern..::..DayOfWeekMask Property
RecurrencePattern Class See Also
Gets or sets the WeekDaysEnum value representing the mask for week days on which the recurring appointment occurs. Monthly and yearly patterns are only valid for a single day. Weekly patterns are only valid as the Or of the DayOfWeekMask. The default value is 0.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public WeekDaysEnum DayOfWeekMask { get; set; }
Visual Basic
Public Property DayOfWeekMask As WeekDaysEnum
    Get
    Set

Remarks

When the RecurrenceType property is set to Daily, the DayOfWeekMask property can only be set to EveryDay; setting the property to any other value will result in an exception. When the RecurrenceType property is set to Workdays, the DayOfWeekMask property can only be set to WorkDays; setting the property to any other value will result in an exception. When the RecurrenceType property is set to Weekly, the DayOfWeekMask property cannot be set to None; doing so will result in an exception being thrown. When the RecurrenceType property is set to Monthly or Yearly the DayOfWeekMask property is not applicable.

See Also

RecurrencePattern Class
C1.C1Schedule Namespace


Description Property

[image]

.NET Framework Class Library
RecurrencePattern..::..Description Property
RecurrencePattern Class See Also
Gets the human-readable description of the RecurrencePattern object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get

See Also

RecurrencePattern Class
C1.C1Schedule Namespace


Duration Property

[image]

.NET Framework Class Library
RecurrencePattern..::..Duration Property
RecurrencePattern Class See Also
Gets or sets the TimeSpan value indicating the duration of each occurrence in the recurrence pattern.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public TimeSpan Duration { get; set; }
Visual Basic
Public Property Duration As TimeSpan
    Get
    Set

See Also

RecurrencePattern Class
C1.C1Schedule Namespace


EndTime Property

[image]

.NET Framework Class Library
RecurrencePattern..::..EndTime Property
RecurrencePattern Class See Also
Gets or sets the DateTime value indicating the end time for the given occurrence of the recurrence pattern.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTime EndTime { get; set; }
Visual Basic
Public Property EndTime As DateTime
    Get
    Set

See Also

RecurrencePattern Class
C1.C1Schedule Namespace


Exceptions Property

[image]

.NET Framework Class Library
RecurrencePattern..::..Exceptions Property
RecurrencePattern Class See Also
Gets the AppointmentList object which holds the list of Appointment objects that define the exceptions to that series of appointments. Appointment objects are added to the Exceptions whenever a property in the corresponding Appointment object is altered.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public AppointmentList Exceptions { get; }
Visual Basic
Public ReadOnly Property Exceptions As AppointmentList
    Get

See Also

RecurrencePattern Class
C1.C1Schedule Namespace


Instance Property

[image]

.NET Framework Class Library
RecurrencePattern..::..Instance Property
RecurrencePattern Class See Also
Get or sets the WeekOfMonthEnum value specifying the count for which the recurrence pattern is valid for a given interval. This property is only valid for recurrences of the MonthlyNth and YearlyNth types and allows the definition of a recurrence pattern that is only valid for the Nth occurrence, such as "the 2nd Sunday in March" pattern. The default value is WeekOfMonthEnum.First.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public WeekOfMonthEnum Instance { get; set; }
Visual Basic
Public Property Instance As WeekOfMonthEnum
    Get
    Set

See Also

RecurrencePattern Class
C1.C1Schedule Namespace


Interval Property

[image]

.NET Framework Class Library
RecurrencePattern..::..Interval Property
RecurrencePattern Class See Also
Gets or sets the Int32 value specifying the interval between occurrences of the recurrence. The Interval property works in conjunction with the RecurrenceType property to determine the cycle of the recurrence. The maximum allowable value is 99 for weekly patterns and 999 for daily patterns. The default value is 1.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public int Interval { get; set; }
Visual Basic
Public Property Interval As Integer
    Get
    Set

Remarks

For example, if the RecurrenceType is set to Daily, and the Interval is set to 3, the recurrence will occur every third day.

See Also

RecurrencePattern Class
C1.C1Schedule Namespace


MonthOfYear Property

[image]

.NET Framework Class Library
RecurrencePattern..::..MonthOfYear Property
RecurrencePattern Class See Also
Gets or sets the value indicating which month of the year is valid for the specified recurrence pattern. Can be a number from 1 to 12. This property is only valid for recurrence patterns whose RecurrenceType property is set to YearlyNth or Yearly. The default value is 1.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public int MonthOfYear { get; set; }
Visual Basic
Public Property MonthOfYear As Integer
    Get
    Set

See Also

RecurrencePattern Class
C1.C1Schedule Namespace


NoEndDate Property

[image]

.NET Framework Class Library
RecurrencePattern..::..NoEndDate Property
RecurrencePattern Class See Also
Gets or sets the Boolean value indicating if the recurrence pattern is endless. The default value is True.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool NoEndDate { get; set; }
Visual Basic
Public Property NoEndDate As Boolean
    Get
    Set

Remarks

This property must be coordinated with other properties when setting up a recurrence pattern. If the PatternEndDate property or the Occurrences property is set, the pattern is considered to be finite and the NoEndDate property is false. If neither PatternEndDate nor Occurrences is set, the pattern is considered infinite and NoEndDate is true.

See Also

RecurrencePattern Class
C1.C1Schedule Namespace


Occurrences Property

[image]

.NET Framework Class Library
RecurrencePattern..::..Occurrences Property
RecurrencePattern Class See Also
Gets or sets the number of occurrences for the recurrence pattern. This property allows the definition of a recurrence pattern that is only valid for the specified number of subsequent occurrences. For example, you can set this property to 10 for a formal training course that will be held on the next ten Thursday evenings. The default value is 0.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public int Occurrences { get; set; }
Visual Basic
Public Property Occurrences As Integer
    Get
    Set

Remarks

This property must be coordinated with other properties when setting up a recurrence pattern. If the PatternEndDate property or the Occurrences property is set, the pattern is considered to be finite and the NoEndDate property is false. If neither PatternEndDate nor Occurrences is set, the pattern is considered infinite and NoEndDate is true.

See Also

RecurrencePattern Class
C1.C1Schedule Namespace


ParentAppointment Property

[image]

.NET Framework Class Library
RecurrencePattern..::..ParentAppointment Property
RecurrencePattern Class See Also
Gets the Appointment object which represents the master appointment for this RecurrencePattern object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Appointment ParentAppointment { get; }
Visual Basic
Public ReadOnly Property ParentAppointment As Appointment
    Get

See Also

RecurrencePattern Class
C1.C1Schedule Namespace


PatternEndDate Property

[image]

.NET Framework Class Library
RecurrencePattern..::..PatternEndDate Property
RecurrencePattern Class See Also
Gets or sets the DateTime value indicating the end date of the recurrence pattern.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTime PatternEndDate { get; set; }
Visual Basic
Public Property PatternEndDate As DateTime
    Get
    Set

Remarks

This property is optional but must be coordinated with other properties when setting up a recurrence pattern. If this property or the Occurrences property is set, the pattern is considered to be finite, and the NoEndDate property is false. If neither PatternEndDate nor Occurrences is set, the pattern is considered infinite and NoEndDate is true. The Interval property must be set before setting PatternEndDate.

See Also

RecurrencePattern Class
C1.C1Schedule Namespace


PatternStartDate Property

[image]

.NET Framework Class Library
RecurrencePattern..::..PatternStartDate Property
RecurrencePattern Class See Also
Gets or sets the DateTime value indicating the start date of the recurrence pattern.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTime PatternStartDate { get; set; }
Visual Basic
Public Property PatternStartDate As DateTime
    Get
    Set

See Also

RecurrencePattern Class
C1.C1Schedule Namespace


RecurrenceType Property

[image]

.NET Framework Class Library
RecurrencePattern..::..RecurrenceType Property
RecurrencePattern Class See Also
Gets or sets the RecurrenceTypeEnum value determining the type of recurrence (daily, monthly, etc.). Default value is RecurrenceTypeEnum.Weekly.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public RecurrenceTypeEnum RecurrenceType { get; set; }
Visual Basic
Public Property RecurrenceType As RecurrenceTypeEnum
    Get
    Set

See Also

RecurrencePattern Class
C1.C1Schedule Namespace


RemovedOccurrences Property

[image]

.NET Framework Class Library
RecurrencePattern..::..RemovedOccurrences Property
RecurrencePattern Class See Also
Gets the AppointmentList object which holds the list of Appointment objects removed from that series of appointments.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public AppointmentList RemovedOccurrences { get; }
Visual Basic
Public ReadOnly Property RemovedOccurrences As AppointmentList
    Get

See Also

RecurrencePattern Class
C1.C1Schedule Namespace


StartTime Property

[image]

.NET Framework Class Library
RecurrencePattern..::..StartTime Property
RecurrencePattern Class See Also
Gets or sets the DateTime value indicating the start time for the given occurrence of the recurrence pattern.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTime StartTime { get; set; }
Visual Basic
Public Property StartTime As DateTime
    Get
    Set

See Also

RecurrencePattern Class
C1.C1Schedule Namespace


RecurrencePattern Events

[image] [image]

.NET Framework Class Library
RecurrencePattern Events
RecurrencePattern Class See Also

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged |

See Also

RecurrencePattern Class
C1.C1Schedule Namespace


INotifyPropertyChanged.PropertyChanged Event

[image]

.NET Framework Class Library
RecurrencePattern..::..INotifyPropertyChanged..::..PropertyChanged Event
RecurrencePattern Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
event PropertyChangedEventHandler INotifyPropertyChanged.PropertyChanged
Visual Basic
Private Event PropertyChanged As PropertyChangedEventHandler
    Implements INotifyPropertyChanged.PropertyChanged

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

RecurrencePattern Class
C1.C1Schedule Namespace


RecurrenceStateEnum Enumeration

[image]

.NET Framework Class Library
RecurrenceStateEnum Enumeration
See Also
Determines the type of the Appointment object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public enum RecurrenceStateEnum
Visual Basic
Public Enumeration RecurrenceStateEnum

Members

Member name | Description
NotRecurring | Represents a standard (non-recurring) appointment.
Master | Represents the appointment which serves as the pattern for the other recurring appointments. The pattern for recurring appointments is specified via the Appointment.Recurrence property.
Occurrence | Represents one of recurring appointments whose pattern appointment is specified via the Appointment.Recurrence property.
Exception | Represents a recurring appointment, which was changed and now doesn't satisfy the pattern of the recurring series.
Removed | Represents a recurring appointment, which was deleted and now doesn't satisfy the pattern of the recurring series.

See Also

C1.C1Schedule Namespace


RecurrenceTypeEnum Enumeration

[image]

.NET Framework Class Library
RecurrenceTypeEnum Enumeration
See Also
Determines the types of recurrent appointments.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public enum RecurrenceTypeEnum
Visual Basic
Public Enumeration RecurrenceTypeEnum

Members

Member name | Description
Daily | The recurring appointment reoccurs on a daily basis.
Workdays | The recurring appointment reoccurs every working day.
Monthly | The recurring appointment reoccurs on a monthly basis.
MonthlyNth | The recurring appointment reoccurs every N months.
Weekly | The recurring appointment reoccurs on a weekly basis.
Yearly | The recurring appointment reoccurs on an yearly basis.
YearlyNth | The recurring appointment reoccurs every N years.

See Also

C1.C1Schedule Namespace


Reminder Class

[image]

.NET Framework Class Library
Reminder Class
Members See Also
The Reminder class represents an object which allows users to keep track of upcoming appointments by scheduling a pop-up dialog box to appear at a given time.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class Reminder : INotifyPropertyChanged
Visual Basic
Public Class Reminder _
    Implements INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
C1.C1Schedule..::..Reminder

See Also

Reminder Members
C1.C1Schedule Namespace


Reminder Members

[image] [image]

.NET Framework Class Library
Reminder Members
Reminder Class Methods Properties Explicit Interface Implementations See Also

The Reminder type exposes the following members.

Methods

 | Name | Description
Public method | Dismiss | Dismisses the current Reminder object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged |
Public method | Snooze | The Snooze(TimeSpan) method notifies the scheduler to defer the triggering of a reminder by the specified interval.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Caption | Gets the String value representing the window caption text of the Appointment object which the Reminder object is applied to.
Public property | IsActive | Gets a value that determines if the Reminder object is currently active (visible).
Public property | NextReminderDate | Gets the DateTime value indicating the next time the specified reminder will occur.
Public property | OriginalReminderDate | Gets the DateTime value specifying the original date and time that the specified reminder is set to occur. It is calculated using the following formula: OriginalReminderDate = Start - ReminderTimeBeforeStart.
Public property | ParentAppointment | Gets the owning Appointment object.

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged |

See Also

Reminder Class
C1.C1Schedule Namespace


Reminder Methods

[image] [image]

.NET Framework Class Library
Reminder Methods
Reminder Class See Also

The Reminder type exposes the following members.

Methods

 | Name | Description
Public method | Dismiss | Dismisses the current Reminder object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged |
Public method | Snooze | The Snooze(TimeSpan) method notifies the scheduler to defer the triggering of a reminder by the specified interval.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reminder Class
C1.C1Schedule Namespace


Dismiss Method

[image]

.NET Framework Class Library
Reminder..::..Dismiss Method
Reminder Class See Also
Dismisses the current Reminder object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void Dismiss()
Visual Basic
Public Sub Dismiss

See Also

Reminder Class
C1.C1Schedule Namespace


OnPropertyChanged Method

[image]

.NET Framework Class Library
Reminder..::..OnPropertyChanged Method
Reminder Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnPropertyChanged(
    string propertyName
)
Visual Basic
Protected Overridable Sub OnPropertyChanged ( _
    propertyName As String _
)

Parameters

propertyName
Type: System..::..String

See Also

Reminder Class
C1.C1Schedule Namespace


Snooze Method

[image]

.NET Framework Class Library
Reminder..::..Snooze Method
Reminder Class See Also
The Snooze(TimeSpan) method notifies the scheduler to defer the triggering of a reminder by the specified interval.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void Snooze(
    TimeSpan delay
)
Visual Basic
Public Sub Snooze ( _
    delay As TimeSpan _
)

Parameters

delay
Type: System..::..TimeSpan
The TimeSpanvalue specifying the interval of time to wait before displaying the reminder again.

See Also

Reminder Class
C1.C1Schedule Namespace


Reminder Properties

[image] [image]

.NET Framework Class Library
Reminder Properties
Reminder Class See Also

The Reminder type exposes the following members.

Properties

 | Name | Description
Public property | Caption | Gets the String value representing the window caption text of the Appointment object which the Reminder object is applied to.
Public property | IsActive | Gets a value that determines if the Reminder object is currently active (visible).
Public property | NextReminderDate | Gets the DateTime value indicating the next time the specified reminder will occur.
Public property | OriginalReminderDate | Gets the DateTime value specifying the original date and time that the specified reminder is set to occur. It is calculated using the following formula: OriginalReminderDate = Start - ReminderTimeBeforeStart.
Public property | ParentAppointment | Gets the owning Appointment object.

See Also

Reminder Class
C1.C1Schedule Namespace


Caption Property

[image]

.NET Framework Class Library
Reminder..::..Caption Property
Reminder Class See Also
Gets the String value representing the window caption text of the Appointment object which the Reminder object is applied to.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string Caption { get; }
Visual Basic
Public ReadOnly Property Caption As String
    Get

See Also

Reminder Class
C1.C1Schedule Namespace


IsActive Property

[image]

.NET Framework Class Library
Reminder..::..IsActive Property
Reminder Class See Also
Gets a value that determines if the Reminder object is currently active (visible).

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsActive { get; internal set; }
Visual Basic
Public Property IsActive As Boolean
    Get
    Friend Set

See Also

Reminder Class
C1.C1Schedule Namespace


NextReminderDate Property

[image]

.NET Framework Class Library
Reminder..::..NextReminderDate Property
Reminder Class See Also
Gets the DateTime value indicating the next time the specified reminder will occur.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTime NextReminderDate { get; private set; }
Visual Basic
Public Property NextReminderDate As DateTime
    Get
    Private Set

Remarks

The NextReminderDate property value changes every time the object's Snooze(TimeSpan) method is executed or when the user clicks the Snooze button.

See Also

Reminder Class
C1.C1Schedule Namespace


OriginalReminderDate Property

[image]

.NET Framework Class Library
Reminder..::..OriginalReminderDate Property
Reminder Class See Also
Gets the DateTime value specifying the original date and time that the specified reminder is set to occur. It is calculated using the following formula: OriginalReminderDate = Start - ReminderTimeBeforeStart.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTime OriginalReminderDate { get; }
Visual Basic
Public ReadOnly Property OriginalReminderDate As DateTime
    Get

Remarks

This value corresponds to the original date and time value before the Snooze(TimeSpan) method is executed or the user clicks the Snooze button.

See Also

Reminder Class
C1.C1Schedule Namespace


ParentAppointment Property

[image]

.NET Framework Class Library
Reminder..::..ParentAppointment Property
Reminder Class See Also
Gets the owning Appointment object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Appointment ParentAppointment { get; }
Visual Basic
Public ReadOnly Property ParentAppointment As Appointment
    Get

See Also

Reminder Class
C1.C1Schedule Namespace


Reminder Events

[image] [image]

.NET Framework Class Library
Reminder Events
Reminder Class See Also

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged |

See Also

Reminder Class
C1.C1Schedule Namespace


INotifyPropertyChanged.PropertyChanged Event

[image]

.NET Framework Class Library
Reminder..::..INotifyPropertyChanged..::..PropertyChanged Event
Reminder Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
event PropertyChangedEventHandler INotifyPropertyChanged.PropertyChanged
Visual Basic
Private Event PropertyChanged As PropertyChangedEventHandler
    Implements INotifyPropertyChanged.PropertyChanged

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

Reminder Class
C1.C1Schedule Namespace


ReminderCollection Class

[image]

.NET Framework Class Library
ReminderCollection Class
Members See Also
The ReminderCollection is a collection of all Reminder objects that represents the reminders for all pending items.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class ReminderCollection : C1ObservableCollection<Reminder>,
    IDisposable
Visual Basic
Public Class ReminderCollection _
    Inherits C1ObservableCollection(Of Reminder) _
    Implements IDisposable

Remarks

Use the Reminders property to get a reference to the Reminders collection. Reminders are created programmatically when a new Appointment object is created with a reminder. For example, a reminder is created when an Appointment object is created and the ReminderSet property is set to true.

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' Reminder >)>)>
C1.C1Schedule..::..C1ObservableCollection <(Of <(<' Reminder >)>)>
C1.C1Schedule..::..ReminderCollection

See Also

ReminderCollection Members
C1.C1Schedule Namespace


ReminderCollection Members

[image] [image]

.NET Framework Class Library
ReminderCollection Members
ReminderCollection Class Methods Properties Explicit Interface Implementations See Also

The ReminderCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Protected method | ClearItems | Overrides default behavior. (Overrides C1ObservableCollection<(Of <(<'T>)>)>..::..ClearItems()()()().)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Public method | Dispose | Releases all unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Protected method | InsertItem | Overrides default behavior. (Overrides C1ObservableCollection<(Of <(<'T>)>)>..::..InsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Protected method | RemoveItem | Overrides default behavior. (Overrides C1ObservableCollection<(Of <(<'T>)>)>..::..RemoveItem(Int32).)
Protected method | SetItem | Overrides default behavior. (Overrides C1ObservableCollection<(Of <(<'T>)>)>..::..SetItem(Int32, T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Reminder >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' Reminder >)>)>.)

See Also

ReminderCollection Class
C1.C1Schedule Namespace


ReminderCollection Methods

[image] [image]

.NET Framework Class Library
ReminderCollection Methods
ReminderCollection Class See Also

The ReminderCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Protected method | ClearItems | Overrides default behavior. (Overrides C1ObservableCollection<(Of <(<'T>)>)>..::..ClearItems()()()().)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Public method | Dispose | Releases all unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Protected method | InsertItem | Overrides default behavior. (Overrides C1ObservableCollection<(Of <(<'T>)>)>..::..InsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Protected method | RemoveItem | Overrides default behavior. (Overrides C1ObservableCollection<(Of <(<'T>)>)>..::..RemoveItem(Int32).)
Protected method | SetItem | Overrides default behavior. (Overrides C1ObservableCollection<(Of <(<'T>)>)>..::..SetItem(Int32, T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' Reminder >)>)>.)

See Also

ReminderCollection Class
C1.C1Schedule Namespace


ClearItems Method

[image]

.NET Framework Class Library
ReminderCollection..::..ClearItems Method
ReminderCollection Class See Also
Overrides default behavior.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void ClearItems()
Visual Basic
Protected Overrides Sub ClearItems

See Also

ReminderCollection Class
C1.C1Schedule Namespace


Dispose Method

[image]

.NET Framework Class Library
ReminderCollection..::..Dispose Method
ReminderCollection Class See Also
Releases all unmanaged resources.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

See Also

ReminderCollection Class
C1.C1Schedule Namespace


InsertItem Method

[image]

.NET Framework Class Library
ReminderCollection..::..InsertItem Method
ReminderCollection Class See Also
Overrides default behavior.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void InsertItem(
    int index,
    Reminder item
)
Visual Basic
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As Reminder _
)

Parameters

index
Type: System..::..Int32
The zero-based index of the item.
item
Type: C1.C1Schedule..::..Reminder
The Reminder object to insert.

See Also

ReminderCollection Class
C1.C1Schedule Namespace


RemoveItem Method

[image]

.NET Framework Class Library
ReminderCollection..::..RemoveItem Method
ReminderCollection Class See Also
Overrides default behavior.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void RemoveItem(
    int index
)
Visual Basic
Protected Overrides Sub RemoveItem ( _
    index As Integer _
)

Parameters

index
Type: System..::..Int32
The zero-based index of the item to remove.

See Also

ReminderCollection Class
C1.C1Schedule Namespace


SetItem Method

[image]

.NET Framework Class Library
ReminderCollection..::..SetItem Method
ReminderCollection Class See Also
Overrides default behavior.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void SetItem(
    int index,
    Reminder item
)
Visual Basic
Protected Overrides Sub SetItem ( _
    index As Integer, _
    item As Reminder _
)

Parameters

index
Type: System..::..Int32
The zero-based index of the item.
item
Type: C1.C1Schedule..::..Reminder
The Reminder object to set.

See Also

ReminderCollection Class
C1.C1Schedule Namespace


ReminderCollection Properties

[image] [image]

.NET Framework Class Library
ReminderCollection Properties
ReminderCollection Class See Also

The ReminderCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Reminder >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Reminder >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' Reminder >)>)>.)

See Also

ReminderCollection Class
C1.C1Schedule Namespace


ReminderCollection Events

[image] [image]

.NET Framework Class Library
ReminderCollection Events
ReminderCollection Class See Also

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)

See Also

ReminderCollection Class
C1.C1Schedule Namespace


ReminderEventArgs Class

[image]

.NET Framework Class Library
ReminderEventArgs Class
Members See Also
Describes event data for Reminder object events.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class ReminderEventArgs : EventArgs
Visual Basic
Public Class ReminderEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
C1.C1Schedule..::..ReminderEventArgs

See Also

ReminderEventArgs Members
C1.C1Schedule Namespace


ReminderEventArgs Members

[image] [image]

.NET Framework Class Library
ReminderEventArgs Members
ReminderEventArgs Class Constructors Methods Properties See Also

The ReminderEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ReminderEventArgs | Initializes a new instance of the ReminderEventArgs class with the specified Reminder object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Reminder | Gets the reminder which the event was raised for.

See Also

ReminderEventArgs Class
C1.C1Schedule Namespace


ReminderEventArgs Constructor

[image]

.NET Framework Class Library
ReminderEventArgs Constructor
ReminderEventArgs Class See Also
Initializes a new instance of the ReminderEventArgs class with the specified Reminder object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ReminderEventArgs(
    Reminder reminder
)
Visual Basic
Public Sub New ( _
    reminder As Reminder _
)

Parameters

reminder
Type: C1.C1Schedule..::..Reminder
The Reminder object.

See Also

ReminderEventArgs Class
C1.C1Schedule Namespace


ReminderEventArgs Methods

[image] [image]

.NET Framework Class Library
ReminderEventArgs Methods
ReminderEventArgs Class See Also

The ReminderEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReminderEventArgs Class
C1.C1Schedule Namespace


ReminderEventArgs Properties

[image] [image]

.NET Framework Class Library
ReminderEventArgs Properties
ReminderEventArgs Class See Also

The ReminderEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Reminder | Gets the reminder which the event was raised for.

See Also

ReminderEventArgs Class
C1.C1Schedule Namespace


Reminder Property

[image]

.NET Framework Class Library
ReminderEventArgs..::..Reminder Property
ReminderEventArgs Class See Also
Gets the reminder which the event was raised for.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Reminder Reminder { get; }
Visual Basic
Public ReadOnly Property Reminder As Reminder
    Get

See Also

ReminderEventArgs Class
C1.C1Schedule Namespace


Resource Class

[image]

.NET Framework Class Library
Resource Class
Members See Also
The Resource class represents the resource which can be associated with the Appointment object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class Resource : BaseObject
Visual Basic
Public Class Resource _
    Inherits BaseObject

Inheritance Hierarchy

System..::..Object
C1.C1Schedule..::..BasePersistableObject
C1.C1Schedule..::..BaseObject
C1.C1Schedule..::..Resource

See Also

Resource Members
C1.C1Schedule Namespace


Resource Members

[image] [image]

.NET Framework Class Library
Resource Members
Resource Class Constructors Methods Properties Explicit Interface Implementations See Also

The Resource type exposes the following members.

Constructors

 | Name | Description
Public method | Resource()()()() | Creates the new Resource object.
Public method | Resource(Guid) | Initializes a new instance of the Resource class with the specified key.
Public method | Resource(Int32) | Initializes a new instance of the Resource class with the specified key.

Methods

 | Name | Description
Public method | BeginEdit | Brings the object in edit mode. (Inherited from BasePersistableObject.)
Protected method | BeginEditInternal | (Inherited from BasePersistableObject.)
Public method | CancelEdit | Discards changes since the last BeginEdit()()()() call. (Inherited from BasePersistableObject.)
Public method | EndEdit()()()() | Finishes edit mode started by the BeginEdit()()()() method and updates a corresponding data source item. (Inherited from BasePersistableObject.)
Protected method | EndEdit(Boolean) | (Inherited from BasePersistableObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromXml(XmlReader) | Loads an object from the specified XmlReader. (Inherited from BaseObject.)
Public method | FromXml(Stream) | Loads an object from the specified Stream. (Inherited from BasePersistableObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Overrides the default behavior. (Inherited from BasePersistableObject.)
Public method | ToString | Overrides the default behavior. (Inherited from BaseObject.)
Public method | ToXml(XmlWriter) | Saves an object into specified XmlWriter. (Inherited from BaseObject.)
Public method | ToXml(Stream) | Saves an object to the specified Stream. (Inherited from BasePersistableObject.)

Properties

 | Name | Description
Public property | Brush | Gets or sets the brush used to fill the user interface object's image. (Inherited from BaseObject.)
Public property | Color | Gets or sets the color of the user interface object. (Inherited from BaseObject.)
Public property | IsEdit | Indicates whether the object is in edit mode, which is started using the BeginEdit()()()() method. (Inherited from BasePersistableObject.)
Public property | Key | Gets an array of objects representing the key of the BasePersistableObject. (Inherited from BasePersistableObject.)
Public property | MenuCaption | Gets or sets the menu caption for the user interface object. (Inherited from BaseObject.)
Public property | Text | Gets or sets the text which identifies a user interface object. (Inherited from BaseObject.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged | (Inherited from BasePersistableObject.)

See Also

Resource Class
C1.C1Schedule Namespace


Resource Constructor

[image] [image]

.NET Framework Class Library
Resource Constructor
Resource Class See Also

Overload List

 | Name | Description
Public method | Resource()()()() | Creates the new Resource object.
Public method | Resource(Guid) | Initializes a new instance of the Resource class with the specified key.
Public method | Resource(Int32) | Initializes a new instance of the Resource class with the specified key.

See Also

Resource Class
Resource Members
C1.C1Schedule Namespace


Resource Constructor

[image]

.NET Framework Class Library
Resource Constructor
Resource Class See Also
Creates the new Resource object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Resource()
Visual Basic
Public Sub New

See Also

Resource Class
Resource Overload
C1.C1Schedule Namespace


Resource Constructor (Guid)

[image]

.NET Framework Class Library
Resource Constructor (Guid)
Resource Class See Also
Initializes a new instance of the Resource class with the specified key.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Resource(
    Guid key
)
Visual Basic
Public Sub New ( _
    key As Guid _
)

Parameters

key
Type: System..::..Guid
The Guid value which should be used as resource key.

Remarks

Use this constructor if your business logic requires setting custom key value. Make sure that you use the correct constructor overload (with integer or Guid key value) and that key value is unique.

See Also

Resource Class
Resource Overload
C1.C1Schedule Namespace


Resource Constructor (Int32)

[image]

.NET Framework Class Library
Resource Constructor (Int32)
Resource Class See Also
Initializes a new instance of the Resource class with the specified key.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Resource(
    int key
)
Visual Basic
Public Sub New ( _
    key As Integer _
)

Parameters

key
Type: System..::..Int32
The Int32 value which should be used as resource key.

Remarks

Use this constructor if your business logic requires setting custom key value. Make sure that you use the correct constructor overload (with integer or Guid key value) and that key value is unique.

See Also

Resource Class
Resource Overload
C1.C1Schedule Namespace


Resource Methods

[image] [image]

.NET Framework Class Library
Resource Methods
Resource Class See Also

The Resource type exposes the following members.

Methods

 | Name | Description
Public method | BeginEdit | Brings the object in edit mode. (Inherited from BasePersistableObject.)
Protected method | BeginEditInternal | (Inherited from BasePersistableObject.)
Public method | CancelEdit | Discards changes since the last BeginEdit()()()() call. (Inherited from BasePersistableObject.)
Public method | EndEdit()()()() | Finishes edit mode started by the BeginEdit()()()() method and updates a corresponding data source item. (Inherited from BasePersistableObject.)
Protected method | EndEdit(Boolean) | (Inherited from BasePersistableObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromXml(XmlReader) | Loads an object from the specified XmlReader. (Inherited from BaseObject.)
Public method | FromXml(Stream) | Loads an object from the specified Stream. (Inherited from BasePersistableObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Overrides the default behavior. (Inherited from BasePersistableObject.)
Public method | ToString | Overrides the default behavior. (Inherited from BaseObject.)
Public method | ToXml(XmlWriter) | Saves an object into specified XmlWriter. (Inherited from BaseObject.)
Public method | ToXml(Stream) | Saves an object to the specified Stream. (Inherited from BasePersistableObject.)

See Also

Resource Class
C1.C1Schedule Namespace


EndEdit Method

[image] [image]

.NET Framework Class Library
Resource..::..EndEdit Method
Resource Class See Also

Overload List

 | Name | Description
Public method | EndEdit()()()() | Finishes edit mode started by the BeginEdit()()()() method and updates a corresponding data source item. (Inherited from BasePersistableObject.)
Protected method | EndEdit(Boolean) | (Inherited from BasePersistableObject.)

See Also

Resource Class
Resource Members
C1.C1Schedule Namespace


FromXml Method

[image] [image]

.NET Framework Class Library
Resource..::..FromXml Method
Resource Class See Also

Overload List

 | Name | Description
Public method | FromXml(XmlReader) | Loads an object from the specified XmlReader. (Inherited from BaseObject.)
Public method | FromXml(Stream) | Loads an object from the specified Stream. (Inherited from BasePersistableObject.)

See Also

Resource Class
Resource Members
C1.C1Schedule Namespace


ToXml Method

[image] [image]

.NET Framework Class Library
Resource..::..ToXml Method
Resource Class See Also

Overload List

 | Name | Description
Public method | ToXml(XmlWriter) | Saves an object into specified XmlWriter. (Inherited from BaseObject.)
Public method | ToXml(Stream) | Saves an object to the specified Stream. (Inherited from BasePersistableObject.)

See Also

Resource Class
Resource Members
C1.C1Schedule Namespace


Resource Properties

[image] [image]

.NET Framework Class Library
Resource Properties
Resource Class See Also

The Resource type exposes the following members.

Properties

 | Name | Description
Public property | Brush | Gets or sets the brush used to fill the user interface object's image. (Inherited from BaseObject.)
Public property | Color | Gets or sets the color of the user interface object. (Inherited from BaseObject.)
Public property | IsEdit | Indicates whether the object is in edit mode, which is started using the BeginEdit()()()() method. (Inherited from BasePersistableObject.)
Public property | Key | Gets an array of objects representing the key of the BasePersistableObject. (Inherited from BasePersistableObject.)
Public property | MenuCaption | Gets or sets the menu caption for the user interface object. (Inherited from BaseObject.)
Public property | Text | Gets or sets the text which identifies a user interface object. (Inherited from BaseObject.)

See Also

Resource Class
C1.C1Schedule Namespace


Resource Events

[image] [image]

.NET Framework Class Library
Resource Events
Resource Class See Also

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged | (Inherited from BasePersistableObject.)

See Also

Resource Class
C1.C1Schedule Namespace


ResourceCollection Class

[image]

.NET Framework Class Library
ResourceCollection Class
Members See Also
The ResourceCollection is a collection of Resource objects which represents all available resources in C1Schedule object model.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class ResourceCollection : BaseCollection<Resource>
Visual Basic
Public Class ResourceCollection _
    Inherits BaseCollection(Of Resource)

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' Resource >)>)>
System.Collections.ObjectModel..::..KeyedCollection <(Of <(<' Guid, Resource >)>)>
C1.C1Schedule..::..C1ObservableKeyedCollection <(Of <(<' Guid, Resource >)>)>
C1.C1Schedule..::..BaseCollection <(Of <(<' Resource >)>)>
C1.C1Schedule..::..ResourceCollection

See Also

ResourceCollection Members
C1.C1Schedule Namespace


ResourceCollection Members

[image] [image]

.NET Framework Class Library
ResourceCollection Members
ResourceCollection Class Constructors Methods Properties Explicit Interface Implementations See Also

The ResourceCollection type exposes the following members.

Constructors

 | Name | Description
Public method | ResourceCollection | Initializes a new instance of the ResourceCollection class.

Methods

 | Name | Description
Public method | Add | Adds a new custom object to the collection. If the item already exists in the collection, its index is returned. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | AddRange(array<T>[]()[][]) | Adds an array of objects to the collection. This methods clears the collection before adding new items. Don't use it if you want to keep preexisting items. (Inherited from BaseCollection<(Of <(<'T>)>)> BaseCollection<(Of <(<'T>)>)>.)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection <(Of <(<' Guid, Resource >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Protected method | ClearItems | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(Int32) | Check if collection contains an item with specified index. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' Guid, Resource >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)> Collection<(Of <(<'T>)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKeyForItem | Extracts the key from the specified element. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Protected method | InsertItem | Overrides default behavior of collection at inserting new items. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, Resource >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)> Collection<(Of <(<'T>)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Protected method | RemoveItem | Overrides base class implementation. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Protected method | SetItem | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection <(Of <(<' Guid, Resource >)>)>.)
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, Resource >)>)>.)
Public property | Item[([( Guid])]) | Gets the element with the specified key if any. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Resource >)>)> Collection<(Of <(<'T>)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Protected property | OwnerInternal | (Inherited from BaseCollection<(Of <(<'T>)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' Resource >)>)>.)

See Also

ResourceCollection Class
C1.C1Schedule Namespace


ResourceCollection Constructor

[image]

.NET Framework Class Library
ResourceCollection Constructor
ResourceCollection Class See Also
Initializes a new instance of the ResourceCollection class.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ResourceCollection()
Visual Basic
Public Sub New

See Also

ResourceCollection Class
C1.C1Schedule Namespace


ResourceCollection Methods

[image] [image]

.NET Framework Class Library
ResourceCollection Methods
ResourceCollection Class See Also

The ResourceCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a new custom object to the collection. If the item already exists in the collection, its index is returned. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | AddRange(array<T>[]()[][]) | Adds an array of objects to the collection. This methods clears the collection before adding new items. Don't use it if you want to keep preexisting items. (Inherited from BaseCollection<(Of <(<'T>)>)> BaseCollection<(Of <(<'T>)>)>.)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection <(Of <(<' Guid, Resource >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Protected method | ClearItems | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(Int32) | Check if collection contains an item with specified index. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' Guid, Resource >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)> Collection<(Of <(<'T>)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKeyForItem | Extracts the key from the specified element. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Protected method | InsertItem | Overrides default behavior of collection at inserting new items. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, Resource >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)> Collection<(Of <(<'T>)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Protected method | RemoveItem | Overrides base class implementation. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Protected method | SetItem | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' Resource >)>)>.)

See Also

ResourceCollection Class
C1.C1Schedule Namespace


Contains Method

[image] [image]

.NET Framework Class Library
ResourceCollection..::..Contains Method
ResourceCollection Class See Also

Overload List

 | Name | Description
Public method | Contains(Int32) | Check if collection contains an item with specified index. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' Guid, Resource >)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)

See Also

ResourceCollection Class
ResourceCollection Members
C1.C1Schedule Namespace


Remove Method

[image] [image]

.NET Framework Class Library
ResourceCollection..::..Remove Method
ResourceCollection Class See Also

Overload List

 | Name | Description
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, Resource >)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)

See Also

ResourceCollection Class
ResourceCollection Members
C1.C1Schedule Namespace


ResourceCollection Properties

[image] [image]

.NET Framework Class Library
ResourceCollection Properties
ResourceCollection Class See Also

The ResourceCollection type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection <(Of <(<' Guid, Resource >)>)>.)
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, Resource >)>)>.)
Public property | Item[([( Guid])]) | Gets the element with the specified key if any. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Resource >)>)> Collection<(Of <(<'T>)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Protected property | OwnerInternal | (Inherited from BaseCollection<(Of <(<'T>)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' Resource >)>)>.)

See Also

ResourceCollection Class
C1.C1Schedule Namespace


Item Property

[image] [image]

.NET Framework Class Library
ResourceCollection..::..Item Property
ResourceCollection Class See Also

Overload List

 | Name | Description
Public property | Item[([( Guid])]) | Gets the element with the specified key if any. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Resource >)>)>.)

See Also

ResourceCollection Class
ResourceCollection Members
C1.C1Schedule Namespace


ResourceCollection Events

[image] [image]

.NET Framework Class Library
ResourceCollection Events
ResourceCollection Class See Also

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)

See Also

ResourceCollection Class
C1.C1Schedule Namespace


ResourceList Class

[image]

.NET Framework Class Library
ResourceList Class
Members See Also
The ResourceList is a list of Resource objects. Only objects existing in the owning ResourceCollection object may be added to this list. Use the ResourceList to associate the set of Resource objects with an Appointment object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class ResourceList : BaseList<Resource>
Visual Basic
Public Class ResourceList _
    Inherits BaseList(Of Resource)

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' Resource >)>)>
C1.C1Schedule..::..C1ObservableCollection <(Of <(<' Resource >)>)>
C1.C1Schedule..::..BaseList <(Of <(<' Resource >)>)>
C1.C1Schedule..::..ResourceList

See Also

ResourceList Members
C1.C1Schedule Namespace


ResourceList Members

[image] [image]

.NET Framework Class Library
ResourceList Members
ResourceList Class Methods Properties Explicit Interface Implementations See Also

The ResourceList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Protected method | ClearItems | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Protected method | InsertItem | Overrides default behavior of Collection. Prevents from adding items non-existent in the parent collection. (Inherited from BaseList<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Protected method | RemoveItem | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Protected method | SetItem | Overrides default behavior of Collection. Prevents from adding items non-existent in the parent collection. (Inherited from BaseList<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from BaseList<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Protected property | Owner | Gets the reference to the owning collection. (Inherited from BaseList<(Of <(<'T>)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' Resource >)>)>.)

See Also

ResourceList Class
C1.C1Schedule Namespace


ResourceList Methods

[image] [image]

.NET Framework Class Library
ResourceList Methods
ResourceList Class See Also

The ResourceList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Protected method | ClearItems | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Protected method | InsertItem | Overrides default behavior of Collection. Prevents from adding items non-existent in the parent collection. (Inherited from BaseList<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Protected method | RemoveItem | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Protected method | SetItem | Overrides default behavior of Collection. Prevents from adding items non-existent in the parent collection. (Inherited from BaseList<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from BaseList<(Of <(<'T>)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' Resource >)>)>.)

See Also

ResourceList Class
C1.C1Schedule Namespace


ResourceList Properties

[image] [image]

.NET Framework Class Library
ResourceList Properties
ResourceList Class See Also

The ResourceList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Protected property | Owner | Gets the reference to the owning collection. (Inherited from BaseList<(Of <(<'T>)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Resource >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' Resource >)>)>.)

See Also

ResourceList Class
C1.C1Schedule Namespace


ResourceList Events

[image] [image]

.NET Framework Class Library
ResourceList Events
ResourceList Class See Also

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)

See Also

ResourceList Class
C1.C1Schedule Namespace


ResourceStorage Class

[image]

.NET Framework Class Library
ResourceStorage Class
Members See Also
The ResourceStorage is the storage for Resource objects. It allows binding to the data source and mapping data source fields to the resource properties.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class ResourceStorage : BaseStorage<Resource, BaseObjectMappingCollection<Resource>>
Visual Basic
Public Class ResourceStorage _
    Inherits BaseStorage(Of Resource, BaseObjectMappingCollection(Of Resource))

Inheritance Hierarchy

System..::..Object
C1.C1Schedule..::..C1BindingSource
C1.C1Schedule..::..BaseStorage <(Of <(<' Resource, BaseObjectMappingCollection <(Of <(<' Resource >)>)>>)>)>
C1.C1Schedule..::..ResourceStorage

See Also

ResourceStorage Members
C1.C1Schedule Namespace


ResourceStorage Members

[image] [image]

.NET Framework Class Library
ResourceStorage Members
ResourceStorage Class Methods Properties Events Explicit Interface Implementations See Also

The ResourceStorage type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an existing item to the internal list. (Inherited from C1BindingSource.)
Public method | AddNew | Adds a new item to the underlying list. (Inherited from C1BindingSource.)
Public method | BeginEdit | Starts an edit operation on the specified object. (Inherited from C1BindingSource.)
Public method | Clear | Removes all elements from the list. (Inherited from C1BindingSource.)
Public method | Contains | Determines whether an object is an item in the list. (Inherited from C1BindingSource.)
Public method | CopyTo | Copies the contents of the List to the specified array, starting at the specified index value. (Inherited from C1BindingSource.)
Public method | EndEdit | Applies pending changes to the underlying data source. (Inherited from C1BindingSource.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FinishAddNew | Commits a pending new item to the collection. (Inherited from C1BindingSource.)
Public method | GetEnumerator | Retrieves an enumerator for the List. (Inherited from C1BindingSource.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the index of the first occurrence within the entire list. (Inherited from C1BindingSource.)
Public method | Insert | Inserts an item into the list at the specified index. (Inherited from C1BindingSource.)
Protected method | IsSynchronizable | Indicates whether the specified collection item should be synchronized. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAddingNew | (Inherited from C1BindingSource.)
Protected method | OnDataMemberChanged | (Inherited from C1BindingSource.)
Protected method | OnDataSourceChanged | (Inherited from C1BindingSource.)
Protected method | OnDataSourceItemSynchronized | Raises the DataSourceItemSynchronized()()()() event. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Protected method | OnListChanged | Translates changes in the internal list to the Objects collection. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | RefreshData | Call this method each time after changing your data source if it doesn't implement IBindingList interface. Or use BaseStorage{T, TMappingCollection}.Add and BaseStorage{T, TMappingCollection}.Remove instead of corresponding methods of your data source class. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | Remove | Removes object from the Objects collection. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | RemoveAt | Removes the item at the specified index in the list. (Inherited from C1BindingSource.)
Public method | ResetBindings | Causes a control bound to the C1BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from C1BindingSource.)
Public method | ResetItem | Causes a control bound to the C1BindingSource to re-read the item at the specified index, and refresh its displayed value. (Inherited from C1BindingSource.)
Protected method | ShouldSerializeMappings | (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowEdit | Gets a value indicating whether items in the underlying list can be edited. (Inherited from C1BindingSource.)
Public property | AllowNew | Gets or sets a value indicating whether the AddNew()()()() method can be used to add items to the list. (Inherited from C1BindingSource.)
Public property | AllowRemove | Gets a value indicating whether items can be removed from the underlying list. (Inherited from C1BindingSource.)
Public property | BoundMode | Gets a value indicating if the collection is bound to data. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | Count | Gets the total number of items in the underlying list. (Inherited from C1BindingSource.)
Protected property | DataKeyNamesInternal | This property is for internal use only. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | DataMember | Gets or sets the specific list in the data source to which the connector currently binds to. (Inherited from C1BindingSource.)
Public property | DataSource | Gets or sets the data source that the connector binds to. (Inherited from C1BindingSource.)
Public property | IsFixedSize | Gets a value indicating whether the underlying list has a fixed size. (Inherited from C1BindingSource.)
Public property | IsReadOnly | Gets a value indicating whether the underlying list is read-only. (Inherited from C1BindingSource.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from C1BindingSource.)
Public property | Item | Gets or sets the list element at the specified index. (Inherited from C1BindingSource.)
Public property | List | Gets the list that the connector is bound to. (Inherited from C1BindingSource.)
Public property | Mappings | Gets or sets the MappingCollectionBase<(Of <(<'T>)>)> derived object that allows the properties of objects maintained by the current collection to be bound to the appropriate fields in the data source. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | Resources | Gets the ResourceCollection object that contains resource related information.
Public property | ScheduleStorage | Gets the reference to the owning C1ScheduleStorage component. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | SupportsChangeNotification | Gets a value indicating whether the data source supports change notification. (Inherited from C1BindingSource.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the underlying list. (Inherited from C1BindingSource.)

Events

 | Name | Description
Public event | AddingNew | Occurs before an item is added to the underlying list. (Inherited from C1BindingSource.)
Public event | DataMemberChanged | Occurs when the DataMember property value has changed. (Inherited from C1BindingSource.)
Public event | DataSourceChanged | Occurs when the DataSource property value has changed. (Inherited from C1BindingSource.)
Public event | ListChanged | Occurs when the underlying list changes or an item in the list changes. (Inherited from C1BindingSource.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitialize..::..BeginInit | (Inherited from C1BindingSource.)
Explicit interface implemetation | ISupportInitialize..::..EndInit | (Inherited from C1BindingSource.)
Explicit interface implemetation | ISupportInitializeNotification..::..Initialized | (Inherited from C1BindingSource.)
Explicit interface implemetation | ISupportInitializeNotification..::..IsInitialized | (Inherited from C1BindingSource.)

See Also

ResourceStorage Class
C1.C1Schedule Namespace


ResourceStorage Methods

[image] [image]

.NET Framework Class Library
ResourceStorage Methods
ResourceStorage Class See Also

The ResourceStorage type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an existing item to the internal list. (Inherited from C1BindingSource.)
Public method | AddNew | Adds a new item to the underlying list. (Inherited from C1BindingSource.)
Public method | BeginEdit | Starts an edit operation on the specified object. (Inherited from C1BindingSource.)
Public method | Clear | Removes all elements from the list. (Inherited from C1BindingSource.)
Public method | Contains | Determines whether an object is an item in the list. (Inherited from C1BindingSource.)
Public method | CopyTo | Copies the contents of the List to the specified array, starting at the specified index value. (Inherited from C1BindingSource.)
Public method | EndEdit | Applies pending changes to the underlying data source. (Inherited from C1BindingSource.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FinishAddNew | Commits a pending new item to the collection. (Inherited from C1BindingSource.)
Public method | GetEnumerator | Retrieves an enumerator for the List. (Inherited from C1BindingSource.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the index of the first occurrence within the entire list. (Inherited from C1BindingSource.)
Public method | Insert | Inserts an item into the list at the specified index. (Inherited from C1BindingSource.)
Protected method | IsSynchronizable | Indicates whether the specified collection item should be synchronized. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAddingNew | (Inherited from C1BindingSource.)
Protected method | OnDataMemberChanged | (Inherited from C1BindingSource.)
Protected method | OnDataSourceChanged | (Inherited from C1BindingSource.)
Protected method | OnDataSourceItemSynchronized | Raises the DataSourceItemSynchronized()()()() event. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Protected method | OnListChanged | Translates changes in the internal list to the Objects collection. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | RefreshData | Call this method each time after changing your data source if it doesn't implement IBindingList interface. Or use BaseStorage{T, TMappingCollection}.Add and BaseStorage{T, TMappingCollection}.Remove instead of corresponding methods of your data source class. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | Remove | Removes object from the Objects collection. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | RemoveAt | Removes the item at the specified index in the list. (Inherited from C1BindingSource.)
Public method | ResetBindings | Causes a control bound to the C1BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from C1BindingSource.)
Public method | ResetItem | Causes a control bound to the C1BindingSource to re-read the item at the specified index, and refresh its displayed value. (Inherited from C1BindingSource.)
Protected method | ShouldSerializeMappings | (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitialize..::..BeginInit | (Inherited from C1BindingSource.)
Explicit interface implemetation | ISupportInitialize..::..EndInit | (Inherited from C1BindingSource.)

See Also

ResourceStorage Class
C1.C1Schedule Namespace


ResourceStorage Properties

[image] [image]

.NET Framework Class Library
ResourceStorage Properties
ResourceStorage Class See Also

The ResourceStorage type exposes the following members.

Properties

 | Name | Description
Public property | AllowEdit | Gets a value indicating whether items in the underlying list can be edited. (Inherited from C1BindingSource.)
Public property | AllowNew | Gets or sets a value indicating whether the AddNew()()()() method can be used to add items to the list. (Inherited from C1BindingSource.)
Public property | AllowRemove | Gets a value indicating whether items can be removed from the underlying list. (Inherited from C1BindingSource.)
Public property | BoundMode | Gets a value indicating if the collection is bound to data. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | Count | Gets the total number of items in the underlying list. (Inherited from C1BindingSource.)
Protected property | DataKeyNamesInternal | This property is for internal use only. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | DataMember | Gets or sets the specific list in the data source to which the connector currently binds to. (Inherited from C1BindingSource.)
Public property | DataSource | Gets or sets the data source that the connector binds to. (Inherited from C1BindingSource.)
Public property | IsFixedSize | Gets a value indicating whether the underlying list has a fixed size. (Inherited from C1BindingSource.)
Public property | IsReadOnly | Gets a value indicating whether the underlying list is read-only. (Inherited from C1BindingSource.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from C1BindingSource.)
Public property | Item | Gets or sets the list element at the specified index. (Inherited from C1BindingSource.)
Public property | List | Gets the list that the connector is bound to. (Inherited from C1BindingSource.)
Public property | Mappings | Gets or sets the MappingCollectionBase<(Of <(<'T>)>)> derived object that allows the properties of objects maintained by the current collection to be bound to the appropriate fields in the data source. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | Resources | Gets the ResourceCollection object that contains resource related information.
Public property | ScheduleStorage | Gets the reference to the owning C1ScheduleStorage component. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | SupportsChangeNotification | Gets a value indicating whether the data source supports change notification. (Inherited from C1BindingSource.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the underlying list. (Inherited from C1BindingSource.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitializeNotification..::..IsInitialized | (Inherited from C1BindingSource.)

See Also

ResourceStorage Class
C1.C1Schedule Namespace


Resources Property

[image]

.NET Framework Class Library
ResourceStorage..::..Resources Property
ResourceStorage Class See Also
Gets the ResourceCollection object that contains resource related information.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ResourceCollection Resources { get; }
Visual Basic
Public ReadOnly Property Resources As ResourceCollection
    Get

See Also

ResourceStorage Class
C1.C1Schedule Namespace


ResourceStorage Events

[image] [image]

.NET Framework Class Library
ResourceStorage Events
ResourceStorage Class See Also

The ResourceStorage type exposes the following members.

Events

 | Name | Description
Public event | AddingNew | Occurs before an item is added to the underlying list. (Inherited from C1BindingSource.)
Public event | DataMemberChanged | Occurs when the DataMember property value has changed. (Inherited from C1BindingSource.)
Public event | DataSourceChanged | Occurs when the DataSource property value has changed. (Inherited from C1BindingSource.)
Public event | ListChanged | Occurs when the underlying list changes or an item in the list changes. (Inherited from C1BindingSource.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitializeNotification..::..Initialized | (Inherited from C1BindingSource.)

See Also

ResourceStorage Class
C1.C1Schedule Namespace


SensitivityEnum Enumeration

[image]

.NET Framework Class Library
SensitivityEnum Enumeration
See Also
Determines the sensitivity of the Appointment object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public enum SensitivityEnum
Visual Basic
Public Enumeration SensitivityEnum

Members

Member name | Description
Confidential | Confidential
Normal | Normal
Personal | Personal
Private | Private

See Also

C1.C1Schedule Namespace


Status Class

[image]

.NET Framework Class Library
Status Class
Members See Also
The Status class represents an availability status for the Appointment object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class Status : BaseObject
Visual Basic
Public Class Status _
    Inherits BaseObject

Inheritance Hierarchy

System..::..Object
C1.C1Schedule..::..BasePersistableObject
C1.C1Schedule..::..BaseObject
C1.C1Schedule..::..Status

See Also

Status Members
C1.C1Schedule Namespace


Status Members

[image] [image]

.NET Framework Class Library
Status Members
Status Class Constructors Methods Properties Explicit Interface Implementations See Also

The Status type exposes the following members.

Constructors

 | Name | Description
Public method | Status()()()() | Creates the new custom Status object with default parameters.
Public method | Status(Guid) | Initializes a new instance of the Status class with the specified key.
Public method | Status(Int32) | Initializes a new instance of the Status class with the specified key.
Public method | Status(String) | Creates a new instance of the custom Status object with the specified text.
Public method | Status(StatusTypeEnum) | Creates a new instance of the Status class and initializes it with the specified type.
Public method | Status(String, String) | Creates the new custom Status object with specified text and menu caption.
Public method | Status(StatusTypeEnum, CultureInfo) | Creates a new instance of the Status class and initializes it with the specified type.
Public method | Status(Color, String, String) | Creates the new custom Status object with specified color, text and menu caption.
Public method | Status(Color, String, String, C1Brush) | Creates the new custom Status object with specified parameters.

Methods

 | Name | Description
Public method | BeginEdit | Brings the object in edit mode. (Inherited from BasePersistableObject.)
Protected method | BeginEditInternal | (Inherited from BasePersistableObject.)
Public method | CancelEdit | Discards changes since the last BeginEdit()()()() call. (Inherited from BasePersistableObject.)
Public method | EndEdit()()()() | Finishes edit mode started by the BeginEdit()()()() method and updates a corresponding data source item. (Inherited from BasePersistableObject.)
Protected method | EndEdit(Boolean) | (Inherited from BasePersistableObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromXml(XmlReader) | Loads an object from the specified XmlReader. (Inherited from BaseObject.)
Public method | FromXml(Stream) | Loads an object from the specified Stream. (Inherited from BasePersistableObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Overrides the default behavior. (Inherited from BasePersistableObject.)
Public method | ToString | Overrides the default behavior. (Inherited from BaseObject.)
Public method | ToXml(XmlWriter) | Saves an object into specified XmlWriter. (Inherited from BaseObject.)
Public method | ToXml(Stream) | Saves an object to the specified Stream. (Inherited from BasePersistableObject.)

Properties

 | Name | Description
Public property | Brush | Gets or sets the brush used to fill the user interface object's image. (Inherited from BaseObject.)
Public property | Color | Gets or sets the color of the user interface object. (Inherited from BaseObject.)
Public property | IsEdit | Indicates whether the object is in edit mode, which is started using the BeginEdit()()()() method. (Inherited from BasePersistableObject.)
Public property | Key | Gets an array of objects representing the key of the BasePersistableObject. (Inherited from BasePersistableObject.)
Public property | MenuCaption | Gets or sets the menu caption for the user interface object. (Inherited from BaseObject.)
Public property | StatusType | Gets the StatusTypeEnum value determining the type of the status.
Public property | Text | Gets or sets the text which identifies a user interface object. (Inherited from BaseObject.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged | (Inherited from BasePersistableObject.)

See Also

Status Class
C1.C1Schedule Namespace


Status Constructor

[image] [image]

.NET Framework Class Library
Status Constructor
Status Class See Also

Overload List

 | Name | Description
Public method | Status()()()() | Creates the new custom Status object with default parameters.
Public method | Status(Guid) | Initializes a new instance of the Status class with the specified key.
Public method | Status(Int32) | Initializes a new instance of the Status class with the specified key.
Public method | Status(String) | Creates a new instance of the custom Status object with the specified text.
Public method | Status(StatusTypeEnum) | Creates a new instance of the Status class and initializes it with the specified type.
Public method | Status(String, String) | Creates the new custom Status object with specified text and menu caption.
Public method | Status(StatusTypeEnum, CultureInfo) | Creates a new instance of the Status class and initializes it with the specified type.
Public method | Status(Color, String, String) | Creates the new custom Status object with specified color, text and menu caption.
Public method | Status(Color, String, String, C1Brush) | Creates the new custom Status object with specified parameters.

See Also

Status Class
Status Members
C1.C1Schedule Namespace


Status Constructor

[image]

.NET Framework Class Library
Status Constructor
Status Class See Also
Creates the new custom Status object with default parameters.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Status()
Visual Basic
Public Sub New

See Also

Status Class
Status Overload
C1.C1Schedule Namespace


Status Constructor (Guid)

[image]

.NET Framework Class Library
Status Constructor (Guid)
Status Class See Also
Initializes a new instance of the Status class with the specified key.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Status(
    Guid key
)
Visual Basic
Public Sub New ( _
    key As Guid _
)

Parameters

key
Type: System..::..Guid
The Guid value which should be used as status key.

Remarks

Use this constructor if your business logic requires setting custom key value. Make sure that you use the correct constructor overload (with integer or Guid key value) and that key value is unique.

See Also

Status Class
Status Overload
C1.C1Schedule Namespace


Status Constructor (Int32)

[image]

.NET Framework Class Library
Status Constructor (Int32)
Status Class See Also
Initializes a new instance of the Status class with the specified key.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Status(
    int key
)
Visual Basic
Public Sub New ( _
    key As Integer _
)

Parameters

key
Type: System..::..Int32
The Int32 value which should be used as status key.

Remarks

Use this constructor if your business logic requires setting custom key value. Make sure that you use the correct constructor overload (with integer or Guid key value) and that key value is unique.

See Also

Status Class
Status Overload
C1.C1Schedule Namespace


Status Constructor (String)

[image]

.NET Framework Class Library
Status Constructor (String)
Status Class See Also
Creates a new instance of the custom Status object with the specified text.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Status(
    string text
)
Visual Basic
Public Sub New ( _
    text As String _
)

Parameters

text
Type: System..::..String
The String value.

See Also

Status Class
Status Overload
C1.C1Schedule Namespace


Status Constructor (StatusTypeEnum)

[image]

.NET Framework Class Library
Status Constructor (StatusTypeEnum)
Status Class See Also
Creates a new instance of the Status class and initializes it with the specified type.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Status(
    StatusTypeEnum type
)
Visual Basic
Public Sub New ( _
    type As StatusTypeEnum _
)

Parameters

type
Type: C1.C1Schedule..::..StatusTypeEnum
The StatusTypeEnum value.

See Also

Status Class
Status Overload
C1.C1Schedule Namespace


Status Constructor (String, String)

[image]

.NET Framework Class Library
Status Constructor (String, String)
Status Class See Also
Creates the new custom Status object with specified text and menu caption.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Status(
    string text,
    string menuCaption
)
Visual Basic
Public Sub New ( _
    text As String, _
    menuCaption As String _
)

Parameters

text
Type: System..::..String
The String value.
menuCaption
Type: System..::..String
The menu caption for displaying status in dialogs.

See Also

Status Class
Status Overload
C1.C1Schedule Namespace


Status Constructor (StatusTypeEnum, CultureInfo)

[image]

.NET Framework Class Library
Status Constructor (StatusTypeEnum, CultureInfo)
Status Class See Also
Creates a new instance of the Status class and initializes it with the specified type.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Status(
    StatusTypeEnum type,
    CultureInfo culture
)
Visual Basic
Public Sub New ( _
    type As StatusTypeEnum, _
    culture As CultureInfo _
)

Parameters

type
Type: C1.C1Schedule..::..StatusTypeEnum
The StatusTypeEnum value.
culture
Type: System.Globalization..::..CultureInfo
The CultureInfo value.

See Also

Status Class
Status Overload
C1.C1Schedule Namespace


Status Constructor (Color, String, String)

[image]

.NET Framework Class Library
Status Constructor (Color, String, String)
Status Class See Also
Creates the new custom Status object with specified color, text and menu caption.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Status(
    Color color,
    string text,
    string menuCaption
)
Visual Basic
Public Sub New ( _
    color As Color, _
    text As String, _
    menuCaption As String _
)

Parameters

color
Type: System.Windows.Media..::..Color
The color which will be used for displaying status.
text
Type: System..::..String
The String value.
menuCaption
Type: System..::..String
The menu caption for displaying status in dialogs.

See Also

Status Class
Status Overload
C1.C1Schedule Namespace


Status Constructor (Color, String, String, C1Brush)

[image]

.NET Framework Class Library
Status Constructor (Color, String, String, C1Brush)
Status Class See Also
Creates the new custom Status object with specified parameters.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Status(
    Color color,
    string text,
    string menuCaption,
    C1Brush brush
)
Visual Basic
Public Sub New ( _
    color As Color, _
    text As String, _
    menuCaption As String, _
    brush As C1Brush _
)

Parameters

color
Type: System.Windows.Media..::..Color
The color which will be used for displaying status.
text
Type: System..::..String
The String value.
menuCaption
Type: System..::..String
The menu caption for displaying status in dialogs.
brush
Type: C1.C1Schedule..::..C1Brush
The brush which will be used for displaying status.

See Also

Status Class
Status Overload
C1.C1Schedule Namespace


Status Methods

[image] [image]

.NET Framework Class Library
Status Methods
Status Class See Also

The Status type exposes the following members.

Methods

 | Name | Description
Public method | BeginEdit | Brings the object in edit mode. (Inherited from BasePersistableObject.)
Protected method | BeginEditInternal | (Inherited from BasePersistableObject.)
Public method | CancelEdit | Discards changes since the last BeginEdit()()()() call. (Inherited from BasePersistableObject.)
Public method | EndEdit()()()() | Finishes edit mode started by the BeginEdit()()()() method and updates a corresponding data source item. (Inherited from BasePersistableObject.)
Protected method | EndEdit(Boolean) | (Inherited from BasePersistableObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromXml(XmlReader) | Loads an object from the specified XmlReader. (Inherited from BaseObject.)
Public method | FromXml(Stream) | Loads an object from the specified Stream. (Inherited from BasePersistableObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Overrides the default behavior. (Inherited from BasePersistableObject.)
Public method | ToString | Overrides the default behavior. (Inherited from BaseObject.)
Public method | ToXml(XmlWriter) | Saves an object into specified XmlWriter. (Inherited from BaseObject.)
Public method | ToXml(Stream) | Saves an object to the specified Stream. (Inherited from BasePersistableObject.)

See Also

Status Class
C1.C1Schedule Namespace


EndEdit Method

[image] [image]

.NET Framework Class Library
Status..::..EndEdit Method
Status Class See Also

Overload List

 | Name | Description
Public method | EndEdit()()()() | Finishes edit mode started by the BeginEdit()()()() method and updates a corresponding data source item. (Inherited from BasePersistableObject.)
Protected method | EndEdit(Boolean) | (Inherited from BasePersistableObject.)

See Also

Status Class
Status Members
C1.C1Schedule Namespace


FromXml Method

[image] [image]

.NET Framework Class Library
Status..::..FromXml Method
Status Class See Also

Overload List

 | Name | Description
Public method | FromXml(XmlReader) | Loads an object from the specified XmlReader. (Inherited from BaseObject.)
Public method | FromXml(Stream) | Loads an object from the specified Stream. (Inherited from BasePersistableObject.)

See Also

Status Class
Status Members
C1.C1Schedule Namespace


ToXml Method

[image] [image]

.NET Framework Class Library
Status..::..ToXml Method
Status Class See Also

Overload List

 | Name | Description
Public method | ToXml(XmlWriter) | Saves an object into specified XmlWriter. (Inherited from BaseObject.)
Public method | ToXml(Stream) | Saves an object to the specified Stream. (Inherited from BasePersistableObject.)

See Also

Status Class
Status Members
C1.C1Schedule Namespace


Status Properties

[image] [image]

.NET Framework Class Library
Status Properties
Status Class See Also

The Status type exposes the following members.

Properties

 | Name | Description
Public property | Brush | Gets or sets the brush used to fill the user interface object's image. (Inherited from BaseObject.)
Public property | Color | Gets or sets the color of the user interface object. (Inherited from BaseObject.)
Public property | IsEdit | Indicates whether the object is in edit mode, which is started using the BeginEdit()()()() method. (Inherited from BasePersistableObject.)
Public property | Key | Gets an array of objects representing the key of the BasePersistableObject. (Inherited from BasePersistableObject.)
Public property | MenuCaption | Gets or sets the menu caption for the user interface object. (Inherited from BaseObject.)
Public property | StatusType | Gets the StatusTypeEnum value determining the type of the status.
Public property | Text | Gets or sets the text which identifies a user interface object. (Inherited from BaseObject.)

See Also

Status Class
C1.C1Schedule Namespace


StatusType Property

[image]

.NET Framework Class Library
Status..::..StatusType Property
Status Class See Also
Gets the StatusTypeEnum value determining the type of the status.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public StatusTypeEnum StatusType { get; }
Visual Basic
Public ReadOnly Property StatusType As StatusTypeEnum
    Get

See Also

Status Class
C1.C1Schedule Namespace


Status Events

[image] [image]

.NET Framework Class Library
Status Events
Status Class See Also

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged | (Inherited from BasePersistableObject.)

See Also

Status Class
C1.C1Schedule Namespace


StatusCollection Class

[image]

.NET Framework Class Library
StatusCollection Class
Members See Also
The StatusCollection is a collection of Status objects which represents all available statuses in C1Schedule object model. By default it contains the set of predefined statuses.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultMemberAttribute("Item")]
public class StatusCollection : BaseCollection<Status>
Visual Basic
<DefaultMemberAttribute("Item")> _
Public Class StatusCollection _
    Inherits BaseCollection(Of Status)

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' Status >)>)>
System.Collections.ObjectModel..::..KeyedCollection <(Of <(<' Guid, Status >)>)>
C1.C1Schedule..::..C1ObservableKeyedCollection <(Of <(<' Guid, Status >)>)>
C1.C1Schedule..::..BaseCollection <(Of <(<' Status >)>)>
C1.C1Schedule..::..StatusCollection

See Also

StatusCollection Members
C1.C1Schedule Namespace


StatusCollection Members

[image] [image]

.NET Framework Class Library
StatusCollection Members
StatusCollection Class Constructors Methods Properties Explicit Interface Implementations See Also

The StatusCollection type exposes the following members.

Constructors

 | Name | Description
Public method | StatusCollection | Initializes a new instance of the StatusCollection class.

Methods

 | Name | Description
Public method | Add | Adds a new custom object to the collection. If the item already exists in the collection, its index is returned. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | AddRange(array<T>[]()[][]) | Adds an array of objects to the collection. This methods clears the collection before adding new items. Don't use it if you want to keep preexisting items. (Inherited from BaseCollection<(Of <(<'T>)>)> BaseCollection<(Of <(<'T>)>)>.)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection <(Of <(<' Guid, Status >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)
Protected method | ClearItems | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(Int32) | Check if collection contains an item with specified index. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' Guid, Status >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)> Collection<(Of <(<'T>)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Status >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKeyForItem | Extracts the key from the specified element. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Status >)>)>.)
Protected method | InsertItem | Overrides default behavior of collection at inserting new items. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | LoadDefaults | Restores the collection to its default state.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, Status >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)> Collection<(Of <(<'T>)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)
Protected method | RemoveItem | Overrides base class implementation. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Protected method | SetItem | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection <(Of <(<' Guid, Status >)>)>.)
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, Status >)>)>.)
Public property | Item[([( Guid])]) | Gets the element with the specified key if any. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Status >)>)> Collection<(Of <(<'T>)>)>.)
Public property | Item[([( StatusTypeEnum])]) | Gets the Status object specified by the appointment status type. For custom statuses returns the first occurrence. If there is no such Status object in the collection, returns null.
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)
Protected property | OwnerInternal | (Inherited from BaseCollection<(Of <(<'T>)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' Status >)>)>.)

See Also

StatusCollection Class
C1.C1Schedule Namespace


StatusCollection Constructor

[image]

.NET Framework Class Library
StatusCollection Constructor
StatusCollection Class See Also
Initializes a new instance of the StatusCollection class.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public StatusCollection()
Visual Basic
Public Sub New

See Also

StatusCollection Class
C1.C1Schedule Namespace


StatusCollection Methods

[image] [image]

.NET Framework Class Library
StatusCollection Methods
StatusCollection Class See Also

The StatusCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a new custom object to the collection. If the item already exists in the collection, its index is returned. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | AddRange(array<T>[]()[][]) | Adds an array of objects to the collection. This methods clears the collection before adding new items. Don't use it if you want to keep preexisting items. (Inherited from BaseCollection<(Of <(<'T>)>)> BaseCollection<(Of <(<'T>)>)>.)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection <(Of <(<' Guid, Status >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)
Protected method | ClearItems | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(Int32) | Check if collection contains an item with specified index. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' Guid, Status >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)> Collection<(Of <(<'T>)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Status >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKeyForItem | Extracts the key from the specified element. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Status >)>)>.)
Protected method | InsertItem | Overrides default behavior of collection at inserting new items. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | LoadDefaults | Restores the collection to its default state.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, Status >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)> Collection<(Of <(<'T>)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)
Protected method | RemoveItem | Overrides base class implementation. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Protected method | SetItem | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' Status >)>)>.)

See Also

StatusCollection Class
C1.C1Schedule Namespace


Contains Method

[image] [image]

.NET Framework Class Library
StatusCollection..::..Contains Method
StatusCollection Class See Also

Overload List

 | Name | Description
Public method | Contains(Int32) | Check if collection contains an item with specified index. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' Guid, Status >)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)

See Also

StatusCollection Class
StatusCollection Members
C1.C1Schedule Namespace


LoadDefaults Method

[image]

.NET Framework Class Library
StatusCollection..::..LoadDefaults Method
StatusCollection Class See Also
Restores the collection to its default state.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void LoadDefaults()
Visual Basic
Public Sub LoadDefaults

Remarks

The LoadDefaults()()()() method removes all the custom appointment statuses from the collection and leaves only the standard ones.

See Also

StatusCollection Class
C1.C1Schedule Namespace


Remove Method

[image] [image]

.NET Framework Class Library
StatusCollection..::..Remove Method
StatusCollection Class See Also

Overload List

 | Name | Description
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, Status >)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)

See Also

StatusCollection Class
StatusCollection Members
C1.C1Schedule Namespace


StatusCollection Properties

[image] [image]

.NET Framework Class Library
StatusCollection Properties
StatusCollection Class See Also

The StatusCollection type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection <(Of <(<' Guid, Status >)>)>.)
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Guid, Status >)>)>.)
Public property | Item[([( Guid])]) | Gets the element with the specified key if any. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Status >)>)> Collection<(Of <(<'T>)>)>.)
Public property | Item[([( StatusTypeEnum])]) | Gets the Status object specified by the appointment status type. For custom statuses returns the first occurrence. If there is no such Status object in the collection, returns null.
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)
Protected property | OwnerInternal | (Inherited from BaseCollection<(Of <(<'T>)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' Status >)>)>.)

See Also

StatusCollection Class
C1.C1Schedule Namespace


Item Property

[image] [image]

.NET Framework Class Library
StatusCollection..::..Item Property
StatusCollection Class See Also

Overload List

 | Name | Description
Public property | Item[([( Guid])]) | Gets the element with the specified key if any. (Inherited from BaseCollection<(Of <(<'T>)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Status >)>)>.)
Public property | Item[([( StatusTypeEnum])]) | Gets the Status object specified by the appointment status type. For custom statuses returns the first occurrence. If there is no such Status object in the collection, returns null.

See Also

StatusCollection Class
StatusCollection Members
C1.C1Schedule Namespace


Item Property (StatusTypeEnum)

[image]

.NET Framework Class Library
StatusCollection..::..Item Property (StatusTypeEnum)
StatusCollection Class See Also
Gets the Status object specified by the appointment status type. For custom statuses returns the first occurrence. If there is no such Status object in the collection, returns null.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Status this[
    StatusTypeEnum type
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    type As StatusTypeEnum _
) As Status
    Get

Parameters

type
Type: C1.C1Schedule..::..StatusTypeEnum
The StatusTypeEnum value.

Return Value

The Status object.

See Also

StatusCollection Class
Item Overload
C1.C1Schedule Namespace


StatusCollection Events

[image] [image]

.NET Framework Class Library
StatusCollection Events
StatusCollection Class See Also

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)

See Also

StatusCollection Class
C1.C1Schedule Namespace


StatusList Class

[image]

.NET Framework Class Library
StatusList Class
Members See Also
The StatusList is a list of Status objects. Only objects existing in the owning StatusCollection object may be added to this list.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class StatusList : BaseList<Status>
Visual Basic
Public Class StatusList _
    Inherits BaseList(Of Status)

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' Status >)>)>
C1.C1Schedule..::..C1ObservableCollection <(Of <(<' Status >)>)>
C1.C1Schedule..::..BaseList <(Of <(<' Status >)>)>
C1.C1Schedule..::..StatusList

See Also

StatusList Members
C1.C1Schedule Namespace


StatusList Members

[image] [image]

.NET Framework Class Library
StatusList Members
StatusList Class Methods Properties Explicit Interface Implementations See Also

The StatusList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)
Protected method | ClearItems | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Status >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Status >)>)>.)
Protected method | InsertItem | Overrides default behavior of Collection. Prevents from adding items non-existent in the parent collection. (Inherited from BaseList<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)
Protected method | RemoveItem | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Protected method | SetItem | Overrides default behavior of Collection. Prevents from adding items non-existent in the parent collection. (Inherited from BaseList<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from BaseList<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Status >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)
Protected property | Owner | Gets the reference to the owning collection. (Inherited from BaseList<(Of <(<'T>)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' Status >)>)>.)

See Also

StatusList Class
C1.C1Schedule Namespace


StatusList Methods

[image] [image]

.NET Framework Class Library
StatusList Methods
StatusList Class See Also

The StatusList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)
Protected method | ClearItems | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Status >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Status >)>)>.)
Protected method | InsertItem | Overrides default behavior of Collection. Prevents from adding items non-existent in the parent collection. (Inherited from BaseList<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)
Protected method | RemoveItem | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Protected method | SetItem | Overrides default behavior of Collection. Prevents from adding items non-existent in the parent collection. (Inherited from BaseList<(Of <(<'T>)>)>.)
Public method | ToString | (Inherited from BaseList<(Of <(<'T>)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' Status >)>)>.)

See Also

StatusList Class
C1.C1Schedule Namespace


StatusList Properties

[image] [image]

.NET Framework Class Library
StatusList Properties
StatusList Class See Also

The StatusList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Status >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Status >)>)>.)
Protected property | Owner | Gets the reference to the owning collection. (Inherited from BaseList<(Of <(<'T>)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Status >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' Status >)>)>.)

See Also

StatusList Class
C1.C1Schedule Namespace


StatusList Events

[image] [image]

.NET Framework Class Library
StatusList Events
StatusList Class See Also

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)

See Also

StatusList Class
C1.C1Schedule Namespace


StatusStorage Class

[image]

.NET Framework Class Library
StatusStorage Class
Members See Also
The StatusStorage is the storage for Status objects. It allows binding to the data source and mapping data sources fields to the status properties.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class StatusStorage : BaseStorage<Status, BaseObjectMappingCollection<Status>>
Visual Basic
Public Class StatusStorage _
    Inherits BaseStorage(Of Status, BaseObjectMappingCollection(Of Status))

Inheritance Hierarchy

System..::..Object
C1.C1Schedule..::..C1BindingSource
C1.C1Schedule..::..BaseStorage <(Of <(<' Status, BaseObjectMappingCollection <(Of <(<' Status >)>)>>)>)>
C1.C1Schedule..::..StatusStorage

See Also

StatusStorage Members
C1.C1Schedule Namespace


StatusStorage Members

[image] [image]

.NET Framework Class Library
StatusStorage Members
StatusStorage Class Methods Properties Events Explicit Interface Implementations See Also

The StatusStorage type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an existing item to the internal list. (Inherited from C1BindingSource.)
Public method | AddNew | Adds a new item to the underlying list. (Inherited from C1BindingSource.)
Public method | BeginEdit | Starts an edit operation on the specified object. (Inherited from C1BindingSource.)
Public method | Clear | Removes all elements from the list. (Inherited from C1BindingSource.)
Public method | Contains | Determines whether an object is an item in the list. (Inherited from C1BindingSource.)
Public method | CopyTo | Copies the contents of the List to the specified array, starting at the specified index value. (Inherited from C1BindingSource.)
Public method | EndEdit | Applies pending changes to the underlying data source. (Inherited from C1BindingSource.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FinishAddNew | Commits a pending new item to the collection. (Inherited from C1BindingSource.)
Public method | GetEnumerator | Retrieves an enumerator for the List. (Inherited from C1BindingSource.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the index of the first occurrence within the entire list. (Inherited from C1BindingSource.)
Public method | Insert | Inserts an item into the list at the specified index. (Inherited from C1BindingSource.)
Protected method | IsSynchronizable | Indicates whether the specified collection item should be synchronized. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAddingNew | (Inherited from C1BindingSource.)
Protected method | OnDataMemberChanged | (Inherited from C1BindingSource.)
Protected method | OnDataSourceChanged | (Inherited from C1BindingSource.)
Protected method | OnDataSourceItemSynchronized | Raises the DataSourceItemSynchronized()()()() event. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Protected method | OnListChanged | Translates changes in the internal list to the Objects collection. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | RefreshData | Call this method each time after changing your data source if it doesn't implement IBindingList interface. Or use BaseStorage{T, TMappingCollection}.Add and BaseStorage{T, TMappingCollection}.Remove instead of corresponding methods of your data source class. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | Remove | Removes object from the Objects collection. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | RemoveAt | Removes the item at the specified index in the list. (Inherited from C1BindingSource.)
Public method | ResetBindings | Causes a control bound to the C1BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from C1BindingSource.)
Public method | ResetItem | Causes a control bound to the C1BindingSource to re-read the item at the specified index, and refresh its displayed value. (Inherited from C1BindingSource.)
Protected method | ShouldSerializeMappings | (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowEdit | Gets a value indicating whether items in the underlying list can be edited. (Inherited from C1BindingSource.)
Public property | AllowNew | Gets or sets a value indicating whether the AddNew()()()() method can be used to add items to the list. (Inherited from C1BindingSource.)
Public property | AllowRemove | Gets a value indicating whether items can be removed from the underlying list. (Inherited from C1BindingSource.)
Public property | BoundMode | Gets a value indicating if the collection is bound to data. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | Count | Gets the total number of items in the underlying list. (Inherited from C1BindingSource.)
Protected property | DataKeyNamesInternal | This property is for internal use only. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | DataMember | Gets or sets the specific list in the data source to which the connector currently binds to. (Inherited from C1BindingSource.)
Public property | DataSource | Gets or sets the data source that the connector binds to. (Inherited from C1BindingSource.)
Public property | IsFixedSize | Gets a value indicating whether the underlying list has a fixed size. (Inherited from C1BindingSource.)
Public property | IsReadOnly | Gets a value indicating whether the underlying list is read-only. (Inherited from C1BindingSource.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from C1BindingSource.)
Public property | Item | Gets or sets the list element at the specified index. (Inherited from C1BindingSource.)
Public property | List | Gets the list that the connector is bound to. (Inherited from C1BindingSource.)
Public property | Mappings | Gets or sets the MappingCollectionBase<(Of <(<'T>)>)> derived object that allows the properties of objects maintained by the current collection to be bound to the appropriate fields in the data source. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | ScheduleStorage | Gets the reference to the owning C1ScheduleStorage component. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | Statuses | Gets the StatusCollection object that contains status related information.
Public property | SupportsChangeNotification | Gets a value indicating whether the data source supports change notification. (Inherited from C1BindingSource.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the underlying list. (Inherited from C1BindingSource.)

Events

 | Name | Description
Public event | AddingNew | Occurs before an item is added to the underlying list. (Inherited from C1BindingSource.)
Public event | DataMemberChanged | Occurs when the DataMember property value has changed. (Inherited from C1BindingSource.)
Public event | DataSourceChanged | Occurs when the DataSource property value has changed. (Inherited from C1BindingSource.)
Public event | ListChanged | Occurs when the underlying list changes or an item in the list changes. (Inherited from C1BindingSource.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitialize..::..BeginInit | (Inherited from C1BindingSource.)
Explicit interface implemetation | ISupportInitialize..::..EndInit | (Inherited from C1BindingSource.)
Explicit interface implemetation | ISupportInitializeNotification..::..Initialized | (Inherited from C1BindingSource.)
Explicit interface implemetation | ISupportInitializeNotification..::..IsInitialized | (Inherited from C1BindingSource.)

See Also

StatusStorage Class
C1.C1Schedule Namespace


StatusStorage Methods

[image] [image]

.NET Framework Class Library
StatusStorage Methods
StatusStorage Class See Also

The StatusStorage type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an existing item to the internal list. (Inherited from C1BindingSource.)
Public method | AddNew | Adds a new item to the underlying list. (Inherited from C1BindingSource.)
Public method | BeginEdit | Starts an edit operation on the specified object. (Inherited from C1BindingSource.)
Public method | Clear | Removes all elements from the list. (Inherited from C1BindingSource.)
Public method | Contains | Determines whether an object is an item in the list. (Inherited from C1BindingSource.)
Public method | CopyTo | Copies the contents of the List to the specified array, starting at the specified index value. (Inherited from C1BindingSource.)
Public method | EndEdit | Applies pending changes to the underlying data source. (Inherited from C1BindingSource.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FinishAddNew | Commits a pending new item to the collection. (Inherited from C1BindingSource.)
Public method | GetEnumerator | Retrieves an enumerator for the List. (Inherited from C1BindingSource.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the index of the first occurrence within the entire list. (Inherited from C1BindingSource.)
Public method | Insert | Inserts an item into the list at the specified index. (Inherited from C1BindingSource.)
Protected method | IsSynchronizable | Indicates whether the specified collection item should be synchronized. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAddingNew | (Inherited from C1BindingSource.)
Protected method | OnDataMemberChanged | (Inherited from C1BindingSource.)
Protected method | OnDataSourceChanged | (Inherited from C1BindingSource.)
Protected method | OnDataSourceItemSynchronized | Raises the DataSourceItemSynchronized()()()() event. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Protected method | OnListChanged | Translates changes in the internal list to the Objects collection. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | RefreshData | Call this method each time after changing your data source if it doesn't implement IBindingList interface. Or use BaseStorage{T, TMappingCollection}.Add and BaseStorage{T, TMappingCollection}.Remove instead of corresponding methods of your data source class. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | Remove | Removes object from the Objects collection. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | RemoveAt | Removes the item at the specified index in the list. (Inherited from C1BindingSource.)
Public method | ResetBindings | Causes a control bound to the C1BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from C1BindingSource.)
Public method | ResetItem | Causes a control bound to the C1BindingSource to re-read the item at the specified index, and refresh its displayed value. (Inherited from C1BindingSource.)
Protected method | ShouldSerializeMappings | (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitialize..::..BeginInit | (Inherited from C1BindingSource.)
Explicit interface implemetation | ISupportInitialize..::..EndInit | (Inherited from C1BindingSource.)

See Also

StatusStorage Class
C1.C1Schedule Namespace


StatusStorage Properties

[image] [image]

.NET Framework Class Library
StatusStorage Properties
StatusStorage Class See Also

The StatusStorage type exposes the following members.

Properties

 | Name | Description
Public property | AllowEdit | Gets a value indicating whether items in the underlying list can be edited. (Inherited from C1BindingSource.)
Public property | AllowNew | Gets or sets a value indicating whether the AddNew()()()() method can be used to add items to the list. (Inherited from C1BindingSource.)
Public property | AllowRemove | Gets a value indicating whether items can be removed from the underlying list. (Inherited from C1BindingSource.)
Public property | BoundMode | Gets a value indicating if the collection is bound to data. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | Count | Gets the total number of items in the underlying list. (Inherited from C1BindingSource.)
Protected property | DataKeyNamesInternal | This property is for internal use only. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | DataMember | Gets or sets the specific list in the data source to which the connector currently binds to. (Inherited from C1BindingSource.)
Public property | DataSource | Gets or sets the data source that the connector binds to. (Inherited from C1BindingSource.)
Public property | IsFixedSize | Gets a value indicating whether the underlying list has a fixed size. (Inherited from C1BindingSource.)
Public property | IsReadOnly | Gets a value indicating whether the underlying list is read-only. (Inherited from C1BindingSource.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe). (Inherited from C1BindingSource.)
Public property | Item | Gets or sets the list element at the specified index. (Inherited from C1BindingSource.)
Public property | List | Gets the list that the connector is bound to. (Inherited from C1BindingSource.)
Public property | Mappings | Gets or sets the MappingCollectionBase<(Of <(<'T>)>)> derived object that allows the properties of objects maintained by the current collection to be bound to the appropriate fields in the data source. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | ScheduleStorage | Gets the reference to the owning C1ScheduleStorage component. (Inherited from BaseStorage<(Of <(<'T, TMappingCollection>)>)>.)
Public property | Statuses | Gets the StatusCollection object that contains status related information.
Public property | SupportsChangeNotification | Gets a value indicating whether the data source supports change notification. (Inherited from C1BindingSource.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the underlying list. (Inherited from C1BindingSource.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitializeNotification..::..IsInitialized | (Inherited from C1BindingSource.)

See Also

StatusStorage Class
C1.C1Schedule Namespace


Statuses Property

[image]

.NET Framework Class Library
StatusStorage..::..Statuses Property
StatusStorage Class See Also
Gets the StatusCollection object that contains status related information.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public StatusCollection Statuses { get; }
Visual Basic
Public ReadOnly Property Statuses As StatusCollection
    Get

See Also

StatusStorage Class
C1.C1Schedule Namespace


StatusStorage Events

[image] [image]

.NET Framework Class Library
StatusStorage Events
StatusStorage Class See Also

The StatusStorage type exposes the following members.

Events

 | Name | Description
Public event | AddingNew | Occurs before an item is added to the underlying list. (Inherited from C1BindingSource.)
Public event | DataMemberChanged | Occurs when the DataMember property value has changed. (Inherited from C1BindingSource.)
Public event | DataSourceChanged | Occurs when the DataSource property value has changed. (Inherited from C1BindingSource.)
Public event | ListChanged | Occurs when the underlying list changes or an item in the list changes. (Inherited from C1BindingSource.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | ISupportInitializeNotification..::..Initialized | (Inherited from C1BindingSource.)

See Also

StatusStorage Class
C1.C1Schedule Namespace


StatusTypeEnum Enumeration

[image]

.NET Framework Class Library
StatusTypeEnum Enumeration
See Also
Determines the type of status.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public enum StatusTypeEnum
Visual Basic
Public Enumeration StatusTypeEnum

Members

Member name | Description
Free | This status means that a person is in the office and available to others.
Tentative | This status means that a person is in the office and tentatively available to others.
Busy | This status means that a person is in the office but unavailable to others.
OutOfOffice | This status means that a person is out of the office and unavailable to others.
Custom | This status represents all custom statuses added to the StatusCollection.

See Also

C1.C1Schedule Namespace


SynchronizationActionEnum Enumeration

[image]

.NET Framework Class Library
SynchronizationActionEnum Enumeration
See Also
Describes the version of data in a data storage.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public enum SynchronizationActionEnum
Visual Basic
Public Enumeration SynchronizationActionEnum

Members

Member name | Description
Added | A new item.
Deleted | A deleted item.
Changed | A changed item.

See Also

C1.C1Schedule Namespace


TimeScaleEnum Enumeration

[image]

.NET Framework Class Library
TimeScaleEnum Enumeration
See Also
Determines the time interval which is used for displaying time slots in the DayView.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public enum TimeScaleEnum
Visual Basic
Public Enumeration TimeScaleEnum

Members

Member name | Description
FiveMinutes | 5 minutes.
SixMinutes | 6 minutes.
TenMinutes | 10 minutes.
FifteenMinutes | 15 minutes.
TwentyMinutes | 20 minutes.
ThirtyMinutes | 30 minutes.
OneHour | 60 minutes.

See Also

C1.C1Schedule Namespace


WeekDaysEnum Enumeration

[image]

.NET Framework Class Library
WeekDaysEnum Enumeration
See Also
Determines the set of days and groups of days for recurrence patterns.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[FlagsAttribute]
public enum WeekDaysEnum
Visual Basic
<FlagsAttribute> _
Public Enumeration WeekDaysEnum

Members

Member name | Description
None | No specific value; the actual value is obtained from the root Appointment object.
Sunday | Specifies Sunday.
Monday | Specifies Monday.
Tuesday | Specifies Tuesday.
Wednesday | Specifies Wednesday.
Thursday | Specifies Thursday.
Friday | Specifies Friday.
Saturday | Specifies Saturday.
WeekendDays | Specifies Saturday and Sunday (or what ever days according to the settings of the C1Schedule).
WorkDays | Specifies work days (all days except weekend).
EveryDay | Specifies every day of the week.

See Also

C1.C1Schedule Namespace


WeekOfMonthEnum Enumeration

[image]

.NET Framework Class Library
WeekOfMonthEnum Enumeration
See Also
Determines the week in a month in which the appointment will occur.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public enum WeekOfMonthEnum
Visual Basic
Public Enumeration WeekOfMonthEnum

Members

Member name | Description
First | The recurring appointment will occur on the specified day or days of the first week in the month.
Second | The recurring appointment will occur on the specified day or days of the second week in the month.
Third | The recurring appointment will occur on the specified day or days of the third week in the month.
Fourth | The recurring appointment will occur on the specified day or days of the fourth week in the month.
Last | The recurring appointment will occur on the specified day or days of the last week in the month.

See Also

C1.C1Schedule Namespace


WorkDays Class

[image]

.NET Framework Class Library
WorkDays Class
Members See Also
The WorkDays class is a list of working days for the single week.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class WorkDays : List<DayOfWeek>
Visual Basic
Public Class WorkDays _
    Inherits List(Of DayOfWeek)

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List <(Of <(<' DayOfWeek >)>)>
C1.C1Schedule..::..WorkDays

See Also

WorkDays Members
C1.C1Schedule Namespace


WorkDays Members

[image] [image]

.NET Framework Class Library
WorkDays Members
WorkDays Class Constructors Methods Properties Explicit Interface Implementations See Also

The WorkDays type exposes the following members.

Constructors

 | Name | Description
Public method | WorkDays | Initializes a new instance of the WorkDays class.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | AddRange(array<DayOfWeek>[]()[][]) | Creates the new WorkDays object.
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item to the IList at the specified index. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)

See Also

WorkDays Class
C1.C1Schedule Namespace


WorkDays Constructor

[image]

.NET Framework Class Library
WorkDays Constructor
WorkDays Class See Also
Initializes a new instance of the WorkDays class.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public WorkDays()
Visual Basic
Public Sub New

See Also

WorkDays Class
C1.C1Schedule Namespace


WorkDays Methods

[image] [image]

.NET Framework Class Library
WorkDays Methods
WorkDays Class See Also

The WorkDays type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | AddRange(array<DayOfWeek>[]()[][]) | Creates the new WorkDays object.
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' DayOfWeek >)>)> List<(Of <(<'T>)>)>.)
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | ToString | (Overrides Object..::..ToString()()()().)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Explicit interface implemetation | IEnumerable<(Of <<'(T>)>>)..::..GetEnumerator | (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item to the IList at the specified index. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)

See Also

WorkDays Class
C1.C1Schedule Namespace


AddRange Method

[image] [image]

.NET Framework Class Library
WorkDays..::..AddRange Method
WorkDays Class See Also

Overload List

 | Name | Description
Public method | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | AddRange(array<DayOfWeek>[]()[][]) | Creates the new WorkDays object.

See Also

WorkDays Class
WorkDays Members
C1.C1Schedule Namespace


AddRange Method (DayOfWeek[])

[image]

.NET Framework Class Library
WorkDays..::..AddRange Method (array<DayOfWeek>[]()[][])
WorkDays Class See Also
Creates the new WorkDays object.

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void AddRange(
    DayOfWeek[] items
)
Visual Basic
Public Sub AddRange ( _
    items As DayOfWeek() _
)

Parameters

items
Type: array< System..::..DayOfWeek >[]()[][]
The array of DayOfWeek objects.

See Also

WorkDays Class
AddRange Overload
C1.C1Schedule Namespace


BinarySearch Method

[image] [image]

.NET Framework Class Library
WorkDays..::..BinarySearch Method
WorkDays Class See Also

Overload List

 | Name | Description
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)

See Also

WorkDays Class
WorkDays Members
C1.C1Schedule Namespace


CopyTo Method

[image] [image]

.NET Framework Class Library
WorkDays..::..CopyTo Method
WorkDays Class See Also

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)

See Also

WorkDays Class
WorkDays Members
C1.C1Schedule Namespace


FindIndex Method

[image] [image]

.NET Framework Class Library
WorkDays..::..FindIndex Method
WorkDays Class See Also

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)

See Also

WorkDays Class
WorkDays Members
C1.C1Schedule Namespace


FindLastIndex Method

[image] [image]

.NET Framework Class Library
WorkDays..::..FindLastIndex Method
WorkDays Class See Also

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)

See Also

WorkDays Class
WorkDays Members
C1.C1Schedule Namespace


IndexOf Method

[image] [image]

.NET Framework Class Library
WorkDays..::..IndexOf Method
WorkDays Class See Also

Overload List

 | Name | Description
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)

See Also

WorkDays Class
WorkDays Members
C1.C1Schedule Namespace


LastIndexOf Method

[image] [image]

.NET Framework Class Library
WorkDays..::..LastIndexOf Method
WorkDays Class See Also

Overload List

 | Name | Description
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)

See Also

WorkDays Class
WorkDays Members
C1.C1Schedule Namespace


Reverse Method

[image] [image]

.NET Framework Class Library
WorkDays..::..Reverse Method
WorkDays Class See Also

Overload List

 | Name | Description
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)

See Also

WorkDays Class
WorkDays Members
C1.C1Schedule Namespace


Sort Method

[image] [image]

.NET Framework Class Library
WorkDays..::..Sort Method
WorkDays Class See Also

Overload List

 | Name | Description
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)

See Also

WorkDays Class
WorkDays Members
C1.C1Schedule Namespace


ToString Method

[image]

.NET Framework Class Library
WorkDays..::..ToString Method
WorkDays Class See Also

Namespace: C1.C1Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

WorkDays Class
C1.C1Schedule Namespace


WorkDays Properties

[image] [image]

.NET Framework Class Library
WorkDays Properties
WorkDays Class See Also

The WorkDays type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from List <(Of <(<' DayOfWeek >)>)>.)

See Also

WorkDays Class
C1.C1Schedule Namespace


C1.Silverlight.Schedule Namespace

[image]

.NET Framework Class Library
C1.Silverlight.Schedule Namespace

Classes

 | Class | Description
Public class | AddingAppointmentEventArgs | The AddingAppointmentEventArgs class describes routed event data for the UserAddingAppointment event.
Public class | AddValueConverter | The AddValueConverter class is the abstract base class for the IncrementConverter and DecrementConverter classes.
Public class | AlternateMonthBrushConverter | AlternateMonthBrushConverter returns background brush for the specified VisualInterval. ConverterParameter property should be set to the base brush value. Returns the base brush for even months; AlternateMonthBrush property value for odd months.
Public class | AppointmentActionEventArgs | The AppointmentActionEventArgs class describes routed event data for user actions on the Appointment object.
Public class | AppointmentsCoverPane | Provides a surface for painting appointment boxes over an arbitrary visual intervals layout.
Public class | AppointmentWrapPanel | Positions child elements in sequential position from left to right, breaking content to the next line at the edge of the containing box. Subsequent ordering happens sequentially from top to bottom or from right to left, depending on the value of the Orientation property. If Orientation property is Vertical this panel behaves as the base class. If Orientation property is Horizontal then AppointmentWrapPanel tries to position child elements in available space. For example, it doesn't wrap the child to the next line if the next line invisible. Instead, it shows as much as possible in the last visible line.
Public class | ArithmeticSubtractConverter | Represents a Binding converter that returns the double value representing the difference between value and converter parameter. This is a one-way converter.
Public class | BeforeViewChangeEventArgs | Provides data for the BeforeViewChange event of the C1Scheduler control.
Public class | BooleanToVisibilityConverter | Represents a Binding converter that converts a Boolean to the corresponding Visibility value. If ConverterParameter is not null, returns inverted value.
Public class | C1Calendar | Represents a multi month calendar with an ability to interactively navigate through months and select a specific DateTime value or its components.
Public class | C1CalendarItem | Represents a single month calendar with an ability to interactively navigate through months and select a specific DateTime or its components.
Public class | C1CalendarItem..::..DateTimeInfoCollection | The C1CalendarItem..::..DateTimeInfoCollection class keeps the list of DateTimeInfo objects which can be used for the C1CalendarItem control navigation.
Public class | C1CalendarItemPresenter | An instance of this class is used in the C1CalendarItem's template visual tree to define a place where a panel with calendar days will appear.
Public class | C1CalendarPresenter | An instance of this class is used in the C1Calendar's template visual tree to define a place where a panel with month calendars will appear.
Public class | C1CalendarResources | The C1CalendarResources keeps the set of resources used by the CalendarBase derived controls. Static fields of this class return default CalendarBase's themes.
Public class | C1ItemsPresenter | Used within the template of a GroupedListBox and GroupItem to specify the place in the control’s visual tree where the ItemsPanel defined by the GroupedListBox is to be added.
Public class | C1ListBoxItem | Represents a selectable item in a GroupedListBox.
Public class | C1Scheduler | Represents a schedule with an ability to interactively manage appointments.
Public class | C1SchedulerPresenter | An instance of this class is used in the C1Scheduler's template visual tree to define a place where a pane representing schedule time intervals will appear.
Public class | C1SchedulerResources | The C1SchedulerResources keeps the set of resources used by the C1Scheduler control. Static fields of this class return default C1Scheduler's themes.
Public class | C1SchedulerSettings | Determines auxiliary properties providing different C1Scheduler object settings.
Public class | CalendarBase | The base class for the C1CalendarItem and C1Calendar controls.
Public class | CalendarHelper | Provides auxiliary properties providing calendar specific information.
Public class | ChangeSignConverter | Represents a Binding converter that changes a sign of a numeric value.
Public class | ChangeThicknessSignConverter | Represents a Binding converter that changes a sign of each member of Thickness.
Public class | ColorToBrushConverter | Represents a Binding converter that converts a color to a brush.
Public class | CoveredElement | Defines a construction that describes a wrapper for the single covered element.
Public class | CoveredElementsCollection | The CoveredElementsCollection represents an observable collection of FrameworkElements.
Public class | CoverElement | Defines a construction that describes a UI that represents a single data object. The UI is constituted of a number of CoverElementChunk elements.
Public class | CoverElementChunk | The CoverElementChunk class represents an indivisible part of a UI for a data object.
Public class | CoverElementChunkCollection | The CoverElementChunkCollection represents the observable collection of CoverElementChunk objects.
Public class | CoverElementCollection | The CoverElementCollection is a observable keyed collection of CoverElement objects.
Public class | CoverElementsPane | Provides a surface for painting UI elements over the arbitrary layout.
Public class | DateFormatIndexer | Obsolete. The DateFormatIndexer class represents an object returning formatted DateTime string by the indexer property.
Public class | DateList | The DateList class represents the observable collection of DateTime values. The collection contains unique values only. Every item in collection is a DateTime value containing the date part only.
Public class | DateTimeInfo | Provides additional info about a DateTime in a specified culture.
Public class | DateTimeInterval | The DateTimeInterval object represents a continuous interval of time.
Public class | DateTimePropertyChangeEventArgs | The DateTimePropertyChangeEventArgs class describes routed event data for the DateTime property changing events.
Public class | DateTimeToStringConverter | Represents a Binding converter that converts a DateTime to one of its string representations.
Public class | DayGroupStyleSelector | This class provides a way to apply day group styles in DayView/WorkWeekView modes.
Public class | DayIntervalStyleSelector | This class provides a way to apply day group styles for ordinal/current days.
Public class | DayOfWeekSlot | Provides a data about a day of a week for the DaysOfWeekPresenter.
Public class | DayOfWeekSlotPresenter | Represents a root element of a visual tree generated for a day of week slot of the C1CalendarItem.
Public class | DaySlot | Represents a day slot in the C1CalendarItem control.
Public class | DaySlotPresenter | Represents a root element of a visual tree generated for a day slot of the C1CalendarItem.
Public class | DaysOfWeekPresenter | An instance of this class is used in the C1CalendarItem's template visual tree to define a place where a panel with day of week captions will appear.
Public class | DecrementConverter | Represents a Binding converter that keeps binding target = binding source - 1, where source and target values are numeric.
Public class | DeferrableObservableCollection<(Of <(<'T>)>)> | The DeferrableObservableCollection<(Of <(<'T>)>)> represents an ObservableCollection<(Of <(<'T>)>)> supported deferring events during the massive collection changes.
Public class | EditAppointmentControl | The EditAppointmentControl control allows editing of all appointment properties.
Public class | EditCollectionControl | The EditCollectionControl control is an auxiliary control encapsulating UI elements for editing Appointment Categories, Links or Resource properties.
Public class | EditRecurrenceControl | The EditRecurrenceControl control allows editing of all recurrence pattern properties.
Public class | EnsureEnumMemberConverter | Represents a Binding converter that indicates whether a binding source value is one of enum members specified in the converter parameter.
Public class | Extensions | Class that provides static extension methods for several other classes.
Public class | GroupedListBox | Contains a list of selectable items. Supports grouping.
Public class | GroupItem | Appears as the root of the visual sub-tree generated for a group.
Public class | GroupStyle | Defines how you want the group to look at each level.
Public class | GroupToSeparatorVisibilityConverter | GroupToSeparatorVisibilityConverter returns a Visibility value determining whether separator should be shown for the specified SchedulerGroupItem.
Public class | ImportanceEnumMemberConverter | Represents a Binding converter that indicates whether a binding source value is an enum member specified in the converter parameter.
Public class | IncrementConverter | Represents a Binding converter that keeps binding target = binding source + 1, where source and target values are numeric.
Public class | IntervalAppointment | Represents an Appointment in a VisualInterval.
Public class | IntervalAppointmentCollection | The IntervalAppointmentCollection class is a ReadOnlyObservableCollection<(Of <(<'T>)>)> collection of IntervalAppointment objects belonging to a certain VisualInterval object.
Public class | IntervalAppointmentPresenter | The IntervalAppointmentPresenter class represents the single appointment element in the C1Scheduler UI and allows in-place appointment editing.
Public class | IntervalGroupDescriptionCollection | Represents a collection of VisualIntervalGroupDescription objects.
Public class | IntervalGroupStyleCollection | Represents a collection of GroupStyle objects.
Public class | IsNotEmptyOrSpaceStringConverter | Represents a Binding converter that returns a Boolean value indicating whether a source value is null or a string containing zero or more space characters only, or a not empty string.
Public class | IsTodayConverter | Represents a Binding converter that returns a Boolean value indicating whether a source value is today's date.
Public class | ItemContainerGenerator | Generates the user interface on behalf of its host GroupedListBox control.
Public class | MonthSlotPresenter | An instance of this class is used to represent the single month.
Public class | MonthToStringConverter | MonthToStringConverter converts VisualInterval start time to string.
Public class | NestedPropertySetter | Represents a property setter which is being used as an item of the NestedSetters collection and is able to assign a value to a C1Scheduler nested property.
Public class | NestedPropertySetterCollection | Represents a collection of NestedPropertySetter objects.
Public class | NumberToStringConverter | Represents a Binding converter that converts an integer value to one of its string representations.
Public class | ObservableCollectionStringConverter | The ObservableCollectionStringConverter provides a type converter to convert ObservableCollection<(Of <(<'T>)>)> objects to and from various other representations.
Public class | PilePanel | Positions child elements one over another as it is done by the Grid panel with single row and single column.
Public class | PropertyChangeEventArgsBase | The PropertyChangeEventArgsBase class describes routed event data for the dependency property changing events.
Public class | RecChoiceControl | This window allows selecting deletion of a single occurrence or the whole recurring series.
Public class | ReentrantObservableCollection<(Of <(<'T>)>)> | The ReentrantObservableCollection<(Of <(<'T>)>)> class represents the same interface and functionality as the DeferrableObservableCollection<(Of <(<'T>)>)> with one exception: it allows collection changing in event handlers for the CollectionChanged event.
Public class | ReminderActionEventArgs | The ReminderActionEventArgs class describes routed event data for actions on the Reminder object.
Public class | ReminderListBoxItem | Represents single Reminder object.
Public class | RemindersListBox | The RemindersListBox represents collection of Reminder objects in a two-column view.
Public class | RemindersToStringConverter | Represents a Binding converter that returns a string title for Reminders Window.
Public class | SchedulerGroupItem | Holds all the data required for displaying individual UI part for the single resource, category or contact when the GroupBy property is set, or default UI otherwise.
Public class | SchedulerGroupItemCollection | Represents a collection of the SchedulerGroupItem objects.
Public class | SelectedEnumMemberConverter | Represents a Binding converter that indicates whether a binding source value is an enum member specified in the converter parameter.
Public class | SelectedEnumMemberConverterBase |
Public class | SelectedEnumMemberFlagConverter | Represents a Binding converter that indicates whether a binding source value contains an enum member (flag) specified in the converter parameter.
Public class | SelectFromListScene | Interaction logic for SelectFromListScene.xaml
Public class | ShiftingCanvas | Positions children elements in the viewport of the parent ScrollViewer control which supports horizontal scrolling.
Public class | ShowRemindersControl | The ShowRemindersControl displays currently active reminders and allows to control them.
Public class | StretchingCanvas | The StretchingCanvas panel positions child elements as standard Canvas and keeps child's Width equal to the parent StretchingCanvas ActualWidth property value. This is a supplementary panel which is required due to Silverlight limitation (Silverlight doesn't support binding to the ActualWidth property).
Public class | ThemeResources | The ThemeResources class is a base abstract class for ThemeResources classes.
Public class | TimeRulerConverter | Represents a Binding converter that converts minute part of DateTimeInfo start time to its string representation.
Public class | TimeRulerHelper | Supplies hours and minutes string representation based on the specified VisualInterval object, current culture and TimeFormat property value.
Public class | TimeRulerVisibilityConverter | Represents a Binding converter that returns a Visibility value for the time ruler UI part.
Public class | TimeSlotGroupStyleSelector | This class provides a way to apply time slot group styles for working/free hours in DayView/WorkWeekView modes.
Public class | TimeSlotStyleSelector | This class provides a way to apply time slot styles for working/free hours in DayView/WorkWeekView modes.
Public class | TimeSlotTemplateSelector | This class provides a way to choose a DataTemplate for the VisualInterval object representing the single time slot in DayView/WorkWeekView modes.
Public class | VisualInterval | Represents a definition of a minimal indivisible time interval represented by the C1Scheduler.
Public class | VisualIntervalCollection | Represents a collection of VisualInterval objects.
Public class | VisualIntervalGroup | Instances of this class appear as DataContext for the C1Scheduler group headers defined in the VisualIntervalGroupStyles collection.
Public class | VisualIntervalGroupDescription | Represents a grouping criteria for a collection of VisualInterval objects.
Public class | VisualIntervalGroupsPresenter | The VisualIntervalGroupsPresenter class is a listbox representing the collection of VisualIntervalGroup objects. This class implements selection logic for all-day areas in Day View, WorkWeek View and Office 2007 Week View modes.
Public class | VisualIntervalPresenter | Represents a selectable item in a VisualIntervalsPresenter.
Public class | VisualIntervalsPresenter | The base class for listboxes which should represent the collection of VisualInterval objects.
Public class | VisualIntervalToStringConverter | VisualIntervalToStringConverter converts VisualInterval start time to string using formatting string specified in one of the C1Scheduler properties: - DayViewDayHeaderFormat, - WeekViewDayHeaderFormat, - MonthViewDayHeaderMonthFormat, - MonthViewDayHeaderDayFormat, - MonthViewHeaderFormat. Converter parameter should specify C1Scheduler property name. If converter parameter is null, uses VisualInterval.Culture.DateTimeFormat.ShortDatePattern as formatting string.
Public class | WeekDaysEnumToStringConverter | Represents a Binding converter that returns a localized string representation of WeekDaysEnum member.
Public class | WeekDaysToIntConverter | Represents a Binding converter that converts a WeekDaysEnum value to integer representations.
Public class | WeekOfMonthEnumToStringConverter | Represents a Binding converter that returns a localized string representation of WeekOfMonthEnum member.
Public class | WorkDaysConverter | The WorkDaysConverter provides a type converter to convert WorkDays objects to and from various other representations.

Delegates

 | Delegate | Description
Public delegate | GroupStyleSelector | Delegate used to select the group style as a function of the parent group and its level.

Enumerations

 | Enumeration | Description
Public enumeration | AppointmentFilterEnum | Determines the type of appointments drawn by the AppointmentsCoverPane pane.
Public enumeration | SelectionCommand | Determines the type of selection.
Public enumeration | SizingType | Describes how UI element is sized with respect to the available space.


AddingAppointmentEventArgs Class

[image]

.NET Framework Class Library
AddingAppointmentEventArgs Class
Members See Also
The AddingAppointmentEventArgs class describes routed event data for the UserAddingAppointment event.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class AddingAppointmentEventArgs : AppointmentActionEventArgs
Visual Basic
Public Class AddingAppointmentEventArgs _
    Inherits AppointmentActionEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.Windows..::..RoutedEventArgs
C1.Silverlight.Schedule..::..AppointmentActionEventArgs
C1.Silverlight.Schedule..::..AddingAppointmentEventArgs

See Also

AddingAppointmentEventArgs Members
C1.Silverlight.Schedule Namespace


AddingAppointmentEventArgs Members

[image] [image]

.NET Framework Class Library
AddingAppointmentEventArgs Members
AddingAppointmentEventArgs Class Constructors Methods Fields Properties See Also

The AddingAppointmentEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | AddingAppointmentEventArgs | Initializes a new instance of the AddingAppointmentEventArgs class with the specified appointment.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _appointment | (Inherited from AppointmentActionEventArgs.)

Properties

 | Name | Description
Public property | Appointment | Gets or sets an Appointment object.
Public property | Handled | Gets or sets a value that indicates the present state of the event handling. (Inherited from AppointmentActionEventArgs.)
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)

See Also

AddingAppointmentEventArgs Class


AddingAppointmentEventArgs Constructor

[image]

.NET Framework Class Library
AddingAppointmentEventArgs Constructor
AddingAppointmentEventArgs Class See Also
Initializes a new instance of the AddingAppointmentEventArgs class with the specified appointment.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public AddingAppointmentEventArgs(
    Appointment appointment
)
Visual Basic
Public Sub New ( _
    appointment As Appointment _
)

Parameters

appointment
Type: C1.C1Schedule..::..Appointment
The Appointment object.

See Also

AddingAppointmentEventArgs Class


AddingAppointmentEventArgs Fields

[image] [image]

.NET Framework Class Library
AddingAppointmentEventArgs Fields
AddingAppointmentEventArgs Class See Also

The AddingAppointmentEventArgs type exposes the following members.

Fields

 | Name | Description
Protected field | _appointment | (Inherited from AppointmentActionEventArgs.)

See Also

AddingAppointmentEventArgs Class


AddingAppointmentEventArgs Methods

[image] [image]

.NET Framework Class Library
AddingAppointmentEventArgs Methods
AddingAppointmentEventArgs Class See Also

The AddingAppointmentEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddingAppointmentEventArgs Class


AddingAppointmentEventArgs Properties

[image] [image]

.NET Framework Class Library
AddingAppointmentEventArgs Properties
AddingAppointmentEventArgs Class See Also

The AddingAppointmentEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Appointment | Gets or sets an Appointment object.
Public property | Handled | Gets or sets a value that indicates the present state of the event handling. (Inherited from AppointmentActionEventArgs.)
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)

See Also

AddingAppointmentEventArgs Class


Appointment Property

[image]

.NET Framework Class Library
AddingAppointmentEventArgs..::..Appointment Property
AddingAppointmentEventArgs Class See Also
Gets or sets an Appointment object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Appointment Appointment { get; set; }
Visual Basic
Public Property Appointment As Appointment
    Get
    Set

See Also

AddingAppointmentEventArgs Class


AddValueConverter Class

[image]

.NET Framework Class Library
AddValueConverter Class
Members See Also
The AddValueConverter class is the abstract base class for the IncrementConverter and DecrementConverter classes.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public abstract class AddValueConverter : IValueConverter
Visual Basic
Public MustInherit Class AddValueConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..AddValueConverter
C1.Silverlight.Schedule..::..DecrementConverter
C1.Silverlight.Schedule..::..IncrementConverter

See Also

AddValueConverter Members


AddValueConverter Members

[image] [image]

.NET Framework Class Library
AddValueConverter Members
AddValueConverter Class Constructors Methods See Also

The AddValueConverter type exposes the following members.

Constructors

 | Name | Description
Protected method | AddValueConverter | Initializes a new instance of the AddValueConverter

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddValueConverter Class


AddValueConverter Constructor

[image]

.NET Framework Class Library
AddValueConverter Constructor
AddValueConverter Class See Also
Initializes a new instance of the AddValueConverter

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected AddValueConverter(
    int delta
)
Visual Basic
Protected Sub New ( _
    delta As Integer _
)

Parameters

delta
Type: System..::..Int32

See Also

AddValueConverter Class


AddValueConverter Methods

[image] [image]

.NET Framework Class Library
AddValueConverter Methods
AddValueConverter Class See Also

The AddValueConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddValueConverter Class


Convert Method

[image]

.NET Framework Class Library
AddValueConverter..::..Convert Method
AddValueConverter Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

AddValueConverter Class


ConvertBack Method

[image]

.NET Framework Class Library
AddValueConverter..::..ConvertBack Method
AddValueConverter Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value that is produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

AddValueConverter Class


AlternateMonthBrushConverter Class

[image]

.NET Framework Class Library
AlternateMonthBrushConverter Class
Members See Also
AlternateMonthBrushConverter returns background brush for the specified VisualInterval. ConverterParameter property should be set to the base brush value. Returns the base brush for even months; AlternateMonthBrush property value for odd months.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class AlternateMonthBrushConverter : IValueConverter
Visual Basic
Public Class AlternateMonthBrushConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..AlternateMonthBrushConverter

See Also

AlternateMonthBrushConverter Members


AlternateMonthBrushConverter Members

[image] [image]

.NET Framework Class Library
AlternateMonthBrushConverter Members
AlternateMonthBrushConverter Class Constructors Methods Fields Properties See Also

The AlternateMonthBrushConverter type exposes the following members.

Constructors

 | Name | Description
Public method | AlternateMonthBrushConverter |

Methods

 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Default | Gets an instance of AlternateMonthBrushConverter.

Properties

 | Name | Description
Public property | AlternateMonthBrush | Gets or sets a Brush object which should be used for alternate months. The default value is white SolidColorBrush.

See Also

AlternateMonthBrushConverter Class


AlternateMonthBrushConverter Constructor

[image]

.NET Framework Class Library
AlternateMonthBrushConverter Constructor
AlternateMonthBrushConverter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public AlternateMonthBrushConverter()
Visual Basic
Public Sub New

See Also

AlternateMonthBrushConverter Class


AlternateMonthBrushConverter Fields

[image] [image]

.NET Framework Class Library
AlternateMonthBrushConverter Fields
AlternateMonthBrushConverter Class See Also

The AlternateMonthBrushConverter type exposes the following members.

Fields

Name | Description
Default | Gets an instance of AlternateMonthBrushConverter.

See Also

AlternateMonthBrushConverter Class


Default Field

[image]

.NET Framework Class Library
AlternateMonthBrushConverter..::..Default Field
AlternateMonthBrushConverter Class See Also
Gets an instance of AlternateMonthBrushConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly AlternateMonthBrushConverter Default
Visual Basic
Public Shared ReadOnly Default As AlternateMonthBrushConverter

See Also

AlternateMonthBrushConverter Class


AlternateMonthBrushConverter Methods

[image] [image]

.NET Framework Class Library
AlternateMonthBrushConverter Methods
AlternateMonthBrushConverter Class See Also

The AlternateMonthBrushConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AlternateMonthBrushConverter Class


Convert Method

[image]

.NET Framework Class Library
AlternateMonthBrushConverter..::..Convert Method
AlternateMonthBrushConverter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
targetType
Type: System..::..Type
parameter
Type: System..::..Object
culture
Type: System.Globalization..::..CultureInfo

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

AlternateMonthBrushConverter Class


ConvertBack Method

[image]

.NET Framework Class Library
AlternateMonthBrushConverter..::..ConvertBack Method
AlternateMonthBrushConverter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
targetType
Type: System..::..Type
parameter
Type: System..::..Object
culture
Type: System.Globalization..::..CultureInfo

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

AlternateMonthBrushConverter Class


AlternateMonthBrushConverter Properties

[image] [image]

.NET Framework Class Library
AlternateMonthBrushConverter Properties
AlternateMonthBrushConverter Class See Also

The AlternateMonthBrushConverter type exposes the following members.

Properties

 | Name | Description
Public property | AlternateMonthBrush | Gets or sets a Brush object which should be used for alternate months. The default value is white SolidColorBrush.

See Also

AlternateMonthBrushConverter Class


AlternateMonthBrush Property

[image]

.NET Framework Class Library
AlternateMonthBrushConverter..::..AlternateMonthBrush Property
AlternateMonthBrushConverter Class See Also
Gets or sets a Brush object which should be used for alternate months. The default value is white SolidColorBrush.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Brush AlternateMonthBrush { get; set; }
Visual Basic
Public Property AlternateMonthBrush As Brush
    Get
    Set

See Also

AlternateMonthBrushConverter Class


AppointmentActionEventArgs Class

[image]

.NET Framework Class Library
AppointmentActionEventArgs Class
Members See Also
The AppointmentActionEventArgs class describes routed event data for user actions on the Appointment object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class AppointmentActionEventArgs : RoutedEventArgs
Visual Basic
Public Class AppointmentActionEventArgs _
    Inherits RoutedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.Windows..::..RoutedEventArgs
C1.Silverlight.Schedule..::..AppointmentActionEventArgs
C1.Silverlight.Schedule..::..AddingAppointmentEventArgs

See Also

AppointmentActionEventArgs Members


AppointmentActionEventArgs Members

[image] [image]

.NET Framework Class Library
AppointmentActionEventArgs Members
AppointmentActionEventArgs Class Constructors Methods Fields Properties See Also

The AppointmentActionEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | AppointmentActionEventArgs | Initializes a new instance of the AppointmentActionEventArgs class with the specified appointment.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _appointment |

Properties

 | Name | Description
Public property | Appointment | Gets an Appointment object.
Public property | Handled | Gets or sets a value that indicates the present state of the event handling.
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)

See Also

AppointmentActionEventArgs Class


AppointmentActionEventArgs Constructor

[image]

.NET Framework Class Library
AppointmentActionEventArgs Constructor
AppointmentActionEventArgs Class See Also
Initializes a new instance of the AppointmentActionEventArgs class with the specified appointment.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public AppointmentActionEventArgs(
    Appointment appointment
)
Visual Basic
Public Sub New ( _
    appointment As Appointment _
)

Parameters

appointment
Type: C1.C1Schedule..::..Appointment
The Appointment object.

See Also

AppointmentActionEventArgs Class


AppointmentActionEventArgs Fields

[image] [image]

.NET Framework Class Library
AppointmentActionEventArgs Fields
AppointmentActionEventArgs Class See Also

The AppointmentActionEventArgs type exposes the following members.

Fields

 | Name | Description
Protected field | _appointment |

See Also

AppointmentActionEventArgs Class


_appointment Field

[image]

.NET Framework Class Library
AppointmentActionEventArgs..::.._appointment Field
AppointmentActionEventArgs Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[CLSCompliantAttribute(false)]
protected Appointment _appointment
Visual Basic
<CLSCompliantAttribute(False)> _
Protected _appointment As Appointment

See Also

AppointmentActionEventArgs Class


AppointmentActionEventArgs Methods

[image] [image]

.NET Framework Class Library
AppointmentActionEventArgs Methods
AppointmentActionEventArgs Class See Also

The AppointmentActionEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AppointmentActionEventArgs Class


AppointmentActionEventArgs Properties

[image] [image]

.NET Framework Class Library
AppointmentActionEventArgs Properties
AppointmentActionEventArgs Class See Also

The AppointmentActionEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Appointment | Gets an Appointment object.
Public property | Handled | Gets or sets a value that indicates the present state of the event handling.
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)

See Also

AppointmentActionEventArgs Class


Appointment Property

[image]

.NET Framework Class Library
AppointmentActionEventArgs..::..Appointment Property
AppointmentActionEventArgs Class See Also
Gets an Appointment object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Appointment Appointment { get; }
Visual Basic
Public ReadOnly Property Appointment As Appointment
    Get

See Also

AppointmentActionEventArgs Class


Handled Property

[image]

.NET Framework Class Library
AppointmentActionEventArgs..::..Handled Property
AppointmentActionEventArgs Class See Also
Gets or sets a value that indicates the present state of the event handling.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool Handled { get; set; }
Visual Basic
Public Property Handled As Boolean
    Get
    Set

See Also

AppointmentActionEventArgs Class


AppointmentFilterEnum Enumeration

[image]

.NET Framework Class Library
AppointmentFilterEnum Enumeration
See Also
Determines the type of appointments drawn by the AppointmentsCoverPane pane.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public enum AppointmentFilterEnum
Visual Basic
Public Enumeration AppointmentFilterEnum

Members

Member name | Description
All | All appointments.
Event | All-day and multi-day events.
Appointment | Appointments with duration less than 1 day.

See Also


AppointmentsCoverPane Class

[image]

.NET Framework Class Library
AppointmentsCoverPane Class
Members See Also
Provides a surface for painting appointment boxes over an arbitrary visual intervals layout.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public sealed class AppointmentsCoverPane : CoverElementsPane
Visual Basic
Public NotInheritable Class AppointmentsCoverPane _
    Inherits CoverElementsPane

Remarks

AppointmentsCoverPane allows you to visually represent a set of appointments that fit in a time range exposed by a current view, and to draw appointment boxes relative to UI elements representing VisualIntervals covered by the appointment. The AppointmentsCoverPane element, being placed somewhere inside C1Scheduler visual tree (usually in C1Scheduler's ControlTemplate), provides a surface where it draws appointment boxes relative to UI elements representing VisualIntervals. AppointmentsCoverPane is capable to recognize the case when the appointment box must be divided into two or more visual boxes, for example, if appointment covers three days in the Working Week View, AppointmentsCoverPane will automatically draw three boxes for the appointment, each box in a corresponding day column, with starting and ending edges positioned at interval UI elements corresponding to start and end time of the appointment in this day.

AppointmentsCoverPane provides this functionality for an arbitrary UI representing VisualIntervals. To make it possible, each element that can be treated as VisualInterval UI representative (usually it's an outer (root) element in the VisualIntervalTemplate definition) must have the attached OrientationProperty assigned (CoverElementsPane is the base class for AppointmentsCoverPane). The assigned value indicates a chronological flow direction of interval elements and can take Horizontal or Vertical values. For example, interval elements in the Working Week View have it assigned to Vertical, while elements of Month View assign it to Horizontal. A content of an appointment box of AppointmentsCoverPane is represented by DataTemplate defined in the IntervalAppointmentTemplate property.

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
C1.Silverlight.Schedule..::..CoverElementsPane
C1.Silverlight.Schedule..::..AppointmentsCoverPane

See Also

AppointmentsCoverPane Members


AppointmentsCoverPane Members

[image] [image]

.NET Framework Class Library
AppointmentsCoverPane Members
AppointmentsCoverPane Class Constructors Methods Fields Properties Attached Properties Events See Also

The AppointmentsCoverPane type exposes the following members.

Constructors

 | Name | Description
Public method | AppointmentsCoverPane | Creates a new instance of the AppointmentsCoverPane pane.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
 | GetAppointmentFilter | Gets the value of the AppointmentFilter attached property for a given framework element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetKeepTimesAtDrop | Gets the value of the KeepTimesAtDrop attached property for a given framework element.
Protected method | GetLaneSize | Returns the size which should be used to draw cover element according to specified sizing type, available space and total lane count. (Inherited from CoverElementsPane.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Protected method | IsPaneElementInternal | Checks whether specified element is covered by the current CoverElementsPane instance. (Inherited from CoverElementsPane.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | Overrides the default behavior. (Inherited from CoverElementsPane.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from CoverElementsPane.)
Protected method | OnMouseLeftButtonUp | Overrides the default behavior. (Inherited from CoverElementsPane.)
Protected method | OnMouseMove | Overrides the default behavior. (Inherited from CoverElementsPane.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
 | SetAppointmentFilter | Sets the value of the AppointmentFilter attached property for a given framework element.
Public method | SetBinding | (Inherited from FrameworkElement.)
 | SetKeepTimesAtDrop | Sets the value of the KeepTimesAtDrop attached property for a given framework element.
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

 | Name | Description
Protected field | _hostElementsList | Keeps the list of child FrameworkElements covered by the ICoverElementsPane which have CoverElementsPane.Orientation property set. (Inherited from CoverElementsPane.)
Protected field | _isAboutToUnload | Determines whether the pane is about to be unloaded. (Inherited from CoverElementsPane.)
Protected field | _lastStart | Might be used in derived classes during HostElementsList collection. (Inherited from CoverElementsPane.)
Protected field | _needSort | Determines whether HostElementsList should be sorted after it is filled. (Inherited from CoverElementsPane.)
 | AppointmentFilterProperty | The AppointmentFilter attached property can be used to specify which type of appointments should be drawn by the AppointmentsCoverPane pane.
 | IntervalAppointmentTemplateProperty | Identifies the IntervalAppointmentTemplate dependency property.
 | KeepTimesAtDropProperty | The KeepTimesAtDrop attached property determines the behavior of moved (dragged) appointments. If this value is True, after dragging an appointment to the desired VisualInterval, the Appointment start date is changed to the VisualInterval start date. If this value is False, the Appointment.Start becomes equal to the VisualInterval.StartTime, and Appointment.Duration becomes equal to the VisualInterval.TimeScale. The default value is False.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | ChunkBreakingAngle | Gets or sets a Double value specifying the breaking angle for painted UI elements. (Inherited from CoverElementsPane.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ContentKind | Gets the type of content acceptable by the current instance of AppointmentsCoverPane. (Overrides CoverElementsPane..::..ContentKind.)
Public property | CoverElementsHeight | Obsolete. Gets or sets a Double value, determining height of the cover elements. This property makes sense for horizontal orientation only. The default value is 19. (Inherited from CoverElementsPane.)
Public property | CoverElementsMargin | Gets or sets a Double value, determining margins of the cover elements. (Inherited from CoverElementsPane.)
Public property | CoverElementsSize | Gets or sets a Double value, determining the size of the cover elements. This is dependency property. The default value is 19. (Inherited from CoverElementsPane.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataCoverElements | Gets a list of CoverElement objects that are drawn on this CoverElementPane. (Inherited from CoverElementsPane.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | ExtendOnOverflow | Gets or sets a Boolean value, specifying the CoverElementsPane behavior in the case when covering elements do not fit into the available space. If False, the CoverElementsOverflowProperty will be set to True. This is default behavior. If True, the covered element will be extended in order to accommodate all covering elements. (Inherited from CoverElementsPane.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IntervalAppointmentTemplate | Gets or sets a DataTemplate that defines a UI representation of an IntervalAppointment object. This is a dependency property.
Public property | IsDragDropDisabled | Gets or sets a Boolean value that indicates whether the CoverElementsPane doesn't allow resizing and drag operations. This is a dependency property. (Inherited from CoverElementsPane.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Owner | Gets the object representing the CoverElementsPane object owner. This is a dependency property. Default value is null. (Inherited from CoverElementsPane.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SizingType | Gets or sets the SizingType values specifying how CoverElementsPane determines UI elements size. The default value is SizingType.Fixed. (Inherited from CoverElementsPane.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | UseSimpleLayout | Only set this property to false if you use complex layout in the custom C1Scheduler control template and found problems with layouting appointments at runtime. In such case AppointmentsCoverPane will use more slow algorithm to determine what elements should be used to layout appointments over them.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Attached Properties

 | Name | Description
Public attached property | AppointmentFilter |
Public attached property | KeepTimesAtDrop |

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

AppointmentsCoverPane Class


AppointmentsCoverPane Constructor

[image]

.NET Framework Class Library
AppointmentsCoverPane Constructor
AppointmentsCoverPane Class See Also
Creates a new instance of the AppointmentsCoverPane pane.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public AppointmentsCoverPane()
Visual Basic
Public Sub New

See Also

AppointmentsCoverPane Class


AppointmentsCoverPane Fields

[image] [image]

.NET Framework Class Library
AppointmentsCoverPane Fields
AppointmentsCoverPane Class See Also

The AppointmentsCoverPane type exposes the following members.

Fields

 | Name | Description
Protected field | _hostElementsList | Keeps the list of child FrameworkElements covered by the ICoverElementsPane which have CoverElementsPane.Orientation property set. (Inherited from CoverElementsPane.)
Protected field | _isAboutToUnload | Determines whether the pane is about to be unloaded. (Inherited from CoverElementsPane.)
Protected field | _lastStart | Might be used in derived classes during HostElementsList collection. (Inherited from CoverElementsPane.)
Protected field | _needSort | Determines whether HostElementsList should be sorted after it is filled. (Inherited from CoverElementsPane.)
 | AppointmentFilterProperty | The AppointmentFilter attached property can be used to specify which type of appointments should be drawn by the AppointmentsCoverPane pane.
 | IntervalAppointmentTemplateProperty | Identifies the IntervalAppointmentTemplate dependency property.
 | KeepTimesAtDropProperty | The KeepTimesAtDrop attached property determines the behavior of moved (dragged) appointments. If this value is True, after dragging an appointment to the desired VisualInterval, the Appointment start date is changed to the VisualInterval start date. If this value is False, the Appointment.Start becomes equal to the VisualInterval.StartTime, and Appointment.Duration becomes equal to the VisualInterval.TimeScale. The default value is False.

See Also

AppointmentsCoverPane Class


AppointmentFilterProperty Field

[image]

.NET Framework Class Library
AppointmentsCoverPane..::..AppointmentFilterProperty Field
AppointmentsCoverPane Class See Also
The AppointmentFilter attached property can be used to specify which type of appointments should be drawn by the AppointmentsCoverPane pane.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty AppointmentFilterProperty
Visual Basic
Public Shared ReadOnly AppointmentFilterProperty As DependencyProperty

See Also

AppointmentsCoverPane Class


IntervalAppointmentTemplateProperty Field

[image]

.NET Framework Class Library
AppointmentsCoverPane..::..IntervalAppointmentTemplateProperty Field
AppointmentsCoverPane Class See Also
Identifies the IntervalAppointmentTemplate dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty IntervalAppointmentTemplateProperty
Visual Basic
Public Shared ReadOnly IntervalAppointmentTemplateProperty As DependencyProperty

See Also

AppointmentsCoverPane Class


KeepTimesAtDropProperty Field

[image]

.NET Framework Class Library
AppointmentsCoverPane..::..KeepTimesAtDropProperty Field
AppointmentsCoverPane Class See Also
The KeepTimesAtDrop attached property determines the behavior of moved (dragged) appointments. If this value is True, after dragging an appointment to the desired VisualInterval, the Appointment start date is changed to the VisualInterval start date. If this value is False, the Appointment.Start becomes equal to the VisualInterval.StartTime, and Appointment.Duration becomes equal to the VisualInterval.TimeScale. The default value is False.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty KeepTimesAtDropProperty
Visual Basic
Public Shared ReadOnly KeepTimesAtDropProperty As DependencyProperty

See Also

AppointmentsCoverPane Class


AppointmentsCoverPane Methods

[image] [image]

.NET Framework Class Library
AppointmentsCoverPane Methods
AppointmentsCoverPane Class See Also

The AppointmentsCoverPane type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
 | GetAppointmentFilter | Gets the value of the AppointmentFilter attached property for a given framework element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetKeepTimesAtDrop | Gets the value of the KeepTimesAtDrop attached property for a given framework element.
Protected method | GetLaneSize | Returns the size which should be used to draw cover element according to specified sizing type, available space and total lane count. (Inherited from CoverElementsPane.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Protected method | IsPaneElementInternal | Checks whether specified element is covered by the current CoverElementsPane instance. (Inherited from CoverElementsPane.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | Overrides the default behavior. (Inherited from CoverElementsPane.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from CoverElementsPane.)
Protected method | OnMouseLeftButtonUp | Overrides the default behavior. (Inherited from CoverElementsPane.)
Protected method | OnMouseMove | Overrides the default behavior. (Inherited from CoverElementsPane.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
 | SetAppointmentFilter | Sets the value of the AppointmentFilter attached property for a given framework element.
Public method | SetBinding | (Inherited from FrameworkElement.)
 | SetKeepTimesAtDrop | Sets the value of the KeepTimesAtDrop attached property for a given framework element.
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

AppointmentsCoverPane Class


GetAppointmentFilter Method

[image]

.NET Framework Class Library
AppointmentsCoverPane..::..GetAppointmentFilter Method
AppointmentsCoverPane Class See Also
Gets the value of the AppointmentFilter attached property for a given framework element.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static AppointmentFilterEnum GetAppointmentFilter(
    FrameworkElement element
)
Visual Basic
Public Shared Function GetAppointmentFilter ( _
    element As FrameworkElement _
) As AppointmentFilterEnum

Parameters

element
Type: System.Windows..::..FrameworkElement
The FrameworkElement from which the property value is read.

Return Value

The AppointmentFilterEnum value of the specified element.

See Also

AppointmentsCoverPane Class


GetKeepTimesAtDrop Method

[image]

.NET Framework Class Library
AppointmentsCoverPane..::..GetKeepTimesAtDrop Method
AppointmentsCoverPane Class See Also
Gets the value of the KeepTimesAtDrop attached property for a given framework element.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static bool GetKeepTimesAtDrop(
    FrameworkElement element
)
Visual Basic
Public Shared Function GetKeepTimesAtDrop ( _
    element As FrameworkElement _
) As Boolean

Parameters

element
Type: System.Windows..::..FrameworkElement
The FrameworkElement from which the property value is read.

Return Value

The Boolean value of the specified element.

See Also

AppointmentsCoverPane Class


SetAppointmentFilter Method

[image]

.NET Framework Class Library
AppointmentsCoverPane..::..SetAppointmentFilter Method
AppointmentsCoverPane Class See Also
Sets the value of the AppointmentFilter attached property for a given framework element.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static void SetAppointmentFilter(
    FrameworkElement element,
    AppointmentFilterEnum value
)
Visual Basic
Public Shared Sub SetAppointmentFilter ( _
    element As FrameworkElement, _
    value As AppointmentFilterEnum _
)

Parameters

element
Type: System.Windows..::..FrameworkElement
The FrameworkElement for which the property value is set.
value
Type: C1.Silverlight.Schedule..::..AppointmentFilterEnum
The AppointmentFilterEnum value to be set on the specified element.

See Also

AppointmentsCoverPane Class


SetKeepTimesAtDrop Method

[image]

.NET Framework Class Library
AppointmentsCoverPane..::..SetKeepTimesAtDrop Method
AppointmentsCoverPane Class See Also
Sets the value of the KeepTimesAtDrop attached property for a given framework element.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static void SetKeepTimesAtDrop(
    FrameworkElement element,
    bool value
)
Visual Basic
Public Shared Sub SetKeepTimesAtDrop ( _
    element As FrameworkElement, _
    value As Boolean _
)

Parameters

element
Type: System.Windows..::..FrameworkElement
The FrameworkElement for which the property value is set.
value
Type: System..::..Boolean
The Boolean value to be set on the specified element.

See Also

AppointmentsCoverPane Class


AppointmentsCoverPane Properties

[image] [image]

.NET Framework Class Library
AppointmentsCoverPane Properties
AppointmentsCoverPane Class See Also

The AppointmentsCoverPane type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | ChunkBreakingAngle | Gets or sets a Double value specifying the breaking angle for painted UI elements. (Inherited from CoverElementsPane.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ContentKind | Gets the type of content acceptable by the current instance of AppointmentsCoverPane. (Overrides CoverElementsPane..::..ContentKind.)
Public property | CoverElementsHeight | Obsolete. Gets or sets a Double value, determining height of the cover elements. This property makes sense for horizontal orientation only. The default value is 19. (Inherited from CoverElementsPane.)
Public property | CoverElementsMargin | Gets or sets a Double value, determining margins of the cover elements. (Inherited from CoverElementsPane.)
Public property | CoverElementsSize | Gets or sets a Double value, determining the size of the cover elements. This is dependency property. The default value is 19. (Inherited from CoverElementsPane.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataCoverElements | Gets a list of CoverElement objects that are drawn on this CoverElementPane. (Inherited from CoverElementsPane.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | ExtendOnOverflow | Gets or sets a Boolean value, specifying the CoverElementsPane behavior in the case when covering elements do not fit into the available space. If False, the CoverElementsOverflowProperty will be set to True. This is default behavior. If True, the covered element will be extended in order to accommodate all covering elements. (Inherited from CoverElementsPane.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IntervalAppointmentTemplate | Gets or sets a DataTemplate that defines a UI representation of an IntervalAppointment object. This is a dependency property.
Public property | IsDragDropDisabled | Gets or sets a Boolean value that indicates whether the CoverElementsPane doesn't allow resizing and drag operations. This is a dependency property. (Inherited from CoverElementsPane.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Owner | Gets the object representing the CoverElementsPane object owner. This is a dependency property. Default value is null. (Inherited from CoverElementsPane.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SizingType | Gets or sets the SizingType values specifying how CoverElementsPane determines UI elements size. The default value is SizingType.Fixed. (Inherited from CoverElementsPane.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | UseSimpleLayout | Only set this property to false if you use complex layout in the custom C1Scheduler control template and found problems with layouting appointments at runtime. In such case AppointmentsCoverPane will use more slow algorithm to determine what elements should be used to layout appointments over them.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

AppointmentsCoverPane Class


ContentKind Property

[image]

.NET Framework Class Library
AppointmentsCoverPane..::..ContentKind Property
AppointmentsCoverPane Class See Also
Gets the type of content acceptable by the current instance of AppointmentsCoverPane.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override Object ContentKind { get; set; }
Visual Basic
Public Overrides Property ContentKind As Object
    Get
    Set

Remarks

This property always returns typeof(IntervalAppointment). The setter for this property does nothing.

See Also

AppointmentsCoverPane Class


IntervalAppointmentTemplate Property

[image]

.NET Framework Class Library
AppointmentsCoverPane..::..IntervalAppointmentTemplate Property
AppointmentsCoverPane Class See Also
Gets or sets a DataTemplate that defines a UI representation of an IntervalAppointment object. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DataTemplate IntervalAppointmentTemplate { get; set; }
Visual Basic
Public Property IntervalAppointmentTemplate As DataTemplate
    Get
    Set

Remarks

A single appointment can be represented by multiple elements in control's view. For example, in the Months view the appointment that hit two weeks will be represented by two separate elements, a different element for each week. Because of this, a DataContext for the appointment template is a IntervalAppointment object (but not an Appointment object), which represents the chunk of appointment covering a specific period of time that can be shown by a single UI element.

See Also

AppointmentsCoverPane Class


UseSimpleLayout Property

[image]

.NET Framework Class Library
AppointmentsCoverPane..::..UseSimpleLayout Property
AppointmentsCoverPane Class See Also
Only set this property to false if you use complex layout in the custom C1Scheduler control template and found problems with layouting appointments at runtime. In such case AppointmentsCoverPane will use more slow algorithm to determine what elements should be used to layout appointments over them.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool UseSimpleLayout { get; set; }
Visual Basic
Public Property UseSimpleLayout As Boolean
    Get
    Set

See Also

AppointmentsCoverPane Class


AppointmentsCoverPane Events

[image] [image]

.NET Framework Class Library
AppointmentsCoverPane Events
AppointmentsCoverPane Class See Also

The AppointmentsCoverPane type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

AppointmentsCoverPane Class


AppointmentsCoverPane Attached Properties

[image] [image]

.NET Framework Class Library
AppointmentsCoverPane Attached Properties
AppointmentsCoverPane Class See Also

The AppointmentsCoverPane type exposes the following members.

Attached Properties

 | Name | Description
Public attached property | AppointmentFilter |
Public attached property | KeepTimesAtDrop |

See Also

AppointmentsCoverPane Class


AppointmentFilter Attached Property

[image]

.NET Framework Class Library
AppointmentsCoverPane..::..AppointmentFilter Attached Property
AppointmentsCoverPane Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
See GetAppointmentFilter, SetAppointmentFilter
Visual Basic
See GetAppointmentFilter, SetAppointmentFilter

See Also

AppointmentsCoverPane Class


KeepTimesAtDrop Attached Property

[image]

.NET Framework Class Library
AppointmentsCoverPane..::..KeepTimesAtDrop Attached Property
AppointmentsCoverPane Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
See GetKeepTimesAtDrop, SetKeepTimesAtDrop
Visual Basic
See GetKeepTimesAtDrop, SetKeepTimesAtDrop

See Also

AppointmentsCoverPane Class


AppointmentWrapPanel Class

[image]

.NET Framework Class Library
AppointmentWrapPanel Class
Members See Also
Positions child elements in sequential position from left to right, breaking content to the next line at the edge of the containing box. Subsequent ordering happens sequentially from top to bottom or from right to left, depending on the value of the Orientation property. If Orientation property is Vertical this panel behaves as the base class. If Orientation property is Horizontal then AppointmentWrapPanel tries to position child elements in available space. For example, it doesn't wrap the child to the next line if the next line invisible. Instead, it shows as much as possible in the last visible line.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class AppointmentWrapPanel : C1WrapPanel
Visual Basic
Public Class AppointmentWrapPanel _
    Inherits C1WrapPanel

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Panel
C1WrapPanel
C1.Silverlight.Schedule..::..AppointmentWrapPanel

See Also

AppointmentWrapPanel Members


AppointmentWrapPanel Members

[image] [image]

.NET Framework Class Library
AppointmentWrapPanel Members
AppointmentWrapPanel Class Constructors Methods Fields Properties Events See Also

The AppointmentWrapPanel type exposes the following members.

Constructors

 | Name | Description
Public method | AppointmentWrapPanel | Creates the new instance of the AppointmentWrapPanel class.

Methods

 | Name | Description
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Arranges the content of a AppointmentWrapPanel element. (Overrides C1WrapPanelArrangeOverride(Size).)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Measures the child elements of a AppointmentWrapPanel in anticipation of arranging them during the ArrangeOverride(Size) pass. (Overrides C1WrapPanelMeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
DockLastChildToEndProperty | Identifies the DockLastChildToEnd dependency property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. This is a dependency property. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | DockLastChildToEnd | The DockLastChildToEnd property determines whether the last child element should be docked to the bottom right corner of the AppointmentWrapPanel. The default value is False. This is a dependency property.
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | ItemHeight | (Inherited from C1WrapPanel.)
Public property | ItemWidth | (Inherited from C1WrapPanel.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Orientation | (Inherited from C1WrapPanel.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

AppointmentWrapPanel Class


AppointmentWrapPanel Constructor

[image]

.NET Framework Class Library
AppointmentWrapPanel Constructor
AppointmentWrapPanel Class See Also
Creates the new instance of the AppointmentWrapPanel class.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public AppointmentWrapPanel()
Visual Basic
Public Sub New

See Also

AppointmentWrapPanel Class


AppointmentWrapPanel Fields

[image] [image]

.NET Framework Class Library
AppointmentWrapPanel Fields
AppointmentWrapPanel Class See Also

The AppointmentWrapPanel type exposes the following members.

Fields

Name | Description
DockLastChildToEndProperty | Identifies the DockLastChildToEnd dependency property.

See Also

AppointmentWrapPanel Class


DockLastChildToEndProperty Field

[image]

.NET Framework Class Library
AppointmentWrapPanel..::..DockLastChildToEndProperty Field
AppointmentWrapPanel Class See Also
Identifies the DockLastChildToEnd dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty DockLastChildToEndProperty
Visual Basic
Public Shared ReadOnly DockLastChildToEndProperty As DependencyProperty

See Also

AppointmentWrapPanel Class


AppointmentWrapPanel Methods

[image] [image]

.NET Framework Class Library
AppointmentWrapPanel Methods
AppointmentWrapPanel Class See Also

The AppointmentWrapPanel type exposes the following members.

Methods

 | Name | Description
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Arranges the content of a AppointmentWrapPanel element. (Overrides C1WrapPanelArrangeOverride(Size).)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Measures the child elements of a AppointmentWrapPanel in anticipation of arranging them during the ArrangeOverride(Size) pass. (Overrides C1WrapPanelMeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

AppointmentWrapPanel Class


ArrangeOverride Method

[image]

.NET Framework Class Library
AppointmentWrapPanel..::..ArrangeOverride Method
AppointmentWrapPanel Class See Also
Arranges the content of a AppointmentWrapPanel element.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override Size ArrangeOverride(
    Size finalSize
)
Visual Basic
Protected Overrides Function ArrangeOverride ( _
    finalSize As Size _
) As Size

Parameters

finalSize
Type: System.Windows..::..Size
The Size that this element should use to arrange its child elements.

Return Value

The Size that represents the arranged size of this AppointmentWrapPanel element and its children.

See Also

AppointmentWrapPanel Class


MeasureOverride Method

[image]

.NET Framework Class Library
AppointmentWrapPanel..::..MeasureOverride Method
AppointmentWrapPanel Class See Also
Measures the child elements of a AppointmentWrapPanel in anticipation of arranging them during the ArrangeOverride(Size) pass.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override Size MeasureOverride(
    Size constraint
)
Visual Basic
Protected Overrides Function MeasureOverride ( _
    constraint As Size _
) As Size

Parameters

constraint
Type: System.Windows..::..Size
An upper limit Size that should not be exceeded.

Return Value

The Size that represents the desired size of the element.

See Also

AppointmentWrapPanel Class


AppointmentWrapPanel Properties

[image] [image]

.NET Framework Class Library
AppointmentWrapPanel Properties
AppointmentWrapPanel Class See Also

The AppointmentWrapPanel type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. This is a dependency property. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | DockLastChildToEnd | The DockLastChildToEnd property determines whether the last child element should be docked to the bottom right corner of the AppointmentWrapPanel. The default value is False. This is a dependency property.
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | ItemHeight | (Inherited from C1WrapPanel.)
Public property | ItemWidth | (Inherited from C1WrapPanel.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Orientation | (Inherited from C1WrapPanel.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

AppointmentWrapPanel Class


DockLastChildToEnd Property

[image]

.NET Framework Class Library
AppointmentWrapPanel..::..DockLastChildToEnd Property
AppointmentWrapPanel Class See Also
The DockLastChildToEnd property determines whether the last child element should be docked to the bottom right corner of the AppointmentWrapPanel. The default value is False. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool DockLastChildToEnd { get; set; }
Visual Basic
Public Property DockLastChildToEnd As Boolean
    Get
    Set

Remarks

For the sample of using look at IntervalAppointmentTemplate in Office 2007 themes. It always shows appointment icons in the bottom right corner of the AppointmentWrapPanel.

See Also

AppointmentWrapPanel Class


AppointmentWrapPanel Events

[image] [image]

.NET Framework Class Library
AppointmentWrapPanel Events
AppointmentWrapPanel Class See Also

The AppointmentWrapPanel type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

AppointmentWrapPanel Class


ArithmeticSubtractConverter Class

[image]

.NET Framework Class Library
ArithmeticSubtractConverter Class
Members See Also
Represents a Binding converter that returns the double value representing the difference between value and converter parameter. This is a one-way converter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class ArithmeticSubtractConverter : IValueConverter
Visual Basic
Public Class ArithmeticSubtractConverter _
    Implements IValueConverter

Remarks

Converted value and converter parameter might be of any type which implements IConvertible interface.

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..ArithmeticSubtractConverter

See Also

ArithmeticSubtractConverter Members


ArithmeticSubtractConverter Members

[image] [image]

.NET Framework Class Library
ArithmeticSubtractConverter Members
ArithmeticSubtractConverter Class Constructors Methods Fields See Also

The ArithmeticSubtractConverter type exposes the following members.

Constructors

 | Name | Description
Public method | ArithmeticSubtractConverter |

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Not implemented.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Default | Gets an instance of ArithmeticSubtractConverter.

See Also

ArithmeticSubtractConverter Class


ArithmeticSubtractConverter Constructor

[image]

.NET Framework Class Library
ArithmeticSubtractConverter Constructor
ArithmeticSubtractConverter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ArithmeticSubtractConverter()
Visual Basic
Public Sub New

See Also

ArithmeticSubtractConverter Class


ArithmeticSubtractConverter Fields

[image] [image]

.NET Framework Class Library
ArithmeticSubtractConverter Fields
ArithmeticSubtractConverter Class See Also

The ArithmeticSubtractConverter type exposes the following members.

Fields

Name | Description
Default | Gets an instance of ArithmeticSubtractConverter.

See Also

ArithmeticSubtractConverter Class


Default Field

[image]

.NET Framework Class Library
ArithmeticSubtractConverter..::..Default Field
ArithmeticSubtractConverter Class See Also
Gets an instance of ArithmeticSubtractConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly ArithmeticSubtractConverter Default
Visual Basic
Public Shared ReadOnly Default As ArithmeticSubtractConverter

See Also

ArithmeticSubtractConverter Class


ArithmeticSubtractConverter Methods

[image] [image]

.NET Framework Class Library
ArithmeticSubtractConverter Methods
ArithmeticSubtractConverter Class See Also

The ArithmeticSubtractConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Not implemented.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ArithmeticSubtractConverter Class


Convert Method

[image]

.NET Framework Class Library
ArithmeticSubtractConverter..::..Convert Method
ArithmeticSubtractConverter Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

ArithmeticSubtractConverter Class


ConvertBack Method

[image]

.NET Framework Class Library
ArithmeticSubtractConverter..::..ConvertBack Method
ArithmeticSubtractConverter Class See Also
Not implemented.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value that is produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

ArithmeticSubtractConverter Class


BeforeViewChangeEventArgs Class

[image]

.NET Framework Class Library
BeforeViewChangeEventArgs Class
Members See Also
Provides data for the BeforeViewChange event of the C1Scheduler control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class BeforeViewChangeEventArgs : RoutedEventArgs
Visual Basic
Public Class BeforeViewChangeEventArgs _
    Inherits RoutedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.Windows..::..RoutedEventArgs
C1.Silverlight.Schedule..::..BeforeViewChangeEventArgs

See Also

BeforeViewChangeEventArgs Members


BeforeViewChangeEventArgs Members

[image] [image]

.NET Framework Class Library
BeforeViewChangeEventArgs Members
BeforeViewChangeEventArgs Class Methods Properties See Also

The BeforeViewChangeEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Dates | Gets or sets the range of dates which should be selected in the view.
Public property | Handled | Gets or sets a value that indicates the present state of the event handling.
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)
Public property | Style | Gets or sets Style value determining which Style should be selected.

See Also

BeforeViewChangeEventArgs Class


BeforeViewChangeEventArgs Methods

[image] [image]

.NET Framework Class Library
BeforeViewChangeEventArgs Methods
BeforeViewChangeEventArgs Class See Also

The BeforeViewChangeEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeforeViewChangeEventArgs Class


BeforeViewChangeEventArgs Properties

[image] [image]

.NET Framework Class Library
BeforeViewChangeEventArgs Properties
BeforeViewChangeEventArgs Class See Also

The BeforeViewChangeEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Dates | Gets or sets the range of dates which should be selected in the view.
Public property | Handled | Gets or sets a value that indicates the present state of the event handling.
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)
Public property | Style | Gets or sets Style value determining which Style should be selected.

See Also

BeforeViewChangeEventArgs Class


Dates Property

[image]

.NET Framework Class Library
BeforeViewChangeEventArgs..::..Dates Property
BeforeViewChangeEventArgs Class See Also
Gets or sets the range of dates which should be selected in the view.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTime[] Dates { get; set; }
Visual Basic
Public Property Dates As DateTime()
    Get
    Set

See Also

BeforeViewChangeEventArgs Class


Handled Property

[image]

.NET Framework Class Library
BeforeViewChangeEventArgs..::..Handled Property
BeforeViewChangeEventArgs Class See Also
Gets or sets a value that indicates the present state of the event handling.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool Handled { get; set; }
Visual Basic
Public Property Handled As Boolean
    Get
    Set

See Also

BeforeViewChangeEventArgs Class


Style Property

[image]

.NET Framework Class Library
BeforeViewChangeEventArgs..::..Style Property
BeforeViewChangeEventArgs Class See Also
Gets or sets Style value determining which Style should be selected.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Style Style { get; set; }
Visual Basic
Public Property Style As Style
    Get
    Set

See Also

BeforeViewChangeEventArgs Class


BooleanToVisibilityConverter Class

[image]

.NET Framework Class Library
BooleanToVisibilityConverter Class
Members See Also
Represents a Binding converter that converts a Boolean to the corresponding Visibility value. If ConverterParameter is not null, returns inverted value.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class BooleanToVisibilityConverter : IValueConverter
Visual Basic
Public Class BooleanToVisibilityConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..BooleanToVisibilityConverter

See Also

BooleanToVisibilityConverter Members


BooleanToVisibilityConverter Members

[image] [image]

.NET Framework Class Library
BooleanToVisibilityConverter Members
BooleanToVisibilityConverter Class Constructors Methods Fields See Also

The BooleanToVisibilityConverter type exposes the following members.

Constructors

 | Name | Description
Public method | BooleanToVisibilityConverter | Initializes a new instance of the BooleanToVisibilityConverter.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Default | Gets an instance of BooleanToVisibilityConverter.

See Also

BooleanToVisibilityConverter Class


BooleanToVisibilityConverter Constructor

[image]

.NET Framework Class Library
BooleanToVisibilityConverter Constructor
BooleanToVisibilityConverter Class See Also
Initializes a new instance of the BooleanToVisibilityConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public BooleanToVisibilityConverter()
Visual Basic
Public Sub New

See Also

BooleanToVisibilityConverter Class


BooleanToVisibilityConverter Fields

[image] [image]

.NET Framework Class Library
BooleanToVisibilityConverter Fields
BooleanToVisibilityConverter Class See Also

The BooleanToVisibilityConverter type exposes the following members.

Fields

Name | Description
Default | Gets an instance of BooleanToVisibilityConverter.

See Also

BooleanToVisibilityConverter Class


Default Field

[image]

.NET Framework Class Library
BooleanToVisibilityConverter..::..Default Field
BooleanToVisibilityConverter Class See Also
Gets an instance of BooleanToVisibilityConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly BooleanToVisibilityConverter Default
Visual Basic
Public Shared ReadOnly Default As BooleanToVisibilityConverter

See Also

BooleanToVisibilityConverter Class


BooleanToVisibilityConverter Methods

[image] [image]

.NET Framework Class Library
BooleanToVisibilityConverter Methods
BooleanToVisibilityConverter Class See Also

The BooleanToVisibilityConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BooleanToVisibilityConverter Class


Convert Method

[image]

.NET Framework Class Library
BooleanToVisibilityConverter..::..Convert Method
BooleanToVisibilityConverter Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

BooleanToVisibilityConverter Class


ConvertBack Method

[image]

.NET Framework Class Library
BooleanToVisibilityConverter..::..ConvertBack Method
BooleanToVisibilityConverter Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value that is produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

BooleanToVisibilityConverter Class


C1Calendar Class

[image]

.NET Framework Class Library
C1Calendar Class
Members See Also
Represents a multi month calendar with an ability to interactively navigate through months and select a specific DateTime value or its components.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[StyleTypedPropertyAttribute(Property = "MonthSlotStyle", StyleTargetType = typeof(MonthSlotPresenter))]
[StyleTypedPropertyAttribute(Property = "MonthCalendarStyle", StyleTargetType = typeof(C1CalendarItem))]
public class C1Calendar : CalendarBase, ICollectionChangedListener
Visual Basic
<StyleTypedPropertyAttribute(Property := "MonthSlotStyle", StyleTargetType := GetType(MonthSlotPresenter))> _
<StyleTypedPropertyAttribute(Property := "MonthCalendarStyle", StyleTargetType := GetType(C1CalendarItem))> _
Public Class C1Calendar _
    Inherits CalendarBase _
    Implements ICollectionChangedListener

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
C1.Silverlight.Schedule..::..CalendarBase
C1.Silverlight.Schedule..::..C1Calendar

See Also

C1Calendar Members


C1Calendar Members

[image] [image]

.NET Framework Class Library
C1Calendar Members
C1Calendar Class Constructors Methods Fields Properties Events See Also

The C1Calendar type exposes the following members.

Constructors

 | Name | Description
Public method | C1Calendar | Initializes the new instance of the C1Calendar control.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | Calendar_Loaded | (Overrides CalendarBase..::..Calendar_Loaded(Object, RoutedEventArgs).)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Protected method | InvalidateCalendarHelper | (Inherited from CalendarBase.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Protected method | InvalidateTheme | (Inherited from CalendarBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextMonth | Makes the next month the month that is currently represented by the control.
Public method | OnApplyTemplate | (Overrides CalendarBase..::..OnApplyTemplate()()()().)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Overrides ControlOnKeyUp(KeyEventArgs).)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMaxDateChanged | (Overrides CalendarBase..::..OnMaxDateChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnMinDateChanged | (Overrides CalendarBase..::..OnMinDateChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnMonthChanged | (Inherited from CalendarBase.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Overrides ControlOnMouseLeftButtonUp(MouseButtonEventArgs).)
Protected method | OnMouseMove | Selects continuous dates if mouse moved with left button pressed. (Overrides ControlOnMouseMove(MouseEventArgs).)
Public method | PreviousMonth | Makes the previous month the month that is currently represented by the control.
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | RefreshTheme | (Overrides CalendarBase..::..RefreshTheme(ResourceDictionary, ResourceDictionary).)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Protected method | SetSelectionToDate | (Overrides CalendarBase..::..SetSelectionToDate()()()().)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | Today | Navigates control to the current date.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

 | Name | Description
 | AdjacentMonthDayBrushProperty | Identifies the AdjacentMonthDayBrush dependency property.
 | BoldedDatesProperty | Identifies the BoldedDates dependency property.
 | DaysOfWeekBorderBrushProperty | Identifies the DaysOfWeekBorderBrush dependency property.
 | DisabledDayBrushProperty | Identifies the DisabledDayBrush dependency property.
 | GenerateAdjacentMonthDaysProperty | Identifies the GenerateAdjacentMonthDays dependency property.
 | MaxSelectionCountProperty | Identifies the MaxSelectionCount dependency property.
 | MonthCalendarStyleProperty | Identifies the MonthCalendarStyle dependency property.
 | MonthCountProperty | Identifies the MonthCount dependency property.
 | MonthHeaderBackgroundProperty | Identifies the MonthHeaderBackground dependency property.
 | MonthHeaderFontFamilyProperty | Identifies the MonthHeaderFontFamily dependency property.
 | MonthHeaderFontSizeProperty | Identifies the MonthHeaderFontSize dependency property.
 | MonthHeaderFontWeightProperty | Identifies the MonthHeaderFontWeight dependency property.
 | MonthHeaderForegroundProperty | Identifies the MonthHeaderForeground dependency property.
 | MonthHeightProperty | Identifies the MonthHeight dependency property.
 | MonthSlotStyleProperty | Identifies the MonthSlotStyle dependency property.
 | MonthsPanelProperty | Identifies the MonthsPanel dependency property.
 | MonthWidthProperty | Identifies the MonthWidth dependency property.
 | NavigationButtonBrushProperty | Identifies the NavigationButtonBrush dependency property.
 | NextMonthCommand | Defines the command that makes a next month the month that is currently represented by the control.
 | PreviousMonthCommand | Defines the command that makes a previous month the month that is currently represented by the control.
Protected field | selectedDateGroupChangeInitiator | (Inherited from CalendarBase.)
 | SelectedDatesProperty | Identifies the SelectedDates dependency property.
 | SelectedDayBrushProperty | Identifies the SelectedDayBrush dependency property.
 | TodayBrushProperty | Identifies the TodayBrush dependency property.
 | WeekendBrushProperty | Identifies the WeekendBrush dependency property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | AdjacentMonthDayBrush | Gets or sets a Brush object used to display adjacent month days. This is a dependency property.
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BoldedDates | Gets or sets the list of bolded dates. This is a dependency property.
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CalendarHelper | Gets or sets the CalendarHelper object that provides calendar-dependant properties. This is a dependency property. (Inherited from CalendarBase.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DayOfWeekSlotStyle | Gets or sets a Style for DayOfWeekSlotPresenter elements which are the root elements of a visual tree representing a single day of the week. (Inherited from CalendarBase.)
Public property | DayOfWeekSlotTemplate | Gets or sets a DataTemplate that defines a UI representation of a single day of the week. This is a dependency property. (Inherited from CalendarBase.)
Public property | DaySlotStyle | Gets or sets a Style for DaySlotPresenter elements which are the root elements of a visual tree representing a single day of a month. (Inherited from CalendarBase.)
Public property | DaySlotTemplate | Gets or sets a DataTemplate that defines a UI representation of a single day of a month. This is a dependency property. (Inherited from CalendarBase.)
Public property | DaysOfWeekBorderBrush | Gets or sets a Brush object used to underline days of week. This is a dependency property.
Public property | DaysOfWeekPanel | Gets or sets an ItemsPanelTemplate that defines the panel that lays out elements representing days of the week. This is a dependency property. (Inherited from CalendarBase.)
Public property | DaysPanel | Gets or sets an ItemsPanelTemplate that defines the panel that lays out elements representing days of a month. This is a dependency property. (Inherited from CalendarBase.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DisabledDayBrush | Gets or sets a Brush object used to display disabled days. This is a dependency property.
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | GenerateAdjacentMonthDays | Gets or sets a value that determines whether to show days corresponding to months which are adjacent for the months currently represented by the control. The default value is False. This is a dependency property.
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IsDisposed | (Inherited from CalendarBase.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxDate | Gets or sets the maximum allowable date. The default is 12/31/9998. This is a dependency property. (Inherited from CalendarBase.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxSelectionCount | Gets or sets the maximum number of days that can be selected in the control. This is a dependency property.
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinDate | Gets or sets the minimum allowable date. The default is 01/01/1753. This is a dependency property. (Inherited from CalendarBase.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Month | Gets or sets a month component of the SelectedDate property. This is a dependency property. (Inherited from CalendarBase.)
Public property | MonthCalendarStyle | Gets or sets a Style applied to each child C1CalendarItem representing a single month. This is a dependency property.
Public property | MonthCount | Gets or sets a number of months currently represented by the calendar. The default value is 1. This is a dependency property.
Public property | MonthHeaderBackground | Gets or sets a Brush object used to color month header. This is a dependency property.
Public property | MonthHeaderFontFamily | Gets or sets a FontFamily object used to to display month header text. This is a dependency property.
Public property | MonthHeaderFontSize | Gets or sets a Double value determining month header font size. This is a dependency property.
Public property | MonthHeaderFontWeight | Gets or sets a FontWeight object used to to display month header text. This is a dependency property.
Public property | MonthHeaderForeground | Gets or sets a Brush object used to color month header text. This is a dependency property.
Public property | MonthHeight | Gets or sets a value that determines a height of each month slot of the calendar. This is a dependency property.
Public property | MonthSlotStyle | Gets or sets a Style for C1CalendarPresenter elements which are the root elements of a visual tree representing a single month. This is a dependency property.
Public property | MonthsPanel | Gets or sets an ItemsPanelTemplate that defines the panel that lays out elements representing separate months. This is a dependency property.
Public property | MonthWidth | Gets or sets a value that determines a width of each month slot of the calendar. This is a dependency property.
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | NavigationButtonBrush | Gets or sets a Brush object used to color navigation buttons. This is a dependency property.
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDate | Gets or sets the currently selected date. This is a dependency property. (Inherited from CalendarBase.)
Public property | SelectedDates | Gets or sets the list of selected dates. This is a dependency property.
Public property | SelectedDayBrush | Gets or sets a Brush object used to highlight selected dates. This is a dependency property.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | SyncRepresentationToDateTime | Gets the Boolean value, determining whether control synchronizes it's representation according to the changes of DateTime property. (Inherited from CalendarBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Theme | Gets or sets a ResourceDictionary object containing calendar theme resources. (Inherited from CalendarBase.)
Public property | TodayBrush | Gets or sets a Brush object used to highlight current date. This is a dependency property.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | WeekendBrush | Gets or sets a Brush object used to display weekends. This is a dependency property.
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Year | Gets or sets a year component of the SelectedDate property. This is a dependency property. (Inherited from CalendarBase.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SelectedDateChanged | Occurs when the SelectedDate property value has been changed. (Inherited from CalendarBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

C1Calendar Class


C1Calendar Constructor

[image]

.NET Framework Class Library
C1Calendar Constructor
C1Calendar Class See Also
Initializes the new instance of the C1Calendar control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1Calendar()
Visual Basic
Public Sub New

See Also

C1Calendar Class


C1Calendar Fields

[image] [image]

.NET Framework Class Library
C1Calendar Fields
C1Calendar Class See Also

The C1Calendar type exposes the following members.

Fields

 | Name | Description
 | AdjacentMonthDayBrushProperty | Identifies the AdjacentMonthDayBrush dependency property.
 | BoldedDatesProperty | Identifies the BoldedDates dependency property.
 | DaysOfWeekBorderBrushProperty | Identifies the DaysOfWeekBorderBrush dependency property.
 | DisabledDayBrushProperty | Identifies the DisabledDayBrush dependency property.
 | GenerateAdjacentMonthDaysProperty | Identifies the GenerateAdjacentMonthDays dependency property.
 | MaxSelectionCountProperty | Identifies the MaxSelectionCount dependency property.
 | MonthCalendarStyleProperty | Identifies the MonthCalendarStyle dependency property.
 | MonthCountProperty | Identifies the MonthCount dependency property.
 | MonthHeaderBackgroundProperty | Identifies the MonthHeaderBackground dependency property.
 | MonthHeaderFontFamilyProperty | Identifies the MonthHeaderFontFamily dependency property.
 | MonthHeaderFontSizeProperty | Identifies the MonthHeaderFontSize dependency property.
 | MonthHeaderFontWeightProperty | Identifies the MonthHeaderFontWeight dependency property.
 | MonthHeaderForegroundProperty | Identifies the MonthHeaderForeground dependency property.
 | MonthHeightProperty | Identifies the MonthHeight dependency property.
 | MonthSlotStyleProperty | Identifies the MonthSlotStyle dependency property.
 | MonthsPanelProperty | Identifies the MonthsPanel dependency property.
 | MonthWidthProperty | Identifies the MonthWidth dependency property.
 | NavigationButtonBrushProperty | Identifies the NavigationButtonBrush dependency property.
 | NextMonthCommand | Defines the command that makes a next month the month that is currently represented by the control.
 | PreviousMonthCommand | Defines the command that makes a previous month the month that is currently represented by the control.
Protected field | selectedDateGroupChangeInitiator | (Inherited from CalendarBase.)
 | SelectedDatesProperty | Identifies the SelectedDates dependency property.
 | SelectedDayBrushProperty | Identifies the SelectedDayBrush dependency property.
 | TodayBrushProperty | Identifies the TodayBrush dependency property.
 | WeekendBrushProperty | Identifies the WeekendBrush dependency property.

See Also

C1Calendar Class


AdjacentMonthDayBrushProperty Field

[image]

.NET Framework Class Library
C1Calendar..::..AdjacentMonthDayBrushProperty Field
C1Calendar Class See Also
Identifies the AdjacentMonthDayBrush dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty AdjacentMonthDayBrushProperty
Visual Basic
Public Shared ReadOnly AdjacentMonthDayBrushProperty As DependencyProperty

See Also

C1Calendar Class


BoldedDatesProperty Field

[image]

.NET Framework Class Library
C1Calendar..::..BoldedDatesProperty Field
C1Calendar Class See Also
Identifies the BoldedDates dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty BoldedDatesProperty
Visual Basic
Public Shared ReadOnly BoldedDatesProperty As DependencyProperty

See Also

C1Calendar Class


DaysOfWeekBorderBrushProperty Field

[image]

.NET Framework Class Library
C1Calendar..::..DaysOfWeekBorderBrushProperty Field
C1Calendar Class See Also
Identifies the DaysOfWeekBorderBrush dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty DaysOfWeekBorderBrushProperty
Visual Basic
Public Shared ReadOnly DaysOfWeekBorderBrushProperty As DependencyProperty

See Also

C1Calendar Class


DisabledDayBrushProperty Field

[image]

.NET Framework Class Library
C1Calendar..::..DisabledDayBrushProperty Field
C1Calendar Class See Also
Identifies the DisabledDayBrush dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty DisabledDayBrushProperty
Visual Basic
Public Shared ReadOnly DisabledDayBrushProperty As DependencyProperty

See Also

C1Calendar Class


GenerateAdjacentMonthDaysProperty Field

[image]

.NET Framework Class Library
C1Calendar..::..GenerateAdjacentMonthDaysProperty Field
C1Calendar Class See Also
Identifies the GenerateAdjacentMonthDays dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty GenerateAdjacentMonthDaysProperty
Visual Basic
Public Shared ReadOnly GenerateAdjacentMonthDaysProperty As DependencyProperty

See Also

C1Calendar Class


MaxSelectionCountProperty Field

[image]

.NET Framework Class Library
C1Calendar..::..MaxSelectionCountProperty Field
C1Calendar Class See Also
Identifies the MaxSelectionCount dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty MaxSelectionCountProperty
Visual Basic
Public Shared ReadOnly MaxSelectionCountProperty As DependencyProperty

See Also

C1Calendar Class


MonthCalendarStyleProperty Field

[image]

.NET Framework Class Library
C1Calendar..::..MonthCalendarStyleProperty Field
C1Calendar Class See Also
Identifies the MonthCalendarStyle dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty MonthCalendarStyleProperty
Visual Basic
Public Shared ReadOnly MonthCalendarStyleProperty As DependencyProperty

See Also

C1Calendar Class


MonthCountProperty Field

[image]

.NET Framework Class Library
C1Calendar..::..MonthCountProperty Field
C1Calendar Class See Also
Identifies the MonthCount dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty MonthCountProperty
Visual Basic
Public Shared ReadOnly MonthCountProperty As DependencyProperty

See Also

C1Calendar Class


MonthHeaderBackgroundProperty Field

[image]

.NET Framework Class Library
C1Calendar..::..MonthHeaderBackgroundProperty Field
C1Calendar Class See Also
Identifies the MonthHeaderBackground dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty MonthHeaderBackgroundProperty
Visual Basic
Public Shared ReadOnly MonthHeaderBackgroundProperty As DependencyProperty

See Also

C1Calendar Class


MonthHeaderFontFamilyProperty Field

[image]

.NET Framework Class Library
C1Calendar..::..MonthHeaderFontFamilyProperty Field
C1Calendar Class See Also
Identifies the MonthHeaderFontFamily dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty MonthHeaderFontFamilyProperty
Visual Basic
Public Shared ReadOnly MonthHeaderFontFamilyProperty As DependencyProperty

See Also

C1Calendar Class


MonthHeaderFontSizeProperty Field

[image]

.NET Framework Class Library
C1Calendar..::..MonthHeaderFontSizeProperty Field
C1Calendar Class See Also
Identifies the MonthHeaderFontSize dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty MonthHeaderFontSizeProperty
Visual Basic
Public Shared ReadOnly MonthHeaderFontSizeProperty As DependencyProperty

See Also

C1Calendar Class


MonthHeaderFontWeightProperty Field

[image]

.NET Framework Class Library
C1Calendar..::..MonthHeaderFontWeightProperty Field
C1Calendar Class See Also
Identifies the MonthHeaderFontWeight dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty MonthHeaderFontWeightProperty
Visual Basic
Public Shared ReadOnly MonthHeaderFontWeightProperty As DependencyProperty

See Also

C1Calendar Class


MonthHeaderForegroundProperty Field

[image]

.NET Framework Class Library
C1Calendar..::..MonthHeaderForegroundProperty Field
C1Calendar Class See Also
Identifies the MonthHeaderForeground dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty MonthHeaderForegroundProperty
Visual Basic
Public Shared ReadOnly MonthHeaderForegroundProperty As DependencyProperty

See Also

C1Calendar Class


MonthHeightProperty Field

[image]

.NET Framework Class Library
C1Calendar..::..MonthHeightProperty Field
C1Calendar Class See Also
Identifies the MonthHeight dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty MonthHeightProperty
Visual Basic
Public Shared ReadOnly MonthHeightProperty As DependencyProperty

See Also

C1Calendar Class


MonthSlotStyleProperty Field

[image]

.NET Framework Class Library
C1Calendar..::..MonthSlotStyleProperty Field
C1Calendar Class See Also
Identifies the MonthSlotStyle dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty MonthSlotStyleProperty
Visual Basic
Public Shared ReadOnly MonthSlotStyleProperty As DependencyProperty

See Also

C1Calendar Class


MonthsPanelProperty Field

[image]

.NET Framework Class Library
C1Calendar..::..MonthsPanelProperty Field
C1Calendar Class See Also
Identifies the MonthsPanel dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty MonthsPanelProperty
Visual Basic
Public Shared ReadOnly MonthsPanelProperty As DependencyProperty

See Also

C1Calendar Class


MonthWidthProperty Field

[image]

.NET Framework Class Library
C1Calendar..::..MonthWidthProperty Field
C1Calendar Class See Also
Identifies the MonthWidth dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty MonthWidthProperty
Visual Basic
Public Shared ReadOnly MonthWidthProperty As DependencyProperty

See Also

C1Calendar Class


NavigationButtonBrushProperty Field

[image]

.NET Framework Class Library
C1Calendar..::..NavigationButtonBrushProperty Field
C1Calendar Class See Also
Identifies the NavigationButtonBrush dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty NavigationButtonBrushProperty
Visual Basic
Public Shared ReadOnly NavigationButtonBrushProperty As DependencyProperty

See Also

C1Calendar Class


NextMonthCommand Field

[image]

.NET Framework Class Library
C1Calendar..::..NextMonthCommand Field
C1Calendar Class See Also
Defines the command that makes a next month the month that is currently represented by the control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly C1Command NextMonthCommand
Visual Basic
Public Shared ReadOnly NextMonthCommand As C1Command

Remarks

This command is executed by the CalendarBase and is implemented by the NextMonth()()()() method.

See Also

C1Calendar Class


PreviousMonthCommand Field

[image]

.NET Framework Class Library
C1Calendar..::..PreviousMonthCommand Field
C1Calendar Class See Also
Defines the command that makes a previous month the month that is currently represented by the control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly C1Command PreviousMonthCommand
Visual Basic
Public Shared ReadOnly PreviousMonthCommand As C1Command

Remarks

This command is executed by the CalendarBase and is implemented by the PreviousMonth()()()() method.

See Also

C1Calendar Class


SelectedDatesProperty Field

[image]

.NET Framework Class Library
C1Calendar..::..SelectedDatesProperty Field
C1Calendar Class See Also
Identifies the SelectedDates dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty SelectedDatesProperty
Visual Basic
Public Shared ReadOnly SelectedDatesProperty As DependencyProperty

See Also

C1Calendar Class


SelectedDayBrushProperty Field

[image]

.NET Framework Class Library
C1Calendar..::..SelectedDayBrushProperty Field
C1Calendar Class See Also
Identifies the SelectedDayBrush dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty SelectedDayBrushProperty
Visual Basic
Public Shared ReadOnly SelectedDayBrushProperty As DependencyProperty

See Also

C1Calendar Class


TodayBrushProperty Field

[image]

.NET Framework Class Library
C1Calendar..::..TodayBrushProperty Field
C1Calendar Class See Also
Identifies the TodayBrush dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty TodayBrushProperty
Visual Basic
Public Shared ReadOnly TodayBrushProperty As DependencyProperty

See Also

C1Calendar Class


WeekendBrushProperty Field

[image]

.NET Framework Class Library
C1Calendar..::..WeekendBrushProperty Field
C1Calendar Class See Also
Identifies the WeekendBrush dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty WeekendBrushProperty
Visual Basic
Public Shared ReadOnly WeekendBrushProperty As DependencyProperty

See Also

C1Calendar Class


C1Calendar Methods

[image] [image]

.NET Framework Class Library
C1Calendar Methods
C1Calendar Class See Also

The C1Calendar type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | Calendar_Loaded | (Overrides CalendarBase..::..Calendar_Loaded(Object, RoutedEventArgs).)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Protected method | InvalidateCalendarHelper | (Inherited from CalendarBase.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Protected method | InvalidateTheme | (Inherited from CalendarBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextMonth | Makes the next month the month that is currently represented by the control.
Public method | OnApplyTemplate | (Overrides CalendarBase..::..OnApplyTemplate()()()().)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Overrides ControlOnKeyUp(KeyEventArgs).)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMaxDateChanged | (Overrides CalendarBase..::..OnMaxDateChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnMinDateChanged | (Overrides CalendarBase..::..OnMinDateChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnMonthChanged | (Inherited from CalendarBase.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Overrides ControlOnMouseLeftButtonUp(MouseButtonEventArgs).)
Protected method | OnMouseMove | Selects continuous dates if mouse moved with left button pressed. (Overrides ControlOnMouseMove(MouseEventArgs).)
Public method | PreviousMonth | Makes the previous month the month that is currently represented by the control.
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | RefreshTheme | (Overrides CalendarBase..::..RefreshTheme(ResourceDictionary, ResourceDictionary).)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Protected method | SetSelectionToDate | (Overrides CalendarBase..::..SetSelectionToDate()()()().)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | Today | Navigates control to the current date.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

C1Calendar Class


Calendar_Loaded Method

[image]

.NET Framework Class Library
C1Calendar..::..Calendar_Loaded Method
C1Calendar Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void Calendar_Loaded(
    Object sender,
    RoutedEventArgs e
)
Visual Basic
Protected Overrides Sub Calendar_Loaded ( _
    sender As Object, _
    e As RoutedEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: System.Windows..::..RoutedEventArgs

See Also

C1Calendar Class


NextMonth Method

[image]

.NET Framework Class Library
C1Calendar..::..NextMonth Method
C1Calendar Class See Also
Makes the next month the month that is currently represented by the control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void NextMonth()
Visual Basic
Public Sub NextMonth

See Also

C1Calendar Class


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1Calendar..::..OnApplyTemplate Method
C1Calendar Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic
Public Overrides Sub OnApplyTemplate

See Also

C1Calendar Class


OnKeyUp Method

[image]

.NET Framework Class Library
C1Calendar..::..OnKeyUp Method
C1Calendar Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnKeyUp(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyUp ( _
    e As KeyEventArgs _
)

Parameters

e
Type: System.Windows.Input..::..KeyEventArgs

See Also

C1Calendar Class


OnMaxDateChanged Method

[image]

.NET Framework Class Library
C1Calendar..::..OnMaxDateChanged Method
C1Calendar Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnMaxDateChanged(
    DependencyPropertyChangedEventArgs e
)
Visual Basic
Protected Overrides Sub OnMaxDateChanged ( _
    e As DependencyPropertyChangedEventArgs _
)

Parameters

e
Type: System.Windows..::..DependencyPropertyChangedEventArgs

See Also

C1Calendar Class


OnMinDateChanged Method

[image]

.NET Framework Class Library
C1Calendar..::..OnMinDateChanged Method
C1Calendar Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnMinDateChanged(
    DependencyPropertyChangedEventArgs e
)
Visual Basic
Protected Overrides Sub OnMinDateChanged ( _
    e As DependencyPropertyChangedEventArgs _
)

Parameters

e
Type: System.Windows..::..DependencyPropertyChangedEventArgs

See Also

C1Calendar Class


OnMouseLeftButtonUp Method

[image]

.NET Framework Class Library
C1Calendar..::..OnMouseLeftButtonUp Method
C1Calendar Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnMouseLeftButtonUp(
    MouseButtonEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseLeftButtonUp ( _
    e As MouseButtonEventArgs _
)

Parameters

e
Type: System.Windows.Input..::..MouseButtonEventArgs

See Also

C1Calendar Class


OnMouseMove Method

[image]

.NET Framework Class Library
C1Calendar..::..OnMouseMove Method
C1Calendar Class See Also
Selects continuous dates if mouse moved with left button pressed.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)

Parameters

e
Type: System.Windows.Input..::..MouseEventArgs

See Also

C1Calendar Class


PreviousMonth Method

[image]

.NET Framework Class Library
C1Calendar..::..PreviousMonth Method
C1Calendar Class See Also
Makes the previous month the month that is currently represented by the control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void PreviousMonth()
Visual Basic
Public Sub PreviousMonth

See Also

C1Calendar Class


RefreshTheme Method

[image]

.NET Framework Class Library
C1Calendar..::..RefreshTheme Method
C1Calendar Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void RefreshTheme(
    ResourceDictionary oldTheme,
    ResourceDictionary newTheme
)
Visual Basic
Protected Overrides Sub RefreshTheme ( _
    oldTheme As ResourceDictionary, _
    newTheme As ResourceDictionary _
)

Parameters

oldTheme
Type: System.Windows..::..ResourceDictionary
newTheme
Type: System.Windows..::..ResourceDictionary

See Also

C1Calendar Class


SetSelectionToDate Method

[image]

.NET Framework Class Library
C1Calendar..::..SetSelectionToDate Method
C1Calendar Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void SetSelectionToDate()
Visual Basic
Protected Overrides Sub SetSelectionToDate

See Also

C1Calendar Class


Today Method

[image]

.NET Framework Class Library
C1Calendar..::..Today Method
C1Calendar Class See Also
Navigates control to the current date.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void Today()
Visual Basic
Public Sub Today

See Also

C1Calendar Class


C1Calendar Properties

[image] [image]

.NET Framework Class Library
C1Calendar Properties
C1Calendar Class See Also

The C1Calendar type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | AdjacentMonthDayBrush | Gets or sets a Brush object used to display adjacent month days. This is a dependency property.
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BoldedDates | Gets or sets the list of bolded dates. This is a dependency property.
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CalendarHelper | Gets or sets the CalendarHelper object that provides calendar-dependant properties. This is a dependency property. (Inherited from CalendarBase.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DayOfWeekSlotStyle | Gets or sets a Style for DayOfWeekSlotPresenter elements which are the root elements of a visual tree representing a single day of the week. (Inherited from CalendarBase.)
Public property | DayOfWeekSlotTemplate | Gets or sets a DataTemplate that defines a UI representation of a single day of the week. This is a dependency property. (Inherited from CalendarBase.)
Public property | DaySlotStyle | Gets or sets a Style for DaySlotPresenter elements which are the root elements of a visual tree representing a single day of a month. (Inherited from CalendarBase.)
Public property | DaySlotTemplate | Gets or sets a DataTemplate that defines a UI representation of a single day of a month. This is a dependency property. (Inherited from CalendarBase.)
Public property | DaysOfWeekBorderBrush | Gets or sets a Brush object used to underline days of week. This is a dependency property.
Public property | DaysOfWeekPanel | Gets or sets an ItemsPanelTemplate that defines the panel that lays out elements representing days of the week. This is a dependency property. (Inherited from CalendarBase.)
Public property | DaysPanel | Gets or sets an ItemsPanelTemplate that defines the panel that lays out elements representing days of a month. This is a dependency property. (Inherited from CalendarBase.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DisabledDayBrush | Gets or sets a Brush object used to display disabled days. This is a dependency property.
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | GenerateAdjacentMonthDays | Gets or sets a value that determines whether to show days corresponding to months which are adjacent for the months currently represented by the control. The default value is False. This is a dependency property.
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IsDisposed | (Inherited from CalendarBase.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxDate | Gets or sets the maximum allowable date. The default is 12/31/9998. This is a dependency property. (Inherited from CalendarBase.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxSelectionCount | Gets or sets the maximum number of days that can be selected in the control. This is a dependency property.
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinDate | Gets or sets the minimum allowable date. The default is 01/01/1753. This is a dependency property. (Inherited from CalendarBase.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Month | Gets or sets a month component of the SelectedDate property. This is a dependency property. (Inherited from CalendarBase.)
Public property | MonthCalendarStyle | Gets or sets a Style applied to each child C1CalendarItem representing a single month. This is a dependency property.
Public property | MonthCount | Gets or sets a number of months currently represented by the calendar. The default value is 1. This is a dependency property.
Public property | MonthHeaderBackground | Gets or sets a Brush object used to color month header. This is a dependency property.
Public property | MonthHeaderFontFamily | Gets or sets a FontFamily object used to to display month header text. This is a dependency property.
Public property | MonthHeaderFontSize | Gets or sets a Double value determining month header font size. This is a dependency property.
Public property | MonthHeaderFontWeight | Gets or sets a FontWeight object used to to display month header text. This is a dependency property.
Public property | MonthHeaderForeground | Gets or sets a Brush object used to color month header text. This is a dependency property.
Public property | MonthHeight | Gets or sets a value that determines a height of each month slot of the calendar. This is a dependency property.
Public property | MonthSlotStyle | Gets or sets a Style for C1CalendarPresenter elements which are the root elements of a visual tree representing a single month. This is a dependency property.
Public property | MonthsPanel | Gets or sets an ItemsPanelTemplate that defines the panel that lays out elements representing separate months. This is a dependency property.
Public property | MonthWidth | Gets or sets a value that determines a width of each month slot of the calendar. This is a dependency property.
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | NavigationButtonBrush | Gets or sets a Brush object used to color navigation buttons. This is a dependency property.
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDate | Gets or sets the currently selected date. This is a dependency property. (Inherited from CalendarBase.)
Public property | SelectedDates | Gets or sets the list of selected dates. This is a dependency property.
Public property | SelectedDayBrush | Gets or sets a Brush object used to highlight selected dates. This is a dependency property.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | SyncRepresentationToDateTime | Gets the Boolean value, determining whether control synchronizes it's representation according to the changes of DateTime property. (Inherited from CalendarBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Theme | Gets or sets a ResourceDictionary object containing calendar theme resources. (Inherited from CalendarBase.)
Public property | TodayBrush | Gets or sets a Brush object used to highlight current date. This is a dependency property.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | WeekendBrush | Gets or sets a Brush object used to display weekends. This is a dependency property.
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Year | Gets or sets a year component of the SelectedDate property. This is a dependency property. (Inherited from CalendarBase.)

See Also

C1Calendar Class


AdjacentMonthDayBrush Property

[image]

.NET Framework Class Library
C1Calendar..::..AdjacentMonthDayBrush Property
C1Calendar Class See Also
Gets or sets a Brush object used to display adjacent month days. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Brush AdjacentMonthDayBrush { get; set; }
Visual Basic
Public Property AdjacentMonthDayBrush As Brush
    Get
    Set

See Also

C1Calendar Class


BoldedDates Property

[image]

.NET Framework Class Library
C1Calendar..::..BoldedDates Property
C1Calendar Class See Also
Gets or sets the list of bolded dates. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public DateList BoldedDates { get; set; }
Visual Basic
<BrowsableAttribute(False)> _
Public Property BoldedDates As DateList
    Get
    Set

See Also

C1Calendar Class


DaysOfWeekBorderBrush Property

[image]

.NET Framework Class Library
C1Calendar..::..DaysOfWeekBorderBrush Property
C1Calendar Class See Also
Gets or sets a Brush object used to underline days of week. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Brush DaysOfWeekBorderBrush { get; set; }
Visual Basic
Public Property DaysOfWeekBorderBrush As Brush
    Get
    Set

See Also

C1Calendar Class


DisabledDayBrush Property

[image]

.NET Framework Class Library
C1Calendar..::..DisabledDayBrush Property
C1Calendar Class See Also
Gets or sets a Brush object used to display disabled days. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Brush DisabledDayBrush { get; set; }
Visual Basic
Public Property DisabledDayBrush As Brush
    Get
    Set

Remarks

The default value corresponds to the current value of the GrayTextColor property.

See Also

C1Calendar Class


GenerateAdjacentMonthDays Property

[image]

.NET Framework Class Library
C1Calendar..::..GenerateAdjacentMonthDays Property
C1Calendar Class See Also
Gets or sets a value that determines whether to show days corresponding to months which are adjacent for the months currently represented by the control. The default value is False. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool GenerateAdjacentMonthDays { get; set; }
Visual Basic
Public Property GenerateAdjacentMonthDays As Boolean
    Get
    Set

Remarks

If GenerateAdjacentMonthDays is set to true, the GenerateAdjacentPreviousMonthDays property for the C1CalendarItem showing a first of currently represented months and the GenerateAdjacentNextMonthDays property for the C1CalendarItem showing a last of currently represented months are set to true.

See Also

C1Calendar Class


MaxSelectionCount Property

[image]

.NET Framework Class Library
C1Calendar..::..MaxSelectionCount Property
C1Calendar Class See Also
Gets or sets the maximum number of days that can be selected in the control. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public int MaxSelectionCount { get; set; }
Visual Basic
Public Property MaxSelectionCount As Integer
    Get
    Set

See Also

C1Calendar Class


MonthCalendarStyle Property

[image]

.NET Framework Class Library
C1Calendar..::..MonthCalendarStyle Property
C1Calendar Class See Also
Gets or sets a Style applied to each child C1CalendarItem representing a single month. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Style MonthCalendarStyle { get; set; }
Visual Basic
Public Property MonthCalendarStyle As Style
    Get
    Set

See Also

C1Calendar Class


MonthCount Property

[image]

.NET Framework Class Library
C1Calendar..::..MonthCount Property
C1Calendar Class See Also
Gets or sets a number of months currently represented by the calendar. The default value is 1. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public int MonthCount { get; set; }
Visual Basic
Public Property MonthCount As Integer
    Get
    Set

Remarks

A default UI of the control is designed so as to fit as many child C1CalendarItem controls as can fit in the current control size, taking into account the size of each single month calendar which is determined by the MonthWidth and MonthHeight properties. As a result, when control is resized, a value of the MonthCount property is changed automatically.

You can change default behavior by using custom ItemsPanelTemplate. For more details see MonthsPanel property description.

See Also

C1Calendar Class


MonthHeaderBackground Property

[image]

.NET Framework Class Library
C1Calendar..::..MonthHeaderBackground Property
C1Calendar Class See Also
Gets or sets a Brush object used to color month header. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Brush MonthHeaderBackground { get; set; }
Visual Basic
Public Property MonthHeaderBackground As Brush
    Get
    Set

See Also

C1Calendar Class


MonthHeaderFontFamily Property

[image]

.NET Framework Class Library
C1Calendar..::..MonthHeaderFontFamily Property
C1Calendar Class See Also
Gets or sets a FontFamily object used to to display month header text. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public FontFamily MonthHeaderFontFamily { get; set; }
Visual Basic
Public Property MonthHeaderFontFamily As FontFamily
    Get
    Set

See Also

C1Calendar Class


MonthHeaderFontSize Property

[image]

.NET Framework Class Library
C1Calendar..::..MonthHeaderFontSize Property
C1Calendar Class See Also
Gets or sets a Double value determining month header font size. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public double MonthHeaderFontSize { get; set; }
Visual Basic
Public Property MonthHeaderFontSize As Double
    Get
    Set

See Also

C1Calendar Class


MonthHeaderFontWeight Property

[image]

.NET Framework Class Library
C1Calendar..::..MonthHeaderFontWeight Property
C1Calendar Class See Also
Gets or sets a FontWeight object used to to display month header text. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public FontWeight MonthHeaderFontWeight { get; set; }
Visual Basic
Public Property MonthHeaderFontWeight As FontWeight
    Get
    Set

See Also

C1Calendar Class


MonthHeaderForeground Property

[image]

.NET Framework Class Library
C1Calendar..::..MonthHeaderForeground Property
C1Calendar Class See Also
Gets or sets a Brush object used to color month header text. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Brush MonthHeaderForeground { get; set; }
Visual Basic
Public Property MonthHeaderForeground As Brush
    Get
    Set

See Also

C1Calendar Class


MonthHeight Property

[image]

.NET Framework Class Library
C1Calendar..::..MonthHeight Property
C1Calendar Class See Also
Gets or sets a value that determines a height of each month slot of the calendar. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public double MonthHeight { get; set; }
Visual Basic
Public Property MonthHeight As Double
    Get
    Set

See Also

C1Calendar Class


MonthSlotStyle Property

[image]

.NET Framework Class Library
C1Calendar..::..MonthSlotStyle Property
C1Calendar Class See Also
Gets or sets a Style for C1CalendarPresenter elements which are the root elements of a visual tree representing a single month. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Style MonthSlotStyle { get; set; }
Visual Basic
Public Property MonthSlotStyle As Style
    Get
    Set

See Also

C1Calendar Class


MonthsPanel Property

[image]

.NET Framework Class Library
C1Calendar..::..MonthsPanel Property
C1Calendar Class See Also
Gets or sets an ItemsPanelTemplate that defines the panel that lays out elements representing separate months. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ItemsPanelTemplate MonthsPanel { get; set; }
Visual Basic
Public Property MonthsPanel As ItemsPanelTemplate
    Get
    Set

Remarks

C1Calendar controls supports the next panels:

  • The C1UniformGrid panel. This is a default setting. A value of the MonthCount property is set automatically according to the available space.
  • The Grid panel. A value of the MonthCount property is set automatically according to the grid definition.
  • The StackPanel panel. The C1Calendar control honors explicitely defined MonthCount property value.
  • The VirtualizingStackPanel panel. The C1Calendar control honors explicitely defined MonthCount property value.

Examples

Copy CodeC#
<c1sched:C1Calendar MonthCount="4">
    <c1sched:C1Calendar.MonthsPanel>
        <ItemsPanelTemplate>
            <StackPanel Orientation="Horizontal"/>
        </ItemsPanelTemplate>
    </c1sched:C1Calendar.MonthsPanel>
</c1sched:C1Calendar>

See Also

C1Calendar Class


MonthWidth Property

[image]

.NET Framework Class Library
C1Calendar..::..MonthWidth Property
C1Calendar Class See Also
Gets or sets a value that determines a width of each month slot of the calendar. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public double MonthWidth { get; set; }
Visual Basic
Public Property MonthWidth As Double
    Get
    Set

See Also

C1Calendar Class


NavigationButtonBrush Property

[image]

.NET Framework Class Library
C1Calendar..::..NavigationButtonBrush Property
C1Calendar Class See Also
Gets or sets a Brush object used to color navigation buttons. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Brush NavigationButtonBrush { get; set; }
Visual Basic
Public Property NavigationButtonBrush As Brush
    Get
    Set

See Also

C1Calendar Class


SelectedDates Property

[image]

.NET Framework Class Library
C1Calendar..::..SelectedDates Property
C1Calendar Class See Also
Gets or sets the list of selected dates. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public DateList SelectedDates { get; set; }
Visual Basic
<BrowsableAttribute(False)> _
Public Property SelectedDates As DateList
    Get
    Set

See Also

C1Calendar Class


SelectedDayBrush Property

[image]

.NET Framework Class Library
C1Calendar..::..SelectedDayBrush Property
C1Calendar Class See Also
Gets or sets a Brush object used to highlight selected dates. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Brush SelectedDayBrush { get; set; }
Visual Basic
Public Property SelectedDayBrush As Brush
    Get
    Set

See Also

C1Calendar Class


TodayBrush Property

[image]

.NET Framework Class Library
C1Calendar..::..TodayBrush Property
C1Calendar Class See Also
Gets or sets a Brush object used to highlight current date. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Brush TodayBrush { get; set; }
Visual Basic
Public Property TodayBrush As Brush
    Get
    Set

See Also

C1Calendar Class


WeekendBrush Property

[image]

.NET Framework Class Library
C1Calendar..::..WeekendBrush Property
C1Calendar Class See Also
Gets or sets a Brush object used to display weekends. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Brush WeekendBrush { get; set; }
Visual Basic
Public Property WeekendBrush As Brush
    Get
    Set

See Also

C1Calendar Class


C1Calendar Events

[image] [image]

.NET Framework Class Library
C1Calendar Events
C1Calendar Class See Also

The C1Calendar type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SelectedDateChanged | Occurs when the SelectedDate property value has been changed. (Inherited from CalendarBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

C1Calendar Class


C1CalendarItem Class

[image]

.NET Framework Class Library
C1CalendarItem Class
Members See Also
Represents a single month calendar with an ability to interactively navigate through months and select a specific DateTime or its components.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[TemplatePartAttribute(Name = "PART_MonthsComboBox", Type = typeof(ComboBox))]
[TemplatePartAttribute(Name = "PART_YearsComboBox", Type = typeof(ComboBox))]
public class C1CalendarItem : CalendarBase,
    IDisposable
Visual Basic
<TemplatePartAttribute(Name := "PART_MonthsComboBox", Type := GetType(ComboBox))> _
<TemplatePartAttribute(Name := "PART_YearsComboBox", Type := GetType(ComboBox))> _
Public Class C1CalendarItem _
    Inherits CalendarBase _
    Implements IDisposable

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
C1.Silverlight.Schedule..::..CalendarBase
C1.Silverlight.Schedule..::..C1CalendarItem

See Also

C1CalendarItem Members


C1CalendarItem Members

[image] [image]

.NET Framework Class Library
C1CalendarItem Members
C1CalendarItem Class Constructors Methods Fields Properties Events See Also

The C1CalendarItem type exposes the following members.

Constructors

 | Name | Description
Public method | C1CalendarItem | Initializes a new instance of the C1CalendarItem control.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | Calendar_Loaded | (Inherited from CalendarBase.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Dispose()()()() | Clean up any resources being used.
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Protected method | InvalidateCalendarHelper | (Inherited from CalendarBase.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Protected method | InvalidateTheme | (Inherited from CalendarBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | (Overrides CalendarBase..::..OnApplyTemplate()()()().)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMaxDateChanged | (Inherited from CalendarBase.)
Protected method | OnMinDateChanged | (Inherited from CalendarBase.)
Protected method | OnMonthChanged | (Overrides CalendarBase..::..OnMonthChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | RefreshTheme | (Inherited from CalendarBase.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Protected method | SetSelectionToDate | (Inherited from CalendarBase.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

 | Name | Description
 | C1CalendarProperty | Identifies the C1Calendar dependency property.
 | GenerateAdjacentNextMonthDaysProperty | Identifies the GenerateAdjacentNextMonthDays dependency property.
 | GenerateAdjacentPreviousMonthDaysProperty | Identifies the GenerateAdjacentPreviousMonthDays dependency property.
Protected field | selectedDateGroupChangeInitiator | (Inherited from CalendarBase.)
 | ShowNextButtonProperty | Identifies the ShowNextButton dependency property.
 | ShowPreviousButtonProperty | Identifies the ShowPreviousButton dependency property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | C1Calendar | Gets a C1Calendar owning this C1CalendarItem control. This is a dependency property.
Public property | CalendarHelper | Gets or sets the CalendarHelper object that provides calendar-dependant properties. This is a dependency property. (Inherited from CalendarBase.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DayOfWeekSlotStyle | Gets or sets a Style for DayOfWeekSlotPresenter elements which are the root elements of a visual tree representing a single day of the week. (Inherited from CalendarBase.)
Public property | DayOfWeekSlotTemplate | Gets or sets a DataTemplate that defines a UI representation of a single day of the week. This is a dependency property. (Inherited from CalendarBase.)
Public property | DaySlotStyle | Gets or sets a Style for DaySlotPresenter elements which are the root elements of a visual tree representing a single day of a month. (Inherited from CalendarBase.)
Public property | DaySlotTemplate | Gets or sets a DataTemplate that defines a UI representation of a single day of a month. This is a dependency property. (Inherited from CalendarBase.)
Public property | DaysOfWeekPanel | Gets or sets an ItemsPanelTemplate that defines the panel that lays out elements representing days of the week. This is a dependency property. (Inherited from CalendarBase.)
Public property | DaysPanel | Gets or sets an ItemsPanelTemplate that defines the panel that lays out elements representing days of a month. This is a dependency property. (Inherited from CalendarBase.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | GenerateAdjacentNextMonthDays | Gets or sets a value that determines whether the day slots corresponding to days of a month next to the currently represented one will show the days or will be empty. The default value is False. This is a dependency property.
Public property | GenerateAdjacentPreviousMonthDays | Gets or sets a value that determines whether the day slots corresponding to days of a month previous to the currently represented one will show the days or will be empty. The default value is False. This is a dependency property.
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IsDisposed | (Inherited from CalendarBase.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxDate | Gets or sets the maximum allowable date. The default is 12/31/9998. This is a dependency property. (Inherited from CalendarBase.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinDate | Gets or sets the minimum allowable date. The default is 01/01/1753. This is a dependency property. (Inherited from CalendarBase.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Month | Gets or sets a month component of the SelectedDate property. This is a dependency property. (Inherited from CalendarBase.)
Public property | MonthFullName | Gets a full name of a month currently represented by calendar taking into account current culture.
Public property | Months | Gets the C1CalendarItem..::..DateTimeInfoCollection object pre-populated with DateTimeInfo objects representing several adjoining months. This object can be used in xaml for navigating the C1CalendarItem control to the one of the adjoining months.
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDate | Gets or sets the currently selected date. This is a dependency property. (Inherited from CalendarBase.)
Public property | ShowNextButton | Gets or sets a value that determines whether to show the next month navigation button. The default value is True. This is a dependency property.
Public property | ShowPreviousButton | Gets or sets a value that determines whether to show the previous month navigation button. The default value is True. This is a dependency property.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | SyncRepresentationToDateTime | Gets the boolean value, determining whether control synchronizes it's representation according to the changes of DateTime property. (Overrides CalendarBase..::..SyncRepresentationToDateTime.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Theme | Gets or sets a ResourceDictionary object containing calendar theme resources. (Inherited from CalendarBase.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Year | Gets or sets a year component of the SelectedDate property. This is a dependency property. (Inherited from CalendarBase.)
Public property | Years | Gets the C1CalendarItem..::..DateTimeInfoCollection object pre-populated with DateTimeInfo objects representing several adjoining years. This object can be used in xaml for navigating the C1CalendarItem control to the one of the adjoining years.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SelectedDateChanged | Occurs when the SelectedDate property value has been changed. (Inherited from CalendarBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

C1CalendarItem Class


C1CalendarItem Constructor

[image]

.NET Framework Class Library
C1CalendarItem Constructor
C1CalendarItem Class See Also
Initializes a new instance of the C1CalendarItem control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public C1CalendarItem()
Visual Basic
<BrowsableAttribute(False)> _
Public Sub New

Remarks

For internal use only.

See Also

C1CalendarItem Class


C1CalendarItem Fields

[image] [image]

.NET Framework Class Library
C1CalendarItem Fields
C1CalendarItem Class See Also

The C1CalendarItem type exposes the following members.

Fields

 | Name | Description
 | C1CalendarProperty | Identifies the C1Calendar dependency property.
 | GenerateAdjacentNextMonthDaysProperty | Identifies the GenerateAdjacentNextMonthDays dependency property.
 | GenerateAdjacentPreviousMonthDaysProperty | Identifies the GenerateAdjacentPreviousMonthDays dependency property.
Protected field | selectedDateGroupChangeInitiator | (Inherited from CalendarBase.)
 | ShowNextButtonProperty | Identifies the ShowNextButton dependency property.
 | ShowPreviousButtonProperty | Identifies the ShowPreviousButton dependency property.

See Also

C1CalendarItem Class


C1CalendarProperty Field

[image]

.NET Framework Class Library
C1CalendarItem..::..C1CalendarProperty Field
C1CalendarItem Class See Also
Identifies the C1Calendar dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty C1CalendarProperty
Visual Basic
Public Shared ReadOnly C1CalendarProperty As DependencyProperty

See Also

C1CalendarItem Class


GenerateAdjacentNextMonthDaysProperty Field

[image]

.NET Framework Class Library
C1CalendarItem..::..GenerateAdjacentNextMonthDaysProperty Field
C1CalendarItem Class See Also
Identifies the GenerateAdjacentNextMonthDays dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty GenerateAdjacentNextMonthDaysProperty
Visual Basic
Public Shared ReadOnly GenerateAdjacentNextMonthDaysProperty As DependencyProperty

See Also

C1CalendarItem Class


GenerateAdjacentPreviousMonthDaysProperty Field

[image]

.NET Framework Class Library
C1CalendarItem..::..GenerateAdjacentPreviousMonthDaysProperty Field
C1CalendarItem Class See Also
Identifies the GenerateAdjacentPreviousMonthDays dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty GenerateAdjacentPreviousMonthDaysProperty
Visual Basic
Public Shared ReadOnly GenerateAdjacentPreviousMonthDaysProperty As DependencyProperty

See Also

C1CalendarItem Class


ShowNextButtonProperty Field

[image]

.NET Framework Class Library
C1CalendarItem..::..ShowNextButtonProperty Field
C1CalendarItem Class See Also
Identifies the ShowNextButton dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty ShowNextButtonProperty
Visual Basic
Public Shared ReadOnly ShowNextButtonProperty As DependencyProperty

See Also

C1CalendarItem Class


ShowPreviousButtonProperty Field

[image]

.NET Framework Class Library
C1CalendarItem..::..ShowPreviousButtonProperty Field
C1CalendarItem Class See Also
Identifies the ShowPreviousButton dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty ShowPreviousButtonProperty
Visual Basic
Public Shared ReadOnly ShowPreviousButtonProperty As DependencyProperty

See Also

C1CalendarItem Class


C1CalendarItem Methods

[image] [image]

.NET Framework Class Library
C1CalendarItem Methods
C1CalendarItem Class See Also

The C1CalendarItem type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | Calendar_Loaded | (Inherited from CalendarBase.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Dispose()()()() | Clean up any resources being used.
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Protected method | InvalidateCalendarHelper | (Inherited from CalendarBase.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Protected method | InvalidateTheme | (Inherited from CalendarBase.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | (Overrides CalendarBase..::..OnApplyTemplate()()()().)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMaxDateChanged | (Inherited from CalendarBase.)
Protected method | OnMinDateChanged | (Inherited from CalendarBase.)
Protected method | OnMonthChanged | (Overrides CalendarBase..::..OnMonthChanged(DependencyPropertyChangedEventArgs).)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | RefreshTheme | (Inherited from CalendarBase.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Protected method | SetSelectionToDate | (Inherited from CalendarBase.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

C1CalendarItem Class


Dispose Method

[image] [image]

.NET Framework Class Library
C1CalendarItem..::..Dispose Method
C1CalendarItem Class See Also

Overload List

 | Name | Description
Public method | Dispose()()()() | Clean up any resources being used.
Protected method | Dispose(Boolean) | Clean up any resources being used.

See Also

C1CalendarItem Class
C1CalendarItem Members


Dispose Method

[image]

.NET Framework Class Library
C1CalendarItem..::..Dispose Method
C1CalendarItem Class See Also
Clean up any resources being used.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

See Also

C1CalendarItem Class
Dispose Overload


Dispose Method (Boolean)

[image]

.NET Framework Class Library
C1CalendarItem..::..Dispose Method (Boolean)
C1CalendarItem Class See Also
Clean up any resources being used.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

C1CalendarItem Class
Dispose Overload


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1CalendarItem..::..OnApplyTemplate Method
C1CalendarItem Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic
Public Overrides Sub OnApplyTemplate

See Also

C1CalendarItem Class


OnMonthChanged Method

[image]

.NET Framework Class Library
C1CalendarItem..::..OnMonthChanged Method
C1CalendarItem Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnMonthChanged(
    DependencyPropertyChangedEventArgs e
)
Visual Basic
Protected Overrides Sub OnMonthChanged ( _
    e As DependencyPropertyChangedEventArgs _
)

Parameters

e
Type: System.Windows..::..DependencyPropertyChangedEventArgs

See Also

C1CalendarItem Class


C1CalendarItem Properties

[image] [image]

.NET Framework Class Library
C1CalendarItem Properties
C1CalendarItem Class See Also

The C1CalendarItem type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | C1Calendar | Gets a C1Calendar owning this C1CalendarItem control. This is a dependency property.
Public property | CalendarHelper | Gets or sets the CalendarHelper object that provides calendar-dependant properties. This is a dependency property. (Inherited from CalendarBase.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DayOfWeekSlotStyle | Gets or sets a Style for DayOfWeekSlotPresenter elements which are the root elements of a visual tree representing a single day of the week. (Inherited from CalendarBase.)
Public property | DayOfWeekSlotTemplate | Gets or sets a DataTemplate that defines a UI representation of a single day of the week. This is a dependency property. (Inherited from CalendarBase.)
Public property | DaySlotStyle | Gets or sets a Style for DaySlotPresenter elements which are the root elements of a visual tree representing a single day of a month. (Inherited from CalendarBase.)
Public property | DaySlotTemplate | Gets or sets a DataTemplate that defines a UI representation of a single day of a month. This is a dependency property. (Inherited from CalendarBase.)
Public property | DaysOfWeekPanel | Gets or sets an ItemsPanelTemplate that defines the panel that lays out elements representing days of the week. This is a dependency property. (Inherited from CalendarBase.)
Public property | DaysPanel | Gets or sets an ItemsPanelTemplate that defines the panel that lays out elements representing days of a month. This is a dependency property. (Inherited from CalendarBase.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | GenerateAdjacentNextMonthDays | Gets or sets a value that determines whether the day slots corresponding to days of a month next to the currently represented one will show the days or will be empty. The default value is False. This is a dependency property.
Public property | GenerateAdjacentPreviousMonthDays | Gets or sets a value that determines whether the day slots corresponding to days of a month previous to the currently represented one will show the days or will be empty. The default value is False. This is a dependency property.
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IsDisposed | (Inherited from CalendarBase.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxDate | Gets or sets the maximum allowable date. The default is 12/31/9998. This is a dependency property. (Inherited from CalendarBase.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinDate | Gets or sets the minimum allowable date. The default is 01/01/1753. This is a dependency property. (Inherited from CalendarBase.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Month | Gets or sets a month component of the SelectedDate property. This is a dependency property. (Inherited from CalendarBase.)
Public property | MonthFullName | Gets a full name of a month currently represented by calendar taking into account current culture.
Public property | Months | Gets the C1CalendarItem..::..DateTimeInfoCollection object pre-populated with DateTimeInfo objects representing several adjoining months. This object can be used in xaml for navigating the C1CalendarItem control to the one of the adjoining months.
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDate | Gets or sets the currently selected date. This is a dependency property. (Inherited from CalendarBase.)
Public property | ShowNextButton | Gets or sets a value that determines whether to show the next month navigation button. The default value is True. This is a dependency property.
Public property | ShowPreviousButton | Gets or sets a value that determines whether to show the previous month navigation button. The default value is True. This is a dependency property.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | SyncRepresentationToDateTime | Gets the boolean value, determining whether control synchronizes it's representation according to the changes of DateTime property. (Overrides CalendarBase..::..SyncRepresentationToDateTime.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Theme | Gets or sets a ResourceDictionary object containing calendar theme resources. (Inherited from CalendarBase.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Year | Gets or sets a year component of the SelectedDate property. This is a dependency property. (Inherited from CalendarBase.)
Public property | Years | Gets the C1CalendarItem..::..DateTimeInfoCollection object pre-populated with DateTimeInfo objects representing several adjoining years. This object can be used in xaml for navigating the C1CalendarItem control to the one of the adjoining years.

See Also

C1CalendarItem Class


C1Calendar Property

[image]

.NET Framework Class Library
C1CalendarItem..::..C1Calendar Property
C1CalendarItem Class See Also
Gets a C1Calendar owning this C1CalendarItem control. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1Calendar C1Calendar { get; }
Visual Basic
Public ReadOnly Property C1Calendar As C1Calendar
    Get

See Also

C1CalendarItem Class


GenerateAdjacentNextMonthDays Property

[image]

.NET Framework Class Library
C1CalendarItem..::..GenerateAdjacentNextMonthDays Property
C1CalendarItem Class See Also
Gets or sets a value that determines whether the day slots corresponding to days of a month next to the currently represented one will show the days or will be empty. The default value is False. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool GenerateAdjacentNextMonthDays { get; set; }
Visual Basic
Public Property GenerateAdjacentNextMonthDays As Boolean
    Get
    Set

Remarks

If GenerateAdjacentNextMonthDays is set to true, the DaySlot objects generated in the DaySlots()()()() collection for next month days will not be empty (Empty is false and Date contains a date from the next month).

If GenerateAdjacentNextMonthDays is set to false, the DaySlot objects generated in the DaySlots()()()() collection for previous month days will be empty (Empty is false).

See Also

C1CalendarItem Class


GenerateAdjacentPreviousMonthDays Property

[image]

.NET Framework Class Library
C1CalendarItem..::..GenerateAdjacentPreviousMonthDays Property
C1CalendarItem Class See Also
Gets or sets a value that determines whether the day slots corresponding to days of a month previous to the currently represented one will show the days or will be empty. The default value is False. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool GenerateAdjacentPreviousMonthDays { get; set; }
Visual Basic
Public Property GenerateAdjacentPreviousMonthDays As Boolean
    Get
    Set

Remarks

If GenerateAdjacentPreviousMonthDays is set to true, the DaySlot objects generated in the DaySlots()()()() collection for previous month days will not be empty (Empty is false and Date contains a date from the previous month).

If GenerateAdjacentPreviousMonthDays is set to false, the DaySlot objects generated in the DaySlots()()()() collection for previous month days will be empty (Empty is false).

See Also

C1CalendarItem Class


MonthFullName Property

[image]

.NET Framework Class Library
C1CalendarItem..::..MonthFullName Property
C1CalendarItem Class See Also
Gets a full name of a month currently represented by calendar taking into account current culture.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string MonthFullName { get; }
Visual Basic
Public ReadOnly Property MonthFullName As String
    Get

See Also

C1CalendarItem Class


Months Property

[image]

.NET Framework Class Library
C1CalendarItem..::..Months Property
C1CalendarItem Class See Also
Gets the C1CalendarItem..::..DateTimeInfoCollection object pre-populated with DateTimeInfo objects representing several adjoining months. This object can be used in xaml for navigating the C1CalendarItem control to the one of the adjoining months.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public C1CalendarItem..::..DateTimeInfoCollection Months { get; }
Visual Basic
<BrowsableAttribute(False)> _
Public ReadOnly Property Months As C1CalendarItem..::..DateTimeInfoCollection
    Get

Remarks

This property is used by default C1CalendarItem style. For the sample of using look into source xaml: themes\CommonCalendarResources.xaml.

See Also

C1CalendarItem Class


ShowNextButton Property

[image]

.NET Framework Class Library
C1CalendarItem..::..ShowNextButton Property
C1CalendarItem Class See Also
Gets or sets a value that determines whether to show the next month navigation button. The default value is True. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(true)]
public bool ShowNextButton { get; set; }
Visual Basic
<DefaultValueAttribute(True)> _
Public Property ShowNextButton As Boolean
    Get
    Set

See Also

C1CalendarItem Class


ShowPreviousButton Property

[image]

.NET Framework Class Library
C1CalendarItem..::..ShowPreviousButton Property
C1CalendarItem Class See Also
Gets or sets a value that determines whether to show the previous month navigation button. The default value is True. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(true)]
public bool ShowPreviousButton { get; set; }
Visual Basic
<DefaultValueAttribute(True)> _
Public Property ShowPreviousButton As Boolean
    Get
    Set

See Also

C1CalendarItem Class


SyncRepresentationToDateTime Property

[image]

.NET Framework Class Library
C1CalendarItem..::..SyncRepresentationToDateTime Property
C1CalendarItem Class See Also
Gets the boolean value, determining whether control synchronizes it's representation according to the changes of DateTime property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override bool SyncRepresentationToDateTime { get; }
Visual Basic
Protected Overrides ReadOnly Property SyncRepresentationToDateTime As Boolean
    Get

Remarks

The return value is false.

See Also

C1CalendarItem Class


Years Property

[image]

.NET Framework Class Library
C1CalendarItem..::..Years Property
C1CalendarItem Class See Also
Gets the C1CalendarItem..::..DateTimeInfoCollection object pre-populated with DateTimeInfo objects representing several adjoining years. This object can be used in xaml for navigating the C1CalendarItem control to the one of the adjoining years.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public C1CalendarItem..::..DateTimeInfoCollection Years { get; }
Visual Basic
<BrowsableAttribute(False)> _
Public ReadOnly Property Years As C1CalendarItem..::..DateTimeInfoCollection
    Get

Remarks

This property is used by default C1CalendarItem style. For the sample of using look into source xaml: themes\CommonCalendarResources.xaml.

See Also

C1CalendarItem Class


C1CalendarItem Events

[image] [image]

.NET Framework Class Library
C1CalendarItem Events
C1CalendarItem Class See Also

The C1CalendarItem type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SelectedDateChanged | Occurs when the SelectedDate property value has been changed. (Inherited from CalendarBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

C1CalendarItem Class


C1CalendarItem.DateTimeInfoCollection Class

[image]

.NET Framework Class Library
C1CalendarItem..::..DateTimeInfoCollection Class
C1CalendarItem Class Members See Also
The C1CalendarItem..::..DateTimeInfoCollection class keeps the list of DateTimeInfo objects which can be used for the C1CalendarItem control navigation.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class DateTimeInfoCollection : INotifyPropertyChanged
Visual Basic
Public Class DateTimeInfoCollection _
    Implements INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..C1CalendarItem..::..DateTimeInfoCollection

See Also

C1CalendarItem..::..DateTimeInfoCollection Members


C1CalendarItem.DateTimeInfoCollection Members

[image] [image]

.NET Framework Class Library
C1CalendarItem..::..DateTimeInfoCollection Members
C1CalendarItem..::..DateTimeInfoCollection Class Methods Properties Events See Also

Represents a single month calendar with an ability to interactively navigate through months and select a specific DateTime or its components.

The C1CalendarItem..::..DateTimeInfoCollection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Collection | Gets a ReadOnlyObservableCollection<(Of <(<'T>)>)> collection.
Public property | SelectedValue | Gets or sets a DateTimeInfo object corresponding to the month and year which are currently displayed by the owning C1CalendarItem control.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes.

See Also

C1CalendarItem..::..DateTimeInfoCollection Class


C1CalendarItem.DateTimeInfoCollection Methods

[image] [image]

.NET Framework Class Library
C1CalendarItem..::..DateTimeInfoCollection Methods
C1CalendarItem..::..DateTimeInfoCollection Class See Also

The C1CalendarItem..::..DateTimeInfoCollection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1CalendarItem..::..DateTimeInfoCollection Class


C1CalendarItem.DateTimeInfoCollection Properties

[image] [image]

.NET Framework Class Library
C1CalendarItem..::..DateTimeInfoCollection Properties
C1CalendarItem..::..DateTimeInfoCollection Class See Also

The C1CalendarItem..::..DateTimeInfoCollection type exposes the following members.

Properties

 | Name | Description
Public property | Collection | Gets a ReadOnlyObservableCollection<(Of <(<'T>)>)> collection.
Public property | SelectedValue | Gets or sets a DateTimeInfo object corresponding to the month and year which are currently displayed by the owning C1CalendarItem control.

See Also

C1CalendarItem..::..DateTimeInfoCollection Class


Collection Property

[image]

.NET Framework Class Library
C1CalendarItem..::..DateTimeInfoCollection..::..Collection Property
C1CalendarItem..::..DateTimeInfoCollection Class See Also
Gets a ReadOnlyObservableCollection<(Of <(<'T>)>)> collection.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ReadOnlyObservableCollection Collection { get; }
Visual Basic
Public ReadOnly Property Collection As ReadOnlyObservableCollection
    Get

See Also

C1CalendarItem..::..DateTimeInfoCollection Class


SelectedValue Property

[image]

.NET Framework Class Library
C1CalendarItem..::..DateTimeInfoCollection..::..SelectedValue Property
C1CalendarItem..::..DateTimeInfoCollection Class See Also
Gets or sets a DateTimeInfo object corresponding to the month and year which are currently displayed by the owning C1CalendarItem control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTimeInfo SelectedValue { get; set; }
Visual Basic
Public Property SelectedValue As DateTimeInfo
    Get
    Set

See Also

C1CalendarItem..::..DateTimeInfoCollection Class


C1CalendarItem.DateTimeInfoCollection Events

[image] [image]

.NET Framework Class Library
C1CalendarItem..::..DateTimeInfoCollection Events
C1CalendarItem..::..DateTimeInfoCollection Class See Also

The C1CalendarItem..::..DateTimeInfoCollection type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes.

See Also

C1CalendarItem..::..DateTimeInfoCollection Class


PropertyChanged Event

[image]

.NET Framework Class Library
C1CalendarItem..::..DateTimeInfoCollection..::..PropertyChanged Event
C1CalendarItem..::..DateTimeInfoCollection Class See Also
Occurs when a property value changes.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

C1CalendarItem..::..DateTimeInfoCollection Class


C1CalendarItemPresenter Class

[image]

.NET Framework Class Library
C1CalendarItemPresenter Class
Members See Also
An instance of this class is used in the C1CalendarItem's template visual tree to define a place where a panel with calendar days will appear.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class C1CalendarItemPresenter : ListBox
Visual Basic
Public Class C1CalendarItemPresenter _
    Inherits ListBox

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ItemsControl
System.Windows.Controls.Primitives..::..Selector
System.Windows.Controls..::..ListBox
C1.Silverlight.Schedule..::..C1CalendarItemPresenter

See Also

C1CalendarItemPresenter Members


C1CalendarItemPresenter Members

[image] [image]

.NET Framework Class Library
C1CalendarItemPresenter Members
C1CalendarItemPresenter Class Constructors Methods Properties Events See Also

The C1CalendarItemPresenter type exposes the following members.

Constructors

 | Name | Description
Public method | C1CalendarItemPresenter | Initializes a new instance of the C1CalendarItemPresenter class.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Protected method | ClearContainerForItemOverride | (Inherited from Selector.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides ListBox..::..GetContainerForItemOverride()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ListBox.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | (Overrides ListBoxOnApplyTemplate()()()().)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBox.)
Protected method | OnGotFocus | (Inherited from ListBox.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnKeyDown | Responds to the KeyDown event. (Inherited from ListBox.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from ListBox.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ListBox.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Calendar | Gets a C1CalendarItem owning the control.
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemContainerStyle | (Inherited from ListBox.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. This is a dependency property. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty This is a dependency property. (Inherited from Selector.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

C1CalendarItemPresenter Class


C1CalendarItemPresenter Constructor

[image]

.NET Framework Class Library
C1CalendarItemPresenter Constructor
C1CalendarItemPresenter Class See Also
Initializes a new instance of the C1CalendarItemPresenter class.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1CalendarItemPresenter()
Visual Basic
Public Sub New

See Also

C1CalendarItemPresenter Class


C1CalendarItemPresenter Methods

[image] [image]

.NET Framework Class Library
C1CalendarItemPresenter Methods
C1CalendarItemPresenter Class See Also

The C1CalendarItemPresenter type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Protected method | ClearContainerForItemOverride | (Inherited from Selector.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides ListBox..::..GetContainerForItemOverride()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ListBox.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | (Overrides ListBoxOnApplyTemplate()()()().)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBox.)
Protected method | OnGotFocus | (Inherited from ListBox.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnKeyDown | Responds to the KeyDown event. (Inherited from ListBox.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from ListBox.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ListBox.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

C1CalendarItemPresenter Class


GetContainerForItemOverride Method

[image]

.NET Framework Class Library
C1CalendarItemPresenter..::..GetContainerForItemOverride Method
C1CalendarItemPresenter Class See Also
Creates or identifies the element used to display the specified item.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override DependencyObject GetContainerForItemOverride()
Visual Basic
Protected Overrides Function GetContainerForItemOverride As DependencyObject

Return Value

The new instance of DaySlotPresenter class.

See Also

C1CalendarItemPresenter Class


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1CalendarItemPresenter..::..OnApplyTemplate Method
C1CalendarItemPresenter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic
Public Overrides Sub OnApplyTemplate

See Also

C1CalendarItemPresenter Class


C1CalendarItemPresenter Properties

[image] [image]

.NET Framework Class Library
C1CalendarItemPresenter Properties
C1CalendarItemPresenter Class See Also

The C1CalendarItemPresenter type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Calendar | Gets a C1CalendarItem owning the control.
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemContainerStyle | (Inherited from ListBox.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. This is a dependency property. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty This is a dependency property. (Inherited from Selector.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

C1CalendarItemPresenter Class


Calendar Property

[image]

.NET Framework Class Library
C1CalendarItemPresenter..::..Calendar Property
C1CalendarItemPresenter Class See Also
Gets a C1CalendarItem owning the control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1CalendarItem Calendar { get; }
Visual Basic
Public ReadOnly Property Calendar As C1CalendarItem
    Get

See Also

C1CalendarItemPresenter Class


C1CalendarItemPresenter Events

[image] [image]

.NET Framework Class Library
C1CalendarItemPresenter Events
C1CalendarItemPresenter Class See Also

The C1CalendarItemPresenter type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

C1CalendarItemPresenter Class


C1CalendarPresenter Class

[image]

.NET Framework Class Library
C1CalendarPresenter Class
Members See Also
An instance of this class is used in the C1Calendar's template visual tree to define a place where a panel with month calendars will appear.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class C1CalendarPresenter : ListBox
Visual Basic
Public Class C1CalendarPresenter _
    Inherits ListBox

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ItemsControl
System.Windows.Controls.Primitives..::..Selector
System.Windows.Controls..::..ListBox
C1.Silverlight.Schedule..::..C1CalendarPresenter

See Also

C1CalendarPresenter Members


C1CalendarPresenter Members

[image] [image]

.NET Framework Class Library
C1CalendarPresenter Members
C1CalendarPresenter Class Constructors Methods Properties Events See Also

The C1CalendarPresenter type exposes the following members.

Constructors

 | Name | Description
Public method | C1CalendarPresenter | Initializes a new instance of the C1CalendarPresenter class.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Protected method | ClearContainerForItemOverride | (Overrides Selector..::..ClearContainerForItemOverride(DependencyObject, Object).)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides ListBox..::..GetContainerForItemOverride()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Overrides ListBox..::..IsItemItsOwnContainerOverride(Object).)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | Overrides the default behavior. (Overrides ListBoxOnApplyTemplate()()()().)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBox.)
Protected method | OnGotFocus | (Inherited from ListBox.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnKeyDown | Responds to the KeyDown event. (Inherited from ListBox.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from ListBox.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ListBox.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Calendar | Gets a C1Calendar owning the control.
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemContainerStyle | (Inherited from ListBox.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. This is a dependency property. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty This is a dependency property. (Inherited from Selector.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

C1CalendarPresenter Class


C1CalendarPresenter Constructor

[image]

.NET Framework Class Library
C1CalendarPresenter Constructor
C1CalendarPresenter Class See Also
Initializes a new instance of the C1CalendarPresenter class.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1CalendarPresenter()
Visual Basic
Public Sub New

See Also

C1CalendarPresenter Class


C1CalendarPresenter Methods

[image] [image]

.NET Framework Class Library
C1CalendarPresenter Methods
C1CalendarPresenter Class See Also

The C1CalendarPresenter type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Protected method | ClearContainerForItemOverride | (Overrides Selector..::..ClearContainerForItemOverride(DependencyObject, Object).)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides ListBox..::..GetContainerForItemOverride()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Overrides ListBox..::..IsItemItsOwnContainerOverride(Object).)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | Overrides the default behavior. (Overrides ListBoxOnApplyTemplate()()()().)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBox.)
Protected method | OnGotFocus | (Inherited from ListBox.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnKeyDown | Responds to the KeyDown event. (Inherited from ListBox.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from ListBox.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ListBox.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

C1CalendarPresenter Class


ClearContainerForItemOverride Method

[image]

.NET Framework Class Library
C1CalendarPresenter..::..ClearContainerForItemOverride Method
C1CalendarPresenter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void ClearContainerForItemOverride(
    DependencyObject element,
    Object item
)
Visual Basic
Protected Overrides Sub ClearContainerForItemOverride ( _
    element As DependencyObject, _
    item As Object _
)

Parameters

element
Type: System.Windows..::..DependencyObject
item
Type: System..::..Object

See Also

C1CalendarPresenter Class


GetContainerForItemOverride Method

[image]

.NET Framework Class Library
C1CalendarPresenter..::..GetContainerForItemOverride Method
C1CalendarPresenter Class See Also
Creates or identifies the element used to display the specified item.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override DependencyObject GetContainerForItemOverride()
Visual Basic
Protected Overrides Function GetContainerForItemOverride As DependencyObject

Return Value

The new instance of MonthSlotPresenter class.

See Also

C1CalendarPresenter Class


IsItemItsOwnContainerOverride Method

[image]

.NET Framework Class Library
C1CalendarPresenter..::..IsItemItsOwnContainerOverride Method
C1CalendarPresenter Class See Also
Determines if the specified item is (or is eligible to be) its own ItemContainer.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override bool IsItemItsOwnContainerOverride(
    Object item
)
Visual Basic
Protected Overrides Function IsItemItsOwnContainerOverride ( _
    item As Object _
) As Boolean

Parameters

item
Type: System..::..Object

Return Value

See Also

C1CalendarPresenter Class


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1CalendarPresenter..::..OnApplyTemplate Method
C1CalendarPresenter Class See Also
Overrides the default behavior.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic
Public Overrides Sub OnApplyTemplate

See Also

C1CalendarPresenter Class


C1CalendarPresenter Properties

[image] [image]

.NET Framework Class Library
C1CalendarPresenter Properties
C1CalendarPresenter Class See Also

The C1CalendarPresenter type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Calendar | Gets a C1Calendar owning the control.
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemContainerStyle | (Inherited from ListBox.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. This is a dependency property. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty This is a dependency property. (Inherited from Selector.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

C1CalendarPresenter Class


Calendar Property

[image]

.NET Framework Class Library
C1CalendarPresenter..::..Calendar Property
C1CalendarPresenter Class See Also
Gets a C1Calendar owning the control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1Calendar Calendar { get; }
Visual Basic
Public ReadOnly Property Calendar As C1Calendar
    Get

See Also

C1CalendarPresenter Class


C1CalendarPresenter Events

[image] [image]

.NET Framework Class Library
C1CalendarPresenter Events
C1CalendarPresenter Class See Also

The C1CalendarPresenter type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

C1CalendarPresenter Class


C1CalendarResources Class

[image]

.NET Framework Class Library
C1CalendarResources Class
Members See Also
The C1CalendarResources keeps the set of resources used by the CalendarBase derived controls. Static fields of this class return default CalendarBase's themes.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class C1CalendarResources : ThemeResources
Visual Basic
Public Class C1CalendarResources _
    Inherits ThemeResources

Remarks

Resource lookup behavior:
  • If Theme property is set to something other than Classic System Colors theme, the lookup process checks for the requested key within the resource dictionary defined by the current control theme
  • The lookup process checks resources in a usual way (in page, window or application resources)
  • The lookup process checks resources in default theme dictionary.

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..ThemeResources
C1.Silverlight.Schedule..::..C1CalendarResources

See Also

C1CalendarResources Members


C1CalendarResources Members

[image] [image]

.NET Framework Class Library
C1CalendarResources Members
C1CalendarResources Class Constructors Methods Properties See Also

The C1CalendarResources type exposes the following members.

Constructors

 | Name | Description
Public method | C1CalendarResources | Initializes the new instance of the C1CalendarResources class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshResources | Refreshes resources according to the currently selected theme. (Overrides ThemeResources..::..RefreshResources()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DayOfWeekSlotStyle | Gets the Style object describing day of week slot style.
Public property | DayOfWeekSlotTemplate | Gets the DataTemplate defining a UI representation of a single day of week.
Public property | DaySlotStyle | Gets the Style object describing the style of single day slot.
Public property | DaySlotTemplate | Gets the DataTemplate defining a UI representation of a single day of a month.
Public property | DaysOfWeekPanel | Gets the ItemsPanelTemplate defining the panel that lays out elements representing days of week.
Public property | DaysPanel | Gets the ItemsPanelTemplate object defining the panel that lays out elements representing days of a month.
Public property | MonthCalendarStyle | Gets the Style object describing style of a single month in a multi-month calendar.
Public property | MonthSlotStyle | Gets the Style object describing style of C1CalendarPresenter elements which are the root elements of a visual tree representing a single month in a multi-month calendar.
Public property | MonthsPanel | Gets the ItemsPanelTemplate defining the panel that lays out elements representing separate months in a multi-month calendar.
Public property | Theme | Gets or sets the ResourceDictionary object used as the theme for the control. (Overrides ThemeResources..::..Theme.)

See Also

C1CalendarResources Class


C1CalendarResources Constructor

[image]

.NET Framework Class Library
C1CalendarResources Constructor
C1CalendarResources Class See Also
Initializes the new instance of the C1CalendarResources class.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1CalendarResources()
Visual Basic
Public Sub New

See Also

C1CalendarResources Class


C1CalendarResources Methods

[image] [image]

.NET Framework Class Library
C1CalendarResources Methods
C1CalendarResources Class See Also

The C1CalendarResources type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshResources | Refreshes resources according to the currently selected theme. (Overrides ThemeResources..::..RefreshResources()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1CalendarResources Class


RefreshResources Method

[image]

.NET Framework Class Library
C1CalendarResources..::..RefreshResources Method
C1CalendarResources Class See Also
Refreshes resources according to the currently selected theme.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override void RefreshResources()
Visual Basic
Public Overrides Sub RefreshResources

See Also

C1CalendarResources Class


C1CalendarResources Properties

[image] [image]

.NET Framework Class Library
C1CalendarResources Properties
C1CalendarResources Class See Also

The C1CalendarResources type exposes the following members.

Properties

 | Name | Description
Public property | DayOfWeekSlotStyle | Gets the Style object describing day of week slot style.
Public property | DayOfWeekSlotTemplate | Gets the DataTemplate defining a UI representation of a single day of week.
Public property | DaySlotStyle | Gets the Style object describing the style of single day slot.
Public property | DaySlotTemplate | Gets the DataTemplate defining a UI representation of a single day of a month.
Public property | DaysOfWeekPanel | Gets the ItemsPanelTemplate defining the panel that lays out elements representing days of week.
Public property | DaysPanel | Gets the ItemsPanelTemplate object defining the panel that lays out elements representing days of a month.
Public property | MonthCalendarStyle | Gets the Style object describing style of a single month in a multi-month calendar.
Public property | MonthSlotStyle | Gets the Style object describing style of C1CalendarPresenter elements which are the root elements of a visual tree representing a single month in a multi-month calendar.
Public property | MonthsPanel | Gets the ItemsPanelTemplate defining the panel that lays out elements representing separate months in a multi-month calendar.
Public property | Theme | Gets or sets the ResourceDictionary object used as the theme for the control. (Overrides ThemeResources..::..Theme.)

See Also

C1CalendarResources Class


DayOfWeekSlotStyle Property

[image]

.NET Framework Class Library
C1CalendarResources..::..DayOfWeekSlotStyle Property
C1CalendarResources Class See Also
Gets the Style object describing day of week slot style.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Style DayOfWeekSlotStyle { get; }
Visual Basic
Public ReadOnly Property DayOfWeekSlotStyle As Style
    Get

See Also

C1CalendarResources Class


DayOfWeekSlotTemplate Property

[image]

.NET Framework Class Library
C1CalendarResources..::..DayOfWeekSlotTemplate Property
C1CalendarResources Class See Also
Gets the DataTemplate defining a UI representation of a single day of week.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DataTemplate DayOfWeekSlotTemplate { get; }
Visual Basic
Public ReadOnly Property DayOfWeekSlotTemplate As DataTemplate
    Get

See Also

C1CalendarResources Class


DaySlotStyle Property

[image]

.NET Framework Class Library
C1CalendarResources..::..DaySlotStyle Property
C1CalendarResources Class See Also
Gets the Style object describing the style of single day slot.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Style DaySlotStyle { get; }
Visual Basic
Public ReadOnly Property DaySlotStyle As Style
    Get

See Also

C1CalendarResources Class


DaySlotTemplate Property

[image]

.NET Framework Class Library
C1CalendarResources..::..DaySlotTemplate Property
C1CalendarResources Class See Also
Gets the DataTemplate defining a UI representation of a single day of a month.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DataTemplate DaySlotTemplate { get; }
Visual Basic
Public ReadOnly Property DaySlotTemplate As DataTemplate
    Get

See Also

C1CalendarResources Class


DaysOfWeekPanel Property

[image]

.NET Framework Class Library
C1CalendarResources..::..DaysOfWeekPanel Property
C1CalendarResources Class See Also
Gets the ItemsPanelTemplate defining the panel that lays out elements representing days of week.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ItemsPanelTemplate DaysOfWeekPanel { get; }
Visual Basic
Public ReadOnly Property DaysOfWeekPanel As ItemsPanelTemplate
    Get

See Also

C1CalendarResources Class


DaysPanel Property

[image]

.NET Framework Class Library
C1CalendarResources..::..DaysPanel Property
C1CalendarResources Class See Also
Gets the ItemsPanelTemplate object defining the panel that lays out elements representing days of a month.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ItemsPanelTemplate DaysPanel { get; }
Visual Basic
Public ReadOnly Property DaysPanel As ItemsPanelTemplate
    Get

See Also

C1CalendarResources Class


MonthCalendarStyle Property

[image]

.NET Framework Class Library
C1CalendarResources..::..MonthCalendarStyle Property
C1CalendarResources Class See Also
Gets the Style object describing style of a single month in a multi-month calendar.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Style MonthCalendarStyle { get; }
Visual Basic
Public ReadOnly Property MonthCalendarStyle As Style
    Get

See Also

C1CalendarResources Class


MonthSlotStyle Property

[image]

.NET Framework Class Library
C1CalendarResources..::..MonthSlotStyle Property
C1CalendarResources Class See Also
Gets the Style object describing style of C1CalendarPresenter elements which are the root elements of a visual tree representing a single month in a multi-month calendar.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Style MonthSlotStyle { get; }
Visual Basic
Public ReadOnly Property MonthSlotStyle As Style
    Get

See Also

C1CalendarResources Class


MonthsPanel Property

[image]

.NET Framework Class Library
C1CalendarResources..::..MonthsPanel Property
C1CalendarResources Class See Also
Gets the ItemsPanelTemplate defining the panel that lays out elements representing separate months in a multi-month calendar.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ItemsPanelTemplate MonthsPanel { get; }
Visual Basic
Public ReadOnly Property MonthsPanel As ItemsPanelTemplate
    Get

See Also

C1CalendarResources Class


Theme Property

[image]

.NET Framework Class Library
C1CalendarResources..::..Theme Property
C1CalendarResources Class See Also
Gets or sets the ResourceDictionary object used as the theme for the control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override ResourceDictionary Theme { get; set; }
Visual Basic
Public Overrides Property Theme As ResourceDictionary
    Get
    Set

See Also

C1CalendarResources Class


C1ItemsPresenter Class

[image]

.NET Framework Class Library
C1ItemsPresenter Class
Members See Also
Used within the template of a GroupedListBox and GroupItem to specify the place in the control’s visual tree where the ItemsPanel defined by the GroupedListBox is to be added.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class C1ItemsPresenter : Control,
    IItemsChangedListener
Visual Basic
Public Class C1ItemsPresenter _
    Inherits Control _
    Implements IItemsChangedListener

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
C1.Silverlight.Schedule..::..C1ItemsPresenter

See Also

C1ItemsPresenter Members


C1ItemsPresenter Members

[image] [image]

.NET Framework Class Library
C1ItemsPresenter Members
C1ItemsPresenter Class Constructors Methods Properties Events See Also

The C1ItemsPresenter type exposes the following members.

Constructors

 | Name | Description
Public method | C1ItemsPresenter | Initializes a new instance of the C1ItemsPresenter class.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | (Overrides FrameworkElement..::..ArrangeOverride(Size).)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | (Overrides FrameworkElement..::..MeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | Called when an internal process or application calls ApplyTemplate, which is used to build the current template's visual tree. (Overrides FrameworkElement..::..OnApplyTemplate()()()().)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

C1ItemsPresenter Class


C1ItemsPresenter Constructor

[image]

.NET Framework Class Library
C1ItemsPresenter Constructor
C1ItemsPresenter Class See Also
Initializes a new instance of the C1ItemsPresenter class.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1ItemsPresenter()
Visual Basic
Public Sub New

See Also

C1ItemsPresenter Class


C1ItemsPresenter Methods

[image] [image]

.NET Framework Class Library
C1ItemsPresenter Methods
C1ItemsPresenter Class See Also

The C1ItemsPresenter type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | (Overrides FrameworkElement..::..ArrangeOverride(Size).)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | (Overrides FrameworkElement..::..MeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | Called when an internal process or application calls ApplyTemplate, which is used to build the current template's visual tree. (Overrides FrameworkElement..::..OnApplyTemplate()()()().)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

C1ItemsPresenter Class


ArrangeOverride Method

[image]

.NET Framework Class Library
C1ItemsPresenter..::..ArrangeOverride Method
C1ItemsPresenter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override Size ArrangeOverride(
    Size arrangeSize
)
Visual Basic
Protected Overrides Function ArrangeOverride ( _
    arrangeSize As Size _
) As Size

Parameters

arrangeSize
Type: System.Windows..::..Size

See Also

C1ItemsPresenter Class


MeasureOverride Method

[image]

.NET Framework Class Library
C1ItemsPresenter..::..MeasureOverride Method
C1ItemsPresenter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override Size MeasureOverride(
    Size constraint
)
Visual Basic
Protected Overrides Function MeasureOverride ( _
    constraint As Size _
) As Size

Parameters

constraint
Type: System.Windows..::..Size

See Also

C1ItemsPresenter Class


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1ItemsPresenter..::..OnApplyTemplate Method
C1ItemsPresenter Class See Also
Called when an internal process or application calls ApplyTemplate, which is used to build the current template's visual tree.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic
Public Overrides Sub OnApplyTemplate

See Also

C1ItemsPresenter Class


C1ItemsPresenter Properties

[image] [image]

.NET Framework Class Library
C1ItemsPresenter Properties
C1ItemsPresenter Class See Also

The C1ItemsPresenter type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

C1ItemsPresenter Class


C1ItemsPresenter Events

[image] [image]

.NET Framework Class Library
C1ItemsPresenter Events
C1ItemsPresenter Class See Also

The C1ItemsPresenter type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

C1ItemsPresenter Class


C1ListBoxItem Class

[image]

.NET Framework Class Library
C1ListBoxItem Class
Members See Also
Represents a selectable item in a GroupedListBox.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class C1ListBoxItem : ListBoxItem
Visual Basic
Public Class C1ListBoxItem _
    Inherits ListBoxItem

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ContentControl
System.Windows.Controls..::..ListBoxItem
C1.Silverlight.Schedule..::..C1ListBoxItem
C1.Silverlight.Schedule..::..VisualIntervalPresenter

See Also

C1ListBoxItem Members


C1ListBoxItem Members

[image] [image]

.NET Framework Class Library
C1ListBoxItem Members
C1ListBoxItem Class Constructors Methods Properties Events See Also

The C1ListBoxItem type exposes the following members.

Constructors

 | Name | Description
Public method | C1ListBoxItem | Initializes a new instance of the C1ListBoxItem class.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | (Inherited from ListBoxItem.)
Protected method | OnContentChanged | (Overrides ContentControl..::..OnContentChanged(Object, Object).)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxItemAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBoxItem.)
Protected method | OnGotFocus | (Inherited from ListBoxItem.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from ListBoxItem.)
Protected method | OnMouseEnter | Called when the mouse enters a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeave | Called when the mouse leaves a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeftButtonDown | (Overrides ListBoxItem..::..OnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets a value that indicates whether a ListBoxItem is selected. This is a dependency property. (Inherited from ListBoxItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Owner | Gets the reference to the owning GroupedListBox control.
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

C1ListBoxItem Class


C1ListBoxItem Constructor

[image]

.NET Framework Class Library
C1ListBoxItem Constructor
C1ListBoxItem Class See Also
Initializes a new instance of the C1ListBoxItem class.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1ListBoxItem()
Visual Basic
Public Sub New

See Also

C1ListBoxItem Class


C1ListBoxItem Methods

[image] [image]

.NET Framework Class Library
C1ListBoxItem Methods
C1ListBoxItem Class See Also

The C1ListBoxItem type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | (Inherited from ListBoxItem.)
Protected method | OnContentChanged | (Overrides ContentControl..::..OnContentChanged(Object, Object).)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxItemAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBoxItem.)
Protected method | OnGotFocus | (Inherited from ListBoxItem.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from ListBoxItem.)
Protected method | OnMouseEnter | Called when the mouse enters a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeave | Called when the mouse leaves a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeftButtonDown | (Overrides ListBoxItem..::..OnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

C1ListBoxItem Class


OnContentChanged Method

[image]

.NET Framework Class Library
C1ListBoxItem..::..OnContentChanged Method
C1ListBoxItem Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnContentChanged(
    Object oldContent,
    Object newContent
)
Visual Basic
Protected Overrides Sub OnContentChanged ( _
    oldContent As Object, _
    newContent As Object _
)

Parameters

oldContent
Type: System..::..Object
newContent
Type: System..::..Object

See Also

C1ListBoxItem Class


OnMouseLeftButtonDown Method

[image]

.NET Framework Class Library
C1ListBoxItem..::..OnMouseLeftButtonDown Method
C1ListBoxItem Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnMouseLeftButtonDown(
    MouseButtonEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseLeftButtonDown ( _
    e As MouseButtonEventArgs _
)

Parameters

e
Type: System.Windows.Input..::..MouseButtonEventArgs

See Also

C1ListBoxItem Class


C1ListBoxItem Properties

[image] [image]

.NET Framework Class Library
C1ListBoxItem Properties
C1ListBoxItem Class See Also

The C1ListBoxItem type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets a value that indicates whether a ListBoxItem is selected. This is a dependency property. (Inherited from ListBoxItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Owner | Gets the reference to the owning GroupedListBox control.
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

C1ListBoxItem Class


Owner Property

[image]

.NET Framework Class Library
C1ListBoxItem..::..Owner Property
C1ListBoxItem Class See Also
Gets the reference to the owning GroupedListBox control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public GroupedListBox Owner { get; internal set; }
Visual Basic
Public Property Owner As GroupedListBox
    Get
    Friend Set

Remarks

This property can be used for binding inside of the C1ListBoxItem control templates.

See Also

C1ListBoxItem Class


C1ListBoxItem Events

[image] [image]

.NET Framework Class Library
C1ListBoxItem Events
C1ListBoxItem Class See Also

The C1ListBoxItem type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

C1ListBoxItem Class


C1Scheduler Class

[image]

.NET Framework Class Library
C1Scheduler Class
Members See Also
Represents a schedule with an ability to interactively manage appointments.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[TemplatePartAttribute(Name = "PART_GroupNavigationScrollBar", Type = typeof(ScrollBar))]
[TemplatePartAttribute(Name = "PART_C1SchedulerScrollBar", Type = typeof(ScrollBar))]
[ContentPropertyAttribute("NestedSetters")]
public class C1Scheduler : Control,
    ICoverPaneHost, ICalendarHelperOwner, IDisposable
Visual Basic
<TemplatePartAttribute(Name := "PART_GroupNavigationScrollBar", Type := GetType(ScrollBar))> _
<TemplatePartAttribute(Name := "PART_C1SchedulerScrollBar", Type := GetType(ScrollBar))> _
<ContentPropertyAttribute("NestedSetters")> _
Public Class C1Scheduler _
    Inherits Control _
    Implements ICoverPaneHost, ICalendarHelperOwner, IDisposable

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
C1.Silverlight.Schedule..::..C1Scheduler

See Also

C1Scheduler Members


C1Scheduler Members

[image] [image]

.NET Framework Class Library
C1Scheduler Members
C1Scheduler Class Constructors Methods Fields Properties Events See Also

The C1Scheduler type exposes the following members.

Constructors

 | Name | Description
Public method | C1Scheduler | Initializes the new instance of the C1Scheduler control.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | BeginUpdate | Disables any redrawing of the control.
Public method | BringTimeIntoView | Attempts to bring into the view a UI element representing a VisualInterval that includes the specified time in the current scheduler view. Optionally tries to make the element to be a top left element of the view.
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | ChangeStyle | Changes the Style property with the specified Style or a style referenced by the specified ResourceDictionary key.
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Compare(Appointment, Appointment) | Performs a comparison of two Appointment objects based on their start time and subject.
Public method | Compare(Status, Status) | Performs a comparison of two Status objects based on their StatusType property value.
Public method | DecrementStartTimeLarge | Decrements the VisualStartTime property value on the amount specified in the LargeStartTimeChange property.
Public method | DecrementStartTimeSmall | Decrements the VisualStartTime property value on the amount specified in the SmallStartTimeChange property.
Public method | DeleteAppointment()()()() | Deletes the appointment that is currently selected in control UI and also shows an appointment deletion options dialog in the case where the appointment is an occurrence of a recurrence pattern.
Public method | DeleteAppointment(Appointment) | Deletes the specified appointment.
Public method | Dispose()()()() | Clean up any resources being used.
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | EditAppointmentDialog | Shows the Edit Appointment dialog for editing of the specified existing Appointment.
Public method | EditRecurrenceDialog | Shows the Edit Recurrence dialog for editing a RecurrencePattern of the specified Appointment.
Public method | EndUpdate | Enables the redrawing of the control.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindUIForTime | Returns the FrameworkElement corresponding to the given DateTime value.
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
 | GetDateTimeAtPoint | Returns the Nullable<(Of <(<'T>)>)> at the specified location.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | IncrementStartTimeLarge | Increments the VisualStartTime property value on the amount specified in the LargeStartTimeChange property.
Public method | IncrementStartTimeSmall | Increments the VisualStartTime property value on the amount specified in the SmallStartTimeChange property.
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NavigateToAppointment(Boolean, Nullable<(Of <<'(DateTime>)>>)) | Navigates the C1Scheduler control to the nearest Appointment.
Public method | NavigateToAppointment(BaseObject, Boolean, Nullable<(Of <<'(DateTime>)>>)) | Navigates the C1Scheduler control to the nearest Appointment in the GroupItems with the specified owner object.
Public method | NavigateToNextAppointment()()()() | Makes the nearest appointment after SelectedDateTime visible in the control UI.
Public method | NavigateToNextAppointment(BaseObject) | Makes the nearest appointment after SelectedDateTime visible in the control UI.
Public method | NavigateToPreviousAppointment()()()() | Makes the nearest appointment before SelectedDateTime visible in the control UI.
Public method | NavigateToPreviousAppointment(BaseObject) | Makes the nearest appointment before SelectedDateTime visible in the control UI.
Public method | NewAppointmentDialog()()()() | Shows the Edit Appointment dialog for the creation of a new Appointment object. Edit Appointment dialog is initialized according to the SelectedDateTimeInterval property value if it is not null; or according to the current date and time and the VisualIntervalScale property value otherwise.
Public method | NewAppointmentDialog(VisualInterval) | Shows the Edit Appointment dialog for the creation of a new Appointment.
Public method | NewAppointmentDialog(DateTime, DateTime) | Shows the Edit Appointment dialog for the creation of a new Appointment object with the specified start and end values.
Public method | NewAppointmentDialog(DateTime, DateTime, BaseObject) | Shows the Edit Appointment dialog for the creation of a new Appointment object with the specified start and end values.
Public method | NewAppointmentDialog(DateTime, DateTime, Nullable<(Of <<'(Boolean>)>>)) | Shows the Edit Appointment dialog for the creation of a new Appointment object with the specified parameters.
Public method | NewAppointmentDialog(DateTime, DateTime, Nullable<(Of <<'(Boolean>)>>), BaseObject) | Shows the Edit Appointment dialog for the creation of a new Appointment object with the specified parameters.
Public method | OnApplyTemplate | (Overrides FrameworkElement..::..OnApplyTemplate()()()().)
Protected method | OnAppointmentAdded | Raises a AppointmentAdded event.
Protected method | OnAppointmentChanged | Raises a AppointmentChanged event.
Protected method | OnAppointmentCustomAction | Raises a AppointmentCustomAction event.
Protected method | OnAppointmentDeleted | Raises a AppointmentDeleted event.
Protected method | OnAppointmentRecurrenceStateChanged | Raises a AppointmentRecurrenceStateChanged event.
Protected method | OnBeforeAppointmentDrop | Raises a BeforeAppointmentDrop event.
Protected method | OnBeforeAppointmentResize | Raises a BeforeAppointmentResize event.
Protected method | OnBeforeAppointmentSave | Raises a BeforeAppointmentResize event.
Protected method | OnBeforeViewChange | Raises a BeforeViewChange event.
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDataSourceItemSynchronized | Raises a DataSourceItemSynchronized event;
Protected method | OnDrop |
Protected method | OnEndChanged | Raises an EndChanged event.
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Overrides ControlOnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel |
Protected method | OnReminderAdded | Raises a ReminderAdded event.
Protected method | OnReminderChanged | Raises a ReminderChanged event.
Protected method | OnReminderFire | Raises a ReminderFire event.
Protected method | OnReminderRemoved | Raises a ReminderRemoved event.
Protected method | OnReminderSnooze | Raises a ReminderSnooze event.
Protected method | OnSelectedAppointmentChanged | Raises a SelectedAppointmentChanged event.
Protected method | OnSelectedDateTimeChanged | Raises a SelectedDateTimeChanged event.
Protected method | OnStartChanged | Raises a StartChanged event.
Protected method | OnStyleChanged | Raises a StyleChanged event.
Protected method | OnUserAddingAppointment | Raises a UserAddingAppointment event.
Protected method | OnUserClosingAppointment | Raises a UserEditingAppointment event.
Protected method | OnUserDeletingAppointment | Raises a UserDeletingAppointment event.
Protected method | OnUserEditingAppointment | Raises a UserEditingAppointment event.
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SelectFromListDialog(IList, IList, Type, Appointment, String) | Shows the Select From List dialog. Honors property values defined in the Settings object.
Public method | SelectFromListDialog(IList, IList, Type, Appointment, String, Boolean, Boolean) | Shows the Select From List dialog.
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetRelativeStartTime | Sets the VisualStartTime property to a value between the Start and End property values based on the specified coefficient.
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Protected method | ShouldSerializeEmptyGroupName |
Protected method | ShouldSerializeEnd |
Protected method | ShouldSerializeNextAppointmentText |
Protected method | ShouldSerializePreviousAppointmentText |
Protected method | ShouldSerializeStart |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
ActiveRemindersProperty | Identifies the ActiveReminders dependency property.
AlternatingBackgroundProperty | Identifies the AlternatingBackground dependency property.
AppointmentForegroundProperty | Identifies the AppointmentForeground dependency property.
BoldedDatesProperty | Identifies the BoldedDates dependency property.
CalendarHelperProperty | Identifies the CalendarHelper dependency property.
CanNavigateNextGroupProperty | Identifies the CanNavigateNextGroup property.
CanNavigatePreviousGroupProperty | Identifies the CanNavigatePreviousGroup property.
ChangeStyleCommand | Defines the command that changes the Style property with the specified Style or a style referenced by the specified ResourceDictionary key.
ControlBackgroundProperty | Identifies the ControlBackground dependency property.
ControlForegroundProperty | Identifies the ControlForeground dependency property.
DayViewDayHeaderFormatProperty | Identifies the DayViewDayHeaderFormat dependency property.
DecrementStartTimeLargeCommand | Defines the command that decrements the VisualStartTime property value on the amount specified in the LargeStartTimeChange property.
DecrementStartTimeSmallCommand | Defines the command that decrements the VisualStartTime property value on the amount specified in the SmallStartTimeChange property.
DeleteAppointmentCommand | Defines the command that deletes the Appointment(s).
DismissCommand | Defines the command that dismisses reminders.
EditAppointmentDialogCommand | Defines the command that shows the Edit Appointment dialog for editing of the specified existing Appointment(s).
EditAppointmentTemplateProperty | Identifies the EditAppointmentTemplate dependency property.
EditRecurrenceDialogCommand | Defines the command that shows the Edit Recurrence dialog for editing a RecurrencePattern of the specified Appointment.
EditRecurrenceTemplateProperty | Identifies the EditRecurrenceTemplate dependency property.
EmptyGroupNameProperty | Identifies the EmptyGroupName property.
EndProperty | Identifies the End dependency property.
ExportCommand | Defines the command that exports Scheduler data to the file.
GroupHeaderTemplateProperty | Identifies the GroupHeaderTemplate dependency property.
GroupPageSizeProperty | Identifies the GroupPageSize dependency property.
HasVisibleAppointmentsProperty | Identifies the HasVisibleAppointments dependency property.
HideGroupCommand | Defines the command that hides the specified SchedulerGroupItem object.
ImportCommand | Defines the command that imports Scheduler data from the file.
IncrementStartTimeLargeCommand | Defines the command that increments the VisualStartTime property value on the amount specified in the LargeStartTimeChange property.
IncrementStartTimeSmallCommand | Defines the command that increments the VisualStartTime property value on the amount specified in the SmallStartTimeChange property.
IntervalAppointmentTemplateProperty | Identifies the IntervalAppointmentTemplate dependency property.
IsDragDropDisabledProperty | Identifies the IsDragDropDisabled dependency property.
IsGroupedProperty | Identifies the IsGrouped property.
IsInPlaceEditingDisabledProperty | Identifies the IsInPlaceEditingDisabled dependency property.
IsTotalGroupItemEnabledProperty | Identifies the IsTotalGroupItemEnabled property.
LargeStartTimeChangeProperty | Identifies the LargeStartTimeChange dependency property.
MonthStyleProperty | Identifies the MonthStyle dependency property.
MonthViewDayHeaderDayFormatProperty | Identifies the MonthViewDayHeaderDayFormat dependency property.
MonthViewDayHeaderMonthFormatProperty | Identifies the MonthViewDayHeaderMonthFormat dependency property.
MonthViewHeaderFormatProperty | Identifies the MonthViewHeaderFormat dependency property.
NavigateToNextAppointmentCommand | Defines the command that makes the nearest appointment after SelectedDateTime visible in the control UI.
NavigateToNextGroupCommand | Defines the command that navigates C1Scheduler UI to the next SchedulerGroupItem object.
NavigateToPreviousAppointmentCommand | Defines the command that makes the nearest appointment before SelectedDateTime visible in the control UI.
NavigateToPreviousGroupCommand | Defines the command that navigates C1Scheduler UI to the previous SchedulerGroupItem object.
NewAppointmentDialogCommand | Defines the command that shows the Edit Appointment dialog for a creation of a new Appointment.
NextAppointmentTextProperty | Identifies the NextAppointmentText property.
OneDayStyleProperty | Identifies the OneDayStyle dependency property.
PreviousAppointmentTextProperty | Identifies the PreviousAppointmentText property.
SelectedAppointmentProperty | Identifies the SelectedAppointment dependency property.
SelectedBackgroundProperty | Identifies the SelectedBackground dependency property.
SelectedDateTimeIntervalProperty | Identifies the SelectedDateTimeInterval dependency property.
SelectedDateTimeProperty | Identifies the SelectedDateTime dependency property.
SelectedGroupItemProperty | Identifies the SelectedGroupItem dependency property.
SelectedIntervalAppointmentProperty | Identifies the SelectedIntervalAppointment dependency property.
SelectedVisualIntervalProperty | Identifies the SelectedVisualInterval dependency property.
SelectFromListDialogCommand | Defines the command that shows the Select From List dialog for specified parameters.
SelectFromListTemplateProperty | Identifies the SelectFromListTemplate dependency property.
SetRelativeStartTimeCommand | Defines the command that sets the VisualStartTime property to a value between the Start and End property values based on the specified coefficient.
SettingsProperty | Identifies the C1SchedulerSettings dependency property.
ShowRemindersTemplateProperty | Identifies the ShowRemindersTemplate dependency property.
ShowWorkTimeOnlyProperty | Identifies the ShowWorkTimeOnly dependency property.
SmallStartTimeChangeProperty | Identifies the SmallStartTimeChange dependency property.
SnoozeCommand | Defines the command that snoozes reminders.
StartProperty | Identifies the Start dependency property.
ThemeProperty | Identifies the Theme dependency property.
TimeFormatProperty | Identifies the TimeFormat dependency property.
TimeLineStyleProperty | Identifies the TimeLineStyle dependency property.
TodayBackgroundProperty | Identifies the TodayBackground dependency property.
ViewStyleSelectorProperty | Identifies the C1StyleSelector dependency property.
VisibleDatesProperty | Identifies the VisibleDates dependency property.
VisualEndTimeProperty | Identifies the VisualEndTimeProperty dependency property.
VisualIntervalGroupDescriptionsProperty | Identifies the VisualIntervalGroupDescriptions dependency property.
VisualIntervalGroupStylesProperty | Identifies the VisualIntervalGroupStyles dependency property.
VisualIntervalPanelProperty | Identifies the VisualIntervalPanel dependency property.
VisualIntervalScaleProperty | Identifies the VisualIntervalScale dependency property.
VisualIntervalTemplateProperty | Identifies the VisualIntervalTemplate dependency property.
VisualStartTimeProperty | Identifies the VisualStartTime dependency property.
VisualTimeSpanProperty | Identifies the VisualTimeSpan dependency property.
WeekStyleProperty | Identifies the WeekStyle dependency property.
WeekViewDayHeaderFormatProperty | Identifies the WeekViewDayHeaderFormat dependency property.
WorkingWeekStyleProperty | Identifies the WorkingWeekStyle dependency property.

Properties

Name | Description
Public property ActiveReminders
Gets a ReadOnlyObservableCollection<(Of <(<'T>)>)> of active Reminder objects. This is a dependency property.
Public property ActualHeight
Gets the rendered height of this element. This is a dependency property.
(Inherited from FrameworkElement.)
Public property ActualWidth
Gets the rendered width of this element. This is a dependency property.
(Inherited from FrameworkElement.)
Public property AlternatingBackground
Gets or sets a Brush object used as background for working hours and days of alternating months. This is a dependency property.
Public property AppointmentComparison
Gets or sets the Comparison<(Of <(<'T>)>)> delegate which is used by the C1Scheduler control to sort appointments.
Public property AppointmentForeground
Gets or sets a Brush object used as a foreground for appointment elements. This is a dependency property.
Public property Background
Gets or sets a brush that describes the background of a control. This is a dependency property.
(Inherited from Control.)
Public property BoldedDates
Gets the collection of dates which contain appointments. This is a dependency property.
Public property BorderBrush
Gets or sets a brush that describes the border background of a control. This is a dependency property.
(Inherited from Control.)
Public property BorderThickness
Gets or sets the border thickness of a control. This is a dependency property.
(Inherited from Control.)
Public property CalendarHelper
Gets or sets the CalendarHelper object which provides calendar-dependant properties. This is a dependency property.
Public property CanNavigateNextGroup
Gets a Boolean value determining whether the C1Scheduler control can be navigated to the next SchedulerGroupItem object. This is a dependency property.
Public property CanNavigatePreviousGroup
Gets a Boolean value determining whether the C1Scheduler control can be navigated to the next SchedulerGroupItem object. This is a dependency property.
Public property Clip
Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property.
(Inherited from UIElement.)
Public property ControlBackground
Gets or sets a Brush object that is the face color of a control (Time Ruler, Month View header, etc.). This is a dependency property.
Public property ControlForeground
Gets or sets a Brush object that is the text color in a control (Time Ruler, Month View header, etc.). This is a dependency property.
Public property Cursor
Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property.
(Inherited from FrameworkElement.)
Public property DataContext
Gets or sets the data context for an element when it participates in data binding. This is a dependency property.
(Inherited from FrameworkElement.)
Public property DataStorage
Gets a C1ScheduleStorage that stores a data that is represented by the control.
Public property DayViewDayHeaderFormat
Gets or sets the String value determining format used to display day header in a Day view. The default value is 'dddd MMM d'. This is a dependency property.
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property DesiredSize
Gets the size that this element computed during the measure pass of the layout process.
(Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property EditAppointmentTemplate
Gets or sets a DataTemplate that defines a UI for the Edit Appointment dialog. This is a dependency property.
Public property EditRecurrenceTemplate
Gets or sets a DataTemplate that defines a UI for the Edit Recurrence dialog. This is a dependency property.
Public property EmptyGroupName
Gets or sets a String value used as default value for the Name property.
Public property End
Gets or sets a DateTime that defines an end of an overall period of time that can be represented by the control. This is a dependency property.
Public property FontFamily
Gets or sets the font family of the control. This is a dependency property.
(Inherited from Control.)
Public property FontSize
Gets or sets the font size. This is a dependency property.
(Inherited from Control.)
Public property FontStretch
Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property.
(Inherited from Control.)
Public property FontStyle
Gets or sets the font style. This is a dependency property.
(Inherited from Control.)
Public property FontWeight
Gets or sets the weight or thickness of the specified font. This is a dependency property.
(Inherited from Control.)
Public property Foreground
Gets or sets a brush that describes the foreground color. This is a dependency property.
(Inherited from Control.)
Public property GroupBy
Gets or sets the String value determining the type of grouping.
Public property GroupHeaderTemplate
Gets or sets a DataTemplate that defines a UI representation of the SchedulerGroupItem object header. This is a dependency property.
Public property GroupItems
Gets a collection of all available SchedulerGroupItem objects for the currently set type of grouping.
Public property GroupPageSize
Gets or sets the Int32 value determining the maximum number of the SchedulerGroupItem objects displayed in UI at the same time. Increasing this value might affect performance. This is a dependency property.
Public property HasVisibleAppointments
Indicates whether there is at least one visible appointment in the current view. This is a dependency property.
Public property Height
Gets or sets the suggested height of the element. This is a dependency property.
(Inherited from FrameworkElement.)
Public property HorizontalAlignment
Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property.
(Inherited from FrameworkElement.)
Public property HorizontalContentAlignment
Gets or sets the horizontal alignment of the control's content. This is a dependency property.
(Inherited from Control.)
Public property IntervalAppointmentTemplate
Gets or sets a DataTemplate that defines a UI representation of an IntervalAppointment object. This is a dependency property.
Public property IsDragDropDisabled
Gets or sets a Boolean value that indicates whether the C1Scheduler doesn't allow appointment resizing and drag operations. This is a dependency property.
Public property | IsEnabled | (Inherited from Control.)
Public property IsGrouped
Gets a Boolean value determining whether grouping has been set for the C1Scheduler control. This is a dependency property.
Public property IsHitTestVisible
Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property.
(Inherited from UIElement.)
Public property IsInPlaceEditingDisabled
Gets or sets a Boolean value that indicates whether in-place editing of appointments is enabled for an end-user. This is a dependency property.
Public property IsTabStop
Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property.
(Inherited from Control.)
Public property IsTotalGroupItemEnabled
Gets a Boolean value determining whether the C1Scheduler control generates visual intervals for the total group. This is a dependency property. The default value is false.
Public property Language
Gets or sets localization/globalization language information that applies to an element. This is a dependency property.
(Inherited from FrameworkElement.)
Public property LargeStartTimeChange
Gets or sets a TimeSpan used to change the VisualStartTime property by the IncrementStartTimeLarge()()()() and DecrementStartTimeLarge()()()() methods and the IncrementStartTimeLargeCommand and DecrementStartTimeLargeCommand commands. This is a dependency property.
Public property Margin
Gets or sets the outer margin of an element. This is a dependency property.
(Inherited from FrameworkElement.)
Public property MaxHeight
Gets or sets the maximum height constraint of the element. This is a dependency property.
(Inherited from FrameworkElement.)
Public property MaxWidth
Gets or sets the maximum width constraint of the element. This is a dependency property.
(Inherited from FrameworkElement.)
Public property MinHeight
Gets or sets the minimum height constraint of the element. This is a dependency property.
(Inherited from FrameworkElement.)
Public property MinWidth
Gets or sets the minimum width constraint of the element. This is a dependency property.
(Inherited from FrameworkElement.)
Public property MonthStyle
Gets or sets a Style object that defines a UI representation of C1Scheduler control in a Month View mode. This is a dependency property.
Public property MonthViewDayHeaderDayFormat
Gets or sets the String value determining format used to display day name in a day header of a Month view. The default value is '%d'. This is a dependency property.
Public property MonthViewDayHeaderMonthFormat
Gets or sets the String value determining format used to display month name in a day header of a Month view. The default value is 'MMMM'. This is a dependency property.
Public property MonthViewHeaderFormat
Gets or sets the String value determining format used to display day names in a Month view header. The default value is 'dddd'. This is a dependency property.
Public property Name
Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property.
(Inherited from FrameworkElement.)
Public property NestedSetters
Represents a collection of NestedPropertySetter objects used to define values for nested properties in XAML.
Public property NextAppointmentText
Gets or sets a String value used as text for the 'Next Appointment' navigation pane.
Public property OneDayStyle
Gets or sets a Style object that defines a UI representation of C1Scheduler control in a Day View mode. This is a dependency property.
Public property Opacity
Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property.
(Inherited from UIElement.)
Public property OpacityMask
Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property.
(Inherited from UIElement.)
Public property Padding
Gets or sets the padding inside a control. This is a dependency property.
(Inherited from Control.)
Public property Parent
Gets the logical parent element of this element.
(Inherited from FrameworkElement.)
Public property PreviousAppointmentText
Gets or sets a String value used as text for the 'Previous Appointment' navigation pane.
Public property RenderSize
Gets (or sets, but see Remarks) the final render size of this element.
(Inherited from UIElement.)
Public property RenderTransform
Gets or sets transform information that affects the rendering position of this element. This is a dependency property.
(Inherited from UIElement.)
Public property RenderTransformOrigin
Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property.
(Inherited from UIElement.)
Public property Resources
Gets or sets the locally-defined resource dictionary.
(Inherited from FrameworkElement.)
Public property SelectedAppointment
Gets or sets an Appointment that is currently selected in the control UI. This is a dependency property.
Public property SelectedBackground
Gets or sets a Brush object used to highlight currently selected day. This is a dependency property.
Public property SelectedDateTime
Gets or sets a DateTime currently selected in control UI. The default value is Today. This is a dependency property.
Public property SelectedDateTimeInterval
Gets the DateTimeInterval object representing time interval which is currently selected in the control UI. This is a dependency property.
Public property SelectedGroupItem
Gets the selected SchedulerGroupItem object or returns null if the selection is empty. This is a dependency property.
Public property SelectedIntervalAppointment
Gets or sets a IntervalAppointment that is currently selected in control UI. This is a dependency property.
Public property SelectedVisualInterval
Gets or sets the first selected VisualInterval object in the current selection or returns null if the selection is empty.
Public property SelectFromListTemplate
Gets or sets a DataTemplate that defines a UI for the dialog like Select Resources, Select Categories and Select Contacts. This is a dependency property.
Public property Settings
Gets or sets the C1SchedulerSettings object which provides C1Scheduler settings properties. This is a dependency property.
Public property ShowEmptyGroupItem
Gets or sets the Boolean value determining whether the C1Scheduler control should display an empty group item.
Public property ShowRemindersTemplate
Gets or sets a DataTemplate that defines a UI for the Show Reminders dialog. This is a dependency property.
Public property ShowWorkTimeOnly
Gets or sets the Boolean value determining whether control shows working time only. This is a dependency property. This property affects Day/Work Week views or any custom view which has VisualIntervalScale value less than one day.
Public property SmallStartTimeChange
Gets or sets a TimeSpan used to change the VisualStartTime property by the IncrementStartTimeSmall()()()() and DecrementStartTimeSmall()()()() methods and the IncrementStartTimeSmallCommand and DecrementStartTimeSmallCommand commands. This is a dependency property.
Public property Start
Gets or sets a DateTime that defines a beginning of an overall period of time that can be represented by the control. This is a dependency property.
Public property StatusComparison
Gets or sets the Comparison<(Of <(<'T>)>)> delegate which is used by the C1Scheduler control to compare availability statuses.
Public property Style
Gets or sets the style used by this element when it is rendered. This is a dependency property.
(Inherited from FrameworkElement.)
Public property TabIndex
Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property.
(Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property Tag
Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property.
(Inherited from FrameworkElement.)
Public property Template
Gets or sets a control template. This is a dependency property.
(Inherited from Control.)
Public property Theme
Gets or sets a ResourceDictionary object containing Scheduler theme resources.
Public property TimeFormat
Gets or sets the String value determining time format used to display time ruler in a Day, Week and Work Week views. The default value is an empty string. In such case C1Scheduler takes default time format from the current culture. This is a dependency property.
Public property TimeLineStyle
Gets or sets a Style object that defines a UI representation of the C1Scheduler control in a Time Line mode. This is a dependency property.
Public property TodayBackground
Gets or sets a Brush object used to color current day. This is a dependency property.
Public property TotalGroupItem
Gets the SchedulerGroupItem object representing the group item which has no owner, but contains appointments of all visible group items.
Public property Triggers
Gets the collection of triggers established directly on this element, or in child elements.
(Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property VerticalAlignment
Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property.
(Inherited from FrameworkElement.)
Public property VerticalContentAlignment
Gets or sets the vertical alignment of the control's content. This is a dependency property.
(Inherited from Control.)
Public property ViewStyleSelector
Enables you to provide custom style-selection logic for a style that should be applied to the C1Scheduler control. The default value is a null reference. This is a dependency property.
Public property Visibility
Gets or sets the user interface (UI) visibility of this element. This is a dependency property.
(Inherited from UIElement.)
Public property VisibleDates
Gets the list of currently visible dates. Changing this list might affect the next properties:
  • VisualStartTime
  • VisualTimeSpan
  • VisualEndTime
  • Style
Public property VisibleGroupItems
Gets a collection of currently visible SchedulerGroupItem objects. This collection can be used in xaml in the C1Scheduler control templates.
Public property VisualEndTime
Gets an end of a period of time that is currently represented in the control UI. This is a dependency property.
Public property VisualIntervalGroupDescriptions
Gets or sets a collection of VisualIntervalGroupDescription objects that defines a grouping criteria applied to the items of the VisualIntervals collection. This is a dependency property.
Public property VisualIntervalGroups Obsolete.
The C1Scheduler control doesn't use this property any more. This property has been moved to the SchedulerGroupItem class. The VisualIntervalGroups property still exists for the backward compatibility. It returns the VisualIntervalGroups of the default SchedulerGroupItem group. If existing application doesn't require grouping functionality and has custom templates for the C1Scheduler control, all templates will continue working after upgrading to the new version.
Public property VisualIntervalGroupStyles
Gets or sets a collection of GroupStyle objects that characterize UI for each group level defined in the VisualIntervalGroupDescriptions collection. This is a dependency property.
Public property VisualIntervalPanel
Gets or sets a DataTemplate that defines the panel that lays out elements representing VisualInterval objects from the VisualIntervals collection. This is a dependency property.
Public property VisualIntervals Obsolete.
The C1Scheduler control doesn't use this property any more. This property has been moved to the SchedulerGroupItem class. The VisualIntervals property still exists for the backward compatibility. It returns the VisualIntervals of the default SchedulerGroupItem group. If existing application doesn't require grouping functionality and has custom templates for the C1Scheduler control, all templates will continue working after upgrading to the new version.
Public property VisualIntervalScale
Gets or sets a TimeSpan of each VisualInterval in the VisualIntervals collection. This is a dependency property.
Public property VisualIntervalsView Obsolete.
The C1Scheduler control doesn't use this property any more. This property has been moved to the SchedulerGroupItem class. The VisualIntervalsView property still exists for the backward compatibility. It returns the VisualIntervalsView of the default SchedulerGroupItem group. If existing application doesn't require grouping functionality and has custom templates for the C1Scheduler control, all templates will continue working after upgrading to the new version.
Public property VisualIntervalTemplate
Gets or sets a DataTemplate that defines a UI representation of VisualInterval objects from the VisualIntervals collection. This is a dependency property.
Public property VisualStartTime
Gets or sets a start of a period of time that is currently represented in the control UI. This is a dependency property.
Public property VisualTimeSpan
Gets or sets a length of a period of time that is currently represented in the control UI. The start of the period is defined by the VisualStartTime property. This is a dependency property.
Public property WeekStyle
Gets or sets a Style object that defines a UI representation of C1Scheduler control in a Week View mode. This is a dependency property.
Public property WeekViewDayHeaderFormat
Gets or sets the String value determining the format string used to display the day header in a Week view. The default value is 'D'. This is a dependency property.
Public property Width
Gets or sets the width of the element. This is a dependency property.
(Inherited from FrameworkElement.)
Public property WorkingWeekStyle
Gets or sets a Style object that defines a UI representation of C1Scheduler control in a Work Week View mode. This is a dependency property.

Events

Name | Description
Public event AppointmentAdded
Occurs when an Appointment object is added.
Public event AppointmentChanged
Occurs when an Appointment object is changed.
Public event AppointmentCustomAction
Occurs immediately before a custom action of an Appointment object executes.
Public event AppointmentDeleted
Occurs when an Appointment object is deleted.
Public event AppointmentRecurrenceStateChanged
Occurs when the RecurrenceState property of an Appointment object is changed.
Public event BeforeAppointmentDrop
Occurs before an Appointment object is dropped by end-user.
Public event BeforeAppointmentResize
Occurs before an Appointment object is resized by end-user.
Public event BeforeAppointmentSave
Occurs before an Appointment is saved by end-user.
Public event BeforeViewChange
Occurs immediately before the next actions:
  • When range of visible dates is changed by the associated calendar control.
  • When range of visible dates and(or) view type is changed by the C1Scheduler commands.
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event DataSourceItemSynchronized
Occurs when changes made to one of the DataStorage collections (for example, to Appointments) has been fully reflected in the storage underlying data source.
Public event EndChanged
Occurs when the End property value has been changed.
Public event GotFocus
Occurs when this element gets logical focus.
(Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event KeyDown
Occurs when a key is pressed while focus is on this element.
(Inherited from UIElement.)
Public event KeyUp
Occurs when a key is released while focus is on this element.
(Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event Loaded
Occurs when the element is laid out, rendered, and ready for interaction.
(Inherited from FrameworkElement.)
Public event LostFocus
Occurs when this element loses logical focus.
(Inherited from UIElement.)
Public event LostMouseCapture
Occurs when this element loses mouse capture.
(Inherited from UIElement.)
Public event MouseEnter
Occurs when the mouse pointer enters the bounds of this element.
(Inherited from UIElement.)
Public event MouseLeave
Occurs when the mouse pointer leaves the bounds of this element.
(Inherited from UIElement.)
Public event MouseLeftButtonDown
Occurs when the left mouse button is pressed while the mouse pointer is over this element.
(Inherited from UIElement.)
Public event MouseLeftButtonUp
Occurs when the left mouse button is released while the mouse pointer is over this element.
(Inherited from UIElement.)
Public event MouseMove
Occurs when the mouse pointer moves while over this element.
(Inherited from UIElement.)
Public event ReminderAdded
Occurs after a Reminder object is added.
Public event ReminderChanged
Occurs after a Reminder object is changed.
Public event ReminderFire
Occurs when a reminder set on an appointment fires, before the Reminders dialog will be shown on a screen or activated.
Public event ReminderRemoved
Occurs when a Reminder object is removed.
Public event ReminderSnooze
Occurs when a Reminder object is snoozed.
Public event SelectedAppointmentChanged
Occurs when the SelectedAppointment property value has been changed.
Public event SelectedDateTimeChanged
Occurs when the SelectedDateTime property value has been changed.
Public event SizeChanged
Occurs when either the ActualHeight or the ActualWidth properties change value on this element.
(Inherited from FrameworkElement.)
Public event StartChanged
Occurs when the Start property value has been changed.
Public event StyleChanged
Occurs immediately after the control style has been changed.
Public event UserAddingAppointment
Occurs before the Edit Appointment dialog appears on the screen as a result of:
  • a double-click on the control area in one of the default control views,
  • the NewAppointmentDialog method call,
  • a NewAppointmentDialogCommand command.
Public event UserClosingAppointment
Occurs when user closes Edit Appointment dialog without saving.
Public event UserDeletingAppointment
Occurs before the currently selected Appointment is deleted by a user or as a result of the DeleteAppointment method call or receiving the DeleteAppointmentCommand command.
Public event UserEditingAppointment
Occurs before the Edit Appointment dialog appears on the screen for editing of an existing appointment, as a result of a double-click on the appointment in one of the default control views, the EditAppointmentDialog(Appointment) method call, or when an EditAppointmentDialogCommand command is received.

See Also

C1Scheduler Class


C1Scheduler Constructor

[image]

.NET Framework Class Library
C1Scheduler Constructor
C1Scheduler Class See Also
Initializes the new instance of the C1Scheduler control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1Scheduler()
Visual Basic
Public Sub New

See Also

C1Scheduler Class


C1Scheduler Fields

[image] [image]

.NET Framework Class Library
C1Scheduler Fields
C1Scheduler Class See Also

The C1Scheduler type exposes the following members.

Fields

Name | Description
ActiveRemindersProperty | Identifies the ActiveReminders dependency property.
AlternatingBackgroundProperty | Identifies the AlternatingBackground dependency property.
AppointmentForegroundProperty | Identifies the AppointmentForeground dependency property.
BoldedDatesProperty | Identifies the BoldedDates dependency property.
CalendarHelperProperty | Identifies the CalendarHelper dependency property.
CanNavigateNextGroupProperty | Identifies the CanNavigateNextGroup property.
CanNavigatePreviousGroupProperty | Identifies the CanNavigatePreviousGroup property.
ChangeStyleCommand | Defines the command that changes the Style property with the specified Style or a style referenced by the specified ResourceDictionary key.
ControlBackgroundProperty | Identifies the ControlBackground dependency property.
ControlForegroundProperty | Identifies the ControlForeground dependency property.
DayViewDayHeaderFormatProperty | Identifies the DayViewDayHeaderFormat dependency property.
DecrementStartTimeLargeCommand | Defines the command that decrements the VisualStartTime property value on the amount specified in the LargeStartTimeChange property.
DecrementStartTimeSmallCommand | Defines the command that decrements the VisualStartTime property value on the amount specified in the SmallStartTimeChange property.
DeleteAppointmentCommand | Defines the command that deletes the Appointment(s).
DismissCommand | Defines the command that dismisses reminders.
EditAppointmentDialogCommand | Defines the command that shows the Edit Appointment dialog for editing of the specified existing Appointment(s).
EditAppointmentTemplateProperty | Identifies the EditAppointmentTemplate dependency property.
EditRecurrenceDialogCommand | Defines the command that shows the Edit Recurrence dialog for editing a RecurrencePattern of the specified Appointment.
EditRecurrenceTemplateProperty | Identifies the EditRecurrenceTemplate dependency property.
EmptyGroupNameProperty | Identifies the EmptyGroupName property.
EndProperty | Identifies the End dependency property.
ExportCommand | Defines the command that exports Scheduler data to the file.
GroupHeaderTemplateProperty | Identifies the GroupHeaderTemplate dependency property.
GroupPageSizeProperty | Identifies the GroupPageSize dependency property.
HasVisibleAppointmentsProperty | Identifies the HasVisibleAppointments dependency property.
HideGroupCommand | Defines the command that hides the specified SchedulerGroupItem object.
ImportCommand | Defines the command that imports Scheduler data from the file.
IncrementStartTimeLargeCommand | Defines the command that increments the VisualStartTime property value on the amount specified in the LargeStartTimeChange property.
IncrementStartTimeSmallCommand | Defines the command that increments the VisualStartTime property value on the amount specified in the SmallStartTimeChange property.
IntervalAppointmentTemplateProperty | Identifies the IntervalAppointmentTemplate dependency property.
IsDragDropDisabledProperty | Identifies the IsDragDropDisabled dependency property.
IsGroupedProperty | Identifies the IsGrouped property.
IsInPlaceEditingDisabledProperty | Identifies the IsInPlaceEditingDisabled dependency property.
IsTotalGroupItemEnabledProperty | Identifies the IsTotalGroupItemEnabled property.
LargeStartTimeChangeProperty | Identifies the LargeStartTimeChange dependency property.
MonthStyleProperty | Identifies the MonthStyle dependency property.
MonthViewDayHeaderDayFormatProperty | Identifies the MonthViewDayHeaderDayFormat dependency property.
MonthViewDayHeaderMonthFormatProperty | Identifies the MonthViewDayHeaderMonthFormat dependency property.
MonthViewHeaderFormatProperty | Identifies the MonthViewHeaderFormat dependency property.
NavigateToNextAppointmentCommand | Defines the command that makes the nearest appointment after SelectedDateTime visible in the control UI.
NavigateToNextGroupCommand | Defines the command that navigates C1Scheduler UI to the next SchedulerGroupItem object.
NavigateToPreviousAppointmentCommand | Defines the command that makes the nearest appointment before SelectedDateTime visible in the control UI.
NavigateToPreviousGroupCommand | Defines the command that navigates C1Scheduler UI to the previous SchedulerGroupItem object.
NewAppointmentDialogCommand | Defines the command that shows the Edit Appointment dialog for a creation of a new Appointment.
NextAppointmentTextProperty | Identifies the NextAppointmentText property.
OneDayStyleProperty | Identifies the OneDayStyle dependency property.
PreviousAppointmentTextProperty | Identifies the PreviousAppointmentText property.
SelectedAppointmentProperty | Identifies the SelectedAppointment dependency property.
SelectedBackgroundProperty | Identifies the SelectedBackground dependency property.
SelectedDateTimeIntervalProperty | Identifies the SelectedDateTimeInterval dependency property.
SelectedDateTimeProperty | Identifies the SelectedDateTime dependency property.
SelectedGroupItemProperty | Identifies the SelectedGroupItem dependency property.
SelectedIntervalAppointmentProperty | Identifies the SelectedIntervalAppointment dependency property.
SelectedVisualIntervalProperty | Identifies the SelectedVisualInterval dependency property.
SelectFromListDialogCommand | Defines the command that shows the Select From List dialog for specified parameters.
SelectFromListTemplateProperty | Identifies the SelectFromListTemplate dependency property.
SetRelativeStartTimeCommand | Defines the command that sets the VisualStartTime property to a value between the Start and End property values based on the specified coefficient.
SettingsProperty | Identifies the C1SchedulerSettings dependency property.
ShowRemindersTemplateProperty | Identifies the ShowRemindersTemplate dependency property.
ShowWorkTimeOnlyProperty | Identifies the ShowWorkTimeOnly dependency property.
SmallStartTimeChangeProperty | Identifies the SmallStartTimeChange dependency property.
SnoozeCommand | Defines the command that snoozes reminders.
StartProperty | Identifies the Start dependency property.
ThemeProperty | Identifies the Theme dependency property.
TimeFormatProperty | Identifies the TimeFormat dependency property.
TimeLineStyleProperty | Identifies the TimeLineStyle dependency property.
TodayBackgroundProperty | Identifies the TodayBackground dependency property.
ViewStyleSelectorProperty | Identifies the C1StyleSelector dependency property.
VisibleDatesProperty | Identifies the VisibleDates dependency property.
VisualEndTimeProperty | Identifies the VisualEndTimeProperty dependency property.
VisualIntervalGroupDescriptionsProperty | Identifies the VisualIntervalGroupDescriptions dependency property.
VisualIntervalGroupStylesProperty | Identifies the VisualIntervalGroupStyles dependency property.
VisualIntervalPanelProperty | Identifies the VisualIntervalPanel dependency property.
VisualIntervalScaleProperty | Identifies the VisualIntervalScale dependency property.
VisualIntervalTemplateProperty | Identifies the VisualIntervalTemplate dependency property.
VisualStartTimeProperty | Identifies the VisualStartTime dependency property.
VisualTimeSpanProperty | Identifies the VisualTimeSpan dependency property.
WeekStyleProperty | Identifies the WeekStyle dependency property.
WeekViewDayHeaderFormatProperty | Identifies the WeekViewDayHeaderFormat dependency property.
WorkingWeekStyleProperty | Identifies the WorkingWeekStyle dependency property.

See Also

C1Scheduler Class


ActiveRemindersProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..ActiveRemindersProperty Field
C1Scheduler Class See Also
Identifies the ActiveReminders dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty ActiveRemindersProperty
Visual Basic
Public Shared ReadOnly ActiveRemindersProperty As DependencyProperty

See Also

C1Scheduler Class


AlternatingBackgroundProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..AlternatingBackgroundProperty Field
C1Scheduler Class See Also
Identifies the AlternatingBackground dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty AlternatingBackgroundProperty
Visual Basic
Public Shared ReadOnly AlternatingBackgroundProperty As DependencyProperty

See Also

C1Scheduler Class


AppointmentForegroundProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..AppointmentForegroundProperty Field
C1Scheduler Class See Also
Identifies the AppointmentForeground dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty AppointmentForegroundProperty
Visual Basic
Public Shared ReadOnly AppointmentForegroundProperty As DependencyProperty

See Also

C1Scheduler Class


BoldedDatesProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..BoldedDatesProperty Field
C1Scheduler Class See Also
Identifies the BoldedDates dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty BoldedDatesProperty
Visual Basic
Public Shared ReadOnly BoldedDatesProperty As DependencyProperty

See Also

C1Scheduler Class


CalendarHelperProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..CalendarHelperProperty Field
C1Scheduler Class See Also
Identifies the CalendarHelper dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty CalendarHelperProperty
Visual Basic
Public Shared ReadOnly CalendarHelperProperty As DependencyProperty

See Also

C1Scheduler Class


CanNavigateNextGroupProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..CanNavigateNextGroupProperty Field
C1Scheduler Class See Also
Identifies the CanNavigateNextGroup property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty CanNavigateNextGroupProperty
Visual Basic
Public Shared ReadOnly CanNavigateNextGroupProperty As DependencyProperty

See Also

C1Scheduler Class


CanNavigatePreviousGroupProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..CanNavigatePreviousGroupProperty Field
C1Scheduler Class See Also
Identifies the CanNavigatePreviousGroup property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty CanNavigatePreviousGroupProperty
Visual Basic
Public Shared ReadOnly CanNavigatePreviousGroupProperty As DependencyProperty

See Also

C1Scheduler Class


ChangeStyleCommand Field

[image]

.NET Framework Class Library
C1Scheduler..::..ChangeStyleCommand Field
C1Scheduler Class See Also
Defines the command that changes the Style property with the specified Style or a style referenced by the specified ResourceDictionary key.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly C1Command ChangeStyleCommand
Visual Basic
Public Shared ReadOnly ChangeStyleCommand As C1Command

Remarks

This command is executed by the C1Scheduler and is implemented by the ChangeStyle(Object) method.

Command parameter: Style or a ResourceDictionary key representing a Style.

See Also

C1Scheduler Class


ControlBackgroundProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..ControlBackgroundProperty Field
C1Scheduler Class See Also
Identifies the ControlBackground dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty ControlBackgroundProperty
Visual Basic
Public Shared ReadOnly ControlBackgroundProperty As DependencyProperty

See Also

C1Scheduler Class


ControlForegroundProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..ControlForegroundProperty Field
C1Scheduler Class See Also
Identifies the ControlForeground dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty ControlForegroundProperty
Visual Basic
Public Shared ReadOnly ControlForegroundProperty As DependencyProperty

See Also

C1Scheduler Class


DayViewDayHeaderFormatProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..DayViewDayHeaderFormatProperty Field
C1Scheduler Class See Also
Identifies the DayViewDayHeaderFormat dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty DayViewDayHeaderFormatProperty
Visual Basic
Public Shared ReadOnly DayViewDayHeaderFormatProperty As DependencyProperty

See Also

C1Scheduler Class


DecrementStartTimeLargeCommand Field

[image]

.NET Framework Class Library
C1Scheduler..::..DecrementStartTimeLargeCommand Field
C1Scheduler Class See Also
Defines the command that decrements the VisualStartTime property value on the amount specified in the LargeStartTimeChange property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly C1Command DecrementStartTimeLargeCommand
Visual Basic
Public Shared ReadOnly DecrementStartTimeLargeCommand As C1Command

Remarks

This command is executed by the C1Scheduler and is implemented by the DecrementStartTimeLarge()()()() method.

Use this command to implement custom scrolling behavior.

See Also

C1Scheduler Class


DecrementStartTimeSmallCommand Field

[image]

.NET Framework Class Library
C1Scheduler..::..DecrementStartTimeSmallCommand Field
C1Scheduler Class See Also
Defines the command that decrements the VisualStartTime property value on the amount specified in the SmallStartTimeChange property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly C1Command DecrementStartTimeSmallCommand
Visual Basic
Public Shared ReadOnly DecrementStartTimeSmallCommand As C1Command

Remarks

This command is executed by the C1Scheduler and is implemented by the DecrementStartTimeSmall()()()() method.

Use this command to implement custom scrolling behavior.

See Also

C1Scheduler Class


DeleteAppointmentCommand Field

[image]

.NET Framework Class Library
C1Scheduler..::..DeleteAppointmentCommand Field
C1Scheduler Class See Also
Defines the command that deletes the Appointment(s).

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly C1Command DeleteAppointmentCommand
Visual Basic
Public Shared ReadOnly DeleteAppointmentCommand As C1Command

Remarks

This command is executed by the C1Scheduler and is implemented by the DeleteAppointment methods.

Command parameter might be one of the next values:

  • the Appointment to delete
  • IList of Appointment objects to delete
If parameter value is not specified, then control will delete the appointment that is currently selected in the control UI.

See Also

C1Scheduler Class


DismissCommand Field

[image]

.NET Framework Class Library
C1Scheduler..::..DismissCommand Field
C1Scheduler Class See Also
Defines the command that dismisses reminders.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly C1Command DismissCommand
Visual Basic
Public Shared ReadOnly DismissCommand As C1Command

Remarks

Command parameter is one of the next values:

  • IList of Reminder objects to dismiss
  • the Reminder object to dismiss
If command parameter is not specified, all active reminders will be dismissed.

See Also

C1Scheduler Class


EditAppointmentDialogCommand Field

[image]

.NET Framework Class Library
C1Scheduler..::..EditAppointmentDialogCommand Field
C1Scheduler Class See Also
Defines the command that shows the Edit Appointment dialog for editing of the specified existing Appointment(s).

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly C1Command EditAppointmentDialogCommand
Visual Basic
Public Shared ReadOnly EditAppointmentDialogCommand As C1Command

Remarks

This command is executed by the C1Scheduler and is implemented by the EditAppointmentDialog(Appointment) method.

Command parameter is one of the next values:

  • the Appointment to edit
  • IList of Appointment objects to edit
  • nullIList of Reminder objects whose parent appointments should be edited
If parameter value is not specified then control will try to get an appointment from the sender’s DataContext.

See Also

C1Scheduler Class


EditAppointmentTemplateProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..EditAppointmentTemplateProperty Field
C1Scheduler Class See Also
Identifies the EditAppointmentTemplate dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty EditAppointmentTemplateProperty
Visual Basic
Public Shared ReadOnly EditAppointmentTemplateProperty As DependencyProperty

See Also

C1Scheduler Class


EditRecurrenceDialogCommand Field

[image]

.NET Framework Class Library
C1Scheduler..::..EditRecurrenceDialogCommand Field
C1Scheduler Class See Also
Defines the command that shows the Edit Recurrence dialog for editing a RecurrencePattern of the specified Appointment.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly C1Command EditRecurrenceDialogCommand
Visual Basic
Public Shared ReadOnly EditRecurrenceDialogCommand As C1Command

Remarks

This command is executed by the C1Scheduler and is implemented by the EditRecurrenceDialog(Appointment) method.

Command parameter might be one of the next values:

  • the Appointment whose RecurrencePattern will be edited.
  • the dialog window which has an Appointment object whose RecurrencePattern will be edited as content.
If parameter value is not specified, control will try to get an appointment from the sender’s DataContext. If parameter value is dialog window which has an Occurrence or Exception of RecurrencePattern as content, then content of this window will be changed to the Master appointment of this RecurrencePattern.

See Also

C1Scheduler Class


EditRecurrenceTemplateProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..EditRecurrenceTemplateProperty Field
C1Scheduler Class See Also
Identifies the EditRecurrenceTemplate dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty EditRecurrenceTemplateProperty
Visual Basic
Public Shared ReadOnly EditRecurrenceTemplateProperty As DependencyProperty

See Also

C1Scheduler Class


EmptyGroupNameProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..EmptyGroupNameProperty Field
C1Scheduler Class See Also
Identifies the EmptyGroupName property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty EmptyGroupNameProperty
Visual Basic
Public Shared ReadOnly EmptyGroupNameProperty As DependencyProperty

See Also

C1Scheduler Class


EndProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..EndProperty Field
C1Scheduler Class See Also
Identifies the End dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty EndProperty
Visual Basic
Public Shared ReadOnly EndProperty As DependencyProperty

See Also

C1Scheduler Class


ExportCommand Field

[image]

.NET Framework Class Library
C1Scheduler..::..ExportCommand Field
C1Scheduler Class See Also
Defines the command that exports Scheduler data to the file.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly C1Command ExportCommand
Visual Basic
Public Shared ReadOnly ExportCommand As C1Command

Remarks

This command opens "Save File" dialog and then exports data to file.

Command parameter is one of the next values:

  • the Appointment for saving
  • IList<(Of <(<'T>)>)> for saving
  • nullto export all Scheduler data

See Also

C1Scheduler Class


GroupHeaderTemplateProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..GroupHeaderTemplateProperty Field
C1Scheduler Class See Also
Identifies the GroupHeaderTemplate dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty GroupHeaderTemplateProperty
Visual Basic
Public Shared ReadOnly GroupHeaderTemplateProperty As DependencyProperty

See Also

C1Scheduler Class


GroupPageSizeProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..GroupPageSizeProperty Field
C1Scheduler Class See Also
Identifies the GroupPageSize dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty GroupPageSizeProperty
Visual Basic
Public Shared ReadOnly GroupPageSizeProperty As DependencyProperty

See Also

C1Scheduler Class


HasVisibleAppointmentsProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..HasVisibleAppointmentsProperty Field
C1Scheduler Class See Also
Identifies the HasVisibleAppointments dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty HasVisibleAppointmentsProperty
Visual Basic
Public Shared ReadOnly HasVisibleAppointmentsProperty As DependencyProperty

See Also

C1Scheduler Class


HideGroupCommand Field

[image]

.NET Framework Class Library
C1Scheduler..::..HideGroupCommand Field
C1Scheduler Class See Also
Defines the command that hides the specified SchedulerGroupItem object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly C1Command HideGroupCommand
Visual Basic
Public Shared ReadOnly HideGroupCommand As C1Command

Remarks

Command parameter must specify the SchedulerGroupItem object to hide.

See Also

C1Scheduler Class


ImportCommand Field

[image]

.NET Framework Class Library
C1Scheduler..::..ImportCommand Field
C1Scheduler Class See Also
Defines the command that imports Scheduler data from the file.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly C1Command ImportCommand
Visual Basic
Public Shared ReadOnly ImportCommand As C1Command

Remarks

This command opens "Open File" dialog and then tries to import data from selected file.

See Also

C1Scheduler Class


IncrementStartTimeLargeCommand Field

[image]

.NET Framework Class Library
C1Scheduler..::..IncrementStartTimeLargeCommand Field
C1Scheduler Class See Also
Defines the command that increments the VisualStartTime property value on the amount specified in the LargeStartTimeChange property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly C1Command IncrementStartTimeLargeCommand
Visual Basic
Public Shared ReadOnly IncrementStartTimeLargeCommand As C1Command

Remarks

This command is executed by the C1Scheduler and is implemented by the IncrementStartTimeLarge()()()() method.

Use this command to implement custom scrolling behavior.

See Also

C1Scheduler Class


IncrementStartTimeSmallCommand Field

[image]

.NET Framework Class Library
C1Scheduler..::..IncrementStartTimeSmallCommand Field
C1Scheduler Class See Also
Defines the command that increments the VisualStartTime property value on the amount specified in the SmallStartTimeChange property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly C1Command IncrementStartTimeSmallCommand
Visual Basic
Public Shared ReadOnly IncrementStartTimeSmallCommand As C1Command

Remarks

This command is executed by the C1Scheduler and is implemented by the IncrementStartTimeSmall()()()() method.

Use this command to implement custom scrolling behavior.

See Also

C1Scheduler Class


IntervalAppointmentTemplateProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..IntervalAppointmentTemplateProperty Field
C1Scheduler Class See Also
Identifies the IntervalAppointmentTemplate dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty IntervalAppointmentTemplateProperty
Visual Basic
Public Shared ReadOnly IntervalAppointmentTemplateProperty As DependencyProperty

See Also

C1Scheduler Class


IsDragDropDisabledProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..IsDragDropDisabledProperty Field
C1Scheduler Class See Also
Identifies the IsDragDropDisabled dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty IsDragDropDisabledProperty
Visual Basic
Public Shared ReadOnly IsDragDropDisabledProperty As DependencyProperty

See Also

C1Scheduler Class


IsGroupedProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..IsGroupedProperty Field
C1Scheduler Class See Also
Identifies the IsGrouped property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty IsGroupedProperty
Visual Basic
Public Shared ReadOnly IsGroupedProperty As DependencyProperty

See Also

C1Scheduler Class


IsInPlaceEditingDisabledProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..IsInPlaceEditingDisabledProperty Field
C1Scheduler Class See Also
Identifies the IsInPlaceEditingDisabled dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty IsInPlaceEditingDisabledProperty
Visual Basic
Public Shared ReadOnly IsInPlaceEditingDisabledProperty As DependencyProperty

See Also

C1Scheduler Class


IsTotalGroupItemEnabledProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..IsTotalGroupItemEnabledProperty Field
C1Scheduler Class See Also
Identifies the IsTotalGroupItemEnabled property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty IsTotalGroupItemEnabledProperty
Visual Basic
Public Shared ReadOnly IsTotalGroupItemEnabledProperty As DependencyProperty

See Also

C1Scheduler Class


LargeStartTimeChangeProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..LargeStartTimeChangeProperty Field
C1Scheduler Class See Also
Identifies the LargeStartTimeChange dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty LargeStartTimeChangeProperty
Visual Basic
Public Shared ReadOnly LargeStartTimeChangeProperty As DependencyProperty

See Also

C1Scheduler Class


MonthStyleProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..MonthStyleProperty Field
C1Scheduler Class See Also
Identifies the MonthStyle dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty MonthStyleProperty
Visual Basic
Public Shared ReadOnly MonthStyleProperty As DependencyProperty

See Also

C1Scheduler Class


MonthViewDayHeaderDayFormatProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..MonthViewDayHeaderDayFormatProperty Field
C1Scheduler Class See Also
Identifies the MonthViewDayHeaderDayFormat dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty MonthViewDayHeaderDayFormatProperty
Visual Basic
Public Shared ReadOnly MonthViewDayHeaderDayFormatProperty As DependencyProperty

See Also

C1Scheduler Class


MonthViewDayHeaderMonthFormatProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..MonthViewDayHeaderMonthFormatProperty Field
C1Scheduler Class See Also
Identifies the MonthViewDayHeaderMonthFormat dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty MonthViewDayHeaderMonthFormatProperty
Visual Basic
Public Shared ReadOnly MonthViewDayHeaderMonthFormatProperty As DependencyProperty

See Also

C1Scheduler Class


MonthViewHeaderFormatProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..MonthViewHeaderFormatProperty Field
C1Scheduler Class See Also
Identifies the MonthViewHeaderFormat dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty MonthViewHeaderFormatProperty
Visual Basic
Public Shared ReadOnly MonthViewHeaderFormatProperty As DependencyProperty

See Also

C1Scheduler Class


NavigateToNextAppointmentCommand Field

[image]

.NET Framework Class Library
C1Scheduler..::..NavigateToNextAppointmentCommand Field
C1Scheduler Class See Also
Defines the command that makes the nearest appointment after SelectedDateTime visible in the control UI.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly C1Command NavigateToNextAppointmentCommand
Visual Basic
Public Shared ReadOnly NavigateToNextAppointmentCommand As C1Command

Remarks

This command is executed by the C1Scheduler and is implemented by the NavigateToNextAppointment methods. See the NavigateToNextAppointment()()()() and NavigateToNextAppointment(BaseObject) method descriptions for details.

Optional command parameter: the SchedulerGroupItem.Owner object to search in the specific group only.

See Also

C1Scheduler Class


NavigateToNextGroupCommand Field

[image]

.NET Framework Class Library
C1Scheduler..::..NavigateToNextGroupCommand Field
C1Scheduler Class See Also
Defines the command that navigates C1Scheduler UI to the next SchedulerGroupItem object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly C1Command NavigateToNextGroupCommand
Visual Basic
Public Shared ReadOnly NavigateToNextGroupCommand As C1Command

Remarks

Optional command parameter is one of the next values:
  • "Page" for the page navigation. The page size is determined by the GroupPageSize property value.
  • "End" for navigating to the last group.

See Also

C1Scheduler Class


NavigateToPreviousAppointmentCommand Field

[image]

.NET Framework Class Library
C1Scheduler..::..NavigateToPreviousAppointmentCommand Field
C1Scheduler Class See Also
Defines the command that makes the nearest appointment before SelectedDateTime visible in the control UI.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly C1Command NavigateToPreviousAppointmentCommand
Visual Basic
Public Shared ReadOnly NavigateToPreviousAppointmentCommand As C1Command

Remarks

This command is executed by the C1Scheduler and is implemented by the NavigateToPreviousAppointment methods. See the NavigateToPreviousAppointment()()()() and NavigateToPreviousAppointment(BaseObject) method descriptions for details.

Optional command parameter: the SchedulerGroupItem.Owner object to search in the specific group only.

See Also

C1Scheduler Class


NavigateToPreviousGroupCommand Field

[image]

.NET Framework Class Library
C1Scheduler..::..NavigateToPreviousGroupCommand Field
C1Scheduler Class See Also
Defines the command that navigates C1Scheduler UI to the previous SchedulerGroupItem object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly C1Command NavigateToPreviousGroupCommand
Visual Basic
Public Shared ReadOnly NavigateToPreviousGroupCommand As C1Command

Remarks

Optional command parameter is one of the next values:
  • "Page" for the page navigation. The page size is determined by the GroupPageSize property value.
  • "Home" for navigating to the first group.

See Also

C1Scheduler Class


NewAppointmentDialogCommand Field

[image]

.NET Framework Class Library
C1Scheduler..::..NewAppointmentDialogCommand Field
C1Scheduler Class See Also
Defines the command that shows the Edit Appointment dialog for a creation of a new Appointment.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly C1Command NewAppointmentDialogCommand
Visual Basic
Public Shared ReadOnly NewAppointmentDialogCommand As C1Command

Remarks

This command is executed by the C1Scheduler and is implemented by the NewAppointmentDialog methods.

The time interval for which an appointment will be created is determined by the sender’s DataContext.

See Also

C1Scheduler Class


NextAppointmentTextProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..NextAppointmentTextProperty Field
C1Scheduler Class See Also
Identifies the NextAppointmentText property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty NextAppointmentTextProperty
Visual Basic
Public Shared ReadOnly NextAppointmentTextProperty As DependencyProperty

See Also

C1Scheduler Class


OneDayStyleProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..OneDayStyleProperty Field
C1Scheduler Class See Also
Identifies the OneDayStyle dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty OneDayStyleProperty
Visual Basic
Public Shared ReadOnly OneDayStyleProperty As DependencyProperty

See Also

C1Scheduler Class


PreviousAppointmentTextProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..PreviousAppointmentTextProperty Field
C1Scheduler Class See Also
Identifies the PreviousAppointmentText property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty PreviousAppointmentTextProperty
Visual Basic
Public Shared ReadOnly PreviousAppointmentTextProperty As DependencyProperty

See Also

C1Scheduler Class


SelectedAppointmentProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..SelectedAppointmentProperty Field
C1Scheduler Class See Also
Identifies the SelectedAppointment dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty SelectedAppointmentProperty
Visual Basic
Public Shared ReadOnly SelectedAppointmentProperty As DependencyProperty

See Also

C1Scheduler Class


SelectedBackgroundProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..SelectedBackgroundProperty Field
C1Scheduler Class See Also
Identifies the SelectedBackground dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty SelectedBackgroundProperty
Visual Basic
Public Shared ReadOnly SelectedBackgroundProperty As DependencyProperty

See Also

C1Scheduler Class


SelectedDateTimeIntervalProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..SelectedDateTimeIntervalProperty Field
C1Scheduler Class See Also
Identifies the SelectedDateTimeInterval dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty SelectedDateTimeIntervalProperty
Visual Basic
Public Shared ReadOnly SelectedDateTimeIntervalProperty As DependencyProperty

See Also

C1Scheduler Class


SelectedDateTimeProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..SelectedDateTimeProperty Field
C1Scheduler Class See Also
Identifies the SelectedDateTime dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty SelectedDateTimeProperty
Visual Basic
Public Shared ReadOnly SelectedDateTimeProperty As DependencyProperty

See Also

C1Scheduler Class


SelectedGroupItemProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..SelectedGroupItemProperty Field
C1Scheduler Class See Also
Identifies the SelectedGroupItem dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty SelectedGroupItemProperty
Visual Basic
Public Shared ReadOnly SelectedGroupItemProperty As DependencyProperty

See Also

C1Scheduler Class


SelectedIntervalAppointmentProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..SelectedIntervalAppointmentProperty Field
C1Scheduler Class See Also
Identifies the SelectedIntervalAppointment dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty SelectedIntervalAppointmentProperty
Visual Basic
Public Shared ReadOnly SelectedIntervalAppointmentProperty As DependencyProperty

See Also

C1Scheduler Class


SelectedVisualIntervalProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..SelectedVisualIntervalProperty Field
C1Scheduler Class See Also
Identifies the SelectedVisualInterval dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty SelectedVisualIntervalProperty
Visual Basic
Public Shared ReadOnly SelectedVisualIntervalProperty As DependencyProperty

See Also

C1Scheduler Class


SelectFromListDialogCommand Field

[image]

.NET Framework Class Library
C1Scheduler..::..SelectFromListDialogCommand Field
C1Scheduler Class See Also
Defines the command that shows the Select From List dialog for specified parameters.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly C1Command SelectFromListDialogCommand
Visual Basic
Public Shared ReadOnly SelectFromListDialogCommand As C1Command

Remarks

This command is executed by the C1Scheduler and is implemented by the SelectFromListDialog methods.

Command parameter should be an array from 4 or 5 values:

  1. The master list to choose from. For example Resources.
  2. The resulting list where to put selected items. For example Resources list.
  3. The Type value specifying the type of items in both lists.
  4. The reference to the owning window if any.
  5. The String value to show as the dialog window title. This parameter is optional.

See Also

C1Scheduler Class


SelectFromListTemplateProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..SelectFromListTemplateProperty Field
C1Scheduler Class See Also
Identifies the SelectFromListTemplate dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty SelectFromListTemplateProperty
Visual Basic
Public Shared ReadOnly SelectFromListTemplateProperty As DependencyProperty

See Also

C1Scheduler Class


SetRelativeStartTimeCommand Field

[image]

.NET Framework Class Library
C1Scheduler..::..SetRelativeStartTimeCommand Field
C1Scheduler Class See Also
Defines the command that sets the VisualStartTime property to a value between the Start and End property values based on the specified coefficient.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly C1Command SetRelativeStartTimeCommand
Visual Basic
Public Shared ReadOnly SetRelativeStartTimeCommand As C1Command

Remarks

This command is executed by the C1Scheduler and is implemented by the SetRelativeStartTime(Double) method. See the SetRelativeStartTime(Double) method description for details.

Command parameter: a floating point number in a range between 0 and 1, or its string representation, that is passed as a parameter to the SetRelativeStartTime(Double) method.

Use this command to implement custom scrolling behavior.

See Also

C1Scheduler Class


SettingsProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..SettingsProperty Field
C1Scheduler Class See Also
Identifies the C1SchedulerSettings dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty SettingsProperty
Visual Basic
Public Shared ReadOnly SettingsProperty As DependencyProperty

See Also

C1Scheduler Class


ShowRemindersTemplateProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..ShowRemindersTemplateProperty Field
C1Scheduler Class See Also
Identifies the ShowRemindersTemplate dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty ShowRemindersTemplateProperty
Visual Basic
Public Shared ReadOnly ShowRemindersTemplateProperty As DependencyProperty

See Also

C1Scheduler Class


ShowWorkTimeOnlyProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..ShowWorkTimeOnlyProperty Field
C1Scheduler Class See Also
Identifies the ShowWorkTimeOnly dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty ShowWorkTimeOnlyProperty
Visual Basic
Public Shared ReadOnly ShowWorkTimeOnlyProperty As DependencyProperty

See Also

C1Scheduler Class


SmallStartTimeChangeProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..SmallStartTimeChangeProperty Field
C1Scheduler Class See Also
Identifies the SmallStartTimeChange dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty SmallStartTimeChangeProperty
Visual Basic
Public Shared ReadOnly SmallStartTimeChangeProperty As DependencyProperty

See Also

C1Scheduler Class


SnoozeCommand Field

[image]

.NET Framework Class Library
C1Scheduler..::..SnoozeCommand Field
C1Scheduler Class See Also
Defines the command that snoozes reminders.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly C1Command SnoozeCommand
Visual Basic
Public Shared ReadOnly SnoozeCommand As C1Command

Remarks

Command parameter may contain an array of 2 values:

  1. The TimeSpan value specifying time interval used for snoozing.
  2. One of the next values:
    • IList of Reminder objects to snooze
    • the Reminder object to snooze
    This item is optional. If it is not specified, all active reminders will be snoozed.

See Also

C1Scheduler Class


StartProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..StartProperty Field
C1Scheduler Class See Also
Identifies the Start dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty StartProperty
Visual Basic
Public Shared ReadOnly StartProperty As DependencyProperty

See Also

C1Scheduler Class


ThemeProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..ThemeProperty Field
C1Scheduler Class See Also
Identifies the Theme dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty ThemeProperty
Visual Basic
Public Shared ReadOnly ThemeProperty As DependencyProperty

See Also

C1Scheduler Class


TimeFormatProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..TimeFormatProperty Field
C1Scheduler Class See Also
Identifies the TimeFormat dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty TimeFormatProperty
Visual Basic
Public Shared ReadOnly TimeFormatProperty As DependencyProperty

See Also

C1Scheduler Class


TimeLineStyleProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..TimeLineStyleProperty Field
C1Scheduler Class See Also
Identifies the TimeLineStyle dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty TimeLineStyleProperty
Visual Basic
Public Shared ReadOnly TimeLineStyleProperty As DependencyProperty

See Also

C1Scheduler Class


TodayBackgroundProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..TodayBackgroundProperty Field
C1Scheduler Class See Also
Identifies the TodayBackground dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty TodayBackgroundProperty
Visual Basic
Public Shared ReadOnly TodayBackgroundProperty As DependencyProperty

See Also

C1Scheduler Class


ViewStyleSelectorProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..ViewStyleSelectorProperty Field
C1Scheduler Class See Also
Identifies the C1StyleSelector dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty ViewStyleSelectorProperty
Visual Basic
Public Shared ReadOnly ViewStyleSelectorProperty As DependencyProperty

See Also

C1Scheduler Class


VisibleDatesProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..VisibleDatesProperty Field
C1Scheduler Class See Also
Identifies the VisibleDates dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty VisibleDatesProperty
Visual Basic
Public Shared ReadOnly VisibleDatesProperty As DependencyProperty

See Also

C1Scheduler Class


VisualEndTimeProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..VisualEndTimeProperty Field
C1Scheduler Class See Also
Identifies the VisualEndTimeProperty dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty VisualEndTimeProperty
Visual Basic
Public Shared ReadOnly VisualEndTimeProperty As DependencyProperty

See Also

C1Scheduler Class


VisualIntervalGroupDescriptionsProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..VisualIntervalGroupDescriptionsProperty Field
C1Scheduler Class See Also
Identifies the VisualIntervalGroupDescriptions dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty VisualIntervalGroupDescriptionsProperty
Visual Basic
Public Shared ReadOnly VisualIntervalGroupDescriptionsProperty As DependencyProperty

See Also

C1Scheduler Class


VisualIntervalGroupStylesProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..VisualIntervalGroupStylesProperty Field
C1Scheduler Class See Also
Identifies the VisualIntervalGroupStyles dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty VisualIntervalGroupStylesProperty
Visual Basic
Public Shared ReadOnly VisualIntervalGroupStylesProperty As DependencyProperty

See Also

C1Scheduler Class


VisualIntervalPanelProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..VisualIntervalPanelProperty Field
C1Scheduler Class See Also
Identifies the VisualIntervalPanel dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty VisualIntervalPanelProperty
Visual Basic
Public Shared ReadOnly VisualIntervalPanelProperty As DependencyProperty

See Also

C1Scheduler Class


VisualIntervalScaleProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..VisualIntervalScaleProperty Field
C1Scheduler Class See Also
Identifies the VisualIntervalScale dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty VisualIntervalScaleProperty
Visual Basic
Public Shared ReadOnly VisualIntervalScaleProperty As DependencyProperty

See Also

C1Scheduler Class


VisualIntervalTemplateProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..VisualIntervalTemplateProperty Field
C1Scheduler Class See Also
Identifies the VisualIntervalTemplate dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty VisualIntervalTemplateProperty
Visual Basic
Public Shared ReadOnly VisualIntervalTemplateProperty As DependencyProperty

See Also

C1Scheduler Class


VisualStartTimeProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..VisualStartTimeProperty Field
C1Scheduler Class See Also
Identifies the VisualStartTime dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty VisualStartTimeProperty
Visual Basic
Public Shared ReadOnly VisualStartTimeProperty As DependencyProperty

See Also

C1Scheduler Class


VisualTimeSpanProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..VisualTimeSpanProperty Field
C1Scheduler Class See Also
Identifies the VisualTimeSpan dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty VisualTimeSpanProperty
Visual Basic
Public Shared ReadOnly VisualTimeSpanProperty As DependencyProperty

See Also

C1Scheduler Class


WeekStyleProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..WeekStyleProperty Field
C1Scheduler Class See Also
Identifies the WeekStyle dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty WeekStyleProperty
Visual Basic
Public Shared ReadOnly WeekStyleProperty As DependencyProperty

See Also

C1Scheduler Class


WeekViewDayHeaderFormatProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..WeekViewDayHeaderFormatProperty Field
C1Scheduler Class See Also
Identifies the WeekViewDayHeaderFormat dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty WeekViewDayHeaderFormatProperty
Visual Basic
Public Shared ReadOnly WeekViewDayHeaderFormatProperty As DependencyProperty

See Also

C1Scheduler Class


WorkingWeekStyleProperty Field

[image]

.NET Framework Class Library
C1Scheduler..::..WorkingWeekStyleProperty Field
C1Scheduler Class See Also
Identifies the WorkingWeekStyle dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty WorkingWeekStyleProperty
Visual Basic
Public Shared ReadOnly WorkingWeekStyleProperty As DependencyProperty

See Also

C1Scheduler Class


C1Scheduler Methods

[image] [image]

.NET Framework Class Library
C1Scheduler Methods
C1Scheduler Class See Also

The C1Scheduler type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | BeginUpdate | Disables any redrawing of the control.
Public method | BringTimeIntoView | Attempts to bring into the view a UI element representing a VisualInterval that includes the specified time in the current scheduler view. Optionally tries to make the element to be a top left element of the view.
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | ChangeStyle | Changes the Style property with the specified Style or a style referenced by the specified ResourceDictionary key.
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Compare(Appointment, Appointment) | Performs a comparison of two Appointment objects based on their start time and subject.
Public method | Compare(Status, Status) | Performs a comparison of two Status objects based on their StatusType property value.
Public method | DecrementStartTimeLarge | Decrements the VisualStartTime property value on the amount specified in the LargeStartTimeChange property.
Public method | DecrementStartTimeSmall | Decrements the VisualStartTime property value on the amount specified in the SmallStartTimeChange property.
Public method | DeleteAppointment()()()() | Deletes the appointment that is currently selected in control UI and also shows an appointment deletion options dialog in the case where the appointment is an occurrence of a recurrence pattern.
Public method | DeleteAppointment(Appointment) | Deletes the specified appointment.
Public method | Dispose()()()() | Clean up any resources being used.
Protected method | Dispose(Boolean) | Clean up any resources being used.
Public method | EditAppointmentDialog | Shows the Edit Appointment dialog for editing of the specified existing Appointment.
Public method | EditRecurrenceDialog | Shows the Edit Recurrence dialog for editing a RecurrencePattern of the specified Appointment.
Public method | EndUpdate | Enables the redrawing of the control.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindUIForTime | Returns the FrameworkElement corresponding to the given DateTime value.
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
 | GetDateTimeAtPoint | Returns the Nullable<(Of <(<'T>)>)> at the specified location.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | IncrementStartTimeLarge | Increments the VisualStartTime property value on the amount specified in the LargeStartTimeChange property.
Public method | IncrementStartTimeSmall | Increments the VisualStartTime property value on the amount specified in the SmallStartTimeChange property.
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NavigateToAppointment(Boolean, Nullable<(Of <<'(DateTime>)>>)) | Navigates the C1Scheduler control to the nearest Appointment.
Public method | NavigateToAppointment(BaseObject, Boolean, Nullable<(Of <<'(DateTime>)>>)) | Navigates the C1Scheduler control to the nearest Appointment in the GroupItems with the specified owner object.
Public method | NavigateToNextAppointment()()()() | Makes the nearest appointment after SelectedDateTime visible in the control UI.
Public method | NavigateToNextAppointment(BaseObject) | Makes the nearest appointment after SelectedDateTime visible in the control UI.
Public method | NavigateToPreviousAppointment()()()() | Makes the nearest appointment before SelectedDateTime visible in the control UI.
Public method | NavigateToPreviousAppointment(BaseObject) | Makes the nearest appointment before SelectedDateTime visible in the control UI.
Public method | NewAppointmentDialog()()()() | Shows the Edit Appointment dialog for the creation of a new Appointment object. Edit Appointment dialog is initialized according to the SelectedDateTimeInterval property value if it is not null; or according to the current date and time and the VisualIntervalScale property value otherwise.
Public method | NewAppointmentDialog(VisualInterval) | Shows the Edit Appointment dialog for the creation of a new Appointment.
Public method | NewAppointmentDialog(DateTime, DateTime) | Shows the Edit Appointment dialog for the creation of a new Appointment object with the specified start and end values.
Public method | NewAppointmentDialog(DateTime, DateTime, BaseObject) | Shows the Edit Appointment dialog for the creation of a new Appointment object with the specified start and end values.
Public method | NewAppointmentDialog(DateTime, DateTime, Nullable<(Of <<'(Boolean>)>>)) | Shows the Edit Appointment dialog for the creation of a new Appointment object with the specified parameters.
Public method | NewAppointmentDialog(DateTime, DateTime, Nullable<(Of <<'(Boolean>)>>), BaseObject) | Shows the Edit Appointment dialog for the creation of a new Appointment object with the specified parameters.
Public method | OnApplyTemplate | (Overrides FrameworkElement..::..OnApplyTemplate()()()().)
Protected method | OnAppointmentAdded | Raises a AppointmentAdded event.
Protected method | OnAppointmentChanged | Raises a AppointmentChanged event.
Protected method | OnAppointmentCustomAction | Raises a AppointmentCustomAction event.
Protected method | OnAppointmentDeleted | Raises a AppointmentDeleted event.
Protected method | OnAppointmentRecurrenceStateChanged | Raises a AppointmentRecurrenceStateChanged event.
Protected method | OnBeforeAppointmentDrop | Raises a BeforeAppointmentDrop event.
Protected method | OnBeforeAppointmentResize | Raises a BeforeAppointmentResize event.
Protected method | OnBeforeAppointmentSave | Raises a BeforeAppointmentResize event.
Protected method | OnBeforeViewChange | Raises a BeforeViewChange event.
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnDataSourceItemSynchronized | Raises a DataSourceItemSynchronized event;
Protected method | OnDrop |
Protected method | OnEndChanged | Raises an EndChanged event.
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Overrides ControlOnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel |
Protected method | OnReminderAdded | Raises a ReminderAdded event.
Protected method | OnReminderChanged | Raises a ReminderChanged event.
Protected method | OnReminderFire | Raises a ReminderFire event.
Protected method | OnReminderRemoved | Raises a ReminderRemoved event.
Protected method | OnReminderSnooze | Raises a ReminderSnooze event.
Protected method | OnSelectedAppointmentChanged | Raises a SelectedAppointmentChanged event.
Protected method | OnSelectedDateTimeChanged | Raises a SelectedDateTimeChanged event.
Protected method | OnStartChanged | Raises a StartChanged event.
Protected method | OnStyleChanged | Raises a StyleChanged event.
Protected method | OnUserAddingAppointment | Raises a UserAddingAppointment event.
Protected method | OnUserClosingAppointment | Raises a UserEditingAppointment event.
Protected method | OnUserDeletingAppointment | Raises a UserDeletingAppointment event.
Protected method | OnUserEditingAppointment | Raises a UserEditingAppointment event.
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SelectFromListDialog(IList, IList, Type, Appointment, String) | Shows the Select From List dialog. Honors property values defined in the Settings object.
Public method | SelectFromListDialog(IList, IList, Type, Appointment, String, Boolean, Boolean) | Shows the Select From List dialog.
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetRelativeStartTime | Sets the VisualStartTime property to a value between the Start and End property values based on the specified coefficient.
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Protected method | ShouldSerializeEmptyGroupName |
Protected method | ShouldSerializeEnd |
Protected method | ShouldSerializeNextAppointmentText |
Protected method | ShouldSerializePreviousAppointmentText |
Protected method | ShouldSerializeStart |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

C1Scheduler Class


BeginUpdate Method

[image]

.NET Framework Class Library
C1Scheduler..::..BeginUpdate Method
C1Scheduler Class See Also
Disables any redrawing of the control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void BeginUpdate()
Visual Basic
Public Sub BeginUpdate

Remarks

To maintain performance while changing several control properties call the BeginUpdate()()()() method. This method prevents the control from painting until the EndUpdate()()()() method is called.

See Also

C1Scheduler Class


BringTimeIntoView Method

[image]

.NET Framework Class Library
C1Scheduler..::..BringTimeIntoView Method
C1Scheduler Class See Also
Attempts to bring into the view a UI element representing a VisualInterval that includes the specified time in the current scheduler view. Optionally tries to make the element to be a top left element of the view.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void BringTimeIntoView(
    DateTime time,
    bool forceTopLeft
)
Visual Basic
Public Sub BringTimeIntoView ( _
    time As DateTime, _
    forceTopLeft As Boolean _
)

Parameters

time
Type: System..::..DateTime
DateTime whose UI representation should be made visible.
forceTopLeft
Type: System..::..Boolean
Indicates whether an attempt to make the requested UI element a top left one should be performed.

See Also

C1Scheduler Class


ChangeStyle Method

[image]

.NET Framework Class Library
C1Scheduler..::..ChangeStyle Method
C1Scheduler Class See Also
Changes the Style property with the specified Style or a style referenced by the specified ResourceDictionary key.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void ChangeStyle(
    Object styleOrKey
)
Visual Basic
Public Sub ChangeStyle ( _
    styleOrKey As Object _
)

Parameters

styleOrKey
Type: System..::..Object
Style or a ResourceDictionary key representing a Style.

See Also

C1Scheduler Class


Compare Method

[image] [image]

.NET Framework Class Library
C1Scheduler..::..Compare Method
C1Scheduler Class See Also

Overload List

 | Name | Description
Public method | Compare(Appointment, Appointment) | Performs a comparison of two Appointment objects based on their start time and subject.
Public method | Compare(Status, Status) | Performs a comparison of two Status objects based on their StatusType property value.

See Also

C1Scheduler Class
C1Scheduler Members


Compare Method (Appointment, Appointment)

[image]

.NET Framework Class Library
C1Scheduler..::..Compare Method (Appointment, Appointment)
C1Scheduler Class See Also
Performs a comparison of two Appointment objects based on their start time and subject.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public int Compare(
    Appointment x,
    Appointment y
)
Visual Basic
Public Function Compare ( _
    x As Appointment, _
    y As Appointment _
) As Integer

Parameters

x
Type: C1.C1Schedule..::..Appointment
The first Appointment to compare.
y
Type: C1.C1Schedule..::..Appointment
The second Appointment to compare.

Return Value

The Int32 value determining the comparison result.

See Also

C1Scheduler Class
Compare Overload


Compare Method (Status, Status)

[image]

.NET Framework Class Library
C1Scheduler..::..Compare Method (Status, Status)
C1Scheduler Class See Also
Performs a comparison of two Status objects based on their StatusType property value.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public int Compare(
    Status x,
    Status y
)
Visual Basic
Public Function Compare ( _
    x As Status, _
    y As Status _
) As Integer

Parameters

x
Type: C1.C1Schedule..::..Status
The first Status to compare.
y
Type: C1.C1Schedule..::..Status
The second Status to compare.

Return Value

The Int32 value determining the comparison result.

See Also

C1Scheduler Class
Compare Overload


DecrementStartTimeLarge Method

[image]

.NET Framework Class Library
C1Scheduler..::..DecrementStartTimeLarge Method
C1Scheduler Class See Also
Decrements the VisualStartTime property value on the amount specified in the LargeStartTimeChange property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void DecrementStartTimeLarge()
Visual Basic
Public Sub DecrementStartTimeLarge

Remarks

This method implements the DecrementStartTimeLargeCommand command.

See Also

C1Scheduler Class


DecrementStartTimeSmall Method

[image]

.NET Framework Class Library
C1Scheduler..::..DecrementStartTimeSmall Method
C1Scheduler Class See Also
Decrements the VisualStartTime property value on the amount specified in the SmallStartTimeChange property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void DecrementStartTimeSmall()
Visual Basic
Public Sub DecrementStartTimeSmall

Remarks

This method implements the DecrementStartTimeSmallCommand command.

See Also

C1Scheduler Class


DeleteAppointment Method

[image] [image]

.NET Framework Class Library
C1Scheduler..::..DeleteAppointment Method
C1Scheduler Class See Also

Overload List

 | Name | Description
Public method | DeleteAppointment()()()() | Deletes the appointment that is currently selected in control UI and also shows an appointment deletion options dialog in the case where the appointment is an occurrence of a recurrence pattern.
Public method | DeleteAppointment(Appointment) | Deletes the specified appointment.

See Also

C1Scheduler Class
C1Scheduler Members


DeleteAppointment Method

[image]

.NET Framework Class Library
C1Scheduler..::..DeleteAppointment Method
C1Scheduler Class See Also
Deletes the appointment that is currently selected in control UI and also shows an appointment deletion options dialog in the case where the appointment is an occurrence of a recurrence pattern.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void DeleteAppointment()
Visual Basic
Public Sub DeleteAppointment

Remarks

This method implements the DeleteAppointmentCommand command.

See Also

C1Scheduler Class
DeleteAppointment Overload


DeleteAppointment Method (Appointment)

[image]

.NET Framework Class Library
C1Scheduler..::..DeleteAppointment Method (Appointment)
C1Scheduler Class See Also
Deletes the specified appointment.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void DeleteAppointment(
    Appointment appointment
)
Visual Basic
Public Sub DeleteAppointment ( _
    appointment As Appointment _
)

Parameters

appointment
Type: C1.C1Schedule..::..Appointment
The Appointment to delete.

Remarks

This method implements the DeleteAppointmentCommand command.

See Also

C1Scheduler Class
DeleteAppointment Overload


Dispose Method

[image] [image]

.NET Framework Class Library
C1Scheduler..::..Dispose Method
C1Scheduler Class See Also

Overload List

 | Name | Description
Public method | Dispose()()()() | Clean up any resources being used.
Protected method | Dispose(Boolean) | Clean up any resources being used.

See Also

C1Scheduler Class
C1Scheduler Members


Dispose Method

[image]

.NET Framework Class Library
C1Scheduler..::..Dispose Method
C1Scheduler Class See Also
Clean up any resources being used.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

See Also

C1Scheduler Class
Dispose Overload


Dispose Method (Boolean)

[image]

.NET Framework Class Library
C1Scheduler..::..Dispose Method (Boolean)
C1Scheduler Class See Also
Clean up any resources being used.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

C1Scheduler Class
Dispose Overload


EditAppointmentDialog Method

[image]

.NET Framework Class Library
C1Scheduler..::..EditAppointmentDialog Method
C1Scheduler Class See Also
Shows the Edit Appointment dialog for editing of the specified existing Appointment.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void EditAppointmentDialog(
    Appointment appointment
)
Visual Basic
Public Sub EditAppointmentDialog ( _
    appointment As Appointment _
)

Parameters

appointment
Type: C1.C1Schedule..::..Appointment
The editing Appointment.

Remarks

This methods implements the EditAppointmentDialogCommand command.

See Also

C1Scheduler Class


EditRecurrenceDialog Method

[image]

.NET Framework Class Library
C1Scheduler..::..EditRecurrenceDialog Method
C1Scheduler Class See Also
Shows the Edit Recurrence dialog for editing a RecurrencePattern of the specified Appointment.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void EditRecurrenceDialog(
    Appointment appointment
)
Visual Basic
Public Sub EditRecurrenceDialog ( _
    appointment As Appointment _
)

Parameters

appointment
Type: C1.C1Schedule..::..Appointment
Appointment whose RecurrencePattern will be edited in the dialog.

Remarks

This methods implements the EditRecurrenceDialogCommand command.

See Also

C1Scheduler Class


EndUpdate Method

[image]

.NET Framework Class Library
C1Scheduler..::..EndUpdate Method
C1Scheduler Class See Also
Enables the redrawing of the control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void EndUpdate()
Visual Basic
Public Sub EndUpdate

Remarks

To maintain performance while changing several control properties call the BeginUpdate()()()() method. This method prevents the control from painting until the EndUpdate()()()() method is called.

See Also

C1Scheduler Class


FindUIForTime Method

[image]

.NET Framework Class Library
C1Scheduler..::..FindUIForTime Method
C1Scheduler Class See Also
Returns the FrameworkElement corresponding to the given DateTime value.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public FrameworkElement FindUIForTime(
    DateTime time
)
Visual Basic
Public Function FindUIForTime ( _
    time As DateTime _
) As FrameworkElement

Parameters

time
Type: System..::..DateTime
The DateTime value to find the FrameworkElement for.

Return Value

A FrameworkElement that corresponds to the given DateTime value. Returns null if the DateTime value does not belong to displayed range, or if a FrameworkElement has not been generated for it.

See Also

C1Scheduler Class


GetDateTimeAtPoint Method

[image]

.NET Framework Class Library
C1Scheduler..::..GetDateTimeAtPoint Method
C1Scheduler Class See Also
Returns the Nullable<(Of <(<'T>)>)> at the specified location.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static Nullable<DateTime> GetDateTimeAtPoint(
    C1Scheduler scheduler,
    Point location
)
Visual Basic
Public Shared Function GetDateTimeAtPoint ( _
    scheduler As C1Scheduler, _
    location As Point _
) As Nullable(Of DateTime)

Parameters

scheduler
Type: C1.Silverlight.Schedule..::..C1Scheduler
The C1Scheduler control.
location
Type: System.Windows..::..Point
The Point object which specifies location inside control boundaries.

Return Value

Returns DateTime value if found; Null - otherwise.

See Also

C1Scheduler Class


IncrementStartTimeLarge Method

[image]

.NET Framework Class Library
C1Scheduler..::..IncrementStartTimeLarge Method
C1Scheduler Class See Also
Increments the VisualStartTime property value on the amount specified in the LargeStartTimeChange property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void IncrementStartTimeLarge()
Visual Basic
Public Sub IncrementStartTimeLarge

Remarks

This method implements the IncrementStartTimeLargeCommand command.

See Also

C1Scheduler Class


IncrementStartTimeSmall Method

[image]

.NET Framework Class Library
C1Scheduler..::..IncrementStartTimeSmall Method
C1Scheduler Class See Also
Increments the VisualStartTime property value on the amount specified in the SmallStartTimeChange property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void IncrementStartTimeSmall()
Visual Basic
Public Sub IncrementStartTimeSmall

Remarks

This method implements the IncrementStartTimeSmallCommand command.

See Also

C1Scheduler Class


NavigateToAppointment Method

[image] [image]

.NET Framework Class Library
C1Scheduler..::..NavigateToAppointment Method
C1Scheduler Class See Also

Overload List

 | Name | Description
Public method | NavigateToAppointment(Boolean, Nullable<(Of <<'(DateTime>)>>)) | Navigates the C1Scheduler control to the nearest Appointment.
Public method | NavigateToAppointment(BaseObject, Boolean, Nullable<(Of <<'(DateTime>)>>)) | Navigates the C1Scheduler control to the nearest Appointment in the GroupItems with the specified owner object.

See Also

C1Scheduler Class
C1Scheduler Members


NavigateToAppointment Method (Boolean, Nullable(DateTime))

[image]

.NET Framework Class Library
C1Scheduler..::..NavigateToAppointment Method (Boolean, Nullable<(Of <(<'DateTime>)>)>)
C1Scheduler Class See Also
Navigates the C1Scheduler control to the nearest Appointment.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool NavigateToAppointment(
    bool previous,
    Nullable<DateTime> startTime
)
Visual Basic
Public Function NavigateToAppointment ( _
    previous As Boolean, _
    startTime As Nullable(Of DateTime) _
) As Boolean

Parameters

previous
Type: System..::..Boolean
If true, means the backward direction; forward direction otherwise.
startTime
Type: System..::..Nullable <(Of <(<' DateTime >)>)>
The start DateTime point. If this parameter has no value, navigation will be performed starting from the SelectedDateTime property value.

Return Value

True if navigation has occurred; False if there are no appointments in the specified direction.

See Also

C1Scheduler Class
NavigateToAppointment Overload


NavigateToAppointment Method (BaseObject, Boolean, Nullable(DateTime))

[image]

.NET Framework Class Library
C1Scheduler..::..NavigateToAppointment Method (BaseObject, Boolean, Nullable<(Of <(<'DateTime>)>)>)
C1Scheduler Class See Also
Navigates the C1Scheduler control to the nearest Appointment in the GroupItems with the specified owner object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool NavigateToAppointment(
    BaseObject owner,
    bool previous,
    Nullable<DateTime> startTime
)
Visual Basic
Public Function NavigateToAppointment ( _
    owner As BaseObject, _
    previous As Boolean, _
    startTime As Nullable(Of DateTime) _
) As Boolean

Parameters

owner
Type: C1.C1Schedule..::..BaseObject
An owner object determining the SchedulerGroupItem to search through.
previous
Type: System..::..Boolean
If true, means the backward direction; forward direction otherwise.
startTime
Type: System..::..Nullable <(Of <(<' DateTime >)>)>
The start DateTime point. If this parameter has no value, navigation will be performed starting from the SelectedDateTime property value.

Return Value

True if navigation has occurred; False if there are no appointments in the specified direction.

See Also

C1Scheduler Class
NavigateToAppointment Overload


NavigateToNextAppointment Method

[image] [image]

.NET Framework Class Library
C1Scheduler..::..NavigateToNextAppointment Method
C1Scheduler Class See Also

Overload List

 | Name | Description
Public method | NavigateToNextAppointment()()()() | Makes the nearest appointment after SelectedDateTime visible in the control UI.
Public method | NavigateToNextAppointment(BaseObject) | Makes the nearest appointment after SelectedDateTime visible in the control UI.

See Also

C1Scheduler Class
C1Scheduler Members


NavigateToNextAppointment Method

[image]

.NET Framework Class Library
C1Scheduler..::..NavigateToNextAppointment Method
C1Scheduler Class See Also
Makes the nearest appointment after SelectedDateTime visible in the control UI.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool NavigateToNextAppointment()
Visual Basic
Public Function NavigateToNextAppointment As Boolean

Return Value

This method returns a value indicating whether the requested appointment has been found and made visible.

Remarks

This method sets the SelectedAppointment property to the next appointment found and the SelectedDateTime property to the start time of the appointment. If the requested appointment has not been found, then the method changes nothing.

This method implements the NavigateToNextAppointmentCommand command.

See Also

C1Scheduler Class
NavigateToNextAppointment Overload


NavigateToNextAppointment Method (BaseObject)

[image]

.NET Framework Class Library
C1Scheduler..::..NavigateToNextAppointment Method (BaseObject)
C1Scheduler Class See Also
Makes the nearest appointment after SelectedDateTime visible in the control UI.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool NavigateToNextAppointment(
    BaseObject owner
)
Visual Basic
Public Function NavigateToNextAppointment ( _
    owner As BaseObject _
) As Boolean

Parameters

owner
Type: C1.C1Schedule..::..BaseObject
An owner object determining the SchedulerGroupItem to search through.

Return Value

This method returns a value indicating whether the requested appointment has been found and made visible.

Remarks

This method sets the SelectedAppointment property to the next appointment found and the SelectedDateTime property to the start time of the appointment. If the requested appointment has not been found, then the method changes nothing.

This method implements the NavigateToNextAppointmentCommand command.

See Also

C1Scheduler Class
NavigateToNextAppointment Overload


NavigateToPreviousAppointment Method

[image] [image]

.NET Framework Class Library
C1Scheduler..::..NavigateToPreviousAppointment Method
C1Scheduler Class See Also

Overload List

 | Name | Description
Public method | NavigateToPreviousAppointment()()()() | Makes the nearest appointment before SelectedDateTime visible in the control UI.
Public method | NavigateToPreviousAppointment(BaseObject) | Makes the nearest appointment before SelectedDateTime visible in the control UI.

See Also

C1Scheduler Class
C1Scheduler Members


NavigateToPreviousAppointment Method

[image]

.NET Framework Class Library
C1Scheduler..::..NavigateToPreviousAppointment Method
C1Scheduler Class See Also
Makes the nearest appointment before SelectedDateTime visible in the control UI.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool NavigateToPreviousAppointment()
Visual Basic
Public Function NavigateToPreviousAppointment As Boolean

Return Value

This method returns a value indicating whether the requested appointment has been found and made visible.

Remarks

This method sets the SelectedAppointment property to the previous appointment found and the SelectedDateTime property to the start time of the appointment. If the requested appointment has not been found, then the method changes nothing.

This method implements the NavigateToPreviousAppointmentCommand command.

See Also

C1Scheduler Class
NavigateToPreviousAppointment Overload


NavigateToPreviousAppointment Method (BaseObject)

[image]

.NET Framework Class Library
C1Scheduler..::..NavigateToPreviousAppointment Method (BaseObject)
C1Scheduler Class See Also
Makes the nearest appointment before SelectedDateTime visible in the control UI.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool NavigateToPreviousAppointment(
    BaseObject owner
)
Visual Basic
Public Function NavigateToPreviousAppointment ( _
    owner As BaseObject _
) As Boolean

Parameters

owner
Type: C1.C1Schedule..::..BaseObject
An owner object determining the SchedulerGroupItem to search through.

Return Value

This method returns a value indicating whether the requested appointment has been found and made visible.

Remarks

This method sets the SelectedAppointment property to the previous appointment found and the SelectedDateTime property to the start time of the appointment. If the requested appointment has not been found, then the method changes nothing.

This method implements the NavigateToPreviousAppointmentCommand command.

See Also

C1Scheduler Class
NavigateToPreviousAppointment Overload


NewAppointmentDialog Method

[image] [image]

.NET Framework Class Library
C1Scheduler..::..NewAppointmentDialog Method
C1Scheduler Class See Also

Overload List

 | Name | Description
Public method | NewAppointmentDialog()()()() | Shows the Edit Appointment dialog for the creation of a new Appointment object. Edit Appointment dialog is initialized according to the SelectedDateTimeInterval property value if it is not null; or according to the current date and time and the VisualIntervalScale property value otherwise.
Public method | NewAppointmentDialog(VisualInterval) | Shows the Edit Appointment dialog for the creation of a new Appointment.
Public method | NewAppointmentDialog(DateTime, DateTime) | Shows the Edit Appointment dialog for the creation of a new Appointment object with the specified start and end values.
Public method | NewAppointmentDialog(DateTime, DateTime, BaseObject) | Shows the Edit Appointment dialog for the creation of a new Appointment object with the specified start and end values.
Public method | NewAppointmentDialog(DateTime, DateTime, Nullable<(Of <<'(Boolean>)>>)) | Shows the Edit Appointment dialog for the creation of a new Appointment object with the specified parameters.
Public method | NewAppointmentDialog(DateTime, DateTime, Nullable<(Of <<'(Boolean>)>>), BaseObject) | Shows the Edit Appointment dialog for the creation of a new Appointment object with the specified parameters.

See Also

C1Scheduler Class
C1Scheduler Members


NewAppointmentDialog Method

[image]

.NET Framework Class Library
C1Scheduler..::..NewAppointmentDialog Method
C1Scheduler Class See Also
Shows the Edit Appointment dialog for the creation of a new Appointment object. Edit Appointment dialog is initialized according to the SelectedDateTimeInterval property value if it is not null; or according to the current date and time and the VisualIntervalScale property value otherwise.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void NewAppointmentDialog()
Visual Basic
Public Sub NewAppointmentDialog

Remarks

This methods implements the NewAppointmentDialogCommand command.

See Also

C1Scheduler Class
NewAppointmentDialog Overload


NewAppointmentDialog Method (VisualInterval)

[image]

.NET Framework Class Library
C1Scheduler..::..NewAppointmentDialog Method (VisualInterval)
C1Scheduler Class See Also
Shows the Edit Appointment dialog for the creation of a new Appointment.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void NewAppointmentDialog(
    VisualInterval forInterval
)
Visual Basic
Public Sub NewAppointmentDialog ( _
    forInterval As VisualInterval _
)

Parameters

forInterval
Type: C1.Silverlight.Schedule..::..VisualInterval
VisualInterval that determines an initial period of time for a creating Appointment.

Remarks

This methods implements the NewAppointmentDialogCommand command.

See Also

C1Scheduler Class
NewAppointmentDialog Overload


NewAppointmentDialog Method (DateTime, DateTime)

[image]

.NET Framework Class Library
C1Scheduler..::..NewAppointmentDialog Method (DateTime, DateTime)
C1Scheduler Class See Also
Shows the Edit Appointment dialog for the creation of a new Appointment object with the specified start and end values.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void NewAppointmentDialog(
    DateTime start,
    DateTime end
)
Visual Basic
Public Sub NewAppointmentDialog ( _
    start As DateTime, _
    end As DateTime _
)

Parameters

start
Type: System..::..DateTime
The start value.
end
Type: System..::..DateTime
The end value.

Remarks

The value of the AllDayEvent property is determined according the start and end values.

See Also

C1Scheduler Class
NewAppointmentDialog Overload


NewAppointmentDialog Method (DateTime, DateTime, BaseObject)

[image]

.NET Framework Class Library
C1Scheduler..::..NewAppointmentDialog Method (DateTime, DateTime, BaseObject)
C1Scheduler Class See Also
Shows the Edit Appointment dialog for the creation of a new Appointment object with the specified start and end values.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void NewAppointmentDialog(
    DateTime start,
    DateTime end,
    BaseObject groupOwner
)
Visual Basic
Public Sub NewAppointmentDialog ( _
    start As DateTime, _
    end As DateTime, _
    groupOwner As BaseObject _
)

Parameters

start
Type: System..::..DateTime
The start value.
end
Type: System..::..DateTime
The end value.
groupOwner
Type: C1.C1Schedule..::..BaseObject
The object determining SchedulerGroupItemen for which appointment should be created.

Remarks

The value of the AllDayEvent property is determined according the start and end values.

See Also

C1Scheduler Class
NewAppointmentDialog Overload


NewAppointmentDialog Method (DateTime, DateTime, Nullable(Boolean))

[image]

.NET Framework Class Library
C1Scheduler..::..NewAppointmentDialog Method (DateTime, DateTime, Nullable<(Of <(<'Boolean>)>)>)
C1Scheduler Class See Also
Shows the Edit Appointment dialog for the creation of a new Appointment object with the specified parameters.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void NewAppointmentDialog(
    DateTime start,
    DateTime end,
    Nullable<bool> allDayEvent
)
Visual Basic
Public Sub NewAppointmentDialog ( _
    start As DateTime, _
    end As DateTime, _
    allDayEvent As Nullable(Of Boolean) _
)

Parameters

start
Type: System..::..DateTime
The start value.
end
Type: System..::..DateTime
The end value.
allDayEvent
Type: System..::..Nullable <(Of <(<' Boolean >)>)>
The Boolean value specifying whether appointment is all-day event.

See Also

C1Scheduler Class
NewAppointmentDialog Overload


NewAppointmentDialog Method (DateTime, DateTime, Nullable(Boolean), BaseObject)

[image]

.NET Framework Class Library
C1Scheduler..::..NewAppointmentDialog Method (DateTime, DateTime, Nullable<(Of <(<'Boolean>)>)>, BaseObject)
C1Scheduler Class See Also
Shows the Edit Appointment dialog for the creation of a new Appointment object with the specified parameters.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void NewAppointmentDialog(
    DateTime start,
    DateTime end,
    Nullable<bool> allDayEvent,
    BaseObject groupOwner
)
Visual Basic
Public Sub NewAppointmentDialog ( _
    start As DateTime, _
    end As DateTime, _
    allDayEvent As Nullable(Of Boolean), _
    groupOwner As BaseObject _
)

Parameters

start
Type: System..::..DateTime
The start value.
end
Type: System..::..DateTime
The end value.
allDayEvent
Type: System..::..Nullable <(Of <(<' Boolean >)>)>
The Boolean value specifying whether appointment is all-day event.
groupOwner
Type: C1.C1Schedule..::..BaseObject
The object determining SchedulerGroupItemen for which appointment should be created.

See Also

C1Scheduler Class
NewAppointmentDialog Overload


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1Scheduler..::..OnApplyTemplate Method
C1Scheduler Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic
Public Overrides Sub OnApplyTemplate

See Also

C1Scheduler Class


OnAppointmentAdded Method

[image]

.NET Framework Class Library
C1Scheduler..::..OnAppointmentAdded Method
C1Scheduler Class See Also
Raises a AppointmentAdded event.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnAppointmentAdded(
    AppointmentActionEventArgs e
)
Visual Basic
Protected Overridable Sub OnAppointmentAdded ( _
    e As AppointmentActionEventArgs _
)

Parameters

e
Type: C1.Silverlight.Schedule..::..AppointmentActionEventArgs

See Also

C1Scheduler Class


OnAppointmentChanged Method

[image]

.NET Framework Class Library
C1Scheduler..::..OnAppointmentChanged Method
C1Scheduler Class See Also
Raises a AppointmentChanged event.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnAppointmentChanged(
    AppointmentActionEventArgs e
)
Visual Basic
Protected Overridable Sub OnAppointmentChanged ( _
    e As AppointmentActionEventArgs _
)

Parameters

e
Type: C1.Silverlight.Schedule..::..AppointmentActionEventArgs

See Also

C1Scheduler Class


OnAppointmentCustomAction Method

[image]

.NET Framework Class Library
C1Scheduler..::..OnAppointmentCustomAction Method
C1Scheduler Class See Also
Raises a AppointmentCustomAction event.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnAppointmentCustomAction(
    AppointmentActionEventArgs e
)
Visual Basic
Protected Overridable Sub OnAppointmentCustomAction ( _
    e As AppointmentActionEventArgs _
)

Parameters

e
Type: C1.Silverlight.Schedule..::..AppointmentActionEventArgs

See Also

C1Scheduler Class


OnAppointmentDeleted Method

[image]

.NET Framework Class Library
C1Scheduler..::..OnAppointmentDeleted Method
C1Scheduler Class See Also
Raises a AppointmentDeleted event.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnAppointmentDeleted(
    AppointmentActionEventArgs e
)
Visual Basic
Protected Overridable Sub OnAppointmentDeleted ( _
    e As AppointmentActionEventArgs _
)

Parameters

e
Type: C1.Silverlight.Schedule..::..AppointmentActionEventArgs

See Also

C1Scheduler Class


OnAppointmentRecurrenceStateChanged Method

[image]

.NET Framework Class Library
C1Scheduler..::..OnAppointmentRecurrenceStateChanged Method
C1Scheduler Class See Also
Raises a AppointmentRecurrenceStateChanged event.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnAppointmentRecurrenceStateChanged(
    AppointmentActionEventArgs e
)
Visual Basic
Protected Overridable Sub OnAppointmentRecurrenceStateChanged ( _
    e As AppointmentActionEventArgs _
)

Parameters

e
Type: C1.Silverlight.Schedule..::..AppointmentActionEventArgs

See Also

C1Scheduler Class


OnBeforeAppointmentDrop Method

[image]

.NET Framework Class Library
C1Scheduler..::..OnBeforeAppointmentDrop Method
C1Scheduler Class See Also
Raises a BeforeAppointmentDrop event.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnBeforeAppointmentDrop(
    AppointmentActionEventArgs e
)
Visual Basic
Protected Overridable Sub OnBeforeAppointmentDrop ( _
    e As AppointmentActionEventArgs _
)

Parameters

e
Type: C1.Silverlight.Schedule..::..AppointmentActionEventArgs

See Also

C1Scheduler Class


OnBeforeAppointmentResize Method

[image]

.NET Framework Class Library
C1Scheduler..::..OnBeforeAppointmentResize Method
C1Scheduler Class See Also
Raises a BeforeAppointmentResize event.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnBeforeAppointmentResize(
    AppointmentActionEventArgs e
)
Visual Basic
Protected Overridable Sub OnBeforeAppointmentResize ( _
    e As AppointmentActionEventArgs _
)

Parameters

e
Type: C1.Silverlight.Schedule..::..AppointmentActionEventArgs

See Also

C1Scheduler Class


OnBeforeAppointmentSave Method

[image]

.NET Framework Class Library
C1Scheduler..::..OnBeforeAppointmentSave Method
C1Scheduler Class See Also
Raises a BeforeAppointmentResize event.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnBeforeAppointmentSave(
    AppointmentActionEventArgs e
)
Visual Basic
Protected Overridable Sub OnBeforeAppointmentSave ( _
    e As AppointmentActionEventArgs _
)

Parameters

e
Type: C1.Silverlight.Schedule..::..AppointmentActionEventArgs

See Also

C1Scheduler Class


OnBeforeViewChange Method

[image]

.NET Framework Class Library
C1Scheduler..::..OnBeforeViewChange Method
C1Scheduler Class See Also
Raises a BeforeViewChange event.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnBeforeViewChange(
    BeforeViewChangeEventArgs e
)
Visual Basic
Protected Overridable Sub OnBeforeViewChange ( _
    e As BeforeViewChangeEventArgs _
)

Parameters

e
Type: C1.Silverlight.Schedule..::..BeforeViewChangeEventArgs

See Also

C1Scheduler Class


OnDataSourceItemSynchronized Method

[image]

.NET Framework Class Library
C1Scheduler..::..OnDataSourceItemSynchronized Method
C1Scheduler Class See Also
Raises a DataSourceItemSynchronized event;

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnDataSourceItemSynchronized(
    ItemSynchronizedEventArgs e
)
Visual Basic
Protected Overridable Sub OnDataSourceItemSynchronized ( _
    e As ItemSynchronizedEventArgs _
)

Parameters

e
Type: C1.C1Schedule..::..ItemSynchronizedEventArgs

See Also

C1Scheduler Class


OnDrop Method

[image]

.NET Framework Class Library
C1Scheduler..::..OnDrop Method
C1Scheduler Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnDrop(
    DragEventArgs e
)
Visual Basic
Protected Overridable Sub OnDrop ( _
    e As DragEventArgs _
)

Parameters

e
Type: System.Windows..::..DragEventArgs

See Also

C1Scheduler Class


OnEndChanged Method

[image]

.NET Framework Class Library
C1Scheduler..::..OnEndChanged Method
C1Scheduler Class See Also
Raises an EndChanged event.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnEndChanged(
    DateTimePropertyChangeEventArgs e
)
Visual Basic
Protected Overridable Sub OnEndChanged ( _
    e As DateTimePropertyChangeEventArgs _
)

Parameters

e
Type: C1.Silverlight.Schedule..::..DateTimePropertyChangeEventArgs

See Also

C1Scheduler Class


OnKeyDown Method

[image]

.NET Framework Class Library
C1Scheduler..::..OnKeyDown Method
C1Scheduler Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)

Parameters

e
Type: System.Windows.Input..::..KeyEventArgs

See Also

C1Scheduler Class


OnMouseWheel Method

[image]

.NET Framework Class Library
C1Scheduler..::..OnMouseWheel Method
C1Scheduler Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnMouseWheel(
    MouseWheelEventArgs e
)
Visual Basic
Protected Overridable Sub OnMouseWheel ( _
    e As MouseWheelEventArgs _
)

Parameters

e
Type: System.Windows.Input..::..MouseWheelEventArgs

See Also

C1Scheduler Class


OnReminderAdded Method

[image]

.NET Framework Class Library
C1Scheduler..::..OnReminderAdded Method
C1Scheduler Class See Also
Raises a ReminderAdded event.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnReminderAdded(
    ReminderActionEventArgs e
)
Visual Basic
Protected Overridable Sub OnReminderAdded ( _
    e As ReminderActionEventArgs _
)

Parameters

e
Type: C1.Silverlight.Schedule..::..ReminderActionEventArgs

See Also

C1Scheduler Class


OnReminderChanged Method

[image]

.NET Framework Class Library
C1Scheduler..::..OnReminderChanged Method
C1Scheduler Class See Also
Raises a ReminderChanged event.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnReminderChanged(
    ReminderActionEventArgs e
)
Visual Basic
Protected Overridable Sub OnReminderChanged ( _
    e As ReminderActionEventArgs _
)

Parameters

e
Type: C1.Silverlight.Schedule..::..ReminderActionEventArgs

See Also

C1Scheduler Class


OnReminderFire Method

[image]

.NET Framework Class Library
C1Scheduler..::..OnReminderFire Method
C1Scheduler Class See Also
Raises a ReminderFire event.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnReminderFire(
    ReminderActionEventArgs e
)
Visual Basic
Protected Overridable Sub OnReminderFire ( _
    e As ReminderActionEventArgs _
)

Parameters

e
Type: C1.Silverlight.Schedule..::..ReminderActionEventArgs

See Also

C1Scheduler Class


OnReminderRemoved Method

[image]

.NET Framework Class Library
C1Scheduler..::..OnReminderRemoved Method
C1Scheduler Class See Also
Raises a ReminderRemoved event.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnReminderRemoved(
    ReminderActionEventArgs e
)
Visual Basic
Protected Overridable Sub OnReminderRemoved ( _
    e As ReminderActionEventArgs _
)

Parameters

e
Type: C1.Silverlight.Schedule..::..ReminderActionEventArgs

See Also

C1Scheduler Class


OnReminderSnooze Method

[image]

.NET Framework Class Library
C1Scheduler..::..OnReminderSnooze Method
C1Scheduler Class See Also
Raises a ReminderSnooze event.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnReminderSnooze(
    ReminderActionEventArgs e
)
Visual Basic
Protected Overridable Sub OnReminderSnooze ( _
    e As ReminderActionEventArgs _
)

Parameters

e
Type: C1.Silverlight.Schedule..::..ReminderActionEventArgs

See Also

C1Scheduler Class


OnSelectedAppointmentChanged Method

[image]

.NET Framework Class Library
C1Scheduler..::..OnSelectedAppointmentChanged Method
C1Scheduler Class See Also
Raises a SelectedAppointmentChanged event.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnSelectedAppointmentChanged(
    PropertyChangeEventArgsBase e
)
Visual Basic
Protected Overridable Sub OnSelectedAppointmentChanged ( _
    e As PropertyChangeEventArgsBase _
)

Parameters

e
Type: C1.Silverlight.Schedule..::..PropertyChangeEventArgsBase

See Also

C1Scheduler Class


OnSelectedDateTimeChanged Method

[image]

.NET Framework Class Library
C1Scheduler..::..OnSelectedDateTimeChanged Method
C1Scheduler Class See Also
Raises a SelectedDateTimeChanged event.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnSelectedDateTimeChanged(
    DateTimePropertyChangeEventArgs e
)
Visual Basic
Protected Overridable Sub OnSelectedDateTimeChanged ( _
    e As DateTimePropertyChangeEventArgs _
)

Parameters

e
Type: C1.Silverlight.Schedule..::..DateTimePropertyChangeEventArgs

See Also

C1Scheduler Class


OnStartChanged Method

[image]

.NET Framework Class Library
C1Scheduler..::..OnStartChanged Method
C1Scheduler Class See Also
Raises a StartChanged event.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnStartChanged(
    DateTimePropertyChangeEventArgs e
)
Visual Basic
Protected Overridable Sub OnStartChanged ( _
    e As DateTimePropertyChangeEventArgs _
)

Parameters

e
Type: C1.Silverlight.Schedule..::..DateTimePropertyChangeEventArgs

See Also

C1Scheduler Class


OnStyleChanged Method

[image]

.NET Framework Class Library
C1Scheduler..::..OnStyleChanged Method
C1Scheduler Class See Also
Raises a StyleChanged event.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnStyleChanged()
Visual Basic
Protected Overridable Sub OnStyleChanged

See Also

C1Scheduler Class


OnUserAddingAppointment Method

[image]

.NET Framework Class Library
C1Scheduler..::..OnUserAddingAppointment Method
C1Scheduler Class See Also
Raises a UserAddingAppointment event.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnUserAddingAppointment(
    AddingAppointmentEventArgs e
)
Visual Basic
Protected Overridable Sub OnUserAddingAppointment ( _
    e As AddingAppointmentEventArgs _
)

Parameters

e
Type: C1.Silverlight.Schedule..::..AddingAppointmentEventArgs

See Also

C1Scheduler Class


OnUserClosingAppointment Method

[image]

.NET Framework Class Library
C1Scheduler..::..OnUserClosingAppointment Method
C1Scheduler Class See Also
Raises a UserEditingAppointment event.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnUserClosingAppointment(
    AppointmentActionEventArgs e
)
Visual Basic
Protected Overridable Sub OnUserClosingAppointment ( _
    e As AppointmentActionEventArgs _
)

Parameters

e
Type: C1.Silverlight.Schedule..::..AppointmentActionEventArgs

See Also

C1Scheduler Class


OnUserDeletingAppointment Method

[image]

.NET Framework Class Library
C1Scheduler..::..OnUserDeletingAppointment Method
C1Scheduler Class See Also
Raises a UserDeletingAppointment event.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnUserDeletingAppointment(
    AppointmentActionEventArgs e
)
Visual Basic
Protected Overridable Sub OnUserDeletingAppointment ( _
    e As AppointmentActionEventArgs _
)

Parameters

e
Type: C1.Silverlight.Schedule..::..AppointmentActionEventArgs

See Also

C1Scheduler Class


OnUserEditingAppointment Method

[image]

.NET Framework Class Library
C1Scheduler..::..OnUserEditingAppointment Method
C1Scheduler Class See Also
Raises a UserEditingAppointment event.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnUserEditingAppointment(
    AppointmentActionEventArgs e
)
Visual Basic
Protected Overridable Sub OnUserEditingAppointment ( _
    e As AppointmentActionEventArgs _
)

Parameters

e
Type: C1.Silverlight.Schedule..::..AppointmentActionEventArgs

See Also

C1Scheduler Class


SelectFromListDialog Method

[image] [image]

.NET Framework Class Library
C1Scheduler..::..SelectFromListDialog Method
C1Scheduler Class See Also

Overload List

 | Name | Description
Public method | SelectFromListDialog(IList, IList, Type, Appointment, String) | Shows the Select From List dialog. Honors property values defined in the Settings object.
Public method | SelectFromListDialog(IList, IList, Type, Appointment, String, Boolean, Boolean) | Shows the Select From List dialog.

See Also

C1Scheduler Class
C1Scheduler Members


SelectFromListDialog Method (IList, IList, Type, Appointment, String)

[image]

.NET Framework Class Library
C1Scheduler..::..SelectFromListDialog Method (IList, IList, Type, Appointment, String)
C1Scheduler Class See Also
Shows the Select From List dialog. Honors property values defined in the Settings object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void SelectFromListDialog(
    IList sourceList,
    IList targetList,
    Type itemType,
    Appointment app,
    string windowTitle
)
Visual Basic
Public Sub SelectFromListDialog ( _
    sourceList As IList, _
    targetList As IList, _
    itemType As Type, _
    app As Appointment, _
    windowTitle As String _
)

Parameters

sourceList
Type: System.Collections..::..IList
The source list.
targetList
Type: System.Collections..::..IList
The target list.
itemType
Type: System..::..Type
The type of items in both lists.
app
Type: C1.C1Schedule..::..Appointment
The appointment object, for which the dialog is shown.
windowTitle
Type: System..::..String
The dialog title.

See Also

C1Scheduler Class
SelectFromListDialog Overload


SelectFromListDialog Method (IList, IList, Type, Appointment, String, Boolean, Boolean)

[image]

.NET Framework Class Library
C1Scheduler..::..SelectFromListDialog Method (IList, IList, Type, Appointment, String, Boolean, Boolean)
C1Scheduler Class See Also
Shows the Select From List dialog.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void SelectFromListDialog(
    IList sourceList,
    IList targetList,
    Type itemType,
    Appointment app,
    string windowTitle,
    bool allowEdit,
    bool allowMultipleSelection
)
Visual Basic
Public Sub SelectFromListDialog ( _
    sourceList As IList, _
    targetList As IList, _
    itemType As Type, _
    app As Appointment, _
    windowTitle As String, _
    allowEdit As Boolean, _
    allowMultipleSelection As Boolean _
)

Parameters

sourceList
Type: System.Collections..::..IList
The source list.
targetList
Type: System.Collections..::..IList
The target list.
itemType
Type: System..::..Type
The type of items in both lists.
app
Type: C1.C1Schedule..::..Appointment
The appointment object, for which the dialog is shown.
windowTitle
Type: System..::..String
The dialog title.
allowEdit
Type: System..::..Boolean
Determines whether the dialog should allow source collection editing.
allowMultipleSelection
Type: System..::..Boolean
Determines whether multiple selection is allowed.

See Also

C1Scheduler Class
SelectFromListDialog Overload


SetRelativeStartTime Method

[image]

.NET Framework Class Library
C1Scheduler..::..SetRelativeStartTime Method
C1Scheduler Class See Also
Sets the VisualStartTime property to a value between the Start and End property values based on the specified coefficient.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void SetRelativeStartTime(
    double coefficient
)
Visual Basic
Public Sub SetRelativeStartTime ( _
    coefficient As Double _
)

Parameters

coefficient
Type: System..::..Double
A double value in a range between 0 and 1 that defines a relative value between Start and End.

Remarks

The approximate new value is calculated with the following formula:

VisualStartTime = Start + (End - Start) * coefficient

After the new value is calculated, it is adjusted so that the old and new values of the VisualStartTime property become different in an amount that is multiple of the SmallStartTimeChange property value, that guarantees that the first VisualInterval in the VisualIntervals collection is properly aligned to be in synch with UI model suppositions.

This method implements the SetRelativeStartTimeCommand command.

See Also

C1Scheduler Class


ShouldSerializeEmptyGroupName Method

[image]

.NET Framework Class Library
C1Scheduler..::..ShouldSerializeEmptyGroupName Method
C1Scheduler Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected internal bool ShouldSerializeEmptyGroupName()
Visual Basic
Protected Friend Function ShouldSerializeEmptyGroupName As Boolean

See Also

C1Scheduler Class


ShouldSerializeEnd Method

[image]

.NET Framework Class Library
C1Scheduler..::..ShouldSerializeEnd Method
C1Scheduler Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected internal bool ShouldSerializeEnd()
Visual Basic
Protected Friend Function ShouldSerializeEnd As Boolean

See Also

C1Scheduler Class


ShouldSerializeNextAppointmentText Method

[image]

.NET Framework Class Library
C1Scheduler..::..ShouldSerializeNextAppointmentText Method
C1Scheduler Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected internal bool ShouldSerializeNextAppointmentText()
Visual Basic
Protected Friend Function ShouldSerializeNextAppointmentText As Boolean

See Also

C1Scheduler Class


ShouldSerializePreviousAppointmentText Method

[image]

.NET Framework Class Library
C1Scheduler..::..ShouldSerializePreviousAppointmentText Method
C1Scheduler Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected internal bool ShouldSerializePreviousAppointmentText()
Visual Basic
Protected Friend Function ShouldSerializePreviousAppointmentText As Boolean

See Also

C1Scheduler Class


ShouldSerializeStart Method

[image]

.NET Framework Class Library
C1Scheduler..::..ShouldSerializeStart Method
C1Scheduler Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected internal bool ShouldSerializeStart()
Visual Basic
Protected Friend Function ShouldSerializeStart As Boolean

See Also

C1Scheduler Class


C1Scheduler Properties

[image] [image]

.NET Framework Class Library
C1Scheduler Properties
C1Scheduler Class See Also

The C1Scheduler type exposes the following members.

Properties

Name | Description
Public property ActiveReminders
Gets a ReadOnlyObservableCollection<(Of <(<'T>)>)> of active Reminder objects. This is a dependency property.
Public property ActualHeight
Gets the rendered height of this element. This is a dependency property.
(Inherited from FrameworkElement.)
Public property ActualWidth
Gets the rendered width of this element. This is a dependency property.
(Inherited from FrameworkElement.)
Public property AlternatingBackground
Gets or sets a Brush object used as background for working hours and days of alternating months. This is a dependency property.
Public property AppointmentComparison
Gets or sets the Comparison<(Of <(<'T>)>)> delegate which is used by the C1Scheduler control to sort appointments.
Public property AppointmentForeground
Gets or sets a Brush object used as a foreground for appointment elements. This is a dependency property.
Public property Background
Gets or sets a brush that describes the background of a control. This is a dependency property.
(Inherited from Control.)
Public property BoldedDates
Gets the collection of dates which contain appointments. This is a dependency property.
Public property BorderBrush
Gets or sets a brush that describes the border background of a control. This is a dependency property.
(Inherited from Control.)
Public property BorderThickness
Gets or sets the border thickness of a control. This is a dependency property.
(Inherited from Control.)
Public property CalendarHelper
Gets or sets the CalendarHelper object which provides calendar-dependant properties. This is a dependency property.
Public property CanNavigateNextGroup
Gets a Boolean value determining whether the C1Scheduler control can be navigated to the next SchedulerGroupItem object. This is a dependency property.
Public property CanNavigatePreviousGroup
Gets a Boolean value determining whether the C1Scheduler control can be navigated to the next SchedulerGroupItem object. This is a dependency property.
Public property Clip
Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property.
(Inherited from UIElement.)
Public property ControlBackground
Gets or sets a Brush object that is the face color of a control (Time Ruler, Month View header, etc.). This is a dependency property.
Public property ControlForeground
Gets or sets a Brush object that is the text color in a control (Time Ruler, Month View header, etc.). This is a dependency property.
Public property Cursor
Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property.
(Inherited from FrameworkElement.)
Public property DataContext
Gets or sets the data context for an element when it participates in data binding. This is a dependency property.
(Inherited from FrameworkElement.)
Public property DataStorage
Gets a C1ScheduleStorage that stores a data that is represented by the control.
Public property DayViewDayHeaderFormat
Gets or sets the String value determining format used to display day header in a Day view. The default value is 'dddd MMM d'. This is a dependency property.
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property DesiredSize
Gets the size that this element computed during the measure pass of the layout process.
(Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property EditAppointmentTemplate
Gets or sets a DataTemplate that defines a UI for the Edit Appointment dialog. This is a dependency property.
Public property EditRecurrenceTemplate
Gets or sets a DataTemplate that defines a UI for the Edit Recurrence dialog. This is a dependency property.
Public property EmptyGroupName
Gets or sets a String value used as default value for the Name property.
Public property End
Gets or sets a DateTime that defines an end of an overall period of time that can be represented by the control. This is a dependency property.
Public property FontFamily
Gets or sets the font family of the control. This is a dependency property.
(Inherited from Control.)
Public property FontSize
Gets or sets the font size. This is a dependency property.
(Inherited from Control.)
Public property FontStretch
Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property.
(Inherited from Control.)
Public property FontStyle
Gets or sets the font style. This is a dependency property.
(Inherited from Control.)
Public property FontWeight
Gets or sets the weight or thickness of the specified font. This is a dependency property.
(Inherited from Control.)
Public property Foreground
Gets or sets a brush that describes the foreground color. This is a dependency property.
(Inherited from Control.)
Public property GroupBy
Gets or sets the String value determining the type of grouping.
Public property GroupHeaderTemplate
Gets or sets a DataTemplate that defines a UI representation of the SchedulerGroupItem object header. This is a dependency property.
Public property GroupItems
Gets a collection of all available SchedulerGroupItem objects for the currently set type of grouping.
Public property GroupPageSize
Gets or sets the Int32 value determining the maximum number of the SchedulerGroupItem objects displayed in UI at the same time. Increasing this value might affect performance. This is a dependency property.
Public property HasVisibleAppointments
Indicates whether there is at least one visible appointment in the current view. This is a dependency property.
Public property Height
Gets or sets the suggested height of the element. This is a dependency property.
(Inherited from FrameworkElement.)
Public property HorizontalAlignment
Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property.
(Inherited from FrameworkElement.)
Public property HorizontalContentAlignment
Gets or sets the horizontal alignment of the control's content. This is a dependency property.
(Inherited from Control.)
Public property IntervalAppointmentTemplate
Gets or sets a DataTemplate that defines a UI representation of an IntervalAppointment object. This is a dependency property.
Public property IsDragDropDisabled
Gets or sets a Boolean value that indicates whether the C1Scheduler doesn't allow appointment resizing and drag operations. This is a dependency property.
Public property | IsEnabled | (Inherited from Control.)
Public property IsGrouped
Gets a Boolean value determining whether grouping has been set for the C1Scheduler control. This is a dependency property.
Public property IsHitTestVisible
Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property.
(Inherited from UIElement.)
Public property IsInPlaceEditingDisabled
Gets or sets a Boolean value that indicates whether in-place editing of appointments is enabled for an end-user. This is a dependency property.
Public property IsTabStop
Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property.
(Inherited from Control.)
Public property IsTotalGroupItemEnabled
Gets a Boolean value determining whether the C1Scheduler control generates visual intervals for the total group. This is a dependency property. The default value is false.
Public property Language
Gets or sets localization/globalization language information that applies to an element. This is a dependency property.
(Inherited from FrameworkElement.)
Public property LargeStartTimeChange
Gets or sets a TimeSpan used to change the VisualStartTime property by the IncrementStartTimeLarge()()()() and DecrementStartTimeLarge()()()() methods and the IncrementStartTimeLargeCommand and DecrementStartTimeLargeCommand commands. This is a dependency property.
Public property Margin
Gets or sets the outer margin of an element. This is a dependency property.
(Inherited from FrameworkElement.)
Public property MaxHeight
Gets or sets the maximum height constraint of the element. This is a dependency property.
(Inherited from FrameworkElement.)
Public property MaxWidth
Gets or sets the maximum width constraint of the element. This is a dependency property.
(Inherited from FrameworkElement.)
Public property MinHeight
Gets or sets the minimum height constraint of the element. This is a dependency property.
(Inherited from FrameworkElement.)
Public property MinWidth
Gets or sets the minimum width constraint of the element. This is a dependency property.
(Inherited from FrameworkElement.)
Public property MonthStyle
Gets or sets a Style object that defines a UI representation of C1Scheduler control in a Month View mode. This is a dependency property.
Public property MonthViewDayHeaderDayFormat
Gets or sets the String value determining format used to display day name in a day header of a Month view. The default value is '%d'. This is a dependency property.
Public property MonthViewDayHeaderMonthFormat
Gets or sets the String value determining format used to display month name in a day header of a Month view. The default value is 'MMMM'. This is a dependency property.
Public property MonthViewHeaderFormat
Gets or sets the String value determining format used to display day names in a Month view header. The default value is 'dddd'. This is a dependency property.
Public property Name
Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property.
(Inherited from FrameworkElement.)
Public property NestedSetters
Represents a collection of NestedPropertySetter objects used to define values for nested properties in XAML.
Public property NextAppointmentText
Gets or sets a String value used as text for the 'Next Appointment' navigation pane.
Public property OneDayStyle
Gets or sets a Style object that defines a UI representation of C1Scheduler control in a Day View mode. This is a dependency property.
Public property Opacity
Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property.
(Inherited from UIElement.)
Public property OpacityMask
Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property.
(Inherited from UIElement.)
Public property Padding
Gets or sets the padding inside a control. This is a dependency property.
(Inherited from Control.)
Public property Parent
Gets the logical parent element of this element.
(Inherited from FrameworkElement.)
Public property PreviousAppointmentText
Gets or sets a String value used as text for the 'Previous Appointment' navigation pane.
Public property RenderSize
Gets (or sets, but see Remarks) the final render size of this element.
(Inherited from UIElement.)
Public property RenderTransform
Gets or sets transform information that affects the rendering position of this element. This is a dependency property.
(Inherited from UIElement.)
Public property RenderTransformOrigin
Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property.
(Inherited from UIElement.)
Public property Resources
Gets or sets the locally-defined resource dictionary.
(Inherited from FrameworkElement.)
Public property SelectedAppointment
Gets or sets an Appointment that is currently selected in the control UI. This is a dependency property.
Public property SelectedBackground
Gets or sets a Brush object used to highlight currently selected day. This is a dependency property.
Public property SelectedDateTime
Gets or sets a DateTime currently selected in control UI. The default value is Today. This is a dependency property.
Public property SelectedDateTimeInterval
Gets the DateTimeInterval object representing time interval which is currently selected in the control UI. This is a dependency property.
Public property SelectedGroupItem
Gets the selected SchedulerGroupItem object or returns null if the selection is empty. This is a dependency property.
Public property SelectedIntervalAppointment
Gets or sets a IntervalAppointment that is currently selected in control UI. This is a dependency property.
Public property SelectedVisualInterval
Gets or sets the first selected VisualInterval object in the current selection or returns null if the selection is empty.
Public property SelectFromListTemplate
Gets or sets a DataTemplate that defines a UI for the dialog like Select Resources, Select Categories and Select Contacts. This is a dependency property.
Public property Settings
Gets or sets the C1SchedulerSettings object which provides C1Scheduler settings properties. This is a dependency property.
Public property ShowEmptyGroupItem
Gets or sets the Boolean value determining whether the C1Scheduler control should display an empty group item.
Public property ShowRemindersTemplate
Gets or sets a DataTemplate that defines a UI for the Show Reminders dialog. This is a dependency property.
Public property ShowWorkTimeOnly
Gets or sets the Boolean value determining whether control shows working time only. This is a dependency property. This property affects Day/Work Week views or any custom view which has VisualIntervalScale value less than one day.
Public property SmallStartTimeChange
Gets or sets a TimeSpan used to change the VisualStartTime property by the IncrementStartTimeSmall()()()() and DecrementStartTimeSmall()()()() methods and the IncrementStartTimeSmallCommand and DecrementStartTimeSmallCommand commands. This is a dependency property.
Public property Start
Gets or sets a DateTime that defines a beginning of an overall period of time that can be represented by the control. This is a dependency property.
Public property StatusComparison
Gets or sets the Comparison<(Of <(<'T>)>)> delegate which is used by the C1Scheduler control to compare availability statuses.
Public property Style
Gets or sets the style used by this element when it is rendered. This is a dependency property.
(Inherited from FrameworkElement.)
Public property TabIndex
Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property.
(Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property Tag
Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property.
(Inherited from FrameworkElement.)
Public property Template
Gets or sets a control template. This is a dependency property.
(Inherited from Control.)
Public property Theme
Gets or sets a ResourceDictionary object containing Scheduler theme resources.
Public property TimeFormat
Gets or sets the String value determining time format used to display time ruler in a Day, Week and Work Week views. The default value is an empty string. In such case C1Scheduler takes default time format from the current culture. This is a dependency property.
Public property TimeLineStyle
Gets or sets a Style object that defines a UI representation of the C1Scheduler control in a Time Line mode. This is a dependency property.
Public property TodayBackground
Gets or sets a Brush object used to color current day. This is a dependency property.
Public property TotalGroupItem
Gets the SchedulerGroupItem object representing the group item which has no owner, but contains appointments of all visible group items.
Public property Triggers
Gets the collection of triggers established directly on this element, or in child elements.
(Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property VerticalAlignment
Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property.
(Inherited from FrameworkElement.)
Public property VerticalContentAlignment
Gets or sets the vertical alignment of the control's content. This is a dependency property.
(Inherited from Control.)
Public property ViewStyleSelector
Enables you to provide custom style-selection logic for a style that should be applied to the C1Scheduler control. The default value is a null reference. This is a dependency property.
Public property Visibility
Gets or sets the user interface (UI) visibility of this element. This is a dependency property.
(Inherited from UIElement.)
Public property VisibleDates
Gets the list of currently visible dates. Changing this list might affect the next properties:
  • VisualStartTime
  • VisualTimeSpan
  • VisualEndTime
  • Style
Public property VisibleGroupItems
Gets a collection of currently visible SchedulerGroupItem objects. This collection can be used in xaml in the C1Scheduler control templates.
Public property VisualEndTime
Gets an end of a period of time that is currently represented in the control UI. This is a dependency property.
Public property VisualIntervalGroupDescriptions
Gets or sets a collection of VisualIntervalGroupDescription objects that defines a grouping criteria applied to the items of the VisualIntervals collection. This is a dependency property.
Public property VisualIntervalGroups Obsolete.
The C1Scheduler control doesn't use this property any more. This property has been moved to the SchedulerGroupItem class. The VisualIntervalGroups property still exists for the backward compatibility. It returns the VisualIntervalGroups of the default SchedulerGroupItem group. If existing application doesn't require grouping functionality and has custom templates for the C1Scheduler control, all templates will continue working after upgrading to the new version.
Public property VisualIntervalGroupStyles
Gets or sets a collection of GroupStyle objects that characterize UI for each group level defined in the VisualIntervalGroupDescriptions collection. This is a dependency property.
Public property VisualIntervalPanel
Gets or sets a DataTemplate that defines the panel that lays out elements representing VisualInterval objects from the VisualIntervals collection. This is a dependency property.
Public property VisualIntervals Obsolete.
The C1Scheduler control doesn't use this property any more. This property has been moved to the SchedulerGroupItem class. The VisualIntervals property still exists for the backward compatibility. It returns the VisualIntervals of the default SchedulerGroupItem group. If existing application doesn't require grouping functionality and has custom templates for the C1Scheduler control, all templates will continue working after upgrading to the new version.
Public property VisualIntervalScale
Gets or sets a TimeSpan of each VisualInterval in the VisualIntervals collection. This is a dependency property.
Public property VisualIntervalsView Obsolete.
The C1Scheduler control doesn't use this property any more. This property has been moved to the SchedulerGroupItem class. The VisualIntervalsView property still exists for the backward compatibility. It returns the VisualIntervalsView of the default SchedulerGroupItem group. If existing application doesn't require grouping functionality and has custom templates for the C1Scheduler control, all templates will continue working after upgrading to the new version.
Public property VisualIntervalTemplate
Gets or sets a DataTemplate that defines a UI representation of VisualInterval objects from the VisualIntervals collection. This is a dependency property.
Public property VisualStartTime
Gets or sets a start of a period of time that is currently represented in the control UI. This is a dependency property.
Public property VisualTimeSpan
Gets or sets a length of a period of time that is currently represented in the control UI. The start of the period is defined by the VisualStartTime property. This is a dependency property.
Public property WeekStyle
Gets or sets a Style object that defines a UI representation of C1Scheduler control in a Week View mode. This is a dependency property.
Public property WeekViewDayHeaderFormat
Gets or sets the String value determining the format string used to display the day header in a Week view. The default value is 'D'. This is a dependency property.
Public property Width
Gets or sets the width of the element. This is a dependency property.
(Inherited from FrameworkElement.)
Public property WorkingWeekStyle
Gets or sets a Style object that defines a UI representation of C1Scheduler control in a Work Week View mode. This is a dependency property.

See Also

C1Scheduler Class


ActiveReminders Property

[image]

.NET Framework Class Library
C1Scheduler..::..ActiveReminders Property
C1Scheduler Class See Also
Gets a ReadOnlyObservableCollection<(Of <(<'T>)>)> of active Reminder objects. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public ReadOnlyObservableCollection ActiveReminders { get; }
Visual Basic
<BrowsableAttribute(False)> _
Public ReadOnly Property ActiveReminders As ReadOnlyObservableCollection
    Get

See Also

C1Scheduler Class


AlternatingBackground Property

[image]

.NET Framework Class Library
C1Scheduler..::..AlternatingBackground Property
C1Scheduler Class See Also
Gets or sets a Brush object used as background for working hours and days of alternating months. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Brush AlternatingBackground { get; set; }
Visual Basic
Public Property AlternatingBackground As Brush
    Get
    Set

See Also

C1Scheduler Class


AppointmentComparison Property

[image]

.NET Framework Class Library
C1Scheduler..::..AppointmentComparison Property
C1Scheduler Class See Also
Gets or sets the Comparison<(Of <(<'T>)>)> delegate which is used by the C1Scheduler control to sort appointments.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public Comparison<Appointment> AppointmentComparison { get; set; }
Visual Basic
<BrowsableAttribute(False)> _
Public Property AppointmentComparison As Comparison(Of Appointment)
    Get
    Set

See Also

C1Scheduler Class


AppointmentForeground Property

[image]

.NET Framework Class Library
C1Scheduler..::..AppointmentForeground Property
C1Scheduler Class See Also
Gets or sets a Brush object used as a foreground for appointment elements. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Brush AppointmentForeground { get; set; }
Visual Basic
Public Property AppointmentForeground As Brush
    Get
    Set

See Also

C1Scheduler Class


BoldedDates Property

[image]

.NET Framework Class Library
C1Scheduler..::..BoldedDates Property
C1Scheduler Class See Also
Gets the collection of dates which contain appointments. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public DateList BoldedDates { get; }
Visual Basic
<BrowsableAttribute(False)> _
Public ReadOnly Property BoldedDates As DateList
    Get

See Also

C1Scheduler Class


CalendarHelper Property

[image]

.NET Framework Class Library
C1Scheduler..::..CalendarHelper Property
C1Scheduler Class See Also
Gets or sets the CalendarHelper object which provides calendar-dependant properties. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public CalendarHelper CalendarHelper { get; set; }
Visual Basic
Public Property CalendarHelper As CalendarHelper
    Get
    Set

See Also

C1Scheduler Class


CanNavigateNextGroup Property

[image]

.NET Framework Class Library
C1Scheduler..::..CanNavigateNextGroup Property
C1Scheduler Class See Also
Gets a Boolean value determining whether the C1Scheduler control can be navigated to the next SchedulerGroupItem object. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public bool CanNavigateNextGroup { get; private set; }
Visual Basic
<BrowsableAttribute(False)> _
Public Property CanNavigateNextGroup As Boolean
    Get
    Private Set

See Also

C1Scheduler Class


CanNavigatePreviousGroup Property

[image]

.NET Framework Class Library
C1Scheduler..::..CanNavigatePreviousGroup Property
C1Scheduler Class See Also
Gets a Boolean value determining whether the C1Scheduler control can be navigated to the next SchedulerGroupItem object. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public bool CanNavigatePreviousGroup { get; private set; }
Visual Basic
<BrowsableAttribute(False)> _
Public Property CanNavigatePreviousGroup As Boolean
    Get
    Private Set

See Also

C1Scheduler Class


ControlBackground Property

[image]

.NET Framework Class Library
C1Scheduler..::..ControlBackground Property
C1Scheduler Class See Also
Gets or sets a Brush object that is the face color of a control (Time Ruler, Month View header, etc.). This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Brush ControlBackground { get; set; }
Visual Basic
Public Property ControlBackground As Brush
    Get
    Set

See Also

C1Scheduler Class


ControlForeground Property

[image]

.NET Framework Class Library
C1Scheduler..::..ControlForeground Property
C1Scheduler Class See Also
Gets or sets a Brush object that is the text color in a control (Time Ruler, Month View header, etc.). This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Brush ControlForeground { get; set; }
Visual Basic
Public Property ControlForeground As Brush
    Get
    Set

See Also

C1Scheduler Class


DataStorage Property

[image]

.NET Framework Class Library
C1Scheduler..::..DataStorage Property
C1Scheduler Class See Also
Gets a C1ScheduleStorage that stores a data that is represented by the control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1ScheduleStorage DataStorage { get; }
Visual Basic
Public ReadOnly Property DataStorage As C1ScheduleStorage
    Get

See Also

C1Scheduler Class


DayViewDayHeaderFormat Property

[image]

.NET Framework Class Library
C1Scheduler..::..DayViewDayHeaderFormat Property
C1Scheduler Class See Also
Gets or sets the String value determining format used to display day header in a Day view. The default value is 'dddd MMM d'. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute("dddd MMM d")]
public string DayViewDayHeaderFormat { get; set; }
Visual Basic
<DefaultValueAttribute("dddd MMM d")> _
Public Property DayViewDayHeaderFormat As String
    Get
    Set

See Also

C1Scheduler Class


EditAppointmentTemplate Property

[image]

.NET Framework Class Library
C1Scheduler..::..EditAppointmentTemplate Property
C1Scheduler Class See Also
Gets or sets a DataTemplate that defines a UI for the Edit Appointment dialog. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DataTemplate EditAppointmentTemplate { get; set; }
Visual Basic
Public Property EditAppointmentTemplate As DataTemplate
    Get
    Set

Remarks

A DataContext for this template is an Appointment object.

See Also

C1Scheduler Class


EditRecurrenceTemplate Property

[image]

.NET Framework Class Library
C1Scheduler..::..EditRecurrenceTemplate Property
C1Scheduler Class See Also
Gets or sets a DataTemplate that defines a UI for the Edit Recurrence dialog. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DataTemplate EditRecurrenceTemplate { get; set; }
Visual Basic
Public Property EditRecurrenceTemplate As DataTemplate
    Get
    Set

Remarks

A DataContext for this template is a RecurrencePattern object.

See Also

C1Scheduler Class


EmptyGroupName Property

[image]

.NET Framework Class Library
C1Scheduler..::..EmptyGroupName Property
C1Scheduler Class See Also
Gets or sets a String value used as default value for the Name property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string EmptyGroupName { get; set; }
Visual Basic
Public Property EmptyGroupName As String
    Get
    Set

See Also

C1Scheduler Class


End Property

[image]

.NET Framework Class Library
C1Scheduler..::..End Property
C1Scheduler Class See Also
Gets or sets a DateTime that defines an end of an overall period of time that can be represented by the control. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[TypeConverterAttribute(typeof(DateTimeTypeConverter))]
public DateTime End { get; set; }
Visual Basic
<TypeConverterAttribute(GetType(DateTimeTypeConverter))> _
Public Property End As DateTime
    Get
    Set

See Also

C1Scheduler Class


GroupBy Property

[image]

.NET Framework Class Library
C1Scheduler..::..GroupBy Property
C1Scheduler Class See Also
Gets or sets the String value determining the type of grouping.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute("")]
public string GroupBy { get; set; }
Visual Basic
<DefaultValueAttribute("")> _
Public Property GroupBy As String
    Get
    Set

Field Value

The default value is an empty string.

Remarks

This property can be equal to one for the next supported keywords: An empty stringno grouping."Owner"grouping by Appointment.Owner property value."Category"grouping by Appointment.Categories property value."Contact"grouping by Appointment.Links property value."Resource"grouping by Appointment.Resources property value.

See Also

C1Scheduler Class


GroupHeaderTemplate Property

[image]

.NET Framework Class Library
C1Scheduler..::..GroupHeaderTemplate Property
C1Scheduler Class See Also
Gets or sets a DataTemplate that defines a UI representation of the SchedulerGroupItem object header. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DataTemplate GroupHeaderTemplate { get; set; }
Visual Basic
Public Property GroupHeaderTemplate As DataTemplate
    Get
    Set

See Also

C1Scheduler Class


GroupItems Property

[image]

.NET Framework Class Library
C1Scheduler..::..GroupItems Property
C1Scheduler Class See Also
Gets a collection of all available SchedulerGroupItem objects for the currently set type of grouping.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public SchedulerGroupItemCollection GroupItems { get; }
Visual Basic
<BrowsableAttribute(False)> _
Public ReadOnly Property GroupItems As SchedulerGroupItemCollection
    Get

See Also

C1Scheduler Class


GroupPageSize Property

[image]

.NET Framework Class Library
C1Scheduler..::..GroupPageSize Property
C1Scheduler Class See Also
Gets or sets the Int32 value determining the maximum number of the SchedulerGroupItem objects displayed in UI at the same time. Increasing this value might affect performance. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public int GroupPageSize { get; set; }
Visual Basic
Public Property GroupPageSize As Integer
    Get
    Set

Field Value

The default value is 2.

See Also

C1Scheduler Class


HasVisibleAppointments Property

[image]

.NET Framework Class Library
C1Scheduler..::..HasVisibleAppointments Property
C1Scheduler Class See Also
Indicates whether there is at least one visible appointment in the current view. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public bool HasVisibleAppointments { get; }
Visual Basic
<BrowsableAttribute(False)> _
Public ReadOnly Property HasVisibleAppointments As Boolean
    Get

See Also

C1Scheduler Class


IntervalAppointmentTemplate Property

[image]

.NET Framework Class Library
C1Scheduler..::..IntervalAppointmentTemplate Property
C1Scheduler Class See Also
Gets or sets a DataTemplate that defines a UI representation of an IntervalAppointment object. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DataTemplate IntervalAppointmentTemplate { get; set; }
Visual Basic
Public Property IntervalAppointmentTemplate As DataTemplate
    Get
    Set

Remarks

A single appointment can be represented by multiple elements in control's view. For example, in the Months view the appointment that hit two weeks will be represented by two separate elements, a different element for each week. Because of this, a DataContext for the appointment template is a IntervalAppointment object (but not an Appointment object), which represents the chunk of appointment covering a specific period of time that can be shown by a single UI element.

See Also

C1Scheduler Class


IsDragDropDisabled Property

[image]

.NET Framework Class Library
C1Scheduler..::..IsDragDropDisabled Property
C1Scheduler Class See Also
Gets or sets a Boolean value that indicates whether the C1Scheduler doesn't allow appointment resizing and drag operations. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(false)]
public bool IsDragDropDisabled { get; set; }
Visual Basic
<DefaultValueAttribute(False)> _
Public Property IsDragDropDisabled As Boolean
    Get
    Set

Remarks

Disabling of appointment resizing and drag operations is implemented with the help of IsDragDropDisabled property in default styles and templates. Make sure to honor IsDragDropDisabled property value in custom styles and templates.

See Also

C1Scheduler Class


IsGrouped Property

[image]

.NET Framework Class Library
C1Scheduler..::..IsGrouped Property
C1Scheduler Class See Also
Gets a Boolean value determining whether grouping has been set for the C1Scheduler control. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public bool IsGrouped { get; private set; }
Visual Basic
<BrowsableAttribute(False)> _
Public Property IsGrouped As Boolean
    Get
    Private Set

See Also

C1Scheduler Class


IsInPlaceEditingDisabled Property

[image]

.NET Framework Class Library
C1Scheduler..::..IsInPlaceEditingDisabled Property
C1Scheduler Class See Also
Gets or sets a Boolean value that indicates whether in-place editing of appointments is enabled for an end-user. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(false)]
public bool IsInPlaceEditingDisabled { get; set; }
Visual Basic
<DefaultValueAttribute(False)> _
Public Property IsInPlaceEditingDisabled As Boolean
    Get
    Set

Remarks

This value only affects a user who is interacting with the control. All data can always be modified programmatically. Note: disabling of in-place editing is implemented with the help of IsReadOnly property in default IntervalAppointment templates. Make sure to honor IsInPlaceEditingDisabled property value in custom IntervalAppointment templates.

See Also

C1Scheduler Class


IsTotalGroupItemEnabled Property

[image]

.NET Framework Class Library
C1Scheduler..::..IsTotalGroupItemEnabled Property
C1Scheduler Class See Also
Gets a Boolean value determining whether the C1Scheduler control generates visual intervals for the total group. This is a dependency property. The default value is false.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsTotalGroupItemEnabled { get; set; }
Visual Basic
Public Property IsTotalGroupItemEnabled As Boolean
    Get
    Set

See Also

C1Scheduler Class


LargeStartTimeChange Property

[image]

.NET Framework Class Library
C1Scheduler..::..LargeStartTimeChange Property
C1Scheduler Class See Also
Gets or sets a TimeSpan used to change the VisualStartTime property by the IncrementStartTimeLarge()()()() and DecrementStartTimeLarge()()()() methods and the IncrementStartTimeLargeCommand and DecrementStartTimeLargeCommand commands. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public TimeSpan LargeStartTimeChange { get; set; }
Visual Basic
<BrowsableAttribute(False)> _
Public Property LargeStartTimeChange As TimeSpan
    Get
    Set

Remarks

If this value is not set, then the value of the VisualTimeSpan property is used.

See Also

C1Scheduler Class


MonthStyle Property

[image]

.NET Framework Class Library
C1Scheduler..::..MonthStyle Property
C1Scheduler Class See Also
Gets or sets a Style object that defines a UI representation of C1Scheduler control in a Month View mode. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Style MonthStyle { get; set; }
Visual Basic
Public Property MonthStyle As Style
    Get
    Set

See Also

C1Scheduler Class


MonthViewDayHeaderDayFormat Property

[image]

.NET Framework Class Library
C1Scheduler..::..MonthViewDayHeaderDayFormat Property
C1Scheduler Class See Also
Gets or sets the String value determining format used to display day name in a day header of a Month view. The default value is '%d'. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute("%d")]
public string MonthViewDayHeaderDayFormat { get; set; }
Visual Basic
<DefaultValueAttribute("%d")> _
Public Property MonthViewDayHeaderDayFormat As String
    Get
    Set

See Also

C1Scheduler Class


MonthViewDayHeaderMonthFormat Property

[image]

.NET Framework Class Library
C1Scheduler..::..MonthViewDayHeaderMonthFormat Property
C1Scheduler Class See Also
Gets or sets the String value determining format used to display month name in a day header of a Month view. The default value is 'MMMM'. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute("MMMM")]
public string MonthViewDayHeaderMonthFormat { get; set; }
Visual Basic
<DefaultValueAttribute("MMMM")> _
Public Property MonthViewDayHeaderMonthFormat As String
    Get
    Set

See Also

C1Scheduler Class


MonthViewHeaderFormat Property

[image]

.NET Framework Class Library
C1Scheduler..::..MonthViewHeaderFormat Property
C1Scheduler Class See Also
Gets or sets the String value determining format used to display day names in a Month view header. The default value is 'dddd'. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute("dddd")]
public string MonthViewHeaderFormat { get; set; }
Visual Basic
<DefaultValueAttribute("dddd")> _
Public Property MonthViewHeaderFormat As String
    Get
    Set

See Also

C1Scheduler Class


NestedSetters Property

[image]

.NET Framework Class Library
C1Scheduler..::..NestedSetters Property
C1Scheduler Class See Also
Represents a collection of NestedPropertySetter objects used to define values for nested properties in XAML.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[BrowsableAttribute(false)]
public NestedPropertySetterCollection NestedSetters { get; }
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
<BrowsableAttribute(False)> _
Public ReadOnly Property NestedSetters As NestedPropertySetterCollection
    Get

Remarks

This collection is primarily designed to provide a design-time serialization of the DataStorage settings.

XAML doesn't provide an ability to assign a value to a nested property. Meanwhile an object model of DataStorage is a nested by its nature. So to work around this limitation the NestedSetters is introduced.

See Also

C1Scheduler Class


NextAppointmentText Property

[image]

.NET Framework Class Library
C1Scheduler..::..NextAppointmentText Property
C1Scheduler Class See Also
Gets or sets a String value used as text for the 'Next Appointment' navigation pane.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string NextAppointmentText { get; set; }
Visual Basic
Public Property NextAppointmentText As String
    Get
    Set

See Also

C1Scheduler Class


OneDayStyle Property

[image]

.NET Framework Class Library
C1Scheduler..::..OneDayStyle Property
C1Scheduler Class See Also
Gets or sets a Style object that defines a UI representation of C1Scheduler control in a Day View mode. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Style OneDayStyle { get; set; }
Visual Basic
Public Property OneDayStyle As Style
    Get
    Set

See Also

C1Scheduler Class


PreviousAppointmentText Property

[image]

.NET Framework Class Library
C1Scheduler..::..PreviousAppointmentText Property
C1Scheduler Class See Also
Gets or sets a String value used as text for the 'Previous Appointment' navigation pane.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string PreviousAppointmentText { get; set; }
Visual Basic
Public Property PreviousAppointmentText As String
    Get
    Set

See Also

C1Scheduler Class


SelectedAppointment Property

[image]

.NET Framework Class Library
C1Scheduler..::..SelectedAppointment Property
C1Scheduler Class See Also
Gets or sets an Appointment that is currently selected in the control UI. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public Appointment SelectedAppointment { get; set; }
Visual Basic
<BrowsableAttribute(False)> _
Public Property SelectedAppointment As Appointment
    Get
    Set

See Also

C1Scheduler Class


SelectedBackground Property

[image]

.NET Framework Class Library
C1Scheduler..::..SelectedBackground Property
C1Scheduler Class See Also
Gets or sets a Brush object used to highlight currently selected day. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Brush SelectedBackground { get; set; }
Visual Basic
Public Property SelectedBackground As Brush
    Get
    Set

See Also

C1Scheduler Class


SelectedDateTime Property

[image]

.NET Framework Class Library
C1Scheduler..::..SelectedDateTime Property
C1Scheduler Class See Also
Gets or sets a DateTime currently selected in control UI. The default value is Today. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public DateTime SelectedDateTime { get; set; }
Visual Basic
<BrowsableAttribute(False)> _
Public Property SelectedDateTime As DateTime
    Get
    Set

Remarks

This property value is related to a VisualInterval from the VisualIntervals collection that is currently selected in control UI. If this property is set to a value that is beyond a currently represented period of time defined by the VisualStartTime and VisualTimeSpan properties, the value of the VisualStartTime property is changed automatically so as to set up a period of time that includes the new SelectedDateTime property value.

You can use this property to bind the control to external controls that provides DateTime navigation, for example, bind it to the SelectedDateTime property of the C1Calendar control.

See Also

C1Scheduler Class


SelectedDateTimeInterval Property

[image]

.NET Framework Class Library
C1Scheduler..::..SelectedDateTimeInterval Property
C1Scheduler Class See Also
Gets the DateTimeInterval object representing time interval which is currently selected in the control UI. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public DateTimeInterval SelectedDateTimeInterval { get; }
Visual Basic
<BrowsableAttribute(False)> _
Public ReadOnly Property SelectedDateTimeInterval As DateTimeInterval
    Get

See Also

C1Scheduler Class


SelectedGroupItem Property

[image]

.NET Framework Class Library
C1Scheduler..::..SelectedGroupItem Property
C1Scheduler Class See Also
Gets the selected SchedulerGroupItem object or returns null if the selection is empty. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public SchedulerGroupItem SelectedGroupItem { get; internal set; }
Visual Basic
<BrowsableAttribute(False)> _
Public Property SelectedGroupItem As SchedulerGroupItem
    Get
    Friend Set

See Also

C1Scheduler Class


SelectedIntervalAppointment Property

[image]

.NET Framework Class Library
C1Scheduler..::..SelectedIntervalAppointment Property
C1Scheduler Class See Also
Gets or sets a IntervalAppointment that is currently selected in control UI. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public IntervalAppointment SelectedIntervalAppointment { get; set; }
Visual Basic
<BrowsableAttribute(False)> _
Public Property SelectedIntervalAppointment As IntervalAppointment
    Get
    Set

See Also

C1Scheduler Class


SelectedVisualInterval Property

[image]

.NET Framework Class Library
C1Scheduler..::..SelectedVisualInterval Property
C1Scheduler Class See Also
Gets or sets the first selected VisualInterval object in the current selection or returns null if the selection is empty.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public VisualInterval SelectedVisualInterval { get; set; }
Visual Basic
<BrowsableAttribute(False)> _
Public Property SelectedVisualInterval As VisualInterval
    Get
    Set

See Also

C1Scheduler Class


SelectFromListTemplate Property

[image]

.NET Framework Class Library
C1Scheduler..::..SelectFromListTemplate Property
C1Scheduler Class See Also
Gets or sets a DataTemplate that defines a UI for the dialog like Select Resources, Select Categories and Select Contacts. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DataTemplate SelectFromListTemplate { get; set; }
Visual Basic
Public Property SelectFromListTemplate As DataTemplate
    Get
    Set

See Also

C1Scheduler Class


Settings Property

[image]

.NET Framework Class Library
C1Scheduler..::..Settings Property
C1Scheduler Class See Also
Gets or sets the C1SchedulerSettings object which provides C1Scheduler settings properties. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1SchedulerSettings Settings { get; set; }
Visual Basic
Public Property Settings As C1SchedulerSettings
    Get
    Set

See Also

C1Scheduler Class


ShowEmptyGroupItem Property

[image]

.NET Framework Class Library
C1Scheduler..::..ShowEmptyGroupItem Property
C1Scheduler Class See Also
Gets or sets the Boolean value determining whether the C1Scheduler control should display an empty group item.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(false)]
public bool ShowEmptyGroupItem { get; set; }
Visual Basic
<DefaultValueAttribute(False)> _
Public Property ShowEmptyGroupItem As Boolean
    Get
    Set

Field Value

The default value is false.

Remarks

This property only makes sense when the GroupBy property is set. If this property is set to True, the C1Scheduler control will display a group item without assigned owner (resource, contact or category). This group item will contain all appointments, which don't fall into other group items.

See Also

C1Scheduler Class


ShowRemindersTemplate Property

[image]

.NET Framework Class Library
C1Scheduler..::..ShowRemindersTemplate Property
C1Scheduler Class See Also
Gets or sets a DataTemplate that defines a UI for the Show Reminders dialog. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DataTemplate ShowRemindersTemplate { get; set; }
Visual Basic
Public Property ShowRemindersTemplate As DataTemplate
    Get
    Set

Remarks

A DataContext for this template is a Reminders collection.

See Also

C1Scheduler Class


ShowWorkTimeOnly Property

[image]

.NET Framework Class Library
C1Scheduler..::..ShowWorkTimeOnly Property
C1Scheduler Class See Also
Gets or sets the Boolean value determining whether control shows working time only. This is a dependency property. This property affects Day/Work Week views or any custom view which has VisualIntervalScale value less than one day.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool ShowWorkTimeOnly { get; set; }
Visual Basic
Public Property ShowWorkTimeOnly As Boolean
    Get
    Set

See Also

C1Scheduler Class


SmallStartTimeChange Property

[image]

.NET Framework Class Library
C1Scheduler..::..SmallStartTimeChange Property
C1Scheduler Class See Also
Gets or sets a TimeSpan used to change the VisualStartTime property by the IncrementStartTimeSmall()()()() and DecrementStartTimeSmall()()()() methods and the IncrementStartTimeSmallCommand and DecrementStartTimeSmallCommand commands. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public TimeSpan SmallStartTimeChange { get; set; }
Visual Basic
<BrowsableAttribute(False)> _
Public Property SmallStartTimeChange As TimeSpan
    Get
    Set

See Also

C1Scheduler Class


Start Property

[image]

.NET Framework Class Library
C1Scheduler..::..Start Property
C1Scheduler Class See Also
Gets or sets a DateTime that defines a beginning of an overall period of time that can be represented by the control. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[TypeConverterAttribute(typeof(DateTimeTypeConverter))]
public DateTime Start { get; set; }
Visual Basic
<TypeConverterAttribute(GetType(DateTimeTypeConverter))> _
Public Property Start As DateTime
    Get
    Set

See Also

C1Scheduler Class


StatusComparison Property

[image]

.NET Framework Class Library
C1Scheduler..::..StatusComparison Property
C1Scheduler Class See Also
Gets or sets the Comparison<(Of <(<'T>)>)> delegate which is used by the C1Scheduler control to compare availability statuses.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public Comparison<Status> StatusComparison { get; set; }
Visual Basic
<BrowsableAttribute(False)> _
Public Property StatusComparison As Comparison(Of Status)
    Get
    Set

Remarks

This comparision is used to determine StatusBrush and TotalStatusBrush property values.

See Also

C1Scheduler Class


Theme Property

[image]

.NET Framework Class Library
C1Scheduler..::..Theme Property
C1Scheduler Class See Also
Gets or sets a ResourceDictionary object containing Scheduler theme resources.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ResourceDictionary Theme { get; set; }
Visual Basic
Public Property Theme As ResourceDictionary
    Get
    Set

See Also

C1Scheduler Class


TimeFormat Property

[image]

.NET Framework Class Library
C1Scheduler..::..TimeFormat Property
C1Scheduler Class See Also
Gets or sets the String value determining time format used to display time ruler in a Day, Week and Work Week views. The default value is an empty string. In such case C1Scheduler takes default time format from the current culture. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute("")]
public string TimeFormat { get; set; }
Visual Basic
<DefaultValueAttribute("")> _
Public Property TimeFormat As String
    Get
    Set

Remarks

Don't use general formats as "T" for this property. Use detailed format string such as "h:mm tt" or "HH:mm".

See Also

C1Scheduler Class


TimeLineStyle Property

[image]

.NET Framework Class Library
C1Scheduler..::..TimeLineStyle Property
C1Scheduler Class See Also
Gets or sets a Style object that defines a UI representation of the C1Scheduler control in a Time Line mode. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Style TimeLineStyle { get; set; }
Visual Basic
Public Property TimeLineStyle As Style
    Get
    Set

See Also

C1Scheduler Class


TodayBackground Property

[image]

.NET Framework Class Library
C1Scheduler..::..TodayBackground Property
C1Scheduler Class See Also
Gets or sets a Brush object used to color current day. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Brush TodayBackground { get; set; }
Visual Basic
Public Property TodayBackground As Brush
    Get
    Set

See Also

C1Scheduler Class


TotalGroupItem Property

[image]

.NET Framework Class Library
C1Scheduler..::..TotalGroupItem Property
C1Scheduler Class See Also
Gets the SchedulerGroupItem object representing the group item which has no owner, but contains appointments of all visible group items.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public SchedulerGroupItem TotalGroupItem { get; }
Visual Basic
<BrowsableAttribute(False)> _
Public ReadOnly Property TotalGroupItem As SchedulerGroupItem
    Get

Remarks

It is a special group item, it is not included into GroupItems and VisibleGroupItems collections. The C1Scheduler control uses this group to display availability status line in the default TimeLineStyle (see source xaml for the sample of using).

See Also

C1Scheduler Class


ViewStyleSelector Property

[image]

.NET Framework Class Library
C1Scheduler..::..ViewStyleSelector Property
C1Scheduler Class See Also
Enables you to provide custom style-selection logic for a style that should be applied to the C1Scheduler control. The default value is a null reference. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public C1StyleSelector ViewStyleSelector { get; set; }
Visual Basic
<BrowsableAttribute(False)> _
Public Property ViewStyleSelector As C1StyleSelector
    Get
    Set

Remarks

The C1Scheduler control has 4 styles:
  • One Day View (defined by the OneDayStyle property);
  • Working Week View (defined by the WorkingWeekStyle property);
  • Week View (defined by the WeekStyle property);
  • Month View (defined by the MonthStyle property).
By default, the C1Scheduler control changes it's style automatically according to changes in the list of visible dates or on ChangeStyleCommand command. You can alter this behavior by providing the custom StyleSelector or by handling BeforeViewChange event.

See Also

C1Scheduler Class


VisibleDates Property

[image]

.NET Framework Class Library
C1Scheduler..::..VisibleDates Property
C1Scheduler Class See Also
Gets the list of currently visible dates. Changing this list might affect the next properties:
  • VisualStartTime
  • VisualTimeSpan
  • VisualEndTime
  • Style

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public DateList VisibleDates { get; }
Visual Basic
<BrowsableAttribute(False)> _
Public ReadOnly Property VisibleDates As DateList
    Get

See Also

C1Scheduler Class


VisibleGroupItems Property

[image]

.NET Framework Class Library
C1Scheduler..::..VisibleGroupItems Property
C1Scheduler Class See Also
Gets a collection of currently visible SchedulerGroupItem objects. This collection can be used in xaml in the C1Scheduler control templates.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public SchedulerGroupItemCollection VisibleGroupItems { get; }
Visual Basic
<BrowsableAttribute(False)> _
Public ReadOnly Property VisibleGroupItems As SchedulerGroupItemCollection
    Get

See Also

C1Scheduler Class


VisualEndTime Property

[image]

.NET Framework Class Library
C1Scheduler..::..VisualEndTime Property
C1Scheduler Class See Also
Gets an end of a period of time that is currently represented in the control UI. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public DateTime VisualEndTime { get; }
Visual Basic
<BrowsableAttribute(False)> _
Public ReadOnly Property VisualEndTime As DateTime
    Get

Remarks

This property value is calculated as a sum of the VisualStartTime and VisualTimeSpan property values.

See Also

C1Scheduler Class


VisualIntervalGroupDescriptions Property

[image]

.NET Framework Class Library
C1Scheduler..::..VisualIntervalGroupDescriptions Property
C1Scheduler Class See Also
Gets or sets a collection of VisualIntervalGroupDescription objects that defines a grouping criteria applied to the items of the VisualIntervals collection. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public IntervalGroupDescriptionCollection VisualIntervalGroupDescriptions { get; set; }
Visual Basic
<BrowsableAttribute(False)> _
Public Property VisualIntervalGroupDescriptions As IntervalGroupDescriptionCollection
    Get
    Set

Remarks

This property is usually used for the purpose of control UI creation in XAML. The defined grouping criteria is applied to the VisualIntervals collection items and is reflected in the VisualIntervalsView view, which exposes grouped items via the Groups property.

This property is used in a conjunction with the VisualIntervalGroupStyles property that defines UI for each group level.

See Also

C1Scheduler Class


VisualIntervalGroups Property

[image]

.NET Framework Class Library
C1Scheduler..::..VisualIntervalGroups Property
C1Scheduler Class See Also
The C1Scheduler control doesn't use this property any more. This property has been moved to the SchedulerGroupItem class. The VisualIntervalGroups property still exists for the backward compatibility. It returns the VisualIntervalGroups of the default SchedulerGroupItem group. If existing application doesn't require grouping functionality and has custom templates for the C1Scheduler control, all templates will continue working after upgrading to the new version.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
[ObsoleteAttribute("Use corresponding property of the SchedulerGroupItem class.")]
public VisualIntervalCollection VisualIntervalGroups { get; }
Visual Basic
<BrowsableAttribute(False)> _
<ObsoleteAttribute("Use corresponding property of the SchedulerGroupItem class.")> _
Public ReadOnly Property VisualIntervalGroups As VisualIntervalCollection
    Get

See Also

C1Scheduler Class


VisualIntervalGroupStyles Property

[image]

.NET Framework Class Library
C1Scheduler..::..VisualIntervalGroupStyles Property
C1Scheduler Class See Also
Gets or sets a collection of GroupStyle objects that characterize UI for each group level defined in the VisualIntervalGroupDescriptions collection. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public IntervalGroupStyleCollection VisualIntervalGroupStyles { get; set; }
Visual Basic
<BrowsableAttribute(False)> _
Public Property VisualIntervalGroupStyles As IntervalGroupStyleCollection
    Get
    Set

Remarks

A DataContext for GroupStyle.HeaderTemplate template of each GroupStyle item of this collection is a VisualIntervalGroup object, which represents a time range which is a union of time ranges of group's child VisualIntervals.

See Also

C1Scheduler Class


VisualIntervalPanel Property

[image]

.NET Framework Class Library
C1Scheduler..::..VisualIntervalPanel Property
C1Scheduler Class See Also
Gets or sets a DataTemplate that defines the panel that lays out elements representing VisualInterval objects from the VisualIntervals collection. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public DataTemplate VisualIntervalPanel { get; set; }
Visual Basic
<BrowsableAttribute(False)> _
Public Property VisualIntervalPanel As DataTemplate
    Get
    Set

See Also

C1Scheduler Class


VisualIntervals Property

[image]

.NET Framework Class Library
C1Scheduler..::..VisualIntervals Property
C1Scheduler Class See Also
The C1Scheduler control doesn't use this property any more. This property has been moved to the SchedulerGroupItem class. The VisualIntervals property still exists for the backward compatibility. It returns the VisualIntervals of the default SchedulerGroupItem group. If existing application doesn't require grouping functionality and has custom templates for the C1Scheduler control, all templates will continue working after upgrading to the new version.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[ObsoleteAttribute("Use corresponding property of the SchedulerGroupItem class.")]
[BrowsableAttribute(false)]
public VisualIntervalCollection VisualIntervals { get; }
Visual Basic
<ObsoleteAttribute("Use corresponding property of the SchedulerGroupItem class.")> _
<BrowsableAttribute(False)> _
Public ReadOnly Property VisualIntervals As VisualIntervalCollection
    Get

See Also

C1Scheduler Class


VisualIntervalScale Property

[image]

.NET Framework Class Library
C1Scheduler..::..VisualIntervalScale Property
C1Scheduler Class See Also
Gets or sets a TimeSpan of each VisualInterval in the VisualIntervals collection. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public TimeSpan VisualIntervalScale { get; set; }
Visual Basic
<BrowsableAttribute(False)> _
Public Property VisualIntervalScale As TimeSpan
    Get
    Set

Remarks

See the VisualIntervals property description for details.

See Also

C1Scheduler Class


VisualIntervalsView Property

[image]

.NET Framework Class Library
C1Scheduler..::..VisualIntervalsView Property
C1Scheduler Class See Also
The C1Scheduler control doesn't use this property any more. This property has been moved to the SchedulerGroupItem class. The VisualIntervalsView property still exists for the backward compatibility. It returns the VisualIntervalsView of the default SchedulerGroupItem group. If existing application doesn't require grouping functionality and has custom templates for the C1Scheduler control, all templates will continue working after upgrading to the new version.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
[ObsoleteAttribute("Use corresponding property of the SchedulerGroupItem class.")]
public PagedCollectionView VisualIntervalsView { get; }
Visual Basic
<BrowsableAttribute(False)> _
<ObsoleteAttribute("Use corresponding property of the SchedulerGroupItem class.")> _
Public ReadOnly Property VisualIntervalsView As PagedCollectionView
    Get

See Also

C1Scheduler Class


VisualIntervalTemplate Property

[image]

.NET Framework Class Library
C1Scheduler..::..VisualIntervalTemplate Property
C1Scheduler Class See Also
Gets or sets a DataTemplate that defines a UI representation of VisualInterval objects from the VisualIntervals collection. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public DataTemplate VisualIntervalTemplate { get; set; }
Visual Basic
<BrowsableAttribute(False)> _
Public Property VisualIntervalTemplate As DataTemplate
    Get
    Set

Remarks

A DataContext for this template is a VisualInterval object from the VisualIntervals collection.

See Also

C1Scheduler Class


VisualStartTime Property

[image]

.NET Framework Class Library
C1Scheduler..::..VisualStartTime Property
C1Scheduler Class See Also
Gets or sets a start of a period of time that is currently represented in the control UI. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public DateTime VisualStartTime { get; set; }
Visual Basic
<BrowsableAttribute(False)> _
Public Property VisualStartTime As DateTime
    Get
    Set

Remarks

Usually this property value should not be set directly; it gets its value automatically based on the VisualTimeSpan and SelectedDateTime properties (the latter one has DateTime.Today as default) so as to be aligned at the beginning of a current week or current month's first week. Setting it to a value that is not correctly aligned relative to the current control UI (for example, if it is not set to the first day of the week for the Month view) can cause an inadequate UI look.

To change a current period of time safely you can use the SelectedDateTime property or the SetRelativeStartTime(Double) method or the SetRelativeStartTimeCommand command.

See Also

C1Scheduler Class


VisualTimeSpan Property

[image]

.NET Framework Class Library
C1Scheduler..::..VisualTimeSpan Property
C1Scheduler Class See Also
Gets or sets a length of a period of time that is currently represented in the control UI. The start of the period is defined by the VisualStartTime property. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public TimeSpan VisualTimeSpan { get; set; }
Visual Basic
<BrowsableAttribute(False)> _
Public Property VisualTimeSpan As TimeSpan
    Get
    Set

See Also

C1Scheduler Class


WeekStyle Property

[image]

.NET Framework Class Library
C1Scheduler..::..WeekStyle Property
C1Scheduler Class See Also
Gets or sets a Style object that defines a UI representation of C1Scheduler control in a Week View mode. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Style WeekStyle { get; set; }
Visual Basic
Public Property WeekStyle As Style
    Get
    Set

See Also

C1Scheduler Class


WeekViewDayHeaderFormat Property

[image]

.NET Framework Class Library
C1Scheduler..::..WeekViewDayHeaderFormat Property
C1Scheduler Class See Also
Gets or sets the String value determining the format string used to display the day header in a Week view. The default value is 'D'. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute("D")]
public string WeekViewDayHeaderFormat { get; set; }
Visual Basic
<DefaultValueAttribute("D")> _
Public Property WeekViewDayHeaderFormat As String
    Get
    Set

See Also

C1Scheduler Class


WorkingWeekStyle Property

[image]

.NET Framework Class Library
C1Scheduler..::..WorkingWeekStyle Property
C1Scheduler Class See Also
Gets or sets a Style object that defines a UI representation of C1Scheduler control in a Work Week View mode. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Style WorkingWeekStyle { get; set; }
Visual Basic
Public Property WorkingWeekStyle As Style
    Get
    Set

See Also

C1Scheduler Class


C1Scheduler Events

[image] [image]

.NET Framework Class Library
C1Scheduler Events
C1Scheduler Class See Also

The C1Scheduler type exposes the following members.

Events

Name | Description
Public event AppointmentAdded
Occurs when an Appointment object is added.
Public event AppointmentChanged
Occurs when an Appointment object is changed.
Public event AppointmentCustomAction
Occurs immediately before a custom action of an Appointment object executes.
Public event AppointmentDeleted
Occurs when an Appointment object is deleted.
Public event AppointmentRecurrenceStateChanged
Occurs when the RecurrenceState property of an Appointment object is changed.
Public event BeforeAppointmentDrop
Occurs before an Appointment object is dropped by end-user.
Public event BeforeAppointmentResize
Occurs before an Appointment object is resized by end-user.
Public event BeforeAppointmentSave
Occurs before an Appointment is saved by end-user.
Public event BeforeViewChange
Occurs immediately before the next actions:
  • When range of visible dates is changed by the associated calendar control.
  • When range of visible dates and(or) view type is changed by the C1Scheduler commands.
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event DataSourceItemSynchronized
Occurs when changes made to one of the DataStorage collections (for example, to Appointments) has been fully reflected in the storage underlying data source.
Public event EndChanged
Occurs when the End property value has been changed.
Public event GotFocus
Occurs when this element gets logical focus.
(Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event KeyDown
Occurs when a key is pressed while focus is on this element.
(Inherited from UIElement.)
Public event KeyUp
Occurs when a key is released while focus is on this element.
(Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event Loaded
Occurs when the element is laid out, rendered, and ready for interaction.
(Inherited from FrameworkElement.)
Public event LostFocus
Occurs when this element loses logical focus.
(Inherited from UIElement.)
Public event LostMouseCapture
Occurs when this element loses mouse capture.
(Inherited from UIElement.)
Public event MouseEnter
Occurs when the mouse pointer enters the bounds of this element.
(Inherited from UIElement.)
Public event MouseLeave
Occurs when the mouse pointer leaves the bounds of this element.
(Inherited from UIElement.)
Public event MouseLeftButtonDown
Occurs when the left mouse button is pressed while the mouse pointer is over this element.
(Inherited from UIElement.)
Public event MouseLeftButtonUp
Occurs when the left mouse button is released while the mouse pointer is over this element.
(Inherited from UIElement.)
Public event MouseMove
Occurs when the mouse pointer moves while over this element.
(Inherited from UIElement.)
Public event ReminderAdded
Occurs after a Reminder object is added.
Public event ReminderChanged
Occurs after a Reminder object is changed.
Public event ReminderFire
Occurs when a reminder set on an appointment fires, before the Reminders dialog will be shown on a screen or activated.
Public event ReminderRemoved
Occurs when a Reminder object is removed.
Public event ReminderSnooze
Occurs when a Reminder object is snoozed.
Public event SelectedAppointmentChanged
Occurs when the SelectedAppointment property value has been changed.
Public event SelectedDateTimeChanged
Occurs when the SelectedDateTime property value has been changed.
Public event SizeChanged
Occurs when either the ActualHeight or the ActualWidth properties change value on this element.
(Inherited from FrameworkElement.)
Public event StartChanged
Occurs when the Start property value has been changed.
Public event StyleChanged
Occurs immediately after the control style has been changed.
Public event UserAddingAppointment
Occurs before the Edit Appointment dialog appears on the screen as a result of:
  • a double-click on the control area in one of the default control views,
  • the NewAppointmentDialog method call,
  • a NewAppointmentDialogCommand command.
Public event UserClosingAppointment
Occurs when user closes Edit Appointment dialog without saving.
Public event UserDeletingAppointment
Occurs before the currently selected Appointment is deleted by a user or as a result of the DeleteAppointment method call or receiving the DeleteAppointmentCommand command.
Public event UserEditingAppointment
Occurs before the Edit Appointment dialog appears on the screen for editing of an existing appointment, as a result of a double-click on the appointment in one of the default control views, the EditAppointmentDialog(Appointment) method call, or when an EditAppointmentDialogCommand command is received.

See Also

C1Scheduler Class


AppointmentAdded Event

[image]

.NET Framework Class Library
C1Scheduler..::..AppointmentAdded Event
C1Scheduler Class See Also
Occurs when an Appointment object is added.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event EventHandler<AppointmentActionEventArgs> AppointmentAdded
Visual Basic
Public Event AppointmentAdded As EventHandler(Of AppointmentActionEventArgs)

See Also

C1Scheduler Class


AppointmentChanged Event

[image]

.NET Framework Class Library
C1Scheduler..::..AppointmentChanged Event
C1Scheduler Class See Also
Occurs when an Appointment object is changed.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event EventHandler<AppointmentActionEventArgs> AppointmentChanged
Visual Basic
Public Event AppointmentChanged As EventHandler(Of AppointmentActionEventArgs)

See Also

C1Scheduler Class


AppointmentCustomAction Event

[image]

.NET Framework Class Library
C1Scheduler..::..AppointmentCustomAction Event
C1Scheduler Class Example See Also
Occurs immediately before a custom action of an Appointment object executes.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event EventHandler<AppointmentActionEventArgs> AppointmentCustomAction
Visual Basic
Public Event AppointmentCustomAction As EventHandler(Of AppointmentActionEventArgs)

Remarks

To cancel default handling, set CancelAppointmentEventArgs.Cancel property to true.

Examples

Copy CodeC#
private void c1Scheduler1_AppointmentAdded(object sender, AppointmentActionEventArgs e)
{
    // create a new action
    Action action = new Action();
    action.Command = "http://www.componentone.com";
    // set appointment action
    e.Appointment.Action = action;
}

See Also

C1Scheduler Class


AppointmentDeleted Event

[image]

.NET Framework Class Library
C1Scheduler..::..AppointmentDeleted Event
C1Scheduler Class See Also
Occurs when an Appointment object is deleted.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event EventHandler<AppointmentActionEventArgs> AppointmentDeleted
Visual Basic
Public Event AppointmentDeleted As EventHandler(Of AppointmentActionEventArgs)

See Also

C1Scheduler Class


AppointmentRecurrenceStateChanged Event

[image]

.NET Framework Class Library
C1Scheduler..::..AppointmentRecurrenceStateChanged Event
C1Scheduler Class See Also
Occurs when the RecurrenceState property of an Appointment object is changed.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event EventHandler<AppointmentActionEventArgs> AppointmentRecurrenceStateChanged
Visual Basic
Public Event AppointmentRecurrenceStateChanged As EventHandler(Of AppointmentActionEventArgs)

See Also

C1Scheduler Class


BeforeAppointmentDrop Event

[image]

.NET Framework Class Library
C1Scheduler..::..BeforeAppointmentDrop Event
C1Scheduler Class See Also
Occurs before an Appointment object is dropped by end-user.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event EventHandler<AppointmentActionEventArgs> BeforeAppointmentDrop
Visual Basic
Public Event BeforeAppointmentDrop As EventHandler(Of AppointmentActionEventArgs)

See Also

C1Scheduler Class


BeforeAppointmentResize Event

[image]

.NET Framework Class Library
C1Scheduler..::..BeforeAppointmentResize Event
C1Scheduler Class See Also
Occurs before an Appointment object is resized by end-user.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event EventHandler<AppointmentActionEventArgs> BeforeAppointmentResize
Visual Basic
Public Event BeforeAppointmentResize As EventHandler(Of AppointmentActionEventArgs)

See Also

C1Scheduler Class


BeforeAppointmentSave Event

[image]

.NET Framework Class Library
C1Scheduler..::..BeforeAppointmentSave Event
C1Scheduler Class See Also
Occurs before an Appointment is saved by end-user.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event EventHandler<AppointmentActionEventArgs> BeforeAppointmentSave
Visual Basic
Public Event BeforeAppointmentSave As EventHandler(Of AppointmentActionEventArgs)

See Also

C1Scheduler Class


BeforeViewChange Event

[image]

.NET Framework Class Library
C1Scheduler..::..BeforeViewChange Event
C1Scheduler Class See Also
Occurs immediately before the next actions:
  • When range of visible dates is changed by the associated calendar control.
  • When range of visible dates and(or) view type is changed by the C1Scheduler commands.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event EventHandler<BeforeViewChangeEventArgs> BeforeViewChange
Visual Basic
Public Event BeforeViewChange As EventHandler(Of BeforeViewChangeEventArgs)

Remarks

Use this event to cancel action, to set other view type or to set other range of dates.

See Also

C1Scheduler Class


DataSourceItemSynchronized Event

[image]

.NET Framework Class Library
C1Scheduler..::..DataSourceItemSynchronized Event
C1Scheduler Class See Also
Occurs when changes made to one of the DataStorage collections (for example, to Appointments) has been fully reflected in the storage underlying data source.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event DataSourceItemSynchronizedEventHandler DataSourceItemSynchronized
Visual Basic
Public Event DataSourceItemSynchronized As DataSourceItemSynchronizedEventHandler

Remarks

If properties of an item of the DataStorage collection are changed between BeginEdit and EndEdit calls performed on the item, this event will not be raised until the EndEdit method will be called.

Use this event if you want to update a back store of your data source only after the changes to a corresponding collection have been fully completed. For example, if you use ADO.NET DataSet as a data source, you can commit the changes made in a DataRow as a result of changes in the collection item to the underlying database.

See Also

C1Scheduler Class


EndChanged Event

[image]

.NET Framework Class Library
C1Scheduler..::..EndChanged Event
C1Scheduler Class See Also
Occurs when the End property value has been changed.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event EventHandler<DateTimePropertyChangeEventArgs> EndChanged
Visual Basic
Public Event EndChanged As EventHandler(Of DateTimePropertyChangeEventArgs)

See Also

C1Scheduler Class


ReminderAdded Event

[image]

.NET Framework Class Library
C1Scheduler..::..ReminderAdded Event
C1Scheduler Class See Also
Occurs after a Reminder object is added.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event EventHandler<ReminderActionEventArgs> ReminderAdded
Visual Basic
Public Event ReminderAdded As EventHandler(Of ReminderActionEventArgs)

See Also

C1Scheduler Class


ReminderChanged Event

[image]

.NET Framework Class Library
C1Scheduler..::..ReminderChanged Event
C1Scheduler Class See Also
Occurs after a Reminder object is changed.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event EventHandler<ReminderActionEventArgs> ReminderChanged
Visual Basic
Public Event ReminderChanged As EventHandler(Of ReminderActionEventArgs)

See Also

C1Scheduler Class


ReminderFire Event

[image]

.NET Framework Class Library
C1Scheduler..::..ReminderFire Event
C1Scheduler Class See Also
Occurs when a reminder set on an appointment fires, before the Reminders dialog will be shown on a screen or activated.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event EventHandler<ReminderActionEventArgs> ReminderFire
Visual Basic
Public Event ReminderFire As EventHandler(Of ReminderActionEventArgs)

Remarks

Use this event to implement your own reaction on this event, instead of activating a standard Reminders window.

To prevent activating a standard window, set the e.Handled event argument to True.

See Also

C1Scheduler Class


ReminderRemoved Event

[image]

.NET Framework Class Library
C1Scheduler..::..ReminderRemoved Event
C1Scheduler Class See Also
Occurs when a Reminder object is removed.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event EventHandler<ReminderActionEventArgs> ReminderRemoved
Visual Basic
Public Event ReminderRemoved As EventHandler(Of ReminderActionEventArgs)

See Also

C1Scheduler Class


ReminderSnooze Event

[image]

.NET Framework Class Library
C1Scheduler..::..ReminderSnooze Event
C1Scheduler Class See Also
Occurs when a Reminder object is snoozed.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event EventHandler<ReminderActionEventArgs> ReminderSnooze
Visual Basic
Public Event ReminderSnooze As EventHandler(Of ReminderActionEventArgs)

See Also

C1Scheduler Class


SelectedAppointmentChanged Event

[image]

.NET Framework Class Library
C1Scheduler..::..SelectedAppointmentChanged Event
C1Scheduler Class See Also
Occurs when the SelectedAppointment property value has been changed.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event EventHandler<PropertyChangeEventArgsBase> SelectedAppointmentChanged
Visual Basic
Public Event SelectedAppointmentChanged As EventHandler(Of PropertyChangeEventArgsBase)

See Also

C1Scheduler Class


SelectedDateTimeChanged Event

[image]

.NET Framework Class Library
C1Scheduler..::..SelectedDateTimeChanged Event
C1Scheduler Class See Also
Occurs when the SelectedDateTime property value has been changed.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event EventHandler<DateTimePropertyChangeEventArgs> SelectedDateTimeChanged
Visual Basic
Public Event SelectedDateTimeChanged As EventHandler(Of DateTimePropertyChangeEventArgs)

See Also

C1Scheduler Class


StartChanged Event

[image]

.NET Framework Class Library
C1Scheduler..::..StartChanged Event
C1Scheduler Class See Also
Occurs when the Start property value has been changed.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event EventHandler<DateTimePropertyChangeEventArgs> StartChanged
Visual Basic
Public Event StartChanged As EventHandler(Of DateTimePropertyChangeEventArgs)

See Also

C1Scheduler Class


StyleChanged Event

[image]

.NET Framework Class Library
C1Scheduler..::..StyleChanged Event
C1Scheduler Class See Also
Occurs immediately after the control style has been changed.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event EventHandler<RoutedEventArgs> StyleChanged
Visual Basic
Public Event StyleChanged As EventHandler(Of RoutedEventArgs)

See Also

C1Scheduler Class


UserAddingAppointment Event

[image]

.NET Framework Class Library
C1Scheduler..::..UserAddingAppointment Event
C1Scheduler Class See Also
Occurs before the Edit Appointment dialog appears on the screen as a result of:
  • a double-click on the control area in one of the default control views,
  • the NewAppointmentDialog method call,
  • a NewAppointmentDialogCommand command.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event EventHandler<AddingAppointmentEventArgs> UserAddingAppointment
Visual Basic
Public Event UserAddingAppointment As EventHandler(Of AddingAppointmentEventArgs)

Remarks

Use this event to make custom settings to a new appointment before it appears on the screen and/or to implement your own reaction on this event, instead of activating a standard dialog window.

In order to change appointment properties before showing the dialog on a screen, use the appointment object referenced by the e.Appointment event argument.

To prevent activating a standard dialog window, set the e.Handled event argument to True.

See Also

C1Scheduler Class


UserClosingAppointment Event

[image]

.NET Framework Class Library
C1Scheduler..::..UserClosingAppointment Event
C1Scheduler Class See Also
Occurs when user closes Edit Appointment dialog without saving.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event EventHandler<AppointmentActionEventArgs> UserClosingAppointment
Visual Basic
Public Event UserClosingAppointment As EventHandler(Of AppointmentActionEventArgs)

Remarks

AppointmentActionEventArgs.Handled property doesn't make sense for this event.

See Also

C1Scheduler Class


UserDeletingAppointment Event

[image]

.NET Framework Class Library
C1Scheduler..::..UserDeletingAppointment Event
C1Scheduler Class See Also
Occurs before the currently selected Appointment is deleted by a user or as a result of the DeleteAppointment method call or receiving the DeleteAppointmentCommand command.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event EventHandler<AppointmentActionEventArgs> UserDeletingAppointment
Visual Basic
Public Event UserDeletingAppointment As EventHandler(Of AppointmentActionEventArgs)

Remarks

Use this event to make custom actions before appointment deletion and/or to implement your own reaction on this event. To prevent a deletion of the appointment, set the e.Handled event argument to True.

See Also

C1Scheduler Class


UserEditingAppointment Event

[image]

.NET Framework Class Library
C1Scheduler..::..UserEditingAppointment Event
C1Scheduler Class See Also
Occurs before the Edit Appointment dialog appears on the screen for editing of an existing appointment, as a result of a double-click on the appointment in one of the default control views, the EditAppointmentDialog(Appointment) method call, or when an EditAppointmentDialogCommand command is received.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event EventHandler<AppointmentActionEventArgs> UserEditingAppointment
Visual Basic
Public Event UserEditingAppointment As EventHandler(Of AppointmentActionEventArgs)

Remarks

Use this event to make custom settings to an editing appointment before it appears on the screen and/or to implement your own reaction on this event, instead of activating a standard dialog window.

In order to change appointment properties before showing the dialog on a screen, use the appointment object referenced by the e.Appointment event argument.

To prevent activating a standard dialog window, set the e.Handled event argument to True.

See Also

C1Scheduler Class


C1SchedulerPresenter Class

[image]

.NET Framework Class Library
C1SchedulerPresenter Class
Members See Also
An instance of this class is used in the C1Scheduler's template visual tree to define a place where a pane representing schedule time intervals will appear.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class C1SchedulerPresenter : VisualIntervalsPresenter,
    ICollectionChangedListener
Visual Basic
Public Class C1SchedulerPresenter _
    Inherits VisualIntervalsPresenter _
    Implements ICollectionChangedListener

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ItemsControl
System.Windows.Controls.Primitives..::..Selector
System.Windows.Controls..::..ListBox
C1.Silverlight.Schedule..::..GroupedListBox
C1.Silverlight.Schedule..::..VisualIntervalsPresenter
C1.Silverlight.Schedule..::..C1SchedulerPresenter

See Also

C1SchedulerPresenter Members


C1SchedulerPresenter Members

[image] [image]

.NET Framework Class Library
C1SchedulerPresenter Members
C1SchedulerPresenter Class Constructors Methods Fields Properties Events See Also

The C1SchedulerPresenter type exposes the following members.

Constructors

 | Name | Description
Public method | C1SchedulerPresenter |

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | AttachSchedulerEvents | Attaches presenter to the C1Scheduler control. (Overrides VisualIntervalsPresenter..::..AttachSchedulerEvents()()()().)
Protected method | AttachToScheduler | Attaches presenter to the C1Scheduler control. (Inherited from VisualIntervalsPresenter.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Protected method | ClearContainerForItemOverride | (Inherited from Selector.)
Protected method | ClearSelection | Clears selection. (Inherited from VisualIntervalsPresenter.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Protected method | DetachEvents | (Inherited from VisualIntervalsPresenter.)
Protected method | DetachFromScheduler | Detaches presenter from the specified C1Scheduler control. (Overrides VisualIntervalsPresenter..::..DetachFromScheduler(C1Scheduler).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Inherited from VisualIntervalsPresenter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetIndexForListBoxItem | Returns the index to an item that corresponds to the specified, generated container element. (Inherited from GroupedListBox.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | HandleItemSelection | (Inherited from VisualIntervalsPresenter.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Protected method | IsAboutToDispose | Override this method in derived classes and return true when control should stop handle selection. (Inherited from VisualIntervalsPresenter.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ListBox.)
Protected method | MakeRangeSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Protected method | MakeSingleSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Protected method | MakeToggleSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | (Inherited from VisualIntervalsPresenter.)
Public method | OnCollectionChanged | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBox.)
Protected method | OnGotFocus | (Inherited from ListBox.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnKeyDown | (Inherited from GroupedListBox.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from ListBox.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | (Inherited from GroupedListBox.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Protected method | SelectItems | Selects all items from time interval determined by the specified start and end values. (Overrides VisualIntervalsPresenter..::..SelectItems(DateTime, DateTime).)
Protected method | SelectRange | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Protected method | SelectSingleItem | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Protected method | SetFocusedItem | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from GroupedListBox.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Protected method | UpdateSelection | Updates selection. (Inherited from VisualIntervalsPresenter.)

Fields

 | Name | Description
Protected field | _anchor | (Inherited from GroupedListBox.)
Protected field | _prevScheduler | (Inherited from VisualIntervalsPresenter.)
Protected field | _selectedItems | (Inherited from GroupedListBox.)
Protected field | _updatingSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from GroupedListBox.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. This is a dependency property. (Inherited from GroupedListBox.)
Public property | HasItems | Gets a value that indicates whether the GroupedListBox contains items. This is a dependency property. (Inherited from GroupedListBox.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. This is a dependency property. (Inherited from GroupedListBox.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from GroupedListBox.)
Public property | ItemContainerStyle | (Inherited from ListBox.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. This is a dependency property. (Inherited from GroupedListBox.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. This is a dependency property. (Inherited from GroupedListBox.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Owner | Gets the BaseObject object representing the SchedulerGroupItem object owner. This property can be null for an empty group item. (Inherited from VisualIntervalsPresenter.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | PanelTemplate | Gets or sets the DataTemplate that defines the panel that controls the layout of items. This is a dependency property. (Inherited from GroupedListBox.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Scheduler | References a C1Scheduler control that owns the VisualIntervalsPresenter. (Inherited from VisualIntervalsPresenter.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty This is a dependency property. (Inherited from Selector.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

C1SchedulerPresenter Class


C1SchedulerPresenter Constructor

[image]

.NET Framework Class Library
C1SchedulerPresenter Constructor
C1SchedulerPresenter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1SchedulerPresenter()
Visual Basic
Public Sub New

See Also

C1SchedulerPresenter Class


C1SchedulerPresenter Fields

[image] [image]

.NET Framework Class Library
C1SchedulerPresenter Fields
C1SchedulerPresenter Class See Also

The C1SchedulerPresenter type exposes the following members.

Fields

 | Name | Description
Protected field | _anchor | (Inherited from GroupedListBox.)
Protected field | _prevScheduler | (Inherited from VisualIntervalsPresenter.)
Protected field | _selectedItems | (Inherited from GroupedListBox.)
Protected field | _updatingSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)

See Also

C1SchedulerPresenter Class


C1SchedulerPresenter Methods

[image] [image]

.NET Framework Class Library
C1SchedulerPresenter Methods
C1SchedulerPresenter Class See Also

The C1SchedulerPresenter type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | AttachSchedulerEvents | Attaches presenter to the C1Scheduler control. (Overrides VisualIntervalsPresenter..::..AttachSchedulerEvents()()()().)
Protected method | AttachToScheduler | Attaches presenter to the C1Scheduler control. (Inherited from VisualIntervalsPresenter.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Protected method | ClearContainerForItemOverride | (Inherited from Selector.)
Protected method | ClearSelection | Clears selection. (Inherited from VisualIntervalsPresenter.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Protected method | DetachEvents | (Inherited from VisualIntervalsPresenter.)
Protected method | DetachFromScheduler | Detaches presenter from the specified C1Scheduler control. (Overrides VisualIntervalsPresenter..::..DetachFromScheduler(C1Scheduler).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Inherited from VisualIntervalsPresenter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetIndexForListBoxItem | Returns the index to an item that corresponds to the specified, generated container element. (Inherited from GroupedListBox.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | HandleItemSelection | (Inherited from VisualIntervalsPresenter.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Protected method | IsAboutToDispose | Override this method in derived classes and return true when control should stop handle selection. (Inherited from VisualIntervalsPresenter.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ListBox.)
Protected method | MakeRangeSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Protected method | MakeSingleSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Protected method | MakeToggleSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | (Inherited from VisualIntervalsPresenter.)
Public method | OnCollectionChanged | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBox.)
Protected method | OnGotFocus | (Inherited from ListBox.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnKeyDown | (Inherited from GroupedListBox.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from ListBox.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | (Inherited from GroupedListBox.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Protected method | SelectItems | Selects all items from time interval determined by the specified start and end values. (Overrides VisualIntervalsPresenter..::..SelectItems(DateTime, DateTime).)
Protected method | SelectRange | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Protected method | SelectSingleItem | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Protected method | SetFocusedItem | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from GroupedListBox.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Protected method | UpdateSelection | Updates selection. (Inherited from VisualIntervalsPresenter.)

See Also

C1SchedulerPresenter Class


AttachSchedulerEvents Method

[image]

.NET Framework Class Library
C1SchedulerPresenter..::..AttachSchedulerEvents Method
C1SchedulerPresenter Class See Also
Attaches presenter to the C1Scheduler control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void AttachSchedulerEvents()
Visual Basic
Protected Overrides Sub AttachSchedulerEvents

See Also

C1SchedulerPresenter Class


DetachFromScheduler Method

[image]

.NET Framework Class Library
C1SchedulerPresenter..::..DetachFromScheduler Method
C1SchedulerPresenter Class See Also
Detaches presenter from the specified C1Scheduler control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void DetachFromScheduler(
    C1Scheduler scheduler
)
Visual Basic
Protected Overrides Sub DetachFromScheduler ( _
    scheduler As C1Scheduler _
)

Parameters

scheduler
Type: C1.Silverlight.Schedule..::..C1Scheduler

See Also

C1SchedulerPresenter Class


SelectItems Method

[image]

.NET Framework Class Library
C1SchedulerPresenter..::..SelectItems Method
C1SchedulerPresenter Class See Also
Selects all items from time interval determined by the specified start and end values.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void SelectItems(
    DateTime start,
    DateTime end
)
Visual Basic
Protected Overrides Sub SelectItems ( _
    start As DateTime, _
    end As DateTime _
)

Parameters

start
Type: System..::..DateTime
end
Type: System..::..DateTime

See Also

C1SchedulerPresenter Class


C1SchedulerPresenter Properties

[image] [image]

.NET Framework Class Library
C1SchedulerPresenter Properties
C1SchedulerPresenter Class See Also

The C1SchedulerPresenter type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from GroupedListBox.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. This is a dependency property. (Inherited from GroupedListBox.)
Public property | HasItems | Gets a value that indicates whether the GroupedListBox contains items. This is a dependency property. (Inherited from GroupedListBox.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. This is a dependency property. (Inherited from GroupedListBox.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from GroupedListBox.)
Public property | ItemContainerStyle | (Inherited from ListBox.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. This is a dependency property. (Inherited from GroupedListBox.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. This is a dependency property. (Inherited from GroupedListBox.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Owner | Gets the BaseObject object representing the SchedulerGroupItem object owner. This property can be null for an empty group item. (Inherited from VisualIntervalsPresenter.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | PanelTemplate | Gets or sets the DataTemplate that defines the panel that controls the layout of items. This is a dependency property. (Inherited from GroupedListBox.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Scheduler | References a C1Scheduler control that owns the VisualIntervalsPresenter. (Inherited from VisualIntervalsPresenter.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty This is a dependency property. (Inherited from Selector.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

C1SchedulerPresenter Class


C1SchedulerPresenter Events

[image] [image]

.NET Framework Class Library
C1SchedulerPresenter Events
C1SchedulerPresenter Class See Also

The C1SchedulerPresenter type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

C1SchedulerPresenter Class


C1SchedulerResources Class

[image]

.NET Framework Class Library
C1SchedulerResources Class
Members See Also
The C1SchedulerResources keeps the set of resources used by the C1Scheduler control. Static fields of this class return default C1Scheduler's themes.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class C1SchedulerResources : ThemeResources
Visual Basic
Public Class C1SchedulerResources _
    Inherits ThemeResources

Remarks

Resource lookup behavior:
  • If Theme property is set to something other than default Office 2007 Blue theme, the lookup process checks for the requested key within the resource dictionary defined by the current control theme
  • The lookup process checks resources in a usual way (in page, window or application resources)
  • The lookup process checks resources in default theme dictionary.

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..ThemeResources
C1.Silverlight.Schedule..::..C1SchedulerResources

See Also

C1SchedulerResources Members


C1SchedulerResources Members

[image] [image]

.NET Framework Class Library
C1SchedulerResources Members
C1SchedulerResources Class Constructors Methods Properties See Also

The C1SchedulerResources type exposes the following members.

Constructors

 | Name | Description
Public method | C1SchedulerResources | Initializes the new instance of the C1SchedulerResources class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshResources | Refreshes resources according to the currently selected theme. (Overrides ThemeResources..::..RefreshResources()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EditAppointmentTemplate | Gets the DataTemplate object used in Edit(New) Appointment dialogs.
Public property | EditRecurrenceTemplate | Gets the DataTemplate object used in Edit Recurrence dialog.
Public property | GroupHeaderTemplate | Gets the DataTemplate object used for displaying SchedulerGroupItem header.
Public property | IntervalAppointmentTemplate | Gets the DataTemplate object used for displaying Appointment objects.
Public property | MonthStyle | Gets the Style object describing Month view of C1Scheduler control.
Public property | OneDayStyle | Gets the Style object describing One Day view of C1Scheduler control.
Public property | SelectFromListTemplate | Gets the DataTemplate object used for displaying Resources, Contacts and Categories dialogs.
Public property | ShowRemindersTemplate | Gets the DataTemplate object used in Show Reminders window.
Public property | Theme | Gets or sets the ResourceDictionary object used as the theme for the C1Scheduler control. (Overrides ThemeResources..::..Theme.)
Public property | TimeLineStyle | Gets the Style object describing Time Line view of C1Scheduler control.
Public property | WeekStyle | Gets the Style object describing Week view of C1Scheduler control.
Public property | WorkingWeekStyle | Gets the Style object describing Working Week view of C1Scheduler control.

See Also

C1SchedulerResources Class


C1SchedulerResources Constructor

[image]

.NET Framework Class Library
C1SchedulerResources Constructor
C1SchedulerResources Class See Also
Initializes the new instance of the C1SchedulerResources class.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1SchedulerResources()
Visual Basic
Public Sub New

See Also

C1SchedulerResources Class


C1SchedulerResources Methods

[image] [image]

.NET Framework Class Library
C1SchedulerResources Methods
C1SchedulerResources Class See Also

The C1SchedulerResources type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshResources | Refreshes resources according to the currently selected theme. (Overrides ThemeResources..::..RefreshResources()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1SchedulerResources Class


RefreshResources Method

[image]

.NET Framework Class Library
C1SchedulerResources..::..RefreshResources Method
C1SchedulerResources Class See Also
Refreshes resources according to the currently selected theme.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override void RefreshResources()
Visual Basic
Public Overrides Sub RefreshResources

See Also

C1SchedulerResources Class


C1SchedulerResources Properties

[image] [image]

.NET Framework Class Library
C1SchedulerResources Properties
C1SchedulerResources Class See Also

The C1SchedulerResources type exposes the following members.

Properties

 | Name | Description
Public property | EditAppointmentTemplate | Gets the DataTemplate object used in Edit(New) Appointment dialogs.
Public property | EditRecurrenceTemplate | Gets the DataTemplate object used in Edit Recurrence dialog.
Public property | GroupHeaderTemplate | Gets the DataTemplate object used for displaying SchedulerGroupItem header.
Public property | IntervalAppointmentTemplate | Gets the DataTemplate object used for displaying Appointment objects.
Public property | MonthStyle | Gets the Style object describing Month view of C1Scheduler control.
Public property | OneDayStyle | Gets the Style object describing One Day view of C1Scheduler control.
Public property | SelectFromListTemplate | Gets the DataTemplate object used for displaying Resources, Contacts and Categories dialogs.
Public property | ShowRemindersTemplate | Gets the DataTemplate object used in Show Reminders window.
Public property | Theme | Gets or sets the ResourceDictionary object used as the theme for the C1Scheduler control. (Overrides ThemeResources..::..Theme.)
Public property | TimeLineStyle | Gets the Style object describing Time Line view of C1Scheduler control.
Public property | WeekStyle | Gets the Style object describing Week view of C1Scheduler control.
Public property | WorkingWeekStyle | Gets the Style object describing Working Week view of C1Scheduler control.

See Also

C1SchedulerResources Class


EditAppointmentTemplate Property

[image]

.NET Framework Class Library
C1SchedulerResources..::..EditAppointmentTemplate Property
C1SchedulerResources Class See Also
Gets the DataTemplate object used in Edit(New) Appointment dialogs.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DataTemplate EditAppointmentTemplate { get; }
Visual Basic
Public ReadOnly Property EditAppointmentTemplate As DataTemplate
    Get

See Also

C1SchedulerResources Class


EditRecurrenceTemplate Property

[image]

.NET Framework Class Library
C1SchedulerResources..::..EditRecurrenceTemplate Property
C1SchedulerResources Class See Also
Gets the DataTemplate object used in Edit Recurrence dialog.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DataTemplate EditRecurrenceTemplate { get; }
Visual Basic
Public ReadOnly Property EditRecurrenceTemplate As DataTemplate
    Get

See Also

C1SchedulerResources Class


GroupHeaderTemplate Property

[image]

.NET Framework Class Library
C1SchedulerResources..::..GroupHeaderTemplate Property
C1SchedulerResources Class See Also
Gets the DataTemplate object used for displaying SchedulerGroupItem header.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DataTemplate GroupHeaderTemplate { get; }
Visual Basic
Public ReadOnly Property GroupHeaderTemplate As DataTemplate
    Get

See Also

C1SchedulerResources Class


IntervalAppointmentTemplate Property

[image]

.NET Framework Class Library
C1SchedulerResources..::..IntervalAppointmentTemplate Property
C1SchedulerResources Class See Also
Gets the DataTemplate object used for displaying Appointment objects.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DataTemplate IntervalAppointmentTemplate { get; }
Visual Basic
Public ReadOnly Property IntervalAppointmentTemplate As DataTemplate
    Get

See Also

C1SchedulerResources Class


MonthStyle Property

[image]

.NET Framework Class Library
C1SchedulerResources..::..MonthStyle Property
C1SchedulerResources Class See Also
Gets the Style object describing Month view of C1Scheduler control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Style MonthStyle { get; }
Visual Basic
Public ReadOnly Property MonthStyle As Style
    Get

See Also

C1SchedulerResources Class


OneDayStyle Property

[image]

.NET Framework Class Library
C1SchedulerResources..::..OneDayStyle Property
C1SchedulerResources Class See Also
Gets the Style object describing One Day view of C1Scheduler control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Style OneDayStyle { get; }
Visual Basic
Public ReadOnly Property OneDayStyle As Style
    Get

See Also

C1SchedulerResources Class


SelectFromListTemplate Property

[image]

.NET Framework Class Library
C1SchedulerResources..::..SelectFromListTemplate Property
C1SchedulerResources Class See Also
Gets the DataTemplate object used for displaying Resources, Contacts and Categories dialogs.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DataTemplate SelectFromListTemplate { get; }
Visual Basic
Public ReadOnly Property SelectFromListTemplate As DataTemplate
    Get

See Also

C1SchedulerResources Class


ShowRemindersTemplate Property

[image]

.NET Framework Class Library
C1SchedulerResources..::..ShowRemindersTemplate Property
C1SchedulerResources Class See Also
Gets the DataTemplate object used in Show Reminders window.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DataTemplate ShowRemindersTemplate { get; }
Visual Basic
Public ReadOnly Property ShowRemindersTemplate As DataTemplate
    Get

See Also

C1SchedulerResources Class


Theme Property

[image]

.NET Framework Class Library
C1SchedulerResources..::..Theme Property
C1SchedulerResources Class See Also
Gets or sets the ResourceDictionary object used as the theme for the C1Scheduler control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override ResourceDictionary Theme { get; set; }
Visual Basic
Public Overrides Property Theme As ResourceDictionary
    Get
    Set

See Also

C1SchedulerResources Class


TimeLineStyle Property

[image]

.NET Framework Class Library
C1SchedulerResources..::..TimeLineStyle Property
C1SchedulerResources Class See Also
Gets the Style object describing Time Line view of C1Scheduler control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Style TimeLineStyle { get; }
Visual Basic
Public ReadOnly Property TimeLineStyle As Style
    Get

See Also

C1SchedulerResources Class


WeekStyle Property

[image]

.NET Framework Class Library
C1SchedulerResources..::..WeekStyle Property
C1SchedulerResources Class See Also
Gets the Style object describing Week view of C1Scheduler control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Style WeekStyle { get; }
Visual Basic
Public ReadOnly Property WeekStyle As Style
    Get

See Also

C1SchedulerResources Class


WorkingWeekStyle Property

[image]

.NET Framework Class Library
C1SchedulerResources..::..WorkingWeekStyle Property
C1SchedulerResources Class See Also
Gets the Style object describing Working Week view of C1Scheduler control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Style WorkingWeekStyle { get; }
Visual Basic
Public ReadOnly Property WorkingWeekStyle As Style
    Get

See Also

C1SchedulerResources Class


C1SchedulerSettings Class

[image]

.NET Framework Class Library
C1SchedulerSettings Class
Members See Also
Determines auxiliary properties providing different C1Scheduler object settings.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class C1SchedulerSettings : DependencyObject
Visual Basic
Public Class C1SchedulerSettings _
    Inherits DependencyObject

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
C1.Silverlight.Schedule..::..C1SchedulerSettings

See Also

C1SchedulerSettings Members


C1SchedulerSettings Members

[image] [image]

.NET Framework Class Library
C1SchedulerSettings Members
C1SchedulerSettings Class Constructors Methods Properties See Also

The C1SchedulerSettings type exposes the following members.

Constructors

 | Name | Description
Public method | C1SchedulerSettings | Initializes a new instance of the C1SchedulerSettings class.

Methods

 | Name | Description
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowCategoriesEditing | Determines whether end-user has permission to edit Categories.
Public property | AllowCategoriesMultiSelection | Determines whether multiple Category objects might be assigned to the single Appointment object.
Public property | AllowContactsEditing | Determines whether end-user has permission to edit Contacts.
Public property | AllowContactsMultiSelection | Determines whether multiple Contact objects might be assigned to the single Appointment object.
Public property | AllowResourcesEditing | Determines whether end-user has permission to edit Resources.
Public property | AllowResourcesMultiSelection | Determines whether multiple Resource objects might be assigned to the single Appointment object.
Public property | AutoScrollToFirstAppointment | Gets or sets the Boolean value determining whether control scrolls itself to the earliest appointment in the current view. This property affects Day/Work Week views or any custom view which has VisualIntervalScale value less than one day.
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FirstVisibleTime | Gets or sets the TimeSpan value representing the first visible time slot in a Day/Work Week views or in any custom view which has a VisualIntervalScale value of less than one day.
Public property | ReminderTimeBeforeStart | Gets or sets the default TimeSpan value which should be used as initial value for the ReminderTimeBeforeStart property. The default value is 15 minutes.
Public property | SetReminder | Gets or sets whether reminder should be set for the newly created appointments. The default value is true.

See Also

C1SchedulerSettings Class


C1SchedulerSettings Constructor

[image]

.NET Framework Class Library
C1SchedulerSettings Constructor
C1SchedulerSettings Class See Also
Initializes a new instance of the C1SchedulerSettings class.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1SchedulerSettings()
Visual Basic
Public Sub New

See Also

C1SchedulerSettings Class


C1SchedulerSettings Methods

[image] [image]

.NET Framework Class Library
C1SchedulerSettings Methods
C1SchedulerSettings Class See Also

The C1SchedulerSettings type exposes the following members.

Methods

 | Name | Description
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1SchedulerSettings Class


C1SchedulerSettings Properties

[image] [image]

.NET Framework Class Library
C1SchedulerSettings Properties
C1SchedulerSettings Class See Also

The C1SchedulerSettings type exposes the following members.

Properties

 | Name | Description
Public property | AllowCategoriesEditing | Determines whether end-user has permission to edit Categories.
Public property | AllowCategoriesMultiSelection | Determines whether multiple Category objects might be assigned to the single Appointment object.
Public property | AllowContactsEditing | Determines whether end-user has permission to edit Contacts.
Public property | AllowContactsMultiSelection | Determines whether multiple Contact objects might be assigned to the single Appointment object.
Public property | AllowResourcesEditing | Determines whether end-user has permission to edit Resources.
Public property | AllowResourcesMultiSelection | Determines whether multiple Resource objects might be assigned to the single Appointment object.
Public property | AutoScrollToFirstAppointment | Gets or sets the Boolean value determining whether control scrolls itself to the earliest appointment in the current view. This property affects Day/Work Week views or any custom view which has VisualIntervalScale value less than one day.
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FirstVisibleTime | Gets or sets the TimeSpan value representing the first visible time slot in a Day/Work Week views or in any custom view which has a VisualIntervalScale value of less than one day.
Public property | ReminderTimeBeforeStart | Gets or sets the default TimeSpan value which should be used as initial value for the ReminderTimeBeforeStart property. The default value is 15 minutes.
Public property | SetReminder | Gets or sets whether reminder should be set for the newly created appointments. The default value is true.

See Also

C1SchedulerSettings Class


AllowCategoriesEditing Property

[image]

.NET Framework Class Library
C1SchedulerSettings..::..AllowCategoriesEditing Property
C1SchedulerSettings Class See Also
Determines whether end-user has permission to edit Categories.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(true)]
public bool AllowCategoriesEditing { get; set; }
Visual Basic
<DefaultValueAttribute(True)> _
Public Property AllowCategoriesEditing As Boolean
    Get
    Set

Field Value

The default value is true.

Remarks

If this property is false, default dialogs will only allow selection from the existing items. If this property is false and CategoryCollection is empty, default Appointment dialog won't show controls for editing Categories.

See Also

C1SchedulerSettings Class


AllowCategoriesMultiSelection Property

[image]

.NET Framework Class Library
C1SchedulerSettings..::..AllowCategoriesMultiSelection Property
C1SchedulerSettings Class See Also
Determines whether multiple Category objects might be assigned to the single Appointment object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(true)]
public bool AllowCategoriesMultiSelection { get; set; }
Visual Basic
<DefaultValueAttribute(True)> _
Public Property AllowCategoriesMultiSelection As Boolean
    Get
    Set

Field Value

The default value is true.

Remarks

If both AllowCategoriesMultiSelection and AllowCategoriesEditing properties are false, the default Appointment dialog will show ComboBox for selecting single Category object.

If this property is true, the default Appointment dialog will allow selecting multiple categories in a separate dialog.

See Also

C1SchedulerSettings Class


AllowContactsEditing Property

[image]

.NET Framework Class Library
C1SchedulerSettings..::..AllowContactsEditing Property
C1SchedulerSettings Class See Also
Determines whether end-user has permission to edit Contacts.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(true)]
public bool AllowContactsEditing { get; set; }
Visual Basic
<DefaultValueAttribute(True)> _
Public Property AllowContactsEditing As Boolean
    Get
    Set

Field Value

The default value is true.

Remarks

If this property is false, default dialogs will only allow selection from the existing items. If this property is false and ContactCollection is empty, default Appointment dialog won't show controls for editing Contacts.

See Also

C1SchedulerSettings Class


AllowContactsMultiSelection Property

[image]

.NET Framework Class Library
C1SchedulerSettings..::..AllowContactsMultiSelection Property
C1SchedulerSettings Class See Also
Determines whether multiple Contact objects might be assigned to the single Appointment object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(true)]
public bool AllowContactsMultiSelection { get; set; }
Visual Basic
<DefaultValueAttribute(True)> _
Public Property AllowContactsMultiSelection As Boolean
    Get
    Set

Field Value

The default value is true.

Remarks

If both AllowContactsMultiSelection and AllowContactsEditing properties are false, the default Appointment dialog will show ComboBox for selecting single Contact object.

If this property is true, the default Appointment dialog will allow selecting multiple contacts in a separate dialog.

See Also

C1SchedulerSettings Class


AllowResourcesEditing Property

[image]

.NET Framework Class Library
C1SchedulerSettings..::..AllowResourcesEditing Property
C1SchedulerSettings Class See Also
Determines whether end-user has permission to edit Resources.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(true)]
public bool AllowResourcesEditing { get; set; }
Visual Basic
<DefaultValueAttribute(True)> _
Public Property AllowResourcesEditing As Boolean
    Get
    Set

Field Value

The default value is true.

Remarks

If this property is false, default dialogs will only allow selection from the existing items. If this property is false and ResourceCollection is empty, default Appointment dialog won't show controls for editing Resources.

See Also

C1SchedulerSettings Class


AllowResourcesMultiSelection Property

[image]

.NET Framework Class Library
C1SchedulerSettings..::..AllowResourcesMultiSelection Property
C1SchedulerSettings Class See Also
Determines whether multiple Resource objects might be assigned to the single Appointment object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(true)]
public bool AllowResourcesMultiSelection { get; set; }
Visual Basic
<DefaultValueAttribute(True)> _
Public Property AllowResourcesMultiSelection As Boolean
    Get
    Set

Field Value

The default value is true.

Remarks

If both AllowResourcesMultiSelection and AllowResourcesEditing properties are false, the default Appointment dialog will show ComboBox for selecting single Resource object.

If this property is true, the default Appointment dialog will allow selecting multiple resources in a separate dialog.

See Also

C1SchedulerSettings Class


AutoScrollToFirstAppointment Property

[image]

.NET Framework Class Library
C1SchedulerSettings..::..AutoScrollToFirstAppointment Property
C1SchedulerSettings Class See Also
Gets or sets the Boolean value determining whether control scrolls itself to the earliest appointment in the current view. This property affects Day/Work Week views or any custom view which has VisualIntervalScale value less than one day.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(false)]
public bool AutoScrollToFirstAppointment { get; set; }
Visual Basic
<DefaultValueAttribute(False)> _
Public Property AutoScrollToFirstAppointment As Boolean
    Get
    Set

Remarks

This property affects only initial scroll position.

See Also

C1SchedulerSettings Class


FirstVisibleTime Property

[image]

.NET Framework Class Library
C1SchedulerSettings..::..FirstVisibleTime Property
C1SchedulerSettings Class See Also
Gets or sets the TimeSpan value representing the first visible time slot in a Day/Work Week views or in any custom view which has a VisualIntervalScale value of less than one day.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public TimeSpan FirstVisibleTime { get; set; }
Visual Basic
Public Property FirstVisibleTime As TimeSpan
    Get
    Set

Remarks

This property only affects initial scroll position.

See Also

C1SchedulerSettings Class


ReminderTimeBeforeStart Property

[image]

.NET Framework Class Library
C1SchedulerSettings..::..ReminderTimeBeforeStart Property
C1SchedulerSettings Class See Also
Gets or sets the default TimeSpan value which should be used as initial value for the ReminderTimeBeforeStart property. The default value is 15 minutes.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(typeof(TimeSpan), "0:15:00")]
public TimeSpan ReminderTimeBeforeStart { get; set; }
Visual Basic
<DefaultValueAttribute(GetType(TimeSpan), "0:15:00")> _
Public Property ReminderTimeBeforeStart As TimeSpan
    Get
    Set

Remarks

You should honor this property if you create appointments from code.

See Also

C1SchedulerSettings Class


SetReminder Property

[image]

.NET Framework Class Library
C1SchedulerSettings..::..SetReminder Property
C1SchedulerSettings Class See Also
Gets or sets whether reminder should be set for the newly created appointments. The default value is true.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(true)]
public bool SetReminder { get; set; }
Visual Basic
<DefaultValueAttribute(True)> _
Public Property SetReminder As Boolean
    Get
    Set

Remarks

This property only affects initial setting. End-user will be able to change reminder settings for every individual Appointment object.

See Also

C1SchedulerSettings Class


CalendarBase Class

[image]

.NET Framework Class Library
CalendarBase Class
Members See Also
The base class for the C1CalendarItem and C1Calendar controls.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[StyleTypedPropertyAttribute(Property = "DayOfWeekSlotStyle", StyleTargetType = typeof(DayOfWeekSlotPresenter))]
[StyleTypedPropertyAttribute(Property = "DaySlotStyle", StyleTargetType = typeof(DaySlotPresenter))]
public abstract class CalendarBase : Control,
    ICalendarHelperOwner
Visual Basic
<StyleTypedPropertyAttribute(Property := "DayOfWeekSlotStyle", StyleTargetType := GetType(DayOfWeekSlotPresenter))> _
<StyleTypedPropertyAttribute(Property := "DaySlotStyle", StyleTargetType := GetType(DaySlotPresenter))> _
Public MustInherit Class CalendarBase _
    Inherits Control _
    Implements ICalendarHelperOwner

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
C1.Silverlight.Schedule..::..CalendarBase
C1.Silverlight.Schedule..::..C1Calendar
C1.Silverlight.Schedule..::..C1CalendarItem

See Also

CalendarBase Members


CalendarBase Members

[image] [image]

.NET Framework Class Library
CalendarBase Members
CalendarBase Class Constructors Methods Fields Properties Events See Also

The CalendarBase type exposes the following members.

Constructors

 | Name | Description
Protected method | CalendarBase | Initializes the new instance of the CalendarBase class.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | Calendar_Loaded |
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
 | GetDateTimeAtPoint | Returns the Nullable<(Of <(<'T>)>)> at the specified location.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Protected method | InvalidateCalendarHelper |
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Protected method | InvalidateTheme |
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | Rebuilds calendar slots after initializing. (Overrides FrameworkElement..::..OnApplyTemplate()()()().)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMaxDateChanged |
Protected method | OnMinDateChanged |
Protected method | OnMonthChanged |
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | RefreshTheme |
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Protected method | SetSelectionToDate |
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

 | Name | Description
 | CalendarHelperProperty | Identifies the CalendarHelper dependency property.
 | DayOfWeekSlotStyleProperty | Identifies the DayOfWeekSlotStyle dependency property.
 | DayOfWeekSlotTemplateProperty | Identifies the DayOfWeekSlotTemplate dependency property.
 | DaySlotStyleProperty | Identifies the DaySlotStyle dependency property.
 | DaySlotTemplateProperty | Identifies the DaySlotTemplate dependency property.
 | DaysOfWeekPanelProperty | Identifies the DaysOfWeekPanel dependency property.
 | DaysPanelProperty | Identifies the DaysPanel dependency property.
 | MaxDateProperty | Identifies the MaxDate dependency property.
 | MinDateProperty | Identifies the MinDate dependency property.
 | MonthProperty | Identifies the Month dependency property.
Protected field | selectedDateGroupChangeInitiator |
 | SelectedDateProperty | Identifies the SelectedDate dependency property.
 | ThemeProperty | Identifies the Theme dependency property.
 | YearProperty | Identifies the Year dependency property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CalendarHelper | Gets or sets the CalendarHelper object that provides calendar-dependant properties. This is a dependency property.
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DayOfWeekSlotStyle | Gets or sets a Style for DayOfWeekSlotPresenter elements which are the root elements of a visual tree representing a single day of the week.
Public property | DayOfWeekSlotTemplate | Gets or sets a DataTemplate that defines a UI representation of a single day of the week. This is a dependency property.
Public property | DaySlotStyle | Gets or sets a Style for DaySlotPresenter elements which are the root elements of a visual tree representing a single day of a month.
Public property | DaySlotTemplate | Gets or sets a DataTemplate that defines a UI representation of a single day of a month. This is a dependency property.
Public property | DaysOfWeekPanel | Gets or sets an ItemsPanelTemplate that defines the panel that lays out elements representing days of the week. This is a dependency property.
Public property | DaysPanel | Gets or sets an ItemsPanelTemplate that defines the panel that lays out elements representing days of a month. This is a dependency property.
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IsDisposed |
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxDate | Gets or sets the maximum allowable date. The default is 12/31/9998. This is a dependency property.
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinDate | Gets or sets the minimum allowable date. The default is 01/01/1753. This is a dependency property.
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Month | Gets or sets a month component of the SelectedDate property. This is a dependency property.
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDate | Gets or sets the currently selected date. This is a dependency property.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | SyncRepresentationToDateTime | Gets the Boolean value, determining whether control synchronizes it's representation according to the changes of DateTime property.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Theme | Gets or sets a ResourceDictionary object containing calendar theme resources.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Year | Gets or sets a year component of the SelectedDate property. This is a dependency property.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SelectedDateChanged | Occurs when the SelectedDate property value has been changed.
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

CalendarBase Class


CalendarBase Constructor

[image]

.NET Framework Class Library
CalendarBase Constructor
CalendarBase Class See Also
Initializes the new instance of the CalendarBase class.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected CalendarBase()
Visual Basic
Protected Sub New

See Also

CalendarBase Class


CalendarBase Fields

[image] [image]

.NET Framework Class Library
CalendarBase Fields
CalendarBase Class See Also

The CalendarBase type exposes the following members.

Fields

 | Name | Description
 | CalendarHelperProperty | Identifies the CalendarHelper dependency property.
 | DayOfWeekSlotStyleProperty | Identifies the DayOfWeekSlotStyle dependency property.
 | DayOfWeekSlotTemplateProperty | Identifies the DayOfWeekSlotTemplate dependency property.
 | DaySlotStyleProperty | Identifies the DaySlotStyle dependency property.
 | DaySlotTemplateProperty | Identifies the DaySlotTemplate dependency property.
 | DaysOfWeekPanelProperty | Identifies the DaysOfWeekPanel dependency property.
 | DaysPanelProperty | Identifies the DaysPanel dependency property.
 | MaxDateProperty | Identifies the MaxDate dependency property.
 | MinDateProperty | Identifies the MinDate dependency property.
 | MonthProperty | Identifies the Month dependency property.
Protected field | selectedDateGroupChangeInitiator |
 | SelectedDateProperty | Identifies the SelectedDate dependency property.
 | ThemeProperty | Identifies the Theme dependency property.
 | YearProperty | Identifies the Year dependency property.

See Also

CalendarBase Class


CalendarHelperProperty Field

[image]

.NET Framework Class Library
CalendarBase..::..CalendarHelperProperty Field
CalendarBase Class See Also
Identifies the CalendarHelper dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty CalendarHelperProperty
Visual Basic
Public Shared ReadOnly CalendarHelperProperty As DependencyProperty

See Also

CalendarBase Class


DayOfWeekSlotStyleProperty Field

[image]

.NET Framework Class Library
CalendarBase..::..DayOfWeekSlotStyleProperty Field
CalendarBase Class See Also
Identifies the DayOfWeekSlotStyle dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty DayOfWeekSlotStyleProperty
Visual Basic
Public Shared ReadOnly DayOfWeekSlotStyleProperty As DependencyProperty

See Also

CalendarBase Class


DayOfWeekSlotTemplateProperty Field

[image]

.NET Framework Class Library
CalendarBase..::..DayOfWeekSlotTemplateProperty Field
CalendarBase Class See Also
Identifies the DayOfWeekSlotTemplate dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty DayOfWeekSlotTemplateProperty
Visual Basic
Public Shared ReadOnly DayOfWeekSlotTemplateProperty As DependencyProperty

See Also

CalendarBase Class


DaySlotStyleProperty Field

[image]

.NET Framework Class Library
CalendarBase..::..DaySlotStyleProperty Field
CalendarBase Class See Also
Identifies the DaySlotStyle dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty DaySlotStyleProperty
Visual Basic
Public Shared ReadOnly DaySlotStyleProperty As DependencyProperty

See Also

CalendarBase Class


DaySlotTemplateProperty Field

[image]

.NET Framework Class Library
CalendarBase..::..DaySlotTemplateProperty Field
CalendarBase Class See Also
Identifies the DaySlotTemplate dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty DaySlotTemplateProperty
Visual Basic
Public Shared ReadOnly DaySlotTemplateProperty As DependencyProperty

See Also

CalendarBase Class


DaysOfWeekPanelProperty Field

[image]

.NET Framework Class Library
CalendarBase..::..DaysOfWeekPanelProperty Field
CalendarBase Class See Also
Identifies the DaysOfWeekPanel dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty DaysOfWeekPanelProperty
Visual Basic
Public Shared ReadOnly DaysOfWeekPanelProperty As DependencyProperty

See Also

CalendarBase Class


DaysPanelProperty Field

[image]

.NET Framework Class Library
CalendarBase..::..DaysPanelProperty Field
CalendarBase Class See Also
Identifies the DaysPanel dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty DaysPanelProperty
Visual Basic
Public Shared ReadOnly DaysPanelProperty As DependencyProperty

See Also

CalendarBase Class


MaxDateProperty Field

[image]

.NET Framework Class Library
CalendarBase..::..MaxDateProperty Field
CalendarBase Class See Also
Identifies the MaxDate dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty MaxDateProperty
Visual Basic
Public Shared ReadOnly MaxDateProperty As DependencyProperty

See Also

CalendarBase Class


MinDateProperty Field

[image]

.NET Framework Class Library
CalendarBase..::..MinDateProperty Field
CalendarBase Class See Also
Identifies the MinDate dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty MinDateProperty
Visual Basic
Public Shared ReadOnly MinDateProperty As DependencyProperty

See Also

CalendarBase Class


MonthProperty Field

[image]

.NET Framework Class Library
CalendarBase..::..MonthProperty Field
CalendarBase Class See Also
Identifies the Month dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty MonthProperty
Visual Basic
Public Shared ReadOnly MonthProperty As DependencyProperty

See Also

CalendarBase Class


selectedDateGroupChangeInitiator Field

[image]

.NET Framework Class Library
CalendarBase..::..selectedDateGroupChangeInitiator Field
CalendarBase Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected DependencyProperty selectedDateGroupChangeInitiator
Visual Basic
Protected selectedDateGroupChangeInitiator As DependencyProperty

See Also

CalendarBase Class


SelectedDateProperty Field

[image]

.NET Framework Class Library
CalendarBase..::..SelectedDateProperty Field
CalendarBase Class See Also
Identifies the SelectedDate dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty SelectedDateProperty
Visual Basic
Public Shared ReadOnly SelectedDateProperty As DependencyProperty

See Also

CalendarBase Class


ThemeProperty Field

[image]

.NET Framework Class Library
CalendarBase..::..ThemeProperty Field
CalendarBase Class See Also
Identifies the Theme dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty ThemeProperty
Visual Basic
Public Shared ReadOnly ThemeProperty As DependencyProperty

See Also

CalendarBase Class


YearProperty Field

[image]

.NET Framework Class Library
CalendarBase..::..YearProperty Field
CalendarBase Class See Also
Identifies the Year dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty YearProperty
Visual Basic
Public Shared ReadOnly YearProperty As DependencyProperty

See Also

CalendarBase Class


CalendarBase Methods

[image] [image]

.NET Framework Class Library
CalendarBase Methods
CalendarBase Class See Also

The CalendarBase type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | Calendar_Loaded |
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
 | GetDateTimeAtPoint | Returns the Nullable<(Of <(<'T>)>)> at the specified location.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Protected method | InvalidateCalendarHelper |
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Protected method | InvalidateTheme |
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | Rebuilds calendar slots after initializing. (Overrides FrameworkElement..::..OnApplyTemplate()()()().)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMaxDateChanged |
Protected method | OnMinDateChanged |
Protected method | OnMonthChanged |
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | RefreshTheme |
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Protected method | SetSelectionToDate |
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

CalendarBase Class


Calendar_Loaded Method

[image]

.NET Framework Class Library
CalendarBase..::..Calendar_Loaded Method
CalendarBase Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void Calendar_Loaded(
    Object sender,
    RoutedEventArgs e
)
Visual Basic
Protected Overridable Sub Calendar_Loaded ( _
    sender As Object, _
    e As RoutedEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: System.Windows..::..RoutedEventArgs

See Also

CalendarBase Class


GetDateTimeAtPoint Method

[image]

.NET Framework Class Library
CalendarBase..::..GetDateTimeAtPoint Method
CalendarBase Class See Also
Returns the Nullable<(Of <(<'T>)>)> at the specified location.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static Nullable<DateTime> GetDateTimeAtPoint(
    CalendarBase calendar,
    Point location
)
Visual Basic
Public Shared Function GetDateTimeAtPoint ( _
    calendar As CalendarBase, _
    location As Point _
) As Nullable(Of DateTime)

Parameters

calendar
Type: C1.Silverlight.Schedule..::..CalendarBase
The CalendarBase control.
location
Type: System.Windows..::..Point
The Point object which specifies location inside control boundaries.

Return Value

Returns DateTime value if found; Null - otherwise.

See Also

CalendarBase Class


InvalidateCalendarHelper Method

[image]

.NET Framework Class Library
CalendarBase..::..InvalidateCalendarHelper Method
CalendarBase Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected void InvalidateCalendarHelper()
Visual Basic
Protected Sub InvalidateCalendarHelper

See Also

CalendarBase Class


InvalidateTheme Method

[image]

.NET Framework Class Library
CalendarBase..::..InvalidateTheme Method
CalendarBase Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected void InvalidateTheme()
Visual Basic
Protected Sub InvalidateTheme

See Also

CalendarBase Class


OnApplyTemplate Method

[image]

.NET Framework Class Library
CalendarBase..::..OnApplyTemplate Method
CalendarBase Class See Also
Rebuilds calendar slots after initializing.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic
Public Overrides Sub OnApplyTemplate

See Also

CalendarBase Class


OnMaxDateChanged Method

[image]

.NET Framework Class Library
CalendarBase..::..OnMaxDateChanged Method
CalendarBase Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnMaxDateChanged(
    DependencyPropertyChangedEventArgs e
)
Visual Basic
Protected Overridable Sub OnMaxDateChanged ( _
    e As DependencyPropertyChangedEventArgs _
)

Parameters

e
Type: System.Windows..::..DependencyPropertyChangedEventArgs

See Also

CalendarBase Class


OnMinDateChanged Method

[image]

.NET Framework Class Library
CalendarBase..::..OnMinDateChanged Method
CalendarBase Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnMinDateChanged(
    DependencyPropertyChangedEventArgs e
)
Visual Basic
Protected Overridable Sub OnMinDateChanged ( _
    e As DependencyPropertyChangedEventArgs _
)

Parameters

e
Type: System.Windows..::..DependencyPropertyChangedEventArgs

See Also

CalendarBase Class


OnMonthChanged Method

[image]

.NET Framework Class Library
CalendarBase..::..OnMonthChanged Method
CalendarBase Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnMonthChanged(
    DependencyPropertyChangedEventArgs e
)
Visual Basic
Protected Overridable Sub OnMonthChanged ( _
    e As DependencyPropertyChangedEventArgs _
)

Parameters

e
Type: System.Windows..::..DependencyPropertyChangedEventArgs

See Also

CalendarBase Class


RefreshTheme Method

[image]

.NET Framework Class Library
CalendarBase..::..RefreshTheme Method
CalendarBase Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void RefreshTheme(
    ResourceDictionary oldTheme,
    ResourceDictionary newTheme
)
Visual Basic
Protected Overridable Sub RefreshTheme ( _
    oldTheme As ResourceDictionary, _
    newTheme As ResourceDictionary _
)

Parameters

oldTheme
Type: System.Windows..::..ResourceDictionary
newTheme
Type: System.Windows..::..ResourceDictionary

See Also

CalendarBase Class


SetSelectionToDate Method

[image]

.NET Framework Class Library
CalendarBase..::..SetSelectionToDate Method
CalendarBase Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void SetSelectionToDate()
Visual Basic
Protected Overridable Sub SetSelectionToDate

See Also

CalendarBase Class


CalendarBase Properties

[image] [image]

.NET Framework Class Library
CalendarBase Properties
CalendarBase Class See Also

The CalendarBase type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CalendarHelper | Gets or sets the CalendarHelper object that provides calendar-dependant properties. This is a dependency property.
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DayOfWeekSlotStyle | Gets or sets a Style for DayOfWeekSlotPresenter elements which are the root elements of a visual tree representing a single day of the week.
Public property | DayOfWeekSlotTemplate | Gets or sets a DataTemplate that defines a UI representation of a single day of the week. This is a dependency property.
Public property | DaySlotStyle | Gets or sets a Style for DaySlotPresenter elements which are the root elements of a visual tree representing a single day of a month.
Public property | DaySlotTemplate | Gets or sets a DataTemplate that defines a UI representation of a single day of a month. This is a dependency property.
Public property | DaysOfWeekPanel | Gets or sets an ItemsPanelTemplate that defines the panel that lays out elements representing days of the week. This is a dependency property.
Public property | DaysPanel | Gets or sets an ItemsPanelTemplate that defines the panel that lays out elements representing days of a month. This is a dependency property.
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IsDisposed |
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxDate | Gets or sets the maximum allowable date. The default is 12/31/9998. This is a dependency property.
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinDate | Gets or sets the minimum allowable date. The default is 01/01/1753. This is a dependency property.
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Month | Gets or sets a month component of the SelectedDate property. This is a dependency property.
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDate | Gets or sets the currently selected date. This is a dependency property.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | SyncRepresentationToDateTime | Gets the Boolean value, determining whether control synchronizes it's representation according to the changes of DateTime property.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Theme | Gets or sets a ResourceDictionary object containing calendar theme resources.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Year | Gets or sets a year component of the SelectedDate property. This is a dependency property.

See Also

CalendarBase Class


CalendarHelper Property

[image]

.NET Framework Class Library
CalendarBase..::..CalendarHelper Property
CalendarBase Class See Also
Gets or sets the CalendarHelper object that provides calendar-dependant properties. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public CalendarHelper CalendarHelper { get; set; }
Visual Basic
Public Property CalendarHelper As CalendarHelper
    Get
    Set

See Also

CalendarBase Class


DayOfWeekSlotStyle Property

[image]

.NET Framework Class Library
CalendarBase..::..DayOfWeekSlotStyle Property
CalendarBase Class See Also
Gets or sets a Style for DayOfWeekSlotPresenter elements which are the root elements of a visual tree representing a single day of the week.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Style DayOfWeekSlotStyle { get; set; }
Visual Basic
Public Property DayOfWeekSlotStyle As Style
    Get
    Set

See Also

CalendarBase Class


DayOfWeekSlotTemplate Property

[image]

.NET Framework Class Library
CalendarBase..::..DayOfWeekSlotTemplate Property
CalendarBase Class See Also
Gets or sets a DataTemplate that defines a UI representation of a single day of the week. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DataTemplate DayOfWeekSlotTemplate { get; set; }
Visual Basic
Public Property DayOfWeekSlotTemplate As DataTemplate
    Get
    Set

Remarks

A DataContext for this template is a DayOfWeekSlot object.

See Also

CalendarBase Class


DaySlotStyle Property

[image]

.NET Framework Class Library
CalendarBase..::..DaySlotStyle Property
CalendarBase Class See Also
Gets or sets a Style for DaySlotPresenter elements which are the root elements of a visual tree representing a single day of a month.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Style DaySlotStyle { get; set; }
Visual Basic
Public Property DaySlotStyle As Style
    Get
    Set

See Also

CalendarBase Class


DaySlotTemplate Property

[image]

.NET Framework Class Library
CalendarBase..::..DaySlotTemplate Property
CalendarBase Class See Also
Gets or sets a DataTemplate that defines a UI representation of a single day of a month. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DataTemplate DaySlotTemplate { get; set; }
Visual Basic
Public Property DaySlotTemplate As DataTemplate
    Get
    Set

Remarks

A DataContext for this template is a DaySlot object.

See Also

CalendarBase Class


DaysOfWeekPanel Property

[image]

.NET Framework Class Library
CalendarBase..::..DaysOfWeekPanel Property
CalendarBase Class See Also
Gets or sets an ItemsPanelTemplate that defines the panel that lays out elements representing days of the week. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ItemsPanelTemplate DaysOfWeekPanel { get; set; }
Visual Basic
Public Property DaysOfWeekPanel As ItemsPanelTemplate
    Get
    Set

Remarks

By default the StackPanel with horizontal orientation is used.

See Also

CalendarBase Class


DaysPanel Property

[image]

.NET Framework Class Library
CalendarBase..::..DaysPanel Property
CalendarBase Class See Also
Gets or sets an ItemsPanelTemplate that defines the panel that lays out elements representing days of a month. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ItemsPanelTemplate DaysPanel { get; set; }
Visual Basic
Public Property DaysPanel As ItemsPanelTemplate
    Get
    Set

Remarks

By default the C1UniformGrid panel with 7 columns and 6 rows is used.

See Also

CalendarBase Class


IsDisposed Property

[image]

.NET Framework Class Library
CalendarBase..::..IsDisposed Property
CalendarBase Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected internal bool IsDisposed { get; protected set; }
Visual Basic
Protected Friend Property IsDisposed As Boolean
    Get
    Protected Set

See Also

CalendarBase Class


MaxDate Property

[image]

.NET Framework Class Library
CalendarBase..::..MaxDate Property
CalendarBase Class See Also
Gets or sets the maximum allowable date. The default is 12/31/9998. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTime MaxDate { get; set; }
Visual Basic
Public Property MaxDate As DateTime
    Get
    Set

See Also

CalendarBase Class


MinDate Property

[image]

.NET Framework Class Library
CalendarBase..::..MinDate Property
CalendarBase Class See Also
Gets or sets the minimum allowable date. The default is 01/01/1753. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTime MinDate { get; set; }
Visual Basic
Public Property MinDate As DateTime
    Get
    Set

See Also

CalendarBase Class


Month Property

[image]

.NET Framework Class Library
CalendarBase..::..Month Property
CalendarBase Class See Also
Gets or sets a month component of the SelectedDate property. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public int Month { get; set; }
Visual Basic
<BrowsableAttribute(False)> _
Public Property Month As Integer
    Get
    Set

Remarks

Changing this property value explicitly or implicitly via the SelectedDate property forces the control to refresh its UI so as to represent an updated month of a year.

See Also

CalendarBase Class


SelectedDate Property

[image]

.NET Framework Class Library
CalendarBase..::..SelectedDate Property
CalendarBase Class See Also
Gets or sets the currently selected date. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public DateTime SelectedDate { get; set; }
Visual Basic
<BrowsableAttribute(False)> _
Public Property SelectedDate As DateTime
    Get
    Set

Remarks

Changing this property may also change the Year and/or Month property values, which in turn will cause a refreshing of the control UI so as to represent an updated month of a year. Use this property when MaxSelectionCount is set to 1.

See Also

CalendarBase Class


SyncRepresentationToDateTime Property

[image]

.NET Framework Class Library
CalendarBase..::..SyncRepresentationToDateTime Property
CalendarBase Class See Also
Gets the Boolean value, determining whether control synchronizes it's representation according to the changes of DateTime property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual bool SyncRepresentationToDateTime { get; }
Visual Basic
Protected Overridable ReadOnly Property SyncRepresentationToDateTime As Boolean
    Get

Remarks

Default implementation always returns true.

See Also

CalendarBase Class


Theme Property

[image]

.NET Framework Class Library
CalendarBase..::..Theme Property
CalendarBase Class See Also
Gets or sets a ResourceDictionary object containing calendar theme resources.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ResourceDictionary Theme { get; set; }
Visual Basic
Public Property Theme As ResourceDictionary
    Get
    Set

See Also

CalendarBase Class


Year Property

[image]

.NET Framework Class Library
CalendarBase..::..Year Property
CalendarBase Class See Also
Gets or sets a year component of the SelectedDate property. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public int Year { get; set; }
Visual Basic
<BrowsableAttribute(False)> _
Public Property Year As Integer
    Get
    Set

Remarks

Changing this property value explicitly or implicitly via the SelectedDate property forces the control to refresh its UI so as to represent an updated month of a year.

See Also

CalendarBase Class


CalendarBase Events

[image] [image]

.NET Framework Class Library
CalendarBase Events
CalendarBase Class See Also

The CalendarBase type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SelectedDateChanged | Occurs when the SelectedDate property value has been changed.
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

CalendarBase Class


SelectedDateChanged Event

[image]

.NET Framework Class Library
CalendarBase..::..SelectedDateChanged Event
CalendarBase Class See Also
Occurs when the SelectedDate property value has been changed.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event EventHandler<DateTimePropertyChangeEventArgs> SelectedDateChanged
Visual Basic
Public Event SelectedDateChanged As EventHandler(Of DateTimePropertyChangeEventArgs)

See Also

CalendarBase Class


CalendarHelper Class

[image]

.NET Framework Class Library
CalendarHelper Class
Members See Also
Provides auxiliary properties providing calendar specific information.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class CalendarHelper : DependencyObject,
    INotifyPropertyChanged
Visual Basic
Public Class CalendarHelper _
    Inherits DependencyObject _
    Implements INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
C1.Silverlight.Schedule..::..CalendarHelper

See Also

CalendarHelper Members


CalendarHelper Members

[image] [image]

.NET Framework Class Library
CalendarHelper Members
CalendarHelper Class Constructors Methods Fields Properties Events See Also

The CalendarHelper type exposes the following members.

Constructors

 | Name | Description
Public method | CalendarHelper | Initializes a new instance of the CalendarHelper class.

Methods

 | Name | Description
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
WorkDaysProperty | Identifies the WorkDays dependency property.

Properties

 | Name | Description
Public property | DateTimeKind | Gets or sets a DateTimeKind value specifying DateTime kind used for saving DateTime values.
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | EndDayTime | Gets or sets the TimeSpan value specifying the end of the working time.
Public property | FullDayNames | Gets an array of culture specific full day names.
Public property | FullMonthNames | Gets an array of culture specific full month names.
Public property | Holidays | Gets or sets the ObservableCollection<(Of <(<'T>)>)> object which holds the list of holidays (non-working days in addition to weekends). You cannot set this property in XAML.
Public property | Info | Gets the underlying CalendarInfo object. For internal use only.
Public property | NoWorkingDays | Gets or sets the Boolean value determining whether the CalendarHelper object has any working days.
Public property | StartDayTime | Gets or sets the TimeSpan value specifying the beginning of the working time.
Public property | WeekendExceptions | Gets or sets the ObservableCollection<(Of <(<'T>)>)> object which holds the list of weekend days which should be working. You cannot set this property in XAML.
Public property | WeekStart | Gets or sets the DayOfWeek value determining the first day of the week. Default is system settings.
Public property | WorkDays | Gets or sets the WorkDays object containing the set of working days in one week.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when the property of CalendarHelper object is changed.

See Also

CalendarHelper Class


CalendarHelper Constructor

[image]

.NET Framework Class Library
CalendarHelper Constructor
CalendarHelper Class See Also
Initializes a new instance of the CalendarHelper class.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public CalendarHelper()
Visual Basic
Public Sub New

See Also

CalendarHelper Class


CalendarHelper Fields

[image] [image]

.NET Framework Class Library
CalendarHelper Fields
CalendarHelper Class See Also

The CalendarHelper type exposes the following members.

Fields

Name | Description
WorkDaysProperty | Identifies the WorkDays dependency property.

See Also

CalendarHelper Class


WorkDaysProperty Field

[image]

.NET Framework Class Library
CalendarHelper..::..WorkDaysProperty Field
CalendarHelper Class See Also
Identifies the WorkDays dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty WorkDaysProperty
Visual Basic
Public Shared ReadOnly WorkDaysProperty As DependencyProperty

See Also

CalendarHelper Class


CalendarHelper Methods

[image] [image]

.NET Framework Class Library
CalendarHelper Methods
CalendarHelper Class See Also

The CalendarHelper type exposes the following members.

Methods

 | Name | Description
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CalendarHelper Class


CalendarHelper Properties

[image] [image]

.NET Framework Class Library
CalendarHelper Properties
CalendarHelper Class See Also

The CalendarHelper type exposes the following members.

Properties

 | Name | Description
Public property | DateTimeKind | Gets or sets a DateTimeKind value specifying DateTime kind used for saving DateTime values.
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | EndDayTime | Gets or sets the TimeSpan value specifying the end of the working time.
Public property | FullDayNames | Gets an array of culture specific full day names.
Public property | FullMonthNames | Gets an array of culture specific full month names.
Public property | Holidays | Gets or sets the ObservableCollection<(Of <(<'T>)>)> object which holds the list of holidays (non-working days in addition to weekends). You cannot set this property in XAML.
Public property | Info | Gets the underlying CalendarInfo object. For internal use only.
Public property | NoWorkingDays | Gets or sets the Boolean value determining whether the CalendarHelper object has any working days.
Public property | StartDayTime | Gets or sets the TimeSpan value specifying the beginning of the working time.
Public property | WeekendExceptions | Gets or sets the ObservableCollection<(Of <(<'T>)>)> object which holds the list of weekend days which should be working. You cannot set this property in XAML.
Public property | WeekStart | Gets or sets the DayOfWeek value determining the first day of the week. Default is system settings.
Public property | WorkDays | Gets or sets the WorkDays object containing the set of working days in one week.

See Also

CalendarHelper Class


DateTimeKind Property

[image]

.NET Framework Class Library
CalendarHelper..::..DateTimeKind Property
CalendarHelper Class See Also
Gets or sets a DateTimeKind value specifying DateTime kind used for saving DateTime values.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(DateTimeKind.Unspecified)]
public DateTimeKind DateTimeKind { get; set; }
Visual Basic
<DefaultValueAttribute(DateTimeKind.Unspecified)> _
Public Property DateTimeKind As DateTimeKind
    Get
    Set

Remarks

This property only has an influence on the process of saving data to the AppointmentStorage.DataSource object and on export operations. All properties of the Appointment and RecurrencePattern objects represent current system local time values. Set this property to DateTimeLind.Utc if you need to save data with universal time. In such case the data will be converted to the local time and back at every read/write operation.

See Also

CalendarHelper Class


EndDayTime Property

[image]

.NET Framework Class Library
CalendarHelper..::..EndDayTime Property
CalendarHelper Class See Also
Gets or sets the TimeSpan value specifying the end of the working time.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public TimeSpan EndDayTime { get; set; }
Visual Basic
Public Property EndDayTime As TimeSpan
    Get
    Set

See Also

CalendarHelper Class


FullDayNames Property

[image]

.NET Framework Class Library
CalendarHelper..::..FullDayNames Property
CalendarHelper Class See Also
Gets an array of culture specific full day names.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ReadOnlyObservableCollection FullDayNames { get; }
Visual Basic
Public ReadOnly Property FullDayNames As ReadOnlyObservableCollection
    Get

See Also

CalendarHelper Class


FullMonthNames Property

[image]

.NET Framework Class Library
CalendarHelper..::..FullMonthNames Property
CalendarHelper Class See Also
Gets an array of culture specific full month names.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ReadOnlyObservableCollection FullMonthNames { get; }
Visual Basic
Public ReadOnly Property FullMonthNames As ReadOnlyObservableCollection
    Get

See Also

CalendarHelper Class


Holidays Property

[image]

.NET Framework Class Library
CalendarHelper..::..Holidays Property
CalendarHelper Class See Also
Gets or sets the ObservableCollection<(Of <(<'T>)>)> object which holds the list of holidays (non-working days in addition to weekends).

You cannot set this property in XAML.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ObservableCollection<DateTime> Holidays { get; set; }
Visual Basic
Public Property Holidays As ObservableCollection(Of DateTime)
    Get
    Set

Remarks

Setting this property copies items from the new value to the underlying collection.

See Also

CalendarHelper Class


Info Property

[image]

.NET Framework Class Library
CalendarHelper..::..Info Property
CalendarHelper Class See Also
Gets the underlying CalendarInfo object. For internal use only.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public CalendarInfo Info { get; }
Visual Basic
Public ReadOnly Property Info As CalendarInfo
    Get

See Also

CalendarHelper Class


NoWorkingDays Property

[image]

.NET Framework Class Library
CalendarHelper..::..NoWorkingDays Property
CalendarHelper Class See Also
Gets or sets the Boolean value determining whether the CalendarHelper object has any working days.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[DefaultValueAttribute(false)]
public bool NoWorkingDays { get; set; }
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
<DefaultValueAttribute(False)> _
Public Property NoWorkingDays As Boolean
    Get
    Set

See Also

CalendarHelper Class


StartDayTime Property

[image]

.NET Framework Class Library
CalendarHelper..::..StartDayTime Property
CalendarHelper Class See Also
Gets or sets the TimeSpan value specifying the beginning of the working time.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public TimeSpan StartDayTime { get; set; }
Visual Basic
Public Property StartDayTime As TimeSpan
    Get
    Set

See Also

CalendarHelper Class


WeekendExceptions Property

[image]

.NET Framework Class Library
CalendarHelper..::..WeekendExceptions Property
CalendarHelper Class See Also
Gets or sets the ObservableCollection<(Of <(<'T>)>)> object which holds the list of weekend days which should be working.

You cannot set this property in XAML.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ObservableCollection<DateTime> WeekendExceptions { get; set; }
Visual Basic
Public Property WeekendExceptions As ObservableCollection(Of DateTime)
    Get
    Set

Remarks

Setting this property copies items from the new value to the underlying collection.

See Also

CalendarHelper Class


WeekStart Property

[image]

.NET Framework Class Library
CalendarHelper..::..WeekStart Property
CalendarHelper Class See Also
Gets or sets the DayOfWeek value determining the first day of the week. Default is system settings.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DayOfWeek WeekStart { get; set; }
Visual Basic
Public Property WeekStart As DayOfWeek
    Get
    Set

See Also

CalendarHelper Class


WorkDays Property

[image]

.NET Framework Class Library
CalendarHelper..::..WorkDays Property
CalendarHelper Class See Also
Gets or sets the WorkDays object containing the set of working days in one week.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[TypeConverterAttribute(typeof(WorkDaysConverter))]
public WorkDays WorkDays { get; set; }
Visual Basic
<TypeConverterAttribute(GetType(WorkDaysConverter))> _
Public Property WorkDays As WorkDays
    Get
    Set

Remarks

Note: WorkingWeekView style should set VisualTimeSpan property to 7 days. The actual number of displayed days will depend on the WorkDays list.

See Also

CalendarHelper Class


CalendarHelper Events

[image] [image]

.NET Framework Class Library
CalendarHelper Events
CalendarHelper Class See Also

The CalendarHelper type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when the property of CalendarHelper object is changed.

See Also

CalendarHelper Class


PropertyChanged Event

[image]

.NET Framework Class Library
CalendarHelper..::..PropertyChanged Event
CalendarHelper Class See Also
Occurs when the property of CalendarHelper object is changed.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

CalendarHelper Class


ChangeSignConverter Class

[image]

.NET Framework Class Library
ChangeSignConverter Class
Members See Also
Represents a Binding converter that changes a sign of a numeric value.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class ChangeSignConverter : IValueConverter
Visual Basic
Public Class ChangeSignConverter _
    Implements IValueConverter

Remarks

ChangeSignConverter is a two-way converter. A source value must be of a numeric type, and a converted value has the same type as a source value.

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..ChangeSignConverter

See Also

ChangeSignConverter Members


ChangeSignConverter Members

[image] [image]

.NET Framework Class Library
ChangeSignConverter Members
ChangeSignConverter Class Constructors Methods Fields See Also

The ChangeSignConverter type exposes the following members.

Constructors

 | Name | Description
Public method | ChangeSignConverter |

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Default | Gets an instance of ChangeSignConverter.

See Also

ChangeSignConverter Class


ChangeSignConverter Constructor

[image]

.NET Framework Class Library
ChangeSignConverter Constructor
ChangeSignConverter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ChangeSignConverter()
Visual Basic
Public Sub New

See Also

ChangeSignConverter Class


ChangeSignConverter Fields

[image] [image]

.NET Framework Class Library
ChangeSignConverter Fields
ChangeSignConverter Class See Also

The ChangeSignConverter type exposes the following members.

Fields

Name | Description
Default | Gets an instance of ChangeSignConverter.

See Also

ChangeSignConverter Class


Default Field

[image]

.NET Framework Class Library
ChangeSignConverter..::..Default Field
ChangeSignConverter Class See Also
Gets an instance of ChangeSignConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly ChangeSignConverter Default
Visual Basic
Public Shared ReadOnly Default As ChangeSignConverter

See Also

ChangeSignConverter Class


ChangeSignConverter Methods

[image] [image]

.NET Framework Class Library
ChangeSignConverter Methods
ChangeSignConverter Class See Also

The ChangeSignConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChangeSignConverter Class


Convert Method

[image]

.NET Framework Class Library
ChangeSignConverter..::..Convert Method
ChangeSignConverter Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

ChangeSignConverter Class


ConvertBack Method

[image]

.NET Framework Class Library
ChangeSignConverter..::..ConvertBack Method
ChangeSignConverter Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value that is produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

ChangeSignConverter Class


ChangeThicknessSignConverter Class

[image]

.NET Framework Class Library
ChangeThicknessSignConverter Class
Members See Also
Represents a Binding converter that changes a sign of each member of Thickness.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class ChangeThicknessSignConverter : IValueConverter
Visual Basic
Public Class ChangeThicknessSignConverter _
    Implements IValueConverter

Remarks

ChangeThicknessSignConverter is a two-way converter. The source value must be a Thickness object, and the converted value is a Thickness where all edges has a thickness with the opposite sign.

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..ChangeThicknessSignConverter

See Also

ChangeThicknessSignConverter Members


ChangeThicknessSignConverter Members

[image] [image]

.NET Framework Class Library
ChangeThicknessSignConverter Members
ChangeThicknessSignConverter Class Constructors Methods Fields See Also

The ChangeThicknessSignConverter type exposes the following members.

Constructors

 | Name | Description
Public method | ChangeThicknessSignConverter |

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Default | Gets an instance of ChangeThicknessSignConverter.

See Also

ChangeThicknessSignConverter Class


ChangeThicknessSignConverter Constructor

[image]

.NET Framework Class Library
ChangeThicknessSignConverter Constructor
ChangeThicknessSignConverter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ChangeThicknessSignConverter()
Visual Basic
Public Sub New

See Also

ChangeThicknessSignConverter Class


ChangeThicknessSignConverter Fields

[image] [image]

.NET Framework Class Library
ChangeThicknessSignConverter Fields
ChangeThicknessSignConverter Class See Also

The ChangeThicknessSignConverter type exposes the following members.

Fields

Name | Description
Default | Gets an instance of ChangeThicknessSignConverter.

See Also

ChangeThicknessSignConverter Class


Default Field

[image]

.NET Framework Class Library
ChangeThicknessSignConverter..::..Default Field
ChangeThicknessSignConverter Class See Also
Gets an instance of ChangeThicknessSignConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly ChangeThicknessSignConverter Default
Visual Basic
Public Shared ReadOnly Default As ChangeThicknessSignConverter

See Also

ChangeThicknessSignConverter Class


ChangeThicknessSignConverter Methods

[image] [image]

.NET Framework Class Library
ChangeThicknessSignConverter Methods
ChangeThicknessSignConverter Class See Also

The ChangeThicknessSignConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChangeThicknessSignConverter Class


Convert Method

[image]

.NET Framework Class Library
ChangeThicknessSignConverter..::..Convert Method
ChangeThicknessSignConverter Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

ChangeThicknessSignConverter Class


ConvertBack Method

[image]

.NET Framework Class Library
ChangeThicknessSignConverter..::..ConvertBack Method
ChangeThicknessSignConverter Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value that is produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

ChangeThicknessSignConverter Class


ColorToBrushConverter Class

[image]

.NET Framework Class Library
ColorToBrushConverter Class
Members See Also
Represents a Binding converter that converts a color to a brush.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class ColorToBrushConverter : IValueConverter
Visual Basic
Public Class ColorToBrushConverter _
    Implements IValueConverter

Remarks

ColorToBrushConverter is a two-way converter. The source value must be a System.Windows.Media.Color, and the target value is a System.Windows.Media.SolidColorBrush based on the color.

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..ColorToBrushConverter

See Also

ColorToBrushConverter Members


ColorToBrushConverter Members

[image] [image]

.NET Framework Class Library
ColorToBrushConverter Members
ColorToBrushConverter Class Constructors Methods Fields See Also

The ColorToBrushConverter type exposes the following members.

Constructors

 | Name | Description
Public method | ColorToBrushConverter |

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Default | Gets an instance of ColorToBrushConverter.

See Also

ColorToBrushConverter Class


ColorToBrushConverter Constructor

[image]

.NET Framework Class Library
ColorToBrushConverter Constructor
ColorToBrushConverter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ColorToBrushConverter()
Visual Basic
Public Sub New

See Also

ColorToBrushConverter Class


ColorToBrushConverter Fields

[image] [image]

.NET Framework Class Library
ColorToBrushConverter Fields
ColorToBrushConverter Class See Also

The ColorToBrushConverter type exposes the following members.

Fields

Name | Description
Default | Gets an instance of ColorToBrushConverter.

See Also

ColorToBrushConverter Class


Default Field

[image]

.NET Framework Class Library
ColorToBrushConverter..::..Default Field
ColorToBrushConverter Class See Also
Gets an instance of ColorToBrushConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly ColorToBrushConverter Default
Visual Basic
Public Shared ReadOnly Default As ColorToBrushConverter

See Also

ColorToBrushConverter Class


ColorToBrushConverter Methods

[image] [image]

.NET Framework Class Library
ColorToBrushConverter Methods
ColorToBrushConverter Class See Also

The ColorToBrushConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColorToBrushConverter Class


Convert Method

[image]

.NET Framework Class Library
ColorToBrushConverter..::..Convert Method
ColorToBrushConverter Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

ColorToBrushConverter Class


ConvertBack Method

[image]

.NET Framework Class Library
ColorToBrushConverter..::..ConvertBack Method
ColorToBrushConverter Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value that is produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

ColorToBrushConverter Class


CoveredElement Class

[image]

.NET Framework Class Library
CoveredElement Class
Members See Also
Defines a construction that describes a wrapper for the single covered element.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class CoveredElement : DependencyObject
Visual Basic
Public Class CoveredElement _
    Inherits DependencyObject

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
C1.Silverlight.Schedule..::..CoveredElement

See Also

CoveredElement Members


CoveredElement Members

[image] [image]

.NET Framework Class Library
CoveredElement Members
CoveredElement Class Constructors Methods Properties See Also

The CoveredElement type exposes the following members.

Constructors

 | Name | Description
Public method | CoveredElement | Initializes a new instance of the CoveredElement class.

Methods

 | Name | Description
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | Owner | Gets a FrameworkElement which is wrapped by the current CoveredElement instance.

See Also

CoveredElement Class


CoveredElement Constructor

[image]

.NET Framework Class Library
CoveredElement Constructor
CoveredElement Class See Also
Initializes a new instance of the CoveredElement class.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public CoveredElement(
    FrameworkElement owner
)
Visual Basic
Public Sub New ( _
    owner As FrameworkElement _
)

Parameters

owner
Type: System.Windows..::..FrameworkElement
The actual FrameworkElement.

See Also

CoveredElement Class


CoveredElement Methods

[image] [image]

.NET Framework Class Library
CoveredElement Methods
CoveredElement Class See Also

The CoveredElement type exposes the following members.

Methods

 | Name | Description
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CoveredElement Class


CoveredElement Properties

[image] [image]

.NET Framework Class Library
CoveredElement Properties
CoveredElement Class See Also

The CoveredElement type exposes the following members.

Properties

 | Name | Description
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | Owner | Gets a FrameworkElement which is wrapped by the current CoveredElement instance.

See Also

CoveredElement Class


Owner Property

[image]

.NET Framework Class Library
CoveredElement..::..Owner Property
CoveredElement Class See Also
Gets a FrameworkElement which is wrapped by the current CoveredElement instance.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public FrameworkElement Owner { get; }
Visual Basic
Public ReadOnly Property Owner As FrameworkElement
    Get

See Also

CoveredElement Class


CoveredElementsCollection Class

[image]

.NET Framework Class Library
CoveredElementsCollection Class
Members See Also
The CoveredElementsCollection represents an observable collection of FrameworkElements.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class CoveredElementsCollection : C1ObservableKeyedCollection<FrameworkElement, CoveredElement>
Visual Basic
Public Class CoveredElementsCollection _
    Inherits C1ObservableKeyedCollection(Of FrameworkElement, CoveredElement)

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' CoveredElement >)>)>
System.Collections.ObjectModel..::..KeyedCollection <(Of <(<' FrameworkElement, CoveredElement >)>)>
C1.C1Schedule..::..C1ObservableKeyedCollection <(Of <(<' FrameworkElement, CoveredElement >)>)>
C1.Silverlight.Schedule..::..CoveredElementsCollection

See Also

CoveredElementsCollection Members


CoveredElementsCollection Members

[image] [image]

.NET Framework Class Library
CoveredElementsCollection Members
CoveredElementsCollection Class Constructors Methods Properties Explicit Interface Implementations See Also

The CoveredElementsCollection type exposes the following members.

Constructors

 | Name | Description
Public method | CoveredElementsCollection |

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection <(Of <(<' FrameworkElement, CoveredElement >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Protected method | ClearItems | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' FrameworkElement, CoveredElement >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoveredElement >)>)> Collection<(Of <(<'T>)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKeyForItem | Extracts the key from the specified element. (Overrides KeyedCollection<(Of <(<'TKey, TItem>)>)>..::..GetKeyForItem(TItem).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Protected method | InsertItem | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' FrameworkElement, CoveredElement >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoveredElement >)>)> Collection<(Of <(<'T>)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Protected method | RemoveItem | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Protected method | SetItem | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection <(Of <(<' FrameworkElement, CoveredElement >)>)>.)
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' FrameworkElement, CoveredElement >)>)>.)
Public property | Item[([( TKey])]) | Gets the element with the specified key. (Inherited from KeyedCollection <(Of <(<' FrameworkElement, CoveredElement >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' CoveredElement >)>)> Collection<(Of <(<'T>)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)

See Also

CoveredElementsCollection Class


CoveredElementsCollection Constructor

[image]

.NET Framework Class Library
CoveredElementsCollection Constructor
CoveredElementsCollection Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public CoveredElementsCollection()
Visual Basic
Public Sub New

See Also

CoveredElementsCollection Class


CoveredElementsCollection Methods

[image] [image]

.NET Framework Class Library
CoveredElementsCollection Methods
CoveredElementsCollection Class See Also

The CoveredElementsCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection <(Of <(<' FrameworkElement, CoveredElement >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Protected method | ClearItems | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' FrameworkElement, CoveredElement >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoveredElement >)>)> Collection<(Of <(<'T>)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKeyForItem | Extracts the key from the specified element. (Overrides KeyedCollection<(Of <(<'TKey, TItem>)>)>..::..GetKeyForItem(TItem).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Protected method | InsertItem | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' FrameworkElement, CoveredElement >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoveredElement >)>)> Collection<(Of <(<'T>)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Protected method | RemoveItem | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Protected method | SetItem | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)

See Also

CoveredElementsCollection Class


Contains Method

[image] [image]

.NET Framework Class Library
CoveredElementsCollection..::..Contains Method
CoveredElementsCollection Class See Also

Overload List

 | Name | Description
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' FrameworkElement, CoveredElement >)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)

See Also

CoveredElementsCollection Class
CoveredElementsCollection Members


GetKeyForItem Method

[image]

.NET Framework Class Library
CoveredElementsCollection..::..GetKeyForItem Method
CoveredElementsCollection Class See Also
Extracts the key from the specified element.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override FrameworkElement GetKeyForItem(
    CoveredElement item
)
Visual Basic
Protected Overrides Function GetKeyForItem ( _
    item As CoveredElement _
) As FrameworkElement

Parameters

item
Type: C1.Silverlight.Schedule..::..CoveredElement
The CoveredElement item.

Return Value

Returns Owner property for the specified item.

See Also

CoveredElementsCollection Class


Remove Method

[image] [image]

.NET Framework Class Library
CoveredElementsCollection..::..Remove Method
CoveredElementsCollection Class See Also

Overload List

 | Name | Description
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' FrameworkElement, CoveredElement >)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)

See Also

CoveredElementsCollection Class
CoveredElementsCollection Members


CoveredElementsCollection Properties

[image] [image]

.NET Framework Class Library
CoveredElementsCollection Properties
CoveredElementsCollection Class See Also

The CoveredElementsCollection type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection <(Of <(<' FrameworkElement, CoveredElement >)>)>.)
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' FrameworkElement, CoveredElement >)>)>.)
Public property | Item[([( TKey])]) | Gets the element with the specified key. (Inherited from KeyedCollection <(Of <(<' FrameworkElement, CoveredElement >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' CoveredElement >)>)> Collection<(Of <(<'T>)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)

See Also

CoveredElementsCollection Class


Item Property

[image] [image]

.NET Framework Class Library
CoveredElementsCollection..::..Item Property
CoveredElementsCollection Class See Also

Overload List

 | Name | Description
Public property | Item[([( TKey])]) | Gets the element with the specified key. (Inherited from KeyedCollection <(Of <(<' FrameworkElement, CoveredElement >)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' CoveredElement >)>)>.)

See Also

CoveredElementsCollection Class
CoveredElementsCollection Members


CoveredElementsCollection Events

[image] [image]

.NET Framework Class Library
CoveredElementsCollection Events
CoveredElementsCollection Class See Also

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)

See Also

CoveredElementsCollection Class


CoverElement Class

[image]

.NET Framework Class Library
CoverElement Class
Members See Also
Defines a construction that describes a UI that represents a single data object. The UI is constituted of a number of CoverElementChunk elements.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class CoverElement : DependencyObject
Visual Basic
Public Class CoverElement _
    Inherits DependencyObject

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
C1.Silverlight.Schedule..::..CoverElement

See Also

CoverElement Members


CoverElement Members

[image] [image]

.NET Framework Class Library
CoverElement Members
CoverElement Class Constructors Methods Properties See Also

The CoverElement type exposes the following members.

Constructors

 | Name | Description
Public method | CoverElement | Initializes a new instance of the CoverElement class.

Methods

 | Name | Description
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Chunks | Gets a list of CoverElementChunk elements that constitute this CoverElement UI.
Public property | CoveredElements | Gets a list of elements that are covered by this CoverElement.
Public property | DataObject | Gets an Object which is represented by the current CoverElement instance.
Public property | Dispatcher | (Inherited from DependencyObject.)

See Also

CoverElement Class


CoverElement Constructor

[image]

.NET Framework Class Library
CoverElement Constructor
CoverElement Class See Also
Initializes a new instance of the CoverElement class.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public CoverElement(
    Object dataObject
)
Visual Basic
Public Sub New ( _
    dataObject As Object _
)

Parameters

dataObject
Type: System..::..Object
The represented data object.

See Also

CoverElement Class


CoverElement Methods

[image] [image]

.NET Framework Class Library
CoverElement Methods
CoverElement Class See Also

The CoverElement type exposes the following members.

Methods

 | Name | Description
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CoverElement Class


CoverElement Properties

[image] [image]

.NET Framework Class Library
CoverElement Properties
CoverElement Class See Also

The CoverElement type exposes the following members.

Properties

 | Name | Description
Public property | Chunks | Gets a list of CoverElementChunk elements that constitute this CoverElement UI.
Public property | CoveredElements | Gets a list of elements that are covered by this CoverElement.
Public property | DataObject | Gets an Object which is represented by the current CoverElement instance.
Public property | Dispatcher | (Inherited from DependencyObject.)

See Also

CoverElement Class


Chunks Property

[image]

.NET Framework Class Library
CoverElement..::..Chunks Property
CoverElement Class See Also
Gets a list of CoverElementChunk elements that constitute this CoverElement UI.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public CoverElementChunkCollection Chunks { get; }
Visual Basic
Public ReadOnly Property Chunks As CoverElementChunkCollection
    Get

See Also

CoverElement Class


CoveredElements Property

[image]

.NET Framework Class Library
CoverElement..::..CoveredElements Property
CoverElement Class See Also
Gets a list of elements that are covered by this CoverElement.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public CoveredElementsCollection CoveredElements { get; }
Visual Basic
Public ReadOnly Property CoveredElements As CoveredElementsCollection
    Get

See Also

CoverElement Class


DataObject Property

[image]

.NET Framework Class Library
CoverElement..::..DataObject Property
CoverElement Class See Also
Gets an Object which is represented by the current CoverElement instance.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object DataObject { get; }
Visual Basic
Public ReadOnly Property DataObject As Object
    Get

See Also

CoverElement Class


CoverElementChunk Class

[image]

.NET Framework Class Library
CoverElementChunk Class
Members See Also
The CoverElementChunk class represents an indivisible part of a UI for a data object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class CoverElementChunk : ContentControl
Visual Basic
Public Class CoverElementChunk _
    Inherits ContentControl

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ContentControl
C1.Silverlight.Schedule..::..CoverElementChunk

See Also

CoverElementChunk Members


CoverElementChunk Members

[image] [image]

.NET Framework Class Library
CoverElementChunk Members
CoverElementChunk Class Constructors Methods Properties Events See Also

The CoverElementChunk type exposes the following members.

Constructors

 | Name | Description
Public method | CoverElementChunk | Initializes the new instance of the CoverElementChunk class.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | CoveredElements | Gets the CoveredElementsCollection object representing the collection of elements covered by this CoverElementChunk object.
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsFirst | Gets the Boolean value determining if this CoverElementChunk object is the first one in the representation of the data object.
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsLast | Gets the Boolean value determining if this CoverElementChunk object is the last one in the representation of the data object.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Owner | Gets the owning CoverElement object.
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

CoverElementChunk Class


CoverElementChunk Constructor

[image]

.NET Framework Class Library
CoverElementChunk Constructor
CoverElementChunk Class See Also
Initializes the new instance of the CoverElementChunk class.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public CoverElementChunk()
Visual Basic
Public Sub New

See Also

CoverElementChunk Class


CoverElementChunk Methods

[image] [image]

.NET Framework Class Library
CoverElementChunk Methods
CoverElementChunk Class See Also

The CoverElementChunk type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

CoverElementChunk Class


CoverElementChunk Properties

[image] [image]

.NET Framework Class Library
CoverElementChunk Properties
CoverElementChunk Class See Also

The CoverElementChunk type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | CoveredElements | Gets the CoveredElementsCollection object representing the collection of elements covered by this CoverElementChunk object.
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsFirst | Gets the Boolean value determining if this CoverElementChunk object is the first one in the representation of the data object.
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsLast | Gets the Boolean value determining if this CoverElementChunk object is the last one in the representation of the data object.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Owner | Gets the owning CoverElement object.
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

CoverElementChunk Class


CoveredElements Property

[image]

.NET Framework Class Library
CoverElementChunk..::..CoveredElements Property
CoverElementChunk Class See Also
Gets the CoveredElementsCollection object representing the collection of elements covered by this CoverElementChunk object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public CoveredElementsCollection CoveredElements { get; }
Visual Basic
Public ReadOnly Property CoveredElements As CoveredElementsCollection
    Get

See Also

CoverElementChunk Class


IsFirst Property

[image]

.NET Framework Class Library
CoverElementChunk..::..IsFirst Property
CoverElementChunk Class See Also
Gets the Boolean value determining if this CoverElementChunk object is the first one in the representation of the data object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsFirst { get; }
Visual Basic
Public ReadOnly Property IsFirst As Boolean
    Get

See Also

CoverElementChunk Class


IsLast Property

[image]

.NET Framework Class Library
CoverElementChunk..::..IsLast Property
CoverElementChunk Class See Also
Gets the Boolean value determining if this CoverElementChunk object is the last one in the representation of the data object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsLast { get; }
Visual Basic
Public ReadOnly Property IsLast As Boolean
    Get

See Also

CoverElementChunk Class


Owner Property

[image]

.NET Framework Class Library
CoverElementChunk..::..Owner Property
CoverElementChunk Class See Also
Gets the owning CoverElement object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public CoverElement Owner { get; }
Visual Basic
Public ReadOnly Property Owner As CoverElement
    Get

See Also

CoverElementChunk Class


CoverElementChunk Events

[image] [image]

.NET Framework Class Library
CoverElementChunk Events
CoverElementChunk Class See Also

The CoverElementChunk type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

CoverElementChunk Class


CoverElementChunkCollection Class

[image]

.NET Framework Class Library
CoverElementChunkCollection Class
Members See Also
The CoverElementChunkCollection represents the observable collection of CoverElementChunk objects.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class CoverElementChunkCollection : C1ObservableCollection<CoverElementChunk>
Visual Basic
Public Class CoverElementChunkCollection _
    Inherits C1ObservableCollection(Of CoverElementChunk)

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' CoverElementChunk >)>)>
C1.C1Schedule..::..C1ObservableCollection <(Of <(<' CoverElementChunk >)>)>
C1.Silverlight.Schedule..::..CoverElementChunkCollection

See Also

CoverElementChunkCollection Members


CoverElementChunkCollection Members

[image] [image]

.NET Framework Class Library
CoverElementChunkCollection Members
CoverElementChunkCollection Class Constructors Methods Properties Explicit Interface Implementations See Also

The CoverElementChunkCollection type exposes the following members.

Constructors

 | Name | Description
Public method | CoverElementChunkCollection | Initializes the new instance of the CoverElementChunkCollection collection.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Protected method | ClearItems | Overrides the default behavior. (Overrides C1ObservableCollection<(Of <(<'T>)>)>..::..ClearItems()()()().)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Protected method | InsertItem | Overrides the default behavior. (Overrides C1ObservableCollection<(Of <(<'T>)>)>..::..InsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Protected method | RemoveItem | Overrides the default behavior. (Overrides C1ObservableCollection<(Of <(<'T>)>)>..::..RemoveItem(Int32).)
Protected method | SetItem | Overrides the default behavior. (Overrides C1ObservableCollection<(Of <(<'T>)>)>..::..SetItem(Int32, T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Public property | Owner | Gets the owning CoverElement object.

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)

See Also

CoverElementChunkCollection Class


CoverElementChunkCollection Constructor

[image]

.NET Framework Class Library
CoverElementChunkCollection Constructor
CoverElementChunkCollection Class See Also
Initializes the new instance of the CoverElementChunkCollection collection.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public CoverElementChunkCollection(
    CoverElement owner
)
Visual Basic
Public Sub New ( _
    owner As CoverElement _
)

Parameters

owner
Type: C1.Silverlight.Schedule..::..CoverElement
The owning CoverElement object.

See Also

CoverElementChunkCollection Class


CoverElementChunkCollection Methods

[image] [image]

.NET Framework Class Library
CoverElementChunkCollection Methods
CoverElementChunkCollection Class See Also

The CoverElementChunkCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Protected method | ClearItems | Overrides the default behavior. (Overrides C1ObservableCollection<(Of <(<'T>)>)>..::..ClearItems()()()().)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Protected method | InsertItem | Overrides the default behavior. (Overrides C1ObservableCollection<(Of <(<'T>)>)>..::..InsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Protected method | RemoveItem | Overrides the default behavior. (Overrides C1ObservableCollection<(Of <(<'T>)>)>..::..RemoveItem(Int32).)
Protected method | SetItem | Overrides the default behavior. (Overrides C1ObservableCollection<(Of <(<'T>)>)>..::..SetItem(Int32, T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)

See Also

CoverElementChunkCollection Class


ClearItems Method

[image]

.NET Framework Class Library
CoverElementChunkCollection..::..ClearItems Method
CoverElementChunkCollection Class See Also
Overrides the default behavior.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void ClearItems()
Visual Basic
Protected Overrides Sub ClearItems

See Also

CoverElementChunkCollection Class


InsertItem Method

[image]

.NET Framework Class Library
CoverElementChunkCollection..::..InsertItem Method
CoverElementChunkCollection Class See Also
Overrides the default behavior.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void InsertItem(
    int index,
    CoverElementChunk item
)
Visual Basic
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As CoverElementChunk _
)

Parameters

index
Type: System..::..Int32
item
Type: C1.Silverlight.Schedule..::..CoverElementChunk

See Also

CoverElementChunkCollection Class


RemoveItem Method

[image]

.NET Framework Class Library
CoverElementChunkCollection..::..RemoveItem Method
CoverElementChunkCollection Class See Also
Overrides the default behavior.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void RemoveItem(
    int index
)
Visual Basic
Protected Overrides Sub RemoveItem ( _
    index As Integer _
)

Parameters

index
Type: System..::..Int32

See Also

CoverElementChunkCollection Class


SetItem Method

[image]

.NET Framework Class Library
CoverElementChunkCollection..::..SetItem Method
CoverElementChunkCollection Class See Also
Overrides the default behavior.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void SetItem(
    int index,
    CoverElementChunk item
)
Visual Basic
Protected Overrides Sub SetItem ( _
    index As Integer, _
    item As CoverElementChunk _
)

Parameters

index
Type: System..::..Int32
item
Type: C1.Silverlight.Schedule..::..CoverElementChunk

See Also

CoverElementChunkCollection Class


CoverElementChunkCollection Properties

[image] [image]

.NET Framework Class Library
CoverElementChunkCollection Properties
CoverElementChunkCollection Class See Also

The CoverElementChunkCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Public property | Owner | Gets the owning CoverElement object.

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' CoverElementChunk >)>)>.)

See Also

CoverElementChunkCollection Class


Owner Property

[image]

.NET Framework Class Library
CoverElementChunkCollection..::..Owner Property
CoverElementChunkCollection Class See Also
Gets the owning CoverElement object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public CoverElement Owner { get; }
Visual Basic
Public ReadOnly Property Owner As CoverElement
    Get

See Also

CoverElementChunkCollection Class


CoverElementChunkCollection Events

[image] [image]

.NET Framework Class Library
CoverElementChunkCollection Events
CoverElementChunkCollection Class See Also

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableCollection<(Of <(<'T>)>)>.)

See Also

CoverElementChunkCollection Class


CoverElementCollection Class

[image]

.NET Framework Class Library
CoverElementCollection Class
Members See Also
The CoverElementCollection is a observable keyed collection of CoverElement objects.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultMemberAttribute("Item")]
public class CoverElementCollection : C1ObservableKeyedCollection<Object, CoverElement>
Visual Basic
<DefaultMemberAttribute("Item")> _
Public Class CoverElementCollection _
    Inherits C1ObservableKeyedCollection(Of Object, CoverElement)

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' CoverElement >)>)>
System.Collections.ObjectModel..::..KeyedCollection <(Of <(<' Object, CoverElement >)>)>
C1.C1Schedule..::..C1ObservableKeyedCollection <(Of <(<' Object, CoverElement >)>)>
C1.Silverlight.Schedule..::..CoverElementCollection

See Also

CoverElementCollection Members


CoverElementCollection Members

[image] [image]

.NET Framework Class Library
CoverElementCollection Members
CoverElementCollection Class Constructors Methods Properties Explicit Interface Implementations See Also

The CoverElementCollection type exposes the following members.

Constructors

 | Name | Description
Public method | CoverElementCollection | Initializes a new instance of the CoverElementCollection class.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection <(Of <(<' Object, CoverElement >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Protected method | ClearItems | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' Object, CoverElement >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElement >)>)> Collection<(Of <(<'T>)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKeyForItem | Returns the DataObject property value. (Overrides KeyedCollection<(Of <(<'TKey, TItem>)>)>..::..GetKeyForItem(TItem).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Protected method | InsertItem | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Object, CoverElement >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElement >)>)> Collection<(Of <(<'T>)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Protected method | RemoveItem | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Protected method | SetItem | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection <(Of <(<' Object, CoverElement >)>)>.)
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Object, CoverElement >)>)>.)
Public property | Item[([( TKey])]) | Gets the element with the specified key. (Inherited from KeyedCollection <(Of <(<' Object, CoverElement >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public property | Item[([( Int32])]) | Gets an object by index.
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Public property | Owner | Gets a reference to the owning CoverElementsPane pane.

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)

See Also

CoverElementCollection Class


CoverElementCollection Constructor

[image]

.NET Framework Class Library
CoverElementCollection Constructor
CoverElementCollection Class See Also
Initializes a new instance of the CoverElementCollection class.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public CoverElementCollection(
    CoverElementsPane owner
)
Visual Basic
Public Sub New ( _
    owner As CoverElementsPane _
)

Parameters

owner
Type: C1.Silverlight.Schedule..::..CoverElementsPane
An owning CoverElementsPane pane.

See Also

CoverElementCollection Class


CoverElementCollection Methods

[image] [image]

.NET Framework Class Library
CoverElementCollection Methods
CoverElementCollection Class See Also

The CoverElementCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection <(Of <(<' Object, CoverElement >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Protected method | ClearItems | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' Object, CoverElement >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElement >)>)> Collection<(Of <(<'T>)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKeyForItem | Returns the DataObject property value. (Overrides KeyedCollection<(Of <(<'TKey, TItem>)>)>..::..GetKeyForItem(TItem).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Protected method | InsertItem | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Object, CoverElement >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElement >)>)> Collection<(Of <(<'T>)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Protected method | RemoveItem | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Protected method | SetItem | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)

See Also

CoverElementCollection Class


Contains Method

[image] [image]

.NET Framework Class Library
CoverElementCollection..::..Contains Method
CoverElementCollection Class See Also

Overload List

 | Name | Description
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection <(Of <(<' Object, CoverElement >)>)>.)
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)

See Also

CoverElementCollection Class
CoverElementCollection Members


GetKeyForItem Method

[image]

.NET Framework Class Library
CoverElementCollection..::..GetKeyForItem Method
CoverElementCollection Class See Also
Returns the DataObject property value.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override Object GetKeyForItem(
    CoverElement item
)
Visual Basic
Protected Overrides Function GetKeyForItem ( _
    item As CoverElement _
) As Object

Parameters

item
Type: C1.Silverlight.Schedule..::..CoverElement

Return Value

See Also

CoverElementCollection Class


Remove Method

[image] [image]

.NET Framework Class Library
CoverElementCollection..::..Remove Method
CoverElementCollection Class See Also

Overload List

 | Name | Description
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Object, CoverElement >)>)>.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)

See Also

CoverElementCollection Class
CoverElementCollection Members


CoverElementCollection Properties

[image] [image]

.NET Framework Class Library
CoverElementCollection Properties
CoverElementCollection Class See Also

The CoverElementCollection type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection <(Of <(<' Object, CoverElement >)>)>.)
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' Object, CoverElement >)>)>.)
Public property | Item[([( TKey])]) | Gets the element with the specified key. (Inherited from KeyedCollection <(Of <(<' Object, CoverElement >)>)> KeyedCollection<(Of <(<'TKey, TItem>)>)>.)
Public property | Item[([( Int32])]) | Gets an object by index.
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Public property | Owner | Gets a reference to the owning CoverElementsPane pane.

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' CoverElement >)>)>.)

See Also

CoverElementCollection Class


Item Property

[image] [image]

.NET Framework Class Library
CoverElementCollection..::..Item Property
CoverElementCollection Class See Also

Overload List

 | Name | Description
Public property | Item[([( TKey])]) | Gets the element with the specified key. (Inherited from KeyedCollection <(Of <(<' Object, CoverElement >)>)>.)
Public property | Item[([( Int32])]) | Gets an object by index.

See Also

CoverElementCollection Class
CoverElementCollection Members


Item Property (Int32)

[image]

.NET Framework Class Library
CoverElementCollection..::..Item Property (Int32)
CoverElementCollection Class See Also
Gets an object by index.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public CoverElement this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    index As Integer _
) As CoverElement
    Get

Parameters

index
Type: System..::..Int32

Return Value

Remarks

The default implementation tries to get an object by key if integer value is specified.

See Also

CoverElementCollection Class
Item Overload


Owner Property

[image]

.NET Framework Class Library
CoverElementCollection..::..Owner Property
CoverElementCollection Class See Also
Gets a reference to the owning CoverElementsPane pane.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public CoverElementsPane Owner { get; }
Visual Basic
Public ReadOnly Property Owner As CoverElementsPane
    Get

See Also

CoverElementCollection Class


CoverElementCollection Events

[image] [image]

.NET Framework Class Library
CoverElementCollection Events
CoverElementCollection Class See Also

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyCollectionChanged..::..CollectionChanged | (Inherited from C1ObservableKeyedCollection<(Of <(<'TKey, TItem>)>)>.)

See Also

CoverElementCollection Class


CoverElementsPane Class

[image]

.NET Framework Class Library
CoverElementsPane Class
Members See Also
Provides a surface for painting UI elements over the arbitrary layout.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[TemplatePartAttribute(Name = "PART_ElementsCanvas", Type = typeof(Canvas))]
public class CoverElementsPane : Control,
    ICoverElementsPane
Visual Basic
<TemplatePartAttribute(Name := "PART_ElementsCanvas", Type := GetType(Canvas))> _
Public Class CoverElementsPane _
    Inherits Control _
    Implements ICoverElementsPane

Remarks

CoverElementsPane allows you to visually represent a set of UI elements relative to UI elements representing the underlying UI.

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
C1.Silverlight.Schedule..::..CoverElementsPane
C1.Silverlight.Schedule..::..AppointmentsCoverPane

See Also

CoverElementsPane Members


CoverElementsPane Members

[image] [image]

.NET Framework Class Library
CoverElementsPane Members
CoverElementsPane Class Constructors Methods Fields Properties Attached Properties Events See Also

The CoverElementsPane type exposes the following members.

Constructors

 | Name | Description
Public method | CoverElementsPane | Initializes the new instance of the CoverElementsPane pane.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
 | GetCoverElementsOverflow | Gets the value of the CoverElementsOverflow attached property for a given framework element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLaneSize | Returns the size which should be used to draw cover element according to specified sizing type, available space and total lane count.
 | GetOrientation | Gets the value of the Orientation attached property for a given framework element.
 | GetPaneName | Gets the value of the PaneName attached property for a given framework element.
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Protected method | IsPaneElementInternal | Checks whether specified element is covered by the current CoverElementsPane instance.
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | Overrides the default behavior. (Overrides FrameworkElement..::..OnApplyTemplate()()()().)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Overrides ControlOnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnMouseLeftButtonUp | Overrides the default behavior. (Overrides ControlOnMouseLeftButtonUp(MouseButtonEventArgs).)
Protected method | OnMouseMove | Overrides the default behavior. (Overrides ControlOnMouseMove(MouseEventArgs).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
 | SetCoverElementsOverflow | Sets the value of the CoverElementsOverflow attached property for a given framework element.
 | SetOrientation | Sets the value of the Orientation attached property for a given framework element.
 | SetPaneName | Sets the value of the PaneName attached property for a given framework element.
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

 | Name | Description
Protected field | _hostElementsList | Keeps the list of child FrameworkElements covered by the ICoverElementsPane which have CoverElementsPane.Orientation property set.
Protected field | _isAboutToUnload | Determines whether the pane is about to be unloaded.
Protected field | _lastStart | Might be used in derived classes during HostElementsList collection.
Protected field | _needSort | Determines whether HostElementsList should be sorted after it is filled.
 | CoverElementsHeightProperty | Obsolete. Identifies the CoverElementsHeight dependency property.
 | CoverElementsMarginProperty | Identifies the CoverElementsMargin dependency property.
 | CoverElementsOverflowProperty | Identifies the CoverElementsOverflow attached property. Being set to true on a covered element that has the OrientationProperty property set, indicates that there are too many covering elements to be represented in the element.
 | CoverElementsSizeProperty | Identifies the CoverElementsSize dependency property.
 | IsDragDropDisabledProperty | Identifies the IsDragDropDisabled dependency property.
 | OrientationProperty | Identifies the Orientation attached property.
 | OwnerProperty | Identifies the Owner dependency property.
 | PaneNameProperty | Identifies the PaneName attached property. If you use several CoverElementsPane objects in a single template, you should specify this property on a covered element that has the OrientationProperty property set. Set this value to the value of the Name property of the corresponding CoverElementsPane object.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | ChunkBreakingAngle | Gets or sets a Double value specifying the breaking angle for painted UI elements.
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ContentKind | Gets or sets the type of content acceptable by the current instance of CoverElementsPane.
Public property | CoverElementsHeight | Obsolete. Gets or sets a Double value, determining height of the cover elements. This property makes sense for horizontal orientation only. The default value is 19.
Public property | CoverElementsMargin | Gets or sets a Double value, determining margins of the cover elements.
Public property | CoverElementsSize | Gets or sets a Double value, determining the size of the cover elements. This is dependency property. The default value is 19.
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataCoverElements | Gets a list of CoverElement objects that are drawn on this CoverElementPane.
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | ExtendOnOverflow | Gets or sets a Boolean value, specifying the CoverElementsPane behavior in the case when covering elements do not fit into the available space. If False, the CoverElementsOverflowProperty will be set to True. This is default behavior. If True, the covered element will be extended in order to accommodate all covering elements.
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsDragDropDisabled | Gets or sets a Boolean value that indicates whether the CoverElementsPane doesn't allow resizing and drag operations. This is a dependency property.
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Owner | Gets the object representing the CoverElementsPane object owner. This is a dependency property. Default value is null.
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SizingType | Gets or sets the SizingType values specifying how CoverElementsPane determines UI elements size. The default value is SizingType.Fixed.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Attached Properties

 | Name | Description
Public attached property | CoverElementsOverflow |
Public attached property | Orientation |
Public attached property | PaneName |

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

CoverElementsPane Class


CoverElementsPane Constructor

[image]

.NET Framework Class Library
CoverElementsPane Constructor
CoverElementsPane Class See Also
Initializes the new instance of the CoverElementsPane pane.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public CoverElementsPane()
Visual Basic
Public Sub New

See Also

CoverElementsPane Class


CoverElementsPane Fields

[image] [image]

.NET Framework Class Library
CoverElementsPane Fields
CoverElementsPane Class See Also

The CoverElementsPane type exposes the following members.

Fields

 | Name | Description
Protected field | _hostElementsList | Keeps the list of child FrameworkElements covered by the ICoverElementsPane which have CoverElementsPane.Orientation property set.
Protected field | _isAboutToUnload | Determines whether the pane is about to be unloaded.
Protected field | _lastStart | Might be used in derived classes during HostElementsList collection.
Protected field | _needSort | Determines whether HostElementsList should be sorted after it is filled.
 | CoverElementsHeightProperty | Obsolete. Identifies the CoverElementsHeight dependency property.
 | CoverElementsMarginProperty | Identifies the CoverElementsMargin dependency property.
 | CoverElementsOverflowProperty | Identifies the CoverElementsOverflow attached property. Being set to true on a covered element that has the OrientationProperty property set, indicates that there are too many covering elements to be represented in the element.
 | CoverElementsSizeProperty | Identifies the CoverElementsSize dependency property.
 | IsDragDropDisabledProperty | Identifies the IsDragDropDisabled dependency property.
 | OrientationProperty | Identifies the Orientation attached property.
 | OwnerProperty | Identifies the Owner dependency property.
 | PaneNameProperty | Identifies the PaneName attached property. If you use several CoverElementsPane objects in a single template, you should specify this property on a covered element that has the OrientationProperty property set. Set this value to the value of the Name property of the corresponding CoverElementsPane object.

See Also

CoverElementsPane Class


_hostElementsList Field

[image]

.NET Framework Class Library
CoverElementsPane..::.._hostElementsList Field
CoverElementsPane Class See Also
Keeps the list of child FrameworkElements covered by the ICoverElementsPane which have CoverElementsPane.Orientation property set.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[CLSCompliantAttribute(false)]
protected List<FrameworkElement> _hostElementsList
Visual Basic
<CLSCompliantAttribute(False)> _
Protected _hostElementsList As List(Of FrameworkElement)

See Also

CoverElementsPane Class


_isAboutToUnload Field

[image]

.NET Framework Class Library
CoverElementsPane..::.._isAboutToUnload Field
CoverElementsPane Class See Also
Determines whether the pane is about to be unloaded.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[CLSCompliantAttribute(false)]
protected bool _isAboutToUnload
Visual Basic
<CLSCompliantAttribute(False)> _
Protected _isAboutToUnload As Boolean

See Also

CoverElementsPane Class


_lastStart Field

[image]

.NET Framework Class Library
CoverElementsPane..::.._lastStart Field
CoverElementsPane Class See Also
Might be used in derived classes during HostElementsList collection.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[CLSCompliantAttribute(false)]
protected DateTime _lastStart
Visual Basic
<CLSCompliantAttribute(False)> _
Protected _lastStart As DateTime

See Also

CoverElementsPane Class


_needSort Field

[image]

.NET Framework Class Library
CoverElementsPane..::.._needSort Field
CoverElementsPane Class See Also
Determines whether HostElementsList should be sorted after it is filled.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[CLSCompliantAttribute(false)]
protected bool _needSort
Visual Basic
<CLSCompliantAttribute(False)> _
Protected _needSort As Boolean

Remarks

Set this property to true in the IsPaneElementInternal override if collected host elements should be sorted after collection.

See Also

CoverElementsPane Class


CoverElementsHeightProperty Field

[image]

.NET Framework Class Library
CoverElementsPane..::..CoverElementsHeightProperty Field
CoverElementsPane Class See Also
Identifies the CoverElementsHeight dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[ObsoleteAttribute("This property is obsolete. Use CoverElementsSizeProperty instead.")]
public static readonly DependencyProperty CoverElementsHeightProperty
Visual Basic
<ObsoleteAttribute("This property is obsolete. Use CoverElementsSizeProperty instead.")> _
Public Shared ReadOnly CoverElementsHeightProperty As DependencyProperty

See Also

CoverElementsPane Class


CoverElementsMarginProperty Field

[image]

.NET Framework Class Library
CoverElementsPane..::..CoverElementsMarginProperty Field
CoverElementsPane Class See Also
Identifies the CoverElementsMargin dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty CoverElementsMarginProperty
Visual Basic
Public Shared ReadOnly CoverElementsMarginProperty As DependencyProperty

See Also

CoverElementsPane Class


CoverElementsOverflowProperty Field

[image]

.NET Framework Class Library
CoverElementsPane..::..CoverElementsOverflowProperty Field
CoverElementsPane Class See Also
Identifies the CoverElementsOverflow attached property. Being set to true on a covered element that has the OrientationProperty property set, indicates that there are too many covering elements to be represented in the element.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty CoverElementsOverflowProperty
Visual Basic
Public Shared ReadOnly CoverElementsOverflowProperty As DependencyProperty

See Also

CoverElementsPane Class


CoverElementsSizeProperty Field

[image]

.NET Framework Class Library
CoverElementsPane..::..CoverElementsSizeProperty Field
CoverElementsPane Class See Also
Identifies the CoverElementsSize dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty CoverElementsSizeProperty
Visual Basic
Public Shared ReadOnly CoverElementsSizeProperty As DependencyProperty

See Also

CoverElementsPane Class


IsDragDropDisabledProperty Field

[image]

.NET Framework Class Library
CoverElementsPane..::..IsDragDropDisabledProperty Field
CoverElementsPane Class See Also
Identifies the IsDragDropDisabled dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty IsDragDropDisabledProperty
Visual Basic
Public Shared ReadOnly IsDragDropDisabledProperty As DependencyProperty

See Also

CoverElementsPane Class


OrientationProperty Field

[image]

.NET Framework Class Library
CoverElementsPane..::..OrientationProperty Field
CoverElementsPane Class See Also
Identifies the Orientation attached property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty OrientationProperty
Visual Basic
Public Shared ReadOnly OrientationProperty As DependencyProperty

See Also

CoverElementsPane Class


OwnerProperty Field

[image]

.NET Framework Class Library
CoverElementsPane..::..OwnerProperty Field
CoverElementsPane Class See Also
Identifies the Owner dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty OwnerProperty
Visual Basic
Public Shared ReadOnly OwnerProperty As DependencyProperty

See Also

CoverElementsPane Class


PaneNameProperty Field

[image]

.NET Framework Class Library
CoverElementsPane..::..PaneNameProperty Field
CoverElementsPane Class See Also
Identifies the PaneName attached property. If you use several CoverElementsPane objects in a single template, you should specify this property on a covered element that has the OrientationProperty property set. Set this value to the value of the Name property of the corresponding CoverElementsPane object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty PaneNameProperty
Visual Basic
Public Shared ReadOnly PaneNameProperty As DependencyProperty

See Also

CoverElementsPane Class


CoverElementsPane Methods

[image] [image]

.NET Framework Class Library
CoverElementsPane Methods
CoverElementsPane Class See Also

The CoverElementsPane type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
 | GetCoverElementsOverflow | Gets the value of the CoverElementsOverflow attached property for a given framework element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLaneSize | Returns the size which should be used to draw cover element according to specified sizing type, available space and total lane count.
 | GetOrientation | Gets the value of the Orientation attached property for a given framework element.
 | GetPaneName | Gets the value of the PaneName attached property for a given framework element.
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Protected method | IsPaneElementInternal | Checks whether specified element is covered by the current CoverElementsPane instance.
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | Overrides the default behavior. (Overrides FrameworkElement..::..OnApplyTemplate()()()().)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Overrides ControlOnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnMouseLeftButtonUp | Overrides the default behavior. (Overrides ControlOnMouseLeftButtonUp(MouseButtonEventArgs).)
Protected method | OnMouseMove | Overrides the default behavior. (Overrides ControlOnMouseMove(MouseEventArgs).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
 | SetCoverElementsOverflow | Sets the value of the CoverElementsOverflow attached property for a given framework element.
 | SetOrientation | Sets the value of the Orientation attached property for a given framework element.
 | SetPaneName | Sets the value of the PaneName attached property for a given framework element.
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

CoverElementsPane Class


GetCoverElementsOverflow Method

[image]

.NET Framework Class Library
CoverElementsPane..::..GetCoverElementsOverflow Method
CoverElementsPane Class See Also
Gets the value of the CoverElementsOverflow attached property for a given framework element.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static bool GetCoverElementsOverflow(
    FrameworkElement element
)
Visual Basic
Public Shared Function GetCoverElementsOverflow ( _
    element As FrameworkElement _
) As Boolean

Parameters

element
Type: System.Windows..::..FrameworkElement
The FrameworkElement from which the property value is read.

Return Value

The Boolean value of the specified element.

See Also

CoverElementsPane Class


GetLaneSize Method

[image]

.NET Framework Class Library
CoverElementsPane..::..GetLaneSize Method
CoverElementsPane Class See Also
Returns the size which should be used to draw cover element according to specified sizing type, available space and total lane count.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual double GetLaneSize(
    SizingType sizingType,
    Object dataContext,
    double availableSpace,
    int totalLanes
)
Visual Basic
Protected Overridable Function GetLaneSize ( _
    sizingType As SizingType, _
    dataContext As Object, _
    availableSpace As Double, _
    totalLanes As Integer _
) As Double

Parameters

sizingType
Type: C1.Silverlight.Schedule..::..SizingType
The SizingType value.
dataContext
Type: System..::..Object
The cover element data context. It can be used to determine additional sizing conditions in overrides.
availableSpace
Type: System..::..Double
The Double value specifying avaliable size.
totalLanes
Type: System..::..Int32
The Int32 value specifying the number of intersecting elements (1 for the single element without intersection).

Return Value

The Double value specifying actual cover element size (height or width depending on the orientation.

See Also

CoverElementsPane Class


GetOrientation Method

[image]

.NET Framework Class Library
CoverElementsPane..::..GetOrientation Method
CoverElementsPane Class See Also
Gets the value of the Orientation attached property for a given framework element.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static Nullable<Orientation> GetOrientation(
    FrameworkElement element
)
Visual Basic
Public Shared Function GetOrientation ( _
    element As FrameworkElement _
) As Nullable(Of Orientation)

Parameters

element
Type: System.Windows..::..FrameworkElement
The FrameworkElement from which the property value is read.

Return Value

The Orientation value of the specified element.

See Also

CoverElementsPane Class


GetPaneName Method

[image]

.NET Framework Class Library
CoverElementsPane..::..GetPaneName Method
CoverElementsPane Class See Also
Gets the value of the PaneName attached property for a given framework element.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string GetPaneName(
    FrameworkElement element
)
Visual Basic
Public Shared Function GetPaneName ( _
    element As FrameworkElement _
) As String

Parameters

element
Type: System.Windows..::..FrameworkElement
The FrameworkElement from which the property value is read.

Return Value

The String value of the specified element.

See Also

CoverElementsPane Class


IsPaneElementInternal Method

[image]

.NET Framework Class Library
CoverElementsPane..::..IsPaneElementInternal Method
CoverElementsPane Class See Also
Checks whether specified element is covered by the current CoverElementsPane instance.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual bool IsPaneElementInternal(
    FrameworkElement element
)
Visual Basic
Protected Overridable Function IsPaneElementInternal ( _
    element As FrameworkElement _
) As Boolean

Parameters

element
Type: System.Windows..::..FrameworkElement
The FrameworkElement to check.

Return Value

Returns True if specified element is coverred by the current CoverElementsPane instance; False otherwise.

Remarks

This method is performance critical. Override it in derived class to perform faster check based on element data context and derived class properties.

See Also

CoverElementsPane Class


OnApplyTemplate Method

[image]

.NET Framework Class Library
CoverElementsPane..::..OnApplyTemplate Method
CoverElementsPane Class See Also
Overrides the default behavior.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic
Public Overrides Sub OnApplyTemplate

See Also

CoverElementsPane Class


OnMouseLeftButtonDown Method

[image]

.NET Framework Class Library
CoverElementsPane..::..OnMouseLeftButtonDown Method
CoverElementsPane Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnMouseLeftButtonDown(
    MouseButtonEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseLeftButtonDown ( _
    e As MouseButtonEventArgs _
)

Parameters

e
Type: System.Windows.Input..::..MouseButtonEventArgs

See Also

CoverElementsPane Class


OnMouseLeftButtonUp Method

[image]

.NET Framework Class Library
CoverElementsPane..::..OnMouseLeftButtonUp Method
CoverElementsPane Class See Also
Overrides the default behavior.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnMouseLeftButtonUp(
    MouseButtonEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseLeftButtonUp ( _
    e As MouseButtonEventArgs _
)

Parameters

e
Type: System.Windows.Input..::..MouseButtonEventArgs

See Also

CoverElementsPane Class


OnMouseMove Method

[image]

.NET Framework Class Library
CoverElementsPane..::..OnMouseMove Method
CoverElementsPane Class See Also
Overrides the default behavior.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)

Parameters

e
Type: System.Windows.Input..::..MouseEventArgs

See Also

CoverElementsPane Class


SetCoverElementsOverflow Method

[image]

.NET Framework Class Library
CoverElementsPane..::..SetCoverElementsOverflow Method
CoverElementsPane Class See Also
Sets the value of the CoverElementsOverflow attached property for a given framework element.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static void SetCoverElementsOverflow(
    FrameworkElement element,
    bool value
)
Visual Basic
Public Shared Sub SetCoverElementsOverflow ( _
    element As FrameworkElement, _
    value As Boolean _
)

Parameters

element
Type: System.Windows..::..FrameworkElement
The FrameworkElement for which the property value is set.
value
Type: System..::..Boolean
The Boolean value to be set on the specified element.

See Also

CoverElementsPane Class


SetOrientation Method

[image]

.NET Framework Class Library
CoverElementsPane..::..SetOrientation Method
CoverElementsPane Class See Also
Sets the value of the Orientation attached property for a given framework element.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static void SetOrientation(
    FrameworkElement element,
    Nullable<Orientation> value
)
Visual Basic
Public Shared Sub SetOrientation ( _
    element As FrameworkElement, _
    value As Nullable(Of Orientation) _
)

Parameters

element
Type: System.Windows..::..FrameworkElement
The FrameworkElement for which the property value is set.
value
Type: System..::..Nullable <(Of <(<' Orientation >)>)>
The Orientation value to be set on the specified element.

See Also

CoverElementsPane Class


SetPaneName Method

[image]

.NET Framework Class Library
CoverElementsPane..::..SetPaneName Method
CoverElementsPane Class See Also
Sets the value of the PaneName attached property for a given framework element.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static void SetPaneName(
    FrameworkElement element,
    string value
)
Visual Basic
Public Shared Sub SetPaneName ( _
    element As FrameworkElement, _
    value As String _
)

Parameters

element
Type: System.Windows..::..FrameworkElement
The FrameworkElement for which the property value is set.
value
Type: System..::..String
The String value to be set on the specified element.

See Also

CoverElementsPane Class


CoverElementsPane Properties

[image] [image]

.NET Framework Class Library
CoverElementsPane Properties
CoverElementsPane Class See Also

The CoverElementsPane type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | ChunkBreakingAngle | Gets or sets a Double value specifying the breaking angle for painted UI elements.
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ContentKind | Gets or sets the type of content acceptable by the current instance of CoverElementsPane.
Public property | CoverElementsHeight | Obsolete. Gets or sets a Double value, determining height of the cover elements. This property makes sense for horizontal orientation only. The default value is 19.
Public property | CoverElementsMargin | Gets or sets a Double value, determining margins of the cover elements.
Public property | CoverElementsSize | Gets or sets a Double value, determining the size of the cover elements. This is dependency property. The default value is 19.
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataCoverElements | Gets a list of CoverElement objects that are drawn on this CoverElementPane.
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | ExtendOnOverflow | Gets or sets a Boolean value, specifying the CoverElementsPane behavior in the case when covering elements do not fit into the available space. If False, the CoverElementsOverflowProperty will be set to True. This is default behavior. If True, the covered element will be extended in order to accommodate all covering elements.
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsDragDropDisabled | Gets or sets a Boolean value that indicates whether the CoverElementsPane doesn't allow resizing and drag operations. This is a dependency property.
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Owner | Gets the object representing the CoverElementsPane object owner. This is a dependency property. Default value is null.
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SizingType | Gets or sets the SizingType values specifying how CoverElementsPane determines UI elements size. The default value is SizingType.Fixed.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

CoverElementsPane Class


ChunkBreakingAngle Property

[image]

.NET Framework Class Library
CoverElementsPane..::..ChunkBreakingAngle Property
CoverElementsPane Class See Also
Gets or sets a Double value specifying the breaking angle for painted UI elements.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute()]
public double ChunkBreakingAngle { get; set; }
Visual Basic
<DefaultValueAttribute()> _
Public Property ChunkBreakingAngle As Double
    Get
    Set

Remarks

The CoverElementsPane lays out UI elements over the arbitrary UI. If the layout direction is changed by an angle greater than what is specified in the ChunkBreakingAngle property, then painted UI element will be broken into pieces.

See Also

CoverElementsPane Class


ContentKind Property

[image]

.NET Framework Class Library
CoverElementsPane..::..ContentKind Property
CoverElementsPane Class See Also
Gets or sets the type of content acceptable by the current instance of CoverElementsPane.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual Object ContentKind { get; set; }
Visual Basic
Public Overridable Property ContentKind As Object
    Get
    Set

See Also

CoverElementsPane Class


CoverElementsHeight Property

[image]

.NET Framework Class Library
CoverElementsPane..::..CoverElementsHeight Property
CoverElementsPane Class See Also
Gets or sets a Double value, determining height of the cover elements. This property makes sense for horizontal orientation only. The default value is 19.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[ObsoleteAttribute("This property is obsolete. Use CoverElementsSize instead.")]
public double CoverElementsHeight { get; set; }
Visual Basic
<ObsoleteAttribute("This property is obsolete. Use CoverElementsSize instead.")> _
Public Property CoverElementsHeight As Double
    Get
    Set

See Also

CoverElementsPane Class


CoverElementsMargin Property

[image]

.NET Framework Class Library
CoverElementsPane..::..CoverElementsMargin Property
CoverElementsPane Class See Also
Gets or sets a Double value, determining margins of the cover elements.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public double CoverElementsMargin { get; set; }
Visual Basic
Public Property CoverElementsMargin As Double
    Get
    Set

See Also

CoverElementsPane Class


CoverElementsSize Property

[image]

.NET Framework Class Library
CoverElementsPane..::..CoverElementsSize Property
CoverElementsPane Class See Also
Gets or sets a Double value, determining the size of the cover elements. This is dependency property. The default value is 19.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public double CoverElementsSize { get; set; }
Visual Basic
Public Property CoverElementsSize As Double
    Get
    Set

Remarks

This property value determines either height or width of the cover elements depending on the Orientation property value. For horizontal orientation this property determines element height, and for vertical orientation it determines element width. Note, this property only makes sense if SizingType property value is SizingType.Fixed or SizingType.ExtendedSingle.

See Also

CoverElementsPane Class


DataCoverElements Property

[image]

.NET Framework Class Library
CoverElementsPane..::..DataCoverElements Property
CoverElementsPane Class See Also
Gets a list of CoverElement objects that are drawn on this CoverElementPane.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public CoverElementCollection DataCoverElements { get; }
Visual Basic
Public ReadOnly Property DataCoverElements As CoverElementCollection
    Get

See Also

CoverElementsPane Class


ExtendOnOverflow Property

[image]

.NET Framework Class Library
CoverElementsPane..::..ExtendOnOverflow Property
CoverElementsPane Class See Also
Gets or sets a Boolean value, specifying the CoverElementsPane behavior in the case when covering elements do not fit into the available space. If False, the CoverElementsOverflowProperty will be set to True. This is default behavior. If True, the covered element will be extended in order to accommodate all covering elements.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(false)]
public bool ExtendOnOverflow { get; set; }
Visual Basic
<DefaultValueAttribute(False)> _
Public Property ExtendOnOverflow As Boolean
    Get
    Set

See Also

CoverElementsPane Class


IsDragDropDisabled Property

[image]

.NET Framework Class Library
CoverElementsPane..::..IsDragDropDisabled Property
CoverElementsPane Class See Also
Gets or sets a Boolean value that indicates whether the CoverElementsPane doesn't allow resizing and drag operations. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsDragDropDisabled { get; set; }
Visual Basic
Public Property IsDragDropDisabled As Boolean
    Get
    Set

See Also

CoverElementsPane Class


Owner Property

[image]

.NET Framework Class Library
CoverElementsPane..::..Owner Property
CoverElementsPane Class See Also
Gets the object representing the CoverElementsPane object owner. This is a dependency property. Default value is null.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(null)]
public Object Owner { get; set; }
Visual Basic
<DefaultValueAttribute(Nothing)> _
Public Property Owner As Object
    Get
    Set

Remarks

The CoverElementsPane class doesn't use this property. It is meant for using by external or derived classes.

See Also

CoverElementsPane Class


SizingType Property

[image]

.NET Framework Class Library
CoverElementsPane..::..SizingType Property
CoverElementsPane Class See Also
Gets or sets the SizingType values specifying how CoverElementsPane determines UI elements size. The default value is SizingType.Fixed.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(SizingType.Fixed)]
public SizingType SizingType { get; set; }
Visual Basic
<DefaultValueAttribute(SizingType.Fixed)> _
Public Property SizingType As SizingType
    Get
    Set

See Also

CoverElementsPane Class


CoverElementsPane Events

[image] [image]

.NET Framework Class Library
CoverElementsPane Events
CoverElementsPane Class See Also

The CoverElementsPane type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

CoverElementsPane Class


CoverElementsPane Attached Properties

[image] [image]

.NET Framework Class Library
CoverElementsPane Attached Properties
CoverElementsPane Class See Also

The CoverElementsPane type exposes the following members.

Attached Properties

 | Name | Description
Public attached property | CoverElementsOverflow |
Public attached property | Orientation |
Public attached property | PaneName |

See Also

CoverElementsPane Class


CoverElementsOverflow Attached Property

[image]

.NET Framework Class Library
CoverElementsPane..::..CoverElementsOverflow Attached Property
CoverElementsPane Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
See GetCoverElementsOverflow, SetCoverElementsOverflow
Visual Basic
See GetCoverElementsOverflow, SetCoverElementsOverflow

See Also

CoverElementsPane Class


Orientation Attached Property

[image]

.NET Framework Class Library
CoverElementsPane..::..Orientation Attached Property
CoverElementsPane Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
See GetOrientation, SetOrientation
Visual Basic
See GetOrientation, SetOrientation

See Also

CoverElementsPane Class


PaneName Attached Property

[image]

.NET Framework Class Library
CoverElementsPane..::..PaneName Attached Property
CoverElementsPane Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
See GetPaneName, SetPaneName
Visual Basic
See GetPaneName, SetPaneName

See Also

CoverElementsPane Class


DateFormatIndexer Class

[image]

.NET Framework Class Library
DateFormatIndexer Class
Members See Also
The DateFormatIndexer class represents an object returning formatted DateTime string by the indexer property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[ObsoleteAttribute("This class is obsolete and will be removed in the future. Use System.Windows.Data.BindingBase.StringFormat instead.")]
[DefaultMemberAttribute("Item")]
public class DateFormatIndexer
Visual Basic
<ObsoleteAttribute("This class is obsolete and will be removed in the future. Use System.Windows.Data.BindingBase.StringFormat instead.")> _
<DefaultMemberAttribute("Item")> _
Public Class DateFormatIndexer

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..DateFormatIndexer

See Also

DateFormatIndexer Members


DateFormatIndexer Members

[image] [image]

.NET Framework Class Library
DateFormatIndexer Members
DateFormatIndexer Class Methods Properties See Also

The DateFormatIndexer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Gets a string representation of underlying DateTime value according to the specified format.

See Also

DateFormatIndexer Class


DateFormatIndexer Methods

[image] [image]

.NET Framework Class Library
DateFormatIndexer Methods
DateFormatIndexer Class See Also

The DateFormatIndexer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DateFormatIndexer Class


DateFormatIndexer Properties

[image] [image]

.NET Framework Class Library
DateFormatIndexer Properties
DateFormatIndexer Class See Also

The DateFormatIndexer type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets a string representation of underlying DateTime value according to the specified format.

See Also

DateFormatIndexer Class


Item Property

[image]

.NET Framework Class Library
DateFormatIndexer..::..Item Property
DateFormatIndexer Class See Also
Gets a string representation of underlying DateTime value according to the specified format.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string this[
    string format
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    format As String _
) As String
    Get

Parameters

format
Type: System..::..String
Date format string.

Return Value

A string representation of underlying DateTime value.

See Also

DateFormatIndexer Class


DateList Class

[image]

.NET Framework Class Library
DateList Class
Members See Also
The DateList class represents the observable collection of DateTime values. The collection contains unique values only. Every item in collection is a DateTime value containing the date part only.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class DateList : ReentrantObservableCollection<DateTime>
Visual Basic
Public Class DateList _
    Inherits ReentrantObservableCollection(Of DateTime)

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' DateTime >)>)>
C1.Silverlight.Schedule..::..ReentrantObservableCollection <(Of <(<' DateTime >)>)>
C1.Silverlight.Schedule..::..DateList

See Also

DateList Members


DateList Members

[image] [image]

.NET Framework Class Library
DateList Members
DateList Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The DateList type exposes the following members.

Constructors

 | Name | Description
Public method | DateList | Initializes a new instance of the DateList collection.

Methods

 | Name | Description
Public method | Add | Adds a DateTime value to the end of the Collection.
Public method | BeginUpdate | Prevents raising events until the EndUpdate()()()() method is called. (Inherited from ReentrantObservableCollection<(Of <(<'T>)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Protected method | ClearItems | Overrides the default behavior. (Inherited from ReentrantObservableCollection<(Of <(<'T>)>)>.)
Public method | Contains | Returns true if specified item exists in the Collection.
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Public method | EndUpdate | Enables raising events. If collection has been changed since the call to the BeginUpdate()()()() method, raises PropertyChanged and CollectionChanged events. (Inherited from ReentrantObservableCollection<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Protected method | InsertItem | Overrides the default behavior. (Inherited from ReentrantObservableCollection<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ReentrantObservableCollection<(Of <(<'T>)>)>.)
Protected method | MoveItem | Implements item moving from one location to another. (Inherited from ReentrantObservableCollection<(Of <(<'T>)>)>.)
Protected method | OnCollectionChanged | Raises CollectionChanged event if the ReentrantObservableCollection<(Of <(<'T>)>)> is not in update mode. (Inherited from ReentrantObservableCollection<(Of <(<'T>)>)>.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Protected method | RemoveItem | Overrides the default behavior. (Inherited from ReentrantObservableCollection<(Of <(<'T>)>)>.)
Protected method | SetItem | Overrides the default behavior. (Inherited from ReentrantObservableCollection<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Public property | InUpdate | Gets a Boolean value determining whether the ReentrantObservableCollection<(Of <(<'T>)>)> is in update mode (BeginUpdate()()()() has been called). (Inherited from ReentrantObservableCollection<(Of <(<'T>)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)

Events

 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ReentrantObservableCollection<(Of <(<'T>)>)>.)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ReentrantObservableCollection<(Of <(<'T>)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged | (Inherited from ReentrantObservableCollection<(Of <(<'T>)>)>.)
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' DateTime >)>)>.)

See Also

DateList Class


DateList Constructor

[image]

.NET Framework Class Library
DateList Constructor
DateList Class See Also
Initializes a new instance of the DateList collection.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateList()
Visual Basic
Public Sub New

See Also

DateList Class


DateList Methods

[image] [image]

.NET Framework Class Library
DateList Methods
DateList Class See Also

The DateList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a DateTime value to the end of the Collection.
Public method | BeginUpdate | Prevents raising events until the EndUpdate()()()() method is called. (Inherited from ReentrantObservableCollection<(Of <(<'T>)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Protected method | ClearItems | Overrides the default behavior. (Inherited from ReentrantObservableCollection<(Of <(<'T>)>)>.)
Public method | Contains | Returns true if specified item exists in the Collection.
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Public method | EndUpdate | Enables raising events. If collection has been changed since the call to the BeginUpdate()()()() method, raises PropertyChanged and CollectionChanged events. (Inherited from ReentrantObservableCollection<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Protected method | InsertItem | Overrides the default behavior. (Inherited from ReentrantObservableCollection<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ReentrantObservableCollection<(Of <(<'T>)>)>.)
Protected method | MoveItem | Implements item moving from one location to another. (Inherited from ReentrantObservableCollection<(Of <(<'T>)>)>.)
Protected method | OnCollectionChanged | Raises CollectionChanged event if the ReentrantObservableCollection<(Of <(<'T>)>)> is not in update mode. (Inherited from ReentrantObservableCollection<(Of <(<'T>)>)>.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Protected method | RemoveItem | Overrides the default behavior. (Inherited from ReentrantObservableCollection<(Of <(<'T>)>)>.)
Protected method | SetItem | Overrides the default behavior. (Inherited from ReentrantObservableCollection<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' DateTime >)>)>.)

See Also

DateList Class


Add Method

[image]

.NET Framework Class Library
DateList..::..Add Method
DateList Class See Also
Adds a DateTime value to the end of the Collection.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void Add(
    DateTime item
)
Visual Basic
Public Sub Add ( _
    item As DateTime _
)

Parameters

item
Type: System..::..DateTime
The DateTime value to be added to the end of the Collection.

See Also

DateList Class


Contains Method

[image]

.NET Framework Class Library
DateList..::..Contains Method
DateList Class See Also
Returns true if specified item exists in the Collection.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool Contains(
    DateTime item
)
Visual Basic
Public Function Contains ( _
    item As DateTime _
) As Boolean

Parameters

item
Type: System..::..DateTime
An item to search for.

Return Value

True if item exists in the Collection.

See Also

DateList Class


DateList Properties

[image] [image]

.NET Framework Class Library
DateList Properties
DateList Class See Also

The DateList type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Public property | InUpdate | Gets a Boolean value determining whether the ReentrantObservableCollection<(Of <(<'T>)>)> is in update mode (BeginUpdate()()()() has been called). (Inherited from ReentrantObservableCollection<(Of <(<'T>)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' DateTime >)>)>.)

See Also

DateList Class


DateList Events

[image] [image]

.NET Framework Class Library
DateList Events
DateList Class See Also

The DateList type exposes the following members.

Events

 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ReentrantObservableCollection<(Of <(<'T>)>)>.)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ReentrantObservableCollection<(Of <(<'T>)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged | (Inherited from ReentrantObservableCollection<(Of <(<'T>)>)>.)

See Also

DateList Class


DateTimeInfo Class

[image]

.NET Framework Class Library
DateTimeInfo Class
Members See Also
Provides additional info about a DateTime in a specified culture.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class DateTimeInfo : INotifyPropertyChanged
Visual Basic
Public Class DateTimeInfo _
    Implements INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..DateTimeInfo

See Also

DateTimeInfo Members


DateTimeInfo Members

[image] [image]

.NET Framework Class Library
DateTimeInfo Members
DateTimeInfo Class Constructors Methods Properties Events See Also

The DateTimeInfo type exposes the following members.

Constructors

 | Name | Description
Public method | DateTimeInfo | Initializes the new instance of the DateTimeInfo class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BaseDateTime | The base DateTime value.
Public property | CalendarHelper | Gets the CalendarHelper object which is used for retrieving calendar specific information.
Public property | FormattedDate | Obsolete. Gets the DateFormatIndexer object.
Public property | IsWeekend | Gets the Boolean value determining whether this date is weekend or holiday.
Public property | MonthFullName | Gets the full month name according to the CalendarHelper culture settings.
Public property | WeekOfYear | Gets a week of year number.
Public property | WeekOfYearFullWeek | Gets a week number in a supposition that last days of a year and the first days of a next year that belongs to the same week having the same week number.
Public property | Year | Gets the String value determining the year representation according to the CalendarHelper culture settings.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when property value is changed.

See Also

DateTimeInfo Class


DateTimeInfo Constructor

[image]

.NET Framework Class Library
DateTimeInfo Constructor
DateTimeInfo Class See Also
Initializes the new instance of the DateTimeInfo class.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTimeInfo(
    DateTime baseDateTime,
    CalendarHelper helper
)
Visual Basic
Public Sub New ( _
    baseDateTime As DateTime, _
    helper As CalendarHelper _
)

Parameters

baseDateTime
Type: System..::..DateTime
The base DateTime value.
helper
Type: C1.Silverlight.Schedule..::..CalendarHelper
The CalendarHelper object holding the calendar specific information.

See Also

DateTimeInfo Class


DateTimeInfo Methods

[image] [image]

.NET Framework Class Library
DateTimeInfo Methods
DateTimeInfo Class See Also

The DateTimeInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DateTimeInfo Class


DateTimeInfo Properties

[image] [image]

.NET Framework Class Library
DateTimeInfo Properties
DateTimeInfo Class See Also

The DateTimeInfo type exposes the following members.

Properties

 | Name | Description
Public property | BaseDateTime | The base DateTime value.
Public property | CalendarHelper | Gets the CalendarHelper object which is used for retrieving calendar specific information.
Public property | FormattedDate | Obsolete. Gets the DateFormatIndexer object.
Public property | IsWeekend | Gets the Boolean value determining whether this date is weekend or holiday.
Public property | MonthFullName | Gets the full month name according to the CalendarHelper culture settings.
Public property | WeekOfYear | Gets a week of year number.
Public property | WeekOfYearFullWeek | Gets a week number in a supposition that last days of a year and the first days of a next year that belongs to the same week having the same week number.
Public property | Year | Gets the String value determining the year representation according to the CalendarHelper culture settings.

See Also

DateTimeInfo Class


BaseDateTime Property

[image]

.NET Framework Class Library
DateTimeInfo..::..BaseDateTime Property
DateTimeInfo Class See Also
The base DateTime value.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTime BaseDateTime { get; }
Visual Basic
Public ReadOnly Property BaseDateTime As DateTime
    Get

See Also

DateTimeInfo Class


CalendarHelper Property

[image]

.NET Framework Class Library
DateTimeInfo..::..CalendarHelper Property
DateTimeInfo Class See Also
Gets the CalendarHelper object which is used for retrieving calendar specific information.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public CalendarHelper CalendarHelper { get; }
Visual Basic
Public ReadOnly Property CalendarHelper As CalendarHelper
    Get

See Also

DateTimeInfo Class


FormattedDate Property

[image]

.NET Framework Class Library
DateTimeInfo..::..FormattedDate Property
DateTimeInfo Class See Also
Gets the DateFormatIndexer object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[ObsoleteAttribute("This property is obsolete and will be removed in the future. Use System.Windows.Data.BindingBase.StringFormat instead.")]
public DateFormatIndexer FormattedDate { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete and will be removed in the future. Use System.Windows.Data.BindingBase.StringFormat instead.")> _
Public ReadOnly Property FormattedDate As DateFormatIndexer
    Get

See Also

DateTimeInfo Class


IsWeekend Property

[image]

.NET Framework Class Library
DateTimeInfo..::..IsWeekend Property
DateTimeInfo Class See Also
Gets the Boolean value determining whether this date is weekend or holiday.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsWeekend { get; }
Visual Basic
Public ReadOnly Property IsWeekend As Boolean
    Get

See Also

DateTimeInfo Class


MonthFullName Property

[image]

.NET Framework Class Library
DateTimeInfo..::..MonthFullName Property
DateTimeInfo Class See Also
Gets the full month name according to the CalendarHelper culture settings.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string MonthFullName { get; }
Visual Basic
Public ReadOnly Property MonthFullName As String
    Get

See Also

DateTimeInfo Class


WeekOfYear Property

[image]

.NET Framework Class Library
DateTimeInfo..::..WeekOfYear Property
DateTimeInfo Class See Also
Gets a week of year number.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public int WeekOfYear { get; }
Visual Basic
Public ReadOnly Property WeekOfYear As Integer
    Get

See Also

DateTimeInfo Class


WeekOfYearFullWeek Property

[image]

.NET Framework Class Library
DateTimeInfo..::..WeekOfYearFullWeek Property
DateTimeInfo Class See Also
Gets a week number in a supposition that last days of a year and the first days of a next year that belongs to the same week having the same week number.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public int WeekOfYearFullWeek { get; }
Visual Basic
Public ReadOnly Property WeekOfYearFullWeek As Integer
    Get

See Also

DateTimeInfo Class


Year Property

[image]

.NET Framework Class Library
DateTimeInfo..::..Year Property
DateTimeInfo Class See Also
Gets the String value determining the year representation according to the CalendarHelper culture settings.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string Year { get; }
Visual Basic
Public ReadOnly Property Year As String
    Get

See Also

DateTimeInfo Class


DateTimeInfo Events

[image] [image]

.NET Framework Class Library
DateTimeInfo Events
DateTimeInfo Class See Also

The DateTimeInfo type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when property value is changed.

See Also

DateTimeInfo Class


PropertyChanged Event

[image]

.NET Framework Class Library
DateTimeInfo..::..PropertyChanged Event
DateTimeInfo Class See Also
Occurs when property value is changed.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

DateTimeInfo Class


DateTimeInterval Class

[image]

.NET Framework Class Library
DateTimeInterval Class
Members See Also
The DateTimeInterval object represents a continuous interval of time.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class DateTimeInterval
Visual Basic
Public Class DateTimeInterval

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..DateTimeInterval

See Also

DateTimeInterval Members


DateTimeInterval Members

[image] [image]

.NET Framework Class Library
DateTimeInterval Members
DateTimeInterval Class Constructors Methods Properties See Also

The DateTimeInterval type exposes the following members.

Constructors

 | Name | Description
Public method | DateTimeInterval | Initializes a new instance of the DateTimeInterval class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | End | Gets or sets the DateTime value representing the end of the interval.
Public property | IsFullDay | Gets the Boolean value, determining if the DateTimeInterval object represents one or more full days.
Public property | Start | Gets or sets the DateTime value representing the beginning of the interval.

See Also

DateTimeInterval Class


DateTimeInterval Constructor

[image]

.NET Framework Class Library
DateTimeInterval Constructor
DateTimeInterval Class See Also
Initializes a new instance of the DateTimeInterval class.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTimeInterval(
    DateTime start,
    DateTime end
)
Visual Basic
Public Sub New ( _
    start As DateTime, _
    end As DateTime _
)

Parameters

start
Type: System..::..DateTime
The DateTime value representing the beginning of the interval.
end
Type: System..::..DateTime
The DateTime value representing the end of the interval.

See Also

DateTimeInterval Class


DateTimeInterval Methods

[image] [image]

.NET Framework Class Library
DateTimeInterval Methods
DateTimeInterval Class See Also

The DateTimeInterval type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DateTimeInterval Class


DateTimeInterval Properties

[image] [image]

.NET Framework Class Library
DateTimeInterval Properties
DateTimeInterval Class See Also

The DateTimeInterval type exposes the following members.

Properties

 | Name | Description
Public property | End | Gets or sets the DateTime value representing the end of the interval.
Public property | IsFullDay | Gets the Boolean value, determining if the DateTimeInterval object represents one or more full days.
Public property | Start | Gets or sets the DateTime value representing the beginning of the interval.

See Also

DateTimeInterval Class


End Property

[image]

.NET Framework Class Library
DateTimeInterval..::..End Property
DateTimeInterval Class See Also
Gets or sets the DateTime value representing the end of the interval.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTime End { get; set; }
Visual Basic
Public Property End As DateTime
    Get
    Set

See Also

DateTimeInterval Class


IsFullDay Property

[image]

.NET Framework Class Library
DateTimeInterval..::..IsFullDay Property
DateTimeInterval Class See Also
Gets the Boolean value, determining if the DateTimeInterval object represents one or more full days.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsFullDay { get; }
Visual Basic
Public ReadOnly Property IsFullDay As Boolean
    Get

See Also

DateTimeInterval Class


Start Property

[image]

.NET Framework Class Library
DateTimeInterval..::..Start Property
DateTimeInterval Class See Also
Gets or sets the DateTime value representing the beginning of the interval.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTime Start { get; set; }
Visual Basic
Public Property Start As DateTime
    Get
    Set

See Also

DateTimeInterval Class


DateTimePropertyChangeEventArgs Class

[image]

.NET Framework Class Library
DateTimePropertyChangeEventArgs Class
Members See Also
The DateTimePropertyChangeEventArgs class describes routed event data for the DateTime property changing events.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class DateTimePropertyChangeEventArgs : PropertyChangeEventArgsBase
Visual Basic
Public Class DateTimePropertyChangeEventArgs _
    Inherits PropertyChangeEventArgsBase

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.Windows..::..RoutedEventArgs
C1.Silverlight.Schedule..::..PropertyChangeEventArgsBase
C1.Silverlight.Schedule..::..DateTimePropertyChangeEventArgs

See Also

DateTimePropertyChangeEventArgs Members


DateTimePropertyChangeEventArgs Members

[image] [image]

.NET Framework Class Library
DateTimePropertyChangeEventArgs Members
DateTimePropertyChangeEventArgs Class Constructors Methods Properties See Also

The DateTimePropertyChangeEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | DateTimePropertyChangeEventArgs | Initializes a new instance of the DateTimePropertyChangeEventArgs class with the specified dependency property, old and new DateTime value.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | NewValue | Gets a new property value.
Public property | OldValue | Gets an old property value.
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)
Public property | Property | Gets a DependencyProperty object. (Inherited from PropertyChangeEventArgsBase.)

See Also

DateTimePropertyChangeEventArgs Class


DateTimePropertyChangeEventArgs Constructor

[image]

.NET Framework Class Library
DateTimePropertyChangeEventArgs Constructor
DateTimePropertyChangeEventArgs Class See Also
Initializes a new instance of the DateTimePropertyChangeEventArgs class with the specified dependency property, old and new DateTime value.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTimePropertyChangeEventArgs(
    DependencyProperty property,
    DateTime oldValue,
    DateTime newValue
)
Visual Basic
Public Sub New ( _
    property As DependencyProperty, _
    oldValue As DateTime, _
    newValue As DateTime _
)

Parameters

property
Type: System.Windows..::..DependencyProperty
The DependencyProperty.
oldValue
Type: System..::..DateTime
The old value of the specified property.
newValue
Type: System..::..DateTime
The new value of the specified property.

See Also

DateTimePropertyChangeEventArgs Class


DateTimePropertyChangeEventArgs Methods

[image] [image]

.NET Framework Class Library
DateTimePropertyChangeEventArgs Methods
DateTimePropertyChangeEventArgs Class See Also

The DateTimePropertyChangeEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DateTimePropertyChangeEventArgs Class


DateTimePropertyChangeEventArgs Properties

[image] [image]

.NET Framework Class Library
DateTimePropertyChangeEventArgs Properties
DateTimePropertyChangeEventArgs Class See Also

The DateTimePropertyChangeEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | NewValue | Gets a new property value.
Public property | OldValue | Gets an old property value.
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)
Public property | Property | Gets a DependencyProperty object. (Inherited from PropertyChangeEventArgsBase.)

See Also

DateTimePropertyChangeEventArgs Class


NewValue Property

[image]

.NET Framework Class Library
DateTimePropertyChangeEventArgs..::..NewValue Property
DateTimePropertyChangeEventArgs Class See Also
Gets a new property value.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTime NewValue { get; }
Visual Basic
Public ReadOnly Property NewValue As DateTime
    Get

See Also

DateTimePropertyChangeEventArgs Class


OldValue Property

[image]

.NET Framework Class Library
DateTimePropertyChangeEventArgs..::..OldValue Property
DateTimePropertyChangeEventArgs Class See Also
Gets an old property value.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTime OldValue { get; }
Visual Basic
Public ReadOnly Property OldValue As DateTime
    Get

See Also

DateTimePropertyChangeEventArgs Class


DateTimeToStringConverter Class

[image]

.NET Framework Class Library
DateTimeToStringConverter Class
Members See Also
Represents a Binding converter that converts a DateTime to one of its string representations.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class DateTimeToStringConverter : IValueConverter
Visual Basic
Public Class DateTimeToStringConverter _
    Implements IValueConverter

Remarks

DateTimeToStringConverter is a two-way converter. The source value must be the DateTime, and a target value is a string that represents the DateTime according to a format specifier defined in a converter parameter. The format specifier definition rules are the same as used in the System.DateTime.ToString(format) method. A back conversion is performed via the DateTime.DateTime.TryParseExact method if converter parameter is specified; otherwise, the DateTime.DateTime.TryParse method is used.

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..DateTimeToStringConverter

See Also

DateTimeToStringConverter Members


DateTimeToStringConverter Members

[image] [image]

.NET Framework Class Library
DateTimeToStringConverter Members
DateTimeToStringConverter Class Constructors Methods Fields See Also

The DateTimeToStringConverter type exposes the following members.

Constructors

 | Name | Description
Public method | DateTimeToStringConverter | Initializes a new instance of the DateTimeToStringConverter.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Default | Gets an instance of DateTimeToStringConverter.

See Also

DateTimeToStringConverter Class


DateTimeToStringConverter Constructor

[image]

.NET Framework Class Library
DateTimeToStringConverter Constructor
DateTimeToStringConverter Class See Also
Initializes a new instance of the DateTimeToStringConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTimeToStringConverter()
Visual Basic
Public Sub New

See Also

DateTimeToStringConverter Class


DateTimeToStringConverter Fields

[image] [image]

.NET Framework Class Library
DateTimeToStringConverter Fields
DateTimeToStringConverter Class See Also

The DateTimeToStringConverter type exposes the following members.

Fields

Name | Description
Default | Gets an instance of DateTimeToStringConverter.

See Also

DateTimeToStringConverter Class


Default Field

[image]

.NET Framework Class Library
DateTimeToStringConverter..::..Default Field
DateTimeToStringConverter Class See Also
Gets an instance of DateTimeToStringConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DateTimeToStringConverter Default
Visual Basic
Public Shared ReadOnly Default As DateTimeToStringConverter

See Also

DateTimeToStringConverter Class


DateTimeToStringConverter Methods

[image] [image]

.NET Framework Class Library
DateTimeToStringConverter Methods
DateTimeToStringConverter Class See Also

The DateTimeToStringConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DateTimeToStringConverter Class


Convert Method

[image]

.NET Framework Class Library
DateTimeToStringConverter..::..Convert Method
DateTimeToStringConverter Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

DateTimeToStringConverter Class


ConvertBack Method

[image]

.NET Framework Class Library
DateTimeToStringConverter..::..ConvertBack Method
DateTimeToStringConverter Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value that is produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

DateTimeToStringConverter Class


DayGroupStyleSelector Class

[image]

.NET Framework Class Library
DayGroupStyleSelector Class
Members See Also
This class provides a way to apply day group styles in DayView/WorkWeekView modes.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class DayGroupStyleSelector : C1StyleSelector
Visual Basic
Public Class DayGroupStyleSelector _
    Inherits C1StyleSelector

Remarks

For the sample of using look at OneDayStyle in themes/SchedulerThemes/Office2007/Blue.xaml.

  1. Create an instance of this class:

    <local:DayGroupStyleSelector x:Key="DayGroupStyleSelector"/>

  2. Define two group styles:
    • with the key "PART_C1Scheduler_Day_Style" for ordinal day style;
    • with the key "PART_C1Scheduler_Today_Style" for the current day style.

  3. Specify style selector in the group definition:

    <GroupStyle ContainerStyleSelector="{StaticResource DayGroupStyleSelector}"/>

Inheritance Hierarchy

System..::..Object
C1StyleSelector
C1.Silverlight.Schedule..::..DayGroupStyleSelector

See Also

DayGroupStyleSelector Members


DayGroupStyleSelector Members

[image] [image]

.NET Framework Class Library
DayGroupStyleSelector Members
DayGroupStyleSelector Class Constructors Methods Properties See Also

The DayGroupStyleSelector type exposes the following members.

Constructors

 | Name | Description
Public method | DayGroupStyleSelector |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SelectStyle | Returns the Style object for the specified group if it is found in resources. (Overrides C1StyleSelectorSelectStyle(Object, DependencyObject).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Resources | (Inherited from C1StyleSelector.)

See Also

DayGroupStyleSelector Class


DayGroupStyleSelector Constructor

[image]

.NET Framework Class Library
DayGroupStyleSelector Constructor
DayGroupStyleSelector Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DayGroupStyleSelector()
Visual Basic
Public Sub New

See Also

DayGroupStyleSelector Class


DayGroupStyleSelector Methods

[image] [image]

.NET Framework Class Library
DayGroupStyleSelector Methods
DayGroupStyleSelector Class See Also

The DayGroupStyleSelector type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SelectStyle | Returns the Style object for the specified group if it is found in resources. (Overrides C1StyleSelectorSelectStyle(Object, DependencyObject).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DayGroupStyleSelector Class


SelectStyle Method

[image]

.NET Framework Class Library
DayGroupStyleSelector..::..SelectStyle Method
DayGroupStyleSelector Class See Also
Returns the Style object for the specified group if it is found in resources.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override Style SelectStyle(
    Object item,
    DependencyObject container
)
Visual Basic
Public Overrides Function SelectStyle ( _
    item As Object, _
    container As DependencyObject _
) As Style

Parameters

item
Type: System..::..Object
The content.
container
Type: System.Windows..::..DependencyObject
The element to which the style will be applied.

Return Value

Returns an application-specific style to apply; otherwise, a null reference (Nothing in Visual Basic).

See Also

DayGroupStyleSelector Class


DayGroupStyleSelector Properties

[image] [image]

.NET Framework Class Library
DayGroupStyleSelector Properties
DayGroupStyleSelector Class See Also

The DayGroupStyleSelector type exposes the following members.

Properties

 | Name | Description
Public property | Resources | (Inherited from C1StyleSelector.)

See Also

DayGroupStyleSelector Class


DayIntervalStyleSelector Class

[image]

.NET Framework Class Library
DayIntervalStyleSelector Class
Members See Also
This class provides a way to apply day group styles for ordinal/current days.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class DayIntervalStyleSelector : C1StyleSelector
Visual Basic
Public Class DayIntervalStyleSelector _
    Inherits C1StyleSelector

Remarks

For the sample of using look at OneDayStyleBase in generic.xaml.

  1. Create an instance of this class:

    <local:DayIntervalStyleSelector x:Key="DayIntervalStyleSelector"/>

  2. Define two group styles:
    • with the key "C1Scheduler_Day_Style" for ordinal days;
    • with the key "C1Scheduler_Today_Style" for the current day.

  3. Specify style selector in the group definition:

    <GroupStyle ContainerStyleSelector="{StaticResource DayIntervalStyleSelector}">

Inheritance Hierarchy

System..::..Object
C1StyleSelector
C1.Silverlight.Schedule..::..DayIntervalStyleSelector

See Also

DayIntervalStyleSelector Members


DayIntervalStyleSelector Members

[image] [image]

.NET Framework Class Library
DayIntervalStyleSelector Members
DayIntervalStyleSelector Class Constructors Methods Properties See Also

The DayIntervalStyleSelector type exposes the following members.

Constructors

 | Name | Description
Public method | DayIntervalStyleSelector |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SelectStyle | (Overrides C1StyleSelectorSelectStyle(Object, DependencyObject).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Resources | (Inherited from C1StyleSelector.)

See Also

DayIntervalStyleSelector Class


DayIntervalStyleSelector Constructor

[image]

.NET Framework Class Library
DayIntervalStyleSelector Constructor
DayIntervalStyleSelector Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DayIntervalStyleSelector()
Visual Basic
Public Sub New

See Also

DayIntervalStyleSelector Class


DayIntervalStyleSelector Methods

[image] [image]

.NET Framework Class Library
DayIntervalStyleSelector Methods
DayIntervalStyleSelector Class See Also

The DayIntervalStyleSelector type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SelectStyle | (Overrides C1StyleSelectorSelectStyle(Object, DependencyObject).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DayIntervalStyleSelector Class


SelectStyle Method

[image]

.NET Framework Class Library
DayIntervalStyleSelector..::..SelectStyle Method
DayIntervalStyleSelector Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override Style SelectStyle(
    Object item,
    DependencyObject container
)
Visual Basic
Public Overrides Function SelectStyle ( _
    item As Object, _
    container As DependencyObject _
) As Style

Parameters

item
Type: System..::..Object
container
Type: System.Windows..::..DependencyObject

See Also

DayIntervalStyleSelector Class


DayIntervalStyleSelector Properties

[image] [image]

.NET Framework Class Library
DayIntervalStyleSelector Properties
DayIntervalStyleSelector Class See Also

The DayIntervalStyleSelector type exposes the following members.

Properties

 | Name | Description
Public property | Resources | (Inherited from C1StyleSelector.)

See Also

DayIntervalStyleSelector Class


DayOfWeekSlot Class

[image]

.NET Framework Class Library
DayOfWeekSlot Class
Members See Also
Provides a data about a day of a week for the DaysOfWeekPresenter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class DayOfWeekSlot : DependencyObject
Visual Basic
Public Class DayOfWeekSlot _
    Inherits DependencyObject

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
C1.Silverlight.Schedule..::..DayOfWeekSlot

See Also

DayOfWeekSlot Members


DayOfWeekSlot Members

[image] [image]

.NET Framework Class Library
DayOfWeekSlot Members
DayOfWeekSlot Class Methods Properties See Also

The DayOfWeekSlot type exposes the following members.

Methods

 | Name | Description
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DayFullName | Gets a culture specific full name for the DayOfWeek.
Public property | DayOfWeek | Gets a day of a week represented by the DayOfWeekSlot.
Public property | DayShortestName | Gets a culture specific shortest name for the DayOfWeek.
Public property | DayShortName | Gets a culture specific short name for the DayOfWeek.
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | IsWeekend | Indicates whether the DayOfWeek is a weekend.
Public property | Owner | Returns reference to the owning C1CalendarItem control.

See Also

DayOfWeekSlot Class


DayOfWeekSlot Methods

[image] [image]

.NET Framework Class Library
DayOfWeekSlot Methods
DayOfWeekSlot Class See Also

The DayOfWeekSlot type exposes the following members.

Methods

 | Name | Description
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DayOfWeekSlot Class


DayOfWeekSlot Properties

[image] [image]

.NET Framework Class Library
DayOfWeekSlot Properties
DayOfWeekSlot Class See Also

The DayOfWeekSlot type exposes the following members.

Properties

 | Name | Description
Public property | DayFullName | Gets a culture specific full name for the DayOfWeek.
Public property | DayOfWeek | Gets a day of a week represented by the DayOfWeekSlot.
Public property | DayShortestName | Gets a culture specific shortest name for the DayOfWeek.
Public property | DayShortName | Gets a culture specific short name for the DayOfWeek.
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | IsWeekend | Indicates whether the DayOfWeek is a weekend.
Public property | Owner | Returns reference to the owning C1CalendarItem control.

See Also

DayOfWeekSlot Class


DayFullName Property

[image]

.NET Framework Class Library
DayOfWeekSlot..::..DayFullName Property
DayOfWeekSlot Class See Also
Gets a culture specific full name for the DayOfWeek.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string DayFullName { get; }
Visual Basic
Public ReadOnly Property DayFullName As String
    Get

See Also

DayOfWeekSlot Class


DayOfWeek Property

[image]

.NET Framework Class Library
DayOfWeekSlot..::..DayOfWeek Property
DayOfWeekSlot Class See Also
Gets a day of a week represented by the DayOfWeekSlot.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DayOfWeek DayOfWeek { get; private set; }
Visual Basic
Public Property DayOfWeek As DayOfWeek
    Get
    Private Set

See Also

DayOfWeekSlot Class


DayShortestName Property

[image]

.NET Framework Class Library
DayOfWeekSlot..::..DayShortestName Property
DayOfWeekSlot Class See Also
Gets a culture specific shortest name for the DayOfWeek.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string DayShortestName { get; }
Visual Basic
Public ReadOnly Property DayShortestName As String
    Get

See Also

DayOfWeekSlot Class


DayShortName Property

[image]

.NET Framework Class Library
DayOfWeekSlot..::..DayShortName Property
DayOfWeekSlot Class See Also
Gets a culture specific short name for the DayOfWeek.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string DayShortName { get; }
Visual Basic
Public ReadOnly Property DayShortName As String
    Get

See Also

DayOfWeekSlot Class


IsWeekend Property

[image]

.NET Framework Class Library
DayOfWeekSlot..::..IsWeekend Property
DayOfWeekSlot Class See Also
Indicates whether the DayOfWeek is a weekend.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsWeekend { get; }
Visual Basic
Public ReadOnly Property IsWeekend As Boolean
    Get

See Also

DayOfWeekSlot Class


Owner Property

[image]

.NET Framework Class Library
DayOfWeekSlot..::..Owner Property
DayOfWeekSlot Class See Also
Returns reference to the owning C1CalendarItem control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1CalendarItem Owner { get; private set; }
Visual Basic
Public Property Owner As C1CalendarItem
    Get
    Private Set

See Also

DayOfWeekSlot Class


DayOfWeekSlotPresenter Class

[image]

.NET Framework Class Library
DayOfWeekSlotPresenter Class
Members See Also
Represents a root element of a visual tree generated for a day of week slot of the C1CalendarItem.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class DayOfWeekSlotPresenter : ListBoxItem
Visual Basic
Public Class DayOfWeekSlotPresenter _
    Inherits ListBoxItem

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ContentControl
System.Windows.Controls..::..ListBoxItem
C1.Silverlight.Schedule..::..DayOfWeekSlotPresenter

See Also

DayOfWeekSlotPresenter Members


DayOfWeekSlotPresenter Members

[image] [image]

.NET Framework Class Library
DayOfWeekSlotPresenter Members
DayOfWeekSlotPresenter Class Constructors Methods Properties Events See Also

The DayOfWeekSlotPresenter type exposes the following members.

Constructors

 | Name | Description
Public method | DayOfWeekSlotPresenter | Initializes the new instance of the DayOfWeekSlotPresenter control.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | (Overrides ListBoxItemOnApplyTemplate()()()().)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxItemAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBoxItem.)
Protected method | OnGotFocus | (Inherited from ListBoxItem.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from ListBoxItem.)
Protected method | OnMouseEnter | Called when the mouse enters a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeave | Called when the mouse leaves a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeftButtonDown | Called when the user presses the right mouse button over the ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DayOfWeekSlot | Gets a DayOfWeekSlot represented by the DayOfWeekSlotPresenter.
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets a value that indicates whether a ListBoxItem is selected. This is a dependency property. (Inherited from ListBoxItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

DayOfWeekSlotPresenter Class


DayOfWeekSlotPresenter Constructor

[image]

.NET Framework Class Library
DayOfWeekSlotPresenter Constructor
DayOfWeekSlotPresenter Class See Also
Initializes the new instance of the DayOfWeekSlotPresenter control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DayOfWeekSlotPresenter()
Visual Basic
Public Sub New

See Also

DayOfWeekSlotPresenter Class


DayOfWeekSlotPresenter Methods

[image] [image]

.NET Framework Class Library
DayOfWeekSlotPresenter Methods
DayOfWeekSlotPresenter Class See Also

The DayOfWeekSlotPresenter type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | (Overrides ListBoxItemOnApplyTemplate()()()().)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxItemAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBoxItem.)
Protected method | OnGotFocus | (Inherited from ListBoxItem.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from ListBoxItem.)
Protected method | OnMouseEnter | Called when the mouse enters a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeave | Called when the mouse leaves a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeftButtonDown | Called when the user presses the right mouse button over the ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

DayOfWeekSlotPresenter Class


OnApplyTemplate Method

[image]

.NET Framework Class Library
DayOfWeekSlotPresenter..::..OnApplyTemplate Method
DayOfWeekSlotPresenter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic
Public Overrides Sub OnApplyTemplate

See Also

DayOfWeekSlotPresenter Class


DayOfWeekSlotPresenter Properties

[image] [image]

.NET Framework Class Library
DayOfWeekSlotPresenter Properties
DayOfWeekSlotPresenter Class See Also

The DayOfWeekSlotPresenter type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DayOfWeekSlot | Gets a DayOfWeekSlot represented by the DayOfWeekSlotPresenter.
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets a value that indicates whether a ListBoxItem is selected. This is a dependency property. (Inherited from ListBoxItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

DayOfWeekSlotPresenter Class


DayOfWeekSlot Property

[image]

.NET Framework Class Library
DayOfWeekSlotPresenter..::..DayOfWeekSlot Property
DayOfWeekSlotPresenter Class See Also
Gets a DayOfWeekSlot represented by the DayOfWeekSlotPresenter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DayOfWeekSlot DayOfWeekSlot { get; }
Visual Basic
Public ReadOnly Property DayOfWeekSlot As DayOfWeekSlot
    Get

See Also

DayOfWeekSlotPresenter Class


DayOfWeekSlotPresenter Events

[image] [image]

.NET Framework Class Library
DayOfWeekSlotPresenter Events
DayOfWeekSlotPresenter Class See Also

The DayOfWeekSlotPresenter type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

DayOfWeekSlotPresenter Class


DaySlot Class

[image]

.NET Framework Class Library
DaySlot Class
Members See Also
Represents a day slot in the C1CalendarItem control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class DaySlot : DependencyObject
Visual Basic
Public Class DaySlot _
    Inherits DependencyObject

Remarks

An instance of this class can represent a day of a month or an empty slot, which is determined by the Empty property value. In the case when DaySlot is empty, the Date property will have a null value, but the other properties will still contain information that allows you to determine the placement of the slot in the calendar. For example the DayOfWeek property will determine a day of week that the slot corresponds to.

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
C1.Silverlight.Schedule..::..DaySlot

See Also

DaySlot Members


DaySlot Members

[image] [image]

.NET Framework Class Library
DaySlot Members
DaySlot Class Methods Properties See Also

The DaySlot type exposes the following members.

Methods

 | Name | Description
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns string representation of the Date property value. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Date | Gets a date represented by the DaySlot object or a null value if the DaySlot is empty.
Public property | DayOfWeek | Gets the day of the week that this slot corresponds to.
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | Empty | Indicates whether the DaySlot is empty, that is doesn't represent a date.
Public property | IsAdjacent | Indicates whether the DaySlot represents a day from an adjacent month, but not of the month currently represented by C1CalendarItem.
Public property | IsBolded | Indicates whether a day represented by the DaySlot is currently bolded in C1CalendarItem UI. This is a dependency property.
Public property | IsEnabled | Indicates whether a day represented by the DaySlot is currently enabled in C1CalendarItem UI. This is a dependency property.
Public property | IsSelected | Indicates whether a day represented by the DaySlot is currently selected in C1CalendarItem UI. This is a dependency property.
Public property | IsToday | Indicates whether the DaySlot represents the current day.
Public property | IsWeekend | Indicates whether the DaySlot represents a weekend day.
Public property | Owner | Returns reference to the owning C1CalendarItem control.

See Also

DaySlot Class


DaySlot Methods

[image] [image]

.NET Framework Class Library
DaySlot Methods
DaySlot Class See Also

The DaySlot type exposes the following members.

Methods

 | Name | Description
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns string representation of the Date property value. (Overrides Object..::..ToString()()()().)

See Also

DaySlot Class


ToString Method

[image]

.NET Framework Class Library
DaySlot..::..ToString Method
DaySlot Class See Also
Returns string representation of the Date property value.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

See Also

DaySlot Class


DaySlot Properties

[image] [image]

.NET Framework Class Library
DaySlot Properties
DaySlot Class See Also

The DaySlot type exposes the following members.

Properties

 | Name | Description
Public property | Date | Gets a date represented by the DaySlot object or a null value if the DaySlot is empty.
Public property | DayOfWeek | Gets the day of the week that this slot corresponds to.
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | Empty | Indicates whether the DaySlot is empty, that is doesn't represent a date.
Public property | IsAdjacent | Indicates whether the DaySlot represents a day from an adjacent month, but not of the month currently represented by C1CalendarItem.
Public property | IsBolded | Indicates whether a day represented by the DaySlot is currently bolded in C1CalendarItem UI. This is a dependency property.
Public property | IsEnabled | Indicates whether a day represented by the DaySlot is currently enabled in C1CalendarItem UI. This is a dependency property.
Public property | IsSelected | Indicates whether a day represented by the DaySlot is currently selected in C1CalendarItem UI. This is a dependency property.
Public property | IsToday | Indicates whether the DaySlot represents the current day.
Public property | IsWeekend | Indicates whether the DaySlot represents a weekend day.
Public property | Owner | Returns reference to the owning C1CalendarItem control.

See Also

DaySlot Class


Date Property

[image]

.NET Framework Class Library
DaySlot..::..Date Property
DaySlot Class See Also
Gets a date represented by the DaySlot object or a null value if the DaySlot is empty.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Nullable<DateTime> Date { get; private set; }
Visual Basic
Public Property Date As Nullable(Of DateTime)
    Get
    Private Set

See Also

DaySlot Class


DayOfWeek Property

[image]

.NET Framework Class Library
DaySlot..::..DayOfWeek Property
DaySlot Class See Also
Gets the day of the week that this slot corresponds to.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DayOfWeek DayOfWeek { get; private set; }
Visual Basic
Public Property DayOfWeek As DayOfWeek
    Get
    Private Set

See Also

DaySlot Class


Empty Property

[image]

.NET Framework Class Library
DaySlot..::..Empty Property
DaySlot Class See Also
Indicates whether the DaySlot is empty, that is doesn't represent a date.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool Empty { get; }
Visual Basic
Public ReadOnly Property Empty As Boolean
    Get

See Also

DaySlot Class


IsAdjacent Property

[image]

.NET Framework Class Library
DaySlot..::..IsAdjacent Property
DaySlot Class See Also
Indicates whether the DaySlot represents a day from an adjacent month, but not of the month currently represented by C1CalendarItem.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsAdjacent { get; private set; }
Visual Basic
Public Property IsAdjacent As Boolean
    Get
    Private Set

See Also

DaySlot Class


IsBolded Property

[image]

.NET Framework Class Library
DaySlot..::..IsBolded Property
DaySlot Class See Also
Indicates whether a day represented by the DaySlot is currently bolded in C1CalendarItem UI. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsBolded { get; }
Visual Basic
Public ReadOnly Property IsBolded As Boolean
    Get

See Also

DaySlot Class


IsEnabled Property

[image]

.NET Framework Class Library
DaySlot..::..IsEnabled Property
DaySlot Class See Also
Indicates whether a day represented by the DaySlot is currently enabled in C1CalendarItem UI. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsEnabled { get; }
Visual Basic
Public ReadOnly Property IsEnabled As Boolean
    Get

See Also

DaySlot Class


IsSelected Property

[image]

.NET Framework Class Library
DaySlot..::..IsSelected Property
DaySlot Class See Also
Indicates whether a day represented by the DaySlot is currently selected in C1CalendarItem UI. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsSelected { get; }
Visual Basic
Public ReadOnly Property IsSelected As Boolean
    Get

See Also

DaySlot Class


IsToday Property

[image]

.NET Framework Class Library
DaySlot..::..IsToday Property
DaySlot Class See Also
Indicates whether the DaySlot represents the current day.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsToday { get; private set; }
Visual Basic
Public Property IsToday As Boolean
    Get
    Private Set

See Also

DaySlot Class


IsWeekend Property

[image]

.NET Framework Class Library
DaySlot..::..IsWeekend Property
DaySlot Class See Also
Indicates whether the DaySlot represents a weekend day.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsWeekend { get; }
Visual Basic
Public ReadOnly Property IsWeekend As Boolean
    Get

See Also

DaySlot Class


Owner Property

[image]

.NET Framework Class Library
DaySlot..::..Owner Property
DaySlot Class See Also
Returns reference to the owning C1CalendarItem control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1CalendarItem Owner { get; private set; }
Visual Basic
Public Property Owner As C1CalendarItem
    Get
    Private Set

See Also

DaySlot Class


DaySlotPresenter Class

[image]

.NET Framework Class Library
DaySlotPresenter Class
Members See Also
Represents a root element of a visual tree generated for a day slot of the C1CalendarItem.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class DaySlotPresenter : ListBoxItem
Visual Basic
Public Class DaySlotPresenter _
    Inherits ListBoxItem

Remarks

A separate DaySlotPresenter element is generated for each DaySlot from the DaySlots()()()() collection.

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ContentControl
System.Windows.Controls..::..ListBoxItem
C1.Silverlight.Schedule..::..DaySlotPresenter

See Also

DaySlotPresenter Members


DaySlotPresenter Members

[image] [image]

.NET Framework Class Library
DaySlotPresenter Members
DaySlotPresenter Class Constructors Methods Properties Events See Also

The DaySlotPresenter type exposes the following members.

Constructors

 | Name | Description
Public method | DaySlotPresenter | Creates a new instance of DaySlotPresenter.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | (Overrides ListBoxItemOnApplyTemplate()()()().)
Protected method | OnContentChanged | Overrides the default behavior. (Overrides ContentControl..::..OnContentChanged(Object, Object).)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxItemAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBoxItem.)
Protected method | OnGotFocus | (Inherited from ListBoxItem.)
Protected method | OnKeyDown | (Overrides ControlOnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from ListBoxItem.)
Protected method | OnMouseEnter | Called when the mouse enters a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeave | Called when the mouse leaves a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeftButtonDown | Overrides the default behavior. (Overrides ListBoxItem..::..OnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Date | Gets a date representing by the DaySlotPresenter or a null value if the element represents an empty DaySlot.
Public property | DaySlot | Gets a DaySlot represented by the DaySlotPresenter.
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | Empty | Indicates whether the DaySlotPresenter represents an empty DaySlot.
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets a value that indicates whether a ListBoxItem is selected. This is a dependency property. (Inherited from ListBoxItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

DaySlotPresenter Class


DaySlotPresenter Constructor

[image]

.NET Framework Class Library
DaySlotPresenter Constructor
DaySlotPresenter Class See Also
Creates a new instance of DaySlotPresenter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DaySlotPresenter()
Visual Basic
Public Sub New

See Also

DaySlotPresenter Class


DaySlotPresenter Methods

[image] [image]

.NET Framework Class Library
DaySlotPresenter Methods
DaySlotPresenter Class See Also

The DaySlotPresenter type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | (Overrides ListBoxItemOnApplyTemplate()()()().)
Protected method | OnContentChanged | Overrides the default behavior. (Overrides ContentControl..::..OnContentChanged(Object, Object).)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxItemAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBoxItem.)
Protected method | OnGotFocus | (Inherited from ListBoxItem.)
Protected method | OnKeyDown | (Overrides ControlOnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from ListBoxItem.)
Protected method | OnMouseEnter | Called when the mouse enters a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeave | Called when the mouse leaves a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeftButtonDown | Overrides the default behavior. (Overrides ListBoxItem..::..OnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

DaySlotPresenter Class


OnApplyTemplate Method

[image]

.NET Framework Class Library
DaySlotPresenter..::..OnApplyTemplate Method
DaySlotPresenter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic
Public Overrides Sub OnApplyTemplate

See Also

DaySlotPresenter Class


OnContentChanged Method

[image]

.NET Framework Class Library
DaySlotPresenter..::..OnContentChanged Method
DaySlotPresenter Class See Also
Overrides the default behavior.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnContentChanged(
    Object oldContent,
    Object newContent
)
Visual Basic
Protected Overrides Sub OnContentChanged ( _
    oldContent As Object, _
    newContent As Object _
)

Parameters

oldContent
Type: System..::..Object
newContent
Type: System..::..Object

See Also

DaySlotPresenter Class


OnKeyDown Method

[image]

.NET Framework Class Library
DaySlotPresenter..::..OnKeyDown Method
DaySlotPresenter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)

Parameters

e
Type: System.Windows.Input..::..KeyEventArgs

See Also

DaySlotPresenter Class


OnMouseLeftButtonDown Method

[image]

.NET Framework Class Library
DaySlotPresenter..::..OnMouseLeftButtonDown Method
DaySlotPresenter Class See Also
Overrides the default behavior.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnMouseLeftButtonDown(
    MouseButtonEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseLeftButtonDown ( _
    e As MouseButtonEventArgs _
)

Parameters

e
Type: System.Windows.Input..::..MouseButtonEventArgs

See Also

DaySlotPresenter Class


DaySlotPresenter Properties

[image] [image]

.NET Framework Class Library
DaySlotPresenter Properties
DaySlotPresenter Class See Also

The DaySlotPresenter type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Date | Gets a date representing by the DaySlotPresenter or a null value if the element represents an empty DaySlot.
Public property | DaySlot | Gets a DaySlot represented by the DaySlotPresenter.
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | Empty | Indicates whether the DaySlotPresenter represents an empty DaySlot.
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets a value that indicates whether a ListBoxItem is selected. This is a dependency property. (Inherited from ListBoxItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

DaySlotPresenter Class


Date Property

[image]

.NET Framework Class Library
DaySlotPresenter..::..Date Property
DaySlotPresenter Class See Also
Gets a date representing by the DaySlotPresenter or a null value if the element represents an empty DaySlot.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Nullable<DateTime> Date { get; }
Visual Basic
Public ReadOnly Property Date As Nullable(Of DateTime)
    Get

See Also

DaySlotPresenter Class


DaySlot Property

[image]

.NET Framework Class Library
DaySlotPresenter..::..DaySlot Property
DaySlotPresenter Class See Also
Gets a DaySlot represented by the DaySlotPresenter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DaySlot DaySlot { get; }
Visual Basic
Public ReadOnly Property DaySlot As DaySlot
    Get

See Also

DaySlotPresenter Class


Empty Property

[image]

.NET Framework Class Library
DaySlotPresenter..::..Empty Property
DaySlotPresenter Class See Also
Indicates whether the DaySlotPresenter represents an empty DaySlot.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool Empty { get; }
Visual Basic
Public ReadOnly Property Empty As Boolean
    Get

See Also

DaySlotPresenter Class


DaySlotPresenter Events

[image] [image]

.NET Framework Class Library
DaySlotPresenter Events
DaySlotPresenter Class See Also

The DaySlotPresenter type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

DaySlotPresenter Class


DaysOfWeekPresenter Class

[image]

.NET Framework Class Library
DaysOfWeekPresenter Class
Members See Also
An instance of this class is used in the C1CalendarItem's template visual tree to define a place where a panel with day of week captions will appear.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class DaysOfWeekPresenter : ListBox
Visual Basic
Public Class DaysOfWeekPresenter _
    Inherits ListBox

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ItemsControl
System.Windows.Controls.Primitives..::..Selector
System.Windows.Controls..::..ListBox
C1.Silverlight.Schedule..::..DaysOfWeekPresenter

See Also

DaysOfWeekPresenter Members


DaysOfWeekPresenter Members

[image] [image]

.NET Framework Class Library
DaysOfWeekPresenter Members
DaysOfWeekPresenter Class Constructors Methods Properties Events See Also

The DaysOfWeekPresenter type exposes the following members.

Constructors

 | Name | Description
Public method | DaysOfWeekPresenter | Initializes a new instance of the DaysOfWeekPresenter class.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Protected method | ClearContainerForItemOverride | (Inherited from Selector.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides ListBox..::..GetContainerForItemOverride()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ListBox.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | (Overrides ListBoxOnApplyTemplate()()()().)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBox.)
Protected method | OnGotFocus | (Inherited from ListBox.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnKeyDown | Responds to the KeyDown event. (Inherited from ListBox.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from ListBox.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ListBox.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemContainerStyle | (Inherited from ListBox.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. This is a dependency property. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty This is a dependency property. (Inherited from Selector.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

DaysOfWeekPresenter Class


DaysOfWeekPresenter Constructor

[image]

.NET Framework Class Library
DaysOfWeekPresenter Constructor
DaysOfWeekPresenter Class See Also
Initializes a new instance of the DaysOfWeekPresenter class.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DaysOfWeekPresenter()
Visual Basic
Public Sub New

See Also

DaysOfWeekPresenter Class


DaysOfWeekPresenter Methods

[image] [image]

.NET Framework Class Library
DaysOfWeekPresenter Methods
DaysOfWeekPresenter Class See Also

The DaysOfWeekPresenter type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Protected method | ClearContainerForItemOverride | (Inherited from Selector.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides ListBox..::..GetContainerForItemOverride()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ListBox.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | (Overrides ListBoxOnApplyTemplate()()()().)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBox.)
Protected method | OnGotFocus | (Inherited from ListBox.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnKeyDown | Responds to the KeyDown event. (Inherited from ListBox.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from ListBox.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ListBox.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

DaysOfWeekPresenter Class


GetContainerForItemOverride Method

[image]

.NET Framework Class Library
DaysOfWeekPresenter..::..GetContainerForItemOverride Method
DaysOfWeekPresenter Class See Also
Creates or identifies the element used to display the specified item.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override DependencyObject GetContainerForItemOverride()
Visual Basic
Protected Overrides Function GetContainerForItemOverride As DependencyObject

Return Value

The new instance of DayOfWeekSlotPresenter class.

See Also

DaysOfWeekPresenter Class


OnApplyTemplate Method

[image]

.NET Framework Class Library
DaysOfWeekPresenter..::..OnApplyTemplate Method
DaysOfWeekPresenter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic
Public Overrides Sub OnApplyTemplate

See Also

DaysOfWeekPresenter Class


DaysOfWeekPresenter Properties

[image] [image]

.NET Framework Class Library
DaysOfWeekPresenter Properties
DaysOfWeekPresenter Class See Also

The DaysOfWeekPresenter type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemContainerStyle | (Inherited from ListBox.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. This is a dependency property. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty This is a dependency property. (Inherited from Selector.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

DaysOfWeekPresenter Class


DaysOfWeekPresenter Events

[image] [image]

.NET Framework Class Library
DaysOfWeekPresenter Events
DaysOfWeekPresenter Class See Also

The DaysOfWeekPresenter type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

DaysOfWeekPresenter Class


DecrementConverter Class

[image]

.NET Framework Class Library
DecrementConverter Class
Members See Also
Represents a Binding converter that keeps binding target = binding source - 1, where source and target values are numeric.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class DecrementConverter : AddValueConverter
Visual Basic
Public Class DecrementConverter _
    Inherits AddValueConverter

Remarks

DecrementConverter is a two-way converter. When converting in any direction, a source value must be of any numeric type, and a converted value is of the System.Int32 type.

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..AddValueConverter
C1.Silverlight.Schedule..::..DecrementConverter

See Also

DecrementConverter Members


DecrementConverter Members

[image] [image]

.NET Framework Class Library
DecrementConverter Members
DecrementConverter Class Constructors Methods Fields See Also

The DecrementConverter type exposes the following members.

Constructors

 | Name | Description
Public method | DecrementConverter | Initializes a new instance of the DecrementConverter.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target. (Inherited from AddValueConverter.)
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source. (Inherited from AddValueConverter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Default | Gets an instance of DecrementConverter.

See Also

DecrementConverter Class


DecrementConverter Constructor

[image]

.NET Framework Class Library
DecrementConverter Constructor
DecrementConverter Class See Also
Initializes a new instance of the DecrementConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DecrementConverter()
Visual Basic
Public Sub New

See Also

DecrementConverter Class


DecrementConverter Fields

[image] [image]

.NET Framework Class Library
DecrementConverter Fields
DecrementConverter Class See Also

The DecrementConverter type exposes the following members.

Fields

Name | Description
Default | Gets an instance of DecrementConverter.

See Also

DecrementConverter Class


Default Field

[image]

.NET Framework Class Library
DecrementConverter..::..Default Field
DecrementConverter Class See Also
Gets an instance of DecrementConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DecrementConverter Default
Visual Basic
Public Shared ReadOnly Default As DecrementConverter

See Also

DecrementConverter Class


DecrementConverter Methods

[image] [image]

.NET Framework Class Library
DecrementConverter Methods
DecrementConverter Class See Also

The DecrementConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target. (Inherited from AddValueConverter.)
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source. (Inherited from AddValueConverter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DecrementConverter Class


DeferrableObservableCollection(T) Class

[image]

.NET Framework Class Library
DeferrableObservableCollection<(Of <(<'T>)>)> Class
Members See Also
The DeferrableObservableCollection<(Of <(<'T>)>)> represents an ObservableCollection<(Of <(<'T>)>)> supported deferring events during the massive collection changes.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class DeferrableObservableCollection<T> : ObservableCollection<T>
Visual Basic
Public Class DeferrableObservableCollection(Of T) _
    Inherits ObservableCollection(Of T)

Type Parameters

T

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<'T>)>)>
System.Collections.ObjectModel..::..ObservableCollection <(Of <(<'T>)>)>
C1.Silverlight.Schedule..::..DeferrableObservableCollection<(Of <(<'T>)>)>
C1.Silverlight.Schedule..::..SchedulerGroupItemCollection
C1.Silverlight.Schedule..::..VisualIntervalCollection

See Also

DeferrableObservableCollection<(Of <(<'T>)>)> Members


DeferrableObservableCollection(T) Members

[image] [image]

.NET Framework Class Library
DeferrableObservableCollection<(Of <(<'T>)>)> Members
DeferrableObservableCollection<(Of <(<'T>)>)> Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The DeferrableObservableCollection<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | DeferrableObservableCollection<(Of <(<'T>)>)> |

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | BeginUpdate | Prevents raising events until the EndUpdate()()()() method is called.
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection <(Of <(<' T >)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | EndUpdate | Enables raising events. If collection has been changed since the call to the BeginUpdate()()()() method, raises PropertyChanged and CollectionChanged events.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollection <(Of <(<' T >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Overrides the default behavior. (Overrides ObservableCollection<(Of <(<'T>)>)>..::..OnCollectionChanged(NotifyCollectionChangedEventArgs).)
Protected method | OnPropertyChanged | Overrides the default behavior. (Overrides ObservableCollection<(Of <(<'T>)>)>..::..OnPropertyChanged(PropertyChangedEventArgs).)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection <(Of <(<' T >)>)>.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollection <(Of <(<' T >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public property | InUpdate | Gets a Boolean value determining whether the DeferrableObservableCollection<(Of <(<'T>)>)> is in update mode (BeginUpdate()()()() has been called).
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)

Events

 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection <(Of <(<' T >)>)>.)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection <(Of <(<' T >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' T >)>)>.)

See Also

DeferrableObservableCollection<(Of <(<'T>)>)> Class


DeferrableObservableCollection(T) Constructor

[image]

.NET Framework Class Library
DeferrableObservableCollection<(Of <(<'T>)>)> Constructor
DeferrableObservableCollection<(Of <(<'T>)>)> Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DeferrableObservableCollection()
Visual Basic
Public Sub New

See Also

DeferrableObservableCollection<(Of <(<'T>)>)> Class


DeferrableObservableCollection(T) Methods

[image] [image]

.NET Framework Class Library
DeferrableObservableCollection<(Of <(<'T>)>)> Methods
DeferrableObservableCollection<(Of <(<'T>)>)> Class See Also

The DeferrableObservableCollection<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | BeginUpdate | Prevents raising events until the EndUpdate()()()() method is called.
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection <(Of <(<' T >)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | EndUpdate | Enables raising events. If collection has been changed since the call to the BeginUpdate()()()() method, raises PropertyChanged and CollectionChanged events.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollection <(Of <(<' T >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Overrides the default behavior. (Overrides ObservableCollection<(Of <(<'T>)>)>..::..OnCollectionChanged(NotifyCollectionChangedEventArgs).)
Protected method | OnPropertyChanged | Overrides the default behavior. (Overrides ObservableCollection<(Of <(<'T>)>)>..::..OnPropertyChanged(PropertyChangedEventArgs).)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection <(Of <(<' T >)>)>.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollection <(Of <(<' T >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' T >)>)>.)

See Also

DeferrableObservableCollection<(Of <(<'T>)>)> Class


BeginUpdate Method

[image]

.NET Framework Class Library
DeferrableObservableCollection<(Of <(<'T>)>)>..::..BeginUpdate Method
DeferrableObservableCollection<(Of <(<'T>)>)> Class See Also
Prevents raising events until the EndUpdate()()()() method is called.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void BeginUpdate()
Visual Basic
Public Sub BeginUpdate

Remarks

The DeferrableObservableCollection<(Of <(<'T>)>)> keeps count of calls to BeginUpdate()()()() method. Be sure to call EndUpdate()()()() method for each call to BeginUpdate()()()() method.

See Also

DeferrableObservableCollection<(Of <(<'T>)>)> Class


EndUpdate Method

[image]

.NET Framework Class Library
DeferrableObservableCollection<(Of <(<'T>)>)>..::..EndUpdate Method
DeferrableObservableCollection<(Of <(<'T>)>)> Class See Also
Enables raising events. If collection has been changed since the call to the BeginUpdate()()()() method, raises PropertyChanged and CollectionChanged events.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void EndUpdate()
Visual Basic
Public Sub EndUpdate

Remarks

The DeferrableObservableCollection<(Of <(<'T>)>)> keeps count of calls to BeginUpdate()()()() method. Be sure to call EndUpdate()()()() method for each call to BeginUpdate()()()() method.

See Also

DeferrableObservableCollection<(Of <(<'T>)>)> Class


OnCollectionChanged Method

[image]

.NET Framework Class Library
DeferrableObservableCollection<(Of <(<'T>)>)>..::..OnCollectionChanged Method
DeferrableObservableCollection<(Of <(<'T>)>)> Class See Also
Overrides the default behavior.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnCollectionChanged(
    NotifyCollectionChangedEventArgs e
)
Visual Basic
Protected Overrides Sub OnCollectionChanged ( _
    e As NotifyCollectionChangedEventArgs _
)

Parameters

e
Type: System.Collections.Specialized..::..NotifyCollectionChangedEventArgs

See Also

DeferrableObservableCollection<(Of <(<'T>)>)> Class


OnPropertyChanged Method

[image]

.NET Framework Class Library
DeferrableObservableCollection<(Of <(<'T>)>)>..::..OnPropertyChanged Method
DeferrableObservableCollection<(Of <(<'T>)>)> Class See Also
Overrides the default behavior.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnPropertyChanged(
    PropertyChangedEventArgs e
)
Visual Basic
Protected Overrides Sub OnPropertyChanged ( _
    e As PropertyChangedEventArgs _
)

Parameters

e
Type: System.ComponentModel..::..PropertyChangedEventArgs

See Also

DeferrableObservableCollection<(Of <(<'T>)>)> Class


DeferrableObservableCollection(T) Properties

[image] [image]

.NET Framework Class Library
DeferrableObservableCollection<(Of <(<'T>)>)> Properties
DeferrableObservableCollection<(Of <(<'T>)>)> Class See Also

The DeferrableObservableCollection<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public property | InUpdate | Gets a Boolean value determining whether the DeferrableObservableCollection<(Of <(<'T>)>)> is in update mode (BeginUpdate()()()() has been called).
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' T >)>)>.)

See Also

DeferrableObservableCollection<(Of <(<'T>)>)> Class


InUpdate Property

[image]

.NET Framework Class Library
DeferrableObservableCollection<(Of <(<'T>)>)>..::..InUpdate Property
DeferrableObservableCollection<(Of <(<'T>)>)> Class See Also
Gets a Boolean value determining whether the DeferrableObservableCollection<(Of <(<'T>)>)> is in update mode (BeginUpdate()()()() has been called).

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool InUpdate { get; }
Visual Basic
Public ReadOnly Property InUpdate As Boolean
    Get

See Also

DeferrableObservableCollection<(Of <(<'T>)>)> Class


DeferrableObservableCollection(T) Events

[image] [image]

.NET Framework Class Library
DeferrableObservableCollection<(Of <(<'T>)>)> Events
DeferrableObservableCollection<(Of <(<'T>)>)> Class See Also

The DeferrableObservableCollection<(Of <(<'T>)>)> type exposes the following members.

Events

 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection <(Of <(<' T >)>)>.)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection <(Of <(<' T >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection <(Of <(<' T >)>)>.)

See Also

DeferrableObservableCollection<(Of <(<'T>)>)> Class


EditAppointmentControl Class

[image]

.NET Framework Class Library
EditAppointmentControl Class
Members See Also
The EditAppointmentControl control allows editing of all appointment properties.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class EditAppointmentControl : UserControl
Visual Basic
Public Class EditAppointmentControl _
    Inherits UserControl

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..UserControl
C1.Silverlight.Schedule..::..EditAppointmentControl

See Also

EditAppointmentControl Members


EditAppointmentControl Members

[image] [image]

.NET Framework Class Library
EditAppointmentControl Members
EditAppointmentControl Class Constructors Methods Fields Properties Events See Also

The EditAppointmentControl type exposes the following members.

Constructors

 | Name | Description
Public method | EditAppointmentControl | Creates the new instance of the EditAppointmentControl class.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InitializeComponent | InitializeComponent
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnKeyDown | (Overrides ControlOnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMouseEnter | (Overrides ControlOnMouseEnter(MouseEventArgs).)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
PatternDescriptionProperty | Identifies the PatternDescription dependency property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Appointment | Gets or sets an Appointment object representing current DataContext.
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Protected property | Content | (Inherited from UserControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Header | Gets a String value which can be used as an Appointment window header.
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PatternDescription | Gets recurrence pattern description.
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

EditAppointmentControl Class


EditAppointmentControl Constructor

[image]

.NET Framework Class Library
EditAppointmentControl Constructor
EditAppointmentControl Class See Also
Creates the new instance of the EditAppointmentControl class.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public EditAppointmentControl()
Visual Basic
Public Sub New

See Also

EditAppointmentControl Class


EditAppointmentControl Fields

[image] [image]

.NET Framework Class Library
EditAppointmentControl Fields
EditAppointmentControl Class See Also

The EditAppointmentControl type exposes the following members.

Fields

Name | Description
PatternDescriptionProperty | Identifies the PatternDescription dependency property.

See Also

EditAppointmentControl Class


PatternDescriptionProperty Field

[image]

.NET Framework Class Library
EditAppointmentControl..::..PatternDescriptionProperty Field
EditAppointmentControl Class See Also
Identifies the PatternDescription dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty PatternDescriptionProperty
Visual Basic
Public Shared ReadOnly PatternDescriptionProperty As DependencyProperty

See Also

EditAppointmentControl Class


EditAppointmentControl Methods

[image] [image]

.NET Framework Class Library
EditAppointmentControl Methods
EditAppointmentControl Class See Also

The EditAppointmentControl type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InitializeComponent | InitializeComponent
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Overrides ControlOnGotFocus(RoutedEventArgs).)
Protected method | OnKeyDown | (Overrides ControlOnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMouseEnter | (Overrides ControlOnMouseEnter(MouseEventArgs).)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

EditAppointmentControl Class


InitializeComponent Method

[image]

.NET Framework Class Library
EditAppointmentControl..::..InitializeComponent Method
EditAppointmentControl Class See Also
InitializeComponent

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DebuggerNonUserCodeAttribute]
public void InitializeComponent()
Visual Basic
<DebuggerNonUserCodeAttribute> _
Public Sub InitializeComponent

See Also

EditAppointmentControl Class


OnGotFocus Method

[image]

.NET Framework Class Library
EditAppointmentControl..::..OnGotFocus Method
EditAppointmentControl Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnGotFocus(
    RoutedEventArgs e
)
Visual Basic
Protected Overrides Sub OnGotFocus ( _
    e As RoutedEventArgs _
)

Parameters

e
Type: System.Windows..::..RoutedEventArgs

See Also

EditAppointmentControl Class


OnKeyDown Method

[image]

.NET Framework Class Library
EditAppointmentControl..::..OnKeyDown Method
EditAppointmentControl Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)

Parameters

e
Type: System.Windows.Input..::..KeyEventArgs

See Also

EditAppointmentControl Class


OnMouseEnter Method

[image]

.NET Framework Class Library
EditAppointmentControl..::..OnMouseEnter Method
EditAppointmentControl Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnMouseEnter(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseEnter ( _
    e As MouseEventArgs _
)

Parameters

e
Type: System.Windows.Input..::..MouseEventArgs

See Also

EditAppointmentControl Class


EditAppointmentControl Properties

[image] [image]

.NET Framework Class Library
EditAppointmentControl Properties
EditAppointmentControl Class See Also

The EditAppointmentControl type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Appointment | Gets or sets an Appointment object representing current DataContext.
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Protected property | Content | (Inherited from UserControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Header | Gets a String value which can be used as an Appointment window header.
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PatternDescription | Gets recurrence pattern description.
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

EditAppointmentControl Class


Appointment Property

[image]

.NET Framework Class Library
EditAppointmentControl..::..Appointment Property
EditAppointmentControl Class See Also
Gets or sets an Appointment object representing current DataContext.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Appointment Appointment { get; set; }
Visual Basic
Public Property Appointment As Appointment
    Get
    Set

See Also

EditAppointmentControl Class


Header Property

[image]

.NET Framework Class Library
EditAppointmentControl..::..Header Property
EditAppointmentControl Class See Also
Gets a String value which can be used as an Appointment window header.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string Header { get; private set; }
Visual Basic
Public Property Header As String
    Get
    Private Set

See Also

EditAppointmentControl Class


PatternDescription Property

[image]

.NET Framework Class Library
EditAppointmentControl..::..PatternDescription Property
EditAppointmentControl Class See Also
Gets recurrence pattern description.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string PatternDescription { get; private set; }
Visual Basic
Public Property PatternDescription As String
    Get
    Private Set

See Also

EditAppointmentControl Class


EditAppointmentControl Events

[image] [image]

.NET Framework Class Library
EditAppointmentControl Events
EditAppointmentControl Class See Also

The EditAppointmentControl type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

EditAppointmentControl Class


EditCollectionControl Class

[image]

.NET Framework Class Library
EditCollectionControl Class
Members See Also
The EditCollectionControl control is an auxiliary control encapsulating UI elements for editing Appointment Categories, Links or Resource properties.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class EditCollectionControl : UserControl
Visual Basic
Public Class EditCollectionControl _
    Inherits UserControl

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..UserControl
C1.Silverlight.Schedule..::..EditCollectionControl

See Also

EditCollectionControl Members


EditCollectionControl Members

[image] [image]

.NET Framework Class Library
EditCollectionControl Members
EditCollectionControl Class Constructors Methods Properties Events See Also

The EditCollectionControl type exposes the following members.

Constructors

 | Name | Description
Public method | EditCollectionControl | Initializes a new instance of the EditCollectionControl control.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InitializeComponent | InitializeComponent
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | ButtonText | Gets or sets a String value whiuch should be used as a button content. This is a dependency property.
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Protected property | Content | (Inherited from UserControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemType | Gets or sets a type of items in a source and target collections.
Public property | LabelText | Gets or sets a String value whiuch should be used as a label content. This is a dependency property.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | ParentAppointment | Gets or sets the appointment object, for which the control is shown.
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Scheduler | Gets or sets the the parent C1Scheduler object.
Public property | ShowButton | Gets or sets a Boolean value determining whether control should show button for external editing or ComboBox for the single selection.
Public property | SourceCollection | Gets or sets an IList list, containing all available items.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TargetCollection | Gets or sets an IList list, containing selected items.
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Text | Gets or sets a String value whiuch should be used as a TextBox content. This is a dependency property.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | WindowTitle | Gets or sets a String value which should be used as a dialog title.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

EditCollectionControl Class


EditCollectionControl Constructor

[image]

.NET Framework Class Library
EditCollectionControl Constructor
EditCollectionControl Class See Also
Initializes a new instance of the EditCollectionControl control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public EditCollectionControl()
Visual Basic
Public Sub New

See Also

EditCollectionControl Class


EditCollectionControl Methods

[image] [image]

.NET Framework Class Library
EditCollectionControl Methods
EditCollectionControl Class See Also

The EditCollectionControl type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InitializeComponent | InitializeComponent
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

EditCollectionControl Class


InitializeComponent Method

[image]

.NET Framework Class Library
EditCollectionControl..::..InitializeComponent Method
EditCollectionControl Class See Also
InitializeComponent

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DebuggerNonUserCodeAttribute]
public void InitializeComponent()
Visual Basic
<DebuggerNonUserCodeAttribute> _
Public Sub InitializeComponent

See Also

EditCollectionControl Class


EditCollectionControl Properties

[image] [image]

.NET Framework Class Library
EditCollectionControl Properties
EditCollectionControl Class See Also

The EditCollectionControl type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | ButtonText | Gets or sets a String value whiuch should be used as a button content. This is a dependency property.
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Protected property | Content | (Inherited from UserControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemType | Gets or sets a type of items in a source and target collections.
Public property | LabelText | Gets or sets a String value whiuch should be used as a label content. This is a dependency property.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | ParentAppointment | Gets or sets the appointment object, for which the control is shown.
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Scheduler | Gets or sets the the parent C1Scheduler object.
Public property | ShowButton | Gets or sets a Boolean value determining whether control should show button for external editing or ComboBox for the single selection.
Public property | SourceCollection | Gets or sets an IList list, containing all available items.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TargetCollection | Gets or sets an IList list, containing selected items.
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Text | Gets or sets a String value whiuch should be used as a TextBox content. This is a dependency property.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | WindowTitle | Gets or sets a String value which should be used as a dialog title.

See Also

EditCollectionControl Class


ButtonText Property

[image]

.NET Framework Class Library
EditCollectionControl..::..ButtonText Property
EditCollectionControl Class See Also
Gets or sets a String value whiuch should be used as a button content. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string ButtonText { get; set; }
Visual Basic
Public Property ButtonText As String
    Get
    Set

See Also

EditCollectionControl Class


ItemType Property

[image]

.NET Framework Class Library
EditCollectionControl..::..ItemType Property
EditCollectionControl Class See Also
Gets or sets a type of items in a source and target collections.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Type ItemType { get; set; }
Visual Basic
Public Property ItemType As Type
    Get
    Set

See Also

EditCollectionControl Class


LabelText Property

[image]

.NET Framework Class Library
EditCollectionControl..::..LabelText Property
EditCollectionControl Class See Also
Gets or sets a String value whiuch should be used as a label content. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string LabelText { get; set; }
Visual Basic
Public Property LabelText As String
    Get
    Set

See Also

EditCollectionControl Class


ParentAppointment Property

[image]

.NET Framework Class Library
EditCollectionControl..::..ParentAppointment Property
EditCollectionControl Class See Also
Gets or sets the appointment object, for which the control is shown.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object ParentAppointment { get; set; }
Visual Basic
Public Property ParentAppointment As Object
    Get
    Set

See Also

EditCollectionControl Class


Scheduler Property

[image]

.NET Framework Class Library
EditCollectionControl..::..Scheduler Property
EditCollectionControl Class See Also
Gets or sets the the parent C1Scheduler object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1Scheduler Scheduler { get; set; }
Visual Basic
Public Property Scheduler As C1Scheduler
    Get
    Set

See Also

EditCollectionControl Class


ShowButton Property

[image]

.NET Framework Class Library
EditCollectionControl..::..ShowButton Property
EditCollectionControl Class See Also
Gets or sets a Boolean value determining whether control should show button for external editing or ComboBox for the single selection.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool ShowButton { get; set; }
Visual Basic
Public Property ShowButton As Boolean
    Get
    Set

Field Value

The default value is true.

Remarks

If this property is true, control shows Button and TextBox. In such case editing and selection from the source collection is implemented by the SelectFromListDialogCommand command.

If this property is false, controls shows ComboBox for the single selection. In this case, TargetCollection is updated automatically when user selects ComboBox item.

See Also

EditCollectionControl Class


SourceCollection Property

[image]

.NET Framework Class Library
EditCollectionControl..::..SourceCollection Property
EditCollectionControl Class See Also
Gets or sets an IList list, containing all available items.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public IList SourceCollection { get; set; }
Visual Basic
Public Property SourceCollection As IList
    Get
    Set

See Also

EditCollectionControl Class


TargetCollection Property

[image]

.NET Framework Class Library
EditCollectionControl..::..TargetCollection Property
EditCollectionControl Class See Also
Gets or sets an IList list, containing selected items.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public IList TargetCollection { get; set; }
Visual Basic
Public Property TargetCollection As IList
    Get
    Set

See Also

EditCollectionControl Class


Text Property

[image]

.NET Framework Class Library
EditCollectionControl..::..Text Property
EditCollectionControl Class See Also
Gets or sets a String value whiuch should be used as a TextBox content. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set

See Also

EditCollectionControl Class


WindowTitle Property

[image]

.NET Framework Class Library
EditCollectionControl..::..WindowTitle Property
EditCollectionControl Class See Also
Gets or sets a String value which should be used as a dialog title.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string WindowTitle { get; set; }
Visual Basic
Public Property WindowTitle As String
    Get
    Set

See Also

EditCollectionControl Class


EditCollectionControl Events

[image] [image]

.NET Framework Class Library
EditCollectionControl Events
EditCollectionControl Class See Also

The EditCollectionControl type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

EditCollectionControl Class


EditRecurrenceControl Class

[image]

.NET Framework Class Library
EditRecurrenceControl Class
Members See Also
The EditRecurrenceControl control allows editing of all recurrence pattern properties.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class EditRecurrenceControl : UserControl
Visual Basic
Public Class EditRecurrenceControl _
    Inherits UserControl

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..UserControl
C1.Silverlight.Schedule..::..EditRecurrenceControl

See Also

EditRecurrenceControl Members


EditRecurrenceControl Members

[image] [image]

.NET Framework Class Library
EditRecurrenceControl Members
EditRecurrenceControl Class Constructors Methods Fields Properties Events See Also

The EditRecurrenceControl type exposes the following members.

Constructors

 | Name | Description
Public method | EditRecurrenceControl | Creates the new instance of the EditRecurrenceControl class.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InitializeComponent | InitializeComponent
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Overrides ControlOnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
SchedulerProperty | Identifies the Scheduler dependency property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Protected property | Content | (Inherited from UserControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Scheduler | Gets or sets reference to the parent Scheduler control.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

EditRecurrenceControl Class


EditRecurrenceControl Constructor

[image]

.NET Framework Class Library
EditRecurrenceControl Constructor
EditRecurrenceControl Class See Also
Creates the new instance of the EditRecurrenceControl class.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public EditRecurrenceControl()
Visual Basic
Public Sub New

See Also

EditRecurrenceControl Class


EditRecurrenceControl Fields

[image] [image]

.NET Framework Class Library
EditRecurrenceControl Fields
EditRecurrenceControl Class See Also

The EditRecurrenceControl type exposes the following members.

Fields

Name | Description
SchedulerProperty | Identifies the Scheduler dependency property.

See Also

EditRecurrenceControl Class


SchedulerProperty Field

[image]

.NET Framework Class Library
EditRecurrenceControl..::..SchedulerProperty Field
EditRecurrenceControl Class See Also
Identifies the Scheduler dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty SchedulerProperty
Visual Basic
Public Shared ReadOnly SchedulerProperty As DependencyProperty

See Also

EditRecurrenceControl Class


EditRecurrenceControl Methods

[image] [image]

.NET Framework Class Library
EditRecurrenceControl Methods
EditRecurrenceControl Class See Also

The EditRecurrenceControl type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InitializeComponent | InitializeComponent
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Overrides ControlOnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

EditRecurrenceControl Class


InitializeComponent Method

[image]

.NET Framework Class Library
EditRecurrenceControl..::..InitializeComponent Method
EditRecurrenceControl Class See Also
InitializeComponent

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DebuggerNonUserCodeAttribute]
public void InitializeComponent()
Visual Basic
<DebuggerNonUserCodeAttribute> _
Public Sub InitializeComponent

See Also

EditRecurrenceControl Class


OnKeyDown Method

[image]

.NET Framework Class Library
EditRecurrenceControl..::..OnKeyDown Method
EditRecurrenceControl Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)

Parameters

e
Type: System.Windows.Input..::..KeyEventArgs

See Also

EditRecurrenceControl Class


EditRecurrenceControl Properties

[image] [image]

.NET Framework Class Library
EditRecurrenceControl Properties
EditRecurrenceControl Class See Also

The EditRecurrenceControl type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Protected property | Content | (Inherited from UserControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Scheduler | Gets or sets reference to the parent Scheduler control.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

EditRecurrenceControl Class


Scheduler Property

[image]

.NET Framework Class Library
EditRecurrenceControl..::..Scheduler Property
EditRecurrenceControl Class See Also
Gets or sets reference to the parent Scheduler control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1Scheduler Scheduler { get; set; }
Visual Basic
Public Property Scheduler As C1Scheduler
    Get
    Set

See Also

EditRecurrenceControl Class


EditRecurrenceControl Events

[image] [image]

.NET Framework Class Library
EditRecurrenceControl Events
EditRecurrenceControl Class See Also

The EditRecurrenceControl type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

EditRecurrenceControl Class


EnsureEnumMemberConverter Class

[image]

.NET Framework Class Library
EnsureEnumMemberConverter Class
Members See Also
Represents a Binding converter that indicates whether a binding source value is one of enum members specified in the converter parameter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class EnsureEnumMemberConverter : IValueConverter
Visual Basic
Public Class EnsureEnumMemberConverter _
    Implements IValueConverter

Remarks

EnsureEnumMemberConverter is a two-way converter. A converter parameter should be a string representing a list of enum member names separated by the ';' or ',' character.

Source - Target behavior:

Returns True if a source value is one of the enum members listed in a parameter; otherwise, False.

Target - Source behavior:

If target is True, then returns a first enum member (as enum, not as a string name) from members listed in a converter parameter.

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..EnsureEnumMemberConverter

See Also

EnsureEnumMemberConverter Members


EnsureEnumMemberConverter Members

[image] [image]

.NET Framework Class Library
EnsureEnumMemberConverter Members
EnsureEnumMemberConverter Class Constructors Methods Fields See Also

The EnsureEnumMemberConverter type exposes the following members.

Constructors

 | Name | Description
Public method | EnsureEnumMemberConverter |

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Default | Gets an instance of EnsureEnumMemberConverter.

See Also

EnsureEnumMemberConverter Class


EnsureEnumMemberConverter Constructor

[image]

.NET Framework Class Library
EnsureEnumMemberConverter Constructor
EnsureEnumMemberConverter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public EnsureEnumMemberConverter()
Visual Basic
Public Sub New

See Also

EnsureEnumMemberConverter Class


EnsureEnumMemberConverter Fields

[image] [image]

.NET Framework Class Library
EnsureEnumMemberConverter Fields
EnsureEnumMemberConverter Class See Also

The EnsureEnumMemberConverter type exposes the following members.

Fields

Name | Description
Default | Gets an instance of EnsureEnumMemberConverter.

See Also

EnsureEnumMemberConverter Class


Default Field

[image]

.NET Framework Class Library
EnsureEnumMemberConverter..::..Default Field
EnsureEnumMemberConverter Class See Also
Gets an instance of EnsureEnumMemberConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly EnsureEnumMemberConverter Default
Visual Basic
Public Shared ReadOnly Default As EnsureEnumMemberConverter

See Also

EnsureEnumMemberConverter Class


EnsureEnumMemberConverter Methods

[image] [image]

.NET Framework Class Library
EnsureEnumMemberConverter Methods
EnsureEnumMemberConverter Class See Also

The EnsureEnumMemberConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EnsureEnumMemberConverter Class


Convert Method

[image]

.NET Framework Class Library
EnsureEnumMemberConverter..::..Convert Method
EnsureEnumMemberConverter Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

EnsureEnumMemberConverter Class


ConvertBack Method

[image]

.NET Framework Class Library
EnsureEnumMemberConverter..::..ConvertBack Method
EnsureEnumMemberConverter Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value that is produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

EnsureEnumMemberConverter Class


Extensions Class

[image]

.NET Framework Class Library
Extensions Class
See Also
Class that provides static extension methods for several other classes.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static class Extensions
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class Extensions

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..Extensions

See Also


GroupedListBox Class

[image]

.NET Framework Class Library
GroupedListBox Class
Members See Also
Contains a list of selectable items. Supports grouping.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class GroupedListBox : ListBox,
    ICollectionChangedListener
Visual Basic
Public Class GroupedListBox _
    Inherits ListBox _
    Implements ICollectionChangedListener

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ItemsControl
System.Windows.Controls.Primitives..::..Selector
System.Windows.Controls..::..ListBox
C1.Silverlight.Schedule..::..GroupedListBox
C1.Silverlight.Schedule..::..VisualIntervalsPresenter

See Also

GroupedListBox Members


GroupedListBox Members

[image] [image]

.NET Framework Class Library
GroupedListBox Members
GroupedListBox Class Constructors Methods Fields Properties Events See Also

The GroupedListBox type exposes the following members.

Constructors

 | Name | Description
Public method | GroupedListBox | Initializes a new instance of the GroupedListBox control.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Protected method | ClearContainerForItemOverride | (Inherited from Selector.)
Protected method | ClearSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Protected method | DetachEvents | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Protected method | GetContainerForItemOverride | (Overrides ListBox..::..GetContainerForItemOverride()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetIndexForListBoxItem | Returns the index to an item that corresponds to the specified, generated container element.
 | GetItemsOwner | Returns the GroupedListBox that the specified element hosts items for.
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | HandleItemSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Protected method | IsAboutToDispose | Override this method in derived classes and return true when control should stop handle selection.
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ListBox.)
 | ItemsControlFromItemContainer | Returns the GroupedListBox that owns the specified container element.
Protected method | MakeRangeSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.
Protected method | MakeSingleSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.
Protected method | MakeToggleSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | (Inherited from ListBox.)
Public method | OnCollectionChanged | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBox.)
Protected method | OnGotFocus | (Inherited from ListBox.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnKeyDown | (Overrides ListBox..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from ListBox.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | (Overrides ListBox..::..PrepareContainerForItemOverride(DependencyObject, Object).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Protected method | SelectRange | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.
Protected method | SelectSingleItem | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.
Public method | SetBinding | (Inherited from FrameworkElement.)
Protected method | SetFocusedItem | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

 | Name | Description
Protected field | _anchor |
Protected field | _selectedItems |
Protected field | _updatingSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.
 | GroupStyleSelectorProperty | Identifies the GroupStyleSelector dependency property.
 | HasItemsProperty | Identifies the HasItems dependency property.
 | IsGroupingProperty | Identifies the IsGrouping dependency property.
 | ItemContainerStyleSelectorProperty | Identifies the ItemContainerStyleSelector dependency property.
 | ItemTemplateSelectorProperty | Identifies the ItemTemplateSelector dependency property.
 | PanelTemplateProperty | Identifies the PanelTemplate dependency property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups.
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. This is a dependency property.
Public property | HasItems | Gets a value that indicates whether the GroupedListBox contains items. This is a dependency property.
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. This is a dependency property.
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control.
Public property | ItemContainerStyle | (Inherited from ListBox.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. This is a dependency property.
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. This is a dependency property.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | PanelTemplate | Gets or sets the DataTemplate that defines the panel that controls the layout of items. This is a dependency property.
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty This is a dependency property. (Inherited from Selector.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

GroupedListBox Class


GroupedListBox Constructor

[image]

.NET Framework Class Library
GroupedListBox Constructor
GroupedListBox Class See Also
Initializes a new instance of the GroupedListBox control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public GroupedListBox()
Visual Basic
Public Sub New

See Also

GroupedListBox Class


GroupedListBox Fields

[image] [image]

.NET Framework Class Library
GroupedListBox Fields
GroupedListBox Class See Also

The GroupedListBox type exposes the following members.

Fields

 | Name | Description
Protected field | _anchor |
Protected field | _selectedItems |
Protected field | _updatingSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.
 | GroupStyleSelectorProperty | Identifies the GroupStyleSelector dependency property.
 | HasItemsProperty | Identifies the HasItems dependency property.
 | IsGroupingProperty | Identifies the IsGrouping dependency property.
 | ItemContainerStyleSelectorProperty | Identifies the ItemContainerStyleSelector dependency property.
 | ItemTemplateSelectorProperty | Identifies the ItemTemplateSelector dependency property.
 | PanelTemplateProperty | Identifies the PanelTemplate dependency property.

See Also

GroupedListBox Class


_anchor Field

[image]

.NET Framework Class Library
GroupedListBox..::.._anchor Field
GroupedListBox Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[CLSCompliantAttribute(false)]
protected ListBoxItem _anchor
Visual Basic
<CLSCompliantAttribute(False)> _
Protected _anchor As ListBoxItem

See Also

GroupedListBox Class


_selectedItems Field

[image]

.NET Framework Class Library
GroupedListBox..::.._selectedItems Field
GroupedListBox Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[CLSCompliantAttribute(false)]
protected ObservableCollection<Object> _selectedItems
Visual Basic
<CLSCompliantAttribute(False)> _
Protected _selectedItems As ObservableCollection(Of Object)

See Also

GroupedListBox Class


_updatingSelection Field

[image]

.NET Framework Class Library
GroupedListBox..::.._updatingSelection Field
GroupedListBox Class See Also
This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[CLSCompliantAttribute(false)]
protected bool _updatingSelection
Visual Basic
<CLSCompliantAttribute(False)> _
Protected _updatingSelection As Boolean

See Also

GroupedListBox Class


GroupStyleSelectorProperty Field

[image]

.NET Framework Class Library
GroupedListBox..::..GroupStyleSelectorProperty Field
GroupedListBox Class See Also
Identifies the GroupStyleSelector dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty GroupStyleSelectorProperty
Visual Basic
Public Shared ReadOnly GroupStyleSelectorProperty As DependencyProperty

See Also

GroupedListBox Class


HasItemsProperty Field

[image]

.NET Framework Class Library
GroupedListBox..::..HasItemsProperty Field
GroupedListBox Class See Also
Identifies the HasItems dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty HasItemsProperty
Visual Basic
Public Shared ReadOnly HasItemsProperty As DependencyProperty

See Also

GroupedListBox Class


IsGroupingProperty Field

[image]

.NET Framework Class Library
GroupedListBox..::..IsGroupingProperty Field
GroupedListBox Class See Also
Identifies the IsGrouping dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty IsGroupingProperty
Visual Basic
Public Shared ReadOnly IsGroupingProperty As DependencyProperty

See Also

GroupedListBox Class


ItemContainerStyleSelectorProperty Field

[image]

.NET Framework Class Library
GroupedListBox..::..ItemContainerStyleSelectorProperty Field
GroupedListBox Class See Also
Identifies the ItemContainerStyleSelector dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty ItemContainerStyleSelectorProperty
Visual Basic
Public Shared ReadOnly ItemContainerStyleSelectorProperty As DependencyProperty

See Also

GroupedListBox Class


ItemTemplateSelectorProperty Field

[image]

.NET Framework Class Library
GroupedListBox..::..ItemTemplateSelectorProperty Field
GroupedListBox Class See Also
Identifies the ItemTemplateSelector dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty ItemTemplateSelectorProperty
Visual Basic
Public Shared ReadOnly ItemTemplateSelectorProperty As DependencyProperty

See Also

GroupedListBox Class


PanelTemplateProperty Field

[image]

.NET Framework Class Library
GroupedListBox..::..PanelTemplateProperty Field
GroupedListBox Class See Also
Identifies the PanelTemplate dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty PanelTemplateProperty
Visual Basic
Public Shared ReadOnly PanelTemplateProperty As DependencyProperty

See Also

GroupedListBox Class


GroupedListBox Methods

[image] [image]

.NET Framework Class Library
GroupedListBox Methods
GroupedListBox Class See Also

The GroupedListBox type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Protected method | ClearContainerForItemOverride | (Inherited from Selector.)
Protected method | ClearSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Protected method | DetachEvents | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Protected method | GetContainerForItemOverride | (Overrides ListBox..::..GetContainerForItemOverride()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetIndexForListBoxItem | Returns the index to an item that corresponds to the specified, generated container element.
 | GetItemsOwner | Returns the GroupedListBox that the specified element hosts items for.
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | HandleItemSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Protected method | IsAboutToDispose | Override this method in derived classes and return true when control should stop handle selection.
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ListBox.)
 | ItemsControlFromItemContainer | Returns the GroupedListBox that owns the specified container element.
Protected method | MakeRangeSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.
Protected method | MakeSingleSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.
Protected method | MakeToggleSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | (Inherited from ListBox.)
Public method | OnCollectionChanged | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBox.)
Protected method | OnGotFocus | (Inherited from ListBox.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnKeyDown | (Overrides ListBox..::..OnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from ListBox.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | (Overrides ListBox..::..PrepareContainerForItemOverride(DependencyObject, Object).)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Protected method | SelectRange | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.
Protected method | SelectSingleItem | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.
Public method | SetBinding | (Inherited from FrameworkElement.)
Protected method | SetFocusedItem | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

GroupedListBox Class


ClearSelection Method

[image]

.NET Framework Class Library
GroupedListBox..::..ClearSelection Method
GroupedListBox Class See Also
This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void ClearSelection()
Visual Basic
Protected Overridable Sub ClearSelection

See Also

GroupedListBox Class


DetachEvents Method

[image]

.NET Framework Class Library
GroupedListBox..::..DetachEvents Method
GroupedListBox Class See Also
This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void DetachEvents()
Visual Basic
Protected Overridable Sub DetachEvents

See Also

GroupedListBox Class


GetContainerForItemOverride Method

[image]

.NET Framework Class Library
GroupedListBox..::..GetContainerForItemOverride Method
GroupedListBox Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override DependencyObject GetContainerForItemOverride()
Visual Basic
Protected Overrides Function GetContainerForItemOverride As DependencyObject

See Also

GroupedListBox Class


GetIndexForListBoxItem Method

[image]

.NET Framework Class Library
GroupedListBox..::..GetIndexForListBoxItem Method
GroupedListBox Class See Also
Returns the index to an item that corresponds to the specified, generated container element.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected int GetIndexForListBoxItem(
    ListBoxItem item
)
Visual Basic
Protected Function GetIndexForListBoxItem ( _
    item As ListBoxItem _
) As Integer

Parameters

item
Type: System.Windows.Controls..::..ListBoxItem
The container that corresponds to the item to the index to be returned.

Return Value

An index to an item that corresponds to the specified, generated container element.

See Also

GroupedListBox Class


GetItemsOwner Method

[image]

.NET Framework Class Library
GroupedListBox..::..GetItemsOwner Method
GroupedListBox Class See Also
Returns the GroupedListBox that the specified element hosts items for.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static GroupedListBox GetItemsOwner(
    DependencyObject element
)
Visual Basic
Public Shared Function GetItemsOwner ( _
    element As DependencyObject _
) As GroupedListBox

Parameters

element
Type: System.Windows..::..DependencyObject
The host element.

Return Value

The GroupedListBox that the specified element hosts items for, or null reference.

See Also

GroupedListBox Class


HandleItemSelection Method

[image]

.NET Framework Class Library
GroupedListBox..::..HandleItemSelection Method
GroupedListBox Class See Also
This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void HandleItemSelection(
    ListBoxItem item,
    bool isMouseSelection
)
Visual Basic
Protected Overridable Sub HandleItemSelection ( _
    item As ListBoxItem, _
    isMouseSelection As Boolean _
)

Parameters

item
Type: System.Windows.Controls..::..ListBoxItem
isMouseSelection
Type: System..::..Boolean

See Also

GroupedListBox Class


IsAboutToDispose Method

[image]

.NET Framework Class Library
GroupedListBox..::..IsAboutToDispose Method
GroupedListBox Class See Also
Override this method in derived classes and return true when control should stop handle selection.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual bool IsAboutToDispose()
Visual Basic
Protected Overridable Function IsAboutToDispose As Boolean

Return Value

The base implementation returns False if control is a part of a visual tree; otherwise, True.

See Also

GroupedListBox Class


ItemsControlFromItemContainer Method

[image]

.NET Framework Class Library
GroupedListBox..::..ItemsControlFromItemContainer Method
GroupedListBox Class See Also
Returns the GroupedListBox that owns the specified container element.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static GroupedListBox ItemsControlFromItemContainer(
    DependencyObject container
)
Visual Basic
Public Shared Function ItemsControlFromItemContainer ( _
    container As DependencyObject _
) As GroupedListBox

Parameters

container
Type: System.Windows..::..DependencyObject
The container element to return the GroupedListBox for.

Return Value

The GroupedListBox that owns the specified container element.

See Also

GroupedListBox Class


MakeRangeSelection Method

[image]

.NET Framework Class Library
GroupedListBox..::..MakeRangeSelection Method
GroupedListBox Class See Also
This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected void MakeRangeSelection(
    ListBoxItem rangeEnd,
    bool clearOldSelection
)
Visual Basic
Protected Sub MakeRangeSelection ( _
    rangeEnd As ListBoxItem, _
    clearOldSelection As Boolean _
)

Parameters

rangeEnd
Type: System.Windows.Controls..::..ListBoxItem
clearOldSelection
Type: System..::..Boolean

See Also

GroupedListBox Class


MakeSingleSelection Method

[image]

.NET Framework Class Library
GroupedListBox..::..MakeSingleSelection Method
GroupedListBox Class See Also
This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected void MakeSingleSelection(
    ListBoxItem item
)
Visual Basic
Protected Sub MakeSingleSelection ( _
    item As ListBoxItem _
)

Parameters

item
Type: System.Windows.Controls..::..ListBoxItem

See Also

GroupedListBox Class


MakeToggleSelection Method

[image]

.NET Framework Class Library
GroupedListBox..::..MakeToggleSelection Method
GroupedListBox Class See Also
This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected void MakeToggleSelection(
    ListBoxItem item
)
Visual Basic
Protected Sub MakeToggleSelection ( _
    item As ListBoxItem _
)

Parameters

item
Type: System.Windows.Controls..::..ListBoxItem

See Also

GroupedListBox Class


OnCollectionChanged Method

[image]

.NET Framework Class Library
GroupedListBox..::..OnCollectionChanged Method
GroupedListBox Class See Also
This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void OnCollectionChanged(
    Object sender,
    NotifyCollectionChangedEventArgs e
)
Visual Basic
Public Sub OnCollectionChanged ( _
    sender As Object, _
    e As NotifyCollectionChangedEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: System.Collections.Specialized..::..NotifyCollectionChangedEventArgs

See Also

GroupedListBox Class


OnKeyDown Method

[image]

.NET Framework Class Library
GroupedListBox..::..OnKeyDown Method
GroupedListBox Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)

Parameters

e
Type: System.Windows.Input..::..KeyEventArgs

See Also

GroupedListBox Class


PrepareContainerForItemOverride Method

[image]

.NET Framework Class Library
GroupedListBox..::..PrepareContainerForItemOverride Method
GroupedListBox Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Visual Basic
Protected Overrides Sub PrepareContainerForItemOverride ( _
    element As DependencyObject, _
    item As Object _
)

Parameters

element
Type: System.Windows..::..DependencyObject
item
Type: System..::..Object

See Also

GroupedListBox Class


SelectRange Method

[image]

.NET Framework Class Library
GroupedListBox..::..SelectRange Method
GroupedListBox Class See Also
This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected void SelectRange(
    int startIndex,
    int endIndex,
    bool clearOldSelection
)
Visual Basic
Protected Sub SelectRange ( _
    startIndex As Integer, _
    endIndex As Integer, _
    clearOldSelection As Boolean _
)

Parameters

startIndex
Type: System..::..Int32
endIndex
Type: System..::..Int32
clearOldSelection
Type: System..::..Boolean

See Also

GroupedListBox Class


SelectSingleItem Method

[image]

.NET Framework Class Library
GroupedListBox..::..SelectSingleItem Method
GroupedListBox Class See Also
This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected void SelectSingleItem(
    Object item
)
Visual Basic
Protected Sub SelectSingleItem ( _
    item As Object _
)

Parameters

item
Type: System..::..Object

See Also

GroupedListBox Class


SetFocusedItem Method

[image]

.NET Framework Class Library
GroupedListBox..::..SetFocusedItem Method
GroupedListBox Class See Also
This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected void SetFocusedItem(
    ListBoxItem item,
    bool scrollIntoView
)
Visual Basic
Protected Sub SetFocusedItem ( _
    item As ListBoxItem, _
    scrollIntoView As Boolean _
)

Parameters

item
Type: System.Windows.Controls..::..ListBoxItem
scrollIntoView
Type: System..::..Boolean

See Also

GroupedListBox Class


ShouldSerializeGroupStyle Method

[image]

.NET Framework Class Library
GroupedListBox..::..ShouldSerializeGroupStyle Method
GroupedListBox Class See Also
Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool ShouldSerializeGroupStyle()
Visual Basic
Public Function ShouldSerializeGroupStyle As Boolean

Return Value

True if the GroupStyle property value should be serialized; otherwise, False.

See Also

GroupedListBox Class


GroupedListBox Properties

[image] [image]

.NET Framework Class Library
GroupedListBox Properties
GroupedListBox Class See Also

The GroupedListBox type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups.
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. This is a dependency property.
Public property | HasItems | Gets a value that indicates whether the GroupedListBox contains items. This is a dependency property.
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. This is a dependency property.
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control.
Public property | ItemContainerStyle | (Inherited from ListBox.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. This is a dependency property.
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. This is a dependency property.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | PanelTemplate | Gets or sets the DataTemplate that defines the panel that controls the layout of items. This is a dependency property.
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty This is a dependency property. (Inherited from Selector.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

GroupedListBox Class


GroupStyle Property

[image]

.NET Framework Class Library
GroupedListBox..::..GroupStyle Property
GroupedListBox Class See Also
Gets a collection of GroupStyle objects that define the appearance of each level of groups.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ObservableCollection<GroupStyle> GroupStyle { get; }
Visual Basic
Public ReadOnly Property GroupStyle As ObservableCollection(Of GroupStyle)
    Get

See Also

GroupedListBox Class


GroupStyleSelector Property

[image]

.NET Framework Class Library
GroupedListBox..::..GroupStyleSelector Property
GroupedListBox Class See Also
Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public GroupStyleSelector GroupStyleSelector { get; set; }
Visual Basic
Public Property GroupStyleSelector As GroupStyleSelector
    Get
    Set

See Also

GroupedListBox Class


HasItems Property

[image]

.NET Framework Class Library
GroupedListBox..::..HasItems Property
GroupedListBox Class See Also
Gets a value that indicates whether the GroupedListBox contains items. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool HasItems { get; }
Visual Basic
Public ReadOnly Property HasItems As Boolean
    Get

See Also

GroupedListBox Class


IsGrouping Property

[image]

.NET Framework Class Library
GroupedListBox..::..IsGrouping Property
GroupedListBox Class See Also
Gets a value that indicates whether the control is using grouping. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsGrouping { get; }
Visual Basic
Public ReadOnly Property IsGrouping As Boolean
    Get

See Also

GroupedListBox Class


ItemContainerGenerator Property

[image]

.NET Framework Class Library
GroupedListBox..::..ItemContainerGenerator Property
GroupedListBox Class See Also
Gets the ItemContainerGenerator that is associated with the control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ItemContainerGenerator ItemContainerGenerator { get; }
Visual Basic
Public ReadOnly Property ItemContainerGenerator As ItemContainerGenerator
    Get

See Also

GroupedListBox Class


ItemContainerStyleSelector Property

[image]

.NET Framework Class Library
GroupedListBox..::..ItemContainerStyleSelector Property
GroupedListBox Class See Also
Gets or sets custom style-selection logic for a style that can be applied to each generated container element. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1StyleSelector ItemContainerStyleSelector { get; set; }
Visual Basic
Public Property ItemContainerStyleSelector As C1StyleSelector
    Get
    Set

See Also

GroupedListBox Class


ItemTemplateSelector Property

[image]

.NET Framework Class Library
GroupedListBox..::..ItemTemplateSelector Property
GroupedListBox Class See Also
Gets or sets the custom logic for choosing a template used to display each item. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1DataTemplateSelector ItemTemplateSelector { get; set; }
Visual Basic
Public Property ItemTemplateSelector As C1DataTemplateSelector
    Get
    Set

See Also

GroupedListBox Class


PanelTemplate Property

[image]

.NET Framework Class Library
GroupedListBox..::..PanelTemplate Property
GroupedListBox Class See Also
Gets or sets the DataTemplate that defines the panel that controls the layout of items. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DataTemplate PanelTemplate { get; set; }
Visual Basic
Public Property PanelTemplate As DataTemplate
    Get
    Set

See Also

GroupedListBox Class


GroupedListBox Events

[image] [image]

.NET Framework Class Library
GroupedListBox Events
GroupedListBox Class See Also

The GroupedListBox type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

GroupedListBox Class


GroupItem Class

[image]

.NET Framework Class Library
GroupItem Class
Members See Also
Appears as the root of the visual sub-tree generated for a group.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class GroupItem : ContentControl
Visual Basic
Public Class GroupItem _
    Inherits ContentControl

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ContentControl
C1.Silverlight.Schedule..::..GroupItem

See Also

GroupItem Members


GroupItem Members

[image] [image]

.NET Framework Class Library
GroupItem Members
GroupItem Class Constructors Methods Properties Events See Also

The GroupItem type exposes the following members.

Constructors

 | Name | Description
Public method | GroupItem | Initializes a new instance of the GroupItem class.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

GroupItem Class


GroupItem Constructor

[image]

.NET Framework Class Library
GroupItem Constructor
GroupItem Class See Also
Initializes a new instance of the GroupItem class.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public GroupItem()
Visual Basic
Public Sub New

See Also

GroupItem Class


GroupItem Methods

[image] [image]

.NET Framework Class Library
GroupItem Methods
GroupItem Class See Also

The GroupItem type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

GroupItem Class


GroupItem Properties

[image] [image]

.NET Framework Class Library
GroupItem Properties
GroupItem Class See Also

The GroupItem type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

GroupItem Class


GroupItem Events

[image] [image]

.NET Framework Class Library
GroupItem Events
GroupItem Class See Also

The GroupItem type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

GroupItem Class


GroupStyle Class

[image]

.NET Framework Class Library
GroupStyle Class
Members See Also
Defines how you want the group to look at each level.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class GroupStyle : INotifyPropertyChanged
Visual Basic
Public Class GroupStyle _
    Implements INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..GroupStyle

See Also

GroupStyle Members


GroupStyle Members

[image] [image]

.NET Framework Class Library
GroupStyle Members
GroupStyle Class Constructors Methods Properties Events See Also

The GroupStyle type exposes the following members.

Constructors

 | Name | Description
Public method | GroupStyle |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ContainerStyle | Gets or sets the style that is applied to the GroupItem generated for each item.
Public property | ContainerStyleSelector | Enables the application writer to provide custom selection logic for a style to apply to each generated GroupItem.
 | Default | Gets the default style of the group.
Public property | HeaderTemplate | Gets or sets the template that is used to display the group header.
Public property | HeaderTemplateSelector | Enables the application writer to provide custom selection logic for a template that is used to display the group header.
Public property | HidesIfEmpty | Gets or sets whether items corresponding to empty groups should be displayed.
Public property | Panel | Gets or sets a template that creates the panel used to layout the items.

Events

 | Name | Description
Public event | PropertyChanged | Occurs after the value of a GroupStyle property is changed.

See Also

GroupStyle Class


GroupStyle Constructor

[image]

.NET Framework Class Library
GroupStyle Constructor
GroupStyle Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public GroupStyle()
Visual Basic
Public Sub New

See Also

GroupStyle Class


GroupStyle Methods

[image] [image]

.NET Framework Class Library
GroupStyle Methods
GroupStyle Class See Also

The GroupStyle type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GroupStyle Class


OnPropertyChanged Method

[image]

.NET Framework Class Library
GroupStyle..::..OnPropertyChanged Method
GroupStyle Class See Also
Raises the PropertyChanged event with the provided arguments.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs e
)
Visual Basic
Protected Overridable Sub OnPropertyChanged ( _
    e As PropertyChangedEventArgs _
)

Parameters

e
Type: System.ComponentModel..::..PropertyChangedEventArgs
Arguments of the event being raised.

See Also

GroupStyle Class


GroupStyle Properties

[image] [image]

.NET Framework Class Library
GroupStyle Properties
GroupStyle Class See Also

The GroupStyle type exposes the following members.

Properties

 | Name | Description
Public property | ContainerStyle | Gets or sets the style that is applied to the GroupItem generated for each item.
Public property | ContainerStyleSelector | Enables the application writer to provide custom selection logic for a style to apply to each generated GroupItem.
 | Default | Gets the default style of the group.
Public property | HeaderTemplate | Gets or sets the template that is used to display the group header.
Public property | HeaderTemplateSelector | Enables the application writer to provide custom selection logic for a template that is used to display the group header.
Public property | HidesIfEmpty | Gets or sets whether items corresponding to empty groups should be displayed.
Public property | Panel | Gets or sets a template that creates the panel used to layout the items.

See Also

GroupStyle Class


ContainerStyle Property

[image]

.NET Framework Class Library
GroupStyle..::..ContainerStyle Property
GroupStyle Class See Also
Gets or sets the style that is applied to the GroupItem generated for each item.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(null)]
public Style ContainerStyle { get; set; }
Visual Basic
<DefaultValueAttribute(Nothing)> _
Public Property ContainerStyle As Style
    Get
    Set

See Also

GroupStyle Class


ContainerStyleSelector Property

[image]

.NET Framework Class Library
GroupStyle..::..ContainerStyleSelector Property
GroupStyle Class See Also
Enables the application writer to provide custom selection logic for a style to apply to each generated GroupItem.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(null)]
public C1StyleSelector ContainerStyleSelector { get; set; }
Visual Basic
<DefaultValueAttribute(Nothing)> _
Public Property ContainerStyleSelector As C1StyleSelector
    Get
    Set

See Also

GroupStyle Class


Default Property

[image]

.NET Framework Class Library
GroupStyle..::..Default Property
GroupStyle Class See Also
Gets the default style of the group.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static GroupStyle Default { get; }
Visual Basic
Public Shared ReadOnly Property Default As GroupStyle
    Get

See Also

GroupStyle Class


HeaderTemplate Property

[image]

.NET Framework Class Library
GroupStyle..::..HeaderTemplate Property
GroupStyle Class See Also
Gets or sets the template that is used to display the group header.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(null)]
public DataTemplate HeaderTemplate { get; set; }
Visual Basic
<DefaultValueAttribute(Nothing)> _
Public Property HeaderTemplate As DataTemplate
    Get
    Set

See Also

GroupStyle Class


HeaderTemplateSelector Property

[image]

.NET Framework Class Library
GroupStyle..::..HeaderTemplateSelector Property
GroupStyle Class See Also
Enables the application writer to provide custom selection logic for a template that is used to display the group header.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(null)]
public C1DataTemplateSelector HeaderTemplateSelector { get; set; }
Visual Basic
<DefaultValueAttribute(Nothing)> _
Public Property HeaderTemplateSelector As C1DataTemplateSelector
    Get
    Set

See Also

GroupStyle Class


HidesIfEmpty Property

[image]

.NET Framework Class Library
GroupStyle..::..HidesIfEmpty Property
GroupStyle Class See Also
Gets or sets whether items corresponding to empty groups should be displayed.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultValueAttribute(false)]
public bool HidesIfEmpty { get; set; }
Visual Basic
<DefaultValueAttribute(False)> _
Public Property HidesIfEmpty As Boolean
    Get
    Set

See Also

GroupStyle Class


Panel Property

[image]

.NET Framework Class Library
GroupStyle..::..Panel Property
GroupStyle Class See Also
Gets or sets a template that creates the panel used to layout the items.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DataTemplate Panel { get; set; }
Visual Basic
Public Property Panel As DataTemplate
    Get
    Set

See Also

GroupStyle Class


GroupStyle Events

[image] [image]

.NET Framework Class Library
GroupStyle Events
GroupStyle Class See Also

The GroupStyle type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs after the value of a GroupStyle property is changed.

See Also

GroupStyle Class


PropertyChanged Event

[image]

.NET Framework Class Library
GroupStyle..::..PropertyChanged Event
GroupStyle Class See Also
Occurs after the value of a GroupStyle property is changed.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

GroupStyle Class


GroupStyleSelector Delegate

[image]

.NET Framework Class Library
GroupStyleSelector Delegate
See Also
Delegate used to select the group style as a function of the parent group and its level.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public delegate GroupStyle GroupStyleSelector(
    CollectionViewGroup group,
    int level
)
Visual Basic
Public Delegate Function GroupStyleSelector ( _
    group As CollectionViewGroup, _
    level As Integer _
) As GroupStyle

Parameters

group
Type: System.Windows.Data..::..CollectionViewGroup
Group whose style is to be selected.
level
Type: System..::..Int32
Level of the group.

Return Value

Selected GroupStyle object.

See Also


GroupToSeparatorVisibilityConverter Class

[image]

.NET Framework Class Library
GroupToSeparatorVisibilityConverter Class
Members See Also
GroupToSeparatorVisibilityConverter returns a Visibility value determining whether separator should be shown for the specified SchedulerGroupItem.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class GroupToSeparatorVisibilityConverter : IValueConverter
Visual Basic
Public Class GroupToSeparatorVisibilityConverter _
    Implements IValueConverter

Remarks

The GroupToSeparatorVisibilityConverter is a one-way converter.

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..GroupToSeparatorVisibilityConverter

See Also

GroupToSeparatorVisibilityConverter Members


GroupToSeparatorVisibilityConverter Members

[image] [image]

.NET Framework Class Library
GroupToSeparatorVisibilityConverter Members
GroupToSeparatorVisibilityConverter Class Constructors Methods Fields See Also

The GroupToSeparatorVisibilityConverter type exposes the following members.

Constructors

 | Name | Description
Public method | GroupToSeparatorVisibilityConverter | Initializes a new instance of the GroupToSeparatorVisibilityConverter.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Throws System.NotImplementedException.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Default | Gets an instance of GroupToSeparatorVisibilityConverter.

See Also

GroupToSeparatorVisibilityConverter Class


GroupToSeparatorVisibilityConverter Constructor

[image]

.NET Framework Class Library
GroupToSeparatorVisibilityConverter Constructor
GroupToSeparatorVisibilityConverter Class See Also
Initializes a new instance of the GroupToSeparatorVisibilityConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public GroupToSeparatorVisibilityConverter()
Visual Basic
Public Sub New

See Also

GroupToSeparatorVisibilityConverter Class


GroupToSeparatorVisibilityConverter Fields

[image] [image]

.NET Framework Class Library
GroupToSeparatorVisibilityConverter Fields
GroupToSeparatorVisibilityConverter Class See Also

The GroupToSeparatorVisibilityConverter type exposes the following members.

Fields

Name | Description
Default | Gets an instance of GroupToSeparatorVisibilityConverter.

See Also

GroupToSeparatorVisibilityConverter Class


Default Field

[image]

.NET Framework Class Library
GroupToSeparatorVisibilityConverter..::..Default Field
GroupToSeparatorVisibilityConverter Class See Also
Gets an instance of GroupToSeparatorVisibilityConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly GroupToSeparatorVisibilityConverter Default
Visual Basic
Public Shared ReadOnly Default As GroupToSeparatorVisibilityConverter

See Also

GroupToSeparatorVisibilityConverter Class


GroupToSeparatorVisibilityConverter Methods

[image] [image]

.NET Framework Class Library
GroupToSeparatorVisibilityConverter Methods
GroupToSeparatorVisibilityConverter Class See Also

The GroupToSeparatorVisibilityConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Throws System.NotImplementedException.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GroupToSeparatorVisibilityConverter Class


Convert Method

[image]

.NET Framework Class Library
GroupToSeparatorVisibilityConverter..::..Convert Method
GroupToSeparatorVisibilityConverter Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

GroupToSeparatorVisibilityConverter Class


ConvertBack Method

[image]

.NET Framework Class Library
GroupToSeparatorVisibilityConverter..::..ConvertBack Method
GroupToSeparatorVisibilityConverter Class See Also
Throws System.NotImplementedException.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value that is produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

GroupToSeparatorVisibilityConverter Class


ImportanceEnumMemberConverter Class

[image]

.NET Framework Class Library
ImportanceEnumMemberConverter Class
Members See Also
Represents a Binding converter that indicates whether a binding source value is an enum member specified in the converter parameter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class ImportanceEnumMemberConverter : IValueConverter
Visual Basic
Public Class ImportanceEnumMemberConverter _
    Implements IValueConverter

Remarks

ImportanceEnumMemberConverter is a two-way converter.

Source - Target behavior:

If a binding source value is an enum member specified in a converter parameter, then a binding target value is True; otherwise, False.

Target - Source behavior:

If target is True, then the source is an enum member specified in a parameter. If target is False and parameter is High or Low, then source is Normal.

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..ImportanceEnumMemberConverter

See Also

ImportanceEnumMemberConverter Members


ImportanceEnumMemberConverter Members

[image] [image]

.NET Framework Class Library
ImportanceEnumMemberConverter Members
ImportanceEnumMemberConverter Class Constructors Methods Fields See Also

The ImportanceEnumMemberConverter type exposes the following members.

Constructors

 | Name | Description
Public method | ImportanceEnumMemberConverter |

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Default | Gets an instance of ImportanceEnumMemberConverter.

See Also

ImportanceEnumMemberConverter Class


ImportanceEnumMemberConverter Constructor

[image]

.NET Framework Class Library
ImportanceEnumMemberConverter Constructor
ImportanceEnumMemberConverter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ImportanceEnumMemberConverter()
Visual Basic
Public Sub New

See Also

ImportanceEnumMemberConverter Class


ImportanceEnumMemberConverter Fields

[image] [image]

.NET Framework Class Library
ImportanceEnumMemberConverter Fields
ImportanceEnumMemberConverter Class See Also

The ImportanceEnumMemberConverter type exposes the following members.

Fields

Name | Description
Default | Gets an instance of ImportanceEnumMemberConverter.

See Also

ImportanceEnumMemberConverter Class


Default Field

[image]

.NET Framework Class Library
ImportanceEnumMemberConverter..::..Default Field
ImportanceEnumMemberConverter Class See Also
Gets an instance of ImportanceEnumMemberConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly ImportanceEnumMemberConverter Default
Visual Basic
Public Shared ReadOnly Default As ImportanceEnumMemberConverter

See Also

ImportanceEnumMemberConverter Class


ImportanceEnumMemberConverter Methods

[image] [image]

.NET Framework Class Library
ImportanceEnumMemberConverter Methods
ImportanceEnumMemberConverter Class See Also

The ImportanceEnumMemberConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImportanceEnumMemberConverter Class


Convert Method

[image]

.NET Framework Class Library
ImportanceEnumMemberConverter..::..Convert Method
ImportanceEnumMemberConverter Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

ImportanceEnumMemberConverter Class


ConvertBack Method

[image]

.NET Framework Class Library
ImportanceEnumMemberConverter..::..ConvertBack Method
ImportanceEnumMemberConverter Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value that is produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

ImportanceEnumMemberConverter Class


IncrementConverter Class

[image]

.NET Framework Class Library
IncrementConverter Class
Members See Also
Represents a Binding converter that keeps binding target = binding source + 1, where source and target values are numeric.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class IncrementConverter : AddValueConverter
Visual Basic
Public Class IncrementConverter _
    Inherits AddValueConverter

Remarks

IncrementConverter is a two-way converter. When converting in any direction, a source value must be of any numeric type, and a converted value is of the System.Int32 type.

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..AddValueConverter
C1.Silverlight.Schedule..::..IncrementConverter

See Also

IncrementConverter Members


IncrementConverter Members

[image] [image]

.NET Framework Class Library
IncrementConverter Members
IncrementConverter Class Constructors Methods Fields See Also

The IncrementConverter type exposes the following members.

Constructors

 | Name | Description
Public method | IncrementConverter | Initializes a new instance of the IncrementConverter

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target. (Inherited from AddValueConverter.)
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source. (Inherited from AddValueConverter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Default | Gets an instance of IncrementConverter.

See Also

IncrementConverter Class


IncrementConverter Constructor

[image]

.NET Framework Class Library
IncrementConverter Constructor
IncrementConverter Class See Also
Initializes a new instance of the IncrementConverter

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public IncrementConverter()
Visual Basic
Public Sub New

See Also

IncrementConverter Class


IncrementConverter Fields

[image] [image]

.NET Framework Class Library
IncrementConverter Fields
IncrementConverter Class See Also

The IncrementConverter type exposes the following members.

Fields

Name | Description
Default | Gets an instance of IncrementConverter.

See Also

IncrementConverter Class


Default Field

[image]

.NET Framework Class Library
IncrementConverter..::..Default Field
IncrementConverter Class See Also
Gets an instance of IncrementConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly IncrementConverter Default
Visual Basic
Public Shared ReadOnly Default As IncrementConverter

See Also

IncrementConverter Class


IncrementConverter Methods

[image] [image]

.NET Framework Class Library
IncrementConverter Methods
IncrementConverter Class See Also

The IncrementConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target. (Inherited from AddValueConverter.)
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source. (Inherited from AddValueConverter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IncrementConverter Class


IntervalAppointment Class

[image]

.NET Framework Class Library
IntervalAppointment Class
Members See Also
Represents an Appointment in a VisualInterval.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class IntervalAppointment : DependencyObject
Visual Basic
Public Class IntervalAppointment _
    Inherits DependencyObject

Remarks

A single Appointment may cover multiple time intervals represented by VisualInterval objects from the VisualIntervals collection. The IntervalAppointment object represents an Appointment belonging to a certain Interval.

The IntervalAppointment objects are used as DataContext for the IntervalAppointmentTemplate DataTemplate.

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
C1.Silverlight.Schedule..::..IntervalAppointment

See Also

IntervalAppointment Members


IntervalAppointment Members

[image] [image]

.NET Framework Class Library
IntervalAppointment Members
IntervalAppointment Class Methods Fields Properties See Also

The IntervalAppointment type exposes the following members.

Methods

 | Name | Description
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
IsSelectedAppointmentProperty | Identifies the IsSelectedAppointment dependency property.
IsSelectedProperty | Identifies the IsSelected dependency property.

Properties

 | Name | Description
Public property | Appointment | Gets an Appointment that is intersected with a VisualInterval.
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | Interval | Gets a VisualInterval that intersects with an Appointment.
Public property | IsSelected | Gets or sets a value that determines whether the UI element that has this IntervalAppointment as a DataContext is selected. This is a dependency property.
Public property | IsSelectedAppointment | Gets or sets a value that determines whether the Appointment is selected in C1Scheduler UI.

See Also

IntervalAppointment Class


IntervalAppointment Fields

[image] [image]

.NET Framework Class Library
IntervalAppointment Fields
IntervalAppointment Class See Also

The IntervalAppointment type exposes the following members.

Fields

Name | Description
IsSelectedAppointmentProperty | Identifies the IsSelectedAppointment dependency property.
IsSelectedProperty | Identifies the IsSelected dependency property.

See Also

IntervalAppointment Class


IsSelectedAppointmentProperty Field

[image]

.NET Framework Class Library
IntervalAppointment..::..IsSelectedAppointmentProperty Field
IntervalAppointment Class See Also
Identifies the IsSelectedAppointment dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty IsSelectedAppointmentProperty
Visual Basic
Public Shared ReadOnly IsSelectedAppointmentProperty As DependencyProperty

See Also

IntervalAppointment Class


IsSelectedProperty Field

[image]

.NET Framework Class Library
IntervalAppointment..::..IsSelectedProperty Field
IntervalAppointment Class See Also
Identifies the IsSelected dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty IsSelectedProperty
Visual Basic
Public Shared ReadOnly IsSelectedProperty As DependencyProperty

See Also

IntervalAppointment Class


IntervalAppointment Methods

[image] [image]

.NET Framework Class Library
IntervalAppointment Methods
IntervalAppointment Class See Also

The IntervalAppointment type exposes the following members.

Methods

 | Name | Description
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IntervalAppointment Class


IntervalAppointment Properties

[image] [image]

.NET Framework Class Library
IntervalAppointment Properties
IntervalAppointment Class See Also

The IntervalAppointment type exposes the following members.

Properties

 | Name | Description
Public property | Appointment | Gets an Appointment that is intersected with a VisualInterval.
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | Interval | Gets a VisualInterval that intersects with an Appointment.
Public property | IsSelected | Gets or sets a value that determines whether the UI element that has this IntervalAppointment as a DataContext is selected. This is a dependency property.
Public property | IsSelectedAppointment | Gets or sets a value that determines whether the Appointment is selected in C1Scheduler UI.

See Also

IntervalAppointment Class


Appointment Property

[image]

.NET Framework Class Library
IntervalAppointment..::..Appointment Property
IntervalAppointment Class See Also
Gets an Appointment that is intersected with a VisualInterval.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Appointment Appointment { get; }
Visual Basic
Public ReadOnly Property Appointment As Appointment
    Get

See Also

IntervalAppointment Class


Interval Property

[image]

.NET Framework Class Library
IntervalAppointment..::..Interval Property
IntervalAppointment Class See Also
Gets a VisualInterval that intersects with an Appointment.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public VisualInterval Interval { get; }
Visual Basic
Public ReadOnly Property Interval As VisualInterval
    Get

See Also

IntervalAppointment Class


IsSelected Property

[image]

.NET Framework Class Library
IntervalAppointment..::..IsSelected Property
IntervalAppointment Class See Also
Gets or sets a value that determines whether the UI element that has this IntervalAppointment as a DataContext is selected. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic
Public Property IsSelected As Boolean
    Get
    Set

See Also

IntervalAppointment Class


IsSelectedAppointment Property

[image]

.NET Framework Class Library
IntervalAppointment..::..IsSelectedAppointment Property
IntervalAppointment Class See Also
Gets or sets a value that determines whether the Appointment is selected in C1Scheduler UI.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsSelectedAppointment { get; set; }
Visual Basic
Public Property IsSelectedAppointment As Boolean
    Get
    Set

See Also

IntervalAppointment Class


IntervalAppointmentCollection Class

[image]

.NET Framework Class Library
IntervalAppointmentCollection Class
Members See Also
The IntervalAppointmentCollection class is a ReadOnlyObservableCollection<(Of <(<'T>)>)> collection of IntervalAppointment objects belonging to a certain VisualInterval object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class IntervalAppointmentCollection : ReadOnlyObservableCollection
Visual Basic
Public Class IntervalAppointmentCollection _
    Inherits ReadOnlyObservableCollection

Inheritance Hierarchy

System.Collections.ObjectModel..::..ReadOnlyObservableCollection<(Of <(<'T>)>)>
C1.Silverlight.Schedule..::..IntervalAppointmentCollection

See Also

IntervalAppointmentCollection Members


IntervalAppointmentCollection Members

[image] [image]

.NET Framework Class Library
IntervalAppointmentCollection Members
IntervalAppointmentCollection Class Constructors Methods Properties See Also

The IntervalAppointmentCollection type exposes the following members.

Constructors

 | Name | Description
Public method | IntervalAppointmentCollection | Initializes the new instance of the IntervalAppointmentCollection class.

Methods

 | Name | Description
Protected method | OnCollectionChanged | Refreshes the HasItems property value.

Properties

 | Name | Description
Public property | HasItems | Gets the Boolean value specifying whether collection has items.

See Also

IntervalAppointmentCollection Class


IntervalAppointmentCollection Constructor

[image]

.NET Framework Class Library
IntervalAppointmentCollection Constructor
IntervalAppointmentCollection Class See Also
Initializes the new instance of the IntervalAppointmentCollection class.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public IntervalAppointmentCollection(
    ObservableCollection<IntervalAppointment> list
)
Visual Basic
Public Sub New ( _
    list As ObservableCollection(Of IntervalAppointment) _
)

Parameters

list
Type: System.Collections.ObjectModel..::..ObservableCollection <(Of <(<' IntervalAppointment >)>)>
The ObservableCollection<(Of <(<'T>)>)> object.

See Also

IntervalAppointmentCollection Class


IntervalAppointmentCollection Methods

[image] [image]

.NET Framework Class Library
IntervalAppointmentCollection Methods
IntervalAppointmentCollection Class See Also

The IntervalAppointmentCollection type exposes the following members.

Methods

 | Name | Description
Protected method | OnCollectionChanged | Refreshes the HasItems property value.

See Also

IntervalAppointmentCollection Class


OnCollectionChanged Method

[image]

.NET Framework Class Library
IntervalAppointmentCollection..::..OnCollectionChanged Method
IntervalAppointmentCollection Class See Also
Refreshes the HasItems property value.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnCollectionChanged(
    NotifyCollectionChangedEventArgs args
)
Visual Basic
Protected Overridable Sub OnCollectionChanged ( _
    args As NotifyCollectionChangedEventArgs _
)

Parameters

args
Type: System.Collections.Specialized..::..NotifyCollectionChangedEventArgs

See Also

IntervalAppointmentCollection Class


IntervalAppointmentCollection Properties

[image] [image]

.NET Framework Class Library
IntervalAppointmentCollection Properties
IntervalAppointmentCollection Class See Also

The IntervalAppointmentCollection type exposes the following members.

Properties

 | Name | Description
Public property | HasItems | Gets the Boolean value specifying whether collection has items.

See Also

IntervalAppointmentCollection Class


HasItems Property

[image]

.NET Framework Class Library
IntervalAppointmentCollection..::..HasItems Property
IntervalAppointmentCollection Class See Also
Gets the Boolean value specifying whether collection has items.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool HasItems { get; }
Visual Basic
Public ReadOnly Property HasItems As Boolean
    Get

See Also

IntervalAppointmentCollection Class


IntervalAppointmentPresenter Class

[image]

.NET Framework Class Library
IntervalAppointmentPresenter Class
Members See Also
The IntervalAppointmentPresenter class represents the single appointment element in the C1Scheduler UI and allows in-place appointment editing.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[TemplateVisualStateAttribute(Name = "Focused", GroupName = "FocusStates")]
[TemplatePartAttribute(Name = "PART_AppointmentWrapPanel", Type = typeof(AppointmentWrapPanel))]
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "MouseOver", GroupName = "CommonStates")]
[TemplatePartAttribute(Name = "PART_Subject", Type = typeof(TextBox))]
[TemplateVisualStateAttribute(Name = "Unselected", GroupName = "SelectionStates")]
[TemplateVisualStateAttribute(Name = "Selected", GroupName = "SelectionStates")]
[TemplateVisualStateAttribute(Name = "Unfocused", GroupName = "FocusStates")]
public class IntervalAppointmentPresenter : Control,
    IPropertyChangedListener
Visual Basic
<TemplateVisualStateAttribute(Name := "Focused", GroupName := "FocusStates")> _
<TemplatePartAttribute(Name := "PART_AppointmentWrapPanel", Type := GetType(AppointmentWrapPanel))> _
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "MouseOver", GroupName := "CommonStates")> _
<TemplatePartAttribute(Name := "PART_Subject", Type := GetType(TextBox))> _
<TemplateVisualStateAttribute(Name := "Unselected", GroupName := "SelectionStates")> _
<TemplateVisualStateAttribute(Name := "Selected", GroupName := "SelectionStates")> _
<TemplateVisualStateAttribute(Name := "Unfocused", GroupName := "FocusStates")> _
Public Class IntervalAppointmentPresenter _
    Inherits Control _
    Implements IPropertyChangedListener

Remarks

When user clicks on the IntervalAppointmentPresenter it tries to find and focus child element with x:Name="PART_Subject". It is used for switching appointment element into in-place editing mode.

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
C1.Silverlight.Schedule..::..IntervalAppointmentPresenter

See Also

IntervalAppointmentPresenter Members


IntervalAppointmentPresenter Members

[image] [image]

.NET Framework Class Library
IntervalAppointmentPresenter Members
IntervalAppointmentPresenter Class Constructors Methods Fields Properties Events See Also

The IntervalAppointmentPresenter type exposes the following members.

Constructors

 | Name | Description
Public method | IntervalAppointmentPresenter | Creates the new instance of the IntervalAppointmentPresenter class.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Overrides ControlOnKeyUp(KeyEventArgs).)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMouseEnter | (Overrides ControlOnMouseEnter(MouseEventArgs).)
Protected method | OnMouseLeave | (Overrides ControlOnMouseLeave(MouseEventArgs).)
Protected method | OnMouseLeftButtonDown | (Overrides ControlOnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
IntervalAppointmentProperty | Identifies the IntervalAppointment dependency property.
IsExceptionProperty | Identifies the IsException dependency property.
IsNotAllDayEventProperty | Identifies the IsNotAllDayEvent dependency property.
IsOccurrenceProperty | Identifies the IsOccurrence dependency property.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property.
IsSelectedProperty | Identifies the IsSelected dependency property.
ShowTimeBorderThicknessProperty | Identifies the ShowTimeBorderThickness dependency property.
TextWrappingProperty | Identifies the TextWrapping dependency property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Appointment | Gets the reference to the Appointment object.
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IntervalAppointment | Gets or sets the IntervalAppointment object which is represented by the IntervalAppointmentPresenter control.
Public property | IsEnabled | (Inherited from Control.)
Public property | IsException | Gets a boolean value specifying whether Appointment is an exception of a recurrence pattern.
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsNotAllDayEvent | Gets a boolean value specifying whether Appointment is not All-Day event.
Public property | IsOccurrence | Gets a boolean value specifying whether Appointment is an occurrence of a recurrence pattern.
Public property | IsReadOnly | Gets or sets a Boolean value that indicates whether the IntervalAppointmentPresenter is read-only to a user interacting with the control. This is a dependency property.
Public property | IsSelected | Gets or sets a value that determines whether the UI element that has this IntervalAppointment as a DataContext is selected. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | LabelBrush | Gets a Brush corresponding to the Appointment.Label.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | ShowTimeBorderThickness | Gets or sets a value determining the thickness of appointment availability status border. This is a dependency property.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | TextWrapping | Gets or sets how the text should be aligned. This is a dependency property.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

IntervalAppointmentPresenter Class


IntervalAppointmentPresenter Constructor

[image]

.NET Framework Class Library
IntervalAppointmentPresenter Constructor
IntervalAppointmentPresenter Class See Also
Creates the new instance of the IntervalAppointmentPresenter class.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public IntervalAppointmentPresenter()
Visual Basic
Public Sub New

See Also

IntervalAppointmentPresenter Class


IntervalAppointmentPresenter Fields

[image] [image]

.NET Framework Class Library
IntervalAppointmentPresenter Fields
IntervalAppointmentPresenter Class See Also

The IntervalAppointmentPresenter type exposes the following members.

Fields

Name | Description
IntervalAppointmentProperty | Identifies the IntervalAppointment dependency property.
IsExceptionProperty | Identifies the IsException dependency property.
IsNotAllDayEventProperty | Identifies the IsNotAllDayEvent dependency property.
IsOccurrenceProperty | Identifies the IsOccurrence dependency property.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property.
IsSelectedProperty | Identifies the IsSelected dependency property.
ShowTimeBorderThicknessProperty | Identifies the ShowTimeBorderThickness dependency property.
TextWrappingProperty | Identifies the TextWrapping dependency property.

See Also

IntervalAppointmentPresenter Class


IntervalAppointmentProperty Field

[image]

.NET Framework Class Library
IntervalAppointmentPresenter..::..IntervalAppointmentProperty Field
IntervalAppointmentPresenter Class See Also
Identifies the IntervalAppointment dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty IntervalAppointmentProperty
Visual Basic
Public Shared ReadOnly IntervalAppointmentProperty As DependencyProperty

See Also

IntervalAppointmentPresenter Class


IsExceptionProperty Field

[image]

.NET Framework Class Library
IntervalAppointmentPresenter..::..IsExceptionProperty Field
IntervalAppointmentPresenter Class See Also
Identifies the IsException dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty IsExceptionProperty
Visual Basic
Public Shared ReadOnly IsExceptionProperty As DependencyProperty

See Also

IntervalAppointmentPresenter Class


IsNotAllDayEventProperty Field

[image]

.NET Framework Class Library
IntervalAppointmentPresenter..::..IsNotAllDayEventProperty Field
IntervalAppointmentPresenter Class See Also
Identifies the IsNotAllDayEvent dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty IsNotAllDayEventProperty
Visual Basic
Public Shared ReadOnly IsNotAllDayEventProperty As DependencyProperty

See Also

IntervalAppointmentPresenter Class


IsOccurrenceProperty Field

[image]

.NET Framework Class Library
IntervalAppointmentPresenter..::..IsOccurrenceProperty Field
IntervalAppointmentPresenter Class See Also
Identifies the IsOccurrence dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty IsOccurrenceProperty
Visual Basic
Public Shared ReadOnly IsOccurrenceProperty As DependencyProperty

See Also

IntervalAppointmentPresenter Class


IsReadOnlyProperty Field

[image]

.NET Framework Class Library
IntervalAppointmentPresenter..::..IsReadOnlyProperty Field
IntervalAppointmentPresenter Class See Also
Identifies the IsReadOnly dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty IsReadOnlyProperty
Visual Basic
Public Shared ReadOnly IsReadOnlyProperty As DependencyProperty

See Also

IntervalAppointmentPresenter Class


IsSelectedProperty Field

[image]

.NET Framework Class Library
IntervalAppointmentPresenter..::..IsSelectedProperty Field
IntervalAppointmentPresenter Class See Also
Identifies the IsSelected dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty IsSelectedProperty
Visual Basic
Public Shared ReadOnly IsSelectedProperty As DependencyProperty

See Also

IntervalAppointmentPresenter Class


ShowTimeBorderThicknessProperty Field

[image]

.NET Framework Class Library
IntervalAppointmentPresenter..::..ShowTimeBorderThicknessProperty Field
IntervalAppointmentPresenter Class See Also
Identifies the ShowTimeBorderThickness dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty ShowTimeBorderThicknessProperty
Visual Basic
Public Shared ReadOnly ShowTimeBorderThicknessProperty As DependencyProperty

See Also

IntervalAppointmentPresenter Class


TextWrappingProperty Field

[image]

.NET Framework Class Library
IntervalAppointmentPresenter..::..TextWrappingProperty Field
IntervalAppointmentPresenter Class See Also
Identifies the TextWrapping dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty TextWrappingProperty
Visual Basic
Public Shared ReadOnly TextWrappingProperty As DependencyProperty

See Also

IntervalAppointmentPresenter Class


IntervalAppointmentPresenter Methods

[image] [image]

.NET Framework Class Library
IntervalAppointmentPresenter Methods
IntervalAppointmentPresenter Class See Also

The IntervalAppointmentPresenter type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Overrides ControlOnKeyUp(KeyEventArgs).)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMouseEnter | (Overrides ControlOnMouseEnter(MouseEventArgs).)
Protected method | OnMouseLeave | (Overrides ControlOnMouseLeave(MouseEventArgs).)
Protected method | OnMouseLeftButtonDown | (Overrides ControlOnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

IntervalAppointmentPresenter Class


OnKeyUp Method

[image]

.NET Framework Class Library
IntervalAppointmentPresenter..::..OnKeyUp Method
IntervalAppointmentPresenter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnKeyUp(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyUp ( _
    e As KeyEventArgs _
)

Parameters

e
Type: System.Windows.Input..::..KeyEventArgs

See Also

IntervalAppointmentPresenter Class


OnMouseEnter Method

[image]

.NET Framework Class Library
IntervalAppointmentPresenter..::..OnMouseEnter Method
IntervalAppointmentPresenter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnMouseEnter(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseEnter ( _
    e As MouseEventArgs _
)

Parameters

e
Type: System.Windows.Input..::..MouseEventArgs

See Also

IntervalAppointmentPresenter Class


OnMouseLeave Method

[image]

.NET Framework Class Library
IntervalAppointmentPresenter..::..OnMouseLeave Method
IntervalAppointmentPresenter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnMouseLeave(
    MouseEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseLeave ( _
    e As MouseEventArgs _
)

Parameters

e
Type: System.Windows.Input..::..MouseEventArgs

See Also

IntervalAppointmentPresenter Class


OnMouseLeftButtonDown Method

[image]

.NET Framework Class Library
IntervalAppointmentPresenter..::..OnMouseLeftButtonDown Method
IntervalAppointmentPresenter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnMouseLeftButtonDown(
    MouseButtonEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseLeftButtonDown ( _
    e As MouseButtonEventArgs _
)

Parameters

e
Type: System.Windows.Input..::..MouseButtonEventArgs

See Also

IntervalAppointmentPresenter Class


IntervalAppointmentPresenter Properties

[image] [image]

.NET Framework Class Library
IntervalAppointmentPresenter Properties
IntervalAppointmentPresenter Class See Also

The IntervalAppointmentPresenter type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Appointment | Gets the reference to the Appointment object.
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IntervalAppointment | Gets or sets the IntervalAppointment object which is represented by the IntervalAppointmentPresenter control.
Public property | IsEnabled | (Inherited from Control.)
Public property | IsException | Gets a boolean value specifying whether Appointment is an exception of a recurrence pattern.
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsNotAllDayEvent | Gets a boolean value specifying whether Appointment is not All-Day event.
Public property | IsOccurrence | Gets a boolean value specifying whether Appointment is an occurrence of a recurrence pattern.
Public property | IsReadOnly | Gets or sets a Boolean value that indicates whether the IntervalAppointmentPresenter is read-only to a user interacting with the control. This is a dependency property.
Public property | IsSelected | Gets or sets a value that determines whether the UI element that has this IntervalAppointment as a DataContext is selected. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | LabelBrush | Gets a Brush corresponding to the Appointment.Label.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | ShowTimeBorderThickness | Gets or sets a value determining the thickness of appointment availability status border. This is a dependency property.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | TextWrapping | Gets or sets how the text should be aligned. This is a dependency property.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

IntervalAppointmentPresenter Class


Appointment Property

[image]

.NET Framework Class Library
IntervalAppointmentPresenter..::..Appointment Property
IntervalAppointmentPresenter Class See Also
Gets the reference to the Appointment object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Appointment Appointment { get; }
Visual Basic
Public ReadOnly Property Appointment As Appointment
    Get

See Also

IntervalAppointmentPresenter Class


IntervalAppointment Property

[image]

.NET Framework Class Library
IntervalAppointmentPresenter..::..IntervalAppointment Property
IntervalAppointmentPresenter Class See Also
Gets or sets the IntervalAppointment object which is represented by the IntervalAppointmentPresenter control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public IntervalAppointment IntervalAppointment { get; set; }
Visual Basic
Public Property IntervalAppointment As IntervalAppointment
    Get
    Set

See Also

IntervalAppointmentPresenter Class


IsException Property

[image]

.NET Framework Class Library
IntervalAppointmentPresenter..::..IsException Property
IntervalAppointmentPresenter Class See Also
Gets a boolean value specifying whether Appointment is an exception of a recurrence pattern.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsException { get; }
Visual Basic
Public ReadOnly Property IsException As Boolean
    Get

See Also

IntervalAppointmentPresenter Class


IsNotAllDayEvent Property

[image]

.NET Framework Class Library
IntervalAppointmentPresenter..::..IsNotAllDayEvent Property
IntervalAppointmentPresenter Class See Also
Gets a boolean value specifying whether Appointment is not All-Day event.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsNotAllDayEvent { get; }
Visual Basic
Public ReadOnly Property IsNotAllDayEvent As Boolean
    Get

See Also

IntervalAppointmentPresenter Class


IsOccurrence Property

[image]

.NET Framework Class Library
IntervalAppointmentPresenter..::..IsOccurrence Property
IntervalAppointmentPresenter Class See Also
Gets a boolean value specifying whether Appointment is an occurrence of a recurrence pattern.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsOccurrence { get; }
Visual Basic
Public ReadOnly Property IsOccurrence As Boolean
    Get

See Also

IntervalAppointmentPresenter Class


IsReadOnly Property

[image]

.NET Framework Class Library
IntervalAppointmentPresenter..::..IsReadOnly Property
IntervalAppointmentPresenter Class See Also
Gets or sets a Boolean value that indicates whether the IntervalAppointmentPresenter is read-only to a user interacting with the control. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsReadOnly { get; set; }
Visual Basic
Public Property IsReadOnly As Boolean
    Get
    Set

Remarks

This value only affects a user who is interacting with the control. The contents of the AppointmentWrapPanel()()()() can always be modified programmatically.

See Also

IntervalAppointmentPresenter Class


IsSelected Property

[image]

.NET Framework Class Library
IntervalAppointmentPresenter..::..IsSelected Property
IntervalAppointmentPresenter Class See Also
Gets or sets a value that determines whether the UI element that has this IntervalAppointment as a DataContext is selected. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic
Public Property IsSelected As Boolean
    Get
    Set

See Also

IntervalAppointmentPresenter Class


LabelBrush Property

[image]

.NET Framework Class Library
IntervalAppointmentPresenter..::..LabelBrush Property
IntervalAppointmentPresenter Class See Also
Gets a Brush corresponding to the Appointment.Label.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Brush LabelBrush { get; }
Visual Basic
Public ReadOnly Property LabelBrush As Brush
    Get

See Also

IntervalAppointmentPresenter Class


ShowTimeBorderThickness Property

[image]

.NET Framework Class Library
IntervalAppointmentPresenter..::..ShowTimeBorderThickness Property
IntervalAppointmentPresenter Class See Also
Gets or sets a value determining the thickness of appointment availability status border. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Thickness ShowTimeBorderThickness { get; set; }
Visual Basic
Public Property ShowTimeBorderThickness As Thickness
    Get
    Set

See Also

IntervalAppointmentPresenter Class


TextWrapping Property

[image]

.NET Framework Class Library
IntervalAppointmentPresenter..::..TextWrapping Property
IntervalAppointmentPresenter Class See Also
Gets or sets how the text should be aligned. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public TextWrapping TextWrapping { get; set; }
Visual Basic
Public Property TextWrapping As TextWrapping
    Get
    Set

See Also

IntervalAppointmentPresenter Class


IntervalAppointmentPresenter Events

[image] [image]

.NET Framework Class Library
IntervalAppointmentPresenter Events
IntervalAppointmentPresenter Class See Also

The IntervalAppointmentPresenter type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

IntervalAppointmentPresenter Class


IntervalGroupDescriptionCollection Class

[image]

.NET Framework Class Library
IntervalGroupDescriptionCollection Class
Members See Also
Represents a collection of VisualIntervalGroupDescription objects.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class IntervalGroupDescriptionCollection : ObservableCollection<VisualIntervalGroupDescription>
Visual Basic
Public Class IntervalGroupDescriptionCollection _
    Inherits ObservableCollection(Of VisualIntervalGroupDescription)

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' VisualIntervalGroupDescription >)>)>
System.Collections.ObjectModel..::..ObservableCollection <(Of <(<' VisualIntervalGroupDescription >)>)>
C1.Silverlight.Schedule..::..IntervalGroupDescriptionCollection

See Also

IntervalGroupDescriptionCollection Members


IntervalGroupDescriptionCollection Members

[image] [image]

.NET Framework Class Library
IntervalGroupDescriptionCollection Members
IntervalGroupDescriptionCollection Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The IntervalGroupDescriptionCollection type exposes the following members.

Constructors

 | Name | Description
Public method | IntervalGroupDescriptionCollection | Initializes a new instance of the IntervalGroupDescriptionCollection class.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from ObservableCollection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)

Events

 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection <(Of <(<' VisualIntervalGroupDescription >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)

See Also

IntervalGroupDescriptionCollection Class


IntervalGroupDescriptionCollection Constructor

[image]

.NET Framework Class Library
IntervalGroupDescriptionCollection Constructor
IntervalGroupDescriptionCollection Class See Also
Initializes a new instance of the IntervalGroupDescriptionCollection class.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public IntervalGroupDescriptionCollection()
Visual Basic
Public Sub New

See Also

IntervalGroupDescriptionCollection Class


IntervalGroupDescriptionCollection Methods

[image] [image]

.NET Framework Class Library
IntervalGroupDescriptionCollection Methods
IntervalGroupDescriptionCollection Class See Also

The IntervalGroupDescriptionCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from ObservableCollection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)

See Also

IntervalGroupDescriptionCollection Class


IntervalGroupDescriptionCollection Properties

[image] [image]

.NET Framework Class Library
IntervalGroupDescriptionCollection Properties
IntervalGroupDescriptionCollection Class See Also

The IntervalGroupDescriptionCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' VisualIntervalGroupDescription >)>)>.)

See Also

IntervalGroupDescriptionCollection Class


IntervalGroupDescriptionCollection Events

[image] [image]

.NET Framework Class Library
IntervalGroupDescriptionCollection Events
IntervalGroupDescriptionCollection Class See Also

The IntervalGroupDescriptionCollection type exposes the following members.

Events

 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection <(Of <(<' VisualIntervalGroupDescription >)>)>.)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection <(Of <(<' VisualIntervalGroupDescription >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection <(Of <(<' VisualIntervalGroupDescription >)>)>.)

See Also

IntervalGroupDescriptionCollection Class


IntervalGroupStyleCollection Class

[image]

.NET Framework Class Library
IntervalGroupStyleCollection Class
Members See Also
Represents a collection of GroupStyle objects.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class IntervalGroupStyleCollection : ObservableCollection<GroupStyle>
Visual Basic
Public Class IntervalGroupStyleCollection _
    Inherits ObservableCollection(Of GroupStyle)

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' GroupStyle >)>)>
System.Collections.ObjectModel..::..ObservableCollection <(Of <(<' GroupStyle >)>)>
C1.Silverlight.Schedule..::..IntervalGroupStyleCollection

See Also

IntervalGroupStyleCollection Members


IntervalGroupStyleCollection Members

[image] [image]

.NET Framework Class Library
IntervalGroupStyleCollection Members
IntervalGroupStyleCollection Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The IntervalGroupStyleCollection type exposes the following members.

Constructors

 | Name | Description
Public method | IntervalGroupStyleCollection |

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection <(Of <(<' GroupStyle >)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollection <(Of <(<' GroupStyle >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from ObservableCollection <(Of <(<' GroupStyle >)>)>.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollection <(Of <(<' GroupStyle >)>)>.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection <(Of <(<' GroupStyle >)>)>.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollection <(Of <(<' GroupStyle >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)

Events

 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection <(Of <(<' GroupStyle >)>)>.)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection <(Of <(<' GroupStyle >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection <(Of <(<' GroupStyle >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)

See Also

IntervalGroupStyleCollection Class


IntervalGroupStyleCollection Constructor

[image]

.NET Framework Class Library
IntervalGroupStyleCollection Constructor
IntervalGroupStyleCollection Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public IntervalGroupStyleCollection()
Visual Basic
Public Sub New

See Also

IntervalGroupStyleCollection Class


IntervalGroupStyleCollection Methods

[image] [image]

.NET Framework Class Library
IntervalGroupStyleCollection Methods
IntervalGroupStyleCollection Class See Also

The IntervalGroupStyleCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection <(Of <(<' GroupStyle >)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollection <(Of <(<' GroupStyle >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from ObservableCollection <(Of <(<' GroupStyle >)>)>.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollection <(Of <(<' GroupStyle >)>)>.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection <(Of <(<' GroupStyle >)>)>.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollection <(Of <(<' GroupStyle >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)

See Also

IntervalGroupStyleCollection Class


IntervalGroupStyleCollection Properties

[image] [image]

.NET Framework Class Library
IntervalGroupStyleCollection Properties
IntervalGroupStyleCollection Class See Also

The IntervalGroupStyleCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' GroupStyle >)>)>.)

See Also

IntervalGroupStyleCollection Class


IntervalGroupStyleCollection Events

[image] [image]

.NET Framework Class Library
IntervalGroupStyleCollection Events
IntervalGroupStyleCollection Class See Also

The IntervalGroupStyleCollection type exposes the following members.

Events

 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection <(Of <(<' GroupStyle >)>)>.)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection <(Of <(<' GroupStyle >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection <(Of <(<' GroupStyle >)>)>.)

See Also

IntervalGroupStyleCollection Class


IsNotEmptyOrSpaceStringConverter Class

[image]

.NET Framework Class Library
IsNotEmptyOrSpaceStringConverter Class
Members See Also
Represents a Binding converter that returns a Boolean value indicating whether a source value is null or a string containing zero or more space characters only, or a not empty string.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class IsNotEmptyOrSpaceStringConverter : IValueConverter
Visual Basic
Public Class IsNotEmptyOrSpaceStringConverter _
    Implements IValueConverter

Remarks

IsNotEmptyOrSpaceStringConverter is a one-way converter. A target value returned by the converter is false if a source value is null or a zero length string or a string containing space characters only; otherwise, a target value is true.

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..IsNotEmptyOrSpaceStringConverter

See Also

IsNotEmptyOrSpaceStringConverter Members


IsNotEmptyOrSpaceStringConverter Members

[image] [image]

.NET Framework Class Library
IsNotEmptyOrSpaceStringConverter Members
IsNotEmptyOrSpaceStringConverter Class Constructors Methods Fields See Also

The IsNotEmptyOrSpaceStringConverter type exposes the following members.

Constructors

 | Name | Description
Public method | IsNotEmptyOrSpaceStringConverter |

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Returns Binding.DoNothing.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Default | Gets an instance of IsNotEmptyOrSpaceStringConverter.

See Also

IsNotEmptyOrSpaceStringConverter Class


IsNotEmptyOrSpaceStringConverter Constructor

[image]

.NET Framework Class Library
IsNotEmptyOrSpaceStringConverter Constructor
IsNotEmptyOrSpaceStringConverter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public IsNotEmptyOrSpaceStringConverter()
Visual Basic
Public Sub New

See Also

IsNotEmptyOrSpaceStringConverter Class


IsNotEmptyOrSpaceStringConverter Fields

[image] [image]

.NET Framework Class Library
IsNotEmptyOrSpaceStringConverter Fields
IsNotEmptyOrSpaceStringConverter Class See Also

The IsNotEmptyOrSpaceStringConverter type exposes the following members.

Fields

Name | Description
Default | Gets an instance of IsNotEmptyOrSpaceStringConverter.

See Also

IsNotEmptyOrSpaceStringConverter Class


Default Field

[image]

.NET Framework Class Library
IsNotEmptyOrSpaceStringConverter..::..Default Field
IsNotEmptyOrSpaceStringConverter Class See Also
Gets an instance of IsNotEmptyOrSpaceStringConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly IsNotEmptyOrSpaceStringConverter Default
Visual Basic
Public Shared ReadOnly Default As IsNotEmptyOrSpaceStringConverter

See Also

IsNotEmptyOrSpaceStringConverter Class


IsNotEmptyOrSpaceStringConverter Methods

[image] [image]

.NET Framework Class Library
IsNotEmptyOrSpaceStringConverter Methods
IsNotEmptyOrSpaceStringConverter Class See Also

The IsNotEmptyOrSpaceStringConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Returns Binding.DoNothing.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IsNotEmptyOrSpaceStringConverter Class


Convert Method

[image]

.NET Framework Class Library
IsNotEmptyOrSpaceStringConverter..::..Convert Method
IsNotEmptyOrSpaceStringConverter Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

IsNotEmptyOrSpaceStringConverter Class


ConvertBack Method

[image]

.NET Framework Class Library
IsNotEmptyOrSpaceStringConverter..::..ConvertBack Method
IsNotEmptyOrSpaceStringConverter Class See Also
Returns Binding.DoNothing.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value that is produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

IsNotEmptyOrSpaceStringConverter Class


IsTodayConverter Class

[image]

.NET Framework Class Library
IsTodayConverter Class
Members See Also
Represents a Binding converter that returns a Boolean value indicating whether a source value is today's date.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class IsTodayConverter : IValueConverter
Visual Basic
Public Class IsTodayConverter _
    Implements IValueConverter

Remarks

IsTodayConverter is a one-way converter.

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..IsTodayConverter

See Also

IsTodayConverter Members


IsTodayConverter Members

[image] [image]

.NET Framework Class Library
IsTodayConverter Members
IsTodayConverter Class Constructors Methods Fields See Also

The IsTodayConverter type exposes the following members.

Constructors

 | Name | Description
Public method | IsTodayConverter |

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Returns Binding.DoNothing.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Default | Gets an instance of IsTodayConverter.

See Also

IsTodayConverter Class


IsTodayConverter Constructor

[image]

.NET Framework Class Library
IsTodayConverter Constructor
IsTodayConverter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public IsTodayConverter()
Visual Basic
Public Sub New

See Also

IsTodayConverter Class


IsTodayConverter Fields

[image] [image]

.NET Framework Class Library
IsTodayConverter Fields
IsTodayConverter Class See Also

The IsTodayConverter type exposes the following members.

Fields

Name | Description
Default | Gets an instance of IsTodayConverter.

See Also

IsTodayConverter Class


Default Field

[image]

.NET Framework Class Library
IsTodayConverter..::..Default Field
IsTodayConverter Class See Also
Gets an instance of IsTodayConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly IsTodayConverter Default
Visual Basic
Public Shared ReadOnly Default As IsTodayConverter

See Also

IsTodayConverter Class


IsTodayConverter Methods

[image] [image]

.NET Framework Class Library
IsTodayConverter Methods
IsTodayConverter Class See Also

The IsTodayConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Returns Binding.DoNothing.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IsTodayConverter Class


Convert Method

[image]

.NET Framework Class Library
IsTodayConverter..::..Convert Method
IsTodayConverter Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

IsTodayConverter Class


ConvertBack Method

[image]

.NET Framework Class Library
IsTodayConverter..::..ConvertBack Method
IsTodayConverter Class See Also
Returns Binding.DoNothing.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value that is produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

IsTodayConverter Class


ItemContainerGenerator Class

[image]

.NET Framework Class Library
ItemContainerGenerator Class
Members See Also
Generates the user interface on behalf of its host GroupedListBox control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public sealed class ItemContainerGenerator : ICollectionChangedListener
Visual Basic
Public NotInheritable Class ItemContainerGenerator _
    Implements ICollectionChangedListener

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..ItemContainerGenerator

See Also

ItemContainerGenerator Members


ItemContainerGenerator Members

[image] [image]

.NET Framework Class Library
ItemContainerGenerator Members
ItemContainerGenerator Class Methods See Also

The ItemContainerGenerator type exposes the following members.

Methods

 | Name | Description
Public method | ContainerFromIndex | Returns the container element corresponding to the item at the given index within the ItemCollection.
Public method | ContainerFromItem | Returns the container element corresponding to the given item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexFromContainer | Returns the index to an item that corresponds to the specified, generated container element.
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container element.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemContainerGenerator Class


ItemContainerGenerator Methods

[image] [image]

.NET Framework Class Library
ItemContainerGenerator Methods
ItemContainerGenerator Class See Also

The ItemContainerGenerator type exposes the following members.

Methods

 | Name | Description
Public method | ContainerFromIndex | Returns the container element corresponding to the item at the given index within the ItemCollection.
Public method | ContainerFromItem | Returns the container element corresponding to the given item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexFromContainer | Returns the index to an item that corresponds to the specified, generated container element.
Public method | ItemFromContainer | Returns the item that corresponds to the specified, generated container element.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemContainerGenerator Class


ContainerFromIndex Method

[image]

.NET Framework Class Library
ItemContainerGenerator..::..ContainerFromIndex Method
ItemContainerGenerator Class See Also
Returns the container element corresponding to the item at the given index within the ItemCollection.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DependencyObject ContainerFromIndex(
    int index
)
Visual Basic
Public Function ContainerFromIndex ( _
    index As Integer _
) As DependencyObject

Parameters

index
Type: System..::..Int32
The index of the desired item.

Return Value

Returns the element corresponding to the item at the given index within the ItemCollection or returns a null reference if the item is not realized.

See Also

ItemContainerGenerator Class


ContainerFromItem Method

[image]

.NET Framework Class Library
ItemContainerGenerator..::..ContainerFromItem Method
ItemContainerGenerator Class See Also
Returns the container element corresponding to the given item.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DependencyObject ContainerFromItem(
    Object item
)
Visual Basic
Public Function ContainerFromItem ( _
    item As Object _
) As DependencyObject

Parameters

item
Type: System..::..Object
The Object item to find the container for.

Return Value

A container element that corresponds to the given item. Returns a null reference if the item does not belong to the item collection, or if a container element has not been generated for it.

See Also

ItemContainerGenerator Class


IndexFromContainer Method

[image]

.NET Framework Class Library
ItemContainerGenerator..::..IndexFromContainer Method
ItemContainerGenerator Class See Also
Returns the index to an item that corresponds to the specified, generated container element.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public int IndexFromContainer(
    DependencyObject container
)
Visual Basic
Public Function IndexFromContainer ( _
    container As DependencyObject _
) As Integer

Parameters

container
Type: System.Windows..::..DependencyObject
The container that corresponds to the item to the index to be returned.

Return Value

An index to an item that corresponds to the specified, generated container element.

See Also

ItemContainerGenerator Class


ItemFromContainer Method

[image]

.NET Framework Class Library
ItemContainerGenerator..::..ItemFromContainer Method
ItemContainerGenerator Class See Also
Returns the item that corresponds to the specified, generated container element.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object ItemFromContainer(
    DependencyObject container
)
Visual Basic
Public Function ItemFromContainer ( _
    container As DependencyObject _
) As Object

Parameters

container
Type: System.Windows..::..DependencyObject
The container that corresponds to the item to be returned.

Return Value

The item which corresponds to the specified, generated container element.

See Also

ItemContainerGenerator Class


MonthSlotPresenter Class

[image]

.NET Framework Class Library
MonthSlotPresenter Class
Members See Also
An instance of this class is used to represent the single month.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class MonthSlotPresenter : ListBoxItem
Visual Basic
Public Class MonthSlotPresenter _
    Inherits ListBoxItem

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ContentControl
System.Windows.Controls..::..ListBoxItem
C1.Silverlight.Schedule..::..MonthSlotPresenter

See Also

MonthSlotPresenter Members


MonthSlotPresenter Members

[image] [image]

.NET Framework Class Library
MonthSlotPresenter Members
MonthSlotPresenter Class Constructors Methods Properties Events See Also

The MonthSlotPresenter type exposes the following members.

Constructors

 | Name | Description
Public method | MonthSlotPresenter | Initializes a new instance of the MonthSlotPresenter class.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | (Inherited from ListBoxItem.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxItemAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBoxItem.)
Protected method | OnGotFocus | (Inherited from ListBoxItem.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from ListBoxItem.)
Protected method | OnMouseEnter | Called when the mouse enters a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeave | Called when the mouse leaves a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeftButtonDown | Called when the user presses the right mouse button over the ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CalendarItem | Gets a C1CalendarItem control.
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets a value that indicates whether a ListBoxItem is selected. This is a dependency property. (Inherited from ListBoxItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

MonthSlotPresenter Class


MonthSlotPresenter Constructor

[image]

.NET Framework Class Library
MonthSlotPresenter Constructor
MonthSlotPresenter Class See Also
Initializes a new instance of the MonthSlotPresenter class.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public MonthSlotPresenter()
Visual Basic
Public Sub New

See Also

MonthSlotPresenter Class


MonthSlotPresenter Methods

[image] [image]

.NET Framework Class Library
MonthSlotPresenter Methods
MonthSlotPresenter Class See Also

The MonthSlotPresenter type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | (Inherited from ListBoxItem.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxItemAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBoxItem.)
Protected method | OnGotFocus | (Inherited from ListBoxItem.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from ListBoxItem.)
Protected method | OnMouseEnter | Called when the mouse enters a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeave | Called when the mouse leaves a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeftButtonDown | Called when the user presses the right mouse button over the ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

MonthSlotPresenter Class


MonthSlotPresenter Properties

[image] [image]

.NET Framework Class Library
MonthSlotPresenter Properties
MonthSlotPresenter Class See Also

The MonthSlotPresenter type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CalendarItem | Gets a C1CalendarItem control.
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets a value that indicates whether a ListBoxItem is selected. This is a dependency property. (Inherited from ListBoxItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

MonthSlotPresenter Class


CalendarItem Property

[image]

.NET Framework Class Library
MonthSlotPresenter..::..CalendarItem Property
MonthSlotPresenter Class See Also
Gets a C1CalendarItem control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1CalendarItem CalendarItem { get; }
Visual Basic
Public ReadOnly Property CalendarItem As C1CalendarItem
    Get

See Also

MonthSlotPresenter Class


MonthSlotPresenter Events

[image] [image]

.NET Framework Class Library
MonthSlotPresenter Events
MonthSlotPresenter Class See Also

The MonthSlotPresenter type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

MonthSlotPresenter Class


MonthToStringConverter Class

[image]

.NET Framework Class Library
MonthToStringConverter Class
Members See Also
MonthToStringConverter converts VisualInterval start time to string.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class MonthToStringConverter : IValueConverter
Visual Basic
Public Class MonthToStringConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..MonthToStringConverter

See Also

MonthToStringConverter Members


MonthToStringConverter Members

[image] [image]

.NET Framework Class Library
MonthToStringConverter Members
MonthToStringConverter Class Constructors Methods Fields See Also

The MonthToStringConverter type exposes the following members.

Constructors

 | Name | Description
Public method | MonthToStringConverter |

Methods

 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Default | Gets an instance of MonthToStringConverter.

See Also

MonthToStringConverter Class


MonthToStringConverter Constructor

[image]

.NET Framework Class Library
MonthToStringConverter Constructor
MonthToStringConverter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public MonthToStringConverter()
Visual Basic
Public Sub New

See Also

MonthToStringConverter Class


MonthToStringConverter Fields

[image] [image]

.NET Framework Class Library
MonthToStringConverter Fields
MonthToStringConverter Class See Also

The MonthToStringConverter type exposes the following members.

Fields

Name | Description
Default | Gets an instance of MonthToStringConverter.

See Also

MonthToStringConverter Class


Default Field

[image]

.NET Framework Class Library
MonthToStringConverter..::..Default Field
MonthToStringConverter Class See Also
Gets an instance of MonthToStringConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly MonthToStringConverter Default
Visual Basic
Public Shared ReadOnly Default As MonthToStringConverter

See Also

MonthToStringConverter Class


MonthToStringConverter Methods

[image] [image]

.NET Framework Class Library
MonthToStringConverter Methods
MonthToStringConverter Class See Also

The MonthToStringConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MonthToStringConverter Class


Convert Method

[image]

.NET Framework Class Library
MonthToStringConverter..::..Convert Method
MonthToStringConverter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
targetType
Type: System..::..Type
parameter
Type: System..::..Object
culture
Type: System.Globalization..::..CultureInfo

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

MonthToStringConverter Class


ConvertBack Method

[image]

.NET Framework Class Library
MonthToStringConverter..::..ConvertBack Method
MonthToStringConverter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
targetType
Type: System..::..Type
parameter
Type: System..::..Object
culture
Type: System.Globalization..::..CultureInfo

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

MonthToStringConverter Class


NestedPropertySetter Class

[image]

.NET Framework Class Library
NestedPropertySetter Class
Members See Also
Represents a property setter which is being used as an item of the NestedSetters collection and is able to assign a value to a C1Scheduler nested property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class NestedPropertySetter : FrameworkElement
Visual Basic
Public Class NestedPropertySetter _
    Inherits FrameworkElement

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
C1.Silverlight.Schedule..::..NestedPropertySetter

See Also

NestedPropertySetter Members


NestedPropertySetter Members

[image] [image]

.NET Framework Class Library
NestedPropertySetter Members
NestedPropertySetter Class Constructors Methods Fields Properties Events See Also

The NestedPropertySetter type exposes the following members.

Constructors

 | Name | Description
Public method | NestedPropertySetter | Initializes a new instance of the NestedPropertySetter element.

Methods

 | Name | Description
Public method | Apply | This method is used for internal purposes only.
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
PropertyNameProperty | Identifies the PropertyName dependency property.
ValueProperty | Identifies the Value dependency property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PropertyName | Gets or sets a path to a nested property relative to the C1Scheduler class. This is a dependency property.
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TargetObject | This property is used for internal purposes only.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | Value | Gets or sets a value that should be assigned to the PropertyName property. This is a dependency property.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

NestedPropertySetter Class


NestedPropertySetter Constructor

[image]

.NET Framework Class Library
NestedPropertySetter Constructor
NestedPropertySetter Class See Also
Initializes a new instance of the NestedPropertySetter element.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public NestedPropertySetter()
Visual Basic
Public Sub New

See Also

NestedPropertySetter Class


NestedPropertySetter Fields

[image] [image]

.NET Framework Class Library
NestedPropertySetter Fields
NestedPropertySetter Class See Also

The NestedPropertySetter type exposes the following members.

Fields

Name | Description
PropertyNameProperty | Identifies the PropertyName dependency property.
ValueProperty | Identifies the Value dependency property.

See Also

NestedPropertySetter Class


PropertyNameProperty Field

[image]

.NET Framework Class Library
NestedPropertySetter..::..PropertyNameProperty Field
NestedPropertySetter Class See Also
Identifies the PropertyName dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty PropertyNameProperty
Visual Basic
Public Shared ReadOnly PropertyNameProperty As DependencyProperty

See Also

NestedPropertySetter Class


ValueProperty Field

[image]

.NET Framework Class Library
NestedPropertySetter..::..ValueProperty Field
NestedPropertySetter Class See Also
Identifies the Value dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty ValueProperty
Visual Basic
Public Shared ReadOnly ValueProperty As DependencyProperty

See Also

NestedPropertySetter Class


NestedPropertySetter Methods

[image] [image]

.NET Framework Class Library
NestedPropertySetter Methods
NestedPropertySetter Class See Also

The NestedPropertySetter type exposes the following members.

Methods

 | Name | Description
Public method | Apply | This method is used for internal purposes only.
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

NestedPropertySetter Class


Apply Method

[image]

.NET Framework Class Library
NestedPropertySetter..::..Apply Method
NestedPropertySetter Class See Also
This method is used for internal purposes only.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void Apply(
    Object targetObject
)
Visual Basic
Public Sub Apply ( _
    targetObject As Object _
)

Parameters

targetObject
Type: System..::..Object

See Also

NestedPropertySetter Class


NestedPropertySetter Properties

[image] [image]

.NET Framework Class Library
NestedPropertySetter Properties
NestedPropertySetter Class See Also

The NestedPropertySetter type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PropertyName | Gets or sets a path to a nested property relative to the C1Scheduler class. This is a dependency property.
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TargetObject | This property is used for internal purposes only.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | Value | Gets or sets a value that should be assigned to the PropertyName property. This is a dependency property.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

NestedPropertySetter Class


PropertyName Property

[image]

.NET Framework Class Library
NestedPropertySetter..::..PropertyName Property
NestedPropertySetter Class See Also
Gets or sets a path to a nested property relative to the C1Scheduler class. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string PropertyName { get; set; }
Visual Basic
Public Property PropertyName As String
    Get
    Set

See Also

NestedPropertySetter Class


TargetObject Property

[image]

.NET Framework Class Library
NestedPropertySetter..::..TargetObject Property
NestedPropertySetter Class See Also
This property is used for internal purposes only.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object TargetObject { get; internal set; }
Visual Basic
Public Property TargetObject As Object
    Get
    Friend Set

See Also

NestedPropertySetter Class


Value Property

[image]

.NET Framework Class Library
NestedPropertySetter..::..Value Property
NestedPropertySetter Class See Also
Gets or sets a value that should be assigned to the PropertyName property. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object Value { get; set; }
Visual Basic
Public Property Value As Object
    Get
    Set

See Also

NestedPropertySetter Class


NestedPropertySetter Events

[image] [image]

.NET Framework Class Library
NestedPropertySetter Events
NestedPropertySetter Class See Also

The NestedPropertySetter type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

NestedPropertySetter Class


NestedPropertySetterCollection Class

[image]

.NET Framework Class Library
NestedPropertySetterCollection Class
Members See Also
Represents a collection of NestedPropertySetter objects.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class NestedPropertySetterCollection : ObservableCollection<NestedPropertySetter>
Visual Basic
Public Class NestedPropertySetterCollection _
    Inherits ObservableCollection(Of NestedPropertySetter)

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' NestedPropertySetter >)>)>
System.Collections.ObjectModel..::..ObservableCollection <(Of <(<' NestedPropertySetter >)>)>
C1.Silverlight.Schedule..::..NestedPropertySetterCollection

See Also

NestedPropertySetterCollection Members


NestedPropertySetterCollection Members

[image] [image]

.NET Framework Class Library
NestedPropertySetterCollection Members
NestedPropertySetterCollection Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The NestedPropertySetterCollection type exposes the following members.

Constructors

 | Name | Description
Public method | NestedPropertySetterCollection | Initialize a new instance of the NestedPropertySetterCollection class.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Protected method | ClearItems | Overrides the default behavior. (Overrides ObservableCollection<(Of <(<'T>)>)>..::..ClearItems()()()().)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Protected method | InsertItem | Overrides the default behavior. (Overrides ObservableCollection<(Of <(<'T>)>)>..::..InsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from ObservableCollection <(Of <(<' NestedPropertySetter >)>)>.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollection <(Of <(<' NestedPropertySetter >)>)>.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Protected method | RemoveItem | Overrides the default behavior. (Overrides ObservableCollection<(Of <(<'T>)>)>..::..RemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollection <(Of <(<' NestedPropertySetter >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Public property | Owner | Gets the owning object.

Events

 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection <(Of <(<' NestedPropertySetter >)>)>.)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection <(Of <(<' NestedPropertySetter >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection <(Of <(<' NestedPropertySetter >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)

See Also

NestedPropertySetterCollection Class


NestedPropertySetterCollection Constructor

[image]

.NET Framework Class Library
NestedPropertySetterCollection Constructor
NestedPropertySetterCollection Class See Also
Initialize a new instance of the NestedPropertySetterCollection class.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public NestedPropertySetterCollection(
    Object owner
)
Visual Basic
Public Sub New ( _
    owner As Object _
)

Parameters

owner
Type: System..::..Object
The owning object.

See Also

NestedPropertySetterCollection Class


NestedPropertySetterCollection Methods

[image] [image]

.NET Framework Class Library
NestedPropertySetterCollection Methods
NestedPropertySetterCollection Class See Also

The NestedPropertySetterCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Protected method | ClearItems | Overrides the default behavior. (Overrides ObservableCollection<(Of <(<'T>)>)>..::..ClearItems()()()().)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Protected method | InsertItem | Overrides the default behavior. (Overrides ObservableCollection<(Of <(<'T>)>)>..::..InsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from ObservableCollection <(Of <(<' NestedPropertySetter >)>)>.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollection <(Of <(<' NestedPropertySetter >)>)>.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Protected method | RemoveItem | Overrides the default behavior. (Overrides ObservableCollection<(Of <(<'T>)>)>..::..RemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollection <(Of <(<' NestedPropertySetter >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)

See Also

NestedPropertySetterCollection Class


ClearItems Method

[image]

.NET Framework Class Library
NestedPropertySetterCollection..::..ClearItems Method
NestedPropertySetterCollection Class See Also
Overrides the default behavior.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void ClearItems()
Visual Basic
Protected Overrides Sub ClearItems

See Also

NestedPropertySetterCollection Class


InsertItem Method

[image]

.NET Framework Class Library
NestedPropertySetterCollection..::..InsertItem Method
NestedPropertySetterCollection Class See Also
Overrides the default behavior.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void InsertItem(
    int index,
    NestedPropertySetter item
)
Visual Basic
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As NestedPropertySetter _
)

Parameters

index
Type: System..::..Int32
item
Type: C1.Silverlight.Schedule..::..NestedPropertySetter

See Also

NestedPropertySetterCollection Class


RemoveItem Method

[image]

.NET Framework Class Library
NestedPropertySetterCollection..::..RemoveItem Method
NestedPropertySetterCollection Class See Also
Overrides the default behavior.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void RemoveItem(
    int index
)
Visual Basic
Protected Overrides Sub RemoveItem ( _
    index As Integer _
)

Parameters

index
Type: System..::..Int32

See Also

NestedPropertySetterCollection Class


NestedPropertySetterCollection Properties

[image] [image]

.NET Framework Class Library
NestedPropertySetterCollection Properties
NestedPropertySetterCollection Class See Also

The NestedPropertySetterCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Public property | Owner | Gets the owning object.

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' NestedPropertySetter >)>)>.)

See Also

NestedPropertySetterCollection Class


Owner Property

[image]

.NET Framework Class Library
NestedPropertySetterCollection..::..Owner Property
NestedPropertySetterCollection Class See Also
Gets the owning object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object Owner { get; }
Visual Basic
Public ReadOnly Property Owner As Object
    Get

See Also

NestedPropertySetterCollection Class


NestedPropertySetterCollection Events

[image] [image]

.NET Framework Class Library
NestedPropertySetterCollection Events
NestedPropertySetterCollection Class See Also

The NestedPropertySetterCollection type exposes the following members.

Events

 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection <(Of <(<' NestedPropertySetter >)>)>.)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection <(Of <(<' NestedPropertySetter >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection <(Of <(<' NestedPropertySetter >)>)>.)

See Also

NestedPropertySetterCollection Class


NumberToStringConverter Class

[image]

.NET Framework Class Library
NumberToStringConverter Class
Members See Also
Represents a Binding converter that converts an integer value to one of its string representations.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class NumberToStringConverter : IValueConverter
Visual Basic
Public Class NumberToStringConverter _
    Implements IValueConverter

Remarks

NumberToStringConverter is a two-way converter. A source value must be a number, and a target value is a string that represents the integer.

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..NumberToStringConverter

See Also

NumberToStringConverter Members


NumberToStringConverter Members

[image] [image]

.NET Framework Class Library
NumberToStringConverter Members
NumberToStringConverter Class Constructors Methods Fields See Also

The NumberToStringConverter type exposes the following members.

Constructors

 | Name | Description
Public method | NumberToStringConverter |

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Default | Gets an instance of NumberToStringConverter.

See Also

NumberToStringConverter Class


NumberToStringConverter Constructor

[image]

.NET Framework Class Library
NumberToStringConverter Constructor
NumberToStringConverter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public NumberToStringConverter()
Visual Basic
Public Sub New

See Also

NumberToStringConverter Class


NumberToStringConverter Fields

[image] [image]

.NET Framework Class Library
NumberToStringConverter Fields
NumberToStringConverter Class See Also

The NumberToStringConverter type exposes the following members.

Fields

Name | Description
Default | Gets an instance of NumberToStringConverter.

See Also

NumberToStringConverter Class


Default Field

[image]

.NET Framework Class Library
NumberToStringConverter..::..Default Field
NumberToStringConverter Class See Also
Gets an instance of NumberToStringConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly NumberToStringConverter Default
Visual Basic
Public Shared ReadOnly Default As NumberToStringConverter

See Also

NumberToStringConverter Class


NumberToStringConverter Methods

[image] [image]

.NET Framework Class Library
NumberToStringConverter Methods
NumberToStringConverter Class See Also

The NumberToStringConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NumberToStringConverter Class


Convert Method

[image]

.NET Framework Class Library
NumberToStringConverter..::..Convert Method
NumberToStringConverter Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

NumberToStringConverter Class


ConvertBack Method

[image]

.NET Framework Class Library
NumberToStringConverter..::..ConvertBack Method
NumberToStringConverter Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value that is produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

NumberToStringConverter Class


ObservableCollectionStringConverter Class

[image]

.NET Framework Class Library
ObservableCollectionStringConverter Class
Members See Also
The ObservableCollectionStringConverter provides a type converter to convert ObservableCollection<(Of <(<'T>)>)> objects to and from various other representations.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class ObservableCollectionStringConverter : TypeConverter
Visual Basic
Public Class ObservableCollectionStringConverter _
    Inherits TypeConverter

Inheritance Hierarchy

System..::..Object
System.ComponentModel..::..TypeConverter
C1.Silverlight.Schedule..::..ObservableCollectionStringConverter

See Also

ObservableCollectionStringConverter Members


ObservableCollectionStringConverter Members

[image] [image]

.NET Framework Class Library
ObservableCollectionStringConverter Members
ObservableCollectionStringConverter Class Constructors Methods See Also

The ObservableCollectionStringConverter type exposes the following members.

Constructors

 | Name | Description
Public method | ObservableCollectionStringConverter |

Methods

 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverter..::..CanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverter..::..CanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverter..::..ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromString | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverter..::..ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToString | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ObservableCollectionStringConverter Class


ObservableCollectionStringConverter Constructor

[image]

.NET Framework Class Library
ObservableCollectionStringConverter Constructor
ObservableCollectionStringConverter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ObservableCollectionStringConverter()
Visual Basic
Public Sub New

See Also

ObservableCollectionStringConverter Class


ObservableCollectionStringConverter Methods

[image] [image]

.NET Framework Class Library
ObservableCollectionStringConverter Methods
ObservableCollectionStringConverter Class See Also

The ObservableCollectionStringConverter type exposes the following members.

Methods

 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverter..::..CanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverter..::..CanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverter..::..ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromString | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverter..::..ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToString | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ObservableCollectionStringConverter Class


CanConvertFrom Method

[image] [image]

.NET Framework Class Library
ObservableCollectionStringConverter..::..CanConvertFrom Method
ObservableCollectionStringConverter Class See Also

Overload List

 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverter..::..CanConvertFrom(ITypeDescriptorContext, Type).)

See Also

ObservableCollectionStringConverter Class
ObservableCollectionStringConverter Members


CanConvertFrom Method (ITypeDescriptorContext, Type)

[image]

.NET Framework Class Library
ObservableCollectionStringConverter..::..CanConvertFrom Method (ITypeDescriptorContext, Type)
ObservableCollectionStringConverter Class See Also
Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Visual Basic
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
sourceType
Type: System..::..Type
A Type that represents the type you want to convert from.

Return Value

True if this converter can perform the conversion; otherwise, false.

See Also

ObservableCollectionStringConverter Class
CanConvertFrom Overload


CanConvertTo Method

[image] [image]

.NET Framework Class Library
ObservableCollectionStringConverter..::..CanConvertTo Method
ObservableCollectionStringConverter Class See Also

Overload List

 | Name | Description
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverter..::..CanConvertTo(ITypeDescriptorContext, Type).)

See Also

ObservableCollectionStringConverter Class
ObservableCollectionStringConverter Members


CanConvertTo Method (ITypeDescriptorContext, Type)

[image]

.NET Framework Class Library
ObservableCollectionStringConverter..::..CanConvertTo Method (ITypeDescriptorContext, Type)
ObservableCollectionStringConverter Class See Also
Returns whether this converter can convert the object to the specified type, using the specified context.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Visual Basic
Public Overrides Function CanConvertTo ( _
    context As ITypeDescriptorContext, _
    destinationType As Type _
) As Boolean

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
destinationType
Type: System..::..Type
A Type that represents the type you want to convert to.

Return Value

True if this converter can perform the conversion; otherwise, false.

See Also

ObservableCollectionStringConverter Class
CanConvertTo Overload


ConvertFrom Method

[image] [image]

.NET Framework Class Library
ObservableCollectionStringConverter..::..ConvertFrom Method
ObservableCollectionStringConverter Class See Also

Overload List

 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverter..::..ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)

See Also

ObservableCollectionStringConverter Class
ObservableCollectionStringConverter Members


ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

[image]

.NET Framework Class Library
ObservableCollectionStringConverter..::..ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)
ObservableCollectionStringConverter Class See Also
Converts the given object to the type of this converter, using the specified context and culture information.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Visual Basic
Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object _
) As Object

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.Globalization..::..CultureInfo
The CultureInfo to use as the current culture.
value
Type: System..::..Object
The Object to convert.

Return Value

An Object that represents the converted value.

See Also

ObservableCollectionStringConverter Class
ConvertFrom Overload


ConvertTo Method

[image] [image]

.NET Framework Class Library
ObservableCollectionStringConverter..::..ConvertTo Method
ObservableCollectionStringConverter Class See Also

Overload List

 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverter..::..ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)

See Also

ObservableCollectionStringConverter Class
ObservableCollectionStringConverter Members


ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

[image]

.NET Framework Class Library
ObservableCollectionStringConverter..::..ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)
ObservableCollectionStringConverter Class See Also
Converts the given value object to the specified type, using the specified context and culture information.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Visual Basic
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.Globalization..::..CultureInfo
The CultureInfo to use as the current culture.
value
Type: System..::..Object
The Object to convert.
destinationType
Type: System..::..Type
A Type that represents the type you want to convert to.

Return Value

An Object that represents the converted value.

See Also

ObservableCollectionStringConverter Class
ConvertTo Overload


PilePanel Class

[image]

.NET Framework Class Library
PilePanel Class
Members See Also
Positions child elements one over another as it is done by the Grid panel with single row and single column.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class PilePanel : Panel
Visual Basic
Public Class PilePanel _
    Inherits Panel

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Panel
C1.Silverlight.Schedule..::..PilePanel

See Also

PilePanel Members


PilePanel Members

[image] [image]

.NET Framework Class Library
PilePanel Members
PilePanel Class Constructors Methods Properties Events See Also

The PilePanel type exposes the following members.

Constructors

 | Name | Description
Public method | PilePanel | Creates the new instance of the PilePanel class.

Methods

 | Name | Description
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Arranges the content of a PilePanel element. (Overrides FrameworkElement..::..ArrangeOverride(Size).)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Measures the child elements of a PilePanel in anticipation of arranging them during the ArrangeOverride(Size) pass. (Overrides FrameworkElement..::..MeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. This is a dependency property. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

PilePanel Class


PilePanel Constructor

[image]

.NET Framework Class Library
PilePanel Constructor
PilePanel Class See Also
Creates the new instance of the PilePanel class.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public PilePanel()
Visual Basic
Public Sub New

See Also

PilePanel Class


PilePanel Methods

[image] [image]

.NET Framework Class Library
PilePanel Methods
PilePanel Class See Also

The PilePanel type exposes the following members.

Methods

 | Name | Description
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Arranges the content of a PilePanel element. (Overrides FrameworkElement..::..ArrangeOverride(Size).)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Measures the child elements of a PilePanel in anticipation of arranging them during the ArrangeOverride(Size) pass. (Overrides FrameworkElement..::..MeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

PilePanel Class


ArrangeOverride Method

[image]

.NET Framework Class Library
PilePanel..::..ArrangeOverride Method
PilePanel Class See Also
Arranges the content of a PilePanel element.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override Size ArrangeOverride(
    Size arrangeSize
)
Visual Basic
Protected Overrides Function ArrangeOverride ( _
    arrangeSize As Size _
) As Size

Parameters

arrangeSize
Type: System.Windows..::..Size
The Size that this element should use to arrange its child elements.

Return Value

The Size that represents the arranged size of this PilePanel element and its children.

See Also

PilePanel Class


MeasureOverride Method

[image]

.NET Framework Class Library
PilePanel..::..MeasureOverride Method
PilePanel Class See Also
Measures the child elements of a PilePanel in anticipation of arranging them during the ArrangeOverride(Size) pass.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override Size MeasureOverride(
    Size constraint
)
Visual Basic
Protected Overrides Function MeasureOverride ( _
    constraint As Size _
) As Size

Parameters

constraint
Type: System.Windows..::..Size
An upper limit Size that should not be exceeded.

Return Value

The Size that represents the desired size of the element.

See Also

PilePanel Class


PilePanel Properties

[image] [image]

.NET Framework Class Library
PilePanel Properties
PilePanel Class See Also

The PilePanel type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. This is a dependency property. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

PilePanel Class


PilePanel Events

[image] [image]

.NET Framework Class Library
PilePanel Events
PilePanel Class See Also

The PilePanel type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

PilePanel Class


PropertyChangeEventArgsBase Class

[image]

.NET Framework Class Library
PropertyChangeEventArgsBase Class
Members See Also
The PropertyChangeEventArgsBase class describes routed event data for the dependency property changing events.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class PropertyChangeEventArgsBase : RoutedEventArgs
Visual Basic
Public Class PropertyChangeEventArgsBase _
    Inherits RoutedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.Windows..::..RoutedEventArgs
C1.Silverlight.Schedule..::..PropertyChangeEventArgsBase
C1.Silverlight.Schedule..::..DateTimePropertyChangeEventArgs

See Also

PropertyChangeEventArgsBase Members


PropertyChangeEventArgsBase Members

[image] [image]

.NET Framework Class Library
PropertyChangeEventArgsBase Members
PropertyChangeEventArgsBase Class Constructors Methods Properties See Also

The PropertyChangeEventArgsBase type exposes the following members.

Constructors

 | Name | Description
Public method | PropertyChangeEventArgsBase | Initializes a new instance of the PropertyChangeEventArgsBase class with the specified DependencyProperty.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)
Public property | Property | Gets a DependencyProperty object.

See Also

PropertyChangeEventArgsBase Class


PropertyChangeEventArgsBase Constructor

[image]

.NET Framework Class Library
PropertyChangeEventArgsBase Constructor
PropertyChangeEventArgsBase Class See Also
Initializes a new instance of the PropertyChangeEventArgsBase class with the specified DependencyProperty.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public PropertyChangeEventArgsBase(
    DependencyProperty property
)
Visual Basic
Public Sub New ( _
    property As DependencyProperty _
)

Parameters

property
Type: System.Windows..::..DependencyProperty
The DependencyProperty.

See Also

PropertyChangeEventArgsBase Class


PropertyChangeEventArgsBase Methods

[image] [image]

.NET Framework Class Library
PropertyChangeEventArgsBase Methods
PropertyChangeEventArgsBase Class See Also

The PropertyChangeEventArgsBase type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PropertyChangeEventArgsBase Class


PropertyChangeEventArgsBase Properties

[image] [image]

.NET Framework Class Library
PropertyChangeEventArgsBase Properties
PropertyChangeEventArgsBase Class See Also

The PropertyChangeEventArgsBase type exposes the following members.

Properties

 | Name | Description
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)
Public property | Property | Gets a DependencyProperty object.

See Also

PropertyChangeEventArgsBase Class


Property Property

[image]

.NET Framework Class Library
PropertyChangeEventArgsBase..::..Property Property
PropertyChangeEventArgsBase Class See Also
Gets a DependencyProperty object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DependencyProperty Property { get; }
Visual Basic
Public ReadOnly Property Property As DependencyProperty
    Get

See Also

PropertyChangeEventArgsBase Class


RecChoiceControl Class

[image]

.NET Framework Class Library
RecChoiceControl Class
Members See Also
This window allows selecting deletion of a single occurrence or the whole recurring series.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class RecChoiceControl : UserControl
Visual Basic
Public Class RecChoiceControl _
    Inherits UserControl

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..UserControl
C1.Silverlight.Schedule..::..RecChoiceControl

See Also

RecChoiceControl Members


RecChoiceControl Members

[image] [image]

.NET Framework Class Library
RecChoiceControl Members
RecChoiceControl Class Constructors Methods Fields Properties Events See Also

The RecChoiceControl type exposes the following members.

Constructors

 | Name | Description
Public method | RecChoiceControl | Initializes a new instance of the RecChoiceControl control.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InitializeComponent | InitializeComponent
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Overrides ControlOnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
MessageProperty | Identifies the Message dependency property.
TitleProperty | Identifies the Title dependency property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Appointment | Gets or sets an Appointment object for which the window is shown.
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Protected property | Content | (Inherited from UserControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsOccurrence | Gets a True value if the user selects removing a single occurrence; False otherwise.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Message | Gets a string message displayed in the window.
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets a title displayed in the window.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

RecChoiceControl Class


RecChoiceControl Constructor

[image]

.NET Framework Class Library
RecChoiceControl Constructor
RecChoiceControl Class See Also
Initializes a new instance of the RecChoiceControl control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public RecChoiceControl(
    C1Scheduler owner,
    Appointment appointment,
    bool remove
)
Visual Basic
Public Sub New ( _
    owner As C1Scheduler, _
    appointment As Appointment, _
    remove As Boolean _
)

Parameters

owner
Type: C1.Silverlight.Schedule..::..C1Scheduler
The owning C1Scheduler control.
appointment
Type: C1.C1Schedule..::..Appointment
The Appointment object for editing.
remove
Type: System..::..Boolean
The Boolean value specifying whether the control should show a message about removing or editing an appointment.

See Also

RecChoiceControl Class


RecChoiceControl Fields

[image] [image]

.NET Framework Class Library
RecChoiceControl Fields
RecChoiceControl Class See Also

The RecChoiceControl type exposes the following members.

Fields

Name | Description
MessageProperty | Identifies the Message dependency property.
TitleProperty | Identifies the Title dependency property.

See Also

RecChoiceControl Class


MessageProperty Field

[image]

.NET Framework Class Library
RecChoiceControl..::..MessageProperty Field
RecChoiceControl Class See Also
Identifies the Message dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty MessageProperty
Visual Basic
Public Shared ReadOnly MessageProperty As DependencyProperty

See Also

RecChoiceControl Class


TitleProperty Field

[image]

.NET Framework Class Library
RecChoiceControl..::..TitleProperty Field
RecChoiceControl Class See Also
Identifies the Title dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty TitleProperty
Visual Basic
Public Shared ReadOnly TitleProperty As DependencyProperty

See Also

RecChoiceControl Class


RecChoiceControl Methods

[image] [image]

.NET Framework Class Library
RecChoiceControl Methods
RecChoiceControl Class See Also

The RecChoiceControl type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InitializeComponent | InitializeComponent
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Overrides ControlOnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

RecChoiceControl Class


InitializeComponent Method

[image]

.NET Framework Class Library
RecChoiceControl..::..InitializeComponent Method
RecChoiceControl Class See Also
InitializeComponent

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DebuggerNonUserCodeAttribute]
public void InitializeComponent()
Visual Basic
<DebuggerNonUserCodeAttribute> _
Public Sub InitializeComponent

See Also

RecChoiceControl Class


OnKeyDown Method

[image]

.NET Framework Class Library
RecChoiceControl..::..OnKeyDown Method
RecChoiceControl Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)

Parameters

e
Type: System.Windows.Input..::..KeyEventArgs

See Also

RecChoiceControl Class


RecChoiceControl Properties

[image] [image]

.NET Framework Class Library
RecChoiceControl Properties
RecChoiceControl Class See Also

The RecChoiceControl type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Appointment | Gets or sets an Appointment object for which the window is shown.
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Protected property | Content | (Inherited from UserControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsOccurrence | Gets a True value if the user selects removing a single occurrence; False otherwise.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Message | Gets a string message displayed in the window.
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets a title displayed in the window.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

RecChoiceControl Class


Appointment Property

[image]

.NET Framework Class Library
RecChoiceControl..::..Appointment Property
RecChoiceControl Class See Also
Gets or sets an Appointment object for which the window is shown.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Appointment Appointment { get; set; }
Visual Basic
Public Property Appointment As Appointment
    Get
    Set

See Also

RecChoiceControl Class


IsOccurrence Property

[image]

.NET Framework Class Library
RecChoiceControl..::..IsOccurrence Property
RecChoiceControl Class See Also
Gets a True value if the user selects removing a single occurrence; False otherwise.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsOccurrence { get; }
Visual Basic
Public ReadOnly Property IsOccurrence As Boolean
    Get

See Also

RecChoiceControl Class


Message Property

[image]

.NET Framework Class Library
RecChoiceControl..::..Message Property
RecChoiceControl Class See Also
Gets a string message displayed in the window.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string Message { get; }
Visual Basic
Public ReadOnly Property Message As String
    Get

See Also

RecChoiceControl Class


Title Property

[image]

.NET Framework Class Library
RecChoiceControl..::..Title Property
RecChoiceControl Class See Also
Gets a title displayed in the window.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string Title { get; }
Visual Basic
Public ReadOnly Property Title As String
    Get

See Also

RecChoiceControl Class


RecChoiceControl Events

[image] [image]

.NET Framework Class Library
RecChoiceControl Events
RecChoiceControl Class See Also

The RecChoiceControl type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

RecChoiceControl Class


ReentrantObservableCollection(T) Class

[image]

.NET Framework Class Library
ReentrantObservableCollection<(Of <(<'T>)>)> Class
Members See Also
The ReentrantObservableCollection<(Of <(<'T>)>)> class represents the same interface and functionality as the DeferrableObservableCollection<(Of <(<'T>)>)> with one exception: it allows collection changing in event handlers for the CollectionChanged event.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class ReentrantObservableCollection<T> : Collection<T>,
    INotifyCollectionChanged, INotifyPropertyChanged
Visual Basic
Public Class ReentrantObservableCollection(Of T) _
    Inherits Collection(Of T) _
    Implements INotifyCollectionChanged, INotifyPropertyChanged

Type Parameters

T

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<'T>)>)>
C1.Silverlight.Schedule..::..ReentrantObservableCollection<(Of <(<'T>)>)>
C1.Silverlight.Schedule..::..DateList

See Also

ReentrantObservableCollection<(Of <(<'T>)>)> Members


ReentrantObservableCollection(T) Members

[image] [image]

.NET Framework Class Library
ReentrantObservableCollection<(Of <(<'T>)>)> Members
ReentrantObservableCollection<(Of <(<'T>)>)> Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The ReentrantObservableCollection<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | ReentrantObservableCollection<(Of <(<'T>)>)> |

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | BeginUpdate | Prevents raising events until the EndUpdate()()()() method is called.
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected method | ClearItems | Overrides the default behavior. (Overrides Collection<(Of <(<'T>)>)>..::..ClearItems()()()().)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | EndUpdate | Enables raising events. If collection has been changed since the call to the BeginUpdate()()()() method, raises PropertyChanged and CollectionChanged events.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected method | InsertItem | Overrides the default behavior. (Overrides Collection<(Of <(<'T>)>)>..::..InsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | Moves the item at the specified index to a new location in the collection.
Protected method | MoveItem | Implements item moving from one location to another.
Protected method | OnCollectionChanged | Raises CollectionChanged event if the ReentrantObservableCollection<(Of <(<'T>)>)> is not in update mode.
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected method | RemoveItem | Overrides the default behavior. (Overrides Collection<(Of <(<'T>)>)>..::..RemoveItem(Int32).)
Protected method | SetItem | Overrides the default behavior. (Overrides Collection<(Of <(<'T>)>)>..::..SetItem(Int32, T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public property | InUpdate | Gets a Boolean value determining whether the ReentrantObservableCollection<(Of <(<'T>)>)> is in update mode (BeginUpdate()()()() has been called).
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)

Events

 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed.
Protected event | PropertyChanged | Occurs when a property value changes.

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged |
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' T >)>)>.)

See Also

ReentrantObservableCollection<(Of <(<'T>)>)> Class


ReentrantObservableCollection(T) Constructor

[image]

.NET Framework Class Library
ReentrantObservableCollection<(Of <(<'T>)>)> Constructor
ReentrantObservableCollection<(Of <(<'T>)>)> Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ReentrantObservableCollection()
Visual Basic
Public Sub New

See Also

ReentrantObservableCollection<(Of <(<'T>)>)> Class


ReentrantObservableCollection(T) Methods

[image] [image]

.NET Framework Class Library
ReentrantObservableCollection<(Of <(<'T>)>)> Methods
ReentrantObservableCollection<(Of <(<'T>)>)> Class See Also

The ReentrantObservableCollection<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | BeginUpdate | Prevents raising events until the EndUpdate()()()() method is called.
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected method | ClearItems | Overrides the default behavior. (Overrides Collection<(Of <(<'T>)>)>..::..ClearItems()()()().)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | EndUpdate | Enables raising events. If collection has been changed since the call to the BeginUpdate()()()() method, raises PropertyChanged and CollectionChanged events.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected method | InsertItem | Overrides the default behavior. (Overrides Collection<(Of <(<'T>)>)>..::..InsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | Moves the item at the specified index to a new location in the collection.
Protected method | MoveItem | Implements item moving from one location to another.
Protected method | OnCollectionChanged | Raises CollectionChanged event if the ReentrantObservableCollection<(Of <(<'T>)>)> is not in update mode.
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected method | RemoveItem | Overrides the default behavior. (Overrides Collection<(Of <(<'T>)>)>..::..RemoveItem(Int32).)
Protected method | SetItem | Overrides the default behavior. (Overrides Collection<(Of <(<'T>)>)>..::..SetItem(Int32, T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' T >)>)>.)

See Also

ReentrantObservableCollection<(Of <(<'T>)>)> Class


BeginUpdate Method

[image]

.NET Framework Class Library
ReentrantObservableCollection<(Of <(<'T>)>)>..::..BeginUpdate Method
ReentrantObservableCollection<(Of <(<'T>)>)> Class See Also
Prevents raising events until the EndUpdate()()()() method is called.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void BeginUpdate()
Visual Basic
Public Sub BeginUpdate

Remarks

The ReentrantObservableCollection<(Of <(<'T>)>)> keeps count of calls to BeginUpdate()()()() method. Be sure to call EndUpdate()()()() method for each call to BeginUpdate()()()() method.

See Also

ReentrantObservableCollection<(Of <(<'T>)>)> Class


ClearItems Method

[image]

.NET Framework Class Library
ReentrantObservableCollection<(Of <(<'T>)>)>..::..ClearItems Method
ReentrantObservableCollection<(Of <(<'T>)>)> Class See Also
Overrides the default behavior.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void ClearItems()
Visual Basic
Protected Overrides Sub ClearItems

See Also

ReentrantObservableCollection<(Of <(<'T>)>)> Class


EndUpdate Method

[image]

.NET Framework Class Library
ReentrantObservableCollection<(Of <(<'T>)>)>..::..EndUpdate Method
ReentrantObservableCollection<(Of <(<'T>)>)> Class See Also
Enables raising events. If collection has been changed since the call to the BeginUpdate()()()() method, raises PropertyChanged and CollectionChanged events.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void EndUpdate()
Visual Basic
Public Sub EndUpdate

Remarks

The ReentrantObservableCollection<(Of <(<'T>)>)> keeps count of calls to BeginUpdate()()()() method. Be sure to call EndUpdate()()()() method for each call to BeginUpdate()()()() method.

See Also

ReentrantObservableCollection<(Of <(<'T>)>)> Class


InsertItem Method

[image]

.NET Framework Class Library
ReentrantObservableCollection<(Of <(<'T>)>)>..::..InsertItem Method
ReentrantObservableCollection<(Of <(<'T>)>)> Class See Also
Overrides the default behavior.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void InsertItem(
    int index,
    T item
)
Visual Basic
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As T _
)

Parameters

index
Type: System..::..Int32
item
Type: T

See Also

ReentrantObservableCollection<(Of <(<'T>)>)> Class


Move Method

[image]

.NET Framework Class Library
ReentrantObservableCollection<(Of <(<'T>)>)>..::..Move Method
ReentrantObservableCollection<(Of <(<'T>)>)> Class See Also
Moves the item at the specified index to a new location in the collection.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void Move(
    int oldIndex,
    int newIndex
)
Visual Basic
Public Sub Move ( _
    oldIndex As Integer, _
    newIndex As Integer _
)

Parameters

oldIndex
Type: System..::..Int32
The zero-based index specifying the location of the item to be moved.
newIndex
Type: System..::..Int32
The zero-based index specifying the new location of the item.

See Also

ReentrantObservableCollection<(Of <(<'T>)>)> Class


MoveItem Method

[image]

.NET Framework Class Library
ReentrantObservableCollection<(Of <(<'T>)>)>..::..MoveItem Method
ReentrantObservableCollection<(Of <(<'T>)>)> Class See Also
Implements item moving from one location to another.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void MoveItem(
    int oldIndex,
    int newIndex
)
Visual Basic
Protected Overridable Sub MoveItem ( _
    oldIndex As Integer, _
    newIndex As Integer _
)

Parameters

oldIndex
Type: System..::..Int32
newIndex
Type: System..::..Int32

See Also

ReentrantObservableCollection<(Of <(<'T>)>)> Class


OnCollectionChanged Method

[image]

.NET Framework Class Library
ReentrantObservableCollection<(Of <(<'T>)>)>..::..OnCollectionChanged Method
ReentrantObservableCollection<(Of <(<'T>)>)> Class See Also
Raises CollectionChanged event if the ReentrantObservableCollection<(Of <(<'T>)>)> is not in update mode.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void OnCollectionChanged(
    NotifyCollectionChangedEventArgs e
)
Visual Basic
Protected Overridable Sub OnCollectionChanged ( _
    e As NotifyCollectionChangedEventArgs _
)

Parameters

e
Type: System.Collections.Specialized..::..NotifyCollectionChangedEventArgs

See Also

ReentrantObservableCollection<(Of <(<'T>)>)> Class


RemoveItem Method

[image]

.NET Framework Class Library
ReentrantObservableCollection<(Of <(<'T>)>)>..::..RemoveItem Method
ReentrantObservableCollection<(Of <(<'T>)>)> Class See Also
Overrides the default behavior.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void RemoveItem(
    int index
)
Visual Basic
Protected Overrides Sub RemoveItem ( _
    index As Integer _
)

Parameters

index
Type: System..::..Int32

See Also

ReentrantObservableCollection<(Of <(<'T>)>)> Class


SetItem Method

[image]

.NET Framework Class Library
ReentrantObservableCollection<(Of <(<'T>)>)>..::..SetItem Method
ReentrantObservableCollection<(Of <(<'T>)>)> Class See Also
Overrides the default behavior.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void SetItem(
    int index,
    T item
)
Visual Basic
Protected Overrides Sub SetItem ( _
    index As Integer, _
    item As T _
)

Parameters

index
Type: System..::..Int32
item
Type: T

See Also

ReentrantObservableCollection<(Of <(<'T>)>)> Class


ReentrantObservableCollection(T) Properties

[image] [image]

.NET Framework Class Library
ReentrantObservableCollection<(Of <(<'T>)>)> Properties
ReentrantObservableCollection<(Of <(<'T>)>)> Class See Also

The ReentrantObservableCollection<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)
Public property | InUpdate | Gets a Boolean value determining whether the ReentrantObservableCollection<(Of <(<'T>)>)> is in update mode (BeginUpdate()()()() has been called).
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' T >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' T >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' T >)>)>.)

See Also

ReentrantObservableCollection<(Of <(<'T>)>)> Class


InUpdate Property

[image]

.NET Framework Class Library
ReentrantObservableCollection<(Of <(<'T>)>)>..::..InUpdate Property
ReentrantObservableCollection<(Of <(<'T>)>)> Class See Also
Gets a Boolean value determining whether the ReentrantObservableCollection<(Of <(<'T>)>)> is in update mode (BeginUpdate()()()() has been called).

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool InUpdate { get; }
Visual Basic
Public ReadOnly Property InUpdate As Boolean
    Get

See Also

ReentrantObservableCollection<(Of <(<'T>)>)> Class


ReentrantObservableCollection(T) Events

[image] [image]

.NET Framework Class Library
ReentrantObservableCollection<(Of <(<'T>)>)> Events
ReentrantObservableCollection<(Of <(<'T>)>)> Class See Also

The ReentrantObservableCollection<(Of <(<'T>)>)> type exposes the following members.

Events

 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed.
Protected event | PropertyChanged | Occurs when a property value changes.

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged |

See Also

ReentrantObservableCollection<(Of <(<'T>)>)> Class


INotifyPropertyChanged.PropertyChanged Event

[image]

.NET Framework Class Library
ReentrantObservableCollection<(Of <(<'T>)>)>..::..INotifyPropertyChanged..::..PropertyChanged Event
ReentrantObservableCollection<(Of <(<'T>)>)> Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
event PropertyChangedEventHandler INotifyPropertyChanged.PropertyChanged
Visual Basic
Private Event PropertyChanged As PropertyChangedEventHandler
    Implements INotifyPropertyChanged.PropertyChanged

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

ReentrantObservableCollection<(Of <(<'T>)>)> Class


CollectionChanged Event

[image]

.NET Framework Class Library
ReentrantObservableCollection<(Of <(<'T>)>)>..::..CollectionChanged Event
ReentrantObservableCollection<(Of <(<'T>)>)> Class See Also
Occurs when an item is added, removed, changed, moved, or the entire list is refreshed.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event NotifyCollectionChangedEventHandler CollectionChanged
Visual Basic
Public Event CollectionChanged As NotifyCollectionChangedEventHandler

Implements

INotifyCollectionChanged..::..CollectionChanged

See Also

ReentrantObservableCollection<(Of <(<'T>)>)> Class


PropertyChanged Event

[image]

.NET Framework Class Library
ReentrantObservableCollection<(Of <(<'T>)>)>..::..PropertyChanged Event
ReentrantObservableCollection<(Of <(<'T>)>)> Class See Also
Occurs when a property value changes.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected event PropertyChangedEventHandler PropertyChanged
Visual Basic
Protected Event PropertyChanged As PropertyChangedEventHandler

See Also

ReentrantObservableCollection<(Of <(<'T>)>)> Class


ReminderActionEventArgs Class

[image]

.NET Framework Class Library
ReminderActionEventArgs Class
Members See Also
The ReminderActionEventArgs class describes routed event data for actions on the Reminder object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class ReminderActionEventArgs : RoutedEventArgs
Visual Basic
Public Class ReminderActionEventArgs _
    Inherits RoutedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.Windows..::..RoutedEventArgs
C1.Silverlight.Schedule..::..ReminderActionEventArgs

See Also

ReminderActionEventArgs Members


ReminderActionEventArgs Members

[image] [image]

.NET Framework Class Library
ReminderActionEventArgs Members
ReminderActionEventArgs Class Constructors Methods Properties See Also

The ReminderActionEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ReminderActionEventArgs | Initializes a new instance of the ReminderActionEventArgs class with the specified reminder.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Handled | Gets or sets a value that indicates the present state of the event handling.
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)
Public property | Reminder | Gets a Reminder object.

See Also

ReminderActionEventArgs Class


ReminderActionEventArgs Constructor

[image]

.NET Framework Class Library
ReminderActionEventArgs Constructor
ReminderActionEventArgs Class See Also
Initializes a new instance of the ReminderActionEventArgs class with the specified reminder.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ReminderActionEventArgs(
    Reminder reminder
)
Visual Basic
Public Sub New ( _
    reminder As Reminder _
)

Parameters

reminder
Type: C1.C1Schedule..::..Reminder
The Reminder object.

See Also

ReminderActionEventArgs Class


ReminderActionEventArgs Methods

[image] [image]

.NET Framework Class Library
ReminderActionEventArgs Methods
ReminderActionEventArgs Class See Also

The ReminderActionEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReminderActionEventArgs Class


ReminderActionEventArgs Properties

[image] [image]

.NET Framework Class Library
ReminderActionEventArgs Properties
ReminderActionEventArgs Class See Also

The ReminderActionEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Handled | Gets or sets a value that indicates the present state of the event handling.
Public property | OriginalSource | Gets the original reporting source as determined by pure hit testing, before any possible Source adjustment by a parent class. (Inherited from RoutedEventArgs.)
Public property | Reminder | Gets a Reminder object.

See Also

ReminderActionEventArgs Class


Handled Property

[image]

.NET Framework Class Library
ReminderActionEventArgs..::..Handled Property
ReminderActionEventArgs Class See Also
Gets or sets a value that indicates the present state of the event handling.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool Handled { get; set; }
Visual Basic
Public Property Handled As Boolean
    Get
    Set

See Also

ReminderActionEventArgs Class


Reminder Property

[image]

.NET Framework Class Library
ReminderActionEventArgs..::..Reminder Property
ReminderActionEventArgs Class See Also
Gets a Reminder object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Reminder Reminder { get; }
Visual Basic
Public ReadOnly Property Reminder As Reminder
    Get

See Also

ReminderActionEventArgs Class


ReminderListBoxItem Class

[image]

.NET Framework Class Library
ReminderListBoxItem Class
Members See Also
Represents single Reminder object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class ReminderListBoxItem : ListBoxItem
Visual Basic
Public Class ReminderListBoxItem _
    Inherits ListBoxItem

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ContentControl
System.Windows.Controls..::..ListBoxItem
C1.Silverlight.Schedule..::..ReminderListBoxItem

See Also

ReminderListBoxItem Members


ReminderListBoxItem Members

[image] [image]

.NET Framework Class Library
ReminderListBoxItem Members
ReminderListBoxItem Class Methods Properties Events See Also

The ReminderListBoxItem type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | (Inherited from ListBoxItem.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxItemAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBoxItem.)
Protected method | OnGotFocus | (Inherited from ListBoxItem.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from ListBoxItem.)
Protected method | OnMouseEnter | Called when the mouse enters a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeave | Called when the mouse leaves a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeftButtonDown | Called when the user presses the right mouse button over the ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets a value that indicates whether a ListBoxItem is selected. This is a dependency property. (Inherited from ListBoxItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Owner | Gets the reference to the owning RemindersListBox control.
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

ReminderListBoxItem Class


ReminderListBoxItem Methods

[image] [image]

.NET Framework Class Library
ReminderListBoxItem Methods
ReminderListBoxItem Class See Also

The ReminderListBoxItem type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | (Inherited from ListBoxItem.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxItemAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBoxItem.)
Protected method | OnGotFocus | (Inherited from ListBoxItem.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from ListBoxItem.)
Protected method | OnMouseEnter | Called when the mouse enters a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeave | Called when the mouse leaves a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeftButtonDown | Called when the user presses the right mouse button over the ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

ReminderListBoxItem Class


ReminderListBoxItem Properties

[image] [image]

.NET Framework Class Library
ReminderListBoxItem Properties
ReminderListBoxItem Class See Also

The ReminderListBoxItem type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets a value that indicates whether a ListBoxItem is selected. This is a dependency property. (Inherited from ListBoxItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Owner | Gets the reference to the owning RemindersListBox control.
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

ReminderListBoxItem Class


Owner Property

[image]

.NET Framework Class Library
ReminderListBoxItem..::..Owner Property
ReminderListBoxItem Class See Also
Gets the reference to the owning RemindersListBox control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public RemindersListBox Owner { get; }
Visual Basic
Public ReadOnly Property Owner As RemindersListBox
    Get

See Also

ReminderListBoxItem Class


ReminderListBoxItem Events

[image] [image]

.NET Framework Class Library
ReminderListBoxItem Events
ReminderListBoxItem Class See Also

The ReminderListBoxItem type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

ReminderListBoxItem Class


RemindersListBox Class

[image]

.NET Framework Class Library
RemindersListBox Class
Members See Also
The RemindersListBox represents collection of Reminder objects in a two-column view.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class RemindersListBox : ListBox
Visual Basic
Public Class RemindersListBox _
    Inherits ListBox

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ItemsControl
System.Windows.Controls.Primitives..::..Selector
System.Windows.Controls..::..ListBox
C1.Silverlight.Schedule..::..RemindersListBox

See Also

RemindersListBox Members


RemindersListBox Members

[image] [image]

.NET Framework Class Library
RemindersListBox Members
RemindersListBox Class Constructors Methods Fields Properties Events See Also

The RemindersListBox type exposes the following members.

Constructors

 | Name | Description
Public method | RemindersListBox | Initializes a new instance of the RemindersListBox control.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Protected method | ClearContainerForItemOverride | (Inherited from Selector.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Protected method | GetContainerForItemOverride | (Overrides ListBox..::..GetContainerForItemOverride()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ListBox.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | (Inherited from ListBox.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBox.)
Protected method | OnGotFocus | (Inherited from ListBox.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnKeyDown | Responds to the KeyDown event. (Inherited from ListBox.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from ListBox.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ListBox.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RefreshData | Refreshes UI information.
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
FirstColumnWidthProperty | Identifies the FirstColumnWidth dependency property.
SecondColumnWidthProperty | Identifies the SecondColumnWidth dependency property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property. (Inherited from ItemsControl.)
Public property | FirstColumnWidth | Gets or sets the first column width.
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemContainerStyle | (Inherited from ListBox.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. This is a dependency property. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Scheduler | Gets or sets reference to the C1Scheduler control which is an owner of displayed Reminder objects.
Public property | SecondColumnWidth | Gets or sets the second column width.
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty This is a dependency property. (Inherited from Selector.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

RemindersListBox Class


RemindersListBox Constructor

[image]

.NET Framework Class Library
RemindersListBox Constructor
RemindersListBox Class See Also
Initializes a new instance of the RemindersListBox control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public RemindersListBox()
Visual Basic
Public Sub New

See Also

RemindersListBox Class


RemindersListBox Fields

[image] [image]

.NET Framework Class Library
RemindersListBox Fields
RemindersListBox Class See Also

The RemindersListBox type exposes the following members.

Fields

Name | Description
FirstColumnWidthProperty | Identifies the FirstColumnWidth dependency property.
SecondColumnWidthProperty | Identifies the SecondColumnWidth dependency property.

See Also

RemindersListBox Class


FirstColumnWidthProperty Field

[image]

.NET Framework Class Library
RemindersListBox..::..FirstColumnWidthProperty Field
RemindersListBox Class See Also
Identifies the FirstColumnWidth dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty FirstColumnWidthProperty
Visual Basic
Public Shared ReadOnly FirstColumnWidthProperty As DependencyProperty

See Also

RemindersListBox Class


SecondColumnWidthProperty Field

[image]

.NET Framework Class Library
RemindersListBox..::..SecondColumnWidthProperty Field
RemindersListBox Class See Also
Identifies the SecondColumnWidth dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty SecondColumnWidthProperty
Visual Basic
Public Shared ReadOnly SecondColumnWidthProperty As DependencyProperty

See Also

RemindersListBox Class


RemindersListBox Methods

[image] [image]

.NET Framework Class Library
RemindersListBox Methods
RemindersListBox Class See Also

The RemindersListBox type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Protected method | ClearContainerForItemOverride | (Inherited from Selector.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Protected method | GetContainerForItemOverride | (Overrides ListBox..::..GetContainerForItemOverride()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ListBox.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | (Inherited from ListBox.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBox.)
Protected method | OnGotFocus | (Inherited from ListBox.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnKeyDown | Responds to the KeyDown event. (Inherited from ListBox.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from ListBox.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ListBox.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RefreshData | Refreshes UI information.
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

RemindersListBox Class


GetContainerForItemOverride Method

[image]

.NET Framework Class Library
RemindersListBox..::..GetContainerForItemOverride Method
RemindersListBox Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override DependencyObject GetContainerForItemOverride()
Visual Basic
Protected Overrides Function GetContainerForItemOverride As DependencyObject

See Also

RemindersListBox Class


RefreshData Method

[image]

.NET Framework Class Library
RemindersListBox..::..RefreshData Method
RemindersListBox Class See Also
Refreshes UI information.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void RefreshData()
Visual Basic
Public Sub RefreshData

See Also

RemindersListBox Class


RemindersListBox Properties

[image] [image]

.NET Framework Class Library
RemindersListBox Properties
RemindersListBox Class See Also

The RemindersListBox type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property. (Inherited from ItemsControl.)
Public property | FirstColumnWidth | Gets or sets the first column width.
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemContainerStyle | (Inherited from ListBox.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. This is a dependency property. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Scheduler | Gets or sets reference to the C1Scheduler control which is an owner of displayed Reminder objects.
Public property | SecondColumnWidth | Gets or sets the second column width.
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty This is a dependency property. (Inherited from Selector.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

RemindersListBox Class


FirstColumnWidth Property

[image]

.NET Framework Class Library
RemindersListBox..::..FirstColumnWidth Property
RemindersListBox Class See Also
Gets or sets the first column width.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public double FirstColumnWidth { get; set; }
Visual Basic
Public Property FirstColumnWidth As Double
    Get
    Set

See Also

RemindersListBox Class


Scheduler Property

[image]

.NET Framework Class Library
RemindersListBox..::..Scheduler Property
RemindersListBox Class See Also
Gets or sets reference to the C1Scheduler control which is an owner of displayed Reminder objects.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1Scheduler Scheduler { get; set; }
Visual Basic
Public Property Scheduler As C1Scheduler
    Get
    Set

See Also

RemindersListBox Class


SecondColumnWidth Property

[image]

.NET Framework Class Library
RemindersListBox..::..SecondColumnWidth Property
RemindersListBox Class See Also
Gets or sets the second column width.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public double SecondColumnWidth { get; set; }
Visual Basic
Public Property SecondColumnWidth As Double
    Get
    Set

See Also

RemindersListBox Class


RemindersListBox Events

[image] [image]

.NET Framework Class Library
RemindersListBox Events
RemindersListBox Class See Also

The RemindersListBox type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

RemindersListBox Class


RemindersToStringConverter Class

[image]

.NET Framework Class Library
RemindersToStringConverter Class
Members See Also
Represents a Binding converter that returns a string title for Reminders Window.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class RemindersToStringConverter : IValueConverter
Visual Basic
Public Class RemindersToStringConverter _
    Implements IValueConverter

Remarks

RemindersToStringConverter is a one-way converter.

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..RemindersToStringConverter

See Also

RemindersToStringConverter Members


RemindersToStringConverter Members

[image] [image]

.NET Framework Class Library
RemindersToStringConverter Members
RemindersToStringConverter Class Constructors Methods Fields See Also

The RemindersToStringConverter type exposes the following members.

Constructors

 | Name | Description
Public method | RemindersToStringConverter |

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Throws System.NotImplementedException.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Default | Gets an instance of RemindersToStringConverter.

See Also

RemindersToStringConverter Class


RemindersToStringConverter Constructor

[image]

.NET Framework Class Library
RemindersToStringConverter Constructor
RemindersToStringConverter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public RemindersToStringConverter()
Visual Basic
Public Sub New

See Also

RemindersToStringConverter Class


RemindersToStringConverter Fields

[image] [image]

.NET Framework Class Library
RemindersToStringConverter Fields
RemindersToStringConverter Class See Also

The RemindersToStringConverter type exposes the following members.

Fields

Name | Description
Default | Gets an instance of RemindersToStringConverter.

See Also

RemindersToStringConverter Class


Default Field

[image]

.NET Framework Class Library
RemindersToStringConverter..::..Default Field
RemindersToStringConverter Class See Also
Gets an instance of RemindersToStringConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly RemindersToStringConverter Default
Visual Basic
Public Shared ReadOnly Default As RemindersToStringConverter

See Also

RemindersToStringConverter Class


RemindersToStringConverter Methods

[image] [image]

.NET Framework Class Library
RemindersToStringConverter Methods
RemindersToStringConverter Class See Also

The RemindersToStringConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Throws System.NotImplementedException.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RemindersToStringConverter Class


Convert Method

[image]

.NET Framework Class Library
RemindersToStringConverter..::..Convert Method
RemindersToStringConverter Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

RemindersToStringConverter Class


ConvertBack Method

[image]

.NET Framework Class Library
RemindersToStringConverter..::..ConvertBack Method
RemindersToStringConverter Class See Also
Throws System.NotImplementedException.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value that is produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

RemindersToStringConverter Class


SchedulerGroupItem Class

[image]

.NET Framework Class Library
SchedulerGroupItem Class
Members See Also
Holds all the data required for displaying individual UI part for the single resource, category or contact when the GroupBy property is set, or default UI otherwise.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class SchedulerGroupItem : DependencyObject
Visual Basic
Public Class SchedulerGroupItem _
    Inherits DependencyObject

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
C1.Silverlight.Schedule..::..SchedulerGroupItem

See Also

SchedulerGroupItem Members


SchedulerGroupItem Members

[image] [image]

.NET Framework Class Library
SchedulerGroupItem Members
SchedulerGroupItem Class Methods Fields Properties See Also

The SchedulerGroupItem type exposes the following members.

Methods

 | Name | Description
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns the string representation of the current SchedulerGroupItem object. (Overrides Object..::..ToString()()()().)

Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property.
DisplayNameProperty | Identifies the DisplayName dependency property.
HasVisibleAppointmentsProperty | Identifies the HasVisibleAppointments dependency property.
IsSelectedProperty | Identifies the IsSelected dependency property.
ShowNextButtonProperty | Identifies the ShowNextButton dependency property.
ShowPreviousButtonProperty | Identifies the ShowPreviousButton dependency property.
TagProperty | Identifies the Tag dependency property.

Properties

 | Name | Description
Public property | Background | Gets or sets the Brush objects which should be used as background color for UI, representing the SchedulerGroupItem object. This is a dependency property.
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | DisplayName | Gets or sets the String value representing the display name of the SchedulerGroupItem object. This is a dependency property.
Public property | HasVisibleAppointments | Indicates whether there is at least one visible appointment in the current view. This is a dependency property.
Public property | IsChecked | Gets or sets a Boolean value determinign whether this SchedulerGroupItem object should be displayed in UI.
Public property | IsSelected | Gets or sets a value that determines whether the UI element that has this SchedulerGroupItem as a DataContext is selected. This is a dependency property.
Public property | Name | Gets the String value representing the name of the SchedulerGroupItem object.
Public property | Owner | Gets the BaseObject object representing the SchedulerGroupItem object owner. This property can be null for an empty group item.
Public property | Scheduler | Gets the Scheduler that SchedulerGroupItem belongs to.
Public property | ShowNextButton | Gets or sets a value that determines whether to show the next group navigation button (buttons). The default value is True. This is a dependency property.
Public property | ShowPreviousButton | Gets or sets a value that determines whether to show the previous group navigation button (buttons). The default value is True. This is a dependency property.
Public property | Tag | Gets or sets the object that contains custom data about the SchedulerGroupItem object. This is a dependency property.
Public property | VisualIntervalGroups | Gets a collection of VisualIntervalGroup objects defining top-level groups of VisualInterval objects currently represented by the control on a screen.
Public property | VisualIntervals | Gets a collection of VisualInterval objects defining time intervals currently represented by the control on a screen.
Public property | VisualIntervalsView | Gets a grouped view on the VisualIntervals collection.

See Also

SchedulerGroupItem Class


SchedulerGroupItem Fields

[image] [image]

.NET Framework Class Library
SchedulerGroupItem Fields
SchedulerGroupItem Class See Also

The SchedulerGroupItem type exposes the following members.

Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property.
DisplayNameProperty | Identifies the DisplayName dependency property.
HasVisibleAppointmentsProperty | Identifies the HasVisibleAppointments dependency property.
IsSelectedProperty | Identifies the IsSelected dependency property.
ShowNextButtonProperty | Identifies the ShowNextButton dependency property.
ShowPreviousButtonProperty | Identifies the ShowPreviousButton dependency property.
TagProperty | Identifies the Tag dependency property.

See Also

SchedulerGroupItem Class


BackgroundProperty Field

[image]

.NET Framework Class Library
SchedulerGroupItem..::..BackgroundProperty Field
SchedulerGroupItem Class See Also
Identifies the Background dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty BackgroundProperty
Visual Basic
Public Shared ReadOnly BackgroundProperty As DependencyProperty

See Also

SchedulerGroupItem Class


DisplayNameProperty Field

[image]

.NET Framework Class Library
SchedulerGroupItem..::..DisplayNameProperty Field
SchedulerGroupItem Class See Also
Identifies the DisplayName dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty DisplayNameProperty
Visual Basic
Public Shared ReadOnly DisplayNameProperty As DependencyProperty

See Also

SchedulerGroupItem Class


HasVisibleAppointmentsProperty Field

[image]

.NET Framework Class Library
SchedulerGroupItem..::..HasVisibleAppointmentsProperty Field
SchedulerGroupItem Class See Also
Identifies the HasVisibleAppointments dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty HasVisibleAppointmentsProperty
Visual Basic
Public Shared ReadOnly HasVisibleAppointmentsProperty As DependencyProperty

See Also

SchedulerGroupItem Class


IsSelectedProperty Field

[image]

.NET Framework Class Library
SchedulerGroupItem..::..IsSelectedProperty Field
SchedulerGroupItem Class See Also
Identifies the IsSelected dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty IsSelectedProperty
Visual Basic
Public Shared ReadOnly IsSelectedProperty As DependencyProperty

See Also

SchedulerGroupItem Class


ShowNextButtonProperty Field

[image]

.NET Framework Class Library
SchedulerGroupItem..::..ShowNextButtonProperty Field
SchedulerGroupItem Class See Also
Identifies the ShowNextButton dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty ShowNextButtonProperty
Visual Basic
Public Shared ReadOnly ShowNextButtonProperty As DependencyProperty

See Also

SchedulerGroupItem Class


ShowPreviousButtonProperty Field

[image]

.NET Framework Class Library
SchedulerGroupItem..::..ShowPreviousButtonProperty Field
SchedulerGroupItem Class See Also
Identifies the ShowPreviousButton dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty ShowPreviousButtonProperty
Visual Basic
Public Shared ReadOnly ShowPreviousButtonProperty As DependencyProperty

See Also

SchedulerGroupItem Class


TagProperty Field

[image]

.NET Framework Class Library
SchedulerGroupItem..::..TagProperty Field
SchedulerGroupItem Class See Also
Identifies the Tag dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty TagProperty
Visual Basic
Public Shared ReadOnly TagProperty As DependencyProperty

See Also

SchedulerGroupItem Class


SchedulerGroupItem Methods

[image] [image]

.NET Framework Class Library
SchedulerGroupItem Methods
SchedulerGroupItem Class See Also

The SchedulerGroupItem type exposes the following members.

Methods

 | Name | Description
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns the string representation of the current SchedulerGroupItem object. (Overrides Object..::..ToString()()()().)

See Also

SchedulerGroupItem Class


ToString Method

[image]

.NET Framework Class Library
SchedulerGroupItem..::..ToString Method
SchedulerGroupItem Class See Also
Returns the string representation of the current SchedulerGroupItem object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

The DisplayName property value.

See Also

SchedulerGroupItem Class


SchedulerGroupItem Properties

[image] [image]

.NET Framework Class Library
SchedulerGroupItem Properties
SchedulerGroupItem Class See Also

The SchedulerGroupItem type exposes the following members.

Properties

 | Name | Description
Public property | Background | Gets or sets the Brush objects which should be used as background color for UI, representing the SchedulerGroupItem object. This is a dependency property.
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | DisplayName | Gets or sets the String value representing the display name of the SchedulerGroupItem object. This is a dependency property.
Public property | HasVisibleAppointments | Indicates whether there is at least one visible appointment in the current view. This is a dependency property.
Public property | IsChecked | Gets or sets a Boolean value determinign whether this SchedulerGroupItem object should be displayed in UI.
Public property | IsSelected | Gets or sets a value that determines whether the UI element that has this SchedulerGroupItem as a DataContext is selected. This is a dependency property.
Public property | Name | Gets the String value representing the name of the SchedulerGroupItem object.
Public property | Owner | Gets the BaseObject object representing the SchedulerGroupItem object owner. This property can be null for an empty group item.
Public property | Scheduler | Gets the Scheduler that SchedulerGroupItem belongs to.
Public property | ShowNextButton | Gets or sets a value that determines whether to show the next group navigation button (buttons). The default value is True. This is a dependency property.
Public property | ShowPreviousButton | Gets or sets a value that determines whether to show the previous group navigation button (buttons). The default value is True. This is a dependency property.
Public property | Tag | Gets or sets the object that contains custom data about the SchedulerGroupItem object. This is a dependency property.
Public property | VisualIntervalGroups | Gets a collection of VisualIntervalGroup objects defining top-level groups of VisualInterval objects currently represented by the control on a screen.
Public property | VisualIntervals | Gets a collection of VisualInterval objects defining time intervals currently represented by the control on a screen.
Public property | VisualIntervalsView | Gets a grouped view on the VisualIntervals collection.

See Also

SchedulerGroupItem Class


Background Property

[image]

.NET Framework Class Library
SchedulerGroupItem..::..Background Property
SchedulerGroupItem Class See Also
Gets or sets the Brush objects which should be used as background color for UI, representing the SchedulerGroupItem object. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Brush Background { get; set; }
Visual Basic
Public Property Background As Brush
    Get
    Set

See Also

SchedulerGroupItem Class


DisplayName Property

[image]

.NET Framework Class Library
SchedulerGroupItem..::..DisplayName Property
SchedulerGroupItem Class See Also
Gets or sets the String value representing the display name of the SchedulerGroupItem object. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string DisplayName { get; set; }
Visual Basic
Public Property DisplayName As String
    Get
    Set

Field Value

The display name.

See Also

SchedulerGroupItem Class


HasVisibleAppointments Property

[image]

.NET Framework Class Library
SchedulerGroupItem..::..HasVisibleAppointments Property
SchedulerGroupItem Class See Also
Indicates whether there is at least one visible appointment in the current view. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public bool HasVisibleAppointments { get; }
Visual Basic
<BrowsableAttribute(False)> _
Public ReadOnly Property HasVisibleAppointments As Boolean
    Get

See Also

SchedulerGroupItem Class


IsChecked Property

[image]

.NET Framework Class Library
SchedulerGroupItem..::..IsChecked Property
SchedulerGroupItem Class See Also
Gets or sets a Boolean value determinign whether this SchedulerGroupItem object should be displayed in UI.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsChecked { get; set; }
Visual Basic
Public Property IsChecked As Boolean
    Get
    Set

See Also

SchedulerGroupItem Class


IsSelected Property

[image]

.NET Framework Class Library
SchedulerGroupItem..::..IsSelected Property
SchedulerGroupItem Class See Also
Gets or sets a value that determines whether the UI element that has this SchedulerGroupItem as a DataContext is selected. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic
Public Property IsSelected As Boolean
    Get
    Set

See Also

SchedulerGroupItem Class


Name Property

[image]

.NET Framework Class Library
SchedulerGroupItem..::..Name Property
SchedulerGroupItem Class See Also
Gets the String value representing the name of the SchedulerGroupItem object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string Name { get; private set; }
Visual Basic
Public Property Name As String
    Get
    Private Set

See Also

SchedulerGroupItem Class


Owner Property

[image]

.NET Framework Class Library
SchedulerGroupItem..::..Owner Property
SchedulerGroupItem Class See Also
Gets the BaseObject object representing the SchedulerGroupItem object owner. This property can be null for an empty group item.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public BaseObject Owner { get; }
Visual Basic
Public ReadOnly Property Owner As BaseObject
    Get

See Also

SchedulerGroupItem Class


Scheduler Property

[image]

.NET Framework Class Library
SchedulerGroupItem..::..Scheduler Property
SchedulerGroupItem Class See Also
Gets the Scheduler that SchedulerGroupItem belongs to.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1Scheduler Scheduler { get; }
Visual Basic
Public ReadOnly Property Scheduler As C1Scheduler
    Get

See Also

SchedulerGroupItem Class


ShowNextButton Property

[image]

.NET Framework Class Library
SchedulerGroupItem..::..ShowNextButton Property
SchedulerGroupItem Class See Also
Gets or sets a value that determines whether to show the next group navigation button (buttons). The default value is True. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool ShowNextButton { get; set; }
Visual Basic
Public Property ShowNextButton As Boolean
    Get
    Set

See Also

SchedulerGroupItem Class


ShowPreviousButton Property

[image]

.NET Framework Class Library
SchedulerGroupItem..::..ShowPreviousButton Property
SchedulerGroupItem Class See Also
Gets or sets a value that determines whether to show the previous group navigation button (buttons). The default value is True. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool ShowPreviousButton { get; set; }
Visual Basic
Public Property ShowPreviousButton As Boolean
    Get
    Set

See Also

SchedulerGroupItem Class


Tag Property

[image]

.NET Framework Class Library
SchedulerGroupItem..::..Tag Property
SchedulerGroupItem Class See Also
Gets or sets the object that contains custom data about the SchedulerGroupItem object. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object Tag { get; set; }
Visual Basic
Public Property Tag As Object
    Get
    Set

See Also

SchedulerGroupItem Class


VisualIntervalGroups Property

[image]

.NET Framework Class Library
SchedulerGroupItem..::..VisualIntervalGroups Property
SchedulerGroupItem Class See Also
Gets a collection of VisualIntervalGroup objects defining top-level groups of VisualInterval objects currently represented by the control on a screen.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public VisualIntervalCollection VisualIntervalGroups { get; }
Visual Basic
<BrowsableAttribute(False)> _
Public ReadOnly Property VisualIntervalGroups As VisualIntervalCollection
    Get

See Also

SchedulerGroupItem Class


VisualIntervals Property

[image]

.NET Framework Class Library
SchedulerGroupItem..::..VisualIntervals Property
SchedulerGroupItem Class See Also
Gets a collection of VisualInterval objects defining time intervals currently represented by the control on a screen.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public VisualIntervalCollection VisualIntervals { get; }
Visual Basic
<BrowsableAttribute(False)> _
Public ReadOnly Property VisualIntervals As VisualIntervalCollection
    Get

Remarks

This collection is generated automatically based on the following property values:
  • VisualStartTime - defines a start time of a period represented by the collection.
  • VisualTimeSpan - defines a length of a period represented by the collection.
  • VisualIntervalScale - defines a length of each VisualInterval in the collection.

See Also

SchedulerGroupItem Class


VisualIntervalsView Property

[image]

.NET Framework Class Library
SchedulerGroupItem..::..VisualIntervalsView Property
SchedulerGroupItem Class See Also
Gets a grouped view on the VisualIntervals collection.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[BrowsableAttribute(false)]
public PagedCollectionView VisualIntervalsView { get; }
Visual Basic
<BrowsableAttribute(False)> _
Public ReadOnly Property VisualIntervalsView As PagedCollectionView
    Get

Remarks

This view is primarily intended to provide a data for building control UI in XAML. It represents a list of VisualInterval objects from the VisualIntervals grouped according to the VisualIntervalGroupDescriptions property value.

See Also

SchedulerGroupItem Class


SchedulerGroupItemCollection Class

[image]

.NET Framework Class Library
SchedulerGroupItemCollection Class
Members See Also
Represents a collection of the SchedulerGroupItem objects.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultMemberAttribute("Item")]
public class SchedulerGroupItemCollection : DeferrableObservableCollection<SchedulerGroupItem>
Visual Basic
<DefaultMemberAttribute("Item")> _
Public Class SchedulerGroupItemCollection _
    Inherits DeferrableObservableCollection(Of SchedulerGroupItem)

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' SchedulerGroupItem >)>)>
System.Collections.ObjectModel..::..ObservableCollection <(Of <(<' SchedulerGroupItem >)>)>
C1.Silverlight.Schedule..::..DeferrableObservableCollection <(Of <(<' SchedulerGroupItem >)>)>
C1.Silverlight.Schedule..::..SchedulerGroupItemCollection

See Also

SchedulerGroupItemCollection Members


SchedulerGroupItemCollection Members

[image] [image]

.NET Framework Class Library
SchedulerGroupItemCollection Members
SchedulerGroupItemCollection Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The SchedulerGroupItemCollection type exposes the following members.

Constructors

 | Name | Description
Public method | SchedulerGroupItemCollection |

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Public method | BeginUpdate | Prevents raising events until the EndUpdate()()()() method is called. (Inherited from DeferrableObservableCollection<(Of <(<'T>)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection <(Of <(<' SchedulerGroupItem >)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Public method | EndUpdate | Enables raising events. If collection has been changed since the call to the BeginUpdate()()()() method, raises PropertyChanged and CollectionChanged events. (Inherited from DeferrableObservableCollection<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollection <(Of <(<' SchedulerGroupItem >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Overrides the default behavior. (Inherited from DeferrableObservableCollection<(Of <(<'T>)>)>.)
Protected method | OnPropertyChanged | Overrides the default behavior. (Inherited from DeferrableObservableCollection<(Of <(<'T>)>)>.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection <(Of <(<' SchedulerGroupItem >)>)>.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollection <(Of <(<' SchedulerGroupItem >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Public property | InUpdate | Gets a Boolean value determining whether the DeferrableObservableCollection<(Of <(<'T>)>)> is in update mode (BeginUpdate()()()() has been called). (Inherited from DeferrableObservableCollection<(Of <(<'T>)>)>.)
Public property | Item[([( Int32])]) | Gets a SchedulerGroupItem object at the specified index.
Public property | Item[([( Object])]) | Gets a SchedulerGroupItem object with the specified owner.
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)

Events

 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection <(Of <(<' SchedulerGroupItem >)>)>.)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection <(Of <(<' SchedulerGroupItem >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection <(Of <(<' SchedulerGroupItem >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)

See Also

SchedulerGroupItemCollection Class


SchedulerGroupItemCollection Constructor

[image]

.NET Framework Class Library
SchedulerGroupItemCollection Constructor
SchedulerGroupItemCollection Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public SchedulerGroupItemCollection()
Visual Basic
Public Sub New

See Also

SchedulerGroupItemCollection Class


SchedulerGroupItemCollection Methods

[image] [image]

.NET Framework Class Library
SchedulerGroupItemCollection Methods
SchedulerGroupItemCollection Class See Also

The SchedulerGroupItemCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Public method | BeginUpdate | Prevents raising events until the EndUpdate()()()() method is called. (Inherited from DeferrableObservableCollection<(Of <(<'T>)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection <(Of <(<' SchedulerGroupItem >)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Public method | EndUpdate | Enables raising events. If collection has been changed since the call to the BeginUpdate()()()() method, raises PropertyChanged and CollectionChanged events. (Inherited from DeferrableObservableCollection<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollection <(Of <(<' SchedulerGroupItem >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Overrides the default behavior. (Inherited from DeferrableObservableCollection<(Of <(<'T>)>)>.)
Protected method | OnPropertyChanged | Overrides the default behavior. (Inherited from DeferrableObservableCollection<(Of <(<'T>)>)>.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection <(Of <(<' SchedulerGroupItem >)>)>.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollection <(Of <(<' SchedulerGroupItem >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)

See Also

SchedulerGroupItemCollection Class


SchedulerGroupItemCollection Properties

[image] [image]

.NET Framework Class Library
SchedulerGroupItemCollection Properties
SchedulerGroupItemCollection Class See Also

The SchedulerGroupItemCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Public property | InUpdate | Gets a Boolean value determining whether the DeferrableObservableCollection<(Of <(<'T>)>)> is in update mode (BeginUpdate()()()() has been called). (Inherited from DeferrableObservableCollection<(Of <(<'T>)>)>.)
Public property | Item[([( Int32])]) | Gets a SchedulerGroupItem object at the specified index.
Public property | Item[([( Object])]) | Gets a SchedulerGroupItem object with the specified owner.
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' SchedulerGroupItem >)>)>.)

See Also

SchedulerGroupItemCollection Class


Item Property

[image] [image]

.NET Framework Class Library
SchedulerGroupItemCollection..::..Item Property
SchedulerGroupItemCollection Class See Also

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets a SchedulerGroupItem object at the specified index.
Public property | Item[([( Object])]) | Gets a SchedulerGroupItem object with the specified owner.

See Also

SchedulerGroupItemCollection Class
SchedulerGroupItemCollection Members


Item Property (Int32)

[image]

.NET Framework Class Library
SchedulerGroupItemCollection..::..Item Property (Int32)
SchedulerGroupItemCollection Class See Also
Gets a SchedulerGroupItem object at the specified index.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public SchedulerGroupItem this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    index As Integer _
) As SchedulerGroupItem
    Get

Parameters

index
Type: System..::..Int32

See Also

SchedulerGroupItemCollection Class
Item Overload


Item Property (Object)

[image]

.NET Framework Class Library
SchedulerGroupItemCollection..::..Item Property (Object)
SchedulerGroupItemCollection Class See Also
Gets a SchedulerGroupItem object with the specified owner.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public SchedulerGroupItem this[
    Object owner
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    owner As Object _
) As SchedulerGroupItem
    Get

Parameters

owner
Type: System..::..Object

See Also

SchedulerGroupItemCollection Class
Item Overload


SchedulerGroupItemCollection Events

[image] [image]

.NET Framework Class Library
SchedulerGroupItemCollection Events
SchedulerGroupItemCollection Class See Also

The SchedulerGroupItemCollection type exposes the following members.

Events

 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection <(Of <(<' SchedulerGroupItem >)>)>.)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection <(Of <(<' SchedulerGroupItem >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection <(Of <(<' SchedulerGroupItem >)>)>.)

See Also

SchedulerGroupItemCollection Class


SelectedEnumMemberConverter Class

[image]

.NET Framework Class Library
SelectedEnumMemberConverter Class
Members See Also
Represents a Binding converter that indicates whether a binding source value is an enum member specified in the converter parameter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class SelectedEnumMemberConverter : SelectedEnumMemberConverterBase
Visual Basic
Public Class SelectedEnumMemberConverter _
    Inherits SelectedEnumMemberConverterBase

Remarks

SelectedEnumMemberConverter is a two-way converter.

Source - Target behavior:

If a binding source value is an enum member specified in a converter parameter, then the binding target value is True; otherwise, False.

Target - Source behavior:

If target is True, then the source is the enum member specified in a parameter. Otherwise, the source is not updated.

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..SelectedEnumMemberConverterBase
C1.Silverlight.Schedule..::..SelectedEnumMemberConverter

See Also

SelectedEnumMemberConverter Members


SelectedEnumMemberConverter Members

[image] [image]

.NET Framework Class Library
SelectedEnumMemberConverter Members
SelectedEnumMemberConverter Class Constructors Methods Fields See Also

The SelectedEnumMemberConverter type exposes the following members.

Constructors

 | Name | Description
Public method | SelectedEnumMemberConverter | Initializes a new instance of the SelectedEnumMemberConverter.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target. (Inherited from SelectedEnumMemberConverterBase.)
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source. (Inherited from SelectedEnumMemberConverterBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Default | Gets an instance of SelectedEnumMemberConverter.

See Also

SelectedEnumMemberConverter Class


SelectedEnumMemberConverter Constructor

[image]

.NET Framework Class Library
SelectedEnumMemberConverter Constructor
SelectedEnumMemberConverter Class See Also
Initializes a new instance of the SelectedEnumMemberConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public SelectedEnumMemberConverter()
Visual Basic
Public Sub New

See Also

SelectedEnumMemberConverter Class


SelectedEnumMemberConverter Fields

[image] [image]

.NET Framework Class Library
SelectedEnumMemberConverter Fields
SelectedEnumMemberConverter Class See Also

The SelectedEnumMemberConverter type exposes the following members.

Fields

Name | Description
Default | Gets an instance of SelectedEnumMemberConverter.

See Also

SelectedEnumMemberConverter Class


Default Field

[image]

.NET Framework Class Library
SelectedEnumMemberConverter..::..Default Field
SelectedEnumMemberConverter Class See Also
Gets an instance of SelectedEnumMemberConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly SelectedEnumMemberConverter Default
Visual Basic
Public Shared ReadOnly Default As SelectedEnumMemberConverter

See Also

SelectedEnumMemberConverter Class


SelectedEnumMemberConverter Methods

[image] [image]

.NET Framework Class Library
SelectedEnumMemberConverter Methods
SelectedEnumMemberConverter Class See Also

The SelectedEnumMemberConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target. (Inherited from SelectedEnumMemberConverterBase.)
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source. (Inherited from SelectedEnumMemberConverterBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SelectedEnumMemberConverter Class


SelectedEnumMemberConverterBase Class

[image]

.NET Framework Class Library
SelectedEnumMemberConverterBase Class
Members See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public abstract class SelectedEnumMemberConverterBase : IValueConverter
Visual Basic
Public MustInherit Class SelectedEnumMemberConverterBase _
    Implements IValueConverter

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..SelectedEnumMemberConverterBase
C1.Silverlight.Schedule..::..SelectedEnumMemberConverter
C1.Silverlight.Schedule..::..SelectedEnumMemberFlagConverter

See Also

SelectedEnumMemberConverterBase Members


SelectedEnumMemberConverterBase Members

[image] [image]

.NET Framework Class Library
SelectedEnumMemberConverterBase Members
SelectedEnumMemberConverterBase Class Constructors Methods See Also

The SelectedEnumMemberConverterBase type exposes the following members.

Constructors

 | Name | Description
Protected method | SelectedEnumMemberConverterBase | Initializes a new instance of the SelectedEnumMemberConverterBase.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SelectedEnumMemberConverterBase Class


SelectedEnumMemberConverterBase Constructor

[image]

.NET Framework Class Library
SelectedEnumMemberConverterBase Constructor
SelectedEnumMemberConverterBase Class See Also
Initializes a new instance of the SelectedEnumMemberConverterBase.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected SelectedEnumMemberConverterBase(
    bool isFlag
)
Visual Basic
Protected Sub New ( _
    isFlag As Boolean _
)

Parameters

isFlag
Type: System..::..Boolean

See Also

SelectedEnumMemberConverterBase Class


SelectedEnumMemberConverterBase Methods

[image] [image]

.NET Framework Class Library
SelectedEnumMemberConverterBase Methods
SelectedEnumMemberConverterBase Class See Also

The SelectedEnumMemberConverterBase type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SelectedEnumMemberConverterBase Class


Convert Method

[image]

.NET Framework Class Library
SelectedEnumMemberConverterBase..::..Convert Method
SelectedEnumMemberConverterBase Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

SelectedEnumMemberConverterBase Class


ConvertBack Method

[image]

.NET Framework Class Library
SelectedEnumMemberConverterBase..::..ConvertBack Method
SelectedEnumMemberConverterBase Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value that is produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

SelectedEnumMemberConverterBase Class


SelectedEnumMemberFlagConverter Class

[image]

.NET Framework Class Library
SelectedEnumMemberFlagConverter Class
Members See Also
Represents a Binding converter that indicates whether a binding source value contains an enum member (flag) specified in the converter parameter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class SelectedEnumMemberFlagConverter : SelectedEnumMemberConverterBase
Visual Basic
Public Class SelectedEnumMemberFlagConverter _
    Inherits SelectedEnumMemberConverterBase

Remarks

Source - Target behavior:

If source value is an enum member and it contains a flag specified in a converter parameter, then the target is True; otherwise, False.

Target - Source behavior:

If target is True, then the source is the enum member specified in a parameter. Otherwise, the source is not updated.

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..SelectedEnumMemberConverterBase
C1.Silverlight.Schedule..::..SelectedEnumMemberFlagConverter

See Also

SelectedEnumMemberFlagConverter Members


SelectedEnumMemberFlagConverter Members

[image] [image]

.NET Framework Class Library
SelectedEnumMemberFlagConverter Members
SelectedEnumMemberFlagConverter Class Constructors Methods Fields See Also

The SelectedEnumMemberFlagConverter type exposes the following members.

Constructors

 | Name | Description
Public method | SelectedEnumMemberFlagConverter | Creates a new instance of SelectedEnumMemberFlagConverter.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target. (Inherited from SelectedEnumMemberConverterBase.)
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source. (Inherited from SelectedEnumMemberConverterBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Default | Gets an instance of SelectedEnumMemberFlagConverter.

See Also

SelectedEnumMemberFlagConverter Class


SelectedEnumMemberFlagConverter Constructor

[image]

.NET Framework Class Library
SelectedEnumMemberFlagConverter Constructor
SelectedEnumMemberFlagConverter Class See Also
Creates a new instance of SelectedEnumMemberFlagConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public SelectedEnumMemberFlagConverter()
Visual Basic
Public Sub New

See Also

SelectedEnumMemberFlagConverter Class


SelectedEnumMemberFlagConverter Fields

[image] [image]

.NET Framework Class Library
SelectedEnumMemberFlagConverter Fields
SelectedEnumMemberFlagConverter Class See Also

The SelectedEnumMemberFlagConverter type exposes the following members.

Fields

Name | Description
Default | Gets an instance of SelectedEnumMemberFlagConverter.

See Also

SelectedEnumMemberFlagConverter Class


Default Field

[image]

.NET Framework Class Library
SelectedEnumMemberFlagConverter..::..Default Field
SelectedEnumMemberFlagConverter Class See Also
Gets an instance of SelectedEnumMemberFlagConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly SelectedEnumMemberFlagConverter Default
Visual Basic
Public Shared ReadOnly Default As SelectedEnumMemberFlagConverter

See Also

SelectedEnumMemberFlagConverter Class


SelectedEnumMemberFlagConverter Methods

[image] [image]

.NET Framework Class Library
SelectedEnumMemberFlagConverter Methods
SelectedEnumMemberFlagConverter Class See Also

The SelectedEnumMemberFlagConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target. (Inherited from SelectedEnumMemberConverterBase.)
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source. (Inherited from SelectedEnumMemberConverterBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SelectedEnumMemberFlagConverter Class


SelectFromListScene Class

[image]

.NET Framework Class Library
SelectFromListScene Class
Members See Also
Interaction logic for SelectFromListScene.xaml

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class SelectFromListScene : UserControl
Visual Basic
Public Class SelectFromListScene _
    Inherits UserControl

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..UserControl
C1.Silverlight.Schedule..::..SelectFromListScene

See Also

SelectFromListScene Members


SelectFromListScene Members

[image] [image]

.NET Framework Class Library
SelectFromListScene Members
SelectFromListScene Class Constructors Methods Properties Events See Also

The SelectFromListScene type exposes the following members.

Constructors

 | Name | Description
Public method | SelectFromListScene | Initializes the new instance of the SelectFromListScene control.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InitializeComponent | InitializeComponent
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Overrides ControlOnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | AllowEdit | Gets or sets boolean value determining whether dialog should allow adding or deleting items.
Public property | AllowMultipleSelection | Gets or sets boolean value determining whether multiple selection is allowed.
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Protected property | Content | (Inherited from UserControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemType | Gets the type of items in collections.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SortedSourceView | Gets the sorted view of SourceCollectionEdited to display in the list of available objects.
Public property | SourceCollection | Gets the reference to the source collection.
Public property | SourceCollectionEdited | Gets the reference to the edited copy of the source collection.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TargetCollection | Gets the reference to the target collection.
Public property | TargetCollectionEdited | Gets the reference to the edited copy of the target collection.
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

SelectFromListScene Class


SelectFromListScene Constructor

[image]

.NET Framework Class Library
SelectFromListScene Constructor
SelectFromListScene Class See Also
Initializes the new instance of the SelectFromListScene control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public SelectFromListScene()
Visual Basic
Public Sub New

See Also

SelectFromListScene Class


SelectFromListScene Methods

[image] [image]

.NET Framework Class Library
SelectFromListScene Methods
SelectFromListScene Class See Also

The SelectFromListScene type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InitializeComponent | InitializeComponent
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Overrides ControlOnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

SelectFromListScene Class


InitializeComponent Method

[image]

.NET Framework Class Library
SelectFromListScene..::..InitializeComponent Method
SelectFromListScene Class See Also
InitializeComponent

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DebuggerNonUserCodeAttribute]
public void InitializeComponent()
Visual Basic
<DebuggerNonUserCodeAttribute> _
Public Sub InitializeComponent

See Also

SelectFromListScene Class


OnKeyDown Method

[image]

.NET Framework Class Library
SelectFromListScene..::..OnKeyDown Method
SelectFromListScene Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)

Parameters

e
Type: System.Windows.Input..::..KeyEventArgs

See Also

SelectFromListScene Class


SelectFromListScene Properties

[image] [image]

.NET Framework Class Library
SelectFromListScene Properties
SelectFromListScene Class See Also

The SelectFromListScene type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | AllowEdit | Gets or sets boolean value determining whether dialog should allow adding or deleting items.
Public property | AllowMultipleSelection | Gets or sets boolean value determining whether multiple selection is allowed.
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Protected property | Content | (Inherited from UserControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemType | Gets the type of items in collections.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SortedSourceView | Gets the sorted view of SourceCollectionEdited to display in the list of available objects.
Public property | SourceCollection | Gets the reference to the source collection.
Public property | SourceCollectionEdited | Gets the reference to the edited copy of the source collection.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TargetCollection | Gets the reference to the target collection.
Public property | TargetCollectionEdited | Gets the reference to the edited copy of the target collection.
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

SelectFromListScene Class


AllowEdit Property

[image]

.NET Framework Class Library
SelectFromListScene..::..AllowEdit Property
SelectFromListScene Class See Also
Gets or sets boolean value determining whether dialog should allow adding or deleting items.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool AllowEdit { get; set; }
Visual Basic
Public Property AllowEdit As Boolean
    Get
    Set

Field Value

The default value is true.

See Also

SelectFromListScene Class


AllowMultipleSelection Property

[image]

.NET Framework Class Library
SelectFromListScene..::..AllowMultipleSelection Property
SelectFromListScene Class See Also
Gets or sets boolean value determining whether multiple selection is allowed.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool AllowMultipleSelection { get; set; }
Visual Basic
Public Property AllowMultipleSelection As Boolean
    Get
    Set

Field Value

The default value is true.

See Also

SelectFromListScene Class


ItemType Property

[image]

.NET Framework Class Library
SelectFromListScene..::..ItemType Property
SelectFromListScene Class See Also
Gets the type of items in collections.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Type ItemType { get; }
Visual Basic
Public ReadOnly Property ItemType As Type
    Get

See Also

SelectFromListScene Class


SortedSourceView Property

[image]

.NET Framework Class Library
SelectFromListScene..::..SortedSourceView Property
SelectFromListScene Class See Also
Gets the sorted view of SourceCollectionEdited to display in the list of available objects.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public PagedCollectionView SortedSourceView { get; }
Visual Basic
Public ReadOnly Property SortedSourceView As PagedCollectionView
    Get

See Also

SelectFromListScene Class


SourceCollection Property

[image]

.NET Framework Class Library
SelectFromListScene..::..SourceCollection Property
SelectFromListScene Class See Also
Gets the reference to the source collection.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public IList SourceCollection { get; }
Visual Basic
Public ReadOnly Property SourceCollection As IList
    Get

See Also

SelectFromListScene Class


SourceCollectionEdited Property

[image]

.NET Framework Class Library
SelectFromListScene..::..SourceCollectionEdited Property
SelectFromListScene Class See Also
Gets the reference to the edited copy of the source collection.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public IList SourceCollectionEdited { get; }
Visual Basic
Public ReadOnly Property SourceCollectionEdited As IList
    Get

See Also

SelectFromListScene Class


TargetCollection Property

[image]

.NET Framework Class Library
SelectFromListScene..::..TargetCollection Property
SelectFromListScene Class See Also
Gets the reference to the target collection.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public IList TargetCollection { get; }
Visual Basic
Public ReadOnly Property TargetCollection As IList
    Get

See Also

SelectFromListScene Class


TargetCollectionEdited Property

[image]

.NET Framework Class Library
SelectFromListScene..::..TargetCollectionEdited Property
SelectFromListScene Class See Also
Gets the reference to the edited copy of the target collection.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public IList TargetCollectionEdited { get; }
Visual Basic
Public ReadOnly Property TargetCollectionEdited As IList
    Get

See Also

SelectFromListScene Class


SelectFromListScene Events

[image] [image]

.NET Framework Class Library
SelectFromListScene Events
SelectFromListScene Class See Also

The SelectFromListScene type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

SelectFromListScene Class


SelectionCommand Enumeration

[image]

.NET Framework Class Library
SelectionCommand Enumeration
See Also
Determines the type of selection.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public enum SelectionCommand
Visual Basic
Public Enumeration SelectionCommand

Members

Member name | Description
Select | Select command.
Unselect | Unselect command.
Toggle | Toggle selection command.
Extend | Extend selection command.

See Also


ShiftingCanvas Class

[image]

.NET Framework Class Library
ShiftingCanvas Class
Members See Also
Positions children elements in the viewport of the parent ScrollViewer control which supports horizontal scrolling.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class ShiftingCanvas : Canvas
Visual Basic
Public Class ShiftingCanvas _
    Inherits Canvas

Remarks

If some part of the ShiftingCanvas is scrolled out of the view, children elements are moved according to the scroll position. Depending on the HorizontalContentAlignment property value children are aligned to the left-most or the right-most viewport side. HorizontalContentAlignment.Center and HorizontalContentAlignment.Stretch are not supported.

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Panel
System.Windows.Controls..::..Canvas
C1.Silverlight.Schedule..::..ShiftingCanvas

See Also

ShiftingCanvas Members


ShiftingCanvas Members

[image] [image]

.NET Framework Class Library
ShiftingCanvas Members
ShiftingCanvas Class Constructors Methods Fields Properties Events See Also

The ShiftingCanvas type exposes the following members.

Constructors

 | Name | Description
Public method | ShiftingCanvas | Creates the new instance of the ShiftingCanvas class.

Methods

 | Name | Description
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Arranges the content of a Canvas element. (Inherited from Canvas.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Measures the child elements of a Canvas in anticipation of arranging them during the ArrangeOverride(Size) pass. (Inherited from Canvas.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
HorizontalContentAlignmentProperty | Identifies the HorizontalContentAlignment dependency property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. This is a dependency property. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property.
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SkipScrollViewers | Gets or sets an Int32 value specifying the number of parent ScrollViewers which should be ignored. The default value is 0.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

ShiftingCanvas Class


ShiftingCanvas Constructor

[image]

.NET Framework Class Library
ShiftingCanvas Constructor
ShiftingCanvas Class See Also
Creates the new instance of the ShiftingCanvas class.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ShiftingCanvas()
Visual Basic
Public Sub New

See Also

ShiftingCanvas Class


ShiftingCanvas Fields

[image] [image]

.NET Framework Class Library
ShiftingCanvas Fields
ShiftingCanvas Class See Also

The ShiftingCanvas type exposes the following members.

Fields

Name | Description
HorizontalContentAlignmentProperty | Identifies the HorizontalContentAlignment dependency property.

See Also

ShiftingCanvas Class


HorizontalContentAlignmentProperty Field

[image]

.NET Framework Class Library
ShiftingCanvas..::..HorizontalContentAlignmentProperty Field
ShiftingCanvas Class See Also
Identifies the HorizontalContentAlignment dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty HorizontalContentAlignmentProperty
Visual Basic
Public Shared ReadOnly HorizontalContentAlignmentProperty As DependencyProperty

See Also

ShiftingCanvas Class


ShiftingCanvas Methods

[image] [image]

.NET Framework Class Library
ShiftingCanvas Methods
ShiftingCanvas Class See Also

The ShiftingCanvas type exposes the following members.

Methods

 | Name | Description
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Arranges the content of a Canvas element. (Inherited from Canvas.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Measures the child elements of a Canvas in anticipation of arranging them during the ArrangeOverride(Size) pass. (Inherited from Canvas.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

ShiftingCanvas Class


ShiftingCanvas Properties

[image] [image]

.NET Framework Class Library
ShiftingCanvas Properties
ShiftingCanvas Class See Also

The ShiftingCanvas type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. This is a dependency property. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property.
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SkipScrollViewers | Gets or sets an Int32 value specifying the number of parent ScrollViewers which should be ignored. The default value is 0.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

ShiftingCanvas Class


HorizontalContentAlignment Property

[image]

.NET Framework Class Library
ShiftingCanvas..::..HorizontalContentAlignment Property
ShiftingCanvas Class See Also
Gets or sets the horizontal alignment of the control's content. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public HorizontalAlignment HorizontalContentAlignment { get; set; }
Visual Basic
Public Property HorizontalContentAlignment As HorizontalAlignment
    Get
    Set

Remarks

HorizontalContentAlignment.Center and HorizontalContentAlignment.Stretch are not supported.

See Also

ShiftingCanvas Class


SkipScrollViewers Property

[image]

.NET Framework Class Library
ShiftingCanvas..::..SkipScrollViewers Property
ShiftingCanvas Class See Also
Gets or sets an Int32 value specifying the number of parent ScrollViewers which should be ignored. The default value is 0.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public int SkipScrollViewers { get; set; }
Visual Basic
Public Property SkipScrollViewers As Integer
    Get
    Set

See Also

ShiftingCanvas Class


ShiftingCanvas Events

[image] [image]

.NET Framework Class Library
ShiftingCanvas Events
ShiftingCanvas Class See Also

The ShiftingCanvas type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

ShiftingCanvas Class


ShowRemindersControl Class

[image]

.NET Framework Class Library
ShowRemindersControl Class
Members See Also
The ShowRemindersControl displays currently active reminders and allows to control them.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class ShowRemindersControl : UserControl
Visual Basic
Public Class ShowRemindersControl _
    Inherits UserControl

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..UserControl
C1.Silverlight.Schedule..::..ShowRemindersControl

See Also

ShowRemindersControl Members


ShowRemindersControl Members

[image] [image]

.NET Framework Class Library
ShowRemindersControl Members
ShowRemindersControl Class Constructors Methods Fields Properties Events See Also

The ShowRemindersControl type exposes the following members.

Constructors

 | Name | Description
Public method | ShowRemindersControl | Initializes a new instance of the ShowRemindersControl class.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InitializeComponent | InitializeComponent
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Overrides ControlOnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
SchedulerProperty | Identifies the Scheduler dependency property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Protected property | Content | (Inherited from UserControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Scheduler | Gets or sets reference to the C1Scheduler control which is an owner of displayed Reminder objects.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

ShowRemindersControl Class


ShowRemindersControl Constructor

[image]

.NET Framework Class Library
ShowRemindersControl Constructor
ShowRemindersControl Class See Also
Initializes a new instance of the ShowRemindersControl class.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public ShowRemindersControl()
Visual Basic
Public Sub New

See Also

ShowRemindersControl Class


ShowRemindersControl Fields

[image] [image]

.NET Framework Class Library
ShowRemindersControl Fields
ShowRemindersControl Class See Also

The ShowRemindersControl type exposes the following members.

Fields

Name | Description
SchedulerProperty | Identifies the Scheduler dependency property.

See Also

ShowRemindersControl Class


SchedulerProperty Field

[image]

.NET Framework Class Library
ShowRemindersControl..::..SchedulerProperty Field
ShowRemindersControl Class See Also
Identifies the Scheduler dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty SchedulerProperty
Visual Basic
Public Shared ReadOnly SchedulerProperty As DependencyProperty

See Also

ShowRemindersControl Class


ShowRemindersControl Methods

[image] [image]

.NET Framework Class Library
ShowRemindersControl Methods
ShowRemindersControl Class See Also

The ShowRemindersControl type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InitializeComponent | InitializeComponent
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Overrides ControlOnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

ShowRemindersControl Class


InitializeComponent Method

[image]

.NET Framework Class Library
ShowRemindersControl..::..InitializeComponent Method
ShowRemindersControl Class See Also
InitializeComponent

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DebuggerNonUserCodeAttribute]
public void InitializeComponent()
Visual Basic
<DebuggerNonUserCodeAttribute> _
Public Sub InitializeComponent

See Also

ShowRemindersControl Class


OnKeyDown Method

[image]

.NET Framework Class Library
ShowRemindersControl..::..OnKeyDown Method
ShowRemindersControl Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)

Parameters

e
Type: System.Windows.Input..::..KeyEventArgs

See Also

ShowRemindersControl Class


ShowRemindersControl Properties

[image] [image]

.NET Framework Class Library
ShowRemindersControl Properties
ShowRemindersControl Class See Also

The ShowRemindersControl type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Protected property | Content | (Inherited from UserControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Scheduler | Gets or sets reference to the C1Scheduler control which is an owner of displayed Reminder objects.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

ShowRemindersControl Class


Scheduler Property

[image]

.NET Framework Class Library
ShowRemindersControl..::..Scheduler Property
ShowRemindersControl Class See Also
Gets or sets reference to the C1Scheduler control which is an owner of displayed Reminder objects.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1Scheduler Scheduler { get; set; }
Visual Basic
Public Property Scheduler As C1Scheduler
    Get
    Set

See Also

ShowRemindersControl Class


ShowRemindersControl Events

[image] [image]

.NET Framework Class Library
ShowRemindersControl Events
ShowRemindersControl Class See Also

The ShowRemindersControl type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

ShowRemindersControl Class


SizingType Enumeration

[image]

.NET Framework Class Library
SizingType Enumeration
See Also
Describes how UI element is sized with respect to the available space.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public enum SizingType
Visual Basic
Public Enumeration SizingType

Members

Member name | Description
Fixed | The element size is fixed.
Proportional | Element size depends on available space. Every element has the same size which is determined so that all elements fit into available space.
ExtendedSingle | If element has no intersection with other elements, it will occupy all available space. If there are 2 or more intersecting elements, they all will have fixed size.

See Also


StretchingCanvas Class

[image]

.NET Framework Class Library
StretchingCanvas Class
Members See Also
The StretchingCanvas panel positions child elements as standard Canvas and keeps child's Width equal to the parent StretchingCanvas ActualWidth property value. This is a supplementary panel which is required due to Silverlight limitation (Silverlight doesn't support binding to the ActualWidth property).

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class StretchingCanvas : Panel
Visual Basic
Public Class StretchingCanvas _
    Inherits Panel

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Panel
C1.Silverlight.Schedule..::..StretchingCanvas

See Also

StretchingCanvas Members


StretchingCanvas Members

[image] [image]

.NET Framework Class Library
StretchingCanvas Members
StretchingCanvas Class Constructors Methods Fields Properties Attached Properties Events See Also

The StretchingCanvas type exposes the following members.

Constructors

 | Name | Description
Public method | StretchingCanvas | Initializes a new instance fo the StretchingCanvas panel.

Methods

 | Name | Description
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | (Overrides FrameworkElement..::..ArrangeOverride(Size).)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLeft | Gets the value of the Left attached property for a given object.
 | GetTop | Gets the value of the Top attached property for a given object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | (Overrides FrameworkElement..::..MeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
 | SetLeft | Sets the value of the Left attached property for a given object.
 | SetTop | Sets the value of the Top attached property for a given object.
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
LeftProperty | Identifies the Left attached property.
TopProperty | Identifies the Top attached property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. This is a dependency property. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Attached Properties

 | Name | Description
Public attached property | Left |
Public attached property | Top |

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

StretchingCanvas Class


StretchingCanvas Constructor

[image]

.NET Framework Class Library
StretchingCanvas Constructor
StretchingCanvas Class See Also
Initializes a new instance fo the StretchingCanvas panel.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public StretchingCanvas()
Visual Basic
Public Sub New

See Also

StretchingCanvas Class


StretchingCanvas Fields

[image] [image]

.NET Framework Class Library
StretchingCanvas Fields
StretchingCanvas Class See Also

The StretchingCanvas type exposes the following members.

Fields

Name | Description
LeftProperty | Identifies the Left attached property.
TopProperty | Identifies the Top attached property.

See Also

StretchingCanvas Class


LeftProperty Field

[image]

.NET Framework Class Library
StretchingCanvas..::..LeftProperty Field
StretchingCanvas Class See Also
Identifies the Left attached property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty LeftProperty
Visual Basic
Public Shared ReadOnly LeftProperty As DependencyProperty

See Also

StretchingCanvas Class


TopProperty Field

[image]

.NET Framework Class Library
StretchingCanvas..::..TopProperty Field
StretchingCanvas Class See Also
Identifies the Top attached property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty TopProperty
Visual Basic
Public Shared ReadOnly TopProperty As DependencyProperty

See Also

StretchingCanvas Class


StretchingCanvas Methods

[image] [image]

.NET Framework Class Library
StretchingCanvas Methods
StretchingCanvas Class See Also

The StretchingCanvas type exposes the following members.

Methods

 | Name | Description
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | (Overrides FrameworkElement..::..ArrangeOverride(Size).)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLeft | Gets the value of the Left attached property for a given object.
 | GetTop | Gets the value of the Top attached property for a given object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | (Overrides FrameworkElement..::..MeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
 | SetLeft | Sets the value of the Left attached property for a given object.
 | SetTop | Sets the value of the Top attached property for a given object.
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

StretchingCanvas Class


ArrangeOverride Method

[image]

.NET Framework Class Library
StretchingCanvas..::..ArrangeOverride Method
StretchingCanvas Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override Size ArrangeOverride(
    Size arrangeSize
)
Visual Basic
Protected Overrides Function ArrangeOverride ( _
    arrangeSize As Size _
) As Size

Parameters

arrangeSize
Type: System.Windows..::..Size

See Also

StretchingCanvas Class


GetLeft Method

[image]

.NET Framework Class Library
StretchingCanvas..::..GetLeft Method
StretchingCanvas Class See Also
Gets the value of the Left attached property for a given object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static double GetLeft(
    UIElement element
)
Visual Basic
Public Shared Function GetLeft ( _
    element As UIElement _
) As Double

Parameters

element
Type: System.Windows..::..UIElement
The object from which the property value is read.

Return Value

The Left value of the specified object.

See Also

StretchingCanvas Class


GetTop Method

[image]

.NET Framework Class Library
StretchingCanvas..::..GetTop Method
StretchingCanvas Class See Also
Gets the value of the Top attached property for a given object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static double GetTop(
    UIElement element
)
Visual Basic
Public Shared Function GetTop ( _
    element As UIElement _
) As Double

Parameters

element
Type: System.Windows..::..UIElement
The object from which the property value is read.

Return Value

The Top value of the specified object.

See Also

StretchingCanvas Class


MeasureOverride Method

[image]

.NET Framework Class Library
StretchingCanvas..::..MeasureOverride Method
StretchingCanvas Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override Size MeasureOverride(
    Size constraint
)
Visual Basic
Protected Overrides Function MeasureOverride ( _
    constraint As Size _
) As Size

Parameters

constraint
Type: System.Windows..::..Size

See Also

StretchingCanvas Class


SetLeft Method

[image]

.NET Framework Class Library
StretchingCanvas..::..SetLeft Method
StretchingCanvas Class See Also
Sets the value of the Left attached property for a given object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static void SetLeft(
    UIElement element,
    double length
)
Visual Basic
Public Shared Sub SetLeft ( _
    element As UIElement, _
    length As Double _
)

Parameters

element
Type: System.Windows..::..UIElement
The object to which the property value is written.
length
Type: System..::..Double
The Left value of the specified element.

See Also

StretchingCanvas Class


SetTop Method

[image]

.NET Framework Class Library
StretchingCanvas..::..SetTop Method
StretchingCanvas Class See Also
Sets the value of the Top attached property for a given object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static void SetTop(
    UIElement element,
    double length
)
Visual Basic
Public Shared Sub SetTop ( _
    element As UIElement, _
    length As Double _
)

Parameters

element
Type: System.Windows..::..UIElement
The object to which the property value is written.
length
Type: System..::..Double
The Top value of the specified element.

See Also

StretchingCanvas Class


StretchingCanvas Properties

[image] [image]

.NET Framework Class Library
StretchingCanvas Properties
StretchingCanvas Class See Also

The StretchingCanvas type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. This is a dependency property. (Inherited from Panel.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

StretchingCanvas Class


StretchingCanvas Events

[image] [image]

.NET Framework Class Library
StretchingCanvas Events
StretchingCanvas Class See Also

The StretchingCanvas type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

StretchingCanvas Class


StretchingCanvas Attached Properties

[image] [image]

.NET Framework Class Library
StretchingCanvas Attached Properties
StretchingCanvas Class See Also

The StretchingCanvas type exposes the following members.

Attached Properties

 | Name | Description
Public attached property | Left |
Public attached property | Top |

See Also

StretchingCanvas Class


Left Attached Property

[image]

.NET Framework Class Library
StretchingCanvas..::..Left Attached Property
StretchingCanvas Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
See GetLeft, SetLeft
Visual Basic
See GetLeft, SetLeft

See Also

StretchingCanvas Class


Top Attached Property

[image]

.NET Framework Class Library
StretchingCanvas..::..Top Attached Property
StretchingCanvas Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
See GetTop, SetTop
Visual Basic
See GetTop, SetTop

See Also

StretchingCanvas Class


ThemeResources Class

[image]

.NET Framework Class Library
ThemeResources Class
Members See Also
The ThemeResources class is a base abstract class for ThemeResources classes.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public abstract class ThemeResources
Visual Basic
Public MustInherit Class ThemeResources

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..ThemeResources
C1.Silverlight.Schedule..::..C1CalendarResources
C1.Silverlight.Schedule..::..C1SchedulerResources

See Also

ThemeResources Members


ThemeResources Members

[image] [image]

.NET Framework Class Library
ThemeResources Members
ThemeResources Class Constructors Methods Properties See Also

The ThemeResources type exposes the following members.

Constructors

 | Name | Description
Protected method | ThemeResources |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshResources | When overridden in a derived class, refreshes class properties from the current theme resources.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Theme | Gets or sets the ResourceDictionary object used as the theme for the control.

See Also

ThemeResources Class


ThemeResources Constructor

[image]

.NET Framework Class Library
ThemeResources Constructor
ThemeResources Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected ThemeResources()
Visual Basic
Protected Sub New

See Also

ThemeResources Class


ThemeResources Methods

[image] [image]

.NET Framework Class Library
ThemeResources Methods
ThemeResources Class See Also

The ThemeResources type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshResources | When overridden in a derived class, refreshes class properties from the current theme resources.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ThemeResources Class


RefreshResources Method

[image]

.NET Framework Class Library
ThemeResources..::..RefreshResources Method
ThemeResources Class See Also
When overridden in a derived class, refreshes class properties from the current theme resources.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public abstract void RefreshResources()
Visual Basic
Public MustOverride Sub RefreshResources

See Also

ThemeResources Class


ThemeResources Properties

[image] [image]

.NET Framework Class Library
ThemeResources Properties
ThemeResources Class See Also

The ThemeResources type exposes the following members.

Properties

 | Name | Description
Public property | Theme | Gets or sets the ResourceDictionary object used as the theme for the control.

See Also

ThemeResources Class


Theme Property

[image]

.NET Framework Class Library
ThemeResources..::..Theme Property
ThemeResources Class See Also
Gets or sets the ResourceDictionary object used as the theme for the control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual ResourceDictionary Theme { get; set; }
Visual Basic
Public Overridable Property Theme As ResourceDictionary
    Get
    Set

See Also

ThemeResources Class


TimeRulerConverter Class

[image]

.NET Framework Class Library
TimeRulerConverter Class
Members See Also
Represents a Binding converter that converts minute part of DateTimeInfo start time to its string representation.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class TimeRulerConverter : IValueConverter
Visual Basic
Public Class TimeRulerConverter _
    Implements IValueConverter

Remarks

TimeRulerConverter is a one-way converter.

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..TimeRulerConverter

See Also

TimeRulerConverter Members


TimeRulerConverter Members

[image] [image]

.NET Framework Class Library
TimeRulerConverter Members
TimeRulerConverter Class Constructors Methods Fields See Also

The TimeRulerConverter type exposes the following members.

Constructors

 | Name | Description
Public method | TimeRulerConverter |

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Throws System.NotImplementedException.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Default | Gets an instance of TimeRulerConverter.

See Also

TimeRulerConverter Class


TimeRulerConverter Constructor

[image]

.NET Framework Class Library
TimeRulerConverter Constructor
TimeRulerConverter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public TimeRulerConverter()
Visual Basic
Public Sub New

See Also

TimeRulerConverter Class


TimeRulerConverter Fields

[image] [image]

.NET Framework Class Library
TimeRulerConverter Fields
TimeRulerConverter Class See Also

The TimeRulerConverter type exposes the following members.

Fields

Name | Description
Default | Gets an instance of TimeRulerConverter.

See Also

TimeRulerConverter Class


Default Field

[image]

.NET Framework Class Library
TimeRulerConverter..::..Default Field
TimeRulerConverter Class See Also
Gets an instance of TimeRulerConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly TimeRulerConverter Default
Visual Basic
Public Shared ReadOnly Default As TimeRulerConverter

See Also

TimeRulerConverter Class


TimeRulerConverter Methods

[image] [image]

.NET Framework Class Library
TimeRulerConverter Methods
TimeRulerConverter Class See Also

The TimeRulerConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Throws System.NotImplementedException.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimeRulerConverter Class


Convert Method

[image]

.NET Framework Class Library
TimeRulerConverter..::..Convert Method
TimeRulerConverter Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

TimeRulerConverter Class


ConvertBack Method

[image]

.NET Framework Class Library
TimeRulerConverter..::..ConvertBack Method
TimeRulerConverter Class See Also
Throws System.NotImplementedException.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value that is produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

TimeRulerConverter Class


TimeRulerHelper Class

[image]

.NET Framework Class Library
TimeRulerHelper Class
Members See Also
Supplies hours and minutes string representation based on the specified VisualInterval object, current culture and TimeFormat property value.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class TimeRulerHelper : FrameworkElement
Visual Basic
Public Class TimeRulerHelper _
    Inherits FrameworkElement

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
C1.Silverlight.Schedule..::..TimeRulerHelper

See Also

TimeRulerHelper Members


TimeRulerHelper Members

[image] [image]

.NET Framework Class Library
TimeRulerHelper Members
TimeRulerHelper Class Constructors Methods Fields Properties Events See Also

The TimeRulerHelper type exposes the following members.

Constructors

 | Name | Description
Public method | TimeRulerHelper | Initializes a new instance of the TimeRulerHelper element.

Methods

 | Name | Description
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
HoursProperty | Identifies the Hours dependency property.
IntervalProperty | Identifies the Interval dependency property.
IsZeroMinuteProperty | Identifies the IsZeroMinute dependency property.
MinutesProperty | Identifies the Minutes dependency property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Hours | Gets the String value representing the hours part of the VisualInterfal.Start time.
Public property | Interval | Gets or sets the VisualInterval object.
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsZeroMinute | Gets the Boolean value determining whether VisualInterval.StartTime.Minute property is 0.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Minutes | Gets the String value representing the minutes part of the VisualInterfal.Start time.
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

TimeRulerHelper Class


TimeRulerHelper Constructor

[image]

.NET Framework Class Library
TimeRulerHelper Constructor
TimeRulerHelper Class See Also
Initializes a new instance of the TimeRulerHelper element.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public TimeRulerHelper()
Visual Basic
Public Sub New

See Also

TimeRulerHelper Class


TimeRulerHelper Fields

[image] [image]

.NET Framework Class Library
TimeRulerHelper Fields
TimeRulerHelper Class See Also

The TimeRulerHelper type exposes the following members.

Fields

Name | Description
HoursProperty | Identifies the Hours dependency property.
IntervalProperty | Identifies the Interval dependency property.
IsZeroMinuteProperty | Identifies the IsZeroMinute dependency property.
MinutesProperty | Identifies the Minutes dependency property.

See Also

TimeRulerHelper Class


HoursProperty Field

[image]

.NET Framework Class Library
TimeRulerHelper..::..HoursProperty Field
TimeRulerHelper Class See Also
Identifies the Hours dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty HoursProperty
Visual Basic
Public Shared ReadOnly HoursProperty As DependencyProperty

See Also

TimeRulerHelper Class


IntervalProperty Field

[image]

.NET Framework Class Library
TimeRulerHelper..::..IntervalProperty Field
TimeRulerHelper Class See Also
Identifies the Interval dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty IntervalProperty
Visual Basic
Public Shared ReadOnly IntervalProperty As DependencyProperty

See Also

TimeRulerHelper Class


IsZeroMinuteProperty Field

[image]

.NET Framework Class Library
TimeRulerHelper..::..IsZeroMinuteProperty Field
TimeRulerHelper Class See Also
Identifies the IsZeroMinute dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty IsZeroMinuteProperty
Visual Basic
Public Shared ReadOnly IsZeroMinuteProperty As DependencyProperty

See Also

TimeRulerHelper Class


MinutesProperty Field

[image]

.NET Framework Class Library
TimeRulerHelper..::..MinutesProperty Field
TimeRulerHelper Class See Also
Identifies the Minutes dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty MinutesProperty
Visual Basic
Public Shared ReadOnly MinutesProperty As DependencyProperty

See Also

TimeRulerHelper Class


TimeRulerHelper Methods

[image] [image]

.NET Framework Class Library
TimeRulerHelper Methods
TimeRulerHelper Class See Also

The TimeRulerHelper type exposes the following members.

Methods

 | Name | Description
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

TimeRulerHelper Class


TimeRulerHelper Properties

[image] [image]

.NET Framework Class Library
TimeRulerHelper Properties
TimeRulerHelper Class See Also

The TimeRulerHelper type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Hours | Gets the String value representing the hours part of the VisualInterfal.Start time.
Public property | Interval | Gets or sets the VisualInterval object.
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsZeroMinute | Gets the Boolean value determining whether VisualInterval.StartTime.Minute property is 0.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Minutes | Gets the String value representing the minutes part of the VisualInterfal.Start time.
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

TimeRulerHelper Class


Hours Property

[image]

.NET Framework Class Library
TimeRulerHelper..::..Hours Property
TimeRulerHelper Class See Also
Gets the String value representing the hours part of the VisualInterfal.Start time.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string Hours { get; private set; }
Visual Basic
Public Property Hours As String
    Get
    Private Set

See Also

TimeRulerHelper Class


Interval Property

[image]

.NET Framework Class Library
TimeRulerHelper..::..Interval Property
TimeRulerHelper Class See Also
Gets or sets the VisualInterval object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public VisualInterval Interval { get; set; }
Visual Basic
Public Property Interval As VisualInterval
    Get
    Set

See Also

TimeRulerHelper Class


IsZeroMinute Property

[image]

.NET Framework Class Library
TimeRulerHelper..::..IsZeroMinute Property
TimeRulerHelper Class See Also
Gets the Boolean value determining whether VisualInterval.StartTime.Minute property is 0.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsZeroMinute { get; private set; }
Visual Basic
Public Property IsZeroMinute As Boolean
    Get
    Private Set

See Also

TimeRulerHelper Class


Minutes Property

[image]

.NET Framework Class Library
TimeRulerHelper..::..Minutes Property
TimeRulerHelper Class See Also
Gets the String value representing the minutes part of the VisualInterfal.Start time.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string Minutes { get; private set; }
Visual Basic
Public Property Minutes As String
    Get
    Private Set

See Also

TimeRulerHelper Class


TimeRulerHelper Events

[image] [image]

.NET Framework Class Library
TimeRulerHelper Events
TimeRulerHelper Class See Also

The TimeRulerHelper type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

TimeRulerHelper Class


TimeRulerVisibilityConverter Class

[image]

.NET Framework Class Library
TimeRulerVisibilityConverter Class
Members See Also
Represents a Binding converter that returns a Visibility value for the time ruler UI part.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class TimeRulerVisibilityConverter : IValueConverter
Visual Basic
Public Class TimeRulerVisibilityConverter _
    Implements IValueConverter

Remarks

TimeRulerVisibilityConverter is a one-way converter. Returns Visibility.Collapsed if specified TimeSpan value is greater or equal to 1 day.

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..TimeRulerVisibilityConverter

See Also

TimeRulerVisibilityConverter Members


TimeRulerVisibilityConverter Members

[image] [image]

.NET Framework Class Library
TimeRulerVisibilityConverter Members
TimeRulerVisibilityConverter Class Constructors Methods Fields See Also

The TimeRulerVisibilityConverter type exposes the following members.

Constructors

 | Name | Description
Public method | TimeRulerVisibilityConverter |

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Throws System.NotImplementedException.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Default | Gets an instance of TimeRulerVisibilityConverter.

See Also

TimeRulerVisibilityConverter Class


TimeRulerVisibilityConverter Constructor

[image]

.NET Framework Class Library
TimeRulerVisibilityConverter Constructor
TimeRulerVisibilityConverter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public TimeRulerVisibilityConverter()
Visual Basic
Public Sub New

See Also

TimeRulerVisibilityConverter Class


TimeRulerVisibilityConverter Fields

[image] [image]

.NET Framework Class Library
TimeRulerVisibilityConverter Fields
TimeRulerVisibilityConverter Class See Also

The TimeRulerVisibilityConverter type exposes the following members.

Fields

Name | Description
Default | Gets an instance of TimeRulerVisibilityConverter.

See Also

TimeRulerVisibilityConverter Class


Default Field

[image]

.NET Framework Class Library
TimeRulerVisibilityConverter..::..Default Field
TimeRulerVisibilityConverter Class See Also
Gets an instance of TimeRulerVisibilityConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly TimeRulerVisibilityConverter Default
Visual Basic
Public Shared ReadOnly Default As TimeRulerVisibilityConverter

See Also

TimeRulerVisibilityConverter Class


TimeRulerVisibilityConverter Methods

[image] [image]

.NET Framework Class Library
TimeRulerVisibilityConverter Methods
TimeRulerVisibilityConverter Class See Also

The TimeRulerVisibilityConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Throws System.NotImplementedException.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimeRulerVisibilityConverter Class


Convert Method

[image]

.NET Framework Class Library
TimeRulerVisibilityConverter..::..Convert Method
TimeRulerVisibilityConverter Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

TimeRulerVisibilityConverter Class


ConvertBack Method

[image]

.NET Framework Class Library
TimeRulerVisibilityConverter..::..ConvertBack Method
TimeRulerVisibilityConverter Class See Also
Throws System.NotImplementedException.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value that is produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

TimeRulerVisibilityConverter Class


TimeSlotGroupStyleSelector Class

[image]

.NET Framework Class Library
TimeSlotGroupStyleSelector Class
Members See Also
This class provides a way to apply time slot group styles for working/free hours in DayView/WorkWeekView modes.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class TimeSlotGroupStyleSelector : C1StyleSelector
Visual Basic
Public Class TimeSlotGroupStyleSelector _
    Inherits C1StyleSelector

Remarks

For the sample of using look at OneDayStyleBase in generic.xaml.

  1. Create an instance of this class:

    <local:TimeSlotGroupStyleSelector x:Key="TimeSlotGroupStyleSelector"/>

  2. Define two group styles:
    • with the key "PART_C1Scheduler_WorkHour_Style" for work hours;
    • with the key "PART_C1Scheduler_FreeHour_Style" for free hours.

  3. Specify style selector in the group definition:

    <GroupStyle ContainerStyleSelector="{StaticResource TimeSlotGroupStyleSelector}">

Inheritance Hierarchy

System..::..Object
C1StyleSelector
C1.Silverlight.Schedule..::..TimeSlotGroupStyleSelector

See Also

TimeSlotGroupStyleSelector Members


TimeSlotGroupStyleSelector Members

[image] [image]

.NET Framework Class Library
TimeSlotGroupStyleSelector Members
TimeSlotGroupStyleSelector Class Constructors Methods Properties See Also

The TimeSlotGroupStyleSelector type exposes the following members.

Constructors

 | Name | Description
Public method | TimeSlotGroupStyleSelector |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SelectStyle | Returns the Style object for the specified group if it is found in resources. (Overrides C1StyleSelectorSelectStyle(Object, DependencyObject).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Resources | (Inherited from C1StyleSelector.)

See Also

TimeSlotGroupStyleSelector Class


TimeSlotGroupStyleSelector Constructor

[image]

.NET Framework Class Library
TimeSlotGroupStyleSelector Constructor
TimeSlotGroupStyleSelector Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public TimeSlotGroupStyleSelector()
Visual Basic
Public Sub New

See Also

TimeSlotGroupStyleSelector Class


TimeSlotGroupStyleSelector Methods

[image] [image]

.NET Framework Class Library
TimeSlotGroupStyleSelector Methods
TimeSlotGroupStyleSelector Class See Also

The TimeSlotGroupStyleSelector type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SelectStyle | Returns the Style object for the specified group if it is found in resources. (Overrides C1StyleSelectorSelectStyle(Object, DependencyObject).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimeSlotGroupStyleSelector Class


SelectStyle Method

[image]

.NET Framework Class Library
TimeSlotGroupStyleSelector..::..SelectStyle Method
TimeSlotGroupStyleSelector Class See Also
Returns the Style object for the specified group if it is found in resources.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override Style SelectStyle(
    Object item,
    DependencyObject container
)
Visual Basic
Public Overrides Function SelectStyle ( _
    item As Object, _
    container As DependencyObject _
) As Style

Parameters

item
Type: System..::..Object
The content.
container
Type: System.Windows..::..DependencyObject
The element to which the style will be applied.

Return Value

Returns an application-specific style to apply; otherwise, a null reference (Nothing in Visual Basic).

See Also

TimeSlotGroupStyleSelector Class


TimeSlotGroupStyleSelector Properties

[image] [image]

.NET Framework Class Library
TimeSlotGroupStyleSelector Properties
TimeSlotGroupStyleSelector Class See Also

The TimeSlotGroupStyleSelector type exposes the following members.

Properties

 | Name | Description
Public property | Resources | (Inherited from C1StyleSelector.)

See Also

TimeSlotGroupStyleSelector Class


TimeSlotStyleSelector Class

[image]

.NET Framework Class Library
TimeSlotStyleSelector Class
Members See Also
This class provides a way to apply time slot styles for working/free hours in DayView/WorkWeekView modes.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class TimeSlotStyleSelector : C1StyleSelector
Visual Basic
Public Class TimeSlotStyleSelector _
    Inherits C1StyleSelector

Remarks

For the sample of using look at OneDayStyle in generic.xaml.

  1. Create an instance of this class:

    <local:TimeSlotStyleSelector x:Key="TimeSlotStyleSelector"/>

  2. Define two group styles:
    • with the key "PART_C1Scheduler_WorkHour_Style" for work hours;
    • with the key "PART_C1Scheduler_FreeHour_Style" for free hours.
  3. Define two optional group styles:
    • with the key "PART_C1Scheduler_TopWorkHour_Style" for the top slot in every work hour;
    • with the key "PART_C1Scheduler_TopFreeHour_Style" for the top slot in every free hour.

  4. Specify ItemContainerStyleSelector property for the C1SchedulerPresenter object:

    <local:C1SchedulerPresenter ItemContainerStyleSelector="{StaticResource TimeSlotTemplateSelector}" />

Inheritance Hierarchy

System..::..Object
C1StyleSelector
C1.Silverlight.Schedule..::..TimeSlotStyleSelector

See Also

TimeSlotStyleSelector Members


TimeSlotStyleSelector Members

[image] [image]

.NET Framework Class Library
TimeSlotStyleSelector Members
TimeSlotStyleSelector Class Constructors Methods Properties See Also

The TimeSlotStyleSelector type exposes the following members.

Constructors

 | Name | Description
Public method | TimeSlotStyleSelector |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SelectStyle | (Overrides C1StyleSelectorSelectStyle(Object, DependencyObject).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Resources | (Inherited from C1StyleSelector.)

See Also

TimeSlotStyleSelector Class


TimeSlotStyleSelector Constructor

[image]

.NET Framework Class Library
TimeSlotStyleSelector Constructor
TimeSlotStyleSelector Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public TimeSlotStyleSelector()
Visual Basic
Public Sub New

See Also

TimeSlotStyleSelector Class


TimeSlotStyleSelector Methods

[image] [image]

.NET Framework Class Library
TimeSlotStyleSelector Methods
TimeSlotStyleSelector Class See Also

The TimeSlotStyleSelector type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SelectStyle | (Overrides C1StyleSelectorSelectStyle(Object, DependencyObject).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimeSlotStyleSelector Class


SelectStyle Method

[image]

.NET Framework Class Library
TimeSlotStyleSelector..::..SelectStyle Method
TimeSlotStyleSelector Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override Style SelectStyle(
    Object item,
    DependencyObject container
)
Visual Basic
Public Overrides Function SelectStyle ( _
    item As Object, _
    container As DependencyObject _
) As Style

Parameters

item
Type: System..::..Object
container
Type: System.Windows..::..DependencyObject

See Also

TimeSlotStyleSelector Class


TimeSlotStyleSelector Properties

[image] [image]

.NET Framework Class Library
TimeSlotStyleSelector Properties
TimeSlotStyleSelector Class See Also

The TimeSlotStyleSelector type exposes the following members.

Properties

 | Name | Description
Public property | Resources | (Inherited from C1StyleSelector.)

See Also

TimeSlotStyleSelector Class


TimeSlotTemplateSelector Class

[image]

.NET Framework Class Library
TimeSlotTemplateSelector Class
Members See Also
This class provides a way to choose a DataTemplate for the VisualInterval object representing the single time slot in DayView/WorkWeekView modes.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class TimeSlotTemplateSelector : C1DataTemplateSelector
Visual Basic
Public Class TimeSlotTemplateSelector _
    Inherits C1DataTemplateSelector

Remarks

For the sample of using look at OneDayStyleBase in generic.xaml.

  1. Create an instance of this class:

    <local:TimeSlotTemplateSelector x:Key="TimeSlotTemplateSelector"/>

  2. Define two DataTemplates:
    • with the key "PART_C1Scheduler_FreeSlot_Template" for free time;
    • with the key "PART_C1Scheduler_WorkSlot_Template" for working time.

  3. Specify ItemsControl.ItemTemplateSelector for the C1SchedulerPresenter object:

    <local:C1SchedulerPresenter ItemTemplateSelector="{StaticResource TimeSlotTemplateSelector}" />

Note, that if you use this method for choosing VisualInterval DataTemplate, you shouldn't set VisualIntervalTemplate property.

Inheritance Hierarchy

System..::..Object
C1DataTemplateSelector
C1.Silverlight.Schedule..::..TimeSlotTemplateSelector

See Also

TimeSlotTemplateSelector Members


TimeSlotTemplateSelector Members

[image] [image]

.NET Framework Class Library
TimeSlotTemplateSelector Members
TimeSlotTemplateSelector Class Constructors Methods Properties See Also

The TimeSlotTemplateSelector type exposes the following members.

Constructors

 | Name | Description
Public method | TimeSlotTemplateSelector |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SelectTemplate | Returns the DataTemplate object for the specified group if it is found in resources. (Overrides C1DataTemplateSelectorSelectTemplate(Object, DependencyObject).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Resources | (Inherited from C1DataTemplateSelector.)

See Also

TimeSlotTemplateSelector Class


TimeSlotTemplateSelector Constructor

[image]

.NET Framework Class Library
TimeSlotTemplateSelector Constructor
TimeSlotTemplateSelector Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public TimeSlotTemplateSelector()
Visual Basic
Public Sub New

See Also

TimeSlotTemplateSelector Class


TimeSlotTemplateSelector Methods

[image] [image]

.NET Framework Class Library
TimeSlotTemplateSelector Methods
TimeSlotTemplateSelector Class See Also

The TimeSlotTemplateSelector type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SelectTemplate | Returns the DataTemplate object for the specified group if it is found in resources. (Overrides C1DataTemplateSelectorSelectTemplate(Object, DependencyObject).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimeSlotTemplateSelector Class


SelectTemplate Method

[image]

.NET Framework Class Library
TimeSlotTemplateSelector..::..SelectTemplate Method
TimeSlotTemplateSelector Class See Also
Returns the DataTemplate object for the specified group if it is found in resources.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override DataTemplate SelectTemplate(
    Object item,
    DependencyObject container
)
Visual Basic
Public Overrides Function SelectTemplate ( _
    item As Object, _
    container As DependencyObject _
) As DataTemplate

Parameters

item
Type: System..::..Object
The data object for which to select the template.
container
Type: System.Windows..::..DependencyObject
The data-bound object.

Return Value

Returns a DataTemplate or a null reference (Nothing in Visual Basic). The default value is a null reference (Nothing in Visual Basic).

See Also

TimeSlotTemplateSelector Class


TimeSlotTemplateSelector Properties

[image] [image]

.NET Framework Class Library
TimeSlotTemplateSelector Properties
TimeSlotTemplateSelector Class See Also

The TimeSlotTemplateSelector type exposes the following members.

Properties

 | Name | Description
Public property | Resources | (Inherited from C1DataTemplateSelector.)

See Also

TimeSlotTemplateSelector Class


VisualInterval Class

[image]

.NET Framework Class Library
VisualInterval Class
Members See Also
Represents a definition of a minimal indivisible time interval represented by the C1Scheduler.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class VisualInterval : DependencyObject,
    INotifyPropertyChanged, IPropertyChangedListener
Visual Basic
Public Class VisualInterval _
    Inherits DependencyObject _
    Implements INotifyPropertyChanged, IPropertyChangedListener

Remarks

The instances of this class are used as DataContext for the VisualIntervalTemplate.

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
C1.Silverlight.Schedule..::..VisualInterval
C1.Silverlight.Schedule..::..VisualIntervalGroup

See Also

VisualInterval Members


VisualInterval Members

[image] [image]

.NET Framework Class Library
VisualInterval Members
VisualInterval Class Constructors Methods Fields Properties Events See Also

The VisualInterval type exposes the following members.

Constructors

 | Name | Description
Public method | VisualInterval | Creates a new VisualInterval object for the specified C1Scheduler that represents the specified time range.

Methods

 | Name | Description
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ContainsTime | Gets a value indicating whether the specified DateTime belongs to the time range represented by the VisualInterval.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _isDisposed |
Protected field | _scheduler |
 | IsSelectedProperty | Identifies the IsSelected dependency property.

Properties

 | Name | Description
Public property | Appointments | Gets a collection of IntervalAppointment objects representing appointments whose time range is intersected with the time range of this VisualInterval.
Public property | Culture | Gets a CultureInfo.
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | EndTime | Gets an end time of a time range represented by the VisualInterval object.
Public property | EndTimeInfo | Gets a DateTimeInfo object containing auxiliary properties for a usage in XAML that provides additional information for the EndTime property value.
Public property | InclusiveEndTime | Gets an inclusive end time of a time range represented by the VisualInterval object.
Public property | InclusiveEndTimeInfo | Gets a DateTimeInfo object containing auxiliary properties for a usage in XAML that provides additional information for the EndTimeInfo property value.
Public property | Index | Gets an index of VisualInterval in the owning VisualIntervals collection.
Public property | IsSelected | Gets or sets a value that determines whether the UI element that has this VisualInterval as a DataContext is selected. This is a dependency property.
Public property | Items | Virtual property returns null in this class implementation.
Public property | OwnerGroup | Gets the owning SchedulerGroupItem object.
Public property | Scheduler | Gets the Scheduler that VisualInterval belongs to.
Public property | StartTime | Gets a start time of a time range represented by the VisualInterval object.
Public property | StartTimeInfo | Gets a DateTimeInfo object containing auxiliary properties for a usage in XAML that provides additional information for the StartTime property value.
Public property | StatusBrush | Gets the Brush object representing interval availability status. Only honors all-day and multi-day events availability status. This is a dependency property.
Public property | TimeScale | Gets a TimeSpan of a time range represented by the VisualInterval object.
Public property | TotalStatusBrush | Gets the Brush object representing interval availability status. Honors status of all appointments in the interval. This is a dependency property.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when property value is changed.

See Also

VisualInterval Class


VisualInterval Constructor

[image]

.NET Framework Class Library
VisualInterval Constructor
VisualInterval Class See Also
Creates a new VisualInterval object for the specified C1Scheduler that represents the specified time range.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public VisualInterval(
    C1Scheduler scheduler,
    SchedulerGroupItem ownerGroup,
    DateTime startTime,
    TimeSpan timescale
)
Visual Basic
Public Sub New ( _
    scheduler As C1Scheduler, _
    ownerGroup As SchedulerGroupItem, _
    startTime As DateTime, _
    timescale As TimeSpan _
)

Parameters

scheduler
Type: C1.Silverlight.Schedule..::..C1Scheduler
A C1Scheduler that VisualInterval is created for.
ownerGroup
Type: C1.Silverlight.Schedule..::..SchedulerGroupItem
A SchedulerGroupItem that VisualInterval is created for.
startTime
Type: System..::..DateTime
A start time of a time range represented by the VisualInterval.
timescale
Type: System..::..TimeSpan
A TimeSpan of a time range represented by the VisualInterval.

See Also

VisualInterval Class


VisualInterval Fields

[image] [image]

.NET Framework Class Library
VisualInterval Fields
VisualInterval Class See Also

The VisualInterval type exposes the following members.

Fields

 | Name | Description
Protected field | _isDisposed |
Protected field | _scheduler |
 | IsSelectedProperty | Identifies the IsSelected dependency property.

See Also

VisualInterval Class


_isDisposed Field

[image]

.NET Framework Class Library
VisualInterval..::.._isDisposed Field
VisualInterval Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[CLSCompliantAttribute(false)]
protected internal bool _isDisposed
Visual Basic
<CLSCompliantAttribute(False)> _
Protected Friend _isDisposed As Boolean

See Also

VisualInterval Class


_scheduler Field

[image]

.NET Framework Class Library
VisualInterval..::.._scheduler Field
VisualInterval Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[CLSCompliantAttribute(false)]
protected internal C1Scheduler _scheduler
Visual Basic
<CLSCompliantAttribute(False)> _
Protected Friend _scheduler As C1Scheduler

See Also

VisualInterval Class


IsSelectedProperty Field

[image]

.NET Framework Class Library
VisualInterval..::..IsSelectedProperty Field
VisualInterval Class See Also
Identifies the IsSelected dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty IsSelectedProperty
Visual Basic
Public Shared ReadOnly IsSelectedProperty As DependencyProperty

See Also

VisualInterval Class


VisualInterval Methods

[image] [image]

.NET Framework Class Library
VisualInterval Methods
VisualInterval Class See Also

The VisualInterval type exposes the following members.

Methods

 | Name | Description
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ContainsTime | Gets a value indicating whether the specified DateTime belongs to the time range represented by the VisualInterval.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VisualInterval Class


ContainsTime Method

[image]

.NET Framework Class Library
VisualInterval..::..ContainsTime Method
VisualInterval Class See Also
Gets a value indicating whether the specified DateTime belongs to the time range represented by the VisualInterval.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool ContainsTime(
    DateTime time
)
Visual Basic
Public Function ContainsTime ( _
    time As DateTime _
) As Boolean

Parameters

time
Type: System..::..DateTime
A checked DateTime.

Return Value

This method returns true if the specified DateTime belongs to the time range represented by the VisualInterval; otherwise, false.

Remarks

A DateTime is considered as belonging to a VisualInterval if the following condition is satisfied:

StartTime <= DateTime and DateTime > EndTime

Note that the bottom boundary of the interval is exclusive, that is DateTime = EndTime is considered as not belonging to the interval.

See Also

VisualInterval Class


VisualInterval Properties

[image] [image]

.NET Framework Class Library
VisualInterval Properties
VisualInterval Class See Also

The VisualInterval type exposes the following members.

Properties

 | Name | Description
Public property | Appointments | Gets a collection of IntervalAppointment objects representing appointments whose time range is intersected with the time range of this VisualInterval.
Public property | Culture | Gets a CultureInfo.
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | EndTime | Gets an end time of a time range represented by the VisualInterval object.
Public property | EndTimeInfo | Gets a DateTimeInfo object containing auxiliary properties for a usage in XAML that provides additional information for the EndTime property value.
Public property | InclusiveEndTime | Gets an inclusive end time of a time range represented by the VisualInterval object.
Public property | InclusiveEndTimeInfo | Gets a DateTimeInfo object containing auxiliary properties for a usage in XAML that provides additional information for the EndTimeInfo property value.
Public property | Index | Gets an index of VisualInterval in the owning VisualIntervals collection.
Public property | IsSelected | Gets or sets a value that determines whether the UI element that has this VisualInterval as a DataContext is selected. This is a dependency property.
Public property | Items | Virtual property returns null in this class implementation.
Public property | OwnerGroup | Gets the owning SchedulerGroupItem object.
Public property | Scheduler | Gets the Scheduler that VisualInterval belongs to.
Public property | StartTime | Gets a start time of a time range represented by the VisualInterval object.
Public property | StartTimeInfo | Gets a DateTimeInfo object containing auxiliary properties for a usage in XAML that provides additional information for the StartTime property value.
Public property | StatusBrush | Gets the Brush object representing interval availability status. Only honors all-day and multi-day events availability status. This is a dependency property.
Public property | TimeScale | Gets a TimeSpan of a time range represented by the VisualInterval object.
Public property | TotalStatusBrush | Gets the Brush object representing interval availability status. Honors status of all appointments in the interval. This is a dependency property.

See Also

VisualInterval Class


Appointments Property

[image]

.NET Framework Class Library
VisualInterval..::..Appointments Property
VisualInterval Class See Also
Gets a collection of IntervalAppointment objects representing appointments whose time range is intersected with the time range of this VisualInterval.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public IntervalAppointmentCollection Appointments { get; }
Visual Basic
Public ReadOnly Property Appointments As IntervalAppointmentCollection
    Get

Remarks

This collection provides active notifications when a set of appointments intersecting with this VisualInterval is changed, so you can safely bind UI elements to it in XAML.

See Also

VisualInterval Class


Culture Property

[image]

.NET Framework Class Library
VisualInterval..::..Culture Property
VisualInterval Class See Also
Gets a CultureInfo.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public CultureInfo Culture { get; }
Visual Basic
Public ReadOnly Property Culture As CultureInfo
    Get

See Also

VisualInterval Class


EndTime Property

[image]

.NET Framework Class Library
VisualInterval..::..EndTime Property
VisualInterval Class See Also
Gets an end time of a time range represented by the VisualInterval object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTime EndTime { get; }
Visual Basic
Public ReadOnly Property EndTime As DateTime
    Get

Remarks

EndTime is calculated as a sum of the StartTime and TimeScale property values.

This property represents an exclusive boundary of the time range, that is the DateTime returned by this property is considered as not belonging to the VisualInterval time range. The inclusive boundary is represented by the InclusiveEndTime property.

See Also

VisualInterval Class


EndTimeInfo Property

[image]

.NET Framework Class Library
VisualInterval..::..EndTimeInfo Property
VisualInterval Class See Also
Gets a DateTimeInfo object containing auxiliary properties for a usage in XAML that provides additional information for the EndTime property value.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTimeInfo EndTimeInfo { get; }
Visual Basic
Public ReadOnly Property EndTimeInfo As DateTimeInfo
    Get

See Also

VisualInterval Class


InclusiveEndTime Property

[image]

.NET Framework Class Library
VisualInterval..::..InclusiveEndTime Property
VisualInterval Class See Also
Gets an inclusive end time of a time range represented by the VisualInterval object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTime InclusiveEndTime { get; }
Visual Basic
Public ReadOnly Property InclusiveEndTime As DateTime
    Get

Remarks

This property represents an inclusive boundary of the time range, that is the maximum DateTime value that is included in the time range represented by the VisualInterval, as opposite to the EndTime property.

See Also

VisualInterval Class


InclusiveEndTimeInfo Property

[image]

.NET Framework Class Library
VisualInterval..::..InclusiveEndTimeInfo Property
VisualInterval Class See Also
Gets a DateTimeInfo object containing auxiliary properties for a usage in XAML that provides additional information for the EndTimeInfo property value.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTimeInfo InclusiveEndTimeInfo { get; }
Visual Basic
Public ReadOnly Property InclusiveEndTimeInfo As DateTimeInfo
    Get

See Also

VisualInterval Class


Index Property

[image]

.NET Framework Class Library
VisualInterval..::..Index Property
VisualInterval Class See Also
Gets an index of VisualInterval in the owning VisualIntervals collection.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public int Index { get; }
Visual Basic
Public ReadOnly Property Index As Integer
    Get

See Also

VisualInterval Class


IsSelected Property

[image]

.NET Framework Class Library
VisualInterval..::..IsSelected Property
VisualInterval Class See Also
Gets or sets a value that determines whether the UI element that has this VisualInterval as a DataContext is selected. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic
Public Property IsSelected As Boolean
    Get
    Set

See Also

VisualInterval Class


Items Property

[image]

.NET Framework Class Library
VisualInterval..::..Items Property
VisualInterval Class See Also
Virtual property returns null in this class implementation.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual ReadOnlyObservableCollection Items { get; }
Visual Basic
Public Overridable ReadOnly Property Items As ReadOnlyObservableCollection
    Get

Remarks

It is necessary to avoid silent exceptions at binding when it is used with inherited classes (in other case binding takes double time).

See Also

VisualInterval Class


OwnerGroup Property

[image]

.NET Framework Class Library
VisualInterval..::..OwnerGroup Property
VisualInterval Class See Also
Gets the owning SchedulerGroupItem object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public SchedulerGroupItem OwnerGroup { get; }
Visual Basic
Public ReadOnly Property OwnerGroup As SchedulerGroupItem
    Get

See Also

VisualInterval Class


Scheduler Property

[image]

.NET Framework Class Library
VisualInterval..::..Scheduler Property
VisualInterval Class See Also
Gets the Scheduler that VisualInterval belongs to.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1Scheduler Scheduler { get; }
Visual Basic
Public ReadOnly Property Scheduler As C1Scheduler
    Get

See Also

VisualInterval Class


StartTime Property

[image]

.NET Framework Class Library
VisualInterval..::..StartTime Property
VisualInterval Class See Also
Gets a start time of a time range represented by the VisualInterval object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTime StartTime { get; }
Visual Basic
Public ReadOnly Property StartTime As DateTime
    Get

See Also

VisualInterval Class


StartTimeInfo Property

[image]

.NET Framework Class Library
VisualInterval..::..StartTimeInfo Property
VisualInterval Class See Also
Gets a DateTimeInfo object containing auxiliary properties for a usage in XAML that provides additional information for the StartTime property value.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public DateTimeInfo StartTimeInfo { get; }
Visual Basic
Public ReadOnly Property StartTimeInfo As DateTimeInfo
    Get

See Also

VisualInterval Class


StatusBrush Property

[image]

.NET Framework Class Library
VisualInterval..::..StatusBrush Property
VisualInterval Class See Also
Gets the Brush object representing interval availability status. Only honors all-day and multi-day events availability status. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Brush StatusBrush { get; }
Visual Basic
Public ReadOnly Property StatusBrush As Brush
    Get

See Also

VisualInterval Class


TimeScale Property

[image]

.NET Framework Class Library
VisualInterval..::..TimeScale Property
VisualInterval Class See Also
Gets a TimeSpan of a time range represented by the VisualInterval object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public TimeSpan TimeScale { get; }
Visual Basic
Public ReadOnly Property TimeScale As TimeSpan
    Get

See Also

VisualInterval Class


TotalStatusBrush Property

[image]

.NET Framework Class Library
VisualInterval..::..TotalStatusBrush Property
VisualInterval Class See Also
Gets the Brush object representing interval availability status. Honors status of all appointments in the interval. This is a dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Brush TotalStatusBrush { get; }
Visual Basic
Public ReadOnly Property TotalStatusBrush As Brush
    Get

See Also

VisualInterval Class


VisualInterval Events

[image] [image]

.NET Framework Class Library
VisualInterval Events
VisualInterval Class See Also

The VisualInterval type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when property value is changed.

See Also

VisualInterval Class


PropertyChanged Event

[image]

.NET Framework Class Library
VisualInterval..::..PropertyChanged Event
VisualInterval Class See Also
Occurs when property value is changed.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

VisualInterval Class


VisualIntervalCollection Class

[image]

.NET Framework Class Library
VisualIntervalCollection Class
Members See Also
Represents a collection of VisualInterval objects.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DefaultMemberAttribute("Item")]
public class VisualIntervalCollection : DeferrableObservableCollection<VisualInterval>
Visual Basic
<DefaultMemberAttribute("Item")> _
Public Class VisualIntervalCollection _
    Inherits DeferrableObservableCollection(Of VisualInterval)

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' VisualInterval >)>)>
System.Collections.ObjectModel..::..ObservableCollection <(Of <(<' VisualInterval >)>)>
C1.Silverlight.Schedule..::..DeferrableObservableCollection <(Of <(<' VisualInterval >)>)>
C1.Silverlight.Schedule..::..VisualIntervalCollection

See Also

VisualIntervalCollection Members


VisualIntervalCollection Members

[image] [image]

.NET Framework Class Library
VisualIntervalCollection Members
VisualIntervalCollection Class Constructors Methods Properties Events Explicit Interface Implementations See Also

The VisualIntervalCollection type exposes the following members.

Constructors

 | Name | Description
Public method | VisualIntervalCollection |

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Public method | BeginUpdate | Prevents raising events until the EndUpdate()()()() method is called. (Inherited from DeferrableObservableCollection<(Of <(<'T>)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection <(Of <(<' VisualInterval >)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Public method | EndUpdate | Enables raising events. If collection has been changed since the call to the BeginUpdate()()()() method, raises PropertyChanged and CollectionChanged events. (Inherited from DeferrableObservableCollection<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollection <(Of <(<' VisualInterval >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Overrides the default behavior. (Inherited from DeferrableObservableCollection<(Of <(<'T>)>)>.)
Protected method | OnPropertyChanged | Overrides the default behavior. (Inherited from DeferrableObservableCollection<(Of <(<'T>)>)>.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection <(Of <(<' VisualInterval >)>)>.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollection <(Of <(<' VisualInterval >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Public property | InUpdate | Gets a Boolean value determining whether the DeferrableObservableCollection<(Of <(<'T>)>)> is in update mode (BeginUpdate()()()() has been called). (Inherited from DeferrableObservableCollection<(Of <(<'T>)>)>.)
Public property | Item[([( DateTime])]) | Gets a VisualInterval that includes the specified DateTime.
Public property | Item[([( Int32])]) | Gets a VisualInterval object at the specified index.
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)

Events

 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection <(Of <(<' VisualInterval >)>)>.)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection <(Of <(<' VisualInterval >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection <(Of <(<' VisualInterval >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)

See Also

VisualIntervalCollection Class


VisualIntervalCollection Constructor

[image]

.NET Framework Class Library
VisualIntervalCollection Constructor
VisualIntervalCollection Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public VisualIntervalCollection()
Visual Basic
Public Sub New

See Also

VisualIntervalCollection Class


VisualIntervalCollection Methods

[image] [image]

.NET Framework Class Library
VisualIntervalCollection Methods
VisualIntervalCollection Class See Also

The VisualIntervalCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Public method | BeginUpdate | Prevents raising events until the EndUpdate()()()() method is called. (Inherited from DeferrableObservableCollection<(Of <(<'T>)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection <(Of <(<' VisualInterval >)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Public method | EndUpdate | Enables raising events. If collection has been changed since the call to the BeginUpdate()()()() method, raises PropertyChanged and CollectionChanged events. (Inherited from DeferrableObservableCollection<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollection <(Of <(<' VisualInterval >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Overrides the default behavior. (Inherited from DeferrableObservableCollection<(Of <(<'T>)>)>.)
Protected method | OnPropertyChanged | Overrides the default behavior. (Inherited from DeferrableObservableCollection<(Of <(<'T>)>)>.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection <(Of <(<' VisualInterval >)>)>.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollection <(Of <(<' VisualInterval >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..Add | Adds an item to the IList. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Explicit interface implemetation | IList..::..Contains | Determines whether the IList contains a specific value. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Explicit interface implemetation | ICollection..::..CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Explicit interface implemetation | IEnumerable..::..GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Explicit interface implemetation | IList..::..IndexOf | Determines the index of a specific item in the IList. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Explicit interface implemetation | IList..::..Insert | Inserts an item into the IList at the specified index. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Explicit interface implemetation | IList..::..Remove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)

See Also

VisualIntervalCollection Class


VisualIntervalCollection Properties

[image] [image]

.NET Framework Class Library
VisualIntervalCollection Properties
VisualIntervalCollection Class See Also

The VisualIntervalCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Public property | InUpdate | Gets a Boolean value determining whether the DeferrableObservableCollection<(Of <(<'T>)>)> is in update mode (BeginUpdate()()()() has been called). (Inherited from DeferrableObservableCollection<(Of <(<'T>)>)>.)
Public property | Item[([( DateTime])]) | Gets a VisualInterval that includes the specified DateTime.
Public property | Item[([( Int32])]) | Gets a VisualInterval object at the specified index.
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | IList..::..IsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Explicit interface implemetation | ICollection<(Of <<'(T>)>>)..::..IsReadOnly | (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Explicit interface implemetation | IList..::..IsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Explicit interface implemetation | ICollection..::..IsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Explicit interface implemetation | IList..::..Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)
Explicit interface implemetation | ICollection..::..SyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection <(Of <(<' VisualInterval >)>)>.)

See Also

VisualIntervalCollection Class


Item Property

[image] [image]

.NET Framework Class Library
VisualIntervalCollection..::..Item Property
VisualIntervalCollection Class See Also

Overload List

 | Name | Description
Public property | Item[([( DateTime])]) | Gets a VisualInterval that includes the specified DateTime.
Public property | Item[([( Int32])]) | Gets a VisualInterval object at the specified index.

See Also

VisualIntervalCollection Class
VisualIntervalCollection Members


Item Property (DateTime)

[image]

.NET Framework Class Library
VisualIntervalCollection..::..Item Property (DateTime)
VisualIntervalCollection Class See Also
Gets a VisualInterval that includes the specified DateTime.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public VisualInterval this[
    DateTime time
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    time As DateTime _
) As VisualInterval
    Get

Parameters

time
Type: System..::..DateTime
DateTime for which a VisualInterval to find.

Return Value

Returns a VisualInterval that includes the specified DateTime, if exists; otherwise, a null value.

Remarks

A DateTime is considered as belonging to a VisualInterval if the following condition is satisfied:

StartTime <= DateTime and DateTime > EndTime

Note that the bottom boundary of the interval is exclusive, that is DateTime = EndTime is considered as not belonging to the interval.

See Also

VisualIntervalCollection Class
Item Overload


Item Property (Int32)

[image]

.NET Framework Class Library
VisualIntervalCollection..::..Item Property (Int32)
VisualIntervalCollection Class See Also
Gets a VisualInterval object at the specified index.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public VisualInterval this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    index As Integer _
) As VisualInterval
    Get

Parameters

index
Type: System..::..Int32

See Also

VisualIntervalCollection Class
Item Overload


VisualIntervalCollection Events

[image] [image]

.NET Framework Class Library
VisualIntervalCollection Events
VisualIntervalCollection Class See Also

The VisualIntervalCollection type exposes the following members.

Events

 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection <(Of <(<' VisualInterval >)>)>.)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection <(Of <(<' VisualInterval >)>)>.)

Explicit Interface Implementations

 | Name | Description
Explicit interface implemetation | INotifyPropertyChanged..::..PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection <(Of <(<' VisualInterval >)>)>.)

See Also

VisualIntervalCollection Class


VisualIntervalGroup Class

[image]

.NET Framework Class Library
VisualIntervalGroup Class
Members See Also
Instances of this class appear as DataContext for the C1Scheduler group headers defined in the VisualIntervalGroupStyles collection.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class VisualIntervalGroup : VisualInterval
Visual Basic
Public Class VisualIntervalGroup _
    Inherits VisualInterval

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
C1.Silverlight.Schedule..::..VisualInterval
C1.Silverlight.Schedule..::..VisualIntervalGroup

See Also

VisualIntervalGroup Members


VisualIntervalGroup Members

[image] [image]

.NET Framework Class Library
VisualIntervalGroup Members
VisualIntervalGroup Class Methods Fields Properties Events See Also

The VisualIntervalGroup type exposes the following members.

Methods

 | Name | Description
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ContainsTime | Gets a value indicating whether the specified DateTime belongs to the time range represented by the VisualInterval. (Inherited from VisualInterval.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _isDisposed | (Inherited from VisualInterval.)
Protected field | _scheduler | (Inherited from VisualInterval.)

Properties

 | Name | Description
Public property | Appointments | Gets a collection of IntervalAppointment objects representing appointments whose time range is intersected with the time range of this VisualInterval. (Inherited from VisualInterval.)
Public property | Culture | Gets a CultureInfo. (Inherited from VisualInterval.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | EndTime | Gets an end time of a time range represented by the VisualInterval object. (Inherited from VisualInterval.)
Public property | EndTimeInfo | Gets a DateTimeInfo object containing auxiliary properties for a usage in XAML that provides additional information for the EndTime property value. (Inherited from VisualInterval.)
Public property | Group | Gets a CollectionViewGroup object representing a group item.
Public property | InclusiveEndTime | Gets an inclusive end time of a time range represented by the VisualInterval object. (Inherited from VisualInterval.)
Public property | InclusiveEndTimeInfo | Gets a DateTimeInfo object containing auxiliary properties for a usage in XAML that provides additional information for the EndTimeInfo property value. (Inherited from VisualInterval.)
Public property | Index | Gets an index of VisualInterval in the owning VisualIntervals collection. (Inherited from VisualInterval.)
Public property | IsSelected | Gets or sets a value that determines whether the UI element that has this VisualInterval as a DataContext is selected. This is a dependency property. (Inherited from VisualInterval.)
Public property | Items | Gets a Items property. (Overrides VisualInterval..::..Items.)
Public property | OwnerGroup | Gets the owning SchedulerGroupItem object. (Inherited from VisualInterval.)
Public property | Scheduler | Gets the Scheduler that VisualInterval belongs to. (Inherited from VisualInterval.)
Public property | StartTime | Gets a start time of a time range represented by the VisualInterval object. (Inherited from VisualInterval.)
Public property | StartTimeInfo | Gets a DateTimeInfo object containing auxiliary properties for a usage in XAML that provides additional information for the StartTime property value. (Inherited from VisualInterval.)
Public property | StatusBrush | Gets the Brush object representing interval availability status. Only honors all-day and multi-day events availability status. This is a dependency property. (Inherited from VisualInterval.)
Public property | TimeScale | Gets a TimeSpan of a time range represented by the VisualInterval object. (Inherited from VisualInterval.)
Public property | TotalStatusBrush | Gets the Brush object representing interval availability status. Honors status of all appointments in the interval. This is a dependency property. (Inherited from VisualInterval.)
Public property | VisualIntervals | Gets a collection of child VisualInterval objects.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when property value is changed. (Inherited from VisualInterval.)

See Also

VisualIntervalGroup Class


VisualIntervalGroup Fields

[image] [image]

.NET Framework Class Library
VisualIntervalGroup Fields
VisualIntervalGroup Class See Also

The VisualIntervalGroup type exposes the following members.

Fields

 | Name | Description
Protected field | _isDisposed | (Inherited from VisualInterval.)
Protected field | _scheduler | (Inherited from VisualInterval.)

See Also

VisualIntervalGroup Class


VisualIntervalGroup Methods

[image] [image]

.NET Framework Class Library
VisualIntervalGroup Methods
VisualIntervalGroup Class See Also

The VisualIntervalGroup type exposes the following members.

Methods

 | Name | Description
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ContainsTime | Gets a value indicating whether the specified DateTime belongs to the time range represented by the VisualInterval. (Inherited from VisualInterval.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VisualIntervalGroup Class


VisualIntervalGroup Properties

[image] [image]

.NET Framework Class Library
VisualIntervalGroup Properties
VisualIntervalGroup Class See Also

The VisualIntervalGroup type exposes the following members.

Properties

 | Name | Description
Public property | Appointments | Gets a collection of IntervalAppointment objects representing appointments whose time range is intersected with the time range of this VisualInterval. (Inherited from VisualInterval.)
Public property | Culture | Gets a CultureInfo. (Inherited from VisualInterval.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | EndTime | Gets an end time of a time range represented by the VisualInterval object. (Inherited from VisualInterval.)
Public property | EndTimeInfo | Gets a DateTimeInfo object containing auxiliary properties for a usage in XAML that provides additional information for the EndTime property value. (Inherited from VisualInterval.)
Public property | Group | Gets a CollectionViewGroup object representing a group item.
Public property | InclusiveEndTime | Gets an inclusive end time of a time range represented by the VisualInterval object. (Inherited from VisualInterval.)
Public property | InclusiveEndTimeInfo | Gets a DateTimeInfo object containing auxiliary properties for a usage in XAML that provides additional information for the EndTimeInfo property value. (Inherited from VisualInterval.)
Public property | Index | Gets an index of VisualInterval in the owning VisualIntervals collection. (Inherited from VisualInterval.)
Public property | IsSelected | Gets or sets a value that determines whether the UI element that has this VisualInterval as a DataContext is selected. This is a dependency property. (Inherited from VisualInterval.)
Public property | Items | Gets a Items property. (Overrides VisualInterval..::..Items.)
Public property | OwnerGroup | Gets the owning SchedulerGroupItem object. (Inherited from VisualInterval.)
Public property | Scheduler | Gets the Scheduler that VisualInterval belongs to. (Inherited from VisualInterval.)
Public property | StartTime | Gets a start time of a time range represented by the VisualInterval object. (Inherited from VisualInterval.)
Public property | StartTimeInfo | Gets a DateTimeInfo object containing auxiliary properties for a usage in XAML that provides additional information for the StartTime property value. (Inherited from VisualInterval.)
Public property | StatusBrush | Gets the Brush object representing interval availability status. Only honors all-day and multi-day events availability status. This is a dependency property. (Inherited from VisualInterval.)
Public property | TimeScale | Gets a TimeSpan of a time range represented by the VisualInterval object. (Inherited from VisualInterval.)
Public property | TotalStatusBrush | Gets the Brush object representing interval availability status. Honors status of all appointments in the interval. This is a dependency property. (Inherited from VisualInterval.)
Public property | VisualIntervals | Gets a collection of child VisualInterval objects.

See Also

VisualIntervalGroup Class


Group Property

[image]

.NET Framework Class Library
VisualIntervalGroup..::..Group Property
VisualIntervalGroup Class See Also
Gets a CollectionViewGroup object representing a group item.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public CollectionViewGroup Group { get; }
Visual Basic
Public ReadOnly Property Group As CollectionViewGroup
    Get

See Also

VisualIntervalGroup Class


Items Property

[image]

.NET Framework Class Library
VisualIntervalGroup..::..Items Property
VisualIntervalGroup Class See Also
Gets a Items property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override ReadOnlyObservableCollection Items { get; }
Visual Basic
Public Overrides ReadOnly Property Items As ReadOnlyObservableCollection
    Get

See Also

VisualIntervalGroup Class


VisualIntervals Property

[image]

.NET Framework Class Library
VisualIntervalGroup..::..VisualIntervals Property
VisualIntervalGroup Class See Also
Gets a collection of child VisualInterval objects.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public VisualIntervalCollection VisualIntervals { get; }
Visual Basic
Public ReadOnly Property VisualIntervals As VisualIntervalCollection
    Get

See Also

VisualIntervalGroup Class


VisualIntervalGroup Events

[image] [image]

.NET Framework Class Library
VisualIntervalGroup Events
VisualIntervalGroup Class See Also

The VisualIntervalGroup type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when property value is changed. (Inherited from VisualInterval.)

See Also

VisualIntervalGroup Class


VisualIntervalGroupDescription Class

[image]

.NET Framework Class Library
VisualIntervalGroupDescription Class
Members See Also
Represents a grouping criteria for a collection of VisualInterval objects.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class VisualIntervalGroupDescription : GroupDescription
Visual Basic
Public Class VisualIntervalGroupDescription _
    Inherits GroupDescription

Inheritance Hierarchy

System.ComponentModel..::..GroupDescription
C1.Silverlight.Schedule..::..VisualIntervalGroupDescription

See Also

VisualIntervalGroupDescription Members


VisualIntervalGroupDescription Members

[image] [image]

.NET Framework Class Library
VisualIntervalGroupDescription Members
VisualIntervalGroupDescription Class Constructors Methods Properties See Also

The VisualIntervalGroupDescription type exposes the following members.

Constructors

 | Name | Description
Public method | VisualIntervalGroupDescription | Creates a VisualIntervalGroupDescription instance.

Methods

 | Name | Description
Public method | GroupNameFromItem | Overrides the behavior of the GroupDescription.GroupNameFromItem method.
Public method | NamesMatch | Overrides the behavior of the GroupDescription.NamesMatch method.

Properties

 | Name | Description
Public property | PropertyName | Gets or sets a property path defining a group.

See Also

VisualIntervalGroupDescription Class


VisualIntervalGroupDescription Constructor

[image]

.NET Framework Class Library
VisualIntervalGroupDescription Constructor
VisualIntervalGroupDescription Class See Also
Creates a VisualIntervalGroupDescription instance.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public VisualIntervalGroupDescription()
Visual Basic
Public Sub New

See Also

VisualIntervalGroupDescription Class


VisualIntervalGroupDescription Methods

[image] [image]

.NET Framework Class Library
VisualIntervalGroupDescription Methods
VisualIntervalGroupDescription Class See Also

The VisualIntervalGroupDescription type exposes the following members.

Methods

 | Name | Description
Public method | GroupNameFromItem | Overrides the behavior of the GroupDescription.GroupNameFromItem method.
Public method | NamesMatch | Overrides the behavior of the GroupDescription.NamesMatch method.

See Also

VisualIntervalGroupDescription Class


GroupNameFromItem Method

[image]

.NET Framework Class Library
VisualIntervalGroupDescription..::..GroupNameFromItem Method
VisualIntervalGroupDescription Class See Also
Overrides the behavior of the GroupDescription.GroupNameFromItem method.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual Object GroupNameFromItem(
    Object item,
    int level,
    CultureInfo culture
)
Visual Basic
Public Overridable Function GroupNameFromItem ( _
    item As Object, _
    level As Integer, _
    culture As CultureInfo _
) As Object

Parameters

item
Type: System..::..Object
level
Type: System..::..Int32
culture
Type: System.Globalization..::..CultureInfo

See Also

VisualIntervalGroupDescription Class


NamesMatch Method

[image]

.NET Framework Class Library
VisualIntervalGroupDescription..::..NamesMatch Method
VisualIntervalGroupDescription Class See Also
Overrides the behavior of the GroupDescription.NamesMatch method.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public virtual bool NamesMatch(
    Object groupName,
    Object itemName
)
Visual Basic
Public Overridable Function NamesMatch ( _
    groupName As Object, _
    itemName As Object _
) As Boolean

Parameters

groupName
Type: System..::..Object
itemName
Type: System..::..Object

Return Value

See Also

VisualIntervalGroupDescription Class


VisualIntervalGroupDescription Properties

[image] [image]

.NET Framework Class Library
VisualIntervalGroupDescription Properties
VisualIntervalGroupDescription Class See Also

The VisualIntervalGroupDescription type exposes the following members.

Properties

 | Name | Description
Public property | PropertyName | Gets or sets a property path defining a group.

See Also

VisualIntervalGroupDescription Class


PropertyName Property

[image]

.NET Framework Class Library
VisualIntervalGroupDescription..::..PropertyName Property
VisualIntervalGroupDescription Class See Also
Gets or sets a property path defining a group.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public string PropertyName { get; set; }
Visual Basic
Public Property PropertyName As String
    Get
    Set

Remarks

This property value can be defined in XAML as a string with property path.

See Also

VisualIntervalGroupDescription Class


VisualIntervalGroupsPresenter Class

[image]

.NET Framework Class Library
VisualIntervalGroupsPresenter Class
Members See Also
The VisualIntervalGroupsPresenter class is a listbox representing the collection of VisualIntervalGroup objects. This class implements selection logic for all-day areas in Day View, WorkWeek View and Office 2007 Week View modes.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class VisualIntervalGroupsPresenter : VisualIntervalsPresenter,
    ICollectionChangedListener
Visual Basic
Public Class VisualIntervalGroupsPresenter _
    Inherits VisualIntervalsPresenter _
    Implements ICollectionChangedListener

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ItemsControl
System.Windows.Controls.Primitives..::..Selector
System.Windows.Controls..::..ListBox
C1.Silverlight.Schedule..::..GroupedListBox
C1.Silverlight.Schedule..::..VisualIntervalsPresenter
C1.Silverlight.Schedule..::..VisualIntervalGroupsPresenter

See Also

VisualIntervalGroupsPresenter Members


VisualIntervalGroupsPresenter Members

[image] [image]

.NET Framework Class Library
VisualIntervalGroupsPresenter Members
VisualIntervalGroupsPresenter Class Constructors Methods Fields Properties Events See Also

The VisualIntervalGroupsPresenter type exposes the following members.

Constructors

 | Name | Description
Public method | VisualIntervalGroupsPresenter |

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | AttachSchedulerEvents | Attaches presenter to the C1Scheduler control. (Overrides VisualIntervalsPresenter..::..AttachSchedulerEvents()()()().)
Protected method | AttachToScheduler | Attaches presenter to the C1Scheduler control. (Inherited from VisualIntervalsPresenter.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Protected method | ClearContainerForItemOverride | (Inherited from Selector.)
Protected method | ClearSelection | Clears selection. (Inherited from VisualIntervalsPresenter.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Protected method | DetachEvents | (Inherited from VisualIntervalsPresenter.)
Protected method | DetachFromScheduler | Detaches presenter from the specified C1Scheduler control. (Overrides VisualIntervalsPresenter..::..DetachFromScheduler(C1Scheduler).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Inherited from VisualIntervalsPresenter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetIndexForListBoxItem | Returns the index to an item that corresponds to the specified, generated container element. (Inherited from GroupedListBox.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | HandleItemSelection | (Inherited from VisualIntervalsPresenter.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Protected method | IsAboutToDispose | Override this method in derived classes and return true when control should stop handle selection. (Inherited from VisualIntervalsPresenter.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ListBox.)
Protected method | MakeRangeSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Protected method | MakeSingleSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Protected method | MakeToggleSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | (Inherited from VisualIntervalsPresenter.)
Public method | OnCollectionChanged | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBox.)
Protected method | OnGotFocus | (Inherited from ListBox.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnKeyDown | (Inherited from GroupedListBox.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from ListBox.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | (Inherited from GroupedListBox.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Protected method | SelectItems | Selects all items from time interval determined by the specified start and end values. (Inherited from VisualIntervalsPresenter.)
Protected method | SelectRange | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Protected method | SelectSingleItem | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Protected method | SetFocusedItem | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from GroupedListBox.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Protected method | UpdateSelection | Updates selection. (Overrides VisualIntervalsPresenter..::..UpdateSelection()()()().)

Fields

 | Name | Description
Protected field | _anchor | (Inherited from GroupedListBox.)
Protected field | _prevScheduler | (Inherited from VisualIntervalsPresenter.)
Protected field | _selectedItems | (Inherited from GroupedListBox.)
Protected field | _updatingSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from GroupedListBox.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. This is a dependency property. (Inherited from GroupedListBox.)
Public property | HasItems | Gets a value that indicates whether the GroupedListBox contains items. This is a dependency property. (Inherited from GroupedListBox.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. This is a dependency property. (Inherited from GroupedListBox.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from GroupedListBox.)
Public property | ItemContainerStyle | (Inherited from ListBox.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. This is a dependency property. (Inherited from GroupedListBox.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. This is a dependency property. (Inherited from GroupedListBox.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Owner | Gets the BaseObject object representing the SchedulerGroupItem object owner. This property can be null for an empty group item. (Inherited from VisualIntervalsPresenter.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | PanelTemplate | Gets or sets the DataTemplate that defines the panel that controls the layout of items. This is a dependency property. (Inherited from GroupedListBox.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Scheduler | References a C1Scheduler control that owns the VisualIntervalsPresenter. (Inherited from VisualIntervalsPresenter.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty This is a dependency property. (Inherited from Selector.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

VisualIntervalGroupsPresenter Class


VisualIntervalGroupsPresenter Constructor

[image]

.NET Framework Class Library
VisualIntervalGroupsPresenter Constructor
VisualIntervalGroupsPresenter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public VisualIntervalGroupsPresenter()
Visual Basic
Public Sub New

See Also

VisualIntervalGroupsPresenter Class


VisualIntervalGroupsPresenter Fields

[image] [image]

.NET Framework Class Library
VisualIntervalGroupsPresenter Fields
VisualIntervalGroupsPresenter Class See Also

The VisualIntervalGroupsPresenter type exposes the following members.

Fields

 | Name | Description
Protected field | _anchor | (Inherited from GroupedListBox.)
Protected field | _prevScheduler | (Inherited from VisualIntervalsPresenter.)
Protected field | _selectedItems | (Inherited from GroupedListBox.)
Protected field | _updatingSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)

See Also

VisualIntervalGroupsPresenter Class


VisualIntervalGroupsPresenter Methods

[image] [image]

.NET Framework Class Library
VisualIntervalGroupsPresenter Methods
VisualIntervalGroupsPresenter Class See Also

The VisualIntervalGroupsPresenter type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | AttachSchedulerEvents | Attaches presenter to the C1Scheduler control. (Overrides VisualIntervalsPresenter..::..AttachSchedulerEvents()()()().)
Protected method | AttachToScheduler | Attaches presenter to the C1Scheduler control. (Inherited from VisualIntervalsPresenter.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Protected method | ClearContainerForItemOverride | (Inherited from Selector.)
Protected method | ClearSelection | Clears selection. (Inherited from VisualIntervalsPresenter.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Protected method | DetachEvents | (Inherited from VisualIntervalsPresenter.)
Protected method | DetachFromScheduler | Detaches presenter from the specified C1Scheduler control. (Overrides VisualIntervalsPresenter..::..DetachFromScheduler(C1Scheduler).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Inherited from VisualIntervalsPresenter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetIndexForListBoxItem | Returns the index to an item that corresponds to the specified, generated container element. (Inherited from GroupedListBox.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | HandleItemSelection | (Inherited from VisualIntervalsPresenter.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Protected method | IsAboutToDispose | Override this method in derived classes and return true when control should stop handle selection. (Inherited from VisualIntervalsPresenter.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ListBox.)
Protected method | MakeRangeSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Protected method | MakeSingleSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Protected method | MakeToggleSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | (Inherited from VisualIntervalsPresenter.)
Public method | OnCollectionChanged | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBox.)
Protected method | OnGotFocus | (Inherited from ListBox.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnKeyDown | (Inherited from GroupedListBox.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from ListBox.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | (Inherited from GroupedListBox.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Protected method | SelectItems | Selects all items from time interval determined by the specified start and end values. (Inherited from VisualIntervalsPresenter.)
Protected method | SelectRange | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Protected method | SelectSingleItem | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Protected method | SetFocusedItem | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from GroupedListBox.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Protected method | UpdateSelection | Updates selection. (Overrides VisualIntervalsPresenter..::..UpdateSelection()()()().)

See Also

VisualIntervalGroupsPresenter Class


AttachSchedulerEvents Method

[image]

.NET Framework Class Library
VisualIntervalGroupsPresenter..::..AttachSchedulerEvents Method
VisualIntervalGroupsPresenter Class See Also
Attaches presenter to the C1Scheduler control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void AttachSchedulerEvents()
Visual Basic
Protected Overrides Sub AttachSchedulerEvents

See Also

VisualIntervalGroupsPresenter Class


DetachFromScheduler Method

[image]

.NET Framework Class Library
VisualIntervalGroupsPresenter..::..DetachFromScheduler Method
VisualIntervalGroupsPresenter Class See Also
Detaches presenter from the specified C1Scheduler control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void DetachFromScheduler(
    C1Scheduler scheduler
)
Visual Basic
Protected Overrides Sub DetachFromScheduler ( _
    scheduler As C1Scheduler _
)

Parameters

scheduler
Type: C1.Silverlight.Schedule..::..C1Scheduler

See Also

VisualIntervalGroupsPresenter Class


UpdateSelection Method

[image]

.NET Framework Class Library
VisualIntervalGroupsPresenter..::..UpdateSelection Method
VisualIntervalGroupsPresenter Class See Also
Updates selection.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void UpdateSelection()
Visual Basic
Protected Overrides Sub UpdateSelection

See Also

VisualIntervalGroupsPresenter Class


VisualIntervalGroupsPresenter Properties

[image] [image]

.NET Framework Class Library
VisualIntervalGroupsPresenter Properties
VisualIntervalGroupsPresenter Class See Also

The VisualIntervalGroupsPresenter type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from GroupedListBox.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. This is a dependency property. (Inherited from GroupedListBox.)
Public property | HasItems | Gets a value that indicates whether the GroupedListBox contains items. This is a dependency property. (Inherited from GroupedListBox.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. This is a dependency property. (Inherited from GroupedListBox.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from GroupedListBox.)
Public property | ItemContainerStyle | (Inherited from ListBox.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. This is a dependency property. (Inherited from GroupedListBox.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. This is a dependency property. (Inherited from GroupedListBox.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Owner | Gets the BaseObject object representing the SchedulerGroupItem object owner. This property can be null for an empty group item. (Inherited from VisualIntervalsPresenter.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | PanelTemplate | Gets or sets the DataTemplate that defines the panel that controls the layout of items. This is a dependency property. (Inherited from GroupedListBox.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Scheduler | References a C1Scheduler control that owns the VisualIntervalsPresenter. (Inherited from VisualIntervalsPresenter.)
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty This is a dependency property. (Inherited from Selector.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

VisualIntervalGroupsPresenter Class


VisualIntervalGroupsPresenter Events

[image] [image]

.NET Framework Class Library
VisualIntervalGroupsPresenter Events
VisualIntervalGroupsPresenter Class See Also

The VisualIntervalGroupsPresenter type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

VisualIntervalGroupsPresenter Class


VisualIntervalPresenter Class

[image]

.NET Framework Class Library
VisualIntervalPresenter Class
Members See Also
Represents a selectable item in a VisualIntervalsPresenter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class VisualIntervalPresenter : C1ListBoxItem
Visual Basic
Public Class VisualIntervalPresenter _
    Inherits C1ListBoxItem

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ContentControl
System.Windows.Controls..::..ListBoxItem
C1.Silverlight.Schedule..::..C1ListBoxItem
C1.Silverlight.Schedule..::..VisualIntervalPresenter

See Also

VisualIntervalPresenter Members


VisualIntervalPresenter Members

[image] [image]

.NET Framework Class Library
VisualIntervalPresenter Members
VisualIntervalPresenter Class Constructors Methods Properties Events See Also

The VisualIntervalPresenter type exposes the following members.

Constructors

 | Name | Description
Public method | VisualIntervalPresenter | Initializes a new instance of the VisualIntervalPresenter class.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | (Inherited from ListBoxItem.)
Protected method | OnContentChanged | (Inherited from C1ListBoxItem.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxItemAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBoxItem.)
Protected method | OnGotFocus | (Inherited from ListBoxItem.)
Protected method | OnKeyDown | (Overrides ControlOnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from ListBoxItem.)
Protected method | OnMouseEnter | Called when the mouse enters a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeave | Called when the mouse leaves a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeftButtonDown | (Inherited from C1ListBoxItem.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Interval | Gets a VisualInterval object representing the content of the VisualIntervalPresenter object.
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets a value that indicates whether a ListBoxItem is selected. This is a dependency property. (Inherited from ListBoxItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Owner | Gets the reference to the owning GroupedListBox control. (Inherited from C1ListBoxItem.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

VisualIntervalPresenter Class


VisualIntervalPresenter Constructor

[image]

.NET Framework Class Library
VisualIntervalPresenter Constructor
VisualIntervalPresenter Class See Also
Initializes a new instance of the VisualIntervalPresenter class.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public VisualIntervalPresenter()
Visual Basic
Public Sub New

See Also

VisualIntervalPresenter Class


VisualIntervalPresenter Methods

[image] [image]

.NET Framework Class Library
VisualIntervalPresenter Methods
VisualIntervalPresenter Class See Also

The VisualIntervalPresenter type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | (Inherited from ListBoxItem.)
Protected method | OnContentChanged | (Inherited from C1ListBoxItem.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxItemAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBoxItem.)
Protected method | OnGotFocus | (Inherited from ListBoxItem.)
Protected method | OnKeyDown | (Overrides ControlOnKeyDown(KeyEventArgs).)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from ListBoxItem.)
Protected method | OnMouseEnter | Called when the mouse enters a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeave | Called when the mouse leaves a ListBoxItem. (Inherited from ListBoxItem.)
Protected method | OnMouseLeftButtonDown | (Inherited from C1ListBoxItem.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

VisualIntervalPresenter Class


OnKeyDown Method

[image]

.NET Framework Class Library
VisualIntervalPresenter..::..OnKeyDown Method
VisualIntervalPresenter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)

Parameters

e
Type: System.Windows.Input..::..KeyEventArgs

See Also

VisualIntervalPresenter Class


VisualIntervalPresenter Properties

[image] [image]

.NET Framework Class Library
VisualIntervalPresenter Properties
VisualIntervalPresenter Class See Also

The VisualIntervalPresenter type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Interval | Gets a VisualInterval object representing the content of the VisualIntervalPresenter object.
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets a value that indicates whether a ListBoxItem is selected. This is a dependency property. (Inherited from ListBoxItem.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Owner | Gets the reference to the owning GroupedListBox control. (Inherited from C1ListBoxItem.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

VisualIntervalPresenter Class


Interval Property

[image]

.NET Framework Class Library
VisualIntervalPresenter..::..Interval Property
VisualIntervalPresenter Class See Also
Gets a VisualInterval object representing the content of the VisualIntervalPresenter object.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public VisualInterval Interval { get; }
Visual Basic
Public ReadOnly Property Interval As VisualInterval
    Get

See Also

VisualIntervalPresenter Class


VisualIntervalPresenter Events

[image] [image]

.NET Framework Class Library
VisualIntervalPresenter Events
VisualIntervalPresenter Class See Also

The VisualIntervalPresenter type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

VisualIntervalPresenter Class


VisualIntervalsPresenter Class

[image]

.NET Framework Class Library
VisualIntervalsPresenter Class
Members See Also
The base class for listboxes which should represent the collection of VisualInterval objects.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class VisualIntervalsPresenter : GroupedListBox
Visual Basic
Public Class VisualIntervalsPresenter _
    Inherits GroupedListBox

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ItemsControl
System.Windows.Controls.Primitives..::..Selector
System.Windows.Controls..::..ListBox
C1.Silverlight.Schedule..::..GroupedListBox
C1.Silverlight.Schedule..::..VisualIntervalsPresenter
C1.Silverlight.Schedule..::..C1SchedulerPresenter
C1.Silverlight.Schedule..::..VisualIntervalGroupsPresenter

See Also

VisualIntervalsPresenter Members


VisualIntervalsPresenter Members

[image] [image]

.NET Framework Class Library
VisualIntervalsPresenter Members
VisualIntervalsPresenter Class Constructors Methods Fields Properties Events See Also

The VisualIntervalsPresenter type exposes the following members.

Constructors

 | Name | Description
Public method | VisualIntervalsPresenter | Creates a new instance of VisualIntervalsPresenter.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | AttachSchedulerEvents | Attaches presenter to the C1Scheduler control.
Protected method | AttachToScheduler | Attaches presenter to the C1Scheduler control.
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Protected method | ClearContainerForItemOverride | (Inherited from Selector.)
Protected method | ClearSelection | Clears selection. (Overrides GroupedListBox..::..ClearSelection()()()().)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Protected method | DetachEvents | (Overrides GroupedListBox..::..DetachEvents()()()().)
Protected method | DetachFromScheduler | Detaches presenter from the specified C1Scheduler control.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides GroupedListBox..::..GetContainerForItemOverride()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetIndexForListBoxItem | Returns the index to an item that corresponds to the specified, generated container element. (Inherited from GroupedListBox.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | HandleItemSelection | (Overrides GroupedListBox..::..HandleItemSelection(ListBoxItem, Boolean).)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Protected method | IsAboutToDispose | Override this method in derived classes and return true when control should stop handle selection. (Overrides GroupedListBox..::..IsAboutToDispose()()()().)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ListBox.)
Protected method | MakeRangeSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Protected method | MakeSingleSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Protected method | MakeToggleSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | (Overrides ListBoxOnApplyTemplate()()()().)
Public method | OnCollectionChanged | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBox.)
Protected method | OnGotFocus | (Inherited from ListBox.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnKeyDown | (Inherited from GroupedListBox.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from ListBox.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | (Inherited from GroupedListBox.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Protected method | SelectItems | Selects all items from time interval determined by the specified start and end values.
Protected method | SelectRange | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Protected method | SelectSingleItem | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Protected method | SetFocusedItem | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from GroupedListBox.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Protected method | UpdateSelection | Updates selection.

Fields

 | Name | Description
Protected field | _anchor | (Inherited from GroupedListBox.)
Protected field | _prevScheduler |
Protected field | _selectedItems | (Inherited from GroupedListBox.)
Protected field | _updatingSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
 | OwnerProperty | Identifies the Owner dependency property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from GroupedListBox.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. This is a dependency property. (Inherited from GroupedListBox.)
Public property | HasItems | Gets a value that indicates whether the GroupedListBox contains items. This is a dependency property. (Inherited from GroupedListBox.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. This is a dependency property. (Inherited from GroupedListBox.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from GroupedListBox.)
Public property | ItemContainerStyle | (Inherited from ListBox.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. This is a dependency property. (Inherited from GroupedListBox.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. This is a dependency property. (Inherited from GroupedListBox.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Owner | Gets the BaseObject object representing the SchedulerGroupItem object owner. This property can be null for an empty group item.
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | PanelTemplate | Gets or sets the DataTemplate that defines the panel that controls the layout of items. This is a dependency property. (Inherited from GroupedListBox.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Scheduler | References a C1Scheduler control that owns the VisualIntervalsPresenter.
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty This is a dependency property. (Inherited from Selector.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

VisualIntervalsPresenter Class


VisualIntervalsPresenter Constructor

[image]

.NET Framework Class Library
VisualIntervalsPresenter Constructor
VisualIntervalsPresenter Class See Also
Creates a new instance of VisualIntervalsPresenter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public VisualIntervalsPresenter()
Visual Basic
Public Sub New

See Also

VisualIntervalsPresenter Class


VisualIntervalsPresenter Fields

[image] [image]

.NET Framework Class Library
VisualIntervalsPresenter Fields
VisualIntervalsPresenter Class See Also

The VisualIntervalsPresenter type exposes the following members.

Fields

 | Name | Description
Protected field | _anchor | (Inherited from GroupedListBox.)
Protected field | _prevScheduler |
Protected field | _selectedItems | (Inherited from GroupedListBox.)
Protected field | _updatingSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
 | OwnerProperty | Identifies the Owner dependency property.

See Also

VisualIntervalsPresenter Class


_prevScheduler Field

[image]

.NET Framework Class Library
VisualIntervalsPresenter..::.._prevScheduler Field
VisualIntervalsPresenter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[CLSCompliantAttribute(false)]
protected C1Scheduler _prevScheduler
Visual Basic
<CLSCompliantAttribute(False)> _
Protected _prevScheduler As C1Scheduler

See Also

VisualIntervalsPresenter Class


OwnerProperty Field

[image]

.NET Framework Class Library
VisualIntervalsPresenter..::..OwnerProperty Field
VisualIntervalsPresenter Class See Also
Identifies the Owner dependency property.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly DependencyProperty OwnerProperty
Visual Basic
Public Shared ReadOnly OwnerProperty As DependencyProperty

See Also

VisualIntervalsPresenter Class


VisualIntervalsPresenter Methods

[image] [image]

.NET Framework Class Library
VisualIntervalsPresenter Methods
VisualIntervalsPresenter Class See Also

The VisualIntervalsPresenter type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | AttachSchedulerEvents | Attaches presenter to the C1Scheduler control.
Protected method | AttachToScheduler | Attaches presenter to the C1Scheduler control.
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Protected method | ClearContainerForItemOverride | (Inherited from Selector.)
Protected method | ClearSelection | Clears selection. (Overrides GroupedListBox..::..ClearSelection()()()().)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Protected method | DetachEvents | (Overrides GroupedListBox..::..DetachEvents()()()().)
Protected method | DetachFromScheduler | Detaches presenter from the specified C1Scheduler control.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Protected method | GetContainerForItemOverride | Creates or identifies the element used to display the specified item. (Overrides GroupedListBox..::..GetContainerForItemOverride()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetIndexForListBoxItem | Returns the index to an item that corresponds to the specified, generated container element. (Inherited from GroupedListBox.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | HandleItemSelection | (Overrides GroupedListBox..::..HandleItemSelection(ListBoxItem, Boolean).)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Protected method | IsAboutToDispose | Override this method in derived classes and return true when control should stop handle selection. (Overrides GroupedListBox..::..IsAboutToDispose()()()().)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Inherited from ListBox.)
Protected method | MakeRangeSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Protected method | MakeSingleSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Protected method | MakeToggleSelection | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | (Overrides ListBoxOnApplyTemplate()()()().)
Public method | OnCollectionChanged | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Protected method | OnCreateAutomationPeer | Provides an appropriate ListBoxAutomationPeer implementation for this control, as part of the WPF automation infrastructure. (Inherited from ListBox.)
Protected method | OnGotFocus | (Inherited from ListBox.)
Protected method | OnItemsChanged | Updates the current selection when an item in the Selector has changed (Inherited from Selector.)
Protected method | OnKeyDown | (Inherited from GroupedListBox.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from ListBox.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | (Inherited from GroupedListBox.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ScrollIntoView | Causes the object to scroll into view. (Inherited from ListBox.)
Protected method | SelectItems | Selects all items from time interval determined by the specified start and end values.
Protected method | SelectRange | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Protected method | SelectSingleItem | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Protected method | SetFocusedItem | This API supports the C1.Silverlight infrastructure and is not intended to be used directly from your code. (Inherited from GroupedListBox.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ShouldSerializeGroupStyle | Returns a value that indicates whether serialization processes should serialize the effective value of the GroupStyle property. (Inherited from GroupedListBox.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Protected method | UpdateSelection | Updates selection.

See Also

VisualIntervalsPresenter Class


AttachSchedulerEvents Method

[image]

.NET Framework Class Library
VisualIntervalsPresenter..::..AttachSchedulerEvents Method
VisualIntervalsPresenter Class See Also
Attaches presenter to the C1Scheduler control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void AttachSchedulerEvents()
Visual Basic
Protected Overridable Sub AttachSchedulerEvents

See Also

VisualIntervalsPresenter Class


AttachToScheduler Method

[image]

.NET Framework Class Library
VisualIntervalsPresenter..::..AttachToScheduler Method
VisualIntervalsPresenter Class See Also
Attaches presenter to the C1Scheduler control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected void AttachToScheduler()
Visual Basic
Protected Sub AttachToScheduler

See Also

VisualIntervalsPresenter Class


ClearSelection Method

[image]

.NET Framework Class Library
VisualIntervalsPresenter..::..ClearSelection Method
VisualIntervalsPresenter Class See Also
Clears selection.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void ClearSelection()
Visual Basic
Protected Overrides Sub ClearSelection

See Also

VisualIntervalsPresenter Class


DetachEvents Method

[image]

.NET Framework Class Library
VisualIntervalsPresenter..::..DetachEvents Method
VisualIntervalsPresenter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void DetachEvents()
Visual Basic
Protected Overrides Sub DetachEvents

See Also

VisualIntervalsPresenter Class


DetachFromScheduler Method

[image]

.NET Framework Class Library
VisualIntervalsPresenter..::..DetachFromScheduler Method
VisualIntervalsPresenter Class See Also
Detaches presenter from the specified C1Scheduler control.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void DetachFromScheduler(
    C1Scheduler scheduler
)
Visual Basic
Protected Overridable Sub DetachFromScheduler ( _
    scheduler As C1Scheduler _
)

Parameters

scheduler
Type: C1.Silverlight.Schedule..::..C1Scheduler

See Also

VisualIntervalsPresenter Class


GetContainerForItemOverride Method

[image]

.NET Framework Class Library
VisualIntervalsPresenter..::..GetContainerForItemOverride Method
VisualIntervalsPresenter Class See Also
Creates or identifies the element used to display the specified item.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override DependencyObject GetContainerForItemOverride()
Visual Basic
Protected Overrides Function GetContainerForItemOverride As DependencyObject

Return Value

The new instance of VisualIntervalPresenter class.

See Also

VisualIntervalsPresenter Class


HandleItemSelection Method

[image]

.NET Framework Class Library
VisualIntervalsPresenter..::..HandleItemSelection Method
VisualIntervalsPresenter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override void HandleItemSelection(
    ListBoxItem item,
    bool isMouseSelection
)
Visual Basic
Protected Overrides Sub HandleItemSelection ( _
    item As ListBoxItem, _
    isMouseSelection As Boolean _
)

Parameters

item
Type: System.Windows.Controls..::..ListBoxItem
isMouseSelection
Type: System..::..Boolean

See Also

VisualIntervalsPresenter Class


IsAboutToDispose Method

[image]

.NET Framework Class Library
VisualIntervalsPresenter..::..IsAboutToDispose Method
VisualIntervalsPresenter Class See Also
Override this method in derived classes and return true when control should stop handle selection.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected override bool IsAboutToDispose()
Visual Basic
Protected Overrides Function IsAboutToDispose As Boolean

Return Value

The base implementation always returns false.

See Also

VisualIntervalsPresenter Class


OnApplyTemplate Method

[image]

.NET Framework Class Library
VisualIntervalsPresenter..::..OnApplyTemplate Method
VisualIntervalsPresenter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic
Public Overrides Sub OnApplyTemplate

See Also

VisualIntervalsPresenter Class


SelectItems Method

[image]

.NET Framework Class Library
VisualIntervalsPresenter..::..SelectItems Method
VisualIntervalsPresenter Class See Also
Selects all items from time interval determined by the specified start and end values.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void SelectItems(
    DateTime start,
    DateTime end
)
Visual Basic
Protected Overridable Sub SelectItems ( _
    start As DateTime, _
    end As DateTime _
)

Parameters

start
Type: System..::..DateTime
end
Type: System..::..DateTime

See Also

VisualIntervalsPresenter Class


UpdateSelection Method

[image]

.NET Framework Class Library
VisualIntervalsPresenter..::..UpdateSelection Method
VisualIntervalsPresenter Class See Also
Updates selection.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected virtual void UpdateSelection()
Visual Basic
Protected Overridable Sub UpdateSelection

See Also

VisualIntervalsPresenter Class


VisualIntervalsPresenter Properties

[image] [image]

.NET Framework Class Library
VisualIntervalsPresenter Properties
VisualIntervalsPresenter Class See Also

The VisualIntervalsPresenter type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | GroupStyle | Gets a collection of GroupStyle objects that define the appearance of each level of groups. (Inherited from GroupedListBox.)
Public property | GroupStyleSelector | Gets or sets a method that enables you to provide custom selection logic for a GroupStyle to apply to each group in a collection. This is a dependency property. (Inherited from GroupedListBox.)
Public property | HasItems | Gets a value that indicates whether the GroupedListBox contains items. This is a dependency property. (Inherited from GroupedListBox.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsGrouping | Gets a value that indicates whether the control is using grouping. This is a dependency property. (Inherited from GroupedListBox.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from GroupedListBox.)
Public property | ItemContainerStyle | (Inherited from ListBox.)
Public property | ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. This is a dependency property. (Inherited from GroupedListBox.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemTemplateSelector | Gets or sets the custom logic for choosing a template used to display each item. This is a dependency property. (Inherited from GroupedListBox.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Owner | Gets the BaseObject object representing the SchedulerGroupItem object owner. This property can be null for an empty group item.
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | PanelTemplate | Gets or sets the DataTemplate that defines the panel that controls the layout of items. This is a dependency property. (Inherited from GroupedListBox.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Scheduler | References a C1Scheduler control that owns the VisualIntervalsPresenter.
Public property | SelectedIndex | Gets or sets the index of the first item in the current selection or returns negative one (-1) if the selection is empty. This is a dependency property. (Inherited from Selector.)
Public property | SelectedItem | Gets or sets the first item in the current selection or returns null if the selection is empty This is a dependency property. (Inherited from Selector.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

VisualIntervalsPresenter Class


Owner Property

[image]

.NET Framework Class Library
VisualIntervalsPresenter..::..Owner Property
VisualIntervalsPresenter Class See Also
Gets the BaseObject object representing the SchedulerGroupItem object owner. This property can be null for an empty group item.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public BaseObject Owner { get; set; }
Visual Basic
Public Property Owner As BaseObject
    Get
    Set

See Also

VisualIntervalsPresenter Class


Scheduler Property

[image]

.NET Framework Class Library
VisualIntervalsPresenter..::..Scheduler Property
VisualIntervalsPresenter Class See Also
References a C1Scheduler control that owns the VisualIntervalsPresenter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1Scheduler Scheduler { get; }
Visual Basic
Public ReadOnly Property Scheduler As C1Scheduler
    Get

See Also

VisualIntervalsPresenter Class


VisualIntervalsPresenter Events

[image] [image]

.NET Framework Class Library
VisualIntervalsPresenter Events
VisualIntervalsPresenter Class See Also

The VisualIntervalsPresenter type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | SelectionChanged | Occurs when the selection of a Selector changes. (Inherited from Selector.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)

See Also

VisualIntervalsPresenter Class


VisualIntervalToStringConverter Class

[image]

.NET Framework Class Library
VisualIntervalToStringConverter Class
Members See Also
VisualIntervalToStringConverter converts VisualInterval start time to string using formatting string specified in one of the C1Scheduler properties: - DayViewDayHeaderFormat, - WeekViewDayHeaderFormat, - MonthViewDayHeaderMonthFormat, - MonthViewDayHeaderDayFormat, - MonthViewHeaderFormat. Converter parameter should specify C1Scheduler property name. If converter parameter is null, uses VisualInterval.Culture.DateTimeFormat.ShortDatePattern as formatting string.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class VisualIntervalToStringConverter : IValueConverter
Visual Basic
Public Class VisualIntervalToStringConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..VisualIntervalToStringConverter

See Also

VisualIntervalToStringConverter Members


VisualIntervalToStringConverter Members

[image] [image]

.NET Framework Class Library
VisualIntervalToStringConverter Members
VisualIntervalToStringConverter Class Constructors Methods Fields See Also

The VisualIntervalToStringConverter type exposes the following members.

Constructors

 | Name | Description
Public method | VisualIntervalToStringConverter |

Methods

 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Default | Gets an instance of VisualIntervalToStringConverter.

See Also

VisualIntervalToStringConverter Class


VisualIntervalToStringConverter Constructor

[image]

.NET Framework Class Library
VisualIntervalToStringConverter Constructor
VisualIntervalToStringConverter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public VisualIntervalToStringConverter()
Visual Basic
Public Sub New

See Also

VisualIntervalToStringConverter Class


VisualIntervalToStringConverter Fields

[image] [image]

.NET Framework Class Library
VisualIntervalToStringConverter Fields
VisualIntervalToStringConverter Class See Also

The VisualIntervalToStringConverter type exposes the following members.

Fields

Name | Description
Default | Gets an instance of VisualIntervalToStringConverter.

See Also

VisualIntervalToStringConverter Class


Default Field

[image]

.NET Framework Class Library
VisualIntervalToStringConverter..::..Default Field
VisualIntervalToStringConverter Class See Also
Gets an instance of VisualIntervalToStringConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly VisualIntervalToStringConverter Default
Visual Basic
Public Shared ReadOnly Default As VisualIntervalToStringConverter

See Also

VisualIntervalToStringConverter Class


VisualIntervalToStringConverter Methods

[image] [image]

.NET Framework Class Library
VisualIntervalToStringConverter Methods
VisualIntervalToStringConverter Class See Also

The VisualIntervalToStringConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert |
Public method | ConvertBack |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VisualIntervalToStringConverter Class


Convert Method

[image]

.NET Framework Class Library
VisualIntervalToStringConverter..::..Convert Method
VisualIntervalToStringConverter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
targetType
Type: System..::..Type
parameter
Type: System..::..Object
culture
Type: System.Globalization..::..CultureInfo

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

VisualIntervalToStringConverter Class


ConvertBack Method

[image]

.NET Framework Class Library
VisualIntervalToStringConverter..::..ConvertBack Method
VisualIntervalToStringConverter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
targetType
Type: System..::..Type
parameter
Type: System..::..Object
culture
Type: System.Globalization..::..CultureInfo

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

VisualIntervalToStringConverter Class


WeekDaysEnumToStringConverter Class

[image]

.NET Framework Class Library
WeekDaysEnumToStringConverter Class
Members See Also
Represents a Binding converter that returns a localized string representation of WeekDaysEnum member.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class WeekDaysEnumToStringConverter : IValueConverter
Visual Basic
Public Class WeekDaysEnumToStringConverter _
    Implements IValueConverter

Remarks

WeekDaysEnumToStringConverter is a one-way converter.

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..WeekDaysEnumToStringConverter

See Also

WeekDaysEnumToStringConverter Members


WeekDaysEnumToStringConverter Members

[image] [image]

.NET Framework Class Library
WeekDaysEnumToStringConverter Members
WeekDaysEnumToStringConverter Class Constructors Methods Fields See Also

The WeekDaysEnumToStringConverter type exposes the following members.

Constructors

 | Name | Description
Public method | WeekDaysEnumToStringConverter |

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Throws System.NotImplementedException.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Default | Gets an instance of WeekDaysEnumToStringConverter.

See Also

WeekDaysEnumToStringConverter Class


WeekDaysEnumToStringConverter Constructor

[image]

.NET Framework Class Library
WeekDaysEnumToStringConverter Constructor
WeekDaysEnumToStringConverter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public WeekDaysEnumToStringConverter()
Visual Basic
Public Sub New

See Also

WeekDaysEnumToStringConverter Class


WeekDaysEnumToStringConverter Fields

[image] [image]

.NET Framework Class Library
WeekDaysEnumToStringConverter Fields
WeekDaysEnumToStringConverter Class See Also

The WeekDaysEnumToStringConverter type exposes the following members.

Fields

Name | Description
Default | Gets an instance of WeekDaysEnumToStringConverter.

See Also

WeekDaysEnumToStringConverter Class


Default Field

[image]

.NET Framework Class Library
WeekDaysEnumToStringConverter..::..Default Field
WeekDaysEnumToStringConverter Class See Also
Gets an instance of WeekDaysEnumToStringConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly WeekDaysEnumToStringConverter Default
Visual Basic
Public Shared ReadOnly Default As WeekDaysEnumToStringConverter

See Also

WeekDaysEnumToStringConverter Class


WeekDaysEnumToStringConverter Methods

[image] [image]

.NET Framework Class Library
WeekDaysEnumToStringConverter Methods
WeekDaysEnumToStringConverter Class See Also

The WeekDaysEnumToStringConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Throws System.NotImplementedException.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WeekDaysEnumToStringConverter Class


Convert Method

[image]

.NET Framework Class Library
WeekDaysEnumToStringConverter..::..Convert Method
WeekDaysEnumToStringConverter Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The values produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

WeekDaysEnumToStringConverter Class


ConvertBack Method

[image]

.NET Framework Class Library
WeekDaysEnumToStringConverter..::..ConvertBack Method
WeekDaysEnumToStringConverter Class See Also
Throws System.NotImplementedException.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value that is produced by the binding target.
targetType
Type: System..::..Type
The array of types to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

WeekDaysEnumToStringConverter Class


WeekDaysToIntConverter Class

[image]

.NET Framework Class Library
WeekDaysToIntConverter Class
Members See Also
Represents a Binding converter that converts a WeekDaysEnum value to integer representations.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class WeekDaysToIntConverter : IValueConverter
Visual Basic
Public Class WeekDaysToIntConverter _
    Implements IValueConverter

Remarks

If the WeekDaysEnum value represents a combination of several flags, this converter will throw away extra flags and return an integer value corresponding to the single flag value. Use this converter to receive a valid value of the selected index in comboboxes which use WeekDaysEnum flags as the data source.

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..WeekDaysToIntConverter

See Also

WeekDaysToIntConverter Members


WeekDaysToIntConverter Members

[image] [image]

.NET Framework Class Library
WeekDaysToIntConverter Members
WeekDaysToIntConverter Class Constructors Methods Fields See Also

The WeekDaysToIntConverter type exposes the following members.

Constructors

 | Name | Description
Public method | WeekDaysToIntConverter |

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Default | Gets an instance of WeekDaysToIntConverter.

See Also

WeekDaysToIntConverter Class


WeekDaysToIntConverter Constructor

[image]

.NET Framework Class Library
WeekDaysToIntConverter Constructor
WeekDaysToIntConverter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public WeekDaysToIntConverter()
Visual Basic
Public Sub New

See Also

WeekDaysToIntConverter Class


WeekDaysToIntConverter Fields

[image] [image]

.NET Framework Class Library
WeekDaysToIntConverter Fields
WeekDaysToIntConverter Class See Also

The WeekDaysToIntConverter type exposes the following members.

Fields

Name | Description
Default | Gets an instance of WeekDaysToIntConverter.

See Also

WeekDaysToIntConverter Class


Default Field

[image]

.NET Framework Class Library
WeekDaysToIntConverter..::..Default Field
WeekDaysToIntConverter Class See Also
Gets an instance of WeekDaysToIntConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly WeekDaysToIntConverter Default
Visual Basic
Public Shared ReadOnly Default As WeekDaysToIntConverter

See Also

WeekDaysToIntConverter Class


WeekDaysToIntConverter Methods

[image] [image]

.NET Framework Class Library
WeekDaysToIntConverter Methods
WeekDaysToIntConverter Class See Also

The WeekDaysToIntConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WeekDaysToIntConverter Class


Convert Method

[image]

.NET Framework Class Library
WeekDaysToIntConverter..::..Convert Method
WeekDaysToIntConverter Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

WeekDaysToIntConverter Class


ConvertBack Method

[image]

.NET Framework Class Library
WeekDaysToIntConverter..::..ConvertBack Method
WeekDaysToIntConverter Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding target to the binding source.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value that is produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

WeekDaysToIntConverter Class


WeekOfMonthEnumToStringConverter Class

[image]

.NET Framework Class Library
WeekOfMonthEnumToStringConverter Class
Members See Also
Represents a Binding converter that returns a localized string representation of WeekOfMonthEnum member.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class WeekOfMonthEnumToStringConverter : IValueConverter
Visual Basic
Public Class WeekOfMonthEnumToStringConverter _
    Implements IValueConverter

Remarks

WeekOfMonthEnumToStringConverter is a one-way converter.

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule..::..WeekOfMonthEnumToStringConverter

See Also

WeekOfMonthEnumToStringConverter Members


WeekOfMonthEnumToStringConverter Members

[image] [image]

.NET Framework Class Library
WeekOfMonthEnumToStringConverter Members
WeekOfMonthEnumToStringConverter Class Constructors Methods Fields See Also

The WeekOfMonthEnumToStringConverter type exposes the following members.

Constructors

 | Name | Description
Public method | WeekOfMonthEnumToStringConverter |

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Throws System.NotImplementedException.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Default | Gets an instance of WeekOfMonthEnumToStringConverter.

See Also

WeekOfMonthEnumToStringConverter Class


WeekOfMonthEnumToStringConverter Constructor

[image]

.NET Framework Class Library
WeekOfMonthEnumToStringConverter Constructor
WeekOfMonthEnumToStringConverter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public WeekOfMonthEnumToStringConverter()
Visual Basic
Public Sub New

See Also

WeekOfMonthEnumToStringConverter Class


WeekOfMonthEnumToStringConverter Fields

[image] [image]

.NET Framework Class Library
WeekOfMonthEnumToStringConverter Fields
WeekOfMonthEnumToStringConverter Class See Also

The WeekOfMonthEnumToStringConverter type exposes the following members.

Fields

Name | Description
Default | Gets an instance of WeekOfMonthEnumToStringConverter.

See Also

WeekOfMonthEnumToStringConverter Class


Default Field

[image]

.NET Framework Class Library
WeekOfMonthEnumToStringConverter..::..Default Field
WeekOfMonthEnumToStringConverter Class See Also
Gets an instance of WeekOfMonthEnumToStringConverter.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static readonly WeekOfMonthEnumToStringConverter Default
Visual Basic
Public Shared ReadOnly Default As WeekOfMonthEnumToStringConverter

See Also

WeekOfMonthEnumToStringConverter Class


WeekOfMonthEnumToStringConverter Methods

[image] [image]

.NET Framework Class Library
WeekOfMonthEnumToStringConverter Methods
WeekOfMonthEnumToStringConverter Class See Also

The WeekOfMonthEnumToStringConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.
Public method | ConvertBack | Throws System.NotImplementedException.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WeekOfMonthEnumToStringConverter Class


Convert Method

[image]

.NET Framework Class Library
WeekOfMonthEnumToStringConverter..::..Convert Method
WeekOfMonthEnumToStringConverter Class See Also
Converts a value. The data binding engine calls this method when it propagates a value from the binding source to the binding target.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

WeekOfMonthEnumToStringConverter Class


ConvertBack Method

[image]

.NET Framework Class Library
WeekOfMonthEnumToStringConverter..::..ConvertBack Method
WeekOfMonthEnumToStringConverter Class See Also
Throws System.NotImplementedException.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::..Object
The value that is produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the converter.

Return Value

A converted value.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

WeekOfMonthEnumToStringConverter Class


WorkDaysConverter Class

[image]

.NET Framework Class Library
WorkDaysConverter Class
Members See Also
The WorkDaysConverter provides a type converter to convert WorkDays objects to and from various other representations.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class WorkDaysConverter : TypeConverter
Visual Basic
Public Class WorkDaysConverter _
    Inherits TypeConverter

Inheritance Hierarchy

System..::..Object
System.ComponentModel..::..TypeConverter
C1.Silverlight.Schedule..::..WorkDaysConverter

See Also

WorkDaysConverter Members


WorkDaysConverter Members

[image] [image]

.NET Framework Class Library
WorkDaysConverter Members
WorkDaysConverter Class Constructors Methods See Also

The WorkDaysConverter type exposes the following members.

Constructors

 | Name | Description
Public method | WorkDaysConverter |

Methods

 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverter..::..CanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverter..::..CanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverter..::..ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromString | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverter..::..ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToString | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorkDaysConverter Class


WorkDaysConverter Constructor

[image]

.NET Framework Class Library
WorkDaysConverter Constructor
WorkDaysConverter Class See Also

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public WorkDaysConverter()
Visual Basic
Public Sub New

See Also

WorkDaysConverter Class


WorkDaysConverter Methods

[image] [image]

.NET Framework Class Library
WorkDaysConverter Methods
WorkDaysConverter Class See Also

The WorkDaysConverter type exposes the following members.

Methods

 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverter..::..CanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverter..::..CanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverter..::..ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromString | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverter..::..ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToString | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorkDaysConverter Class


CanConvertFrom Method

[image] [image]

.NET Framework Class Library
WorkDaysConverter..::..CanConvertFrom Method
WorkDaysConverter Class See Also

Overload List

 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverter..::..CanConvertFrom(ITypeDescriptorContext, Type).)

See Also

WorkDaysConverter Class
WorkDaysConverter Members


CanConvertFrom Method (ITypeDescriptorContext, Type)

[image]

.NET Framework Class Library
WorkDaysConverter..::..CanConvertFrom Method (ITypeDescriptorContext, Type)
WorkDaysConverter Class See Also
Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Visual Basic
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
sourceType
Type: System..::..Type
A Type that represents the type you want to convert from.

Return Value

True if this converter can perform the conversion; otherwise, false.

See Also

WorkDaysConverter Class
CanConvertFrom Overload


CanConvertTo Method

[image] [image]

.NET Framework Class Library
WorkDaysConverter..::..CanConvertTo Method
WorkDaysConverter Class See Also

Overload List

 | Name | Description
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverter..::..CanConvertTo(ITypeDescriptorContext, Type).)

See Also

WorkDaysConverter Class
WorkDaysConverter Members


CanConvertTo Method (ITypeDescriptorContext, Type)

[image]

.NET Framework Class Library
WorkDaysConverter..::..CanConvertTo Method (ITypeDescriptorContext, Type)
WorkDaysConverter Class See Also
Returns whether this converter can convert the object to the specified type, using the specified context.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Visual Basic
Public Overrides Function CanConvertTo ( _
    context As ITypeDescriptorContext, _
    destinationType As Type _
) As Boolean

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
destinationType
Type: System..::..Type
A Type that represents the type you want to convert to.

Return Value

True if this converter can perform the conversion; otherwise, false.

See Also

WorkDaysConverter Class
CanConvertTo Overload


ConvertFrom Method

[image] [image]

.NET Framework Class Library
WorkDaysConverter..::..ConvertFrom Method
WorkDaysConverter Class See Also

Overload List

 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverter..::..ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)

See Also

WorkDaysConverter Class
WorkDaysConverter Members


ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

[image]

.NET Framework Class Library
WorkDaysConverter..::..ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)
WorkDaysConverter Class See Also
Converts the given object to the type of this converter, using the specified context and culture information.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Visual Basic
Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object _
) As Object

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.Globalization..::..CultureInfo
The CultureInfo to use as the current culture.
value
Type: System..::..Object
The Object to convert.

Return Value

An Object that represents the converted value.

See Also

WorkDaysConverter Class
ConvertFrom Overload


ConvertTo Method

[image] [image]

.NET Framework Class Library
WorkDaysConverter..::..ConvertTo Method
WorkDaysConverter Class See Also

Overload List

 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverter..::..ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)

See Also

WorkDaysConverter Class
WorkDaysConverter Members


ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

[image]

.NET Framework Class Library
WorkDaysConverter..::..ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)
WorkDaysConverter Class See Also
Converts the given value object to the specified type, using the specified context and culture information.

Namespace: C1.Silverlight.Schedule
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Visual Basic
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.Globalization..::..CultureInfo
The CultureInfo to use as the current culture.
value
Type: System..::..Object
The Object to convert.
destinationType
Type: System..::..Type
A Type that represents the type you want to convert to.

Return Value

An Object that represents the converted value.

See Also

WorkDaysConverter Class
ConvertTo Overload


C1.Silverlight.Schedule.Resources Namespace

[image]

.NET Framework Class Library
C1.Silverlight.Schedule.Resources Namespace

Classes

 | Class | Description
Public class | C1_Schedule_Categories | A strongly-typed resource class, for looking up localized strings, etc.
Public class | C1_Schedule_EditAppointment | A strongly-typed resource class, for looking up localized strings, etc.
Public class | C1_Schedule_EditRecurrence | A strongly-typed resource class, for looking up localized strings, etc.
Public class | C1_Schedule_Exceptions | A strongly-typed resource class, for looking up localized strings, etc.
Public class | C1_Schedule_Labels | A strongly-typed resource class, for looking up localized strings, etc.
Public class | C1_Schedule_MiscStrings | A strongly-typed resource class, for looking up localized strings, etc.
Public class | C1_Schedule_RecChoice | A strongly-typed resource class, for looking up localized strings, etc.
Public class | C1_Schedule_SelectFromListScene | A strongly-typed resource class, for looking up localized strings, etc.
Public class | C1_Schedule_ShowReminders | A strongly-typed resource class, for looking up localized strings, etc.
Public class | C1_Schedule_Statuses | A strongly-typed resource class, for looking up localized strings, etc.
Public class | C1_Schedule_TimeStrings | A strongly-typed resource class, for looking up localized strings, etc.


C1_Schedule_Categories Class

[image]

.NET Framework Class Library
C1_Schedule_Categories Class
Members See Also
A strongly-typed resource class, for looking up localized strings, etc.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[GeneratedCodeAttribute("System.Resources.Tools.StronglyTypedResourceBuilder",
    "2.0.0.0")]
[CompilerGeneratedAttribute]
public class C1_Schedule_Categories
Visual Basic
<GeneratedCodeAttribute("System.Resources.Tools.StronglyTypedResourceBuilder",  _
    "2.0.0.0")> _
<CompilerGeneratedAttribute> _
Public Class C1_Schedule_Categories

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule.Resources..::..C1_Schedule_Categories

See Also

C1_Schedule_Categories Members
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_Categories Members

[image] [image]

.NET Framework Class Library
C1_Schedule_Categories Members
C1_Schedule_Categories Class Constructors Methods Properties See Also

The C1_Schedule_Categories type exposes the following members.

Constructors

 | Name | Description
Public method | C1_Schedule_Categories | Initializes a new instance of the C1_Schedule_Categories class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Business | Looks up a localized string similar to Business.
Competition | Looks up a localized string similar to Competition.
Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
Favorites | Looks up a localized string similar to Favorites.
Gifts | Looks up a localized string similar to Gifts.
Goals | Looks up a localized string similar to Goals/Objectives.
Holiday | Looks up a localized string similar to Holiday.
HolidayCards | Looks up a localized string similar to Holiday Cards.
HotContacts | Looks up a localized string similar to Hot Contacts.
Ideas | Looks up a localized string similar to Ideas.
International | Looks up a localized string similar to International.
KeyCustomer | Looks up a localized string similar to Key Customer.
Miscellanneous | Looks up a localized string similar to Miscellanneous.
Personal | Looks up a localized string similar to Personal.
PhoneCalls | Looks up a localized string similar to Phone Calls.
ResourceManager | Returns the cached ResourceManager instance used by this class.
Status | Looks up a localized string similar to Status.
Strategies | Looks up a localized string similar to Strategies.
Suppliers | Looks up a localized string similar to Suppliers.
Time | Looks up a localized string similar to Time & Expenses.
VIP | Looks up a localized string similar to VIP.
Waiting | Looks up a localized string similar to Waiting.

See Also

C1_Schedule_Categories Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_Categories Constructor

[image]

.NET Framework Class Library
C1_Schedule_Categories Constructor
C1_Schedule_Categories Class See Also
Initializes a new instance of the C1_Schedule_Categories class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1_Schedule_Categories()
Visual Basic
Public Sub New

See Also

C1_Schedule_Categories Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_Categories Methods

[image] [image]

.NET Framework Class Library
C1_Schedule_Categories Methods
C1_Schedule_Categories Class See Also

The C1_Schedule_Categories type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1_Schedule_Categories Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_Categories Properties

[image] [image]

.NET Framework Class Library
C1_Schedule_Categories Properties
C1_Schedule_Categories Class See Also

The C1_Schedule_Categories type exposes the following members.

Properties

Name | Description
Business | Looks up a localized string similar to Business.
Competition | Looks up a localized string similar to Competition.
Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
Favorites | Looks up a localized string similar to Favorites.
Gifts | Looks up a localized string similar to Gifts.
Goals | Looks up a localized string similar to Goals/Objectives.
Holiday | Looks up a localized string similar to Holiday.
HolidayCards | Looks up a localized string similar to Holiday Cards.
HotContacts | Looks up a localized string similar to Hot Contacts.
Ideas | Looks up a localized string similar to Ideas.
International | Looks up a localized string similar to International.
KeyCustomer | Looks up a localized string similar to Key Customer.
Miscellanneous | Looks up a localized string similar to Miscellanneous.
Personal | Looks up a localized string similar to Personal.
PhoneCalls | Looks up a localized string similar to Phone Calls.
ResourceManager | Returns the cached ResourceManager instance used by this class.
Status | Looks up a localized string similar to Status.
Strategies | Looks up a localized string similar to Strategies.
Suppliers | Looks up a localized string similar to Suppliers.
Time | Looks up a localized string similar to Time & Expenses.
VIP | Looks up a localized string similar to VIP.
Waiting | Looks up a localized string similar to Waiting.

See Also

C1_Schedule_Categories Class
C1.Silverlight.Schedule.Resources Namespace


Business Property

[image]

.NET Framework Class Library
C1_Schedule_Categories..::..Business Property
C1_Schedule_Categories Class See Also
Looks up a localized string similar to Business.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Business { get; }
Visual Basic
Public Shared ReadOnly Property Business As String
    Get

See Also

C1_Schedule_Categories Class
C1.Silverlight.Schedule.Resources Namespace


Competition Property

[image]

.NET Framework Class Library
C1_Schedule_Categories..::..Competition Property
C1_Schedule_Categories Class See Also
Looks up a localized string similar to Competition.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Competition { get; }
Visual Basic
Public Shared ReadOnly Property Competition As String
    Get

See Also

C1_Schedule_Categories Class
C1.Silverlight.Schedule.Resources Namespace


Culture Property

[image]

.NET Framework Class Library
C1_Schedule_Categories..::..Culture Property
C1_Schedule_Categories Class See Also
Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public static CultureInfo Culture { get; set; }
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public Shared Property Culture As CultureInfo
    Get
    Set

See Also

C1_Schedule_Categories Class
C1.Silverlight.Schedule.Resources Namespace


Favorites Property

[image]

.NET Framework Class Library
C1_Schedule_Categories..::..Favorites Property
C1_Schedule_Categories Class See Also
Looks up a localized string similar to Favorites.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Favorites { get; }
Visual Basic
Public Shared ReadOnly Property Favorites As String
    Get

See Also

C1_Schedule_Categories Class
C1.Silverlight.Schedule.Resources Namespace


Gifts Property

[image]

.NET Framework Class Library
C1_Schedule_Categories..::..Gifts Property
C1_Schedule_Categories Class See Also
Looks up a localized string similar to Gifts.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Gifts { get; }
Visual Basic
Public Shared ReadOnly Property Gifts As String
    Get

See Also

C1_Schedule_Categories Class
C1.Silverlight.Schedule.Resources Namespace


Goals Property

[image]

.NET Framework Class Library
C1_Schedule_Categories..::..Goals Property
C1_Schedule_Categories Class See Also
Looks up a localized string similar to Goals/Objectives.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Goals { get; }
Visual Basic
Public Shared ReadOnly Property Goals As String
    Get

See Also

C1_Schedule_Categories Class
C1.Silverlight.Schedule.Resources Namespace


Holiday Property

[image]

.NET Framework Class Library
C1_Schedule_Categories..::..Holiday Property
C1_Schedule_Categories Class See Also
Looks up a localized string similar to Holiday.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Holiday { get; }
Visual Basic
Public Shared ReadOnly Property Holiday As String
    Get

See Also

C1_Schedule_Categories Class
C1.Silverlight.Schedule.Resources Namespace


HolidayCards Property

[image]

.NET Framework Class Library
C1_Schedule_Categories..::..HolidayCards Property
C1_Schedule_Categories Class See Also
Looks up a localized string similar to Holiday Cards.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string HolidayCards { get; }
Visual Basic
Public Shared ReadOnly Property HolidayCards As String
    Get

See Also

C1_Schedule_Categories Class
C1.Silverlight.Schedule.Resources Namespace


HotContacts Property

[image]

.NET Framework Class Library
C1_Schedule_Categories..::..HotContacts Property
C1_Schedule_Categories Class See Also
Looks up a localized string similar to Hot Contacts.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string HotContacts { get; }
Visual Basic
Public Shared ReadOnly Property HotContacts As String
    Get

See Also

C1_Schedule_Categories Class
C1.Silverlight.Schedule.Resources Namespace


Ideas Property

[image]

.NET Framework Class Library
C1_Schedule_Categories..::..Ideas Property
C1_Schedule_Categories Class See Also
Looks up a localized string similar to Ideas.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Ideas { get; }
Visual Basic
Public Shared ReadOnly Property Ideas As String
    Get

See Also

C1_Schedule_Categories Class
C1.Silverlight.Schedule.Resources Namespace


International Property

[image]

.NET Framework Class Library
C1_Schedule_Categories..::..International Property
C1_Schedule_Categories Class See Also
Looks up a localized string similar to International.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string International { get; }
Visual Basic
Public Shared ReadOnly Property International As String
    Get

See Also

C1_Schedule_Categories Class
C1.Silverlight.Schedule.Resources Namespace


KeyCustomer Property

[image]

.NET Framework Class Library
C1_Schedule_Categories..::..KeyCustomer Property
C1_Schedule_Categories Class See Also
Looks up a localized string similar to Key Customer.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string KeyCustomer { get; }
Visual Basic
Public Shared ReadOnly Property KeyCustomer As String
    Get

See Also

C1_Schedule_Categories Class
C1.Silverlight.Schedule.Resources Namespace


Miscellanneous Property

[image]

.NET Framework Class Library
C1_Schedule_Categories..::..Miscellanneous Property
C1_Schedule_Categories Class See Also
Looks up a localized string similar to Miscellanneous.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Miscellanneous { get; }
Visual Basic
Public Shared ReadOnly Property Miscellanneous As String
    Get

See Also

C1_Schedule_Categories Class
C1.Silverlight.Schedule.Resources Namespace


Personal Property

[image]

.NET Framework Class Library
C1_Schedule_Categories..::..Personal Property
C1_Schedule_Categories Class See Also
Looks up a localized string similar to Personal.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Personal { get; }
Visual Basic
Public Shared ReadOnly Property Personal As String
    Get

See Also

C1_Schedule_Categories Class
C1.Silverlight.Schedule.Resources Namespace


PhoneCalls Property

[image]

.NET Framework Class Library
C1_Schedule_Categories..::..PhoneCalls Property
C1_Schedule_Categories Class See Also
Looks up a localized string similar to Phone Calls.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string PhoneCalls { get; }
Visual Basic
Public Shared ReadOnly Property PhoneCalls As String
    Get

See Also

C1_Schedule_Categories Class
C1.Silverlight.Schedule.Resources Namespace


ResourceManager Property

[image]

.NET Framework Class Library
C1_Schedule_Categories..::..ResourceManager Property
C1_Schedule_Categories Class See Also
Returns the cached ResourceManager instance used by this class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public static ResourceManager ResourceManager { get; }
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public Shared ReadOnly Property ResourceManager As ResourceManager
    Get

See Also

C1_Schedule_Categories Class
C1.Silverlight.Schedule.Resources Namespace


Status Property

[image]

.NET Framework Class Library
C1_Schedule_Categories..::..Status Property
C1_Schedule_Categories Class See Also
Looks up a localized string similar to Status.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Status { get; }
Visual Basic
Public Shared ReadOnly Property Status As String
    Get

See Also

C1_Schedule_Categories Class
C1.Silverlight.Schedule.Resources Namespace


Strategies Property

[image]

.NET Framework Class Library
C1_Schedule_Categories..::..Strategies Property
C1_Schedule_Categories Class See Also
Looks up a localized string similar to Strategies.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Strategies { get; }
Visual Basic
Public Shared ReadOnly Property Strategies As String
    Get

See Also

C1_Schedule_Categories Class
C1.Silverlight.Schedule.Resources Namespace


Suppliers Property

[image]

.NET Framework Class Library
C1_Schedule_Categories..::..Suppliers Property
C1_Schedule_Categories Class See Also
Looks up a localized string similar to Suppliers.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Suppliers { get; }
Visual Basic
Public Shared ReadOnly Property Suppliers As String
    Get

See Also

C1_Schedule_Categories Class
C1.Silverlight.Schedule.Resources Namespace


Time Property

[image]

.NET Framework Class Library
C1_Schedule_Categories..::..Time Property
C1_Schedule_Categories Class See Also
Looks up a localized string similar to Time & Expenses.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Time { get; }
Visual Basic
Public Shared ReadOnly Property Time As String
    Get

See Also

C1_Schedule_Categories Class
C1.Silverlight.Schedule.Resources Namespace


VIP Property

[image]

.NET Framework Class Library
C1_Schedule_Categories..::..VIP Property
C1_Schedule_Categories Class See Also
Looks up a localized string similar to VIP.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string VIP { get; }
Visual Basic
Public Shared ReadOnly Property VIP As String
    Get

See Also

C1_Schedule_Categories Class
C1.Silverlight.Schedule.Resources Namespace


Waiting Property

[image]

.NET Framework Class Library
C1_Schedule_Categories..::..Waiting Property
C1_Schedule_Categories Class See Also
Looks up a localized string similar to Waiting.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Waiting { get; }
Visual Basic
Public Shared ReadOnly Property Waiting As String
    Get

See Also

C1_Schedule_Categories Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_EditAppointment Class

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment Class
Members See Also
A strongly-typed resource class, for looking up localized strings, etc.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[CompilerGeneratedAttribute]
[GeneratedCodeAttribute("System.Resources.Tools.StronglyTypedResourceBuilder",
    "4.0.0.0")]
public class C1_Schedule_EditAppointment
Visual Basic
<CompilerGeneratedAttribute> _
<GeneratedCodeAttribute("System.Resources.Tools.StronglyTypedResourceBuilder",  _
    "4.0.0.0")> _
Public Class C1_Schedule_EditAppointment

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule.Resources..::..C1_Schedule_EditAppointment

See Also

C1_Schedule_EditAppointment Members
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_EditAppointment Members

[image] [image]

.NET Framework Class Library
C1_Schedule_EditAppointment Members
C1_Schedule_EditAppointment Class Constructors Methods Properties See Also

The C1_Schedule_EditAppointment type exposes the following members.

Constructors

 | Name | Description
Public method | C1_Schedule_EditAppointment | Initializes a new instance of the C1_Schedule_EditAppointment class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
allDayEvent | Looks up a localized string similar to All day event.
Appointment | Looks up a localized string similar to Appointment.
categoriesButton | Looks up a localized string similar to Categories....
categoryLabel | Looks up a localized string similar to Category:.
contactLabel | Looks up a localized string similar to Contact:.
contactsButton | Looks up a localized string similar to Contacts....
Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
deleteButton_ToolTip | Looks up a localized string similar to Delete.
endTime | Looks up a localized string similar to End time:.
Event | Looks up a localized string similar to Event.
highImportance_ToolTip | Looks up a localized string similar to High Importance.
label | Looks up a localized string similar to Label:.
location | Looks up a localized string similar to Location:.
lowImportance_ToolTip | Looks up a localized string similar to Low Importance.
PART_DialogSaveButton_AccessText | Looks up a localized string similar to Save and Close.
PART_DialogSaveButton_Tooltip | Looks up a localized string similar to Save and Close.
private_ | Looks up a localized string similar to Private.
reccButton_AccessText | Looks up a localized string similar to Recurrence....
reccButton_ToolTip | Looks up a localized string similar to Recurrence.
recurrence | Looks up a localized string similar to Recurrence:.
reminderSet | Looks up a localized string similar to Reminder:.
resourceLabel | Looks up a localized string similar to Resource:.
ResourceManager | Returns the cached ResourceManager instance used by this class.
resourcesButton | Looks up a localized string similar to Resources....
saveAsButton_AccessText | Looks up a localized string similar to Save As....
saveAsButton_Tooltip | Looks up a localized string similar to Save As.
showTimeAs | Looks up a localized string similar to Show time as:.
startTime | Looks up a localized string similar to Start time:.
subject | Looks up a localized string similar to Subject:.
Untitled | Looks up a localized string similar to Untitled.

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_EditAppointment Constructor

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment Constructor
C1_Schedule_EditAppointment Class See Also
Initializes a new instance of the C1_Schedule_EditAppointment class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1_Schedule_EditAppointment()
Visual Basic
Public Sub New

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_EditAppointment Methods

[image] [image]

.NET Framework Class Library
C1_Schedule_EditAppointment Methods
C1_Schedule_EditAppointment Class See Also

The C1_Schedule_EditAppointment type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_EditAppointment Properties

[image] [image]

.NET Framework Class Library
C1_Schedule_EditAppointment Properties
C1_Schedule_EditAppointment Class See Also

The C1_Schedule_EditAppointment type exposes the following members.

Properties

Name | Description
allDayEvent | Looks up a localized string similar to All day event.
Appointment | Looks up a localized string similar to Appointment.
categoriesButton | Looks up a localized string similar to Categories....
categoryLabel | Looks up a localized string similar to Category:.
contactLabel | Looks up a localized string similar to Contact:.
contactsButton | Looks up a localized string similar to Contacts....
Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
deleteButton_ToolTip | Looks up a localized string similar to Delete.
endTime | Looks up a localized string similar to End time:.
Event | Looks up a localized string similar to Event.
highImportance_ToolTip | Looks up a localized string similar to High Importance.
label | Looks up a localized string similar to Label:.
location | Looks up a localized string similar to Location:.
lowImportance_ToolTip | Looks up a localized string similar to Low Importance.
PART_DialogSaveButton_AccessText | Looks up a localized string similar to Save and Close.
PART_DialogSaveButton_Tooltip | Looks up a localized string similar to Save and Close.
private_ | Looks up a localized string similar to Private.
reccButton_AccessText | Looks up a localized string similar to Recurrence....
reccButton_ToolTip | Looks up a localized string similar to Recurrence.
recurrence | Looks up a localized string similar to Recurrence:.
reminderSet | Looks up a localized string similar to Reminder:.
resourceLabel | Looks up a localized string similar to Resource:.
ResourceManager | Returns the cached ResourceManager instance used by this class.
resourcesButton | Looks up a localized string similar to Resources....
saveAsButton_AccessText | Looks up a localized string similar to Save As....
saveAsButton_Tooltip | Looks up a localized string similar to Save As.
showTimeAs | Looks up a localized string similar to Show time as:.
startTime | Looks up a localized string similar to Start time:.
subject | Looks up a localized string similar to Subject:.
Untitled | Looks up a localized string similar to Untitled.

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


allDayEvent Property

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment..::..allDayEvent Property
C1_Schedule_EditAppointment Class See Also
Looks up a localized string similar to All day event.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string allDayEvent { get; }
Visual Basic
Public Shared ReadOnly Property allDayEvent As String
    Get

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


Appointment Property

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment..::..Appointment Property
C1_Schedule_EditAppointment Class See Also
Looks up a localized string similar to Appointment.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Appointment { get; }
Visual Basic
Public Shared ReadOnly Property Appointment As String
    Get

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


categoriesButton Property

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment..::..categoriesButton Property
C1_Schedule_EditAppointment Class See Also
Looks up a localized string similar to Categories....

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string categoriesButton { get; }
Visual Basic
Public Shared ReadOnly Property categoriesButton As String
    Get

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


categoryLabel Property

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment..::..categoryLabel Property
C1_Schedule_EditAppointment Class See Also
Looks up a localized string similar to Category:.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string categoryLabel { get; }
Visual Basic
Public Shared ReadOnly Property categoryLabel As String
    Get

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


contactLabel Property

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment..::..contactLabel Property
C1_Schedule_EditAppointment Class See Also
Looks up a localized string similar to Contact:.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string contactLabel { get; }
Visual Basic
Public Shared ReadOnly Property contactLabel As String
    Get

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


contactsButton Property

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment..::..contactsButton Property
C1_Schedule_EditAppointment Class See Also
Looks up a localized string similar to Contacts....

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string contactsButton { get; }
Visual Basic
Public Shared ReadOnly Property contactsButton As String
    Get

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


Culture Property

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment..::..Culture Property
C1_Schedule_EditAppointment Class See Also
Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public static CultureInfo Culture { get; set; }
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public Shared Property Culture As CultureInfo
    Get
    Set

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


deleteButton_ToolTip Property

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment..::..deleteButton_ToolTip Property
C1_Schedule_EditAppointment Class See Also
Looks up a localized string similar to Delete.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string deleteButton_ToolTip { get; }
Visual Basic
Public Shared ReadOnly Property deleteButton_ToolTip As String
    Get

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


endTime Property

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment..::..endTime Property
C1_Schedule_EditAppointment Class See Also
Looks up a localized string similar to End time:.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string endTime { get; }
Visual Basic
Public Shared ReadOnly Property endTime As String
    Get

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


Event Property

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment..::..Event Property
C1_Schedule_EditAppointment Class See Also
Looks up a localized string similar to Event.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Event { get; }
Visual Basic
Public Shared ReadOnly Property Event As String
    Get

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


highImportance_ToolTip Property

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment..::..highImportance_ToolTip Property
C1_Schedule_EditAppointment Class See Also
Looks up a localized string similar to High Importance.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string highImportance_ToolTip { get; }
Visual Basic
Public Shared ReadOnly Property highImportance_ToolTip As String
    Get

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


label Property

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment..::..label Property
C1_Schedule_EditAppointment Class See Also
Looks up a localized string similar to Label:.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string label { get; }
Visual Basic
Public Shared ReadOnly Property label As String
    Get

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


location Property

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment..::..location Property
C1_Schedule_EditAppointment Class See Also
Looks up a localized string similar to Location:.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string location { get; }
Visual Basic
Public Shared ReadOnly Property location As String
    Get

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


lowImportance_ToolTip Property

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment..::..lowImportance_ToolTip Property
C1_Schedule_EditAppointment Class See Also
Looks up a localized string similar to Low Importance.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string lowImportance_ToolTip { get; }
Visual Basic
Public Shared ReadOnly Property lowImportance_ToolTip As String
    Get

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


PART_DialogSaveButton_AccessText Property

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment..::..PART_DialogSaveButton_AccessText Property
C1_Schedule_EditAppointment Class See Also
Looks up a localized string similar to Save and Close.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string PART_DialogSaveButton_AccessText { get; }
Visual Basic
Public Shared ReadOnly Property PART_DialogSaveButton_AccessText As String
    Get

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


PART_DialogSaveButton_Tooltip Property

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment..::..PART_DialogSaveButton_Tooltip Property
C1_Schedule_EditAppointment Class See Also
Looks up a localized string similar to Save and Close.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string PART_DialogSaveButton_Tooltip { get; }
Visual Basic
Public Shared ReadOnly Property PART_DialogSaveButton_Tooltip As String
    Get

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


private_ Property

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment..::..private_ Property
C1_Schedule_EditAppointment Class See Also
Looks up a localized string similar to Private.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string private_ { get; }
Visual Basic
Public Shared ReadOnly Property private_ As String
    Get

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


reccButton_AccessText Property

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment..::..reccButton_AccessText Property
C1_Schedule_EditAppointment Class See Also
Looks up a localized string similar to Recurrence....

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string reccButton_AccessText { get; }
Visual Basic
Public Shared ReadOnly Property reccButton_AccessText As String
    Get

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


reccButton_ToolTip Property

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment..::..reccButton_ToolTip Property
C1_Schedule_EditAppointment Class See Also
Looks up a localized string similar to Recurrence.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string reccButton_ToolTip { get; }
Visual Basic
Public Shared ReadOnly Property reccButton_ToolTip As String
    Get

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


recurrence Property

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment..::..recurrence Property
C1_Schedule_EditAppointment Class See Also
Looks up a localized string similar to Recurrence:.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string recurrence { get; }
Visual Basic
Public Shared ReadOnly Property recurrence As String
    Get

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


reminderSet Property

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment..::..reminderSet Property
C1_Schedule_EditAppointment Class See Also
Looks up a localized string similar to Reminder:.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string reminderSet { get; }
Visual Basic
Public Shared ReadOnly Property reminderSet As String
    Get

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


resourceLabel Property

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment..::..resourceLabel Property
C1_Schedule_EditAppointment Class See Also
Looks up a localized string similar to Resource:.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string resourceLabel { get; }
Visual Basic
Public Shared ReadOnly Property resourceLabel As String
    Get

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


ResourceManager Property

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment..::..ResourceManager Property
C1_Schedule_EditAppointment Class See Also
Returns the cached ResourceManager instance used by this class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public static ResourceManager ResourceManager { get; }
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public Shared ReadOnly Property ResourceManager As ResourceManager
    Get

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


resourcesButton Property

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment..::..resourcesButton Property
C1_Schedule_EditAppointment Class See Also
Looks up a localized string similar to Resources....

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string resourcesButton { get; }
Visual Basic
Public Shared ReadOnly Property resourcesButton As String
    Get

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


saveAsButton_AccessText Property

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment..::..saveAsButton_AccessText Property
C1_Schedule_EditAppointment Class See Also
Looks up a localized string similar to Save As....

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string saveAsButton_AccessText { get; }
Visual Basic
Public Shared ReadOnly Property saveAsButton_AccessText As String
    Get

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


saveAsButton_Tooltip Property

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment..::..saveAsButton_Tooltip Property
C1_Schedule_EditAppointment Class See Also
Looks up a localized string similar to Save As.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string saveAsButton_Tooltip { get; }
Visual Basic
Public Shared ReadOnly Property saveAsButton_Tooltip As String
    Get

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


showTimeAs Property

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment..::..showTimeAs Property
C1_Schedule_EditAppointment Class See Also
Looks up a localized string similar to Show time as:.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string showTimeAs { get; }
Visual Basic
Public Shared ReadOnly Property showTimeAs As String
    Get

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


startTime Property

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment..::..startTime Property
C1_Schedule_EditAppointment Class See Also
Looks up a localized string similar to Start time:.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string startTime { get; }
Visual Basic
Public Shared ReadOnly Property startTime As String
    Get

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


subject Property

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment..::..subject Property
C1_Schedule_EditAppointment Class See Also
Looks up a localized string similar to Subject:.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string subject { get; }
Visual Basic
Public Shared ReadOnly Property subject As String
    Get

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


Untitled Property

[image]

.NET Framework Class Library
C1_Schedule_EditAppointment..::..Untitled Property
C1_Schedule_EditAppointment Class See Also
Looks up a localized string similar to Untitled.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Untitled { get; }
Visual Basic
Public Shared ReadOnly Property Untitled As String
    Get

See Also

C1_Schedule_EditAppointment Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_EditRecurrence Class

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence Class
Members See Also
A strongly-typed resource class, for looking up localized strings, etc.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DebuggerNonUserCodeAttribute]
[CompilerGeneratedAttribute]
[GeneratedCodeAttribute("System.Resources.Tools.StronglyTypedResourceBuilder",
    "2.0.0.0")]
public class C1_Schedule_EditRecurrence
Visual Basic
<DebuggerNonUserCodeAttribute> _
<CompilerGeneratedAttribute> _
<GeneratedCodeAttribute("System.Resources.Tools.StronglyTypedResourceBuilder",  _
    "2.0.0.0")> _
Public Class C1_Schedule_EditRecurrence

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule.Resources..::..C1_Schedule_EditRecurrence

See Also

C1_Schedule_EditRecurrence Members
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_EditRecurrence Members

[image] [image]

.NET Framework Class Library
C1_Schedule_EditRecurrence Members
C1_Schedule_EditRecurrence Class Constructors Methods Properties See Also

The C1_Schedule_EditRecurrence type exposes the following members.

Constructors

 | Name | Description
Public method | C1_Schedule_EditRecurrence | Initializes a new instance of the C1_Schedule_EditRecurrence class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
btnCancel | Looks up a localized string similar to Cancel.
btnOk | Looks up a localized string similar to Ok.
btnRemove | Looks up a localized string similar to Remove Recurrence.
Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
dayNumberValidationError | Looks up a localized string similar to Please enter valid day number for the specified month..
duration | Looks up a localized string similar to Duration:.
end | Looks up a localized string similar to End:.
grpRange | Looks up a localized string similar to Range.
grpRepeats | Looks up a localized string similar to Repeats.
grpWhen | Looks up a localized string similar to When.
lblEveryWeek | Looks up a localized string similar to Recur every.
occurrences | Looks up a localized string similar to occurrences.
occurrencesValidationError | Looks up a localized string similar to Please enter value in range 1 - 999..
rbDaily | Looks up a localized string similar to Daily.
rbDailyRB | Looks up a localized string similar to Every.
rbEndAfter | Looks up a localized string similar to End after:.
rbEndBy | Looks up a localized string similar to End by:.
rbMonthly | Looks up a localized string similar to Monthly.
rbMonthlyNthRB | Looks up a localized string similar to The.
rbMonthlyRB | Looks up a localized string similar to Day.
rbNoEndDate | Looks up a localized string similar to No end date.
rbWeekly | Looks up a localized string similar to Weekly.
rbWorkdaysRB | Looks up a localized string similar to Every weekday.
rbYearly | Looks up a localized string similar to Yearly.
rbYearlyNthRB | Looks up a localized string similar to The.
rbYearlyRB | Looks up a localized string similar to Every.
ResourceManager | Returns the cached ResourceManager instance used by this class.
start | Looks up a localized string similar to Start:.
Title | Looks up a localized string similar to Appointment Recurrence.
txtDays | Looks up a localized string similar to day(s).
txtEveryWeek | Looks up a localized string similar to week(s) on:.
txtMonthly1 | Looks up a localized string similar to of every.
txtMonthly2 | Looks up a localized string similar to month(s).
txtMonthlyNth1 | Looks up a localized string similar to of every.
txtMonthlyNth2 | Looks up a localized string similar to month(s).
txtYearly | Looks up a localized string similar to .
txtYearlyNth1 | Looks up a localized string similar to of.
txtYearlyNth2 | Looks up a localized string similar to .

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_EditRecurrence Constructor

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence Constructor
C1_Schedule_EditRecurrence Class See Also
Initializes a new instance of the C1_Schedule_EditRecurrence class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1_Schedule_EditRecurrence()
Visual Basic
Public Sub New

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_EditRecurrence Methods

[image] [image]

.NET Framework Class Library
C1_Schedule_EditRecurrence Methods
C1_Schedule_EditRecurrence Class See Also

The C1_Schedule_EditRecurrence type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_EditRecurrence Properties

[image] [image]

.NET Framework Class Library
C1_Schedule_EditRecurrence Properties
C1_Schedule_EditRecurrence Class See Also

The C1_Schedule_EditRecurrence type exposes the following members.

Properties

Name | Description
btnCancel | Looks up a localized string similar to Cancel.
btnOk | Looks up a localized string similar to Ok.
btnRemove | Looks up a localized string similar to Remove Recurrence.
Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
dayNumberValidationError | Looks up a localized string similar to Please enter valid day number for the specified month..
duration | Looks up a localized string similar to Duration:.
end | Looks up a localized string similar to End:.
grpRange | Looks up a localized string similar to Range.
grpRepeats | Looks up a localized string similar to Repeats.
grpWhen | Looks up a localized string similar to When.
lblEveryWeek | Looks up a localized string similar to Recur every.
occurrences | Looks up a localized string similar to occurrences.
occurrencesValidationError | Looks up a localized string similar to Please enter value in range 1 - 999..
rbDaily | Looks up a localized string similar to Daily.
rbDailyRB | Looks up a localized string similar to Every.
rbEndAfter | Looks up a localized string similar to End after:.
rbEndBy | Looks up a localized string similar to End by:.
rbMonthly | Looks up a localized string similar to Monthly.
rbMonthlyNthRB | Looks up a localized string similar to The.
rbMonthlyRB | Looks up a localized string similar to Day.
rbNoEndDate | Looks up a localized string similar to No end date.
rbWeekly | Looks up a localized string similar to Weekly.
rbWorkdaysRB | Looks up a localized string similar to Every weekday.
rbYearly | Looks up a localized string similar to Yearly.
rbYearlyNthRB | Looks up a localized string similar to The.
rbYearlyRB | Looks up a localized string similar to Every.
ResourceManager | Returns the cached ResourceManager instance used by this class.
start | Looks up a localized string similar to Start:.
Title | Looks up a localized string similar to Appointment Recurrence.
txtDays | Looks up a localized string similar to day(s).
txtEveryWeek | Looks up a localized string similar to week(s) on:.
txtMonthly1 | Looks up a localized string similar to of every.
txtMonthly2 | Looks up a localized string similar to month(s).
txtMonthlyNth1 | Looks up a localized string similar to of every.
txtMonthlyNth2 | Looks up a localized string similar to month(s).
txtYearly | Looks up a localized string similar to .
txtYearlyNth1 | Looks up a localized string similar to of.
txtYearlyNth2 | Looks up a localized string similar to .

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


btnCancel Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..btnCancel Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to Cancel.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string btnCancel { get; }
Visual Basic
Public Shared ReadOnly Property btnCancel As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


btnOk Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..btnOk Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to Ok.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string btnOk { get; }
Visual Basic
Public Shared ReadOnly Property btnOk As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


btnRemove Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..btnRemove Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to Remove Recurrence.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string btnRemove { get; }
Visual Basic
Public Shared ReadOnly Property btnRemove As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


Culture Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..Culture Property
C1_Schedule_EditRecurrence Class See Also
Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public static CultureInfo Culture { get; set; }
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public Shared Property Culture As CultureInfo
    Get
    Set

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


dayNumberValidationError Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..dayNumberValidationError Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to Please enter valid day number for the specified month..

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string dayNumberValidationError { get; }
Visual Basic
Public Shared ReadOnly Property dayNumberValidationError As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


duration Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..duration Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to Duration:.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string duration { get; }
Visual Basic
Public Shared ReadOnly Property duration As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


end Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..end Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to End:.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string end { get; }
Visual Basic
Public Shared ReadOnly Property end As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


grpRange Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..grpRange Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to Range.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string grpRange { get; }
Visual Basic
Public Shared ReadOnly Property grpRange As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


grpRepeats Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..grpRepeats Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to Repeats.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string grpRepeats { get; }
Visual Basic
Public Shared ReadOnly Property grpRepeats As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


grpWhen Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..grpWhen Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to When.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string grpWhen { get; }
Visual Basic
Public Shared ReadOnly Property grpWhen As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


lblEveryWeek Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..lblEveryWeek Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to Recur every.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string lblEveryWeek { get; }
Visual Basic
Public Shared ReadOnly Property lblEveryWeek As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


occurrences Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..occurrences Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to occurrences.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string occurrences { get; }
Visual Basic
Public Shared ReadOnly Property occurrences As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


occurrencesValidationError Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..occurrencesValidationError Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to Please enter value in range 1 - 999..

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string occurrencesValidationError { get; }
Visual Basic
Public Shared ReadOnly Property occurrencesValidationError As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


rbDaily Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..rbDaily Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to Daily.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string rbDaily { get; }
Visual Basic
Public Shared ReadOnly Property rbDaily As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


rbDailyRB Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..rbDailyRB Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to Every.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string rbDailyRB { get; }
Visual Basic
Public Shared ReadOnly Property rbDailyRB As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


rbEndAfter Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..rbEndAfter Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to End after:.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string rbEndAfter { get; }
Visual Basic
Public Shared ReadOnly Property rbEndAfter As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


rbEndBy Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..rbEndBy Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to End by:.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string rbEndBy { get; }
Visual Basic
Public Shared ReadOnly Property rbEndBy As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


rbMonthly Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..rbMonthly Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to Monthly.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string rbMonthly { get; }
Visual Basic
Public Shared ReadOnly Property rbMonthly As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


rbMonthlyNthRB Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..rbMonthlyNthRB Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to The.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string rbMonthlyNthRB { get; }
Visual Basic
Public Shared ReadOnly Property rbMonthlyNthRB As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


rbMonthlyRB Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..rbMonthlyRB Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to Day.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string rbMonthlyRB { get; }
Visual Basic
Public Shared ReadOnly Property rbMonthlyRB As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


rbNoEndDate Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..rbNoEndDate Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to No end date.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string rbNoEndDate { get; }
Visual Basic
Public Shared ReadOnly Property rbNoEndDate As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


rbWeekly Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..rbWeekly Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to Weekly.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string rbWeekly { get; }
Visual Basic
Public Shared ReadOnly Property rbWeekly As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


rbWorkdaysRB Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..rbWorkdaysRB Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to Every weekday.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string rbWorkdaysRB { get; }
Visual Basic
Public Shared ReadOnly Property rbWorkdaysRB As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


rbYearly Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..rbYearly Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to Yearly.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string rbYearly { get; }
Visual Basic
Public Shared ReadOnly Property rbYearly As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


rbYearlyNthRB Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..rbYearlyNthRB Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to The.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string rbYearlyNthRB { get; }
Visual Basic
Public Shared ReadOnly Property rbYearlyNthRB As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


rbYearlyRB Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..rbYearlyRB Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to Every.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string rbYearlyRB { get; }
Visual Basic
Public Shared ReadOnly Property rbYearlyRB As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


ResourceManager Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..ResourceManager Property
C1_Schedule_EditRecurrence Class See Also
Returns the cached ResourceManager instance used by this class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public static ResourceManager ResourceManager { get; }
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public Shared ReadOnly Property ResourceManager As ResourceManager
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


start Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..start Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to Start:.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string start { get; }
Visual Basic
Public Shared ReadOnly Property start As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


Title Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..Title Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to Appointment Recurrence.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Title { get; }
Visual Basic
Public Shared ReadOnly Property Title As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


txtDays Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..txtDays Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to day(s).

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string txtDays { get; }
Visual Basic
Public Shared ReadOnly Property txtDays As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


txtEveryWeek Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..txtEveryWeek Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to week(s) on:.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string txtEveryWeek { get; }
Visual Basic
Public Shared ReadOnly Property txtEveryWeek As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


txtMonthly1 Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..txtMonthly1 Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to of every.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string txtMonthly1 { get; }
Visual Basic
Public Shared ReadOnly Property txtMonthly1 As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


txtMonthly2 Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..txtMonthly2 Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to month(s).

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string txtMonthly2 { get; }
Visual Basic
Public Shared ReadOnly Property txtMonthly2 As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


txtMonthlyNth1 Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..txtMonthlyNth1 Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to of every.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string txtMonthlyNth1 { get; }
Visual Basic
Public Shared ReadOnly Property txtMonthlyNth1 As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


txtMonthlyNth2 Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..txtMonthlyNth2 Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to month(s).

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string txtMonthlyNth2 { get; }
Visual Basic
Public Shared ReadOnly Property txtMonthlyNth2 As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


txtYearly Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..txtYearly Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to .

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string txtYearly { get; }
Visual Basic
Public Shared ReadOnly Property txtYearly As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


txtYearlyNth1 Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..txtYearlyNth1 Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to of.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string txtYearlyNth1 { get; }
Visual Basic
Public Shared ReadOnly Property txtYearlyNth1 As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


txtYearlyNth2 Property

[image]

.NET Framework Class Library
C1_Schedule_EditRecurrence..::..txtYearlyNth2 Property
C1_Schedule_EditRecurrence Class See Also
Looks up a localized string similar to .

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string txtYearlyNth2 { get; }
Visual Basic
Public Shared ReadOnly Property txtYearlyNth2 As String
    Get

See Also

C1_Schedule_EditRecurrence Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_Exceptions Class

[image]

.NET Framework Class Library
C1_Schedule_Exceptions Class
Members See Also
A strongly-typed resource class, for looking up localized strings, etc.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DebuggerNonUserCodeAttribute]
[GeneratedCodeAttribute("System.Resources.Tools.StronglyTypedResourceBuilder",
    "2.0.0.0")]
[CompilerGeneratedAttribute]
public class C1_Schedule_Exceptions
Visual Basic
<DebuggerNonUserCodeAttribute> _
<GeneratedCodeAttribute("System.Resources.Tools.StronglyTypedResourceBuilder",  _
    "2.0.0.0")> _
<CompilerGeneratedAttribute> _
Public Class C1_Schedule_Exceptions

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule.Resources..::..C1_Schedule_Exceptions

See Also

C1_Schedule_Exceptions Members
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_Exceptions Members

[image] [image]

.NET Framework Class Library
C1_Schedule_Exceptions Members
C1_Schedule_Exceptions Class Constructors Methods Properties See Also

The C1_Schedule_Exceptions type exposes the following members.

Constructors

 | Name | Description
Public method | C1_Schedule_Exceptions | Initializes a new instance of the C1_Schedule_Exceptions class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
DateOutOfRange | Looks up a localized string similar to The valid value is between {0} and {1}..
FormatNotSupported | Looks up a localized string similar to Format {0} is not supported..
ImportError | Looks up a localized string similar to Unable to import data. File is in incorrect format or damaged..
InvalidVCALInformation | Looks up a localized string similar to It is not valid VCALENDAR information..
MappingRequired | Looks up a localized string similar to The required MappingName for the {0} is not specified..
MethodNotSupported | Looks up a localized string similar to This method is not supported on this operating system..
MinMaxDateValidationFailed | Looks up a localized string similar to The MaxDate value should be greater than MinDate value..
NoFileOpenPermission | Looks up a localized string similar to There is no permission to open files..
NoFileSavePermission | Looks up a localized string similar to There is no permission to save file..
NotAllInforImported | Looks up a localized string similar to Not all information was imported due to not valid data..
ResourceManager | Returns the cached ResourceManager instance used by this class.
StartEndValidationFailed | Looks up a localized string similar to The End value should be greater than Start value..
XmlImportError | Looks up a localized string similar to Cannot find C1Schedule node..

See Also

C1_Schedule_Exceptions Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_Exceptions Constructor

[image]

.NET Framework Class Library
C1_Schedule_Exceptions Constructor
C1_Schedule_Exceptions Class See Also
Initializes a new instance of the C1_Schedule_Exceptions class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1_Schedule_Exceptions()
Visual Basic
Public Sub New

See Also

C1_Schedule_Exceptions Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_Exceptions Methods

[image] [image]

.NET Framework Class Library
C1_Schedule_Exceptions Methods
C1_Schedule_Exceptions Class See Also

The C1_Schedule_Exceptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1_Schedule_Exceptions Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_Exceptions Properties

[image] [image]

.NET Framework Class Library
C1_Schedule_Exceptions Properties
C1_Schedule_Exceptions Class See Also

The C1_Schedule_Exceptions type exposes the following members.

Properties

Name | Description
Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
DateOutOfRange | Looks up a localized string similar to The valid value is between {0} and {1}..
FormatNotSupported | Looks up a localized string similar to Format {0} is not supported..
ImportError | Looks up a localized string similar to Unable to import data. File is in incorrect format or damaged..
InvalidVCALInformation | Looks up a localized string similar to It is not valid VCALENDAR information..
MappingRequired | Looks up a localized string similar to The required MappingName for the {0} is not specified..
MethodNotSupported | Looks up a localized string similar to This method is not supported on this operating system..
MinMaxDateValidationFailed | Looks up a localized string similar to The MaxDate value should be greater than MinDate value..
NoFileOpenPermission | Looks up a localized string similar to There is no permission to open files..
NoFileSavePermission | Looks up a localized string similar to There is no permission to save file..
NotAllInforImported | Looks up a localized string similar to Not all information was imported due to not valid data..
ResourceManager | Returns the cached ResourceManager instance used by this class.
StartEndValidationFailed | Looks up a localized string similar to The End value should be greater than Start value..
XmlImportError | Looks up a localized string similar to Cannot find C1Schedule node..

See Also

C1_Schedule_Exceptions Class
C1.Silverlight.Schedule.Resources Namespace


Culture Property

[image]

.NET Framework Class Library
C1_Schedule_Exceptions..::..Culture Property
C1_Schedule_Exceptions Class See Also
Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public static CultureInfo Culture { get; set; }
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public Shared Property Culture As CultureInfo
    Get
    Set

See Also

C1_Schedule_Exceptions Class
C1.Silverlight.Schedule.Resources Namespace


DateOutOfRange Property

[image]

.NET Framework Class Library
C1_Schedule_Exceptions..::..DateOutOfRange Property
C1_Schedule_Exceptions Class See Also
Looks up a localized string similar to The valid value is between {0} and {1}..

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string DateOutOfRange { get; }
Visual Basic
Public Shared ReadOnly Property DateOutOfRange As String
    Get

See Also

C1_Schedule_Exceptions Class
C1.Silverlight.Schedule.Resources Namespace


FormatNotSupported Property

[image]

.NET Framework Class Library
C1_Schedule_Exceptions..::..FormatNotSupported Property
C1_Schedule_Exceptions Class See Also
Looks up a localized string similar to Format {0} is not supported..

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string FormatNotSupported { get; }
Visual Basic
Public Shared ReadOnly Property FormatNotSupported As String
    Get

See Also

C1_Schedule_Exceptions Class
C1.Silverlight.Schedule.Resources Namespace


ImportError Property

[image]

.NET Framework Class Library
C1_Schedule_Exceptions..::..ImportError Property
C1_Schedule_Exceptions Class See Also
Looks up a localized string similar to Unable to import data. File is in incorrect format or damaged..

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string ImportError { get; }
Visual Basic
Public Shared ReadOnly Property ImportError As String
    Get

See Also

C1_Schedule_Exceptions Class
C1.Silverlight.Schedule.Resources Namespace


InvalidVCALInformation Property

[image]

.NET Framework Class Library
C1_Schedule_Exceptions..::..InvalidVCALInformation Property
C1_Schedule_Exceptions Class See Also
Looks up a localized string similar to It is not valid VCALENDAR information..

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string InvalidVCALInformation { get; }
Visual Basic
Public Shared ReadOnly Property InvalidVCALInformation As String
    Get

See Also

C1_Schedule_Exceptions Class
C1.Silverlight.Schedule.Resources Namespace


MappingRequired Property

[image]

.NET Framework Class Library
C1_Schedule_Exceptions..::..MappingRequired Property
C1_Schedule_Exceptions Class See Also
Looks up a localized string similar to The required MappingName for the {0} is not specified..

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string MappingRequired { get; }
Visual Basic
Public Shared ReadOnly Property MappingRequired As String
    Get

See Also

C1_Schedule_Exceptions Class
C1.Silverlight.Schedule.Resources Namespace


MethodNotSupported Property

[image]

.NET Framework Class Library
C1_Schedule_Exceptions..::..MethodNotSupported Property
C1_Schedule_Exceptions Class See Also
Looks up a localized string similar to This method is not supported on this operating system..

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string MethodNotSupported { get; }
Visual Basic
Public Shared ReadOnly Property MethodNotSupported As String
    Get

See Also

C1_Schedule_Exceptions Class
C1.Silverlight.Schedule.Resources Namespace


MinMaxDateValidationFailed Property

[image]

.NET Framework Class Library
C1_Schedule_Exceptions..::..MinMaxDateValidationFailed Property
C1_Schedule_Exceptions Class See Also
Looks up a localized string similar to The MaxDate value should be greater than MinDate value..

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string MinMaxDateValidationFailed { get; }
Visual Basic
Public Shared ReadOnly Property MinMaxDateValidationFailed As String
    Get

See Also

C1_Schedule_Exceptions Class
C1.Silverlight.Schedule.Resources Namespace


NoFileOpenPermission Property

[image]

.NET Framework Class Library
C1_Schedule_Exceptions..::..NoFileOpenPermission Property
C1_Schedule_Exceptions Class See Also
Looks up a localized string similar to There is no permission to open files..

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string NoFileOpenPermission { get; }
Visual Basic
Public Shared ReadOnly Property NoFileOpenPermission As String
    Get

See Also

C1_Schedule_Exceptions Class
C1.Silverlight.Schedule.Resources Namespace


NoFileSavePermission Property

[image]

.NET Framework Class Library
C1_Schedule_Exceptions..::..NoFileSavePermission Property
C1_Schedule_Exceptions Class See Also
Looks up a localized string similar to There is no permission to save file..

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string NoFileSavePermission { get; }
Visual Basic
Public Shared ReadOnly Property NoFileSavePermission As String
    Get

See Also

C1_Schedule_Exceptions Class
C1.Silverlight.Schedule.Resources Namespace


NotAllInforImported Property

[image]

.NET Framework Class Library
C1_Schedule_Exceptions..::..NotAllInforImported Property
C1_Schedule_Exceptions Class See Also
Looks up a localized string similar to Not all information was imported due to not valid data..

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string NotAllInforImported { get; }
Visual Basic
Public Shared ReadOnly Property NotAllInforImported As String
    Get

See Also

C1_Schedule_Exceptions Class
C1.Silverlight.Schedule.Resources Namespace


ResourceManager Property

[image]

.NET Framework Class Library
C1_Schedule_Exceptions..::..ResourceManager Property
C1_Schedule_Exceptions Class See Also
Returns the cached ResourceManager instance used by this class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public static ResourceManager ResourceManager { get; }
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public Shared ReadOnly Property ResourceManager As ResourceManager
    Get

See Also

C1_Schedule_Exceptions Class
C1.Silverlight.Schedule.Resources Namespace


StartEndValidationFailed Property

[image]

.NET Framework Class Library
C1_Schedule_Exceptions..::..StartEndValidationFailed Property
C1_Schedule_Exceptions Class See Also
Looks up a localized string similar to The End value should be greater than Start value..

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string StartEndValidationFailed { get; }
Visual Basic
Public Shared ReadOnly Property StartEndValidationFailed As String
    Get

See Also

C1_Schedule_Exceptions Class
C1.Silverlight.Schedule.Resources Namespace


XmlImportError Property

[image]

.NET Framework Class Library
C1_Schedule_Exceptions..::..XmlImportError Property
C1_Schedule_Exceptions Class See Also
Looks up a localized string similar to Cannot find C1Schedule node..

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string XmlImportError { get; }
Visual Basic
Public Shared ReadOnly Property XmlImportError As String
    Get

See Also

C1_Schedule_Exceptions Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_Labels Class

[image]

.NET Framework Class Library
C1_Schedule_Labels Class
Members See Also
A strongly-typed resource class, for looking up localized strings, etc.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DebuggerNonUserCodeAttribute]
[GeneratedCodeAttribute("System.Resources.Tools.StronglyTypedResourceBuilder",
    "2.0.0.0")]
[CompilerGeneratedAttribute]
public class C1_Schedule_Labels
Visual Basic
<DebuggerNonUserCodeAttribute> _
<GeneratedCodeAttribute("System.Resources.Tools.StronglyTypedResourceBuilder",  _
    "2.0.0.0")> _
<CompilerGeneratedAttribute> _
Public Class C1_Schedule_Labels

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule.Resources..::..C1_Schedule_Labels

See Also

C1_Schedule_Labels Members
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_Labels Members

[image] [image]

.NET Framework Class Library
C1_Schedule_Labels Members
C1_Schedule_Labels Class Constructors Methods Properties See Also

The C1_Schedule_Labels type exposes the following members.

Constructors

 | Name | Description
Public method | C1_Schedule_Labels | Initializes a new instance of the C1_Schedule_Labels class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Anniversary | Looks up a localized string similar to Anniversary.
Birthday | Looks up a localized string similar to Birthday.
Business | Looks up a localized string similar to Business.
Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
Deadline | Looks up a localized string similar to Deadline.
Important | Looks up a localized string similar to Important.
MustAttend | Looks up a localized string similar to Must Attend.
NeedsPreparation | Looks up a localized string similar to Needs Preparation.
None | Looks up a localized string similar to None.
Personal | Looks up a localized string similar to Personal.
PhoneCall | Looks up a localized string similar to Phone Call.
ResourceManager | Returns the cached ResourceManager instance used by this class.
TravelRequired | Looks up a localized string similar to Travel Required.
Vacation | Looks up a localized string similar to Vacation.

See Also

C1_Schedule_Labels Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_Labels Constructor

[image]

.NET Framework Class Library
C1_Schedule_Labels Constructor
C1_Schedule_Labels Class See Also
Initializes a new instance of the C1_Schedule_Labels class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1_Schedule_Labels()
Visual Basic
Public Sub New

See Also

C1_Schedule_Labels Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_Labels Methods

[image] [image]

.NET Framework Class Library
C1_Schedule_Labels Methods
C1_Schedule_Labels Class See Also

The C1_Schedule_Labels type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1_Schedule_Labels Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_Labels Properties

[image] [image]

.NET Framework Class Library
C1_Schedule_Labels Properties
C1_Schedule_Labels Class See Also

The C1_Schedule_Labels type exposes the following members.

Properties

Name | Description
Anniversary | Looks up a localized string similar to Anniversary.
Birthday | Looks up a localized string similar to Birthday.
Business | Looks up a localized string similar to Business.
Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
Deadline | Looks up a localized string similar to Deadline.
Important | Looks up a localized string similar to Important.
MustAttend | Looks up a localized string similar to Must Attend.
NeedsPreparation | Looks up a localized string similar to Needs Preparation.
None | Looks up a localized string similar to None.
Personal | Looks up a localized string similar to Personal.
PhoneCall | Looks up a localized string similar to Phone Call.
ResourceManager | Returns the cached ResourceManager instance used by this class.
TravelRequired | Looks up a localized string similar to Travel Required.
Vacation | Looks up a localized string similar to Vacation.

See Also

C1_Schedule_Labels Class
C1.Silverlight.Schedule.Resources Namespace


Anniversary Property

[image]

.NET Framework Class Library
C1_Schedule_Labels..::..Anniversary Property
C1_Schedule_Labels Class See Also
Looks up a localized string similar to Anniversary.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Anniversary { get; }
Visual Basic
Public Shared ReadOnly Property Anniversary As String
    Get

See Also

C1_Schedule_Labels Class
C1.Silverlight.Schedule.Resources Namespace


Birthday Property

[image]

.NET Framework Class Library
C1_Schedule_Labels..::..Birthday Property
C1_Schedule_Labels Class See Also
Looks up a localized string similar to Birthday.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Birthday { get; }
Visual Basic
Public Shared ReadOnly Property Birthday As String
    Get

See Also

C1_Schedule_Labels Class
C1.Silverlight.Schedule.Resources Namespace


Business Property

[image]

.NET Framework Class Library
C1_Schedule_Labels..::..Business Property
C1_Schedule_Labels Class See Also
Looks up a localized string similar to Business.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Business { get; }
Visual Basic
Public Shared ReadOnly Property Business As String
    Get

See Also

C1_Schedule_Labels Class
C1.Silverlight.Schedule.Resources Namespace


Culture Property

[image]

.NET Framework Class Library
C1_Schedule_Labels..::..Culture Property
C1_Schedule_Labels Class See Also
Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public static CultureInfo Culture { get; set; }
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public Shared Property Culture As CultureInfo
    Get
    Set

See Also

C1_Schedule_Labels Class
C1.Silverlight.Schedule.Resources Namespace


Deadline Property

[image]

.NET Framework Class Library
C1_Schedule_Labels..::..Deadline Property
C1_Schedule_Labels Class See Also
Looks up a localized string similar to Deadline.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Deadline { get; }
Visual Basic
Public Shared ReadOnly Property Deadline As String
    Get

See Also

C1_Schedule_Labels Class
C1.Silverlight.Schedule.Resources Namespace


Important Property

[image]

.NET Framework Class Library
C1_Schedule_Labels..::..Important Property
C1_Schedule_Labels Class See Also
Looks up a localized string similar to Important.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Important { get; }
Visual Basic
Public Shared ReadOnly Property Important As String
    Get

See Also

C1_Schedule_Labels Class
C1.Silverlight.Schedule.Resources Namespace


MustAttend Property

[image]

.NET Framework Class Library
C1_Schedule_Labels..::..MustAttend Property
C1_Schedule_Labels Class See Also
Looks up a localized string similar to Must Attend.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string MustAttend { get; }
Visual Basic
Public Shared ReadOnly Property MustAttend As String
    Get

See Also

C1_Schedule_Labels Class
C1.Silverlight.Schedule.Resources Namespace


NeedsPreparation Property

[image]

.NET Framework Class Library
C1_Schedule_Labels..::..NeedsPreparation Property
C1_Schedule_Labels Class See Also
Looks up a localized string similar to Needs Preparation.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string NeedsPreparation { get; }
Visual Basic
Public Shared ReadOnly Property NeedsPreparation As String
    Get

See Also

C1_Schedule_Labels Class
C1.Silverlight.Schedule.Resources Namespace


None Property

[image]

.NET Framework Class Library
C1_Schedule_Labels..::..None Property
C1_Schedule_Labels Class See Also
Looks up a localized string similar to None.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string None { get; }
Visual Basic
Public Shared ReadOnly Property None As String
    Get

See Also

C1_Schedule_Labels Class
C1.Silverlight.Schedule.Resources Namespace


Personal Property

[image]

.NET Framework Class Library
C1_Schedule_Labels..::..Personal Property
C1_Schedule_Labels Class See Also
Looks up a localized string similar to Personal.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Personal { get; }
Visual Basic
Public Shared ReadOnly Property Personal As String
    Get

See Also

C1_Schedule_Labels Class
C1.Silverlight.Schedule.Resources Namespace


PhoneCall Property

[image]

.NET Framework Class Library
C1_Schedule_Labels..::..PhoneCall Property
C1_Schedule_Labels Class See Also
Looks up a localized string similar to Phone Call.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string PhoneCall { get; }
Visual Basic
Public Shared ReadOnly Property PhoneCall As String
    Get

See Also

C1_Schedule_Labels Class
C1.Silverlight.Schedule.Resources Namespace


ResourceManager Property

[image]

.NET Framework Class Library
C1_Schedule_Labels..::..ResourceManager Property
C1_Schedule_Labels Class See Also
Returns the cached ResourceManager instance used by this class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public static ResourceManager ResourceManager { get; }
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public Shared ReadOnly Property ResourceManager As ResourceManager
    Get

See Also

C1_Schedule_Labels Class
C1.Silverlight.Schedule.Resources Namespace


TravelRequired Property

[image]

.NET Framework Class Library
C1_Schedule_Labels..::..TravelRequired Property
C1_Schedule_Labels Class See Also
Looks up a localized string similar to Travel Required.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string TravelRequired { get; }
Visual Basic
Public Shared ReadOnly Property TravelRequired As String
    Get

See Also

C1_Schedule_Labels Class
C1.Silverlight.Schedule.Resources Namespace


Vacation Property

[image]

.NET Framework Class Library
C1_Schedule_Labels..::..Vacation Property
C1_Schedule_Labels Class See Also
Looks up a localized string similar to Vacation.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Vacation { get; }
Visual Basic
Public Shared ReadOnly Property Vacation As String
    Get

See Also

C1_Schedule_Labels Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_MiscStrings Class

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings Class
Members See Also
A strongly-typed resource class, for looking up localized strings, etc.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[GeneratedCodeAttribute("System.Resources.Tools.StronglyTypedResourceBuilder",
    "4.0.0.0")]
[DebuggerNonUserCodeAttribute]
[CompilerGeneratedAttribute]
public class C1_Schedule_MiscStrings
Visual Basic
<GeneratedCodeAttribute("System.Resources.Tools.StronglyTypedResourceBuilder",  _
    "4.0.0.0")> _
<DebuggerNonUserCodeAttribute> _
<CompilerGeneratedAttribute> _
Public Class C1_Schedule_MiscStrings

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule.Resources..::..C1_Schedule_MiscStrings

See Also

C1_Schedule_MiscStrings Members
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_MiscStrings Members

[image] [image]

.NET Framework Class Library
C1_Schedule_MiscStrings Members
C1_Schedule_MiscStrings Class Constructors Methods Properties See Also

The C1_Schedule_MiscStrings type exposes the following members.

Constructors

 | Name | Description
Public method | C1_Schedule_MiscStrings | Initializes a new instance of the C1_Schedule_MiscStrings class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
Daily | Looks up a localized string similar to Occurs every day.
Day | Looks up a localized string similar to day.
EmptyGroupName | Looks up a localized string similar to Calendar.
EveryNDay | Looks up a localized string similar to Occurs every {0} days.
EveryNMonth | Looks up a localized string similar to Occurs day {1} of every {0} months.
EveryNMonthOnTheNWeekday | Looks up a localized string similar to Occurs the {1} {2} of every {0} months.
EveryNWeek | Looks up a localized string similar to Occurs every {0} weeks on {1}.
First | Looks up a localized string similar to first.
Fourth | Looks up a localized string similar to fourth.
IncorrectPattern | Looks up a localized string similar to incorrect reccurrence pattern.
Last | Looks up a localized string similar to last.
Monthly | Looks up a localized string similar to Occurs day {0} of every 1 month.
MonthlyOnTheNWeekday | Looks up a localized string similar to Occurs the {0} {1} of every 1 month.
MoreAppointments | Looks up a localized string similar to Click for more appointments..
NextAppointment | Looks up a localized string similar to Next Appointment.
OnWorkingDays | Looks up a localized string similar to Occurs every week day.
PreviousAppointment | Looks up a localized string similar to Previous Appointment.
ResourceManager | Returns the cached ResourceManager instance used by this class.
Second | Looks up a localized string similar to second.
Since | Looks up a localized string similar to effective {0} from {1} to {2}..
SinceNTimes | Looks up a localized string similar to effective {0} from {1} to {2}, {3} times..
SinceUntil | Looks up a localized string similar to effective {0} until {1} from {2} to {3}..
Third | Looks up a localized string similar to third.
Weekday | Looks up a localized string similar to week day.
Weekend | Looks up a localized string similar to weekend.
Weekly | Looks up a localized string similar to Occurs every {0}.
Yearly | Looks up a localized string similar to Occurs every {1} {0}.
YearlyNth | Looks up a localized string similar to Occurs the {0} {1} of {2}.

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_MiscStrings Constructor

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings Constructor
C1_Schedule_MiscStrings Class See Also
Initializes a new instance of the C1_Schedule_MiscStrings class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1_Schedule_MiscStrings()
Visual Basic
Public Sub New

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_MiscStrings Methods

[image] [image]

.NET Framework Class Library
C1_Schedule_MiscStrings Methods
C1_Schedule_MiscStrings Class See Also

The C1_Schedule_MiscStrings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_MiscStrings Properties

[image] [image]

.NET Framework Class Library
C1_Schedule_MiscStrings Properties
C1_Schedule_MiscStrings Class See Also

The C1_Schedule_MiscStrings type exposes the following members.

Properties

Name | Description
Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
Daily | Looks up a localized string similar to Occurs every day.
Day | Looks up a localized string similar to day.
EmptyGroupName | Looks up a localized string similar to Calendar.
EveryNDay | Looks up a localized string similar to Occurs every {0} days.
EveryNMonth | Looks up a localized string similar to Occurs day {1} of every {0} months.
EveryNMonthOnTheNWeekday | Looks up a localized string similar to Occurs the {1} {2} of every {0} months.
EveryNWeek | Looks up a localized string similar to Occurs every {0} weeks on {1}.
First | Looks up a localized string similar to first.
Fourth | Looks up a localized string similar to fourth.
IncorrectPattern | Looks up a localized string similar to incorrect reccurrence pattern.
Last | Looks up a localized string similar to last.
Monthly | Looks up a localized string similar to Occurs day {0} of every 1 month.
MonthlyOnTheNWeekday | Looks up a localized string similar to Occurs the {0} {1} of every 1 month.
MoreAppointments | Looks up a localized string similar to Click for more appointments..
NextAppointment | Looks up a localized string similar to Next Appointment.
OnWorkingDays | Looks up a localized string similar to Occurs every week day.
PreviousAppointment | Looks up a localized string similar to Previous Appointment.
ResourceManager | Returns the cached ResourceManager instance used by this class.
Second | Looks up a localized string similar to second.
Since | Looks up a localized string similar to effective {0} from {1} to {2}..
SinceNTimes | Looks up a localized string similar to effective {0} from {1} to {2}, {3} times..
SinceUntil | Looks up a localized string similar to effective {0} until {1} from {2} to {3}..
Third | Looks up a localized string similar to third.
Weekday | Looks up a localized string similar to week day.
Weekend | Looks up a localized string similar to weekend.
Weekly | Looks up a localized string similar to Occurs every {0}.
Yearly | Looks up a localized string similar to Occurs every {1} {0}.
YearlyNth | Looks up a localized string similar to Occurs the {0} {1} of {2}.

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


Culture Property

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings..::..Culture Property
C1_Schedule_MiscStrings Class See Also
Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public static CultureInfo Culture { get; set; }
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public Shared Property Culture As CultureInfo
    Get
    Set

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


Daily Property

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings..::..Daily Property
C1_Schedule_MiscStrings Class See Also
Looks up a localized string similar to Occurs every day.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Daily { get; }
Visual Basic
Public Shared ReadOnly Property Daily As String
    Get

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


Day Property

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings..::..Day Property
C1_Schedule_MiscStrings Class See Also
Looks up a localized string similar to day.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Day { get; }
Visual Basic
Public Shared ReadOnly Property Day As String
    Get

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


EmptyGroupName Property

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings..::..EmptyGroupName Property
C1_Schedule_MiscStrings Class See Also
Looks up a localized string similar to Calendar.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string EmptyGroupName { get; }
Visual Basic
Public Shared ReadOnly Property EmptyGroupName As String
    Get

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


EveryNDay Property

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings..::..EveryNDay Property
C1_Schedule_MiscStrings Class See Also
Looks up a localized string similar to Occurs every {0} days.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string EveryNDay { get; }
Visual Basic
Public Shared ReadOnly Property EveryNDay As String
    Get

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


EveryNMonth Property

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings..::..EveryNMonth Property
C1_Schedule_MiscStrings Class See Also
Looks up a localized string similar to Occurs day {1} of every {0} months.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string EveryNMonth { get; }
Visual Basic
Public Shared ReadOnly Property EveryNMonth As String
    Get

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


EveryNMonthOnTheNWeekday Property

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings..::..EveryNMonthOnTheNWeekday Property
C1_Schedule_MiscStrings Class See Also
Looks up a localized string similar to Occurs the {1} {2} of every {0} months.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string EveryNMonthOnTheNWeekday { get; }
Visual Basic
Public Shared ReadOnly Property EveryNMonthOnTheNWeekday As String
    Get

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


EveryNWeek Property

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings..::..EveryNWeek Property
C1_Schedule_MiscStrings Class See Also
Looks up a localized string similar to Occurs every {0} weeks on {1}.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string EveryNWeek { get; }
Visual Basic
Public Shared ReadOnly Property EveryNWeek As String
    Get

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


First Property

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings..::..First Property
C1_Schedule_MiscStrings Class See Also
Looks up a localized string similar to first.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string First { get; }
Visual Basic
Public Shared ReadOnly Property First As String
    Get

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


Fourth Property

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings..::..Fourth Property
C1_Schedule_MiscStrings Class See Also
Looks up a localized string similar to fourth.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Fourth { get; }
Visual Basic
Public Shared ReadOnly Property Fourth As String
    Get

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


IncorrectPattern Property

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings..::..IncorrectPattern Property
C1_Schedule_MiscStrings Class See Also
Looks up a localized string similar to incorrect reccurrence pattern.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string IncorrectPattern { get; }
Visual Basic
Public Shared ReadOnly Property IncorrectPattern As String
    Get

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


Last Property

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings..::..Last Property
C1_Schedule_MiscStrings Class See Also
Looks up a localized string similar to last.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Last { get; }
Visual Basic
Public Shared ReadOnly Property Last As String
    Get

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


Monthly Property

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings..::..Monthly Property
C1_Schedule_MiscStrings Class See Also
Looks up a localized string similar to Occurs day {0} of every 1 month.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Monthly { get; }
Visual Basic
Public Shared ReadOnly Property Monthly As String
    Get

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


MonthlyOnTheNWeekday Property

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings..::..MonthlyOnTheNWeekday Property
C1_Schedule_MiscStrings Class See Also
Looks up a localized string similar to Occurs the {0} {1} of every 1 month.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string MonthlyOnTheNWeekday { get; }
Visual Basic
Public Shared ReadOnly Property MonthlyOnTheNWeekday As String
    Get

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


MoreAppointments Property

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings..::..MoreAppointments Property
C1_Schedule_MiscStrings Class See Also
Looks up a localized string similar to Click for more appointments..

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string MoreAppointments { get; }
Visual Basic
Public Shared ReadOnly Property MoreAppointments As String
    Get

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


NextAppointment Property

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings..::..NextAppointment Property
C1_Schedule_MiscStrings Class See Also
Looks up a localized string similar to Next Appointment.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string NextAppointment { get; }
Visual Basic
Public Shared ReadOnly Property NextAppointment As String
    Get

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


OnWorkingDays Property

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings..::..OnWorkingDays Property
C1_Schedule_MiscStrings Class See Also
Looks up a localized string similar to Occurs every week day.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string OnWorkingDays { get; }
Visual Basic
Public Shared ReadOnly Property OnWorkingDays As String
    Get

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


PreviousAppointment Property

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings..::..PreviousAppointment Property
C1_Schedule_MiscStrings Class See Also
Looks up a localized string similar to Previous Appointment.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string PreviousAppointment { get; }
Visual Basic
Public Shared ReadOnly Property PreviousAppointment As String
    Get

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


ResourceManager Property

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings..::..ResourceManager Property
C1_Schedule_MiscStrings Class See Also
Returns the cached ResourceManager instance used by this class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public static ResourceManager ResourceManager { get; }
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public Shared ReadOnly Property ResourceManager As ResourceManager
    Get

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


Second Property

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings..::..Second Property
C1_Schedule_MiscStrings Class See Also
Looks up a localized string similar to second.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Second { get; }
Visual Basic
Public Shared ReadOnly Property Second As String
    Get

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


Since Property

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings..::..Since Property
C1_Schedule_MiscStrings Class See Also
Looks up a localized string similar to effective {0} from {1} to {2}..

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Since { get; }
Visual Basic
Public Shared ReadOnly Property Since As String
    Get

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


SinceNTimes Property

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings..::..SinceNTimes Property
C1_Schedule_MiscStrings Class See Also
Looks up a localized string similar to effective {0} from {1} to {2}, {3} times..

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string SinceNTimes { get; }
Visual Basic
Public Shared ReadOnly Property SinceNTimes As String
    Get

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


SinceUntil Property

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings..::..SinceUntil Property
C1_Schedule_MiscStrings Class See Also
Looks up a localized string similar to effective {0} until {1} from {2} to {3}..

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string SinceUntil { get; }
Visual Basic
Public Shared ReadOnly Property SinceUntil As String
    Get

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


Third Property

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings..::..Third Property
C1_Schedule_MiscStrings Class See Also
Looks up a localized string similar to third.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Third { get; }
Visual Basic
Public Shared ReadOnly Property Third As String
    Get

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


Weekday Property

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings..::..Weekday Property
C1_Schedule_MiscStrings Class See Also
Looks up a localized string similar to week day.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Weekday { get; }
Visual Basic
Public Shared ReadOnly Property Weekday As String
    Get

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


Weekend Property

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings..::..Weekend Property
C1_Schedule_MiscStrings Class See Also
Looks up a localized string similar to weekend.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Weekend { get; }
Visual Basic
Public Shared ReadOnly Property Weekend As String
    Get

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


Weekly Property

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings..::..Weekly Property
C1_Schedule_MiscStrings Class See Also
Looks up a localized string similar to Occurs every {0}.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Weekly { get; }
Visual Basic
Public Shared ReadOnly Property Weekly As String
    Get

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


Yearly Property

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings..::..Yearly Property
C1_Schedule_MiscStrings Class See Also
Looks up a localized string similar to Occurs every {1} {0}.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Yearly { get; }
Visual Basic
Public Shared ReadOnly Property Yearly As String
    Get

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


YearlyNth Property

[image]

.NET Framework Class Library
C1_Schedule_MiscStrings..::..YearlyNth Property
C1_Schedule_MiscStrings Class See Also
Looks up a localized string similar to Occurs the {0} {1} of {2}.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string YearlyNth { get; }
Visual Basic
Public Shared ReadOnly Property YearlyNth As String
    Get

See Also

C1_Schedule_MiscStrings Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_RecChoice Class

[image]

.NET Framework Class Library
C1_Schedule_RecChoice Class
Members See Also
A strongly-typed resource class, for looking up localized strings, etc.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[DebuggerNonUserCodeAttribute]
[GeneratedCodeAttribute("System.Resources.Tools.StronglyTypedResourceBuilder",
    "2.0.0.0")]
[CompilerGeneratedAttribute]
public class C1_Schedule_RecChoice
Visual Basic
<DebuggerNonUserCodeAttribute> _
<GeneratedCodeAttribute("System.Resources.Tools.StronglyTypedResourceBuilder",  _
    "2.0.0.0")> _
<CompilerGeneratedAttribute> _
Public Class C1_Schedule_RecChoice

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule.Resources..::..C1_Schedule_RecChoice

See Also

C1_Schedule_RecChoice Members
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_RecChoice Members

[image] [image]

.NET Framework Class Library
C1_Schedule_RecChoice Members
C1_Schedule_RecChoice Class Constructors Methods Properties See Also

The C1_Schedule_RecChoice type exposes the following members.

Constructors

 | Name | Description
Public method | C1_Schedule_RecChoice | Initializes a new instance of the C1_Schedule_RecChoice class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
btnCancel_Text | Looks up a localized string similar to Cancel.
btnOk_Text | Looks up a localized string similar to Ok.
Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
OpenSeriesMessage | Looks up a localized string similar to "{0}" is a recurring appointment.\nDo you want to open only this occurrence or the series?.
OpenTheSeries | Looks up a localized string similar to Open the series.
OpenThisOccurrence | Looks up a localized string similar to Open this occurrence.
OpenTitle | Looks up a localized string similar to Open Recurring Appointment.
RemoveSeriesMessage | Looks up a localized string similar to Do you want to delete all occurrences of the recurring appointment "{0}", or just this one?.
RemoveTheSeries | Looks up a localized string similar to Delete the series.
RemoveThisOccurrence | Looks up a localized string similar to Delete this occurrence.
RemoveTitle | Looks up a localized string similar to Confirm Delete Appointment.
ResourceManager | Returns the cached ResourceManager instance used by this class.

See Also

C1_Schedule_RecChoice Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_RecChoice Constructor

[image]

.NET Framework Class Library
C1_Schedule_RecChoice Constructor
C1_Schedule_RecChoice Class See Also
Initializes a new instance of the C1_Schedule_RecChoice class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1_Schedule_RecChoice()
Visual Basic
Public Sub New

See Also

C1_Schedule_RecChoice Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_RecChoice Methods

[image] [image]

.NET Framework Class Library
C1_Schedule_RecChoice Methods
C1_Schedule_RecChoice Class See Also

The C1_Schedule_RecChoice type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1_Schedule_RecChoice Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_RecChoice Properties

[image] [image]

.NET Framework Class Library
C1_Schedule_RecChoice Properties
C1_Schedule_RecChoice Class See Also

The C1_Schedule_RecChoice type exposes the following members.

Properties

Name | Description
btnCancel_Text | Looks up a localized string similar to Cancel.
btnOk_Text | Looks up a localized string similar to Ok.
Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
OpenSeriesMessage | Looks up a localized string similar to "{0}" is a recurring appointment.\nDo you want to open only this occurrence or the series?.
OpenTheSeries | Looks up a localized string similar to Open the series.
OpenThisOccurrence | Looks up a localized string similar to Open this occurrence.
OpenTitle | Looks up a localized string similar to Open Recurring Appointment.
RemoveSeriesMessage | Looks up a localized string similar to Do you want to delete all occurrences of the recurring appointment "{0}", or just this one?.
RemoveTheSeries | Looks up a localized string similar to Delete the series.
RemoveThisOccurrence | Looks up a localized string similar to Delete this occurrence.
RemoveTitle | Looks up a localized string similar to Confirm Delete Appointment.
ResourceManager | Returns the cached ResourceManager instance used by this class.

See Also

C1_Schedule_RecChoice Class
C1.Silverlight.Schedule.Resources Namespace


btnCancel_Text Property

[image]

.NET Framework Class Library
C1_Schedule_RecChoice..::..btnCancel_Text Property
C1_Schedule_RecChoice Class See Also
Looks up a localized string similar to Cancel.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string btnCancel_Text { get; }
Visual Basic
Public Shared ReadOnly Property btnCancel_Text As String
    Get

See Also

C1_Schedule_RecChoice Class
C1.Silverlight.Schedule.Resources Namespace


btnOk_Text Property

[image]

.NET Framework Class Library
C1_Schedule_RecChoice..::..btnOk_Text Property
C1_Schedule_RecChoice Class See Also
Looks up a localized string similar to Ok.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string btnOk_Text { get; }
Visual Basic
Public Shared ReadOnly Property btnOk_Text As String
    Get

See Also

C1_Schedule_RecChoice Class
C1.Silverlight.Schedule.Resources Namespace


Culture Property

[image]

.NET Framework Class Library
C1_Schedule_RecChoice..::..Culture Property
C1_Schedule_RecChoice Class See Also
Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public static CultureInfo Culture { get; set; }
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public Shared Property Culture As CultureInfo
    Get
    Set

See Also

C1_Schedule_RecChoice Class
C1.Silverlight.Schedule.Resources Namespace


OpenSeriesMessage Property

[image]

.NET Framework Class Library
C1_Schedule_RecChoice..::..OpenSeriesMessage Property
C1_Schedule_RecChoice Class See Also
Looks up a localized string similar to "{0}" is a recurring appointment.\nDo you want to open only this occurrence or the series?.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string OpenSeriesMessage { get; }
Visual Basic
Public Shared ReadOnly Property OpenSeriesMessage As String
    Get

See Also

C1_Schedule_RecChoice Class
C1.Silverlight.Schedule.Resources Namespace


OpenTheSeries Property

[image]

.NET Framework Class Library
C1_Schedule_RecChoice..::..OpenTheSeries Property
C1_Schedule_RecChoice Class See Also
Looks up a localized string similar to Open the series.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string OpenTheSeries { get; }
Visual Basic
Public Shared ReadOnly Property OpenTheSeries As String
    Get

See Also

C1_Schedule_RecChoice Class
C1.Silverlight.Schedule.Resources Namespace


OpenThisOccurrence Property

[image]

.NET Framework Class Library
C1_Schedule_RecChoice..::..OpenThisOccurrence Property
C1_Schedule_RecChoice Class See Also
Looks up a localized string similar to Open this occurrence.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string OpenThisOccurrence { get; }
Visual Basic
Public Shared ReadOnly Property OpenThisOccurrence As String
    Get

See Also

C1_Schedule_RecChoice Class
C1.Silverlight.Schedule.Resources Namespace


OpenTitle Property

[image]

.NET Framework Class Library
C1_Schedule_RecChoice..::..OpenTitle Property
C1_Schedule_RecChoice Class See Also
Looks up a localized string similar to Open Recurring Appointment.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string OpenTitle { get; }
Visual Basic
Public Shared ReadOnly Property OpenTitle As String
    Get

See Also

C1_Schedule_RecChoice Class
C1.Silverlight.Schedule.Resources Namespace


RemoveSeriesMessage Property

[image]

.NET Framework Class Library
C1_Schedule_RecChoice..::..RemoveSeriesMessage Property
C1_Schedule_RecChoice Class See Also
Looks up a localized string similar to Do you want to delete all occurrences of the recurring appointment "{0}", or just this one?.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string RemoveSeriesMessage { get; }
Visual Basic
Public Shared ReadOnly Property RemoveSeriesMessage As String
    Get

See Also

C1_Schedule_RecChoice Class
C1.Silverlight.Schedule.Resources Namespace


RemoveTheSeries Property

[image]

.NET Framework Class Library
C1_Schedule_RecChoice..::..RemoveTheSeries Property
C1_Schedule_RecChoice Class See Also
Looks up a localized string similar to Delete the series.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string RemoveTheSeries { get; }
Visual Basic
Public Shared ReadOnly Property RemoveTheSeries As String
    Get

See Also

C1_Schedule_RecChoice Class
C1.Silverlight.Schedule.Resources Namespace


RemoveThisOccurrence Property

[image]

.NET Framework Class Library
C1_Schedule_RecChoice..::..RemoveThisOccurrence Property
C1_Schedule_RecChoice Class See Also
Looks up a localized string similar to Delete this occurrence.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string RemoveThisOccurrence { get; }
Visual Basic
Public Shared ReadOnly Property RemoveThisOccurrence As String
    Get

See Also

C1_Schedule_RecChoice Class
C1.Silverlight.Schedule.Resources Namespace


RemoveTitle Property

[image]

.NET Framework Class Library
C1_Schedule_RecChoice..::..RemoveTitle Property
C1_Schedule_RecChoice Class See Also
Looks up a localized string similar to Confirm Delete Appointment.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string RemoveTitle { get; }
Visual Basic
Public Shared ReadOnly Property RemoveTitle As String
    Get

See Also

C1_Schedule_RecChoice Class
C1.Silverlight.Schedule.Resources Namespace


ResourceManager Property

[image]

.NET Framework Class Library
C1_Schedule_RecChoice..::..ResourceManager Property
C1_Schedule_RecChoice Class See Also
Returns the cached ResourceManager instance used by this class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public static ResourceManager ResourceManager { get; }
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public Shared ReadOnly Property ResourceManager As ResourceManager
    Get

See Also

C1_Schedule_RecChoice Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_SelectFromListScene Class

[image]

.NET Framework Class Library
C1_Schedule_SelectFromListScene Class
Members See Also
A strongly-typed resource class, for looking up localized strings, etc.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[GeneratedCodeAttribute("System.Resources.Tools.StronglyTypedResourceBuilder",
    "2.0.0.0")]
[DebuggerNonUserCodeAttribute]
[CompilerGeneratedAttribute]
public class C1_Schedule_SelectFromListScene
Visual Basic
<GeneratedCodeAttribute("System.Resources.Tools.StronglyTypedResourceBuilder",  _
    "2.0.0.0")> _
<DebuggerNonUserCodeAttribute> _
<CompilerGeneratedAttribute> _
Public Class C1_Schedule_SelectFromListScene

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule.Resources..::..C1_Schedule_SelectFromListScene

See Also

C1_Schedule_SelectFromListScene Members
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_SelectFromListScene Members

[image] [image]

.NET Framework Class Library
C1_Schedule_SelectFromListScene Members
C1_Schedule_SelectFromListScene Class Constructors Methods Properties See Also

The C1_Schedule_SelectFromListScene type exposes the following members.

Constructors

 | Name | Description
Public method | C1_Schedule_SelectFromListScene | Initializes a new instance of the C1_Schedule_SelectFromListScene class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
available | Looks up a localized string similar to Available:.
btnAdd_Text | Looks up a localized string similar to Add.
btnCancel_Text | Looks up a localized string similar to Cancel.
btnOk_Text | Looks up a localized string similar to Ok.
btnRemove_Text | Looks up a localized string similar to Delete.
btnReset_Text | Looks up a localized string similar to Reset.
Categories | Looks up a localized string similar to Categories.
Contacts | Looks up a localized string similar to Contacts.
Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
ResourceManager | Returns the cached ResourceManager instance used by this class.
Resources | Looks up a localized string similar to Resources.
selected | Looks up a localized string similar to Selected:.

See Also

C1_Schedule_SelectFromListScene Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_SelectFromListScene Constructor

[image]

.NET Framework Class Library
C1_Schedule_SelectFromListScene Constructor
C1_Schedule_SelectFromListScene Class See Also
Initializes a new instance of the C1_Schedule_SelectFromListScene class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1_Schedule_SelectFromListScene()
Visual Basic
Public Sub New

See Also

C1_Schedule_SelectFromListScene Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_SelectFromListScene Methods

[image] [image]

.NET Framework Class Library
C1_Schedule_SelectFromListScene Methods
C1_Schedule_SelectFromListScene Class See Also

The C1_Schedule_SelectFromListScene type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1_Schedule_SelectFromListScene Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_SelectFromListScene Properties

[image] [image]

.NET Framework Class Library
C1_Schedule_SelectFromListScene Properties
C1_Schedule_SelectFromListScene Class See Also

The C1_Schedule_SelectFromListScene type exposes the following members.

Properties

Name | Description
available | Looks up a localized string similar to Available:.
btnAdd_Text | Looks up a localized string similar to Add.
btnCancel_Text | Looks up a localized string similar to Cancel.
btnOk_Text | Looks up a localized string similar to Ok.
btnRemove_Text | Looks up a localized string similar to Delete.
btnReset_Text | Looks up a localized string similar to Reset.
Categories | Looks up a localized string similar to Categories.
Contacts | Looks up a localized string similar to Contacts.
Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
ResourceManager | Returns the cached ResourceManager instance used by this class.
Resources | Looks up a localized string similar to Resources.
selected | Looks up a localized string similar to Selected:.

See Also

C1_Schedule_SelectFromListScene Class
C1.Silverlight.Schedule.Resources Namespace


available Property

[image]

.NET Framework Class Library
C1_Schedule_SelectFromListScene..::..available Property
C1_Schedule_SelectFromListScene Class See Also
Looks up a localized string similar to Available:.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string available { get; }
Visual Basic
Public Shared ReadOnly Property available As String
    Get

See Also

C1_Schedule_SelectFromListScene Class
C1.Silverlight.Schedule.Resources Namespace


btnAdd_Text Property

[image]

.NET Framework Class Library
C1_Schedule_SelectFromListScene..::..btnAdd_Text Property
C1_Schedule_SelectFromListScene Class See Also
Looks up a localized string similar to Add.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string btnAdd_Text { get; }
Visual Basic
Public Shared ReadOnly Property btnAdd_Text As String
    Get

See Also

C1_Schedule_SelectFromListScene Class
C1.Silverlight.Schedule.Resources Namespace


btnCancel_Text Property

[image]

.NET Framework Class Library
C1_Schedule_SelectFromListScene..::..btnCancel_Text Property
C1_Schedule_SelectFromListScene Class See Also
Looks up a localized string similar to Cancel.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string btnCancel_Text { get; }
Visual Basic
Public Shared ReadOnly Property btnCancel_Text As String
    Get

See Also

C1_Schedule_SelectFromListScene Class
C1.Silverlight.Schedule.Resources Namespace


btnOk_Text Property

[image]

.NET Framework Class Library
C1_Schedule_SelectFromListScene..::..btnOk_Text Property
C1_Schedule_SelectFromListScene Class See Also
Looks up a localized string similar to Ok.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string btnOk_Text { get; }
Visual Basic
Public Shared ReadOnly Property btnOk_Text As String
    Get

See Also

C1_Schedule_SelectFromListScene Class
C1.Silverlight.Schedule.Resources Namespace


btnRemove_Text Property

[image]

.NET Framework Class Library
C1_Schedule_SelectFromListScene..::..btnRemove_Text Property
C1_Schedule_SelectFromListScene Class See Also
Looks up a localized string similar to Delete.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string btnRemove_Text { get; }
Visual Basic
Public Shared ReadOnly Property btnRemove_Text As String
    Get

See Also

C1_Schedule_SelectFromListScene Class
C1.Silverlight.Schedule.Resources Namespace


btnReset_Text Property

[image]

.NET Framework Class Library
C1_Schedule_SelectFromListScene..::..btnReset_Text Property
C1_Schedule_SelectFromListScene Class See Also
Looks up a localized string similar to Reset.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string btnReset_Text { get; }
Visual Basic
Public Shared ReadOnly Property btnReset_Text As String
    Get

See Also

C1_Schedule_SelectFromListScene Class
C1.Silverlight.Schedule.Resources Namespace


Categories Property

[image]

.NET Framework Class Library
C1_Schedule_SelectFromListScene..::..Categories Property
C1_Schedule_SelectFromListScene Class See Also
Looks up a localized string similar to Categories.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Categories { get; }
Visual Basic
Public Shared ReadOnly Property Categories As String
    Get

See Also

C1_Schedule_SelectFromListScene Class
C1.Silverlight.Schedule.Resources Namespace


Contacts Property

[image]

.NET Framework Class Library
C1_Schedule_SelectFromListScene..::..Contacts Property
C1_Schedule_SelectFromListScene Class See Also
Looks up a localized string similar to Contacts.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Contacts { get; }
Visual Basic
Public Shared ReadOnly Property Contacts As String
    Get

See Also

C1_Schedule_SelectFromListScene Class
C1.Silverlight.Schedule.Resources Namespace


Culture Property

[image]

.NET Framework Class Library
C1_Schedule_SelectFromListScene..::..Culture Property
C1_Schedule_SelectFromListScene Class See Also
Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public static CultureInfo Culture { get; set; }
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public Shared Property Culture As CultureInfo
    Get
    Set

See Also

C1_Schedule_SelectFromListScene Class
C1.Silverlight.Schedule.Resources Namespace


ResourceManager Property

[image]

.NET Framework Class Library
C1_Schedule_SelectFromListScene..::..ResourceManager Property
C1_Schedule_SelectFromListScene Class See Also
Returns the cached ResourceManager instance used by this class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public static ResourceManager ResourceManager { get; }
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public Shared ReadOnly Property ResourceManager As ResourceManager
    Get

See Also

C1_Schedule_SelectFromListScene Class
C1.Silverlight.Schedule.Resources Namespace


Resources Property

[image]

.NET Framework Class Library
C1_Schedule_SelectFromListScene..::..Resources Property
C1_Schedule_SelectFromListScene Class See Also
Looks up a localized string similar to Resources.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Resources { get; }
Visual Basic
Public Shared ReadOnly Property Resources As String
    Get

See Also

C1_Schedule_SelectFromListScene Class
C1.Silverlight.Schedule.Resources Namespace


selected Property

[image]

.NET Framework Class Library
C1_Schedule_SelectFromListScene..::..selected Property
C1_Schedule_SelectFromListScene Class See Also
Looks up a localized string similar to Selected:.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string selected { get; }
Visual Basic
Public Shared ReadOnly Property selected As String
    Get

See Also

C1_Schedule_SelectFromListScene Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_ShowReminders Class

[image]

.NET Framework Class Library
C1_Schedule_ShowReminders Class
Members See Also
A strongly-typed resource class, for looking up localized strings, etc.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[GeneratedCodeAttribute("System.Resources.Tools.StronglyTypedResourceBuilder",
    "2.0.0.0")]
[DebuggerNonUserCodeAttribute]
[CompilerGeneratedAttribute]
public class C1_Schedule_ShowReminders
Visual Basic
<GeneratedCodeAttribute("System.Resources.Tools.StronglyTypedResourceBuilder",  _
    "2.0.0.0")> _
<DebuggerNonUserCodeAttribute> _
<CompilerGeneratedAttribute> _
Public Class C1_Schedule_ShowReminders

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule.Resources..::..C1_Schedule_ShowReminders

See Also

C1_Schedule_ShowReminders Members
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_ShowReminders Members

[image] [image]

.NET Framework Class Library
C1_Schedule_ShowReminders Members
C1_Schedule_ShowReminders Class Constructors Methods Properties See Also

The C1_Schedule_ShowReminders type exposes the following members.

Constructors

 | Name | Description
Public method | C1_Schedule_ShowReminders | Initializes a new instance of the C1_Schedule_ShowReminders class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
btnDismiss_Text | Looks up a localized string similar to Dismiss.
btnDismissAll_Text | Looks up a localized string similar to Dismiss All.
btnOpen_Text | Looks up a localized string similar to Open Item.
btnSnooze_Text | Looks up a localized string similar to Snooze.
colSubject | Looks up a localized string similar to Subject.
colTime | Looks up a localized string similar to Due in.
Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
lblLocation | Looks up a localized string similar to Location:.
lblSnooze | Looks up a localized string similar to Click Snooze to be reminded again in:.
lblStart | Looks up a localized string similar to Start time:.
NDaysOverdue | Looks up a localized string similar to {0} days overdue.
NHoursOverdue | Looks up a localized string similar to {0} hours overdue.
NMinutesOverdue | Looks up a localized string similar to {0} minutes overdue.
Now | Looks up a localized string similar to Now.
OneDayOverdue | Looks up a localized string similar to 1 day overdue.
OneHourOverdue | Looks up a localized string similar to 1 hour overdue.
OneMinuteOverdue | Looks up a localized string similar to 1 minute overdue.
OneReminder | Looks up a localized string similar to 1 Reminder.
openMenuItem | Looks up a localized string similar to Open.
RemindersNumber | Looks up a localized string similar to {0} Reminders.
ResourceManager | Returns the cached ResourceManager instance used by this class.
SelectedRemindersNumber | Looks up a localized string similar to Selected reminders -.
Title | Looks up a localized string similar to Reminders.

See Also

C1_Schedule_ShowReminders Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_ShowReminders Constructor

[image]

.NET Framework Class Library
C1_Schedule_ShowReminders Constructor
C1_Schedule_ShowReminders Class See Also
Initializes a new instance of the C1_Schedule_ShowReminders class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1_Schedule_ShowReminders()
Visual Basic
Public Sub New

See Also

C1_Schedule_ShowReminders Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_ShowReminders Methods

[image] [image]

.NET Framework Class Library
C1_Schedule_ShowReminders Methods
C1_Schedule_ShowReminders Class See Also

The C1_Schedule_ShowReminders type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1_Schedule_ShowReminders Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_ShowReminders Properties

[image] [image]

.NET Framework Class Library
C1_Schedule_ShowReminders Properties
C1_Schedule_ShowReminders Class See Also

The C1_Schedule_ShowReminders type exposes the following members.

Properties

Name | Description
btnDismiss_Text | Looks up a localized string similar to Dismiss.
btnDismissAll_Text | Looks up a localized string similar to Dismiss All.
btnOpen_Text | Looks up a localized string similar to Open Item.
btnSnooze_Text | Looks up a localized string similar to Snooze.
colSubject | Looks up a localized string similar to Subject.
colTime | Looks up a localized string similar to Due in.
Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
lblLocation | Looks up a localized string similar to Location:.
lblSnooze | Looks up a localized string similar to Click Snooze to be reminded again in:.
lblStart | Looks up a localized string similar to Start time:.
NDaysOverdue | Looks up a localized string similar to {0} days overdue.
NHoursOverdue | Looks up a localized string similar to {0} hours overdue.
NMinutesOverdue | Looks up a localized string similar to {0} minutes overdue.
Now | Looks up a localized string similar to Now.
OneDayOverdue | Looks up a localized string similar to 1 day overdue.
OneHourOverdue | Looks up a localized string similar to 1 hour overdue.
OneMinuteOverdue | Looks up a localized string similar to 1 minute overdue.
OneReminder | Looks up a localized string similar to 1 Reminder.
openMenuItem | Looks up a localized string similar to Open.
RemindersNumber | Looks up a localized string similar to {0} Reminders.
ResourceManager | Returns the cached ResourceManager instance used by this class.
SelectedRemindersNumber | Looks up a localized string similar to Selected reminders -.
Title | Looks up a localized string similar to Reminders.

See Also

C1_Schedule_ShowReminders Class
C1.Silverlight.Schedule.Resources Namespace


btnDismiss_Text Property

[image]

.NET Framework Class Library
C1_Schedule_ShowReminders..::..btnDismiss_Text Property
C1_Schedule_ShowReminders Class See Also
Looks up a localized string similar to Dismiss.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string btnDismiss_Text { get; }
Visual Basic
Public Shared ReadOnly Property btnDismiss_Text As String
    Get

See Also

C1_Schedule_ShowReminders Class
C1.Silverlight.Schedule.Resources Namespace


btnDismissAll_Text Property

[image]

.NET Framework Class Library
C1_Schedule_ShowReminders..::..btnDismissAll_Text Property
C1_Schedule_ShowReminders Class See Also
Looks up a localized string similar to Dismiss All.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string btnDismissAll_Text { get; }
Visual Basic
Public Shared ReadOnly Property btnDismissAll_Text As String
    Get

See Also

C1_Schedule_ShowReminders Class
C1.Silverlight.Schedule.Resources Namespace


btnOpen_Text Property

[image]

.NET Framework Class Library
C1_Schedule_ShowReminders..::..btnOpen_Text Property
C1_Schedule_ShowReminders Class See Also
Looks up a localized string similar to Open Item.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string btnOpen_Text { get; }
Visual Basic
Public Shared ReadOnly Property btnOpen_Text As String
    Get

See Also

C1_Schedule_ShowReminders Class
C1.Silverlight.Schedule.Resources Namespace


btnSnooze_Text Property

[image]

.NET Framework Class Library
C1_Schedule_ShowReminders..::..btnSnooze_Text Property
C1_Schedule_ShowReminders Class See Also
Looks up a localized string similar to Snooze.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string btnSnooze_Text { get; }
Visual Basic
Public Shared ReadOnly Property btnSnooze_Text As String
    Get

See Also

C1_Schedule_ShowReminders Class
C1.Silverlight.Schedule.Resources Namespace


colSubject Property

[image]

.NET Framework Class Library
C1_Schedule_ShowReminders..::..colSubject Property
C1_Schedule_ShowReminders Class See Also
Looks up a localized string similar to Subject.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string colSubject { get; }
Visual Basic
Public Shared ReadOnly Property colSubject As String
    Get

See Also

C1_Schedule_ShowReminders Class
C1.Silverlight.Schedule.Resources Namespace


colTime Property

[image]

.NET Framework Class Library
C1_Schedule_ShowReminders..::..colTime Property
C1_Schedule_ShowReminders Class See Also
Looks up a localized string similar to Due in.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string colTime { get; }
Visual Basic
Public Shared ReadOnly Property colTime As String
    Get

See Also

C1_Schedule_ShowReminders Class
C1.Silverlight.Schedule.Resources Namespace


Culture Property

[image]

.NET Framework Class Library
C1_Schedule_ShowReminders..::..Culture Property
C1_Schedule_ShowReminders Class See Also
Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public static CultureInfo Culture { get; set; }
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public Shared Property Culture As CultureInfo
    Get
    Set

See Also

C1_Schedule_ShowReminders Class
C1.Silverlight.Schedule.Resources Namespace


lblLocation Property

[image]

.NET Framework Class Library
C1_Schedule_ShowReminders..::..lblLocation Property
C1_Schedule_ShowReminders Class See Also
Looks up a localized string similar to Location:.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string lblLocation { get; }
Visual Basic
Public Shared ReadOnly Property lblLocation As String
    Get

See Also

C1_Schedule_ShowReminders Class
C1.Silverlight.Schedule.Resources Namespace


lblSnooze Property

[image]

.NET Framework Class Library
C1_Schedule_ShowReminders..::..lblSnooze Property
C1_Schedule_ShowReminders Class See Also
Looks up a localized string similar to Click Snooze to be reminded again in:.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string lblSnooze { get; }
Visual Basic
Public Shared ReadOnly Property lblSnooze As String
    Get

See Also

C1_Schedule_ShowReminders Class
C1.Silverlight.Schedule.Resources Namespace


lblStart Property

[image]

.NET Framework Class Library
C1_Schedule_ShowReminders..::..lblStart Property
C1_Schedule_ShowReminders Class See Also
Looks up a localized string similar to Start time:.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string lblStart { get; }
Visual Basic
Public Shared ReadOnly Property lblStart As String
    Get

See Also

C1_Schedule_ShowReminders Class
C1.Silverlight.Schedule.Resources Namespace


NDaysOverdue Property

[image]

.NET Framework Class Library
C1_Schedule_ShowReminders..::..NDaysOverdue Property
C1_Schedule_ShowReminders Class See Also
Looks up a localized string similar to {0} days overdue.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string NDaysOverdue { get; }
Visual Basic
Public Shared ReadOnly Property NDaysOverdue As String
    Get

See Also

C1_Schedule_ShowReminders Class
C1.Silverlight.Schedule.Resources Namespace


NHoursOverdue Property

[image]

.NET Framework Class Library
C1_Schedule_ShowReminders..::..NHoursOverdue Property
C1_Schedule_ShowReminders Class See Also
Looks up a localized string similar to {0} hours overdue.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string NHoursOverdue { get; }
Visual Basic
Public Shared ReadOnly Property NHoursOverdue As String
    Get

See Also

C1_Schedule_ShowReminders Class
C1.Silverlight.Schedule.Resources Namespace


NMinutesOverdue Property

[image]

.NET Framework Class Library
C1_Schedule_ShowReminders..::..NMinutesOverdue Property
C1_Schedule_ShowReminders Class See Also
Looks up a localized string similar to {0} minutes overdue.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string NMinutesOverdue { get; }
Visual Basic
Public Shared ReadOnly Property NMinutesOverdue As String
    Get

See Also

C1_Schedule_ShowReminders Class
C1.Silverlight.Schedule.Resources Namespace


Now Property

[image]

.NET Framework Class Library
C1_Schedule_ShowReminders..::..Now Property
C1_Schedule_ShowReminders Class See Also
Looks up a localized string similar to Now.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Now { get; }
Visual Basic
Public Shared ReadOnly Property Now As String
    Get

See Also

C1_Schedule_ShowReminders Class
C1.Silverlight.Schedule.Resources Namespace


OneDayOverdue Property

[image]

.NET Framework Class Library
C1_Schedule_ShowReminders..::..OneDayOverdue Property
C1_Schedule_ShowReminders Class See Also
Looks up a localized string similar to 1 day overdue.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string OneDayOverdue { get; }
Visual Basic
Public Shared ReadOnly Property OneDayOverdue As String
    Get

See Also

C1_Schedule_ShowReminders Class
C1.Silverlight.Schedule.Resources Namespace


OneHourOverdue Property

[image]

.NET Framework Class Library
C1_Schedule_ShowReminders..::..OneHourOverdue Property
C1_Schedule_ShowReminders Class See Also
Looks up a localized string similar to 1 hour overdue.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string OneHourOverdue { get; }
Visual Basic
Public Shared ReadOnly Property OneHourOverdue As String
    Get

See Also

C1_Schedule_ShowReminders Class
C1.Silverlight.Schedule.Resources Namespace


OneMinuteOverdue Property

[image]

.NET Framework Class Library
C1_Schedule_ShowReminders..::..OneMinuteOverdue Property
C1_Schedule_ShowReminders Class See Also
Looks up a localized string similar to 1 minute overdue.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string OneMinuteOverdue { get; }
Visual Basic
Public Shared ReadOnly Property OneMinuteOverdue As String
    Get

See Also

C1_Schedule_ShowReminders Class
C1.Silverlight.Schedule.Resources Namespace


OneReminder Property

[image]

.NET Framework Class Library
C1_Schedule_ShowReminders..::..OneReminder Property
C1_Schedule_ShowReminders Class See Also
Looks up a localized string similar to 1 Reminder.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string OneReminder { get; }
Visual Basic
Public Shared ReadOnly Property OneReminder As String
    Get

See Also

C1_Schedule_ShowReminders Class
C1.Silverlight.Schedule.Resources Namespace


openMenuItem Property

[image]

.NET Framework Class Library
C1_Schedule_ShowReminders..::..openMenuItem Property
C1_Schedule_ShowReminders Class See Also
Looks up a localized string similar to Open.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string openMenuItem { get; }
Visual Basic
Public Shared ReadOnly Property openMenuItem As String
    Get

See Also

C1_Schedule_ShowReminders Class
C1.Silverlight.Schedule.Resources Namespace


RemindersNumber Property

[image]

.NET Framework Class Library
C1_Schedule_ShowReminders..::..RemindersNumber Property
C1_Schedule_ShowReminders Class See Also
Looks up a localized string similar to {0} Reminders.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string RemindersNumber { get; }
Visual Basic
Public Shared ReadOnly Property RemindersNumber As String
    Get

See Also

C1_Schedule_ShowReminders Class
C1.Silverlight.Schedule.Resources Namespace


ResourceManager Property

[image]

.NET Framework Class Library
C1_Schedule_ShowReminders..::..ResourceManager Property
C1_Schedule_ShowReminders Class See Also
Returns the cached ResourceManager instance used by this class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public static ResourceManager ResourceManager { get; }
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public Shared ReadOnly Property ResourceManager As ResourceManager
    Get

See Also

C1_Schedule_ShowReminders Class
C1.Silverlight.Schedule.Resources Namespace


SelectedRemindersNumber Property

[image]

.NET Framework Class Library
C1_Schedule_ShowReminders..::..SelectedRemindersNumber Property
C1_Schedule_ShowReminders Class See Also
Looks up a localized string similar to Selected reminders -.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string SelectedRemindersNumber { get; }
Visual Basic
Public Shared ReadOnly Property SelectedRemindersNumber As String
    Get

See Also

C1_Schedule_ShowReminders Class
C1.Silverlight.Schedule.Resources Namespace


Title Property

[image]

.NET Framework Class Library
C1_Schedule_ShowReminders..::..Title Property
C1_Schedule_ShowReminders Class See Also
Looks up a localized string similar to Reminders.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Title { get; }
Visual Basic
Public Shared ReadOnly Property Title As String
    Get

See Also

C1_Schedule_ShowReminders Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_Statuses Class

[image]

.NET Framework Class Library
C1_Schedule_Statuses Class
Members See Also
A strongly-typed resource class, for looking up localized strings, etc.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[GeneratedCodeAttribute("System.Resources.Tools.StronglyTypedResourceBuilder",
    "2.0.0.0")]
[DebuggerNonUserCodeAttribute]
[CompilerGeneratedAttribute]
public class C1_Schedule_Statuses
Visual Basic
<GeneratedCodeAttribute("System.Resources.Tools.StronglyTypedResourceBuilder",  _
    "2.0.0.0")> _
<DebuggerNonUserCodeAttribute> _
<CompilerGeneratedAttribute> _
Public Class C1_Schedule_Statuses

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule.Resources..::..C1_Schedule_Statuses

See Also

C1_Schedule_Statuses Members
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_Statuses Members

[image] [image]

.NET Framework Class Library
C1_Schedule_Statuses Members
C1_Schedule_Statuses Class Constructors Methods Properties See Also

The C1_Schedule_Statuses type exposes the following members.

Constructors

 | Name | Description
Public method | C1_Schedule_Statuses | Initializes a new instance of the C1_Schedule_Statuses class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Busy | Looks up a localized string similar to Busy.
Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
Free | Looks up a localized string similar to Free.
OutOfOffice | Looks up a localized string similar to Out of Office.
ResourceManager | Returns the cached ResourceManager instance used by this class.
Tentative | Looks up a localized string similar to Tentative.

See Also

C1_Schedule_Statuses Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_Statuses Constructor

[image]

.NET Framework Class Library
C1_Schedule_Statuses Constructor
C1_Schedule_Statuses Class See Also
Initializes a new instance of the C1_Schedule_Statuses class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1_Schedule_Statuses()
Visual Basic
Public Sub New

See Also

C1_Schedule_Statuses Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_Statuses Methods

[image] [image]

.NET Framework Class Library
C1_Schedule_Statuses Methods
C1_Schedule_Statuses Class See Also

The C1_Schedule_Statuses type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1_Schedule_Statuses Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_Statuses Properties

[image] [image]

.NET Framework Class Library
C1_Schedule_Statuses Properties
C1_Schedule_Statuses Class See Also

The C1_Schedule_Statuses type exposes the following members.

Properties

Name | Description
Busy | Looks up a localized string similar to Busy.
Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
Free | Looks up a localized string similar to Free.
OutOfOffice | Looks up a localized string similar to Out of Office.
ResourceManager | Returns the cached ResourceManager instance used by this class.
Tentative | Looks up a localized string similar to Tentative.

See Also

C1_Schedule_Statuses Class
C1.Silverlight.Schedule.Resources Namespace


Busy Property

[image]

.NET Framework Class Library
C1_Schedule_Statuses..::..Busy Property
C1_Schedule_Statuses Class See Also
Looks up a localized string similar to Busy.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Busy { get; }
Visual Basic
Public Shared ReadOnly Property Busy As String
    Get

See Also

C1_Schedule_Statuses Class
C1.Silverlight.Schedule.Resources Namespace


Culture Property

[image]

.NET Framework Class Library
C1_Schedule_Statuses..::..Culture Property
C1_Schedule_Statuses Class See Also
Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public static CultureInfo Culture { get; set; }
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public Shared Property Culture As CultureInfo
    Get
    Set

See Also

C1_Schedule_Statuses Class
C1.Silverlight.Schedule.Resources Namespace


Free Property

[image]

.NET Framework Class Library
C1_Schedule_Statuses..::..Free Property
C1_Schedule_Statuses Class See Also
Looks up a localized string similar to Free.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Free { get; }
Visual Basic
Public Shared ReadOnly Property Free As String
    Get

See Also

C1_Schedule_Statuses Class
C1.Silverlight.Schedule.Resources Namespace


OutOfOffice Property

[image]

.NET Framework Class Library
C1_Schedule_Statuses..::..OutOfOffice Property
C1_Schedule_Statuses Class See Also
Looks up a localized string similar to Out of Office.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string OutOfOffice { get; }
Visual Basic
Public Shared ReadOnly Property OutOfOffice As String
    Get

See Also

C1_Schedule_Statuses Class
C1.Silverlight.Schedule.Resources Namespace


ResourceManager Property

[image]

.NET Framework Class Library
C1_Schedule_Statuses..::..ResourceManager Property
C1_Schedule_Statuses Class See Also
Returns the cached ResourceManager instance used by this class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public static ResourceManager ResourceManager { get; }
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public Shared ReadOnly Property ResourceManager As ResourceManager
    Get

See Also

C1_Schedule_Statuses Class
C1.Silverlight.Schedule.Resources Namespace


Tentative Property

[image]

.NET Framework Class Library
C1_Schedule_Statuses..::..Tentative Property
C1_Schedule_Statuses Class See Also
Looks up a localized string similar to Tentative.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string Tentative { get; }
Visual Basic
Public Shared ReadOnly Property Tentative As String
    Get

See Also

C1_Schedule_Statuses Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_TimeStrings Class

[image]

.NET Framework Class Library
C1_Schedule_TimeStrings Class
Members See Also
A strongly-typed resource class, for looking up localized strings, etc.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[GeneratedCodeAttribute("System.Resources.Tools.StronglyTypedResourceBuilder",
    "2.0.0.0")]
[CompilerGeneratedAttribute]
[DebuggerNonUserCodeAttribute]
public class C1_Schedule_TimeStrings
Visual Basic
<GeneratedCodeAttribute("System.Resources.Tools.StronglyTypedResourceBuilder",  _
    "2.0.0.0")> _
<CompilerGeneratedAttribute> _
<DebuggerNonUserCodeAttribute> _
Public Class C1_Schedule_TimeStrings

Inheritance Hierarchy

System..::..Object
C1.Silverlight.Schedule.Resources..::..C1_Schedule_TimeStrings

See Also

C1_Schedule_TimeStrings Members
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_TimeStrings Members

[image] [image]

.NET Framework Class Library
C1_Schedule_TimeStrings Members
C1_Schedule_TimeStrings Class Constructors Methods Properties See Also

The C1_Schedule_TimeStrings type exposes the following members.

Constructors

 | Name | Description
Public method | C1_Schedule_TimeStrings | Initializes a new instance of the C1_Schedule_TimeStrings class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
day | Looks up a localized string similar to day.
days | Looks up a localized string similar to days.
hour | Looks up a localized string similar to hour.
hours | Looks up a localized string similar to hours.
minute | Looks up a localized string similar to minute.
minutes | Looks up a localized string similar to minutes.
NDays | Looks up a localized string similar to {0} days.
NHours | Looks up a localized string similar to {0} hours.
NMinutes | Looks up a localized string similar to {0} minutes.
NWeeks | Looks up a localized string similar to {0} weeks.
OneDay | Looks up a localized string similar to 1 day.
OneHour | Looks up a localized string similar to 1 hour.
OneMinute | Looks up a localized string similar to 1 minute.
OneWeek | Looks up a localized string similar to 1 week.
ResourceManager | Returns the cached ResourceManager instance used by this class.
week | Looks up a localized string similar to week.
weeks | Looks up a localized string similar to weeks.

See Also

C1_Schedule_TimeStrings Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_TimeStrings Constructor

[image]

.NET Framework Class Library
C1_Schedule_TimeStrings Constructor
C1_Schedule_TimeStrings Class See Also
Initializes a new instance of the C1_Schedule_TimeStrings class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public C1_Schedule_TimeStrings()
Visual Basic
Public Sub New

See Also

C1_Schedule_TimeStrings Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_TimeStrings Methods

[image] [image]

.NET Framework Class Library
C1_Schedule_TimeStrings Methods
C1_Schedule_TimeStrings Class See Also

The C1_Schedule_TimeStrings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1_Schedule_TimeStrings Class
C1.Silverlight.Schedule.Resources Namespace


C1_Schedule_TimeStrings Properties

[image] [image]

.NET Framework Class Library
C1_Schedule_TimeStrings Properties
C1_Schedule_TimeStrings Class See Also

The C1_Schedule_TimeStrings type exposes the following members.

Properties

Name | Description
Culture | Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.
day | Looks up a localized string similar to day.
days | Looks up a localized string similar to days.
hour | Looks up a localized string similar to hour.
hours | Looks up a localized string similar to hours.
minute | Looks up a localized string similar to minute.
minutes | Looks up a localized string similar to minutes.
NDays | Looks up a localized string similar to {0} days.
NHours | Looks up a localized string similar to {0} hours.
NMinutes | Looks up a localized string similar to {0} minutes.
NWeeks | Looks up a localized string similar to {0} weeks.
OneDay | Looks up a localized string similar to 1 day.
OneHour | Looks up a localized string similar to 1 hour.
OneMinute | Looks up a localized string similar to 1 minute.
OneWeek | Looks up a localized string similar to 1 week.
ResourceManager | Returns the cached ResourceManager instance used by this class.
week | Looks up a localized string similar to week.
weeks | Looks up a localized string similar to weeks.

See Also

C1_Schedule_TimeStrings Class
C1.Silverlight.Schedule.Resources Namespace


Culture Property

[image]

.NET Framework Class Library
C1_Schedule_TimeStrings..::..Culture Property
C1_Schedule_TimeStrings Class See Also
Overrides the current thread's CurrentUICulture property for all resource lookups using this strongly typed resource class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public static CultureInfo Culture { get; set; }
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public Shared Property Culture As CultureInfo
    Get
    Set

See Also

C1_Schedule_TimeStrings Class
C1.Silverlight.Schedule.Resources Namespace


day Property

[image]

.NET Framework Class Library
C1_Schedule_TimeStrings..::..day Property
C1_Schedule_TimeStrings Class See Also
Looks up a localized string similar to day.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string day { get; }
Visual Basic
Public Shared ReadOnly Property day As String
    Get

See Also

C1_Schedule_TimeStrings Class
C1.Silverlight.Schedule.Resources Namespace


days Property

[image]

.NET Framework Class Library
C1_Schedule_TimeStrings..::..days Property
C1_Schedule_TimeStrings Class See Also
Looks up a localized string similar to days.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string days { get; }
Visual Basic
Public Shared ReadOnly Property days As String
    Get

See Also

C1_Schedule_TimeStrings Class
C1.Silverlight.Schedule.Resources Namespace


hour Property

[image]

.NET Framework Class Library
C1_Schedule_TimeStrings..::..hour Property
C1_Schedule_TimeStrings Class See Also
Looks up a localized string similar to hour.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string hour { get; }
Visual Basic
Public Shared ReadOnly Property hour As String
    Get

See Also

C1_Schedule_TimeStrings Class
C1.Silverlight.Schedule.Resources Namespace


hours Property

[image]

.NET Framework Class Library
C1_Schedule_TimeStrings..::..hours Property
C1_Schedule_TimeStrings Class See Also
Looks up a localized string similar to hours.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string hours { get; }
Visual Basic
Public Shared ReadOnly Property hours As String
    Get

See Also

C1_Schedule_TimeStrings Class
C1.Silverlight.Schedule.Resources Namespace


minute Property

[image]

.NET Framework Class Library
C1_Schedule_TimeStrings..::..minute Property
C1_Schedule_TimeStrings Class See Also
Looks up a localized string similar to minute.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string minute { get; }
Visual Basic
Public Shared ReadOnly Property minute As String
    Get

See Also

C1_Schedule_TimeStrings Class
C1.Silverlight.Schedule.Resources Namespace


minutes Property

[image]

.NET Framework Class Library
C1_Schedule_TimeStrings..::..minutes Property
C1_Schedule_TimeStrings Class See Also
Looks up a localized string similar to minutes.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string minutes { get; }
Visual Basic
Public Shared ReadOnly Property minutes As String
    Get

See Also

C1_Schedule_TimeStrings Class
C1.Silverlight.Schedule.Resources Namespace


NDays Property

[image]

.NET Framework Class Library
C1_Schedule_TimeStrings..::..NDays Property
C1_Schedule_TimeStrings Class See Also
Looks up a localized string similar to {0} days.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string NDays { get; }
Visual Basic
Public Shared ReadOnly Property NDays As String
    Get

See Also

C1_Schedule_TimeStrings Class
C1.Silverlight.Schedule.Resources Namespace


NHours Property

[image]

.NET Framework Class Library
C1_Schedule_TimeStrings..::..NHours Property
C1_Schedule_TimeStrings Class See Also
Looks up a localized string similar to {0} hours.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string NHours { get; }
Visual Basic
Public Shared ReadOnly Property NHours As String
    Get

See Also

C1_Schedule_TimeStrings Class
C1.Silverlight.Schedule.Resources Namespace


NMinutes Property

[image]

.NET Framework Class Library
C1_Schedule_TimeStrings..::..NMinutes Property
C1_Schedule_TimeStrings Class See Also
Looks up a localized string similar to {0} minutes.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string NMinutes { get; }
Visual Basic
Public Shared ReadOnly Property NMinutes As String
    Get

See Also

C1_Schedule_TimeStrings Class
C1.Silverlight.Schedule.Resources Namespace


NWeeks Property

[image]

.NET Framework Class Library
C1_Schedule_TimeStrings..::..NWeeks Property
C1_Schedule_TimeStrings Class See Also
Looks up a localized string similar to {0} weeks.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string NWeeks { get; }
Visual Basic
Public Shared ReadOnly Property NWeeks As String
    Get

See Also

C1_Schedule_TimeStrings Class
C1.Silverlight.Schedule.Resources Namespace


OneDay Property

[image]

.NET Framework Class Library
C1_Schedule_TimeStrings..::..OneDay Property
C1_Schedule_TimeStrings Class See Also
Looks up a localized string similar to 1 day.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string OneDay { get; }
Visual Basic
Public Shared ReadOnly Property OneDay As String
    Get

See Also

C1_Schedule_TimeStrings Class
C1.Silverlight.Schedule.Resources Namespace


OneHour Property

[image]

.NET Framework Class Library
C1_Schedule_TimeStrings..::..OneHour Property
C1_Schedule_TimeStrings Class See Also
Looks up a localized string similar to 1 hour.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string OneHour { get; }
Visual Basic
Public Shared ReadOnly Property OneHour As String
    Get

See Also

C1_Schedule_TimeStrings Class
C1.Silverlight.Schedule.Resources Namespace


OneMinute Property

[image]

.NET Framework Class Library
C1_Schedule_TimeStrings..::..OneMinute Property
C1_Schedule_TimeStrings Class See Also
Looks up a localized string similar to 1 minute.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string OneMinute { get; }
Visual Basic
Public Shared ReadOnly Property OneMinute As String
    Get

See Also

C1_Schedule_TimeStrings Class
C1.Silverlight.Schedule.Resources Namespace


OneWeek Property

[image]

.NET Framework Class Library
C1_Schedule_TimeStrings..::..OneWeek Property
C1_Schedule_TimeStrings Class See Also
Looks up a localized string similar to 1 week.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string OneWeek { get; }
Visual Basic
Public Shared ReadOnly Property OneWeek As String
    Get

See Also

C1_Schedule_TimeStrings Class
C1.Silverlight.Schedule.Resources Namespace


ResourceManager Property

[image]

.NET Framework Class Library
C1_Schedule_TimeStrings..::..ResourceManager Property
C1_Schedule_TimeStrings Class See Also
Returns the cached ResourceManager instance used by this class.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public static ResourceManager ResourceManager { get; }
Visual Basic
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public Shared ReadOnly Property ResourceManager As ResourceManager
    Get

See Also

C1_Schedule_TimeStrings Class
C1.Silverlight.Schedule.Resources Namespace


week Property

[image]

.NET Framework Class Library
C1_Schedule_TimeStrings..::..week Property
C1_Schedule_TimeStrings Class See Also
Looks up a localized string similar to week.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string week { get; }
Visual Basic
Public Shared ReadOnly Property week As String
    Get

See Also

C1_Schedule_TimeStrings Class
C1.Silverlight.Schedule.Resources Namespace


weeks Property

[image]

.NET Framework Class Library
C1_Schedule_TimeStrings..::..weeks Property
C1_Schedule_TimeStrings Class See Also
Looks up a localized string similar to weeks.

Namespace: C1.Silverlight.Schedule.Resources
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static string weeks { get; }
Visual Basic
Public Shared ReadOnly Property weeks As String
    Get

See Also

C1_Schedule_TimeStrings Class
C1.Silverlight.Schedule.Resources Namespace


System.ComponentModel Namespace

[image]

.NET Framework Class Library
System.ComponentModel Namespace
The System.ComponentModel namespace provides classes that are used to implement the run-time and design-time behavior of components and controls. This namespace includes the base classes and interfaces for implementing attributes and type converters, binding to data sources, and licensing components.

Classes

 | Class | Description
Public class | EnumConverter | Provides a type converter to convert Enum objects to and from various other representations.


EnumConverter Class

[image]

.NET Framework Class Library
EnumConverter Class
Members See Also
Provides a type converter to convert Enum objects to and from various other representations.

Namespace: System.ComponentModel
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public class EnumConverter : TypeConverter
Visual Basic
Public Class EnumConverter _
    Inherits TypeConverter

Inheritance Hierarchy

System..::..Object
System.ComponentModel..::..TypeConverter
System.ComponentModel..::..EnumConverter

See Also

EnumConverter Members
System.ComponentModel Namespace


EnumConverter Members

[image] [image]

.NET Framework Class Library
EnumConverter Members
EnumConverter Class Constructors Methods Properties See Also

The EnumConverter type exposes the following members.

Constructors

 | Name | Description
Public method | EnumConverter | Initializes a new instance of the EnumConverter class for the given type.

Methods

 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Gets a value indicating whether this converter can convert an object in the given source type to an enumeration object using the specified context. (Overrides TypeConverter..::..CanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the specified value object to an enumeration object. (Overrides TypeConverter..::..ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromString | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified destination type. (Overrides TypeConverter..::..ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToString | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | EnumType | Specifies the type of the enumerator this converter is associated with.

See Also

EnumConverter Class
System.ComponentModel Namespace


EnumConverter Constructor

[image]

.NET Framework Class Library
EnumConverter Constructor
EnumConverter Class See Also
Initializes a new instance of the EnumConverter class for the given type.

Namespace: System.ComponentModel
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public EnumConverter(
    Type type
)
Visual Basic
Public Sub New ( _
    type As Type _
)

Parameters

type
Type: System..::..Type
A Type that represents the type of enumeration to associate with this enumeration converter.

See Also

EnumConverter Class
System.ComponentModel Namespace


EnumConverter Methods

[image] [image]

.NET Framework Class Library
EnumConverter Methods
EnumConverter Class See Also

The EnumConverter type exposes the following members.

Methods

 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Gets a value indicating whether this converter can convert an object in the given source type to an enumeration object using the specified context. (Overrides TypeConverter..::..CanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the specified value object to an enumeration object. (Overrides TypeConverter..::..ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromString | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified destination type. (Overrides TypeConverter..::..ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToString | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EnumConverter Class
System.ComponentModel Namespace


CanConvertFrom Method

[image] [image]

.NET Framework Class Library
EnumConverter..::..CanConvertFrom Method
EnumConverter Class See Also

Overload List

 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Gets a value indicating whether this converter can convert an object in the given source type to an enumeration object using the specified context. (Overrides TypeConverter..::..CanConvertFrom(ITypeDescriptorContext, Type).)

See Also

EnumConverter Class
EnumConverter Members
System.ComponentModel Namespace


CanConvertFrom Method (ITypeDescriptorContext, Type)

[image]

.NET Framework Class Library
EnumConverter..::..CanConvertFrom Method (ITypeDescriptorContext, Type)
EnumConverter Class See Also
Gets a value indicating whether this converter can convert an object in the given source type to an enumeration object using the specified context.

Namespace: System.ComponentModel
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Visual Basic
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
sourceType
Type: System..::..Type
A Type that represents the type you wish to convert from.

Return Value

true if this converter can perform the conversion; otherwise, false.

See Also

EnumConverter Class
CanConvertFrom Overload
System.ComponentModel Namespace


CanConvertTo Method

[image] [image]

.NET Framework Class Library
EnumConverter..::..CanConvertTo Method
EnumConverter Class See Also

Overload List

 | Name | Description
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)

See Also

EnumConverter Class
EnumConverter Members
System.ComponentModel Namespace


ConvertFrom Method

[image] [image]

.NET Framework Class Library
EnumConverter..::..ConvertFrom Method
EnumConverter Class See Also

Overload List

 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the specified value object to an enumeration object. (Overrides TypeConverter..::..ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)

See Also

EnumConverter Class
EnumConverter Members
System.ComponentModel Namespace


ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

[image]

.NET Framework Class Library
EnumConverter..::..ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)
EnumConverter Class See Also
Converts the specified value object to an enumeration object.

Namespace: System.ComponentModel
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Visual Basic
Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object _
) As Object

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.Globalization..::..CultureInfo
An optional CultureInfo. If not supplied, the current culture is assumed.
value
Type: System..::..Object
The Object to convert.

Return Value

An Object that represents the converted value.

Exceptions

Exception | Condition
System..::..NotSupportedException | The conversion cannot be performed.
System..::..FormatException | value is not a valid value for the target type.

See Also

EnumConverter Class
ConvertFrom Overload
System.ComponentModel Namespace


ConvertTo Method

[image] [image]

.NET Framework Class Library
EnumConverter..::..ConvertTo Method
EnumConverter Class See Also

Overload List

 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified destination type. (Overrides TypeConverter..::..ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)

See Also

EnumConverter Class
EnumConverter Members
System.ComponentModel Namespace


ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

[image]

.NET Framework Class Library
EnumConverter..::..ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)
EnumConverter Class See Also
Converts the given value object to the specified destination type.

Namespace: System.ComponentModel
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Visual Basic
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.Globalization..::..CultureInfo
An optional CultureInfo. If not supplied, the current culture is assumed.
value
Type: System..::..Object
The Object to convert.
destinationType
Type: System..::..Type
The Type to convert the value to.

Return Value

An Object that represents the converted value.

Exceptions

Exception | Condition
System..::..ArgumentException | value is not a valid value for the enumeration.
System..::..ArgumentNullException | destinationType is null.
System..::..NotSupportedException | The conversion cannot be performed.

See Also

EnumConverter Class
ConvertTo Overload
System.ComponentModel Namespace


EnumConverter Properties

[image] [image]

.NET Framework Class Library
EnumConverter Properties
EnumConverter Class See Also

The EnumConverter type exposes the following members.

Properties

 | Name | Description
Protected property | EnumType | Specifies the type of the enumerator this converter is associated with.

See Also

EnumConverter Class
System.ComponentModel Namespace


EnumType Property

[image]

.NET Framework Class Library
EnumConverter..::..EnumType Property
EnumConverter Class See Also
Specifies the type of the enumerator this converter is associated with.

Namespace: System.ComponentModel
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
protected Type EnumType { get; }
Visual Basic
Protected ReadOnly Property EnumType As Type
    Get

Return Value

The type of the enumerator this converter is associated with.

See Also

EnumConverter Class
System.ComponentModel Namespace


System.Windows Namespace

[image]

.NET Framework Class Library
System.Windows Namespace

Structures

 | Structure | Description
Public structure | Vector | Represents a displacement in 2-D space.


Vector Structure

[image]

.NET Framework Class Library
Vector Structure
Members See Also
Represents a displacement in 2-D space.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public struct Vector
Visual Basic
Public Structure Vector

See Also

Vector Members
System.Windows Namespace


Vector Members

[image] [image]

.NET Framework Class Library
Vector Members
Vector Structure Constructors Methods Operators Properties See Also

The Vector type exposes the following members.

Constructors

 | Name | Description
Public method | Vector | Initializes a new instance of the Vector structure.

Methods

 | Name | Description
 | Add(Vector, Point) | Translates the specified point by the specified vector and returns the resulting point.
 | Add(Vector, Vector) | Adds two vectors and returns the result as a Vector structure.
 | AngleBetween | Retrieves the angle, expressed in degrees, between the two specified vectors.
 | CrossProduct | Calculates the cross product of two vectors.
 | Determinant | Calculates the determinant of two vectors.
 | Divide | Divides the specified vector by the specified scalar and returns the result as a Vector.
Public method | Equals(Object) | Determines whether the specified Object is a Vector structure and, if it is, whether it has the same X and Y values as this vector. (Overrides ValueType..::..Equals(Object).)
Public method | Equals(Vector) | Compares two vectors for equality.
 | Equals(Vector, Vector) | Compares the two specified vectors for equality.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this vector. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Multiply(Double, Vector) | Multiplies the specified scalar by the specified vector and returns the resulting Vector.
 | Multiply(Vector, Double) | Multiplies the specified vector by the specified scalar and returns the resulting Vector.
 | Multiply(Vector, Vector) | Calculates the dot product of the two specified vectors and returns the result as a Double.
Public method | Negate | Negates this vector. The vector has the same magnitude as before, but its direction is now opposite.
Public method | Normalize | Normalizes this vector.
 | Subtract | Subtracts the specified vector from another specified vector.
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Operators

Name | Description
Addition(Vector, Point) | Translates a point by the specified vector and returns the resulting point.
Addition(Vector, Vector) | Adds two vectors and returns the result as a vector.
Division | Divides the specified vector by the specified scalar and returns the resulting vector.
Equality | Compares two vectors for equality.
Explicit Narrowing Explicit Explicit Explicit (Vector to Point) | Creates a Point with the X and Y values of this vector.
Explicit Narrowing Explicit Explicit Explicit (Vector to Size) | Creates a Size from the offsets of this vector.
Inequality | Compares two vectors for inequality.
Multiply(Double, Vector) | Multiplies the specified scalar by the specified vector and returns the resulting vector.
Multiply(Vector, Double) | Multiplies the specified vector by the specified scalar and returns the resulting vector.
Multiply(Vector, Vector) | Calculates the dot product of the two specified vector structures and returns the result as a Double.
Subtraction | Subtracts one specified vector from another.
UnaryNegation | Negates the specified vector.

Properties

 | Name | Description
Public property | Length | Gets the length of this vector.
Public property | LengthSquared | Gets the square of the length of this vector.
Public property | X | Gets or sets the X component of this vector.
Public property | Y | Gets or sets the Y component of this vector.

See Also

Vector Structure
System.Windows Namespace


Vector Constructor

[image]

.NET Framework Class Library
Vector Constructor
Vector Structure See Also
Initializes a new instance of the Vector structure.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public Vector(
    double x,
    double y
)
Visual Basic
Public Sub New ( _
    x As Double, _
    y As Double _
)

Parameters

x
Type: System..::..Double
The X-offset of the new Vector.
y
Type: System..::..Double
The Y-offset of the new Vector.

See Also

Vector Structure
System.Windows Namespace


Vector Methods

[image] [image]

.NET Framework Class Library
Vector Methods
Vector Structure See Also

The Vector type exposes the following members.

Methods

 | Name | Description
 | Add(Vector, Point) | Translates the specified point by the specified vector and returns the resulting point.
 | Add(Vector, Vector) | Adds two vectors and returns the result as a Vector structure.
 | AngleBetween | Retrieves the angle, expressed in degrees, between the two specified vectors.
 | CrossProduct | Calculates the cross product of two vectors.
 | Determinant | Calculates the determinant of two vectors.
 | Divide | Divides the specified vector by the specified scalar and returns the result as a Vector.
Public method | Equals(Object) | Determines whether the specified Object is a Vector structure and, if it is, whether it has the same X and Y values as this vector. (Overrides ValueType..::..Equals(Object).)
Public method | Equals(Vector) | Compares two vectors for equality.
 | Equals(Vector, Vector) | Compares the two specified vectors for equality.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this vector. (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Multiply(Double, Vector) | Multiplies the specified scalar by the specified vector and returns the resulting Vector.
 | Multiply(Vector, Double) | Multiplies the specified vector by the specified scalar and returns the resulting Vector.
 | Multiply(Vector, Vector) | Calculates the dot product of the two specified vectors and returns the result as a Double.
Public method | Negate | Negates this vector. The vector has the same magnitude as before, but its direction is now opposite.
Public method | Normalize | Normalizes this vector.
 | Subtract | Subtracts the specified vector from another specified vector.
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

Vector Structure
System.Windows Namespace


Add Method

[image] [image]

.NET Framework Class Library
Vector..::..Add Method
Vector Structure See Also

Overload List

Name | Description
Add(Vector, Point) | Translates the specified point by the specified vector and returns the resulting point.
Add(Vector, Vector) | Adds two vectors and returns the result as a Vector structure.

See Also

Vector Structure
Vector Members
System.Windows Namespace


Add Method (Vector, Point)

[image]

.NET Framework Class Library
Vector..::..Add Method (Vector, Point)
Vector Structure See Also
Translates the specified point by the specified vector and returns the resulting point.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static Point Add(
    Vector vector,
    Point point
)
Visual Basic
Public Shared Function Add ( _
    vector As Vector, _
    point As Point _
) As Point

Parameters

vector
Type: System.Windows..::..Vector
The amount to translate the specified point.
point
Type: System.Windows..::..Point
The point to translate.

Return Value

The result of translating point by vector.

See Also

Vector Structure
Add Overload
System.Windows Namespace


Add Method (Vector, Vector)

[image]

.NET Framework Class Library
Vector..::..Add Method (Vector, Vector)
Vector Structure See Also
Adds two vectors and returns the result as a Vector structure.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static Vector Add(
    Vector vector1,
    Vector vector2
)
Visual Basic
Public Shared Function Add ( _
    vector1 As Vector, _
    vector2 As Vector _
) As Vector

Parameters

vector1
Type: System.Windows..::..Vector
The first vector to add.
vector2
Type: System.Windows..::..Vector
The second vector to add.

Return Value

The sum of vector1 and vector2.

See Also

Vector Structure
Add Overload
System.Windows Namespace


AngleBetween Method

[image]

.NET Framework Class Library
Vector..::..AngleBetween Method
Vector Structure See Also
Retrieves the angle, expressed in degrees, between the two specified vectors.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static double AngleBetween(
    Vector vector1,
    Vector vector2
)
Visual Basic
Public Shared Function AngleBetween ( _
    vector1 As Vector, _
    vector2 As Vector _
) As Double

Parameters

vector1
Type: System.Windows..::..Vector
The first vector to evaluate.
vector2
Type: System.Windows..::..Vector
The second vector to evaluate.

Return Value

The angle, in degrees, between vector1 and vector2.

See Also

Vector Structure
System.Windows Namespace


CrossProduct Method

[image]

.NET Framework Class Library
Vector..::..CrossProduct Method
Vector Structure See Also
Calculates the cross product of two vectors.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static double CrossProduct(
    Vector vector1,
    Vector vector2
)
Visual Basic
Public Shared Function CrossProduct ( _
    vector1 As Vector, _
    vector2 As Vector _
) As Double

Parameters

vector1
Type: System.Windows..::..Vector
The first vector to evaluate.
vector2
Type: System.Windows..::..Vector
The second vector to evaluate.

Return Value

The cross product of vector1 and vector2. The following formula is used to calculate the cross product: (Vector1.X * Vector2.Y) - (Vector1.Y * Vector2.X)

See Also

Vector Structure
System.Windows Namespace


Determinant Method

[image]

.NET Framework Class Library
Vector..::..Determinant Method
Vector Structure See Also
Calculates the determinant of two vectors.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static double Determinant(
    Vector vector1,
    Vector vector2
)
Visual Basic
Public Shared Function Determinant ( _
    vector1 As Vector, _
    vector2 As Vector _
) As Double

Parameters

vector1
Type: System.Windows..::..Vector
The first vector to evaluate.
vector2
Type: System.Windows..::..Vector
The second vector to evaluate.

Return Value

The determinant of vector1 and vector2.

See Also

Vector Structure
System.Windows Namespace


Divide Method

[image]

.NET Framework Class Library
Vector..::..Divide Method
Vector Structure See Also
Divides the specified vector by the specified scalar and returns the result as a Vector.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static Vector Divide(
    Vector vector,
    double scalar
)
Visual Basic
Public Shared Function Divide ( _
    vector As Vector, _
    scalar As Double _
) As Vector

Parameters

vector
Type: System.Windows..::..Vector
The vector structure to divide.
scalar
Type: System..::..Double
The amount by which vector is divided.

Return Value

The result of dividing vector by scalar.

See Also

Vector Structure
System.Windows Namespace


Equals Method

[image] [image]

.NET Framework Class Library
Vector..::..Equals Method
Vector Structure See Also

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is a Vector structure and, if it is, whether it has the same X and Y values as this vector. (Overrides ValueType..::..Equals(Object).)
Public method | Equals(Vector) | Compares two vectors for equality.
 | Equals(Vector, Vector) | Compares the two specified vectors for equality.

See Also

Vector Structure
Vector Members
System.Windows Namespace


Equals Method (Object)

[image]

.NET Framework Class Library
Vector..::..Equals Method (Object)
Vector Structure See Also
Determines whether the specified Object is a Vector structure and, if it is, whether it has the same X and Y values as this vector.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic
Public Overrides Function Equals ( _
    o As Object _
) As Boolean

Parameters

o
Type: System..::..Object
The vector to compare.

Return Value

true if o is a Vector and has the same X and Y values as this vector; otherwise, false.

See Also

Vector Structure
Equals Overload
System.Windows Namespace


Equals Method (Vector)

[image]

.NET Framework Class Library
Vector..::..Equals Method (Vector)
Vector Structure See Also
Compares two vectors for equality.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public bool Equals(
    Vector value
)
Visual Basic
Public Function Equals ( _
    value As Vector _
) As Boolean

Parameters

value
Type: System.Windows..::..Vector
The vector to compare with this vector.

Return Value

true if value has the same X and Y values as this vector; otherwise, false.

See Also

Vector Structure
Equals Overload
System.Windows Namespace


Equals Method (Vector, Vector)

[image]

.NET Framework Class Library
Vector..::..Equals Method (Vector, Vector)
Vector Structure See Also
Compares the two specified vectors for equality.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static bool Equals(
    Vector vector1,
    Vector vector2
)
Visual Basic
Public Shared Function Equals ( _
    vector1 As Vector, _
    vector2 As Vector _
) As Boolean

Parameters

vector1
Type: System.Windows..::..Vector
The first vector to compare.
vector2
Type: System.Windows..::..Vector
The second vector to compare.

Return Value

true if t he X and Y components of vector1 and vector2 are equal; otherwise, false.

See Also

Vector Structure
Equals Overload
System.Windows Namespace


GetHashCode Method

[image]

.NET Framework Class Library
Vector..::..GetHashCode Method
Vector Structure See Also
Returns the hash code for this vector.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

Return Value

The hash code for this instance.

See Also

Vector Structure
System.Windows Namespace


Multiply Method

[image] [image]

.NET Framework Class Library
Vector..::..Multiply Method
Vector Structure See Also

Overload List

Name | Description
Multiply(Double, Vector) | Multiplies the specified scalar by the specified vector and returns the resulting Vector.
Multiply(Vector, Double) | Multiplies the specified vector by the specified scalar and returns the resulting Vector.
Multiply(Vector, Vector) | Calculates the dot product of the two specified vectors and returns the result as a Double.

See Also

Vector Structure
Vector Members
System.Windows Namespace


Multiply Method (Double, Vector)

[image]

.NET Framework Class Library
Vector..::..Multiply Method (Double, Vector)
Vector Structure See Also
Multiplies the specified scalar by the specified vector and returns the resulting Vector.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static Vector Multiply(
    double scalar,
    Vector vector
)
Visual Basic
Public Shared Function Multiply ( _
    scalar As Double, _
    vector As Vector _
) As Vector

Parameters

scalar
Type: System..::..Double
The scalar to multiply.
vector
Type: System.Windows..::..Vector
The vector to multiply.

Return Value

The result of multiplying scalar and vector.

See Also

Vector Structure
Multiply Overload
System.Windows Namespace


Multiply Method (Vector, Double)

[image]

.NET Framework Class Library
Vector..::..Multiply Method (Vector, Double)
Vector Structure See Also
Multiplies the specified vector by the specified scalar and returns the resulting Vector.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static Vector Multiply(
    Vector vector,
    double scalar
)
Visual Basic
Public Shared Function Multiply ( _
    vector As Vector, _
    scalar As Double _
) As Vector

Parameters

vector
Type: System.Windows..::..Vector
The vector to multiply.
scalar
Type: System..::..Double
The scalar to multiply.

Return Value

The result of multiplying vector and scalar.

See Also

Vector Structure
Multiply Overload
System.Windows Namespace


Multiply Method (Vector, Vector)

[image]

.NET Framework Class Library
Vector..::..Multiply Method (Vector, Vector)
Vector Structure See Also
Calculates the dot product of the two specified vectors and returns the result as a Double.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static double Multiply(
    Vector vector1,
    Vector vector2
)
Visual Basic
Public Shared Function Multiply ( _
    vector1 As Vector, _
    vector2 As Vector _
) As Double

Parameters

vector1
Type: System.Windows..::..Vector
The first vector to multiply.
vector2
Type: System.Windows..::..Vector
The second vector structure to multiply.

Return Value

A Double containing the scalar dot product of vector1 and vector2, which is calculated using the following formula: (vector1.X * vector2.X) + (vector1.Y * vector2.Y)

See Also

Vector Structure
Multiply Overload
System.Windows Namespace


Negate Method

[image]

.NET Framework Class Library
Vector..::..Negate Method
Vector Structure See Also
Negates this vector. The vector has the same magnitude as before, but its direction is now opposite.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void Negate()
Visual Basic
Public Sub Negate

See Also

Vector Structure
System.Windows Namespace


Normalize Method

[image]

.NET Framework Class Library
Vector..::..Normalize Method
Vector Structure See Also
Normalizes this vector.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public void Normalize()
Visual Basic
Public Sub Normalize

See Also

Vector Structure
System.Windows Namespace


Subtract Method

[image]

.NET Framework Class Library
Vector..::..Subtract Method
Vector Structure See Also
Subtracts the specified vector from another specified vector.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static Vector Subtract(
    Vector vector1,
    Vector vector2
)
Visual Basic
Public Shared Function Subtract ( _
    vector1 As Vector, _
    vector2 As Vector _
) As Vector

Parameters

vector1
Type: System.Windows..::..Vector
The vector from which vector2 is subtracted.
vector2
Type: System.Windows..::..Vector
The vector to subtract from vector1.

Return Value

The difference between vector1 and vector2.

See Also

Vector Structure
System.Windows Namespace


Vector Operators and Type Conversions

[image] [image]

.NET Framework Class Library
Vector Operators and Type Conversions
Vector Structure See Also

The Vector type exposes the following members.

Operators

Name | Description
Addition(Vector, Point) | Translates a point by the specified vector and returns the resulting point.
Addition(Vector, Vector) | Adds two vectors and returns the result as a vector.
Division | Divides the specified vector by the specified scalar and returns the resulting vector.
Equality | Compares two vectors for equality.
Explicit Narrowing Explicit Explicit Explicit (Vector to Point) | Creates a Point with the X and Y values of this vector.
Explicit Narrowing Explicit Explicit Explicit (Vector to Size) | Creates a Size from the offsets of this vector.
Inequality | Compares two vectors for inequality.
Multiply(Double, Vector) | Multiplies the specified scalar by the specified vector and returns the resulting vector.
Multiply(Vector, Double) | Multiplies the specified vector by the specified scalar and returns the resulting vector.
Multiply(Vector, Vector) | Calculates the dot product of the two specified vector structures and returns the result as a Double.
Subtraction | Subtracts one specified vector from another.
UnaryNegation | Negates the specified vector.

See Also

Vector Structure
System.Windows Namespace


Addition Operator

[image] [image]

.NET Framework Class Library
Vector..::..Addition Operator
Vector Structure See Also

Overload List

Name | Description
Addition(Vector, Point) | Translates a point by the specified vector and returns the resulting point.
Addition(Vector, Vector) | Adds two vectors and returns the result as a vector.

See Also

Vector Structure
Vector Members
System.Windows Namespace


Addition Operator (Vector, Point)

[image]

.NET Framework Class Library
Vector..::..Addition Operator (Vector, Point)
Vector Structure See Also
Translates a point by the specified vector and returns the resulting point.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static Point operator +(
    Vector vector,
    Point point
)
Visual Basic
Public Shared Operator + ( _
    vector As Vector, _
    point As Point _
) As Point

Parameters

vector
Type: System.Windows..::..Vector
The vector used to translate point.
point
Type: System.Windows..::..Point
The point to translate.

Return Value

The result of translating point by vector.

See Also

Vector Structure
Addition Overload
System.Windows Namespace


Addition Operator (Vector, Vector)

[image]

.NET Framework Class Library
Vector..::..Addition Operator (Vector, Vector)
Vector Structure See Also
Adds two vectors and returns the result as a vector.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static Vector operator +(
    Vector vector1,
    Vector vector2
)
Visual Basic
Public Shared Operator + ( _
    vector1 As Vector, _
    vector2 As Vector _
) As Vector

Parameters

vector1
Type: System.Windows..::..Vector
The first vector to add.
vector2
Type: System.Windows..::..Vector
The second vector to add.

Return Value

The sum of vector1 and vector2.

See Also

Vector Structure
Addition Overload
System.Windows Namespace


Division Operator

[image]

.NET Framework Class Library
Vector..::..Division Operator
Vector Structure See Also
Divides the specified vector by the specified scalar and returns the resulting vector.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static Vector operator /(
    Vector vector,
    double scalar
)
Visual Basic
Public Shared Operator / ( _
    vector As Vector, _
    scalar As Double _
) As Vector

Parameters

vector
Type: System.Windows..::..Vector
The vector to divide.
scalar
Type: System..::..Double
The scalar by which vector will be divided.

Return Value

The result of dividing vector by scalar.

See Also

Vector Structure
System.Windows Namespace


Equality Operator

[image]

.NET Framework Class Library
Vector..::..Equality Operator
Vector Structure See Also
Compares two vectors for equality.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static bool operator ==(
    Vector vector1,
    Vector vector2
)
Visual Basic
Public Shared Operator = ( _
    vector1 As Vector, _
    vector2 As Vector _
) As Boolean

Parameters

vector1
Type: System.Windows..::..Vector
The first vector to compare.
vector2
Type: System.Windows..::..Vector
The second vector to compare.

Return Value

true if the X and Y components of vector1 and vector2 are equal; otherwise, false.

See Also

Vector Structure
System.Windows Namespace


Explicit Conversion Operators

[image] [image]

.NET Framework Class Library
Vector ExplicitNarrowingExplicitExplicitExplicit Conversion Operators
Vector Structure See Also

Overload List

Name | Description
Explicit Narrowing Explicit Explicit Explicit (Vector to Point) | Creates a Point with the X and Y values of this vector.
Explicit Narrowing Explicit Explicit Explicit (Vector to Size) | Creates a Size from the offsets of this vector.

See Also

Vector Structure
Vector Members
System.Windows Namespace


Explicit Conversion (Vector to Point)

[image]

.NET Framework Class Library
Vector ExplicitNarrowingExplicitExplicitExplicit Conversion (Vector to Point)
Vector Structure See Also
Creates a Point with the X and Y values of this vector.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static explicit operator Point (
    Vector vector
)
Visual Basic
Public Shared Narrowing Operator CType ( _
    vector As Vector _
) As Point

Parameters

vector
Type: System.Windows..::..Vector
The vector to convert.

Return Value

A point with X- and Y-coordinate values equal to the X and Y offset values of vector.

See Also

Vector Structure
ExplicitNarrowingExplicitExplicitExplicit Overload
System.Windows Namespace


Explicit Conversion (Vector to Size)

[image]

.NET Framework Class Library
Vector ExplicitNarrowingExplicitExplicitExplicit Conversion (Vector to Size)
Vector Structure See Also
Creates a Size from the offsets of this vector.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static explicit operator Size (
    Vector vector
)
Visual Basic
Public Shared Narrowing Operator CType ( _
    vector As Vector _
) As Size

Parameters

vector
Type: System.Windows..::..Vector
The vector to convert.

Return Value

A Size with a Width equal to the absolute value of this vector's X property and a Height equal to the absolute value of this vector's Y property.

See Also

Vector Structure
ExplicitNarrowingExplicitExplicitExplicit Overload
System.Windows Namespace


Inequality Operator

[image]

.NET Framework Class Library
Vector..::..Inequality Operator
Vector Structure See Also
Compares two vectors for inequality.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static bool operator !=(
    Vector vector1,
    Vector vector2
)
Visual Basic
Public Shared Operator <> ( _
    vector1 As Vector, _
    vector2 As Vector _
) As Boolean

Parameters

vector1
Type: System.Windows..::..Vector
The first vector to compare.
vector2
Type: System.Windows..::..Vector
The second vector to compare.

Return Value

true if the X and Y components of vector1 and vector2 are different; otherwise, false.

See Also

Vector Structure
System.Windows Namespace


Multiply Operator

[image] [image]

.NET Framework Class Library
Vector..::..Multiply Operator
Vector Structure See Also

Overload List

Name | Description
Multiply(Double, Vector) | Multiplies the specified scalar by the specified vector and returns the resulting vector.
Multiply(Vector, Double) | Multiplies the specified vector by the specified scalar and returns the resulting vector.
Multiply(Vector, Vector) | Calculates the dot product of the two specified vector structures and returns the result as a Double.

See Also

Vector Structure
Vector Members
System.Windows Namespace


Multiply Operator (Double, Vector)

[image]

.NET Framework Class Library
Vector..::..Multiply Operator (Double, Vector)
Vector Structure See Also
Multiplies the specified scalar by the specified vector and returns the resulting vector.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static Vector operator *(
    double scalar,
    Vector vector
)
Visual Basic
Public Shared Operator * ( _
    scalar As Double, _
    vector As Vector _
) As Vector

Parameters

scalar
Type: System..::..Double
The scalar to multiply.
vector
Type: System.Windows..::..Vector
The vector to multiply.

Return Value

The result of multiplying scalar and vector.

See Also

Vector Structure
Multiply Overload
System.Windows Namespace


Multiply Operator (Vector, Double)

[image]

.NET Framework Class Library
Vector..::..Multiply Operator (Vector, Double)
Vector Structure See Also
Multiplies the specified vector by the specified scalar and returns the resulting vector.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static Vector operator *(
    Vector vector,
    double scalar
)
Visual Basic
Public Shared Operator * ( _
    vector As Vector, _
    scalar As Double _
) As Vector

Parameters

vector
Type: System.Windows..::..Vector
The vector to multiply.
scalar
Type: System..::..Double
The scalar to multiply.

Return Value

The result of multiplying vector and scalar.

See Also

Vector Structure
Multiply Overload
System.Windows Namespace


Multiply Operator (Vector, Vector)

[image]

.NET Framework Class Library
Vector..::..Multiply Operator (Vector, Vector)
Vector Structure See Also
Calculates the dot product of the two specified vector structures and returns the result as a Double.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static double operator *(
    Vector vector1,
    Vector vector2
)
Visual Basic
Public Shared Operator * ( _
    vector1 As Vector, _
    vector2 As Vector _
) As Double

Parameters

vector1
Type: System.Windows..::..Vector
The first vector to multiply.
vector2
Type: System.Windows..::..Vector
The second vector to multiply.

Return Value

Returns a Double containing the scalar dot product of vector1 and vector2, which is calculated using the following formula: vector1.X * vector2.X + vector1.Y * vector2.Y

See Also

Vector Structure
Multiply Overload
System.Windows Namespace


Subtraction Operator

[image]

.NET Framework Class Library
Vector..::..Subtraction Operator
Vector Structure See Also
Subtracts one specified vector from another.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static Vector operator -(
    Vector vector1,
    Vector vector2
)
Visual Basic
Public Shared Operator - ( _
    vector1 As Vector, _
    vector2 As Vector _
) As Vector

Parameters

vector1
Type: System.Windows..::..Vector
The vector from which vector2 is subtracted.
vector2
Type: System.Windows..::..Vector
The vector to subtract from vector1.

Return Value

The difference between vector1 and vector2.

See Also

Vector Structure
System.Windows Namespace


UnaryNegation Operator

[image]

.NET Framework Class Library
Vector..::..UnaryNegation Operator
Vector Structure See Also
Negates the specified vector.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public static Vector operator -(
    Vector vector
)
Visual Basic
Public Shared Operator - ( _
    vector As Vector _
) As Vector

Parameters

vector
Type: System.Windows..::..Vector
The vector to negate.

Return Value

A vector with X and Y values opposite of the X and Y values of vector.

See Also

Vector Structure
System.Windows Namespace


Vector Properties

[image] [image]

.NET Framework Class Library
Vector Properties
Vector Structure See Also

The Vector type exposes the following members.

Properties

 | Name | Description
Public property | Length | Gets the length of this vector.
Public property | LengthSquared | Gets the square of the length of this vector.
Public property | X | Gets or sets the X component of this vector.
Public property | Y | Gets or sets the Y component of this vector.

See Also

Vector Structure
System.Windows Namespace


Length Property

[image]

.NET Framework Class Library
Vector..::..Length Property
Vector Structure See Also
Gets the length of this vector.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public double Length { get; }
Visual Basic
Public ReadOnly Property Length As Double
    Get

Return Value

The length of this vector.

See Also

Vector Structure
System.Windows Namespace


LengthSquared Property

[image]

.NET Framework Class Library
Vector..::..LengthSquared Property
Vector Structure See Also
Gets the square of the length of this vector.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public double LengthSquared { get; }
Visual Basic
Public ReadOnly Property LengthSquared As Double
    Get

Return Value

The square of the Length of this vector.

See Also

Vector Structure
System.Windows Namespace


X Property

[image]

.NET Framework Class Library
Vector..::..X Property
Vector Structure See Also
Gets or sets the X component of this vector.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public double X { get; set; }
Visual Basic
Public Property X As Double
    Get
    Set

Return Value

The X component of this vector. The default value is 0.

See Also

Vector Structure
System.Windows Namespace


Y Property

[image]

.NET Framework Class Library
Vector..::..Y Property
Vector Structure See Also
Gets or sets the Y component of this vector.

Namespace: System.Windows
Assembly: C1.Silverlight.Schedule (in C1.Silverlight.Schedule.dll)

Syntax

C#
public double Y { get; set; }
Visual Basic
Public Property Y As Double
    Get
    Set

Return Value

The Y component of this vector. The default value is 0.

See Also

Vector Structure
System.Windows Namespace


Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


Search ComponentOne Search ComponentOne