Welcome to ComponentOne Spell for .NET

ComponentOne Spell for .NET E-mail sent to documentation@componentone.com is for documentation feedback only. We welcome any suggestions to help improve our documentation.

Welcome to ComponentOne Spell for .NET

Previous Next

Welcome to ComponentOne Spell™ for .NET. Now you can add spell-checking and thesaurus functionality to any Visual Basic® project using Spell for .NET or its companion, Thesaurus for .NET. If you like Spell for .NET, you can check out our other products by visiting our web site at http://www.componentone.com.

ComponentOne has a user-friendly distribution policy. We want every programmer to obtain a copy of Spell for .NET to try for as long as they wish. Those who like the product and find it useful may buy a license for a reasonable price. The only restriction is that unlicensed copies of Spell for .NET will display a ComponentOne banner every time they are loaded to remind developers to license the product.

We are confident that you'll like ComponentOne Spell for .NET. If you have any suggestions or ideas for new features that you'd like to see included in a future version, or ideas about new components, please call us or write:

Corporate Headquarters

ComponentOne LLC
201 South Highland Avenue
3rd Floor
Pittsburgh, PA 15206 USA 412.681.4343
412.681.4384 (Fax)

http://www.componentone.com

Overview

What's New in ComponentOne Spell for .NET

Installing Spell for .NET and Thesaurus for .NET

END-USER LICENSE AGREEMENT FOR COMPONENTONE SOFTWARE

Licensing FAQs

Technical Support

Redistributable Files

Namespaces

Creating a .NET Project

Adding the C1Spell Components to the Toolbox

Migrating a C1Spell Project to Visual Studio 2005

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


Overview

Overview

ComponentOne Spell for .NET is a library consisting of C1Spell and C1Thesaurus .NET components. These components allow you to add spell-checking and thesaurus functionality to any Visual Basic application.

Both components are available as 32-bit .NET components.


Overview of the C1Spell component

Overview of the C1Spell component

Just place a C1Spell component on your form and you instantly have the power of ComponentOne Spell for .NET's extensive American English word dictionary. The C1Spell component features a built-in spelling dialog box, the ability to generate suggestions for bad words, the ability to create new main dictionaries based on existing main dictionaries (such as those created in Microsoft Word), the ability to ignore all or change all bad words, and utilities to build and maintain dictionaries. Some of the features of the C1Spell component are:

· Ability to link C1Spell to other components to provide automatic spell checking as the user types.

· Little code is needed to add spell checking to your Visual Basic application.

· Built-in spelling dialog box.

· Ability to check individual words, sentences or paragraphs.

· Ability to generate alternate spellings for bad words.

· Ability to create new dictionaries based on existing ones.

· Support for custom dictionaries.


Overview of the C1Thesaurus component

Overview of the C1Thesaurus component

Place a C1Thesaurus componenton your form and gain the ability to provide users with a professional thesaurus similar to the one provided by Microsoft Word. Some of the features of the C1Thesaurus componentare:

· Little code is needed to add thesaurus functionality to your Visual Basic application.

· Built-in automatic dialog box.

· Ability to create new thesaurus files based on existing thesaurus files.

IMPORTANT: ComponentOne reserves the right to change the dictionary and thesaurus file formats with new versions of Spell for .NET. In these cases, a conversion utility will be supplied at no charge to our customers who upgrade.


Features

Features

This section summarizes the most recent features in ComponentOne Spell for .NET. If you are familiar with previous versions of VSSpell, this section will get you up to speed quickly. For details on each new feature, check the main body of the documentation.

Default Options Dialog Box

Use this dialog box to set spelling properties that will determine what occurs during a spell check. For example, checking the Suggest Corrections checkbox in the Options dialog box allows words to be suggested as replacements when C1Spell finds a misspelled word. The Options dialog box also allows you to add or remove custom dictionaries.

Default Context Menu

The context menu appears when you right-click a misspelled word. The menu offers a list of suggestions, or you can Ignore All, use AutoCorrect or choose a word from the Spelling dialog box.

C1TextBox Support

C1Spell now supports the C1TextBox control, which means the CheckControl or CheckTyping methods can be used to check its spelling.

New SeparateChars Property

The new SeparateChars property allows you to add characters to the SeparateChars array. You can specify new characters so they will not be considered misspelled during a spell check.

New PartialClear Method

Use the PartialClear method to keep data from being cleared from the IgnoreAll and ChangeAllPair arrays. All other internal settings will be cleared.

As-you-type Spell Checking (regular text boxes and RTF)

Use the CheckTyping method to link the C1Spell component to any textbox or rich textbox. C1Spell will monitor the component as the user types, underlining spelling mistakes with a wiggly red line just like Microsoft Word, or trap the TypingError event and provide users with custom warnings when they make typing mistakes.

AutoLink to RichTextBox Components

C1Spell can be linked to regular TextBox or to RichTextBox controls. It will correct spelling mistakes without disturbing the text format.

Unlimited Text Length

C1Spell component can spell check entire documents at once. You may use the CheckControl method to link C1Spell to regular or rich text editors with documents of unlimited length.

New CheckControl Method

Use the new CheckControl method to link C1Spell component to a control derived from TextBoxBase. While spell checking, C1Spell will automatically highlight offending words when the user interacts with the built-in Spelling dialog box. The new CheckControl method has replaced the old CheckWindow method.

Improved Spelling Dialog Box

C1Spell component allows you to set the font to be used in the Spelling dialog box, so it looks consistent with your application. Also, the dialog has a checkbox that users may click to enable or disable suggestions. Finally, the new Spelling dialog box remembers its position when the user moves it around the screen, making it much easier and more intuitive to use.

Dependency Free

C1Spell component does not depend on any additional .dlls. To distribute applications that use C1Spell, simply include C1SPELL in your setup.

Larger Dictionary (250,000+ words)

C1Spell component has a larger built-in dictionary (over four times the entries than in the previous versions).


What's New in ComponentOne Spell for .NET

What's New in ComponentOne Spell for .NET

This documentation was last revised on November 1, 2005.

Overview of What's New in ComponentOne Spell for .NET

The task-based help for C1Spell has recently been added, allowing developers to concentrate on important application-specific tasks.


Feature Overview

Feature Overview

Spanish science dictionary has recently been added to C1Spell for .NET which allows the user more flexibility.


Task-Based Help Overview

Task-Based Help Overview

The following C1Spell task-based help topics have been added:

Task-Based Help | Description
Show a red sign | This topic shows how to use a red sign to signal misspelled words as you type. This topic uses the CheckTyping method and calls the TypingError event
Pop-up menu | This topic demonstrates how to provide as-you-type spell checking using the pop-up menu.
Window mode | This topic demonstrate the methods, good for windows that hold long documents, of check spelling using the C1Spell class.


Installing Spell for .NET and Thesaurus for .NET

Installing Spell for .NET and Thesaurus for .NET

To install the Spell for .NET, run the C1UI.msi installation file provided in the distribution CD (or downloaded from the web). If the installation is being performed from the distribution CD, a menu should appear when it is placed in the computer. From the menu, click the "Install Software" link for the User Interface Components, and follow the instructions. It is important to note that selecting the "Typical" installation type will install all of the ComponentOne controls and components within the msi and their supporting files. If it is the wish of the developer to install only the Spell, select the "Custom" installation type and remove those features that are not desired.

Spell for .NET Setup Files

System Requirements

Installing Demonstration Versions

Uninstalling C1Spell for .NET

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


Spell for .NET Setup Files

Spell for .NET Setup Files

The installation program will create a directory called "ComponentOne Studio.NET" under "Program Files". This directory will contain the following subdirectories:

bin | Contains copies of all binaries (DLLs, EXEs) in the ComponentOne Visual Studio.NET package.
Common | Contains support and data files that are used by many of the demo programs.
Help | Contains online documentation for all Studio components.
C1Spell | Contains samples for C1Spell.


Spell for .NET files

Spell for .NET files

C1SPELL | C1Spell 32-bit custom component for Visual Basic.
C1SP_AE.DCT | American English 250,000+ word dictionary.
C1SP_AEC.DCT | Compact American English word dictionary.
C1SP_BE.DCT | British English word dictionary.
C1SP_BEC.DCT | Compact British English word dictionary.
C1SP_ES.DCT | Spanish dictionary.
C1SP_NL.DCT | Dutch dictionary.
C1SPELLNET.CHM | Help file used by the C1Spell and C1Thesaurus custom components.
SAMPLES\*.VB | Visual Basic example form file.
SAMPLES\*.VBPROJ | Visual Basic example project file.
SAMPLES\*.SLN | Visual Basic example solution file.
SAMPLES\*.RESX | Visual Basic example resource template file.
OLE.RTF | Word file loaded for spell checking.
README.TXT | Release notes since the manual was printed.


Thesaurus for .NET files

Thesaurus for .NET files

C1THESAURUS | C1Thesaurus 32-bit custom component for Visual Basic.
C1TH_AE.THE | American English thesaurus.
SAMPLES\*.VB | Visual Basic example form file.
SAMPLES\*.VBPROJ | Visual Basic example project file.
SAMPLES\*.SLN | Visual Basic example solution file.
SAMPLES\*.RESX | Visual Basic example resource template file.
README.TXT | Release notes since the manual was printed.


System Requirements

System Requirements

· Operating Systems:

Windows 2000

Windows 2003 Server

Windows NT 4

Windows XP, SP1, SP2

· Environments:

.NET Framework 1.0

.NET Framework1.1

C# .NET

Delphi

Visual Basic .NET

· Environments (Visual Studio 2005):

.NET Framework 2.0

C# .NET

Visual Basic .NET

· Hard Disk Space: 18 MB of hard disk space for storage of the software

· Disc Drive: CD or DVD-ROM drive if installing from CD


Installing Demonstration Versions

Installing Demonstration Versions

If you wish to try C1Spell for .NET or any of our other products and do not have a registration key, follow the steps through the installation wizard and use the default serial number.

The only difference between unregistered (demonstration) and registered (purchased) versions of our products is that registered versions will stamp every application you compile so a ComponentOne banner will not appear when your users run the applications.


Uninstalling C1Spell for .NET

Uninstalling C1Spell for .NET

To uninstall C1Spell for .NET, open Control Panel and select the Add or Remove Programs. Select C1Spell for .NET and click the Remove button.


END-USER LICENSE AGREEMENT FOR COMPONENTONE SOFTWARE

END-USER LICENSE AGREEMENT FOR COMPONENTONE SOFTWARE

IMPORTANT-READ CAREFULLY: This End User License Agreement (this "EULA") contains the terms and conditions that govern your use of the SOFTWARE (as defined below) and imposes material limitations to your rights. You should read this EULA carefully and treat it as valuable property.

I. THIS EULA.

1. Software Covered by this EULA. This EULA governs your use of the ComponentOne, LLC ("C1") software product(s) enclosed or otherwise accompanied herewith (individually and collectively, the "SOFTWARE"). The term "SOFTWARE" includes, to the extent provided by C1: 1) any revisions, updates and/or upgrades thereto; 2) any data, image or executable files, databases, data engines, computer software, or similar items customarily used or distributed with computer software products; 3) anything in any form whatsoever intended to be used with or in conjunction with the SOFTWARE; and 4) any associated media, documentation (including physical, electronic and online) and printed materials (the "Documentation").

2. This EULA is a Legally Binding Agreement Between You and C1. If you are acting as an agent of a company or another legal person, such as an officer or other employee acting for your employer, then "you" and "your" mean your principal, the entity or other legal person for whom you are acting. However, importantly, even if you are acting as an agent for another, you may still be personally liable for violation of federal and State laws, such as copyright infringement.

By signifying your acceptance of the terms of this EULA, you intend to be, and hereby are, legally bound to this EULA to the same extent as if C1 and you physically signed this EULA. By installing, copying, or otherwise using the SOFTWARE, you agree to be bound by all the terms and conditions of this EULA. If you do not agree to all of such terms and conditions, you may not install or use the SOFTWARE. If you do not agree with any of the terms herewith and, for whatever reason, installation has begun or has been completed, you should cancel installation or un-install the SOFTWARE, as the case may be. Furthermore, you should promptly return the SOFTWARE to the place of business from which you obtained it in accordance with any return policies of such place of business. Return policies may vary among resellers; therefore you must comply with the return policies of your supplier as you agreed at the point of purchase. If the place of business from which you purchased the SOFTWARE does not honor a full refund for a period of thirty (30) days from the date of purchase, you may then return the SOFTWARE directly to C1 for a refund provided that such returns is authorized within the same thirty (30) days time period. To return the product directly to C1, you must first obtain a Return Authorization Number by contacting C1, and you must forward to C1 all items purchased, including the proof of purchase. The return must be postage-prepaid, and post-marked within thirty (30) days from the proof of purchase, time being of the essence. The return option to C1 is only available to the original purchaser of an unopened factory packaged item.

II. YOUR LICENSE TO DEVELOP AND TO DISTRIBUTE.

As provided in more detail below, this EULA grants you two licenses: 1) a license to use the SOFTWARE to develop other software products (the "Development License"); and 2) a license to use and/or distribute the Developed Software (the "Distribution License"). These licenses (individually and collectively, the "Licenses") are explained and defined in more detail below.

1. Definitions. The following terms have the respective meanings as used in this EULA:

"Network Server" means a computer with one or more computer central processing units (CPU's) that operates for the purpose of serving other computers logically or physically connected to it, including, but not limited to, other computers connected to it on an internal network, intranet or the Internet.

"Web Server" means a type of Network Server that serves other computers which, are specifically connected to it through either an intranet or the Internet.

"Developed Software" means those computer software products that are developed by or through the use of the SOFTWARE.

"Developed Web Server Software" means those Developed Software products that reside logically or physically on at least one Web Server and are operated (meaning the computer software instruction set is carried out) by the Web Server's central processing unit(s) (CPU).

"Redistributable Files" means the SOFTWARE files or other portions of the SOFTWARE that are provided by C1 and are identified as such in the Documentation for distribution by you with the Developed Software.

"Developer" means a human being or any other automated device using the SOFTWARE in accordance with the terms and conditions of this EULA.

"Developer Seat License" means that each Developer using or otherwise accessing the programmatic interface or the SOFTWARE must obtain the right to do so by purchasing a separate End User License.

"Source Code" shall mean computer software code or programs in human readable format, such as a printed listing of such a program written in a high-level computer language. The term "Source Code" includes, but is not limited to, documents and materials in support of the development effort of the SOFTWARE, such as flow charts, pseudo code and program notes.

2. Your Development License. You are hereby granted a limited, royalty-free, non-exclusive right to use the SOFTWARE to design, develop, and test Developed Software, on the express condition that, and only for so long as, you fully comply with all terms and conditions of this EULA.

The SOFTWARE is licensed to you on a Developer Seat License basis.

Developer Seat License basis means that you may perform an installation of the SOFTWARE for use in designing, testing and creating Developed Software by a single Developer on one or more computers, each with a single set of input devices, so long as 1) such computer/computers is/are used only by one single Developer at any given time and not concurrently and, 2) the user is the primary User to whom the license has been granted. Conversely, you may not install or use the SOFTWARE on a computer that is a network server or a computer at which the SOFTWARE is used by more than one Developer. You may not network the SOFTWARE or any component part of it, where it is or may be used by more than one Developer unless you purchase an additional Development License for each Developer. You must purchase another separate license to the SOFTWARE in order to add additional developer seats, whether the additional developers are accessing the SOFTWARE in a stand-alone environment or on a computer network.

The license rights granted under this Agreement may be limited to a specified number of days after you first install the SOFTWARE unless you supply information required to license or verify your licensed copy, as the case may be, within the time and the manner described during the SOFTWARE setup sequence and/or in the dialog boxes appearing during use of the SOFTWARE. You may need to verify the SOFTWARE through the use of the Internet, email or telephone; toll charges may apply. You may need to re-verify the SOFTWARE if you modify your computer hardware. Product verification is based on the exchange of information between your computer and C1. None of this information contains personally identifiable information nor can they be used to identify any personal information about you or any information you store in your computer. YOU ACKNOWLEDGE AND UNDERSTAND THAT THERE ARE TECHNOLOGICAL MEASURES IN THE SOFTWARE THAT ARE DESIGNED TO PREVENT UNLICENSED OR ILLEGAL USE OF THE SOFTWARE. YOU AGREE THAT C1 MAY USE SUCH MEASURES AND YOU AGREE TO FOLLOW ANY REQUIREMENTS REGARDING SUCH TECHNOLOGICAL MEASURES. YOU ACKNOWLEDGE AND AGREE THAT THE SOFTWARE WILL CEASE TO FUNCTION UNLESS AND UNTIL YOU VERIFY THE APPLICABLE SOFTWARE SERIAL KEY.

You agree that C1 may audit your use of the SOFTWARE for compliance with these terms at any time, upon reasonable notice. In the event that such audit reveals any use of the SOFTWARE other than in full compliance with the terms of this EULA, you shall reimburse C1 for all reasonable expenses related to such audit in addition to any other liabilities you may incur as a result of such non-compliance.

In all cases, (a) you may not use C1's name, logo, or trademarks to market your Developed Software without the express written consent of C1; (b) you must include the following C1 copyright notice in your Developed Software documentation and/or in the "About Box" of your Developed Software, and wherever the copyright/rights notice is located in the Developed Software (“Portions Copyright © ComponentOne, LLC 1991-2005. All Rights Reserved.”); (c) you agree to indemnify, hold harmless, and defend C1, its suppliers and resellers, from and against any claims or lawsuits, including attorney's fees that may arise from the use or distribution of your Developed Software; (d) you may use the SOFTWARE only to create Developed Software that is significantly different than the SOFTWARE.

3. Your Distribution License.

License to Distribute Developed Software. Subject to the terms and conditions in this EULA, you are granted the license to use and to distribute Developed Software on a royalty-free basis, provided that the Developed Software incorporates the SOFTWARE as an integral part of the Developed Software in machine-language compiled format (customarily an ".exe", or ".dll", etc.). You may not distribute, bundle, wrap or subclass the SOFTWARE as Developed Software which, when used in a "designtime" development environment, exposes the programmatic interface of the SOFTWARE. You may distribute, on a royalty-free basis, Redistributable Files with Developed Software only. You may not add or transfer the SOFTWARE license key to the computer where the Developed Software is installed. Users of the Developed Software may not use the SOFTWARE or the Redistributable Files, directly or indirectly, for development purposes. In particular, if you create a control (or user control) using the SOFTWARE as a constituent control, you are not licensed to distribute the control you created with the SOFTWARE to users for development purposes.

4. Specific Product Limitations. Notwithstanding anything in this EULA to the contrary, if the license you have purchased is for any of the following products, then the following additional limitations will apply:

a. ComponentOne Reports for .NET Designer Edition. ComponentOne Reports for .NET Designer Edition includes at least: 1) one dynamic link library file (c1.win.c1reportdesigner.dll) known as C1ReportDesigner Component, 2) one executable file (ReportDesigner.exe) known as C1ReportDesigner Application and, 3) the Source Code of the C1ReportDesigner Application. The C1ReportDesigner Component is subject to the general terms and restrictions set forth in this EULA. The C1ReportDesigner Application is an executable file used to design and prepare reports; the C1ReportDesigner Application may be distributed, free of royalties, only in conjunction with the Developed Software.

C1 hereby also grants you the right to use and to modify the C1ReportDesigner Application Source Code to create derivative works that are based on the licensed Source Code. You may distribute such derivative works, solely in object code format and exclusively in conjunction with and/or as a part of the Developed Software. You are expressly not granted the right to distribute, disclose or otherwise make available to any third party the licensed Source Code, any portion, modified version or derivative work thereof, in source code format.

C1 shall retain all right, title and interest in and to the licensed Source Code, and all C1 updates, modifications or enhancements thereof. Nothing herein shall be deemed to transfer any ownership or title rights in and to the licensed Source Code from C1 to you.

SOURCE CODE IS LICENSED TO YOU AS IS. C1 DOES NOT AND SHALL NOT PROVIDE YOU WITH ANY TECHNICAL SUPPORT FOR YOUR SOURCE CODE LICENSE.

b. VSView Reporting Edition (ActiveX). VSView Reporting Edition includes at least one executable file listed as “VSRptX.exe” (where X indicates the version number i.e.7,8, etc.), known as “Designer.” The file "VSRptX.exe”, or any upgrade or future versions of the Designer, are subject to the restrictions set forth in this EULA and may not be distributed with your Developed Software or in any other way.

c. Studio Products. You may not share the component parts of the Studio Products licensed to you with other Developers, nor may you allow the use and/or installation of such components by other Developers.

5. Updates/Upgrades; Studio Subscription. Subject to the terms and conditions of this EULA, the Licenses are perpetual. Updates and upgrades to the SOFTWARE may be provided by C1 from time-to-time, and, if so provided by C1, are provided upon the terms and conditions offered at that time by C1 in its sole discretion. C1 may provide updates and upgrades to the SOFTWARE for free or for any charge, at any time or never, and through its chosen manner of access and distribution, all in C1's sole discretion.

C1 licenses certain of its separately-licensed products bundled together in a product suite, called the C1 "Studio" product line (the "Studio Products"). The exact separately-licensed products that are bundled into the Studio Products may change from time-to-time in C1's sole discretion. If the SOFTWARE is identified as a C1 "Studio" product, then the SOFTWARE is one of the Studio Products. The SOFTWARE and the Studio Products are revised from time-to-time (meaning, for example, revised with updates, upgrades and, in the case of Studio products, some times changes to the mix of products included in the bundle). To receive any such revisions to the SOFTWARE or the Studio Products, as the case may be, you must have a valid SOFTWARE license or a valid Studio subscription. Together with the Licenses, the original purchaser is granted a one-year subscription from the date of purchase. Upon expiration, you must renew your license subscription to continue to be entitled to receive SOFTWARE and/or the Studio Products revisions as the case may be.

6. Serial Number. With your license, you will be issued a unique serial number (the "Serial Number") used for the activation of the SOFTWARE. The Serial Number is subject to the restrictions set forth in this EULA and may not be disclosed or distributed either with your Developed Software or in any other way. The disclosure or distribution of the Serial Number constitutes a breach of this EULA, the effect of which shall be the immediate termination and revocation of all the rights granted herein.

7. Evaluation Copy. If you are using an "evaluation copy", specifically designated as such by C1 on its website or elsewhere, then the Licenses are limited as follows: a) you are granted a license to use the SOFTWARE for a period of thirty (30) days counted from the day of installation (the "Evaluation Period"); b) upon completion of the Evaluation Period, you shall either i) delete the SOFTWARE from the computer containing the installation, or you may ii) obtain a paid license of the SOFTWARE from C1 or any of its resellers; and c) any Developed Software developed with the Evaluation Copy may not be distributed or used for any commercial purpose.

III. INTELLECTUAL PROPERTY.

1. Copyright. You agree that all right, title, and interest in and to the SOFTWARE (including, but not limited to, any images, photographs, animations, video, audio, music, text, and “applets” incorporated into the SOFTWARE), and any copies of the SOFTWARE, and any copyrights and other intellectual properties therein or related thereto are owned exclusively by C1, except to the limited extent that C1 may be the rightful license holder of certain third-party technologies incorporated into the SOFTWARE. The SOFTWARE is protected by copyright laws and international treaty provisions. The SOFTWARE is licensed to you, not sold to you. C1 reserves all rights not otherwise expressly and specifically granted to you in this EULA.

2. Backups. You may make a copy of the SOFTWARE solely for backup or archival purposes. Notwithstanding the foregoing, you may not copy the printed Documentation.

3. General Limitations. You may not reverse engineer, decompile, or disassemble the SOFTWARE, except and only to the extent that applicable law expressly permits such activity notwithstanding this limitation.

4. Software Transfers. You may not rent or lease the SOFTWARE. You may permanently transfer all of your rights under the EULA, provided that you retain no copies, that you transfer all the SOFTWARE (including all component parts, the media and printed materials, any updates, upgrades, this EULA and, if applicable, the Certificate of Authenticity), and that the transferee agrees to be bound by the terms of this EULA. If the SOFTWARE is an update or upgrade, any transfer must include all prior versions of the SOFTWARE.

5. Termination. Without prejudice to any other rights it may have, C1 may terminate this EULA and the Licenses if you fail to comply with the terms and conditions contained herein. In such an event, you must destroy all copies of the SOFTWARE and all of its component parts.

6. Export Restrictions. You acknowledge that the SOFTWARE is of U.S. origin. You acknowledge that the license and distribution of the SOFTWARE is subject to the export control laws and regulations of the United States of America, and any amendments thereof, which restrict exports and re-exports of software, technical data, and direct products of technical data, including services and Developed Software. You agree that you will not export or re-export the SOFTWARE or any Developed Software, or any information, documentation and/or printed materials related thereto, directly or indirectly, without first obtaining permission to do so as required from the United States of America Department of Commerce's Bureau of Export Administration ("BXA"), or other appropriate governmental agencies, to any countries, end-users, or for any end-uses that are restricted by U.S. export laws and regulations, and any amendments thereof, which include, but are not limited to: Restricted Countries, Restricted End-Users, and Restricted End-Uses.

These restrictions change from time to time. You represent and warrant that neither the BXA nor any other United States federal agency has suspended, revoked or denied your export privileges. C1 acknowledges that it shall use reasonable efforts to supply you with all reasonably necessary information regarding the SOFTWARE and its business to enable you to fully comply with the provisions of this Section. If you have any questions regarding your obligations under United States of America export regulations, you should contact the Bureau of Export Administration, United States Department of Commerce, Exporter Counseling Division, Washington DC. U.S.A. (202) 482-4811, http://www.bxa.doc.gov.

7. U.S. Government Restricted Rights. The SOFTWARE and documentation are provided with RESTRICTED RIGHTS. You will comply with any requirements of the Government to obtain such RESTRICTED RIGHTS protection, including without limitation, the placement of any restrictive legends on the SOFTWARE, and any license agreement used in connection with the distribution of the SOFTWARE. Manufacturer is ComponentOne, LLC, 201 South Highland Avenue , 3rd Floor, Pittsburgh, Pennsylvania 15206 USA. For solicitations issued by the Government on or after December 1, 1995 and the Department of Defense on or after September 29, 1995, the only rights provided in the software and documentation provided herein shall be those contained in this EULA. Under no circumstances shall C1 be obligated to comply with any Governmental requirements regarding the submission of or the request for exemption from submission of cost or pricing data or cost accounting requirements. For any distribution of the SOFTWARE that would require compliance by C1 with the Government's requirements relating to cost or pricing data or cost accounting requirements, you must obtain an appropriate waiver or exemption from such requirements for the benefit of C1 from the appropriate Government authority before the distribution and/or license of the SOFTWARE to the Government.

IV. WARRANTIES AND REMEDIES.

1. Limited Warranty. C1 warrants that the original media, if any, are free from defects for ninety (90) days from the date of delivery of the SOFTWARE. C1 also warrants that: (i) it has the full power to enter into this Agreement and grant the license rights set forth herein; (ii) it has not granted and will not grant any rights in the Software to any third party which grant is inconsistent with the rights granted to you in this Agreement; and (iii) the Software does not and will not infringe any trade secret, copyright, trademark or other proprietary right held by any third party and does not infringe any patent held by any third party. EXCEPT AS OTHERWISE PROVIDED IN THE PRECEDING SENTENCE, AND TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, C1 EXPRESSLY DISCLAIMS ANY WARRANTY FOR THE SOFTWARE, DOCUMENTATION AND ANYTHING ELSE PROVIDED BY C1 HEREBY AND C1 PROVIDES THE SAME IN “AS IS” CONDITION WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, THE IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK ARISING OUT OF USE OR PERFORMANCE OF THE SOFTWARE AND DOCUMENTATION REMAINS WITH YOU. THIS LIMITED WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS. YOU MAY HAVE OTHERS WHICH VARY FROM STATE TO STATE.

2. Limited Remedy. C1 PROVIDES NO REMEDIES OR WARRANTIES, WHETHER EXPRESS OR IMPLIED, FOR ANY SAMPLE APPLICATION CODE, REDISTRIBUTABLE FILES, TRIAL VERSION AND THE NOT FOR RESALE VERSION OF THE SOFTWARE. ANY SAMPLE APPLICATION CODE, TRIAL VERSION AND THE NOT FOR RESALE VERSION OF THE SOFTWARE ARE PROVIDED “AS IS”.

C1's entire liability and your exclusive remedy under this EULA shall be, at C1's sole option, either (a) return of the price paid for the SOFTWARE; (b) repair the SOFTWARE through updates distributed online or otherwise in C1's discretion; or (c) replace the SOFTWARE with SOFTWARE that substantially performs as described in the SOFTWARE documentation, provided that you return the SOFTWARE in the same manner as provided in Section I.2 for return of the SOFTWARE for non-acceptance of this EULA. Any media for any repaired or replacement SOFTWARE will be warranted for the remainder of the original warranty period or thirty (30) days, whichever is longer. THESE REMEDIES ARE NOT AVAILABLE OUTSIDE OF THE UNITED STATES OF AMERICA. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT SHALL C1 BE LIABLE FOR ANY DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS PROFIT, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, OR ANY OTHER PECUNIARY LOSS) ARISING OUT OF THE USE OR INABILITY TO USE THE SOFTWARE, EVEN IF C1 HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. BECAUSE SOME STATES/JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES IN CERTAIN CASES, THE ABOVE LIMITATION MAY NOT APPLY TO YOU.

V. MISCELLANEOUS.

1. This is the Entire Agreement. This EULA (including any addendum to this EULA included with the SOFTWARE) is the final, complete and exclusive statement of the entire agreement between you and C1 relating to the SOFTWARE. This EULA supersedes any prior and contemporaneous proposals, purchase orders, advertisements, and all other communications in relation to the subject matter of this EULA, whether oral or written. No terms or conditions, other than those contained herein, and no other understanding or agreement which in any way modifies these terms and conditions, shall be binding upon the parties unless entered into in writing executed between the parties, or by other non-oral manner of agreement whereby the parties objectively and definitively act in a manner to be bound (such as by continuing with an installation of the SOFTWARE, etc.). Employees, agents and other representatives of C1 are not permitted to orally modify this EULA.

2. You Indemnify C1. You agree to indemnify, hold harmless, and defend C1 and its suppliers and resellers from and against any and all claims or lawsuits, including attorney's fees, which arise out of or result from your distribution of your Developed Software, your Developed Web Server Software or from your breach of any of the terms and conditions of this EULA.

3. Interpretation of this EULA. If for any reason a court of competent jurisdiction finds any provision of this EULA, or any portion thereof, to be unenforceable, that provision of this EULA will be enforced to the maximum extent permissible so as to effect the intent of the parties, and the remainder of this EULA will continue in full force and effect. Formatives of defined terms shall have the same meaning of the defined term. Failure by either party to enforce any provision of this EULA will not be deemed a waiver of future enforcement of that or any other provision. Except as otherwise required or superseded by law, this EULA is governed by the laws of the Commonwealth of Pennsylvania, without regard to its conflict of laws principles. The parties consent to the personal jurisdiction and venue of the Commonwealth of Pennsylvania, in the County of Allegheny, and agree that any legal proceedings arising out of this EULA shall be conducted solely in such Commonwealth. If the SOFTWARE was acquired outside the United States, then local law may apply.


Licensing FAQs

Licensing FAQs

This section describes the main technical aspects of licensing. It may help the user to understand and resolve licensing problems he may experience when using ComponentOne .NET and ASP.NET products.

What is Licensing?

How does Licensing Work?

Common Scenarios

Troubleshooting

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


What is Licensing?

What is Licensing?

Previous Next

Licensing is a mechanism used to protect intellectual property by ensuring that users are authorized to use software products.

Licensing is not only used to prevent illegal distribution of software products. Many software vendors, including ComponentOne, use licensing to allow potential users to test products before they decide to purchase them.

Without licensing, this type of distribution would not be practical for the vendor or convenient for the user. Vendors would either have to distribute evaluation software with limited functionality, or shift the burden of managing software licenses to customers, who could easily forget that the software being used is an evaluation version and has not been purchased.


How does Licensing Work?

How does Licensing Work?

Previous Next

ComponentOne uses a licensing model based on the standard set by Microsoft, which works with all types of components.

Note: The Compact Framework components use a slightly different mechanism for licensing than the other ComponentOne components due to platform differences.

When a user decides to purchase a product, he receives an installation program and a Serial Number. During the installation process, the user is prompted for the serial number that is saved on the system. (Users can also enter the serial number by clicking the "License" button on the About Box of any ComponentOne product.)

When a licensed component is added to a form or web page, Visual Studio asks the newly created component for licensing information. The component looks for licensing information stored in the system and generates a key, which Visual Studio saves in two files:

1. a "<projectName>.licenses" resource file which contains the actual key and

2. a "licenses.licx" file that contains references to those resources.

These files are automatically added to the project.

Note that the licenses.licx file is usually not shown in the Solution Explorer; it appears if you press the "Show All Files" button in the Solution Explorer's Toolbox, or select "Project | Show All Files" from Visual Studio's main menu.

Later, when the component is created at run time, it gets passed the key that was created at design time and can decide whether to simply accept the key, to throw an exception and fail altogether, or to display some information reminding the user that the software has not been licensed.

All ComponentOne products are designed to display licensing information if the product is not licensed. None will throw licensing exceptions and prevent applications from running.


Common Scenarios

Common Scenarios

Creating components at design time

Creating components at run time

Inheriting from licensed components

Using licensed components in console applications

Using licensed components in Visual C++ applications


Creating components at design time

Creating components at design time

This is the most common scenario and also the simplest: the user adds one or more controls to the form, the licensing information is stored in the licenses.licx file, and the component works.

Note that the mechanism is exactly the same for Windows Forms and Web Forms (ASP.NET) projects.


Creating components at run time

Creating components at run time

This is also a fairly common scenario. You do not need an instance of the component on the form, but would like to create one or more instances at run time.

In this case, the project will not contain a licenses.licx file (or the file will not contain an appropriate key for the component) and therefore licensing will fail.

To fix this problem, add an instance of the component to a form in the project. This will create the licenses.licx file and things will then work as expected. (The component can be removed from the form after the licenses.licx file has been created).


Inheriting from licensed components

Inheriting from licensed components

If a component that inherits from a licensed component is created, the licensing information to be stored in the form is still needed. This can be done in two ways:

1. Add a LicenseProvider attribute to the component.

This will mark the component as licensed. When a component is added to a form, Visual Studio will create and manage the licenses.licx file, and the base class will handle the licensing process as usual. No additional work is needed. For example:

[LicenseProvider(typeof(LicenseProvider))]

class MyGrid: C1.Win.C1FlexGrid.C1FlexGrid

{

// ...

}

2. Add an instance of the base component to the form.

This will embed the licensing information into the licenses.licx file as in the previous scenario, and the base component will find it and use it. As before, the extra instance can be deleted after the licenses.licx file has been created.


Using licensed components in console applications

Using licensed components in console applications

When building console applications, there are no forms to add components to, and therefore Visual Studio won't create a licenses.licx file.

In these cases, create a temporary Windows Forms application and add all the desired licensed components to a form. Then close the Windows Forms application and copy the licenses.licx file into the console application project.

Make sure the licensex.licx file is configured as an embedded resource. To do this, right-click the licenses.licx file in the Solution Explorer window and select Properties. In the Property window, set the "Build Action" property to "Embedded Resource".


Using licensed components in Visual C++ applications

Using licensed components in Visual C++ applications

It seems there is a bug in VC++ 2003. The licenses.licx is ignored during the build process, therefore the licensing information is not included in VC++ applications.

To fix this problem, extra steps must be taken to compile the licensing resources and link them to the project. Note the following:

1. Build the C++ project as usual. This should create an exe file and also a licenses.licx file with licensing information in it.

2. Copy the licenses.licx file from the app directory to the target folder (Debug or Release).

3. Copy the C1Lc.exe utility and the licensed dlls to the target folder. (Don't use the standard lc.exe, it has bugs.)

4. Use C1Lc.exe to compile the licenses.licx file. The command line should look like this:

c1lc /target:MyApp.exe /complist:licenses.licx /i:C1.Win.C1FlexGrid.dll

5. Link the licenses into the project. To do this, go back to Visual Studio, right-click the project, select properties, and go to the Linker/Command Line option. Enter the following:

/ASSEMBLYRESOURCE:Debug\MyApp.exe.licenses

6. Rebuild the executable to include the licensing information in the application.


Troubleshooting

Troubleshooting

We try very hard to make the licensing mechanism as unobtrusive as possible, but problems may occur for a number of reasons.

Below is a description of the most common problems and their solutions.


I have a licensed version of a ComponentOne product but I still get the splash screen when I run my project.

I have a licensed version of a ComponentOne product but I still get the splash screen when I run my project.

Previous Next

If this happens, there must be a problem with the licenses.licx file in the project. It either doesn't exist, contains wrong information, or is not configured correctly.

First, try a full rebuild ("Rebuild All" from the Visual Studio Build menu). This will usually rebuild the correct licensing resources.

If that fails, follow these steps:

1. Open the project and go to the Solution Explorer window.

2. Click the "Show All Files" button on the top of the window.

3. Find the licenses.licx file and delete it.

4. Close the project and reopen it.

5. Open the main form and add an instance of each licensed control.

6. Check the Solution Explorer window, there should be a licenses.licx file there.

7. Rebuild the project using the "Rebuild All" option (not just "Rebuild").


I have a licensed version of a ComponentOne product on my web server but the components still behave as unlicensed.

I have a licensed version of a ComponentOne product on my web server but the components still behave as unlicensed.

Previous Next

There is no need to install any licenses on machines used as servers and not used for development.

The components must be licensed on the development machine, therefore the licensing information will be saved into the executable (.exe or .dll) when the project is built. After that, the application can be deployed on any machine, including web servers.

Note that additional server licenses may be needed to be able to _legally_ deploy applications on web servers. Please refer to the EULA or contact sales@componentone.com for details.


I downloaded a new build of a component that I have purchased, and now I'm getting the splash screen when I build my projects.

I downloaded a new build of a component that I have purchased, and now I'm getting the splash screen when I build my projects.

Previous Next

Make sure that the license key is still valid. If you licensed the component over a year ago, your subscription may have expired. In this case, you have two options:

Option 1 - Renew your subscription to get a new license key.

If you choose this option, you will receive a new key that you can use to license the new components (from the installation utility or directly from the About Box).

The new subscription will entitle you to a full year of upgrades and to download the latest maintenance builds directly from http://prerelease.componentone.com.

Option 2 – Continue to use the components you have.

Subscriptions expire, products do not. You can continue to use the components you received or downloaded while your subscription was valid.


Technical Support

Technical Support

ComponentOne Spell for .NET is developed and supported by ComponentOne LLC, a company formed by the merger of APEX Software Corporation and VideoSoft. You can obtain technical support using any of the following methods:

ComponentOne Web site

ComponentOne HelpCentral

Internet e-mail

Peer-to-Peer newsgroup

Documentation

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


ComponentOne Web site

ComponentOne Web site

The ComponentOne Web site at www.componentone.com provides a wealth of information and software downloads for Spell for .NET users, including:

· Descriptions of the various support options available through the ComponentOne Service Team.

· Answers to frequently asked questions (FAQ's) about our products, organized by functionality. Please consult the FAQ's before contacting us directly, as this can save you time and also introduce you to other useful information pertaining to our products.

· Free product updates, which provide you with bug fixes and new features.


ComponentOne HelpCentral

ComponentOne HelpCentral

ComponentOne HelpCentral is the new online resource for Visual Studio developers and Help authors. Visit HelpCentral to get information on ComponentOne products, view online demos, get Tech Tips and answers to frequently asked questions (FAQ's), search the ComponentOne knowledgebase and more!


Internet e-mail

Internet e-mail

For technical support through the Internet, e-mail us at:

Support.Spell.NET@componentone.com

To help us provide you with the best support, please include the following information when contacting ComponentOne:

· Your ComponentOne product serial number.

· The version and name of your operating system.

· Your development environment and its version.

For more information on technical support, go to:

www.componentone.com/support


Peer-to-Peer newsgroup

Peer-to-Peer newsgroup

ComponentOne also sponsors peer-to-peer newsgroups for C1Spell users. ComponentOne does not offer formal technical support in this newsgroup, but instead sponsors it as a forum for users to post and answer each other's questions regarding C1Spell. However, ComponentOne may monitor the newsgroups to ensure accuracy of information and provide comments when necessary.

You can access the newsgroup from the ComponentOne Web site at http://helpcentral.componentone.com/Newsgroups.aspx.


Documentation

Documentation

ComponentOne documentation is available with each of our products in HTML Help, Microsoft Help 2.0 (.NET, ASP.NET and Mobile Device products only), and PDF format. All of the PDFs are also available on ComponentOne HelpCentral. If you have suggestions on how we can improve our documentation, please email the Documentation team. Please note that e-mail sent to the Documentation team is for documentation feedback only. Technical Support and Sales issues should be sent directly to their respective departments.


Redistributable Files

Redistributable Files

ComponentOne Spell for .NET is developed and published by ComponentOne LLC. You may use it for development with Microsoft Visual Studio or any other programming environment. You may also distribute the following control files, royalty free, with any application you develop:

· C1.Win.C1Spell.dll

· C1.Win.C1Spell.2.dll (if using Visual Studio 2005)

· C1.Win.C1Thesaurus.dll

· C1.Win.C1Thesaurus.2.dll (if using Visual Studio 2005)

In addition to the control files above, you may redistribute dictionary and thesaurus files supplied with Spell for .Net, like C1SP_AE.dct and C1TH_AE.THE.

Groups of multiple developers may be interested in acquiring ComponentOne product site licenses. Please contact ComponentOne for details.

When shipping your applications, we strongly suggest that you use a professional installation utility such as the Wise Installation System®, InstallShield®, or the setup wizard that ships with Microsoft Visual Basic 5.0 and later.


Namespaces

Namespaces

Namespaces organize the objects defined in an assembly. Assemblies can contain multiple namespaces, which can in turn contain other namespaces. Namespaces prevent ambiguity and simplify references when using large groups of objects such as class libraries.

The general namespace for ComponentOne Windows products is C1.Win. The namespace for the C1Spell component is C1.Win.C1Spell. The following code fragment shows how to declare a C1Spell component using the fully qualified name for this class:

· Visual Basic

· C#

· Delphi

Namespaces address a problem sometimes known as namespace pollution, in which the developer of a class library is hampered by the use of similar names in another library. These conflicts with existing components are sometimes called name collisions.

For example, if you create a new class named C1Spell, you can use it inside your project without qualification. However, the C1Spell assembly also implements a class called C1Spell. So, if you want to use the C1Spell class in the same project, you must use a fully qualified reference to make the reference unique. If the reference is not unique, Visual Studio .NET produces an error stating that the name is ambiguous. The following code snippet demonstrates how to declare these objects:

· Visual Basic

· C#

· Delphi

Fully qualified names are object references that are prefixed with the name of the namespace where the object is defined. You can use objects defined in other projects if you create a reference to the class (by choosing Add Reference from the Project menu) and then use the fully qualified name for the object in your code.

Fully qualified names prevent naming conflicts because the compiler can always determine which object is being used. However, the names themselves can get long and cumbersome. To get around this, you can use the Imports statement (using in C#) to define an alias — an abbreviated name you can use in place of a fully qualified name. For example, the following code snippet creates aliases for two fully qualified names, and uses these aliases to define two objects:

· Visual Basic

· C#

· Delphi

If you use the Imports statement without an alias, you can use all the names in that namespace without qualification provided they are unique to the project.


Creating a .NET Project

Creating a .NET Project

This topic demonstrates how to create a new .NET project.

1. From the File menu in Microsoft Visual Studio .NET, select New and click Project. The New Project dialog box opens.

2. Under Project Types, choose either Visual Basic Projects or Visual C# Projects, and select Windows Application from the list of Templates in the right pane.

3. Enter or browse for a location for your application in the Location field and click OK.

A new Microsoft Visual Studio .NET project is created in the specified location. In addition, a new Form1 is displayed in the Designer view.

4. Double-click the C1Spell components from the Toolbox to add them to Form1. For information on adding a component to the toolbox, see Adding the C1Spell Components to the Toolbox.


Adding the C1Spell Components to the Toolbox

Adding the C1Spell Components to the Toolbox

When you install Spell for .NET, the following new components will appear in the Visual Studio Toolbox customization dialog box:

· C1Spell

· C1Thesaurus

In order to use these components, you must add them to the Visual Studio Toolbox:

1. Open the Visual Studio IDE (Microsoft Development Environment). Make sure the Toolbox is visible (select View | Toolbox, if necessary). Press the right mouse button over the Toolbox to open its context menu.

If you want Spell for .NET components to appear on their own tab in the Toolbox, select Add Tab from the context menu and type in the tab name, for example, “C1Spell”.

Select the tab where you want the components to appear. Press the right mouse button over that tab and select Choose Items from the context menu. The Choose Toolbox Items dialog box opens.

Note: In Visual Studio 2003 you would select Add/Remove from the context menu.

2. In the Choose Toolbox Items dialog box, go to the .NET Framework Components tab. Sort the list by Namespace (click the Namespace column header) and check the check boxes for all components belonging to namespaces C1.Win.C1Spell and C1.Win.C1Thesaurus.


Migrating a C1Spell Project to Visual Studio 2005

Migrating a C1Spell Project to Visual Studio 2005

To migrate a project using ComponentOne components to Visual Studio 2005, there are two main steps that must be performed. First, you must convert your project to Visual Studio 2005, which includes removing any references to a previous assembly and adding a reference to the new assembly. Secondly, the .licx file, or licensing file, must be updated in order for the project to run correctly.

To convert the project:

1. Open Visual Studio 2005 and select File | Open | Project/Solution.

2. Locate the .sln file for the project that you wish to convert to Visual Studio 2005. Select it and click Open. The Visual Studio Conversion Wizard appears.

3. Click Next.

4. Select Yes, create a backup before converting to create a backup of your current project and click Next.

5. Click Finish to convert your project to Visual Studio 2005. The Conversion Complete window appears.

6. Click Show the conversion log when the wizard is closed if you want to view the conversion log.

7. Click Close. The project opens. Now you must remove references to any of the previous ComponentOne .dlls and add references to the new ones.

8. Go to the Solution Explorer (View | Solution Explorer), select the project, and click the Show All Files button.

Note: The Show All Files button does not appear in the Solution Explorer toolbar if the Solution project node is selected.

9. Expand the References node, right-click C1.Win.C1Spell and select Remove. Also remove C1.Win.C1Thesaurus the same way.

10. Right-click the References node and select Add Reference.

11. Locate and select C1.Win.C1Spell.2.dll. Click OK to add it to the project. Also add C1.Win.C1Thesaurus.2.dll the same way.

To update the .licx file:

1. In the Solution Explorer, right-click the licenses.licx file and select Delete.

2. Click OK to permanently delete licenses.licx. The project must be rebuilt to create a new, updated version of the .licx file.

3. Click the Start Debugging button to compile and run the project. The new .licx file may not be visible in the Solution Explorer.

4. Select File | Close to close the form and then double-click the Form.vb or Form.cs file in the Solution Explorer to reopen it. The new licenses.licx file appears in the list of files.

The migration process is complete.


Spell for .NET QuickStart

Spell for .NET QuickStart

This section will lead you through the creation of a simple Visual Basic project that uses the C1Spell component.

Begin by adding the C1Spell component to the Visual Basic Toolbox. If you are not sure how to do this, reference your Visual Basic manual or help file on how to add custom components. Next, add a C1Spell component to the form by double clicking on the C1Spell component button in the toolbox. The component will appear below the form, not on it. Add a Textbox control and a Button control to the form and set the following properties:

· Visual Basic

· C#

· Delphi

Your form should look like the one shown below:

Then implement the following code in the body of the Button1.Click event handler.

· Visual Basic

· C#

· Delphi

Now the sample application is ready. Run it, type any text in the TextBox control, click the button and observe spell-checking functionality.

Main and Custom Dictionary Files

Spelling Dialog Box

HasSuggestions

Other Spell for .NET Features

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


Main and Custom Dictionary Files

Main and Custom Dictionary Files

You no longer have to set the MainDictFile property or the CustomDictFiles property of the C1Spell Component in order to start spell checking words. If you choose to set these properties, each must be set to contain the complete path and filename of a main or custom dictionary file. This may be done in design mode or at runtime. If a path and filename are not specified, the component will search for the default main dictionary filename (C1SP_AE.DCT) in the current directory or the Windows System directory.


Spelling Dialog Box

Spelling Dialog Box

Leave the BadWordDialog property set to the default setting, EnglishDialog. This causes a dialog box to appear when a bad word is encountered as shown below. This greatly reduces the code needed to handle bad words.


HasSuggestions

HasSuggestions

Leave the HasSuggestions property set to the default setting, True. This displays replacement suggestions for the bad word (if any are generated). The Suggestion event is fired each time a new suggestion is added to the Suggestions collection. The BadWord event is fired after the last Suggestion event for a word is fired. When the suggestions are displayed, the user has the following options:

· Ignore the word this time only.

· Ignore the word and any other occurrences of the word.

· Change the word and any other occurrences of the word.

· Add the word to the custom dictionary.

· Cancel the spell-checking process.

The Suggestion and BadWord events are fired whether or not the dialog box is used. However, if you are using the automatic dialog box, there is no need to respond to the events, since the dialog box can handle the user's responses automatically.

That's all there is to it! You can now run your program. Type some words into the textbox and then click on the Check spelling button. If the word is misspelled, the Spelling Check dialog box appears and the BadWord event is fired. If suggestions can be generated for the bad word, the Suggestion event is fired for each suggestion prior to the BadWord event being fired.

After the spell check is complete, the Complete event is fired.

Note: Any code following the setting of the CheckString method will begin executing after the Complete event is fired. For example, if you set the CheckString method from code, any code following the statement that sets the CheckString method will not run until the Complete event is fired.


Using the Default Options Dialog Box

Using the Default Options Dialog Box

You can set spelling properties using the Options dialog box. Setting the OptionBtnVisible property to True causes a customizable button to be shown on the dialog box. By default, the Options button in the Spelling Check dialog box is visible.

Click the button, and the Options dialog box appears.

From the Options dialog box you can determine whether C1Spell should “Suggest Corrections,” “Ignore Words in Upper Case,” “Ignore Words with Numbers,” or “Ignore Words in Mixed Case.”

Click the Custom Dictionaries tab to add or delete custom dictionaries.

Once you set the custom dictionaries, they will be available the next time the application is run, unless you set IsOptionSettingFixed to False. In that case, the application will use the setting from your code or from design time specifications.

Settings in the Options dialog box are saved in the registry. If you want to clear the current settings, call the DeleteOptionSetting method.


Using the Default Context Menu

Using the Default Context Menu

When you are in CheckTyping mode and you find a misspelled word, right-click the word and the default context menu appears.

The first section of the context menu contains words from the suggestion list.

Note: The number of words suggested depends on the value of the MaxMenuSuggests property. The default value for this property is five.

Click one of the suggested words to replace the misspelled word.

You can also select Spelling at the bottom of the context menu, and the Spelling Check dialog box appears. You can choose a replacement word from there.


Other Spell for .NET Features

Other Spell for .NET Features

Checking a Single Word or Multiple Words

Dialog Box Option Button (C1Spell)

Dialog Box Help Button (C1Spell)

StringCollections

Custom Dictionary Files

Adding Words to a Custom Dictionary

Common Word Cache

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


Checking a Single Word or Multiple Words

Checking a Single Word or Multiple Words

To check a word or multiple words, set the CheckString method to a string containing the word(s) to be checked.


Dialog Box Option Button (C1Spell)

Dialog Box Option Button (C1Spell)

Previous Next

Setting the OptionBtnVisible property to True causes a customizable button to be shown on the dialog box. By default, the option button is visible. The default caption for the button is Options, but it can be changed by setting the OptionBtnCaption property. If the DisplayDefaultOption property is set to False, then pressing the button fires the OptionBtnClick event; otherwise, the default option dialog box will appear.


Dialog Box Help Button (C1Spell)

Dialog Box Help Button (C1Spell)

Previous Next

Setting the HelpBtnVisible property to True causes a Help button to be shown on the dialog box. By default, the Help button is not visible. Pressing the Help button fires the HelpBtnClick event.


StringCollections

StringCollections

The IgnoreAll and ChangeAllPair StringCollections allow a word to be ignored or changed for all future occurrences of the word until the entries are cleared (explained below). This is done when the user presses either the Ignore All or Change All buttons on the spelling dialog box following a BadWord event.

When a word is ignored for all occurrences of the word, the word being checked is added to the IgnoreAll collection.

When a word is changed for all occurrences of the word, the word being checked is added to the ChangeAllPair collection.

All property arrays are zero-based. The first entry is 0, the second is 1, etc.

Invoking the Clear method clears all entries from the IgnoreAll and ChangeAllPair collections.


Custom Dictionary Files

Custom Dictionary Files

Each custom dictionary file has a complete path and filename specified in the CustomDictFiles property. A custom dictionary file is a text file with one word per line. Each line ends with a carriage return and a line-feed character. The words do not need to be sorted alphabetically.

The CustomDictFiles property can be set in design mode or at runtime. Setting this property causes the custom dictionary files to be reread before the next spell check is performed.


Adding Words to a Custom Dictionary

Adding Words to a Custom Dictionary

Words can be added to a custom dictionary if the user presses the Add button on the Options dialog box. Pressing the Add button automatically adds the word to the custom dictionary. Use the WhichCustomDict property to tell Spell for .NET to which dictionary it should add the word.


Common Word Cache

Common Word Cache

A list of common words is built into Spell for .NET to help speed spell checking. This results in fewer accesses to the dictionary files. Setting the CommonWordCache property to False disables this feature. Otherwise, set the property to a value that indicates which language cache will be used. Setting the CommonWordCache property to EnglishCommonCache enables the American English common word cache. Setting the CommonWordCache property to SpanishCommonCache enables the Spanish common word cache. The common word cache contains approximately 1,000 words and substantially increases the speed of the spell-checking process.


Property Groups

Property Groups

This section lists the main Spell for .NET properties and methods. The properties and methods are grouped according to function. For details on any property or method, refer to the main body of the documentation.


Initialization Properties

Initialization Properties

You may set these properties before you start using the C1Spell component. You don't need to initialize properties with default values that are the ones you want to use.

Name | Description
CustomDictFiles | Set this property if you have custom dictionary files.
IgnoreWithNumbers | Set these properties to specify types of words to ignore while spell checking.
IgnoreInUpperCase | Set these properties to specify types of words to ignore while spell checking.
IgnoreInMixedCase | Set these properties to specify types of words to ignore while spell checking.
HasSuggestions | Set this property to specify whether or not the component should build a suggestion list and present it to the user when a bad word is found. You may inspect the list using the Suggestion.C1Spell event.
BadWordDialog | Set this property to NoDialog if you don't want the spelling dialog box to appear every time a bad word is detected. You may also choose to display the dialog in a language other than English.
DialogProp | Set this property to customize the spelling dialog box.


Perform Spell Checking

Perform Spell Checking

Use these properties and methods to spell check a control, a string, or a single word. Typically, you will use only one method depending on the type of application you are developing.

Name | Description
CheckControl | Use this method to spell check the contents of a given control derived from TextBoxBase.
CheckString | Set this property to spell check a single word or multiple words.
CheckTyping | Use this method to spell check a control as the user types. Also set the TypingErrorAction property to specify the action to be taken when an error is found, or trap the TypingError event to provide custom error handling.


Check Results

Check Results

After the spell-checking process is done, or when Spell for .NET events are fired, you may want to inspect the results using these properties.

Name | Description
BadWordCount | Returns the number of bad words found while spell checking the document.
WordCount | Returns the number of words checked while spell checking the document.
WordsPerMinute | Returns the number of words checked per minute.
AverageWordLength | Returns the average length of the words that were spell checked.


Building and Maintaining Dictionary Files

Building and Maintaining Dictionary Files

The Spell for .NET distribution CD includes a utility program called DICTUTIL.EXE that allows you to create and maintain dictionary files. You can use it to add words to the main dictionary or to create new dictionaries in languages other than English.

The installation utility copies the DICTUTIL.EXE program to the ComponentOne directory you specify during the installation process. When you run DICTUTIL.EXE, you will see the following on your screen:

The utility is simple and easy to use. It is used to perform two functions:

· Dump an existing dictionary file to a text file, which can be edited with any text editor.

· Compile an existing text file into a new dictionary file.


To Dump an Existing Main Dictionary

To Dump an Existing Main Dictionary

1. Click the button next to the Dictionary File field and select the dictionary file you want to dump into a text file.

2. Click the button next to the Text File field and select the name and location of the text file you want to create. If the file already exists, it will be overwritten.

3. Click the Dump Dictionary to Text File button.

4. Click the x button on the top right of the window to close the utility.

The text file generated by the DICTUTIL program contains one word per line. Each line ends with a carriage return and a line-feed character (vbCrLf). The last character of the file is an end-of-file character (ASCII code decimal 26 or Control Z).

Note that not all dictionaries may be dumped. If the dictionary was created with the Protection option enabled (the Allow Others to Dump Dictionary checkbox deselected) then you will not be able to dump the dictionary. If you plan to use the Protection option, make sure you save the words used to create the dictionary.


To Build a New Main Dictionary

To Build a New Main Dictionary

1. Click the button next to the Text File field and select the text file containing the list of words that will be used to build the dictionary.

2. Click the button next to the Dictionary File field and select the name and location of the new dictionary file you want to create. If the file already exists, it will be overwritten.

3. Click the Build Dictionary from Text File button.

4. Click the x button on the top right of the window to close the utility.

When the build is complete, the new, main dictionary will contain the words from the text file.

When creating a text file that will be used to build a dictionary, remember these rules:

1. The text file must have one word per line.

2. Each line must end with a carriage return and a line-feed character (vbCrLf).

3. The last character of the file must be an end-of-file character (ASCII code decimal 26 or Control Z).

4. The words do not have to be in alphabetical order.

5. Case is not important.

6. Duplicate words will be detected and replaced with a single entry.


C1Spell Samples

C1Spell Samples

Please be advised that this ComponentOne software title is accompanied by various sample projects and/or demos, which may or not make use of other ComponentOne development tools. While the sample projects and/or demos included with the software are used to demonstrate and highlight the product’s features, and how the control may be integrated with the rest of the ComponentOne product line, some of the controls used in the demo/sample project may not be included with the purchase of certain individual products.

The ComponentOne Samples are also available at http://helpcentral.componentone.com/ProductResources.aspx.


Visual Basic and C# Samples

Visual Basic and C# Samples

SpellTutor

Shows three modes of spell checking: typing, window, and text. This sample uses the C1Spell control.


Spell for .NET Tutorial

Spell for .NET Tutorial

This section will lead you through the creation of a Visual Basic project that uses the C1Spell component. The project shows how to use the C1Spell component to provide three types of spell checking:

1. Data-Entry Screens (As-you-type): in this mode, the C1Spell component is linked to individual textboxes and monitors them as the user types. When errors are detected, the offending word is underlined and a beep sounds. The demo also provides an "AutoCorrect" option that will display a menu with suggestions when the user makes a typing error.

2. Long Documents: in this mode, the C1Spell component is invoked when the document is ready for checking. The demo uses the CheckControl method and from then on the whole process is automatic. The text is retrieved from the control, a spelling dialog box is displayed whenever a bad word is found, and the changes made by the user through the dialog box are applied to the control.

3. Plain or Arbitrary Text (no controls): in this mode, the C1Spell component is used to check strings that come from arbitrary sources. The demo retrieves the strings from a ListBox control, but in practice the text comes from a database, text file, or any other source.

Step 1: Create the Main Form

Step 2: Initialize the Form

Step 3: Provide As-you-type Spell Checking (top panel)

Step 4: Provide Long Document Spell Checking (middle panel)

Step 5: Provide Spell Checking for Arbitrary Strings (bottom panel)


Step 1: Create the Main Form

Step 1: Create the Main Form

Start a new Visual Basic project, add the C1Spell component to the Visual Basic toolbox, and add controls to create the main form. The form is divided into three sections, each consisting of a frame control with its own C1Spell component and other subordinate controls. When completed, here is how the final form will appear:

The top panel will demonstrate As-you-type Spell Checking (Data Entry). It has the following controls:

Name | Type | Function
C1Spell1 | C1Spell | Provides spell checking for this panel.
TextBox1 | TextBox | This is where the user will type the text to be spell checked.
TextBox2 | TextBox | This is where the user will type text to be spell checked.
TextBox3 | TextBox | This is where the user will type text to be spell checked.
CheckBox1 | CheckBox | Toggles auto-correct mode on and off.
PictureBox1 | PictureBox | Used to show a red signal when the user makes a typing error.

The middle panel will demonstrate Long Document Spell Checking. It has the following controls:

Name | Type | Function
C1Spell2 | C1Spell | Provides spell checking for this panel.
TextBox4 | TextBox | This is where the user will type the text to be spell checked. This could also be a RichTextBox control. To be able to see misspelled words better, set the HideSelection property to False. Set the Multiline property to True so the user can enter more than one line of text.
Button1 | CommandButton | Starts spell checking the text in TextBox2.

The bottom panel will demonstrate Spell Checking Plain Text. It has the following controls:

Name | Type | Function
C1Spell3 | C1Spell | Provides spell checking for this panel.
TextBox5 | TextBox | Used for changing ListBox entries.
ListBox1 | ListBox | Contains strings that will be spell checked.
Button2 | CommandButton | Spell check every ListBox item.

Also use the ContextMenu control to create a single menu called mPopup, with an array of six sub-items.


Step 2: Initialize the Form

Step 2: Initialize the Form

Double-click the form and add the following code to the Form_Load event:

· Visual Basic

· C#

· Delphi

This routine initializes some text controls and the list box selection.


Step 3: Provide As-you-type Spell Checking (top panel)

Step 3: Provide As-you-type Spell Checking (top panel)

Previous Next

Double-click the first textbox and add the following code to the TextBox1_GotFocus event:

· Visual Basic

· C#

· Delphi

Add the following code to the TextBox2_GotFocus and TextBox3_GotFocus events, respectively.

· Visual Basic

· C#

· Delphi

The code starts by connecting the C1Spell component to the textbox that has the focus. Then the CheckTyping method is used for basic As-you-type Spell Checking. The value of the current textbox is then saved into the C1Spell IntegerTag property.

By default, the C1Spell component will beep and underline misspelled words. Our demo will provide additional functionality. We will show a red sign when a bad word is detected and, optionally, display a list of suggestions. To do this, add the following code to the C1Spell1_TypingError event:

· Visual Basic

· C#

· Delphi

This routine is pretty long, but it's fairly simple. If the "AutoCorrect" option is off, it simply shows the red shape to indicate that a word was misspelled and allows the C1Spell1 component to provide the default user-feedback actions (beep and underline the offending word).

If "AutoCorrect" is on, the routine uses the C1Spell1 CheckString method to build a list of suggestions. If C1Spell cannot provide any suggestions, the routine returns immediately. If a single suggestion is provided, the code replaces the offending word with the suggestion automatically. This is probably not a great idea in practice, but it's pretty cool to watch as the component corrects words automatically. Finally, if many suggestions are available, the component assembles them into a pop-up menu and prompts the user to select one of the options. In the demo, we only use the first five suggestions.

To make the pop-up menu work, we need to implement the menu-handling and text-changing functions. This code allows the user to select one of the items from the pop-up menu to replace the misspelled word. Once an error is corrected, the PictureBox will become green.

· Visual Basic

· C#

· Delphi

We're almost done now. We need to be able to hide the red shape when the user types in a word that is correct. This can be done easily using the C1Spell1_TypingOK event.

· Visual Basic

· C#

· Delphi

That's it for the top pane on our demo. Save the project and run it. Start typing into the top three textboxes and you will see Spell for .NET's As-you-type Spell Checking in action.

Here's how the main form looks when an error is found:


Step 4: Provide Long Document Spell Checking (middle panel)

Step 4: Provide Long Document Spell Checking (middle panel)

Previous Next

This step is really simple. Double-click the button on the middle panel and add the following code to the Button1_Click event:

· Visual Basic

· C#

· Delphi

All it takes to spell check the window is a single call to the CheckControl method. We also show a message box after we're done spell checking, but this is optional.

If you think you will be spell checking really long documents (over 200K, say), you may also want to handle the C1Spell2_Checking event. This will fire every second while spell checking a long document so you can display a progress bar or cancel the spell-checking process.

That's it for the middle pane on our demo. Save the project and run it again. Type some text into the middle panel textbox and click the button below. If you make any mistakes, you will see a dialog box containing suggestions, as shown below:


Step 5: Provide Spell Checking for Arbitrary Strings (bottom panel)

Step 5: Provide Spell Checking for Arbitrary Strings (bottom panel)

Previous Next

This part of the demo allows the user to change the contents of a list box and to spell check each item by clicking a button. In this case, the C1Spell component is not connected to any other controls. All spell checking is done through its CheckString method.

First of all, add the following two routines to connect the TextBox5 and ListBox1 controls.

· Visual Basic

· C#

· Delphi

The first routine copies a selected item from ListBox1 into TextBox5. The second copies the contents of TextBox5 into ListBox1 when the user makes any changes.

The final step is the routine that does the spell checking. It simply scans the ListBox1 control checking each list item and setting its selected state to True if no spelling errors were found, or False otherwise. Here is the code:

· Visual Basic

· C#

· Delphi

To spell check in this panel, type a word into the text box. You will notice that the word displays in the list. If you click on another word in the list and click the Spell Check button the misspelled word will be highlighted in the list.

That's it. This demo covers most aspects of the C1Spell component.


C1Spell Task-Based Help

C1Spell Task-Based Help

The task-based help assumes that you are familiar with programming in Visual Studio.NET. By following the steps outlined in the help, you will be able to utilize the features of ComponentOne Spell for .NET.

Each task-based help topic also assumes that you have created a new .NET project and have placed a bound C1Spell component on the form. For additional information, see Creating a .NET Project and Adding the C1Spell Components to the Toolbox.


As-you-type mode

As-you-type mode

The topics below demonstrate the methods, good for general data entry tasks, of check spelling using the C1Spell class.


Show a red sign

Show a red sign

The topic below shows how to use a red sign to signal misspelled words as you type. This topic uses the CheckTyping method and calls the TypingError event.

1. Place a C1Spell, TextBox, Label, and Panel component on the form. For more information, see Adding the C1Spell Components to the Toolbox.

Here is how the form should appear:

2. Double-click the form. To connect the C1Spell component to TextBox1, enter the following code in the Form_Load event handler:

· Visual Basic

· C#

· Delphi

3. To show a red sign for misspelled words call the TypingError event, and to show a green sign for correctly typed words call the TypingOK event. Add the code below:

· Visual Basic

· C#

· Delphi

4. Run your application. Here is what each form should look when an incorrect word or correct word is typed, respectfully:


Pop-up menu

Pop-up menu

This topic demonstrates how to provide as-you-type spell checking using the pop-up menu.

1. Place a C1Spell and ContextMenu component on the form. For more information, see Adding the C1Spell Components to the Toolbox.

2. From the component tray, select the ContextMenu control to view the control on the form. Right-click the control and select Insert New from the context menu. Place your cursor over "Type Here" and enter the following menu items:

3. Note that the default property for TypingErrorAction property is BeepandUnderline. You may choose a different action for the TypingErrorAction property, see the TypingErrorActionEnum enumeration members.

4. To connect the C1Spell component to TextBox1, double-click the form and enter the following code in the Form_Load event handler:

· Visual Basic

· C#

· Delphi

5. To call the TypingError event, enter the code below:

· Visual Basic

· C#

· Delphi

5. To create a context menu that includes more than one spelling suggestion, use the following code:

· Visual Basic

· C#

· Delphi

6. The code below selects the error word and replaces it with the correctly spelled menu item chosen by the user:

· Visual Basic

· C#

· Delphi

7. Run your application. Type a word in the TextBox. If it is misspelled, it will beep and underline. Right-click the word to view the spelling suggestions from the pop-up menu:


Window mode

Window mode

The topics below demonstrate the methods, good for windows that hold long documents, of check spelling using the C1Spell class.

1. Place a C1Spell component on the form. For more information, see Adding the C1Spell Components to the Toolbox.

2. From the Toolbox, add a TextBox and Button component to the form by double-clicking each component or dragging-and-dropping each onto the form.

Note that in order for the TextBox to hold more than one line of text, you must set the Multiline property of the TextBox to True. Also, to be able to see misspelled words better, set the HideSelection property to False.

3. To put text in the TextBox, double-click the form. In the Form_Load event handler, enter the following code:

· Visual Basic

· C#

· Delphi

4. To connect the C1Spell component to button1, double-click the button. In the button click event, enter the code below. This will check the entire window, displaying the Spelling Check dialog box when a misspelled word is found and listing suggestions when applicable:

· Visual Basic

· C#

· Delphi

5. To show a message box when the spell checking is complete, enter the following code in the button Click event:

· Visual Basic

· C#

· Delphi

6. Run your application. Misspell a word and the Spelling Check dialog box will appear:

The message box will appear when spell checking is complete, showing the total number of misspellings:


Thesaurus for .NET QuickStart

Thesaurus for .NET QuickStart

This section will lead you through the creation of a Visual Basic project that uses the C1Thesaurus component.

Begin by adding the C1Thesaurus component to the Visual Basic toolbox. If you are not sure how to do this, reference your Visual Basic manual or Help file on how to add custom components. Next, add a C1Thesaurus component to the form by double clicking on the C1Thesaurus component button in the toolbox. Add a textbox and a command button to the form and set the following properties:

· Visual Basic

· C#

· Delphi

Your form should look like the one shown below:

Main Thesaurus File

Setting Thesaurus for .NET to Check a Selected Word

Automatic Dialog Box

Other Thesaurus for .NET Features

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


Main Thesaurus File

Main Thesaurus File

Before any words can be checked, the MainThesFile property must be set to contain the complete path and filename of the main thesaurus file. This may be done in design time or at runtime. The component will search for the default main thesaurus filename (C1th_ae.the) in the Windows System directory. If the file is located there, you do not need to adjust the MainThesFile property.

However, if your main thesaurus file is not located in the Windows System directory you must specify the complete path and file name in the MainThesFile property, for example:


Setting Thesaurus for .NET to Check a Selected Word

Setting Thesaurus for .NET to Check a Selected Word

To check a word selected in the textbox, set the CheckWord method to the selected string. The following code does this:

· Visual Basic

· C#

· Delphi

Note: Once you set the CheckWord method from code, execution of your code is suspended until the Complete event is fired. In other words, any code following the statement that sets the CheckWord method will not run until the Complete event is fired.

· Run the C1Thesaurus program.

· In the textbox, type a word and highlight it.

· Then click the Thesaurus button to look for other similar words.


Automatic Dialog Box

Automatic Dialog Box

Leave the AutomaticDialog property set to its default value, EnglishDialog. This causes a dialog box (shown below) to show synonyms when a word is selected and the Thesaurus command button is pressed. The built-in dialog box greatly reduces the code needed to handle thesaurus checking.

Synonyms are generated for a word that is found in the thesaurus. The Suggestion event is fired each time a new synonym is added to the Synonyms collection. The NotFound event is fired if the word is not found in the thesaurus. The Suggestion event is not fired in this case.

The Suggestion, NotFound, and Complete events may be fired whether or not the dialog box is used. However, if you are using the automatic dialog box, there is no need to respond to the events since the dialog box can handle the user's responses automatically.

You have completed all the necessary steps to incorporate thesaurus functionality. You can now run your program. Type some words in the textbox, select a word and then press the Thesaurus button. The Thesaurus dialog box will appear. If the word is not found in the thesaurus file, the NotFound event is fired. After the thesaurus check is complete, the Complete event is fired, whether the word is good or bad.


Other Thesaurus for .NET Features

ComponentOne Spell for .NET E-mail sent to documentation@componentone.com is for documentation feedback only. We welcome any suggestions to help improve our documentation.

Other Thesaurus for .NET Features

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


Dialog Box Option Button (C1Thesaurus)

Dialog Box Option Button (C1Thesaurus)

Previous Next

Setting the OptionBtnVisible property to True (non-zero) causes a customizable option to be shown on the dialog box. By default, the option button is not visible. The default caption for the button is Options, but it can be changed by setting the OptionBtnCaption property. Pressing the button fires the OptionBtnClick event.


Dialog Box Help Button (C1Thesaurus)

Dialog Box Help Button (C1Thesaurus)

Previous Next

Setting the HelpBtnVisible property to True (non-zero) causes a Help button to be shown on the dialog box. By default, the Help button is not visible. Pressing the button fires the HelpBtnClick event.


C1.Win.C1Spell.2 Assembly

C1.Win.C1Spell.2 Assembly

Namespaces

C1.Win.C1Spell

See Also

C1.Win.C1Thesaurus.2 Assembly

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Thesaurus.2 Assembly

C1.Win.C1Thesaurus.2 Assembly

Namespaces

C1.Win.C1Thesaurus

See Also

C1.Win.C1Spell.2 Assembly

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Spell Namespace

C1.Win.C1Spell Namespace

C1.Win.C1Spell Hierarchy

Classes

Class | Description
BadWordEventArgs | Provides data for the BadWord event of C1Spell
C1Spell | Represents a spell checking control.
CharPair | Instances of the class that store the character pairs.
CharPairCollection | A collection of unique CharPair items.
CheckingEventArgs | Provides data for the Checking event of the C1Spell.
CheckStartEventArgs | Provides data for the CheckStart event of the C1Spell.
C1.Win.C1Spell.CompleteEventArgs | Provides data for the Complete event of C1Spell.
CustomDictionaryCollection | A collection of custom dictionaries.
DialogActionEventArgs | Provides data for the DialogAction event of C1Spell.
DialogProperty | Represents the title, font and location of the bad-word dialog box.
DictionaryItem | This class stores information about the path to a single custom dictionary file and Boolean flag that indicates if this file is used.
DlgSetting | Encapsulates the spell-checking options of the C1Spell component.
SpellErrorEventArgs | Provides data for the SpellError event of the C1Spell.
StringPair | String pairs are stored in instances of the StringPair class.
StringPairCollection | A collection of unique StringPair items.
C1.Win.C1Spell.SuggestionEventArgs | Provides data for the Suggestion event of C1Spell
TypingErrorEventArgs | Provides data for the TypingError event of C1Spell.
TypingOKEventArgs | Provides data for the TypingOK event of the C1Spell.
UIStrings | Collection of key-and-value pairs.
UIStringsItemEventArgs | Provides data for the ItemAdded and the ItemChanged events of the UIStrings class.

Delegates

Delegate | Description
BadWordEventHandler | Represents the method that will handle the BadWord event of C1Spell.
CheckingEventHandler | Represents the method that will handle the Checking event of the C1Spell.
CheckStartEventHandler | Represents the method that will handle the CheckStart event of the C1Spell.
CompleteEventHandler | Represents the method that will handle the Complete event of C1Spell.
DialogActionEventHandler | Represents the method that will handle the DialogAction event of C1Spell.
SpellErrorEventHandler | Represents the method that will handle the SpellError event of the C1Spell.
SuggestionEventHandler | Represents the method that will handle the Suggestion event of C1Spell.
TypingErrorEventHandler | Represents the method that will handle the TypingError event of C1Spell.
TypingOKEventHandler | Represents the method that will handle the TypingOK event of the C1Spell.

Enumerations

Enumeration | Description
BadWordDialogEnum | Enumerates the available dialog boxes that can appear when a bad word is found.
BadWordProblemEnum | Enumerates the problem caused during a spell check when a bad word is found and cannot be corrected when BadWord event was fired.
CommonWordCacheEnum | Enumerates the available common word caches to be used during spell checking.
DialogActionEnum | Enumerates the possible actions performed on the spelling dialog box during a spell check when DialogAction event was fired.
ErrorTypeEnum | Enumerates the possible types of errors caused when the SpellError event is fired.
LanguageEnum | Language of the MainDictFile dictionary.
TypingErrorActionEnum | Enumerates the available actions to be taken when an error word is typed.
UIStringsEnum | Sets the dialog strings for spell dialog and option dialog.
UnderlineStyleEnum | Enumerates the styles of underlining used when a word is misspelled.

See Also

C1.Win.C1Thesaurus.2 Assembly

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


BadWordDialogEnum Enumeration

BadWordDialogEnum Enumeration

Enumerates the available dialog boxes that can appear when a bad word is found.

[Visual Basic]

Public Enum BadWordDialogEnum

[C#]

public enum BadWordDialogEnum

[Delphi]

type BadWordDialogEnum = (DutchDialog, EnglishDialog, FrenchDialog, GermanDialog, NoDialog, SpanishDialog);

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

Remarks

Use the members of this enumeration to set the value of the BadWordDialog property.

Members

Member name | Description
DutchDialog | Indicates Dutch dialog box will appear.
EnglishDialog | Indicates the English dialog box will appear.
FrenchDialog | Indicates French dialog box will appear.
GermanDialog | Indicates the German dialog box will appear.
NoDialog | Indicates no dialog box will appear.
SpanishDialog | Indicates the Spanish dialog box will appear.

See Also

C1.Win.C1Spell Namespace

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


BadWordEventArgs Class

BadWordEventArgs Class

Provides data for the BadWord event of C1Spell

For a list of all members of this type, see BadWordEventArgs Members.

System.Object

System.EventArgs

C1.Win.C1Spell.BadWordEventArgs

[Visual Basic]

Public Class BadWordEventArgs

Inherits EventArgs

[C#]

public class BadWordEventArgs : EventArgs

[Delphi]

type BadWordEventArgs = class (EventArgs);

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


BadWordEventArgs Members

BadWordEventArgs Members

BadWordEventArgs overview

Public Constructors

BadWordEventArgs Constructor

Initializes a new instance of the BadWordEventArgs with the default values.

Public Properties

Problem

Gets or sets the BadWordProblemEnum object that represents the problem.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


BadWordEventArgs Constructor

BadWordEventArgs Constructor

Overload List

Initializes a new instance of the BadWordEventArgs with the default values.

[Visual Basic] Public Function New()

[C#] public BadWordEventArgs();

[Delphi] public constructor Create(); overload;

Initializes a new instance of the BadWordEventArgs with the predefined properties.

[Visual Basic] Public Function New(BadWordProblemEnum)

[C#] public BadWordEventArgs(BadWordProblemEnum);

[Delphi] public constructor Create(BadWordProblemEnum); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


BadWordEventArgs Constructor ()

BadWordEventArgs Constructor ()

Previous Next

Initializes a new instance of the BadWordEventArgs with the default values.

[Visual Basic]

Public Function New()

[C#]

public BadWordEventArgs()

[Delphi]

public constructor Create(); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


BadWordEventArgs Constructor (BadWordProblemEnum)

BadWordEventArgs Constructor (BadWordProblemEnum)

Previous Next

Initializes a new instance of the BadWordEventArgs with the predefined properties.

[Visual Basic]

Public Function New( _

ByVal problem As BadWordProblemEnum _

)

[C#]

public BadWordEventArgs(

BadWordProblemEnum problem

);

[Delphi]

public constructor Create(

problem: BadWordProblemEnum

); overload;

Parameters

problem

The BadWordProblemEnum object that represents the problem.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


BadWordEventArgs Properties

BadWordEventArgs Properties

The properties of the BadWordEventArgs class are listed here. For a complete list of BadWordEventArgs class members, see the BadWordEventArgs Members topic.

Public Properties

Problem

Gets or sets the BadWordProblemEnum object that represents the problem.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


BadWordEventArgs.Problem Property

BadWordEventArgs.Problem Property

Gets or sets the BadWordProblemEnum object that represents the problem.

[Visual Basic]

Public Property Problem As BadWordProblemEnum

[C#]

public BadWordProblemEnum Problem {get;set;}

[Delphi]

public property Problem: BadWordProblemEnum read get_Problem write set_Problem;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Spell.BadWordEventHandler Delegate

C1.Win.C1Spell.BadWordEventHandler Delegate

Represents the method that will handle the BadWord event of C1Spell.

[Visual Basic]

Public Delegate Sub BadWordEventHandler( _

ByVal sender As Object, _

ByVal e As BadWordEventArgs _

)

[C#]

public delegate void BadWordEventHandler(

object sender,

BadWordEventArgs e

);

[Delphi]

type BadWordEventHandler = procedure (

sender: Object;

e: BadWordEventArgs

) of object;

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

See Also

C1.Win.C1Spell Namespace

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


BadWordProblemEnum Enumeration

BadWordProblemEnum Enumeration

Enumerates the problem caused during a spell check when a bad word is found and cannot be corrected when BadWord event was fired.

[Visual Basic]

Public Enum BadWordProblemEnum

[C#]

public enum BadWordProblemEnum

[Delphi]

type BadWordProblemEnum = (NotInDict);

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

Members

Member name | Description
NotInDict | Indicates the bad word is not in any dictionary.

See Also

C1.Win.C1Spell Namespace

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell Class

C1Spell Class

Represents a spell checking control.

For a list of all members of this type, see C1Spell Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

C1.Win.C1Spell.C1Spell

[Visual Basic]

Public Class C1Spell

Inherits Component

Implements ah

[C#]

public class C1Spell : Component , ah

[Delphi]

type C1Spell = class (Component, ah);

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell Members

C1Spell Members

C1Spell overview

Public Constructors

C1Spell Constructor

Creates a new instance of the C1Spell class.

Public Properties

AddBtnVisible | Sets or returns whether the Add button is displayed in the bad-word dialog box.
AverageWordLength | Returns the average length of the words that were checked.
BadWordCount | Returns the number of bad words which were found during the last spell check.
BadWordDialog | Sets or returns the BadWordDialogEnum object that represents whether the bad-word dialog will be used and the language that should be used to display it.
CancelSpelling | Gets or sets value indicating whether spell checking process must be stopped or not.
CaretPosX | Returns the horizontal position of the caret in the edit window linked to the C1Spell control.
CaretPosY | Returns the vertical position of the caret in the edit window linked to the C1Spell control.
ChangeAllPair | Returns collection of the pairs "word - word to change". If word currently being checked exists in the collection then it is automatically replaced with corresponding one.
ChangeAllWords | Setting this property causes the word that is currently checked to be ignored and automatically replaces all words in the spell checking text that equals to the checked one with a value. After that, the currently checked word and the value are added to the ChangeAllPair collection.
CheckWord | Gets or sets the word being checked.
CommonWordCache | Gets or sets the CommonWordCacheEnum object that represents which cache of common words the control will use.
CustomDictFiles | Sets or returns the paths and filenames of the custom dictionary files.
DialogChangedWord | Returns the last word typed by the user into the bad-word dialog box.
DialogProp | Gets or sets the DialogProperty object that represents the title, font and location of the bad-word dialog box.
DictionaryIsProtected | Returns whether the MainDictFile file was protected when it was created.
DictionaryLanguage | Gets the LanguageEnum object that represents the language of the MainDictFile file.
DictionaryVersion | Returns the version number of the MainDictFile file.
DisplayDefaultOption | Sets or returns if the default option dialogbox will be used.
ForceWordToCustomDict | Sets or returns if the changed word will be added to the custom dictionary.
HasSuggestions | Sets or returns whether suggestions are generated for bad words.
HelpBtnVisible | Sets or returns if the Help button is visible in the bad-word dialog box.
IgnoreAll | Returns collection of words that will be automatically ignored during spell checking.
IgnoreAllWord | Setting this property to True causes the word that is being checked to be ignored and adds it to the IgnoreAll collection.
IgnoreInMixedCase | Sets or returns if words with uppercase characters after lowercase characters are ignored during spell checking.
IgnoreInUpperCase | Sets or returns if words in all uppercase are ignored during spell checking.
IgnoreWithNumbers | Sets or returns if words containing numbers are ignored during spell checking.
IgnoreWord | Setting this property to True causes the currently checked word to be ignored.
IntegerTag | This property is similar to the Tag standard property.
IsOptionSettingFixed | Sets or returns if the option setting by users will persist when the application runs the next time.
LastSpellError | Returns the last error code that occurred in the C1Spell control.
MainDictFile | Sets or returns the fully qualified filename of the main dictionary file.
MaxMenuSuggests | Sets or returns the maximum number of suggestions in the context menu.
OptionBtnCaption | Sets or returns the caption of the Option button in the bad-word dialog box.
OptionBtnVisible | Sets or returns if the Option button is visible in the bad-word dialog box.
SelLength | Returns the length of the word currently being checked.
SelStart | Returns the zero-based offset to the beginning of the word currently being checked.
SeparateChars | Returns the current separation characters for the spelling.
ShowDefaultContextMenu | Sets or returns whether or not the default context menu will be shown.
SkipCharsCollection | Returns the CharPairCollection collection of characters which bounds the text to be skipped during spell checking.
StartPosition | Sets or returns the start checking position in the text.
Suggestions | Returns the suggested word specified by the element during a BadWord event.
Tag | Sets or returns a string to store any string information for the component.
TypingErrorAction | Sets or returns the TypingErrorActionEnum object that represents the action to be taken when a typing error is detected.
UIStrings | Get the UIStrings object that represents the array of the user interface strings.
UnderlineColor | Sets or returns the color of the underline effect used to highlight typing errors.
UnderlineStyle | Sets or returns the UnderlineStyleEnum object that represents the style of the underline effect used to highlight typing errors while check typing.
UseFileNameInComb | Gets or sets if the file name that will be used in the combobox in the spelling dialog.
UseUIStrings | Determines whether or not we use the UIStrings.
WhichCustomDict | Sets or returns which custom dictionary to use when adding words to the custom dictionary.
WordCount | Returns the number of words that were checked during the last spell check.
WordsPerMinute | Returns the number of words processed per minute during a spell check.

Public Methods

AddChangeAll | Adds a word to the ChangeAllPair collection.
AddCharToSeparateArr | Adds new char into the SeparateChars array.
AddIgnoreAll | Adds a word to the IgnoreAll collection with duplicate checking.
AddToCustomFile | Adds the specified word to the custom dictionary specified by the WhichCustomDict property.
CheckControl | Overloaded. Starts spell checking the text in a given control.
CheckHTMLInControl | Overloaded. Starts spell checking the HTML text in a given control.
CheckHTMLString | Overloaded. Starts spell checking the given HTML string.
CheckString | Overloaded. Starts spell checking the given string without any bad-word dialog.
CheckTyping | Overloaded. Starts spell checking a control as the user types.
Clear | Clears the contents of all spell checking related properties.
ClearCheckTyping | Clears the content of the control properties that are related to the check typing process.
DeleteOptionSetting | Deletes the default spell checking settings file.
LoadSettings | Overloaded. Loads spell checking settings from the default xml file.
PartialClear | Clears the content of control properties related to the spell checking process, but preserves the IgnoreAll and ChangeAllPair collections.
RemoveCharFromSeparateArr | Removes specified char from the SeparateChars array.
RemoveSkipChars | Clears the SkipCharsCollection property.
SaveSettings | Overloaded. Saves the spell checking settings to the default xml file.
SkipInsideChars | Adds values to the SkipCharsCollection.

Public Events

BadWord | Fired when a bad word is encountered during a spell check.
Changed | Fired after the checked string is changed.
Checking | Fired every second during spell checking to provide user feedback while checking long documents.
CheckStart | Fired right before the spell checking is started.
Complete | Fired after the spell check has been completed.
DialogAction | Fired when a button is clicked on the bad-word dialog box.
HelpBtnClick | Fired when the Help button on the bad-word dialog box is clicked.
OptionBtnClick | Fired when the Option button on the bad-word dialog box is clicked.
PopupDialog | Fires when the user clicks the "spelling..." item of the C1Spell run-time context menu.
SpellError | Fired when a spell-checking error occurs.
Suggestion | Fired after a word has been added to the Suggestions collection.
TypingError | Fired when a typing error is detected after the CheckTyping method is invoked.
TypingOK | Fired when a correct word is typed after the CheckTyping method is invoked.

Protected Methods

Dispose

Overloaded. Overriden. Clean up any resources being used.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell Constructor

C1Spell Constructor

Creates a new instance of the C1Spell class.

[Visual Basic]

Public Function New()

[C#]

public C1Spell()

[Delphi]

public constructor Create();

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell Properties

C1Spell Properties

The properties of the C1Spell class are listed here. For a complete list of C1Spell class members, see the C1Spell Members topic.

Public Properties

AddBtnVisible | Sets or returns whether the Add button is displayed in the bad-word dialog box.
AverageWordLength | Returns the average length of the words that were checked.
BadWordCount | Returns the number of bad words which were found during the last spell check.
BadWordDialog | Sets or returns the BadWordDialogEnum object that represents whether the bad-word dialog will be used and the language that should be used to display it.
CancelSpelling | Gets or sets value indicating whether spell checking process must be stopped or not.
CaretPosX | Returns the horizontal position of the caret in the edit window linked to the C1Spell control.
CaretPosY | Returns the vertical position of the caret in the edit window linked to the C1Spell control.
ChangeAllPair | Returns collection of the pairs "word - word to change". If word currently being checked exists in the collection then it is automatically replaced with corresponding one.
ChangeAllWords | Setting this property causes the word that is currently checked to be ignored and automatically replaces all words in the spell checking text that equals to the checked one with a value. After that, the currently checked word and the value are added to the ChangeAllPair collection.
CheckWord | Gets or sets the word being checked.
CommonWordCache | Gets or sets the CommonWordCacheEnum object that represents which cache of common words the control will use.
CustomDictFiles | Sets or returns the paths and filenames of the custom dictionary files.
DialogChangedWord | Returns the last word typed by the user into the bad-word dialog box.
DialogProp | Gets or sets the DialogProperty object that represents the title, font and location of the bad-word dialog box.
DictionaryIsProtected | Returns whether the MainDictFile file was protected when it was created.
DictionaryLanguage | Gets the LanguageEnum object that represents the language of the MainDictFile file.
DictionaryVersion | Returns the version number of the MainDictFile file.
DisplayDefaultOption | Sets or returns if the default option dialogbox will be used.
ForceWordToCustomDict | Sets or returns if the changed word will be added to the custom dictionary.
HasSuggestions | Sets or returns whether suggestions are generated for bad words.
HelpBtnVisible | Sets or returns if the Help button is visible in the bad-word dialog box.
IgnoreAll | Returns collection of words that will be automatically ignored during spell checking.
IgnoreAllWord | Setting this property to True causes the word that is being checked to be ignored and adds it to the IgnoreAll collection.
IgnoreInMixedCase | Sets or returns if words with uppercase characters after lowercase characters are ignored during spell checking.
IgnoreInUpperCase | Sets or returns if words in all uppercase are ignored during spell checking.
IgnoreWithNumbers | Sets or returns if words containing numbers are ignored during spell checking.
IgnoreWord | Setting this property to True causes the currently checked word to be ignored.
IntegerTag | This property is similar to the Tag standard property.
IsOptionSettingFixed | Sets or returns if the option setting by users will persist when the application runs the next time.
LastSpellError | Returns the last error code that occurred in the C1Spell control.
MainDictFile | Sets or returns the fully qualified filename of the main dictionary file.
MaxMenuSuggests | Sets or returns the maximum number of suggestions in the context menu.
OptionBtnCaption | Sets or returns the caption of the Option button in the bad-word dialog box.
OptionBtnVisible | Sets or returns if the Option button is visible in the bad-word dialog box.
SelLength | Returns the length of the word currently being checked.
SelStart | Returns the zero-based offset to the beginning of the word currently being checked.
SeparateChars | Returns the current separation characters for the spelling.
ShowDefaultContextMenu | Sets or returns whether or not the default context menu will be shown.
SkipCharsCollection | Returns the CharPairCollection collection of characters which bounds the text to be skipped during spell checking.
StartPosition | Sets or returns the start checking position in the text.
Suggestions | Returns the suggested word specified by the element during a BadWord event.
Tag | Sets or returns a string to store any string information for the component.
TypingErrorAction | Sets or returns the TypingErrorActionEnum object that represents the action to be taken when a typing error is detected.
UIStrings | Get the UIStrings object that represents the array of the user interface strings.
UnderlineColor | Sets or returns the color of the underline effect used to highlight typing errors.
UnderlineStyle | Sets or returns the UnderlineStyleEnum object that represents the style of the underline effect used to highlight typing errors while check typing.
UseFileNameInComb | Gets or sets if the file name that will be used in the combobox in the spelling dialog.
UseUIStrings | Determines whether or not we use the UIStrings.
WhichCustomDict | Sets or returns which custom dictionary to use when adding words to the custom dictionary.
WordCount | Returns the number of words that were checked during the last spell check.
WordsPerMinute | Returns the number of words processed per minute during a spell check.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.AddBtnVisible Property

C1Spell.AddBtnVisible Property

Sets or returns whether the Add button is displayed in the bad-word dialog box.

[Visual Basic]

Public Property AddBtnVisible As Boolean

[C#]

public bool AddBtnVisible {get;set;}

[Delphi]

public property AddBtnVisible: Boolean read get_AddBtnVisible write set_AddBtnVisible;

Remarks

Use the Add button to add a word to the custom dictionary.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.AverageWordLength Property

C1Spell.AverageWordLength Property

Returns the average length of the words that were checked.

[Visual Basic]

Public ReadOnly Property AverageWordLength As Long

[C#]

public long AverageWordLength {get;}

[Delphi]

public property AverageWordLength: Int64 read get_AverageWordLength;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.BadWordCount Property

C1Spell.BadWordCount Property

Returns the number of bad words which were found during the last spell check.

[Visual Basic]

Public ReadOnly Property BadWordCount As Integer

[C#]

public int BadWordCount {get;}

[Delphi]

public property BadWordCount: Int32 read get_BadWordCount;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.BadWordDialog Property

C1Spell.BadWordDialog Property

Sets or returns the BadWordDialogEnum object that represents whether the bad-word dialog will be used and the language that should be used to display it.

[Visual Basic]

Public Property BadWordDialog As BadWordDialogEnum

[C#]

public BadWordDialogEnum BadWordDialog {get;set;}

[Delphi]

public property BadWordDialog: BadWordDialogEnum read get_BadWordDialog write set_BadWordDialog;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.CancelSpelling Property

C1Spell.CancelSpelling Property

Gets or sets value indicating whether spell checking process must be stopped or not.

[Visual Basic]

Public Property CancelSpelling As Boolean

[C#]

public bool CancelSpelling {get;set;}

[Delphi]

public property CancelSpelling: Boolean read get_CancelSpelling write set_CancelSpelling;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.CaretPosX Property

C1Spell.CaretPosX Property

Returns the horizontal position of the caret in the edit window linked to the C1Spell control.

[Visual Basic]

Public ReadOnly Property CaretPosX As Long

[C#]

public long CaretPosX {get;}

[Delphi]

public property CaretPosX: Int64 read get_CaretPosX;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.CaretPosY Property

C1Spell.CaretPosY Property

Returns the vertical position of the caret in the edit window linked to the C1Spell control.

[Visual Basic]

Public ReadOnly Property CaretPosY As Long

[C#]

public long CaretPosY {get;}

[Delphi]

public property CaretPosY: Int64 read get_CaretPosY;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.ChangeAllPair Property

C1Spell.ChangeAllPair Property

Returns collection of the pairs "word - word to change". If word currently being checked exists in the collection then it is automatically replaced with corresponding one.

[Visual Basic]

Public ReadOnly Property ChangeAllPair As StringPairCollection

[C#]

public StringPairCollection ChangeAllPair {get;}

[Delphi]

public property ChangeAllPair: StringPairCollection read get_ChangeAllPair;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.ChangeAllWords Property

C1Spell.ChangeAllWords Property

Setting this property causes the word that is currently checked to be ignored and automatically replaces all words in the spell checking text that equals to the checked one with a value. After that, the currently checked word and the value are added to the ChangeAllPair collection.

[Visual Basic]

Public WriteOnly Property ChangeAllWords As String

[C#]

public string ChangeAllWords {set;}

[Delphi]

public property ChangeAllWords: String write set_ChangeAllWords;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.CheckWord Property

C1Spell.CheckWord Property

Gets or sets the word being checked.

[Visual Basic]

Public Property CheckWord As String

[C#]

public string CheckWord {get;set;}

[Delphi]

public property CheckWord: String read get_CheckWord write set_CheckWord;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.CommonWordCache Property

C1Spell.CommonWordCache Property

Gets or sets the CommonWordCacheEnum object that represents which cache of common words the control will use.

[Visual Basic]

Public Property CommonWordCache As CommonWordCacheEnum

[C#]

public CommonWordCacheEnum CommonWordCache {get;set;}

[Delphi]

public property CommonWordCache: CommonWordCacheEnum read get_CommonWordCache write set_CommonWordCache;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.CustomDictFiles Property

C1Spell.CustomDictFiles Property

Sets or returns the paths and filenames of the custom dictionary files.

[Visual Basic]

Public Property CustomDictFiles As String()

[C#]

public string[] CustomDictFiles {get;set;}

[Delphi]

public property CustomDictFiles: array of String read get_CustomDictFiles write set_CustomDictFiles;

Remarks

Custom dictionary is the plain "string per line" file.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.DialogChangedWord Property

C1Spell.DialogChangedWord Property

Returns the last word typed by the user into the bad-word dialog box.

[Visual Basic]

Public Property DialogChangedWord As String

[C#]

public string DialogChangedWord {get;set;}

[Delphi]

public property DialogChangedWord: String read get_DialogChangedWord write set_DialogChangedWord;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.DialogProp Property

C1Spell.DialogProp Property

Gets or sets the DialogProperty object that represents the title, font and location of the bad-word dialog box.

[Visual Basic]

Public ReadOnly Property DialogProp As DialogProperty

[C#]

public DialogProperty DialogProp {get;}

[Delphi]

public property DialogProp: DialogProperty read get_DialogProp;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.DictionaryIsProtected Property

C1Spell.DictionaryIsProtected Property

Returns whether the MainDictFile file was protected when it was created.

[Visual Basic]

Public ReadOnly Property DictionaryIsProtected As Boolean

[C#]

public bool DictionaryIsProtected {get;}

[Delphi]

public property DictionaryIsProtected: Boolean read get_DictionaryIsProtected;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.DictionaryLanguage Property

C1Spell.DictionaryLanguage Property

Gets the LanguageEnum object that represents the language of the MainDictFile file.

[Visual Basic]

Public ReadOnly Property DictionaryLanguage As LanguageEnum

[C#]

public LanguageEnum DictionaryLanguage {get;}

[Delphi]

public property DictionaryLanguage: LanguageEnum read get_DictionaryLanguage;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.DictionaryVersion Property

C1Spell.DictionaryVersion Property

Returns the version number of the MainDictFile file.

[Visual Basic]

Public ReadOnly Property DictionaryVersion As Integer

[C#]

public int DictionaryVersion {get;}

[Delphi]

public property DictionaryVersion: Int32 read get_DictionaryVersion;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.DisplayDefaultOption Property

C1Spell.DisplayDefaultOption Property

Sets or returns if the default option dialogbox will be used.

[Visual Basic]

Public Property DisplayDefaultOption As Boolean

[C#]

public bool DisplayDefaultOption {get;set;}

[Delphi]

public property DisplayDefaultOption: Boolean read get_DisplayDefaultOption write set_DisplayDefaultOption;

Remarks

By setting this property to False you can handle the OptionBtnClick event to show your custom Option dialog or something else.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.ForceWordToCustomDict Property

C1Spell.ForceWordToCustomDict Property

Sets or returns if the changed word will be added to the custom dictionary.

[Visual Basic]

Public Property ForceWordToCustomDict As Boolean

[C#]

public bool ForceWordToCustomDict {get;set;}

[Delphi]

public property ForceWordToCustomDict: Boolean read get_ForceWordToCustomDict write set_ForceWordToCustomDict;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.HasSuggestions Property

C1Spell.HasSuggestions Property

Sets or returns whether suggestions are generated for bad words.

[Visual Basic]

Public Property HasSuggestions As Boolean

[C#]

public bool HasSuggestions {get;set;}

[Delphi]

public property HasSuggestions: Boolean read get_HasSuggestions write set_HasSuggestions;

Remarks

Set this property to False to improve speed of the spell checking.

Use the Suggestion event to find out the generated suggestion.

See the Suggestions collection to find out all suggestions generated for spell checking words.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.HelpBtnVisible Property

C1Spell.HelpBtnVisible Property

Sets or returns if the Help button is visible in the bad-word dialog box.

[Visual Basic]

Public Property HelpBtnVisible As Boolean

[C#]

public bool HelpBtnVisible {get;set;}

[Delphi]

public property HelpBtnVisible: Boolean read get_HelpBtnVisible write set_HelpBtnVisible;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.IgnoreAll Property

C1Spell.IgnoreAll Property

Returns collection of words that will be automatically ignored during spell checking.

[Visual Basic]

Public ReadOnly Property IgnoreAll As StringCollection

[C#]

public StringCollection IgnoreAll {get;}

[Delphi]

public property IgnoreAll: StringCollection read get_IgnoreAll;

Remarks

Because duplicate strings are allowed in this collection it is recommended to use the AddIgnoreAll method to add strings into the collection instead of direct call of the collection's Add method.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.IgnoreAllWord Property

C1Spell.IgnoreAllWord Property

Setting this property to True causes the word that is being checked to be ignored and adds it to the IgnoreAll collection.

[Visual Basic]

Public Property IgnoreAllWord As Boolean

[C#]

public bool IgnoreAllWord {get;set;}

[Delphi]

public property IgnoreAllWord: Boolean read get_IgnoreAllWord write set_IgnoreAllWord;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.IgnoreInMixedCase Property

C1Spell.IgnoreInMixedCase Property

Sets or returns if words with uppercase characters after lowercase characters are ignored during spell checking.

[Visual Basic]

Public Property IgnoreInMixedCase As Boolean

[C#]

public bool IgnoreInMixedCase {get;set;}

[Delphi]

public property IgnoreInMixedCase: Boolean read get_IgnoreInMixedCase write set_IgnoreInMixedCase;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.IgnoreInUpperCase Property

C1Spell.IgnoreInUpperCase Property

Sets or returns if words in all uppercase are ignored during spell checking.

[Visual Basic]

Public Property IgnoreInUpperCase As Boolean

[C#]

public bool IgnoreInUpperCase {get;set;}

[Delphi]

public property IgnoreInUpperCase: Boolean read get_IgnoreInUpperCase write set_IgnoreInUpperCase;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.IgnoreWithNumbers Property

C1Spell.IgnoreWithNumbers Property

Sets or returns if words containing numbers are ignored during spell checking.

[Visual Basic]

Public Property IgnoreWithNumbers As Boolean

[C#]

public bool IgnoreWithNumbers {get;set;}

[Delphi]

public property IgnoreWithNumbers: Boolean read get_IgnoreWithNumbers write set_IgnoreWithNumbers;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.IgnoreWord Property

C1Spell.IgnoreWord Property

Setting this property to True causes the currently checked word to be ignored.

[Visual Basic]

Public WriteOnly Property IgnoreWord As Boolean

[C#]

public bool IgnoreWord {set;}

[Delphi]

public property IgnoreWord: Boolean write set_IgnoreWord;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.IntegerTag Property

C1Spell.IntegerTag Property

This property is similar to the Tag standard property.

[Visual Basic]

Public Property IntegerTag As Integer

[C#]

public int IntegerTag {get;set;}

[Delphi]

public property IntegerTag: Int32 read get_IntegerTag write set_IntegerTag;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.IsOptionSettingFixed Property

C1Spell.IsOptionSettingFixed Property

Sets or returns if the option setting by users will persist when the application runs the next time.

[Visual Basic]

Public Property IsOptionSettingFixed As Boolean

[C#]

public bool IsOptionSettingFixed {get;set;}

[Delphi]

public property IsOptionSettingFixed: Boolean read get_IsOptionSettingFixed write set_IsOptionSettingFixed;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.LastSpellError Property

C1Spell.LastSpellError Property

Returns the last error code that occurred in the C1Spell control.

[Visual Basic]

Public ReadOnly Property LastSpellError As ErrorTypeEnum

[C#]

public ErrorTypeEnum LastSpellError {get;}

[Delphi]

public property LastSpellError: ErrorTypeEnum read get_LastSpellError;

Remarks

See also the SpellError event.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.MainDictFile Property

C1Spell.MainDictFile Property

Sets or returns the fully qualified filename of the main dictionary file.

[Visual Basic]

Public Property MainDictFile As String

[C#]

public string MainDictFile {get;set;}

[Delphi]

public property MainDictFile: String read get_MainDictFile write set_MainDictFile;

Remarks

If only the filename is specified, then the file searches in the following directories: system directory, current directory, and assembly directory.

Use the LastSpellError property and the SpellError event to find out the occurred errors.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.MaxMenuSuggests Property

C1Spell.MaxMenuSuggests Property

Sets or returns the maximum number of suggestions in the context menu.

[Visual Basic]

Public Property MaxMenuSuggests As Integer

[C#]

public int MaxMenuSuggests {get;set;}

[Delphi]

public property MaxMenuSuggests: Int32 read get_MaxMenuSuggests write set_MaxMenuSuggests;

Remarks

This menu appears when the user right-clicks the mouse button on the incorrect word during the check typing.

See also ShowDefaultContextMenu

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.OptionBtnCaption Property

C1Spell.OptionBtnCaption Property

Sets or returns the caption of the Option button in the bad-word dialog box.

[Visual Basic]

Public Property OptionBtnCaption As String

[C#]

public string OptionBtnCaption {get;set;}

[Delphi]

public property OptionBtnCaption: String read get_OptionBtnCaption write set_OptionBtnCaption;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.OptionBtnVisible Property

C1Spell.OptionBtnVisible Property

Sets or returns if the Option button is visible in the bad-word dialog box.

[Visual Basic]

Public Property OptionBtnVisible As Boolean

[C#]

public bool OptionBtnVisible {get;set;}

[Delphi]

public property OptionBtnVisible: Boolean read get_OptionBtnVisible write set_OptionBtnVisible;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.SelLength Property

C1Spell.SelLength Property

Returns the length of the word currently being checked.

[Visual Basic]

Public Property SelLength As Long

[C#]

public long SelLength {get;set;}

[Delphi]

public property SelLength: Int64 read get_SelLength write set_SelLength;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.SelStart Property

C1Spell.SelStart Property

Returns the zero-based offset to the beginning of the word currently being checked.

[Visual Basic]

Public Property SelStart As Long

[C#]

public long SelStart {get;set;}

[Delphi]

public property SelStart: Int64 read get_SelStart write set_SelStart;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.SeparateChars Property

C1Spell.SeparateChars Property

Returns the current separation characters for the spelling.

[Visual Basic]

Public ReadOnly Property SeparateChars As Char()

[C#]

public char[] SeparateChars {get;}

[Delphi]

public property SeparateChars: array of Char read get_SeparateChars;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.ShowDefaultContextMenu Property

C1Spell.ShowDefaultContextMenu Property

Sets or returns whether or not the default context menu will be shown.

[Visual Basic]

Public Property ShowDefaultContextMenu As Boolean

[C#]

public bool ShowDefaultContextMenu {get;set;}

[Delphi]

public property ShowDefaultContextMenu: Boolean read get_ShowDefaultContextMenu write set_ShowDefaultContextMenu;

Remarks

This menu appears when the user right-clicks the mouse button on the incorrect word during the check typing.

See also MaxMenuSuggests

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.SkipCharsCollection Property

C1Spell.SkipCharsCollection Property

Returns the CharPairCollection collection of characters which bounds the text to be skipped during spell checking.

[Visual Basic]

Public ReadOnly Property SkipCharsCollection As CharPairCollection

[C#]

public CharPairCollection SkipCharsCollection {get;}

[Delphi]

public property SkipCharsCollection: CharPairCollection read get_SkipCharsCollection;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.StartPosition Property

C1Spell.StartPosition Property

Sets or returns the start checking position in the text.

[Visual Basic]

Public Property StartPosition As Integer

[C#]

public int StartPosition {get;set;}

[Delphi]

public property StartPosition: Int32 read get_StartPosition write set_StartPosition;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.Suggestions Property

C1Spell.Suggestions Property

Returns the suggested word specified by the element during a BadWord event.

[Visual Basic]

Public ReadOnly Property Suggestions As StringCollection

[C#]

public StringCollection Suggestions {get;}

[Delphi]

public property Suggestions: StringCollection read get_Suggestions;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.Tag Property

C1Spell.Tag Property

Sets or returns a string to store any string information for the component.

[Visual Basic]

Public Property Tag As String

[C#]

public string Tag {get;set;}

[Delphi]

public property Tag: String read get_Tag write set_Tag;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.TypingErrorAction Property

C1Spell.TypingErrorAction Property

Sets or returns the TypingErrorActionEnum object that represents the action to be taken when a typing error is detected.

[Visual Basic]

Public Property TypingErrorAction As TypingErrorActionEnum

[C#]

public TypingErrorActionEnum TypingErrorAction {get;set;}

[Delphi]

public property TypingErrorAction: TypingErrorActionEnum read get_TypingErrorAction write set_TypingErrorAction;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.UIStrings Property

C1Spell.UIStrings Property

Get the UIStrings object that represents the array of the user interface strings.

[Visual Basic]

Public ReadOnly Property UIStrings As UIStrings

[C#]

public UIStrings UIStrings {get;}

[Delphi]

public property UIStrings: UIStrings read get_UIStrings;

Remarks

You must set the UseUIStrings property to True, to enable this feature.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.UnderlineColor Property

C1Spell.UnderlineColor Property

Sets or returns the color of the underline effect used to highlight typing errors.

[Visual Basic]

Public Property UnderlineColor As Color

[C#]

public Color UnderlineColor {get;set;}

[Delphi]

public property UnderlineColor: Color read get_UnderlineColor write set_UnderlineColor;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.UnderlineStyle Property

C1Spell.UnderlineStyle Property

Sets or returns the UnderlineStyleEnum object that represents the style of the underline effect used to highlight typing errors while check typing.

[Visual Basic]

Public Property UnderlineStyle As UnderlineStyleEnum

[C#]

public UnderlineStyleEnum UnderlineStyle {get;set;}

[Delphi]

public property UnderlineStyle: UnderlineStyleEnum read get_UnderlineStyle write set_UnderlineStyle;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.UseFileNameInComb Property

C1Spell.UseFileNameInComb Property

Gets or sets if the file name that will be used in the combobox in the spelling dialog.

[Visual Basic]

Public Property UseFileNameInComb As Boolean

[C#]

public bool UseFileNameInComb {get;set;}

[Delphi]

public property UseFileNameInComb: Boolean read get_UseFileNameInComb write set_UseFileNameInComb;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.UseUIStrings Property

C1Spell.UseUIStrings Property

Determines whether or not we use the UIStrings.

[Visual Basic]

Public Property UseUIStrings As Boolean

[C#]

public bool UseUIStrings {get;set;}

[Delphi]

public property UseUIStrings: Boolean read get_UseUIStrings write set_UseUIStrings;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.WhichCustomDict Property

C1Spell.WhichCustomDict Property

Sets or returns which custom dictionary to use when adding words to the custom dictionary.

[Visual Basic]

Public Property WhichCustomDict As Integer

[C#]

public int WhichCustomDict {get;set;}

[Delphi]

public property WhichCustomDict: Int32 read get_WhichCustomDict write set_WhichCustomDict;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.WordCount Property

C1Spell.WordCount Property

Returns the number of words that were checked during the last spell check.

[Visual Basic]

Public ReadOnly Property WordCount As Long

[C#]

public long WordCount {get;}

[Delphi]

public property WordCount: Int64 read get_WordCount;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.WordsPerMinute Property

C1Spell.WordsPerMinute Property

Returns the number of words processed per minute during a spell check.

[Visual Basic]

Public ReadOnly Property WordsPerMinute As Long

[C#]

public long WordsPerMinute {get;}

[Delphi]

public property WordsPerMinute: Int64 read get_WordsPerMinute;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell Methods

C1Spell Methods

The methods of the C1Spell class are listed here. For a complete list of C1Spell class members, see the C1Spell Members topic.

Public Methods

AddChangeAll | Adds a word to the ChangeAllPair collection.
AddCharToSeparateArr | Adds new char into the SeparateChars array.
AddIgnoreAll | Adds a word to the IgnoreAll collection with duplicate checking.
AddToCustomFile | Adds the specified word to the custom dictionary specified by the WhichCustomDict property.
CheckControl | Overloaded. Starts spell checking the text in a given control.
CheckHTMLInControl | Overloaded. Starts spell checking the HTML text in a given control.
CheckHTMLString | Overloaded. Starts spell checking the given HTML string.
CheckString | Overloaded. Starts spell checking the given string without any bad-word dialog.
CheckTyping | Overloaded. Starts spell checking a control as the user types.
Clear | Clears the contents of all spell checking related properties.
ClearCheckTyping | Clears the content of the control properties that are related to the check typing process.
DeleteOptionSetting | Deletes the default spell checking settings file.
LoadSettings | Overloaded. Loads spell checking settings from the default xml file.
PartialClear | Clears the content of control properties related to the spell checking process, but preserves the IgnoreAll and ChangeAllPair collections.
RemoveCharFromSeparateArr | Removes specified char from the SeparateChars array.
RemoveSkipChars | Clears the SkipCharsCollection property.
SaveSettings | Overloaded. Saves the spell checking settings to the default xml file.
SkipInsideChars | Adds values to the SkipCharsCollection.

Protected Methods

Dispose

Overloaded. Overriden. Clean up any resources being used.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.AddChangeAll Method

C1Spell.AddChangeAll Method

Adds a word to the ChangeAllPair collection.

[Visual Basic]

Public Sub AddChangeAll( _

ByVal word As String, _

ByVal changeTo As String _

)

[C#]

public void AddChangeAll(

string word,

string changeTo

);

[Delphi]

public procedure AddChangeAll(

word: String;

changeTo: String

);

Parameters

word

Word to be changed.

changeTo

Word to change to.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.AddCharToSeparateArr Method

C1Spell.AddCharToSeparateArr Method

Adds new char into the SeparateChars array.

[Visual Basic]

Public Sub AddCharToSeparateArr( _

ByVal c As Char _

)

[C#]

public void AddCharToSeparateArr(

char c

);

[Delphi]

public procedure AddCharToSeparateArr(

c: Char

);

Parameters

c

Char to add.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.AddIgnoreAll Method

C1Spell.AddIgnoreAll Method

Adds a word to the IgnoreAll collection with duplicate checking.

[Visual Basic]

Public Sub AddIgnoreAll( _

ByVal word As String _

)

[C#]

public void AddIgnoreAll(

string word

);

[Delphi]

public procedure AddIgnoreAll(

word: String

);

Parameters

word

Word to add.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.AddToCustomFile Method

C1Spell.AddToCustomFile Method

Adds the specified word to the custom dictionary specified by the WhichCustomDict property.

[Visual Basic]

Public Function AddToCustomFile( _

ByVal word As String _

) As Boolean

[C#]

public bool AddToCustomFile(

string word

);

[Delphi]

public function AddToCustomFile(

word: String

): Boolean;

Return Value

Value indicates if word has been successfully added to the custom dictionary or not.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.CheckControl Method

C1Spell.CheckControl Method

Overload List

Starts spell checking the text in a given control.

[Visual Basic] Overloads Public Sub CheckControl(Control)

[C#] public void CheckControl(Control);

[Delphi] public procedure CheckControl(Control); overload;

Starts spell checking the text in a given control.

[Visual Basic] Overloads Public Sub CheckControl(Control, BadWordDialogEnum)

[C#] public void CheckControl(Control, BadWordDialogEnum);

[Delphi] public procedure CheckControl(Control; BadWordDialogEnum); overload;

Starts spell checking the text in a given control.

[Visual Basic] Overloads Public Sub CheckControl(Control, BadWordDialogEnum, Boolean, Boolean, Boolean)

[C#] public void CheckControl(Control, BadWordDialogEnum, bool, bool, bool);

[Delphi] public procedure CheckControl(Control; BadWordDialogEnum; Boolean; Boolean; Boolean); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.CheckControl Method (Control)

C1Spell.CheckControl Method (Control)

Previous Next

Starts spell checking the text in a given control.

[Visual Basic]

Overloads Public Sub CheckControl( _

ByVal ctrl As Control _

)

[C#]

public void CheckControl(

Control ctrl

);

[Delphi]

public procedure CheckControl(

ctrl: Control

); overload;

Parameters

ctrl

Control to check

Remarks

Use the LastSpellError property and the SpellError event to find out the occurred errors.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.CheckControl Method (Control, BadWordDialogEnum)

C1Spell.CheckControl Method (Control, BadWordDialogEnum)

Previous Next

Starts spell checking the text in a given control.

[Visual Basic]

Overloads Public Sub CheckControl( _

ByVal ctrl As Control, _

ByVal dialog As BadWordDialogEnum _

)

[C#]

public void CheckControl(

Control ctrl,

BadWordDialogEnum dialog

);

[Delphi]

public procedure CheckControl(

ctrl: Control;

dialog: BadWordDialogEnum

); overload;

Parameters

ctrl

Control to check.

dialog

The BadWordDialogEnum object that represents whether the bad-word dialog will be used and the language that should be used to display it.

Remarks

Use the LastSpellError property and the SpellError event to find out the occurred errors.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.CheckControl Method (Control, BadWordDialogEnum, Boolean, Boolean, Boolean)

C1Spell.CheckControl Method (Control, BadWordDialogEnum, Boolean, Boolean, Boolean)

Previous Next

Starts spell checking the text in a given control.

[Visual Basic]

Overloads Public Sub CheckControl( _

ByVal ctrl As Control, _

ByVal dialog As BadWordDialogEnum, _

ByVal ignoreWithNumbers As Boolean, _

ByVal ignoreInUpperCase As Boolean, _

ByVal ignoreInMixedCase As Boolean _

)

[C#]

public void CheckControl(

Control ctrl,

BadWordDialogEnum dialog,

bool ignoreWithNumbers,

bool ignoreInUpperCase,

bool ignoreInMixedCase

);

[Delphi]

public procedure CheckControl(

ctrl: Control;

dialog: BadWordDialogEnum;

ignoreWithNumbers: Boolean;

ignoreInUpperCase: Boolean;

ignoreInMixedCase: Boolean

); overload;

Parameters

ctrl

Control to check.

dialog

The BadWordDialogEnum object that represents whether the bad-word dialog will be used and the language that should be used to display it.

ignoreWithNumbers

Value that indicates if words containing numbers are ignored during spell checking.

ignoreInUpperCase

Value that indicates if words in all uppercase are ignored during spell checking.

ignoreInMixedCase

Value that indicates if words with uppercase characters after lowercase characters are ignored during spell checking.

Remarks

Use the LastSpellError property and the SpellError event to find out the occurred errors.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.CheckHTMLInControl Method

C1Spell.CheckHTMLInControl Method

Overload List

Starts spell checking the HTML text in a given control.

[Visual Basic] Overloads Public Sub CheckHTMLInControl(Control)

[C#] public void CheckHTMLInControl(Control);

[Delphi] public procedure CheckHTMLInControl(Control); overload;

Starts spell checking the HTML text in a given control.

[Visual Basic] Overloads Public Sub CheckHTMLInControl(Control, BadWordDialogEnum)

[C#] public void CheckHTMLInControl(Control, BadWordDialogEnum);

[Delphi] public procedure CheckHTMLInControl(Control; BadWordDialogEnum); overload;

Starts spell checking the HTML text in a given control.

[Visual Basic] Overloads Public Sub CheckHTMLInControl(Control, BadWordDialogEnum, Boolean, Boolean, Boolean)

[C#] public void CheckHTMLInControl(Control, BadWordDialogEnum, bool, bool, bool);

[Delphi] public procedure CheckHTMLInControl(Control; BadWordDialogEnum; Boolean; Boolean; Boolean); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.CheckHTMLInControl Method (Control)

C1Spell.CheckHTMLInControl Method (Control)

Previous Next

Starts spell checking the HTML text in a given control.

[Visual Basic]

Overloads Public Sub CheckHTMLInControl( _

ByVal ctrl As Control _

)

[C#]

public void CheckHTMLInControl(

Control ctrl

);

[Delphi]

public procedure CheckHTMLInControl(

ctrl: Control

); overload;

Parameters

ctrl

Control to check.

Remarks

All text inside the html tags will be skipped during the spell checking.

Use the LastSpellError property and the SpellError event to find out the occurred errors.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.CheckHTMLInControl Method (Control, BadWordDialogEnum)

C1Spell.CheckHTMLInControl Method (Control, BadWordDialogEnum)

Previous Next

Starts spell checking the HTML text in a given control.

[Visual Basic]

Overloads Public Sub CheckHTMLInControl( _

ByVal ctrl As Control, _

ByVal dialog As BadWordDialogEnum _

)

[C#]

public void CheckHTMLInControl(

Control ctrl,

BadWordDialogEnum dialog

);

[Delphi]

public procedure CheckHTMLInControl(

ctrl: Control;

dialog: BadWordDialogEnum

); overload;

Parameters

ctrl

Control to check.

dialog

The BadWordDialogEnum object that represents whether the bad-word dialog will be used and the language that should be used to display it.

Remarks

All text inside the html tags will be skipped during the spell checking.

Use the LastSpellError property and the SpellError event to find out the occurred errors.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.CheckHTMLInControl Method (Control, BadWordDialogEnum, Boolean, Boolean, Boolean)

C1Spell.CheckHTMLInControl Method (Control, BadWordDialogEnum, Boolean, Boolean, Boolean)

Previous Next

Starts spell checking the HTML text in a given control.

[Visual Basic]

Overloads Public Sub CheckHTMLInControl( _

ByVal ctrl As Control, _

ByVal dialog As BadWordDialogEnum, _

ByVal ignoreWithNumbers As Boolean, _

ByVal ignoreInUpperCase As Boolean, _

ByVal ignoreInMixedCase As Boolean _

)

[C#]

public void CheckHTMLInControl(

Control ctrl,

BadWordDialogEnum dialog,

bool ignoreWithNumbers,

bool ignoreInUpperCase,

bool ignoreInMixedCase

);

[Delphi]

public procedure CheckHTMLInControl(

ctrl: Control;

dialog: BadWordDialogEnum;

ignoreWithNumbers: Boolean;

ignoreInUpperCase: Boolean;

ignoreInMixedCase: Boolean

); overload;

Parameters

ctrl

Control to check.

dialog

The BadWordDialogEnum object that represents whether the bad-word dialog will be used and the language that should be used to display it.

ignoreWithNumbers

Value that indicates if words containing numbers are ignored during spell checking.

ignoreInUpperCase

Value that indicates if words in all uppercase are ignored during spell checking.

ignoreInMixedCase

Value that indicates if words with uppercase characters after lowercase characters are ignored during spell checking.

Remarks

All text inside the html tags will be skipped during the spell checking.

Use the LastSpellError property and the SpellError event to find out the occurred errors.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.CheckHTMLString Method

C1Spell.CheckHTMLString Method

Overload List

Starts spell checking the given HTML string.

[Visual Basic] Overloads Public Function CheckHTMLString(String) As String

[C#] public string CheckHTMLString(string);

[Delphi] public function CheckHTMLString(String) : String; overload;

Starts spell checking the given HTML string.

[Visual Basic] Overloads Public Function CheckHTMLString(String, BadWordDialogEnum) As String

[C#] public string CheckHTMLString(string, BadWordDialogEnum);

[Delphi] public function CheckHTMLString(String; BadWordDialogEnum) : String; overload;

Starts spell checking the given HTML string.

[Visual Basic] Overloads Public Function CheckHTMLString(String, BadWordDialogEnum, Boolean, Boolean, Boolean) As String

[C#] public string CheckHTMLString(string, BadWordDialogEnum, bool, bool, bool);

[Delphi] public function CheckHTMLString(String; BadWordDialogEnum; Boolean; Boolean; Boolean) : String; overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.CheckHTMLString Method (String)

C1Spell.CheckHTMLString Method (String)

Previous Next

Starts spell checking the given HTML string.

[Visual Basic]

Overloads Public Function CheckHTMLString( _

ByVal htmlStr As String _

) As String

[C#]

public string CheckHTMLString(

string htmlStr

);

[Delphi]

public function CheckHTMLString(

htmlStr: String

): String; overload;

Parameters

htmlStr

HTML string to check.

Return Value

Checked string.

Remarks

Use the LastSpellError property and the SpellError event to find out the occurred errors.

All text inside the html tags will be skipped during the spell checking.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.CheckHTMLString Method (String, BadWordDialogEnum)

C1Spell.CheckHTMLString Method (String, BadWordDialogEnum)

Previous Next

Starts spell checking the given HTML string.

[Visual Basic]

Overloads Public Function CheckHTMLString( _

ByVal htmlStr As String, _

ByVal dialog As BadWordDialogEnum _

) As String

[C#]

public string CheckHTMLString(

string htmlStr,

BadWordDialogEnum dialog

);

[Delphi]

public function CheckHTMLString(

htmlStr: String;

dialog: BadWordDialogEnum

): String; overload;

Parameters

htmlStr

HTML string to check.

dialog

The BadWordDialogEnum object that represents whether the bad-word dialog will be used and the language that should be used to display it.

Return Value

Checked string.

Remarks

Use the LastSpellError property and the SpellError event to find out the occurred errors.

All text inside the html tags will be skipped during the spell checking.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.CheckHTMLString Method (String, BadWordDialogEnum, Boolean, Boolean, Boolean)

C1Spell.CheckHTMLString Method (String, BadWordDialogEnum, Boolean, Boolean, Boolean)

Previous Next

Starts spell checking the given HTML string.

[Visual Basic]

Overloads Public Function CheckHTMLString( _

ByVal htmlStr As String, _

ByVal dialog As BadWordDialogEnum, _

ByVal ignoreWithNumbers As Boolean, _

ByVal ignoreInUpperCase As Boolean, _

ByVal ignoreInMixedCase As Boolean _

) As String

[C#]

public string CheckHTMLString(

string htmlStr,

BadWordDialogEnum dialog,

bool ignoreWithNumbers,

bool ignoreInUpperCase,

bool ignoreInMixedCase

);

[Delphi]

public function CheckHTMLString(

htmlStr: String;

dialog: BadWordDialogEnum;

ignoreWithNumbers: Boolean;

ignoreInUpperCase: Boolean;

ignoreInMixedCase: Boolean

): String; overload;

Parameters

htmlStr

HTML string to check.

dialog

The BadWordDialogEnum object that represents whether the bad-word dialog will be used and the language that should be used to display it.

ignoreWithNumbers

Value that indicates if words containing numbers are ignored during spell checking.

ignoreInUpperCase

Value that indicates if words in all uppercase are ignored during spell checking.

ignoreInMixedCase

Value that indicates if words with uppercase characters after lowercase characters are ignored during spell checking.

Return Value

Checked string.

Remarks

Use the LastSpellError property and the SpellError event to find out the occurred errors.

All text inside the html tags will be skipped during the spell checking.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.CheckString Method

C1Spell.CheckString Method

Overload List

Starts spell checking the given string without any bad-word dialog.

[Visual Basic] Overloads Public Function CheckString(String) As Boolean

[C#] public bool CheckString(string);

[Delphi] public function CheckString(String) : Boolean; overload;

Starts spell checking the given string.

[Visual Basic] Overloads Public Function CheckString(String, BadWordDialogEnum) As String

[C#] public string CheckString(string, BadWordDialogEnum);

[Delphi] public function CheckString(String; BadWordDialogEnum) : String; overload;

Starts spell checking the given string.

[Visual Basic] Overloads Public Function CheckString(String, BadWordDialogEnum, Boolean, Boolean, Boolean) As String

[C#] public string CheckString(string, BadWordDialogEnum, bool, bool, bool);

[Delphi] public function CheckString(String; BadWordDialogEnum; Boolean; Boolean; Boolean) : String; overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.CheckString Method (String)

C1Spell.CheckString Method (String)

Previous Next

Starts spell checking the given string without any bad-word dialog.

[Visual Basic]

Overloads Public Function CheckString( _

ByVal str As String _

) As Boolean

[C#]

public bool CheckString(

string str

);

[Delphi]

public function CheckString(

str: String

): Boolean; overload;

Parameters

str

String to check.

Return Value

Value indicates if string was checked successful or not.

Remarks

Use the LastSpellError property and the SpellError event to find out the occurred errors.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.CheckString Method (String, BadWordDialogEnum)

C1Spell.CheckString Method (String, BadWordDialogEnum)

Previous Next

Starts spell checking the given string.

[Visual Basic]

Overloads Public Function CheckString( _

ByVal str As String, _

ByVal dialog As BadWordDialogEnum _

) As String

[C#]

public string CheckString(

string str,

BadWordDialogEnum dialog

);

[Delphi]

public function CheckString(

str: String;

dialog: BadWordDialogEnum

): String; overload;

Parameters

str

String to check.

dialog

The BadWordDialogEnum object that represents whether the bad-word dialog will be used and the language that should be used to display it.

Return Value

Checked string.

Remarks

Use the LastSpellError property and the SpellError event to find out the occurred errors.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.CheckString Method (String, BadWordDialogEnum, Boolean, Boolean, Boolean)

C1Spell.CheckString Method (String, BadWordDialogEnum, Boolean, Boolean, Boolean)

Previous Next

Starts spell checking the given string.

[Visual Basic]

Overloads Public Function CheckString( _

ByVal str As String, _

ByVal dialog As BadWordDialogEnum, _

ByVal ignoreWithNumbers As Boolean, _

ByVal ignoreInUpperCase As Boolean, _

ByVal ignoreInMixedCase As Boolean _

) As String

[C#]

public string CheckString(

string str,

BadWordDialogEnum dialog,

bool ignoreWithNumbers,

bool ignoreInUpperCase,

bool ignoreInMixedCase

);

[Delphi]

public function CheckString(

str: String;

dialog: BadWordDialogEnum;

ignoreWithNumbers: Boolean;

ignoreInUpperCase: Boolean;

ignoreInMixedCase: Boolean

): String; overload;

Parameters

str

String to check.

dialog

The BadWordDialogEnum object that represents whether the bad-word dialog will be used and the language that should be used to display it.

ignoreWithNumbers

Value that indicates if words containing numbers are ignored during spell checking.

ignoreInUpperCase

Value that indicates if words in all uppercase are ignored during spell checking.

ignoreInMixedCase

Value that indicates if words with uppercase characters after lowercase characters are ignored during spell checking.

Return Value

Checked string.

Remarks

Use the LastSpellError property and the SpellError event to find out the occurred errors.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.CheckTyping Method

C1Spell.CheckTyping Method

Overload List

Starts spell checking a control as the user types.

[Visual Basic] Overloads Public Sub CheckTyping(Control)

[C#] public void CheckTyping(Control);

[Delphi] public procedure CheckTyping(Control); overload;

Starts spell checking a control as the user types.

[Visual Basic] Overloads Public Sub CheckTyping(Control, TypingErrorActionEnum)

[C#] public void CheckTyping(Control, TypingErrorActionEnum);

[Delphi] public procedure CheckTyping(Control; TypingErrorActionEnum); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.CheckTyping Method (Control)

C1Spell.CheckTyping Method (Control)

Previous Next

Starts spell checking a control as the user types.

[Visual Basic]

Overloads Public Sub CheckTyping( _

ByVal ctrl As Control _

)

[C#]

public void CheckTyping(

Control ctrl

);

[Delphi]

public procedure CheckTyping(

ctrl: Control

); overload;

Parameters

ctrl

Control to check.

Remarks

Use the LastSpellError property and the SpellError event to find out the occurred errors.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.CheckTyping Method (Control, TypingErrorActionEnum)

C1Spell.CheckTyping Method (Control, TypingErrorActionEnum)

Previous Next

Starts spell checking a control as the user types.

[Visual Basic]

Overloads Public Sub CheckTyping( _

ByVal ctrl As Control, _

ByVal errAction As TypingErrorActionEnum _

)

[C#]

public void CheckTyping(

Control ctrl,

TypingErrorActionEnum errAction

);

[Delphi]

public procedure CheckTyping(

ctrl: Control;

errAction: TypingErrorActionEnum

); overload;

Parameters

ctrl

Control to check.

errAction

The TypingErrorActionEnum object than represents the action to be taken when a typing error is detected.

Remarks

Use the LastSpellError property and the SpellError event to find out the occurred errors.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.Clear Method

C1Spell.Clear Method

Clears the contents of all spell checking related properties.

[Visual Basic]

Public Sub Clear()

[C#]

public void Clear()

[Delphi]

public procedure Clear();

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.ClearCheckTyping Method

C1Spell.ClearCheckTyping Method

Clears the content of the control properties that are related to the check typing process.

[Visual Basic]

Public Sub ClearCheckTyping()

[C#]

public void ClearCheckTyping()

[Delphi]

public procedure ClearCheckTyping();

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.DeleteOptionSetting Method

C1Spell.DeleteOptionSetting Method

Deletes the default spell checking settings file.

[Visual Basic]

Public Sub DeleteOptionSetting()

[C#]

public void DeleteOptionSetting()

[Delphi]

public procedure DeleteOptionSetting();

Remarks

The C1Spell control options are automatically saved and loaded using this file when IsOptionSettingFixed is True.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.Dispose Method

C1Spell.Dispose Method

Clean up any resources being used.

[Visual Basic]

Overrides Protected Sub Dispose( _

ByVal disposing As Boolean _

)

[C#]

override protected void Dispose(

bool disposing

);

[Delphi]

strict protected procedure Dispose(

disposing: Boolean

); overload; override;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.LoadSettings Method

C1Spell.LoadSettings Method

Overload List

Loads spell checking settings from the default xml file.

[Visual Basic] Overloads Public Sub LoadSettings()

[C#] public void LoadSettings();

[Delphi] public procedure LoadSettings(); overload;

Loads spell checking settings from the stream.

[Visual Basic] Overloads Public Sub LoadSettings(Stream)

[C#] public void LoadSettings(Stream);

[Delphi] public procedure LoadSettings(Stream); overload;

Loads spell checking settings from the specified file.

[Visual Basic] Overloads Public Sub LoadSettings(String)

[C#] public void LoadSettings(string);

[Delphi] public procedure LoadSettings(String); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.LoadSettings Method ()

C1Spell.LoadSettings Method ()

Previous Next

Loads spell checking settings from the default xml file.

[Visual Basic]

Overloads Public Sub LoadSettings()

[C#]

public void LoadSettings()

[Delphi]

public procedure LoadSettings(); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.LoadSettings Method (Stream)

C1Spell.LoadSettings Method (Stream)

Previous Next

Loads spell checking settings from the stream.

[Visual Basic]

Overloads Public Sub LoadSettings( _

ByVal stream As Stream _

)

[C#]

public void LoadSettings(

Stream stream

);

[Delphi]

public procedure LoadSettings(

stream: Stream

); overload;

Parameters

stream

Stream to load.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.LoadSettings Method (String)

C1Spell.LoadSettings Method (String)

Previous Next

Loads spell checking settings from the specified file.

[Visual Basic]

Overloads Public Sub LoadSettings( _

ByVal path As String _

)

[C#]

public void LoadSettings(

string path

);

[Delphi]

public procedure LoadSettings(

path: String

); overload;

Parameters

path

File to load.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.PartialClear Method

C1Spell.PartialClear Method

Clears the content of control properties related to the spell checking process, but preserves the IgnoreAll and ChangeAllPair collections.

[Visual Basic]

Public Sub PartialClear()

[C#]

public void PartialClear()

[Delphi]

public procedure PartialClear();

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.RemoveCharFromSeparateArr Method

C1Spell.RemoveCharFromSeparateArr Method

Removes specified char from the SeparateChars array.

[Visual Basic]

Public Sub RemoveCharFromSeparateArr( _

ByVal c As Char _

)

[C#]

public void RemoveCharFromSeparateArr(

char c

);

[Delphi]

public procedure RemoveCharFromSeparateArr(

c: Char

);

Parameters

c

Char to remove.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.RemoveSkipChars Method

C1Spell.RemoveSkipChars Method

Clears the SkipCharsCollection property.

[Visual Basic]

Public Sub RemoveSkipChars()

[C#]

public void RemoveSkipChars()

[Delphi]

public procedure RemoveSkipChars();

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.SaveSettings Method

C1Spell.SaveSettings Method

Overload List

Saves the spell checking settings to the default xml file.

[Visual Basic] Overloads Public Sub SaveSettings()

[C#] public void SaveSettings();

[Delphi] public procedure SaveSettings(); overload;

Saves the spell checking settings to the specified stream.

[Visual Basic] Overloads Public Sub SaveSettings(Stream)

[C#] public void SaveSettings(Stream);

[Delphi] public procedure SaveSettings(Stream); overload;

Saves the spell checking settings to the specified file.

[Visual Basic] Overloads Public Sub SaveSettings(String)

[C#] public void SaveSettings(string);

[Delphi] public procedure SaveSettings(String); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.SaveSettings Method ()

C1Spell.SaveSettings Method ()

Previous Next

Saves the spell checking settings to the default xml file.

[Visual Basic]

Overloads Public Sub SaveSettings()

[C#]

public void SaveSettings()

[Delphi]

public procedure SaveSettings(); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.SaveSettings Method (Stream)

C1Spell.SaveSettings Method (Stream)

Previous Next

Saves the spell checking settings to the specified stream.

[Visual Basic]

Overloads Public Sub SaveSettings( _

ByVal stream As Stream _

)

[C#]

public void SaveSettings(

Stream stream

);

[Delphi]

public procedure SaveSettings(

stream: Stream

); overload;

Parameters

stream

Stream in which spell checking options will be persisted.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.SaveSettings Method (String)

C1Spell.SaveSettings Method (String)

Previous Next

Saves the spell checking settings to the specified file.

[Visual Basic]

Overloads Public Sub SaveSettings( _

ByVal path As String _

)

[C#]

public void SaveSettings(

string path

);

[Delphi]

public procedure SaveSettings(

path: String

); overload;

Parameters

path

File name in which spell checking options will be persisted.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.SkipInsideChars Method

C1Spell.SkipInsideChars Method

Adds values to the SkipCharsCollection.

[Visual Basic]

Public Sub SkipInsideChars( _

ByVal p As Char, _

ByVal q As Char _

)

[C#]

public void SkipInsideChars(

char p,

char q

);

[Delphi]

public procedure SkipInsideChars(

p: Char;

q: Char

);

Parameters

p

Value that bounds checking text from left.

q

Value that bounds checking text from right.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell Events

C1Spell Events

The events of the C1Spell class are listed here. For a complete list of C1Spell class members, see the C1Spell Members topic.

Public Events

BadWord | Fired when a bad word is encountered during a spell check.
Changed | Fired after the checked string is changed.
Checking | Fired every second during spell checking to provide user feedback while checking long documents.
CheckStart | Fired right before the spell checking is started.
Complete | Fired after the spell check has been completed.
DialogAction | Fired when a button is clicked on the bad-word dialog box.
HelpBtnClick | Fired when the Help button on the bad-word dialog box is clicked.
OptionBtnClick | Fired when the Option button on the bad-word dialog box is clicked.
PopupDialog | Fires when the user clicks the "spelling..." item of the C1Spell run-time context menu.
SpellError | Fired when a spell-checking error occurs.
Suggestion | Fired after a word has been added to the Suggestions collection.
TypingError | Fired when a typing error is detected after the CheckTyping method is invoked.
TypingOK | Fired when a correct word is typed after the CheckTyping method is invoked.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.BadWord Event

C1Spell.BadWord Event

Fired when a bad word is encountered during a spell check.

[Visual Basic]

Public Event BadWord As BadWordEventHandler

[C#]

public event BadWordEventHandler BadWord

[Delphi]

public property BadWord: BadWordEventHandler read remove_BadWord write add_BadWord;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.Changed Event

C1Spell.Changed Event

Fired after the checked string is changed.

[Visual Basic]

Public Event Changed As EventHandler

[C#]

public event EventHandler Changed

[Delphi]

public property Changed: EventHandler read remove_Changed write add_Changed;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.Checking Event

C1Spell.Checking Event

Fired every second during spell checking to provide user feedback while checking long documents.

[Visual Basic]

Public Event Checking As CheckingEventHandler

[C#]

public event CheckingEventHandler Checking

[Delphi]

public property Checking: CheckingEventHandler read remove_Checking write add_Checking;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.CheckStart Event

C1Spell.CheckStart Event

Fired right before the spell checking is started.

[Visual Basic]

Public Event CheckStart As CheckStartEventHandler

[C#]

public event CheckStartEventHandler CheckStart

[Delphi]

public property CheckStart: CheckStartEventHandler read remove_CheckStart write add_CheckStart;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.Complete Event

C1Spell.Complete Event

Fired after the spell check has been completed.

[Visual Basic]

Public Event Complete As CompleteEventHandler

[C#]

public event CompleteEventHandler Complete

[Delphi]

public property Complete: CompleteEventHandler read remove_Complete write add_Complete;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.DialogAction Event

C1Spell.DialogAction Event

Fired when a button is clicked on the bad-word dialog box.

[Visual Basic]

Public Event DialogAction As DialogActionEventHandler

[C#]

public event DialogActionEventHandler DialogAction

[Delphi]

public property DialogAction: DialogActionEventHandler read remove_DialogAction write add_DialogAction;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.HelpBtnClick Event

C1Spell.HelpBtnClick Event

Fired when the Help button on the bad-word dialog box is clicked.

[Visual Basic]

Public Event HelpBtnClick As EventHandler

[C#]

public event EventHandler HelpBtnClick

[Delphi]

public property HelpBtnClick: EventHandler read remove_HelpBtnClick write add_HelpBtnClick;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.OptionBtnClick Event

C1Spell.OptionBtnClick Event

Fired when the Option button on the bad-word dialog box is clicked.

[Visual Basic]

Public Event OptionBtnClick As EventHandler

[C#]

public event EventHandler OptionBtnClick

[Delphi]

public property OptionBtnClick: EventHandler read remove_OptionBtnClick write add_OptionBtnClick;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.PopupDialog Event

C1Spell.PopupDialog Event

Fires when the user clicks the "spelling..." item of the C1Spell run-time context menu.

[Visual Basic]

Public Event PopupDialog As EventHandler

[C#]

public event EventHandler PopupDialog

[Delphi]

public property PopupDialog: EventHandler read remove_PopupDialog write add_PopupDialog;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.SpellError Event

C1Spell.SpellError Event

Fired when a spell-checking error occurs.

[Visual Basic]

Public Event SpellError As SpellErrorEventHandler

[C#]

public event SpellErrorEventHandler SpellError

[Delphi]

public property SpellError: SpellErrorEventHandler read remove_SpellError write add_SpellError;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.Suggestion Event

C1Spell.Suggestion Event

Fired after a word has been added to the Suggestions collection.

[Visual Basic]

Public Event Suggestion As SuggestionEventHandler

[C#]

public event SuggestionEventHandler Suggestion

[Delphi]

public property Suggestion: SuggestionEventHandler read remove_Suggestion write add_Suggestion;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.TypingError Event

C1Spell.TypingError Event

Fired when a typing error is detected after the CheckTyping method is invoked.

[Visual Basic]

Public Event TypingError As TypingErrorEventHandler

[C#]

public event TypingErrorEventHandler TypingError

[Delphi]

public property TypingError: TypingErrorEventHandler read remove_TypingError write add_TypingError;

Example

The following code makes a picturebox red color when the user types an incorrect word:

· Visual Basic

· C#

· Delphi

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Spell.TypingOK Event

C1Spell.TypingOK Event

Fired when a correct word is typed after the CheckTyping method is invoked.

[Visual Basic]

Public Event TypingOK As TypingOKEventHandler

[C#]

public event TypingOKEventHandler TypingOK

[Delphi]

public property TypingOK: TypingOKEventHandler read remove_TypingOK write add_TypingOK;

Example

The following code makes a picturebox green color when the user types a correct word:

· Visual Basic

· C#

· Delphi

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CharPair Class

CharPair Class

Instances of the class that store the character pairs.

For a list of all members of this type, see CharPair Members.

System.Object

C1.Win.C1Spell.CharPair

[Visual Basic]

Public Class CharPair

[C#]

public class CharPair

[Delphi]

type CharPair = class;

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CharPair Members

CharPair Members

CharPair overview

Public Constructors

CharPair Constructor

Creates and initiates an instance of the class.

Public Properties

Char1 | The first character of the character pair.
Char2 | The second character of the character pair.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CharPair Constructor

CharPair Constructor

Creates and initiates an instance of the class.

[Visual Basic]

Public Function New( _

ByVal char1 As Char, _

ByVal char2 As Char _

)

[C#]

public CharPair(

char char1,

char char2

);

[Delphi]

public constructor Create(

char1: Char;

char2: Char

);

Parameters

char1

First char.

char2

Second char.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CharPair Properties

CharPair Properties

The properties of the CharPair class are listed here. For a complete list of CharPair class members, see the CharPair Members topic.

Public Properties

Char1 | The first character of the character pair.
Char2 | The second character of the character pair.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CharPair.Char1 Property

CharPair.Char1 Property

The first character of the character pair.

[Visual Basic]

Public Property Char1 As Char

[C#]

public char Char1 {get;set;}

[Delphi]

public property Char1: Char read get_Char1 write set_Char1;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CharPair.Char2 Property

CharPair.Char2 Property

The second character of the character pair.

[Visual Basic]

Public Property Char2 As Char

[C#]

public char Char2 {get;set;}

[Delphi]

public property Char2: Char read get_Char2 write set_Char2;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CharPairCollection Class

CharPairCollection Class

A collection of unique CharPair items.

For a list of all members of this type, see CharPairCollection Members.

System.Object

System.Collections.CollectionBase

C1.Win.C1Spell.CharPairCollection

[Visual Basic]

Public Class CharPairCollection

Inherits CollectionBase

[C#]

public class CharPairCollection : CollectionBase

[Delphi]

type CharPairCollection = class (CollectionBase);

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CharPairCollection Members

CharPairCollection Members

CharPairCollection overview

Public Properties

Item

Indexer. Gets or sets the CharPair element by its index.

Public Methods

Add | Overloaded. Adds specified CharPair item to the collection.
Clear | Clears collection.
IndexOf | Overloaded. Searches for the specified CharPair item in the collection.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CharPairCollection Properties

CharPairCollection Properties

The properties of the CharPairCollection class are listed here. For a complete list of CharPairCollection class members, see the CharPairCollection Members topic.

Public Properties

Item

Indexer. Gets or sets the CharPair element by its index.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CharPairCollection.Item Property

CharPairCollection.Item Property

Indexer. Gets or sets the CharPair element by its index.

[Visual Basic]

Public Default ReadOnly Property Item( _

ByVal index As Integer _

) As CharPair

[C#]

public CharPair this[

int index

] {get;}

[Delphi]

public property Item[

index: Int32

]: CharPair read get_Item;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CharPairCollection Methods

CharPairCollection Methods

The methods of the CharPairCollection class are listed here. For a complete list of CharPairCollection class members, see the CharPairCollection Members topic.

Public Methods

Add | Overloaded. Adds specified CharPair item to the collection.
Clear | Clears collection.
IndexOf | Overloaded. Searches for the specified CharPair item in the collection.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CharPairCollection.Add Method

CharPairCollection.Add Method

Overload List

Creates new CharPair item from the specified chars and adds it to the collection.

[Visual Basic] Overloads Public Function Add(Char, Char) As Boolean

[C#] public bool Add(char, char);

[Delphi] public function Add(Char; Char) : Boolean; overload;

Adds specified CharPair item to the collection.

[Visual Basic] Overloads Public Function Add(CharPair) As Boolean

[C#] public bool Add(CharPair);

[Delphi] public function Add(CharPair) : Boolean; overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CharPairCollection.Add Method (Char, Char)

CharPairCollection.Add Method (Char, Char)

Previous Next

Creates new CharPair item from the specified chars and adds it to the collection.

[Visual Basic]

Overloads Public Function Add( _

ByVal char1 As Char, _

ByVal char2 As Char _

) As Boolean

[C#]

public bool Add(

char char1,

char char2

);

[Delphi]

public function Add(

char1: Char;

char2: Char

): Boolean; overload;

Parameters

char1

First char.

char2

Second char.

Return Value

True, if item is successfully added into the collection, otherwise False (if such item already exists in the collection).

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CharPairCollection.Add Method (CharPair)

CharPairCollection.Add Method (CharPair)

Previous Next

Adds specified CharPair item to the collection.

[Visual Basic]

Overloads Public Function Add( _

ByVal item As CharPair _

) As Boolean

[C#]

public bool Add(

CharPair item

);

[Delphi]

public function Add(

item: CharPair

): Boolean; overload;

Parameters

item

CharPair item to add.

Return Value

True, if item is successfully added into the collection, otherwise False (if such item already exists in the collection).

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CharPairCollection.Clear Method

CharPairCollection.Clear Method

Clears collection.

[Visual Basic]

Public Sub Clear()

[C#]

new public void Clear()

[Delphi]

public procedure Clear();

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CharPairCollection.IndexOf Method

CharPairCollection.IndexOf Method

Overload List

Searches for the specified char pairs in the collection.

[Visual Basic] Overloads Public Function IndexOf(Char, Char) As Integer

[C#] public int IndexOf(char, char);

[Delphi] public function IndexOf(Char; Char) : Int32; overload;

Searches for the specified CharPair item in the collection.

[Visual Basic] Overloads Public Function IndexOf(CharPair) As Integer

[C#] public int IndexOf(CharPair);

[Delphi] public function IndexOf(CharPair) : Int32; overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CharPairCollection.IndexOf Method (Char, Char)

CharPairCollection.IndexOf Method (Char, Char)

Previous Next

Searches for the specified char pairs in the collection.

[Visual Basic]

Overloads Public Function IndexOf( _

ByVal char1 As Char, _

ByVal char2 As Char _

) As Integer

[C#]

public int IndexOf(

char char1,

char char2

);

[Delphi]

public function IndexOf(

char1: Char;

char2: Char

): Int32; overload;

Parameters

char1

First char.

char2

Second char.

Return Value

The index of the occurrence of char pair within the collection, if found. Otherwise -1.

Remarks

Char comparsions are case-insensitive.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CharPairCollection.IndexOf Method (CharPair)

CharPairCollection.IndexOf Method (CharPair)

Previous Next

Searches for the specified CharPair item in the collection.

[Visual Basic]

Overloads Public Function IndexOf( _

ByVal item As CharPair _

) As Integer

[C#]

public int IndexOf(

CharPair item

);

[Delphi]

public function IndexOf(

item: CharPair

): Int32; overload;

Parameters

item

CharPair item to search.

Return Value

The index of the occurrence of the item within the collection, if found. Otherwise -1.

Remarks

Char comparsions are case-insensitive.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CheckingEventArgs Class

CheckingEventArgs Class

Provides data for the Checking event of the C1Spell.

For a list of all members of this type, see CheckingEventArgs Members.

System.Object

System.EventArgs

C1.Win.C1Spell.CheckingEventArgs

[Visual Basic]

Public Class CheckingEventArgs

Inherits EventArgs

[C#]

public class CheckingEventArgs : EventArgs

[Delphi]

type CheckingEventArgs = class (EventArgs);

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CheckingEventArgs Members

CheckingEventArgs Members

CheckingEventArgs overview

Public Constructors

CheckingEventArgs Constructor

Initializes a new instance of the CheckingEventArgs with the default values.

Public Properties

Cancel

Gets or sets the value indicating if the spell-checking process must be stopped or not.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CheckingEventArgs Constructor

CheckingEventArgs Constructor

Overload List

Initializes a new instance of the CheckingEventArgs with the default values.

[Visual Basic] Public Function New()

[C#] public CheckingEventArgs();

[Delphi] public constructor Create(); overload;

Initializes a new instance of the CheckingEventArgs with the predefined values.

[Visual Basic] Public Function New(Boolean)

[C#] public CheckingEventArgs(bool);

[Delphi] public constructor Create(Boolean); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CheckingEventArgs Constructor ()

CheckingEventArgs Constructor ()

Previous Next

Initializes a new instance of the CheckingEventArgs with the default values.

[Visual Basic]

Public Function New()

[C#]

public CheckingEventArgs()

[Delphi]

public constructor Create(); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CheckingEventArgs Constructor (Boolean)

CheckingEventArgs Constructor (Boolean)

Previous Next

Initializes a new instance of the CheckingEventArgs with the predefined values.

[Visual Basic]

Public Function New( _

ByVal cancel As Boolean _

)

[C#]

public CheckingEventArgs(

bool cancel

);

[Delphi]

public constructor Create(

cancel: Boolean

); overload;

Parameters

cancel

When set to True, spell-checking is stopped.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CheckingEventArgs Properties

CheckingEventArgs Properties

The properties of the CheckingEventArgs class are listed here. For a complete list of CheckingEventArgs class members, see the CheckingEventArgs Members topic.

Public Properties

Cancel

Gets or sets the value indicating if the spell-checking process must be stopped or not.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CheckingEventArgs.Cancel Property

CheckingEventArgs.Cancel Property

Gets or sets the value indicating if the spell-checking process must be stopped or not.

[Visual Basic]

Public Property Cancel As Boolean

[C#]

public bool Cancel {get;set;}

[Delphi]

public property Cancel: Boolean read get_Cancel write set_Cancel;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CheckingEventHandler Delegate

CheckingEventHandler Delegate

Represents the method that will handle the Checking event of the C1Spell.

[Visual Basic]

Public Delegate Sub CheckingEventHandler( _

ByVal sender As Object, _

ByVal e As CheckingEventArgs _

)

[C#]

public delegate void CheckingEventHandler(

object sender,

CheckingEventArgs e

);

[Delphi]

type CheckingEventHandler = procedure (

sender: Object;

e: CheckingEventArgs

) of object;

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

See Also

C1.Win.C1Spell Namespace

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CheckStartEventArgs Class

CheckStartEventArgs Class

Provides data for the CheckStart event of the C1Spell.

For a list of all members of this type, see CheckStartEventArgs Members.

System.Object

System.EventArgs

C1.Win.C1Spell.CheckStartEventArgs

[Visual Basic]

Public Class CheckStartEventArgs

Inherits EventArgs

[C#]

public class CheckStartEventArgs : EventArgs

[Delphi]

type CheckStartEventArgs = class (EventArgs);

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CheckStartEventArgs Members

CheckStartEventArgs Members

CheckStartEventArgs overview

Public Constructors

CheckStartEventArgs Constructor

Initializes a new instance of the CheckStartEventArgs with the default values.

Public Properties

Cancel

Gets or sets value indicating if the spell-checking process must be stopped or not.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CheckStartEventArgs Constructor

CheckStartEventArgs Constructor

Overload List

Initializes a new instance of the CheckStartEventArgs with the default values.

[Visual Basic] Public Function New()

[C#] public CheckStartEventArgs();

[Delphi] public constructor Create(); overload;

Initializes a new instance of the CheckStartEventArgs with the predefined values.

[Visual Basic] Public Function New(Boolean)

[C#] public CheckStartEventArgs(bool);

[Delphi] public constructor Create(Boolean); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CheckStartEventArgs Constructor ()

CheckStartEventArgs Constructor ()

Previous Next

Initializes a new instance of the CheckStartEventArgs with the default values.

[Visual Basic]

Public Function New()

[C#]

public CheckStartEventArgs()

[Delphi]

public constructor Create(); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CheckStartEventArgs Constructor (Boolean)

CheckStartEventArgs Constructor (Boolean)

Previous Next

Initializes a new instance of the CheckStartEventArgs with the predefined values.

[Visual Basic]

Public Function New( _

ByVal cancel As Boolean _

)

[C#]

public CheckStartEventArgs(

bool cancel

);

[Delphi]

public constructor Create(

cancel: Boolean

); overload;

Parameters

cancel

When set to True, spell-checking is stopped.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CheckStartEventArgs Properties

CheckStartEventArgs Properties

The properties of the CheckStartEventArgs class are listed here. For a complete list of CheckStartEventArgs class members, see the CheckStartEventArgs Members topic.

Public Properties

Cancel

Gets or sets value indicating if the spell-checking process must be stopped or not.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CheckStartEventArgs.Cancel Property

CheckStartEventArgs.Cancel Property

Gets or sets value indicating if the spell-checking process must be stopped or not.

[Visual Basic]

Public Property Cancel As Boolean

[C#]

public bool Cancel {get;set;}

[Delphi]

public property Cancel: Boolean read get_Cancel write set_Cancel;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CheckStartEventHandler Delegate

CheckStartEventHandler Delegate

Represents the method that will handle the CheckStart event of the C1Spell.

[Visual Basic]

Public Delegate Sub CheckStartEventHandler( _

ByVal sender As Object, _

ByVal e As CheckStartEventArgs _

)

[C#]

public delegate void CheckStartEventHandler(

object sender,

CheckStartEventArgs e

);

[Delphi]

type CheckStartEventHandler = procedure (

sender: Object;

e: CheckStartEventArgs

) of object;

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

See Also

C1.Win.C1Spell Namespace

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CommonWordCacheEnum Enumeration

CommonWordCacheEnum Enumeration

Enumerates the available common word caches to be used during spell checking.

[Visual Basic]

Public Enum CommonWordCacheEnum

[C#]

public enum CommonWordCacheEnum

[Delphi]

type CommonWordCacheEnum = (EnglishCommonCache, NoCommonCache, SpanishCommonCache);

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

Remarks

Use the members of this enumeration to set the value of the CommonWordCache property

Members

Member name | Description
EnglishCommonCache | Indicates the English common word cache is to be used.
NoCommonCache | Indicates no common word cache is to be used.
SpanishCommonCache | Indicates the Spanish common word cache is to be used.

See Also

C1.Win.C1Spell Namespace

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Spell.CompleteEventArgs Class

C1.Win.C1Spell.CompleteEventArgs Class

Provides data for the Complete event of C1Spell.

For a list of all members of this type, see CompleteEventArgs Members.

System.Object

System.EventArgs

C1.Win.C1Spell.CompleteEventArgs

[Visual Basic]

Public Class CompleteEventArgs

Inherits EventArgs

[C#]

public class CompleteEventArgs : EventArgs

[Delphi]

type CompleteEventArgs = class (EventArgs);

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Spell.CompleteEventArgs Members

C1.Win.C1Spell.CompleteEventArgs Members

CompleteEventArgs overview

Public Constructors

C1.Win.C1Spell.CompleteEventArgs Constructor

Initializes a new instance of the CompleteEventArgs with the default values.

Public Properties

Cancelled

Value that indicates whether the spell checking process was cancelled or not.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Spell.CompleteEventArgs Constructor

C1.Win.C1Spell.CompleteEventArgs Constructor

Overload List

Initializes a new instance of the CompleteEventArgs with the default values.

[Visual Basic] Public Function New()

[C#] public CompleteEventArgs();

[Delphi] public constructor Create(); overload;

Initializes a new instance of CompleteEventArgs with the predefined values.

[Visual Basic] Public Function New(Boolean)

[C#] public CompleteEventArgs(bool);

[Delphi] public constructor Create(Boolean); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Spell.CompleteEventArgs Constructor ()

C1.Win.C1Spell.CompleteEventArgs Constructor ()

Previous Next

Initializes a new instance of the CompleteEventArgs with the default values.

[Visual Basic]

Public Function New()

[C#]

public CompleteEventArgs()

[Delphi]

public constructor Create(); overload;

See Also

C1.Win.C1Spell.CompleteEventArgs Class | C1.Win.C1Spell.CompleteEventArgs Members | C1.Win.C1Spell Namespace | C1.Win.C1Spell.CompleteEventArgs Constructor Overload List


C1.Win.C1Spell.CompleteEventArgs Constructor (Boolean)

C1.Win.C1Spell.CompleteEventArgs Constructor (Boolean)

Previous Next

Initializes a new instance of CompleteEventArgs with the predefined values.

[Visual Basic]

Public Function New( _

ByVal status As Boolean _

)

[C#]

public CompleteEventArgs(

bool status

);

[Delphi]

public constructor Create(

status: Boolean

); overload;

Parameters

status

Value that indicates whether the spell checking process was cancelled or not.

See Also

C1.Win.C1Spell.CompleteEventArgs Class | C1.Win.C1Spell.CompleteEventArgs Members | C1.Win.C1Spell Namespace | C1.Win.C1Spell.CompleteEventArgs Constructor Overload List


C1.Win.C1Spell.CompleteEventArgs Properties

C1.Win.C1Spell.CompleteEventArgs Properties

The properties of the CompleteEventArgs class are listed here. For a complete list of CompleteEventArgs class members, see the C1.Win.C1Spell.CompleteEventArgs Members topic.

Public Properties

Cancelled

Value that indicates whether the spell checking process was cancelled or not.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Spell.CompleteEventArgs.Cancelled Property

C1.Win.C1Spell.CompleteEventArgs.Cancelled Property

Value that indicates whether the spell checking process was cancelled or not.

[Visual Basic]

Public Property Cancelled As Boolean

[C#]

public bool Cancelled {get;set;}

[Delphi]

public property Cancelled: Boolean read get_Cancelled write set_Cancelled;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Spell.CompleteEventHandler Delegate

C1.Win.C1Spell.CompleteEventHandler Delegate

Represents the method that will handle the Complete event of C1Spell.

[Visual Basic]

Public Delegate Sub CompleteEventHandler( _

ByVal sender As Object, _

ByVal e As CompleteEventArgs _

)

[C#]

public delegate void CompleteEventHandler(

object sender,

CompleteEventArgs e

);

[Delphi]

type CompleteEventHandler = procedure (

sender: Object;

e: CompleteEventArgs

) of object;

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

See Also

C1.Win.C1Spell Namespace

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CustomDictionaryCollection Class

CustomDictionaryCollection Class

A collection of custom dictionaries.

For a list of all members of this type, see CustomDictionaryCollection Members.

System.Object

System.Collections.CollectionBase

C1.Win.C1Spell.CustomDictionaryCollection

[Visual Basic]

Public Class CustomDictionaryCollection

Inherits CollectionBase

[C#]

public class CustomDictionaryCollection : CollectionBase

[Delphi]

type CustomDictionaryCollection = class (CollectionBase);

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CustomDictionaryCollection Members

CustomDictionaryCollection Members

CustomDictionaryCollection overview

Public Properties

Item

Indexer. Gets or sets the DictionaryItem element by its index.

Public Methods

Add | Adds specified DictionaryItem value to the collection.
Clear | Clears collection.
InsertAt | Inserts DictionaryItem element into the collection at specified position.
Remove | Removes DictionaryItem item from the collection at a specified index.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CustomDictionaryCollection Properties

CustomDictionaryCollection Properties

The properties of the CustomDictionaryCollection class are listed here. For a complete list of CustomDictionaryCollection class members, see the CustomDictionaryCollection Members topic.

Public Properties

Item

Indexer. Gets or sets the DictionaryItem element by its index.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CustomDictionaryCollection.Item Property

CustomDictionaryCollection.Item Property

Indexer. Gets or sets the DictionaryItem element by its index.

[Visual Basic]

Public Default Property Item( _

ByVal index As Integer _

) As DictionaryItem

[C#]

public DictionaryItem this[

int index

] {get;set;}

[Delphi]

public property Item[

index: Int32

]: DictionaryItem read get_Item write set_Item;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CustomDictionaryCollection Methods

CustomDictionaryCollection Methods

The methods of the CustomDictionaryCollection class are listed here. For a complete list of CustomDictionaryCollection class members, see the CustomDictionaryCollection Members topic.

Public Methods

Add | Adds specified DictionaryItem value to the collection.
Clear | Clears collection.
InsertAt | Inserts DictionaryItem element into the collection at specified position.
Remove | Removes DictionaryItem item from the collection at a specified index.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CustomDictionaryCollection.Add Method

CustomDictionaryCollection.Add Method

Adds specified DictionaryItem value to the collection.

[Visual Basic]

Public Sub Add( _

ByVal item As DictionaryItem _

)

[C#]

public void Add(

DictionaryItem item

);

[Delphi]

public procedure Add(

item: DictionaryItem

);

Parameters

item

A DictionaryItem element to add.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CustomDictionaryCollection.Clear Method

CustomDictionaryCollection.Clear Method

Clears collection.

[Visual Basic]

Public Sub Clear()

[C#]

new public void Clear()

[Delphi]

public procedure Clear();

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CustomDictionaryCollection.InsertAt Method

CustomDictionaryCollection.InsertAt Method

Inserts DictionaryItem element into the collection at specified position.

[Visual Basic]

Public Sub InsertAt( _

ByVal index As Integer, _

ByVal item As DictionaryItem _

)

[C#]

public void InsertAt(

int index,

DictionaryItem item

);

[Delphi]

public procedure InsertAt(

index: Int32;

item: DictionaryItem

);

Parameters

index

Position to insert to.

item

A DictionaryItem element to insert.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CustomDictionaryCollection.Remove Method

CustomDictionaryCollection.Remove Method

Removes DictionaryItem item from the collection at a specified index.

[Visual Basic]

Public Sub Remove( _

ByVal index As Integer _

)

[C#]

public void Remove(

int index

);

[Delphi]

public procedure Remove(

index: Int32

);

Parameters

index

Index of the item to remove.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DialogActionEnum Enumeration

DialogActionEnum Enumeration

Enumerates the possible actions performed on the spelling dialog box during a spell check when DialogAction event was fired.

[Visual Basic]

Public Enum DialogActionEnum

[C#]

public enum DialogActionEnum

[Delphi]

type DialogActionEnum = (Add, Cancel, Change, ChangeAll, Ignore, IgnoreAll, NoAction);

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

Members

Member name | Description
Add | Indicates the user pressed the Add button on the spelling dialog box.
Cancel | Indicates the user pressed the Cancel button on the spelling dialog box.
Change | Indicates the user pressed the Change button on the spelling dialog box.
ChangeAll | Indicates the user pressed the ChangeAll button on the spelling dialog box.
Ignore | Indicates the user pressed the Ignore button on the spelling dialog box.
IgnoreAll | Indicates the user pressed the IgnoreAll button on the spelling dialog box.
NoAction | Indicates no button is clicked.

See Also

C1.Win.C1Spell Namespace

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DialogActionEventArgs Class

DialogActionEventArgs Class

Provides data for the DialogAction event of C1Spell.

For a list of all members of this type, see DialogActionEventArgs Members.

System.Object

System.EventArgs

C1.Win.C1Spell.DialogActionEventArgs

[Visual Basic]

Public Class DialogActionEventArgs

Inherits EventArgs

[C#]

public class DialogActionEventArgs : EventArgs

[Delphi]

type DialogActionEventArgs = class (EventArgs);

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DialogActionEventArgs Members

DialogActionEventArgs Members

DialogActionEventArgs overview

Public Constructors

DialogActionEventArgs Constructor

Initializes a new instance of DialogActionEventArgs with the default values.

Public Properties

Action

The DialogActionEnum object that represents user action during the bad-word dialog.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DialogActionEventArgs Constructor

DialogActionEventArgs Constructor

Overload List

Initializes a new instance of DialogActionEventArgs with the default values.

[Visual Basic] Public Function New()

[C#] public DialogActionEventArgs();

[Delphi] public constructor Create(); overload;

Initializes a new instance of DialogActionEventArgs with the predefined values.

[Visual Basic] Public Function New(DialogActionEnum)

[C#] public DialogActionEventArgs(DialogActionEnum);

[Delphi] public constructor Create(DialogActionEnum); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DialogActionEventArgs Constructor ()

DialogActionEventArgs Constructor ()

Previous Next

Initializes a new instance of DialogActionEventArgs with the default values.

[Visual Basic]

Public Function New()

[C#]

public DialogActionEventArgs()

[Delphi]

public constructor Create(); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DialogActionEventArgs Constructor (DialogActionEnum)

DialogActionEventArgs Constructor (DialogActionEnum)

Previous Next

Initializes a new instance of DialogActionEventArgs with the predefined values.

[Visual Basic]

Public Function New( _

ByVal action As DialogActionEnum _

)

[C#]

public DialogActionEventArgs(

DialogActionEnum action

);

[Delphi]

public constructor Create(

action: DialogActionEnum

); overload;

Parameters

action

The DialogActionEnum object that represents user action during the bad-word dialog.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DialogActionEventArgs Properties

DialogActionEventArgs Properties

The properties of the DialogActionEventArgs class are listed here. For a complete list of DialogActionEventArgs class members, see the DialogActionEventArgs Members topic.

Public Properties

Action

The DialogActionEnum object that represents user action during the bad-word dialog.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DialogActionEventArgs.Action Property

DialogActionEventArgs.Action Property

The DialogActionEnum object that represents user action during the bad-word dialog.

[Visual Basic]

Public Property Action As DialogActionEnum

[C#]

public DialogActionEnum Action {get;set;}

[Delphi]

public property Action: DialogActionEnum read get_Action write set_Action;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DialogActionEventHandler Delegate

DialogActionEventHandler Delegate

Represents the method that will handle the DialogAction event of C1Spell.

[Visual Basic]

Public Delegate Sub DialogActionEventHandler( _

ByVal sender As Object, _

ByVal e As DialogActionEventArgs _

)

[C#]

public delegate void DialogActionEventHandler(

object sender,

DialogActionEventArgs e

);

[Delphi]

type DialogActionEventHandler = procedure (

sender: Object;

e: DialogActionEventArgs

) of object;

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

See Also

C1.Win.C1Spell Namespace

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DialogProperty Class

DialogProperty Class

Represents the title, font and location of the bad-word dialog box.

For a list of all members of this type, see DialogProperty Members.

System.Object

C1.Win.C1Spell.DialogProperty

[Visual Basic]

Public Class DialogProperty

[C#]

public class DialogProperty

[Delphi]

type DialogProperty = class;

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DialogProperty Members

DialogProperty Members

DialogProperty overview

Public Properties

Font | Gets or sets the bad-word dialog box font.
Location | Gets or sets the bad-word dialog box location.
Title | Gets or sets the bad-word dialog box title.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DialogProperty Properties

DialogProperty Properties

The properties of the DialogProperty class are listed here. For a complete list of DialogProperty class members, see the DialogProperty Members topic.

Public Properties

Font | Gets or sets the bad-word dialog box font.
Location | Gets or sets the bad-word dialog box location.
Title | Gets or sets the bad-word dialog box title.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DialogProperty.Font Property

DialogProperty.Font Property

Gets or sets the bad-word dialog box font.

[Visual Basic]

Public Property Font As Font

[C#]

public Font Font {get;set;}

[Delphi]

public property Font: Font read get_Font write set_Font;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DialogProperty.Location Property

DialogProperty.Location Property

Gets or sets the bad-word dialog box location.

[Visual Basic]

Public Property Location As Point

[C#]

public Point Location {get;set;}

[Delphi]

public property Location: Point read get_Location write set_Location;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DialogProperty.Title Property

DialogProperty.Title Property

Gets or sets the bad-word dialog box title.

[Visual Basic]

Public Property Title As String

[C#]

public string Title {get;set;}

[Delphi]

public property Title: String read get_Title write set_Title;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DictionaryItem Class

DictionaryItem Class

This class stores information about the path to a single custom dictionary file and Boolean flag that indicates if this file is used.

For a list of all members of this type, see DictionaryItem Members.

System.Object

C1.Win.C1Spell.DictionaryItem

[Visual Basic]

Public Class DictionaryItem

[C#]

public class DictionaryItem

[Delphi]

type DictionaryItem = class;

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DictionaryItem Members

DictionaryItem Members

DictionaryItem overview

Public Properties

Checked | Gets or sets the value indicating if the file is used for spell-checking.
Item | Gets or sets the path to the custom dictionary file.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DictionaryItem Properties

DictionaryItem Properties

The properties of the DictionaryItem class are listed here. For a complete list of DictionaryItem class members, see the DictionaryItem Members topic.

Public Properties

Checked | Gets or sets the value indicating if the file is used for spell-checking.
Item | Gets or sets the path to the custom dictionary file.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DictionaryItem.Checked Property

DictionaryItem.Checked Property

Gets or sets the value indicating if the file is used for spell-checking.

[Visual Basic]

Public Property Checked As Boolean

[C#]

public bool Checked {get;set;}

[Delphi]

public property Checked: Boolean read get_Checked write set_Checked;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DictionaryItem.Item Property

DictionaryItem.Item Property

Gets or sets the path to the custom dictionary file.

[Visual Basic]

Public Property Item As String

[C#]

public string Item {get;set;}

[Delphi]

public property Item: String read get_Item write set_Item;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DlgSetting Class

DlgSetting Class

Encapsulates the spell-checking options of the C1Spell component.

For a list of all members of this type, see DlgSetting Members.

System.Object

C1.Win.C1Spell.DlgSetting

[Visual Basic]

Public Class DlgSetting

[C#]

public class DlgSetting

[Delphi]

type DlgSetting = class;

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DlgSetting Members

DlgSetting Members

DlgSetting overview

Public Constructors

DlgSetting Constructor

Initializes new instance of the DlgSetting class with default values.

Public Properties

CustomDictionaries | Sets or returns the paths and filenames of the custom dictionary files.
HasSuggest | Sets or returns whether suggestions are generated for bad words.
IgnoreMixed | Sets or returns the value indicating if words with uppercase characters after lowercase characters are ignored.
IgnoreNumber | Sets or returns if words containing numbers are ignored.
IgnoreUpper | Sets or returns if words in all uppercase are ignored.

Public Methods

Assign | Extracts settings from the C1Spell instance.
AssignTo | Copies the setting to the C1Spell instance.
Clone | Creates a new instance with the current settings.
Equals | Overriden. Checks if the given instance of the DlgSetting is equal to the current object.
GetHashCode | Overriden. Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DlgSetting Constructor

DlgSetting Constructor

Overload List

Initializes new instance of the DlgSetting class with default values.

[Visual Basic] Public Function New()

[C#] public DlgSetting();

[Delphi] public constructor Create(); overload;

Initializes new instance of the DlgSetting class with values extracts from the specified C1Spell object.

[Visual Basic] Public Function New(C1Spell)

[C#] public DlgSetting(C1Spell);

[Delphi] public constructor Create(C1Spell); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DlgSetting Constructor ()

DlgSetting Constructor ()

Previous Next

Initializes new instance of the DlgSetting class with default values.

[Visual Basic]

Public Function New()

[C#]

public DlgSetting()

[Delphi]

public constructor Create(); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DlgSetting Constructor (C1Spell)

DlgSetting Constructor (C1Spell)

Previous Next

Initializes new instance of the DlgSetting class with values extracts from the specified C1Spell object.

[Visual Basic]

Public Function New( _

ByVal spell As C1Spell _

)

[C#]

public DlgSetting(

C1Spell spell

);

[Delphi]

public constructor Create(

spell: C1Spell

); overload;

Parameters

spell

C1Spell object from which spell-checking options will be extracted.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DlgSetting Properties

DlgSetting Properties

The properties of the DlgSetting class are listed here. For a complete list of DlgSetting class members, see the DlgSetting Members topic.

Public Properties

CustomDictionaries | Sets or returns the paths and filenames of the custom dictionary files.
HasSuggest | Sets or returns whether suggestions are generated for bad words.
IgnoreMixed | Sets or returns the value indicating if words with uppercase characters after lowercase characters are ignored.
IgnoreNumber | Sets or returns if words containing numbers are ignored.
IgnoreUpper | Sets or returns if words in all uppercase are ignored.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DlgSetting.CustomDictionaries Property

DlgSetting.CustomDictionaries Property

Sets or returns the paths and filenames of the custom dictionary files.

[Visual Basic]

Public Property CustomDictionaries As CustomDictionaryCollection

[C#]

public CustomDictionaryCollection CustomDictionaries {get;set;}

[Delphi]

public property CustomDictionaries: CustomDictionaryCollection read get_CustomDictionaries write set_CustomDictionaries;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DlgSetting.HasSuggest Property

DlgSetting.HasSuggest Property

Sets or returns whether suggestions are generated for bad words.

[Visual Basic]

Public Property HasSuggest As Boolean

[C#]

public bool HasSuggest {get;set;}

[Delphi]

public property HasSuggest: Boolean read get_HasSuggest write set_HasSuggest;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DlgSetting.IgnoreMixed Property

DlgSetting.IgnoreMixed Property

Sets or returns the value indicating if words with uppercase characters after lowercase characters are ignored.

[Visual Basic]

Public Property IgnoreMixed As Boolean

[C#]

public bool IgnoreMixed {get;set;}

[Delphi]

public property IgnoreMixed: Boolean read get_IgnoreMixed write set_IgnoreMixed;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DlgSetting.IgnoreNumber Property

DlgSetting.IgnoreNumber Property

Sets or returns if words containing numbers are ignored.

[Visual Basic]

Public Property IgnoreNumber As Boolean

[C#]

public bool IgnoreNumber {get;set;}

[Delphi]

public property IgnoreNumber: Boolean read get_IgnoreNumber write set_IgnoreNumber;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DlgSetting.IgnoreUpper Property

DlgSetting.IgnoreUpper Property

Sets or returns if words in all uppercase are ignored.

[Visual Basic]

Public Property IgnoreUpper As Boolean

[C#]

public bool IgnoreUpper {get;set;}

[Delphi]

public property IgnoreUpper: Boolean read get_IgnoreUpper write set_IgnoreUpper;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DlgSetting Methods

DlgSetting Methods

The methods of the DlgSetting class are listed here. For a complete list of DlgSetting class members, see the DlgSetting Members topic.

Public Methods

Assign | Extracts settings from the C1Spell instance.
AssignTo | Copies the setting to the C1Spell instance.
Clone | Creates a new instance with the current settings.
Equals | Overriden. Checks if the given instance of the DlgSetting is equal to the current object.
GetHashCode | Overriden. Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DlgSetting.Assign Method

DlgSetting.Assign Method

Extracts settings from the C1Spell instance.

[Visual Basic]

Public Sub Assign( _

ByVal spell As C1Spell _

)

[C#]

public void Assign(

C1Spell spell

);

[Delphi]

public procedure Assign(

spell: C1Spell

);

Parameters

spell

C1Spell instance.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DlgSetting.AssignTo Method

DlgSetting.AssignTo Method

Copies the setting to the C1Spell instance.

[Visual Basic]

Public Sub AssignTo( _

ByVal spell As C1Spell _

)

[C#]

public void AssignTo(

C1Spell spell

);

[Delphi]

public procedure AssignTo(

spell: C1Spell

);

Parameters

spell

C1Spell instance in which settings will be copied.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DlgSetting.Clone Method

DlgSetting.Clone Method

Creates a new instance with the current settings.

[Visual Basic]

Public Function Clone() As DlgSetting

[C#]

public DlgSetting Clone()

[Delphi]

public function Clone(): DlgSetting;

Return Value

New DlgSetting instance.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DlgSetting.Equals Method

DlgSetting.Equals Method

Checks if the given instance of the DlgSetting is equal to the current object.

[Visual Basic]

Overrides Public Function Equals( _

ByVal obj As Object _

) As Boolean

[C#]

override public bool Equals(

object obj

);

[Delphi]

public function Equals(

obj: Object

): Boolean; override;

Parameters

obj

The DlgSetting instance to compare with the current object.

Return Value

True if the specified DlgSetting object is equal to the current object; otherwise, False.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


DlgSetting.GetHashCode Method

DlgSetting.GetHashCode Method

Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

[Visual Basic]

Overrides Public Function GetHashCode() As Integer

[C#]

override public int GetHashCode()

[Delphi]

public function GetHashCode(): Int32; override;

Return Value

A hash code for the current object.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Spell.ErrorTypeEnum Enumeration

C1.Win.C1Spell.ErrorTypeEnum Enumeration

Enumerates the possible types of errors caused when the SpellError event is fired.

[Visual Basic]

Public Enum C1.Win.C1Spell.ErrorTypeEnum

[C#]

public enum C1.Win.C1Spell.ErrorTypeEnum

[Delphi]

type C1.Win.C1Spell.ErrorTypeEnum = (AlreadyChecking, CanNotCreateCustDict, CanNotFindMainDict, CanNotOpenMainDict, InvalidWnd, NoErrors, WhichCustDictOutOfRange, WrongDictVersion);

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

Members

Member name | Description
AlreadyChecking | It is checking some other text.
CanNotCreateCustDict | Cannot create a custom dictionary.
CanNotFindMainDict | Cannot find the main dictionary file.
CanNotOpenMainDict | Cannot open the main dictionary file.
InvalidWnd | The checking window is invalid.
NoErrors | No errors.
WhichCustDictOutOfRange | The WhichCustomDict number is out of range.
WrongDictVersion | The MainDictFiledictionary file is the wrong version.

See Also

C1.Win.C1Spell Namespace

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Spell.LanguageEnum Enumeration

C1.Win.C1Spell.LanguageEnum Enumeration

Language of the MainDictFile dictionary.

[Visual Basic]

Public Enum C1.Win.C1Spell.LanguageEnum

[C#]

public enum C1.Win.C1Spell.LanguageEnum

[Delphi]

type C1.Win.C1Spell.LanguageEnum = (LangDutch, LangEnglish, LangFrench, LangGerman, LangIceland, LangItalian, LangNorway, LangSpanish, LangSwedish, LangUnknown);

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

Members

Member name | Description
LangDutch | Dictionary was created in Dutch.
LangEnglish | Dictionary was created in English.
LangFrench | Dictionary was created in French.
LangGerman | Dictionary was created in German.
LangIceland | Dictionary was created in Iceland.
LangItalian | Dictionary was created in Italian.
LangNorway | Dictionary was created in Norway.
LangSpanish | Dictionary was created in Spanish.
LangSwedish | Dictionary was created in Swedish.
LangUnknown | Language of the dictionary is unknown.

See Also

C1.Win.C1Spell Namespace

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


SpellErrorEventArgs Class

SpellErrorEventArgs Class

Provides data for the SpellError event of the C1Spell.

For a list of all members of this type, see SpellErrorEventArgs Members.

System.Object

System.EventArgs

C1.Win.C1Spell.SpellErrorEventArgs

[Visual Basic]

Public Class SpellErrorEventArgs

Inherits EventArgs

[C#]

public class SpellErrorEventArgs : EventArgs

[Delphi]

type SpellErrorEventArgs = class (EventArgs);

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


SpellErrorEventArgs Members

SpellErrorEventArgs Members

SpellErrorEventArgs overview

Public Constructors

SpellErrorEventArgs Constructor

Initializes a new instance of the SpellErrorEventArgs with the default values.

Public Properties

ErrorDesc | Gets or sets the description of the error.
ErrorType | Gets or sets the ErrorTypeEnum object that represents the error type.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


SpellErrorEventArgs Constructor

SpellErrorEventArgs Constructor

Overload List

Initializes a new instance of the SpellErrorEventArgs with the default values.

[Visual Basic] Public Function New()

[C#] public SpellErrorEventArgs();

[Delphi] public constructor Create(); overload;

Initializes a new instance of the SpellErrorEventArgs with the predefined values.

[Visual Basic] Public Function New(ErrorTypeEnum, String)

[C#] public SpellErrorEventArgs(ErrorTypeEnum, string);

[Delphi] public constructor Create(ErrorTypeEnum; String); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


SpellErrorEventArgs Constructor ()

SpellErrorEventArgs Constructor ()

Previous Next

Initializes a new instance of the SpellErrorEventArgs with the default values.

[Visual Basic]

Public Function New()

[C#]

public SpellErrorEventArgs()

[Delphi]

public constructor Create(); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


SpellErrorEventArgs Constructor (ErrorTypeEnum, String)

SpellErrorEventArgs Constructor (ErrorTypeEnum, String)

Previous Next

Initializes a new instance of the SpellErrorEventArgs with the predefined values.

[Visual Basic]

Public Function New( _

ByVal errorType As ErrorTypeEnum, _

ByVal errorDesc As String _

)

[C#]

public SpellErrorEventArgs(

ErrorTypeEnum errorType,

string errorDesc

);

[Delphi]

public constructor Create(

errorType: ErrorTypeEnum;

errorDesc: String

); overload;

Parameters

errorType

The ErrorTypeEnum object that represents the error type.

errorDesc

Gives the description of the error.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


SpellErrorEventArgs Properties

SpellErrorEventArgs Properties

The properties of the SpellErrorEventArgs class are listed here. For a complete list of SpellErrorEventArgs class members, see the SpellErrorEventArgs Members topic.

Public Properties

ErrorDesc | Gets or sets the description of the error.
ErrorType | Gets or sets the ErrorTypeEnum object that represents the error type.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


SpellErrorEventArgs.ErrorDesc Property

SpellErrorEventArgs.ErrorDesc Property

Gets or sets the description of the error.

[Visual Basic]

Public Property ErrorDesc As String

[C#]

public string ErrorDesc {get;set;}

[Delphi]

public property ErrorDesc: String read get_ErrorDesc write set_ErrorDesc;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


SpellErrorEventArgs.ErrorType Property

SpellErrorEventArgs.ErrorType Property

Gets or sets the ErrorTypeEnum object that represents the error type.

[Visual Basic]

Public Property ErrorType As ErrorTypeEnum

[C#]

public ErrorTypeEnum ErrorType {get;set;}

[Delphi]

public property ErrorType: ErrorTypeEnum read get_ErrorType write set_ErrorType;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


SpellErrorEventHandler Delegate

SpellErrorEventHandler Delegate

Represents the method that will handle the SpellError event of the C1Spell.

[Visual Basic]

Public Delegate Sub SpellErrorEventHandler( _

ByVal sender As Object, _

ByVal e As SpellErrorEventArgs _

)

[C#]

public delegate void SpellErrorEventHandler(

object sender,

SpellErrorEventArgs e

);

[Delphi]

type SpellErrorEventHandler = procedure (

sender: Object;

e: SpellErrorEventArgs

) of object;

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

See Also

C1.Win.C1Spell Namespace

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


StringPair Class

StringPair Class

String pairs are stored in instances of the StringPair class.

For a list of all members of this type, see StringPair Members.

System.Object

C1.Win.C1Spell.StringPair

[Visual Basic]

Public Class StringPair

[C#]

public class StringPair

[Delphi]

type StringPair = class;

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


StringPair Members

StringPair Members

StringPair overview

Public Constructors

StringPair Constructor

Initializes new instance of the StringPair class.

Public Properties

String1 | Gets or sets the first string of the string pair.
String2 | Gets or sets the second string of the string pair.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


StringPair Constructor

StringPair Constructor

Initializes new instance of the StringPair class.

[Visual Basic]

Public Function New( _

ByVal str1 As String, _

ByVal str2 As String _

)

[C#]

public StringPair(

string str1,

string str2

);

[Delphi]

public constructor Create(

str1: String;

str2: String

);

Parameters

str1

First string.

str2

Second string.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


StringPair Properties

StringPair Properties

The properties of the StringPair class are listed here. For a complete list of StringPair class members, see the StringPair Members topic.

Public Properties

String1 | Gets or sets the first string of the string pair.
String2 | Gets or sets the second string of the string pair.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


StringPair.String1 Property

StringPair.String1 Property

Gets or sets the first string of the string pair.

[Visual Basic]

Public Property String1 As String

[C#]

public string String1 {get;set;}

[Delphi]

public property String1: String read get_String1 write set_String1;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


StringPair.String2 Property

StringPair.String2 Property

Gets or sets the second string of the string pair.

[Visual Basic]

Public Property String2 As String

[C#]

public string String2 {get;set;}

[Delphi]

public property String2: String read get_String2 write set_String2;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


StringPairCollection Class

StringPairCollection Class

A collection of unique StringPair items.

For a list of all members of this type, see StringPairCollection Members.

System.Object

System.Collections.CollectionBase

C1.Win.C1Spell.StringPairCollection

[Visual Basic]

Public Class StringPairCollection

Inherits CollectionBase

[C#]

public class StringPairCollection : CollectionBase

[Delphi]

type StringPairCollection = class (CollectionBase);

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


StringPairCollection Members

StringPairCollection Members

StringPairCollection overview

Public Properties

Item

Indexer. Gets or sets the StringPair element by its index.

Public Methods

Add | Overloaded. Adds specified StringPair item to the collection.
Clear | Clears collection.
IndexOf | Overloaded. Searches for the specified StringPair item in the collection.
IndexOfStr1 | Searches for the specified string among the String1 values in the collection.
IndexOfStr2 | Searches for the specified string among the String2 properties in the collection.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


StringPairCollection Properties

StringPairCollection Properties

The properties of the StringPairCollection class are listed here. For a complete list of StringPairCollection class members, see the StringPairCollection Members topic.

Public Properties

Item

Indexer. Gets or sets the StringPair element by its index.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


StringPairCollection.Item Property

StringPairCollection.Item Property

Indexer. Gets or sets the StringPair element by its index.

[Visual Basic]

Public Default ReadOnly Property Item( _

ByVal index As Integer _

) As StringPair

[C#]

public StringPair this[

int index

] {get;}

[Delphi]

public property Item[

index: Int32

]: StringPair read get_Item;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


StringPairCollection Methods

StringPairCollection Methods

The methods of the StringPairCollection class are listed here. For a complete list of StringPairCollection class members, see the StringPairCollection Members topic.

Public Methods

Add | Overloaded. Adds specified StringPair item to the collection.
Clear | Clears collection.
IndexOf | Overloaded. Searches for the specified StringPair item in the collection.
IndexOfStr1 | Searches for the specified string among the String1 values in the collection.
IndexOfStr2 | Searches for the specified string among the String2 properties in the collection.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


StringPairCollection.Add Method

StringPairCollection.Add Method

Overload List

Creates new StringPair item from the specified strings and adds them to the collection.

[Visual Basic] Overloads Public Function Add(String, String) As Boolean

[C#] public bool Add(string, string);

[Delphi] public function Add(String; String) : Boolean; overload;

Adds specified StringPair item to the collection.

[Visual Basic] Overloads Public Function Add(StringPair) As Boolean

[C#] public bool Add(StringPair);

[Delphi] public function Add(StringPair) : Boolean; overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


StringPairCollection.Add Method (String, String)

StringPairCollection.Add Method (String, String)

Previous Next

Creates new StringPair item from the specified strings and adds them to the collection.

[Visual Basic]

Overloads Public Function Add( _

ByVal str1 As String, _

ByVal str2 As String _

) As Boolean

[C#]

public bool Add(

string str1,

string str2

);

[Delphi]

public function Add(

str1: String;

str2: String

): Boolean; overload;

Parameters

str1

First string.

str2

Second string.

Return Value

True, if item is successfully added into the collection, otherwise False (if such item already exists in collection).

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


StringPairCollection.Add Method (StringPair)

StringPairCollection.Add Method (StringPair)

Previous Next

Adds specified StringPair item to the collection.

[Visual Basic]

Overloads Public Function Add( _

ByVal item As StringPair _

) As Boolean

[C#]

public bool Add(

StringPair item

);

[Delphi]

public function Add(

item: StringPair

): Boolean; overload;

Parameters

item

StringPair item to add.

Return Value

True, if item is successfully added into the collection, otherwise False (if such item already exists in collection).

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


StringPairCollection.Clear Method

StringPairCollection.Clear Method

Clears collection.

[Visual Basic]

Public Sub Clear()

[C#]

new public void Clear()

[Delphi]

public procedure Clear();

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


StringPairCollection.IndexOf Method

StringPairCollection.IndexOf Method

Overload List

Searches for the specified strings pair in the collection.

[Visual Basic] Overloads Public Function IndexOf(String, String) As Integer

[C#] public int IndexOf(string, string);

[Delphi] public function IndexOf(String; String) : Int32; overload;

Searches for the specified StringPair item in the collection.

[Visual Basic] Overloads Public Function IndexOf(StringPair) As Integer

[C#] public int IndexOf(StringPair);

[Delphi] public function IndexOf(StringPair) : Int32; overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


StringPairCollection.IndexOf Method (String, String)

StringPairCollection.IndexOf Method (String, String)

Previous Next

Searches for the specified strings pair in the collection.

[Visual Basic]

Overloads Public Function IndexOf( _

ByVal str1 As String, _

ByVal str2 As String _

) As Integer

[C#]

public int IndexOf(

string str1,

string str2

);

[Delphi]

public function IndexOf(

str1: String;

str2: String

): Int32; overload;

Parameters

str1

First string.

str2

Second string.

Return Value

The index of the occurrence of string pair within the collection, if found. Otherwise -1.

Remarks

String comparsions are case-insensitive.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


StringPairCollection.IndexOf Method (StringPair)

StringPairCollection.IndexOf Method (StringPair)

Previous Next

Searches for the specified StringPair item in the collection.

[Visual Basic]

Overloads Public Function IndexOf( _

ByVal item As StringPair _

) As Integer

[C#]

public int IndexOf(

StringPair item

);

[Delphi]

public function IndexOf(

item: StringPair

): Int32; overload;

Parameters

item

StringPair item to search.

Return Value

The index of the occurrence of the item within the collection, if found. Otherwise -1.

Remarks

String comparsions are case-insensitive.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


StringPairCollection.IndexOfStr1 Method

StringPairCollection.IndexOfStr1 Method

Searches for the specified string among the String1 values in the collection.

[Visual Basic]

Public Function IndexOfStr1( _

ByVal str1 As String _

) As Integer

[C#]

public int IndexOfStr1(

string str1

);

[Delphi]

public function IndexOfStr1(

str1: String

): Int32;

Parameters

str1

String to find.

Return Value

The index of the first occurrence of the StringPair item within the collection with the String1 value equal to the search string, if found. Otherwise -1.

Remarks

String comparsions are case-insensitive.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


StringPairCollection.IndexOfStr2 Method

StringPairCollection.IndexOfStr2 Method

Searches for the specified string among the String2 properties in the collection.

[Visual Basic]

Public Function IndexOfStr2( _

ByVal str2 As String _

) As Integer

[C#]

public int IndexOfStr2(

string str2

);

[Delphi]

public function IndexOfStr2(

str2: String

): Int32;

Parameters

str2

String to find.

Return Value

The index of the first occurrence of the StringPair item within the collection with the String2 value equal to the search string, if found. Otherwise -1.

Remarks

String comparsions are case-insensitive.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Spell.SuggestionEventArgs Class

C1.Win.C1Spell.SuggestionEventArgs Class

Provides data for the Suggestion event of C1Spell

For a list of all members of this type, see SuggestionEventArgs Members.

System.Object

System.EventArgs

C1.Win.C1Spell.SuggestionEventArgs

[Visual Basic]

Public Class SuggestionEventArgs

Inherits EventArgs

[C#]

public class SuggestionEventArgs : EventArgs

[Delphi]

type SuggestionEventArgs = class (EventArgs);

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Spell.SuggestionEventArgs Members

C1.Win.C1Spell.SuggestionEventArgs Members

SuggestionEventArgs overview

Public Constructors

C1.Win.C1Spell.SuggestionEventArgs Constructor

Initializes a new instance of the SuggestionEventArgs with the default values.

Public Properties

Cancel | If True then suggestion process will be cancelled.
Index | The index of the suggested words.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Spell.SuggestionEventArgs Constructor

C1.Win.C1Spell.SuggestionEventArgs Constructor

Overload List

Initializes a new instance of the SuggestionEventArgs with the default values.

[Visual Basic] Public Function New()

[C#] public SuggestionEventArgs();

[Delphi] public constructor Create(); overload;

Initializes a new instance of SuggestionEventArgs with the predefined values.

[Visual Basic] Public Function New(Integer, Boolean)

[C#] public SuggestionEventArgs(int, bool);

[Delphi] public constructor Create(Int32; Boolean); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Spell.SuggestionEventArgs Constructor ()

C1.Win.C1Spell.SuggestionEventArgs Constructor ()

Previous Next

Initializes a new instance of the SuggestionEventArgs with the default values.

[Visual Basic]

Public Function New()

[C#]

public SuggestionEventArgs()

[Delphi]

public constructor Create(); overload;

See Also

C1.Win.C1Spell.SuggestionEventArgs Class | C1.Win.C1Spell.SuggestionEventArgs Members | C1.Win.C1Spell Namespace | C1.Win.C1Spell.SuggestionEventArgs Constructor Overload List


C1.Win.C1Spell.SuggestionEventArgs Constructor (Int32, Boolean)

C1.Win.C1Spell.SuggestionEventArgs Constructor (Int32, Boolean)

Previous Next

Initializes a new instance of SuggestionEventArgs with the predefined values.

[Visual Basic]

Public Function New( _

ByVal index As Integer, _

ByVal cancel As Boolean _

)

[C#]

public SuggestionEventArgs(

int index,

bool cancel

);

[Delphi]

public constructor Create(

index: Int32;

cancel: Boolean

); overload;

Parameters

index

The index of the suggested words.

cancel

If True then suggestion process will cancelled.

See Also

C1.Win.C1Spell.SuggestionEventArgs Class | C1.Win.C1Spell.SuggestionEventArgs Members | C1.Win.C1Spell Namespace | C1.Win.C1Spell.SuggestionEventArgs Constructor Overload List


C1.Win.C1Spell.SuggestionEventArgs Properties

C1.Win.C1Spell.SuggestionEventArgs Properties

The properties of the SuggestionEventArgs class are listed here. For a complete list of SuggestionEventArgs class members, see the C1.Win.C1Spell.SuggestionEventArgs Members topic.

Public Properties

Cancel | If True then suggestion process will be cancelled.
Index | The index of the suggested words.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Spell.SuggestionEventArgs.Cancel Property

C1.Win.C1Spell.SuggestionEventArgs.Cancel Property

If True then suggestion process will be cancelled.

[Visual Basic]

Public Property Cancel As Boolean

[C#]

public bool Cancel {get;set;}

[Delphi]

public property Cancel: Boolean read get_Cancel write set_Cancel;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Spell.SuggestionEventArgs.Index Property

C1.Win.C1Spell.SuggestionEventArgs.Index Property

The index of the suggested words.

[Visual Basic]

Public Property Index As Integer

[C#]

public int Index {get;set;}

[Delphi]

public property Index: Int32 read get_Index write set_Index;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Spell.SuggestionEventHandler Delegate

C1.Win.C1Spell.SuggestionEventHandler Delegate

Represents the method that will handle the Suggestion event of C1Spell

[Visual Basic]

Public Delegate Sub SuggestionEventHandler( _

ByVal sender As Object, _

ByVal e As SuggestionEventArgs _

)

[C#]

public delegate void SuggestionEventHandler(

object sender,

SuggestionEventArgs e

);

[Delphi]

type SuggestionEventHandler = procedure (

sender: Object;

e: SuggestionEventArgs

) of object;

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

See Also

C1.Win.C1Spell Namespace

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


TypingErrorActionEnum Enumeration

TypingErrorActionEnum Enumeration

Enumerates the available actions to be taken when an error word is typed.

[Visual Basic]

Public Enum TypingErrorActionEnum

[C#]

public enum TypingErrorActionEnum

[Delphi]

type TypingErrorActionEnum = (Beep, BeepAndUnderline, NoAction, Underline);

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

Remarks

Use the members of this enumeration to set the value of the TypingErrorAction property.

Members

Member name | Description
Beep | Indicates a beep will sound when the user types an error.
BeepAndUnderline | Indicates a beep will sound when the user types an error, and the error will be underlined.
NoAction | Indicates no action will be taken.
Underline | Indicates a typing error will be underlined.

See Also

C1.Win.C1Spell Namespace

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


TypingErrorEventArgs Class

TypingErrorEventArgs Class

Provides data for the TypingError event of C1Spell.

For a list of all members of this type, see TypingErrorEventArgs Members.

System.Object

System.EventArgs

C1.Win.C1Spell.TypingErrorEventArgs

[Visual Basic]

Public Class TypingErrorEventArgs

Inherits EventArgs

[C#]

public class TypingErrorEventArgs : EventArgs

[Delphi]

type TypingErrorEventArgs = class (EventArgs);

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


TypingErrorEventArgs Members

TypingErrorEventArgs Members

TypingErrorEventArgs overview

Public Constructors

TypingErrorEventArgs Constructor

Initializes a new instance of the TypingErrorEventArgs with the default values.

Public Properties

Cancel | When True, the TypingErrorAction of the C1Spell is cancelled, and user can set a custom action.
ErrWord | The last word typed.
SelLength | The length of the last word typed.
SelStart | The start position of the last word typed.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


TypingErrorEventArgs Constructor

TypingErrorEventArgs Constructor

Overload List

Initializes a new instance of the TypingErrorEventArgs with the default values.

[Visual Basic] Public Function New()

[C#] public TypingErrorEventArgs();

[Delphi] public constructor Create(); overload;

Initializes a new instance of the TypingErrorEventArgs with the predefined values.

[Visual Basic] Public Function New(String, Long, Long, Boolean)

[C#] public TypingErrorEventArgs(string, long, long, bool);

[Delphi] public constructor Create(String; Int64; Int64; Boolean); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


TypingErrorEventArgs Constructor ()

TypingErrorEventArgs Constructor ()

Previous Next

Initializes a new instance of the TypingErrorEventArgs with the default values.

[Visual Basic]

Public Function New()

[C#]

public TypingErrorEventArgs()

[Delphi]

public constructor Create(); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


TypingErrorEventArgs Constructor (String, Int64, Int64, Boolean)

TypingErrorEventArgs Constructor (String, Int64, Int64, Boolean)

Previous Next

Initializes a new instance of the TypingErrorEventArgs with the predefined values.

[Visual Basic]

Public Function New( _

ByVal word As String, _

ByVal selStart As Long, _

ByVal selLength As Long, _

ByVal cancel As Boolean _

)

[C#]

public TypingErrorEventArgs(

string word,

long selStart,

long selLength,

bool cancel

);

[Delphi]

public constructor Create(

word: String;

selStart: Int64;

selLength: Int64;

cancel: Boolean

); overload;

Parameters

word

The last word typed.

selStart

The start position of the last word typed.

selLength

The length of the last word typed.

cancel

When True, the TypingErrorAction of the C1Spell is cancelled, and user can set a custom action.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


TypingErrorEventArgs Properties

TypingErrorEventArgs Properties

The properties of the TypingErrorEventArgs class are listed here. For a complete list of TypingErrorEventArgs class members, see the TypingErrorEventArgs Members topic.

Public Properties

Cancel | When True, the TypingErrorAction of the C1Spell is cancelled, and user can set a custom action.
ErrWord | The last word typed.
SelLength | The length of the last word typed.
SelStart | The start position of the last word typed.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


TypingErrorEventArgs.Cancel Property

TypingErrorEventArgs.Cancel Property

When True, the TypingErrorAction of the C1Spell is cancelled, and user can set a custom action.

[Visual Basic]

Public Property Cancel As Boolean

[C#]

public bool Cancel {get;set;}

[Delphi]

public property Cancel: Boolean read get_Cancel write set_Cancel;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


TypingErrorEventArgs.ErrWord Property

TypingErrorEventArgs.ErrWord Property

The last word typed.

[Visual Basic]

Public ReadOnly Property ErrWord As String

[C#]

public string ErrWord {get;}

[Delphi]

public property ErrWord: String read get_ErrWord;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


TypingErrorEventArgs.SelLength Property

TypingErrorEventArgs.SelLength Property

The length of the last word typed.

[Visual Basic]

Public ReadOnly Property SelLength As Long

[C#]

public long SelLength {get;}

[Delphi]

public property SelLength: Int64 read get_SelLength;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


TypingErrorEventArgs.SelStart Property

TypingErrorEventArgs.SelStart Property

The start position of the last word typed.

[Visual Basic]

Public ReadOnly Property SelStart As Long

[C#]

public long SelStart {get;}

[Delphi]

public property SelStart: Int64 read get_SelStart;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


TypingErrorEventHandler Delegate

TypingErrorEventHandler Delegate

Represents the method that will handle the TypingError event of C1Spell.

[Visual Basic]

Public Delegate Sub TypingErrorEventHandler( _

ByVal sender As Object, _

ByVal e As TypingErrorEventArgs _

)

[C#]

public delegate void TypingErrorEventHandler(

object sender,

TypingErrorEventArgs e

);

[Delphi]

type TypingErrorEventHandler = procedure (

sender: Object;

e: TypingErrorEventArgs

) of object;

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

See Also

C1.Win.C1Spell Namespace

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


TypingOKEventArgs Class

TypingOKEventArgs Class

Provides data for the TypingOK event of the C1Spell.

For a list of all members of this type, see TypingOKEventArgs Members.

System.Object

System.EventArgs

C1.Win.C1Spell.TypingOKEventArgs

[Visual Basic]

Public Class TypingOKEventArgs

Inherits EventArgs

[C#]

public class TypingOKEventArgs : EventArgs

[Delphi]

type TypingOKEventArgs = class (EventArgs);

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


TypingOKEventArgs Members

TypingOKEventArgs Members

TypingOKEventArgs overview

Public Constructors

TypingOKEventArgs Constructor

Initializes a new instance of the TypingOKEventArgs with the default values.

Public Properties

SelLength | The length of the last word typed.
SelStart | The start position of the last word typed.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


TypingOKEventArgs Constructor

TypingOKEventArgs Constructor

Overload List

Initializes a new instance of the TypingOKEventArgs with the default values.

[Visual Basic] Public Function New()

[C#] public TypingOKEventArgs();

[Delphi] public constructor Create(); overload;

Initializes a new instance of the TypingOKEventArgs with the predefined values.

[Visual Basic] Public Function New(Long, Long)

[C#] public TypingOKEventArgs(long, long);

[Delphi] public constructor Create(Int64; Int64); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


TypingOKEventArgs Constructor ()

TypingOKEventArgs Constructor ()

Previous Next

Initializes a new instance of the TypingOKEventArgs with the default values.

[Visual Basic]

Public Function New()

[C#]

public TypingOKEventArgs()

[Delphi]

public constructor Create(); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


TypingOKEventArgs Constructor (Int64, Int64)

TypingOKEventArgs Constructor (Int64, Int64)

Previous Next

Initializes a new instance of the TypingOKEventArgs with the predefined values.

[Visual Basic]

Public Function New( _

ByVal selStart As Long, _

ByVal selLength As Long _

)

[C#]

public TypingOKEventArgs(

long selStart,

long selLength

);

[Delphi]

public constructor Create(

selStart: Int64;

selLength: Int64

); overload;

Parameters

selStart

The start position of the last word typed.

selLength

The length of the last word typed.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


TypingOKEventArgs Properties

TypingOKEventArgs Properties

The properties of the TypingOKEventArgs class are listed here. For a complete list of TypingOKEventArgs class members, see the TypingOKEventArgs Members topic.

Public Properties

SelLength | The length of the last word typed.
SelStart | The start position of the last word typed.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


TypingOKEventArgs.SelLength Property

TypingOKEventArgs.SelLength Property

The length of the last word typed.

[Visual Basic]

Public Property SelLength As Long

[C#]

public long SelLength {get;set;}

[Delphi]

public property SelLength: Int64 read get_SelLength write set_SelLength;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


TypingOKEventArgs.SelStart Property

TypingOKEventArgs.SelStart Property

The start position of the last word typed.

[Visual Basic]

Public Property SelStart As Long

[C#]

public long SelStart {get;set;}

[Delphi]

public property SelStart: Int64 read get_SelStart write set_SelStart;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


TypingOKEventHandler Delegate

TypingOKEventHandler Delegate

Represents the method that will handle the TypingOK event of the C1Spell.

[Visual Basic]

Public Delegate Sub TypingOKEventHandler( _

ByVal sender As Object, _

ByVal e As TypingOKEventArgs _

)

[C#]

public delegate void TypingOKEventHandler(

object sender,

TypingOKEventArgs e

);

[Delphi]

type TypingOKEventHandler = procedure (

sender: Object;

e: TypingOKEventArgs

) of object;

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

See Also

C1.Win.C1Spell Namespace

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStrings Class

UIStrings Class

For a list of all members of this type, see UIStrings Members.

System.Object

C1.Win.C1Spell.UIStrings

[Visual Basic]

Public Class UIStrings

[C#]

public class UIStrings

[Delphi]

type UIStrings = class;

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStrings Members

UIStrings Members

UIStrings overview

Public Properties

Count | Returns the number of elements contained in the collection.
Item | Gets or sets the string value for the specified key.

Public Methods

Add | Overloaded. Adds a string to the collection, specifying the ordinal.
AddInOrder | Adds a string to the collection, preserving the order.
GetDescription | Returns the item description.
GetKeyAt | Returns the key of an item with the specified index.
GetValueAt | Gets the string by its index.
IsDefault | Returns True if the string is equal to its default value.
Reset | Overloaded. Sets all strings in collection to their default values.
SetValueAt | Sets the string by its index.
ShouldSerialize | Returns True if there is any non-default string in the collection.

Public Events

CollectionChanged | Occurs when the collection has been changed.
ItemAdded | Occurs when a new item added to the collection.
ItemChanged | Occurs when an item changed in the collection.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStrings Properties

UIStrings Properties

The properties of the UIStrings class are listed here. For a complete list of UIStrings class members, see the UIStrings Members topic.

Public Properties

Count | Returns the number of elements contained in the collection.
Item | Gets or sets the string value for the specified key.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStrings.Count Property

UIStrings.Count Property

Returns the number of elements contained in the collection.

[Visual Basic]

Public ReadOnly Property Count As Integer

[C#]

public int Count {get;}

[Delphi]

public property Count: Int32 read get_Count;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStrings.Item Property

UIStrings.Item Property

Gets or sets the string value for the specified key.

[Visual Basic]

Public Default Property Item( _

ByVal key As Object _

) As String

[C#]

public string this[

object key

] {get;set;}

[Delphi]

public property Item[

key: Object

]: String read get_Item write set_Item;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStrings Methods

UIStrings Methods

The methods of the UIStrings class are listed here. For a complete list of UIStrings class members, see the UIStrings Members topic.

Public Methods

Add | Overloaded. Adds a string to the collection, specifying the ordinal.
AddInOrder | Adds a string to the collection, preserving the order.
GetDescription | Returns the item description.
GetKeyAt | Returns the key of an item with the specified index.
GetValueAt | Gets the string by its index.
IsDefault | Returns True if the string is equal to its default value.
Reset | Overloaded. Sets all strings in collection to their default values.
SetValueAt | Sets the string by its index.
ShouldSerialize | Returns True if there is any non-default string in the collection.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStrings.Add Method

UIStrings.Add Method

Overload List

Adds a string to the collection, specifying the ordinal.

[Visual Basic] Overloads Public Sub Add(Object, Integer, String, String)

[C#] public void Add(object, int, string, string);

[Delphi] public procedure Add(Object; Int32; String; String); overload;

Adds a string to the collection in alphabetical order.

[Visual Basic] Overloads Public Sub Add(Object, String, String)

[C#] public void Add(object, string, string);

[Delphi] public procedure Add(Object; String; String); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStrings.Add Method (Object, Int32, String, String)

UIStrings.Add Method (Object, Int32, String, String)

Previous Next

Adds a string to the collection, specifying the ordinal.

[Visual Basic]

Overloads Public Sub Add( _

ByVal key As Object, _

ByVal ordinal As Integer, _

ByVal value As String, _

ByVal description As String _

)

[C#]

public void Add(

object key,

int ordinal,

string value,

string description

);

[Delphi]

public procedure Add(

key: Object;

ordinal: Int32;

value: String;

description: String

); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStrings.Add Method (Object, String, String)

UIStrings.Add Method (Object, String, String)

Previous Next

Adds a string to the collection in alphabetical order.

[Visual Basic]

Overloads Public Sub Add( _

ByVal key As Object, _

ByVal value As String, _

ByVal description As String _

)

[C#]

public void Add(

object key,

string value,

string description

);

[Delphi]

public procedure Add(

key: Object;

value: String;

description: String

); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStrings.AddInOrder Method

UIStrings.AddInOrder Method

Adds a string to the collection, preserving the order.

[Visual Basic]

Public Sub AddInOrder( _

ByVal key As Object, _

ByVal value As String, _

ByVal description As String _

)

[C#]

public void AddInOrder(

object key,

string value,

string description

);

[Delphi]

public procedure AddInOrder(

key: Object;

value: String;

description: String

);

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStrings.GetDescription Method

UIStrings.GetDescription Method

Returns the item description.

[Visual Basic]

Public Function GetDescription( _

ByVal key As Object _

) As String

[C#]

public string GetDescription(

object key

);

[Delphi]

public function GetDescription(

key: Object

): String;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStrings.GetKeyAt Method

UIStrings.GetKeyAt Method

Returns the key of an item with the specified index.

[Visual Basic]

Public Function GetKeyAt( _

ByVal index As Integer _

) As Object

[C#]

public object GetKeyAt(

int index

);

[Delphi]

public function GetKeyAt(

index: Int32

): Object;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStrings.GetValueAt Method

UIStrings.GetValueAt Method

Gets the string by its index.

[Visual Basic]

Public Function GetValueAt( _

ByVal index As Integer _

) As String

[C#]

public string GetValueAt(

int index

);

[Delphi]

public function GetValueAt(

index: Int32

): String;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStrings.IsDefault Method

UIStrings.IsDefault Method

Returns True if the string is equal to its default value.

[Visual Basic]

Public Function IsDefault( _

ByVal key As Object _

) As Boolean

[C#]

public bool IsDefault(

object key

);

[Delphi]

public function IsDefault(

key: Object

): Boolean;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStrings.Reset Method

UIStrings.Reset Method

Overload List

Sets all strings in collection to their default values.

[Visual Basic] Overloads Public Sub Reset()

[C#] public void Reset();

[Delphi] public procedure Reset(); overload;

Sets the string to its default value.

[Visual Basic] Overloads Public Sub Reset(Object)

[C#] public void Reset(object);

[Delphi] public procedure Reset(Object); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStrings.Reset Method ()

UIStrings.Reset Method ()

Previous Next

Sets all strings in collection to their default values.

[Visual Basic]

Overloads Public Sub Reset()

[C#]

public void Reset()

[Delphi]

public procedure Reset(); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStrings.Reset Method (Object)

UIStrings.Reset Method (Object)

Previous Next

Sets the string to its default value.

[Visual Basic]

Overloads Public Sub Reset( _

ByVal key As Object _

)

[C#]

public void Reset(

object key

);

[Delphi]

public procedure Reset(

key: Object

); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStrings.SetValueAt Method

UIStrings.SetValueAt Method

Sets the string by its index.

[Visual Basic]

Public Sub SetValueAt( _

ByVal index As Integer, _

ByVal value As String _

)

[C#]

public void SetValueAt(

int index,

string value

);

[Delphi]

public procedure SetValueAt(

index: Int32;

value: String

);

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStrings.ShouldSerialize Method

UIStrings.ShouldSerialize Method

Returns True if there is any non-default string in the collection.

[Visual Basic]

Public Function ShouldSerialize() As Boolean

[C#]

public bool ShouldSerialize()

[Delphi]

public function ShouldSerialize(): Boolean;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStrings Events

UIStrings Events

The events of the UIStrings class are listed here. For a complete list of UIStrings class members, see the UIStrings Members topic.

Public Events

CollectionChanged | Occurs when the collection has been changed.
ItemAdded | Occurs when a new item added to the collection.
ItemChanged | Occurs when an item changed in the collection.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStrings.CollectionChanged Event

UIStrings.CollectionChanged Event

Occurs when the collection has been changed.

[Visual Basic]

Public Event CollectionChanged As EventHandler

[C#]

public event EventHandler CollectionChanged

[Delphi]

public property CollectionChanged: EventHandler read remove_CollectionChanged write add_CollectionChanged;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStrings.ItemAdded Event

UIStrings.ItemAdded Event

Occurs when a new item added to the collection.

[Visual Basic]

Public Event ItemAdded As UIStringsItemEventHandler

[C#]

public event UIStringsItemEventHandler ItemAdded

[Delphi]

public property ItemAdded: UIStringsItemEventHandler read remove_ItemAdded write add_ItemAdded;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStrings.ItemChanged Event

UIStrings.ItemChanged Event

Occurs when an item changed in the collection.

[Visual Basic]

Public Event ItemChanged As UIStringsItemEventHandler

[C#]

public event UIStringsItemEventHandler ItemChanged

[Delphi]

public property ItemChanged: UIStringsItemEventHandler read remove_ItemChanged write add_ItemChanged;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStringsEnum Enumeration

UIStringsEnum Enumeration

Sets the dialog strings for spell dialog and option dialog.

[Visual Basic]

Public Enum UIStringsEnum

[C#]

public enum UIStringsEnum

[Delphi]

type UIStringsEnum = (OAdd, OCancel, OCustomDictionaries, OFullPath, OIgnoreWordsInMixedCase, OIgnoreWordsInUpperCase, OIgnoreWordsWithNumbers, OOk, OOptions, ORemove, OSpellSetting, OSuggestCorrections, SAdd, SAddWordsTo, SCancel, SChange, SChangeAll, SHelp, SIgnore, SIgnoreAll, SNotInDictionary, SOptions, SSpellingCheck, SSuggestions);

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

Remarks

Use the members of this enumeration to set the value of the UIStrings property.

Members

Member name | Description
OAdd | "Add" button text.
OCancel | "Cancel" button text.
OCustomDictionaries | Text of the "Custom dictionaries" panel.
OFullPath | "Full Path" label text.
OIgnoreWordsInMixedCase | "Ignore Words in Mixed Case" CheckBox text.
OIgnoreWordsInUpperCase | "Ignore Words in Upper Case" CheckBox text.
OIgnoreWordsWithNumbers | "Ignore Words with Numbers" CheckBox text.
OOk | "OK" button text.
OOptions | Text of the option dialog.
ORemove | "Remove" button text.
OSpellSetting | Text of the "Spell settings" panel.
OSuggestCorrections | "Suggest Corrections" CheckBox text.
SAdd | "Add" button text.
SAddWordsTo | "Add Words To" label text.
SCancel | "Cancel" button text.
SChange | "Change" button text.
SChangeAll | "Change All" button text.
SHelp | "Help" button text.
SIgnore | "Ignore" button text.
SIgnoreAll | "Ignore All" button text.
SNotInDictionary | "Not in Dictionary" label text.
SOptions | "Options" button text.
SSpellingCheck | Text of the spell dialog.
SSuggestions | "Suggestions" button text.

See Also

C1.Win.C1Spell Namespace

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStringsItemEventArgs Class

UIStringsItemEventArgs Class

For a list of all members of this type, see UIStringsItemEventArgs Members.

System.Object

System.EventArgs

C1.Win.C1Spell.UIStringsItemEventArgs

[Visual Basic]

Public Class UIStringsItemEventArgs

Inherits EventArgs

[C#]

public class UIStringsItemEventArgs : EventArgs

[Delphi]

type UIStringsItemEventArgs = class (EventArgs);

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStringsItemEventArgs Members

UIStringsItemEventArgs Members

UIStringsItemEventArgs overview

Public Properties

Description | The description provided for the item.
IsDefault | True if the value is equal to the default string.
Key | The key of the item being added or changed.
Value | The new string value.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStringsItemEventArgs Properties

UIStringsItemEventArgs Properties

The properties of the UIStringsItemEventArgs class are listed here. For a complete list of UIStringsItemEventArgs class members, see the UIStringsItemEventArgs Members topic.

Public Properties

Description | The description provided for the item.
IsDefault | True if the value is equal to the default string.
Key | The key of the item being added or changed.
Value | The new string value.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStringsItemEventArgs.Description Property

UIStringsItemEventArgs.Description Property

The description provided for the item.

[Visual Basic]

Public ReadOnly Property Description As String

[C#]

public string Description {get;}

[Delphi]

public property Description: String read get_Description;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStringsItemEventArgs.IsDefault Property

UIStringsItemEventArgs.IsDefault Property

True if the value is equal to the default string.

[Visual Basic]

Public ReadOnly Property IsDefault As Boolean

[C#]

public bool IsDefault {get;}

[Delphi]

public property IsDefault: Boolean read get_IsDefault;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStringsItemEventArgs.Key Property

UIStringsItemEventArgs.Key Property

The key of the item being added or changed.

[Visual Basic]

Public ReadOnly Property Key As Object

[C#]

public object Key {get;}

[Delphi]

public property Key: Object read get_Key;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UIStringsItemEventArgs.Value Property

UIStringsItemEventArgs.Value Property

The new string value.

[Visual Basic]

Public ReadOnly Property Value As String

[C#]

public string Value {get;}

[Delphi]

public property Value: String read get_Value;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


UnderlineStyleEnum Enumeration

UnderlineStyleEnum Enumeration

Enumerates the styles of underlining used when a word is misspelled.

[Visual Basic]

Public Enum UnderlineStyleEnum

[C#]

public enum UnderlineStyleEnum

[Delphi]

type UnderlineStyleEnum = (ULDouble, ULInvert, ULNone, ULSingle, ULWiggly);

Namespace: C1.Win.C1Spell

Assembly: C1.Win.C1Spell.2 (in C1.Win.C1Spell.2.dll)

Remarks

Use the members of this enumeration to set the value of the UnderlineStyle property.

Members

Member name | Description
ULDouble | Misspelled words are underlined with a double line.
ULInvert | Misspelled words are inverted.
ULNone | Misspelled words are not underlined.
ULSingle | Misspelled words are underlined with a single line.
ULWiggly | Misspelled words are underlined with a wiggly line.

See Also

C1.Win.C1Spell Namespace

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Thesaurus Namespace

C1.Win.C1Thesaurus Namespace

C1.Win.C1Thesaurus Hierarchy

Classes

Class | Description
C1Thesaurus | Represents the C1Thesaurus control.
C1.Win.C1Thesaurus.CompleteEventArgs | Provides data for the Complete event of the C1Thesaurus.
NotFoundEventArgs | Provides data for the NotFound event of C1Thesaurus.
C1.Win.C1Thesaurus.SuggestionEventArgs | Provides data for the Suggestion event of the C1Thesaurus.
ThesErrorEventArgs | Provides data for the ThesError event of the C1Thesaurus.

Delegates

Delegate | Description
BadWordEventHandler | Represents the method that will handle the NotFound event of C1Thesaurus.
CompleteEventHandler | Represents the method that will handle the Complete event of the C1Thesaurus.
SuggestionEventHandler | Represents the method that will handle the Suggestion event of the C1Thesaurus.
ThesErrorEventHandler | Represents the method that will handle the ThesError event of the C1Thesaurus.

Enumerations

Enumeration | Description
AutomaticDialogEnum | Enumerates the possible languages to be used when the synonym box is displayed.
ErrorTypeEnum | Enumerates the possible types of errors that can occur when the ThesError event is fired.
LanguageEnum | Language of the MainThesFile dictionary.
ProblemEnum | Enumerates the problem that occurs when the word being checked is not found in the MainThesFile file when NotFound event was fired.

See Also

C1.Win.C1Thesaurus.2 Assembly

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


AutomaticDialogEnum Enumeration

AutomaticDialogEnum Enumeration

Enumerates the possible languages to be used when the synonym box is displayed.

[Visual Basic]

Public Enum AutomaticDialogEnum

[C#]

public enum AutomaticDialogEnum

[Delphi]

type AutomaticDialogEnum = (EnglishDialog, FrenchDialog, GermanDialog, NoDialog, SpanishDialog);

Namespace: C1.Win.C1Thesaurus

Assembly: C1.Win.C1Thesaurus.2 (in C1.Win.C1Thesaurus.2.dll)

Remarks

Use the members of this enumeration to set the value of the AutomaticDialog property.

Members

Member name | Description
EnglishDialog | The English synonym dialog will be displayed.
FrenchDialog | The French synonym dialog will be displayed.
GermanDialog | The German synonym dialog will be displayed.
NoDialog | No synonym dialog will be displayed by the C1Thesaurus component. The calling application may choose to display its own custom dialog.
SpanishDialog | The Spanish synonym dialog will be displayed.

See Also

C1.Win.C1Thesaurus Namespace

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Thesaurus.BadWordEventHandler Delegate

C1.Win.C1Thesaurus.BadWordEventHandler Delegate

Represents the method that will handle the NotFound event of C1Thesaurus.

[Visual Basic]

Public Delegate Sub BadWordEventHandler( _

ByVal sender As Object, _

ByVal e As NotFoundEventArgs _

)

[C#]

public delegate void BadWordEventHandler(

object sender,

NotFoundEventArgs e

);

[Delphi]

type BadWordEventHandler = procedure (

sender: Object;

e: NotFoundEventArgs

) of object;

Namespace: C1.Win.C1Thesaurus

Assembly: C1.Win.C1Thesaurus.2 (in C1.Win.C1Thesaurus.2.dll)

See Also

C1.Win.C1Thesaurus Namespace

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Thesaurus Class

C1Thesaurus Class

Represents the C1Thesaurus control.

For a list of all members of this type, see C1Thesaurus Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

C1.Win.C1Thesaurus.C1Thesaurus

[Visual Basic]

Public Class C1Thesaurus

Inherits Component

Implements t

[C#]

public class C1Thesaurus : Component , t

[Delphi]

type C1Thesaurus = class (Component, t);

Namespace: C1.Win.C1Thesaurus

Assembly: C1.Win.C1Thesaurus.2 (in C1.Win.C1Thesaurus.2.dll)

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Thesaurus Members

C1Thesaurus Members

C1Thesaurus overview

Public Constructors

C1Thesaurus Constructor

Creates new C1Thesaurus instance.

Public Properties

AutomaticDialog | Gets or sets the AutomaticDialogEnum object that indicates whether the synonym dialog box will be used and the language that should be used to display it.
ChangedWord | Returns the synonym chosen as a replacement for the CheckWord method following a thesaurus check.
DialogProp | Returns the DialogProperty object that represents the title, font and location of the synonym dialog box.
HelpBtnVisible | Sets or returns if the Help button is visible on the synonym dialog box.
LastThesError | Returns the last error code that occurred in the C1Thesaurus control.
MainThesFile | Gets or sets the fully qualified filename of the main thesaurus file.
OptionBtnCaption | Sets or returns the caption of the Option button on the synonym dialog box.
OptionBtnVisible | Sets or returns if the Option button is visible on the synonym dialog box.
Synonyms | Returns the synonym collection found for the word.
ThesaurusLanguage | Returns the language of the MainThesFile.
ThesaurusVersion | Returns the version of the MainThesFile.

Public Methods

CheckWord

Sets a word to be looked up in the thesaurus.

Public Events

Changed | Fired to indicate that the user pressed the Replace button on the synonym dialog box.
Complete | Fired after the thesaurus check is performed.
HelpBtnClick | Fired when the Help button on the synonym dialog box is clicked.
NotFound | Fired when the word being checked is not found in the main thesaurus file.
OptionBtnClick | Fired when the Options button on the synonym dialog box is clicked.
Suggestion | Fired after each synonym is added to the Synonym collection.
ThesError | Fired when an error occurs.

Protected Methods

Dispose

Overloaded. Overriden. Clean up any resources being used.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Thesaurus Constructor

C1Thesaurus Constructor

Creates new C1Thesaurus instance.

[Visual Basic]

Public Function New()

[C#]

public C1Thesaurus()

[Delphi]

public constructor Create();

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Thesaurus Properties

C1Thesaurus Properties

The properties of the C1Thesaurus class are listed here. For a complete list of C1Thesaurus class members, see the C1Thesaurus Members topic.

Public Properties

AutomaticDialog | Gets or sets the AutomaticDialogEnum object that indicates whether the synonym dialog box will be used and the language that should be used to display it.
ChangedWord | Returns the synonym chosen as a replacement for the CheckWord method following a thesaurus check.
DialogProp | Returns the DialogProperty object that represents the title, font and location of the synonym dialog box.
HelpBtnVisible | Sets or returns if the Help button is visible on the synonym dialog box.
LastThesError | Returns the last error code that occurred in the C1Thesaurus control.
MainThesFile | Gets or sets the fully qualified filename of the main thesaurus file.
OptionBtnCaption | Sets or returns the caption of the Option button on the synonym dialog box.
OptionBtnVisible | Sets or returns if the Option button is visible on the synonym dialog box.
Synonyms | Returns the synonym collection found for the word.
ThesaurusLanguage | Returns the language of the MainThesFile.
ThesaurusVersion | Returns the version of the MainThesFile.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Thesaurus.AutomaticDialog Property

C1Thesaurus.AutomaticDialog Property

Gets or sets the AutomaticDialogEnum object that indicates whether the synonym dialog box will be used and the language that should be used to display it.

[Visual Basic]

Public Property AutomaticDialog As AutomaticDialogEnum

[C#]

public AutomaticDialogEnum AutomaticDialog {get;set;}

[Delphi]

public property AutomaticDialog: AutomaticDialogEnum read get_AutomaticDialog write set_AutomaticDialog;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Thesaurus.ChangedWord Property

C1Thesaurus.ChangedWord Property

Returns the synonym chosen as a replacement for the CheckWord method following a thesaurus check.

[Visual Basic]

Public ReadOnly Property ChangedWord As String

[C#]

public string ChangedWord {get;}

[Delphi]

public property ChangedWord: String read get_ChangedWord;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Thesaurus.DialogProp Property

C1Thesaurus.DialogProp Property

Returns the DialogProperty object that represents the title, font and location of the synonym dialog box.

[Visual Basic]

Public ReadOnly Property DialogProp As DialogProperty

[C#]

public DialogProperty DialogProp {get;}

[Delphi]

public property DialogProp: DialogProperty read get_DialogProp;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Thesaurus.HelpBtnVisible Property

C1Thesaurus.HelpBtnVisible Property

Sets or returns if the Help button is visible on the synonym dialog box.

[Visual Basic]

Public Property HelpBtnVisible As Boolean

[C#]

public bool HelpBtnVisible {get;set;}

[Delphi]

public property HelpBtnVisible: Boolean read get_HelpBtnVisible write set_HelpBtnVisible;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Thesaurus.LastThesError Property

C1Thesaurus.LastThesError Property

Returns the last error code that occurred in the C1Thesaurus control.

[Visual Basic]

Public ReadOnly Property LastThesError As ErrorTypeEnum

[C#]

public ErrorTypeEnum LastThesError {get;}

[Delphi]

public property LastThesError: ErrorTypeEnum read get_LastThesError;

Remarks

See also the ThesError event.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Thesaurus.MainThesFile Property

C1Thesaurus.MainThesFile Property

Gets or sets the fully qualified filename of the main thesaurus file.

[Visual Basic]

Public Property MainThesFile As String

[C#]

public string MainThesFile {get;set;}

[Delphi]

public property MainThesFile: String read get_MainThesFile write set_MainThesFile;

Remarks

Use the LastThesError property and the ThesError event to find out the occurred errors.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Thesaurus.OptionBtnCaption Property

C1Thesaurus.OptionBtnCaption Property

Sets or returns the caption of the Option button on the synonym dialog box.

[Visual Basic]

Public Property OptionBtnCaption As String

[C#]

public string OptionBtnCaption {get;set;}

[Delphi]

public property OptionBtnCaption: String read get_OptionBtnCaption write set_OptionBtnCaption;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Thesaurus.OptionBtnVisible Property

C1Thesaurus.OptionBtnVisible Property

Sets or returns if the Option button is visible on the synonym dialog box.

[Visual Basic]

Public Property OptionBtnVisible As Boolean

[C#]

public bool OptionBtnVisible {get;set;}

[Delphi]

public property OptionBtnVisible: Boolean read get_OptionBtnVisible write set_OptionBtnVisible;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Thesaurus.Synonyms Property

C1Thesaurus.Synonyms Property

Returns the synonym collection found for the word.

[Visual Basic]

Public ReadOnly Property Synonyms As StringCollection

[C#]

public StringCollection Synonyms {get;}

[Delphi]

public property Synonyms: StringCollection read get_Synonyms;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Thesaurus.ThesaurusLanguage Property

C1Thesaurus.ThesaurusLanguage Property

Returns the language of the MainThesFile.

[Visual Basic]

Public ReadOnly Property ThesaurusLanguage As LanguageEnum

[C#]

public LanguageEnum ThesaurusLanguage {get;}

[Delphi]

public property ThesaurusLanguage: LanguageEnum read get_ThesaurusLanguage;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Thesaurus.ThesaurusVersion Property

C1Thesaurus.ThesaurusVersion Property

Returns the version of the MainThesFile.

[Visual Basic]

Public ReadOnly Property ThesaurusVersion As Integer

[C#]

public int ThesaurusVersion {get;}

[Delphi]

public property ThesaurusVersion: Int32 read get_ThesaurusVersion;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Thesaurus Methods

C1Thesaurus Methods

The methods of the C1Thesaurus class are listed here. For a complete list of C1Thesaurus class members, see the C1Thesaurus Members topic.

Public Methods

CheckWord

Sets a word to be looked up in the thesaurus.

Protected Methods

Dispose

Overloaded. Overriden. Clean up any resources being used.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Thesaurus.CheckWord Method

C1Thesaurus.CheckWord Method

Sets a word to be looked up in the thesaurus.

[Visual Basic]

Public Function CheckWord( _

ByVal word As String _

) As String

[C#]

public string CheckWord(

string word

);

[Delphi]

public function CheckWord(

word: String

): String;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Thesaurus.Dispose Method

C1Thesaurus.Dispose Method

Clean up any resources being used.

[Visual Basic]

Overrides Protected Sub Dispose( _

ByVal disposing As Boolean _

)

[C#]

override protected void Dispose(

bool disposing

);

[Delphi]

strict protected procedure Dispose(

disposing: Boolean

); overload; override;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Thesaurus Events

C1Thesaurus Events

The events of the C1Thesaurus class are listed here. For a complete list of C1Thesaurus class members, see the C1Thesaurus Members topic.

Public Events

Changed | Fired to indicate that the user pressed the Replace button on the synonym dialog box.
Complete | Fired after the thesaurus check is performed.
HelpBtnClick | Fired when the Help button on the synonym dialog box is clicked.
NotFound | Fired when the word being checked is not found in the main thesaurus file.
OptionBtnClick | Fired when the Options button on the synonym dialog box is clicked.
Suggestion | Fired after each synonym is added to the Synonym collection.
ThesError | Fired when an error occurs.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Thesaurus.Changed Event

C1Thesaurus.Changed Event

Fired to indicate that the user pressed the Replace button on the synonym dialog box.

[Visual Basic]

Public Event Changed As EventHandler

[C#]

public event EventHandler Changed

[Delphi]

public property Changed: EventHandler read remove_Changed write add_Changed;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Thesaurus.Complete Event

C1Thesaurus.Complete Event

Fired after the thesaurus check is performed.

[Visual Basic]

Public Event Complete As CompleteEventHandler

[C#]

public event CompleteEventHandler Complete

[Delphi]

public property Complete: CompleteEventHandler read remove_Complete write add_Complete;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Thesaurus.HelpBtnClick Event

C1Thesaurus.HelpBtnClick Event

Fired when the Help button on the synonym dialog box is clicked.

[Visual Basic]

Public Event HelpBtnClick As EventHandler

[C#]

public event EventHandler HelpBtnClick

[Delphi]

public property HelpBtnClick: EventHandler read remove_HelpBtnClick write add_HelpBtnClick;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Thesaurus.NotFound Event

C1Thesaurus.NotFound Event

Fired when the word being checked is not found in the main thesaurus file.

[Visual Basic]

Public Event NotFound As BadWordEventHandler

[C#]

public event BadWordEventHandler NotFound

[Delphi]

public property NotFound: BadWordEventHandler read remove_NotFound write add_NotFound;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Thesaurus.OptionBtnClick Event

C1Thesaurus.OptionBtnClick Event

Fired when the Options button on the synonym dialog box is clicked.

[Visual Basic]

Public Event OptionBtnClick As EventHandler

[C#]

public event EventHandler OptionBtnClick

[Delphi]

public property OptionBtnClick: EventHandler read remove_OptionBtnClick write add_OptionBtnClick;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Thesaurus.Suggestion Event

C1Thesaurus.Suggestion Event

Fired after each synonym is added to the Synonym collection.

[Visual Basic]

Public Event Suggestion As SuggestionEventHandler

[C#]

public event SuggestionEventHandler Suggestion

[Delphi]

public property Suggestion: SuggestionEventHandler read remove_Suggestion write add_Suggestion;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1Thesaurus.ThesError Event

C1Thesaurus.ThesError Event

Fired when an error occurs.

[Visual Basic]

Public Event ThesError As ThesErrorEventHandler

[C#]

public event ThesErrorEventHandler ThesError

[Delphi]

public property ThesError: ThesErrorEventHandler read remove_ThesError write add_ThesError;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Thesaurus.CompleteEventArgs Class

C1.Win.C1Thesaurus.CompleteEventArgs Class

Provides data for the Complete event of the C1Thesaurus.

For a list of all members of this type, see CompleteEventArgs Members.

System.Object

System.EventArgs

C1.Win.C1Thesaurus.CompleteEventArgs

[Visual Basic]

Public Class CompleteEventArgs

Inherits EventArgs

[C#]

public class CompleteEventArgs : EventArgs

[Delphi]

type CompleteEventArgs = class (EventArgs);

Namespace: C1.Win.C1Thesaurus

Assembly: C1.Win.C1Thesaurus.2 (in C1.Win.C1Thesaurus.2.dll)

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Thesaurus.CompleteEventArgs Members

C1.Win.C1Thesaurus.CompleteEventArgs Members

CompleteEventArgs overview

Public Constructors

C1.Win.C1Thesaurus.CompleteEventArgs Constructor

Initializes a new instance of the CompleteEventArgs with the default values.

Public Properties

Cancelled

Gets or sets the value that indicates how the thesaurus check ended. It is set to False if the process ended normally, or True if the process was aborted by the user.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Thesaurus.CompleteEventArgs Constructor

C1.Win.C1Thesaurus.CompleteEventArgs Constructor

Initializes a new instance of the CompleteEventArgs with the default values.

[Visual Basic]

Public Function New()

[C#]

public CompleteEventArgs()

[Delphi]

public constructor Create(); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Thesaurus.CompleteEventArgs Properties

C1.Win.C1Thesaurus.CompleteEventArgs Properties

The properties of the CompleteEventArgs class are listed here. For a complete list of CompleteEventArgs class members, see the C1.Win.C1Thesaurus.CompleteEventArgs Members topic.

Public Properties

Cancelled

Gets or sets the value that indicates how the thesaurus check ended. It is set to False if the process ended normally, or True if the process was aborted by the user.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Thesaurus.CompleteEventArgs.Cancelled Property

C1.Win.C1Thesaurus.CompleteEventArgs.Cancelled Property

Gets or sets the value that indicates how the thesaurus check ended. It is set to False if the process ended normally, or True if the process was aborted by the user.

[Visual Basic]

Public Property Cancelled As Boolean

[C#]

public bool Cancelled {get;set;}

[Delphi]

public property Cancelled: Boolean read get_Cancelled write set_Cancelled;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Thesaurus.CompleteEventHandler Delegate

C1.Win.C1Thesaurus.CompleteEventHandler Delegate

Represents the method that will handle the Complete event of the C1Thesaurus.

[Visual Basic]

Public Delegate Sub CompleteEventHandler( _

ByVal sender As Object, _

ByVal e As CompleteEventArgs _

)

[C#]

public delegate void CompleteEventHandler(

object sender,

CompleteEventArgs e

);

[Delphi]

type CompleteEventHandler = procedure (

sender: Object;

e: CompleteEventArgs

) of object;

Namespace: C1.Win.C1Thesaurus

Assembly: C1.Win.C1Thesaurus.2 (in C1.Win.C1Thesaurus.2.dll)

See Also

C1.Win.C1Thesaurus Namespace

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Thesaurus.ErrorTypeEnum Enumeration

C1.Win.C1Thesaurus.ErrorTypeEnum Enumeration

Enumerates the possible types of errors that can occur when the ThesError event is fired.

[Visual Basic]

Public Enum C1.Win.C1Thesaurus.ErrorTypeEnum

[C#]

public enum C1.Win.C1Thesaurus.ErrorTypeEnum

[Delphi]

type C1.Win.C1Thesaurus.ErrorTypeEnum = (CanNotFindFile, CanNotOpenFile, InvalidFile, NoErrors, WrongFileVersion);

Namespace: C1.Win.C1Thesaurus

Assembly: C1.Win.C1Thesaurus.2 (in C1.Win.C1Thesaurus.2.dll)

Members

Member name | Description
CanNotFindFile | Cannot find the main Thesaurus file.
CanNotOpenFile | Cannot open the main Thesaurus file.
InvalidFile | The main Thesaurus file is an invalid file.
NoErrors | No Error occurred.
WrongFileVersion | The MainThesFile file has a wrong file version.

See Also

C1.Win.C1Thesaurus Namespace

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Thesaurus.LanguageEnum Enumeration

C1.Win.C1Thesaurus.LanguageEnum Enumeration

Language of the MainThesFile dictionary.

[Visual Basic]

Public Enum C1.Win.C1Thesaurus.LanguageEnum

[C#]

public enum C1.Win.C1Thesaurus.LanguageEnum

[Delphi]

type C1.Win.C1Thesaurus.LanguageEnum = (LangDutch, LangEnglish, LangFrench, LangGerman, LangIceland, LangItalian, LangNorway, LangSpanish, LangSwedish);

Namespace: C1.Win.C1Thesaurus

Assembly: C1.Win.C1Thesaurus.2 (in C1.Win.C1Thesaurus.2.dll)

Members

Member name | Description
LangDutch | Dictionary was created in Dutch.
LangEnglish | Dictionary was created in English.
LangFrench | Dictionary was created in French.
LangGerman | Dictionary was created in German.
LangIceland | Dictionary was created in Iceland.
LangItalian | Dictionary was created in Italian.
LangNorway | Dictionary was created in Norway.
LangSpanish | Dictionary was created in Spanish.
LangSwedish | Dictionary was created in Swedish.

See Also

C1.Win.C1Thesaurus Namespace

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


NotFoundEventArgs Class

NotFoundEventArgs Class

Provides data for the NotFound event of C1Thesaurus.

For a list of all members of this type, see NotFoundEventArgs Members.

System.Object

System.EventArgs

C1.Win.C1Thesaurus.NotFoundEventArgs

[Visual Basic]

Public Class NotFoundEventArgs

Inherits EventArgs

[C#]

public class NotFoundEventArgs : EventArgs

[Delphi]

type NotFoundEventArgs = class (EventArgs);

Namespace: C1.Win.C1Thesaurus

Assembly: C1.Win.C1Thesaurus.2 (in C1.Win.C1Thesaurus.2.dll)

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


NotFoundEventArgs Members

NotFoundEventArgs Members

NotFoundEventArgs overview

Public Constructors

NotFoundEventArgs Constructor

Initializes a new instance of the NotFoundEventArgs with the default values.

Public Properties

Problem

Gets or sets the ProblemEnum object that represents problem.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


NotFoundEventArgs Constructor

NotFoundEventArgs Constructor

Overload List

Initializes a new instance of the NotFoundEventArgs with the default values.

[Visual Basic] Public Function New()

[C#] public NotFoundEventArgs();

[Delphi] public constructor Create(); overload;

Initializes a new instance of NotFoundEventArgs with the predefined values.

[Visual Basic] Public Function New(ProblemEnum)

[C#] public NotFoundEventArgs(ProblemEnum);

[Delphi] public constructor Create(ProblemEnum); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


NotFoundEventArgs Constructor ()

NotFoundEventArgs Constructor ()

Previous Next

Initializes a new instance of the NotFoundEventArgs with the default values.

[Visual Basic]

Public Function New()

[C#]

public NotFoundEventArgs()

[Delphi]

public constructor Create(); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


NotFoundEventArgs Constructor (ProblemEnum)

NotFoundEventArgs Constructor (ProblemEnum)

Previous Next

Initializes a new instance of NotFoundEventArgs with the predefined values.

[Visual Basic]

Public Function New( _

ByVal problem As ProblemEnum _

)

[C#]

public NotFoundEventArgs(

ProblemEnum problem

);

[Delphi]

public constructor Create(

problem: ProblemEnum

); overload;

Parameters

problem

The ProblemEnum object that represents the problem.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


NotFoundEventArgs Properties

NotFoundEventArgs Properties

The properties of the NotFoundEventArgs class are listed here. For a complete list of NotFoundEventArgs class members, see the NotFoundEventArgs Members topic.

Public Properties

Problem

Gets or sets the ProblemEnum object that represents problem.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


NotFoundEventArgs.Problem Property

NotFoundEventArgs.Problem Property

Gets or sets the ProblemEnum object that represents problem.

[Visual Basic]

Public Property Problem As ProblemEnum

[C#]

public ProblemEnum Problem {get;set;}

[Delphi]

public property Problem: ProblemEnum read get_Problem write set_Problem;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


ProblemEnum Enumeration

ProblemEnum Enumeration

Enumerates the problem that occurs when the word being checked is not found in the MainThesFile file when NotFound event was fired.

[Visual Basic]

Public Enum ProblemEnum

[C#]

public enum ProblemEnum

[Delphi]

type ProblemEnum = (NotInThes);

Namespace: C1.Win.C1Thesaurus

Assembly: C1.Win.C1Thesaurus.2 (in C1.Win.C1Thesaurus.2.dll)

Members

Member name | Description
NotInThes | Indicates the problem that caused the word to be bad.

See Also

C1.Win.C1Thesaurus Namespace

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Thesaurus.SuggestionEventArgs Class

C1.Win.C1Thesaurus.SuggestionEventArgs Class

Provides data for the Suggestion event of the C1Thesaurus.

For a list of all members of this type, see SuggestionEventArgs Members.

System.Object

System.EventArgs

C1.Win.C1Thesaurus.SuggestionEventArgs

[Visual Basic]

Public Class SuggestionEventArgs

Inherits EventArgs

[C#]

public class SuggestionEventArgs : EventArgs

[Delphi]

type SuggestionEventArgs = class (EventArgs);

Namespace: C1.Win.C1Thesaurus

Assembly: C1.Win.C1Thesaurus.2 (in C1.Win.C1Thesaurus.2.dll)

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Thesaurus.SuggestionEventArgs Members

C1.Win.C1Thesaurus.SuggestionEventArgs Members

SuggestionEventArgs overview

Public Constructors

C1.Win.C1Thesaurus.SuggestionEventArgs Constructor

Initializes a new instance of the SuggestionEventArgs with the default values.

Public Properties

Cancel | Set this property to True to stop suggesting synonyms.
Index | Gets or sets the value that indicates the index of the suggested synonym.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Thesaurus.SuggestionEventArgs Constructor

C1.Win.C1Thesaurus.SuggestionEventArgs Constructor

Initializes a new instance of the SuggestionEventArgs with the default values.

[Visual Basic]

Public Function New()

[C#]

public SuggestionEventArgs()

[Delphi]

public constructor Create(); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Thesaurus.SuggestionEventArgs Properties

C1.Win.C1Thesaurus.SuggestionEventArgs Properties

The properties of the SuggestionEventArgs class are listed here. For a complete list of SuggestionEventArgs class members, see the C1.Win.C1Thesaurus.SuggestionEventArgs Members topic.

Public Properties

Cancel | Set this property to True to stop suggesting synonyms.
Index | Gets or sets the value that indicates the index of the suggested synonym.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Thesaurus.SuggestionEventArgs.Cancel Property

C1.Win.C1Thesaurus.SuggestionEventArgs.Cancel Property

Set this property to True to stop suggesting synonyms.

[Visual Basic]

Public Property Cancel As Boolean

[C#]

public bool Cancel {get;set;}

[Delphi]

public property Cancel: Boolean read get_Cancel write set_Cancel;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Thesaurus.SuggestionEventArgs.Index Property

C1.Win.C1Thesaurus.SuggestionEventArgs.Index Property

Gets or sets the value that indicates the index of the suggested synonym.

[Visual Basic]

Public Property Index As Integer

[C#]

public int Index {get;set;}

[Delphi]

public property Index: Int32 read get_Index write set_Index;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Thesaurus.SuggestionEventHandler Delegate

C1.Win.C1Thesaurus.SuggestionEventHandler Delegate

Represents the method that will handle the Suggestion event of the C1Thesaurus.

[Visual Basic]

Public Delegate Sub SuggestionEventHandler( _

ByVal sender As Object, _

ByVal e As SuggestionEventArgs _

)

[C#]

public delegate void SuggestionEventHandler(

object sender,

SuggestionEventArgs e

);

[Delphi]

type SuggestionEventHandler = procedure (

sender: Object;

e: SuggestionEventArgs

) of object;

Namespace: C1.Win.C1Thesaurus

Assembly: C1.Win.C1Thesaurus.2 (in C1.Win.C1Thesaurus.2.dll)

See Also

C1.Win.C1Thesaurus Namespace

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


ThesErrorEventArgs Class

ThesErrorEventArgs Class

Provides data for the ThesError event of the C1Thesaurus.

For a list of all members of this type, see ThesErrorEventArgs Members.

System.Object

System.EventArgs

C1.Win.C1Thesaurus.ThesErrorEventArgs

[Visual Basic]

Public Class ThesErrorEventArgs

Inherits EventArgs

[C#]

public class ThesErrorEventArgs : EventArgs

[Delphi]

type ThesErrorEventArgs = class (EventArgs);

Namespace: C1.Win.C1Thesaurus

Assembly: C1.Win.C1Thesaurus.2 (in C1.Win.C1Thesaurus.2.dll)

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


ThesErrorEventArgs Members

ThesErrorEventArgs Members

ThesErrorEventArgs overview

Public Constructors

ThesErrorEventArgs Constructor

Initializes a new instance of the ThesErrorEventArgs with the default values.

Public Properties

ErrorDesc | Gets or sets the description of the error.
ErrorType | Gets or sets the ErrorTypeEnum object that represents the error type.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


ThesErrorEventArgs Constructor

ThesErrorEventArgs Constructor

Overload List

Initializes a new instance of the ThesErrorEventArgs with the default values.

[Visual Basic] Public Function New()

[C#] public ThesErrorEventArgs();

[Delphi] public constructor Create(); overload;

Initializes a new instance of the ThesErrorEventArgs with the predefined values.

[Visual Basic] Public Function New(ErrorTypeEnum, String)

[C#] public ThesErrorEventArgs(ErrorTypeEnum, string);

[Delphi] public constructor Create(ErrorTypeEnum; String); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


ThesErrorEventArgs Constructor ()

ThesErrorEventArgs Constructor ()

Previous Next

Initializes a new instance of the ThesErrorEventArgs with the default values.

[Visual Basic]

Public Function New()

[C#]

public ThesErrorEventArgs()

[Delphi]

public constructor Create(); overload;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


ThesErrorEventArgs Constructor (ErrorTypeEnum, String)

ThesErrorEventArgs Constructor (ErrorTypeEnum, String)

Previous Next

Initializes a new instance of the ThesErrorEventArgs with the predefined values.

[Visual Basic]

Public Function New( _

ByVal errorType As ErrorTypeEnum, _

ByVal errorDesc As String _

)

[C#]

public ThesErrorEventArgs(

ErrorTypeEnum errorType,

string errorDesc

);

[Delphi]

public constructor Create(

errorType: ErrorTypeEnum;

errorDesc: String

); overload;

Parameters

errorType

The ErrorTypeEnum object that represents the error type.

errorDesc

Gives the description of the error.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


ThesErrorEventArgs Properties

ThesErrorEventArgs Properties

The properties of the ThesErrorEventArgs class are listed here. For a complete list of ThesErrorEventArgs class members, see the ThesErrorEventArgs Members topic.

Public Properties

ErrorDesc | Gets or sets the description of the error.
ErrorType | Gets or sets the ErrorTypeEnum object that represents the error type.

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


ThesErrorEventArgs.ErrorDesc Property

ThesErrorEventArgs.ErrorDesc Property

Gets or sets the description of the error.

[Visual Basic]

Public Property ErrorDesc As String

[C#]

public string ErrorDesc {get;set;}

[Delphi]

public property ErrorDesc: String read get_ErrorDesc write set_ErrorDesc;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


ThesErrorEventArgs.ErrorType Property

ThesErrorEventArgs.ErrorType Property

Gets or sets the ErrorTypeEnum object that represents the error type.

[Visual Basic]

Public Property ErrorType As ErrorTypeEnum

[C#]

public ErrorTypeEnum ErrorType {get;set;}

[Delphi]

public property ErrorType: ErrorTypeEnum read get_ErrorType write set_ErrorType;

See Also

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


ThesErrorEventHandler Delegate

ThesErrorEventHandler Delegate

Represents the method that will handle the ThesError event of the C1Thesaurus.

[Visual Basic]

Public Delegate Sub ThesErrorEventHandler( _

ByVal sender As Object, _

ByVal e As ThesErrorEventArgs _

)

[C#]

public delegate void ThesErrorEventHandler(

object sender,

ThesErrorEventArgs e

);

[Delphi]

type ThesErrorEventHandler = procedure (

sender: Object;

e: ThesErrorEventArgs

) of object;

Namespace: C1.Win.C1Thesaurus

Assembly: C1.Win.C1Thesaurus.2 (in C1.Win.C1Thesaurus.2.dll)

See Also

C1.Win.C1Thesaurus Namespace

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


AddToCustomFile Method - C#

C#

bool bRes;

bRes = C1Spell1.AddToCustomFile("YYY");


AddToCustomFile Method - Delphi

Delphi

var

bRes: Boolean;

begin

bRes := C1Spell1.AddToCustomFile('YYY');


AddToCustomFile Method - Visual Basic

Visual Basic

Dim bRes As Boolean

bRes = C1Spell1.AddToCustomFile("YYY")


C1.Win.C1Spell Hierarchy

C1.Win.C1Spell Hierarchy

System.Object

System.EventArgs

C1.Win.C1Spell.BadWordEventArgs

C1.Win.C1Spell.CheckingEventArgs

C1.Win.C1Spell.CheckStartEventArgs

C1.Win.C1Spell.CompleteEventArgs

C1.Win.C1Spell.DialogActionEventArgs

C1.Win.C1Spell.SpellErrorEventArgs

C1.Win.C1Spell.SuggestionEventArgs

C1.Win.C1Spell.TypingErrorEventArgs

C1.Win.C1Spell.TypingOKEventArgs

C1.Win.C1Spell.UIStringsItemEventArgs

System.MarshalByRefObject

System.ComponentModel.Component

C1.Win.C1Spell.C1Spell ---- ah

C1.Win.C1Spell.CharPair

System.Collections.CollectionBase

C1.Win.C1Spell.CharPairCollection

C1.Win.C1Spell.CustomDictionaryCollection

C1.Win.C1Spell.StringPairCollection

C1.Win.C1Spell.DialogProperty

C1.Win.C1Spell.DictionaryItem

C1.Win.C1Spell.DlgSetting

C1.Win.C1Spell.StringPair

C1.Win.C1Spell.UIStrings

System.ValueType

System.[Enum]

C1.Win.C1Spell.BadWordDialogEnum

C1.Win.C1Spell.BadWordProblemEnum

C1.Win.C1Spell.CommonWordCacheEnum

C1.Win.C1Spell.DialogActionEnum

C1.Win.C1Spell.ErrorTypeEnum

C1.Win.C1Spell.LanguageEnum

C1.Win.C1Spell.TypingErrorActionEnum

C1.Win.C1Spell.UIStringsEnum

C1.Win.C1Spell.UnderlineStyleEnum

System.[Delegate]

System.MulticastDelegate

C1.Win.C1Spell.BadWordEventHandler

C1.Win.C1Spell.CheckingEventHandler

C1.Win.C1Spell.CheckStartEventHandler

C1.Win.C1Spell.CompleteEventHandler

C1.Win.C1Spell.DialogActionEventHandler

C1.Win.C1Spell.SpellErrorEventHandler

C1.Win.C1Spell.SuggestionEventHandler

C1.Win.C1Spell.TypingErrorEventHandler

C1.Win.C1Spell.TypingOKEventHandler

See Also

C1.Win.C1Spell Namespace

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


C1.Win.C1Thesaurus Hierarchy

C1.Win.C1Thesaurus Hierarchy

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

C1.Win.C1Thesaurus.C1Thesaurus ---- t

System.EventArgs

C1.Win.C1Thesaurus.CompleteEventArgs

C1.Win.C1Thesaurus.NotFoundEventArgs

C1.Win.C1Thesaurus.SuggestionEventArgs

C1.Win.C1Thesaurus.ThesErrorEventArgs

System.ValueType

System.[Enum]

C1.Win.C1Thesaurus.AutomaticDialogEnum

C1.Win.C1Thesaurus.ErrorTypeEnum

C1.Win.C1Thesaurus.LanguageEnum

C1.Win.C1Thesaurus.ProblemEnum

System.[Delegate]

System.MulticastDelegate

C1.Win.C1Thesaurus.BadWordEventHandler

C1.Win.C1Thesaurus.CompleteEventHandler

C1.Win.C1Thesaurus.SuggestionEventHandler

C1.Win.C1Thesaurus.ThesErrorEventHandler

See Also

C1.Win.C1Thesaurus Namespace

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


CaretPosX Property - C#

C#

Point pos;

int x, y;

x = C1Spell1.CaretPosX;

y = C1Spell1.CaretPosY;

pos = new Point(x, y);

pos = TextBox1.PointToClient(pos);

this.mPopup.Show(TextBox1, pos);


CaretPosX Property - Delphi

Delphi

var

pos: Point;

x, y: Integer;

begin

x := C1Spell1.CaretPosX;

y := C1Spell1.CaretPosY;

pos := Point.Create(x, y);

pos := TextBox1.PointToClient(pos);

Self.mPopup.Show(TextBox1, pos);

end;


CaretPosX Property - Visual Basic

Visual Basic

Dim pos As Point

Dim x, y

x = C1Spell1.CaretPosX

y = C1Spell1.CaretPosY

pos = New Point(x, y)

pos = TextBox1.PointToClient(pos)

Me.mPopup.Show(TextBox1, pos)


CheckControl Method - C#

C#

C1Spell1.CheckControl(TextBox1, C1.Win.C1Spell.BadWordDialogEnum.FrenchDialog);


CheckControl Method - Delphi

Delphi

C1Spell1.CheckControl(TextBox1, C1.Win.C1Spell.BadWordDialogEnum.FrenchDialog);


CheckControl Method - Visual Basic

Visual Basic

C1Spell1.CheckControl(TextBox1, C1.Win.C1Spell.BadWordDialogEnum.FrenchDialog)


CheckString Method ex. #1 - C#

C#

bool bRes;

bRes = C1Spell1.CheckString("tex");

if (bRes) {

MessageBox.Show("spelling is correct");

} else {

MessageBox.Show("bad spelling");

}


CheckString Method ex. #1 - Delphi

Delphi

var

bRes: Boolean;

begin

bRes := C1Spell1.CheckString('tex');

if (bRes) then

MessageBox.Show('spelling is correct')

else

MessageBox.Show('bad spelling');


CheckString Method ex. #1 - Visual Basic

Visual Basic

Dim bRes As Boolean

bRes = C1Spell1.CheckString("tex")

If (bRes) Then

MessageBox.Show("spelling is correct")

Else

MessageBox.Show("bad spelling")

End If

string CheckString(string str, BadWordDialogEnum dialog)


CheckString Method ex. #2 - C#

C#

string bRes;

bRes = C1Spell1.CheckString("Hello tex", C1.Win.C1Spell.BadWordDialogEnum.EnglishDialog);


CheckString Method ex. #2 - Delphi

Delphi

var

bRes: String;

begin

bRes := C1Spell1.CheckString('Hello tex');


CheckString Method ex. #2 - Visual Basic

Visual Basic

Dim bRes As String

bRes = C1Spell1.CheckString("Hello tex", C1.Win.C1Spell.BadWordDialogEnum.EnglishDialog)


CheckTyping Method - C#

C#

C1Spell1.CheckTyping(TextBox1, C1.Win.C1Spell.TypingErrorActionEnum.Beep);


CheckTyping Method - Delphi

Delphi

C1Spell1.CheckTyping(TextBox1, C1.Win.C1Spell.TypingErrorActionEnum.Beep);


CheckTyping Method - Visual Basic

Visual Basic

C1Spell1.CheckTyping(TextBox1, C1.Win.C1Spell.TypingErrorActionEnum.Beep)


CheckWord Method - C#

C#

private void Button1_Click( object sender, System.EventArgs e)

{

TextBox1.Text = this.C1Thesarusu1.CheckWord(TextBox1.Text);

}


CheckWord Method - Delphi

Delphi

procedure MainForm.Button1_Click(Sender: System.Object; e: System.EventArgs);

begin

TextBox1.Text := Self.C1Thesarusu1.CheckWord(TextBox1.Text);

end;


CheckWord Method - Visual Basic

Visual Basic

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click

TextBox1.Text = Me.C1Thesarusu1.CheckWord(TextBox1.Text)

End Sub


Complete Event (C1Spell) - C#

C#

if ( e.Cancelled )

MessageBox.Show("The spell checking is cancelled by user.");

else

MessageBox.Show("The spell checking is done.");


Complete Event (C1Spell) - Delphi

Delphi

if e.Cancelled then

MessageBox.Show('The spell checking is cancelled by user.')

Else

MessageBox.Show('The spell checking is done.');


Complete Event (C1Spell) - Visual Basic

Visual Basic

If e.Cancelled Then

MessageBox.Show("The spell checking is cancelled by user.")

Else

MessageBox.Show("The spell checking is done.")

End If


CustomDictFiles Property - C#

C#

C1Spell1.CustomDictFiles = new string[4];


CustomDictFiles Property - Delphi

Delphi

ReDim C1Spell1.CustomDictFiles(4);


CustomDictFiles Property - Visual Basic

Visual Basic

ReDim C1Spell1.CustomDictFiles(4)


DialogProp Property (C1Spell) - C#

C#

C1Spell1.DialogProp.Title = "Bad Word Display Dialog";

Font ft;

ft = C1Spell1.DialogProp.Font;

Point pt;


DialogProp Property (C1Spell) - Delphi

Delphi

var

ft: Font;

pt: Point;

begin

C1Spell1.DialogProp.Title := 'Bad Word Display Dialog';

ft := C1Spell1.DialogProp.Font;


DialogProp Property (C1Spell) - Visual Basic

Visual Basic

C1Spell1.DialogProp.Title = "Bad Word Display Dialog"

Dim ft As Font

ft = C1Spell1.DialogProp.Font

Dim pt As Point


DialogProp Property (C1Thesaurus) - C#

C#

Font ft;

Ft =c1Thesaurus1.DialogProp.Font;

Point pt;

Pt = c1Thesaurus1.DialogProp.Location;


DialogProp Property (C1Thesaurus) - Delphi

Delphi

var

ft: Font;

pt: Point;

begin

Ft := c1Thesaurus1.DialogProp.Font;

Pt := c1Thesaurus1.DialogProp.Location;


DialogProp Property (C1Thesaurus) - Visual Basic

Visual Basic

Dim ft As Font

Ft =c1Thesaurus1.DialogProp.Font

Dim pt As Point

Pt = c1Thesaurus1.DialogProp.Location


IgnoreAll Property - C#

C#

System.Collections.Specialized.StringCollection strCol;

strCol = C1Spell1.IgnoreAll;

int cnt = C1Spell1.IgnoreAll.Count;

string str = C1Spell.IgnoreAll[i];


IgnoreAll Property - Delphi

Delphi

var

strCol: System.Collections.Specialized.StringCollection;

begin

strCol := C1Spell1.IgnoreAll;

cnt := C1Spell1.IgnoreAll.Count;

str := C1Spell.IgnoreAll[i];


IgnoreAll Property - Visual Basic

Visual Basic

Dim strCol As System.Collections.Specialized.StringCollection

strCol = C1Spell1.IgnoreAll

cnt = C1Spell1.IgnoreAll.Count

str = C1Spell.IgnoreAll(i)


LastSpellError Property - C#

C#

if (C1Spell1.LastSpellError ==C1.Win.C1Spell.ErrorTypeEnum.CanNotFindMainDict)

return;


LastSpellError Property - Delphi

Delphi

if (C1Spell1.LastSpellError = C1.Win.C1Spell.ErrorTypeEnum.CanNotFindMainDict) then

exit;


LastSpellError Property - Visual Basic

Visual Basic

If (C1Spell1.LastSpellError =C1.Win.C1Spell.ErrorTypeEnum.CanNotFindMainDict) then

Exit Sub

End If


LastThesError Property - C#

C#

if ( C1Thesaurus1.LastThesError == C1.Win.C1Thesaurus.ErrorTypeEnum.CanNotFindFile ) return;


LastThesError Property - Delphi

Delphi

if C1Thesaurus1.LastThesError = C1.Win.C1Thesaurus.ErrorTypeEnum.CanNotFindFile then exit;


LastThesError Property - Visual Basic

Visual Basic

If C1Thesaurus1.LastThesError = C1.Win.C1Thesaurus.ErrorTypeEnum.CanNotFindFile Then Exit Sub

End If


Namespaces Example 1 - C#

C#

C1.Win.C1Spell.C1Spell spell;


Namespaces Example 1 - Delphi

Delphi

Spell: C1.Win.C1Spell.C1Spell;


Namespaces Example 1 - Visual Basic

Visual Basic

Dim spell As C1.Win.C1Spell.C1Spell


Namespaces Example 2 - C#

C#

// Define a new object based on your C1Spell class.

C1Spell MyC1Spell;

// Define a new C1Spell.C1Spell object.

C1.Win.C1Spell.C1Spell Spell;


Namespaces Example 2 - Delphi

Delphi

// Define a new object based on your C1Spell class.

MyC1Spell = class(C1Spell);

// Define a new C1Spell.C1Spell object.

Spell: C1.Win.C1Spell.C1Spell;


Namespaces Example 2 - Visual Basic

Visual Basic

' Define a new object based on your C1Spell class.

Dim MyC1Spell as C1Spell

' Define a new C1Spell.C1Spell object.

Dim Spell as C1.Win.C1Spell.C1Spell


Namespaces Example 3 - C#

C#

using C1Spell = C1.Win.C1Spell.C1Spell;

using MyC1Spell = MyProject.Objects.C1Spell;

C1Spell c1;

MyC1Spell c2;


Namespaces Example 3 - Delphi

Delphi

uses C1.Win.C1Spell.C1Spell, MyProject.Objects.C1Spell;

c1: C1Spell;

c2: MyC1Spell;


Namespaces Example 3 - Visual Basic

Visual Basic

Imports C1Spell = C1.Win.C1Spell.C1Spell

Imports MyC1Spell = MyProject.Objects.C1Spell

Dim c1 As C1Spell

Dim c2 As MyC1Spell


PartialClear Method ex. #1 - C#

C#

C1Spell1.CheckControl(this.textBox1);


PartialClear Method ex. #1 - Delphi

Delphi

C1Spell1.CheckControl(Self.textBox1);


PartialClear Method ex. #1 - Visual Basic

Visual Basic

C1Spell1.CheckControl(me.textBox1)


PartialClear Method ex. #2 - C#

C#

C1Spell1.Clear();

C1Spell1.CheckTyping(this.textBox1);


PartialClear Method ex. #2 - Delphi

Delphi

C1Spell1.Clear;

C1Spell1.CheckTyping(Self.textBox1);


PartialClear Method ex. #2 - Visual Basic

Visual Basic

C1Spell1.Clear()

C1Spell1.CheckTyping(me.textBox1)


PartialClear Method ex. #3 - C#

C#

C1Spell1.PartialClear();


PartialClear Method ex. #3 - Delphi

Delphi

C1Spell1.PartialClear;


PartialClear Method ex. #3 - Visual Basic

Visual Basic

C1Spell1.PartialClear()


Reference TypingError - C#

C#

private void c1Spell1_TypingError(object sender, C1.Win.C1Spell.TypingErrorEventArgs e)

{

//show red light to indicate an error was detected

this.panel1.BackColor = Color.Red;

}


Reference TypingError - Delphi

Delphi

Procedure c1Spell1_TypingError(sender: System.Object; e: C1.Win.C1Spell.TypingErrorEventArgs);

begin

//show red light to indicate an error was detected

Self.panel1.BackColor := Color.Red;

end;


Reference TypingError - VB

Visual Basic

Private Sub C1Spell1_TypingError(ByVal sender As Object, ByVal e As C1.Win.C1Spell.TypingErrorEventArgs) Handles C1Spell1.TypingError

'show red light to indicate an error was detected

Panel1.BackColor = Color.Red

End Sub


Reference TypingOK - C#

C#

private void c1Spell1_TypingOK(object sender, C1.Win.C1Spell.TypingOKEventArgs e)

{

//typed something right? Use green color.

pictureBox1.BackColor = Color.Green;

}


Reference TypingOK - Delphi

Delphi

Procedure c1Spell1_TypingOK(sender: System.Object; e: C1.Win.C1Spell.TypingOKEventArgs);

begin

// typed something right? Use green color.

Self.panel1.BackColor := Color.Green;

end;


Reference TypingOK - VB

Visual Basic

Private Sub C1Spell1_TypingOK(ByVal sender As Object, ByVal e As C1.Win.C1Spell.TypingOKEventArgs) Handles C1Spell1.TypingOK

'typed something right? Use green color.

Panel1.BackColor = Color.Green

End Sub


Setting Thesaurus for .NET to Check a Selected Word - C#

C#

private void Command1_Click() {

TextBox1.SelectedText = this.C1Thesaurus1.CheckWord(TextBox1.SelectedText);

}


Setting Thesaurus for .NET to Check a Selected Word - Delphi

Delphi

procedure MainForm.Command1_Click();

begin

TextBox1.SelectedText := Self.C1Thesaurus1.CheckWord(TextBox1.SelectedText);

end;


Setting Thesaurus for .NET to Check a Selected Word - Visual Basic

Visual Basic

Private Sub Command1_Click()

TextBox1.SelectedText = Me.C1Thesaurus1.CheckWord(TextBox1.SelectedText)

End Sub


SkipInsideChars Method - C#

C#

C1Spell1.SkipInsideChars(’<’, ’>’) ;


SkipInsideChars Method - Delphi

Delphi

C1Spell1.SkipInsideChars('<', '>') ;


SkipInsideChars Method - Visual Basic

Visual Basic

C1Spell1.SkipInsideChars("<"c, ">"c)


Spell for .NET QuickStart Ex. 1 - C#

C#

Button1.Text = "Check Spelling";

TextBox1.Text = "";


Spell for .NET QuickStart Ex. 1 - Delphi

Delphi

Button1.Text := 'Check Spelling';

TextBox1.Text := '';


Spell for .NET QuickStart Ex. 1 - Visual Basic

Visual Basic

Button1.Text = "Check Spelling"

TextBox1.Text = ""


Spell for .NET QuickStart Ex. 2 - C#

C#

private void Button1_Click(System.object Sender,

System.EventArgs e)

{ C1Spell1.CheckControl(TextBox1)};


Spell for .NET QuickStart Ex. 2 - Delphi

Delphi

procedure MainForm.Button1_Click(Sender: System.Object;

e: System.EventArgs);

begin

C1Spell1.CheckControl(TextBox1);

end;


Spell for .NET QuickStart Ex. 2 - Visual Basic

Visual Basic

Private Sub Button1_Click(ByVal Sender As System.Object, ByVal

e As System.EventArgs) Handles Button1.Click

C1Spell1.CheckControl(TextBox1)

End Sub


Spell for .NET Tutorial; Step 2: Initialize the Form - C#

C#

private void Form1_Load( System.object sender, System.EventArgs e) {

//put some text in the large text window

TextBox4.Text = TextBox1.Text + (char)13 + (char)10 + TextBox2.Text + (char)13 + (char)10 + TextBox3.Text;

//select first item in the listbox

ListBox1.SetSelected(0, true);

TextBox5.Text = (string)ListBox1.SelectedItem;

}


Spell for .NET Tutorial; Step 2: Initialize the Form - Delphi

Delphi

procedure MainForm.Form1_Load(sender: System.Object; e: System.EventArgs);

begin

// put some text in the large text window

TextBox4.Text := TextBox1.Text + #13#10 + TextBox2.Text + #13#10 + TextBox3.Text;

// select first item in the listbox

ListBox1.SetSelected(0, True);

TextBox5.Text := ListBox1.SelectedItem;

end;


Spell for .NET Tutorial; Step 2: Initialize the Form - Visual Basic

Visual Basic

Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

'put some text in the large text window

TextBox4.Text = TextBox1.Text & vbCrLf & TextBox2.Text & vbCrLf & TextBox3.Text

'select first item in the listbox

ListBox1.SetSelected(0, True)

TextBox5.Text = ListBox1.SelectedItem

End Sub


Spell for .NET Tutorial; Step 3 ex. 1 - C#

C#

private void TextBox1_GotFocus(object sender, System.EventArgs e) {

C1Spell1.CheckTyping(TextBox1);

C1Spell1.IntegerTag = 1;

}


Spell for .NET Tutorial; Step 3 ex.1 - Delphi

Delphi

procedure MainForm.TextBox1_GotFocus(sender: System.Object;

e: System.EventArgs);

begin

TextBox1.GotFocus;

C1Spell1.CheckTyping(TextBox1);

C1Spell1.IntegerTag := 1;

end;


Spell for .NET Tutorial; Step 3 ex.1 - Visual Basic

Visual Basic

Private Sub TextBox1_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles TextBox1.GotFocus

C1Spell1.CheckTyping(TextBox1)

C1Spell1.IntegerTag = 1

End Sub


Spell for .NET Tutorial; Step 3 ex. 2 - C#

C#

private void TextBox2_GotFocus( object sender, System.EventArgs e) {

C1Spell1.CheckTyping(TextBox2);

C1Spell1.IntegerTag = 2;

}

private void TextBox3_GotFocus( object sender, System.EventArgs e) {

C1Spell1.CheckTyping(TextBox3);

C1Spell1.IntegerTag = 3;

}


Spell for .NET Tutorial; Step 3 ex. 2 - Delphi

Delphi

procedure MainForm.TextBox2_GotFocus(sender: System.Object; e: System.EventArgs);

begin

C1Spell1.CheckTyping(TextBox2);

C1Spell1.IntegerTag := 2;

end;

procedure TextBox3_GotFocus(sender: System.Object; e: System.EventArgs);

begin

C1Spell1.CheckTyping(TextBox3);

C1Spell1.IntegerTag := 3;

end;


Spell for .NET Tutorial; Step 3 ex. 2 - Visual Basic

Visual Basic

Private Sub TextBox2_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles TextBox2.GotFocus

C1Spell1.CheckTyping(TextBox2)

C1Spell1.IntegerTag = 2

End Sub

Private Sub TextBox3_GotFocus(ByVal sender As Object, ByVal e As System.EventArgs) Handles TextBox3.GotFocus

C1Spell1.CheckTyping(TextBox3)

C1Spell1.IntegerTag = 3

End Sub


Spell for .NET Tutorial; Step 3 ex. #3 C#

C#

private void C1Spell1_TypingError( object sender, C1.Win.C1Spell.TypingErrorEventArgs e) {

//show red light to indicate an error was detected

PictureBox1.BackColor = Color.Red;

//if AutoCorrect is not set, we are done

if (! CheckBox1.Checked ) {

C1Spell1.TypingErrorAction = C1.Win.C1Spell.TypingErrorActionEnum.Underline;

return;

}

C1Spell1.TypingErrorAction = C1.Win.C1Spell.TypingErrorActionEnum.NoAction;

//use CheckString method to build a list of suggestions

C1Spell1.CheckString(e.ErrWord, C1.Win.C1Spell.BadWordDialogEnum.NoDialog);

//if no suggestions, just quit

if ( C1Spell1.Suggestions.Count == 0 ) return;

//now select the word

SetSelection(e.SelStart, e.SelLength);

//only one suggestion, assume it is the correct word

//replace it automatically

if ( C1Spell1.Suggestions.Count == 1 ) {

ChangeText(C1Spell1.Suggestions[0]);

return;

}

//build the context menu if there are at least two suggestions

//and put the suggestion words as the menu texts

int i;

for (i = 1; i <= 5; i++)

this.mPopup.MenuItems[i].Visible = false;

//

this.mPopup.MenuItems[0].Text = e.ErrWord + " (not in dictionary)";

for (i = 1; i <= 5; i++)

if ( C1Spell1.Suggestions.Count < i ) break;

this.mPopup.MenuItems[i].Text = C1Spell1.Suggestions[i - 1];

this.mPopup.MenuItems[i].Visible = true;

} //

//Show the context menu at the current caret position

//note that the caret position is the screen position and it

//should be transferred to the client position for each textbox

Point pos;

int x, y;

x = C1Spell1.CaretPosX;

y = C1Spell1.CaretPosY;

pos = new Point(x, y);

switch (C1Spell1.IntegerTag)

{

case 1:

pos = TextBox1.PointToClient(pos);

this.mPopup.Show(TextBox1, pos);

break;

case 2:

pos = TextBox2.PointToClient(pos);

this.mPopup.Show(TextBox2, pos);

break;

case 3:

pos = TextBox3.PointToClient(pos);

this.mPopup.Show(TextBox3, pos);

break;

}

}

//this sub routine will select the error word

private void SetSelection( start, length) {

switch (C1Spell1.IntegerTag)

{

case 1:

TextBox1.Select(start, length);

case 2:

TextBox2.Select(start, length);

break;

case 3:

TextBox3.Select(start, length);

break;

}

}


Spell for .NET Tutorial; Step 3 ex. #3 Delphi

Delphi

procedure MainForm.c1Spell1_TypingError(Sender: System.Object; e: C1.Win.C1Spell.TypingErrorEventArgs);

var

I: Integer;

APos: System.Drawing.Point;

begin

pictureBox1.BackColor := Color.Red;

if checkBox1.Checked then

begin

C1Spell1.TypingErrorAction := C1.Win.C1Spell.TypingErrorActionEnum.Underline;

exit;

end;

c1Spell1.TypingErrorAction := C1.Win.C1Spell.TypingErrorActionEnum.NoAction;

c1Spell1.CheckString(e.ErrWord, C1.Win.C1Spell.BadWordDialogEnum.NoDialog);

if c1Spell1.Suggestions.Count = 0 then

exit;

case c1Spell1.IntegerTag of

1: textBox1.Select(Integer(e.SelStart), Integer(e.SelLength));

2: textBox2.Select(Integer(e.SelStart), Integer(e.SelLength));

3: textBox3.Select(Integer(e.SelStart), Integer(e.SelLength));

end;

//If only one suggestion, assume it is the correct word

//replace it automatically

if c1Spell1.Suggestions.Count = 1 then

begin

ChangeText(c1Spell1.Suggestions[0]);

exit;

end;

//build the context menu if there are at least two suggestions

//and put the suggestion words as the menu texts

for I := 1 to 5 do

contextMenu1.MenuItems[I].Visible := False;

contextMenu1.MenuItems[0].Text := e.ErrWord + ' (not in dictionary)';

for I := 1 to 5 do

begin

if c1Spell1.Suggestions.Count < I then

break;

with contextMenu1.MenuItems[I] do

begin

Text := c1Spell1.Suggestions[i-1];

Visible := True;

end;

end;

//Show the context menu at the current caret position

//note that the caret position is the screen position and it

//should be transferred to the client position for each textbox

APos := System.Drawing.Point.Create(c1Spell1.CaretPosX, c1Spell1.CaretPosY);

case c1Spell1.IntegerTag of

1: begin

APos := textBox1.PointToClient(APos);

contextMenu1.Show(textBox1, APos);

end;

2: begin

APos := textBox2.PointToClient(APos);

contextMenu1.Show(textBox2, APos);

end;

3: begin

APos := textBox3.PointToClient(APos);

contextMenu1.Show(textBox3, APos);

end;

end;

end;

// this sub routine will change the error word

procedure MainForm.ChangeText(const S: string);

begin

case c1Spell1.IntegerTag of

1: textBox1.SelectedText := S;

2: textBox2.SelectedText := S;

3: textBox3.SelectedText := S;

end;

pictureBox1.BackColor := Color.Green;

end;


Spell for .NET Tutorial; Step 3 ex. 3 - Visual Basic

Visual Basic

Private Sub C1Spell1_TypingError(ByVal sender As Object, ByVal e As C1.Win.C1Spell.TypingErrorEventArgs) Handles C1Spell1.TypingError

'show red light to indicate an error was detected

PictureBox1.BackColor = Color.Red

'if AutoCorrect is not set, we are done

If Not CheckBox1.Checked Then

C1Spell1.TypingErrorAction = C1.Win.C1Spell.TypingErrorActionEnum.Underline

Exit Sub

End If

C1Spell1.TypingErrorAction = C1.Win.C1Spell.TypingErrorActionEnum.NoAction

'use CheckString method to build a list of suggestions

C1Spell1.CheckString(e.ErrWord, C1.Win.C1Spell.BadWordDialogEnum.NoDialog)

'if no suggestions, just quit

If C1Spell1.Suggestions.Count = 0 Then Exit Sub

'now select the word

SetSelection(e.SelStart, e.SelLength)

'only one suggestion, assume it is the correct word

'replace it automatically

If C1Spell1.Suggestions.Count = 1 Then

ChangeText(C1Spell1.Suggestions(0))

Exit Sub

End If

'build the context menu if there are at least two suggestions

'and put the suggestion words as the menu texts

Dim i As Integer

For i = 1 To 5

Me.mPopup.MenuItems(i).Visible = False

Next

Me.mPopup.MenuItems(0).Text = e.ErrWord & " (not in dictionary)"

For i = 1 To 5

If i > 5 Then Exit For

If C1Spell1.Suggestions.Count < i Then Exit For

Me.mPopup.MenuItems(i).Text = C1Spell1.Suggestions(i - 1)

Me.mPopup.MenuItems(i).Visible = True

Next

'Show the context menu at the current caret position

'note that the caret position is the screen position and it

'should be transferred to the client position for each textbox

Dim pos As Point

Dim x, y

x = C1Spell1.CaretPosX

y = C1Spell1.CaretPosY

pos = New Point(x, y)

Select Case C1Spell1.IntegerTag

Case 1

pos = TextBox1.PointToClient(pos)

Me.mPopup.Show(TextBox1, pos)

Case 2

pos = TextBox2.PointToClient(pos)

Me.mPopup.Show(TextBox2, pos)

Case 3

pos = TextBox3.PointToClient(pos)

Me.mPopup.Show(TextBox3, pos)

End Select

End Sub

'this sub routine will select the error word

Private Sub SetSelection(ByVal start, ByVal length)

Select Case C1Spell1.IntegerTag

Case 1

TextBox1.Select(start, length)

Case 2

TextBox2.Select(start, length)

Case 3

TextBox3.Select(start, length)

End Select

End Sub


Spell for .NET Tutorial; Step 3 ex. 4 - C#

C#

private void MenuItem1_Click( object sender, System.EventArgs e)

{

//Ignore this word

this.C1Spell1.IgnoreAllWord = true;

//change the color

PictureBox1.BackColor = Color.Green;

}

//this sub routine will change the error word to

//val

private void ChangeText( string val)

{

switch (C1Spell1.IntegerTag)

{

case 1:

TextBox1.SelectedText = val;

break;

case 2:

TextBox2.SelectedText = val;

break;

case 3:

TextBox3.SelectedText = val;

break;

}

//the error is corrected

PictureBox1.BackColor = Color.Green;

}

private void MenuItem2_Click( object sender, System.EventArgs e) {

//handle menu click

ChangeText(MenuItem2.Text);

}

private void MenuItem3_Click( object sender, System.EventArgs e) {

//handle menu click

ChangeText(MenuItem3.Text);

}

private void MenuItem4_Click( object sender, System.EventArgs e) {

//handle menu click

ChangeText(MenuItem4.Text);

}

private void MenuItem5_Click( object sender, System.EventArgs e) {

//handle menu click

ChangeText(MenuItem5.Text);

}

private void MenuItem6_Click( object sender, System.EventArgs e) {

//handle menu click

ChangeText(MenuItem6.Text);

}


Spell for .NET Tutorial; Step 3 ex. 4 - Delphi

Delphi

procedure MainForm.MenuItem1_Click(sender: System.Object; e: System.EventArgs);

begin

// Ignore this word

Me.C1Spell1.IgnoreAllWord := True;

// change the color

PictureBox1.BackColor := Color.Green;

end;

// this sub routine will change the error word to

// val

procedure MainForm.ChangeText(val: String);

begin

case c1Spell1.IntegerTag of

1: textBox1.SelectedText := S;

2: textBox2.SelectedText := S;

3: textBox3.SelectedText := S;

end;

// the error is corrected

pictureBox1.BackColor := Color.Green;

end;

procedure MainForm.MenuItem2_Click(sender: System.Object; e: System.EventArgs);

begin

// handle menu click

ChangeText(MenuItem2.Text);

end;

procedure MainForm.MenuItem3_Click(sender: System.Object; e: System.EventArgs);

begin

// handle menu click

ChangeText(MenuItem3.Text);

end;

procedure MainForm.MenuItem4_Click(sender: System.Object; e: System.EventArgs);

begin

// handle menu click

ChangeText(MenuItem4.Text);

end;

procedure MainForm.MenuItem5_Click(sender: System.Object; e: System.EventArgs);

begin

// handle menu click

ChangeText(MenuItem5.Text);

end;

procedure MainForm.MenuItem6_Click(sender: System.Object; e: System.EventArgs)

begin

// handle menu click

ChangeText(MenuItem6.Text);

end;


Spell for .NET Tutorial; Step 3 ex. 4 - Visual Basic

Visual Basic

Private Sub MenuItem1_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles MenuItem1.Click

'Ignore this word

Me.C1Spell1.IgnoreAllWord = True

'change the color

PictureBox1.BackColor = Color.Green

End Sub

'this sub routine will change the error word to

'val

Private Sub ChangeText(ByVal val As String)

Select Case C1Spell1.IntegerTag

Case 1

TextBox1.SelectedText = val

Case 2

TextBox2.SelectedText = val

Case 3

TextBox3.SelectedText = val

End Select

'the error is corrected

PictureBox1.BackColor = Color.Green

End Sub

Private Sub MenuItem2_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles MenuItem2.Click

'handle menu click

ChangeText(MenuItem2.Text)

End Sub

Private Sub MenuItem3_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles MenuItem3.Click

'handle menu click

ChangeText(MenuItem3.Text)

End Sub

Private Sub MenuItem4_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles MenuItem4.Click

'handle menu click

ChangeText(MenuItem4.Text)

End Sub

Private Sub MenuItem5_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles MenuItem5.Click

'handle menu click

ChangeText(MenuItem5.Text)

End Sub

Private Sub MenuItem6_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles MenuItem6.Click

'handle menu click

ChangeText(MenuItem6.Text)

End Sub


Spell for .NET Tutorial; Step 3 ex. 5 - C#

C#

private void C1Spell1_TypingOK( object sender, C1.Win.C1Spell.TypingOKEventArgs e) {

//typed something right? Use green color.

PictureBox1.BackColor = Color.Green;

}


Spell for .NET Tutorial; Step 3 ex. 5 - Delphi

Delphi

procedure MainForm.C1Spell1_TypingOK(sender: System.Object; e: C1.Win.C1Spell.TypingOKEventArgs);

begin

// typed something right? Use green color.

PictureBox1.BackColor := Color.Green;

end;


Spell for .NET Tutorial; Step 3 ex. 5 - Visual Basic

Visual Basic

Private Sub C1Spell1_TypingOK(ByVal sender As Object, ByVal e As C1.Win.C1Spell.TypingOKEventArgs) Handles C1Spell1.TypingOK

'typed something right? Use green color.

PictureBox1.BackColor = Color.Green

End Sub


Spell for .NET Tutorial; Step 4: Provide Long Document Spell Checking (middle panel) - C#

C#

private void Button1_Click( System.object sender, System.EventArgs e) {

//this will check the whole window, displaying the spelling dialog

//when a bad word is found and correcting words as needed

C1Spell2.CheckControl(TextBox4);

//when it is done, give the user some feedback

if ( C1Spell2.BadWordCount > 0 )

MessageBox.Show("Done spell checking. " + C1Spell2.BadWordCount + " typing errors.")

else

MessageBox.Show("Done spell checking. No spelling errors.");

}

}


Spell for .NET Tutorial; Step 4: Provide Long Document Spell Checking (middle panel) - Delphi

Delphi

procedure MainForm.button1_Click(Sender: System.Object; e: System.EventArgs);

begin

//this will check the whole window, displaying the spelling dialog

//when a bad word is found and correcting words as needed

c1Spell2.CheckControl(textBox4);

//when it is done, give the user some feedback

if c1Spell2.BadWordCount > 0 then

MessageBox.Show('Done spell checking. ' + c1Spell2.BadWordCount.ToString + ' typing errors.')

else

MessageBox.Show('Done spell checking. No spelling errors.');

end;


Spell for .NET Tutorial; Step 4: Provide Long Document Spell Checking (middle panel) - Visual Basic

Visual Basic

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click

'this will check the whole window, displaying the spelling dialog

'when a bad word is found and correcting words as needed

C1Spell2.CheckControl(TextBox4)

'when it is done, give the user some feedback

If C1Spell2.BadWordCount > 0 Then

MessageBox.Show("Done spell checking. " & C1Spell2.BadWordCount & " typing errors.")

Else

MessageBox.Show("Done spell checking. No spelling errors.")

End If

End Sub


Spell for .NET Tutorial; Step 5 (ex. #1): Provide Spell Checking for Arbitrary Strings (bottom panel) - C#

C#

private void ListBox1_Click( object sender, System.EventArgs e) {

if (ListBox1.SelectedIndex > -1 ) {

TextBox5.Text = (string)ListBox1.Items[ListBox1.SelectedIndex];

}

}

private void TextBox5_TextChanged( object sender, System.EventArgs e) {

if (ListBox1.SelectedIndex > -1) {

ListBox1.Items[ListBox1.SelectedIndex] = TextBox5.Text;

}

}


Spell for .NET Tutorial; Step 5 (ex. #1): Provide Spell Checking for Arbitrary Strings (bottom panel) - Delphi

Delphi

procedure MainForm.listBox1_SelectedIndexChanged(Sender: System.Object; e: System.EventArgs);

begin

if listBox1.SelectedIndex > -1 then

textBox5.Text := listBox1.Items[listBox1.SelectedIndex].ToString;

end;

procedure MainForm.textBox5_TextChanged(Sender: System.Object; e: System.EventArgs);

begin

if listBox1.SelectedIndex > -1 then

listBox1.Items[listBox1.SelectedIndex] := textBox5.Text;

end;


Spell for .NET Tutorial; Step 5 (ex. #1): Provide Spell Checking for Arbitrary Strings (bottom panel) - Visual Basic

Visual Basic

Private Sub ListBox1_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles ListBox1.Click

If (ListBox1.SelectedIndex > -1) Then

TextBox5.Text = ListBox1.Items(ListBox1.SelectedIndex)

End If

End Sub

Private Sub TextBox5_TextChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles TextBox5.TextChanged

If (ListBox1.SelectedIndex > -1) Then

ListBox1.Items(ListBox1.SelectedIndex) = TextBox5.Text

End If

End Sub


Spell for .NET Tutorial; Step 5 (ex. #2): Provide Spell Checking for Arbitrary Strings (bottom panel) - C#

C#

private void Button2_Click( System.object sender, System.EventArgs e) {

//Check the listbox items one by one

for (int i = 0; i <= ListBox1.Items.Count -– 1; i++)

{

if (! C1Spell3.CheckString(ListBox1.Items[i].ToString()) ) {

//there are bad words in this item, so select the bad item

ListBox1.SetSelected(i, true);

//find any one, then exit for

break;

}

} //

}


Spell for .NET Tutorial; Step 5 (ex. #2): Provide Spell Checking for Arbitrary Strings (bottom panel) - Delphi

Delphi

procedure MainForm.button2_Click(Sender: System.Object; e: System.EventArgs);

var

AFound: Boolean;

AIndex: Integer;

begin

//Check the listbox items one by one

AFound := False;

for AIndex := 0 to listBox1.Items.Count - 1 do

if not c1Spell3.CheckString(listBox1.Items[AIndex].ToString) then

begin

//there are bad words in this item, so select that item

listBox1.SetSelected(AIndex, true);

//found one, then exit for loop

AFound := true;

break;

end;

//give feedback

if AFound then

MessageBox.Show('Spelling errors are found in the ' + Convert.ToString(AIndex + 1) + 'th entry. Correct that and check again.')

else

MessageBox.Show('The spelling is correct for all entries.');

end;


Spell for .NET Tutorial; Step 5 (ex. #2): Provide Spell Checking for Arbitrary Strings (bottom panel) - Visual Basic

Visual Basic

Private Sub Button2_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button2.Click

Dim i As Integer

'Check the listbox items one by one

For i = 0 To ListBox1.Items.Count - 1

If Not C1Spell3.CheckString(ListBox1.Items(i)) Then

'there are bad words in this item, so select the bad item

ListBox1.SetSelected(i, True)

'find any one, then exit for

Exit For

End If

Next

End Sub


StartPosition Property ex. #1- C#

C#

c1Spell1.StartPosition = 0;

C1Spell1.CheckControl(TextBox1, C1.Win.C1Spell.BadWordDialogEnum.FrenchDialog);


StartPosition Property ex. #1- Delphi

Delphi

c1Spell1.StartPosition := 0;

C1Spell1.CheckControl(TextBox1, C1.Win.C1Spell.BadWordDialogEnum.FrenchDialog);


StartPosition Property ex. #1 - Visual Basic

Visual Basic

c1Spell1.StartPosition = 0;

C1Spell1.CheckControl(TextBox1, C1.Win.C1Spell.BadWordDialogEnum.FrenchDialog)


StartPosition Property ex. #2 - C#

C#

C1Spell1.CheckControl(TextBox1, C1.Win.C1Spell.BadWordDialogEnum.FrenchDialog);


StartPosition Property ex. #2 - Delphi

Delphi

C1Spell1.CheckControl(TextBox1, C1.Win.C1Spell.BadWordDialogEnum.FrenchDialog);


StartPosition Property ex. #2 - Visual Basic

Visual Basic

C1Spell1.CheckControl(TextBox1, C1.Win.C1Spell.BadWordDialogEnum.FrenchDialog)


Suggestion Event (C1Spell) - C#

C#

if ( e.Index >= 2 )

e.Cancel = true;


Suggestion Event (C1Spell) - Delphi

Delphi

if e.Index >= 2 then

e.Cancel := True;


Suggestion Event (C1Spell) - Visual Basic

Visual Basic

If e.Index >= 2 Then

e.Cancel = True

End If


Suggestion Event (C1Thesaurus) - C#

C#

if (e.Index >= 2)

e.Cancel=true;


Suggestion Event (C1Thesaurus) - Delphi

Delphi

if e.Index >= 2 then

e.Cancel := True;


Suggestion Event (C1Thesaurus) - Visual Basic

Visual Basic

If e.Index >= 2 Then

e.Cancel=True

End If


Suggestions Property - C#

C#

System.Collections.Specialized.StringCollection strCol;

strCol = C1Spell1.Suggestions;

int cnt = C1Spell1.Suggestions.Count;

string str = C1Spell1.Suggestions[i];


Suggestions Property - Delphi

Delphi

var

strCol: System.Collections.Specialized.StringCollection;

begin

strCol := C1Spell1.Suggestions;

cnt := C1Spell1.Suggestions.Count;

str := C1Spell1.Suggestions[i];


Suggestions Property - Visual Basic

Visual Basic

Dim strCol As System.Collections.Specialized.StringCollection

strCol = C1Spell1.Suggestions

cnt = C1Spell1.Suggestions.Count

str = C1Spell1.Suggestions(i)


Synonyms Property - C#

C#

System.Collections.Specialized.StringCollection sy;

int m;

sy = this.C1Thesaurus1.Synonyms;

if (sy != null)

m = sy.Count;


Synonyms Property - Delphi

Delphi

sy, m;

sy := Self.C1Thesaurus1.Synonyms;

if sy <> nil then

m := sy.Count;


Synonyms Property - Visual Basic

Visual Basic

Dim sy, m

sy = Me.C1Thesaurus1.Synonyms

If Not (sy Is Nothing) Then

m = sy.Count

End If


TBH Pop Up Menu (C1Spell) - C#

C#

this.c1Spell1.CheckTyping(this.textBox1);


TBH Pop Up Menu (C1Spell) - C#2

C#

private void c1Spell1_TypingError(object sender, C1.Win.C1Spell.TypingErrorEventArgs e)

{

this.c1Spell1.TypingErrorAction = C1.Win.C1Spell.TypingErrorActionEnum.Underline;

//use CheckString method to build a list of suggestions

this.c1Spell1.CheckString(e.ErrWord, C1.Win.C1Spell.BadWordDialogEnum.NoDialog);

//if no suggestions, just quit

if (this.c1Spell1.Suggestions.Count == 0)

return;

//now select the word

textBox1.Select((int)e.SelStart, (int)e.SelLength);


TBH Pop Up Menu (C1Spell) - C#3

C#

//build the context menu if there are at least two suggestions

//and put the suggestion words as the menu texts

for(int i = 1; i <= 5; i++)

this.contextMenu1.MenuItems[i].Visible = false;

this.contextMenu1.MenuItems[0].Text = e.ErrWord + " (not in dictionary)";

for( int i = 1; i <= 5; i++)

{

if (this.c1Spell1.Suggestions.Count < i)

break;

this.contextMenu1.MenuItems[i].Text = this.c1Spell1.Suggestions[i-1];

this.contextMenu1.MenuItems[i].Visible = true;

}

//Show the context menu at the current caret position

//note that the caret position is the screen position and it

//should be transferred to the client position for each textbox

Point pos = new Point((int)this.c1Spell1.CaretPosX, (int)this.c1Spell1.CaretPosY);

pos = this.textBox1.PointToClient(pos);

this.contextMenu1.Show(this.textBox1, pos);

}


TBH Pop Up Menu (C1Spell) - C#4

C#

private void menuItem_Click(object sender, System.EventArgs e)

{

//ignore this word

this.c1Spell1.IgnoreAllWord = true;

}

//this sub routine will change the error word to val

private void ChangeText(string val)

{

this.textBox1.SelectedText = val;

}


TBH Pop Up Menu (C1Spell) - Delphi

Delphi

Self.c1Spell1.CheckTyping(Self.textBox1);


TBH Pop Up Menu (C1Spell) - Delphi2

Delphi

procedure c1Spell1_TypingError(sender: System.Object; e: C1.Win.C1Spell.TypingErrorEventArgs);

begin

Self.c1Spell1.TypingErrorAction := C1.Win.C1Spell.TypingErrorActionEnum.Underline;

//use CheckString method to build a list of suggestions

Self.c1Spell1.CheckString(e.ErrWord, C1.Win.C1Spell.BadWordDialogEnum.NoDialog);

//if no suggestions, just quit

if (Self.c1Spell1.Suggestions.Count = 0) then

exit;

//now select the word

textBox1.Select(e.SelStart, e.SelLength);

end;


TBH Pop Up Menu (C1Spell) - Delphi3

Delphi

var

i: Integer;

pos: System.Drawing.Point;

begin

//build the context menu if there are at least two suggestions

//and put the suggestion words as the menu texts

for I := 1 to 5 do

Self.contextMenu1.MenuItems[i].Visible := false;

Self.contextMenu1.MenuItems[0].Text := e.ErrWord + ‘ (not in dictionary)’;

for I := 1 to 5 do

begin

if Self.c1Spell1.Suggestions.Count < I then

break;

Self.contextMenu1.MenuItems[i].Text := this.c1Spell1.Suggestions[i-1];

this.contextMenu1.MenuItems[i].Visible := true;

end;

//Show the context menu at the current caret position

//note that the caret position is the screen position and it

//should be transferred to the client position for each textbox

pos := System.Drawing.Point.Create(Self.c1Spell1.CaretPosX, Self.c1Spell1.CaretPosY);

pos := Self.textBox1.PointToClient(pos);

Self.contextMenu1.Show(this.textBox1, pos);


TBH Pop Up Menu (C1Spell) - Delphi4

Delphi

procedure menuItem_Click(sender: System.Object; e: System.EventArgs);

begin

//ignore this word

Self.c1Spell1.IgnoreAllWord := true;

end;

//this sub routine will change the error word to val

procedure ChangeText(val: string);

begin

Self.textBox1.SelectedText := val;

end;


TBH Pop Up Menu (C1Spell) - VB

Visual Basic

Me.c1Spell1.CheckTyping(Me.textBox1)


TBH Pop Up Menu (C1Spell) - VB2

Visual Basic

Private Sub C1Spell1_TypingError(ByVal sender As Object, ByVal e As C1.Win.C1Spell.TypingErrorEventArgs) Handles C1Spell1.TypingError

C1Spell1.TypingErrorAction = C1.Win.C1Spell.TypingErrorActionEnum.Underline

Exit Sub

'use CheckString method to build a list of suggestions

C1Spell1.CheckString(e.ErrWord, C1.Win.C1Spell.BadWordDialogEnum.NoDialog)

'if no suggestions, just quit

If C1Spell1.Suggestions.Count = 0 Then Exit Sub

'now select the word

SetSelection(e.SelStart, e.SelLength)


TBH Pop Up Menu (C1Spell) - VB3

Visual Basic

'build the context menu if there are at least two suggestions

'and put the suggestion words as the menu texts

Dim i As Integer

For i = 1 To 5

Me.ContextMenu1.MenuItems(i).Visible = False

Next

Me.ContextMenu1.MenuItems(0).Text = e.ErrWord & " (not in dictionary)"

For i = 1 To 5

If i > 5 Then Exit For

If C1Spell1.Suggestions.Count < i Then Exit For

Me.ContextMenu1.MenuItems(i).Text = C1Spell1.Suggestions(i - 1)

Me.ContextMenu1.MenuItems(i).Visible = True

Next

'Show the context menu at the current caret position

'note that the caret position is the screen position and it

'should be transfer to the client position for each textbox

Dim pos As Point

Dim x, y

x = C1Spell1.CaretPosX

y = C1Spell1.CaretPosY

pos = New Point(x, y)

pos = TextBox1.PointToClient(pos)

Me.ContextMenu1.Show(TextBox1, pos)

End Sub


TBH Pop Up Menu (C1Spell) - VB4

Visual Basic

'this sub routine will select the error word

Private Sub SetSelection(ByVal start As Integer, ByVal length As Integer)

TextBox1.Select(start, length)

End Sub

Private Sub menuItem_Click(ByVal sender As Object, ByVal e As System.EventArgs)

'ignore this word

Me.C1Spell1.IgnoreAllWord = True

End Sub

'this sub routine will change the error word to val

Private Sub ChangeText(ByVal val As String)

Me.TextBox1.SelectedText = val

End Sub


TBH Show a Red Sign (C1Spell) - C#

C#

this.c1Spell1.CheckTyping(this.textBox1);


TBH Show a Red Sign (C1Spell) - C#2

C#

private void c1Spell1_TypingError(object sender, C1.Win.C1Spell.TypingErrorEventArgs e)

{

//show red light to indicate an error was detected

this.panel1.BackColor = Color.Red;

}

private void c1Spell1_TypingOK(object sender, C1.Win.C1Spell.TypingOKEventArgs e)

{

//typed something right? Use green color.

this.panel1.BackColor = Color.Green;

}


TBH Show a Red Sign (C1Spell) - Delphi

Delphi

Self.c1Spell1.CheckTyping(Self.textBox1);


TBH Show a Red Sign (C1Spell) - Delphi2

Delphi

Procedure c1Spell1_TypingError(sender: System.Object; e: C1.Win.C1Spell.TypingErrorEventArgs);

begin

//show red light to indicate an error was detected

Self.panel1.BackColor := Color.Red;

end;

Procedure c1Spell1_TypingOK(sender: System.Object; e: C1.Win.C1Spell.TypingOKEventArgs);

begin

// typed something right? Use green color.

Self.panel1.BackColor := Color.Green;

end;


TBH Show a Red Sign (C1Spell) - VB

Visual Basic

Me.C1Spell1.CheckTyping(Me.TextBox1)


TBH Show a Red Sign (C1Spell) - VB2

Visual Basic

Private Sub C1Spell1_TypingError(ByVal sender As Object, ByVal e As C1.Win.C1Spell.TypingErrorEventArgs) Handles C1Spell1.TypingError

'show red light to indicate an error was detected

Panel1.BackColor = Color.Red

End Sub

Private Sub C1Spell1_TypingOK(ByVal sender As Object, ByVal e As C1.Win.C1Spell.TypingOKEventArgs) Handles C1Spell1.TypingOK

'typed something right? Use green color.

Panel1.BackColor = Color.Green

End Sub


TBH Window Mode (C1Spell) - C#

C#

this.textBox1.Text = "The C1Spell component features a built-in spelling dialog box, the ability to generate suggestions for bad words, the ability to create new main dictionaries based on existing main dictionaries (such as those created in Microsoft Word), the ability to ignore all or change all bad words, and utilities to build and maintain dictionaries.";


TBH Window Mode (C1Spell) - C#2

C#

this.c1Spell1.CheckControl(this.textBox1);


TBH Window Mode (C1Spell) - C#3

C#

//when spell checking is done, give the user some feedback

if (this.c1Spell1.BadWordCount > 0)

MessageBox.Show("Done spell checking. " + this.c1Spell1.BadWordCount + " typing errors.");

else

MessageBox.Show("Done spell checking. No spelling errors.");


TBH Window Mode (C1Spell) - Delphi

Delphi

Self.textBox1.Text := ‘The C1Spell component features a built-in spelling dialog box, the ability to generate suggestions for bad words, the ability to create new main dictionaries based on existing main dictionaries (such as those created in Microsoft Word), the ability to ignore all or change all bad words, and utilities to build and maintain dictionaries.’;


TBH Window Mode (C1Spell) - Delphi2

Delphi

Self.c1Spell1.CheckControl(this.textBox1);


TBH Window Mode (C1Spell) - Delphi3

Delphi

//when spell checking is done, give the user some feedback

if (Self.c1Spell1.BadWordCount > 0) then

MessageBox.Show(‘Done spell checking. ‘ + this.c1Spell1.BadWordCount.ToString() + ‘ typing errors.’)

else

MessageBox.Show(‘Done spell checking. No spelling errors.’);


TBH Window Mode (C1Spell) - VB

Visual Basic

me.textBox1.Text = "The C1Spell component features a built-in spelling dialog box, the ability to generate suggestions for bad words, the ability to create new main dictionaries based on existing main dictionaries (such as those created in Microsoft Word), the ability to ignore all or change all bad words, and utilities to build and maintain dictionaries."


TBH Window Mode (C1Spell) - VB2

Visual Basic

Me.c1Spell1.CheckControl(Me.textBox1)


TBH Window Mode (C1Spell) - VB3

Visual Basic

'when spell checking is done, give the user some feedback

If Me.c1Spell1.BadWordCount > 0 Then

MessageBox.Show(("Done spell checking. " + Me.c1Spell1.BadWordCount + " typing errors."))

Else

MessageBox.Show("Done spell checking. No spelling errors.")

End If


Thesaurus for .NET QuickStart - C#

C#

Button1.Text = "Thesaurus";

TextBox1.Text="";


Thesaurus for .NET QuickStart - Delphi

Delphi

Button1.Text := 'Thesaurus';

TextBox1.Text := '';


Thesaurus for .NET QuickStart - Visual Basic

Visual Basic

Button1.Text = "Thesaurus"

TextBox1.Text=""


ThesaurusLanguage Property - C#

C#

C1.Win.C1Thesaurus.LanguageEnum Lang;

Lang = this.C1Thesaurus1.ThesaurusLanguage;


ThesaurusLanguage Property - Delphi

Delphi

var

Lang: C1.Win.C1Thesaurus.LanguageEnum;

Lang := Me.C1Thesaurus1.ThesaurusLanguage;


ThesaurusLanguage Property - Visual Basic

Visual Basic

Dim Lang As C1.Win.C1Thesaurus.LanguageEnum

Lang = Me.C1Thesaurus1.ThesaurusLanguage


ThesaurusVersion Property - C#

C#

int i;

i = this.C1Thesaurus1.ThesaurusVersion;


ThesaurusVersion Property - Delphi

Delphi

var

i: Integer;

begin

i := Self.C1Thesaurus1.ThesaurusVersion;


ThesaurusVersion Property - Visual Basic

Visual Basic

Dim i As Integer

i = Me.C1Thesaurus1.ThesaurusVersion


UIStrings Property - C#

C#

C1Spell1.UIStrings[C1.Win.C1Spell.UIStringsEnum.SSpellingCheck] = "Spell Dialog";


UIStrings Property - Delphi

Delphi

C1Spell1.UIStrings(C1.Win.C1Spell.UIStringsEnum.SSpellingCheck) := 'Spell Dialog';


UIStrings Property - Visual Basic

Visual Basic

C1Spell1.UIStrings(C1.Win.C1Spell.UIStringsEnum.SSpellingCheck) = "Spell Dialog"


Copyright © ComponentOne LLC. All rights reserved.