Welcome to ComponentOne WebMenus and WebBars for ASP.NET

Untitled Document ComponentOne WebMenus and WebBars for ASP.NET Untitled Document E-mail sent to documentation@componentone.com is for documentation feedback only. We welcome any suggestions to help improve our documentation.

Welcome to ComponentOne WebMenus and WebBars for ASP.NET

Previous Next

ComponentOne WebMenus and WebBars™ for ASP.NET is a suite of ASP.NET components providing menus and other User Interface elements for ASP.NET web pages.

If you like WebMenus and WebBars for ASP.NET, you can check out our other products by visiting the ComponentOne website.

ComponentOne has a user-friendly distribution policy. We want every programmer to obtain a copy of WebMenus and WebBars™ for ASP.NET to try for as long as they wish. Those who like the product and find it useful may buy a license for a reasonable price. The only restriction is that unlicensed copies of WebMenus and WebBars™ for ASP.NET will display a ComponentOne banner every time they are loaded to remind developers to license the product.

We are confident that you will like WebMenus and WebBars™ for ASP.NET. If you have any suggestions or ideas for new features that you'd like to see included in a future version, or ideas for new controls, please call us or write:

Corporate Headquarters

ComponentOne LLC
201 South Highland Avenue
3rd Floor
Pittsburgh, PA 15206 USA
412.681.4343
412.681.4384 (Fax)

http://www.componentone.com

Overview

What's New in ComponentOne WebMenus and WebBars for ASP.NET

Installing WebMenus and WebBars for ASP.NET

END-USER LICENSE AGREEMENT FOR COMPONENTONE SOFTWARE

Licensing FAQs

Technical Support

Redistributable Files

Namespaces

Creating an ASP.NET Project

Untitled Document
Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


Overview

Overview

The WebMenus and WebBars for ASP.NET allows you to easily add cascading menus to your ASP.NET web pages. Some highlights include:

· Full Microsoft Visual Studio .NET design-time support.

· Customizable cascading styles for menus and individual items.

· Functional in all modern browsers.

Terminology

Client Side Script

Browser Compatibility

Class Hierarchy


Terminology

Terminology

In this text, C1WebCommand is used as a short name to designate the whole ComponentOne WebMenus and WebBars for ASP.NET product.


Client Side Script

Client Side Script

C1WebCommand’s client side functionality is provided by JavaScript modules included in the product. That scripts (files with the .js extension) should be installed into the /c1webcommand_client virtual directory on your web server, and should have corresponding permissions.


Browser Compatibility

Browser Compatibility

C1WebCommand has been tested and verified to work correctly with the following browsers:

· Internet Explorer 6

· Mozilla 1.7

· Netscape 7.1

· FireFox 1.0

· Opera 7.5

Note: Javascript must be enabled in the browser.

Support for other browsers may be added in a future version.


Class Hierarchy

Class Hierarchy

This section summarizes the class relationships between the more important classes included in C1WebCommand.

· C1.Web.C1Command.C1MenuBase : System.Web.UI.WebControls.Panel

Encapsulates most of the menu functionality. Base class for root menus and submenus.

· C1.Web.C1Command.C1WebMenu : C1.Web.C1Command.C1MenuBase

Root menu. This component is shown in the Visual Studio’s toolbox.

· C1.Web.C1Command.C1SubMenu : C1.Web.C1Command.C1MenuBase

Submenu. Can be created with the Add Child command of the C1WebMenu editor.

· C1.Web.C1Command.C1MenuItem : System.Web.UI.WebControls.WebControl

Menu item can be created with the Add Child, Append Item or Insert Item commands of the C1WebMenu editor.

· C1.Web.C1Command.C1MenuItemStyle : System.Object

Encapsulates display styles of menu items. Used to specify how normal, selected and disabled menu items should look.

· C1WebToolBarContainerBase: System.Web.UI.WebControls.Panel

Base class for C1WebToolBar control and toolbar’s groups.

· C1.Web.C1Command.C1ToolBar : C1.Web.C1Command.C1WebToolBarContainerBase

Represents a toolbar. This component is shown in the Visual Studio’s toolbox.

· C1.Web.C1Command.C1WebToolBarToggleGroupBase: C1.Web.C1Command.C1WebToolBarContainerBase

Base class for toolbar’s groups.

· C1.Web.C1Command.C1WebToolBarToggleGroup:C1.Web.C1Command.C1WebToolBarToggleGroupBase

Represents a toggle group.

· C1.Web.C1Command.C1ToolBarControl : System.Web.UI.WebControls.WebControl

Base class for all toolbar controls.

· C1.WebC1Command.C1ToolBarSeparator : C1.Web.C1Command.C1ToolBarControl

Separator control for C1WebToolBar.

· C1.WebC1Command.C1ToolBarButtonBase : C1.Web.C1Command.C1ToolBarControl

Base class for all toolbar buttons.

· C1.Web.C1Command.C1ToolBarButton : C1.Web.C1Command.C1ToolBarButtonBase

Represents a simple toolbar button.

· C1.Web.C1Command.C1WebToolBarStyle : System.Web.UI.WebControls.

StyleEncapsulates display styles of toolbar buttons.

· C1.Web.C1Command.C1WebTopicBar: System.Web.UI.WebControls.WebControl

Represents a toolbar. This component is shown in the Visual Studio’s toolbox.

· C1.Web.C1Command.C1WebTopicBarCustomGroup: System.Object

Base class for topicbar’s groups.

· C1.Web.C1Command.C1WebTopicBarItemsGroup: C1.Web.C1Command.C1WebTopicBarCustomGroup

Represents a group which’s contains items in collection.

· C1.Web.C1Command.C1WebTopicBarPanelGroup:C1.Web.C1Command.C1WebTopicBarCustomGroup

Represents a group which can contains other controls on the body.

· C1.Web.C1Command.C1WebTopicBarItem: System.Object

Represents a single item.

· C1.Web.C1Command.C1WebTopicBarStyle: System.Web.Style

Base class for the C1WebTopicBar’s styles.

· C1.Web.C1Command.C1WebTopicBarItemStyle: C1.Web.C1Command.C1WebTopicBarStyle

Style used for the items.

· C1.Web.C1Command.C1WebTopicBarGroupStyle: C1.Web.C1Command.C1WebTopicBarStyle

Style used for the groups

· C1.Web.C1Command.C1WebTopicBarHeaderStyle: C1.Web.C1Command.C1WebTopicBarStyle

Style used for the groups’ headers


What's New in ComponentOne WebMenus and WebBars for ASP.NET

What's New in ComponentOne WebMenus and WebBars for ASP.NET

This documentation was last revised on November 23, 2005.

Overview of What’s New in ComponentOne WebMenus and WebBars for ASP.NET

A new property and a enumeration have been added to WebMenus and WebBars for ASP.NET to allow the user more flexibility.


Feature Overview

Feature Overview

There are no new features in WebMenus and WebBars for ASP.NET at this time.


Class Members

Class Members

Below is a collection of the most recent members added to WebMenus and WebBars for ASP.NET.

C1WebMenu Class | Description
SubMenuMark | This property indicates whether the icon place is displayed.

SubMenuMark Enumeration | Description
Auto | The icon place is shown if at least one item has a submenu.
No | The icon place is never shown.
Yes | The icon place is always shown. This is the default value.


Installing WebMenus and WebBars for ASP.NET

Installing WebMenus and WebBars for ASP.NET

This section describes the setup files and system requirements for WebMenus and WebBars for ASP.NET. It also explains how to install demonstration versions of ComponentOne products and uninstall WebMenus and WebBars for ASP.NET.

WebMenus and WebBars for .ASP.NET Setup Files

System Requirements

Installing Demonstration Versions

Uninstalling WebMenus and WebBars for ASP.NET


WebMenus and WebBars for .ASP.NET Setup Files

WebMenus and WebBars for .ASP.NET Setup Files

The installation program will create the directory C:\Program Files\ComponentOne Studio.NET, which contains the following subdirectories:

bin | Contains copies of all binaries (DLLs, EXEs) in the ComponentOne Visual Studio.NET package.
Common | Contains support and data files that are used by many of the demo programs.
Help | Contains online documentation for all Studio components.
C1WebCommand | Contains samples and tutorials for WebMenus and WebBars for ASP.NET. It also contains a client folder that includes the client scripts and images such as c1menu.js, c1toolbar.js, and c1topicbar.js.

The text above assumes that the installation directory for the C1 Web studio is "C:\Program Files\ComponentOne Studio.NET". That directory can be different in a real installation of course. Subdirectories' names mentioned below should *NOT* be changed.

The bin\C1.Web.C1Command.dll is installed as usual for dlls - in the "C:\Program Files\ComponentOne Studio.NET\bin\" directory or similar. It is NOT required to be installed in the GAC (but it can be installed there).

The following virtual directory must be added to the web server running ASP.NET applications on the target machine:

· /c1webcommand_client

and it should be mapped to the following directory:

· C:\Program Files\ComponentOne Studio.NET\C1WebCommand\client

so that the web server can execute the following scripts with the fully qualified names:

· /c1webcommand_client/v1_1/c1menu.js

· /c1webcommand_client/v1_1/c1toolbar.js

· /c1webcommand_client/v1_1/c1topicbar.js

NOTE: The installation adds these directories as virtual directories within IIS(Internet Information Services) so they can be accessed via run-time. Wherever these directories are placed on the web server, they need to be added to virtual directories to IIS as well. The c1webcommand_client virtual directory, and the v1_1 directory inside it must be given script executing permissions (which are read).You can ensure the c1webcommand_client virtual directory and the v1_1 directory inside it is given script executing permissions by following these steps:

1. In Windows 2000, right-click on the my computer icon and select manage from its context menu.

2. The Computer Management dialog box will open.

3. Expand the Services and Applications|Default Web Site| located in the left pane.

4. Right-click the c1webcommand_client and select properties from its context menu.

5. The c1webcommand client's properties dialog box will appear. There should be a check-mark in the check-box for read. The scripts only should appear in the executing permissions field.

You can create a new virtual directory by following these simple steps:

1. Right click an existing directory located in IIS.

2. Select properties from its context menu.

3. A properties dialog box will appear similar to this:

4. Click on the Create button and select OK.

5. A new virtual directory will be created.


System Requirements

System Requirements

· Operating Systems:

Windows 2000

Windows 2003 Server

Windows NT 4

Windows XP, sp1, sp2

· Web Server:

Microsoft Internet Information Services (IIS) 5.x

Microsoft Internet Information Services (IIS) 6.x

· Environments:

NET Framework 1.0

.NET Framework 1.1

ASP.NET

C# .NET

Delphi

Internet Explorer 4.x

Internet Explorer 5.x

Internet Explorer 6.x

Netscape 4

Netscape 6

Netscape 7

Visual Basic .NET

· Environments (Visual Studio 2005):

.NET Framework 2.0

C# .NET

Visual Basic .NET

· Hard Disk Space: 6 MB hard disk space for storage of the software

· Disc Drive: CD or DVD-ROM drive if installing from CD


Installing Demonstration Versions

Installing Demonstration Versions

If you wish to try WebMenus and WebBars for ASP.NET or any of our other products and do not have a registration key, follow the steps through the installation wizard and use the default serial number.

The only difference between unregistered (demonstration) and registered (purchased) versions of our products is that registered versions will stamp every application you compile so a ComponentOne banner will not appear when your users run the applications.


Uninstalling WebMenus and WebBars for ASP.NET

Uninstalling WebMenus and WebBars for ASP.NET

To uninstall WebMenus and WebBars for ASP.NET, open the Control Panel and select the Add or Remove Programs. Select WebMenus and WebBars for ASP.NET and click the Remove button.


END-USER LICENSE AGREEMENT FOR COMPONENTONE SOFTWARE

END-USER LICENSE AGREEMENT FOR COMPONENTONE SOFTWARE

IMPORTANT-READ CAREFULLY: This End User License Agreement (this "EULA") contains the terms and conditions that govern your use of the SOFTWARE (as defined below) and imposes material limitations to your rights. You should read this EULA carefully and treat it as valuable property.

I. THIS EULA.

1. Software Covered by this EULA. This EULA governs your use of the ComponentOne, LLC ("C1") software product(s) enclosed or otherwise accompanied herewith (individually and collectively, the "SOFTWARE"). The term "SOFTWARE" includes, to the extent provided by C1: 1) any revisions, updates and/or upgrades thereto; 2) any data, image or executable files, databases, data engines, computer software, or similar items customarily used or distributed with computer software products; 3) anything in any form whatsoever intended to be used with or in conjunction with the SOFTWARE; and 4) any associated media, documentation (including physical, electronic and online) and printed materials (the "Documentation").

2. This EULA is a Legally Binding Agreement Between You and C1. If you are acting as an agent of a company or another legal person, such as an officer or other employee acting for your employer, then "you" and "your" mean your principal, the entity or other legal person for whom you are acting. However, importantly, even if you are acting as an agent for another, you may still be personally liable for violation of federal and State laws, such as copyright infringement.

By signifying your acceptance of the terms of this EULA, you intend to be, and hereby are, legally bound to this EULA to the same extent as if C1 and you physically signed this EULA. By installing, copying, or otherwise using the SOFTWARE, you agree to be bound by all the terms and conditions of this EULA. If you do not agree to all of such terms and conditions, you may not install or use the SOFTWARE. If you do not agree with any of the terms herewith and, for whatever reason, installation has begun or has been completed, you should cancel installation or un-install the SOFTWARE, as the case may be. Furthermore, you should promptly return the SOFTWARE to the place of business from which you obtained it in accordance with any return policies of such place of business. Return policies may vary among resellers; therefore you must comply with the return policies of your supplier as you agreed at the point of purchase. If the place of business from which you purchased the SOFTWARE does not honor a full refund for a period of thirty (30) days from the date of purchase, you may then return the SOFTWARE directly to C1 for a refund provided that such returns is authorized within the same thirty (30) days time period. To return the product directly to C1, you must first obtain a Return Authorization Number by contacting C1, and you must forward to C1 all items purchased, including the proof of purchase. The return must be postage-prepaid, and post-marked within thirty (30) days from the proof of purchase, time being of the essence. The return option to C1 is only available to the original purchaser of an unopened factory packaged item.

II. YOUR LICENSE TO DEVELOP AND TO DISTRIBUTE.

As provided in more detail below, this EULA grants you two licenses: 1) a license to use the SOFTWARE to develop other software products (the "Development License"); and 2) a license to use and/or distribute the Developed Software (the "Distribution License"). These licenses (individually and collectively, the "Licenses") are explained and defined in more detail below.

1. Definitions. The following terms have the respective meanings as used in this EULA:

"Network Server" means a computer with one or more computer central processing units (CPU's) that operates for the purpose of serving other computers logically or physically connected to it, including, but not limited to, other computers connected to it on an internal network, intranet or the Internet.

"Web Server" means a type of Network Server that serves other computers which, are specifically connected to it through either an intranet or the Internet.

"Developed Software" means those computer software products that are developed by or through the use of the SOFTWARE.

"Developed Web Server Software" means those Developed Software products that reside logically or physically on at least one Web Server and are operated (meaning the computer software instruction set is carried out) by the Web Server's central processing unit(s) (CPU).

"Redistributable Files" means the SOFTWARE files or other portions of the SOFTWARE that are provided by C1 and are identified as such in the Documentation for distribution by you with the Developed Software.

"Developer" means a human being or any other automated device using the SOFTWARE in accordance with the terms and conditions of this EULA.

"Developer Seat License" means that each Developer using or otherwise accessing the programmatic interface or the SOFTWARE must obtain the right to do so by purchasing a separate End User License.

“Source Code” shall mean computer software code or programs in human readable format, such as a printed listing of such a program written in a high-level computer language. The term "Source Code" includes, but is not limited to, documents and materials in support of the development effort of the SOFTWARE, such as flow charts, pseudo code and program notes.

2. Your Development License. You are hereby granted a limited, royalty-free, non-exclusive right to use the SOFTWARE to design, develop, and test Developed Software, on the express condition that, and only for so long as, you fully comply with all terms and conditions of this EULA.

The SOFTWARE is licensed to you on a Developer Seat License basis.

Developer Seat License basis means that you may perform an installation of the SOFTWARE for use in designing, testing and creating Developed Software by a single Developer on one or more computers, each with a single set of input devices, so long as 1) such computer/computers is/are used only by one single Developer at any given time and not concurrently and, 2) the user is the primary User to whom the license has been granted. Conversely, you may not install or use the SOFTWARE on a computer that is a network server or a computer at which the SOFTWARE is used by more than one Developer. You may not network the SOFTWARE or any component part of it, where it is or may be used by more than one Developer unless you purchase an additional Development License for each Developer. You must purchase another separate license to the SOFTWARE in order to add additional developer seats, whether the additional developers are accessing the SOFTWARE in a stand-alone environment or on a computer network.

The license rights granted under this Agreement may be limited to a specified number of days after you first install the SOFTWARE unless you supply information required to license or verify your licensed copy, as the case may be, within the time and the manner described during the SOFTWARE setup sequence and/or in the dialog boxes appearing during use of the SOFTWARE. You may need to verify the SOFTWARE through the use of the Internet, email or telephone; toll charges may apply. You may need to re-verify the SOFTWARE if you modify your computer hardware. Product verification is based on the exchange of information between your computer and C1. None of this information contains personally identifiable information nor can they be used to identify any personal information about you or any information you store in your computer. YOU ACKNOWLEDGE AND UNDERSTAND THAT THERE ARE TECHNOLOGICAL MEASURES IN THE SOFTWARE THAT ARE DESIGNED TO PREVENT UNLICENSED OR ILLEGAL USE OF THE SOFTWARE. YOU AGREE THAT C1 MAY USE SUCH MEASURES AND YOU AGREE TO FOLLOW ANY REQUIREMENTS REGARDING SUCH TECHNOLOGICAL MEASURES. YOU ACKNOWLEDGE AND AGREE THAT THE SOFTWARE WILL CEASE TO FUNCTION UNLESS AND UNTIL YOU VERIFY THE APPLICABLE SOFTWARE SERIAL KEY.

You agree that C1 may audit your use of the SOFTWARE for compliance with these terms at any time, upon reasonable notice. In the event that such audit reveals any use of the SOFTWARE other than in full compliance with the terms of this EULA, you shall reimburse C1 for all reasonable expenses related to such audit in addition to any other liabilities you may incur as a result of such non-compliance.

In all cases, (a) you may not use C1's name, logo, or trademarks to market your Developed Software without the express written consent of C1; (b) you must include the following C1 copyright notice in your Developed Software documentation and/or in the "About Box" of your Developed Software, and wherever the copyright/rights notice is located in the Developed Software (“Portions Copyright © ComponentOne, LLC 1991-2005. All Rights Reserved.”); (c) you agree to indemnify, hold harmless, and defend C1, its suppliers and resellers, from and against any claims or lawsuits, including attorney's fees that may arise from the use or distribution of your Developed Software; (d) you may use the SOFTWARE only to create Developed Software that is significantly different than the SOFTWARE.

3. Your Distribution License.

License to Distribute Developed Software. Subject to the terms and conditions in this EULA, you are granted the license to use and to distribute Developed Software on a royalty-free basis, provided that the Developed Software incorporates the SOFTWARE as an integral part of the Developed Software in machine-language compiled format (customarily an ".exe", or ".dll", etc.). You may not distribute, bundle, wrap or subclass the SOFTWARE as Developed Software which, when used in a "designtime" development environment, exposes the programmatic interface of the SOFTWARE. You may distribute, on a royalty-free basis, Redistributable Files with Developed Software only. You may not add or transfer the SOFTWARE license key to the computer where the Developed Software is installed. Users of the Developed Software may not use the SOFTWARE or the Redistributable Files, directly or indirectly, for development purposes. In particular, if you create a control (or user control) using the SOFTWARE as a constituent control, you are not licensed to distribute the control you created with the SOFTWARE to users for development purposes.

4. Specific Product Limitations. Notwithstanding anything in this EULA to the contrary, if the license you have purchased is for any of the following products, then the following additional limitations will apply:

a. ComponentOne Reports for .NET Designer Edition. ComponentOne Reports for .NET Designer Edition includes at least: 1) one dynamic link library file (c1.win.c1reportdesigner.dll) known as C1ReportDesigner Component, 2) one executable file (ReportDesigner.exe) known as C1ReportDesigner Application and, 3) the Source Code of the C1ReportDesigner Application. The C1ReportDesigner Component is subject to the general terms and restrictions set forth in this EULA. The C1ReportDesigner Application is an executable file used to design and prepare reports; the C1ReportDesigner Application may be distributed, free of royalties, only in conjunction with the Developed Software.

C1 hereby also grants you the right to use and to modify the C1ReportDesigner Application Source Code to create derivative works that are based on the licensed Source Code. You may distribute such derivative works, solely in object code format and exclusively in conjunction with and/or as a part of the Developed Software. You are expressly not granted the right to distribute, disclose or otherwise make available to any third party the licensed Source Code, any portion, modified version or derivative work thereof, in source code format.

C1 shall retain all right, title and interest in and to the licensed Source Code, and all C1 updates, modifications or enhancements thereof. Nothing herein shall be deemed to transfer any ownership or title rights in and to the licensed Source Code from C1 to you.

SOURCE CODE IS LICENSED TO YOU AS IS. C1 DOES NOT AND SHALL NOT PROVIDE YOU WITH ANY TECHNICAL SUPPORT FOR YOUR SOURCE CODE LICENSE.

b. VSView Reporting Edition (ActiveX). VSView Reporting Edition includes at least one executable file listed as “VSRptX.exe” (where X indicates the version number i.e.7,8, etc.), known as “Designer.” The file "VSRptX.exe”, or any upgrade or future versions of the Designer, are subject to the restrictions set forth in this EULA and may not be distributed with your Developed Software or in any other way.

c. Studio Products. You may not share the component parts of the Studio Products licensed to you with other Developers, nor may you allow the use and/or installation of such components by other Developers.

5. Updates/Upgrades; Studio Subscription. Subject to the terms and conditions of this EULA, the Licenses are perpetual. Updates and upgrades to the SOFTWARE may be provided by C1 from time-to-time, and, if so provided by C1, are provided upon the terms and conditions offered at that time by C1 in its sole discretion. C1 may provide updates and upgrades to the SOFTWARE for free or for any charge, at any time or never, and through its chosen manner of access and distribution, all in C1's sole discretion.

C1 licenses certain of its separately-licensed products bundled together in a product suite, called the C1 "Studio" product line (the "Studio Products"). The exact separately-licensed products that are bundled into the Studio Products may change from time-to-time in C1's sole discretion. If the SOFTWARE is identified as a C1 "Studio" product, then the SOFTWARE is one of the Studio Products. The SOFTWARE and the Studio Products are revised from time-to-time (meaning, for example, revised with updates, upgrades and, in the case of Studio products, some times changes to the mix of products included in the bundle). To receive any such revisions to the SOFTWARE or the Studio Products, as the case may be, you must have a valid SOFTWARE license or a valid Studio subscription. Together with the Licenses, the original purchaser is granted a one-year subscription from the date of purchase. Upon expiration, you must renew your license subscription to continue to be entitled to receive SOFTWARE and/or the Studio Products revisions as the case may be.

6. Serial Number. With your license, you will be issued a unique serial number (the "Serial Number") used for the activation of the SOFTWARE. The Serial Number is subject to the restrictions set forth in this EULA and may not be disclosed or distributed either with your Developed Software or in any other way. The disclosure or distribution of the Serial Number constitutes a breach of this EULA, the effect of which shall be the immediate termination and revocation of all the rights granted herein.

7. Evaluation Copy. If you are using an "evaluation copy", specifically designated as such by C1 on its website or elsewhere, then the Licenses are limited as follows: a) you are granted a license to use the SOFTWARE for a period of thirty (30) days counted from the day of installation (the "Evaluation Period"); b) upon completion of the Evaluation Period, you shall either i) delete the SOFTWARE from the computer containing the installation, or you may ii) obtain a paid license of the SOFTWARE from C1 or any of its resellers; and c) any Developed Software developed with the Evaluation Copy may not be distributed or used for any commercial purpose.

III. INTELLECTUAL PROPERTY.

1. Copyright. You agree that all right, title, and interest in and to the SOFTWARE (including, but not limited to, any images, photographs, animations, video, audio, music, text, and “applets” incorporated into the SOFTWARE), and any copies of the SOFTWARE, and any copyrights and other intellectual properties therein or related thereto are owned exclusively by C1, except to the limited extent that C1 may be the rightful license holder of certain third-party technologies incorporated into the SOFTWARE. The SOFTWARE is protected by copyright laws and international treaty provisions. The SOFTWARE is licensed to you, not sold to you. C1 reserves all rights not otherwise expressly and specifically granted to you in this EULA.

2. Backups. You may make a copy of the SOFTWARE solely for backup or archival purposes. Notwithstanding the foregoing, you may not copy the printed Documentation.

3. General Limitations. You may not reverse engineer, decompile, or disassemble the SOFTWARE, except and only to the extent that applicable law expressly permits such activity notwithstanding this limitation.

4. Software Transfers. You may not rent or lease the SOFTWARE. You may permanently transfer all of your rights under the EULA, provided that you retain no copies, that you transfer all the SOFTWARE (including all component parts, the media and printed materials, any updates, upgrades, this EULA and, if applicable, the Certificate of Authenticity), and that the transferee agrees to be bound by the terms of this EULA. If the SOFTWARE is an update or upgrade, any transfer must include all prior versions of the SOFTWARE.

5. Termination. Without prejudice to any other rights it may have, C1 may terminate this EULA and the Licenses if you fail to comply with the terms and conditions contained herein. In such an event, you must destroy all copies of the SOFTWARE and all of its component parts.

6. Export Restrictions. You acknowledge that the SOFTWARE is of U.S. origin. You acknowledge that the license and distribution of the SOFTWARE is subject to the export control laws and regulations of the United States of America, and any amendments thereof, which restrict exports and re-exports of software, technical data, and direct products of technical data, including services and Developed Software. You agree that you will not export or re-export the SOFTWARE or any Developed Software, or any information, documentation and/or printed materials related thereto, directly or indirectly, without first obtaining permission to do so as required from the United States of America Department of Commerce's Bureau of Export Administration ("BXA"), or other appropriate governmental agencies, to any countries, end-users, or for any end-uses that are restricted by U.S. export laws and regulations, and any amendments thereof, which include, but are not limited to: Restricted Countries, Restricted End-Users, and Restricted End-Uses.

These restrictions change from time to time. You represent and warrant that neither the BXA nor any other United States federal agency has suspended, revoked or denied your export privileges. C1 acknowledges that it shall use reasonable efforts to supply you with all reasonably necessary information regarding the SOFTWARE and its business to enable you to fully comply with the provisions of this Section. If you have any questions regarding your obligations under United States of America export regulations, you should contact the Bureau of Export Administration, United States Department of Commerce, Exporter Counseling Division, Washington DC. U.S.A. (202) 482-4811, http://www.bxa.doc.gov.

7. U.S. Government Restricted Rights. The SOFTWARE and documentation are provided with RESTRICTED RIGHTS. You will comply with any requirements of the Government to obtain such RESTRICTED RIGHTS protection, including without limitation, the placement of any restrictive legends on the SOFTWARE, and any license agreement used in connection with the distribution of the SOFTWARE. Manufacturer is ComponentOne, LLC, 201 South Highland Avenue , 3rd Floor, Pittsburgh, Pennsylvania 15206 USA. For solicitations issued by the Government on or after December 1, 1995 and the Department of Defense on or after September 29, 1995, the only rights provided in the software and documentation provided herein shall be those contained in this EULA. Under no circumstances shall C1 be obligated to comply with any Governmental requirements regarding the submission of or the request for exemption from submission of cost or pricing data or cost accounting requirements. For any distribution of the SOFTWARE that would require compliance by C1 with the Government's requirements relating to cost or pricing data or cost accounting requirements, you must obtain an appropriate waiver or exemption from such requirements for the benefit of C1 from the appropriate Government authority before the distribution and/or license of the SOFTWARE to the Government.

IV. WARRANTIES AND REMEDIES.

1. Limited Warranty. C1 warrants that the original media, if any, are free from defects for ninety (90) days from the date of delivery of the SOFTWARE. C1 also warrants that: (i) it has the full power to enter into this Agreement and grant the license rights set forth herein; (ii) it has not granted and will not grant any rights in the Software to any third party which grant is inconsistent with the rights granted to you in this Agreement; and (iii) the Software does not and will not infringe any trade secret, copyright, trademark or other proprietary right held by any third party and does not infringe any patent held by any third party. EXCEPT AS OTHERWISE PROVIDED IN THE PRECEDING SENTENCE, AND TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, C1 EXPRESSLY DISCLAIMS ANY WARRANTY FOR THE SOFTWARE, DOCUMENTATION AND ANYTHING ELSE PROVIDED BY C1 HEREBY AND C1 PROVIDES THE SAME IN “AS IS” CONDITION WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, THE IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK ARISING OUT OF USE OR PERFORMANCE OF THE SOFTWARE AND DOCUMENTATION REMAINS WITH YOU. THIS LIMITED WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS. YOU MAY HAVE OTHERS WHICH VARY FROM STATE TO STATE.

2. Limited Remedy. C1 PROVIDES NO REMEDIES OR WARRANTIES, WHETHER EXPRESS OR IMPLIED, FOR ANY SAMPLE APPLICATION CODE, REDISTRIBUTABLE FILES, TRIAL VERSION AND THE NOT FOR RESALE VERSION OF THE SOFTWARE. ANY SAMPLE APPLICATION CODE, TRIAL VERSION AND THE NOT FOR RESALE VERSION OF THE SOFTWARE ARE PROVIDED “AS IS”.

C1's entire liability and your exclusive remedy under this EULA shall be, at C1's sole option, either (a) return of the price paid for the SOFTWARE; (b) repair the SOFTWARE through updates distributed online or otherwise in C1's discretion; or (c) replace the SOFTWARE with SOFTWARE that substantially performs as described in the SOFTWARE documentation, provided that you return the SOFTWARE in the same manner as provided in Section I.2 for return of the SOFTWARE for non-acceptance of this EULA. Any media for any repaired or replacement SOFTWARE will be warranted for the remainder of the original warranty period or thirty (30) days, whichever is longer. THESE REMEDIES ARE NOT AVAILABLE OUTSIDE OF THE UNITED STATES OF AMERICA. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT SHALL C1 BE LIABLE FOR ANY DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS PROFIT, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, OR ANY OTHER PECUNIARY LOSS) ARISING OUT OF THE USE OR INABILITY TO USE THE SOFTWARE, EVEN IF C1 HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. BECAUSE SOME STATES/JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES IN CERTAIN CASES, THE ABOVE LIMITATION MAY NOT APPLY TO YOU.

V. MISCELLANEOUS.

1. This is the Entire Agreement. This EULA (including any addendum to this EULA included with the SOFTWARE) is the final, complete and exclusive statement of the entire agreement between you and C1 relating to the SOFTWARE. This EULA supersedes any prior and contemporaneous proposals, purchase orders, advertisements, and all other communications in relation to the subject matter of this EULA, whether oral or written. No terms or conditions, other than those contained herein, and no other understanding or agreement which in any way modifies these terms and conditions, shall be binding upon the parties unless entered into in writing executed between the parties, or by other non-oral manner of agreement whereby the parties objectively and definitively act in a manner to be bound (such as by continuing with an installation of the SOFTWARE, etc.). Employees, agents and other representatives of C1 are not permitted to orally modify this EULA.

2. You Indemnify C1. . You agree to indemnify, hold harmless, and defend C1 and its suppliers and resellers from and against any and all claims or lawsuits, including attorney's fees, which arise out of or result from your distribution of your Developed Software, your Developed Web Server Software or from your breach of any of the terms and conditions of this EULA.

3. Interpretation of this EULA. If for any reason a court of competent jurisdiction finds any provision of this EULA, or any portion thereof, to be unenforceable, that provision of this EULA will be enforced to the maximum extent permissible so as to effect the intent of the parties, and the remainder of this EULA will continue in full force and effect. Formatives of defined terms shall have the same meaning of the defined term. Failure by either party to enforce any provision of this EULA will not be deemed a waiver of future enforcement of that or any other provision. Except as otherwise required or superseded by law, this EULA is governed by the laws of the Commonwealth of Pennsylvania, without regard to its conflict of laws principles. The parties consent to the personal jurisdiction and venue of the Commonwealth of Pennsylvania, in the County of Allegheny, and agree that any legal proceedings arising out of this EULA shall be conducted solely in such Commonwealth. If the SOFTWARE was acquired outside the United States, then local law may apply.


Licensing FAQs

Licensing FAQs

This section describes the main technical aspects of licensing. It may help the user to understand and resolve licensing problems he may experience when using ComponentOne .NET and ASP.NET products.

What is Licensing?

How does Licensing Work?

Common Scenarios

Troubleshooting


What is Licensing?

What is Licensing?

Previous Next

Licensing is a mechanism used to protect intellectual property by ensuring that users are authorized to use software products.

Licensing is not only used to prevent illegal distribution of software products. Many software vendors, including ComponentOne, use licensing to allow potential users to test products before they decide to purchase them.

Without licensing, this type of distribution would not be practical for the vendor or convenient for the user. Vendors would either have to distribute evaluation software with limited functionality, or shift the burden of managing software licenses to customers, who could easily forget that the software being used is an evaluation version and has not been purchased.


How does Licensing Work?

How does Licensing Work?

Previous Next

ComponentOne uses a licensing model based on the standard set by Microsoft, which works with all types of components.

Note: The Compact Framework components use a slightly different mechanism for licensing than the other ComponentOne components due to platform differences.

When a user decides to purchase a product, he receives an installation program and a Serial Number. During the installation process, the user is prompted for the serial number that is saved on the system. (Users can also enter the serial number by clicking the "License" button on the About Box of any ComponentOne product.)

When a licensed component is added to a form or web page, Visual Studio asks the newly created component for licensing information. The component looks for licensing information stored in the system and generates a key, which Visual Studio saves in two files:

1. a "<projectName>.licenses" resource file which contains the actual key and

2. a "licenses.licx" file that contains references to those resources.

These files are automatically added to the project.

Note that the licenses.licx file is usually not shown in the Solution Explorer; it appears if you press the "Show All Files" button in the Solution Explorer's toolbox, or select "Project | Show All Files" from Visual Studio's main menu.

Later, when the component is created at run time, it gets passed the key that was created at design time and can decide whether to simply accept the key, to throw an exception and fail altogether, or to display some information reminding the user that the software has not been licensed.

All ComponentOne products are designed to display licensing information if the product is not licensed. None will throw licensing exceptions and prevent applications from running.


Common Scenarios

Common Scenarios

Creating components at design time

Creating components at run time

Inheriting from licensed components

Using licensed components in console applications

Using licensed components in Visual C++ applications


Creating components at design time

Creating components at design time

This is the most common scenario and also the simplest: the user adds one or more controls to the form, the licensing information is stored in the licenses.licx file, and the component works.

Note that the mechanism is exactly the same for Windows Forms and Web Forms (ASP.NET) projects.


Creating components at run time

Creating components at run time

This is also a fairly common scenario. You do not need an instance of the component on the form, but would like to create one or more instances at run time.

In this case, the project will not contain a licenses.licx file (or the file will not contain an appropriate key for the component) and therefore licensing will fail.

To fix this problem, add an instance of the component to a form in the project. This will create the licenses.licx file and things will then work as expected. (The component can be removed from the form after the licenses.licx file has been created).


Inheriting from licensed components

Inheriting from licensed components

If a component that inherits from a licensed component is created, the licensing information to be stored in the form is still needed. This can be done in two ways:

1. Add a LicenseProvider attribute to the component.

This will mark the component as licensed. When a component is added to a form, Visual Studio will create and manage the licenses.licx file, and the base class will handle the licensing process as usual. No additional work is needed. For example:

[LicenseProvider(typeof(LicenseProvider))]

class MyGrid: C1.Win.C1FlexGrid.C1FlexGrid

{

//

}

2. Add an instance of the base component to the form.

This will embed the licensing information into the licenses.licx file as in the previous scenario, and the base component will find it and use it. As before, the extra instance can be deleted after the licenses.licx file has been created.


Using licensed components in console applications

Using licensed components in console applications

When building console applications, there are no forms to add components to, and therefore Visual Studio won't create a licenses.licx file.

In these cases, create a temporary Windows Forms application and add all the desired licensed components to a form. Then close the Windows Forms application and copy the licenses.licx file into the console application project.

Make sure the licensex.licx file is configured as an embedded resource. To do this, right-click the licenses.licx file in the Solution Explorer window and select Properties. In the property window, set the "Build Action" property to "Embedded Resource".


Using licensed components in Visual C++ applications

Using licensed components in Visual C++ applications

It seems there is a bug in VC++ 2003. The licenses.licx is ignored during the build process, therefore the licensing information is not included in VC++ applications.

To fix this problem, extra steps must be taken to compile the licensing resources and link them to the project. Note the following:

1. Build the C++ project as usual. This should create an exe file and also a licenses.licx file with licensing information in it.

2. Copy the licenses.licx file from the app directory to the target folder (Debug or Release).

3. Copy the C1Lc.exe utility and the licensed dlls to the target folder. (Don't use the standard lc.exe, it has bugs.)

4. Use C1Lc.exe to compile the licenses.licx file. The command line should look like this:

5. c1lc /target:MyApp.exe /complist:licenses.licx /i:C1.Win.C1FlexGrid.dll

6. Link the licenses into the project. To do this, go back to Visual Studio, right-click the project, select properties, and go to the Linker/Command Line option. Enter the following:

7. /ASSEMBLYRESOURCE:Debug\MyApp.exe.licenses

8. Rebuild the executable to include the licensing information in the application.


Troubleshooting

Troubleshooting

We try very hard to make the licensing mechanism as unobtrusive as possible, but problems may occur for a number of reasons.

Below is a description of the most common problems and their solutions.


I have a licensed version of a ComponentOne product but I still get the splash screen when I run my project.

I have a licensed version of a ComponentOne product but I still get the splash screen when I run my project.

Previous Next

If this happens, there must be a problem with the licenses.licx file in the project. It either doesn't exist, contains wrong information, or is not configured correctly.

First, try a full rebuild ("Rebuild All" from the Visual Studio Build menu). This will usually rebuild the correct licensing resources.

If that fails, follow these steps:

1. Open the project and go to the Solution Explorer window.

2. Click the "Show All Files" button on the top of the window.

3. Find the licenses.licx file and delete it.

4. Close the project and reopen it.

5. Open the main form and add an instance of each licensed control.

6. Check the Solution Explorer window, there should be a licenses.licx file there.

7. Rebuild the project using the "Rebuild All" option (not just "Rebuild").


I have a licensed version of a ComponentOne product on my web server but the components still behave as unlicensed.

I have a licensed version of a ComponentOne product on my web server but the components still behave as unlicensed.

Previous Next

There is no need to install any licenses on machines used as servers and not used for development.

The components must be licensed on the development machine, therefore the licensing information will be saved into the executable (exe or dll) when the project is built. After that, the application can be deployed on any machine, including web servers.


I downloaded a new build of a component that I have purchased, and now I'm getting the splash screen when I build my projects.

I downloaded a new build of a component that I have purchased, and now I'm getting the splash screen when I build my projects.

Previous Next

Make sure that the license key is still valid. If you licensed the component over a year ago, your subscription may have expired. In this case, you have two options:

Option 1 - Renew your subscription to get a new license key.

If you choose this option, you will receive a new key that you can use to license the new components (from the installation utility or directly from the About Box).

The new subscription will entitle you to a full year of upgrades and to download the latest maintenance builds directly from http://prerelease.componentone.com/.

Option 2 – Continue to use the components you have.

Subscriptions expire, products do not. You can continue to use the components you received or downloaded while your subscription was valid.


Technical Support

Technical Support

ComponentOne WebMenus and WebBars for ASP.NET is developed and supported by ComponentOne LLC, a company formed by the merger of APEX Software Corporation and VideoSoft. You can obtain technical support using any of the following methods:

ComponentOne Web Site

ComponentOne HelpCentral

Internet E-mail

Peer-to-Peer Newsgroup

Documentation


ComponentOne Web Site

ComponentOne Web Site

The ComponentOne Web site at www.componentone.com provides a wealth of information and software downloads for Preview for .NET users, including:

· Descriptions of the various support options available through the ComponentOne Service Team.

· Answers to frequently asked questions (FAQ's) about our products, organized by functionality. Please consult the FAQ's before contacting us directly, as this can save you time and also introduce you to other useful information pertaining to our products.

· Free product updates, which provide you with bug fixes and new features.


ComponentOne HelpCentral

ComponentOne HelpCentral

ComponentOne HelpCentral is the new online resource for Visual Studio developers and Help authors. Visit HelpCentral to get information on ComponentOne products, view online demos, get Tech Tips and answers to frequently asked questions (FAQ's), search the ComponentOne knowledgebase and more!


Internet E-mail

Internet E-mail

For technical support through the Internet, e-mail us at:

Support.Command.NET@componentone.com

To help us provide you with the best support, please include the following information when contacting ComponentOne:

· Your ComponentOne product serial number.

· The version and name of your operating system.

· Your development environment and its version.

For more information on technical support, go to:

www.componentone.com/support


Peer-to-Peer Newsgroup

Peer-to-Peer Newsgroup

ComponentOne also sponsors peer-to-peer newsgroups for C1WebCommand users. ComponentOne does not offer formal technical support in this newsgroup, but instead sponsors it as a forum for users to post and answer each other's questions regarding C1WebCommand. However, ComponentOne may monitor the newsgroups to ensure accuracy of information and provide comments when necessary. You can access the newsgroup from the ComponentOne Web site at http://helpcentral.componentone.com/Newsgroups.aspx.


Documentation

Documentation

ComponentOne documentation is available with each of our products in HTML Help, Microsoft Help 2.0 (.NET, ASP.NET and Mobile Device products only), and PDF format. All of the PDFs are also available on HelpCentral. If you have suggestions on how we can improve our documentation, please email the Documentation team. Please note that e-mail sent to the Documentation team is for documentation feedback only. Technical Support and Sales issues should be sent directly to their respective departments.


Redistributable Files

Redistributable Files

ComponentOne WebCommand for .NET is developed and published by ComponentOne LLC. You may use it to develop applications in conjunction with Microsoft Visual Studio or any other programming environment that enables the user to use and integrate the control(s). You may also distribute, free of royalties, the following Redistributable Files with any such application you develop to the extent that they are used separately on a single CPU on the client/workstation side of the network:

· C1.Web.C1Command.dll

· C1.Web.C1Command.Classic.2.dll (if using Visual Studio 2005)

Site licenses are available for groups of multiple developers. Please contact Sales@ComponentOne.com for details.


Namespaces

Namespaces

Namespaces organize the objects defined in an assembly. Assemblies can contain multiple namespaces, which can in turn contain other namespaces. Namespaces prevent ambiguity and simplify references when using large groups of objects such as class libraries.

The general namespace for ComponentOne Web products is C1.Web. The namespace for the C1WebCommand is C1.Web.C1Command. The following code fragment shows how to declare a C1WebMenu (which is one of the core WebMenus and WebBars for ASP.NET classes) using the fully qualified name for this class:

· Visual Basic

· C#

· Delphi

Namespaces address a problem sometimes known as namespace pollution, in which the developer of a class library is hampered by the use of similar names in another library. These conflicts with existing components are sometimes called name collisions.

For example, if you create a new class named C1WebMenu, you can use it inside your project without qualification. However, the C1.Web.C1Command.dll assembly also implements a class called C1WebMenu. So, if you want to use both C1WebMenu classes in the same project, you must use a fully qualified reference to make the reference unique. If the reference is not unique, Visual Studio .NET produces an error stating that the name is ambiguous. The following code snippet demonstrates how to declare these objects:

· Visual Basic

· C#

· Delphi

Fully qualified names are object references that are prefixed with the name of the namespace where the object is defined. You can use objects defined in other projects if you create a reference to the class (by choosing Add Reference from the Project menu) and then use the fully qualified name for the object in your code.

Fully qualified names prevent naming conflicts because the compiler can always determine which object is being used. However, the names themselves can get long and cumbersome. To get around this, you can use the Imports statement (using in C#) to define an alias — an abbreviated name you can use in place of a fully qualified name. For example, the following code snippet creates aliases for two fully qualified names, and uses these aliases to define two objects:

· Visual Basic

· C#

· Delphi

If you use the Imports statement without an alias, you can use all the names in that namespace without qualification provided they are unique to the project.


Creating an ASP.NET Project

Creating an ASP.NET Project

This topic demonstrates how to create a new ASP.NET project.

1. From the File menu in .NET, select New and click Project. The New Project dialog box opens.

2. Under Project Types, choose either Visual Basic Projects or Visual C# Projects, and select ASP.NET Web Application from the list of Templates in the right pane.

3. Enter a URL for your application in the Location field and click OK.

4. Note: The Web server must have IIS version 5 or later and the .NET Framework installed on it. If you have IIS on your computer, you can specify http://localhost for the server.


Adding the C1WebCommand Components to the Toolbox

Adding the C1WebCommand Components to the Toolbox

When you install C1WebCommand and select it from the .NET components in the Visual Studio’s toolbox customization dialog, the following new components will appear on your toolbox:

· C1WebMenu

· C1WebToolBar

· C1WebTopicBar

C1WebMenu is the control representing a root menu – a menu that (unlike submenus) is always visible on your form. After you have placed it on the form, you can add menu items to it by right-clicking the menu and selecting Edit menu from the context menu exposes the C1WebMenu Editor, which can be used to add, delete, and move menu items and submenus in the hierarchy.. You can select either horizontal or vertical layout for the root menu. Several root menus can be placed on the same form.

C1WebToolBar represents a toolbar. Like the root menu, it is also always visible on the form. Buttons (of the type C1WebToolBarButton) can be added, toggled, and separated to the toolbar by selecting Append Button, Append Toggle Group, and Append Separator, from the toolbar’s context menu, respectively. Also use the design-time context menu to change the style of the C1WebToolBar by selecting Auto Format and choosing a pre-defined scheme from the Auto Format dialog box.

C1WebTopicBar represents a topicbar web control. Like the root menu and toolbar, it is always visible on the form. It consists of two types of groups that can be collapsed or expanded: C1WebTopicBarItemsGroup and C1WebTopicBarPanelGroup. The C1WebTopicBar control allows you to implement elegant windows XP-style or custom designed navigation panels on your web pages.

After installing C1WebCommand on your computer, you need to add the C1WebCommand components to the Visual Studio Toolbox. To do this, follow these steps:

1. Open the Visual Studio IDE (Microsoft Development Environment). Make sure the Toolbox is visible (select Toolbox in the View menu if necessary). Right-click the Toolbox to open the toolbox context menu.

2. If you want the C1WebCommand for ASP.NET components to appear on its own tab in the Toolbox, select Add Tab from the context menu and type in the tab name, for example, “C1WebCommand”. Select the tab where you want the component to appear. Right-click that tab and select Customize Toolbox… from the context menu. The Customize Toolbox dialog box will open.

3. In the Customize Toolbox dialog box, go to the .NET Framework Components tab. Sort the list by Namespace (click the Namespace column header) and check the check boxes for C1WebMenu C1WebToolBar, and C1WebTopicBar.

4. The C1WebCommand components will appear under the C1WebCommand tab. The picture below illustrates how the C1WebMenu, C1WebToolBar, and C1WebTopic components look when they are added to the form.


Using C1WebCommand

Using C1WebCommand

The three main components for building menu systems with C1WebCommand are C1WebMenu, C1SubMenu and C1MenuItem. Menus are trees. The root of each menu tree is always a C1WebMenu component.

Creating a Menu

Menu Item Actions

Menu and Menu Item Styles

XML Support


Creating a Menu

Creating a Menu

To create a new menu tree, select C1WebMenu from the toolbox and place it on your web form. You can put several C1WebMenu objects on one form. For a menu to be functional, one or more menu items (of the type C1MenuItem) should be added to it. You can add, delete, and move items and submenus with the external C1WebMenu Editor. The editor can be called by right-clicking on the menu and selecting the Edit command from the context menu. See Using the C1WebMenu Editor for details.


Menu Item Actions

Menu Item Actions

Ultimately, a menu system must have actions associated with the menu items to be of any use. C1WebCommand’s menu items allow you to associate one of the following three kinds of actions with them:

· Invoke the form’s postback

· Open a URL

· Arbitrary piece of client-side code

To make an item invoke the postback event when the user clicks it, attach an event handler to the item’s Click or Command events, or to the ItemClick or ItemCommand event of the menu containing the item. When a menu item is clicked, the form is posted back to the server, and the corresponding event fires for the menu item (if an item has both Click or Command event handlers attached, they are fired in sequence). For Command events and ItemCommand, the item’s CommandName and CommandArgument properties are passed to the event handler. For the Click event, the item, clicked by the user is passed to the event handler.

Both C1SubMenu and C1WebMenu classes have ItemClick and ItemCommand events. However, C1SubMenu differs from C1WebMenu by one feature. In C1SubMenu, the ItemClick and ItemCommand events occur only when the user clicks the item that is directly nested in the submenu. Whereas, in C1WebMenu, these events occur when the user clicks any item in the menu.

To make an item open in another location when clicked, specify that location’s URL in the item’s LinkUrl property. When the user clicks such an item, the specified location will be opened in the same window.

The third option allows you to execute arbitrary client-side script code when the menu item is clicked. To do this, set the value of the item’s Script property to the string containing the script. That string will be executed as a script when the user clicks the item.

Do not associate more than one action option with a specific item (e.g. do not specify both a Script and a LinkUrl for the same item). By doing this, it becomes ambiguous as to which action option should take precedence. Note: In this version of C1WebCommand, Script takes precedence over LinkUrl, and that in turn takes precedence over Click or Command event handlers, but it is not guaranteed that this will hold true in future versions.

It is perfectly valid and in fact can be useful to associate both an action and a submenu with the same item. E.g. an item can have the URL of your company’s web home page specified as the value of its LinkUrl, and have a submenu with URLs of different pages inside your web site. In that case, clicking the menu item will open the home page, while opening the submenu and clicking an item inside will take the user directly to a specific location within the site.


Menu and Menu Item Styles

Menu and Menu Item Styles

The way C1WebCommand menus and menu items look can be customized using styles. Both menus and menu items are Web Controls (see Class Hierarchy for details), and as such both have ControlStyle property where colors, fonts and other display attributes can be defined.

C1WebCommand defines a special class C1MenuItemStyle which (in addition to the .NET framework’s standard System.Web.UI.WebControls.Style class) is used to determine the look of menu items. The C1MenuItemStyle class encapsulates properties relevant to the display of menu items, and is in many respects similar to the System.Web.UI.WebControls.Style class. Please see the reference section for details.

The following properties affect how a particular menu or menu item look:

· Menu’s ControlStyle. Style attributes defined by this property are applied to the HTML element of the menu itself. Because menu items are HTML children of the menu element, their look is also influenced by this style.

· Menu’s ItemStyle. Style attributes defined by this property are applied to HTML elements of the individual menu items in the menu.

· Menu item’s ControlStyle. Style attributes defined by this property are applied to the HTML element of the menu item. Attributes defined by this property (if set) override same attributes defined by the ItemStyle of the parent menu.

· When an item in a menu is selected, menu’s SelectedItemStyle and item’s own SelectedStyle are applied to the item (in that order).

· If an item in a menu is disabled, menu’s DisabledItemStyle and item’s own DisabledItemStyle are applied to the item (in that order).

· Although submenus are not HTML children of the parent menu or item, a special feature of C1WebMenus provides inheritance of style attribute from parent to child menus. Each submenu has a Boolean property InheritParentStyle. If that property is set to true (which is the default), all attributes in the menu’s style properties inherit from the attributes in the corresponding style of the parent menu. Thus, when creating a menu tree, you only need to specify the display properties of the root menu. All nested menus will automatically inherit styles from the root menu and hence will look consistently even if you later change the style of the root menu.

· Finally note, that in addition to (or instead of) specifying individual style attributes (such as color), for all style properties you can specify the name of the CSS class (CssClass property), and the style corresponding to that class will be applied to the item. Inheritance rules described above apply to CssClass also.


XML Support

XML Support

XML support for persisting menus is provided in the following forms:

· Methods are provided that can persist (save to and load from XML) menu trees at runtime. Persistence of styles controlling the look of the menus is optional.

· At design time, the menu can be saved to an XML file using the Save Menu as XML… menu command of C1WebMenu editor and loaded from XML file using Load Menu From XML command.


Using the C1WebMenu Editor

Using the C1WebMenu Editor

Introduction

C1WebMenu editor is an application in the C1.Web.C1Command.MenuEditor.dll assembly. The C1WebMenu editor's main part of its application consists of a windows form which conveniently allows the users to edit the C1WebMenu. Using the editor, the user has a possibility to add, delete, and move items and submenus in the hierarchy.

Another favorable feature is the ease of changing properties and event handlers of menu and submenu items. C1WebMenu editor also enables menu saving and loading from xml files.

For the user's convenience, the possibility of previewing the working menu is supported in editing mode.


Base parts of the editor

Base parts of the editor

This topic provides a visual tour of the interface.

Upon startup, the application will be displayed as shown below:

C1WebMenuEditor's Tabs

C1WebMenu Editor's Main Menu

C1WebMenu Editor's Toolbar

C1WebMenu Editor's Remaining Elements


C1WebMenuEditor's Tabs

C1WebMenuEditor's Tabs

C1WebMenuEditor consist of two important tabs: Edit and Preview tab.

The Edit tab will look like this:

When the user clicks on the Edit tab he/she can edit his/her menus.

The Preview tab will look like this:

The Preview tab is a nice feature for the users when they want to see what their menus will look like at design time. The Preview tab saves the user's time from running their program every time to see what their changes look like at run-time.


C1WebMenu Editor's Main Menu

C1WebMenu Editor's Main Menu

The File menu of the editor has the following structure:

Command | Description
Load From XML | Loads the menu tree from XML.
Save As XML | Saves the menu tree as XML.
Exit | Closes the editor and saves all changes.

The Edit menu of the editor has the following structure:

Command | Description
Insert Item | Inserts a new menu item before selected item in tree.
Append item | Appends a new item to the end at the same level.
Add child | Adds a new menu item as a child of the selected item or submenu (or a webmenu). Creates a new submenu if it is necessary.
Cut | Removes the menu element (with nested elements) from the workspace and copies it to the internal clipboard.
Copy | Copies the menu element (with nested elements) to the internal clipboard.
Paste | Copies the contents of the internal clipboard into the workspace.
Delete | Removes the menu element (with nested elements) from the workspace.

The Help menu of the editor has the following structure:

Command | Description
Dynamic help | Shows help about C1WebCommand.
About | Shows information about the installed version of C1WebCommand.


C1WebMenu Editor's Toolbar

C1WebMenu Editor's Toolbar

The C1WebMenu Editor contains the following items in its toolbar:

Item | Description
Move item up | Moves a menu item up (without change of level).
Move item down | Moves a menu item down (without change of level).
Move item to Parent | Changes the level of an item “up”. Item moves to the same level as its Parent.
Move item to Child | Changes the level of an item “low”. Item moves to child items of the previous item. A new submenu is created if it is necessary.
Insert Item | Inserts a new menu item before selected item in the tree.
Append item | Appends a new item to the end at the same level.
Add child | Adds a new menu item as a child of selected item or submenu (or a webmenu). Creates a new submenu if it is necessary. Same as in the main menu.
Cut | Removes the menu element (with nested elements) from the workspace and copies it to the internal clipboard.
Copy | Copies the menu element (with nested elements) to the internal clipboard.
Paste | Copies the contents of the internal clipboard into the workspace.
Delete | Removes a menu element (with nested elements) from the workspace.


C1WebMenu Editor's Remaining Elements

C1WebMenu Editor's Remaining Elements

The remaining elements that exist in the C1WebMenuEditor are listed below:

Item | Description
Tree view of the menu | Control, in which menu is displayed as a “tree”.
Property grid | The control used to modify the properties and events of the selected element.
Preview tab | Allows a user to see how the menu will look during runtime.
OK button | Closes the edit dialog box and saves all the changes.
Cancel button | Cancels the editing and reverts the changes made in the editing mode.
Help button | Shows help about C1WebCommand.
Tree view context menu | Contains the same commands as the Edit submenu of the main menu.
Property grid context menu | Has the following commands: · Reset – Resets the value of the selected property. · Description – Displays the name and description of the selected property in the last rectangular box of the Property Grid .


Using the C1WebTopicBar

Using the C1WebTopicBar

Introduction

C1WebTopicBar is a Web control that provides users the possibility to implement elegant Windows XP – styled or custom designed navigation panels on their Web Pages. C1WebTopicBar consists of groups that contain items. The items can be collapsed or expanded.

C1WebTopicBar provides the user many capabilities such as: implementing cascading style sheets, combining built-in functions from other controls into the panel groups, dragging and dropping group headers, and modifying or customizing the appearance of the C1WebTopicBar. Also, C1WebTopicBar is very simple to use because the user can easily make multiple changes to their C1WebTopicBar by using the C1WebMenu Editor. As a result, it will take the user less time to create powerful navigation panels.

The picture below is a basic design of the C1WebTopicBar. In this particular design there are three groups and each group contains several items. There is no limit in the amount of items each group can hold.

C1WebTopicBar's primary objects are Groups and Items.

There can be two types of groups:

· One can be based on a collection of navigation items, such as the picture above. The default name for groups based on a collection of navigation items is called C1WebTopicBarItemsGroup.

· Or it can be a group with an associated Panel control that allows placing any web elements/controls on its surface by the drag-and-drop operation at design-time. The default name for this type of group is called C1WebTopicBarPanelGroup.

The picture below shows an example of a Panel-based group:

Groups based on items can be easily setup to represent a set of links; it has an optional group header and mandatory group body. You can use the NavigateUrl property to set links for each item.

By combining both the panel-based group and a group where you have a collection of items you have the ability to create powerful navigation panels on your Web Pages. For example, using a panel-based group you can modify the navigation panel's behavior by changing the group's style or function.


C1WebTopicBarCustomGroup Collection Editor

C1WebTopicBarCustomGroup Collection Editor

The picture below shows the collection of properties for C1WebTopicBarCustomGroup. The C1WebTopicBarCustomGroup Collection Editor makes it easy for the user to view and modify his or her groups. Also, when the user selects the group he or she wants to modify, the group's name appears above the group's properties.

The following properties are available below for the user in the C1WebTopicBarCustomGroup:

Appearance Properties

The appearance properties change the appearance of the group. Below are the appearance properties and their functions:

Property Name | Description
CaptionImageHeight | Gets or sets the height of the image set in the CaptionImageUrl property of header styles.
CaptionImageWidth | Gets or sets the width of image set in the CaptionImageUrl property of header styles.
CaptionLabelHorizontalAlign | Gets or sets the default value for the horizontal alignment of the labels in the headers.
CaptionVerticalAlign | Gets or sets the default value for the vertical alignment of the labels in the headers.
Text | Gets or sets text which is displayed in the group header.
TextHeight | Gets or sets the height of the group header text.
ToolTip | Gets or sets the ToolTip text displayed when the mouse pointer rests over the group.

Behavior Properties

The behavior properties change the behavior of the group. Below are the behavior properties and their functions:

Property Name | Description
AllowSelectItem | Determines whether a user will be able to select an item in the group.
Collapsed | If set to true, it collapses the group.
Enabled | Gets or sets a value indicating whether the group is collapsed or not.
EnableExpandCollapse | Gets or sets a value indicating whether a user can expand or collapse the group by double-clicking on the header or clicking on the indicator image.
Visible | Gets or sets a value indicating whether the group is visible or not.
WrapText | Gets or sets a value that indicates whether the text of the items is wrapped.

Misc Properties

The miscellaneous property and its function are listed below:

Property Name | Description
Items | Gets or sets the item that is located at a specified index of the collection.

Style Properties

The style properties change the group's style. The style properties and their functions are listed below:

Property Name | Description
CollapsedHeaderStyle | Default style for the group headers in the collapsed state.
DisabledGroupStyle | Default style for the disabled groups.
DisabledHeaderStyle | Default style for the group headers in the disabled state.
DisabledItemStyle | Default style for the items in the disabled state.
ExpandedHeaderStyle | Default style for the group headers in the expanded state.
GroupStyle | Default style for the groups.
ItemStyle | Default style for the items.
MouseOverCollapsedHeaderStyle | Default style for the group headers in the collapsed state when mouse hovers over them.
MouseOverExpandedHeaderStyle | Default style for the group headers in the expanded state when mouse hovers over them.
MouseOverItemStyle | Default style for the items when the mouse hovers over them.
SelectedItemStyle | Default style for the items in the selected state.

C1WebTopicBar control

Here is a picture that depicts several properties from the C1WebTopicBar control:


C1WebTopicBarPanelGroup Properties

C1WebTopicBarPanelGroup Properties

C1WebTopicBarPanelGroup

The picture below shows the collection of properties for C1WebTopicBarPanelGroup. The panel group includes all the same properties that the C1WebTopicBarItemsGroup has, plus some additional appearance properties. The additional appearance properties include the following: BodyHeight, HorizontalAlign, and VerticalAlign.

Appearance Properties

The appearance properties change the appearance of the group. The appearance properties and their functions are listed below:

Property Name | Description
BodyHeight | Gets or sets the height of the group body (container area where controls can be placed).
CaptionImageHeight | Gets or sets the height of the image set in the CaptionImageUrl property of the header styles.
CaptionImageWidth | Gets or sets the width of the image set in the CaptionImageUrl property of the header styles.
HorizontalAlign | Specifies the horizontal alignment of controls within a group body.
Text | Gets or sets the text which is displayed in the group header.
TextHeight | Gets or sets the height of the group header text.
ToolTip | Gets or sets the ToolTip text displayed when the mouse pointer rests over the group.
VerticalAlign | Specifies the vertical alignment of controls within a group body.

The remaining properties for C1WebTopicBarPanelGroup are the same as C1WebTopicBarItemsGroup.


C1WebTopicBarItem Collection Editor

C1WebTopicBarItem Collection Editor

C1WebTopicBarItems

The picture below shows the collection of properties for C1WebTopicBar's items. The C1WebTopicBarItemCollection Editor makes it easy for the user to view and modify his or her items.

The following properties are available for the user in the C1WebTopicBarItem Collection Editor:

Appearance Properties

The appearance properties change the appearance of the item. The appearance properties and their functions are listed below:

Property Name | Description
ImageUrl | Gets or sets the height of image set in the CaptionImageUrl property of the header styles.
NavigateUrl | Gets or sets the width of image set in the CaptionImageUrl property of the header styles.
Text | Gets or sets text which is displayed in the group header.
ToolTip | Gets or sets the ToolTip text displayed when the mouse pointer rests over the group.

Behavior Properties

The behavior properties change the item's behavior. The behavior properties and their functions are listed below:

Property Name | Description
CausesValidation | Determines whether validation is performed when the item is clicked.
ClientScripts | Collection of client-side scripts associated with the item.
CommandArgument | Gets or sets an optional parameter passed to the ItemClick and ItemSelected events of the C1WebTopicBar component along with the associated CommandName.
CommandName | Gets or sets the command name associated with the C1WebTopicBarItem passed to the ItemClick and ItemSelected events of the C1WebTopicBar component.
Enabled | Gets or sets a value indicating whether the group is collapsed or not.
EnableExpandCollapse | Gets or sets a value indicating whether a user can expand or collapse the group by double-clicking on the header or clicking on the indicator image.
Script | A script attached to the mousedown event (alias for ClientScripts["onclick"]).
Selected | Determines whether the item is selected or not.
Target | Gets or sets the target window or frame to display the link.
Visible | Gets or sets a value indicating whether the group is visible or not.
WrapText | Gets or sets a value that indicates whether the item's text is wrapped.

Style Properties

The style properties change the item's style. The style properties and their functions are listed below:

Property Name | Description
DisabledItemStyle | Default style for the items in the disabled state.
ItemStyle | Default style for the items.
MouseOverItemStyle | Default style for the items when the mouse hovers over them.
SelectedItemStyle | Default style for the items in the selected state.


Using the Auto Format Dialog box

Using the Auto Format Dialog box

The Auto Format Dialog box allows you to choose a preformatted style to apply to C1WebMenu, C1WebToolBar or the C1WebTopicBar control.

1. Right-click on the C1WebMenu, C1WebToolBar or C1WebTopicBar control and select Auto Format from the context menu. The Auto Format dialog box opens.

2. Select one of the predefined formats under Select a Scheme in the left pane. You can preview each format in the right pane.

3. Click OK.


C1WebCommand Samples

C1WebCommand Samples

Please be advised that this ComponentOne software title is accompanied by various sample projects and/or demos, which may or not make use of other ComponentOne development tools. While the sample projects and/or demos included with the software are used to demonstrate and highlight the product’s features, and how the control may be integrated with the rest of the ComponentOne product line, some of the controls used in the demo/sample project may not be included with the purchase of certain individual products.

The ComponentOne Samples are also available at http://helpcentral.componentone.com/ProductResources.aspx.


C# Samples

C# Samples

CreatingMenusInCode | This sample shows to create and wire up C1WebCommand menus in code.
CreatingSubMenusInCode | This sample shows how to create menus trees in code with C1WebCommand. This sample is based on the CreatingMenusInCode sample. In addition to it, this sample shows you how to create and wire up event handlers submenus in your C# code.
MenuNavigation | This sample shows various ways to navigate through the menus.
Sample1 | This sample shows some of the features of C1WebCommand. This sample uses C1MenuItem and C1SubMenu controls.
Sample2 | This sample uses the C1WebToolBarButton, C1WebMenu, and C1WebToolBar controls.
TabStrip | This demo shows how to create TabStrip-like functionality using C1WebCommand. For a TabStrip's head, C1WebToolBar is used. For a TabStrip's body, C1WebTopicBar is used.
WebCommandTips | This sample shows the various aspects of using webmenu and toolbars. It uses CSS, programmic creating, client and server events, and inside the web user control.
Samples for C1WebTopicBar in C1WebTopicBar\CS\
ButtonView | This sample shows how the user can build a button-like topic bar using the panel groupand ItemSelected event. This sample uses the C1WebTopicBar control.
ClientEvents | This sample shows how the user can use the client-side events. This sample uses the C1WebTopicBar control.
ClientEvents2 | This sample shows how the user can use the client-side events. This sample uses the C1WebTopicBar control.
Layouts | This sample demonstrates how to use the LoadLayout and SaveLaout methods This sample uses the C1WebTopicBar control.
RunTime | This sample shows how to create C1WebTopicBar's elements in code.
ServerEvents | This sample demonstrates how to use the ItemClick, ItemSelected, GroupExpanded and GroupCollapsed server events.
TopicBarPanelInCode | This sample demonstrate how to do the following: Add panel groups to C1WebTopicBar control. Add a custom set of web controls to the panel group.
TreeView-Like | This sample shows how to make a TreeView-like functionality using the C1WebTopicBar control.
UsingCss | This sample demonstrates how to use the CSS for defining the C1WebTopicbar’s appearance. This sample uses the C1WebTopicBar control.
UsingCss2 | This sample demonstrates how to use the MS DirectX filters in CSS to define the C1WebTopicbar’s appearance. This sample uses the C1WebTopicBar control.
XPSilver | This sample shows how the user can build a XP-like topic bar with a Silver color scheme. It also shows how to use the ItemClick event. This sample uses the C1WebTopicBar control.


Visual Basic Samples

Visual Basic Samples

ContextMenus

This sample shows how to create and use C1WebMenu in context mode. The sample consists of the 3 pages:

DefaultContextMenu.aspx. Demonstrates how to create a default context menu using the C1WebMenu.

ControlContextMenu.aspx. Demonstrates how to create a control-specific context menu that appears when user right-clicks the specified control.

CustomContextMenu.aspx. Demonstrates how to set up and call a context menu using the function c1c_showContextMenu(id, x, y).

TopicBarInUserControl

Shows how to use C1WebTopicBar inside web user control and possible ways of navigation. Set Frameset1.htm as start page. The topic bar control is inside topicbar.ascx user control. In the sample use can see how to use link items for navigation in the same frame and in another frame.

TopicBarNavigation1

This sample shows how to use the Item.CommandArgument for navigation.


Task-Based Help

Task-Based Help

The task-based help assumes that you are familiar with programming in Visual Basic.NET. By following the steps outlined in the help, you will be able to utilize the features of ComponentOne WebMenus and WebBars for ASP.NET.

WebMenus Tasks

Advanced WebMenu Tasks

Context Menu Tasks

WebToolbars Tasks

C1WebMenuEditor Tasks

WebTopicBar Tasks


WebMenus Tasks

WebMenus Tasks

Adding a Menu

Adding a Sub-Menu at Design-Time

Changing the Menu from Vertical to Horizontal

Changing the Menu Direction to Right to Left

Changing the Menu Direction to Left to Right

Changing the Menu to Bottom to Top

Modifying the Appearance of the Menus

Using the Target Property in C1WebMenu to Navigate in a Frameset

Using the Target Property in C1WebMenu to Navigate in an Iframe Area

Using ClientScripts in C1WebMenu to Navigate in a Frameset

Using ClientScripts in C1WebMenu to Navigate in an Iframe Area

Adding a Menu Item in Code

Adding a SubMenu in Code

Adding Items to the SubMenu in Code


Adding a Menu

Adding a Menu

This topic demonstrates how to define a standard C1WebMenu menu. For more details about using the editor, see Using the C1WebMenu Editor.

1. Start a new Visual Basic ASP.NET Web Application project, and add the C1WebCommand component to the toolbox.

2. Place a C1WebMenu component on the WebForm.

3. Select the C1WebMenu1 control and set the BackColor property to Tan.

4. To edit WebMenu, right-click the C1WebMenu1 control, and select Edit menu from the context menu.

5. Add a first, second and third C1MenuItem. You will note that the three items are placed vertically inside the component. Use Add Child, Insert item tool buttons for this.

Your menu in Preview tab should appear similar to the menu items below:


Adding a Sub-Menu at Design-Time

Adding a Sub-Menu at Design-Time

This topic demonstrates how to add a sub-menu to your C1MenuItems.

1. Go to the Edit tab in the C1WebMenuEditor and select C1MenuItem1 in tree view.

2. Click on Add Child tool button.

3. Add two more items by selecting Insert Item from the context menu or toolbar.

Your menu in Preview tab should look like this:


Changing the Menu from Vertical to Horizontal

Changing the Menu from Vertical to Horizontal

This topic demonstrates how to change the positioning of the menu from vertical to horizontal.

1. Select the C1WebMenu control.

2. In the property pane, set the MenuLayout property to Horizontal.

Your menu in Preview tab should look like this:


Changing the Menu Direction to Right to Left

Changing the Menu Direction to Right to Left

This topic demonstrates how to make the menu appear right to left. The key solution is setting the HorzPopupDirection property to "RightToLeft".

1. Select the C1WebMenu control.

2. In the property pane, set the HorzPopupDirection property to "RightToLeft".

3. Save and run your web application. Your menu at run-time will appear in the RightToLeft direction.


Changing the Menu Direction to Left to Right

Changing the Menu Direction to Left to Right

This topic demonstrates how to make the menu appear left to right. The key solution is setting the HorzPopupDirection property to "LeftToRight".

1. Select the C1WebMenu control.

2. In the property pane, set the HorzPopupDirection property to"LeftToRight".

3. Save and run your web application. Your menu in run-time will appear in the LeftToRight direction.


Changing the Menu to Bottom to Top

Changing the Menu to Bottom to Top

This topic shows how to make the menu appear in the bottom-to-top direction. The key solution is setting the VertPopupDirection property to "BottomToTop".

1. Select the C1WebMenu control.

2. In the property pane, set the VertPopupDirection property to "BottomToTop".

3. Save and run your web application. Your menu at run-time will appear in the BottomToTop direction.


Modifying the Appearance of the Menus

Modifying the Appearance of the Menus

By using the associated properties, you can customize each menu item.

1. Go to the Edit tab in the C1WebMenuEditor and select C1MenuItem1 in tree view.

2. Select C1WebMenu1 control and set the related properties to:

· ItemStyle |BackColor - Silver

· ItemStyle | BorderColor – DarkRed

· ItemStyle | BorderStyle – Solid

· ItemStyle | BorderWidth – 1px

· ItemStyle | ForeColor – DarkRed

· BorderWidth – 1px

· BorderStyle – Solid

· BorderColor - DarkViolet

3. Select C1MenuItem6 and set the related properties to:

· BackColor - #C0FFC0

4. Select C1SubMenu1 and set the related properties to:

· SelectedItemStyle|BackColor – #C0C0FF

5. Build and run the web application and note:

· Unless otherwise modified, the sub-menu items inherit formatting from the parent WebMenu.

· You can modify the individual items as necessary.


Using the Target Property in C1WebMenu to Navigate in a Frameset

Using the Target Property in C1WebMenu to Navigate in a Frameset

Previous Next

This topic shows how to set up C1WebMenu, to use another frame as a target for the item's navigation. If you would like to set up C1WebToolBar to use another frame as a target for the item's navigation, see Using the Target Property in C1WebToolBar to Navigate in a Frameset.

1. Start a new web application project.

NOTE: Once you create your new web appilcation you need to create a virtual directory for it. The virtual directory is created in the Internet Information Services.

2. Add a new web form to your project and call it index.aspx.

3. Drag and drop the C1WebMenu control to the index.aspx page.

4. Select Edit Menu from the C1Webmenu control's context menu. In the Edit tab of the C1WebMenu Editor, right-click C1WebMenu1 and select Add Child to add a new menu item. To add the first navigation to the menu item, set the C1MenuItem1's Text property to "Google". Add another menu item and set the C1MenuItem2's Text property to "Microsoft".

5. In the Edit Tab, select the Google item and locate its Target. Set the Target property to "main".

6. Set the Google item's LinkUrl property to "http:/www.google.com".

7. In the Edit Tab, select the Microsoft item and locate its Target and LinkUrl property. Set its Target property to "main" and its LinkUrl property to "http:/www.microsoft.com".

8. Add a new frameset to the project. File->Add New Item->Frameset. Select the "Contents" frameset template.

9. Set the frameset as the start page. Right-click on the frameset1.htm in the solution explorer window and select Set as Start Page from its context menu.

10. Select the right frame. Set the "name" property of the frame to "main".

11. Select the left frame. Set the "name" property of the frame to "contents". Set the "src" property of the left frame to "Index.aspx".

NOTE: If you make changes to your control, please make sure to re-add the index.aspx page to your src property in the left frame of the Frameset. If you don't re-add the index.aspx page to your src in the frameset the new changes will not be updated when you run your program.

12. Save and run your application. It should appear similar to the picture below:


Using the Target Property in C1WebMenu to Navigate in an Iframe Area

Using the Target Property in C1WebMenu to Navigate in an Iframe Area

Previous Next

This topic shows how to set up C1WebMenu, to use an Iframe as a target for the item's navigation. If you would like to set up C1WebToolBar to use an Iframe as a target for the item's navigation, see, Using the Target Property in C1WebToolBar to Navigate in an Iframe Area.

1. Start a new web application project.

NOTE: Once you create your new web appilcation you need to create a virtual directory for it. The virtual directory is created in the Internet Information Services.

2. Add a new web form to your project and call it index.aspx.

3. Drag and drop the C1WebMenu control to the index.aspx page.

4. Select the Edit Menu from the C1Webmenu control's context menu. In the Edit tab of the C1WebMenu Editor, right-click C1WebMenu1 and select Add Child to add a new menu item. To add the first navigation to the menu item, set the C1MenuItem1's Text property to "Google". Add another menu item and set the C1MenuItem2's Text property to "Microsoft".

5. In the Edit Tab, select the Google item and locate its Target. Set the Target property to "main".

6. Set the Google item's LinkUrl property to "http:/www.google.com".

7. Click on the HTML tab in your index.aspx web page and add the Iframe code in the body:

"<IFRAME name="main"></IFRAME>"

8. Save and run your application. It should appear similar to the picture below:


Using ClientScripts in C1WebMenu to Navigate in a Frameset

Using ClientScripts in C1WebMenu to Navigate in a Frameset

This topic shows how to set up C1WebMenu, to use another frame as a target for the item's navigation. If you would like to set up C1WebToolBar to use another frame as a target for the item's navigation, see Using ClientScripts in C1WebToolBar to Navigate in a Frameset or if you would like to see how to set up C1WebTopicBar to use another frame as a target for the item's navigation, see Using ClientScripts in C1WebTopicBar to Navigate in a Frameset.

1. Start a new web application project.

NOTE: Once you create your new web appilcation you need to create a virtual directory for it. The virtual directory is created in the Internet Information Services.

2. Add a new web form to your project and call it index.aspx.

3. Drag and drop the C1WebMenu to the index.aspx page.

4. Select Edit Menu from the C1Webmenu control's context menu. In the Edit tab of the C1WebMenu Editor, right-click C1WebMenu1 and select Add Child to add a new menu item. To add the first navigation to the menu item, set the C1MenuItem1's Text property to "Google".

5. In the Edit Tab, select the Google item and locate its ClientScripts property. Here we will add an onclick event to fire the specified url once the menu item is clicked. To add an "onclick" event to the menu item, Google, select its ClientScripts property and click on the ellipsis button. The Script Definition Collection Editor will appear. Click on the Add button to add the "onclick" event. Select the "onclick" option from EventName drop-down box. Set the ScriptCode as "window.open('http://www.google.com', 'main')". This will make a new window open in the main window to the web site, www.google.com, once you click on the Google menu item.

6. In the Edit tab of the C1WebMenu Editor, add another menu item for the second navigation. Set its Text property to "Microsoft". Here we will add an onclick event to fire the specified url once the menu item is clicked. To add an "onclick" event to the menu item, Microsoft, select its ClientScripts property and click on the ellipsis button. The Script Definition Collection Editor will appear. Click on the Add button to add the "onclick" event. Select the "onclick" option from the EventName drop-down box. Set the ScriptCode as "window.open('http://www.microsoft.com', 'main')". This will make a new window open to the web site, www.microsoft.com, once you click on the Microsoft menu item.

7. Add a new frameset to the project. File->Add New Item->Frameset. Select "Contents" frameset template.

8. Set the frameset as the start page. Right-click on the frameset1.htm in the solution explorer window and select Set as Start Page from its context menu.

9. Select the right frame. Set the "name" property of the frame to "main".

10. Select the left frame. Set the "name" property of the frame to "contents". Set the "src" property of the left frame to "Index.aspx".

NOTE: If you make changes to your control, please make sure to re-add the index.aspx page to your src property in the left frame of the Frameset. If you don't re-add the index.aspx page to your src in the frameset the new changes will not be updated when you run your program.

11. Save and run your application. It should appear similar to the picture below:

Note how the Google web site appears in the right frame when you click on the Google menu item. This is the result of the script we created for the onclick event.


Using ClientScripts in C1WebMenu to Navigate in an Iframe Area

Using ClientScripts in C1WebMenu to Navigate in an Iframe Area

Previous Next

This topic shows how to set up C1WebMenu, to use an Iframe as a target for the item's navigation. If you would like to set up C1WebToolBar to use an Iframe as a target for the item's navigation, see, Using ClientScripts in C1WebToolBar to Navigate in an Iframe Area or if you would like to see how to set up C1WebTopicBar to use an iframe as a target for the item's navigation, see, Using ClientScripts in C1WebTopicBar to Navigate in an Iframe Area.

1. Start a new web application project.

NOTE: Once you create your new web appilcation you need to create a virtual directory for it. The virtual directory is created in the Internet Information Services.

2. Add a new web form to your project and call it index.aspx.

3. Drag and drop the C1WebMenu to the index.aspx page.

4. Select Edit Menu from the C1Webmenu control's context menu. In the Edit tab of the C1WebMenu Editor, right-click C1WebMenu1 and select Add Child to add a new menu item. To add the first navigation to the menu item, set the C1MenuItem1's Text property to "Google".

5. In the Edit Tab, select the Google item and locate its ClientScripts property. Here we will add an onclick event to fire the specified url once the menu item is clicked. To add an "onclick" event to the menu item, Google, select its ClientScripts property and click on the elipsis button. The Script Definition Collection Editor will appear. Click on the Add button to add the "onclick" event. Select the "onclick" option from EventName drop-down box. Set the ScriptCode as "window.open('http://www.google.com', 'main')". This will make a new window open in the main window to the web site, www.google.com, once you click on the Google menu item.

6. In the Edit tab of the C1WebMenu Editor, add another menu item for the second navigation. Set its Text property to "Microsoft". Here we will add an onclick event to fire the specified url once the menu item is clicked. To add an "onclick" event to the menu item, Microsoft, select its ClientScripts property and click on the ellipsis button. The Script Definition Collection Editor will appear. Click on the Add button to add the "onclick" event. Select the "onclick" option from the EventName drop-down box. Set the ScriptCode as "window.open('http://www.microsoft.com', 'main')". This will make a new window open to the web site, www.microsoft.com, once you click on the Microsoft menu item.

7. Click on the HTML tab in your index.aspx web page and add the Iframe code in the body:

"<IFRAME name="main"></IFRAME>"

8. Save and run your application. It should appear similar to the picture below:


Adding a Menu Item in Code

Adding a Menu Item in Code

This topic demonstrates how to add a menu in code.

1. Start a new Visual Basic ASP.NET Web Application project, and add the C1.Web.C1Command dll to the project's reference in the solution explorer.

2. Double click on the blank form. This will bring up the soure code.

3. Add the C1.Web.C1Command namespace to your source code.

· Visual Basic

· C#

· Delphi

4. Enter the following code to create a new menu item:

· Visual Basic

· C#

· Delphi

5. Add text to the new menu you created by entering the following code:

· Visual Basic

· C#

· Delphi

6. Add the new item, "Search the Web", to the C1WebMenu. Enter the following code:

· Visual Basic

· C#

· Delphi

7. Save and run your web application. You'll have a single menu item that appears like this:


Adding a SubMenu in Code

Adding a SubMenu in Code

This topic demonstrates how to add a submenu in code. This topic assumes you have an existing ASP.NET project that contains the reference to the C1.Web.C1Command.dll and you have an existing menu item.

Enter the following code to create a new submenu to the existing menu:

· Visual Basic

· C#

· Delphi


Adding Items to the SubMenu in Code

Adding Items to the SubMenu in Code

This topic demonstrates how to add items to a submenu in code. This topic assumes you have an existing ASP.NET project that contains the reference to the C1.Web.C1Command.dll and you have an existing submenu.

1. Use the following code below to create a new C1MenuItem:

· Visual Basic

· C#

· Delphi

2. Assign an ID to the submenu item by using the following code:

· Visual Basic

· C#

· Delphi

3. Add the new C1MenuItem to the submenu by using the following code:

· Visual Basic

· C#

· Delphi

4. Save and run your web application. The submenu will appear similar to the menu below in function, but not in design:


Advanced WebMenu Tasks

Advanced WebMenu Tasks


Loading a Menu from an XML file

Loading a Menu from an XML file

This topic demonstrates how to re-use a menu file created in xml.

Start a new Visual Basic ASP.NET Web Application project, and add the C1WebCommand component to the toolbox.

1. Place a C1WebMenu component on the WebForm.

2. Create a simple menu in xml code. Save it as MenuTree.xml in your project folder.

NOTE: Make sure to name your menu C1WebMenu1 in your xml file.

3. Add the XML namespace to your source code.

· Visual Basic

· C#

· Delphi

4. The following sample loads xml from the MenuTree.xml file. The MapPath method returns a path relative to the directory of the .asp file being processed. The C1MenuBase.LoadTree method loads the menu tree from the Xml file.

· Visual Basic

· C#

· Delphi

5. Save and run your vb, c#, or delphi application. The menu you created in xml should load like this:


Adding HTML Tags to the Item.Text Property

Adding HTML Tags to the Item.Text Property

This topic demonstrates how to add HTML tags to C1MenuItem's Text property.

The following code shows how to add HTML tags.

· Visual Basic

· C#

· Delphi


Context Menu Tasks

Context Menu Tasks

Context menus appear on a page when a user right-clicks the mouse. A user has the option to choose from three different modes of context menus in C1WebMenu's properties toolbox. In the default mode, the context menu appears on any point of the page when the user right-clicks the mouse. In the Control mode, the context menu appears if the user right-clicks the specified control. In the Custom mode, a user calls the client-script function to show the context menu.

The following help topics will show you how to apply the default, control, and custom mode of the context menu to the C1WebMenu control.


Creating a Default Context Menu

Creating a Default Context Menu

This topic demonstrates how to create a default context menu using the C1WebMenu.

1. Add the C1WebMenu control to the WebForm.

2. Select the C1WebMenu control. The C1WebMenu properties toolbox will appear.

3. Select the ContextMenu property and choose Default from its drop-down box.

4. The context menu will appear on any point of the page at run-time once you right-click the mouse.


Creating a Control-Specific Context Menu

Creating a Control-Specific Context Menu

This topic demonstrates how to create a control-specific context menu that appears when the user right-clicks the specified control.

1. Add the C1WebMenu control to the WebForm.

2. Select the C1WebMenu control. The C1WebMenu properties toolbox will appear.

3. Select the ContextMenu property and choose Control from its drop-down box.

4. Select the ContextControlId property and choose the specific control ID that you want to link with the menu.

5. The context menu will appear on the page at run-time when you select the RadioButtonList1 control and right-click on the mouse.


Creating a Custom Context Menu

Creating a Custom Context Menu

This topic demonstrates how to set up and call a context menu using the function c1c_showContextMenu(id).

1. Add the C1WebMenu control to the WebForm.

2. Select the C1WebMenu control. The C1WebMenu properties toolbox will appear.

3. Select the ContextMenu property and choose Custom from its drop-down box.

4. To show the menu call function c1c_showContextMenu(id, x, y) on the client side where id is the ClientID of your menu. The parameter, id, of the c1c_showContextMenu function represents the id of the context menu. The parameter, x, represents the x-coordinate of the left edge of the menu in pixels and the last parameter, y, represents the y-coordinate of the top edge of the menu in pixels.

5. The following custom context menu below appears when the user mouses over the second toolbar button at run-time. This context menu was set up programmatically so it appears directly below the second toolbar button.


WebToolbars Tasks

WebToolbars Tasks

Adding a ToolBar

Modifying the Appearance of the Toolbar

Creating Toggle groups

Using the Target Property in C1WebToolBar to Navigate in a Frameset

Using the Target Property in C1WebToolBar to Navigate in an Iframe Area

Using ClientScripts in C1WebToolBar to Navigate in a Frameset

Using ClientScripts in C1WebToolBar to Navigate in an Iframe Area


Adding a ToolBar

Adding a ToolBar

This topic demonstrates how to define a standard C1WebToolBar toolbar.

Start a new Visual Basic ASP.NET Web Application project, and add the C1WebCommand component to the toolbox.

1. Place a C1WebToolbar component on the WebForm.

2. To add a button to the toolbar, right-click the C1WebToolBar1 control, and select Append Button from the context menu.

3. To add a separator to the toolbar, right-click the C1WebToolBar1 control, and select Append Separator from the context menu.

4. Add one more button to the toolbar: right-click the C1WebToolBar1 control, and select Append Button from the context menu.

5. Build and run the web application.

Your toolbar at run-time should appear like the toolbar below:


Modifying the Appearance of the Toolbar

Modifying the Appearance of the Toolbar

By using the associated properties, you can customize each toolbar element.

1. Select C1WebToolBar1 control and set the related properties to:

· BackColor - RosyBrown

· BorderStyle - None

· ItemStyle|BackColor – RosyBrown

· ItemStyle|BorderColor – Silver

· ItemStyle|BorderStyle – Solid

· ItemStyle|BorderWidth – 1px

· ItemSize – 30px

· SelectedItemStyle|BorderColor - Maroon

2. Select C1WebToolBarButton1 and set the related properties to:

· IsToggle – True

· IsToggle – True

After setting these properties, the toolbar looks like this:


Creating Toggle groups

Creating Toggle groups

1. Right-click the C1WebToolBar1 control, and select Append Toggle Group from the context menu.

2. Right-click the new Toggle button, and select Append Button from the context menu.

3. Right-click the new Toggle button, and select Append Button from the context menu. The last three buttons are in toggle group.

4. Select the first button called, C1WebToolBarButton1, and set the BackColor property to RosyBrown.

5. Select the second button called, C1WebToolBarButton2, and set the BackColor property to RosyBrown.

6. Select the last button called, C1WebToolBarButton3, and set the BackColor property to RosyBrown.

The new toggle groups will look like this:


Using the Target Property in C1WebToolBar to Navigate in a Frameset

Using the Target Property in C1WebToolBar to Navigate in a Frameset

Previous Next

This topic shows how to set up C1WebToolBar, to use another frame as a target for the item's navigation. If you would like to set up C1WebMenu to use another frame as a target for the item's navigation, see Using the Target Property in C1WebMenu to Navigate in a Frameset.

1. Start a new web application project.

NOTE: Once you create your new web appilcation you need to create a virtual directory for it. The virtual directory is created in the Internet Information Services.

2. Add a new web form to your project and call it index.aspx.

3. Drag and drop the C1WebToolBar control to the index.aspx page.

4. Select Append Button from the C1WebToolBar control's context menu. In C1WebToolBarButton1's property window, set its Text property to "Google".

5. Select the Google toolbar button and locate its Target property. Set the Target property to "main".

6. Set the Google item's LinkUrl property to "http:/www.google.com".

7. Add another button to the C1WebToolBar. Right-click the C1WebToolbar and select Append Button from its context menu. In C1WebToolBarButton2's property window, set its Text property to "Microsoft".

8. Select the Microsoft toolbar button and locate its Target and LinkUrl property. Set its Target property to "main" and set its LinkUrl property to "http:/www.microsoft.com".

9. Add a new frameset to the project. File->Add New Item->Frameset. Select the "Contents" frameset template.

10. Set the frameset as the start page. Right-click on the frameset1.htm in the solution explorer window and select Set as Start Page from its context menu.

11. Select the right frame. Set the "name" property of the frame to "main".

12. Select the left frame. Set the "name" property of the frame to "contents". Set the "src" property of the left frame to "Index.aspx".

NOTE: If you make changes to your control, please make sure to re-add the index.aspx page to your src property in the left frame of the Frameset. If you don't re-add the index.aspx page to your src in the frameset the new changes will not be updated when you run your program.

13. Save and run your application. It should appear similar to the picture below:


Using the Target Property in C1WebToolBar to Navigate in an Iframe Area

Using the Target Property in C1WebToolBar to Navigate in an Iframe Area

Previous Next

This topic shows how to set up C1WebToolBar, to use an iframe as a target for the item's navigation. If you would like to set up C1WebMenu to use another frame as a target for the item's navigation, see, Using the Target Property in C1WebMenu to Navigate in an Iframe Area.

1. Start a new web application project.

NOTE: Once you create your new web appilcation you need to create a virtual directory for it. The virtual directory is created in the Internet Information Services.

2. Add a new web form to your project and call it index.aspx.

3. Drag and drop the C1WebToolBar control to the index.aspx page.

4. Select Append Button from the C1WebToolBar control's context menu. In C1WebToolBarButton1's property window, set its Text property to "Google".

5. Select the Google toolbar button and locate its Target property. Set the Target property to "main".

6. Set the Google item's LinkUrl property to "http:/www.google.com".

7. Add another button to the C1WebToolBar. Right-click the C1WebToolbar and select Append Button from its context menu. In C1WebToolBarButton2's property window, set its Text property to "Microsoft".

8. Select the Microsoft toolbar button and locate its Target and LinkUrl property. Set its Target property to "main" and its LinkUrl property to "http:/www.microsoft.com".

9. Click on the HTML tab in your index.aspx web page and add the Iframe code in the body:

"<IFRAME name="main"></IFRAME>"

10. Save and run your application. It should appear similar to the picture below:


Using ClientScripts in C1WebToolBar to Navigate in a Frameset

Using ClientScripts in C1WebToolBar to Navigate in a Frameset

Previous Next

This topic shows how to set up C1WebToolBar, to use another frame as a target for the toolbar button's navigation. If you would like to set up C1WebMenu to use another frame as a target for the item's navigation, see Using ClientScripts in C1WebMenu to Navigate in a Frameset or if you would like to see how to set up C1WebTopicBar to use another frame as a target for the item's navigation, see Using ClientScripts in C1WebTopicBar to Navigate in a Frameset.

1. Start a new web application project.

NOTE: Once you create your new web appilcation you need to create a virtual directory for it. The virtual directory is created in the Internet Information Services.

2. Add a new web form to your project and call it index.aspx.

3. Drag and drop the C1WebToolBar to the index.aspx page.

4. Select Append Button from the C1WebToolBar control's context menu. In C1WebToolBarButton1's property window, set its Text property to "Google".

5. Select ClientScripts property in C1WebToolBarButton's property toolbox. Here we will add an onclick event to fire the specified url once the toolbar button is clicked. To add an "onclick" event to the menu item, Google, select its ClientScripts property and click on the ellipsis button. The Script Definition Collection Editor will appear. Click on the Add button to add the "onclick" event. Select the "onclick" option from EventName drop-down box. Set the ScriptCode as "window.open('http://www.google.com', 'main')". This will make a new window open in the main window to the web site, www.google.com, once you click on the Google toolbar button.

6. Select the C1WebToolBarButton1 control and select Append Button from its context menu. Another toolbar button will be added for the second navigation. Set its Text property to "Microsoft". Here we will add an onclick event to fire the specified url once the toolbar button is clicked. To add an "onclick" event to the menu item, Microsoft, select its ClientScripts property and click on the ellipsis button. The Script Definition Collection Editor will appear. Click on the Add button to add the "onclick" event. Select the "onclick" option from the EventName drop-down box. Set the ScriptCode as "window.open('http://www.microsoft.com', 'main')". This will make a new window open to the web site, www.microsoft.com, once you click on the Microsoft menu item.

7. Add a new frameset to the project. File->Add New Item->Frameset. Select "Contents" frameset template.

8. To set the frameset as the start page. Right-click on the frameset1.htm in the solution explorer window and select Set as Start Page from its context menu.

9. Select the right frame. Set the "name" property of the frame to "main".

10. Select the left frame. Set the "name" property of the frame to "contents". Set the "src" property of the left frame to "Index.aspx"

NOTE: If you make changes to your control, please make sure to re-add the index.aspx page to your src property in the left frame of the Frameset. If you don't re-add the index.aspx page to your src in the frameset the new changes will not be updated when you run your program.

11. Save and run your application. It should appear similar to the picture below:

Note, how the Microsoft web site appears in the right frame when you click on the Microsoft toolbar button. This is the result of the script we created for the onclick event.


Using ClientScripts in C1WebToolBar to Navigate in an Iframe Area

Using ClientScripts in C1WebToolBar to Navigate in an Iframe Area

Previous Next

This topic shows how to set up C1WebToolBar, to use an iframe as a target for the item's navigation. If you would like to set up C1WebMenu to use another frame as a target for the item's navigation, see Using ClientScripts in C1WebMenu to Navigate in an Iframe Area or if you would like to see how to set up C1WebTopicBar to use an iframe as a target for the item's navigation, see Using ClientScripts in C1WebTopicBar to Navigate in an Iframe Area.

1. Start a new web application project.

NOTE: Once you create your new web appilcation you need to create a virtual directory for it. The virtual directory is created in the Internet Information Services.

2. Add a new web form to your project and call it index.aspx.

3. Drag and drop the C1WebToolBar to the index.aspx page.

4. Select Append Button from the C1WebToolBar control's context menu. In C1WebToolBarButton1's property window, set its Text property to "Google".

5. Select ClientScripts property in C1WebToolBarButton's property toolbox. Here we will add an onclick event to fire the specified url once the toolbar button is clicked. To add an "onclick" event to the menu item, Google, select its ClientScripts property and click on the ellipsis button. The Script Definition Collection Editor will appear. Click on the Add button to add the "onclick" event. Select the "onclick" option from EventName drop-down box. Set the ScriptCode as "window.open('http://www.google.com', 'main')". This will make a new window open in the main window to the web site, www.google.com, once you click on the Google toolbar button.

6. Select the C1WebToolBarButton1 control and select Append Button from its context menu. Another toolbar button will be added for the second navigation. Set its Text property to "Microsoft". Here we will add an onclick event to fire the specified url once the toolbar button is clicked. To add an "onclick" event to the menu item, Microsoft, select its ClientScripts property and click on the ellipsis button. The Script Definition Collection Editor will appear. Click on the Add button to add the "onclick" event. Select the "onclick" option from the EventName drop-down box. Set the ScriptCode as "window.open('http://www.microsoft.com', 'main')". This will make a new window open to the web site, www.microsoft.com, once you click on the Microsoft menu item.

7. Click on the HTML tab in your index.aspx web page and add the Iframe code in the body:

"<IFRAME name="main"></IFRAME>"

8. Save and run your application. It should appear similar to the picture below:


C1WebMenuEditor Tasks

C1WebMenuEditor Tasks

The task-based help assumes that you are familiar with programming in Visual Basic.NET. By following the steps outlined in the help, you will be able to utilize the features of C1WebMenu Editor.

Calling the C1WebMenu Editor

Adding Menu Items

Creating Submenus

Creating Multiple Items and SubMenus

Moving Items and Submenus in Menu Hierarchy

Modifying the Appearance of the Menus

Binding events

Copying Menu Items and Submenus

Deleting Menu Items and Submenus

Previewing the Menu

Applying changes to the Menu

Reverting changes to the Menu

Continuous Typing

Renaming the Menu Items


Calling the C1WebMenu Editor

Calling the C1WebMenu Editor

This topic demonstrates three ways how to call the C1WebMenuEditor.

1. Right-click on the C1WebMenu control.

2. Select “Edit menu” from the context menu.

Or

· You can access this editor in the Designer Verb area at the bottom of the Properties window. Click on “Edit menu” verb for this.

Or

· Select the ellipses (…) button of the Controls property of the C1WebMenu component.


Adding Menu Items

Adding Menu Items

This topic demonstrates how to add menu items to C1WebMenu using the C1WebMenuEditor.

1. Right-click on the C1WebMenu control and select “Edit menu” from the context menu.

2. The C1WebMenuEditor will appear. Select the [image] Add Child button from the toolbar or Add Child operation from the main menu or context menu.

3. Once you have added a child to the C1WebMenu, it automatically becomes a new menu item. The new item will be created as a child of the selected menu. The following new functions in C1WebMenu Editor's toolbar, main menu, and context menu become available for your use: move item up, move item down, move item to child, insert item, cut, copy, and delete.

4. If you would like to insert a new menu item you can click on the [image] "Insert Item" button to insert a new item. The new item will be created before the current selected item.


Creating Submenus

Creating Submenus

This topic demonstrates how to create a submenu for an existing menu item using the C1WebMenu Editor. In this example, we will create a submenu for our menu called, C1MenuItem2.

1. Select the Edit tab. The menu items will appear in a tree-view.

2. Select C1MenuItem2 and select the “Add child” operation from the main or context menu, or a toolbar.

3. The submenu will be created with one menu item below it. For this example, we will name the new submenu, sub item1.

The new submenu item will appear like the picture below:

4. If you select the preview tab, you can see what the new submenu item will look like at run-time. Below is what the new sub-menu item will look like.


Creating Multiple Items and SubMenus

Creating Multiple Items and SubMenus

This topic demonstrates how to create multiple items and submenus using the C1WebMenu Editor.

1. Select C1WebMenu item in the tree and select the"Add Child" operation from main, context menu, or a toolbar. The new item will be created as a child of the selected menu.

2. Select C1MenuItem1 in the tree and select the "Insert Item" operation from main, context menu or a toolbar. The new menu item will appear above the selected item.

3. Select C1MenuItem2 in the tree and select the "Add Child" operation from main, context menu or a toolbar. A new submenu will be added to C1MenuItem2.

4. Select C1MenuItem3 in the tree and select the "Insert Item" operation from main, context menu or a toolbar. A new item will appear above the selected item. Repeat this one more time. After completing this step you should have three new items below the C1SubMenu1.

5. Select C1MenuItem3 in the tree and select the "Add Child" operation from main, context menu or a toolbar. A new submenu item will appear below the C1MenuItem3.

6. Your menu in the Preview tab should look like this:


Moving Items and Submenus in Menu Hierarchy

Moving Items and Submenus in Menu Hierarchy

This topic demonstrates different techniques in moving items and submenus in menu hierarchy using the C1WebMenu Editor.

Using the Cut/Paste Method from the Main or Context Menu

1. Right-click on the C1WebMenu control and select Edit from the context menu.

2. In the C1WebMenu Editor tree, select the menu item you want to cut.

3. Right-click on the menu item and select Cut from the context menu or select Cut from the edit menu in the main menu of the C1WebMenu editor.

4. Select the place where you want the menu to appear in the tree of the C1WebMenu editor.

5. Right-click and select Paste from the context menu or select paste from the edit menu in the main menu of the C1WebMenu Editor. The menu item will appear in a new position after choosing Paste.

Using the Drag and Drop method

1. Right-click on the C1WebMenu control and select Edit from the context menu.

2. In the C1WebMenu Editor tree, select the menu item you want to move.

3. Drag the menu item and drop it where you would like it to appear.

Using the “Move item up”, “Move item down”, “Move item to Parent”, and“Move item to Child” Buttons on the Toolbar

1. Right-click on the C1WebMenu control and select Edit from the context menu.

2. In the C1WebMenu Editor tree, select the menu item you want to move.

3. Use the "Move item up" * method in the toolbar if you would like the item to move up one position.

4. Use the "Move item down" * method in the toolbar if you would like the item to move down one position.

5. Use the "Move item to Parent" * method in the toolbar if you would like the item to move from the child position to the parent position.

6. Use the "Move item to Child" * method in the toolbar if you would like the item to move from the parent position to the child position.


Modifying the Appearance of the Menus

Modifying the Appearance of the Menus

This topic demonstrates how to modify the appearance of the menus using the C1WebMenu Editor.

1. Right-click on the C1WebMenu control and select Edit from the context menu.

2. Use the Property Grid located on the right side of the C1WebMenu Editor to change properties of the menu elements.


Binding events

Binding events

This topic demonstrates how to bind events in the C1WebMenu using the C1WebMenu Editor.

1. Right-click on the C1WebMenu control and select Edit from the context menu.

2. Select the menu item you want to bind.

3. Click the events button [image] located in C1WebMenu Editor's property grid.

4. Double-click on the empty fields in the property grid to create and bind new event handlers.

5. Select the existing handler from the drop-down box to bind the event.


Copying Menu Items and Submenus

Copying Menu Items and Submenus

This topic demonstrates how to copy menu items and submenus using the C1WebMenu Editor.

1. Use the copy/paste operation from main or context menu.

2. Press and hold the CTRL key, then drag the menu element. When you drop it, it will be copied with all nested elements.


Deleting Menu Items and Submenus

Deleting Menu Items and Submenus

This topic demonstrates how to delete menu items and submenu items using the C1WebMenu Editor.

1. Right-click on the C1WebMenu control and select Edit menu from the context menu.

2. Select the menu item you want to delete.

3. Right-click on the menu item in the tree-view of the C1WebMenu Editor.

4. Select the “Delete” operation from the context menu.

Or

1. Right-click on the C1WebMenu control and select Edit menu from the context menu.

2. Select the menu item you want to delete.

3. Select the menu item in the tree-view of the C1WebMenuEditor.

4. Select the "Delete" operation from the Edit menu of the C1WebMenuEditor.


Previewing the Menu

Previewing the Menu

This topic demonstrates how to preview the C1WebMenu using the C1WebMenu Editor.

1. Right-click on the C1WebMenu control and select Edit menu from the context menu.

2. The C1WebMenuEditor will appear.

3. Select the Preview tab in the C1WebMenu Editor.


Applying changes to the Menu

Applying changes to the Menu

This topic demonstrates how to apply changes to the C1WebMenu using the C1WebMenu Editor.

1. Right-click on the C1WebMenu control and select Edit from the context menu.

2. The C1WebMenu Editor will appear.

3. In the C1WebMenu Editor, select the File menu and click on the Exit menu or click on the OK button at the bottom of the C1WebMenu Editor.

4. Your new changes will be applied to your menu.


Reverting changes to the Menu

Reverting changes to the Menu

This topic demonstrates how to revert changes to the C1WebMenu using the C1WebMenu Editor.

1. Right-click on the C1WebMenu control and select the Edit menu from the context menu.

2. The C1WebMenu Editor will appear.

3. In the C1WebMenuEditor, click on the Cancel button to revert/undo the changes you made.


Continuous Typing

Continuous Typing

This topic demonstrates how to continuously type in new items to the C1WebMenu using the C1WebMenu Editor.

1. Right-click on the C1WebMenu control and select Edit menu from the context menu.

2. Select any menu item in the tree-view of the C1WebMenu Editor.

3. Click on the “Append Item” button on the toolbar.

4. The new menu item will be added. Type the item's name where is says "Type here" in the highlighted blue box as shown below:

5. Press the Enter key after you finish typing the new name of the menu.

6. Another menu item will appear like this:

7. You can keep adding new items by pressing the Enter key after each time you type a new name.

8. You can stop the continuous typing by pressing the Enter key without typing anything.


Renaming the Menu Items

Renaming the Menu Items

This topic demonstrates how to rename the menu items.

1. Right-click on the C1WebMenu control and select Edit menu from the context menu.

2. In the tree-view of the C1WebMenu Editor, right-click the menu item you want to rename.

3. Select “Rename” from the context menu.

4. Type the new item’s text and press the Enter key.


WebTopicBar Tasks

WebTopicBar Tasks

Adding a C1WebTopicBar

Adding the Items Group

Adding Items to the Groups

Modifying the Appearance of the C1WebTopicBar

Applying the Cascading Style Sheets

Defining the Mouseover Cursor

Defining the Indicator Image

Defining the Caption Image for the Group

Applying the Caption Label Position to the C1WebTopicBar

Applying the Caption Label Position to Individual Groups of the C1WebTopicBar

Using ClientScripts in C1WebTopicBar to Navigate in a Frameset

Using ClientScripts in C1WebTopicBar to Navigate in an Iframe Area

Adding the Panel Group

Adding Controls to the Panel Group

Changing the Height of the Panel Group


Adding a C1WebTopicBar

Adding a C1WebTopicBar

This topic demonstrates how to add the C1WebTopicBar control to your project.

1. Start a new Visual Basic ASP.NET Web Application project.

2. Go to the view menu and select solution explorer.

3. Right click on References and select add reference.

4. The add reference box will appear. Select the Browse button to find the location of the C1.Web.C1Command.dll. Select C1.Web.C1Command.dll and click on the open button.

5. Dispay toolbox by clicking on the Toolbox icon. Right-click in the toolbox and select Customize Toolbox.

6. The Customize Toolbox will appear. Select the .NET Framework Components tab.

7. Click on the Browse button to find the lactation of the C1.Web.C1Command.dll. Select C1.Web.C1Command.dll and click on the open button.

8. The new controls will automatically be loaded to the Customize Toolbox.

9. Select the box for the C1WebTopicBar. A check mark will appear once you select it. Select the OK button.

10. The new component will appear on your Toolbox.

11. To add the C1WebTopicBar to your form: Double click on the C1WebTopicBar or drag and drop it on the form.

12. It will look like the picture below once you put it on the form:


Adding the Items Group

Adding the Items Group

This topic demonstrates how to add the groups.

1. Select the drop down arrow in the properties toolbox and select the C1WebTopicBar1 or select the C1WebTopicBar that is on the form.

NOTE: If the C1WebTopicBar is not appearing in the properties drop down box then see Adding a C1WebTopicBar.

2. Look in the properties toolbox to find Groups. It will say (Collection) to the right.

3. Select ellipses (…) button of Groups property of the C1WebTopicBar component.

4. Select C1WebTopicBarItemsGroup item in “Add” button’s dropdown menu.

5. Set Text property for the group.


Adding Items to the Groups

Adding Items to the Groups

This topic demonstrates how to add items to the group.

1. Select the C1WebTopicBarComponent that is on your form.

2. Look in the properties toolbox to find Groups. It will say (Collection) to the right.

3. Select the ellipses (…) button of the Groups property of the C1WebTopicBar component.

4. The C1WebTopicBarCustomGroup Collection Editor box will appear.

5. In the C1WebTopicBarCustomGroup Collection Editor box, select the ellipses (…) button of the Item's property of the C1WebTopicBar component.

6. The C1WebTopicBarItem Collection Editor will appear.

7. Click on the Add button. Each time you click the add button, it will add another item.

8. Set Text property for the new items.


Modifying the Appearance of the C1WebTopicBar

Modifying the Appearance of the C1WebTopicBar

This topic demonstrates how to modify the appearance of the C1WebTopicBar.

1. Select C1WebTopicBar component.

2. Expand the Font properties of the C1WebTopicBar Component, set the Font.Name property to "Microsoft Sans Serif"

3. Set TextHeight to “24px”.

4. Set GroupSpacing to “10px”.

5. Set BackColor to "#C1C4D3".

6. Expand the Style properties.

7. Select the GroupStyle property and expand it.

8. Set the following GroupStyle properties:

· ItemSpacing to "10px".

· BackColor to "#F0F1F5".

The C1WebTopicControl should appear like this on the form:

9. Set the following ExpandedHeaderStyle properties:

· Font.Bold to "True".

· ForeColor to "White".

· BackColor to "#ACADC0".

· BorderColor to "White".

· BorderStyle to "None".

· Font.Size to “8pt”.

The C1WebTopicControl should appear like this on the form:

10. Set the following CollapsedHeaderStyle properties:

· Font.Bold to "True".

· ForeColor to "White".

· BackColor to "#ACADC0".

· Font.Size to “8pt”.

11. Expand the MouseOverExpandedHeaderStyle properties and set its ForeColor property to "#E0E0E0".

12. Expand the MouseOverCollapsedHeaderStyle properties and set its ForeColor property to "#E0E0E0".

13. Expand ItemStyle and set the following ItemStyle properties:

· Font.Size to "8pt".

· BorderWidth to "2px".

· ForeColor to "DimGray".

· ItemAlign to "Left".

· BorderStyle to "Solid".

· ItemImagePosition to "Near".

· BorderColor to "#F0F1F5".

· BackColor to "#F0F1F5".

14. Expand the MouseOverItemStyle properties and set the Font.Underline to “True".

15. The appearance of the C1WebTopicBar will look like the picture below:

NOTE: The picture displayed below illustrates the appearance of the C1WebTopic after following the tutorial, but it does not illustrate how the content will appear since we did not add any content in the tutorial above.


Applying the Cascading Style Sheets

Applying the Cascading Style Sheets

This topic demonstrates how to apply Cascading Style Sheets (CSS) to the C1WebTopicBar.

1. Select File->New->File from main menu.

2. Select “Style Sheet” item. Open the “Style Sheet” item.

3. Select File->Save StyleSheet.css As Sample1.css.

4. Select your projectname.aspx.

5. In design view, Select “Format”->”Document styles”.

6. Right click on style and select Add style link.

7. The Select Style Sheet Box will appear.

8. Select the “styles.css” and hit the OK button.


Defining the Mouseover Cursor

Defining the Mouseover Cursor

This topic demonstrates how to define the mouseover cursor in the C1WebTopicBar.

1. Open the style.css file.

2. Add new class:

.C1WebTopicBar

{

cursor: default;

}

3. Select C1WebTopicBar component.

4. Set CssClass property to “.C1WebTopicBar”


Defining the Indicator Image

Defining the Indicator Image

This topic demonstrates how to define the indicator image.

1. Select C1WebTopicBar component.

2. Set the IndicatorUrl property for ExpandedHeaderStyle and CollapsedHeaderStyle styles.

3. Set the IndicatorUrl property for MouseOverExpandedHeaderStyle and MouseOverCollapsedHeaderStyle styles, if it is necessary to show different images then the mouse moves over header.

Your output can look like the picture below, once you set the IndicatorUrl property for the MouseOverExpandedHeader:


Defining the Caption Image for the Group

Defining the Caption Image for the Group

This topic demonstrates how to define the CaptionImageUrl property for the group.

1. Select C1WebTopicBar component.

2. Call the C1WebTopicBarCustomGroup Collection Editor by selecting the Groups property.

3. Set the CaptionImageUrl property for the ExpandedHeaderStyle and CollapsedHeaderStyle styles of the group.

4. Set CaptionImageUrl property for MouseOverExpandedHeaderStyle and MouseOverCollapsedHeaderStyle styles, if it is necessary to show different images then the mouse moves over header.


Applying the Caption Label Position to the C1WebTopicBar

Applying the Caption Label Position to the C1WebTopicBar

This topic demonstrates how to apply the CaptionLabelHorizontalAlign and the CaptionLabelVerticalAlign properties in the C1WebTopicBar in design time.

1. Select the C1WebTopicBar control and right-click on the properties in the context menu.

2. The C1WebTopicBar properties box will appear in the right pane.

3. Select the CaptionLabelHorizontalAlign property and select Right from its drop down menu. The text will be aligned in the right position in the group.

4. Select the CaptionLabelVerticalAlign property and select Top from its drop down menu. The text will be in the top position of the group.

5. The C1WebTopicBar will appear like this in run-time:


Applying the Caption Label Position to Individual Groups of the C1WebTopicBar

Applying the Caption Label Position to Individual Groups of the C1WebTopicBar

Previous Next

This topic demonstrates how to apply the CaptionLabelHorizontalAlign and the CaptionLabelVerticalAlign properties in the C1WebTopicBarCustomGroup in design time.

1. Select the C1WebTopicBar control and right-click on the properties in the context menu.

2. The C1WebTopicBar properties box will appear in the right pane.

3. Select the ellipsis button of the group's property.

4. The C1WebTopicBarCustomGroup Collection Editor will appear.

5. Select the group member that you want to apply the CaptionLabelHorizontalAlign and the CaptionLabelVerticalAlign properties to.

6. Select the CaptionLabelHorizontalAlign property and select Left from its drop down menu. The text will be aligned in the left position in the group.

7. Select the CaptionLabelVerticalAlign property and select Bottom from its drop down menu. The text will be in the bottom position of the group.

8. The C1WebTopicBar will appear like this in run-time:


Using ClientScripts in C1WebTopicBar to Navigate in a Frameset

Using ClientScripts in C1WebTopicBar to Navigate in a Frameset

Previous Next

This topic shows how to set up C1WebTopicBar, to use another frame as a target for the item's navigation. If you would like to set up C1WebToolBar to use another frame as a target for the item's navigation, see Using ClientScripts in C1WebToolBar to Navigate in a Frameset or if you would like to see how to set up C1WebMenu to use another frame as a target for the item's navigation, see Using ClientScripts in C1WebMenu to Navigate in a Frameset.

1. Start new web application project.

NOTE: Once you create your new web appilcation you need to create a virtual directory for it. The virtual directory is created in the Internet Information Services.

2. Add a new web form to your project and call it index.aspx.

3. Drag and drop the C1WebTopicBar to the index.aspx page.

4. Select ellipsis button in the Groups property of C1WebTopic. The C1WebTopicBarCustomGroup Collection Editor will appear. Click on the ellipsis button of the Items property. The C1WebTopicBarItem Collection Editor will appear. Select the Text property and replace Item1 with the text, Google.

5. Select Google from the Members list in the C1WebTopicBarItem Collection Editor. Locate the ClientScripts property and double-click on the ellipsis button. Here we will add an onclick event to fire the specified url once the item is clicked. The Script Definition Collection Editor will appear. Click on the Add button to add the "onclick" event. Select the "onclick" option from EventName drop-down box. Set the ScriptCode as "window.open('http://www.google.com', 'main')". This will make a new window open in the main window once the Google item is clicked. Click the OK button once you are finished.

6. In the C1WebTopicBarCollection Editor, click on the Add button to add another item to the group. Set its text property to "Microsoft". Here we will add an onclick event to fire the specified url once the item is clicked. To add an "onclick" event to the item, Microsoft, select its ClientScripts property and click on the ellipsis button. The Script Definition Collection Editor will appear. Click on the Add button to add the "onclick" event. Select the "onclick" option from the EventName drop-down box. Set the ScriptCode as "window.open('http://www.microsoft.com', 'main')". This will make a new window open to the web site, www.microsoft.com, once you click on the Microsoft menu item.

7. Add a new frameset to the project. File->Add New Item->Frameset. Select "Contents" frameset template.

8. To set the frameset as the start page. Right-click on the frameset1.htm in the solution explorer window and select Set as Start Page from its context menu.

9. Select the right frame. Set the "name" property of the frame to "main".

10. Select the left frame. Set the "name" property of the frame to "contents". Set the "src" property of the left frame to "Index.aspx"

NOTE: If you make changes to your control, please make sure to re-add the index.aspx page to your src property in the left frame of the Frameset. If you don't re-add the index.aspx page to your src in the frameset the new changes will not be updated when you run the program.

11. Save and run your application. It should appear similar to the picture below:

Note, how the Google web site appears in the right frame when you click on the Google item. This is the result of the script we created for the onclick event.


Using ClientScripts in C1WebTopicBar to Navigate in an Iframe Area

Using ClientScripts in C1WebTopicBar to Navigate in an Iframe Area

Previous Next

This topic shows how to set up C1WebTopicBar to use an iframe as a target for the item's navigation. If you would like to set up C1WebToolBar to use an iframe as a target for the item's navigation, see Using ClientScripts in C1WebToolBar to Navigate in an Iframe Area or if you would like to see how to set up C1WebMenu to use an iframe as a target for the item's navigation, see Using ClientScripts in C1WebMenu to Navigate in an Iframe Area.

1. Start new web application project.

NOTE: Once you create your new web appilcation you need to create a virtual directory for it. The virtual directory is created in the Internet Information Services.

2. Add a new web form to your project and call it index.aspx.

3. Drag and drop the C1WebTopicBar to the index.aspx page.

4. Select ellipsis button in the Groups property of C1WebTopic. The C1WebTopicBarCustomGroup Collection Editor will appear. Click on the ellipsis button of the Items property. The C1WebTopicBarItem Collection Editor will appear. Select the Text property and replace Item1 with the text, Google.

5. Select Google from the Members list in the C1WebTopicBarItem Collection Editor. Locate the ClientScripts property and double-click on the ellipsis button.. Here we will add an onclick event to fire the specified url once the item is clicked. The Script Definition Collection Editor will appear. Click on the Add button to add the "onclick" event. Select the "onclick" option from EventName drop-down box. Set the Script code as "window.open('http://www.google.com', 'main')". This will make a new window open in the main window once the Google item is clicked. Click the OK button once you are finished.

6. In the C1WebTopicBarCollection Editor, click on the Add button to add another item to the group. Set its text property to "Microsoft". Here we will add an onclick event to fire the specified url once the item is clicked. To add an "onclick" event to the item, Microsoft, select its ClientScripts property and click on the ellipsis button. The Script Definition Collection Editor will appear. Click on the Add button to add the "onclick" event. Select the "onclick" option from the EventName drop-down box. Set the ScriptCode as "window.open('http://www.microsoft.com', 'main')". This will make a new window open to the web site, www.microsoft.com, once you click on the Microsoft item.

7. Click on the HTML tab in your index.aspx web page and add the Iframe code inside the body:

"<IFRAME name="main"></IFRAME>"

8. Save and run your application. It should appear similar to the picture below:


Adding the Panel Group

Adding the Panel Group

This topic demonstrates how to add the panel group.

1. Select the ellipses (…) button of the Groups property in the C1WebTopicBar properties toolbox.

2. Select the C1WebTopicBarPanelGroup item in “Add” button’s dropdown menu.

3. Set the Text property for the group.


Adding Controls to the Panel Group

Adding Controls to the Panel Group

This topic demonstrates how to add controls to the panel group.

· Drag and drop the controls from the toolbox into the PanelGroup body.


Changing the Height of the Panel Group

Changing the Height of the Panel Group

This topic demonstrates how to change the height of the panel group.

1. Select the group in the C1WebTopicBarCustomGroup Collection Editor.

2. Set BodyHeight property for the Panel Group.


C1.Web.C1Command Assembly

C1.Web.C1Command Assembly

Namespaces

C1.Web.C1Command


C1.Web.C1Command Namespace

C1.Web.C1Command Namespace

C1.Web.C1Command Hierarchy

Classes

Class | Description
C1MenuBase | Encapsulates most of the menu functionality. Base class for root menus and submenus.
C1MenuItem | Represents a menu item.
C1MenuItemCollection | This class describes a collection of menu items (of the type C1MenuItem) contained in a menu. It implements the following interfaces: IList, ICollection, IEnumerable.
C1MenuItemCollection.C1MenuItemCollectionEnumerator | Represents Enumerator for items within menu.
C1MenuItemStyle |
C1SubMenu | Represents a submenu object.
C1WebCommandColorConverter | Class for using instead of WebColorConverter.
C1WebCommandConsts | Common for C1WebCommand constants.
C1WebMenu | Represents a C1WebMenu control.
C1WebToolBar | Represents a C1WebToolBar control.
C1WebToolBarButton | Represents a toolbar button.
C1WebToolBarButtonBase | The base class for the web toolbar buttons.
C1WebToolBarContainerBase | The base class for the C1WebToolBar and the C1WebToolBarToggleGroup.
C1WebToolBarControl | Base class for the C1WebToolBarButton and the C1WebToolBarSeparator controls.
C1WebToolBarSeparator | Represents separator on the toolbar.
C1WebToolBarStyle | Style for the web toolbar elements.
C1WebToolBarToggleGroup |
C1WebToolBarToggleGroupBase |
C1WebTopicBar | Represents the TopicBar Web control.
C1WebTopicBarCommandEventArgs | C1WebTopicBarCommandEventArgs use for the following events: C1WebTopicBar.ItemClick C1WebTopicBar.ItemSelected
C1WebTopicBarCustomGroup | Base class for the C1WebTopicBarItemsGroup and C1WebTopicBarPanelGroup classes.
C1WebTopicBarGroupBeforeEventArgs | C1WebTopicBarGroupBeforeEventHandler use for the following events: C1WebTopicBar.GroupCollapsing C1WebTopicBar.GroupExpanding
C1WebTopicBarGroupCollection | Contains the values of a C1WebTopicBar.Groups property.
C1WebTopicBarGroupEventArgs | C1WebTopicBarGroupEventArgs use for the following events: C1WebTopicBar.GroupCollapsed C1WebTopicBar.GroupExpanded
C1WebTopicBarGroupStyle | Represents the style for a topicbar group.
C1WebTopicBarHeaderStyle | Represents the style for a topic bar's header.
C1WebTopicBarItem | Represents a navigation item in the topic bar control.
C1WebTopicBarItemCollection | Contains the values of a C1WebTopicBarItemsGroup.Items property.
C1WebTopicBarItemsGroup | Represents a group which contains navigation items.
C1WebTopicBarItemStyle | Style used for the items in the C1WebTopicBar control.
C1WebTopicBarPanelBodyHelper |
C1WebTopicBarPanelGroup | Represents a group that can contain other controls on its body.
C1WebTopicBarStrings | This class includes string constants, used in other classes of WebTopicBar.
C1WebTopicBarStyle | Represents the style for a topic bar control.
GetSpecialSymbolEventArgs | Arguments: Item - Returns the item object associated with the event. Symbol - Returns the symbol type Style - Gets or sets the string contains inline style information is used with the symbol in HTML. Text - Gets or sets text for the symbol. ImageUrl - Gets or sets url for the symbol.
ItemClickEventArgs | item - Source item is raised the event.
ItemCommandEventArgs | commandName - The name of the command. commandArgument - The argument for the command. commandSource - The source of the event.

Delegates

Delegate | Description
C1WebTopicBarCommandEventHandler | Delegate type for handling events that are related to the items.
C1WebTopicBarGroupBeforeEventHandler | Delegate type for handling cancellable events that are related to the groups.
C1WebTopicBarGroupEventHandler | Delegate type for handling events that are related to the groups.
GetSpecialSymbolEventHandler | source - The source of the event. e - A GetSpecialSymbolEventArgs object that contains the event data.
ItemClickEventHandler | source - The source of the event. e - A ItemCommandEventArgs object that contains the event data.
ItemCommandEventHandler | source - The source of the event. e - A ItemClickEventArgs object that contains the event data.

Enumerations

Enumeration | Description
C1WebTopicBarItemAlignEnum | Specifies position of an image relative to the item text.
ContextMenuTypeEnum | Use the members of this enumeration to set the value of the ContextMenu property.
HorzPopupDirectionEnum | Use the members of this enumeration to set the value of the HorzPopupDirection property.
MenuLayoutEnum | Use the members of this enumeration to set the value of the MenuLayout property.
PresentationEnum | Determines the look and behavior settings of the C1WebTopicBar control.
SpecialSymbolEnum | Use the members of this enumeration to set the value of the Symbol property of GetSpecialSymbolEventArgs.
SubMenuMarkEnum | Use the members of this enumeration to set the value of the SubMenuMark property.
VertPopupDirectionEnum | Use the members of this enumeration to set the value of the VertPopupDirection property.

See Also

C1.Web.C1Command Assembly


C1MenuBase Class

C1MenuBase Class

Encapsulates most of the menu functionality. Base class for root menus and submenus.

For a list of all members of this type, see C1MenuBase Members.

System.Object

System.Web.UI.Control

System.Web.UI.WebControls.WebControl

System.Web.UI.WebControls.Panel

C1.Web.C1Command.C1MenuBase

C1.Web.C1Command.C1SubMenu

C1.Web.C1Command.C1WebMenu

[Visual Basic]

MustInherit Public Class C1MenuBase

Inherits Panel

Implements IPostBackEventHandler

[C#]

public abstract class C1MenuBase : Panel , IPostBackEventHandler

[Delphi]

type C1MenuBase = class abstract (Panel, IPostBackEventHandler);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1MenuBase Members

C1MenuBase Members

C1MenuBase overview

Public Constructors

C1MenuBase Constructor

Initializes a new instance of the C1MenuBase class.

Public Properties

AccessKey (inherited from WebControl) | Keyboard shortcut used by the control.
AppRelativeTemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Attributes (inherited from WebControl) | Tag attributes of the control.
BackColor (inherited from WebControl) | Color of the background of the control.
BackImageUrl (inherited from Panel) | The background image of the panel.
BorderColor (inherited from WebControl) | Color of the border around the control.
BorderStyle (inherited from WebControl) | Style of the border around the control.
BorderWidth (inherited from WebControl) | Width of the border around the control.
ClientID (inherited from Control) | The ID of the control that is rendered for the client.
Controls (inherited from Control) | The collection of child controls owned by the control.
ControlStyle (inherited from WebControl) | The style associated with the control.
ControlStyleCreated (inherited from WebControl) | Whether the style associated with the control has been created.
CssClass (inherited from WebControl) | CSS Class name applied to the control.
DefaultButton (inherited from Panel) | The default button for the panel.
Direction (inherited from Panel) | The direction of text in the panel.
DisabledItemStyle | The style applied to disabled items in this menu.
Enabled (inherited from WebControl) | Enabled state of the control.
EnableViewState (inherited from Control) | Whether the control automatically saves its state for use in round-trips.
Font (inherited from WebControl) | The font used for text within the control.
ForeColor (inherited from WebControl) | Color of the text within the control.
GroupingText (inherited from Panel) | The text of group box around this control's contents.
Height (inherited from WebControl) | The height of the control.
IconBarWidth | Sets or returns the width of the icon bar drawn on the side of the menus.
ID (inherited from Control) | Programmatic name of the control.
Items | Gets the collection of menu items contained in this menu.
ItemSpacing | Gets or sets spacing between the menu's border and item's border.
ItemStyle | The style applied to items in this menu.
ItemTextSpacing | Gets or sets spacing between the item's border and item's text.
MenuLayout | Indicates whether to layout menu items vertically or horizontally.
NamingContainer (inherited from Control) | The containing control or page within which ID is unique.
Page (inherited from Control) | The page containing the control.
Parent (inherited from Control) | The control containing this control.
ScrollBars (inherited from Panel) | The appearance of scrollbars for the panel.
SelectedItemStyle | The style applied to selected items in this menu.
Site (inherited from Control) | Site of the control.
Style (inherited from WebControl) | Low-level access to control styles.
TabIndex (inherited from WebControl) | The tab order of the control.
Target | Gets or sets the default target window or frame that displays the linked Web page content once an item is clicked.
TemplateControl (inherited from Control) | The TemplateControl that hosts this control.
TemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
ToolTip (inherited from WebControl) | The tooltip displayed when the mouse is over the control.
UniqueID (inherited from Control) | The unique ID of the control within the page.
Visible (inherited from Control) | Indicates whether the control is visible and rendered.
Width (inherited from WebControl) | The width of the control.

Public Methods

AddItem | Adds a menu item.
LoadTree | Overloaded. Loads the menu tree from XML.
SaveTree | Overloaded. Saves the menu tree as XML.

Public Events

DataBinding (inherited from Control) | Fires when the control's data binding expressions are to be evaluated.
Disposed (inherited from Control) | Fires when the control has been disposed.
Init (inherited from Control) | Fires when the page has been initialized.
ItemClick | Fired when the child menu item is clicked.
ItemCommand | Fired when an item belonging to the menu is clicked.
Load (inherited from Control) | Fires when the page has been loaded.
PreRender (inherited from Control) | Fires before the page is rendered.
Unload (inherited from Control) | Fires when the page is unloaded.

Protected Properties

ViewState (inherited from Control)

Current viewstate of the control.

See Also


C1MenuBase Constructor

C1MenuBase Constructor

Initializes a new instance of the C1MenuBase class.

[Visual Basic]

Public Function New()

[C#]

public C1MenuBase()

[Delphi]

public constructor Create();

See Also


C1MenuBase Properties

C1MenuBase Properties

The properties of the C1MenuBase class are listed here. For a complete list of C1MenuBase class members, see the C1MenuBase Members topic.

Public Properties

AccessKey (inherited from WebControl) | Keyboard shortcut used by the control.
AppRelativeTemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Attributes (inherited from WebControl) | Tag attributes of the control.
BackColor (inherited from WebControl) | Color of the background of the control.
BackImageUrl (inherited from Panel) | The background image of the panel.
BorderColor (inherited from WebControl) | Color of the border around the control.
BorderStyle (inherited from WebControl) | Style of the border around the control.
BorderWidth (inherited from WebControl) | Width of the border around the control.
ClientID (inherited from Control) | The ID of the control that is rendered for the client.
Controls (inherited from Control) | The collection of child controls owned by the control.
ControlStyle (inherited from WebControl) | The style associated with the control.
ControlStyleCreated (inherited from WebControl) | Whether the style associated with the control has been created.
CssClass (inherited from WebControl) | CSS Class name applied to the control.
DefaultButton (inherited from Panel) | The default button for the panel.
Direction (inherited from Panel) | The direction of text in the panel.
DisabledItemStyle | The style applied to disabled items in this menu.
Enabled (inherited from WebControl) | Enabled state of the control.
EnableViewState (inherited from Control) | Whether the control automatically saves its state for use in round-trips.
Font (inherited from WebControl) | The font used for text within the control.
ForeColor (inherited from WebControl) | Color of the text within the control.
GroupingText (inherited from Panel) | The text of group box around this control's contents.
Height (inherited from WebControl) | The height of the control.
IconBarWidth | Sets or returns the width of the icon bar drawn on the side of the menus.
ID (inherited from Control) | Programmatic name of the control.
Items | Gets the collection of menu items contained in this menu.
ItemSpacing | Gets or sets spacing between the menu's border and item's border.
ItemStyle | The style applied to items in this menu.
ItemTextSpacing | Gets or sets spacing between the item's border and item's text.
MenuLayout | Indicates whether to layout menu items vertically or horizontally.
NamingContainer (inherited from Control) | The containing control or page within which ID is unique.
Page (inherited from Control) | The page containing the control.
Parent (inherited from Control) | The control containing this control.
ScrollBars (inherited from Panel) | The appearance of scrollbars for the panel.
SelectedItemStyle | The style applied to selected items in this menu.
Site (inherited from Control) | Site of the control.
Style (inherited from WebControl) | Low-level access to control styles.
TabIndex (inherited from WebControl) | The tab order of the control.
Target | Gets or sets the default target window or frame that displays the linked Web page content once an item is clicked.
TemplateControl (inherited from Control) | The TemplateControl that hosts this control.
TemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
ToolTip (inherited from WebControl) | The tooltip displayed when the mouse is over the control.
UniqueID (inherited from Control) | The unique ID of the control within the page.
Visible (inherited from Control) | Indicates whether the control is visible and rendered.
Width (inherited from WebControl) | The width of the control.

Protected Properties

ViewState (inherited from Control)

Current viewstate of the control.

See Also


C1MenuBase.DisabledItemStyle Property

C1MenuBase.DisabledItemStyle Property

The style applied to disabled items in this menu.

[Visual Basic]

Public ReadOnly Property DisabledItemStyle As C1MenuItemStyle

[C#]

public C1MenuItemStyle DisabledItemStyle {get;}

[Delphi]

public property DisabledItemStyle: C1MenuItemStyle read get_DisabledItemStyle;

See Also


C1MenuBase.IconBarWidth Property

C1MenuBase.IconBarWidth Property

Sets or returns the width of the icon bar drawn on the side of the menus.

[Visual Basic]

Public Property IconBarWidth As Unit

[C#]

public Unit IconBarWidth {get;set;}

[Delphi]

public property IconBarWidth: Unit read get_IconBarWidth write set_IconBarWidth;

See Also


C1MenuBase.Items Property

C1MenuBase.Items Property

Gets the collection of menu items contained in this menu.

[Visual Basic]

Public ReadOnly Property Items As C1MenuItemCollection

[C#]

public C1MenuItemCollection Items {get;}

[Delphi]

public property Items: C1MenuItemCollection read get_Items;

See Also


C1MenuBase.ItemSpacing Property

C1MenuBase.ItemSpacing Property

Gets or sets spacing between the menu's border and item's border.

[Visual Basic]

Public Property ItemSpacing As Unit

[C#]

public Unit ItemSpacing {get;set;}

[Delphi]

public property ItemSpacing: Unit read get_ItemSpacing write set_ItemSpacing;

See Also


C1MenuBase.ItemStyle Property

C1MenuBase.ItemStyle Property

The style applied to items in this menu.

[Visual Basic]

Public ReadOnly Property ItemStyle As C1MenuItemStyle

[C#]

public C1MenuItemStyle ItemStyle {get;}

[Delphi]

public property ItemStyle: C1MenuItemStyle read get_ItemStyle;

See Also


C1MenuBase.ItemTextSpacing Property

C1MenuBase.ItemTextSpacing Property

Gets or sets spacing between the item's border and item's text.

[Visual Basic]

Public Property ItemTextSpacing As Unit

[C#]

public Unit ItemTextSpacing {get;set;}

[Delphi]

public property ItemTextSpacing: Unit read get_ItemTextSpacing write set_ItemTextSpacing;

See Also


C1MenuBase.MenuLayout Property

C1MenuBase.MenuLayout Property

Indicates whether to layout menu items vertically or horizontally.

[Visual Basic]

Overridable MustInherit Public Property MenuLayout As MenuLayoutEnum

[C#]

virtual abstract public MenuLayoutEnum MenuLayout {get;set;}

[Delphi]

public property MenuLayout: MenuLayoutEnum read get_MenuLayout write set_MenuLayout;

See Also


C1MenuBase.SelectedItemStyle Property

C1MenuBase.SelectedItemStyle Property

The style applied to selected items in this menu.

[Visual Basic]

Public ReadOnly Property SelectedItemStyle As C1MenuItemStyle

[C#]

public C1MenuItemStyle SelectedItemStyle {get;}

[Delphi]

public property SelectedItemStyle: C1MenuItemStyle read get_SelectedItemStyle;

See Also


C1MenuBase.Target Property

C1MenuBase.Target Property

Gets or sets the default target window or frame that displays the linked Web page content once an item is clicked.

[Visual Basic]

Public Property Target As String

[C#]

public string Target {get;set;}

[Delphi]

public property Target: String read get_Target write set_Target;

See Also


C1MenuBase Methods

C1MenuBase Methods

The methods of the C1MenuBase class are listed here. For a complete list of C1MenuBase class members, see the C1MenuBase Members topic.

Public Methods

AddItem | Adds a menu item.
LoadTree | Overloaded. Loads the menu tree from XML.
SaveTree | Overloaded. Saves the menu tree as XML.

See Also


C1MenuBase.AddItem Method

C1MenuBase.AddItem Method

Adds a menu item.

[Visual Basic]

Public Function AddItem( _

ByVal text As String _

) As C1MenuItem

[C#]

public C1MenuItem AddItem(

string text

);

[Delphi]

public function AddItem(

text: String

): C1MenuItem;

Remarks

Obsolete. Use Items.Add() instead.

See Also


C1MenuBase.LoadTree Method

C1MenuBase.LoadTree Method

Overload List

Loads the menu tree from XML.

[Visual Basic] Overloads Public Sub LoadTree(XmlTextReader)

[C#] public void LoadTree(XmlTextReader);

[Delphi] public procedure LoadTree(XmlTextReader); overload;

Loads the menu tree from XML.

[Visual Basic] Overloads Public Sub LoadTree(XmlTextReader, Boolean)

[C#] public void LoadTree(XmlTextReader, bool);

[Delphi] public procedure LoadTree(XmlTextReader; Boolean); overload;

Loads the menu tree from XML.

[Visual Basic] Overloads Public Sub LoadTree(XmlTextReader, Boolean, Boolean)

[C#] public void LoadTree(XmlTextReader, bool, bool);

[Delphi] public procedure LoadTree(XmlTextReader; Boolean; Boolean); overload;

See Also


C1MenuBase.LoadTree Method (XmlTextReader)

C1MenuBase.LoadTree Method (XmlTextReader)

Previous Next

Loads the menu tree from XML.

[Visual Basic]

Overloads Public Sub LoadTree( _

ByVal xtr As XmlTextReader _

)

[C#]

public void LoadTree(

XmlTextReader xtr

);

[Delphi]

public procedure LoadTree(

xtr: XmlTextReader

); overload;

Parameters

xtr

The XmlTextWriter object that is provided with the control content.

See Also


C1MenuBase.LoadTree Method (XmlTextReader, Boolean)

C1MenuBase.LoadTree Method (XmlTextReader, Boolean)

Previous Next

Loads the menu tree from XML.

[Visual Basic]

Overloads Public Sub LoadTree( _

ByVal xtr As XmlTextReader, _

ByVal styles As Boolean _

)

[C#]

public void LoadTree(

XmlTextReader xtr,

bool styles

);

[Delphi]

public procedure LoadTree(

xtr: XmlTextReader;

styles: Boolean

); overload;

Parameters

xtr

The XmlTextWriter object that provides with the control content.

styles

Whether or not the method have to load styles info.

See Also


C1MenuBase.LoadTree Method (XmlTextReader, Boolean, Boolean)

C1MenuBase.LoadTree Method (XmlTextReader, Boolean, Boolean)

Previous Next

Loads the menu tree from XML.

[Visual Basic]

Overloads Public Sub LoadTree( _

ByVal xtr As XmlTextReader, _

ByVal styles As Boolean, _

ByVal reset As Boolean _

)

[C#]

public void LoadTree(

XmlTextReader xtr,

bool styles,

bool reset

);

[Delphi]

public procedure LoadTree(

xtr: XmlTextReader;

styles: Boolean;

reset: Boolean

); overload;

Parameters

xtr

The XmlTextWriter object that provides with the control content.

styles

Whether or not the method have to load styles info.

reset

If true (default), reset all the properties which are not included in the xml file.

See Also


C1MenuBase.SaveTree Method

C1MenuBase.SaveTree Method

Overload List

Saves the menu tree as XML.

[Visual Basic] Overloads Public Sub SaveTree(XmlTextWriter)

[C#] public void SaveTree(XmlTextWriter);

[Delphi] public procedure SaveTree(XmlTextWriter); overload;

Saves the menu tree as XML.

[Visual Basic] Overloads Public Sub SaveTree(XmlTextWriter, Boolean)

[C#] public void SaveTree(XmlTextWriter, bool);

[Delphi] public procedure SaveTree(XmlTextWriter; Boolean); overload;

See Also


C1MenuBase.SaveTree Method (XmlTextWriter)

C1MenuBase.SaveTree Method (XmlTextWriter)

Previous Next

Saves the menu tree as XML.

[Visual Basic]

Overloads Public Sub SaveTree( _

ByVal xtw As XmlTextWriter _

)

[C#]

public void SaveTree(

XmlTextWriter xtw

);

[Delphi]

public procedure SaveTree(

xtw: XmlTextWriter

); overload;

Parameters

xtw

Provider to save control as XML.

See Also


C1MenuBase.SaveTree Method (XmlTextWriter, Boolean)

C1MenuBase.SaveTree Method (XmlTextWriter, Boolean)

Previous Next

Saves the menu tree as XML.

[Visual Basic]

Overloads Public Sub SaveTree( _

ByVal xtw As XmlTextWriter, _

ByVal styles As Boolean _

)

[C#]

public void SaveTree(

XmlTextWriter xtw,

bool styles

);

[Delphi]

public procedure SaveTree(

xtw: XmlTextWriter;

styles: Boolean

); overload;

Parameters

xtw

Provider to save control as XML.

styles

Whether or not the method have to save styles info.

See Also


C1MenuBase Events

C1MenuBase Events

The events of the C1MenuBase class are listed here. For a complete list of C1MenuBase class members, see the C1MenuBase Members topic.

Public Events

DataBinding (inherited from Control) | Fires when the control's data binding expressions are to be evaluated.
Disposed (inherited from Control) | Fires when the control has been disposed.
Init (inherited from Control) | Fires when the page has been initialized.
ItemClick | Fired when the child menu item is clicked.
ItemCommand | Fired when an item belonging to the menu is clicked.
Load (inherited from Control) | Fires when the page has been loaded.
PreRender (inherited from Control) | Fires before the page is rendered.
Unload (inherited from Control) | Fires when the page is unloaded.

See Also


C1MenuBase.ItemClick Event

C1MenuBase.ItemClick Event

Fired when the child menu item is clicked.

[Visual Basic]

Public Event ItemClick As ItemClickEventHandler

[C#]

public event ItemClickEventHandler ItemClick

[Delphi]

public property ItemClick: ItemClickEventHandler read remove_ItemClick write add_ItemClick;

See Also


C1MenuBase.ItemCommand Event

C1MenuBase.ItemCommand Event

Fired when an item belonging to the menu is clicked.

[Visual Basic]

Public Event ItemCommand As ItemCommandEventHandler

[C#]

public event ItemCommandEventHandler ItemCommand

[Delphi]

public property ItemCommand: ItemCommandEventHandler read remove_ItemCommand write add_ItemCommand;

See Also


C1MenuItem Class

C1MenuItem Class

Represents a menu item.

For a list of all members of this type, see C1MenuItem Members.

System.Object

System.Web.UI.Control

System.Web.UI.WebControls.WebControl

C1.Web.C1Command.C1MenuItem

[Visual Basic]

Public Class C1MenuItem

Inherits WebControl

Implements IPostBackEventHandler

[C#]

public class C1MenuItem : WebControl , IPostBackEventHandler

[Delphi]

type C1MenuItem = class (WebControl, IPostBackEventHandler);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1MenuItem Members

C1MenuItem Members

C1MenuItem overview

Public Properties

AccessKey (inherited from WebControl) | Keyboard shortcut used by the control.
AppRelativeTemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Attributes (inherited from WebControl) | Tag attributes of the control.
BackColor (inherited from WebControl) | Color of the background of the control.
BorderColor (inherited from WebControl) | Color of the border around the control.
BorderStyle (inherited from WebControl) | Style of the border around the control.
BorderWidth (inherited from WebControl) | Width of the border around the control.
Caption | Indicates whether the item is a caption (an item that cannot be clicked or selected).
CausesValidation | Determines whether the menu item causes validation to fire.
Checked | Indicates whether to display a check mark near the item.
ClientID (inherited from Control) | The ID of the control that is rendered for the client.
ClientScripts | Allows the specification of a client-side script for any event (previously only for onmousedown).
CommandArgument | The command argument associated with the menu item.
CommandName | The command name associated with the menu item.
Controls (inherited from Control) | The collection of child controls owned by the control.
ControlStyle (inherited from WebControl) | The style associated with the control.
ControlStyleCreated (inherited from WebControl) | Whether the style associated with the control has been created.
CssClass (inherited from WebControl) | CSS Class name applied to the control.
Delimiter | Indicates whether to show the item as a delimiter.
DisabledStyle | The style to use when the item is disabled.
Enabled (inherited from WebControl) | Enabled state of the control.
EnableViewState (inherited from Control) | Whether the control automatically saves its state for use in round-trips.
Font (inherited from WebControl) | The font used for text within the control.
ForeColor (inherited from WebControl) | Color of the text within the control.
HasSubMenu | Returns a value indicating whether the item contains a submenu.
Height (inherited from WebControl) | The height of the control.
ID (inherited from Control) | Programmatic name of the control.
ImageUrl | The image to show alongside the item.
LinkUrl | If not empty, clicking on the item will bring up this URL in the browser.
NamingContainer (inherited from Control) | The containing control or page within which ID is unique.
Page (inherited from Control) | The page containing the control.
Parent (inherited from Control) | The control containing this control.
Radio | If the item is Checked, indicates whether to show a bullet near the item.
Script | Arbitrary script that will be executed when the item is clicked.
SelectedStyle | The style to use when the item is selected.
Site (inherited from Control) | Site of the control.
StatusText | The text to show in the status area of the browser when the item is selected.
Style (inherited from WebControl) | Low-level access to control styles.
SubMenu | The submenu attached to this item.
TabIndex (inherited from WebControl) | The tab order of the control.
Target | Gets or sets the default target window or frame that displays the linked Web page content once an item is clicked.
TemplateControl (inherited from Control) | The TemplateControl that hosts this control.
TemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Text | The menu item text.
ToolTip (inherited from WebControl) | The tooltip displayed when the mouse is over the control.
UniqueID (inherited from Control) | The unique ID of the control within the page.
Visible (inherited from Control) | Indicates whether the control is visible and rendered.
Width (inherited from WebControl) | The width of the control.

Public Methods

AddSubMenu | Overloaded. Adds a submenu to the menu item.
RemoveSubMenu | Removes the item’s submenu if it exists.

Public Events

Click | Occurs when the control is clicked.
Command | Occurs when a menu item is clicked.
DataBinding (inherited from Control) | Fires when the control's data binding expressions are to be evaluated.
Disposed (inherited from Control) | Fires when the control has been disposed.
Init (inherited from Control) | Fires when the page has been initialized.
Load (inherited from Control) | Fires when the page has been loaded.
PreRender (inherited from Control) | Fires before the page is rendered.
Unload (inherited from Control) | Fires when the page is unloaded.

Protected Properties

ViewState (inherited from Control)

Current viewstate of the control.

See Also


C1MenuItem Properties

C1MenuItem Properties

The properties of the C1MenuItem class are listed here. For a complete list of C1MenuItem class members, see the C1MenuItem Members topic.

Public Properties

AccessKey (inherited from WebControl) | Keyboard shortcut used by the control.
AppRelativeTemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Attributes (inherited from WebControl) | Tag attributes of the control.
BackColor (inherited from WebControl) | Color of the background of the control.
BorderColor (inherited from WebControl) | Color of the border around the control.
BorderStyle (inherited from WebControl) | Style of the border around the control.
BorderWidth (inherited from WebControl) | Width of the border around the control.
Caption | Indicates whether the item is a caption (an item that cannot be clicked or selected).
CausesValidation | Determines whether the menu item causes validation to fire.
Checked | Indicates whether to display a check mark near the item.
ClientID (inherited from Control) | The ID of the control that is rendered for the client.
ClientScripts | Allows the specification of a client-side script for any event (previously only for onmousedown).
CommandArgument | The command argument associated with the menu item.
CommandName | The command name associated with the menu item.
Controls (inherited from Control) | The collection of child controls owned by the control.
ControlStyle (inherited from WebControl) | The style associated with the control.
ControlStyleCreated (inherited from WebControl) | Whether the style associated with the control has been created.
CssClass (inherited from WebControl) | CSS Class name applied to the control.
Delimiter | Indicates whether to show the item as a delimiter.
DisabledStyle | The style to use when the item is disabled.
Enabled (inherited from WebControl) | Enabled state of the control.
EnableViewState (inherited from Control) | Whether the control automatically saves its state for use in round-trips.
Font (inherited from WebControl) | The font used for text within the control.
ForeColor (inherited from WebControl) | Color of the text within the control.
HasSubMenu | Returns a value indicating whether the item contains a submenu.
Height (inherited from WebControl) | The height of the control.
ID (inherited from Control) | Programmatic name of the control.
ImageUrl | The image to show alongside the item.
LinkUrl | If not empty, clicking on the item will bring up this URL in the browser.
NamingContainer (inherited from Control) | The containing control or page within which ID is unique.
Page (inherited from Control) | The page containing the control.
Parent (inherited from Control) | The control containing this control.
Radio | If the item is Checked, indicates whether to show a bullet near the item.
Script | Arbitrary script that will be executed when the item is clicked.
SelectedStyle | The style to use when the item is selected.
Site (inherited from Control) | Site of the control.
StatusText | The text to show in the status area of the browser when the item is selected.
Style (inherited from WebControl) | Low-level access to control styles.
SubMenu | The submenu attached to this item.
TabIndex (inherited from WebControl) | The tab order of the control.
Target | Gets or sets the default target window or frame that displays the linked Web page content once an item is clicked.
TemplateControl (inherited from Control) | The TemplateControl that hosts this control.
TemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Text | The menu item text.
ToolTip (inherited from WebControl) | The tooltip displayed when the mouse is over the control.
UniqueID (inherited from Control) | The unique ID of the control within the page.
Visible (inherited from Control) | Indicates whether the control is visible and rendered.
Width (inherited from WebControl) | The width of the control.

Protected Properties

ViewState (inherited from Control)

Current viewstate of the control.

See Also


C1MenuItem.Caption Property

C1MenuItem.Caption Property

Indicates whether the item is a caption (an item that cannot be clicked or selected).

[Visual Basic]

Public Property Caption As Boolean

[C#]

public bool Caption {get;set;}

[Delphi]

public property Caption: Boolean read get_Caption write set_Caption;

See Also


C1MenuItem.CausesValidation Property

C1MenuItem.CausesValidation Property

Determines whether the menu item causes validation to fire.

[Visual Basic]

Public Property CausesValidation As Boolean

[C#]

public bool CausesValidation {get;set;}

[Delphi]

public property CausesValidation: Boolean read get_CausesValidation write set_CausesValidation;

See Also


C1MenuItem.Checked Property

C1MenuItem.Checked Property

Indicates whether to display a check mark near the item.

[Visual Basic]

Public Property Checked As Boolean

[C#]

public bool Checked {get;set;}

[Delphi]

public property Checked: Boolean read get_Checked write set_Checked;

See Also


C1MenuItem.ClientScripts Property

C1MenuItem.ClientScripts Property

Allows the specification of a client-side script for any event (previously only for onmousedown).

[Visual Basic]

Public Property ClientScripts As ScriptDefCollection

[C#]

public ScriptDefCollection ClientScripts {get;set;}

[Delphi]

public property ClientScripts: ScriptDefCollection read get_ClientScripts write set_ClientScripts;

Remarks

This property allows a script handler to be provided for any client-side event. At design time, an editor is provided where the event name can be selected from list or typed, and arbitrary code for the event handler can be entered.

Example

item.ClientScripts[“onmousedown”] = “alert(‘mouse down’)”;

See Also


C1MenuItem.CommandArgument Property

C1MenuItem.CommandArgument Property

The command argument associated with the menu item.

[Visual Basic]

Public Property CommandArgument As String

[C#]

public string CommandArgument {get;set;}

[Delphi]

public property CommandArgument: String read get_CommandArgument write set_CommandArgument;

See Also


C1MenuItem.CommandName Property

C1MenuItem.CommandName Property

The command name associated with the menu item.

[Visual Basic]

Public Property CommandName As String

[C#]

public string CommandName {get;set;}

[Delphi]

public property CommandName: String read get_CommandName write set_CommandName;

See Also


C1MenuItem.Delimiter Property

C1MenuItem.Delimiter Property

Indicates whether to show the item as a delimiter.

[Visual Basic]

Public Property Delimiter As Boolean

[C#]

public bool Delimiter {get;set;}

[Delphi]

public property Delimiter: Boolean read get_Delimiter write set_Delimiter;

Remarks

When Delimiter = True, you can use Height, BorderStyle, BorderColor, and Borderwidth properties to set the delimter's type. Also, you can use C1MenuItem.ImageUrl property for defining the size of the delimiter.

See Also


C1MenuItem.DisabledStyle Property

C1MenuItem.DisabledStyle Property

The style to use when the item is disabled.

[Visual Basic]

Public ReadOnly Property DisabledStyle As C1MenuItemStyle

[C#]

public C1MenuItemStyle DisabledStyle {get;}

[Delphi]

public property DisabledStyle: C1MenuItemStyle read get_DisabledStyle;

See Also


C1MenuItem.HasSubMenu Property

C1MenuItem.HasSubMenu Property

Returns a value indicating whether the item contains a submenu.

[Visual Basic]

Public ReadOnly Property HasSubMenu As Boolean

[C#]

public bool HasSubMenu {get;}

[Delphi]

public property HasSubMenu: Boolean read get_HasSubMenu;

See Also


C1MenuItem.ImageUrl Property

C1MenuItem.ImageUrl Property

The image to show alongside the item.

[Visual Basic]

Public Property ImageUrl As String

[C#]

public string ImageUrl {get;set;}

[Delphi]

public property ImageUrl: String read get_ImageUrl write set_ImageUrl;

See Also


C1MenuItem.LinkUrl Property

C1MenuItem.LinkUrl Property

If not empty, clicking on the item will bring up this URL in the browser.

[Visual Basic]

Public Property LinkUrl As String

[C#]

public string LinkUrl {get;set;}

[Delphi]

public property LinkUrl: String read get_LinkUrl write set_LinkUrl;

See Also


C1MenuItem.Radio Property

C1MenuItem.Radio Property

If the item is Checked, indicates whether to show a bullet near the item.

[Visual Basic]

Public Property Radio As Boolean

[C#]

public bool Radio {get;set;}

[Delphi]

public property Radio: Boolean read get_Radio write set_Radio;

See Also


C1MenuItem.Script Property

C1MenuItem.Script Property

Arbitrary script that will be executed when the item is clicked.

[Visual Basic]

Public Property Script As String

[C#]

public string Script {get;set;}

[Delphi]

public property Script: String read get_Script write set_Script;

See Also


C1MenuItem.SelectedStyle Property

C1MenuItem.SelectedStyle Property

The style to use when the item is selected.

[Visual Basic]

Public ReadOnly Property SelectedStyle As C1MenuItemStyle

[C#]

public C1MenuItemStyle SelectedStyle {get;}

[Delphi]

public property SelectedStyle: C1MenuItemStyle read get_SelectedStyle;

See Also


C1MenuItem.StatusText Property

C1MenuItem.StatusText Property

The text to show in the status area of the browser when the item is selected.

[Visual Basic]

Public Property StatusText As String

[C#]

public string StatusText {get;set;}

[Delphi]

public property StatusText: String read get_StatusText write set_StatusText;

See Also


C1MenuItem.SubMenu Property

C1MenuItem.SubMenu Property

The submenu attached to this item.

[Visual Basic]

Public Property SubMenu As C1SubMenu

[C#]

public C1SubMenu SubMenu {get;set;}

[Delphi]

public property SubMenu: C1SubMenu read get_SubMenu write set_SubMenu;

See Also


C1MenuItem.Target Property

C1MenuItem.Target Property

Gets or sets the default target window or frame that displays the linked Web page content once an item is clicked.

[Visual Basic]

Public Property Target As String

[C#]

public string Target {get;set;}

[Delphi]

public property Target: String read get_Target write set_Target;

See Also


C1MenuItem.Text Property

C1MenuItem.Text Property

The menu item text.

[Visual Basic]

Public Property Text As String

[C#]

public string Text {get;set;}

[Delphi]

public property Text: String read get_Text write set_Text;

See Also


C1MenuItem Methods

C1MenuItem Methods

The methods of the C1MenuItem class are listed here. For a complete list of C1MenuItem class members, see the C1MenuItem Members topic.

Public Methods

AddSubMenu | Overloaded. Adds a submenu to the menu item.
RemoveSubMenu | Removes the item’s submenu if it exists.

See Also


C1MenuItem.AddSubMenu Method

C1MenuItem.AddSubMenu Method

Overload List

Adds a submenu to the menu item.

[Visual Basic] Overloads Public Function AddSubMenu() As C1SubMenu

[C#] public C1SubMenu AddSubMenu();

[Delphi] public function AddSubMenu() : C1SubMenu; overload;

Adds a submenu to the menu item.

[Visual Basic] Overloads Public Function AddSubMenu(Control) As C1SubMenu

[C#] public C1SubMenu AddSubMenu(Control);

[Delphi] public function AddSubMenu(Control) : C1SubMenu; overload;

See Also


C1MenuItem.AddSubMenu Method ()

C1MenuItem.AddSubMenu Method ()

Previous Next

Adds a submenu to the menu item.

[Visual Basic]

Overloads Public Function AddSubMenu() As C1SubMenu

[C#]

public C1SubMenu AddSubMenu()

[Delphi]

public function AddSubMenu():
C1SubMenu;
overload;

Return Value

SubMenu which has been created.

Remarks

If parent is null, the submenu is added to the Page.Controls collection, otherwise it is added to the specified parent's Controls collection. The AddSubMenu() overload (without parameters) adds new submenus to the Controls collection of the parent menu of the menu item the method is called on. This fixes problems with "cannot modify parents' controls collection" errors when adding submenus programmatically. When menus are loaded from XML, submenus are added to the Page.Controls collection as before.

See Also


C1MenuItem.AddSubMenu Method (Control)

C1MenuItem.AddSubMenu Method (Control)

Previous Next

Adds a submenu to the menu item.

[Visual Basic]

Overloads Public Function AddSubMenu( _

ByVal parent As Control _

) As C1SubMenu

[C#]

public C1SubMenu AddSubMenu(

Control parent

);

[Delphi]

public function AddSubMenu(

parent: Control

): C1SubMenu; overload;

Parameters

parent

If parent is null, the submenu is added to the Page.Controls collection, otherwise it is added to the specified parent's Controls collection.

Remarks

The AddSubMenu() overload (without parameters) adds new submenus to the Controls collection of the parent menu of the menu item the method is called on. This fixes problems with "cannot modify parents' controls collection" errors when adding submenus programmatically. When menus are loaded from XML, submenus are added to the Page.Controls collection as before.

See Also


C1MenuItem.RemoveSubMenu Method

C1MenuItem.RemoveSubMenu Method

Removes the item’s submenu if it exists.

[Visual Basic]

Public Sub RemoveSubMenu()

[C#]

public void RemoveSubMenu()

[Delphi]

public procedure RemoveSubMenu();

See Also


C1MenuItem Events

C1MenuItem Events

The events of the C1MenuItem class are listed here. For a complete list of C1MenuItem class members, see the C1MenuItem Members topic.

Public Events

Click | Occurs when the control is clicked.
Command | Occurs when a menu item is clicked.
DataBinding (inherited from Control) | Fires when the control's data binding expressions are to be evaluated.
Disposed (inherited from Control) | Fires when the control has been disposed.
Init (inherited from Control) | Fires when the page has been initialized.
Load (inherited from Control) | Fires when the page has been loaded.
PreRender (inherited from Control) | Fires before the page is rendered.
Unload (inherited from Control) | Fires when the page is unloaded.

See Also


C1MenuItem.Click Event

C1MenuItem.Click Event

Occurs when the control is clicked.

[Visual Basic]

Public Event Click As EventHandler

[C#]

public event EventHandler Click

[Delphi]

public property Click: EventHandler read remove_Click write add_Click;

See Also


C1MenuItem.Command Event

C1MenuItem.Command Event

Occurs when a menu item is clicked.

[Visual Basic]

Public Event Command As CommandEventHandler

[C#]

public event CommandEventHandler Command

[Delphi]

public property Command: CommandEventHandler read remove_Command write add_Command;

See Also


C1MenuItemCollection Class

C1MenuItemCollection Class

This class describes a collection of menu items (of the type C1MenuItem) contained in a menu. It implements the following interfaces: IList, ICollection, IEnumerable.

For a list of all members of this type, see C1MenuItemCollection Members.

System.Object

C1.Web.C1Command.C1MenuItemCollection

[Visual Basic]

Public Class C1MenuItemCollection

Implements ICollection, IEnumerable, IList

[C#]

public class C1MenuItemCollection : ICollection, IEnumerable, IList

[Delphi]

type C1MenuItemCollection = class (TObject, ICollection, IEnumerable, IList);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1MenuItemCollection Members

C1MenuItemCollection Members

C1MenuItemCollection overview

Public Constructors

C1MenuItemCollection Constructor

Initializes a new instance of the C1MenuItemCollection class.

Public Properties

Count | Gets the number of items in the collection.
IsFixedSize | Gets a value indicating whether the collection has fixed size.
IsReadOnly | Gets a value indicating whether the collection is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the menu item at the specified indexed location in the menu item collection.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

Add | Overloaded. Adds a new menu item at the end of the collection.
Clear | Removes all menu items from the collection.
Contains | Determines whether the specified item is a member of the collection.
CopyTo | Copies all items in the collection to the specified array, starting at the specified destination index.
GetEnumerator | Returns an enumerator that can be used to iterate through the menu item collection.
IndexOf | Gets the index of the specified menu item in the collection.
Insert | Overloaded. Inserts the specified menu item into the collection at the specified position.
Remove | Removes the specified menu item from the collection.
RemoveAt | Removes the menu item at the specified position from the collection.

See Also


C1MenuItemCollection Constructor

C1MenuItemCollection Constructor

Initializes a new instance of the C1MenuItemCollection class.

[Visual Basic]

Public Function New( _

ByVal owner As C1MenuBase _

)

[C#]

public C1MenuItemCollection(

C1MenuBase owner

);

[Delphi]

public constructor Create(

owner: C1MenuBase

);

Parameters

owner

See Also


C1MenuItemCollection Properties

C1MenuItemCollection Properties

The properties of the C1MenuItemCollection class are listed here. For a complete list of C1MenuItemCollection class members, see the C1MenuItemCollection Members topic.

Public Properties

Count | Gets the number of items in the collection.
IsFixedSize | Gets a value indicating whether the collection has fixed size.
IsReadOnly | Gets a value indicating whether the collection is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the menu item at the specified indexed location in the menu item collection.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also


C1MenuItemCollection.Count Property

C1MenuItemCollection.Count Property

Gets the number of items in the collection.

[Visual Basic]

Overridable Public ReadOnly Property Count As Integer Implements ICollection.Count

[C#]

virtual public int Count {get;}

[Delphi]

public property Count: Int32 read get_Count;

Implements

ICollection.Count

See Also


C1MenuItemCollection.IsFixedSize Property

C1MenuItemCollection.IsFixedSize Property

Gets a value indicating whether the collection has fixed size.

[Visual Basic]

Overridable Public ReadOnly Property IsFixedSize As Boolean Implements IList.IsFixedSize

[C#]

virtual public bool IsFixedSize {get;}

[Delphi]

public property IsFixedSize: Boolean read get_IsFixedSize;

Implements

IList.IsFixedSize

See Also


C1MenuItemCollection.IsReadOnly Property

C1MenuItemCollection.IsReadOnly Property

Gets a value indicating whether the collection is read-only.

[Visual Basic]

Overridable Public ReadOnly Property IsReadOnly As Boolean Implements IList.IsReadOnly

[C#]

virtual public bool IsReadOnly {get;}

[Delphi]

public property IsReadOnly: Boolean read get_IsReadOnly;

Implements

IList.IsReadOnly

See Also


C1MenuItemCollection.IsSynchronized Property

C1MenuItemCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]

Overridable Public ReadOnly Property IsSynchronized As Boolean Implements ICollection.IsSynchronized

[C#]

virtual public bool IsSynchronized {get;}

[Delphi]

public property IsSynchronized: Boolean read get_IsSynchronized;

Implements

ICollection.IsSynchronized

See Also


C1MenuItemCollection.Item Property

C1MenuItemCollection.Item Property

Gets or sets the menu item at the specified indexed location in the menu item collection.

[Visual Basic]

Overridable Public Default Property Item( _

ByVal index As Integer _

) As C1MenuItem Implements IList.Item

[C#]

virtual public C1MenuItem this[

int index

] {get;set;}

[Delphi]

public property Item[

index: Int32

]: C1MenuItem read get_Item write set_Item;

Implements

IList.Item

See Also


C1MenuItemCollection.SyncRoot Property

C1MenuItemCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

[Visual Basic]

Overridable Public ReadOnly Property SyncRoot As Object Implements ICollection.SyncRoot

[C#]

virtual public object SyncRoot {get;}

[Delphi]

public property SyncRoot: Object read get_SyncRoot;

Implements

ICollection.SyncRoot

See Also


C1MenuItemCollection Methods

C1MenuItemCollection Methods

The methods of the C1MenuItemCollection class are listed here. For a complete list of C1MenuItemCollection class members, see the C1MenuItemCollection Members topic.

Public Methods

Add | Overloaded. Adds a new menu item at the end of the collection.
Clear | Removes all menu items from the collection.
Contains | Determines whether the specified item is a member of the collection.
CopyTo | Copies all items in the collection to the specified array, starting at the specified destination index.
GetEnumerator | Returns an enumerator that can be used to iterate through the menu item collection.
IndexOf | Gets the index of the specified menu item in the collection.
Insert | Overloaded. Inserts the specified menu item into the collection at the specified position.
Remove | Removes the specified menu item from the collection.
RemoveAt | Removes the menu item at the specified position from the collection.

See Also


C1MenuItemCollection.Add Method

C1MenuItemCollection.Add Method

Overload List

Adds a new menu item at the end of the collection.

[Visual Basic] Overloads Overridable Public Function Add(C1MenuItem) As Integer

[C#] virtual public int Add(C1MenuItem);

[Delphi] public function Add(C1MenuItem) : Int32; overload; virtual;

Adds a new menu item at the end of the collection.

[Visual Basic] Overloads Overridable Public Function Add(String) As Integer

[C#] virtual public int Add(string);

[Delphi] public function Add(String) : Int32; overload; virtual;

See Also


C1MenuItemCollection.Add Method (C1MenuItem)

C1MenuItemCollection.Add Method (C1MenuItem)

Previous Next

Adds a new menu item at the end of the collection.

[Visual Basic]

Overloads Overridable Public Function Add( _

ByVal item As C1MenuItem _

) As Integer

[C#]

virtual public int Add(

C1MenuItem item

);

[Delphi]

public function Add(

item: C1MenuItem

): Int32; overload; virtual;

Parameters

item

Item to add to the collection.

Return Value

Index of the item in the collection.

See Also


C1MenuItemCollection.Add Method (String)

C1MenuItemCollection.Add Method (String)

Previous Next

Adds a new menu item at the end of the collection.

[Visual Basic]

Overloads Overridable Public Function Add( _

ByVal text As String _

) As Integer

[C#]

virtual public int Add(

string text

);

[Delphi]

public function Add(

text: String

): Int32; overload; virtual;

Parameters

text

Text for the new item.

Return Value

The instance of the new item.

See Also


C1MenuItemCollection.Clear Method

C1MenuItemCollection.Clear Method

Removes all menu items from the collection.

[Visual Basic]

Overridable Public Sub Clear() Implements IList.Clear

[C#]

virtual public void Clear()

[Delphi]

public procedure Clear(); virtual;

Implements

IList.Clear

See Also


C1MenuItemCollection.Contains Method

C1MenuItemCollection.Contains Method

Determines whether the specified item is a member of the collection.

[Visual Basic]

Overridable Public Function Contains( _

ByVal item As C1MenuItem _

) As Boolean

[C#]

virtual public bool Contains(

C1MenuItem item

);

[Delphi]

public function Contains(

item: C1MenuItem

): Boolean; virtual;

Parameters

item

Specifies item to find in collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also


C1MenuItemCollection.CopyTo Method

C1MenuItemCollection.CopyTo Method

Copies all items in the collection to the specified array, starting at the specified destination index.

[Visual Basic]

Overridable Public Sub CopyTo( _

ByVal array As Array, _

ByVal index As Integer _

) Implements ICollection.CopyTo

[C#]

virtual public void CopyTo(

Array array,

int index

);

[Delphi]

public procedure CopyTo(

array: Array;

index: Int32

); virtual;

Implements

ICollection.CopyTo

Parameters

array

The one-dimensional Array that is the destination of the elements copied from the current Array.

index

A 32-bit integer that represents the index in array at which copying begins.

See Also


C1MenuItemCollection.GetEnumerator Method

C1MenuItemCollection.GetEnumerator Method

Returns an enumerator that can be used to iterate through the menu item collection.

[Visual Basic]

Overridable Public Function GetEnumerator() As IEnumerator Implements IEnumerable.GetEnumerator

[C#]

virtual public IEnumerator GetEnumerator()

[Delphi]

public function GetEnumerator(): IEnumerator; virtual;

Implements

IEnumerable.GetEnumerator

Return Value

An IEnumerator object that can be used to iterate through the collection.

See Also


C1MenuItemCollection.IndexOf Method

C1MenuItemCollection.IndexOf Method

Gets the index of the specified menu item in the collection.

[Visual Basic]

Overridable Public Function IndexOf( _

ByVal item As C1MenuItem _

) As Integer

[C#]

virtual public int IndexOf(

C1MenuItem item

);

[Delphi]

public function IndexOf(

item: C1MenuItem

): Int32; virtual;

Parameters

item

The item to locate in the collection.

Return Value

See Also


C1MenuItemCollection.Insert Method

C1MenuItemCollection.Insert Method

Overload List

Inserts the specified menu item into the collection at the specified position.

[Visual Basic] Overloads Overridable Public Sub Insert(Integer, C1MenuItem)

[C#] virtual public void Insert(int, C1MenuItem);

[Delphi] public procedure Insert(Int32; C1MenuItem); overload; virtual;

Creates new menu item with the specified text and then inserts one into the collection at the specified position.

[Visual Basic] Overloads Overridable Public Sub Insert(Integer, String)

[C#] virtual public void Insert(int, string);

[Delphi] public procedure Insert(Int32; String); overload; virtual;

See Also


C1MenuItemCollection.Insert Method (Int32, C1MenuItem)

C1MenuItemCollection.Insert Method (Int32, C1MenuItem)

Previous Next

Inserts the specified menu item into the collection at the specified position.

[Visual Basic]

Overloads Overridable Public Sub Insert( _

ByVal index As Integer, _

ByVal item As C1MenuItem _

)

[C#]

virtual public void Insert(

int index,

C1MenuItem item

);

[Delphi]

public procedure Insert(

index: Int32;

item: C1MenuItem

); overload; virtual;

Parameters

index

The zero-based index at which item should be inserted.

item

The item to insert.

See Also


C1MenuItemCollection.Insert Method (Int32, String)

C1MenuItemCollection.Insert Method (Int32, String)

Previous Next

Creates new menu item with the specified text and then inserts one into the collection at the specified position.

[Visual Basic]

Overloads Overridable Public Sub Insert( _

ByVal index As Integer, _

ByVal text As String _

)

[C#]

virtual public void Insert(

int index,

string text

);

[Delphi]

public procedure Insert(

index: Int32;

text: String

); overload; virtual;

Parameters

index

The zero-based index at which item should be inserted.

text

The text for the new item.

See Also


C1MenuItemCollection.Remove Method

C1MenuItemCollection.Remove Method

Removes the specified menu item from the collection.

[Visual Basic]

Overridable Public Sub Remove( _

ByVal item As C1MenuItem _

)

[C#]

virtual public void Remove(

C1MenuItem item

);

[Delphi]

public procedure Remove(

item: C1MenuItem

); virtual;

Parameters

item

The item to remove.

See Also


C1MenuItemCollection.RemoveAt Method

C1MenuItemCollection.RemoveAt Method

Removes the menu item at the specified position from the collection.

[Visual Basic]

Overridable Public Sub RemoveAt( _

ByVal index As Integer _

) Implements IList.RemoveAt

[C#]

virtual public void RemoveAt(

int index

);

[Delphi]

public procedure RemoveAt(

index: Int32

); virtual;

Implements

IList.RemoveAt

Parameters

index

The zero-based index of the item to remove.

See Also


C1MenuItemCollection.C1MenuItemCollectionEnumerator Class

C1MenuItemCollection.C1MenuItemCollectionEnumerator Class

Represents Enumerator for items within menu.

For a list of all members of this type, see C1MenuItemCollection.C1MenuItemCollectionEnumerator Members.

System.Object

C1.Web.C1Command.C1MenuItemCollection.C1MenuItemCollectionEnumerator

[Visual Basic]

Public Class C1MenuItemCollection.C1MenuItemCollectionEnumerator

Implements IEnumerator

[C#]

public class C1MenuItemCollection.C1MenuItemCollectionEnumerator : IEnumerator

[Delphi]

type C1MenuItemCollection.C1MenuItemCollectionEnumerator = class (TObject, IEnumerator);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1MenuItemCollection.C1MenuItemCollectionEnumerator Members

C1MenuItemCollection.C1MenuItemCollectionEnumerator Members

C1MenuItemCollection.C1MenuItemCollectionEnumerator overview

See Also


C1MenuItemStyle Class

C1MenuItemStyle Class

For a list of all members of this type, see C1MenuItemStyle Members.

System.Object

C1.Web.C1Command.C1MenuItemStyle

[Visual Basic]

Public Class C1MenuItemStyle

[C#]

public class C1MenuItemStyle

[Delphi]

type C1MenuItemStyle = class;

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1MenuItemStyle Members

C1MenuItemStyle Members

C1MenuItemStyle overview

Public Properties

BackColor | Item background color.
BorderColor | Item border color.
BorderStyle | Item border style.
BorderWidth | Item border width.
CssClass | CSS class name applied to the item.
ForeColor | Item text color.
ImageUrl | The image to show alongside the item.

See Also


C1MenuItemStyle Properties

C1MenuItemStyle Properties

The properties of the C1MenuItemStyle class are listed here. For a complete list of C1MenuItemStyle class members, see the C1MenuItemStyle Members topic.

Public Properties

BackColor | Item background color.
BorderColor | Item border color.
BorderStyle | Item border style.
BorderWidth | Item border width.
CssClass | CSS class name applied to the item.
ForeColor | Item text color.
ImageUrl | The image to show alongside the item.

See Also


C1MenuItemStyle.BackColor Property

C1MenuItemStyle.BackColor Property

Item background color.

[Visual Basic]

Public Property BackColor As Color

[C#]

public Color BackColor {get;set;}

[Delphi]

public property BackColor: Color read get_BackColor write set_BackColor;

See Also


C1MenuItemStyle.BorderColor Property

C1MenuItemStyle.BorderColor Property

Item border color.

[Visual Basic]

Public Property BorderColor As Color

[C#]

public Color BorderColor {get;set;}

[Delphi]

public property BorderColor: Color read get_BorderColor write set_BorderColor;

See Also


C1MenuItemStyle.BorderStyle Property

C1MenuItemStyle.BorderStyle Property

Item border style.

[Visual Basic]

Public Property BorderStyle As BorderStyle

[C#]

public BorderStyle BorderStyle {get;set;}

[Delphi]

public property BorderStyle: BorderStyle read get_BorderStyle write set_BorderStyle;

See Also


C1MenuItemStyle.BorderWidth Property

C1MenuItemStyle.BorderWidth Property

Item border width.

[Visual Basic]

Public Property BorderWidth As Unit

[C#]

public Unit BorderWidth {get;set;}

[Delphi]

public property BorderWidth: Unit read get_BorderWidth write set_BorderWidth;

See Also


C1MenuItemStyle.CssClass Property

C1MenuItemStyle.CssClass Property

CSS class name applied to the item.

[Visual Basic]

Public Property CssClass As String

[C#]

public string CssClass {get;set;}

[Delphi]

public property CssClass: String read get_CssClass write set_CssClass;

See Also


C1MenuItemStyle.ForeColor Property

C1MenuItemStyle.ForeColor Property

Item text color.

[Visual Basic]

Public Property ForeColor As Color

[C#]

public Color ForeColor {get;set;}

[Delphi]

public property ForeColor: Color read get_ForeColor write set_ForeColor;

See Also


C1MenuItemStyle.ImageUrl Property

C1MenuItemStyle.ImageUrl Property

The image to show alongside the item.

[Visual Basic]

Public Property ImageUrl As String

[C#]

public string ImageUrl {get;set;}

[Delphi]

public property ImageUrl: String read get_ImageUrl write set_ImageUrl;

See Also


C1SubMenu Class

C1SubMenu Class

Represents a submenu object.

For a list of all members of this type, see C1SubMenu Members.

System.Object

System.Web.UI.Control

System.Web.UI.WebControls.WebControl

System.Web.UI.WebControls.Panel

C1.Web.C1Command.C1MenuBase

C1.Web.C1Command.C1SubMenu

[Visual Basic]

Public Class C1SubMenu

Inherits C1MenuBase

[C#]

public class C1SubMenu : C1MenuBase

[Delphi]

type C1SubMenu = class (C1MenuBase);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1SubMenu Members

C1SubMenu Members

C1SubMenu overview

Public Constructors

C1SubMenu Constructor

Initializes a new instance of the C1SubMenu class.

Public Properties

AccessKey (inherited from WebControl) | Keyboard shortcut used by the control.
AppRelativeTemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Attributes (inherited from WebControl) | Tag attributes of the control.
BackColor (inherited from WebControl) | Color of the background of the control.
BackImageUrl (inherited from Panel) | The background image of the panel.
BorderColor (inherited from WebControl) | Color of the border around the control.
BorderStyle (inherited from WebControl) | Style of the border around the control.
BorderWidth (inherited from WebControl) | Width of the border around the control.
ClientID (inherited from Control) | The ID of the control that is rendered for the client.
Controls (inherited from Control) | The collection of child controls owned by the control.
ControlStyle (inherited from WebControl) | The style associated with the control.
ControlStyleCreated (inherited from WebControl) | Whether the style associated with the control has been created.
CssClass (inherited from WebControl) | CSS Class name applied to the control.
DefaultButton (inherited from Panel) | The default button for the panel.
Direction (inherited from Panel) | The direction of text in the panel.
DisabledItemStyle (inherited from C1MenuBase) | The style applied to disabled items in this menu.
Enabled (inherited from WebControl) | Enabled state of the control.
EnableViewState (inherited from Control) | Whether the control automatically saves its state for use in round-trips.
Font (inherited from WebControl) | The font used for text within the control.
ForeColor (inherited from WebControl) | Color of the text within the control.
GroupingText (inherited from Panel) | The text of group box around this control's contents.
Height (inherited from WebControl) | The height of the control.
IconBarWidth (inherited from C1MenuBase) | Sets or returns the width of the icon bar drawn on the side of the menus.
ID (inherited from Control) | Programmatic name of the control.
InheritParentStyle | Indicates whether to inherit style from the parent menu.
Items (inherited from C1MenuBase) | Gets the collection of menu items contained in this menu.
ItemSpacing (inherited from C1MenuBase) | Gets or sets spacing between the menu's border and item's border.
ItemStyle (inherited from C1MenuBase) | The style applied to items in this menu.
ItemTextSpacing (inherited from C1MenuBase) | Gets or sets spacing between the item's border and item's text.
MenuLayout | Overriden. The layout for the submenus is always vertical.
NamingContainer (inherited from Control) | The containing control or page within which ID is unique.
Page (inherited from Control) | The page containing the control.
Parent (inherited from Control) | The control containing this control.
ParentMenu | Returns the parent menu.
ParentMenuItem | Returns the parent menu item.
ScrollBars (inherited from Panel) | The appearance of scrollbars for the panel.
SelectedItemStyle (inherited from C1MenuBase) | The style applied to selected items in this menu.
Site (inherited from Control) | Site of the control.
Style (inherited from WebControl) | Low-level access to control styles.
TabIndex (inherited from WebControl) | The tab order of the control.
Target (inherited from C1MenuBase) | Gets or sets the default target window or frame that displays the linked Web page content once an item is clicked.
TemplateControl (inherited from Control) | The TemplateControl that hosts this control.
TemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
ToolTip (inherited from WebControl) | The tooltip displayed when the mouse is over the control.
UniqueID (inherited from Control) | The unique ID of the control within the page.
Visible (inherited from Control) | Indicates whether the control is visible and rendered.
Width (inherited from WebControl) | The width of the control.

Public Events

DataBinding (inherited from Control) | Fires when the control's data binding expressions are to be evaluated.
Disposed (inherited from Control) | Fires when the control has been disposed.
Init (inherited from Control) | Fires when the page has been initialized.
ItemClick (inherited from C1MenuBase) | Fired when the child menu item is clicked.
ItemCommand (inherited from C1MenuBase) | Fired when an item belonging to the menu is clicked.
Load (inherited from Control) | Fires when the page has been loaded.
PreRender (inherited from Control) | Fires before the page is rendered.
Unload (inherited from Control) | Fires when the page is unloaded.

Protected Properties

ViewState (inherited from Control)

Current viewstate of the control.

See Also


C1SubMenu Constructor

C1SubMenu Constructor

Initializes a new instance of the C1SubMenu class.

[Visual Basic]

Public Function New()

[C#]

public C1SubMenu()

[Delphi]

public constructor Create();

See Also


C1SubMenu Properties

C1SubMenu Properties

The properties of the C1SubMenu class are listed here. For a complete list of C1SubMenu class members, see the C1SubMenu Members topic.

Public Properties

AccessKey (inherited from WebControl) | Keyboard shortcut used by the control.
AppRelativeTemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Attributes (inherited from WebControl) | Tag attributes of the control.
BackColor (inherited from WebControl) | Color of the background of the control.
BackImageUrl (inherited from Panel) | The background image of the panel.
BorderColor (inherited from WebControl) | Color of the border around the control.
BorderStyle (inherited from WebControl) | Style of the border around the control.
BorderWidth (inherited from WebControl) | Width of the border around the control.
ClientID (inherited from Control) | The ID of the control that is rendered for the client.
Controls (inherited from Control) | The collection of child controls owned by the control.
ControlStyle (inherited from WebControl) | The style associated with the control.
ControlStyleCreated (inherited from WebControl) | Whether the style associated with the control has been created.
CssClass (inherited from WebControl) | CSS Class name applied to the control.
DefaultButton (inherited from Panel) | The default button for the panel.
Direction (inherited from Panel) | The direction of text in the panel.
DisabledItemStyle (inherited from C1MenuBase) | The style applied to disabled items in this menu.
Enabled (inherited from WebControl) | Enabled state of the control.
EnableViewState (inherited from Control) | Whether the control automatically saves its state for use in round-trips.
Font (inherited from WebControl) | The font used for text within the control.
ForeColor (inherited from WebControl) | Color of the text within the control.
GroupingText (inherited from Panel) | The text of group box around this control's contents.
Height (inherited from WebControl) | The height of the control.
IconBarWidth (inherited from C1MenuBase) | Sets or returns the width of the icon bar drawn on the side of the menus.
ID (inherited from Control) | Programmatic name of the control.
InheritParentStyle | Indicates whether to inherit style from the parent menu.
Items (inherited from C1MenuBase) | Gets the collection of menu items contained in this menu.
ItemSpacing (inherited from C1MenuBase) | Gets or sets spacing between the menu's border and item's border.
ItemStyle (inherited from C1MenuBase) | The style applied to items in this menu.
ItemTextSpacing (inherited from C1MenuBase) | Gets or sets spacing between the item's border and item's text.
MenuLayout | Overriden. The layout for the submenus is always vertical.
NamingContainer (inherited from Control) | The containing control or page within which ID is unique.
Page (inherited from Control) | The page containing the control.
Parent (inherited from Control) | The control containing this control.
ParentMenu | Returns the parent menu.
ParentMenuItem | Returns the parent menu item.
ScrollBars (inherited from Panel) | The appearance of scrollbars for the panel.
SelectedItemStyle (inherited from C1MenuBase) | The style applied to selected items in this menu.
Site (inherited from Control) | Site of the control.
Style (inherited from WebControl) | Low-level access to control styles.
TabIndex (inherited from WebControl) | The tab order of the control.
Target (inherited from C1MenuBase) | Gets or sets the default target window or frame that displays the linked Web page content once an item is clicked.
TemplateControl (inherited from Control) | The TemplateControl that hosts this control.
TemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
ToolTip (inherited from WebControl) | The tooltip displayed when the mouse is over the control.
UniqueID (inherited from Control) | The unique ID of the control within the page.
Visible (inherited from Control) | Indicates whether the control is visible and rendered.
Width (inherited from WebControl) | The width of the control.

Protected Properties

ViewState (inherited from Control)

Current viewstate of the control.

See Also


C1SubMenu.InheritParentStyle Property

C1SubMenu.InheritParentStyle Property

Indicates whether to inherit style from the parent menu.

[Visual Basic]

Public Property InheritParentStyle As Boolean

[C#]

public bool InheritParentStyle {get;set;}

[Delphi]

public property InheritParentStyle: Boolean read get_InheritParentStyle write set_InheritParentStyle;

See Also


C1SubMenu.MenuLayout Property

C1SubMenu.MenuLayout Property

Overriden. The layout for the submenus is always vertical.

[Visual Basic]

Overrides Public Property MenuLayout As MenuLayoutEnum

[C#]

override public MenuLayoutEnum MenuLayout {get;set;}

[Delphi]

public property MenuLayout: MenuLayoutEnum read get_MenuLayout write set_MenuLayout;

Remarks

Always vertical.

See Also


C1SubMenu.ParentMenu Property

C1SubMenu.ParentMenu Property

Returns the parent menu.

[Visual Basic]

Public ReadOnly Property ParentMenu As C1MenuBase

[C#]

public C1MenuBase ParentMenu {get;}

[Delphi]

public property ParentMenu: C1MenuBase read get_ParentMenu;

See Also


C1SubMenu.ParentMenuItem Property

C1SubMenu.ParentMenuItem Property

Returns the parent menu item.

[Visual Basic]

Public ReadOnly Property ParentMenuItem As C1MenuItem

[C#]

public C1MenuItem ParentMenuItem {get;}

[Delphi]

public property ParentMenuItem: C1MenuItem read get_ParentMenuItem;

See Also


C1SubMenu Events

C1SubMenu Events

The events of the C1SubMenu class are listed here. For a complete list of C1SubMenu class members, see the C1SubMenu Members topic.

Public Events

DataBinding (inherited from Control) | Fires when the control's data binding expressions are to be evaluated.
Disposed (inherited from Control) | Fires when the control has been disposed.
Init (inherited from Control) | Fires when the page has been initialized.
ItemClick (inherited from C1MenuBase) | Fired when the child menu item is clicked.
ItemCommand (inherited from C1MenuBase) | Fired when an item belonging to the menu is clicked.
Load (inherited from Control) | Fires when the page has been loaded.
PreRender (inherited from Control) | Fires before the page is rendered.
Unload (inherited from Control) | Fires when the page is unloaded.

See Also


C1WebCommandColorConverter Class

C1WebCommandColorConverter Class

Class for using instead of WebColorConverter.

For a list of all members of this type, see C1WebCommandColorConverter Members.

System.Object

System.ComponentModel.TypeConverter

System.Drawing.ColorConverter

System.Web.UI.WebControls.WebColorConverter

C1.Web.C1Command.C1WebCommandColorConverter

[Visual Basic]

Public Class C1WebCommandColorConverter

Inherits WebColorConverter

[C#]

public class C1WebCommandColorConverter : WebColorConverter

[Delphi]

type C1WebCommandColorConverter = class (WebColorConverter);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1WebCommandColorConverter Members

C1WebCommandColorConverter Members

C1WebCommandColorConverter overview

See Also


C1WebCommandConsts Class

C1WebCommandConsts Class

Common for C1WebCommand constants.

For a list of all members of this type, see C1WebCommandConsts Members.

System.Object

C1.Web.C1Command.C1WebCommandConsts

[Visual Basic]

Public Class C1WebCommandConsts

[C#]

public class C1WebCommandConsts

[Delphi]

type C1WebCommandConsts = class;

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1WebCommandConsts Members

C1WebCommandConsts Members

C1WebCommandConsts overview

See Also


C1WebMenu Class

C1WebMenu Class

Represents a C1WebMenu control.

For a list of all members of this type, see C1WebMenu Members.

System.Object

System.Web.UI.Control

System.Web.UI.WebControls.WebControl

System.Web.UI.WebControls.Panel

C1.Web.C1Command.C1MenuBase

C1.Web.C1Command.C1WebMenu

[Visual Basic]

Public Class C1WebMenu

Inherits C1MenuBase

Implements IDisposable

[C#]

public class C1WebMenu : C1MenuBase , IDisposable

[Delphi]

type C1WebMenu = class (C1MenuBase, IDisposable);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1WebMenu Members

C1WebMenu Members

C1WebMenu overview

Public Constructors

C1WebMenu Constructor

Initializes a new instance of the C1WebMenu class.

Public Properties

AccessKey (inherited from WebControl) | Keyboard shortcut used by the control.
AppRelativeTemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Attributes (inherited from WebControl) | Tag attributes of the control.
BackColor (inherited from WebControl) | Color of the background of the control.
BackImageUrl (inherited from Panel) | The background image of the panel.
BorderColor (inherited from WebControl) | Color of the border around the control.
BorderStyle (inherited from WebControl) | Style of the border around the control.
BorderWidth (inherited from WebControl) | Width of the border around the control.
ClientDir | Determines where the client scripts are loaded from.
ClientID (inherited from Control) | The ID of the control that is rendered for the client.
ContextControlId | A client side Id that binds an element to the context menu.
ContextMenu | Provides three different modes of context menus: default, control, and custom for the user to choose from. It also contains the member, none, if the user does not want a context menu to appear in the menu.
ControlStyle (inherited from WebControl) | The style associated with the control.
ControlStyleCreated (inherited from WebControl) | Whether the style associated with the control has been created.
CssClass (inherited from WebControl) | CSS Class name applied to the control.
DefaultButton (inherited from Panel) | The default button for the panel.
Direction (inherited from Panel) | The direction of text in the panel.
DisabledItemStyle (inherited from C1MenuBase) | The style applied to disabled items in this menu.
Enabled (inherited from WebControl) | Enabled state of the control.
EnableViewState (inherited from Control) | Whether the control automatically saves its state for use in round-trips.
Font (inherited from WebControl) | The font used for text within the control.
ForeColor (inherited from WebControl) | Color of the text within the control.
GroupingText (inherited from Panel) | The text of group box around this control's contents.
Height (inherited from WebControl) | The height of the control.
HorzPopupDirection | Gets or sets the horizontal direction of the submenu's appearance.
IconBarWidth (inherited from C1MenuBase) | Sets or returns the width of the icon bar drawn on the side of the menus.
ID (inherited from Control) | Programmatic name of the control.
Items (inherited from C1MenuBase) | Gets the collection of menu items contained in this menu.
ItemSpacing (inherited from C1MenuBase) | Gets or sets spacing between the menu's border and item's border.
ItemStyle (inherited from C1MenuBase) | The style applied to items in this menu.
ItemTextSpacing (inherited from C1MenuBase) | Gets or sets spacing between the item's border and item's text.
MenuLayout | Overriden. Indicates whether to layout the web menu items vertically or horizontally.
NamingContainer (inherited from Control) | The containing control or page within which ID is unique.
Page (inherited from Control) | The page containing the control.
Parent (inherited from Control) | The control containing this control.
PreloadImages | Specifies whether to preload images used in menu control.
ScrollBars (inherited from Panel) | The appearance of scrollbars for the panel.
SelectedItemStyle (inherited from C1MenuBase) | The style applied to selected items in this menu.
Site (inherited from Control) | Site of the control.
Style (inherited from WebControl) | Low-level access to control styles.
SubMenuMark | Indicates whether space for the submenu mark is displayed.
TabIndex (inherited from WebControl) | The tab order of the control.
Target (inherited from C1MenuBase) | Gets or sets the default target window or frame that displays the linked Web page content once an item is clicked.
TemplateControl (inherited from Control) | The TemplateControl that hosts this control.
TemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
ToolTip (inherited from WebControl) | The tooltip displayed when the mouse is over the control.
UniqueID (inherited from Control) | The unique ID of the control within the page.
VertPopupDirection | Gets or sets the vertical direction of the submenu's appearance.
Visible (inherited from Control) | Indicates whether the control is visible and rendered.
Width (inherited from WebControl) | The width of the control.

Public Events

DataBinding (inherited from Control) | Fires when the control's data binding expressions are to be evaluated.
Disposed (inherited from Control) | Fires when the control has been disposed.
GetSpecialSymbol | Allow users to define their own special symbols, or images for the: left submenu marker, right submenu marker, check mark, and radio mark.
Init (inherited from Control) | Fires when the page has been initialized.
ItemClick (inherited from C1MenuBase) | Fired when the child menu item is clicked.
ItemCommand (inherited from C1MenuBase) | Fired when an item belonging to the menu is clicked.
Load (inherited from Control) | Fires when the page has been loaded.
PreRender (inherited from Control) | Fires before the page is rendered.
Unload (inherited from Control) | Fires when the page is unloaded.

Protected Properties

ViewState (inherited from Control)

Current viewstate of the control.

See Also


C1WebMenu Constructor

C1WebMenu Constructor

Initializes a new instance of the C1WebMenu class.

[Visual Basic]

Public Function New()

[C#]

public C1WebMenu()

[Delphi]

public constructor Create();

See Also


C1WebMenu Properties

C1WebMenu Properties

The properties of the C1WebMenu class are listed here. For a complete list of C1WebMenu class members, see the C1WebMenu Members topic.

Public Properties

AccessKey (inherited from WebControl) | Keyboard shortcut used by the control.
AppRelativeTemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Attributes (inherited from WebControl) | Tag attributes of the control.
BackColor (inherited from WebControl) | Color of the background of the control.
BackImageUrl (inherited from Panel) | The background image of the panel.
BorderColor (inherited from WebControl) | Color of the border around the control.
BorderStyle (inherited from WebControl) | Style of the border around the control.
BorderWidth (inherited from WebControl) | Width of the border around the control.
ClientDir | Determines where the client scripts are loaded from.
ClientID (inherited from Control) | The ID of the control that is rendered for the client.
ContextControlId | A client side Id that binds an element to the context menu.
ContextMenu | Provides three different modes of context menus: default, control, and custom for the user to choose from. It also contains the member, none, if the user does not want a context menu to appear in the menu.
ControlStyle (inherited from WebControl) | The style associated with the control.
ControlStyleCreated (inherited from WebControl) | Whether the style associated with the control has been created.
CssClass (inherited from WebControl) | CSS Class name applied to the control.
DefaultButton (inherited from Panel) | The default button for the panel.
Direction (inherited from Panel) | The direction of text in the panel.
DisabledItemStyle (inherited from C1MenuBase) | The style applied to disabled items in this menu.
Enabled (inherited from WebControl) | Enabled state of the control.
EnableViewState (inherited from Control) | Whether the control automatically saves its state for use in round-trips.
Font (inherited from WebControl) | The font used for text within the control.
ForeColor (inherited from WebControl) | Color of the text within the control.
GroupingText (inherited from Panel) | The text of group box around this control's contents.
Height (inherited from WebControl) | The height of the control.
HorzPopupDirection | Gets or sets the horizontal direction of the submenu's appearance.
IconBarWidth (inherited from C1MenuBase) | Sets or returns the width of the icon bar drawn on the side of the menus.
ID (inherited from Control) | Programmatic name of the control.
Items (inherited from C1MenuBase) | Gets the collection of menu items contained in this menu.
ItemSpacing (inherited from C1MenuBase) | Gets or sets spacing between the menu's border and item's border.
ItemStyle (inherited from C1MenuBase) | The style applied to items in this menu.
ItemTextSpacing (inherited from C1MenuBase) | Gets or sets spacing between the item's border and item's text.
MenuLayout | Overriden. Indicates whether to layout the web menu items vertically or horizontally.
NamingContainer (inherited from Control) | The containing control or page within which ID is unique.
Page (inherited from Control) | The page containing the control.
Parent (inherited from Control) | The control containing this control.
PreloadImages | Specifies whether to preload images used in menu control.
ScrollBars (inherited from Panel) | The appearance of scrollbars for the panel.
SelectedItemStyle (inherited from C1MenuBase) | The style applied to selected items in this menu.
Site (inherited from Control) | Site of the control.
Style (inherited from WebControl) | Low-level access to control styles.
SubMenuMark | Indicates whether space for the submenu mark is displayed.
TabIndex (inherited from WebControl) | The tab order of the control.
Target (inherited from C1MenuBase) | Gets or sets the default target window or frame that displays the linked Web page content once an item is clicked.
TemplateControl (inherited from Control) | The TemplateControl that hosts this control.
TemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
ToolTip (inherited from WebControl) | The tooltip displayed when the mouse is over the control.
UniqueID (inherited from Control) | The unique ID of the control within the page.
VertPopupDirection | Gets or sets the vertical direction of the submenu's appearance.
Visible (inherited from Control) | Indicates whether the control is visible and rendered.
Width (inherited from WebControl) | The width of the control.

Protected Properties

ViewState (inherited from Control)

Current viewstate of the control.

See Also


C1WebMenu.ClientDir Property

C1WebMenu.ClientDir Property

Determines where the client scripts are loaded from.

[Visual Basic]

Public Property ClientDir As String

[C#]

public string ClientDir {get;set;}

[Delphi]

public property ClientDir: String read get_ClientDir write set_ClientDir;

Remarks

The default value is /c1webcommand_client/v1_1". If there are more than one menu or toolbar on the page, all should have this property set to the same value, otherwise the result is undefined.

See Also


C1WebMenu.ContextControlId Property

C1WebMenu.ContextControlId Property

A client side Id that binds an element to the context menu.

[Visual Basic]

Public Property ContextControlId As String

[C#]

public string ContextControlId {get;set;}

[Delphi]

public property ContextControlId: String read get_ContextControlId write set_ContextControlId;

See Also


C1WebMenu.ContextMenu Property

C1WebMenu.ContextMenu Property

Provides three different modes of context menus: default, control, and custom for the user to choose from. It also contains the member, none, if the user does not want a context menu to appear in the menu.

[Visual Basic]

Public Property ContextMenu As ContextMenuTypeEnum

[C#]

public ContextMenuTypeEnum ContextMenu {get;set;}

[Delphi]

public property ContextMenu: ContextMenuTypeEnum read get_ContextMenu write set_ContextMenu;

Remarks

The contextmenu property contains three different modes of context menus: default, control, and custom. The default context menu appears on any point of the page when the user right-clicks the mouse. The control context menu appears on the control that the user specified in the ContextControlId property. The custom context menu appears when the user calls the client script function. If the you don't want a context menu to appear set the context menu to None.

See Also


C1WebMenu.HorzPopupDirection Property

C1WebMenu.HorzPopupDirection Property

Gets or sets the horizontal direction of the submenu's appearance.

[Visual Basic]

Public Property HorzPopupDirection As HorzPopupDirectionEnum

[C#]

public HorzPopupDirectionEnum HorzPopupDirection {get;set;}

[Delphi]

public property HorzPopupDirection: HorzPopupDirectionEnum read get_HorzPopupDirection write set_HorzPopupDirection;

See Also


C1WebMenu.MenuLayout Property

C1WebMenu.MenuLayout Property

Indicates whether to layout the web menu items vertically or horizontally.

[Visual Basic]

Overrides Public Property MenuLayout As MenuLayoutEnum

[C#]

override public MenuLayoutEnum MenuLayout {get;set;}

[Delphi]

public property MenuLayout: MenuLayoutEnum read get_MenuLayout write set_MenuLayout;

See Also


C1WebMenu.PreloadImages Property

C1WebMenu.PreloadImages Property

Specifies whether to preload images used in menu control.

[Visual Basic]

Public Property PreloadImages As Boolean

[C#]

public bool PreloadImages {get;set;}

[Delphi]

public property PreloadImages: Boolean read get_PreloadImages write set_PreloadImages;

Remarks

Set value to false if you don't want to preload images.

See Also


C1WebMenu.SubMenuMark Property

C1WebMenu.SubMenuMark Property

Indicates whether space for the submenu mark is displayed.

[Visual Basic]

Public Property SubMenuMark As SubMenuMarkEnum

[C#]

public SubMenuMarkEnum SubMenuMark {get;set;}

[Delphi]

public property SubMenuMark: SubMenuMarkEnum read get_SubMenuMark write set_SubMenuMark;

See Also


C1WebMenu.VertPopupDirection Property

C1WebMenu.VertPopupDirection Property

Gets or sets the vertical direction of the submenu's appearance.

[Visual Basic]

Public Property VertPopupDirection As VertPopupDirectionEnum

[C#]

public VertPopupDirectionEnum VertPopupDirection {get;set;}

[Delphi]

public property VertPopupDirection: VertPopupDirectionEnum read get_VertPopupDirection write set_VertPopupDirection;

See Also


C1WebMenu Events

C1WebMenu Events

The events of the C1WebMenu class are listed here. For a complete list of C1WebMenu class members, see the C1WebMenu Members topic.

Public Events

DataBinding (inherited from Control) | Fires when the control's data binding expressions are to be evaluated.
Disposed (inherited from Control) | Fires when the control has been disposed.
GetSpecialSymbol | Allow users to define their own special symbols, or images for the: left submenu marker, right submenu marker, check mark, and radio mark.
Init (inherited from Control) | Fires when the page has been initialized.
ItemClick (inherited from C1MenuBase) | Fired when the child menu item is clicked.
ItemCommand (inherited from C1MenuBase) | Fired when an item belonging to the menu is clicked.
Load (inherited from Control) | Fires when the page has been loaded.
PreRender (inherited from Control) | Fires before the page is rendered.
Unload (inherited from Control) | Fires when the page is unloaded.

See Also


C1WebMenu.GetSpecialSymbol Event

C1WebMenu.GetSpecialSymbol Event

Allow users to define their own special symbols, or images for the: left submenu marker, right submenu marker, check mark, and radio mark.

[Visual Basic]

Public Event GetSpecialSymbol As GetSpecialSymbolEventHandler

[C#]

public event GetSpecialSymbolEventHandler GetSpecialSymbol

[Delphi]

public property GetSpecialSymbol: GetSpecialSymbolEventHandler read remove_GetSpecialSymbol write add_GetSpecialSymbol;

See Also


C1WebToolBar Class

C1WebToolBar Class

Represents a C1WebToolBar control.

For a list of all members of this type, see C1WebToolBar Members.

System.Object

System.Web.UI.Control

System.Web.UI.WebControls.WebControl

System.Web.UI.WebControls.Panel

C1.Web.C1Command.C1WebToolBarContainerBase

C1.Web.C1Command.C1WebToolBar

[Visual Basic]

Public Class C1WebToolBar

Inherits C1WebToolBarContainerBase

Implements IDisposable

[C#]

public class C1WebToolBar : C1WebToolBarContainerBase , IDisposable

[Delphi]

type C1WebToolBar = class (C1WebToolBarContainerBase, IDisposable);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1WebToolBar Members

C1WebToolBar Members

C1WebToolBar overview

Public Constructors

C1WebToolBar Constructor

Initializes a new instance of the C1WebToolBar class.

Public Properties

AccessKey (inherited from WebControl) | Keyboard shortcut used by the control.
AppRelativeTemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Attributes (inherited from WebControl) | Tag attributes of the control.
BackColor (inherited from WebControl) | Color of the background of the control.
BackImageUrl (inherited from Panel) | The background image of the panel.
BorderColor (inherited from WebControl) | Color of the border around the control.
BorderStyle (inherited from WebControl) | Style of the border around the control.
BorderWidth (inherited from WebControl) | Width of the border around the control.
ClientDir | Determines where the client scripts are loaded from.
ClientID (inherited from Control) | The ID of the control that is rendered for the client.
ControlStyle (inherited from WebControl) | The style associated with the control.
ControlStyleCreated (inherited from WebControl) | Whether the style associated with the control has been created.
CssClass (inherited from WebControl) | CSS Class name applied to the control.
DefaultButton (inherited from Panel) | The default button for the panel.
Direction (inherited from Panel) | The direction of text in the panel.
DisabledItemStyle (inherited from C1WebToolBarContainerBase) | The style applied to disabled items.
Enabled (inherited from WebControl) | Enabled state of the control.
EnableViewState (inherited from Control) | Whether the control automatically saves its state for use in round-trips.
Font (inherited from WebControl) | The font used for text within the control.
ForeColor (inherited from WebControl) | Color of the text within the control.
GroupingText (inherited from Panel) | The text of group box around this control's contents.
Height (inherited from WebControl) | The height of the control.
HorizontalAlign (inherited from Panel) | The horizontal alignment of the content.
HoverItemStyle (inherited from C1WebToolBarContainerBase) | The style applied to items when the mouse hovers over them.
ID (inherited from Control) | Programmatic name of the control.
ItemImageHeight (inherited from C1WebToolBarContainerBase) | Gets or sets the height of the item image.
ItemImageWidth (inherited from C1WebToolBarContainerBase) | Gets or sets the width of the item image.
ItemSize | Gets or sets the size (height for horizontal and width for vertical) of buttons and separators on the C1WebToolBar control.
ItemSpacing (inherited from C1WebToolBarContainerBase) | Gets or sets spacing between toolbar's border and button's border.
ItemStyle (inherited from C1WebToolBarContainerBase) | The style applied to items in this toolbar.
ItemTextSpacing (inherited from C1WebToolBarContainerBase) | Gets or sets spacing between buttons's border and buttons's text.
Layout (inherited from C1WebToolBarContainerBase) | Indicates whether to layout menu items vertically or horizontally.
LayoutActual (inherited from C1WebToolBarContainerBase) | Gets the actual menu layout.
NamingContainer (inherited from Control) | The containing control or page within which ID is unique.
Page (inherited from Control) | The page containing the control.
Parent (inherited from Control) | The control containing this control.
PreloadImages | Specifies whether to preload images used in toolbar control.
ScrollBars (inherited from Panel) | The appearance of scrollbars for the panel.
SelectedItemStyle (inherited from C1WebToolBarContainerBase) | The style applied to selected items.
Site (inherited from Control) | Site of the control.
Style (inherited from WebControl) | Low-level access to control styles.
TabIndex (inherited from WebControl) | The tab order of the control.
Target | Gets or sets the default target window or frame to display the Web page content linked to when the button is clicked.
TemplateControl (inherited from Control) | The TemplateControl that hosts this control.
TemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
ToolTip (inherited from WebControl) | The tooltip displayed when the mouse is over the control.
UniqueID (inherited from Control) | The unique ID of the control within the page.
Visible (inherited from Control) | Indicates whether the control is visible and rendered.
Width (inherited from WebControl) | The width of the control.
Wrap (inherited from Panel) | Whether the content should wrap or not.

Public Methods

LoadLayout | Overloaded. Load control layout properties from the stream.
SaveLayout | Overloaded. Saves control layout properties to the stream.

Public Events

DataBinding (inherited from Control) | Fires when the control's data binding expressions are to be evaluated.
Disposed (inherited from Control) | Fires when the control has been disposed.
Init (inherited from Control) | Fires when the page has been initialized.
Load (inherited from Control) | Fires when the page has been loaded.
PreRender (inherited from Control) | Fires before the page is rendered.
Unload (inherited from Control) | Fires when the page is unloaded.

Protected Properties

ViewState (inherited from Control)

Current viewstate of the control.

See Also


C1WebToolBar Constructor

C1WebToolBar Constructor

Initializes a new instance of the C1WebToolBar class.

[Visual Basic]

Public Function New()

[C#]

public C1WebToolBar()

[Delphi]

public constructor Create();

See Also


C1WebToolBar Properties

C1WebToolBar Properties

The properties of the C1WebToolBar class are listed here. For a complete list of C1WebToolBar class members, see the C1WebToolBar Members topic.

Public Properties

AccessKey (inherited from WebControl) | Keyboard shortcut used by the control.
AppRelativeTemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Attributes (inherited from WebControl) | Tag attributes of the control.
BackColor (inherited from WebControl) | Color of the background of the control.
BackImageUrl (inherited from Panel) | The background image of the panel.
BorderColor (inherited from WebControl) | Color of the border around the control.
BorderStyle (inherited from WebControl) | Style of the border around the control.
BorderWidth (inherited from WebControl) | Width of the border around the control.
ClientDir | Determines where the client scripts are loaded from.
ClientID (inherited from Control) | The ID of the control that is rendered for the client.
ControlStyle (inherited from WebControl) | The style associated with the control.
ControlStyleCreated (inherited from WebControl) | Whether the style associated with the control has been created.
CssClass (inherited from WebControl) | CSS Class name applied to the control.
DefaultButton (inherited from Panel) | The default button for the panel.
Direction (inherited from Panel) | The direction of text in the panel.
DisabledItemStyle (inherited from C1WebToolBarContainerBase) | The style applied to disabled items.
Enabled (inherited from WebControl) | Enabled state of the control.
EnableViewState (inherited from Control) | Whether the control automatically saves its state for use in round-trips.
Font (inherited from WebControl) | The font used for text within the control.
ForeColor (inherited from WebControl) | Color of the text within the control.
GroupingText (inherited from Panel) | The text of group box around this control's contents.
Height (inherited from WebControl) | The height of the control.
HorizontalAlign (inherited from Panel) | The horizontal alignment of the content.
HoverItemStyle (inherited from C1WebToolBarContainerBase) | The style applied to items when the mouse hovers over them.
ID (inherited from Control) | Programmatic name of the control.
ItemImageHeight (inherited from C1WebToolBarContainerBase) | Gets or sets the height of the item image.
ItemImageWidth (inherited from C1WebToolBarContainerBase) | Gets or sets the width of the item image.
ItemSize | Gets or sets the size (height for horizontal and width for vertical) of buttons and separators on the C1WebToolBar control.
ItemSpacing (inherited from C1WebToolBarContainerBase) | Gets or sets spacing between toolbar's border and button's border.
ItemStyle (inherited from C1WebToolBarContainerBase) | The style applied to items in this toolbar.
ItemTextSpacing (inherited from C1WebToolBarContainerBase) | Gets or sets spacing between buttons's border and buttons's text.
Layout (inherited from C1WebToolBarContainerBase) | Indicates whether to layout menu items vertically or horizontally.
LayoutActual (inherited from C1WebToolBarContainerBase) | Gets the actual menu layout.
NamingContainer (inherited from Control) | The containing control or page within which ID is unique.
Page (inherited from Control) | The page containing the control.
Parent (inherited from Control) | The control containing this control.
PreloadImages | Specifies whether to preload images used in toolbar control.
ScrollBars (inherited from Panel) | The appearance of scrollbars for the panel.
SelectedItemStyle (inherited from C1WebToolBarContainerBase) | The style applied to selected items.
Site (inherited from Control) | Site of the control.
Style (inherited from WebControl) | Low-level access to control styles.
TabIndex (inherited from WebControl) | The tab order of the control.
Target | Gets or sets the default target window or frame to display the Web page content linked to when the button is clicked.
TemplateControl (inherited from Control) | The TemplateControl that hosts this control.
TemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
ToolTip (inherited from WebControl) | The tooltip displayed when the mouse is over the control.
UniqueID (inherited from Control) | The unique ID of the control within the page.
Visible (inherited from Control) | Indicates whether the control is visible and rendered.
Width (inherited from WebControl) | The width of the control.
Wrap (inherited from Panel) | Whether the content should wrap or not.

Protected Properties

ViewState (inherited from Control)

Current viewstate of the control.

See Also


C1WebToolBar.ClientDir Property

C1WebToolBar.ClientDir Property

Determines where the client scripts are loaded from.

[Visual Basic]

Public Property ClientDir As String

[C#]

public string ClientDir {get;set;}

[Delphi]

public property ClientDir: String read get_ClientDir write set_ClientDir;

See Also


C1WebToolBar.ItemSize Property

C1WebToolBar.ItemSize Property

Gets or sets the size (height for horizontal and width for vertical) of buttons and separators on the C1WebToolBar control.

[Visual Basic]

Overridable Public Property ItemSize As Unit

[C#]

virtual public Unit ItemSize {get;set;}

[Delphi]

public property ItemSize: Unit read get_ItemSize write set_ItemSize;

See Also


C1WebToolBar.PreloadImages Property

C1WebToolBar.PreloadImages Property

Specifies whether to preload images used in toolbar control.

[Visual Basic]

Public Property PreloadImages As Boolean

[C#]

public bool PreloadImages {get;set;}

[Delphi]

public property PreloadImages: Boolean read get_PreloadImages write set_PreloadImages;

Remarks

Set value to false if you don't want to preload images.

See Also


C1WebToolBar.Target Property

C1WebToolBar.Target Property

Gets or sets the default target window or frame to display the Web page content linked to when the button is clicked.

[Visual Basic]

Public Property Target As String

[C#]

public string Target {get;set;}

[Delphi]

public property Target: String read get_Target write set_Target;

See Also


C1WebToolBar Methods

C1WebToolBar Methods

The methods of the C1WebToolBar class are listed here. For a complete list of C1WebToolBar class members, see the C1WebToolBar Members topic.

Public Methods

LoadLayout | Overloaded. Load control layout properties from the stream.
SaveLayout | Overloaded. Saves control layout properties to the stream.

See Also


C1WebToolBar.LoadLayout Method

C1WebToolBar.LoadLayout Method

Overload List

Load control layout properties from the stream.

[Visual Basic] Overloads Public Sub LoadLayout(Stream)

[C#] public void LoadLayout(Stream);

[Delphi] public procedure LoadLayout(Stream); overload;

Loads control layout properties from the file.

[Visual Basic] Overloads Public Sub LoadLayout(String)

[C#] public void LoadLayout(string);

[Delphi] public procedure LoadLayout(String); overload;

Loads control layout properties with specified types from the stream.

[Visual Basic] Overloads Public Sub LoadLayout(Stream, LayoutTypeFlags)

[C#] public void LoadLayout(Stream, LayoutTypeFlags);

[Delphi] public procedure LoadLayout(Stream; LayoutTypeFlags); overload;

Loads control layout properties with specified types from the file.

[Visual Basic] Overloads Public Sub LoadLayout(String, LayoutTypeFlags)

[C#] public void LoadLayout(string, LayoutTypeFlags);

[Delphi] public procedure LoadLayout(String; LayoutTypeFlags); overload;

See Also


C1WebToolBar.LoadLayout Method (Stream)

C1WebToolBar.LoadLayout Method (Stream)

Previous Next

Load control layout properties from the stream.

[Visual Basic]

Overloads Public Sub LoadLayout( _

ByVal stream As Stream _

)

[C#]

public void LoadLayout(

Stream stream

);

[Delphi]

public procedure LoadLayout(

stream: Stream

); overload;

Parameters

stream

stream from which the values of layout properties will be loaded

See Also


C1WebToolBar.LoadLayout Method (String)

C1WebToolBar.LoadLayout Method (String)

Previous Next

Loads control layout properties from the file.

[Visual Basic]

Overloads Public Sub LoadLayout( _

ByVal filename As String _

)

[C#]

public void LoadLayout(

string filename

);

[Delphi]

public procedure LoadLayout(

filename: String

); overload;

Parameters

filename

file from which the values of layout properties will be loaded

See Also


C1WebToolBar.LoadLayout Method (Stream, LayoutTypeFlags)

C1WebToolBar.LoadLayout Method (Stream, LayoutTypeFlags)

Previous Next

Loads control layout properties with specified types from the stream.

[Visual Basic]

Overloads Public Sub LoadLayout( _

ByVal stream As Stream, _

ByVal layoutTypes As LayoutTypeFlags _

)

[C#]

public void LoadLayout(

Stream stream,

LayoutTypeFlags layoutTypes

);

[Delphi]

public procedure LoadLayout(

stream: Stream;

layoutTypes: LayoutTypeFlags

); overload;

Parameters

stream

stream from which the values of layout properties will be loaded

layoutTypes

layout types to load

See Also


C1WebToolBar.LoadLayout Method (String, LayoutTypeFlags)

C1WebToolBar.LoadLayout Method (String, LayoutTypeFlags)

Previous Next

Loads control layout properties with specified types from the file.

[Visual Basic]

Overloads Public Sub LoadLayout( _

ByVal filename As String, _

ByVal layoutTypes As LayoutTypeFlags _

)

[C#]

public void LoadLayout(

string filename,

LayoutTypeFlags layoutTypes

);

[Delphi]

public procedure LoadLayout(

filename: String;

layoutTypes: LayoutTypeFlags

); overload;

Parameters

filename

file from which the values of layout properties will be loaded

layoutTypes

layout types to load

See Also


C1WebToolBar.SaveLayout Method

C1WebToolBar.SaveLayout Method

Overload List

Saves control layout properties to the stream.

[Visual Basic] Overloads Public Sub SaveLayout(Stream)

[C#] public void SaveLayout(Stream);

[Delphi] public procedure SaveLayout(Stream); overload;

Saves control layout properties to the file.

[Visual Basic] Overloads Public Sub SaveLayout(String)

[C#] public void SaveLayout(string);

[Delphi] public procedure SaveLayout(String); overload;

See Also


C1WebToolBar.SaveLayout Method (Stream)

C1WebToolBar.SaveLayout Method (Stream)

Previous Next

Saves control layout properties to the stream.

[Visual Basic]

Overloads Public Sub SaveLayout( _

ByVal stream As Stream _

)

[C#]

public void SaveLayout(

Stream stream

);

[Delphi]

public procedure SaveLayout(

stream: Stream

); overload;

Parameters

stream

stream to which the values of layout properties will be saved

See Also


C1WebToolBar.SaveLayout Method (String)

C1WebToolBar.SaveLayout Method (String)

Previous Next

Saves control layout properties to the file.

[Visual Basic]

Overloads Public Sub SaveLayout( _

ByVal filename As String _

)

[C#]

public void SaveLayout(

string filename

);

[Delphi]

public procedure SaveLayout(

filename: String

); overload;

Parameters

filename

file to which the values of layout properties will be saved

See Also


C1WebToolBar Events

C1WebToolBar Events

The events of the C1WebToolBar class are listed here. For a complete list of C1WebToolBar class members, see the C1WebToolBar Members topic.

Public Events

DataBinding (inherited from Control) | Fires when the control's data binding expressions are to be evaluated.
Disposed (inherited from Control) | Fires when the control has been disposed.
Init (inherited from Control) | Fires when the page has been initialized.
Load (inherited from Control) | Fires when the page has been loaded.
PreRender (inherited from Control) | Fires before the page is rendered.
Unload (inherited from Control) | Fires when the page is unloaded.

See Also


C1WebToolBarButton Class

C1WebToolBarButton Class

Represents a toolbar button.

For a list of all members of this type, see C1WebToolBarButton Members.

System.Object

System.Web.UI.Control

System.Web.UI.WebControls.WebControl

C1.Web.C1Command.C1WebToolBarControl

C1.Web.C1Command.C1WebToolBarButtonBase

C1.Web.C1Command.C1WebToolBarButton

[Visual Basic]

Public Class C1WebToolBarButton

Inherits C1WebToolBarButtonBase

[C#]

public class C1WebToolBarButton : C1WebToolBarButtonBase

[Delphi]

type C1WebToolBarButton = class (C1WebToolBarButtonBase);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1WebToolBarButton Members

C1WebToolBarButton Members

C1WebToolBarButton overview

Public Properties

AccessKey (inherited from WebControl) | Keyboard shortcut used by the control.
AppRelativeTemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Attributes (inherited from WebControl) | Tag attributes of the control.
BackColor (inherited from WebControl) | Color of the background of the control.
BackImageUrl (inherited from C1WebToolBarControl) | Gets or sets the URL of an image to display in the background of the C1WebToolBarControl control.
BorderColor (inherited from WebControl) | Color of the border around the control.
BorderStyle (inherited from WebControl) | Style of the border around the control.
BorderWidth (inherited from WebControl) | Width of the border around the control.
ClientID (inherited from Control) | The ID of the control that is rendered for the client.
ClientScripts (inherited from C1WebToolBarControl) | Client-side scripts associated with the item.
Controls (inherited from Control) | The collection of child controls owned by the control.
ControlStyle (inherited from WebControl) | The style associated with the control.
ControlStyleCreated (inherited from WebControl) | Whether the style associated with the control has been created.
CssClass (inherited from WebControl) | CSS Class name applied to the control.
DisabledStyle (inherited from C1WebToolBarButtonBase) | Gets the disabled style of the C1WebToolBarButton.
Enabled (inherited from WebControl) | Enabled state of the control.
EnableViewState (inherited from Control) | Whether the control automatically saves its state for use in round-trips.
Font (inherited from WebControl) | The font used for text within the control.
ForeColor (inherited from WebControl) | Color of the text within the control.
HoverStyle (inherited from C1WebToolBarButtonBase) | Gets the style of the C1WebToolBarButton when the user hovers the mouse pointer over it.
ID (inherited from Control) | Programmatic name of the control.
ImageHeight | Gets the height of the C1WebToolBarButton.
ImageUrl | Gets or sets the location of an image to display in the C1WebToolBarButton.
ImageWidth | Gets or sets the width of the C1WebToolBarButton.
IsPushed | Determines whether the C1WebToolBarButton is pressed.
IsToggle | Determines whether the C1WebToolBarButton is toggled.
LinkUrl (inherited from C1WebToolBarControl) | Gets or sets the URL linked to the C1WebToolBarControl control.
NamingContainer (inherited from Control) | The containing control or page within which ID is unique.
Page (inherited from Control) | The page containing the control.
Parent (inherited from Control) | The control containing this control.
SelectedStyle (inherited from C1WebToolBarButtonBase) | Style for the "selected" state (e.g. button is pushed etc.)
Site (inherited from Control) | Site of the control.
Style (inherited from WebControl) | Low-level access to control styles.
TabIndex (inherited from WebControl) | The tab order of the control.
Target | Gets or sets the default target window or frame that displays the linked Web page content once an item is clicked.
TemplateControl (inherited from Control) | The TemplateControl that hosts this control.
TemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Text | Gets or sets the text of the C1WebToolBarButton.
ToolTip (inherited from WebControl) | The tooltip displayed when the mouse is over the control.
UniqueID (inherited from Control) | The unique ID of the control within the page.
Visible (inherited from Control) | Indicates whether the control is visible and rendered.
Width (inherited from C1WebToolBarControl) | Gets or sets the width of the C1WebToolBarControl.

Public Events

Click (inherited from C1WebToolBarButtonBase) | Fires when the C1WebToolBarControl is clicked.
DataBinding (inherited from Control) | Fires when the control's data binding expressions are to be evaluated.
Disposed (inherited from Control) | Fires when the control has been disposed.
Init (inherited from Control) | Fires when the page has been initialized.
Load (inherited from Control) | Fires when the page has been loaded.
PreRender (inherited from Control) | Fires before the page is rendered.
Unload (inherited from Control) | Fires when the page is unloaded.

Protected Properties

ViewState (inherited from Control)

Current viewstate of the control.

See Also


C1WebToolBarButton Properties

C1WebToolBarButton Properties

The properties of the C1WebToolBarButton class are listed here. For a complete list of C1WebToolBarButton class members, see the C1WebToolBarButton Members topic.

Public Properties

AccessKey (inherited from WebControl) | Keyboard shortcut used by the control.
AppRelativeTemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Attributes (inherited from WebControl) | Tag attributes of the control.
BackColor (inherited from WebControl) | Color of the background of the control.
BackImageUrl (inherited from C1WebToolBarControl) | Gets or sets the URL of an image to display in the background of the C1WebToolBarControl control.
BorderColor (inherited from WebControl) | Color of the border around the control.
BorderStyle (inherited from WebControl) | Style of the border around the control.
BorderWidth (inherited from WebControl) | Width of the border around the control.
ClientID (inherited from Control) | The ID of the control that is rendered for the client.
ClientScripts (inherited from C1WebToolBarControl) | Client-side scripts associated with the item.
Controls (inherited from Control) | The collection of child controls owned by the control.
ControlStyle (inherited from WebControl) | The style associated with the control.
ControlStyleCreated (inherited from WebControl) | Whether the style associated with the control has been created.
CssClass (inherited from WebControl) | CSS Class name applied to the control.
DisabledStyle (inherited from C1WebToolBarButtonBase) | Gets the disabled style of the C1WebToolBarButton.
Enabled (inherited from WebControl) | Enabled state of the control.
EnableViewState (inherited from Control) | Whether the control automatically saves its state for use in round-trips.
Font (inherited from WebControl) | The font used for text within the control.
ForeColor (inherited from WebControl) | Color of the text within the control.
HoverStyle (inherited from C1WebToolBarButtonBase) | Gets the style of the C1WebToolBarButton when the user hovers the mouse pointer over it.
ID (inherited from Control) | Programmatic name of the control.
ImageHeight | Gets the height of the C1WebToolBarButton.
ImageUrl | Gets or sets the location of an image to display in the C1WebToolBarButton.
ImageWidth | Gets or sets the width of the C1WebToolBarButton.
IsPushed | Determines whether the C1WebToolBarButton is pressed.
IsToggle | Determines whether the C1WebToolBarButton is toggled.
LinkUrl (inherited from C1WebToolBarControl) | Gets or sets the URL linked to the C1WebToolBarControl control.
NamingContainer (inherited from Control) | The containing control or page within which ID is unique.
Page (inherited from Control) | The page containing the control.
Parent (inherited from Control) | The control containing this control.
SelectedStyle (inherited from C1WebToolBarButtonBase) | Style for the "selected" state (e.g. button is pushed etc.)
Site (inherited from Control) | Site of the control.
Style (inherited from WebControl) | Low-level access to control styles.
TabIndex (inherited from WebControl) | The tab order of the control.
Target | Gets or sets the default target window or frame that displays the linked Web page content once an item is clicked.
TemplateControl (inherited from Control) | The TemplateControl that hosts this control.
TemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Text | Gets or sets the text of the C1WebToolBarButton.
ToolTip (inherited from WebControl) | The tooltip displayed when the mouse is over the control.
UniqueID (inherited from Control) | The unique ID of the control within the page.
Visible (inherited from Control) | Indicates whether the control is visible and rendered.
Width (inherited from C1WebToolBarControl) | Gets or sets the width of the C1WebToolBarControl.

Protected Properties

ViewState (inherited from Control)

Current viewstate of the control.

See Also


C1WebToolBarButton.ImageHeight Property

C1WebToolBarButton.ImageHeight Property

Gets the height of the C1WebToolBarButton.

[Visual Basic]

Public Property ImageHeight As Unit

[C#]

public Unit ImageHeight {get;set;}

[Delphi]

public property ImageHeight: Unit read get_ImageHeight write set_ImageHeight;

See Also


C1WebToolBarButton.ImageUrl Property

C1WebToolBarButton.ImageUrl Property

Gets or sets the location of an image to display in the C1WebToolBarButton.

[Visual Basic]

Public Property ImageUrl As String

[C#]

public string ImageUrl {get;set;}

[Delphi]

public property ImageUrl: String read get_ImageUrl write set_ImageUrl;

See Also


C1WebToolBarButton.ImageWidth Property

C1WebToolBarButton.ImageWidth Property

Gets or sets the width of the C1WebToolBarButton.

[Visual Basic]

Public Property ImageWidth As Unit

[C#]

public Unit ImageWidth {get;set;}

[Delphi]

public property ImageWidth: Unit read get_ImageWidth write set_ImageWidth;

See Also


C1WebToolBarButton.IsPushed Property

C1WebToolBarButton.IsPushed Property

Determines whether the C1WebToolBarButton is pressed.

[Visual Basic]

Public Property IsPushed As Boolean

[C#]

public bool IsPushed {get;set;}

[Delphi]

public property IsPushed: Boolean read get_IsPushed write set_IsPushed;

See Also


C1WebToolBarButton.IsToggle Property

C1WebToolBarButton.IsToggle Property

Determines whether the C1WebToolBarButton is toggled.

[Visual Basic]

Public Property IsToggle As Boolean

[C#]

public bool IsToggle {get;set;}

[Delphi]

public property IsToggle: Boolean read get_IsToggle write set_IsToggle;

See Also


C1WebToolBarButton.Target Property

C1WebToolBarButton.Target Property

Gets or sets the default target window or frame that displays the linked Web page content once an item is clicked.

[Visual Basic]

Public Property Target As String

[C#]

public string Target {get;set;}

[Delphi]

public property Target: String read get_Target write set_Target;

See Also


C1WebToolBarButton.Text Property

C1WebToolBarButton.Text Property

Gets or sets the text of the C1WebToolBarButton.

[Visual Basic]

Public Property Text As String

[C#]

public string Text {get;set;}

[Delphi]

public property Text: String read get_Text write set_Text;

See Also


C1WebToolBarButton Events

C1WebToolBarButton Events

The events of the C1WebToolBarButton class are listed here. For a complete list of C1WebToolBarButton class members, see the C1WebToolBarButton Members topic.

Public Events

Click (inherited from C1WebToolBarButtonBase) | Fires when the C1WebToolBarControl is clicked.
DataBinding (inherited from Control) | Fires when the control's data binding expressions are to be evaluated.
Disposed (inherited from Control) | Fires when the control has been disposed.
Init (inherited from Control) | Fires when the page has been initialized.
Load (inherited from Control) | Fires when the page has been loaded.
PreRender (inherited from Control) | Fires before the page is rendered.
Unload (inherited from Control) | Fires when the page is unloaded.

See Also


C1WebToolBarButtonBase Class

C1WebToolBarButtonBase Class

The base class for the web toolbar buttons.

For a list of all members of this type, see C1WebToolBarButtonBase Members.

System.Object

System.Web.UI.Control

System.Web.UI.WebControls.WebControl

C1.Web.C1Command.C1WebToolBarControl

C1.Web.C1Command.C1WebToolBarButtonBase

C1.Web.C1Command.C1WebToolBarButton

[Visual Basic]

MustInherit Public Class C1WebToolBarButtonBase

Inherits C1WebToolBarControl

[C#]

public abstract class C1WebToolBarButtonBase : C1WebToolBarControl

[Delphi]

type C1WebToolBarButtonBase = class abstract (C1WebToolBarControl);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1WebToolBarButtonBase Members

C1WebToolBarButtonBase Members

C1WebToolBarButtonBase overview

Public Properties

AccessKey (inherited from WebControl) | Keyboard shortcut used by the control.
AppRelativeTemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Attributes (inherited from WebControl) | Tag attributes of the control.
BackColor (inherited from WebControl) | Color of the background of the control.
BackImageUrl (inherited from C1WebToolBarControl) | Gets or sets the URL of an image to display in the background of the C1WebToolBarControl control.
BorderColor (inherited from WebControl) | Color of the border around the control.
BorderStyle (inherited from WebControl) | Style of the border around the control.
BorderWidth (inherited from WebControl) | Width of the border around the control.
ClientID (inherited from Control) | The ID of the control that is rendered for the client.
ClientScripts (inherited from C1WebToolBarControl) | Client-side scripts associated with the item.
Controls (inherited from Control) | The collection of child controls owned by the control.
ControlStyle (inherited from WebControl) | The style associated with the control.
ControlStyleCreated (inherited from WebControl) | Whether the style associated with the control has been created.
CssClass (inherited from WebControl) | CSS Class name applied to the control.
DisabledStyle | Gets the disabled style of the C1WebToolBarButton.
Enabled (inherited from WebControl) | Enabled state of the control.
EnableViewState (inherited from Control) | Whether the control automatically saves its state for use in round-trips.
Font (inherited from WebControl) | The font used for text within the control.
ForeColor (inherited from WebControl) | Color of the text within the control.
HoverStyle | Gets the style of the C1WebToolBarButton when the user hovers the mouse pointer over it.
ID (inherited from Control) | Programmatic name of the control.
LinkUrl (inherited from C1WebToolBarControl) | Gets or sets the URL linked to the C1WebToolBarControl control.
NamingContainer (inherited from Control) | The containing control or page within which ID is unique.
Page (inherited from Control) | The page containing the control.
Parent (inherited from Control) | The control containing this control.
SelectedStyle | Style for the "selected" state (e.g. button is pushed etc.)
Site (inherited from Control) | Site of the control.
Style (inherited from WebControl) | Low-level access to control styles.
TabIndex (inherited from WebControl) | The tab order of the control.
TemplateControl (inherited from Control) | The TemplateControl that hosts this control.
TemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
ToolTip (inherited from WebControl) | The tooltip displayed when the mouse is over the control.
UniqueID (inherited from Control) | The unique ID of the control within the page.
Visible (inherited from Control) | Indicates whether the control is visible and rendered.
Width (inherited from C1WebToolBarControl) | Gets or sets the width of the C1WebToolBarControl.

Public Events

Click | Fires when the C1WebToolBarControl is clicked.
DataBinding (inherited from Control) | Fires when the control's data binding expressions are to be evaluated.
Disposed (inherited from Control) | Fires when the control has been disposed.
Init (inherited from Control) | Fires when the page has been initialized.
Load (inherited from Control) | Fires when the page has been loaded.
PreRender (inherited from Control) | Fires before the page is rendered.
Unload (inherited from Control) | Fires when the page is unloaded.

Protected Properties

ViewState (inherited from Control)

Current viewstate of the control.

See Also


C1WebToolBarButtonBase Properties

C1WebToolBarButtonBase Properties

The properties of the C1WebToolBarButtonBase class are listed here. For a complete list of C1WebToolBarButtonBase class members, see the C1WebToolBarButtonBase Members topic.

Public Properties

AccessKey (inherited from WebControl) | Keyboard shortcut used by the control.
AppRelativeTemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Attributes (inherited from WebControl) | Tag attributes of the control.
BackColor (inherited from WebControl) | Color of the background of the control.
BackImageUrl (inherited from C1WebToolBarControl) | Gets or sets the URL of an image to display in the background of the C1WebToolBarControl control.
BorderColor (inherited from WebControl) | Color of the border around the control.
BorderStyle (inherited from WebControl) | Style of the border around the control.
BorderWidth (inherited from WebControl) | Width of the border around the control.
ClientID (inherited from Control) | The ID of the control that is rendered for the client.
ClientScripts (inherited from C1WebToolBarControl) | Client-side scripts associated with the item.
Controls (inherited from Control) | The collection of child controls owned by the control.
ControlStyle (inherited from WebControl) | The style associated with the control.
ControlStyleCreated (inherited from WebControl) | Whether the style associated with the control has been created.
CssClass (inherited from WebControl) | CSS Class name applied to the control.
DisabledStyle | Gets the disabled style of the C1WebToolBarButton.
Enabled (inherited from WebControl) | Enabled state of the control.
EnableViewState (inherited from Control) | Whether the control automatically saves its state for use in round-trips.
Font (inherited from WebControl) | The font used for text within the control.
ForeColor (inherited from WebControl) | Color of the text within the control.
HoverStyle | Gets the style of the C1WebToolBarButton when the user hovers the mouse pointer over it.
ID (inherited from Control) | Programmatic name of the control.
LinkUrl (inherited from C1WebToolBarControl) | Gets or sets the URL linked to the C1WebToolBarControl control.
NamingContainer (inherited from Control) | The containing control or page within which ID is unique.
Page (inherited from Control) | The page containing the control.
Parent (inherited from Control) | The control containing this control.
SelectedStyle | Style for the "selected" state (e.g. button is pushed etc.)
Site (inherited from Control) | Site of the control.
Style (inherited from WebControl) | Low-level access to control styles.
TabIndex (inherited from WebControl) | The tab order of the control.
TemplateControl (inherited from Control) | The TemplateControl that hosts this control.
TemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
ToolTip (inherited from WebControl) | The tooltip displayed when the mouse is over the control.
UniqueID (inherited from Control) | The unique ID of the control within the page.
Visible (inherited from Control) | Indicates whether the control is visible and rendered.
Width (inherited from C1WebToolBarControl) | Gets or sets the width of the C1WebToolBarControl.

Protected Properties

ViewState (inherited from Control)

Current viewstate of the control.

See Also


C1WebToolBarButtonBase.DisabledStyle Property

C1WebToolBarButtonBase.DisabledStyle Property

Gets the disabled style of the C1WebToolBarButton.

[Visual Basic]

Public ReadOnly Property DisabledStyle As C1WebToolBarStyle

[C#]

public C1WebToolBarStyle DisabledStyle {get;}

[Delphi]

public property DisabledStyle: C1WebToolBarStyle read get_DisabledStyle;

See Also


C1WebToolBarButtonBase.HoverStyle Property

C1WebToolBarButtonBase.HoverStyle Property

Gets the style of the C1WebToolBarButton when the user hovers the mouse pointer over it.

[Visual Basic]

Public ReadOnly Property HoverStyle As C1WebToolBarStyle

[C#]

public C1WebToolBarStyle HoverStyle {get;}

[Delphi]

public property HoverStyle: C1WebToolBarStyle read get_HoverStyle;

See Also


C1WebToolBarButtonBase.SelectedStyle Property

C1WebToolBarButtonBase.SelectedStyle Property

Style for the "selected" state (e.g. button is pushed etc.)

[Visual Basic]

Public ReadOnly Property SelectedStyle As C1WebToolBarStyle

[C#]

public C1WebToolBarStyle SelectedStyle {get;}

[Delphi]

public property SelectedStyle: C1WebToolBarStyle read get_SelectedStyle;

See Also


C1WebToolBarButtonBase Events

C1WebToolBarButtonBase Events

The events of the C1WebToolBarButtonBase class are listed here. For a complete list of C1WebToolBarButtonBase class members, see the C1WebToolBarButtonBase Members topic.

Public Events

Click | Fires when the C1WebToolBarControl is clicked.
DataBinding (inherited from Control) | Fires when the control's data binding expressions are to be evaluated.
Disposed (inherited from Control) | Fires when the control has been disposed.
Init (inherited from Control) | Fires when the page has been initialized.
Load (inherited from Control) | Fires when the page has been loaded.
PreRender (inherited from Control) | Fires before the page is rendered.
Unload (inherited from Control) | Fires when the page is unloaded.

See Also


C1WebToolBarButtonBase.Click Event

C1WebToolBarButtonBase.Click Event

Fires when the C1WebToolBarControl is clicked.

[Visual Basic]

Public Event Click As EventHandler

[C#]

public event EventHandler Click

[Delphi]

public property Click: EventHandler read remove_Click write add_Click;

See Also


C1WebToolBarContainerBase Class

C1WebToolBarContainerBase Class

The base class for the C1WebToolBar and the C1WebToolBarToggleGroup.

For a list of all members of this type, see C1WebToolBarContainerBase Members.

System.Object

System.Web.UI.Control

System.Web.UI.WebControls.WebControl

System.Web.UI.WebControls.Panel

C1.Web.C1Command.C1WebToolBarContainerBase

C1.Web.C1Command.C1WebToolBar

C1.Web.C1Command.C1WebToolBarToggleGroupBase

[Visual Basic]

MustInherit Public Class C1WebToolBarContainerBase

Inherits Panel

Implements IPostBackDataHandler

[C#]

public abstract class C1WebToolBarContainerBase : Panel , IPostBackDataHandler

[Delphi]

type C1WebToolBarContainerBase = class abstract (Panel, IPostBackDataHandler);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1WebToolBarContainerBase Members

C1WebToolBarContainerBase Members

C1WebToolBarContainerBase overview

Public Properties

AccessKey (inherited from WebControl) | Keyboard shortcut used by the control.
AppRelativeTemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Attributes (inherited from WebControl) | Tag attributes of the control.
BackColor (inherited from WebControl) | Color of the background of the control.
BackImageUrl (inherited from Panel) | The background image of the panel.
BorderColor (inherited from WebControl) | Color of the border around the control.
BorderStyle (inherited from WebControl) | Style of the border around the control.
BorderWidth (inherited from WebControl) | Width of the border around the control.
ClientID (inherited from Control) | The ID of the control that is rendered for the client.
ControlStyle (inherited from WebControl) | The style associated with the control.
ControlStyleCreated (inherited from WebControl) | Whether the style associated with the control has been created.
CssClass (inherited from WebControl) | CSS Class name applied to the control.
DefaultButton (inherited from Panel) | The default button for the panel.
Direction (inherited from Panel) | The direction of text in the panel.
DisabledItemStyle | The style applied to disabled items.
Enabled (inherited from WebControl) | Enabled state of the control.
EnableViewState (inherited from Control) | Whether the control automatically saves its state for use in round-trips.
Font (inherited from WebControl) | The font used for text within the control.
ForeColor (inherited from WebControl) | Color of the text within the control.
GroupingText (inherited from Panel) | The text of group box around this control's contents.
Height (inherited from WebControl) | The height of the control.
HorizontalAlign (inherited from Panel) | The horizontal alignment of the content.
HoverItemStyle | The style applied to items when the mouse hovers over them.
ID (inherited from Control) | Programmatic name of the control.
ItemImageHeight | Gets or sets the height of the item image.
ItemImageWidth | Gets or sets the width of the item image.
ItemSpacing | Gets or sets spacing between toolbar's border and button's border.
ItemStyle | The style applied to items in this toolbar.
ItemTextSpacing | Gets or sets spacing between buttons's border and buttons's text.
Layout | Indicates whether to layout menu items vertically or horizontally.
LayoutActual | Gets the actual menu layout.
NamingContainer (inherited from Control) | The containing control or page within which ID is unique.
Page (inherited from Control) | The page containing the control.
Parent (inherited from Control) | The control containing this control.
ScrollBars (inherited from Panel) | The appearance of scrollbars for the panel.
SelectedItemStyle | The style applied to selected items.
Site (inherited from Control) | Site of the control.
Style (inherited from WebControl) | Low-level access to control styles.
TabIndex (inherited from WebControl) | The tab order of the control.
TemplateControl (inherited from Control) | The TemplateControl that hosts this control.
TemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
ToolTip (inherited from WebControl) | The tooltip displayed when the mouse is over the control.
UniqueID (inherited from Control) | The unique ID of the control within the page.
Visible (inherited from Control) | Indicates whether the control is visible and rendered.
Width (inherited from WebControl) | The width of the control.
Wrap (inherited from Panel) | Whether the content should wrap or not.

Public Events

DataBinding (inherited from Control) | Fires when the control's data binding expressions are to be evaluated.
Disposed (inherited from Control) | Fires when the control has been disposed.
Init (inherited from Control) | Fires when the page has been initialized.
Load (inherited from Control) | Fires when the page has been loaded.
PreRender (inherited from Control) | Fires before the page is rendered.
Unload (inherited from Control) | Fires when the page is unloaded.

Protected Properties

ViewState (inherited from Control)

Current viewstate of the control.

See Also


C1WebToolBarContainerBase Properties

C1WebToolBarContainerBase Properties

The properties of the C1WebToolBarContainerBase class are listed here. For a complete list of C1WebToolBarContainerBase class members, see the C1WebToolBarContainerBase Members topic.

Public Properties

AccessKey (inherited from WebControl) | Keyboard shortcut used by the control.
AppRelativeTemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Attributes (inherited from WebControl) | Tag attributes of the control.
BackColor (inherited from WebControl) | Color of the background of the control.
BackImageUrl (inherited from Panel) | The background image of the panel.
BorderColor (inherited from WebControl) | Color of the border around the control.
BorderStyle (inherited from WebControl) | Style of the border around the control.
BorderWidth (inherited from WebControl) | Width of the border around the control.
ClientID (inherited from Control) | The ID of the control that is rendered for the client.
ControlStyle (inherited from WebControl) | The style associated with the control.
ControlStyleCreated (inherited from WebControl) | Whether the style associated with the control has been created.
CssClass (inherited from WebControl) | CSS Class name applied to the control.
DefaultButton (inherited from Panel) | The default button for the panel.
Direction (inherited from Panel) | The direction of text in the panel.
DisabledItemStyle | The style applied to disabled items.
Enabled (inherited from WebControl) | Enabled state of the control.
EnableViewState (inherited from Control) | Whether the control automatically saves its state for use in round-trips.
Font (inherited from WebControl) | The font used for text within the control.
ForeColor (inherited from WebControl) | Color of the text within the control.
GroupingText (inherited from Panel) | The text of group box around this control's contents.
Height (inherited from WebControl) | The height of the control.
HorizontalAlign (inherited from Panel) | The horizontal alignment of the content.
HoverItemStyle | The style applied to items when the mouse hovers over them.
ID (inherited from Control) | Programmatic name of the control.
ItemImageHeight | Gets or sets the height of the item image.
ItemImageWidth | Gets or sets the width of the item image.
ItemSpacing | Gets or sets spacing between toolbar's border and button's border.
ItemStyle | The style applied to items in this toolbar.
ItemTextSpacing | Gets or sets spacing between buttons's border and buttons's text.
Layout | Indicates whether to layout menu items vertically or horizontally.
LayoutActual | Gets the actual menu layout.
NamingContainer (inherited from Control) | The containing control or page within which ID is unique.
Page (inherited from Control) | The page containing the control.
Parent (inherited from Control) | The control containing this control.
ScrollBars (inherited from Panel) | The appearance of scrollbars for the panel.
SelectedItemStyle | The style applied to selected items.
Site (inherited from Control) | Site of the control.
Style (inherited from WebControl) | Low-level access to control styles.
TabIndex (inherited from WebControl) | The tab order of the control.
TemplateControl (inherited from Control) | The TemplateControl that hosts this control.
TemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
ToolTip (inherited from WebControl) | The tooltip displayed when the mouse is over the control.
UniqueID (inherited from Control) | The unique ID of the control within the page.
Visible (inherited from Control) | Indicates whether the control is visible and rendered.
Width (inherited from WebControl) | The width of the control.
Wrap (inherited from Panel) | Whether the content should wrap or not.

Protected Properties

ViewState (inherited from Control)

Current viewstate of the control.

See Also


C1WebToolBarContainerBase.DisabledItemStyle Property

C1WebToolBarContainerBase.DisabledItemStyle Property

The style applied to disabled items.

[Visual Basic]

Public ReadOnly Property DisabledItemStyle As C1WebToolBarStyle

[C#]

public C1WebToolBarStyle DisabledItemStyle {get;}

[Delphi]

public property DisabledItemStyle: C1WebToolBarStyle read get_DisabledItemStyle;

See Also


C1WebToolBarContainerBase.HoverItemStyle Property

C1WebToolBarContainerBase.HoverItemStyle Property

The style applied to items when the mouse hovers over them.

[Visual Basic]

Public ReadOnly Property HoverItemStyle As C1WebToolBarStyle

[C#]

public C1WebToolBarStyle HoverItemStyle {get;}

[Delphi]

public property HoverItemStyle: C1WebToolBarStyle read get_HoverItemStyle;

See Also


C1WebToolBarContainerBase.ItemImageHeight Property

C1WebToolBarContainerBase.ItemImageHeight Property

Gets or sets the height of the item image.

[Visual Basic]

Public Property ItemImageHeight As Unit

[C#]

public Unit ItemImageHeight {get;set;}

[Delphi]

public property ItemImageHeight: Unit read get_ItemImageHeight write set_ItemImageHeight;

See Also


C1WebToolBarContainerBase.ItemImageWidth Property

C1WebToolBarContainerBase.ItemImageWidth Property

Gets or sets the width of the item image.

[Visual Basic]

Public Property ItemImageWidth As Unit

[C#]

public Unit ItemImageWidth {get;set;}

[Delphi]

public property ItemImageWidth: Unit read get_ItemImageWidth write set_ItemImageWidth;

See Also


C1WebToolBarContainerBase.ItemSpacing Property

C1WebToolBarContainerBase.ItemSpacing Property

Gets or sets spacing between toolbar's border and button's border.

[Visual Basic]

Public Property ItemSpacing As Unit

[C#]

public Unit ItemSpacing {get;set;}

[Delphi]

public property ItemSpacing: Unit read get_ItemSpacing write set_ItemSpacing;

See Also


C1WebToolBarContainerBase.ItemStyle Property

C1WebToolBarContainerBase.ItemStyle Property

The style applied to items in this toolbar.

[Visual Basic]

Public ReadOnly Property ItemStyle As C1WebToolBarStyle

[C#]

public C1WebToolBarStyle ItemStyle {get;}

[Delphi]

public property ItemStyle: C1WebToolBarStyle read get_ItemStyle;

See Also


C1WebToolBarContainerBase.ItemTextSpacing Property

C1WebToolBarContainerBase.ItemTextSpacing Property

Gets or sets spacing between buttons's border and buttons's text.

[Visual Basic]

Public Property ItemTextSpacing As Unit

[C#]

public Unit ItemTextSpacing {get;set;}

[Delphi]

public property ItemTextSpacing: Unit read get_ItemTextSpacing write set_ItemTextSpacing;

See Also


C1WebToolBarContainerBase.Layout Property

C1WebToolBarContainerBase.Layout Property

Indicates whether to layout menu items vertically or horizontally.

[Visual Basic]

Public Property Layout As MenuLayoutEnum

[C#]

public MenuLayoutEnum Layout {get;set;}

[Delphi]

public property Layout: MenuLayoutEnum read get_Layout write set_Layout;

See Also


C1WebToolBarContainerBase.LayoutActual Property

C1WebToolBarContainerBase.LayoutActual Property

Gets the actual menu layout.

[Visual Basic]

Public ReadOnly Property LayoutActual As MenuLayoutEnum

[C#]

public MenuLayoutEnum LayoutActual {get;}

[Delphi]

public property LayoutActual: MenuLayoutEnum read get_LayoutActual;

See Also


C1WebToolBarContainerBase.SelectedItemStyle Property

C1WebToolBarContainerBase.SelectedItemStyle Property

The style applied to selected items.

[Visual Basic]

Public ReadOnly Property SelectedItemStyle As C1WebToolBarStyle

[C#]

public C1WebToolBarStyle SelectedItemStyle {get;}

[Delphi]

public property SelectedItemStyle: C1WebToolBarStyle read get_SelectedItemStyle;

See Also


C1WebToolBarContainerBase Events

C1WebToolBarContainerBase Events

The events of the C1WebToolBarContainerBase class are listed here. For a complete list of C1WebToolBarContainerBase class members, see the C1WebToolBarContainerBase Members topic.

Public Events

DataBinding (inherited from Control) | Fires when the control's data binding expressions are to be evaluated.
Disposed (inherited from Control) | Fires when the control has been disposed.
Init (inherited from Control) | Fires when the page has been initialized.
Load (inherited from Control) | Fires when the page has been loaded.
PreRender (inherited from Control) | Fires before the page is rendered.
Unload (inherited from Control) | Fires when the page is unloaded.

See Also


C1WebToolBarControl Class

C1WebToolBarControl Class

Base class for the C1WebToolBarButton and the C1WebToolBarSeparator controls.

For a list of all members of this type, see C1WebToolBarControl Members.

System.Object

System.Web.UI.Control

System.Web.UI.WebControls.WebControl

C1.Web.C1Command.C1WebToolBarControl

C1.Web.C1Command.C1WebToolBarButtonBase

C1.Web.C1Command.C1WebToolBarSeparator

[Visual Basic]

MustInherit Public Class C1WebToolBarControl

Inherits WebControl

Implements IPostBackDataHandler, IPostBackEventHandler

[C#]

public abstract class C1WebToolBarControl : WebControl , IPostBackDataHandler, IPostBackEventHandler

[Delphi]

type C1WebToolBarControl = class abstract (WebControl, IPostBackDataHandler, IPostBackEventHandler);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1WebToolBarControl Members

C1WebToolBarControl Members

C1WebToolBarControl overview

Public Properties

AccessKey (inherited from WebControl) | Keyboard shortcut used by the control.
AppRelativeTemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Attributes (inherited from WebControl) | Tag attributes of the control.
BackColor (inherited from WebControl) | Color of the background of the control.
BackImageUrl | Gets or sets the URL of an image to display in the background of the C1WebToolBarControl control.
BorderColor (inherited from WebControl) | Color of the border around the control.
BorderStyle (inherited from WebControl) | Style of the border around the control.
BorderWidth (inherited from WebControl) | Width of the border around the control.
ClientID (inherited from Control) | The ID of the control that is rendered for the client.
ClientScripts | Client-side scripts associated with the item.
Controls (inherited from Control) | The collection of child controls owned by the control.
ControlStyle (inherited from WebControl) | The style associated with the control.
ControlStyleCreated (inherited from WebControl) | Whether the style associated with the control has been created.
CssClass (inherited from WebControl) | CSS Class name applied to the control.
Enabled (inherited from WebControl) | Enabled state of the control.
EnableViewState (inherited from Control) | Whether the control automatically saves its state for use in round-trips.
Font (inherited from WebControl) | The font used for text within the control.
ForeColor (inherited from WebControl) | Color of the text within the control.
ID (inherited from Control) | Programmatic name of the control.
LinkUrl | Gets or sets the URL linked to the C1WebToolBarControl control.
NamingContainer (inherited from Control) | The containing control or page within which ID is unique.
Page (inherited from Control) | The page containing the control.
Parent (inherited from Control) | The control containing this control.
Site (inherited from Control) | Site of the control.
Style (inherited from WebControl) | Low-level access to control styles.
TabIndex (inherited from WebControl) | The tab order of the control.
TemplateControl (inherited from Control) | The TemplateControl that hosts this control.
TemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
ToolTip (inherited from WebControl) | The tooltip displayed when the mouse is over the control.
UniqueID (inherited from Control) | The unique ID of the control within the page.
Visible (inherited from Control) | Indicates whether the control is visible and rendered.
Width | Overriden. Gets or sets the width of the C1WebToolBarControl.

Public Events

DataBinding (inherited from Control) | Fires when the control's data binding expressions are to be evaluated.
Disposed (inherited from Control) | Fires when the control has been disposed.
Init (inherited from Control) | Fires when the page has been initialized.
Load (inherited from Control) | Fires when the page has been loaded.
PreRender (inherited from Control) | Fires before the page is rendered.
Unload (inherited from Control) | Fires when the page is unloaded.

Protected Properties

ViewState (inherited from Control)

Current viewstate of the control.

See Also


C1WebToolBarControl Properties

C1WebToolBarControl Properties

The properties of the C1WebToolBarControl class are listed here. For a complete list of C1WebToolBarControl class members, see the C1WebToolBarControl Members topic.

Public Properties

AccessKey (inherited from WebControl) | Keyboard shortcut used by the control.
AppRelativeTemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Attributes (inherited from WebControl) | Tag attributes of the control.
BackColor (inherited from WebControl) | Color of the background of the control.
BackImageUrl | Gets or sets the URL of an image to display in the background of the C1WebToolBarControl control.
BorderColor (inherited from WebControl) | Color of the border around the control.
BorderStyle (inherited from WebControl) | Style of the border around the control.
BorderWidth (inherited from WebControl) | Width of the border around the control.
ClientID (inherited from Control) | The ID of the control that is rendered for the client.
ClientScripts | Client-side scripts associated with the item.
Controls (inherited from Control) | The collection of child controls owned by the control.
ControlStyle (inherited from WebControl) | The style associated with the control.
ControlStyleCreated (inherited from WebControl) | Whether the style associated with the control has been created.
CssClass (inherited from WebControl) | CSS Class name applied to the control.
Enabled (inherited from WebControl) | Enabled state of the control.
EnableViewState (inherited from Control) | Whether the control automatically saves its state for use in round-trips.
Font (inherited from WebControl) | The font used for text within the control.
ForeColor (inherited from WebControl) | Color of the text within the control.
ID (inherited from Control) | Programmatic name of the control.
LinkUrl | Gets or sets the URL linked to the C1WebToolBarControl control.
NamingContainer (inherited from Control) | The containing control or page within which ID is unique.
Page (inherited from Control) | The page containing the control.
Parent (inherited from Control) | The control containing this control.
Site (inherited from Control) | Site of the control.
Style (inherited from WebControl) | Low-level access to control styles.
TabIndex (inherited from WebControl) | The tab order of the control.
TemplateControl (inherited from Control) | The TemplateControl that hosts this control.
TemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
ToolTip (inherited from WebControl) | The tooltip displayed when the mouse is over the control.
UniqueID (inherited from Control) | The unique ID of the control within the page.
Visible (inherited from Control) | Indicates whether the control is visible and rendered.
Width | Overriden. Gets or sets the width of the C1WebToolBarControl.

Protected Properties

ViewState (inherited from Control)

Current viewstate of the control.

See Also


C1WebToolBarControl.BackImageUrl Property

C1WebToolBarControl.BackImageUrl Property

Gets or sets the URL of an image to display in the background of the C1WebToolBarControl control.

[Visual Basic]

Public Property BackImageUrl As String

[C#]

public string BackImageUrl {get;set;}

[Delphi]

public property BackImageUrl: String read get_BackImageUrl write set_BackImageUrl;

See Also


C1WebToolBarControl.ClientScripts Property

C1WebToolBarControl.ClientScripts Property

Client-side scripts associated with the item.

[Visual Basic]

Public Property ClientScripts As ScriptDefCollection

[C#]

public ScriptDefCollection ClientScripts {get;set;}

[Delphi]

public property ClientScripts: ScriptDefCollection read get_ClientScripts write set_ClientScripts;

See Also


C1WebToolBarControl.LinkUrl Property

C1WebToolBarControl.LinkUrl Property

Gets or sets the URL linked to the C1WebToolBarControl control.

[Visual Basic]

Public Property LinkUrl As String

[C#]

public string LinkUrl {get;set;}

[Delphi]

public property LinkUrl: String read get_LinkUrl write set_LinkUrl;

See Also


C1WebToolBarControl.Width Property

C1WebToolBarControl.Width Property

Gets or sets the width of the C1WebToolBarControl.

[Visual Basic]

Overrides Public Property Width As Unit

[C#]

override public Unit Width {get;set;}

[Delphi]

public property Width: Unit read get_Width write set_Width;

See Also


C1WebToolBarControl Events

C1WebToolBarControl Events

The events of the C1WebToolBarControl class are listed here. For a complete list of C1WebToolBarControl class members, see the C1WebToolBarControl Members topic.

Public Events

DataBinding (inherited from Control) | Fires when the control's data binding expressions are to be evaluated.
Disposed (inherited from Control) | Fires when the control has been disposed.
Init (inherited from Control) | Fires when the page has been initialized.
Load (inherited from Control) | Fires when the page has been loaded.
PreRender (inherited from Control) | Fires before the page is rendered.
Unload (inherited from Control) | Fires when the page is unloaded.

See Also


C1WebToolBarSeparator Class

C1WebToolBarSeparator Class

Represents separator on the toolbar.

For a list of all members of this type, see C1WebToolBarSeparator Members.

System.Object

System.Web.UI.Control

System.Web.UI.WebControls.WebControl

C1.Web.C1Command.C1WebToolBarControl

C1.Web.C1Command.C1WebToolBarSeparator

[Visual Basic]

Public Class C1WebToolBarSeparator

Inherits C1WebToolBarControl

[C#]

public class C1WebToolBarSeparator : C1WebToolBarControl

[Delphi]

type C1WebToolBarSeparator = class (C1WebToolBarControl);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1WebToolBarSeparator Members

C1WebToolBarSeparator Members

C1WebToolBarSeparator overview

Public Properties

AccessKey (inherited from WebControl) | Keyboard shortcut used by the control.
AppRelativeTemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Attributes (inherited from WebControl) | Tag attributes of the control.
BackColor (inherited from WebControl) | Color of the background of the control.
BackImageUrl (inherited from C1WebToolBarControl) | Gets or sets the URL of an image to display in the background of the C1WebToolBarControl control.
BorderColor (inherited from WebControl) | Color of the border around the control.
BorderStyle (inherited from WebControl) | Style of the border around the control.
BorderWidth (inherited from WebControl) | Width of the border around the control.
ClientID (inherited from Control) | The ID of the control that is rendered for the client.
ClientScripts (inherited from C1WebToolBarControl) | Client-side scripts associated with the item.
Controls (inherited from Control) | The collection of child controls owned by the control.
ControlStyle (inherited from WebControl) | The style associated with the control.
ControlStyleCreated (inherited from WebControl) | Whether the style associated with the control has been created.
CssClass (inherited from WebControl) | CSS Class name applied to the control.
Enabled (inherited from WebControl) | Enabled state of the control.
EnableViewState (inherited from Control) | Whether the control automatically saves its state for use in round-trips.
Font (inherited from WebControl) | The font used for text within the control.
ForeColor (inherited from WebControl) | Color of the text within the control.
GapWidth | Gets or sets the width of the C1WebToolBarSeparator.
Height | Overriden. Gets or sets the height of the C1WebToolBarSeparator.
ID (inherited from Control) | Programmatic name of the control.
LinkUrl (inherited from C1WebToolBarControl) | Gets or sets the URL linked to the C1WebToolBarControl control.
NamingContainer (inherited from Control) | The containing control or page within which ID is unique.
Page (inherited from Control) | The page containing the control.
Parent (inherited from Control) | The control containing this control.
Site (inherited from Control) | Site of the control.
Style (inherited from WebControl) | Low-level access to control styles.
TabIndex (inherited from WebControl) | The tab order of the control.
TemplateControl (inherited from Control) | The TemplateControl that hosts this control.
TemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
ToolTip (inherited from WebControl) | The tooltip displayed when the mouse is over the control.
UniqueID (inherited from Control) | The unique ID of the control within the page.
Visible (inherited from Control) | Indicates whether the control is visible and rendered.
Width | Overriden. Gets or sets the width of the C1WebToolBarSeparator.

Public Events

DataBinding (inherited from Control) | Fires when the control's data binding expressions are to be evaluated.
Disposed (inherited from Control) | Fires when the control has been disposed.
Init (inherited from Control) | Fires when the page has been initialized.
Load (inherited from Control) | Fires when the page has been loaded.
PreRender (inherited from Control) | Fires before the page is rendered.
Unload (inherited from Control) | Fires when the page is unloaded.

Protected Properties

ViewState (inherited from Control)

Current viewstate of the control.

See Also


C1WebToolBarSeparator Properties

C1WebToolBarSeparator Properties

The properties of the C1WebToolBarSeparator class are listed here. For a complete list of C1WebToolBarSeparator class members, see the C1WebToolBarSeparator Members topic.

Public Properties

AccessKey (inherited from WebControl) | Keyboard shortcut used by the control.
AppRelativeTemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Attributes (inherited from WebControl) | Tag attributes of the control.
BackColor (inherited from WebControl) | Color of the background of the control.
BackImageUrl (inherited from C1WebToolBarControl) | Gets or sets the URL of an image to display in the background of the C1WebToolBarControl control.
BorderColor (inherited from WebControl) | Color of the border around the control.
BorderStyle (inherited from WebControl) | Style of the border around the control.
BorderWidth (inherited from WebControl) | Width of the border around the control.
ClientID (inherited from Control) | The ID of the control that is rendered for the client.
ClientScripts (inherited from C1WebToolBarControl) | Client-side scripts associated with the item.
Controls (inherited from Control) | The collection of child controls owned by the control.
ControlStyle (inherited from WebControl) | The style associated with the control.
ControlStyleCreated (inherited from WebControl) | Whether the style associated with the control has been created.
CssClass (inherited from WebControl) | CSS Class name applied to the control.
Enabled (inherited from WebControl) | Enabled state of the control.
EnableViewState (inherited from Control) | Whether the control automatically saves its state for use in round-trips.
Font (inherited from WebControl) | The font used for text within the control.
ForeColor (inherited from WebControl) | Color of the text within the control.
GapWidth | Gets or sets the width of the C1WebToolBarSeparator.
Height | Overriden. Gets or sets the height of the C1WebToolBarSeparator.
ID (inherited from Control) | Programmatic name of the control.
LinkUrl (inherited from C1WebToolBarControl) | Gets or sets the URL linked to the C1WebToolBarControl control.
NamingContainer (inherited from Control) | The containing control or page within which ID is unique.
Page (inherited from Control) | The page containing the control.
Parent (inherited from Control) | The control containing this control.
Site (inherited from Control) | Site of the control.
Style (inherited from WebControl) | Low-level access to control styles.
TabIndex (inherited from WebControl) | The tab order of the control.
TemplateControl (inherited from Control) | The TemplateControl that hosts this control.
TemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
ToolTip (inherited from WebControl) | The tooltip displayed when the mouse is over the control.
UniqueID (inherited from Control) | The unique ID of the control within the page.
Visible (inherited from Control) | Indicates whether the control is visible and rendered.
Width | Overriden. Gets or sets the width of the C1WebToolBarSeparator.

Protected Properties

ViewState (inherited from Control)

Current viewstate of the control.

See Also


C1WebToolBarSeparator.GapWidth Property

C1WebToolBarSeparator.GapWidth Property

Gets or sets the width of the C1WebToolBarSeparator.

[Visual Basic]

Public Property GapWidth As Unit

[C#]

public Unit GapWidth {get;set;}

[Delphi]

public property GapWidth: Unit read get_GapWidth write set_GapWidth;

See Also


C1WebToolBarSeparator.Height Property

C1WebToolBarSeparator.Height Property

Gets or sets the height of the C1WebToolBarSeparator.

[Visual Basic]

Overrides Public Property Height As Unit

[C#]

override public Unit Height {get;set;}

[Delphi]

public property Height: Unit read get_Height write set_Height;

See Also


C1WebToolBarSeparator.Width Property

C1WebToolBarSeparator.Width Property

Gets or sets the width of the C1WebToolBarSeparator.

[Visual Basic]

Overrides Public Property Width As Unit

[C#]

override public Unit Width {get;set;}

[Delphi]

public property Width: Unit read get_Width write set_Width;

See Also


C1WebToolBarSeparator Events

C1WebToolBarSeparator Events

The events of the C1WebToolBarSeparator class are listed here. For a complete list of C1WebToolBarSeparator class members, see the C1WebToolBarSeparator Members topic.

Public Events

DataBinding (inherited from Control) | Fires when the control's data binding expressions are to be evaluated.
Disposed (inherited from Control) | Fires when the control has been disposed.
Init (inherited from Control) | Fires when the page has been initialized.
Load (inherited from Control) | Fires when the page has been loaded.
PreRender (inherited from Control) | Fires before the page is rendered.
Unload (inherited from Control) | Fires when the page is unloaded.

See Also


C1WebToolBarStyle Class

C1WebToolBarStyle Class

Style for the web toolbar elements.

For a list of all members of this type, see C1WebToolBarStyle Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Web.UI.WebControls.Style

C1.Web.C1Command.C1WebToolBarStyle

[Visual Basic]

Public Class C1WebToolBarStyle

Inherits Style

[C#]

public class C1WebToolBarStyle : Style

[Delphi]

type C1WebToolBarStyle = class (Style);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1WebToolBarStyle Members

C1WebToolBarStyle Members

C1WebToolBarStyle overview

Public Properties

BackColor (inherited from Style) | Background color of the controls applied with this style.
BackImageUrl | Gets or sets the URL of an image to display in the background of the C1WebToolBarStyle control.
BorderColor (inherited from Style) | Border color of the controls applied with this style.
BorderStyle (inherited from Style) | Style of the border of controls applied with this style.
BorderWidth (inherited from Style) | Thickness of the border around the controls applied with this style.
CssClass (inherited from Style) | CSS class name applied to the user of this style.
Font (inherited from Style) | The font used for text in controls applied with this style.
ForeColor (inherited from Style) | Foreground color of the controls applied with this style.
ImageUrl | Gets or sets the location of an image to display in the C1WebToolBarStyle.

See Also


C1WebToolBarStyle Properties

C1WebToolBarStyle Properties

The properties of the C1WebToolBarStyle class are listed here. For a complete list of C1WebToolBarStyle class members, see the C1WebToolBarStyle Members topic.

Public Properties

BackColor (inherited from Style) | Background color of the controls applied with this style.
BackImageUrl | Gets or sets the URL of an image to display in the background of the C1WebToolBarStyle control.
BorderColor (inherited from Style) | Border color of the controls applied with this style.
BorderStyle (inherited from Style) | Style of the border of controls applied with this style.
BorderWidth (inherited from Style) | Thickness of the border around the controls applied with this style.
CssClass (inherited from Style) | CSS class name applied to the user of this style.
Font (inherited from Style) | The font used for text in controls applied with this style.
ForeColor (inherited from Style) | Foreground color of the controls applied with this style.
ImageUrl | Gets or sets the location of an image to display in the C1WebToolBarStyle.

See Also


C1WebToolBarStyle.BackImageUrl Property

C1WebToolBarStyle.BackImageUrl Property

Gets or sets the URL of an image to display in the background of the C1WebToolBarStyle control.

[Visual Basic]

Public Property BackImageUrl As String

[C#]

public string BackImageUrl {get;set;}

[Delphi]

public property BackImageUrl: String read get_BackImageUrl write set_BackImageUrl;

See Also


C1WebToolBarStyle.ImageUrl Property

C1WebToolBarStyle.ImageUrl Property

Gets or sets the location of an image to display in the C1WebToolBarStyle.

[Visual Basic]

Public Property ImageUrl As String

[C#]

public string ImageUrl {get;set;}

[Delphi]

public property ImageUrl: String read get_ImageUrl write set_ImageUrl;

See Also


C1WebToolBarToggleGroup Class

C1WebToolBarToggleGroup Class

For a list of all members of this type, see C1WebToolBarToggleGroup Members.

System.Object

System.Web.UI.Control

System.Web.UI.WebControls.WebControl

System.Web.UI.WebControls.Panel

C1.Web.C1Command.C1WebToolBarContainerBase

C1.Web.C1Command.C1WebToolBarToggleGroupBase

C1.Web.C1Command.C1WebToolBarToggleGroup

[Visual Basic]

Public Class C1WebToolBarToggleGroup

Inherits C1WebToolBarToggleGroupBase

[C#]

public class C1WebToolBarToggleGroup : C1WebToolBarToggleGroupBase

[Delphi]

type C1WebToolBarToggleGroup = class (C1WebToolBarToggleGroupBase);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1WebToolBarToggleGroup Members

C1WebToolBarToggleGroup Members

C1WebToolBarToggleGroup overview

Public Properties

AccessKey (inherited from WebControl) | Keyboard shortcut used by the control.
AppRelativeTemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Attributes (inherited from WebControl) | Tag attributes of the control.
BackColor (inherited from WebControl) | Color of the background of the control.
BackImageUrl (inherited from Panel) | The background image of the panel.
BorderColor (inherited from WebControl) | Color of the border around the control.
BorderStyle (inherited from WebControl) | Style of the border around the control.
BorderWidth (inherited from WebControl) | Width of the border around the control.
ClientID (inherited from Control) | The ID of the control that is rendered for the client.
ControlStyle (inherited from WebControl) | The style associated with the control.
ControlStyleCreated (inherited from WebControl) | Whether the style associated with the control has been created.
CssClass (inherited from WebControl) | CSS Class name applied to the control.
DefaultButton (inherited from Panel) | The default button for the panel.
Direction (inherited from Panel) | The direction of text in the panel.
DisabledItemStyle (inherited from C1WebToolBarContainerBase) | The style applied to disabled items.
Enabled (inherited from WebControl) | Enabled state of the control.
EnableViewState (inherited from Control) | Whether the control automatically saves its state for use in round-trips.
Font (inherited from WebControl) | The font used for text within the control.
ForeColor (inherited from WebControl) | Color of the text within the control.
GroupingText (inherited from Panel) | The text of group box around this control's contents.
Height (inherited from WebControl) | The height of the control.
HorizontalAlign (inherited from Panel) | The horizontal alignment of the content.
HoverItemStyle (inherited from C1WebToolBarContainerBase) | The style applied to items when the mouse hovers over them.
ID (inherited from Control) | Programmatic name of the control.
ItemImageHeight (inherited from C1WebToolBarContainerBase) | Gets or sets the height of the item image.
ItemImageWidth (inherited from C1WebToolBarContainerBase) | Gets or sets the width of the item image.
ItemSpacing (inherited from C1WebToolBarContainerBase) | Gets or sets spacing between toolbar's border and button's border.
ItemStyle (inherited from C1WebToolBarContainerBase) | The style applied to items in this toolbar.
ItemTextSpacing (inherited from C1WebToolBarContainerBase) | Gets or sets spacing between buttons's border and buttons's text.
Layout (inherited from C1WebToolBarContainerBase) | Indicates whether to layout menu items vertically or horizontally.
LayoutActual (inherited from C1WebToolBarContainerBase) | Gets the actual menu layout.
NamingContainer (inherited from Control) | The containing control or page within which ID is unique.
Page (inherited from Control) | The page containing the control.
Parent (inherited from Control) | The control containing this control.
ScrollBars (inherited from Panel) | The appearance of scrollbars for the panel.
SelectedItemStyle (inherited from C1WebToolBarContainerBase) | The style applied to selected items.
Site (inherited from Control) | Site of the control.
Style (inherited from WebControl) | Low-level access to control styles.
TabIndex (inherited from WebControl) | The tab order of the control.
TemplateControl (inherited from Control) | The TemplateControl that hosts this control.
TemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
ToolTip (inherited from WebControl) | The tooltip displayed when the mouse is over the control.
UniqueID (inherited from Control) | The unique ID of the control within the page.
Visible (inherited from Control) | Indicates whether the control is visible and rendered.
Width (inherited from WebControl) | The width of the control.
Wrap (inherited from Panel) | Whether the content should wrap or not.

Public Events

DataBinding (inherited from Control) | Fires when the control's data binding expressions are to be evaluated.
Disposed (inherited from Control) | Fires when the control has been disposed.
Init (inherited from Control) | Fires when the page has been initialized.
Load (inherited from Control) | Fires when the page has been loaded.
PreRender (inherited from Control) | Fires before the page is rendered.
Unload (inherited from Control) | Fires when the page is unloaded.

Protected Properties

ViewState (inherited from Control)

Current viewstate of the control.

See Also


C1WebToolBarToggleGroup Properties

C1WebToolBarToggleGroup Properties

The properties of the C1WebToolBarToggleGroup class are listed here. For a complete list of C1WebToolBarToggleGroup class members, see the C1WebToolBarToggleGroup Members topic.

Public Properties

AccessKey (inherited from WebControl) | Keyboard shortcut used by the control.
AppRelativeTemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Attributes (inherited from WebControl) | Tag attributes of the control.
BackColor (inherited from WebControl) | Color of the background of the control.
BackImageUrl (inherited from Panel) | The background image of the panel.
BorderColor (inherited from WebControl) | Color of the border around the control.
BorderStyle (inherited from WebControl) | Style of the border around the control.
BorderWidth (inherited from WebControl) | Width of the border around the control.
ClientID (inherited from Control) | The ID of the control that is rendered for the client.
ControlStyle (inherited from WebControl) | The style associated with the control.
ControlStyleCreated (inherited from WebControl) | Whether the style associated with the control has been created.
CssClass (inherited from WebControl) | CSS Class name applied to the control.
DefaultButton (inherited from Panel) | The default button for the panel.
Direction (inherited from Panel) | The direction of text in the panel.
DisabledItemStyle (inherited from C1WebToolBarContainerBase) | The style applied to disabled items.
Enabled (inherited from WebControl) | Enabled state of the control.
EnableViewState (inherited from Control) | Whether the control automatically saves its state for use in round-trips.
Font (inherited from WebControl) | The font used for text within the control.
ForeColor (inherited from WebControl) | Color of the text within the control.
GroupingText (inherited from Panel) | The text of group box around this control's contents.
Height (inherited from WebControl) | The height of the control.
HorizontalAlign (inherited from Panel) | The horizontal alignment of the content.
HoverItemStyle (inherited from C1WebToolBarContainerBase) | The style applied to items when the mouse hovers over them.
ID (inherited from Control) | Programmatic name of the control.
ItemImageHeight (inherited from C1WebToolBarContainerBase) | Gets or sets the height of the item image.
ItemImageWidth (inherited from C1WebToolBarContainerBase) | Gets or sets the width of the item image.
ItemSpacing (inherited from C1WebToolBarContainerBase) | Gets or sets spacing between toolbar's border and button's border.
ItemStyle (inherited from C1WebToolBarContainerBase) | The style applied to items in this toolbar.
ItemTextSpacing (inherited from C1WebToolBarContainerBase) | Gets or sets spacing between buttons's border and buttons's text.
Layout (inherited from C1WebToolBarContainerBase) | Indicates whether to layout menu items vertically or horizontally.
LayoutActual (inherited from C1WebToolBarContainerBase) | Gets the actual menu layout.
NamingContainer (inherited from Control) | The containing control or page within which ID is unique.
Page (inherited from Control) | The page containing the control.
Parent (inherited from Control) | The control containing this control.
ScrollBars (inherited from Panel) | The appearance of scrollbars for the panel.
SelectedItemStyle (inherited from C1WebToolBarContainerBase) | The style applied to selected items.
Site (inherited from Control) | Site of the control.
Style (inherited from WebControl) | Low-level access to control styles.
TabIndex (inherited from WebControl) | The tab order of the control.
TemplateControl (inherited from Control) | The TemplateControl that hosts this control.
TemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
ToolTip (inherited from WebControl) | The tooltip displayed when the mouse is over the control.
UniqueID (inherited from Control) | The unique ID of the control within the page.
Visible (inherited from Control) | Indicates whether the control is visible and rendered.
Width (inherited from WebControl) | The width of the control.
Wrap (inherited from Panel) | Whether the content should wrap or not.

Protected Properties

ViewState (inherited from Control)

Current viewstate of the control.

See Also


C1WebToolBarToggleGroup Events

C1WebToolBarToggleGroup Events

The events of the C1WebToolBarToggleGroup class are listed here. For a complete list of C1WebToolBarToggleGroup class members, see the C1WebToolBarToggleGroup Members topic.

Public Events

DataBinding (inherited from Control) | Fires when the control's data binding expressions are to be evaluated.
Disposed (inherited from Control) | Fires when the control has been disposed.
Init (inherited from Control) | Fires when the page has been initialized.
Load (inherited from Control) | Fires when the page has been loaded.
PreRender (inherited from Control) | Fires before the page is rendered.
Unload (inherited from Control) | Fires when the page is unloaded.

See Also


C1WebToolBarToggleGroupBase Class

C1WebToolBarToggleGroupBase Class

For a list of all members of this type, see C1WebToolBarToggleGroupBase Members.

System.Object

System.Web.UI.Control

System.Web.UI.WebControls.WebControl

System.Web.UI.WebControls.Panel

C1.Web.C1Command.C1WebToolBarContainerBase

C1.Web.C1Command.C1WebToolBarToggleGroupBase

C1.Web.C1Command.C1WebToolBarToggleGroup

[Visual Basic]

MustInherit Public Class C1WebToolBarToggleGroupBase

Inherits C1WebToolBarContainerBase

[C#]

public abstract class C1WebToolBarToggleGroupBase : C1WebToolBarContainerBase

[Delphi]

type C1WebToolBarToggleGroupBase = class abstract (C1WebToolBarContainerBase);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1WebToolBarToggleGroupBase Members

C1WebToolBarToggleGroupBase Members

C1WebToolBarToggleGroupBase overview

Public Properties

AccessKey (inherited from WebControl) | Keyboard shortcut used by the control.
AppRelativeTemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Attributes (inherited from WebControl) | Tag attributes of the control.
BackColor (inherited from WebControl) | Color of the background of the control.
BackImageUrl (inherited from Panel) | The background image of the panel.
BorderColor (inherited from WebControl) | Color of the border around the control.
BorderStyle (inherited from WebControl) | Style of the border around the control.
BorderWidth (inherited from WebControl) | Width of the border around the control.
ClientID (inherited from Control) | The ID of the control that is rendered for the client.
ControlStyle (inherited from WebControl) | The style associated with the control.
ControlStyleCreated (inherited from WebControl) | Whether the style associated with the control has been created.
CssClass (inherited from WebControl) | CSS Class name applied to the control.
DefaultButton (inherited from Panel) | The default button for the panel.
Direction (inherited from Panel) | The direction of text in the panel.
DisabledItemStyle (inherited from C1WebToolBarContainerBase) | The style applied to disabled items.
Enabled (inherited from WebControl) | Enabled state of the control.
EnableViewState (inherited from Control) | Whether the control automatically saves its state for use in round-trips.
Font (inherited from WebControl) | The font used for text within the control.
ForeColor (inherited from WebControl) | Color of the text within the control.
GroupingText (inherited from Panel) | The text of group box around this control's contents.
Height (inherited from WebControl) | The height of the control.
HorizontalAlign (inherited from Panel) | The horizontal alignment of the content.
HoverItemStyle (inherited from C1WebToolBarContainerBase) | The style applied to items when the mouse hovers over them.
ID (inherited from Control) | Programmatic name of the control.
ItemImageHeight (inherited from C1WebToolBarContainerBase) | Gets or sets the height of the item image.
ItemImageWidth (inherited from C1WebToolBarContainerBase) | Gets or sets the width of the item image.
ItemSpacing (inherited from C1WebToolBarContainerBase) | Gets or sets spacing between toolbar's border and button's border.
ItemStyle (inherited from C1WebToolBarContainerBase) | The style applied to items in this toolbar.
ItemTextSpacing (inherited from C1WebToolBarContainerBase) | Gets or sets spacing between buttons's border and buttons's text.
Layout (inherited from C1WebToolBarContainerBase) | Indicates whether to layout menu items vertically or horizontally.
LayoutActual (inherited from C1WebToolBarContainerBase) | Gets the actual menu layout.
NamingContainer (inherited from Control) | The containing control or page within which ID is unique.
Page (inherited from Control) | The page containing the control.
Parent (inherited from Control) | The control containing this control.
ScrollBars (inherited from Panel) | The appearance of scrollbars for the panel.
SelectedItemStyle (inherited from C1WebToolBarContainerBase) | The style applied to selected items.
Site (inherited from Control) | Site of the control.
Style (inherited from WebControl) | Low-level access to control styles.
TabIndex (inherited from WebControl) | The tab order of the control.
TemplateControl (inherited from Control) | The TemplateControl that hosts this control.
TemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
ToolTip (inherited from WebControl) | The tooltip displayed when the mouse is over the control.
UniqueID (inherited from Control) | The unique ID of the control within the page.
Visible (inherited from Control) | Indicates whether the control is visible and rendered.
Width (inherited from WebControl) | The width of the control.
Wrap (inherited from Panel) | Whether the content should wrap or not.

Public Events

DataBinding (inherited from Control) | Fires when the control's data binding expressions are to be evaluated.
Disposed (inherited from Control) | Fires when the control has been disposed.
Init (inherited from Control) | Fires when the page has been initialized.
Load (inherited from Control) | Fires when the page has been loaded.
PreRender (inherited from Control) | Fires before the page is rendered.
Unload (inherited from Control) | Fires when the page is unloaded.

Protected Properties

ViewState (inherited from Control)

Current viewstate of the control.

See Also


C1WebToolBarToggleGroupBase Properties

C1WebToolBarToggleGroupBase Properties

The properties of the C1WebToolBarToggleGroupBase class are listed here. For a complete list of C1WebToolBarToggleGroupBase class members, see the C1WebToolBarToggleGroupBase Members topic.

Public Properties

AccessKey (inherited from WebControl) | Keyboard shortcut used by the control.
AppRelativeTemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Attributes (inherited from WebControl) | Tag attributes of the control.
BackColor (inherited from WebControl) | Color of the background of the control.
BackImageUrl (inherited from Panel) | The background image of the panel.
BorderColor (inherited from WebControl) | Color of the border around the control.
BorderStyle (inherited from WebControl) | Style of the border around the control.
BorderWidth (inherited from WebControl) | Width of the border around the control.
ClientID (inherited from Control) | The ID of the control that is rendered for the client.
ControlStyle (inherited from WebControl) | The style associated with the control.
ControlStyleCreated (inherited from WebControl) | Whether the style associated with the control has been created.
CssClass (inherited from WebControl) | CSS Class name applied to the control.
DefaultButton (inherited from Panel) | The default button for the panel.
Direction (inherited from Panel) | The direction of text in the panel.
DisabledItemStyle (inherited from C1WebToolBarContainerBase) | The style applied to disabled items.
Enabled (inherited from WebControl) | Enabled state of the control.
EnableViewState (inherited from Control) | Whether the control automatically saves its state for use in round-trips.
Font (inherited from WebControl) | The font used for text within the control.
ForeColor (inherited from WebControl) | Color of the text within the control.
GroupingText (inherited from Panel) | The text of group box around this control's contents.
Height (inherited from WebControl) | The height of the control.
HorizontalAlign (inherited from Panel) | The horizontal alignment of the content.
HoverItemStyle (inherited from C1WebToolBarContainerBase) | The style applied to items when the mouse hovers over them.
ID (inherited from Control) | Programmatic name of the control.
ItemImageHeight (inherited from C1WebToolBarContainerBase) | Gets or sets the height of the item image.
ItemImageWidth (inherited from C1WebToolBarContainerBase) | Gets or sets the width of the item image.
ItemSpacing (inherited from C1WebToolBarContainerBase) | Gets or sets spacing between toolbar's border and button's border.
ItemStyle (inherited from C1WebToolBarContainerBase) | The style applied to items in this toolbar.
ItemTextSpacing (inherited from C1WebToolBarContainerBase) | Gets or sets spacing between buttons's border and buttons's text.
Layout (inherited from C1WebToolBarContainerBase) | Indicates whether to layout menu items vertically or horizontally.
LayoutActual (inherited from C1WebToolBarContainerBase) | Gets the actual menu layout.
NamingContainer (inherited from Control) | The containing control or page within which ID is unique.
Page (inherited from Control) | The page containing the control.
Parent (inherited from Control) | The control containing this control.
ScrollBars (inherited from Panel) | The appearance of scrollbars for the panel.
SelectedItemStyle (inherited from C1WebToolBarContainerBase) | The style applied to selected items.
Site (inherited from Control) | Site of the control.
Style (inherited from WebControl) | Low-level access to control styles.
TabIndex (inherited from WebControl) | The tab order of the control.
TemplateControl (inherited from Control) | The TemplateControl that hosts this control.
TemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
ToolTip (inherited from WebControl) | The tooltip displayed when the mouse is over the control.
UniqueID (inherited from Control) | The unique ID of the control within the page.
Visible (inherited from Control) | Indicates whether the control is visible and rendered.
Width (inherited from WebControl) | The width of the control.
Wrap (inherited from Panel) | Whether the content should wrap or not.

Protected Properties

ViewState (inherited from Control)

Current viewstate of the control.

See Also


C1WebToolBarToggleGroupBase Events

C1WebToolBarToggleGroupBase Events

The events of the C1WebToolBarToggleGroupBase class are listed here. For a complete list of C1WebToolBarToggleGroupBase class members, see the C1WebToolBarToggleGroupBase Members topic.

Public Events

DataBinding (inherited from Control) | Fires when the control's data binding expressions are to be evaluated.
Disposed (inherited from Control) | Fires when the control has been disposed.
Init (inherited from Control) | Fires when the page has been initialized.
Load (inherited from Control) | Fires when the page has been loaded.
PreRender (inherited from Control) | Fires before the page is rendered.
Unload (inherited from Control) | Fires when the page is unloaded.

See Also


C1WebTopicBar Class

C1WebTopicBar Class

Represents the TopicBar Web control.

For a list of all members of this type, see C1WebTopicBar Members.

System.Object

System.Web.UI.Control

System.Web.UI.WebControls.WebControl

C1.Web.C1Command.C1WebTopicBar

[Visual Basic]

Public Class C1WebTopicBar

Inherits WebControl

Implements IDisposable, IPostBackDataHandler, IPostBackEventHandler

[C#]

public class C1WebTopicBar : WebControl , IDisposable, IPostBackDataHandler, IPostBackEventHandler

[Delphi]

type C1WebTopicBar = class (WebControl, IDisposable, IPostBackDataHandler, IPostBackEventHandler);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1WebTopicBar Members

C1WebTopicBar Members

C1WebTopicBar overview

Public Constructors

C1WebTopicBar Constructor

Constructor. Initializes a new instance of the C1WebTopicBar class.

Public Properties

AccessKey (inherited from WebControl) | Keyboard shortcut used by the control.
AppRelativeTemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Attributes (inherited from WebControl) | Tag attributes of the control.
AutoCollapse | If enabled, contol will collapse all previously expanded groups except the one being expanded by user.
BackColor (inherited from WebControl) | Color of the background of the control.
BorderColor (inherited from WebControl) | Color of the border around the control.
BorderStyle (inherited from WebControl) | Style of the border around the control.
BorderWidth (inherited from WebControl) | Width of the border around the control.
CaptionImageHeight | Gets or sets the height of image set in the CaptionImageUrl property of header styles.
CaptionImageWidth | Gets or sets the width of image set in the CaptionImageUrl property of header styles.
CaptionLabelHorizontalAlign | Gets or sets the default value for the horizontal align of the labels in the headers.
CaptionLabelVerticalAlign | Gets or sets the default value for the vertical align of the labels in the headers.
ClientDir | Points to the directory which contains client script and images.
ClientID (inherited from Control) | The ID of the control that is rendered for the client.
CollapsedHeaderStyle | Default style for the group headers in the collapsed state
Controls (inherited from Control) | The collection of child controls owned by the control.
ControlStyle (inherited from WebControl) | The style associated with the control.
ControlStyleCreated (inherited from WebControl) | Whether the style associated with the control has been created.
CssClass (inherited from WebControl) | CSS Class name applied to the control.
DisabledGroupStyle | Default style for the disabled groups.
DisabledHeaderStyle | Default style for the group headers in the disabled state.
DisabledItemStyle | Default style for the items in the disabled state.
Enabled (inherited from WebControl) | Enabled state of the control.
EnableDragDrop | Determines whether user will be able to change group order by dragging its header to a desired position.
EnableViewState (inherited from Control) | Whether the control automatically saves its state for use in round-trips.
ExpandedHeaderStyle | Default style for the group headers in the expanded state.
Font (inherited from WebControl) | The font used for text within the control.
ForeColor (inherited from WebControl) | Color of the text within the control.
Groups | Returns collection of C1WebTopicBarCustomGroup objects.
GroupSpacing | Reads or writes spacing between groups.
GroupStyle | Default style for the groups.
Height (inherited from WebControl) | The height of the control.
ID (inherited from Control) | Programmatic name of the control.
ItemStyle | Default style for the items.
MouseOverCollapsedHeaderStyle | Default style for the group headers in the collapsed state when mouse hovers over them.
MouseOverExpandedHeaderStyle | Default style for the group headers in the expanded state when mouse hovers over them.
MouseOverItemStyle | Default style for the items when mouse hovers over them.
NamingContainer (inherited from Control) | The containing control or page within which ID is unique.
Page (inherited from Control) | The page containing the control.
Parent (inherited from Control) | The control containing this control.
PreloadImages | Specifies whether to preload images used in topicbar control.
SelectedItemStyle | Default style for the items in the selected state.
ShowGroupHeaders | Determines whether control will render its group headers or not.
Site (inherited from Control) | Site of the control.
Style (inherited from WebControl) | Low-level access to control styles.
TabIndex (inherited from WebControl) | The tab order of the control.
TemplateControl (inherited from Control) | The TemplateControl that hosts this control.
TemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
TextHeight | Gets or sets the height of the group header's text.
ToolTip (inherited from WebControl) | The tooltip displayed when the mouse is over the control.
UniqueID (inherited from Control) | The unique ID of the control within the page.
ViewStyle | Determines the look and behavior settings of the control (standard or button).
Visible (inherited from Control) | Indicates whether the control is visible and rendered.
Width (inherited from WebControl) | The width of the control.

Public Methods

Dispose | Overriden. Overrides Dispose.
LoadLayout | Overloaded. Load control layout properties from the stream.
LoadPostData | Handling client side post back.
RaisePostBackEvent | Implements IPostBackDataHandler.RaisePostBackEvent.
RaisePostDataChangedEvent | Implements IPostBackDataHandler.RaisePostDataChangedEvent.
SaveLayout | Overloaded. Saves control layout properties to the stream.

Public Events

DataBinding (inherited from Control) | Fires when the control's data binding expressions are to be evaluated.
Disposed (inherited from Control) | Fires when the control has been disposed.
GroupCollapsed | Fires after group has been collapsed.
GroupCollapsing | Fires before group collapsing.
GroupExpanded | Fires after group has been expanded.
GroupExpanding | Fires before group expanding.
Init (inherited from Control) | Fires when the page has been initialized.
ItemClick | Fires when an item is clicked.
ItemSelected | Fires when an item is selected.
Load (inherited from Control) | Fires when the page has been loaded.
PreRender (inherited from Control) | Fires before the page is rendered.
Unload (inherited from Control) | Fires when the page is unloaded.

Protected Properties

ViewState (inherited from Control)

Current viewstate of the control.

Protected Methods

AddAttributesToRender | Overriden. This member overrides WebControl.AddAttributesToRender.
CreateChildControls | Overriden. This member overrides Control.CreateChildControls.
LoadViewState | Overriden. This member overrides Control.LoadViewState.
OnInit | Overriden. This member overrides Control.OnInit.
OnPreRender | Overriden. This member overrides Control.OnPreRender.
Render | Overriden. This member overrides Control.Render.
SaveViewState | Overriden. This member overrides Control.SaveViewState.
TrackViewState | Overriden. This member overrides Control.TrackViewState.

See Also


C1WebTopicBar Constructor

C1WebTopicBar Constructor

Constructor. Initializes a new instance of the C1WebTopicBar class.

[Visual Basic]

Public Function New()

[C#]

public C1WebTopicBar()

[Delphi]

public constructor Create();

See Also


C1WebTopicBar Properties

C1WebTopicBar Properties

The properties of the C1WebTopicBar class are listed here. For a complete list of C1WebTopicBar class members, see the C1WebTopicBar Members topic.

Public Properties

AccessKey (inherited from WebControl) | Keyboard shortcut used by the control.
AppRelativeTemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Attributes (inherited from WebControl) | Tag attributes of the control.
AutoCollapse | If enabled, contol will collapse all previously expanded groups except the one being expanded by user.
BackColor (inherited from WebControl) | Color of the background of the control.
BorderColor (inherited from WebControl) | Color of the border around the control.
BorderStyle (inherited from WebControl) | Style of the border around the control.
BorderWidth (inherited from WebControl) | Width of the border around the control.
CaptionImageHeight | Gets or sets the height of image set in the CaptionImageUrl property of header styles.
CaptionImageWidth | Gets or sets the width of image set in the CaptionImageUrl property of header styles.
CaptionLabelHorizontalAlign | Gets or sets the default value for the horizontal align of the labels in the headers.
CaptionLabelVerticalAlign | Gets or sets the default value for the vertical align of the labels in the headers.
ClientDir | Points to the directory which contains client script and images.
ClientID (inherited from Control) | The ID of the control that is rendered for the client.
CollapsedHeaderStyle | Default style for the group headers in the collapsed state
Controls (inherited from Control) | The collection of child controls owned by the control.
ControlStyle (inherited from WebControl) | The style associated with the control.
ControlStyleCreated (inherited from WebControl) | Whether the style associated with the control has been created.
CssClass (inherited from WebControl) | CSS Class name applied to the control.
DisabledGroupStyle | Default style for the disabled groups.
DisabledHeaderStyle | Default style for the group headers in the disabled state.
DisabledItemStyle | Default style for the items in the disabled state.
Enabled (inherited from WebControl) | Enabled state of the control.
EnableDragDrop | Determines whether user will be able to change group order by dragging its header to a desired position.
EnableViewState (inherited from Control) | Whether the control automatically saves its state for use in round-trips.
ExpandedHeaderStyle | Default style for the group headers in the expanded state.
Font (inherited from WebControl) | The font used for text within the control.
ForeColor (inherited from WebControl) | Color of the text within the control.
Groups | Returns collection of C1WebTopicBarCustomGroup objects.
GroupSpacing | Reads or writes spacing between groups.
GroupStyle | Default style for the groups.
Height (inherited from WebControl) | The height of the control.
ID (inherited from Control) | Programmatic name of the control.
ItemStyle | Default style for the items.
MouseOverCollapsedHeaderStyle | Default style for the group headers in the collapsed state when mouse hovers over them.
MouseOverExpandedHeaderStyle | Default style for the group headers in the expanded state when mouse hovers over them.
MouseOverItemStyle | Default style for the items when mouse hovers over them.
NamingContainer (inherited from Control) | The containing control or page within which ID is unique.
Page (inherited from Control) | The page containing the control.
Parent (inherited from Control) | The control containing this control.
PreloadImages | Specifies whether to preload images used in topicbar control.
SelectedItemStyle | Default style for the items in the selected state.
ShowGroupHeaders | Determines whether control will render its group headers or not.
Site (inherited from Control) | Site of the control.
Style (inherited from WebControl) | Low-level access to control styles.
TabIndex (inherited from WebControl) | The tab order of the control.
TemplateControl (inherited from Control) | The TemplateControl that hosts this control.
TemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
TextHeight | Gets or sets the height of the group header's text.
ToolTip (inherited from WebControl) | The tooltip displayed when the mouse is over the control.
UniqueID (inherited from Control) | The unique ID of the control within the page.
ViewStyle | Determines the look and behavior settings of the control (standard or button).
Visible (inherited from Control) | Indicates whether the control is visible and rendered.
Width (inherited from WebControl) | The width of the control.

Protected Properties

ViewState (inherited from Control)

Current viewstate of the control.

See Also


C1WebTopicBar.AutoCollapse Property

C1WebTopicBar.AutoCollapse Property

If enabled, contol will collapse all previously expanded groups except the one being expanded by user.

[Visual Basic]

Public Property AutoCollapse As Boolean

[C#]

public bool AutoCollapse {get;set;}

[Delphi]

public property AutoCollapse: Boolean read get_AutoCollapse write set_AutoCollapse;

See Also


C1WebTopicBar.CaptionImageHeight Property

C1WebTopicBar.CaptionImageHeight Property

Gets or sets the height of image set in the CaptionImageUrl property of header styles.

[Visual Basic]

Public Property CaptionImageHeight As Unit

[C#]

public Unit CaptionImageHeight {get;set;}

[Delphi]

public property CaptionImageHeight: Unit read get_CaptionImageHeight write set_CaptionImageHeight;

Remarks

If property is not set then height will be calculated automatically (using physical dimensions of an image).

See Also


C1WebTopicBar.CaptionImageWidth Property

C1WebTopicBar.CaptionImageWidth Property

Gets or sets the width of image set in the CaptionImageUrl property of header styles.

[Visual Basic]

Public Property CaptionImageWidth As Unit

[C#]

public Unit CaptionImageWidth {get;set;}

[Delphi]

public property CaptionImageWidth: Unit read get_CaptionImageWidth write set_CaptionImageWidth;

Remarks

If property is not set then width will be calculated automatically (using physical dimensions of an image).

See Also


C1WebTopicBar.CaptionLabelHorizontalAlign Property

C1WebTopicBar.CaptionLabelHorizontalAlign Property

Gets or sets the default value for the horizontal align of the labels in the headers.

[Visual Basic]

Public Property CaptionLabelHorizontalAlign As HorizontalAlign

[C#]

public HorizontalAlign CaptionLabelHorizontalAlign {get;set;}

[Delphi]

public property CaptionLabelHorizontalAlign: HorizontalAlign read get_CaptionLabelHorizontalAlign write set_CaptionLabelHorizontalAlign;

See Also


C1WebTopicBar.CaptionLabelVerticalAlign Property

C1WebTopicBar.CaptionLabelVerticalAlign Property

Gets or sets the default value for the vertical align of the labels in the headers.

[Visual Basic]

Public Property CaptionLabelVerticalAlign As VerticalAlign

[C#]

public VerticalAlign CaptionLabelVerticalAlign {get;set;}

[Delphi]

public property CaptionLabelVerticalAlign: VerticalAlign read get_CaptionLabelVerticalAlign write set_CaptionLabelVerticalAlign;

See Also


C1WebTopicBar.ClientDir Property

C1WebTopicBar.ClientDir Property

Points to the directory which contains client script and images.

[Visual Basic]

Public Property ClientDir As String

[C#]

public string ClientDir {get;set;}

[Delphi]

public property ClientDir: String read get_ClientDir write set_ClientDir;

See Also


C1WebTopicBar.CollapsedHeaderStyle Property

C1WebTopicBar.CollapsedHeaderStyle Property

Default style for the group headers in the collapsed state

[Visual Basic]

Public ReadOnly Property CollapsedHeaderStyle As C1WebTopicBarHeaderStyle

[C#]

public C1WebTopicBarHeaderStyle CollapsedHeaderStyle {get;}

[Delphi]

public property CollapsedHeaderStyle: C1WebTopicBarHeaderStyle read get_CollapsedHeaderStyle;

Remarks

You can define the style individually for each group.

See Also


C1WebTopicBar.DisabledGroupStyle Property

C1WebTopicBar.DisabledGroupStyle Property

Default style for the disabled groups.

[Visual Basic]

Public ReadOnly Property DisabledGroupStyle As C1WebTopicBarGroupStyle

[C#]

public C1WebTopicBarGroupStyle DisabledGroupStyle {get;}

[Delphi]

public property DisabledGroupStyle: C1WebTopicBarGroupStyle read get_DisabledGroupStyle;

Remarks

You can define style individually for each group.

See Also


C1WebTopicBar.DisabledHeaderStyle Property

C1WebTopicBar.DisabledHeaderStyle Property

Default style for the group headers in the disabled state.

[Visual Basic]

Public ReadOnly Property DisabledHeaderStyle As C1WebTopicBarHeaderStyle

[C#]

public C1WebTopicBarHeaderStyle DisabledHeaderStyle {get;}

[Delphi]

public property DisabledHeaderStyle: C1WebTopicBarHeaderStyle read get_DisabledHeaderStyle;

Remarks

You can define the style individually for each group.

See Also


C1WebTopicBar.DisabledItemStyle Property

C1WebTopicBar.DisabledItemStyle Property

Default style for the items in the disabled state.

[Visual Basic]

Public ReadOnly Property DisabledItemStyle As C1WebTopicBarItemStyle

[C#]

public C1WebTopicBarItemStyle DisabledItemStyle {get;}

[Delphi]

public property DisabledItemStyle: C1WebTopicBarItemStyle read get_DisabledItemStyle;

Remarks

You can define style individually for each group and its items.

See Also


C1WebTopicBar.EnableDragDrop Property

C1WebTopicBar.EnableDragDrop Property

Determines whether user will be able to change group order by dragging its header to a desired position.

[Visual Basic]

Public Property EnableDragDrop As Boolean

[C#]

public bool EnableDragDrop {get;set;}

[Delphi]

public property EnableDragDrop: Boolean read get_EnableDragDrop write set_EnableDragDrop;

See Also


C1WebTopicBar.ExpandedHeaderStyle Property

C1WebTopicBar.ExpandedHeaderStyle Property

Default style for the group headers in the expanded state.

[Visual Basic]

Public ReadOnly Property ExpandedHeaderStyle As C1WebTopicBarHeaderStyle

[C#]

public C1WebTopicBarHeaderStyle ExpandedHeaderStyle {get;}

[Delphi]

public property ExpandedHeaderStyle: C1WebTopicBarHeaderStyle read get_ExpandedHeaderStyle;

Remarks

You can define the style individually for each group.

See Also


C1WebTopicBar.Groups Property

C1WebTopicBar.Groups Property

Returns collection of C1WebTopicBarCustomGroup objects.

[Visual Basic]

Public ReadOnly Property Groups As C1WebTopicBarGroupCollection

[C#]

public C1WebTopicBarGroupCollection Groups {get;}

[Delphi]

public property Groups: C1WebTopicBarGroupCollection read get_Groups;

See Also


C1WebTopicBar.GroupSpacing Property

C1WebTopicBar.GroupSpacing Property

Reads or writes spacing between groups.

[Visual Basic]

Public Property GroupSpacing As Unit

[C#]

public Unit GroupSpacing {get;set;}

[Delphi]

public property GroupSpacing: Unit read get_GroupSpacing write set_GroupSpacing;

See Also


C1WebTopicBar.GroupStyle Property

C1WebTopicBar.GroupStyle Property

Default style for the groups.

[Visual Basic]

Public ReadOnly Property GroupStyle As C1WebTopicBarGroupStyle

[C#]

public C1WebTopicBarGroupStyle GroupStyle {get;}

[Delphi]

public property GroupStyle: C1WebTopicBarGroupStyle read get_GroupStyle;

Remarks

You can define style individually for each group.

See Also


C1WebTopicBar.ItemStyle Property

C1WebTopicBar.ItemStyle Property

Default style for the items.

[Visual Basic]

Public ReadOnly Property ItemStyle As C1WebTopicBarItemStyle

[C#]

public C1WebTopicBarItemStyle ItemStyle {get;}

[Delphi]

public property ItemStyle: C1WebTopicBarItemStyle read get_ItemStyle;

Remarks

You can define style individually for each group and its items.

See Also


C1WebTopicBar.MouseOverCollapsedHeaderStyle Property

C1WebTopicBar.MouseOverCollapsedHeaderStyle Property

Default style for the group headers in the collapsed state when mouse hovers over them.

[Visual Basic]

Public ReadOnly Property MouseOverCollapsedHeaderStyle As C1WebTopicBarHeaderStyle

[C#]

public C1WebTopicBarHeaderStyle MouseOverCollapsedHeaderStyle {get;}

[Delphi]

public property MouseOverCollapsedHeaderStyle: C1WebTopicBarHeaderStyle read get_MouseOverCollapsedHeaderStyle;

Remarks

You can define the style individually for each group.

See Also


C1WebTopicBar.MouseOverExpandedHeaderStyle Property

C1WebTopicBar.MouseOverExpandedHeaderStyle Property

Default style for the group headers in the expanded state when mouse hovers over them.

[Visual Basic]

Public ReadOnly Property MouseOverExpandedHeaderStyle As C1WebTopicBarHeaderStyle

[C#]

public C1WebTopicBarHeaderStyle MouseOverExpandedHeaderStyle {get;}

[Delphi]

public property MouseOverExpandedHeaderStyle: C1WebTopicBarHeaderStyle read get_MouseOverExpandedHeaderStyle;

Remarks

You can define style individually for each group.

See Also


C1WebTopicBar.MouseOverItemStyle Property

C1WebTopicBar.MouseOverItemStyle Property

Default style for the items when mouse hovers over them.

[Visual Basic]

Public ReadOnly Property MouseOverItemStyle As C1WebTopicBarItemStyle

[C#]

public C1WebTopicBarItemStyle MouseOverItemStyle {get;}

[Delphi]

public property MouseOverItemStyle: C1WebTopicBarItemStyle read get_MouseOverItemStyle;

Remarks

You can define style individually for each group and its items.

See Also


C1WebTopicBar.PreloadImages Property

C1WebTopicBar.PreloadImages Property

Specifies whether to preload images used in topicbar control.

[Visual Basic]

Public Property PreloadImages As Boolean

[C#]

public bool PreloadImages {get;set;}

[Delphi]

public property PreloadImages: Boolean read get_PreloadImages write set_PreloadImages;

Remarks

Set value to false if you don't want to preload images.

See Also


C1WebTopicBar.SelectedItemStyle Property

C1WebTopicBar.SelectedItemStyle Property

Default style for the items in the selected state.

[Visual Basic]

Public ReadOnly Property SelectedItemStyle As C1WebTopicBarItemStyle

[C#]

public C1WebTopicBarItemStyle SelectedItemStyle {get;}

[Delphi]

public property SelectedItemStyle: C1WebTopicBarItemStyle read get_SelectedItemStyle;

Remarks

You can define style individually for each group and its items.

See Also


C1WebTopicBar.ShowGroupHeaders Property

C1WebTopicBar.ShowGroupHeaders Property

Determines whether control will render its group headers or not.

[Visual Basic]

Public Property ShowGroupHeaders As Boolean

[C#]

public bool ShowGroupHeaders {get;set;}

[Delphi]

public property ShowGroupHeaders: Boolean read get_ShowGroupHeaders write set_ShowGroupHeaders;

See Also


C1WebTopicBar.TextHeight Property

C1WebTopicBar.TextHeight Property

Gets or sets the height of the group header's text.

[Visual Basic]

Public Property TextHeight As Unit

[C#]

public Unit TextHeight {get;set;}

[Delphi]

public property TextHeight: Unit read get_TextHeight write set_TextHeight;

See Also


C1WebTopicBar.ViewStyle Property

C1WebTopicBar.ViewStyle Property

Determines the look and behavior settings of the control (standard or button).

[Visual Basic]

Public Property ViewStyle As PresentationEnum

[C#]

public PresentationEnum ViewStyle {get;set;}

[Delphi]

public property ViewStyle: PresentationEnum read get_ViewStyle write set_ViewStyle;

Remarks

If property is set to "Button" then the look of the control will be much like the Outlook panel.

See Also


C1WebTopicBar Methods

C1WebTopicBar Methods

The methods of the C1WebTopicBar class are listed here. For a complete list of C1WebTopicBar class members, see the C1WebTopicBar Members topic.

Public Methods

Dispose | Overriden. Overrides Dispose.
LoadLayout | Overloaded. Load control layout properties from the stream.
LoadPostData | Handling client side post back.
RaisePostBackEvent | Implements IPostBackDataHandler.RaisePostBackEvent.
RaisePostDataChangedEvent | Implements IPostBackDataHandler.RaisePostDataChangedEvent.
SaveLayout | Overloaded. Saves control layout properties to the stream.

Protected Methods

AddAttributesToRender | Overriden. This member overrides WebControl.AddAttributesToRender.
CreateChildControls | Overriden. This member overrides Control.CreateChildControls.
LoadViewState | Overriden. This member overrides Control.LoadViewState.
OnInit | Overriden. This member overrides Control.OnInit.
OnPreRender | Overriden. This member overrides Control.OnPreRender.
Render | Overriden. This member overrides Control.Render.
SaveViewState | Overriden. This member overrides Control.SaveViewState.
TrackViewState | Overriden. This member overrides Control.TrackViewState.

See Also


C1WebTopicBar.AddAttributesToRender Method

C1WebTopicBar.AddAttributesToRender Method

This member overrides WebControl.AddAttributesToRender.

[Visual Basic]

Overrides Protected Sub AddAttributesToRender( _

ByVal writer As HtmlTextWriter _

)

[C#]

override protected void AddAttributesToRender(

HtmlTextWriter writer

);

[Delphi]

strict protected procedure AddAttributesToRender(

writer: HtmlTextWriter

); override;

Parameters

writer

A System.Web.UI.HtmlTextWriter that represents the output stream to render HTML content on the client.

See Also


C1WebTopicBar.CreateChildControls Method

C1WebTopicBar.CreateChildControls Method

This member overrides Control.CreateChildControls.

[Visual Basic]

Overrides Protected Sub CreateChildControls()

[C#]

override protected void CreateChildControls()

[Delphi]

strict protected procedure CreateChildControls(); override;

See Also


C1WebTopicBar.Dispose Method

C1WebTopicBar.Dispose Method

Overrides Dispose.

[Visual Basic]

Overrides Public Sub Dispose() Implements IDisposable.Dispose

[C#]

override public void Dispose()

[Delphi]

public procedure Dispose(); override;

Implements

IDisposable.Dispose

See Also


C1WebTopicBar.LoadLayout Method

C1WebTopicBar.LoadLayout Method

Overload List

Load control layout properties from the stream.

[Visual Basic] Overloads Public Sub LoadLayout(Stream)

[C#] public void LoadLayout(Stream);

[Delphi] public procedure LoadLayout(Stream); overload;

Loads control layout properties from the file.

[Visual Basic] Overloads Public Sub LoadLayout(String)

[C#] public void LoadLayout(string);

[Delphi] public procedure LoadLayout(String); overload;

Loads control layout properties with specified types from the stream.

[Visual Basic] Overloads Public Sub LoadLayout(Stream, LayoutTypeFlags)

[C#] public void LoadLayout(Stream, LayoutTypeFlags);

[Delphi] public procedure LoadLayout(Stream; LayoutTypeFlags); overload;

Loads control layout properties with specified types from the file.

[Visual Basic] Overloads Public Sub LoadLayout(String, LayoutTypeFlags)

[C#] public void LoadLayout(string, LayoutTypeFlags);

[Delphi] public procedure LoadLayout(String; LayoutTypeFlags); overload;

See Also


C1WebTopicBar.LoadLayout Method (Stream)

C1WebTopicBar.LoadLayout Method (Stream)

Previous Next

Load control layout properties from the stream.

[Visual Basic]

Overloads Public Sub LoadLayout( _

ByVal stream As Stream _

)

[C#]

public void LoadLayout(

Stream stream

);

[Delphi]

public procedure LoadLayout(

stream: Stream

); overload;

Parameters

stream

stream from which the values of layout properties will be loaded

See Also


C1WebTopicBar.LoadLayout Method (String)

C1WebTopicBar.LoadLayout Method (String)

Previous Next

Loads control layout properties from the file.

[Visual Basic]

Overloads Public Sub LoadLayout( _

ByVal filename As String _

)

[C#]

public void LoadLayout(

string filename

);

[Delphi]

public procedure LoadLayout(

filename: String

); overload;

Parameters

filename

file from which the values of layout properties will be loaded

See Also


C1WebTopicBar.LoadLayout Method (Stream, LayoutTypeFlags)

C1WebTopicBar.LoadLayout Method (Stream, LayoutTypeFlags)

Previous Next

Loads control layout properties with specified types from the stream.

[Visual Basic]

Overloads Public Sub LoadLayout( _

ByVal stream As Stream, _

ByVal layoutTypes As LayoutTypeFlags _

)

[C#]

public void LoadLayout(

Stream stream,

LayoutTypeFlags layoutTypes

);

[Delphi]

public procedure LoadLayout(

stream: Stream;

layoutTypes: LayoutTypeFlags

); overload;

Parameters

stream

stream from which the values of layout properties will be loaded

layoutTypes

layout types to load

See Also


C1WebTopicBar.LoadLayout Method (String, LayoutTypeFlags)

C1WebTopicBar.LoadLayout Method (String, LayoutTypeFlags)

Previous Next

Loads control layout properties with specified types from the file.

[Visual Basic]

Overloads Public Sub LoadLayout( _

ByVal filename As String, _

ByVal layoutTypes As LayoutTypeFlags _

)

[C#]

public void LoadLayout(

string filename,

LayoutTypeFlags layoutTypes

);

[Delphi]

public procedure LoadLayout(

filename: String;

layoutTypes: LayoutTypeFlags

); overload;

Parameters

filename

file from which the values of layout properties will be loaded

layoutTypes

layout types to load

See Also


C1WebTopicBar.LoadPostData Method

C1WebTopicBar.LoadPostData Method

Handling client side post back.

[Visual Basic]

Overridable Public Function LoadPostData( _

ByVal postDataKey As String, _

ByVal values As NameValueCollection _

) As Boolean Implements IPostBackDataHandler.LoadPostData

[C#]

virtual public bool LoadPostData(

string postDataKey,

NameValueCollection values

);

[Delphi]

public function LoadPostData(

postDataKey: String;

values: NameValueCollection

): Boolean; virtual;

Implements

IPostBackDataHandler.LoadPostData

See Also


C1WebTopicBar.LoadViewState Method

C1WebTopicBar.LoadViewState Method

This member overrides Control.LoadViewState.

[Visual Basic]

Overrides Protected Sub LoadViewState( _

ByVal state As Object _

)

[C#]

override protected void LoadViewState(

object state

);

[Delphi]

strict protected procedure LoadViewState(

state: Object

); override;

See Also


C1WebTopicBar.OnInit Method

C1WebTopicBar.OnInit Method

This member overrides Control.OnInit.

[Visual Basic]

Overrides Protected Sub OnInit( _

ByVal e As EventArgs _

)

[C#]

override protected void OnInit(

EventArgs e

);

[Delphi]

strict protected procedure OnInit(

e: EventArgs

); override;

See Also


C1WebTopicBar.OnPreRender Method

C1WebTopicBar.OnPreRender Method

This member overrides Control.OnPreRender.

[Visual Basic]

Overrides Protected Sub OnPreRender( _

ByVal e As EventArgs _

)

[C#]

override protected void OnPreRender(

EventArgs e

);

[Delphi]

strict protected procedure OnPreRender(

e: EventArgs

); override;

See Also


C1WebTopicBar.RaisePostBackEvent Method

C1WebTopicBar.RaisePostBackEvent Method

Implements IPostBackDataHandler.RaisePostBackEvent.

[Visual Basic]

Overridable Public Sub RaisePostBackEvent( _

ByVal eventargs As String _

) Implements IPostBackEventHandler.RaisePostBackEvent

[C#]

virtual public void RaisePostBackEvent(

string eventargs

);

[Delphi]

public procedure RaisePostBackEvent(

eventargs: String

); virtual;

Implements

IPostBackEventHandler.RaisePostBackEvent

See Also


C1WebTopicBar.RaisePostDataChangedEvent Method

C1WebTopicBar.RaisePostDataChangedEvent Method

Implements IPostBackDataHandler.RaisePostDataChangedEvent.

[Visual Basic]

Overridable Public Sub RaisePostDataChangedEvent() Implements IPostBackDataHandler.RaisePostDataChangedEvent

[C#]

virtual public void RaisePostDataChangedEvent()

[Delphi]

public procedure RaisePostDataChangedEvent(); virtual;

Implements

IPostBackDataHandler.RaisePostDataChangedEvent

See Also


C1WebTopicBar.Render Method

C1WebTopicBar.Render Method

This member overrides Control.Render.

[Visual Basic]

Overrides Protected Sub Render( _

ByVal writer As HtmlTextWriter _

)

[C#]

override protected void Render(

HtmlTextWriter writer

);

[Delphi]

strict protected procedure Render(

writer: HtmlTextWriter

); override;

See Also


C1WebTopicBar.SaveLayout Method

C1WebTopicBar.SaveLayout Method

Overload List

Saves control layout properties to the stream.

[Visual Basic] Overloads Public Sub SaveLayout(Stream)

[C#] public void SaveLayout(Stream);

[Delphi] public procedure SaveLayout(Stream); overload;

Saves control layout properties to the file.

[Visual Basic] Overloads Public Sub SaveLayout(String)

[C#] public void SaveLayout(string);

[Delphi] public procedure SaveLayout(String); overload;

See Also


C1WebTopicBar.SaveLayout Method (Stream)

C1WebTopicBar.SaveLayout Method (Stream)

Previous Next

Saves control layout properties to the stream.

[Visual Basic]

Overloads Public Sub SaveLayout( _

ByVal stream As Stream _

)

[C#]

public void SaveLayout(

Stream stream

);

[Delphi]

public procedure SaveLayout(

stream: Stream

); overload;

Parameters

stream

stream to which the values of layout properties will be saved

See Also


C1WebTopicBar.SaveLayout Method (String)

C1WebTopicBar.SaveLayout Method (String)

Previous Next

Saves control layout properties to the file.

[Visual Basic]

Overloads Public Sub SaveLayout( _

ByVal filename As String _

)

[C#]

public void SaveLayout(

string filename

);

[Delphi]

public procedure SaveLayout(

filename: String

); overload;

Parameters

filename

file to which the values of layout properties will be saved

See Also


C1WebTopicBar.SaveViewState Method

C1WebTopicBar.SaveViewState Method

This member overrides Control.SaveViewState.

[Visual Basic]

Overrides Protected Function SaveViewState() As Object

[C#]

override protected object SaveViewState()

[Delphi]

strict protected function SaveViewState(): Object; override;

See Also


C1WebTopicBar.TrackViewState Method

C1WebTopicBar.TrackViewState Method

This member overrides Control.TrackViewState.

[Visual Basic]

Overrides Protected Sub TrackViewState()

[C#]

override protected void TrackViewState()

[Delphi]

strict protected procedure TrackViewState(); override;

See Also


C1WebTopicBar Events

C1WebTopicBar Events

The events of the C1WebTopicBar class are listed here. For a complete list of C1WebTopicBar class members, see the C1WebTopicBar Members topic.

Public Events

DataBinding (inherited from Control) | Fires when the control's data binding expressions are to be evaluated.
Disposed (inherited from Control) | Fires when the control has been disposed.
GroupCollapsed | Fires after group has been collapsed.
GroupCollapsing | Fires before group collapsing.
GroupExpanded | Fires after group has been expanded.
GroupExpanding | Fires before group expanding.
Init (inherited from Control) | Fires when the page has been initialized.
ItemClick | Fires when an item is clicked.
ItemSelected | Fires when an item is selected.
Load (inherited from Control) | Fires when the page has been loaded.
PreRender (inherited from Control) | Fires before the page is rendered.
Unload (inherited from Control) | Fires when the page is unloaded.

See Also


C1WebTopicBar.GroupCollapsed Event

C1WebTopicBar.GroupCollapsed Event

Fires after group has been collapsed.

[Visual Basic]

Public Event GroupCollapsed As C1WebTopicBarGroupEventHandler

[C#]

public event C1WebTopicBarGroupEventHandler GroupCollapsed

[Delphi]

public property GroupCollapsed: C1WebTopicBarGroupEventHandler read remove_GroupCollapsed write add_GroupCollapsed;

See Also


C1WebTopicBar.GroupCollapsing Event

C1WebTopicBar.GroupCollapsing Event

Fires before group collapsing.

[Visual Basic]

Public Event GroupCollapsing As C1WebTopicBarGroupBeforeEventHandler

[C#]

public event C1WebTopicBarGroupBeforeEventHandler GroupCollapsing

[Delphi]

public property GroupCollapsing: C1WebTopicBarGroupBeforeEventHandler read remove_GroupCollapsing write add_GroupCollapsing;

See Also


C1WebTopicBar.GroupExpanded Event

C1WebTopicBar.GroupExpanded Event

Fires after group has been expanded.

[Visual Basic]

Public Event GroupExpanded As C1WebTopicBarGroupEventHandler

[C#]

public event C1WebTopicBarGroupEventHandler GroupExpanded

[Delphi]

public property GroupExpanded: C1WebTopicBarGroupEventHandler read remove_GroupExpanded write add_GroupExpanded;

See Also


C1WebTopicBar.GroupExpanding Event

C1WebTopicBar.GroupExpanding Event

Fires before group expanding.

[Visual Basic]

Public Event GroupExpanding As C1WebTopicBarGroupBeforeEventHandler

[C#]

public event C1WebTopicBarGroupBeforeEventHandler GroupExpanding

[Delphi]

public property GroupExpanding: C1WebTopicBarGroupBeforeEventHandler read remove_GroupExpanding write add_GroupExpanding;

See Also


C1WebTopicBar.ItemClick Event

C1WebTopicBar.ItemClick Event

Fires when an item is clicked.

[Visual Basic]

Public Event ItemClick As C1WebTopicBarCommandEventHandler

[C#]

public event C1WebTopicBarCommandEventHandler ItemClick

[Delphi]

public property ItemClick: C1WebTopicBarCommandEventHandler read remove_ItemClick write add_ItemClick;

See Also


C1WebTopicBar.ItemSelected Event

C1WebTopicBar.ItemSelected Event

Fires when an item is selected.

[Visual Basic]

Public Event ItemSelected As C1WebTopicBarCommandEventHandler

[C#]

public event C1WebTopicBarCommandEventHandler ItemSelected

[Delphi]

public property ItemSelected: C1WebTopicBarCommandEventHandler read remove_ItemSelected write add_ItemSelected;

See Also


C1WebTopicBarCommandEventArgs Class

C1WebTopicBarCommandEventArgs Class

C1WebTopicBarCommandEventArgs use for the following events: C1WebTopicBar.ItemClick C1WebTopicBar.ItemSelected

For a list of all members of this type, see C1WebTopicBarCommandEventArgs Members.

System.Object

System.EventArgs

System.Web.UI.WebControls.CommandEventArgs

C1.Web.C1Command.C1WebTopicBarCommandEventArgs

[Visual Basic]

Public Class C1WebTopicBarCommandEventArgs

Inherits CommandEventArgs

[C#]

public class C1WebTopicBarCommandEventArgs : CommandEventArgs

[Delphi]

type C1WebTopicBarCommandEventArgs = class (CommandEventArgs);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1WebTopicBarCommandEventArgs Members

C1WebTopicBarCommandEventArgs Members

C1WebTopicBarCommandEventArgs overview

Public Properties

Group | Group in the C1WebTopicBar control which raised an event.
Item | Item in the C1WebTopicBar control which raised an event.

See Also


C1WebTopicBarCommandEventArgs Properties

C1WebTopicBarCommandEventArgs Properties

The properties of the C1WebTopicBarCommandEventArgs class are listed here. For a complete list of C1WebTopicBarCommandEventArgs class members, see the C1WebTopicBarCommandEventArgs Members topic.

Public Properties

Group | Group in the C1WebTopicBar control which raised an event.
Item | Item in the C1WebTopicBar control which raised an event.

See Also


C1WebTopicBarCommandEventArgs.Group Property

C1WebTopicBarCommandEventArgs.Group Property

Group in the C1WebTopicBar control which raised an event.

[Visual Basic]

Public ReadOnly Property Group As C1WebTopicBarCustomGroup

[C#]

public C1WebTopicBarCustomGroup Group {get;}

[Delphi]

public property Group: C1WebTopicBarCustomGroup read get_Group;

See Also


C1WebTopicBarCommandEventArgs.Item Property

C1WebTopicBarCommandEventArgs.Item Property

Item in the C1WebTopicBar control which raised an event.

[Visual Basic]

Public ReadOnly Property Item As C1WebTopicBarItem

[C#]

public C1WebTopicBarItem Item {get;}

[Delphi]

public property Item: C1WebTopicBarItem read get_Item;

See Also


C1WebTopicBarCommandEventHandler Delegate

C1WebTopicBarCommandEventHandler Delegate

Delegate type for handling events that are related to the items.

[Visual Basic]

Public Delegate Sub C1WebTopicBarCommandEventHandler( _

ByVal sender As Object, _

ByVal e As C1WebTopicBarCommandEventArgs _

)

[C#]

public delegate void C1WebTopicBarCommandEventHandler(

object sender,

C1WebTopicBarCommandEventArgs e

);

[Delphi]

type C1WebTopicBarCommandEventHandler = procedure (

sender: Object;

e: C1WebTopicBarCommandEventArgs

) of object;

Parameters

sender

The source of the event

e

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also

C1.Web.C1Command Namespace


C1WebTopicBarCustomGroup Class

C1WebTopicBarCustomGroup Class

Base class for the C1WebTopicBarItemsGroup and C1WebTopicBarPanelGroup classes.

For a list of all members of this type, see C1WebTopicBarCustomGroup Members.

System.Object

C1.Web.C1Command.C1WebTopicBarCustomGroup

C1.Web.C1Command.C1WebTopicBarItemsGroup

C1.Web.C1Command.C1WebTopicBarPanelGroup

[Visual Basic]

Public Class C1WebTopicBarCustomGroup

Implements IStateManager

[C#]

public class C1WebTopicBarCustomGroup : IStateManager

[Delphi]

type C1WebTopicBarCustomGroup = class (TObject, IStateManager);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1WebTopicBarCustomGroup Members

C1WebTopicBarCustomGroup Members

C1WebTopicBarCustomGroup overview

Public Constructors

C1WebTopicBarCustomGroup Constructor

Constructor. Initializes a new instance of the C1WebTopicBarCustomGroup class.

Public Properties

CaptionImageHeight | Gets or sets the height of image set in the CaptionImageUrl property of header styles.
CaptionImageWidth | Gets or sets the width of image set in the CaptionImageUrl property of header styles.
CaptionLabelHorizontalAlign | Gets or sets the value for the horizontal align of the labels in the headers.
CaptionLabelVerticalAlign | Gets or sets the value for the vertical align of the labels in the headers.
Collapsed | Gets or sets a value indicating whether the group collapsed or not.
CollapsedHeaderStyle | Style for the group header in the collapsed state.
DisabledGroupStyle | Style for the disabled group.
DisabledHeaderStyle | Style for the group header in the disabled state.
Enabled | Gets or sets a value indicating whether the group can respond to user interaction or not.
EnableExpandCollapse | Gets or sets a value indicating whether user can expand or collapse the group by double-clicking on header or clicking on the indicator image.
ExpandedHeaderStyle | Style for the group header in the expanded state.
GroupStyle | Style for the group.
MouseOverCollapsedHeaderStyle | Style for the group header in the collapsed state when the mouse hovers over them.
MouseOverExpandedHeaderStyle | Style for the group header in the expanded state when the mouse hovers over them.
Text | Gets or sets text that is displayed in the group header.
TextHeight | Gets or sets the height of the group header text.
ToolTip | Gets or sets the ToolTip text displayed when the mouse pointer rests over the group.
Visible | Gets or sets a value indicating whether the group visible or not.
WrapText | Gets or sets a value that indicates whether the text of the items is wrapped.

Public Methods

ToString

Overriden. Overrided for nice presentation in Groups collection editor.

Protected Properties

IsTrackingViewState | Indicates whether the server control is saving changes to its view state.
ViewState | View state for the group.

Protected Methods

LoadViewState | Loads view state in the group object.
MarkGroupTypeInViewState | Marks current group in view state. For internal use.
ProcessBody | Adds child controls to the group's body.
ProcessHeader | Adds child controls to the group's header.
SaveViewState | Saves view state and returns as object.
TrackViewState | Tracks view state.

See Also


C1WebTopicBarCustomGroup Constructor

C1WebTopicBarCustomGroup Constructor

Constructor. Initializes a new instance of the C1WebTopicBarCustomGroup class.

[Visual Basic]

Public Function New()

[C#]

public C1WebTopicBarCustomGroup()

[Delphi]

public constructor Create();

See Also


C1WebTopicBarCustomGroup Properties

C1WebTopicBarCustomGroup Properties

The properties of the C1WebTopicBarCustomGroup class are listed here. For a complete list of C1WebTopicBarCustomGroup class members, see the C1WebTopicBarCustomGroup Members topic.

Public Properties

CaptionImageHeight | Gets or sets the height of image set in the CaptionImageUrl property of header styles.
CaptionImageWidth | Gets or sets the width of image set in the CaptionImageUrl property of header styles.
CaptionLabelHorizontalAlign | Gets or sets the value for the horizontal align of the labels in the headers.
CaptionLabelVerticalAlign | Gets or sets the value for the vertical align of the labels in the headers.
Collapsed | Gets or sets a value indicating whether the group collapsed or not.
CollapsedHeaderStyle | Style for the group header in the collapsed state.
DisabledGroupStyle | Style for the disabled group.
DisabledHeaderStyle | Style for the group header in the disabled state.
Enabled | Gets or sets a value indicating whether the group can respond to user interaction or not.
EnableExpandCollapse | Gets or sets a value indicating whether user can expand or collapse the group by double-clicking on header or clicking on the indicator image.
ExpandedHeaderStyle | Style for the group header in the expanded state.
GroupStyle | Style for the group.
MouseOverCollapsedHeaderStyle | Style for the group header in the collapsed state when the mouse hovers over them.
MouseOverExpandedHeaderStyle | Style for the group header in the expanded state when the mouse hovers over them.
Text | Gets or sets text that is displayed in the group header.
TextHeight | Gets or sets the height of the group header text.
ToolTip | Gets or sets the ToolTip text displayed when the mouse pointer rests over the group.
Visible | Gets or sets a value indicating whether the group visible or not.
WrapText | Gets or sets a value that indicates whether the text of the items is wrapped.

Protected Properties

IsTrackingViewState | Indicates whether the server control is saving changes to its view state.
ViewState | View state for the group.

See Also


C1WebTopicBarCustomGroup.CaptionImageHeight Property

C1WebTopicBarCustomGroup.CaptionImageHeight Property

Gets or sets the height of image set in the CaptionImageUrl property of header styles.

[Visual Basic]

Public Property CaptionImageHeight As Unit

[C#]

public Unit CaptionImageHeight {get;set;}

[Delphi]

public property CaptionImageHeight: Unit read get_CaptionImageHeight write set_CaptionImageHeight;

Remarks

If property is not set then height will be calculated automatically (using physical dimensions of an image).

See Also


C1WebTopicBarCustomGroup.CaptionImageWidth Property

C1WebTopicBarCustomGroup.CaptionImageWidth Property

Gets or sets the width of image set in the CaptionImageUrl property of header styles.

[Visual Basic]

Public Property CaptionImageWidth As Unit

[C#]

public Unit CaptionImageWidth {get;set;}

[Delphi]

public property CaptionImageWidth: Unit read get_CaptionImageWidth write set_CaptionImageWidth;

Remarks

If property is not set then width will be calculated automatically (using physical dimensions of an image).

See Also


C1WebTopicBarCustomGroup.CaptionLabelHorizontalAlign Property

C1WebTopicBarCustomGroup.CaptionLabelHorizontalAlign Property

Previous Next

Gets or sets the value for the horizontal align of the labels in the headers.

[Visual Basic]

Public Property CaptionLabelHorizontalAlign As HorizontalAlign

[C#]

public HorizontalAlign CaptionLabelHorizontalAlign {get;set;}

[Delphi]

public property CaptionLabelHorizontalAlign: HorizontalAlign read get_CaptionLabelHorizontalAlign write set_CaptionLabelHorizontalAlign;

See Also


C1WebTopicBarCustomGroup.CaptionLabelVerticalAlign Property

C1WebTopicBarCustomGroup.CaptionLabelVerticalAlign Property

Gets or sets the value for the vertical align of the labels in the headers.

[Visual Basic]

Public Property CaptionLabelVerticalAlign As VerticalAlign

[C#]

public VerticalAlign CaptionLabelVerticalAlign {get;set;}

[Delphi]

public property CaptionLabelVerticalAlign: VerticalAlign read get_CaptionLabelVerticalAlign write set_CaptionLabelVerticalAlign;

See Also


C1WebTopicBarCustomGroup.Collapsed Property

C1WebTopicBarCustomGroup.Collapsed Property

Gets or sets a value indicating whether the group collapsed or not.

[Visual Basic]

Public Property Collapsed As Boolean

[C#]

public bool Collapsed {get;set;}

[Delphi]

public property Collapsed: Boolean read get_Collapsed write set_Collapsed;

See Also


C1WebTopicBarCustomGroup.CollapsedHeaderStyle Property

C1WebTopicBarCustomGroup.CollapsedHeaderStyle Property

Style for the group header in the collapsed state.

[Visual Basic]

Public ReadOnly Property CollapsedHeaderStyle As C1WebTopicBarHeaderStyle

[C#]

public C1WebTopicBarHeaderStyle CollapsedHeaderStyle {get;}

[Delphi]

public property CollapsedHeaderStyle: C1WebTopicBarHeaderStyle read get_CollapsedHeaderStyle;

See Also


C1WebTopicBarCustomGroup.DisabledGroupStyle Property

C1WebTopicBarCustomGroup.DisabledGroupStyle Property

Style for the disabled group.

[Visual Basic]

Public ReadOnly Property DisabledGroupStyle As C1WebTopicBarGroupStyle

[C#]

public C1WebTopicBarGroupStyle DisabledGroupStyle {get;}

[Delphi]

public property DisabledGroupStyle: C1WebTopicBarGroupStyle read get_DisabledGroupStyle;

See Also


C1WebTopicBarCustomGroup.DisabledHeaderStyle Property

C1WebTopicBarCustomGroup.DisabledHeaderStyle Property

Style for the group header in the disabled state.

[Visual Basic]

Public ReadOnly Property DisabledHeaderStyle As C1WebTopicBarHeaderStyle

[C#]

public C1WebTopicBarHeaderStyle DisabledHeaderStyle {get;}

[Delphi]

public property DisabledHeaderStyle: C1WebTopicBarHeaderStyle read get_DisabledHeaderStyle;

See Also


C1WebTopicBarCustomGroup.Enabled Property

C1WebTopicBarCustomGroup.Enabled Property

Gets or sets a value indicating whether the group can respond to user interaction or not.

[Visual Basic]

Public Property Enabled As Boolean

[C#]

public bool Enabled {get;set;}

[Delphi]

public property Enabled: Boolean read get_Enabled write set_Enabled;

See Also


C1WebTopicBarCustomGroup.EnableExpandCollapse Property

C1WebTopicBarCustomGroup.EnableExpandCollapse Property

Gets or sets a value indicating whether user can expand or collapse the group by double-clicking on header or clicking on the indicator image.

[Visual Basic]

Public Property EnableExpandCollapse As Boolean

[C#]

public bool EnableExpandCollapse {get;set;}

[Delphi]

public property EnableExpandCollapse: Boolean read get_EnableExpandCollapse write set_EnableExpandCollapse;

See Also


C1WebTopicBarCustomGroup.ExpandedHeaderStyle Property

C1WebTopicBarCustomGroup.ExpandedHeaderStyle Property

Style for the group header in the expanded state.

[Visual Basic]

Public ReadOnly Property ExpandedHeaderStyle As C1WebTopicBarHeaderStyle

[C#]

public C1WebTopicBarHeaderStyle ExpandedHeaderStyle {get;}

[Delphi]

public property ExpandedHeaderStyle: C1WebTopicBarHeaderStyle read get_ExpandedHeaderStyle;

See Also


C1WebTopicBarCustomGroup.GroupStyle Property

C1WebTopicBarCustomGroup.GroupStyle Property

Style for the group.

[Visual Basic]

Public ReadOnly Property GroupStyle As C1WebTopicBarGroupStyle

[C#]

public C1WebTopicBarGroupStyle GroupStyle {get;}

[Delphi]

public property GroupStyle: C1WebTopicBarGroupStyle read get_GroupStyle;

See Also


C1WebTopicBarCustomGroup.IsTrackingViewState Property

C1WebTopicBarCustomGroup.IsTrackingViewState Property

Indicates whether the server control is saving changes to its view state.

[Visual Basic]

Protected ReadOnly Property IsTrackingViewState As Boolean

[C#]

protected bool IsTrackingViewState {get;}

[Delphi]

strict protected property IsTrackingViewState: Boolean read get_IsTrackingViewState;

See Also


C1WebTopicBarCustomGroup.MouseOverCollapsedHeaderStyle Property

C1WebTopicBarCustomGroup.MouseOverCollapsedHeaderStyle Property

Previous Next

Style for the group header in the collapsed state when the mouse hovers over them.

[Visual Basic]

Public ReadOnly Property MouseOverCollapsedHeaderStyle As C1WebTopicBarHeaderStyle

[C#]

public C1WebTopicBarHeaderStyle MouseOverCollapsedHeaderStyle {get;}

[Delphi]

public property MouseOverCollapsedHeaderStyle: C1WebTopicBarHeaderStyle read get_MouseOverCollapsedHeaderStyle;

See Also


C1WebTopicBarCustomGroup.MouseOverExpandedHeaderStyle Property

C1WebTopicBarCustomGroup.MouseOverExpandedHeaderStyle Property

Previous Next

Style for the group header in the expanded state when the mouse hovers over them.

[Visual Basic]

Public ReadOnly Property MouseOverExpandedHeaderStyle As C1WebTopicBarHeaderStyle

[C#]

public C1WebTopicBarHeaderStyle MouseOverExpandedHeaderStyle {get;}

[Delphi]

public property MouseOverExpandedHeaderStyle: C1WebTopicBarHeaderStyle read get_MouseOverExpandedHeaderStyle;

See Also


C1WebTopicBarCustomGroup.Text Property

C1WebTopicBarCustomGroup.Text Property

Gets or sets text that is displayed in the group header.

[Visual Basic]

Public Property Text As String

[C#]

public string Text {get;set;}

[Delphi]

public property Text: String read get_Text write set_Text;

See Also


C1WebTopicBarCustomGroup.TextHeight Property

C1WebTopicBarCustomGroup.TextHeight Property

Gets or sets the height of the group header text.

[Visual Basic]

Public Property TextHeight As Unit

[C#]

public Unit TextHeight {get;set;}

[Delphi]

public property TextHeight: Unit read get_TextHeight write set_TextHeight;

See Also


C1WebTopicBarCustomGroup.ToolTip Property

C1WebTopicBarCustomGroup.ToolTip Property

Gets or sets the ToolTip text displayed when the mouse pointer rests over the group.

[Visual Basic]

Public Property ToolTip As String

[C#]

public string ToolTip {get;set;}

[Delphi]

public property ToolTip: String read get_ToolTip write set_ToolTip;

See Also


C1WebTopicBarCustomGroup.ViewState Property

C1WebTopicBarCustomGroup.ViewState Property

View state for the group.

[Visual Basic]

Protected ReadOnly Property ViewState As StateBag

[C#]

protected StateBag ViewState {get;}

[Delphi]

strict protected property ViewState: StateBag read get_ViewState;

See Also


C1WebTopicBarCustomGroup.Visible Property

C1WebTopicBarCustomGroup.Visible Property

Gets or sets a value indicating whether the group visible or not.

[Visual Basic]

Public Property Visible As Boolean

[C#]

public bool Visible {get;set;}

[Delphi]

public property Visible: Boolean read get_Visible write set_Visible;

See Also


C1WebTopicBarCustomGroup.WrapText Property

C1WebTopicBarCustomGroup.WrapText Property

Gets or sets a value that indicates whether the text of the items is wrapped.

[Visual Basic]

Public Property WrapText As Boolean

[C#]

public bool WrapText {get;set;}

[Delphi]

public property WrapText: Boolean read get_WrapText write set_WrapText;

See Also


C1WebTopicBarCustomGroup Methods

C1WebTopicBarCustomGroup Methods

The methods of the C1WebTopicBarCustomGroup class are listed here. For a complete list of C1WebTopicBarCustomGroup class members, see the C1WebTopicBarCustomGroup Members topic.

Public Methods

ToString

Overriden. Overrided for nice presentation in Groups collection editor.

Protected Methods

LoadViewState | Loads view state in the group object.
MarkGroupTypeInViewState | Marks current group in view state. For internal use.
ProcessBody | Adds child controls to the group's body.
ProcessHeader | Adds child controls to the group's header.
SaveViewState | Saves view state and returns as object.
TrackViewState | Tracks view state.

See Also


C1WebTopicBarCustomGroup.LoadViewState Method

C1WebTopicBarCustomGroup.LoadViewState Method

Loads view state in the group object.

[Visual Basic]

Overridable Protected Sub LoadViewState( _

ByVal state As Object _

) Implements IStateManager.LoadViewState

[C#]

virtual protected void LoadViewState(

object state

);

[Delphi]

strict protected procedure LoadViewState(

state: Object

); virtual;

Implements

IStateManager.LoadViewState

Parameters

state

View state ot load.

See Also


C1WebTopicBarCustomGroup.MarkGroupTypeInViewState Method

C1WebTopicBarCustomGroup.MarkGroupTypeInViewState Method

Marks current group in view state. For internal use.

[Visual Basic]

Protected Sub MarkGroupTypeInViewState()

[C#]

protected void MarkGroupTypeInViewState()

[Delphi]

strict protected procedure MarkGroupTypeInViewState();

See Also


C1WebTopicBarCustomGroup.ProcessBody Method

C1WebTopicBarCustomGroup.ProcessBody Method

Adds child controls to the group's body.

[Visual Basic]

Overridable Protected Sub ProcessBody( _

ByVal cell As TableCell _

)

[C#]

virtual protected void ProcessBody(

TableCell cell

);

[Delphi]

strict protected procedure ProcessBody(

cell: TableCell

); virtual;

See Also


C1WebTopicBarCustomGroup.ProcessHeader Method

C1WebTopicBarCustomGroup.ProcessHeader Method

Adds child controls to the group's header.

[Visual Basic]

Overridable Protected Function ProcessHeader( _

ByVal cell As TableCell _

) As Table

[C#]

virtual protected Table ProcessHeader(

TableCell cell

);

[Delphi]

strict protected function ProcessHeader(

cell: TableCell

): Table; virtual;

See Also


C1WebTopicBarCustomGroup.SaveViewState Method

C1WebTopicBarCustomGroup.SaveViewState Method

Saves view state and returns as object.

[Visual Basic]

Overridable Protected Function SaveViewState() As Object Implements IStateManager.SaveViewState

[C#]

virtual protected object SaveViewState()

[Delphi]

strict protected function SaveViewState(): Object; virtual;

Implements

IStateManager.SaveViewState

Return Value

Saved view state.

See Also


C1WebTopicBarCustomGroup.ToString Method

C1WebTopicBarCustomGroup.ToString Method

Overrided for nice presentation in Groups collection editor.

[Visual Basic]

Overrides Public Function ToString() As String

[C#]

override public string ToString()

[Delphi]

public function ToString(): String; override;

See Also


C1WebTopicBarCustomGroup.TrackViewState Method

C1WebTopicBarCustomGroup.TrackViewState Method

Tracks view state.

[Visual Basic]

Overridable Protected Sub TrackViewState() Implements IStateManager.TrackViewState

[C#]

virtual protected void TrackViewState()

[Delphi]

strict protected procedure TrackViewState(); virtual;

Implements

IStateManager.TrackViewState

See Also


C1WebTopicBarGroupBeforeEventArgs Class

C1WebTopicBarGroupBeforeEventArgs Class

C1WebTopicBarGroupBeforeEventHandler use for the following events: C1WebTopicBar.GroupCollapsing C1WebTopicBar.GroupExpanding

For a list of all members of this type, see C1WebTopicBarGroupBeforeEventArgs Members.

System.Object

System.EventArgs

System.ComponentModel.CancelEventArgs

C1.Web.C1Command.C1WebTopicBarGroupBeforeEventArgs

[Visual Basic]

Public Class C1WebTopicBarGroupBeforeEventArgs

Inherits CancelEventArgs

[C#]

public class C1WebTopicBarGroupBeforeEventArgs : CancelEventArgs

[Delphi]

type C1WebTopicBarGroupBeforeEventArgs = class (CancelEventArgs);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1WebTopicBarGroupBeforeEventArgs Members

C1WebTopicBarGroupBeforeEventArgs Members

C1WebTopicBarGroupBeforeEventArgs overview

Public Properties

Group

C1WebTopicBar group that raised an event.

See Also


C1WebTopicBarGroupBeforeEventArgs Properties

C1WebTopicBarGroupBeforeEventArgs Properties

The properties of the C1WebTopicBarGroupBeforeEventArgs class are listed here. For a complete list of C1WebTopicBarGroupBeforeEventArgs class members, see the C1WebTopicBarGroupBeforeEventArgs Members topic.

Public Properties

Group

C1WebTopicBar group that raised an event.

See Also


C1WebTopicBarGroupBeforeEventArgs.Group Property

C1WebTopicBarGroupBeforeEventArgs.Group Property

C1WebTopicBar group that raised an event.

[Visual Basic]

Public ReadOnly Property Group As C1WebTopicBarCustomGroup

[C#]

public C1WebTopicBarCustomGroup Group {get;}

[Delphi]

public property Group: C1WebTopicBarCustomGroup read get_Group;

See Also


C1WebTopicBarGroupBeforeEventHandler Delegate

C1WebTopicBarGroupBeforeEventHandler Delegate

Delegate type for handling cancellable events that are related to the groups.

[Visual Basic]

Public Delegate Sub C1WebTopicBarGroupBeforeEventHandler( _

ByVal sender As Object, _

ByVal e As C1WebTopicBarGroupBeforeEventArgs _

)

[C#]

public delegate void C1WebTopicBarGroupBeforeEventHandler(

object sender,

C1WebTopicBarGroupBeforeEventArgs e

);

[Delphi]

type C1WebTopicBarGroupBeforeEventHandler = procedure (

sender: Object;

e: C1WebTopicBarGroupBeforeEventArgs

) of object;

Parameters

sender

The source of the event

e

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also

C1.Web.C1Command Namespace


C1WebTopicBarGroupCollection Class

C1WebTopicBarGroupCollection Class

Contains the values of a C1WebTopicBar.Groups property.

For a list of all members of this type, see C1WebTopicBarGroupCollection Members.

System.Object

System.Collections.CollectionBase

C1.Web.C1Command.C1WebTopicBarGroupCollection

[Visual Basic]

Public Class C1WebTopicBarGroupCollection

Inherits CollectionBase

Implements IStateManager

[C#]

public class C1WebTopicBarGroupCollection : CollectionBase , IStateManager

[Delphi]

type C1WebTopicBarGroupCollection = class (CollectionBase, IStateManager);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1WebTopicBarGroupCollection Members

C1WebTopicBarGroupCollection Members

C1WebTopicBarGroupCollection overview

Public Constructors

C1WebTopicBarGroupCollection Constructor

Constructor. Initializes a new instance of the C1WebTopicBarGroupCollection class.

Public Properties

Item

Indexer (Item property in VB). Gets or sets the group that is located at a specified index of the collection.

Public Methods

Add | Appends a group to the collection.
Contains | Determines whether the specifed group is in the collection.
IndexOf | Searches for the specified group and returns the zero-based index of the first occurrence within the collection.
Insert | Inserts a group into the collection at the specified index.

See Also


C1WebTopicBarGroupCollection Constructor

C1WebTopicBarGroupCollection Constructor

Constructor. Initializes a new instance of the C1WebTopicBarGroupCollection class.

[Visual Basic]

Public Function New( _

ByVal owner As C1WebTopicBar _

)

[C#]

public C1WebTopicBarGroupCollection(

C1WebTopicBar owner

);

[Delphi]

public constructor Create(

owner: C1WebTopicBar

);

Parameters

owner

C1WebTopicBar instance

See Also


C1WebTopicBarGroupCollection Properties

C1WebTopicBarGroupCollection Properties

The properties of the C1WebTopicBarGroupCollection class are listed here. For a complete list of C1WebTopicBarGroupCollection class members, see the C1WebTopicBarGroupCollection Members topic.

Public Properties

Item

Indexer (Item property in VB). Gets or sets the group that is located at a specified index of the collection.

See Also


C1WebTopicBarGroupCollection.Item Property

C1WebTopicBarGroupCollection.Item Property

Indexer (Item property in VB). Gets or sets the group that is located at a specified index of the collection.

[Visual Basic]

Public Default Property Item( _

ByVal index As Integer _

) As C1WebTopicBarCustomGroup

[C#]

public C1WebTopicBarCustomGroup this[

int index

] {get;set;}

[Delphi]

public property Item[

index: Int32

]: C1WebTopicBarCustomGroup read get_Item write set_Item;

Parameters

index

The zero-based index of the group.

See Also


C1WebTopicBarGroupCollection Methods

C1WebTopicBarGroupCollection Methods

The methods of the C1WebTopicBarGroupCollection class are listed here. For a complete list of C1WebTopicBarGroupCollection class members, see the C1WebTopicBarGroupCollection Members topic.

Public Methods

Add | Appends a group to the collection.
Contains | Determines whether the specifed group is in the collection.
IndexOf | Searches for the specified group and returns the zero-based index of the first occurrence within the collection.
Insert | Inserts a group into the collection at the specified index.

See Also


C1WebTopicBarGroupCollection.Add Method

C1WebTopicBarGroupCollection.Add Method

Appends a group to the collection.

[Visual Basic]

Public Sub Add( _

ByVal value As C1WebTopicBarCustomGroup _

)

[C#]

public void Add(

C1WebTopicBarCustomGroup value

);

[Delphi]

public procedure Add(

value: C1WebTopicBarCustomGroup

);

Parameters

value

The group to add

See Also


C1WebTopicBarGroupCollection.Contains Method

C1WebTopicBarGroupCollection.Contains Method

Determines whether the specifed group is in the collection.

[Visual Basic]

Public Function Contains( _

ByVal value As C1WebTopicBarCustomGroup _

) As Boolean

[C#]

public bool Contains(

C1WebTopicBarCustomGroup value

);

[Delphi]

public function Contains(

value: C1WebTopicBarCustomGroup

): Boolean;

Parameters

value

The group to locate in the collection

Return Value

true if value is found in the collection; otherwise, false

See Also


C1WebTopicBarGroupCollection.IndexOf Method

C1WebTopicBarGroupCollection.IndexOf Method

Searches for the specified group and returns the zero-based index of the first occurrence within the collection.

[Visual Basic]

Public Function IndexOf( _

ByVal value As C1WebTopicBarCustomGroup _

) As Integer

[C#]

public int IndexOf(

C1WebTopicBarCustomGroup value

);

[Delphi]

public function IndexOf(

value: C1WebTopicBarCustomGroup

): Int32;

Parameters

value

The group to locate in the collection.

Return Value

The zero-based index of the first occurrence of group in the collection, if found; otherwise, -1.

See Also


C1WebTopicBarGroupCollection.Insert Method

C1WebTopicBarGroupCollection.Insert Method

Inserts a group into the collection at the specified index.

[Visual Basic]

Public Sub Insert( _

ByVal index As Integer, _

ByVal value As C1WebTopicBarCustomGroup _

)

[C#]

public void Insert(

int index,

C1WebTopicBarCustomGroup value

);

[Delphi]

public procedure Insert(

index: Int32;

value: C1WebTopicBarCustomGroup

);

Parameters

index

The zero-based index at which group is inserted

value

The group to insert

See Also


C1WebTopicBarGroupEventArgs Class

C1WebTopicBarGroupEventArgs Class

C1WebTopicBarGroupEventArgs use for the following events: C1WebTopicBar.GroupCollapsed C1WebTopicBar.GroupExpanded

For a list of all members of this type, see C1WebTopicBarGroupEventArgs Members.

System.Object

System.EventArgs

C1.Web.C1Command.C1WebTopicBarGroupEventArgs

[Visual Basic]

Public Class C1WebTopicBarGroupEventArgs

Inherits EventArgs

[C#]

public class C1WebTopicBarGroupEventArgs : EventArgs

[Delphi]

type C1WebTopicBarGroupEventArgs = class (EventArgs);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1WebTopicBarGroupEventArgs Members

C1WebTopicBarGroupEventArgs Members

C1WebTopicBarGroupEventArgs overview

Public Properties

Group

C1WebTopicBar group that raised an event.

See Also


C1WebTopicBarGroupEventArgs Properties

C1WebTopicBarGroupEventArgs Properties

The properties of the C1WebTopicBarGroupEventArgs class are listed here. For a complete list of C1WebTopicBarGroupEventArgs class members, see the C1WebTopicBarGroupEventArgs Members topic.

Public Properties

Group

C1WebTopicBar group that raised an event.

See Also


C1WebTopicBarGroupEventArgs.Group Property

C1WebTopicBarGroupEventArgs.Group Property

C1WebTopicBar group that raised an event.

[Visual Basic]

Public ReadOnly Property Group As C1WebTopicBarCustomGroup

[C#]

public C1WebTopicBarCustomGroup Group {get;}

[Delphi]

public property Group: C1WebTopicBarCustomGroup read get_Group;

See Also


C1WebTopicBarGroupEventHandler Delegate

C1WebTopicBarGroupEventHandler Delegate

Delegate type for handling events that are related to the groups.

[Visual Basic]

Public Delegate Sub C1WebTopicBarGroupEventHandler( _

ByVal sender As Object, _

ByVal e As C1WebTopicBarGroupEventArgs _

)

[C#]

public delegate void C1WebTopicBarGroupEventHandler(

object sender,

C1WebTopicBarGroupEventArgs e

);

[Delphi]

type C1WebTopicBarGroupEventHandler = procedure (

sender: Object;

e: C1WebTopicBarGroupEventArgs

) of object;

Parameters

sender

The source of the event.

e

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also

C1.Web.C1Command Namespace


C1WebTopicBarGroupStyle Class

C1WebTopicBarGroupStyle Class

Represents the style for a topicbar group.

For a list of all members of this type, see C1WebTopicBarGroupStyle Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Web.UI.WebControls.Style

C1.Web.C1Command.C1WebTopicBarStyle

C1.Web.C1Command.C1WebTopicBarGroupStyle

[Visual Basic]

Public Class C1WebTopicBarGroupStyle

Inherits C1WebTopicBarStyle

[C#]

public class C1WebTopicBarGroupStyle : C1WebTopicBarStyle

[Delphi]

type C1WebTopicBarGroupStyle = class (C1WebTopicBarStyle);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1WebTopicBarGroupStyle Members

C1WebTopicBarGroupStyle Members

C1WebTopicBarGroupStyle overview

Public Constructors

C1WebTopicBarGroupStyle Constructor

Constructor. Initializes a new instance of the C1WebTopicBarGroupStyle class.

Public Properties

BackColor (inherited from Style) | Background color of the controls applied with this style.
BackgroundImageUrl | Gets or sets the background image displayed in the header.
BorderColor (inherited from Style) | Border color of the controls applied with this style.
BorderStyle (inherited from Style) | Style of the border of controls applied with this style.
BorderWidth (inherited from Style) | Thickness of the border around the controls applied with this style.
CssClass (inherited from Style) | CSS class name applied to the user of this style.
Font (inherited from Style) | The font used for text in controls applied with this style.
ForeColor (inherited from Style) | Foreground color of the controls applied with this style.
IsEmpty (inherited from Style) | Overrides C1WebTopicBarStyle.IsEmpty.
ItemSpacing | Gets or sets space between items and group body borders.

Public Methods

AddAttributesToRender | Overloaded. Overriden. Overrides C1WebTopicBarStyle.AddAttributesToRender
CopyFrom | Overriden. Overrides Style.CopyFrom.
MergeWith | Overriden. Overrides Style.MergeWith.

See Also


C1WebTopicBarGroupStyle Constructor

C1WebTopicBarGroupStyle Constructor

Constructor. Initializes a new instance of the C1WebTopicBarGroupStyle class.

[Visual Basic]

Public Function New( _

ByVal owner As WebControl _

)

[C#]

public C1WebTopicBarGroupStyle(

WebControl owner

);

[Delphi]

public constructor Create(

owner: WebControl

);

Parameters

owner

The WebControl object to which the C1WebTopicBarGroupStyle object belongs

See Also


C1WebTopicBarGroupStyle Properties

C1WebTopicBarGroupStyle Properties

The properties of the C1WebTopicBarGroupStyle class are listed here. For a complete list of C1WebTopicBarGroupStyle class members, see the C1WebTopicBarGroupStyle Members topic.

Public Properties

BackColor (inherited from Style) | Background color of the controls applied with this style.
BackgroundImageUrl | Gets or sets the background image displayed in the header.
BorderColor (inherited from Style) | Border color of the controls applied with this style.
BorderStyle (inherited from Style) | Style of the border of controls applied with this style.
BorderWidth (inherited from Style) | Thickness of the border around the controls applied with this style.
CssClass (inherited from Style) | CSS class name applied to the user of this style.
Font (inherited from Style) | The font used for text in controls applied with this style.
ForeColor (inherited from Style) | Foreground color of the controls applied with this style.
IsEmpty (inherited from Style) | Overrides C1WebTopicBarStyle.IsEmpty.
ItemSpacing | Gets or sets space between items and group body borders.

See Also


C1WebTopicBarGroupStyle.BackgroundImageUrl Property

C1WebTopicBarGroupStyle.BackgroundImageUrl Property

Gets or sets the background image displayed in the header.

[Visual Basic]

Public Property BackgroundImageUrl As String

[C#]

public string BackgroundImageUrl {get;set;}

[Delphi]

public property BackgroundImageUrl: String read get_BackgroundImageUrl write set_BackgroundImageUrl;

See Also


C1WebTopicBarGroupStyle.ItemSpacing Property

C1WebTopicBarGroupStyle.ItemSpacing Property

Gets or sets space between items and group body borders.

[Visual Basic]

Public Property ItemSpacing As Unit

[C#]

public Unit ItemSpacing {get;set;}

[Delphi]

public property ItemSpacing: Unit read get_ItemSpacing write set_ItemSpacing;

See Also


C1WebTopicBarGroupStyle Methods

C1WebTopicBarGroupStyle Methods

The methods of the C1WebTopicBarGroupStyle class are listed here. For a complete list of C1WebTopicBarGroupStyle class members, see the C1WebTopicBarGroupStyle Members topic.

Public Methods

AddAttributesToRender | Overloaded. Overriden. Overrides C1WebTopicBarStyle.AddAttributesToRender
CopyFrom | Overriden. Overrides Style.CopyFrom.
MergeWith | Overriden. Overrides Style.MergeWith.

See Also


C1WebTopicBarGroupStyle.AddAttributesToRender Method

C1WebTopicBarGroupStyle.AddAttributesToRender Method

Overrides C1WebTopicBarStyle.AddAttributesToRender

[Visual Basic]

Overrides Public Sub AddAttributesToRender( _

ByVal writer As HtmlTextWriter, _

ByVal owner As WebControl _

)

[C#]

override public void AddAttributesToRender(

HtmlTextWriter writer,

WebControl owner

);

[Delphi]

public procedure AddAttributesToRender(

writer: HtmlTextWriter;

owner: WebControl

); overload; override;

See Also


C1WebTopicBarGroupStyle.CopyFrom Method

C1WebTopicBarGroupStyle.CopyFrom Method

Overrides Style.CopyFrom.

[Visual Basic]

Overrides Public Sub CopyFrom( _

ByVal style As Style _

)

[C#]

override public void CopyFrom(

Style style

);

[Delphi]

public procedure CopyFrom(

style: Style

); override;

See Also


C1WebTopicBarGroupStyle.MergeWith Method

C1WebTopicBarGroupStyle.MergeWith Method

Overrides Style.MergeWith.

[Visual Basic]

Overrides Public Sub MergeWith( _

ByVal style As Style _

)

[C#]

override public void MergeWith(

Style style

);

[Delphi]

public procedure MergeWith(

style: Style

); override;

See Also


C1WebTopicBarHeaderStyle Class

C1WebTopicBarHeaderStyle Class

Represents the style for a topic bar's header.

For a list of all members of this type, see C1WebTopicBarHeaderStyle Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Web.UI.WebControls.Style

C1.Web.C1Command.C1WebTopicBarStyle

C1.Web.C1Command.C1WebTopicBarHeaderStyle

[Visual Basic]

Public Class C1WebTopicBarHeaderStyle

Inherits C1WebTopicBarStyle

[C#]

public class C1WebTopicBarHeaderStyle : C1WebTopicBarStyle

[Delphi]

type C1WebTopicBarHeaderStyle = class (C1WebTopicBarStyle);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1WebTopicBarHeaderStyle Members

C1WebTopicBarHeaderStyle Members

C1WebTopicBarHeaderStyle overview

Public Constructors

C1WebTopicBarHeaderStyle Constructor

Constructor. Initializes a new instance of the C1WebTopicBarHeaderStyle class.

Public Properties

BackColor (inherited from Style) | Background color of the controls applied with this style.
BackgroundImageUrl | Gets or sets the background image displayed in the header.
BorderColor (inherited from Style) | Border color of the controls applied with this style.
BorderStyle (inherited from Style) | Style of the border of controls applied with this style.
BorderWidth (inherited from Style) | Thickness of the border around the controls applied with this style.
CaptionImageUrl | Get or sets the caption image displayed in the header.
CssClass (inherited from Style) | CSS class name applied to the user of this style.
Font (inherited from Style) | The font used for text in controls applied with this style.
ForeColor (inherited from Style) | Foreground color of the controls applied with this style.
IndicatorUrl | Get or sets the indicator image displayed in the header.
IsEmpty (inherited from Style) | Overrides C1WebTopicBarStyle.IsEmpty.

Public Methods

AddAttributesToRender | Overloaded. Overriden. Overrides C1WebTopicBarStyle.AddAttributesToRender
CopyFrom | Overriden. Overrides C1WebTopicBarStyle.CopyFrom.
MergeWith | Overriden. Overrides C1WebTopicBarStyle.MergeWith.

See Also


C1WebTopicBarHeaderStyle Constructor

C1WebTopicBarHeaderStyle Constructor

Constructor. Initializes a new instance of the C1WebTopicBarHeaderStyle class.

[Visual Basic]

Public Function New( _

ByVal owner As WebControl _

)

[C#]

public C1WebTopicBarHeaderStyle(

WebControl owner

);

[Delphi]

public constructor Create(

owner: WebControl

);

Parameters

owner

The WebControl object to which the C1WebTopicBarHeaderStyle object belongs

See Also


C1WebTopicBarHeaderStyle Properties

C1WebTopicBarHeaderStyle Properties

The properties of the C1WebTopicBarHeaderStyle class are listed here. For a complete list of C1WebTopicBarHeaderStyle class members, see the C1WebTopicBarHeaderStyle Members topic.

Public Properties

BackColor (inherited from Style) | Background color of the controls applied with this style.
BackgroundImageUrl | Gets or sets the background image displayed in the header.
BorderColor (inherited from Style) | Border color of the controls applied with this style.
BorderStyle (inherited from Style) | Style of the border of controls applied with this style.
BorderWidth (inherited from Style) | Thickness of the border around the controls applied with this style.
CaptionImageUrl | Get or sets the caption image displayed in the header.
CssClass (inherited from Style) | CSS class name applied to the user of this style.
Font (inherited from Style) | The font used for text in controls applied with this style.
ForeColor (inherited from Style) | Foreground color of the controls applied with this style.
IndicatorUrl | Get or sets the indicator image displayed in the header.
IsEmpty (inherited from Style) | Overrides C1WebTopicBarStyle.IsEmpty.

See Also


C1WebTopicBarHeaderStyle.BackgroundImageUrl Property

C1WebTopicBarHeaderStyle.BackgroundImageUrl Property

Gets or sets the background image displayed in the header.

[Visual Basic]

Public Property BackgroundImageUrl As String

[C#]

public string BackgroundImageUrl {get;set;}

[Delphi]

public property BackgroundImageUrl: String read get_BackgroundImageUrl write set_BackgroundImageUrl;

See Also


C1WebTopicBarHeaderStyle.CaptionImageUrl Property

C1WebTopicBarHeaderStyle.CaptionImageUrl Property

Get or sets the caption image displayed in the header.

[Visual Basic]

Public Property CaptionImageUrl As String

[C#]

public string CaptionImageUrl {get;set;}

[Delphi]

public property CaptionImageUrl: String read get_CaptionImageUrl write set_CaptionImageUrl;

See Also


C1WebTopicBarHeaderStyle.IndicatorUrl Property

C1WebTopicBarHeaderStyle.IndicatorUrl Property

Get or sets the indicator image displayed in the header.

[Visual Basic]

Public Property IndicatorUrl As String

[C#]

public string IndicatorUrl {get;set;}

[Delphi]

public property IndicatorUrl: String read get_IndicatorUrl write set_IndicatorUrl;

Remarks

Indicator image is the image used for expanding\collapsing group by clicking on them

See Also


C1WebTopicBarHeaderStyle Methods

C1WebTopicBarHeaderStyle Methods

The methods of the C1WebTopicBarHeaderStyle class are listed here. For a complete list of C1WebTopicBarHeaderStyle class members, see the C1WebTopicBarHeaderStyle Members topic.

Public Methods

AddAttributesToRender | Overloaded. Overriden. Overrides C1WebTopicBarStyle.AddAttributesToRender
CopyFrom | Overriden. Overrides C1WebTopicBarStyle.CopyFrom.
MergeWith | Overriden. Overrides C1WebTopicBarStyle.MergeWith.

See Also


C1WebTopicBarHeaderStyle.AddAttributesToRender Method

C1WebTopicBarHeaderStyle.AddAttributesToRender Method

Overrides C1WebTopicBarStyle.AddAttributesToRender

[Visual Basic]

Overrides Public Sub AddAttributesToRender( _

ByVal writer As HtmlTextWriter, _

ByVal owner As WebControl _

)

[C#]

override public void AddAttributesToRender(

HtmlTextWriter writer,

WebControl owner

);

[Delphi]

public procedure AddAttributesToRender(

writer: HtmlTextWriter;

owner: WebControl

); overload; override;

See Also


C1WebTopicBarHeaderStyle.CopyFrom Method

C1WebTopicBarHeaderStyle.CopyFrom Method

Overrides C1WebTopicBarStyle.CopyFrom.

[Visual Basic]

Overrides Public Sub CopyFrom( _

ByVal style As Style _

)

[C#]

override public void CopyFrom(

Style style

);

[Delphi]

public procedure CopyFrom(

style: Style

); override;

See Also


C1WebTopicBarHeaderStyle.MergeWith Method

C1WebTopicBarHeaderStyle.MergeWith Method

Overrides C1WebTopicBarStyle.MergeWith.

[Visual Basic]

Overrides Public Sub MergeWith( _

ByVal style As Style _

)

[C#]

override public void MergeWith(

Style style

);

[Delphi]

public procedure MergeWith(

style: Style

); override;

See Also


C1WebTopicBarItem Class

C1WebTopicBarItem Class

Represents a navigation item in the topic bar control.

For a list of all members of this type, see C1WebTopicBarItem Members.

System.Object

C1.Web.C1Command.C1WebTopicBarItem

[Visual Basic]

Public Class C1WebTopicBarItem

Implements IStateManager

[C#]

public class C1WebTopicBarItem : IStateManager

[Delphi]

type C1WebTopicBarItem = class (TObject, IStateManager);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1WebTopicBarItem Members

C1WebTopicBarItem Members

C1WebTopicBarItem overview

Public Constructors

C1WebTopicBarItem Constructor

Constructor. Initializes a new instance of the C1WebTopicBarItem class.

Public Properties

CausesValidation | Determines whether validation is performed when the item is clicked.
ClientScripts | Collection of client-side scripts associated with the item.
CommandArgument | Gets or sets an optional parameter passed to the ItemClick and ItemSelected events of the C1WebTopicBar component along with the associated CommandName.
CommandName | Gets or sets the command name associated with the C1WebTopicBarItem passed to the ItemClick and ItemSelected events. of the C1TopicBar component.
DisabledItemStyle | Style for the item in the disabled state.
Enabled | Indicates if the item should respond to user interaction or not.
ImageUrl | Gets or sets the URL to an image that is displayed in the item area.
ItemStyle | Style for the item.
MouseOverItemStyle | Style for the items when the mouse hovers over them.
NavigateUrl | Gets or sets the URL to the link once the item is clicked.
Script | A script attached to the mousedown event (alias for ClientScripts["onclick"]).
Selected | Determines whether the item selected or not.
SelectedItemStyle | Style for the items in the selected state.
Target | Gets or sets the default target window frame that displays the linked Web page content once an item is clicked.
Text | Gets or sets text associated with the item.
ToolTip | Gets or sets the ToolTip text displayed when the mouse pointer rests over the item.
Visible | Gets or sets a value indicating whether the item is visible or not.
WrapText | Gets or sets a value that indicates whether the text of the item is wrapped.

Public Methods

ToString

Overriden. Overrides object.ToString()

Protected Properties

ViewState

Represents view state object for the item.

Protected Methods

LoadViewState | Loads view state in the item.
SaveViewState | Saves view state for the item.
TrackViewState | Tracks view state for the item.

See Also


C1WebTopicBarItem Constructor

C1WebTopicBarItem Constructor

Constructor. Initializes a new instance of the C1WebTopicBarItem class.

[Visual Basic]

Public Function New()

[C#]

public C1WebTopicBarItem()

[Delphi]

public constructor Create();

See Also


C1WebTopicBarItem Properties

C1WebTopicBarItem Properties

The properties of the C1WebTopicBarItem class are listed here. For a complete list of C1WebTopicBarItem class members, see the C1WebTopicBarItem Members topic.

Public Properties

CausesValidation | Determines whether validation is performed when the item is clicked.
ClientScripts | Collection of client-side scripts associated with the item.
CommandArgument | Gets or sets an optional parameter passed to the ItemClick and ItemSelected events of the C1WebTopicBar component along with the associated CommandName.
CommandName | Gets or sets the command name associated with the C1WebTopicBarItem passed to the ItemClick and ItemSelected events. of the C1TopicBar component.
DisabledItemStyle | Style for the item in the disabled state.
Enabled | Indicates if the item should respond to user interaction or not.
ImageUrl | Gets or sets the URL to an image that is displayed in the item area.
ItemStyle | Style for the item.
MouseOverItemStyle | Style for the items when the mouse hovers over them.
NavigateUrl | Gets or sets the URL to the link once the item is clicked.
Script | A script attached to the mousedown event (alias for ClientScripts["onclick"]).
Selected | Determines whether the item selected or not.
SelectedItemStyle | Style for the items in the selected state.
Target | Gets or sets the default target window frame that displays the linked Web page content once an item is clicked.
Text | Gets or sets text associated with the item.
ToolTip | Gets or sets the ToolTip text displayed when the mouse pointer rests over the item.
Visible | Gets or sets a value indicating whether the item is visible or not.
WrapText | Gets or sets a value that indicates whether the text of the item is wrapped.

Protected Properties

ViewState

Represents view state object for the item.

See Also


C1WebTopicBarItem.CausesValidation Property

C1WebTopicBarItem.CausesValidation Property

Determines whether validation is performed when the item is clicked.

[Visual Basic]

Public Property CausesValidation As Boolean

[C#]

public bool CausesValidation {get;set;}

[Delphi]

public property CausesValidation: Boolean read get_CausesValidation write set_CausesValidation;

See Also


C1WebTopicBarItem.ClientScripts Property

C1WebTopicBarItem.ClientScripts Property

Collection of client-side scripts associated with the item.

[Visual Basic]

Public Property ClientScripts As ScriptDefCollection

[C#]

public ScriptDefCollection ClientScripts {get;set;}

[Delphi]

public property ClientScripts: ScriptDefCollection read get_ClientScripts write set_ClientScripts;

See Also


C1WebTopicBarItem.CommandArgument Property

C1WebTopicBarItem.CommandArgument Property

Gets or sets an optional parameter passed to the ItemClick and ItemSelected events of the C1WebTopicBar component along with the associated CommandName.

[Visual Basic]

Public Property CommandArgument As String

[C#]

public string CommandArgument {get;set;}

[Delphi]

public property CommandArgument: String read get_CommandArgument write set_CommandArgument;

Remarks

The CommandArgument property complements the CommandName property by allowing you to provide additional information about the command to perform.

See Also


C1WebTopicBarItem.CommandName Property

C1WebTopicBarItem.CommandName Property

Gets or sets the command name associated with the C1WebTopicBarItem passed to the ItemClick and ItemSelected events. of the C1TopicBar component.

[Visual Basic]

Public Property CommandName As String

[C#]

public string CommandName {get;set;}

[Delphi]

public property CommandName: String read get_CommandName write set_CommandName;

See Also


C1WebTopicBarItem.DisabledItemStyle Property

C1WebTopicBarItem.DisabledItemStyle Property

Style for the item in the disabled state.

[Visual Basic]

Public ReadOnly Property DisabledItemStyle As C1WebTopicBarItemStyle

[C#]

public C1WebTopicBarItemStyle DisabledItemStyle {get;}

[Delphi]

public property DisabledItemStyle: C1WebTopicBarItemStyle read get_DisabledItemStyle;

See Also


C1WebTopicBarItem.Enabled Property

C1WebTopicBarItem.Enabled Property

Indicates if the item should respond to user interaction or not.

[Visual Basic]

Public Property Enabled As Boolean

[C#]

public bool Enabled {get;set;}

[Delphi]

public property Enabled: Boolean read get_Enabled write set_Enabled;

See Also


C1WebTopicBarItem.ImageUrl Property

C1WebTopicBarItem.ImageUrl Property

Gets or sets the URL to an image that is displayed in the item area.

[Visual Basic]

Public Property ImageUrl As String

[C#]

public string ImageUrl {get;set;}

[Delphi]

public property ImageUrl: String read get_ImageUrl write set_ImageUrl;

See Also


C1WebTopicBarItem.ItemStyle Property

C1WebTopicBarItem.ItemStyle Property

Style for the item.

[Visual Basic]

Public ReadOnly Property ItemStyle As C1WebTopicBarItemStyle

[C#]

public C1WebTopicBarItemStyle ItemStyle {get;}

[Delphi]

public property ItemStyle: C1WebTopicBarItemStyle read get_ItemStyle;

See Also


C1WebTopicBarItem.MouseOverItemStyle Property

C1WebTopicBarItem.MouseOverItemStyle Property

Style for the items when the mouse hovers over them.

[Visual Basic]

Public ReadOnly Property MouseOverItemStyle As C1WebTopicBarItemStyle

[C#]

public C1WebTopicBarItemStyle MouseOverItemStyle {get;}

[Delphi]

public property MouseOverItemStyle: C1WebTopicBarItemStyle read get_MouseOverItemStyle;

See Also


C1WebTopicBarItem.NavigateUrl Property

C1WebTopicBarItem.NavigateUrl Property

Gets or sets the URL to the link once the item is clicked.

[Visual Basic]

Public Property NavigateUrl As String

[C#]

public string NavigateUrl {get;set;}

[Delphi]

public property NavigateUrl: String read get_NavigateUrl write set_NavigateUrl;

See Also


C1WebTopicBarItem.Script Property

C1WebTopicBarItem.Script Property

A script attached to the mousedown event (alias for ClientScripts["onclick"]).

[Visual Basic]

Public Property Script As String

[C#]

public string Script {get;set;}

[Delphi]

public property Script: String read get_Script write set_Script;

See Also


C1WebTopicBarItem.Selected Property

C1WebTopicBarItem.Selected Property

Determines whether the item selected or not.

[Visual Basic]

Public Property Selected As Boolean

[C#]

public bool Selected {get;set;}

[Delphi]

public property Selected: Boolean read get_Selected write set_Selected;

See Also


C1WebTopicBarItem.SelectedItemStyle Property

C1WebTopicBarItem.SelectedItemStyle Property

Style for the items in the selected state.

[Visual Basic]

Public ReadOnly Property SelectedItemStyle As C1WebTopicBarItemStyle

[C#]

public C1WebTopicBarItemStyle SelectedItemStyle {get;}

[Delphi]

public property SelectedItemStyle: C1WebTopicBarItemStyle read get_SelectedItemStyle;

See Also


C1WebTopicBarItem.Target Property

C1WebTopicBarItem.Target Property

Gets or sets the default target window frame that displays the linked Web page content once an item is clicked.

[Visual Basic]

Public Property Target As String

[C#]

public string Target {get;set;}

[Delphi]

public property Target: String read get_Target write set_Target;

See Also


C1WebTopicBarItem.Text Property

C1WebTopicBarItem.Text Property

Gets or sets text associated with the item.

[Visual Basic]

Public Property Text As String

[C#]

public string Text {get;set;}

[Delphi]

public property Text: String read get_Text write set_Text;

See Also


C1WebTopicBarItem.ToolTip Property

C1WebTopicBarItem.ToolTip Property

Gets or sets the ToolTip text displayed when the mouse pointer rests over the item.

[Visual Basic]

Public Property ToolTip As String

[C#]

public string ToolTip {get;set;}

[Delphi]

public property ToolTip: String read get_ToolTip write set_ToolTip;

See Also


C1WebTopicBarItem.ViewState Property

C1WebTopicBarItem.ViewState Property

Represents view state object for the item.

[Visual Basic]

Overridable Protected ReadOnly Property ViewState As StateBag

[C#]

virtual protected StateBag ViewState {get;}

[Delphi]

strict protected property ViewState: StateBag read get_ViewState;

See Also


C1WebTopicBarItem.Visible Property

C1WebTopicBarItem.Visible Property

Gets or sets a value indicating whether the item is visible or not.

[Visual Basic]

Public Property Visible As Boolean

[C#]

public bool Visible {get;set;}

[Delphi]

public property Visible: Boolean read get_Visible write set_Visible;

See Also


C1WebTopicBarItem.WrapText Property

C1WebTopicBarItem.WrapText Property

Gets or sets a value that indicates whether the text of the item is wrapped.

[Visual Basic]

Public Property WrapText As Boolean

[C#]

public bool WrapText {get;set;}

[Delphi]

public property WrapText: Boolean read get_WrapText write set_WrapText;

See Also


C1WebTopicBarItem Methods

C1WebTopicBarItem Methods

The methods of the C1WebTopicBarItem class are listed here. For a complete list of C1WebTopicBarItem class members, see the C1WebTopicBarItem Members topic.

Public Methods

ToString

Overriden. Overrides object.ToString()

Protected Methods

LoadViewState | Loads view state in the item.
SaveViewState | Saves view state for the item.
TrackViewState | Tracks view state for the item.

See Also


C1WebTopicBarItem.LoadViewState Method

C1WebTopicBarItem.LoadViewState Method

Loads view state in the item.

[Visual Basic]

Overridable Protected Sub LoadViewState( _

ByVal state As Object _

) Implements IStateManager.LoadViewState

[C#]

virtual protected void LoadViewState(

object state

);

[Delphi]

strict protected procedure LoadViewState(

state: Object

); virtual;

Implements

IStateManager.LoadViewState

See Also


C1WebTopicBarItem.SaveViewState Method

C1WebTopicBarItem.SaveViewState Method

Saves view state for the item.

[Visual Basic]

Overridable Protected Function SaveViewState() As Object Implements IStateManager.SaveViewState

[C#]

virtual protected object SaveViewState()

[Delphi]

strict protected function SaveViewState(): Object; virtual;

Implements

IStateManager.SaveViewState

See Also


C1WebTopicBarItem.ToString Method

C1WebTopicBarItem.ToString Method

Overrides object.ToString()

[Visual Basic]

Overrides Public Function ToString() As String

[C#]

override public string ToString()

[Delphi]

public function ToString(): String; override;

See Also


C1WebTopicBarItem.TrackViewState Method

C1WebTopicBarItem.TrackViewState Method

Tracks view state for the item.

[Visual Basic]

Overridable Protected Sub TrackViewState() Implements IStateManager.TrackViewState

[C#]

virtual protected void TrackViewState()

[Delphi]

strict protected procedure TrackViewState(); virtual;

Implements

IStateManager.TrackViewState

See Also


C1WebTopicBarItemAlignEnum Enumeration

C1WebTopicBarItemAlignEnum Enumeration

Specifies position of an image relative to the item text.

[Visual Basic]

Public Enum C1WebTopicBarItemAlignEnum

[C#]

public enum C1WebTopicBarItemAlignEnum

[Delphi]

type C1WebTopicBarItemAlignEnum = (Bottom, Far, Near, NotSet, Top);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

Members

Member name | Description
Bottom | Image placed under the item text.
Far | Image placed far to the item text.
Near | Image placed near to the item text.
NotSet | Image position is not set.
Top | Image placed above the item text.

See Also

C1.Web.C1Command Namespace


C1WebTopicBarItemCollection Class

C1WebTopicBarItemCollection Class

Contains the values of a C1WebTopicBarItemsGroup.Items property.

For a list of all members of this type, see C1WebTopicBarItemCollection Members.

System.Object

System.Collections.CollectionBase

C1.Web.C1Command.C1WebTopicBarItemCollection

[Visual Basic]

Public Class C1WebTopicBarItemCollection

Inherits CollectionBase

Implements IStateManager

[C#]

public class C1WebTopicBarItemCollection : CollectionBase , IStateManager

[Delphi]

type C1WebTopicBarItemCollection = class (CollectionBase, IStateManager);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1WebTopicBarItemCollection Members

C1WebTopicBarItemCollection Members

C1WebTopicBarItemCollection overview

Public Constructors

C1WebTopicBarItemCollection Constructor

Constructor. Initializes a new instance of the C1WebTopicBarItemCollection class.

Public Properties

Item

Indexer (Item property in VB). Gets or sets the item that is located at a specified index of the collection.

Public Methods

Add | Appends a item to the collection.
IndexOf | Searches for the specified item and returns the zero-based index of the first occurrence within the collection.

See Also


C1WebTopicBarItemCollection Constructor

C1WebTopicBarItemCollection Constructor

Constructor. Initializes a new instance of the C1WebTopicBarItemCollection class.

[Visual Basic]

Public Function New( _

ByVal owner As C1WebTopicBarItemsGroup _

)

[C#]

public C1WebTopicBarItemCollection(

C1WebTopicBarItemsGroup owner

);

[Delphi]

public constructor Create(

owner: C1WebTopicBarItemsGroup

);

Parameters

owner

C1WebTopicBarItemsGroup instance

See Also


C1WebTopicBarItemCollection Properties

C1WebTopicBarItemCollection Properties

The properties of the C1WebTopicBarItemCollection class are listed here. For a complete list of C1WebTopicBarItemCollection class members, see the C1WebTopicBarItemCollection Members topic.

Public Properties

Item

Indexer (Item property in VB). Gets or sets the item that is located at a specified index of the collection.

See Also


C1WebTopicBarItemCollection.Item Property

C1WebTopicBarItemCollection.Item Property

Indexer (Item property in VB). Gets or sets the item that is located at a specified index of the collection.

[Visual Basic]

Public Default Property Item( _

ByVal index As Integer _

) As C1WebTopicBarItem

[C#]

public C1WebTopicBarItem this[

int index

] {get;set;}

[Delphi]

public property Item[

index: Int32

]: C1WebTopicBarItem read get_Item write set_Item;

Parameters

index

The zero-based index of the item.

See Also


C1WebTopicBarItemCollection Methods

C1WebTopicBarItemCollection Methods

The methods of the C1WebTopicBarItemCollection class are listed here. For a complete list of C1WebTopicBarItemCollection class members, see the C1WebTopicBarItemCollection Members topic.

Public Methods

Add | Appends a item to the collection.
IndexOf | Searches for the specified item and returns the zero-based index of the first occurrence within the collection.

See Also


C1WebTopicBarItemCollection.Add Method

C1WebTopicBarItemCollection.Add Method

Appends a item to the collection.

[Visual Basic]

Public Sub Add( _

ByVal value As C1WebTopicBarItem _

)

[C#]

public void Add(

C1WebTopicBarItem value

);

[Delphi]

public procedure Add(

value: C1WebTopicBarItem

);

Parameters

value

The item to add

See Also


C1WebTopicBarItemCollection.IndexOf Method

C1WebTopicBarItemCollection.IndexOf Method

Searches for the specified item and returns the zero-based index of the first occurrence within the collection.

[Visual Basic]

Public Function IndexOf( _

ByVal value As C1WebTopicBarItem _

) As Integer

[C#]

public int IndexOf(

C1WebTopicBarItem value

);

[Delphi]

public function IndexOf(

value: C1WebTopicBarItem

): Int32;

Parameters

value

The item to locate in the collection.

Return Value

The zero-based index of the first occurrence of the item in the collection, if found; otherwise, -1.

See Also


C1WebTopicBarItemsGroup Class

C1WebTopicBarItemsGroup Class

Represents a group which contains navigation items.

For a list of all members of this type, see C1WebTopicBarItemsGroup Members.

System.Object

C1.Web.C1Command.C1WebTopicBarCustomGroup

C1.Web.C1Command.C1WebTopicBarItemsGroup

[Visual Basic]

Public Class C1WebTopicBarItemsGroup

Inherits C1WebTopicBarCustomGroup

[C#]

public class C1WebTopicBarItemsGroup : C1WebTopicBarCustomGroup

[Delphi]

type C1WebTopicBarItemsGroup = class (C1WebTopicBarCustomGroup);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1WebTopicBarItemsGroup Members

C1WebTopicBarItemsGroup Members

C1WebTopicBarItemsGroup overview

Public Constructors

C1WebTopicBarItemsGroup Constructor

Constructor. Initializes a new instance of the C1WebTopicBarCustomGroup class.

Public Properties

AllowSelectItem | Determines whether the user will be able to select an item in the group.
CaptionImageHeight (inherited from C1WebTopicBarCustomGroup) | Gets or sets the height of image set in the CaptionImageUrl property of header styles.
CaptionImageWidth (inherited from C1WebTopicBarCustomGroup) | Gets or sets the width of image set in the CaptionImageUrl property of header styles.
CaptionLabelHorizontalAlign (inherited from C1WebTopicBarCustomGroup) | Gets or sets the value for the horizontal align of the labels in the headers.
CaptionLabelVerticalAlign (inherited from C1WebTopicBarCustomGroup) | Gets or sets the value for the vertical align of the labels in the headers.
Collapsed (inherited from C1WebTopicBarCustomGroup) | Gets or sets a value indicating whether the group collapsed or not.
CollapsedHeaderStyle (inherited from C1WebTopicBarCustomGroup) | Style for the group header in the collapsed state.
DisabledGroupStyle (inherited from C1WebTopicBarCustomGroup) | Style for the disabled group.
DisabledHeaderStyle (inherited from C1WebTopicBarCustomGroup) | Style for the group header in the disabled state.
DisabledItemStyle | Style for the items in the disabled state.
Enabled (inherited from C1WebTopicBarCustomGroup) | Gets or sets a value indicating whether the group can respond to user interaction or not.
EnableExpandCollapse (inherited from C1WebTopicBarCustomGroup) | Gets or sets a value indicating whether user can expand or collapse the group by double-clicking on header or clicking on the indicator image.
ExpandedHeaderStyle (inherited from C1WebTopicBarCustomGroup) | Style for the group header in the expanded state.
GroupStyle (inherited from C1WebTopicBarCustomGroup) | Style for the group.
Items | Returns a collection of C1WebTopicBarItem objects.
ItemStyle | Style for the items
MouseOverCollapsedHeaderStyle (inherited from C1WebTopicBarCustomGroup) | Style for the group header in the collapsed state when the mouse hovers over them.
MouseOverExpandedHeaderStyle (inherited from C1WebTopicBarCustomGroup) | Style for the group header in the expanded state when the mouse hovers over them.
MouseOverItemStyle | Style for the items when the mouse hovers over them.
SelectedItemStyle | Style for the items in the selected state
Text (inherited from C1WebTopicBarCustomGroup) | Gets or sets text that is displayed in the group header.
TextHeight (inherited from C1WebTopicBarCustomGroup) | Gets or sets the height of the group header text.
ToolTip (inherited from C1WebTopicBarCustomGroup) | Gets or sets the ToolTip text displayed when the mouse pointer rests over the group.
Visible (inherited from C1WebTopicBarCustomGroup) | Gets or sets a value indicating whether the group visible or not.
WrapText (inherited from C1WebTopicBarCustomGroup) | Gets or sets a value that indicates whether the text of the items is wrapped.

Public Methods

ToString

Overriden. Overrides object.ToString().

Protected Properties

IsTrackingViewState (inherited from C1WebTopicBarCustomGroup) | Indicates whether the server control is saving changes to its view state.
ViewState (inherited from C1WebTopicBarCustomGroup) | View state for the group.

Protected Methods

AddAttributesToGroup | Overriden. Overrides C1WebTopicBarCustomGroup.AddAttributesToGroup.
MarkGroupTypeInViewState (inherited from C1WebTopicBarCustomGroup) | Marks current group in view state. For internal use.
ProcessBody | Overriden. Overrides.

See Also


C1WebTopicBarItemsGroup Constructor

C1WebTopicBarItemsGroup Constructor

Constructor. Initializes a new instance of the C1WebTopicBarCustomGroup class.

[Visual Basic]

Public Function New()

[C#]

public C1WebTopicBarItemsGroup()

[Delphi]

public constructor Create();

See Also


C1WebTopicBarItemsGroup Properties

C1WebTopicBarItemsGroup Properties

The properties of the C1WebTopicBarItemsGroup class are listed here. For a complete list of C1WebTopicBarItemsGroup class members, see the C1WebTopicBarItemsGroup Members topic.

Public Properties

AllowSelectItem | Determines whether the user will be able to select an item in the group.
CaptionImageHeight (inherited from C1WebTopicBarCustomGroup) | Gets or sets the height of image set in the CaptionImageUrl property of header styles.
CaptionImageWidth (inherited from C1WebTopicBarCustomGroup) | Gets or sets the width of image set in the CaptionImageUrl property of header styles.
CaptionLabelHorizontalAlign (inherited from C1WebTopicBarCustomGroup) | Gets or sets the value for the horizontal align of the labels in the headers.
CaptionLabelVerticalAlign (inherited from C1WebTopicBarCustomGroup) | Gets or sets the value for the vertical align of the labels in the headers.
Collapsed (inherited from C1WebTopicBarCustomGroup) | Gets or sets a value indicating whether the group collapsed or not.
CollapsedHeaderStyle (inherited from C1WebTopicBarCustomGroup) | Style for the group header in the collapsed state.
DisabledGroupStyle (inherited from C1WebTopicBarCustomGroup) | Style for the disabled group.
DisabledHeaderStyle (inherited from C1WebTopicBarCustomGroup) | Style for the group header in the disabled state.
DisabledItemStyle | Style for the items in the disabled state.
Enabled (inherited from C1WebTopicBarCustomGroup) | Gets or sets a value indicating whether the group can respond to user interaction or not.
EnableExpandCollapse (inherited from C1WebTopicBarCustomGroup) | Gets or sets a value indicating whether user can expand or collapse the group by double-clicking on header or clicking on the indicator image.
ExpandedHeaderStyle (inherited from C1WebTopicBarCustomGroup) | Style for the group header in the expanded state.
GroupStyle (inherited from C1WebTopicBarCustomGroup) | Style for the group.
Items | Returns a collection of C1WebTopicBarItem objects.
ItemStyle | Style for the items
MouseOverCollapsedHeaderStyle (inherited from C1WebTopicBarCustomGroup) | Style for the group header in the collapsed state when the mouse hovers over them.
MouseOverExpandedHeaderStyle (inherited from C1WebTopicBarCustomGroup) | Style for the group header in the expanded state when the mouse hovers over them.
MouseOverItemStyle | Style for the items when the mouse hovers over them.
SelectedItemStyle | Style for the items in the selected state
Text (inherited from C1WebTopicBarCustomGroup) | Gets or sets text that is displayed in the group header.
TextHeight (inherited from C1WebTopicBarCustomGroup) | Gets or sets the height of the group header text.
ToolTip (inherited from C1WebTopicBarCustomGroup) | Gets or sets the ToolTip text displayed when the mouse pointer rests over the group.
Visible (inherited from C1WebTopicBarCustomGroup) | Gets or sets a value indicating whether the group visible or not.
WrapText (inherited from C1WebTopicBarCustomGroup) | Gets or sets a value that indicates whether the text of the items is wrapped.

Protected Properties

IsTrackingViewState (inherited from C1WebTopicBarCustomGroup) | Indicates whether the server control is saving changes to its view state.
ViewState (inherited from C1WebTopicBarCustomGroup) | View state for the group.

See Also


C1WebTopicBarItemsGroup.AllowSelectItem Property

C1WebTopicBarItemsGroup.AllowSelectItem Property

Determines whether the user will be able to select an item in the group.

[Visual Basic]

Public Property AllowSelectItem As Boolean

[C#]

public bool AllowSelectItem {get;set;}

[Delphi]

public property AllowSelectItem: Boolean read get_AllowSelectItem write set_AllowSelectItem;

See Also


C1WebTopicBarItemsGroup.DisabledItemStyle Property

C1WebTopicBarItemsGroup.DisabledItemStyle Property

Style for the items in the disabled state.

[Visual Basic]

Public ReadOnly Property DisabledItemStyle As C1WebTopicBarItemStyle

[C#]

public C1WebTopicBarItemStyle DisabledItemStyle {get;}

[Delphi]

public property DisabledItemStyle: C1WebTopicBarItemStyle read get_DisabledItemStyle;

Remarks

You can define style individually for each item.

See Also


C1WebTopicBarItemsGroup.Items Property

C1WebTopicBarItemsGroup.Items Property

Returns a collection of C1WebTopicBarItem objects.

[Visual Basic]

Public ReadOnly Property Items As C1WebTopicBarItemCollection

[C#]

public C1WebTopicBarItemCollection Items {get;}

[Delphi]

public property Items: C1WebTopicBarItemCollection read get_Items;

See Also


C1WebTopicBarItemsGroup.ItemStyle Property

C1WebTopicBarItemsGroup.ItemStyle Property

Style for the items

[Visual Basic]

Public ReadOnly Property ItemStyle As C1WebTopicBarItemStyle

[C#]

public C1WebTopicBarItemStyle ItemStyle {get;}

[Delphi]

public property ItemStyle: C1WebTopicBarItemStyle read get_ItemStyle;

Remarks

You can define style individually for each item.

See Also


C1WebTopicBarItemsGroup.MouseOverItemStyle Property

C1WebTopicBarItemsGroup.MouseOverItemStyle Property

Style for the items when the mouse hovers over them.

[Visual Basic]

Public ReadOnly Property MouseOverItemStyle As C1WebTopicBarItemStyle

[C#]

public C1WebTopicBarItemStyle MouseOverItemStyle {get;}

[Delphi]

public property MouseOverItemStyle: C1WebTopicBarItemStyle read get_MouseOverItemStyle;

Remarks

You can define style individually for each item.

See Also


C1WebTopicBarItemsGroup.SelectedItemStyle Property

C1WebTopicBarItemsGroup.SelectedItemStyle Property

Style for the items in the selected state

[Visual Basic]

Public ReadOnly Property SelectedItemStyle As C1WebTopicBarItemStyle

[C#]

public C1WebTopicBarItemStyle SelectedItemStyle {get;}

[Delphi]

public property SelectedItemStyle: C1WebTopicBarItemStyle read get_SelectedItemStyle;

Remarks

You can define style individually for each item.

See Also


C1WebTopicBarItemsGroup Methods

C1WebTopicBarItemsGroup Methods

The methods of the C1WebTopicBarItemsGroup class are listed here. For a complete list of C1WebTopicBarItemsGroup class members, see the C1WebTopicBarItemsGroup Members topic.

Public Methods

ToString

Overriden. Overrides object.ToString().

Protected Methods

AddAttributesToGroup | Overriden. Overrides C1WebTopicBarCustomGroup.AddAttributesToGroup.
MarkGroupTypeInViewState (inherited from C1WebTopicBarCustomGroup) | Marks current group in view state. For internal use.
ProcessBody | Overriden. Overrides.

See Also


C1WebTopicBarItemsGroup.AddAttributesToGroup Method

C1WebTopicBarItemsGroup.AddAttributesToGroup Method

Overrides C1WebTopicBarCustomGroup.AddAttributesToGroup.

[Visual Basic]

Overrides Protected Sub AddAttributesToGroup( _

ByVal control As WebControl _

)

[C#]

override protected void AddAttributesToGroup(

WebControl control

);

[Delphi]

strict protected procedure AddAttributesToGroup(

control: WebControl

); override;

See Also


C1WebTopicBarItemsGroup.ProcessBody Method

C1WebTopicBarItemsGroup.ProcessBody Method

Overrides.

[Visual Basic]

Overrides Protected Sub ProcessBody( _

ByVal cell As TableCell _

)

[C#]

override protected void ProcessBody(

TableCell cell

);

[Delphi]

strict protected procedure ProcessBody(

cell: TableCell

); override;

Parameters

cell

Return Value

See Also


C1WebTopicBarItemsGroup.ToString Method

C1WebTopicBarItemsGroup.ToString Method

Overrides object.ToString().

[Visual Basic]

Overrides Public Function ToString() As String

[C#]

override public string ToString()

[Delphi]

public function ToString(): String; override;

See Also


C1WebTopicBarItemStyle Class

C1WebTopicBarItemStyle Class

For a list of all members of this type, see C1WebTopicBarItemStyle Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Web.UI.WebControls.Style

C1.Web.C1Command.C1WebTopicBarStyle

C1.Web.C1Command.C1WebTopicBarItemStyle

[Visual Basic]

Public Class C1WebTopicBarItemStyle

Inherits C1WebTopicBarStyle

[C#]

public class C1WebTopicBarItemStyle : C1WebTopicBarStyle

[Delphi]

type C1WebTopicBarItemStyle = class (C1WebTopicBarStyle);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1WebTopicBarItemStyle Members

C1WebTopicBarItemStyle Members

C1WebTopicBarItemStyle overview

Public Constructors

C1WebTopicBarItemStyle Constructor

Constructor. Initializes a new instance of the C1WebTopicBarItemStyle class.

Public Properties

BackColor (inherited from Style) | Background color of the controls applied with this style.
BackgroundImageUrl | Gets or sets the URL for background image displayed in the item.
BorderColor (inherited from Style) | Border color of the controls applied with this style.
BorderStyle (inherited from Style) | Style of the border of controls applied with this style.
BorderWidth (inherited from Style) | Thickness of the border around the controls applied with this style.
CssClass (inherited from Style) | CSS class name applied to the user of this style.
Font (inherited from Style) | The font used for text in controls applied with this style.
ForeColor (inherited from Style) | Foreground color of the controls applied with this style.
ImageTextSpacing | Gets or sets distance between item image and item text.
ItemAlign | Specifies the horizontal alignment of content within an item.
ItemImagePosition | Specifies position of an image relative to the item text.

See Also


C1WebTopicBarItemStyle Constructor

C1WebTopicBarItemStyle Constructor

Constructor. Initializes a new instance of the C1WebTopicBarItemStyle class.

[Visual Basic]

Public Function New( _

ByVal owner As WebControl _

)

[C#]

public C1WebTopicBarItemStyle(

WebControl owner

);

[Delphi]

public constructor Create(

owner: WebControl

);

Parameters

owner

The WebControl object to which the C1WebTopicBarItemStyle object belongs

See Also


C1WebTopicBarItemStyle Properties

C1WebTopicBarItemStyle Properties

The properties of the C1WebTopicBarItemStyle class are listed here. For a complete list of C1WebTopicBarItemStyle class members, see the C1WebTopicBarItemStyle Members topic.

Public Properties

BackColor (inherited from Style) | Background color of the controls applied with this style.
BackgroundImageUrl | Gets or sets the URL for background image displayed in the item.
BorderColor (inherited from Style) | Border color of the controls applied with this style.
BorderStyle (inherited from Style) | Style of the border of controls applied with this style.
BorderWidth (inherited from Style) | Thickness of the border around the controls applied with this style.
CssClass (inherited from Style) | CSS class name applied to the user of this style.
Font (inherited from Style) | The font used for text in controls applied with this style.
ForeColor (inherited from Style) | Foreground color of the controls applied with this style.
ImageTextSpacing | Gets or sets distance between item image and item text.
ItemAlign | Specifies the horizontal alignment of content within an item.
ItemImagePosition | Specifies position of an image relative to the item text.

See Also


C1WebTopicBarItemStyle.BackgroundImageUrl Property

C1WebTopicBarItemStyle.BackgroundImageUrl Property

Gets or sets the URL for background image displayed in the item.

[Visual Basic]

Public Property BackgroundImageUrl As String

[C#]

public string BackgroundImageUrl {get;set;}

[Delphi]

public property BackgroundImageUrl: String read get_BackgroundImageUrl write set_BackgroundImageUrl;

See Also


C1WebTopicBarItemStyle.ImageTextSpacing Property

C1WebTopicBarItemStyle.ImageTextSpacing Property

Gets or sets distance between item image and item text.

[Visual Basic]

Public Property ImageTextSpacing As Unit

[C#]

public Unit ImageTextSpacing {get;set;}

[Delphi]

public property ImageTextSpacing: Unit read get_ImageTextSpacing write set_ImageTextSpacing;

See Also


C1WebTopicBarItemStyle.ItemAlign Property

C1WebTopicBarItemStyle.ItemAlign Property

Specifies the horizontal alignment of content within an item.

[Visual Basic]

Public Property ItemAlign As HorizontalAlign

[C#]

public HorizontalAlign ItemAlign {get;set;}

[Delphi]

public property ItemAlign: HorizontalAlign read get_ItemAlign write set_ItemAlign;

See Also


C1WebTopicBarItemStyle.ItemImagePosition Property

C1WebTopicBarItemStyle.ItemImagePosition Property

Specifies position of an image relative to the item text.

[Visual Basic]

Public Property ItemImagePosition As C1WebTopicBarItemAlignEnum

[C#]

public C1WebTopicBarItemAlignEnum ItemImagePosition {get;set;}

[Delphi]

public property ItemImagePosition: C1WebTopicBarItemAlignEnum read get_ItemImagePosition write set_ItemImagePosition;

See Also


C1WebTopicBarPanelBodyHelper Class

C1WebTopicBarPanelBodyHelper Class

For a list of all members of this type, see C1WebTopicBarPanelBodyHelper Members.

System.Object

System.Web.UI.Control

System.Web.UI.WebControls.WebControl

System.Web.UI.WebControls.Panel

C1.Web.C1Command.C1WebTopicBarPanelBodyHelper

[Visual Basic]

Public Class C1WebTopicBarPanelBodyHelper

Inherits Panel

[C#]

public class C1WebTopicBarPanelBodyHelper : Panel

[Delphi]

type C1WebTopicBarPanelBodyHelper = class (Panel);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1WebTopicBarPanelBodyHelper Members

C1WebTopicBarPanelBodyHelper Members

C1WebTopicBarPanelBodyHelper overview

Public Properties

AccessKey (inherited from WebControl) | Keyboard shortcut used by the control.
AppRelativeTemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Attributes (inherited from WebControl) | Tag attributes of the control.
BackColor (inherited from WebControl) | Color of the background of the control.
BackImageUrl (inherited from Panel) | The background image of the panel.
BorderColor (inherited from WebControl) | Color of the border around the control.
BorderStyle (inherited from WebControl) | Style of the border around the control.
BorderWidth (inherited from WebControl) | Width of the border around the control.
ClientID (inherited from Control) | The ID of the control that is rendered for the client.
Controls (inherited from Control) | The collection of child controls owned by the control.
ControlStyle (inherited from WebControl) | The style associated with the control.
ControlStyleCreated (inherited from WebControl) | Whether the style associated with the control has been created.
CssClass (inherited from WebControl) | CSS Class name applied to the control.
DefaultButton (inherited from Panel) | The default button for the panel.
Direction (inherited from Panel) | The direction of text in the panel.
Enabled (inherited from WebControl) | Enabled state of the control.
EnableViewState (inherited from Control) | Whether the control automatically saves its state for use in round-trips.
Font (inherited from WebControl) | The font used for text within the control.
ForeColor (inherited from WebControl) | Color of the text within the control.
GroupingText (inherited from Panel) | The text of group box around this control's contents.
Height (inherited from WebControl) | The height of the control.
HorizontalAlign (inherited from Panel) | The horizontal alignment of the content.
ID (inherited from Control) | Programmatic name of the control.
NamingContainer (inherited from Control) | The containing control or page within which ID is unique.
Page (inherited from Control) | The page containing the control.
Parent (inherited from Control) | The control containing this control.
ScrollBars (inherited from Panel) | The appearance of scrollbars for the panel.
Site (inherited from Control) | Site of the control.
Style (inherited from WebControl) | Low-level access to control styles.
TabIndex (inherited from WebControl) | The tab order of the control.
TemplateControl (inherited from Control) | The TemplateControl that hosts this control.
TemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
ToolTip (inherited from WebControl) | The tooltip displayed when the mouse is over the control.
UniqueID (inherited from Control) | The unique ID of the control within the page.
Visible (inherited from Control) | Indicates whether the control is visible and rendered.
Width (inherited from WebControl) | The width of the control.
Wrap (inherited from Panel) | Whether the content should wrap or not.

Public Events

DataBinding (inherited from Control) | Fires when the control's data binding expressions are to be evaluated.
Disposed (inherited from Control) | Fires when the control has been disposed.
Init (inherited from Control) | Fires when the page has been initialized.
Load (inherited from Control) | Fires when the page has been loaded.
PreRender (inherited from Control) | Fires before the page is rendered.
Unload (inherited from Control) | Fires when the page is unloaded.

Protected Properties

ViewState (inherited from Control)

Current viewstate of the control.

Protected Methods

Render

Overriden. Does not render since nested controls at runtime will be added to C1WebTopicBarPanelGroup controls.

See Also


C1WebTopicBarPanelBodyHelper Properties

C1WebTopicBarPanelBodyHelper Properties

The properties of the C1WebTopicBarPanelBodyHelper class are listed here. For a complete list of C1WebTopicBarPanelBodyHelper class members, see the C1WebTopicBarPanelBodyHelper Members topic.

Public Properties

AccessKey (inherited from WebControl) | Keyboard shortcut used by the control.
AppRelativeTemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
Attributes (inherited from WebControl) | Tag attributes of the control.
BackColor (inherited from WebControl) | Color of the background of the control.
BackImageUrl (inherited from Panel) | The background image of the panel.
BorderColor (inherited from WebControl) | Color of the border around the control.
BorderStyle (inherited from WebControl) | Style of the border around the control.
BorderWidth (inherited from WebControl) | Width of the border around the control.
ClientID (inherited from Control) | The ID of the control that is rendered for the client.
Controls (inherited from Control) | The collection of child controls owned by the control.
ControlStyle (inherited from WebControl) | The style associated with the control.
ControlStyleCreated (inherited from WebControl) | Whether the style associated with the control has been created.
CssClass (inherited from WebControl) | CSS Class name applied to the control.
DefaultButton (inherited from Panel) | The default button for the panel.
Direction (inherited from Panel) | The direction of text in the panel.
Enabled (inherited from WebControl) | Enabled state of the control.
EnableViewState (inherited from Control) | Whether the control automatically saves its state for use in round-trips.
Font (inherited from WebControl) | The font used for text within the control.
ForeColor (inherited from WebControl) | Color of the text within the control.
GroupingText (inherited from Panel) | The text of group box around this control's contents.
Height (inherited from WebControl) | The height of the control.
HorizontalAlign (inherited from Panel) | The horizontal alignment of the content.
ID (inherited from Control) | Programmatic name of the control.
NamingContainer (inherited from Control) | The containing control or page within which ID is unique.
Page (inherited from Control) | The page containing the control.
Parent (inherited from Control) | The control containing this control.
ScrollBars (inherited from Panel) | The appearance of scrollbars for the panel.
Site (inherited from Control) | Site of the control.
Style (inherited from WebControl) | Low-level access to control styles.
TabIndex (inherited from WebControl) | The tab order of the control.
TemplateControl (inherited from Control) | The TemplateControl that hosts this control.
TemplateSourceDirectory (inherited from Control) | The virtual directory of the Page or UserControl that contains this control.
ToolTip (inherited from WebControl) | The tooltip displayed when the mouse is over the control.
UniqueID (inherited from Control) | The unique ID of the control within the page.
Visible (inherited from Control) | Indicates whether the control is visible and rendered.
Width (inherited from WebControl) | The width of the control.
Wrap (inherited from Panel) | Whether the content should wrap or not.

Protected Properties

ViewState (inherited from Control)

Current viewstate of the control.

See Also


C1WebTopicBarPanelBodyHelper Methods

C1WebTopicBarPanelBodyHelper Methods

The methods of the C1WebTopicBarPanelBodyHelper class are listed here. For a complete list of C1WebTopicBarPanelBodyHelper class members, see the C1WebTopicBarPanelBodyHelper Members topic.

Protected Methods

Render

Overriden. Does not render since nested controls at runtime will be added to C1WebTopicBarPanelGroup controls.

See Also


C1WebTopicBarPanelBodyHelper.Render Method

C1WebTopicBarPanelBodyHelper.Render Method

Does not render since nested controls at runtime will be added to C1WebTopicBarPanelGroup controls.

[Visual Basic]

Overrides Protected Sub Render( _

ByVal writer As HtmlTextWriter _

)

[C#]

override protected void Render(

HtmlTextWriter writer

);

[Delphi]

strict protected procedure Render(

writer: HtmlTextWriter

); override;

See Also


C1WebTopicBarPanelBodyHelper Events

C1WebTopicBarPanelBodyHelper Events

The events of the C1WebTopicBarPanelBodyHelper class are listed here. For a complete list of C1WebTopicBarPanelBodyHelper class members, see the C1WebTopicBarPanelBodyHelper Members topic.

Public Events

DataBinding (inherited from Control) | Fires when the control's data binding expressions are to be evaluated.
Disposed (inherited from Control) | Fires when the control has been disposed.
Init (inherited from Control) | Fires when the page has been initialized.
Load (inherited from Control) | Fires when the page has been loaded.
PreRender (inherited from Control) | Fires before the page is rendered.
Unload (inherited from Control) | Fires when the page is unloaded.

See Also


C1WebTopicBarPanelGroup Class

C1WebTopicBarPanelGroup Class

For a list of all members of this type, see C1WebTopicBarPanelGroup Members.

System.Object

C1.Web.C1Command.C1WebTopicBarCustomGroup

C1.Web.C1Command.C1WebTopicBarPanelGroup

[Visual Basic]

Public Class C1WebTopicBarPanelGroup

Inherits C1WebTopicBarCustomGroup

[C#]

public class C1WebTopicBarPanelGroup : C1WebTopicBarCustomGroup

[Delphi]

type C1WebTopicBarPanelGroup = class (C1WebTopicBarCustomGroup);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1WebTopicBarPanelGroup Members

C1WebTopicBarPanelGroup Members

C1WebTopicBarPanelGroup overview

Public Constructors

C1WebTopicBarPanelGroup Constructor

Constructor. Initializes a new instance of the C1WebTopicBarPanelGroup class.

Public Properties

BodyHeight | Gets or sets the height of the group body (container area where controls can be placed).
CaptionImageHeight (inherited from C1WebTopicBarCustomGroup) | Gets or sets the height of image set in the CaptionImageUrl property of header styles.
CaptionImageWidth (inherited from C1WebTopicBarCustomGroup) | Gets or sets the width of image set in the CaptionImageUrl property of header styles.
CaptionLabelHorizontalAlign (inherited from C1WebTopicBarCustomGroup) | Gets or sets the value for the horizontal align of the labels in the headers.
CaptionLabelVerticalAlign (inherited from C1WebTopicBarCustomGroup) | Gets or sets the value for the vertical align of the labels in the headers.
Collapsed (inherited from C1WebTopicBarCustomGroup) | Gets or sets a value indicating whether the group collapsed or not.
CollapsedHeaderStyle (inherited from C1WebTopicBarCustomGroup) | Style for the group header in the collapsed state.
DisabledGroupStyle (inherited from C1WebTopicBarCustomGroup) | Style for the disabled group.
DisabledHeaderStyle (inherited from C1WebTopicBarCustomGroup) | Style for the group header in the disabled state.
Enabled (inherited from C1WebTopicBarCustomGroup) | Gets or sets a value indicating whether the group can respond to user interaction or not.
EnableExpandCollapse (inherited from C1WebTopicBarCustomGroup) | Gets or sets a value indicating whether user can expand or collapse the group by double-clicking on header or clicking on the indicator image.
ExpandedHeaderStyle (inherited from C1WebTopicBarCustomGroup) | Style for the group header in the expanded state.
GroupStyle (inherited from C1WebTopicBarCustomGroup) | Style for the group.
HorizontalAlign | Specifies the horizonal alignment of controls within a group body.
MouseOverCollapsedHeaderStyle (inherited from C1WebTopicBarCustomGroup) | Style for the group header in the collapsed state when the mouse hovers over them.
MouseOverExpandedHeaderStyle (inherited from C1WebTopicBarCustomGroup) | Style for the group header in the expanded state when the mouse hovers over them.
Text (inherited from C1WebTopicBarCustomGroup) | Gets or sets text that is displayed in the group header.
TextHeight (inherited from C1WebTopicBarCustomGroup) | Gets or sets the height of the group header text.
ToolTip (inherited from C1WebTopicBarCustomGroup) | Gets or sets the ToolTip text displayed when the mouse pointer rests over the group.
VerticalAlign | Specifies the vertical alignment of controls within a group body.
Visible (inherited from C1WebTopicBarCustomGroup) | Gets or sets a value indicating whether the group visible or not.
WrapText (inherited from C1WebTopicBarCustomGroup) | Gets or sets a value that indicates whether the text of the items is wrapped.

Public Methods

Add

Adds the specified Control object to the Panel Group's body.

Protected Properties

IsTrackingViewState (inherited from C1WebTopicBarCustomGroup) | Indicates whether the server control is saving changes to its view state.
ViewState (inherited from C1WebTopicBarCustomGroup) | View state for the group.

Protected Methods

MarkGroupTypeInViewState (inherited from C1WebTopicBarCustomGroup) | Marks current group in view state. For internal use.
TrackViewState (inherited from C1WebTopicBarCustomGroup) | Tracks view state.

See Also


C1WebTopicBarPanelGroup Constructor

C1WebTopicBarPanelGroup Constructor

Constructor. Initializes a new instance of the C1WebTopicBarPanelGroup class.

[Visual Basic]

Public Function New()

[C#]

public C1WebTopicBarPanelGroup()

[Delphi]

public constructor Create();

See Also


C1WebTopicBarPanelGroup Properties

C1WebTopicBarPanelGroup Properties

The properties of the C1WebTopicBarPanelGroup class are listed here. For a complete list of C1WebTopicBarPanelGroup class members, see the C1WebTopicBarPanelGroup Members topic.

Public Properties

BodyHeight | Gets or sets the height of the group body (container area where controls can be placed).
CaptionImageHeight (inherited from C1WebTopicBarCustomGroup) | Gets or sets the height of image set in the CaptionImageUrl property of header styles.
CaptionImageWidth (inherited from C1WebTopicBarCustomGroup) | Gets or sets the width of image set in the CaptionImageUrl property of header styles.
CaptionLabelHorizontalAlign (inherited from C1WebTopicBarCustomGroup) | Gets or sets the value for the horizontal align of the labels in the headers.
CaptionLabelVerticalAlign (inherited from C1WebTopicBarCustomGroup) | Gets or sets the value for the vertical align of the labels in the headers.
Collapsed (inherited from C1WebTopicBarCustomGroup) | Gets or sets a value indicating whether the group collapsed or not.
CollapsedHeaderStyle (inherited from C1WebTopicBarCustomGroup) | Style for the group header in the collapsed state.
DisabledGroupStyle (inherited from C1WebTopicBarCustomGroup) | Style for the disabled group.
DisabledHeaderStyle (inherited from C1WebTopicBarCustomGroup) | Style for the group header in the disabled state.
Enabled (inherited from C1WebTopicBarCustomGroup) | Gets or sets a value indicating whether the group can respond to user interaction or not.
EnableExpandCollapse (inherited from C1WebTopicBarCustomGroup) | Gets or sets a value indicating whether user can expand or collapse the group by double-clicking on header or clicking on the indicator image.
ExpandedHeaderStyle (inherited from C1WebTopicBarCustomGroup) | Style for the group header in the expanded state.
GroupStyle (inherited from C1WebTopicBarCustomGroup) | Style for the group.
HorizontalAlign | Specifies the horizonal alignment of controls within a group body.
MouseOverCollapsedHeaderStyle (inherited from C1WebTopicBarCustomGroup) | Style for the group header in the collapsed state when the mouse hovers over them.
MouseOverExpandedHeaderStyle (inherited from C1WebTopicBarCustomGroup) | Style for the group header in the expanded state when the mouse hovers over them.
Text (inherited from C1WebTopicBarCustomGroup) | Gets or sets text that is displayed in the group header.
TextHeight (inherited from C1WebTopicBarCustomGroup) | Gets or sets the height of the group header text.
ToolTip (inherited from C1WebTopicBarCustomGroup) | Gets or sets the ToolTip text displayed when the mouse pointer rests over the group.
VerticalAlign | Specifies the vertical alignment of controls within a group body.
Visible (inherited from C1WebTopicBarCustomGroup) | Gets or sets a value indicating whether the group visible or not.
WrapText (inherited from C1WebTopicBarCustomGroup) | Gets or sets a value that indicates whether the text of the items is wrapped.

Protected Properties

IsTrackingViewState (inherited from C1WebTopicBarCustomGroup) | Indicates whether the server control is saving changes to its view state.
ViewState (inherited from C1WebTopicBarCustomGroup) | View state for the group.

See Also


C1WebTopicBarPanelGroup.BodyHeight Property

C1WebTopicBarPanelGroup.BodyHeight Property

Gets or sets the height of the group body (container area where controls can be placed).

[Visual Basic]

Public Property BodyHeight As Unit

[C#]

public Unit BodyHeight {get;set;}

[Delphi]

public property BodyHeight: Unit read get_BodyHeight write set_BodyHeight;

See Also


C1WebTopicBarPanelGroup.HorizontalAlign Property

C1WebTopicBarPanelGroup.HorizontalAlign Property

Specifies the horizonal alignment of controls within a group body.

[Visual Basic]

Public Property HorizontalAlign As HorizontalAlign

[C#]

public HorizontalAlign HorizontalAlign {get;set;}

[Delphi]

public property HorizontalAlign: HorizontalAlign read get_HorizontalAlign write set_HorizontalAlign;

See Also


C1WebTopicBarPanelGroup.VerticalAlign Property

C1WebTopicBarPanelGroup.VerticalAlign Property

Specifies the vertical alignment of controls within a group body.

[Visual Basic]

Public Property VerticalAlign As VerticalAlign

[C#]

public VerticalAlign VerticalAlign {get;set;}

[Delphi]

public property VerticalAlign: VerticalAlign read get_VerticalAlign write set_VerticalAlign;

See Also


C1WebTopicBarPanelGroup Methods

C1WebTopicBarPanelGroup Methods

The methods of the C1WebTopicBarPanelGroup class are listed here. For a complete list of C1WebTopicBarPanelGroup class members, see the C1WebTopicBarPanelGroup Members topic.

Public Methods

Add

Adds the specified Control object to the Panel Group's body.

Protected Methods

MarkGroupTypeInViewState (inherited from C1WebTopicBarCustomGroup) | Marks current group in view state. For internal use.
TrackViewState (inherited from C1WebTopicBarCustomGroup) | Tracks view state.

See Also


C1WebTopicBarPanelGroup.Add Method

C1WebTopicBarPanelGroup.Add Method

Adds the specified Control object to the Panel Group's body.

[Visual Basic]

Public Sub Add( _

ByVal control As Control _

)

[C#]

public void Add(

Control control

);

[Delphi]

public procedure Add(

control: Control

);

Parameters

control

The Control object to add to the group.

Remarks

Use this property to add controls to the group programmically.

Example

Use this property to add controls to the group programmically.

See Also


C1WebTopicBarStrings Class

C1WebTopicBarStrings Class

This class includes string constants, used in other classes of WebTopicBar.

For a list of all members of this type, see C1WebTopicBarStrings Members.

System.Object

C1.Web.C1Command.C1WebTopicBarStrings

[Visual Basic]

Public Class C1WebTopicBarStrings

[C#]

public class C1WebTopicBarStrings

[Delphi]

type C1WebTopicBarStrings = class;

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1WebTopicBarStrings Members

C1WebTopicBarStrings Members

C1WebTopicBarStrings overview

See Also


C1WebTopicBarStyle Class

C1WebTopicBarStyle Class

Represents the style for a topic bar control.

For a list of all members of this type, see C1WebTopicBarStyle Members.

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Web.UI.WebControls.Style

C1.Web.C1Command.C1WebTopicBarStyle

C1.Web.C1Command.C1WebTopicBarGroupStyle

C1.Web.C1Command.C1WebTopicBarHeaderStyle

C1.Web.C1Command.C1WebTopicBarItemStyle

[Visual Basic]

Public Class C1WebTopicBarStyle

Inherits Style

[C#]

public class C1WebTopicBarStyle : Style

[Delphi]

type C1WebTopicBarStyle = class (Style);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


C1WebTopicBarStyle Members

C1WebTopicBarStyle Members

C1WebTopicBarStyle overview

Public Constructors

C1WebTopicBarStyle Constructor

Constructor. Initializes a new instance of the C1WebTopicBarStyle class.

Public Properties

BackColor (inherited from Style) | Background color of the controls applied with this style.
BorderColor (inherited from Style) | Border color of the controls applied with this style.
BorderStyle (inherited from Style) | Style of the border of controls applied with this style.
BorderWidth (inherited from Style) | Thickness of the border around the controls applied with this style.
CssClass (inherited from Style) | CSS class name applied to the user of this style.
Font (inherited from Style) | The font used for text in controls applied with this style.
ForeColor (inherited from Style) | Foreground color of the controls applied with this style.
Height (inherited from Style) | The height of the controls applied with this style.
Width (inherited from Style) | The width of the controls applied with this style.

See Also


C1WebTopicBarStyle Constructor

C1WebTopicBarStyle Constructor

Constructor. Initializes a new instance of the C1WebTopicBarStyle class.

[Visual Basic]

Public Function New( _

ByVal owner As WebControl _

)

[C#]

public C1WebTopicBarStyle(

WebControl owner

);

[Delphi]

public constructor Create(

owner: WebControl

);

Parameters

owner

The WebControl object to which the C1WebTopicBarStyle object belongs

See Also


C1WebTopicBarStyle Properties

C1WebTopicBarStyle Properties

The properties of the C1WebTopicBarStyle class are listed here. For a complete list of C1WebTopicBarStyle class members, see the C1WebTopicBarStyle Members topic.

Public Properties

BackColor (inherited from Style) | Background color of the controls applied with this style.
BorderColor (inherited from Style) | Border color of the controls applied with this style.
BorderStyle (inherited from Style) | Style of the border of controls applied with this style.
BorderWidth (inherited from Style) | Thickness of the border around the controls applied with this style.
CssClass (inherited from Style) | CSS class name applied to the user of this style.
Font (inherited from Style) | The font used for text in controls applied with this style.
ForeColor (inherited from Style) | Foreground color of the controls applied with this style.
Height (inherited from Style) | The height of the controls applied with this style.
Width (inherited from Style) | The width of the controls applied with this style.

See Also


ContextMenuTypeEnum Enumeration

ContextMenuTypeEnum Enumeration

Use the members of this enumeration to set the value of the ContextMenu property.

[Visual Basic]

Public Enum ContextMenuTypeEnum

[C#]

public enum ContextMenuTypeEnum

[Delphi]

type ContextMenuTypeEnum = (Control, Custom, Default, None);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

Members

Member name | Description
Control | Context menu appears on the control that the user specifies in the ContextControlId.
Custom | The context menu is shown when the user calls the client-side function, c1c_showContextMenu(id).
Default | Context menu appears then the user right-clicks on any area of the page.
None | The context menu will not be available in the C1WebMenu.

See Also

C1.Web.C1Command Namespace


GetSpecialSymbolEventArgs Class

GetSpecialSymbolEventArgs Class

Arguments: Item - Returns the item object associated with the event. Symbol - Returns the symbol type Style - Gets or sets the string contains inline style information is used with the symbol in HTML. Text - Gets or sets text for the symbol. ImageUrl - Gets or sets url for the symbol.

For a list of all members of this type, see GetSpecialSymbolEventArgs Members.

System.Object

System.EventArgs

C1.Web.C1Command.GetSpecialSymbolEventArgs

[Visual Basic]

Public Class GetSpecialSymbolEventArgs

Inherits EventArgs

[C#]

public class GetSpecialSymbolEventArgs : EventArgs

[Delphi]

type GetSpecialSymbolEventArgs = class (EventArgs);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


GetSpecialSymbolEventArgs Members

GetSpecialSymbolEventArgs Members

GetSpecialSymbolEventArgs overview

See Also


GetSpecialSymbolEventHandler Delegate

GetSpecialSymbolEventHandler Delegate

source - The source of the event. e - A GetSpecialSymbolEventArgs object that contains the event data.

[Visual Basic]

Public Delegate Sub GetSpecialSymbolEventHandler( _

ByVal source As Object, _

ByVal e As GetSpecialSymbolEventArgs _

)

[C#]

public delegate void GetSpecialSymbolEventHandler(

object source,

GetSpecialSymbolEventArgs e

);

[Delphi]

type GetSpecialSymbolEventHandler = procedure (

source: Object;

e: GetSpecialSymbolEventArgs

) of object;

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also

C1.Web.C1Command Namespace


HorzPopupDirectionEnum Enumeration

HorzPopupDirectionEnum Enumeration

Use the members of this enumeration to set the value of the HorzPopupDirection property.

[Visual Basic]

Public Enum HorzPopupDirectionEnum

[C#]

public enum HorzPopupDirectionEnum

[Delphi]

type HorzPopupDirectionEnum = (Auto, LeftToRight, RightToLeft);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

Members

Member name | Description
Auto | Automatic selection of submenu showing for horizontal menu.
LeftToRight | Submenus for horizontal menu will be displayed from left to right.
RightToLeft | Submenus for horizontal menu will be displayed from right to left.

See Also

C1.Web.C1Command Namespace


ItemClickEventArgs Class

ItemClickEventArgs Class

item - Source item is raised the event.

For a list of all members of this type, see ItemClickEventArgs Members.

System.Object

System.EventArgs

C1.Web.C1Command.ItemClickEventArgs

[Visual Basic]

Public Class ItemClickEventArgs

Inherits EventArgs

[C#]

public class ItemClickEventArgs : EventArgs

[Delphi]

type ItemClickEventArgs = class (EventArgs);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


ItemClickEventArgs Members

ItemClickEventArgs Members

ItemClickEventArgs overview

See Also


ItemClickEventHandler Delegate

ItemClickEventHandler Delegate

source - The source of the event. e - A ItemCommandEventArgs object that contains the event data.

[Visual Basic]

Public Delegate Sub ItemClickEventHandler( _

ByVal source As Object, _

ByVal e As ItemClickEventArgs _

)

[C#]

public delegate void ItemClickEventHandler(

object source,

ItemClickEventArgs e

);

[Delphi]

type ItemClickEventHandler = procedure (

source: Object;

e: ItemClickEventArgs

) of object;

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also

C1.Web.C1Command Namespace


ItemCommandEventArgs Class

ItemCommandEventArgs Class

commandName - The name of the command. commandArgument - The argument for the command. commandSource - The source of the event.

For a list of all members of this type, see ItemCommandEventArgs Members.

System.Object

System.EventArgs

System.Web.UI.WebControls.CommandEventArgs

C1.Web.C1Command.ItemCommandEventArgs

[Visual Basic]

Public Class ItemCommandEventArgs

Inherits CommandEventArgs

[C#]

public class ItemCommandEventArgs : CommandEventArgs

[Delphi]

type ItemCommandEventArgs = class (CommandEventArgs);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also


ItemCommandEventArgs Members

ItemCommandEventArgs Members

ItemCommandEventArgs overview

See Also


ItemCommandEventHandler Delegate

ItemCommandEventHandler Delegate

source - The source of the event. e - A ItemClickEventArgs object that contains the event data.

[Visual Basic]

Public Delegate Sub ItemCommandEventHandler( _

ByVal source As Object, _

ByVal e As ItemCommandEventArgs _

)

[C#]

public delegate void ItemCommandEventHandler(

object source,

ItemCommandEventArgs e

);

[Delphi]

type ItemCommandEventHandler = procedure (

source: Object;

e: ItemCommandEventArgs

) of object;

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

See Also

C1.Web.C1Command Namespace


MenuLayoutEnum Enumeration

MenuLayoutEnum Enumeration

Use the members of this enumeration to set the value of the MenuLayout property.

[Visual Basic]

Public Enum MenuLayoutEnum

[C#]

public enum MenuLayoutEnum

[Delphi]

type MenuLayoutEnum = (Auto, Horizontal, Vertical);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

Members

Member name | Description
Auto | Automatic selection of vertical or horizontal orientation.
Horizontal | Horizontal orientation of menus and toolbars.
Vertical | Vertical orientation of menus and toolbars.

See Also

C1.Web.C1Command Namespace


PresentationEnum Enumeration

PresentationEnum Enumeration

Determines the look and behavior settings of the C1WebTopicBar control.

[Visual Basic]

Public Enum PresentationEnum

[C#]

public enum PresentationEnum

[Delphi]

type PresentationEnum = (Button, Standard);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

Members

Member name | Description
Button | C1WebTopicBar control looks and behaves like the Outlook panel.
Standard | Standard presentation.

See Also

C1.Web.C1Command Namespace


SpecialSymbolEnum Enumeration

SpecialSymbolEnum Enumeration

Use the members of this enumeration to set the value of the Symbol property of GetSpecialSymbolEventArgs.

[Visual Basic]

Public Enum SpecialSymbolEnum

[C#]

public enum SpecialSymbolEnum

[Delphi]

type SpecialSymbolEnum = (CheckMark, RadioMark, SubMenuDown, SubMenuLeft, SubMenuRight);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

Members

Member name | Description
CheckMark | Symbol for the check mark.
RadioMark | Symbol for the radio mark.
SubMenuDown | Reserved.
SubMenuLeft | Symbol for pointer to the right submenu.
SubMenuRight | Symbol for pointer to the right submenu.

See Also

C1.Web.C1Command Namespace


SubMenuMarkEnum Enumeration

SubMenuMarkEnum Enumeration

Use the members of this enumeration to set the value of the SubMenuMark property.

[Visual Basic]

Public Enum SubMenuMarkEnum

[C#]

public enum SubMenuMarkEnum

[Delphi]

type SubMenuMarkEnum = (Auto, No, Yes);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

Members

Member name | Description
Auto | Space for SubMenu marks is shown if at least one item has submenu.
No | SubMenu marks are never shown.
Yes | Space for SubMenu marks is always shown.

See Also

C1.Web.C1Command Namespace


VertPopupDirectionEnum Enumeration

VertPopupDirectionEnum Enumeration

Use the members of this enumeration to set the value of the VertPopupDirection property.

[Visual Basic]

Public Enum VertPopupDirectionEnum

[C#]

public enum VertPopupDirectionEnum

[Delphi]

type VertPopupDirectionEnum = (Auto, BottomToTop, TopToBottom);

Namespace: C1.Web.C1Command

Assembly: C1.Web.C1Command (in C1.Web.C1Command.dll)

Members

Member name | Description
Auto | Automatic selection of submenu showing for horizontal menu.
BottomToTop | Submenus for horizontal menu will be displayed from bottom to top.
TopToBottom | Submenus for horizontal menu will be displayed from top to bottom.

See Also

C1.Web.C1Command Namespace


C1.Web.C1Command Hierarchy

C1.Web.C1Command Hierarchy

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Web.UI.WebControls.Style

C1.Web.C1Command.C1WebToolBarStyle

C1.Web.C1Command.C1WebTopicBarStyle

C1.Web.C1Command.C1WebTopicBarGroupStyle

C1.Web.C1Command.C1WebTopicBarHeaderStyle

C1.Web.C1Command.C1WebTopicBarItemStyle

System.Web.UI.Control

System.Web.UI.WebControls.WebControl

C1.Web.C1Command.C1MenuItem ---- System.Web.UI.IPostBackEventHandler

C1.Web.C1Command.C1WebToolBarControl ---- System.Web.UI.IPostBackDataHandler, System.Web.UI.IPostBackEventHandler

C1.Web.C1Command.C1WebToolBarButtonBase

C1.Web.C1Command.C1WebToolBarButton

C1.Web.C1Command.C1WebToolBarSeparator

C1.Web.C1Command.C1WebTopicBar ---- System.IDisposable, System.Web.UI.IPostBackDataHandler, System.Web.UI.IPostBackEventHandler

System.Web.UI.WebControls.Panel

C1.Web.C1Command.C1MenuBase ---- System.Web.UI.IPostBackEventHandler

C1.Web.C1Command.C1SubMenu

C1.Web.C1Command.C1WebMenu ---- System.IDisposable

C1.Web.C1Command.C1WebToolBarContainerBase ---- System.Web.UI.IPostBackDataHandler

C1.Web.C1Command.C1WebToolBar ---- System.IDisposable

C1.Web.C1Command.C1WebToolBarToggleGroupBase

C1.Web.C1Command.C1WebToolBarToggleGroup

C1.Web.C1Command.C1WebTopicBarPanelBodyHelper

C1.Web.C1Command.C1MenuItemCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList

C1.Web.C1Command.C1MenuItemCollection.C1MenuItemCollectionEnumerator ---- System.Collections.IEnumerator

C1.Web.C1Command.C1MenuItemStyle

System.ComponentModel.TypeConverter

System.Drawing.ColorConverter

System.Web.UI.WebControls.WebColorConverter

C1.Web.C1Command.C1WebCommandColorConverter

C1.Web.C1Command.C1WebCommandConsts

System.EventArgs

C1.Web.C1Command.C1WebTopicBarGroupEventArgs

C1.Web.C1Command.GetSpecialSymbolEventArgs

C1.Web.C1Command.ItemClickEventArgs

System.ComponentModel.CancelEventArgs

C1.Web.C1Command.C1WebTopicBarGroupBeforeEventArgs

System.Web.UI.WebControls.CommandEventArgs

C1.Web.C1Command.C1WebTopicBarCommandEventArgs

C1.Web.C1Command.ItemCommandEventArgs

C1.Web.C1Command.C1WebTopicBarCustomGroup ---- System.Web.UI.IStateManager

C1.Web.C1Command.C1WebTopicBarItemsGroup

C1.Web.C1Command.C1WebTopicBarPanelGroup

System.Collections.CollectionBase

C1.Web.C1Command.C1WebTopicBarGroupCollection ---- System.Web.UI.IStateManager

C1.Web.C1Command.C1WebTopicBarItemCollection ---- System.Web.UI.IStateManager

C1.Web.C1Command.C1WebTopicBarItem ---- System.Web.UI.IStateManager

C1.Web.C1Command.C1WebTopicBarStrings

System.ValueType

System.[Enum]

C1.Web.C1Command.C1WebTopicBarItemAlignEnum

C1.Web.C1Command.ContextMenuTypeEnum

C1.Web.C1Command.HorzPopupDirectionEnum

C1.Web.C1Command.MenuLayoutEnum

C1.Web.C1Command.PresentationEnum

C1.Web.C1Command.SpecialSymbolEnum

C1.Web.C1Command.SubMenuMarkEnum

C1.Web.C1Command.VertPopupDirectionEnum

System.[Delegate]

System.MulticastDelegate

C1.Web.C1Command.C1WebTopicBarCommandEventHandler

C1.Web.C1Command.C1WebTopicBarGroupBeforeEventHandler

C1.Web.C1Command.C1WebTopicBarGroupEventHandler

C1.Web.C1Command.GetSpecialSymbolEventHandler

C1.Web.C1Command.ItemClickEventHandler

C1.Web.C1Command.ItemCommandEventHandler

See Also

C1.Web.C1Command Namespace


C1WebCommand ClientScript- C#

C#

item.ClientScripts[“onmousedown”] = “alert(‘mouse down’)”;


C1WebCommand ClientScript - Delphi

Delphi

Item.ClientScripts[‘onmousedown’]:= 'alert(‘’mouse down’’)';


C1WebCommand ClientScript- Visual Basic

Visual Basic

item.ClientScripts(“onmousedown”) = “alert(‘mouse’)”


C1WebCommand Declare Objects - C#

C#

// Define a new object of your C1WebMenu class type.

myWebMenu as C1WebMenu;

// Define a new C1.Web.C1Command.C1WebMenu object.

c1WebMenu as C1.Web.C1Command.C1WebMenu;


C1WebCommand Declare Objects - Delphi

Delphi

// Define a new object of your C1WebMenu class type.;

myWebMenu: C1WebMenu;

// Define a new C1.Web.C1Command.C1WebMenu object.;

c1WebMenu: C1.Web.C1Command.C1WebMenu;


C1WebCommand Declare Objects - Visual Basic

Visual Basic

' Define a new object of your C1WebMenu class type.

Dim myWebMenu as C1WebMenu

' Define a new C1.Web.C1Command.C1WebMenu object.

Dim c1WebMenu as C1.Web.C1Command.C1WebMenu


C1WebCommand GetSpecialSymbol event - C#

C#

private void C1WebMenu1_GetSpecialSymbol(object source, C1.Web.C1Command.GetSpecialSymbolEventArgs e)

{

if (e.Symbol == C1.Web.C1Command.SpecialSymbolEnum.SubMenuRight)

{

e.Style = "color:red;text-align:right;";

e.Text = ">>";

}

}


C1WebCommand GetSpecialSymbol event - Delphi

Delphi

Procedure C1WebMenu1_GetSpecialSymbol(Sender: Object; e: C1.Web.C1Command.GetSpecialSymbolEventArgs)

begin

if (e.Symbol = C1.Web.C1Command.SpecialSymbolEnum.SubMenuRight) then

begin

e.Style := 'color:red;text-align:right;';

e.Text := '>>';

end

end


C1WebCommand GetSpecialSymbol event - Visual Basic

Visual Basic

Private Sub C1WebMenu1_GetSpecialSymbol(ByVal sender As Object, ByVal e As C1.Web.C1Command.GetSpecialSymbolEventArgs) Handles C1WebMenu1.GetSpecialSymbol

If (e.Symbol = C1.Web.C1Command.SpecialSymbolEnum.SubMenuRight) Then

e.Style = "color:red;text-align:right;"

e.Text = ">>"

End If

End Sub


C1WebCommand Imports - C#

C#

using C1WebMenu = C1.Web.C1Command.C1WebMenu;

using MyWebMenu = MyProject.Objects.C1WebMenu;

C1WebMenu wm1;

MyWebMenu wm2;


C1WebCommand Imports - Delphi

Delphi

C1WebMenu := C1.Web.C1Command.C1WebMenu;

MyWebMenu := MyProject.Objects.C1WebMenu;

wm1: C1WebMenu;

wm2: MyWebMenu;


C1WebCommand Imports - Visual Basic

Visual Basic

Imports C1WebMenu = C1.Web.C1Command.C1WebMenu

Imports MyWebMenu = MyProject.Objects.C1WebMenu

Dim wm1 As C1WebMenu

Dim wm2 As MyWebMenu


C1WebCommand NameSpaces - C#

C#

C1.Web.C1Command.C1WebMenu webMenu;


C1WebCommand NameSpaces - Delphi

Delphi

webMenu: C1.Web.C1Command.C1WebMenu;


C1WebCommand NameSpaces - Visual Basic

Visual Basic

Dim webMenu As C1.Web.C1Command.C1WebMenu


C1WebCommand TBH - Adding a menu item in code step 1 - C#

C#

using C1.Web.C1Command;


C1WebCommand TBH - Adding a menu item in code step 1 - Delphi

Delphi

uses C1.Web.C1Command;


C1WebCommand TBH - Adding a menu item in code step 1- Visual Basic

Visual Basic

Imports C1.Web.C1Command


C1WebCommand TBH - Adding a menu item in code step 2 - C#

C#

item = new C1MenuItem();


C1WebCommand TBH - Adding a menu item in code step 2 - Delphi

Delphi

var

item: C1.Web.C1Command.C1MenuItem;

begin

item:=C1.Web.C1Command.C1MenuItem.Create;


C1WebCommand TBH - Adding a menu item in code step 2 - Visual Basic

Visual Basic

Dim item As New C1.Web.C1Command.C1MenuItem


C1WebCommand TBH - Adding a menu item in code step 3 - C#

C#

item.Text = "Search the Web";


C1WebCommand TBH - Adding a menu item in code step 3 - Delphi

Delphi

item.Text:= 'Search the Web';


C1WebCommand TBH - Adding a menu item in code step 3 - Visual Basic

Visual Basic

item.Text = "Search the Web"


C1WebCommand TBH - Adding a menu item in code step 4 - C#

C#

C1WebMenu1.Items.Add(item);


C1WebCommand TBH - Adding a menu item in code step 4 - Delphi

Delphi

C1WebMenu1.Items.Add(item);


C1WebCommand TBH - Adding a menu item in code step 4 - Visual Basic

Visual Basic

C1WebMenu.Items.Add(item)


C1WebCommand TBH - Adding a submenu item in code - C#

C#

C1SubMenu submenu = item.AddSubMenu();


C1WebCommand TBH - Adding a submenu item in code - Delphi

Delphi

var

submenu: C1SubMenu;

begin

submenu:= item.AddSubMenu;


C1WebCommand TBH - Adding a submenu item in code - Visual Basic

Visual Basic

Dim submenu As C1SubMenu = item.AddSubMenu


C1WebCommand TBH - Adding HTML tags - C#

C#

item.Text = "<b><font size='-1'>Search the web</font></b>";


C1WebCommand TBH - Adding HTML tags - Delphi

Delphi

item.Text := '<b><font size='-1'>Search the web</font></b>';


C1WebCommand TBH - Adding HTML tags - Visual Basic

Visual Basic

item.Text = "<b><font size='-1'>Search the web</font></b>"


C1WebCommand TBH - Adding items to the submenu in code step1 - C#

C#

item = new C1MenuItem();


C1WebCommand TBH - Adding items to the submenu in code step1 - Delphi

Delphi

var

item: C1.Web.C1Command.C1MenuItem;

begin

item:=C1.Web.C1Command.C1MenuItem.Create;


C1WebCommand TBH - Adding items to the submenu in code step1 - Visual Basic

Visual Basic

Dim item As New C1.Web.C1Command.C1MenuItem


C1WebCommand TBH - Adding items to the submenu in code step2 - C#

C#

Item.ID = "SubmenuItemCNN";


C1WebCommand TBH - Adding items to the submenu in code step2 - Delphi

Delphi

Item.ID:= 'SubmenuItemCNN';


C1WebCommand TBH - Adding items to the submenu in code step2 - Visual Basic

Visual Basic

Item.ID = "SubmenuItemCNN"


C1WebCommand TBH - Adding items to the submenu in code step3 - C#

C#

submenu.Items.Add(item);


C1WebCommand TBH - Adding items to the submenu in code step3 - Delphi

Delphi

submenu.Items.Add(item);


C1WebCommand TBH - Adding items to the submenu in code step3 - Visual Basic

Visual Basic

submenu.Items.Add(item)


C1WebCommand TBH - Loading an xml menu step1 - C#

C#

using System.Xml;


C1WebCommand TBH - Loading an xml menu step1 - Delphi

Delphi

uses System.Xml;


C1WebCommand TBH - Loading an xml menu step1 - Visual Basic

Visual Basic

Imports System.Xml


C1WebCommand TBH - Loading an xml menu step2 - C#

C#

private void Page_Load(object sender, System.EventArgs e)

{

XmlTextReader xtr = new XmlTextReader(Page.MapPath("MenuTree.xml"));

C1WebMenu1.LoadTree(xtr, true);

xtr.Close();

}


C1WebCommand TBH - Loading an xml menu step2 - Delphi

Dephi

procedure WebForm1.Page_Load(sender: System.Object; e: System.EventArgs);

var

xtr: XmlTextReader;

begin

xtr := XmlTextReader.Create(Self.Page.MapPath('MenuTree.xml'));

Self.C1WebMenu1.LoadTree(xtr, True);

xtr.Close;

end;


C1WebCommand TBH - Loading an xml menu step2 - Visual Basic

Visual Basic

Private Sub Page_Load(ByVal sender As Object, ByVal e As System.EventArgs)

Dim xtr As New XmlTextReader(Page.MapPath("MenuTree.xml"))

C1WebMenu1.LoadTree(xtr, True)

xtr.Close()

End Sub 'Page_Load


Untitled Document

Send comments about this topic to ComponentOne.
Copyright © ComponentOne LLC. All rights reserved.


Untitled Document

 ComponentOne WebMenus and WebBars for ASP.NET


Untitled Document

 E-mail sent to documentation@componentone.com is for documentation feedback only. We welcome any suggestions to help improve our documentation.