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Release notes
Thank you for using IDERA DB Change Manager, an essential database change management tool for DBAs and data 
professionals. It uniquely offers automated compare and synchronization capabilities to simplify change 
operations, allows you to rapidly identify changes and streamline upgrades to new releases, and helps you pinpoint 
environmental differences resulting from changes at the data, schema and database configuration levels.

To get a quick glimpse into the newest features, fixed issues, and known issues in this release of DB Change 
Manager, review the following sections of the Release Notes:

Learn about key new features in this release
Review issues fixed by this release
See what was introduced or fixed in previous releases
Read important notes before upgrading
See known issues

http://www.idera.com/
http://www.idera.com/productssolutions/sqlserver
https://www.idera.com/buynow/onlinestore
https://idera.secure.force.com/
http://community.idera.com/
http://www.idera.com/resourcecentral
http://www.idera.com/about/aboutus
https://www.idera.com/legal/termsofuse
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New features and fixed issues
DB Change Manager provides the following new features and fixed issues. For items introduced or fixed in an earlier 
release, see Previous features and fixed issues.

18.4 New features

Adds native Git support
DBArtisan now includes native Git version control. You must have Git installed on the system where you want to use 
DBArtisan to utilize the native Git version control functionality.

Users may use Git version control to:

create projects
get the latest version
add a file or project
remove a file or project
check in a file or project
get history logs of files

Supports SQL Server 2022
DBArtisan 18.4 includes support for SQL Server 2022.

Improves space, capacity, and performance for Azure SQL and PostgreSQL
This release of DBArtisan includes updates that improve space, capacity, and performance for Azure SQL and 
PostgreSQL.

Includes sign-on for AzureAD for PostgreSQL, MySQL, and SQL Server
DBArtisan now includes sign-on capability for AzureAD for PostgreSQL, MySQL, and SQL Server.

Includes support for PostgreSQL identity columns
DBArtisan now includes support for PostgreSQL identity columns.

Updates Azure SQL for Data Copying in DB Change Manager
DB Change Manager/Data Compare includes updated support for Azure SQL for data copying.

18.4 Fixed issues

Issue Number Description DBMS

DBA-34810 Output from migration does not create table DB/2

http://www.idera.com/
http://www.idera.com/productssolutions/sqlserver
https://www.idera.com/buynow/onlinestore
https://idera.secure.force.com/
http://community.idera.com/
http://www.idera.com/resourcecentral
http://www.idera.com/about/aboutus
https://www.idera.com/legal/termsofuse
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Issue Number Description DBMS

DBA-34792 Error message "Incorrect syntax near 'Index'" 
appears when dropping the Foreign Key between 
two tables

SQL Server

DBA-34788 Unable to drop an index on Azure SQL DB Azure SQL

DBA-34784 Descending sort order is missing when editing 
properties of an index

Azure SQL, Oracle

http://www.idera.com/
http://www.idera.com/productssolutions/sqlserver
https://www.idera.com/buynow/onlinestore
https://idera.secure.force.com/
http://community.idera.com/
http://www.idera.com/resourcecentral
http://www.idera.com/about/aboutus
https://www.idera.com/legal/termsofuse
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Previous features and fixed issues
18.3 New features
18.3 Fixed issues
18.2 New features
18.2 Fixed issues
18.1 New features
18.1 Fixed issues
18.0 New features & fixed issues

18.3 New features

Updates Azure cloud monitoring capability in DBArtisan
The monitoring capability for Microsoft Azure cloud is updated in DBArtisan. This functionality includes multi-
tabbed process monitoring and management as well as allows you to catch performance issues before they arise.

Supports the latest version of Log4j
DB PowerStudio 18.3 includes support for the latest version of Apache Log4j, which is essential for proper logging 
and diagnostics of applications. 

Improves multiple areas within DBArtisan and Rapid SQL
DB PowerStudio 18.3 includes updates to the following areas within DBArtisan and Rapid SQL:

Extraction operations on roles for PostgreSQL allows users to have higher control over their data security.
Handling procedures with cascaded parameters on Redshift provides additional usage options with those 
parameters.
Connections to Azure SQL using multi-factor authentication provides more secure access.
Connections to PostgreSQL via Java Database Connectivity (JDBC) provides native connectivity for quicker 
access.
Reordering columns for Data Definition Language (DLL) validation allows the flexibility to rerun or reuse in 
scripts.

Improves multiple areas within DB Change Manager
Validation of Dump Devices, Linked Servers, Remote Servers and Server Triggers on Azure enables higher 
quality of those features.
Reuse of connection settings on logins when a node is accessible in SQL Server Management Studio (SSMS) 
allows faster user connections.
Fully populating database nodes on Azure for completeness.

Updates profiling session capability in DB Optimizer
DB Optimizer 18.3 updates profiling session capability, which alerts users to potentially problematic SQL ahead of 
time.

http://www.idera.com/
http://www.idera.com/productssolutions/sqlserver
https://www.idera.com/buynow/onlinestore
https://idera.secure.force.com/
http://community.idera.com/
http://www.idera.com/resourcecentral
http://www.idera.com/about/aboutus
https://www.idera.com/legal/termsofuse
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18.3 Fixed issues

Issue Number Description DBMS

DBA-34744 Log4J Upgrade all of DB PowerStudio

DBA-34743 DDL validation failing after reordering columns Oracle

DBA-34682 Windows Authentication not working with 
Access Analyst

SQL Server

DBA-34605 Cannot connect to Azure SQL using MFA Azure SQL

DBA-34524 Receiving an error when trying to connect to 
PostgreSQL

PostgreSQL

DBA-34244 User would like additional features for Azure 
support

Azure SQL

OPT-5352 Profiling session does not finish and seems to 
stall

Sybase ASE

18.2 New features

Adds support for Snowflake in DBArtisan and Rapid SQL
DB PowerStudio 18.2 adds support for Snowflake in DBArtisan and Rapid SQL.

Adds support for Windows 11
DB PowerStudio now supports the Microsoft Windows 11 operating system.

Updates database platform support in DBArtisan and Rapid SQL
This release of DB PowerStudio includes updated support in DBArtisan and Rapid SQL for the following database 
platforms:

DB2 LUW 11.5
Sybase IQ 16.1

Updates trial licensing in DB Optimizer
This release of DB PowerStudio includes updated trial licensing support for DB Optimizer to limit the number of 
suggestions a user can submit.

http://www.idera.com/
http://www.idera.com/productssolutions/sqlserver
https://www.idera.com/buynow/onlinestore
https://idera.secure.force.com/
http://community.idera.com/
http://www.idera.com/resourcecentral
http://www.idera.com/about/aboutus
https://www.idera.com/legal/termsofuse
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18.2 Fixed issues

Issue Number Description DBMS

DBA-34677 Issue when importing .xlsx files in DBArtisan 18.0 Sybase ASE

DBA-34675 Issue when opening tables in the DB2 Servers 
database

DBA-34674 Issue in DBArtisan when using Audit Unified Policies 
tree nodes in Oracle 19c and 21c

Oracle

DBA-34673 Performance issues in DBArtisan 18.0 Oracle

DBA-34672 DBArtisan is missing security roles and MQT 
extraction

DB2 for LUW

DBA-34667 Sybase ASE Data Cache window does not properly 
show bound objects in the cache

Sybase ASE

DBA-34666 DBArtisan displays incorrect Create Date for 
individual logins

Sybase ASE

DBA-34665 DBArtisan does not recognize "lockless" cache 
types

Sybase ASE

DBA-34662 Permissions error when using Capacity Analyst Sybase ASE

18.1 New features

Adds support for Oracle 21c and PostgreSQL 13 in DBArtisan and Rapid SQL
DBArtisan and Rapid SQL 18.1 add support for Oracle 21c and PostgreSQL 13. This release also includes a number of 
fixed issues that you may review in the Release Notes.

18.1 Fixed issues
There are no new features in this release of DB Change Manager, but there are the following fixed issues in DB 
PowerStudio.

http://www.idera.com/
http://www.idera.com/productssolutions/sqlserver
https://www.idera.com/buynow/onlinestore
https://idera.secure.force.com/
http://community.idera.com/
http://www.idera.com/resourcecentral
http://www.idera.com/about/aboutus
https://www.idera.com/legal/termsofuse
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Issue Number Description DBMS

DBA-34651 Update OpenJDK 11.0.7 to the latest OpenJDK 
11 release

DBA-34650 Update PostgreSQL support to version 13 PostgreSQL

DBA-34649 Update Oracle support to version 21c Oracle

DBA-34646 Provide ability to open multiple files from the 
command line

DBA-34644 Sybase ASE Syntax Drop Login, Alter Login not 
presenting with DDL Extract

Sybase ASE

RAP-6189 Format SQL Clears out commands Sybase ASE

RAP-6188 Stored Procedure is not extracting correctly 
with Rapid SQL 17.1.1

Oracle, SQL Server

18.0 New features & fixed issues
There are no new features in this release of DB Change Manager, but there are the following fixed issues.

Issue Number Description

SC-14793 Comparison Results tab user interface is incorrect

SC-14784 Stored Procedures comparison shows there are differences but View 
Differences shows none

SC-14783 Date comparison between Oracle and SQL Server is incorrect

SC-14782 Change Manager reports differences of the CREATE line when running 
a live comparison

SC-14771 Simple Alter is allowed for a default change and making a decimal 
bigger, but Change Manager chooses Extended Alter for both the 
Extended Alter and Simple Alter

SC-14765 Schema Comparison displays different results

http://www.idera.com/
http://www.idera.com/productssolutions/sqlserver
https://www.idera.com/buynow/onlinestore
https://idera.secure.force.com/
http://community.idera.com/
http://www.idera.com/resourcecentral
http://www.idera.com/about/aboutus
https://www.idera.com/legal/termsofuse
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Known issues
The following table lists issues that currently exist in DB Change Manager.

Issue Number Description DBMS

SC-14764 Errors coming up for schema comparison job 
movies_dev to movies_prod

Oracle

SC-14757 Configuration compare job does not save work Oracle

SC-14626 NullPointer exception while generating report once 
Schema Archive Job completed

http://www.idera.com/
http://www.idera.com/productssolutions/sqlserver
https://www.idera.com/buynow/onlinestore
https://idera.secure.force.com/
http://community.idera.com/
http://www.idera.com/resourcecentral
http://www.idera.com/about/aboutus
https://www.idera.com/legal/termsofuse


IDERA DB Change Manager 18.4

IDERA|Products|Purchase|Support|Community|Resources|About Us|Legal

18

•
•
•

•

•
•
•
•
•
•
•

•

•
•

•

•
•
•

•

•
•
•

•

Welcome to DB Change Manager
IDERA DB Change Manager helps database administrators and developers to:

Simplify and automate database change management.
Streamline development cycles.
Ensure availability, performance, and compliance.

DB Change Manager provides comparison, synchronization, data masking, and auditing capabilities that let you 
track and report on changes, roll out new releases, and pinpoint problems resulting from changes at the data, 
schema, and database configuration levels. 

By comparing a live database to a schema or configuration “snapshot,” administrators can quickly identify changes 
and correct problems. By monitoring configuration settings, administrators can ensure compliance with regulatory 
policies and performance standards and maintain overall database performance and availability.

What can you do with DB Change Manager?
This topic describes what you can do with DB Change Manager and links to more detailed information about how to 
perform the tasks. In addition, DB Change Manager includes step-by- step Eclipse-style cheat sheets to help you 
learn the tasks.

Complete Commonly-performed tasks. These tasks describe basic functions and help you use DB Change 
Manager most effectively. In addition, you can customize the interface using preferences. See 
the Preferences reference for details.

Registering and organizing data sources
Creating a job report
Scheduling a job
Filtering data source objects
Searching for database objects and synchronization scripts
Viewing Change History
Exporting and importing jobs

Compare and synchronize data. Data Comparison jobs help you manage data changes and synchronize 
changes between databases.

Comparing data
Synchronizing data repositories

Compare and synchronize schemas. In DB Change Manager you can select schema objects and types, 
compare them across data sources, and synchronize them to each other. You can also create a snapshot or 
archive of the schema objects, to use in a comparison or to save for future reference. In addition, you can 
clone schema comparison jobs to make it easier to reuse existing jobs.

Comparing schemas, including how to clone a schema comparison job
Synchronizing schemas
Creating a schema archive

Manage database configurations. DB Change Manager helps you keep track of database settings and 
version information; such as patch levels. You can define database configuration values and ranges and then 
run a configuration comparison job to check for compliance against those parameters.

Comparing database configuration settings
Creating a standard for configuration settings
Creating a configuration archive

Create masked data for development environments. Protecting personally identifiable information while 
having accurate data for testing can be difficult. DB Change Manager lets you create a masked copy of 
production data for use during development and testing. This way the data is functionally correct and at the 
same time does not compromise privacy or security.

http://www.idera.com/
http://www.idera.com/productssolutions/sqlserver
https://www.idera.com/buynow/onlinestore
https://idera.secure.force.com/
http://community.idera.com/
http://www.idera.com/resourcecentral
http://www.idera.com/about/aboutus
https://www.idera.com/legal/termsofuse
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Masking data
Automate and script jobs. You may need some jobs to run on a regular basis without using Windows Task 
Scheduler (as described in Scheduling a job.) The Script Wizard lets you define scripts that run jobs, and 
batch files to run multiple scripts.

Scheduling a job
Generating command line scripts

http://www.idera.com/
http://www.idera.com/productssolutions/sqlserver
https://www.idera.com/buynow/onlinestore
https://idera.secure.force.com/
http://community.idera.com/
http://www.idera.com/resourcecentral
http://www.idera.com/about/aboutus
https://www.idera.com/legal/termsofuse
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Getting started
DB Change Manager provides features to help you manage databases from development to deployment and 
maintenance cycles. These features include:

Data comparison and synchronization
Schema comparison and synchronization
Database configuration management
Reports, notifications, and change history
Data masking
Source control system integration

Data comparison and synchronization
DB Change Manager can analyze and compare the data in two different data sources. It generates a SQL script that 
can update one data source so that it matches another. You can modify the SQL and run it as you wish. You can 
even define a comparison and synchronization process, called a job, and set it to run automatically. These features 
help you better manage common scenarios, such as:

Keeping primary and backup data in sync
Keeping up with data changes during the development and testing cycles, and later on to deployment 
environments
Managing data migrations during upgrade activities

Schema comparison and synchronization
DB Change Manager can capture and compare the database schema in your enterprise. Over the lifecycle of a single 
schema, you can capture a baseline or archive schema and analyze changes through time. In addition, DB Change 
Manager generates a SQL script that can update a target schema so that it matches a standard. You can modify the 
SQL and execute it as needed.

Database configuration management
In addition to schema, there are configuration settings that can vary across an enterprise. DB Change Manager can 
capture the configuration settings of a data source. You can capture a baseline or archive configuration and analyze 
changes through time. You can create a configuration standard that defines the norms for your enterprise and 
against which you can compare your databases.

Reports, notifications, and change history
DB Change Manager supports your data management activities with notifications when processes execute, reports 
that capture key information, and change history tracking.

Data masking
There are specific scenarios when you need to hide the true values of the data in a database. For example, during 
development you need to protect personal or proprietary data, yet you still need to work with data that accurately 
represents the source. By combining data synchronization with data masking features, such as randomization or 
shuffling, you can duplicate source data and use the masked copies in non-production or non-secure environments.
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Source control system integration
You can integrate DB Change Manager with source control systems such as Concurrent Versions System (CVS), 
Visual Source Safe (VSS), or Eclipse plugins. The Navigator in DB Change Manager is the interface for accessing files 
under source control. Job files and archive versions are stored as XML files and synchronization scripts are stored as 
text files. You perform all source code control actions using the source control system.
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Product requirements and database support
For the latest list of product requirements and database support, see DB Change Manager Technical Specifications.

Eclipse plugin support
If you choose to install the Eclipse plugin version, you also need the following items:

Eclipse 3.6+
Sun Java Standard Edition 6, Update 45+
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Upgrade notes
Install this release of DB Change Manager in a different directory than previous version. If DB Change 
Manager is installed in the same directory, the following error appears at application start up, "Unable to 
read workbench state. Workbench UI layout will be reset."
If one of the conflicting versions is already installed on your machine, either change the default Workspace 
or delete all files from the Workspace directory. The Workspace directory location appears whenever you 
start DB Change Manager and can be redefined from this dialog box. If the same Workspace is indicated for 
the new version, as was indicated previously, the following error will result, "Cannot restore workbench 
layout."
If DB Change Manager is already running, you can also modify the Workspace directory by choosing File > 
Switch Workspace > Other from the Main menu.
The format in which schema comparisons are saved changed in 6.x. Use the import feature to import pre-6.0 
schema comparison jobs.
Beginning with version 17.0, DB Change Manager provides an upgrade process for moving jobs and other 
information from an existing DB Change Manager 4.0, 5.0, 5.1.x, 5.5.x or 5.6 installation. No upgrade process 
is required to move from 6.x installations to this release of DB Change Manager.

Upgrading from Version 5.0, 5.1.x, 5.5.x or 5.6 to DB Change Manager 2016 (6.3.3) 
and later
You can import all objects from version 5.0, 5.1.x, 5.5.x or 5.6 to DB Change Manager 2016 (6.3.3) and later.

To upgrade from 5.0, 5.1.x, 5.5.x or 5.6:

Make sure that the earlier product is not running and that no command line jobs are being processed.
Install and run this release of DB Change Manager in a different directory than the previous installation.
The Welcome to DB Change Manager dialog opens with the Setup and Import data sources, jobs, and 
settings from a previous version import options selected.
Click Get Started to launch the Import Wizard. Alternatively, you can launch the Import Wizard from the 
main menu using the following steps:

Select File > Import.
Select Change Manager Workspace from the IDERA group, and then click Next.

Select the version of DB Change Manager from which to import.
Select the location of your DB Change Manager workspace. The default value is the default workspace, so 
you need to change this value only if you configured DB Change Manager to store the workspace in a custom 
location. The wizard imports the items from the previous DB Change Manager version.
Click Next to continue through each step of the wizard.
Click Finish. The jobs are imported to this release of DB Change Manager.

Upgrading from Version CMSchema 4.0 or CMData/Config 4.0 to this release of DB 
Change Manager
You can import the following objects from version 4.0:

data sources
all comparison jobs (data, configuration, and schema)

You do not have to upgrade to 5.6, and then to DB Change Manager 17.1. The import procedure is the 
same.


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configuration archives
configuration standards

You cannot import the following objects from version 4.0:

schema archive versions
synchronization scripts
reports
command line automation (scheduled jobs, batch files, etc.)

To upgrade from CM Schema 4.0:

To import schema comparison jobs from 4.0, obtain and install cmschema_40_932_upgrade.exe from your 
IDERA Technical Support representative.
Run cmschema_40_932_upgrade.exe to convert the schema component jobs from version 4.0 to 5.0, which 
uses an XML-based format.
Follow the steps as described in the previous section, Upgrading from Version 5.0, 5.1.x, 5.5.x or 5.6 to DB 
Change Manager 2016 (6.3.3) and later.

4.0 should remain installed to access any archives and reports.
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Installing DB Change Manager
To install DB Change Manager on a workstation, run the installer and follow the prompts provided by the 
Installation Wizard. When the installation is complete, see the ReadMe file for known issues or advisory notes that 
could affect your use of the product.

Installing DB Change Manager in an AppWave environment
If you are a DB Change Manager user and your System Administrator provides you with AppWave, then your System 
Administrator enables DB Change Manager in your AppWave Browser. Consult your System Administrator and the 
AppWave Browser online help for details.
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Licensing DB Change Manager
DB Change Manager supports the following types of licenses:

Trial licenses. A license for a time-limited, full-featured trial version of the product. You must register the 
trial license before you can use the product.
Workstation licenses. A license or set of licenses that is tied to a particular workstation. The product can 
only be used on that workstation.
AppWave licenses. AppWave licenses are normally concurrent licenses managed by your System 
Administrator. See your System Administrator for details.

Registering a Trial or Workstation license at application startup
Shortly after downloading a trial version of an IDERA product, you should receive an email from IDERA containing a 
serial number, which must be registered. These instructions also apply if you have purchased a product and 
received a serial number prior to running the application for the first time, or if the trial period expired.

To register a serial number at application startup

Start the application. The License Registration dialog appears.
Copy the serial number from the email, and then paste it into Serial Number.
Enter your Developer Network (EDN) account credentials in the Login, or in the Email and Password fields.
If you have not previously created an EDN account, or have forgotten your password, click I need to 
create ... or I’ve lost my password.
Click Register.

The activation file should automatically download and install. If this does not happen, click the Trouble 
Connecting? Try Web Registration link and follow the prompts.

Registering a Workstation license after application startup
The following instructions assume that you have received a workstation license by email and that you currently 
have a valid trial license. If you did not install a trial version or if the trial period has expired, follow the instructions 
in Registering a Tri al or Workstation License at Application Startup instead.

To register a serial number after application startup

Click Help > Launch License Manager. 
The License Manager dialog appears. 
In the License Manager dialog, click Serial > Add.
Copy the serial number from the email, and then paste it into the Add Serial Number dialog.
Click OK.
Expand Unregistered Serial Numbers, right-click the serial number just added, and then click Register. 
A registration dialog appears.

Ensure that Register using Online Registration is selected.
Provide Developer Network credentials in the Login field, or into the Email and Password fields.
Click Register. 
The activation file should download and install automatically. If this does not happen, click the Trouble 
Connecting? Try Web Registration link and follow the prompts.

The Registration Code box shows a machine-specific identifier required with other registration 
methods.


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Registering by phone
If you have problems with either of the above procedures, you can register licenses by phone. You must provide the 
following information:

Developer Network credentials;
registration code displayed in the License Registration dialog that appears when you start an unlicensed 
application;
product base license serial number; and
license serial numbers for any additional features purchased

For North America, Latin America, and Asia Pacific: call (415) 834-3131 option 2, and then follow the prompts. 
The hours are Monday to Friday, 6:00 A.M. to 6:00 P.M. Pacific time.

For Europe, Africa, and the Middle East: Call +44 (0)1628-684 494. The hours are Monday to Friday, 9 A.M. to 5:30 
P.M. U.K. time.

After phoning in, you will receive an email containing an activation file to import into DB Change Manager.

To import an activation file

Save the activation file from the email to the desktop or to a scratch directory such as c:\temp.
From within the application, click Help > IDERA Licensing > License Registration.
Click License > Import.
Navigate to the directory where you saved the activation file and then double-click the activation
Click the Import button to import the activation
Click Finish.
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Key concepts of DB Change Manager
Understanding jobs and scripts in DB Change Manager
Understanding the DB Change Manager User Interface

Understanding jobs and scripts in DB Change Manager
DB Change Manager uses the concept of a job to organize reusable processes. A job uses objects of the following 
types:

Data source. A data source is a data repository or database.
Configuration standard. A standard is a customized set of properties with threshold operators that help 
you create optimal configurations against which you can compare other data source configurations.
Schema or configuration archive. An archive is a snapshot of a configuration or schema.

You can use this archive to compare against other schemas or configurations.

There are two types of jobs in DB Change Manager:

Object creation jobs. Some jobs create objects that are used in other jobs. You use a job to create 
configuration standards and archives.
Comparison jobs. Processes source and target objects and provides information describing their similarities 
and differences. This comparison is then used to generate SQL scripts. A comparison job can be of the 
following types:

Data comparison. Looks at the data repositories of two data sources and determines their 
differences. You can use this information to determine whether to update a target data source.
Data masking. A special kind of data comparison job that creates a copy of sensitive data, which 
masks the true values of specified fields.
Configuration comparison. Determines whether the configuration settings between a source and a 
target are the same. This information helps you quickly diagnose problems.
Schema comparison. Lets you compare the schemas of different data sources or archives. It helps 
you manage schema changes through development, testing, and production cycles.

Once it has run a comparison job, DB Change Manager can generate an SQL synchronization script that can update 
target data, configurations, or schemas. You can modify a script before you run it. For example, you can use a DB 
Change Manager script to synchronize data between development and testing environments. Once you are 
comfortable with the job’s specifications, you can let it automatically run the script and synchronize the data.

You can group jobs and scripts into projects, which are visible in the Project explorer and in the Navigator view. The 
Navigator view provides a way to interact with files in a source control system.

Understanding the DB Change Manager User Interface
The Workbench is the DB Change Manager development environment. It provides you with an interface to create, 
manage, and navigate comparison jobs through interaction with views, editors, and menus. If you are familiar with 
Eclipse you will recognize many elements of the interface.
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The Welcome Page is the first screen you see when you initially launch the application. The screen provides links to 
information that may be of value to new users.

Views help you navigate a hierarchy of information, open editors, or display the properties of various application 
elements. For example, the Data Source Explorer view provides a tree of all data sources in the environment and the 
comparison jobs associated with each. You can launch these jobs directly, modify the connection properties of data 
sources, or create and edit configuration archives from the view.

Editors help you perform various tasks, such as running a job. For example, you use the Schema Comparison Job 
editor to define and execute schema comparison jobs.

The Menu Bar and Command Toolbar options provide various functions, such as launching views and editors, 
navigating, and setting preferences.
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Tutorials for DB Change Manager

This section guides you through the key features of DB Change Manager using the following step-by-step tutorials:

Tutorial 1: Comparing data
Tutorial 2: Synchronizing data
Tutorial 3: Comparing configurations
Tutorial 4: Defining a configuration standard
Tutorial 5: Comparing and synchronizing schemas
Tutorial 6: Defining a schema archive
Tutorial 7: Masking data
Tutorial 8: Defining and running automated scripts

Before working with tutorials, identify two data sources that you can use for practice. These data sources 
should not be live or mission-critical, and they should be similar in schema and data.


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Tutorial 1: Comparing data

Data comparison jobs automate the process of comparing and correcting data between data sources at the 
database, table, and row level. You select a source and a target data source from Data Source Explorer, map 
databases and tables between the two selections, and then run the comparison job.

DB Change Manager compares the information and returns a results screen with details including:

An overall percentage of the data that is the same between the source and target
Discrepancies between the two databases, such as data values that exist on only one

Once a data comparison job has run, you can then correct any synchronization issues by running an automatically-
generated SQL script that adds missing rows and updates out-of-sync values. You can modify the SQL script prior to 
running it, and store it for future use.

To start Change Manager

Start Change Manager using the Start menu’s IDERA DB Change Manager [version] item.

When DB Change Manager first starts, it displays a Welcome screen. Review the Welcome screen options, and then 
close it.

Adding data sources
In order to define and run jobs, you first register data sources by providing connection information and other details 
to DB Change Manager. Once a data source has been registered, it remains stored in a catalog and does not need to 
be reregistered each time you open DB Change Manager. You can use a single registered data source in multiple 
jobs.

Data Source Explorer shows the registered data sources and their associated jobs, if any. Before registering a data 
source, gather the information about the repository location and connectivity permissions.

To add a data source

Click the Discover Data Sources icon at the top of the Data Source Explorer view.

Before working with tutorials, identify two data sources that you can use for practice. These data sources 
should not be live or mission-critical, and they should be similar in schema and data.


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In the Discover Data Sources wizard, select the locations to search for data sources, and then click Next.

Select the data sources you want to add to the DB Change Manager environment, and then click Finish.

The new data source or sources appear in the Data Source Explorer.

An alternative to using the Discover Data Sources wizard is to click File > New Data Source and set 
its connection properties.


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1.

In the Data Source Explorer, right-click on a data source and select Properties to work with connection 
properties for the datasource.

Creating a data comparison job
Prior to performing the following steps, make sure you have at least two data sources registered in DB Change 
Manager. Ideally these two data sources are similar in schema and content, so that the comparison is meaningful to 
you.

To create a data comparison job in the Overview tab

Click File > New > Data Comparison Job.
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Use the Select a Project dialog’s Create New button to open a dialog that lets you provide a name and 
location for a project for this exercise. Select the new project from the Select a Project dialog.

In the Overview tab, type the name of the job in the Name field.
Click and drag a data source from Data Source Explorer to the Data Comparison Source box.
By default, all databases in the data source are selected. If you prefer, use the menu to specify a single 
database.
Click and drag a data source from Data Source Explorer to the Data Comparison Target.
Click File > Save or type Ctrl+S to save the job.

To customize the job in the Options tab
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Click the Options tab.

In the Options tab, review the various settings available to you. In particular, select or de- select the check 
boxes in the Mapping Options section.

To refine comparisons in the Mapping tab
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Click the Mapping tab.
Select the databases you want to compare; usually they have the same or a similar name.

By default, DB Change Manager does not show the table mappings. To see them, select the Inspect: 
Checked option on the right side of the Database Mapping pane. The progress bar displays in the lower 
right corner. The Table Mapping pane shows how and whether the tables map to each other in the two 
databases.

Use the All and None commands at the bottom of the pane to select all or none of the databases.

http://www.idera.com/
http://www.idera.com/productssolutions/sqlserver
https://www.idera.com/buynow/onlinestore
https://idera.secure.force.com/
http://community.idera.com/
http://www.idera.com/resourcecentral
http://www.idera.com/about/aboutus
https://www.idera.com/legal/termsofuse


IDERA DB Change Manager 18.4

IDERA|Products|Purchase|Support|Community|Resources|About Us|Legal

37

•

The Data Comparison Job Editor automatically maps and selects databases and tables between the source 
and target when it detects correspondences. It indicates when there is no mapping and displays information 
when it cannot make a match.

Select or de-select the check box next to each mapping, as needed. You can adjust incomplete mappings 
before running the job. Click undefined items in the Target data source column and use the drop down 
menu to map them.
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To specify notifiers in the Notification tab

Click the Notification tab.

In the Notification tab, select where DB Change Manager sends notifications when this job is run.

To run the job and see the results

Click the Run Job icon located in the upper-right side of the window.

The Results tab displays the job progress bar and the results, when available.

Click Filter: edit while a pair is selected to use the Columns, Comparison Key, and Filter dialog and further 
refine the mappings, such as inserting a WHERE clause.


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2.

3.

Click View in the Results column to view information for an individual pair.

In the Database Results tab, review the detailed results for the tables and rows of the selected databases.
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Tutorial 2: Synchronizing data

To generate and run an SQL synchronization script

At the bottom of the Database Results tab of a database comparison job, click one of the radio buttons, such 
as Mismatched, to specify the type of resolution to perform.
At the lower right, click Generate an SQL Script.

In the SQL Editor, click the Execute SQL icon, the green arrow, to synchronize the data.

If you want to create a report, select the Database Results tab, and then click View Diff Report.

Highlighted Feature: The Compression Comparison Option
Comparing large repositories with many databases, tables, and rows can be a time consuming and tedious process, 
especially when you require row-level accuracy.

Before working with tutorials, identify two data sources that you can use for practice. These data sources 
should not be live or mission-critical, and they should be similar in schema and data.



Executing an SQL script may change the data in your data sources. Be sure to review all potential 
changes, and read the script, before running the script.


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The Compression Comparison option enables an algorithm that causes the data comparison to initially execute at a 
table level instead of the row level. Each table in a pair is assigned a value and if the values match the comparison 
process moves to the next pair of tables. If the values do not match, the process performs a more detailed 
comparison at the row level. This allows for a faster comparison process in general, without losing any accuracy 
during the process.

To enable this feature, navigate to the Options tab > Execution Options section, and then select Compression 
Comparison.
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Tutorial 3: Comparing configurations

Configuration comparison jobs examine the configuration settings of two specified data sources and describe the 
differences between them. You select a pair of data sources from Data Source Explorer, refine the property 
comparisons, run the job, and view the results. Based on the results you can correct any issues between the pair.

You can also compare a data source against a configuration archive or standard. Archives are a snapshot of the 
configuration settings of a data source at a point in time. Standards are customized sets of properties with 
threshold operators that help you create optimal configurations; against which you can compare existing data 
source settings.

To define and run a configuration comparison job

Select File > New > Configuration Comparison Job. If prompted to select a project, select the project you 
created earlier.
Type the name of the job in the Name field.
Drag and drop a data source from Data Source Explorer to the Configuration Comparison Source box.
Drag and drop a data source from Data Source Explorer to the Configuration Comparison Target box.
Click the Refinements tab.

Keep the defaults in the Refinements tab.
Click the Options tab.

Before working with tutorials, identify two data sources that you can use for practice. These data sources 
should not be live or mission-critical, and they should be similar in schema and data.



http://www.idera.com/
http://www.idera.com/productssolutions/sqlserver
https://www.idera.com/buynow/onlinestore
https://idera.secure.force.com/
http://community.idera.com/
http://www.idera.com/resourcecentral
http://www.idera.com/about/aboutus
https://www.idera.com/legal/termsofuse


IDERA DB Change Manager 18.4

IDERA|Products|Purchase|Support|Community|Resources|About Us|Legal

43

8.

9.
10.

In the Options tab, select the Extract DDL check box.

Click the Run Job icon.
In the Comparison Results tab, the job progress bar displays and the results appear. Review the job results.

In the Comparison Results tab, you can generate an SQL script to synchronize the configurations just as in 
Tutorial 2: Synchronizing data.

Highlighted feature: Comparing multiple targets
You can compare multiple target sources against a single source. In the Configuration Comparison Target box of the 
Overview tab, click the Add More Targets option. The box changes to a column list view, where you can drag and 
drop additional sources from Data Source Explorer to the Configuration Comparison Target box.
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Tutorial 4: Defining a configuration standard

A configuration standard is composed of properties and values that you define:

Configuration properties (static or dynamically updated based on the source values)
Values that include threshold comparison operators (greater than, less than, falls within or is a member of a 
specified set, etc.)

You can use a standard in configuration comparison jobs against data sources and archives in order to determine if 
the target conforms to the standard. A standard can only be used as a source in comparison jobs.

To define a configuration standard

Select File > New > Configuration Standard.
If prompted, select a project to use.
In the Overview tab, enter the name of the standard in the Name field.
Drag and drop a data source from Data Source Explorer to the Standard Sources table.

In the Refinement tab, define each listed property using the Source, Operator, and Value controls.
Select File > Save to save the standard. It appears in the Project Explorer.

You can subsequently drag and drop the new standard from Project Explorer to the Comparison Source box in the 
Configuration Comparison Job Editor. You can then run a job using the standard as you would use a registered data 
source.

Before working with tutorials, identify two data sources that you can use for practice. These data sources 
should not be live or mission-critical, and they should be similar in schema and data.


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Tutorial 5: Comparing and synchronizing schemas

Once you create a baseline archive of your schema, you can compare it against the other schemas, even in live 
environments. Also, you can synchronize the schema of a data source with the archive using the Schema 
Comparison Job editor.

To define a schema comparison job

Select File > New > Schema Comparison Job and if prompted, select a project.
In the Schema Comparison Job editor, type the name of the job in the Name field.
Drag and drop a data source from Data Source Explorer to the Schema Comparison Source box.
Drag and drop a data source from Data Source Explorer to the Schema Comparison Target box.
Click the Mapping tab.
In the Mapping tab, review the object mappings that are already set up for you. Change the target mappings 
as needed.
In the Options tab, select or de-select the configuration properties.
Click the Run Job icon.
In the Comparison Results tab, the job progress bar displays and the results appear. Review the job results.

To generate and run a schema synchronization script

In the Comparison Results tab, click Generate Sync Script in the Resolution column of the Comparison 
Results table. DB Change Manager generates a synchronization script in the SQL Editor.
Modify the script as needed, and save it using the File > Save command.
In the SQL Editor, select the Execute SQL icon to synchronize the data.

If you want to create a report, click Generate Report. The Export dialog opens and provides additional 
report options.

Before working with tutorials, identify two data sources that you can use for practice. These data sources 
should not be live or mission-critical, and they should be similar in schema and data.



Executing the SQL script changes the schema in your target data source. Be sure to review all 
potential changes and read the script before running it.


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Tutorial 6: Defining a schema archive

A schema archive contains a snapshot of the schema of a registered data source. You compare schema archives 
against other data sources and archives to identify possible inconsistencies.

A schema archive is generated from a single data source at a specific point in time. Like a configuration archive, a 
schema archive has versioning functionality and can be periodically updated with the current values of the data 
source. Older versions are retained and can be recalled as needed.

You create a schema archive using the Schema Archive Job editor. Once created and saved, it is listed in the Data 
Source Explorer.

To define a schema archive

Right-click on a data source in Data Source Explorer and select Archive > Schema Archive Job. Select a 
project, if prompted.
In the Archive Job editor, enter the name of the archive in the Name field.
In the Refinements tab, narrow the job down by selecting owners, object types, and specific objects to 
include.
Click the Run Job icon.
In the New Unsaved Version tab, the results appear. Review the job results.
Click File > Save. The Unsaved Version tab changes to Version 1, and Version 1 appears in the Datasource 
Explorer tab under the datasource you chose.

You can subsequently drag and drop the new archive version from Data Source Explorer to the Source or Target
boxes in the Schema Comparison Job editor. You can now run a job using the archive just as you would use a data 
source.

Before working with tutorials, identify two data sources that you can use for practice. These data sources 
should not be live or mission-critical, and they should be similar in schema and data.



You can create more versions by clicking the Run Job icon again.
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Tutorial 7: Masking data

Data masking is a way of securing sensitive data during the development or testing phases of a database 
development project. It is often performed as a security or compliance measure that protects important 
information. By masking valid production data, you can provide a copy of the data that is “scrambled” but still 
represents your production environment.

To mask data

Select File > New > Data Comparison Job and if prompted, select a project.
Provide a name of the job in the Name field and then drag and drop datasources from the Data Source 
Explorer to the Data Comparison Source and Data Comparison Target boxes.
In the Options tab, ensure that Automatically Synchronize is selected and read the description shown for 
that option.
In the Mapping tab, select a row corresponding to a matching database pair in the Database Mapping box, 
and then select Yes retrieve the objects in this pair.

Before working with tutorials, identify two data sources that you can use for practice. These data sources 
should not be live or mission-critical, and they should be similar in schema and data.


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In the Table Mapping box, click View Column Mapping.

Click on the Data Masking Rule option for a column and select one of the following:
Use Default. The default masking rule as set in the Database Mapping box.
None. No masking is applied.
Randomize. Replaces characters with other random characters.
Shuffle. Reorders the values in different rows; for example, in a First Name column, Bob, Ted, and 
Alice can change to Alice, Bob, and Ted.

Close the window.
Continue to experiment with selection and settings until you are comfortable with masking options.
Click File > Save to save the job.
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10. Click the Run Job icon.

The Database Results tab shows the masked data.
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Tutorial 8: Defining and running automated scripts

When you need to repeatedly run the same job, you can set up automated tasks that execute the jobs on a regular 
schedule. DB Change Manager helps create a command line executable for any job. You can run the command line 
executable on an ad hoc basis. You can also group the commands into a batch file and run them.

To define command line syntax and generate batch files

Open the job for which you want to define an execution script.
Select the Command Line Syntax icon in the upper right of any tab.
In the Script Generation Wizard, add output report options.
Specify the Directory where the files are generated.
Click Next.
Specify the Location where the batch file is generated.
Specify the file format for the script.
Click Finish.
DB Change Manager generates the file and saves it to the location you specified.

If you want to add multiple jobs to the batch file, generate a batch file as normal, and then copy the script syntax to 
the clipboard for each job you want to add to the batch file. You can then add them to the existing batch file 
manually.

Before working with tutorials, identify two data sources that you can use for practice. These data sources 
should not be live or mission-critical, and they should be similar in schema and data.


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Comparing and synchronizing data
Registering and organizing data sources
Filtering data source objects
Comparing data
Synchronizing data repositories
Comparing database configuration settings
Creating a standard for configuration settings
Creating a configuration archive
Masking data
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Registering and organizing data sources
DB Change Manager can register data sources by scanning your systems on startup or as needed. Also, instead of 
scanning, you can provide the information for one data source at a time.
Once registered, the data source appears in the Data Source Explorer view. If you have created more than one 
workspace, they all share the same data source catalog. You can organize data sources into groups and subgroups.
Once a data source has been registered, the connection parameters are stored locally. In some cases, a user ID and 
password are required to connect to a registered data source. DB Change Manager can encrypt and save user IDs 
and passwords to connect automatically.
You can import an existing data source catalog from other IDERA products, or from third- party DBMS sources. You 
can also export a data source to an XML file. These topics include:

Registering data sources on start up
Scanning for and registering data sources
Registering a new data source one at a time
Grouping data sources
Importing and exporting data sources

Registering data sources on start up
When DB Change Manager first starts, it prompts you to discover data source catalogs that have been created by 
any previously installed IDERA products (DBArtisan, Rapid SQL, DB Optimizer), or other instances of DB Change 
Manager.
Additionally, the system can scan your machine for the client software of all supported third- party DBMS platforms 
(TOAD or Eclipse Data Tools Platform) and add them to the data source catalog.
If you do not want to do this on startup, at a later time you can scan for data sources, or add them one at a time.

Scanning for and registering data sources
DB Change Manager can register data sources by scanning your systems.

To initiate a scan for data sources

Click the Discover Data Sources icon at the top of Data Source explorer.
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In the Discover Data Sources dialog, choose the type of data sources that you want returned in the search 
results.

Click Next.
The search returns a list of the discovered data sources.
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Choose the data source(s) that you want to add to the DB Change Manager environment, and then 
click Finish. Data Source explorer automatically populates with the new data source selections.

Registering a new data source one at a time
If a data source is not present in Data Source explorer, you can add it. 

To register a new data source

In Data Source explorer, right-click the Managed Data Sources folder, and then select New > Data Source.
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In the New Data Source wizard, select the data source server platform.

If you have previously set up a group and want to add this data source to that group, select the appropriate 
group in this window. Otherwise, leave the default selection, Managed Data Sources.
Click Next.
Type the connectivity details and login credentials, and then click Test Connection to confirm that the 
configuration information is correct.

Click Finish. Data Source explorer now lists the new data source.
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Grouping data sources
You can organize data sources in Data Source Explorer into groups and subgroups, which appear as folders. Groups 
help you manage a large number of data sources.

To create a data source group

In Data Source Explorer, right-click the Managed Data Sources folder and select New > Data Source Group.
Type a descriptive name for the new group in the Name field, and then click OK.
Data Source Explorer lists the new group. You can drag and drop data sources into the group folder or add 
new data sources to the folder.

To create a data source subgroup

In Data Source Explorer, right-click the Group folder and select New > Data Source Group.
Type a descriptive name for the new group in the Name field, and then click OK.

Importing and exporting data sources
You can import an existing data source catalog from other IDERA products or from third- party DBMS sources, 
including:

Eclipse Data Tools Platform (DTP)
Previously-registered IDERA Data Sources (File)
Previously-registered IDERA Data Sources (Registry)
Quest Software (TOAD)

Conversely, you can export your current data source catalog to a file, which can then be imported into other 
instances of DB Change Manager using the Previously Registered IDERA Data Sources (File) option.

To import data sources

Select File > Import > Data Sources.

Choose a source from which you want to import the data sources, and then click Next.

If you experience problems importing data sources from other IDERA products, you can import the old 
data sources using your Windows registry by selecting File > Import... > IDERA > Data Sources > 
Previously Registered IDERA Data Sources (Registry).


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Specify the details about the location of the import source.
Click Finish. Data Source Explorer is automatically populated with the new data sources.

To export data sources

Select File > Export > Data Sources.

Browse the list, and then select a data source to export.
Type or use the Browse File System or Browse Workspace buttons to enter the directory path and file 
name.
Click Finish. The data source is exported as an XML file. You can import this file to other instances of DB 
Change Manager.
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Filtering data source objects
You can specify a filter on data sources and their objects to control how they are viewed in Data Source Explorer. If 
you have data sources that contain large numbers of database objects, you can apply filters to view only the ones 
you need.

There are two types of data source filters:

Global filters affect all registered data sources.
Data source specific filters affect only the specified data source.

You can create one or more filter templates and apply them to one or more data sources. You can activate and 
deactivate filter templates as needed. You can use multiple filter templates on global or specific data sources.

To define a global filter

From the Main menu, select Preferences > SQL Filters.
The SQL Filters pane displays global filter templates in tabs organized by platform. You can create and apply 
a global filter to a database platform such as SQL Server, and all databases associated with that platform 
will use the filter. By default, all filters ignore system objects.

Click New. The Filter Template dialog appears.

To define a data source specific filter

In Data Source Explorer, right-click the data source, and then select Properties.
Select the SQL Filter node.
Select Enable data source specific settings. The other controls on the dialog become enabled.
Click New. The Filter Template dialog appears.
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To create a filter template

Specify the parameters of the filter template:
In the Name field, enter the name of the filter that will appear in the SQL Filter list.
In the Database Type pane on the left, deselect the data source objects that you do not want to see 
in Data Source Explorer.
Click New to add filter parameters for data source objects properties. The New SQL Filter Predicate 
dialog appears.
Use the Property and Operator fields to supply the filter criteria. Property specifies if the value is a 
name, schema, or specific. Operator specifies the matching criteria: Equals, Not Equals, Like, Not 
Like, In, or Not In.
In the Value field, enter the full or partial syntax of the property or properties you want the template 
to filter.

Click OK.
Repeat the previous step to add more filter parameters.
When you have finished defining the filter template, click OK.
The SQL Filters pane lists the new template.
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Comparing data
You can create a data comparison job to compare the data of two registered data sources, specify configuration 
adjustments and refine mapping parameters. After running the job, DB Change Manager can generate SQL scripts 
which you can run to synchronize any discrepancies. You can run the scripts to update data sources immediately, or 
store the scripts for later use.

DB Change Manager displays data comparison job results at row level, and it can automatically update mismatches 
or add missing rows at the table level.

The following tasks step you through creating and running a data comparison job:

Create a Data Comparison Job
Describe and Save the Job
Specify the Source and Target Data Sources
Specify Execution, Mapping, Comparison, and Resolution Options
Understand the Data Source Mapping Process
Customize Database Mapping
Inspect the Databases
Customize Table Mapping
Reconfigure the Data Source Mapping
Set Job Notification Options
Run the Data Comparison Job
Review Comparison Results

After comparing the data, you can synchronize it to match. For more information about this feature, see 
Synchronizing Data Repositories.

Create a Data Comparison Job
You create, modify, and run a Data Comparison job in the Data Comparison Job editor. For more details about the 
editor, see Data Comparison Job Editor.

To create a new data comparison job

Select File > New > Data Comparison Job and the Data Comparison Job editor opens.

To open an existing data comparison job

Select File > Open Job.
Select a data comparison job from the list.
Click OK.
The Data Comparison Job editor opens.

Describe and Save the Job
The Job Name and Description pane contains more than just the Name field. It shows where the job is stored in 
Project Explorer. When you click the Details button, you can see the project’s directory path.

If the job will be used to monitor compliance against company standards or policies, you can add it to 
the Compliance Explorer list. This list lets you quickly see all the jobs that have recently passed or failed the 
compliance criteria you set.
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To describe and save a job

Type a new name for the job in the Name field. Enter a meaningful name that will quickly and uniquely 
identify the job in other views and dialogs.
Add relevant information in the Notes field.
Click Track Results in Compliance Explorer if you want the job to be listed in the Compliance Explorer. 
Compliance is used most commonly for configuration comparisons.
Click File > Save or File > Save All, or highlight the editor window and press Ctrl+S.

Specify the Source and Target Data Sources
The Data Comparison Source and Data Comparison Target boxes identify what data sources are compared when 
the job runs. When a data source is added to a job, its name, database type, and host are displayed. The Databases 
drop down menu lets you select from a list of the databases on the source.

To add a data source to a job

Click and drag a data source from Data Source Explorer to the Data Comparison Source or Data 
Comparison Target box, or click Select Data Source in the appropriate box and choose a data source from 
the dialog.

You can change a data source selection by clicking Change Data Source from the appropriate box, 
or by dragging a different data source to the box from Data Source Explorer.


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Select the databases, or tables and views (depending on the type of database), from the Databases
pulldown menu.
After you name the job and specify the data sources, click Options.

Specify Execution, Mapping, Comparison, and Resolution Options
You can set various options that control how a job is processed on the Options tab.

To set data comparison job options

Scroll down to see all the options and their descriptions, and select or deselect them as needed.
If an option is not available for the data source, the check box is greyed out. The options are described in the 
DB Change Manager Preferences:

Execution Options
Mapping Options
Comparison Options
Resolution Options

When you are satisfied with the options, click Mapping.

To save options as defaults for future jobs

Set the options.
Click Make these the defaults for new jobs.
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Understand the Data Source Mapping Process
Mapping is the process of pairing data source elements between the source and target of a job. These elements 
(databases, tables, and rows) are compared when the job runs to determine matches and mismatches between the 
two sources.

Mapping details are shown on the Mapping tab of the editor.

Customize Database Mapping
When you first click into the Mapping tab, the Database Mapping table lists the two data sources and lists all of 
their databases. If you previously selected a database in the Overview tab, it is selected. You can scroll right to see 
the Last Inspected column, which indicates that the pair has not yet been analyzed, or inspected, by DB Change 
Manager. The right side of the pane provides similar information.

To select databases to compare

Use the check boxes to select the databases you want to compare. The Select All or None option is helpful if there 
are many databases in the list.

To change the default target database

In the database row, select the target.
From the dropdown menu, select a new database.

Inspect the Databases
Before you can see the default, initial table mappings, you run an inspection process.

To run the database comparison inspection

On the right side of the Database Mapping pane, click one of the following Inspect options:

All inspects all pairs in the table. This is not recommended if you have a large number of databases.
Current inspects the current object mappings.
Checked inspects only those pairs selected in the table.
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Once inspected, icons in the table that indicate how much of the selected objects matched. Hover over the icon to 
see more information.

To restore the Database Mapping table to its original settings

In the Database Mappings pane, click Remap to Defaults.

All settings revert to the original object mappings saved with the job, based on the options you selected in the 
Mapping tab.

Customize Table Mapping
The Table Mapping pane lists the paired tables. The icons indicate whether mappings were complete, and if not, 
error icons indicate what problems were encountered, if any.

To change the mapping to a new target column

In the table row, select the target.
From the dropdown menu, select a new target column.

To view or update the column mappings of a pair of tables

Select a row by highlighting it with the cursor. (The check box is irrelevant for this task.)

Alternatively, you can select a row and in the Table Mapping pane click Yes, retrieve the objects in 
this pair.


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On the right side of the pane, click View Column Mapping.

In the Columns and Comparison Key pane, you can:
Select or deselect columns to use in the comparison job. Because this could affect referential 
integrity, review Resolution Options.
Change or add a comparison key if multiple keys are available. In the Comparison Filter pane, you 
can:

Write a WHERE clause to use during the comparison.
Create a different WHERE clause per table in the pair. Select Separate Where Clause and an 
additional text box is added for a second WHERE clause.

Reconfigure the Data Source Mapping
After configuring and running a comparison job, you may discover that you need to set different mapping options. 
You can reconfigure the way DB Change Manager maps data source elements and then run the job again.

To reconfigure the automatic mapping process

In the Options tab, select or deselect Mapping Options. The options are also described in Mapping Options.

In the Mapping tab, click Refresh Databases and Owners to update the automatic comparison.

Set Job Notification Options
When a job completes, DB Change Manager provides various ways of notifying you. See Setting Job Notifications for 
details.

Run the Data Comparison Job
After you have specified the options and mappings for a data comparison job, you can run it.

To run a job

Click File > Save to save the job before you run it.

When entering selective WHERE clauses, do not include the WHERE keyword; for 
example, use “AGE>12” instead of “WHERE AGE>12”.



If you change the mapping options in Preferences, they will become the defaults for all new jobs.
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In the upper right of the Data Comparison Job editor, click the Run icon.

While the process runs, the Results tab appears and displays the Comparison Summary pane. This information 
includes:

Source and target data source names
When the job started
Estimated remaining time for the job to run
Elapsed time of the job
Names of objects currently being compared
A progress bar showing percentage completion

Review Comparison Results
After a job run completes, the Results tab shows the Comparison Results table.

The Comparison Results table lists:

The source and target databases
Progress status; either Done, Failed, or, if no pairs were specified, Nothing to Compare
The Compare Index percentage of matches
The Results Column View icon links to details about the comparison job

After running a data comparison job, you may decide to synchronize one to the other. For more information, see 
Synchronizing Data Repositories.
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Synchronizing data repositories
After a data comparison job completes, you can use synchronization commands to match the data between 
repositories. You specify how you want the data to be resolved, and DB Change Manager generates UPDATE, 
INSERT, and DELETE statements for the relevant databases. Then you run the scripts to synchronize the data.

Select Data to Resolve
Run the SQL Synchronization Script

Select Data to Resolve
If data is inconsistent between the sources, you can synchronize them.

To view columns and rows to resolve

On the Results tab in the Comparison Results table, click View in the row you want to resolve. See Review 
Comparison Results for context.

The Database Results tab appears, and the Results Overview table displays the pairings in the selected tables.

The Results Overview - Activation pane includes:

Source and target database columns
Number of matched rows between the source and target.
Rows that exist only in the source database.
Rows that exist only in the target database.
Number of differences between the two databases.

To view data in the columns

Select a row from the Results Overview table.
Examine the row information in the Selected Table pane.

To specify how the data synchronization is resolved

Under the Selected Table pane, click All, Mismatched, Source, Only Source, Target, or Only Target.
In the Data Diff view, choose one of the following Row Synchronization options:

Make Target Match Source for Selected Row
Make Source Match Target for Selected Row
Do Not Resolve Selected Row

To generate an SQL script

At the bottom right of the Database Results, click Generate an SQL Script.
In the SQL Editor, review the script and edit it is as needed. For more information, see SQL Editor.
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Run the SQL Synchronization Script
You can run synchronization scripts in the SQL Editor. For more information, see SQL Editor.

To run the SQL synchronization script

In the SQL Editor, click the Execute SQL icon. DB Change Manager executes the code on the data source you 
specified. Results are displayed in the same tab or in a new tab.

After running a comparison job, you can create a job report using the View Report command on the Results tab. See 
Creating a Job Report for more information.
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Comparing database configuration settings
Configuration comparison jobs compare the configuration settings between two registered data sources. They help 
you ensure consistency between the settings of two data sources in order to meet guidelines for data storage and 
retention.

Configuration comparison job results are presented as an overall “percentage matched” between two data sources. 
The results list individual configuration properties and details. The job shows:

The total number of properties that match
The total number of properties that do not match
The properties available on only one data source
The overall total number of properties compared in the job

You can create a configuration standard, which is a customized list of configuration parameters, values, and 
comparison operators, to compare against a data source. For more information, see Creating a standard for 
configuration settings.

You can also compare a data source or standard against an archive, which is a saved version of the configuration 
properties of a registered data source. For more information, see Creating a configuration archive.

The following tasks step you through creating and running a configuration comparison job:

Create or Open a Configuration Comparison Job
Describe and Save the Job
Specify Configuration Comparison Source and Targets
Refine property comparisons
Specify Configuration Comparison Job Options
Set Configuration Comparison Job Notifications
Run the Configuration Comparison Job
View the Results of the Configuration Comparison
Create a Job Report
Synchronize Configurations
Execute an SQL Synchronization Script

All comparison jobs, archives, and standards provide version information with regards to each data source 
platform. For more information, see Version Information Reference.

Create or Open a Configuration Comparison Job
You create, modify, and run a configuration comparison job in the Configuration Comparison Job Editor.

To create a new configuration comparison job:

Select File > New > Configuration Comparison Job. The Configuration Comparison Job editor opens.

To open an existing configuration comparison job:

Select File > Open Job.
Select a configuration comparison job from the list.
Click OK.
The Configuration Comparison Job editor opens.
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Describe and Save the Job
The Job Name and Description pane contains more than just the Name field. It shows where the job is stored in 
Project Explorer. When you click the Details button, you can see the project’s file directory path.

If you want the job to monitor compliance against company standards or policies, you can add it to the Compliance 
Explorer list. This list lets you quickly see all the jobs that have recently passed or failed the compliance criteria you 
set.

To describe and save a job

Type a new name for the job in the Name field. Enter a meaningful name that will quickly and uniquely 
identify the job in other views and dialogs.
Add relevant information in the Notes field.
Click Track Results in Compliance Explorer if you want the job to be listed in the Compliance Explorer.
Click File > Save or File > Save All, or highlight the editor window, and then press Ctrl+S.

Specify Configuration Comparison Source and Targets
The Job Sources section of the Configuration Comparison Job editor specifies the data sources, archives, and 
standards to be compared. You can compare:

Two data sources
A data source against an archive
A standard against a data source
A standard against an archive
An archive against a data source
Two archives

You can also compare a single source against multiple targets.

To add a data source to a job

Click and drag a data source from Data Source Explorer to the Comparison Source or Comparison Target
box, or click Select Data Source in the appropriate box, and then choose a data source from the dialog.
Select Use Live Sources to compare the current properties of the data source when the job is executed.
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To add a configuration standard to the job

If you have not already, create a configuration standard. For more information, see Creating a standard for 
configuration settings.
Click and drag a standard from Data Source Explorer to the Comparison Source, or click Select Standard, 
and then choose a standard from the dialog.

To add a configuration archive to the job

If you have not done so already, create a configuration archive. For more information, see Creating a 
configuration archive.
Click and drag an archive from Data Source Explorer to the Comparison Source or Comparison 
Target box, or click Use an Archive, and then choose an archive from the dialog.

To add multiple targets to the comparison job

At the bottom of the pane, click Add More Targets.
Drag and drop additional data sources or archives from Data Source Explorer to the Configuration 
Comparison Target box, or click the Add Archive or Add Data Source commands below the table, and then 
select the appropriate target from the dialog.

When you are finished setting up the source and target or targets for the configuration comparison job, click 
Refinements to review the properties that are compared.

Refine property comparisons
After you specify a comparison job source and its target or targets, you can customize the comparison properties 
using the Refinements tab of the Configuration Comparison Job editor.

You can change a data source selection by clicking Change Data Source from the appropriate box, 
or by dragging a different data source to the box from Data Source Explorer.


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To specify the properties used in the comparison job

In the Refinements tab, click the category to see all of its properties.
Select the configuration properties you wish to compare, and then deselect the rest.

After you have set the comparison properties, you can set the job options that pertain to how the job is executed.

Specify Configuration Comparison Job Options
The Options tab in the Configuration Comparison Job editor contains the Extract DDL option. If you select it, the 
synchronization code produced by the job comparison appears in a separate editor window when the comparison 
is done.

Set Configuration Comparison Job Notifications
When a job completes, DB Change Manager provides various ways of notifying you. For more information, see 
Setting job notifications.

Run the Configuration Comparison Job
The configuration comparison job runs when you click the Run Job icon in the Configuration Comparison Job 
Editor.

While it runs, the Comparison Results tab appears and displays the progress of the job.

View the Results of the Configuration Comparison
When a job is complete, the Comparison Results tab displays the results.
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The Comparison Summary shows:

The number of matching properties
The number of mismatched properties
The number of properties that are in the source but not in the target

The Comparison Results table lists the details further down in the window.

Comparison Results includes:

The Property column lists settings found on the source.
The Source column contains the value of the property on the source.
The Op column provides the operator used in the job comparison that defines what constitutes a match. For 
most jobs, the operator is always EQUALS. For jobs that use a standard, it can be another operator.
The last column, or columns if multiple targets were used, includes the target name and indicates the 
matches:
A check mark icon, along with the value of the property, indicates a match.
An X icon, along with the value of the property, indicates a mismatch.
A warning icon, along with the value of the property, indicates a value in the target that was not set in the 
source.
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Create a Job Report
After running a comparison job, you can create a job report using the View Report button on the Results tab. For 
more information, see Creating a job report.

Synchronize Configurations
If you want the configuration information to be the same between the source and target or targets, DB Change 
Manager can generate a script that will resolve the differences.

To create a SQL synchronization script

In the Resolution pane of the Comparison Results tab, click Generate a SQL Script.
In the SQL Editor, review the script, and then edit it is as needed.

Execute an SQL Synchronization Script
You can execute synchronization scripts in the SQL Editor. For more information, see SQL Editor.

To execute the SQL synchronization script

In the SQL Editor, click the Execute SQL icon. DB Change Manager executes the code on the target data source and 
displays the results.
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Creating a standard for configuration settings
A configuration standard is an object used in configuration comparison jobs that stores data source configuration 
properties. You compare a configuration standard against registered data sources and archives to determine if and 
how the latter differs from your company-standard values and ranges.

A configuration standard has a list of properties to which you assign values. Properties are derived from data 
sources, archives, or other standards. You assign each property value a range or set an operator to be used in 
comparisons. For more information, see Comparing database configuration settings.

The following tasks step you through creating a configuration standard:

Create or open a configuration standard
Describe and Save the Standard
Define Configuration Standard Properties
Use a Configuration Standard in Configuration Comparison Jobs

Create or open a configuration standard
You create or modify a Configuration Standard in the Configuration Standard Editor.

To create a new configuration standard

Select File > New > Configuration Standard. The Configuration Standard editor opens.

To open an existing configuration standard

In Project Explorer, click Standards > Configuration Standards.
Double-click a standard from the list.
The Configuration Standard editor opens.

Describe and Save the Standard
The Job Name and Description pane shows where the job is stored in Project Explorer. When you click the Details
button, you can see the project’s file directory path.

To describe and save a configuration standard

Type a new name for the job in the Name field. Enter a meaningful name that will quickly and uniquely 
identify the job in other views and dialogs.
Add relevant information in the Notes field.
Click File > Save or File > Save All, or highlight the editor window, and then press Ctrl+S.

Add Standard Sources
The Standard Sources table lists the registered data sources, archives, and other standards from which properties 
for the new standard is derived.

To add properties to a standard

Drag and drop a data source, archive, or standard from Data Source Explorer to the Standard Sources table. 
Alternatively, use the Add Data Source, Add Archive Version, or Add Standard buttons below the table.

All of the properties of the selected data source, archive, or standard populate the new standard.
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Define Configuration Standard Properties
The Configuration Property Refinement tab displays properties and corresponding sources applied to the standard.

You can include or exclude properties in the standard and set thresholds and individual property values in the 
Operator column. The following operators apply:

Less Than
Greater Than
Greater Than Equal To
Equals
Less Than or Equal To
Not Equals

The Value column indicates the value that the Operator definition must match.

To define the properties of a configuration standard

Deselect the properties you do not want to consider using the check boxes.
Click Show: Selected Properties to narrow down the list in the window.
For a property you want to use in the standard, click its appropriate row value in the Operator column, and 
then choose a selection from the drop-down menu.
Type a string or a regular expression in the corresponding Value column.
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Repeat the previous steps until you have defined the properties you require.
Click File > Save or File > Save All, or highlight the editor window, and then press Ctrl+S.

Use a Configuration Standard in Configuration Comparison Jobs
You can use a configuration standard as a source in configuration comparison jobs, the same way as registered data 
sources or archives. You cannot use a standard as a comparison target.

To add a standard to a configuration comparison job

Drag and drop the standard from the Project Explorer to the comparison source box in the Configuration 
Comparison Job Editor.
Continue to define and run the job. For more information, see Comparing database configuration settings.
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Creating a configuration archive
A configuration archive is a snapshot of the configuration parameters of a registered data source. You use a 
configuration archive in configuration comparisons against other data sources, standards, and archives to monitor 
property values and provide backups.

You can periodically update archives with the current values of an associated data source to create new versions. 
Older versions are retained with an archive and can be recalled as needed.

Archives are listed in Data Source Explorer under their corresponding data source. The following tasks step you 
through creating a configuration archive:

Create or Open a Configuration Archive Job
Describe the Configuration Archive Job
Specify a Configuration Archive Source
Refine Configuration Archive Properties
Set Configuration Archive Job Notifications
Specify Configuration Archive Job Options
Create a Version and Save the Archive Job
Create an Archive Job Report
Use an Archive in a configuration Comparison Job

Create or Open a Configuration Archive Job
You create or modify a configuration archive in the Configuration Archive editor. For more details about the editor, 
see Configuration Archive Job Editor.

To create a new configuration archive job

Select File > New > Configuration Archive Job. The Configuration Archive editor opens.

To open an existing configuration archive job

Select File > Open Job.
Select a configuration job from the list.
Click OK.
The Configuration Archive editor opens.

Describe the Configuration Archive Job
The Archive Name and Description pane contains more than just the Name field. It shows where the job is stored in 
Project Explorer. When you click the Details button, you can see the project’s file directory path.

To describe a configuration archive job

Type a new name for the job in the Name field. Enter a meaningful name that will quickly and uniquely 
identify the job in other views and dialogs.
Add relevant information in the Notes field.

Specify a Configuration Archive Source
The configuration Archive Source table specifies the data source from which the archive is derived.

To specify and save a configuration archive source
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Drag and drop the data source to be archived from Data Source Explorer to the Configuration Archive 
Source box. The data source is listed by name, database type, and host.
Click File > Save or File > Save All, or highlight the editor window and press Ctrl+S.

Refine Configuration Archive Properties
When you create a new archive, by default all data source properties are included. However, you may choose to 
archive only a specific group of properties. For example, you may want to define an archive that retains only the 
security properties of the associated data source.

You can create multiple archives for the same data source. For example, another archive may retain only the 
performance properties.

Archive configuration properties are listed on the Refinements tab of the Archive Job editor.

To specify configuration archive properties

Use the check boxes to select or deselect properties.

Within the same archive, properties are retained across versions unless you specify new values.

Set Configuration Archive Job Notifications
When an archive job completes, DB Change Manager provides various ways of notifying you. For more information, 
see Setting job notifications.

Each time you create a new archive, DB Change Manager includes all properties of the specified data 
source and you must again refine the properties.


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Specify Configuration Archive Job Options
The Options tab in the Configuration Archive Job editor contains options for handling the DDL and purging older 
archives.

If you select the Extract DDL option, the synchronization code produced by the job comparison will appear in a 
separate editor window when the comparison is done.

The Automatic Purge Options delete archive files after a number of days, number of versions, and/or when the size 
of the files reaches a certain limit. The purge conditions are checked and enforced when an archive job is saved or 
when a new version is created.

To specify the conditions for automatically deleting archives

In the Options tab, fill in one, two, or all of the options:
The number of Days after which archives will be deleted.
The number of Versions stored, after which the oldest version will be deleted.
The number of MB total size of the version files, after which the oldest version will be deleted.

Create a Version and Save the Archive Job
When you first run an archive job, DB Change Manager creates the first version of the archive. A version stores 
snapshots of the same archive job for backup or tracking comparison purposes. Versions are listed in the Archive 
Job History table on the History tab and in the Data Source Explorer.

To create a version and save a configuration archive job
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In the Configuration Archive Job editor, click Run Job. The New Unsaved Version tab lists the properties of 
the archive.

Highlight the tab, and then select File > Save or File > Save All. The tab shows that the version is saved.
Click the History tab. The Archive Job History table lists the archive version, the number of properties 
retained by the version, a time stamp, and whether the archive job was run from the workbench or the 
command line.

You create additional versions within the same archive job each time you click Run Job. The new version contains 
the latest values for the archive job properties as specified on the Refinements tab.

To open an archive version

In the History tab or in the Job Explorer, double-click the version. The selected version opens in a new tab of 
the Archive Job editor.

Create an Archive Job Report
After running a comparison job, you can create a job report using the View Report button on the Results tab. For 
more information, see Creating a job report.
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Use an Archive in a configuration Comparison Job
You can use a configuration archive in configuration comparison job the same way as registered data sources or 
standards.

To add a configuration archive to a configuration comparison job

Drag and drop an archive version from Data Source Explorer to the source or target boxes in the 
Configuration Comparison Job Editor. Alternatively, if a data source is selected as the source or target, select 
Use an Archive in the respective box and use the drop-down menu to choose an archive.

For more information, see Comparing database configuration settings.
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Masking data
Data masking is a way of securing sensitive data during the development or testing phases of a database 
development project. It is often performed as a security or compliance measure that protects important 
information. By masking valid production data, you can provide a copy of the data that is “scrambled” but still 
represents your production environment.

DB Change Manager lets you specify masking rules for moving data between a source and a target in a data 
comparison job. You can set rules for individual columns, tables, and entire databases. When you run a data 
comparison with the Automatically Synchronize option on, the data on the target is replaced with data from the 
source and any items configured with a masking rule will be masked. You can then use the masked data in your 
development and testing environments.

The following tasks describe how to create masked data:

Create a New Masking Job
Specify a Masking Job Name
Specify Source and Target Data Sources
Set to Automatically Synchronize
Specify Mapping Options
Specify Masking Rules for Individual Columns
Run the Database Masking Job
See the Masked Data

Create a New Masking Job
Use the Data Comparison Job Editor to define a masking job.

To start creating a new Data Masking Job:

Select File > New > Data Comparison Job.

Specify a Masking Job Name
The name of the job distinguishes it between other jobs in the application environment.

To name a masked data job

Type the name of the job in the Name field of the Data Masking Job Editor.
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Specify Source and Target Data Sources
The Job Sources section of the Data Comparison Job Editor contains the Data Comparison Source box, which 
identifies the original data source, and Target Data Source box, which identifies the data source where the data is 
altered.

To specify source and target data sources

Click and drag a data source to be masked from the Data Source Explorer to the Data Comparison Source
box. Drag and drop a target data source, where the mask is applied, from the Data Source Explorer to the 
Data Comparison Target box.
Use the drop-down Database menu to specify the database to be masked for the Data Comparison Source, 
and the database to which you want to apply masking definitions on the Data Comparison Target.

Set to Automatically Synchronize
Prior to running a masking job, set it to automatically clear all the data on the target and replace it with new, 
masked data.

To set synchronization

Click on the Options tab.
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Select the Automatically Synchronize check box.

Specify Mapping Options
Use the Mappings tab to specify the tables to mask. You can apply a Default Masking Rule to selected columns using 
the pulldown menus.

The options are:

Use Default. The default masking rule as set in the Database Mapping box.
None. No masking is applied.
Randomize. Replaces characters with random other characters.
Shuffle. Reorders the values in different rows. For example, in a First Name column Bob, Ted, and Alice can 
change to Alice, Bob, and Ted.

Use the check boxes in the left-hand column to de-select any columns that you do not want to include in the data 
masking job process.
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To specify mapping options

Click on the Mappings tab.
Select check box of the database you want to mask.
Click on the Yes, retrieve the objects in the pair button to inspect the tables and columns.
The Table Mapping section opens.
Select a Default Masking Rule for the in the Database Mapping box.
Select a Default Masking Rule in the Table Mapping box.

Specify Masking Rules for Individual Columns
You can specify different masking rules for different columns.

To specify a masking rule for a column

In the Table Mapping box, click View Column Mapping.
Click on the Data Masking Rule option for the column and select from the pulldown menu one of the 
following:

Use Default. The default masking rule as set in the Database Mapping box.
None. No masking is applied.
Randomize. Replaces characters with random other characters.
Shuffle. Reorders the values in different rows. For example, in a First Name column Bob, Ted, and 
Alice can change to Alice, Bob, and Ted.

Close the window.

Run the Database Masking Job
To execute the data masking job

Click File > Save to save the job.
Click the Run Job icon in the upper right-hand corner of the screen.
Click OK in the Confirmation dialog box to agree that you want to overwrite the target data. 
The Results tab displays the progression of the masking job as it executes, and the Rows Written column 
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indicates how many rows of data have been masked by the job.

See the Masked Data
You can see the masked data by running a new Data Comparison job and looking at the changes. For more 
information, see Comparing data.

For rows that do not have masking applied, you should see “0” in the Different column of the Results Overview
box. For rows that are masked, you should see the number of rows that changed.

In the Selected Table box, you can see the masked data in the target table. For example, the First and Last Name
data shown below was masked using the Randomize setting.
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Comparing and synchronizing schemas
Comparing schemas
Creating a schema archive
Synchronizing schemas
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Comparing schemas
You can create a schema comparison job to capture, compare, and synchronize database schemas. In addition, you 
can compare a schema against an archived version of a schema. For more information, see Creating a schema 
archive.

The following tasks step you through creating and running a schema comparison job:

Create or Open a Schema Comparison Job
Describe and Save the Schema Comparison Job
Specify a Schema Comparison Source and Targets
Refine Schema Comparisons
Customize Schema Mapping
Specify Schema Comparison Job Options
Set Schema Comparison Job Notifications
Run the Schema Comparison Job
Create a Schema Comparison Job Report
Cloning a schema comparison job

After comparing the data, you can synchronize it to match; see Synchronizing Data Repositories.

Create or Open a Schema Comparison Job
You create, modify, and run a schema comparison job in the Schema Comparison Job editor.

To create a new schema comparison job

Select File > New > Schema Comparison Job. The Schema Comparison Job editor opens.

To open an existing schema comparison job

Select File > Open Job. Select a job from the list, and then click OK. The Schema Comparison Job editor 
opens.

Describe and Save the Schema Comparison Job
The Job Name and Description pane shows where the job is stored in Project Explorer. When you click the Details
button, you can see the project’s file directory path.

If the job is used to monitor compliance against company standards or policies, you can add it to the Compliance 
Explorer list. This list lets you quickly see all the jobs that have recently passed or failed the compliance criteria you 
set.

To describe and save a job

Type a new name for the job in the Name field. Enter a meaningful name that will quickly and uniquely 
identify the job in other views and dialogs.
Add relevant information in the Notes field.
Click Track Results in Compliance Explorer if you want the job to be listed in the Compliance Explorer.
Click File > Save or File > Save All, or highlight the editor window, and then press Ctrl+S.
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Specify a Schema Comparison Source and Targets
The Schema Comparison Source and Schema Comparison Target panes identify what data sources or schema 
archives are compared when the job runs. The Schema Comparison Job editor displays the Name, Type, and Host
of the source and target.

You can also use a schema archive in a schema comparison job, to compare an older schema against a new one. For 
more information, see Creating a schema archive.

In addition, you can use the following radio buttons to specify whether to compare the current properties of the live 
data source, or an archived set of properties previously stored in DB Change Manager.

Select Use Live Sources to compare the current properties of the data source when the job is executed.
Select Use an Archive, and then select the schema archive and version from the pulldown menu.

To add a data source to a schema comparison job

Click and drag a data source from Data Source Explorer to the Schema Comparison Source or Schema 
Comparison Target box, or click Change Data Source, and then choose a data source from the dialog box.

To add a schema archive to a schema comparison job

Click and drag a schema archive from Data Source Explorer to the Schema Comparison Source or Schema 
Comparison Target box.

To change a schema archive or data source in a schema comparison job

Click Change Data Source in the appropriate box, and then select a new data source from the dialog; or 
drag a different data source from Data Source Explorer to the box.

Cross-Platform Schema Comparisons Supported by DB Change Manager
DB Change Manager supports cross-platform schema comparisons. However, such jobs are limited to the following 
DBMS combinations and data source objects:

DBMS Source/Target Objects Compared

Sybase / SQL Server Tables, Unique Keys, Check Constraints, Foreign Keys, Indexes, 
Primary Keys, Views

Oracle / SQL Server Tables, Unique Keys, Check Constraints, Foreign Keys, Indexes, 
Primary Keys, Views

If you attempt to compare two data sources that are not compatible, the Schema Comparison Job editor does not 
let you place objects in the Source or Target panes.

Add Multiple Schema Comparison Job Targets
You can add more targets to compare a source schema against multiple target schemas.
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To add multiple targets to a schema comparison job

Drag and drop additional data sources or schema archives from Data Source Explorer to the Schema Comparison 
Target box, or click the Add Archive or Add Data Source buttons beneath the table and select the appropriate 
target from the dialog box.

Refine Schema Comparisons
You can refine the schema comparison to use only the schema objects you want to include using the Refinements 
tab in the Schema Comparison Job editor.

The Object Refinement pane lists the database objects of the comparison source. Objects are listed by 
owner (if applicable to the database platform) or by object type.
The Filter by Owner and Filter by Type panes let you add or remove objects from the Object Refinement
pane by owner (if applicable to the database platform) or by object type.
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To specify the objects used in a schema comparison job

In the Refinements tab, select or deselect objects in the Filter by Owner and/or Filter by Type panes to add 
or remove objects from the Object Refinement pane.
Select or deselect the objects in the Object Refinement pane.

Customize Schema Mapping
The mapping process pairs objects between the job source and target so that the objects can be compared. You can 
see and modify pairs using the Mapping tab of the Schema Comparison Job editor.

DB Change Manager automatically maps schema objects based on its interpretation of both schemas. Elements 
that do not match are initially excluded; you can manually map them prior to running the job.

The Refinements Mapping table lists schema elements for the job source and target.
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By default, new objects are included in this list. For more information, see CM/Schema > Refinements Options.

When comparing master catalogs or user mappings, you can select multiple targets against a single source.

To redefine schema object mappings

In the Refinements Mapping tab, click the target of the pair you want to change. Use the drop-down menu to 
define the object you prefer.

To restore original schema object mappings

Click Restore Default Mappings to revert to the original object mappings as determined by DB Change 
Manager.

Specify Schema Comparison Job Options
Prior to running a job, you can set various options to control aspects of the comparison process. Set them using the 
Options tab.

The list of options differs depending on the DMBS of the source and target data sources. Options differ according to 
the objects included in the job. For example, Ignore Constraint Name Differences do not appear if you exclude 
constants from the job.

The options you see in the job have defaults. You can change the defaults using Preferences.

Schema comparison job options include:
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Synchronization Options. These options specify how you want DB Change Manager to handle the 
synchronization script after it runs the comparison job, either:

Manual causes DB Change Manager to display the results of the comparison, but it does not 
automatically attempt to repair any synchronization issues. If you choose this option, you will still be 
able to manually generate and run a synchronization script after the job runs.
Automatic causes DB Change Manager to automatically generate and run a synchronization script 
immediately after the comparison job runs.

Include Object Options. These settings determine what elements of the job source and target will be 
omitted when running a schema comparison job and synchronization. For more information, see CM/
Schema > Comparison Options > Include Objects Options.
Compare Options. These settings affect how objects are treated in the comparison process. You can include 
or exclude specific object types in the job, and specify the behavior of the comparison job and 
synchronization scripts. For more information, see CM/Schema > Comparison Options > Compare Options.
Decorator Options. These settings affect particular database objects. For more information, see CM/
Schema > Comparison Options > Decorator Options.
Identifier Options. These settings determine what elements of the source and target data source will be 
ignored during the schema comparison and synchronization process. For more information, see CM/Schema 
> Comparison Options > Identifier Options.
DDL Extract Option. This setting causes the DDL code to appear in a separate editor window after the 
comparison job runs. For more information, see CM/Schema > Comparison Options > DDL Extract Options.
Custom Options. This section lists options that you defined in the Create New Schema Custom Compare 
Options dialog. For more information, see Select Schema Properties to Ignore During a Comparison.

As needed, DBMS-specific options settings are also listed. For more information, see CM/Schema > Comparison 
Options > Additional Options.

Select Schema Properties to Ignore During a Comparison
You can create a custom list of schema properties that are ignored by a schema comparison job.

To define schema properties to ignore

Click File > New > Custom Schema Comparison Option.
Name the custom properties and add a description.
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Select the properties that you want to ignore.

Click Finish.
Open a schema comparison job Options tab.
Under Custom Options, select the custom option.

Set Schema Comparison Job Notifications
When a job completes, DB Change Manager provides various ways of notifying you. For more information, see 
Setting job notifications.

Run the Schema Comparison Job
To run the schema comparison job:

Click the Run icon located in the upper right-hand corner of the Schema Comparison Job editor.

While the process runs, the Comparison Results tab appears and indicates the progress of the job.
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When the job is complete, the Comparison Results pane shows information about the comparison.

The Comparison Results pane includes these columns:

The Target column shows the name of the target, and provides a link to open the Individual Comparison 
Results tab, which provides more details. For more information on viewing individual results, see View 
Individual Schema Comparison Results.
The Task column shows what kind of job was run.
The Progress column shows whether the job is in progress or has completed, and how many errors were 
encountered.
The Compare Index column indicates the percentage of schema that matched between the source and 
targets of the job.
The Results column provides a Show Individual Results link to open the Individual Comparison Results tab, 
which provides more details. For more information on viewing individual results, see View Individual 
Schema Comparison Results.
The Resolution column provides a command that produces a synchronization script that, when run, 
automatically synchronizes the compared schema. For more information on generating a synchronization 
script, see Synchronizing schemas.
The Errors column indicates how many errors were encountered during the comparison process, and 
provides a link to view them in a separate window.
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View Individual Schema Comparison Results
To see specific schema comparison results

After a job runs, in the Comparison Results table, click Show Individual Results. 

The Individual Comparison Results window appears.

To browse the objects

Select or deselect the check boxes in the left-panel list.
Right-click and use the menu to select or deselect objects at the global or page levels.
Click the right and left arrows underneath the middle panel.
Enter a page number in the box underneath the middle panel.

To filter the objects

Type a search string into the Show/Hide Objects search box.
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To see a summary report

Click Generate Report.

To view the DDL between two schema comparison results
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Click View Details.

To save individual schema comparison results data to a text file

Click Export to File.

To view the synchronization script and DDL between two individual objects

In the Individual Comparison Results window Compared Objects pane, select an object that does not 
match.

Script and DDL details appear in the pane below.

In the Script tab, view the SQL that synchronizes the objects.

Create a Schema Comparison Job Report
After running a comparison job, you can create a job report using the View Report button in the Results tab. For 
more information, see Creating a job report.

Cloning a schema comparison job
You can create a copy of a schema comparison job, using a different data source.

To clone a schema comparison job
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After you have saved and run a job, the Clone Job button is enabled in the Schema Comparison Job Editor.

Click Clone Job.

In the Data Source Selection list, select the new target for the cloned job. If you need to add a new data 
source to the list, click New Data Source.
Click OK.
DB Change Manager lists the new, cloned job in the Job Explorer. You can modify and run the cloned job as 
just as any other schema comparison job. In addition, you can preserve the target mapping from the original 
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job.

To preserve target mapping in a cloned schema comparison job

Open the cloned job in the Schema Comparison Job editor.
In the Job Sources target pane, click Preserve Target Mapping.
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Creating a schema archive
A schema archive is a snapshot of the schema of a registered data source. You use a schema archive in schema 
comparisons against other data sources and archives. It is useful as a baseline to monitor data loss and 
inconsistencies when you move databases between testing and production environments.

Archive jobs are versioned. Older versions are retained within an archive.

Archive jobs are located in Data Source Explorer on the Schema Archive Jobs node of the corresponding data 
source.

The following tasks step you through creating a schema archive:

Create or Open a Schema Archive Job
Describe and Save the Schema Archive Job
Refine Schema Archive Properties
Specify Schema Archive Job Options
Set Schema Archive Job Notifications
Create a Version and Save the Schema Archive Job
Browse and Modify Schema Archive Contents
Create a Job Report
Use an Archive in Schema Comparison Jobs

Create or Open a Schema Archive Job
You create or modify a schema archive in the Configuration Archive Job editor. For more details about the editor, 
see Schema Archive Job Editor.

To create a new schema archive

Select File > New > Schema Archive Job. The Schema Archive Job editor opens.

To open an existing schema archive

Select File > Open Archive.
Select a job from the list, and then click OK.
The Schema Archive Job editor opens.

Describe and Save the Schema Archive Job
The Job Name and Description pane shows where the job is stored in Project Explorer. When you click the Details
button, you can see the project file directory path.

To describe and save a configuration archive job

Type a new name for the job in the Name field. Enter a meaningful name that will quickly and uniquely 
identify the job in other views and dialogs.
Add relevant information in the Notes field.
Click File > Save or File > Save All, or highlight the editor window, and then press Ctrl+S.

Specify a Schema Archive Job Source
The Schema Archive Source table specifies the data source from which the archive job is created.

To specify a schema archive job source

http://www.idera.com/
http://www.idera.com/productssolutions/sqlserver
https://www.idera.com/buynow/onlinestore
https://idera.secure.force.com/
http://community.idera.com/
http://www.idera.com/resourcecentral
http://www.idera.com/about/aboutus
https://www.idera.com/legal/termsofuse


IDERA DB Change Manager 18.4

IDERA|Products|Purchase|Support|Community|Resources|About Us|Legal

104

•

1.

2.

Drag and drop the data source to be archived from Data Source Explorer to the Schema Archive Source
box. The data source is listed by name, database type, and host.

Refine Schema Archive Properties
When you create a new schema archive, by default all schema properties are included. However, you may choose to 
archive only a specific group of properties. For example, you may want to define an archive that retains a subset of 
the properties. You can create multiple schema archives for the same data source.

Archive job properties are located on the Refinements tab of the Schema Archive Job Editor, where they are listed 
by object name, owner (if applicable to the database platform), and type.

To refine schema archive properties

In the Schema Archive editor, click the Refinements tab.
DB Change Manager analyzes the data source and displays schema information in the Refinements tab.

Use the check boxes to select only the data source objects from which you want to create a schema archive.
Within the same archive, properties are retained across versions unless you specify new values.

Each time you create a new schema archive, DB Change Manager includes all properties of the 
specified data source and you must again refine the properties.


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Specify Schema Archive Job Options
The Options tab contains the Include Objects Options, DDL Extraction Options, and the Automatic Purge 
Options settings.

Include Objects Options
The Include Table Dependencies option includes table dependent objects in the results of the archive job.

DDL Extraction Options
You define whether DDL is extracted and stored in files during the archive process using the DDL Extraction Options. 
You can also obtain the DDL from the archive after the job runs.

These options include:

The default, None, means that the process does not separately save the DDL when building the schema 
archive.
One File means that the DDL also is saved to a single .SQL file.
Multiple Files means that the DDL also is saved to multiple .SQL files. Each object will have a corresponding 
file.

If you choose to store the DDL, you can find the directory location of the saved files on the History tab of the editor 
after archive versions are created.

To specify the DDL extraction process

In the Options tab, select None, One File, or Multiple Files to indicate how the DDL is stored.

Automatic Purge Options
The Automatic Purge Options delete archive files after a number of days, number of versions, and/or when the size 
of the files reaches a certain limit. The purge conditions are checked and enforced when an archive job is saved or 
when a new version is created.

To specify the conditions for automatically deleting archives

In the Options tab, fill in one, two, or all of the options:
The number of Days after which archives are deleted.
The number of Versions stored, after which the oldest version is deleted.
The number of MB total size of the version files, after which the oldest version is deleted.

Set Schema Archive Job Notifications
When a job completes, DB Change Manager provides various ways of notifying you. For more information, see 
Setting job notifications.

Create a Version and Save the Schema Archive Job
When you first run an archive job, DB Change Manager creates the first version of the archive. A version stores 
snapshots of the same archive job for backup or tracking comparison purposes. Versions are listed in the Archive 
Job History table on the History tab and in the Data Source Explorer.

To create a version and save a schema archive job
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In the Archive Job Editor, click Run Job.
The New Unsaved Version tab lists the properties of the archive.
Highlight the tab, and then select File > Save or File > Save All.
A version appears in the Archive Job History table on the History tab containing the name of the archive, 
the number of properties retained by the version, a time stamp, and whether the archive job was run from 
the workbench or the command line.

Browse and Modify Schema Archive Contents
After you run a schema archive job, you can look at its contents and, if needed, modify the list of objects to be 
included in the job. A View Objects Summary report shows you what objects are selected and are included in the 
DDL Extract script.

To browse the contents of the archive

In the Archive Contents list, use the scroll bar and page arrow buttons at the bottom to see all the archive 
contents.
At the top of the Archive Contents list, use the search box to filter and find objects.

To modify the contents of the archive

In the Archive Contents list, right-click an object to select or deselect multiple objects.
Check or uncheck the boxes to select or deselect single objects.

To see a list of objects used in the Extract DDL script

At the top of the archive Results tab, click View Objects Summary. The report lists details about the types 
and number of objects in the job.

To see the DDL

In the Archive Contents list, right-click the object, and then select Extract. The DDL appears in the DDL 
Extract pane. You create additional versions within the same archive job each time you click Run Job. Each 
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new version contains the latest values for the archive job properties you specified on the Refinements tab.

To edit the DDL

Open the Version tab of the schema archive.
At the bottom of the tab, click the Open Script in SQL Editor button.
The SQL Editor appears. For more information, see SQL Editor.

To extract the DDL of the archive contents to a file

Open the Version tab of the schema archive.
In the Archive Contents list, right-click the object, and then select Extract DLL Scripts.
The Extract DLL Scripts window opens. For more information, see Extract DDL Scripts.

Review the History of Archived Objects
You can compare two versions of an object and restore an object to a previous version.

To see the history of an archived object

http://www.idera.com/
http://www.idera.com/productssolutions/sqlserver
https://www.idera.com/buynow/onlinestore
https://idera.secure.force.com/
http://community.idera.com/
http://www.idera.com/resourcecentral
http://www.idera.com/about/aboutus
https://www.idera.com/legal/termsofuse


IDERA DB Change Manager 18.4

IDERA|Products|Purchase|Support|Community|Resources|About Us|Legal

108

1.

2.
3.

1.

2.

•

•

In the Archive Contents list, right-click the object, and then select History.
The Object History window appears.

Select the two versions that you want to compare.
Click Compare.
DB Change Manager compares the two and reports on the differences, if any.

To restore an archived object to its previous version

In the Object History window, select the version you want to replace and the version with which you want to 
replace it.
Click Restore.
The newer version is replaced by a copy of the older version.

Create a Job Report
After running a schema archive job, you can create a job report using the View Report button on the Version tab. 
For more information, see Creating a job report.

Use an Archive in Schema Comparison Jobs
You can use a schema archive in schema comparison job.

To add a schema archive to a schema comparison job

In the Schema Comparison Job editor, drag and drop an archive version from Data Source Explorer to the 
Comparison Source or Comparison Target boxes.
Alternatively, if a data source is selected as the source or target, select Use an Archive in the respective box, 
and then use the drop-down menu to choose an archive.

For more information, see Comparing schemas.
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Synchronizing schemas
This topic contains the following subtopics:

Resolve Schema via a Generated SQL Script
Execute a SQL Synchronization Script
Configure an SQL Session

Resolve Schema via a Generated SQL Script
Once a schema comparison job completes, you can choose to run synchronization commands that match the 
schemas to each other. The synchronization process generates CREATE, DROP, and ALTER statements, and stored 
procedures on the source and target data sources.

To generate a SQL synchronization script

On the Results tab, click Sync All in the Resolution column of the Comparison Results table. A 
synchronizing script is produced in another window.
The script can be modified manually, executed as needed, and saved at any time.
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Execute a SQL Synchronization Script
You execute SQL synchronization scripts using commands in the Run menu or the command icons located along 
the top right of SQL Editor.

When an SQL file is open in the workspace, select it and choose a database and an associated catalog on which you 
want to execute file using the drop down menus in SQL Editor. You can click the execute icon to execute the code on 
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the specified database and catalog, start a transaction or commit a transaction, or modify the SQL session options 
prior to execution.

To execute SQL code

Open the SQL file you want to run. Make sure that it is associated with the correct database.
Click the Execute SQL icon.
DB Change Manager executes the code on the data source you specified and displays the results in the same 
tab or in a new tab.

To execute a transaction

Open the transaction file you want to run. Make sure that it is associated with the correct database.
Click the Start Transaction icon.
DB Change Manager executes the transaction on the data source you specified.

To commit a transaction

Open the transaction file you want to commit. Make sure that it is associated with the correct database.
Click the Commit Transaction icon.
DB Change Manager commits the transaction on the data source you specified.

You can set transactions to auto-commit prior to execution on the SQL Execution node of the Preferences panel.

Configure an SQL Session
The SQL Session Options dialog provides configuration parameters that indicate to DB Change Manager how to 
execute code in the development environment.

To modify SQL session options

In the SQL Editor, click the Set SQL Session Options icon.
The SQL Session Options dialog appears.

The synchronization script generation process does not support all object parameters. You should add the 
following object parameters, as needed, after a synchronization script is generated: fillfactor, consumers, 
allow_dup_row, and statistics.


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Click on individual parameters in the Value column to change the configuration of each property.

Click Finish.
The session options change and DB Change Manager executes the code as specified when you launch the 
script.

After running the job, you can generate a job report that summarizes the archived configuration information. You 
can also generate job reports for any archive versions that exist in the system. Click View Report on the Results tab. 
For more information, see Creating a job report.
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Working with jobs
Creating a job report
Scheduling a job
Setting job notifications
Exporting and importing jobs
Automating batch scripts
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Creating a job report
After you run a job, you can see its default report, and you can export a report in various formats.

To view or print a default job report

On the Results tab, click the View Report button.
The report opens in a separate window and can be read on screen, sent to a printer, and saved to disk.

To save a report in a particular file format

On the Results tab, click the Export Results button.
In the Export dialog, select a directory location where the report will be saved.

Click an output format.
Click Report Preferences.
In the Report Preferences tabs, select the visual properties of the report including style, paper size, and font. 
For details about the preferences, see Reports.
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In the Contents tab, specify the criteria to include in the report.

For configuration comparison jobs:
Select Include matching configuration parameters to include configuration parameters and 
values that matched when the job was run.

For data comparison jobs:
Select Include matching data fields (database level) to include tables and/or views that 
matched in a data comparison job. If this option is not checked, only comparison tables and/
or views that did not match will be included.
Select Include matching data fields (table level), after deselecting the database level 
option, to include data fields that matched in rows, for which one value did not match. If this 
option is not checked, only comparison key values and values that did not match are 
included.
Select Include detail reports in CM/Data notifiers to include information for all data fields 
selected in a data comparison job.

For schema comparison jobs:
Select Include matching schema objects to include information about the objects that 
matched in a schema comparison job.
Select Include DDL in Schema Reports to include information about the DDL.

Use the Split reports when exceeding number of objects option to limit the number of objects 
per section.

A schema report runs faster if you do not generate the DDL in the report.

If your schema comparison reports are very large and use a lot of memory, you can 
split them into smaller sections for better performance.


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Scheduling a job
You can use Windows Task Scheduler to run jobs on a regular schedule.

To schedule a job

In a job editor, click the Schedule Job button.

In the informational dialog, click OK.
In the Schedule tab, specify when and how often you want the job to run, and then click OK.

You can also open the Job Scheduler from the Tools > Schedule Job menu or right-click on any 
job, and then select Schedule Job.


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In the dialog, verify your user name and type your Windows password, and then click OK. 
The Job Scheduler gives you additional options on the Settings tab.

To modify an existing job schedule

In the toolbar, click the Open Scheduled Tasks button.

In the Scheduled Tasks list, double-click the job you want to change.
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Setting job notifications
When a job completes, DB Change Manager provides various ways of notifying you, including:

Email Notifications
File System notification for Log Files
System Tray Notifications
Send Notification and Attachment Options

Email Notifications
You can configure notification emails, with optional reports, to be sent when a job runs. You can specify the email 
addresses, the email message format, and the conditions under which a notification email will be sent.

To set up email notifications

Click Enable Email Notifier to enable email notification. When you select this check box, a list of notification 
parameters appears.
If you have not set your email notification preferences, a message will alert you to do so. For more 
information, see Notification > Email Notification.
Enter the email addresses to which the notification will be sent in the To field.
Select an email format template in the Template field.

To specify when to attach log files

Select a Log Files option to set whether DB Change Manager sends a log file every time or only when there are 
errors.

To specify when notifications are sent

Select the Send Notification options, including:
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The When Run From option specifies that email notifications are sent depending on where the job is 
initiated. By default, notifications are sent when you use either the Workbench or Command Line.
The Job Outcome option specifies that email notifications are sent depending on whether the job is 
successful. By default, notifications are sent every time.

For comparison jobs, the For Threshold option specifies the threshold level for which email notifications are sent, 
based on job results.

You can click Open Compliance Page to specify the percentage value of each of the threshold warning levels. These 
values are based on the percent match results of a given comparison job.

To specify where to put notification reports

Select Attach Report to Email to send it as an email attachment.
Select Publish Report on Web Server to post the file to a web server. Be sure to specify the web server 
preferences. For more information, see Notification > Email Notification.

To specify the format of email report files

Select the Report option, and then select the preferred file format for the attached report.

File System notification for Log Files
You can configure logging options in the File System Notifier, to specify when the log file is generated and where it is 
saved.

To set up file system notifications

Click Enable File System Notifier to enable reports and logs.
Browse to and select a directory location for each of the output file in the Report Directory, Log Directory, 
and Script Directory fields.
Optional. If you want to change the directory locations at the application level rather than just the job level, 
click Show File System Notification Preferences, and then specify the Send Notification and Attachment 
Options.

System Tray Notifications
When you are running jobs in the background, DB Change Manager can send Windows system tray notifications to 
your desktop.

To set up system tray notifications

Click Enable System Tray Notifier.
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Click Show System Tray Notifications to specify the appearance and behavior of the specific pop-up 
windows.
Specify the Send Notification and Attachment Options.

Send Notification and Attachment Options
Email, file system, and system tray notifications include options that control when and how notifications are sent.

To specify when notifications are sent

Select the Send Notification options, including:

The When Run From option specifies that email notifications will be sent depending on where the job is 
initiated. By default, notifications are sent when you use either the Workbench or Command Line.
The Job Outcome option specifies that email notifications will be sent depending on whether or not the job 
is successful. By default, notifications are sent every time.

For comparison jobs, the For Threshold option specifies the threshold level for which email notifications are sent, 
based on job results.

You can click Open Compliance Page to specify the percentage value of each of the threshold warning levels. These 
values are based on the percent match results of a given comparison job.

To specify the format of notification files

Select the Report option, and then select the preferred file format for the attached report.

http://www.idera.com/
http://www.idera.com/productssolutions/sqlserver
https://www.idera.com/buynow/onlinestore
https://idera.secure.force.com/
http://community.idera.com/
http://www.idera.com/resourcecentral
http://www.idera.com/about/aboutus
https://www.idera.com/legal/termsofuse


IDERA DB Change Manager 18.4

IDERA|Products|Purchase|Support|Community|Resources|About Us|Legal

121

•
•

1.

2.
3.

Exporting and importing jobs
You can use the Jobs wizard to export or import a job or jobs stored in a zip file.

Export a Job
Import a Job

Export a Job
To export a job or jobs

Click File > Export > Jobs. The Export Jobs wizard opens.

Select the job or job version that you want to export. You can select more than one.
Click Browse and set the location of the zip file, and then click Next.
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In the Export Jobs Dependencies pane, review the dependencies that will be exported with the job.

Click Finish. DB Change Manager will generate the zip file and save it to the specified location.

Import a Job
To import a job or jobs

Click File > Import > Jobs. The Workspace Selection wizard opens.

Select Zip file.
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Click Browse and specify the zip file to import.
Click OK. The Import Jobs wizard opens.

Select the job or job version that you want to import. You can select more than one.
Click Next. The Import Jobs Dependencies pane shows the dependent jobs and data sources that will be 
imported.
Click Finish. DB Change Manager imports the zip file job or jobs.
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Automating batch scripts
This topic contains the following subtopics:

Generating command line scripts
Using the changec Command Line Program

Generating command line scripts
Each job editor has a Generate Command Line button to launch the Script Generation Wizard, which helps you 
create batch files that automatically run one or more jobs.

By default, each command line script picks up the name of its job. You can specify output files in CSV, XML, RTF, 
HTML, or PDF format.

The Report Directory column indicates the location where reports are created.

The Store Results column indicates whether the job results are saved once the job has executed.

To create a script file

In the job editor, select the Generate Command Line icon located in the upper-right hand corner.
In the Script Generation Wizard, locate the job in the table.
Check the job report output format you prefer.
Click and specify the Report Directory where you want to store the report file.
If you want to create a batch file to run multiple jobs, click Add, and then add the other jobs.
If needed, reorder the jobs using the Remove, Up, and Down buttons. For example, an archive needs to be 
created before its version can be used in a comparison job.
Click Next.
Click and specify the location where you want to store the batch script file.
Select the script format, .bat or .xml.

Make sure that the job has been saved.
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Click Finish. The job immediately runs.

Using the changec Command Line Program
The changec  command line program runs DB Change Manager job scripts. It is located in the DB Change 
Manager installation directory.

changec  options include:

The -job  option specifies the jobs to run. Its parameter is the fully-qualified job file name and location.

The -output  option specifies reporting format for the job. Its parameters are: CSV, XML, RTF, HTML, or 
PDF.
The optional -dontstore  flag specifies that the results for the job are not stored.

For example, the syntax below runs the MyConfigCompare database comparison job and generates a report in PDF 
format:

-job

“C:

\Users\test1\change_workbench_5_0\workspace\DatabaseChange\MyConfigCompare.d
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cj”

-output PDF “c:/report”

To execute multiple jobs from the same command line, use the following syntax:

changec -bulk bulk_file_name

Where  bulk_file_name  is a file where each row has a -job  option. The -job  option accepts these 
regular expressions:

** indicates all sub folders in a directory location
* indicates any string

For example, the following command runs all jobs in all projects and folders in the workspace:

changec -job workspace:\**\*.caj

To run a job from the command line:

From the command line, enter a command with the following format:
changec -job “path_and_name.dcj” -output report_format “ 

report_directory_path”
The job immediately runs and saves the report in the specified directory.
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Database management system reference
These topics describe the operations permissions and version information regarding the database management 
system (DBMS) or systems you use with DB Change Manager:

DBMS Operations Permissions
Version Information Reference
Version Information for DB2 for LUW
Version Information for Oracle
Version Information for SQL Server
Version Information for Sybase

DBMS Operations Permissions
When DB Change Manager performs operations based on data source comparisons, there are minimal permissions 
required in some cases, dependent on data source platform and the action itself.

Permissions Required for DB2 for LUW
Permissions Required for Oracle
Permissions Required for SQL Server
Permissions Required for Sybase

Permissions Required for DB2 for LUW

Task Permissions for Own Objects Permissions for All Objects

Archive and Compare

Schemas Alter Schema

Object Configuration

Settings

Compare Data Select privilege on the relevant tables 
and views.

Schema archive permissions on the 
database or schema objects used in 
the job.

Select privilege on the relevant tables 
and views.

Schema archive permissions on the 
database or schema objects used in 
the job.

Synchronize/Mask/Move 
Data

Insert/Update/Delete privileges on the 
relevant tables and views.

Schema archive permissions on the 
database or schema objects used in 
the job.

Insert/Update/Delete privileges on the 
relevant tables and views.

Schema archive permissions on the 
database or schema objects used in 
the job.
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Permissions Required for Oracle

Task Permissions for Own Objects Permissions for All Objects

Archive and Compare 
Schemas

No special privileges required. SELECT_CATALOG_ROLE

Alter Schema Object No special privileges required. DBA role to alter system objects

Configuration Settings Not applicable DBA role

Compare Data Select privilege on the relevant tables 
and views.

Schema archive permissions on the 
database or schema objects used in 
the job.

Select privilege on the relevant tables 
and views.

Schema archive permissions on the 
database or schema objects used in 
the job.

Synchronize/Mask/Move 
Data

Insert/Update/Delete privileges on 
the relevant tables and views.

Schema archive permissions on the 
database or schema objects used in 
the job.

Insert/Update/Delete privileges on 
the relevant tables and views.

Schema archive permissions on the 
database or schema objects used in 
the job.

Permissions Required for SQL Server

Task Permissions for Own Objects Permissions for All Objects

Archive and Compare 
Schemas

No special privileges required.

Encrypted stored procedures cannot 
be viewed.

No special privileges required.

Encrypted stored procedures cannot 
be viewed.

Alter Schema Object Permission to connect to the MSDB 
database.

No special privileges for objects 
owned by the user.

sysadmin

On SQL Server 2000, you must enable 
sp_configure  to allow updates, 

and have permission to connect to the 
MSDB database.

Configuration Settings Not applicable sysadmin
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Task Permissions for Own Objects Permissions for All Objects

Compare Data Select privilege on the relevant tables 
and views.

Schema archive permissions on the 
database or schema objects used in 
the job.

Cannot view encrypted stored 
procedures.

Select privilege on the relevant tables 
and views.

Schema archive permissions on the 
database or schema objects used in 
the job.

Cannot view encrypted stored 
procedures.

Synchronize/Mask/Move 
Data

Insert/Update/Delete privileges on 
the relevant tables and views.

Schema archive permissions on the 
database or schema objects used in 
the job.

Insert/Update/Delete privileges on 
the relevant tables and views.

Schema archive permissions on the 
database or schema objects used in 
the job.

Permissions Required for Sybase

Task Permissions for Own Objects Permissions for All Objects

Archive and Compare 
Schemas

No special privileges required.

Stored procedures cannot be hidden.

syscomment.text  read must be 
allowed in order to compare or 
archive stored procedures.

No special privileges required.

Stored procedures cannot be hidden.

syscomment.text  read must be 
allowed in order to compare or 
archive stored procedures.

Alter Schema Object No special privileges required. sa_role

Enable sp_configure  to allow 
updates

Configuration Settings Not applicable sa_role

Compare Data Select privilege on the relevant tables 
and views.

Schema archive permissions on the 
database or schema objects used in 
the job.

The compression comparison 
function is unavailable for Sybase at 
this time.

Select privilege on the relevant tables 
and views.

Schema archive permissions on the 
database or schema objects used in 
the job.

The compression comparison 
function is unavailable for Sybase at 
this time.
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Task Permissions for Own Objects Permissions for All Objects

Synchronize/Mask/Move 
Data

Insert/Update/Delete privileges on 
the relevant tables and views.

Schema archive permissions on the 
database or schema objects used in 
the job.

Insert/Update/Delete privileges on 
the relevant tables and views.

Schema archive permissions on the 
database or schema objects used in 
the job.

Version Information Reference
The following subtopics describe the version information used when comparing, archiving, or creating a 
configuration standard:

Version Information for DB2 for LUW
Version Information for Oracle
Version Information for SQL Server
Version Information for Sybase

Version Information for DB2 for LUW

Parameter Description

INST_NAME Name of the current instance.

IS_INST_PARTITIONABLE Indicates whether the current instance is a partitionable 
database server instance.

Possible return values are 0, if it is NOT a partitionable database 
server instance, and 1if it IS a partitionable database server 
instance.

NUM_DBPARTITIONS The number of database partitions.

If it is NOT a partitioned database environment, this value is 1.

INST_PTR_SIZE The bit size of the current instance. Values are 32 or 64.

RELEASE_NUM The internal release number as returned by the db2level 
command.

For example, 03030106.

SERVICE_LEVEL The service level as returned by the db2level command.

For example, DB2 v8.1.80.
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Parameter Description

BLD_LEVEL The build level as returned by the db2level command.

For example, n041021.

PTF The program temporary fix (PTF) identifier as returned by the 
db2level command.

For example, U498350.

FIXPACK_NUM The FixPak number as returned by the db2level command.

For example, 9.

Version Information for Oracle
On Oracle platforms, DB Change Manager provides a list of all products installed on the Oracle instance and their 
versions.

Version Information for SQL Server
On SQL Server, the following parameters are included:

Product Version (e.g. 9.00.3042.00)
Platform (e.g. NT INTEL X86)
Language
Physical Memory
Processor Count
Processor Type
Windows Version

Version Information for Sybase
On Sybase platforms, two groups of configuration parameters are supplied:

The Server Information group displays the results of executing sp_server_info , where the attribute 
name is the configuration parameter and the value is its value.
The Version Information group, which contains the following parameters:

Build Number
Build Type
Compilation Date & Time
Compilation Kernel
Compilation OS Bit Size

For entries that contain internal values, the numeric attribute is also available for standard comparisons. 
For example, the Product Version attribute has a character and an internal value of “8.00.2039” and 
524288, respectively. DB Change Manager supplies the Product Version as “8.00.2039,” and the Product 
Version Internal Value as 524288.


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Compilation OS Platform
EBF Version
Post Build Type
Product
Product Code
Version
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Preferences reference
To customize the interface, select Window > Preferences. The Preferences dialog lets you set general Eclipse as well 
as DB Change Manager options. Depending on you Eclipse environment, you may see additional nodes in the 
Preferences.

DB Change Manager Preferences
Eclipse SQL Development Preferences

Once you are familiar with the options, you can use the Preferences menu to select a specific category of DB Change 
Manager options.
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DB Change Manager Preferences
The following topics describe preferences specific to DB Change Manager:

CM/Config > Archive Options
CM/Config > Comparison Options
CM/Data > Comparison Options
CM/Data > Data Result Options
CM/Data > General
CM/Data > Mapping Validation
CM/Data > Script Generation
CM/Schema > Archive Options
CM/Schema > Comparison Options
Notification > Email Notification
Notification > Email Notification > Advance Settings
Notification > Email Notification > Contacts
Notification > Email Notification > Templates
Notification > File System Notifier
Notification > Popup Notification
Notification > Popup Notification > Advanced Settings
Projects
Reports
Script Execution Options
System Tray
Task Scheduler
Data Sources

CM/Config > Archive Options
You can set this option to take effect whenever you create a new configuration archive job:

Extract DDL

By default, a new configuration archive does not include DDL. If you want each new archive to include the DDL, 
check this box, and then click Apply.

CM/Config > Comparison Options
You can set this option to take effect whenever you create a new configuration comparison job:

Extract DDL

By default, a new configuration comparison does not include DDL. If you want each new comparison to include the 
DDL, check this box, and then click Apply.

CM/Data > Comparison Options
The Comparison Options defaults correspond to the job options listed on the Options tab of the Data Comparison 
Job editor. For more information, see Specify Execution, Mapping, Comparison, and Resolution Options.

Data comparison options are grouped into these categories:

Execution Options
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Mapping Options
Comparison Options
Resolution Options

Execution Options
Execution Options control aspects of processing the job:

Automatically Synchronize indicates that the job automatically attempts to synchronize any issues it finds 
between the source and target data sources upon completing comparison execution. If you leave this option 
unchecked, you can generate a synchronization script at a later point, after job completion.
Compression Comparison speeds up a job by compressing row data for faster transmission and 
comparison. The compression does not affect the accuracy of a job. This option is useful with slow networks, 
with large volumes of data in each row, and with faster database servers.

Optimize comparison based on row length. The value determines when compression is applied on a table 
during the data comparison process, based on the total size of all of the rows. If the size of the rows is 
greater than this value, then compression is automatically enabled.
Generate DML indicates that the synchronization DML used in the job is automatically placed in a separate 
file. If this option is selected, you can specify on the Notifications tab to send the resulting output with any 
notification.

Mapping Options
Mapping Options control how the data sources in the job are mapped to each other using the following options:

Ignore Case indicates that objects are analyzed without regard to case. For example, the table 
Product_Prices is compared to the table PRODUCT_PRICES.
Ignore Spaces indicates that spaces are ignored when analyzing objects. For example, the table Product 
Prices is compared to the table ProductPrices.
Ignore Underscores disregards underscores in object names for comparison purposes. For example, the 
table Product_Prices is compared to the table ProductPrices.
Include Views indicates that the comparison process include views during the mapping process. If this 
option is not selected, views are automatically excluded from the comparison.
Exclude Computed Columns indicates that the comparison does not include columns whose values are 
computed in the mapping and comparison processes.

For more information, see Customize Database Mapping.

Comparison Options
The Comparison Options specify how the job handles naming conventions:

Ignore Case indicates the job ignores case when comparing data. For example, Apple matches a 
corresponding value of apple.
Trim Trailing Spaces indicates the job comparison ignores extra spaces at the end of values when 
comparing data. For example, Apple matches a corresponding value of Apple.
Match Empty Strings with Nulls indicates that the job comparison considers empty values to be the same 
as null values for matching purposes.
Cache Long Datatype Values indicates that long data types (blob, clob, varchar(max), etc.) values that do 
not match are cached during comparison and available for resolution during that stage of the process. When 
this value is disabled, the results of the job indicate that the values did not match but resolution is 

Compression Comparison is not available for Sybase.
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unavailable. Individual long datatype values can be retrieved when exploring results regardless of the 
selection of this property.
Check Rows from Source checks the rows that exist in the source tables. If the option is not selected, the 
rows that exist on the source tables are not included in the comparison.
Check Rows from Target checks the rows that exist in the target tables. If the option is not selected, the 
rows that exist on the target tables are not included in the comparison.

Resolution Options
The Resolution Options section determines how the job resolves any discrepancies discovered during the 
comparison process.

Drop and Recreate Foreign Keys indicates that all foreign keys are dropped prior to applying changes 
during the resolution process. This option should be used with Wrap Statements in Transaction to ensure 
that foreign keys do not remain dropped in the event that the synchronization script used to resolve it fails.
If this option is not selected, a data comparison job generates ordered table insert and delete statements, 
and you must do the following tasks:

In the Mapping page, select all dependent tables. If a referenced table is missing from the 
comparison, DB Change Manager cannot ensure the referential integrity of the data.
If you also change the comparison key, you must set the same column as a comparison key for all 
dependent tables. If you do not do so, DB Change Manager cannot insure the referential integrity of 
the data.

Wrap Statements in a Transaction utilizes a transaction and rolls back any repository changes if it 
encounters an error.

Enable Identity Column Inserts and Updates enables changes to identity column values on SQL Server and 
Sybase platforms. The update and insert statements are automatically included in the synchronization 
script when this option is selected.

CM/Data > Data Result Options
The Data Result Options affect how data comparison results are processed:

Cache options. The Comparison Result Cache Location specifies the directory path of the result cache, 
where job data is captured. Use the Default Location, or de-select it, and then browse to a new directory 
location.

Refresh Interval. The Data Movement Progress Refresh Interval determines how quickly the progress of 
the data comparison is updated, in seconds.

CM/Data > General
The General options relate to data mapping:

Remembered dialog decisions. When you select a default masking rule on a database or table, this option 
affects the masking rule used on the corresponding tables or columns. Yes means the rule is used on all. No

This option is only available for SQL Server scripts.

This option is not supported for DB2 for LUW scripts.

This is a temporary cache. Large data comparison jobs may require many system resources.
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means the tables or columns use the rule set explicitly for them. The default Prompt allows you to make the 
decision at the time you select the masking rule on the database or table.
Don’t show again decisions. When the Automatically Synchronize option is toggled, some mappings 
become invalid and are removed. If you want to see this information, select this box.

CM/Data > Mapping Validation
DB Change Manager performs a variety of validation checks when it compares or synchronizes data. You can specify 
severity responses for mapping validation checks on comparison and synchronization jobs. By default, some checks 
always indicate an error. For other checks, you can configure the response.
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Ignore means that there is no indication regarding that specific validation check.
Warning means that a warning message indicating that there is a problem with the mapping validation is 
issued.
Error means that an error message indicating that there is a problem with the mapping validation is issued.

Once you configure the responses, click Apply.
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CM/Data > Script Generation
Script Generation Options affect how DB Change Manager builds a synchronization script for a data comparison job. 
These options are useful if the match key for a table in a data comparison job does not reflect uniqueness. For 
example, if a match is performed on last_name , and there are several values of “Smith” in a table, the data 
synchronization may have unexpected results.

Warn about duplicate rows. By default, DB Change Manager issues a warning whenever it encounters 
duplicate rows while generating a synchronization script.
Exclude duplicate rows. If you want to automatically ignore duplicate rows while generating a 
synchronization script, select this option.
Set quoted identifier ON/OFF. For SQL Server and Sybase only, if the quoted identifier database option is 
off, this option prefixes the data synchronization script with SET QUOTED IDENTIFIER ON  and suffixes 

it with SET QUOTED IDENTIFIER OFF .

Once you configure the responses, click Apply.

CM/Schema > Archive Options
The Include Table Dependencies option extracts all table dependencies. By default, it is not selected.

You can specify defaults for how to extract DDL when the option is enabled in the Schema Archive Job editor.

None means that DB Change Manager creates the archive in the development environment workspace. You 
can then extract the DDL directly from the archive.
One File means that DB Change Manager exports the objects of the archive job to a single .SQL file, in 
addition to building the archive in the development environment. You can locate the SQL file in the Project 
Explorer.
Multiple Files means that DB Change Manager exports each object of the archive job into individual .SQL 
files, in addition to building the archive in the development environment. You can locate the SQL files in the 
Project Explorer.

The Automatic Purge Options delete archive files after a number of days, number of versions, and/or when the size 
of the files reaches a certain limit. The purge conditions are checked and enforced when an archive job is saved or 
when a new version is created.

The number of Days after which archives are deleted.
The number of Versions stored, after which the oldest version is deleted.
The number of MB total size of the version files, after which the oldest version is deleted.

Once you configure the preferences, click Apply.

CM/Schema > Comparison Options
You can set the default job options for schema comparison jobs. Choose a database tab and then select the check 
box of the appropriate job option to indicate that it is on by default.

The list of options differs depending on the DMBS of the source and target data sources. The parameters in the 
panel correspond to the job options listed on the Options tab of the Schema Comparison Job Editor. The option 
categories include:

CM/Schema > Comparison Options > Include Objects Options
CM/Schema > Comparison Options > Compare Options
CM/Schema > Comparison Options > Decorator Options
CM/Schema > Comparison Options > Identifier Options
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CM/Schema > Comparison Options > DDL Extract Options
CM/Schema > Comparison Options > Additional Options
CM/Schema > General
CM/Schema > Mapping Options
CM/Schema > Refinements Options
Command Line
Compliance
Label Decorations

After you reconfigure any options, click Apply.

CM/Schema > Comparison Options > Include Objects Options
The Include Object Options settings determine what elements of the job source and target will be included or 
omitted when running a schema comparison job and synchronization. The list of options differs depending on the 
DMBS of the source and target data sources.

These options include:

The Exist in Source Only (Create) option specifies that objects only existing on the source appear in the job 
results.
The Exist in Source and Target and Don’t Match (Alter) option specifies that objects that differ between 
the source and the target appear in the job results.
The Force Extended Alter option specifies that the synchronization process always drops and recreates 
objects that don’t match instead of using an ALTER  statement on existing objects.
The Include Table Dependencies option indicates that table dependent objects are included in the 
generated DDL.
The Exist in Target Only (Drop) option specifies that objects only existing on the target appear in the job 
results.
The Generate Data Copy DDL indicates that data copy DDL is generated on extended  ALTER  statements 
in the automated synchronization script.

CM/Schema > Comparison Options > Compare Options
Compare Options settings affect how objects are treated in the comparison process. You can include or exclude 
specific object types in the job, and specify the behavior of the comparison job and synchronization scripts.

These options include:

Ignore Storage ignores storage comparison when running the job.
Ignore Partition Differences (Oracle only) ignores partition differences when running the job.
Ignore Column Order ignores table column order differences when running the job.
Ignore Check Constraints Quotes ignores quotes in check constraints when running the job.
Ignore Table Comment ignores table comments when running the job.
Ignore Text Case ignores syntax case in text object comparisons when running the job. (views, procedures, 
trigger, etc.)
Ignore Text Comments ignores comments in text objects when running the job.
Ignore Text Whitespace ignores white space when running the job.
Ignore Tablespace File Name ignores tablespace file names when running the job.

The list of options differs depending on the DMBS of the source and target data sources. If an option is not 
supported for the database, it is not available in the Preferences.


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Ignore Password Differences ignores differences in object passwords when running the job. (group, login, 
role, user, etc.)
Ignore Tablespace (IBM only) ignores tablespaces for table, index, cluster, etc.
Ignore Object Permissions ignores the permissions on objects when running a job.
Ignore Logging/No Logging Differences (Oracle only) ignores object differences where one is set to 
Logging and the other is set to No Logging.
Ignore Sequence Start Value (Oracle only) ignores the Start Value property of an Oracle Sequence.
Ignore Data Capture (IBM only) ignores the Data Capture property for tables.
Ignore File Group (SQL Server only) ignores the File Group property for tables and indexes.
Ignore Segment (Sybase only) ignores the Segment property for tables, indexes, and partition definitions.

CM/Schema > Comparison Options > Decorator Options
Decorator Options affect particular database objects.

These options include:

Preserve Target File Group (on extended alter) (SQL Server only) When an extended alter is generated for an 
object, the target objects file group remains the same as the original object if this option is enabled.
If this option is disabled, the targets objects file group are set to the one used by the source object.
Preserve Target Storage (Oracle only) The functionality is similar to Preserve Target File Group but this 
option applies to the storage properties of Oracle objects.
Preserve Target Tablespace (Oracle only) The functionality is similar to Preserve Target File Group but 
this option applies to the tablespace properties of Oracle objects.
Preserve Target Segment (Sybase only) Preserves the Segment property for tables, indexes, and partition 
definitions.
Recompile This option triggers a recompilation for dependent procedures, when the target object needs to 
be dropped and recreated (extended altered).
Comment Out Extended Alters for Tablespaces An extended alter is essentially a drop and then a recreate. 
For tablespaces, an extended alter is a dangerous operation that may cause data loss.
This option is by default enabled and generates commented out DDL for tablespace extended alter.

CM/Schema > Comparison Options > Identifier Options
The Identifier Options panel contains parameters that determine what elements of the source and target data 
source are ignored during the schema comparison and synchronization process.

These options include:

The Ignore Name Case option specifies that the syntax case is ignored when doing comparisons. This option 
is deselected by default.
The Ignore Constraint Names option specifies that differences in table constraint names are ignored when 
doing comparisons. This option is deselected by default.
The Ignore Specific Name (IBM DB2 for LUW only) option ignores SQL specific names in procedures, 
functions, and methods. This option is deselected by default.

CM/Schema > Comparison Options > DDL Extract Options
The DDL Extract Options section contains the Extract DDL parameter. When it is selected, the DDL code appears 
separate editor window after the comparison job runs. This option is deselected by default.

CM/Schema > Comparison Options > Additional Options
Additional comparison options are listed at the bottom of the list of preferences.
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These options include:

Enable Dependency Linking. When this option is activated, the comparison contains information about 
dependencies between objects. This information is critical for the ordering of the generated DDL. If the 
option is not enabled, the schema comparison is faster but when DDL is generated for more than one object, 
the ordering is incorrect. By default, Enable Dependency Linking is deselected for Oracle, so all GRANT
statements for Oracle objects are not extracted and compared.

CM/Schema > General
The General options relate to schema comparison jobs:

Show uncomment alter tablespace script confirm dialog. There is an alter tablespace script confirm 
dialog that displays by default. Deselect this option if you do not want to see this dialog.
Do not ask about running the created jobs. Select this option if you want to ignore the system prompt 
when running schema comparison jobs. If you select this option, you can also select whether to 
automatically run a schema comparison job when an object is created.
Automatically launch jobs created from selected objects. Select this option if you want to automatically 
run a schema comparison job when an object is created.

Once you configure new defaults, click Apply.

CM/Schema > Mapping Options
You can specify the default mapping job options available on the Mapping tab of the Schema Comparison Job 
editor:

Ignore Case. By default, schema comparison jobs ignore the case of the texts. Deselect this option if case is 
important to you.
Ignore Spaces. By default, schema comparison jobs ignore spaces in the texts. Deselect this option if spaces 
are important to you.
Ignore Underscores. By default, schema comparison jobs compare underscores in the texts. Select this 
option if you do want to ignore underscores.
Show Users. (Oracle only) By default, schema comparison jobs show users from the source and target that 
have at least one object. Select this option if you want to show all users from the target, regardless of 
whether they have any objects in their schema, and map them with users from the source.

Once you configure new defaults, click Apply.

CM/Schema > Refinements Options
The Refinements Options determine whether new objects are included. By default, they are included when you 
run a schema comparison job. You can configure the job to ignore new objects by unchecking this option.

Command Line
You can specify the Default Script Output for the following command line jobs:

Windows (*.bat). By default, the command line interface produces batch files.
Ant (*.xml). Click Ant (*.xml) if you want the command line interface to produce XML files by default.

Once you configure new defaults, click Apply. For more information, see Generating Command Line Scripts.
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Compliance
You can specify default compliance ranges for comparison results. These ranges are percentage amounts that 
specify when to pass, warn, or fail a configuration comparison job in the Compliance Explorer.

These options include:

Compliance Met. By default, this value is 100%, which allows a job to pass.
Compliance Critical. By default, this value is 75, meaning that 75-99% compliance results in a warning.
Compliance Not Met. By default, this value is 0, meaning that 0-74% compliance results in a failure.

Once you configure new defaults, click Apply.

Label Decorations
Label Decorations provides a link to the standard Eclipse Preferences section where you can specify decorations 
for an object in the Eclipse interface.

In the Job Decoration Text panel, select Project to add a decoration in the Project Explorer.

Once you configure new defaults, click Apply.

Notification > Email Notification
You can specify email server parameters that enable email notifications for jobs.

The parameters include:

Host. The name of the email host server is required.
Port. The default port number is 25.
Sender Address. The email address to use for sending email from DB Change Manager to others.
User Name. The user name of the sender on the mail server.
Password. The password of the sender on the mail server.
Web Server Report Directory. The root directory of the web server where DB Change Manager saves 
reports; for example, c:\apache2\htdocs.
Web URL Prefix. The URL used by DB Change Manager to specify links in the report and in the notification 
email; for example, http://www.webserver.com/.

Use the Test Email button to validate the settings. DB Change Manager prompts you for an email address, and then 
sends a test notification email to that address.

Once you have validated the email settings, click Apply.

Notification > Email Notification > Advance Settings
Advanced Settings lets you map SMTP properties to values. Refer to https://javaee.github.io/javamail/FAQ for more 
information.

SMTP properties are listed at: http://https://javaee.github.io/javamail/docs/api/com/sun/mail/smtp/package-
summary.html.

Notification > Email Notification > Contacts
Contacts are email addresses used in email notifications. When a new notification is sent, it is sent to all of the 
addresses added to the contact list.

To add a contact
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In Preferences > Notification > Email Notification > Contacts, click Add.
Enter an email address, and then click OK.

You can also import existing contact lists from XML files, or export the current contact list as an XML file.

Notification > Email Notification > Templates
You can create and edit email templates that format the texts used in email notifications. The default template 
shows how the templates work. You can add a template and customize the values of the template variables.

Available actions include:

Edit. The Edit button opens the Edit Template dialog for the selected template.

Add. Opens the Add Template dialog.
Remove. Removes the selected template.

To create a new email notification template

Select the default template.
Click Edit.
Click the Template Key icon on the left to see the template variables that are available.
In the Body section, select and copy the template text.
Click Cancel.
In Preferences > Templates, click Add.
In the Add a Template dialog Body section, paste the copied text.
Edit the text. Click the Insert template key dropdown to select from a list of variables.
Name the template.
Type the Subject content that is the subject of your email. You can use variables in a subject.

Notification > File System Notifier
You can specify where file system notifications are stored using Preferences > Notification > File System Notifier
options, including:

Enable file system notification service. By default, file system notifications are not enabled. Select this 
option to enable them.
Report, Log, and Script Directories. By default, file system notifications are created in the Documents and 
Settings/username/ Change Manager Results directory. Click Browse to change the default directories.

Once you have validated the email settings, click Apply.

Notification > Popup Notification
You can set the default options for System Tray notifications, including:

Enable system tray notification service. By default, system tray notifications are not enabled. Select this 
option to enable them.
Display notification time. By default, the notification lasts for 3000 milliseconds.
Show only when minimized to tray. By default, the popup displays when the System Tray is minimized.
Play sound. By default, if notifications are enabled, a sound accompanies a notification.
Custom sound. You can change the default sound and select a .wav sound file.

Once you have validated the email settings, click Apply.

Press Ctrl-Space on the Notification screen to open a list of variables.
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Notification > Popup Notification > Advanced Settings
You can change the default options for System Tray notifications. These options include:

Generate notification when job is run from. By default, if notifications are enabled, a notification is 
generated for each job run from the Workbench or from the command line. You can limit notifications to one 
or the other.
Generate notification when job finishes. By default, a notification is generated for each job that succeeds 
or fails. You can limit notifications to one or the other.
Generate notification for threshold. This option is currently unavailable.

After you change the notification settings, click Apply.

Projects
The Projects option applies to the Project Explorer:

Suppress Project Required Warning Dialog. This option disables the warning dialog when using the Project 
Explorer. By default, it is disabled.

After you change the projects settings, click Apply.

Reports
The Reports settings let you customize the look, feel, and format of reports issued when you generate a job report 
for comparison jobs.

The Report Style tab
Logo. You can browse to upload a logo. The logo should be 80 pixels wide by up to 420 pixels tall.
Accent color. You can select an accent color from the color palette.

After you change the style settings, click Apply.

The Paper Setup tab
Paper size. You can use the dropdown list to select from a list of standard paper sizes, and choose 
between Portrait or Landscape orientations.
Margins. You can set the Top, Right, Left, and Bottom margins for the paper. If you prefer not to use 
inches, set the Unit option to either centimeters or millimeters.

After you change the paper setup options, click Apply.

The Contents tab
CM/Config: Include matching configuration parameters. By default, matching configuration 
parameters are included in a report.
CM/Data: Include matching data fields (database level). By default, matching data fields in 
databases are included in a report.
CM/Data: Include matching data fields (table level). By default, matching data fields in tables are 
included in a report. You cannot change this option.
CM/Data: Include detail reports in CM/Data notifiers. By default, details are included in a data job 
notification.
CM/Schema: Include matching schema objects. By default, matching schema objects are included 
in a report.
CM/Schema: Include DDL in Schema Reports. By default, DDL is included in a report. If you do not 
need the DDL in the report, and to improve performance, deselect this option.
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Split reports when exceeding _ number of objects. By default, reports including over 1000 objects 
are split into multiple sections, to improve performance. You can change the default number of 
objects in a section.

After you change the contents options, click Apply.

The Font tab
Path. By default, DB Change Manager includes the FreeSerif.ttf font for use in reports. You can 
change this to another font on your system.
PDF Encoding. If you change the font, make sure that the appropriate PDF encoding is set. Leave the 
field blank to use the default encoding.

After you change the font options, click Apply.

Script Execution Options
The Script Execution Options apply to automation scripts:

Connection Auto Commit. By default, auto commit applies to synchronization scripts for data comparison 
jobs.

If you change the script execution settings, click Apply.

System Tray
The System Tray options affect the Windows System Tray:

Show System Tray Icon. By default, the System Tray icon is shown.
Minimize to System Tray. You can minimize the system tray by selecting this option.

If you change the System Tray settings, click Apply.

Task Scheduler
The Task Scheduler options affect batch files:

Always schedule auto generated batch files. By default, automatically generated batch files do not run on 
schedule. Select this option to require scheduling.
Batch files directory. By default, batch files are saved in Documents and 
Settings\username\change_manager_x\workspace\Change Management\AutoGeneratedBatchFiles. 
You can change this to another directory.

If you change the task scheduler settings, click Apply.

Data Sources
The Data Sources preferences specify where registered data source definitions and metadata are stored:

Data Sources. By default, batch files are saved in Documents and Settings\username\Application 
Data\IDERA\Data Sources. You can change this to another directory.
Metadata. By default, metadata files are saved in Documents and Settings\username\Application 
Data\IDERA\Data Sources\metadata. You can change this to another directory.

If you change the data source file location settings, click Apply.
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Eclipse SQL Development Preferences
Some SQL Development preferences are important for DB Change Manager jobs, including:

SQL Development > SQL Editor
SQL Development > SQL Editor > Code Assist
SQL Development > SQL Editor > Code Formatter
SQL Development > SQL Editor > Results Viewer
SQL Development > SQL Editor > Syntax Coloring
SQL Development > SQL Filters

SQL Development > SQL Editor
The SQL Editor options include:

Enable the SQL Parser for Files Smaller than 700 KB
By default, for better performance files smaller than 700 KB are enabled, and larger files are disabled. You 
can configure the file size.
Deselecting Enable the SQL Parser disables many of the “smart” SQL Editor features including code 
formatting, auto completion, semantic validation, and hyperlinks.
Severity Level for Semantic Validation Problems
This option determines how semantic code errors are flagged in the SQL Editor and the Problems view.

SQL Development > SQL Editor > Code Assist
The Code Assist options affect code completion features in the SQL Editor:

Enable Auto Activation
By default, Code Assist is enabled. The auto-activation delay determines how long before the Code Assist 
feature activates.
Insert Single Proposals Automatically
By default, if only a single code completion suggestion is returned, it is automatically inserted. To disable 
automatic inserts, deselect this option.
Fully Qualify Completions Automatically
By default, code completion results are the minimum required to identify the object. Select this option to 
return specific, fully-qualified code completions.
Code Assist Color Options
By default, the background color of code completion proposals is white and the foreground is black. You can 
modify these options using the color picker.

SQL Development > SQL Editor > Code Formatter
The Code Formatter options configure code formatting in the SQL Editor. DB Change Manager provides a built-in 
profile.

You can choose from a drop-down list of formatting profiles, and the Preview box displays how each profile 
formats code. You can import your own custom Code Formatter profile.

SQL Development > SQL Editor > Results Viewer
The Results Viewer options specify how the Results view displays results, and whether the results are shown in the 
SQL Editor or sent to a file.
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Results sets options include:

Maximum number of result sets
By default, up to 100 results sets are included.
Suppress execution messages
Select this option to disable system messages in the Results view.

By default, results are shown in SQL Editor. The Show results in editor options include:

Grid refresh interval (ms)
This option defines the speed in milliseconds that the Results view refreshes.
Maximum result rows to sort
By default, the results will sort up to 25,000 rows.
Results Format
By default, Results are in a grid format. You can change that to HTML, XML, or text format.
Stripe the rows of the results table
This option adds intermittent highlighted bars in the Results view.
Display results in separate tab in the SQL Editor
This option opens the Results view in a separate tab on the Workbench. You can save results to a file. When 
selected, you specify:

Prompt to save file
Whether DB Change Manager will prompt you to specify a location for the file. If so, you must specify 
a default location for the file.
Include SQL text
To include SQL text, you must specify a file format and text qualifier.

SQL Development > SQL Editor > Syntax Coloring
The Syntax Coloring options change the look and feel of code syntax in the SQL Editor. Use the Element box to 
select the comment type or SQL element you want to modify, and assign color options on the right. The Preview
box displays sample code that updates according to the changes you make.

SQL Development > SQL Filters
The SQL Filters options specify whether to ignore system objects when performing jobs. By default, system objects 
are ignored. For more information, see Filtering Data Source Objects.
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User interface reference
This section describes the various dialogs, editors, and menus available in DB Change Manager. Understanding how 
the DB Change Manager user interface functions helps you work faster and more efficiently.

The following interface components compose the DB Change Manager work environment:

DB Change Manager Workbench
Welcome Page
Workspace
Views
Editors
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DB Change Manager Workbench
The Workbench is the DB Change Manager development environment. It provides the interface to create, manage, 
and navigate DB Change Manager processes through interaction with views, editors, and menus.

Based on Eclipse standards, the individual parts of the Workbench share certain elements in common and provide 
you with a uniform, integrated system for working in DB Change Manager. In addition, you can customize aspects of 
the environment to suite your development requirements.

The Workbench space is composed of Views and Editors, as well as the Menu Bar and Command Toolbar.

The Menu Bar options control functionality and processes. They apply either to the whole application, or to 
individual views and editors, depending on what has the focus of the mouse.
The Command Toolbar icons run commonly-used Menu Bar commands.
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License Selection Dialog
The license Selection dialog opens if, at startup, the product detects more than one license available. You can 
choose the license you want to use from a list that includes details about each license.
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Welcome Page
The Welcome page opens when you launch DB Change Manager. It provides easy access to information for new 
users, and helps you get started with the application.

The Getting Started tab presents commonly-performed tasks. Choose the options you want, and then click 
Get Started. A list of related instructions appears.
The New Job tab provides a list of jobs that you can run. Click the job you want to start, and then the 
appropriate editor opens.
The Recently Changed tab displays jobs that are recently modified. Select a job from the list, and then click 
Open Job to open the job in the Workbench.
The Recently Run tab displays jobs that are recently executed. Select a job from the list, and then click 
Open Job to open the job in the Workbench.
The Tutorials tab lists DB Change Manager tutorials which describe how to perform various tasks. Choose a 
tutorial, and then click Start the Tutorial to begin.
The Show on Startup check box controls whether the Welcome page opens when you start DB Change 
Manager.
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Workspace
A workspace is the location where your project files are stored. When you have many Eclipse projects, workspaces 
make it easier to organize and manage your work.

The Workspace launcher allows you to switch between multiple DB Change Manager workspaces, or convert 
workspaces to new versions of DB Change Manager.

To switch DB Change Manager workspaces

From the Main menu, click File > Switch Workspace.
In the Workspace Launcher dialog, browse to the directory and select it.
Select the version of the older workspace.
Click OK.
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Views
Job explorer
Navigator view
Compliance Explorer
SQL Errors view
Data Diff view
Extract DDL Scripts
SQL Log
SQL Errors Log
Search view

A view is a Workbench interface component typically used to navigate a hierarchy of information or list, open 
editors for jobs, or display properties or settings.

Views complement editors and provide alternative presentations or navigations of the information in the 
Workbench. For example, Data Source Explorer provides a list of all registered data sources in DB Change Manager, 
organized by group folder.

Views can be active or inactive, but only one view can be active at any one time. The title of an active view is 
highlighted and the view is the target for common commands such as cut, copy, and paste. Views can be stacked 
with other views to create tabbed notebooks.

All views have two ways to access command menus:

Right-click the view tab
Click the icon in the view toolbar

Here are some of the ways you can interact with views:

To move a view. Click the tab of the view and drag your mouse. A frame indicates where the view will fit in 
the Workbench. Release the button to move the view to its new location.
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To toggle a floating view. Right-click the tab of the view and select Detached. The view switches to a 
floating window format that can be used to position it overtop of embedded views in the Workbench.
To build a tabbed view. Drag a view over another view and release the mouse button when the frames 
meet. Both views overlap and create tabs within the same frame. You can combine multiple views in this 
way.

Job explorer
Job Explorer provides an interface for managing existing jobs in DB Change Manager.

Use Job Explorer when searching for jobs of a specific type or name. You can list jobs according to a wide variety of 
categories.

To view jobs in Job Explorer

Navigate to Job Explorer, and then click Arrange By to view a list of categories.
Select a category. Job Explorer displays all jobs based on your new selection.

To open a job in its editor

In Job Explorer, double-click a job.

Viewing change history
Each time a job runs, its history is recorded and listed in the Job Explorer. You can see the history of a specific job in 
the job editor History tab.

Data Source Explorer
Data Source Explorer lists registered data sources and the comparison jobs and archives associated with them.

When you register a new data source, you specify its connection information. Once registered, it remains stored in a 
catalog and does not need to be re-registered. It can be archived and used in multiple jobs.

You can organize data sources based on working sets. A working set is a user-defined collection of data sources.

To create a working set

Click the menu icon in the Data Source Explorer toolbar.
Click Select Working Set.
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In the Select Working Set dialog, click New to define a new set.

When you select a working set, Data Source Explorer only shows those data sources you specified for the set. To 
change back to the default view, click the menu icon, and then choose Deselect Working Set.

To add a data source

Right-click on the Managed Data Sources node in Data Source Explorer, and then select New > Data Source. 
The Add Data Source dialog appears.

Follow the steps in the Data Source Wizard by selecting the data source platform and entering the 
appropriate connectivity parameters in the fields provided.
Click Finish when you are finished. The new data source appears in Data Source Explorer.

To create Data Source Group folders and organize Data Source Explorer objects
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Right-click the Managed Data Sources node in Data Source Explorer, and then select New > Data Source 
Group. The Create Data Source Group dialog appears.

Enter a meaningful name for the new group in the Name field, and then choose a parent folder, if any.
Click Finish. The Data Source Group folder is added to Data Source Explorer. You can drag and drop data 
sources in the folder or add new data sources to the folder.

Data Source Properties
After you import a data source, you can view and change its properties.

Basic Data Source Configuration

The name and connection properties you specified when you set up the data source are available in the 
Configuration pane.

To change data source properties
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In the Data Source Explorer, right-click on the data source, and then select Properties. The properties pane 
displays the Data Source Configuration tab.

In the Data Source Configuration pane, you can review and update important details about:
The name
The type of database and its network connections
The default database
The user name and password for the connection, and whether it is encrypted and trusted

Click Apply to save the configuration.
Click Test Connection to validate the configuration.

Lifecycle Categories for Organizing Data Sources

You can categorize data sources into the phases of the database lifecycle: Development, Test, QA, and Production. 
Use the Category dropdown menu to assign a category to a data source. The color coding of the category, if set, is 
displayed in the Data Source Explorer so you can easily differentiate the usage of multiple databases.
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Drivers for Data Source Connections

The Advanced tab of the Data Source Configuration properties lets you specify the JDBC or other driver properties.

Project Explorer
Project Explorer provides a list that organizes jobs, standards, and synchronization scripts into project folders.
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The list is organized by Jobs, Standards, and Sync Scripts. Double-click on the objects to open them in their 
editors.

A group of administrators can share a set of project files by connecting it to a source code control system and using 
the Navigator.

You can use the File > New > Project command to create project folders to organize and manage your jobs. When 
you create a new project, a folder is added to the Project Explorer with the name that you specified. You can add or 
delete files under this folder by dragging and dropping them from the Change Management branch.

To create a new project

Select File > New > Project. The New Project wizard appears.
Expand the General Node, and then select Project.
Click Next.
Type a project name into the field provided. The Location field indicates where the project files are stored 
on your machine. By default, all project data is stored in the location where you installed DB Change 
Manager. If you want to change this location, deselect the Use Default Location check box and define a new 
directory location.
Click Finish. The new project folder appears in Project Explorer.

Navigator view
The Navigator view lists all files in each of your projects. You use the Navigator to share files with a source control 
system for jobs, results, standards, and scripts.
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Whenever a job, standard, or synchronization script is generated by the system, its output is saved to a file that is 
stored in a directory and displayed in the Navigator. These files can then be shared in a team environment using a 
source control system.

All jobs, synchronization scripts, and archive versions are stored in XML format, so that objects can be merged and 
differentiated between multiple versions of the same object.

Compliance Explorer
The Compliance Explorer provides you a quick way to see comparison jobs that may have failed compliance checks.

The Compliance Explorer lists comparison jobs that have been run and specifies:

The day the job was last run
The day the job last failed, if applicable

By default, jobs are not listed in the Compliance Explorer. To list a job here, select Track Results in Compliance 
Editor check box on the Overview tab of the specific job.

SQL Errors view
When comparison jobs run, you can optionally generate a SQL script that can synchronization the data repositories 
of the data sources. A synchronization script can be saved and retrieved at any time, and executed within the 
application.

The SQL Errors view logs any errors that may occur when executing SQL scripts.

Before you can use source code control, you need to install an Eclipse third-party plug- in and the 
appropriate client tools.


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SQL Errors are listed by SQL Error Code, SQL State, Resource, and Location.

Data Diff view
The Data Diff view displays the values of a mismatched row pairs when viewing the results of a data comparison job. 
The view contains row synchronization icons and the specific data values of a selected pair.

You can specify how data is resolved in the Data Diff view by selecting one of the appropriate icons beside the 
Synchronization prompt. By row, you can choose to Make Target Match Source for Selected Row, Make Source 
Match Target for Selected Row, or Do Not Resolve Selected Row, respectively.

You can add the Data Diff View to the Workbench by selecting Window > Show View > Data Diff View.

This view lets you specify changes without resolving the repositories of both data sources with synchronization 
scripts.

Extract DDL Scripts
To extract the DDL of the archive contents to a file

Open the Version tab of the archive.
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In the Archive Contents list, right-click the object, and then select Extract DLL Scripts.
The Extract DLL Scripts window opens.

Select the object for which you want to save scripts.
Select One File to save the DDL for all selected objects to one file, or select Multiple Files to save the DDL for 
all selected objects into single files for each object.

SQL Log
The SQL Log captures all SQL commands executed by SQL Editor and the system. SQL Log entries are listed by SQL 
Statement name, Date issued, Host/Server, Service, User, Source, and the Time (in milliseconds) it took to 
execute the command.

SQL Errors Log
The SQL Errors log automatically logs all SQL errors encountered when SQL commands are executed through DB 
Change Manager. Errors are listed by Error Code, SQL State, error Details, Resource, and the Location of the error 
in the SQL file.

Search view
The Search view displays result values when you issue the Search command from the Main Menu.
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The returned results are organized by the job type where the file resides, or by synchronization script, depending on 
the scope you specified. Navigate to the file that you want to open and double-click it. The file opens in a separate 
editor window.

In addition, the Search view toolbar provides shortcuts to preferences, a filter option when viewing results, and 
history commands to return or review old search results.

For more information about searching for files, see Searching for Database Objects and Synchronization Scripts.

Searching for database objects and synchronization scripts
The Search function provides a means of searching for database objects you have registered, and synchronization 
scripts generated by DB Change Manager.

To open the Search dialog

Click the Search icon in the Toolbar, or select Search > Search from the Main Menu.

The Search dialog contains two tabs:

Database Search
File Search

To search for databases

Navigate to the Database Search tab.
Use the parameter fields provided to search and locate a database:

In the box on the left-hand side of the window, use the check boxes to select the Data Source Groups
you want to search in.
In the Search String field, type a value to search. Use the * character to indicate wildcard string 
values, and the ? character to indicate wildcard character values. The \ character indicates an escape 
character for literals. (* ? and /).
Select Case Sensitive to take case into account when searching for string matches.
Select Search Indexed Data to include any information that is retained by DB Change Manager’s 
indexing function.
Select Apply SQL Filters to apply any filters you may have associated with the registered data 
sources in the system.
Specify whether the search is limited to Declarations, References, or All Occurrences in the Limit 
Search to section.
In the box in the lower right-hand corner of the screen, select and de-select the object types you want 
to include in the search. Only selected objects that match your search criteria are returned.

Click Search. 
DB Change Manager returns a list of all possible script selections based on the variables you entered.

To search for synchronization scripts

Navigate to the File Search tab.
Use the parameter fields provided to search and locate a synchronization script:

Type a value to search in the Containing Text field. Use the * character to indicate wildcard string 
values, the ? character to indicate wildcard character values, and the \ character to indicate an 
escape character for literals. (* ? and /).
Select Case Sensitive to take case into account when searching for string matches.
Select Regular Expression to identify the string as a regular function in terms of search criteria.
In the File Name Pattern field, specify the extension name of the files to search for explicitly. If the 
value in this field is a * character, the search function searches all files regardless of extension. 
Manually type the extensions to indicate the file type (separate multiple file types with commas), or 
click Choose and use the Select Types dialog to select the file extensions the process will use to 
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search for the string. For example, selecting *.caj searches for configuration archive job files, 
exclusively.
Select Consider Derived Resources to include derived resources in the search.

Click Search. 
DB Change Manager returns a list of all possible script selections based on the variables you entered.
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Editors
Editors are Workbench interface components that enable DB Change Manager jobs.

Data Comparison Job Editor
Configuration Comparison Job Editor
Configuration Standard Editor
Configuration Archive Job Editor
Schema Comparison Job Editor
Schema Archive Job Editor
SQL Editor
SQL Session Options

The following actions can be performed on all editors:

To move an editor

Click the tab of the editor and drag your mouse. A frame indicates where the editor fits into the Workbench. 
Release the button to move the editor to its new location.

To build a tabbed frame

Drag the editor over another editor and release the mouse button when the frames meet.

Both editors overlap and create a tabbed frame. Multiple editors can be combined in this format.

Data Comparison Job Editor
The Data Comparison Job editor compares the data repositories of two specified data sources at the table and row 
levels. In addition, the editor lets you specify table mappings and data matching functions that synchronize it at the 
global, table, and row level. It also provides high- level mapping refinement options for a job, specific to the data 
source.
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For more information on comparing the data repositories of two specified data sources, see Comparing data.

Configuration Comparison Job Editor
The Configuration Comparison Job Editor compares the configuration settings of two specified data sources. 
Additional, the editor provides the ability to define standard settings templates and archive individual data source 
properties to be used in comparison jobs.
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For more information on comparing the configuration settings of two specified data sources, see Comparing 
database configuration settings.

Configuration Standard Editor
The Configuration Standard editor defines a configuration standard. A configuration standard is a set of customized 
data source configuration properties. Once defined, standards are used in configuration comparison jobs against 
data sources and archives to compare against a specific set of values and threshold operators. You use standards in 
configuration comparison jobs to ensure that configuration values fall within acceptable ranges.

If you want to add the properties of an existing data source or archive to a new standard, click and drag the 
appropriate object from Data Source Explorer to the Standard Sources table. All of the properties of the selected 
data source or archive populate the new standard.
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For more information on creating configuration standards, see Creating a standard for configuration settings.

Configuration Archive Job Editor
The Configuration Archive Job editor provides the ability to capture a snapshot of existing data source 
configuration values. You can version the same archive multiple times, so you can store and use archive 
configuration values from different points in time.

Configuration archives are snapshots of existing data source configuration values. Each data source in your 
environment can contain multiple archive versions. These versions can be used in configuration comparison jobs 
against other data sources, archives, or standards.
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For more information on creating configuration archives for data sources, see Creating a configuration archive.

Schema Comparison Job Editor
The Schema Comparison Job editor compares two schemas on registered data sources, to identify differences 
between them. You can compare the schemas of two live data sources, a live data source and an archive, or two 
archives. For example, in order to ensure that approved changes are rolled forward between testing and production 
environments, you could first archive a baseline schema and use it to compare with the live environment once the 
move is completed.

DB Change Manager can support cross-platform schema comparisons, but such jobs are limited to the following 
DBMS combinations and data source objects:

DBMS Source/Target Objects Compared

Sybase / SQL Server Tables, Unique Keys, Check Constraints, Foreign Keys, Indexes, 
Primary Keys, Views

Oracle / SQL Server Tables, Unique Keys, Check Constraints, Foreign Keys, Indexes, 
Primary Keys, Views
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For more information on comparing the schemas of two data sources, see Comparing schemas.

Schema Archive Job Editor
The Schema Archive Job editor captures a "snapshot" of an existing schema archive. The interface provides the 
ability to version the same archive multiple times, so you can store and use archived schemas from different points 
in time.

Schema archives are snapshots of existing schema values. Each data source in your environment can contain 
multiple archive versions. These versions can be used as baselines in schema comparison jobs against other data 
sources, archives, or standards.
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For more information, see Creating a schema archive.

SQL Editor
In the SQL Editor, you can view and modify job scripts.
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When DB Change Manager initially generates a script, it appears in SQL Editor. By default, new scripts are 
automatically saved and appear in the Navigator and Project Explorer in a default directory specified by DB Change 
Manager. You can edit the SQL scripts and save your changes.

When an SQL file is open in the Workspace, select it and choose a database and an associated catalog on which you 
want to execute file using the drop down menus in SQL Editor. You can execute the code on the specified database 
and catalog, start a transaction or commit a transaction, or modify the SQL session options prior to execution.

To run SQL code

Open the SQL file you want to run, ensure it is associated with the correct database
Click the Execute icon. 
DB Change Manager executes the code on the data source you specified. Results are displayed in the same 
or a new tab.

To execute a transaction

Open the transaction file you want to run and ensure it is associated with the correct database.
Click the Start Transaction icon. 
DB Change Manager executes the transaction on the data source you specified.

To commit a transaction

Open the transaction file you want to commit and ensure it is associated with the correct database.
Click the Commit Transaction icon. 
DB Change Manager commits the transaction on the data source you specified.

You can set transactions to auto-commit prior to execution on the SQL Execution node of the Preferences panel.

•

The synchronization script generation process does not support all object parameters. The following 
object parameters should be manually added after a synchronization script is generated, as required:

fillfactor


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SQL Session Options
The SQL Session Options dialog provides configuration parameters for running code in the development 
environment.

To modify SQL session options

On the Toolbar, click the SQL Session Options icon.
In the SQL Session Options dialog, click on individual parameters in the Value column to change the 
configuration of each property, as specified.
Click Finish.
The session options change and DB Change Manager executes the code as specified when you launch the 
script.

•

•

•

consumers

allow_dup_row

statistics
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You can rerun scripts that are saved in DB Change Manager by double-clicking the script name in the Navigator 
view.

Session options only apply to the corresponding editor and are not retained when executing 
multiple SQL files.


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Eclipse plugin extensions reference
DB Change Manager publishes extensions that can be implemented as plugins to customize the application.

The Notifications extension helps you code a plugin for DB Change Manager that implements any type of job 
execution notification required for your organization. DB Change Manager includes email notification by default, 
and you can code additional Java plugins to add to DB Change Manager.

The Configuration Parameters extension helps you code a plugin for DB Change Manager that adds additional 
configuration parameters and values for configuration standards, archive jobs, and comparisons. DB Change 
Manager includes plugins for standard configuration properties and version information, and you can code 
additional plugins that query data sources using Java JDBC for additional or environment-specific information.

To write Eclipse plugins, you need to have some experience coding in Java. For instructions, see:

Creating and implementing a notification plugin
Creating and implementing a custom configuration plugin
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1.

2.

Creating and implementing a notification plugin
Notifications can be set to alert you if a job is successful, unsuccessful, or either result. Additionally, a notification 
can also indicate if a job was launched from the Workbench or from a command line, and can produce a report in a 
number of different file formats.

You can select the following options and option parameters using the job notification plugin:

Notification Option Option Parameters

Notify When Run From Workbench
Command Line
Both

Attached Report None
CSV
XML
HTML
PDF
RTF

Send Notification Always
Only on Success
Only on Failure

Notification parameters are set independently on each job configured in DB Change Manager. Additionally, each set 
of notification options apply individually per job selected.

The notification plugin must be defined in Eclipse and then activated in DB Change Manager. The following tasks 
provide a high-level overview of defining and implementing the notification plugin:

Create a plugin project
Configure the target platform
Define dependencies
Implement a notifier class
Implement a viewer contribution
Specify setup constants
Implement the DirectoryNotifier class
Implement the DirectoryNotifierContribution class
Register the extensions
Deploy the Notifier plugin

Create a plugin project
In order to start building a plugin, you need to create a new plugin platform in Eclipse.

To create a plugin project

Select File > New > Other.
The Select a Wizard dialog appears.
Select Plugin Project, and then click Next.
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4.

5.

Type a name for the plugin in the appropriate field, and leave the remainder of the parameters as they 
appear.
Click Next.
Retain the default parameters on the next dialog, and then click Finish.
The new plugin project is created in Eclipse and is ready for plugin development.

Configure the target platform
The target platform for the plugin development process needs to be identified in DB Change Manager. This 
indicates to the new plugin for what product it extends, and grants the plugin access to the system.

To configure the target platform

Select Window > Preferences.
The Preferences dialog appears.
Choose the Plugin Development > Target Platform node, and then click Browse.
Navigate to the install directory for DB Change Manager.
Click Apply, and then click OK.
The Preferences dialog closes and the target platform of the plugin is now indicated.

Define dependencies
The new plugin requires a pair of dependency definitions on the DB Change Manager Notification plugin:

com.idera.change.notifications

org.eclipse.ui.forms

Navigate to the META-INF  folder in your project and double-click  MANIFEST.MF .

The  MANIFEST.MF  file opens in Eclipse.
Select the Dependencies tab, and then click Add.
Choose com.idera.change.notifications , and then click OK.
The dependency is added.
Choose org.eclipse.ui.forms , and then click OK.
The dependency is added.
Press Ctrl+S to save the changes; or choose File>Save from the menu to retain the new dependencies, and 
then close the editor.

Implement a notifier class
Each notification plugin requires a Notifier  class that must implement the interface 

com.idera.change.notifications.api.INotifier . To do this, you subclass 

com.idera.change.notifications.api.AbstractNotifier  and customize it.

To implement a notifier class

If AbstractNotifier  or INotifier  cannot be found in Eclipse, the target platform or plugin 
dependencies are not configured properly. Ensure that you have configured these prerequisites and then 
search again for the notifier classes.


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•

•

Right-click on your project, and then select New > Class.
The New Java Class dialog appears.

Enter the appropriate information in the fields provided to define the new Java class:
In the Name field, type "DirectoryNotifier".
In the Package field, type "org.acme.directorynotifier".
In the Superclass field, type "com.idera.change.notifications.api.AbstractNotifier".

Click Finish to create the new class.

Once you have defined the DirectoryNotifier  class, two methods require implementation:

isReportSupported  returns a Boolean value indicating if the notification can include a report. The 
directory notifier returns true, because reports can be replaced in a directory, but a notification may not 
support reports. This method is called when creating job editors to determine if the reporting section is 
shown for this type of notification.
sendNotification  is called after a job runs and is responsible for the notification. The three 

parameters are as follows:
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Parameter Type Description

notifierData iNotifierData This instance contains the configuration for 
the notification of the job just run.

jobMetaData Map<String, String> This map contains information about the job 
execution. The keys in the map correspond to 
entries in the NotificationPropertyEnum.
For example, to get the data and time of the 
execution, you would code:
"jobMetaData.get(NotificationPropertyEnum.
DATE_TIME.getTag())"
NOTE: The keys are the tag of the enum 
entries, so ensure that getTag() is called when 
accessing jobMetaData.

notificationInfo iReportGenerator Used to generate the report and access any 
DDL or sync script output.

Implement a viewer contribution
Each notifier can be configured for a job in DB Change Manager.

The notifier enables a user to select a target directory in which to put results. The email notifier that is supplied with 
the application enables users to select the email template that will be used to generate the message as well as the 
addresses of those who will receive it.

In order to add a directory field to the job editor, you write a class that implements the interface named 
com.idera.change.notifications.api.INotifierViewerContribution .

Create a new class named "DirectoryNotifierViewerContribution" and follow the same steps you used to 
create the DirectoryNotifier  class. The exception to this process is that you need to leave the 
Superclass parameter set to "java.lang.Object", as well as adding the interface 
INotifierViewerContribution  to the list of implemented interfaces.

Specify setup constants
The notifier only allows users to select a directory in which reports and outcomes are written whenever jobs are 
executed.

The DirectoryNotifierConstants  class is a small constants class that stores the property name for 
storage and retrieval purposes.

Create a new class named DirectoryNotifierConstants .

Enter the following code for the class definition:  

/**

          * Constantsforthisnetworksharenotifier

          */

          publicfinalclassDirectoryNotifierConstants

http://www.idera.com/
http://www.idera.com/productssolutions/sqlserver
https://www.idera.com/buynow/onlinestore
https://idera.secure.force.com/
http://community.idera.com/
http://www.idera.com/resourcecentral
http://www.idera.com/about/aboutus
https://www.idera.com/legal/termsofuse


IDERA DB Change Manager 18.4

IDERA|Products|Purchase|Support|Community|Resources|About Us|Legal

181

•

•

•

1.

2.

          {

                     //Overviewfilename publicstatisfinalString 

OVERVIEW_FILE_NAME="outcome.txt";

                    //PersistedJobSettingsKey 

publicstatisfinalSTringTARGET_DIRECTORY="directorynotifier.targetdir";

          /**

          * Constantutilityclasscannotbeinstantiated

          */

          privateDirectoryNotifierConstants()

          {

          }

}

Implement the DirectoryNotifier class
The DirectoryNotifier  class can be coded with two return methods:

isReportSupported

SendNotification

To implement the isReportSupported  method

Enter the following code:

public boolean isReportSupported()

{

     return true;

}

To implement the SendNotification  method

To add the notifierProperties  and assign the targetDirectory  to a variable to provide a 
directory that the user selected for the executed job, add the following code:
     public void sendNotification (INotifierData notifierData, Map<String, 

String> jobMetaData, notificationInfo

     Map<String, String> notifierProperties = 

notifierData.getNotificationProperties(); 

     String targetDirectory = notifierProperties.get 

(DirectoryNotifierConstants.TARGET_DIRECTORY);
Enter the following code to define that the report and output file need to be placed in a directory whose 
name is composed of the job execution date and time.
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     //Create a new directory named by the execution date and time

          String dateTime = jobMetaData.get 

(NotificationPropertyEnum.DATE_TIME.getTag() ); 

          File dir = new File (targetDirectory +  File.seperatorChar + 

dateTime.replace ( ':', '-' ) ); 

          boolean createdDirectory = dir.mkdir(); 

          if (!createdDirectory )

          {

          throw new RuntimeException ("Create Failed: " +  

dir.getAbsolutePath () );
          }

Enter the following code to define the outcome file, which includes each of the job execution parameters:  

     try

     {

          //Write the results to an output file

          File f = new File (dir.getAbsolutePath() + File.seperatorChar +

          DirectoryNotifierConstants.OVERVIEW_FILE_NAME );

          f.createNewFIle();

          BufferedWriter writer = new BufferedWriter (new FileWriter (f) );

          String newLine = System.getProperty ("line.seperator");

          writer.write ("Outcome: " + jobMetaDAta.get

               (NotificationPropertyEnum.JOB_OUTCOME.getTag() ) + newLine);

               writer.write (newLine);

          writer.write ("Date & TimeL" + jobMetaData.get (

               NotificationPropertyEnum.DATE_TIME.getTag() ) + newLine);

          writer.write ("Elapsed Time: " +  jobMetaData.get (

               NotificationPropertyEnum.ELAPSED_TIME.getTag() ) + newLine);

               writer.write newLine );

          writer.write ("Name: " + jobMetaDAta.get (

               NotificationPropertyEnum.JOB_NAME.getTag() ) + newLine);

               writer.write (newLine);

          writer.write ("Host: " + jobMetaData.get (

If a directory cannot be created, the code below also includes a RuntimeException .
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               NotificationPropertyEnum.JOB_HOST.getTag() ) + newLine);

          writer.write ("Job Type: " + jobMetaData.get (

               NotificationPropertyEnum.JOB_TYPE.getTag() ) _  newLine);

          writer.write ("Module: " + jobMetaData.get (

               NotificationPropertyEnum.MODULE.getTag() ) +  newLine);

               writer.write (newLine);

          writer.write ("Sources: " + jobMetaData.get (

               NotificationPropertyEnum.JOB_SOURCES.getTag() ) + newLine);

          writer.write ("Targets: " + jobMetaData.get (

               NotificationPropertyEnum.JOB_TARGETS.getTag() ) + newLine);

               writer.write (newLine);

          writer.write ("Job Notes: " + jobMetaDAta.get (

               NotificationPropertyEnum.JOB_NOTES.getTag() ) + newLine );

               writer.flush();

               writer.close();

     }

     catch (Throwable t)

     {

          throw new RuntimeException (t);

     }
Enter the following code to generate the report. This code also provides a null report if the report type is set 
to none at execution time.
     //Create the report if required

     File reportFile = notificationInfo.getReport() ;

     if (reportFile !=null)

     {

          File destinationReportFile = new File dir.getAbsolutePath() + 

File.seperatorChar + 

          reportFile.getName()); eportFile.renameTo 

(destinationReportFile);

     }
Finally, output any DDL or synchronization SQL: 
     //Write the script File scriptFile=notificationInfo.getScript();

     

     if ( scriptFile !=null) File DestinationScriptFIle = new File 

(dir.getAbsolutePath() + 
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          File.separatorChar + scriptFile.getName () ); 

          scriptFile.renameTo (destinationScriptFile);

Implement the DirectoryNotifierContribution  class

Add the code below to the DirectoryNotifierViewerContribution  class to provide functionality for the 
interface:

The DirectoryNotifierViewerContribution  class requires three class-level private attributes. 
These attributes store notification data, which is the composite on which any options are placed, as well as 
the folderField , which is used to enter a file directory address.

     private INotifierData notificationData; 

     private Composite body; 

     private Text folderField;

The createFormContent  attribute creates a new composite and provides a layout template for options 
and entry fields. The code below adds a label and a text field to the interface:
     public Composite createFormContent (Composite parent, FormToolkit 

toolkit) body = toolkit.createComposite (parent);

     body.setLayout (new GridLayout ()); 

     

          toolkit.createLabel (parent, "Target Directory:"); 

          String folder = notificationData == null ? " " " : 

notificationData.getNotificationProperties().get 

(DirectoryNotifierConstants.TARGET_DIRECTORY); 

     

          folderField = toolkit.createText (parent, folder, SWT.SINGLE | 

SWT.BORDER); 

          folderField.setLayoutData (new GridData (SWT.FILL, SWT.CENTER, 

true, false)); 

          folderField.addModifyListener (new ModifyListener () {

               public void modifyText (ModifyEvent e) 

          {

               notificationData.setNotificationPropert 

(DirectoryNotifierConstants.TARGET_DIRECTORY, 

folderField.getText().trim() ); 

          }

     });
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     return body;
The code does the following:

Creates a new composite body, and sets it to have a grid layout.
Creates a label for the target directory field.
Retrieves the folder from the job, if the job is new or unsaved, or defaults to an empty string if the 
result is null.
Initializes the folderField text element and sets it to justify.

Adds a listener for changes on the folderField element that updates the 

notificationData , thus enabling save actions.
Returns the body to be added to the DB Change Manager job editor to which this class applies.

Add the setData  method using the following code, which is called to update the user interface with job 

information. This method accepts and stores the new instance of INotifierData  containing job-

specific data for the notifier. If the folderField has already had something entered, the notification 
properties are initialized and store the value that was previously entered.
     public void setData (INotifierData notificationData) 

          this.notificationData = notificationData; 

          if (folderField !=null && !folderField.isDisposed() && 

folderField.getText().trim().length() > 0))

               if (notificationData !=null) Map<String, String> propMap 

notificationData.getNotificationProperties(); 

               if (propMap == null) 

               {

                    notificationData.setNotificationProperties(new 

HashMap<String, String>()); 

                    propMap = notificationData.getNotificationProperties(); 

               } 

               notificationData.setNotificationProperty 

(DirectoryNotifierConstants.TARGET_DIRECTORY, folderField.getText());

               } 

          } 

     }

Register the extensions
Once you have coded the plugin and implemented the notifier and user interface, you include definitions that 
explain how DB Change Manager should interact with the plugin.
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You register the extensions that define the Notifier  and NotifierViewerContribution  to DB Change 
Manager. When the plugin is added to DB Change Manager, the extensions are registered and DB Change Manager 
understands the purpose of the plugin.

Open the MANIFEST.MF  file.
Navigate to the plugin.xml tab and display the source.
Add the following code:
     <extension point="com.idera.change.notifications.notifier"> 

          notifier 

               id="org.acme.directorynotifier" name="Directory Notifier" 

               notifier="org.acme.directorynotifier.DirectoryNotifier" 

              

 viewContribution="org.acme.directorynotifier.DirectoryNotifierViewerContri

bution"> 

          </notifier> 

     </extension>
Save the file by pressing Ctrl+S or by clicking File > Save.

When org.acme.directorynotifier  is found, the notification extension point is registered. The 

notifier  and viewContribution  attributes are the class names for two implementations and Eclipse 
reflectively registers these objects for use in DB Change Manager.

Deploy the Notifier  plugin
Once the plugin has been defined, you need to deploy the plugin in DB Change Manager.

Stop DB Change Manager if it is currently running.
Select File > Export.
The Export dialog appears.
Choose Deployable Plugins and Fragments from the Plugin Development group.
Click Next.
Select org.acme.directorynotifier  and ensure that the target directory is attributing to the DB 
Change Manager installation folder.
Click Finish.
Start DB Change Manager, and then create a new data comparison job.
Define a source and target data source, and then navigate to the Notifications tab.
The Directory Notifier appears as a section to the tab.
Choose Enable Directory Notifier to enable the feature.
Specify the Target Directory, such as C:\ChangeManagerNotifications, and then choose PDF in the 
Attached Report section.
Execute the job, and then open the target folder. A new folder is created containing two output files from the 
job.
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Creating and implementing a custom configuration plugin
Follow the instructions in these sections to code an Eclipse plugin for DB Change Manager that adds additional 
configuration parameters and values for configuration standards, archive jobs, and comparisons.

Create a project plugin
Configure the target platform
Define dependencies
Implement a property source
Determine support
Define properties
Gather results
Synchronize the job
Register extensions
Deploy the custom configuration plugin

Create a project plugin
In order to start building a plugin, you need to create a new plugin platform in Eclipse.

To create a plugin project

Select File > New > Other.
The Select a Wizard dialog appears.
Select Plugin Project, and then click Next.
Type a name for the plugin in the appropriate field, and leave the remainder of the parameters as they 
appear.
Click Next.
Leave the parameters on the next screen as they appear, and then click Finish.
The new plugin project is created in Eclipse and is ready for plugin development.

Configure the target platform
The target platform for the plugin development process needs to be identified in DB Change Manager. The target 
platform indicates to the new plugin for what product it extends, and grants the plugin access to the system.

Select Window > Preferences.
The Preferences dialog appears.
Choose the plugin Development > Target Platform node, and then click Browse.
Navigate to the install directory for DB Change Manager, and then click Apply.
Click OK.
The Preferences dialog closes and the target platform of the plugin is now indicated.

Define dependencies
The plugin requires a dependency for configuration comparison jobs in DB Change Manager. This dependency can 
be set by opening the MANIFEST.MF  file located in the META-INF  directory of your project.

Select the Dependencies tab, and then click Add.
Choose com.idera.change.config.propertysource , and then click OK.
The dependency is added to the plugin and appears in the Dependencies list.
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Press CTRL-S or click File>Save.
Once the dependency definition is saved, you can close the editor and the system retains your selection.

Implement a property source
Each configuration property source plugin must contain a class that extends 
com.idera.change.config.propertysource.api.ConfigurationPropertySource.

Right-click the project, and then select New>Class.
The New Java Class dialog appears.
Name the class JDBCVersionInformation , set the package to 

org.acme.versioninformation , and then set the superclass to 

com.idera.change.config.propertysource.api.ConfigurationPropertySource .
Click Finish.
The new class is generated.

Determine support
Each class that subclasses ConfigurationPropertySource  contributes properties to the configuration 
comparison job functionality.

The implementation uses the isSupported  method, which determines if there are attributes available for a 
specific data source.

For example, if a user added the Sybase @@Version tag as a configuration property, it would be pointless to run the 
code for Oracle, SQL Server, or DB2 for LUW data sources.

The method has the following signature:

boolean isSupported (IDatasourceIdentifier dataSourceIdentifier)

This method is called by DB Change Manager for any registered content plugin when a data source is used in a 
configuration archive job, a standard, or a comparison job. When it encounters a data source identifier, it returns 
true or false and indicates whether the property source provides parameters for the data source.

Implement the following code to define this method:

public boolean isSupported (IDatasourceIdentifier dataSourceIdentifier) 

{ 

     return dataSourceIdentifier.getDatabaseVersion().getDBMSType() !

=DBMSType.DB2; 

}

Define properties
The getAvailableProperties  function returns a set of instances of IConfigurationProperty
instances.

If ConfigurationPropertySource cannot be found in Eclipse, it means you have misconfigured the target 
platform or target dependencies.


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There are several utility methods to help instantiate these instances, named of the form, 
createConfigurationProperty .

Implement the following code to define the getAvailableProperties  method:

public Set(IConfigurationProperty> getAvailableProperties 

(IDatasourceIdentifier identifier)

{

     Set<IConfigurationProperty> results = new 

HashSet<IConfigurationProperty>();

     for (EVersionProperties prop : EVersionProperties.values())

     {

          results.add (createCOnfigurationProperty (prop.getDisplayName(), 

prop.name(),"", prop.getType(), "" ));

     }

return results;

}

Because the EVersionProperties  code cannot be resolved, you can add a Java enum to define the properties 
provided by the plugin.

Create a new file named EVersionProperties.java  and implement the following code:

package org.acme.versioninformation;

import java.sql.Connection;

import java.sql.SQLException;

import com.idera.change.config.propertysource.api.ConfigurationPropertyType;

/**

* An enumeration of version properties

*/

public enum EVersionProperties

{

     PRODUCT_NAME (ConfigurationPropertyType.STRING, "Product Name")

     {

          /**

          * @returns the JDBC metadata's information for product name

          * @throws SQLException if ther eis a JDBC error

          */

          public String getValue (Connection connection) throws SQLException

          {
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               return connection.getMetaData().getDatabaseProductName();

          }

     },

     PRODUCT_VERSION (ConfigurationPropertyType.STRING, "Product Version")

     {

          /**

          * @returns the JDBC metadata's information for product version

          * @throws SQLException if there is a JDBC error

          */

          public String getVAlue (Connection connection) throws SQLException

          {

               return connection.getMetaData().getDAtabaseProductVersion();

          }

     },

     MAJOR_VERSION (ConfigurationPropertyType.NUMERIC, "Major Version")

     {

          /**

          * @returns the JDBC metadata's information for major version

          * @throws SQLException if there is a JDBC error

          */

          public String getValue (Connection connection) throws SQLException

          {

               return "" + connection.getMetaData().getDataMajorVersion();

          }

     };

//Attributes private ConfigurationPropertyType type; private String name;

/**

* Constructor to set entry attributes

* @param type the type

* @param name

*/

private EVersionProperties (ConfigurationPropertyType type, String name)

}

{

/**

     this.type = type;
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     this.name = name;

* Given a JDBC connection return the parameter's value

* @param connection the database connection

* @throws SQLException if there is a JDBC error

*/

abstract String getValue (Connection connection) throws SQLException;

/**

* @return the display name of the parameter

*/

public String getDisplayName()

{

return name;

}

/**

* @return the type of the parameter

*/

public ConfigurationPropertyType getType()

{

return type;

}

/**

* Finds a property of a name and returns it

* @param name the name of the property

* @return the property

*/

public static EVersionProperties getProperty (String name)

{

     for (EVersionProperties p : values())

     {

          if (p.name().equals (name))

          {

               return p;

          }

     }

     throw new RuntimeException (EVersionProperties.class.getName() + "not 

found for '" + name + "'");
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     }

}

In the code above, the four entries that capture from JDBC the product name, version, minor version, and major 
version are added to the enum.

Gather results
DB Change Manager gathers results when it collects all of the properties and values for display purposes or to store 
in an archive. The extraction method is called when a data source is indicated in a standard, or when an archive or 
comparison job is run.

public Set<IConfigurationPropertyResult> 

extract(Set<IConfigurationProperty> properties, IDatasourceIdentifier 

dataSourceIdentifier)

A set of IConfigurationPropertyResult  instances that correspond to the properties must be returned, 
and values need to be added for the properties returned from the data source, as follows:

public Set<IConfigurationPropertyResult> extract 

(Set<IConfigurationProperty> properties, IDatasourceIdentifier 

dataSourceIdentifier)

{

     try

     {

          Set<IConfigurationPropertyResult> results = 

new HashSet<IConfigurationPropertyResult> ();

          Connection connection = getConnection (dataSourceIdentifier);

          for (IConfigurationProperty configProp : properties)

          {

               EVersionProperties prop = EVersionProperties.getProperty 

(configProp.getPropertyIdentifier());

               String value = prop.getValue (connection);

               results.add (createConfigurationPropertyResult (configProp, 

true, value)

               );

          }

     return results;

     }

catch (SQLException sql)

{

     throw new RuntimeException (sql);
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     }

}

In the above implementation, the code creates an empty set to hold the results and then retrieves the JDBC 
connection to the data source. For each retrieval, the enum constant EVersionProperties  on which 

getValue  is called to retrieve each property value from JDBC metadata. Finally, 

createConfigurationPropertyResult  is called to create the result instance.

Synchronize the job
The synchronization method returns an empty array because users cannot synchronize version information.

public List<IPropertyResultsSynchronization> sync (IDatasourceIdentifier 

dataSourceIdentifier, 

     List<IConfigurationPropertyResult> sourcePropertyValues, 

List<IConfigurationPropertyResult> 

     targetPropertyValues)

{

     return new ArrayList<IPropertyResultsSynchronization>();

}

Register extensions
Once you have completed coding the plugin, register it with DB Change Manager by implementing an Eclipse 
extension. When the plugin is added to DB Change Manager, the extensions are registered and DB Change Manager 
understands that the plugin adds a new type of notification to the module.

To register extensions

Open the Manifest.MF  file and navigate to the Extensions tab.
Click Add to register an extension.
The New Extension dialog appears.
Choose com.idera.change.config.propertysource.contribution .
Click Finish, and then close the dialog.
The extension is added to the All Extensions list.
Select the (source) entry on the right-hand side of the screen, and then enter the following details:

display-name: JDBC Metadata version information
source-identifier: org.acme.jdbc.versioninformation.source

class: org.acme.jdbcversioninformation.JDBCVersionInformation

Save the file by pressing CTRL-S or by choosing File>Save from the menu.
The class notification is complete, and DB Change Manager and Eclipse are informed about the property 

The class name is used to enable DB Change Manager to instantiate the new class, while the 
display-name is the group under which the four JDBC metadata version properties appear.


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source. When the plugin is added to DB Change Manager, it will add your properties to configuration 
comparison and standard jobs.

Deploy the custom configuration plugin
To deploy the custom plugin

Shut down DB Change Manager if it is running.
Click File>Export.
The Export dialog appears.
Select Deployable Plugins and Fragments from the Plugin Development group, and click then Next.
Select org.acme.jdbcversioninformation  and ensure the target directory is the same as the DB 
Change Manager installation folder.
Click Finish.
The new plugin is deployed.
Start DB Change Manager and create a new configuration archive job. When you select an Oracle, Sybase, or 
SQL Server data source, the Refinements and the Results tabs contain the four version properties you 
defined in the new plugin.
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