IronOcr Namespace
IronOcr is an industry leading .Net OCR library. It provides cutting edge OCR technology in over 80 languages for C# and .Net framework software projects.

http://ironsoftware.com/csharp/ocr/

Classes
 | Class | Description
Public class | AdvancedOcr | An advanced OCR engine which gives the developer access to advanced Image pro-processing and calibration settings. See also IronOcr.AutoOcr for a fully automated OCR Class with fewer settings.
Public class | AutoOcr | A user-friendly OCR engine which extracts text and barcodes from images. AutoOcr "looks" at each image before scanning it, and uses meta-data and computer-vision to predict intelligent default settings for each setting. See also IronOcr.AdvancedOcr for faster, more specific OCR results.
Public class | IronOcrInstallation | Sets global installation parameters for IronOCR.
Public class | License | Allows IronOcr license keys to be applied globally across an application. Apply your lice using LicenseKey in your code, or add the key IronOcr.LicenseKey to Web.Conbfig or App.Config
Public class | OcrResult | Detailed results from reading one or more images using IronOcr. OcrResult contains text, barcodes, images and a detailed object model for every discovered object on each page, with detailed meta-data.
Public class | OcrResultOcrBarcode | Object describing a Barcode or QR code discovered by IronOcr. 20+ formats are supported.
Public class | OcrResultOcrCharacter | An object representing each instance of each character (symbol) of readable text discovered with OCR.
Public class | OcrResultOcrLine | An object representing each line of text discovered in an OCRResult
Public class | OcrResultOcrPage | An object representing a whole page of content read by IronOcr. May contains text & barcodes alongside detailed enumerable meta-data
Public class | OcrResultOcrParagraph | An object representing each paragraph of text read by IronOcr
Public class | OcrResultOcrWord | An object representing each word read by IronOcr
Enumerations
 | Enumeration | Description
Public enumeration | AdvancedOcrInputTypes | Types of document to expect to read.
Public enumeration | AdvancedOcrOcrColorSpace | IronOcr can scan images in full color for greater accuracy, or in black, white and gray for speed.
Public enumeration | AdvancedOcrOcrStrategy | IronOcr image text analysis algorithms
Public enumeration | OcrResultOcrBarcodeBarcodeFormat | Describes types of barcode
Public enumeration | OcrResultTextFlow | The direction in which OCR text should be read. For Example English text is read "LeftToRight"

IronOcr C# OCR Library - (C) 2017 Iron Software


AdvancedOcr Class
An advanced OCR engine which gives the developer access to advanced Image pro-processing and calibration settings. See also IronOcr.AutoOcr for a fully automated OCR Class with fewer settings.
Inheritance Hierarchy
SystemObject
IronOcrAdvancedOcr

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public class AdvancedOcr
Public Class AdvancedOcr
type AdvancedOcr =  class end

The AdvancedOcr type exposes the following members.

Constructors
 | Name | Description
Public method | AdvancedOcr | Initializes a new instance of the AdvancedOcr class
Top
Methods
 | Name | Description
Public method | Read(IEnumerableBitmap) | Performs OCR on multiple Images in parallel using multi-threading;
Public method | Read(IEnumerableImage) | Performs OCR on multiple Images simultaneously using parallel multi threading;
Public method | Read(IEnumerableString) | Performs OCR on multiple Images using multi-threaded parallel processing
Public method | Read(Bitmap) | Performs OCR on an Image.
Public method | Read(Image) | Performs OCR on an Image.
Public method | Read(String) | Performs OCR on an Image.
Public method | Read(Bitmap, Rectangle) | Performs OCR on an Image. Only Text and Barcodes within the CropArea will be scanned
Public method | Read(Image, Rectangle) | Performs OCR on an Image. Only Text and Barcodes within the CropArea will be scanned
Public method | Read(String, Rectangle) | Performs OCR on an Image. Only Text and Barcodes within the CropArea will be scanned
Public method | ReadMultiFrameTiff(Bitmap) | Performs OCR on a multi-pages image such as a multi-frame Tiff. Also works on GIF files.
Public method | ReadMultiFrameTiff(String) | Performs OCR on a multi-pages image such as a multi-frame Tiff. Also works on GIF files.
Public method | ReadMultiThreaded(IEnumerableBitmap, Int32) | Performs OCR on multiple images simultaneously, using multiple threads and cores for the best performance.
Public method | ReadMultiThreaded(IEnumerableImage, Int32) | Performs OCR on multiple images simultaneously, using multiple threads and cores for the best performance.
Public method | ReadMultiThreaded(IEnumerableString, Int32) | Performs OCR on multiple images simultaneously, using multiple threads and cores for the best performance.
Public method | ReadMultiThreaded(IEnumerableBitmap, Rectangle, Int32) | Performs OCR on multiple images simultaneously, using multiple threads and cores for the best performance.
Public method | ReadMultiThreaded(IEnumerableImage, Rectangle, Int32) | Performs OCR on multiple images simultaneously, using multiple threads and cores for the best performance.
Public method | ReadMultiThreaded(IEnumerableString, Rectangle, Int32) | Performs OCR on multiple images simultaneously, using multiple threads and cores for the best performance.
Public method | ReadPdf(Byte, IEnumerableInt32) | Performs OCR on a PDF Document.
Public method | ReadPdf(Byte, Int32) | Performs OCR on one page an PDF Document.
Public method | ReadPdf(Stream, IEnumerableInt32) | Performs OCR on an page range within a PDF Document.
Public method | ReadPdf(Stream, Int32) | Performs OCR on a cropped area of one page of a PDF Document.
Public method | ReadPdf(String, IEnumerableInt32) | Performs OCR on a PDF Document.
Public method | ReadPdf(String, Int32) | Performs OCR on one page of a PDF Document.
Public method | ReadPdf(Byte, Rectangle, IEnumerableInt32) | Performs OCR on a cropped area of a PDF Document.
Public method | ReadPdf(Byte, Rectangle, Int32) | Performs OCR on a cropped area of one page of a PDF Document.
Public method | ReadPdf(Stream, Rectangle, IEnumerableInt32) | Performs OCR on specific area of a PDF Document.
Public method | ReadPdf(Stream, Rectangle, Int32) | Performs OCR on one page an PDF Document.
Public method | ReadPdf(String, Rectangle, IEnumerableInt32) | Performs OCR on a cropped area of a PDF Document.
Public method | ReadPdf(String, Rectangle, Int32) | Performs OCR on a cropped area of one page of a PDF Document.
Top
Fields
 | Name | Description
Public field | AcceptedOcrCharacters | Specifies the characters the OCR engine will look for, which can hugely improve speed and accuracy. The default behavior is to identify all UTF-8 characters including accented characters borrowed from international languages. E.g. "0123456789" or only numbers, or "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz.:;?!@$%&+-,-()\"'0123456789" for English characters without accents.
Public field | CleanBackgroundNoise | AdvancedOcr will clean background 'noise' , dust, speckles and signs of paper away from printed text. Works even scrupled, stained or damaged paper. RotateAndStraighten is a powerful tool, making imperfect scans OCR accurately. CPU/GPU intensive.
Public field | ColorDepth | Bits of color per channel per pixel. Lower ColorDepth can reduce scanning time for documents that also contain many colors or images. A value of ZERO will result in image color depths not being modified from the original source image.
Public field | ColorSpace | OCR documents can be scanned in GreyScale to reduce processing time. This may not work well for low-contrast text on a non-white backgrounds.
Public field | DetectWhiteTextOnDarkBackgrounds | Automatically detects and adjusts white text on darker backgrounds such as found in microfilm, negatives and some styles of graphic design.
Public field | EnhanceContrast | Enhances image contrast adaptively, which generally increases text readability both by humans ans machines.
Public field | EnhanceResolution | Re-renders low quality images at a higher DPI. IronOcr works faster and more accurately with high resolution images. Useful for images scanned at under 250 DPI
Public field | InputImageType | Hints the OCR Engine about the type of image being scanned, which can reduce OCR time and increase accuracy.
Public field | Language | Natural Language of the scanned documents. Default is English.
Public field | ReadBarCodes | Enables Barcodes to be extracted from OCR documents, alongside the text content.
Public field | RotateAndStraighten | AdvancedOcr will deskew and rotate images to be straight, upright, unbent and without perspective. RotateAndStraighten is a powerful tool, making imperfect scans OCR accurately. CPU/GPU intensive.
Public field | Strategy | Algorithm to be used for OCR text analysis.
Top
See Also

Reference

IronOcr Namespace


AdvancedOcr Constructor

Initializes a new instance of the AdvancedOcr class

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public AdvancedOcr()
Public Sub New
new : unit -> AdvancedOcr
See Also

Reference

AdvancedOcr Class


AdvancedOcr Methods
Methods
 | Name | Description
Public method | Read(IEnumerableBitmap) | Performs OCR on multiple Images in parallel using multi-threading;
Public method | Read(IEnumerableImage) | Performs OCR on multiple Images simultaneously using parallel multi threading;
Public method | Read(IEnumerableString) | Performs OCR on multiple Images using multi-threaded parallel processing
Public method | Read(Bitmap) | Performs OCR on an Image.
Public method | Read(Image) | Performs OCR on an Image.
Public method | Read(String) | Performs OCR on an Image.
Public method | Read(Bitmap, Rectangle) | Performs OCR on an Image. Only Text and Barcodes within the CropArea will be scanned
Public method | Read(Image, Rectangle) | Performs OCR on an Image. Only Text and Barcodes within the CropArea will be scanned
Public method | Read(String, Rectangle) | Performs OCR on an Image. Only Text and Barcodes within the CropArea will be scanned
Public method | ReadMultiFrameTiff(Bitmap) | Performs OCR on a multi-pages image such as a multi-frame Tiff. Also works on GIF files.
Public method | ReadMultiFrameTiff(String) | Performs OCR on a multi-pages image such as a multi-frame Tiff. Also works on GIF files.
Public method | ReadMultiThreaded(IEnumerableBitmap, Int32) | Performs OCR on multiple images simultaneously, using multiple threads and cores for the best performance.
Public method | ReadMultiThreaded(IEnumerableImage, Int32) | Performs OCR on multiple images simultaneously, using multiple threads and cores for the best performance.
Public method | ReadMultiThreaded(IEnumerableString, Int32) | Performs OCR on multiple images simultaneously, using multiple threads and cores for the best performance.
Public method | ReadMultiThreaded(IEnumerableBitmap, Rectangle, Int32) | Performs OCR on multiple images simultaneously, using multiple threads and cores for the best performance.
Public method | ReadMultiThreaded(IEnumerableImage, Rectangle, Int32) | Performs OCR on multiple images simultaneously, using multiple threads and cores for the best performance.
Public method | ReadMultiThreaded(IEnumerableString, Rectangle, Int32) | Performs OCR on multiple images simultaneously, using multiple threads and cores for the best performance.
Public method | ReadPdf(Byte, IEnumerableInt32) | Performs OCR on a PDF Document.
Public method | ReadPdf(Byte, Int32) | Performs OCR on one page an PDF Document.
Public method | ReadPdf(Stream, IEnumerableInt32) | Performs OCR on an page range within a PDF Document.
Public method | ReadPdf(Stream, Int32) | Performs OCR on a cropped area of one page of a PDF Document.
Public method | ReadPdf(String, IEnumerableInt32) | Performs OCR on a PDF Document.
Public method | ReadPdf(String, Int32) | Performs OCR on one page of a PDF Document.
Public method | ReadPdf(Byte, Rectangle, IEnumerableInt32) | Performs OCR on a cropped area of a PDF Document.
Public method | ReadPdf(Byte, Rectangle, Int32) | Performs OCR on a cropped area of one page of a PDF Document.
Public method | ReadPdf(Stream, Rectangle, IEnumerableInt32) | Performs OCR on specific area of a PDF Document.
Public method | ReadPdf(Stream, Rectangle, Int32) | Performs OCR on one page an PDF Document.
Public method | ReadPdf(String, Rectangle, IEnumerableInt32) | Performs OCR on a cropped area of a PDF Document.
Public method | ReadPdf(String, Rectangle, Int32) | Performs OCR on a cropped area of one page of a PDF Document.
Top
See Also

Reference

AdvancedOcr Class


AdvancedOcr.Read Method

IronOcr - C# OCR Library Documentation

AdvancedOcrRead Method

Overload List
 | Name | Description
Public method | Read(IEnumerableBitmap) | Performs OCR on multiple Images in parallel using multi-threading;
Public method | Read(IEnumerableImage) | Performs OCR on multiple Images simultaneously using parallel multi threading;
Public method | Read(IEnumerableString) | Performs OCR on multiple Images using multi-threaded parallel processing
Public method | Read(Bitmap) | Performs OCR on an Image.
Public method | Read(Image) | Performs OCR on an Image.
Public method | Read(String) | Performs OCR on an Image.
Public method | Read(Bitmap, Rectangle) | Performs OCR on an Image. Only Text and Barcodes within the CropArea will be scanned
Public method | Read(Image, Rectangle) | Performs OCR on an Image. Only Text and Barcodes within the CropArea will be scanned
Public method | Read(String, Rectangle) | Performs OCR on an Image. Only Text and Barcodes within the CropArea will be scanned
Top
See Also

Reference

AdvancedOcr Class


AdvancedOcr.Read Method (IEnumerable(Bitmap))

AdvancedOcrRead Method (IEnumerableBitmap)
Performs OCR on multiple Images in parallel using multi-threading;

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult Read(
    IEnumerable<Bitmap> Bitmaps
)
Public Function Read (
    Bitmaps As IEnumerable(Of Bitmap)
) As OcrResult
member Read :
        Bitmaps : IEnumerable<Bitmap> -> OcrResult

Parameters

Bitmaps
Type: System.Collections.GenericIEnumerable Bitmap
Documents to be scanned as an IEnumerable of System.Drawing.Bitmap

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence, etc.
See Also

Reference

AdvancedOcr Class
Read Overload


AdvancedOcr.Read Method (IEnumerable(Image))

AdvancedOcrRead Method (IEnumerableImage)
Performs OCR on multiple Images simultaneously using parallel multi threading;

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult Read(
    IEnumerable<Image> Images
)
Public Function Read (
    Images As IEnumerable(Of Image)
) As OcrResult
member Read :
        Images : IEnumerable<Image> -> OcrResult

Parameters

Images
Type: System.Collections.GenericIEnumerable Image
Document to be scanned as a System.Drawing.Image

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence etc.
See Also

Reference

AdvancedOcr Class
Read Overload


AdvancedOcr.Read Method (IEnumerable(String))

AdvancedOcrRead Method (IEnumerableString)
Performs OCR on multiple Images using multi-threaded parallel processing

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult Read(
    IEnumerable<string> ImageFilePaths
)
Public Function Read (
    ImageFilePaths As IEnumerable(Of String)
) As OcrResult
member Read :
        ImageFilePaths : IEnumerable<string> -> OcrResult

Parameters

ImageFilePaths
Type: System.Collections.GenericIEnumerable String
Documents to be scanned as an image file path.

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence etc.
See Also

Reference

AdvancedOcr Class
Read Overload


AdvancedOcr.Read Method (Bitmap)

AdvancedOcrRead Method (Bitmap)
Performs OCR on an Image.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult Read(
    Bitmap Bitmap
)
Public Function Read (
    Bitmap As Bitmap
) As OcrResult
member Read :
        Bitmap : Bitmap -> OcrResult

Parameters

Bitmap
Type: System.DrawingBitmap
Document to be scanned as a System.Drawing.Bitmap

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence, etc.
See Also

Reference

AdvancedOcr Class
Read Overload


AdvancedOcr.Read Method (Image)

AdvancedOcrRead Method (Image)
Performs OCR on an Image.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult Read(
    Image Image
)
Public Function Read (
    Image As Image
) As OcrResult
member Read :
        Image : Image -> OcrResult

Parameters

Image
Type: System.DrawingImage
Document to be scanned as a System.Drawing.Image

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence etc.
See Also

Reference

AdvancedOcr Class
Read Overload


AdvancedOcr.Read Method (String)

AdvancedOcrRead Method (String)
Performs OCR on an Image.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult Read(
    string ImageFilePath
)
Public Function Read (
    ImageFilePath As String
) As OcrResult
member Read :
        ImageFilePath : string -> OcrResult

Parameters

ImageFilePath
Type: SystemString
Document to be scanned as an image file path.

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence etc.
See Also

Reference

AdvancedOcr Class
Read Overload


AdvancedOcr.Read Method (Bitmap, Rectangle)

AdvancedOcrRead Method (Bitmap, Rectangle)
Performs OCR on an Image.

Only Text and Barcodes within the CropArea will be scanned

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult Read(
    Bitmap Bitmap,
    Rectangle CropArea
)
Public Function Read (
    Bitmap As Bitmap,
    CropArea As Rectangle
) As OcrResult
member Read :
        Bitmap : Bitmap *
        CropArea : Rectangle -> OcrResult

Parameters

Bitmap
Type: System.DrawingBitmap
Document to be scanned as a System.Drawing.Bitmap
CropArea
Type: System.DrawingRectangle
A rectangular area of the image to be scanned for OCR.

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence etc.
See Also

Reference

AdvancedOcr Class
Read Overload


AdvancedOcr.Read Method (Image, Rectangle)

AdvancedOcrRead Method (Image, Rectangle)
Performs OCR on an Image.

Only Text and Barcodes within the CropArea will be scanned

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult Read(
    Image Image,
    Rectangle CropArea
)
Public Function Read (
    Image As Image,
    CropArea As Rectangle
) As OcrResult
member Read :
        Image : Image *
        CropArea : Rectangle -> OcrResult

Parameters

Image
Type: System.DrawingImage
Document to be scanned as a System.Drawing.Image
CropArea
Type: System.DrawingRectangle
A rectangular area of the image to be scanned for OCR.

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence etc.
See Also

Reference

AdvancedOcr Class
Read Overload


AdvancedOcr.Read Method (String, Rectangle)

AdvancedOcrRead Method (String, Rectangle)
Performs OCR on an Image.

Only Text and Barcodes within the CropArea will be scanned

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult Read(
    string ImageFilePath,
    Rectangle CropArea
)
Public Function Read (
    ImageFilePath As String,
    CropArea As Rectangle
) As OcrResult
member Read :
        ImageFilePath : string *
        CropArea : Rectangle -> OcrResult

Parameters

ImageFilePath
Type: SystemString
Document to be scanned as an image file path.
CropArea
Type: System.DrawingRectangle
A rectangular area of the image to be scanned for OCR.

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence etc.
See Also

Reference

AdvancedOcr Class
Read Overload


AdvancedOcr.ReadMultiFrameTiff Method

AdvancedOcrReadMultiFrameTiff Method

Overload List
 | Name | Description
Public method | ReadMultiFrameTiff(Bitmap) | Performs OCR on a multi-pages image such as a multi-frame Tiff. Also works on GIF files.
Public method | ReadMultiFrameTiff(String) | Performs OCR on a multi-pages image such as a multi-frame Tiff. Also works on GIF files.
Top
See Also

Reference

AdvancedOcr Class


AdvancedOcr.ReadMultiFrameTiff Method (Bitmap)

AdvancedOcrReadMultiFrameTiff Method (Bitmap)
Performs OCR on a multi-pages image such as a multi-frame Tiff. Also works on GIF files.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadMultiFrameTiff(
    Bitmap Tiff
)
Public Function ReadMultiFrameTiff (
    Tiff As Bitmap
) As OcrResult
member ReadMultiFrameTiff :
        Tiff : Bitmap -> OcrResult

Parameters

Tiff
Type: System.DrawingBitmap
Systemn.Drawing.Bitmap of a Tiff file with multiple pages/frames

Return Value

Type: OcrResult
Returns paginated OCR results for all pages of the Tiff, containing Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence etc.
See Also

Reference

AdvancedOcr Class
ReadMultiFrameTiff Overload


AdvancedOcr.ReadMultiFrameTiff Method (String)

AdvancedOcrReadMultiFrameTiff Method (String)
Performs OCR on a multi-pages image such as a multi-frame Tiff. Also works on GIF files.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadMultiFrameTiff(
    string TiffPath
)
Public Function ReadMultiFrameTiff (
    TiffPath As String
) As OcrResult
member ReadMultiFrameTiff :
        TiffPath : string -> OcrResult

Parameters

TiffPath
Type: SystemString
File path to a Tiff file with multiple pages/frames

Return Value

Type: OcrResult
Returns paginated OCR results for all pages of the Tiff, containing Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence etc.
See Also

Reference

AdvancedOcr Class
ReadMultiFrameTiff Overload


AdvancedOcr.ReadMultiThreaded Method

AdvancedOcrReadMultiThreaded Method

Overload List
 | Name | Description
Public method | ReadMultiThreaded(IEnumerableBitmap, Int32) | Performs OCR on multiple images simultaneously, using multiple threads and cores for the best performance.
Public method | ReadMultiThreaded(IEnumerableImage, Int32) | Performs OCR on multiple images simultaneously, using multiple threads and cores for the best performance.
Public method | ReadMultiThreaded(IEnumerableString, Int32) | Performs OCR on multiple images simultaneously, using multiple threads and cores for the best performance.
Public method | ReadMultiThreaded(IEnumerableBitmap, Rectangle, Int32) | Performs OCR on multiple images simultaneously, using multiple threads and cores for the best performance.
Public method | ReadMultiThreaded(IEnumerableImage, Rectangle, Int32) | Performs OCR on multiple images simultaneously, using multiple threads and cores for the best performance.
Public method | ReadMultiThreaded(IEnumerableString, Rectangle, Int32) | Performs OCR on multiple images simultaneously, using multiple threads and cores for the best performance.
Top
See Also

Reference

AdvancedOcr Class


AdvancedOcr.ReadMultiThreaded Method (IEnumerable(Bitmap), Int32)

AdvancedOcrReadMultiThreaded Method (IEnumerableBitmap, Int32)
Performs OCR on multiple images simultaneously, using multiple threads and cores for the best performance.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadMultiThreaded(
    IEnumerable<Bitmap> Bitmaps,
    int MaximumNumberOfThreads = 4
)
Public Function ReadMultiThreaded (
    Bitmaps As IEnumerable(Of Bitmap),
    Optional MaximumNumberOfThreads As Integer = 4
) As OcrResult
member ReadMultiThreaded :
        Bitmaps : IEnumerable<Bitmap> *
        ?MaximumNumberOfThreads : int
(* Defaults:
        let _MaximumNumberOfThreads = defaultArg MaximumNumberOfThreads 4
*)
-> OcrResult

Parameters

Bitmaps
Type: System.Collections.GenericIEnumerable Bitmap
Multiple document pages to be scanned
MaximumNumberOfThreads (Optional)
Type: SystemInt32
The maximum number of document pages to be read simultaneously.

Return Value

Type: OcrResult
See Also

Reference

AdvancedOcr Class
ReadMultiThreaded Overload


AdvancedOcr.ReadMultiThreaded Method (IEnumerable(Image), Int32)

AdvancedOcrReadMultiThreaded Method (IEnumerableImage, Int32)
Performs OCR on multiple images simultaneously, using multiple threads and cores for the best performance.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadMultiThreaded(
    IEnumerable<Image> Images,
    int MaximumNumberOfThreads = 4
)
Public Function ReadMultiThreaded (
    Images As IEnumerable(Of Image),
    Optional MaximumNumberOfThreads As Integer = 4
) As OcrResult
member ReadMultiThreaded :
        Images : IEnumerable<Image> *
        ?MaximumNumberOfThreads : int
(* Defaults:
        let _MaximumNumberOfThreads = defaultArg MaximumNumberOfThreads 4
*)
-> OcrResult

Parameters

Images
Type: System.Collections.GenericIEnumerable Image
Multiple document pages to be scanned
MaximumNumberOfThreads (Optional)
Type: SystemInt32
The maximum number of document pages to be read simultaneously.

Return Value

Type: OcrResult
See Also

Reference

AdvancedOcr Class
ReadMultiThreaded Overload


AdvancedOcr.ReadMultiThreaded Method (IEnumerable(String), Int32)

AdvancedOcrReadMultiThreaded Method (IEnumerableString, Int32)
Performs OCR on multiple images simultaneously, using multiple threads and cores for the best performance.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadMultiThreaded(
    IEnumerable<string> ImageFilePaths,
    int MaximumNumberOfThreads = 4
)
Public Function ReadMultiThreaded (
    ImageFilePaths As IEnumerable(Of String),
    Optional MaximumNumberOfThreads As Integer = 4
) As OcrResult
member ReadMultiThreaded :
        ImageFilePaths : IEnumerable<string> *
        ?MaximumNumberOfThreads : int
(* Defaults:
        let _MaximumNumberOfThreads = defaultArg MaximumNumberOfThreads 4
*)
-> OcrResult

Parameters

ImageFilePaths
Type: System.Collections.GenericIEnumerable String
File paths to multiple images
MaximumNumberOfThreads (Optional)
Type: SystemInt32
The maximum number of document pages to be read simultaneously.

Return Value

Type: OcrResult
Returns paginated results for all pages, containing Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence etc.
See Also

Reference

AdvancedOcr Class
ReadMultiThreaded Overload


AdvancedOcr.ReadMultiThreaded Method (IEnumerable(Bitmap), Rectangle, Int32)

AdvancedOcrReadMultiThreaded Method (IEnumerableBitmap, Rectangle, Int32)
Performs OCR on multiple images simultaneously, using multiple threads and cores for the best performance.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadMultiThreaded(
    IEnumerable<Bitmap> Bitmaps,
    Rectangle CropArea,
    int MaximumNumberOfThreads = 4
)
Public Function ReadMultiThreaded (
    Bitmaps As IEnumerable(Of Bitmap),
    CropArea As Rectangle,
    Optional MaximumNumberOfThreads As Integer = 4
) As OcrResult
member ReadMultiThreaded :
        Bitmaps : IEnumerable<Bitmap> *
        CropArea : Rectangle *
        ?MaximumNumberOfThreads : int
(* Defaults:
        let _MaximumNumberOfThreads = defaultArg MaximumNumberOfThreads 4
*)
-> OcrResult

Parameters

Bitmaps
Type: System.Collections.GenericIEnumerable Bitmap
Multiple document pages to be scanned
CropArea
Type: System.DrawingRectangle
A rectangular area of the images to be scanned for OCR.
MaximumNumberOfThreads (Optional)
Type: SystemInt32
The maximum number of document pages to be read simultaneously.

Return Value

Type: OcrResult
See Also

Reference

AdvancedOcr Class
ReadMultiThreaded Overload


AdvancedOcr.ReadMultiThreaded Method (IEnumerable(Image), Rectangle, Int32)

AdvancedOcrReadMultiThreaded Method (IEnumerableImage, Rectangle, Int32)
Performs OCR on multiple images simultaneously, using multiple threads and cores for the best performance.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadMultiThreaded(
    IEnumerable<Image> Images,
    Rectangle CropArea,
    int MaximumNumberOfThreads = 4
)
Public Function ReadMultiThreaded (
    Images As IEnumerable(Of Image),
    CropArea As Rectangle,
    Optional MaximumNumberOfThreads As Integer = 4
) As OcrResult
member ReadMultiThreaded :
        Images : IEnumerable<Image> *
        CropArea : Rectangle *
        ?MaximumNumberOfThreads : int
(* Defaults:
        let _MaximumNumberOfThreads = defaultArg MaximumNumberOfThreads 4
*)
-> OcrResult

Parameters

Images
Type: System.Collections.GenericIEnumerable Image
Multiple document pages to be scanned
CropArea
Type: System.DrawingRectangle
A rectangular area of the images to be scanned for OCR.
MaximumNumberOfThreads (Optional)
Type: SystemInt32
The maximum number of document pages to be read simultaneously.

Return Value

Type: OcrResult
See Also

Reference

AdvancedOcr Class
ReadMultiThreaded Overload


AdvancedOcr.ReadMultiThreaded Method (IEnumerable(String), Rectangle, Int32)

AdvancedOcrReadMultiThreaded Method (IEnumerableString, Rectangle, Int32)
Performs OCR on multiple images simultaneously, using multiple threads and cores for the best performance.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadMultiThreaded(
    IEnumerable<string> ImageFilePaths,
    Rectangle CropArea,
    int MaximumNumberOfThreads = 4
)
Public Function ReadMultiThreaded (
    ImageFilePaths As IEnumerable(Of String),
    CropArea As Rectangle,
    Optional MaximumNumberOfThreads As Integer = 4
) As OcrResult
member ReadMultiThreaded :
        ImageFilePaths : IEnumerable<string> *
        CropArea : Rectangle *
        ?MaximumNumberOfThreads : int
(* Defaults:
        let _MaximumNumberOfThreads = defaultArg MaximumNumberOfThreads 4
*)
-> OcrResult

Parameters

ImageFilePaths
Type: System.Collections.GenericIEnumerable String
File paths to multiple images
CropArea
Type: System.DrawingRectangle
A rectangular area of the images to be scanned for OCR.
MaximumNumberOfThreads (Optional)
Type: SystemInt32
The maximum number of document pages to be read simultaneously.

Return Value

Type: OcrResult
Returns paginated results for all pages, containing Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence etc.
See Also

Reference

AdvancedOcr Class
ReadMultiThreaded Overload


AdvancedOcr.ReadPdf Method

AdvancedOcrReadPdf Method

Overload List
 | Name | Description
Public method | ReadPdf(Byte, IEnumerableInt32) | Performs OCR on a PDF Document.
Public method | ReadPdf(Byte, Int32) | Performs OCR on one page an PDF Document.
Public method | ReadPdf(Stream, IEnumerableInt32) | Performs OCR on an page range within a PDF Document.
Public method | ReadPdf(Stream, Int32) | Performs OCR on a cropped area of one page of a PDF Document.
Public method | ReadPdf(String, IEnumerableInt32) | Performs OCR on a PDF Document.
Public method | ReadPdf(String, Int32) | Performs OCR on one page of a PDF Document.
Public method | ReadPdf(Byte, Rectangle, IEnumerableInt32) | Performs OCR on a cropped area of a PDF Document.
Public method | ReadPdf(Byte, Rectangle, Int32) | Performs OCR on a cropped area of one page of a PDF Document.
Public method | ReadPdf(Stream, Rectangle, IEnumerableInt32) | Performs OCR on specific area of a PDF Document.
Public method | ReadPdf(Stream, Rectangle, Int32) | Performs OCR on one page an PDF Document.
Public method | ReadPdf(String, Rectangle, IEnumerableInt32) | Performs OCR on a cropped area of a PDF Document.
Public method | ReadPdf(String, Rectangle, Int32) | Performs OCR on a cropped area of one page of a PDF Document.
Top
See Also

Reference

AdvancedOcr Class


AdvancedOcr.ReadPdf Method (Byte[], IEnumerable(Int32))

AdvancedOcrReadPdf Method (Byte, IEnumerableInt32)
Performs OCR on a PDF Document.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadPdf(
    byte[] PdfBinaryData,
    IEnumerable<int> PageRange = null
)
Public Function ReadPdf (
    PdfBinaryData As Byte(),
    Optional PageRange As IEnumerable(Of Integer) = Nothing
) As OcrResult
member ReadPdf :
        PdfBinaryData : byte[] *
        ?PageRange : IEnumerable<int>
(* Defaults:
        let _PageRange = defaultArg PageRange null
*)
-> OcrResult

Parameters

PdfBinaryData
Type: SystemByte
The binary data for a PDF Document to be converted back to text.
PageRange (Optional)
Type: System.Collections.GenericIEnumerable Int32

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence, etc.
See Also

Reference

AdvancedOcr Class
ReadPdf Overload


AdvancedOcr.ReadPdf Method (Byte[], Int32)

AdvancedOcrReadPdf Method (Byte, Int32)
Performs OCR on one page an PDF Document.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadPdf(
    byte[] PdfBinaryData,
    int PageNumber
)
Public Function ReadPdf (
    PdfBinaryData As Byte(),
    PageNumber As Integer
) As OcrResult
member ReadPdf :
        PdfBinaryData : byte[] *
        PageNumber : int -> OcrResult

Parameters

PdfBinaryData
Type: SystemByte
The binary data for a PDF Document to be converted back to text.
PageNumber
Type: SystemInt32

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence, etc.
See Also

Reference

AdvancedOcr Class
ReadPdf Overload


AdvancedOcr.ReadPdf Method (Stream, IEnumerable(Int32))

AdvancedOcrReadPdf Method (Stream, IEnumerableInt32)
Performs OCR on an page range within a PDF Document.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadPdf(
    Stream PdfStreamData,
    IEnumerable<int> PageRange = null
)
Public Function ReadPdf (
    PdfStreamData As Stream,
    Optional PageRange As IEnumerable(Of Integer) = Nothing
) As OcrResult
member ReadPdf :
        PdfStreamData : Stream *
        ?PageRange : IEnumerable<int>
(* Defaults:
        let _PageRange = defaultArg PageRange null
*)
-> OcrResult

Parameters

PdfStreamData
Type: System.IOStream
The stream data for a PDF Document to be converted back to text.
PageRange (Optional)
Type: System.Collections.GenericIEnumerable Int32

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence, etc.
See Also

Reference

AdvancedOcr Class
ReadPdf Overload


AdvancedOcr.ReadPdf Method (Stream, Int32)

AdvancedOcrReadPdf Method (Stream, Int32)
Performs OCR on a cropped area of one page of a PDF Document.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadPdf(
    Stream PdfStreamData,
    int PageNumber
)
Public Function ReadPdf (
    PdfStreamData As Stream,
    PageNumber As Integer
) As OcrResult
member ReadPdf :
        PdfStreamData : Stream *
        PageNumber : int -> OcrResult

Parameters

PdfStreamData
Type: System.IOStream
The stream data for a PDF Document to be converted back to text.
PageNumber
Type: SystemInt32

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence, etc.
See Also

Reference

AdvancedOcr Class
ReadPdf Overload


AdvancedOcr.ReadPdf Method (String, IEnumerable(Int32))

AdvancedOcrReadPdf Method (String, IEnumerableInt32)
Performs OCR on a PDF Document.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadPdf(
    string PdfFilePath,
    IEnumerable<int> PageRange = null
)
Public Function ReadPdf (
    PdfFilePath As String,
    Optional PageRange As IEnumerable(Of Integer) = Nothing
) As OcrResult
member ReadPdf :
        PdfFilePath : string *
        ?PageRange : IEnumerable<int>
(* Defaults:
        let _PageRange = defaultArg PageRange null
*)
-> OcrResult

Parameters

PdfFilePath
Type: SystemString
PDF Document to be converted back to text.
PageRange (Optional)
Type: System.Collections.GenericIEnumerable Int32

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence, etc.
See Also

Reference

AdvancedOcr Class
ReadPdf Overload


AdvancedOcr.ReadPdf Method (String, Int32)

AdvancedOcrReadPdf Method (String, Int32)
Performs OCR on one page of a PDF Document.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadPdf(
    string PdfFilePath,
    int PageNumber
)
Public Function ReadPdf (
    PdfFilePath As String,
    PageNumber As Integer
) As OcrResult
member ReadPdf :
        PdfFilePath : string *
        PageNumber : int -> OcrResult

Parameters

PdfFilePath
Type: SystemString
PDF Document to be converted back to text.
PageNumber
Type: SystemInt32

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence, etc.
See Also

Reference

AdvancedOcr Class
ReadPdf Overload


AdvancedOcr.ReadPdf Method (Byte[], Rectangle, IEnumerable(Int32))

AdvancedOcrReadPdf Method (Byte, Rectangle, IEnumerableInt32)
Performs OCR on a cropped area of a PDF Document.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadPdf(
    byte[] PdfBinaryData,
    Rectangle CropArea,
    IEnumerable<int> PageRange = null
)
Public Function ReadPdf (
    PdfBinaryData As Byte(),
    CropArea As Rectangle,
    Optional PageRange As IEnumerable(Of Integer) = Nothing
) As OcrResult
member ReadPdf :
        PdfBinaryData : byte[] *
        CropArea : Rectangle *
        ?PageRange : IEnumerable<int>
(* Defaults:
        let _PageRange = defaultArg PageRange null
*)
-> OcrResult

Parameters

PdfBinaryData
Type: SystemByte
The binary data for a PDF Document to be converted back to text.
CropArea
Type: System.DrawingRectangle
The crop area as a System.Drawing.Rectangle.
PageRange (Optional)
Type: System.Collections.GenericIEnumerable Int32

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence, etc.
See Also

Reference

AdvancedOcr Class
ReadPdf Overload


AdvancedOcr.ReadPdf Method (Byte[], Rectangle, Int32)

AdvancedOcrReadPdf Method (Byte, Rectangle, Int32)
Performs OCR on a cropped area of one page of a PDF Document.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadPdf(
    byte[] PdfBinaryData,
    Rectangle CropArea,
    int PageNumber
)
Public Function ReadPdf (
    PdfBinaryData As Byte(),
    CropArea As Rectangle,
    PageNumber As Integer
) As OcrResult
member ReadPdf :
        PdfBinaryData : byte[] *
        CropArea : Rectangle *
        PageNumber : int -> OcrResult

Parameters

PdfBinaryData
Type: SystemByte
The binary data for a PDF Document to be converted back to text.
CropArea
Type: System.DrawingRectangle
The crop area as a System.Drawing.Rectangle.
PageNumber
Type: SystemInt32

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence, etc.
See Also

Reference

AdvancedOcr Class
ReadPdf Overload


AdvancedOcr.ReadPdf Method (Stream, Rectangle, IEnumerable(Int32))

AdvancedOcrReadPdf Method (Stream, Rectangle, IEnumerableInt32)
Performs OCR on specific area of a PDF Document.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadPdf(
    Stream PdfStreamData,
    Rectangle CropArea,
    IEnumerable<int> PageRange = null
)
Public Function ReadPdf (
    PdfStreamData As Stream,
    CropArea As Rectangle,
    Optional PageRange As IEnumerable(Of Integer) = Nothing
) As OcrResult
member ReadPdf :
        PdfStreamData : Stream *
        CropArea : Rectangle *
        ?PageRange : IEnumerable<int>
(* Defaults:
        let _PageRange = defaultArg PageRange null
*)
-> OcrResult

Parameters

PdfStreamData
Type: System.IOStream
The stream data for a PDF Document to be converted back to text.
CropArea
Type: System.DrawingRectangle
The crop area as a System.Drawing.Rectangle.
PageRange (Optional)
Type: System.Collections.GenericIEnumerable Int32
The page range.

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence, etc.
Exceptions
Exception | Condition
FileLoadException | IronOcr.ReadPdf - could not convert stream to binary data
See Also

Reference

AdvancedOcr Class
ReadPdf Overload


AdvancedOcr.ReadPdf Method (Stream, Rectangle, Int32)

AdvancedOcrReadPdf Method (Stream, Rectangle, Int32)
Performs OCR on one page an PDF Document.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadPdf(
    Stream PdfStreamData,
    Rectangle CropArea,
    int PageNumber
)
Public Function ReadPdf (
    PdfStreamData As Stream,
    CropArea As Rectangle,
    PageNumber As Integer
) As OcrResult
member ReadPdf :
        PdfStreamData : Stream *
        CropArea : Rectangle *
        PageNumber : int -> OcrResult

Parameters

PdfStreamData
Type: System.IOStream
The stream data for a PDF Document to be converted back to text.
CropArea
Type: System.DrawingRectangle
The crop area as a System.Drawing.Rectangle.
PageNumber
Type: SystemInt32

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence, etc.
See Also

Reference

AdvancedOcr Class
ReadPdf Overload


AdvancedOcr.ReadPdf Method (String, Rectangle, IEnumerable(Int32))

AdvancedOcrReadPdf Method (String, Rectangle, IEnumerableInt32)
Performs OCR on a cropped area of a PDF Document.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadPdf(
    string PdfFilePath,
    Rectangle CropArea,
    IEnumerable<int> PageRange = null
)
Public Function ReadPdf (
    PdfFilePath As String,
    CropArea As Rectangle,
    Optional PageRange As IEnumerable(Of Integer) = Nothing
) As OcrResult
member ReadPdf :
        PdfFilePath : string *
        CropArea : Rectangle *
        ?PageRange : IEnumerable<int>
(* Defaults:
        let _PageRange = defaultArg PageRange null
*)
-> OcrResult

Parameters

PdfFilePath
Type: SystemString
PDF Document to be converted back to text.
CropArea
Type: System.DrawingRectangle
The crop area as a System.Drawing.Rectangle.
PageRange (Optional)
Type: System.Collections.GenericIEnumerable Int32
The page range.

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence, etc.
See Also

Reference

AdvancedOcr Class
ReadPdf Overload


AdvancedOcr.ReadPdf Method (String, Rectangle, Int32)

AdvancedOcrReadPdf Method (String, Rectangle, Int32)
Performs OCR on a cropped area of one page of a PDF Document.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadPdf(
    string PdfFilePath,
    Rectangle CropArea,
    int PageNumber
)
Public Function ReadPdf (
    PdfFilePath As String,
    CropArea As Rectangle,
    PageNumber As Integer
) As OcrResult
member ReadPdf :
        PdfFilePath : string *
        CropArea : Rectangle *
        PageNumber : int -> OcrResult

Parameters

PdfFilePath
Type: SystemString
PDF Document to be converted back to text.
CropArea
Type: System.DrawingRectangle
The crop area as a System.Drawing.Rectangle.
PageNumber
Type: SystemInt32

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence, etc.
See Also

Reference

AdvancedOcr Class
ReadPdf Overload


AdvancedOcr Fields

The AdvancedOcr type exposes the following members.

Fields
 | Name | Description
Public field | AcceptedOcrCharacters | Specifies the characters the OCR engine will look for, which can hugely improve speed and accuracy. The default behavior is to identify all UTF-8 characters including accented characters borrowed from international languages. E.g. "0123456789" or only numbers, or "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz.:;?!@$%&+-,-()\"'0123456789" for English characters without accents.
Public field | CleanBackgroundNoise | AdvancedOcr will clean background 'noise' , dust, speckles and signs of paper away from printed text. Works even scrupled, stained or damaged paper. RotateAndStraighten is a powerful tool, making imperfect scans OCR accurately. CPU/GPU intensive.
Public field | ColorDepth | Bits of color per channel per pixel. Lower ColorDepth can reduce scanning time for documents that also contain many colors or images. A value of ZERO will result in image color depths not being modified from the original source image.
Public field | ColorSpace | OCR documents can be scanned in GreyScale to reduce processing time. This may not work well for low-contrast text on a non-white backgrounds.
Public field | DetectWhiteTextOnDarkBackgrounds | Automatically detects and adjusts white text on darker backgrounds such as found in microfilm, negatives and some styles of graphic design.
Public field | EnhanceContrast | Enhances image contrast adaptively, which generally increases text readability both by humans ans machines.
Public field | EnhanceResolution | Re-renders low quality images at a higher DPI. IronOcr works faster and more accurately with high resolution images. Useful for images scanned at under 250 DPI
Public field | InputImageType | Hints the OCR Engine about the type of image being scanned, which can reduce OCR time and increase accuracy.
Public field | Language | Natural Language of the scanned documents. Default is English.
Public field | ReadBarCodes | Enables Barcodes to be extracted from OCR documents, alongside the text content.
Public field | RotateAndStraighten | AdvancedOcr will deskew and rotate images to be straight, upright, unbent and without perspective. RotateAndStraighten is a powerful tool, making imperfect scans OCR accurately. CPU/GPU intensive.
Public field | Strategy | Algorithm to be used for OCR text analysis.
Top
See Also

Reference

AdvancedOcr Class


AdvancedOcr.AcceptedOcrCharacters Field

AdvancedOcrAcceptedOcrCharacters Field
Specifies the characters the OCR engine will look for, which can hugely improve speed and accuracy. The default behavior is to identify all UTF-8 characters including accented characters borrowed from international languages.

E.g. "0123456789" or only numbers, or "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz.:;?!@$%&+-,-()\"'0123456789" for English characters without accents.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public string AcceptedOcrCharacters
Public AcceptedOcrCharacters As String
val mutable AcceptedOcrCharacters: string

Field Value

Type: String
See Also

Reference

AdvancedOcr Class


AdvancedOcr.CleanBackgroundNoise Field

AdvancedOcrCleanBackgroundNoise Field
AdvancedOcr will clean background 'noise' , dust, speckles and signs of paper away from printed text. Works even scrupled, stained or damaged paper.

RotateAndStraighten is a powerful tool, making imperfect scans OCR accurately. CPU/GPU intensive.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public bool CleanBackgroundNoise
Public CleanBackgroundNoise As Boolean
val mutable CleanBackgroundNoise: bool

Field Value

Type: Boolean
See Also

Reference

AdvancedOcr Class


AdvancedOcr.ColorDepth Field

AdvancedOcrColorDepth Field
Bits of color per channel per pixel. Lower ColorDepth can reduce scanning time for documents that also contain many colors or images. A value of ZERO will result in image color depths not being modified from the original source image.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int ColorDepth
Public ColorDepth As Integer
val mutable ColorDepth: int

Field Value

Type: Int32
See Also

Reference

AdvancedOcr Class


AdvancedOcr.ColorSpace Field

AdvancedOcrColorSpace Field
OCR documents can be scanned in GreyScale to reduce processing time. This may not work well for low-contrast text on a non-white backgrounds.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public AdvancedOcrOcrColorSpace ColorSpace
Public ColorSpace As AdvancedOcrOcrColorSpace
val mutable ColorSpace: AdvancedOcrOcrColorSpace

Field Value

Type: AdvancedOcrOcrColorSpace
See Also

Reference

AdvancedOcr Class


AdvancedOcr.DetectWhiteTextOnDarkBackgrounds Field

AdvancedOcrDetectWhiteTextOnDarkBackgrounds Field
Automatically detects and adjusts white text on darker backgrounds such as found in microfilm, negatives and some styles of graphic design.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public bool DetectWhiteTextOnDarkBackgrounds
Public DetectWhiteTextOnDarkBackgrounds As Boolean
val mutable DetectWhiteTextOnDarkBackgrounds: bool

Field Value

Type: Boolean
See Also

Reference

AdvancedOcr Class


AdvancedOcr.EnhanceContrast Field

AdvancedOcrEnhanceContrast Field
Enhances image contrast adaptively, which generally increases text readability both by humans ans machines.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public bool EnhanceContrast
Public EnhanceContrast As Boolean
val mutable EnhanceContrast: bool

Field Value

Type: Boolean
See Also

Reference

AdvancedOcr Class


AdvancedOcr.EnhanceResolution Field

AdvancedOcrEnhanceResolution Field
Re-renders low quality images at a higher DPI.

IronOcr works faster and more accurately with high resolution images. Useful for images scanned at under 250 DPI

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public bool EnhanceResolution
Public EnhanceResolution As Boolean
val mutable EnhanceResolution: bool

Field Value

Type: Boolean
See Also

Reference

AdvancedOcr Class


AdvancedOcr.InputImageType Field

AdvancedOcrInputImageType Field
Hints the OCR Engine about the type of image being scanned, which can reduce OCR time and increase accuracy.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public AdvancedOcrInputTypes InputImageType
Public InputImageType As AdvancedOcrInputTypes
val mutable InputImageType: AdvancedOcrInputTypes

Field Value

Type: AdvancedOcrInputTypes
See Also

Reference

AdvancedOcr Class


AdvancedOcr.Language Field

AdvancedOcrLanguage Field
Natural Language of the scanned documents. Default is English.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public IOcrLanguagePack Language
Public Language As IOcrLanguagePack
val mutable Language: IOcrLanguagePack

Field Value

Type: IOcrLanguagePack
See Also

Reference

AdvancedOcr Class


AdvancedOcr.ReadBarCodes Field

AdvancedOcrReadBarCodes Field
Enables Barcodes to be extracted from OCR documents, alongside the text content.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public bool ReadBarCodes
Public ReadBarCodes As Boolean
val mutable ReadBarCodes: bool

Field Value

Type: Boolean
See Also

Reference

AdvancedOcr Class


AdvancedOcr.RotateAndStraighten Field

AdvancedOcrRotateAndStraighten Field
AdvancedOcr will deskew and rotate images to be straight, upright, unbent and without perspective.

RotateAndStraighten is a powerful tool, making imperfect scans OCR accurately. CPU/GPU intensive.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public bool RotateAndStraighten
Public RotateAndStraighten As Boolean
val mutable RotateAndStraighten: bool

Field Value

Type: Boolean
See Also

Reference

AdvancedOcr Class


AdvancedOcr.Strategy Field

AdvancedOcrStrategy Field
Algorithm to be used for OCR text analysis.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public AdvancedOcrOcrStrategy Strategy
Public Strategy As AdvancedOcrOcrStrategy
val mutable Strategy: AdvancedOcrOcrStrategy

Field Value

Type: AdvancedOcrOcrStrategy
See Also

Reference

AdvancedOcr Class


AdvancedOcr.InputTypes Enumeration

AdvancedOcrInputTypes Enumeration
Types of document to expect to read.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public enum InputTypes
Public Enumeration InputTypes
type InputTypes
Members
Member name | Value | Description
AutoDetect | 0 |
Document | 1 |
Snippet | 2 |
See Also

Reference

IronOcr Namespace

IronOcr C# OCR Library - (C) 2017 Iron Software


AdvancedOcr.OcrColorSpace Enumeration

AdvancedOcrOcrColorSpace Enumeration
IronOcr can scan images in full color for greater accuracy, or in black, white and gray for speed.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public enum OcrColorSpace
Public Enumeration OcrColorSpace
type OcrColorSpace
Members
Member name | Value | Description
GrayScale | 0 | Documents are converted to shades of Gray
Color | 1 | Documents are scanned by the OCR software in full color
See Also

Reference

IronOcr Namespace

IronOcr C# OCR Library - (C) 2017 Iron Software


AdvancedOcr.OcrStrategy Enumeration

AdvancedOcrOcrStrategy Enumeration
IronOcr image text analysis algorithms

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public enum OcrStrategy
Public Enumeration OcrStrategy
type OcrStrategy
Members
Member name | Value | Description
Fast | 0 |
Advanced | 1 |
See Also

Reference

IronOcr Namespace

IronOcr C# OCR Library - (C) 2017 Iron Software


AutoOcr Class
A user-friendly OCR engine which extracts text and barcodes from images. AutoOcr "looks" at each image before scanning it, and uses meta-data and computer-vision to predict intelligent default settings for each setting. See also IronOcr.AdvancedOcr for faster, more specific OCR results.
Inheritance Hierarchy
SystemObject
IronOcrAutoOcr

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public class AutoOcr
Public Class AutoOcr
type AutoOcr =  class end

The AutoOcr type exposes the following members.

Constructors
 | Name | Description
Public method | AutoOcr | Initializes a new instance of the AutoOcr class
Top
Methods
 | Name | Description
Public method | Read(IEnumerableBitmap) | Performs OCR on multiple Images in parallel using multi-threading;
Public method | Read(IEnumerableImage) | Performs OCR on multiple Images simultaneously using parallel multi threading;
Public method | Read(IEnumerableString) | Performs OCR on multiple Images using multi-threaded parallel processing
Public method | Read(Bitmap) | Performs OCR on an Image.
Public method | Read(Image) | Performs OCR on an Image.
Public method | Read(String) | Performs OCR on an Image.
Public method | Read(Bitmap, Rectangle) | Performs OCR on an Image. Only Text and Barcodes within the CropArea will be scanned
Public method | Read(Image, Rectangle) | Performs OCR on an Image. Only Text and Barcodes within the CropArea will be scanned
Public method | Read(String, Rectangle) | Performs OCR on an Image. Only Text and Barcodes within the CropArea will be scanned
Public method | ReadMultiFrameTiff(Bitmap) | Performs OCR on a multi-pages image such as a multi-frame Tiff. Also works on GIF files.
Public method | ReadMultiFrameTiff(String) | Performs OCR on a multi-pages image such as a multi-frame Tiff. Also works on GIF files.
Public method | ReadPdf(Byte, IEnumerableInt32) | Performs OCR on a PDF Document.
Public method | ReadPdf(Byte, Int32) | Performs OCR on one page a PDF Document.
Public method | ReadPdf(Stream, IEnumerableInt32) | Performs OCR on a PDF Document.
Public method | ReadPdf(Stream, Int32) | Performs OCR on one page a PDF Document.
Public method | ReadPdf(String, IEnumerableInt32) | Performs OCR on selected pages of a PDF Document.
Public method | ReadPdf(String, Int32) | Performs OCR on one page of a PDF Document.
Public method | ReadPdf(Byte, Rectangle, IEnumerableInt32) | Performs OCR on specific cropped area of a PDF Document.
Public method | ReadPdf(Byte, Rectangle, Int32) | Performs OCR on a cropped area of one page a PDF Document.
Public method | ReadPdf(Stream, Rectangle, IEnumerableInt32) | Performs OCR on specific cropped area of a PDF Document.
Public method | ReadPdf(Stream, Rectangle, Int32) | Performs OCR on a cropped area of on one page a PDF Document.
Public method | ReadPdf(String, Rectangle, IEnumerableInt32) | Performs OCR on a specific cropped area of selected pages of a PDF Document.
Public method | ReadPdf(String, Rectangle, Int32) | Performs OCR on specific cropped area of a PDF Document.
Top
Fields
 | Name | Description
Public field | Language | Natural Language of the scanned documents. Default is English.
Public field | ReadBarCodes | Enables Barcodes to be extracted from OCR documents, alongside the text content.
Top
See Also

Reference

IronOcr Namespace

IronOcr C# OCR Library - (C) 2017 Iron Software


AutoOcr Constructor

Initializes a new instance of the AutoOcr class

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public AutoOcr()
Public Sub New
new : unit -> AutoOcr
See Also

Reference

AutoOcr Class


AutoOcr Methods
Methods
 | Name | Description
Public method | Read(IEnumerableBitmap) | Performs OCR on multiple Images in parallel using multi-threading;
Public method | Read(IEnumerableImage) | Performs OCR on multiple Images simultaneously using parallel multi threading;
Public method | Read(IEnumerableString) | Performs OCR on multiple Images using multi-threaded parallel processing
Public method | Read(Bitmap) | Performs OCR on an Image.
Public method | Read(Image) | Performs OCR on an Image.
Public method | Read(String) | Performs OCR on an Image.
Public method | Read(Bitmap, Rectangle) | Performs OCR on an Image. Only Text and Barcodes within the CropArea will be scanned
Public method | Read(Image, Rectangle) | Performs OCR on an Image. Only Text and Barcodes within the CropArea will be scanned
Public method | Read(String, Rectangle) | Performs OCR on an Image. Only Text and Barcodes within the CropArea will be scanned
Public method | ReadMultiFrameTiff(Bitmap) | Performs OCR on a multi-pages image such as a multi-frame Tiff. Also works on GIF files.
Public method | ReadMultiFrameTiff(String) | Performs OCR on a multi-pages image such as a multi-frame Tiff. Also works on GIF files.
Public method | ReadPdf(Byte, IEnumerableInt32) | Performs OCR on a PDF Document.
Public method | ReadPdf(Byte, Int32) | Performs OCR on one page a PDF Document.
Public method | ReadPdf(Stream, IEnumerableInt32) | Performs OCR on a PDF Document.
Public method | ReadPdf(Stream, Int32) | Performs OCR on one page a PDF Document.
Public method | ReadPdf(String, IEnumerableInt32) | Performs OCR on selected pages of a PDF Document.
Public method | ReadPdf(String, Int32) | Performs OCR on one page of a PDF Document.
Public method | ReadPdf(Byte, Rectangle, IEnumerableInt32) | Performs OCR on specific cropped area of a PDF Document.
Public method | ReadPdf(Byte, Rectangle, Int32) | Performs OCR on a cropped area of one page a PDF Document.
Public method | ReadPdf(Stream, Rectangle, IEnumerableInt32) | Performs OCR on specific cropped area of a PDF Document.
Public method | ReadPdf(Stream, Rectangle, Int32) | Performs OCR on a cropped area of on one page a PDF Document.
Public method | ReadPdf(String, Rectangle, IEnumerableInt32) | Performs OCR on a specific cropped area of selected pages of a PDF Document.
Public method | ReadPdf(String, Rectangle, Int32) | Performs OCR on specific cropped area of a PDF Document.
Top
See Also

Reference

AutoOcr Class


AutoOcr.Read Method

AutoOcrRead Method

Overload List
 | Name | Description
Public method | Read(IEnumerableBitmap) | Performs OCR on multiple Images in parallel using multi-threading;
Public method | Read(IEnumerableImage) | Performs OCR on multiple Images simultaneously using parallel multi threading;
Public method | Read(IEnumerableString) | Performs OCR on multiple Images using multi-threaded parallel processing
Public method | Read(Bitmap) | Performs OCR on an Image.
Public method | Read(Image) | Performs OCR on an Image.
Public method | Read(String) | Performs OCR on an Image.
Public method | Read(Bitmap, Rectangle) | Performs OCR on an Image. Only Text and Barcodes within the CropArea will be scanned
Public method | Read(Image, Rectangle) | Performs OCR on an Image. Only Text and Barcodes within the CropArea will be scanned
Public method | Read(String, Rectangle) | Performs OCR on an Image. Only Text and Barcodes within the CropArea will be scanned
Top
See Also

Reference

AutoOcr Class


AutoOcr.Read Method (IEnumerable(Bitmap))

AutoOcrRead Method (IEnumerableBitmap)
Performs OCR on multiple Images in parallel using multi-threading;

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult Read(
    IEnumerable<Bitmap> Bitmaps
)
Public Function Read (
    Bitmaps As IEnumerable(Of Bitmap)
) As OcrResult
member Read :
        Bitmaps : IEnumerable<Bitmap> -> OcrResult

Parameters

Bitmaps
Type: System.Collections.GenericIEnumerable Bitmap
Documents to be scanned as an IEnumerable of System.Drawing.Bitmap

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence, etc.
See Also

Reference

AutoOcr Class
Read Overload


AutoOcr.Read Method (IEnumerable(Image))

AutoOcrRead Method (IEnumerableImage)
Performs OCR on multiple Images simultaneously using parallel multi threading;

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult Read(
    IEnumerable<Image> Images
)
Public Function Read (
    Images As IEnumerable(Of Image)
) As OcrResult
member Read :
        Images : IEnumerable<Image> -> OcrResult

Parameters

Images
Type: System.Collections.GenericIEnumerable Image
Document to be scanned as a System.Drawing.Image

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence etc.
See Also

Reference

AutoOcr Class
Read Overload


AutoOcr.Read Method (IEnumerable(String))

AutoOcrRead Method (IEnumerableString)
Performs OCR on multiple Images using multi-threaded parallel processing

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult Read(
    IEnumerable<string> ImageFilePaths
)
Public Function Read (
    ImageFilePaths As IEnumerable(Of String)
) As OcrResult
member Read :
        ImageFilePaths : IEnumerable<string> -> OcrResult

Parameters

ImageFilePaths
Type: System.Collections.GenericIEnumerable String
Documents to be scanned as an image file path.

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence etc.
See Also

Reference

AutoOcr Class
Read Overload


AutoOcr.Read Method (Bitmap)

AutoOcrRead Method (Bitmap)
Performs OCR on an Image.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult Read(
    Bitmap Bitmap
)
Public Function Read (
    Bitmap As Bitmap
) As OcrResult
member Read :
        Bitmap : Bitmap -> OcrResult

Parameters

Bitmap
Type: System.DrawingBitmap
Document to be scanned as a System.Drawing.Bitmap

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence, etc.
See Also

Reference

AutoOcr Class
Read Overload


AutoOcr.Read Method (Image)

AutoOcrRead Method (Image)
Performs OCR on an Image.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult Read(
    Image Image
)
Public Function Read (
    Image As Image
) As OcrResult
member Read :
        Image : Image -> OcrResult

Parameters

Image
Type: System.DrawingImage
Document to be scanned as a System.Drawing.Image

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence etc.
See Also

Reference

AutoOcr Class
Read Overload


AutoOcr.Read Method (String)

AutoOcrRead Method (String)
Performs OCR on an Image.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult Read(
    string ImageFilePath
)
Public Function Read (
    ImageFilePath As String
) As OcrResult
member Read :
        ImageFilePath : string -> OcrResult

Parameters

ImageFilePath
Type: SystemString
Document file path to be read using OCR

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence etc.
See Also

Reference

AutoOcr Class
Read Overload


AutoOcr.Read Method (Bitmap, Rectangle)

AutoOcrRead Method (Bitmap, Rectangle)
Performs OCR on an Image.

Only Text and Barcodes within the CropArea will be scanned

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult Read(
    Bitmap Bitmap,
    Rectangle CropArea
)
Public Function Read (
    Bitmap As Bitmap,
    CropArea As Rectangle
) As OcrResult
member Read :
        Bitmap : Bitmap *
        CropArea : Rectangle -> OcrResult

Parameters

Bitmap
Type: System.DrawingBitmap
Document to be scanned as a System.Drawing.Bitmap
CropArea
Type: System.DrawingRectangle
A rectangular area of the image to be scanned for OCR.

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence etc.
See Also

Reference

AutoOcr Class
Read Overload


AutoOcr.Read Method (Image, Rectangle)

AutoOcrRead Method (Image, Rectangle)
Performs OCR on an Image.

Only Text and Barcodes within the CropArea will be scanned

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult Read(
    Image Image,
    Rectangle CropArea
)
Public Function Read (
    Image As Image,
    CropArea As Rectangle
) As OcrResult
member Read :
        Image : Image *
        CropArea : Rectangle -> OcrResult

Parameters

Image
Type: System.DrawingImage
Document to be scanned as a System.Drawing.Image
CropArea
Type: System.DrawingRectangle
A rectangular area of the image to be scanned for OCR.

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence etc.
See Also

Reference

AutoOcr Class
Read Overload


AutoOcr.Read Method (String, Rectangle)

AutoOcrRead Method (String, Rectangle)
Performs OCR on an Image.

Only Text and Barcodes within the CropArea will be scanned

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult Read(
    string ImageFilePath,
    Rectangle CropArea
)
Public Function Read (
    ImageFilePath As String,
    CropArea As Rectangle
) As OcrResult
member Read :
        ImageFilePath : string *
        CropArea : Rectangle -> OcrResult

Parameters

ImageFilePath
Type: SystemString
Document to be scanned as an image file path.
CropArea
Type: System.DrawingRectangle
A rectangular area of the image to be scanned for OCR.

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence etc.
See Also

Reference

AutoOcr Class
Read Overload


AutoOcr.ReadMultiFrameTiff Method

AutoOcrReadMultiFrameTiff Method

Overload List
 | Name | Description
Public method | ReadMultiFrameTiff(Bitmap) | Performs OCR on a multi-pages image such as a multi-frame Tiff. Also works on GIF files.
Public method | ReadMultiFrameTiff(String) | Performs OCR on a multi-pages image such as a multi-frame Tiff. Also works on GIF files.
Top
See Also

Reference

AutoOcr Class


AutoOcr.ReadMultiFrameTiff Method (Bitmap)

AutoOcrReadMultiFrameTiff Method (Bitmap)
Performs OCR on a multi-pages image such as a multi-frame Tiff. Also works on GIF files.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadMultiFrameTiff(
    Bitmap Tiff
)
Public Function ReadMultiFrameTiff (
    Tiff As Bitmap
) As OcrResult
member ReadMultiFrameTiff :
        Tiff : Bitmap -> OcrResult

Parameters

Tiff
Type: System.DrawingBitmap
Systemn.Drawing.Bitmap of a Tiff file with multiple pages/frames

Return Value

Type: OcrResult
Returns paginated OCR results for all pages of the Tiff, containing Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence etc. Each frame is treated as a single page.
See Also

Reference

AutoOcr Class
ReadMultiFrameTiff Overload


AutoOcr.ReadMultiFrameTiff Method (String)

AutoOcrReadMultiFrameTiff Method (String)
Performs OCR on a multi-pages image such as a multi-frame Tiff. Also works on GIF files.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadMultiFrameTiff(
    string TiffPath
)
Public Function ReadMultiFrameTiff (
    TiffPath As String
) As OcrResult
member ReadMultiFrameTiff :
        TiffPath : string -> OcrResult

Parameters

TiffPath
Type: SystemString
File path to a Tiff file with multiple pages/frames

Return Value

Type: OcrResult
Returns paginated OCR results for all pages of the Tiff, containing Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence etc. Each frame is treated as a single page.
See Also

Reference

AutoOcr Class
ReadMultiFrameTiff Overload


AutoOcr.ReadPdf Method

AutoOcrReadPdf Method

Overload List
 | Name | Description
Public method | ReadPdf(Byte, IEnumerableInt32) | Performs OCR on a PDF Document.
Public method | ReadPdf(Byte, Int32) | Performs OCR on one page a PDF Document.
Public method | ReadPdf(Stream, IEnumerableInt32) | Performs OCR on a PDF Document.
Public method | ReadPdf(Stream, Int32) | Performs OCR on one page a PDF Document.
Public method | ReadPdf(String, IEnumerableInt32) | Performs OCR on selected pages of a PDF Document.
Public method | ReadPdf(String, Int32) | Performs OCR on one page of a PDF Document.
Public method | ReadPdf(Byte, Rectangle, IEnumerableInt32) | Performs OCR on specific cropped area of a PDF Document.
Public method | ReadPdf(Byte, Rectangle, Int32) | Performs OCR on a cropped area of one page a PDF Document.
Public method | ReadPdf(Stream, Rectangle, IEnumerableInt32) | Performs OCR on specific cropped area of a PDF Document.
Public method | ReadPdf(Stream, Rectangle, Int32) | Performs OCR on a cropped area of on one page a PDF Document.
Public method | ReadPdf(String, Rectangle, IEnumerableInt32) | Performs OCR on a specific cropped area of selected pages of a PDF Document.
Public method | ReadPdf(String, Rectangle, Int32) | Performs OCR on specific cropped area of a PDF Document.
Top
See Also

Reference

AutoOcr Class


AutoOcr.ReadPdf Method (Byte[], IEnumerable(Int32))

AutoOcrReadPdf Method (Byte, IEnumerableInt32)
Performs OCR on a PDF Document.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadPdf(
    byte[] PdfBinaryData,
    IEnumerable<int> PageRange = null
)
Public Function ReadPdf (
    PdfBinaryData As Byte(),
    Optional PageRange As IEnumerable(Of Integer) = Nothing
) As OcrResult
member ReadPdf :
        PdfBinaryData : byte[] *
        ?PageRange : IEnumerable<int>
(* Defaults:
        let _PageRange = defaultArg PageRange null
*)
-> OcrResult

Parameters

PdfBinaryData
Type: SystemByte
The binary data for a PDF Document to be converted back to text.
PageRange (Optional)
Type: System.Collections.GenericIEnumerable Int32

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence, etc.
See Also

Reference

AutoOcr Class
ReadPdf Overload


AutoOcr.ReadPdf Method (Byte[], Int32)

AutoOcrReadPdf Method (Byte, Int32)
Performs OCR on one page a PDF Document.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadPdf(
    byte[] PdfBinaryData,
    int PageNumber
)
Public Function ReadPdf (
    PdfBinaryData As Byte(),
    PageNumber As Integer
) As OcrResult
member ReadPdf :
        PdfBinaryData : byte[] *
        PageNumber : int -> OcrResult

Parameters

PdfBinaryData
Type: SystemByte
The binary data for a PDF Document to be converted back to text.
PageNumber
Type: SystemInt32

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence, etc.
See Also

Reference

AutoOcr Class
ReadPdf Overload


AutoOcr.ReadPdf Method (Stream, IEnumerable(Int32))

AutoOcrReadPdf Method (Stream, IEnumerableInt32)
Performs OCR on a PDF Document.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadPdf(
    Stream PdfStreamData,
    IEnumerable<int> PageRange = null
)
Public Function ReadPdf (
    PdfStreamData As Stream,
    Optional PageRange As IEnumerable(Of Integer) = Nothing
) As OcrResult
member ReadPdf :
        PdfStreamData : Stream *
        ?PageRange : IEnumerable<int>
(* Defaults:
        let _PageRange = defaultArg PageRange null
*)
-> OcrResult

Parameters

PdfStreamData
Type: System.IOStream
The stream data for a PDF Document to be converted back to text.
PageRange (Optional)
Type: System.Collections.GenericIEnumerable Int32

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence, etc.
See Also

Reference

AutoOcr Class
ReadPdf Overload


AutoOcr.ReadPdf Method (Stream, Int32)

AutoOcrReadPdf Method (Stream, Int32)
Performs OCR on one page a PDF Document.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadPdf(
    Stream PdfStreamData,
    int PageNumber
)
Public Function ReadPdf (
    PdfStreamData As Stream,
    PageNumber As Integer
) As OcrResult
member ReadPdf :
        PdfStreamData : Stream *
        PageNumber : int -> OcrResult

Parameters

PdfStreamData
Type: System.IOStream
The stream data for a PDF Document to be converted back to text.
PageNumber
Type: SystemInt32

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence, etc.
See Also

Reference

AutoOcr Class
ReadPdf Overload


AutoOcr.ReadPdf Method (String, IEnumerable(Int32))

AutoOcrReadPdf Method (String, IEnumerableInt32)
Performs OCR on selected pages of a PDF Document.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadPdf(
    string PdfFilePath,
    IEnumerable<int> PageRange = null
)
Public Function ReadPdf (
    PdfFilePath As String,
    Optional PageRange As IEnumerable(Of Integer) = Nothing
) As OcrResult
member ReadPdf :
        PdfFilePath : string *
        ?PageRange : IEnumerable<int>
(* Defaults:
        let _PageRange = defaultArg PageRange null
*)
-> OcrResult

Parameters

PdfFilePath
Type: SystemString
PDF Document to be converted back to text.
PageRange (Optional)
Type: System.Collections.GenericIEnumerable Int32

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence, etc.
See Also

Reference

AutoOcr Class
ReadPdf Overload


AutoOcr.ReadPdf Method (String, Int32)

AutoOcrReadPdf Method (String, Int32)
Performs OCR on one page of a PDF Document.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadPdf(
    string PdfFilePath,
    int PageNumber
)
Public Function ReadPdf (
    PdfFilePath As String,
    PageNumber As Integer
) As OcrResult
member ReadPdf :
        PdfFilePath : string *
        PageNumber : int -> OcrResult

Parameters

PdfFilePath
Type: SystemString
PDF Document to be converted back to text.
PageNumber
Type: SystemInt32

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence, etc.
See Also

Reference

AutoOcr Class
ReadPdf Overload


AutoOcr.ReadPdf Method (Byte[], Rectangle, IEnumerable(Int32))

AutoOcrReadPdf Method (Byte, Rectangle, IEnumerableInt32)
Performs OCR on specific cropped area of a PDF Document.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadPdf(
    byte[] PdfBinaryData,
    Rectangle CropArea,
    IEnumerable<int> PageRange = null
)
Public Function ReadPdf (
    PdfBinaryData As Byte(),
    CropArea As Rectangle,
    Optional PageRange As IEnumerable(Of Integer) = Nothing
) As OcrResult
member ReadPdf :
        PdfBinaryData : byte[] *
        CropArea : Rectangle *
        ?PageRange : IEnumerable<int>
(* Defaults:
        let _PageRange = defaultArg PageRange null
*)
-> OcrResult

Parameters

PdfBinaryData
Type: SystemByte
The binary data for a PDF Document to be converted back to text.
CropArea
Type: System.DrawingRectangle
The crop area as a System.Drawing.Rectangle.
PageRange (Optional)
Type: System.Collections.GenericIEnumerable Int32

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence, etc.
See Also

Reference

AutoOcr Class
ReadPdf Overload


AutoOcr.ReadPdf Method (Byte[], Rectangle, Int32)

AutoOcrReadPdf Method (Byte, Rectangle, Int32)
Performs OCR on a cropped area of one page a PDF Document.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadPdf(
    byte[] PdfBinaryData,
    Rectangle CropArea,
    int PageNumber
)
Public Function ReadPdf (
    PdfBinaryData As Byte(),
    CropArea As Rectangle,
    PageNumber As Integer
) As OcrResult
member ReadPdf :
        PdfBinaryData : byte[] *
        CropArea : Rectangle *
        PageNumber : int -> OcrResult

Parameters

PdfBinaryData
Type: SystemByte
The binary data for a PDF Document to be converted back to text.
CropArea
Type: System.DrawingRectangle
The crop area as a System.Drawing.Rectangle.
PageNumber
Type: SystemInt32

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence, etc.
See Also

Reference

AutoOcr Class
ReadPdf Overload


AutoOcr.ReadPdf Method (Stream, Rectangle, IEnumerable(Int32))

AutoOcrReadPdf Method (Stream, Rectangle, IEnumerableInt32)
Performs OCR on specific cropped area of a PDF Document.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadPdf(
    Stream PdfStreamData,
    Rectangle CropArea,
    IEnumerable<int> PageRange = null
)
Public Function ReadPdf (
    PdfStreamData As Stream,
    CropArea As Rectangle,
    Optional PageRange As IEnumerable(Of Integer) = Nothing
) As OcrResult
member ReadPdf :
        PdfStreamData : Stream *
        CropArea : Rectangle *
        ?PageRange : IEnumerable<int>
(* Defaults:
        let _PageRange = defaultArg PageRange null
*)
-> OcrResult

Parameters

PdfStreamData
Type: System.IOStream
The stream data for a PDF Document to be converted back to text.
CropArea
Type: System.DrawingRectangle
The crop area as a System.Drawing.Rectangle.
PageRange (Optional)
Type: System.Collections.GenericIEnumerable Int32

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence, etc.
See Also

Reference

AutoOcr Class
ReadPdf Overload


AutoOcr.ReadPdf Method (Stream, Rectangle, Int32)

AutoOcrReadPdf Method (Stream, Rectangle, Int32)
Performs OCR on a cropped area of on one page a PDF Document.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadPdf(
    Stream PdfStreamData,
    Rectangle CropArea,
    int PageNumber
)
Public Function ReadPdf (
    PdfStreamData As Stream,
    CropArea As Rectangle,
    PageNumber As Integer
) As OcrResult
member ReadPdf :
        PdfStreamData : Stream *
        CropArea : Rectangle *
        PageNumber : int -> OcrResult

Parameters

PdfStreamData
Type: System.IOStream
The stream data for a PDF Document to be converted back to text.
CropArea
Type: System.DrawingRectangle
The crop area as a System.Drawing.Rectangle.
PageNumber
Type: SystemInt32

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence, etc.
See Also

Reference

AutoOcr Class
ReadPdf Overload


AutoOcr.ReadPdf Method (String, Rectangle, IEnumerable(Int32))

AutoOcrReadPdf Method (String, Rectangle, IEnumerableInt32)
Performs OCR on a specific cropped area of selected pages of a PDF Document.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadPdf(
    string PdfFilePath,
    Rectangle CropArea,
    IEnumerable<int> PageRange = null
)
Public Function ReadPdf (
    PdfFilePath As String,
    CropArea As Rectangle,
    Optional PageRange As IEnumerable(Of Integer) = Nothing
) As OcrResult
member ReadPdf :
        PdfFilePath : string *
        CropArea : Rectangle *
        ?PageRange : IEnumerable<int>
(* Defaults:
        let _PageRange = defaultArg PageRange null
*)
-> OcrResult

Parameters

PdfFilePath
Type: SystemString
PDF Document to be converted back to text.
CropArea
Type: System.DrawingRectangle
The crop area as a System.Drawing.Rectangle.
PageRange (Optional)
Type: System.Collections.GenericIEnumerable Int32

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence, etc.
See Also

Reference

AutoOcr Class
ReadPdf Overload


AutoOcr.ReadPdf Method (String, Rectangle, Int32)

AutoOcrReadPdf Method (String, Rectangle, Int32)
Performs OCR on specific cropped area of a PDF Document.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult ReadPdf(
    string PdfFilePath,
    Rectangle CropArea,
    int PageNumber
)
Public Function ReadPdf (
    PdfFilePath As String,
    CropArea As Rectangle,
    PageNumber As Integer
) As OcrResult
member ReadPdf :
        PdfFilePath : string *
        CropArea : Rectangle *
        PageNumber : int -> OcrResult

Parameters

PdfFilePath
Type: SystemString
PDF Document to be converted back to text.
CropArea
Type: System.DrawingRectangle
The crop area as a System.Drawing.Rectangle.
PageNumber
Type: SystemInt32

Return Value

Type: OcrResult
Returns Text, Barcodes, and an object model containing rich OCR data such as text-sizes, fonts, statistical confidence, etc.
See Also

Reference

AutoOcr Class
ReadPdf Overload


AutoOcr Fields

The AutoOcr type exposes the following members.

Fields
 | Name | Description
Public field | Language | Natural Language of the scanned documents. Default is English.
Public field | ReadBarCodes | Enables Barcodes to be extracted from OCR documents, alongside the text content.
Top
See Also

Reference

AutoOcr Class


AutoOcr.Language Field

AutoOcrLanguage Field
Natural Language of the scanned documents. Default is English.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public IOcrLanguagePack Language
Public Language As IOcrLanguagePack
val mutable Language: IOcrLanguagePack

Field Value

Type: IOcrLanguagePack
See Also

Reference

AutoOcr Class


AutoOcr.ReadBarCodes Field

AutoOcrReadBarCodes Field
Enables Barcodes to be extracted from OCR documents, alongside the text content.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public bool ReadBarCodes
Public ReadBarCodes As Boolean
val mutable ReadBarCodes: bool

Field Value

Type: Boolean
See Also

Reference

AutoOcr Class


IronOcrInstallation Class
Sets global installation parameters for IronOCR.
Inheritance Hierarchy
SystemObject
IronOcrIronOcrInstallation

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public static class IronOcrInstallation
Public NotInheritable Class IronOcrInstallation
[<AbstractClassAttribute>]
[<SealedAttribute>]
type IronOcrInstallation =  class end

The IronOcrInstallation type exposes the following members.

Properties
Name | Description
InstallationPath | Gets or sets the installation path directory to which assemblies will and temporary files will be deployed. InstallationPath should be set before any AdvancedOcr or AutoOcr methods are called.
Top
See Also

Reference

IronOcr Namespace

IronOcr C# OCR Library - (C) 2017 Iron Software


IronOcrInstallation Properties

The IronOcrInstallation type exposes the following members.

Properties
Name | Description
InstallationPath | Gets or sets the installation path directory to which assemblies will and temporary files will be deployed. InstallationPath should be set before any AdvancedOcr or AutoOcr methods are called.
Top
See Also

Reference

IronOcrInstallation Class


IronOcrInstallation.InstallationPath Property

IronOcrInstallationInstallationPath Property

Gets or sets the installation path directory to which assemblies will and temporary files will be deployed. InstallationPath should be set before any AdvancedOcr or AutoOcr methods are called.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public static string InstallationPath { get; set; }
Public Shared Property InstallationPath As String
    Get
    Set
static member InstallationPath : string with get, set

Property Value

Type: String
The installation path on a local hard disk. Leaving this value null will select a suitable temporary folder.
See Also

Reference

IronOcrInstallation Class


License Class
Allows IronOcr license keys to be applied globally across an application.

Apply your lice using LicenseKey in your code, or add the key IronOcr.LicenseKey to Web.Conbfig or App.Config

Inheritance Hierarchy
SystemObject
IronOcrLicense

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public static class License
Public NotInheritable Class License
[<AbstractClassAttribute>]
[<SealedAttribute>]
type License =  class end

The License type exposes the following members.

Methods
Name | Description
IsValidLicense | Determines whether a license key is valid.
Top
Fields
Name | Description
LicenseKey | License IronOcr for deployment. Get Licensed at http://ironsoftware.com/csharp/ocr/licensing/ A License key can also be added to Web.Config or App.Config as IronOcr.LicenseKey
Top
See Also

Reference

IronOcr Namespace

IronOcr C# OCR Library - (C) 2017 Iron Software


License Methods

The License type exposes the following members.

Methods
Name | Description
IsValidLicense | Determines whether a license key is valid.
Top
See Also

Reference

License Class


License.IsValidLicense Method

LicenseIsValidLicense Method

Determines whether a license key is valid.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public static bool IsValidLicense(
    string LicenseKey
)
Public Shared Function IsValidLicense (
    LicenseKey As String
) As Boolean
static member IsValidLicense :
        LicenseKey : string -> bool

Parameters

LicenseKey
Type: SystemString
IronOcr license key as a string

Return Value

Type: Boolean
See Also

Reference

License Class


License Fields

The License type exposes the following members.

Fields
Name | Description
LicenseKey | License IronOcr for deployment. Get Licensed at http://ironsoftware.com/csharp/ocr/licensing/ A License key can also be added to Web.Config or App.Config as IronOcr.LicenseKey
Top
See Also

Reference

License Class


License.LicenseKey Field

LicenseLicenseKey Field
License IronOcr for deployment. Get Licensed at http://ironsoftware.com/csharp/ocr/licensing/ A License key can also be added to Web.Config or App.Config as IronOcr.LicenseKey

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public static string LicenseKey
Public Shared LicenseKey As String
static val mutable LicenseKey: string

Field Value

Type: String
See Also

Reference

License Class


OcrResult Class
Detailed results from reading one or more images using IronOcr.

OcrResult contains text, barcodes, images and a detailed object model for every discovered object on each page, with detailed meta-data.

Inheritance Hierarchy
SystemObject
IronOcrOcrResult

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public class OcrResult
Public Class OcrResult
type OcrResult =  class end

The OcrResult type exposes the following members.

Constructors
 | Name | Description
Public method | OcrResult | Initializes a new instance of the OcrResult class
Top
Properties
 | Name | Description
Public property | Barcodes | All Barcodes and QR codes discovered within the document.
Public property | FontName | The name of the most common font / typeface the document. If the font is unknown, a close visual match will be chosen.
Public property | FontSize | The most common font size within the document. In Pixels.
Public property | Pages | A detailed object model containing every paragraph, line of text, word and character in every page of the scanned document with detailed images, coordinates and meta-data.
Public property | Text | Gets the full text content for the document. Each Lines as seen on the paper document with be terminated with System.NewLine. Paragraphs are separated by 2 x System.NewLine. Pages are separated by 4 x System.NewLine
Top
Methods
 | Name | Description
Public method | SaveAsTextFile | Saves the OCRText to a file.
Public method | ToString | The full OCR text as a UTF-8 string. (Overrides ObjectToString.)
Top
See Also

Reference

IronOcr Namespace

IronOcr C# OCR Library - (C) 2017 Iron Software


OcrResult Constructor

Initializes a new instance of the OcrResult class

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResult()
Public Sub New
new : unit -> OcrResult
See Also

Reference

OcrResult Class


OcrResult Properties

The OcrResult type exposes the following members.

Properties
 | Name | Description
Public property | Barcodes | All Barcodes and QR codes discovered within the document.
Public property | FontName | The name of the most common font / typeface the document. If the font is unknown, a close visual match will be chosen.
Public property | FontSize | The most common font size within the document. In Pixels.
Public property | Pages | A detailed object model containing every paragraph, line of text, word and character in every page of the scanned document with detailed images, coordinates and meta-data.
Public property | Text | Gets the full text content for the document. Each Lines as seen on the paper document with be terminated with System.NewLine. Paragraphs are separated by 2 x System.NewLine. Pages are separated by 4 x System.NewLine
Top
See Also

Reference

OcrResult Class


OcrResult.Barcodes Property

OcrResultBarcodes Property

All Barcodes and QR codes discovered within the document.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResultOcrBarcode[] Barcodes { get; }
Public ReadOnly Property Barcodes As OcrResultOcrBarcode()
    Get
member Barcodes : OcrResultOcrBarcode[] with get

Property Value

Type: OcrResultOcrBarcode
Array of OcrBarcode
See Also

Reference

OcrResult Class


OcrResult.FontName Property

OcrResultFontName Property

The name of the most common font / typeface the document. If the font is unknown, a close visual match will be chosen.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public string FontName { get; }
Public ReadOnly Property FontName As String
    Get
member FontName : string with get

Property Value

Type: String
The name of the font. Null if no text was detected.
See Also

Reference

OcrResult Class


OcrResult.FontSize Property

OcrResultFontSize Property

The most common font size within the document. In Pixels.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public double FontSize { get; }
Public ReadOnly Property FontSize As Double
    Get
member FontSize : float with get

Property Value

Type: Double
The size of the font. Zero (0) if no text was detected.
See Also

Reference

OcrResult Class


OcrResult.Pages Property

OcrResultPages Property

A detailed object model containing every paragraph, line of text, word and character in every page of the scanned document with detailed images, coordinates and meta-data.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public List<OcrResultOcrPage> Pages { get; }
Public ReadOnly Property Pages As List(Of OcrResultOcrPage)
    Get
member Pages : List<OcrResultOcrPage> with get

Property Value

Type: List OcrResultOcrPage
See Also

Reference

OcrResult Class


OcrResult.Text Property

OcrResultText Property

Gets the full text content for the document.

Each Lines as seen on the paper document with be terminated with System.NewLine. Paragraphs are separated by 2 x System.NewLine. Pages are separated by 4 x System.NewLine

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get
member Text : string with get

Property Value

Type: String
Plain UTF-8 text.
See Also

Reference

OcrResult Class


OcrResult Methods

The OcrResult type exposes the following members.

Methods
 | Name | Description
Public method | SaveAsTextFile | Saves the OCRText to a file.
Public method | ToString | The full OCR text as a UTF-8 string. (Overrides ObjectToString.)
Top
See Also

Reference

OcrResult Class


OcrResult.SaveAsTextFile Method

OcrResultSaveAsTextFile Method

Saves the OCRText to a file.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public void SaveAsTextFile(
    string FilePath
)
Public Sub SaveAsTextFile (
    FilePath As String
)
member SaveAsTextFile :
        FilePath : string -> unit

Parameters

FilePath
Type: SystemString
The file path.
See Also

Reference

OcrResult Class


OcrResult.ToString Method

OcrResultToString Method

The full OCR text as a UTF-8 string.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A String that represents this instance.
See Also

Reference

OcrResult Class


OcrResult.OcrBarcode Class

OcrResultOcrBarcode Class
Object describing a Barcode or QR code discovered by IronOcr. 20+ formats are supported.
Inheritance Hierarchy
SystemObject
IronOcrOcrResultOcrBarcode

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public class OcrBarcode
Public Class OcrBarcode
type OcrBarcode =  class end

The OcrResultOcrBarcode type exposes the following members.

Constructors
 | Name | Description
Public method | OcrResultOcrBarcode | Initializes a new instance of the OcrResultOcrBarcode class
Top
Properties
 | Name | Description
Public property | Height | Height of the barcode in Pixels. Height may be approximated for 1 dimensional barcodes. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Public property | Image | An image of this barcode
Public property | OcrObjectId | A unique name for this barcode within an OcrResult.
Public property | PageNumber | The OcrResult page number this barcode was found on
Public property | Width | Width of the barcode in Pixels. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Public property | X | Horizontal location of this barcode relative to the left edge of the page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Public property | Y | Vertical location of this barcode relative to the top edge of the page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Top
Methods
 | Name | Description
Public method | ToString | Returns the Value of this barcode as a string. (Overrides ObjectToString.)
Top
Fields
 | Name | Description
Public field | BarcodeNumber | The position of this barcode within an OcrResultOcrPage. The first barcode is numbered 1, rather than zero.
Public field | Format | Describes the type of barcode discovered.
Public field | Location | The location and size of this barcode as discovered in Image Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Public field | Value | The value of this barcode as a string. It may represent numbers, a url, or UTF-8 text.
Top
See Also

Reference

IronOcr Namespace

IronOcr C# OCR Library - (C) 2017 Iron Software


OcrResult.OcrBarcode Constructor

OcrResultOcrBarcode Constructor

Initializes a new instance of the OcrResultOcrBarcode class

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrBarcode()
Public Sub New
new : unit -> OcrBarcode
See Also

Reference

OcrResultOcrBarcode Class


OcrBarcode Properties

The OcrResultOcrBarcode type exposes the following members.

Properties
 | Name | Description
Public property | Height | Height of the barcode in Pixels. Height may be approximated for 1 dimensional barcodes. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Public property | Image | An image of this barcode
Public property | OcrObjectId | A unique name for this barcode within an OcrResult.
Public property | PageNumber | The OcrResult page number this barcode was found on
Public property | Width | Width of the barcode in Pixels. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Public property | X | Horizontal location of this barcode relative to the left edge of the page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Public property | Y | Vertical location of this barcode relative to the top edge of the page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Top
See Also

Reference

OcrResultOcrBarcode Class


OcrResult.OcrBarcode.Height Property

OcrResultOcrBarcodeHeight Property

Height of the barcode in Pixels. Height may be approximated for 1 dimensional barcodes.

Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int Height { get; }
Public ReadOnly Property Height As Integer
    Get
member Height : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrBarcode Class


OcrResult.OcrBarcode.Image Property

OcrResultOcrBarcodeImage Property

An image of this barcode

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public Bitmap Image { get; }
Public ReadOnly Property Image As Bitmap
    Get
member Image : Bitmap with get

Property Value

Type: Bitmap
See Also

Reference

OcrResultOcrBarcode Class


OcrResult.OcrBarcode.OcrObjectId Property

OcrResultOcrBarcodeOcrObjectId Property

A unique name for this barcode within an OcrResult.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public string OcrObjectId { get; }
Public ReadOnly Property OcrObjectId As String
    Get
member OcrObjectId : string with get

Property Value

Type: String
See Also

Reference

OcrResultOcrBarcode Class


OcrResult.OcrBarcode.PageNumber Property

OcrResultOcrBarcodePageNumber Property

The OcrResult page number this barcode was found on

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int PageNumber { get; }
Public ReadOnly Property PageNumber As Integer
    Get
member PageNumber : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrBarcode Class


OcrResult.OcrBarcode.Width Property

OcrResultOcrBarcodeWidth Property

Width of the barcode in Pixels.

Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int Width { get; }
Public ReadOnly Property Width As Integer
    Get
member Width : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrBarcode Class


OcrResult.OcrBarcode.X Property

OcrResultOcrBarcodeX Property

Horizontal location of this barcode relative to the left edge of the page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int X { get; }
Public ReadOnly Property X As Integer
    Get
member X : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrBarcode Class


OcrResult.OcrBarcode.Y Property

OcrResultOcrBarcodeY Property

Vertical location of this barcode relative to the top edge of the page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int Y { get; }
Public ReadOnly Property Y As Integer
    Get
member Y : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrBarcode Class


OcrBarcode Methods

The OcrResultOcrBarcode type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Returns the Value of this barcode as a string. (Overrides ObjectToString.)
Top
See Also

Reference

OcrResultOcrBarcode Class


OcrResult.OcrBarcode.ToString Method

OcrResultOcrBarcodeToString Method

Returns the Value of this barcode as a string.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

OcrResultOcrBarcode Class


OcrBarcode Fields

The OcrResultOcrBarcode type exposes the following members.

Fields
 | Name | Description
Public field | BarcodeNumber | The position of this barcode within an OcrResultOcrPage. The first barcode is numbered 1, rather than zero.
Public field | Format | Describes the type of barcode discovered.
Public field | Location | The location and size of this barcode as discovered in Image Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Public field | Value | The value of this barcode as a string. It may represent numbers, a url, or UTF-8 text.
Top
See Also

Reference

OcrResultOcrBarcode Class


OcrResult.OcrBarcode.BarcodeNumber Field

OcrResultOcrBarcodeBarcodeNumber Field
The position of this barcode within an OcrResultOcrPage. The first barcode is numbered 1, rather than zero.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int BarcodeNumber
Public BarcodeNumber As Integer
val mutable BarcodeNumber: int

Field Value

Type: Int32
See Also

Reference

OcrResultOcrBarcode Class


OcrResult.OcrBarcode.Format Field

OcrResultOcrBarcodeFormat Field
Describes the type of barcode discovered.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResultOcrBarcodeBarcodeFormat Format
Public Format As OcrResultOcrBarcodeBarcodeFormat
val mutable Format: OcrResultOcrBarcodeBarcodeFormat

Field Value

Type: OcrResultOcrBarcodeBarcodeFormat
See Also

Reference

OcrResultOcrBarcode Class


OcrResult.OcrBarcode.Location Field

OcrResultOcrBarcodeLocation Field
The location and size of this barcode as discovered in Image

Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public Rectangle Location
Public Location As Rectangle
val mutable Location: Rectangle

Field Value

Type: Rectangle
See Also

Reference

OcrResultOcrBarcode Class


OcrResult.OcrBarcode.Value Field

OcrResultOcrBarcodeValue Field
The value of this barcode as a string. It may represent numbers, a url, or UTF-8 text.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public string Value
Public Value As String
val mutable Value: string

Field Value

Type: String
See Also

Reference

OcrResultOcrBarcode Class


OcrResult.OcrBarcode.BarcodeFormat Enumeration

OcrResultOcrBarcodeBarcodeFormat Enumeration
Describes types of barcode

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public enum BarcodeFormat
Public Enumeration BarcodeFormat
type BarcodeFormat
Members
Member name | Value | Description
Aztec | 1 |
CodaBar | 2 |
Code39 | 4 |
Code93 | 8 |
Code128 | 16 |
DataMatrix | 32 |
EAN13 | 128 |
ITF | 256 |
MaxiCode | 512 |
PDF417 | 1024 |
QRCode | 2048 |
Rss14 | 4096 |
RssExpanded | 8192 |
UPCA | 16384 |
UPCE | 32768 |
MSI | 131072 |
Plessey | 262144 |
IMB | 524288 |
See Also

Reference

IronOcr Namespace

IronOcr C# OCR Library - (C) 2017 Iron Software


OcrResult.OcrCharacter Class

OcrResultOcrCharacter Class
An object representing each instance of each character (symbol) of readable text discovered with OCR.
Inheritance Hierarchy
SystemObject
IronOcrOcrResultOcrCharacter

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public class OcrCharacter
Public Class OcrCharacter
type OcrCharacter =  class end

The OcrResultOcrCharacter type exposes the following members.

Constructors
 | Name | Description
Public method | OcrResultOcrCharacter | Initializes a new instance of the OcrResultOcrCharacter class
Top
Properties
 | Name | Description
Public property | Height | Height of the character in pixels.
Public property | Image | An image of this character
Public property | OcrObjectId | A unique name for this character instance within the OcrResults model.
Public property | PageNumber | The OcrResult page number this character was found on
Public property | Width | Width of the character in pixels.
Public property | X | Horizontal location of the character relative to the left edge of the page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Public property | Y | Vertical location of the character relative to the top edge of the page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Top
Methods
 | Name | Description
Public method | ToString | Return the characters as a single length UFT-8 string. (Overrides ObjectToString.)
Top
Fields
 | Name | Description
Public field | CharacterNumber | The position of this character within the word it was forms a part of
Public field | Confidence | The percentage statistical confidence that this character has been correctly identified.
Public field | LineNumber | The line number in which this character was found
Public field | Location | The location and size of this character as discovered in Image Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Public field | ParagraphNumber | The paragraph in which this character was found
Public field | Text | Return the characters as a single length UFT-8 string.
Public field | WordNumber | The word number in which this character was found
Top
See Also

Reference

IronOcr Namespace

IronOcr C# OCR Library - (C) 2017 Iron Software


OcrResult.OcrCharacter Constructor

OcrResultOcrCharacter Constructor

Initializes a new instance of the OcrResultOcrCharacter class

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrCharacter()
Public Sub New
new : unit -> OcrCharacter
See Also

Reference

OcrResultOcrCharacter Class


OcrCharacter Properties

The OcrResultOcrCharacter type exposes the following members.

Properties
 | Name | Description
Public property | Height | Height of the character in pixels.
Public property | Image | An image of this character
Public property | OcrObjectId | A unique name for this character instance within the OcrResults model.
Public property | PageNumber | The OcrResult page number this character was found on
Public property | Width | Width of the character in pixels.
Public property | X | Horizontal location of the character relative to the left edge of the page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Public property | Y | Vertical location of the character relative to the top edge of the page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Top
See Also

Reference

OcrResultOcrCharacter Class


OcrResult.OcrCharacter.Height Property

OcrResultOcrCharacterHeight Property

Height of the character in pixels.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int Height { get; }
Public ReadOnly Property Height As Integer
    Get
member Height : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrCharacter Class


OcrResult.OcrCharacter.Image Property

OcrResultOcrCharacterImage Property

An image of this character

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public Bitmap Image { get; }
Public ReadOnly Property Image As Bitmap
    Get
member Image : Bitmap with get

Property Value

Type: Bitmap
See Also

Reference

OcrResultOcrCharacter Class


OcrResult.OcrCharacter.OcrObjectId Property

OcrResultOcrCharacterOcrObjectId Property

A unique name for this character instance within the OcrResults model.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public string OcrObjectId { get; }
Public ReadOnly Property OcrObjectId As String
    Get
member OcrObjectId : string with get

Property Value

Type: String
See Also

Reference

OcrResultOcrCharacter Class


OcrResult.OcrCharacter.PageNumber Property

OcrResultOcrCharacterPageNumber Property

The OcrResult page number this character was found on

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int PageNumber { get; }
Public ReadOnly Property PageNumber As Integer
    Get
member PageNumber : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrCharacter Class


OcrResult.OcrCharacter.Width Property

OcrResultOcrCharacterWidth Property

Width of the character in pixels.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int Width { get; }
Public ReadOnly Property Width As Integer
    Get
member Width : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrCharacter Class


OcrResult.OcrCharacter.X Property

OcrResultOcrCharacterX Property

Horizontal location of the character relative to the left edge of the page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int X { get; }
Public ReadOnly Property X As Integer
    Get
member X : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrCharacter Class


OcrResult.OcrCharacter.Y Property

OcrResultOcrCharacterY Property

Vertical location of the character relative to the top edge of the page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int Y { get; }
Public ReadOnly Property Y As Integer
    Get
member Y : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrCharacter Class


OcrCharacter Methods

The OcrResultOcrCharacter type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Return the characters as a single length UFT-8 string. (Overrides ObjectToString.)
Top
See Also

Reference

OcrResultOcrCharacter Class


OcrResult.OcrCharacter.ToString Method

OcrResultOcrCharacterToString Method

Return the characters as a single length UFT-8 string.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

OcrResultOcrCharacter Class


OcrCharacter Fields

The OcrResultOcrCharacter type exposes the following members.

Fields
 | Name | Description
Public field | CharacterNumber | The position of this character within the word it was forms a part of
Public field | Confidence | The percentage statistical confidence that this character has been correctly identified.
Public field | LineNumber | The line number in which this character was found
Public field | Location | The location and size of this character as discovered in Image Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Public field | ParagraphNumber | The paragraph in which this character was found
Public field | Text | Return the characters as a single length UFT-8 string.
Public field | WordNumber | The word number in which this character was found
Top
See Also

Reference

OcrResultOcrCharacter Class


OcrResult.OcrCharacter.CharacterNumber Field

OcrResultOcrCharacterCharacterNumber Field
The position of this character within the word it was forms a part of

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int CharacterNumber
Public CharacterNumber As Integer
val mutable CharacterNumber: int

Field Value

Type: Int32
See Also

Reference

OcrResultOcrCharacter Class


OcrResult.OcrCharacter.Confidence Field

OcrResultOcrCharacterConfidence Field
The percentage statistical confidence that this character has been correctly identified.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public double Confidence
Public Confidence As Double
val mutable Confidence: float

Field Value

Type: Double
See Also

Reference

OcrResultOcrCharacter Class


OcrResult.OcrCharacter.LineNumber Field

OcrResultOcrCharacterLineNumber Field
The line number in which this character was found

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int LineNumber
Public LineNumber As Integer
val mutable LineNumber: int

Field Value

Type: Int32
See Also

Reference

OcrResultOcrCharacter Class


OcrResult.OcrCharacter.Location Field

OcrResultOcrCharacterLocation Field
The location and size of this character as discovered in Image

Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public Rectangle Location
Public Location As Rectangle
val mutable Location: Rectangle

Field Value

Type: Rectangle
See Also

Reference

OcrResultOcrCharacter Class


OcrResult.OcrCharacter.ParagraphNumber Field

OcrResultOcrCharacterParagraphNumber Field
The paragraph in which this character was found

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int ParagraphNumber
Public ParagraphNumber As Integer
val mutable ParagraphNumber: int

Field Value

Type: Int32
See Also

Reference

OcrResultOcrCharacter Class


OcrResult.OcrCharacter.Text Field

OcrResultOcrCharacterText Field
Return the characters as a single length UFT-8 string.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public string Text
Public Text As String
val mutable Text: string

Field Value

Type: String
See Also

Reference

OcrResultOcrCharacter Class


OcrResult.OcrCharacter.WordNumber Field

OcrResultOcrCharacterWordNumber Field
The word number in which this character was found

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int WordNumber
Public WordNumber As Integer
val mutable WordNumber: int

Field Value

Type: Int32
See Also

Reference

OcrResultOcrCharacter Class


OcrResult.OcrLine Class

OcrResultOcrLine Class
An object representing each line of text discovered in an OCRResult
Inheritance Hierarchy
SystemObject
IronOcrOcrResultOcrLine

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public class OcrLine
Public Class OcrLine
type OcrLine =  class end

The OcrResultOcrLine type exposes the following members.

Constructors
 | Name | Description
Public method | OcrResultOcrLine | Initializes a new instance of the OcrResultOcrLine class
Top
Properties
 | Name | Description
Public property | Height | Height of the line of text, in pixels.
Public property | Image | An image of this entire line of text
Public property | OcrObjectId | A unique name for this line of text within an OcrResult.
Public property | PageNumber | The OcrResult page number this line of text was found on
Public property | Text | The full text of this line of words as a UTF-8 string. EAch word is separated by a single 'space' character.
Public property | Width | Width of the line of text, in pixels.
Public property | WordCount | The number of words discovered within this line of text
Public property | X | Horizontal location of this line of text relative to the left edge of the page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Public property | Y | Vertical location of this line of text relative to the top edge of the page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Top
Methods
 | Name | Description
Public method | ToString | Return the line's full Text as a string (Overrides ObjectToString.)
Top
Fields
 | Name | Description
Public field | BaselineAngle | The angle of skew (rotation) of the text, measured in counter-clockwise degrees.
Public field | BaselineOffset | The displacement (signed distance) of the baseline of this text-line relative to its top edge (see Y). For example the bottom baseline would sit at the bottom of a letter 'o', "a" or any number. The letters 'y' and 'g' have tails which drop below the baseline.
Public field | Confidence | The mean (average) percentage statistical confidence IronOcr has in its analysis of this line of text. Values range from 0-100.
Public field | LineNumber | The number of this line within its enclosing paragraph. One based.
Public field | Location | The location and size of this line of text as discovered in Image Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Public field | ParagraphNumber | The paragraph in which this line was found
Public field | Words | Objects for word discovered within this line of text
Top
See Also

Reference

IronOcr Namespace

IronOcr C# OCR Library - (C) 2017 Iron Software


OcrResult.OcrLine Constructor

OcrResultOcrLine Constructor

Initializes a new instance of the OcrResultOcrLine class

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrLine()
Public Sub New
new : unit -> OcrLine
See Also

Reference

OcrResultOcrLine Class


OcrLine Properties

The OcrResultOcrLine type exposes the following members.

Properties
 | Name | Description
Public property | Height | Height of the line of text, in pixels.
Public property | Image | An image of this entire line of text
Public property | OcrObjectId | A unique name for this line of text within an OcrResult.
Public property | PageNumber | The OcrResult page number this line of text was found on
Public property | Text | The full text of this line of words as a UTF-8 string. EAch word is separated by a single 'space' character.
Public property | Width | Width of the line of text, in pixels.
Public property | WordCount | The number of words discovered within this line of text
Public property | X | Horizontal location of this line of text relative to the left edge of the page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Public property | Y | Vertical location of this line of text relative to the top edge of the page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Top
See Also

Reference

OcrResultOcrLine Class


OcrResult.OcrLine.Height Property

OcrResultOcrLineHeight Property

Height of the line of text, in pixels.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int Height { get; }
Public ReadOnly Property Height As Integer
    Get
member Height : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrLine Class


OcrResult.OcrLine.Image Property

OcrResultOcrLineImage Property

An image of this entire line of text

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public Bitmap Image { get; }
Public ReadOnly Property Image As Bitmap
    Get
member Image : Bitmap with get

Property Value

Type: Bitmap
See Also

Reference

OcrResultOcrLine Class


OcrResult.OcrLine.OcrObjectId Property

OcrResultOcrLineOcrObjectId Property

A unique name for this line of text within an OcrResult.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public string OcrObjectId { get; }
Public ReadOnly Property OcrObjectId As String
    Get
member OcrObjectId : string with get

Property Value

Type: String
See Also

Reference

OcrResultOcrLine Class


OcrResult.OcrLine.PageNumber Property

OcrResultOcrLinePageNumber Property

The OcrResult page number this line of text was found on

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int PageNumber { get; }
Public ReadOnly Property PageNumber As Integer
    Get
member PageNumber : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrLine Class


OcrResult.OcrLine.Text Property

OcrResultOcrLineText Property

The full text of this line of words as a UTF-8 string. EAch word is separated by a single 'space' character.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get
member Text : string with get

Property Value

Type: String
See Also

Reference

OcrResultOcrLine Class


OcrResult.OcrLine.Width Property

OcrResultOcrLineWidth Property

Width of the line of text, in pixels.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int Width { get; }
Public ReadOnly Property Width As Integer
    Get
member Width : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrLine Class


OcrResult.OcrLine.WordCount Property

OcrResultOcrLineWordCount Property

The number of words discovered within this line of text

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int WordCount { get; }
Public ReadOnly Property WordCount As Integer
    Get
member WordCount : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrLine Class


OcrResult.OcrLine.X Property

OcrResultOcrLineX Property

Horizontal location of this line of text relative to the left edge of the page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int X { get; }
Public ReadOnly Property X As Integer
    Get
member X : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrLine Class


OcrResult.OcrLine.Y Property

OcrResultOcrLineY Property

Vertical location of this line of text relative to the top edge of the page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int Y { get; }
Public ReadOnly Property Y As Integer
    Get
member Y : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrLine Class


OcrLine Methods

The OcrResultOcrLine type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Return the line's full Text as a string (Overrides ObjectToString.)
Top
See Also

Reference

OcrResultOcrLine Class


OcrResult.OcrLine.ToString Method

OcrResultOcrLineToString Method

Return the line's full Text as a string

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

OcrResultOcrLine Class


OcrLine Fields

The OcrResultOcrLine type exposes the following members.

Fields
 | Name | Description
Public field | BaselineAngle | The angle of skew (rotation) of the text, measured in counter-clockwise degrees.
Public field | BaselineOffset | The displacement (signed distance) of the baseline of this text-line relative to its top edge (see Y). For example the bottom baseline would sit at the bottom of a letter 'o', "a" or any number. The letters 'y' and 'g' have tails which drop below the baseline.
Public field | Confidence | The mean (average) percentage statistical confidence IronOcr has in its analysis of this line of text. Values range from 0-100.
Public field | LineNumber | The number of this line within its enclosing paragraph. One based.
Public field | Location | The location and size of this line of text as discovered in Image Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Public field | ParagraphNumber | The paragraph in which this line was found
Public field | Words | Objects for word discovered within this line of text
Top
See Also

Reference

OcrResultOcrLine Class


OcrResult.OcrLine.BaselineAngle Field

OcrResultOcrLineBaselineAngle Field
The angle of skew (rotation) of the text, measured in counter-clockwise degrees.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public double BaselineAngle
Public BaselineAngle As Double
val mutable BaselineAngle: float

Field Value

Type: Double
See Also

Reference

OcrResultOcrLine Class


OcrResult.OcrLine.BaselineOffset Field

OcrResultOcrLineBaselineOffset Field
The displacement (signed distance) of the baseline of this text-line relative to its top edge (see Y). For example the bottom baseline would sit at the bottom of a letter 'o', "a" or any number. The letters 'y' and 'g' have tails which drop below the baseline.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int BaselineOffset
Public BaselineOffset As Integer
val mutable BaselineOffset: int

Field Value

Type: Int32
See Also

Reference

OcrResultOcrLine Class


OcrResult.OcrLine.Confidence Field

OcrResultOcrLineConfidence Field
The mean (average) percentage statistical confidence IronOcr has in its analysis of this line of text. Values range from 0-100.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public double Confidence
Public Confidence As Double
val mutable Confidence: float

Field Value

Type: Double
See Also

Reference

OcrResultOcrLine Class


OcrResult.OcrLine.LineNumber Field

OcrResultOcrLineLineNumber Field
The number of this line within its enclosing paragraph. One based.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int LineNumber
Public LineNumber As Integer
val mutable LineNumber: int

Field Value

Type: Int32
See Also

Reference

OcrResultOcrLine Class


OcrResult.OcrLine.Location Field

OcrResultOcrLineLocation Field
The location and size of this line of text as discovered in Image

Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public Rectangle Location
Public Location As Rectangle
val mutable Location: Rectangle

Field Value

Type: Rectangle
See Also

Reference

OcrResultOcrLine Class


OcrResult.OcrLine.ParagraphNumber Field

OcrResultOcrLineParagraphNumber Field
The paragraph in which this line was found

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int ParagraphNumber
Public ParagraphNumber As Integer
val mutable ParagraphNumber: int

Field Value

Type: Int32
See Also

Reference

OcrResultOcrLine Class


OcrResult.OcrLine.Words Field

OcrResultOcrLineWords Field
Objects for word discovered within this line of text

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public List<OcrResultOcrWord> Words
Public Words As List(Of OcrResultOcrWord)
val mutable Words: List<OcrResultOcrWord>

Field Value

Type: List OcrResultOcrWord
See Also

Reference

OcrResultOcrLine Class


OcrResult.OcrPage Class

OcrResultOcrPage Class
An object representing a whole page of content read by IronOcr. May contains text & barcodes alongside detailed enumerable meta-data
Inheritance Hierarchy
SystemObject
IronOcrOcrResultOcrPage

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public class OcrPage
Public Class OcrPage
type OcrPage =  class end

The OcrResultOcrPage type exposes the following members.

Constructors
 | Name | Description
Public method | OcrResultOcrPage | Initializes a new instance of the OcrResultOcrPage class
Top
Properties
 | Name | Description
Public property | Characters | Objects describing each character found in this scanned page.
Public property | FontName | The name of the most common typeface discovered within this page. If a typeface is unknown, the closest match will be returned.
Public property | FontSize | The most common text size discovered within this page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Public property | Height | Height of the input document image in pixels (measured after it has been unrotated and deskewed by RotateAndStraighten)
Public property | Image | A bitmap image of this page. The image may have been straightened if the original input image was skewed, deformed or had perspective.
Public property | LinesOfText | Objects describing each line of text found in this scanned page.
Public property | PageNumber | The number of this page within an OcrResult. Being 1 based, the first page is numbered 1, rather than zero.
Public property | Text | Full text discovered within this page as a UFT-8 string. Each paragraph of text will be separated by 2 x Environment.NewLine
Public property | Width | Width of the input document image in pixels (measured after it has been unrotated and deskewed by RotateAndStraighten)
Public property | WordCount | The number of words discovered by IronOcr in this page.
Public property | Words | Objects describing each word found in this scanned page.
Top
Methods
 | Name | Description
Public method | ToString | Return the pages's full Text (Overrides ObjectToString.)
Top
Fields
 | Name | Description
Public field | Barcodes | Objects describing each barcode found in this scanned page.
Public field | Paragraphs | Objects describing each paragraph found in this scanned page.
Top
See Also

Reference

IronOcr Namespace

IronOcr C# OCR Library - (C) 2017 Iron Software


OcrResult.OcrPage Constructor

OcrResultOcrPage Constructor

Initializes a new instance of the OcrResultOcrPage class

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrPage()
Public Sub New
new : unit -> OcrPage
See Also

Reference

OcrResultOcrPage Class


OcrPage Properties

The OcrResultOcrPage type exposes the following members.

Properties
 | Name | Description
Public property | Characters | Objects describing each character found in this scanned page.
Public property | FontName | The name of the most common typeface discovered within this page. If a typeface is unknown, the closest match will be returned.
Public property | FontSize | The most common text size discovered within this page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Public property | Height | Height of the input document image in pixels (measured after it has been unrotated and deskewed by RotateAndStraighten)
Public property | Image | A bitmap image of this page. The image may have been straightened if the original input image was skewed, deformed or had perspective.
Public property | LinesOfText | Objects describing each line of text found in this scanned page.
Public property | PageNumber | The number of this page within an OcrResult. Being 1 based, the first page is numbered 1, rather than zero.
Public property | Text | Full text discovered within this page as a UFT-8 string. Each paragraph of text will be separated by 2 x Environment.NewLine
Public property | Width | Width of the input document image in pixels (measured after it has been unrotated and deskewed by RotateAndStraighten)
Public property | WordCount | The number of words discovered by IronOcr in this page.
Public property | Words | Objects describing each word found in this scanned page.
Top
See Also

Reference

OcrResultOcrPage Class


OcrResult.OcrPage.Characters Property

OcrResultOcrPageCharacters Property

Objects describing each character found in this scanned page.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResultOcrCharacter[] Characters { get; }
Public ReadOnly Property Characters As OcrResultOcrCharacter()
    Get
member Characters : OcrResultOcrCharacter[] with get

Property Value

Type: OcrResultOcrCharacter
See Also

Reference

OcrResultOcrPage Class


OcrResult.OcrPage.FontName Property

OcrResultOcrPageFontName Property

The name of the most common typeface discovered within this page. If a typeface is unknown, the closest match will be returned.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public string FontName { get; }
Public ReadOnly Property FontName As String
    Get
member FontName : string with get

Property Value

Type: String
The name of the font. Null if no text was detected.
See Also

Reference

OcrResultOcrPage Class


OcrResult.OcrPage.FontSize Property

OcrResultOcrPageFontSize Property

The most common text size discovered within this page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public double FontSize { get; }
Public ReadOnly Property FontSize As Double
    Get
member FontSize : float with get

Property Value

Type: Double
The size of the font in px. Zero (0) if no text was detected.
See Also

Reference

OcrResultOcrPage Class


OcrResult.OcrPage.Height Property

OcrResultOcrPageHeight Property

Height of the input document image in pixels (measured after it has been unrotated and deskewed by RotateAndStraighten)

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int Height { get; }
Public ReadOnly Property Height As Integer
    Get
member Height : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrPage Class


OcrResult.OcrPage.Image Property

OcrResultOcrPageImage Property

A bitmap image of this page. The image may have been straightened if the original input image was skewed, deformed or had perspective.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public Bitmap Image { get; }
Public ReadOnly Property Image As Bitmap
    Get
member Image : Bitmap with get

Property Value

Type: Bitmap
See Also

Reference

OcrResultOcrPage Class


OcrResult.OcrPage.LinesOfText Property

OcrResultOcrPageLinesOfText Property

Objects describing each line of text found in this scanned page.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResultOcrLine[] LinesOfText { get; }
Public ReadOnly Property LinesOfText As OcrResultOcrLine()
    Get
member LinesOfText : OcrResultOcrLine[] with get

Property Value

Type: OcrResultOcrLine
See Also

Reference

OcrResultOcrPage Class


OcrResult.OcrPage.PageNumber Property

OcrResultOcrPagePageNumber Property

The number of this page within an OcrResult. Being 1 based, the first page is numbered 1, rather than zero.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int PageNumber { get; }
Public ReadOnly Property PageNumber As Integer
    Get
member PageNumber : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrPage Class


OcrResult.OcrPage.Text Property

OcrResultOcrPageText Property

Full text discovered within this page as a UFT-8 string. Each paragraph of text will be separated by 2 x Environment.NewLine

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get
member Text : string with get

Property Value

Type: String
See Also

Reference

OcrResultOcrPage Class


OcrResult.OcrPage.Width Property

OcrResultOcrPageWidth Property

Width of the input document image in pixels (measured after it has been unrotated and deskewed by RotateAndStraighten)

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int Width { get; }
Public ReadOnly Property Width As Integer
    Get
member Width : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrPage Class


OcrResult.OcrPage.WordCount Property

OcrResultOcrPageWordCount Property

The number of words discovered by IronOcr in this page.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int WordCount { get; }
Public ReadOnly Property WordCount As Integer
    Get
member WordCount : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrPage Class


OcrResult.OcrPage.Words Property

OcrResultOcrPageWords Property

Objects describing each word found in this scanned page.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResultOcrWord[] Words { get; }
Public ReadOnly Property Words As OcrResultOcrWord()
    Get
member Words : OcrResultOcrWord[] with get

Property Value

Type: OcrResultOcrWord
See Also

Reference

OcrResultOcrPage Class


OcrPage Methods

The OcrResultOcrPage type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Return the pages's full Text (Overrides ObjectToString.)
Top
See Also

Reference

OcrResultOcrPage Class


OcrResult.OcrPage.ToString Method

OcrResultOcrPageToString Method

Return the pages's full Text

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

OcrResultOcrPage Class


OcrPage Fields

The OcrResultOcrPage type exposes the following members.

Fields
 | Name | Description
Public field | Barcodes | Objects describing each barcode found in this scanned page.
Public field | Paragraphs | Objects describing each paragraph found in this scanned page.
Top
See Also

Reference

OcrResultOcrPage Class


OcrResult.OcrPage.Barcodes Field

OcrResultOcrPageBarcodes Field
Objects describing each barcode found in this scanned page.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public List<OcrResultOcrBarcode> Barcodes
Public Barcodes As List(Of OcrResultOcrBarcode)
val mutable Barcodes: List<OcrResultOcrBarcode>

Field Value

Type: List OcrResultOcrBarcode
See Also

Reference

OcrResultOcrPage Class


OcrResult.OcrPage.Paragraphs Field

OcrResultOcrPageParagraphs Field
Objects describing each paragraph found in this scanned page.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public List<OcrResultOcrParagraph> Paragraphs
Public Paragraphs As List(Of OcrResultOcrParagraph)
val mutable Paragraphs: List<OcrResultOcrParagraph>

Field Value

Type: List OcrResultOcrParagraph
See Also

Reference

OcrResultOcrPage Class


OcrResult.OcrParagraph Class

OcrResultOcrParagraph Class
An object representing each paragraph of text read by IronOcr
Inheritance Hierarchy
SystemObject
IronOcrOcrResultOcrParagraph

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public class OcrParagraph
Public Class OcrParagraph
type OcrParagraph =  class end

The OcrResultOcrParagraph type exposes the following members.

Constructors
 | Name | Description
Public method | OcrResultOcrParagraph | Initializes a new instance of the OcrResultOcrParagraph class
Top
Properties
 | Name | Description
Public property | FontName | The name of the most common font / typeface in this the paragraph. If the font is unknown, a close visual match will be chosen.
Public property | FontSize | The most common font size for words within the paragraph. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Public property | Height | Height of the paragraph in pixels.
Public property | Image | An image of this word
Public property | OcrObjectId | A unique name for this paragraph of text within the OcrResults model.
Public property | PageNumber | The OcrResult page number this paragraph was found on
Public property | Text | Full text discovered within this paragraph as a UFT-8 string. Each line of text - as read - will be separated by one Environment.NewLine
Public property | Width | Width of the paragraph in pixels.
Public property | WordCount | Number of words in this paragraph
Public property | Words | Objects describing each word in this paragraph.
Public property | X | Horizontal location of the paragraph relative to the left edge of the page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Public property | Y | Vertical location of the paragraph relative to the top edge of the page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Top
Methods
 | Name | Description
Public method | ToString | Return the paragraph's Text (Overrides ObjectToString.)
Top
Fields
 | Name | Description
Public field | Confidence | The percentage statistical confidence IronOcr has in analysis of this paragraph of text. Values range from 0-100. For higher contrast (lower Confidence scores for words which may have been read incorrectly, try setting Strategy = Advanced and looking at the confidence of each individual Word.
Public field | Lines | Objects describing each line of text in this paragraph.
Public field | Location | The location and size of this paragraph as discovered in Image Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Public field | ParagraphNumber | The position of this word within its page
Public field | TextDirection | The direction in which text should be read within this paragraph.
Public field | TextOrientation | The clockwise rotation of this text relative to the top of the page. Measured in degrees. A value of 0 means the text is perfectly vertical.
Top
See Also

Reference

IronOcr Namespace

IronOcr C# OCR Library - (C) 2017 Iron Software


OcrResult.OcrParagraph Constructor

OcrResultOcrParagraph Constructor

Initializes a new instance of the OcrResultOcrParagraph class

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrParagraph()
Public Sub New
new : unit -> OcrParagraph
See Also

Reference

OcrResultOcrParagraph Class


OcrParagraph Properties

The OcrResultOcrParagraph type exposes the following members.

Properties
 | Name | Description
Public property | FontName | The name of the most common font / typeface in this the paragraph. If the font is unknown, a close visual match will be chosen.
Public property | FontSize | The most common font size for words within the paragraph. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Public property | Height | Height of the paragraph in pixels.
Public property | Image | An image of this word
Public property | OcrObjectId | A unique name for this paragraph of text within the OcrResults model.
Public property | PageNumber | The OcrResult page number this paragraph was found on
Public property | Text | Full text discovered within this paragraph as a UFT-8 string. Each line of text - as read - will be separated by one Environment.NewLine
Public property | Width | Width of the paragraph in pixels.
Public property | WordCount | Number of words in this paragraph
Public property | Words | Objects describing each word in this paragraph.
Public property | X | Horizontal location of the paragraph relative to the left edge of the page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Public property | Y | Vertical location of the paragraph relative to the top edge of the page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Top
See Also

Reference

OcrResultOcrParagraph Class


OcrResult.OcrParagraph.FontName Property

OcrResultOcrParagraphFontName Property

The name of the most common font / typeface in this the paragraph. If the font is unknown, a close visual match will be chosen.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public string FontName { get; }
Public ReadOnly Property FontName As String
    Get
member FontName : string with get

Property Value

Type: String
The name of the font. Null is no text was detected
See Also

Reference

OcrResultOcrParagraph Class


OcrResult.OcrParagraph.FontSize Property

OcrResultOcrParagraphFontSize Property

The most common font size for words within the paragraph. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public double FontSize { get; }
Public ReadOnly Property FontSize As Double
    Get
member FontSize : float with get

Property Value

Type: Double
The size of the font in pixels. Zero (0) if no text was detected.
See Also

Reference

OcrResultOcrParagraph Class


OcrResult.OcrParagraph.Height Property

OcrResultOcrParagraphHeight Property

Height of the paragraph in pixels.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int Height { get; }
Public ReadOnly Property Height As Integer
    Get
member Height : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrParagraph Class


OcrResult.OcrParagraph.Image Property

OcrResultOcrParagraphImage Property

An image of this word

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public Bitmap Image { get; }
Public ReadOnly Property Image As Bitmap
    Get
member Image : Bitmap with get

Property Value

Type: Bitmap
See Also

Reference

OcrResultOcrParagraph Class


OcrResult.OcrParagraph.OcrObjectId Property

OcrResultOcrParagraphOcrObjectId Property

A unique name for this paragraph of text within the OcrResults model.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public string OcrObjectId { get; }
Public ReadOnly Property OcrObjectId As String
    Get
member OcrObjectId : string with get

Property Value

Type: String
See Also

Reference

OcrResultOcrParagraph Class


OcrResult.OcrParagraph.PageNumber Property

OcrResultOcrParagraphPageNumber Property

The OcrResult page number this paragraph was found on

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int PageNumber { get; }
Public ReadOnly Property PageNumber As Integer
    Get
member PageNumber : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrParagraph Class


OcrResult.OcrParagraph.Text Property

OcrResultOcrParagraphText Property

Full text discovered within this paragraph as a UFT-8 string. Each line of text - as read - will be separated by one Environment.NewLine

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public string Text { get; }
Public ReadOnly Property Text As String
    Get
member Text : string with get

Property Value

Type: String
See Also

Reference

OcrResultOcrParagraph Class


OcrResult.OcrParagraph.Width Property

OcrResultOcrParagraphWidth Property

Width of the paragraph in pixels.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int Width { get; }
Public ReadOnly Property Width As Integer
    Get
member Width : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrParagraph Class


OcrResult.OcrParagraph.WordCount Property

OcrResultOcrParagraphWordCount Property

Number of words in this paragraph

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int WordCount { get; }
Public ReadOnly Property WordCount As Integer
    Get
member WordCount : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrParagraph Class


OcrResult.OcrParagraph.Words Property

OcrResultOcrParagraphWords Property

Objects describing each word in this paragraph.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResultOcrWord[] Words { get; }
Public ReadOnly Property Words As OcrResultOcrWord()
    Get
member Words : OcrResultOcrWord[] with get

Property Value

Type: OcrResultOcrWord
See Also

Reference

OcrResultOcrParagraph Class


OcrResult.OcrParagraph.X Property

OcrResultOcrParagraphX Property

Horizontal location of the paragraph relative to the left edge of the page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int X { get; }
Public ReadOnly Property X As Integer
    Get
member X : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrParagraph Class


OcrResult.OcrParagraph.Y Property

OcrResultOcrParagraphY Property

Vertical location of the paragraph relative to the top edge of the page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int Y { get; }
Public ReadOnly Property Y As Integer
    Get
member Y : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrParagraph Class


OcrParagraph Methods

The OcrResultOcrParagraph type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Return the paragraph's Text (Overrides ObjectToString.)
Top
See Also

Reference

OcrResultOcrParagraph Class


OcrResult.OcrParagraph.ToString Method

OcrResultOcrParagraphToString Method

Return the paragraph's Text

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

OcrResultOcrParagraph Class


OcrParagraph Fields

The OcrResultOcrParagraph type exposes the following members.

Fields
 | Name | Description
Public field | Confidence | The percentage statistical confidence IronOcr has in analysis of this paragraph of text. Values range from 0-100. For higher contrast (lower Confidence scores for words which may have been read incorrectly, try setting Strategy = Advanced and looking at the confidence of each individual Word.
Public field | Lines | Objects describing each line of text in this paragraph.
Public field | Location | The location and size of this paragraph as discovered in Image Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Public field | ParagraphNumber | The position of this word within its page
Public field | TextDirection | The direction in which text should be read within this paragraph.
Public field | TextOrientation | The clockwise rotation of this text relative to the top of the page. Measured in degrees. A value of 0 means the text is perfectly vertical.
Top
See Also

Reference

OcrResultOcrParagraph Class


OcrResult.OcrParagraph.Confidence Field

OcrResultOcrParagraphConfidence Field
The percentage statistical confidence IronOcr has in analysis of this paragraph of text. Values range from 0-100. For higher contrast (lower Confidence scores for words which may have been read incorrectly, try setting Strategy = Advanced and looking at the confidence of each individual Word.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public double Confidence
Public Confidence As Double
val mutable Confidence: float

Field Value

Type: Double
See Also

Reference

OcrResultOcrParagraph Class


OcrResult.OcrParagraph.Lines Field

OcrResultOcrParagraphLines Field
Objects describing each line of text in this paragraph.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public List<OcrResultOcrLine> Lines
Public Lines As List(Of OcrResultOcrLine)
val mutable Lines: List<OcrResultOcrLine>

Field Value

Type: List OcrResultOcrLine
See Also

Reference

OcrResultOcrParagraph Class


OcrResult.OcrParagraph.Location Field

OcrResultOcrParagraphLocation Field
The location and size of this paragraph as discovered in Image

Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public Rectangle Location
Public Location As Rectangle
val mutable Location: Rectangle

Field Value

Type: Rectangle
See Also

Reference

OcrResultOcrParagraph Class


OcrResult.OcrParagraph.ParagraphNumber Field

OcrResultOcrParagraphParagraphNumber Field
The position of this word within its page

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int ParagraphNumber
Public ParagraphNumber As Integer
val mutable ParagraphNumber: int

Field Value

Type: Int32
See Also

Reference

OcrResultOcrParagraph Class


OcrResult.OcrParagraph.TextDirection Field

OcrResultOcrParagraphTextDirection Field
The direction in which text should be read within this paragraph.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResultTextFlow TextDirection
Public TextDirection As OcrResultTextFlow
val mutable TextDirection: OcrResultTextFlow

Field Value

Type: OcrResultTextFlow
See Also

Reference

OcrResultOcrParagraph Class


OcrResult.OcrParagraph.TextOrientation Field

OcrResultOcrParagraphTextOrientation Field
The clockwise rotation of this text relative to the top of the page. Measured in degrees. A value of 0 means the text is perfectly vertical.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public double TextOrientation
Public TextOrientation As Double
val mutable TextOrientation: float

Field Value

Type: Double
See Also

Reference

OcrResultOcrParagraph Class


OcrResult.OcrWord Class

OcrResultOcrWord Class
An object representing each word read by IronOcr
Inheritance Hierarchy
SystemObject
IronOcrOcrResultOcrWord

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public class OcrWord
Public Class OcrWord
type OcrWord =  class end

The OcrResultOcrWord type exposes the following members.

Constructors
 | Name | Description
Public method | OcrResultOcrWord | Initializes a new instance of the OcrResultOcrWord class
Top
Properties
 | Name | Description
Public property | Height | Height of the word in pixels.
Public property | Image | An image of this word
Public property | OcrObjectId | A unique name for this word within an OcrResult.
Public property | PageNumber | The OcrResult page number this word was found on
Public property | Width | Width of the word in pixels.
Public property | X | Horizontal location of the word relative to the left edge of the page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Public property | Y | Vertical location of the word relative to the top edge of the page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Top
Methods
 | Name | Description
Public method | ToString | Return the word's Text (Overrides ObjectToString.)
Top
Fields
 | Name | Description
Public field | Characters | The individual characters which make up this word
Public field | Confidence | The percentage statistical confidence IronOcr has in analysis of this word. Values range from 0-100. For higher contrast (lower Confidence scores for words which may have been read incorrectly, try setting Strategy = Advanced
Public field | FontIsBold | Word is printed bold.
Public field | FontIsCaligraphic | Word is written in ornate or luminary script
Public field | FontIsFixedWidth | Word's typeface is fixed-width
Public field | FontIsItalic | Word is italic.
Public field | FontIsSerif | Word has serif markings
Public field | FontIsUnderlined | Word is underlined
Public field | FontName | The name of the typeface this word was printed in. If a typeface is unknown, the closest match will be returned.
Public field | FontSize | The height of the typeface letters in this typeface. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Public field | LanguageCode | The natural language which IronOcr believes this word belongs to.
Public field | LineNumber | The line number in which this word was found
Public field | Location | The location and size of this word as discovered in Image Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Public field | ParagraphNumber | The paragraph in which this word was found
Public field | Text | The word as read, rendered as a UTF-8 string with no whitespace.
Public field | TextDirection | The direction in which this word should be read.
Public field | WordNumber | The position of this word within a line of text
Top
See Also

Reference

IronOcr Namespace

IronOcr C# OCR Library - (C) 2017 Iron Software


OcrResult.OcrWord Constructor

OcrResultOcrWord Constructor

Initializes a new instance of the OcrResultOcrWord class

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrWord()
Public Sub New
new : unit -> OcrWord
See Also

Reference

OcrResultOcrWord Class


OcrWord Properties

The OcrResultOcrWord type exposes the following members.

Properties
 | Name | Description
Public property | Height | Height of the word in pixels.
Public property | Image | An image of this word
Public property | OcrObjectId | A unique name for this word within an OcrResult.
Public property | PageNumber | The OcrResult page number this word was found on
Public property | Width | Width of the word in pixels.
Public property | X | Horizontal location of the word relative to the left edge of the page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Public property | Y | Vertical location of the word relative to the top edge of the page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Top
See Also

Reference

OcrResultOcrWord Class


OcrResult.OcrWord.Height Property

OcrResultOcrWordHeight Property

Height of the word in pixels.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int Height { get; }
Public ReadOnly Property Height As Integer
    Get
member Height : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrWord Class


OcrResult.OcrWord.Image Property

OcrResultOcrWordImage Property

An image of this word

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public Bitmap Image { get; }
Public ReadOnly Property Image As Bitmap
    Get
member Image : Bitmap with get

Property Value

Type: Bitmap
See Also

Reference

OcrResultOcrWord Class


OcrResult.OcrWord.OcrObjectId Property

OcrResultOcrWordOcrObjectId Property

A unique name for this word within an OcrResult.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public string OcrObjectId { get; }
Public ReadOnly Property OcrObjectId As String
    Get
member OcrObjectId : string with get

Property Value

Type: String
See Also

Reference

OcrResultOcrWord Class


OcrResult.OcrWord.PageNumber Property

OcrResultOcrWordPageNumber Property

The OcrResult page number this word was found on

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int PageNumber { get; }
Public ReadOnly Property PageNumber As Integer
    Get
member PageNumber : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrWord Class


OcrResult.OcrWord.Width Property

OcrResultOcrWordWidth Property

Width of the word in pixels.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int Width { get; }
Public ReadOnly Property Width As Integer
    Get
member Width : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrWord Class


OcrResult.OcrWord.X Property

OcrResultOcrWordX Property

Horizontal location of the word relative to the left edge of the page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int X { get; }
Public ReadOnly Property X As Integer
    Get
member X : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrWord Class


OcrResult.OcrWord.Y Property

OcrResultOcrWordY Property

Vertical location of the word relative to the top edge of the page. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int Y { get; }
Public ReadOnly Property Y As Integer
    Get
member Y : int with get

Property Value

Type: Int32
See Also

Reference

OcrResultOcrWord Class


OcrWord Methods

The OcrResultOcrWord type exposes the following members.

Methods
 | Name | Description
Public method | ToString | Return the word's Text (Overrides ObjectToString.)
Top
See Also

Reference

OcrResultOcrWord Class


OcrResult.OcrWord.ToString Method

OcrResultOcrWordToString Method

Return the word's Text

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

OcrResultOcrWord Class


OcrWord Fields

The OcrResultOcrWord type exposes the following members.

Fields
 | Name | Description
Public field | Characters | The individual characters which make up this word
Public field | Confidence | The percentage statistical confidence IronOcr has in analysis of this word. Values range from 0-100. For higher contrast (lower Confidence scores for words which may have been read incorrectly, try setting Strategy = Advanced
Public field | FontIsBold | Word is printed bold.
Public field | FontIsCaligraphic | Word is written in ornate or luminary script
Public field | FontIsFixedWidth | Word's typeface is fixed-width
Public field | FontIsItalic | Word is italic.
Public field | FontIsSerif | Word has serif markings
Public field | FontIsUnderlined | Word is underlined
Public field | FontName | The name of the typeface this word was printed in. If a typeface is unknown, the closest match will be returned.
Public field | FontSize | The height of the typeface letters in this typeface. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Public field | LanguageCode | The natural language which IronOcr believes this word belongs to.
Public field | LineNumber | The line number in which this word was found
Public field | Location | The location and size of this word as discovered in Image Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).
Public field | ParagraphNumber | The paragraph in which this word was found
Public field | Text | The word as read, rendered as a UTF-8 string with no whitespace.
Public field | TextDirection | The direction in which this word should be read.
Public field | WordNumber | The position of this word within a line of text
Top
See Also

Reference

OcrResultOcrWord Class


OcrResult.OcrWord.Characters Field

OcrResultOcrWordCharacters Field
The individual characters which make up this word

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public List<OcrResultOcrCharacter> Characters
Public Characters As List(Of OcrResultOcrCharacter)
val mutable Characters: List<OcrResultOcrCharacter>

Field Value

Type: List OcrResultOcrCharacter
See Also

Reference

OcrResultOcrWord Class


OcrResult.OcrWord.Confidence Field

OcrResultOcrWordConfidence Field
The percentage statistical confidence IronOcr has in analysis of this word. Values range from 0-100. For higher contrast (lower Confidence scores for words which may have been read incorrectly, try setting Strategy = Advanced

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public double Confidence
Public Confidence As Double
val mutable Confidence: float

Field Value

Type: Double
See Also

Reference

OcrResultOcrWord Class


OcrResult.OcrWord.FontIsBold Field

OcrResultOcrWordFontIsBold Field
Word is printed bold.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public bool FontIsBold
Public FontIsBold As Boolean
val mutable FontIsBold: bool

Field Value

Type: Boolean
See Also

Reference

OcrResultOcrWord Class


OcrResult.OcrWord.FontIsCaligraphic Field

OcrResultOcrWordFontIsCaligraphic Field
Word is written in ornate or luminary script

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public bool FontIsCaligraphic
Public FontIsCaligraphic As Boolean
val mutable FontIsCaligraphic: bool

Field Value

Type: Boolean
See Also

Reference

OcrResultOcrWord Class


OcrResult.OcrWord.FontIsFixedWidth Field

OcrResultOcrWordFontIsFixedWidth Field
Word's typeface is fixed-width

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public bool FontIsFixedWidth
Public FontIsFixedWidth As Boolean
val mutable FontIsFixedWidth: bool

Field Value

Type: Boolean
See Also

Reference

OcrResultOcrWord Class


OcrResult.OcrWord.FontIsItalic Field

OcrResultOcrWordFontIsItalic Field
Word is italic.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public bool FontIsItalic
Public FontIsItalic As Boolean
val mutable FontIsItalic: bool

Field Value

Type: Boolean
See Also

Reference

OcrResultOcrWord Class


OcrResult.OcrWord.FontIsSerif Field

OcrResultOcrWordFontIsSerif Field
Word has serif markings

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public bool FontIsSerif
Public FontIsSerif As Boolean
val mutable FontIsSerif: bool

Field Value

Type: Boolean
See Also

Reference

OcrResultOcrWord Class


OcrResult.OcrWord.FontIsUnderlined Field

OcrResultOcrWordFontIsUnderlined Field
Word is underlined

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public bool FontIsUnderlined
Public FontIsUnderlined As Boolean
val mutable FontIsUnderlined: bool

Field Value

Type: Boolean
See Also

Reference

OcrResultOcrWord Class


OcrResult.OcrWord.FontName Field

OcrResultOcrWordFontName Field
The name of the typeface this word was printed in. If a typeface is unknown, the closest match will be returned.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public string FontName
Public FontName As String
val mutable FontName: string

Field Value

Type: String
See Also

Reference

OcrResultOcrWord Class


OcrResult.OcrWord.FontSize Field

OcrResultOcrWordFontSize Field
The height of the typeface letters in this typeface. Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public double FontSize
Public FontSize As Double
val mutable FontSize: float

Field Value

Type: Double
See Also

Reference

OcrResultOcrWord Class


OcrResult.OcrWord.LanguageCode Field

OcrResultOcrWordLanguageCode Field
The natural language which IronOcr believes this word belongs to.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public string LanguageCode
Public LanguageCode As String
val mutable LanguageCode: string

Field Value

Type: String
See Also

Reference

OcrResultOcrWord Class


OcrResult.OcrWord.LineNumber Field

OcrResultOcrWordLineNumber Field
The line number in which this word was found

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int LineNumber
Public LineNumber As Integer
val mutable LineNumber: int

Field Value

Type: Int32
See Also

Reference

OcrResultOcrWord Class


OcrResult.OcrWord.Location Field

OcrResultOcrWordLocation Field
The location and size of this word as discovered in Image

Measured in pixels on the current OcrPage.Image (which may differ from the source image if it has been deskewed, upscaled or rotated for OCR processing).

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public Rectangle Location
Public Location As Rectangle
val mutable Location: Rectangle

Field Value

Type: Rectangle
See Also

Reference

OcrResultOcrWord Class


OcrResult.OcrWord.ParagraphNumber Field

OcrResultOcrWordParagraphNumber Field
The paragraph in which this word was found

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int ParagraphNumber
Public ParagraphNumber As Integer
val mutable ParagraphNumber: int

Field Value

Type: Int32
See Also

Reference

OcrResultOcrWord Class


OcrResult.OcrWord.Text Field

OcrResultOcrWordText Field
The word as read, rendered as a UTF-8 string with no whitespace.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public string Text
Public Text As String
val mutable Text: string

Field Value

Type: String
See Also

Reference

OcrResultOcrWord Class


OcrResult.OcrWord.TextDirection Field

OcrResultOcrWordTextDirection Field
The direction in which this word should be read.

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public OcrResultTextFlow TextDirection
Public TextDirection As OcrResultTextFlow
val mutable TextDirection: OcrResultTextFlow

Field Value

Type: OcrResultTextFlow
See Also

Reference

OcrResultOcrWord Class


OcrResult.OcrWord.WordNumber Field

OcrResultOcrWordWordNumber Field
The position of this word within a line of text

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public int WordNumber
Public WordNumber As Integer
val mutable WordNumber: int

Field Value

Type: Int32
See Also

Reference

OcrResultOcrWord Class


OcrResult.TextFlow Enumeration

OcrResultTextFlow Enumeration
The direction in which OCR text should be read. For Example English text is read "LeftToRight"

Namespace: IronOcr
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public enum TextFlow
Public Enumeration TextFlow
type TextFlow
Members
Member name | Value | Description
LeftToRight | 1 | Text is read horizontally, left to right
RightToLeft | 2 | Text is read horizontally, right to left
TopToBottom | 3 | Text is read vertically, top to bottom (downwards in columns)
BottomToTop | 4 | Text is read vertically, bottom to top (upwards in columns)
See Also

Reference

IronOcr Namespace

IronOcr C# OCR Library - (C) 2017 Iron Software


IronOcr.Languages Namespace
Classes
 | Class | Description
Public class | English | English Language Pack. Installed by default with IronOcr. Get more language packs on Nuget or by downloading DLLs from http://ironsoftware.com/csharp/ocr/
Public class | IOcrLanguagePack | Abstract class defining IronOcr language packs. English is installed by default. Additional Language packs may be added to your project via Nuget or by downloading DLLs from http://ironsoftware.com/csharp/ocr/
Public class | MultiLanguage |


English Class
English Language Pack. Installed by default with IronOcr.

Get more language packs on Nuget or by downloading DLLs from http://ironsoftware.com/csharp/ocr/

Inheritance Hierarchy
SystemObject
IronOcr.LanguagesIOcrLanguagePack
IronOcr.LanguagesEnglish

Namespace: IronOcr.Languages
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public class English : IOcrLanguagePack
Public Class English
    Inherits IOcrLanguagePack
type English =
    class
        inherit IOcrLanguagePack
    end

The English type exposes the following members.

Properties
Name | Description
OcrLanguagePack |
Top
See Also

Reference

IronOcr.Languages Namespace


English Properties

The English type exposes the following members.

Properties
Name | Description
OcrLanguagePack |
Top
See Also

Reference

English Class
IronOcr.Languages Namespace


English.OcrLanguagePack Property

EnglishOcrLanguagePack Property

Namespace: IronOcr.Languages
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public static IOcrLanguagePack OcrLanguagePack { get; }
Public Shared ReadOnly Property OcrLanguagePack As IOcrLanguagePack
    Get
static member OcrLanguagePack : IOcrLanguagePack with get

Property Value

Type: IOcrLanguagePack
See Also

Reference

English Class
IronOcr.Languages Namespace


IOcrLanguagePack Class
Abstract class defining IronOcr language packs.

English is installed by default. Additional Language packs may be added to your project via Nuget or by downloading DLLs from http://ironsoftware.com/csharp/ocr/

Inheritance Hierarchy
SystemObject
IronOcr.LanguagesIOcrLanguagePack
IronOcr.LanguagesEnglish
IronOcr.LanguagesMultiLanguage

Namespace: IronOcr.Languages
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public abstract class IOcrLanguagePack
Public MustInherit Class IOcrLanguagePack
[<AbstractClassAttribute>]
type IOcrLanguagePack =  class end
See Also

Reference

IronOcr.Languages Namespace


MultiLanguage Class
Inheritance Hierarchy
SystemObject
IronOcr.LanguagesIOcrLanguagePack
IronOcr.LanguagesMultiLanguage

Namespace: IronOcr.Languages
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public class MultiLanguage : IOcrLanguagePack
Public Class MultiLanguage
    Inherits IOcrLanguagePack
type MultiLanguage =
    class
        inherit IOcrLanguagePack
    end

The MultiLanguage type exposes the following members.

Constructors
Name | Description
MultiLanguage | Initializes a new instance of the MultiLanguage language pack class.
Top
Methods
Name | Description
OcrLanguagePack | Returns a composite language pack allowing IronOcr to read documents in more than once language at the same time.
Top
See Also

Reference

IronOcr.Languages Namespace


MultiLanguage Constructor

Initializes a new instance of the MultiLanguage language pack class.

Namespace: IronOcr.Languages
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public MultiLanguage(
    params IOcrLanguagePack[] Languages
)
Public Sub New (
    ParamArray Languages As IOcrLanguagePack()
)
new :
        Languages : IOcrLanguagePack[] -> MultiLanguage

Parameters

Languages
Type: IronOcr.LanguagesIOcrLanguagePack
Any number of Languages as instances of IOcrLanguagePack
Examples
var Ocr = new IronOcr.AdvancedOcr()
                        {
                            Language =  IronOcr.Languages.MultiLanguage.OcrLanguagePack(IronOcr.Languages.English.OcrLanguagePack, IronOcr.Languages.German.OcrLanguagePack)
                        };
See Also

Reference

MultiLanguage Class
IronOcr.Languages Namespace


MultiLanguage Methods

The MultiLanguage type exposes the following members.

Methods
Name | Description
OcrLanguagePack | Returns a composite language pack allowing IronOcr to read documents in more than once language at the same time.
Top
See Also

Reference

MultiLanguage Class
IronOcr.Languages Namespace


MultiLanguage.OcrLanguagePack Method

MultiLanguageOcrLanguagePack Method

Returns a composite language pack allowing IronOcr to read documents in more than once language at the same time.

Namespace: IronOcr.Languages
Assembly: IronOcr (in IronOcr.dll) Version: 4.4.0.21181 (4.4.0.0)
Syntax
C#
VB
F#
Copy
public static IOcrLanguagePack OcrLanguagePack(
    params IOcrLanguagePack[] Languages
)
Public Shared Function OcrLanguagePack (
    ParamArray Languages As IOcrLanguagePack()
) As IOcrLanguagePack
static member OcrLanguagePack :
        Languages : IOcrLanguagePack[] -> IOcrLanguagePack

Parameters

Languages
Type: IronOcr.LanguagesIOcrLanguagePack
Any number of Languages as instances of IOcrLanguagePack

Return Value

Type: IOcrLanguagePack
Examples
var Ocr = new IronOcr.AdvancedOcr()
                       {
                           Language = IronOcr.Languages.MultiLanguage.OcrLanguagePack(IronOcr.Languages.English.OcrLanguagePack, IronOcr.Languages.German.OcrLanguagePack)
                       };
See Also

Reference

MultiLanguage Class
IronOcr.Languages Namespace