IronPdf Namespace

IronPDF is a .NET library allowing the generation and manipulation of PDF files in C# and other .Net projects. Supports .Net 4.0 and above , .Net Standard 2.x and .Net Core 2 & 3
Classes
 | Class | Description
Public class | AspxToPdf | Renders any .Net Web Page (ASPX) into a PDF Document. Simply add it to the Page_Load event. Not available in .Net Core because ASPX is superseded by the MVC model
Public class | HtmlHeaderFooter | A Html Header or Footer which will be printed onto every page of the PDF. This can be used to override Header and Footer When using HtmlHeaderFooter it is important to set HtmlFragment and Height Merge meta-data into your html using any of these placeholder strings: {page} {total-pages} {url} {date} {time} {html-title} {pdf-title}
Public class | HtmlStamp | Class HtmlStamp. Used With the StampHTML(HtmlStamp) methods to edit PDF documents by 'stamping' additional content into the foreground or background.
Public class | HtmlToPdf | IronPdf.HtmlToPdf allows any web page or Html 'snippet' to be turned into a PDF document.
Public class | HttpLoginCredentials | Provides credentials for IronPdf to log-in to an intranet, extranet or website, impersonating a user. This allows a unique ability to render web-pages as PDFs even on secure intranets, extranets and websites.
Public class | ImageToPdfConverter | The ImageToPdfConveter class can be used to create PDF documents from images. It accepts both image files and Image objects as input. The ImageToPdf static methods create simple PDF documents containing each image as one page of the created PDF. To rasterize PDF documents as images (the reverse operation), see ToBitmap(Int32) and RasterizeToImageFiles(String, ImageType, Int32)
Public class | Installation | Global installation and setup preferences for all instances of IronPDF
Public class | License | Allows IronPdf license keys to be applied globally across an application.
Public class | PdfBookMark | Represents a PDF bookmark as seen in the sidebar of PDF reader software to help user's navigate.
Public class | PdfDocument | A PDF Document
Public class | PdfDocumentPdfCustomMetadataProperties | Class that represents set of custom metadata properties
Public class | PdfDocumentPdfMetaData | A class defining PDF file meta-data. Allows File meta-data to be read and set including: Authors, File Dates, Keywords, Title and Subject Implemented in MetaData.
Public class | PdfDocumentPdfSecuritySettings | A class defining user security settings for a PDF document. Allows the developer to control user access passwords, encryption, and also who may edit, print and copy content from the PDF document Implemented in SecuritySettings.
Public class | PdfDocumentTextAnnotation | Defines a Sticky-Note style PDF annotation.
Public class | PdfOutline | A editable collection of PDF navigational bookmark objects.
Public class | PdfPage | Class that represents pdf page.
Public class | PdfPagesCollection | Class for managing the collection of PdfPage elements.
Public class | PdfPrintOptions | PDF output options for IronPdf. Specifies options such as Paper-Size, DPI, Headers and Footers.
Public class | PdfSignature | A class that represents a PDF signing certificate (.PFX or .p12) format which can be used to digitally sign a PDF. This protecting it from alteration. Not implemented in .Net Core
Public class | SimpleHeaderFooter | Defines PDF Header and Footer display options.
Public class | TempFolder | Provides operations over the temporary folder
Public class | Util | Useful methods for working with HTML and PDF files.
Enumerations
 | Enumeration | Description
Public enumeration | AspxToPdfFileBehavior | Determines the web browser behavior towards a PDF document.
Public enumeration | HtmlStampStampLayer | Defines if a stamp should be placed behind or on-top of existing PDF contents.
Public enumeration | ImageType | An Image File Type Enumeration used to select image file formats when converting PDF documents to images. Also see: RasterizeToImageFiles(String, ImageType, Int32)
Public enumeration | PageOrientation | Specifies the orientation of a page.
Public enumeration | PdfDocumentPdfSecuritySettingsPdfEditSecurity | Enumeration defining levels of PDF user access rights to edit a PDF. Edit rights may also be limited by the User's PDF document client software. See AllowUserEdits
Public enumeration | PdfDocumentPdfSecuritySettingsPdfPrintSecrity | Enumeration defining levels of PDF user access rights to print a PDF. See AllowUserPrinting
Public enumeration | PdfDocumentTextAnnotationAnnotationIcon | Icons used to interact with (open/close) the annotation with the PDF page.
Public enumeration | PdfDocumentWaterMarkLocation | Location for a simple watermark to be applied to a PDF page.
Public enumeration | PdfPrintOptionsPdfCssMediaType | Defines which style-sheet should be rendered. 'Print' or 'Screen'. This matches the CSS3 Media Queries standard.
Public enumeration | PdfPrintOptionsPdfPaperOrientation | Paper Orientation
Public enumeration | PdfPrintOptionsPdfPaperSize | Defines the target paper size the PDF will use of pagination. Relates to real-world paper-sizes.
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


AspxToPdf Class

Renders any .Net Web Page (ASPX) into a PDF Document. Simply add it to the Page_Load event.

Not available in .Net Core because ASPX is superseded by the MVC model

Inheritance Hierarchy
SystemObject
IronPdfAspxToPdf

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public static class AspxToPdf
Public NotInheritable Class AspxToPdf
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AspxToPdf =  class end

The AspxToPdf type exposes the following members.

Methods
Name Description
RenderThisPageAsPdf
Automatically renders any ASPX page into PDF instead of Html. Use it in the Page_Load Event.

Example:

Copy
protected void Page_Load(object sender, EventArgs e){
                   IronPdf.AspxToPdf.RenderThisPageAsPdf(FileBehavior.Attachment, "MyPdf.pdf", new  PdfPrintOptions(){ Dpi = 300 });
                 }
Top
See Also

Reference

IronPdf Namespace


AspxToPdf Methods

The AspxToPdf type exposes the following members.

Methods
Name Description
RenderThisPageAsPdf
Automatically renders any ASPX page into PDF instead of Html. Use it in the Page_Load Event.

Example:

Copy
protected void Page_Load(object sender, EventArgs e){
                   IronPdf.AspxToPdf.RenderThisPageAsPdf(FileBehavior.Attachment, "MyPdf.pdf", new  PdfPrintOptions(){ Dpi = 300 });
                 }
Top
See Also

Reference

AspxToPdf Class


AspxToPdf.RenderThisPageAsPdf Method

IronPdf - The C# PDF Library

AspxToPdfRenderThisPageAsPdf Method

Automatically renders any ASPX page into PDF instead of Html. Use it in the Page_Load Event.

Example:

Copy
protected void Page_Load(object sender, EventArgs e){
                   IronPdf.AspxToPdf.RenderThisPageAsPdf(FileBehavior.Attachment, "MyPdf.pdf", new  PdfPrintOptions(){ Dpi = 300 });
                 }

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public static void RenderThisPageAsPdf(
    AspxToPdfFileBehavior PdfBehavior = AspxToPdfFileBehavior.InBrowser,
    string PdfFileName = null,
    PdfPrintOptions PrintOptions = null
)
Public Shared Sub RenderThisPageAsPdf (
    Optional PdfBehavior As AspxToPdfFileBehavior = AspxToPdfFileBehavior.InBrowser,
    Optional PdfFileName As String = Nothing,
    Optional PrintOptions As PdfPrintOptions = Nothing
)
static member RenderThisPageAsPdf :
        ?PdfBehavior : AspxToPdfFileBehavior *
        ?PdfFileName : string *
        ?PrintOptions : PdfPrintOptions
(* Defaults:
        let _PdfBehavior = defaultArg PdfBehavior AspxToPdfFileBehavior.InBrowser
        let _PdfFileName = defaultArg PdfFileName null
        let _PrintOptions = defaultArg PrintOptions null
*)
-> unit

Parameters

PdfBehavior (Optional)
Type: IronPdfAspxToPdfFileBehavior
Specifies if the PDF file should be downloaded as an attachment, or displayed directly in the browser of users.
PdfFileName (Optional)
Type: SystemString
The file-name of the PDF. If no name is set, a suitable name will be automatically assigned chosen based on the Html title, PrintOptions or name of the ASPX page.
PrintOptions (Optional)
Type: IronPdfPdfPrintOptions
Sets PDF output options such as PDF Title, paper-size, DPI, headers and footers.
See Also

Reference

AspxToPdf Class


AspxToPdf.FileBehavior Enumeration

AspxToPdfFileBehavior Enumeration

Determines the web browser behavior towards a PDF document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public enum FileBehavior
Public Enumeration FileBehavior
type FileBehavior
Members
Member name | Value | Description
Attachment | 0 | Instructs the user's web-browser to download the PDF as a file.
InBrowser | 1 | Instructs the user's web-browser to render the PDF wherever possible.
See Also

Reference

IronPdf Namespace
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


HtmlHeaderFooter Class

A Html Header or Footer which will be printed onto every page of the PDF. This can be used to override Header and Footer

When using HtmlHeaderFooter it is important to set HtmlFragment and Height

Merge meta-data into your html using any of these placeholder strings: {page} {total-pages} {url} {date} {time} {html-title} {pdf-title}

Inheritance Hierarchy
SystemObject
IronPdfSimpleHeaderFooter
IronPdfHtmlHeaderFooter

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public class HtmlHeaderFooter : SimpleHeaderFooter
Public Class HtmlHeaderFooter
    Inherits SimpleHeaderFooter
type HtmlHeaderFooter =
    class
        inherit SimpleHeaderFooter
    end

The HtmlHeaderFooter type exposes the following members.

Constructors
 | Name | Description
Public method | HtmlHeaderFooter | Initializes a new instance of the HtmlHeaderFooter class
Top
Methods
 | Name | Description
Public method | Clone | Clones this instance.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | BaseUrl | The Base URL all URLS in the HtmlFragment will be relative to. This includes 'src' attributes on images, scripts, style-sheets and also hrefs on hyper-links. Note: A base URL that points to a directory should end with a slash. Base URL accepts file paths as well as URLS. If no BaseUrl is given, the HtmlHeaderFooter BaseUrl will be inherited from the main HTML document where possible.
Public field | CenterText | Sets the centered header text for the PDF document. Merge meta-data into your header using any of these placeholder strings: {page} {total-pages} {url} {date} {time} {html-title} {pdf-title} (Inherited from SimpleHeaderFooter.)
Public field | DrawDividerLine | Adds a horizontal line divider between the header / footer and the page content on every page of the PDF document. (Inherited from SimpleHeaderFooter.)
Public field | FontFamily | Font used to render the PDF header. (Inherited from SimpleHeaderFooter.)
Public field | FontSize | Font size in px. (Inherited from SimpleHeaderFooter.)
Public field | Height | Height of the Html Header / Footer in millimeters. This value must be set sufficiently high to display the full html header / footer content.
Public field | HtmlFragment | The Html which will be use to render the Header / Footer. Should be an HTML snippet rather than a complete document. May contain styles & images. Merge meta-data into the HtmlFragment by putting any of these placeholder strings into the text: {page} {total-pages} {url} {date} {time} {html-title} {pdf-title}. An alternative mail-merge style using the pattern <span class='total-pages'></span> also workd HtmlFragment is a stand alone HTML document which does not inherit styles or settings from your main HTML content unless LoadStylesAndCSSFromMainHtmlDocument is set true
Public field | LeftText | Sets the left hand side header text for the PDF document. Merge meta-data into your header using any of these placeholder strings: {page} {total-pages} {url} {date} {time} {html-title} {pdf-title} (Inherited from SimpleHeaderFooter.)
Public field | LoadStylesAndCSSFromMainHtmlDocument | Loads style code blocks and links to CSS style sheets from the main HTML document (which provides the PDF content) into the HtmlHeaderFooter . By default, Html Headers and Footers are stand-alone HTML documents with their own default styles. Setting LoadStylesAndCSSFromMainHtmlDocument to true will attempt to load all STYLE and LINK tags from the main HTML document (which renders teh PDF) into the HtmlHeaderFooter. If your main HTML document contains complex CSS frameworks, styles the HEAD or BODY element heavily or loads CSS from javascript then this method may not work as intended. This feature is not available for RenderUrlAsPdf(String) and other RenderUrlAsPdf methods. It works for HTMLToPdf and HtmlFileToPdf conversions only. It is often preferable to load style sheets explicitly into your HTML Headers and Footers as STYLE and LINK tags within the HtmlFragment for granular control
Public field | RightText | Sets the right hand side header text for the PDF document. Merge meta-data into your header using any of these placeholder strings: {page} {total-pages} {url} {date} {time} {html-title} {pdf-title} (Inherited from SimpleHeaderFooter.)
Public field | Spacing | Space between the header and page content in millimeters. (Inherited from SimpleHeaderFooter.)
Top
See Also

Reference

IronPdf Namespace
PdfPrintOptionsHeader
PdfPrintOptionsFooter


HtmlHeaderFooter Constructor

Initializes a new instance of the HtmlHeaderFooter class

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public HtmlHeaderFooter()
Public Sub New
new : unit -> HtmlHeaderFooter
See Also

Reference

HtmlHeaderFooter Class


HtmlHeaderFooter Methods

The HtmlHeaderFooter type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clones this instance.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

HtmlHeaderFooter Class


HtmlHeaderFooter.Clone Method

HtmlHeaderFooterClone Method

Clones this instance.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public Object Clone()
Public Function Clone As Object
member Clone : unit -> Object

Return Value

Type: Object
System.Object of type HtmlHeaderFooter
See Also

Reference

HtmlHeaderFooter Class


HtmlHeaderFooter Fields

The HtmlHeaderFooter type exposes the following members.

Fields
 | Name | Description
Public field | BaseUrl | The Base URL all URLS in the HtmlFragment will be relative to. This includes 'src' attributes on images, scripts, style-sheets and also hrefs on hyper-links. Note: A base URL that points to a directory should end with a slash. Base URL accepts file paths as well as URLS. If no BaseUrl is given, the HtmlHeaderFooter BaseUrl will be inherited from the main HTML document where possible.
Public field | CenterText | Sets the centered header text for the PDF document. Merge meta-data into your header using any of these placeholder strings: {page} {total-pages} {url} {date} {time} {html-title} {pdf-title} (Inherited from SimpleHeaderFooter.)
Public field | DrawDividerLine | Adds a horizontal line divider between the header / footer and the page content on every page of the PDF document. (Inherited from SimpleHeaderFooter.)
Public field | FontFamily | Font used to render the PDF header. (Inherited from SimpleHeaderFooter.)
Public field | FontSize | Font size in px. (Inherited from SimpleHeaderFooter.)
Public field | Height | Height of the Html Header / Footer in millimeters. This value must be set sufficiently high to display the full html header / footer content.
Public field | HtmlFragment | The Html which will be use to render the Header / Footer. Should be an HTML snippet rather than a complete document. May contain styles & images. Merge meta-data into the HtmlFragment by putting any of these placeholder strings into the text: {page} {total-pages} {url} {date} {time} {html-title} {pdf-title}. An alternative mail-merge style using the pattern <span class='total-pages'></span> also workd HtmlFragment is a stand alone HTML document which does not inherit styles or settings from your main HTML content unless LoadStylesAndCSSFromMainHtmlDocument is set true
Public field | LeftText | Sets the left hand side header text for the PDF document. Merge meta-data into your header using any of these placeholder strings: {page} {total-pages} {url} {date} {time} {html-title} {pdf-title} (Inherited from SimpleHeaderFooter.)
Public field | LoadStylesAndCSSFromMainHtmlDocument | Loads style code blocks and links to CSS style sheets from the main HTML document (which provides the PDF content) into the HtmlHeaderFooter . By default, Html Headers and Footers are stand-alone HTML documents with their own default styles. Setting LoadStylesAndCSSFromMainHtmlDocument to true will attempt to load all STYLE and LINK tags from the main HTML document (which renders teh PDF) into the HtmlHeaderFooter. If your main HTML document contains complex CSS frameworks, styles the HEAD or BODY element heavily or loads CSS from javascript then this method may not work as intended. This feature is not available for RenderUrlAsPdf(String) and other RenderUrlAsPdf methods. It works for HTMLToPdf and HtmlFileToPdf conversions only. It is often preferable to load style sheets explicitly into your HTML Headers and Footers as STYLE and LINK tags within the HtmlFragment for granular control
Public field | RightText | Sets the right hand side header text for the PDF document. Merge meta-data into your header using any of these placeholder strings: {page} {total-pages} {url} {date} {time} {html-title} {pdf-title} (Inherited from SimpleHeaderFooter.)
Public field | Spacing | Space between the header and page content in millimeters. (Inherited from SimpleHeaderFooter.)
Top
See Also

Reference

HtmlHeaderFooter Class


HtmlHeaderFooter.BaseUrl Field

HtmlHeaderFooterBaseUrl Field

The Base URL all URLS in the HtmlFragment will be relative to. This includes 'src' attributes on images, scripts, style-sheets and also hrefs on hyper-links.

Note: A base URL that points to a directory should end with a slash.

Base URL accepts file paths as well as URLS. If no BaseUrl is given, the HtmlHeaderFooter BaseUrl will be inherited from the main HTML document where possible.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string BaseUrl
Public BaseUrl As String
val mutable BaseUrl: string

Field Value

Type: String
See Also

Reference

HtmlHeaderFooter Class


HtmlHeaderFooter.Height Field

HtmlHeaderFooterHeight Field

Height of the Html Header / Footer in millimeters. This value must be set sufficiently high to display the full html header / footer content.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public int Height
Public Height As Integer
val mutable Height: int

Field Value

Type: Int32
See Also

Reference

HtmlHeaderFooter Class


HtmlHeaderFooter.HtmlFragment Field

HtmlHeaderFooterHtmlFragment Field

The Html which will be use to render the Header / Footer. Should be an HTML snippet rather than a complete document. May contain styles & images.

Merge meta-data into the HtmlFragment by putting any of these placeholder strings into the text: {page} {total-pages} {url} {date} {time} {html-title} {pdf-title}. An alternative mail-merge style using the pattern <span class='total-pages'></span> also workd

HtmlFragment is a stand alone HTML document which does not inherit styles or settings from your main HTML content unless LoadStylesAndCSSFromMainHtmlDocument is set true

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string HtmlFragment
Public HtmlFragment As String
val mutable HtmlFragment: string

Field Value

Type: String
See Also

Reference

HtmlHeaderFooter Class


HtmlHeaderFooter.LoadStylesAndCSSFromMainHtmlDocument Field

HtmlHeaderFooterLoadStylesAndCSSFromMainHtmlDocument Field

Loads style code blocks and links to CSS style sheets from the main HTML document (which provides the PDF content) into the HtmlHeaderFooter .

By default, Html Headers and Footers are stand-alone HTML documents with their own default styles. Setting LoadStylesAndCSSFromMainHtmlDocument to true will attempt to load all STYLE and LINK tags from the main HTML document (which renders teh PDF) into the HtmlHeaderFooter.

If your main HTML document contains complex CSS frameworks, styles the HEAD or BODY element heavily or loads CSS from javascript then this method may not work as intended.

This feature is not available for RenderUrlAsPdf(String) and other RenderUrlAsPdf methods. It works for HTMLToPdf and HtmlFileToPdf conversions only.

It is often preferable to load style sheets explicitly into your HTML Headers and Footers as STYLE and LINK tags within the HtmlFragment for granular control

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public bool LoadStylesAndCSSFromMainHtmlDocument
Public LoadStylesAndCSSFromMainHtmlDocument As Boolean
val mutable LoadStylesAndCSSFromMainHtmlDocument: bool

Field Value

Type: Boolean
See Also

Reference

HtmlHeaderFooter Class


HtmlStamp Class

Class HtmlStamp. Used With the StampHTML(HtmlStamp) methods to edit PDF documents by 'stamping' additional content into the foreground or background.
Inheritance Hierarchy
SystemObject
IronPdfHtmlStamp

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public class HtmlStamp
Public Class HtmlStamp
type HtmlStamp =  class end

The HtmlStamp type exposes the following members.

Constructors
 | Name | Description
Public method | HtmlStamp | Initializes a new instance of the HtmlStamp class.
Public method | HtmlStamp(String) | Initializes a new instance of the HtmlStamp class.
Public method | HtmlStamp(String, Int32, Int32) | Initializes a new instance of the HtmlStamp class.
Top
Properties
 | Name | Description
Public property | Bottom | The position of the stamp from the Bottom edge of the PDF document in mm. If Top or Bottom is not set, the stamp will be vertically centered in the document.
Public property | Height | The height of the stamp in mm. Stamps can not automatically detect their own size based on their content.
Public property | Left | The position of the stamp from the Left of the PDF document in mm. If Left or Right is not set, the stamp will be horizontally centered in the document.
Public property | Right | The position of the stamp from the Right of the PDF document in mm. If Left or Right is not set, the stamp will be horizontally centered in the document.
Public property | Top | The position of the stamp from the Top edge of the PDF document in mm. If Top or Bottom is not set, the stamp will be vertically centered in the document.
Public property | Width | The width of the stamp in mm. Stamps can not automatically detect their own size based on their content.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
Name Description
Public field AutoCenterStampContentOnStampCanvas
The automatic centers stamp content within stamp canvas as defined by Width and Height.
Public field Html
The HTML fragment which will be stamped onto your PDF. All external references to javascript, CSS and image files will be relative to HtmlBaseUrl.
Public field HtmlBaseUrl
The HTML base URL for which references to external CSS, Javascript and Image files will be relative.

A trick to make references relative to a your project file is

Copy
HtmlBaseUrl = new Uri(System.Reflection.Assembly.GetEntryAssembly().Location).AbsoluteUri

Public field Hyperlink
Makes the entire stamp link to a web hyperlink. Note that HTML links created by <a href=''> tags are not reserved by stamping.
Public field Opacity
Allows the stamp to be transparent. 0 is invisible, 100 if fully opaque.
Public field Rotation
Rotates the stamp clockwise from 0 to 360 degrees as specified.
Public field ZIndex
Defines if this stamp should be placed behind or on-top of existing PDF contents.
Top
See Also

Reference

IronPdf Namespace
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


HtmlStamp Constructor

Overload List
 | Name | Description
Public method | HtmlStamp | Initializes a new instance of the HtmlStamp class.
Public method | HtmlStamp(String) | Initializes a new instance of the HtmlStamp class.
Public method | HtmlStamp(String, Int32, Int32) | Initializes a new instance of the HtmlStamp class.
Top
See Also

Reference

HtmlStamp Class


HtmlStamp Constructor

Initializes a new instance of the HtmlStamp class.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public HtmlStamp()
Public Sub New
new : unit -> HtmlStamp
See Also

Reference

HtmlStamp Class
HtmlStamp Overload


HtmlStamp Constructor (String)

Initializes a new instance of the HtmlStamp class.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public HtmlStamp(
    string Html
)
Public Sub New (
    Html As String
)
new :
        Html : string -> HtmlStamp

Parameters

Html
Type: SystemString
The HTML fragment which will be stamped onto your PDF.
See Also

Reference

HtmlStamp Class
HtmlStamp Overload


HtmlStamp Constructor (String, Int32, Int32)

Initializes a new instance of the HtmlStamp class.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public HtmlStamp(
    string Html,
    int WidthInMM,
    int HeightInMM
)
Public Sub New (
    Html As String,
    WidthInMM As Integer,
    HeightInMM As Integer
)
new :
        Html : string *
        WidthInMM : int *
        HeightInMM : int -> HtmlStamp

Parameters

Html
Type: SystemString
The HTML fragment which will be stamped onto your PDF.
WidthInMM
Type: SystemInt32
The width of the stamp in mm.
HeightInMM
Type: SystemInt32
The height of the stamp in mm.
See Also

Reference

HtmlStamp Class
HtmlStamp Overload


HtmlStamp Properties

The HtmlStamp type exposes the following members.

Properties
 | Name | Description
Public property | Bottom | The position of the stamp from the Bottom edge of the PDF document in mm. If Top or Bottom is not set, the stamp will be vertically centered in the document.
Public property | Height | The height of the stamp in mm. Stamps can not automatically detect their own size based on their content.
Public property | Left | The position of the stamp from the Left of the PDF document in mm. If Left or Right is not set, the stamp will be horizontally centered in the document.
Public property | Right | The position of the stamp from the Right of the PDF document in mm. If Left or Right is not set, the stamp will be horizontally centered in the document.
Public property | Top | The position of the stamp from the Top edge of the PDF document in mm. If Top or Bottom is not set, the stamp will be vertically centered in the document.
Public property | Width | The width of the stamp in mm. Stamps can not automatically detect their own size based on their content.
Top
See Also

Reference

HtmlStamp Class


HtmlStamp.Bottom Property

HtmlStampBottom Property

The position of the stamp from the Bottom edge of the PDF document in mm. If Top or Bottom is not set, the stamp will be vertically centered in the document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public Nullable<int> Bottom { get; set; }
Public Property Bottom As Nullable(Of Integer)
    Get
    Set
member Bottom : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

HtmlStamp Class


HtmlStamp.Height Property

HtmlStampHeight Property

The height of the stamp in mm. Stamps can not automatically detect their own size based on their content.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public int Height { get; set; }
Public Property Height As Integer
    Get
    Set
member Height : int with get, set

Property Value

Type: Int32
See Also

Reference

HtmlStamp Class


HtmlStamp.Left Property

HtmlStampLeft Property

The position of the stamp from the Left of the PDF document in mm. If Left or Right is not set, the stamp will be horizontally centered in the document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public Nullable<int> Left { get; set; }
Public Property Left As Nullable(Of Integer)
    Get
    Set
member Left : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

HtmlStamp Class


HtmlStamp.Right Property

HtmlStampRight Property

The position of the stamp from the Right of the PDF document in mm. If Left or Right is not set, the stamp will be horizontally centered in the document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public Nullable<int> Right { get; set; }
Public Property Right As Nullable(Of Integer)
    Get
    Set
member Right : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

HtmlStamp Class


HtmlStamp.Top Property

HtmlStampTop Property

The position of the stamp from the Top edge of the PDF document in mm. If Top or Bottom is not set, the stamp will be vertically centered in the document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public Nullable<int> Top { get; set; }
Public Property Top As Nullable(Of Integer)
    Get
    Set
member Top : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

HtmlStamp Class


HtmlStamp.Width Property

HtmlStampWidth Property

The width of the stamp in mm. Stamps can not automatically detect their own size based on their content.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public int Width { get; set; }
Public Property Width As Integer
    Get
    Set
member Width : int with get, set

Property Value

Type: Int32
See Also

Reference

HtmlStamp Class


HtmlStamp Methods

The HtmlStamp type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

HtmlStamp Class


HtmlStamp Fields

The HtmlStamp type exposes the following members.

Fields
Name Description
Public field AutoCenterStampContentOnStampCanvas
The automatic centers stamp content within stamp canvas as defined by Width and Height.
Public field Html
The HTML fragment which will be stamped onto your PDF. All external references to javascript, CSS and image files will be relative to HtmlBaseUrl.
Public field HtmlBaseUrl
The HTML base URL for which references to external CSS, Javascript and Image files will be relative.

A trick to make references relative to a your project file is

Copy
HtmlBaseUrl = new Uri(System.Reflection.Assembly.GetEntryAssembly().Location).AbsoluteUri

Public field Hyperlink
Makes the entire stamp link to a web hyperlink. Note that HTML links created by <a href=''> tags are not reserved by stamping.
Public field Opacity
Allows the stamp to be transparent. 0 is invisible, 100 if fully opaque.
Public field Rotation
Rotates the stamp clockwise from 0 to 360 degrees as specified.
Public field ZIndex
Defines if this stamp should be placed behind or on-top of existing PDF contents.
Top
See Also

Reference

HtmlStamp Class


HtmlStamp.AutoCenterStampContentOnStampCanvas Field

HtmlStampAutoCenterStampContentOnStampCanvas Field

The automatic centers stamp content within stamp canvas as defined by Width and Height.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public bool AutoCenterStampContentOnStampCanvas
Public AutoCenterStampContentOnStampCanvas As Boolean
val mutable AutoCenterStampContentOnStampCanvas: bool

Field Value

Type: Boolean
See Also

Reference

HtmlStamp Class


HtmlStamp.Html Field

HtmlStampHtml Field

The HTML fragment which will be stamped onto your PDF. All external references to javascript, CSS and image files will be relative to HtmlBaseUrl.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string Html
Public Html As String
val mutable Html: string

Field Value

Type: String
See Also

Reference

HtmlStamp Class


HtmlStamp.HtmlBaseUrl Field

HtmlStampHtmlBaseUrl Field

The HTML base URL for which references to external CSS, Javascript and Image files will be relative.

A trick to make references relative to a your project file is

Copy
HtmlBaseUrl = new Uri(System.Reflection.Assembly.GetEntryAssembly().Location).AbsoluteUri

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string HtmlBaseUrl
Public HtmlBaseUrl As String
val mutable HtmlBaseUrl: string

Field Value

Type: String
See Also

Reference

HtmlStamp Class


HtmlStamp.Hyperlink Field

HtmlStampHyperlink Field

Makes the entire stamp link to a web hyperlink. Note that HTML links created by <a href=''> tags are not reserved by stamping.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string Hyperlink
Public Hyperlink As String
val mutable Hyperlink: string

Field Value

Type: String
See Also

Reference

HtmlStamp Class


HtmlStamp.Opacity Field

HtmlStampOpacity Field

Allows the stamp to be transparent. 0 is invisible, 100 if fully opaque.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public int Opacity
Public Opacity As Integer
val mutable Opacity: int

Field Value

Type: Int32
See Also

Reference

HtmlStamp Class


HtmlStamp.Rotation Field

HtmlStampRotation Field

Rotates the stamp clockwise from 0 to 360 degrees as specified.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public int Rotation
Public Rotation As Integer
val mutable Rotation: int

Field Value

Type: Int32
See Also

Reference

HtmlStamp Class


HtmlStamp.ZIndex Field

HtmlStampZIndex Field

Defines if this stamp should be placed behind or on-top of existing PDF contents.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public HtmlStampStampLayer ZIndex
Public ZIndex As HtmlStampStampLayer
val mutable ZIndex: HtmlStampStampLayer

Field Value

Type: HtmlStampStampLayer
See Also

Reference

HtmlStamp Class


HtmlStamp.StampLayer Enumeration

HtmlStampStampLayer Enumeration

Defines if a stamp should be placed behind or on-top of existing PDF contents.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public enum StampLayer
Public Enumeration StampLayer
type StampLayer
Members
Member name | Value | Description
BehindExistingPDFContent | 0 | Stamp in the background
OnTopOfExistingPDFContent | 1 | Stamp in the foreground
See Also

Reference

IronPdf Namespace
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


HtmlToPdf Class

IronPdf.HtmlToPdf allows any web page or Html 'snippet' to be turned into a PDF document.
Inheritance Hierarchy
SystemObject
IronPdfHtmlToPdf

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public class HtmlToPdf
Public Class HtmlToPdf
type HtmlToPdf =  class end

The HtmlToPdf type exposes the following members.

Constructors
 | Name | Description
Public method | HtmlToPdf | The IronPdf.HtmlToPdf allows developers to create PDF files from any web page or Html Snippet
Public method | HtmlToPdf(PdfPrintOptions) | Initializes a new instance of the HtmlToPdf class
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | RenderHtmlAsPdf(String, String, String) | Creates a PDF file from an Html string, and returns it as an IronPdf.PdfDocument
 | RenderHtmlAsPdf(String, Uri, String) | Creates a PDF file from an Html string, and returns it as an IronPdf.PdfDocument
Public method | RenderHTMLFileAsPdf | Renders an HTML file as PDF binary data.
Public method | RenderUrlAsPdf(String) | Renders the URL as PDF binary data.
 | RenderUrlAsPdf(Uri) | Renders the URL as PDF binary data.
 | StaticRenderHtmlAsPdf(String, PdfPrintOptions) | Static version of the RenderHtmlAsPdf(String, String, String) function. Renders any Html strings into a PDF document.
 | StaticRenderHtmlAsPdf(String, String, PdfPrintOptions, String) | Static version of the RenderHtmlAsPdf(String, String, String) function. Renders any Html strings into a PDF document.
 | StaticRenderHtmlAsPdf(String, Uri, PdfPrintOptions, String) | Static version of the RenderHtmlAsPdf(String, Uri, String) function. Renders any Html strings into a PDF document.
 | StaticRenderHTMLFileAsPdf | Renders an HTML file as PDF binary data.
 | StaticRenderUrlAsPdf(String, PdfPrintOptions, HttpLoginCredentials) | Static version of the RenderUrlAsPdf(String) function. Renders all Html and assets at a given Url into a PDF file.
 | StaticRenderUrlAsPdf(Uri, PdfPrintOptions, HttpLoginCredentials) | Static version of the RenderUrlAsPdf(Uri) function. Renders all Html and assets at a given Url into a PDF file.
Public method | ToString | (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | LoginCredentials | An instance of the HttpLoginCredentials class. Allows developers to specify login credentials using Windows, Linux or Html Forms based authentication. This allows PDFs to be printed, even if they reside on private Intranets, Extranets or within 'login' areas of websites.
Public field | PrintOptions | An instance of the PdfPrintOptions class. Sets PDF output options such as Paper-Size, DPI, Headers and Footers.
Top
See Also

Reference

IronPdf Namespace
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


HtmlToPdf Constructor

Overload List
 | Name | Description
Public method | HtmlToPdf | The IronPdf.HtmlToPdf allows developers to create PDF files from any web page or Html Snippet
Public method | HtmlToPdf(PdfPrintOptions) | Initializes a new instance of the HtmlToPdf class
Top
See Also

Reference

HtmlToPdf Class


HtmlToPdf Constructor

The IronPdf.HtmlToPdf allows developers to create PDF files from any web page or Html Snippet

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public HtmlToPdf()
Public Sub New
new : unit -> HtmlToPdf
See Also

Reference

HtmlToPdf Class
HtmlToPdf Overload


HtmlToPdf Constructor (PdfPrintOptions)

Initializes a new instance of the HtmlToPdf class

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public HtmlToPdf(
    PdfPrintOptions PrintOptions
)
Public Sub New (
    PrintOptions As PdfPrintOptions
)
new :
        PrintOptions : PdfPrintOptions -> HtmlToPdf

Parameters

PrintOptions
Type: IronPdfPdfPrintOptions
Sets PDF output options such as paper-size, DPI, headers and footers using an instance of the IronPdf.PdfPrintOptions Class.
See Also

Reference

HtmlToPdf Class
HtmlToPdf Overload


HtmlToPdf Methods

The HtmlToPdf type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | RenderHtmlAsPdf(String, String, String) | Creates a PDF file from an Html string, and returns it as an IronPdf.PdfDocument
 | RenderHtmlAsPdf(String, Uri, String) | Creates a PDF file from an Html string, and returns it as an IronPdf.PdfDocument
Public method | RenderHTMLFileAsPdf | Renders an HTML file as PDF binary data.
Public method | RenderUrlAsPdf(String) | Renders the URL as PDF binary data.
 | RenderUrlAsPdf(Uri) | Renders the URL as PDF binary data.
 | StaticRenderHtmlAsPdf(String, PdfPrintOptions) | Static version of the RenderHtmlAsPdf(String, String, String) function. Renders any Html strings into a PDF document.
 | StaticRenderHtmlAsPdf(String, String, PdfPrintOptions, String) | Static version of the RenderHtmlAsPdf(String, String, String) function. Renders any Html strings into a PDF document.
 | StaticRenderHtmlAsPdf(String, Uri, PdfPrintOptions, String) | Static version of the RenderHtmlAsPdf(String, Uri, String) function. Renders any Html strings into a PDF document.
 | StaticRenderHTMLFileAsPdf | Renders an HTML file as PDF binary data.
 | StaticRenderUrlAsPdf(String, PdfPrintOptions, HttpLoginCredentials) | Static version of the RenderUrlAsPdf(String) function. Renders all Html and assets at a given Url into a PDF file.
 | StaticRenderUrlAsPdf(Uri, PdfPrintOptions, HttpLoginCredentials) | Static version of the RenderUrlAsPdf(Uri) function. Renders all Html and assets at a given Url into a PDF file.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

HtmlToPdf Class


HtmlToPdf.RenderHtmlAsPdf Method

HtmlToPdfRenderHtmlAsPdf Method

Overload List
Name | Description
RenderHtmlAsPdf(String, String, String) | Creates a PDF file from an Html string, and returns it as an IronPdf.PdfDocument
RenderHtmlAsPdf(String, Uri, String) | Creates a PDF file from an Html string, and returns it as an IronPdf.PdfDocument
Top
See Also

Reference

HtmlToPdf Class


HtmlToPdf.RenderHtmlAsPdf Method (String, String, String)

HtmlToPdfRenderHtmlAsPdf Method (String, String, String)

Creates a PDF file from an Html string, and returns it as an IronPdf.PdfDocument

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument RenderHtmlAsPdf(
    string Html,
    string BaseUrlOrPath,
    string Proxy = null
)
Public Function RenderHtmlAsPdf (
    Html As String,
    BaseUrlOrPath As String,
    Optional Proxy As String = Nothing
) As PdfDocument
member RenderHtmlAsPdf :
        Html : string *
        BaseUrlOrPath : string *
        ?Proxy : string
(* Defaults:
        let _Proxy = defaultArg Proxy null
*)
-> PdfDocument

Parameters

Html
Type: SystemString
The Html to be rendered as a PDF.
BaseUrlOrPath
Type: SystemString
Setting the BaseUrlOrPath property gives the relative context for hyper-links, images, CSS and JavaScript files.
Proxy (Optional)
Type: SystemString
Specifies an Http proxy server. Use the pattern: http(s)://user-name:password@host:port

Return Value

Type: PdfDocument
A PdfDocument
Examples
Copy
HtmlToPdf myHtmlToPdf = new IronPdf.HtmlToPdf();
            myHtmlToPdf.RenderHtmlAsPdf("<p>html</p>").SaveAs(@"Path\File.Pdf");
See Also

Reference

HtmlToPdf Class
RenderHtmlAsPdf Overload


HtmlToPdf.RenderHtmlAsPdf Method (String, Uri, String)

HtmlToPdfRenderHtmlAsPdf Method (String, Uri, String)

Creates a PDF file from an Html string, and returns it as an IronPdf.PdfDocument

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument RenderHtmlAsPdf(
    string Html,
    Uri BaseUrl = null,
    string Proxy = null
)
Public Function RenderHtmlAsPdf (
    Html As String,
    Optional BaseUrl As Uri = Nothing,
    Optional Proxy As String = Nothing
) As PdfDocument
member RenderHtmlAsPdf :
        Html : string *
        ?BaseUrl : Uri *
        ?Proxy : string
(* Defaults:
        let _BaseUrl = defaultArg BaseUrl null
        let _Proxy = defaultArg Proxy null
*)
-> PdfDocument

Parameters

Html
Type: SystemString
The Html to be rendered as a PDF.
BaseUrl (Optional)
Type: SystemUri
Setting the BaseURL property gives the relative context for hyper-links, images, CSS and JavaScript files.
Proxy (Optional)
Type: SystemString
Specifies an Http proxy server. Use the pattern: http(s)://user-name:password@host:port

Return Value

Type: PdfDocument
A PdfDocument
Examples
Copy
HtmlToPdf myHtmlToPdf = new IronPdf.HtmlToPdf();
            myHtmlToPdf.RenderHtmlAsPdf("<p>html</p>").SaveAs(@"Path\File.Pdf");
See Also

Reference

HtmlToPdf Class
RenderHtmlAsPdf Overload


HtmlToPdf.RenderHTMLFileAsPdf Method

HtmlToPdfRenderHTMLFileAsPdf Method

Renders an HTML file as PDF binary data.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument RenderHTMLFileAsPdf(
    string FilePath
)
Public Function RenderHTMLFileAsPdf (
    FilePath As String
) As PdfDocument
member RenderHTMLFileAsPdf :
        FilePath : string -> PdfDocument

Parameters

FilePath
Type: SystemString
Path to an Html file.

Return Value

Type: PdfDocument
A PdfDocument
See Also

Reference

HtmlToPdf Class


HtmlToPdf.RenderUrlAsPdf Method

HtmlToPdfRenderUrlAsPdf Method

Overload List
 | Name | Description
Public method | RenderUrlAsPdf(String) | Renders the URL as PDF binary data.
 | RenderUrlAsPdf(Uri) | Renders the URL as PDF binary data.
Top
See Also

Reference

HtmlToPdf Class


HtmlToPdf.RenderUrlAsPdf Method (String)

HtmlToPdfRenderUrlAsPdf Method (String)

Renders the URL as PDF binary data.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument RenderUrlAsPdf(
    string UrlOrPath
)
Public Function RenderUrlAsPdf (
    UrlOrPath As String
) As PdfDocument
member RenderUrlAsPdf :
        UrlOrPath : string -> PdfDocument

Parameters

UrlOrPath
Type: SystemString
A url or file path.

Return Value

Type: PdfDocument
A PdfDocument
See Also

Reference

HtmlToPdf Class
RenderUrlAsPdf Overload


HtmlToPdf.RenderUrlAsPdf Method (Uri)

HtmlToPdfRenderUrlAsPdf Method (Uri)

Renders the URL as PDF binary data.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument RenderUrlAsPdf(
    Uri Url
)
Public Function RenderUrlAsPdf (
    Url As Uri
) As PdfDocument
member RenderUrlAsPdf :
        Url : Uri -> PdfDocument

Parameters

Url
Type: SystemUri
An absolute Uri. Points to the Html document to be rendered as a PDF.

Return Value

Type: PdfDocument
A PdfDocument
Examples
Copy
HtmlToPdf myHtmlToPdf = new IronPdf.HtmlToPdf();
                  Uri  myUri = new Uri("http://www.example.com");
                  myHtmlToPdf.RenderUrlAsPdf(myUri).SaveAs(@"Path\File.Pdf");
See Also

Reference

HtmlToPdf Class
RenderUrlAsPdf Overload


HtmlToPdf.StaticRenderHtmlAsPdf Method

HtmlToPdfStaticRenderHtmlAsPdf Method

Overload List
Name | Description
StaticRenderHtmlAsPdf(String, PdfPrintOptions) | Static version of the RenderHtmlAsPdf(String, String, String) function. Renders any Html strings into a PDF document.
StaticRenderHtmlAsPdf(String, String, PdfPrintOptions, String) | Static version of the RenderHtmlAsPdf(String, String, String) function. Renders any Html strings into a PDF document.
StaticRenderHtmlAsPdf(String, Uri, PdfPrintOptions, String) | Static version of the RenderHtmlAsPdf(String, Uri, String) function. Renders any Html strings into a PDF document.
Top
See Also

Reference

HtmlToPdf Class


HtmlToPdf.StaticRenderHtmlAsPdf Method (String, PdfPrintOptions)

HtmlToPdfStaticRenderHtmlAsPdf Method (String, PdfPrintOptions)

Static version of the RenderHtmlAsPdf(String, String, String) function. Renders any Html strings into a PDF document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public static PdfDocument StaticRenderHtmlAsPdf(
    string Html,
    PdfPrintOptions PrintOptions
)
Public Shared Function StaticRenderHtmlAsPdf (
    Html As String,
    PrintOptions As PdfPrintOptions
) As PdfDocument
static member StaticRenderHtmlAsPdf :
        Html : string *
        PrintOptions : PdfPrintOptions -> PdfDocument

Parameters

Html
Type: SystemString
Html to be turned into a PDF.
PrintOptions
Type: IronPdfPdfPrintOptions
Instance of PdfPrintOptions. Optional print options and settings.

Return Value

Type: PdfDocument
A PdfDocument
See Also

Reference

HtmlToPdf Class
StaticRenderHtmlAsPdf Overload


HtmlToPdf.StaticRenderHtmlAsPdf Method (String, String, PdfPrintOptions, String)

HtmlToPdfStaticRenderHtmlAsPdf Method (String, String, PdfPrintOptions, String)

Static version of the RenderHtmlAsPdf(String, String, String) function. Renders any Html strings into a PDF document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public static PdfDocument StaticRenderHtmlAsPdf(
    string Html,
    string BaseUrlOrPath,
    PdfPrintOptions PrintOptions = null,
    string Proxy = null
)
Public Shared Function StaticRenderHtmlAsPdf (
    Html As String,
    BaseUrlOrPath As String,
    Optional PrintOptions As PdfPrintOptions = Nothing,
    Optional Proxy As String = Nothing
) As PdfDocument
static member StaticRenderHtmlAsPdf :
        Html : string *
        BaseUrlOrPath : string *
        ?PrintOptions : PdfPrintOptions *
        ?Proxy : string
(* Defaults:
        let _PrintOptions = defaultArg PrintOptions null
        let _Proxy = defaultArg Proxy null
*)
-> PdfDocument

Parameters

Html
Type: SystemString
Html to be turned into a PDF.
BaseUrlOrPath
Type: SystemString
Setting the BaseUrlOrPath property gives the Html a relative for content links such as hyper-links, images, CSS and JavaScript files.
PrintOptions (Optional)
Type: IronPdfPdfPrintOptions
Instance of PdfPrintOptions. Optional print options and settings.
Proxy (Optional)
Type: SystemString
Specifies an Http proxy server. Use the pattern: http(s)://user-name:password@host:port/

Return Value

Type: PdfDocument
A PdfDocument
See Also

Reference

HtmlToPdf Class
StaticRenderHtmlAsPdf Overload


HtmlToPdf.StaticRenderHtmlAsPdf Method (String, Uri, PdfPrintOptions, String)

HtmlToPdfStaticRenderHtmlAsPdf Method (String, Uri, PdfPrintOptions, String)

Static version of the RenderHtmlAsPdf(String, Uri, String) function. Renders any Html strings into a PDF document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public static PdfDocument StaticRenderHtmlAsPdf(
    string Html,
    Uri BaseUrl = null,
    PdfPrintOptions PrintOptions = null,
    string Proxy = null
)
Public Shared Function StaticRenderHtmlAsPdf (
    Html As String,
    Optional BaseUrl As Uri = Nothing,
    Optional PrintOptions As PdfPrintOptions = Nothing,
    Optional Proxy As String = Nothing
) As PdfDocument
static member StaticRenderHtmlAsPdf :
        Html : string *
        ?BaseUrl : Uri *
        ?PrintOptions : PdfPrintOptions *
        ?Proxy : string
(* Defaults:
        let _BaseUrl = defaultArg BaseUrl null
        let _PrintOptions = defaultArg PrintOptions null
        let _Proxy = defaultArg Proxy null
*)
-> PdfDocument

Parameters

Html
Type: SystemString
Html to be turned into a PDF.
BaseUrl (Optional)
Type: SystemUri
Setting the BaseURL property gives the Html a relative for content links such as hyper-links, images, CSS and JavaScript files.
PrintOptions (Optional)
Type: IronPdfPdfPrintOptions
Instance of PdfPrintOptions. Optional print options and settings.
Proxy (Optional)
Type: SystemString
Specifies an Http proxy server. Use the pattern: http(s)://user-name:password@host:port/

Return Value

Type: PdfDocument
A PdfDocument
See Also

Reference

HtmlToPdf Class
StaticRenderHtmlAsPdf Overload


HtmlToPdf.StaticRenderHTMLFileAsPdf Method

HtmlToPdfStaticRenderHTMLFileAsPdf Method

Renders an HTML file as PDF binary data.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public static PdfDocument StaticRenderHTMLFileAsPdf(
    string FilePath,
    PdfPrintOptions PrintOptions = null
)
Public Shared Function StaticRenderHTMLFileAsPdf (
    FilePath As String,
    Optional PrintOptions As PdfPrintOptions = Nothing
) As PdfDocument
static member StaticRenderHTMLFileAsPdf :
        FilePath : string *
        ?PrintOptions : PdfPrintOptions
(* Defaults:
        let _PrintOptions = defaultArg PrintOptions null
*)
-> PdfDocument

Parameters

FilePath
Type: SystemString
Path to an Html file.
PrintOptions (Optional)
Type: IronPdfPdfPrintOptions
Instance of PdfPrintOptions. Optional print options and settings.

Return Value

Type: PdfDocument
A PdfDocument
See Also

Reference

HtmlToPdf Class


HtmlToPdf.StaticRenderUrlAsPdf Method

HtmlToPdfStaticRenderUrlAsPdf Method

Overload List
Name | Description
StaticRenderUrlAsPdf(String, PdfPrintOptions, HttpLoginCredentials) | Static version of the RenderUrlAsPdf(String) function. Renders all Html and assets at a given Url into a PDF file.
StaticRenderUrlAsPdf(Uri, PdfPrintOptions, HttpLoginCredentials) | Static version of the RenderUrlAsPdf(Uri) function. Renders all Html and assets at a given Url into a PDF file.
Top
See Also

Reference

HtmlToPdf Class


HtmlToPdf.StaticRenderUrlAsPdf Method (String, PdfPrintOptions, HttpLoginCredentials)

HtmlToPdfStaticRenderUrlAsPdf Method (String, PdfPrintOptions, HttpLoginCredentials)

Static version of the RenderUrlAsPdf(String) function. Renders all Html and assets at a given Url into a PDF file.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public static PdfDocument StaticRenderUrlAsPdf(
    string UrlOrPath,
    PdfPrintOptions PrintOptions = null,
    HttpLoginCredentials LoginCredentials = null
)
Public Shared Function StaticRenderUrlAsPdf (
    UrlOrPath As String,
    Optional PrintOptions As PdfPrintOptions = Nothing,
    Optional LoginCredentials As HttpLoginCredentials = Nothing
) As PdfDocument
static member StaticRenderUrlAsPdf :
        UrlOrPath : string *
        ?PrintOptions : PdfPrintOptions *
        ?LoginCredentials : HttpLoginCredentials
(* Defaults:
        let _PrintOptions = defaultArg PrintOptions null
        let _LoginCredentials = defaultArg LoginCredentials null
*)
-> PdfDocument

Parameters

UrlOrPath
Type: SystemString
An absolute Url or file path. Points to the Html document to be rendered as a PDF.
PrintOptions (Optional)
Type: IronPdfPdfPrintOptions
Instance of PdfPrintOptions. Optional print options and settings.
LoginCredentials (Optional)
Type: IronPdfHttpLoginCredentials
Instance of HttpLoginCredentials. Optional login credentials for Windows, Linux and Html Form login environments.

Return Value

Type: PdfDocument
A PdfDocument
See Also

Reference

HtmlToPdf Class
StaticRenderUrlAsPdf Overload


HtmlToPdf.StaticRenderUrlAsPdf Method (Uri, PdfPrintOptions, HttpLoginCredentials)

HtmlToPdfStaticRenderUrlAsPdf Method (Uri, PdfPrintOptions, HttpLoginCredentials)

Static version of the RenderUrlAsPdf(Uri) function. Renders all Html and assets at a given Url into a PDF file.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public static PdfDocument StaticRenderUrlAsPdf(
    Uri Url,
    PdfPrintOptions PrintOptions = null,
    HttpLoginCredentials LoginCredentials = null
)
Public Shared Function StaticRenderUrlAsPdf (
    Url As Uri,
    Optional PrintOptions As PdfPrintOptions = Nothing,
    Optional LoginCredentials As HttpLoginCredentials = Nothing
) As PdfDocument
static member StaticRenderUrlAsPdf :
        Url : Uri *
        ?PrintOptions : PdfPrintOptions *
        ?LoginCredentials : HttpLoginCredentials
(* Defaults:
        let _PrintOptions = defaultArg PrintOptions null
        let _LoginCredentials = defaultArg LoginCredentials null
*)
-> PdfDocument

Parameters

Url
Type: SystemUri
An absolute Uri. Points to the Html document to be rendered as a PDF.
PrintOptions (Optional)
Type: IronPdfPdfPrintOptions
Instance of PdfPrintOptions. Optional print options and settings.
LoginCredentials (Optional)
Type: IronPdfHttpLoginCredentials
Instance of HttpLoginCredentials. Optional login credentials for Windows, Linux and Html Form login environments.

Return Value

Type: PdfDocument
A PdfDocument
See Also

Reference

HtmlToPdf Class
StaticRenderUrlAsPdf Overload


HtmlToPdf Fields

The HtmlToPdf type exposes the following members.

Fields
 | Name | Description
Public field | LoginCredentials | An instance of the HttpLoginCredentials class. Allows developers to specify login credentials using Windows, Linux or Html Forms based authentication. This allows PDFs to be printed, even if they reside on private Intranets, Extranets or within 'login' areas of websites.
Public field | PrintOptions | An instance of the PdfPrintOptions class. Sets PDF output options such as Paper-Size, DPI, Headers and Footers.
Top
See Also

Reference

HtmlToPdf Class


HtmlToPdf.LoginCredentials Field

HtmlToPdfLoginCredentials Field

An instance of the HttpLoginCredentials class. Allows developers to specify login credentials using Windows, Linux or Html Forms based authentication. This allows PDFs to be printed, even if they reside on private Intranets, Extranets or within 'login' areas of websites.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public HttpLoginCredentials LoginCredentials
Public LoginCredentials As HttpLoginCredentials
val mutable LoginCredentials: HttpLoginCredentials

Field Value

Type: HttpLoginCredentials
See Also

Reference

HtmlToPdf Class


HtmlToPdf.PrintOptions Field

HtmlToPdfPrintOptions Field

An instance of the PdfPrintOptions class. Sets PDF output options such as Paper-Size, DPI, Headers and Footers.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfPrintOptions PrintOptions
Public PrintOptions As PdfPrintOptions
val mutable PrintOptions: PdfPrintOptions

Field Value

Type: PdfPrintOptions
See Also

Reference

HtmlToPdf Class


HttpLoginCredentials Class

Provides credentials for IronPdf to log-in to an intranet, extranet or website, impersonating a user. This allows a unique ability to render web-pages as PDFs even on secure intranets, extranets and websites.
Inheritance Hierarchy
SystemObject
IronPdfHttpLoginCredentials

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public class HttpLoginCredentials
Public Class HttpLoginCredentials
type HttpLoginCredentials =  class end

The HttpLoginCredentials type exposes the following members.

Constructors
 | Name | Description
Public method | HttpLoginCredentials | Initializes a new instance of the HttpLoginCredentials class
Top
Properties
 | Name | Description
Public property | UserAgent | The Http User-Agent header which will be used to fetch any remote HTML.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | CustomCookies | A Dictionary which allows custom cookies to be posted with every login request, and HTTP request made by RenderUriToHml methods.
Public field | CustomHttpHeaders | A dictionary of custom HTTP headers to be sent with every HTTP Request
Public field | CustomPostFiles | Optional, Advanced Usage: Specifies a collection files to summited on every PDF rendering request. Allows images and documents to be submitted to forms such that the output will be rendered as an PDF. Note: The Key is the name of the post field, The value is the full file path.. UrlEncoding is not required.
Public field | CustomPostVariables | Optional: Specifies a collection of HTTP 'POST' variables to submit on every PDF rendering request. Note: The 'key' is the name of the post field, The 'value' is its value. UrlEncoding is not required. Note: Not implemented in .Net Core.
Public field | EnableCookies | Enables cookies to be stored and sent when using RenderUriToHml methods.
Public field | LoginFormPostVariables | Optional: Specifies a collection of HTTP form variables to post/submit to LoginFormUrl.
Public field | LoginFormUrl | Optional: Gives the URL to post website login-form authentication. Should be the absolute Url which the form's action attribute specifies.
Public field | NetworkPassword | Optional: Password credential for Windows / Linux network security authentication.
Public field | NetworkUsername | Optional: User-name credential for Windows / Linux network security authentication.
Public field | Proxy | e Specifies an Http proxy server. Use the pattern: http(s)://user-name:password@host:port/
Top
See Also

Reference

IronPdf Namespace
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


HttpLoginCredentials Constructor

Initializes a new instance of the HttpLoginCredentials class

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public HttpLoginCredentials()
Public Sub New
new : unit -> HttpLoginCredentials
See Also

Reference

HttpLoginCredentials Class


HttpLoginCredentials Properties

The HttpLoginCredentials type exposes the following members.

Properties
 | Name | Description
Public property | UserAgent | The Http User-Agent header which will be used to fetch any remote HTML.
Top
See Also

Reference

HttpLoginCredentials Class


HttpLoginCredentials.UserAgent Property

HttpLoginCredentialsUserAgent Property

The Http User-Agent header which will be used to fetch any remote HTML.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string UserAgent { get; set; }
Public Property UserAgent As String
    Get
    Set
member UserAgent : string with get, set

Property Value

Type: String
See Also

Reference

HttpLoginCredentials Class


HttpLoginCredentials Methods

The HttpLoginCredentials type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

HttpLoginCredentials Class


HttpLoginCredentials Fields

The HttpLoginCredentials type exposes the following members.

Fields
 | Name | Description
Public field | CustomCookies | A Dictionary which allows custom cookies to be posted with every login request, and HTTP request made by RenderUriToHml methods.
Public field | CustomHttpHeaders | A dictionary of custom HTTP headers to be sent with every HTTP Request
Public field | CustomPostFiles | Optional, Advanced Usage: Specifies a collection files to summited on every PDF rendering request. Allows images and documents to be submitted to forms such that the output will be rendered as an PDF. Note: The Key is the name of the post field, The value is the full file path.. UrlEncoding is not required.
Public field | CustomPostVariables | Optional: Specifies a collection of HTTP 'POST' variables to submit on every PDF rendering request. Note: The 'key' is the name of the post field, The 'value' is its value. UrlEncoding is not required. Note: Not implemented in .Net Core.
Public field | EnableCookies | Enables cookies to be stored and sent when using RenderUriToHml methods.
Public field | LoginFormPostVariables | Optional: Specifies a collection of HTTP form variables to post/submit to LoginFormUrl.
Public field | LoginFormUrl | Optional: Gives the URL to post website login-form authentication. Should be the absolute Url which the form's action attribute specifies.
Public field | NetworkPassword | Optional: Password credential for Windows / Linux network security authentication.
Public field | NetworkUsername | Optional: User-name credential for Windows / Linux network security authentication.
Public field | Proxy | e Specifies an Http proxy server. Use the pattern: http(s)://user-name:password@host:port/
Top
See Also

Reference

HttpLoginCredentials Class


HttpLoginCredentials.CustomCookies Field

HttpLoginCredentialsCustomCookies Field

A Dictionary which allows custom cookies to be posted with every login request, and HTTP request made by RenderUriToHml methods.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public Dictionary<string, string> CustomCookies
Public CustomCookies As Dictionary(Of String, String)
val mutable CustomCookies: Dictionary<string, string>

Field Value

Type: Dictionary String, String
See Also

Reference

HttpLoginCredentials Class


HttpLoginCredentials.CustomHttpHeaders Field

HttpLoginCredentialsCustomHttpHeaders Field

A dictionary of custom HTTP headers to be sent with every HTTP Request

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public Dictionary<string, string> CustomHttpHeaders
Public CustomHttpHeaders As Dictionary(Of String, String)
val mutable CustomHttpHeaders: Dictionary<string, string>

Field Value

Type: Dictionary String, String
See Also

Reference

HttpLoginCredentials Class


HttpLoginCredentials.CustomPostFiles Field

HttpLoginCredentialsCustomPostFiles Field

Optional, Advanced Usage: Specifies a collection files to summited on every PDF rendering request. Allows images and documents to be submitted to forms such that the output will be rendered as an PDF.

Note: The Key is the name of the post field, The value is the full file path.. UrlEncoding is not required.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public Dictionary<string, string> CustomPostFiles
Public CustomPostFiles As Dictionary(Of String, String)
val mutable CustomPostFiles: Dictionary<string, string>

Field Value

Type: Dictionary String, String
See Also

Reference

HttpLoginCredentials Class


HttpLoginCredentials.CustomPostVariables Field

HttpLoginCredentialsCustomPostVariables Field

Optional: Specifies a collection of HTTP 'POST' variables to submit on every PDF rendering request.

Note: The 'key' is the name of the post field, The 'value' is its value. UrlEncoding is not required.

Note: Not implemented in .Net Core.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public Dictionary<string, string> CustomPostVariables
Public CustomPostVariables As Dictionary(Of String, String)
val mutable CustomPostVariables: Dictionary<string, string>

Field Value

Type: Dictionary String, String
See Also

Reference

HttpLoginCredentials Class


HttpLoginCredentials.EnableCookies Field

HttpLoginCredentialsEnableCookies Field

Enables cookies to be stored and sent when using RenderUriToHml methods.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public bool EnableCookies
Public EnableCookies As Boolean
val mutable EnableCookies: bool

Field Value

Type: Boolean
See Also

Reference

HttpLoginCredentials Class


HttpLoginCredentials.LoginFormPostVariables Field

HttpLoginCredentialsLoginFormPostVariables Field

Optional: Specifies a collection of HTTP form variables to post/submit to LoginFormUrl.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public Dictionary<string, string> LoginFormPostVariables
Public LoginFormPostVariables As Dictionary(Of String, String)
val mutable LoginFormPostVariables: Dictionary<string, string>

Field Value

Type: Dictionary String, String
See Also

Reference

HttpLoginCredentials Class


HttpLoginCredentials.LoginFormUrl Field

HttpLoginCredentialsLoginFormUrl Field

Optional: Gives the URL to post website login-form authentication. Should be the absolute Url which the form's action attribute specifies.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public Uri LoginFormUrl
Public LoginFormUrl As Uri
val mutable LoginFormUrl: Uri

Field Value

Type: Uri
See Also

Reference

HttpLoginCredentials Class


HttpLoginCredentials.NetworkPassword Field

HttpLoginCredentialsNetworkPassword Field

Optional: Password credential for Windows / Linux network security authentication.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string NetworkPassword
Public NetworkPassword As String
val mutable NetworkPassword: string

Field Value

Type: String
See Also

Reference

HttpLoginCredentials Class


HttpLoginCredentials.NetworkUsername Field

HttpLoginCredentialsNetworkUsername Field

Optional: User-name credential for Windows / Linux network security authentication.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string NetworkUsername
Public NetworkUsername As String
val mutable NetworkUsername: string

Field Value

Type: String
See Also

Reference

HttpLoginCredentials Class


HttpLoginCredentials.Proxy Field

HttpLoginCredentialsProxy Field

e Specifies an Http proxy server. Use the pattern: http(s)://user-name:password@host:port/

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string Proxy
Public Proxy As String
val mutable Proxy: string

Field Value

Type: String
See Also

Reference

HttpLoginCredentials Class


ImageToPdfConverter Class

The ImageToPdfConveter class can be used to create PDF documents from images. It accepts both image files and Image objects as input.

The ImageToPdf static methods create simple PDF documents containing each image as one page of the created PDF.

To rasterize PDF documents as images (the reverse operation), see ToBitmap(Int32) and RasterizeToImageFiles(String, ImageType, Int32)

Inheritance Hierarchy
SystemObject
IronPdfImageToPdfConverter

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public static class ImageToPdfConverter
Public NotInheritable Class ImageToPdfConverter
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ImageToPdfConverter =  class end
Methods
Name | Description
ImageToPdf(IEnumerableImage) | Converts multiple Image objects or Bitmaps into a PDF document. Each image creates 1 page which matches the image dimensions.
ImageToPdf(IEnumerableString) | Converts multiple image files to a PDF document. Each image creates 1 page which matches the image dimensions.
ImageToPdf(Image) | Converts a single Image object or Bitmap to a PDF document of matching dimensions.
ImageToPdf(String) | Converts a single image file to an identical PDF document of matching dimensions.
Top
See Also

Reference

IronPdf Namespace
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


ImageToPdfConverter Methods

Methods
Name | Description
ImageToPdf(IEnumerableImage) | Converts multiple Image objects or Bitmaps into a PDF document. Each image creates 1 page which matches the image dimensions.
ImageToPdf(IEnumerableString) | Converts multiple image files to a PDF document. Each image creates 1 page which matches the image dimensions.
ImageToPdf(Image) | Converts a single Image object or Bitmap to a PDF document of matching dimensions.
ImageToPdf(String) | Converts a single image file to an identical PDF document of matching dimensions.
Top
See Also

Reference

ImageToPdfConverter Class


ImageToPdfConverter.ImageToPdf Method

ImageToPdfConverterImageToPdf Method

Overload List
Name | Description
ImageToPdf(IEnumerableImage) | Converts multiple Image objects or Bitmaps into a PDF document. Each image creates 1 page which matches the image dimensions.
ImageToPdf(IEnumerableString) | Converts multiple image files to a PDF document. Each image creates 1 page which matches the image dimensions.
ImageToPdf(Image) | Converts a single Image object or Bitmap to a PDF document of matching dimensions.
ImageToPdf(String) | Converts a single image file to an identical PDF document of matching dimensions.
Top
See Also

Reference

ImageToPdfConverter Class


ImageToPdfConverter.ImageToPdf Method (IEnumerable(Image))

ImageToPdfConverterImageToPdf Method (IEnumerableImage)

Converts multiple Image objects or Bitmaps into a PDF document. Each image creates 1 page which matches the image dimensions.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public static PdfDocument ImageToPdf(
    IEnumerable<Image> Images
)
Public Shared Function ImageToPdf (
    Images As IEnumerable(Of Image)
) As PdfDocument
static member ImageToPdf :
        Images : IEnumerable<Image> -> PdfDocument

Parameters

Images
Type: System.Collections.GenericIEnumerable Image
The image objects. Requires a project reference to the System.Drawing Assembly.

Return Value

Type: PdfDocument
Returns a PdfDocument document which can then be edited, saved or served over the web.
See Also

Reference

ImageToPdfConverter Class
ImageToPdf Overload


ImageToPdfConverter.ImageToPdf Method (IEnumerable(String))

ImageToPdfConverterImageToPdf Method (IEnumerableString)

Converts multiple image files to a PDF document. Each image creates 1 page which matches the image dimensions.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public static PdfDocument ImageToPdf(
    IEnumerable<string> ImageFileNames
)
Public Shared Function ImageToPdf (
    ImageFileNames As IEnumerable(Of String)
) As PdfDocument
static member ImageToPdf :
        ImageFileNames : IEnumerable<string> -> PdfDocument

Parameters

ImageFileNames
Type: System.Collections.GenericIEnumerable String
The image file path names.

Return Value

Type: PdfDocument
Returns a PdfDocument document which can then be edited, saved or served over the web.
See Also

Reference

ImageToPdfConverter Class
ImageToPdf Overload


ImageToPdfConverter.ImageToPdf Method (Image)

ImageToPdfConverterImageToPdf Method (Image)

Converts a single Image object or Bitmap to a PDF document of matching dimensions.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public static PdfDocument ImageToPdf(
    Image Image
)
Public Shared Function ImageToPdf (
    Image As Image
) As PdfDocument
static member ImageToPdf :
        Image : Image -> PdfDocument

Parameters

Image
Type: System.DrawingImage
The image object. Requires a project reference to the System.Drawing Assembly.

Return Value

Type: PdfDocument
Returns a PdfDocument document which can then be edited, saved or served over the web.
See Also

Reference

ImageToPdfConverter Class
ImageToPdf Overload


ImageToPdfConverter.ImageToPdf Method (String)

ImageToPdfConverterImageToPdf Method (String)

Converts a single image file to an identical PDF document of matching dimensions.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public static PdfDocument ImageToPdf(
    string ImageFileName
)
Public Shared Function ImageToPdf (
    ImageFileName As String
) As PdfDocument
static member ImageToPdf :
        ImageFileName : string -> PdfDocument

Parameters

ImageFileName
Type: SystemString
File path of the image file.

Return Value

Type: PdfDocument
Returns a PdfDocument document which can then be edited, saved or served over the web.
See Also

Reference

ImageToPdfConverter Class
ImageToPdf Overload


ImageType Enumeration

An Image File Type Enumeration used to select image file formats when converting PDF documents to images. Also see: RasterizeToImageFiles(String, ImageType, Int32)

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public enum ImageType
Public Enumeration ImageType
type ImageType
Members
Member name | Value | Description
Default | 0 | Default file type. WIll save images in a Bitmap file type unless a file pattern ends in an image file format such as .png or .jpeg
Bitmap | 1 | PDF pages will be rendered to windows Bitmap image files.
Jpeg | 2 | PDF pages will be rendered to JPEG image files.
Png | 3 | PDF pages will be rendered to PNG (Portable Network Graphics) image files.
Gif | 4 | PDF pages will be rendered to non-animated GIF image files. The GIF
Tiff | 5 | PDF pages will be rendered to TIFF image files.
See Also

Reference

IronPdf Namespace
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


Installation Class

Global installation and setup preferences for all instances of IronPDF
Inheritance Hierarchy
SystemObject
IronPdfInstallation

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public static class Installation
Public NotInheritable Class Installation
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Installation =  class end

The Installation type exposes the following members.

Properties
Name | Description
TempFolderPath | The temporary folder path which temporary files and rendering engine DLLs will be deployed to where necessary. The default location is the system temp folder which is appropriate for most use cases.
Top
Fields
Name | Description
LegacyIIS | Obsolete. Reduces the risk of locked resources and un-handled interop exceptions within of Microsoft IIS on windows platforms. May for Microsoft IIS versions 7 and lower.
LinuxAndDockerDependenciesAutoConfig | If true The necessary package dependencies for IronPDf rendering will we automatically installed to Docker and Debian / Ubuntu Linux deployments. Applies only to IronPDF for .Net Core. This will take a few minutes the next time you run IronPDF. Watch the Visual Studio "Output" window for progress. Set this to false if manual Docker / Linux setup is more convenient: https://ironpdf.com/docs/questions/docker-linux/
Top
See Also

Reference

IronPdf Namespace
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


Installation Properties

The Installation type exposes the following members.

Properties
Name | Description
TempFolderPath | The temporary folder path which temporary files and rendering engine DLLs will be deployed to where necessary. The default location is the system temp folder which is appropriate for most use cases.
Top
See Also

Reference

Installation Class


Installation.TempFolderPath Property

InstallationTempFolderPath Property

The temporary folder path which temporary files and rendering engine DLLs will be deployed to where necessary. The default location is the system temp folder which is appropriate for most use cases.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public static string TempFolderPath { get; set; }
Public Shared Property TempFolderPath As String
    Get
    Set
static member TempFolderPath : string with get, set

Property Value

Type: String
See Also

Reference

Installation Class


Installation Fields

The Installation type exposes the following members.

Fields
Name | Description
LegacyIIS | Obsolete. Reduces the risk of locked resources and un-handled interop exceptions within of Microsoft IIS on windows platforms. May for Microsoft IIS versions 7 and lower.
LinuxAndDockerDependenciesAutoConfig | If true The necessary package dependencies for IronPDf rendering will we automatically installed to Docker and Debian / Ubuntu Linux deployments. Applies only to IronPDF for .Net Core. This will take a few minutes the next time you run IronPDF. Watch the Visual Studio "Output" window for progress. Set this to false if manual Docker / Linux setup is more convenient: https://ironpdf.com/docs/questions/docker-linux/
Top
See Also

Reference

Installation Class


Installation.LegacyIIS Field

InstallationLegacyIIS Field

Note: This API is now obsolete.

Reduces the risk of locked resources and un-handled interop exceptions within of Microsoft IIS on windows platforms. May for Microsoft IIS versions 7 and lower.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
[ObsoleteAttribute("LegacyIIS mode is functionally obsolete.", false)]
public static bool LegacyIIS
<ObsoleteAttribute("LegacyIIS mode is functionally obsolete.", false)>
Public Shared LegacyIIS As Boolean
[<ObsoleteAttribute("LegacyIIS mode is functionally obsolete.", false)>]
static val mutable LegacyIIS: bool

Field Value

Type: Boolean
See Also

Reference

Installation Class


Installation.LinuxAndDockerDependenciesAutoConfig Field

InstallationLinuxAndDockerDependenciesAutoConfig Field

If true The necessary package dependencies for IronPDf rendering will we automatically installed to Docker and Debian / Ubuntu Linux deployments.

Applies only to IronPDF for .Net Core.

This will take a few minutes the next time you run IronPDF. Watch the Visual Studio "Output" window for progress.

Set this to false if manual Docker / Linux setup is more convenient: https://ironpdf.com/docs/questions/docker-linux/

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public static bool LinuxAndDockerDependenciesAutoConfig
Public Shared LinuxAndDockerDependenciesAutoConfig As Boolean
static val mutable LinuxAndDockerDependenciesAutoConfig: bool

Field Value

Type: Boolean
See Also

Reference

Installation Class


License Class

Allows IronPdf license keys to be applied globally across an application.
Inheritance Hierarchy
SystemObject
IronPdfLicense

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public static class License
Public NotInheritable Class License
[<AbstractClassAttribute>]
[<SealedAttribute>]
type License =  class end

The License type exposes the following members.

Properties
Name | Description
IsLicensed | Determines whether this instance of IronPDF is Licensed. Will return false unless a LicenseKey is set to a valid trial or full license key in IronPdf.License.LicenseKey, Web.Config , App.Config or appsettings.json in .Net Core. See https://ironpdf.com/licensing/ and https://ironpdf.com/docs/license/license-keys/
Top
Methods
Name | Description
IsValidLicense | Determines whether a string license key is valid. See https://ironpdf.com/licensing/ for trial, development and commercial deployment licensing options.
Top
Fields
Name | Description
LicenseKey | Removes watermarks. Get Licensed at http://ironpdf.com/license For .Net framework applications, a license key can alternatively be added to Web.Config or App.Config XML file using <add key="IronPdf.LicenseKey" value="IRONPDF-LICENSE-KEY"/> within the appSettings tag. See https://ironpdf.com/docs/license/license-keys/ For .Net Core applications, a license key may be added to appsettings.json where the key name is "IronPdf.LicenseKey" and the value is a valid IronPDF trial or full license key. See https://ironpdf.com/licensing/ for licensing options.
Top
See Also

Reference

IronPdf Namespace
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


License Properties

The License type exposes the following members.

Properties
Name | Description
IsLicensed | Determines whether this instance of IronPDF is Licensed. Will return false unless a LicenseKey is set to a valid trial or full license key in IronPdf.License.LicenseKey, Web.Config , App.Config or appsettings.json in .Net Core. See https://ironpdf.com/licensing/ and https://ironpdf.com/docs/license/license-keys/
Top
See Also

Reference

License Class


License.IsLicensed Property

LicenseIsLicensed Property

Determines whether this instance of IronPDF is Licensed.

Will return false unless a LicenseKey is set to a valid trial or full license key in IronPdf.License.LicenseKey, Web.Config , App.Config or appsettings.json in .Net Core.

See https://ironpdf.com/licensing/ and https://ironpdf.com/docs/license/license-keys/

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public static bool IsLicensed { get; }
Public Shared ReadOnly Property IsLicensed As Boolean
    Get
static member IsLicensed : bool with get

Return Value

Type: Boolean
True if the license key given is valid.
See Also

Reference

License Class


License Methods

The License type exposes the following members.

Methods
Name | Description
IsValidLicense | Determines whether a string license key is valid. See https://ironpdf.com/licensing/ for trial, development and commercial deployment licensing options.
Top
See Also

Reference

License Class


License.IsValidLicense Method

LicenseIsValidLicense Method

Determines whether a string license key is valid.

See https://ironpdf.com/licensing/ for trial, development and commercial deployment licensing options.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public static bool IsValidLicense(
    string LicenseKey
)
Public Shared Function IsValidLicense (
    LicenseKey As String
) As Boolean
static member IsValidLicense :
        LicenseKey : string -> bool

Parameters

LicenseKey
Type: SystemString
IronPDF license key as a string

Return Value

Type: Boolean
True if the license key given is valid.
See Also

Reference

License Class


License Fields

The License type exposes the following members.

Fields
Name | Description
LicenseKey | Removes watermarks. Get Licensed at http://ironpdf.com/license For .Net framework applications, a license key can alternatively be added to Web.Config or App.Config XML file using <add key="IronPdf.LicenseKey" value="IRONPDF-LICENSE-KEY"/> within the appSettings tag. See https://ironpdf.com/docs/license/license-keys/ For .Net Core applications, a license key may be added to appsettings.json where the key name is "IronPdf.LicenseKey" and the value is a valid IronPDF trial or full license key. See https://ironpdf.com/licensing/ for licensing options.
Top
See Also

Reference

License Class


License.LicenseKey Field

LicenseLicenseKey Field

Removes watermarks. Get Licensed at http://ironpdf.com/license

For .Net framework applications, a license key can alternatively be added to Web.Config or App.Config XML file using <add key="IronPdf.LicenseKey" value="IRONPDF-LICENSE-KEY"/> within the appSettings tag. See https://ironpdf.com/docs/license/license-keys/

For .Net Core applications, a license key may be added to appsettings.json where the key name is "IronPdf.LicenseKey" and the value is a valid IronPDF trial or full license key.

See https://ironpdf.com/licensing/ for licensing options.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public static string LicenseKey
Public Shared LicenseKey As String
static val mutable LicenseKey: string

Field Value

Type: String
See Also

Reference

License Class


PageOrientation Enumeration

Specifies the orientation of a page.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public enum PageOrientation
Public Enumeration PageOrientation
type PageOrientation
Members
Member name | Value | Description
Portrait | 0 | The default page orientation.
Landscape | 1 | The width and height of the page are reversed.
See Also

Reference

IronPdf Namespace
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


PdfBookMark Class

Represents a PDF bookmark as seen in the sidebar of PDF reader software to help user's navigate.
Inheritance Hierarchy
SystemObject
IronPdfPdfBookMark

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public class PdfBookMark
Public Class PdfBookMark
type PdfBookMark =  class end

The PdfBookMark type exposes the following members.

Constructors
 | Name | Description
Public method | PdfBookMark | Initializes a new instance of the PdfBookMark class
Top
Properties
 | Name | Description
Public property | PageIndex | The zero based page number that the bookmark links to.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | IndentLevel | The indent level of the bookmark in the outline. An indent level of 0 represents a bookmark in the root. A bookmark of N will be nested inside the most recent previous bookmark of IndentLevel N-1.
Public field | Text | The display text of the bookmark
Top
See Also

Reference

IronPdf Namespace
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


PdfBookMark Constructor

Initializes a new instance of the PdfBookMark class

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfBookMark()
Public Sub New
new : unit -> PdfBookMark
See Also

Reference

PdfBookMark Class


PdfBookMark Properties

The PdfBookMark type exposes the following members.

Properties
 | Name | Description
Public property | PageIndex | The zero based page number that the bookmark links to.
Top
See Also

Reference

PdfBookMark Class


PdfBookMark.PageIndex Property

PdfBookMarkPageIndex Property

The zero based page number that the bookmark links to.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public int PageIndex { get; set; }
Public Property PageIndex As Integer
    Get
    Set
member PageIndex : int with get, set

Property Value

Type: Int32
The index of the page.
See Also

Reference

PdfBookMark Class


PdfBookMark Methods

The PdfBookMark type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PdfBookMark Class


PdfBookMark Fields

The PdfBookMark type exposes the following members.

Fields
 | Name | Description
Public field | IndentLevel | The indent level of the bookmark in the outline. An indent level of 0 represents a bookmark in the root. A bookmark of N will be nested inside the most recent previous bookmark of IndentLevel N-1.
Public field | Text | The display text of the bookmark
Top
See Also

Reference

PdfBookMark Class


PdfBookMark.IndentLevel Field

PdfBookMarkIndentLevel Field

The indent level of the bookmark in the outline.

An indent level of 0 represents a bookmark in the root. A bookmark of N will be nested inside the most recent previous bookmark of IndentLevel N-1.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public int IndentLevel
Public IndentLevel As Integer
val mutable IndentLevel: int

Field Value

Type: Int32
See Also

Reference

PdfBookMark Class


PdfBookMark.Text Field

PdfBookMarkText Field

The display text of the bookmark

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string Text
Public Text As String
val mutable Text: string

Field Value

Type: String
See Also

Reference

PdfBookMark Class


PdfDocument Class

A PDF Document
Inheritance Hierarchy
SystemObject
IronPdfPdfDocument

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public class PdfDocument
Public Class PdfDocument
type PdfDocument =  class end

The PdfDocument type exposes the following members.

Constructors
 | Name | Description
Public method | PdfDocument(Byte, String, String) | Opens an existing PDF document for editing.
Public method | PdfDocument(Stream, String, String) | Opens an existing PDF document for editing.
Public method | PdfDocument(String, String, String) | Opens an existing PDF document for editing.
Top
Properties
 | Name | Description
Public property | BinaryData | Gets the binary data for the full PDF file as a byte array;
Public property | BookMarks |
Public property | Form | Gets an object returning any PDF editable form fields which can have their values both read and set programmatically.
Public property | MetaData | MetaData information settings for the PDF. Allows File meta-data to be read and set including: Authors, File Dates, Keywords, Title and Subject
Public property | OwnerPassword | Sets the owner password and enables 128Bit encryption of PDF content. An owner password is one used to enable and disable all other security settings. OwnerPassword must be set to a non empty string value for AllowUserCopyPasteContent, AllowUserAnnotations, AllowUserFormData, AllowUserPrinting and AllowUserEdits to be restricted.
Public property | PageCount | Gets the number of pages in the PDF document.
Public property | Pages | Gets the list of pages in the pdf document.
Public property | Password | Sets a Password used to protect and encrypt the PDF File. Setting a password will cause IronPDF to automatically protect the PDF file content using strong 128 bit encryption. Setting the password to null will remove any existing password.
Public property | SecuritySettings | Advanced security settings for the PDF. Allows the developer to control user access passwords, encryption, and also who may edit, print and copy content from the PDF document
Public property | Stream | Gets the binary data for the full PDF file as a Stream
Top
Methods
 | Name | Description
Public method | AddBackgroundPdf(String, Int32) | Adds a background to each page of this PDF. The background is copied from a page in another PDF document.
Public method | AddBackgroundPdf(PdfDocument, Int32) | Adds a background to each page of this PDF. The background is copied from a page in another PDF document.
Public method | AddBackgroundPdfToPage(Int32, PdfDocument, Int32) | Adds the background to one page of this PDF. The background is copied from a page in another PDF document.
Public method | AddBackgroundPdfToPage(Int32, String, Int32) | Adds the background to one page of this PDF. The background is copied from a page in another PDF document.
Public method | AddBackgroundPdfToPageRange(IEnumerableInt32, PdfDocument, Int32) | Adds the background to specified pages of this PDF. The background is copied from a page in another PDF document.
Public method | AddBackgroundPdfToPageRange(IEnumerableInt32, String, Int32) | Adds the background to specified pages of this PDF. The background is copied from a page in another PDF document.
Public method | AddBackgroundPdfToPageRange(Int32, Int32, PdfDocument, Int32) | Adds the background to a range of pages in this PDF. The background is copied from a page in another PDF document.
Public method | AddBackgroundPdfToPageRange(Int32, Int32, String, Int32) | Adds the background to a range of pages in this PDF. The background is copied from a page in another PDF document.
Public method | AddFooters(SimpleHeaderFooter, Boolean, IEnumerableInt32) | Renders page footers to an existing PDF File Margin spacing on the PDF page for the footer are set to default values of 25mm. An overload method allow footer margins to be chosen specifically or set to zero.
Public method | AddFooters(SimpleHeaderFooter, Double, Double, Double, Boolean, IEnumerableInt32) | Renders page footers to an existing PDF File
Public method | AddForegroundOverlayPdf(String, Int32) | Adds an overlay to each page of this PDF. The foreground overlay is copied from a page in another PDF document.
Public method | AddForegroundOverlayPdf(PdfDocument, Int32) | Adds an overlay to each page of this PDF. The foreground overlay is copied from a page in another PDF document.
Public method | AddForegroundOverlayPdfToPage(Int32, PdfDocument, Int32) | Adds an overlay to one page of this PDF. The foreground overlay is copied from a page in another PDF document.
Public method | AddForegroundOverlayPdfToPage(Int32, String, Int32) | Adds an overlay to one page of this PDF. The foreground overlay is copied from a page in another PDF document.
Public method | AddForegroundOverlayPdfToPageRange(IEnumerableInt32, PdfDocument, Int32) | Adds an overlay to a range page of this PDF. The foreground overlay is copied from a page in another PDF document.
Public method | AddForegroundOverlayPdfToPageRange(IEnumerableInt32, String, Int32) | Adds an overlay to a range page of this PDF. The foreground overlay is copied from a page in another PDF document.
Public method | AddForegroundOverlayPdfToPageRange(Int32, Int32, PdfDocument, Int32) | Adds an overlay to a range page of this PDF. The foreground overlay is copied from a page in another PDF document.
Public method | AddForegroundOverlayPdfToPageRange(Int32, Int32, String, Int32) | Adds an overlay to a range page of this PDF. The foreground overlay is copied from a page in another PDF document.
Public method | AddHeaders(SimpleHeaderFooter, Boolean, IEnumerableInt32) | Renders page headers to an existing PDF File Margin spacing on the PDF page for the header are set to default values of 25mm. An overload method allow header margins to be chosen specifically or set to zero.
Public method | AddHeaders(SimpleHeaderFooter, Double, Double, Double, Boolean, IEnumerableInt32) | Renders page headers to an existing PDF File
Public method | AddHTMLFooters(HtmlHeaderFooter, Boolean, IEnumerableInt32) | Renders HTML page footers to an existing PDF File Margin spacing on the PDF page for the footer are set to default values of 25mm. An overload method allow footer margins to be chosen specifically or set to zero.
Public method | AddHTMLFooters(HtmlHeaderFooter, Double, Double, Double, Boolean, IEnumerableInt32) | Renders HTML page footers to an existing PDF File
Public method | AddHTMLHeaders(HtmlHeaderFooter, Boolean, IEnumerableInt32) | Renders HTML page headers to an existing PDF File Margin spacing on the PDF page for the header are set to default values of 25mm. An overload method allow header margins to be chosen specifically or set to zero.
Public method | AddHTMLHeaders(HtmlHeaderFooter, Double, Double, Double, Boolean, IEnumerableInt32) | Renders HTML page headers to an existing PDF File
Public method | AddTextAnnotation(PdfDocumentTextAnnotation, Int32, Int32, Int32, Int32, Int32) | Adds an annotation to a page of this PdfDocument
Public method | AddTextAnnotation(String, String, String, Int32, Int32, Int32, Int32, Int32, PdfDocumentTextAnnotationAnnotationIcon, Boolean, Boolean, Boolean, String, Double) | Adds an annotation to a page of this PdfDocument
Public method | AppendPdf | Appends another PDF to the end of the current PdfDocument
Public method | CopyPage | Creates a new PDF by copying a page from this PdfDocument.
Public method | CopyPages(IEnumerableInt32) | Creates a new PDF by copying a range of pages from this PdfDocument.
Public method | CopyPages(Int32, Int32) | Creates a new PDF by copying a range of pages from this PdfDocument.
Public method | Equals | (Inherited from Object.)
Public method | ExtractAllBitmaps | Finds all embedded Images from within the PDF and returns then as System.Drawing.Bitmap objects
Public method | ExtractAllImages | Finds all embedded Images from within the PDF and returns then as System.Drawing.Image objects
Public method | ExtractAllRawImages | Extracts all images from a PDf document. Images are Returned as their raw data in as Byte Arrays (byte[])
Public method | ExtractAllText | Extracts the written text content from the PDF and returns it as a string. Pages will be separated by 4 consecutive newline characters ("\n\n\n\n")
Public method | ExtractBitmapsFromPage | Finds all embedded Images from within one page of the PDF and returns them as System.Drawing.Bitmap objects
Public method | ExtractBitmapsFromPages(IEnumerableInt32) | Finds all embedded Images from within a specified pages in the PDF and returns them as System.Drawing.Bitmap objects
Public method | ExtractBitmapsFromPages(Int32, Int32) | Finds all embedded Images from within a range of pages in the PDF and returns them as System.Drawing.Bitmap objects
Public method | ExtractImagesFromPage | Finds all embedded Images from within one page of the PDF and returns them as System.Drawing.Image objects
Public method | ExtractImagesFromPages(IEnumerableInt32) | Finds all embedded Images from within a specified pages in the PDF and returns them as System.Drawing.Image objects
Public method | ExtractImagesFromPages(Int32, Int32) | Finds all embedded Images from within a range of pages in the PDF and returns them as System.Drawing.Bitmap objects
Public method | ExtractRawImagesFromPage | Finds all embedded Images from within one page of the PDF and returns them as raw image byte array objects
Public method | ExtractRawImagesFromPages(IEnumerableInt32) | Finds all embedded Images from within a specified pages in the PDF and returns them as System.Drawing.Image objects
Public method | ExtractRawImagesFromPages(Int32, Int32) | Finds all embedded Images from within a range of pages in the PDF and returns them as raw image byte array objects
Public method | ExtractTextFromPage | Extracts the text content from one page of the PDF and returns it as a string.
Public method | ExtractTextFromPages(IEnumerableInt32) | Extracts the written text content from specified pages in the PDF PDF and returns it as a string. Pages will be separated by 4 consecutive newline characters ("\n\n\n\n")
Public method | ExtractTextFromPages(Int32, Int32) | Extracts the written text content from a range of pages within the PDF and returns it as a string. Pages will be separated by 4 consecutive newline characters ("\n\n\n\n")
Public method | Flatten | Flattens a document (make the fields non-editable).
 | FromFile | Opens an existing PDF document for editing.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetPageRotation | Gets the rotation of a PDF page in degrees.
Public method | GetPrintDocument | Returns a PrintDocument for the PDF allowing developers granular control over sending the PDF to a Printer. An assembly reference to System.Drawing is required in your project. Available in IronPDF for .Net Framework, and .Net Core. For Linux and OSX targets please install the PDFium library to your application or bin directory for this functionality to work.
Public method | GetType | (Inherited from Object.)
Public method | InsertPdf | Inserts another PDF into of the current PdfDocument, starting at a given Page Index.
 | Merge(IEnumerablePdfDocument) | Static method that joins (concatenates) multiple PDF documents together into one compiled PDF document.
 | Merge(PdfDocument, PdfDocument) | Static method that joins (concatenates) 2 PDF documents together into one final PDF document.
Public method | PageToBitmap(Int32, Int32) | Renders a single page of the PDF to a System.Drawing.Bitmap object. Please add an assembly reference to System.Drawing to use this "PDF To Image" method Please Dispose() each Bitmap object after use.
Public method | PageToBitmap(Int32, NullableInt32, NullableInt32, Int32) | Renders a single page of the PDF to a System.Drawing.Bitmap object. Please add an assembly reference to System.Drawing to use this "PDF To Image" method Please Dispose() each Bitmap object after use.
Public method | PrependPdf | Adds another PDF to the beginning of the current PdfDocument
Public method | Print | Prints this PDF by sending it to the computer's default printer. Windows print UI dialogs will be displayed to the user. For advanced real-world printing options please see GetPrintDocument. Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Public method | QuickSignPdfWithDigitalSignatureFile | Sign PDF with digital signature certificate. For more advanced Options please see QuickSignPdfWithDigitalSignatureFile(String, String) Note that the PDF will not be fully signed until Saved using SaveAs(String), TrySaveAs(String), Stream or BinaryData. Multiple certificates may be used. Not implemented in .Net Core
Public method | RasterizeToImageFiles(String, ImageType, Int32) | Renders the PDF and exports image Files in convenient formats. 1 image file is created for each page. FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Public method | RasterizeToImageFiles(String, IEnumerableInt32, ImageType, Int32) | Renders the PDF and exports image Files in convenient formats. Page Numbers may be specified. 1 image file is created for each page. FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Public method | RasterizeToImageFiles(String, NullableInt32, NullableInt32, ImageType, Int32) | Renders the PDF and exports image Files in convenient formats. Image dimensions may be specified. 1 image file is created for each page. FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers
Public method | RasterizeToImageFiles(String, IEnumerableInt32, NullableInt32, NullableInt32, ImageType, Int32) | Renders the PDF and exports image Files in convenient formats. Page Numbers may be specified. 1 image file is created for each page. FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Public method | RemovePage | Removes a page from the PDF at the given index.
Public method | RemovePages(IEnumerableInt32) | Removes a range of pages from the PDF
Public method | RemovePages(Int32, Int32) | Removes a range of pages from the PDF
Public method | RotateAllPages | Rotates all pages of the PdfDocument by a specified number of degrees.
Public method | RotatePage | Rotates one page of the PdfDocument by a specified number of degrees.
Public method | RotateSelectedPages | Rotates selected pages of the PdfDocument by a specified number of degrees.
Public method | SaveAs | Saves the PdfDocument to a file. Supports site relative paths staring with "~/" in .Net Framework Web 4+ Applications
Public method | SignPdfWithDigitalSignature | Signs the PDF with digital signature with advanced options. Note that the PDF will not be fully signed until Saved using SaveAs(String), TrySaveAs(String), Stream or BinaryData. Multiple certificates may be used. Not implemented in .Net Core
Public method | StampHTML(HtmlStamp) | Edits the PDF by adding rendered HTML either behind or in-front of the existing contents of every page.
Public method | StampHTML(HtmlStamp, IEnumerableInt32) | Edits the PDF by adding rendered HTML either behind or in-front of the existing contents of specified pages.
Public method | StampHTML(HtmlStamp, Int32) | Edits the PDF by adding rendered HTML either behind or in-front of the existing contents of one page.
Public method | ToBitmap(Int32) | Rasterizes (renders) the PDF into System.Drawing.Bitmap objects. 1 Bitmap for each page. Please add an assembly reference to System.Drawing to use this "PDF To Image" method. Please Dispose() each Bitmap object after use.
Public method | ToBitmap(IEnumerableInt32, Int32) | Rasterizes (renders) the PDF into System.Drawing.Bitmap objects. Specific pages may be selected using the PageNumbers parameter. Please add an assembly reference to System.Drawing to use this "PDF To Image" method Please Dispose() each Bitmap object after use.
Public method | ToBitmap(NullableInt32, NullableInt32, IEnumerableInt32, Int32) | Rasterizes (renders) the PDF into System.Drawing.Bitmap objects. Specific pages may be selected using the PageNumbers parameter. The Widths and Height of the output images may be specified. Please add an assembly reference to System.Drawing to use this "PDF To Image" method Please Dispose() each Bitmap object after use.
Public method | ToJpegImages(String, Int32) | Renders the pages of the PDF as JPEG files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers
Public method | ToJpegImages(String, IEnumerableInt32, Int32) | Renders the pages of the PDF as JPEG files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Public method | ToJpegImages(String, NullableInt32, NullableInt32, Int32) | Renders the pages of the PDF as JPEG files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Public method | ToJpegImages(String, IEnumerableInt32, NullableInt32, NullableInt32, Int32) | Renders the pages of the PDF as JPEG files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers
Public method | ToPngImages(String, Int32) | Renders the pages of the PDF as PNG (Portable Network Graphic) files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers
Public method | ToPngImages(String, IEnumerableInt32, Int32) | Renders the pages of the PDF as PNG (Portable Network Graphic) files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Public method | ToPngImages(String, NullableInt32, NullableInt32, Int32) | Renders the pages of the PDF as PNG (Portable Network Graphic) files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Public method | ToPngImages(String, IEnumerableInt32, NullableInt32, NullableInt32, Int32) | Renders the pages of the PDF as PNG (Portable Network Graphic) files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Public method | ToString | (Inherited from Object.)
Public method | ToTiffImages(String, Int32) | Renders the pages of the PDF as TIFF (Tagged Image File Format / Tif) files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Public method | ToTiffImages(String, IEnumerableInt32, Int32) | Renders the pages of the PDF as TIFF (Tagged Image File Format / Tif) files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Public method | ToTiffImages(String, NullableInt32, NullableInt32, Int32) | Renders the pages of the PDF as TIFF (Tagged Image File Format / Tif) files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers
Public method | ToTiffImages(String, IEnumerableInt32, NullableInt32, NullableInt32, Int32) | Renders the pages of the PDF as TIFF (Tagged Image File Format / Tif) files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers
Public method | TrySaveAs | Attempt to save the PdfDocument to a file.
Public method | VerifyPdfSignatures | Verifies all the PDF signatures for this PDF document and returns true if there are no invalid signatures.
 | VerifyPdfSignaturesInFile | Verifies all the PDF signatures for a PDF file (by file path) and returns true if there are no invalid signatures.
Public method | WatermarkAllPages | Watermarks all pages of this PDF with HTML content. Watermarks are restricted to basic positioning and a 100mm by 100mm maximum size. For more advanced options see StampHTML(HtmlStamp)
Public method | WatermarkPage | Watermarks a single page of this PDF with HTML content. Watermarks are restricted to basic positioning and a 100mm by 100mm maximum size. For more advanced options see StampHTML(HtmlStamp, Int32)
Public method | WatermarkPages | Watermarks all pages of this PDF with HTML content. Watermarks are restricted to basic positioning and a 100mm by 100mm maximum size. For more advanced options see StampHTML(HtmlStamp, IEnumerableInt32)
Top
See Also

Reference

IronPdf Namespace
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


PdfDocument Constructor

Overload List
 | Name | Description
Public method | PdfDocument(Byte, String, String) | Opens an existing PDF document for editing.
Public method | PdfDocument(Stream, String, String) | Opens an existing PDF document for editing.
Public method | PdfDocument(String, String, String) | Opens an existing PDF document for editing.
Top
See Also

Reference

PdfDocument Class


PdfDocument Constructor (Byte[], String, String)

PdfDocument Constructor (Byte, String, String)

Opens an existing PDF document for editing.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument(
    byte[] PdfData,
    string password = null,
    string ownerPassword = null
)
Public Sub New (
    PdfData As Byte(),
    Optional password As String = Nothing,
    Optional ownerPassword As String = Nothing
)
new :
        PdfData : byte[] *
        ?password : string *
        ?ownerPassword : string
(* Defaults:
        let _password = defaultArg password null
        let _ownerPassword = defaultArg ownerPassword null
*)
-> PdfDocument

Parameters

PdfData
Type: SystemByte
The PDF file data as byte array.
password (Optional)
Type: SystemString
Optional user password if the PDF document is encrypted.
ownerPassword (Optional)
Type: SystemString
Optional password if the PDF document is protected by owner (printing, modifying restrictions etc..).
Exceptions
Exception | Condition
IOException | Exception thrown if can not be opened.
See Also

Reference

PdfDocument Class
PdfDocument Overload


PdfDocument Constructor (Stream, String, String)

Opens an existing PDF document for editing.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument(
    Stream PdfDataStream,
    string password = null,
    string ownerPassword = null
)
Public Sub New (
    PdfDataStream As Stream,
    Optional password As String = Nothing,
    Optional ownerPassword As String = Nothing
)
new :
        PdfDataStream : Stream *
        ?password : string *
        ?ownerPassword : string
(* Defaults:
        let _password = defaultArg password null
        let _ownerPassword = defaultArg ownerPassword null
*)
-> PdfDocument

Parameters

PdfDataStream
Type: System.IOStream
The PDF file data as a Stream.
password (Optional)
Type: SystemString
Optional user password if the PDF document is encrypted.
ownerPassword (Optional)
Type: SystemString
Optional password if the PDF document is protected by owner (printing, modifying restrictions etc..).
Exceptions
Exception | Condition
IOException | Exception thrown if can not be opened.
See Also

Reference

PdfDocument Class
PdfDocument Overload


PdfDocument Constructor (String, String, String)

Opens an existing PDF document for editing.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument(
    string PdfFilePath,
    string password = null,
    string ownerPassword = null
)
Public Sub New (
    PdfFilePath As String,
    Optional password As String = Nothing,
    Optional ownerPassword As String = Nothing
)
new :
        PdfFilePath : string *
        ?password : string *
        ?ownerPassword : string
(* Defaults:
        let _password = defaultArg password null
        let _ownerPassword = defaultArg ownerPassword null
*)
-> PdfDocument

Parameters

PdfFilePath
Type: SystemString
The PDF file path.
password (Optional)
Type: SystemString
Optional user password if the PDF document is encrypted.
ownerPassword (Optional)
Type: SystemString
Optional password if the PDF document is protected by owner (printing, modifying restrictions etc..).
Exceptions
Exception | Condition
IOException | Exception thrown if can not be opened.
See Also

Reference

PdfDocument Class
PdfDocument Overload


PdfDocument Properties

The PdfDocument type exposes the following members.

Properties
 | Name | Description
Public property | BinaryData | Gets the binary data for the full PDF file as a byte array;
Public property | BookMarks |
Public property | Form | Gets an object returning any PDF editable form fields which can have their values both read and set programmatically.
Public property | MetaData | MetaData information settings for the PDF. Allows File meta-data to be read and set including: Authors, File Dates, Keywords, Title and Subject
Public property | OwnerPassword | Sets the owner password and enables 128Bit encryption of PDF content. An owner password is one used to enable and disable all other security settings. OwnerPassword must be set to a non empty string value for AllowUserCopyPasteContent, AllowUserAnnotations, AllowUserFormData, AllowUserPrinting and AllowUserEdits to be restricted.
Public property | PageCount | Gets the number of pages in the PDF document.
Public property | Pages | Gets the list of pages in the pdf document.
Public property | Password | Sets a Password used to protect and encrypt the PDF File. Setting a password will cause IronPDF to automatically protect the PDF file content using strong 128 bit encryption. Setting the password to null will remove any existing password.
Public property | SecuritySettings | Advanced security settings for the PDF. Allows the developer to control user access passwords, encryption, and also who may edit, print and copy content from the PDF document
Public property | Stream | Gets the binary data for the full PDF file as a Stream
Top
See Also

Reference

PdfDocument Class


PdfDocument.BinaryData Property

PdfDocumentBinaryData Property

Gets the binary data for the full PDF file as a byte array;

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public byte[] BinaryData { get; }
Public ReadOnly Property BinaryData As Byte()
    Get
member BinaryData : byte[] with get

Property Value

Type: Byte
The PDF file as a byte array.
See Also

Reference

PdfDocument Class


PdfDocument.BookMarks Property

PdfDocumentBookMarks Property

[Missing <summary> documentation for "P:IronPdf.PdfDocument.BookMarks"]

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfOutline BookMarks { get; set; }
Public Property BookMarks As PdfOutline
    Get
    Set
member BookMarks : PdfOutline with get, set

Property Value

Type: PdfOutline
See Also

Reference

PdfDocument Class


PdfDocument.Form Property

PdfDocumentForm Property

Gets an object returning any PDF editable form fields which can have their values both read and set programmatically.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfForm Form { get; }
Public ReadOnly Property Form As PdfForm
    Get
member Form : PdfForm with get

Property Value

Type: PdfForm
The form.
See Also

Reference

PdfDocument Class


PdfDocument.MetaData Property

PdfDocumentMetaData Property

MetaData information settings for the PDF.

Allows File meta-data to be read and set including: Authors, File Dates, Keywords, Title and Subject

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocumentPdfMetaData MetaData { get; }
Public ReadOnly Property MetaData As PdfDocumentPdfMetaData
    Get
member MetaData : PdfDocumentPdfMetaData with get

Property Value

Type: PdfDocumentPdfMetaData
MetaData settings for this PDF as an instance of PdfDocumentPdfMetaData
See Also

Reference

PdfDocument Class


PdfDocument.OwnerPassword Property

PdfDocumentOwnerPassword Property

Sets the owner password and enables 128Bit encryption of PDF content. An owner password is one used to enable and disable all other security settings.

OwnerPassword must be set to a non empty string value for AllowUserCopyPasteContent, AllowUserAnnotations, AllowUserFormData, AllowUserPrinting and AllowUserEdits to be restricted.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string OwnerPassword { get; set; }
Public Property OwnerPassword As String
    Get
    Set
member OwnerPassword : string with get, set

Property Value

Type: String
See Also

Reference

PdfDocument Class


PdfDocument.PageCount Property

PdfDocumentPageCount Property

Gets the number of pages in the PDF document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public int PageCount { get; }
Public ReadOnly Property PageCount As Integer
    Get
member PageCount : int with get

Property Value

Type: Int32
The page count.
See Also

Reference

PdfDocument Class


PdfDocument.Pages Property

PdfDocumentPages Property

Gets the list of pages in the pdf document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfPagesCollection Pages { get; }
Public ReadOnly Property Pages As PdfPagesCollection
    Get
member Pages : PdfPagesCollection with get

Property Value

Type: PdfPagesCollection
See Also

Reference

PdfDocument Class


PdfDocument.Password Property

PdfDocumentPassword Property

Sets a Password used to protect and encrypt the PDF File. Setting a password will cause IronPDF to automatically protect the PDF file content using strong 128 bit encryption. Setting the password to null will remove any existing password.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set
member Password : string with get, set

Property Value

Type: String
See Also

Reference

PdfDocument Class


PdfDocument.SecuritySettings Property

PdfDocumentSecuritySettings Property

Advanced security settings for the PDF.

Allows the developer to control user access passwords, encryption, and also who may edit, print and copy content from the PDF document

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocumentPdfSecuritySettings SecuritySettings { get; }
Public ReadOnly Property SecuritySettings As PdfDocumentPdfSecuritySettings
    Get
member SecuritySettings : PdfDocumentPdfSecuritySettings with get

Property Value

Type: PdfDocumentPdfSecuritySettings
Advanced security settings for this PDF as an instance of PdfDocumentPdfSecuritySettings
See Also

Reference

PdfDocument Class


PdfDocument.Stream Property

PdfDocumentStream Property

Gets the binary data for the full PDF file as a Stream

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public MemoryStream Stream { get; }
Public ReadOnly Property Stream As MemoryStream
    Get
member Stream : MemoryStream with get

Property Value

Type: MemoryStream
The PDF file as a MemoryStream
See Also

Reference

PdfDocument Class


PdfDocument Methods

The PdfDocument type exposes the following members.

Methods
 | Name | Description
Public method | AddBackgroundPdf(String, Int32) | Adds a background to each page of this PDF. The background is copied from a page in another PDF document.
Public method | AddBackgroundPdf(PdfDocument, Int32) | Adds a background to each page of this PDF. The background is copied from a page in another PDF document.
Public method | AddBackgroundPdfToPage(Int32, PdfDocument, Int32) | Adds the background to one page of this PDF. The background is copied from a page in another PDF document.
Public method | AddBackgroundPdfToPage(Int32, String, Int32) | Adds the background to one page of this PDF. The background is copied from a page in another PDF document.
Public method | AddBackgroundPdfToPageRange(IEnumerableInt32, PdfDocument, Int32) | Adds the background to specified pages of this PDF. The background is copied from a page in another PDF document.
Public method | AddBackgroundPdfToPageRange(IEnumerableInt32, String, Int32) | Adds the background to specified pages of this PDF. The background is copied from a page in another PDF document.
Public method | AddBackgroundPdfToPageRange(Int32, Int32, PdfDocument, Int32) | Adds the background to a range of pages in this PDF. The background is copied from a page in another PDF document.
Public method | AddBackgroundPdfToPageRange(Int32, Int32, String, Int32) | Adds the background to a range of pages in this PDF. The background is copied from a page in another PDF document.
Public method | AddFooters(SimpleHeaderFooter, Boolean, IEnumerableInt32) | Renders page footers to an existing PDF File Margin spacing on the PDF page for the footer are set to default values of 25mm. An overload method allow footer margins to be chosen specifically or set to zero.
Public method | AddFooters(SimpleHeaderFooter, Double, Double, Double, Boolean, IEnumerableInt32) | Renders page footers to an existing PDF File
Public method | AddForegroundOverlayPdf(String, Int32) | Adds an overlay to each page of this PDF. The foreground overlay is copied from a page in another PDF document.
Public method | AddForegroundOverlayPdf(PdfDocument, Int32) | Adds an overlay to each page of this PDF. The foreground overlay is copied from a page in another PDF document.
Public method | AddForegroundOverlayPdfToPage(Int32, PdfDocument, Int32) | Adds an overlay to one page of this PDF. The foreground overlay is copied from a page in another PDF document.
Public method | AddForegroundOverlayPdfToPage(Int32, String, Int32) | Adds an overlay to one page of this PDF. The foreground overlay is copied from a page in another PDF document.
Public method | AddForegroundOverlayPdfToPageRange(IEnumerableInt32, PdfDocument, Int32) | Adds an overlay to a range page of this PDF. The foreground overlay is copied from a page in another PDF document.
Public method | AddForegroundOverlayPdfToPageRange(IEnumerableInt32, String, Int32) | Adds an overlay to a range page of this PDF. The foreground overlay is copied from a page in another PDF document.
Public method | AddForegroundOverlayPdfToPageRange(Int32, Int32, PdfDocument, Int32) | Adds an overlay to a range page of this PDF. The foreground overlay is copied from a page in another PDF document.
Public method | AddForegroundOverlayPdfToPageRange(Int32, Int32, String, Int32) | Adds an overlay to a range page of this PDF. The foreground overlay is copied from a page in another PDF document.
Public method | AddHeaders(SimpleHeaderFooter, Boolean, IEnumerableInt32) | Renders page headers to an existing PDF File Margin spacing on the PDF page for the header are set to default values of 25mm. An overload method allow header margins to be chosen specifically or set to zero.
Public method | AddHeaders(SimpleHeaderFooter, Double, Double, Double, Boolean, IEnumerableInt32) | Renders page headers to an existing PDF File
Public method | AddHTMLFooters(HtmlHeaderFooter, Boolean, IEnumerableInt32) | Renders HTML page footers to an existing PDF File Margin spacing on the PDF page for the footer are set to default values of 25mm. An overload method allow footer margins to be chosen specifically or set to zero.
Public method | AddHTMLFooters(HtmlHeaderFooter, Double, Double, Double, Boolean, IEnumerableInt32) | Renders HTML page footers to an existing PDF File
Public method | AddHTMLHeaders(HtmlHeaderFooter, Boolean, IEnumerableInt32) | Renders HTML page headers to an existing PDF File Margin spacing on the PDF page for the header are set to default values of 25mm. An overload method allow header margins to be chosen specifically or set to zero.
Public method | AddHTMLHeaders(HtmlHeaderFooter, Double, Double, Double, Boolean, IEnumerableInt32) | Renders HTML page headers to an existing PDF File
Public method | AddTextAnnotation(PdfDocumentTextAnnotation, Int32, Int32, Int32, Int32, Int32) | Adds an annotation to a page of this PdfDocument
Public method | AddTextAnnotation(String, String, String, Int32, Int32, Int32, Int32, Int32, PdfDocumentTextAnnotationAnnotationIcon, Boolean, Boolean, Boolean, String, Double) | Adds an annotation to a page of this PdfDocument
Public method | AppendPdf | Appends another PDF to the end of the current PdfDocument
Public method | CopyPage | Creates a new PDF by copying a page from this PdfDocument.
Public method | CopyPages(IEnumerableInt32) | Creates a new PDF by copying a range of pages from this PdfDocument.
Public method | CopyPages(Int32, Int32) | Creates a new PDF by copying a range of pages from this PdfDocument.
Public method | Equals | (Inherited from Object.)
Public method | ExtractAllBitmaps | Finds all embedded Images from within the PDF and returns then as System.Drawing.Bitmap objects
Public method | ExtractAllImages | Finds all embedded Images from within the PDF and returns then as System.Drawing.Image objects
Public method | ExtractAllRawImages | Extracts all images from a PDf document. Images are Returned as their raw data in as Byte Arrays (byte[])
Public method | ExtractAllText | Extracts the written text content from the PDF and returns it as a string. Pages will be separated by 4 consecutive newline characters ("\n\n\n\n")
Public method | ExtractBitmapsFromPage | Finds all embedded Images from within one page of the PDF and returns them as System.Drawing.Bitmap objects
Public method | ExtractBitmapsFromPages(IEnumerableInt32) | Finds all embedded Images from within a specified pages in the PDF and returns them as System.Drawing.Bitmap objects
Public method | ExtractBitmapsFromPages(Int32, Int32) | Finds all embedded Images from within a range of pages in the PDF and returns them as System.Drawing.Bitmap objects
Public method | ExtractImagesFromPage | Finds all embedded Images from within one page of the PDF and returns them as System.Drawing.Image objects
Public method | ExtractImagesFromPages(IEnumerableInt32) | Finds all embedded Images from within a specified pages in the PDF and returns them as System.Drawing.Image objects
Public method | ExtractImagesFromPages(Int32, Int32) | Finds all embedded Images from within a range of pages in the PDF and returns them as System.Drawing.Bitmap objects
Public method | ExtractRawImagesFromPage | Finds all embedded Images from within one page of the PDF and returns them as raw image byte array objects
Public method | ExtractRawImagesFromPages(IEnumerableInt32) | Finds all embedded Images from within a specified pages in the PDF and returns them as System.Drawing.Image objects
Public method | ExtractRawImagesFromPages(Int32, Int32) | Finds all embedded Images from within a range of pages in the PDF and returns them as raw image byte array objects
Public method | ExtractTextFromPage | Extracts the text content from one page of the PDF and returns it as a string.
Public method | ExtractTextFromPages(IEnumerableInt32) | Extracts the written text content from specified pages in the PDF PDF and returns it as a string. Pages will be separated by 4 consecutive newline characters ("\n\n\n\n")
Public method | ExtractTextFromPages(Int32, Int32) | Extracts the written text content from a range of pages within the PDF and returns it as a string. Pages will be separated by 4 consecutive newline characters ("\n\n\n\n")
Public method | Flatten | Flattens a document (make the fields non-editable).
 | FromFile | Opens an existing PDF document for editing.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetPageRotation | Gets the rotation of a PDF page in degrees.
Public method | GetPrintDocument | Returns a PrintDocument for the PDF allowing developers granular control over sending the PDF to a Printer. An assembly reference to System.Drawing is required in your project. Available in IronPDF for .Net Framework, and .Net Core. For Linux and OSX targets please install the PDFium library to your application or bin directory for this functionality to work.
Public method | GetType | (Inherited from Object.)
Public method | InsertPdf | Inserts another PDF into of the current PdfDocument, starting at a given Page Index.
 | Merge(IEnumerablePdfDocument) | Static method that joins (concatenates) multiple PDF documents together into one compiled PDF document.
 | Merge(PdfDocument, PdfDocument) | Static method that joins (concatenates) 2 PDF documents together into one final PDF document.
Public method | PageToBitmap(Int32, Int32) | Renders a single page of the PDF to a System.Drawing.Bitmap object. Please add an assembly reference to System.Drawing to use this "PDF To Image" method Please Dispose() each Bitmap object after use.
Public method | PageToBitmap(Int32, NullableInt32, NullableInt32, Int32) | Renders a single page of the PDF to a System.Drawing.Bitmap object. Please add an assembly reference to System.Drawing to use this "PDF To Image" method Please Dispose() each Bitmap object after use.
Public method | PrependPdf | Adds another PDF to the beginning of the current PdfDocument
Public method | Print | Prints this PDF by sending it to the computer's default printer. Windows print UI dialogs will be displayed to the user. For advanced real-world printing options please see GetPrintDocument. Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Public method | QuickSignPdfWithDigitalSignatureFile | Sign PDF with digital signature certificate. For more advanced Options please see QuickSignPdfWithDigitalSignatureFile(String, String) Note that the PDF will not be fully signed until Saved using SaveAs(String), TrySaveAs(String), Stream or BinaryData. Multiple certificates may be used. Not implemented in .Net Core
Public method | RasterizeToImageFiles(String, ImageType, Int32) | Renders the PDF and exports image Files in convenient formats. 1 image file is created for each page. FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Public method | RasterizeToImageFiles(String, IEnumerableInt32, ImageType, Int32) | Renders the PDF and exports image Files in convenient formats. Page Numbers may be specified. 1 image file is created for each page. FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Public method | RasterizeToImageFiles(String, NullableInt32, NullableInt32, ImageType, Int32) | Renders the PDF and exports image Files in convenient formats. Image dimensions may be specified. 1 image file is created for each page. FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers
Public method | RasterizeToImageFiles(String, IEnumerableInt32, NullableInt32, NullableInt32, ImageType, Int32) | Renders the PDF and exports image Files in convenient formats. Page Numbers may be specified. 1 image file is created for each page. FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Public method | RemovePage | Removes a page from the PDF at the given index.
Public method | RemovePages(IEnumerableInt32) | Removes a range of pages from the PDF
Public method | RemovePages(Int32, Int32) | Removes a range of pages from the PDF
Public method | RotateAllPages | Rotates all pages of the PdfDocument by a specified number of degrees.
Public method | RotatePage | Rotates one page of the PdfDocument by a specified number of degrees.
Public method | RotateSelectedPages | Rotates selected pages of the PdfDocument by a specified number of degrees.
Public method | SaveAs | Saves the PdfDocument to a file. Supports site relative paths staring with "~/" in .Net Framework Web 4+ Applications
Public method | SignPdfWithDigitalSignature | Signs the PDF with digital signature with advanced options. Note that the PDF will not be fully signed until Saved using SaveAs(String), TrySaveAs(String), Stream or BinaryData. Multiple certificates may be used. Not implemented in .Net Core
Public method | StampHTML(HtmlStamp) | Edits the PDF by adding rendered HTML either behind or in-front of the existing contents of every page.
Public method | StampHTML(HtmlStamp, IEnumerableInt32) | Edits the PDF by adding rendered HTML either behind or in-front of the existing contents of specified pages.
Public method | StampHTML(HtmlStamp, Int32) | Edits the PDF by adding rendered HTML either behind or in-front of the existing contents of one page.
Public method | ToBitmap(Int32) | Rasterizes (renders) the PDF into System.Drawing.Bitmap objects. 1 Bitmap for each page. Please add an assembly reference to System.Drawing to use this "PDF To Image" method. Please Dispose() each Bitmap object after use.
Public method | ToBitmap(IEnumerableInt32, Int32) | Rasterizes (renders) the PDF into System.Drawing.Bitmap objects. Specific pages may be selected using the PageNumbers parameter. Please add an assembly reference to System.Drawing to use this "PDF To Image" method Please Dispose() each Bitmap object after use.
Public method | ToBitmap(NullableInt32, NullableInt32, IEnumerableInt32, Int32) | Rasterizes (renders) the PDF into System.Drawing.Bitmap objects. Specific pages may be selected using the PageNumbers parameter. The Widths and Height of the output images may be specified. Please add an assembly reference to System.Drawing to use this "PDF To Image" method Please Dispose() each Bitmap object after use.
Public method | ToJpegImages(String, Int32) | Renders the pages of the PDF as JPEG files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers
Public method | ToJpegImages(String, IEnumerableInt32, Int32) | Renders the pages of the PDF as JPEG files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Public method | ToJpegImages(String, NullableInt32, NullableInt32, Int32) | Renders the pages of the PDF as JPEG files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Public method | ToJpegImages(String, IEnumerableInt32, NullableInt32, NullableInt32, Int32) | Renders the pages of the PDF as JPEG files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers
Public method | ToPngImages(String, Int32) | Renders the pages of the PDF as PNG (Portable Network Graphic) files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers
Public method | ToPngImages(String, IEnumerableInt32, Int32) | Renders the pages of the PDF as PNG (Portable Network Graphic) files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Public method | ToPngImages(String, NullableInt32, NullableInt32, Int32) | Renders the pages of the PDF as PNG (Portable Network Graphic) files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Public method | ToPngImages(String, IEnumerableInt32, NullableInt32, NullableInt32, Int32) | Renders the pages of the PDF as PNG (Portable Network Graphic) files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Public method | ToString | (Inherited from Object.)
Public method | ToTiffImages(String, Int32) | Renders the pages of the PDF as TIFF (Tagged Image File Format / Tif) files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Public method | ToTiffImages(String, IEnumerableInt32, Int32) | Renders the pages of the PDF as TIFF (Tagged Image File Format / Tif) files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Public method | ToTiffImages(String, NullableInt32, NullableInt32, Int32) | Renders the pages of the PDF as TIFF (Tagged Image File Format / Tif) files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers
Public method | ToTiffImages(String, IEnumerableInt32, NullableInt32, NullableInt32, Int32) | Renders the pages of the PDF as TIFF (Tagged Image File Format / Tif) files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers
Public method | TrySaveAs | Attempt to save the PdfDocument to a file.
Public method | VerifyPdfSignatures | Verifies all the PDF signatures for this PDF document and returns true if there are no invalid signatures.
 | VerifyPdfSignaturesInFile | Verifies all the PDF signatures for a PDF file (by file path) and returns true if there are no invalid signatures.
Public method | WatermarkAllPages | Watermarks all pages of this PDF with HTML content. Watermarks are restricted to basic positioning and a 100mm by 100mm maximum size. For more advanced options see StampHTML(HtmlStamp)
Public method | WatermarkPage | Watermarks a single page of this PDF with HTML content. Watermarks are restricted to basic positioning and a 100mm by 100mm maximum size. For more advanced options see StampHTML(HtmlStamp, Int32)
Public method | WatermarkPages | Watermarks all pages of this PDF with HTML content. Watermarks are restricted to basic positioning and a 100mm by 100mm maximum size. For more advanced options see StampHTML(HtmlStamp, IEnumerableInt32)
Top
See Also

Reference

PdfDocument Class


PdfDocument.AddBackgroundPdf Method

PdfDocumentAddBackgroundPdf Method

Overload List
 | Name | Description
Public method | AddBackgroundPdf(String, Int32) | Adds a background to each page of this PDF. The background is copied from a page in another PDF document.
Public method | AddBackgroundPdf(PdfDocument, Int32) | Adds a background to each page of this PDF. The background is copied from a page in another PDF document.
Top
See Also

Reference

PdfDocument Class


PdfDocument.AddBackgroundPdf Method (String, Int32)

PdfDocumentAddBackgroundPdf Method (String, Int32)

Adds a background to each page of this PDF. The background is copied from a page in another PDF document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument AddBackgroundPdf(
    string BackgroundPdfPath,
    int BackgroundPdfPageIndex = 0
)
Public Function AddBackgroundPdf (
    BackgroundPdfPath As String,
    Optional BackgroundPdfPageIndex As Integer = 0
) As PdfDocument
member AddBackgroundPdf :
        BackgroundPdfPath : string *
        ?BackgroundPdfPageIndex : int
(* Defaults:
        let _BackgroundPdfPageIndex = defaultArg BackgroundPdfPageIndex 0
*)
-> PdfDocument

Parameters

BackgroundPdfPath
Type: SystemString
The background PDF's file path.
BackgroundPdfPageIndex (Optional)
Type: SystemInt32
Index (zero-based page number) to copy from the BackgroundPdf.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class
AddBackgroundPdf Overload


PdfDocument.AddBackgroundPdf Method (PdfDocument, Int32)

PdfDocumentAddBackgroundPdf Method (PdfDocument, Int32)

Adds a background to each page of this PDF. The background is copied from a page in another PDF document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument AddBackgroundPdf(
    PdfDocument BackgroundPdf,
    int BackgroundPdfPageIndex = 0
)
Public Function AddBackgroundPdf (
    BackgroundPdf As PdfDocument,
    Optional BackgroundPdfPageIndex As Integer = 0
) As PdfDocument
member AddBackgroundPdf :
        BackgroundPdf : PdfDocument *
        ?BackgroundPdfPageIndex : int
(* Defaults:
        let _BackgroundPdfPageIndex = defaultArg BackgroundPdfPageIndex 0
*)
-> PdfDocument

Parameters

BackgroundPdf
Type: IronPdfPdfDocument
The Background PDF as a PdfDocument.
BackgroundPdfPageIndex (Optional)
Type: SystemInt32
Index (zero-based page number) to copy from the BackgroundPdf.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class
AddBackgroundPdf Overload


PdfDocument.AddBackgroundPdfToPage Method

PdfDocumentAddBackgroundPdfToPage Method

Overload List
 | Name | Description
Public method | AddBackgroundPdfToPage(Int32, PdfDocument, Int32) | Adds the background to one page of this PDF. The background is copied from a page in another PDF document.
Public method | AddBackgroundPdfToPage(Int32, String, Int32) | Adds the background to one page of this PDF. The background is copied from a page in another PDF document.
Top
See Also

Reference

PdfDocument Class


PdfDocument.AddBackgroundPdfToPage Method (Int32, PdfDocument, Int32)

PdfDocumentAddBackgroundPdfToPage Method (Int32, PdfDocument, Int32)

Adds the background to one page of this PDF. The background is copied from a page in another PDF document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument AddBackgroundPdfToPage(
    int ToPageIndex,
    PdfDocument BackgroundPdf,
    int BackgroundPdfPageIndex = 0
)
Public Function AddBackgroundPdfToPage (
    ToPageIndex As Integer,
    BackgroundPdf As PdfDocument,
    Optional BackgroundPdfPageIndex As Integer = 0
) As PdfDocument
member AddBackgroundPdfToPage :
        ToPageIndex : int *
        BackgroundPdf : PdfDocument *
        ?BackgroundPdfPageIndex : int
(* Defaults:
        let _BackgroundPdfPageIndex = defaultArg BackgroundPdfPageIndex 0
*)
-> PdfDocument

Parameters

ToPageIndex
Type: SystemInt32
Index (zero-based page number) of the page of this PDF to which the background will be applied to.
BackgroundPdf
Type: IronPdfPdfDocument
The Background PDF as a PdfDocument.
BackgroundPdfPageIndex (Optional)
Type: SystemInt32
Index (zero-based page number) to copy from the BackgroundPdf.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class
AddBackgroundPdfToPage Overload


PdfDocument.AddBackgroundPdfToPage Method (Int32, String, Int32)

PdfDocumentAddBackgroundPdfToPage Method (Int32, String, Int32)

Adds the background to one page of this PDF. The background is copied from a page in another PDF document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument AddBackgroundPdfToPage(
    int ToPageIndex,
    string BackgroundPdfPath,
    int BackgroundPdfPageIndex = 0
)
Public Function AddBackgroundPdfToPage (
    ToPageIndex As Integer,
    BackgroundPdfPath As String,
    Optional BackgroundPdfPageIndex As Integer = 0
) As PdfDocument
member AddBackgroundPdfToPage :
        ToPageIndex : int *
        BackgroundPdfPath : string *
        ?BackgroundPdfPageIndex : int
(* Defaults:
        let _BackgroundPdfPageIndex = defaultArg BackgroundPdfPageIndex 0
*)
-> PdfDocument

Parameters

ToPageIndex
Type: SystemInt32
Index (zero-based page number) of the page of this PDF to which the background will be applied to.
BackgroundPdfPath
Type: SystemString
The background PDF path.
BackgroundPdfPageIndex (Optional)
Type: SystemInt32
Index (zero-based page number) to copy from the BackgroundPdf.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class
AddBackgroundPdfToPage Overload


PdfDocument.AddBackgroundPdfToPageRange Method

PdfDocumentAddBackgroundPdfToPageRange Method

Overload List
 | Name | Description
Public method | AddBackgroundPdfToPageRange(IEnumerableInt32, PdfDocument, Int32) | Adds the background to specified pages of this PDF. The background is copied from a page in another PDF document.
Public method | AddBackgroundPdfToPageRange(IEnumerableInt32, String, Int32) | Adds the background to specified pages of this PDF. The background is copied from a page in another PDF document.
Public method | AddBackgroundPdfToPageRange(Int32, Int32, PdfDocument, Int32) | Adds the background to a range of pages in this PDF. The background is copied from a page in another PDF document.
Public method | AddBackgroundPdfToPageRange(Int32, Int32, String, Int32) | Adds the background to a range of pages in this PDF. The background is copied from a page in another PDF document.
Top
See Also

Reference

PdfDocument Class


PdfDocument.AddBackgroundPdfToPageRange Method (IEnumerable(Int32), PdfDocument, Int32)

PdfDocumentAddBackgroundPdfToPageRange Method (IEnumerableInt32, PdfDocument, Int32)

Adds the background to specified pages of this PDF. The background is copied from a page in another PDF document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument AddBackgroundPdfToPageRange(
    IEnumerable<int> ToPageIndexes,
    PdfDocument BackgroundPdf,
    int BackgroundPdfPageIndex = 0
)
Public Function AddBackgroundPdfToPageRange (
    ToPageIndexes As IEnumerable(Of Integer),
    BackgroundPdf As PdfDocument,
    Optional BackgroundPdfPageIndex As Integer = 0
) As PdfDocument
member AddBackgroundPdfToPageRange :
        ToPageIndexes : IEnumerable<int> *
        BackgroundPdf : PdfDocument *
        ?BackgroundPdfPageIndex : int
(* Defaults:
        let _BackgroundPdfPageIndex = defaultArg BackgroundPdfPageIndex 0
*)
-> PdfDocument

Parameters

ToPageIndexes
Type: System.Collections.GenericIEnumerable Int32
A list of Indexes (zero-based page numbers) of pages in this PDF to which the background will be applied to.
BackgroundPdf
Type: IronPdfPdfDocument
The Background PDF as a PdfDocument.
BackgroundPdfPageIndex (Optional)
Type: SystemInt32
Index (zero-based page number) to copy from the BackgroundPdf.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class
AddBackgroundPdfToPageRange Overload


PdfDocument.AddBackgroundPdfToPageRange Method (IEnumerable(Int32), String, Int32)

PdfDocumentAddBackgroundPdfToPageRange Method (IEnumerableInt32, String, Int32)

Adds the background to specified pages of this PDF. The background is copied from a page in another PDF document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument AddBackgroundPdfToPageRange(
    IEnumerable<int> ToPageIndexes,
    string BackgroundPdfPath,
    int BackgroundPdfPageIndex = 0
)
Public Function AddBackgroundPdfToPageRange (
    ToPageIndexes As IEnumerable(Of Integer),
    BackgroundPdfPath As String,
    Optional BackgroundPdfPageIndex As Integer = 0
) As PdfDocument
member AddBackgroundPdfToPageRange :
        ToPageIndexes : IEnumerable<int> *
        BackgroundPdfPath : string *
        ?BackgroundPdfPageIndex : int
(* Defaults:
        let _BackgroundPdfPageIndex = defaultArg BackgroundPdfPageIndex 0
*)
-> PdfDocument

Parameters

ToPageIndexes
Type: System.Collections.GenericIEnumerable Int32
A list of Indexes (zero-based page numbers) of pages in this PDF to which the background will be applied to.
BackgroundPdfPath
Type: SystemString
The background PDF path.
BackgroundPdfPageIndex (Optional)
Type: SystemInt32
Index (zero-based page number) to copy from the BackgroundPdf.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class
AddBackgroundPdfToPageRange Overload


PdfDocument.AddBackgroundPdfToPageRange Method (Int32, Int32, PdfDocument, Int32)

PdfDocumentAddBackgroundPdfToPageRange Method (Int32, Int32, PdfDocument, Int32)

Adds the background to a range of pages in this PDF. The background is copied from a page in another PDF document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument AddBackgroundPdfToPageRange(
    int StartPageIndex,
    int EndPageIndex,
    PdfDocument BackgroundPdf,
    int BackgroundPdfPageIndex = 0
)
Public Function AddBackgroundPdfToPageRange (
    StartPageIndex As Integer,
    EndPageIndex As Integer,
    BackgroundPdf As PdfDocument,
    Optional BackgroundPdfPageIndex As Integer = 0
) As PdfDocument
member AddBackgroundPdfToPageRange :
        StartPageIndex : int *
        EndPageIndex : int *
        BackgroundPdf : PdfDocument *
        ?BackgroundPdfPageIndex : int
(* Defaults:
        let _BackgroundPdfPageIndex = defaultArg BackgroundPdfPageIndex 0
*)
-> PdfDocument

Parameters

StartPageIndex
Type: SystemInt32
First index (zero-based page number) to start adding backgrounds to .
EndPageIndex
Type: SystemInt32
Last index (zero-based page number) to end adding backgrounds to.
BackgroundPdf
Type: IronPdfPdfDocument
The Background PDF as a PdfDocument.
BackgroundPdfPageIndex (Optional)
Type: SystemInt32
Index (zero-based page number) to copy from the BackgroundPdf.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class
AddBackgroundPdfToPageRange Overload


PdfDocument.AddBackgroundPdfToPageRange Method (Int32, Int32, String, Int32)

PdfDocumentAddBackgroundPdfToPageRange Method (Int32, Int32, String, Int32)

Adds the background to a range of pages in this PDF. The background is copied from a page in another PDF document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument AddBackgroundPdfToPageRange(
    int StartPageIndex,
    int EndPageIndex,
    string BackgroundPdfPath,
    int BackgroundPdfPageIndex = 0
)
Public Function AddBackgroundPdfToPageRange (
    StartPageIndex As Integer,
    EndPageIndex As Integer,
    BackgroundPdfPath As String,
    Optional BackgroundPdfPageIndex As Integer = 0
) As PdfDocument
member AddBackgroundPdfToPageRange :
        StartPageIndex : int *
        EndPageIndex : int *
        BackgroundPdfPath : string *
        ?BackgroundPdfPageIndex : int
(* Defaults:
        let _BackgroundPdfPageIndex = defaultArg BackgroundPdfPageIndex 0
*)
-> PdfDocument

Parameters

StartPageIndex
Type: SystemInt32
First index (zero-based page number) to start adding backgrounds to .
EndPageIndex
Type: SystemInt32
Last index (zero-based page number) to end adding backgrounds to.
BackgroundPdfPath
Type: SystemString
The background PDF path.
BackgroundPdfPageIndex (Optional)
Type: SystemInt32
Index (zero-based page number) to copy from the BackgroundPdf.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class
AddBackgroundPdfToPageRange Overload


PdfDocument.AddFooters Method

PdfDocumentAddFooters Method

Overload List
 | Name | Description
Public method | AddFooters(SimpleHeaderFooter, Boolean, IEnumerableInt32) | Renders page footers to an existing PDF File Margin spacing on the PDF page for the footer are set to default values of 25mm. An overload method allow footer margins to be chosen specifically or set to zero.
Public method | AddFooters(SimpleHeaderFooter, Double, Double, Double, Boolean, IEnumerableInt32) | Renders page footers to an existing PDF File
Top
See Also

Reference

PdfDocument Class


PdfDocument.AddFooters Method (SimpleHeaderFooter, Boolean, IEnumerable(Int32))

PdfDocumentAddFooters Method (SimpleHeaderFooter, Boolean, IEnumerableInt32)

Renders page footers to an existing PDF File

Margin spacing on the PDF page for the footer are set to default values of 25mm. An overload method allow footer margins to be chosen specifically or set to zero.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument AddFooters(
    SimpleHeaderFooter Footer,
    bool SkipFirstPage = false,
    IEnumerable<int> PageIndexesToAddFootersTo = null
)
Public Function AddFooters (
    Footer As SimpleHeaderFooter,
    Optional SkipFirstPage As Boolean = false,
    Optional PageIndexesToAddFootersTo As IEnumerable(Of Integer) = Nothing
) As PdfDocument
member AddFooters :
        Footer : SimpleHeaderFooter *
        ?SkipFirstPage : bool *
        ?PageIndexesToAddFootersTo : IEnumerable<int>
(* Defaults:
        let _SkipFirstPage = defaultArg SkipFirstPage false
        let _PageIndexesToAddFootersTo = defaultArg PageIndexesToAddFootersTo null
*)
-> PdfDocument

Parameters

Footer
Type: IronPdfSimpleHeaderFooter
An new instance of IronPdf.SimpleHeaderFooter that defines the footer content and layout.
SkipFirstPage (Optional)
Type: SystemBoolean
if set to true, the first (cover) page is not counted or stamped with a footer.
PageIndexesToAddFootersTo (Optional)
Type: System.Collections.GenericIEnumerable Int32
Optional. The PageIndexes (zero-based page numbers) to which the footer will be added.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class
AddFooters Overload


PdfDocument.AddFooters Method (SimpleHeaderFooter, Double, Double, Double, Boolean, IEnumerable(Int32))

PdfDocumentAddFooters Method (SimpleHeaderFooter, Double, Double, Double, Boolean, IEnumerableInt32)

Renders page footers to an existing PDF File

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument AddFooters(
    SimpleHeaderFooter Footer,
    double MarginLeft,
    double MarginRight,
    double MarginBottom,
    bool SkipFirstPage = false,
    IEnumerable<int> PageIndexesToAddFootersTo = null
)
Public Function AddFooters (
    Footer As SimpleHeaderFooter,
    MarginLeft As Double,
    MarginRight As Double,
    MarginBottom As Double,
    Optional SkipFirstPage As Boolean = false,
    Optional PageIndexesToAddFootersTo As IEnumerable(Of Integer) = Nothing
) As PdfDocument
member AddFooters :
        Footer : SimpleHeaderFooter *
        MarginLeft : float *
        MarginRight : float *
        MarginBottom : float *
        ?SkipFirstPage : bool *
        ?PageIndexesToAddFootersTo : IEnumerable<int>
(* Defaults:
        let _SkipFirstPage = defaultArg SkipFirstPage false
        let _PageIndexesToAddFootersTo = defaultArg PageIndexesToAddFootersTo null
*)
-> PdfDocument

Parameters

Footer
Type: IronPdfSimpleHeaderFooter
An new instance of IronPdf.SimpleHeaderFooter that defines the footer content and layout.
MarginLeft
Type: SystemDouble
The left margin of the footer on the page in mm.
MarginRight
Type: SystemDouble
The right margin of the footer on the page in mm.
MarginBottom
Type: SystemDouble
The bottom margin of the footer on the page in mm.
SkipFirstPage (Optional)
Type: SystemBoolean
if set to true, the first (cover) page is not counted or stamped with a footer.
PageIndexesToAddFootersTo (Optional)
Type: System.Collections.GenericIEnumerable Int32
Optional. The PageIndexes (zero-based page numbers) to which the footer will be added.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class
AddFooters Overload


PdfDocument.AddForegroundOverlayPdf Method

PdfDocumentAddForegroundOverlayPdf Method

Overload List
 | Name | Description
Public method | AddForegroundOverlayPdf(String, Int32) | Adds an overlay to each page of this PDF. The foreground overlay is copied from a page in another PDF document.
Public method | AddForegroundOverlayPdf(PdfDocument, Int32) | Adds an overlay to each page of this PDF. The foreground overlay is copied from a page in another PDF document.
Top
See Also

Reference

PdfDocument Class


PdfDocument.AddForegroundOverlayPdf Method (String, Int32)

PdfDocumentAddForegroundOverlayPdf Method (String, Int32)

Adds an overlay to each page of this PDF. The foreground overlay is copied from a page in another PDF document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument AddForegroundOverlayPdf(
    string OverlayPdfPath,
    int OverlayPdfPageIndex = 0
)
Public Function AddForegroundOverlayPdf (
    OverlayPdfPath As String,
    Optional OverlayPdfPageIndex As Integer = 0
) As PdfDocument
member AddForegroundOverlayPdf :
        OverlayPdfPath : string *
        ?OverlayPdfPageIndex : int
(* Defaults:
        let _OverlayPdfPageIndex = defaultArg OverlayPdfPageIndex 0
*)
-> PdfDocument

Parameters

OverlayPdfPath
Type: SystemString
The background PDF's file path.
OverlayPdfPageIndex (Optional)
Type: SystemInt32
Index (zero-based page number) to copy from the Overlay PDF.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class
AddForegroundOverlayPdf Overload


PdfDocument.AddForegroundOverlayPdf Method (PdfDocument, Int32)

PdfDocumentAddForegroundOverlayPdf Method (PdfDocument, Int32)

Adds an overlay to each page of this PDF. The foreground overlay is copied from a page in another PDF document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument AddForegroundOverlayPdf(
    PdfDocument OverlayPdf,
    int OverlayPdfPageIndex = 0
)
Public Function AddForegroundOverlayPdf (
    OverlayPdf As PdfDocument,
    Optional OverlayPdfPageIndex As Integer = 0
) As PdfDocument
member AddForegroundOverlayPdf :
        OverlayPdf : PdfDocument *
        ?OverlayPdfPageIndex : int
(* Defaults:
        let _OverlayPdfPageIndex = defaultArg OverlayPdfPageIndex 0
*)
-> PdfDocument

Parameters

OverlayPdf
Type: IronPdfPdfDocument
The overlay PDF as a PdfDocument.
OverlayPdfPageIndex (Optional)
Type: SystemInt32
Index (zero-based page number) to copy from the Overlay PDF.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class
AddForegroundOverlayPdf Overload


PdfDocument.AddForegroundOverlayPdfToPage Method

PdfDocumentAddForegroundOverlayPdfToPage Method

Overload List
 | Name | Description
Public method | AddForegroundOverlayPdfToPage(Int32, PdfDocument, Int32) | Adds an overlay to one page of this PDF. The foreground overlay is copied from a page in another PDF document.
Public method | AddForegroundOverlayPdfToPage(Int32, String, Int32) | Adds an overlay to one page of this PDF. The foreground overlay is copied from a page in another PDF document.
Top
See Also

Reference

PdfDocument Class


PdfDocument.AddForegroundOverlayPdfToPage Method (Int32, PdfDocument, Int32)

PdfDocumentAddForegroundOverlayPdfToPage Method (Int32, PdfDocument, Int32)

Adds an overlay to one page of this PDF. The foreground overlay is copied from a page in another PDF document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument AddForegroundOverlayPdfToPage(
    int ToPageIndex,
    PdfDocument OverlayPdf,
    int OverlayPdfPageIndex = 0
)
Public Function AddForegroundOverlayPdfToPage (
    ToPageIndex As Integer,
    OverlayPdf As PdfDocument,
    Optional OverlayPdfPageIndex As Integer = 0
) As PdfDocument
member AddForegroundOverlayPdfToPage :
        ToPageIndex : int *
        OverlayPdf : PdfDocument *
        ?OverlayPdfPageIndex : int
(* Defaults:
        let _OverlayPdfPageIndex = defaultArg OverlayPdfPageIndex 0
*)
-> PdfDocument

Parameters

ToPageIndex
Type: SystemInt32
Index (zero-based page number) of the page of this PDF to which the foreground will be applied to.
OverlayPdf
Type: IronPdfPdfDocument
The overlay PDF as a PdfDocument.
OverlayPdfPageIndex (Optional)
Type: SystemInt32
Index (zero-based page number) to copy from the Overlay PDF.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class
AddForegroundOverlayPdfToPage Overload


PdfDocument.AddForegroundOverlayPdfToPage Method (Int32, String, Int32)

PdfDocumentAddForegroundOverlayPdfToPage Method (Int32, String, Int32)

Adds an overlay to one page of this PDF. The foreground overlay is copied from a page in another PDF document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument AddForegroundOverlayPdfToPage(
    int ToPageIndex,
    string OverlayPdfPath,
    int OverlayPdfPageIndex = 0
)
Public Function AddForegroundOverlayPdfToPage (
    ToPageIndex As Integer,
    OverlayPdfPath As String,
    Optional OverlayPdfPageIndex As Integer = 0
) As PdfDocument
member AddForegroundOverlayPdfToPage :
        ToPageIndex : int *
        OverlayPdfPath : string *
        ?OverlayPdfPageIndex : int
(* Defaults:
        let _OverlayPdfPageIndex = defaultArg OverlayPdfPageIndex 0
*)
-> PdfDocument

Parameters

ToPageIndex
Type: SystemInt32
Index (zero-based page number) of the page of this PDF to which the foreground will be applied to.
OverlayPdfPath
Type: SystemString
The overlay PDF path.
OverlayPdfPageIndex (Optional)
Type: SystemInt32
Index (zero-based page number) to copy from the Overlay PDF.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class
AddForegroundOverlayPdfToPage Overload


PdfDocument.AddForegroundOverlayPdfToPageRange Method

PdfDocumentAddForegroundOverlayPdfToPageRange Method

Overload List
 | Name | Description
Public method | AddForegroundOverlayPdfToPageRange(IEnumerableInt32, PdfDocument, Int32) | Adds an overlay to a range page of this PDF. The foreground overlay is copied from a page in another PDF document.
Public method | AddForegroundOverlayPdfToPageRange(IEnumerableInt32, String, Int32) | Adds an overlay to a range page of this PDF. The foreground overlay is copied from a page in another PDF document.
Public method | AddForegroundOverlayPdfToPageRange(Int32, Int32, PdfDocument, Int32) | Adds an overlay to a range page of this PDF. The foreground overlay is copied from a page in another PDF document.
Public method | AddForegroundOverlayPdfToPageRange(Int32, Int32, String, Int32) | Adds an overlay to a range page of this PDF. The foreground overlay is copied from a page in another PDF document.
Top
See Also

Reference

PdfDocument Class


PdfDocument.AddForegroundOverlayPdfToPageRange Method (IEnumerable(Int32), PdfDocument, Int32)

PdfDocumentAddForegroundOverlayPdfToPageRange Method (IEnumerableInt32, PdfDocument, Int32)

Adds an overlay to a range page of this PDF. The foreground overlay is copied from a page in another PDF document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument AddForegroundOverlayPdfToPageRange(
    IEnumerable<int> ToPageIndexes,
    PdfDocument OverlayPdf,
    int OverlayPdfPageIndex = 0
)
Public Function AddForegroundOverlayPdfToPageRange (
    ToPageIndexes As IEnumerable(Of Integer),
    OverlayPdf As PdfDocument,
    Optional OverlayPdfPageIndex As Integer = 0
) As PdfDocument
member AddForegroundOverlayPdfToPageRange :
        ToPageIndexes : IEnumerable<int> *
        OverlayPdf : PdfDocument *
        ?OverlayPdfPageIndex : int
(* Defaults:
        let _OverlayPdfPageIndex = defaultArg OverlayPdfPageIndex 0
*)
-> PdfDocument

Parameters

ToPageIndexes
Type: System.Collections.GenericIEnumerable Int32
A list of Indexes (zero-based page numbers) of pages in this PDF to which the overlay will be applied to.
OverlayPdf
Type: IronPdfPdfDocument
The overlay PDF as a PdfDocument.
OverlayPdfPageIndex (Optional)
Type: SystemInt32
Index (zero-based page number) to copy from the Overlay PDF.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class
AddForegroundOverlayPdfToPageRange Overload


PdfDocument.AddForegroundOverlayPdfToPageRange Method (IEnumerable(Int32), String, Int32)

PdfDocumentAddForegroundOverlayPdfToPageRange Method (IEnumerableInt32, String, Int32)

Adds an overlay to a range page of this PDF. The foreground overlay is copied from a page in another PDF document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument AddForegroundOverlayPdfToPageRange(
    IEnumerable<int> ToPageIndexes,
    string OverlayPdfPath,
    int OverlayPdfPageIndex = 0
)
Public Function AddForegroundOverlayPdfToPageRange (
    ToPageIndexes As IEnumerable(Of Integer),
    OverlayPdfPath As String,
    Optional OverlayPdfPageIndex As Integer = 0
) As PdfDocument
member AddForegroundOverlayPdfToPageRange :
        ToPageIndexes : IEnumerable<int> *
        OverlayPdfPath : string *
        ?OverlayPdfPageIndex : int
(* Defaults:
        let _OverlayPdfPageIndex = defaultArg OverlayPdfPageIndex 0
*)
-> PdfDocument

Parameters

ToPageIndexes
Type: System.Collections.GenericIEnumerable Int32
A list of Indexes (zero-based page numbers) of pages in this PDF to which the overlay will be applied to.
OverlayPdfPath
Type: SystemString
The overlay PDF path.
OverlayPdfPageIndex (Optional)
Type: SystemInt32
Index (zero-based page number) to copy from the Overlay PDF.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class
AddForegroundOverlayPdfToPageRange Overload


PdfDocument.AddForegroundOverlayPdfToPageRange Method (Int32, Int32, PdfDocument, Int32)

PdfDocumentAddForegroundOverlayPdfToPageRange Method (Int32, Int32, PdfDocument, Int32)

Adds an overlay to a range page of this PDF. The foreground overlay is copied from a page in another PDF document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument AddForegroundOverlayPdfToPageRange(
    int StartPageIndex,
    int EndPageIndex,
    PdfDocument OverlayPdf,
    int OverlayPdfPageIndex = 0
)
Public Function AddForegroundOverlayPdfToPageRange (
    StartPageIndex As Integer,
    EndPageIndex As Integer,
    OverlayPdf As PdfDocument,
    Optional OverlayPdfPageIndex As Integer = 0
) As PdfDocument
member AddForegroundOverlayPdfToPageRange :
        StartPageIndex : int *
        EndPageIndex : int *
        OverlayPdf : PdfDocument *
        ?OverlayPdfPageIndex : int
(* Defaults:
        let _OverlayPdfPageIndex = defaultArg OverlayPdfPageIndex 0
*)
-> PdfDocument

Parameters

StartPageIndex
Type: SystemInt32
First index (zero-based page number) to start adding overlays to .
EndPageIndex
Type: SystemInt32
Last index (zero-based page number) to end adding overlays to.
OverlayPdf
Type: IronPdfPdfDocument
The overlay PDF as a PdfDocument.
OverlayPdfPageIndex (Optional)
Type: SystemInt32
Index (zero-based page number) to copy from the Overlay PDF.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class
AddForegroundOverlayPdfToPageRange Overload


PdfDocument.AddForegroundOverlayPdfToPageRange Method (Int32, Int32, String, Int32)

PdfDocumentAddForegroundOverlayPdfToPageRange Method (Int32, Int32, String, Int32)

Adds an overlay to a range page of this PDF. The foreground overlay is copied from a page in another PDF document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument AddForegroundOverlayPdfToPageRange(
    int StartPageIndex,
    int EndPageIndex,
    string OverlayPdfPath,
    int OverlayPdfPageIndex = 0
)
Public Function AddForegroundOverlayPdfToPageRange (
    StartPageIndex As Integer,
    EndPageIndex As Integer,
    OverlayPdfPath As String,
    Optional OverlayPdfPageIndex As Integer = 0
) As PdfDocument
member AddForegroundOverlayPdfToPageRange :
        StartPageIndex : int *
        EndPageIndex : int *
        OverlayPdfPath : string *
        ?OverlayPdfPageIndex : int
(* Defaults:
        let _OverlayPdfPageIndex = defaultArg OverlayPdfPageIndex 0
*)
-> PdfDocument

Parameters

StartPageIndex
Type: SystemInt32
First index (zero-based page number) to start adding overlays to .
EndPageIndex
Type: SystemInt32
Last index (zero-based page number) to end adding overlays to.
OverlayPdfPath
Type: SystemString
The overlay PDF path.
OverlayPdfPageIndex (Optional)
Type: SystemInt32
Index (zero-based page number) to copy from the Overlay PDF.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class
AddForegroundOverlayPdfToPageRange Overload


PdfDocument.AddHeaders Method

PdfDocumentAddHeaders Method

Overload List
 | Name | Description
Public method | AddHeaders(SimpleHeaderFooter, Boolean, IEnumerableInt32) | Renders page headers to an existing PDF File Margin spacing on the PDF page for the header are set to default values of 25mm. An overload method allow header margins to be chosen specifically or set to zero.
Public method | AddHeaders(SimpleHeaderFooter, Double, Double, Double, Boolean, IEnumerableInt32) | Renders page headers to an existing PDF File
Top
See Also

Reference

PdfDocument Class


PdfDocument.AddHeaders Method (SimpleHeaderFooter, Boolean, IEnumerable(Int32))

PdfDocumentAddHeaders Method (SimpleHeaderFooter, Boolean, IEnumerableInt32)

Renders page headers to an existing PDF File

Margin spacing on the PDF page for the header are set to default values of 25mm. An overload method allow header margins to be chosen specifically or set to zero.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument AddHeaders(
    SimpleHeaderFooter Header,
    bool SkipFirstPage = false,
    IEnumerable<int> PageIndexesToAddHeadersTo = null
)
Public Function AddHeaders (
    Header As SimpleHeaderFooter,
    Optional SkipFirstPage As Boolean = false,
    Optional PageIndexesToAddHeadersTo As IEnumerable(Of Integer) = Nothing
) As PdfDocument
member AddHeaders :
        Header : SimpleHeaderFooter *
        ?SkipFirstPage : bool *
        ?PageIndexesToAddHeadersTo : IEnumerable<int>
(* Defaults:
        let _SkipFirstPage = defaultArg SkipFirstPage false
        let _PageIndexesToAddHeadersTo = defaultArg PageIndexesToAddHeadersTo null
*)
-> PdfDocument

Parameters

Header
Type: IronPdfSimpleHeaderFooter
An new instance of IronPdf.SimpleHeaderFooter that defines the header content and layout.
SkipFirstPage (Optional)
Type: SystemBoolean
if set to true, the first (cover) page is not counted or stamped with a header.
PageIndexesToAddHeadersTo (Optional)
Type: System.Collections.GenericIEnumerable Int32
Optional. The PageIndexes (zero-based page numbers) to which the header will be added.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class
AddHeaders Overload


PdfDocument.AddHeaders Method (SimpleHeaderFooter, Double, Double, Double, Boolean, IEnumerable(Int32))

PdfDocumentAddHeaders Method (SimpleHeaderFooter, Double, Double, Double, Boolean, IEnumerableInt32)

Renders page headers to an existing PDF File

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument AddHeaders(
    SimpleHeaderFooter Header,
    double MarginLeft,
    double MarginRight,
    double MarginTop,
    bool SkipFirstPage = false,
    IEnumerable<int> PageIndexesToAddHeadersTo = null
)
Public Function AddHeaders (
    Header As SimpleHeaderFooter,
    MarginLeft As Double,
    MarginRight As Double,
    MarginTop As Double,
    Optional SkipFirstPage As Boolean = false,
    Optional PageIndexesToAddHeadersTo As IEnumerable(Of Integer) = Nothing
) As PdfDocument
member AddHeaders :
        Header : SimpleHeaderFooter *
        MarginLeft : float *
        MarginRight : float *
        MarginTop : float *
        ?SkipFirstPage : bool *
        ?PageIndexesToAddHeadersTo : IEnumerable<int>
(* Defaults:
        let _SkipFirstPage = defaultArg SkipFirstPage false
        let _PageIndexesToAddHeadersTo = defaultArg PageIndexesToAddHeadersTo null
*)
-> PdfDocument

Parameters

Header
Type: IronPdfSimpleHeaderFooter
An new instance of IronPdf.SimpleHeaderFooter that defines the header content and layout.
MarginLeft
Type: SystemDouble
The left margin of the header on the page in mm.
MarginRight
Type: SystemDouble
The right margin of the header on the page in mm.
MarginTop
Type: SystemDouble
The top margin of the header on the page in mm.
SkipFirstPage (Optional)
Type: SystemBoolean
if set to true, the first (cover) page is not counted or stamped with a header.
PageIndexesToAddHeadersTo (Optional)
Type: System.Collections.GenericIEnumerable Int32
Optional. The PageIndexes (zero-based page numbers) to which the header will be added.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class
AddHeaders Overload


PdfDocument.AddHTMLFooters Method

PdfDocumentAddHTMLFooters Method

Overload List
 | Name | Description
Public method | AddHTMLFooters(HtmlHeaderFooter, Boolean, IEnumerableInt32) | Renders HTML page footers to an existing PDF File Margin spacing on the PDF page for the footer are set to default values of 25mm. An overload method allow footer margins to be chosen specifically or set to zero.
Public method | AddHTMLFooters(HtmlHeaderFooter, Double, Double, Double, Boolean, IEnumerableInt32) | Renders HTML page footers to an existing PDF File
Top
See Also

Reference

PdfDocument Class


PdfDocument.AddHTMLFooters Method (HtmlHeaderFooter, Boolean, IEnumerable(Int32))

PdfDocumentAddHTMLFooters Method (HtmlHeaderFooter, Boolean, IEnumerableInt32)

Renders HTML page footers to an existing PDF File

Margin spacing on the PDF page for the footer are set to default values of 25mm. An overload method allow footer margins to be chosen specifically or set to zero.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument AddHTMLFooters(
    HtmlHeaderFooter Footer,
    bool SkipFirstPage = false,
    IEnumerable<int> PageIndexesToAddFootersTo = null
)
Public Function AddHTMLFooters (
    Footer As HtmlHeaderFooter,
    Optional SkipFirstPage As Boolean = false,
    Optional PageIndexesToAddFootersTo As IEnumerable(Of Integer) = Nothing
) As PdfDocument
member AddHTMLFooters :
        Footer : HtmlHeaderFooter *
        ?SkipFirstPage : bool *
        ?PageIndexesToAddFootersTo : IEnumerable<int>
(* Defaults:
        let _SkipFirstPage = defaultArg SkipFirstPage false
        let _PageIndexesToAddFootersTo = defaultArg PageIndexesToAddFootersTo null
*)
-> PdfDocument

Parameters

Footer
Type: IronPdfHtmlHeaderFooter
An new instance of IronPdf.HtmlHeaderFooter that defines the footer content and layout.
SkipFirstPage (Optional)
Type: SystemBoolean
if set to true, the first (cover) page is not counted or stamped with a footer.
PageIndexesToAddFootersTo (Optional)
Type: System.Collections.GenericIEnumerable Int32
Optional. The PageIndexes (zero-based page numbers) to which the footer will be added.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class
AddHTMLFooters Overload


PdfDocument.AddHTMLFooters Method (HtmlHeaderFooter, Double, Double, Double, Boolean, IEnumerable(Int32))

PdfDocumentAddHTMLFooters Method (HtmlHeaderFooter, Double, Double, Double, Boolean, IEnumerableInt32)

Renders HTML page footers to an existing PDF File

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument AddHTMLFooters(
    HtmlHeaderFooter Footer,
    double MarginLeft,
    double MarginRight,
    double MarginBottom,
    bool SkipFirstPage = false,
    IEnumerable<int> PageIndexesToAddFootersTo = null
)
Public Function AddHTMLFooters (
    Footer As HtmlHeaderFooter,
    MarginLeft As Double,
    MarginRight As Double,
    MarginBottom As Double,
    Optional SkipFirstPage As Boolean = false,
    Optional PageIndexesToAddFootersTo As IEnumerable(Of Integer) = Nothing
) As PdfDocument
member AddHTMLFooters :
        Footer : HtmlHeaderFooter *
        MarginLeft : float *
        MarginRight : float *
        MarginBottom : float *
        ?SkipFirstPage : bool *
        ?PageIndexesToAddFootersTo : IEnumerable<int>
(* Defaults:
        let _SkipFirstPage = defaultArg SkipFirstPage false
        let _PageIndexesToAddFootersTo = defaultArg PageIndexesToAddFootersTo null
*)
-> PdfDocument

Parameters

Footer
Type: IronPdfHtmlHeaderFooter
An new instance of IronPdf.HtmlHeaderFooter that defines the footer content and layout.
MarginLeft
Type: SystemDouble
The left margin of the footer on the page in mm.
MarginRight
Type: SystemDouble
The right margin of the footer on the page in mm.
MarginBottom
Type: SystemDouble
The bottom margin of the footer on the page in mm.
SkipFirstPage (Optional)
Type: SystemBoolean
if set to true, the first (cover) page is not counted or stamped with a footer.
PageIndexesToAddFootersTo (Optional)
Type: System.Collections.GenericIEnumerable Int32
Optional. The PageIndexes (zero-based page numbers) to which the footer will be added.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class
AddHTMLFooters Overload


PdfDocument.AddHTMLHeaders Method

PdfDocumentAddHTMLHeaders Method

Overload List
 | Name | Description
Public method | AddHTMLHeaders(HtmlHeaderFooter, Boolean, IEnumerableInt32) | Renders HTML page headers to an existing PDF File Margin spacing on the PDF page for the header are set to default values of 25mm. An overload method allow header margins to be chosen specifically or set to zero.
Public method | AddHTMLHeaders(HtmlHeaderFooter, Double, Double, Double, Boolean, IEnumerableInt32) | Renders HTML page headers to an existing PDF File
Top
See Also

Reference

PdfDocument Class


PdfDocument.AddHTMLHeaders Method (HtmlHeaderFooter, Boolean, IEnumerable(Int32))

PdfDocumentAddHTMLHeaders Method (HtmlHeaderFooter, Boolean, IEnumerableInt32)

Renders HTML page headers to an existing PDF File

Margin spacing on the PDF page for the header are set to default values of 25mm. An overload method allow header margins to be chosen specifically or set to zero.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument AddHTMLHeaders(
    HtmlHeaderFooter Header,
    bool SkipFirstPage = false,
    IEnumerable<int> PageIndexesToAddHeadersTo = null
)
Public Function AddHTMLHeaders (
    Header As HtmlHeaderFooter,
    Optional SkipFirstPage As Boolean = false,
    Optional PageIndexesToAddHeadersTo As IEnumerable(Of Integer) = Nothing
) As PdfDocument
member AddHTMLHeaders :
        Header : HtmlHeaderFooter *
        ?SkipFirstPage : bool *
        ?PageIndexesToAddHeadersTo : IEnumerable<int>
(* Defaults:
        let _SkipFirstPage = defaultArg SkipFirstPage false
        let _PageIndexesToAddHeadersTo = defaultArg PageIndexesToAddHeadersTo null
*)
-> PdfDocument

Parameters

Header
Type: IronPdfHtmlHeaderFooter
An new instance of IronPdf.HtmlHeaderFooter that defines the header content and layout.
SkipFirstPage (Optional)
Type: SystemBoolean
if set to true, the first (cover) page is not counted or stamped with a header.
PageIndexesToAddHeadersTo (Optional)
Type: System.Collections.GenericIEnumerable Int32
Optional. The PageIndexes (zero-based page numbers) to which the header will be added.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class
AddHTMLHeaders Overload


PdfDocument.AddHTMLHeaders Method (HtmlHeaderFooter, Double, Double, Double, Boolean, IEnumerable(Int32))

PdfDocumentAddHTMLHeaders Method (HtmlHeaderFooter, Double, Double, Double, Boolean, IEnumerableInt32)

Renders HTML page headers to an existing PDF File

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument AddHTMLHeaders(
    HtmlHeaderFooter Header,
    double MarginLeft,
    double MarginRight,
    double MarginTop,
    bool SkipFirstPage = false,
    IEnumerable<int> PageIndexesToAddHeadersTo = null
)
Public Function AddHTMLHeaders (
    Header As HtmlHeaderFooter,
    MarginLeft As Double,
    MarginRight As Double,
    MarginTop As Double,
    Optional SkipFirstPage As Boolean = false,
    Optional PageIndexesToAddHeadersTo As IEnumerable(Of Integer) = Nothing
) As PdfDocument
member AddHTMLHeaders :
        Header : HtmlHeaderFooter *
        MarginLeft : float *
        MarginRight : float *
        MarginTop : float *
        ?SkipFirstPage : bool *
        ?PageIndexesToAddHeadersTo : IEnumerable<int>
(* Defaults:
        let _SkipFirstPage = defaultArg SkipFirstPage false
        let _PageIndexesToAddHeadersTo = defaultArg PageIndexesToAddHeadersTo null
*)
-> PdfDocument

Parameters

Header
Type: IronPdfHtmlHeaderFooter
An new instance of IronPdf.HtmlHeaderFooter that defines the header content and layout.
MarginLeft
Type: SystemDouble
The left margin of the header on the page in mm.
MarginRight
Type: SystemDouble
The right margin of the header on the page in mm.
MarginTop
Type: SystemDouble
The top margin of the header on the page in mm.
SkipFirstPage (Optional)
Type: SystemBoolean
if set to true, the first (cover) page is not counted or stamped with a header.
PageIndexesToAddHeadersTo (Optional)
Type: System.Collections.GenericIEnumerable Int32
Optional. The PageIndexes (zero-based page numbers) to which the header will be added.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class
AddHTMLHeaders Overload


PdfDocument.AddTextAnnotation Method

PdfDocumentAddTextAnnotation Method

Overload List
 | Name | Description
Public method | AddTextAnnotation(PdfDocumentTextAnnotation, Int32, Int32, Int32, Int32, Int32) | Adds an annotation to a page of this PdfDocument
Public method | AddTextAnnotation(String, String, String, Int32, Int32, Int32, Int32, Int32, PdfDocumentTextAnnotationAnnotationIcon, Boolean, Boolean, Boolean, String, Double) | Adds an annotation to a page of this PdfDocument
Top
See Also

Reference

PdfDocument Class


PdfDocument.AddTextAnnotation Method (PdfDocument.TextAnnotation, Int32, Int32, Int32, Int32, Int32)

PdfDocumentAddTextAnnotation Method (PdfDocumentTextAnnotation, Int32, Int32, Int32, Int32, Int32)

Adds an annotation to a page of this PdfDocument

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public void AddTextAnnotation(
    PdfDocumentTextAnnotation TextAnnotation,
    int PageIndex,
    int X,
    int Y,
    int Width = 30,
    int Height = 30
)
Public Sub AddTextAnnotation (
    TextAnnotation As PdfDocumentTextAnnotation,
    PageIndex As Integer,
    X As Integer,
    Y As Integer,
    Optional Width As Integer = 30,
    Optional Height As Integer = 30
)
member AddTextAnnotation :
        TextAnnotation : PdfDocumentTextAnnotation *
        PageIndex : int *
        X : int *
        Y : int *
        ?Width : int *
        ?Height : int
(* Defaults:
        let _Width = defaultArg Width 30
        let _Height = defaultArg Height 30
*)
-> unit

Parameters

TextAnnotation
Type: IronPdfPdfDocumentTextAnnotation
The annotation as a PdfDocumentTextAnnotation object.
PageIndex
Type: SystemInt32
Index of the page to add the annotation. The first page has a PageIndex of 0
X
Type: SystemInt32
The horizontal X position of the annotation on your page in pixels
Y
Type: SystemInt32
The vertical Y position of the annotation on your page in pixels. Measured from top downwards.
Width (Optional)
Type: SystemInt32
The width of your annotation's icon and interactive area in pixels
Height (Optional)
Type: SystemInt32
The height of your annotation's icon and interactive area in pixels
See Also

Reference

PdfDocument Class
AddTextAnnotation Overload


PdfDocument.AddTextAnnotation Method (String, String, String, Int32, Int32, Int32, Int32, Int32, PdfDocument.TextAnnotation.AnnotationIcon, Boolean, Boolean, Boolean, String, Double)

PdfDocumentAddTextAnnotation Method (String, String, String, Int32, Int32, Int32, Int32, Int32, PdfDocumentTextAnnotationAnnotationIcon, Boolean, Boolean, Boolean, String, Double)

Adds an annotation to a page of this PdfDocument

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public void AddTextAnnotation(
    string Title,
    string Subject,
    string Contents,
    int PageIndex,
    int X,
    int Y,
    int Width = 30,
    int Height = 30,
    PdfDocumentTextAnnotationAnnotationIcon Icon = PdfDocumentTextAnnotationAnnotationIcon.Comment,
    bool Open = true,
    bool ReadOnly = true,
    bool Printable = false,
    string RgbColor = "#FFFF33",
    double Opacity = 1
)
Public Sub AddTextAnnotation (
    Title As String,
    Subject As String,
    Contents As String,
    PageIndex As Integer,
    X As Integer,
    Y As Integer,
    Optional Width As Integer = 30,
    Optional Height As Integer = 30,
    Optional Icon As PdfDocumentTextAnnotationAnnotationIcon = PdfDocumentTextAnnotationAnnotationIcon.Comment,
    Optional Open As Boolean = true,
    Optional ReadOnly As Boolean = true,
    Optional Printable As Boolean = false,
    Optional RgbColor As String = "#FFFF33",
    Optional Opacity As Double = 1
)
member AddTextAnnotation :
        Title : string *
        Subject : string *
        Contents : string *
        PageIndex : int *
        X : int *
        Y : int *
        ?Width : int *
        ?Height : int *
        ?Icon : PdfDocumentTextAnnotationAnnotationIcon *
        ?Open : bool *
        ?ReadOnly : bool *
        ?Printable : bool *
        ?RgbColor : string *
        ?Opacity : float
(* Defaults:
        let _Width = defaultArg Width 30
        let _Height = defaultArg Height 30
        let _Icon = defaultArg Icon PdfDocumentTextAnnotationAnnotationIcon.Comment
        let _Open = defaultArg Open true
        let _ReadOnly = defaultArg ReadOnly true
        let _Printable = defaultArg Printable false
        let _RgbColor = defaultArg RgbColor "#FFFF33"
        let _Opacity = defaultArg Opacity 1
*)
-> unit

Parameters

Title
Type: SystemString
The title of the annotation
Subject
Type: SystemString
The subject or 'subheading' of the annotation
Contents
Type: SystemString
The text content of the annotation
PageIndex
Type: SystemInt32
Index of the page to add the annotation. The first page has a PageIndex of 0
X
Type: SystemInt32
The horizontal X position of the annotation on your page in pixels
Y
Type: SystemInt32
The vertical Y position of the annotation on your page in pixels. Measured from top downwards.
Width (Optional)
Type: SystemInt32
The width of your annotation's icon and interactive area in pixels
Height (Optional)
Type: SystemInt32
The height of your annotation's icon and interactive area in pixels
Icon (Optional)
Type: IronPdfPdfDocumentTextAnnotationAnnotationIcon
The icon used to display the interactive annotation within the PDF
Open (Optional)
Type: SystemBoolean
Sets the annotation to be opened and readable by default, without user interaction
ReadOnly (Optional)
Type: SystemBoolean
Makes the annotation non user editable
Printable (Optional)
Type: SystemBoolean
Makes the annotation render during user PDF printing operations
RgbColor (Optional)
Type: SystemString
Color of the annotation's background 'sticky note' using Html color notation. E.g. '#FFFF33'.
Opacity (Optional)
Type: SystemDouble
The opacity of the annotation (valid values are from 0.0 to 1.0)
See Also

Reference

PdfDocument Class
AddTextAnnotation Overload


PdfDocument.AppendPdf Method

PdfDocumentAppendPdf Method

Appends another PDF to the end of the current PdfDocument

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument AppendPdf(
    PdfDocument AnotherPdfFile
)
Public Function AppendPdf (
    AnotherPdfFile As PdfDocument
) As PdfDocument
member AppendPdf :
        AnotherPdfFile : PdfDocument -> PdfDocument

Parameters

AnotherPdfFile
Type: IronPdfPdfDocument
PdfDocument to append.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class


PdfDocument.CopyPage Method

PdfDocumentCopyPage Method

Creates a new PDF by copying a page from this PdfDocument.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument CopyPage(
    int PageIndex
)
Public Function CopyPage (
    PageIndex As Integer
) As PdfDocument
member CopyPage :
        PageIndex : int -> PdfDocument

Parameters

PageIndex
Type: SystemInt32
Index of the page. Note: Page 1 has index 0...

Return Value

Type: PdfDocument
This PdfDocument for a LINQ like 'fluent' coding style.
See Also

Reference

PdfDocument Class


PdfDocument.CopyPages Method

PdfDocumentCopyPages Method

Overload List
 | Name | Description
Public method | CopyPages(IEnumerableInt32) | Creates a new PDF by copying a range of pages from this PdfDocument.
Public method | CopyPages(Int32, Int32) | Creates a new PDF by copying a range of pages from this PdfDocument.
Top
See Also

Reference

PdfDocument Class


PdfDocument.CopyPages Method (IEnumerable(Int32))

PdfDocumentCopyPages Method (IEnumerableInt32)

Creates a new PDF by copying a range of pages from this PdfDocument.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument CopyPages(
    IEnumerable<int> PageIndexes
)
Public Function CopyPages (
    PageIndexes As IEnumerable(Of Integer)
) As PdfDocument
member CopyPages :
        PageIndexes : IEnumerable<int> -> PdfDocument

Parameters

PageIndexes
Type: System.Collections.GenericIEnumerable Int32
An IEnumerable of page indexes to copy into the new PDF.

Return Value

Type: PdfDocument
This PdfDocument for a LINQ like 'fluent' coding style.
See Also

Reference

PdfDocument Class
CopyPages Overload


PdfDocument.CopyPages Method (Int32, Int32)

PdfDocumentCopyPages Method (Int32, Int32)

Creates a new PDF by copying a range of pages from this PdfDocument.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument CopyPages(
    int StartIndex,
    int EndIndex
)
Public Function CopyPages (
    StartIndex As Integer,
    EndIndex As Integer
) As PdfDocument
member CopyPages :
        StartIndex : int *
        EndIndex : int -> PdfDocument

Parameters

StartIndex
Type: SystemInt32
The index of the first PDF page to copy.. Note: Page 1 has index 0
EndIndex
Type: SystemInt32
The index of the last PDF page to copy.>

Return Value

Type: PdfDocument
This PdfDocument for a LINQ like 'fluent' coding style.
See Also

Reference

PdfDocument Class
CopyPages Overload


PdfDocument.ExtractAllBitmaps Method

PdfDocumentExtractAllBitmaps Method

Finds all embedded Images from within the PDF and returns then as System.Drawing.Bitmap objects

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public IEnumerable<Bitmap> ExtractAllBitmaps()
Public Function ExtractAllBitmaps As IEnumerable(Of Bitmap)
member ExtractAllBitmaps : unit -> IEnumerable<Bitmap>

Return Value

Type: IEnumerable Bitmap
IEnumerable of Bitmap. The extracted images as System.Drawing Objects
See Also

Reference

PdfDocument Class


PdfDocument.ExtractAllImages Method

PdfDocumentExtractAllImages Method

Finds all embedded Images from within the PDF and returns then as System.Drawing.Image objects

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public IEnumerable<Image> ExtractAllImages()
Public Function ExtractAllImages As IEnumerable(Of Image)
member ExtractAllImages : unit -> IEnumerable<Image>

Return Value

Type: IEnumerable Image
IEnumerable of Image. The extracted images as System.Drawing Objects
See Also

Reference

PdfDocument Class


PdfDocument.ExtractAllRawImages Method

PdfDocumentExtractAllRawImages Method

Extracts all images from a PDf document. Images are Returned as their raw data in as Byte Arrays (byte[])

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public IEnumerable<byte[]> ExtractAllRawImages()
Public Function ExtractAllRawImages As IEnumerable(Of Byte())
member ExtractAllRawImages : unit -> IEnumerable<byte[]>

Return Value

Type: IEnumerable Byte
An Enumerable of Byte Arrays. Each Byte Array represents one image.
See Also

Reference

PdfDocument Class


PdfDocument.ExtractAllText Method

PdfDocumentExtractAllText Method

Extracts the written text content from the PDF and returns it as a string. Pages will be separated by 4 consecutive newline characters ("\n\n\n\n")

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string ExtractAllText()
Public Function ExtractAllText As String
member ExtractAllText : unit -> string

Return Value

Type: String
All text in the PDF as a string.
See Also

Reference

PdfDocument Class


PdfDocument.ExtractBitmapsFromPage Method

PdfDocumentExtractBitmapsFromPage Method

Finds all embedded Images from within one page of the PDF and returns them as System.Drawing.Bitmap objects

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public IEnumerable<Bitmap> ExtractBitmapsFromPage(
    int PageIndex
)
Public Function ExtractBitmapsFromPage (
    PageIndex As Integer
) As IEnumerable(Of Bitmap)
member ExtractBitmapsFromPage :
        PageIndex : int -> IEnumerable<Bitmap>

Parameters

PageIndex
Type: SystemInt32
Index of the page. Note: Page 1 has index 0...

Return Value

Type: IEnumerable Bitmap
IEnumerable of Bitmap. The extracted images as System.Drawing Objects
See Also

Reference

PdfDocument Class


PdfDocument.ExtractBitmapsFromPages Method

PdfDocumentExtractBitmapsFromPages Method

Overload List
 | Name | Description
Public method | ExtractBitmapsFromPages(IEnumerableInt32) | Finds all embedded Images from within a specified pages in the PDF and returns them as System.Drawing.Bitmap objects
Public method | ExtractBitmapsFromPages(Int32, Int32) | Finds all embedded Images from within a range of pages in the PDF and returns them as System.Drawing.Bitmap objects
Top
See Also

Reference

PdfDocument Class


PdfDocument.ExtractBitmapsFromPages Method (IEnumerable(Int32))

PdfDocumentExtractBitmapsFromPages Method (IEnumerableInt32)

Finds all embedded Images from within a specified pages in the PDF and returns them as System.Drawing.Bitmap objects

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public IEnumerable<Bitmap> ExtractBitmapsFromPages(
    IEnumerable<int> PageIndexes
)
Public Function ExtractBitmapsFromPages (
    PageIndexes As IEnumerable(Of Integer)
) As IEnumerable(Of Bitmap)
member ExtractBitmapsFromPages :
        PageIndexes : IEnumerable<int> -> IEnumerable<Bitmap>

Parameters

PageIndexes
Type: System.Collections.GenericIEnumerable Int32
An IEnumerable list of page indexes.

Return Value

Type: IEnumerable Bitmap
IEnumerable of Bitmap. The extracted images as System.Drawing Objects
See Also

Reference

PdfDocument Class
ExtractBitmapsFromPages Overload


PdfDocument.ExtractBitmapsFromPages Method (Int32, Int32)

PdfDocumentExtractBitmapsFromPages Method (Int32, Int32)

Finds all embedded Images from within a range of pages in the PDF and returns them as System.Drawing.Bitmap objects

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public IEnumerable<Bitmap> ExtractBitmapsFromPages(
    int StartIndex,
    int EndIndex
)
Public Function ExtractBitmapsFromPages (
    StartIndex As Integer,
    EndIndex As Integer
) As IEnumerable(Of Bitmap)
member ExtractBitmapsFromPages :
        StartIndex : int *
        EndIndex : int -> IEnumerable<Bitmap>

Parameters

StartIndex
Type: SystemInt32
The index of the first PDF page to extract images from.. Note: Page 1 has index 0
EndIndex
Type: SystemInt32
The index of the last PDF page to extract images from.

Return Value

Type: IEnumerable Bitmap
IEnumerable of Bitmap. The extracted images as System.Drawing Objects
See Also

Reference

PdfDocument Class
ExtractBitmapsFromPages Overload


PdfDocument.ExtractImagesFromPage Method

PdfDocumentExtractImagesFromPage Method

Finds all embedded Images from within one page of the PDF and returns them as System.Drawing.Image objects

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public IEnumerable<Image> ExtractImagesFromPage(
    int PageIndex
)
Public Function ExtractImagesFromPage (
    PageIndex As Integer
) As IEnumerable(Of Image)
member ExtractImagesFromPage :
        PageIndex : int -> IEnumerable<Image>

Parameters

PageIndex
Type: SystemInt32
Index of the page. Note: Page 1 has index 0...

Return Value

Type: IEnumerable Image
IEnumerable of Image. The extracted images as System.Drawing Objects
See Also

Reference

PdfDocument Class


PdfDocument.ExtractImagesFromPages Method

PdfDocumentExtractImagesFromPages Method

Overload List
 | Name | Description
Public method | ExtractImagesFromPages(IEnumerableInt32) | Finds all embedded Images from within a specified pages in the PDF and returns them as System.Drawing.Image objects
Public method | ExtractImagesFromPages(Int32, Int32) | Finds all embedded Images from within a range of pages in the PDF and returns them as System.Drawing.Bitmap objects
Top
See Also

Reference

PdfDocument Class


PdfDocument.ExtractImagesFromPages Method (IEnumerable(Int32))

PdfDocumentExtractImagesFromPages Method (IEnumerableInt32)

Finds all embedded Images from within a specified pages in the PDF and returns them as System.Drawing.Image objects

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public IEnumerable<Image> ExtractImagesFromPages(
    IEnumerable<int> PageIndexes
)
Public Function ExtractImagesFromPages (
    PageIndexes As IEnumerable(Of Integer)
) As IEnumerable(Of Image)
member ExtractImagesFromPages :
        PageIndexes : IEnumerable<int> -> IEnumerable<Image>

Parameters

PageIndexes
Type: System.Collections.GenericIEnumerable Int32
An IEnumerable list of page indexes.

Return Value

Type: IEnumerable Image
IEnumerable of Image. The extracted images as System.Drawing Objects
See Also

Reference

PdfDocument Class
ExtractImagesFromPages Overload


PdfDocument.ExtractImagesFromPages Method (Int32, Int32)

PdfDocumentExtractImagesFromPages Method (Int32, Int32)

Finds all embedded Images from within a range of pages in the PDF and returns them as System.Drawing.Bitmap objects

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public IEnumerable<Image> ExtractImagesFromPages(
    int StartIndex,
    int EndIndex
)
Public Function ExtractImagesFromPages (
    StartIndex As Integer,
    EndIndex As Integer
) As IEnumerable(Of Image)
member ExtractImagesFromPages :
        StartIndex : int *
        EndIndex : int -> IEnumerable<Image>

Parameters

StartIndex
Type: SystemInt32
The index of the first PDF page to extract images from.. Note: Page 1 has index 0
EndIndex
Type: SystemInt32
The index of the last PDF page to extract images from.

Return Value

Type: IEnumerable Image
IEnumerable of Image. The extracted images as System.Drawing Objects
See Also

Reference

PdfDocument Class
ExtractImagesFromPages Overload


PdfDocument.ExtractRawImagesFromPage Method

PdfDocumentExtractRawImagesFromPage Method

Finds all embedded Images from within one page of the PDF and returns them as raw image byte array objects

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public IEnumerable<byte[]> ExtractRawImagesFromPage(
    int PageIndex
)
Public Function ExtractRawImagesFromPage (
    PageIndex As Integer
) As IEnumerable(Of Byte())
member ExtractRawImagesFromPage :
        PageIndex : int -> IEnumerable<byte[]>

Parameters

PageIndex
Type: SystemInt32
Index of the page. Note: Page 1 has index 0...

Return Value

Type: IEnumerable Byte
IEnumerable of raw image byte array.
See Also

Reference

PdfDocument Class


PdfDocument.ExtractRawImagesFromPages Method

PdfDocumentExtractRawImagesFromPages Method

Overload List
 | Name | Description
Public method | ExtractRawImagesFromPages(IEnumerableInt32) | Finds all embedded Images from within a specified pages in the PDF and returns them as System.Drawing.Image objects
Public method | ExtractRawImagesFromPages(Int32, Int32) | Finds all embedded Images from within a range of pages in the PDF and returns them as raw image byte array objects
Top
See Also

Reference

PdfDocument Class


PdfDocument.ExtractRawImagesFromPages Method (IEnumerable(Int32))

PdfDocumentExtractRawImagesFromPages Method (IEnumerableInt32)

Finds all embedded Images from within a specified pages in the PDF and returns them as System.Drawing.Image objects

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public IEnumerable<byte[]> ExtractRawImagesFromPages(
    IEnumerable<int> PageIndexes
)
Public Function ExtractRawImagesFromPages (
    PageIndexes As IEnumerable(Of Integer)
) As IEnumerable(Of Byte())
member ExtractRawImagesFromPages :
        PageIndexes : IEnumerable<int> -> IEnumerable<byte[]>

Parameters

PageIndexes
Type: System.Collections.GenericIEnumerable Int32
An IEnumerable list of page indexes.

Return Value

Type: IEnumerable Byte
IEnumerable of raw image byte array.
See Also

Reference

PdfDocument Class
ExtractRawImagesFromPages Overload


PdfDocument.ExtractRawImagesFromPages Method (Int32, Int32)

PdfDocumentExtractRawImagesFromPages Method (Int32, Int32)

Finds all embedded Images from within a range of pages in the PDF and returns them as raw image byte array objects

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public IEnumerable<byte[]> ExtractRawImagesFromPages(
    int StartIndex,
    int EndIndex
)
Public Function ExtractRawImagesFromPages (
    StartIndex As Integer,
    EndIndex As Integer
) As IEnumerable(Of Byte())
member ExtractRawImagesFromPages :
        StartIndex : int *
        EndIndex : int -> IEnumerable<byte[]>

Parameters

StartIndex
Type: SystemInt32
The index of the first PDF page to extract images from.. Note: Page 1 has index 0
EndIndex
Type: SystemInt32
The index of the last PDF page to extract images from.

Return Value

Type: IEnumerable Byte
IEnumerable of raw image byte array.
See Also

Reference

PdfDocument Class
ExtractRawImagesFromPages Overload


PdfDocument.ExtractTextFromPage Method

PdfDocumentExtractTextFromPage Method

Extracts the text content from one page of the PDF and returns it as a string.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string ExtractTextFromPage(
    int PageIndex
)
Public Function ExtractTextFromPage (
    PageIndex As Integer
) As String
member ExtractTextFromPage :
        PageIndex : int -> string

Parameters

PageIndex
Type: SystemInt32
Index of the page. Note: Page 1 has index 0...

Return Value

Type: String
The text extracted from the PDF page as a string.
See Also

Reference

PdfDocument Class


PdfDocument.ExtractTextFromPages Method

PdfDocumentExtractTextFromPages Method

Overload List
 | Name | Description
Public method | ExtractTextFromPages(IEnumerableInt32) | Extracts the written text content from specified pages in the PDF PDF and returns it as a string. Pages will be separated by 4 consecutive newline characters ("\n\n\n\n")
Public method | ExtractTextFromPages(Int32, Int32) | Extracts the written text content from a range of pages within the PDF and returns it as a string. Pages will be separated by 4 consecutive newline characters ("\n\n\n\n")
Top
See Also

Reference

PdfDocument Class


PdfDocument.ExtractTextFromPages Method (IEnumerable(Int32))

PdfDocumentExtractTextFromPages Method (IEnumerableInt32)

Extracts the written text content from specified pages in the PDF PDF and returns it as a string. Pages will be separated by 4 consecutive newline characters ("\n\n\n\n")

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string ExtractTextFromPages(
    IEnumerable<int> PageIndexes
)
Public Function ExtractTextFromPages (
    PageIndexes As IEnumerable(Of Integer)
) As String
member ExtractTextFromPages :
        PageIndexes : IEnumerable<int> -> string

Parameters

PageIndexes
Type: System.Collections.GenericIEnumerable Int32
An IEnumerable list of page indexes.

Return Value

Type: String
The text extracted from the PDF pages as a string.
See Also

Reference

PdfDocument Class
ExtractTextFromPages Overload


PdfDocument.ExtractTextFromPages Method (Int32, Int32)

PdfDocumentExtractTextFromPages Method (Int32, Int32)

Extracts the written text content from a range of pages within the PDF and returns it as a string. Pages will be separated by 4 consecutive newline characters ("\n\n\n\n")

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string ExtractTextFromPages(
    int StartIndex,
    int EndIndex
)
Public Function ExtractTextFromPages (
    StartIndex As Integer,
    EndIndex As Integer
) As String
member ExtractTextFromPages :
        StartIndex : int *
        EndIndex : int -> string

Parameters

StartIndex
Type: SystemInt32
The start page index. Note: Page 1 has index 0
EndIndex
Type: SystemInt32
The end page index. Note: The last page has index PageCount -1

Return Value

Type: String
The text extracted from the PDF pages as a string.
See Also

Reference

PdfDocument Class
ExtractTextFromPages Overload


PdfDocument.Flatten Method

PdfDocumentFlatten Method

Flattens a document (make the fields non-editable).

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public void Flatten()
Public Sub Flatten
member Flatten : unit -> unit
See Also

Reference

PdfDocument Class


PdfDocument.FromFile Method

PdfDocumentFromFile Method

Opens an existing PDF document for editing.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public static PdfDocument FromFile(
    string PdfFilePath,
    string password = null,
    string ownerPassword = null
)
Public Shared Function FromFile (
    PdfFilePath As String,
    Optional password As String = Nothing,
    Optional ownerPassword As String = Nothing
) As PdfDocument
static member FromFile :
        PdfFilePath : string *
        ?password : string *
        ?ownerPassword : string
(* Defaults:
        let _password = defaultArg password null
        let _ownerPassword = defaultArg ownerPassword null
*)
-> PdfDocument

Parameters

PdfFilePath
Type: SystemString
The PDF file path.
password (Optional)
Type: SystemString
Optional user password if the PDF document is encrypted.
ownerPassword (Optional)
Type: SystemString
Optional password if the PDF document is protected by owner (printing, modifying restrictions etc..).

Return Value

Type: PdfDocument
An IronPdf.PdfDocument object as loaded from the file path.
Exceptions
Exception | Condition
IOException | Exception thrown if can not be opened.
See Also

Reference

PdfDocument Class


PdfDocument.GetPageRotation Method

PdfDocumentGetPageRotation Method

Gets the rotation of a PDF page in degrees.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public int GetPageRotation(
    int PageIndex
)
Public Function GetPageRotation (
    PageIndex As Integer
) As Integer
member GetPageRotation :
        PageIndex : int -> int

Parameters

PageIndex
Type: SystemInt32
Index of the page to inspect. PageIndex is a 'Zero based' page number, the first page being 0.

Return Value

Type: Int32
A number of degrees rotation
See Also

Reference

PdfDocument Class


PdfDocument.GetPrintDocument Method

PdfDocumentGetPrintDocument Method

Returns a PrintDocument for the PDF allowing developers granular control over sending the PDF to a Printer.

An assembly reference to System.Drawing is required in your project.

Available in IronPDF for .Net Framework, and .Net Core. For Linux and OSX targets please install the PDFium library to your application or bin directory for this functionality to work.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PrintDocument GetPrintDocument()
Public Function GetPrintDocument As PrintDocument
member GetPrintDocument : unit -> PrintDocument

Return Value

Type: PrintDocument
A PrintDocument.
Exceptions
Exception | Condition
Exception | IronPdf must be licensed to use this feature.
See Also

Reference

PdfDocument Class


PdfDocument.InsertPdf Method

PdfDocumentInsertPdf Method

Inserts another PDF into of the current PdfDocument, starting at a given Page Index.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument InsertPdf(
    PdfDocument AnotherPdfFile,
    int AtIndex = 0
)
Public Function InsertPdf (
    AnotherPdfFile As PdfDocument,
    Optional AtIndex As Integer = 0
) As PdfDocument
member InsertPdf :
        AnotherPdfFile : PdfDocument *
        ?AtIndex : int
(* Defaults:
        let _AtIndex = defaultArg AtIndex 0
*)
-> PdfDocument

Parameters

AnotherPdfFile
Type: IronPdfPdfDocument
Another PdfDocument.
AtIndex (Optional)
Type: SystemInt32
Index at which to insert the new content. Note: Page 1 has index 0...

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class


PdfDocument.Merge Method

PdfDocumentMerge Method

Overload List
Name | Description
Merge(IEnumerablePdfDocument) | Static method that joins (concatenates) multiple PDF documents together into one compiled PDF document.
Merge(PdfDocument, PdfDocument) | Static method that joins (concatenates) 2 PDF documents together into one final PDF document.
Top
See Also

Reference

PdfDocument Class


PdfDocument.Merge Method (IEnumerable(PdfDocument))

PdfDocumentMerge Method (IEnumerablePdfDocument)

Static method that joins (concatenates) multiple PDF documents together into one compiled PDF document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public static PdfDocument Merge(
    IEnumerable<PdfDocument> PDFs
)
Public Shared Function Merge (
    PDFs As IEnumerable(Of PdfDocument)
) As PdfDocument
static member Merge :
        PDFs : IEnumerable<PdfDocument> -> PdfDocument

Parameters

PDFs
Type: System.Collections.GenericIEnumerable PdfDocument
A IEnumerable of PdfDocument. To merge existing PDF files you may use the PdfDocument.FromFile static method in conjunction with Merge.

Return Value

Type: PdfDocument
The merged PDF file.
See Also

Reference

PdfDocument Class
Merge Overload


PdfDocument.Merge Method (PdfDocument, PdfDocument)

PdfDocumentMerge Method (PdfDocument, PdfDocument)

Static method that joins (concatenates) 2 PDF documents together into one final PDF document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public static PdfDocument Merge(
    PdfDocument A,
    PdfDocument B
)
Public Shared Function Merge (
    A As PdfDocument,
    B As PdfDocument
) As PdfDocument
static member Merge :
        A : PdfDocument *
        B : PdfDocument -> PdfDocument

Parameters

A
Type: IronPdfPdfDocument
A PDF
B
Type: IronPdfPdfDocument
A Seconds PDF

Return Value

Type: PdfDocument
A new merged PDF file.
See Also

Reference

PdfDocument Class
Merge Overload


PdfDocument.PageToBitmap Method

PdfDocumentPageToBitmap Method

Overload List
 | Name | Description
Public method | PageToBitmap(Int32, Int32) | Renders a single page of the PDF to a System.Drawing.Bitmap object. Please add an assembly reference to System.Drawing to use this "PDF To Image" method Please Dispose() each Bitmap object after use.
Public method | PageToBitmap(Int32, NullableInt32, NullableInt32, Int32) | Renders a single page of the PDF to a System.Drawing.Bitmap object. Please add an assembly reference to System.Drawing to use this "PDF To Image" method Please Dispose() each Bitmap object after use.
Top
See Also

Reference

PdfDocument Class


PdfDocument.PageToBitmap Method (Int32, Int32)

PdfDocumentPageToBitmap Method (Int32, Int32)

Renders a single page of the PDF to a System.Drawing.Bitmap object.

Please add an assembly reference to System.Drawing to use this "PDF To Image" method

Please Dispose() each Bitmap object after use.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public Bitmap PageToBitmap(
    int PageNumber,
    int DPI = 72
)
Public Function PageToBitmap (
    PageNumber As Integer,
    Optional DPI As Integer = 72
) As Bitmap
member PageToBitmap :
        PageNumber : int *
        ?DPI : int
(* Defaults:
        let _DPI = defaultArg DPI 72
*)
-> Bitmap

Parameters

PageNumber
Type: SystemInt32
The page number to be converted to an image.
DPI (Optional)
Type: SystemInt32
The desired resolution of the output Images.

Return Value

Type: Bitmap
A System.Drawing.Bitmap of the rendered PDF page.
See Also

Reference

PdfDocument Class
PageToBitmap Overload


PdfDocument.PageToBitmap Method (Int32, Nullable(Int32), Nullable(Int32), Int32)

PdfDocumentPageToBitmap Method (Int32, NullableInt32, NullableInt32, Int32)

Renders a single page of the PDF to a System.Drawing.Bitmap object.

Please add an assembly reference to System.Drawing to use this "PDF To Image" method

Please Dispose() each Bitmap object after use.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public Bitmap PageToBitmap(
    int pageNumber,
    Nullable<int> imageMaxWidth,
    Nullable<int> imageMaxHeight,
    int DPI = 72
)
Public Function PageToBitmap (
    pageNumber As Integer,
    imageMaxWidth As Nullable(Of Integer),
    imageMaxHeight As Nullable(Of Integer),
    Optional DPI As Integer = 72
) As Bitmap
member PageToBitmap :
        pageNumber : int *
        imageMaxWidth : Nullable<int> *
        imageMaxHeight : Nullable<int> *
        ?DPI : int
(* Defaults:
        let _DPI = defaultArg DPI 72
*)
-> Bitmap

Parameters

pageNumber
Type: SystemInt32
The page number to be converted to an image.
imageMaxWidth
Type: SystemNullable Int32
The target maximum width of the output images.
imageMaxHeight
Type: SystemNullable Int32
The target maximum height of the output images.
DPI (Optional)
Type: SystemInt32
The desired resolution of the output Images.

Return Value

Type: Bitmap
A System.Drawing.Bitmap of the rendered PDF page.
See Also

Reference

PdfDocument Class
PageToBitmap Overload


PdfDocument.PrependPdf Method

PdfDocumentPrependPdf Method

Adds another PDF to the beginning of the current PdfDocument

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument PrependPdf(
    PdfDocument AnotherPdfFile
)
Public Function PrependPdf (
    AnotherPdfFile As PdfDocument
) As PdfDocument
member PrependPdf :
        AnotherPdfFile : PdfDocument -> PdfDocument

Parameters

AnotherPdfFile
Type: IronPdfPdfDocument
PdfDocument to prepend.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class


PdfDocument.Print Method

PdfDocumentPrint Method

Prints this PDF by sending it to the computer's default printer.

Windows print UI dialogs will be displayed to the user.

For advanced real-world printing options please see GetPrintDocument.

Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public void Print()
Public Sub Print
member Print : unit -> unit
See Also

Reference

PdfDocument Class


PdfDocument.QuickSignPdfWithDigitalSignatureFile Method

PdfDocumentQuickSignPdfWithDigitalSignatureFile Method

Sign PDF with digital signature certificate. For more advanced Options please see QuickSignPdfWithDigitalSignatureFile(String, String)

Note that the PDF will not be fully signed until Saved using SaveAs(String), TrySaveAs(String), Stream or BinaryData. Multiple certificates may be used.

Not implemented in .Net Core

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument QuickSignPdfWithDigitalSignatureFile(
    string CertificateFilePath,
    string Password
)
Public Function QuickSignPdfWithDigitalSignatureFile (
    CertificateFilePath As String,
    Password As String
) As PdfDocument
member QuickSignPdfWithDigitalSignatureFile :
        CertificateFilePath : string *
        Password : string -> PdfDocument

Parameters

CertificateFilePath
Type: SystemString
The file path to a .pfx or .p12 digital signing certificate which may be generated using Adobe Acrobat Viewer.
Password
Type: SystemString
The certificate password as a String.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class
IronPdf Namespace
IronPdfPdfSignature


PdfDocument.RasterizeToImageFiles Method

PdfDocumentRasterizeToImageFiles Method

Overload List
 | Name | Description
Public method | RasterizeToImageFiles(String, ImageType, Int32) | Renders the PDF and exports image Files in convenient formats. 1 image file is created for each page. FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Public method | RasterizeToImageFiles(String, IEnumerableInt32, ImageType, Int32) | Renders the PDF and exports image Files in convenient formats. Page Numbers may be specified. 1 image file is created for each page. FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Public method | RasterizeToImageFiles(String, NullableInt32, NullableInt32, ImageType, Int32) | Renders the PDF and exports image Files in convenient formats. Image dimensions may be specified. 1 image file is created for each page. FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers
Public method | RasterizeToImageFiles(String, IEnumerableInt32, NullableInt32, NullableInt32, ImageType, Int32) | Renders the PDF and exports image Files in convenient formats. Page Numbers may be specified. 1 image file is created for each page. FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Top
See Also

Reference

PdfDocument Class


PdfDocument.RasterizeToImageFiles Method (String, ImageType, Int32)

PdfDocumentRasterizeToImageFiles Method (String, ImageType, Int32)

Renders the PDF and exports image Files in convenient formats. 1 image file is created for each page.

FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers

Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string[] RasterizeToImageFiles(
    string FileNamePattern,
    ImageType ImageFileType = ImageType.Default,
    int DPI = 72
)
Public Function RasterizeToImageFiles (
    FileNamePattern As String,
    Optional ImageFileType As ImageType = ImageType.Default,
    Optional DPI As Integer = 72
) As String()
member RasterizeToImageFiles :
        FileNamePattern : string *
        ?ImageFileType : ImageType *
        ?DPI : int
(* Defaults:
        let _ImageFileType = defaultArg ImageFileType ImageType.Default
        let _DPI = defaultArg DPI 72
*)
-> string[]

Parameters

FileNamePattern
Type: SystemString
A full or partial file path for the output files containing an asterisk. E.g. C:\images\pdf_page_*.png
ImageFileType (Optional)
Type: IronPdfImageType
Type of the image file. If not specified, a best guess will be taken from the FileNamePattern file extension
DPI (Optional)
Type: SystemInt32
The desired resolution of the output Images.

Return Value

Type: String
An array of the file paths of the image files created.
See Also

Reference

PdfDocument Class
RasterizeToImageFiles Overload


PdfDocument.RasterizeToImageFiles Method (String, IEnumerable(Int32), ImageType, Int32)

PdfDocumentRasterizeToImageFiles Method (String, IEnumerableInt32, ImageType, Int32)

Renders the PDF and exports image Files in convenient formats. Page Numbers may be specified. 1 image file is created for each page.

FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers

Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string[] RasterizeToImageFiles(
    string FileNamePattern,
    IEnumerable<int> PageNumbers,
    ImageType ImageFileType = ImageType.Default,
    int DPI = 72
)
Public Function RasterizeToImageFiles (
    FileNamePattern As String,
    PageNumbers As IEnumerable(Of Integer),
    Optional ImageFileType As ImageType = ImageType.Default,
    Optional DPI As Integer = 72
) As String()
member RasterizeToImageFiles :
        FileNamePattern : string *
        PageNumbers : IEnumerable<int> *
        ?ImageFileType : ImageType *
        ?DPI : int
(* Defaults:
        let _ImageFileType = defaultArg ImageFileType ImageType.Default
        let _DPI = defaultArg DPI 72
*)
-> string[]

Parameters

FileNamePattern
Type: SystemString
A full or partial file path for the output files containing an asterisk. E.g. C:\images\pdf_page_*.png
PageNumbers
Type: System.Collections.GenericIEnumerable Int32
A list of the specific page numbers to render as images.
ImageFileType (Optional)
Type: IronPdfImageType
Type of the image file. If not specified, a best guess will be taken from the FileNamePattern file extension
DPI (Optional)
Type: SystemInt32
The desired resolution of the output Images.

Return Value

Type: String
An array of the file paths of the image files created.
See Also

Reference

PdfDocument Class
RasterizeToImageFiles Overload


PdfDocument.RasterizeToImageFiles Method (String, Nullable(Int32), Nullable(Int32), ImageType, Int32)

PdfDocumentRasterizeToImageFiles Method (String, NullableInt32, NullableInt32, ImageType, Int32)

Renders the PDF and exports image Files in convenient formats. Image dimensions may be specified. 1 image file is created for each page.

FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string[] RasterizeToImageFiles(
    string FileNamePattern,
    Nullable<int> ImageMaxWidth,
    Nullable<int> ImageMaxHeight,
    ImageType ImageFileType = ImageType.Default,
    int DPI = 72
)
Public Function RasterizeToImageFiles (
    FileNamePattern As String,
    ImageMaxWidth As Nullable(Of Integer),
    ImageMaxHeight As Nullable(Of Integer),
    Optional ImageFileType As ImageType = ImageType.Default,
    Optional DPI As Integer = 72
) As String()
member RasterizeToImageFiles :
        FileNamePattern : string *
        ImageMaxWidth : Nullable<int> *
        ImageMaxHeight : Nullable<int> *
        ?ImageFileType : ImageType *
        ?DPI : int
(* Defaults:
        let _ImageFileType = defaultArg ImageFileType ImageType.Default
        let _DPI = defaultArg DPI 72
*)
-> string[]

Parameters

FileNamePattern
Type: SystemString
A full or partial file path for the output files containing an asterisk. E.g. C:\images\pdf_page_*.png
ImageMaxWidth
Type: SystemNullable Int32
The target maximum width of the output images.
ImageMaxHeight
Type: SystemNullable Int32
The target maximum height of the output images.
ImageFileType (Optional)
Type: IronPdfImageType
Type of the image file. If not specified, a best guess will be taken from the FileNamePattern file extension
DPI (Optional)
Type: SystemInt32
The desired resolution of the output Images.

Return Value

Type: String
An array of the file paths of the image files created.
See Also

Reference

PdfDocument Class
RasterizeToImageFiles Overload


PdfDocument.RasterizeToImageFiles Method (String, IEnumerable(Int32), Nullable(Int32), Nullable(Int32), ImageType, Int32)

PdfDocumentRasterizeToImageFiles Method (String, IEnumerableInt32, NullableInt32, NullableInt32, ImageType, Int32)

Renders the PDF and exports image Files in convenient formats. Page Numbers may be specified. 1 image file is created for each page.

FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers

Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string[] RasterizeToImageFiles(
    string FileNamePattern,
    IEnumerable<int> PageNumbers,
    Nullable<int> ImageMaxWidth,
    Nullable<int> ImageMaxHeight,
    ImageType ImageFileType = ImageType.Default,
    int DPI = 72
)
Public Function RasterizeToImageFiles (
    FileNamePattern As String,
    PageNumbers As IEnumerable(Of Integer),
    ImageMaxWidth As Nullable(Of Integer),
    ImageMaxHeight As Nullable(Of Integer),
    Optional ImageFileType As ImageType = ImageType.Default,
    Optional DPI As Integer = 72
) As String()
member RasterizeToImageFiles :
        FileNamePattern : string *
        PageNumbers : IEnumerable<int> *
        ImageMaxWidth : Nullable<int> *
        ImageMaxHeight : Nullable<int> *
        ?ImageFileType : ImageType *
        ?DPI : int
(* Defaults:
        let _ImageFileType = defaultArg ImageFileType ImageType.Default
        let _DPI = defaultArg DPI 72
*)
-> string[]

Parameters

FileNamePattern
Type: SystemString
A full or partial file path for the output files containing an asterisk. E.g. C:\images\pdf_page_*.png
PageNumbers
Type: System.Collections.GenericIEnumerable Int32
A list of the specific page numbers to render as images.
ImageMaxWidth
Type: SystemNullable Int32
The target maximum width of the output images.
ImageMaxHeight
Type: SystemNullable Int32
The target maximum height of the output images.
ImageFileType (Optional)
Type: IronPdfImageType
Type of the image file. If not specified, a best guess will be taken from the FileNamePattern file extension
DPI (Optional)
Type: SystemInt32
The desired resolution of the output Images.

Return Value

Type: String
An array of the file paths of the image files created.
See Also

Reference

PdfDocument Class
RasterizeToImageFiles Overload


PdfDocument.RemovePage Method

PdfDocumentRemovePage Method

Removes a page from the PDF at the given index.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument RemovePage(
    int PageIndex
)
Public Function RemovePage (
    PageIndex As Integer
) As PdfDocument
member RemovePage :
        PageIndex : int -> PdfDocument

Parameters

PageIndex
Type: SystemInt32
Index of the page. Note: Page 1 has index 0...

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class


PdfDocument.RemovePages Method

PdfDocumentRemovePages Method

Overload List
 | Name | Description
Public method | RemovePages(IEnumerableInt32) | Removes a range of pages from the PDF
Public method | RemovePages(Int32, Int32) | Removes a range of pages from the PDF
Top
See Also

Reference

PdfDocument Class


PdfDocument.RemovePages Method (IEnumerable(Int32))

PdfDocumentRemovePages Method (IEnumerableInt32)

Removes a range of pages from the PDF

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument RemovePages(
    IEnumerable<int> PageIndexes
)
Public Function RemovePages (
    PageIndexes As IEnumerable(Of Integer)
) As PdfDocument
member RemovePages :
        PageIndexes : IEnumerable<int> -> PdfDocument

Parameters

PageIndexes
Type: System.Collections.GenericIEnumerable Int32
An list of pages indexes to remove.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class
RemovePages Overload


PdfDocument.RemovePages Method (Int32, Int32)

PdfDocumentRemovePages Method (Int32, Int32)

Removes a range of pages from the PDF

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument RemovePages(
    int StartIndex,
    int EndIndex
)
Public Function RemovePages (
    StartIndex As Integer,
    EndIndex As Integer
) As PdfDocument
member RemovePages :
        StartIndex : int *
        EndIndex : int -> PdfDocument

Parameters

StartIndex
Type: SystemInt32
The start index. Note: Page 1 has index 0
EndIndex
Type: SystemInt32
The end index. Note: The last page has index PageCount -1

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class
RemovePages Overload


PdfDocument.RotateAllPages Method

PdfDocumentRotateAllPages Method

Rotates all pages of the PdfDocument by a specified number of degrees.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public void RotateAllPages(
    int Degrees
)
Public Sub RotateAllPages (
    Degrees As Integer
)
member RotateAllPages :
        Degrees : int -> unit

Parameters

Degrees
Type: SystemInt32
The number of degrees to rotate the pages. 0, 90, 180 or 270 are accepted values.
See Also

Reference

PdfDocument Class


PdfDocument.RotatePage Method

PdfDocumentRotatePage Method

Rotates one page of the PdfDocument by a specified number of degrees.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public void RotatePage(
    int PageIndex,
    int Degrees
)
Public Sub RotatePage (
    PageIndex As Integer,
    Degrees As Integer
)
member RotatePage :
        PageIndex : int *
        Degrees : int -> unit

Parameters

PageIndex
Type: SystemInt32
Index of the page to rotate. PageIndex is a 'Zero based' page number, the first page being 0.
Degrees
Type: SystemInt32
The number of degrees to rotate the pages. 0, 90, 180 or 270 are accepted values.
See Also

Reference

PdfDocument Class


PdfDocument.RotateSelectedPages Method

PdfDocumentRotateSelectedPages Method

Rotates selected pages of the PdfDocument by a specified number of degrees.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public void RotateSelectedPages(
    IEnumerable<int> PageIndexes,
    int Degrees
)
Public Sub RotateSelectedPages (
    PageIndexes As IEnumerable(Of Integer),
    Degrees As Integer
)
member RotateSelectedPages :
        PageIndexes : IEnumerable<int> *
        Degrees : int -> unit

Parameters

PageIndexes
Type: System.Collections.GenericIEnumerable Int32
Indexes of the pages to rotate in an IEnumerable, list or array. PageIndex is a 'Zero based' page number, the first page being 0.
Degrees
Type: SystemInt32
The number of degrees to rotate the pages. 0, 90, 180 or 270 are accepted values.
See Also

Reference

PdfDocument Class


PdfDocument.SaveAs Method

PdfDocumentSaveAs Method

Saves the PdfDocument to a file.

Supports site relative paths staring with "~/" in .Net Framework Web 4+ Applications

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument SaveAs(
    string FileName
)
Public Function SaveAs (
    FileName As String
) As PdfDocument
member SaveAs :
        FileName : string -> PdfDocument

Parameters

FileName
Type: SystemString
File Path

Return Value

Type: PdfDocument
This PdfDocument for fluid code notation.
See Also

Reference

PdfDocument Class


PdfDocument.SignPdfWithDigitalSignature Method

PdfDocumentSignPdfWithDigitalSignature Method

Signs the PDF with digital signature with advanced options.

Note that the PDF will not be fully signed until Saved using SaveAs(String), TrySaveAs(String), Stream or BinaryData. Multiple certificates may be used.

Not implemented in .Net Core

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument SignPdfWithDigitalSignature(
    PdfSignature Signature
)
Public Function SignPdfWithDigitalSignature (
    Signature As PdfSignature
) As PdfDocument
member SignPdfWithDigitalSignature :
        Signature : PdfSignature -> PdfDocument

Parameters

Signature
Type: IronPdfPdfSignature
The PdfSignature.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class


PdfDocument.StampHTML Method

PdfDocumentStampHTML Method

Overload List
 | Name | Description
Public method | StampHTML(HtmlStamp) | Edits the PDF by adding rendered HTML either behind or in-front of the existing contents of every page.
Public method | StampHTML(HtmlStamp, IEnumerableInt32) | Edits the PDF by adding rendered HTML either behind or in-front of the existing contents of specified pages.
Public method | StampHTML(HtmlStamp, Int32) | Edits the PDF by adding rendered HTML either behind or in-front of the existing contents of one page.
Top
See Also

Reference

PdfDocument Class


PdfDocument.StampHTML Method (HtmlStamp)

PdfDocumentStampHTML Method (HtmlStamp)

Edits the PDF by adding rendered HTML either behind or in-front of the existing contents of every page.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument StampHTML(
    HtmlStamp Stamp
)
Public Function StampHTML (
    Stamp As HtmlStamp
) As PdfDocument
member StampHTML :
        Stamp : HtmlStamp -> PdfDocument

Parameters

Stamp
Type: IronPdfHtmlStamp
The HtmlStamp stamp.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class
StampHTML Overload


PdfDocument.StampHTML Method (HtmlStamp, IEnumerable(Int32))

PdfDocumentStampHTML Method (HtmlStamp, IEnumerableInt32)

Edits the PDF by adding rendered HTML either behind or in-front of the existing contents of specified pages.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument StampHTML(
    HtmlStamp Stamp,
    IEnumerable<int> PageIndexesToStamp
)
Public Function StampHTML (
    Stamp As HtmlStamp,
    PageIndexesToStamp As IEnumerable(Of Integer)
) As PdfDocument
member StampHTML :
        Stamp : HtmlStamp *
        PageIndexesToStamp : IEnumerable<int> -> PdfDocument

Parameters

Stamp
Type: IronPdfHtmlStamp
The HtmlStamp stamp.
PageIndexesToStamp
Type: System.Collections.GenericIEnumerable Int32
The list page indexes (zero-based page number) to stamp.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class
StampHTML Overload


PdfDocument.StampHTML Method (HtmlStamp, Int32)

PdfDocumentStampHTML Method (HtmlStamp, Int32)

Edits the PDF by adding rendered HTML either behind or in-front of the existing contents of one page.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument StampHTML(
    HtmlStamp Stamp,
    int PageIndexToStamp
)
Public Function StampHTML (
    Stamp As HtmlStamp,
    PageIndexToStamp As Integer
) As PdfDocument
member StampHTML :
        Stamp : HtmlStamp *
        PageIndexToStamp : int -> PdfDocument

Parameters

Stamp
Type: IronPdfHtmlStamp
The HtmlStamp stamp.
PageIndexToStamp
Type: SystemInt32
The page index (zero-based page number) to stamp.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class
StampHTML Overload


PdfDocument.ToBitmap Method

PdfDocumentToBitmap Method

Overload List
 | Name | Description
Public method | ToBitmap(Int32) | Rasterizes (renders) the PDF into System.Drawing.Bitmap objects. 1 Bitmap for each page. Please add an assembly reference to System.Drawing to use this "PDF To Image" method. Please Dispose() each Bitmap object after use.
Public method | ToBitmap(IEnumerableInt32, Int32) | Rasterizes (renders) the PDF into System.Drawing.Bitmap objects. Specific pages may be selected using the PageNumbers parameter. Please add an assembly reference to System.Drawing to use this "PDF To Image" method Please Dispose() each Bitmap object after use.
Public method | ToBitmap(NullableInt32, NullableInt32, IEnumerableInt32, Int32) | Rasterizes (renders) the PDF into System.Drawing.Bitmap objects. Specific pages may be selected using the PageNumbers parameter. The Widths and Height of the output images may be specified. Please add an assembly reference to System.Drawing to use this "PDF To Image" method Please Dispose() each Bitmap object after use.
Top
See Also

Reference

PdfDocument Class


PdfDocument.ToBitmap Method (Int32)

PdfDocumentToBitmap Method (Int32)

Rasterizes (renders) the PDF into System.Drawing.Bitmap objects. 1 Bitmap for each page.

Please add an assembly reference to System.Drawing to use this "PDF To Image" method.

Please Dispose() each Bitmap object after use.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public Bitmap[] ToBitmap(
    int DPI = 72
)
Public Function ToBitmap (
    Optional DPI As Integer = 72
) As Bitmap()
member ToBitmap :
        ?DPI : int
(* Defaults:
        let _DPI = defaultArg DPI 72
*)
-> Bitmap[]

Parameters

DPI (Optional)
Type: SystemInt32
The resolution of the output Bitmap in 'Dots Per Inch'. Higher DPI creates larger bitmap files of higher image quality.

Return Value

Type: Bitmap
An array of System.Drawing.Bitmap image objects which can be saved, manipulated, displayed or edited programmatically.
See Also

Reference

PdfDocument Class
ToBitmap Overload


PdfDocument.ToBitmap Method (IEnumerable(Int32), Int32)

PdfDocumentToBitmap Method (IEnumerableInt32, Int32)

Rasterizes (renders) the PDF into System.Drawing.Bitmap objects.

Specific pages may be selected using the PageNumbers parameter.

Please add an assembly reference to System.Drawing to use this "PDF To Image" method

Please Dispose() each Bitmap object after use.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public Bitmap[] ToBitmap(
    IEnumerable<int> pageNumbers,
    int DPI = 72
)
Public Function ToBitmap (
    pageNumbers As IEnumerable(Of Integer),
    Optional DPI As Integer = 72
) As Bitmap()
member ToBitmap :
        pageNumbers : IEnumerable<int> *
        ?DPI : int
(* Defaults:
        let _DPI = defaultArg DPI 72
*)
-> Bitmap[]

Parameters

pageNumbers
Type: System.Collections.GenericIEnumerable Int32
Specific page numbers may be given to only convert part of the PDF document to images
DPI (Optional)
Type: SystemInt32
The desired resolution of the output Images.

Return Value

Type: Bitmap
An array of System.Drawing.Bitmap image objects which can be saved, manipulated, displayed or edited programmatically.
See Also

Reference

PdfDocument Class
ToBitmap Overload


PdfDocument.ToBitmap Method (Nullable(Int32), Nullable(Int32), IEnumerable(Int32), Int32)

PdfDocumentToBitmap Method (NullableInt32, NullableInt32, IEnumerableInt32, Int32)

Rasterizes (renders) the PDF into System.Drawing.Bitmap objects.

Specific pages may be selected using the PageNumbers parameter. The Widths and Height of the output images may be specified.

Please add an assembly reference to System.Drawing to use this "PDF To Image" method

Please Dispose() each Bitmap object after use.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public Bitmap[] ToBitmap(
    Nullable<int> imageMaxWidth,
    Nullable<int> imageMaxHeight,
    IEnumerable<int> pageNumbers = null,
    int DPI = 72
)
Public Function ToBitmap (
    imageMaxWidth As Nullable(Of Integer),
    imageMaxHeight As Nullable(Of Integer),
    Optional pageNumbers As IEnumerable(Of Integer) = Nothing,
    Optional DPI As Integer = 72
) As Bitmap()
member ToBitmap :
        imageMaxWidth : Nullable<int> *
        imageMaxHeight : Nullable<int> *
        ?pageNumbers : IEnumerable<int> *
        ?DPI : int
(* Defaults:
        let _pageNumbers = defaultArg pageNumbers null
        let _DPI = defaultArg DPI 72
*)
-> Bitmap[]

Parameters

imageMaxWidth
Type: SystemNullable Int32
The target maximum width(in mm) of the output images.
imageMaxHeight
Type: SystemNullable Int32
The target maximum height(in mm) of the output images.
pageNumbers (Optional)
Type: System.Collections.GenericIEnumerable Int32
Specific page numbers may be given to only convert part of the PDF document to images
DPI (Optional)
Type: SystemInt32
The desired resolution of the output Images.

Return Value

Type: Bitmap
An array of System.Drawing.Bitmap image objects which can be saved, manipulated, displayed or edited programmatically.
See Also

Reference

PdfDocument Class
ToBitmap Overload


PdfDocument.ToJpegImages Method

PdfDocumentToJpegImages Method

Overload List
 | Name | Description
Public method | ToJpegImages(String, Int32) | Renders the pages of the PDF as JPEG files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers
Public method | ToJpegImages(String, IEnumerableInt32, Int32) | Renders the pages of the PDF as JPEG files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Public method | ToJpegImages(String, NullableInt32, NullableInt32, Int32) | Renders the pages of the PDF as JPEG files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Public method | ToJpegImages(String, IEnumerableInt32, NullableInt32, NullableInt32, Int32) | Renders the pages of the PDF as JPEG files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers
Top
See Also

Reference

PdfDocument Class


PdfDocument.ToJpegImages Method (String, Int32)

PdfDocumentToJpegImages Method (String, Int32)

Renders the pages of the PDF as JPEG files and saves them to disk.

Specific image dimensions and page numbers may be given as optional parameters

FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string[] ToJpegImages(
    string FileNamePattern,
    int DPI = 72
)
Public Function ToJpegImages (
    FileNamePattern As String,
    Optional DPI As Integer = 72
) As String()
member ToJpegImages :
        FileNamePattern : string *
        ?DPI : int
(* Defaults:
        let _DPI = defaultArg DPI 72
*)
-> string[]

Parameters

FileNamePattern
Type: SystemString
A full or partial file path for the output files containing an asterisk. E.g. C:\images\pdf_page_*.jpg
DPI (Optional)
Type: SystemInt32
The desired resolution of the output Images.

Return Value

Type: String
An array of the file paths of the image files created.
See Also

Reference

PdfDocument Class
ToJpegImages Overload


PdfDocument.ToJpegImages Method (String, IEnumerable(Int32), Int32)

PdfDocumentToJpegImages Method (String, IEnumerableInt32, Int32)

Renders the pages of the PDF as JPEG files and saves them to disk.

Specific image dimensions and page numbers may be given as optional parameters

FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers

Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string[] ToJpegImages(
    string FileNamePattern,
    IEnumerable<int> PageNumbers,
    int DPI = 72
)
Public Function ToJpegImages (
    FileNamePattern As String,
    PageNumbers As IEnumerable(Of Integer),
    Optional DPI As Integer = 72
) As String()
member ToJpegImages :
        FileNamePattern : string *
        PageNumbers : IEnumerable<int> *
        ?DPI : int
(* Defaults:
        let _DPI = defaultArg DPI 72
*)
-> string[]

Parameters

FileNamePattern
Type: SystemString
A full or partial file path for the output files containing an asterisk. E.g. C:\images\pdf_page_*.jpg
PageNumbers
Type: System.Collections.GenericIEnumerable Int32
A list of the specific page numbers to render as images.
DPI (Optional)
Type: SystemInt32
The desired resolution of the output Images.

Return Value

Type: String
An array of the file paths of the image files created.
See Also

Reference

PdfDocument Class
ToJpegImages Overload


PdfDocument.ToJpegImages Method (String, Nullable(Int32), Nullable(Int32), Int32)

PdfDocumentToJpegImages Method (String, NullableInt32, NullableInt32, Int32)

Renders the pages of the PDF as JPEG files and saves them to disk.

Specific image dimensions and page numbers may be given as optional parameters

FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers

Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string[] ToJpegImages(
    string FileNamePattern,
    Nullable<int> ImageMaxWidth,
    Nullable<int> ImageMaxHeight,
    int DPI = 72
)
Public Function ToJpegImages (
    FileNamePattern As String,
    ImageMaxWidth As Nullable(Of Integer),
    ImageMaxHeight As Nullable(Of Integer),
    Optional DPI As Integer = 72
) As String()
member ToJpegImages :
        FileNamePattern : string *
        ImageMaxWidth : Nullable<int> *
        ImageMaxHeight : Nullable<int> *
        ?DPI : int
(* Defaults:
        let _DPI = defaultArg DPI 72
*)
-> string[]

Parameters

FileNamePattern
Type: SystemString
A full or partial file path for the output files containing an asterisk. E.g. C:\images\pdf_page_*.jpg
ImageMaxWidth
Type: SystemNullable Int32
The target maximum width of the output images.
ImageMaxHeight
Type: SystemNullable Int32
The target maximum height of the output images.
DPI (Optional)
Type: SystemInt32
The desired resolution of the output Images.

Return Value

Type: String
An array of the file paths of the image files created.
See Also

Reference

PdfDocument Class
ToJpegImages Overload


PdfDocument.ToJpegImages Method (String, IEnumerable(Int32), Nullable(Int32), Nullable(Int32), Int32)

PdfDocumentToJpegImages Method (String, IEnumerableInt32, NullableInt32, NullableInt32, Int32)

Renders the pages of the PDF as JPEG files and saves them to disk.

Specific image dimensions and page numbers may be given as optional parameters

FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string[] ToJpegImages(
    string FileNamePattern,
    IEnumerable<int> PageNumbers,
    Nullable<int> ImageMaxWidth,
    Nullable<int> ImageMaxHeight,
    int DPI = 72
)
Public Function ToJpegImages (
    FileNamePattern As String,
    PageNumbers As IEnumerable(Of Integer),
    ImageMaxWidth As Nullable(Of Integer),
    ImageMaxHeight As Nullable(Of Integer),
    Optional DPI As Integer = 72
) As String()
member ToJpegImages :
        FileNamePattern : string *
        PageNumbers : IEnumerable<int> *
        ImageMaxWidth : Nullable<int> *
        ImageMaxHeight : Nullable<int> *
        ?DPI : int
(* Defaults:
        let _DPI = defaultArg DPI 72
*)
-> string[]

Parameters

FileNamePattern
Type: SystemString
A full or partial file path for the output files containing an asterisk. E.g. C:\images\pdf_page_*.jpg
PageNumbers
Type: System.Collections.GenericIEnumerable Int32
A list of the specific page numbers to render as images.
ImageMaxWidth
Type: SystemNullable Int32
The target maximum width of the output images.
ImageMaxHeight
Type: SystemNullable Int32
The target maximum height of the output images.
DPI (Optional)
Type: SystemInt32
The desired resolution of the output Images.

Return Value

Type: String
An array of the file paths of the image files created.
See Also

Reference

PdfDocument Class
ToJpegImages Overload


PdfDocument.ToPngImages Method

PdfDocumentToPngImages Method

Overload List
 | Name | Description
Public method | ToPngImages(String, Int32) | Renders the pages of the PDF as PNG (Portable Network Graphic) files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers
Public method | ToPngImages(String, IEnumerableInt32, Int32) | Renders the pages of the PDF as PNG (Portable Network Graphic) files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Public method | ToPngImages(String, NullableInt32, NullableInt32, Int32) | Renders the pages of the PDF as PNG (Portable Network Graphic) files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Public method | ToPngImages(String, IEnumerableInt32, NullableInt32, NullableInt32, Int32) | Renders the pages of the PDF as PNG (Portable Network Graphic) files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Top
See Also

Reference

PdfDocument Class


PdfDocument.ToPngImages Method (String, Int32)

PdfDocumentToPngImages Method (String, Int32)

Renders the pages of the PDF as PNG (Portable Network Graphic) files and saves them to disk.

Specific image dimensions and page numbers may be given as optional parameters

FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string[] ToPngImages(
    string FileNamePattern,
    int DPI = 72
)
Public Function ToPngImages (
    FileNamePattern As String,
    Optional DPI As Integer = 72
) As String()
member ToPngImages :
        FileNamePattern : string *
        ?DPI : int
(* Defaults:
        let _DPI = defaultArg DPI 72
*)
-> string[]

Parameters

FileNamePattern
Type: SystemString
A full or partial file path for the output files containing an asterisk. E.g. C:\images\pdf_pages_*.png
DPI (Optional)
Type: SystemInt32
The desired resolution of the output Images.

Return Value

Type: String
An array of the file paths of the image files created.
See Also

Reference

PdfDocument Class
ToPngImages Overload


PdfDocument.ToPngImages Method (String, IEnumerable(Int32), Int32)

PdfDocumentToPngImages Method (String, IEnumerableInt32, Int32)

Renders the pages of the PDF as PNG (Portable Network Graphic) files and saves them to disk.

Specific image dimensions and page numbers may be given as optional parameters

FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers

Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string[] ToPngImages(
    string FileNamePattern,
    IEnumerable<int> PageNumbers,
    int DPI = 72
)
Public Function ToPngImages (
    FileNamePattern As String,
    PageNumbers As IEnumerable(Of Integer),
    Optional DPI As Integer = 72
) As String()
member ToPngImages :
        FileNamePattern : string *
        PageNumbers : IEnumerable<int> *
        ?DPI : int
(* Defaults:
        let _DPI = defaultArg DPI 72
*)
-> string[]

Parameters

FileNamePattern
Type: SystemString
A full or partial file path for the output files containing an asterisk. E.g. C:\images\pdf_pages_*.png
PageNumbers
Type: System.Collections.GenericIEnumerable Int32
A list of the specific page numbers to render as images.
DPI (Optional)
Type: SystemInt32
The desired resolution of the output Images.

Return Value

Type: String
An array of the file paths of the image files created.
See Also

Reference

PdfDocument Class
ToPngImages Overload


PdfDocument.ToPngImages Method (String, Nullable(Int32), Nullable(Int32), Int32)

PdfDocumentToPngImages Method (String, NullableInt32, NullableInt32, Int32)

Renders the pages of the PDF as PNG (Portable Network Graphic) files and saves them to disk.

Specific image dimensions and page numbers may be given as optional parameters

FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers

Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string[] ToPngImages(
    string FileNamePattern,
    Nullable<int> ImageMaxWidth,
    Nullable<int> ImageMaxHeight,
    int DPI = 72
)
Public Function ToPngImages (
    FileNamePattern As String,
    ImageMaxWidth As Nullable(Of Integer),
    ImageMaxHeight As Nullable(Of Integer),
    Optional DPI As Integer = 72
) As String()
member ToPngImages :
        FileNamePattern : string *
        ImageMaxWidth : Nullable<int> *
        ImageMaxHeight : Nullable<int> *
        ?DPI : int
(* Defaults:
        let _DPI = defaultArg DPI 72
*)
-> string[]

Parameters

FileNamePattern
Type: SystemString
A full or partial file path for the output files containing an asterisk. E.g. C:\images\pdf_pages_*.png
ImageMaxWidth
Type: SystemNullable Int32
The target maximum width of the output images.
ImageMaxHeight
Type: SystemNullable Int32
The target maximum height of the output images.
DPI (Optional)
Type: SystemInt32
The desired resolution of the output Images.

Return Value

Type: String
An array of the file paths of the image files created.
See Also

Reference

PdfDocument Class
ToPngImages Overload


PdfDocument.ToPngImages Method (String, IEnumerable(Int32), Nullable(Int32), Nullable(Int32), Int32)

PdfDocumentToPngImages Method (String, IEnumerableInt32, NullableInt32, NullableInt32, Int32)

Renders the pages of the PDF as PNG (Portable Network Graphic) files and saves them to disk.

Specific image dimensions and page numbers may be given as optional parameters

FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers

Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string[] ToPngImages(
    string FileNamePattern,
    IEnumerable<int> PageNumbers,
    Nullable<int> ImageMaxWidth,
    Nullable<int> ImageMaxHeight,
    int DPI = 72
)
Public Function ToPngImages (
    FileNamePattern As String,
    PageNumbers As IEnumerable(Of Integer),
    ImageMaxWidth As Nullable(Of Integer),
    ImageMaxHeight As Nullable(Of Integer),
    Optional DPI As Integer = 72
) As String()
member ToPngImages :
        FileNamePattern : string *
        PageNumbers : IEnumerable<int> *
        ImageMaxWidth : Nullable<int> *
        ImageMaxHeight : Nullable<int> *
        ?DPI : int
(* Defaults:
        let _DPI = defaultArg DPI 72
*)
-> string[]

Parameters

FileNamePattern
Type: SystemString
A full or partial file path for the output files containing an asterisk. E.g. C:\images\pdf_pages_*.png
PageNumbers
Type: System.Collections.GenericIEnumerable Int32
A list of the specific page numbers to render as images.
ImageMaxWidth
Type: SystemNullable Int32
The target maximum width of the output images.
ImageMaxHeight
Type: SystemNullable Int32
The target maximum height of the output images.
DPI (Optional)
Type: SystemInt32
The desired resolution of the output Images.

Return Value

Type: String
An array of the file paths of the image files created.
See Also

Reference

PdfDocument Class
ToPngImages Overload


PdfDocument.ToTiffImages Method

PdfDocumentToTiffImages Method

Overload List
 | Name | Description
Public method | ToTiffImages(String, Int32) | Renders the pages of the PDF as TIFF (Tagged Image File Format / Tif) files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Public method | ToTiffImages(String, IEnumerableInt32, Int32) | Renders the pages of the PDF as TIFF (Tagged Image File Format / Tif) files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.
Public method | ToTiffImages(String, NullableInt32, NullableInt32, Int32) | Renders the pages of the PDF as TIFF (Tagged Image File Format / Tif) files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers
Public method | ToTiffImages(String, IEnumerableInt32, NullableInt32, NullableInt32, Int32) | Renders the pages of the PDF as TIFF (Tagged Image File Format / Tif) files and saves them to disk. Specific image dimensions and page numbers may be given as optional parameters FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers
Top
See Also

Reference

PdfDocument Class


PdfDocument.ToTiffImages Method (String, Int32)

PdfDocumentToTiffImages Method (String, Int32)

Renders the pages of the PDF as TIFF (Tagged Image File Format / Tif) files and saves them to disk.

Specific image dimensions and page numbers may be given as optional parameters

FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers

Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string[] ToTiffImages(
    string FileNamePattern,
    int DPI
)
Public Function ToTiffImages (
    FileNamePattern As String,
    DPI As Integer
) As String()
member ToTiffImages :
        FileNamePattern : string *
        DPI : int -> string[]

Parameters

FileNamePattern
Type: SystemString
A full or partial file path for the output files containing an asterisk. E.g. C:\images\pdf_pages_*.tiff
DPI
Type: SystemInt32
The desired resolution of the output Images.

Return Value

Type: String
An array of the file paths of the image files created.
See Also

Reference

PdfDocument Class
ToTiffImages Overload


PdfDocument.ToTiffImages Method (String, IEnumerable(Int32), Int32)

PdfDocumentToTiffImages Method (String, IEnumerableInt32, Int32)

Renders the pages of the PDF as TIFF (Tagged Image File Format / Tif) files and saves them to disk.

Specific image dimensions and page numbers may be given as optional parameters

FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers

Available in IronPDF for .Net Framework, and .Net Core, but only for Windows and Azure machines.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string[] ToTiffImages(
    string FileNamePattern,
    IEnumerable<int> PageNumbers,
    int DPI = 72
)
Public Function ToTiffImages (
    FileNamePattern As String,
    PageNumbers As IEnumerable(Of Integer),
    Optional DPI As Integer = 72
) As String()
member ToTiffImages :
        FileNamePattern : string *
        PageNumbers : IEnumerable<int> *
        ?DPI : int
(* Defaults:
        let _DPI = defaultArg DPI 72
*)
-> string[]

Parameters

FileNamePattern
Type: SystemString
A full or partial file path for the output files containing an asterisk. E.g. C:\images\pdf_pages_*.tiff
PageNumbers
Type: System.Collections.GenericIEnumerable Int32
A list of the specific page numbers to render as images.
DPI (Optional)
Type: SystemInt32
The desired resolution of the output Images.

Return Value

Type: String
An array of the file paths of the image files created.
See Also

Reference

PdfDocument Class
ToTiffImages Overload


PdfDocument.ToTiffImages Method (String, Nullable(Int32), Nullable(Int32), Int32)

PdfDocumentToTiffImages Method (String, NullableInt32, NullableInt32, Int32)

Renders the pages of the PDF as TIFF (Tagged Image File Format / Tif) files and saves them to disk.

Specific image dimensions and page numbers may be given as optional parameters

FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string[] ToTiffImages(
    string FileNamePattern,
    Nullable<int> ImageMaxWidth,
    Nullable<int> ImageMaxHeight,
    int DPI = 72
)
Public Function ToTiffImages (
    FileNamePattern As String,
    ImageMaxWidth As Nullable(Of Integer),
    ImageMaxHeight As Nullable(Of Integer),
    Optional DPI As Integer = 72
) As String()
member ToTiffImages :
        FileNamePattern : string *
        ImageMaxWidth : Nullable<int> *
        ImageMaxHeight : Nullable<int> *
        ?DPI : int
(* Defaults:
        let _DPI = defaultArg DPI 72
*)
-> string[]

Parameters

FileNamePattern
Type: SystemString
A full or partial file path for the output files containing an asterisk. E.g. C:\images\pdf_pages_*.tiff
ImageMaxWidth
Type: SystemNullable Int32
The target maximum width of the output images.
ImageMaxHeight
Type: SystemNullable Int32
The target maximum height of the output images.
DPI (Optional)
Type: SystemInt32
The desired resolution of the output Images.

Return Value

Type: String
An array of the file paths of the image files created.
See Also

Reference

PdfDocument Class
ToTiffImages Overload


PdfDocument.ToTiffImages Method (String, IEnumerable(Int32), Nullable(Int32), Nullable(Int32), Int32)

PdfDocumentToTiffImages Method (String, IEnumerableInt32, NullableInt32, NullableInt32, Int32)

Renders the pages of the PDF as TIFF (Tagged Image File Format / Tif) files and saves them to disk.

Specific image dimensions and page numbers may be given as optional parameters

FileNamePattern should normally contain an asterisk (*) character which will be substituted for the page numbers

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string[] ToTiffImages(
    string FileNamePattern,
    IEnumerable<int> PageNumbers,
    Nullable<int> ImageMaxWidth,
    Nullable<int> ImageMaxHeight,
    int DPI = 72
)
Public Function ToTiffImages (
    FileNamePattern As String,
    PageNumbers As IEnumerable(Of Integer),
    ImageMaxWidth As Nullable(Of Integer),
    ImageMaxHeight As Nullable(Of Integer),
    Optional DPI As Integer = 72
) As String()
member ToTiffImages :
        FileNamePattern : string *
        PageNumbers : IEnumerable<int> *
        ImageMaxWidth : Nullable<int> *
        ImageMaxHeight : Nullable<int> *
        ?DPI : int
(* Defaults:
        let _DPI = defaultArg DPI 72
*)
-> string[]

Parameters

FileNamePattern
Type: SystemString
A full or partial file path for the output files containing an asterisk. E.g. C:\images\pdf_pages_*.tiff
PageNumbers
Type: System.Collections.GenericIEnumerable Int32
A list of the specific page numbers to render as images.
ImageMaxWidth
Type: SystemNullable Int32
The target maximum width of the output images.
ImageMaxHeight
Type: SystemNullable Int32
The target maximum height of the output images.
DPI (Optional)
Type: SystemInt32
The desired resolution of the output Images.

Return Value

Type: String
An array of the file paths of the image files created.
See Also

Reference

PdfDocument Class
ToTiffImages Overload


PdfDocument.TrySaveAs Method

PdfDocumentTrySaveAs Method

Attempt to save the PdfDocument to a file.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public bool TrySaveAs(
    string FileName
)
Public Function TrySaveAs (
    FileName As String
) As Boolean
member TrySaveAs :
        FileName : string -> bool

Parameters

FileName
Type: SystemString
File Path

Return Value

Type: Boolean
}true if the file was saved successfully. false if an error occurred (e.g. file was locked or insufficient permissions).
See Also

Reference

PdfDocument Class


PdfDocument.VerifyPdfSignatures Method

PdfDocumentVerifyPdfSignatures Method

Verifies all the PDF signatures for this PDF document and returns true if there are no invalid signatures.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public bool VerifyPdfSignatures()
Public Function VerifyPdfSignatures As Boolean
member VerifyPdfSignatures : unit -> bool

Return Value

Type: Boolean
true file is signed and all digital signatures for this PDF document are currently valid. Editing a PDF document in any way will invalidate signatures.
See Also

Reference

PdfDocument Class


PdfDocument.VerifyPdfSignaturesInFile Method

PdfDocumentVerifyPdfSignaturesInFile Method

Verifies all the PDF signatures for a PDF file (by file path) and returns true if there are no invalid signatures.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public static bool VerifyPdfSignaturesInFile(
    string PdfFilePath
)
Public Shared Function VerifyPdfSignaturesInFile (
    PdfFilePath As String
) As Boolean
static member VerifyPdfSignaturesInFile :
        PdfFilePath : string -> bool

Parameters

PdfFilePath
Type: SystemString
The full or relative PDF file path.

Return Value

Type: Boolean
true if file is signed and all digital signatures for the PDF document are currently valid. Editing a PDF document in any way will invalidate signatures.
See Also

Reference

PdfDocument Class


PdfDocument.WatermarkAllPages Method

PdfDocumentWatermarkAllPages Method

Watermarks all pages of this PDF with HTML content.

Watermarks are restricted to basic positioning and a 100mm by 100mm maximum size. For more advanced options see StampHTML(HtmlStamp)

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument WatermarkAllPages(
    string Html,
    PdfDocumentWaterMarkLocation Location = PdfDocumentWaterMarkLocation.MiddleCenter,
    int Opacity = 100,
    int Rotation = 0,
    string Hyperlink = ""
)
Public Function WatermarkAllPages (
    Html As String,
    Optional Location As PdfDocumentWaterMarkLocation = PdfDocumentWaterMarkLocation.MiddleCenter,
    Optional Opacity As Integer = 100,
    Optional Rotation As Integer = 0,
    Optional Hyperlink As String = ""
) As PdfDocument
member WatermarkAllPages :
        Html : string *
        ?Location : PdfDocumentWaterMarkLocation *
        ?Opacity : int *
        ?Rotation : int *
        ?Hyperlink : string
(* Defaults:
        let _Location = defaultArg Location PdfDocumentWaterMarkLocation.MiddleCenter
        let _Opacity = defaultArg Opacity 100
        let _Rotation = defaultArg Rotation 0
        let _Hyperlink = defaultArg Hyperlink ""
*)
-> PdfDocument

Parameters

Html
Type: SystemString
The HTML fragment
Location (Optional)
Type: IronPdfPdfDocumentWaterMarkLocation
The location of the watermark. PdfDocumentWaterMarkLocation
Opacity (Optional)
Type: SystemInt32
The opacity of the watermark from 0-100%. 100 is opaque, 0 is invisible.
Rotation (Optional)
Type: SystemInt32
The rotation of the watermark content in clockwise degrees.
Hyperlink (Optional)
Type: SystemString
An optional hyperlink which the watermark will link to.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class


PdfDocument.WatermarkPage Method

PdfDocumentWatermarkPage Method

Watermarks a single page of this PDF with HTML content.

Watermarks are restricted to basic positioning and a 100mm by 100mm maximum size. For more advanced options see StampHTML(HtmlStamp, Int32)

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument WatermarkPage(
    string Html,
    int PageIndexToWaterMark,
    PdfDocumentWaterMarkLocation Location = PdfDocumentWaterMarkLocation.MiddleCenter,
    int Opacity = 100,
    int Rotation = 0,
    string Hyperlink = ""
)
Public Function WatermarkPage (
    Html As String,
    PageIndexToWaterMark As Integer,
    Optional Location As PdfDocumentWaterMarkLocation = PdfDocumentWaterMarkLocation.MiddleCenter,
    Optional Opacity As Integer = 100,
    Optional Rotation As Integer = 0,
    Optional Hyperlink As String = ""
) As PdfDocument
member WatermarkPage :
        Html : string *
        PageIndexToWaterMark : int *
        ?Location : PdfDocumentWaterMarkLocation *
        ?Opacity : int *
        ?Rotation : int *
        ?Hyperlink : string
(* Defaults:
        let _Location = defaultArg Location PdfDocumentWaterMarkLocation.MiddleCenter
        let _Opacity = defaultArg Opacity 100
        let _Rotation = defaultArg Rotation 0
        let _Hyperlink = defaultArg Hyperlink ""
*)
-> PdfDocument

Parameters

Html
Type: SystemString
The HTML fragment
PageIndexToWaterMark
Type: SystemInt32
The page index (zero-based page number) of this PDF to watermark.
Location (Optional)
Type: IronPdfPdfDocumentWaterMarkLocation
The location of the watermark. PdfDocumentWaterMarkLocation
Opacity (Optional)
Type: SystemInt32
The opacity of the watermark from 0-100%. 100 is opaque, 0 is invisible.
Rotation (Optional)
Type: SystemInt32
The rotation of the watermark content in clockwise degrees.
Hyperlink (Optional)
Type: SystemString
An optional hyperlink which the watermark will link to.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class


PdfDocument.WatermarkPages Method

PdfDocumentWatermarkPages Method

Watermarks all pages of this PDF with HTML content.

Watermarks are restricted to basic positioning and a 100mm by 100mm maximum size. For more advanced options see StampHTML(HtmlStamp, IEnumerableInt32)

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocument WatermarkPages(
    string Html,
    IEnumerable<int> PageIndexesToWaterMark,
    PdfDocumentWaterMarkLocation Location = PdfDocumentWaterMarkLocation.MiddleCenter,
    int Opacity = 100,
    int Rotation = 0,
    string Hyperlink = ""
)
Public Function WatermarkPages (
    Html As String,
    PageIndexesToWaterMark As IEnumerable(Of Integer),
    Optional Location As PdfDocumentWaterMarkLocation = PdfDocumentWaterMarkLocation.MiddleCenter,
    Optional Opacity As Integer = 100,
    Optional Rotation As Integer = 0,
    Optional Hyperlink As String = ""
) As PdfDocument
member WatermarkPages :
        Html : string *
        PageIndexesToWaterMark : IEnumerable<int> *
        ?Location : PdfDocumentWaterMarkLocation *
        ?Opacity : int *
        ?Rotation : int *
        ?Hyperlink : string
(* Defaults:
        let _Location = defaultArg Location PdfDocumentWaterMarkLocation.MiddleCenter
        let _Opacity = defaultArg Opacity 100
        let _Rotation = defaultArg Rotation 0
        let _Hyperlink = defaultArg Hyperlink ""
*)
-> PdfDocument

Parameters

Html
Type: SystemString
The HTML fragment
PageIndexesToWaterMark
Type: System.Collections.GenericIEnumerable Int32
A list of page index (zero-based page number) of this PDF to watermark.
Location (Optional)
Type: IronPdfPdfDocumentWaterMarkLocation
The location of the watermark. PdfDocumentWaterMarkLocation
Opacity (Optional)
Type: SystemInt32
The opacity of the watermark from 0-100%. 100 is opaque, 0 is invisible.
Rotation (Optional)
Type: SystemInt32
The rotation of the watermark content in clockwise degrees.
Hyperlink (Optional)
Type: SystemString
An optional hyperlink which the watermark will link to.

Return Value

Type: PdfDocument
Returns this PdfDocument object, allowing for a 'fluent' (LINQ like) chained in-line code style
See Also

Reference

PdfDocument Class


PdfDocument.PdfCustomMetadataProperties Class

PdfDocumentPdfCustomMetadataProperties Class

Class that represents set of custom metadata properties
Inheritance Hierarchy
SystemObject
IronPdfPdfDocumentPdfCustomMetadataProperties

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public class PdfCustomMetadataProperties
Public Class PdfCustomMetadataProperties
type PdfCustomMetadataProperties =  class end

The PdfDocumentPdfCustomMetadataProperties type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the count of the PdfDocumentPdfCustomMetadataProperties.
Public property | Item | Gets or sets element value with the specified key.
Public property | Keys | Gets the collection of the PdfDocumentPdfCustomMetadataProperties keys.
Public property | Values | Gets the collection of the PdfDocumentPdfCustomMetadataProperties values.
Top
Methods
 | Name | Description
Public method | Add | Method for adding property with the specified name and value. You can convert value of any type to the string and store it in custom properties.
Public method | Contains | Method to check whether set of properties contains property with the specified name.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Remove | Method for removing property by its name.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

IronPdf Namespace
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


PdfCustomMetadataProperties Properties

The PdfDocumentPdfCustomMetadataProperties type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the count of the PdfDocumentPdfCustomMetadataProperties.
Public property | Item | Gets or sets element value with the specified key.
Public property | Keys | Gets the collection of the PdfDocumentPdfCustomMetadataProperties keys.
Public property | Values | Gets the collection of the PdfDocumentPdfCustomMetadataProperties values.
Top
See Also

Reference

PdfDocumentPdfCustomMetadataProperties Class


PdfDocument.PdfCustomMetadataProperties.Count Property

PdfDocumentPdfCustomMetadataPropertiesCount Property

Gets the count of the PdfDocumentPdfCustomMetadataProperties.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
member Count : int with get

Property Value

Type: Int32
See Also

Reference

PdfDocumentPdfCustomMetadataProperties Class


PdfDocument.PdfCustomMetadataProperties.Item Property

PdfDocumentPdfCustomMetadataPropertiesItem Property

Gets or sets element value with the specified key.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string this[
    string key
] { get; set; }
Public Default Property Item (
    key As String
) As String
    Get
    Set
member Item : string with get, set

Parameters

key
Type: SystemString
The key of the element.

Return Value

Type: String
See Also

Reference

PdfDocumentPdfCustomMetadataProperties Class


PdfDocument.PdfCustomMetadataProperties.Keys Property

PdfDocumentPdfCustomMetadataPropertiesKeys Property

Gets the collection of the PdfDocumentPdfCustomMetadataProperties keys.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public ICollection<string> Keys { get; }
Public ReadOnly Property Keys As ICollection(Of String)
    Get
member Keys : ICollection<string> with get

Property Value

Type: ICollection String
See Also

Reference

PdfDocumentPdfCustomMetadataProperties Class


PdfDocument.PdfCustomMetadataProperties.Values Property

PdfDocumentPdfCustomMetadataPropertiesValues Property

Gets the collection of the PdfDocumentPdfCustomMetadataProperties values.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public ICollection<string> Values { get; }
Public ReadOnly Property Values As ICollection(Of String)
    Get
member Values : ICollection<string> with get

Property Value

Type: ICollection String
See Also

Reference

PdfDocumentPdfCustomMetadataProperties Class


PdfCustomMetadataProperties Methods

The PdfDocumentPdfCustomMetadataProperties type exposes the following members.

Methods
 | Name | Description
Public method | Add | Method for adding property with the specified name and value. You can convert value of any type to the string and store it in custom properties.
Public method | Contains | Method to check whether set of properties contains property with the specified name.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Remove | Method for removing property by its name.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PdfDocumentPdfCustomMetadataProperties Class


PdfDocument.PdfCustomMetadataProperties.Add Method

PdfDocumentPdfCustomMetadataPropertiesAdd Method

Method for adding property with the specified name and value.

You can convert value of any type to the string and store it in custom properties.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public void Add(
    string name,
    string value
)
Public Sub Add (
    name As String,
    value As String
)
member Add :
        name : string *
        value : string -> unit

Parameters

name
Type: SystemString
The name of the custom PDF MetaData Property.
value
Type: SystemString
The value of the custom PDF MetaData Property as a String.
See Also

Reference

PdfDocumentPdfCustomMetadataProperties Class


PdfDocument.PdfCustomMetadataProperties.Contains Method

PdfDocumentPdfCustomMetadataPropertiesContains Method

Method to check whether set of properties contains property with the specified name.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public bool Contains(
    string name
)
Public Function Contains (
    name As String
) As Boolean
member Contains :
        name : string -> bool

Parameters

name
Type: SystemString
Name of the property.

Return Value

Type: Boolean
true if property with the specified name exists, otherwise false.
See Also

Reference

PdfDocumentPdfCustomMetadataProperties Class


PdfDocument.PdfCustomMetadataProperties.Remove Method

PdfDocumentPdfCustomMetadataPropertiesRemove Method

Method for removing property by its name.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public bool Remove(
    string name
)
Public Function Remove (
    name As String
) As Boolean
member Remove :
        name : string -> bool

Parameters

name
Type: SystemString
The name of the property.

Return Value

Type: Boolean
true if property was removed, otherwise false.
See Also

Reference

PdfDocumentPdfCustomMetadataProperties Class


PdfDocument.PdfMetaData Class

PdfDocumentPdfMetaData Class

A class defining PDF file meta-data.

Allows File meta-data to be read and set including: Authors, File Dates, Keywords, Title and Subject

Implemented in MetaData.

Inheritance Hierarchy
SystemObject
IronPdfPdfDocumentPdfMetaData

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public class PdfMetaData
Public Class PdfMetaData
type PdfMetaData =  class end

The PdfDocumentPdfMetaData type exposes the following members.

Properties
 | Name | Description
Public property | Author | Gets or sets the Author of the document.
Public property | CreationDate | Gets or sets the PDF file creation DateTime.
Public property | Creator | Gets or sets the Creator of the document.
Public property | CustomProperties | Property defining custom metadata properties of the document.
Public property | Keywords | Gets or sets the Keywords of the document. This helps search indexes and operating systems correctly index the PDF.
Public property | ModifiedDate | Gets or sets the PDF file last-modified DateTime.
Public property | Producer | Gets or sets the Producer of the document.
Public property | Subject | Gets or sets the Subject of the document. This helps search indexes and operating systems correctly index the PDF, and may appear in PDF viewer software.
Public property | Title | Gets or sets the Title of the document. This helps search indexes and operating systems correctly index the PDF, and may appear in PDF viewer software.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

IronPdf Namespace
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


PdfMetaData Properties

The PdfDocumentPdfMetaData type exposes the following members.

Properties
 | Name | Description
Public property | Author | Gets or sets the Author of the document.
Public property | CreationDate | Gets or sets the PDF file creation DateTime.
Public property | Creator | Gets or sets the Creator of the document.
Public property | CustomProperties | Property defining custom metadata properties of the document.
Public property | Keywords | Gets or sets the Keywords of the document. This helps search indexes and operating systems correctly index the PDF.
Public property | ModifiedDate | Gets or sets the PDF file last-modified DateTime.
Public property | Producer | Gets or sets the Producer of the document.
Public property | Subject | Gets or sets the Subject of the document. This helps search indexes and operating systems correctly index the PDF, and may appear in PDF viewer software.
Public property | Title | Gets or sets the Title of the document. This helps search indexes and operating systems correctly index the PDF, and may appear in PDF viewer software.
Top
See Also

Reference

PdfDocumentPdfMetaData Class


PdfDocument.PdfMetaData.Author Property

PdfDocumentPdfMetaDataAuthor Property

Gets or sets the Author of the document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string Author { get; set; }
Public Property Author As String
    Get
    Set
member Author : string with get, set

Property Value

Type: String
The author name as a string.
See Also

Reference

PdfDocumentPdfMetaData Class


PdfDocument.PdfMetaData.CreationDate Property

PdfDocumentPdfMetaDataCreationDate Property

Gets or sets the PDF file creation DateTime.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public DateTime CreationDate { get; set; }
Public Property CreationDate As DateTime
    Get
    Set
member CreationDate : DateTime with get, set

Property Value

Type: DateTime
DateTime of PDF file creation.
See Also

Reference

PdfDocumentPdfMetaData Class


PdfDocument.PdfMetaData.Creator Property

PdfDocumentPdfMetaDataCreator Property

Gets or sets the Creator of the document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string Creator { get; set; }
Public Property Creator As String
    Get
    Set
member Creator : string with get, set

Property Value

Type: String
The creator name as a string.
See Also

Reference

PdfDocumentPdfMetaData Class


PdfDocument.PdfMetaData.CustomProperties Property

PdfDocumentPdfMetaDataCustomProperties Property

Property defining custom metadata properties of the document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocumentPdfCustomMetadataProperties CustomProperties { get; }
Public ReadOnly Property CustomProperties As PdfDocumentPdfCustomMetadataProperties
    Get
member CustomProperties : PdfDocumentPdfCustomMetadataProperties with get

Property Value

Type: PdfDocumentPdfCustomMetadataProperties
See Also

Reference

PdfDocumentPdfMetaData Class


PdfDocument.PdfMetaData.Keywords Property

PdfDocumentPdfMetaDataKeywords Property

Gets or sets the Keywords of the document. This helps search indexes and operating systems correctly index the PDF.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string Keywords { get; set; }
Public Property Keywords As String
    Get
    Set
member Keywords : string with get, set

Property Value

Type: String
The Keywords of the document as a string. It is customary to use comma separation between keywords.
See Also

Reference

PdfDocumentPdfMetaData Class


PdfDocument.PdfMetaData.ModifiedDate Property

PdfDocumentPdfMetaDataModifiedDate Property

Gets or sets the PDF file last-modified DateTime.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public DateTime ModifiedDate { get; set; }
Public Property ModifiedDate As DateTime
    Get
    Set
member ModifiedDate : DateTime with get, set

Property Value

Type: DateTime
DateTime of PDF file modification.
See Also

Reference

PdfDocumentPdfMetaData Class


PdfDocument.PdfMetaData.Producer Property

PdfDocumentPdfMetaDataProducer Property

Gets or sets the Producer of the document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string Producer { get; set; }
Public Property Producer As String
    Get
    Set
member Producer : string with get, set

Property Value

Type: String
The producer name as a string.
See Also

Reference

PdfDocumentPdfMetaData Class


PdfDocument.PdfMetaData.Subject Property

PdfDocumentPdfMetaDataSubject Property

Gets or sets the Subject of the document. This helps search indexes and operating systems correctly index the PDF, and may appear in PDF viewer software.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string Subject { get; set; }
Public Property Subject As String
    Get
    Set
member Subject : string with get, set

Property Value

Type: String
The Subject of the document as a string.
See Also

Reference

PdfDocumentPdfMetaData Class


PdfDocument.PdfMetaData.Title Property

PdfDocumentPdfMetaDataTitle Property

Gets or sets the Title of the document. This helps search indexes and operating systems correctly index the PDF, and may appear in PDF viewer software.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
member Title : string with get, set

Property Value

Type: String
The Title of the document as a string.
See Also

Reference

PdfDocumentPdfMetaData Class


PdfMetaData Methods

The PdfDocumentPdfMetaData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PdfDocumentPdfMetaData Class


PdfDocument.PdfSecuritySettings Class

PdfDocumentPdfSecuritySettings Class

A class defining user security settings for a PDF document.

Allows the developer to control user access passwords, encryption, and also who may edit, print and copy content from the PDF document

Implemented in SecuritySettings.

Inheritance Hierarchy
SystemObject
IronPdfPdfDocumentPdfSecuritySettings

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public class PdfSecuritySettings
Public Class PdfSecuritySettings
type PdfSecuritySettings =  class end

The PdfDocumentPdfSecuritySettings type exposes the following members.

Properties
 | Name | Description
Public property | AllowUserAnnotations | Gets or sets the permissions for users to annotate the PDF document with comments. If AllowUserAnnotations is set false, the OwnerPassword must be set for the security measure to take effect.
Public property | AllowUserCopyPasteContent | Gets or sets the permissions for users to extract or 'copy & paste' content (text and images) from f the PDF document. If AllowUserCopyPasteContent is set false, the OwnerPassword must also be set for the security measure to take effect.
Public property | AllowUserEdits | Gets or sets the permissions for users edit the PDF document. The features to edit the document depends entirely on the PDF client software used by the end user. If editing rights are restricted, then the OwnerPassword must be set for the security measure to take effect.
Public property | AllowUserFormData | Gets or sets the permissions for users to fill-in (enter data into) forms in the PDF document. If AllowUserFormData is set false, the OwnerPassword must be set for the security measure to take effect. Note. If you want to make the form readonly in Adobe Acrobat Reader please call MakePdfDocumentReadOnly(String) method or set AllowUserEdits to NoEdit and set OwnerPassword.
Public property | AllowUserPrinting | Gets or sets the permissions for users to print the PDF document. If print rights are restricted, then the OwnerPassword must be set for the security measure to take effect.
Public property | OwnerPassword | Sets the owner password and enables 128Bit encryption of PDF content. An owner password is one used to enable and disable all other security settings. OwnerPassword must be set to a non empty string value for AllowUserCopyPasteContent, AllowUserAnnotations, AllowUserFormData,s AllowUserPrinting and AllowUserEdits to be restricted.
Public property | UserPassword | Sets the user password and enables 128Bit encryption of PDF content . A user password if a password that each user must enter to open or print the PDF document.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | MakePdfDocumentReadOnly | Makes this PDF document read only such that: Content is encrypted at 128 bit. Copy and paste of content is disallowed. Annotations and form editing are disabled.
Public method | RemovePasswordsAndEncryption | Removes all user and owner password security for a PDF document. Also disables content encryption. Content is encrypted at 128 bit. Copy and paste of content is disallowed. Annotations and form editing are disabled.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

IronPdf Namespace
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


PdfSecuritySettings Properties

The PdfDocumentPdfSecuritySettings type exposes the following members.

Properties
 | Name | Description
Public property | AllowUserAnnotations | Gets or sets the permissions for users to annotate the PDF document with comments. If AllowUserAnnotations is set false, the OwnerPassword must be set for the security measure to take effect.
Public property | AllowUserCopyPasteContent | Gets or sets the permissions for users to extract or 'copy & paste' content (text and images) from f the PDF document. If AllowUserCopyPasteContent is set false, the OwnerPassword must also be set for the security measure to take effect.
Public property | AllowUserEdits | Gets or sets the permissions for users edit the PDF document. The features to edit the document depends entirely on the PDF client software used by the end user. If editing rights are restricted, then the OwnerPassword must be set for the security measure to take effect.
Public property | AllowUserFormData | Gets or sets the permissions for users to fill-in (enter data into) forms in the PDF document. If AllowUserFormData is set false, the OwnerPassword must be set for the security measure to take effect. Note. If you want to make the form readonly in Adobe Acrobat Reader please call MakePdfDocumentReadOnly(String) method or set AllowUserEdits to NoEdit and set OwnerPassword.
Public property | AllowUserPrinting | Gets or sets the permissions for users to print the PDF document. If print rights are restricted, then the OwnerPassword must be set for the security measure to take effect.
Public property | OwnerPassword | Sets the owner password and enables 128Bit encryption of PDF content. An owner password is one used to enable and disable all other security settings. OwnerPassword must be set to a non empty string value for AllowUserCopyPasteContent, AllowUserAnnotations, AllowUserFormData,s AllowUserPrinting and AllowUserEdits to be restricted.
Public property | UserPassword | Sets the user password and enables 128Bit encryption of PDF content . A user password if a password that each user must enter to open or print the PDF document.
Top
See Also

Reference

PdfDocumentPdfSecuritySettings Class


PdfDocument.PdfSecuritySettings.AllowUserAnnotations Property

PdfDocumentPdfSecuritySettingsAllowUserAnnotations Property

Gets or sets the permissions for users to annotate the PDF document with comments.

If AllowUserAnnotations is set false, the OwnerPassword must be set for the security measure to take effect.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public bool AllowUserAnnotations { get; set; }
Public Property AllowUserAnnotations As Boolean
    Get
    Set
member AllowUserAnnotations : bool with get, set

Property Value

Type: Boolean
true if users may annotate the PDF document, otherwise false.
See Also

Reference

PdfDocumentPdfSecuritySettings Class


PdfDocument.PdfSecuritySettings.AllowUserCopyPasteContent Property

PdfDocumentPdfSecuritySettingsAllowUserCopyPasteContent Property

Gets or sets the permissions for users to extract or 'copy & paste' content (text and images) from f the PDF document.

If AllowUserCopyPasteContent is set false, the OwnerPassword must also be set for the security measure to take effect.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public bool AllowUserCopyPasteContent { get; set; }
Public Property AllowUserCopyPasteContent As Boolean
    Get
    Set
member AllowUserCopyPasteContent : bool with get, set

Property Value

Type: Boolean
true if users may 'copy and paste' content out of the PDF otherwise, false.
See Also

Reference

PdfDocumentPdfSecuritySettings Class


PdfDocument.PdfSecuritySettings.AllowUserEdits Property

PdfDocumentPdfSecuritySettingsAllowUserEdits Property

Gets or sets the permissions for users edit the PDF document. The features to edit the document depends entirely on the PDF client software used by the end user.

If editing rights are restricted, then the OwnerPassword must be set for the security measure to take effect.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocumentPdfSecuritySettingsPdfEditSecurity AllowUserEdits { get; set; }
Public Property AllowUserEdits As PdfDocumentPdfSecuritySettingsPdfEditSecurity
    Get
    Set
member AllowUserEdits : PdfDocumentPdfSecuritySettingsPdfEditSecurity with get, set

Property Value

Type: PdfDocumentPdfSecuritySettingsPdfEditSecurity
The PdfDocumentPdfSecuritySettingsPdfEditSecurity value for user edit security.
See Also

Reference

PdfDocumentPdfSecuritySettings Class


PdfDocument.PdfSecuritySettings.AllowUserFormData Property

PdfDocumentPdfSecuritySettingsAllowUserFormData Property

Gets or sets the permissions for users to fill-in (enter data into) forms in the PDF document.

If AllowUserFormData is set false, the OwnerPassword must be set for the security measure to take effect.

Note. If you want to make the form readonly in Adobe Acrobat Reader please call MakePdfDocumentReadOnly(String) method or set AllowUserEdits to NoEdit and set OwnerPassword.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public bool AllowUserFormData { get; set; }
Public Property AllowUserFormData As Boolean
    Get
    Set
member AllowUserFormData : bool with get, set

Property Value

Type: Boolean
true if users may annotate the PDF document, otherwise false. Setting AllowUserFormData true will also enable annotations.
See Also

Reference

PdfDocumentPdfSecuritySettings Class


PdfDocument.PdfSecuritySettings.AllowUserPrinting Property

PdfDocumentPdfSecuritySettingsAllowUserPrinting Property

Gets or sets the permissions for users to print the PDF document.

If print rights are restricted, then the OwnerPassword must be set for the security measure to take effect.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocumentPdfSecuritySettingsPdfPrintSecrity AllowUserPrinting { get; set; }
Public Property AllowUserPrinting As PdfDocumentPdfSecuritySettingsPdfPrintSecrity
    Get
    Set
member AllowUserPrinting : PdfDocumentPdfSecuritySettingsPdfPrintSecrity with get, set

Property Value

Type: PdfDocumentPdfSecuritySettingsPdfPrintSecrity
The PdfDocumentPdfSecuritySettingsPdfPrintSecrity value for user printing.
See Also

Reference

PdfDocumentPdfSecuritySettings Class


PdfDocument.PdfSecuritySettings.OwnerPassword Property

PdfDocumentPdfSecuritySettingsOwnerPassword Property

Sets the owner password and enables 128Bit encryption of PDF content. An owner password is one used to enable and disable all other security settings.

OwnerPassword must be set to a non empty string value for AllowUserCopyPasteContent, AllowUserAnnotations, AllowUserFormData,s AllowUserPrinting and AllowUserEdits to be restricted.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string OwnerPassword { set; }
Public WriteOnly Property OwnerPassword As String
    Set
member OwnerPassword : string with set

Property Value

Type: String
See Also

Reference

PdfDocumentPdfSecuritySettings Class


PdfDocument.PdfSecuritySettings.UserPassword Property

PdfDocumentPdfSecuritySettingsUserPassword Property

Sets the user password and enables 128Bit encryption of PDF content .

A user password if a password that each user must enter to open or print the PDF document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string UserPassword { set; }
Public WriteOnly Property UserPassword As String
    Set
member UserPassword : string with set

Property Value

Type: String
See Also

Reference

PdfDocumentPdfSecuritySettings Class


PdfSecuritySettings Methods

The PdfDocumentPdfSecuritySettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | MakePdfDocumentReadOnly | Makes this PDF document read only such that: Content is encrypted at 128 bit. Copy and paste of content is disallowed. Annotations and form editing are disabled.
Public method | RemovePasswordsAndEncryption | Removes all user and owner password security for a PDF document. Also disables content encryption. Content is encrypted at 128 bit. Copy and paste of content is disallowed. Annotations and form editing are disabled.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PdfDocumentPdfSecuritySettings Class


PdfDocument.PdfSecuritySettings.MakePdfDocumentReadOnly Method

PdfDocumentPdfSecuritySettingsMakePdfDocumentReadOnly Method

Makes this PDF document read only such that:

Content is encrypted at 128 bit. Copy and paste of content is disallowed. Annotations and form editing are disabled.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public void MakePdfDocumentReadOnly(
    string OwnerPassword
)
Public Sub MakePdfDocumentReadOnly (
    OwnerPassword As String
)
member MakePdfDocumentReadOnly :
        OwnerPassword : string -> unit

Parameters

OwnerPassword
Type: SystemString
The owner password for the PDF. A string for owner password is required to enable PDF encryption and all document security options.
See Also

Reference

PdfDocumentPdfSecuritySettings Class


PdfDocument.PdfSecuritySettings.RemovePasswordsAndEncryption Method

PdfDocumentPdfSecuritySettingsRemovePasswordsAndEncryption Method

Removes all user and owner password security for a PDF document. Also disables content encryption.

Content is encrypted at 128 bit. Copy and paste of content is disallowed. Annotations and form editing are disabled.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public void RemovePasswordsAndEncryption()
Public Sub RemovePasswordsAndEncryption
member RemovePasswordsAndEncryption : unit -> unit
See Also

Reference

PdfDocumentPdfSecuritySettings Class


PdfDocument.PdfSecuritySettings.PdfEditSecurity Enumeration

PdfDocumentPdfSecuritySettingsPdfEditSecurity Enumeration

Enumeration defining levels of PDF user access rights to edit a PDF. Edit rights may also be limited by the User's PDF document client software.

See AllowUserEdits

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public enum PdfEditSecurity
Public Enumeration PdfEditSecurity
type PdfEditSecurity
Members
Member name | Value | Description
NoEdit | 0 | The user may not edit the PDF unless they have the Owner password.
EditPages | 1 | The user may re-arrange pages, rotate pages and manage PDF thumbnails, but may not otherwise edit the PDF unless they have the Owner password.
EditAll | 2 | The user may edit the PDF as allowed by their PDF client software.
See Also

Reference

IronPdf Namespace
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


PdfDocument.PdfSecuritySettings.PdfPrintSecrity Enumeration

PdfDocumentPdfSecuritySettingsPdfPrintSecrity Enumeration

Enumeration defining levels of PDF user access rights to print a PDF.

See AllowUserPrinting

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public enum PdfPrintSecrity
Public Enumeration PdfPrintSecrity
type PdfPrintSecrity
Members
Member name | Value | Description
NoPrint | 0 | The user may not print the PDF unless they have the Owner password.
PrintLowQuality | 1 | The user may only print the PDF at low resolution unless they have the Owner password.
FullPrintRights | 2 | Users may print the PDF without restriction.
See Also

Reference

IronPdf Namespace
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


PdfDocument.TextAnnotation Class

PdfDocumentTextAnnotation Class

Defines a Sticky-Note style PDF annotation.
Inheritance Hierarchy
SystemObject
IronPdfPdfDocumentTextAnnotation

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public class TextAnnotation
Public Class TextAnnotation
type TextAnnotation =  class end

The PdfDocumentTextAnnotation type exposes the following members.

Constructors
 | Name | Description
Public method | PdfDocumentTextAnnotation | Initializes a new instance of the PdfDocumentTextAnnotation class
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | Returns a String that represents this annotation. (Overrides ObjectToString.)
Top
Fields
 | Name | Description
Public field | Color | The color of the annotation's 'Sticky Note'
Public field | Contents | The contents of the 'sticky note' annotation
Public field | Hidden | Hides the annotation from users
Public field | Icon | An icon to visually represent the 'sticky note' annotation
Public field | Opacity | The opacity of the annotation (valid values are from 0.0 to 1.0)
Public field | OpenByDefault | Sets the annotation to be opened and readable by default, without user interaction
Public field | Printable | Allows the annotation to be printed when users print the PDF
Public field | ReadOnly | Allows the annotation to be printed when users print the PDF
Public field | Rotateable | Allows the annotation to be rotated. E.g. when the containing page os rotated
Public field | Subject | The sub title of the annotation as displayed in the header of the 'sticky note'
Public field | Title | The main title of the annotation as displayed in the header of the 'sticky note'
Top
See Also

Reference

IronPdf Namespace
PdfDocumentAddTextAnnotation(PdfDocumentTextAnnotation, Int32, Int32, Int32, Int32, Int32)


PdfDocument.TextAnnotation Constructor

PdfDocumentTextAnnotation Constructor

Initializes a new instance of the PdfDocumentTextAnnotation class

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public TextAnnotation()
Public Sub New
new : unit -> TextAnnotation
See Also

Reference

PdfDocumentTextAnnotation Class


TextAnnotation Methods

The PdfDocumentTextAnnotation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | Returns a String that represents this annotation. (Overrides ObjectToString.)
Top
See Also

Reference

PdfDocumentTextAnnotation Class


PdfDocument.TextAnnotation.ToString Method

PdfDocumentTextAnnotationToString Method

Returns a String that represents this annotation.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A String that represents this instance.
See Also

Reference

PdfDocumentTextAnnotation Class


TextAnnotation Fields

The PdfDocumentTextAnnotation type exposes the following members.

Fields
 | Name | Description
Public field | Color | The color of the annotation's 'Sticky Note'
Public field | Contents | The contents of the 'sticky note' annotation
Public field | Hidden | Hides the annotation from users
Public field | Icon | An icon to visually represent the 'sticky note' annotation
Public field | Opacity | The opacity of the annotation (valid values are from 0.0 to 1.0)
Public field | OpenByDefault | Sets the annotation to be opened and readable by default, without user interaction
Public field | Printable | Allows the annotation to be printed when users print the PDF
Public field | ReadOnly | Allows the annotation to be printed when users print the PDF
Public field | Rotateable | Allows the annotation to be rotated. E.g. when the containing page os rotated
Public field | Subject | The sub title of the annotation as displayed in the header of the 'sticky note'
Public field | Title | The main title of the annotation as displayed in the header of the 'sticky note'
Top
See Also

Reference

PdfDocumentTextAnnotation Class


PdfDocument.TextAnnotation.Color Field

PdfDocumentTextAnnotationColor Field

The color of the annotation's 'Sticky Note'

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public Nullable<Color> Color
Public Color As Nullable(Of Color)
val mutable Color: Nullable<Color>

Field Value

Type: Nullable Color
See Also

Reference

PdfDocumentTextAnnotation Class


PdfDocument.TextAnnotation.Contents Field

PdfDocumentTextAnnotationContents Field

The contents of the 'sticky note' annotation

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string Contents
Public Contents As String
val mutable Contents: string

Field Value

Type: String
See Also

Reference

PdfDocumentTextAnnotation Class


PdfDocument.TextAnnotation.Hidden Field

PdfDocumentTextAnnotationHidden Field

Hides the annotation from users

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public bool Hidden
Public Hidden As Boolean
val mutable Hidden: bool

Field Value

Type: Boolean
See Also

Reference

PdfDocumentTextAnnotation Class


PdfDocument.TextAnnotation.Icon Field

PdfDocumentTextAnnotationIcon Field

An icon to visually represent the 'sticky note' annotation

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfDocumentTextAnnotationAnnotationIcon Icon
Public Icon As PdfDocumentTextAnnotationAnnotationIcon
val mutable Icon: PdfDocumentTextAnnotationAnnotationIcon

Field Value

Type: PdfDocumentTextAnnotationAnnotationIcon
See Also

Reference

PdfDocumentTextAnnotation Class


PdfDocument.TextAnnotation.Opacity Field

PdfDocumentTextAnnotationOpacity Field

The opacity of the annotation (valid values are from 0.0 to 1.0)

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public double Opacity
Public Opacity As Double
val mutable Opacity: float

Field Value

Type: Double
See Also

Reference

PdfDocumentTextAnnotation Class


PdfDocument.TextAnnotation.OpenByDefault Field

PdfDocumentTextAnnotationOpenByDefault Field

Sets the annotation to be opened and readable by default, without user interaction

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public bool OpenByDefault
Public OpenByDefault As Boolean
val mutable OpenByDefault: bool

Field Value

Type: Boolean
See Also

Reference

PdfDocumentTextAnnotation Class


PdfDocument.TextAnnotation.Printable Field

PdfDocumentTextAnnotationPrintable Field

Allows the annotation to be printed when users print the PDF

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public bool Printable
Public Printable As Boolean
val mutable Printable: bool

Field Value

Type: Boolean
See Also

Reference

PdfDocumentTextAnnotation Class


PdfDocument.TextAnnotation.ReadOnly Field

PdfDocumentTextAnnotationReadOnly Field

Allows the annotation to be printed when users print the PDF

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public bool ReadOnly
Public ReadOnly As Boolean
val mutable ReadOnly: bool

Field Value

Type: Boolean
See Also

Reference

PdfDocumentTextAnnotation Class


PdfDocument.TextAnnotation.Rotateable Field

PdfDocumentTextAnnotationRotateable Field

Allows the annotation to be rotated. E.g. when the containing page os rotated

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public bool Rotateable
Public Rotateable As Boolean
val mutable Rotateable: bool

Field Value

Type: Boolean
See Also

Reference

PdfDocumentTextAnnotation Class


PdfDocument.TextAnnotation.Subject Field

PdfDocumentTextAnnotationSubject Field

The sub title of the annotation as displayed in the header of the 'sticky note'

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string Subject
Public Subject As String
val mutable Subject: string

Field Value

Type: String
See Also

Reference

PdfDocumentTextAnnotation Class


PdfDocument.TextAnnotation.Title Field

PdfDocumentTextAnnotationTitle Field

The main title of the annotation as displayed in the header of the 'sticky note'

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string Title
Public Title As String
val mutable Title: string

Field Value

Type: String
See Also

Reference

PdfDocumentTextAnnotation Class


PdfDocument.TextAnnotation.AnnotationIcon Enumeration

PdfDocumentTextAnnotationAnnotationIcon Enumeration

Icons used to interact with (open/close) the annotation with the PDF page.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public enum AnnotationIcon
Public Enumeration AnnotationIcon
type AnnotationIcon
Members
Member name | Value | Description
NoIcon | 0 | No icon, this is useful when an annotation will be signified by an existing graphic or object.
Comment | 1 | A Comment Icon
Help | 2 | A Help Icon
Insert | 3 | An 'Insert' Icon
Key | 4 | A Key Icon
NewParagraph | 5 | A New Paragraph Icon
Note | 6 | A Note Icon
Paragraph | 7 | A 'Paragraph of Text' Icon
See Also

Reference

IronPdf Namespace
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


PdfDocument.WaterMarkLocation Enumeration

PdfDocumentWaterMarkLocation Enumeration

Location for a simple watermark to be applied to a PDF page.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public enum WaterMarkLocation
Public Enumeration WaterMarkLocation
type WaterMarkLocation
Members
Member name | Value | Description
TopLeft | 0 | The top left of the page
TopCenter | 1 | The top center of the page
TopRight | 2 | The top right of the page
MiddleLeft | 3 | The middle left of the page
MiddleCenter | 4 | The dead center of the page
MiddleRight | 5 | The middle right of the page
BottomLeft | 6 | The bottom left of the page
BottomCenter | 7 | The bottom center of the page
BottomRight | 8 | The bottom right of the page
See Also

Reference

IronPdf Namespace
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


PdfOutline Class

A editable collection of PDF navigational bookmark objects.
Inheritance Hierarchy
SystemObject
IronPdfPdfOutline

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public class PdfOutline
Public Class PdfOutline
type PdfOutline =  class end

The PdfOutline type exposes the following members.

Properties
 | Name | Description
Public property | BookMarkList | Gets the full list of current outline book marks.
Top
Methods
 | Name | Description
Public method | AddBookMarkAtEnd | Adds a bookmark at the end of the document outline.
Public method | AddBookMarkAtStart | Adds a bookmark at the start of the document outline.
Public method | Clean | Removes all existing bookmarks from the PDF
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | InsertBookMark | Insert a bookmark at the start of the document outline.
Public method | RemoveBookMark | Removes a single book mark from the BookMarkList
Public method | RemoveBookMarkAt | Removes a single book mark from the BookMarkList
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

IronPdf Namespace
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


PdfOutline Properties

The PdfOutline type exposes the following members.

Properties
 | Name | Description
Public property | BookMarkList | Gets the full list of current outline book marks.
Top
See Also

Reference

PdfOutline Class


PdfOutline.BookMarkList Property

PdfOutlineBookMarkList Property

Gets the full list of current outline book marks.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public List<PdfBookMark> BookMarkList { get; }
Public ReadOnly Property BookMarkList As List(Of PdfBookMark)
    Get
member BookMarkList : List<PdfBookMark> with get

Property Value

Type: List PdfBookMark
The PDF documents full collection of bookmarks.
See Also

Reference

PdfOutline Class


PdfOutline Methods

The PdfOutline type exposes the following members.

Methods
 | Name | Description
Public method | AddBookMarkAtEnd | Adds a bookmark at the end of the document outline.
Public method | AddBookMarkAtStart | Adds a bookmark at the start of the document outline.
Public method | Clean | Removes all existing bookmarks from the PDF
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | InsertBookMark | Insert a bookmark at the start of the document outline.
Public method | RemoveBookMark | Removes a single book mark from the BookMarkList
Public method | RemoveBookMarkAt | Removes a single book mark from the BookMarkList
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PdfOutline Class


PdfOutline.AddBookMarkAtEnd Method

PdfOutlineAddBookMarkAtEnd Method

Adds a bookmark at the end of the document outline.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public void AddBookMarkAtEnd(
    string Text,
    int PageIndex,
    int IndentLevel = 0
)
Public Sub AddBookMarkAtEnd (
    Text As String,
    PageIndex As Integer,
    Optional IndentLevel As Integer = 0
)
member AddBookMarkAtEnd :
        Text : string *
        PageIndex : int *
        ?IndentLevel : int
(* Defaults:
        let _IndentLevel = defaultArg IndentLevel 0
*)
-> unit

Parameters

Text
Type: SystemString
The display text for the link.
PageIndex
Type: SystemInt32
The zero based page number to link to. E.g. Page 1 has a PageIndex of 0
IndentLevel (Optional)
Type: SystemInt32
The indent level in the outline. An IndentLevel of zero is in the root. An IndentLevel of N will be nested inside the most recent previous bookmark of IndentLevel N-1.
See Also

Reference

PdfOutline Class


PdfOutline.AddBookMarkAtStart Method

PdfOutlineAddBookMarkAtStart Method

Adds a bookmark at the start of the document outline.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public void AddBookMarkAtStart(
    string Text,
    int PageIndex,
    int IndentLevel = 0
)
Public Sub AddBookMarkAtStart (
    Text As String,
    PageIndex As Integer,
    Optional IndentLevel As Integer = 0
)
member AddBookMarkAtStart :
        Text : string *
        PageIndex : int *
        ?IndentLevel : int
(* Defaults:
        let _IndentLevel = defaultArg IndentLevel 0
*)
-> unit

Parameters

Text
Type: SystemString
The display text for the link.
PageIndex
Type: SystemInt32
The zero based page number to link to. E.g. Page 1 has a PageIndex of 0
IndentLevel (Optional)
Type: SystemInt32
The indent level in the outline. An IndentLevel of zero is in the root. An IndentLevel of N will be nested inside the most recent previous bookmark of IndentLevel N-1.
See Also

Reference

PdfOutline Class


PdfOutline.Clean Method

PdfOutlineClean Method

Removes all existing bookmarks from the PDF

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public void Clean()
Public Sub Clean
member Clean : unit -> unit
See Also

Reference

PdfOutline Class


PdfOutline.InsertBookMark Method

PdfOutlineInsertBookMark Method

Insert a bookmark at the start of the document outline.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public void InsertBookMark(
    int Position,
    string Text,
    int PageIndex,
    int IndentLevel = 0
)
Public Sub InsertBookMark (
    Position As Integer,
    Text As String,
    PageIndex As Integer,
    Optional IndentLevel As Integer = 0
)
member InsertBookMark :
        Position : int *
        Text : string *
        PageIndex : int *
        ?IndentLevel : int
(* Defaults:
        let _IndentLevel = defaultArg IndentLevel 0
*)
-> unit

Parameters

Position
Type: SystemInt32
The position of the bookmark in the BookMark list.
Text
Type: SystemString
The display text for the link.
PageIndex
Type: SystemInt32
The zero based page number to link to. E.g. Page 1 has a PageIndex of 0
IndentLevel (Optional)
Type: SystemInt32
The indent level in the outline. An IndentLevel of zero is in the root. An IndentLevel of N will be nested inside the most recent previous bookmark of IndentLevel N-1.
See Also

Reference

PdfOutline Class


PdfOutline.RemoveBookMark Method

PdfOutlineRemoveBookMark Method

Removes a single book mark from the BookMarkList

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public void RemoveBookMark(
    PdfBookMark BookMark
)
Public Sub RemoveBookMark (
    BookMark As PdfBookMark
)
member RemoveBookMark :
        BookMark : PdfBookMark -> unit

Parameters

BookMark
Type: IronPdfPdfBookMark
The bookmark object to remove.
See Also

Reference

PdfOutline Class


PdfOutline.RemoveBookMarkAt Method

PdfOutlineRemoveBookMarkAt Method

Removes a single book mark from the BookMarkList

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public void RemoveBookMarkAt(
    int Index
)
Public Sub RemoveBookMarkAt (
    Index As Integer
)
member RemoveBookMarkAt :
        Index : int -> unit

Parameters

Index
Type: SystemInt32
The index of the bookmark to remove.
See Also

Reference

PdfOutline Class


PdfPage Class

Class that represents pdf page.
Inheritance Hierarchy
SystemObject
IronPdfPdfPage

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public class PdfPage
Public Class PdfPage
type PdfPage =  class end

The PdfPage type exposes the following members.

Properties
 | Name | Description
Public property | Height | Gets the height of the pdf page.
Public property | PageOrientation | Gets the page orientation.
Public property | Width | Gets the width of the pdf page.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

IronPdf Namespace
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


PdfPage Properties

The PdfPage type exposes the following members.

Properties
 | Name | Description
Public property | Height | Gets the height of the pdf page.
Public property | PageOrientation | Gets the page orientation.
Public property | Width | Gets the width of the pdf page.
Top
See Also

Reference

PdfPage Class


PdfPage.Height Property

PdfPageHeight Property

Gets the height of the pdf page.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public double Height { get; }
Public ReadOnly Property Height As Double
    Get
member Height : float with get

Property Value

Type: Double
See Also

Reference

PdfPage Class


PdfPage.PageOrientation Property

PdfPagePageOrientation Property

Gets the page orientation.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PageOrientation PageOrientation { get; }
Public ReadOnly Property PageOrientation As PageOrientation
    Get
member PageOrientation : PageOrientation with get

Property Value

Type: PageOrientation
See Also

Reference

PdfPage Class


PdfPage.Width Property

PdfPageWidth Property

Gets the width of the pdf page.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public double Width { get; }
Public ReadOnly Property Width As Double
    Get
member Width : float with get

Property Value

Type: Double
See Also

Reference

PdfPage Class


PdfPage Methods

The PdfPage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PdfPage Class


PdfPagesCollection Class

Class for managing the collection of PdfPage elements.
Inheritance Hierarchy
SystemObject
IronPdfPdfPagesCollection

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public class PdfPagesCollection : IEnumerable<PdfPage>,
    IEnumerable
Public Class PdfPagesCollection
    Implements IEnumerable(Of PdfPage), IEnumerable
type PdfPagesCollection =
    class
        interface IEnumerable<PdfPage>
        interface IEnumerable
    end

The PdfPagesCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection.
Public property | Item | Gets the PdfPage at the specified index.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

IronPdf Namespace
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


PdfPagesCollection Properties

The PdfPagesCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the collection.
Public property | Item | Gets the PdfPage at the specified index.
Top
See Also

Reference

PdfPagesCollection Class


PdfPagesCollection.Count Property

PdfPagesCollectionCount Property

Gets the number of elements contained in the collection.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
member Count : int with get

Property Value

Type: Int32
The count of pages.
See Also

Reference

PdfPagesCollection Class


PdfPagesCollection.Item Property

PdfPagesCollectionItem Property

Gets the PdfPage at the specified index.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfPage this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As PdfPage
    Get
member Item : PdfPage with get

Parameters

index
Type: SystemInt32
The index.

Property Value

Type: PdfPage
The PdfPage.

Return Value

Type: PdfPage
See Also

Reference

PdfPagesCollection Class


PdfPagesCollection Methods

The PdfPagesCollection type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PdfPagesCollection Class


PdfPagesCollection.GetEnumerator Method

PdfPagesCollectionGetEnumerator Method

Returns an enumerator that iterates through the collection.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public IEnumerator<PdfPage> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of PdfPage)
abstract GetEnumerator : unit -> IEnumerator<PdfPage>
override GetEnumerator : unit -> IEnumerator<PdfPage>

Return Value

Type: IEnumerator PdfPage
An enumerator that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

PdfPagesCollection Class


PdfPrintOptions Class

PDF output options for IronPdf. Specifies options such as Paper-Size, DPI, Headers and Footers.
Inheritance Hierarchy
SystemObject
IronPdfPdfPrintOptions

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public class PdfPrintOptions
Public Class PdfPrintOptions
type PdfPrintOptions =  class end

The PdfPrintOptions type exposes the following members.

Constructors
 | Name | Description
Public method | PdfPrintOptions | Initializes a new instance of the PdfPrintOptions class
Top
Properties
 | Name | Description
Public property | ViewPortHeight | Defines a virtual screen height used to render HTML to PDF in IronPdf. Measured in pixels. Viewport size is important in modern responsive HTML5 + CSS3 websites (e.g. Bootstrap framework websites) because the rendering and order of elements on the screen is dependent on viewport size. The default viewport is 1280px wide by 1024px high to ensure the desktop version of a website is rendered unless otherwise specified. Smaller sizes (particularly width) will render responsive versions of many websites.
Public property | ViewPortWidth | Defines a virtual screen width used to render HTML to PDF in IronPdf. Measured in pixels. Viewport size is important in modern responsive HTML5 + CSS3 websites (e.g. Bootstrap framework websites) because the rendering and order of elements on the screen is dependent on viewport size. The default viewport is 1280px wide by 1024px high to ensure the desktop version of a website is rendered unless otherwise specified. Smaller sizes (particularly width) will render responsive versions of many website
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | SetCustomPaperSize | Sets the size of the custom paper. Depreciated.
Public method | SetCustomPaperSizeInInches | Set an output paper size for PDF pages. Dimensions are in Inches.
Public method | SetCustomPaperSizeinMilimeters | Set an output paper size for PDF pages. Dimensions are in millimeters.
Public method | ToString | (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | CreatePdfFormsFromHtml | Turns all Html forms elements into editable PDF forms.
Public field | CssMediaType | Enables Media="screen" CSS Styles and StyleSheets Note: By setting AllowScreenCss=false, IronPdf prints using CSS for media="print" only.
Public field | CustomCssUrl | Allows a custom CSS style-sheet to be applied to Html before rendering. May be a local file path, or remote url.
Public field | DPI | Printing output DPI. 300 is standard for most print jobs. Higher resolutions produce clearer images and text, but also larger PDF files.
Public field | EnableJavaScript | Enables JavaScript and Json to be executed before the page is rendered. Ideal for printing from Ajax / Angular Applications. Also see RenderDelay
Public field | FirstPageNumber | First page number to be used in PDF headers and footers.
Public field | FitToPaperWidth | Where possible, shrinks the PDF content to 1 page of paper width. This applies when the PDF content is too wide for the given PaperSize (given that 1 HTML pixel = 1 DPI).
Public field | Footer | Sets the footer content for every PDF page as Html or String. Supports 'mail-merge'.
Public field | GrayScale | Outputs a black-and-white PDF
Public field | Header | Sets the header content for every PDF page as Html or String. Supports 'mail-merge'.
Public field | InputEncoding | The input character encoding as a string;
Public field | JpegQuality | Quality of any image that must be re-sampled. 0-100
Public field | MarginBottom | Paper margin in millimeters. Set to zero for border-less and commercial printing applications.
Public field | MarginLeft | Paper margin in millimeters. Set to zero for border-less and commercial printing applications.
Public field | MarginRight | Paper margin in millimeters. Set to zero for border-less and commercial printing applications.
Public field | MarginTop | Paper margin in millimeters. Set to zero for border-less and commercial printing applications.
Public field | PaperOrientation | The PDF paper orientation.
Public field | PaperSize | Set an output paper size for PDF pages. System.Drawing.Printing.PaperKind. Use SetCustomPaperSize(int width, int height) for custom sizes.
Public field | PrintHtmlBackgrounds | Prints background-colors and images from Html
Public field | RenderDelay | Milliseconds to wait after Html is rendered before printing. This can use useful when considering the rendering of JavaScript, Ajax or animations.
Public field | Title | PDF Document Name and Title meta-data. Not required.
Public field | Zoom | The zoom level in %. Enlarges the rendering size of Html documents.
Top
See Also

Reference

IronPdf Namespace
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


PdfPrintOptions Constructor

Initializes a new instance of the PdfPrintOptions class

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfPrintOptions()
Public Sub New
new : unit -> PdfPrintOptions
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions Properties

The PdfPrintOptions type exposes the following members.

Properties
 | Name | Description
Public property | ViewPortHeight | Defines a virtual screen height used to render HTML to PDF in IronPdf. Measured in pixels. Viewport size is important in modern responsive HTML5 + CSS3 websites (e.g. Bootstrap framework websites) because the rendering and order of elements on the screen is dependent on viewport size. The default viewport is 1280px wide by 1024px high to ensure the desktop version of a website is rendered unless otherwise specified. Smaller sizes (particularly width) will render responsive versions of many websites.
Public property | ViewPortWidth | Defines a virtual screen width used to render HTML to PDF in IronPdf. Measured in pixels. Viewport size is important in modern responsive HTML5 + CSS3 websites (e.g. Bootstrap framework websites) because the rendering and order of elements on the screen is dependent on viewport size. The default viewport is 1280px wide by 1024px high to ensure the desktop version of a website is rendered unless otherwise specified. Smaller sizes (particularly width) will render responsive versions of many website
Top
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions.ViewPortHeight Property

PdfPrintOptionsViewPortHeight Property

Defines a virtual screen height used to render HTML to PDF in IronPdf. Measured in pixels.

Viewport size is important in modern responsive HTML5 + CSS3 websites (e.g. Bootstrap framework websites) because the rendering and order of elements on the screen is dependent on viewport size.

The default viewport is 1280px wide by 1024px high to ensure the desktop version of a website is rendered unless otherwise specified. Smaller sizes (particularly width) will render responsive versions of many websites.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public int ViewPortHeight { get; set; }
Public Property ViewPortHeight As Integer
    Get
    Set
member ViewPortHeight : int with get, set

Property Value

Type: Int32
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions.ViewPortWidth Property

PdfPrintOptionsViewPortWidth Property

Defines a virtual screen width used to render HTML to PDF in IronPdf. Measured in pixels.

Viewport size is important in modern responsive HTML5 + CSS3 websites (e.g. Bootstrap framework websites) because the rendering and order of elements on the screen is dependent on viewport size.

The default viewport is 1280px wide by 1024px high to ensure the desktop version of a website is rendered unless otherwise specified. Smaller sizes (particularly width) will render responsive versions of many website

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public int ViewPortWidth { get; set; }
Public Property ViewPortWidth As Integer
    Get
    Set
member ViewPortWidth : int with get, set

Property Value

Type: Int32
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions Methods

The PdfPrintOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | SetCustomPaperSize | Sets the size of the custom paper. Depreciated.
Public method | SetCustomPaperSizeInInches | Set an output paper size for PDF pages. Dimensions are in Inches.
Public method | SetCustomPaperSizeinMilimeters | Set an output paper size for PDF pages. Dimensions are in millimeters.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions.SetCustomPaperSize Method

PdfPrintOptionsSetCustomPaperSize Method

Sets the size of the custom paper. Depreciated.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public void SetCustomPaperSize(
    double width,
    double height
)
Public Sub SetCustomPaperSize (
    width As Double,
    height As Double
)
member SetCustomPaperSize :
        width : float *
        height : float -> unit

Parameters

width
Type: SystemDouble
The width.
height
Type: SystemDouble
The height.
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions.SetCustomPaperSizeInInches Method

PdfPrintOptionsSetCustomPaperSizeInInches Method

Set an output paper size for PDF pages. Dimensions are in Inches.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public void SetCustomPaperSizeInInches(
    double width,
    double height
)
Public Sub SetCustomPaperSizeInInches (
    width As Double,
    height As Double
)
member SetCustomPaperSizeInInches :
        width : float *
        height : float -> unit

Parameters

width
Type: SystemDouble
Custom paper width in Inches.
height
Type: SystemDouble
>Custom paper height in Inches.
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions.SetCustomPaperSizeinMilimeters Method

PdfPrintOptionsSetCustomPaperSizeinMilimeters Method

Set an output paper size for PDF pages. Dimensions are in millimeters.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public void SetCustomPaperSizeinMilimeters(
    double width,
    double height
)
Public Sub SetCustomPaperSizeinMilimeters (
    width As Double,
    height As Double
)
member SetCustomPaperSizeinMilimeters :
        width : float *
        height : float -> unit

Parameters

width
Type: SystemDouble
Custom paper width in millimeters.
height
Type: SystemDouble
>Custom paper height in millimeters.
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions Fields

The PdfPrintOptions type exposes the following members.

Fields
 | Name | Description
Public field | CreatePdfFormsFromHtml | Turns all Html forms elements into editable PDF forms.
Public field | CssMediaType | Enables Media="screen" CSS Styles and StyleSheets Note: By setting AllowScreenCss=false, IronPdf prints using CSS for media="print" only.
Public field | CustomCssUrl | Allows a custom CSS style-sheet to be applied to Html before rendering. May be a local file path, or remote url.
Public field | DPI | Printing output DPI. 300 is standard for most print jobs. Higher resolutions produce clearer images and text, but also larger PDF files.
Public field | EnableJavaScript | Enables JavaScript and Json to be executed before the page is rendered. Ideal for printing from Ajax / Angular Applications. Also see RenderDelay
Public field | FirstPageNumber | First page number to be used in PDF headers and footers.
Public field | FitToPaperWidth | Where possible, shrinks the PDF content to 1 page of paper width. This applies when the PDF content is too wide for the given PaperSize (given that 1 HTML pixel = 1 DPI).
Public field | Footer | Sets the footer content for every PDF page as Html or String. Supports 'mail-merge'.
Public field | GrayScale | Outputs a black-and-white PDF
Public field | Header | Sets the header content for every PDF page as Html or String. Supports 'mail-merge'.
Public field | InputEncoding | The input character encoding as a string;
Public field | JpegQuality | Quality of any image that must be re-sampled. 0-100
Public field | MarginBottom | Paper margin in millimeters. Set to zero for border-less and commercial printing applications.
Public field | MarginLeft | Paper margin in millimeters. Set to zero for border-less and commercial printing applications.
Public field | MarginRight | Paper margin in millimeters. Set to zero for border-less and commercial printing applications.
Public field | MarginTop | Paper margin in millimeters. Set to zero for border-less and commercial printing applications.
Public field | PaperOrientation | The PDF paper orientation.
Public field | PaperSize | Set an output paper size for PDF pages. System.Drawing.Printing.PaperKind. Use SetCustomPaperSize(int width, int height) for custom sizes.
Public field | PrintHtmlBackgrounds | Prints background-colors and images from Html
Public field | RenderDelay | Milliseconds to wait after Html is rendered before printing. This can use useful when considering the rendering of JavaScript, Ajax or animations.
Public field | Title | PDF Document Name and Title meta-data. Not required.
Public field | Zoom | The zoom level in %. Enlarges the rendering size of Html documents.
Top
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions.CreatePdfFormsFromHtml Field

PdfPrintOptionsCreatePdfFormsFromHtml Field

Turns all Html forms elements into editable PDF forms.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public bool CreatePdfFormsFromHtml
Public CreatePdfFormsFromHtml As Boolean
val mutable CreatePdfFormsFromHtml: bool

Field Value

Type: Boolean
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions.CssMediaType Field

PdfPrintOptionsCssMediaType Field

Enables Media="screen" CSS Styles and StyleSheets

Note: By setting AllowScreenCss=false, IronPdf prints using CSS for media="print" only.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfPrintOptionsPdfCssMediaType CssMediaType
Public CssMediaType As PdfPrintOptionsPdfCssMediaType
val mutable CssMediaType: PdfPrintOptionsPdfCssMediaType

Field Value

Type: PdfPrintOptionsPdfCssMediaType
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions.CustomCssUrl Field

PdfPrintOptionsCustomCssUrl Field

Allows a custom CSS style-sheet to be applied to Html before rendering. May be a local file path, or remote url.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string CustomCssUrl
Public CustomCssUrl As String
val mutable CustomCssUrl: string

Field Value

Type: String
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions.DPI Field

PdfPrintOptionsDPI Field

Printing output DPI. 300 is standard for most print jobs. Higher resolutions produce clearer images and text, but also larger PDF files.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public int DPI
Public DPI As Integer
val mutable DPI: int

Field Value

Type: Int32
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions.EnableJavaScript Field

PdfPrintOptionsEnableJavaScript Field

Enables JavaScript and Json to be executed before the page is rendered. Ideal for printing from Ajax / Angular Applications.

Also see RenderDelay

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public bool EnableJavaScript
Public EnableJavaScript As Boolean
val mutable EnableJavaScript: bool

Field Value

Type: Boolean
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions.FirstPageNumber Field

PdfPrintOptionsFirstPageNumber Field

First page number to be used in PDF headers and footers.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public int FirstPageNumber
Public FirstPageNumber As Integer
val mutable FirstPageNumber: int

Field Value

Type: Int32
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions.FitToPaperWidth Field

PdfPrintOptionsFitToPaperWidth Field

Where possible, shrinks the PDF content to 1 page of paper width.

This applies when the PDF content is too wide for the given PaperSize (given that 1 HTML pixel = 1 DPI).

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public bool FitToPaperWidth
Public FitToPaperWidth As Boolean
val mutable FitToPaperWidth: bool

Field Value

Type: Boolean
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions.Footer Field

PdfPrintOptionsFooter Field

Sets the footer content for every PDF page as Html or String. Supports 'mail-merge'.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public SimpleHeaderFooter Footer
Public Footer As SimpleHeaderFooter
val mutable Footer: SimpleHeaderFooter

Field Value

Type: SimpleHeaderFooter
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions.GrayScale Field

PdfPrintOptionsGrayScale Field

Outputs a black-and-white PDF

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public bool GrayScale
Public GrayScale As Boolean
val mutable GrayScale: bool

Field Value

Type: Boolean
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions.Header Field

PdfPrintOptionsHeader Field

Sets the header content for every PDF page as Html or String. Supports 'mail-merge'.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public SimpleHeaderFooter Header
Public Header As SimpleHeaderFooter
val mutable Header: SimpleHeaderFooter

Field Value

Type: SimpleHeaderFooter
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions.InputEncoding Field

PdfPrintOptionsInputEncoding Field

The input character encoding as a string;

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public Encoding InputEncoding
Public InputEncoding As Encoding
val mutable InputEncoding: Encoding

Field Value

Type: Encoding
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions.JpegQuality Field

PdfPrintOptionsJpegQuality Field

Quality of any image that must be re-sampled. 0-100

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public int JpegQuality
Public JpegQuality As Integer
val mutable JpegQuality: int

Field Value

Type: Int32
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions.MarginBottom Field

PdfPrintOptionsMarginBottom Field

Paper margin in millimeters. Set to zero for border-less and commercial printing applications.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public double MarginBottom
Public MarginBottom As Double
val mutable MarginBottom: float

Field Value

Type: Double
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions.MarginLeft Field

PdfPrintOptionsMarginLeft Field

Paper margin in millimeters. Set to zero for border-less and commercial printing applications.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public double MarginLeft
Public MarginLeft As Double
val mutable MarginLeft: float

Field Value

Type: Double
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions.MarginRight Field

PdfPrintOptionsMarginRight Field

Paper margin in millimeters. Set to zero for border-less and commercial printing applications.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public double MarginRight
Public MarginRight As Double
val mutable MarginRight: float

Field Value

Type: Double
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions.MarginTop Field

PdfPrintOptionsMarginTop Field

Paper margin in millimeters. Set to zero for border-less and commercial printing applications.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public double MarginTop
Public MarginTop As Double
val mutable MarginTop: float

Field Value

Type: Double
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions.PaperOrientation Field

PdfPrintOptionsPaperOrientation Field

The PDF paper orientation.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfPrintOptionsPdfPaperOrientation PaperOrientation
Public PaperOrientation As PdfPrintOptionsPdfPaperOrientation
val mutable PaperOrientation: PdfPrintOptionsPdfPaperOrientation

Field Value

Type: PdfPrintOptionsPdfPaperOrientation
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions.PaperSize Field

PdfPrintOptionsPaperSize Field

Set an output paper size for PDF pages. System.Drawing.Printing.PaperKind.

Use SetCustomPaperSize(int width, int height) for custom sizes.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfPrintOptionsPdfPaperSize PaperSize
Public PaperSize As PdfPrintOptionsPdfPaperSize
val mutable PaperSize: PdfPrintOptionsPdfPaperSize

Field Value

Type: PdfPrintOptionsPdfPaperSize
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions.PrintHtmlBackgrounds Field

PdfPrintOptionsPrintHtmlBackgrounds Field

Prints background-colors and images from Html

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public bool PrintHtmlBackgrounds
Public PrintHtmlBackgrounds As Boolean
val mutable PrintHtmlBackgrounds: bool

Field Value

Type: Boolean
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions.RenderDelay Field

PdfPrintOptionsRenderDelay Field

Milliseconds to wait after Html is rendered before printing. This can use useful when considering the rendering of JavaScript, Ajax or animations.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public int RenderDelay
Public RenderDelay As Integer
val mutable RenderDelay: int

Field Value

Type: Int32
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions.Title Field

PdfPrintOptionsTitle Field

PDF Document Name and Title meta-data. Not required.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string Title
Public Title As String
val mutable Title: string

Field Value

Type: String
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions.Zoom Field

PdfPrintOptionsZoom Field

The zoom level in %. Enlarges the rendering size of Html documents.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public int Zoom
Public Zoom As Integer
val mutable Zoom: int

Field Value

Type: Int32
See Also

Reference

PdfPrintOptions Class


PdfPrintOptions.PdfCssMediaType Enumeration

PdfPrintOptionsPdfCssMediaType Enumeration

Defines which style-sheet should be rendered. 'Print' or 'Screen'. This matches the CSS3 Media Queries standard.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public enum PdfCssMediaType
Public Enumeration PdfCssMediaType
type PdfCssMediaType
Members
Member name | Value | Description
Print | 0 |
Screen | 1 |
See Also

Reference

IronPdf Namespace
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


PdfPrintOptions.PdfPaperOrientation Enumeration

PdfPrintOptionsPdfPaperOrientation Enumeration

Paper Orientation

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public enum PdfPaperOrientation
Public Enumeration PdfPaperOrientation
type PdfPaperOrientation
Members
Member name | Value | Description
Portrait | 0 |
Landscape | 1 |
See Also

Reference

IronPdf Namespace
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


PdfPrintOptions.PdfPaperSize Enumeration

PdfPrintOptionsPdfPaperSize Enumeration

Defines the target paper size the PDF will use of pagination. Relates to real-world paper-sizes.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public enum PdfPaperSize
Public Enumeration PdfPaperSize
type PdfPaperSize
Members
Member name | Value | Description
Letter | 0 |
Legal | 1 |
A4 | 2 |
CSheet | 3 |
DSheet | 4 |
ESheet | 5 |
LetterSmall | 6 |
Tabloid | 7 |
Ledger | 8 |
Statement | 9 |
Executive | 10 |
A3 | 11 |
A4Small | 12 |
A5 | 13 |
B4 | 14 |
B5 | 15 |
Folio | 16 |
Quarto | 17 |
Standard10x14 | 18 |
Standard11x17 | 19 |
Note | 20 |
Number9Envelope | 21 |
Number10Envelope | 22 |
Number11Envelope | 23 |
Number12Envelope | 24 |
Number14Envelope | 25 |
DLEnvelope | 26 |
C5Envelope | 27 |
C3Envelope | 28 |
C4Envelope | 29 |
C6Envelope | 30 |
C65Envelope | 31 |
B4Envelope | 32 |
B5Envelope | 33 |
B6Envelope | 34 |
ItalyEnvelope | 35 |
MonarchEnvelope | 36 |
PersonalEnvelope | 37 |
USStandardFanfold | 38 |
GermanStandardFanfold | 39 |
GermanLegalFanfold | 40 |
IsoB4 | 41 |
JapanesePostcard | 42 |
Standard9x11 | 43 |
Standard10x11 | 44 |
Standard15x11 | 45 |
InviteEnvelope | 46 |
LetterExtra | 47 |
LegalExtra | 48 |
TabloidExtra | 49 |
A4Extra | 50 |
LetterTransverse | 51 |
A4Transverse | 52 |
LetterExtraTransverse | 53 |
APlus | 54 |
BPlus | 55 |
LetterPlus | 56 |
A4Plus | 57 |
A5Transverse | 58 |
B5Transverse | 59 |
A3Extra | 60 |
A5Extra | 61 |
B5Extra | 62 |
A2 | 63 |
A3Transverse | 64 |
A3ExtraTransverse | 65 |
JapaneseDoublePostcard | 66 |
A6 | 67 |
LetterRotated | 68 |
A3Rotated | 69 |
A4Rotated | 70 |
A5Rotated | 71 |
B4JisRotated | 72 |
B5JisRotated | 73 |
JapanesePostcardRotated | 74 |
JapaneseDoublePostcardRotated | 75 |
A6Rotated | 76 |
B6Jis | 77 |
B6JisRotated | 78 |
Standard12x11 | 79 |
Prc16K | 80 |
Prc32K | 81 |
Prc32KBig | 82 |
PrcEnvelopeNumber1 | 83 |
PrcEnvelopeNumber2 | 84 |
PrcEnvelopeNumber3 | 85 |
PrcEnvelopeNumber4 | 86 |
PrcEnvelopeNumber5 | 87 |
PrcEnvelopeNumber6 | 88 |
PrcEnvelopeNumber7 | 89 |
PrcEnvelopeNumber8 | 90 |
PrcEnvelopeNumber9 | 91 |
PrcEnvelopeNumber10 | 92 |
Prc16KRotated | 93 |
Prc32KRotated | 94 |
Prc32KBigRotated | 95 |
PrcEnvelopeNumber1Rotated | 96 |
PrcEnvelopeNumber2Rotated | 97 |
PrcEnvelopeNumber3Rotated | 98 |
PrcEnvelopeNumber4Rotated | 99 |
PrcEnvelopeNumber5Rotated | 100 |
PrcEnvelopeNumber6Rotated | 101 |
PrcEnvelopeNumber7Rotated | 102 |
PrcEnvelopeNumber8Rotated | 103 |
PrcEnvelopeNumber9Rotated | 104 |
PrcEnvelopeNumber10Rotated | 105 |
Custom | 106 |
See Also

Reference

IronPdf Namespace
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


PdfSignature Class

A class that represents a PDF signing certificate (.PFX or .p12) format which can be used to digitally sign a PDF. This protecting it from alteration.

Not implemented in .Net Core

Inheritance Hierarchy
SystemObject
IronPdfPdfSignature

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public class PdfSignature
Public Class PdfSignature
type PdfSignature =  class end

The PdfSignature type exposes the following members.

Constructors
 | Name | Description
Public method | PdfSignature(X509Certificate2) | Initializes a new instance of the PdfSignature class.
Public method | PdfSignature(Byte, String) | Initializes a new instance of the PdfSignature class.
Public method | PdfSignature(String, String) | Initializes a new instance of the PdfSignature class using a .pfx or .p12 digital signature file.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | LoadSignatureImageFromFile | Loads a signature image from an image file. This appends a visual signature in addition to cryptographic signing.
Public method | LoadSignatureImageFromStream | Loads a signature image from a stream. This appends visual signature in addition to cryptographic signing.
Public method | SignPdfFile | Signs an existing PDF file.
Public method | ToString | (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | SignatureDate | The date and time of the digital signature. If left null, the signature will be timestamped at the millisecond that the PdfDocument is saved to Disk or Stream.
Public field | SignatureImage | A visual image for the sign, often a PNG of a human signature or company stamp (optional). This appends a visual signature in addition to cryptographic signing.
Public field | SigningContact | The contact person or email address for signing related inquiries (optional).
Public field | SigningLocation | The physical location the PDF was signed (optional).
Public field | SigningReason | The reason the PDF was signed (optional).
Top
See Also

Reference

IronPdf Namespace
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


PdfSignature Constructor

Overload List
 | Name | Description
Public method | PdfSignature(X509Certificate2) | Initializes a new instance of the PdfSignature class.
Public method | PdfSignature(Byte, String) | Initializes a new instance of the PdfSignature class.
Public method | PdfSignature(String, String) | Initializes a new instance of the PdfSignature class using a .pfx or .p12 digital signature file.
Top
See Also

Reference

PdfSignature Class


PdfSignature Constructor (X509Certificate2)

Initializes a new instance of the PdfSignature class.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfSignature(
    X509Certificate2 ExportableNativeCertificate
)
Public Sub New (
    ExportableNativeCertificate As X509Certificate2
)
new :
        ExportableNativeCertificate : X509Certificate2 -> PdfSignature

Parameters

ExportableNativeCertificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate2
The exportable native certificate as a System.Security.Cryptography.X509Certificates.X509Certificate2.
See Also

Reference

PdfSignature Class
PdfSignature Overload


PdfSignature Constructor (Byte[], String)

PdfSignature Constructor (Byte, String)

Initializes a new instance of the PdfSignature class.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfSignature(
    byte[] CertificateRawData,
    string Password
)
Public Sub New (
    CertificateRawData As Byte(),
    Password As String
)
new :
        CertificateRawData : byte[] *
        Password : string -> PdfSignature

Parameters

CertificateRawData
Type: SystemByte
The certificate as a binary data (byte array).
Password
Type: SystemString
The certificate's password.
See Also

Reference

PdfSignature Class
PdfSignature Overload


PdfSignature Constructor (String, String)

Initializes a new instance of the PdfSignature class using a .pfx or .p12 digital signature file.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfSignature(
    string FilePathToCertificate,
    string Password
)
Public Sub New (
    FilePathToCertificate As String,
    Password As String
)
new :
        FilePathToCertificate : string *
        Password : string -> PdfSignature

Parameters

FilePathToCertificate
Type: SystemString
The file path to certificate.
Password
Type: SystemString
The certificate's password.
See Also

Reference

PdfSignature Class
PdfSignature Overload


PdfSignature Methods

The PdfSignature type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | LoadSignatureImageFromFile | Loads a signature image from an image file. This appends a visual signature in addition to cryptographic signing.
Public method | LoadSignatureImageFromStream | Loads a signature image from a stream. This appends visual signature in addition to cryptographic signing.
Public method | SignPdfFile | Signs an existing PDF file.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PdfSignature Class


PdfSignature.LoadSignatureImageFromFile Method

PdfSignatureLoadSignatureImageFromFile Method

Loads a signature image from an image file. This appends a visual signature in addition to cryptographic signing.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public void LoadSignatureImageFromFile(
    string FilePath
)
Public Sub LoadSignatureImageFromFile (
    FilePath As String
)
member LoadSignatureImageFromFile :
        FilePath : string -> unit

Parameters

FilePath
Type: SystemString
The file path.
See Also

Reference

PdfSignature Class


PdfSignature.LoadSignatureImageFromStream Method

PdfSignatureLoadSignatureImageFromStream Method

Loads a signature image from a stream. This appends visual signature in addition to cryptographic signing.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public void LoadSignatureImageFromStream(
    Stream Stream
)
Public Sub LoadSignatureImageFromStream (
    Stream As Stream
)
member LoadSignatureImageFromStream :
        Stream : Stream -> unit

Parameters

Stream
Type: System.IOStream
The image file as a stream.
See Also

Reference

PdfSignature Class


PdfSignature.SignPdfFile Method

PdfSignatureSignPdfFile Method

Signs an existing PDF file.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public bool SignPdfFile(
    string PdfFilePath,
    bool RemoveOldSignatures = false
)
Public Function SignPdfFile (
    PdfFilePath As String,
    Optional RemoveOldSignatures As Boolean = false
) As Boolean
member SignPdfFile :
        PdfFilePath : string *
        ?RemoveOldSignatures : bool
(* Defaults:
        let _RemoveOldSignatures = defaultArg RemoveOldSignatures false
*)
-> bool

Parameters

PdfFilePath
Type: SystemString
The PDF file path.
RemoveOldSignatures (Optional)
Type: SystemBoolean
if set to true old digital signatures are removed to ensure signing validity.

Return Value

Type: Boolean
true if successful.
See Also

Reference

PdfSignature Class


PdfSignature Fields

The PdfSignature type exposes the following members.

Fields
 | Name | Description
Public field | SignatureDate | The date and time of the digital signature. If left null, the signature will be timestamped at the millisecond that the PdfDocument is saved to Disk or Stream.
Public field | SignatureImage | A visual image for the sign, often a PNG of a human signature or company stamp (optional). This appends a visual signature in addition to cryptographic signing.
Public field | SigningContact | The contact person or email address for signing related inquiries (optional).
Public field | SigningLocation | The physical location the PDF was signed (optional).
Public field | SigningReason | The reason the PDF was signed (optional).
Top
See Also

Reference

PdfSignature Class


PdfSignature.SignatureDate Field

PdfSignatureSignatureDate Field

The date and time of the digital signature. If left null, the signature will be timestamped at the millisecond that the PdfDocument is saved to Disk or Stream.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public Nullable<DateTime> SignatureDate
Public SignatureDate As Nullable(Of DateTime)
val mutable SignatureDate: Nullable<DateTime>

Field Value

Type: Nullable DateTime
See Also

Reference

PdfSignature Class


PdfSignature.SignatureImage Field

PdfSignatureSignatureImage Field

A visual image for the sign, often a PNG of a human signature or company stamp (optional).

This appends a visual signature in addition to cryptographic signing.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public Image SignatureImage
Public SignatureImage As Image
val mutable SignatureImage: Image

Field Value

Type: Image
See Also

Reference

PdfSignature Class
IronPdf Namespace
PdfSignatureLoadSignatureImageFromFile(String)
PdfSignatureLoadSignatureImageFromStream(Stream)


PdfSignature.SigningContact Field

PdfSignatureSigningContact Field

The contact person or email address for signing related inquiries (optional).

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string SigningContact
Public SigningContact As String
val mutable SigningContact: string

Field Value

Type: String
See Also

Reference

PdfSignature Class


PdfSignature.SigningLocation Field

PdfSignatureSigningLocation Field

The physical location the PDF was signed (optional).

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string SigningLocation
Public SigningLocation As String
val mutable SigningLocation: string

Field Value

Type: String
See Also

Reference

PdfSignature Class


PdfSignature.SigningReason Field

PdfSignatureSigningReason Field

The reason the PDF was signed (optional).

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string SigningReason
Public SigningReason As String
val mutable SigningReason: string

Field Value

Type: String
See Also

Reference

PdfSignature Class


SimpleHeaderFooter Class

Defines PDF Header and Footer display options.
Inheritance Hierarchy
SystemObject
IronPdfSimpleHeaderFooter
IronPdfHtmlHeaderFooter

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public class SimpleHeaderFooter : ICloneable
Public Class SimpleHeaderFooter
    Implements ICloneable
type SimpleHeaderFooter =
    class
        interface ICloneable
    end

The SimpleHeaderFooter type exposes the following members.

Constructors
 | Name | Description
Public method | SimpleHeaderFooter | Initializes a new instance of the SimpleHeaderFooter class
Top
Methods
 | Name | Description
Public method | Clone | Clones this instance.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | CenterText | Sets the centered header text for the PDF document. Merge meta-data into your header using any of these placeholder strings: {page} {total-pages} {url} {date} {time} {html-title} {pdf-title}
Public field | DrawDividerLine | Adds a horizontal line divider between the header / footer and the page content on every page of the PDF document.
Public field | FontFamily | Font used to render the PDF header.
Public field | FontSize | Font size in px.
Public field | LeftText | Sets the left hand side header text for the PDF document. Merge meta-data into your header using any of these placeholder strings: {page} {total-pages} {url} {date} {time} {html-title} {pdf-title}
Public field | RightText | Sets the right hand side header text for the PDF document. Merge meta-data into your header using any of these placeholder strings: {page} {total-pages} {url} {date} {time} {html-title} {pdf-title}
Public field | Spacing | Space between the header and page content in millimeters.
Top
See Also

Reference

IronPdf Namespace
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


SimpleHeaderFooter Constructor

Initializes a new instance of the SimpleHeaderFooter class

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public SimpleHeaderFooter()
Public Sub New
new : unit -> SimpleHeaderFooter
See Also

Reference

SimpleHeaderFooter Class


SimpleHeaderFooter Methods

The SimpleHeaderFooter type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Clones this instance.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SimpleHeaderFooter Class


SimpleHeaderFooter.Clone Method

SimpleHeaderFooterClone Method

Clones this instance.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public Object Clone()
Public Function Clone As Object
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Object
System.Object of type SimpleHeaderFooter

Implements

ICloneableClone
See Also

Reference

SimpleHeaderFooter Class


SimpleHeaderFooter Fields

The SimpleHeaderFooter type exposes the following members.

Fields
 | Name | Description
Public field | CenterText | Sets the centered header text for the PDF document. Merge meta-data into your header using any of these placeholder strings: {page} {total-pages} {url} {date} {time} {html-title} {pdf-title}
Public field | DrawDividerLine | Adds a horizontal line divider between the header / footer and the page content on every page of the PDF document.
Public field | FontFamily | Font used to render the PDF header.
Public field | FontSize | Font size in px.
Public field | LeftText | Sets the left hand side header text for the PDF document. Merge meta-data into your header using any of these placeholder strings: {page} {total-pages} {url} {date} {time} {html-title} {pdf-title}
Public field | RightText | Sets the right hand side header text for the PDF document. Merge meta-data into your header using any of these placeholder strings: {page} {total-pages} {url} {date} {time} {html-title} {pdf-title}
Public field | Spacing | Space between the header and page content in millimeters.
Top
See Also

Reference

SimpleHeaderFooter Class


SimpleHeaderFooter.CenterText Field

SimpleHeaderFooterCenterText Field

Sets the centered header text for the PDF document.

Merge meta-data into your header using any of these placeholder strings: {page} {total-pages} {url} {date} {time} {html-title} {pdf-title}

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string CenterText
Public CenterText As String
val mutable CenterText: string

Field Value

Type: String
See Also

Reference

SimpleHeaderFooter Class


SimpleHeaderFooter.DrawDividerLine Field

SimpleHeaderFooterDrawDividerLine Field

Adds a horizontal line divider between the header / footer and the page content on every page of the PDF document.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public bool DrawDividerLine
Public DrawDividerLine As Boolean
val mutable DrawDividerLine: bool

Field Value

Type: Boolean
See Also

Reference

SimpleHeaderFooter Class


SimpleHeaderFooter.FontFamily Field

SimpleHeaderFooterFontFamily Field

Font used to render the PDF header.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string FontFamily
Public FontFamily As String
val mutable FontFamily: string

Field Value

Type: String
See Also

Reference

SimpleHeaderFooter Class


SimpleHeaderFooter.FontSize Field

SimpleHeaderFooterFontSize Field

Font size in px.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public int FontSize
Public FontSize As Integer
val mutable FontSize: int

Field Value

Type: Int32
See Also

Reference

SimpleHeaderFooter Class


SimpleHeaderFooter.LeftText Field

SimpleHeaderFooterLeftText Field

Sets the left hand side header text for the PDF document.

Merge meta-data into your header using any of these placeholder strings: {page} {total-pages} {url} {date} {time} {html-title} {pdf-title}

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string LeftText
Public LeftText As String
val mutable LeftText: string

Field Value

Type: String
See Also

Reference

SimpleHeaderFooter Class


SimpleHeaderFooter.RightText Field

SimpleHeaderFooterRightText Field

Sets the right hand side header text for the PDF document.

Merge meta-data into your header using any of these placeholder strings: {page} {total-pages} {url} {date} {time} {html-title} {pdf-title}

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string RightText
Public RightText As String
val mutable RightText: string

Field Value

Type: String
See Also

Reference

SimpleHeaderFooter Class


SimpleHeaderFooter.Spacing Field

SimpleHeaderFooterSpacing Field

Space between the header and page content in millimeters.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public int Spacing
Public Spacing As Integer
val mutable Spacing: int

Field Value

Type: Int32
See Also

Reference

SimpleHeaderFooter Class


TempFolder Class

Provides operations over the temporary folder
Inheritance Hierarchy
SystemObject
IronPdfTempFolder

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public static class TempFolder
Public NotInheritable Class TempFolder
[<AbstractClassAttribute>]
[<SealedAttribute>]
type TempFolder =  class end

The TempFolder type exposes the following members.

Methods
Name | Description
CleanupTempImages | Method to remove temporary images from TempFolderPath If you used a custom TempFolderPath then set TempFolderPath to point towards your deployment directory before you call this cleanup method.
Top
See Also

Reference

IronPdf Namespace
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


TempFolder Methods

The TempFolder type exposes the following members.

Methods
Name | Description
CleanupTempImages | Method to remove temporary images from TempFolderPath If you used a custom TempFolderPath then set TempFolderPath to point towards your deployment directory before you call this cleanup method.
Top
See Also

Reference

TempFolder Class


TempFolder.CleanupTempImages Method

TempFolderCleanupTempImages Method

Method to remove temporary images from TempFolderPath

If you used a custom TempFolderPath then set TempFolderPath to point towards your deployment directory before you call this cleanup method.

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public static void CleanupTempImages(
    Nullable<TimeSpan> expirationTime = null
)
Public Shared Sub CleanupTempImages (
    Optional expirationTime As Nullable(Of TimeSpan) = Nothing
)
static member CleanupTempImages :
        ?expirationTime : Nullable<TimeSpan>
(* Defaults:
        let _expirationTime = defaultArg expirationTime null
*)
-> unit

Parameters

expirationTime (Optional)
Type: SystemNullable TimeSpan
Time from last access for files to delete. All files are deleted by default.
See Also

Reference

TempFolder Class


Util Class

Useful methods for working with HTML and PDF files.
Inheritance Hierarchy
SystemObject
IronPdfUtil

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public static class Util
Public NotInheritable Class Util
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Util =  class end

The Util type exposes the following members.

Methods
Name | Description
ImageToDataUri | Turns a System.Drawing.Image or System.Drawing.Bitmap into a DataUri which can used to embed the Image directly into an HTML document. Read standard https://en.wikipedia.org/wiki/Data_URI_scheme
Top
See Also

Reference

IronPdf Namespace
IronPdf - The C# PDF Library Copyright IronPdf.com 2015-2016


Util Methods

The Util type exposes the following members.

Methods
Name | Description
ImageToDataUri | Turns a System.Drawing.Image or System.Drawing.Bitmap into a DataUri which can used to embed the Image directly into an HTML document. Read standard https://en.wikipedia.org/wiki/Data_URI_scheme
Top
See Also

Reference

Util Class


Util.ImageToDataUri Method

UtilImageToDataUri Method

Turns a System.Drawing.Image or System.Drawing.Bitmap into a DataUri which can used to embed the Image directly into an HTML document.

Read standard https://en.wikipedia.org/wiki/Data_URI_scheme

Namespace: IronPdf
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public static string ImageToDataUri(
    Image Image,
    bool Rasterize = false
)
Public Shared Function ImageToDataUri (
    Image As Image,
    Optional Rasterize As Boolean = false
) As String
static member ImageToDataUri :
        Image : Image *
        ?Rasterize : bool
(* Defaults:
        let _Rasterize = defaultArg Rasterize false
*)
-> string

Parameters

Image
Type: System.DrawingImage
A non-null System.Drawing.Image or System.Drawing.Bitmap
Rasterize (Optional)
Type: SystemBoolean
Optional flag to flatten the image to raw pixels to increase compatibility with HTML (may affect PDF file size and rendering time)

Return Value

Type: String
A data URL which can be used as the src attribute of an HTML <img tag
See Also

Reference

Util Class


IronPdf.Forms Namespace

[Missing <summary> documentation for "N:IronPdf.Forms"]

Classes
 | Class | Description
Public class | CheckBoxField | Represents a check-box in a PDF form.
Public class | ComboBoxField | Represents a combo-box (drop down menu) in a PDF form.
Public class | FormField | Generic base class from which all PDF Form fields are derived.
Public class | PdfForm |
Public class | TextField | Represents an editable text input field in a PDF document.


CheckBoxField Class

Represents a check-box in a PDF form.
Inheritance Hierarchy
SystemObject
IronPdf.FormsFormField
IronPdf.FormsCheckBoxField

Namespace: IronPdf.Forms
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public class CheckBoxField : FormField
Public Class CheckBoxField
    Inherits FormField
type CheckBoxField =
    class
        inherit FormField
    end

The CheckBoxField type exposes the following members.

Constructors
 | Name | Description
Public method | CheckBoxField | Initializes a new instance of the CheckBoxField class
Top
Properties
 | Name | Description
Public property | BooleanValue | Gets or sets a value indicating whether the check-box is checked (ticked).
Public property | Name | Gets the ID name of this field. (Inherited from FormField.)
Public property | ReadOnly | Gets or sets the permissions for users to fill-in current form field. (Inherited from FormField.)
Public property | Value | Gets or sets the value of the CheckBoxField as a string. (Overrides FormFieldValue.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | SetFont | Sets the font to the text field of pdf form. (Inherited from FormField.)
Public method | ToString | Returns the value of this field. (Inherited from FormField.)
Top
See Also

Reference

IronPdf.Forms Namespace
IronPdf.FormsFormField


CheckBoxField Constructor

Initializes a new instance of the CheckBoxField class

Namespace: IronPdf.Forms
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public CheckBoxField()
Public Sub New
new : unit -> CheckBoxField
See Also

Reference

CheckBoxField Class
IronPdf.Forms Namespace


CheckBoxField Properties

The CheckBoxField type exposes the following members.

Properties
 | Name | Description
Public property | BooleanValue | Gets or sets a value indicating whether the check-box is checked (ticked).
Public property | Name | Gets the ID name of this field. (Inherited from FormField.)
Public property | ReadOnly | Gets or sets the permissions for users to fill-in current form field. (Inherited from FormField.)
Public property | Value | Gets or sets the value of the CheckBoxField as a string. (Overrides FormFieldValue.)
Top
See Also

Reference

CheckBoxField Class
IronPdf.Forms Namespace


CheckBoxField.BooleanValue Property

CheckBoxFieldBooleanValue Property

Gets or sets a value indicating whether the check-box is checked (ticked).

Namespace: IronPdf.Forms
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public bool BooleanValue { get; set; }
Public Property BooleanValue As Boolean
    Get
    Set
member BooleanValue : bool with get, set

Property Value

Type: Boolean
true if checked; otherwise, false.
See Also

Reference

CheckBoxField Class
IronPdf.Forms Namespace


CheckBoxField.Value Property

CheckBoxFieldValue Property

Gets or sets the value of the CheckBoxField as a string.

Namespace: IronPdf.Forms
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public override string Value { get; set; }
Public Overrides Property Value As String
    Get
    Set
abstract Value : string with get, set
override Value : string with get, set

Property Value

Type: String
A typical return value for a checked box is "/Yes", other values mean that the box is not checked.
See Also

Reference

CheckBoxField Class
IronPdf.Forms Namespace
CheckBoxFieldBooleanValue


CheckBoxField Methods

The CheckBoxField type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | SetFont | Sets the font to the text field of pdf form. (Inherited from FormField.)
Public method | ToString | Returns the value of this field. (Inherited from FormField.)
Top
See Also

Reference

CheckBoxField Class
IronPdf.Forms Namespace


ComboBoxField Class

Represents a combo-box (drop down menu) in a PDF form.
Inheritance Hierarchy
SystemObject
IronPdf.FormsFormField
IronPdf.FormsComboBoxField

Namespace: IronPdf.Forms
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public class ComboBoxField : FormField
Public Class ComboBoxField
    Inherits FormField
type ComboBoxField =
    class
        inherit FormField
    end

The ComboBoxField type exposes the following members.

Constructors
 | Name | Description
Public method | ComboBoxField | Initializes a new instance of the ComboBoxField class
Top
Properties
 | Name | Description
Public property | Name | Gets the ID name of this field. (Inherited from FormField.)
Public property | Options | Gets the available options for the combo-box in zero based index order.
Public property | ReadOnly | Gets or sets the permissions for users to fill-in current form field. (Inherited from FormField.)
Public property | SelectedIndex | Gets the index of the selected option.
Public property | Value | Gets or sets the text value of the combo-box. (Overrides FormFieldValue.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | SetFont | Sets the font to the text field of pdf form. (Inherited from FormField.)
Public method | ToString | Returns the value of this field. (Inherited from FormField.)
Top
See Also

Reference

IronPdf.Forms Namespace
IronPdf.FormsFormField


ComboBoxField Constructor

Initializes a new instance of the ComboBoxField class

Namespace: IronPdf.Forms
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public ComboBoxField()
Public Sub New
new : unit -> ComboBoxField
See Also

Reference

ComboBoxField Class
IronPdf.Forms Namespace


ComboBoxField Properties

The ComboBoxField type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the ID name of this field. (Inherited from FormField.)
Public property | Options | Gets the available options for the combo-box in zero based index order.
Public property | ReadOnly | Gets or sets the permissions for users to fill-in current form field. (Inherited from FormField.)
Public property | SelectedIndex | Gets the index of the selected option.
Public property | Value | Gets or sets the text value of the combo-box. (Overrides FormFieldValue.)
Top
See Also

Reference

ComboBoxField Class
IronPdf.Forms Namespace


ComboBoxField.Options Property

ComboBoxFieldOptions Property

Gets the available options for the combo-box in zero based index order.

Namespace: IronPdf.Forms
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string[] Options { get; }
Public ReadOnly Property Options As String()
    Get
member Options : string[] with get

Property Value

Type: String
The option names as strings.
See Also

Reference

ComboBoxField Class
IronPdf.Forms Namespace


ComboBoxField.SelectedIndex Property

ComboBoxFieldSelectedIndex Property

Gets the index of the selected option.

Namespace: IronPdf.Forms
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public int SelectedIndex { get; }
Public ReadOnly Property SelectedIndex As Integer
    Get
member SelectedIndex : int with get

Property Value

Type: Int32
The index of the selected. 0 based.
See Also

Reference

ComboBoxField Class
IronPdf.Forms Namespace


ComboBoxField.Value Property

ComboBoxFieldValue Property

Gets or sets the text value of the combo-box.

Namespace: IronPdf.Forms
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public override string Value { get; set; }
Public Overrides Property Value As String
    Get
    Set
abstract Value : string with get, set
override Value : string with get, set

Property Value

Type: String
The value as a string.
See Also

Reference

ComboBoxField Class
IronPdf.Forms Namespace


ComboBoxField Methods

The ComboBoxField type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | SetFont | Sets the font to the text field of pdf form. (Inherited from FormField.)
Public method | ToString | Returns the value of this field. (Inherited from FormField.)
Top
See Also

Reference

ComboBoxField Class
IronPdf.Forms Namespace


FormField Class

Generic base class from which all PDF Form fields are derived.
Inheritance Hierarchy
SystemObject
IronPdf.FormsFormField
IronPdf.FormsCheckBoxField
IronPdf.FormsComboBoxField
IronPdf.FormsTextField

Namespace: IronPdf.Forms
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public class FormField
Public Class FormField
type FormField =  class end

The FormField type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the ID name of this field.
Public property | ReadOnly | Gets or sets the permissions for users to fill-in current form field.
Public property | Value | Gets the value of the editable PDF field.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | SetFont | Sets the font to the text field of pdf form.
Public method | ToString | Returns the value of this field. (Overrides ObjectToString.)
Top
See Also

Reference

IronPdf.Forms Namespace


FormField Properties

The FormField type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the ID name of this field.
Public property | ReadOnly | Gets or sets the permissions for users to fill-in current form field.
Public property | Value | Gets the value of the editable PDF field.
Top
See Also

Reference

FormField Class
IronPdf.Forms Namespace


FormField.Name Property

FormFieldName Property

Gets the ID name of this field.

Namespace: IronPdf.Forms
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
member Name : string with get

Property Value

Type: String
The name as a string.
See Also

Reference

FormField Class
IronPdf.Forms Namespace
PdfFormGetFieldByName(String)


FormField.ReadOnly Property

FormFieldReadOnly Property

Gets or sets the permissions for users to fill-in current form field.

Namespace: IronPdf.Forms
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public bool ReadOnly { get; set; }
Public Property ReadOnly As Boolean
    Get
    Set
member ReadOnly : bool with get, set

Property Value

Type: Boolean
true if form field is readonly, otherwise false.
See Also

Reference

FormField Class
IronPdf.Forms Namespace


FormField.Value Property

FormFieldValue Property

Gets the value of the editable PDF field.

Namespace: IronPdf.Forms
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public virtual string Value { get; set; }
Public Overridable Property Value As String
    Get
    Set
abstract Value : string with get, set
override Value : string with get, set

Property Value

Type: String
The value.
See Also

Reference

FormField Class
IronPdf.Forms Namespace


FormField Methods

The FormField type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | SetFont | Sets the font to the text field of pdf form.
Public method | ToString | Returns the value of this field. (Overrides ObjectToString.)
Top
See Also

Reference

FormField Class
IronPdf.Forms Namespace


FormField.SetFont Method

FormFieldSetFont Method

Sets the font to the text field of pdf form.

Namespace: IronPdf.Forms
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public virtual void SetFont(
    FontTypes fontType,
    double fontSize = 11
)
Public Overridable Sub SetFont (
    fontType As FontTypes,
    Optional fontSize As Double = 11
)
abstract SetFont :
        fontType : FontTypes *
        ?fontSize : float
(* Defaults:
        let _fontSize = defaultArg fontSize 11
*)
-> unit
override SetFont :
        fontType : FontTypes *
        ?fontSize : float
(* Defaults:
        let _fontSize = defaultArg fontSize 11
*)
-> unit

Parameters

fontType
Type: IronPdf.Forms.EnumsFontTypes
Type of the font.
fontSize (Optional)
Type: SystemDouble
Size of the font.
See Also

Reference

FormField Class
IronPdf.Forms Namespace


FormField.ToString Method

FormFieldToString Method

Returns the value of this field.

Namespace: IronPdf.Forms
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
The value of this field.
See Also

Reference

FormField Class
IronPdf.Forms Namespace


PdfForm Class

[Missing <summary> documentation for "T:IronPdf.Forms.PdfForm"]

Inheritance Hierarchy
SystemObject
IronPdf.FormsPdfForm

Namespace: IronPdf.Forms
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public class PdfForm
Public Class PdfForm
type PdfForm =  class end

The PdfForm type exposes the following members.

Constructors
 | Name | Description
Public method | PdfForm | Initializes a new instance of the PdfForm class
Top
Properties
 | Name | Description
Public property | FieldNames | Returns the field name of every editable data field in the PDF.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetFieldByName | Returns a FormField by its name. This method is fault tolerant and will attempt to match case mistakes and partial field names.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Fields | The editable fields within this PDF.
Top
See Also

Reference

IronPdf.Forms Namespace


PdfForm Constructor

Initializes a new instance of the PdfForm class

Namespace: IronPdf.Forms
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public PdfForm()
Public Sub New
new : unit -> PdfForm
See Also

Reference

PdfForm Class
IronPdf.Forms Namespace


PdfForm Properties

The PdfForm type exposes the following members.

Properties
 | Name | Description
Public property | FieldNames | Returns the field name of every editable data field in the PDF.
Top
See Also

Reference

PdfForm Class
IronPdf.Forms Namespace


PdfForm.FieldNames Property

PdfFormFieldNames Property

Returns the field name of every editable data field in the PDF.

Namespace: IronPdf.Forms
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public string[] FieldNames { get; }
Public ReadOnly Property FieldNames As String()
    Get
member FieldNames : string[] with get

Property Value

Type: String
The field names as an array of strings.
See Also

Reference

PdfForm Class
IronPdf.Forms Namespace


PdfForm Methods

The PdfForm type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetFieldByName | Returns a FormField by its name. This method is fault tolerant and will attempt to match case mistakes and partial field names.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PdfForm Class
IronPdf.Forms Namespace


PdfForm.GetFieldByName Method

PdfFormGetFieldByName Method

Returns a FormField by its name. This method is fault tolerant and will attempt to match case mistakes and partial field names.

Namespace: IronPdf.Forms
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public FormField GetFieldByName(
    string FieldName
)
Public Function GetFieldByName (
    FieldName As String
) As FormField
member GetFieldByName :
        FieldName : string -> FormField

Parameters

FieldName
Type: SystemString
The name of the field to be edited. This is analogous to the HTML input 'name' attribute when creating a PDF with forms from HTML using IronPDF.

Return Value

Type: FormField
A FormField object
See Also

Reference

PdfForm Class
IronPdf.Forms Namespace


PdfForm Fields

The PdfForm type exposes the following members.

Fields
 | Name | Description
Public field | Fields | The editable fields within this PDF.
Top
See Also

Reference

PdfForm Class
IronPdf.Forms Namespace


PdfForm.Fields Field

PdfFormFields Field

The editable fields within this PDF.

Namespace: IronPdf.Forms
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public FormField[] Fields
Public Fields As FormField()
val mutable Fields: FormField[]

Field Value

Type: FormField
See Also

Reference

PdfForm Class
IronPdf.Forms Namespace
PdfDocumentForm


TextField Class

Represents an editable text input field in a PDF document.
Inheritance Hierarchy
SystemObject
IronPdf.FormsFormField
IronPdf.FormsTextField

Namespace: IronPdf.Forms
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public class TextField : FormField
Public Class TextField
    Inherits FormField
type TextField =
    class
        inherit FormField
    end

The TextField type exposes the following members.

Constructors
 | Name | Description
Public method | TextField | Initializes a new instance of the TextField class
Top
Properties
 | Name | Description
Public property | Name | Gets the ID name of this field. (Inherited from FormField.)
Public property | ReadOnly | Gets or sets the permissions for users to fill-in current form field. (Inherited from FormField.)
Public property | Value | Gets or sets the text in the text-box. (Overrides FormFieldValue.)
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | SetFont | Sets the font to the text field of pdf form. (Overrides FormFieldSetFont(FontTypes, Double).)
Public method | ToString | Returns the value of this field. (Inherited from FormField.)
Top
See Also

Reference

IronPdf.Forms Namespace
IronPdf.FormsFormField


TextField Constructor

Initializes a new instance of the TextField class

Namespace: IronPdf.Forms
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public TextField()
Public Sub New
new : unit -> TextField
See Also

Reference

TextField Class
IronPdf.Forms Namespace


TextField Properties

The TextField type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the ID name of this field. (Inherited from FormField.)
Public property | ReadOnly | Gets or sets the permissions for users to fill-in current form field. (Inherited from FormField.)
Public property | Value | Gets or sets the text in the text-box. (Overrides FormFieldValue.)
Top
See Also

Reference

TextField Class
IronPdf.Forms Namespace


TextField.Value Property

TextFieldValue Property

Gets or sets the text in the text-box.

Namespace: IronPdf.Forms
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public override string Value { get; set; }
Public Overrides Property Value As String
    Get
    Set
abstract Value : string with get, set
override Value : string with get, set

Property Value

Type: String
Text value as a string.
See Also

Reference

TextField Class
IronPdf.Forms Namespace


TextField Methods

The TextField type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | SetFont | Sets the font to the text field of pdf form. (Overrides FormFieldSetFont(FontTypes, Double).)
Public method | ToString | Returns the value of this field. (Inherited from FormField.)
Top
See Also

Reference

TextField Class
IronPdf.Forms Namespace


TextField.SetFont Method

TextFieldSetFont Method

Sets the font to the text field of pdf form.

Namespace: IronPdf.Forms
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public override void SetFont(
    FontTypes fontType,
    double fontSize = 11
)
Public Overrides Sub SetFont (
    fontType As FontTypes,
    Optional fontSize As Double = 11
)
abstract SetFont :
        fontType : FontTypes *
        ?fontSize : float
(* Defaults:
        let _fontSize = defaultArg fontSize 11
*)
-> unit
override SetFont :
        fontType : FontTypes *
        ?fontSize : float
(* Defaults:
        let _fontSize = defaultArg fontSize 11
*)
-> unit

Parameters

fontType
Type: IronPdf.Forms.EnumsFontTypes
Type of the font.
fontSize (Optional)
Type: SystemDouble
Size of the font.
See Also

Reference

TextField Class
IronPdf.Forms Namespace


IronPdf.Forms.Enums Namespace

[Missing <summary> documentation for "N:IronPdf.Forms.Enums"]

Enumerations
 | Enumeration | Description
Public enumeration | FontTypes | Enum that represents the list of available fonts for text fields.


FontTypes Enumeration

Enum that represents the list of available fonts for text fields.

Namespace: IronPdf.Forms.Enums
Assembly: IronPdf (in IronPdf.dll) Version: 2020.0.1.24570 (2020.0.1.0)
Syntax
C#
VB
F#
Copy
public enum FontTypes
Public Enumeration FontTypes
type FontTypes
Members
Member name | Value | Description
TimesRoman | 0 |
TimesBold | 1 |
TimesItalic | 2 |
TimesBoldItalic | 3 |
Helvetica | 4 |
HelveticaBold | 5 |
HelveticaOblique | 6 |
HelveticaBoldOblique | 7 |
Courier | 8 |
CourierBold | 9 |
CourierOblique | 10 |
CourierBoldOblique | 11 |
Symbol | 12 |
ZapfDingbats | 13 |
See Also

Reference

IronPdf.Forms.Enums Namespace