Keyoti.Thesaurus.Model

Thesaurus Desktop API Documentation

Keyoti.Thesaurus.Model Namespace

Contains core Thesaurus components.

Classes

Class | Description
Term | Represents a 'term' in the thesaurus, which is of type WordType (N., V., Adj., Adv., Phr.) and list of synonyms.
ThesaurusEngine | Provides access to the thesaurus.

Interfaces

Interface | Description
IThesaurusEngine | Defines interface for a Thesaurus engine.

Enumerations

Enumeration | Description
Term.TermType | Term types.

© Copyright 2004 Keyoti Inc.


IThesaurusEngine Interface

Defines interface for a Thesaurus engine.

For a list of all members of this type, see IThesaurusEngine Members.

[Visual Basic]
Public Interface IThesaurusEngine
[C#]
public interface IThesaurusEngine

Requirements

Namespace: Keyoti.Thesaurus.Model

Assembly: Keyoti.Thesaurus.Model (in Keyoti.Thesaurus.Model.dll)

See Also

IThesaurusEngine Members | Keyoti.Thesaurus.Model Namespace

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


IThesaurusEngine Members

IThesaurusEngine overview

Public Instance Methods

GetAllSynonyms | Returns list of all synonyms (words with same meaning).
GetAlphabeticalSuggestions | Returns list of words in thesaurus that are alphabetically close to word.
GetMatchingTerms | Returns list of Term objects each with their own synonyms and antonyms.
GetRelatedWords | Returns list of words that share the same stem (lemmas).
StripDescriptor | Removes the text in [ ] from word

See Also

IThesaurusEngine Interface | Keyoti.Thesaurus.Model Namespace

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


IThesaurusEngine Methods

The methods of the IThesaurusEngine interface are listed below. For a complete list of IThesaurusEngine interface members, see the IThesaurusEngine Members topic.

Public Instance Methods

GetAllSynonyms | Returns list of all synonyms (words with same meaning).
GetAlphabeticalSuggestions | Returns list of words in thesaurus that are alphabetically close to word.
GetMatchingTerms | Returns list of Term objects each with their own synonyms and antonyms.
GetRelatedWords | Returns list of words that share the same stem (lemmas).
StripDescriptor | Removes the text in [ ] from word

See Also

IThesaurusEngine Interface | Keyoti.Thesaurus.Model Namespace

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


IThesaurusEngine.GetAllSynonyms Method

Returns list of all synonyms (words with same meaning).

[Visual Basic]
Function GetAllSynonyms( _
ByVal word As String _
) As ArrayList
[C#]
ArrayList GetAllSynonyms(
string word
);

Parameters

word

Return Value

See Also

IThesaurusEngine Interface | Keyoti.Thesaurus.Model Namespace

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


IThesaurusEngine.GetAlphabeticalSuggestions Method

Returns list of words in thesaurus that are alphabetically close to word.

[Visual Basic]
Function GetAlphabeticalSuggestions( _
ByVal word As String, _
ByVal maxNumber As Integer _
) As ArrayList
[C#]
ArrayList GetAlphabeticalSuggestions(
string word,
int maxNumber
);

Parameters

word
Word to look up
maxNumber
Maximum number of suggestions to return

See Also

IThesaurusEngine Interface | Keyoti.Thesaurus.Model Namespace

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


IThesaurusEngine.GetMatchingTerms Method

Returns list of Term objects each with their own synonyms and antonyms.

[Visual Basic]
Function GetMatchingTerms( _
ByVal word As String _
) As ArrayList
[C#]
ArrayList GetMatchingTerms(
string word
);

Parameters

word

Return Value

See Also

IThesaurusEngine Interface | Keyoti.Thesaurus.Model Namespace

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


IThesaurusEngine.GetRelatedWords Method

Returns list of words that share the same stem (lemmas).

[Visual Basic]
Function GetRelatedWords( _
ByVal word As String _
) As ArrayList
[C#]
ArrayList GetRelatedWords(
string word
);

Parameters

word

Return Value

See Also

IThesaurusEngine Interface | Keyoti.Thesaurus.Model Namespace

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


IThesaurusEngine.StripDescriptor Method

Removes the text in [ ] from word

[Visual Basic]
Function StripDescriptor( _
ByVal word As String _
) As String
[C#]
string StripDescriptor(
string word
);

Parameters

word

Return Value

See Also

IThesaurusEngine Interface | Keyoti.Thesaurus.Model Namespace

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


Term Class

Represents a 'term' in the thesaurus, which is of type WordType (N., V., Adj., Adv., Phr.) and list of synonyms.

For a list of all members of this type, see Term Members.

System.Object
Term

[Visual Basic]
Public Class Term
[C#]
public class Term

Requirements

Namespace: Keyoti.Thesaurus.Model

Assembly: Keyoti.Thesaurus.Model (in Keyoti.Thesaurus.Model.dll)

See Also

Term Members | Keyoti.Thesaurus.Model Namespace

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


Term Members

Term overview

Public Instance Constructors

Term Overloaded. Initializes a new instance of the Term class.

Public Instance Properties

Synonyms | ArrayList of string synonyms (and antonyms).
Type | The type of the term.
Value | String value of this term.
WordType | The word type, N., Adj., V., Phr., Adv.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Term Class | Keyoti.Thesaurus.Model Namespace

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


Term Constructor

Creates new Term.

Overload List

Creates new Term.

public Term(string,string,ArrayList);

Creates new Term.

public Term(string,string,ArrayList,TermType);

See Also

Term Class | Keyoti.Thesaurus.Model Namespace

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


Term Constructor (String, String, ArrayList)

Creates new Term.

[Visual Basic]
Overloads Public Sub New( _
ByVal term As String, _
ByVal wordType As String, _
ByVal synonyms As ArrayList _
)
[C#]
public Term(
string term,
string wordType,
ArrayList synonyms
);

Parameters

term
The term
wordType
The type of word that this term is
synonyms
List of synonyms

See Also

Term Class | Keyoti.Thesaurus.Model Namespace | Term Constructor Overload List

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


Term Constructor (String, String, ArrayList, TermType)

Creates new Term.

[Visual Basic]
Overloads Public Sub New( _
ByVal term As String, _
ByVal wordType As String, _
ByVal synonyms As ArrayList, _
ByVal type As TermType _
)
[C#]
public Term(
string term,
string wordType,
ArrayList synonyms,
TermType type
);

Parameters

term
The term
wordType
The type of word that this term is
synonyms
List of synonyms
type
Whether this is an Antonym or a Synonym term

See Also

Term Class | Keyoti.Thesaurus.Model Namespace | Term Constructor Overload List

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


Term Properties

The properties of the Term class are listed below. For a complete list of Term class members, see the Term Members topic.

Public Instance Properties

Synonyms | ArrayList of string synonyms (and antonyms).
Type | The type of the term.
Value | String value of this term.
WordType | The word type, N., Adj., V., Phr., Adv.

See Also

Term Class | Keyoti.Thesaurus.Model Namespace

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


Term.Synonyms Property

ArrayList of string synonyms (and antonyms).

[Visual Basic]
Public ReadOnly Property Synonyms As ArrayList
[C#]
public System.Collections.ArrayList Synonyms {get;}

See Also

Term Class | Keyoti.Thesaurus.Model Namespace

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


Term.Type Property

The type of the term.

[Visual Basic]
Public Property Type As TermType
[C#]
public Term.TermType Type {get; set;}

See Also

Term Class | Keyoti.Thesaurus.Model Namespace

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


Term.Value Property

String value of this term.

[Visual Basic]
Public ReadOnly Property Value As String
[C#]
public string Value {get;}

See Also

Term Class | Keyoti.Thesaurus.Model Namespace

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


Term.WordType Property

The word type, N., Adj., V., Phr., Adv.

[Visual Basic]
Public ReadOnly Property WordType As String
[C#]
public string WordType {get;}

See Also

Term Class | Keyoti.Thesaurus.Model Namespace

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


Term.TermType Enumeration

Term types.

[Visual Basic]
Public Enum Term.TermType
[C#]
public enum Term.TermType

Members

Member Name | Description
Synonym | Similar meaning word.
Antonym | Opposite meaning word.
Undefined | Undefined.
RelatedWords | Related words (lemmas).

Requirements

Namespace: Keyoti.Thesaurus.Model

Assembly: Keyoti.Thesaurus.Model (in Keyoti.Thesaurus.Model.dll)

See Also

Keyoti.Thesaurus.Model Namespace

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


ThesaurusEngine Class

Provides access to the thesaurus.

For a list of all members of this type, see ThesaurusEngine Members.

System.Object
ThesaurusEngine

[Visual Basic]
Public Class ThesaurusEngine
Implements IThesaurusEngine, IDisposable
[C#]
public class ThesaurusEngine : IThesaurusEngine, IDisposable

Requirements

Namespace: Keyoti.Thesaurus.Model

Assembly: Keyoti.Thesaurus.Model (in Keyoti.Thesaurus.Model.dll)

See Also

ThesaurusEngine Members | Keyoti.Thesaurus.Model Namespace

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


ThesaurusEngine Members

ThesaurusEngine overview

Public Instance Constructors

ThesaurusEngine Overloaded. Initializes a new instance of the ThesaurusEngine class.

Public Instance Methods

Dispose | Overloaded. Clean up any resources being used.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAllSynonyms | Returns list of all synonyms (words with same meaning).
GetAlphabeticalSuggestions | Returns list of words in thesaurus that are alphabetically close to word.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetMatchingTerms | Returns list of Term objects each with their own synonyms and antonyms.
GetRelatedWords | Returns list of words that share the same stem (lemmas).
GetType (inherited from Object) | Gets the Type of the current instance.
StripDescriptor | Removes the text in [ ] from word
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Dispose | Overloaded. Disposes of resources.
Finalize | Frees up resources.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ThesaurusEngine Class | Keyoti.Thesaurus.Model Namespace

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


ThesaurusEngine Constructor

Creates a new thesaurus of the ThesaurusEngine, throws licensing exception if no license exists.

Overload List

Creates a new thesaurus of the ThesaurusEngine, throws licensing exception if no license exists.

public ThesaurusEngine();

Used internally.

public ThesaurusEngine(string);

See Also

ThesaurusEngine Class | Keyoti.Thesaurus.Model Namespace

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


ThesaurusEngine Constructor ()

Creates a new thesaurus of the ThesaurusEngine, throws licensing exception if no license exists.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ThesaurusEngine();

See Also

ThesaurusEngine Class | Keyoti.Thesaurus.Model Namespace | ThesaurusEngine Constructor Overload List

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


ThesaurusEngine Constructor (String)

Used internally.

[Visual Basic]
Overloads Public Sub New( _
ByVal key As String _
)
[C#]
public ThesaurusEngine(
string key
);

Parameters

key
License key

See Also

ThesaurusEngine Class | Keyoti.Thesaurus.Model Namespace | ThesaurusEngine Constructor Overload List

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


ThesaurusEngine Methods

The methods of the ThesaurusEngine class are listed below. For a complete list of ThesaurusEngine class members, see the ThesaurusEngine Members topic.

Public Instance Methods

Dispose | Overloaded. Clean up any resources being used.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAllSynonyms | Returns list of all synonyms (words with same meaning).
GetAlphabeticalSuggestions | Returns list of words in thesaurus that are alphabetically close to word.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetMatchingTerms | Returns list of Term objects each with their own synonyms and antonyms.
GetRelatedWords | Returns list of words that share the same stem (lemmas).
GetType (inherited from Object) | Gets the Type of the current instance.
StripDescriptor | Removes the text in [ ] from word
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Dispose | Overloaded. Disposes of resources.
Finalize | Frees up resources.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ThesaurusEngine Class | Keyoti.Thesaurus.Model Namespace

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


Dispose Method

Thesaurus Desktop API Documentation

ThesaurusEngine.Dispose Method

Clean up any resources being used.

Overload List

Clean up any resources being used.

public virtual void Dispose();

Disposes of resources.

protected virtual void Dispose(bool);

See Also

ThesaurusEngine Class | Keyoti.Thesaurus.Model Namespace

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


ThesaurusEngine.Dispose Method ()

Clean up any resources being used.

[Visual Basic]
Overridable Overloads Public Sub Dispose() Implements _
IDisposable.Dispose
[C#]
public virtual void Dispose();

Implements

IDisposable.Dispose

See Also

ThesaurusEngine Class | Keyoti.Thesaurus.Model Namespace | ThesaurusEngine.Dispose Overload List

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


ThesaurusEngine.Dispose Method (Boolean)

Disposes of resources.

[Visual Basic]
Overridable Overloads Protected Sub Dispose( _
ByVal disposing As Boolean _
)
[C#]
protected virtual void Dispose(
bool disposing
);

Parameters

disposing

See Also

ThesaurusEngine Class | Keyoti.Thesaurus.Model Namespace | ThesaurusEngine.Dispose Overload List

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


ThesaurusEngine.Finalize Method

Frees up resources.

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();

See Also

ThesaurusEngine Class | Keyoti.Thesaurus.Model Namespace

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


ThesaurusEngine.GetAllSynonyms Method

Returns list of all synonyms (words with same meaning).

[Visual Basic]
Overridable Public Function GetAllSynonyms( _
ByVal word As String _
) As ArrayList Implements _
IThesaurusEngine.GetAllSynonyms
[C#]
public virtual ArrayList GetAllSynonyms(
string word
);

Parameters

word

Return Value

If none are found, returns empty ArrayList.

Implements

IThesaurusEngine.GetAllSynonyms

See Also

ThesaurusEngine Class | Keyoti.Thesaurus.Model Namespace

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


ThesaurusEngine.GetAlphabeticalSuggestions Method

Returns list of words in thesaurus that are alphabetically close to word.

[Visual Basic]
Overridable Public Function GetAlphabeticalSuggestions( _
ByVal word As String, _
ByVal maxNumber As Integer _
) As ArrayList Implements _
IThesaurusEngine.GetAlphabeticalSuggestions
[C#]
public virtual ArrayList GetAlphabeticalSuggestions(
string word,
int maxNumber
);

Parameters

word
Word to look up
maxNumber
Maximum number of suggestions to return

Implements

IThesaurusEngine.GetAlphabeticalSuggestions

See Also

ThesaurusEngine Class | Keyoti.Thesaurus.Model Namespace

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


ThesaurusEngine.GetMatchingTerms Method

Returns list of Term objects each with their own synonyms and antonyms.

[Visual Basic]
Overridable Public Function GetMatchingTerms( _
ByVal word As String _
) As ArrayList Implements _
IThesaurusEngine.GetMatchingTerms
[C#]
public virtual ArrayList GetMatchingTerms(
string word
);

Parameters

word

Return Value

Implements

IThesaurusEngine.GetMatchingTerms

See Also

ThesaurusEngine Class | Keyoti.Thesaurus.Model Namespace

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


ThesaurusEngine.GetRelatedWords Method

Returns list of words that share the same stem (lemmas).

[Visual Basic]
Overridable Public Function GetRelatedWords( _
ByVal word As String _
) As ArrayList Implements _
IThesaurusEngine.GetRelatedWords
[C#]
public virtual ArrayList GetRelatedWords(
string word
);

Parameters

word

Return Value

Implements

IThesaurusEngine.GetRelatedWords

See Also

ThesaurusEngine Class | Keyoti.Thesaurus.Model Namespace

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


ThesaurusEngine.StripDescriptor Method

Removes the text in [ ] from word

[Visual Basic]
Overridable Public Function StripDescriptor( _
ByVal word As String _
) As String Implements _
IThesaurusEngine.StripDescriptor
[C#]
public virtual string StripDescriptor(
string word
);

Parameters

word

Return Value

Implements

IThesaurusEngine.StripDescriptor

See Also

ThesaurusEngine Class | Keyoti.Thesaurus.Model Namespace

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Model [1.0.0.27400]


Keyoti.Thesaurus.Windows

Thesaurus Desktop API Documentation

Keyoti.Thesaurus.Windows Namespace

Contains Windows Controls.

Classes

Class | Description
DefaultDialogFormProvider | Default DialogForm provider.
DefaultThesaurusControlProvider | Default ThesaurusControl provider, returns instance of ThesaurusControl.
Meaning | Represents a meaning in the ThesaurusControl meanings list.
RegisterForm | Internally used for registering license keys.
Thesaurus | Summary description for Thesaurus.
ThesaurusControl | User interface for thesaurus, typically hosted in a form by the Thesaurus component.
ThesaurusDialog | Form used to hold an IThesaurusControl.

Interfaces

Interface | Description
IDialogFormProvider | Defines an interface for objects which will create ThesaurusDialog objects to house IThesaurusControl.
IThesaurusableTextComponent | Defines requirements a text box must meet to work with the Thesaurus component.
IThesaurusControl | Defines the interface for a ThesaurusControl
IThesaurusControlProvider | Defines an interface for objects which will create IThesaurusControl objects.


DefaultDialogFormProvider Class

Default DialogForm provider.

For a list of all members of this type, see DefaultDialogFormProvider Members.

System.Object
DefaultDialogFormProvider

[Visual Basic]
Public Class DefaultDialogFormProvider
Implements IDialogFormProvider
[C#]
public class DefaultDialogFormProvider : IDialogFormProvider

Requirements

Namespace: Keyoti.Thesaurus.Windows

Assembly: Keyoti.Thesaurus.Windows (in Keyoti.Thesaurus.Windows.dll)

See Also

DefaultDialogFormProvider Members | Keyoti.Thesaurus.Windows Namespace

© Copyright 2004 Keyoti Inc.

Generated from assembly Keyoti.Thesaurus.Windows [1.0.0.27401]


DefaultDialogFormProvider Members

DefaultDialogFormProvider overview

Public Instance Constructors

DefaultDialogFormProvider Constructor Initializes a new instance of the DefaultDialogFormProvider class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDialogForm | Returns a ThesaurusDialog instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefaultDialogFormProvider Class | Keyoti.Thesaurus.Windows Namespace


DefaultDialogFormProvider Constructor

Initializes a new instance of the DefaultDialogFormProvider class.

[Visual Basic]
Public Sub New()
[C#]
public DefaultDialogFormProvider();

See Also

DefaultDialogFormProvider Class | Keyoti.Thesaurus.Windows Namespace


DefaultDialogFormProvider Methods

The methods of the DefaultDialogFormProvider class are listed below. For a complete list of DefaultDialogFormProvider class members, see the DefaultDialogFormProvider Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDialogForm | Returns a ThesaurusDialog instance.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefaultDialogFormProvider Class | Keyoti.Thesaurus.Windows Namespace


DefaultDialogFormProvider.GetDialogForm Method

Returns a ThesaurusDialog instance.

[Visual Basic]
Overridable Public Function GetDialogForm() As ThesaurusDialog Implements _
IDialogFormProvider.GetDialogForm
[C#]
public virtual ThesaurusDialog GetDialogForm();

Implements

IDialogFormProvider.GetDialogForm

See Also

DefaultDialogFormProvider Class | Keyoti.Thesaurus.Windows Namespace


DefaultThesaurusControlProvider Class

Default ThesaurusControl provider, returns instance of ThesaurusControl.

For a list of all members of this type, see DefaultThesaurusControlProvider Members.

System.Object
DefaultThesaurusControlProvider

[Visual Basic]
Public Class DefaultThesaurusControlProvider
Implements IThesaurusControlProvider
[C#]
public class DefaultThesaurusControlProvider : IThesaurusControlProvider

Requirements

Namespace: Keyoti.Thesaurus.Windows

Assembly: Keyoti.Thesaurus.Windows (in Keyoti.Thesaurus.Windows.dll)

See Also

DefaultThesaurusControlProvider Members | Keyoti.Thesaurus.Windows Namespace


DefaultThesaurusControlProvider Members

DefaultThesaurusControlProvider overview

Public Instance Constructors

DefaultThesaurusControlProvider Constructor Initializes a new instance of the DefaultThesaurusControlProvider class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetThesaurusControl | Returns an instance of ThesaurusControl.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefaultThesaurusControlProvider Class | Keyoti.Thesaurus.Windows Namespace


DefaultThesaurusControlProvider Constructor

Initializes a new instance of the DefaultThesaurusControlProvider class.

[Visual Basic]
Public Sub New()
[C#]
public DefaultThesaurusControlProvider();

See Also

DefaultThesaurusControlProvider Class | Keyoti.Thesaurus.Windows Namespace


DefaultThesaurusControlProvider Methods

The methods of the DefaultThesaurusControlProvider class are listed below. For a complete list of DefaultThesaurusControlProvider class members, see the DefaultThesaurusControlProvider Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetThesaurusControl | Returns an instance of ThesaurusControl.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DefaultThesaurusControlProvider Class | Keyoti.Thesaurus.Windows Namespace


DefaultThesaurusControlProvider.GetThesaurusControl Method

Returns an instance of ThesaurusControl.

[Visual Basic]
Overridable Public Function GetThesaurusControl() As IThesaurusControl Implements _
IThesaurusControlProvider.GetThesaurusControl
[C#]
public virtual IThesaurusControl GetThesaurusControl();

Implements

IThesaurusControlProvider.GetThesaurusControl

See Also

DefaultThesaurusControlProvider Class | Keyoti.Thesaurus.Windows Namespace


IDialogFormProvider Interface

Defines an interface for objects which will create ThesaurusDialog objects to house IThesaurusControl.

For a list of all members of this type, see IDialogFormProvider Members.

[Visual Basic]
Public Interface IDialogFormProvider
[C#]
public interface IDialogFormProvider

Requirements

Namespace: Keyoti.Thesaurus.Windows

Assembly: Keyoti.Thesaurus.Windows (in Keyoti.Thesaurus.Windows.dll)

See Also

IDialogFormProvider Members | Keyoti.Thesaurus.Windows Namespace


IDialogFormProvider Members

IDialogFormProvider overview

Public Instance Methods

GetDialogForm Returns a ThesaurusDialog (or subclass) instance.

See Also

IDialogFormProvider Interface | Keyoti.Thesaurus.Windows Namespace


IDialogFormProvider Methods

The methods of the IDialogFormProvider interface are listed below. For a complete list of IDialogFormProvider interface members, see the IDialogFormProvider Members topic.

Public Instance Methods

GetDialogForm Returns a ThesaurusDialog (or subclass) instance.

See Also

IDialogFormProvider Interface | Keyoti.Thesaurus.Windows Namespace


IDialogFormProvider.GetDialogForm Method

Returns a ThesaurusDialog (or subclass) instance.

[Visual Basic]
Function GetDialogForm() As ThesaurusDialog
[C#]
ThesaurusDialog GetDialogForm();

See Also

IDialogFormProvider Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusableTextComponent Interface

Defines requirements a text box must meet to work with the Thesaurus component.

For a list of all members of this type, see IThesaurusableTextComponent Members.

[Visual Basic]
Public Interface IThesaurusableTextComponent
[C#]
public interface IThesaurusableTextComponent

Requirements

Namespace: Keyoti.Thesaurus.Windows

Assembly: Keyoti.Thesaurus.Windows (in Keyoti.Thesaurus.Windows.dll)

See Also

IThesaurusableTextComponent Members | Keyoti.Thesaurus.Windows Namespace


IThesaurusableTextComponent Members

IThesaurusableTextComponent overview

Public Instance Properties

Control | Gets the Control, that the thesarus is working on.
SelectedText | Gets or sets a value indicating the currently selected text in the control.
SelectionLength | Gets or sets the number of characters selected in the text box.
SelectionStart | Gets or sets the starting point of text selected in the text box.
Text | Gets or sets the current text in the text box.

Public Instance Methods

GetCharIndexFromPoint Returns the character index of a position p

Public Instance Events

Enter | Occurs when the control receives focus.
KeyDown | Occurs when the user presses a key.
MouseDown | Occurs when the user presses a mouse button.

See Also

IThesaurusableTextComponent Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusableTextComponent Properties

The properties of the IThesaurusableTextComponent interface are listed below. For a complete list of IThesaurusableTextComponent interface members, see the IThesaurusableTextComponent Members topic.

Public Instance Properties

Control | Gets the Control, that the thesarus is working on.
SelectedText | Gets or sets a value indicating the currently selected text in the control.
SelectionLength | Gets or sets the number of characters selected in the text box.
SelectionStart | Gets or sets the starting point of text selected in the text box.
Text | Gets or sets the current text in the text box.

See Also

IThesaurusableTextComponent Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusableTextComponent.Control Property

Gets the Control, that the thesarus is working on.

[Visual Basic]
Property Control As Control
[C#]
System.Windows.Forms.Control Control {get;}

Remarks

If the class implementing this interface is a wrapper for the actual text box, this property should return the text box. If no Control exists, this can return null - however the GetSuggestionMenuItems method should not be called, when this is the case.

See Also

IThesaurusableTextComponent Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusableTextComponent.SelectedText Property

Gets or sets a value indicating the currently selected text in the control.

[Visual Basic]
Property SelectedText As String
[C#]
string SelectedText {get; set;}

See Also

IThesaurusableTextComponent Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusableTextComponent.SelectionLength Property

Gets or sets the number of characters selected in the text box.

[Visual Basic]
Property SelectionLength As Integer
[C#]
int SelectionLength {get; set;}

See Also

IThesaurusableTextComponent Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusableTextComponent.SelectionStart Property

Gets or sets the starting point of text selected in the text box.

[Visual Basic]
Property SelectionStart As Integer
[C#]
int SelectionStart {get; set;}

See Also

IThesaurusableTextComponent Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusableTextComponent.Text Property

Gets or sets the current text in the text box.

[Visual Basic]
Property Text As String
[C#]
string Text {get; set;}

See Also

IThesaurusableTextComponent Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusableTextComponent Methods

The methods of the IThesaurusableTextComponent interface are listed below. For a complete list of IThesaurusableTextComponent interface members, see the IThesaurusableTextComponent Members topic.

Public Instance Methods

GetCharIndexFromPoint Returns the character index of a position p

See Also

IThesaurusableTextComponent Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusableTextComponent.GetCharIndexFromPoint Method

Returns the character index of a position p

[Visual Basic]
Function GetCharIndexFromPoint( _
ByVal p As Point _
) As Integer
[C#]
int GetCharIndexFromPoint(
Point p
);

Parameters

p
A Point in the text box.

Return Value

The zero based character index nearest p

See Also

IThesaurusableTextComponent Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusableTextComponent Events

The events of the IThesaurusableTextComponent interface are listed below. For a complete list of IThesaurusableTextComponent interface members, see the IThesaurusableTextComponent Members topic.

Public Instance Events

Enter | Occurs when the control receives focus.
KeyDown | Occurs when the user presses a key.
MouseDown | Occurs when the user presses a mouse button.

See Also

IThesaurusableTextComponent Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusableTextComponent.Enter Event

Occurs when the control receives focus.

[Visual Basic]
Event Enter As EventHandler
[C#]
event EventHandler Enter;

See Also

IThesaurusableTextComponent Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusableTextComponent.KeyDown Event

Occurs when the user presses a key.

[Visual Basic]
Event KeyDown As KeyEventHandler
[C#]
event KeyEventHandler KeyDown;

See Also

IThesaurusableTextComponent Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusableTextComponent.MouseDown Event

Occurs when the user presses a mouse button.

[Visual Basic]
Event MouseDown As MouseEventHandler
[C#]
event MouseEventHandler MouseDown;

See Also

IThesaurusableTextComponent Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusControl Interface

Defines the interface for a ThesaurusControl

For a list of all members of this type, see IThesaurusControl Members.

[Visual Basic]
Public Interface IThesaurusControl
[C#]
public interface IThesaurusControl

Requirements

Namespace: Keyoti.Thesaurus.Windows

Assembly: Keyoti.Thesaurus.Windows (in Keyoti.Thesaurus.Windows.dll)

See Also

IThesaurusControl Members | Keyoti.Thesaurus.Windows Namespace


IThesaurusControl Members

IThesaurusControl overview

Public Instance Properties

CancelButton | Button used to close container (form).
Dock | Gets or sets which edge of the parent container a control is docked to.
IsDisposed | Whether the control has been disposed.
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LookUpButton | Button used to look up term in ReplaceTextBox.
LookUpListComboBox | Combo box showing words looked up.
MeaningsListBox | List box showing meanings for looked up word.
PreviousButton | Button used to move backwards in look up history.
ReplaceButton | Button used to replace word with synonym/antonym.
ReplaceTextBox | Text box where 'replace with' word is shown.
Size | Gets or sets the height and width of the control.
SynonymsListBox | List box showing synonyms/antonyms/related words for selected meaning.
TabIndex | Gets or sets the tab order of the control within its container.

See Also

IThesaurusControl Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusControl Properties

The properties of the IThesaurusControl interface are listed below. For a complete list of IThesaurusControl interface members, see the IThesaurusControl Members topic.

Public Instance Properties

CancelButton | Button used to close container (form).
Dock | Gets or sets which edge of the parent container a control is docked to.
IsDisposed | Whether the control has been disposed.
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LookUpButton | Button used to look up term in ReplaceTextBox.
LookUpListComboBox | Combo box showing words looked up.
MeaningsListBox | List box showing meanings for looked up word.
PreviousButton | Button used to move backwards in look up history.
ReplaceButton | Button used to replace word with synonym/antonym.
ReplaceTextBox | Text box where 'replace with' word is shown.
Size | Gets or sets the height and width of the control.
SynonymsListBox | List box showing synonyms/antonyms/related words for selected meaning.
TabIndex | Gets or sets the tab order of the control within its container.

See Also

IThesaurusControl Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusControl.CancelButton Property

Button used to close container (form).

[Visual Basic]
Property CancelButton As Button
[C#]
System.Windows.Forms.Button CancelButton {get;}

See Also

IThesaurusControl Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusControl.Dock Property

Gets or sets which edge of the parent container a control is docked to.

[Visual Basic]
Property Dock As DockStyle
[C#]
System.Windows.Forms.DockStyle Dock {get; set;}

See Also

IThesaurusControl Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusControl.IsDisposed Property

Whether the control has been disposed.

[Visual Basic]
Property IsDisposed As Boolean
[C#]
bool IsDisposed {get;}

See Also

IThesaurusControl Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusControl.Location Property

Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.

[Visual Basic]
Property Location As Point
[C#]
System.Drawing.Point Location {get; set;}

See Also

IThesaurusControl Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusControl.LookUpButton Property

Button used to look up term in ReplaceTextBox.

[Visual Basic]
Property LookUpButton As Button
[C#]
System.Windows.Forms.Button LookUpButton {get;}

See Also

IThesaurusControl Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusControl.LookUpListComboBox Property

Combo box showing words looked up.

[Visual Basic]
Property LookUpListComboBox As ComboBox
[C#]
System.Windows.Forms.ComboBox LookUpListComboBox {get;}

See Also

IThesaurusControl Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusControl.MeaningsListBox Property

List box showing meanings for looked up word.

[Visual Basic]
Property MeaningsListBox As ListBox
[C#]
System.Windows.Forms.ListBox MeaningsListBox {get;}

See Also

IThesaurusControl Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusControl.PreviousButton Property

Button used to move backwards in look up history.

[Visual Basic]
Property PreviousButton As Button
[C#]
System.Windows.Forms.Button PreviousButton {get;}

See Also

IThesaurusControl Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusControl.ReplaceButton Property

Button used to replace word with synonym/antonym.

[Visual Basic]
Property ReplaceButton As Button
[C#]
System.Windows.Forms.Button ReplaceButton {get;}

See Also

IThesaurusControl Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusControl.ReplaceTextBox Property

Text box where 'replace with' word is shown.

[Visual Basic]
Property ReplaceTextBox As TextBox
[C#]
System.Windows.Forms.TextBox ReplaceTextBox {get;}

See Also

IThesaurusControl Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusControl.Size Property

Gets or sets the height and width of the control.

[Visual Basic]
Property Size As Size
[C#]
System.Drawing.Size Size {get; set;}

See Also

IThesaurusControl Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusControl.SynonymsListBox Property

List box showing synonyms/antonyms/related words for selected meaning.

[Visual Basic]
Property SynonymsListBox As ListBox
[C#]
System.Windows.Forms.ListBox SynonymsListBox {get;}

See Also

IThesaurusControl Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusControl.TabIndex Property

Gets or sets the tab order of the control within its container.

[Visual Basic]
Property TabIndex As Integer
[C#]
int TabIndex {get; set;}

See Also

IThesaurusControl Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusControlProvider Interface

Defines an interface for objects which will create IThesaurusControl objects.

For a list of all members of this type, see IThesaurusControlProvider Members.

[Visual Basic]
Public Interface IThesaurusControlProvider
[C#]
public interface IThesaurusControlProvider

Requirements

Namespace: Keyoti.Thesaurus.Windows

Assembly: Keyoti.Thesaurus.Windows (in Keyoti.Thesaurus.Windows.dll)

See Also

IThesaurusControlProvider Members | Keyoti.Thesaurus.Windows Namespace


IThesaurusControlProvider Members

IThesaurusControlProvider overview

Public Instance Methods

GetThesaurusControl Returns an instance of an IThesaurusControl.

See Also

IThesaurusControlProvider Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusControlProvider Methods

The methods of the IThesaurusControlProvider interface are listed below. For a complete list of IThesaurusControlProvider interface members, see the IThesaurusControlProvider Members topic.

Public Instance Methods

GetThesaurusControl Returns an instance of an IThesaurusControl.

See Also

IThesaurusControlProvider Interface | Keyoti.Thesaurus.Windows Namespace


IThesaurusControlProvider.GetThesaurusControl Method

Returns an instance of an IThesaurusControl.

[Visual Basic]
Function GetThesaurusControl() As IThesaurusControl
[C#]
IThesaurusControl GetThesaurusControl();

See Also

IThesaurusControlProvider Interface | Keyoti.Thesaurus.Windows Namespace


Meaning Class

Represents a meaning in the ThesaurusControl meanings list.

For a list of all members of this type, see Meaning Members.

System.Object
Meaning

[Visual Basic]
Public Class Meaning
[C#]
public class Meaning

Requirements

Namespace: Keyoti.Thesaurus.Windows

Assembly: Keyoti.Thesaurus.Windows (in Keyoti.Thesaurus.Windows.dll)

See Also

Meaning Members | Keyoti.Thesaurus.Windows Namespace


Meaning Members

Meaning overview

Public Instance Constructors

Meaning Constructor Creates new instance

Public Instance Properties

Term Gets the Term that this is displaying

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Formats term into view friendly string.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Meaning Class | Keyoti.Thesaurus.Windows Namespace


Meaning Constructor

Creates new instance

[Visual Basic]
Public Sub New( _
ByVal t As Term _
)
[C#]
public Meaning(
Term t
);

Parameters

t
Term to show as a meaning.

See Also

Meaning Class | Keyoti.Thesaurus.Windows Namespace


Meaning Properties

The properties of the Meaning class are listed below. For a complete list of Meaning class members, see the Meaning Members topic.

Public Instance Properties

Term Gets the Term that this is displaying

See Also

Meaning Class | Keyoti.Thesaurus.Windows Namespace


Meaning.Term Property

Gets the Term that this is displaying

[Visual Basic]
Public ReadOnly Property Term As Term
[C#]
public Keyoti.Thesaurus.Model.Term Term {get;}

See Also

Meaning Class | Keyoti.Thesaurus.Windows Namespace


Meaning Methods

The methods of the Meaning class are listed below. For a complete list of Meaning class members, see the Meaning Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Formats term into view friendly string.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Meaning Class | Keyoti.Thesaurus.Windows Namespace


Meaning.ToString Method

Formats term into view friendly string.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

See Also

Meaning Class | Keyoti.Thesaurus.Windows Namespace


RegisterForm Class

Internally used for registering license keys.

For a list of all members of this type, see RegisterForm Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
RegisterForm

[Visual Basic]
Public Class RegisterForm
Inherits Form
[C#]
public class RegisterForm : Form

Requirements

Namespace: Keyoti.Thesaurus.Windows

Assembly: Keyoti.Thesaurus.Windows (in Keyoti.Thesaurus.Windows.dll)

See Also

RegisterForm Members | Keyoti.Thesaurus.Windows Namespace


RegisterForm Members

RegisterForm overview

Public Instance Constructors

RegisterForm Constructor Initializes a new instance of the RegisterForm class.

Public Instance Fields

keyTB
registerClicked

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from Form) |
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActivateMdiChild (inherited from Form) |
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) |
CenterToParent (inherited from Form) |
CenterToScreen (inherited from Form) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) |
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnActivated (inherited from Form) | Raises the Activated event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from Form) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Form) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Form) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) |
ProcessCmdKey (inherited from Form) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from Form) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Form) |
Select (inherited from Form) | Overloaded.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) |
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from Form) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

RegisterForm Class | Keyoti.Thesaurus.Windows Namespace


RegisterForm Constructor

Initializes a new instance of the RegisterForm class.

[Visual Basic]
Public Sub New()
[C#]
public RegisterForm();

See Also

RegisterForm Class | Keyoti.Thesaurus.Windows Namespace


RegisterForm Fields

The fields of the RegisterForm class are listed below. For a complete list of RegisterForm class members, see the RegisterForm Members topic.

Public Instance Fields

keyTB
registerClicked

See Also

RegisterForm Class | Keyoti.Thesaurus.Windows Namespace


RegisterForm.keyTB Field

[Visual Basic]
Public keyTB As TextBox
[C#]
public TextBox keyTB;

See Also

RegisterForm Class | Keyoti.Thesaurus.Windows Namespace


RegisterForm.registerClicked Field

[Visual Basic]
Public registerClicked As Boolean
[C#]
public bool registerClicked;

See Also

RegisterForm Class | Keyoti.Thesaurus.Windows Namespace


RegisterForm Methods

The methods of the RegisterForm class are listed below. For a complete list of RegisterForm class members, see the RegisterForm Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActivateMdiChild (inherited from Form) |
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) |
CenterToParent (inherited from Form) |
CenterToScreen (inherited from Form) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) |
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnActivated (inherited from Form) | Raises the Activated event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from Form) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Form) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Form) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) |
ProcessCmdKey (inherited from Form) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from Form) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Form) |
Select (inherited from Form) | Overloaded.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) |
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from Form) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

RegisterForm Class | Keyoti.Thesaurus.Windows Namespace


Dispose Method

Thesaurus Desktop API Documentation

RegisterForm.Dispose Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void Dispose();

Clean up any resources being used.

protected override void Dispose(bool);

See Also

RegisterForm Class | Keyoti.Thesaurus.Windows Namespace


RegisterForm.Dispose Method (Boolean)

Clean up any resources being used.

[Visual Basic]
Overrides Overloads Protected Sub Dispose( _
ByVal disposing As Boolean _
)
[C#]
protected override void Dispose(
bool disposing
);

See Also

RegisterForm Class | Keyoti.Thesaurus.Windows Namespace | RegisterForm.Dispose Overload List


Thesaurus Class

Summary description for Thesaurus.

For a list of all members of this type, see Thesaurus Members.

System.Object
MarshalByRefObject
Component
Thesaurus

[Visual Basic]
Public Class Thesaurus
Inherits Component
[C#]
public class Thesaurus : Component

Requirements

Namespace: Keyoti.Thesaurus.Windows

Assembly: Keyoti.Thesaurus.Windows (in Keyoti.Thesaurus.Windows.dll)

See Also

Thesaurus Members | Keyoti.Thesaurus.Windows Namespace


Thesaurus Members

Thesaurus overview

Public Instance Constructors

Thesaurus Overloaded. Initializes a new instance of the Thesaurus class.

Public Instance Properties

Container (inherited from Component) | Gets the IContainer that contains the Component.
DialogForm | The form containing the thesaurus control, this is created by DialogFormProvider.GetDialogForm().
DialogFormProvider | The provider of Form objects to house the ThesaurusControl in.
FocusCharacterPosition | Gets the index of the character that the user last right clicked on, pressed the Apps key on, or called the thesaurus on.
Site (inherited from Component) | Gets or sets the ISite of the Component.
TextBoxBase | A text component the thesaurus is currently running on.
TextBoxBases | The TextBoxBase (eg; TextBox etc) array that this GUI will run the thesaurus on.
ThesaurusControl | The ThesaurusControl that is currently interacting with the user. If this is not set, uses instance returned by ThesaurusControlProvider.GetThesaurusControl().
ThesaurusControlProvider | The provider of IThesaurusControl objects.
ThesaurusEngine | The thesaurus engine used to do lookups. If this is not set, uses default.
ThirdPartyTextComponent | The 3rd Party Component that this GUI will run the thesaurus over.
ThirdPartyTextComponents | The 3rd Party Component array that this GUI will run the thesaurus over.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetSuggestionMenuItems | Returns MenuItemCollection of suggestions (synonyms, antonyms or related words) if there are any, for word that was clicked on or Apps key activated on.
GetType (inherited from Object) | Gets the Type of the current instance.
GetWord | Overloaded. Returns the word that caretPosition is inside of, or immediately next to, in text; and the start index of the word.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
LookUpMeanings | Looks up meanings and displays them in the ThesaurusControl
ReplaceWord | Replaces the original word in the text box with newWord
Show | Overloaded. Shows the thesaurus dialog, non-modally, working with the word nearest the cursor.
ShowDialog | Overloaded. Shows the thesaurus dialog, modally, working with the word nearest the cursor.
ShowSynonyms | Displays synonyms/antonyms/related words for term.
ToString (inherited from Component) |

Public Instance Events

Disposed (inherited from Component) Adds an event handler to listen to the Disposed event on the component.

Protected Instance Properties

DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.

Protected Instance Methods

Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnCancelClick | Cancel button clicked
OnDialogLoad | Called when the dialog is loaded, calls LookUpMeanings.
OnLookUpClick | Looks up meanings for word in "Replace with" text box.
OnLookUpListComboBoxSelectionChanged | A meaning has been selected
OnMeaningsListBoxSelectionChanged | A meaning has been selected
OnPreviousClick | Moves back to previous term
OnReplaceClick | Replace button clicked
OnReplaceTextBoxKeyDown | Replace text box keyed down in
OnSuggestionsMenuItemClick | Listens to click events in the suggestions menu items
OnSynonymsListBoxDataSourceChanged | When synonyms list box data source changes
OnSynonymsListBoxDoubleClick | Synonyms list box double clicked.
OnSynonymsListBoxSelectedIndexChanged | When synonyms list box selection changes
OnTextComponentKeyDown | Called when key is pressed in any text box being monitored.
OnTextComponentMouseDown | Called when mouse button is pressed in any text box being monitored.

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus Constructor

Creates instance of this component.

Overload List

Creates instance of this component.

public Thesaurus();

Creates instance of this component.

public Thesaurus(IContainer);

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus Constructor (IContainer)

Creates instance of this component.

[Visual Basic]
Overloads Public Sub New( _
ByVal container As IContainer _
)
[C#]
public Thesaurus(
IContainer container
);

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace | Thesaurus Constructor Overload List


Thesaurus Constructor ()

Creates instance of this component.

[Visual Basic]
Overloads Public Sub New()
[C#]
public Thesaurus();

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace | Thesaurus Constructor Overload List


Thesaurus Properties

The properties of the Thesaurus class are listed below. For a complete list of Thesaurus class members, see the Thesaurus Members topic.

Public Instance Properties

Container (inherited from Component) | Gets the IContainer that contains the Component.
DialogForm | The form containing the thesaurus control, this is created by DialogFormProvider.GetDialogForm().
DialogFormProvider | The provider of Form objects to house the ThesaurusControl in.
FocusCharacterPosition | Gets the index of the character that the user last right clicked on, pressed the Apps key on, or called the thesaurus on.
Site (inherited from Component) | Gets or sets the ISite of the Component.
TextBoxBase | A text component the thesaurus is currently running on.
TextBoxBases | The TextBoxBase (eg; TextBox etc) array that this GUI will run the thesaurus on.
ThesaurusControl | The ThesaurusControl that is currently interacting with the user. If this is not set, uses instance returned by ThesaurusControlProvider.GetThesaurusControl().
ThesaurusControlProvider | The provider of IThesaurusControl objects.
ThesaurusEngine | The thesaurus engine used to do lookups. If this is not set, uses default.
ThirdPartyTextComponent | The 3rd Party Component that this GUI will run the thesaurus over.
ThirdPartyTextComponents | The 3rd Party Component array that this GUI will run the thesaurus over.

Protected Instance Properties

DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus.DialogForm Property

The form containing the thesaurus control, this is created by DialogFormProvider.GetDialogForm().

[Visual Basic]
Public ReadOnly Property DialogForm As ThesaurusDialog
[C#]
public ThesaurusDialog DialogForm {get;}

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus.DialogFormProvider Property

The provider of Form objects to house the ThesaurusControl in.

[Visual Basic]
Overridable Public Property DialogFormProvider As IDialogFormProvider
[C#]
public virtual IDialogFormProvider DialogFormProvider {get; set;}

Remarks

The purpose of this property is to allow developers to create their own implementations of IThesaurusControl; because this class needs to create new instances every time the form is displayed after being disposed. If this is not set, it defaults to a provider that returns DialogForm instances.

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus.FocusCharacterPosition Property

Gets the index of the character that the user last right clicked on, pressed the Apps key on, or called the thesaurus on.

[Visual Basic]
Overridable Public ReadOnly Property FocusCharacterPosition As Integer
[C#]
public virtual int FocusCharacterPosition {get;}

Remarks

Typically used when opening the thesaurus dialog from a context menu, with Show[Dialog]( FocusCharacterPosition );

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus.TextBoxBase Property

A text component the thesaurus is currently running on.

[Visual Basic]
Overridable Public Property TextBoxBase As TextBoxBase
[C#]
public virtual System.Windows.Forms.TextBoxBase TextBoxBase {get; set;}

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus.TextBoxBases Property

The TextBoxBase (eg; TextBox etc) array that this GUI will run the thesaurus on.

[Visual Basic]
Overridable Public Property TextBoxBases As TextBoxBase()
[C#]
public virtual System.Windows.Forms.TextBoxBase[] TextBoxBases {get; set;}

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus.ThesaurusControl Property

The ThesaurusControl that is currently interacting with the user. If this is not set, uses instance returned by ThesaurusControlProvider.GetThesaurusControl().

[Visual Basic]
Overridable Public Property ThesaurusControl As IThesaurusControl
[C#]
public virtual IThesaurusControl ThesaurusControl {get; set;}

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus.ThesaurusControlProvider Property

The provider of IThesaurusControl objects.

[Visual Basic]
Overridable Public Property ThesaurusControlProvider As IThesaurusControlProvider
[C#]
public virtual IThesaurusControlProvider ThesaurusControlProvider {get; set;}

Remarks

The purpose of this property is to allow developers to create their own implementations of IThesaurusControl; because this class needs to create new instances every time the form is displayed after being disposed. If this is not set, it defaults to a provider that returns Keyoti.Thesaurus.Windows.ThesaurusControl.

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus.ThesaurusEngine Property

The thesaurus engine used to do lookups. If this is not set, uses default.

[Visual Basic]
Public Property ThesaurusEngine As IThesaurusEngine
[C#]
public Keyoti.Thesaurus.Model.IThesaurusEngine ThesaurusEngine {get; set;}

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus.ThirdPartyTextComponent Property

The 3rd Party Component that this GUI will run the thesaurus over.

[Visual Basic]
Overridable Public Property ThirdPartyTextComponent As IThesaurusableTextComponent
[C#]
public virtual IThesaurusableTextComponent ThirdPartyTextComponent {get; set;}

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus.ThirdPartyTextComponents Property

The 3rd Party Component array that this GUI will run the thesaurus over.

[Visual Basic]
Overridable Public Property ThirdPartyTextComponents As IThesaurusableTextComponent()
[C#]
public virtual IThesaurusableTextComponent[] ThirdPartyTextComponents {get; set;}

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus Methods

The methods of the Thesaurus class are listed below. For a complete list of Thesaurus class members, see the Thesaurus Members topic.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetSuggestionMenuItems | Returns MenuItemCollection of suggestions (synonyms, antonyms or related words) if there are any, for word that was clicked on or Apps key activated on.
GetType (inherited from Object) | Gets the Type of the current instance.
GetWord | Overloaded. Returns the word that caretPosition is inside of, or immediately next to, in text; and the start index of the word.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
LookUpMeanings | Looks up meanings and displays them in the ThesaurusControl
ReplaceWord | Replaces the original word in the text box with newWord
Show | Overloaded. Shows the thesaurus dialog, non-modally, working with the word nearest the cursor.
ShowDialog | Overloaded. Shows the thesaurus dialog, modally, working with the word nearest the cursor.
ShowSynonyms | Displays synonyms/antonyms/related words for term.
ToString (inherited from Component) |

Protected Instance Methods

Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnCancelClick | Cancel button clicked
OnDialogLoad | Called when the dialog is loaded, calls LookUpMeanings.
OnLookUpClick | Looks up meanings for word in "Replace with" text box.
OnLookUpListComboBoxSelectionChanged | A meaning has been selected
OnMeaningsListBoxSelectionChanged | A meaning has been selected
OnPreviousClick | Moves back to previous term
OnReplaceClick | Replace button clicked
OnReplaceTextBoxKeyDown | Replace text box keyed down in
OnSuggestionsMenuItemClick | Listens to click events in the suggestions menu items
OnSynonymsListBoxDataSourceChanged | When synonyms list box data source changes
OnSynonymsListBoxDoubleClick | Synonyms list box double clicked.
OnSynonymsListBoxSelectedIndexChanged | When synonyms list box selection changes
OnTextComponentKeyDown | Called when key is pressed in any text box being monitored.
OnTextComponentMouseDown | Called when mouse button is pressed in any text box being monitored.

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Dispose Method

Thesaurus Desktop API Documentation

Thesaurus.Dispose Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void Dispose();

Clean up any resources being used.

protected override void Dispose(bool);

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus.Dispose Method (Boolean)

Clean up any resources being used.

[Visual Basic]
Overrides Overloads Protected Sub Dispose( _
ByVal disposing As Boolean _
)
[C#]
protected override void Dispose(
bool disposing
);

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace | Thesaurus.Dispose Overload List


Thesaurus.GetSuggestionMenuItems Method

Returns MenuItemCollection of suggestions (synonyms, antonyms or related words) if there are any, for word that was clicked on or Apps key activated on.

[Visual Basic]
Overridable Public Function GetSuggestionMenuItems() As MenuItem()
[C#]
public virtual MenuItem[] GetSuggestionMenuItems();

Return Value

Any suggestions found, or null if none were found.

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


GetWord Method

Thesaurus Desktop API Documentation

Thesaurus.GetWord Method

Returns the word that caretPosition is inside of, or immediately next to, in text; and the start index of the word.

Overload List

Returns the word that caretPosition is inside of, or immediately next to, in text; and the start index of the word.

public virtual object[] GetWord(int,int,string);

Returns the word that caretPosition is inside of, or immediately next to, in text; and the start index of the word.

public virtual object[] GetWord(int,string);

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus.GetWord Method (Int32, Int32, String)

Returns the word that caretPosition is inside of, or immediately next to, in text; and the start index of the word.

[Visual Basic]
Overridable Overloads Public Function GetWord( _
ByVal caretPosition As Integer, _
ByVal selectionLength As Integer, _
ByVal text As String _
) As Object()
[C#]
public virtual object[] GetWord(
int caretPosition,
int selectionLength,
string text
);

Return Value

object[0] = (string) theWord object[1] = (int) startPos

Remarks

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace | Thesaurus.GetWord Overload List


Thesaurus.GetWord Method (Int32, String)

Returns the word that caretPosition is inside of, or immediately next to, in text; and the start index of the word.

[Visual Basic]
Overridable Overloads Public Function GetWord( _
ByVal caretPosition As Integer, _
ByVal text As String _
) As Object()
[C#]
public virtual object[] GetWord(
int caretPosition,
string text
);

Return Value

object[0] = (string) theWord object[1] = (int) startPos

Remarks

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace | Thesaurus.GetWord Overload List


Thesaurus.LookUpMeanings Method

Looks up meanings and displays them in the ThesaurusControl

[Visual Basic]
Overridable Public Sub LookUpMeanings( _
ByVal word As String _
)
[C#]
public virtual void LookUpMeanings(
string word
);

Parameters

word

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus.OnCancelClick Method

Cancel button clicked

[Visual Basic]
Overridable Protected Sub OnCancelClick( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
[C#]
protected virtual void OnCancelClick(
object sender,
EventArgs e
);

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus.OnDialogLoad Method

Called when the dialog is loaded, calls LookUpMeanings.

[Visual Basic]
Overridable Protected Sub OnDialogLoad( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
[C#]
protected virtual void OnDialogLoad(
object sender,
EventArgs e
);

Parameters

sender
e

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus.OnLookUpClick Method

Looks up meanings for word in "Replace with" text box.

[Visual Basic]
Overridable Protected Sub OnLookUpClick( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
[C#]
protected virtual void OnLookUpClick(
object sender,
EventArgs e
);

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus.OnLookUpListComboBoxSelectionChanged Method

A meaning has been selected

[Visual Basic]
Overridable Protected Sub OnLookUpListComboBoxSelectionChanged( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
[C#]
protected virtual void OnLookUpListComboBoxSelectionChanged(
object sender,
EventArgs e
);

Parameters

sender
e

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus.OnMeaningsListBoxSelectionChanged Method

A meaning has been selected

[Visual Basic]
Overridable Protected Sub OnMeaningsListBoxSelectionChanged( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
[C#]
protected virtual void OnMeaningsListBoxSelectionChanged(
object sender,
EventArgs e
);

Parameters

sender
e

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus.OnPreviousClick Method

Moves back to previous term

[Visual Basic]
Overridable Protected Sub OnPreviousClick( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
[C#]
protected virtual void OnPreviousClick(
object sender,
EventArgs e
);

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus.OnReplaceClick Method

Replace button clicked

[Visual Basic]
Overridable Protected Sub OnReplaceClick( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
[C#]
protected virtual void OnReplaceClick(
object sender,
EventArgs e
);

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus.OnReplaceTextBoxKeyDown Method

Replace text box keyed down in

[Visual Basic]
Overridable Protected Sub OnReplaceTextBoxKeyDown( _
ByVal sender As Object, _
ByVal e As KeyEventArgs _
)
[C#]
protected virtual void OnReplaceTextBoxKeyDown(
object sender,
KeyEventArgs e
);

Remarks

Default behaviour is to look up the word entered when 'Enter' is pressed.

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus.OnSuggestionsMenuItemClick Method

Listens to click events in the suggestions menu items

[Visual Basic]
Overridable Protected Sub OnSuggestionsMenuItemClick( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
[C#]
protected virtual void OnSuggestionsMenuItemClick(
object sender,
EventArgs e
);

Parameters

sender
e

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus.OnSynonymsListBoxDataSourceChanged Method

When synonyms list box data source changes

[Visual Basic]
Overridable Protected Sub OnSynonymsListBoxDataSourceChanged( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
[C#]
protected virtual void OnSynonymsListBoxDataSourceChanged(
object sender,
EventArgs e
);

Parameters

sender
e

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus.OnSynonymsListBoxDoubleClick Method

Synonyms list box double clicked.

[Visual Basic]
Overridable Protected Sub OnSynonymsListBoxDoubleClick( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
[C#]
protected virtual void OnSynonymsListBoxDoubleClick(
object sender,
EventArgs e
);

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus.OnSynonymsListBoxSelectedIndexChanged Method

When synonyms list box selection changes

[Visual Basic]
Overridable Protected Sub OnSynonymsListBoxSelectedIndexChanged( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
[C#]
protected virtual void OnSynonymsListBoxSelectedIndexChanged(
object sender,
EventArgs e
);

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus.OnTextComponentKeyDown Method

Called when key is pressed in any text box being monitored.

[Visual Basic]
Overridable Protected Sub OnTextComponentKeyDown( _
ByVal sender As Object, _
ByVal e As KeyEventArgs _
)
[C#]
protected virtual void OnTextComponentKeyDown(
object sender,
KeyEventArgs e
);

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus.OnTextComponentMouseDown Method

Called when mouse button is pressed in any text box being monitored.

[Visual Basic]
Overridable Protected Sub OnTextComponentMouseDown( _
ByVal sender As Object, _
ByVal e As MouseEventArgs _
)
[C#]
protected virtual void OnTextComponentMouseDown(
object sender,
MouseEventArgs e
);

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus.ReplaceWord Method

Replaces the original word in the text box with newWord

[Visual Basic]
Overridable Public Sub ReplaceWord( _
ByVal existingWordStart As Integer, _
ByVal existingWord As String, _
ByVal newWord As String _
)
[C#]
public virtual void ReplaceWord(
int existingWordStart,
string existingWord,
string newWord
);

Parameters

existingWordStart
Character index of original word
existingWord
Original word in text box
newWord
New word to replace old word with

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Show Method

Thesaurus Desktop API Documentation

Thesaurus.Show Method

Shows the thesaurus dialog, non-modally, working with the word nearest the cursor.

Overload List

Shows the thesaurus dialog, non-modally, working with the word nearest the cursor.

public virtual void Show();

Shows the thesaurus dialog, non-modally, working with the word nearest wordAtPosition.

public virtual void Show(int);

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus.Show Method ()

Shows the thesaurus dialog, non-modally, working with the word nearest the cursor.

[Visual Basic]
Overridable Overloads Public Sub Show()
[C#]
public virtual void Show();

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace | Thesaurus.Show Overload List


Thesaurus.Show Method (Int32)

Shows the thesaurus dialog, non-modally, working with the word nearest wordAtPosition.

[Visual Basic]
Overridable Overloads Public Sub Show( _
ByVal wordAtPosition As Integer _
)
[C#]
public virtual void Show(
int wordAtPosition
);

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace | Thesaurus.Show Overload List


ShowDialog Method

Thesaurus Desktop API Documentation

Thesaurus.ShowDialog Method

Shows the thesaurus dialog, modally, working with the word nearest the cursor.

Overload List

Shows the thesaurus dialog, modally, working with the word nearest the cursor.

public virtual void ShowDialog();

Shows the thesaurus dialog, modally, working with the word nearest wordAtPosition.

public virtual void ShowDialog(int);

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


Thesaurus.ShowDialog Method ()

Shows the thesaurus dialog, modally, working with the word nearest the cursor.

[Visual Basic]
Overridable Overloads Public Sub ShowDialog()
[C#]
public virtual void ShowDialog();

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace | Thesaurus.ShowDialog Overload List


Thesaurus.ShowDialog Method (Int32)

Shows the thesaurus dialog, modally, working with the word nearest wordAtPosition.

[Visual Basic]
Overridable Overloads Public Sub ShowDialog( _
ByVal wordAtPosition As Integer _
)
[C#]
public virtual void ShowDialog(
int wordAtPosition
);

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace | Thesaurus.ShowDialog Overload List


Thesaurus.ShowSynonyms Method

Displays synonyms/antonyms/related words for term.

[Visual Basic]
Overridable Public Sub ShowSynonyms( _
ByVal term As Term _
)
[C#]
public virtual void ShowSynonyms(
Term term
);

See Also

Thesaurus Class | Keyoti.Thesaurus.Windows Namespace


ThesaurusControl Class

User interface for thesaurus, typically hosted in a form by the Thesaurus component.

For a list of all members of this type, see ThesaurusControl Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
ThesaurusControl

[Visual Basic]
Public Class ThesaurusControl
Inherits UserControl
Implements IThesaurusControl
[C#]
public class ThesaurusControl : UserControl, IThesaurusControl

Remarks

In order to use this user control with the Thesaurus component, it must implement the IThesaurusControl interface.

Requirements

Namespace: Keyoti.Thesaurus.Windows

Assembly: Keyoti.Thesaurus.Windows (in Keyoti.Thesaurus.Windows.dll)

See Also

ThesaurusControl Members | Keyoti.Thesaurus.Windows Namespace


ThesaurusControl Members

ThesaurusControl overview

Public Instance Constructors

ThesaurusControl Constructor Creates new instance of this user control.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton | Button used to close container (form).
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LookUpButton | Button used to look up term in ReplaceTextBox.
LookUpListComboBox | Combo box showing words looked up.
MeaningsListBox | List box showing meanings for looked up word.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreviousButton | Button used to move backwards in look up history.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
ReplaceButton | Button used to replace word with synonym/antonym.
ReplaceTextBox | Text box where 'replace with' word is shown.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
SynonymsListBox | List box showing synonyms/antonyms/related words for selected meaning.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from UserControl) | Occurs before the control becomes visible for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from UserControl) |
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

ThesaurusControl Class | Keyoti.Thesaurus.Windows Namespace


ThesaurusControl Constructor

Creates new instance of this user control.

[Visual Basic]
Public Sub New()
[C#]
public ThesaurusControl();

See Also

ThesaurusControl Class | Keyoti.Thesaurus.Windows Namespace


ThesaurusControl Properties

The properties of the ThesaurusControl class are listed below. For a complete list of ThesaurusControl class members, see the ThesaurusControl Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton | Button used to close container (form).
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LookUpButton | Button used to look up term in ReplaceTextBox.
LookUpListComboBox | Combo box showing words looked up.
MeaningsListBox | List box showing meanings for looked up word.
Name (inherited from Control) | Gets or sets the name of the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
PreviousButton | Button used to move backwards in look up history.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
ReplaceButton | Button used to replace word with synonym/antonym.
ReplaceTextBox | Text box where 'replace with' word is shown.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
SynonymsListBox | List box showing synonyms/antonyms/related words for selected meaning.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from UserControl) |
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from ContainerControl) |
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from UserControl) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

ThesaurusControl Class | Keyoti.Thesaurus.Windows Namespace


ThesaurusControl.CancelButton Property

Button used to close container (form).

[Visual Basic]
NotOverridable Public ReadOnly Property CancelButton As Button Implements _
IThesaurusControl.CancelButton
[C#]
public System.Windows.Forms.Button CancelButton {get;}

Implements

IThesaurusControl.CancelButton

See Also

ThesaurusControl Class | Keyoti.Thesaurus.Windows Namespace


ThesaurusControl.LookUpButton Property

Button used to look up term in ReplaceTextBox.

[Visual Basic]
NotOverridable Public ReadOnly Property LookUpButton As Button Implements _
IThesaurusControl.LookUpButton
[C#]
public System.Windows.Forms.Button LookUpButton {get;}

Implements

IThesaurusControl.LookUpButton

See Also

ThesaurusControl Class | Keyoti.Thesaurus.Windows Namespace


ThesaurusControl.LookUpListComboBox Property

Combo box showing words looked up.

[Visual Basic]
NotOverridable Public ReadOnly Property LookUpListComboBox As ComboBox Implements _
IThesaurusControl.LookUpListComboBox
[C#]
public System.Windows.Forms.ComboBox LookUpListComboBox {get;}

Implements

IThesaurusControl.LookUpListComboBox

See Also

ThesaurusControl Class | Keyoti.Thesaurus.Windows Namespace


ThesaurusControl.MeaningsListBox Property

List box showing meanings for looked up word.

[Visual Basic]
NotOverridable Public ReadOnly Property MeaningsListBox As ListBox Implements _
IThesaurusControl.MeaningsListBox
[C#]
public System.Windows.Forms.ListBox MeaningsListBox {get;}

Implements

IThesaurusControl.MeaningsListBox

See Also

ThesaurusControl Class | Keyoti.Thesaurus.Windows Namespace


ThesaurusControl.PreviousButton Property

Button used to move backwards in look up history.

[Visual Basic]
NotOverridable Public ReadOnly Property PreviousButton As Button Implements _
IThesaurusControl.PreviousButton
[C#]
public System.Windows.Forms.Button PreviousButton {get;}

Implements

IThesaurusControl.PreviousButton

See Also

ThesaurusControl Class | Keyoti.Thesaurus.Windows Namespace


ThesaurusControl.ReplaceButton Property

Button used to replace word with synonym/antonym.

[Visual Basic]
NotOverridable Public ReadOnly Property ReplaceButton As Button Implements _
IThesaurusControl.ReplaceButton
[C#]
public System.Windows.Forms.Button ReplaceButton {get;}

Implements

IThesaurusControl.ReplaceButton

See Also

ThesaurusControl Class | Keyoti.Thesaurus.Windows Namespace


ThesaurusControl.ReplaceTextBox Property

Text box where 'replace with' word is shown.

[Visual Basic]
NotOverridable Public ReadOnly Property ReplaceTextBox As TextBox Implements _
IThesaurusControl.ReplaceTextBox
[C#]
public System.Windows.Forms.TextBox ReplaceTextBox {get;}

Implements

IThesaurusControl.ReplaceTextBox

See Also

ThesaurusControl Class | Keyoti.Thesaurus.Windows Namespace


ThesaurusControl.SynonymsListBox Property

List box showing synonyms/antonyms/related words for selected meaning.

[Visual Basic]
NotOverridable Public ReadOnly Property SynonymsListBox As ListBox Implements _
IThesaurusControl.SynonymsListBox
[C#]
public System.Windows.Forms.ListBox SynonymsListBox {get;}

Implements

IThesaurusControl.SynonymsListBox

See Also

ThesaurusControl Class | Keyoti.Thesaurus.Windows Namespace


ThesaurusControl Methods

The methods of the ThesaurusControl class are listed below. For a complete list of ThesaurusControl class members, see the ThesaurusControl Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Component) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
AdjustFormScrollbars (inherited from ContainerControl) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) | Sends the specified message to the default window procedure.
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from UserControl) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Control) | Raises the FontChangedevent.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Control) | Raises the HandleCreated event.
OnHandleDestroyed (inherited from Control) | Raises the HandleDestroyed event.
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from UserControl) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMouseDown (inherited from UserControl) |
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Control) | Raises the Resize event.
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) | Processes a command key.
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from ContainerControl) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Control) | Previews a keyboard message.
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from ContainerControl) | Selects the next available control and makes it the active control.
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from ScrollableControl) |
Select (inherited from ContainerControl) | Overloaded.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from ContainerControl) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from UserControl) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

ThesaurusControl Class | Keyoti.Thesaurus.Windows Namespace


Dispose Method

Thesaurus Desktop API Documentation

ThesaurusControl.Dispose Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void Dispose();

Clean up any resources being used.

protected override void Dispose(bool);

See Also

ThesaurusControl Class | Keyoti.Thesaurus.Windows Namespace


ThesaurusControl.Dispose Method (Boolean)

Clean up any resources being used.

[Visual Basic]
Overrides Overloads Protected Sub Dispose( _
ByVal disposing As Boolean _
)
[C#]
protected override void Dispose(
bool disposing
);

See Also

ThesaurusControl Class | Keyoti.Thesaurus.Windows Namespace | ThesaurusControl.Dispose Overload List


ThesaurusDialog Class

Form used to hold an IThesaurusControl.

For a list of all members of this type, see ThesaurusDialog Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
ThesaurusDialog

[Visual Basic]
Public Class ThesaurusDialog
Inherits Form
[C#]
public class ThesaurusDialog : Form

Requirements

Namespace: Keyoti.Thesaurus.Windows

Assembly: Keyoti.Thesaurus.Windows (in Keyoti.Thesaurus.Windows.dll)

See Also

ThesaurusDialog Members | Keyoti.Thesaurus.Windows Namespace


ThesaurusDialog Members

ThesaurusDialog overview

Public Instance Constructors

ThesaurusDialog Constructor Creates the form.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
ThesaurusControl | The thesaurus control to show.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Public Instance Events

Activated (inherited from Form) | Occurs when the form is activated in code or by the user.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
Closed (inherited from Form) | Occurs when the form is closed.
Closing (inherited from Form) | Occurs when the form is closing.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection .
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection .
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Deactivate (inherited from Form) | Occurs when the form loses focus and is not the active form.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
InputLanguageChanged (inherited from Form) | Occurs after the input language of the form has changed.
InputLanguageChanging (inherited from Form) | Occurs when the user attempts to change the input language for the form.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Occurs when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Occurs when a key is released while the control has focus.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
Load (inherited from Form) | Occurs before a form is displayed for the first time.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MaximizedBoundsChanged (inherited from Form) | Occurs when the value of the MaximizedBounds property has changed.
MaximumSizeChanged (inherited from Form) | Occurs when the value of the MaximumSize property has changed.
MdiChildActivate (inherited from Form) | Occurs when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MenuComplete (inherited from Form) | Occurs when the menu of a form loses focus.
MenuStart (inherited from Form) | Occurs when the menu of a form receives focus.
MinimumSizeChanged (inherited from Form) | Occurs when the value of the MinimumSize property has changed.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and allows the drag source to determine whether the drag-and-drop operation should be canceled.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Form) |
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Control) | Occurs when the Text property value changes.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CreateParams (inherited from Form) |
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActivateMdiChild (inherited from Form) |
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) |
CenterToParent (inherited from Form) |
CenterToScreen (inherited from Form) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) |
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnActivated (inherited from Form) | Raises the Activated event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from Form) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Form) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Form) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) |
ProcessCmdKey (inherited from Form) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from Form) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Form) |
Select (inherited from Form) | Overloaded.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) |
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from Form) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

ThesaurusDialog Class | Keyoti.Thesaurus.Windows Namespace


ThesaurusDialog Constructor

Creates the form.

[Visual Basic]
Public Sub New()
[C#]
public ThesaurusDialog();

See Also

ThesaurusDialog Class | Keyoti.Thesaurus.Windows Namespace


ThesaurusDialog Properties

The properties of the ThesaurusDialog class are listed below. For a complete list of ThesaurusDialog class members, see the ThesaurusDialog Members topic.

Public Instance Properties

AcceptButton (inherited from Form) | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveMdiChild (inherited from Form) | Gets the currently active multiple document interface (MDI) child window.
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
AllowTransparency (inherited from Form) |
Anchor (inherited from Control) | Gets or sets which edges of the control are anchored to the edges of its container.
AutoScale (inherited from Form) | Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls.
AutoScaleBaseSize (inherited from Form) | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from Form) | Gets or sets a value indicating whether the form enables autoscrolling.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
BackColor (inherited from Form) |
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BindingContext (inherited from ContainerControl) |
Bottom (inherited from Control) | Gets the distance between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements.
CancelButton (inherited from Form) | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Form) | Gets or sets the size of the client area of the form.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ControlBox (inherited from Form) | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DesktopBounds (inherited from Form) | Gets or sets the size and location of the form on the Windows desktop.
DesktopLocation (inherited from Form) | Gets or sets the location of the form on the Windows desktop.
DialogResult (inherited from Form) | Gets or sets the dialog result for the form.
DisplayRectangle (inherited from ScrollableControl) |
Disposing (inherited from Control) | Gets a value indicating whether the control is in the process of being disposed of.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle (inherited from Form) | Gets or sets the border style of the form.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HelpButton (inherited from Form) | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form.
Icon (inherited from Form) | Gets or sets the icon for the form.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMdiChild (inherited from Form) | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer (inherited from Form) | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
IsRestrictedWindow (inherited from Form) |
KeyPreview (inherited from Form) | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
MaximizeBox (inherited from Form) | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MaximumSize (inherited from Form) | Gets the maximum size the form can be resized to.
MdiChildren (inherited from Form) | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent (inherited from Form) | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu (inherited from Form) | Gets or sets the MainMenu that is displayed in the form.
MergedMenu (inherited from Form) | Gets the merged menu for the form.
MinimizeBox (inherited from Form) | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MinimumSize (inherited from Form) | Gets or sets the minimum size the form can be resized to.
Modal (inherited from Form) | Gets a value indicating whether this form is displayed modally.
Name (inherited from Control) | Gets or sets the name of the control.
Opacity (inherited from Form) | Gets or sets the opacity level of the form.
OwnedForms (inherited from Form) | Gets an array of Form objects that represent all forms that are owned by this form.
Owner (inherited from Form) | Gets or sets the form that owns this form.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ParentForm (inherited from ContainerControl) | Gets the form that the container control is assigned to.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
ShowInTaskbar (inherited from Form) | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Form) | Gets or sets the size of the form.
SizeGripStyle (inherited from Form) | Gets or sets the style of the size grip to display in the lower-right corner of the form.
StartPosition (inherited from Form) | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Form) |
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
ThesaurusControl | The thesaurus control to show.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevel (inherited from Form) | Gets or sets a value indicating whether to display the form as a top-level window.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost (inherited from Form) | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey (inherited from Form) | Gets or sets the color that will represent transparent areas of the form.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState (inherited from Form) | Gets or sets the form's window state.
WindowTarget (inherited from Control) |

Protected Instance Properties

CreateParams (inherited from Form) |
DefaultImeMode (inherited from Form) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultSize (inherited from Form) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
MaximizedBounds (inherited from Form) | Gets and sets the size of the form when it is maximized.
RenderRightToLeft (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the control should display keyboard shortcuts.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

See Also

ThesaurusDialog Class | Keyoti.Thesaurus.Windows Namespace


ThesaurusDialog.ThesaurusControl Property

The thesaurus control to show.

[Visual Basic]
Public Property ThesaurusControl As IThesaurusControl
[C#]
public IThesaurusControl ThesaurusControl {get; set;}

See Also

ThesaurusDialog Class | Keyoti.Thesaurus.Windows Namespace


ThesaurusDialog Methods

The methods of the ThesaurusDialog class are listed below. For a complete list of ThesaurusDialog class members, see the ThesaurusDialog Members topic.

Public Instance Methods

Activate (inherited from Form) | Activates the form and gives it focus.
AddOwnedForm (inherited from Form) | Adds an owned form to this form.
BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close (inherited from Form) | Closes the form.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult object passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.
LayoutMdi (inherited from Form) | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessMessage (inherited from Control) | Preprocesses input messages within the message loop before they are dispatched.
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RemoveOwnedForm (inherited from Form) | Removes an owned form from this form.
ResetBackColor (inherited from Control) | Resets the BackColor property to its default value.
ResetBindings (inherited from Control) | Resets the DataBindings property to its default value.
ResetCursor (inherited from Control) | Resets the Cursor property to its default value.
ResetFont (inherited from Control) | Resets the Fontproperty to its default value.
ResetForeColor (inherited from Control) | Resets the ForeColor property to its default value.
ResetImeMode (inherited from Control) | Resets the ImeMode property to its default value.
ResetRightToLeft (inherited from Control) | Resets the RightToLeft property to its default value.
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes normal layout logic.
Scale (inherited from Control) | Overloaded. Scales the control and any child controls to the specified ratio.
ScrollControlIntoView (inherited from ScrollableControl) |
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
SetDesktopBounds (inherited from Form) | Sets the bounds of the form in desktop coordinates.
SetDesktopLocation (inherited from Form) | Sets the location of the form in desktop coordinates.
Show (inherited from Control) | Displays the control to the user.
ShowDialog (inherited from Form) | Overloaded. Shows the form as a modal dialog box with no owner window.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Form) |
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.
Validate (inherited from ContainerControl) | Validates the last invalidated control and its ancestors up through, but not including, the current control.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ActivateMdiChild (inherited from Form) |
AdjustFormScrollbars (inherited from Form) |
ApplyAutoScaling (inherited from Form) |
CenterToParent (inherited from Form) |
CenterToScreen (inherited from Form) |
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Form) |
CreateHandle (inherited from Form) |
DefWndProc (inherited from Form) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose | Overloaded. Clean up any resources being used.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetScrollState (inherited from ScrollableControl) |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) |
OnActivated (inherited from Form) | Raises the Activated event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChangedevent.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChangedevent.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClosed (inherited from Form) | Raises the Closed event.
OnClosing (inherited from Form) | Raises the Closing event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChangedevent.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from ContainerControl) |
OnCreateControl (inherited from Form) |
OnCursorChanged (inherited from Control) | Raises the CursorChangedevent.
OnDeactivate (inherited from Form) | Raises the Deactivate event.
OnDockChanged (inherited from Control) | Raises the DockChangedevent.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFontChanged (inherited from Form) |
OnForeColorChanged (inherited from Control) | Raises the ForeColorChangedevent.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated (inherited from Form) |
OnHandleDestroyed (inherited from Form) |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInputLanguageChanged (inherited from Form) | Raises the InputLanguageChanged event.
OnInputLanguageChanging (inherited from Form) | Raises the InputLanguageChanging event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLoad (inherited from Form) | Raises the Load event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMaximizedBoundsChanged (inherited from Form) | Raises the MaximizedBoundsChanged event.
OnMaximumSizeChanged (inherited from Form) | Raises the MaximumSizeChanged event.
OnMdiChildActivate (inherited from Form) | Raises the MdiChildActivate event.
OnMenuComplete (inherited from Form) | Raises the MenuComplete event.
OnMenuStart (inherited from Form) | Raises the MenuStart event.
OnMinimumSizeChanged (inherited from Form) | Raises the MinimumSizeChanged event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) |
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaint (inherited from Form) |
OnPaintBackground (inherited from Control) | Paints the background of the control.
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnResize (inherited from Form) |
OnRightToLeftChanged (inherited from Control) | Raises the RightToLeftChangedevent.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Form) |
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Form) |
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from Form) |
ProcessCmdKey (inherited from Form) |
ProcessDialogChar (inherited from ContainerControl) |
ProcessDialogKey (inherited from Form) |
ProcessKeyEventArgs (inherited from Control) | Processes a key message and generates the appropriate control events.
ProcessKeyPreview (inherited from Form) |
ProcessMnemonic (inherited from ContainerControl) |
ProcessTabKey (inherited from Form) |
RaiseDragEvent (inherited from Control) |
RaiseKeyEvent (inherited from Control) |
RaiseMouseEvent (inherited from Control) |
RaisePaintEvent (inherited from Control) |
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) |
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleCore (inherited from Form) |
Select (inherited from Form) | Overloaded.
SetBoundsCore (inherited from Form) |
SetClientSizeCore (inherited from Form) |
SetDisplayRectLocation (inherited from ScrollableControl) |
SetScrollState (inherited from ScrollableControl) |
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Form) |
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.
UpdateDefaultButton (inherited from Form) |
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from Form) |

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Processes a keyboard message.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl)

See Also

ThesaurusDialog Class | Keyoti.Thesaurus.Windows Namespace


Dispose Method

Thesaurus Desktop API Documentation

ThesaurusDialog.Dispose Method

Clean up any resources being used.

Overload List

Inherited from Component.

public void Dispose();

Clean up any resources being used.

protected override void Dispose(bool);

See Also

ThesaurusDialog Class | Keyoti.Thesaurus.Windows Namespace


ThesaurusDialog.Dispose Method (Boolean)

Clean up any resources being used.

[Visual Basic]
Overrides Overloads Protected Sub Dispose( _
ByVal disposing As Boolean _
)
[C#]
protected override void Dispose(
bool disposing
);

See Also

ThesaurusDialog Class | Keyoti.Thesaurus.Windows Namespace | ThesaurusDialog.Dispose Overload List