RapidSpell Silverlight Documentation: Terms & Conditions

Terms & Conditions

If you do not agree to these terms and conditions then you may not install, use, or distribute RapidSpell Silverlight.
1. License and Ownership. RapidSpell Silverlight is a licensed software product. RapidSpell Silverlight, including its accompanying files and documentation, is owned and copyrighted by Keyoti Inc., © Copyright 2002-2010, all rights reserved. Keyoti Inc. grants the user in possession of an official receipt of purchase a nonexclusive license to download and use the software, for any lawful commercial or noncommercial purposes provided the terms of this agreement are met.
2. Distribution. If you purchased an Individual License Version of RapidSpell Silverlight, you may copy and use the RapidSpell Silverlight distribution file (.zip) on any systems you use but for your individual use only. Individual use is defined as one person having the ability to read or copy any of the files originally contained in the RapidSpell Silverlight distribution file including (but not limited to) the .dll, .cs, .vb, .html, .gif, .jpg, .bat, and .txt files. You must take appropriate safeguards to protect this product from unauthorized access by others.
If you purchased a Site License Version of RapidSpell Silverlight, then you may provide copies of the RapidSpell Silverlight distribution file (.zip) to anyone employed by your company whose primary work address is within a 100 mile (160 km) radius of your primary work address. These individuals then have license rights and responsibilities equivalent to the Individual License Version. In all cases the copies of the RapidSpell Silverlight distribution file (.zip) must be unaltered and complete, including this license agreement and all copyright notices. You may not reverse engineer, disassemble, decompile, or modify this software or its accompanying documentation in any way.
You may reproduce and redistribute a copy of the dll files as part of any .NET based software developed and licensed by you that itself uses RapidSpell Silverlight provided
a) your software has clearly distinct and added functionality,
b) you are responsible for all technical support,
c) the RapidSpell Silverlight application programming interfaces are not documented, exposed, or otherwise made available by your software,
d) attribution is given to Keyoti Inc. (http://www.keyoti.com) in any documentation or screen displays where other credits appear,
e) you do not allow recipients of your software to reverse engineer, disassemble, decompile, or copy portions from your software allowing them to gain separate access to RapidSpell Silverlight or any parts of it,
f) your software is not used by software developers as part of their application, and
g) your software is not a software component or 'Control'.
The source code samples included with this package and in the RapidSpell Silverlight documentation may be freely used, modified, incorporated, and distributed without restriction as part of any software that uses RapidSpell Silverlight itself.
3. Warranty Disclaimer and Limitation of Liability. RapidSpell Silverlight is licensed to the user on an "AS IS" basis. Keyoti Inc. MAKES NO WARRANTIES, EITHER EXPRESSED OR IMPLIED, WITH RESPECT TO THIS SOFTWARE AND ITS ASSOCIATED FILES AND DOCUMENTATION, INCLUDING BUT NOT LIMITED TO ANY WARRANTY OF MERCHANTABILITY OR FITNESS FOR ANY PARTICULAR PURPOSE. KEYOTI Inc. DOES NOT WARRANT THAT THE OPERATION OF THIS SOFTWARE WILL BE UNINTERRUPTED OR ERROR FREE, OR THAT DEFECTS WILL BE CORRECTED. You the user are solely responsible for determining the appropriateness of this software for your use and accept full responsibility for all risks associated with its use. Keyoti Inc. is not and will not be liable for any direct, indirect, special or incidental damages in any amount including loss of profits or interruption of business however caused, even if Keyoti Inc. has been advised of the possibility of such damages. Keyoti Inc. retains the right to, in its sole discretion, refund the purchase price of this software as a complete and final resolution to any dispute.
SPECIFIC DISCLAIMER FOR HIGH-RISK ACTIVITIES.
The SOFTWARE is not designed or intended for use in high-risk activities including, without restricting the generality of the foregoing, online control of aircraft, air traffic, aircraft navigation or aircraft communications; or in the design, construction, operation or maintenance of any nuclear facility. Keyoti Inc. and its suppliers specifically disclaim any express or implied warranty of fitness for such purposes or any other purposes.
NO LIABILITY FOR CONSEQUENTIAL DAMAGES.
To the maximum extent permitted by applicable laws, in no event shall Keyoti Inc. or its suppliers be liable for any damages whatsoever (including without limitation, damages for loss of business profits, business interruption, loss of information, or other pecuniary loss) arising out of the use of or inability to use this Keyoti Inc. product, even if Keyoti Inc. has been advised of the possibility of such damages. Because some states and jurisdictions do not allow the exclusion or limitation of liability for consequential or incidental damages, the above limitation may not apply to you.
4. Support and Source Code Licensing. Keyoti Inc. does provide formal customer support for RapidSpell Silverlight for a fee. We also make every effort to ensure the quality of our products, and questions, bug reports, and feature requests are encouraged, please use email. Due to resource limitations, it may not be possible to resolve all issues and no assurances can be given as to when or if problems will be addressed. Customers incorporating RapidSpell Silverlight into software for deployment or sale are encouraged to purchase the Source Code License Version of RapidSpell Silverlight which will enable self-support, debugging, and modifications or extensions to the base functionality (but not distribution of the source code itself).


RapidSpell Silverlight Documentation: Introduction

RapidSpell Silverlight v2.0

Thank you for purchasing RapidSpell, please keep up to date through our website keyoti.com and feel invited to post feedback. We also ask that you register your purchase so that we may offer you support and free upgrades from time to time, at http://keyoti.com/care/register

Overview

RapidSpell consists of 2 spelling components (GUI and non-GUI) which provide for rapid integration within your application. Keyoti has developed these highly granular components with simplicity of application development in mind.

The assembly holds a graphical user interface component, which can be implemented with 2 lines of code to supply complete spell checker functionality to any Silverlight based application and a non-GUI class which provides a clean API for model (business/logic) level integration. While simplicity of use has been a major guiding force in the component design, user customization has not been spared, the GUI can be easily used as a base class and extended to provide UI customization and the non-GUI component provides access to core spell checking functionality.

Common Uses

Spell checking;
  • Strings programmatically
  • Silverlight text editors (RichTextBox, TextBox)

Requirements

The components support Silverlight 3, 4, 5 and Windows Phone


RapidSpell Silverlight Documentation: Release Notes

RapidSpell Silverlight Release Notes

2.0.0

Compatibility
  • Fully backwards compatible
Improvements
  • Added Silverlight 5 DLL
  • Sentence capitalization correction
  • Small bug fixes

1.0.0

Initial release, based on RapidSpell Desktop .NET v4 code-base.


RapidSpell Silverlight Documentation: Installation

Installation

Running the MSI installer is all that is required to install the controls for development. Initially the controls will display a nag screen until a license key is set.

After installation, the DLLs are made available to the list of assemblies in Visual Studio, from here the controls can be added to the VS toolbar by right clicking in the Toolbox and selecting "Choose Items" and from there selecting the controls in the dialog list.

Referencing Keyoti Assemblies (DLLs)

Standard:
Silverlight 3
Reference Keyoti3.RapidSpell.Silverlight.DLL (from the DLLs folder)

Silverlight 4
Reference Keyoti4.RapidSpell.Silverlight.DLL (from the DLLs folder)

Silverlight 5
Reference Keyoti5.RapidSpell.Silverlight.DLL (from the DLLs folder)

Windows Phone 7
Reference Keyoti4.RapidSpell.Silverlight.Phone.DLL (from the DLLs folder)

Licensing

The controls can be licensed by setting a valid key in the LicenseKey property of every RapidSpellDialog control.

Alternatively, the license key can be added once, to the App.xaml;

Inside

<Application.Resources>
   <ResourceDictionary>

   </ResourceDictionary>
</Application.Resources>

add this

<sys:String x:Key="Keyoti-RapidSpell-Silverlight-License-Key"
xmlns:sys="clr-namespace:System;assembly=mscorlib">PLACE LICENSE KEY HERE</sys:String>

Deployment

The RapidSpell Silverlight DLL and at least one dictionary (.dict) file should be deployed as part of your application package (XAP).


Keyoti Inc. - Quick Start

Quick Start - Dialog mode

Step 1
Step 2
Step 3
Step 4
Step 5
Step 6

Step 1. Get your Silverlight project ready (load or create it).

Next

Step 2. Drag the rapidSpellDialog Control onto your page and add a TextBox.

Next

Step 3. Set the TextBox property of rapidSpellDialog1 to your TextBox.

a. Click on the Advanced Properties box

b. Click 'Apply Data Binding'

c. Select 'ElementName' and your TextBox

Or set the control property in XAML

TextBox="{Binding ElementName=richTextBox1}"

Next

Step 4. Add a button to the page and call Check() in the click event.

Next

Step 5. Set the DictFileUri property to the filename of the main dictionary to be used.

a. Add a Dict file to the root of your application
(Dict files are located in the product install folder under 'Dictionaries').

b. From the property window mark the Dict file as "Build Action = Content"

c. Set the DictFileUri property of the RapidSpellDialog control to the name of your Dict file.

Note:

The DictFileUri property can be set to an absolute path. Please consult the Help.chm documentation for details.

Next

Step 6. Run!

Note:

To offer an "Add" function to the user, set UserDictionaryEnabled property to True.

Users can edit the word being checked using the dialog form and replace it with their own.


RapidSpell Silverlight Documentation: RapidSpellDialog

RapidSpellDialog

The RapidSpellDialog control conveniently wraps access to the RapidSpellGUIPresenter class providing dialog spell checking functionality for Silverlight with single or multiple text boxes.

This control mirrors most properties and methods available in RapidSpellGUIPresenter. Some members of note are below (please consult API docs for more info):
Properties
Options | - the users options
TextBox | - the TextBox to be checked
TextBoxBasesToCheck | - an array of TextBoxBases to be checked (also see AddTextComponent method)
Modal | - whether to spell check modally
SuggestSplitWords | - whether to suggest split words (eg. thistime -> this time)
SuggestionsMethod | - the suggestions method in use (hashing or phonetic)
GUILanguage | - the text language used in the GUI
IgnoreXML | - whether to ignore XML or HTML tags
ShowFinishedBoxAtEnd | - whether to show a spell check finished box at end
IgnoreCapitalizedWords | - whether to ignore capitalized words
IncludeUserDictionaryInSuggestions | - whether to include user dictionary words in suggestions
LookIntoHyphenatedText | - whether to consider hyphenated parts as individual words
UserInterfaceFormProvider | - allows customized user interfaces to be used
Methods
Check() | - runs the spell checker dialog
AddTextComponent(...) | - adds a TextBox, RichTextBox or ISpellCheckableTextComponent to be spell checked
RemoveTextComponent(...) | - removes a TextBox, RichTextBox or ISpellCheckableTextComponent from the list to be spell checked
Events
SpellCheckStarted | - fired when checking starts
SpellCheckStartedTextBox | - fired when spell check starts on a text box (used in multiple text box checking situations)
SpellCheckFinished | - fired when checked ends
SpellCheckFinishedTextBox | - fired when spell check starts on a text box (used in multiple text box checking situations)
WordAdded | - fired when word added to user dictionary
WordChanged | - fired when word changed
WordIgnored | - fired when word ignored
CreateDialogView | - allows customization of the UI by replacing the form used in the dialog
CreateDialogViewOptions | - allows customization of the UI by replacing the form used in the dialog
CreateDialogViewUserDictionaryEdit | - allows customization of the UI by replacing the form used in the dialog
RecheckDocumentRequest | - user has requested the document be rechecked


RapidSpell Silverlight Documentation: Main DLLs

Main DLLs

.NET 3 & 3.5

Keyoti3.RapidSpell.Silverlight.DLL contains the main controls for .NET 3.0/3.5 use.

.NET 4.0

Keyoti4.RapidSpell.Silverlight.DLL contains the main controls for .NET 4.0 use.


RapidSpell Silverlight Documentation: Dictionaries

Dictionaries

RapidSpell can use 2 different types of dictionary at once; The "main dictionary" and a "user dictionary".

Main Dictionary

Included are 3 dictionary files, UK and US English dictionaries, each containing ~110K words, a combined UK and US dictionary containing ~115K words. Also available for download: Australian and Canadian dictionaries.

Keyoti offer a number of non-English dictionaries. Further details and evaluation versions are available at;

http://keyoti.com/products/rapidspell/dotNet/dictionaries.html

Dict File Dictionaries

RapidSpell supports it's own proprietary dictionary format, these dictionaries are called Dict files. They have been developed to allow greater flexibility.

Features
- Small file size (~270KB for English)
- Swappable during run-time
- Customizable by developer

Using Dict Files

To use a Dict file simply set the DictFileUri property to the path of the Dict file to be used, this must be done BEFORE the Check method is called.

The DictFileUri can be set in one of 2 ways;

A relative path, eg. "DICT-EN-UK-UKEnglish.2.dict" or "dictionaries/DICT-EN-UK-UKEnglish.2.dict" (note there should not be a leading /). When used this way, the .dict file should be embedded as "Build Action = Content" in the application project. The path is relative to the root of the application.

An absolute path. eg. "http://host/DICT-EN-UK-UKEnglish.2.dict" (note that your application may be restricted to only accessing the origin host). When used this way the .dict file is hosted on the web, separate to the Silverlight app. This would be useful, for example, if the app. supports multiple languages but the developer does not wish to deploy all dictionaries in the XAP. Allowing the user to choose the dictionary before use, and downloading from the web is more bandwidth efficient.

Preloading The Dictionary
The dictionary can be loaded asynchronously (non blocking) before it is required for spell checking by calling the LoadDictionary() method in RapidSpellDialog. As soon as the method is called, the dictionary specified in the DictFileUri property is downloaded and decompressed. It is therefore advantageous to call it as the application initializes, instead of when the Check() method is called.

Dictionary Customization

It is possible to customize the dictionaries and create new ones using the convenient Dict Manager tool included in RapidSpell Silverlight, please load the tool and consult the help system provided in it for more details.

The Dict Manager tool included in RapidSpell Silverlight

Programmatic Use Of Dict Manager
To use Dict Manager programmatically:
  • Reference DictManager.exe in your project (when you browse for the assembly, just change the file type to *.exe in the open dialog).
  • Create an instance: model = new DictManager.DictManagerModel();
  • Use any of the API calls:
CreateDict		Creates a new dict file
LoadDict		Loads an existing dict file
AddWord			Adds a word to current open dict file
MergeDictFile		Merges an existing dict file with the open dict file
MergeTextFile		Merges an existing text file with the open dict file
RemoveWord		Removes a word from the dict file
LookUp			Checks if a word is in the dict file
SaveDict		Saves the currently open dict file
Compressed		Set to true for Silverlight

Typical usages should be in the following order;

create or load

modifying operations

save.

User (Custom) Dictionaries / Add Button

To offer an "Add" function to the user, set the UserDictionaryEnabled property to True. The user dictionary is a simple UTF-8 text file with words listed one per line (it is not a .dict file and isn't created by 'Dict Manager') and is stored in the IsolatedStorage folder. The user dictionary is suited best to relatively short lists added to by the user. If a large list (order of thousands) of custom words needs to be added, it is suggested that they are added to the main dictionary using Dict Manager.

The contents of the user dictionary can be edited by the user via the options form.


RapidSpell Silverlight Documentation: User Options

User Options

The options form (in RapidSpellDialog or invoked programmatically) allows the user to store their own spell check preferences and also edit their user dictionary.

By default, user options are enabled and stored under Silverlight IsolatedStorage. It's important to remember that user options (if enabled) will override the properties set in the spell checker controls

Disabling User Options

Set OptionsEnabled in the RapidSpellDialog control.

Programmatically Setting User Options

Call SetUserOptions on the options object and pass the values that should be used. Then call Save to write the changes. In this example we use the existing values (so no changes are made).
Dim o As Options.UserOptions = rapidSpellDialog1.Options
rapidSpellDialog1.Options.SetUserOptions(o.CheckAsYouType, o.IncludeUserDictionaryInSuggestions, _
    o.IgnoreWordsWithDigits, o.IgnoreURLsAndEmailAddresses, o.IgnoreCapitalizedWords, _
    o.AllowMixedCase, o.AllowAnyCase, o.FindSuggestions, False)
rapidSpellDialog1.Options.Save()
Eg. To change the "Check as you type" option, replace o.CheckAsYouType with either true or false.

Changing Storage Location

Set OptionsStorageLocation to either IsolatedStorage (default) or Stream see below.

Maintaining Separate Options Profiles

Set OptionsFileName in the RapidSpellDialog control to a unique name for each separate set of options to use.

Reseting / Deleting Options

Call UserOptions.Delete() to empty the file and allow the default options to be recreated. Eg. RapidSpellDialog.Options.Delete()

Launching Options Editor Programmatically

  1. Create an instance of Keyoti.RapidSpell.Wpf.Options.OptionsPresenter
  2. Call it's Show method with the UserOptions instance
  3. If Show returns true, then save the UserOptions object

Eg.
            OptionsPresenter optionsPresenter = new OptionsPresenter();
            if (optionsPresenter.Show(this, rapidSpellAsYouType1.Options))
            {
                rapidSpellAsYouType1.Options.Save();
            }

How To Use A Custom Stream For Storage

Events are available which can be used to determine when to prepare a stream to read/write to.

For example, to use a custom stream to write to an XML file;

.........
       Public Sub New()
        MyBase.New
        InitializeComponent
        rapidSpellAsYouType1.OptionsStorageLocation = Keyoti.RapidSpell.Wpf.Options.UserOptions.StorageType.Stream
        rapidSpellDialog1.OptionsStorageLocation = Keyoti.RapidSpell.Wpf.Options.UserOptions.StorageType.Stream
        Dim options As Keyoti.RapidSpell.Wpf.Options.UserOptions = New Keyoti.RapidSpell.Wpf.Options.UserOptions
        options.StorageLocation = Keyoti.RapidSpell.Wpf.Options.UserOptions.StorageType.Stream
        AddHandler options.NeedCustomStreamForSaving, AddressOf Me.NeedSaveStream
        AddHandler options.NeedCustomStreamForLoading, AddressOf Me.NeedLoadStream
        AddHandler options.OptionsSaved, AddressOf Me.options_OptionsSaved
        options.Load
        rapidSpellAsYouType1.Options = options
        rapidSpellDialog1.Options = options
        rapidSpellAsYouType1.TextBox = Me.aytTextBox1
    End Sub

    Private Sub options_OptionsSaved(ByVal sender As Object, ByVal e As Keyoti.RapidSpell.Event.OptionsSavedEventArgs)
        'update the DB?
    End Sub

    Private Sub NeedSaveStream(ByVal sender As Object, ByVal e As Keyoti.RapidSpell.Wpf.Options.NeedStreamEventArgs)
        e.RequiredStream = New System.IO.FileStream("c:\useropt.xml", System.IO.FileMode.Truncate, System.IO.FileAccess.Write)
    End Sub

    Private Sub NeedLoadStream(ByVal sender As Object, ByVal e As Keyoti.RapidSpell.Wpf.Options.NeedStreamEventArgs)
        e.RequiredStream = New System.IO.FileStream("c:\useropt.xml", System.IO.FileMode.OpenOrCreate)
    End Sub
.........
NOTE:

You can use the OptionsSaved event to write the stream's contents to a DB instead.


RapidSpell Silverlight Documentation: RapidSpellGUIPresenter

RapidSpellGUIPresenter

The RapidSpellGUIPresenter has a 100% customizable UI (IDialogView), provides user dictionary functionality, is multi-threaded and is extremely simple to use. The interface has a familiar layout and functionality.

RapidSpellGUIPresenter will interactively check any TextBoxBase derived class, this includes TextBox, RichTextBox and their sub-classes.

When invoked in an application the component will query the user on each misspelled word allowing the following functions;
Ignore
Ignore All occurrences of misspelt word
Add to user dictionary if provided
Change misspelt word to suggestion or user amended text
Change All occurrences of misspelt word
Undo last action
Options editor with user dictionary edit
Cancel

The GUI checks selections (querying to continue when finished), wraps from current caret position back to current caret position and handles the user editing the text in your application while checking is in progress.

Please see later sections for details on customizing the UI and the API documentation for member information.


RapidSpell Silverlight Documentation: RapidSpellChecker

RapidSpellChecker

Provides a model (business/logic) level spell checker API which can be used in a client-server environment and any applications where a client GUI does not exist. User dictionaries can optionally be used, allowing words to be added. This component can be used in 2 different ways, in an iterative fashion or on a query by query basis. Please see the API docs for code level details.

Using RapidSpellChecker in an iterative manner provides complete textual correction of strings similar to a GUI based spell checker. A string is loaded into RapidSpellChecker and then successive calls to the NextBadWord() method move through the string allowing FindSuggestions() and ChangeBadWord(replacement) to be called to find spelling suggestions and optionally correct the misspelt words in the text, finally GetAmendedText() returns the corrected text.

Alternatively RapidSpellChecker may be used in a simple query by query basis, calls to LookUp(word) and FindSuggestions(word) methods allow bare bones spell checking functionality.

Key API Points

Methods
RapidSpellChecker() | - argumentless constructor
Check(text [, startPosition]) | - begins checking text
FindSuggestions(word) | - finds suggestions for word
LookUp(word) | - checks if word is in either main or user dictionaries
SetUserDictionary(file) | - allows you to define which file will be used as a user dictionary
IgnoreAll(word) | - ignores all future occurrences of word
AddWord(word) | - adds word to the user dictionary if it exists
NextBadWord() | - finds the next misspelt word in the text
ChangeBadWord(newWord) | - changes the misspelt word last identified by NextBadWord()
GetAmendedText() | - returns the corrected text
FindCompoundWords(text, list) | - adds compound words in text string
FindAnagrams(word, list) | - adds anagrams of word to list
Properties
DictFilePath | - the path to a .dict dictionary file.
LanguageParser | - the language parser to be used (LanguageType.ENGLISH, LanguageType.FRENCH....)
IgnoreXML | - whether to ignore XML tags
ModalMode | - whether to operate modally
SuggestSplitWords | - whether to suggest split words, eg. "myhouse" -> "my house"
CheckCompoundWords/font> | - whether to check unknown words for compound forms
LookIntoHyphenatedText | - whether to treat hyphens as word separators

Query by Query Usage Sequence Diagram

Iterative Usage Sequence Diagram

See Examples section for details.


RapidSpell Silverlight Documentation: Dialog Spell Checking

Dialog Spell Checking

To use the GUI dialog spell checker control (RapidSpellDialog) as an integral part of your application simply instantiate it, set the text component you wish this GUI to spell check and call Check(), which will bring up this component in a new Window allowing the user to correct their document.

In this example the UK + US English dictionary is used (dict-en-g-uk+us.2.dict) it should be added to the root of the application and marked (in the property window) as "Build Action = Content"

Code Example

<navigation:Page x:Class="Main.Dialog.SimpleDialog"
           xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
           xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
           xmlns:d="http://schemas.microsoft.com/expression/blend/2008"
           xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006"
           mc:Ignorable="d"
           xmlns:navigation="clr-namespace:System.Windows.Controls;assembly=System.Windows.Controls.Navigation"
           d:DesignWidth="640" d:DesignHeight="480"
           Title="SimpleDialog Page"
           xmlns:my="clr-namespace:Keyoti.RapidSpell;assembly=Keyoti4.RapidSpell.Silverlight"
    >
    <Grid x:Name="LayoutRoot">

<TextBox Name="textBox1" Margin="12,41,12,12" AcceptsReturn="True" TextWrapping="Wrap">
</TextBox>

<my:RapidSpellDialog DictFileUri="dict-en-g-uk+us.2.dict" TextBox="{Binding ElementName=textBox1}"
Name="rapidSpellDialog1" />

<Button Content="Spell Check..." Height="23" Name="spellButton" VerticalAlignment="Top"
Margin="0,12,12,0" Click="spellButton_Click" HorizontalAlignment="Right" Width="99" />

    </Grid>
</navigation:Page>

    //C#
    private void spellButton_Click(object sender, RoutedEventArgs e)
    {
        rapidSpellDialog1.Check();
    }

    'VB
    Sub spellButton_Click(ByVal sender As Object, ByVal e As RoutedEventArgs)
        rapidSpellDialog1.Check()
    End Sub

Preloading The Dictionary

The dictionary can be loaded asynchronously (non blocking) before it is required for spell checking by calling the LoadDictionary() method in RapidSpellDialog. As soon as the method is called, the dictionary specified in the DictFileUri property is downloaded and decompressed. It is therefore advantageous to call it as the application initializes, instead of when the Check() method is called.

Checking Multiple TextBoxes

To add more textboxes to be checked, use the AddTextComponent method in RapidSpellDialog, eg.

    rapidSpellDialog1.AddTextComponent( richTextBox2 )


RapidSpell Silverlight Documentation: Custom RapidSpellDialog User Interface

Custom RapidSpellDialog User Interface

Layout/Style

It is easy to customize the UI used by the RapidSpellDialog control. The example projects include full source code for the default UIs, which can be modified by hand or in the Visual Studio designer. It's also possible to implement the lightweight IDialogView interface from scratch and use any class as a UI (eg. built on 3rd party forms).

Assuming IDialogView has been implemented already (see demos), the class is used by handling the CreateDialogView event in RapidSpellDialog, and setting an instance of the class (which implements IDialogView) in the event argument's NewView property.

C#

    private void rapidSpellDialog1_CreateDialogView(object sender,
                        Keyoti.RapidSpell.Event.CreateDialogViewEventArgs e)
    {
         e.NewView = new CustomGUIView();
    }

VB.NET

    Sub rapidSpellDialog1_CreateDialogView(ByVal sender As System.Object, _
        ByVal e As Keyoti.RapidSpell.Event.CreateDialogViewEventArgs) Handles _
        rapidSpellDialog1.CreateDialogView
        e.NewView = New CustomGUIView
    End Sub

The above assumes that CustomGUIView is a class implementing IDialogView.

Options And User Dictionary Editor

Similarly, the CreateDialogViewOptions and CreateDialogViewUserDictionaryEdit events allow substitution of the default UIs for option and user dictionary editing. Please see the demo projects for full source.

Behavior

It is easy to customize the UI behavior used by the RapidSpellDialog control. This is done by subclassing "RapidSpellGUIPresenter" which is the logic behind the RapidSpellDialog user interface. RapidSpellGUIPresenter has methods which react to user input and also controls the Form, which it holds in it's "DialogView" property (this is actually the instance returned via the "CreateDialogView" event, see above).

To use a subclass of RapidSpellGUIPresenter, handle the RapidSpellDialog.CreateUserInterfaceFormPresenter event.

C#

    private void rapidSpellDialog1_CreateUserInterfaceFormPresenter(object sender,
                    Keyoti.RapidSpell.Event.CreateUserInterfaceFormPresenterEventArgs e)
    {
       e.NewPresenter = new CRapidSpellGUIPresenter();
    }

VB.NET

    Sub rapidSpellDialog1_CreateUserInterfaceFormPresenter(ByVal sender As System.Object, _
        ByVal e As Keyoti.RapidSpell.Event.CreateUserInterfaceFormPresenterEventArgs) Handles _
        rapidSpellDialog1.CreateUserInterfaceFormPresenter
        e.NewPresenter = new CRapidSpellGUIPresenter()
    End Sub

This sets the instance of the RapidSpellGUIPresenter subclass "CRapidSpellGUIPresenter" in the event property.

Consult the API docs (under namespaces) for details of the various methods which can be overridden. As an example, consider the case where the "change" buttons should be disabled when there are no suggestions. The CRapidSpellGUIPresenter class would look like this.

C#

    public class CRapidSpellGUIPresenter : RapidSpellGUIPresenter
    {

        protected override void Resume()
        {
            base.Resume();
            System.Collections.ArrayList suggs;
            suggs = CheckerEngine.FindSuggestions();

            DialogView.ChangeAllButtonEnabled = suggs.Count > 0;
            DialogView.ChangeButtonEnabled = suggs.Count > 0;

        }
    }

The Resume method is called every time a word is shown as an error to the user, and the opportunity is taken to look at how many suggestions there are (using the CheckerEngine property). When there are no suggestions the change buttons are disabled (note how they are accessed via the DialogView property, which returns the IDialogView instance in use).


RapidSpell Silverlight Documentation: Non-GUI Spell Checker

Non-GUI Spell Checker

The RapidSpellChecker component is of particular use in non-GUI scenarios. Below is a very simple excerpt of how this component can be used.

Code Example

.........

    RapidSpellChecker c = new RapidSpellChecker();
    AsyncDictionaryLoader loader = new AsyncDictionaryLoader(rsc);

    //Load is an asynchronous method, so must wait until the dictionary is loaded.
    /It's best to call Load as early as possible in your app. so that the dictionary is downloaded before it's needed.
    loader.Load("DICT-EN-UK-UKEnglish.2.dict");
    while (loader.IsLoading) { System.Threading.Thread.Sleep(50); }

    BadWord badWord;
    ArrayList suggestions;

    //check some text.
    c.Check("This is sume text.");

    //iterate through all bad words in the text.
    while((badWord = c.NextBadWord())!=null){

        Console.WriteLine(badWord.GetWord() +
            "- is not spelt correctly. Suggestions:");

        try{
            //get suggestions for the current bad word.
            suggestions = c.FindSuggestions();

            //display all suggestions.
            for(int i=0; i<suggestions.Count; i++){
                Console.WriteLine(suggestions[i]);
            }

            //change the bad word in the text with "replacement".
            c.ChangeBadWord("replacement");
        } catch (NoCurrentBadWordException e){
            Console.WriteLine(e);
        }
    }
    Console.WriteLine(c.GetAmendedText());
.........


RapidSpell Silverlight Documentation: Ignore Pattern Customization

Ignore Pattern Customization & Email/URL Addresses

The IgnoreURLsAndEmailAddresses property/option can be used to make the spell checker ignore these types of strings. A built in regex does this matching, however for performance reasons it does not match every known top level domain (eg. .no), and also will not match custom domains.

The AddIgnorePattern method allows customization of the patterns that are ignored, this can be applied to most strings, not just domains.

Eg. to also ignore .no and .ro domains, call this

C#
string pattern = @"[a-zA-Z0-9]+(?:[a-zA-Z0-9\-\.]+)?\.(?:no|ro){1,2}";

(rapidSpellDialog.CheckerEngine as RapidSpellChecker).AddIgnorePattern(pattern);
rapidSpellAsYouType.RapidSpellChecker.AddIgnorePattern(pattern);
VB.NET
Dim pattern As String = "[a-zA-Z0-9]+(?:[a-zA-Z0-9\-\.]+)?\.(?:no|ro){1,2}"
CType(rapidSpellDialog.CheckerEngine,RapidSpellChecker).AddIgnorePattern(pattern)
rapidSpellAsYouType.RapidSpellChecker.AddIgnorePattern(pattern)


RapidSpell Silverlight Documentation: Suggestions Algorithm

Suggestions Algorithm

It is possible to choose (programmatically) the algorithm used to find suggestions for spelling errors, there are two algorithms on offer, 'hashing' (default) and 'phonetic'. Each algorithm has it's own advantages and disadvantages;

Hashing (default): Very fast, roughly 40 times faster than the phonetic algorithm, works best on typographic errors and common spelling mistakes. Similar to most spell checker suggestions.

Phonetic (Sounds like, English only): Slower, works well with genuine attempts to spell correctly, works poorly with typographic errors. Can appear to produce wild results, although results do sound like the word in question. Does not work with non English languages. Unusual.

It is recommended that you choose the suggestions algorithm in line with your target audience. The phonetic algorithm, although appearing worse overall, is more suited for people who have not spoken English for very long, e.g. non native English speakers and children.


RapidSpell Silverlight Documentation: Consideration Range

Consideration Range

The hashing suggestion algorithm is very fast because it accurately cuts down the list of words to look at as possible suggestions. The factory default consideration range is 80, which provides optimal speed with a loss of only a fraction of possible suggestions. It is possible to set the consideration range through the RapidSpellDialog, RapidSpellGUI and RapidSpellChecker classes. The relationship between speed, number of suggestions and consideration range is shown below.


RapidSpell Silverlight Documentation: Conclusion

Conclusion

Thank you for using the RapidSpell component, we hope that you experience much success with it. Keyoti is committed to improving all of it's products and truly values customer feedback of any kind. If you would like to contact us about any of our products please do so through our web site.

http://www.keyoti.com/contact.html

We thrive on suggestions for components and feature requests, if you have a component wish please don't hesitate to get in touch, it may be the next thing we develop!


Loading...


Keyoti.RapidSpell Namespace

Keyoti RapidSpell Silverlight API Docs
Keyoti.RapidSpell Namespace
API ► Keyoti.RapidSpell
Keyoti RapidSpell Silverlight
The core namespace for RapidSpell.

Main namespace

Declaration Syntax
C# Visual Basic Visual C++
namespace Keyoti.RapidSpell
Namespace Keyoti.RapidSpell
namespace Keyoti.RapidSpell
Types
All Types Classes Interfaces Enumerations Delegates
Icon | Type | Description
 | ApplicationException |
 | ArrayList |
 | AsyncDictionaryLoader | Loads the main dictionary asynchronously.
 | BadWord | Represents a mis-spelt word in the text.
 | BrowsableAttribute |
 | CancelEventArgs |
 | CheckerEngineAdapter | Abstract base implementation of ICheckerEngine, override chosen members for desired functionality.
 | ComClientInteropSupport | This class supports users who access RapidSpell controls from COM code.
 | Component |
 | DesignableComponent | Base support for non-visual components.
 | DesignerSerializationVisibility |
 | DesignerSerializationVisibilityAttribute |
 | DialogResult |
 | DialogTexts | Contains all texts in RapidSpellDialog and user options.
 | DictionaryCache | Cache of loaded dictionaries.
 | DictionaryLoadException | Exception with dictionary loading.
 | Hashtable |
 | IButtonControl |
 | ICheckerEngine | Defines the interface required for a class to be used as a checker engine
 | ISpellCheckableTextComponent | Defines the interface required for a text component to be spell checkable using the RapidSpellDialog control (or RapidSpellGUI class)
 | ISpellCheckableTextComponent2 | Defines the interface required for a text component to be spell checkable using the RapidSpellDialog control (or RapidSpellGUI class)
 | IUserInterfaceFormPresenter | Interface requirements for a dialog based UI form.
 | Label |
 | LanguageType | Enumeration of language types.
 | License |
 | LicenseProvider |
 | ListBox |
 | UserDictionary..::.ListChangedEventArgs | Event args for ListChanged event
 | UserDictionary..::.ListChangedEventHandler | Event handler
 | UserDictionary..::.ListChangedEventArgs..::.ListChangeOperation | Types of operation
 | AsyncDictionaryLoader..::.LoadCompleteEventArgs | Load complete event args
 | AsyncDictionaryLoader..::.LoadCompleteEventHandler |
 | MessageBoxButtons |
 | MessageBoxIcon |
 | NoCurrentBadWordException | Thrown if NextBadWord has not been run first and found a mis-spelt word.
 | NoTextComponentException | Thrown if a valid text component hasn't been set to be checked (by the GUI for example).
 | UndoableOperation..::.Operation | Types of operation
 | OperationScope | The scope of an operation.
 | OptionsSavedEventArgs | Args for the options saved event.
 | OptionsSavedEventHandler | Handler
 | RapidSpellChecker | Spell checker engine, checks a text string for spelling errors and makes suggested corrections.
 | RapidSpellDialog | RapidSpell Desktop Dialog Control, this convenience control provides design time support for RapidSpellGUI and multiple text box support.
 | RapidSpellGUIPresenter | Controls the UI logic used for RapidSpellDialog forms.
 | RapidSpellGUIPresenter..::.SpellCheckEventHandler | Spell check event handler delegate.
 | RapidSpellDialog..::.SpellCheckEventHandler | Spell check event handler delegate.
 | SpellingDictionary |
 | RapidSpellChecker..::.State | State of the spell checker
 | UserDictionary..::.StorageLocation | Location options for storage
 | Suggestion | Represents a suggestion.
 | SuggestionsMethodType | Suggestions algorithm identifiers.
 | TextBoxEx | TextBox subclass which supports visible selection when focus elsewhere.
 | RapidSpellDialog..::.TextBoxSpellCheckEventHandler | Handler delegate
 | UndoableOperation | An operation which can be undone
 | UndoableStateEventArgs | Args for the events fired when words are ignored.
 | UndoEventArgs | Undo event args
 | UndoEventHandler | Event handler delegate
 | UndoManager | Manages the undoable operation stack.
 | UserDictionary | Represents the UserDictionary
 | WordAddedEventArgs | Args for the events fired when words are added to the user dictionary.
 | WordAddedEventHandler | Handler delegate
 | WordChangedEventArgs | Args for the events fired when words are changed.
 | WordChangedEventHandler | Handler delegate
 | WordIgnoredEventArgs | Args for the events fired when words are ignored.
 | WordIgnoredEventHandler | Handler delegate
 | WordOccurrence | Represents a word in the text.
 | WordRemovedEventArgs | Args for the events fired when words are removed from the user dictionary.
 | WordRemovedEventHandler | Handler delegate

Send comments on this topic to support@keyoti.com

2010-2012 Keyoti Inc.


ApplicationException Class

ApplicationException Class
API ► Keyoti.RapidSpell ► ApplicationException
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public class ApplicationException : Exception
Public Class ApplicationException _
    Inherits Exception
public ref class ApplicationException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ApplicationException(String) |
 | ApplicationException()()() |
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | ApplicationException
 |  |  | NoCurrentBadWordException

Send comments on this topic to support@keyoti.com

2010-2012 Keyoti Inc.

Assembly: Keyoti3.RapidSpell.Silverlight (Module: Keyoti3.RapidSpell.Silverlight) Version: 2.0.12.706 (2.0.12.706)


ApplicationException Constructor

ApplicationException Constructor
API ► Keyoti.RapidSpell ► ApplicationException ► ApplicationException()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | ApplicationException(String) |
 | ApplicationException()()() |


ApplicationException Constructor

ApplicationException Constructor
API ► Keyoti.RapidSpell ► ApplicationException ► ApplicationException()()()
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public ApplicationException()
Public Sub New
public:
ApplicationException()


ApplicationException Constructor (m)

ApplicationException Constructor (m)
API ► Keyoti.RapidSpell ► ApplicationException ► ApplicationException(String)
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public ApplicationException(
    string m
)
Public Sub New ( _
    m As String _
)
public:
ApplicationException(
    String^ m
)
Parameters
m (String)


ArrayList Class

ArrayList Class
API ► Keyoti.RapidSpell ► ArrayList
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public class ArrayList : List<Object>
Public Class ArrayList _
    Inherits List(Of Object)
public ref class ArrayList : public List<Object^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ArrayList(Int32) |
 | ArrayList(array<String>[]()[]) |
 | ArrayList(List<(Of <(Object>)>)) |
 | ArrayList(array<Regex>[]()[]) |
 | ArrayList()()() |
 | Add(T) | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Object >)>).)
 | AddRange(IEnumerable<(Of <(T>)>)) | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Object >)>).)
 | AsReadOnly()()() | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Object >)>).)
 | BinarySearch(String, IComparer) |
 | BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Object >)>).)
 | BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Object >)>).)
 | BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Object >)>).)
 | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Object >)>).)
 | Clear()()() | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Object >)>).)
 | Clone()()() |
 | Contains(T) | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Object >)>).)
 | ConvertAll<(Of <(TOutput>)>)(Converter<(Of <(T, TOutput>)>)) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Object >)>).)
 | CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <( Object >)>).)
 | CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Object >)>).)
 | CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Object >)>).)
 | Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Object >)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(Predicate<(Of <(T>)>)) | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Object >)>).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Object >)>).)
 | FindAll(Predicate<(Of <(T>)>)) | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Object >)>).)
 | FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Object >)>).)
 | FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Object >)>).)
 | FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Object >)>).)
 | FindLast(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Object >)>).)
 | FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Object >)>).)
 | FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Object >)>).)
 | FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Object >)>).)
 | ForEach(Action<(Of <(T>)>)) | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Object >)>).)
 | GetEnumerator()()() | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Object >)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRange(Int32, Int32) | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Object >)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Object >)>).)
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Object >)>).)
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Object >)>).)
 | Insert(Int32, T) | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Object >)>).)
 | InsertRange(Int32, IEnumerable<(Of <(T>)>)) | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Object >)>).)
 | Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from List <(Of <( Object >)>).)
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Object >)>).)
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Object >)>).)
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Object >)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( Object >)>).)
 | RemoveAll(Predicate<(Of <(T>)>)) | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Object >)>).)
 | RemoveAt(Int32) | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( Object >)>).)
 | RemoveRange(Int32, Int32) | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Object >)>).)
 | Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List <(Of <( Object >)>).)
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <( Object >)>).)
 | Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List <(Of <( Object >)>).)
 | Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Object >)>).)
 | Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Object >)>).)
 | Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List <(Of <( Object >)>).)
 | Synchronized(ArrayList) |
 | ToArray(Type) |
 | ToArray()()() | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Object >)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrimExcess()()() | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Object >)>).)
 | TrueForAll(Predicate<(Of <(T>)>)) | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Object >)>).)
Inheritance Hierarchy
Object
 | List <(Of <( Object >)>)
 |  | ArrayList


ArrayList Constructor

ArrayList Constructor
API ► Keyoti.RapidSpell ► ArrayList ► ArrayList()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | ArrayList(Int32) |
 | ArrayList(array<String>[]()[]) |
 | ArrayList(List<(Of <(Object>)>)) |
 | ArrayList(array<Regex>[]()[]) |
 | ArrayList()()() |


ArrayList Constructor

ArrayList Constructor
API ► Keyoti.RapidSpell ► ArrayList ► ArrayList()()()
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList()
Public Sub New
public:
ArrayList()


ArrayList Constructor (s)

ArrayList Constructor (s)
API ► Keyoti.RapidSpell ► ArrayList ► ArrayList(List<(Of <(Object>)>))
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList(
    List<Object> s
)
Public Sub New ( _
    s As List(Of Object) _
)
public:
ArrayList(
    List<Object^>^ s
)
Parameters
s (List <(Of <( Object >)>))


ArrayList Constructor (s)

ArrayList Constructor (s)
API ► Keyoti.RapidSpell ► ArrayList ► ArrayList(Int32)
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList(
    int s
)
Public Sub New ( _
    s As Integer _
)
public:
ArrayList(
    int s
)
Parameters
s (Int32)


ArrayList Constructor (s)

ArrayList Constructor (s)
API ► Keyoti.RapidSpell ► ArrayList ► ArrayList(array<String>[]()[])
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList(
    string[] s
)
Public Sub New ( _
    s As String() _
)
public:
ArrayList(
    array<String^>^ s
)
Parameters
s (array< String >[]()[])


ArrayList Constructor (s)

ArrayList Constructor (s)
API ► Keyoti.RapidSpell ► ArrayList ► ArrayList(array<Regex>[]()[])
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList(
    Regex[] s
)
Public Sub New ( _
    s As Regex() _
)
public:
ArrayList(
    array<Regex^>^ s
)
Parameters
s (array< Regex >[]()[])


BinarySearch Method (w, c)

BinarySearch Method (w, c)
API ► Keyoti.RapidSpell ► ArrayList ► BinarySearch(String, IComparer)
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public int BinarySearch(
    string w,
    IComparer c
)
Public Function BinarySearch ( _
    w As String, _
    c As IComparer _
) As Integer
public:
int BinarySearch(
    String^ w,
    IComparer^ c
)
Parameters
w (String)
c (IComparer)


Clone Method

Clone Method
API ► Keyoti.RapidSpell ► ArrayList ► Clone()()()
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList Clone()
Public Function Clone As ArrayList
public:
ArrayList^ Clone()


Synchronized Method (a)

Synchronized Method (a)
API ► Keyoti.RapidSpell ► ArrayList ► Synchronized(ArrayList)
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public static ArrayList Synchronized(
    ArrayList a
)
Public Shared Function Synchronized ( _
    a As ArrayList _
) As ArrayList
public:
static ArrayList^ Synchronized(
    ArrayList^ a
)
Parameters
a (ArrayList)


ToArray Method (t)

ToArray Method (t)
API ► Keyoti.RapidSpell ► ArrayList ► ToArray(Type)
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public Array ToArray(
    Type t
)
Public Function ToArray ( _
    t As Type _
) As Array
public:
Array^ ToArray(
    Type^ t
)
Parameters
t (Type)


AsyncDictionaryLoader Class

AsyncDictionaryLoader Class
API ► Keyoti.RapidSpell ► AsyncDictionaryLoader
Keyoti RapidSpell Silverlight
Loads the main dictionary asynchronously.
Declaration Syntax
C# Visual Basic Visual C++
public class AsyncDictionaryLoader
Public Class AsyncDictionaryLoader
public ref class AsyncDictionaryLoader
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AsyncDictionaryLoader(ICheckerEngine) |
 | DictionaryUri | The dictionary being loaded.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsLoading | Whether the dictionary is currently loading.
 | Load(String) |
 | Loaded |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
AsyncDictionaryLoader


AsyncDictionaryLoader Constructor (checkerEngine)

AsyncDictionaryLoader Constructor (checkerEngine)
API ► Keyoti.RapidSpell ► AsyncDictionaryLoader ► AsyncDictionaryLoader(ICheckerEngine)
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public AsyncDictionaryLoader(
    ICheckerEngine checkerEngine
)
Public Sub New ( _
    checkerEngine As ICheckerEngine _
)
public:
AsyncDictionaryLoader(
    ICheckerEngine^ checkerEngine
)
Parameters
checkerEngine (ICheckerEngine)


DictionaryUri Property

DictionaryUri Property
API ► Keyoti.RapidSpell ► AsyncDictionaryLoader ► DictionaryUri
Keyoti RapidSpell Silverlight
The dictionary being loaded.
Declaration Syntax
C# Visual Basic Visual C++
public string DictionaryUri { get; }
Public ReadOnly Property DictionaryUri As String
public:
property String^ DictionaryUri {
    String^ get ();
}


IsLoading Property

IsLoading Property
API ► Keyoti.RapidSpell ► AsyncDictionaryLoader ► IsLoading
Keyoti RapidSpell Silverlight
Whether the dictionary is currently loading.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsLoading { get; }
Public ReadOnly Property IsLoading As Boolean
public:
property bool IsLoading {
    bool get ();
}


Load Method (dictFileUri)

Load Method (dictFileUri)
API ► Keyoti.RapidSpell ► AsyncDictionaryLoader ► Load(String)
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public void Load(
    string dictFileUri
)
Public Sub Load ( _
    dictFileUri As String _
)
public:
void Load(
    String^ dictFileUri
)
Parameters
dictFileUri (String)


Loaded Event

Loaded Event
API ► Keyoti.RapidSpell ► AsyncDictionaryLoader ► Loaded
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public event AsyncDictionaryLoader..::.LoadCompleteEventHandler Loaded
Public Event Loaded As AsyncDictionaryLoader..::.LoadCompleteEventHandler
public:
 event AsyncDictionaryLoader..::.LoadCompleteEventHandler^ Loaded {
    void add (AsyncDictionaryLoader..::.LoadCompleteEventHandler^ value);
    void remove (AsyncDictionaryLoader..::.LoadCompleteEventHandler^ value);
}


AsyncDictionaryLoader.LoadCompleteEventArgs Class

AsyncDictionaryLoader..::.LoadCompleteEventArgs Class
API ► Keyoti.RapidSpell ► AsyncDictionaryLoader ► AsyncDictionaryLoader..::.LoadCompleteEventArgs
Keyoti RapidSpell Silverlight
Load complete event args
Declaration Syntax
C# Visual Basic Visual C++
public class LoadCompleteEventArgs
Public Class LoadCompleteEventArgs
public ref class LoadCompleteEventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AsyncDictionaryLoader..::.LoadCompleteEventArgs(Boolean) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Success |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
AsyncDictionaryLoader..::.LoadCompleteEventArgs


AsyncDictionaryLoader.LoadCompleteEventArgs Constructor (success)

AsyncDictionaryLoader..::.LoadCompleteEventArgs Constructor (success)
API ► Keyoti.RapidSpell ► AsyncDictionaryLoader..::.LoadCompleteEventArgs ► AsyncDictionaryLoader..::.LoadCompleteEventArgs(Boolean)
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public LoadCompleteEventArgs(
    bool success
)
Public Sub New ( _
    success As Boolean _
)
public:
LoadCompleteEventArgs(
    bool success
)
Parameters
success (Boolean)


Success Property

Success Property
API ► Keyoti.RapidSpell ► AsyncDictionaryLoader..::.LoadCompleteEventArgs ► Success
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public bool Success { get; set; }
Public Property Success As Boolean
public:
property bool Success {
    bool get ();
    void set (bool value);
}


AsyncDictionaryLoader.LoadCompleteEventHandler Delegate

AsyncDictionaryLoader..::.LoadCompleteEventHandler Delegate
API ► Keyoti.RapidSpell ► AsyncDictionaryLoader ► AsyncDictionaryLoader..::.LoadCompleteEventHandler
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public delegate void LoadCompleteEventHandler(
    Object sender,
    AsyncDictionaryLoader..::.LoadCompleteEventArgs e
)
Public Delegate Sub LoadCompleteEventHandler ( _
    sender As Object, _
    e As AsyncDictionaryLoader..::.LoadCompleteEventArgs _
)
public delegate void LoadCompleteEventHandler(
    Object^ sender,
    AsyncDictionaryLoader..::.LoadCompleteEventArgs^ e
)
Parameters
sender (Object)
e (AsyncDictionaryLoader..::.LoadCompleteEventArgs)


BadWord Class

BadWord Class
API ► Keyoti.RapidSpell ► BadWord
Keyoti RapidSpell Silverlight
Represents a mis-spelt word in the text.
Declaration Syntax
C# Visual Basic Visual C++
public class BadWord : WordOccurrence
Public Class BadWord _
    Inherits WordOccurrence
public ref class BadWord : public WordOccurrence
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BadWord(String, Int32, Int32) | Constructs a BadWord (REASON_SPELLING) instance.
 | BadWord(String, Int32, Int32, Int32) | Constructs a BadWord instance.
 | caretEnd | End of word (Inherited from WordOccurrence.)
 | caretStart | Start of word (Inherited from WordOccurrence.)
 | Clone()()() | Clones this instance
 | EndPosition | Gets the position of the end of this word in the main text. (Inherited from WordOccurrence.)
 | Equals(Object) | See base. (Overrides Object.Equals(Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEndPosition()()() | Gets the position of the end of this word in the main text. (Inherited from WordOccurrence.)
 | GetHashCode()()() | See base (Overrides Object.GetHashCode()()().)
 | GetReason()()() | Gets the reason that this is a bad word.
 | GetStartPosition()()() | Gets the position of the start of this word in the main text. (Inherited from WordOccurrence.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWord()()() | Gets the String of this bad word. (Inherited from WordOccurrence.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Reason | Gets the reason that this is a bad word.
 | REASON_CAPITALIZATION | BadWord reason, incorrect capitalization.
 | REASON_DUPLICATE | BadWord reason, duplicate word occurrence.
 | REASON_SPELLING | BadWord reason, incorrect spelling.
 | Shift(Int32) | Moves the bad word position by delta
 | StartPosition | Gets the position of the start of this word in the main text. (Inherited from WordOccurrence.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Word | Gets the string of this bad word. (Inherited from WordOccurrence.)
Inheritance Hierarchy
Object
 | WordOccurrence
 |  | BadWord


BadWord Constructor

BadWord Constructor
API ► Keyoti.RapidSpell ► BadWord ► BadWord()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | BadWord(String, Int32, Int32) | Constructs a BadWord (REASON_SPELLING) instance.
 | BadWord(String, Int32, Int32, Int32) | Constructs a BadWord instance.


BadWord Constructor (word, caretStart, caretEnd)

BadWord Constructor (word, caretStart, caretEnd)
API ► Keyoti.RapidSpell ► BadWord ► BadWord(String, Int32, Int32)
Keyoti RapidSpell Silverlight
Constructs a BadWord (REASON_SPELLING) instance.
Declaration Syntax
C# Visual Basic Visual C++
public BadWord(
    string word,
    int caretStart,
    int caretEnd
)
Public Sub New ( _
    word As String, _
    caretStart As Integer, _
    caretEnd As Integer _
)
public:
BadWord(
    String^ word,
    int caretStart,
    int caretEnd
)
Parameters
word (String)
the word String that is misspelt
caretStart (Int32)
the position in the original text
caretEnd (Int32)
the end position in the text


BadWord Constructor (word, caretStart, caretEnd, reason)

BadWord Constructor (word, caretStart, caretEnd, reason)
API ► Keyoti.RapidSpell ► BadWord ► BadWord(String, Int32, Int32, Int32)
Keyoti RapidSpell Silverlight
Constructs a BadWord instance.
Declaration Syntax
C# Visual Basic Visual C++
public BadWord(
    string word,
    int caretStart,
    int caretEnd,
    int reason
)
Public Sub New ( _
    word As String, _
    caretStart As Integer, _
    caretEnd As Integer, _
    reason As Integer _
)
public:
BadWord(
    String^ word,
    int caretStart,
    int caretEnd,
    int reason
)
Parameters
word (String)
the word String that is misspelt
caretStart (Int32)
the position in the original text
caretEnd (Int32)
the end position in the text
reason (Int32)
the reason this is a bad word, either REASON_DUPLICATE or REASON_SPELLING


Clone Method

Clone Method
API ► Keyoti.RapidSpell ► BadWord ► Clone()()()
Keyoti RapidSpell Silverlight
Clones this instance
Declaration Syntax
C# Visual Basic Visual C++
public BadWord Clone()
Public Function Clone As BadWord
public:
BadWord^ Clone()
Return Value


Equals Method (obj)

Equals Method (obj)
API ► Keyoti.RapidSpell ► BadWord ► Equals(Object)
Keyoti RapidSpell Silverlight
See base.
Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj (Object)


GetHashCode Method

GetHashCode Method
API ► Keyoti.RapidSpell ► BadWord ► GetHashCode()()()
Keyoti RapidSpell Silverlight
See base
Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override


GetReason Method

GetReason Method
API ► Keyoti.RapidSpell ► BadWord ► GetReason()()()
Keyoti RapidSpell Silverlight
Gets the reason that this is a bad word.
Declaration Syntax
C# Visual Basic Visual C++
public int GetReason()
Public Function GetReason As Integer
public:
int GetReason()


Reason Property

Reason Property
API ► Keyoti.RapidSpell ► BadWord ► Reason
Keyoti RapidSpell Silverlight
Gets the reason that this is a bad word.
Declaration Syntax
C# Visual Basic Visual C++
public int Reason { get; }
Public ReadOnly Property Reason As Integer
public:
property int Reason {
    int get ();
}


REASON_CAPITALIZATION Field

REASON_CAPITALIZATION Field
API ► Keyoti.RapidSpell ► BadWord ► REASON_CAPITALIZATION
Keyoti RapidSpell Silverlight
BadWord reason, incorrect capitalization.
Declaration Syntax
C# Visual Basic Visual C++
public static int REASON_CAPITALIZATION
Public Shared REASON_CAPITALIZATION As Integer
public:
static int REASON_CAPITALIZATION


REASON_DUPLICATE Field

REASON_DUPLICATE Field
API ► Keyoti.RapidSpell ► BadWord ► REASON_DUPLICATE
Keyoti RapidSpell Silverlight
BadWord reason, duplicate word occurrence.
Declaration Syntax
C# Visual Basic Visual C++
public static int REASON_DUPLICATE
Public Shared REASON_DUPLICATE As Integer
public:
static int REASON_DUPLICATE


REASON_SPELLING Field

REASON_SPELLING Field
API ► Keyoti.RapidSpell ► BadWord ► REASON_SPELLING
Keyoti RapidSpell Silverlight
BadWord reason, incorrect spelling.
Declaration Syntax
C# Visual Basic Visual C++
public static int REASON_SPELLING
Public Shared REASON_SPELLING As Integer
public:
static int REASON_SPELLING


Shift Method (delta)

Shift Method (delta)
API ► Keyoti.RapidSpell ► BadWord ► Shift(Int32)
Keyoti RapidSpell Silverlight
Moves the bad word position by delta
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Shift(
    int delta
)
Public Overridable Sub Shift ( _
    delta As Integer _
)
public:
virtual void Shift(
    int delta
)
Parameters
delta (Int32)


BrowsableAttribute Class

BrowsableAttribute Class
API ► Keyoti.RapidSpell ► BrowsableAttribute
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public class BrowsableAttribute : Attribute
Public Class BrowsableAttribute _
    Inherits Attribute
public ref class BrowsableAttribute : public Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BrowsableAttribute(Boolean) |
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | BrowsableAttribute


BrowsableAttribute Constructor (b)

BrowsableAttribute Constructor (b)
API ► Keyoti.RapidSpell ► BrowsableAttribute ► BrowsableAttribute(Boolean)
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public BrowsableAttribute(
    bool b
)
Public Sub New ( _
    b As Boolean _
)
public:
BrowsableAttribute(
    bool b
)
Parameters
b (Boolean)


CancelEventArgs Class

CancelEventArgs Class
API ► Keyoti.RapidSpell ► CancelEventArgs
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public class CancelEventArgs : EventArgs
Public Class CancelEventArgs _
    Inherits EventArgs
public ref class CancelEventArgs : public EventArgs
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CancelEventArgs()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | CancelEventArgs


CancelEventArgs Constructor

CancelEventArgs Constructor
API ► Keyoti.RapidSpell ► CancelEventArgs ► CancelEventArgs()()()
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public CancelEventArgs()
Public Sub New
public:
CancelEventArgs()


CheckerEngineAdapter Class

CheckerEngineAdapter Class
API ► Keyoti.RapidSpell ► CheckerEngineAdapter
Keyoti RapidSpell Silverlight
Abstract base implementation of ICheckerEngine, override chosen members for desired functionality.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class CheckerEngineAdapter : ICheckerEngine
Public MustInherit Class CheckerEngineAdapter _
    Implements ICheckerEngine
public ref class CheckerEngineAdapter abstract : ICheckerEngine
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CheckerEngineAdapter()()() |
 | AddWord(String) | Adds a word to the user dictionary, if it exists.
 | AllowAnyCase | Whether to allow words spelt with any case, eg. "africa" instead of "Africa", this is more relaxed than AllowMixedCase.
 | AllowMixedCase | Whether to allow words spelt with mixed case, eg. "MIxEd"
 | ChangeBadWord(String) | Changes the current bad word to newWord in the text.
 | ChangeBadWord(BadWord, String) | Changes badWord to newWord in the text.
 | Check(String) | Checks the text for errors.
 | Check(String, Boolean) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
 | CheckCompoundWords | Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
 | CurrentBadWord | Gets the current bad word (last returned by NextBadWord).
 | DictFilePath | The file to be used as the main dictionary, if this is null then the RapidSpellMDict.DLL satellite assembly is used.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindCapitalizedSuggestions | Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
 | FindSuggestions()()() | Returns an ArrayList of Strings that are suitable suggestions for the current bad word (that is, the one last returned by NextBadWord()).
 | FindSuggestions(String) | Returns an ArrayList of Strings that are suitable suggestions for word.
 | GetConsiderationRange()()() | Gets the factor for words to consider for suggestions.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIgnoreCapitalizedWords()()() | Gets whether to ignore words that start with capital letters.
 | GetIncludeUserDictionaryInSuggestions()()() | Gets whether the user dictionary should be used in finding suggestions for misspelt words.
 | GetSuggestionsMethod()()() | Sets the suggestions method, where method is an integer identifier.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUndoableStatePoint()()() | Returns null as undo is not supported
 | IgnoreAll(String) | Marks word to be ignored in rest of the text.
 | IgnoreIncorrectSentenceCapitalization | Whether to ignore incorrect sentence capitalization.
 | IgnoreInEnglishLowerCaseI | Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
 | IgnoreList | The words to ignore, note this list is changed by IgnoreAll.
 | IgnoreURLsAndEmailAddresses | Whether to ignore URLs and email addresses (requires V2Parser=true)
 | IgnoreWordsWithDigits | Whether to ignore words with numbers in them (eg. A10 or 7-11).
 | IgnoreXML | Whether to ignore XML tags in the text.
 | LanguageParser | The type of language parsing to use.
 | LookIntoHyphenatedText | Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
 | LookUp(String) | Looks up word in the dictionary, returns true if it is in there.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NextBadWord()()() | Gets the next bad word in the list that was identified by Check.
 | RevertToUndoableStatePoint(RapidSpellChecker..::.State) | Throws NotImplementedException
 | SetConsiderationRange(Int32) | Sets the breadth of the suggestions search.
 | SetDictFileStream(Stream, String) | Passes a Dict file as a stream, to be used for the main dictionary.
 | SetIgnoreCapitalizedWords(Boolean) | Sets whether to ignore capitalized words.
 | SetIncludeUserDictionaryInSuggestions(Boolean) | Sets whether to include the user dictionary in suggestions taken from this engine.
 | SetOptionalContext(String, String) | Provides the engine with any helpful text around the text snippet which will be passed to the Check method. Implementation is not required.
 | SetPosition(Int32) | Sets the pointer position for the NextBadWord iterator.
 | SetSeparateHyphenWords(Boolean) | Sets whether to separate words with hyphens in them into separate words.
 | SetSuggestionsMethod(Int32) | Sets the suggestions method, where method is an integer identifier.
 | SetUserDictionary(UserDictionary) | Sets the UserDictionary object to be used as a user dictionary source.
 | SetUserDictionary(String) | Sets the UserDictionary file path to be used as a user dictionary source.
 | SuggestSplitWords | Whether to look for connected words in suggestions.
 | TextBoundary | The AdvancedTextBoundary class to use to parse words.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UnloadMainDictionary()()() | Empties the main dictionary store.
 | userDictionary | The user dictionary, this should be null (C#) or nothing (VB.NET) if no user dictionary is being used.
 | V2Parser | Whether to use parser version 2
 | WarnDuplicates | Whether to treat duplicate words as errors (eg. "this is is an error").
 | WordAdded | Fires when a word is added
Remarks
None of the members contained in this class do anything.
Inheritance Hierarchy
Object
CheckerEngineAdapter


CheckerEngineAdapter Constructor

CheckerEngineAdapter Constructor
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► CheckerEngineAdapter()()()
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
protected CheckerEngineAdapter()
Protected Sub New
protected:
CheckerEngineAdapter()


AddWord Method (word)

AddWord Method (word)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► AddWord(String)
Keyoti RapidSpell Silverlight
Adds a word to the user dictionary, if it exists.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool AddWord(
    string word
)
Public Overridable Function AddWord ( _
    word As String _
) As Boolean
public:
virtual bool AddWord(
    String^ word
)
Parameters
word (String)
Return Value
This implementation always returns false.
Remarks
Should return true if the word was added successfully, false otherwise.


AllowAnyCase Property

AllowAnyCase Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► AllowAnyCase
Keyoti RapidSpell Silverlight
Whether to allow words spelt with any case, eg. "africa" instead of "Africa", this is more relaxed than AllowMixedCase.
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowAnyCase { get; set; }
Public Property AllowAnyCase As Boolean
public:
virtual property bool AllowAnyCase {
    bool get () sealed;
    void set (bool value) sealed;
}


AllowMixedCase Property

AllowMixedCase Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► AllowMixedCase
Keyoti RapidSpell Silverlight
Whether to allow words spelt with mixed case, eg. "MIxEd"
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool AllowMixedCase { get; set; }
Public Overridable Property AllowMixedCase As Boolean
public:
virtual property bool AllowMixedCase {
    bool get ();
    void set (bool value);
}


ChangeBadWord Method

ChangeBadWord Method
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► ChangeBadWord()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | ChangeBadWord(String) | Changes the current bad word to newWord in the text.
 | ChangeBadWord(BadWord, String) | Changes badWord to newWord in the text.


ChangeBadWord Method (badWord, newWord)

ChangeBadWord Method (badWord, newWord)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► ChangeBadWord(BadWord, String)
Keyoti RapidSpell Silverlight
Changes badWord to newWord in the text.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void ChangeBadWord(
    BadWord badWord,
    string newWord
)
Public Overridable Sub ChangeBadWord ( _
    badWord As BadWord, _
    newWord As String _
)
public:
virtual void ChangeBadWord(
    BadWord^ badWord,
    String^ newWord
)
Parameters
badWord (BadWord)
the bad word to replace
newWord (String)
replaces the current misspelt word.
Return Value
void
Exceptions
Exception | Condition
ArgumentNullException | if newWord parameter is null.


ChangeBadWord Method (newWord)

ChangeBadWord Method (newWord)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► ChangeBadWord(String)
Keyoti RapidSpell Silverlight
Changes the current bad word to newWord in the text.
Declaration Syntax
C# Visual Basic Visual C++
public void ChangeBadWord(
    string newWord
)
Public Sub ChangeBadWord ( _
    newWord As String _
)
public:
virtual void ChangeBadWord(
    String^ newWord
) sealed
Parameters
newWord (String)
replaces the current misspelt word.
Return Value
void
Exceptions
Exception | Condition
NoCurrentBadWordException | if nextBadWord() hasn't been run first AND found an erroneous word.
ArgumentNullException | if newWord parameter is null.


Check Method

Check Method
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► Check()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | Check(String) | Checks the text for errors.
 | Check(String, Boolean) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.


Check Method (text)

Check Method (text)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► Check(String)
Keyoti RapidSpell Silverlight
Checks the text for errors.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Check(
    string text
)
Public Overridable Sub Check ( _
    text As String _
)
public:
virtual void Check(
    String^ text
)
Parameters
text (String)
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


Check Method (text, isStartOfTextBody)

Check Method (text, isStartOfTextBody)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► Check(String, Boolean)
Keyoti RapidSpell Silverlight
Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
Declaration Syntax
C# Visual Basic Visual C++
public void Check(
    string text,
    bool isStartOfTextBody
)
Public Sub Check ( _
    text As String, _
    isStartOfTextBody As Boolean _
)
public:
virtual void Check(
    String^ text,
    bool isStartOfTextBody
) sealed
Parameters
text (String)
to spell check.
isStartOfTextBody (Boolean)
whether the text being spell checked is at the start of the text body (eg. start of text box), this affects sentence capitalization determination.
Return Value
void
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


CheckCompoundWords Property

CheckCompoundWords Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► CheckCompoundWords
Keyoti RapidSpell Silverlight
Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool CheckCompoundWords { get; set; }
Public Overridable Property CheckCompoundWords As Boolean
public:
virtual property bool CheckCompoundWords {
    bool get ();
    void set (bool value);
}
Remarks
If this=false then LookUp("thesewordsarejoined") = false

If this=true then LookUp("thesewordsarejoined") = true

If this=false then LookUp("abcdef") = false

If this=true then LookUp("abcdef") = false

Setting this to true will degrade lookup performance


CurrentBadWord Property

CurrentBadWord Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► CurrentBadWord
Keyoti RapidSpell Silverlight
Gets the current bad word (last returned by NextBadWord).
Declaration Syntax
C# Visual Basic Visual C++
public virtual BadWord CurrentBadWord { get; }
Public Overridable ReadOnly Property CurrentBadWord As BadWord
public:
virtual property BadWord^ CurrentBadWord {
    BadWord^ get ();
}


DictFilePath Property

DictFilePath Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► DictFilePath
Keyoti RapidSpell Silverlight
The file to be used as the main dictionary, if this is null then the RapidSpellMDict.DLL satellite assembly is used.
Declaration Syntax
C# Visual Basic Visual C++
public virtual string DictFilePath { get; set; }
Public Overridable Property DictFilePath As String
public:
virtual property String^ DictFilePath {
    String^ get ();
    void set (String^ value);
}
Return Value
This implementation always returns null.


FindCapitalizedSuggestions Property

FindCapitalizedSuggestions Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► FindCapitalizedSuggestions
Keyoti RapidSpell Silverlight
Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
Declaration Syntax
C# Visual Basic Visual C++
public bool FindCapitalizedSuggestions { get; set; }
Public Property FindCapitalizedSuggestions As Boolean
public:
virtual property bool FindCapitalizedSuggestions {
    bool get () sealed;
    void set (bool value) sealed;
}


FindSuggestions Method

FindSuggestions Method
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► FindSuggestions()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | FindSuggestions()()() | Returns an ArrayList of Strings that are suitable suggestions for the current bad word (that is, the one last returned by NextBadWord()).
 | FindSuggestions(String) | Returns an ArrayList of Strings that are suitable suggestions for word.


FindSuggestions Method

FindSuggestions Method
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► FindSuggestions()()()
Keyoti RapidSpell Silverlight
Returns an ArrayList of Strings that are suitable suggestions for the current bad word (that is, the one last returned by NextBadWord()).
Declaration Syntax
C# Visual Basic Visual C++
public virtual ArrayList FindSuggestions()
Public Overridable Function FindSuggestions As ArrayList
public:
virtual ArrayList^ FindSuggestions()
Return Value
An empty ArrayList
Remarks
If no suggestions can be found, this should return an empty ArrayList. This method should be thread safe if operating with RapidSpell Desktop.
Exceptions
Exception | Condition
NoCurrentBadWordException | If NextBadWord() hasn't been run first AND found an erroneous word.


FindSuggestions Method (word)

FindSuggestions Method (word)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► FindSuggestions(String)
Keyoti RapidSpell Silverlight
Returns an ArrayList of Strings that are suitable suggestions for word.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ArrayList FindSuggestions(
    string word
)
Public Overridable Function FindSuggestions ( _
    word As String _
) As ArrayList
public:
virtual ArrayList^ FindSuggestions(
    String^ word
)
Parameters
word (String)
Return Value
An empty ArrayList
Remarks
If no suggestions can be found, this should return an empty ArrayList. This method should be thread safe if operating with RapidSpell Desktop.


GetConsiderationRange Method

GetConsiderationRange Method
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► GetConsiderationRange()()()
Keyoti RapidSpell Silverlight
Gets the factor for words to consider for suggestions.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int GetConsiderationRange()
Public Overridable Function GetConsiderationRange As Integer
public:
virtual int GetConsiderationRange()
Return Value
This implementation always returns 0.


GetIgnoreCapitalizedWords Method

GetIgnoreCapitalizedWords Method
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► GetIgnoreCapitalizedWords()()()
Keyoti RapidSpell Silverlight
Gets whether to ignore words that start with capital letters.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool GetIgnoreCapitalizedWords()
Public Overridable Function GetIgnoreCapitalizedWords As Boolean
public:
virtual bool GetIgnoreCapitalizedWords()
Return Value
This implementation always returns false.


GetIncludeUserDictionaryInSuggestions Method

GetIncludeUserDictionaryInSuggestions Method
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► GetIncludeUserDictionaryInSuggestions()()()
Keyoti RapidSpell Silverlight
Gets whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool GetIncludeUserDictionaryInSuggestions()
Public Overridable Function GetIncludeUserDictionaryInSuggestions As Boolean
public:
virtual bool GetIncludeUserDictionaryInSuggestions()
Return Value
This implementation always returns false.


GetSuggestionsMethod Method

GetSuggestionsMethod Method
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► GetSuggestionsMethod()()()
Keyoti RapidSpell Silverlight
Sets the suggestions method, where method is an integer identifier.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int GetSuggestionsMethod()
Public Overridable Function GetSuggestionsMethod As Integer
public:
virtual int GetSuggestionsMethod()


GetUndoableStatePoint Method

GetUndoableStatePoint Method
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► GetUndoableStatePoint()()()
Keyoti RapidSpell Silverlight
Returns null as undo is not supported
Declaration Syntax
C# Visual Basic Visual C++
public virtual RapidSpellChecker..::.State GetUndoableStatePoint()
Public Overridable Function GetUndoableStatePoint As RapidSpellChecker..::.State
public:
virtual RapidSpellChecker..::.State^ GetUndoableStatePoint()
Return Value
Returns the current state, or null if not supporting undo.


IgnoreAll Method (word)

IgnoreAll Method (word)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► IgnoreAll(String)
Keyoti RapidSpell Silverlight
Marks word to be ignored in rest of the text.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void IgnoreAll(
    string word
)
Public Overridable Sub IgnoreAll ( _
    word As String _
)
public:
virtual void IgnoreAll(
    String^ word
)
Parameters
word (String)
to ignore
Return Value
void
Exceptions
Exception | Condition
ArgumentNullException | if word parameter is null.


IgnoreIncorrectSentenceCapitalization Property

IgnoreIncorrectSentenceCapitalization Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► IgnoreIncorrectSentenceCapitalization
Keyoti RapidSpell Silverlight
Whether to ignore incorrect sentence capitalization.
Declaration Syntax
C# Visual Basic Visual C++
public bool IgnoreIncorrectSentenceCapitalization { get; set; }
Public Property IgnoreIncorrectSentenceCapitalization As Boolean
public:
virtual property bool IgnoreIncorrectSentenceCapitalization {
    bool get () sealed;
    void set (bool value) sealed;
}


IgnoreInEnglishLowerCaseI Property

IgnoreInEnglishLowerCaseI Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► IgnoreInEnglishLowerCaseI
Keyoti RapidSpell Silverlight
Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
Declaration Syntax
C# Visual Basic Visual C++
public bool IgnoreInEnglishLowerCaseI { get; set; }
Public Property IgnoreInEnglishLowerCaseI As Boolean
public:
virtual property bool IgnoreInEnglishLowerCaseI {
    bool get () sealed;
    void set (bool value) sealed;
}


IgnoreList Property

IgnoreList Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► IgnoreList
Keyoti RapidSpell Silverlight
The words to ignore, note this list is changed by IgnoreAll.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ArrayList IgnoreList { get; set; }
Public Overridable Property IgnoreList As ArrayList
public:
virtual property ArrayList^ IgnoreList {
    ArrayList^ get ();
    void set (ArrayList^ value);
}


IgnoreURLsAndEmailAddresses Property

IgnoreURLsAndEmailAddresses Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► IgnoreURLsAndEmailAddresses
Keyoti RapidSpell Silverlight
Whether to ignore URLs and email addresses (requires V2Parser=true)
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IgnoreURLsAndEmailAddresses { get; set; }
Public Overridable Property IgnoreURLsAndEmailAddresses As Boolean
public:
virtual property bool IgnoreURLsAndEmailAddresses {
    bool get ();
    void set (bool value);
}
Remarks
This will cause the following strings to be accepted as non-spelling errors;
"user@domain.com", "http://www.domain.com", "domain.co.uk" etc.


IgnoreWordsWithDigits Property

IgnoreWordsWithDigits Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► IgnoreWordsWithDigits
Keyoti RapidSpell Silverlight
Whether to ignore words with numbers in them (eg. A10 or 7-11).
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IgnoreWordsWithDigits { get; set; }
Public Overridable Property IgnoreWordsWithDigits As Boolean
public:
virtual property bool IgnoreWordsWithDigits {
    bool get ();
    void set (bool value);
}


IgnoreXML Property

IgnoreXML Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► IgnoreXML
Keyoti RapidSpell Silverlight
Whether to ignore XML tags in the text.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IgnoreXML { get; set; }
Public Overridable Property IgnoreXML As Boolean
public:
virtual property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
Return Value
This property is always false.


LanguageParser Property

LanguageParser Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► LanguageParser
Keyoti RapidSpell Silverlight
The type of language parsing to use.
Declaration Syntax
C# Visual Basic Visual C++
public virtual LanguageType LanguageParser { get; set; }
Public Overridable Property LanguageParser As LanguageType
public:
virtual property LanguageType LanguageParser {
    LanguageType get ();
    void set (LanguageType value);
}
Return Value
This implementation always returns RapidSpellChecker.LanguageParserType.ENGLISH.
Remarks
Eg. If the dictionary is set to French, you should use the French parser.


LookIntoHyphenatedText Property

LookIntoHyphenatedText Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► LookIntoHyphenatedText
Keyoti RapidSpell Silverlight
Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool LookIntoHyphenatedText { get; set; }
Public Overridable Property LookIntoHyphenatedText As Boolean
public:
virtual property bool LookIntoHyphenatedText {
    bool get ();
    void set (bool value);
}
Remarks
Eg. "socio-economic" will be checked as "socio" and "economic".


LookUp Method (word)

LookUp Method (word)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► LookUp(String)
Keyoti RapidSpell Silverlight
Looks up word in the dictionary, returns true if it is in there.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool LookUp(
    string word
)
Public Overridable Function LookUp ( _
    word As String _
) As Boolean
public:
virtual bool LookUp(
    String^ word
)
Parameters
word (String)


NextBadWord Method

NextBadWord Method
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► NextBadWord()()()
Keyoti RapidSpell Silverlight
Gets the next bad word in the list that was identified by Check.
Declaration Syntax
C# Visual Basic Visual C++
public virtual BadWord NextBadWord()
Public Overridable Function NextBadWord As BadWord
public:
virtual BadWord^ NextBadWord()
Return Value
This implementation always returns null.
Remarks
Check must be called before this method.


RevertToUndoableStatePoint Method (state)

RevertToUndoableStatePoint Method (state)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► RevertToUndoableStatePoint(RapidSpellChecker..::.State)
Keyoti RapidSpell Silverlight
Throws NotImplementedException
Declaration Syntax
C# Visual Basic Visual C++
public virtual void RevertToUndoableStatePoint(
    RapidSpellChecker..::.State state
)
Public Overridable Sub RevertToUndoableStatePoint ( _
    state As RapidSpellChecker..::.State _
)
public:
virtual void RevertToUndoableStatePoint(
    RapidSpellChecker..::.State^ state
)
Parameters
state (RapidSpellChecker..::.State)


SetConsiderationRange Method (range)

SetConsiderationRange Method (range)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetConsiderationRange(Int32)
Keyoti RapidSpell Silverlight
Sets the breadth of the suggestions search.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetConsiderationRange(
    int range
)
Public Overridable Sub SetConsiderationRange ( _
    range As Integer _
)
public:
virtual void SetConsiderationRange(
    int range
)
Parameters
range (Int32)


SetDictFileStream Method (dictFileStream, id)

SetDictFileStream Method (dictFileStream, id)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetDictFileStream(Stream, String)
Keyoti RapidSpell Silverlight
Passes a Dict file as a stream, to be used for the main dictionary.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetDictFileStream(
    Stream dictFileStream,
    string id
)
Public Overridable Sub SetDictFileStream ( _
    dictFileStream As Stream, _
    id As String _
)
public:
virtual void SetDictFileStream(
    Stream^ dictFileStream,
    String^ id
)
Parameters
dictFileStream (Stream)
The stream containing the dictionary
id (String)
Remarks
Note this method must be set before Check is called, and the stream position must be at beginning of Dict file. The stream is NOT closed by this method.


SetIgnoreCapitalizedWords Method (ignore)

SetIgnoreCapitalizedWords Method (ignore)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetIgnoreCapitalizedWords(Boolean)
Keyoti RapidSpell Silverlight
Sets whether to ignore capitalized words.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetIgnoreCapitalizedWords(
    bool ignore
)
Public Overridable Sub SetIgnoreCapitalizedWords ( _
    ignore As Boolean _
)
public:
virtual void SetIgnoreCapitalizedWords(
    bool ignore
)
Parameters
ignore (Boolean)


SetIncludeUserDictionaryInSuggestions Method (includeUserDictionaryInSuggestions)

SetIncludeUserDictionaryInSuggestions Method (includeUserDictionaryInSuggestions)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetIncludeUserDictionaryInSuggestions(Boolean)
Keyoti RapidSpell Silverlight
Sets whether to include the user dictionary in suggestions taken from this engine.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetIncludeUserDictionaryInSuggestions(
    bool includeUserDictionaryInSuggestions
)
Public Overridable Sub SetIncludeUserDictionaryInSuggestions ( _
    includeUserDictionaryInSuggestions As Boolean _
)
public:
virtual void SetIncludeUserDictionaryInSuggestions(
    bool includeUserDictionaryInSuggestions
)
Parameters
includeUserDictionaryInSuggestions (Boolean)


SetOptionalContext Method (beforeToCheckSnippet, afterToCheckSnippet)

SetOptionalContext Method (beforeToCheckSnippet, afterToCheckSnippet)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetOptionalContext(String, String)
Keyoti RapidSpell Silverlight
Provides the engine with any helpful text around the text snippet which will be passed to the Check method. Implementation is not required.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetOptionalContext(
    string beforeToCheckSnippet,
    string afterToCheckSnippet
)
Public Overridable Sub SetOptionalContext ( _
    beforeToCheckSnippet As String, _
    afterToCheckSnippet As String _
)
public:
virtual void SetOptionalContext(
    String^ beforeToCheckSnippet,
    String^ afterToCheckSnippet
)
Parameters
beforeToCheckSnippet (String)
Any text before the to check snippet
afterToCheckSnippet (String)
Any text after the snippet
Remarks
Eg. if the document contains "This is an an example piece." and Check will be called on "an example piece", then the fact that 'an' is duplicated will not be detected. Therefore, by passing "This is an " to beforeToCheckSnippet the checker will be able to detect that an is duplicated.


SetPosition Method (pos)

SetPosition Method (pos)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetPosition(Int32)
Keyoti RapidSpell Silverlight
Sets the pointer position for the NextBadWord iterator.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetPosition(
    int pos
)
Public Overridable Sub SetPosition ( _
    pos As Integer _
)
public:
virtual void SetPosition(
    int pos
)
Parameters
pos (Int32)
Remarks
Further calls to NextBadWord will look for the next bad word from position pos. If position > the text length it is set to the text length. If position < 0, it is set to zero.


SetSeparateHyphenWords Method (separate)

SetSeparateHyphenWords Method (separate)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetSeparateHyphenWords(Boolean)
Keyoti RapidSpell Silverlight
Sets whether to separate words with hyphens in them into separate words.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetSeparateHyphenWords(
    bool separate
)
Public Overridable Sub SetSeparateHyphenWords ( _
    separate As Boolean _
)
public:
virtual void SetSeparateHyphenWords(
    bool separate
)
Parameters
separate (Boolean)


SetSuggestionsMethod Method (method)

SetSuggestionsMethod Method (method)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetSuggestionsMethod(Int32)
Keyoti RapidSpell Silverlight
Sets the suggestions method, where method is an integer identifier.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetSuggestionsMethod(
    int method
)
Public Overridable Sub SetSuggestionsMethod ( _
    method As Integer _
)
public:
virtual void SetSuggestionsMethod(
    int method
)
Parameters
method (Int32)


SetUserDictionary Method

SetUserDictionary Method
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetUserDictionary()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | SetUserDictionary(UserDictionary) | Sets the UserDictionary object to be used as a user dictionary source.
 | SetUserDictionary(String) | Sets the UserDictionary file path to be used as a user dictionary source.


SetUserDictionary Method (userDictionary)

SetUserDictionary Method (userDictionary)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetUserDictionary(UserDictionary)
Keyoti RapidSpell Silverlight
Sets the UserDictionary object to be used as a user dictionary source.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetUserDictionary(
    UserDictionary userDictionary
)
Public Overridable Sub SetUserDictionary ( _
    userDictionary As UserDictionary _
)
public:
virtual void SetUserDictionary(
    UserDictionary^ userDictionary
)
Parameters
userDictionary (UserDictionary)


SetUserDictionary Method (userDictionary)

SetUserDictionary Method (userDictionary)
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetUserDictionary(String)
Keyoti RapidSpell Silverlight
Sets the UserDictionary file path to be used as a user dictionary source.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetUserDictionary(
    string userDictionary
)
Public Overridable Sub SetUserDictionary ( _
    userDictionary As String _
)
public:
virtual void SetUserDictionary(
    String^ userDictionary
)
Parameters
userDictionary (String)


SuggestSplitWords Property

SuggestSplitWords Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SuggestSplitWords
Keyoti RapidSpell Silverlight
Whether to look for connected words in suggestions.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool SuggestSplitWords { get; set; }
Public Overridable Property SuggestSplitWords As Boolean
public:
virtual property bool SuggestSplitWords {
    bool get ();
    void set (bool value);
}
Remarks
if this=true then suggestions may include joined words.

Eg; suggestions for "myhouse" will include "my house"


TextBoundary Property

TextBoundary Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► TextBoundary
Keyoti RapidSpell Silverlight
The AdvancedTextBoundary class to use to parse words.
Declaration Syntax
C# Visual Basic Visual C++
public AdvancedTextBoundary TextBoundary { get; set; }
Public Property TextBoundary As AdvancedTextBoundary
public:
virtual property AdvancedTextBoundary^ TextBoundary {
    AdvancedTextBoundary^ get () sealed;
    void set (AdvancedTextBoundary^ value) sealed;
}


UnloadMainDictionary Method

UnloadMainDictionary Method
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► UnloadMainDictionary()()()
Keyoti RapidSpell Silverlight
Empties the main dictionary store.
Declaration Syntax
C# Visual Basic Visual C++
public void UnloadMainDictionary()
Public Sub UnloadMainDictionary
public:
virtual void UnloadMainDictionary() sealed


userDictionary Property

userDictionary Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► userDictionary
Keyoti RapidSpell Silverlight
The user dictionary, this should be null (C#) or nothing (VB.NET) if no user dictionary is being used.
Declaration Syntax
C# Visual Basic Visual C++
public virtual UserDictionary userDictionary { get; }
Public Overridable ReadOnly Property userDictionary As UserDictionary
public:
virtual property UserDictionary^ userDictionary {
    UserDictionary^ get ();
}
Return Value
This implementation always returns null.


V2Parser Property

V2Parser Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► V2Parser
Keyoti RapidSpell Silverlight
Whether to use parser version 2
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool V2Parser { get; set; }
Public Overridable Property V2Parser As Boolean
public:
virtual property bool V2Parser {
    bool get ();
    void set (bool value);
}


WarnDuplicates Property

WarnDuplicates Property
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► WarnDuplicates
Keyoti RapidSpell Silverlight
Whether to treat duplicate words as errors (eg. "this is is an error").
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool WarnDuplicates { get; set; }
Public Overridable Property WarnDuplicates As Boolean
public:
virtual property bool WarnDuplicates {
    bool get ();
    void set (bool value);
}


WordAdded Event

WordAdded Event
API ► Keyoti.RapidSpell ► CheckerEngineAdapter ► WordAdded
Keyoti RapidSpell Silverlight
Fires when a word is added
Declaration Syntax
C# Visual Basic Visual C++
public event WordAddedEventHandler WordAdded
Public Event WordAdded As WordAddedEventHandler
public:
virtual  event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}


ComClientInteropSupport Class

ComClientInteropSupport Class
API ► Keyoti.RapidSpell ► ComClientInteropSupport
Keyoti RapidSpell Silverlight
This class supports users who access RapidSpell controls from COM code.
Declaration Syntax
C# Visual Basic Visual C++
public class ComClientInteropSupport
Public Class ComClientInteropSupport
public ref class ComClientInteropSupport
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ComClientInteropSupport()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Key | The COM support key (email support@keyoti.com for a key).
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
RapidSpell .NET, although completely written in .NET, can be used from COM, as per MS documented procedure. Please note that according to MS, not all containers are 'supported' http://support.microsoft.com/default.aspx?scid=KB;EN-US;311334
Inheritance Hierarchy
Object
ComClientInteropSupport


ComClientInteropSupport Constructor

ComClientInteropSupport Constructor
API ► Keyoti.RapidSpell ► ComClientInteropSupport ► ComClientInteropSupport()()()
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public ComClientInteropSupport()
Public Sub New
public:
ComClientInteropSupport()


Key Property

Key Property
API ► Keyoti.RapidSpell ► ComClientInteropSupport ► Key
Keyoti RapidSpell Silverlight
The COM support key (email support@keyoti.com for a key).
Declaration Syntax
C# Visual Basic Visual C++
public string Key { set; }
Public WriteOnly Property Key As String
public:
property String^ Key {
    void set (String^ value);
}


Component Class

Component Class
API ► Keyoti.RapidSpell ► Component
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public class Component
Public Class Component
public ref class Component
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Component()()() |
 | Dispose(Boolean) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Component
 |  | RapidSpellGUIPresenter


Component Constructor

Component Constructor
API ► Keyoti.RapidSpell ► Component ► Component()()()
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public Component()
Public Sub New
public:
Component()


Dispose Method (disposing)

Dispose Method (disposing)
API ► Keyoti.RapidSpell ► Component ► Dispose(Boolean)
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
)
Parameters
disposing (Boolean)


DesignableComponent Class

DesignableComponent Class
API ► Keyoti.RapidSpell ► DesignableComponent
Keyoti RapidSpell Silverlight
Base support for non-visual components.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class DesignableComponent : FrameworkElement
Public MustInherit Class DesignableComponent _
    Inherits FrameworkElement
public ref class DesignableComponent abstract : public FrameworkElement
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DesignableComponent(String, Double, Double) | New
 | ActualHeight | (Inherited from FrameworkElement.)
 | ActualWidth | (Inherited from FrameworkElement.)
 | AddHandler(RoutedEvent, Delegate, Boolean) | (Inherited from UIElement.)
 | AllowDrop | (Inherited from UIElement.)
 | Arrange(Rect) | (Inherited from UIElement.)
 | ArrangeOverride(Size) | (Inherited from FrameworkElement.)
 | BindingValidationError()()() | (Inherited from FrameworkElement.)
 | CacheMode()()() | (Inherited from UIElement.)
 | CaptureMouse()()() | (Inherited from UIElement.)
 | CheckAccess()()() | (Inherited from DependencyObject.)
 | ClearValue(DependencyProperty) | (Inherited from DependencyObject.)
 | Clip | (Inherited from UIElement.)
 | Cursor | (Inherited from FrameworkElement.)
 | DataContext | (Inherited from FrameworkElement.)
 | DesignMode | Whether control is in design mode
 | DesiredSize | (Inherited from UIElement.)
 | Dispatcher()()() | (Inherited from DependencyObject.)
 | DragEnter | (Inherited from UIElement.)
 | DragLeave | (Inherited from UIElement.)
 | DragOver | (Inherited from UIElement.)
 | Drop | (Inherited from UIElement.)
 | Effect()()() | (Inherited from UIElement.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindName(String) | (Inherited from FrameworkElement.)
 | FlowDirection | (Inherited from FrameworkElement.)
 | GetAnimationBaseValue(DependencyProperty) | (Inherited from DependencyObject.)
 | GetBindingExpression(DependencyProperty) | (Inherited from FrameworkElement.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(DependencyProperty) | (Inherited from DependencyObject.)
 | GotFocus | (Inherited from UIElement.)
 | Height | (Inherited from FrameworkElement.)
 | HorizontalAlignment | (Inherited from FrameworkElement.)
 | InvalidateArrange()()() | (Inherited from UIElement.)
 | InvalidateMeasure()()() | (Inherited from UIElement.)
 | IsHitTestVisible | (Inherited from UIElement.)
 | KeyDown | (Inherited from UIElement.)
 | KeyUp | (Inherited from UIElement.)
 | Language | (Inherited from FrameworkElement.)
 | LayoutUpdated()()() | (Inherited from FrameworkElement.)
 | Loaded | (Inherited from FrameworkElement.)
 | LostFocus | (Inherited from UIElement.)
 | LostMouseCapture | (Inherited from UIElement.)
 | ManipulationCompleted()()() | (Inherited from UIElement.)
 | ManipulationDelta()()() | (Inherited from UIElement.)
 | ManipulationStarted()()() | (Inherited from UIElement.)
 | Margin | (Inherited from FrameworkElement.)
 | MaxHeight | (Inherited from FrameworkElement.)
 | MaxWidth | (Inherited from FrameworkElement.)
 | Measure(Size) | (Inherited from UIElement.)
 | MeasureOverride(Size) | (Inherited from FrameworkElement.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinHeight | (Inherited from FrameworkElement.)
 | MinWidth | (Inherited from FrameworkElement.)
 | MouseEnter | (Inherited from UIElement.)
 | MouseLeave | (Inherited from UIElement.)
 | MouseLeftButtonDown | (Inherited from UIElement.)
 | MouseLeftButtonUp | (Inherited from UIElement.)
 | MouseMove | (Inherited from UIElement.)
 | MouseRightButtonDown | (Inherited from UIElement.)
 | MouseRightButtonUp | (Inherited from UIElement.)
 | MouseWheel | (Inherited from UIElement.)
 | Name | (Inherited from FrameworkElement.)
 | OnApplyTemplate()()() | (Inherited from FrameworkElement.)
 | OnCreateAutomationPeer()()() | (Inherited from UIElement.)
 | Opacity | (Inherited from UIElement.)
 | OpacityMask | (Inherited from UIElement.)
 | Parent | (Inherited from FrameworkElement.)
 | Projection()()() | (Inherited from UIElement.)
 | ReadLocalValue(DependencyProperty) | (Inherited from DependencyObject.)
 | ReleaseMouseCapture()()() | (Inherited from UIElement.)
 | RemoveHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
 | RenderSize | (Inherited from UIElement.)
 | RenderTransform | (Inherited from UIElement.)
 | RenderTransformOrigin | (Inherited from UIElement.)
 | Resources | (Inherited from FrameworkElement.)
 | SetBinding(DependencyProperty, Binding) | (Inherited from FrameworkElement.)
 | SetValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
 | SizeChanged | (Inherited from FrameworkElement.)
 | Style | (Inherited from FrameworkElement.)
 | Tag | (Inherited from FrameworkElement.)
 | TextInput | (Inherited from UIElement.)
 | TextInputStart()()() | (Inherited from UIElement.)
 | TextInputUpdate()()() | (Inherited from UIElement.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TransformToVisual(UIElement) | (Inherited from UIElement.)
 | Triggers | (Inherited from FrameworkElement.)
 | Unloaded | (Inherited from FrameworkElement.)
 | UpdateLayout()()() | (Inherited from UIElement.)
 | UseLayoutRounding()()() | (Inherited from UIElement.)
 | VerticalAlignment | (Inherited from FrameworkElement.)
 | Visibility | (Inherited from UIElement.)
 | Width | (Inherited from FrameworkElement.)
Inheritance Hierarchy
Object
 | DependencyObject
 |  | UIElement
 |  |  | FrameworkElement
 |  |  |  | DesignableComponent
 |  |  |  |  | RapidSpellDialog


DesignableComponent Constructor (label, width, height)

DesignableComponent Constructor (label, width, height)
API ► Keyoti.RapidSpell ► DesignableComponent ► DesignableComponent(String, Double, Double)
Keyoti RapidSpell Silverlight
New
Declaration Syntax
C# Visual Basic Visual C++
public DesignableComponent(
    string label,
    double width,
    double height
)
Public Sub New ( _
    label As String, _
    width As Double, _
    height As Double _
)
public:
DesignableComponent(
    String^ label,
    double width,
    double height
)
Parameters
label (String)
width (Double)
height (Double)


DesignMode Property

DesignMode Property
API ► Keyoti.RapidSpell ► DesignableComponent ► DesignMode
Keyoti RapidSpell Silverlight
Whether control is in design mode
Declaration Syntax
C# Visual Basic Visual C++
public bool DesignMode { get; }
Public ReadOnly Property DesignMode As Boolean
public:
property bool DesignMode {
    bool get ();
}


DesignerSerializationVisibility Enumeration

DesignerSerializationVisibility Enumeration
API ► Keyoti.RapidSpell ► DesignerSerializationVisibility
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public enum DesignerSerializationVisibility
Public Enumeration DesignerSerializationVisibility
public enum class DesignerSerializationVisibility
Members
Member | Description
Hidden |
Visible |


DesignerSerializationVisibilityAttribute Class

DesignerSerializationVisibilityAttribute Class
API ► Keyoti.RapidSpell ► DesignerSerializationVisibilityAttribute
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public class DesignerSerializationVisibilityAttribute : Attribute
Public Class DesignerSerializationVisibilityAttribute _
    Inherits Attribute
public ref class DesignerSerializationVisibilityAttribute : public Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility) |
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | DesignerSerializationVisibilityAttribute


DesignerSerializationVisibilityAttribute Constructor (v)

DesignerSerializationVisibilityAttribute Constructor (v)
API ► Keyoti.RapidSpell ► DesignerSerializationVisibilityAttribute ► DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility)
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public DesignerSerializationVisibilityAttribute(
    DesignerSerializationVisibility v
)
Public Sub New ( _
    v As DesignerSerializationVisibility _
)
public:
DesignerSerializationVisibilityAttribute(
    DesignerSerializationVisibility v
)
Parameters
v (DesignerSerializationVisibility)


DialogResult Enumeration

DialogResult Enumeration
API ► Keyoti.RapidSpell ► DialogResult
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public enum DialogResult
Public Enumeration DialogResult
public enum class DialogResult
Members
Member | Description
OK |
Cancel |
Yes |


DialogTexts Class

DialogTexts Class
API ► Keyoti.RapidSpell ► DialogTexts
Keyoti RapidSpell Silverlight
Contains all texts in RapidSpellDialog and user options.
Declaration Syntax
C# Visual Basic Visual C++
public class DialogTexts
Public Class DialogTexts
public ref class DialogTexts
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DialogTexts()()() |
 | AddButtonText | Add button text.
 | ApplyLanguage(LanguageType, LanguageType) | Applies text settings
 | ApplyTo(IUserInterfaceFormPresenter) | Applies text settings
 | ApplyTo(IDialogViewUserDictionaryEdit) | Applies text settings
 | ApplyTo(IDialogViewOptions) | Applies text settings
 | CancelButtonText | Cancel button text.
 | ChangeAllButtonText | Change All button text.
 | ChangeButtonText | Change button text.
 | CheckCompletePopUpText | Check complete pop up text
 | CheckCompletePopUpTitle | Check complete pop up title
 | CheckingSpellingText | Checking spelling text
 | DialogTitleText | Dialog title text
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindingSuggestionsLabelText | Finding suggestions label text.
 | FindSuggestionsLabelText | Find suggestions label text.
 | FinishedCheckingSelectionPopUpText | Finished checking selection dialog text
 | FinishedCheckingSelectionPopUpTitle | Finished checking selection dialog title
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IgnoreAllButtonText | Ignore All button text.
 | IgnoreButtonText | Ignore button text.
 | InDictionaryLabelText | In dictionary label text
 | LoadingDictionaryText | UI Text
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NoSuggestionsText | No suggestions found text
 | NotInDictionaryLabelText | Not in dictionary label text
 | OptionsButtonText | Options button text.
 | OptionsFormAdvancedSettingsText | UI Text
 | OptionsFormAlwaysSuggestCorrectionsText | UI Text
 | OptionsFormBasicSettingsText | UI Text
 | OptionsFormCancelText | UI Text
 | OptionsFormCheckAsYouTypeText | UI Text
 | OptionsFormIgnoreImproperCaseText | UI Text
 | OptionsFormIgnoreInternetAddressesText | UI Text
 | OptionsFormIgnoreWordsInUppercaseText | UI Text
 | OptionsFormIgnoreWordsWithNumbersText | UI Text
 | OptionsFormOKText | UI Text
 | OptionsFormRecheckTextText | UI Text
 | OptionsFormSuggestFromMainDictionaryOnlyText | UI Text
 | OptionsFormTitleText | UI Text
 | OptionsFormUserDictionaryEditText | UI Text
 | RemoveDuplicateWordText | Remove duplicate word text
 | ResetText | Used at design time to reset UI text.
 | ResumeButtonText | Resume button text
 | SuggestionsLabelText | Suggestions label text
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UndoButtonText | Undo button text.
 | UserDictionaryFormAddText | UI Text
 | UserDictionaryFormCancelText | UI Text
 | UserDictionaryFormContentsText | UI Text
 | UserDictionaryFormDeleteText | UI Text
 | UserDictionaryFormDictionaryLabelText | UI Text
 | UserDictionaryFormOKText | UI Text
 | UserDictionaryFormTitleText | UI Text
 | UserDictionaryFormWordLabelText | UI Text
Inheritance Hierarchy
Object
DialogTexts


DialogTexts Constructor

DialogTexts Constructor
API ► Keyoti.RapidSpell ► DialogTexts ► DialogTexts()()()
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public DialogTexts()
Public Sub New
public:
DialogTexts()


AddButtonText Property

AddButtonText Property
API ► Keyoti.RapidSpell ► DialogTexts ► AddButtonText
Keyoti RapidSpell Silverlight
Add button text.
Declaration Syntax
C# Visual Basic Visual C++
public string AddButtonText { get; set; }
Public Property AddButtonText As String
public:
property String^ AddButtonText {
    String^ get ();
    void set (String^ value);
}


ApplyLanguage Method (newlang, oldlang)

ApplyLanguage Method (newlang, oldlang)
API ► Keyoti.RapidSpell ► DialogTexts ► ApplyLanguage(LanguageType, LanguageType)
Keyoti RapidSpell Silverlight
Applies text settings
Declaration Syntax
C# Visual Basic Visual C++
public void ApplyLanguage(
    LanguageType newlang,
    LanguageType oldlang
)
Public Sub ApplyLanguage ( _
    newlang As LanguageType, _
    oldlang As LanguageType _
)
public:
void ApplyLanguage(
    LanguageType newlang,
    LanguageType oldlang
)
Parameters
newlang (LanguageType)
oldlang (LanguageType)


ApplyTo Method

ApplyTo Method
API ► Keyoti.RapidSpell ► DialogTexts ► ApplyTo()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | ApplyTo(IUserInterfaceFormPresenter) | Applies text settings
 | ApplyTo(IDialogViewUserDictionaryEdit) | Applies text settings
 | ApplyTo(IDialogViewOptions) | Applies text settings


ApplyTo Method (o)

ApplyTo Method (o)
API ► Keyoti.RapidSpell ► DialogTexts ► ApplyTo(IDialogViewOptions)
Keyoti RapidSpell Silverlight
Applies text settings
Declaration Syntax
C# Visual Basic Visual C++
public void ApplyTo(
    IDialogViewOptions o
)
Public Sub ApplyTo ( _
    o As IDialogViewOptions _
)
public:
void ApplyTo(
    IDialogViewOptions^ o
)
Parameters
o (IDialogViewOptions)


ApplyTo Method (o)

ApplyTo Method (o)
API ► Keyoti.RapidSpell ► DialogTexts ► ApplyTo(IDialogViewUserDictionaryEdit)
Keyoti RapidSpell Silverlight
Applies text settings
Declaration Syntax
C# Visual Basic Visual C++
public void ApplyTo(
    IDialogViewUserDictionaryEdit o
)
Public Sub ApplyTo ( _
    o As IDialogViewUserDictionaryEdit _
)
public:
void ApplyTo(
    IDialogViewUserDictionaryEdit^ o
)
Parameters
o (IDialogViewUserDictionaryEdit)


ApplyTo Method (rs)

ApplyTo Method (rs)
API ► Keyoti.RapidSpell ► DialogTexts ► ApplyTo(IUserInterfaceFormPresenter)
Keyoti RapidSpell Silverlight
Applies text settings
Declaration Syntax
C# Visual Basic Visual C++
public void ApplyTo(
    IUserInterfaceFormPresenter rs
)
Public Sub ApplyTo ( _
    rs As IUserInterfaceFormPresenter _
)
public:
void ApplyTo(
    IUserInterfaceFormPresenter^ rs
)
Parameters
rs (IUserInterfaceFormPresenter)


CancelButtonText Property

CancelButtonText Property
API ► Keyoti.RapidSpell ► DialogTexts ► CancelButtonText
Keyoti RapidSpell Silverlight
Cancel button text.
Declaration Syntax
C# Visual Basic Visual C++
public string CancelButtonText { get; set; }
Public Property CancelButtonText As String
public:
property String^ CancelButtonText {
    String^ get ();
    void set (String^ value);
}


ChangeAllButtonText Property

ChangeAllButtonText Property
API ► Keyoti.RapidSpell ► DialogTexts ► ChangeAllButtonText
Keyoti RapidSpell Silverlight
Change All button text.
Declaration Syntax
C# Visual Basic Visual C++
public string ChangeAllButtonText { get; set; }
Public Property ChangeAllButtonText As String
public:
property String^ ChangeAllButtonText {
    String^ get ();
    void set (String^ value);
}


ChangeButtonText Property

ChangeButtonText Property
API ► Keyoti.RapidSpell ► DialogTexts ► ChangeButtonText
Keyoti RapidSpell Silverlight
Change button text.
Declaration Syntax
C# Visual Basic Visual C++
public string ChangeButtonText { get; set; }
Public Property ChangeButtonText As String
public:
property String^ ChangeButtonText {
    String^ get ();
    void set (String^ value);
}


CheckCompletePopUpText Property

CheckCompletePopUpText Property
API ► Keyoti.RapidSpell ► DialogTexts ► CheckCompletePopUpText
Keyoti RapidSpell Silverlight
Check complete pop up text
Declaration Syntax
C# Visual Basic Visual C++
public string CheckCompletePopUpText { get; set; }
Public Property CheckCompletePopUpText As String
public:
property String^ CheckCompletePopUpText {
    String^ get ();
    void set (String^ value);
}


CheckCompletePopUpTitle Property

CheckCompletePopUpTitle Property
API ► Keyoti.RapidSpell ► DialogTexts ► CheckCompletePopUpTitle
Keyoti RapidSpell Silverlight
Check complete pop up title
Declaration Syntax
C# Visual Basic Visual C++
public string CheckCompletePopUpTitle { get; set; }
Public Property CheckCompletePopUpTitle As String
public:
property String^ CheckCompletePopUpTitle {
    String^ get ();
    void set (String^ value);
}


CheckingSpellingText Property

CheckingSpellingText Property
API ► Keyoti.RapidSpell ► DialogTexts ► CheckingSpellingText
Keyoti RapidSpell Silverlight
Checking spelling text
Declaration Syntax
C# Visual Basic Visual C++
public string CheckingSpellingText { get; set; }
Public Property CheckingSpellingText As String
public:
property String^ CheckingSpellingText {
    String^ get ();
    void set (String^ value);
}


DialogTitleText Property

DialogTitleText Property
API ► Keyoti.RapidSpell ► DialogTexts ► DialogTitleText
Keyoti RapidSpell Silverlight
Dialog title text
Declaration Syntax
C# Visual Basic Visual C++
public string DialogTitleText { get; set; }
Public Property DialogTitleText As String
public:
property String^ DialogTitleText {
    String^ get ();
    void set (String^ value);
}


FindingSuggestionsLabelText Property

FindingSuggestionsLabelText Property
API ► Keyoti.RapidSpell ► DialogTexts ► FindingSuggestionsLabelText
Keyoti RapidSpell Silverlight
Finding suggestions label text.
Declaration Syntax
C# Visual Basic Visual C++
public string FindingSuggestionsLabelText { get; set; }
Public Property FindingSuggestionsLabelText As String
public:
property String^ FindingSuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}


FindSuggestionsLabelText Property

FindSuggestionsLabelText Property
API ► Keyoti.RapidSpell ► DialogTexts ► FindSuggestionsLabelText
Keyoti RapidSpell Silverlight
Find suggestions label text.
Declaration Syntax
C# Visual Basic Visual C++
public string FindSuggestionsLabelText { get; set; }
Public Property FindSuggestionsLabelText As String
public:
property String^ FindSuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}


FinishedCheckingSelectionPopUpText Property

FinishedCheckingSelectionPopUpText Property
API ► Keyoti.RapidSpell ► DialogTexts ► FinishedCheckingSelectionPopUpText
Keyoti RapidSpell Silverlight
Finished checking selection dialog text
Declaration Syntax
C# Visual Basic Visual C++
public string FinishedCheckingSelectionPopUpText { get; set; }
Public Property FinishedCheckingSelectionPopUpText As String
public:
property String^ FinishedCheckingSelectionPopUpText {
    String^ get ();
    void set (String^ value);
}


FinishedCheckingSelectionPopUpTitle Property

FinishedCheckingSelectionPopUpTitle Property
API ► Keyoti.RapidSpell ► DialogTexts ► FinishedCheckingSelectionPopUpTitle
Keyoti RapidSpell Silverlight
Finished checking selection dialog title
Declaration Syntax
C# Visual Basic Visual C++
public string FinishedCheckingSelectionPopUpTitle { get; set; }
Public Property FinishedCheckingSelectionPopUpTitle As String
public:
property String^ FinishedCheckingSelectionPopUpTitle {
    String^ get ();
    void set (String^ value);
}


IgnoreAllButtonText Property

IgnoreAllButtonText Property
API ► Keyoti.RapidSpell ► DialogTexts ► IgnoreAllButtonText
Keyoti RapidSpell Silverlight
Ignore All button text.
Declaration Syntax
C# Visual Basic Visual C++
public string IgnoreAllButtonText { get; set; }
Public Property IgnoreAllButtonText As String
public:
property String^ IgnoreAllButtonText {
    String^ get ();
    void set (String^ value);
}


IgnoreButtonText Property

IgnoreButtonText Property
API ► Keyoti.RapidSpell ► DialogTexts ► IgnoreButtonText
Keyoti RapidSpell Silverlight
Ignore button text.
Declaration Syntax
C# Visual Basic Visual C++
public string IgnoreButtonText { get; set; }
Public Property IgnoreButtonText As String
public:
property String^ IgnoreButtonText {
    String^ get ();
    void set (String^ value);
}


InDictionaryLabelText Property

InDictionaryLabelText Property
API ► Keyoti.RapidSpell ► DialogTexts ► InDictionaryLabelText
Keyoti RapidSpell Silverlight
In dictionary label text
Declaration Syntax
C# Visual Basic Visual C++
public string InDictionaryLabelText { get; set; }
Public Property InDictionaryLabelText As String
public:
property String^ InDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}


LoadingDictionaryText Property

LoadingDictionaryText Property
API ► Keyoti.RapidSpell ► DialogTexts ► LoadingDictionaryText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
public string LoadingDictionaryText { get; set; }
Public Property LoadingDictionaryText As String
public:
property String^ LoadingDictionaryText {
    String^ get ();
    void set (String^ value);
}


NoSuggestionsText Property

NoSuggestionsText Property
API ► Keyoti.RapidSpell ► DialogTexts ► NoSuggestionsText
Keyoti RapidSpell Silverlight
No suggestions found text
Declaration Syntax
C# Visual Basic Visual C++
public string NoSuggestionsText { get; set; }
Public Property NoSuggestionsText As String
public:
property String^ NoSuggestionsText {
    String^ get ();
    void set (String^ value);
}


NotInDictionaryLabelText Property

NotInDictionaryLabelText Property
API ► Keyoti.RapidSpell ► DialogTexts ► NotInDictionaryLabelText
Keyoti RapidSpell Silverlight
Not in dictionary label text
Declaration Syntax
C# Visual Basic Visual C++
public string NotInDictionaryLabelText { get; set; }
Public Property NotInDictionaryLabelText As String
public:
property String^ NotInDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}


OptionsButtonText Property

OptionsButtonText Property
API ► Keyoti.RapidSpell ► DialogTexts ► OptionsButtonText
Keyoti RapidSpell Silverlight
Options button text.
Declaration Syntax
C# Visual Basic Visual C++
public string OptionsButtonText { get; set; }
Public Property OptionsButtonText As String
public:
property String^ OptionsButtonText {
    String^ get ();
    void set (String^ value);
}


OptionsFormAdvancedSettingsText Property

OptionsFormAdvancedSettingsText Property
API ► Keyoti.RapidSpell ► DialogTexts ► OptionsFormAdvancedSettingsText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
public string OptionsFormAdvancedSettingsText { get; set; }
Public Property OptionsFormAdvancedSettingsText As String
public:
property String^ OptionsFormAdvancedSettingsText {
    String^ get ();
    void set (String^ value);
}


OptionsFormAlwaysSuggestCorrectionsText Property

OptionsFormAlwaysSuggestCorrectionsText Property
API ► Keyoti.RapidSpell ► DialogTexts ► OptionsFormAlwaysSuggestCorrectionsText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
public string OptionsFormAlwaysSuggestCorrectionsText { get; set; }
Public Property OptionsFormAlwaysSuggestCorrectionsText As String
public:
property String^ OptionsFormAlwaysSuggestCorrectionsText {
    String^ get ();
    void set (String^ value);
}


OptionsFormBasicSettingsText Property

OptionsFormBasicSettingsText Property
API ► Keyoti.RapidSpell ► DialogTexts ► OptionsFormBasicSettingsText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
public string OptionsFormBasicSettingsText { get; set; }
Public Property OptionsFormBasicSettingsText As String
public:
property String^ OptionsFormBasicSettingsText {
    String^ get ();
    void set (String^ value);
}


OptionsFormCancelText Property

OptionsFormCancelText Property
API ► Keyoti.RapidSpell ► DialogTexts ► OptionsFormCancelText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
public string OptionsFormCancelText { get; set; }
Public Property OptionsFormCancelText As String
public:
property String^ OptionsFormCancelText {
    String^ get ();
    void set (String^ value);
}


OptionsFormCheckAsYouTypeText Property

OptionsFormCheckAsYouTypeText Property
API ► Keyoti.RapidSpell ► DialogTexts ► OptionsFormCheckAsYouTypeText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
public string OptionsFormCheckAsYouTypeText { get; set; }
Public Property OptionsFormCheckAsYouTypeText As String
public:
property String^ OptionsFormCheckAsYouTypeText {
    String^ get ();
    void set (String^ value);
}


OptionsFormIgnoreImproperCaseText Property

OptionsFormIgnoreImproperCaseText Property
API ► Keyoti.RapidSpell ► DialogTexts ► OptionsFormIgnoreImproperCaseText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
public string OptionsFormIgnoreImproperCaseText { get; set; }
Public Property OptionsFormIgnoreImproperCaseText As String
public:
property String^ OptionsFormIgnoreImproperCaseText {
    String^ get ();
    void set (String^ value);
}


OptionsFormIgnoreInternetAddressesText Property

OptionsFormIgnoreInternetAddressesText Property
API ► Keyoti.RapidSpell ► DialogTexts ► OptionsFormIgnoreInternetAddressesText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
public string OptionsFormIgnoreInternetAddressesText { get; set; }
Public Property OptionsFormIgnoreInternetAddressesText As String
public:
property String^ OptionsFormIgnoreInternetAddressesText {
    String^ get ();
    void set (String^ value);
}


OptionsFormIgnoreWordsInUppercaseText Property

OptionsFormIgnoreWordsInUppercaseText Property
API ► Keyoti.RapidSpell ► DialogTexts ► OptionsFormIgnoreWordsInUppercaseText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
public string OptionsFormIgnoreWordsInUppercaseText { get; set; }
Public Property OptionsFormIgnoreWordsInUppercaseText As String
public:
property String^ OptionsFormIgnoreWordsInUppercaseText {
    String^ get ();
    void set (String^ value);
}


OptionsFormIgnoreWordsWithNumbersText Property

OptionsFormIgnoreWordsWithNumbersText Property
API ► Keyoti.RapidSpell ► DialogTexts ► OptionsFormIgnoreWordsWithNumbersText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
public string OptionsFormIgnoreWordsWithNumbersText { get; set; }
Public Property OptionsFormIgnoreWordsWithNumbersText As String
public:
property String^ OptionsFormIgnoreWordsWithNumbersText {
    String^ get ();
    void set (String^ value);
}


OptionsFormOKText Property

OptionsFormOKText Property
API ► Keyoti.RapidSpell ► DialogTexts ► OptionsFormOKText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
public string OptionsFormOKText { get; set; }
Public Property OptionsFormOKText As String
public:
property String^ OptionsFormOKText {
    String^ get ();
    void set (String^ value);
}


OptionsFormRecheckTextText Property

OptionsFormRecheckTextText Property
API ► Keyoti.RapidSpell ► DialogTexts ► OptionsFormRecheckTextText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
public string OptionsFormRecheckTextText { get; set; }
Public Property OptionsFormRecheckTextText As String
public:
property String^ OptionsFormRecheckTextText {
    String^ get ();
    void set (String^ value);
}


OptionsFormSuggestFromMainDictionaryOnlyText Property

OptionsFormSuggestFromMainDictionaryOnlyText Property
API ► Keyoti.RapidSpell ► DialogTexts ► OptionsFormSuggestFromMainDictionaryOnlyText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
public string OptionsFormSuggestFromMainDictionaryOnlyText { get; set; }
Public Property OptionsFormSuggestFromMainDictionaryOnlyText As String
public:
property String^ OptionsFormSuggestFromMainDictionaryOnlyText {
    String^ get ();
    void set (String^ value);
}


OptionsFormTitleText Property

OptionsFormTitleText Property
API ► Keyoti.RapidSpell ► DialogTexts ► OptionsFormTitleText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
public string OptionsFormTitleText { get; set; }
Public Property OptionsFormTitleText As String
public:
property String^ OptionsFormTitleText {
    String^ get ();
    void set (String^ value);
}


OptionsFormUserDictionaryEditText Property

OptionsFormUserDictionaryEditText Property
API ► Keyoti.RapidSpell ► DialogTexts ► OptionsFormUserDictionaryEditText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
public string OptionsFormUserDictionaryEditText { get; set; }
Public Property OptionsFormUserDictionaryEditText As String
public:
property String^ OptionsFormUserDictionaryEditText {
    String^ get ();
    void set (String^ value);
}


RemoveDuplicateWordText Property

RemoveDuplicateWordText Property
API ► Keyoti.RapidSpell ► DialogTexts ► RemoveDuplicateWordText
Keyoti RapidSpell Silverlight
Remove duplicate word text
Declaration Syntax
C# Visual Basic Visual C++
public string RemoveDuplicateWordText { get; set; }
Public Property RemoveDuplicateWordText As String
public:
property String^ RemoveDuplicateWordText {
    String^ get ();
    void set (String^ value);
}


ResetText Property

ResetText Property
API ► Keyoti.RapidSpell ► DialogTexts ► ResetText
Keyoti RapidSpell Silverlight
Used at design time to reset UI text.
Declaration Syntax
C# Visual Basic Visual C++
public bool ResetText { get; set; }
Public Property ResetText As Boolean
public:
property bool ResetText {
    bool get ();
    void set (bool value);
}


ResumeButtonText Property

ResumeButtonText Property
API ► Keyoti.RapidSpell ► DialogTexts ► ResumeButtonText
Keyoti RapidSpell Silverlight
Resume button text
Declaration Syntax
C# Visual Basic Visual C++
public string ResumeButtonText { get; set; }
Public Property ResumeButtonText As String
public:
property String^ ResumeButtonText {
    String^ get ();
    void set (String^ value);
}


SuggestionsLabelText Property

SuggestionsLabelText Property
API ► Keyoti.RapidSpell ► DialogTexts ► SuggestionsLabelText
Keyoti RapidSpell Silverlight
Suggestions label text
Declaration Syntax
C# Visual Basic Visual C++
public string SuggestionsLabelText { get; set; }
Public Property SuggestionsLabelText As String
public:
property String^ SuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}


UndoButtonText Property

UndoButtonText Property
API ► Keyoti.RapidSpell ► DialogTexts ► UndoButtonText
Keyoti RapidSpell Silverlight
Undo button text.
Declaration Syntax
C# Visual Basic Visual C++
public string UndoButtonText { get; set; }
Public Property UndoButtonText As String
public:
property String^ UndoButtonText {
    String^ get ();
    void set (String^ value);
}


UserDictionaryFormAddText Property

UserDictionaryFormAddText Property
API ► Keyoti.RapidSpell ► DialogTexts ► UserDictionaryFormAddText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
public string UserDictionaryFormAddText { get; set; }
Public Property UserDictionaryFormAddText As String
public:
property String^ UserDictionaryFormAddText {
    String^ get ();
    void set (String^ value);
}


UserDictionaryFormCancelText Property

UserDictionaryFormCancelText Property
API ► Keyoti.RapidSpell ► DialogTexts ► UserDictionaryFormCancelText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
public string UserDictionaryFormCancelText { get; set; }
Public Property UserDictionaryFormCancelText As String
public:
property String^ UserDictionaryFormCancelText {
    String^ get ();
    void set (String^ value);
}


UserDictionaryFormContentsText Property

UserDictionaryFormContentsText Property
API ► Keyoti.RapidSpell ► DialogTexts ► UserDictionaryFormContentsText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
public string UserDictionaryFormContentsText { get; set; }
Public Property UserDictionaryFormContentsText As String
public:
property String^ UserDictionaryFormContentsText {
    String^ get ();
    void set (String^ value);
}


UserDictionaryFormDeleteText Property

UserDictionaryFormDeleteText Property
API ► Keyoti.RapidSpell ► DialogTexts ► UserDictionaryFormDeleteText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
public string UserDictionaryFormDeleteText { get; set; }
Public Property UserDictionaryFormDeleteText As String
public:
property String^ UserDictionaryFormDeleteText {
    String^ get ();
    void set (String^ value);
}


UserDictionaryFormDictionaryLabelText Property

UserDictionaryFormDictionaryLabelText Property
API ► Keyoti.RapidSpell ► DialogTexts ► UserDictionaryFormDictionaryLabelText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
public string UserDictionaryFormDictionaryLabelText { get; set; }
Public Property UserDictionaryFormDictionaryLabelText As String
public:
property String^ UserDictionaryFormDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}


UserDictionaryFormOKText Property

UserDictionaryFormOKText Property
API ► Keyoti.RapidSpell ► DialogTexts ► UserDictionaryFormOKText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
public string UserDictionaryFormOKText { get; set; }
Public Property UserDictionaryFormOKText As String
public:
property String^ UserDictionaryFormOKText {
    String^ get ();
    void set (String^ value);
}


UserDictionaryFormTitleText Property

UserDictionaryFormTitleText Property
API ► Keyoti.RapidSpell ► DialogTexts ► UserDictionaryFormTitleText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
public string UserDictionaryFormTitleText { get; set; }
Public Property UserDictionaryFormTitleText As String
public:
property String^ UserDictionaryFormTitleText {
    String^ get ();
    void set (String^ value);
}


UserDictionaryFormWordLabelText Property

UserDictionaryFormWordLabelText Property
API ► Keyoti.RapidSpell ► DialogTexts ► UserDictionaryFormWordLabelText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
public string UserDictionaryFormWordLabelText { get; set; }
Public Property UserDictionaryFormWordLabelText As String
public:
property String^ UserDictionaryFormWordLabelText {
    String^ get ();
    void set (String^ value);
}


DictionaryCache Class

DictionaryCache Class
API ► Keyoti.RapidSpell ► DictionaryCache
Keyoti RapidSpell Silverlight
Cache of loaded dictionaries.
Declaration Syntax
C# Visual Basic Visual C++
public class DictionaryCache
Public Class DictionaryCache
public ref class DictionaryCache
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DictionaryCache()()() |
 | AddDictionary(SpellingDictionary) | Adds a dictionary to the cache.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDictionary(String) | Gets a dictionary from the cache.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemoveAllDictionaries()()() | Removes all dictionaries in the cache, they will be reloaded if needed later.
 | RemoveDictionary(String) | Removes a dictionary from the cache based on its filename.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DictionaryCache


DictionaryCache Constructor

DictionaryCache Constructor
API ► Keyoti.RapidSpell ► DictionaryCache ► DictionaryCache()()()
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public DictionaryCache()
Public Sub New
public:
DictionaryCache()


AddDictionary Method (dictionary)

AddDictionary Method (dictionary)
API ► Keyoti.RapidSpell ► DictionaryCache ► AddDictionary(SpellingDictionary)
Keyoti RapidSpell Silverlight
Adds a dictionary to the cache.
Declaration Syntax
C# Visual Basic Visual C++
public static void AddDictionary(
    SpellingDictionary dictionary
)
Public Shared Sub AddDictionary ( _
    dictionary As SpellingDictionary _
)
public:
static void AddDictionary(
    SpellingDictionary^ dictionary
)
Parameters
dictionary (SpellingDictionary)


GetDictionary Method (path)

GetDictionary Method (path)
API ► Keyoti.RapidSpell ► DictionaryCache ► GetDictionary(String)
Keyoti RapidSpell Silverlight
Gets a dictionary from the cache.
Declaration Syntax
C# Visual Basic Visual C++
public static SpellingDictionary GetDictionary(
    string path
)
Public Shared Function GetDictionary ( _
    path As String _
) As SpellingDictionary
public:
static SpellingDictionary^ GetDictionary(
    String^ path
)
Parameters
path (String)


RemoveAllDictionaries Method

RemoveAllDictionaries Method
API ► Keyoti.RapidSpell ► DictionaryCache ► RemoveAllDictionaries()()()
Keyoti RapidSpell Silverlight
Removes all dictionaries in the cache, they will be reloaded if needed later.
Declaration Syntax
C# Visual Basic Visual C++
public static void RemoveAllDictionaries()
Public Shared Sub RemoveAllDictionaries
public:
static void RemoveAllDictionaries()


RemoveDictionary Method (path)

RemoveDictionary Method (path)
API ► Keyoti.RapidSpell ► DictionaryCache ► RemoveDictionary(String)
Keyoti RapidSpell Silverlight
Removes a dictionary from the cache based on its filename.
Declaration Syntax
C# Visual Basic Visual C++
public static void RemoveDictionary(
    string path
)
Public Shared Sub RemoveDictionary ( _
    path As String _
)
public:
static void RemoveDictionary(
    String^ path
)
Parameters
path (String)
Path to the dictionary


DictionaryLoadException Class

DictionaryLoadException Class
API ► Keyoti.RapidSpell ► DictionaryLoadException
Keyoti RapidSpell Silverlight
Exception with dictionary loading.
Declaration Syntax
C# Visual Basic Visual C++
public class DictionaryLoadException : Exception
Public Class DictionaryLoadException _
    Inherits Exception
public ref class DictionaryLoadException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DictionaryLoadException(String, Exception) | New
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | DictionaryLoadException


DictionaryLoadException Constructor (message, inner)

DictionaryLoadException Constructor (message, inner)
API ► Keyoti.RapidSpell ► DictionaryLoadException ► DictionaryLoadException(String, Exception)
Keyoti RapidSpell Silverlight
New
Declaration Syntax
C# Visual Basic Visual C++
public DictionaryLoadException(
    string message,
    Exception inner
)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
public:
DictionaryLoadException(
    String^ message,
    Exception^ inner
)
Parameters
message (String)
inner (Exception)


Hashtable Class

Hashtable Class
API ► Keyoti.RapidSpell ► Hashtable
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public class Hashtable : Dictionary<Object, Object>
Public Class Hashtable _
    Inherits Dictionary(Of Object, Object)
public ref class Hashtable : public Dictionary<Object^, Object^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Hashtable()()() |
 | Add(TKey, TValue) | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <( Object, Object >)>).)
 | Clear()()() | Removes all keys and values from the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary <(Of <( Object, Object >)>).)
 | Comparer | Gets the IEqualityComparer<(Of <(T>)>) that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <( Object, Object >)>).)
 | ContainsKey(TKey) | Determines whether the Dictionary<(Of <(TKey, TValue>)>) contains the specified key. (Inherited from Dictionary <(Of <( Object, Object >)>).)
 | ContainsValue(TValue) | Determines whether the Dictionary<(Of <(TKey, TValue>)>) contains a specific value. (Inherited from Dictionary <(Of <( Object, Object >)>).)
 | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary <(Of <( Object, Object >)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() | Returns an enumerator that iterates through the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary <(Of <( Object, Object >)>).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(TKey, TValue>)>) instance. (Inherited from Dictionary <(Of <( Object, Object >)>).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(TKey])]) | Gets or sets the value associated with the specified key. (Inherited from Dictionary <(Of <( Object, Object >)>).)
 | Keys | Gets a collection containing the keys in the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary <(Of <( Object, Object >)>).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDeserialization(Object) | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <( Object, Object >)>).)
 | Remove(TKey) | Removes the value with the specified key from the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary <(Of <( Object, Object >)>).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryGetValue(TKey, TValue%) | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <( Object, Object >)>).)
 | Values | Gets a collection containing the values in the Dictionary<(Of <(TKey, TValue>)>). (Inherited from Dictionary <(Of <( Object, Object >)>).)
Inheritance Hierarchy
Object
 | Dictionary <(Of <( Object, Object >)>)
 |  | Hashtable


Hashtable Constructor

Hashtable Constructor
API ► Keyoti.RapidSpell ► Hashtable ► Hashtable()()()
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public Hashtable()
Public Sub New
public:
Hashtable()


IButtonControl Interface

IButtonControl Interface
API ► Keyoti.RapidSpell ► IButtonControl
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public interface IButtonControl
Public Interface IButtonControl
public interface class IButtonControl


ICheckerEngine Interface

ICheckerEngine Interface
API ► Keyoti.RapidSpell ► ICheckerEngine
Keyoti RapidSpell Silverlight
Defines the interface required for a class to be used as a checker engine
Declaration Syntax
C# Visual Basic Visual C++
public interface ICheckerEngine
Public Interface ICheckerEngine
public interface class ICheckerEngine
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddWord(String) | Adds a word to the user dictionary, if it exists.
 | AllowAnyCase | Whether to allow words spelt with any case, eg. "africa" instead of "Africa", this is more relaxed than AllowMixedCase.
 | AllowMixedCase | Whether to allow words spelt with mixed case, eg. "MIxEd"
 | ChangeBadWord(String) | Changes the current bad word to newWord in the text.
 | ChangeBadWord(BadWord, String) | Changes badWord to newWord in the text.
 | Check(String) | Checks the text for errors.
 | Check(String, Boolean) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
 | CheckCompoundWords | Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
 | CurrentBadWord | Gets the current bad word (last returned by NextBadWord).
 | DictFilePath | The file to be used as the main dictionary, if this is null then the RapidSpellMDict.DLL satellite assembly is used.
 | FindCapitalizedSuggestions | Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
 | FindSuggestions()()() | Returns an ArrayList of Strings that are suitable suggestions for the current bad word (that is, the one last returned by NextBadWord()).
 | FindSuggestions(String) | Returns an ArrayList of Strings that are suitable suggestions for word.
 | GetConsiderationRange()()() | Gets the factor for words to consider for suggestions.
 | GetIgnoreCapitalizedWords()()() | Gets whether to ignore words that start with capital letters.
 | GetIncludeUserDictionaryInSuggestions()()() | Gets whether the user dictionary should be used in finding suggestions for misspelt words.
 | GetSuggestionsMethod()()() | Gets the suggestions method, where method is an integer identifier.
 | GetUndoableStatePoint()()() | Gets the state of the current run, which can be stored and used with RevertToUndoableStatePoint(RapidSpellChecker..::.State)
 | IgnoreAll(String) | Marks word to be ignored in rest of the text.
 | IgnoreIncorrectSentenceCapitalization | Whether to ignore incorrect sentence capitalization.
 | IgnoreInEnglishLowerCaseI | Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
 | IgnoreList | The words to ignore, note this list is changed by IgnoreAll.
 | IgnoreURLsAndEmailAddresses | Whether to ignore URLs and email addresses (requires V2Parser=true)
 | IgnoreWordsWithDigits | Whether to ignore words with numbers in them (eg. A10 or 7-11).
 | IgnoreXML | Whether to ignore XML tags in the text.
 | LanguageParser | The type of language parsing to use.
 | LookIntoHyphenatedText | Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
 | LookUp(String) | Looks up word in the dictionary, returns true if it is in there.
 | NextBadWord()()() | Gets the next bad word in the list that was identified by Check.
 | RevertToUndoableStatePoint(RapidSpellChecker..::.State) | Reverts the state to that it was when GetUndoableStatePoint()()() was called.
 | SetConsiderationRange(Int32) | Sets the breadth of the suggestions search.
 | SetDictFileStream(Stream, String) | Passes a Dict file as a stream, to be used for the main dictionary.
 | SetIgnoreCapitalizedWords(Boolean) | Sets whether to ignore capitalized words.
 | SetIncludeUserDictionaryInSuggestions(Boolean) | Sets whether to include the user dictionary in suggestions taken from this engine.
 | SetOptionalContext(String, String) | Provides the engine with any helpful text around the text snippet which will be passed to the Check method. Implementation is not required.
 | SetPosition(Int32) | Sets the pointer position for the NextBadWord iterator.
 | SetSeparateHyphenWords(Boolean) | Sets whether to separate words with hyphens in them into separate words.
 | SetSuggestionsMethod(Int32) | Sets the suggestions method, where method is an integer identifier.
 | SetUserDictionary(UserDictionary) | Sets the UserDictionary object to be used as a user dictionary source.
 | SetUserDictionary(String) | Sets the UserDictionary file path to be used as a user dictionary source.
 | SuggestSplitWords | Whether to look for connected words in suggestions.
 | TextBoundary | The AdvancedTextBoundary class to use to parse words.
 | UnloadMainDictionary()()() | Empties the main dictionary store.
 | userDictionary | The user dictionary, this should be null (C#) or nothing (VB.NET) if no user dictionary is being used.
 | V2Parser | Whether to use parser version 2 (specific to RapidSpellChecker).
 | WarnDuplicates | Whether to treat duplicate words as errors (eg. "this is is an error").
 | WordAdded | Indicates a word has been added
Remarks
This is the interface which any checker engine must have, by implementing this interface any object can be used to parse text and identify 'bad words'. It is not necessary to functionally implement all members, for this reason an abstract empty implementation class is provided (CheckerEngineAdapter) which can be extended and overridden for desired functionality.


AddWord Method (word)

AddWord Method (word)
API ► Keyoti.RapidSpell ► ICheckerEngine ► AddWord(String)
Keyoti RapidSpell Silverlight
Adds a word to the user dictionary, if it exists.
Declaration Syntax
C# Visual Basic Visual C++
bool AddWord(
    string word
)
Function AddWord ( _
    word As String _
) As Boolean
bool AddWord(
    String^ word
)
Parameters
word (String)
Remarks
Should return true if the word was added successfully, false otherwise.


AllowAnyCase Property

AllowAnyCase Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► AllowAnyCase
Keyoti RapidSpell Silverlight
Whether to allow words spelt with any case, eg. "africa" instead of "Africa", this is more relaxed than AllowMixedCase.
Declaration Syntax
C# Visual Basic Visual C++
bool AllowAnyCase { get; set; }
Property AllowAnyCase As Boolean
property bool AllowAnyCase {
    bool get ();
    void set (bool value);
}


AllowMixedCase Property

AllowMixedCase Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► AllowMixedCase
Keyoti RapidSpell Silverlight
Whether to allow words spelt with mixed case, eg. "MIxEd"
Declaration Syntax
C# Visual Basic Visual C++
bool AllowMixedCase { get; set; }
Property AllowMixedCase As Boolean
property bool AllowMixedCase {
    bool get ();
    void set (bool value);
}


ChangeBadWord Method

ChangeBadWord Method
API ► Keyoti.RapidSpell ► ICheckerEngine ► ChangeBadWord()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | ChangeBadWord(String) | Changes the current bad word to newWord in the text.
 | ChangeBadWord(BadWord, String) | Changes badWord to newWord in the text.


ChangeBadWord Method (badWord, newWord)

ChangeBadWord Method (badWord, newWord)
API ► Keyoti.RapidSpell ► ICheckerEngine ► ChangeBadWord(BadWord, String)
Keyoti RapidSpell Silverlight
Changes badWord to newWord in the text.
Declaration Syntax
C# Visual Basic Visual C++
void ChangeBadWord(
    BadWord badWord,
    string newWord
)
Sub ChangeBadWord ( _
    badWord As BadWord, _
    newWord As String _
)
void ChangeBadWord(
    BadWord^ badWord,
    String^ newWord
)
Parameters
badWord (BadWord)
the word to reaplce
newWord (String)
replaces the current misspelt word.
Return Value
void
Exceptions
Exception | Condition
ArgumentNullException | if newWord parameter is null.


ChangeBadWord Method (newWord)

ChangeBadWord Method (newWord)
API ► Keyoti.RapidSpell ► ICheckerEngine ► ChangeBadWord(String)
Keyoti RapidSpell Silverlight
Changes the current bad word to newWord in the text.
Declaration Syntax
C# Visual Basic Visual C++
void ChangeBadWord(
    string newWord
)
Sub ChangeBadWord ( _
    newWord As String _
)
void ChangeBadWord(
    String^ newWord
)
Parameters
newWord (String)
replaces the current misspelt word.
Return Value
void
Exceptions
Exception | Condition
NoCurrentBadWordException | if nextBadWord() hasn't been run first AND found an erroneous word.
ArgumentNullException | if newWord parameter is null.


Check Method

Check Method
API ► Keyoti.RapidSpell ► ICheckerEngine ► Check()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | Check(String) | Checks the text for errors.
 | Check(String, Boolean) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.


Check Method (text)

Check Method (text)
API ► Keyoti.RapidSpell ► ICheckerEngine ► Check(String)
Keyoti RapidSpell Silverlight
Checks the text for errors.
Declaration Syntax
C# Visual Basic Visual C++
void Check(
    string text
)
Sub Check ( _
    text As String _
)
void Check(
    String^ text
)
Parameters
text (String)
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


Check Method (text, isStartOfTextBody)

Check Method (text, isStartOfTextBody)
API ► Keyoti.RapidSpell ► ICheckerEngine ► Check(String, Boolean)
Keyoti RapidSpell Silverlight
Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
Declaration Syntax
C# Visual Basic Visual C++
void Check(
    string text,
    bool isStartOfTextBody
)
Sub Check ( _
    text As String, _
    isStartOfTextBody As Boolean _
)
void Check(
    String^ text,
    bool isStartOfTextBody
)
Parameters
text (String)
to spell check.
isStartOfTextBody (Boolean)
whether the text being spell checked is at the start of the text body (eg. start of text box), this affects sentence capitalization determination.
Return Value
void
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


CheckCompoundWords Property

CheckCompoundWords Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► CheckCompoundWords
Keyoti RapidSpell Silverlight
Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
Declaration Syntax
C# Visual Basic Visual C++
bool CheckCompoundWords { get; set; }
Property CheckCompoundWords As Boolean
property bool CheckCompoundWords {
    bool get ();
    void set (bool value);
}
Remarks
If this=false then LookUp("thesewordsarejoined") = false

If this=true then LookUp("thesewordsarejoined") = true

If this=false then LookUp("abcdef") = false

If this=true then LookUp("abcdef") = false

Setting this to true will degrade lookup performance


CurrentBadWord Property

CurrentBadWord Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► CurrentBadWord
Keyoti RapidSpell Silverlight
Gets the current bad word (last returned by NextBadWord).
Declaration Syntax
C# Visual Basic Visual C++
BadWord CurrentBadWord { get; }
ReadOnly Property CurrentBadWord As BadWord
property BadWord^ CurrentBadWord {
    BadWord^ get ();
}


DictFilePath Property

DictFilePath Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► DictFilePath
Keyoti RapidSpell Silverlight
The file to be used as the main dictionary, if this is null then the RapidSpellMDict.DLL satellite assembly is used.
Declaration Syntax
C# Visual Basic Visual C++
string DictFilePath { get; set; }
Property DictFilePath As String
property String^ DictFilePath {
    String^ get ();
    void set (String^ value);
}


FindCapitalizedSuggestions Property

FindCapitalizedSuggestions Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► FindCapitalizedSuggestions
Keyoti RapidSpell Silverlight
Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
Declaration Syntax
C# Visual Basic Visual C++
bool FindCapitalizedSuggestions { get; set; }
Property FindCapitalizedSuggestions As Boolean
property bool FindCapitalizedSuggestions {
    bool get ();
    void set (bool value);
}


FindSuggestions Method

FindSuggestions Method
API ► Keyoti.RapidSpell ► ICheckerEngine ► FindSuggestions()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | FindSuggestions()()() | Returns an ArrayList of Strings that are suitable suggestions for the current bad word (that is, the one last returned by NextBadWord()).
 | FindSuggestions(String) | Returns an ArrayList of Strings that are suitable suggestions for word.


FindSuggestions Method

FindSuggestions Method
API ► Keyoti.RapidSpell ► ICheckerEngine ► FindSuggestions()()()
Keyoti RapidSpell Silverlight
Returns an ArrayList of Strings that are suitable suggestions for the current bad word (that is, the one last returned by NextBadWord()).
Declaration Syntax
C# Visual Basic Visual C++
ArrayList FindSuggestions()
Function FindSuggestions As ArrayList
ArrayList^ FindSuggestions()
Remarks
If no suggestions can be found, this should return an empty ArrayList. This method should be thread safe if operating with RapidSpell Desktop.
Exceptions
Exception | Condition
NoCurrentBadWordException | If NextBadWord() hasn't been run first AND found an erroneous word.


FindSuggestions Method (word)

FindSuggestions Method (word)
API ► Keyoti.RapidSpell ► ICheckerEngine ► FindSuggestions(String)
Keyoti RapidSpell Silverlight
Returns an ArrayList of Strings that are suitable suggestions for word.
Declaration Syntax
C# Visual Basic Visual C++
ArrayList FindSuggestions(
    string word
)
Function FindSuggestions ( _
    word As String _
) As ArrayList
ArrayList^ FindSuggestions(
    String^ word
)
Parameters
word (String)
Remarks
If no suggestions can be found, this should return an empty ArrayList. This method should be thread safe if operating with RapidSpell Desktop.


GetConsiderationRange Method

GetConsiderationRange Method
API ► Keyoti.RapidSpell ► ICheckerEngine ► GetConsiderationRange()()()
Keyoti RapidSpell Silverlight
Gets the factor for words to consider for suggestions.
Declaration Syntax
C# Visual Basic Visual C++
int GetConsiderationRange()
Function GetConsiderationRange As Integer
int GetConsiderationRange()


GetIgnoreCapitalizedWords Method

GetIgnoreCapitalizedWords Method
API ► Keyoti.RapidSpell ► ICheckerEngine ► GetIgnoreCapitalizedWords()()()
Keyoti RapidSpell Silverlight
Gets whether to ignore words that start with capital letters.
Declaration Syntax
C# Visual Basic Visual C++
bool GetIgnoreCapitalizedWords()
Function GetIgnoreCapitalizedWords As Boolean
bool GetIgnoreCapitalizedWords()


GetIncludeUserDictionaryInSuggestions Method

GetIncludeUserDictionaryInSuggestions Method
API ► Keyoti.RapidSpell ► ICheckerEngine ► GetIncludeUserDictionaryInSuggestions()()()
Keyoti RapidSpell Silverlight
Gets whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# Visual Basic Visual C++
bool GetIncludeUserDictionaryInSuggestions()
Function GetIncludeUserDictionaryInSuggestions As Boolean
bool GetIncludeUserDictionaryInSuggestions()


GetSuggestionsMethod Method

GetSuggestionsMethod Method
API ► Keyoti.RapidSpell ► ICheckerEngine ► GetSuggestionsMethod()()()
Keyoti RapidSpell Silverlight
Gets the suggestions method, where method is an integer identifier.
Declaration Syntax
C# Visual Basic Visual C++
int GetSuggestionsMethod()
Function GetSuggestionsMethod As Integer
int GetSuggestionsMethod()


GetUndoableStatePoint Method

GetUndoableStatePoint Method
API ► Keyoti.RapidSpell ► ICheckerEngine ► GetUndoableStatePoint()()()
Keyoti RapidSpell Silverlight
Gets the state of the current run, which can be stored and used with RevertToUndoableStatePoint(RapidSpellChecker..::.State)
Declaration Syntax
C# Visual Basic Visual C++
RapidSpellChecker..::.State GetUndoableStatePoint()
Function GetUndoableStatePoint As RapidSpellChecker..::.State
RapidSpellChecker..::.State^ GetUndoableStatePoint()
Return Value
Returns the current state, or null if not supporting undo.


IgnoreAll Method (word)

IgnoreAll Method (word)
API ► Keyoti.RapidSpell ► ICheckerEngine ► IgnoreAll(String)
Keyoti RapidSpell Silverlight
Marks word to be ignored in rest of the text.
Declaration Syntax
C# Visual Basic Visual C++
void IgnoreAll(
    string word
)
Sub IgnoreAll ( _
    word As String _
)
void IgnoreAll(
    String^ word
)
Parameters
word (String)
to ignore
Return Value
void
Exceptions
Exception | Condition
ArgumentNullException | if word parameter is null.


IgnoreIncorrectSentenceCapitalization Property

IgnoreIncorrectSentenceCapitalization Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► IgnoreIncorrectSentenceCapitalization
Keyoti RapidSpell Silverlight
Whether to ignore incorrect sentence capitalization.
Declaration Syntax
C# Visual Basic Visual C++
bool IgnoreIncorrectSentenceCapitalization { get; set; }
Property IgnoreIncorrectSentenceCapitalization As Boolean
property bool IgnoreIncorrectSentenceCapitalization {
    bool get ();
    void set (bool value);
}


IgnoreInEnglishLowerCaseI Property

IgnoreInEnglishLowerCaseI Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► IgnoreInEnglishLowerCaseI
Keyoti RapidSpell Silverlight
Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
Declaration Syntax
C# Visual Basic Visual C++
bool IgnoreInEnglishLowerCaseI { get; set; }
Property IgnoreInEnglishLowerCaseI As Boolean
property bool IgnoreInEnglishLowerCaseI {
    bool get ();
    void set (bool value);
}


IgnoreList Property

IgnoreList Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► IgnoreList
Keyoti RapidSpell Silverlight
The words to ignore, note this list is changed by IgnoreAll.
Declaration Syntax
C# Visual Basic Visual C++
ArrayList IgnoreList { get; set; }
Property IgnoreList As ArrayList
property ArrayList^ IgnoreList {
    ArrayList^ get ();
    void set (ArrayList^ value);
}


IgnoreURLsAndEmailAddresses Property

IgnoreURLsAndEmailAddresses Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► IgnoreURLsAndEmailAddresses
Keyoti RapidSpell Silverlight
Whether to ignore URLs and email addresses (requires V2Parser=true)
Declaration Syntax
C# Visual Basic Visual C++
bool IgnoreURLsAndEmailAddresses { get; set; }
Property IgnoreURLsAndEmailAddresses As Boolean
property bool IgnoreURLsAndEmailAddresses {
    bool get ();
    void set (bool value);
}
Remarks
This will cause the following strings to be accepted as non-spelling errors;
"user@domain.com", "http://www.domain.com", "domain.co.uk" etc.


IgnoreWordsWithDigits Property

IgnoreWordsWithDigits Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► IgnoreWordsWithDigits
Keyoti RapidSpell Silverlight
Whether to ignore words with numbers in them (eg. A10 or 7-11).
Declaration Syntax
C# Visual Basic Visual C++
bool IgnoreWordsWithDigits { get; set; }
Property IgnoreWordsWithDigits As Boolean
property bool IgnoreWordsWithDigits {
    bool get ();
    void set (bool value);
}


IgnoreXML Property

IgnoreXML Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► IgnoreXML
Keyoti RapidSpell Silverlight
Whether to ignore XML tags in the text.
Declaration Syntax
C# Visual Basic Visual C++
bool IgnoreXML { get; set; }
Property IgnoreXML As Boolean
property bool IgnoreXML {
    bool get ();
    void set (bool value);
}


LanguageParser Property

LanguageParser Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► LanguageParser
Keyoti RapidSpell Silverlight
The type of language parsing to use.
Declaration Syntax
C# Visual Basic Visual C++
LanguageType LanguageParser { get; set; }
Property LanguageParser As LanguageType
property LanguageType LanguageParser {
    LanguageType get ();
    void set (LanguageType value);
}
Return Value
This implementation always returns ENGLISH.
Remarks
Eg. If the dictionary is set to French, you should use the French parser.


LookIntoHyphenatedText Property

LookIntoHyphenatedText Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► LookIntoHyphenatedText
Keyoti RapidSpell Silverlight
Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
Declaration Syntax
C# Visual Basic Visual C++
bool LookIntoHyphenatedText { get; set; }
Property LookIntoHyphenatedText As Boolean
property bool LookIntoHyphenatedText {
    bool get ();
    void set (bool value);
}
Remarks
Eg. "socio-economic" will be checked as "socio" and "economic".


LookUp Method (word)

LookUp Method (word)
API ► Keyoti.RapidSpell ► ICheckerEngine ► LookUp(String)
Keyoti RapidSpell Silverlight
Looks up word in the dictionary, returns true if it is in there.
Declaration Syntax
C# Visual Basic Visual C++
bool LookUp(
    string word
)
Function LookUp ( _
    word As String _
) As Boolean
bool LookUp(
    String^ word
)
Parameters
word (String)


NextBadWord Method

NextBadWord Method
API ► Keyoti.RapidSpell ► ICheckerEngine ► NextBadWord()()()
Keyoti RapidSpell Silverlight
Gets the next bad word in the list that was identified by Check.
Declaration Syntax
C# Visual Basic Visual C++
BadWord NextBadWord()
Function NextBadWord As BadWord
BadWord^ NextBadWord()
Return Value
The next BadWord object from the text, must return null (C#) or nothing (VB.NET) when no more bad words exist.
Remarks
Check must be called before this method.


RevertToUndoableStatePoint Method (state)

RevertToUndoableStatePoint Method (state)
API ► Keyoti.RapidSpell ► ICheckerEngine ► RevertToUndoableStatePoint(RapidSpellChecker..::.State)
Keyoti RapidSpell Silverlight
Reverts the state to that it was when GetUndoableStatePoint()()() was called.
Declaration Syntax
C# Visual Basic Visual C++
void RevertToUndoableStatePoint(
    RapidSpellChecker..::.State state
)
Sub RevertToUndoableStatePoint ( _
    state As RapidSpellChecker..::.State _
)
void RevertToUndoableStatePoint(
    RapidSpellChecker..::.State^ state
)
Parameters
state (RapidSpellChecker..::.State)


SetConsiderationRange Method (range)

SetConsiderationRange Method (range)
API ► Keyoti.RapidSpell ► ICheckerEngine ► SetConsiderationRange(Int32)
Keyoti RapidSpell Silverlight
Sets the breadth of the suggestions search.
Declaration Syntax
C# Visual Basic Visual C++
void SetConsiderationRange(
    int range
)
Sub SetConsiderationRange ( _
    range As Integer _
)
void SetConsiderationRange(
    int range
)
Parameters
range (Int32)


SetDictFileStream Method (dictFileStream, id)

SetDictFileStream Method (dictFileStream, id)
API ► Keyoti.RapidSpell ► ICheckerEngine ► SetDictFileStream(Stream, String)
Keyoti RapidSpell Silverlight
Passes a Dict file as a stream, to be used for the main dictionary.
Declaration Syntax
C# Visual Basic Visual C++
void SetDictFileStream(
    Stream dictFileStream,
    string id
)
Sub SetDictFileStream ( _
    dictFileStream As Stream, _
    id As String _
)
void SetDictFileStream(
    Stream^ dictFileStream,
    String^ id
)
Parameters
dictFileStream (Stream)
The stream containing the dictionary
id (String)
Remarks
Note this method must be set before Check is called, and the stream position must be at beginning of Dict file. The stream is NOT closed by this method.


SetIgnoreCapitalizedWords Method (ignore)

SetIgnoreCapitalizedWords Method (ignore)
API ► Keyoti.RapidSpell ► ICheckerEngine ► SetIgnoreCapitalizedWords(Boolean)
Keyoti RapidSpell Silverlight
Sets whether to ignore capitalized words.
Declaration Syntax
C# Visual Basic Visual C++
void SetIgnoreCapitalizedWords(
    bool ignore
)
Sub SetIgnoreCapitalizedWords ( _
    ignore As Boolean _
)
void SetIgnoreCapitalizedWords(
    bool ignore
)
Parameters
ignore (Boolean)


SetIncludeUserDictionaryInSuggestions Method (includeUserDictionaryInSuggestions)

SetIncludeUserDictionaryInSuggestions Method (includeUserDictionaryInSuggestions)
API ► Keyoti.RapidSpell ► ICheckerEngine ► SetIncludeUserDictionaryInSuggestions(Boolean)
Keyoti RapidSpell Silverlight
Sets whether to include the user dictionary in suggestions taken from this engine.
Declaration Syntax
C# Visual Basic Visual C++
void SetIncludeUserDictionaryInSuggestions(
    bool includeUserDictionaryInSuggestions
)
Sub SetIncludeUserDictionaryInSuggestions ( _
    includeUserDictionaryInSuggestions As Boolean _
)
void SetIncludeUserDictionaryInSuggestions(
    bool includeUserDictionaryInSuggestions
)
Parameters
includeUserDictionaryInSuggestions (Boolean)


SetOptionalContext Method (beforeToCheckSnippet, afterToCheckSnippet)

SetOptionalContext Method (beforeToCheckSnippet, afterToCheckSnippet)
API ► Keyoti.RapidSpell ► ICheckerEngine ► SetOptionalContext(String, String)
Keyoti RapidSpell Silverlight
Provides the engine with any helpful text around the text snippet which will be passed to the Check method. Implementation is not required.
Declaration Syntax
C# Visual Basic Visual C++
void SetOptionalContext(
    string beforeToCheckSnippet,
    string afterToCheckSnippet
)
Sub SetOptionalContext ( _
    beforeToCheckSnippet As String, _
    afterToCheckSnippet As String _
)
void SetOptionalContext(
    String^ beforeToCheckSnippet,
    String^ afterToCheckSnippet
)
Parameters
beforeToCheckSnippet (String)
Any text before the to check snippet
afterToCheckSnippet (String)
Any text after the snippet
Remarks
Eg. if the document contains "This is an an example piece." and Check will be called on "an example piece", then the fact that 'an' is duplicated will not be detected. Therefore, by passing "This is an " to beforeToCheckSnippet the checker will be able to detect that an is duplicated.


SetPosition Method (pos)

SetPosition Method (pos)
API ► Keyoti.RapidSpell ► ICheckerEngine ► SetPosition(Int32)
Keyoti RapidSpell Silverlight
Sets the pointer position for the NextBadWord iterator.
Declaration Syntax
C# Visual Basic Visual C++
void SetPosition(
    int pos
)
Sub SetPosition ( _
    pos As Integer _
)
void SetPosition(
    int pos
)
Parameters
pos (Int32)
Remarks
Further calls to NextBadWord will look for the next bad word from position pos. If position > the text length it is set to the text length. If position < 0, it is set to zero.


SetSeparateHyphenWords Method (separate)

SetSeparateHyphenWords Method (separate)
API ► Keyoti.RapidSpell ► ICheckerEngine ► SetSeparateHyphenWords(Boolean)
Keyoti RapidSpell Silverlight
Sets whether to separate words with hyphens in them into separate words.
Declaration Syntax
C# Visual Basic Visual C++
void SetSeparateHyphenWords(
    bool separate
)
Sub SetSeparateHyphenWords ( _
    separate As Boolean _
)
void SetSeparateHyphenWords(
    bool separate
)
Parameters
separate (Boolean)


SetSuggestionsMethod Method (method)

SetSuggestionsMethod Method (method)
API ► Keyoti.RapidSpell ► ICheckerEngine ► SetSuggestionsMethod(Int32)
Keyoti RapidSpell Silverlight
Sets the suggestions method, where method is an integer identifier.
Declaration Syntax
C# Visual Basic Visual C++
void SetSuggestionsMethod(
    int method
)
Sub SetSuggestionsMethod ( _
    method As Integer _
)
void SetSuggestionsMethod(
    int method
)
Parameters
method (Int32)


SetUserDictionary Method

SetUserDictionary Method
API ► Keyoti.RapidSpell ► ICheckerEngine ► SetUserDictionary()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | SetUserDictionary(UserDictionary) | Sets the UserDictionary object to be used as a user dictionary source.
 | SetUserDictionary(String) | Sets the UserDictionary file path to be used as a user dictionary source.


SetUserDictionary Method (userDictionary)

SetUserDictionary Method (userDictionary)
API ► Keyoti.RapidSpell ► ICheckerEngine ► SetUserDictionary(UserDictionary)
Keyoti RapidSpell Silverlight
Sets the UserDictionary object to be used as a user dictionary source.
Declaration Syntax
C# Visual Basic Visual C++
void SetUserDictionary(
    UserDictionary userDictionary
)
Sub SetUserDictionary ( _
    userDictionary As UserDictionary _
)
void SetUserDictionary(
    UserDictionary^ userDictionary
)
Parameters
userDictionary (UserDictionary)


SetUserDictionary Method (userDictionary)

SetUserDictionary Method (userDictionary)
API ► Keyoti.RapidSpell ► ICheckerEngine ► SetUserDictionary(String)
Keyoti RapidSpell Silverlight
Sets the UserDictionary file path to be used as a user dictionary source.
Declaration Syntax
C# Visual Basic Visual C++
void SetUserDictionary(
    string userDictionary
)
Sub SetUserDictionary ( _
    userDictionary As String _
)
void SetUserDictionary(
    String^ userDictionary
)
Parameters
userDictionary (String)


SuggestSplitWords Property

SuggestSplitWords Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► SuggestSplitWords
Keyoti RapidSpell Silverlight
Whether to look for connected words in suggestions.
Declaration Syntax
C# Visual Basic Visual C++
bool SuggestSplitWords { get; set; }
Property SuggestSplitWords As Boolean
property bool SuggestSplitWords {
    bool get ();
    void set (bool value);
}
Remarks
if this=true then suggestions may include joined words.

Eg; suggestions for "myhouse" will include "my house"


TextBoundary Property

TextBoundary Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► TextBoundary
Keyoti RapidSpell Silverlight
The AdvancedTextBoundary class to use to parse words.
Declaration Syntax
C# Visual Basic Visual C++
AdvancedTextBoundary TextBoundary { get; set; }
Property TextBoundary As AdvancedTextBoundary
property AdvancedTextBoundary^ TextBoundary {
    AdvancedTextBoundary^ get ();
    void set (AdvancedTextBoundary^ value);
}


UnloadMainDictionary Method

UnloadMainDictionary Method
API ► Keyoti.RapidSpell ► ICheckerEngine ► UnloadMainDictionary()()()
Keyoti RapidSpell Silverlight
Empties the main dictionary store.
Declaration Syntax
C# Visual Basic Visual C++
void UnloadMainDictionary()
Sub UnloadMainDictionary
void UnloadMainDictionary()


userDictionary Property

userDictionary Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► userDictionary
Keyoti RapidSpell Silverlight
The user dictionary, this should be null (C#) or nothing (VB.NET) if no user dictionary is being used.
Declaration Syntax
C# Visual Basic Visual C++
UserDictionary userDictionary { get; }
ReadOnly Property userDictionary As UserDictionary
property UserDictionary^ userDictionary {
    UserDictionary^ get ();
}


V2Parser Property

V2Parser Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► V2Parser
Keyoti RapidSpell Silverlight
Whether to use parser version 2 (specific to RapidSpellChecker).
Declaration Syntax
C# Visual Basic Visual C++
bool V2Parser { get; set; }
Property V2Parser As Boolean
property bool V2Parser {
    bool get ();
    void set (bool value);
}


WarnDuplicates Property

WarnDuplicates Property
API ► Keyoti.RapidSpell ► ICheckerEngine ► WarnDuplicates
Keyoti RapidSpell Silverlight
Whether to treat duplicate words as errors (eg. "this is is an error").
Declaration Syntax
C# Visual Basic Visual C++
bool WarnDuplicates { get; set; }
Property WarnDuplicates As Boolean
property bool WarnDuplicates {
    bool get ();
    void set (bool value);
}


WordAdded Event

WordAdded Event
API ► Keyoti.RapidSpell ► ICheckerEngine ► WordAdded
Keyoti RapidSpell Silverlight
Indicates a word has been added
Declaration Syntax
C# Visual Basic Visual C++
event WordAddedEventHandler WordAdded
Event WordAdded As WordAddedEventHandler
 event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}


ISpellCheckableTextComponent Interface

ISpellCheckableTextComponent Interface
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent
Keyoti RapidSpell Silverlight
Defines the interface required for a text component to be spell checkable using the RapidSpellDialog control (or RapidSpellGUI class)
Declaration Syntax
C# Visual Basic Visual C++
public interface ISpellCheckableTextComponent
Public Interface ISpellCheckableTextComponent
public interface class ISpellCheckableTextComponent
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Dispose()()() | Dispose of resources
 | Disposed | Occurs when the control is disposed of.
 | Enabled | Whether the textbox is enabled
 | GotFocus | Occurs when the control receives focus.
 | HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.
 | ReadOnly | Whether the textbox is readonly
 | ScrollToCaret()()() | Scrolls the contents of the control to the current caret position.
 | SelectedText | Gets or sets a value indicating the currently selected text in the control.
 | SelectionLength | Gets or sets the number of characters selected in the text box.
 | SelectionStart | Gets or sets the starting point of text selected in the text box.
 | Text | Gets or sets the current text in the text box.
Remarks
This is typically used in conjunction with 3rd party text controls.


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent ► Dispose()()()
Keyoti RapidSpell Silverlight
Dispose of resources
Declaration Syntax
C# Visual Basic Visual C++
void Dispose()
Sub Dispose
void Dispose()


Disposed Event

Disposed Event
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent ► Disposed
Keyoti RapidSpell Silverlight
Occurs when the control is disposed of.
Declaration Syntax
C# Visual Basic Visual C++
event EventHandler Disposed
Event Disposed As EventHandler
 event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


Enabled Property

Enabled Property
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent ► Enabled
Keyoti RapidSpell Silverlight
Whether the textbox is enabled
Declaration Syntax
C# Visual Basic Visual C++
bool Enabled { get; }
ReadOnly Property Enabled As Boolean
property bool Enabled {
    bool get ();
}
Remarks
If not supported, return true.


GotFocus Event

GotFocus Event
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent ► GotFocus
Keyoti RapidSpell Silverlight
Occurs when the control receives focus.
Declaration Syntax
C# Visual Basic Visual C++
event EventHandler GotFocus
Event GotFocus As EventHandler
 event EventHandler^ GotFocus {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


HideSelection Property

HideSelection Property
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent ► HideSelection
Keyoti RapidSpell Silverlight
Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.
Declaration Syntax
C# Visual Basic Visual C++
bool HideSelection { get; set; }
Property HideSelection As Boolean
property bool HideSelection {
    bool get ();
    void set (bool value);
}


ReadOnly Property

ReadOnly Property
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent ► ReadOnly
Keyoti RapidSpell Silverlight
Whether the textbox is readonly
Declaration Syntax
C# Visual Basic Visual C++
bool ReadOnly { get; }
ReadOnly Property ReadOnly As Boolean
property bool ReadOnly {
    bool get ();
}
Remarks
If not supported, return false.


ScrollToCaret Method

ScrollToCaret Method
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent ► ScrollToCaret()()()
Keyoti RapidSpell Silverlight
Scrolls the contents of the control to the current caret position.
Declaration Syntax
C# Visual Basic Visual C++
void ScrollToCaret()
Sub ScrollToCaret
void ScrollToCaret()


SelectedText Property

SelectedText Property
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent ► SelectedText
Keyoti RapidSpell Silverlight
Gets or sets a value indicating the currently selected text in the control.
Declaration Syntax
C# Visual Basic Visual C++
string SelectedText { get; set; }
Property SelectedText As String
property String^ SelectedText {
    String^ get ();
    void set (String^ value);
}


SelectionLength Property

SelectionLength Property
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent ► SelectionLength
Keyoti RapidSpell Silverlight
Gets or sets the number of characters selected in the text box.
Declaration Syntax
C# Visual Basic Visual C++
int SelectionLength { get; set; }
Property SelectionLength As Integer
property int SelectionLength {
    int get ();
    void set (int value);
}


SelectionStart Property

SelectionStart Property
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent ► SelectionStart
Keyoti RapidSpell Silverlight
Gets or sets the starting point of text selected in the text box.
Declaration Syntax
C# Visual Basic Visual C++
int SelectionStart { get; set; }
Property SelectionStart As Integer
property int SelectionStart {
    int get ();
    void set (int value);
}


Text Property

Text Property
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent ► Text
Keyoti RapidSpell Silverlight
Gets or sets the current text in the text box.
Declaration Syntax
C# Visual Basic Visual C++
string Text { get; set; }
Property Text As String
property String^ Text {
    String^ get ();
    void set (String^ value);
}


ISpellCheckableTextComponent2 Interface

ISpellCheckableTextComponent2 Interface
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent2
Keyoti RapidSpell Silverlight
Defines the interface required for a text component to be spell checkable using the RapidSpellDialog control (or RapidSpellGUI class)
Declaration Syntax
C# Visual Basic Visual C++
public interface ISpellCheckableTextComponent2 : ISpellCheckableTextComponent
Public Interface ISpellCheckableTextComponent2 _
    Implements ISpellCheckableTextComponent
public interface class ISpellCheckableTextComponent2 : ISpellCheckableTextComponent
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CaretPosition | The caret or selection start position
 | Dispose()()() | Dispose of resources (Inherited from ISpellCheckableTextComponent.)
 | Disposed | Occurs when the control is disposed of. (Inherited from ISpellCheckableTextComponent.)
 | Enabled | Whether the textbox is enabled (Inherited from ISpellCheckableTextComponent.)
 | GotFocus | Occurs when the control receives focus. (Inherited from ISpellCheckableTextComponent.)
 | HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus. (Inherited from ISpellCheckableTextComponent.)
 | ReadOnly | Whether the textbox is readonly (Inherited from ISpellCheckableTextComponent.)
 | ScrollToCaret()()() | Scrolls the contents of the control to the current caret position. (Inherited from ISpellCheckableTextComponent.)
 | Select(Int32, Int32) | Make a selection
 | SelectedText | Gets or sets a value indicating the currently selected text in the control. (Inherited from ISpellCheckableTextComponent.)
 | SelectionEnd | Gets or sets the starting point of text selected in the text box.
 | SelectionLength | Gets or sets the number of characters selected in the text box. (Inherited from ISpellCheckableTextComponent.)
 | SelectionStart | Gets or sets the starting point of text selected in the text box. (Inherited from ISpellCheckableTextComponent.)
 | Text | Gets or sets the current text in the text box. (Inherited from ISpellCheckableTextComponent.)
Remarks
This is typically used in conjunction with 3rd party text controls.


CaretPosition Property

CaretPosition Property
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent2 ► CaretPosition
Keyoti RapidSpell Silverlight
The caret or selection start position
Declaration Syntax
C# Visual Basic Visual C++
int CaretPosition { get; set; }
Property CaretPosition As Integer
property int CaretPosition {
    int get ();
    void set (int value);
}


Select Method (from, to)

Select Method (from, to)
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent2 ► Select(Int32, Int32)
Keyoti RapidSpell Silverlight
Make a selection
Declaration Syntax
C# Visual Basic Visual C++
void Select(
    int from,
    int to
)
Sub Select ( _
    from As Integer, _
    to As Integer _
)
void Select(
    int from,
    int to
)
Parameters
from (Int32)
to (Int32)


SelectionEnd Property

SelectionEnd Property
API ► Keyoti.RapidSpell ► ISpellCheckableTextComponent2 ► SelectionEnd
Keyoti RapidSpell Silverlight
Gets or sets the starting point of text selected in the text box.
Declaration Syntax
C# Visual Basic Visual C++
int SelectionEnd { get; }
ReadOnly Property SelectionEnd As Integer
property int SelectionEnd {
    int get ();
}


IUserInterfaceFormPresenter Interface

IUserInterfaceFormPresenter Interface
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter
Keyoti RapidSpell Silverlight
Interface requirements for a dialog based UI form.
Declaration Syntax
C# Visual Basic Visual C++
public interface IUserInterfaceFormPresenter : IDialogViewEventHandler
Public Interface IUserInterfaceFormPresenter _
    Implements IDialogViewEventHandler
public interface class IUserInterfaceFormPresenter : IDialogViewEventHandler
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddButtonText | Add button text.
 | AllOperationScope | The scope that ignore-all/change-all should have.
 | CancelButtonText | Cancel button text.
 | Cancelled | Whether the spell check has been cancelled.
 | ChangeAllButtonText | Change All button text.
 | ChangeButtonText | Change button text.
 | Check()()() | Bring up the spell checker Form and start checking the component set by SetTextComponentToCheck.
 | Check(ISpellCheckableTextComponent) | Bring up the spell checker Form and start checking the TextBoxBase textComponent.
 | CheckCompletePopUpText | Check complete pop up text
 | CheckCompletePopUpTitle | Check complete pop up title
 | CheckCompoundWords | Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
 | CheckerEngine | The checker engine to use, this object must implement the ICheckerEngine interface, allows customization or replacement of the spell checker.
 | CheckFromStartOfText | Whether to check from the start of the text (true) or whereever the cursor is (false)
 | CheckingSpellingText | Checking spelling text
 | ConsiderationRange | The factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anything.
 | CreateDialogView | Indicates that a new IDialogView is being created, also provides chance to override the default IDialogView.
 | CreateDialogViewOptions | Indicates that a new IDialogViewOptions is being created, also provides chance to override the default IDialogViewOptions.
 | CreateDialogViewUserDictionaryEdit | Indicates that a new IDialogViewUserDictionaryEdit is being created, also provides chance to override the default IDialogViewUserDictionaryEdit.
 | DialogTitleText | Dialog title text
 | DialogView | The IDialogView to use
 | DialogView_AddButtonClick(Object, EventArgs) | The add button was clicked (Inherited from IDialogViewEventHandler.)
 | DialogView_CancelButtonClick(Object, EventArgs) | The cancel button was clicked (Inherited from IDialogViewEventHandler.)
 | DialogView_ChangeAllButtonClick(Object, EventArgs) | The change-all button was clicked (Inherited from IDialogViewEventHandler.)
 | DialogView_ChangeButtonClick(Object, EventArgs) | The change button was clicked (Inherited from IDialogViewEventHandler.)
 | DialogView_Closing(Object, CancelEventArgs) | The view is closing (Inherited from IDialogViewEventHandler.)
 | DialogView_IgnoreAllButtonClick(Object, EventArgs) | The ignore all button was clicked (Inherited from IDialogViewEventHandler.)
 | DialogView_IgnoreButtonClick(Object, EventArgs) | The ignore button was clicked (Inherited from IDialogViewEventHandler.)
 | DialogView_Load(Object, EventArgs) | The view has loaded (Inherited from IDialogViewEventHandler.)
 | DialogView_OptionsButtonClick(Object, EventArgs) | The options button was clicked (Inherited from IDialogViewEventHandler.)
 | DialogView_QueryTextBoxEnter(Object, EventArgs) | Query textbox has been entered (Inherited from IDialogViewEventHandler.)
 | DialogView_QueryTextBoxTextChanged(Object, EventArgs) | The text in the query textbox changed (Inherited from IDialogViewEventHandler.)
 | DialogView_SuggestionsListDoubleClick(Object, EventArgs) | The user double clicked on a suggested item. Not mandatory to implement. (Inherited from IDialogViewEventHandler.)
 | DialogView_UndoButtonClick(Object, EventArgs) | The undo button was clicked (Inherited from IDialogViewEventHandler.)
 | DialogView_UserNeedsSuggestionsChanged(Object, EventArgs) | User has checked the "Find Suggestions" checkbox (if it exists). (Inherited from IDialogViewEventHandler.)
 | DictFilePath | Optional file path to the main dictionary .dict file to use.
 | DictionaryLoader | The dictionary loader, which reports loading status.
 | Dispose()()() | Dispose of resources
 | DisposeAtEnd | Whether to dispose of this form when spell check is finished.
 | FindCapitalizedSuggestions | Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
 | FindingSuggestionsLabelText | Finding suggestions label text.
 | FindSuggestionsLabelText | Find suggestions label text.
 | FinishedCheckingSelectionPopUpText | Finished checking selection dialog text
 | FinishedCheckingSelectionPopUpTitle | Finished checking selection dialog title
 | GUILanguage | The language to show the UI in.
 | IgnoreAllButtonText | Ignore All button text.
 | IgnoreButtonText | Ignore button text.
 | IgnoreCapitalizedWords | Sets whether to ignore words with capital letters.
 | IgnoreIncorrectSentenceCapitalization | Whether to ignore incorrect sentence capitalization.
 | IgnoreInEnglishLowerCaseI | Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
 | IgnoreWordsWithDigits | Whether to ignore words with numbers in them (eg. A10 or 7-11).
 | IgnoreXML | Whether to ignore XML/HTML tags, false by default.
 | IncludeUserDictionaryInSuggestions | Whether the user dictionary should be used in finding suggestions for misspelt words.
 | InDictionaryLabelText | In dictionary label text
 | LanguageParser | The type of language parsing to use.
 | Load | Fired when the DialogView loads.
 | LookIntoHyphenatedText | Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
 | MaximumContextualWords | The maximum number of words to show the user in the sentence around misspelled words.
 | ModalAutoDispose | When running modally, determines if the dialog will be disposed of when spell check finishes.
 | ModalMode | Whether the spell checker will run modally. (Modal operation blocks the parent form)
 | NoSuggestionsText | No suggestions found text
 | NotInDictionaryLabelText | Not in dictionary label text
 | NumberSuggestionList | Whether to number the items in the suggestion list, for quick user selection.
 | Options | Object responsible for holding, loading and saving the user's spell check options.
 | OptionsButtonText | Options button text
 | OptionsPresenter | Presenter for the user options form (IDialogViewOptions).
 | Ready | Fired when ready to proceed with first query.
 | RecheckDocumentRequest | Fired when the text should be rechecked
 | Remove()()() | Safely frees up resources.
 | RemoveDuplicateWordText | Remove duplicate word text
 | ResumeButtonText | Resume button text
 | SeparateHyphenWords | Sets whether to treat hyphenated (-) words as separate words, default is false.
 | SetIgnoreOnceBadWords(ArrayList) | Provide a list of BadWord objects that have been ignored
 | ShowContextSentence | Whether to show the query in context of it's sentence/line.
 | ShowFinishedMessageBox | Whether a message box should be opened when the spell check is complete.
 | SpellCheckFinished | Fired when checking finishes
 | SpellCheckStarted | Fired when checking starts
 | SuggestionsLabelText | Suggestions label text
 | SuggestionsMethod | Sets the suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
 | SuggestSplitWords | Whether to look for connected words in suggestions.
 | UndoButtonText | Undo button text
 | Undone | Fired when an Undo occurs
 | UserDictionary | Set the user dictionary object.
 | UserDictionaryFile | Set the user dictionary file, if this file doesn't exist it will be created.
 | UserQuery | Indicates that the user is being queried on a spelling error.
 | WarnDuplicates | Whether to show duplicate words as errors (eg. "this is is an error").
 | WordAdded | Fired when word added to user dictionary
 | WordChanged | Fired when word changed
 | WordChanging | Fired before a word is changed
 | WordIgnored | Fired when word ignored
Remarks
Implement this interface in custom UI objects that you wish to plug-in to RapidSpellDialog.

Note: Sub-classes of RapidSpellGUI implement this interface by inheritance (automatically).


AddButtonText Property

AddButtonText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► AddButtonText
Keyoti RapidSpell Silverlight
Add button text.
Declaration Syntax
C# Visual Basic Visual C++
string AddButtonText { get; set; }
Property AddButtonText As String
property String^ AddButtonText {
    String^ get ();
    void set (String^ value);
}


AllOperationScope Property

AllOperationScope Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► AllOperationScope
Keyoti RapidSpell Silverlight
The scope that ignore-all/change-all should have.
Declaration Syntax
C# Visual Basic Visual C++
OperationScope AllOperationScope { get; set; }
Property AllOperationScope As OperationScope
property OperationScope AllOperationScope {
    OperationScope get ();
    void set (OperationScope value);
}


CancelButtonText Property

CancelButtonText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► CancelButtonText
Keyoti RapidSpell Silverlight
Cancel button text.
Declaration Syntax
C# Visual Basic Visual C++
string CancelButtonText { get; set; }
Property CancelButtonText As String
property String^ CancelButtonText {
    String^ get ();
    void set (String^ value);
}


Cancelled Property

Cancelled Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► Cancelled
Keyoti RapidSpell Silverlight
Whether the spell check has been cancelled.
Declaration Syntax
C# Visual Basic Visual C++
bool Cancelled { get; }
ReadOnly Property Cancelled As Boolean
property bool Cancelled {
    bool get ();
}


ChangeAllButtonText Property

ChangeAllButtonText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► ChangeAllButtonText
Keyoti RapidSpell Silverlight
Change All button text.
Declaration Syntax
C# Visual Basic Visual C++
string ChangeAllButtonText { get; set; }
Property ChangeAllButtonText As String
property String^ ChangeAllButtonText {
    String^ get ();
    void set (String^ value);
}


ChangeButtonText Property

ChangeButtonText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► ChangeButtonText
Keyoti RapidSpell Silverlight
Change button text.
Declaration Syntax
C# Visual Basic Visual C++
string ChangeButtonText { get; set; }
Property ChangeButtonText As String
property String^ ChangeButtonText {
    String^ get ();
    void set (String^ value);
}


Check Method

Check Method
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► Check()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | Check()()() | Bring up the spell checker Form and start checking the component set by SetTextComponentToCheck.
 | Check(ISpellCheckableTextComponent) | Bring up the spell checker Form and start checking the TextBoxBase textComponent.


Check Method

Check Method
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► Check()()()
Keyoti RapidSpell Silverlight
Bring up the spell checker Form and start checking the component set by SetTextComponentToCheck.
Declaration Syntax
C# Visual Basic Visual C++
void Check()
Sub Check
void Check()
Exceptions
Exception | Condition
NoTextComponentException | if SetTextComponentToCheck hasn't be called first with a TextBoxBase object.


Check Method (textComponent)

Check Method (textComponent)
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► Check(ISpellCheckableTextComponent)
Keyoti RapidSpell Silverlight
Bring up the spell checker Form and start checking the TextBoxBase textComponent.
Declaration Syntax
C# Visual Basic Visual C++
void Check(
    ISpellCheckableTextComponent textComponent
)
Sub Check ( _
    textComponent As ISpellCheckableTextComponent _
)
void Check(
    ISpellCheckableTextComponent^ textComponent
)
Parameters
textComponent (ISpellCheckableTextComponent)
Exceptions
Exception | Condition
ArgumentNullException | if textComponent parameter is null.


CheckCompletePopUpText Property

CheckCompletePopUpText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► CheckCompletePopUpText
Keyoti RapidSpell Silverlight
Check complete pop up text
Declaration Syntax
C# Visual Basic Visual C++
string CheckCompletePopUpText { get; set; }
Property CheckCompletePopUpText As String
property String^ CheckCompletePopUpText {
    String^ get ();
    void set (String^ value);
}


CheckCompletePopUpTitle Property

CheckCompletePopUpTitle Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► CheckCompletePopUpTitle
Keyoti RapidSpell Silverlight
Check complete pop up title
Declaration Syntax
C# Visual Basic Visual C++
string CheckCompletePopUpTitle { get; set; }
Property CheckCompletePopUpTitle As String
property String^ CheckCompletePopUpTitle {
    String^ get ();
    void set (String^ value);
}


CheckCompoundWords Property

CheckCompoundWords Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► CheckCompoundWords
Keyoti RapidSpell Silverlight
Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
Declaration Syntax
C# Visual Basic Visual C++
bool CheckCompoundWords { get; set; }
Property CheckCompoundWords As Boolean
property bool CheckCompoundWords {
    bool get ();
    void set (bool value);
}
Remarks
If this=false then LookUp("thesewordsarejoined") = false

If this=true then LookUp("thesewordsarejoined") = true

If this=false then LookUp("abcdef") = false

If this=true then LookUp("abcdef") = false

Setting this to true will degrade lookup performance


CheckerEngine Property

CheckerEngine Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► CheckerEngine
Keyoti RapidSpell Silverlight
The checker engine to use, this object must implement the ICheckerEngine interface, allows customization or replacement of the spell checker.
Declaration Syntax
C# Visual Basic Visual C++
ICheckerEngine CheckerEngine { get; set; }
Property CheckerEngine As ICheckerEngine
property ICheckerEngine^ CheckerEngine {
    ICheckerEngine^ get ();
    void set (ICheckerEngine^ value);
}
Remarks
Use this property to replace the object used to perform checking, it is not necessary to replace this with a spell checker, any type of word parser can be used. For example an abbreviations checker could be written to replace common words with abbreviations. Caveat: Most properties in RapidSpellGUI are mirrors of properties in ICheckerEngine, setting a CheckerEngine AFTER setting properties in RapidSpellGUI will overwrite those property values with the values of CheckerEngine.


CheckFromStartOfText Property

CheckFromStartOfText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► CheckFromStartOfText
Keyoti RapidSpell Silverlight
Whether to check from the start of the text (true) or whereever the cursor is (false)
Declaration Syntax
C# Visual Basic Visual C++
bool CheckFromStartOfText { get; set; }
Property CheckFromStartOfText As Boolean
property bool CheckFromStartOfText {
    bool get ();
    void set (bool value);
}


CheckingSpellingText Property

CheckingSpellingText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► CheckingSpellingText
Keyoti RapidSpell Silverlight
Checking spelling text
Declaration Syntax
C# Visual Basic Visual C++
string CheckingSpellingText { get; set; }
Property CheckingSpellingText As String
property String^ CheckingSpellingText {
    String^ get ();
    void set (String^ value);
}


ConsiderationRange Property

ConsiderationRange Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► ConsiderationRange
Keyoti RapidSpell Silverlight
The factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anything.
Declaration Syntax
C# Visual Basic Visual C++
int ConsiderationRange { get; set; }
Property ConsiderationRange As Integer
property int ConsiderationRange {
    int get ();
    void set (int value);
}


CreateDialogView Event

CreateDialogView Event
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► CreateDialogView
Keyoti RapidSpell Silverlight
Indicates that a new IDialogView is being created, also provides chance to override the default IDialogView.
Declaration Syntax
C# Visual Basic Visual C++
event CreateDialogViewEventHandler CreateDialogView
Event CreateDialogView As CreateDialogViewEventHandler
 event CreateDialogViewEventHandler^ CreateDialogView {
    void add (CreateDialogViewEventHandler^ value);
    void remove (CreateDialogViewEventHandler^ value);
}


CreateDialogViewOptions Event

CreateDialogViewOptions Event
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► CreateDialogViewOptions
Keyoti RapidSpell Silverlight
Indicates that a new IDialogViewOptions is being created, also provides chance to override the default IDialogViewOptions.
Declaration Syntax
C# Visual Basic Visual C++
event CreateDialogViewOptionsEventHandler CreateDialogViewOptions
Event CreateDialogViewOptions As CreateDialogViewOptionsEventHandler
 event CreateDialogViewOptionsEventHandler^ CreateDialogViewOptions {
    void add (CreateDialogViewOptionsEventHandler^ value);
    void remove (CreateDialogViewOptionsEventHandler^ value);
}


CreateDialogViewUserDictionaryEdit Event

CreateDialogViewUserDictionaryEdit Event
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► CreateDialogViewUserDictionaryEdit
Keyoti RapidSpell Silverlight
Indicates that a new IDialogViewUserDictionaryEdit is being created, also provides chance to override the default IDialogViewUserDictionaryEdit.
Declaration Syntax
C# Visual Basic Visual C++
event CreateDialogViewUserDictionaryEditEventHandler CreateDialogViewUserDictionaryEdit
Event CreateDialogViewUserDictionaryEdit As CreateDialogViewUserDictionaryEditEventHandler
 event CreateDialogViewUserDictionaryEditEventHandler^ CreateDialogViewUserDictionaryEdit {
    void add (CreateDialogViewUserDictionaryEditEventHandler^ value);
    void remove (CreateDialogViewUserDictionaryEditEventHandler^ value);
}


DialogTitleText Property

DialogTitleText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► DialogTitleText
Keyoti RapidSpell Silverlight
Dialog title text
Declaration Syntax
C# Visual Basic Visual C++
string DialogTitleText { get; set; }
Property DialogTitleText As String
property String^ DialogTitleText {
    String^ get ();
    void set (String^ value);
}


DialogView Property

DialogView Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► DialogView
Keyoti RapidSpell Silverlight
The IDialogView to use
Declaration Syntax
C# Visual Basic Visual C++
IDialogView DialogView { get; set; }
Property DialogView As IDialogView
property IDialogView^ DialogView {
    IDialogView^ get ();
    void set (IDialogView^ value);
}


DictFilePath Property

DictFilePath Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► DictFilePath
Keyoti RapidSpell Silverlight
Optional file path to the main dictionary .dict file to use.
Declaration Syntax
C# Visual Basic Visual C++
string DictFilePath { get; set; }
Property DictFilePath As String
property String^ DictFilePath {
    String^ get ();
    void set (String^ value);
}


DictionaryLoader Property

DictionaryLoader Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► DictionaryLoader
Keyoti RapidSpell Silverlight
The dictionary loader, which reports loading status.
Declaration Syntax
C# Visual Basic Visual C++
AsyncDictionaryLoader DictionaryLoader { get; set; }
Property DictionaryLoader As AsyncDictionaryLoader
property AsyncDictionaryLoader^ DictionaryLoader {
    AsyncDictionaryLoader^ get ();
    void set (AsyncDictionaryLoader^ value);
}


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► Dispose()()()
Keyoti RapidSpell Silverlight
Dispose of resources
Declaration Syntax
C# Visual Basic Visual C++
void Dispose()
Sub Dispose
void Dispose()


DisposeAtEnd Property

DisposeAtEnd Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► DisposeAtEnd
Keyoti RapidSpell Silverlight
Whether to dispose of this form when spell check is finished.
Declaration Syntax
C# Visual Basic Visual C++
bool DisposeAtEnd { get; set; }
Property DisposeAtEnd As Boolean
property bool DisposeAtEnd {
    bool get ();
    void set (bool value);
}


FindCapitalizedSuggestions Property

FindCapitalizedSuggestions Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► FindCapitalizedSuggestions
Keyoti RapidSpell Silverlight
Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
Declaration Syntax
C# Visual Basic Visual C++
bool FindCapitalizedSuggestions { get; set; }
Property FindCapitalizedSuggestions As Boolean
property bool FindCapitalizedSuggestions {
    bool get ();
    void set (bool value);
}


FindingSuggestionsLabelText Property

FindingSuggestionsLabelText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► FindingSuggestionsLabelText
Keyoti RapidSpell Silverlight
Finding suggestions label text.
Declaration Syntax
C# Visual Basic Visual C++
string FindingSuggestionsLabelText { get; set; }
Property FindingSuggestionsLabelText As String
property String^ FindingSuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}


FindSuggestionsLabelText Property

FindSuggestionsLabelText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► FindSuggestionsLabelText
Keyoti RapidSpell Silverlight
Find suggestions label text.
Declaration Syntax
C# Visual Basic Visual C++
string FindSuggestionsLabelText { get; set; }
Property FindSuggestionsLabelText As String
property String^ FindSuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}


FinishedCheckingSelectionPopUpText Property

FinishedCheckingSelectionPopUpText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► FinishedCheckingSelectionPopUpText
Keyoti RapidSpell Silverlight
Finished checking selection dialog text
Declaration Syntax
C# Visual Basic Visual C++
string FinishedCheckingSelectionPopUpText { get; set; }
Property FinishedCheckingSelectionPopUpText As String
property String^ FinishedCheckingSelectionPopUpText {
    String^ get ();
    void set (String^ value);
}


FinishedCheckingSelectionPopUpTitle Property

FinishedCheckingSelectionPopUpTitle Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► FinishedCheckingSelectionPopUpTitle
Keyoti RapidSpell Silverlight
Finished checking selection dialog title
Declaration Syntax
C# Visual Basic Visual C++
string FinishedCheckingSelectionPopUpTitle { get; set; }
Property FinishedCheckingSelectionPopUpTitle As String
property String^ FinishedCheckingSelectionPopUpTitle {
    String^ get ();
    void set (String^ value);
}


GUILanguage Property

GUILanguage Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► GUILanguage
Keyoti RapidSpell Silverlight
The language to show the UI in.
Declaration Syntax
C# Visual Basic Visual C++
LanguageType GUILanguage { get; set; }
Property GUILanguage As LanguageType
property LanguageType GUILanguage {
    LanguageType get ();
    void set (LanguageType value);
}


IgnoreAllButtonText Property

IgnoreAllButtonText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► IgnoreAllButtonText
Keyoti RapidSpell Silverlight
Ignore All button text.
Declaration Syntax
C# Visual Basic Visual C++
string IgnoreAllButtonText { get; set; }
Property IgnoreAllButtonText As String
property String^ IgnoreAllButtonText {
    String^ get ();
    void set (String^ value);
}


IgnoreButtonText Property

IgnoreButtonText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► IgnoreButtonText
Keyoti RapidSpell Silverlight
Ignore button text.
Declaration Syntax
C# Visual Basic Visual C++
string IgnoreButtonText { get; set; }
Property IgnoreButtonText As String
property String^ IgnoreButtonText {
    String^ get ();
    void set (String^ value);
}


IgnoreCapitalizedWords Property

IgnoreCapitalizedWords Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► IgnoreCapitalizedWords
Keyoti RapidSpell Silverlight
Sets whether to ignore words with capital letters.
Declaration Syntax
C# Visual Basic Visual C++
bool IgnoreCapitalizedWords { get; set; }
Property IgnoreCapitalizedWords As Boolean
property bool IgnoreCapitalizedWords {
    bool get ();
    void set (bool value);
}


IgnoreIncorrectSentenceCapitalization Property

IgnoreIncorrectSentenceCapitalization Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► IgnoreIncorrectSentenceCapitalization
Keyoti RapidSpell Silverlight
Whether to ignore incorrect sentence capitalization.
Declaration Syntax
C# Visual Basic Visual C++
bool IgnoreIncorrectSentenceCapitalization { get; set; }
Property IgnoreIncorrectSentenceCapitalization As Boolean
property bool IgnoreIncorrectSentenceCapitalization {
    bool get ();
    void set (bool value);
}


IgnoreInEnglishLowerCaseI Property

IgnoreInEnglishLowerCaseI Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► IgnoreInEnglishLowerCaseI
Keyoti RapidSpell Silverlight
Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
Declaration Syntax
C# Visual Basic Visual C++
bool IgnoreInEnglishLowerCaseI { get; set; }
Property IgnoreInEnglishLowerCaseI As Boolean
property bool IgnoreInEnglishLowerCaseI {
    bool get ();
    void set (bool value);
}


IgnoreWordsWithDigits Property

IgnoreWordsWithDigits Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► IgnoreWordsWithDigits
Keyoti RapidSpell Silverlight
Whether to ignore words with numbers in them (eg. A10 or 7-11).
Declaration Syntax
C# Visual Basic Visual C++
bool IgnoreWordsWithDigits { get; set; }
Property IgnoreWordsWithDigits As Boolean
property bool IgnoreWordsWithDigits {
    bool get ();
    void set (bool value);
}


IgnoreXML Property

IgnoreXML Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► IgnoreXML
Keyoti RapidSpell Silverlight
Whether to ignore XML/HTML tags, false by default.
Declaration Syntax
C# Visual Basic Visual C++
bool IgnoreXML { get; set; }
Property IgnoreXML As Boolean
property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
Remarks
This identifies XML tags as anything in between < and > characters, there for it will cause undesirable effects in text such as "the sign for less than is < and the sign for greater than is >". Of course in HTML that should have been written as "the sign for less than is &lt; and the sign for greater than is &gt;" anyway, which would be fine.


IncludeUserDictionaryInSuggestions Property

IncludeUserDictionaryInSuggestions Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► IncludeUserDictionaryInSuggestions
Keyoti RapidSpell Silverlight
Whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# Visual Basic Visual C++
bool IncludeUserDictionaryInSuggestions { get; set; }
Property IncludeUserDictionaryInSuggestions As Boolean
property bool IncludeUserDictionaryInSuggestions {
    bool get ();
    void set (bool value);
}


InDictionaryLabelText Property

InDictionaryLabelText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► InDictionaryLabelText
Keyoti RapidSpell Silverlight
In dictionary label text
Declaration Syntax
C# Visual Basic Visual C++
string InDictionaryLabelText { get; set; }
Property InDictionaryLabelText As String
property String^ InDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}


LanguageParser Property

LanguageParser Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► LanguageParser
Keyoti RapidSpell Silverlight
The type of language parsing to use.
Declaration Syntax
C# Visual Basic Visual C++
LanguageType LanguageParser { get; set; }
Property LanguageParser As LanguageType
property LanguageType LanguageParser {
    LanguageType get ();
    void set (LanguageType value);
}
Remarks
Eg. If the dictionary is set to French, you should use the French parser.


Load Event

Load Event
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► Load
Keyoti RapidSpell Silverlight
Fired when the DialogView loads.
Declaration Syntax
C# Visual Basic Visual C++
event EventHandler Load
Event Load As EventHandler
 event EventHandler^ Load {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


LookIntoHyphenatedText Property

LookIntoHyphenatedText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► LookIntoHyphenatedText
Keyoti RapidSpell Silverlight
Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
Declaration Syntax
C# Visual Basic Visual C++
bool LookIntoHyphenatedText { get; set; }
Property LookIntoHyphenatedText As Boolean
property bool LookIntoHyphenatedText {
    bool get ();
    void set (bool value);
}
Remarks
Eg. "socio-economic" will be checked as "socio" and "economic".


MaximumContextualWords Property

MaximumContextualWords Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► MaximumContextualWords
Keyoti RapidSpell Silverlight
The maximum number of words to show the user in the sentence around misspelled words.
Declaration Syntax
C# Visual Basic Visual C++
int MaximumContextualWords { get; set; }
Property MaximumContextualWords As Integer
property int MaximumContextualWords {
    int get ();
    void set (int value);
}


ModalAutoDispose Property

ModalAutoDispose Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► ModalAutoDispose
Keyoti RapidSpell Silverlight
When running modally, determines if the dialog will be disposed of when spell check finishes.
Declaration Syntax
C# Visual Basic Visual C++
bool ModalAutoDispose { get; set; }
Property ModalAutoDispose As Boolean
property bool ModalAutoDispose {
    bool get ();
    void set (bool value);
}
Remarks
If a modal form disposes of itself, there will be slight flickering on the screen, to prevent this, set this property to false and call Dispose() when finished with this control.


ModalMode Property

ModalMode Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► ModalMode
Keyoti RapidSpell Silverlight
Whether the spell checker will run modally. (Modal operation blocks the parent form)
Declaration Syntax
C# Visual Basic Visual C++
bool ModalMode { get; set; }
Property ModalMode As Boolean
property bool ModalMode {
    bool get ();
    void set (bool value);
}


NoSuggestionsText Property

NoSuggestionsText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► NoSuggestionsText
Keyoti RapidSpell Silverlight
No suggestions found text
Declaration Syntax
C# Visual Basic Visual C++
string NoSuggestionsText { get; set; }
Property NoSuggestionsText As String
property String^ NoSuggestionsText {
    String^ get ();
    void set (String^ value);
}


NotInDictionaryLabelText Property

NotInDictionaryLabelText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► NotInDictionaryLabelText
Keyoti RapidSpell Silverlight
Not in dictionary label text
Declaration Syntax
C# Visual Basic Visual C++
string NotInDictionaryLabelText { get; set; }
Property NotInDictionaryLabelText As String
property String^ NotInDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}


NumberSuggestionList Property

NumberSuggestionList Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► NumberSuggestionList
Keyoti RapidSpell Silverlight
Whether to number the items in the suggestion list, for quick user selection.
Declaration Syntax
C# Visual Basic Visual C++
bool NumberSuggestionList { get; set; }
Property NumberSuggestionList As Boolean
property bool NumberSuggestionList {
    bool get ();
    void set (bool value);
}


Options Property

Options Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► Options
Keyoti RapidSpell Silverlight
Object responsible for holding, loading and saving the user's spell check options.
Declaration Syntax
C# Visual Basic Visual C++
UserOptions Options { get; set; }
Property Options As UserOptions
property UserOptions^ Options {
    UserOptions^ get ();
    void set (UserOptions^ value);
}
Remarks
To customize how the user's options are saved/loaded, subclass UserOptions and set an instance in this property.


OptionsButtonText Property

OptionsButtonText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► OptionsButtonText
Keyoti RapidSpell Silverlight
Options button text
Declaration Syntax
C# Visual Basic Visual C++
string OptionsButtonText { get; set; }
Property OptionsButtonText As String
property String^ OptionsButtonText {
    String^ get ();
    void set (String^ value);
}


OptionsPresenter Property

OptionsPresenter Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► OptionsPresenter
Keyoti RapidSpell Silverlight
Presenter for the user options form (IDialogViewOptions).
Declaration Syntax
C# Visual Basic Visual C++
OptionsPresenter OptionsPresenter { get; set; }
Property OptionsPresenter As OptionsPresenter
property OptionsPresenter^ OptionsPresenter {
    OptionsPresenter^ get ();
    void set (OptionsPresenter^ value);
}
Remarks
Set properties in this instance to affect the options shown to the user, or handle CreateDialogViewOptions to create your own IDialogViewOptions form instance.


Ready Event

Ready Event
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► Ready
Keyoti RapidSpell Silverlight
Fired when ready to proceed with first query.
Declaration Syntax
C# Visual Basic Visual C++
event EventHandler Ready
Event Ready As EventHandler
 event EventHandler^ Ready {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


RecheckDocumentRequest Event

RecheckDocumentRequest Event
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► RecheckDocumentRequest
Keyoti RapidSpell Silverlight
Fired when the text should be rechecked
Declaration Syntax
C# Visual Basic Visual C++
event EventHandler RecheckDocumentRequest
Event RecheckDocumentRequest As EventHandler
 event EventHandler^ RecheckDocumentRequest {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


Remove Method

Remove Method
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► Remove()()()
Keyoti RapidSpell Silverlight
Safely frees up resources.
Declaration Syntax
C# Visual Basic Visual C++
void Remove()
Sub Remove
void Remove()


RemoveDuplicateWordText Property

RemoveDuplicateWordText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► RemoveDuplicateWordText
Keyoti RapidSpell Silverlight
Remove duplicate word text
Declaration Syntax
C# Visual Basic Visual C++
string RemoveDuplicateWordText { get; set; }
Property RemoveDuplicateWordText As String
property String^ RemoveDuplicateWordText {
    String^ get ();
    void set (String^ value);
}


ResumeButtonText Property

ResumeButtonText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► ResumeButtonText
Keyoti RapidSpell Silverlight
Resume button text
Declaration Syntax
C# Visual Basic Visual C++
string ResumeButtonText { get; set; }
Property ResumeButtonText As String
property String^ ResumeButtonText {
    String^ get ();
    void set (String^ value);
}


SeparateHyphenWords Property

SeparateHyphenWords Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► SeparateHyphenWords
Keyoti RapidSpell Silverlight
Sets whether to treat hyphenated (-) words as separate words, default is false.
Declaration Syntax
C# Visual Basic Visual C++
bool SeparateHyphenWords { get; set; }
Property SeparateHyphenWords As Boolean
property bool SeparateHyphenWords {
    bool get ();
    void set (bool value);
}
Remarks
For eg. if this is true text like "cheap-deals" will be treated as two words "cheap" and "deals", otherwise this will be treated as one word "cheap-deals".


SetIgnoreOnceBadWords Method (ignoreOnceBadWords)

SetIgnoreOnceBadWords Method (ignoreOnceBadWords)
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► SetIgnoreOnceBadWords(ArrayList)
Keyoti RapidSpell Silverlight
Provide a list of BadWord objects that have been ignored
Declaration Syntax
C# Visual Basic Visual C++
void SetIgnoreOnceBadWords(
    ArrayList ignoreOnceBadWords
)
Sub SetIgnoreOnceBadWords ( _
    ignoreOnceBadWords As ArrayList _
)
void SetIgnoreOnceBadWords(
    ArrayList^ ignoreOnceBadWords
)
Parameters
ignoreOnceBadWords (ArrayList)


ShowContextSentence Property

ShowContextSentence Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► ShowContextSentence
Keyoti RapidSpell Silverlight
Whether to show the query in context of it's sentence/line.
Declaration Syntax
C# Visual Basic Visual C++
bool ShowContextSentence { get; set; }
Property ShowContextSentence As Boolean
property bool ShowContextSentence {
    bool get ();
    void set (bool value);
}


ShowFinishedMessageBox Property

ShowFinishedMessageBox Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► ShowFinishedMessageBox
Keyoti RapidSpell Silverlight
Whether a message box should be opened when the spell check is complete.
Declaration Syntax
C# Visual Basic Visual C++
bool ShowFinishedMessageBox { get; set; }
Property ShowFinishedMessageBox As Boolean
property bool ShowFinishedMessageBox {
    bool get ();
    void set (bool value);
}


SpellCheckFinished Event

SpellCheckFinished Event
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► SpellCheckFinished
Keyoti RapidSpell Silverlight
Fired when checking finishes
Declaration Syntax
C# Visual Basic Visual C++
event RapidSpellGUIPresenter..::.SpellCheckEventHandler SpellCheckFinished
Event SpellCheckFinished As RapidSpellGUIPresenter..::.SpellCheckEventHandler
 event RapidSpellGUIPresenter..::.SpellCheckEventHandler^ SpellCheckFinished {
    void add (RapidSpellGUIPresenter..::.SpellCheckEventHandler^ value);
    void remove (RapidSpellGUIPresenter..::.SpellCheckEventHandler^ value);
}


SpellCheckStarted Event

SpellCheckStarted Event
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► SpellCheckStarted
Keyoti RapidSpell Silverlight
Fired when checking starts
Declaration Syntax
C# Visual Basic Visual C++
event RapidSpellGUIPresenter..::.SpellCheckEventHandler SpellCheckStarted
Event SpellCheckStarted As RapidSpellGUIPresenter..::.SpellCheckEventHandler
 event RapidSpellGUIPresenter..::.SpellCheckEventHandler^ SpellCheckStarted {
    void add (RapidSpellGUIPresenter..::.SpellCheckEventHandler^ value);
    void remove (RapidSpellGUIPresenter..::.SpellCheckEventHandler^ value);
}


SuggestionsLabelText Property

SuggestionsLabelText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► SuggestionsLabelText
Keyoti RapidSpell Silverlight
Suggestions label text
Declaration Syntax
C# Visual Basic Visual C++
string SuggestionsLabelText { get; set; }
Property SuggestionsLabelText As String
property String^ SuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}


SuggestionsMethod Property

SuggestionsMethod Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► SuggestionsMethod
Keyoti RapidSpell Silverlight
Sets the suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
Declaration Syntax
C# Visual Basic Visual C++
SuggestionsMethodType SuggestionsMethod { get; set; }
Property SuggestionsMethod As SuggestionsMethodType
property SuggestionsMethodType SuggestionsMethod {
    SuggestionsMethodType get ();
    void set (SuggestionsMethodType value);
}


SuggestSplitWords Property

SuggestSplitWords Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► SuggestSplitWords
Keyoti RapidSpell Silverlight
Whether to look for connected words in suggestions.
Declaration Syntax
C# Visual Basic Visual C++
bool SuggestSplitWords { get; set; }
Property SuggestSplitWords As Boolean
property bool SuggestSplitWords {
    bool get ();
    void set (bool value);
}
Remarks
if this=true then suggestions may include joined words.

Eg; suggestions for "myhouse" will include "my house"


UndoButtonText Property

UndoButtonText Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► UndoButtonText
Keyoti RapidSpell Silverlight
Undo button text
Declaration Syntax
C# Visual Basic Visual C++
string UndoButtonText { get; set; }
Property UndoButtonText As String
property String^ UndoButtonText {
    String^ get ();
    void set (String^ value);
}


Undone Event

Undone Event
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► Undone
Keyoti RapidSpell Silverlight
Fired when an Undo occurs
Declaration Syntax
C# Visual Basic Visual C++
event UndoEventHandler Undone
Event Undone As UndoEventHandler
 event UndoEventHandler^ Undone {
    void add (UndoEventHandler^ value);
    void remove (UndoEventHandler^ value);
}


UserDictionary Property

UserDictionary Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► UserDictionary
Keyoti RapidSpell Silverlight
Set the user dictionary object.
Declaration Syntax
C# Visual Basic Visual C++
UserDictionary UserDictionary { get; set; }
Property UserDictionary As UserDictionary
property UserDictionary^ UserDictionary {
    UserDictionary^ get ();
    void set (UserDictionary^ value);
}
Remarks
Use of a user dictionary is optional.


UserDictionaryFile Property

UserDictionaryFile Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► UserDictionaryFile
Keyoti RapidSpell Silverlight
Set the user dictionary file, if this file doesn't exist it will be created.
Declaration Syntax
C# Visual Basic Visual C++
string UserDictionaryFile { set; }
WriteOnly Property UserDictionaryFile As String
property String^ UserDictionaryFile {
    void set (String^ value);
}
Remarks
Use of a user dictionary is optional.


UserQuery Event

UserQuery Event
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► UserQuery
Keyoti RapidSpell Silverlight
Indicates that the user is being queried on a spelling error.
Declaration Syntax
C# Visual Basic Visual C++
event UserQueryEventHandler UserQuery
Event UserQuery As UserQueryEventHandler
 event UserQueryEventHandler^ UserQuery {
    void add (UserQueryEventHandler^ value);
    void remove (UserQueryEventHandler^ value);
}


WarnDuplicates Property

WarnDuplicates Property
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► WarnDuplicates
Keyoti RapidSpell Silverlight
Whether to show duplicate words as errors (eg. "this is is an error").
Declaration Syntax
C# Visual Basic Visual C++
bool WarnDuplicates { get; set; }
Property WarnDuplicates As Boolean
property bool WarnDuplicates {
    bool get ();
    void set (bool value);
}


WordAdded Event

WordAdded Event
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► WordAdded
Keyoti RapidSpell Silverlight
Fired when word added to user dictionary
Declaration Syntax
C# Visual Basic Visual C++
event WordAddedEventHandler WordAdded
Event WordAdded As WordAddedEventHandler
 event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}


WordChanged Event

WordChanged Event
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► WordChanged
Keyoti RapidSpell Silverlight
Fired when word changed
Declaration Syntax
C# Visual Basic Visual C++
event WordChangedEventHandler WordChanged
Event WordChanged As WordChangedEventHandler
 event WordChangedEventHandler^ WordChanged {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}


WordChanging Event

WordChanging Event
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► WordChanging
Keyoti RapidSpell Silverlight
Fired before a word is changed
Declaration Syntax
C# Visual Basic Visual C++
event WordChangedEventHandler WordChanging
Event WordChanging As WordChangedEventHandler
 event WordChangedEventHandler^ WordChanging {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}


WordIgnored Event

WordIgnored Event
API ► Keyoti.RapidSpell ► IUserInterfaceFormPresenter ► WordIgnored
Keyoti RapidSpell Silverlight
Fired when word ignored
Declaration Syntax
C# Visual Basic Visual C++
event WordIgnoredEventHandler WordIgnored
Event WordIgnored As WordIgnoredEventHandler
 event WordIgnoredEventHandler^ WordIgnored {
    void add (WordIgnoredEventHandler^ value);
    void remove (WordIgnoredEventHandler^ value);
}


Label Class

Label Class
API ► Keyoti.RapidSpell ► Label
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public class Label
Public Class Label
public ref class Label
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Label()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Text |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Label


Label Constructor

Label Constructor
API ► Keyoti.RapidSpell ► Label ► Label()()()
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public Label()
Public Sub New
public:
Label()


Text Property

Text Property
API ► Keyoti.RapidSpell ► Label ► Text
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public string Text { get; set; }
Public Property Text As String
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}


LanguageType Enumeration

LanguageType Enumeration
API ► Keyoti.RapidSpell ► LanguageType
Keyoti RapidSpell Silverlight
Enumeration of language types.
Declaration Syntax
C# Visual Basic Visual C++
public enum LanguageType
Public Enumeration LanguageType
public enum class LanguageType
Members
Member | Description
ENGLISH | English.
DUTCH | Dutch.
FRENCH | French.
GERMAN | German.
ITALIAN | Italian.
PORTUGUESE | Portuguese.
SPANISH | Spanish.
POLISH | Polish.


License Class

License Class
API ► Keyoti.RapidSpell ► License
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public class License
Public Class License
public ref class License
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | License()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
License


License Constructor

License Constructor
API ► Keyoti.RapidSpell ► License ► License()()()
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public License()
Public Sub New
public:
License()


LicenseProvider Class

LicenseProvider Class
API ► Keyoti.RapidSpell ► LicenseProvider
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public class LicenseProvider
Public Class LicenseProvider
public ref class LicenseProvider
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | LicenseProvider()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
LicenseProvider


LicenseProvider Constructor

LicenseProvider Constructor
API ► Keyoti.RapidSpell ► LicenseProvider ► LicenseProvider()()()
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public LicenseProvider()
Public Sub New
public:
LicenseProvider()


ListBox Class

ListBox Class
API ► Keyoti.RapidSpell ► ListBox
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public class ListBox
Public Class ListBox
public ref class ListBox
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ListBox()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ListBox


ListBox Constructor

ListBox Constructor
API ► Keyoti.RapidSpell ► ListBox ► ListBox()()()
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public ListBox()
Public Sub New
public:
ListBox()


MessageBoxButtons Enumeration

MessageBoxButtons Enumeration
API ► Keyoti.RapidSpell ► MessageBoxButtons
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public enum MessageBoxButtons
Public Enumeration MessageBoxButtons
public enum class MessageBoxButtons
Members
Member | Description
OK |
YesNo |


MessageBoxIcon Enumeration

MessageBoxIcon Enumeration
API ► Keyoti.RapidSpell ► MessageBoxIcon
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public enum MessageBoxIcon
Public Enumeration MessageBoxIcon
public enum class MessageBoxIcon
Members
Member | Description
Error |
Question |
Information |


NoCurrentBadWordException Class

NoCurrentBadWordException Class
API ► Keyoti.RapidSpell ► NoCurrentBadWordException
Keyoti RapidSpell Silverlight
Thrown if NextBadWord has not been run first and found a mis-spelt word.
Declaration Syntax
C# Visual Basic Visual C++
public class NoCurrentBadWordException : ApplicationException
Public Class NoCurrentBadWordException _
    Inherits ApplicationException
public ref class NoCurrentBadWordException : public ApplicationException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NoCurrentBadWordException()()() | Create a new instance with no message.
 | NoCurrentBadWordException(String) | Create a new instance with mesg as a message.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | ApplicationException
 |  |  | NoCurrentBadWordException


NoCurrentBadWordException Constructor

NoCurrentBadWordException Constructor
API ► Keyoti.RapidSpell ► NoCurrentBadWordException ► NoCurrentBadWordException()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | NoCurrentBadWordException()()() | Create a new instance with no message.
 | NoCurrentBadWordException(String) | Create a new instance with mesg as a message.


NoCurrentBadWordException Constructor

NoCurrentBadWordException Constructor
API ► Keyoti.RapidSpell ► NoCurrentBadWordException ► NoCurrentBadWordException()()()
Keyoti RapidSpell Silverlight
Create a new instance with no message.
Declaration Syntax
C# Visual Basic Visual C++
public NoCurrentBadWordException()
Public Sub New
public:
NoCurrentBadWordException()


NoCurrentBadWordException Constructor (mesg)

NoCurrentBadWordException Constructor (mesg)
API ► Keyoti.RapidSpell ► NoCurrentBadWordException ► NoCurrentBadWordException(String)
Keyoti RapidSpell Silverlight
Create a new instance with mesg as a message.
Declaration Syntax
C# Visual Basic Visual C++
public NoCurrentBadWordException(
    string mesg
)
Public Sub New ( _
    mesg As String _
)
public:
NoCurrentBadWordException(
    String^ mesg
)
Parameters
mesg (String)


NoTextComponentException Class

NoTextComponentException Class
API ► Keyoti.RapidSpell ► NoTextComponentException
Keyoti RapidSpell Silverlight
Thrown if a valid text component hasn't been set to be checked (by the GUI for example).
Declaration Syntax
C# Visual Basic Visual C++
public class NoTextComponentException : Exception
Public Class NoTextComponentException _
    Inherits Exception
public ref class NoTextComponentException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NoTextComponentException()()() | Create a new instance with no message.
 | NoTextComponentException(String) | Create a new instance with mesg as a message.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | NoTextComponentException


NoTextComponentException Constructor

NoTextComponentException Constructor
API ► Keyoti.RapidSpell ► NoTextComponentException ► NoTextComponentException()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | NoTextComponentException()()() | Create a new instance with no message.
 | NoTextComponentException(String) | Create a new instance with mesg as a message.


NoTextComponentException Constructor

NoTextComponentException Constructor
API ► Keyoti.RapidSpell ► NoTextComponentException ► NoTextComponentException()()()
Keyoti RapidSpell Silverlight
Create a new instance with no message.
Declaration Syntax
C# Visual Basic Visual C++
public NoTextComponentException()
Public Sub New
public:
NoTextComponentException()


NoTextComponentException Constructor (mesg)

NoTextComponentException Constructor (mesg)
API ► Keyoti.RapidSpell ► NoTextComponentException ► NoTextComponentException(String)
Keyoti RapidSpell Silverlight
Create a new instance with mesg as a message.
Declaration Syntax
C# Visual Basic Visual C++
public NoTextComponentException(
    string mesg
)
Public Sub New ( _
    mesg As String _
)
public:
NoTextComponentException(
    String^ mesg
)
Parameters
mesg (String)


OperationScope Enumeration

OperationScope Enumeration
API ► Keyoti.RapidSpell ► OperationScope
Keyoti RapidSpell Silverlight
The scope of an operation.
Declaration Syntax
C# Visual Basic Visual C++
public enum OperationScope
Public Enumeration OperationScope
public enum class OperationScope
Members
Member | Description
AllAssignedTextBoxes | Perform operation on all assigned text boxes.
CurrentTextBox | Perform operation on current text box only.


OptionsSavedEventArgs Class

OptionsSavedEventArgs Class
API ► Keyoti.RapidSpell ► OptionsSavedEventArgs
Keyoti RapidSpell Silverlight
Args for the options saved event.
Declaration Syntax
C# Visual Basic Visual C++
public class OptionsSavedEventArgs : EventArgs
Public Class OptionsSavedEventArgs _
    Inherits EventArgs
public ref class OptionsSavedEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OptionsSavedEventArgs(Boolean) | New instance
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TextRecheckRequired | Whether the change in options requires the text to be rechecked.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | OptionsSavedEventArgs


OptionsSavedEventArgs Constructor (textRecheckRequired)

OptionsSavedEventArgs Constructor (textRecheckRequired)
API ► Keyoti.RapidSpell ► OptionsSavedEventArgs ► OptionsSavedEventArgs(Boolean)
Keyoti RapidSpell Silverlight
New instance
Declaration Syntax
C# Visual Basic Visual C++
public OptionsSavedEventArgs(
    bool textRecheckRequired
)
Public Sub New ( _
    textRecheckRequired As Boolean _
)
public:
OptionsSavedEventArgs(
    bool textRecheckRequired
)
Parameters
textRecheckRequired (Boolean)
Whether the change in options requires the text to be rechecked.


TextRecheckRequired Property

TextRecheckRequired Property
API ► Keyoti.RapidSpell ► OptionsSavedEventArgs ► TextRecheckRequired
Keyoti RapidSpell Silverlight
Whether the change in options requires the text to be rechecked.
Declaration Syntax
C# Visual Basic Visual C++
public bool TextRecheckRequired { get; }
Public ReadOnly Property TextRecheckRequired As Boolean
public:
property bool TextRecheckRequired {
    bool get ();
}


OptionsSavedEventHandler Delegate

OptionsSavedEventHandler Delegate
API ► Keyoti.RapidSpell ► OptionsSavedEventHandler
Keyoti RapidSpell Silverlight
Handler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void OptionsSavedEventHandler(
    Object sender,
    OptionsSavedEventArgs e
)
Public Delegate Sub OptionsSavedEventHandler ( _
    sender As Object, _
    e As OptionsSavedEventArgs _
)
public delegate void OptionsSavedEventHandler(
    Object^ sender,
    OptionsSavedEventArgs^ e
)
Parameters
sender (Object)
e (OptionsSavedEventArgs)


RapidSpellChecker Class

RapidSpellChecker Class
API ► Keyoti.RapidSpell ► RapidSpellChecker
Keyoti RapidSpell Silverlight
Spell checker engine, checks a text string for spelling errors and makes suggested corrections.
Declaration Syntax
C# Visual Basic Visual C++
public class RapidSpellChecker : ICheckerEngine
Public Class RapidSpellChecker _
    Implements ICheckerEngine
public ref class RapidSpellChecker : ICheckerEngine
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RapidSpellChecker()()() | Creates a RapidSpellChecker, with no user dictionary.
 | AddIgnorePattern(String) | Adds a regex pattern to ignore (maximum of 20 can be added - IgnoreURLsAndEmailAddresses=true counts as 1).
 | AddWord(String) | Adds word to the user dictionary (if it has been specified).
 | AllowAnyCase | Whether to allow words spelt with incorrect case, eg. "africa", instead of "Africa", this is more relaxed than AllowMixedCase
 | AllowMixedCase | Whether to allow words spelt with mixed case, eg. "MIxEd" - also see AllowAnyCase.
 | ChangeAll(String) | Changes all instances of the current bad word to newWord in the text.
 | ChangeBadWord(String) | Changes the current bad word to newWord in the text.
 | ChangeBadWord(BadWord, String) | Changes badWord to newWord in the text.
 | Check(String) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
 | Check(String, Boolean) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
 | Check(String, Int32) | Checks text for spelling correctness, from startPosition in text, mis-spelt words can be accessed through NextBadWord.
 | Check(String, Int32, Boolean) | Checks text for spelling correctness, from startPosition in text, mis-spelt words can be accessed through NextBadWord.
 | CheckCompoundWords | Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
 | convertHtmlEntities(String) | Converts HTML entity codes to their Unicode characters
 | convertHtmlEntities(String, Boolean) | Converts HTML entity codes to their Unicode characters
 | CurrentBadWord | Gets the current bad word (last returned by NextBadWord).
 | DictFilePath |
 | Dispose(Boolean) | Disposes of resources.
 | Dispose()()() | Clean up any resources being used.
 | dontSuggest | Don't suggest words in this array (swear words).
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Frees up resources. (Overrides Object.Finalize()()().)
 | FindAnagrams(String, IList) | Finds anagrams of word and puts them in anagrams if not already present.
 | FindCapitalizedSuggestions | Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
 | FindCompoundWords(String, IList) | Finds the compound words in text and puts them in subwords, set subwords to null/nothing to just find if text has compound word formation.
 | FindSuggestions()()() | Gets an enumeration of String suggestions for spelling of current bad word.
 | FindSuggestions(String) | Gets an enumeration of String suggestions for word.
 | FindSuggestions(String, Boolean) | Gets an enumeration of String suggestions for word.
 | GetAmendedText()()() | Returns the original text sent to check() but with any alterations made through change
 | GetConsiderationRange()()() | Gets the factor for words to consider for suggestions.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIgnoreCapitalizedWords()()() | Gets whether to ignore words with capital letters.
 | GetIncludeUserDictionaryInSuggestions()()() | Gets whether the user dictionary should be used in finding suggestions for misspelt words.
 | GetNextWord()()() | Returns the next word in the text.
 | GetSeparateHyphenWords()()() | Gets whether to treat hyphenated (-) words as separate words, default is false.
 | GetSuggestionsMethod()()() | Gets the suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUndoableStatePoint()()() | Gets the state of the current run, which can be stored and used with RevertToUndoableStatePoint(RapidSpellChecker..::.State)
 | HASHING_SUGGESTIONS | Indicator for suggestion method (Hashing is default).
 | IgnoreAll(String) | Marks word to be ignored in rest of the text.
 | IgnoreIncorrectSentenceCapitalization | Whether to ignore incorrect sentence capitalization.
 | IgnoreInEnglishLowerCaseI | Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
 | IgnoreList | The words to ignore, note this list is changed by IgnoreAll.
 | IgnoreRtfCodes | Sets whether this should ignore Rtf (or any escaped) codes in the text.
 | IgnoreURLsAndEmailAddresses | Whether to ignore URLs and email addresses (requires V2Parser=true)
 | IgnoreWordsWithDigits | Whether to ignore words with numbers in them (eg. A10 or 7-11).
 | IgnoreXML | Whether to ignore XML/HTML tags, should be set true for RichTextBox support, false by default.
 | IsAllCaps(String) | Whether all chars in s are in upper case
 | IsStartsWithCap(String) | Whether first letter is a capital and rest are lower.
 | IsWord(Int32, Int32) | Whether the word defined by the parameters is a word or whitespace.
 | LanguageParser | The type of language parsing to use.
 | LicenseKey | The license key
 | LookIntoHyphenatedText | Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
 | LookUp(String) | Checks if query is in the main dictionary or user.
 | LookUpMainDictionary(String) | Checks if query is in the word dictionary. Returns true if doesnt start with a letter or apostrophe
 | LookUpUserDictionary(String) | Look up the query in the user dictionary if it exists.
 | Main(array<String>[]()[]) | For test purposes
 | MakeCap(String) | Capitalises first letter of word
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NextBadWord()()() | Returns the next mis-spelt word in the text, as a BadWord object.
 | PHONETIC_SUGGESTIONS | Indicator for suggestion method (Hashing is default).
 | ReloadUserDictionary()()() | Reloads the user dictionary.
 | RemoveIgnorePattern(String) | Removes a regex pattern to ignore (maximum of 20 can be added - IgnoreURLsAndEmailAddresses=true counts as 1).
 | RevertToUndoableStatePoint(RapidSpellChecker..::.State) | Reverts the state to what it was when GetUndoableStatePoint()()() was called.
 | SetConsiderationRange(Int32) | Sets the factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anything.
 | SetDictFileStream(Stream, String) | Passes a Dict file as a stream, to be used for the main dictionary.
 | SetIgnoreCapitalizedWords(Boolean) | Sets whether to ignore words with capital letters.
 | SetIncludeUserDictionaryInSuggestions(Boolean) | Sets whether the user dictionary should be used in finding suggestions for misspelt words.
 | SetOptionalContext(String, String) | Provides the engine with any helpful text around the text snippet which will be passed to the Check method.
 | SetPosition(Int32) | Sets the pointer position for the NextBadWord iterator.
 | SetSeparateHyphenWords(Boolean) | Sets whether to treat hyphenated (-) words as separate words, default is false.
 | SetSuggestionsMethod(Int32) | Sets the suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
 | SetUserDictionary(String) | Set the user dictionary to use.
 | SetUserDictionary(UserDictionary) | Set the user dictionary to use.
 | ShareDictionary | Obsolete. Whether to share the dictionary in memory across all instances of RapidSpellChecker (false by default).
 | SuggestSplitWords | Whether to look for connected words in suggestions.
 | TextBoundary | The AdvancedTextBoundary class to use to parse words.
 | theCurrentBadWord |
 | theText | The text being checked.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UnloadMainDictionary()()() | Obsolete. Empties the main dictionary store.
 | userDictionary | The UserDictionary being used, may be null if no user dictionary is being used.
 | V2Parser | Whether to use parser version 2 - Set to false for backwards compatibility.
 | WarnDuplicates | Whether to treat duplicate words as errors (eg. "this is is an error").
 | WordAdded | Fired when word added to user dictionary
 | WordChanged | Change word event, fired when a word is changed.
 | wordEnd | The end index of the current word being checked/parsed.
 | WordIgnored | Fired when word ignored
 | wordStart | The start index of the current word being checked/parsed.
Remarks
This is a non-GUI component, suitable for the business/logic layer of your application. You would use this component in web server based applications. This component can be used in 2 different ways. The most common usage, in an iterative fashion is detailed below, but it may also be used on a query by query basis. To use this component in an iterative way you must first call Check to set the text to check and then iterate through NextBadWord() to identify misspelt words. NextBadWord will return a BadWord object and internally locate the the misspelt word in the text, then you can call FindSuggestions which will return a ArrayList of suggestions as String objects. You may also call ChangeBadWord(replacement) to replace that current misspelt word in the text. NextBadWord() will return null when the text has been checked. GetAmendedText returns the current state of the text with corrections. Calling ChangeBadWord or FindSuggestions before NextBadWord has been called and returned a BadWord (i.e. not null) will result in a NoCurrentBadWordException
Remarks

The second way to use this component is simply to query words yourself using LookUp(word) to check if word is in the lexicon/dictionary and FindSuggestions(word) to find spelling suggestions for word.

Examples
Check some text, find suggestions and replace mis-spelt words with "replacement".
CopyC#
RapidSpellChecker c = new RapidSpellChecker();
BadWord badWord;
ArrayList suggestions;

 //check some text.
c.Check("This is sume text.");

//iterate through all bad words in the text.
while((badWord = c.NextBadWord())!=null){

    Console.WriteLine(badWord.GetWord() + "- is not spelt correctly. Suggestions:");

    try{
        //get suggestions for the current bad word.
        suggestions = c.FindSuggestions();

        //display all suggestions.
        for(int i=0; i<suggestions.Count; i++){
            Console.WriteLine(suggestions[i]);
        }

        //change the bad word in the text with "replacement".
        c.ChangeBadWord("replacement");

    } catch (NoCurrentBadWordException e){
        Console.WriteLine(e);
    }

}
Console.WriteLine(c.GetAmendedText());
Inheritance Hierarchy
Object
RapidSpellChecker


RapidSpellChecker Constructor

RapidSpellChecker Constructor
API ► Keyoti.RapidSpell ► RapidSpellChecker ► RapidSpellChecker()()()
Keyoti RapidSpell Silverlight
Creates a RapidSpellChecker, with no user dictionary.
Declaration Syntax
C# Visual Basic Visual C++
public RapidSpellChecker()
Public Sub New
public:
RapidSpellChecker()
Exceptions
Exception | Condition
[!:System.ApplicationException] | If the dictionary cannot be read.


AddIgnorePattern Method (p)

AddIgnorePattern Method (p)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► AddIgnorePattern(String)
Keyoti RapidSpell Silverlight
Adds a regex pattern to ignore (maximum of 20 can be added - IgnoreURLsAndEmailAddresses=true counts as 1).
Declaration Syntax
C# Visual Basic Visual C++
public virtual void AddIgnorePattern(
    string p
)
Public Overridable Sub AddIgnorePattern ( _
    p As String _
)
public:
virtual void AddIgnorePattern(
    String^ p
)
Parameters
p (String)
Remarks
Eg, to ignore email addresses either set IgnoreURLsAndEmailAddresses=true or AddIgnorePattern("^(?:[0-9a-zA-Z](?:[-.\w]*[0-9a-zA-Z])*@(?:[0-9a-zA-Z][-\w]*[0-9a-zA-Z]\.)+[a-zA-Z]{2,9})$").


AddWord Method (word)

AddWord Method (word)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► AddWord(String)
Keyoti RapidSpell Silverlight
Adds word to the user dictionary (if it has been specified).
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool AddWord(
    string word
)
Public Overridable Function AddWord ( _
    word As String _
) As Boolean
public:
virtual bool AddWord(
    String^ word
)
Parameters
word (String)
String to add to user dictionary, if it is being used.
Return Value
boolean true if the word was is now in the user dictionary, false if the word could not be added to the user dictionary.
Exceptions
Exception | Condition
ArgumentNullException | If word parameter is null.


AllowAnyCase Property

AllowAnyCase Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► AllowAnyCase
Keyoti RapidSpell Silverlight
Whether to allow words spelt with incorrect case, eg. "africa", instead of "Africa", this is more relaxed than AllowMixedCase
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowAnyCase { get; set; }
Public Property AllowAnyCase As Boolean
public:
virtual property bool AllowAnyCase {
    bool get () sealed;
    void set (bool value) sealed;
}


AllowMixedCase Property

AllowMixedCase Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► AllowMixedCase
Keyoti RapidSpell Silverlight
Whether to allow words spelt with mixed case, eg. "MIxEd" - also see AllowAnyCase.
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowMixedCase { get; set; }
Public Property AllowMixedCase As Boolean
public:
virtual property bool AllowMixedCase {
    bool get () sealed;
    void set (bool value) sealed;
}


ChangeAll Method (newWord)

ChangeAll Method (newWord)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► ChangeAll(String)
Keyoti RapidSpell Silverlight
Changes all instances of the current bad word to newWord in the text.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void ChangeAll(
    string newWord
)
Public Overridable Sub ChangeAll ( _
    newWord As String _
)
public:
virtual void ChangeAll(
    String^ newWord
)
Parameters
newWord (String)
Exceptions
Exception | Condition
NoCurrentBadWordException | if nextBadWord() hasn't been run first AND found an erroneous word.
ArgumentNullException | if newWord parameter is null.


ChangeBadWord Method

ChangeBadWord Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► ChangeBadWord()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | ChangeBadWord(String) | Changes the current bad word to newWord in the text.
 | ChangeBadWord(BadWord, String) | Changes badWord to newWord in the text.


ChangeBadWord Method (badWord, newWord)

ChangeBadWord Method (badWord, newWord)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► ChangeBadWord(BadWord, String)
Keyoti RapidSpell Silverlight
Changes badWord to newWord in the text.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void ChangeBadWord(
    BadWord badWord,
    string newWord
)
Public Overridable Sub ChangeBadWord ( _
    badWord As BadWord, _
    newWord As String _
)
public:
virtual void ChangeBadWord(
    BadWord^ badWord,
    String^ newWord
)
Parameters
badWord (BadWord)
word to replace
newWord (String)
replaces the current misspelt word.
Return Value
void
Exceptions
Exception | Condition
ArgumentNullException | if newWord parameter is null.


ChangeBadWord Method (newWord)

ChangeBadWord Method (newWord)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► ChangeBadWord(String)
Keyoti RapidSpell Silverlight
Changes the current bad word to newWord in the text.
Declaration Syntax
C# Visual Basic Visual C++
public void ChangeBadWord(
    string newWord
)
Public Sub ChangeBadWord ( _
    newWord As String _
)
public:
virtual void ChangeBadWord(
    String^ newWord
) sealed
Parameters
newWord (String)
Replaces the current misspelt word.
Return Value
void
Exceptions
Exception | Condition
NoCurrentBadWordException | if nextBadWord() hasn't been run first AND found an erroneous word.
ArgumentNullException | if newWord parameter is null.


Check Method

Check Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► Check()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | Check(String) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
 | Check(String, Boolean) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
 | Check(String, Int32) | Checks text for spelling correctness, from startPosition in text, mis-spelt words can be accessed through NextBadWord.
 | Check(String, Int32, Boolean) | Checks text for spelling correctness, from startPosition in text, mis-spelt words can be accessed through NextBadWord.


Check Method (text)

Check Method (text)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► Check(String)
Keyoti RapidSpell Silverlight
Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
Declaration Syntax
C# Visual Basic Visual C++
public void Check(
    string text
)
Public Sub Check ( _
    text As String _
)
public:
virtual void Check(
    String^ text
) sealed
Parameters
text (String)
to spell check.
Return Value
void
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


Check Method (text, isStartOfTextBody)

Check Method (text, isStartOfTextBody)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► Check(String, Boolean)
Keyoti RapidSpell Silverlight
Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
Declaration Syntax
C# Visual Basic Visual C++
public void Check(
    string text,
    bool isStartOfTextBody
)
Public Sub Check ( _
    text As String, _
    isStartOfTextBody As Boolean _
)
public:
virtual void Check(
    String^ text,
    bool isStartOfTextBody
) sealed
Parameters
text (String)
to spell check.
isStartOfTextBody (Boolean)
whether the text being spell checked is at the start of the text body (eg. start of text box), this affects sentence capitalization determination.
Return Value
void
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


Check Method (text, startPosition)

Check Method (text, startPosition)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► Check(String, Int32)
Keyoti RapidSpell Silverlight
Checks text for spelling correctness, from startPosition in text, mis-spelt words can be accessed through NextBadWord.
Declaration Syntax
C# Visual Basic Visual C++
public void Check(
    string text,
    int startPosition
)
Public Sub Check ( _
    text As String, _
    startPosition As Integer _
)
public:
void Check(
    String^ text,
    int startPosition
)
Parameters
text (String)
the text to be checked
startPosition (Int32)
the position in the text to begin checking from
Return Value
void
Remarks
startPosition should be >=0 but if it is < 0 it is set = 0.
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


Check Method (text, startPosition, isStartOfTextBody)

Check Method (text, startPosition, isStartOfTextBody)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► Check(String, Int32, Boolean)
Keyoti RapidSpell Silverlight
Checks text for spelling correctness, from startPosition in text, mis-spelt words can be accessed through NextBadWord.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Check(
    string text,
    int startPosition,
    bool isStartOfTextBody
)
Public Overridable Sub Check ( _
    text As String, _
    startPosition As Integer, _
    isStartOfTextBody As Boolean _
)
public:
virtual void Check(
    String^ text,
    int startPosition,
    bool isStartOfTextBody
)
Parameters
text (String)
the text to be checked
startPosition (Int32)
the position in the text to begin checking from
isStartOfTextBody (Boolean)
whether the text being spell checked is at the start of the text body (eg. start of text box), this affects sentence capitalization determination.
Return Value
void
Remarks
startPosition should be >=0 but if it is < 0 it is set = 0.
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


CheckCompoundWords Property

CheckCompoundWords Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► CheckCompoundWords
Keyoti RapidSpell Silverlight
Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckCompoundWords { get; set; }
Public Property CheckCompoundWords As Boolean
public:
virtual property bool CheckCompoundWords {
    bool get () sealed;
    void set (bool value) sealed;
}
Remarks
If this=false then LookUp("thesewordsarejoined") = false

If this=true then LookUp("thesewordsarejoined") = true

If this=false then LookUp("abcdef") = false

If this=true then LookUp("abcdef") = false

Setting this to true will degrade lookup performance by a maximum of approx. 100[1-1/n] percent (where n is the number of letters in the word) for misspelt words. There is no preformance degredation for correctly spelt words. On average for texts with mostly correctly spelt words the performance degredation for the Check method is roughly 25%.


convertHtmlEntities Method

convertHtmlEntities Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► convertHtmlEntities()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | convertHtmlEntities(String) | Converts HTML entity codes to their Unicode characters
 | convertHtmlEntities(String, Boolean) | Converts HTML entity codes to their Unicode characters


convertHtmlEntities Method (text)

convertHtmlEntities Method (text)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► convertHtmlEntities(String)
Keyoti RapidSpell Silverlight
Converts HTML entity codes to their Unicode characters
Declaration Syntax
C# Visual Basic Visual C++
public static string convertHtmlEntities(
    string text
)
Public Shared Function convertHtmlEntities ( _
    text As String _
) As String
public:
static String^ convertHtmlEntities(
    String^ text
)
Parameters
text (String)


convertHtmlEntities Method (text, convertAMP)

convertHtmlEntities Method (text, convertAMP)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► convertHtmlEntities(String, Boolean)
Keyoti RapidSpell Silverlight
Converts HTML entity codes to their Unicode characters
Declaration Syntax
C# Visual Basic Visual C++
public static string convertHtmlEntities(
    string text,
    bool convertAMP
)
Public Shared Function convertHtmlEntities ( _
    text As String, _
    convertAMP As Boolean _
) As String
public:
static String^ convertHtmlEntities(
    String^ text,
    bool convertAMP
)
Parameters
text (String)
The text containing the entities to convert.
convertAMP (Boolean)
Whether to convert &amp; entities to &


CurrentBadWord Property

CurrentBadWord Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► CurrentBadWord
Keyoti RapidSpell Silverlight
Gets the current bad word (last returned by NextBadWord).
Declaration Syntax
C# Visual Basic Visual C++
public BadWord CurrentBadWord { get; }
Public ReadOnly Property CurrentBadWord As BadWord
public:
virtual property BadWord^ CurrentBadWord {
    BadWord^ get () sealed;
}


DictFilePath Property

DictFilePath Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► DictFilePath
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public string DictFilePath { get; set; }
Public Property DictFilePath As String
public:
virtual property String^ DictFilePath {
    String^ get () sealed;
    void set (String^ value) sealed;
}


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► Dispose()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | Dispose(Boolean) | Disposes of resources.
 | Dispose()()() | Clean up any resources being used.


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► Dispose()()()
Keyoti RapidSpell Silverlight
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Dispose()
Public Overridable Sub Dispose
public:
virtual void Dispose()


Dispose Method (disposing)

Dispose Method (disposing)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► Dispose(Boolean)
Keyoti RapidSpell Silverlight
Disposes of resources.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
)
Parameters
disposing (Boolean)


dontSuggest Field

dontSuggest Field
API ► Keyoti.RapidSpell ► RapidSpellChecker ► dontSuggest
Keyoti RapidSpell Silverlight
Don't suggest words in this array (swear words).
Declaration Syntax
C# Visual Basic Visual C++
protected string[] dontSuggest
Protected dontSuggest As String()
protected:
array<String^>^ dontSuggest


Finalize Method

Finalize Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► Finalize()()()
Keyoti RapidSpell Silverlight
Frees up resources.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Finalize()
Protected Overrides Sub Finalize
protected:
virtual void Finalize() override


FindAnagrams Method (word, anagrams)

FindAnagrams Method (word, anagrams)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► FindAnagrams(String, IList)
Keyoti RapidSpell Silverlight
Finds anagrams of word and puts them in anagrams if not already present.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void FindAnagrams(
    string word,
    IList anagrams
)
Public Overridable Sub FindAnagrams ( _
    word As String, _
    anagrams As IList _
)
public:
virtual void FindAnagrams(
    String^ word,
    IList^ anagrams
)
Parameters
word (String)
The word to find anagrams of
anagrams (IList)
A list that anagrams will be added to.
Remarks
Exceptions
Exception | Condition
ArgumentNullException | if word is null/nothing


FindCapitalizedSuggestions Property

FindCapitalizedSuggestions Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► FindCapitalizedSuggestions
Keyoti RapidSpell Silverlight
Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
Declaration Syntax
C# Visual Basic Visual C++
public bool FindCapitalizedSuggestions { get; set; }
Public Property FindCapitalizedSuggestions As Boolean
public:
virtual property bool FindCapitalizedSuggestions {
    bool get () sealed;
    void set (bool value) sealed;
}


FindCompoundWords Method (text, subwords)

FindCompoundWords Method (text, subwords)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► FindCompoundWords(String, IList)
Keyoti RapidSpell Silverlight
Finds the compound words in text and puts them in subwords, set subwords to null/nothing to just find if text has compound word formation.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool FindCompoundWords(
    string text,
    IList subwords
)
Public Overridable Function FindCompoundWords ( _
    text As String, _
    subwords As IList _
) As Boolean
public:
virtual bool FindCompoundWords(
    String^ text,
    IList^ subwords
)
Parameters
text (String)
The text to find compound words in
subwords (IList)
A list that formative sub-words will be added to, can be null/nothing.
Return Value
True if text is entirely formed from compound words, False if not.
Remarks
Only adds words to list if all are valid. In other words, this will not find all words that are part of text, but only the words that all make up text.

Eg. "catchmentarea" has words "catchment" and "area" but not "cat", "me" etc.

The order of the words in the list is the reverse of their order in text.
Exceptions
Exception | Condition
ArgumentNullException | if text is null


FindSuggestions Method

FindSuggestions Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► FindSuggestions()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | FindSuggestions()()() | Gets an enumeration of String suggestions for spelling of current bad word.
 | FindSuggestions(String) | Gets an enumeration of String suggestions for word.
 | FindSuggestions(String, Boolean) | Gets an enumeration of String suggestions for word.


FindSuggestions Method

FindSuggestions Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► FindSuggestions()()()
Keyoti RapidSpell Silverlight
Gets an enumeration of String suggestions for spelling of current bad word.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ArrayList FindSuggestions()
Public Overridable Function FindSuggestions As ArrayList
public:
virtual ArrayList^ FindSuggestions()
Return Value
ArrayList of String suggestions for current bad word.
Exceptions
Exception | Condition
NoCurrentBadWordException | If NextBadWord() hasn't been run first AND found an erroneous word.


FindSuggestions Method (word)

FindSuggestions Method (word)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► FindSuggestions(String)
Keyoti RapidSpell Silverlight
Gets an enumeration of String suggestions for word.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ArrayList FindSuggestions(
    string word
)
Public Overridable Function FindSuggestions ( _
    word As String _
) As ArrayList
public:
virtual ArrayList^ FindSuggestions(
    String^ word
)
Parameters
word (String)
the word to check the spelling of.
Return Value
ArrayList of String suggestions for word.
Exceptions
Exception | Condition
ArgumentNullException | if word parameter is null.


FindSuggestions Method (word, searchLowerCase)

FindSuggestions Method (word, searchLowerCase)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► FindSuggestions(String, Boolean)
Keyoti RapidSpell Silverlight
Gets an enumeration of String suggestions for word.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual ArrayList FindSuggestions(
    string word,
    bool searchLowerCase
)
Protected Overridable Function FindSuggestions ( _
    word As String, _
    searchLowerCase As Boolean _
) As ArrayList
protected:
virtual ArrayList^ FindSuggestions(
    String^ word,
    bool searchLowerCase
)
Parameters
word (String)
the word to check the spelling of.
searchLowerCase (Boolean)
whether to return suggestions for word in a lower case form (if it's capitalized).
Return Value
ArrayList of String suggestions for word.
Exceptions
Exception | Condition
ArgumentNullException | if word parameter is null.


GetAmendedText Method

GetAmendedText Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► GetAmendedText()()()
Keyoti RapidSpell Silverlight
Returns the original text sent to check() but with any alterations made through change
Declaration Syntax
C# Visual Basic Visual C++
public virtual string GetAmendedText()
Public Overridable Function GetAmendedText As String
public:
virtual String^ GetAmendedText()
Return Value
String the text after corrections, null if there is no text.


GetConsiderationRange Method

GetConsiderationRange Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► GetConsiderationRange()()()
Keyoti RapidSpell Silverlight
Gets the factor for words to consider for suggestions.
Declaration Syntax
C# Visual Basic Visual C++
public int GetConsiderationRange()
Public Function GetConsiderationRange As Integer
public:
virtual int GetConsiderationRange() sealed


GetIgnoreCapitalizedWords Method

GetIgnoreCapitalizedWords Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► GetIgnoreCapitalizedWords()()()
Keyoti RapidSpell Silverlight
Gets whether to ignore words with capital letters.
Declaration Syntax
C# Visual Basic Visual C++
public bool GetIgnoreCapitalizedWords()
Public Function GetIgnoreCapitalizedWords As Boolean
public:
virtual bool GetIgnoreCapitalizedWords() sealed


GetIncludeUserDictionaryInSuggestions Method

GetIncludeUserDictionaryInSuggestions Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► GetIncludeUserDictionaryInSuggestions()()()
Keyoti RapidSpell Silverlight
Gets whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# Visual Basic Visual C++
public bool GetIncludeUserDictionaryInSuggestions()
Public Function GetIncludeUserDictionaryInSuggestions As Boolean
public:
virtual bool GetIncludeUserDictionaryInSuggestions() sealed


GetNextWord Method

GetNextWord Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► GetNextWord()()()
Keyoti RapidSpell Silverlight
Returns the next word in the text.
Declaration Syntax
C# Visual Basic Visual C++
protected internal virtual string GetNextWord()
Protected Friend Overridable Function GetNextWord As String
protected public:
virtual String^ GetNextWord()
Return Value
String the next word in the text


GetSeparateHyphenWords Method

GetSeparateHyphenWords Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► GetSeparateHyphenWords()()()
Keyoti RapidSpell Silverlight
Gets whether to treat hyphenated (-) words as separate words, default is false.
Declaration Syntax
C# Visual Basic Visual C++
public bool GetSeparateHyphenWords()
Public Function GetSeparateHyphenWords As Boolean
public:
bool GetSeparateHyphenWords()
Remarks
For eg. if this is true text like "cheap-deals" will be treated as two words "cheap" and "deals", otherwise this will be treated as one word "cheap-deals".


GetSuggestionsMethod Method

GetSuggestionsMethod Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► GetSuggestionsMethod()()()
Keyoti RapidSpell Silverlight
Gets the suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
Declaration Syntax
C# Visual Basic Visual C++
public virtual int GetSuggestionsMethod()
Public Overridable Function GetSuggestionsMethod As Integer
public:
virtual int GetSuggestionsMethod()


GetUndoableStatePoint Method

GetUndoableStatePoint Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► GetUndoableStatePoint()()()
Keyoti RapidSpell Silverlight
Gets the state of the current run, which can be stored and used with RevertToUndoableStatePoint(RapidSpellChecker..::.State)
Declaration Syntax
C# Visual Basic Visual C++
public virtual RapidSpellChecker..::.State GetUndoableStatePoint()
Public Overridable Function GetUndoableStatePoint As RapidSpellChecker..::.State
public:
virtual RapidSpellChecker..::.State^ GetUndoableStatePoint()
Return Value
Returns the current state, or null if not supporting undo.


HASHING_SUGGESTIONS Field

HASHING_SUGGESTIONS Field
API ► Keyoti.RapidSpell ► RapidSpellChecker ► HASHING_SUGGESTIONS
Keyoti RapidSpell Silverlight
Indicator for suggestion method (Hashing is default).
Declaration Syntax
C# Visual Basic Visual C++
public static int HASHING_SUGGESTIONS
Public Shared HASHING_SUGGESTIONS As Integer
public:
static int HASHING_SUGGESTIONS


IgnoreAll Method (word)

IgnoreAll Method (word)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► IgnoreAll(String)
Keyoti RapidSpell Silverlight
Marks word to be ignored in rest of the text.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void IgnoreAll(
    string word
)
Public Overridable Sub IgnoreAll ( _
    word As String _
)
public:
virtual void IgnoreAll(
    String^ word
)
Parameters
word (String)
to ignore
Return Value
void
Exceptions
Exception | Condition
ArgumentNullException | if word parameter is null.


IgnoreIncorrectSentenceCapitalization Property

IgnoreIncorrectSentenceCapitalization Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► IgnoreIncorrectSentenceCapitalization
Keyoti RapidSpell Silverlight
Whether to ignore incorrect sentence capitalization.
Declaration Syntax
C# Visual Basic Visual C++
public bool IgnoreIncorrectSentenceCapitalization { get; set; }
Public Property IgnoreIncorrectSentenceCapitalization As Boolean
public:
virtual property bool IgnoreIncorrectSentenceCapitalization {
    bool get () sealed;
    void set (bool value) sealed;
}


IgnoreInEnglishLowerCaseI Property

IgnoreInEnglishLowerCaseI Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► IgnoreInEnglishLowerCaseI
Keyoti RapidSpell Silverlight
Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
Declaration Syntax
C# Visual Basic Visual C++
public bool IgnoreInEnglishLowerCaseI { get; set; }
Public Property IgnoreInEnglishLowerCaseI As Boolean
public:
virtual property bool IgnoreInEnglishLowerCaseI {
    bool get () sealed;
    void set (bool value) sealed;
}


IgnoreList Property

IgnoreList Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► IgnoreList
Keyoti RapidSpell Silverlight
The words to ignore, note this list is changed by IgnoreAll.
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList IgnoreList { get; set; }
Public Property IgnoreList As ArrayList
public:
virtual property ArrayList^ IgnoreList {
    ArrayList^ get () sealed;
    void set (ArrayList^ value) sealed;
}


IgnoreRtfCodes Property

IgnoreRtfCodes Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► IgnoreRtfCodes
Keyoti RapidSpell Silverlight
Sets whether this should ignore Rtf (or any escaped) codes in the text.
Declaration Syntax
C# Visual Basic Visual C++
public bool IgnoreRtfCodes { get; set; }
Public Property IgnoreRtfCodes As Boolean
public:
property bool IgnoreRtfCodes {
    bool get ();
    void set (bool value);
}


IgnoreURLsAndEmailAddresses Property

IgnoreURLsAndEmailAddresses Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► IgnoreURLsAndEmailAddresses
Keyoti RapidSpell Silverlight
Whether to ignore URLs and email addresses (requires V2Parser=true)
Declaration Syntax
C# Visual Basic Visual C++
public bool IgnoreURLsAndEmailAddresses { get; set; }
Public Property IgnoreURLsAndEmailAddresses As Boolean
public:
virtual property bool IgnoreURLsAndEmailAddresses {
    bool get () sealed;
    void set (bool value) sealed;
}
Remarks
This will cause the following strings to be accepted as non-spelling errors;
"user@domain.com", "http://www.domain.com", "domain.co.uk" etc.


IgnoreWordsWithDigits Property

IgnoreWordsWithDigits Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► IgnoreWordsWithDigits
Keyoti RapidSpell Silverlight
Whether to ignore words with numbers in them (eg. A10 or 7-11).
Declaration Syntax
C# Visual Basic Visual C++
public bool IgnoreWordsWithDigits { get; set; }
Public Property IgnoreWordsWithDigits As Boolean
public:
virtual property bool IgnoreWordsWithDigits {
    bool get () sealed;
    void set (bool value) sealed;
}


IgnoreXML Property

IgnoreXML Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► IgnoreXML
Keyoti RapidSpell Silverlight
Whether to ignore XML/HTML tags, should be set true for RichTextBox support, false by default.
Declaration Syntax
C# Visual Basic Visual C++
public bool IgnoreXML { get; set; }
Public Property IgnoreXML As Boolean
public:
virtual property bool IgnoreXML {
    bool get () sealed;
    void set (bool value) sealed;
}


IsAllCaps Method (s)

IsAllCaps Method (s)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► IsAllCaps(String)
Keyoti RapidSpell Silverlight
Whether all chars in s are in upper case
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsAllCaps(
    string s
)
Public Shared Function IsAllCaps ( _
    s As String _
) As Boolean
public:
static bool IsAllCaps(
    String^ s
)
Parameters
s (String)


IsStartsWithCap Method (word)

IsStartsWithCap Method (word)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► IsStartsWithCap(String)
Keyoti RapidSpell Silverlight
Whether first letter is a capital and rest are lower.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsStartsWithCap(
    string word
)
Public Shared Function IsStartsWithCap ( _
    word As String _
) As Boolean
public:
static bool IsStartsWithCap(
    String^ word
)
Parameters
word (String)


IsWord Method (wordStart, wordEnd)

IsWord Method (wordStart, wordEnd)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► IsWord(Int32, Int32)
Keyoti RapidSpell Silverlight
Whether the word defined by the parameters is a word or whitespace.
Declaration Syntax
C# Visual Basic Visual C++
protected internal virtual bool IsWord(
    int wordStart,
    int wordEnd
)
Protected Friend Overridable Function IsWord ( _
    wordStart As Integer, _
    wordEnd As Integer _
) As Boolean
protected public:
virtual bool IsWord(
    int wordStart,
    int wordEnd
)
Parameters
wordStart (Int32)
wordEnd (Int32)
Return Value
True if is a word, false if whitespace.


LanguageParser Property

LanguageParser Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► LanguageParser
Keyoti RapidSpell Silverlight
The type of language parsing to use.
Declaration Syntax
C# Visual Basic Visual C++
public LanguageType LanguageParser { get; set; }
Public Property LanguageParser As LanguageType
public:
virtual property LanguageType LanguageParser {
    LanguageType get () sealed;
    void set (LanguageType value) sealed;
}
Remarks
Eg. If the dictionary is set to French, you should use the French parser.


LicenseKey Property

LicenseKey Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► LicenseKey
Keyoti RapidSpell Silverlight
The license key
Declaration Syntax
C# Visual Basic Visual C++
public string LicenseKey { set; }
Public WriteOnly Property LicenseKey As String
public:
property String^ LicenseKey {
    void set (String^ value);
}


LookIntoHyphenatedText Property

LookIntoHyphenatedText Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► LookIntoHyphenatedText
Keyoti RapidSpell Silverlight
Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
Declaration Syntax
C# Visual Basic Visual C++
public bool LookIntoHyphenatedText { get; set; }
Public Property LookIntoHyphenatedText As Boolean
public:
virtual property bool LookIntoHyphenatedText {
    bool get () sealed;
    void set (bool value) sealed;
}
Remarks
Eg. "socio-economic" will be checked as "socio" and "economic".


LookUp Method (query)

LookUp Method (query)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► LookUp(String)
Keyoti RapidSpell Silverlight
Checks if query is in the main dictionary or user.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool LookUp(
    string query
)
Public Overridable Function LookUp ( _
    query As String _
) As Boolean
public:
virtual bool LookUp(
    String^ query
)
Parameters
query (String)
the word to check spelling of
Return Value
true if spelt correctly, false if not in dictionary
Remarks
This method is inconsiderate of the words in IgnoreList.
Exceptions
Exception | Condition
ArgumentNullException | if query parameter is null.


LookUpMainDictionary Method (query)

LookUpMainDictionary Method (query)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► LookUpMainDictionary(String)
Keyoti RapidSpell Silverlight
Checks if query is in the word dictionary. Returns true if doesnt start with a letter or apostrophe
Declaration Syntax
C# Visual Basic Visual C++
protected virtual bool LookUpMainDictionary(
    string query
)
Protected Overridable Function LookUpMainDictionary ( _
    query As String _
) As Boolean
protected:
virtual bool LookUpMainDictionary(
    String^ query
)
Parameters
query (String)
the word to check spelling of
Return Value
boolean true if spelt correctly, false if not in dictionary


LookUpUserDictionary Method (query)

LookUpUserDictionary Method (query)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► LookUpUserDictionary(String)
Keyoti RapidSpell Silverlight
Look up the query in the user dictionary if it exists.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual bool LookUpUserDictionary(
    string query
)
Protected Overridable Function LookUpUserDictionary ( _
    query As String _
) As Boolean
protected:
virtual bool LookUpUserDictionary(
    String^ query
)
Parameters
query (String)


Main Method (args)

Main Method (args)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► Main(array<String>[]()[])
Keyoti RapidSpell Silverlight
For test purposes
Declaration Syntax
C# Visual Basic Visual C++
public static void Main(
    string[] args
)
Public Shared Sub Main ( _
    args As String() _
)
public:
static void Main(
    array<String^>^ args
)
Parameters
args (array< String >[]()[])


MakeCap Method (word)

MakeCap Method (word)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► MakeCap(String)
Keyoti RapidSpell Silverlight
Capitalises first letter of word
Declaration Syntax
C# Visual Basic Visual C++
public static string MakeCap(
    string word
)
Public Shared Function MakeCap ( _
    word As String _
) As String
public:
static String^ MakeCap(
    String^ word
)
Parameters
word (String)


NextBadWord Method

NextBadWord Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► NextBadWord()()()
Keyoti RapidSpell Silverlight
Returns the next mis-spelt word in the text, as a BadWord object.
Declaration Syntax
C# Visual Basic Visual C++
public virtual BadWord NextBadWord()
Public Overridable Function NextBadWord As BadWord
public:
virtual BadWord^ NextBadWord()
Return Value
Keyoti.RapidSpell.BadWord or null if there are no more bad words.


PHONETIC_SUGGESTIONS Field

PHONETIC_SUGGESTIONS Field
API ► Keyoti.RapidSpell ► RapidSpellChecker ► PHONETIC_SUGGESTIONS
Keyoti RapidSpell Silverlight
Indicator for suggestion method (Hashing is default).
Declaration Syntax
C# Visual Basic Visual C++
public static int PHONETIC_SUGGESTIONS
Public Shared PHONETIC_SUGGESTIONS As Integer
public:
static int PHONETIC_SUGGESTIONS


ReloadUserDictionary Method

ReloadUserDictionary Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► ReloadUserDictionary()()()
Keyoti RapidSpell Silverlight
Reloads the user dictionary.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void ReloadUserDictionary()
Public Overridable Sub ReloadUserDictionary
public:
virtual void ReloadUserDictionary()
Remarks
Call this when the user dictionary is changed externally


RemoveIgnorePattern Method (p)

RemoveIgnorePattern Method (p)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► RemoveIgnorePattern(String)
Keyoti RapidSpell Silverlight
Removes a regex pattern to ignore (maximum of 20 can be added - IgnoreURLsAndEmailAddresses=true counts as 1).
Declaration Syntax
C# Visual Basic Visual C++
public virtual void RemoveIgnorePattern(
    string p
)
Public Overridable Sub RemoveIgnorePattern ( _
    p As String _
)
public:
virtual void RemoveIgnorePattern(
    String^ p
)
Parameters
p (String)


RevertToUndoableStatePoint Method (state)

RevertToUndoableStatePoint Method (state)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► RevertToUndoableStatePoint(RapidSpellChecker..::.State)
Keyoti RapidSpell Silverlight
Reverts the state to what it was when GetUndoableStatePoint()()() was called.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void RevertToUndoableStatePoint(
    RapidSpellChecker..::.State state
)
Public Overridable Sub RevertToUndoableStatePoint ( _
    state As RapidSpellChecker..::.State _
)
public:
virtual void RevertToUndoableStatePoint(
    RapidSpellChecker..::.State^ state
)
Parameters
state (RapidSpellChecker..::.State)


SetConsiderationRange Method (w)

SetConsiderationRange Method (w)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► SetConsiderationRange(Int32)
Keyoti RapidSpell Silverlight
Sets the factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anything.
Declaration Syntax
C# Visual Basic Visual C++
public void SetConsiderationRange(
    int w
)
Public Sub SetConsiderationRange ( _
    w As Integer _
)
public:
virtual void SetConsiderationRange(
    int w
) sealed
Parameters
w (Int32)


SetDictFileStream Method (dictFileStream, dictionaryID)

SetDictFileStream Method (dictFileStream, dictionaryID)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► SetDictFileStream(Stream, String)
Keyoti RapidSpell Silverlight
Passes a Dict file as a stream, to be used for the main dictionary.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetDictFileStream(
    Stream dictFileStream,
    string dictionaryID
)
Public Overridable Sub SetDictFileStream ( _
    dictFileStream As Stream, _
    dictionaryID As String _
)
public:
virtual void SetDictFileStream(
    Stream^ dictFileStream,
    String^ dictionaryID
)
Parameters
dictFileStream (Stream)
The stream containing the dictionary
dictionaryID (String)
Any generated identity string which the spell checker can use to cache and identify this dictionary.
Remarks
Note this method must be set before Check is called, and the stream position must be at beginning of Dict file. The stream is NOT closed by this method.


SetIgnoreCapitalizedWords Method (v)

SetIgnoreCapitalizedWords Method (v)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► SetIgnoreCapitalizedWords(Boolean)
Keyoti RapidSpell Silverlight
Sets whether to ignore words with capital letters.
Declaration Syntax
C# Visual Basic Visual C++
public void SetIgnoreCapitalizedWords(
    bool v
)
Public Sub SetIgnoreCapitalizedWords ( _
    v As Boolean _
)
public:
virtual void SetIgnoreCapitalizedWords(
    bool v
) sealed
Parameters
v (Boolean)


SetIncludeUserDictionaryInSuggestions Method (v)

SetIncludeUserDictionaryInSuggestions Method (v)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► SetIncludeUserDictionaryInSuggestions(Boolean)
Keyoti RapidSpell Silverlight
Sets whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# Visual Basic Visual C++
public void SetIncludeUserDictionaryInSuggestions(
    bool v
)
Public Sub SetIncludeUserDictionaryInSuggestions ( _
    v As Boolean _
)
public:
virtual void SetIncludeUserDictionaryInSuggestions(
    bool v
) sealed
Parameters
v (Boolean)


SetOptionalContext Method (beforeToCheckSnippet, afterToCheckSnippet)

SetOptionalContext Method (beforeToCheckSnippet, afterToCheckSnippet)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► SetOptionalContext(String, String)
Keyoti RapidSpell Silverlight
Provides the engine with any helpful text around the text snippet which will be passed to the Check method.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetOptionalContext(
    string beforeToCheckSnippet,
    string afterToCheckSnippet
)
Public Overridable Sub SetOptionalContext ( _
    beforeToCheckSnippet As String, _
    afterToCheckSnippet As String _
)
public:
virtual void SetOptionalContext(
    String^ beforeToCheckSnippet,
    String^ afterToCheckSnippet
)
Parameters
beforeToCheckSnippet (String)
Any text before the to check snippet
afterToCheckSnippet (String)
Any text after the snippet
Remarks
Eg. if the document contains "This is an an example piece." and Check will be called on "an example piece", then the fact that 'an' is duplicated will not be detected. Therefore, by passing "This is an " to beforeToCheckSnippet the checker will be able to detect that an is duplicated.


SetPosition Method (pos)

SetPosition Method (pos)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► SetPosition(Int32)
Keyoti RapidSpell Silverlight
Sets the pointer position for the NextBadWord iterator.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetPosition(
    int pos
)
Public Overridable Sub SetPosition ( _
    pos As Integer _
)
public:
virtual void SetPosition(
    int pos
)
Parameters
pos (Int32)
Remarks
Further calls to NextBadWord will look for the next bad word from position pos. If position > the text length it is set to the text length. If position < 0, it is set to zero.


SetSeparateHyphenWords Method (f)

SetSeparateHyphenWords Method (f)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► SetSeparateHyphenWords(Boolean)
Keyoti RapidSpell Silverlight
Sets whether to treat hyphenated (-) words as separate words, default is false.
Declaration Syntax
C# Visual Basic Visual C++
public void SetSeparateHyphenWords(
    bool f
)
Public Sub SetSeparateHyphenWords ( _
    f As Boolean _
)
public:
virtual void SetSeparateHyphenWords(
    bool f
) sealed
Parameters
f (Boolean)
Remarks
For eg. if this is true text like "cheap-deals" will be treated as two words "cheap" and "deals", otherwise this will be treated as one word "cheap-deals". Also see LookIntoHyphenatedText.


SetSuggestionsMethod Method (method)

SetSuggestionsMethod Method (method)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► SetSuggestionsMethod(Int32)
Keyoti RapidSpell Silverlight
Sets the suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
Declaration Syntax
C# Visual Basic Visual C++
public void SetSuggestionsMethod(
    int method
)
Public Sub SetSuggestionsMethod ( _
    method As Integer _
)
public:
virtual void SetSuggestionsMethod(
    int method
) sealed
Parameters
method (Int32)


SetUserDictionary Method

SetUserDictionary Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► SetUserDictionary()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | SetUserDictionary(String) | Set the user dictionary to use.
 | SetUserDictionary(UserDictionary) | Set the user dictionary to use.


SetUserDictionary Method (userDictionary)

SetUserDictionary Method (userDictionary)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► SetUserDictionary(UserDictionary)
Keyoti RapidSpell Silverlight
Set the user dictionary to use.
Declaration Syntax
C# Visual Basic Visual C++
public void SetUserDictionary(
    UserDictionary userDictionary
)
Public Sub SetUserDictionary ( _
    userDictionary As UserDictionary _
)
public:
virtual void SetUserDictionary(
    UserDictionary^ userDictionary
) sealed
Parameters
userDictionary (UserDictionary)
a UserDictionary object representing a user dictionary
Remarks
If the userDictionary can not be created/read it will be ignored
Exceptions
Exception | Condition
ArgumentNullException | if userDictionary is null.


SetUserDictionary Method (userDictionaryFile)

SetUserDictionary Method (userDictionaryFile)
API ► Keyoti.RapidSpell ► RapidSpellChecker ► SetUserDictionary(String)
Keyoti RapidSpell Silverlight
Set the user dictionary to use.
Declaration Syntax
C# Visual Basic Visual C++
public void SetUserDictionary(
    string userDictionaryFile
)
Public Sub SetUserDictionary ( _
    userDictionaryFile As String _
)
public:
virtual void SetUserDictionary(
    String^ userDictionaryFile
) sealed
Parameters
userDictionaryFile (String)
a file to be used as a user dictionary
Remarks
If the userDictionary can not be created/read it will be ignored
Exceptions
Exception | Condition
ArgumentNullException | if userDictionaryFile is null


ShareDictionary Property

ShareDictionary Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► ShareDictionary
Keyoti RapidSpell Silverlight
Whether to share the dictionary in memory across all instances of RapidSpellChecker (false by default).
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Unnecessary, all dictionaries are cached now in a superior manner.",
    false)]
public bool ShareDictionary { get; set; }
<ObsoleteAttribute("Unnecessary, all dictionaries are cached now in a superior manner.",  _
    False)> _
Public Property ShareDictionary As Boolean
[ObsoleteAttribute(L"Unnecessary, all dictionaries are cached now in a superior manner.",
    false)]
public:
property bool ShareDictionary {
    bool get ();
    void set (bool value);
}
Remarks
Setting this to true will lower memory usage if multiple instances of RapidSpellChecker are in use at once, but will mean that only one dictionary may be used at one time. This does not affect user dictionaries.

Note that all instances with this set to true should use the same dictionary. This property must be set before any spell checking begins.


SuggestSplitWords Property

SuggestSplitWords Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► SuggestSplitWords
Keyoti RapidSpell Silverlight
Whether to look for connected words in suggestions.
Declaration Syntax
C# Visual Basic Visual C++
public bool SuggestSplitWords { get; set; }
Public Property SuggestSplitWords As Boolean
public:
virtual property bool SuggestSplitWords {
    bool get () sealed;
    void set (bool value) sealed;
}
Remarks
if this=true then suggestions may include joined words.

Eg; suggestions for "yourhouse" will include "yourhouse"

Setting this to true (default) has a slight performance impact.


TextBoundary Property

TextBoundary Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► TextBoundary
Keyoti RapidSpell Silverlight
The AdvancedTextBoundary class to use to parse words.
Declaration Syntax
C# Visual Basic Visual C++
public AdvancedTextBoundary TextBoundary { get; set; }
Public Property TextBoundary As AdvancedTextBoundary
public:
virtual property AdvancedTextBoundary^ TextBoundary {
    AdvancedTextBoundary^ get () sealed;
    void set (AdvancedTextBoundary^ value) sealed;
}


theCurrentBadWord Field

theCurrentBadWord Field
API ► Keyoti.RapidSpell ► RapidSpellChecker ► theCurrentBadWord
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
protected BadWord theCurrentBadWord
Protected theCurrentBadWord As BadWord
protected:
BadWord^ theCurrentBadWord


theText Field

theText Field
API ► Keyoti.RapidSpell ► RapidSpellChecker ► theText
Keyoti RapidSpell Silverlight
The text being checked.
Declaration Syntax
C# Visual Basic Visual C++
protected StringBuilder theText
Protected theText As StringBuilder
protected:
StringBuilder^ theText


UnloadMainDictionary Method

UnloadMainDictionary Method
API ► Keyoti.RapidSpell ► RapidSpellChecker ► UnloadMainDictionary()()()
Keyoti RapidSpell Silverlight
Empties the main dictionary store.
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("No longer useful because of new dictionary caching.  See release notes.",
    true)]
public void UnloadMainDictionary()
<ObsoleteAttribute("No longer useful because of new dictionary caching.  See release notes.",  _
    True)> _
Public Sub UnloadMainDictionary
[ObsoleteAttribute(L"No longer useful because of new dictionary caching.  See release notes.",
    true)]
public:
virtual void UnloadMainDictionary() sealed


userDictionary Property

userDictionary Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► userDictionary
Keyoti RapidSpell Silverlight
The UserDictionary being used, may be null if no user dictionary is being used.
Declaration Syntax
C# Visual Basic Visual C++
public UserDictionary userDictionary { get; set; }
Public Property userDictionary As UserDictionary
public:
virtual property UserDictionary^ userDictionary {
    UserDictionary^ get () sealed;
    void set (UserDictionary^ value) sealed;
}


V2Parser Property

V2Parser Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► V2Parser
Keyoti RapidSpell Silverlight
Whether to use parser version 2 - Set to false for backwards compatibility.
Declaration Syntax
C# Visual Basic Visual C++
public bool V2Parser { get; set; }
Public Property V2Parser As Boolean
public:
virtual property bool V2Parser {
    bool get () sealed;
    void set (bool value) sealed;
}


WarnDuplicates Property

WarnDuplicates Property
API ► Keyoti.RapidSpell ► RapidSpellChecker ► WarnDuplicates
Keyoti RapidSpell Silverlight
Whether to treat duplicate words as errors (eg. "this is is an error").
Declaration Syntax
C# Visual Basic Visual C++
public bool WarnDuplicates { get; set; }
Public Property WarnDuplicates As Boolean
public:
virtual property bool WarnDuplicates {
    bool get () sealed;
    void set (bool value) sealed;
}


WordAdded Event

WordAdded Event
API ► Keyoti.RapidSpell ► RapidSpellChecker ► WordAdded
Keyoti RapidSpell Silverlight
Fired when word added to user dictionary
Declaration Syntax
C# Visual Basic Visual C++
public event WordAddedEventHandler WordAdded
Public Event WordAdded As WordAddedEventHandler
public:
virtual  event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}


WordChanged Event

WordChanged Event
API ► Keyoti.RapidSpell ► RapidSpellChecker ► WordChanged
Keyoti RapidSpell Silverlight
Change word event, fired when a word is changed.
Declaration Syntax
C# Visual Basic Visual C++
public event WordChangedEventHandler WordChanged
Public Event WordChanged As WordChangedEventHandler
public:
 event WordChangedEventHandler^ WordChanged {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}


wordEnd Field

wordEnd Field
API ► Keyoti.RapidSpell ► RapidSpellChecker ► wordEnd
Keyoti RapidSpell Silverlight
The end index of the current word being checked/parsed.
Declaration Syntax
C# Visual Basic Visual C++
protected int wordEnd
Protected wordEnd As Integer
protected:
int wordEnd


WordIgnored Event

WordIgnored Event
API ► Keyoti.RapidSpell ► RapidSpellChecker ► WordIgnored
Keyoti RapidSpell Silverlight
Fired when word ignored
Declaration Syntax
C# Visual Basic Visual C++
public event WordIgnoredEventHandler WordIgnored
Public Event WordIgnored As WordIgnoredEventHandler
public:
 event WordIgnoredEventHandler^ WordIgnored {
    void add (WordIgnoredEventHandler^ value);
    void remove (WordIgnoredEventHandler^ value);
}


wordStart Field

wordStart Field
API ► Keyoti.RapidSpell ► RapidSpellChecker ► wordStart
Keyoti RapidSpell Silverlight
The start index of the current word being checked/parsed.
Declaration Syntax
C# Visual Basic Visual C++
protected int wordStart
Protected wordStart As Integer
protected:
int wordStart


RapidSpellChecker.State Class

RapidSpellChecker..::.State Class
API ► Keyoti.RapidSpell ► RapidSpellChecker ► RapidSpellChecker..::.State
Keyoti RapidSpell Silverlight
State of the spell checker
Declaration Syntax
C# Visual Basic Visual C++
public class State
Public Class State
public ref class State
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RapidSpellChecker..::.State(Int32, String, BadWord) | New
 | CurrentBadWord | Current misspelling
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Position | Spell checkers position in text
 | PreviousWord | Word before current word
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
RapidSpellChecker..::.State


RapidSpellChecker.State Constructor (position, previousWord, currentBadWord)

RapidSpellChecker..::.State Constructor (position, previousWord, currentBadWord)
API ► Keyoti.RapidSpell ► RapidSpellChecker..::.State ► RapidSpellChecker..::.State(Int32, String, BadWord)
Keyoti RapidSpell Silverlight
New
Declaration Syntax
C# Visual Basic Visual C++
public State(
    int position,
    string previousWord,
    BadWord currentBadWord
)
Public Sub New ( _
    position As Integer, _
    previousWord As String, _
    currentBadWord As BadWord _
)
public:
State(
    int position,
    String^ previousWord,
    BadWord^ currentBadWord
)
Parameters
position (Int32)
previousWord (String)
currentBadWord (BadWord)


CurrentBadWord Property

CurrentBadWord Property
API ► Keyoti.RapidSpell ► RapidSpellChecker..::.State ► CurrentBadWord
Keyoti RapidSpell Silverlight
Current misspelling
Declaration Syntax
C# Visual Basic Visual C++
public BadWord CurrentBadWord { get; set; }
Public Property CurrentBadWord As BadWord
public:
property BadWord^ CurrentBadWord {
    BadWord^ get ();
    void set (BadWord^ value);
}


Position Property

Position Property
API ► Keyoti.RapidSpell ► RapidSpellChecker..::.State ► Position
Keyoti RapidSpell Silverlight
Spell checkers position in text
Declaration Syntax
C# Visual Basic Visual C++
public int Position { get; set; }
Public Property Position As Integer
public:
property int Position {
    int get ();
    void set (int value);
}


PreviousWord Property

PreviousWord Property
API ► Keyoti.RapidSpell ► RapidSpellChecker..::.State ► PreviousWord
Keyoti RapidSpell Silverlight
Word before current word
Declaration Syntax
C# Visual Basic Visual C++
public string PreviousWord { get; set; }
Public Property PreviousWord As String
public:
property String^ PreviousWord {
    String^ get ();
    void set (String^ value);
}


RapidSpellDialog Class

RapidSpellDialog Class
API ► Keyoti.RapidSpell ► RapidSpellDialog
Keyoti RapidSpell Silverlight
RapidSpell Desktop Dialog Control, this convenience control provides design time support for RapidSpellGUI and multiple text box support.
Declaration Syntax
C# Visual Basic Visual C++
public class RapidSpellDialog : DesignableComponent
Public Class RapidSpellDialog _
    Inherits DesignableComponent
public ref class RapidSpellDialog : public DesignableComponent
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RapidSpellDialog()()() | Default constructor.
 | RapidSpellDialog(IContainer) | Designer constructor.
 | ActualHeight | (Inherited from FrameworkElement.)
 | ActualWidth | (Inherited from FrameworkElement.)
 | AddHandler(RoutedEvent, Delegate, Boolean) | (Inherited from UIElement.)
 | AddTextComponent(Control) | Adds a TextBoxBase (TextBox, RichTextBox and derivatives) to be checked.
 | AddTextComponent(ISpellCheckableTextComponent) | Adds an ISpellCheckableTextComponent to be checked.
 | AllOperationScope | The scope that ignore-all/change-all should have.
 | AllowAnyCase | Whether to allow words spelt with incorrect case, eg. "africa", instead of "Africa", this is more relaxed than AllowMixedCase
 | AllowDrop | (Inherited from UIElement.)
 | AllowMixedCase | Whether to allow words spelt with mixed case, eg. "MIxEd"
 | AlwaysShowDialog | Whether to show dialog even when there are no errors in the text box. If set to false causes a spell check before opening the dialog, if there are no errors a message box appears instead of the dialog.
 | Arrange(Rect) | (Inherited from UIElement.)
 | ArrangeOverride(Size) | (Inherited from FrameworkElement.)
 | BindingValidationError()()() | (Inherited from FrameworkElement.)
 | CacheMode()()() | (Inherited from UIElement.)
 | CaptureMouse()()() | (Inherited from UIElement.)
 | Check()()() | Bring up the spell checker dialog and start checking the component set to check.
 | CheckAccess()()() | (Inherited from DependencyObject.)
 | CheckCompoundWords | Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
 | CheckerEngine | The checker engine to use, this object must implement the ICheckerEngine interface, allows customization or replacement of the spell checker.
 | CheckFromStartOfTextOnMultiples | Whether to check each textbox from the start of the text when working with multiple textboxes.
 | CheckReadOnlyTextBoxes | Whether to spell check textboxes which are readonly.
 | ClearTextComponents()()() | Removes all text components from being spell checked.
 | ClearValue(DependencyProperty) | (Inherited from DependencyObject.)
 | Clip | (Inherited from UIElement.)
 | Close()()() | Close the spell checker dialog window, if open.
 | ConsiderationRange | Sets the factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 500. If w <= 1 this method won't do anything.
 | CreateDialogView | Fired when an IDialogView is being created. Allows for customization
 | CreateDialogViewOptions | Fired when an IDialogViewOptions is being created. Allows for customization
 | CreateDialogViewUserDictionaryEdit | Indicates that a new IDialogViewUserDictionaryEdit is being created, also provides chance to override the default IDialogViewUserDictionaryEdit.
 | CreateUserInterfaceFormPresenter | Fired when an IUserInterfaceFormPresenter is being created. Allows for customization
 | Cursor | (Inherited from FrameworkElement.)
 | DataContext | (Inherited from FrameworkElement.)
 | DesignMode | Whether control is in design mode (Inherited from DesignableComponent.)
 | DesiredSize | (Inherited from UIElement.)
 | DictFileUri | Uri of the Dict File to use for main dictionary. See remarks.
 | Dispatcher()()() | (Inherited from DependencyObject.)
 | Dispose(Boolean) | Disposes of unmanaged resources.
 | DragEnter | (Inherited from UIElement.)
 | DragLeave | (Inherited from UIElement.)
 | DragOver | (Inherited from UIElement.)
 | Drop | (Inherited from UIElement.)
 | Effect()()() | (Inherited from UIElement.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Cleanup (Overrides Object.Finalize()()().)
 | FindCapitalizedSuggestions | Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
 | FindName(String) | (Inherited from FrameworkElement.)
 | FlowDirection | (Inherited from FrameworkElement.)
 | GetAnimationBaseValue(DependencyProperty) | (Inherited from DependencyObject.)
 | GetBindingExpression(DependencyProperty) | (Inherited from FrameworkElement.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(DependencyProperty) | (Inherited from DependencyObject.)
 | GotFocus | (Inherited from UIElement.)
 | GUILanguage | The language to show the UI in.
 | Height | (Inherited from FrameworkElement.)
 | HorizontalAlignment | (Inherited from FrameworkElement.)
 | IgnoreCapitalizedWords | Whether to ignore words with capital letters.
 | IgnoreIncorrectSentenceCapitalization | Whether to ignore incorrect sentence capitalization.
 | IgnoreInEnglishLowerCaseI | Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
 | IgnoreURLsAndEmailAddresses | Whether to ignore URLs and email addresses (requires V2Parser=true)
 | IgnoreWordsWithDigits | Whether to ignore words with numbers in them (eg. A10 or 7-11).
 | IgnoreXML | Whether to ignore XML/HTML tags, false by default.
 | IncludeUserDictionaryInSuggestions | Whether the user dictionary should be used in finding suggestions for misspelt words.
 | InvalidateArrange()()() | (Inherited from UIElement.)
 | InvalidateMeasure()()() | (Inherited from UIElement.)
 | IsHitTestVisible | (Inherited from UIElement.)
 | KeyDown | (Inherited from UIElement.)
 | KeyUp | (Inherited from UIElement.)
 | Language | (Inherited from FrameworkElement.)
 | LanguageParser | The type of language parsing to use.
 | LayoutUpdated()()() | (Inherited from FrameworkElement.)
 | LicenseKey | The license key.
 | LoadDictionary()()() | Loads the dictionary now (in a background thread), instead of when the spell check starts;
 | Loaded | (Inherited from FrameworkElement.)
 | LookIntoHyphenatedText | Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
 | LostFocus | (Inherited from UIElement.)
 | LostMouseCapture | (Inherited from UIElement.)
 | ManipulationCompleted()()() | (Inherited from UIElement.)
 | ManipulationDelta()()() | (Inherited from UIElement.)
 | ManipulationStarted()()() | (Inherited from UIElement.)
 | Margin | (Inherited from FrameworkElement.)
 | MaxHeight | (Inherited from FrameworkElement.)
 | MaxWidth | (Inherited from FrameworkElement.)
 | Measure(Size) | (Inherited from UIElement.)
 | MeasureOverride(Size) | (Inherited from FrameworkElement.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinHeight | (Inherited from FrameworkElement.)
 | MinWidth | (Inherited from FrameworkElement.)
 | MouseEnter | (Inherited from UIElement.)
 | MouseLeave | (Inherited from UIElement.)
 | MouseLeftButtonDown | (Inherited from UIElement.)
 | MouseLeftButtonUp | (Inherited from UIElement.)
 | MouseMove | (Inherited from UIElement.)
 | MouseRightButtonDown | (Inherited from UIElement.)
 | MouseRightButtonUp | (Inherited from UIElement.)
 | MouseWheel | (Inherited from UIElement.)
 | Name | (Inherited from FrameworkElement.)
 | NumberSuggestionList | Whether to number the items in the suggestion list, for quick user selection.
 | OnApplyTemplate()()() | (Inherited from FrameworkElement.)
 | OnCreateAutomationPeer()()() | (Inherited from UIElement.)
 | OnCreateDialogView(CreateDialogViewEventArgs) | Raises event
 | OnCreateDialogViewOptions(CreateDialogViewOptionsEventArgs) | Raises event
 | OnCreateDialogViewUserDictionaryEdit(CreateDialogViewUserDictionaryEditEventArgs) | Fires the CreateDialogViewUserDictionaryEdit event.
 | OnCreateUserInterfaceFormPresenter(CreateUserInterfaceFormPresenterEventArgs) | Raises event
 | OnSpellCheckFinishedTextBox(TextBoxSpellCheckEventArgs) | Raises event
 | OnSpellCheckStartedTextBox(TextBoxSpellCheckEventArgs) | Raises event
 | OnWordAdded(Object, WordAddedEventArgs) | Fires WordAdded event
 | OnWordChanged(Object, WordChangedEventArgs) | Fires WordChanged event
 | OnWordChanging(Object, WordChangedEventArgs) | Fires WordChanging event
 | OnWordIgnored(Object, WordIgnoredEventArgs) | Fires WordIgnored event
 | Opacity | (Inherited from UIElement.)
 | OpacityMask | (Inherited from UIElement.)
 | Options | Object responsible for holding, loading and saving the user's spell check options.
 | OptionsEnabled | Whether to use user options.
 | OptionsFileName | The file name used to store the settings (by default in IsolatedStorage).
 | OptionsPresenter | Presenter for the user options form (IDialogViewOptions).
 | OptionsStorageLocation | Where the user's options are stored.
 | Parent | (Inherited from FrameworkElement.)
 | Projection()()() | (Inherited from UIElement.)
 | QueryTextBoxMultiline | Whether 'not in dictionary' text box is multiline or single line.
 | ReadLocalValue(DependencyProperty) | (Inherited from DependencyObject.)
 | Ready | Fired when ready to proceed with first query.
 | RecheckDocumentRequest | Fired when the text should be rechecked
 | ReleaseMouseCapture()()() | (Inherited from UIElement.)
 | RemoveHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
 | RemoveTextComponent(Control) | Removes a TextBoxBase (TextBox, RichTextBox and derivatives) to be checked.
 | RemoveTextComponent(ISpellCheckableTextComponent) | Removes an ISpellCheckableTextComponent to be checked.
 | RenderSize | (Inherited from UIElement.)
 | RenderTransform | (Inherited from UIElement.)
 | RenderTransformOrigin | (Inherited from UIElement.)
 | ResetIgnoredWords()()() | Resets all ignored words, so that the document will be rechecked.
 | Resources | (Inherited from FrameworkElement.)
 | SeparateHyphenWords | Whether to treat hyphenated (-) words as separate words, default is false.
 | SetBinding(DependencyProperty, Binding) | (Inherited from FrameworkElement.)
 | SetValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
 | ShowContextSentence | Whether to show the query in context of it's sentence/line.
 | ShowFinishedBoxAtEnd | Whether to show the spell check complete dialog box at the end, true by default.
 | ShowOptionsButton | Whether to show the options button.
 | ShowUndoButton | Whether to show the undo button.
 | SizeChanged | (Inherited from FrameworkElement.)
 | SpellCheckFinished | Fired when checking finishes
 | SpellCheckFinishedTextBox | Fired when spell check starts on a text box (used in multiple text box checking situations)
 | SpellCheckStarted | Fired when checking starts
 | SpellCheckStartedTextBox | Fired when spell check starts on a text box (used in multiple text box checking situations)
 | Style | (Inherited from FrameworkElement.)
 | SuggestionsMethod | The suggestions method to use.
 | SuggestSplitWords | Whether to look for connected words in suggestions.
 | Tag | (Inherited from FrameworkElement.)
 | TextBox | The TextBox or RichTextBox to work with
 | TextBoxBasesToCheck | Array of TextBoxBases this GUI will spell check.
 | TextBoxProperty | The RapidSpellAsYouType to work with.
 | TextInput | (Inherited from UIElement.)
 | TextInputStart()()() | (Inherited from UIElement.)
 | TextInputUpdate()()() | (Inherited from UIElement.)
 | Texts | The UI texts.
 | ThirdPartyTextComponentsToCheck | Array of ISpellCheckableTextComponent this GUI will spell check.
 | ThirdPartyTextComponentToCheck | The 3rd Party Component that this GUI will spell check.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TransformToVisual(UIElement) | (Inherited from UIElement.)
 | Triggers | (Inherited from FrameworkElement.)
 | Undone | Fired when an Undo occurs
 | Unloaded | (Inherited from FrameworkElement.)
 | UpdateLayout()()() | (Inherited from UIElement.)
 | UseLayoutRounding()()() | (Inherited from UIElement.)
 | UserDictionary | A custom instance of UserDictionary to use instead of the default file based dictionary.
 | UserDictionaryEnabled | Whether the user dictionary (Add button) is active.
 | UserInterfaceFormPresenter | The presenter (eg. RapidSpellGUIPresenter) currently in use, may be null/Nothing if not created yet.
 | UserQuery | Indicates that the user is being queried on a spelling error.
 | V2Parser | Whether to use parser version 2 - Set to false for backwards (pre v3.4) compatibility.
 | VerticalAlignment | (Inherited from FrameworkElement.)
 | Visibility | (Inherited from UIElement.)
 | WarnDuplicates | Whether to show duplicate words as errors (eg. "this is is an error").
 | Width | (Inherited from FrameworkElement.)
 | WordAdded | Fired when word added to user dictionary
 | WordChanged | Fired when a word is changed
 | WordChanging | Fired before a word is changed
 | WordIgnored | Fired when word ignored
 | WordRemoved | Fired when a word is removed from user dictionary.
Inheritance Hierarchy
Object
 | DependencyObject
 |  | UIElement
 |  |  | FrameworkElement
 |  |  |  | DesignableComponent
 |  |  |  |  | RapidSpellDialog


RapidSpellDialog Constructor

RapidSpellDialog Constructor
API ► Keyoti.RapidSpell ► RapidSpellDialog ► RapidSpellDialog()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | RapidSpellDialog()()() | Default constructor.
 | RapidSpellDialog(IContainer) | Designer constructor.


RapidSpellDialog Constructor

RapidSpellDialog Constructor
API ► Keyoti.RapidSpell ► RapidSpellDialog ► RapidSpellDialog()()()
Keyoti RapidSpell Silverlight
Default constructor.
Declaration Syntax
C# Visual Basic Visual C++
public RapidSpellDialog()
Public Sub New
public:
RapidSpellDialog()


RapidSpellDialog Constructor (container)

RapidSpellDialog Constructor (container)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► RapidSpellDialog(IContainer)
Keyoti RapidSpell Silverlight
Designer constructor.
Declaration Syntax
C# Visual Basic Visual C++
public RapidSpellDialog(
    IContainer container
)
Public Sub New ( _
    container As IContainer _
)
public:
RapidSpellDialog(
    IContainer^ container
)
Parameters
container (IContainer)


AddTextComponent Method

AddTextComponent Method
API ► Keyoti.RapidSpell ► RapidSpellDialog ► AddTextComponent()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | AddTextComponent(Control) | Adds a TextBoxBase (TextBox, RichTextBox and derivatives) to be checked.
 | AddTextComponent(ISpellCheckableTextComponent) | Adds an ISpellCheckableTextComponent to be checked.


AddTextComponent Method (textComponent)

AddTextComponent Method (textComponent)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► AddTextComponent(ISpellCheckableTextComponent)
Keyoti RapidSpell Silverlight
Adds an ISpellCheckableTextComponent to be checked.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void AddTextComponent(
    ISpellCheckableTextComponent textComponent
)
Public Overridable Sub AddTextComponent ( _
    textComponent As ISpellCheckableTextComponent _
)
public:
virtual void AddTextComponent(
    ISpellCheckableTextComponent^ textComponent
)
Parameters
textComponent (ISpellCheckableTextComponent)


AddTextComponent Method (textBoxBase)

AddTextComponent Method (textBoxBase)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► AddTextComponent(Control)
Keyoti RapidSpell Silverlight
Adds a TextBoxBase (TextBox, RichTextBox and derivatives) to be checked.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void AddTextComponent(
    Control textBoxBase
)
Public Overridable Sub AddTextComponent ( _
    textBoxBase As Control _
)
public:
virtual void AddTextComponent(
    Control^ textBoxBase
)
Parameters
textBoxBase (Control)


AllOperationScope Property

AllOperationScope Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► AllOperationScope
Keyoti RapidSpell Silverlight
The scope that ignore-all/change-all should have.
Declaration Syntax
C# Visual Basic Visual C++
public OperationScope AllOperationScope { get; set; }
Public Property AllOperationScope As OperationScope
public:
property OperationScope AllOperationScope {
    OperationScope get ();
    void set (OperationScope value);
}


AllowAnyCase Property

AllowAnyCase Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► AllowAnyCase
Keyoti RapidSpell Silverlight
Whether to allow words spelt with incorrect case, eg. "africa", instead of "Africa", this is more relaxed than AllowMixedCase
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowAnyCase { get; set; }
Public Property AllowAnyCase As Boolean
public:
property bool AllowAnyCase {
    bool get ();
    void set (bool value);
}


AllowMixedCase Property

AllowMixedCase Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► AllowMixedCase
Keyoti RapidSpell Silverlight
Whether to allow words spelt with mixed case, eg. "MIxEd"
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowMixedCase { get; set; }
Public Property AllowMixedCase As Boolean
public:
property bool AllowMixedCase {
    bool get ();
    void set (bool value);
}


AlwaysShowDialog Property

AlwaysShowDialog Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► AlwaysShowDialog
Keyoti RapidSpell Silverlight
Whether to show dialog even when there are no errors in the text box. If set to false causes a spell check before opening the dialog, if there are no errors a message box appears instead of the dialog.
Declaration Syntax
C# Visual Basic Visual C++
public bool AlwaysShowDialog { get; set; }
Public Property AlwaysShowDialog As Boolean
public:
property bool AlwaysShowDialog {
    bool get ();
    void set (bool value);
}


Check Method

Check Method
API ► Keyoti.RapidSpell ► RapidSpellDialog ► Check()()()
Keyoti RapidSpell Silverlight
Bring up the spell checker dialog and start checking the component set to check.
Declaration Syntax
C# Visual Basic Visual C++
public void Check()
Public Sub Check
public:
void Check()
Exceptions
Exception | Condition
NoTextComponentException | if text component to check hasn't been set first with a TextBoxBase or 3rd Party component.


CheckCompoundWords Property

CheckCompoundWords Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► CheckCompoundWords
Keyoti RapidSpell Silverlight
Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckCompoundWords { get; set; }
Public Property CheckCompoundWords As Boolean
public:
property bool CheckCompoundWords {
    bool get ();
    void set (bool value);
}
Remarks
If this=false then LookUp("thesewordsarejoined") = false

If this=true then LookUp("thesewordsarejoined") = true

If this=false then LookUp("abcdef") = false

If this=true then LookUp("abcdef") = false

Setting this to true will degrade lookup performance


CheckerEngine Property

CheckerEngine Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► CheckerEngine
Keyoti RapidSpell Silverlight
The checker engine to use, this object must implement the ICheckerEngine interface, allows customization or replacement of the spell checker.
Declaration Syntax
C# Visual Basic Visual C++
public ICheckerEngine CheckerEngine { get; set; }
Public Property CheckerEngine As ICheckerEngine
public:
property ICheckerEngine^ CheckerEngine {
    ICheckerEngine^ get ();
    void set (ICheckerEngine^ value);
}
Remarks
Use this property to replace the object used to perform checking, it is not necessary to replace this with a spell checker, any type of word parser can be used. For example an abbreviations checker could be written to replace common words with abbreviations. Caveat: Most behavior properties in RapidSpellDialog are mirrors of properties in ICheckerEngine; any values set in ICheckerEngine will be overwritten by values set in RapidSpellDialog.


CheckFromStartOfTextOnMultiples Property

CheckFromStartOfTextOnMultiples Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► CheckFromStartOfTextOnMultiples
Keyoti RapidSpell Silverlight
Whether to check each textbox from the start of the text when working with multiple textboxes.
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckFromStartOfTextOnMultiples { get; set; }
Public Property CheckFromStartOfTextOnMultiples As Boolean
public:
property bool CheckFromStartOfTextOnMultiples {
    bool get ();
    void set (bool value);
}


CheckReadOnlyTextBoxes Property

CheckReadOnlyTextBoxes Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► CheckReadOnlyTextBoxes
Keyoti RapidSpell Silverlight
Whether to spell check textboxes which are readonly.
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckReadOnlyTextBoxes { get; set; }
Public Property CheckReadOnlyTextBoxes As Boolean
public:
property bool CheckReadOnlyTextBoxes {
    bool get ();
    void set (bool value);
}


ClearTextComponents Method

ClearTextComponents Method
API ► Keyoti.RapidSpell ► RapidSpellDialog ► ClearTextComponents()()()
Keyoti RapidSpell Silverlight
Removes all text components from being spell checked.
Declaration Syntax
C# Visual Basic Visual C++
public void ClearTextComponents()
Public Sub ClearTextComponents
public:
void ClearTextComponents()


Close Method

Close Method
API ► Keyoti.RapidSpell ► RapidSpellDialog ► Close()()()
Keyoti RapidSpell Silverlight
Close the spell checker dialog window, if open.
Declaration Syntax
C# Visual Basic Visual C++
public void Close()
Public Sub Close
public:
void Close()


ConsiderationRange Property

ConsiderationRange Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► ConsiderationRange
Keyoti RapidSpell Silverlight
Sets the factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 500. If w <= 1 this method won't do anything.
Declaration Syntax
C# Visual Basic Visual C++
public int ConsiderationRange { get; set; }
Public Property ConsiderationRange As Integer
public:
property int ConsiderationRange {
    int get ();
    void set (int value);
}


CreateDialogView Event

CreateDialogView Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► CreateDialogView
Keyoti RapidSpell Silverlight
Fired when an IDialogView is being created. Allows for customization
Declaration Syntax
C# Visual Basic Visual C++
public event CreateDialogViewEventHandler CreateDialogView
Public Event CreateDialogView As CreateDialogViewEventHandler
public:
 event CreateDialogViewEventHandler^ CreateDialogView {
    void add (CreateDialogViewEventHandler^ value);
    void remove (CreateDialogViewEventHandler^ value);
}


CreateDialogViewOptions Event

CreateDialogViewOptions Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► CreateDialogViewOptions
Keyoti RapidSpell Silverlight
Fired when an IDialogViewOptions is being created. Allows for customization
Declaration Syntax
C# Visual Basic Visual C++
public event CreateDialogViewOptionsEventHandler CreateDialogViewOptions
Public Event CreateDialogViewOptions As CreateDialogViewOptionsEventHandler
public:
 event CreateDialogViewOptionsEventHandler^ CreateDialogViewOptions {
    void add (CreateDialogViewOptionsEventHandler^ value);
    void remove (CreateDialogViewOptionsEventHandler^ value);
}


CreateDialogViewUserDictionaryEdit Event

CreateDialogViewUserDictionaryEdit Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► CreateDialogViewUserDictionaryEdit
Keyoti RapidSpell Silverlight
Indicates that a new IDialogViewUserDictionaryEdit is being created, also provides chance to override the default IDialogViewUserDictionaryEdit.
Declaration Syntax
C# Visual Basic Visual C++
public event CreateDialogViewUserDictionaryEditEventHandler CreateDialogViewUserDictionaryEdit
Public Event CreateDialogViewUserDictionaryEdit As CreateDialogViewUserDictionaryEditEventHandler
public:
 event CreateDialogViewUserDictionaryEditEventHandler^ CreateDialogViewUserDictionaryEdit {
    void add (CreateDialogViewUserDictionaryEditEventHandler^ value);
    void remove (CreateDialogViewUserDictionaryEditEventHandler^ value);
}


CreateUserInterfaceFormPresenter Event

CreateUserInterfaceFormPresenter Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► CreateUserInterfaceFormPresenter
Keyoti RapidSpell Silverlight
Fired when an IUserInterfaceFormPresenter is being created. Allows for customization
Declaration Syntax
C# Visual Basic Visual C++
public event CreateUserInterfaceFormPresenterEventHandler CreateUserInterfaceFormPresenter
Public Event CreateUserInterfaceFormPresenter As CreateUserInterfaceFormPresenterEventHandler
public:
 event CreateUserInterfaceFormPresenterEventHandler^ CreateUserInterfaceFormPresenter {
    void add (CreateUserInterfaceFormPresenterEventHandler^ value);
    void remove (CreateUserInterfaceFormPresenterEventHandler^ value);
}


DictFileUri Property

DictFileUri Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► DictFileUri
Keyoti RapidSpell Silverlight
Uri of the Dict File to use for main dictionary. See remarks.
Declaration Syntax
C# Visual Basic Visual C++
public string DictFileUri { get; set; }
Public Property DictFileUri As String
public:
property String^ DictFileUri {
    String^ get ();
    void set (String^ value);
}
Remarks
Can be used 2 ways;

1. Add the .dict file to the application project and mark as Build Action -> Content in properties. Set DictFileUri (this property) to the name of the .dict file.

2. Host the .dict file on the web-server hosting the application, and set this property to the absolute URL of the .dict file. Hint: the URL of the .xap can be gained dynamically using App.Current.Host.Source in your code.


Dispose Method (disposing)

Dispose Method (disposing)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► Dispose(Boolean)
Keyoti RapidSpell Silverlight
Disposes of unmanaged resources.
Declaration Syntax
C# Visual Basic Visual C++
protected void Dispose(
    bool disposing
)
Protected Sub Dispose ( _
    disposing As Boolean _
)
protected:
void Dispose(
    bool disposing
)
Parameters
disposing (Boolean)


Finalize Method

Finalize Method
API ► Keyoti.RapidSpell ► RapidSpellDialog ► Finalize()()()
Keyoti RapidSpell Silverlight
Cleanup
Declaration Syntax
C# Visual Basic Visual C++
protected override void Finalize()
Protected Overrides Sub Finalize
protected:
virtual void Finalize() override


FindCapitalizedSuggestions Property

FindCapitalizedSuggestions Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► FindCapitalizedSuggestions
Keyoti RapidSpell Silverlight
Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
Declaration Syntax
C# Visual Basic Visual C++
public bool FindCapitalizedSuggestions { get; set; }
Public Property FindCapitalizedSuggestions As Boolean
public:
property bool FindCapitalizedSuggestions {
    bool get ();
    void set (bool value);
}


GUILanguage Property

GUILanguage Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► GUILanguage
Keyoti RapidSpell Silverlight
The language to show the UI in.
Declaration Syntax
C# Visual Basic Visual C++
public LanguageType GUILanguage { get; set; }
Public Property GUILanguage As LanguageType
public:
property LanguageType GUILanguage {
    LanguageType get ();
    void set (LanguageType value);
}


IgnoreCapitalizedWords Property

IgnoreCapitalizedWords Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► IgnoreCapitalizedWords
Keyoti RapidSpell Silverlight
Whether to ignore words with capital letters.
Declaration Syntax
C# Visual Basic Visual C++
public bool IgnoreCapitalizedWords { get; set; }
Public Property IgnoreCapitalizedWords As Boolean
public:
property bool IgnoreCapitalizedWords {
    bool get ();
    void set (bool value);
}


IgnoreIncorrectSentenceCapitalization Property

IgnoreIncorrectSentenceCapitalization Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► IgnoreIncorrectSentenceCapitalization
Keyoti RapidSpell Silverlight
Whether to ignore incorrect sentence capitalization.
Declaration Syntax
C# Visual Basic Visual C++
public bool IgnoreIncorrectSentenceCapitalization { get; set; }
Public Property IgnoreIncorrectSentenceCapitalization As Boolean
public:
property bool IgnoreIncorrectSentenceCapitalization {
    bool get ();
    void set (bool value);
}


IgnoreInEnglishLowerCaseI Property

IgnoreInEnglishLowerCaseI Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► IgnoreInEnglishLowerCaseI
Keyoti RapidSpell Silverlight
Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
Declaration Syntax
C# Visual Basic Visual C++
public bool IgnoreInEnglishLowerCaseI { get; set; }
Public Property IgnoreInEnglishLowerCaseI As Boolean
public:
property bool IgnoreInEnglishLowerCaseI {
    bool get ();
    void set (bool value);
}


IgnoreURLsAndEmailAddresses Property

IgnoreURLsAndEmailAddresses Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► IgnoreURLsAndEmailAddresses
Keyoti RapidSpell Silverlight
Whether to ignore URLs and email addresses (requires V2Parser=true)
Declaration Syntax
C# Visual Basic Visual C++
public bool IgnoreURLsAndEmailAddresses { get; set; }
Public Property IgnoreURLsAndEmailAddresses As Boolean
public:
property bool IgnoreURLsAndEmailAddresses {
    bool get ();
    void set (bool value);
}
Remarks
This will cause the following strings to be accepted as non-spelling errors;
"user@domain.com", "http://www.domain.com", "domain.co.uk" etc.


IgnoreWordsWithDigits Property

IgnoreWordsWithDigits Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► IgnoreWordsWithDigits
Keyoti RapidSpell Silverlight
Whether to ignore words with numbers in them (eg. A10 or 7-11).
Declaration Syntax
C# Visual Basic Visual C++
public bool IgnoreWordsWithDigits { get; set; }
Public Property IgnoreWordsWithDigits As Boolean
public:
property bool IgnoreWordsWithDigits {
    bool get ();
    void set (bool value);
}


IgnoreXML Property

IgnoreXML Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► IgnoreXML
Keyoti RapidSpell Silverlight
Whether to ignore XML/HTML tags, false by default.
Declaration Syntax
C# Visual Basic Visual C++
public bool IgnoreXML { get; set; }
Public Property IgnoreXML As Boolean
public:
property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
Remarks
This identifies XML tags as anything in between < and > characters, there for it will cause undesirable effects in text such as "the sign for less than is < and the sign for greater than is >". Of course in HTML that should have been written as "the sign for less than is &lt; and the sign for greater than is &gt;" anyway, which would be fine.


IncludeUserDictionaryInSuggestions Property

IncludeUserDictionaryInSuggestions Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► IncludeUserDictionaryInSuggestions
Keyoti RapidSpell Silverlight
Whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeUserDictionaryInSuggestions { get; set; }
Public Property IncludeUserDictionaryInSuggestions As Boolean
public:
property bool IncludeUserDictionaryInSuggestions {
    bool get ();
    void set (bool value);
}


LanguageParser Property

LanguageParser Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► LanguageParser
Keyoti RapidSpell Silverlight
The type of language parsing to use.
Declaration Syntax
C# Visual Basic Visual C++
public LanguageType LanguageParser { get; set; }
Public Property LanguageParser As LanguageType
public:
property LanguageType LanguageParser {
    LanguageType get ();
    void set (LanguageType value);
}
Remarks
Eg. If the dictionary is set to French, you should use the French parser.


LicenseKey Property

LicenseKey Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► LicenseKey
Keyoti RapidSpell Silverlight
The license key.
Declaration Syntax
C# Visual Basic Visual C++
public string LicenseKey { get; set; }
Public Property LicenseKey As String
public:
property String^ LicenseKey {
    String^ get ();
    void set (String^ value);
}


LoadDictionary Method

LoadDictionary Method
API ► Keyoti.RapidSpell ► RapidSpellDialog ► LoadDictionary()()()
Keyoti RapidSpell Silverlight
Loads the dictionary now (in a background thread), instead of when the spell check starts;
Declaration Syntax
C# Visual Basic Visual C++
public void LoadDictionary()
Public Sub LoadDictionary
public:
void LoadDictionary()


LookIntoHyphenatedText Property

LookIntoHyphenatedText Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► LookIntoHyphenatedText
Keyoti RapidSpell Silverlight
Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
Declaration Syntax
C# Visual Basic Visual C++
public bool LookIntoHyphenatedText { get; set; }
Public Property LookIntoHyphenatedText As Boolean
public:
property bool LookIntoHyphenatedText {
    bool get ();
    void set (bool value);
}
Remarks
Eg. "socio-economic" will be checked as "socio" and "economic".


NumberSuggestionList Property

NumberSuggestionList Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► NumberSuggestionList
Keyoti RapidSpell Silverlight
Whether to number the items in the suggestion list, for quick user selection.
Declaration Syntax
C# Visual Basic Visual C++
public bool NumberSuggestionList { get; set; }
Public Property NumberSuggestionList As Boolean
public:
property bool NumberSuggestionList {
    bool get ();
    void set (bool value);
}


OnCreateDialogView Method (e)

OnCreateDialogView Method (e)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► OnCreateDialogView(CreateDialogViewEventArgs)
Keyoti RapidSpell Silverlight
Raises event
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void OnCreateDialogView(
    CreateDialogViewEventArgs e
)
Protected Overridable Sub OnCreateDialogView ( _
    e As CreateDialogViewEventArgs _
)
protected:
virtual void OnCreateDialogView(
    CreateDialogViewEventArgs^ e
)
Parameters
e (CreateDialogViewEventArgs)


OnCreateDialogViewOptions Method (e)

OnCreateDialogViewOptions Method (e)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► OnCreateDialogViewOptions(CreateDialogViewOptionsEventArgs)
Keyoti RapidSpell Silverlight
Raises event
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void OnCreateDialogViewOptions(
    CreateDialogViewOptionsEventArgs e
)
Protected Overridable Sub OnCreateDialogViewOptions ( _
    e As CreateDialogViewOptionsEventArgs _
)
protected:
virtual void OnCreateDialogViewOptions(
    CreateDialogViewOptionsEventArgs^ e
)
Parameters
e (CreateDialogViewOptionsEventArgs)


OnCreateDialogViewUserDictionaryEdit Method (e)

OnCreateDialogViewUserDictionaryEdit Method (e)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► OnCreateDialogViewUserDictionaryEdit(CreateDialogViewUserDictionaryEditEventArgs)
Keyoti RapidSpell Silverlight
Fires the CreateDialogViewUserDictionaryEdit event.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void OnCreateDialogViewUserDictionaryEdit(
    CreateDialogViewUserDictionaryEditEventArgs e
)
Protected Overridable Sub OnCreateDialogViewUserDictionaryEdit ( _
    e As CreateDialogViewUserDictionaryEditEventArgs _
)
protected:
virtual void OnCreateDialogViewUserDictionaryEdit(
    CreateDialogViewUserDictionaryEditEventArgs^ e
)
Parameters
e (CreateDialogViewUserDictionaryEditEventArgs)


OnCreateUserInterfaceFormPresenter Method (e)

OnCreateUserInterfaceFormPresenter Method (e)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► OnCreateUserInterfaceFormPresenter(CreateUserInterfaceFormPresenterEventArgs)
Keyoti RapidSpell Silverlight
Raises event
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void OnCreateUserInterfaceFormPresenter(
    CreateUserInterfaceFormPresenterEventArgs e
)
Protected Overridable Sub OnCreateUserInterfaceFormPresenter ( _
    e As CreateUserInterfaceFormPresenterEventArgs _
)
protected:
virtual void OnCreateUserInterfaceFormPresenter(
    CreateUserInterfaceFormPresenterEventArgs^ e
)
Parameters
e (CreateUserInterfaceFormPresenterEventArgs)


OnSpellCheckFinishedTextBox Method (e)

OnSpellCheckFinishedTextBox Method (e)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► OnSpellCheckFinishedTextBox(TextBoxSpellCheckEventArgs)
Keyoti RapidSpell Silverlight
Raises event
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void OnSpellCheckFinishedTextBox(
    TextBoxSpellCheckEventArgs e
)
Protected Overridable Sub OnSpellCheckFinishedTextBox ( _
    e As TextBoxSpellCheckEventArgs _
)
protected:
virtual void OnSpellCheckFinishedTextBox(
    TextBoxSpellCheckEventArgs^ e
)
Parameters
e (TextBoxSpellCheckEventArgs)


OnSpellCheckStartedTextBox Method (e)

OnSpellCheckStartedTextBox Method (e)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► OnSpellCheckStartedTextBox(TextBoxSpellCheckEventArgs)
Keyoti RapidSpell Silverlight
Raises event
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void OnSpellCheckStartedTextBox(
    TextBoxSpellCheckEventArgs e
)
Protected Overridable Sub OnSpellCheckStartedTextBox ( _
    e As TextBoxSpellCheckEventArgs _
)
protected:
virtual void OnSpellCheckStartedTextBox(
    TextBoxSpellCheckEventArgs^ e
)
Parameters
e (TextBoxSpellCheckEventArgs)


OnWordAdded Method (sender, e)

OnWordAdded Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► OnWordAdded(Object, WordAddedEventArgs)
Keyoti RapidSpell Silverlight
Fires WordAdded event
Declaration Syntax
C# Visual Basic Visual C++
protected internal void OnWordAdded(
    Object sender,
    WordAddedEventArgs e
)
Protected Friend Sub OnWordAdded ( _
    sender As Object, _
    e As WordAddedEventArgs _
)
protected public:
void OnWordAdded(
    Object^ sender,
    WordAddedEventArgs^ e
)
Parameters
sender (Object)
e (WordAddedEventArgs)


OnWordChanged Method (sender, e)

OnWordChanged Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► OnWordChanged(Object, WordChangedEventArgs)
Keyoti RapidSpell Silverlight
Fires WordChanged event
Declaration Syntax
C# Visual Basic Visual C++
protected internal void OnWordChanged(
    Object sender,
    WordChangedEventArgs e
)
Protected Friend Sub OnWordChanged ( _
    sender As Object, _
    e As WordChangedEventArgs _
)
protected public:
void OnWordChanged(
    Object^ sender,
    WordChangedEventArgs^ e
)
Parameters
sender (Object)
e (WordChangedEventArgs)


OnWordChanging Method (sender, e)

OnWordChanging Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► OnWordChanging(Object, WordChangedEventArgs)
Keyoti RapidSpell Silverlight
Fires WordChanging event
Declaration Syntax
C# Visual Basic Visual C++
protected internal void OnWordChanging(
    Object sender,
    WordChangedEventArgs e
)
Protected Friend Sub OnWordChanging ( _
    sender As Object, _
    e As WordChangedEventArgs _
)
protected public:
void OnWordChanging(
    Object^ sender,
    WordChangedEventArgs^ e
)
Parameters
sender (Object)
e (WordChangedEventArgs)


OnWordIgnored Method (sender, e)

OnWordIgnored Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► OnWordIgnored(Object, WordIgnoredEventArgs)
Keyoti RapidSpell Silverlight
Fires WordIgnored event
Declaration Syntax
C# Visual Basic Visual C++
protected internal void OnWordIgnored(
    Object sender,
    WordIgnoredEventArgs e
)
Protected Friend Sub OnWordIgnored ( _
    sender As Object, _
    e As WordIgnoredEventArgs _
)
protected public:
void OnWordIgnored(
    Object^ sender,
    WordIgnoredEventArgs^ e
)
Parameters
sender (Object)
e (WordIgnoredEventArgs)


Options Property

Options Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► Options
Keyoti RapidSpell Silverlight
Object responsible for holding, loading and saving the user's spell check options.
Declaration Syntax
C# Visual Basic Visual C++
public virtual UserOptions Options { get; set; }
Public Overridable Property Options As UserOptions
public:
virtual property UserOptions^ Options {
    UserOptions^ get ();
    void set (UserOptions^ value);
}
Remarks
To customize how the user's options are saved/loaded, subclass UserOptions and set an instance in this property.


OptionsEnabled Property

OptionsEnabled Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► OptionsEnabled
Keyoti RapidSpell Silverlight
Whether to use user options.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool OptionsEnabled { get; set; }
Public Overridable Property OptionsEnabled As Boolean
public:
virtual property bool OptionsEnabled {
    bool get ();
    void set (bool value);
}


OptionsFileName Property

OptionsFileName Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► OptionsFileName
Keyoti RapidSpell Silverlight
The file name used to store the settings (by default in IsolatedStorage).
Declaration Syntax
C# Visual Basic Visual C++
public string OptionsFileName { get; set; }
Public Property OptionsFileName As String
public:
property String^ OptionsFileName {
    String^ get ();
    void set (String^ value);
}
Remarks
Changing this can ensure different applications have unique user settings.


OptionsPresenter Property

OptionsPresenter Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► OptionsPresenter
Keyoti RapidSpell Silverlight
Presenter for the user options form (IDialogViewOptions).
Declaration Syntax
C# Visual Basic Visual C++
public virtual OptionsPresenter OptionsPresenter { get; set; }
Public Overridable Property OptionsPresenter As OptionsPresenter
public:
virtual property OptionsPresenter^ OptionsPresenter {
    OptionsPresenter^ get ();
    void set (OptionsPresenter^ value);
}
Remarks
Set properties in this instance to affect the options shown to the user, or handle CreateDialogViewOptions to create your own IDialogViewOptions form instance.


OptionsStorageLocation Property

OptionsStorageLocation Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► OptionsStorageLocation
Keyoti RapidSpell Silverlight
Where the user's options are stored.
Declaration Syntax
C# Visual Basic Visual C++
public UserOptions..::.StorageType OptionsStorageLocation { get; set; }
Public Property OptionsStorageLocation As UserOptions..::.StorageType
public:
property UserOptions..::.StorageType OptionsStorageLocation {
    UserOptions..::.StorageType get ();
    void set (UserOptions..::.StorageType value);
}


QueryTextBoxMultiline Property

QueryTextBoxMultiline Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► QueryTextBoxMultiline
Keyoti RapidSpell Silverlight
Whether 'not in dictionary' text box is multiline or single line.
Declaration Syntax
C# Visual Basic Visual C++
public bool QueryTextBoxMultiline { get; set; }
Public Property QueryTextBoxMultiline As Boolean
public:
property bool QueryTextBoxMultiline {
    bool get ();
    void set (bool value);
}


Ready Event

Ready Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► Ready
Keyoti RapidSpell Silverlight
Fired when ready to proceed with first query.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler Ready
Public Event Ready As EventHandler
public:
 event EventHandler^ Ready {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


RecheckDocumentRequest Event

RecheckDocumentRequest Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► RecheckDocumentRequest
Keyoti RapidSpell Silverlight
Fired when the text should be rechecked
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler RecheckDocumentRequest
Public Event RecheckDocumentRequest As EventHandler
public:
 event EventHandler^ RecheckDocumentRequest {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


RemoveTextComponent Method

RemoveTextComponent Method
API ► Keyoti.RapidSpell ► RapidSpellDialog ► RemoveTextComponent()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | RemoveTextComponent(Control) | Removes a TextBoxBase (TextBox, RichTextBox and derivatives) to be checked.
 | RemoveTextComponent(ISpellCheckableTextComponent) | Removes an ISpellCheckableTextComponent to be checked.


RemoveTextComponent Method (textComponent)

RemoveTextComponent Method (textComponent)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► RemoveTextComponent(ISpellCheckableTextComponent)
Keyoti RapidSpell Silverlight
Removes an ISpellCheckableTextComponent to be checked.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void RemoveTextComponent(
    ISpellCheckableTextComponent textComponent
)
Public Overridable Sub RemoveTextComponent ( _
    textComponent As ISpellCheckableTextComponent _
)
public:
virtual void RemoveTextComponent(
    ISpellCheckableTextComponent^ textComponent
)
Parameters
textComponent (ISpellCheckableTextComponent)


RemoveTextComponent Method (textBoxBase)

RemoveTextComponent Method (textBoxBase)
API ► Keyoti.RapidSpell ► RapidSpellDialog ► RemoveTextComponent(Control)
Keyoti RapidSpell Silverlight
Removes a TextBoxBase (TextBox, RichTextBox and derivatives) to be checked.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void RemoveTextComponent(
    Control textBoxBase
)
Public Overridable Sub RemoveTextComponent ( _
    textBoxBase As Control _
)
public:
virtual void RemoveTextComponent(
    Control^ textBoxBase
)
Parameters
textBoxBase (Control)


ResetIgnoredWords Method

ResetIgnoredWords Method
API ► Keyoti.RapidSpell ► RapidSpellDialog ► ResetIgnoredWords()()()
Keyoti RapidSpell Silverlight
Resets all ignored words, so that the document will be rechecked.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void ResetIgnoredWords()
Public Overridable Sub ResetIgnoredWords
public:
virtual void ResetIgnoredWords()


SeparateHyphenWords Property

SeparateHyphenWords Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► SeparateHyphenWords
Keyoti RapidSpell Silverlight
Whether to treat hyphenated (-) words as separate words, default is false.
Declaration Syntax
C# Visual Basic Visual C++
public bool SeparateHyphenWords { get; set; }
Public Property SeparateHyphenWords As Boolean
public:
property bool SeparateHyphenWords {
    bool get ();
    void set (bool value);
}
Remarks
For eg. if this is true text like "cheap-deals" will be treated as two words "cheap" and "deals", otherwise this will be treated as one word "cheap-deals".


ShowContextSentence Property

ShowContextSentence Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► ShowContextSentence
Keyoti RapidSpell Silverlight
Whether to show the query in context of it's sentence/line.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowContextSentence { get; set; }
Public Property ShowContextSentence As Boolean
public:
property bool ShowContextSentence {
    bool get ();
    void set (bool value);
}


ShowFinishedBoxAtEnd Property

ShowFinishedBoxAtEnd Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► ShowFinishedBoxAtEnd
Keyoti RapidSpell Silverlight
Whether to show the spell check complete dialog box at the end, true by default.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowFinishedBoxAtEnd { get; set; }
Public Property ShowFinishedBoxAtEnd As Boolean
public:
property bool ShowFinishedBoxAtEnd {
    bool get ();
    void set (bool value);
}


ShowOptionsButton Property

ShowOptionsButton Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► ShowOptionsButton
Keyoti RapidSpell Silverlight
Whether to show the options button.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowOptionsButton { get; set; }
Public Property ShowOptionsButton As Boolean
public:
property bool ShowOptionsButton {
    bool get ();
    void set (bool value);
}


ShowUndoButton Property

ShowUndoButton Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► ShowUndoButton
Keyoti RapidSpell Silverlight
Whether to show the undo button.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowUndoButton { get; set; }
Public Property ShowUndoButton As Boolean
public:
property bool ShowUndoButton {
    bool get ();
    void set (bool value);
}


SpellCheckFinished Event

SpellCheckFinished Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► SpellCheckFinished
Keyoti RapidSpell Silverlight
Fired when checking finishes
Declaration Syntax
C# Visual Basic Visual C++
public event RapidSpellDialog..::.SpellCheckEventHandler SpellCheckFinished
Public Event SpellCheckFinished As RapidSpellDialog..::.SpellCheckEventHandler
public:
 event RapidSpellDialog..::.SpellCheckEventHandler^ SpellCheckFinished {
    void add (RapidSpellDialog..::.SpellCheckEventHandler^ value);
    void remove (RapidSpellDialog..::.SpellCheckEventHandler^ value);
}


SpellCheckFinishedTextBox Event

SpellCheckFinishedTextBox Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► SpellCheckFinishedTextBox
Keyoti RapidSpell Silverlight
Fired when spell check starts on a text box (used in multiple text box checking situations)
Declaration Syntax
C# Visual Basic Visual C++
public event RapidSpellDialog..::.TextBoxSpellCheckEventHandler SpellCheckFinishedTextBox
Public Event SpellCheckFinishedTextBox As RapidSpellDialog..::.TextBoxSpellCheckEventHandler
public:
 event RapidSpellDialog..::.TextBoxSpellCheckEventHandler^ SpellCheckFinishedTextBox {
    void add (RapidSpellDialog..::.TextBoxSpellCheckEventHandler^ value);
    void remove (RapidSpellDialog..::.TextBoxSpellCheckEventHandler^ value);
}


SpellCheckStarted Event

SpellCheckStarted Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► SpellCheckStarted
Keyoti RapidSpell Silverlight
Fired when checking starts
Declaration Syntax
C# Visual Basic Visual C++
public event RapidSpellDialog..::.SpellCheckEventHandler SpellCheckStarted
Public Event SpellCheckStarted As RapidSpellDialog..::.SpellCheckEventHandler
public:
 event RapidSpellDialog..::.SpellCheckEventHandler^ SpellCheckStarted {
    void add (RapidSpellDialog..::.SpellCheckEventHandler^ value);
    void remove (RapidSpellDialog..::.SpellCheckEventHandler^ value);
}


SpellCheckStartedTextBox Event

SpellCheckStartedTextBox Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► SpellCheckStartedTextBox
Keyoti RapidSpell Silverlight
Fired when spell check starts on a text box (used in multiple text box checking situations)
Declaration Syntax
C# Visual Basic Visual C++
public event RapidSpellDialog..::.TextBoxSpellCheckEventHandler SpellCheckStartedTextBox
Public Event SpellCheckStartedTextBox As RapidSpellDialog..::.TextBoxSpellCheckEventHandler
public:
 event RapidSpellDialog..::.TextBoxSpellCheckEventHandler^ SpellCheckStartedTextBox {
    void add (RapidSpellDialog..::.TextBoxSpellCheckEventHandler^ value);
    void remove (RapidSpellDialog..::.TextBoxSpellCheckEventHandler^ value);
}


SuggestionsMethod Property

SuggestionsMethod Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► SuggestionsMethod
Keyoti RapidSpell Silverlight
The suggestions method to use.
Declaration Syntax
C# Visual Basic Visual C++
public SuggestionsMethodType SuggestionsMethod { get; set; }
Public Property SuggestionsMethod As SuggestionsMethodType
public:
property SuggestionsMethodType SuggestionsMethod {
    SuggestionsMethodType get ();
    void set (SuggestionsMethodType value);
}


SuggestSplitWords Property

SuggestSplitWords Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► SuggestSplitWords
Keyoti RapidSpell Silverlight
Whether to look for connected words in suggestions.
Declaration Syntax
C# Visual Basic Visual C++
public bool SuggestSplitWords { get; set; }
Public Property SuggestSplitWords As Boolean
public:
property bool SuggestSplitWords {
    bool get ();
    void set (bool value);
}
Remarks
if this=true then suggestions may include joined words.

Eg; suggestions for "myhouse" will include "my house"


TextBox Property

TextBox Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► TextBox
Keyoti RapidSpell Silverlight
The TextBox or RichTextBox to work with
Declaration Syntax
C# Visual Basic Visual C++
public Control TextBox { get; set; }
Public Property TextBox As Control
public:
property Control^ TextBox {
    Control^ get ();
    void set (Control^ value);
}


TextBoxBasesToCheck Property

TextBoxBasesToCheck Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► TextBoxBasesToCheck
Keyoti RapidSpell Silverlight
Array of TextBoxBases this GUI will spell check.
Declaration Syntax
C# Visual Basic Visual C++
public Control[] TextBoxBasesToCheck { get; set; }
Public Property TextBoxBasesToCheck As Control()
public:
property array<Control^>^ TextBoxBasesToCheck {
    array<Control^>^ get ();
    void set (array<Control^>^ value);
}


TextBoxProperty Field

TextBoxProperty Field
API ► Keyoti.RapidSpell ► RapidSpellDialog ► TextBoxProperty
Keyoti RapidSpell Silverlight
The RapidSpellAsYouType to work with.
Declaration Syntax
C# Visual Basic Visual C++
public static readonly DependencyProperty TextBoxProperty
Public Shared ReadOnly TextBoxProperty As DependencyProperty
public:
static initonly DependencyProperty^ TextBoxProperty


Texts Property

Texts Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► Texts
Keyoti RapidSpell Silverlight
The UI texts.
Declaration Syntax
C# Visual Basic Visual C++
public DialogTexts Texts { get; set; }
Public Property Texts As DialogTexts
public:
property DialogTexts^ Texts {
    DialogTexts^ get ();
    void set (DialogTexts^ value);
}


ThirdPartyTextComponentsToCheck Property

ThirdPartyTextComponentsToCheck Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► ThirdPartyTextComponentsToCheck
Keyoti RapidSpell Silverlight
Array of ISpellCheckableTextComponent this GUI will spell check.
Declaration Syntax
C# Visual Basic Visual C++
public ISpellCheckableTextComponent[] ThirdPartyTextComponentsToCheck { get; set; }
Public Property ThirdPartyTextComponentsToCheck As ISpellCheckableTextComponent()
public:
property array<ISpellCheckableTextComponent^>^ ThirdPartyTextComponentsToCheck {
    array<ISpellCheckableTextComponent^>^ get ();
    void set (array<ISpellCheckableTextComponent^>^ value);
}


ThirdPartyTextComponentToCheck Property

ThirdPartyTextComponentToCheck Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► ThirdPartyTextComponentToCheck
Keyoti RapidSpell Silverlight
The 3rd Party Component that this GUI will spell check.
Declaration Syntax
C# Visual Basic Visual C++
public ISpellCheckableTextComponent ThirdPartyTextComponentToCheck { get; set; }
Public Property ThirdPartyTextComponentToCheck As ISpellCheckableTextComponent
public:
property ISpellCheckableTextComponent^ ThirdPartyTextComponentToCheck {
    ISpellCheckableTextComponent^ get ();
    void set (ISpellCheckableTextComponent^ value);
}


Undone Event

Undone Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► Undone
Keyoti RapidSpell Silverlight
Fired when an Undo occurs
Declaration Syntax
C# Visual Basic Visual C++
public event UndoEventHandler Undone
Public Event Undone As UndoEventHandler
public:
 event UndoEventHandler^ Undone {
    void add (UndoEventHandler^ value);
    void remove (UndoEventHandler^ value);
}


UserDictionary Property

UserDictionary Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► UserDictionary
Keyoti RapidSpell Silverlight
A custom instance of UserDictionary to use instead of the default file based dictionary.
Declaration Syntax
C# Visual Basic Visual C++
public UserDictionary UserDictionary { get; set; }
Public Property UserDictionary As UserDictionary
public:
property UserDictionary^ UserDictionary {
    UserDictionary^ get ();
    void set (UserDictionary^ value);
}


UserDictionaryEnabled Property

UserDictionaryEnabled Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► UserDictionaryEnabled
Keyoti RapidSpell Silverlight
Whether the user dictionary (Add button) is active.
Declaration Syntax
C# Visual Basic Visual C++
public bool UserDictionaryEnabled { get; set; }
Public Property UserDictionaryEnabled As Boolean
public:
property bool UserDictionaryEnabled {
    bool get ();
    void set (bool value);
}


UserInterfaceFormPresenter Property

UserInterfaceFormPresenter Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► UserInterfaceFormPresenter
Keyoti RapidSpell Silverlight
The presenter (eg. RapidSpellGUIPresenter) currently in use, may be null/Nothing if not created yet.
Declaration Syntax
C# Visual Basic Visual C++
public IUserInterfaceFormPresenter UserInterfaceFormPresenter { get; }
Public ReadOnly Property UserInterfaceFormPresenter As IUserInterfaceFormPresenter
public:
property IUserInterfaceFormPresenter^ UserInterfaceFormPresenter {
    IUserInterfaceFormPresenter^ get ();
}


UserQuery Event

UserQuery Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► UserQuery
Keyoti RapidSpell Silverlight
Indicates that the user is being queried on a spelling error.
Declaration Syntax
C# Visual Basic Visual C++
public event UserQueryEventHandler UserQuery
Public Event UserQuery As UserQueryEventHandler
public:
 event UserQueryEventHandler^ UserQuery {
    void add (UserQueryEventHandler^ value);
    void remove (UserQueryEventHandler^ value);
}


V2Parser Property

V2Parser Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► V2Parser
Keyoti RapidSpell Silverlight
Whether to use parser version 2 - Set to false for backwards (pre v3.4) compatibility.
Declaration Syntax
C# Visual Basic Visual C++
public bool V2Parser { get; set; }
Public Property V2Parser As Boolean
public:
property bool V2Parser {
    bool get ();
    void set (bool value);
}


WarnDuplicates Property

WarnDuplicates Property
API ► Keyoti.RapidSpell ► RapidSpellDialog ► WarnDuplicates
Keyoti RapidSpell Silverlight
Whether to show duplicate words as errors (eg. "this is is an error").
Declaration Syntax
C# Visual Basic Visual C++
public bool WarnDuplicates { get; set; }
Public Property WarnDuplicates As Boolean
public:
property bool WarnDuplicates {
    bool get ();
    void set (bool value);
}


WordAdded Event

WordAdded Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► WordAdded
Keyoti RapidSpell Silverlight
Fired when word added to user dictionary
Declaration Syntax
C# Visual Basic Visual C++
public event WordAddedEventHandler WordAdded
Public Event WordAdded As WordAddedEventHandler
public:
 event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}


WordChanged Event

WordChanged Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► WordChanged
Keyoti RapidSpell Silverlight
Fired when a word is changed
Declaration Syntax
C# Visual Basic Visual C++
public event WordChangedEventHandler WordChanged
Public Event WordChanged As WordChangedEventHandler
public:
 event WordChangedEventHandler^ WordChanged {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}


WordChanging Event

WordChanging Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► WordChanging
Keyoti RapidSpell Silverlight
Fired before a word is changed
Declaration Syntax
C# Visual Basic Visual C++
public event WordChangedEventHandler WordChanging
Public Event WordChanging As WordChangedEventHandler
public:
 event WordChangedEventHandler^ WordChanging {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}


WordIgnored Event

WordIgnored Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► WordIgnored
Keyoti RapidSpell Silverlight
Fired when word ignored
Declaration Syntax
C# Visual Basic Visual C++
public event WordIgnoredEventHandler WordIgnored
Public Event WordIgnored As WordIgnoredEventHandler
public:
 event WordIgnoredEventHandler^ WordIgnored {
    void add (WordIgnoredEventHandler^ value);
    void remove (WordIgnoredEventHandler^ value);
}


WordRemoved Event

WordRemoved Event
API ► Keyoti.RapidSpell ► RapidSpellDialog ► WordRemoved
Keyoti RapidSpell Silverlight
Fired when a word is removed from user dictionary.
Declaration Syntax
C# Visual Basic Visual C++
public event WordRemovedEventHandler WordRemoved
Public Event WordRemoved As WordRemovedEventHandler
public:
 event WordRemovedEventHandler^ WordRemoved {
    void add (WordRemovedEventHandler^ value);
    void remove (WordRemovedEventHandler^ value);
}


RapidSpellDialog.SpellCheckEventHandler Delegate

RapidSpellDialog..::.SpellCheckEventHandler Delegate
API ► Keyoti.RapidSpell ► RapidSpellDialog ► RapidSpellDialog..::.SpellCheckEventHandler
Keyoti RapidSpell Silverlight
Spell check event handler delegate.
Declaration Syntax
C# Visual Basic Visual C++
public delegate void SpellCheckEventHandler(
    Object sender,
    SpellCheckEventArgs e
)
Public Delegate Sub SpellCheckEventHandler ( _
    sender As Object, _
    e As SpellCheckEventArgs _
)
public delegate void SpellCheckEventHandler(
    Object^ sender,
    SpellCheckEventArgs^ e
)
Parameters
sender (Object)
e (SpellCheckEventArgs)


RapidSpellDialog.TextBoxSpellCheckEventHandler Delegate

RapidSpellDialog..::.TextBoxSpellCheckEventHandler Delegate
API ► Keyoti.RapidSpell ► RapidSpellDialog ► RapidSpellDialog..::.TextBoxSpellCheckEventHandler
Keyoti RapidSpell Silverlight
Handler delegate
Declaration Syntax
C# Visual Basic Visual C++
public delegate void TextBoxSpellCheckEventHandler(
    Object sender,
    TextBoxSpellCheckEventArgs e
)
Public Delegate Sub TextBoxSpellCheckEventHandler ( _
    sender As Object, _
    e As TextBoxSpellCheckEventArgs _
)
public delegate void TextBoxSpellCheckEventHandler(
    Object^ sender,
    TextBoxSpellCheckEventArgs^ e
)
Parameters
sender (Object)
e (TextBoxSpellCheckEventArgs)


RapidSpellGUIPresenter Class

RapidSpellGUIPresenter Class
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter
Keyoti RapidSpell Silverlight
Controls the UI logic used for RapidSpellDialog forms.
Declaration Syntax
C# Visual Basic Visual C++
public class RapidSpellGUIPresenter : Component,
    IUserInterfaceFormPresenter, IDialogViewEventHandler
Public Class RapidSpellGUIPresenter _
    Inherits Component _
    Implements IUserInterfaceFormPresenter, IDialogViewEventHandler
public ref class RapidSpellGUIPresenter : public Component,
    IUserInterfaceFormPresenter, IDialogViewEventHandler
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RapidSpellGUIPresenter()()() | Construct this GUI component - this will NOT open a new Form, call Check to do that.
 | ActionPerformed(Object, EventArgs) | Obsolete. Listen to GUI events and perform actions depending on the button sending the event.
 | active | The state of this GUI. It can be either active (user is using it) or inactive (user focus is elsewhere).
 | AddButtonText | Add button text.
 | AddWord()()() | Adds the current bad word to the user dictionary.
 | AllOperationScope | The scope that ignore-all/change-all should have.
 | CancelActionPerformed(Object, CancelEventArgs) | Obsolete. Listen to GUI events and perform actions depending on the button sending the event.
 | CancelButtonText | Cancel button text.
 | Cancelled | Whether the spell check has been cancelled.
 | ChangeAll()()() | Called when user wants to change all instances of current bad word to selected word
 | ChangeAllButtonText | Change All button text.
 | ChangeButtonText | Change button text.
 | ChangeWord()()() | User wants to change current bad word to selected word
 | Check()()() | Bring up the spell checker Form and start checking the component set by SetTextComponentToCheck.
 | Check(ISpellCheckableTextComponent) | Bring up the spell checker Form and start checking the TextBoxBase textComponent.
 | CheckCompletePopUpText | Check complete pop up text
 | CheckCompletePopUpTitle | Check complete pop up title
 | CheckCompoundWords | Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
 | CheckerEngine | The checker engine to use, this object must implement the ICheckerEngine interface, allows customization or replacement of the spell checker.
 | CheckFromStartOfText | Whether to check from the start of the text (true) or whereever the cursor is (false)
 | checkingSelection | The state of this GUI. It can be either active (user is using it) or inactive (user focus is elsewhere).
 | CheckingSpellingText | Checking spelling text
 | Close()()() | Closes the form if open.
 | ConsiderationRange | The factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anything.
 | CreateDialogView | Indicates that a new IDialogView has been created, also provides chance to override the default IDialogView.
 | CreateDialogViewOptions | Indicates that a new IDialogViewOptions is being created, also provides chance to override the default IDialogViewOptions.
 | CreateDialogViewUserDictionaryEdit | Indicates that a new IDialogViewUserDictionaryEdit is being created, also provides chance to override the default IDialogViewUserDictionaryEdit.
 | DialogTitleText | Dialog title text
 | DialogView | The IDialogView instance to use for the UI.
 | DialogView_AddButtonClick(Object, EventArgs) | Handles IDialogView event
 | DialogView_CancelButtonClick(Object, EventArgs) | Handles IDialogView event
 | DialogView_ChangeAllButtonClick(Object, EventArgs) | Handles IDialogView event
 | DialogView_ChangeButtonClick(Object, EventArgs) | Handles IDialogView event
 | DialogView_Closing(Object, CancelEventArgs) | Handles IDialogView event
 | DialogView_IgnoreAllButtonClick(Object, EventArgs) | Handles IDialogView event
 | DialogView_IgnoreButtonClick(Object, EventArgs) | Handles IDialogView event
 | DialogView_Load(Object, EventArgs) | Handles IDialogView event
 | DialogView_OptionsButtonClick(Object, EventArgs) | Handles IDialogView event
 | DialogView_QueryTextBoxEnter(Object, EventArgs) | Handles IDialogView event
 | DialogView_QueryTextBoxTextChanged(Object, EventArgs) | Handles IDialogView event
 | DialogView_SuggestionsListDoubleClick(Object, EventArgs) | Handles IDialogView event
 | DialogView_UndoButtonClick(Object, EventArgs) | Handles the Undo button click
 | DialogView_UserNeedsSuggestionsChanged(Object, EventArgs) | Handles IDialogView event
 | DialogViewOptionsPresenter_CreateDialogViewOptions(Object, CreateDialogViewOptionsEventArgs) | Handles IDialogView event
 | DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit(Object, CreateDialogViewUserDictionaryEditEventArgs) | Handles IDialogView event
 | DictFilePath | Optional file path to the main dictionary .dict file to use.
 | DictionaryLoader | The dictionary loader, which reports loading status.
 | Dispose()()() | Disposes of resources
 | Dispose(Boolean) | Frees up resources (Overrides Component.Dispose(Boolean).)
 | DisposeAtEnd | Whether to dispose of this form when spell check is finished.
 | End()()() | Called when finished checking document, brings up spelling check is complete message.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindCapitalizedSuggestions | Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
 | FindingSuggestionsLabelText | Finding suggestions label text.
 | findSuggestions | Whether this should look up suggestions for misspelt words or not.
 | FindSuggestionsLabelText | Find suggestions label text.
 | FindWordEnd(Int32) | Returns the end of the word that fromPos is in.
 | FinishedCheckingSelectionPopUpText | Finished checking selection dialog text
 | FinishedCheckingSelectionPopUpTitle | Finished checking selection dialog title
 | FocusGained(Object, EventArgs) | Called when objects whose focus this is listening to gain focus.
 | fromPosition | Where the user wants to check from in the document
 | GenerateSentenceParts(Int32, Int32) | Finds the sentence up to a point and the sentence after a point
 | GetConsiderationRange()()() | Obsolete. Gets the factor for words to consider for suggestions.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIgnoreCapitalizedWords()()() | Obsolete. Gets whether to ignore words with capital letters.
 | GetIncludeUserDictionaryInSuggestions()()() | Obsolete. Gets whether the user dictionary should be used in finding suggestions for misspelt words.
 | GetSeparateHyphenWords()()() | Obsolete. Gets whether to treat hyphenated (-) words as separate words, default is false.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GUILanguage | The language to show the UI in.
 | guiShowing | Whether the gui is currently showing
 | Ignore()()() | Ignore the current bad word.
 | IgnoreAll()()() | Ignores all occurrences of this word.
 | IgnoreAllButtonText | Ignore All button text.
 | IgnoreButtonText | Ignore button text.
 | IgnoreCapitalizedWords | Whether to ignore words with capital letters.
 | IgnoreIncorrectSentenceCapitalization | Whether to ignore incorrect sentence capitalization.
 | IgnoreInEnglishLowerCaseI | Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
 | IgnoreWordsWithDigits | Whether to ignore words with numbers in them (eg. A10 or 7-11).
 | IgnoreXML | Whether to ignore XML/HTML tags, false by default.
 | IncludeUserDictionaryInSuggestions | Whether the user dictionary should be used in finding suggestions for misspelt words.
 | InDictionaryLabelText | In dictionary label text
 | IsDisposed | Whether the IDialogView is disposed of
 | IsShowFinishedMessageBox()()() | Obsolete. Returns whether a message box should be opened when the spell check is complete.
 | LanguageParser | The type of language parsing to use.
 | Load | Fired when the DialogView loads.
 | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
 | LookIntoHyphenatedText | Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
 | MakeChange()()() | Changes the current bad word for one selected from the suggestions list or entered in the query pane returns the word used.
 | MakeChange(Boolean) | Changes the current bad word for one selected from the suggestions list or entered in the query pane returns the word used.
 | MakeChange(Boolean, String, Boolean) | Changes the current bad word for one selected from the suggestions list or entered in the query pane returns the word used.
 | MaximumContextualWords | The maximum number of words to show the user in the sentence around misspelled words.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ModalAutoDispose | When running modally, determines if the dialog will be disposed of when spell check finishes.
 | ModalMode | Whether the spell checker will run modally. (Modal operation blocks the parent form)
 | MoveCaretToWordEnd()()() | Moves the caret to the end of the word the caret is in, or where it is if not on a word.
 | MoveCaretToWordStart()()() | Moves the caret to the start of the word the caret is in, or where it is if not on a word.
 | NoSuggestionsText | No suggestions found text
 | NotInDictionaryLabelText | Not in dictionary label text
 | NumberSuggestionList | Whether to number the items in the suggestion list, for quick user selection.
 | OnCreateDialogView(CreateDialogViewEventArgs) | Fires the CreateDialogView event.
 | OnSuggestionsDoubleClick(Object, EventArgs) | Called when the user double clicks on a suggestion.
 | OnUndone(UndoEventArgs) | Raises the Undone event
 | OnUserQuery(UserQueryEventArgs) | Fires the user query event
 | Options | Object responsible for holding, loading and saving the user's spell check options.
 | OptionsButtonText | Options button text
 | OptionsPresenter | Presenter for the user options form (IDialogViewOptions).
 | ProceedFromEnd()()() | Decides what to do once reached end of required text check region
 | QueryTextBoxMultiline | Whether 'not in dictionary' text box is multiline or single line.
 | Ready | Fired when ready to proceed with first query.
 | RecheckDocumentRequest | Fired when document recheck is requested
 | Remove()()() | Safely frees up resources.
 | RemoveDuplicateWordText | Remove duplicate word text
 | Resume()()() | Looks for next bad word
 | ResumeButtonText | Resume button text
 | SelectText(BadWord) | Selects a bad word in the text component
 | SeparateHyphenWords | Sets whether to treat hyphenated (-) words as separate words, default is false.
 | SetConsiderationRange(Int32) | Obsolete. Sets the factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anything.
 | SetDisposeAtEnd(Boolean) | Sets whether this will dispose of self at the end of the spell check.
 | SetFormCancelButton(IButtonControl) | Obsolete. Sets the Form.CancelButton property - this is for VB.NET users who are inheriting from this class.
 | SetIgnoreCapitalizedWords(Boolean) | Obsolete. Sets whether to ignore words with capital letters.
 | SetIgnoreOnceBadWords(ArrayList) | Provide a list of BadWord objects that have been ignored
 | SetIncludeUserDictionaryInSuggestions(Boolean) | Obsolete. Sets whether the user dictionary should be used in finding suggestions for misspelt words.
 | SetSeparateHyphenWords(Boolean) | Obsolete. Sets whether to treat hyphenated (-) words as separate words, default is false.
 | SetShowFinishedMessageBox(Boolean) | Obsolete. Sets whether a message box should be opened when the spell check is complete.
 | SetSuggestionsMethod(Int32) | Obsolete. Sets the suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
 | SetTextComponentToCheck(TextBox) | Set the TextBox that this GUI will spell check.
 | SetTextComponentToCheck(ISpellCheckableTextComponent) | Sets the ISpellCheckableTextComponent that this GUI will spell check.
 | SetTextComponentToCheck(ISpellCheckableTextComponent2) | Sets the ISpellCheckableTextComponent2 that this GUI will spell check.
 | SetUITexts()()() | Applies the UI texts to the IDialogView
 | SetUserDictionary(UserDictionary) | Obsolete. Set the user dictionary object.
 | SetUserDictionaryFile(String) | Obsolete. Set the user dictionary file, if this file doesn't exist it will be created.
 | ShouldEnableAddButton()()() | Determines if the Add button should be enabled
 | ShowContextSentence | Whether to show the query in context of it's sentence/line.
 | ShowFinishedMessageBox | Whether a message box should be opened when the spell check is complete.
 | showMessageBoxAtEnd |
 | SpellCheckFinished | Fired when checking finishes
 | SpellCheckStarted | Fired when checking starts
 | subFromPosition | To check from and to positions that are wrapped, need to do in 2 steps check from subFromPosition ( = fromPosition) -> subToPosition (= doc end) and then check from subFromPosition (= 0) -> subToPosition (= toPosition)
 | subToPosition | To check from and to positions that are wrapped, need to do in 2 steps check from subFromPosition ( = fromPosition) -> subToPosition (= doc end) and then check from subFromPosition (= 0) -> subToPosition (= toPosition)
 | SuggestionsKeyboardText | Suggestions label text when in keyboard mode
 | SuggestionsLabelText | Suggestions label text
 | SuggestionsMethod | The suggestions method to use.
 | SuggestSplitWords | Whether to look for connected words in suggestions.
 | TextBoundary | The AdvancedTextBoundary class to use to parse words.
 | TextBox | The text box instance that this is working with, the actual type depends on whether the TextBoxBaseToCheck property or ThirdPartyTextComponentToCheck property was set.
 | theBadWord |
 | theSpellChecker | The spell checker component being used
 | theTextComponent | The text component being checked
 | toPosition | Where the user wants to check to
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Undo()()() | Undoes the previous user operation.
 | UndoButtonText | Undo button text
 | Undone | Fired when an Undo occurs
 | UserDictionary | Set the user dictionary object.
 | UserDictionaryFile | Set the user dictionary file, if this file doesn't exist it will be created.
 | UserQuery | Indicates that the user is being queried on a spelling error.
 | WarnDuplicates | Whether to show duplicate words as errors (eg. "this is is an error").
 | WordAdded | Fired when word added to user dictionary
 | WordChanged | Fired when word changed
 | WordChanging | Fired before a word is changed
 | WordIgnored | Fired when word ignored
 | Wrap()()() | Wraps the checker to start at beginning of doc
 | wrapped |
Remarks
This class contains no UI elements, instead they are held in it's DialogView property. To customize the UI layout and/or behavior, consult the user guide section "Custom RapidSpellDialog User Interface", which outlines how to use the various "Create*" events in RapidSpellDialog to return custom instances of this class or implementations of IDialogView.
Inheritance Hierarchy
Object
 | Component
 |  | RapidSpellGUIPresenter


RapidSpellGUIPresenter Constructor

RapidSpellGUIPresenter Constructor
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► RapidSpellGUIPresenter()()()
Keyoti RapidSpell Silverlight
Construct this GUI component - this will NOT open a new Form, call Check to do that.
Declaration Syntax
C# Visual Basic Visual C++
public RapidSpellGUIPresenter()
Public Sub New
public:
RapidSpellGUIPresenter()


ActionPerformed Method (sender, e)

ActionPerformed Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► ActionPerformed(Object, EventArgs)
Keyoti RapidSpell Silverlight
Listen to GUI events and perform actions depending on the button sending the event.
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use DialogView_* methods instead.", true)]
protected virtual void ActionPerformed(
    Object sender,
    EventArgs e
)
<ObsoleteAttribute("Use DialogView_* methods instead.", True)> _
Protected Overridable Sub ActionPerformed ( _
    sender As Object, _
    e As EventArgs _
)
[ObsoleteAttribute(L"Use DialogView_* methods instead.", true)]
protected:
virtual void ActionPerformed(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


active Field

active Field
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► active
Keyoti RapidSpell Silverlight
The state of this GUI. It can be either active (user is using it) or inactive (user focus is elsewhere).
Declaration Syntax
C# Visual Basic Visual C++
protected bool active
Protected active As Boolean
protected:
bool active
Remarks
When this window loses focus the GUI is deactivated, because the text in theTextComponent can change whilst focus is away, and upon reactivation the new text must be loaded in. findSuggestions determines if should look up suggestions or not.


AddButtonText Property

AddButtonText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► AddButtonText
Keyoti RapidSpell Silverlight
Add button text.
Declaration Syntax
C# Visual Basic Visual C++
public string AddButtonText { get; set; }
Public Property AddButtonText As String
public:
virtual property String^ AddButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}


AddWord Method

AddWord Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► AddWord()()()
Keyoti RapidSpell Silverlight
Adds the current bad word to the user dictionary.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void AddWord()
Protected Overridable Sub AddWord
protected:
virtual void AddWord()
Return Value
void


AllOperationScope Property

AllOperationScope Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► AllOperationScope
Keyoti RapidSpell Silverlight
The scope that ignore-all/change-all should have.
Declaration Syntax
C# Visual Basic Visual C++
public OperationScope AllOperationScope { get; set; }
Public Property AllOperationScope As OperationScope
public:
virtual property OperationScope AllOperationScope {
    OperationScope get () sealed;
    void set (OperationScope value) sealed;
}


CancelActionPerformed Method (sender, e)

CancelActionPerformed Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► CancelActionPerformed(Object, CancelEventArgs)
Keyoti RapidSpell Silverlight
Listen to GUI events and perform actions depending on the button sending the event.
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use DialogView_Closing instead.", true)]
protected virtual void CancelActionPerformed(
    Object sender,
    CancelEventArgs e
)
<ObsoleteAttribute("Use DialogView_Closing instead.", True)> _
Protected Overridable Sub CancelActionPerformed ( _
    sender As Object, _
    e As CancelEventArgs _
)
[ObsoleteAttribute(L"Use DialogView_Closing instead.", true)]
protected:
virtual void CancelActionPerformed(
    Object^ sender,
    CancelEventArgs^ e
)
Parameters
sender (Object)
e (CancelEventArgs)


CancelButtonText Property

CancelButtonText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► CancelButtonText
Keyoti RapidSpell Silverlight
Cancel button text.
Declaration Syntax
C# Visual Basic Visual C++
public string CancelButtonText { get; set; }
Public Property CancelButtonText As String
public:
virtual property String^ CancelButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}


Cancelled Property

Cancelled Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Cancelled
Keyoti RapidSpell Silverlight
Whether the spell check has been cancelled.
Declaration Syntax
C# Visual Basic Visual C++
public bool Cancelled { get; }
Public ReadOnly Property Cancelled As Boolean
public:
virtual property bool Cancelled {
    bool get () sealed;
}


ChangeAll Method

ChangeAll Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► ChangeAll()()()
Keyoti RapidSpell Silverlight
Called when user wants to change all instances of current bad word to selected word
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void ChangeAll()
Protected Overridable Sub ChangeAll
protected:
virtual void ChangeAll()
Return Value
void


ChangeAllButtonText Property

ChangeAllButtonText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► ChangeAllButtonText
Keyoti RapidSpell Silverlight
Change All button text.
Declaration Syntax
C# Visual Basic Visual C++
public string ChangeAllButtonText { get; set; }
Public Property ChangeAllButtonText As String
public:
virtual property String^ ChangeAllButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}


ChangeButtonText Property

ChangeButtonText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► ChangeButtonText
Keyoti RapidSpell Silverlight
Change button text.
Declaration Syntax
C# Visual Basic Visual C++
public string ChangeButtonText { get; set; }
Public Property ChangeButtonText As String
public:
virtual property String^ ChangeButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}


ChangeWord Method

ChangeWord Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► ChangeWord()()()
Keyoti RapidSpell Silverlight
User wants to change current bad word to selected word
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void ChangeWord()
Protected Overridable Sub ChangeWord
protected:
virtual void ChangeWord()
Return Value
void


Check Method

Check Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Check()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | Check()()() | Bring up the spell checker Form and start checking the component set by SetTextComponentToCheck.
 | Check(ISpellCheckableTextComponent) | Bring up the spell checker Form and start checking the TextBoxBase textComponent.


Check Method

Check Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Check()()()
Keyoti RapidSpell Silverlight
Bring up the spell checker Form and start checking the component set by SetTextComponentToCheck.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Check()
Public Overridable Sub Check
public:
virtual void Check()
Exceptions
Exception | Condition
NoTextComponentException | if SetTextComponentToCheck hasn't be called first with a TextBoxBase object.


Check Method (textComponent)

Check Method (textComponent)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Check(ISpellCheckableTextComponent)
Keyoti RapidSpell Silverlight
Bring up the spell checker Form and start checking the TextBoxBase textComponent.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Check(
    ISpellCheckableTextComponent textComponent
)
Public Overridable Sub Check ( _
    textComponent As ISpellCheckableTextComponent _
)
public:
virtual void Check(
    ISpellCheckableTextComponent^ textComponent
)
Parameters
textComponent (ISpellCheckableTextComponent)
Exceptions
Exception | Condition
ArgumentNullException | if textComponent parameter is null.


CheckCompletePopUpText Property

CheckCompletePopUpText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► CheckCompletePopUpText
Keyoti RapidSpell Silverlight
Check complete pop up text
Declaration Syntax
C# Visual Basic Visual C++
public string CheckCompletePopUpText { get; set; }
Public Property CheckCompletePopUpText As String
public:
virtual property String^ CheckCompletePopUpText {
    String^ get () sealed;
    void set (String^ value) sealed;
}


CheckCompletePopUpTitle Property

CheckCompletePopUpTitle Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► CheckCompletePopUpTitle
Keyoti RapidSpell Silverlight
Check complete pop up title
Declaration Syntax
C# Visual Basic Visual C++
public string CheckCompletePopUpTitle { get; set; }
Public Property CheckCompletePopUpTitle As String
public:
virtual property String^ CheckCompletePopUpTitle {
    String^ get () sealed;
    void set (String^ value) sealed;
}


CheckCompoundWords Property

CheckCompoundWords Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► CheckCompoundWords
Keyoti RapidSpell Silverlight
Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckCompoundWords { get; set; }
Public Property CheckCompoundWords As Boolean
public:
virtual property bool CheckCompoundWords {
    bool get () sealed;
    void set (bool value) sealed;
}
Remarks
If this=false then LookUp("thesewordsarejoined") = false

If this=true then LookUp("thesewordsarejoined") = true

If this=false then LookUp("abcdef") = false

If this=true then LookUp("abcdef") = false

Setting this to true will degrade lookup performance


CheckerEngine Property

CheckerEngine Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► CheckerEngine
Keyoti RapidSpell Silverlight
The checker engine to use, this object must implement the ICheckerEngine interface, allows customization or replacement of the spell checker.
Declaration Syntax
C# Visual Basic Visual C++
public virtual ICheckerEngine CheckerEngine { get; set; }
Public Overridable Property CheckerEngine As ICheckerEngine
public:
virtual property ICheckerEngine^ CheckerEngine {
    ICheckerEngine^ get ();
    void set (ICheckerEngine^ value);
}
Remarks
Use this property to replace the object used to perform checking, it is not necessary to replace this with a spell checker, any type of word parser can be used. For example an abbreviations checker could be written to replace common words with abbreviations. Caveat: Most properties in RapidSpellGUI are mirrors of properties in ICheckerEngine, setting a CheckerEngine AFTER setting properties in RapidSpellGUI will overwrite those property values with the values of CheckerEngine.


CheckFromStartOfText Property

CheckFromStartOfText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► CheckFromStartOfText
Keyoti RapidSpell Silverlight
Whether to check from the start of the text (true) or whereever the cursor is (false)
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckFromStartOfText { get; set; }
Public Property CheckFromStartOfText As Boolean
public:
virtual property bool CheckFromStartOfText {
    bool get () sealed;
    void set (bool value) sealed;
}


checkingSelection Field

checkingSelection Field
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► checkingSelection
Keyoti RapidSpell Silverlight
The state of this GUI. It can be either active (user is using it) or inactive (user focus is elsewhere).
Declaration Syntax
C# Visual Basic Visual C++
protected bool checkingSelection
Protected checkingSelection As Boolean
protected:
bool checkingSelection
Remarks
When this window loses focus the GUI is deactivated, because the text in theTextComponent can change whilst focus is away, and upon reactivation the new text must be loaded in. findSuggestions determines if should look up suggestions or not.


CheckingSpellingText Property

CheckingSpellingText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► CheckingSpellingText
Keyoti RapidSpell Silverlight
Checking spelling text
Declaration Syntax
C# Visual Basic Visual C++
public string CheckingSpellingText { get; set; }
Public Property CheckingSpellingText As String
public:
virtual property String^ CheckingSpellingText {
    String^ get () sealed;
    void set (String^ value) sealed;
}


Close Method

Close Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Close()()()
Keyoti RapidSpell Silverlight
Closes the form if open.
Declaration Syntax
C# Visual Basic Visual C++
public void Close()
Public Sub Close
public:
void Close()


ConsiderationRange Property

ConsiderationRange Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► ConsiderationRange
Keyoti RapidSpell Silverlight
The factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anything.
Declaration Syntax
C# Visual Basic Visual C++
public int ConsiderationRange { get; set; }
Public Property ConsiderationRange As Integer
public:
virtual property int ConsiderationRange {
    int get () sealed;
    void set (int value) sealed;
}


CreateDialogView Event

CreateDialogView Event
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► CreateDialogView
Keyoti RapidSpell Silverlight
Indicates that a new IDialogView has been created, also provides chance to override the default IDialogView.
Declaration Syntax
C# Visual Basic Visual C++
public event CreateDialogViewEventHandler CreateDialogView
Public Event CreateDialogView As CreateDialogViewEventHandler
public:
virtual  event CreateDialogViewEventHandler^ CreateDialogView {
    void add (CreateDialogViewEventHandler^ value);
    void remove (CreateDialogViewEventHandler^ value);
}


CreateDialogViewOptions Event

CreateDialogViewOptions Event
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► CreateDialogViewOptions
Keyoti RapidSpell Silverlight
Indicates that a new IDialogViewOptions is being created, also provides chance to override the default IDialogViewOptions.
Declaration Syntax
C# Visual Basic Visual C++
public event CreateDialogViewOptionsEventHandler CreateDialogViewOptions
Public Event CreateDialogViewOptions As CreateDialogViewOptionsEventHandler
public:
virtual  event CreateDialogViewOptionsEventHandler^ CreateDialogViewOptions {
    void add (CreateDialogViewOptionsEventHandler^ value);
    void remove (CreateDialogViewOptionsEventHandler^ value);
}


CreateDialogViewUserDictionaryEdit Event

CreateDialogViewUserDictionaryEdit Event
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► CreateDialogViewUserDictionaryEdit
Keyoti RapidSpell Silverlight
Indicates that a new IDialogViewUserDictionaryEdit is being created, also provides chance to override the default IDialogViewUserDictionaryEdit.
Declaration Syntax
C# Visual Basic Visual C++
public event CreateDialogViewUserDictionaryEditEventHandler CreateDialogViewUserDictionaryEdit
Public Event CreateDialogViewUserDictionaryEdit As CreateDialogViewUserDictionaryEditEventHandler
public:
virtual  event CreateDialogViewUserDictionaryEditEventHandler^ CreateDialogViewUserDictionaryEdit {
    void add (CreateDialogViewUserDictionaryEditEventHandler^ value);
    void remove (CreateDialogViewUserDictionaryEditEventHandler^ value);
}


DialogTitleText Property

DialogTitleText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogTitleText
Keyoti RapidSpell Silverlight
Dialog title text
Declaration Syntax
C# Visual Basic Visual C++
public string DialogTitleText { get; set; }
Public Property DialogTitleText As String
public:
virtual property String^ DialogTitleText {
    String^ get () sealed;
    void set (String^ value) sealed;
}


DialogView Property

DialogView Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogView
Keyoti RapidSpell Silverlight
The IDialogView instance to use for the UI.
Declaration Syntax
C# Visual Basic Visual C++
public virtual IDialogView DialogView { get; set; }
Public Overridable Property DialogView As IDialogView
public:
virtual property IDialogView^ DialogView {
    IDialogView^ get ();
    void set (IDialogView^ value);
}
Remarks
Handler CreateDialogView and set NewView to set a different instance to use.


DialogView_AddButtonClick Method (sender, e)

DialogView_AddButtonClick Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogView_AddButtonClick(Object, EventArgs)
Keyoti RapidSpell Silverlight
Handles IDialogView event
Declaration Syntax
C# Visual Basic Visual C++
public virtual void DialogView_AddButtonClick(
    Object sender,
    EventArgs e
)
Public Overridable Sub DialogView_AddButtonClick ( _
    sender As Object, _
    e As EventArgs _
)
public:
virtual void DialogView_AddButtonClick(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


DialogView_CancelButtonClick Method (sender, e)

DialogView_CancelButtonClick Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogView_CancelButtonClick(Object, EventArgs)
Keyoti RapidSpell Silverlight
Handles IDialogView event
Declaration Syntax
C# Visual Basic Visual C++
public virtual void DialogView_CancelButtonClick(
    Object sender,
    EventArgs e
)
Public Overridable Sub DialogView_CancelButtonClick ( _
    sender As Object, _
    e As EventArgs _
)
public:
virtual void DialogView_CancelButtonClick(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


DialogView_ChangeAllButtonClick Method (sender, e)

DialogView_ChangeAllButtonClick Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogView_ChangeAllButtonClick(Object, EventArgs)
Keyoti RapidSpell Silverlight
Handles IDialogView event
Declaration Syntax
C# Visual Basic Visual C++
public virtual void DialogView_ChangeAllButtonClick(
    Object sender,
    EventArgs e
)
Public Overridable Sub DialogView_ChangeAllButtonClick ( _
    sender As Object, _
    e As EventArgs _
)
public:
virtual void DialogView_ChangeAllButtonClick(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


DialogView_ChangeButtonClick Method (sender, e)

DialogView_ChangeButtonClick Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogView_ChangeButtonClick(Object, EventArgs)
Keyoti RapidSpell Silverlight
Handles IDialogView event
Declaration Syntax
C# Visual Basic Visual C++
public virtual void DialogView_ChangeButtonClick(
    Object sender,
    EventArgs e
)
Public Overridable Sub DialogView_ChangeButtonClick ( _
    sender As Object, _
    e As EventArgs _
)
public:
virtual void DialogView_ChangeButtonClick(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


DialogView_Closing Method (sender, e)

DialogView_Closing Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogView_Closing(Object, CancelEventArgs)
Keyoti RapidSpell Silverlight
Handles IDialogView event
Declaration Syntax
C# Visual Basic Visual C++
public virtual void DialogView_Closing(
    Object sender,
    CancelEventArgs e
)
Public Overridable Sub DialogView_Closing ( _
    sender As Object, _
    e As CancelEventArgs _
)
public:
virtual void DialogView_Closing(
    Object^ sender,
    CancelEventArgs^ e
)
Parameters
sender (Object)
e (CancelEventArgs)


DialogView_IgnoreAllButtonClick Method (s, e)

DialogView_IgnoreAllButtonClick Method (s, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogView_IgnoreAllButtonClick(Object, EventArgs)
Keyoti RapidSpell Silverlight
Handles IDialogView event
Declaration Syntax
C# Visual Basic Visual C++
public virtual void DialogView_IgnoreAllButtonClick(
    Object s,
    EventArgs e
)
Public Overridable Sub DialogView_IgnoreAllButtonClick ( _
    s As Object, _
    e As EventArgs _
)
public:
virtual void DialogView_IgnoreAllButtonClick(
    Object^ s,
    EventArgs^ e
)
Parameters
s (Object)
e (EventArgs)


DialogView_IgnoreButtonClick Method (s, e)

DialogView_IgnoreButtonClick Method (s, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogView_IgnoreButtonClick(Object, EventArgs)
Keyoti RapidSpell Silverlight
Handles IDialogView event
Declaration Syntax
C# Visual Basic Visual C++
public virtual void DialogView_IgnoreButtonClick(
    Object s,
    EventArgs e
)
Public Overridable Sub DialogView_IgnoreButtonClick ( _
    s As Object, _
    e As EventArgs _
)
public:
virtual void DialogView_IgnoreButtonClick(
    Object^ s,
    EventArgs^ e
)
Parameters
s (Object)
e (EventArgs)


DialogView_Load Method (s, e)

DialogView_Load Method (s, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogView_Load(Object, EventArgs)
Keyoti RapidSpell Silverlight
Handles IDialogView event
Declaration Syntax
C# Visual Basic Visual C++
public virtual void DialogView_Load(
    Object s,
    EventArgs e
)
Public Overridable Sub DialogView_Load ( _
    s As Object, _
    e As EventArgs _
)
public:
virtual void DialogView_Load(
    Object^ s,
    EventArgs^ e
)
Parameters
s (Object)
e (EventArgs)


DialogView_OptionsButtonClick Method (sender, e)

DialogView_OptionsButtonClick Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogView_OptionsButtonClick(Object, EventArgs)
Keyoti RapidSpell Silverlight
Handles IDialogView event
Declaration Syntax
C# Visual Basic Visual C++
public virtual void DialogView_OptionsButtonClick(
    Object sender,
    EventArgs e
)
Public Overridable Sub DialogView_OptionsButtonClick ( _
    sender As Object, _
    e As EventArgs _
)
public:
virtual void DialogView_OptionsButtonClick(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


DialogView_QueryTextBoxEnter Method (sender, e)

DialogView_QueryTextBoxEnter Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogView_QueryTextBoxEnter(Object, EventArgs)
Keyoti RapidSpell Silverlight
Handles IDialogView event
Declaration Syntax
C# Visual Basic Visual C++
public virtual void DialogView_QueryTextBoxEnter(
    Object sender,
    EventArgs e
)
Public Overridable Sub DialogView_QueryTextBoxEnter ( _
    sender As Object, _
    e As EventArgs _
)
public:
virtual void DialogView_QueryTextBoxEnter(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


DialogView_QueryTextBoxTextChanged Method (sender, e)

DialogView_QueryTextBoxTextChanged Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogView_QueryTextBoxTextChanged(Object, EventArgs)
Keyoti RapidSpell Silverlight
Handles IDialogView event
Declaration Syntax
C# Visual Basic Visual C++
public virtual void DialogView_QueryTextBoxTextChanged(
    Object sender,
    EventArgs e
)
Public Overridable Sub DialogView_QueryTextBoxTextChanged ( _
    sender As Object, _
    e As EventArgs _
)
public:
virtual void DialogView_QueryTextBoxTextChanged(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


DialogView_SuggestionsListDoubleClick Method (sender, e)

DialogView_SuggestionsListDoubleClick Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogView_SuggestionsListDoubleClick(Object, EventArgs)
Keyoti RapidSpell Silverlight
Handles IDialogView event
Declaration Syntax
C# Visual Basic Visual C++
public virtual void DialogView_SuggestionsListDoubleClick(
    Object sender,
    EventArgs e
)
Public Overridable Sub DialogView_SuggestionsListDoubleClick ( _
    sender As Object, _
    e As EventArgs _
)
public:
virtual void DialogView_SuggestionsListDoubleClick(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


DialogView_UndoButtonClick Method (sender, e)

DialogView_UndoButtonClick Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogView_UndoButtonClick(Object, EventArgs)
Keyoti RapidSpell Silverlight
Handles the Undo button click
Declaration Syntax
C# Visual Basic Visual C++
public virtual void DialogView_UndoButtonClick(
    Object sender,
    EventArgs e
)
Public Overridable Sub DialogView_UndoButtonClick ( _
    sender As Object, _
    e As EventArgs _
)
public:
virtual void DialogView_UndoButtonClick(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


DialogView_UserNeedsSuggestionsChanged Method (sender, e)

DialogView_UserNeedsSuggestionsChanged Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogView_UserNeedsSuggestionsChanged(Object, EventArgs)
Keyoti RapidSpell Silverlight
Handles IDialogView event
Declaration Syntax
C# Visual Basic Visual C++
public virtual void DialogView_UserNeedsSuggestionsChanged(
    Object sender,
    EventArgs e
)
Public Overridable Sub DialogView_UserNeedsSuggestionsChanged ( _
    sender As Object, _
    e As EventArgs _
)
public:
virtual void DialogView_UserNeedsSuggestionsChanged(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


DialogViewOptionsPresenter_CreateDialogViewOptions Method (s, ev)

DialogViewOptionsPresenter_CreateDialogViewOptions Method (s, ev)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogViewOptionsPresenter_CreateDialogViewOptions(Object, CreateDialogViewOptionsEventArgs)
Keyoti RapidSpell Silverlight
Handles IDialogView event
Declaration Syntax
C# Visual Basic Visual C++
protected internal virtual void DialogViewOptionsPresenter_CreateDialogViewOptions(
    Object s,
    CreateDialogViewOptionsEventArgs ev
)
Protected Friend Overridable Sub DialogViewOptionsPresenter_CreateDialogViewOptions ( _
    s As Object, _
    ev As CreateDialogViewOptionsEventArgs _
)
protected public:
virtual void DialogViewOptionsPresenter_CreateDialogViewOptions(
    Object^ s,
    CreateDialogViewOptionsEventArgs^ ev
)
Parameters
s (Object)
ev (CreateDialogViewOptionsEventArgs)


DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit Method (sender, e)

DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit(Object, CreateDialogViewUserDictionaryEditEventArgs)
Keyoti RapidSpell Silverlight
Handles IDialogView event
Declaration Syntax
C# Visual Basic Visual C++
protected internal virtual void DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit(
    Object sender,
    CreateDialogViewUserDictionaryEditEventArgs e
)
Protected Friend Overridable Sub DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit ( _
    sender As Object, _
    e As CreateDialogViewUserDictionaryEditEventArgs _
)
protected public:
virtual void DialogViewOptionsPresenter_CreateDialogViewUserDictionaryEdit(
    Object^ sender,
    CreateDialogViewUserDictionaryEditEventArgs^ e
)
Parameters
sender (Object)
e (CreateDialogViewUserDictionaryEditEventArgs)


DictFilePath Property

DictFilePath Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DictFilePath
Keyoti RapidSpell Silverlight
Optional file path to the main dictionary .dict file to use.
Declaration Syntax
C# Visual Basic Visual C++
public string DictFilePath { get; set; }
Public Property DictFilePath As String
public:
virtual property String^ DictFilePath {
    String^ get () sealed;
    void set (String^ value) sealed;
}


DictionaryLoader Property

DictionaryLoader Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DictionaryLoader
Keyoti RapidSpell Silverlight
The dictionary loader, which reports loading status.
Declaration Syntax
C# Visual Basic Visual C++
public AsyncDictionaryLoader DictionaryLoader { get; set; }
Public Property DictionaryLoader As AsyncDictionaryLoader
public:
virtual property AsyncDictionaryLoader^ DictionaryLoader {
    AsyncDictionaryLoader^ get () sealed;
    void set (AsyncDictionaryLoader^ value) sealed;
}


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Dispose()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | Dispose()()() | Disposes of resources
 | Dispose(Boolean) | Frees up resources (Overrides Component.Dispose(Boolean).)


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Dispose()()()
Keyoti RapidSpell Silverlight
Disposes of resources
Declaration Syntax
C# Visual Basic Visual C++
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed


Dispose Method (disposing)

Dispose Method (disposing)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Dispose(Boolean)
Keyoti RapidSpell Silverlight
Frees up resources
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)


DisposeAtEnd Property

DisposeAtEnd Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► DisposeAtEnd
Keyoti RapidSpell Silverlight
Whether to dispose of this form when spell check is finished.
Declaration Syntax
C# Visual Basic Visual C++
public bool DisposeAtEnd { get; set; }
Public Property DisposeAtEnd As Boolean
public:
virtual property bool DisposeAtEnd {
    bool get () sealed;
    void set (bool value) sealed;
}


End Method

End Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► End()()()
Keyoti RapidSpell Silverlight
Called when finished checking document, brings up spelling check is complete message.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void End()
Protected Overridable Sub End
protected:
virtual void End()


FindCapitalizedSuggestions Property

FindCapitalizedSuggestions Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► FindCapitalizedSuggestions
Keyoti RapidSpell Silverlight
Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
Declaration Syntax
C# Visual Basic Visual C++
public bool FindCapitalizedSuggestions { get; set; }
Public Property FindCapitalizedSuggestions As Boolean
public:
virtual property bool FindCapitalizedSuggestions {
    bool get () sealed;
    void set (bool value) sealed;
}


FindingSuggestionsLabelText Property

FindingSuggestionsLabelText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► FindingSuggestionsLabelText
Keyoti RapidSpell Silverlight
Finding suggestions label text.
Declaration Syntax
C# Visual Basic Visual C++
public string FindingSuggestionsLabelText { get; set; }
Public Property FindingSuggestionsLabelText As String
public:
virtual property String^ FindingSuggestionsLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}


findSuggestions Field

findSuggestions Field
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► findSuggestions
Keyoti RapidSpell Silverlight
Whether this should look up suggestions for misspelt words or not.
Declaration Syntax
C# Visual Basic Visual C++
protected bool findSuggestions
Protected findSuggestions As Boolean
protected:
bool findSuggestions


FindSuggestionsLabelText Property

FindSuggestionsLabelText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► FindSuggestionsLabelText
Keyoti RapidSpell Silverlight
Find suggestions label text.
Declaration Syntax
C# Visual Basic Visual C++
public string FindSuggestionsLabelText { get; set; }
Public Property FindSuggestionsLabelText As String
public:
virtual property String^ FindSuggestionsLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}


FindWordEnd Method (fromPos)

FindWordEnd Method (fromPos)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► FindWordEnd(Int32)
Keyoti RapidSpell Silverlight
Returns the end of the word that fromPos is in.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual int FindWordEnd(
    int fromPos
)
Protected Overridable Function FindWordEnd ( _
    fromPos As Integer _
) As Integer
protected:
virtual int FindWordEnd(
    int fromPos
)
Parameters
fromPos (Int32)


FinishedCheckingSelectionPopUpText Property

FinishedCheckingSelectionPopUpText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► FinishedCheckingSelectionPopUpText
Keyoti RapidSpell Silverlight
Finished checking selection dialog text
Declaration Syntax
C# Visual Basic Visual C++
public string FinishedCheckingSelectionPopUpText { get; set; }
Public Property FinishedCheckingSelectionPopUpText As String
public:
virtual property String^ FinishedCheckingSelectionPopUpText {
    String^ get () sealed;
    void set (String^ value) sealed;
}


FinishedCheckingSelectionPopUpTitle Property

FinishedCheckingSelectionPopUpTitle Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► FinishedCheckingSelectionPopUpTitle
Keyoti RapidSpell Silverlight
Finished checking selection dialog title
Declaration Syntax
C# Visual Basic Visual C++
public string FinishedCheckingSelectionPopUpTitle { get; set; }
Public Property FinishedCheckingSelectionPopUpTitle As String
public:
virtual property String^ FinishedCheckingSelectionPopUpTitle {
    String^ get () sealed;
    void set (String^ value) sealed;
}


FocusGained Method (sender, e)

FocusGained Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► FocusGained(Object, EventArgs)
Keyoti RapidSpell Silverlight
Called when objects whose focus this is listening to gain focus.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void FocusGained(
    Object sender,
    EventArgs e
)
Protected Overridable Sub FocusGained ( _
    sender As Object, _
    e As EventArgs _
)
protected:
virtual void FocusGained(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


fromPosition Field

fromPosition Field
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► fromPosition
Keyoti RapidSpell Silverlight
Where the user wants to check from in the document
Declaration Syntax
C# Visual Basic Visual C++
protected int fromPosition
Protected fromPosition As Integer
protected:
int fromPosition


GenerateSentenceParts Method (preEnd, postStart)

GenerateSentenceParts Method (preEnd, postStart)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► GenerateSentenceParts(Int32, Int32)
Keyoti RapidSpell Silverlight
Finds the sentence up to a point and the sentence after a point
Declaration Syntax
C# Visual Basic Visual C++
protected virtual string[] GenerateSentenceParts(
    int preEnd,
    int postStart
)
Protected Overridable Function GenerateSentenceParts ( _
    preEnd As Integer, _
    postStart As Integer _
) As String()
protected:
virtual array<String^>^ GenerateSentenceParts(
    int preEnd,
    int postStart
)
Parameters
preEnd (Int32)
The point at which the first part of the sentence ends
postStart (Int32)
The point at which the second part of the sentence starts
Return Value
A 2 element string array holding the sentence up to preEnd in the first element and the sentence after postStart in the second element. The intention is that preEnd is the beginning of a misspelled word and postStart is the end of a misspelled word. The sentence parts are then used as context in the query dialog box.


GetConsiderationRange Method

GetConsiderationRange Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► GetConsiderationRange()()()
Keyoti RapidSpell Silverlight
Gets the factor for words to consider for suggestions.
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use ConsiderationRange instead.", true)]
public int GetConsiderationRange()
<ObsoleteAttribute("Use ConsiderationRange instead.", True)> _
Public Function GetConsiderationRange As Integer
[ObsoleteAttribute(L"Use ConsiderationRange instead.", true)]
public:
int GetConsiderationRange()


GetIgnoreCapitalizedWords Method

GetIgnoreCapitalizedWords Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► GetIgnoreCapitalizedWords()()()
Keyoti RapidSpell Silverlight
Gets whether to ignore words with capital letters.
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use IgnoreCapitalizedWords instead.", true)]
public bool GetIgnoreCapitalizedWords()
<ObsoleteAttribute("Use IgnoreCapitalizedWords instead.", True)> _
Public Function GetIgnoreCapitalizedWords As Boolean
[ObsoleteAttribute(L"Use IgnoreCapitalizedWords instead.", true)]
public:
bool GetIgnoreCapitalizedWords()


GetIncludeUserDictionaryInSuggestions Method

GetIncludeUserDictionaryInSuggestions Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► GetIncludeUserDictionaryInSuggestions()()()
Keyoti RapidSpell Silverlight
Gets whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use IncludeUserDictionaryInSuggestions instead.",
    true)]
public bool GetIncludeUserDictionaryInSuggestions()
<ObsoleteAttribute("Use IncludeUserDictionaryInSuggestions instead.",  _
    True)> _
Public Function GetIncludeUserDictionaryInSuggestions As Boolean
[ObsoleteAttribute(L"Use IncludeUserDictionaryInSuggestions instead.",
    true)]
public:
bool GetIncludeUserDictionaryInSuggestions()


GetSeparateHyphenWords Method

GetSeparateHyphenWords Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► GetSeparateHyphenWords()()()
Keyoti RapidSpell Silverlight
Gets whether to treat hyphenated (-) words as separate words, default is false.
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use SeparateHyphenWords instead.", true)]
public bool GetSeparateHyphenWords()
<ObsoleteAttribute("Use SeparateHyphenWords instead.", True)> _
Public Function GetSeparateHyphenWords As Boolean
[ObsoleteAttribute(L"Use SeparateHyphenWords instead.", true)]
public:
bool GetSeparateHyphenWords()
Remarks
For eg. if this is true text like "cheap-deals" will be treated as two words "cheap" and "deals", otherwise this will be treated as one word "cheap-deals".


GUILanguage Property

GUILanguage Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► GUILanguage
Keyoti RapidSpell Silverlight
The language to show the UI in.
Declaration Syntax
C# Visual Basic Visual C++
public LanguageType GUILanguage { get; set; }
Public Property GUILanguage As LanguageType
public:
virtual property LanguageType GUILanguage {
    LanguageType get () sealed;
    void set (LanguageType value) sealed;
}


guiShowing Field

guiShowing Field
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► guiShowing
Keyoti RapidSpell Silverlight
Whether the gui is currently showing
Declaration Syntax
C# Visual Basic Visual C++
protected bool guiShowing
Protected guiShowing As Boolean
protected:
bool guiShowing


Ignore Method

Ignore Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Ignore()()()
Keyoti RapidSpell Silverlight
Ignore the current bad word.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void Ignore()
Protected Overridable Sub Ignore
protected:
virtual void Ignore()
Return Value
void


IgnoreAll Method

IgnoreAll Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► IgnoreAll()()()
Keyoti RapidSpell Silverlight
Ignores all occurrences of this word.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void IgnoreAll()
Protected Overridable Sub IgnoreAll
protected:
virtual void IgnoreAll()
Return Value
void


IgnoreAllButtonText Property

IgnoreAllButtonText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► IgnoreAllButtonText
Keyoti RapidSpell Silverlight
Ignore All button text.
Declaration Syntax
C# Visual Basic Visual C++
public string IgnoreAllButtonText { get; set; }
Public Property IgnoreAllButtonText As String
public:
virtual property String^ IgnoreAllButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}


IgnoreButtonText Property

IgnoreButtonText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► IgnoreButtonText
Keyoti RapidSpell Silverlight
Ignore button text.
Declaration Syntax
C# Visual Basic Visual C++
public string IgnoreButtonText { get; set; }
Public Property IgnoreButtonText As String
public:
virtual property String^ IgnoreButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}


IgnoreCapitalizedWords Property

IgnoreCapitalizedWords Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► IgnoreCapitalizedWords
Keyoti RapidSpell Silverlight
Whether to ignore words with capital letters.
Declaration Syntax
C# Visual Basic Visual C++
public bool IgnoreCapitalizedWords { get; set; }
Public Property IgnoreCapitalizedWords As Boolean
public:
virtual property bool IgnoreCapitalizedWords {
    bool get () sealed;
    void set (bool value) sealed;
}


IgnoreIncorrectSentenceCapitalization Property

IgnoreIncorrectSentenceCapitalization Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► IgnoreIncorrectSentenceCapitalization
Keyoti RapidSpell Silverlight
Whether to ignore incorrect sentence capitalization.
Declaration Syntax
C# Visual Basic Visual C++
public bool IgnoreIncorrectSentenceCapitalization { get; set; }
Public Property IgnoreIncorrectSentenceCapitalization As Boolean
public:
virtual property bool IgnoreIncorrectSentenceCapitalization {
    bool get () sealed;
    void set (bool value) sealed;
}


IgnoreInEnglishLowerCaseI Property

IgnoreInEnglishLowerCaseI Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► IgnoreInEnglishLowerCaseI
Keyoti RapidSpell Silverlight
Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
Declaration Syntax
C# Visual Basic Visual C++
public bool IgnoreInEnglishLowerCaseI { get; set; }
Public Property IgnoreInEnglishLowerCaseI As Boolean
public:
virtual property bool IgnoreInEnglishLowerCaseI {
    bool get () sealed;
    void set (bool value) sealed;
}


IgnoreWordsWithDigits Property

IgnoreWordsWithDigits Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► IgnoreWordsWithDigits
Keyoti RapidSpell Silverlight
Whether to ignore words with numbers in them (eg. A10 or 7-11).
Declaration Syntax
C# Visual Basic Visual C++
public bool IgnoreWordsWithDigits { get; set; }
Public Property IgnoreWordsWithDigits As Boolean
public:
virtual property bool IgnoreWordsWithDigits {
    bool get () sealed;
    void set (bool value) sealed;
}


IgnoreXML Property

IgnoreXML Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► IgnoreXML
Keyoti RapidSpell Silverlight
Whether to ignore XML/HTML tags, false by default.
Declaration Syntax
C# Visual Basic Visual C++
public bool IgnoreXML { get; set; }
Public Property IgnoreXML As Boolean
public:
virtual property bool IgnoreXML {
    bool get () sealed;
    void set (bool value) sealed;
}
Remarks
This identifies XML tags as anything in between < and > characters, there for it will cause undesirable effects in text such as "the sign for less than is < and the sign for greater than is >". Of course in HTML that should have been written as "the sign for less than is &lt; and the sign for greater than is &gt;" anyway, which would be fine.


IncludeUserDictionaryInSuggestions Property

IncludeUserDictionaryInSuggestions Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► IncludeUserDictionaryInSuggestions
Keyoti RapidSpell Silverlight
Whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeUserDictionaryInSuggestions { get; set; }
Public Property IncludeUserDictionaryInSuggestions As Boolean
public:
virtual property bool IncludeUserDictionaryInSuggestions {
    bool get () sealed;
    void set (bool value) sealed;
}


InDictionaryLabelText Property

InDictionaryLabelText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► InDictionaryLabelText
Keyoti RapidSpell Silverlight
In dictionary label text
Declaration Syntax
C# Visual Basic Visual C++
public string InDictionaryLabelText { get; set; }
Public Property InDictionaryLabelText As String
public:
virtual property String^ InDictionaryLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}


IsDisposed Property

IsDisposed Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► IsDisposed
Keyoti RapidSpell Silverlight
Whether the IDialogView is disposed of
Declaration Syntax
C# Visual Basic Visual C++
public bool IsDisposed { get; }
Public ReadOnly Property IsDisposed As Boolean
public:
property bool IsDisposed {
    bool get ();
}


IsShowFinishedMessageBox Method

IsShowFinishedMessageBox Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► IsShowFinishedMessageBox()()()
Keyoti RapidSpell Silverlight
Returns whether a message box should be opened when the spell check is complete.
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use ShowFinishedMessageBox instead.", true)]
public bool IsShowFinishedMessageBox()
<ObsoleteAttribute("Use ShowFinishedMessageBox instead.", True)> _
Public Function IsShowFinishedMessageBox As Boolean
[ObsoleteAttribute(L"Use ShowFinishedMessageBox instead.", true)]
public:
bool IsShowFinishedMessageBox()
Return Value
true if the message box should be opened, false otherwise.


LanguageParser Property

LanguageParser Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► LanguageParser
Keyoti RapidSpell Silverlight
The type of language parsing to use.
Declaration Syntax
C# Visual Basic Visual C++
public LanguageType LanguageParser { get; set; }
Public Property LanguageParser As LanguageType
public:
virtual property LanguageType LanguageParser {
    LanguageType get () sealed;
    void set (LanguageType value) sealed;
}
Remarks
Eg. If the dictionary is set to French, you should use the French parser.


Load Event

Load Event
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Load
Keyoti RapidSpell Silverlight
Fired when the DialogView loads.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler Load
Public Event Load As EventHandler
public:
virtual  event EventHandler^ Load {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


Location Property

Location Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Location
Keyoti RapidSpell Silverlight
Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Declaration Syntax
C# Visual Basic Visual C++
public Point Location { get; set; }
Public Property Location As Point
public:
property Point Location {
    Point get ();
    void set (Point value);
}


LookIntoHyphenatedText Property

LookIntoHyphenatedText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► LookIntoHyphenatedText
Keyoti RapidSpell Silverlight
Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
Declaration Syntax
C# Visual Basic Visual C++
public bool LookIntoHyphenatedText { get; set; }
Public Property LookIntoHyphenatedText As Boolean
public:
virtual property bool LookIntoHyphenatedText {
    bool get () sealed;
    void set (bool value) sealed;
}
Remarks
Eg. "socio-economic" will be checked as "socio" and "economic".


MakeChange Method

MakeChange Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► MakeChange()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | MakeChange()()() | Changes the current bad word for one selected from the suggestions list or entered in the query pane returns the word used.
 | MakeChange(Boolean) | Changes the current bad word for one selected from the suggestions list or entered in the query pane returns the word used.
 | MakeChange(Boolean, String, Boolean) | Changes the current bad word for one selected from the suggestions list or entered in the query pane returns the word used.


MakeChange Method

MakeChange Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► MakeChange()()()
Keyoti RapidSpell Silverlight
Changes the current bad word for one selected from the suggestions list or entered in the query pane returns the word used.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual string MakeChange()
Protected Overridable Function MakeChange As String
protected:
virtual String^ MakeChange()


MakeChange Method (inChangeAllProcess)

MakeChange Method (inChangeAllProcess)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► MakeChange(Boolean)
Keyoti RapidSpell Silverlight
Changes the current bad word for one selected from the suggestions list or entered in the query pane returns the word used.
Declaration Syntax
C# Visual Basic Visual C++
protected string MakeChange(
    bool inChangeAllProcess
)
Protected Function MakeChange ( _
    inChangeAllProcess As Boolean _
) As String
protected:
String^ MakeChange(
    bool inChangeAllProcess
)
Parameters
inChangeAllProcess (Boolean)
Remarks
inChangeAllProcess is true if this operation is part of a 'Change All'


MakeChange Method (inChangeAllProcess, newWord, removeDuplicate)

MakeChange Method (inChangeAllProcess, newWord, removeDuplicate)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► MakeChange(Boolean, String, Boolean)
Keyoti RapidSpell Silverlight
Changes the current bad word for one selected from the suggestions list or entered in the query pane returns the word used.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual string MakeChange(
    bool inChangeAllProcess,
    string newWord,
    bool removeDuplicate
)
Protected Overridable Function MakeChange ( _
    inChangeAllProcess As Boolean, _
    newWord As String, _
    removeDuplicate As Boolean _
) As String
protected:
virtual String^ MakeChange(
    bool inChangeAllProcess,
    String^ newWord,
    bool removeDuplicate
)
Parameters
inChangeAllProcess (Boolean)
newWord (String)
removeDuplicate (Boolean)
Remarks
inChangeAllProcess is true if this operation is part of a 'Change All'


MaximumContextualWords Property

MaximumContextualWords Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► MaximumContextualWords
Keyoti RapidSpell Silverlight
The maximum number of words to show the user in the sentence around misspelled words.
Declaration Syntax
C# Visual Basic Visual C++
public int MaximumContextualWords { get; set; }
Public Property MaximumContextualWords As Integer
public:
virtual property int MaximumContextualWords {
    int get () sealed;
    void set (int value) sealed;
}


ModalAutoDispose Property

ModalAutoDispose Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► ModalAutoDispose
Keyoti RapidSpell Silverlight
When running modally, determines if the dialog will be disposed of when spell check finishes.
Declaration Syntax
C# Visual Basic Visual C++
public bool ModalAutoDispose { get; set; }
Public Property ModalAutoDispose As Boolean
public:
virtual property bool ModalAutoDispose {
    bool get () sealed;
    void set (bool value) sealed;
}
Remarks
If a modal form disposes of itself, there will be slight flickering on the screen, to prevent this, set this property to false and call Dispose() when finished with this control.


ModalMode Property

ModalMode Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► ModalMode
Keyoti RapidSpell Silverlight
Whether the spell checker will run modally. (Modal operation blocks the parent form)
Declaration Syntax
C# Visual Basic Visual C++
public bool ModalMode { get; set; }
Public Property ModalMode As Boolean
public:
virtual property bool ModalMode {
    bool get () sealed;
    void set (bool value) sealed;
}


MoveCaretToWordEnd Method

MoveCaretToWordEnd Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► MoveCaretToWordEnd()()()
Keyoti RapidSpell Silverlight
Moves the caret to the end of the word the caret is in, or where it is if not on a word.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void MoveCaretToWordEnd()
Protected Overridable Sub MoveCaretToWordEnd
protected:
virtual void MoveCaretToWordEnd()


MoveCaretToWordStart Method

MoveCaretToWordStart Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► MoveCaretToWordStart()()()
Keyoti RapidSpell Silverlight
Moves the caret to the start of the word the caret is in, or where it is if not on a word.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void MoveCaretToWordStart()
Protected Overridable Sub MoveCaretToWordStart
protected:
virtual void MoveCaretToWordStart()


NoSuggestionsText Property

NoSuggestionsText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► NoSuggestionsText
Keyoti RapidSpell Silverlight
No suggestions found text
Declaration Syntax
C# Visual Basic Visual C++
public string NoSuggestionsText { get; set; }
Public Property NoSuggestionsText As String
public:
virtual property String^ NoSuggestionsText {
    String^ get () sealed;
    void set (String^ value) sealed;
}


NotInDictionaryLabelText Property

NotInDictionaryLabelText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► NotInDictionaryLabelText
Keyoti RapidSpell Silverlight
Not in dictionary label text
Declaration Syntax
C# Visual Basic Visual C++
public string NotInDictionaryLabelText { get; set; }
Public Property NotInDictionaryLabelText As String
public:
virtual property String^ NotInDictionaryLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}


NumberSuggestionList Property

NumberSuggestionList Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► NumberSuggestionList
Keyoti RapidSpell Silverlight
Whether to number the items in the suggestion list, for quick user selection.
Declaration Syntax
C# Visual Basic Visual C++
public bool NumberSuggestionList { get; set; }
Public Property NumberSuggestionList As Boolean
public:
virtual property bool NumberSuggestionList {
    bool get () sealed;
    void set (bool value) sealed;
}


OnCreateDialogView Method (e)

OnCreateDialogView Method (e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► OnCreateDialogView(CreateDialogViewEventArgs)
Keyoti RapidSpell Silverlight
Fires the CreateDialogView event.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void OnCreateDialogView(
    CreateDialogViewEventArgs e
)
Protected Overridable Sub OnCreateDialogView ( _
    e As CreateDialogViewEventArgs _
)
protected:
virtual void OnCreateDialogView(
    CreateDialogViewEventArgs^ e
)
Parameters
e (CreateDialogViewEventArgs)


OnSuggestionsDoubleClick Method (sender, e)

OnSuggestionsDoubleClick Method (sender, e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► OnSuggestionsDoubleClick(Object, EventArgs)
Keyoti RapidSpell Silverlight
Called when the user double clicks on a suggestion.
Declaration Syntax
C# Visual Basic Visual C++
protected void OnSuggestionsDoubleClick(
    Object sender,
    EventArgs e
)
Protected Sub OnSuggestionsDoubleClick ( _
    sender As Object, _
    e As EventArgs _
)
protected:
void OnSuggestionsDoubleClick(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


OnUndone Method (e)

OnUndone Method (e)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► OnUndone(UndoEventArgs)
Keyoti RapidSpell Silverlight
Raises the Undone event
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void OnUndone(
    UndoEventArgs e
)
Protected Overridable Sub OnUndone ( _
    e As UndoEventArgs _
)
protected:
virtual void OnUndone(
    UndoEventArgs^ e
)
Parameters
e (UndoEventArgs)


OnUserQuery Method (userQueryEventArgs)

OnUserQuery Method (userQueryEventArgs)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► OnUserQuery(UserQueryEventArgs)
Keyoti RapidSpell Silverlight
Fires the user query event
Declaration Syntax
C# Visual Basic Visual C++
protected void OnUserQuery(
    UserQueryEventArgs userQueryEventArgs
)
Protected Sub OnUserQuery ( _
    userQueryEventArgs As UserQueryEventArgs _
)
protected:
void OnUserQuery(
    UserQueryEventArgs^ userQueryEventArgs
)
Parameters
userQueryEventArgs (UserQueryEventArgs)


Options Property

Options Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Options
Keyoti RapidSpell Silverlight
Object responsible for holding, loading and saving the user's spell check options.
Declaration Syntax
C# Visual Basic Visual C++
public virtual UserOptions Options { get; set; }
Public Overridable Property Options As UserOptions
public:
virtual property UserOptions^ Options {
    UserOptions^ get ();
    void set (UserOptions^ value);
}
Remarks
To customize how the user's options are saved/loaded, subclass UserOptions and set an instance in this property.


OptionsButtonText Property

OptionsButtonText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► OptionsButtonText
Keyoti RapidSpell Silverlight
Options button text
Declaration Syntax
C# Visual Basic Visual C++
public string OptionsButtonText { get; set; }
Public Property OptionsButtonText As String
public:
virtual property String^ OptionsButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}


OptionsPresenter Property

OptionsPresenter Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► OptionsPresenter
Keyoti RapidSpell Silverlight
Presenter for the user options form (IDialogViewOptions).
Declaration Syntax
C# Visual Basic Visual C++
public virtual OptionsPresenter OptionsPresenter { get; set; }
Public Overridable Property OptionsPresenter As OptionsPresenter
public:
virtual property OptionsPresenter^ OptionsPresenter {
    OptionsPresenter^ get ();
    void set (OptionsPresenter^ value);
}
Remarks
Set properties in this instance to affect the options shown to the user, or handle CreateDialogViewOptions to create your own IDialogViewOptions form instance.


ProceedFromEnd Method

ProceedFromEnd Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► ProceedFromEnd()()()
Keyoti RapidSpell Silverlight
Decides what to do once reached end of required text check region
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void ProceedFromEnd()
Protected Overridable Sub ProceedFromEnd
protected:
virtual void ProceedFromEnd()


QueryTextBoxMultiline Property

QueryTextBoxMultiline Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► QueryTextBoxMultiline
Keyoti RapidSpell Silverlight
Whether 'not in dictionary' text box is multiline or single line.
Declaration Syntax
C# Visual Basic Visual C++
public bool QueryTextBoxMultiline { get; set; }
Public Property QueryTextBoxMultiline As Boolean
public:
property bool QueryTextBoxMultiline {
    bool get ();
    void set (bool value);
}


Ready Event

Ready Event
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Ready
Keyoti RapidSpell Silverlight
Fired when ready to proceed with first query.
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler Ready
Public Event Ready As EventHandler
public:
virtual  event EventHandler^ Ready {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


RecheckDocumentRequest Event

RecheckDocumentRequest Event
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► RecheckDocumentRequest
Keyoti RapidSpell Silverlight
Fired when document recheck is requested
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler RecheckDocumentRequest
Public Event RecheckDocumentRequest As EventHandler
public:
virtual  event EventHandler^ RecheckDocumentRequest {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


Remove Method

Remove Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Remove()()()
Keyoti RapidSpell Silverlight
Safely frees up resources.
Declaration Syntax
C# Visual Basic Visual C++
public void Remove()
Public Sub Remove
public:
virtual void Remove() sealed


RemoveDuplicateWordText Property

RemoveDuplicateWordText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► RemoveDuplicateWordText
Keyoti RapidSpell Silverlight
Remove duplicate word text
Declaration Syntax
C# Visual Basic Visual C++
public string RemoveDuplicateWordText { get; set; }
Public Property RemoveDuplicateWordText As String
public:
virtual property String^ RemoveDuplicateWordText {
    String^ get () sealed;
    void set (String^ value) sealed;
}


Resume Method

Resume Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Resume()()()
Keyoti RapidSpell Silverlight
Looks for next bad word
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void Resume()
Protected Overridable Sub Resume
protected:
virtual void Resume()
Return Value
void


ResumeButtonText Property

ResumeButtonText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► ResumeButtonText
Keyoti RapidSpell Silverlight
Resume button text
Declaration Syntax
C# Visual Basic Visual C++
public string ResumeButtonText { get; set; }
Public Property ResumeButtonText As String
public:
virtual property String^ ResumeButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}


SelectText Method (theBadWord)

SelectText Method (theBadWord)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SelectText(BadWord)
Keyoti RapidSpell Silverlight
Selects a bad word in the text component
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void SelectText(
    BadWord theBadWord
)
Protected Overridable Sub SelectText ( _
    theBadWord As BadWord _
)
protected:
virtual void SelectText(
    BadWord^ theBadWord
)
Parameters
theBadWord (BadWord)


SeparateHyphenWords Property

SeparateHyphenWords Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SeparateHyphenWords
Keyoti RapidSpell Silverlight
Sets whether to treat hyphenated (-) words as separate words, default is false.
Declaration Syntax
C# Visual Basic Visual C++
public bool SeparateHyphenWords { get; set; }
Public Property SeparateHyphenWords As Boolean
public:
virtual property bool SeparateHyphenWords {
    bool get () sealed;
    void set (bool value) sealed;
}
Remarks
For eg. if this is true text like "cheap-deals" will be treated as two words "cheap" and "deals", otherwise this will be treated as one word "cheap-deals".


SetConsiderationRange Method (w)

SetConsiderationRange Method (w)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetConsiderationRange(Int32)
Keyoti RapidSpell Silverlight
Sets the factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anything.
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use ConsiderationRange instead.", true)]
public void SetConsiderationRange(
    int w
)
<ObsoleteAttribute("Use ConsiderationRange instead.", True)> _
Public Sub SetConsiderationRange ( _
    w As Integer _
)
[ObsoleteAttribute(L"Use ConsiderationRange instead.", true)]
public:
void SetConsiderationRange(
    int w
)
Parameters
w (Int32)


SetDisposeAtEnd Method (v)

SetDisposeAtEnd Method (v)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetDisposeAtEnd(Boolean)
Keyoti RapidSpell Silverlight
Sets whether this will dispose of self at the end of the spell check.
Declaration Syntax
C# Visual Basic Visual C++
protected void SetDisposeAtEnd(
    bool v
)
Protected Sub SetDisposeAtEnd ( _
    v As Boolean _
)
protected:
void SetDisposeAtEnd(
    bool v
)
Parameters
v (Boolean)
Remarks
Use with caution.


SetFormCancelButton Method (b)

SetFormCancelButton Method (b)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetFormCancelButton(IButtonControl)
Keyoti RapidSpell Silverlight
Sets the Form.CancelButton property - this is for VB.NET users who are inheriting from this class.
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use DialogView to set this property instead.", true)]
protected void SetFormCancelButton(
    IButtonControl b
)
<ObsoleteAttribute("Use DialogView to set this property instead.", True)> _
Protected Sub SetFormCancelButton ( _
    b As IButtonControl _
)
[ObsoleteAttribute(L"Use DialogView to set this property instead.",
    true)]
protected:
void SetFormCancelButton(
    IButtonControl^ b
)
Parameters
b (IButtonControl)
Remarks
VB.NET users must use this to set Form.CancelButton, because VB.NET is case insensitive and this class has a cancelButton field.


SetIgnoreCapitalizedWords Method (v)

SetIgnoreCapitalizedWords Method (v)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetIgnoreCapitalizedWords(Boolean)
Keyoti RapidSpell Silverlight
Sets whether to ignore words with capital letters.
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use IgnoreCapitalizedWords instead.", true)]
public void SetIgnoreCapitalizedWords(
    bool v
)
<ObsoleteAttribute("Use IgnoreCapitalizedWords instead.", True)> _
Public Sub SetIgnoreCapitalizedWords ( _
    v As Boolean _
)
[ObsoleteAttribute(L"Use IgnoreCapitalizedWords instead.", true)]
public:
void SetIgnoreCapitalizedWords(
    bool v
)
Parameters
v (Boolean)


SetIgnoreOnceBadWords Method (ignoreOnceBadWords)

SetIgnoreOnceBadWords Method (ignoreOnceBadWords)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetIgnoreOnceBadWords(ArrayList)
Keyoti RapidSpell Silverlight
Provide a list of BadWord objects that have been ignored
Declaration Syntax
C# Visual Basic Visual C++
public void SetIgnoreOnceBadWords(
    ArrayList ignoreOnceBadWords
)
Public Sub SetIgnoreOnceBadWords ( _
    ignoreOnceBadWords As ArrayList _
)
public:
virtual void SetIgnoreOnceBadWords(
    ArrayList^ ignoreOnceBadWords
) sealed
Parameters
ignoreOnceBadWords (ArrayList)


SetIncludeUserDictionaryInSuggestions Method (v)

SetIncludeUserDictionaryInSuggestions Method (v)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetIncludeUserDictionaryInSuggestions(Boolean)
Keyoti RapidSpell Silverlight
Sets whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use IncludeUserDictionaryInSuggestions instead.",
    true)]
public void SetIncludeUserDictionaryInSuggestions(
    bool v
)
<ObsoleteAttribute("Use IncludeUserDictionaryInSuggestions instead.",  _
    True)> _
Public Sub SetIncludeUserDictionaryInSuggestions ( _
    v As Boolean _
)
[ObsoleteAttribute(L"Use IncludeUserDictionaryInSuggestions instead.",
    true)]
public:
void SetIncludeUserDictionaryInSuggestions(
    bool v
)
Parameters
v (Boolean)


SetSeparateHyphenWords Method (f)

SetSeparateHyphenWords Method (f)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetSeparateHyphenWords(Boolean)
Keyoti RapidSpell Silverlight
Sets whether to treat hyphenated (-) words as separate words, default is false.
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use SeparateHyphenWords instead.", true)]
public void SetSeparateHyphenWords(
    bool f
)
<ObsoleteAttribute("Use SeparateHyphenWords instead.", True)> _
Public Sub SetSeparateHyphenWords ( _
    f As Boolean _
)
[ObsoleteAttribute(L"Use SeparateHyphenWords instead.", true)]
public:
void SetSeparateHyphenWords(
    bool f
)
Parameters
f (Boolean)
Remarks
For eg. if this is true text like "cheap-deals" will be treated as two words "cheap" and "deals", otherwise this will be treated as one word "cheap-deals".


SetShowFinishedMessageBox Method (b)

SetShowFinishedMessageBox Method (b)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetShowFinishedMessageBox(Boolean)
Keyoti RapidSpell Silverlight
Sets whether a message box should be opened when the spell check is complete.
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use ShowFinishedMessageBox instead.", true)]
public void SetShowFinishedMessageBox(
    bool b
)
<ObsoleteAttribute("Use ShowFinishedMessageBox instead.", True)> _
Public Sub SetShowFinishedMessageBox ( _
    b As Boolean _
)
[ObsoleteAttribute(L"Use ShowFinishedMessageBox instead.", true)]
public:
void SetShowFinishedMessageBox(
    bool b
)
Parameters
b (Boolean)
boolean indicating if the message box should be opened.


SetSuggestionsMethod Method (method)

SetSuggestionsMethod Method (method)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetSuggestionsMethod(Int32)
Keyoti RapidSpell Silverlight
Sets the suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use SuggestionsMethod instead.", true)]
public void SetSuggestionsMethod(
    int method
)
<ObsoleteAttribute("Use SuggestionsMethod instead.", True)> _
Public Sub SetSuggestionsMethod ( _
    method As Integer _
)
[ObsoleteAttribute(L"Use SuggestionsMethod instead.", true)]
public:
void SetSuggestionsMethod(
    int method
)
Parameters
method (Int32)


SetTextComponentToCheck Method

SetTextComponentToCheck Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetTextComponentToCheck()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | SetTextComponentToCheck(TextBox) | Set the TextBox that this GUI will spell check.
 | SetTextComponentToCheck(ISpellCheckableTextComponent) | Sets the ISpellCheckableTextComponent that this GUI will spell check.
 | SetTextComponentToCheck(ISpellCheckableTextComponent2) | Sets the ISpellCheckableTextComponent2 that this GUI will spell check.


SetTextComponentToCheck Method (textComponent)

SetTextComponentToCheck Method (textComponent)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetTextComponentToCheck(ISpellCheckableTextComponent)
Keyoti RapidSpell Silverlight
Sets the ISpellCheckableTextComponent that this GUI will spell check.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetTextComponentToCheck(
    ISpellCheckableTextComponent textComponent
)
Public Overridable Sub SetTextComponentToCheck ( _
    textComponent As ISpellCheckableTextComponent _
)
public:
virtual void SetTextComponentToCheck(
    ISpellCheckableTextComponent^ textComponent
)
Parameters
textComponent (ISpellCheckableTextComponent)
the ISpellCheckableTextComponent that this will spell check.
Exceptions
Exception | Condition
ArgumentNullException | if textComponent parameter is null.


SetTextComponentToCheck Method (textComponent)

SetTextComponentToCheck Method (textComponent)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetTextComponentToCheck(ISpellCheckableTextComponent2)
Keyoti RapidSpell Silverlight
Sets the ISpellCheckableTextComponent2 that this GUI will spell check.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetTextComponentToCheck(
    ISpellCheckableTextComponent2 textComponent
)
Public Overridable Sub SetTextComponentToCheck ( _
    textComponent As ISpellCheckableTextComponent2 _
)
public:
virtual void SetTextComponentToCheck(
    ISpellCheckableTextComponent2^ textComponent
)
Parameters
textComponent (ISpellCheckableTextComponent2)
the ISpellCheckableTextComponent2 that this will spell check.
Exceptions
Exception | Condition
ArgumentNullException | if textComponent parameter is null.


SetTextComponentToCheck Method (textComponent)

SetTextComponentToCheck Method (textComponent)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetTextComponentToCheck(TextBox)
Keyoti RapidSpell Silverlight
Set the TextBox that this GUI will spell check.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetTextComponentToCheck(
    TextBox textComponent
)
Public Overridable Sub SetTextComponentToCheck ( _
    textComponent As TextBox _
)
public:
virtual void SetTextComponentToCheck(
    TextBox^ textComponent
)
Parameters
textComponent (TextBox)
Exceptions
Exception | Condition
ArgumentNullException | If textComponent parameter is null.


SetUITexts Method

SetUITexts Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetUITexts()()()
Keyoti RapidSpell Silverlight
Applies the UI texts to the IDialogView
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void SetUITexts()
Protected Overridable Sub SetUITexts
protected:
virtual void SetUITexts()


SetUserDictionary Method (userDictionary)

SetUserDictionary Method (userDictionary)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetUserDictionary(UserDictionary)
Keyoti RapidSpell Silverlight
Set the user dictionary object.
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use UserDictionary instead.", true)]
public void SetUserDictionary(
    UserDictionary userDictionary
)
<ObsoleteAttribute("Use UserDictionary instead.", True)> _
Public Sub SetUserDictionary ( _
    userDictionary As UserDictionary _
)
[ObsoleteAttribute(L"Use UserDictionary instead.", true)]
public:
void SetUserDictionary(
    UserDictionary^ userDictionary
)
Parameters
userDictionary (UserDictionary)
the UserDictionary to use as a user dictionary.
Remarks
Use of a user dictionary is optional.
Exceptions
Exception | Condition
ArgumentNullException | if userDictionary parameter is null.


SetUserDictionaryFile Method (userDictionaryFile)

SetUserDictionaryFile Method (userDictionaryFile)
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SetUserDictionaryFile(String)
Keyoti RapidSpell Silverlight
Set the user dictionary file, if this file doesn't exist it will be created.
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use UserDictionaryFile instead.", true)]
public void SetUserDictionaryFile(
    string userDictionaryFile
)
<ObsoleteAttribute("Use UserDictionaryFile instead.", True)> _
Public Sub SetUserDictionaryFile ( _
    userDictionaryFile As String _
)
[ObsoleteAttribute(L"Use UserDictionaryFile instead.", true)]
public:
void SetUserDictionaryFile(
    String^ userDictionaryFile
)
Parameters
userDictionaryFile (String)
the File to use as a user dictionary.
Remarks
Use of a user dictionary is optional.
Exceptions
Exception | Condition
ArgumentNullException | if userDictionaryFile parameter is null.


ShouldEnableAddButton Method

ShouldEnableAddButton Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► ShouldEnableAddButton()()()
Keyoti RapidSpell Silverlight
Determines if the Add button should be enabled
Declaration Syntax
C# Visual Basic Visual C++
protected virtual bool ShouldEnableAddButton()
Protected Overridable Function ShouldEnableAddButton As Boolean
protected:
virtual bool ShouldEnableAddButton()
Return Value


ShowContextSentence Property

ShowContextSentence Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► ShowContextSentence
Keyoti RapidSpell Silverlight
Whether to show the query in context of it's sentence/line.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowContextSentence { get; set; }
Public Property ShowContextSentence As Boolean
public:
virtual property bool ShowContextSentence {
    bool get () sealed;
    void set (bool value) sealed;
}


ShowFinishedMessageBox Property

ShowFinishedMessageBox Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► ShowFinishedMessageBox
Keyoti RapidSpell Silverlight
Whether a message box should be opened when the spell check is complete.
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowFinishedMessageBox { get; set; }
Public Property ShowFinishedMessageBox As Boolean
public:
virtual property bool ShowFinishedMessageBox {
    bool get () sealed;
    void set (bool value) sealed;
}


showMessageBoxAtEnd Field

showMessageBoxAtEnd Field
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► showMessageBoxAtEnd
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
protected bool showMessageBoxAtEnd
Protected showMessageBoxAtEnd As Boolean
protected:
bool showMessageBoxAtEnd


SpellCheckFinished Event

SpellCheckFinished Event
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SpellCheckFinished
Keyoti RapidSpell Silverlight
Fired when checking finishes
Declaration Syntax
C# Visual Basic Visual C++
public event RapidSpellGUIPresenter..::.SpellCheckEventHandler SpellCheckFinished
Public Event SpellCheckFinished As RapidSpellGUIPresenter..::.SpellCheckEventHandler
public:
virtual  event RapidSpellGUIPresenter..::.SpellCheckEventHandler^ SpellCheckFinished {
    void add (RapidSpellGUIPresenter..::.SpellCheckEventHandler^ value);
    void remove (RapidSpellGUIPresenter..::.SpellCheckEventHandler^ value);
}


SpellCheckStarted Event

SpellCheckStarted Event
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SpellCheckStarted
Keyoti RapidSpell Silverlight
Fired when checking starts
Declaration Syntax
C# Visual Basic Visual C++
public event RapidSpellGUIPresenter..::.SpellCheckEventHandler SpellCheckStarted
Public Event SpellCheckStarted As RapidSpellGUIPresenter..::.SpellCheckEventHandler
public:
virtual  event RapidSpellGUIPresenter..::.SpellCheckEventHandler^ SpellCheckStarted {
    void add (RapidSpellGUIPresenter..::.SpellCheckEventHandler^ value);
    void remove (RapidSpellGUIPresenter..::.SpellCheckEventHandler^ value);
}


subFromPosition Field

subFromPosition Field
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► subFromPosition
Keyoti RapidSpell Silverlight
To check from and to positions that are wrapped, need to do in 2 steps check from subFromPosition ( = fromPosition) -> subToPosition (= doc end) and then check from subFromPosition (= 0) -> subToPosition (= toPosition)
Declaration Syntax
C# Visual Basic Visual C++
protected int subFromPosition
Protected subFromPosition As Integer
protected:
int subFromPosition


subToPosition Field

subToPosition Field
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► subToPosition
Keyoti RapidSpell Silverlight
To check from and to positions that are wrapped, need to do in 2 steps check from subFromPosition ( = fromPosition) -> subToPosition (= doc end) and then check from subFromPosition (= 0) -> subToPosition (= toPosition)
Declaration Syntax
C# Visual Basic Visual C++
protected int subToPosition
Protected subToPosition As Integer
protected:
int subToPosition


SuggestionsKeyboardText Property

SuggestionsKeyboardText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SuggestionsKeyboardText
Keyoti RapidSpell Silverlight
Suggestions label text when in keyboard mode
Declaration Syntax
C# Visual Basic Visual C++
public string SuggestionsKeyboardText { get; set; }
Public Property SuggestionsKeyboardText As String
public:
property String^ SuggestionsKeyboardText {
    String^ get ();
    void set (String^ value);
}


SuggestionsLabelText Property

SuggestionsLabelText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SuggestionsLabelText
Keyoti RapidSpell Silverlight
Suggestions label text
Declaration Syntax
C# Visual Basic Visual C++
public string SuggestionsLabelText { get; set; }
Public Property SuggestionsLabelText As String
public:
virtual property String^ SuggestionsLabelText {
    String^ get () sealed;
    void set (String^ value) sealed;
}


SuggestionsMethod Property

SuggestionsMethod Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SuggestionsMethod
Keyoti RapidSpell Silverlight
The suggestions method to use.
Declaration Syntax
C# Visual Basic Visual C++
public SuggestionsMethodType SuggestionsMethod { get; set; }
Public Property SuggestionsMethod As SuggestionsMethodType
public:
virtual property SuggestionsMethodType SuggestionsMethod {
    SuggestionsMethodType get () sealed;
    void set (SuggestionsMethodType value) sealed;
}


SuggestSplitWords Property

SuggestSplitWords Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► SuggestSplitWords
Keyoti RapidSpell Silverlight
Whether to look for connected words in suggestions.
Declaration Syntax
C# Visual Basic Visual C++
public bool SuggestSplitWords { get; set; }
Public Property SuggestSplitWords As Boolean
public:
virtual property bool SuggestSplitWords {
    bool get () sealed;
    void set (bool value) sealed;
}
Remarks
if this=true then suggestions may include joined words.

Eg; suggestions for "myhouse" will include "my house"


TextBoundary Property

TextBoundary Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► TextBoundary
Keyoti RapidSpell Silverlight
The AdvancedTextBoundary class to use to parse words.
Declaration Syntax
C# Visual Basic Visual C++
public AdvancedTextBoundary TextBoundary { get; set; }
Public Property TextBoundary As AdvancedTextBoundary
public:
property AdvancedTextBoundary^ TextBoundary {
    AdvancedTextBoundary^ get ();
    void set (AdvancedTextBoundary^ value);
}


TextBox Property

TextBox Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► TextBox
Keyoti RapidSpell Silverlight
The text box instance that this is working with, the actual type depends on whether the TextBoxBaseToCheck property or ThirdPartyTextComponentToCheck property was set.
Declaration Syntax
C# Visual Basic Visual C++
public Object TextBox { get; }
Public ReadOnly Property TextBox As Object
public:
property Object^ TextBox {
    Object^ get ();
}


theBadWord Field

theBadWord Field
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► theBadWord
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
protected BadWord theBadWord
Protected theBadWord As BadWord
protected:
BadWord^ theBadWord


theSpellChecker Field

theSpellChecker Field
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► theSpellChecker
Keyoti RapidSpell Silverlight
The spell checker component being used
Declaration Syntax
C# Visual Basic Visual C++
protected ICheckerEngine theSpellChecker
Protected theSpellChecker As ICheckerEngine
protected:
ICheckerEngine^ theSpellChecker


theTextComponent Field

theTextComponent Field
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► theTextComponent
Keyoti RapidSpell Silverlight
The text component being checked
Declaration Syntax
C# Visual Basic Visual C++
protected ISpellCheckableTextComponent2 theTextComponent
Protected theTextComponent As ISpellCheckableTextComponent2
protected:
ISpellCheckableTextComponent2^ theTextComponent


toPosition Field

toPosition Field
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► toPosition
Keyoti RapidSpell Silverlight
Where the user wants to check to
Declaration Syntax
C# Visual Basic Visual C++
protected int toPosition
Protected toPosition As Integer
protected:
int toPosition


Undo Method

Undo Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Undo()()()
Keyoti RapidSpell Silverlight
Undoes the previous user operation.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Undo()
Public Overridable Sub Undo
public:
virtual void Undo()


UndoButtonText Property

UndoButtonText Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► UndoButtonText
Keyoti RapidSpell Silverlight
Undo button text
Declaration Syntax
C# Visual Basic Visual C++
public string UndoButtonText { get; set; }
Public Property UndoButtonText As String
public:
virtual property String^ UndoButtonText {
    String^ get () sealed;
    void set (String^ value) sealed;
}


Undone Event

Undone Event
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Undone
Keyoti RapidSpell Silverlight
Fired when an Undo occurs
Declaration Syntax
C# Visual Basic Visual C++
public event UndoEventHandler Undone
Public Event Undone As UndoEventHandler
public:
virtual  event UndoEventHandler^ Undone {
    void add (UndoEventHandler^ value);
    void remove (UndoEventHandler^ value);
}


UserDictionary Property

UserDictionary Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► UserDictionary
Keyoti RapidSpell Silverlight
Set the user dictionary object.
Declaration Syntax
C# Visual Basic Visual C++
public UserDictionary UserDictionary { get; set; }
Public Property UserDictionary As UserDictionary
public:
virtual property UserDictionary^ UserDictionary {
    UserDictionary^ get () sealed;
    void set (UserDictionary^ value) sealed;
}
Remarks
Use of a user dictionary is optional.


UserDictionaryFile Property

UserDictionaryFile Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► UserDictionaryFile
Keyoti RapidSpell Silverlight
Set the user dictionary file, if this file doesn't exist it will be created.
Declaration Syntax
C# Visual Basic Visual C++
public string UserDictionaryFile { set; }
Public WriteOnly Property UserDictionaryFile As String
public:
virtual property String^ UserDictionaryFile {
    void set (String^ value) sealed;
}
Remarks
Use of a user dictionary is optional.


UserQuery Event

UserQuery Event
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► UserQuery
Keyoti RapidSpell Silverlight
Indicates that the user is being queried on a spelling error.
Declaration Syntax
C# Visual Basic Visual C++
public event UserQueryEventHandler UserQuery
Public Event UserQuery As UserQueryEventHandler
public:
virtual  event UserQueryEventHandler^ UserQuery {
    void add (UserQueryEventHandler^ value);
    void remove (UserQueryEventHandler^ value);
}


WarnDuplicates Property

WarnDuplicates Property
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► WarnDuplicates
Keyoti RapidSpell Silverlight
Whether to show duplicate words as errors (eg. "this is is an error").
Declaration Syntax
C# Visual Basic Visual C++
public bool WarnDuplicates { get; set; }
Public Property WarnDuplicates As Boolean
public:
virtual property bool WarnDuplicates {
    bool get () sealed;
    void set (bool value) sealed;
}


WordAdded Event

WordAdded Event
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► WordAdded
Keyoti RapidSpell Silverlight
Fired when word added to user dictionary
Declaration Syntax
C# Visual Basic Visual C++
public event WordAddedEventHandler WordAdded
Public Event WordAdded As WordAddedEventHandler
public:
virtual  event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}


WordChanged Event

WordChanged Event
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► WordChanged
Keyoti RapidSpell Silverlight
Fired when word changed
Declaration Syntax
C# Visual Basic Visual C++
public event WordChangedEventHandler WordChanged
Public Event WordChanged As WordChangedEventHandler
public:
virtual  event WordChangedEventHandler^ WordChanged {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}


WordChanging Event

WordChanging Event
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► WordChanging
Keyoti RapidSpell Silverlight
Fired before a word is changed
Declaration Syntax
C# Visual Basic Visual C++
public event WordChangedEventHandler WordChanging
Public Event WordChanging As WordChangedEventHandler
public:
virtual  event WordChangedEventHandler^ WordChanging {
    void add (WordChangedEventHandler^ value);
    void remove (WordChangedEventHandler^ value);
}


WordIgnored Event

WordIgnored Event
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► WordIgnored
Keyoti RapidSpell Silverlight
Fired when word ignored
Declaration Syntax
C# Visual Basic Visual C++
public event WordIgnoredEventHandler WordIgnored
Public Event WordIgnored As WordIgnoredEventHandler
public:
virtual  event WordIgnoredEventHandler^ WordIgnored {
    void add (WordIgnoredEventHandler^ value);
    void remove (WordIgnoredEventHandler^ value);
}


Wrap Method

Wrap Method
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► Wrap()()()
Keyoti RapidSpell Silverlight
Wraps the checker to start at beginning of doc
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void Wrap()
Protected Overridable Sub Wrap
protected:
virtual void Wrap()


wrapped Field

wrapped Field
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► wrapped
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
protected bool wrapped
Protected wrapped As Boolean
protected:
bool wrapped


RapidSpellGUIPresenter.SpellCheckEventHandler Delegate

RapidSpellGUIPresenter..::.SpellCheckEventHandler Delegate
API ► Keyoti.RapidSpell ► RapidSpellGUIPresenter ► RapidSpellGUIPresenter..::.SpellCheckEventHandler
Keyoti RapidSpell Silverlight
Spell check event handler delegate.
Declaration Syntax
C# Visual Basic Visual C++
public delegate void SpellCheckEventHandler(
    Object sender,
    SpellCheckEventArgs e
)
Public Delegate Sub SpellCheckEventHandler ( _
    sender As Object, _
    e As SpellCheckEventArgs _
)
public delegate void SpellCheckEventHandler(
    Object^ sender,
    SpellCheckEventArgs^ e
)
Parameters
sender (Object)
e (SpellCheckEventArgs)


SpellingDictionary Class

SpellingDictionary Class
API ► Keyoti.RapidSpell ► SpellingDictionary
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public class SpellingDictionary
Public Class SpellingDictionary
public ref class SpellingDictionary
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Path |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SpellingDictionary


Path Property

Path Property
API ► Keyoti.RapidSpell ► SpellingDictionary ► Path
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public string Path { get; }
Public ReadOnly Property Path As String
public:
property String^ Path {
    String^ get ();
}


Suggestion Class

Suggestion Class
API ► Keyoti.RapidSpell ► Suggestion
Keyoti RapidSpell Silverlight
Represents a suggestion.
Declaration Syntax
C# Visual Basic Visual C++
public class Suggestion
Public Class Suggestion
public ref class Suggestion
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Suggestion(String, Int32) | Creates an instance
 | Contains(ArrayList, Suggestion) | Returns true if suggestion is in list.
 | Contains(ArrayList, String) | Returns true if suggestion is in list.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Score | The score 0-1000 of how suitable suggestion is. -1 if unknown
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Word | The suggested word.
Inheritance Hierarchy
Object
Suggestion


Suggestion Constructor (word, score)

Suggestion Constructor (word, score)
API ► Keyoti.RapidSpell ► Suggestion ► Suggestion(String, Int32)
Keyoti RapidSpell Silverlight
Creates an instance
Declaration Syntax
C# Visual Basic Visual C++
public Suggestion(
    string word,
    int score
)
Public Sub New ( _
    word As String, _
    score As Integer _
)
public:
Suggestion(
    String^ word,
    int score
)
Parameters
word (String)
The suggested word
score (Int32)
The score 0-1000 of how suitable suggestion is.


Contains Method

Contains Method
API ► Keyoti.RapidSpell ► Suggestion ► Contains()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | Contains(ArrayList, Suggestion) | Returns true if suggestion is in list.
 | Contains(ArrayList, String) | Returns true if suggestion is in list.


Contains Method (list, suggestion)

Contains Method (list, suggestion)
API ► Keyoti.RapidSpell ► Suggestion ► Contains(ArrayList, Suggestion)
Keyoti RapidSpell Silverlight
Returns true if suggestion is in list.
Declaration Syntax
C# Visual Basic Visual C++
public static bool Contains(
    ArrayList list,
    Suggestion suggestion
)
Public Shared Function Contains ( _
    list As ArrayList, _
    suggestion As Suggestion _
) As Boolean
public:
static bool Contains(
    ArrayList^ list,
    Suggestion^ suggestion
)
Parameters
list (ArrayList)
suggestion (Suggestion)


Contains Method (list, suggestion)

Contains Method (list, suggestion)
API ► Keyoti.RapidSpell ► Suggestion ► Contains(ArrayList, String)
Keyoti RapidSpell Silverlight
Returns true if suggestion is in list.
Declaration Syntax
C# Visual Basic Visual C++
public static bool Contains(
    ArrayList list,
    string suggestion
)
Public Shared Function Contains ( _
    list As ArrayList, _
    suggestion As String _
) As Boolean
public:
static bool Contains(
    ArrayList^ list,
    String^ suggestion
)
Parameters
list (ArrayList)
suggestion (String)


Score Property

Score Property
API ► Keyoti.RapidSpell ► Suggestion ► Score
Keyoti RapidSpell Silverlight
The score 0-1000 of how suitable suggestion is. -1 if unknown
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Score { get; set; }
Public Overridable Property Score As Integer
public:
virtual property int Score {
    int get ();
    void set (int value);
}


Word Property

Word Property
API ► Keyoti.RapidSpell ► Suggestion ► Word
Keyoti RapidSpell Silverlight
The suggested word.
Declaration Syntax
C# Visual Basic Visual C++
public virtual string Word { get; set; }
Public Overridable Property Word As String
public:
virtual property String^ Word {
    String^ get ();
    void set (String^ value);
}


SuggestionsMethodType Enumeration

SuggestionsMethodType Enumeration
API ► Keyoti.RapidSpell ► SuggestionsMethodType
Keyoti RapidSpell Silverlight
Suggestions algorithm identifiers.
Declaration Syntax
C# Visual Basic Visual C++
public enum SuggestionsMethodType
Public Enumeration SuggestionsMethodType
public enum class SuggestionsMethodType
Members
Member | Description
PhoneticSuggestions | Phonetic (sounds like) algorithm
HashingSuggestions | Hashing (closest match) algorithm


TextBoxEx Class

TextBoxEx Class
API ► Keyoti.RapidSpell ► TextBoxEx
Keyoti RapidSpell Silverlight
TextBox subclass which supports visible selection when focus elsewhere.
Declaration Syntax
C# Visual Basic Visual C++
public class TextBoxEx : TextBox
Public Class TextBoxEx _
    Inherits TextBox
public ref class TextBoxEx : public TextBox
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TextBoxEx()()() | New
 | AcceptsReturn()()() | (Inherited from TextBox.)
 | ActualHeight | (Inherited from FrameworkElement.)
 | ActualWidth | (Inherited from FrameworkElement.)
 | AddHandler(RoutedEvent, Delegate, Boolean) | (Inherited from UIElement.)
 | AllowDrop | (Inherited from UIElement.)
 | ApplyTemplate()()() | (Inherited from Control.)
 | Arrange(Rect) | (Inherited from UIElement.)
 | ArrangeOverride(Size) | (Inherited from FrameworkElement.)
 | Background | (Inherited from Control.)
 | BaselineOffset()()() | (Inherited from TextBox.)
 | BindingValidationError()()() | (Inherited from FrameworkElement.)
 | BorderBrush | (Inherited from Control.)
 | BorderThickness | (Inherited from Control.)
 | CacheMode()()() | (Inherited from UIElement.)
 | CaptureMouse()()() | (Inherited from UIElement.)
 | CaretBrush()()() | (Inherited from TextBox.)
 | CheckAccess()()() | (Inherited from DependencyObject.)
 | ClearValue(DependencyProperty) | (Inherited from DependencyObject.)
 | Clip | (Inherited from UIElement.)
 | Cursor | (Inherited from FrameworkElement.)
 | DataContext | (Inherited from FrameworkElement.)
 | DefaultStyleKey()()() | (Inherited from Control.)
 | DesiredSize | (Inherited from UIElement.)
 | Dispatcher()()() | (Inherited from DependencyObject.)
 | DragEnter | (Inherited from UIElement.)
 | DragLeave | (Inherited from UIElement.)
 | DragOver | (Inherited from UIElement.)
 | Drop | (Inherited from UIElement.)
 | Effect()()() | (Inherited from UIElement.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | (Overrides Object.Finalize()()().)
 | FindName(String) | (Inherited from FrameworkElement.)
 | FlowDirection | (Inherited from FrameworkElement.)
 | Focus()()() | (Inherited from Control.)
 | FontFamily | (Inherited from Control.)
 | FontSize | (Inherited from Control.)
 | FontSource()()() | (Inherited from TextBox.)
 | FontStretch | (Inherited from Control.)
 | FontStyle | (Inherited from Control.)
 | FontWeight | (Inherited from Control.)
 | Foreground | (Inherited from Control.)
 | GetAnimationBaseValue(DependencyProperty) | (Inherited from DependencyObject.)
 | GetBindingExpression(DependencyProperty) | (Inherited from FrameworkElement.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRectFromCharacterIndex(Int32) | (Inherited from TextBox.)
 | GetRectFromCharacterIndex(Int32, Boolean) | (Inherited from TextBox.)
 | GetTemplateChild(String) | (Inherited from Control.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(DependencyProperty) | (Inherited from DependencyObject.)
 | GotFocus | (Inherited from UIElement.)
 | Height | (Inherited from FrameworkElement.)
 | HideSelection | Whether to hide the selection when the user is focussed elsewhere.
 | HorizontalAlignment | (Inherited from FrameworkElement.)
 | HorizontalContentAlignment | (Inherited from Control.)
 | HorizontalScrollBarVisibility()()() | (Inherited from TextBox.)
 | InputScope()()() | (Inherited from TextBox.)
 | InvalidateArrange()()() | (Inherited from UIElement.)
 | InvalidateMeasure()()() | (Inherited from UIElement.)
 | IsEnabled()()() | (Inherited from Control.)
 | IsEnabledChanged()()() | (Inherited from Control.)
 | IsHitTestVisible | (Inherited from UIElement.)
 | IsReadOnly()()() | (Inherited from TextBox.)
 | IsTabStop | (Inherited from Control.)
 | KeyDown | (Inherited from UIElement.)
 | KeyUp | (Inherited from UIElement.)
 | Language | (Inherited from FrameworkElement.)
 | LayoutUpdated()()() | (Inherited from FrameworkElement.)
 | Loaded | (Inherited from FrameworkElement.)
 | LostFocus | (Inherited from UIElement.)
 | LostMouseCapture | (Inherited from UIElement.)
 | ManipulationCompleted()()() | (Inherited from UIElement.)
 | ManipulationDelta()()() | (Inherited from UIElement.)
 | ManipulationStarted()()() | (Inherited from UIElement.)
 | Margin | (Inherited from FrameworkElement.)
 | MaxHeight | (Inherited from FrameworkElement.)
 | MaxLength | (Inherited from TextBox.)
 | MaxWidth | (Inherited from FrameworkElement.)
 | Measure(Size) | (Inherited from UIElement.)
 | MeasureOverride(Size) | (Inherited from FrameworkElement.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinHeight | (Inherited from FrameworkElement.)
 | MinWidth | (Inherited from FrameworkElement.)
 | MouseEnter | (Inherited from UIElement.)
 | MouseLeave | (Inherited from UIElement.)
 | MouseLeftButtonDown | (Inherited from UIElement.)
 | MouseLeftButtonUp | (Inherited from UIElement.)
 | MouseMove | (Inherited from UIElement.)
 | MouseRightButtonDown | (Inherited from UIElement.)
 | MouseRightButtonUp | (Inherited from UIElement.)
 | MouseWheel | (Inherited from UIElement.)
 | Name | (Inherited from FrameworkElement.)
 | OnApplyTemplate()()() | (Inherited from FrameworkElement.)
 | OnCreateAutomationPeer()()() | (Inherited from TextBox.)
 | OnDragEnter(DragEventArgs) | (Inherited from Control.)
 | OnDragLeave(DragEventArgs) | (Inherited from Control.)
 | OnDragOver(DragEventArgs) | (Inherited from Control.)
 | OnDrop(DragEventArgs) | (Inherited from Control.)
 | OnGotFocus(RoutedEventArgs) | (Inherited from TextBox.)
 | OnKeyDown(KeyEventArgs) | (Inherited from TextBox.)
 | OnKeyUp(KeyEventArgs) | (Inherited from TextBox.)
 | OnLostFocus(RoutedEventArgs) | (Overrides TextBox.OnLostFocus(RoutedEventArgs).)
 | OnLostMouseCapture(MouseEventArgs) | (Inherited from TextBox.)
 | OnManipulationCompleted(ManipulationCompletedEventArgs) | (Inherited from Control.)
 | OnManipulationDelta(ManipulationDeltaEventArgs) | (Inherited from Control.)
 | OnManipulationStarted(ManipulationStartedEventArgs) | (Inherited from Control.)
 | OnMouseEnter(MouseEventArgs) | (Inherited from TextBox.)
 | OnMouseLeave(MouseEventArgs) | (Inherited from TextBox.)
 | OnMouseLeftButtonDown(MouseButtonEventArgs) | (Inherited from TextBox.)
 | OnMouseLeftButtonUp(MouseButtonEventArgs) | (Inherited from TextBox.)
 | OnMouseMove(MouseEventArgs) | (Inherited from TextBox.)
 | OnMouseRightButtonDown(MouseButtonEventArgs) | (Inherited from Control.)
 | OnMouseRightButtonUp(MouseButtonEventArgs) | (Inherited from Control.)
 | OnMouseWheel(MouseWheelEventArgs) | (Inherited from Control.)
 | OnTextInput(TextCompositionEventArgs) | (Inherited from TextBox.)
 | OnTextInputStart(TextCompositionEventArgs) | (Inherited from TextBox.)
 | OnTextInputUpdate(TextCompositionEventArgs) | (Inherited from TextBox.)
 | Opacity | (Inherited from UIElement.)
 | OpacityMask | (Inherited from UIElement.)
 | Padding | (Inherited from Control.)
 | Parent | (Inherited from FrameworkElement.)
 | Projection()()() | (Inherited from UIElement.)
 | ReadLocalValue(DependencyProperty) | (Inherited from DependencyObject.)
 | ReleaseMouseCapture()()() | (Inherited from UIElement.)
 | RemoveHandler(RoutedEvent, Delegate) | (Inherited from UIElement.)
 | RenderSize | (Inherited from UIElement.)
 | RenderTransform | (Inherited from UIElement.)
 | RenderTransformOrigin | (Inherited from UIElement.)
 | Resources | (Inherited from FrameworkElement.)
 | Select(Int32, Int32) | (Inherited from TextBox.)
 | SelectAll()()() | (Inherited from TextBox.)
 | SelectedText | (Inherited from TextBox.)
 | SelectionBackground()()() | (Inherited from TextBox.)
 | SelectionChanged()()() | (Inherited from TextBox.)
 | SelectionForeground()()() | (Inherited from TextBox.)
 | SelectionLength | (Inherited from TextBox.)
 | SelectionStart | (Inherited from TextBox.)
 | SetBinding(DependencyProperty, Binding) | (Inherited from FrameworkElement.)
 | SetValue(DependencyProperty, Object) | (Inherited from DependencyObject.)
 | SizeChanged | (Inherited from FrameworkElement.)
 | Style | (Inherited from FrameworkElement.)
 | TabIndex | (Inherited from Control.)
 | TabNavigation()()() | (Inherited from Control.)
 | Tag | (Inherited from FrameworkElement.)
 | Template | (Inherited from Control.)
 | Text | (Inherited from TextBox.)
 | TextAlignment | (Inherited from TextBox.)
 | TextChanged()()() | (Inherited from TextBox.)
 | TextInput | (Inherited from UIElement.)
 | TextInputStart()()() | (Inherited from UIElement.)
 | TextInputUpdate()()() | (Inherited from UIElement.)
 | TextWrapping | (Inherited from TextBox.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TransformToVisual(UIElement) | (Inherited from UIElement.)
 | Triggers | (Inherited from FrameworkElement.)
 | Unloaded | (Inherited from FrameworkElement.)
 | UpdateLayout()()() | (Inherited from UIElement.)
 | UseLayoutRounding()()() | (Inherited from UIElement.)
 | VerticalAlignment | (Inherited from FrameworkElement.)
 | VerticalContentAlignment | (Inherited from Control.)
 | VerticalScrollBarVisibility()()() | (Inherited from TextBox.)
 | Visibility | (Inherited from UIElement.)
 | Watermark()()() | (Inherited from TextBox.)
 | Width | (Inherited from FrameworkElement.)
Inheritance Hierarchy
Object
 | DependencyObject
 |  | UIElement
 |  |  | FrameworkElement
 |  |  |  | Control
 |  |  |  |  | TextBox
 |  |  |  |  |  | TextBoxEx


TextBoxEx Constructor

TextBoxEx Constructor
API ► Keyoti.RapidSpell ► TextBoxEx ► TextBoxEx()()()
Keyoti RapidSpell Silverlight
New
Declaration Syntax
C# Visual Basic Visual C++
public TextBoxEx()
Public Sub New
public:
TextBoxEx()


Finalize Method

Finalize Method
API ► Keyoti.RapidSpell ► TextBoxEx ► Finalize()()()
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
protected override void Finalize()
Protected Overrides Sub Finalize
protected:
virtual void Finalize() override


HideSelection Property

HideSelection Property
API ► Keyoti.RapidSpell ► TextBoxEx ► HideSelection
Keyoti RapidSpell Silverlight
Whether to hide the selection when the user is focussed elsewhere.
Declaration Syntax
C# Visual Basic Visual C++
public bool HideSelection { get; set; }
Public Property HideSelection As Boolean
public:
property bool HideSelection {
    bool get ();
    void set (bool value);
}


OnLostFocus Method (e)

OnLostFocus Method (e)
API ► Keyoti.RapidSpell ► TextBoxEx ► OnLostFocus(RoutedEventArgs)
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
protected override void OnLostFocus(
    RoutedEventArgs e
)
Protected Overrides Sub OnLostFocus ( _
    e As RoutedEventArgs _
)
protected:
virtual void OnLostFocus(
    RoutedEventArgs^ e
) override
Parameters
e (RoutedEventArgs)


UndoableOperation Class

UndoableOperation Class
API ► Keyoti.RapidSpell ► UndoableOperation
Keyoti RapidSpell Silverlight
An operation which can be undone
Declaration Syntax
C# Visual Basic Visual C++
public class UndoableOperation
Public Class UndoableOperation
public ref class UndoableOperation
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UndoableOperation(UndoableOperation..::.Operation, UndoableStateEventArgs) | Constructor
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperationType | The operation type
 | SourceEvent | The event which indicated the operation occurred.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
UndoableOperation


UndoableOperation Constructor (operationType, sourceEvent)

UndoableOperation Constructor (operationType, sourceEvent)
API ► Keyoti.RapidSpell ► UndoableOperation ► UndoableOperation(UndoableOperation..::.Operation, UndoableStateEventArgs)
Keyoti RapidSpell Silverlight
Constructor
Declaration Syntax
C# Visual Basic Visual C++
public UndoableOperation(
    UndoableOperation..::.Operation operationType,
    UndoableStateEventArgs sourceEvent
)
Public Sub New ( _
    operationType As UndoableOperation..::.Operation, _
    sourceEvent As UndoableStateEventArgs _
)
public:
UndoableOperation(
    UndoableOperation..::.Operation operationType,
    UndoableStateEventArgs^ sourceEvent
)
Parameters
operationType (UndoableOperation..::.Operation)
sourceEvent (UndoableStateEventArgs)


OperationType Property

OperationType Property
API ► Keyoti.RapidSpell ► UndoableOperation ► OperationType
Keyoti RapidSpell Silverlight
The operation type
Declaration Syntax
C# Visual Basic Visual C++
public UndoableOperation..::.Operation OperationType { get; }
Public ReadOnly Property OperationType As UndoableOperation..::.Operation
public:
property UndoableOperation..::.Operation OperationType {
    UndoableOperation..::.Operation get ();
}


SourceEvent Property

SourceEvent Property
API ► Keyoti.RapidSpell ► UndoableOperation ► SourceEvent
Keyoti RapidSpell Silverlight
The event which indicated the operation occurred.
Declaration Syntax
C# Visual Basic Visual C++
public UndoableStateEventArgs SourceEvent { get; }
Public ReadOnly Property SourceEvent As UndoableStateEventArgs
public:
property UndoableStateEventArgs^ SourceEvent {
    UndoableStateEventArgs^ get ();
}


UndoableOperation.Operation Enumeration

UndoableOperation..::.Operation Enumeration
API ► Keyoti.RapidSpell ► UndoableOperation ► UndoableOperation..::.Operation
Keyoti RapidSpell Silverlight
Types of operation
Declaration Syntax
C# Visual Basic Visual C++
public enum Operation
Public Enumeration Operation
public enum class Operation
Members
Member | Description
Ignore | Ignore
IgnoreAll | Ignore all
Change | Change
ChangeAll | Change all
Add | Add


UndoableStateEventArgs Class

UndoableStateEventArgs Class
API ► Keyoti.RapidSpell ► UndoableStateEventArgs
Keyoti RapidSpell Silverlight
Args for the events fired when words are ignored.
Declaration Syntax
C# Visual Basic Visual C++
public class UndoableStateEventArgs : EventArgs
Public Class UndoableStateEventArgs _
    Inherits EventArgs
public ref class UndoableStateEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UndoableStateEventArgs(RapidSpellChecker..::.State) | New
 | BadWord | The word involved.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UndoableState | The state of RapidSpellChecker
 | word | The bad word
Inheritance Hierarchy
Object
 | EventArgs
 |  | UndoableStateEventArgs
 |  |  | WordAddedEventArgs
 |  |  | WordChangedEventArgs
 |  |  | WordIgnoredEventArgs


UndoableStateEventArgs Constructor (undoableState)

UndoableStateEventArgs Constructor (undoableState)
API ► Keyoti.RapidSpell ► UndoableStateEventArgs ► UndoableStateEventArgs(RapidSpellChecker..::.State)
Keyoti RapidSpell Silverlight
New
Declaration Syntax
C# Visual Basic Visual C++
public UndoableStateEventArgs(
    RapidSpellChecker..::.State undoableState
)
Public Sub New ( _
    undoableState As RapidSpellChecker..::.State _
)
public:
UndoableStateEventArgs(
    RapidSpellChecker..::.State^ undoableState
)
Parameters
undoableState (RapidSpellChecker..::.State)


BadWord Property

BadWord Property
API ► Keyoti.RapidSpell ► UndoableStateEventArgs ► BadWord
Keyoti RapidSpell Silverlight
The word involved.
Declaration Syntax
C# Visual Basic Visual C++
public BadWord BadWord { get; }
Public ReadOnly Property BadWord As BadWord
public:
property BadWord^ BadWord {
    BadWord^ get ();
}


UndoableState Property

UndoableState Property
API ► Keyoti.RapidSpell ► UndoableStateEventArgs ► UndoableState
Keyoti RapidSpell Silverlight
The state of RapidSpellChecker
Declaration Syntax
C# Visual Basic Visual C++
public RapidSpellChecker..::.State UndoableState { get; set; }
Public Property UndoableState As RapidSpellChecker..::.State
public:
property RapidSpellChecker..::.State^ UndoableState {
    RapidSpellChecker..::.State^ get ();
    void set (RapidSpellChecker..::.State^ value);
}


word Field

word Field
API ► Keyoti.RapidSpell ► UndoableStateEventArgs ► word
Keyoti RapidSpell Silverlight
The bad word
Declaration Syntax
C# Visual Basic Visual C++
protected BadWord word
Protected word As BadWord
protected:
BadWord^ word


UndoEventArgs Class

UndoEventArgs Class
API ► Keyoti.RapidSpell ► UndoEventArgs
Keyoti RapidSpell Silverlight
Undo event args
Declaration Syntax
C# Visual Basic Visual C++
public class UndoEventArgs : EventArgs
Public Class UndoEventArgs _
    Inherits EventArgs
public ref class UndoEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UndoEventArgs(UndoableOperation) | New instance
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UndoneOperation | The operation which is undone.
Inheritance Hierarchy
Object
 | EventArgs
 |  | UndoEventArgs


UndoEventArgs Constructor (undoneOperation)

UndoEventArgs Constructor (undoneOperation)
API ► Keyoti.RapidSpell ► UndoEventArgs ► UndoEventArgs(UndoableOperation)
Keyoti RapidSpell Silverlight
New instance
Declaration Syntax
C# Visual Basic Visual C++
public UndoEventArgs(
    UndoableOperation undoneOperation
)
Public Sub New ( _
    undoneOperation As UndoableOperation _
)
public:
UndoEventArgs(
    UndoableOperation^ undoneOperation
)
Parameters
undoneOperation (UndoableOperation)
The operation which is undone.


UndoneOperation Property

UndoneOperation Property
API ► Keyoti.RapidSpell ► UndoEventArgs ► UndoneOperation
Keyoti RapidSpell Silverlight
The operation which is undone.
Declaration Syntax
C# Visual Basic Visual C++
public UndoableOperation UndoneOperation { get; }
Public ReadOnly Property UndoneOperation As UndoableOperation
public:
property UndoableOperation^ UndoneOperation {
    UndoableOperation^ get ();
}


UndoEventHandler Delegate

UndoEventHandler Delegate
API ► Keyoti.RapidSpell ► UndoEventHandler
Keyoti RapidSpell Silverlight
Event handler delegate
Declaration Syntax
C# Visual Basic Visual C++
public delegate void UndoEventHandler(
    Object sender,
    UndoEventArgs e
)
Public Delegate Sub UndoEventHandler ( _
    sender As Object, _
    e As UndoEventArgs _
)
public delegate void UndoEventHandler(
    Object^ sender,
    UndoEventArgs^ e
)
Parameters
sender (Object)
e (UndoEventArgs)


UndoManager Class

UndoManager Class
API ► Keyoti.RapidSpell ► UndoManager
Keyoti RapidSpell Silverlight
Manages the undoable operation stack.
Declaration Syntax
C# Visual Basic Visual C++
public class UndoManager
Public Class UndoManager
public ref class UndoManager
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UndoManager()()() | Constructor
 | BufferAddedTo | Indicates that an operation has been added
 | BufferEmptied | Indicates there are no more operations to undo
 | Dispose()()() | Cleans up resources
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | g_WordAdded(Object, WordAddedEventArgs) | Handles word added events
 | g_WordChanged(Object, WordChangedEventArgs) | Handles word changed events
 | g_WordIgnored(Object, WordIgnoredEventArgs) | Handles word ignored events
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Pop()()() | Pops off the last operation from the stack
 | Reset()()() | Resets the stack to empty.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
UndoManager


UndoManager Constructor

UndoManager Constructor
API ► Keyoti.RapidSpell ► UndoManager ► UndoManager()()()
Keyoti RapidSpell Silverlight
Constructor
Declaration Syntax
C# Visual Basic Visual C++
public UndoManager()
Public Sub New
public:
UndoManager()


BufferAddedTo Event

BufferAddedTo Event
API ► Keyoti.RapidSpell ► UndoManager ► BufferAddedTo
Keyoti RapidSpell Silverlight
Indicates that an operation has been added
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler BufferAddedTo
Public Event BufferAddedTo As EventHandler
public:
 event EventHandler^ BufferAddedTo {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


BufferEmptied Event

BufferEmptied Event
API ► Keyoti.RapidSpell ► UndoManager ► BufferEmptied
Keyoti RapidSpell Silverlight
Indicates there are no more operations to undo
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler BufferEmptied
Public Event BufferEmptied As EventHandler
public:
 event EventHandler^ BufferEmptied {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell ► UndoManager ► Dispose()()()
Keyoti RapidSpell Silverlight
Cleans up resources
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Dispose()
Public Overridable Sub Dispose
public:
virtual void Dispose()


g_WordAdded Method (s, e)

g_WordAdded Method (s, e)
API ► Keyoti.RapidSpell ► UndoManager ► g_WordAdded(Object, WordAddedEventArgs)
Keyoti RapidSpell Silverlight
Handles word added events
Declaration Syntax
C# Visual Basic Visual C++
public void g_WordAdded(
    Object s,
    WordAddedEventArgs e
)
Public Sub g_WordAdded ( _
    s As Object, _
    e As WordAddedEventArgs _
)
public:
void g_WordAdded(
    Object^ s,
    WordAddedEventArgs^ e
)
Parameters
s (Object)
e (WordAddedEventArgs)


g_WordChanged Method (s, e)

g_WordChanged Method (s, e)
API ► Keyoti.RapidSpell ► UndoManager ► g_WordChanged(Object, WordChangedEventArgs)
Keyoti RapidSpell Silverlight
Handles word changed events
Declaration Syntax
C# Visual Basic Visual C++
public void g_WordChanged(
    Object s,
    WordChangedEventArgs e
)
Public Sub g_WordChanged ( _
    s As Object, _
    e As WordChangedEventArgs _
)
public:
void g_WordChanged(
    Object^ s,
    WordChangedEventArgs^ e
)
Parameters
s (Object)
e (WordChangedEventArgs)


g_WordIgnored Method (s, e)

g_WordIgnored Method (s, e)
API ► Keyoti.RapidSpell ► UndoManager ► g_WordIgnored(Object, WordIgnoredEventArgs)
Keyoti RapidSpell Silverlight
Handles word ignored events
Declaration Syntax
C# Visual Basic Visual C++
public void g_WordIgnored(
    Object s,
    WordIgnoredEventArgs e
)
Public Sub g_WordIgnored ( _
    s As Object, _
    e As WordIgnoredEventArgs _
)
public:
void g_WordIgnored(
    Object^ s,
    WordIgnoredEventArgs^ e
)
Parameters
s (Object)
e (WordIgnoredEventArgs)


Pop Method

Pop Method
API ► Keyoti.RapidSpell ► UndoManager ► Pop()()()
Keyoti RapidSpell Silverlight
Pops off the last operation from the stack
Declaration Syntax
C# Visual Basic Visual C++
public UndoableOperation Pop()
Public Function Pop As UndoableOperation
public:
UndoableOperation^ Pop()


Reset Method

Reset Method
API ► Keyoti.RapidSpell ► UndoManager ► Reset()()()
Keyoti RapidSpell Silverlight
Resets the stack to empty.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Reset()
Public Overridable Sub Reset
public:
virtual void Reset()


UserDictionary Class

UserDictionary Class
API ► Keyoti.RapidSpell ► UserDictionary
Keyoti RapidSpell Silverlight
Represents the UserDictionary
Declaration Syntax
C# Visual Basic Visual C++
public class UserDictionary
Public Class UserDictionary
public ref class UserDictionary
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserDictionary(String) | Construct a UserDictionary based on the userDictionaryFile, which does not have to exist.
 | UserDictionary()()() | Constructs an invalid UserDictionary
 | UserDictionary(String, Int32) | Construct a UserDictionary based on the userDictionaryFile, which does not have to exist.
 | AddWord(String) | Tries to add word to this dictionary
 | dictFile | The file containing the dictionary
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid()()() | Returns whether the dictionary file is valid.
 | ListChanged | Notifies handlers that the word list has changed.
 | Location | Where to store the user dictionary
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnListChanged(UserDictionary..::.ListChangedEventArgs) | Raises ListChanged
 | ReadAll(ArrayList) | Read the dictionary word list into list.
 | ReloadDictionary()()() | Loads the dictionary into an internal collection.
 | RemoveWord(String) | Tries to remove word from this dictionary
 | SaveList(ArrayList) | Replaces the contents of the file with newList.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
UserDictionary


UserDictionary Constructor

UserDictionary Constructor
API ► Keyoti.RapidSpell ► UserDictionary ► UserDictionary()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | UserDictionary(String) | Construct a UserDictionary based on the userDictionaryFile, which does not have to exist.
 | UserDictionary()()() | Constructs an invalid UserDictionary
 | UserDictionary(String, Int32) | Construct a UserDictionary based on the userDictionaryFile, which does not have to exist.


UserDictionary Constructor

UserDictionary Constructor
API ► Keyoti.RapidSpell ► UserDictionary ► UserDictionary()()()
Keyoti RapidSpell Silverlight
Constructs an invalid UserDictionary
Declaration Syntax
C# Visual Basic Visual C++
public UserDictionary()
Public Sub New
public:
UserDictionary()


UserDictionary Constructor (userDictionaryFile)

UserDictionary Constructor (userDictionaryFile)
API ► Keyoti.RapidSpell ► UserDictionary ► UserDictionary(String)
Keyoti RapidSpell Silverlight
Construct a UserDictionary based on the userDictionaryFile, which does not have to exist.
Declaration Syntax
C# Visual Basic Visual C++
public UserDictionary(
    string userDictionaryFile
)
Public Sub New ( _
    userDictionaryFile As String _
)
public:
UserDictionary(
    String^ userDictionaryFile
)
Parameters
userDictionaryFile (String)
the file used for a user dictionary.
Remarks
User dictionary is limited to 5,000 words.


UserDictionary Constructor (userDictionaryFile, wordLimit)

UserDictionary Constructor (userDictionaryFile, wordLimit)
API ► Keyoti.RapidSpell ► UserDictionary ► UserDictionary(String, Int32)
Keyoti RapidSpell Silverlight
Construct a UserDictionary based on the userDictionaryFile, which does not have to exist.
Declaration Syntax
C# Visual Basic Visual C++
public UserDictionary(
    string userDictionaryFile,
    int wordLimit
)
Public Sub New ( _
    userDictionaryFile As String, _
    wordLimit As Integer _
)
public:
UserDictionary(
    String^ userDictionaryFile,
    int wordLimit
)
Parameters
userDictionaryFile (String)
the file used for a user dictionary.
wordLimit (Int32)
number of words user dictionary is limited to (150,000 max). If wordLimit is <=0 it will be set to 150,000.


AddWord Method (word)

AddWord Method (word)
API ► Keyoti.RapidSpell ► UserDictionary ► AddWord(String)
Keyoti RapidSpell Silverlight
Tries to add word to this dictionary
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool AddWord(
    string word
)
Public Overridable Function AddWord ( _
    word As String _
) As Boolean
public:
virtual bool AddWord(
    String^ word
)
Parameters
word (String)
String containing the new word
Return Value
true if added successfully, false otherwise.


dictFile Field

dictFile Field
API ► Keyoti.RapidSpell ► UserDictionary ► dictFile
Keyoti RapidSpell Silverlight
The file containing the dictionary
Declaration Syntax
C# Visual Basic Visual C++
public string dictFile
Public dictFile As String
public:
String^ dictFile


IsValid Method

IsValid Method
API ► Keyoti.RapidSpell ► UserDictionary ► IsValid()()()
Keyoti RapidSpell Silverlight
Returns whether the dictionary file is valid.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsValid()
Public Overridable Function IsValid As Boolean
public:
virtual bool IsValid()


ListChanged Event

ListChanged Event
API ► Keyoti.RapidSpell ► UserDictionary ► ListChanged
Keyoti RapidSpell Silverlight
Notifies handlers that the word list has changed.
Declaration Syntax
C# Visual Basic Visual C++
public event UserDictionary..::.ListChangedEventHandler ListChanged
Public Event ListChanged As UserDictionary..::.ListChangedEventHandler
public:
 event UserDictionary..::.ListChangedEventHandler^ ListChanged {
    void add (UserDictionary..::.ListChangedEventHandler^ value);
    void remove (UserDictionary..::.ListChangedEventHandler^ value);
}


Location Property

Location Property
API ► Keyoti.RapidSpell ► UserDictionary ► Location
Keyoti RapidSpell Silverlight
Where to store the user dictionary
Declaration Syntax
C# Visual Basic Visual C++
public UserDictionary..::.StorageLocation Location { get; set; }
Public Property Location As UserDictionary..::.StorageLocation
public:
property UserDictionary..::.StorageLocation Location {
    UserDictionary..::.StorageLocation get ();
    void set (UserDictionary..::.StorageLocation value);
}


OnListChanged Method (e)

OnListChanged Method (e)
API ► Keyoti.RapidSpell ► UserDictionary ► OnListChanged(UserDictionary..::.ListChangedEventArgs)
Keyoti RapidSpell Silverlight
Raises ListChanged
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void OnListChanged(
    UserDictionary..::.ListChangedEventArgs e
)
Protected Overridable Sub OnListChanged ( _
    e As UserDictionary..::.ListChangedEventArgs _
)
protected:
virtual void OnListChanged(
    UserDictionary..::.ListChangedEventArgs^ e
)
Parameters
e (UserDictionary..::.ListChangedEventArgs)


ReadAll Method (list)

ReadAll Method (list)
API ► Keyoti.RapidSpell ► UserDictionary ► ReadAll(ArrayList)
Keyoti RapidSpell Silverlight
Read the dictionary word list into list.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int ReadAll(
    ArrayList list
)
Public Overridable Function ReadAll ( _
    list As ArrayList _
) As Integer
public:
virtual int ReadAll(
    ArrayList^ list
)
Parameters
list (ArrayList)
the String array that the word list will be read into.
Return Value
number of words in list.


ReloadDictionary Method

ReloadDictionary Method
API ► Keyoti.RapidSpell ► UserDictionary ► ReloadDictionary()()()
Keyoti RapidSpell Silverlight
Loads the dictionary into an internal collection.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool ReloadDictionary()
Public Overridable Function ReloadDictionary As Boolean
public:
virtual bool ReloadDictionary()
Return Value
Whether the dictionary was reloaded successfully.
Remarks
The user dictionary can be changed externally (eg. by a different control), and this method is called when that happens to cause the internal collection to be updated.


RemoveWord Method (word)

RemoveWord Method (word)
API ► Keyoti.RapidSpell ► UserDictionary ► RemoveWord(String)
Keyoti RapidSpell Silverlight
Tries to remove word from this dictionary
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool RemoveWord(
    string word
)
Public Overridable Function RemoveWord ( _
    word As String _
) As Boolean
public:
virtual bool RemoveWord(
    String^ word
)
Parameters
word (String)
String containing the new word
Return Value
true if added successfully, false otherwise.


SaveList Method (newList)

SaveList Method (newList)
API ► Keyoti.RapidSpell ► UserDictionary ► SaveList(ArrayList)
Keyoti RapidSpell Silverlight
Replaces the contents of the file with newList.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SaveList(
    ArrayList newList
)
Public Overridable Sub SaveList ( _
    newList As ArrayList _
)
public:
virtual void SaveList(
    ArrayList^ newList
)
Parameters
newList (ArrayList)


UserDictionary.ListChangedEventArgs Class

UserDictionary..::.ListChangedEventArgs Class
API ► Keyoti.RapidSpell ► UserDictionary ► UserDictionary..::.ListChangedEventArgs
Keyoti RapidSpell Silverlight
Event args for ListChanged event
Declaration Syntax
C# Visual Basic Visual C++
public class ListChangedEventArgs : EventArgs
Public Class ListChangedEventArgs _
    Inherits EventArgs
public ref class ListChangedEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserDictionary..::.ListChangedEventArgs(UserDictionary..::.ListChangedEventArgs..::.ListChangeOperation, String) | New
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Operation | The type of operation
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Word | The word that was added or removed, may be null for ListSave.
Inheritance Hierarchy
Object
 | EventArgs
 |  | UserDictionary..::.ListChangedEventArgs


UserDictionary.ListChangedEventArgs Constructor (op, word)

UserDictionary..::.ListChangedEventArgs Constructor (op, word)
API ► Keyoti.RapidSpell ► UserDictionary..::.ListChangedEventArgs ► UserDictionary..::.ListChangedEventArgs(UserDictionary..::.ListChangedEventArgs..::.ListChangeOperation, String)
Keyoti RapidSpell Silverlight
New
Declaration Syntax
C# Visual Basic Visual C++
public ListChangedEventArgs(
    UserDictionary..::.ListChangedEventArgs..::.ListChangeOperation op,
    string word
)
Public Sub New ( _
    op As UserDictionary..::.ListChangedEventArgs..::.ListChangeOperation, _
    word As String _
)
public:
ListChangedEventArgs(
    UserDictionary..::.ListChangedEventArgs..::.ListChangeOperation op,
    String^ word
)
Parameters
op (UserDictionary..::.ListChangedEventArgs..::.ListChangeOperation)
word (String)


Operation Property

Operation Property
API ► Keyoti.RapidSpell ► UserDictionary..::.ListChangedEventArgs ► Operation
Keyoti RapidSpell Silverlight
The type of operation
Declaration Syntax
C# Visual Basic Visual C++
public UserDictionary..::.ListChangedEventArgs..::.ListChangeOperation Operation { get; }
Public ReadOnly Property Operation As UserDictionary..::.ListChangedEventArgs..::.ListChangeOperation
public:
property UserDictionary..::.ListChangedEventArgs..::.ListChangeOperation Operation {
    UserDictionary..::.ListChangedEventArgs..::.ListChangeOperation get ();
}


Word Property

Word Property
API ► Keyoti.RapidSpell ► UserDictionary..::.ListChangedEventArgs ► Word
Keyoti RapidSpell Silverlight
The word that was added or removed, may be null for ListSave.
Declaration Syntax
C# Visual Basic Visual C++
public string Word { get; }
Public ReadOnly Property Word As String
public:
property String^ Word {
    String^ get ();
}


UserDictionary.ListChangedEventArgs.ListChangeOperation Enumeration

UserDictionary..::.ListChangedEventArgs..::.ListChangeOperation Enumeration
API ► Keyoti.RapidSpell ► UserDictionary..::.ListChangedEventArgs ► UserDictionary..::.ListChangedEventArgs..::.ListChangeOperation
Keyoti RapidSpell Silverlight
Types of operation
Declaration Syntax
C# Visual Basic Visual C++
public enum ListChangeOperation
Public Enumeration ListChangeOperation
public enum class ListChangeOperation
Members
Member | Description
WordAdd | Word added.
WordRemove | Word removed
ListSave | List saved


UserDictionary.ListChangedEventHandler Delegate

UserDictionary..::.ListChangedEventHandler Delegate
API ► Keyoti.RapidSpell ► UserDictionary ► UserDictionary..::.ListChangedEventHandler
Keyoti RapidSpell Silverlight
Event handler
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ListChangedEventHandler(
    Object s,
    UserDictionary..::.ListChangedEventArgs e
)
Public Delegate Sub ListChangedEventHandler ( _
    s As Object, _
    e As UserDictionary..::.ListChangedEventArgs _
)
public delegate void ListChangedEventHandler(
    Object^ s,
    UserDictionary..::.ListChangedEventArgs^ e
)
Parameters
s (Object)
e (UserDictionary..::.ListChangedEventArgs)


UserDictionary.StorageLocation Enumeration

UserDictionary..::.StorageLocation Enumeration
API ► Keyoti.RapidSpell ► UserDictionary ► UserDictionary..::.StorageLocation
Keyoti RapidSpell Silverlight
Location options for storage
Declaration Syntax
C# Visual Basic Visual C++
public enum StorageLocation
Public Enumeration StorageLocation
public enum class StorageLocation
Members
Member | Description
IsolatedStorage | IsolatedStorage based.


WordAddedEventArgs Class

WordAddedEventArgs Class
API ► Keyoti.RapidSpell ► WordAddedEventArgs
Keyoti RapidSpell Silverlight
Args for the events fired when words are added to the user dictionary.
Declaration Syntax
C# Visual Basic Visual C++
public class WordAddedEventArgs : UndoableStateEventArgs
Public Class WordAddedEventArgs _
    Inherits UndoableStateEventArgs
public ref class WordAddedEventArgs : public UndoableStateEventArgs
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WordAddedEventArgs(BadWord, RapidSpellChecker..::.State, Object) |
 | BadWord | The word involved. (Inherited from UndoableStateEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TextBox | The current text box, if known.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UndoableState | The state of RapidSpellChecker (Inherited from UndoableStateEventArgs.)
 | word | The bad word (Inherited from UndoableStateEventArgs.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | UndoableStateEventArgs
 |  |  | WordAddedEventArgs


WordAddedEventArgs Constructor (word, undoableState, textBox)

WordAddedEventArgs Constructor (word, undoableState, textBox)
API ► Keyoti.RapidSpell ► WordAddedEventArgs ► WordAddedEventArgs(BadWord, RapidSpellChecker..::.State, Object)
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public WordAddedEventArgs(
    BadWord word,
    RapidSpellChecker..::.State undoableState,
    Object textBox
)
Public Sub New ( _
    word As BadWord, _
    undoableState As RapidSpellChecker..::.State, _
    textBox As Object _
)
public:
WordAddedEventArgs(
    BadWord^ word,
    RapidSpellChecker..::.State^ undoableState,
    Object^ textBox
)
Parameters
word (BadWord)
undoableState (RapidSpellChecker..::.State)
textBox (Object)


TextBox Property

TextBox Property
API ► Keyoti.RapidSpell ► WordAddedEventArgs ► TextBox
Keyoti RapidSpell Silverlight
The current text box, if known.
Declaration Syntax
C# Visual Basic Visual C++
public Object TextBox { get; }
Public ReadOnly Property TextBox As Object
public:
property Object^ TextBox {
    Object^ get ();
}


WordAddedEventHandler Delegate

WordAddedEventHandler Delegate
API ► Keyoti.RapidSpell ► WordAddedEventHandler
Keyoti RapidSpell Silverlight
Handler delegate
Declaration Syntax
C# Visual Basic Visual C++
public delegate void WordAddedEventHandler(
    Object sender,
    WordAddedEventArgs e
)
Public Delegate Sub WordAddedEventHandler ( _
    sender As Object, _
    e As WordAddedEventArgs _
)
public delegate void WordAddedEventHandler(
    Object^ sender,
    WordAddedEventArgs^ e
)
Parameters
sender (Object)
e (WordAddedEventArgs)


WordChangedEventArgs Class

WordChangedEventArgs Class
API ► Keyoti.RapidSpell ► WordChangedEventArgs
Keyoti RapidSpell Silverlight
Args for the events fired when words are changed.
Declaration Syntax
C# Visual Basic Visual C++
public class WordChangedEventArgs : UndoableStateEventArgs
Public Class WordChangedEventArgs _
    Inherits UndoableStateEventArgs
public ref class WordChangedEventArgs : public UndoableStateEventArgs
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WordChangedEventArgs(Boolean, BadWord, String, RapidSpellChecker..::.State, ArrayList, Int32, Object) |
 | All | Whether all instances of the word were changed.
 | BadWord | The word involved. (Inherited from UndoableStateEventArgs.)
 | ChangeIndices | List of ints pointing to locations in the text where other instances of the word were changed, if there were any, null/nothing otherwise
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Replacement | The replacement word.
 | TextBox | The current text box, if known.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UndoableState | The state of RapidSpellChecker (Inherited from UndoableStateEventArgs.)
 | word | The bad word (Inherited from UndoableStateEventArgs.)
 | WrappedChangeDelta | The change to indices caused by wrapped text changes
Inheritance Hierarchy
Object
 | EventArgs
 |  | UndoableStateEventArgs
 |  |  | WordChangedEventArgs


WordChangedEventArgs Constructor (all, badWord, replacement, undoableState, changeIndices, wrappedChangeDelta, textBox)

WordChangedEventArgs Constructor (all, badWord, replacement, undoableState, changeIndices, wrappedChangeDelta, textBox)
API ► Keyoti.RapidSpell ► WordChangedEventArgs ► WordChangedEventArgs(Boolean, BadWord, String, RapidSpellChecker..::.State, ArrayList, Int32, Object)
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public WordChangedEventArgs(
    bool all,
    BadWord badWord,
    string replacement,
    RapidSpellChecker..::.State undoableState,
    ArrayList changeIndices,
    int wrappedChangeDelta,
    Object textBox
)
Public Sub New ( _
    all As Boolean, _
    badWord As BadWord, _
    replacement As String, _
    undoableState As RapidSpellChecker..::.State, _
    changeIndices As ArrayList, _
    wrappedChangeDelta As Integer, _
    textBox As Object _
)
public:
WordChangedEventArgs(
    bool all,
    BadWord^ badWord,
    String^ replacement,
    RapidSpellChecker..::.State^ undoableState,
    ArrayList^ changeIndices,
    int wrappedChangeDelta,
    Object^ textBox
)
Parameters
all (Boolean)
badWord (BadWord)
replacement (String)
undoableState (RapidSpellChecker..::.State)
changeIndices (ArrayList)
wrappedChangeDelta (Int32)
textBox (Object)


All Property

All Property
API ► Keyoti.RapidSpell ► WordChangedEventArgs ► All
Keyoti RapidSpell Silverlight
Whether all instances of the word were changed.
Declaration Syntax
C# Visual Basic Visual C++
public bool All { get; }
Public ReadOnly Property All As Boolean
public:
property bool All {
    bool get ();
}


ChangeIndices Property

ChangeIndices Property
API ► Keyoti.RapidSpell ► WordChangedEventArgs ► ChangeIndices
Keyoti RapidSpell Silverlight
List of ints pointing to locations in the text where other instances of the word were changed, if there were any, null/nothing otherwise
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList ChangeIndices { get; }
Public ReadOnly Property ChangeIndices As ArrayList
public:
property ArrayList^ ChangeIndices {
    ArrayList^ get ();
}


Replacement Property

Replacement Property
API ► Keyoti.RapidSpell ► WordChangedEventArgs ► Replacement
Keyoti RapidSpell Silverlight
The replacement word.
Declaration Syntax
C# Visual Basic Visual C++
public string Replacement { get; internal set; }
Public Property Replacement As String
public:
property String^ Replacement {
    String^ get ();
    void set (String^ value);
}


TextBox Property

TextBox Property
API ► Keyoti.RapidSpell ► WordChangedEventArgs ► TextBox
Keyoti RapidSpell Silverlight
The current text box, if known.
Declaration Syntax
C# Visual Basic Visual C++
public Object TextBox { get; }
Public ReadOnly Property TextBox As Object
public:
property Object^ TextBox {
    Object^ get ();
}


WrappedChangeDelta Property

WrappedChangeDelta Property
API ► Keyoti.RapidSpell ► WordChangedEventArgs ► WrappedChangeDelta
Keyoti RapidSpell Silverlight
The change to indices caused by wrapped text changes
Declaration Syntax
C# Visual Basic Visual C++
public int WrappedChangeDelta { get; }
Public ReadOnly Property WrappedChangeDelta As Integer
public:
property int WrappedChangeDelta {
    int get ();
}


WordChangedEventHandler Delegate

WordChangedEventHandler Delegate
API ► Keyoti.RapidSpell ► WordChangedEventHandler
Keyoti RapidSpell Silverlight
Handler delegate
Declaration Syntax
C# Visual Basic Visual C++
public delegate void WordChangedEventHandler(
    Object sender,
    WordChangedEventArgs e
)
Public Delegate Sub WordChangedEventHandler ( _
    sender As Object, _
    e As WordChangedEventArgs _
)
public delegate void WordChangedEventHandler(
    Object^ sender,
    WordChangedEventArgs^ e
)
Parameters
sender (Object)
e (WordChangedEventArgs)


WordIgnoredEventArgs Class

WordIgnoredEventArgs Class
API ► Keyoti.RapidSpell ► WordIgnoredEventArgs
Keyoti RapidSpell Silverlight
Args for the events fired when words are ignored.
Declaration Syntax
C# Visual Basic Visual C++
public class WordIgnoredEventArgs : UndoableStateEventArgs
Public Class WordIgnoredEventArgs _
    Inherits UndoableStateEventArgs
public ref class WordIgnoredEventArgs : public UndoableStateEventArgs
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WordIgnoredEventArgs(Boolean, BadWord, Object, RapidSpellChecker..::.State) |
 | All | Whether all instances of the word were ignored.
 | BadWord | The word involved. (Inherited from UndoableStateEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TextBox | The text box object in which the operation was performed, if known.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UndoableState | The state of RapidSpellChecker (Inherited from UndoableStateEventArgs.)
 | word | The bad word (Inherited from UndoableStateEventArgs.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | UndoableStateEventArgs
 |  |  | WordIgnoredEventArgs


WordIgnoredEventArgs Constructor (all, badWord, textBox, undoableState)

WordIgnoredEventArgs Constructor (all, badWord, textBox, undoableState)
API ► Keyoti.RapidSpell ► WordIgnoredEventArgs ► WordIgnoredEventArgs(Boolean, BadWord, Object, RapidSpellChecker..::.State)
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public WordIgnoredEventArgs(
    bool all,
    BadWord badWord,
    Object textBox,
    RapidSpellChecker..::.State undoableState
)
Public Sub New ( _
    all As Boolean, _
    badWord As BadWord, _
    textBox As Object, _
    undoableState As RapidSpellChecker..::.State _
)
public:
WordIgnoredEventArgs(
    bool all,
    BadWord^ badWord,
    Object^ textBox,
    RapidSpellChecker..::.State^ undoableState
)
Parameters
all (Boolean)
badWord (BadWord)
textBox (Object)
undoableState (RapidSpellChecker..::.State)


All Property

All Property
API ► Keyoti.RapidSpell ► WordIgnoredEventArgs ► All
Keyoti RapidSpell Silverlight
Whether all instances of the word were ignored.
Declaration Syntax
C# Visual Basic Visual C++
public bool All { get; }
Public ReadOnly Property All As Boolean
public:
property bool All {
    bool get ();
}


TextBox Property

TextBox Property
API ► Keyoti.RapidSpell ► WordIgnoredEventArgs ► TextBox
Keyoti RapidSpell Silverlight
The text box object in which the operation was performed, if known.
Declaration Syntax
C# Visual Basic Visual C++
public Object TextBox { get; }
Public ReadOnly Property TextBox As Object
public:
property Object^ TextBox {
    Object^ get ();
}
Remarks
This is null when the event originates in RapidSpellChecker


WordIgnoredEventHandler Delegate

WordIgnoredEventHandler Delegate
API ► Keyoti.RapidSpell ► WordIgnoredEventHandler
Keyoti RapidSpell Silverlight
Handler delegate
Declaration Syntax
C# Visual Basic Visual C++
public delegate void WordIgnoredEventHandler(
    Object sender,
    WordIgnoredEventArgs e
)
Public Delegate Sub WordIgnoredEventHandler ( _
    sender As Object, _
    e As WordIgnoredEventArgs _
)
public delegate void WordIgnoredEventHandler(
    Object^ sender,
    WordIgnoredEventArgs^ e
)
Parameters
sender (Object)
e (WordIgnoredEventArgs)


WordOccurrence Class

WordOccurrence Class
API ► Keyoti.RapidSpell ► WordOccurrence
Keyoti RapidSpell Silverlight
Represents a word in the text.
Declaration Syntax
C# Visual Basic Visual C++
public class WordOccurrence
Public Class WordOccurrence
public ref class WordOccurrence
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WordOccurrence(String, Int32, Int32) | Constructs a BadWord instance.
 | caretEnd | End of word
 | caretStart | Start of word
 | EndPosition | Gets the position of the end of this word in the main text.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEndPosition()()() | Gets the position of the end of this word in the main text.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStartPosition()()() | Gets the position of the start of this word in the main text.
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWord()()() | Gets the String of this bad word.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | StartPosition | Gets the position of the start of this word in the main text.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Word | Gets the string of this bad word.
Inheritance Hierarchy
Object
 | WordOccurrence
 |  | BadWord


WordOccurrence Constructor (word, caretStart, caretEnd)

WordOccurrence Constructor (word, caretStart, caretEnd)
API ► Keyoti.RapidSpell ► WordOccurrence ► WordOccurrence(String, Int32, Int32)
Keyoti RapidSpell Silverlight
Constructs a BadWord instance.
Declaration Syntax
C# Visual Basic Visual C++
public WordOccurrence(
    string word,
    int caretStart,
    int caretEnd
)
Public Sub New ( _
    word As String, _
    caretStart As Integer, _
    caretEnd As Integer _
)
public:
WordOccurrence(
    String^ word,
    int caretStart,
    int caretEnd
)
Parameters
word (String)
the word String that is misspelt
caretStart (Int32)
the position in the original text
caretEnd (Int32)
the end position in the text


caretEnd Field

caretEnd Field
API ► Keyoti.RapidSpell ► WordOccurrence ► caretEnd
Keyoti RapidSpell Silverlight
End of word
Declaration Syntax
C# Visual Basic Visual C++
protected int caretEnd
Protected caretEnd As Integer
protected:
int caretEnd


caretStart Field

caretStart Field
API ► Keyoti.RapidSpell ► WordOccurrence ► caretStart
Keyoti RapidSpell Silverlight
Start of word
Declaration Syntax
C# Visual Basic Visual C++
protected int caretStart
Protected caretStart As Integer
protected:
int caretStart


EndPosition Property

EndPosition Property
API ► Keyoti.RapidSpell ► WordOccurrence ► EndPosition
Keyoti RapidSpell Silverlight
Gets the position of the end of this word in the main text.
Declaration Syntax
C# Visual Basic Visual C++
public int EndPosition { get; set; }
Public Property EndPosition As Integer
public:
property int EndPosition {
    int get ();
    void set (int value);
}


GetEndPosition Method

GetEndPosition Method
API ► Keyoti.RapidSpell ► WordOccurrence ► GetEndPosition()()()
Keyoti RapidSpell Silverlight
Gets the position of the end of this word in the main text.
Declaration Syntax
C# Visual Basic Visual C++
public int GetEndPosition()
Public Function GetEndPosition As Integer
public:
int GetEndPosition()
Return Value
int position in the text where this word ends


GetStartPosition Method

GetStartPosition Method
API ► Keyoti.RapidSpell ► WordOccurrence ► GetStartPosition()()()
Keyoti RapidSpell Silverlight
Gets the position of the start of this word in the main text.
Declaration Syntax
C# Visual Basic Visual C++
public int GetStartPosition()
Public Function GetStartPosition As Integer
public:
int GetStartPosition()
Return Value
int position in the text where this word starts.


GetWord Method

GetWord Method
API ► Keyoti.RapidSpell ► WordOccurrence ► GetWord()()()
Keyoti RapidSpell Silverlight
Gets the String of this bad word.
Declaration Syntax
C# Visual Basic Visual C++
public string GetWord()
Public Function GetWord As String
public:
String^ GetWord()
Return Value
String in this BadWord


StartPosition Property

StartPosition Property
API ► Keyoti.RapidSpell ► WordOccurrence ► StartPosition
Keyoti RapidSpell Silverlight
Gets the position of the start of this word in the main text.
Declaration Syntax
C# Visual Basic Visual C++
public int StartPosition { get; set; }
Public Property StartPosition As Integer
public:
property int StartPosition {
    int get ();
    void set (int value);
}


Word Property

Word Property
API ► Keyoti.RapidSpell ► WordOccurrence ► Word
Keyoti RapidSpell Silverlight
Gets the string of this bad word.
Declaration Syntax
C# Visual Basic Visual C++
public string Word { get; set; }
Public Property Word As String
public:
property String^ Word {
    String^ get ();
    void set (String^ value);
}


WordRemovedEventArgs Class

WordRemovedEventArgs Class
API ► Keyoti.RapidSpell ► WordRemovedEventArgs
Keyoti RapidSpell Silverlight
Args for the events fired when words are removed from the user dictionary.
Declaration Syntax
C# Visual Basic Visual C++
public class WordRemovedEventArgs : EventArgs
Public Class WordRemovedEventArgs _
    Inherits EventArgs
public ref class WordRemovedEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WordRemovedEventArgs(String) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Word | The word that was removed
Inheritance Hierarchy
Object
 | EventArgs
 |  | WordRemovedEventArgs


WordRemovedEventArgs Constructor (word)

WordRemovedEventArgs Constructor (word)
API ► Keyoti.RapidSpell ► WordRemovedEventArgs ► WordRemovedEventArgs(String)
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public WordRemovedEventArgs(
    string word
)
Public Sub New ( _
    word As String _
)
public:
WordRemovedEventArgs(
    String^ word
)
Parameters
word (String)


Word Property

Word Property
API ► Keyoti.RapidSpell ► WordRemovedEventArgs ► Word
Keyoti RapidSpell Silverlight
The word that was removed
Declaration Syntax
C# Visual Basic Visual C++
public string Word { get; }
Public ReadOnly Property Word As String
public:
property String^ Word {
    String^ get ();
}


WordRemovedEventHandler Delegate

WordRemovedEventHandler Delegate
API ► Keyoti.RapidSpell ► WordRemovedEventHandler
Keyoti RapidSpell Silverlight
Handler delegate
Declaration Syntax
C# Visual Basic Visual C++
public delegate void WordRemovedEventHandler(
    Object sender,
    WordRemovedEventArgs e
)
Public Delegate Sub WordRemovedEventHandler ( _
    sender As Object, _
    e As WordRemovedEventArgs _
)
public delegate void WordRemovedEventHandler(
    Object^ sender,
    WordRemovedEventArgs^ e
)
Parameters
sender (Object)
e (WordRemovedEventArgs)


Keyoti.RapidSpell.Compression Namespace

Keyoti.RapidSpell.Compression Namespace
API ► Keyoti.RapidSpell.Compression
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
namespace Keyoti.RapidSpell.Compression
Namespace Keyoti.RapidSpell.Compression
namespace Keyoti.RapidSpell.Compression
Types
All Types Classes Enumerations
Icon | Type | Description
 | CompressionLevel | The compression level to be used when using a DeflateStream or ZlibStream with CompressionMode.Compress.
 | CompressionMode | An enum to specify the direction of transcoding - whether to compress or decompress.
 | CompressionStrategy | Describes options for how the compression algorithm is executed. Different strategies work better on different sorts of data. The strategy parameter can affect the compression ratio and the speed of compression but not the correctness of the compresssion.
 | CRC32 | Calculates a 32bit Cyclic Redundancy Checksum (CRC) using the same polynomial used by Zip. This type is used internally by DotNetZip; it is generally not used directly by applications wishing to create, read, or manipulate zip archive files.
 | CrcCalculatorStream | A Stream that calculates a CRC32 (a checksum) on all bytes read, or on all bytes written.
 | DeflateStream | A class for compressing and decompressing streams using the Deflate algorithm.
 | FlushType | Describes how to flush the current deflate operation.
 | GZipStream | A class for compressing and decompressing GZIP streams.
 | ZlibCodec | Encoder and Decoder for ZLIB and DEFLATE (IETF RFC1950 and RFC1951).
 | ZlibConstants | A bunch of constants used in the Zlib interface.
 | ZlibException | A general purpose exception class for exceptions in the Zlib library.
 | ZlibStream | Represents a Zlib stream for compression or decompression.


CompressionLevel Enumeration

CompressionLevel Enumeration
API ► Keyoti.RapidSpell.Compression ► CompressionLevel
Keyoti RapidSpell Silverlight
The compression level to be used when using a DeflateStream or ZlibStream with CompressionMode.Compress.
Declaration Syntax
C# Visual Basic Visual C++
public enum CompressionLevel
Public Enumeration CompressionLevel
public enum class CompressionLevel
Members
Member | Description
None | None means that the data will be simply stored, with no change at all. If you are producing ZIPs for use on Mac OSX, be aware that archives produced with CompressionLevel.None cannot be opened with the default zip reader. Use a different CompressionLevel.
Level0 | Same as None.
BestSpeed | The fastest but least effective compression.
Level1 | A synonym for BestSpeed.
Level2 | A little slower, but better, than level 1.
Level3 | A little slower, but better, than level 2.
Level4 | A little slower, but better, than level 3.
Level5 | A little slower than level 4, but with better compression.
Default | The default compression level, with a good balance of speed and compression efficiency.
Level6 | A synonym for Default.
Level7 | Pretty good compression!
Level8 | Better compression than Level7!
BestCompression | The "best" compression, where best means greatest reduction in size of the input data stream. This is also the slowest compression.
Level9 | A synonym for BestCompression.


CompressionMode Enumeration

CompressionMode Enumeration
API ► Keyoti.RapidSpell.Compression ► CompressionMode
Keyoti RapidSpell Silverlight
An enum to specify the direction of transcoding - whether to compress or decompress.
Declaration Syntax
C# Visual Basic Visual C++
public enum CompressionMode
Public Enumeration CompressionMode
public enum class CompressionMode
Members
Member | Description
Compress | Used to specify that the stream should compress the data.
Decompress | Used to specify that the stream should decompress the data.


CompressionStrategy Enumeration

CompressionStrategy Enumeration
API ► Keyoti.RapidSpell.Compression ► CompressionStrategy
Keyoti RapidSpell Silverlight
Describes options for how the compression algorithm is executed. Different strategies work better on different sorts of data. The strategy parameter can affect the compression ratio and the speed of compression but not the correctness of the compresssion.
Declaration Syntax
C# Visual Basic Visual C++
public enum CompressionStrategy
Public Enumeration CompressionStrategy
public enum class CompressionStrategy
Members
Member | Description
Default | The default strategy is probably the best for normal data.
Filtered | The Filtered strategy is intended to be used most effectively with data produced by a filter or predictor. By this definition, filtered data consists mostly of small values with a somewhat random distribution. In this case, the compression algorithm is tuned to compress them better. The effect of Filtered is to force more Huffman coding and less string matching; it is a half-step between Default and HuffmanOnly.
HuffmanOnly | Using HuffmanOnly will force the compressor to do Huffman encoding only, with no string matching.


CRC32 Class

CRC32 Class
API ► Keyoti.RapidSpell.Compression ► CRC32
Keyoti RapidSpell Silverlight
Calculates a 32bit Cyclic Redundancy Checksum (CRC) using the same polynomial used by Zip. This type is used internally by DotNetZip; it is generally not used directly by applications wishing to create, read, or manipulate zip archive files.
Declaration Syntax
C# Visual Basic Visual C++
public class CRC32
Public Class CRC32
public ref class CRC32
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CRC32()()() |
 | Combine(Int32, Int32) | Combines the given CRC32 value with the current running total.
 | ComputeCrc32(Int32, Byte) | Get the CRC32 for the given (word,byte) combo. This is a computation defined by PKzip.
 | Crc32Result | Indicates the current CRC for all blocks slurped in.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCrc32(Stream) | Returns the CRC32 for the specified stream.
 | GetCrc32AndCopy(Stream, Stream) | Returns the CRC32 for the specified stream, and writes the input into the output stream.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SlurpBlock(array<Byte>[]()[], Int32, Int32) | Update the value for the running CRC32 using the given block of bytes. This is useful when using the CRC32() class in a Stream.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalBytesRead | indicates the total number of bytes read on the CRC stream. This is used when writing the ZipDirEntry when compressing files.
Inheritance Hierarchy
Object
CRC32


CRC32 Constructor

CRC32 Constructor
API ► Keyoti.RapidSpell.Compression ► CRC32 ► CRC32()()()
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public CRC32()
Public Sub New
public:
CRC32()


Combine Method (crc, length)

Combine Method (crc, length)
API ► Keyoti.RapidSpell.Compression ► CRC32 ► Combine(Int32, Int32)
Keyoti RapidSpell Silverlight
Combines the given CRC32 value with the current running total.
Declaration Syntax
C# Visual Basic Visual C++
public void Combine(
    int crc,
    int length
)
Public Sub Combine ( _
    crc As Integer, _
    length As Integer _
)
public:
void Combine(
    int crc,
    int length
)
Parameters
crc (Int32)
the crc value to be combined with this one
length (Int32)
the length of data the CRC value was calculated on
Remarks
This is useful when using a divide-and-conquer approach to calculating a CRC. Multiple threads can each calculate a CRC32 on a segment of the data, and then combine the individual CRC32 values at the end.


ComputeCrc32 Method (W, B)

ComputeCrc32 Method (W, B)
API ► Keyoti.RapidSpell.Compression ► CRC32 ► ComputeCrc32(Int32, Byte)
Keyoti RapidSpell Silverlight
Get the CRC32 for the given (word,byte) combo. This is a computation defined by PKzip.
Declaration Syntax
C# Visual Basic Visual C++
public int ComputeCrc32(
    int W,
    byte B
)
Public Function ComputeCrc32 ( _
    W As Integer, _
    B As Byte _
) As Integer
public:
int ComputeCrc32(
    int W,
    unsigned char B
)
Parameters
W (Int32)
The word to start with.
B (Byte)
The byte to combine it with.
Return Value
The CRC-ized result.


Crc32Result Property

Crc32Result Property
API ► Keyoti.RapidSpell.Compression ► CRC32 ► Crc32Result
Keyoti RapidSpell Silverlight
Indicates the current CRC for all blocks slurped in.
Declaration Syntax
C# Visual Basic Visual C++
public int Crc32Result { get; }
Public ReadOnly Property Crc32Result As Integer
public:
property int Crc32Result {
    int get ();
}


GetCrc32 Method (input)

GetCrc32 Method (input)
API ► Keyoti.RapidSpell.Compression ► CRC32 ► GetCrc32(Stream)
Keyoti RapidSpell Silverlight
Returns the CRC32 for the specified stream.
Declaration Syntax
C# Visual Basic Visual C++
public int GetCrc32(
    Stream input
)
Public Function GetCrc32 ( _
    input As Stream _
) As Integer
public:
int GetCrc32(
    Stream^ input
)
Parameters
input (Stream)
The stream over which to calculate the CRC32
Return Value
the CRC32 calculation


GetCrc32AndCopy Method (input, output)

GetCrc32AndCopy Method (input, output)
API ► Keyoti.RapidSpell.Compression ► CRC32 ► GetCrc32AndCopy(Stream, Stream)
Keyoti RapidSpell Silverlight
Returns the CRC32 for the specified stream, and writes the input into the output stream.
Declaration Syntax
C# Visual Basic Visual C++
public int GetCrc32AndCopy(
    Stream input,
    Stream output
)
Public Function GetCrc32AndCopy ( _
    input As Stream, _
    output As Stream _
) As Integer
public:
int GetCrc32AndCopy(
    Stream^ input,
    Stream^ output
)
Parameters
input (Stream)
The stream over which to calculate the CRC32
output (Stream)
The stream into which to deflate the input
Return Value
the CRC32 calculation


SlurpBlock Method (block, offset, count)

SlurpBlock Method (block, offset, count)
API ► Keyoti.RapidSpell.Compression ► CRC32 ► SlurpBlock(array<Byte>[]()[], Int32, Int32)
Keyoti RapidSpell Silverlight
Update the value for the running CRC32 using the given block of bytes. This is useful when using the CRC32() class in a Stream.
Declaration Syntax
C# Visual Basic Visual C++
public void SlurpBlock(
    byte[] block,
    int offset,
    int count
)
Public Sub SlurpBlock ( _
    block As Byte(), _
    offset As Integer, _
    count As Integer _
)
public:
void SlurpBlock(
    array<unsigned char>^ block,
    int offset,
    int count
)
Parameters
block (array< Byte >[]()[])
block of bytes to slurp
offset (Int32)
starting point in the block
count (Int32)
how many bytes within the block to slurp


TotalBytesRead Property

TotalBytesRead Property
API ► Keyoti.RapidSpell.Compression ► CRC32 ► TotalBytesRead
Keyoti RapidSpell Silverlight
indicates the total number of bytes read on the CRC stream. This is used when writing the ZipDirEntry when compressing files.
Declaration Syntax
C# Visual Basic Visual C++
public long TotalBytesRead { get; }
Public ReadOnly Property TotalBytesRead As Long
public:
property long long TotalBytesRead {
    long long get ();
}


CrcCalculatorStream Class

CrcCalculatorStream Class
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream
Keyoti RapidSpell Silverlight
A Stream that calculates a CRC32 (a checksum) on all bytes read, or on all bytes written.
Declaration Syntax
C# Visual Basic Visual C++
public class CrcCalculatorStream : Stream,
    IDisposable
Public Class CrcCalculatorStream _
    Inherits Stream _
    Implements IDisposable
public ref class CrcCalculatorStream : public Stream,
    IDisposable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CrcCalculatorStream(Stream) | The default constructor.
 | CrcCalculatorStream(Stream, Boolean) | The constructor allows the caller to specify how to handle the underlying stream at close.
 | CrcCalculatorStream(Stream, Int64) | A constructor allowing the specification of the length of the stream to read.
 | CrcCalculatorStream(Stream, Int64, Boolean) | A constructor allowing the specification of the length of the stream to read, as well as whether to keep the underlying stream open upon Close().
 | BeginRead(array<Byte>[]()[], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous read operation. (Inherited from Stream.)
 | BeginWrite(array<Byte>[]()[], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous write operation. (Inherited from Stream.)
 | CanRead | Indicates whether the stream supports reading. (Overrides Stream.CanRead.)
 | CanSeek | Indicates whether the stream supports seeking. (Overrides Stream.CanSeek.)
 | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
 | CanWrite | Indicates whether the stream supports writing. (Overrides Stream.CanWrite.)
 | Close()()() | Closes the stream. (Overrides Stream.Close()()().)
 | Crc | Provides the current CRC for all blocks slurped in.
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateWaitHandle()()() | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
 | Dispose()()() | Releases all resources used by the Stream. (Inherited from Stream.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
 | EndRead(IAsyncResult) | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
 | EndWrite(IAsyncResult) | Ends an asynchronous write operation. (Inherited from Stream.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Flush()()() | Flush the stream. (Overrides Stream.Flush()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | LeaveOpen | Indicates whether the underlying stream will be left open when the CrcCalculatorStream is Closed.
 | Length | Not implemented. (Overrides Stream.Length.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Position | Not implemented. (Overrides Stream.Position.)
 | Read(array<Byte>[]()[], Int32, Int32) | Read from the stream (Overrides Stream.Read(array<Byte>[]()[], Int32, Int32).)
 | ReadByte()()() | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
 | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
 | Seek(Int64, SeekOrigin) | Not implemented. (Overrides Stream.Seek(Int64, SeekOrigin).)
 | SetLength(Int64) | Not implemented. (Overrides Stream.SetLength(Int64).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalBytesSlurped | Gets the total number of bytes run through the CRC32 calculator.
 | Write(array<Byte>[]()[], Int32, Int32) | Write to the stream. (Overrides Stream.Write(array<Byte>[]()[], Int32, Int32).)
 | WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
 | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Remarks

This class can be used to verify the CRC of a ZipEntry when reading from a stream, or to calculate a CRC when writing to a stream. The stream should be used to either read, or write, but not both. If you intermix reads and writes, the results are not defined.

This class is intended primarily for use internally by the DotNetZip library.

Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Stream
 |  |  | CrcCalculatorStream


CrcCalculatorStream Constructor

CrcCalculatorStream Constructor
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► CrcCalculatorStream()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | CrcCalculatorStream(Stream) | The default constructor.
 | CrcCalculatorStream(Stream, Boolean) | The constructor allows the caller to specify how to handle the underlying stream at close.
 | CrcCalculatorStream(Stream, Int64) | A constructor allowing the specification of the length of the stream to read.
 | CrcCalculatorStream(Stream, Int64, Boolean) | A constructor allowing the specification of the length of the stream to read, as well as whether to keep the underlying stream open upon Close().


CrcCalculatorStream Constructor (stream)

CrcCalculatorStream Constructor (stream)
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► CrcCalculatorStream(Stream)
Keyoti RapidSpell Silverlight
The default constructor.
Declaration Syntax
C# Visual Basic Visual C++
public CrcCalculatorStream(
    Stream stream
)
Public Sub New ( _
    stream As Stream _
)
public:
CrcCalculatorStream(
    Stream^ stream
)
Parameters
stream (Stream)
The underlying stream
Remarks
Instances returned from this constructor will leave the underlying stream open upon Close().


CrcCalculatorStream Constructor (stream, leaveOpen)

CrcCalculatorStream Constructor (stream, leaveOpen)
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► CrcCalculatorStream(Stream, Boolean)
Keyoti RapidSpell Silverlight
The constructor allows the caller to specify how to handle the underlying stream at close.
Declaration Syntax
C# Visual Basic Visual C++
public CrcCalculatorStream(
    Stream stream,
    bool leaveOpen
)
Public Sub New ( _
    stream As Stream, _
    leaveOpen As Boolean _
)
public:
CrcCalculatorStream(
    Stream^ stream,
    bool leaveOpen
)
Parameters
stream (Stream)
The underlying stream
leaveOpen (Boolean)
true to leave the underlying stream open upon close of the CrcCalculatorStream.; false otherwise.


CrcCalculatorStream Constructor (stream, length)

CrcCalculatorStream Constructor (stream, length)
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► CrcCalculatorStream(Stream, Int64)
Keyoti RapidSpell Silverlight
A constructor allowing the specification of the length of the stream to read.
Declaration Syntax
C# Visual Basic Visual C++
public CrcCalculatorStream(
    Stream stream,
    long length
)
Public Sub New ( _
    stream As Stream, _
    length As Long _
)
public:
CrcCalculatorStream(
    Stream^ stream,
    long long length
)
Parameters
stream (Stream)
The underlying stream
length (Int64)
The length of the stream to slurp
Remarks
Instances returned from this constructor will leave the underlying stream open upon Close().


CrcCalculatorStream Constructor (stream, length, leaveOpen)

CrcCalculatorStream Constructor (stream, length, leaveOpen)
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► CrcCalculatorStream(Stream, Int64, Boolean)
Keyoti RapidSpell Silverlight
A constructor allowing the specification of the length of the stream to read, as well as whether to keep the underlying stream open upon Close().
Declaration Syntax
C# Visual Basic Visual C++
public CrcCalculatorStream(
    Stream stream,
    long length,
    bool leaveOpen
)
Public Sub New ( _
    stream As Stream, _
    length As Long, _
    leaveOpen As Boolean _
)
public:
CrcCalculatorStream(
    Stream^ stream,
    long long length,
    bool leaveOpen
)
Parameters
stream (Stream)
The underlying stream
length (Int64)
The length of the stream to slurp
leaveOpen (Boolean)
true to leave the underlying stream open upon close of the CrcCalculatorStream.; false otherwise.


CanRead Property

CanRead Property
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► CanRead
Keyoti RapidSpell Silverlight
Indicates whether the stream supports reading.
Declaration Syntax
C# Visual Basic Visual C++
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
public:
virtual property bool CanRead {
    bool get () override;
}


CanSeek Property

CanSeek Property
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► CanSeek
Keyoti RapidSpell Silverlight
Indicates whether the stream supports seeking.
Declaration Syntax
C# Visual Basic Visual C++
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
public:
virtual property bool CanSeek {
    bool get () override;
}


CanWrite Property

CanWrite Property
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► CanWrite
Keyoti RapidSpell Silverlight
Indicates whether the stream supports writing.
Declaration Syntax
C# Visual Basic Visual C++
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
public:
virtual property bool CanWrite {
    bool get () override;
}


Close Method

Close Method
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► Close()()()
Keyoti RapidSpell Silverlight
Closes the stream.
Declaration Syntax
C# Visual Basic Visual C++
public override void Close()
Public Overrides Sub Close
public:
virtual void Close() override


Crc Property

Crc Property
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► Crc
Keyoti RapidSpell Silverlight
Provides the current CRC for all blocks slurped in.
Declaration Syntax
C# Visual Basic Visual C++
public int Crc { get; }
Public ReadOnly Property Crc As Integer
public:
property int Crc {
    int get ();
}


Flush Method

Flush Method
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► Flush()()()
Keyoti RapidSpell Silverlight
Flush the stream.
Declaration Syntax
C# Visual Basic Visual C++
public override void Flush()
Public Overrides Sub Flush
public:
virtual void Flush() override


LeaveOpen Property

LeaveOpen Property
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► LeaveOpen
Keyoti RapidSpell Silverlight
Indicates whether the underlying stream will be left open when the CrcCalculatorStream is Closed.
Declaration Syntax
C# Visual Basic Visual C++
public bool LeaveOpen { get; set; }
Public Property LeaveOpen As Boolean
public:
property bool LeaveOpen {
    bool get ();
    void set (bool value);
}


Length Property

Length Property
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► Length
Keyoti RapidSpell Silverlight
Not implemented.
Declaration Syntax
C# Visual Basic Visual C++
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
public:
virtual property long long Length {
    long long get () override;
}


Position Property

Position Property
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► Position
Keyoti RapidSpell Silverlight
Not implemented.
Declaration Syntax
C# Visual Basic Visual C++
public override long Position { get; set; }
Public Overrides Property Position As Long
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}


Read Method (buffer, offset, count)

Read Method (buffer, offset, count)
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► Read(array<Byte>[]()[], Int32, Int32)
Keyoti RapidSpell Silverlight
Read from the stream
Declaration Syntax
C# Visual Basic Visual C++
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Function Read ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
) As Integer
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
Parameters
buffer (array< Byte >[]()[])
the buffer to read
offset (Int32)
the offset at which to start
count (Int32)
the number of bytes to read
Return Value
the number of bytes actually read


Seek Method (offset, origin)

Seek Method (offset, origin)
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► Seek(Int64, SeekOrigin)
Keyoti RapidSpell Silverlight
Not implemented.
Declaration Syntax
C# Visual Basic Visual C++
public override long Seek(
    long offset,
    SeekOrigin origin
)
Public Overrides Function Seek ( _
    offset As Long, _
    origin As SeekOrigin _
) As Long
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
Parameters
offset (Int64)
N/A
origin (SeekOrigin)
N/A
Return Value
N/A


SetLength Method (value)

SetLength Method (value)
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► SetLength(Int64)
Keyoti RapidSpell Silverlight
Not implemented.
Declaration Syntax
C# Visual Basic Visual C++
public override void SetLength(
    long value
)
Public Overrides Sub SetLength ( _
    value As Long _
)
public:
virtual void SetLength(
    long long value
) override
Parameters
value (Int64)
N/A


TotalBytesSlurped Property

TotalBytesSlurped Property
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► TotalBytesSlurped
Keyoti RapidSpell Silverlight
Gets the total number of bytes run through the CRC32 calculator.
Declaration Syntax
C# Visual Basic Visual C++
public long TotalBytesSlurped { get; }
Public ReadOnly Property TotalBytesSlurped As Long
public:
property long long TotalBytesSlurped {
    long long get ();
}
Remarks
This is either the total number of bytes read, or the total number of bytes written, depending on the direction of this stream.


Write Method (buffer, offset, count)

Write Method (buffer, offset, count)
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► Write(array<Byte>[]()[], Int32, Int32)
Keyoti RapidSpell Silverlight
Write to the stream.
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Write ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
)
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
Parameters
buffer (array< Byte >[]()[])
the buffer from which to write
offset (Int32)
the offset at which to start writing
count (Int32)
the number of bytes to write


DeflateStream Class

DeflateStream Class
API ► Keyoti.RapidSpell.Compression ► DeflateStream
Keyoti RapidSpell Silverlight
A class for compressing and decompressing streams using the Deflate algorithm.
Declaration Syntax
C# Visual Basic Visual C++
public class DeflateStream : Stream
Public Class DeflateStream _
    Inherits Stream
public ref class DeflateStream : public Stream
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DeflateStream(Stream, CompressionMode) | Create a DeflateStream using the specified CompressionMode.
 | DeflateStream(Stream, CompressionMode, CompressionLevel) | Create a DeflateStream using the specified CompressionMode and the specified CompressionLevel.
 | DeflateStream(Stream, CompressionMode, Boolean) | Create a DeflateStream using the specified CompressionMode, and explicitly specify whether the stream should be left open after Deflation or Inflation.
 | DeflateStream(Stream, CompressionMode, CompressionLevel, Boolean) | Create a DeflateStream using the specified CompressionMode and the specified CompressionLevel, and explicitly specify whether the stream should be left open after Deflation or Inflation.
 | BeginRead(array<Byte>[]()[], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous read operation. (Inherited from Stream.)
 | BeginWrite(array<Byte>[]()[], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous write operation. (Inherited from Stream.)
 | BufferSize | The size of the working buffer for the compression codec.
 | CanRead | Indicates whether the stream can be read. (Overrides Stream.CanRead.)
 | CanSeek | Indicates whether the stream supports Seek operations. (Overrides Stream.CanSeek.)
 | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
 | CanWrite | Indicates whether the stream can be written. (Overrides Stream.CanWrite.)
 | Close()()() | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. (Inherited from Stream.)
 | CompressBuffer(array<Byte>[]()[]) | Compress a byte array into a new byte array using DEFLATE.
 | CompressString(String) | Compress a string into a byte array using DEFLATE (RFC 1951).
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateWaitHandle()()() | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
 | Dispose(Boolean) | Dispose the stream. (Overrides Stream.Dispose(Boolean).)
 | Dispose()()() | Releases all resources used by the Stream. (Inherited from Stream.)
 | EndRead(IAsyncResult) | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
 | EndWrite(IAsyncResult) | Ends an asynchronous write operation. (Inherited from Stream.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Flush()()() | Flush the stream. (Overrides Stream.Flush()()().)
 | FlushMode | This property sets the flush behavior on the stream.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | Length | Reading this property always throws a NotImplementedException. (Overrides Stream.Length.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Position | The position of the stream pointer. (Overrides Stream.Position.)
 | Read(array<Byte>[]()[], Int32, Int32) | Read data from the stream. (Overrides Stream.Read(array<Byte>[]()[], Int32, Int32).)
 | ReadByte()()() | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
 | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
 | Seek(Int64, SeekOrigin) | Calling this method always throws a NotImplementedException. (Overrides Stream.Seek(Int64, SeekOrigin).)
 | SetLength(Int64) | Calling this method always throws a NotImplementedException. (Overrides Stream.SetLength(Int64).)
 | Strategy | The ZLIB strategy to be used during compression.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalIn | Returns the total number of bytes input so far.
 | TotalOut | Returns the total number of bytes output so far.
 | UncompressBuffer(array<Byte>[]()[]) | Uncompress a DEFLATE'd byte array into a byte array.
 | UncompressString(array<Byte>[]()[]) | Uncompress a DEFLATE'd byte array into a single string.
 | Write(array<Byte>[]()[], Int32, Int32) | Write data to the stream. (Overrides Stream.Write(array<Byte>[]()[], Int32, Int32).)
 | WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
 | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Remarks

The DeflateStream is a Decorator on a Stream. It adds DEFLATE compression or decompression to any stream.

Using this stream, applications can compress or decompress data via stream Read and Write operations. Either compresssion or decompression can occur through either reading or writing. The compression format used is DEFLATE, which is documented in IETF RFC 1951, "DEFLATE Compressed Data Format Specification version 1.3.".

This class is similar to ZlibStream, except that ZlibStream adds the RFC 1950 - ZLIB framing bytes to a compressed stream when compressing, or expects the RFC1950 framing bytes when decompressing. The DeflateStream does not.

Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Stream
 |  |  | DeflateStream
See Also
ZlibStream
GZipStream


DeflateStream Constructor

DeflateStream Constructor
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► DeflateStream()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | DeflateStream(Stream, CompressionMode) | Create a DeflateStream using the specified CompressionMode.
 | DeflateStream(Stream, CompressionMode, CompressionLevel) | Create a DeflateStream using the specified CompressionMode and the specified CompressionLevel.
 | DeflateStream(Stream, CompressionMode, Boolean) | Create a DeflateStream using the specified CompressionMode, and explicitly specify whether the stream should be left open after Deflation or Inflation.
 | DeflateStream(Stream, CompressionMode, CompressionLevel, Boolean) | Create a DeflateStream using the specified CompressionMode and the specified CompressionLevel, and explicitly specify whether the stream should be left open after Deflation or Inflation.


DeflateStream Constructor (stream, mode)

DeflateStream Constructor (stream, mode)
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► DeflateStream(Stream, CompressionMode)
Keyoti RapidSpell Silverlight
Create a DeflateStream using the specified CompressionMode.
Declaration Syntax
C# Visual Basic Visual C++
public DeflateStream(
    Stream stream,
    CompressionMode mode
)
Public Sub New ( _
    stream As Stream, _
    mode As CompressionMode _
)
public:
DeflateStream(
    Stream^ stream,
    CompressionMode mode
)
Parameters
stream (Stream)
The stream which will be read or written.
mode (CompressionMode)
Indicates whether the DeflateStream will compress or decompress.
Remarks
When mode is CompressionMode.Compress, the DeflateStream will use the default compression level. The "captive" stream will be closed when the DeflateStream is closed.
Examples
This example uses a DeflateStream to compress data from a file, and writes the compressed data to another file.
CopyC#
using (System.IO.Stream input = System.IO.File.OpenRead(fileToCompress))
{
    using (var raw = System.IO.File.Create(fileToCompress + ".deflated"))
    {
        using (Stream compressor = new DeflateStream(raw, CompressionMode.Compress))
        {
            byte[] buffer = new byte[WORKING_BUFFER_SIZE];
            int n;
            while ((n= input.Read(buffer, 0, buffer.Length)) != 0)
            {
                compressor.Write(buffer, 0, n);
            }
        }
    }
}
CopyVB.NET
Using input As Stream = File.OpenRead(fileToCompress)
    Using raw As FileStream = File.Create(fileToCompress & ".deflated")
        Using compressor As Stream = New DeflateStream(raw, CompressionMode.Compress)
            Dim buffer As Byte() = New Byte(4096) {}
            Dim n As Integer = -1
            Do While (n <> 0)
                If (n > 0) Then
                    compressor.Write(buffer, 0, n)
                End If
                n = input.Read(buffer, 0, buffer.Length)
            Loop
        End Using
    End Using
End Using


DeflateStream Constructor (stream, mode, level)

DeflateStream Constructor (stream, mode, level)
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► DeflateStream(Stream, CompressionMode, CompressionLevel)
Keyoti RapidSpell Silverlight
Create a DeflateStream using the specified CompressionMode and the specified CompressionLevel.
Declaration Syntax
C# Visual Basic Visual C++
public DeflateStream(
    Stream stream,
    CompressionMode mode,
    CompressionLevel level
)
Public Sub New ( _
    stream As Stream, _
    mode As CompressionMode, _
    level As CompressionLevel _
)
public:
DeflateStream(
    Stream^ stream,
    CompressionMode mode,
    CompressionLevel level
)
Parameters
stream (Stream)
The stream to be read or written while deflating or inflating.
mode (CompressionMode)
Indicates whether the DeflateStream will compress or decompress.
level (CompressionLevel)
A tuning knob to trade speed for effectiveness.
Remarks

When mode is CompressionMode.Decompress, the level parameter is ignored. The "captive" stream will be closed when the DeflateStream is closed.

Examples
This example uses a DeflateStream to compress data from a file, and writes the compressed data to another file.
CopyC#
using (System.IO.Stream input = System.IO.File.OpenRead(fileToCompress))
{
    using (var raw = System.IO.File.Create(fileToCompress + ".deflated"))
    {
        using (Stream compressor = new DeflateStream(raw,
                                                     CompressionMode.Compress,
                                                     CompressionLevel.BestCompression))
        {
            byte[] buffer = new byte[WORKING_BUFFER_SIZE];
            int n= -1;
            while (n != 0)
            {
                if (n > 0)
                    compressor.Write(buffer, 0, n);
                n= input.Read(buffer, 0, buffer.Length);
            }
        }
    }
}
CopyVB.NET
Using input As Stream = File.OpenRead(fileToCompress)
    Using raw As FileStream = File.Create(fileToCompress & ".deflated")
        Using compressor As Stream = New DeflateStream(raw, CompressionMode.Compress, CompressionLevel.BestCompression)
            Dim buffer As Byte() = New Byte(4096) {}
            Dim n As Integer = -1
            Do While (n <> 0)
                If (n > 0) Then
                    compressor.Write(buffer, 0, n)
                End If
                n = input.Read(buffer, 0, buffer.Length)
            Loop
        End Using
    End Using
End Using


DeflateStream Constructor (stream, mode, level, leaveOpen)

DeflateStream Constructor (stream, mode, level, leaveOpen)
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► DeflateStream(Stream, CompressionMode, CompressionLevel, Boolean)
Keyoti RapidSpell Silverlight
Create a DeflateStream using the specified CompressionMode and the specified CompressionLevel, and explicitly specify whether the stream should be left open after Deflation or Inflation.
Declaration Syntax
C# Visual Basic Visual C++
public DeflateStream(
    Stream stream,
    CompressionMode mode,
    CompressionLevel level,
    bool leaveOpen
)
Public Sub New ( _
    stream As Stream, _
    mode As CompressionMode, _
    level As CompressionLevel, _
    leaveOpen As Boolean _
)
public:
DeflateStream(
    Stream^ stream,
    CompressionMode mode,
    CompressionLevel level,
    bool leaveOpen
)
Parameters
stream (Stream)
The stream which will be read or written.
mode (CompressionMode)
Indicates whether the DeflateStream will compress or decompress.
level (CompressionLevel)
A tuning knob to trade speed for effectiveness.
leaveOpen (Boolean)
true if the application would like the stream to remain open after inflation/deflation.
Remarks

When mode is CompressionMode.Decompress, the level parameter is ignored.

This constructor allows the application to request that the captive stream remain open after the deflation or inflation occurs. By default, after Close() is called on the stream, the captive stream is also closed. In some cases this is not desired, for example if the stream is a MemoryStream that will be re-read after compression. Specify true for the leaveOpen parameter to leave the stream open.

Examples
This example shows how to use a DeflateStream to compress data from a file, and store the compressed data into another file.
CopyC#
using (var output = System.IO.File.Create(fileToCompress + ".deflated"))
{
    using (System.IO.Stream input = System.IO.File.OpenRead(fileToCompress))
    {
        using (Stream compressor = new DeflateStream(output, CompressionMode.Compress, CompressionLevel.BestCompression, true))
        {
            byte[] buffer = new byte[WORKING_BUFFER_SIZE];
            int n= -1;
            while (n != 0)
            {
                if (n > 0)
                    compressor.Write(buffer, 0, n);
                n= input.Read(buffer, 0, buffer.Length);
            }
        }
    }
    // can write additional data to the output stream here
}
CopyVB.NET
Using output As FileStream = File.Create(fileToCompress & ".deflated")
    Using input As Stream = File.OpenRead(fileToCompress)
        Using compressor As Stream = New DeflateStream(output, CompressionMode.Compress, CompressionLevel.BestCompression, True)
            Dim buffer As Byte() = New Byte(4096) {}
            Dim n As Integer = -1
            Do While (n <> 0)
                If (n > 0) Then
                    compressor.Write(buffer, 0, n)
                End If
                n = input.Read(buffer, 0, buffer.Length)
            Loop
        End Using
    End Using
    ' can write additional data to the output stream here.
End Using


DeflateStream Constructor (stream, mode, leaveOpen)

DeflateStream Constructor (stream, mode, leaveOpen)
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► DeflateStream(Stream, CompressionMode, Boolean)
Keyoti RapidSpell Silverlight
Create a DeflateStream using the specified CompressionMode, and explicitly specify whether the stream should be left open after Deflation or Inflation.
Declaration Syntax
C# Visual Basic Visual C++
public DeflateStream(
    Stream stream,
    CompressionMode mode,
    bool leaveOpen
)
Public Sub New ( _
    stream As Stream, _
    mode As CompressionMode, _
    leaveOpen As Boolean _
)
public:
DeflateStream(
    Stream^ stream,
    CompressionMode mode,
    bool leaveOpen
)
Parameters
stream (Stream)
The stream which will be read or written. This is called the "captive" stream in other places in this documentation.
mode (CompressionMode)
Indicates whether the DeflateStream will compress or decompress.
leaveOpen (Boolean)
true if the application would like the stream to remain open after inflation/deflation.
Remarks

This constructor allows the application to request that the captive stream remain open after the deflation or inflation occurs. By default, after Close() is called on the stream, the captive stream is also closed. In some cases this is not desired, for example if the stream is a memory stream that will be re-read after compression. Specify true for the leaveOpen parameter to leave the stream open.

The DeflateStream will use the default compression level.

See the other overloads of this constructor for example code.


BufferSize Property

BufferSize Property
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► BufferSize
Keyoti RapidSpell Silverlight
The size of the working buffer for the compression codec.
Declaration Syntax
C# Visual Basic Visual C++
public int BufferSize { get; set; }
Public Property BufferSize As Integer
public:
property int BufferSize {
    int get ();
    void set (int value);
}
Remarks

The working buffer is used for all stream operations. The default size is 1024 bytes. The minimum size is 128 bytes. You may get better performance with a larger buffer. Then again, you might not. You would have to test it.

Set this before the first call to Read() or Write() on the stream. If you try to set it afterwards, it will throw.


CanRead Property

CanRead Property
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► CanRead
Keyoti RapidSpell Silverlight
Indicates whether the stream can be read.
Declaration Syntax
C# Visual Basic Visual C++
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
public:
virtual property bool CanRead {
    bool get () override;
}
Remarks
The return value depends on whether the captive stream supports reading.


CanSeek Property

CanSeek Property
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► CanSeek
Keyoti RapidSpell Silverlight
Indicates whether the stream supports Seek operations.
Declaration Syntax
C# Visual Basic Visual C++
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
public:
virtual property bool CanSeek {
    bool get () override;
}
Remarks
Always returns false.


CanWrite Property

CanWrite Property
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► CanWrite
Keyoti RapidSpell Silverlight
Indicates whether the stream can be written.
Declaration Syntax
C# Visual Basic Visual C++
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
public:
virtual property bool CanWrite {
    bool get () override;
}
Remarks
The return value depends on whether the captive stream supports writing.


CompressBuffer Method (b)

CompressBuffer Method (b)
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► CompressBuffer(array<Byte>[]()[])
Keyoti RapidSpell Silverlight
Compress a byte array into a new byte array using DEFLATE.
Declaration Syntax
C# Visual Basic Visual C++
public static byte[] CompressBuffer(
    byte[] b
)
Public Shared Function CompressBuffer ( _
    b As Byte() _
) As Byte()
public:
static array<unsigned char>^ CompressBuffer(
    array<unsigned char>^ b
)
Parameters
b (array< Byte >[]()[])
A buffer to compress.
Return Value
The data in compressed form
Remarks
Uncompress it with UncompressBuffer(array<Byte>[]()[]).
See Also
DeflateStream.CompressString(string)
DeflateStream.UncompressBuffer(byte[])
GZipStream.CompressBuffer(byte[])
ZlibStream.CompressBuffer(byte[])


CompressString Method (s)

CompressString Method (s)
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► CompressString(String)
Keyoti RapidSpell Silverlight
Compress a string into a byte array using DEFLATE (RFC 1951).
Declaration Syntax
C# Visual Basic Visual C++
public static byte[] CompressString(
    string s
)
Public Shared Function CompressString ( _
    s As String _
) As Byte()
public:
static array<unsigned char>^ CompressString(
    String^ s
)
Parameters
s (String)
A string to compress. The string will first be encoded using UTF8, then compressed.
Return Value
The string in compressed form
Remarks
Uncompress it with UncompressString(array<Byte>[]()[]).
See Also
DeflateStream.UncompressString(byte[])
DeflateStream.CompressBuffer(byte[])
GZipStream.CompressString(string)
ZlibStream.CompressString(string)


Dispose Method (disposing)

Dispose Method (disposing)
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► Dispose(Boolean)
Keyoti RapidSpell Silverlight
Dispose the stream.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
Remarks
This may or may not result in a Close() call on the captive stream. See the constructors that have a leaveOpen parameter for more information.


Flush Method

Flush Method
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► Flush()()()
Keyoti RapidSpell Silverlight
Flush the stream.
Declaration Syntax
C# Visual Basic Visual C++
public override void Flush()
Public Overrides Sub Flush
public:
virtual void Flush() override


FlushMode Property

FlushMode Property
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► FlushMode
Keyoti RapidSpell Silverlight
This property sets the flush behavior on the stream.
Declaration Syntax
C# Visual Basic Visual C++
public virtual FlushType FlushMode { get; set; }
Public Overridable Property FlushMode As FlushType
public:
virtual property FlushType FlushMode {
    FlushType get ();
    void set (FlushType value);
}
Remarks
See the ZLIB documentation for the meaning of the flush behavior.


Length Property

Length Property
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► Length
Keyoti RapidSpell Silverlight
Reading this property always throws a NotImplementedException.
Declaration Syntax
C# Visual Basic Visual C++
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
public:
virtual property long long Length {
    long long get () override;
}


Position Property

Position Property
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► Position
Keyoti RapidSpell Silverlight
The position of the stream pointer.
Declaration Syntax
C# Visual Basic Visual C++
public override long Position { get; set; }
Public Overrides Property Position As Long
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}
Remarks
Setting this property always throws a NotImplementedException. Reading will return the total bytes written out, if used in writing, or the total bytes read in, if used in reading. The count may refer to compressed bytes or uncompressed bytes, depending on how you've used the stream.


Read Method (buffer, offset, count)

Read Method (buffer, offset, count)
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► Read(array<Byte>[]()[], Int32, Int32)
Keyoti RapidSpell Silverlight
Read data from the stream.
Declaration Syntax
C# Visual Basic Visual C++
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Function Read ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
) As Integer
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
Parameters
buffer (array< Byte >[]()[])
The buffer into which the read data should be placed.
offset (Int32)
the offset within that data array to put the first byte read.
count (Int32)
the number of bytes to read.
Return Value
the number of bytes actually read
Remarks

If you wish to use the DeflateStream to compress data while reading, you can create a DeflateStream with CompressionMode.Compress, providing an uncompressed data stream. Then call Read() on that DeflateStream, and the data read will be compressed as you read. If you wish to use the DeflateStream to decompress data while reading, you can create a DeflateStream with CompressionMode.Decompress, providing a readable compressed data stream. Then call Read() on that DeflateStream, and the data read will be decompressed as you read.

A DeflateStream can be used for Read() or Write(), but not both.


Seek Method (offset, origin)

Seek Method (offset, origin)
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► Seek(Int64, SeekOrigin)
Keyoti RapidSpell Silverlight
Calling this method always throws a NotImplementedException.
Declaration Syntax
C# Visual Basic Visual C++
public override long Seek(
    long offset,
    SeekOrigin origin
)
Public Overrides Function Seek ( _
    offset As Long, _
    origin As SeekOrigin _
) As Long
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
Parameters
offset (Int64)
this is irrelevant, since it will always throw!
origin (SeekOrigin)
this is irrelevant, since it will always throw!
Return Value
irrelevant!


SetLength Method (value)

SetLength Method (value)
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► SetLength(Int64)
Keyoti RapidSpell Silverlight
Calling this method always throws a NotImplementedException.
Declaration Syntax
C# Visual Basic Visual C++
public override void SetLength(
    long value
)
Public Overrides Sub SetLength ( _
    value As Long _
)
public:
virtual void SetLength(
    long long value
) override
Parameters
value (Int64)
this is irrelevant, since it will always throw!


Strategy Property

Strategy Property
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► Strategy
Keyoti RapidSpell Silverlight
The ZLIB strategy to be used during compression.
Declaration Syntax
C# Visual Basic Visual C++
public CompressionStrategy Strategy { get; set; }
Public Property Strategy As CompressionStrategy
public:
property CompressionStrategy Strategy {
    CompressionStrategy get ();
    void set (CompressionStrategy value);
}
Remarks
By tweaking this parameter, you may be able to optimize the compression for data with particular characteristics.


TotalIn Property

TotalIn Property
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► TotalIn
Keyoti RapidSpell Silverlight
Returns the total number of bytes input so far.
Declaration Syntax
C# Visual Basic Visual C++
public virtual long TotalIn { get; }
Public Overridable ReadOnly Property TotalIn As Long
public:
virtual property long long TotalIn {
    long long get ();
}


TotalOut Property

TotalOut Property
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► TotalOut
Keyoti RapidSpell Silverlight
Returns the total number of bytes output so far.
Declaration Syntax
C# Visual Basic Visual C++
public virtual long TotalOut { get; }
Public Overridable ReadOnly Property TotalOut As Long
public:
virtual property long long TotalOut {
    long long get ();
}


UncompressBuffer Method (compressed)

UncompressBuffer Method (compressed)
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► UncompressBuffer(array<Byte>[]()[])
Keyoti RapidSpell Silverlight
Uncompress a DEFLATE'd byte array into a byte array.
Declaration Syntax
C# Visual Basic Visual C++
public static byte[] UncompressBuffer(
    byte[] compressed
)
Public Shared Function UncompressBuffer ( _
    compressed As Byte() _
) As Byte()
public:
static array<unsigned char>^ UncompressBuffer(
    array<unsigned char>^ compressed
)
Parameters
compressed (array< Byte >[]()[])
A buffer containing data that has been compressed with DEFLATE.
Return Value
The data in uncompressed form
See Also
DeflateStream.CompressBuffer(byte[])
DeflateStream.UncompressString(byte[])
GZipStream.UncompressBuffer(byte[])
ZlibStream.UncompressBuffer(byte[])


UncompressString Method (compressed)

UncompressString Method (compressed)
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► UncompressString(array<Byte>[]()[])
Keyoti RapidSpell Silverlight
Uncompress a DEFLATE'd byte array into a single string.
Declaration Syntax
C# Visual Basic Visual C++
public static string UncompressString(
    byte[] compressed
)
Public Shared Function UncompressString ( _
    compressed As Byte() _
) As String
public:
static String^ UncompressString(
    array<unsigned char>^ compressed
)
Parameters
compressed (array< Byte >[]()[])
A buffer containing DEFLATE-compressed data.
Return Value
The uncompressed string
See Also
DeflateStream.CompressString(String)
DeflateStream.UncompressBuffer(byte[])
GZipStream.UncompressString(byte[])
ZlibStream.UncompressString(byte[])


Write Method (buffer, offset, count)

Write Method (buffer, offset, count)
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► Write(array<Byte>[]()[], Int32, Int32)
Keyoti RapidSpell Silverlight
Write data to the stream.
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Write ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
)
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
Parameters
buffer (array< Byte >[]()[])
The buffer holding data to write to the stream.
offset (Int32)
the offset within that data array to find the first byte to write.
count (Int32)
the number of bytes to write.
Remarks

If you wish to use the DeflateStream to compress data while writing, you can create a DeflateStream with CompressionMode.Compress, and a writable output stream. Then call Write() on that DeflateStream, providing uncompressed data as input. The data sent to the output stream will be the compressed form of the data written. If you wish to use the DeflateStream to decompress data while writing, you can create a DeflateStream with CompressionMode.Decompress, and a writable output stream. Then call Write() on that stream, providing previously compressed data. The data sent to the output stream will be the decompressed form of the data written.

A DeflateStream can be used for Read() or Write(), but not both.


FlushType Enumeration

FlushType Enumeration
API ► Keyoti.RapidSpell.Compression ► FlushType
Keyoti RapidSpell Silverlight
Describes how to flush the current deflate operation.
Declaration Syntax
C# Visual Basic Visual C++
public enum FlushType
Public Enumeration FlushType
public enum class FlushType
Members
Member | Description
None | No flush at all.
Partial | Closes the current block, but doesn't flush it to the output. Used internally only in hypothetical scenarios. This was supposed to be removed by Zlib, but it is still in use in some edge cases.
Sync | Use this during compression to specify that all pending output should be flushed to the output buffer and the output should be aligned on a byte boundary. You might use this in a streaming communication scenario, so that the decompressor can get all input data available so far. When using this with a ZlibCodec, AvailableBytesIn will be zero after the call if enough output space has been provided before the call. Flushing will degrade compression and so it should be used only when necessary.
Full | Use this during compression to specify that all output should be flushed, as with FlushType.Sync, but also, the compression state should be reset so that decompression can restart from this point if previous compressed data has been damaged or if random access is desired. Using FlushType.Full too often can significantly degrade the compression.
Finish | Signals the end of the compression/decompression stream.
Remarks
The different FlushType values are useful when using a Deflate in a streaming application.


GZipStream Class

GZipStream Class
API ► Keyoti.RapidSpell.Compression ► GZipStream
Keyoti RapidSpell Silverlight
A class for compressing and decompressing GZIP streams.
Declaration Syntax
C# Visual Basic Visual C++
public class GZipStream : Stream
Public Class GZipStream _
    Inherits Stream
public ref class GZipStream : public Stream
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GZipStream(Stream, CompressionMode) | Create a GZipStream using the specified CompressionMode.
 | GZipStream(Stream, CompressionMode, CompressionLevel) | Create a GZipStream using the specified CompressionMode and the specified CompressionLevel.
 | GZipStream(Stream, CompressionMode, Boolean) | Create a GZipStream using the specified CompressionMode, and explicitly specify whether the stream should be left open after Deflation or Inflation.
 | GZipStream(Stream, CompressionMode, CompressionLevel, Boolean) | Create a GZipStream using the specified CompressionMode and the specified CompressionLevel, and explicitly specify whether the stream should be left open after Deflation or Inflation.
 | BeginRead(array<Byte>[]()[], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous read operation. (Inherited from Stream.)
 | BeginWrite(array<Byte>[]()[], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous write operation. (Inherited from Stream.)
 | BufferSize | The size of the working buffer for the compression codec.
 | CanRead | Indicates whether the stream can be read. (Overrides Stream.CanRead.)
 | CanSeek | Indicates whether the stream supports Seek operations. (Overrides Stream.CanSeek.)
 | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
 | CanWrite | Indicates whether the stream can be written. (Overrides Stream.CanWrite.)
 | Close()()() | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. (Inherited from Stream.)
 | Comment | The comment on the GZIP stream.
 | CompressBuffer(array<Byte>[]()[]) | Compress a byte array into a new byte array using GZip.
 | CompressString(String) | Compress a string into a byte array using GZip.
 | Crc32 | The CRC on the GZIP stream.
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateWaitHandle()()() | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
 | Dispose(Boolean) | Dispose the stream. (Overrides Stream.Dispose(Boolean).)
 | Dispose()()() | Releases all resources used by the Stream. (Inherited from Stream.)
 | EndRead(IAsyncResult) | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
 | EndWrite(IAsyncResult) | Ends an asynchronous write operation. (Inherited from Stream.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileName | The FileName for the GZIP stream.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Flush()()() | Flush the stream. (Overrides Stream.Flush()()().)
 | FlushMode | This property sets the flush behavior on the stream.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | LastModified | The last modified time for the GZIP stream.
 | Length | Reading this property always throws a NotImplementedException. (Overrides Stream.Length.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Position | The position of the stream pointer. (Overrides Stream.Position.)
 | Read(array<Byte>[]()[], Int32, Int32) | Read and decompress data from the source stream. (Overrides Stream.Read(array<Byte>[]()[], Int32, Int32).)
 | ReadByte()()() | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
 | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
 | Seek(Int64, SeekOrigin) | Calling this method always throws a NotImplementedException. (Overrides Stream.Seek(Int64, SeekOrigin).)
 | SetLength(Int64) | Calling this method always throws a NotImplementedException. (Overrides Stream.SetLength(Int64).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalIn | Returns the total number of bytes input so far.
 | TotalOut | Returns the total number of bytes output so far.
 | UncompressBuffer(array<Byte>[]()[]) | Uncompress a GZip'ed byte array into a byte array.
 | UncompressString(array<Byte>[]()[]) | Uncompress a GZip'ed byte array into a single string.
 | Write(array<Byte>[]()[], Int32, Int32) | Write data to the stream. (Overrides Stream.Write(array<Byte>[]()[], Int32, Int32).)
 | WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
 | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Remarks

The GZipStream is a Decorator on a Stream. It adds GZIP compression or decompression to any stream.

Like the System.IO.Compression.GZipStream in the .NET Base Class Library, the Keyoti.RapidSpell.Compression.GZipStream can compress while writing, or decompress while reading, but not vice versa. The compression method used is GZIP, which is documented in IETF RFC 1952, "GZIP file format specification version 4.3".

A GZipStream can be used to decompress data (through Read()) or to compress data (through Write()), but not both.

If you wish to use the GZipStream to compress data, you must wrap it around a write-able stream. As you call Write() on the GZipStream, the data will be compressed into the GZIP format. If you want to decompress data, you must wrap the GZipStream around a readable stream that contains an IETF RFC 1952-compliant stream. The data will be decompressed as you call Read() on the GZipStream.

Though the GZIP format allows data from multiple files to be concatenated together, this stream handles only a single segment of GZIP format, typically representing a single file.

This class is similar to ZlibStream and DeflateStream. ZlibStream handles RFC1950-compliant streams. DeflateStream handles RFC1951-compliant streams. This class handles RFC1952-compliant streams.

Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Stream
 |  |  | GZipStream
See Also
DeflateStream
ZlibStream


GZipStream Constructor

GZipStream Constructor
API ► Keyoti.RapidSpell.Compression ► GZipStream ► GZipStream()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | GZipStream(Stream, CompressionMode) | Create a GZipStream using the specified CompressionMode.
 | GZipStream(Stream, CompressionMode, CompressionLevel) | Create a GZipStream using the specified CompressionMode and the specified CompressionLevel.
 | GZipStream(Stream, CompressionMode, Boolean) | Create a GZipStream using the specified CompressionMode, and explicitly specify whether the stream should be left open after Deflation or Inflation.
 | GZipStream(Stream, CompressionMode, CompressionLevel, Boolean) | Create a GZipStream using the specified CompressionMode and the specified CompressionLevel, and explicitly specify whether the stream should be left open after Deflation or Inflation.


GZipStream Constructor (stream, mode)

GZipStream Constructor (stream, mode)
API ► Keyoti.RapidSpell.Compression ► GZipStream ► GZipStream(Stream, CompressionMode)
Keyoti RapidSpell Silverlight
Create a GZipStream using the specified CompressionMode.
Declaration Syntax
C# Visual Basic Visual C++
public GZipStream(
    Stream stream,
    CompressionMode mode
)
Public Sub New ( _
    stream As Stream, _
    mode As CompressionMode _
)
public:
GZipStream(
    Stream^ stream,
    CompressionMode mode
)
Parameters
stream (Stream)
The stream which will be read or written.
mode (CompressionMode)
Indicates whether the GZipStream will compress or decompress.
Remarks

When mode is CompressionMode.Compress, the GZipStream will use the default compression level.

As noted in the class documentation, the CompressionMode (Compress or Decompress) also establishes the "direction" of the stream. A GZipStream with CompressionMode.Compress works only through Write(). A GZipStream with CompressionMode.Decompress works only through Read().

Examples
This example shows how to use a GZipStream to compress data.
CopyC#
using (System.IO.Stream input = System.IO.File.OpenRead(fileToCompress))
{
    using (var raw = System.IO.File.Create(outputFile))
    {
        using (Stream compressor = new GZipStream(raw, CompressionMode.Compress))
        {
            byte[] buffer = new byte[WORKING_BUFFER_SIZE];
            int n;
            while ((n= input.Read(buffer, 0, buffer.Length)) != 0)
            {
                compressor.Write(buffer, 0, n);
            }
        }
    }
}
CopyVB.NET
Dim outputFile As String = (fileToCompress & ".compressed")
Using input As Stream = File.OpenRead(fileToCompress)
    Using raw As FileStream = File.Create(outputFile)
    Using compressor As Stream = New GZipStream(raw, CompressionMode.Compress)
        Dim buffer As Byte() = New Byte(4096) {}
        Dim n As Integer = -1
        Do While (n <> 0)
            If (n > 0) Then
                compressor.Write(buffer, 0, n)
            End If
            n = input.Read(buffer, 0, buffer.Length)
        Loop
    End Using
    End Using
End Using
Examples
This example shows how to use a GZipStream to uncompress a file.
CopyC#
private void GunZipFile(string filename)
{
    if (!filename.EndsWith(".gz))
        throw new ArgumentException("filename");
    var DecompressedFile = filename.Substring(0,filename.Length-3);
    byte[] working = new byte[WORKING_BUFFER_SIZE];
    int n= 1;
    using (System.IO.Stream input = System.IO.File.OpenRead(filename))
    {
        using (Stream decompressor= new Keyoti.RapidSpell.Compression.GZipStream(input, CompressionMode.Decompress, true))
        {
            using (var output = System.IO.File.Create(DecompressedFile))
            {
                while (n !=0)
                {
                    n= decompressor.Read(working, 0, working.Length);
                    if (n > 0)
                    {
                        output.Write(working, 0, n);
                    }
                }
            }
        }
    }
}
CopyVB.NET
Private Sub GunZipFile(ByVal filename as String)
    If Not (filename.EndsWith(".gz)) Then
        Throw New ArgumentException("filename")
    End If
    Dim DecompressedFile as String = filename.Substring(0,filename.Length-3)
    Dim working(WORKING_BUFFER_SIZE) as Byte
    Dim n As Integer = 1
    Using input As Stream = File.OpenRead(filename)
        Using decompressor As Stream = new Keyoti.RapidSpell.Compression.GZipStream(input, CompressionMode.Decompress, True)
            Using output As Stream = File.Create(UncompressedFile)
                Do
                    n= decompressor.Read(working, 0, working.Length)
                    If n > 0 Then
                        output.Write(working, 0, n)
                    End IF
                Loop While (n  > 0)
            End Using
        End Using
    End Using
End Sub


GZipStream Constructor (stream, mode, level)

GZipStream Constructor (stream, mode, level)
API ► Keyoti.RapidSpell.Compression ► GZipStream ► GZipStream(Stream, CompressionMode, CompressionLevel)
Keyoti RapidSpell Silverlight
Create a GZipStream using the specified CompressionMode and the specified CompressionLevel.
Declaration Syntax
C# Visual Basic Visual C++
public GZipStream(
    Stream stream,
    CompressionMode mode,
    CompressionLevel level
)
Public Sub New ( _
    stream As Stream, _
    mode As CompressionMode, _
    level As CompressionLevel _
)
public:
GZipStream(
    Stream^ stream,
    CompressionMode mode,
    CompressionLevel level
)
Parameters
stream (Stream)
The stream to be read or written while deflating or inflating.
mode (CompressionMode)
Indicates whether the GZipStream will compress or decompress.
level (CompressionLevel)
A tuning knob to trade speed for effectiveness.
Remarks

The CompressionMode (Compress or Decompress) also establishes the "direction" of the stream. A GZipStream with CompressionMode.Compress works only through Write(). A GZipStream with CompressionMode.Decompress works only through Read().

Examples
This example shows how to use a GZipStream to compress a file into a .gz file.
CopyC#
using (System.IO.Stream input = System.IO.File.OpenRead(fileToCompress))
{
    using (var raw = System.IO.File.Create(fileToCompress + ".gz"))
    {
        using (Stream compressor = new GZipStream(raw,
                                                  CompressionMode.Compress,
                                                  CompressionLevel.BestCompression))
        {
            byte[] buffer = new byte[WORKING_BUFFER_SIZE];
            int n;
            while ((n= input.Read(buffer, 0, buffer.Length)) != 0)
            {
                compressor.Write(buffer, 0, n);
            }
        }
    }
}
CopyVB.NET
Using input As Stream = File.OpenRead(fileToCompress)
    Using raw As FileStream = File.Create(fileToCompress & ".gz")
        Using compressor As Stream = New GZipStream(raw, CompressionMode.Compress, CompressionLevel.BestCompression)
            Dim buffer As Byte() = New Byte(4096) {}
            Dim n As Integer = -1
            Do While (n <> 0)
                If (n > 0) Then
                    compressor.Write(buffer, 0, n)
                End If
                n = input.Read(buffer, 0, buffer.Length)
            Loop
        End Using
    End Using
End Using


GZipStream Constructor (stream, mode, level, leaveOpen)

GZipStream Constructor (stream, mode, level, leaveOpen)
API ► Keyoti.RapidSpell.Compression ► GZipStream ► GZipStream(Stream, CompressionMode, CompressionLevel, Boolean)
Keyoti RapidSpell Silverlight
Create a GZipStream using the specified CompressionMode and the specified CompressionLevel, and explicitly specify whether the stream should be left open after Deflation or Inflation.
Declaration Syntax
C# Visual Basic Visual C++
public GZipStream(
    Stream stream,
    CompressionMode mode,
    CompressionLevel level,
    bool leaveOpen
)
Public Sub New ( _
    stream As Stream, _
    mode As CompressionMode, _
    level As CompressionLevel, _
    leaveOpen As Boolean _
)
public:
GZipStream(
    Stream^ stream,
    CompressionMode mode,
    CompressionLevel level,
    bool leaveOpen
)
Parameters
stream (Stream)
The stream which will be read or written.
mode (CompressionMode)
Indicates whether the GZipStream will compress or decompress.
level (CompressionLevel)
A tuning knob to trade speed for effectiveness.
leaveOpen (Boolean)
true if the application would like the stream to remain open after inflation/deflation.
Remarks

This constructor allows the application to request that the captive stream remain open after the deflation or inflation occurs. By default, after Close() is called on the stream, the captive stream is also closed. In some cases this is not desired, for example if the stream is a memory stream that will be re-read after compressed data has been written to it. Specify true for the leaveOpen parameter to leave the stream open.

As noted in the class documentation, the CompressionMode (Compress or Decompress) also establishes the "direction" of the stream. A GZipStream with CompressionMode.Compress works only through Write(). A GZipStream with CompressionMode.Decompress works only through Read().

Examples
This example shows how to use a GZipStream to compress data.
CopyC#
using (System.IO.Stream input = System.IO.File.OpenRead(fileToCompress))
{
    using (var raw = System.IO.File.Create(outputFile))
    {
        using (Stream compressor = new GZipStream(raw, CompressionMode.Compress, CompressionLevel.BestCompression, true))
        {
            byte[] buffer = new byte[WORKING_BUFFER_SIZE];
            int n;
            while ((n= input.Read(buffer, 0, buffer.Length)) != 0)
            {
                compressor.Write(buffer, 0, n);
            }
        }
    }
}
CopyVB.NET
Dim outputFile As String = (fileToCompress & ".compressed")
Using input As Stream = File.OpenRead(fileToCompress)
    Using raw As FileStream = File.Create(outputFile)
    Using compressor As Stream = New GZipStream(raw, CompressionMode.Compress, CompressionLevel.BestCompression, True)
        Dim buffer As Byte() = New Byte(4096) {}
        Dim n As Integer = -1
        Do While (n <> 0)
            If (n > 0) Then
                compressor.Write(buffer, 0, n)
            End If
            n = input.Read(buffer, 0, buffer.Length)
        Loop
    End Using
    End Using
End Using


GZipStream Constructor (stream, mode, leaveOpen)

GZipStream Constructor (stream, mode, leaveOpen)
API ► Keyoti.RapidSpell.Compression ► GZipStream ► GZipStream(Stream, CompressionMode, Boolean)
Keyoti RapidSpell Silverlight
Create a GZipStream using the specified CompressionMode, and explicitly specify whether the stream should be left open after Deflation or Inflation.
Declaration Syntax
C# Visual Basic Visual C++
public GZipStream(
    Stream stream,
    CompressionMode mode,
    bool leaveOpen
)
Public Sub New ( _
    stream As Stream, _
    mode As CompressionMode, _
    leaveOpen As Boolean _
)
public:
GZipStream(
    Stream^ stream,
    CompressionMode mode,
    bool leaveOpen
)
Parameters
stream (Stream)
The stream which will be read or written. This is called the "captive" stream in other places in this documentation.
mode (CompressionMode)
Indicates whether the GZipStream will compress or decompress.
leaveOpen (Boolean)
true if the application would like the base stream to remain open after inflation/deflation.
Remarks

This constructor allows the application to request that the captive stream remain open after the deflation or inflation occurs. By default, after Close() is called on the stream, the captive stream is also closed. In some cases this is not desired, for example if the stream is a memory stream that will be re-read after compressed data has been written to it. Specify true for the leaveOpen parameter to leave the stream open.

The CompressionMode (Compress or Decompress) also establishes the "direction" of the stream. A GZipStream with CompressionMode.Compress works only through Write(). A GZipStream with CompressionMode.Decompress works only through Read().

The GZipStream will use the default compression level. If you want to specify the compression level, see GZipStream(Stream, CompressionMode, CompressionLevel, Boolean).

See the other overloads of this constructor for example code.


BufferSize Property

BufferSize Property
API ► Keyoti.RapidSpell.Compression ► GZipStream ► BufferSize
Keyoti RapidSpell Silverlight
The size of the working buffer for the compression codec.
Declaration Syntax
C# Visual Basic Visual C++
public int BufferSize { get; set; }
Public Property BufferSize As Integer
public:
property int BufferSize {
    int get ();
    void set (int value);
}
Remarks

The working buffer is used for all stream operations. The default size is 1024 bytes. The minimum size is 128 bytes. You may get better performance with a larger buffer. Then again, you might not. You would have to test it.

Set this before the first call to Read() or Write() on the stream. If you try to set it afterwards, it will throw.


CanRead Property

CanRead Property
API ► Keyoti.RapidSpell.Compression ► GZipStream ► CanRead
Keyoti RapidSpell Silverlight
Indicates whether the stream can be read.
Declaration Syntax
C# Visual Basic Visual C++
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
public:
virtual property bool CanRead {
    bool get () override;
}
Remarks
The return value depends on whether the captive stream supports reading.


CanSeek Property

CanSeek Property
API ► Keyoti.RapidSpell.Compression ► GZipStream ► CanSeek
Keyoti RapidSpell Silverlight
Indicates whether the stream supports Seek operations.
Declaration Syntax
C# Visual Basic Visual C++
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
public:
virtual property bool CanSeek {
    bool get () override;
}
Remarks
Always returns false.


CanWrite Property

CanWrite Property
API ► Keyoti.RapidSpell.Compression ► GZipStream ► CanWrite
Keyoti RapidSpell Silverlight
Indicates whether the stream can be written.
Declaration Syntax
C# Visual Basic Visual C++
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
public:
virtual property bool CanWrite {
    bool get () override;
}
Remarks
The return value depends on whether the captive stream supports writing.


Comment Property

Comment Property
API ► Keyoti.RapidSpell.Compression ► GZipStream ► Comment
Keyoti RapidSpell Silverlight
The comment on the GZIP stream.
Declaration Syntax
C# Visual Basic Visual C++
public string Comment { get; set; }
Public Property Comment As String
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}
Remarks

The GZIP format allows for each file to optionally have an associated comment stored with the file. The comment is encoded with the ISO-8859-1 code page. To include a comment in a GZIP stream you create, set this property before calling Write() for the first time on the GZipStream.

When using GZipStream to decompress, you can retrieve this property after the first call to Read(). If no comment has been set in the GZIP bytestream, the Comment property will return null (Nothing in VB).


CompressBuffer Method (b)

CompressBuffer Method (b)
API ► Keyoti.RapidSpell.Compression ► GZipStream ► CompressBuffer(array<Byte>[]()[])
Keyoti RapidSpell Silverlight
Compress a byte array into a new byte array using GZip.
Declaration Syntax
C# Visual Basic Visual C++
public static byte[] CompressBuffer(
    byte[] b
)
Public Shared Function CompressBuffer ( _
    b As Byte() _
) As Byte()
public:
static array<unsigned char>^ CompressBuffer(
    array<unsigned char>^ b
)
Parameters
b (array< Byte >[]()[])
A buffer to compress.
Return Value
The data in compressed form
Remarks
Uncompress it with UncompressBuffer(array<Byte>[]()[]).
See Also
CompressString(String)
UncompressBuffer(array<Byte>[]()[])


CompressString Method (s)

CompressString Method (s)
API ► Keyoti.RapidSpell.Compression ► GZipStream ► CompressString(String)
Keyoti RapidSpell Silverlight
Compress a string into a byte array using GZip.
Declaration Syntax
C# Visual Basic Visual C++
public static byte[] CompressString(
    string s
)
Public Shared Function CompressString ( _
    s As String _
) As Byte()
public:
static array<unsigned char>^ CompressString(
    String^ s
)
Parameters
s (String)
A string to compress. The string will first be encoded using UTF8, then compressed.
Return Value
The string in compressed form
Remarks
Uncompress it with UncompressString(array<Byte>[]()[]).
See Also
UncompressString(array<Byte>[]()[])
CompressBuffer(array<Byte>[]()[])


Crc32 Property

Crc32 Property
API ► Keyoti.RapidSpell.Compression ► GZipStream ► Crc32
Keyoti RapidSpell Silverlight
The CRC on the GZIP stream.
Declaration Syntax
C# Visual Basic Visual C++
public int Crc32 { get; }
Public ReadOnly Property Crc32 As Integer
public:
property int Crc32 {
    int get ();
}
Remarks
This is used for internal error checking. You probably don't need to look at this property.


Dispose Method (disposing)

Dispose Method (disposing)
API ► Keyoti.RapidSpell.Compression ► GZipStream ► Dispose(Boolean)
Keyoti RapidSpell Silverlight
Dispose the stream.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
Remarks
This may or may not result in a Close() call on the captive stream. See the doc on constructors that take a leaveOpen parameter for more information.


FileName Property

FileName Property
API ► Keyoti.RapidSpell.Compression ► GZipStream ► FileName
Keyoti RapidSpell Silverlight
The FileName for the GZIP stream.
Declaration Syntax
C# Visual Basic Visual C++
public string FileName { get; set; }
Public Property FileName As String
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
Remarks

The GZIP format optionally allows each file to have an associated filename. When compressing data (through Write()), set this FileName before calling Write() the first time on the GZipStream. The actual filename is encoded into the GZIP bytestream with the ISO-8859-1 code page, according to RFC 1952. It is the application's responsibility to insure that the FileName can be encoded and decoded correctly with this code page.

When decompressing (through Read()), you can retrieve this value any time after the first Read(). In the case where there was no filename encoded into the GZIP bytestream, the property will return null (Nothing in VB).


Flush Method

Flush Method
API ► Keyoti.RapidSpell.Compression ► GZipStream ► Flush()()()
Keyoti RapidSpell Silverlight
Flush the stream.
Declaration Syntax
C# Visual Basic Visual C++
public override void Flush()
Public Overrides Sub Flush
public:
virtual void Flush() override


FlushMode Property

FlushMode Property
API ► Keyoti.RapidSpell.Compression ► GZipStream ► FlushMode
Keyoti RapidSpell Silverlight
This property sets the flush behavior on the stream.
Declaration Syntax
C# Visual Basic Visual C++
public virtual FlushType FlushMode { get; set; }
Public Overridable Property FlushMode As FlushType
public:
virtual property FlushType FlushMode {
    FlushType get ();
    void set (FlushType value);
}


LastModified Field

LastModified Field
API ► Keyoti.RapidSpell.Compression ► GZipStream ► LastModified
Keyoti RapidSpell Silverlight
The last modified time for the GZIP stream.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime LastModified
Public LastModified As DateTime
public:
DateTime LastModified
Remarks
GZIP allows the storage of a last modified time with each GZIP entry. When compressing data, you can set this before the first call to Write(). When decompressing, you can retrieve this value any time after the first call to Read().


Length Property

Length Property
API ► Keyoti.RapidSpell.Compression ► GZipStream ► Length
Keyoti RapidSpell Silverlight
Reading this property always throws a NotImplementedException.
Declaration Syntax
C# Visual Basic Visual C++
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
public:
virtual property long long Length {
    long long get () override;
}


Position Property

Position Property
API ► Keyoti.RapidSpell.Compression ► GZipStream ► Position
Keyoti RapidSpell Silverlight
The position of the stream pointer.
Declaration Syntax
C# Visual Basic Visual C++
public override long Position { get; set; }
Public Overrides Property Position As Long
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}
Remarks
Setting this property always throws a NotImplementedException. Reading will return the total bytes written out, if used in writing, or the total bytes read in, if used in reading. The count may refer to compressed bytes or uncompressed bytes, depending on how you've used the stream.


Read Method (buffer, offset, count)

Read Method (buffer, offset, count)
API ► Keyoti.RapidSpell.Compression ► GZipStream ► Read(array<Byte>[]()[], Int32, Int32)
Keyoti RapidSpell Silverlight
Read and decompress data from the source stream.
Declaration Syntax
C# Visual Basic Visual C++
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Function Read ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
) As Integer
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
Parameters
buffer (array< Byte >[]()[])
The buffer into which the decompressed data should be placed.
offset (Int32)
the offset within that data array to put the first byte read.
count (Int32)
the number of bytes to read.
Return Value
the number of bytes actually read
Remarks
With a GZipStream, decompression is done through reading.
Examples
CopyC#
byte[] working = new byte[WORKING_BUFFER_SIZE];
using (System.IO.Stream input = System.IO.File.OpenRead(_CompressedFile))
{
    using (Stream decompressor= new Keyoti.RapidSpell.Compression.GZipStream(input, CompressionMode.Decompress, true))
    {
        using (var output = System.IO.File.Create(_DecompressedFile))
        {
            int n;
            while ((n= decompressor.Read(working, 0, working.Length)) !=0)
            {
                output.Write(working, 0, n);
            }
        }
    }
}


Seek Method (offset, origin)

Seek Method (offset, origin)
API ► Keyoti.RapidSpell.Compression ► GZipStream ► Seek(Int64, SeekOrigin)
Keyoti RapidSpell Silverlight
Calling this method always throws a NotImplementedException.
Declaration Syntax
C# Visual Basic Visual C++
public override long Seek(
    long offset,
    SeekOrigin origin
)
Public Overrides Function Seek ( _
    offset As Long, _
    origin As SeekOrigin _
) As Long
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
Parameters
offset (Int64)
irrelevant; it will always throw!
origin (SeekOrigin)
irrelevant; it will always throw!
Return Value
irrelevant!


SetLength Method (value)

SetLength Method (value)
API ► Keyoti.RapidSpell.Compression ► GZipStream ► SetLength(Int64)
Keyoti RapidSpell Silverlight
Calling this method always throws a NotImplementedException.
Declaration Syntax
C# Visual Basic Visual C++
public override void SetLength(
    long value
)
Public Overrides Sub SetLength ( _
    value As Long _
)
public:
virtual void SetLength(
    long long value
) override
Parameters
value (Int64)
irrelevant; this method will always throw!


TotalIn Property

TotalIn Property
API ► Keyoti.RapidSpell.Compression ► GZipStream ► TotalIn
Keyoti RapidSpell Silverlight
Returns the total number of bytes input so far.
Declaration Syntax
C# Visual Basic Visual C++
public virtual long TotalIn { get; }
Public Overridable ReadOnly Property TotalIn As Long
public:
virtual property long long TotalIn {
    long long get ();
}


TotalOut Property

TotalOut Property
API ► Keyoti.RapidSpell.Compression ► GZipStream ► TotalOut
Keyoti RapidSpell Silverlight
Returns the total number of bytes output so far.
Declaration Syntax
C# Visual Basic Visual C++
public virtual long TotalOut { get; }
Public Overridable ReadOnly Property TotalOut As Long
public:
virtual property long long TotalOut {
    long long get ();
}


UncompressBuffer Method (compressed)

UncompressBuffer Method (compressed)
API ► Keyoti.RapidSpell.Compression ► GZipStream ► UncompressBuffer(array<Byte>[]()[])
Keyoti RapidSpell Silverlight
Uncompress a GZip'ed byte array into a byte array.
Declaration Syntax
C# Visual Basic Visual C++
public static byte[] UncompressBuffer(
    byte[] compressed
)
Public Shared Function UncompressBuffer ( _
    compressed As Byte() _
) As Byte()
public:
static array<unsigned char>^ UncompressBuffer(
    array<unsigned char>^ compressed
)
Parameters
compressed (array< Byte >[]()[])
A buffer containing data that has been compressed with GZip.
Return Value
The data in uncompressed form
See Also
CompressBuffer(array<Byte>[]()[])
UncompressString(array<Byte>[]()[])


UncompressString Method (compressed)

UncompressString Method (compressed)
API ► Keyoti.RapidSpell.Compression ► GZipStream ► UncompressString(array<Byte>[]()[])
Keyoti RapidSpell Silverlight
Uncompress a GZip'ed byte array into a single string.
Declaration Syntax
C# Visual Basic Visual C++
public static string UncompressString(
    byte[] compressed
)
Public Shared Function UncompressString ( _
    compressed As Byte() _
) As String
public:
static String^ UncompressString(
    array<unsigned char>^ compressed
)
Parameters
compressed (array< Byte >[]()[])
A buffer containing GZIP-compressed data.
Return Value
The uncompressed string
See Also
CompressString(String)
UncompressBuffer(array<Byte>[]()[])


Write Method (buffer, offset, count)

Write Method (buffer, offset, count)
API ► Keyoti.RapidSpell.Compression ► GZipStream ► Write(array<Byte>[]()[], Int32, Int32)
Keyoti RapidSpell Silverlight
Write data to the stream.
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Write ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
)
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
Parameters
buffer (array< Byte >[]()[])
The buffer holding data to write to the stream.
offset (Int32)
the offset within that data array to find the first byte to write.
count (Int32)
the number of bytes to write.
Remarks

If you wish to use the GZipStream to compress data while writing, you can create a GZipStream with CompressionMode.Compress, and a writable output stream. Then call Write() on that GZipStream, providing uncompressed data as input. The data sent to the output stream will be the compressed form of the data written.

A GZipStream can be used for Read() or Write(), but not both. Writing implies compression. Reading implies decompression.


ZlibCodec Class

ZlibCodec Class
API ► Keyoti.RapidSpell.Compression ► ZlibCodec
Keyoti RapidSpell Silverlight
Encoder and Decoder for ZLIB and DEFLATE (IETF RFC1950 and RFC1951).
Declaration Syntax
C# Visual Basic Visual C++
public sealed class ZlibCodec
Public NotInheritable Class ZlibCodec
public ref class ZlibCodec sealed
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZlibCodec()()() | Create a ZlibCodec.
 | ZlibCodec(CompressionMode) | Create a ZlibCodec that either compresses or decompresses.
 | Adler32 | The Adler32 checksum on the data transferred through the codec so far. You probably don't need to look at this.
 | AvailableBytesIn | The number of bytes available in the InputBuffer, starting at NextIn.
 | AvailableBytesOut | The number of bytes available in the OutputBuffer, starting at NextOut.
 | CompressLevel | The compression level to use in this codec. Useful only in compression mode.
 | Deflate(FlushType) | Deflate one batch of data.
 | EndDeflate()()() | End a deflation session.
 | EndInflate()()() | Ends an inflation session.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Inflate(FlushType) | Inflate the data in the InputBuffer, placing the result in the OutputBuffer.
 | InitializeDeflate()()() | Initialize the ZlibCodec for deflation operation.
 | InitializeDeflate(CompressionLevel) | Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel.
 | InitializeDeflate(CompressionLevel, Boolean) | Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel, and the explicit flag governing whether to emit an RFC1950 header byte pair.
 | InitializeDeflate(CompressionLevel, Int32) | Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel, and the specified number of window bits.
 | InitializeDeflate(CompressionLevel, Int32, Boolean) | Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel, the specified number of window bits, and the explicit flag governing whether to emit an RFC1950 header byte pair.
 | InitializeInflate()()() | Initialize the inflation state.
 | InitializeInflate(Boolean) | Initialize the inflation state with an explicit flag to govern the handling of RFC1950 header bytes.
 | InitializeInflate(Int32) | Initialize the ZlibCodec for inflation, with the specified number of window bits.
 | InitializeInflate(Int32, Boolean) | Initialize the inflation state with an explicit flag to govern the handling of RFC1950 header bytes.
 | InputBuffer | The buffer from which data is taken.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | used for diagnostics, when something goes wrong!
 | NextIn | An index into the InputBuffer array, indicating where to start reading.
 | NextOut | An index into the OutputBuffer array, indicating where to start writing.
 | OutputBuffer | Buffer to store output data.
 | ResetDeflate()()() | Reset a codec for another deflation session.
 | SetDeflateParams(CompressionLevel, CompressionStrategy) | Set the CompressionStrategy and CompressionLevel for a deflation session.
 | SetDictionary(array<Byte>[]()[]) | Set the dictionary to be used for either Inflation or Deflation.
 | Strategy | The compression strategy to use.
 | SyncInflate()()() | I don't know what this does!
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalBytesIn | Total number of bytes read so far, through all calls to Inflate()/Deflate().
 | TotalBytesOut | Total number of bytes written to the output so far, through all calls to Inflate()/Deflate().
 | WindowBits | The number of Window Bits to use.
Remarks
This class compresses and decompresses data according to the Deflate algorithm and optionally, the ZLIB format, as documented in RFC 1950 - ZLIB and RFC 1951 - DEFLATE.
Inheritance Hierarchy
Object
ZlibCodec


ZlibCodec Constructor

ZlibCodec Constructor
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► ZlibCodec()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | ZlibCodec()()() | Create a ZlibCodec.
 | ZlibCodec(CompressionMode) | Create a ZlibCodec that either compresses or decompresses.


ZlibCodec Constructor

ZlibCodec Constructor
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► ZlibCodec()()()
Keyoti RapidSpell Silverlight
Create a ZlibCodec.
Declaration Syntax
C# Visual Basic Visual C++
public ZlibCodec()
Public Sub New
public:
ZlibCodec()
Remarks
If you use this default constructor, you will later have to explicitly call InitializeInflate() or InitializeDeflate() before using the ZlibCodec to compress or decompress.


ZlibCodec Constructor (mode)

ZlibCodec Constructor (mode)
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► ZlibCodec(CompressionMode)
Keyoti RapidSpell Silverlight
Create a ZlibCodec that either compresses or decompresses.
Declaration Syntax
C# Visual Basic Visual C++
public ZlibCodec(
    CompressionMode mode
)
Public Sub New ( _
    mode As CompressionMode _
)
public:
ZlibCodec(
    CompressionMode mode
)
Parameters
mode (CompressionMode)
Indicates whether the codec should compress (deflate) or decompress (inflate).


Adler32 Property

Adler32 Property
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► Adler32
Keyoti RapidSpell Silverlight
The Adler32 checksum on the data transferred through the codec so far. You probably don't need to look at this.
Declaration Syntax
C# Visual Basic Visual C++
public int Adler32 { get; }
Public ReadOnly Property Adler32 As Integer
public:
property int Adler32 {
    int get ();
}


AvailableBytesIn Field

AvailableBytesIn Field
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► AvailableBytesIn
Keyoti RapidSpell Silverlight
The number of bytes available in the InputBuffer, starting at NextIn.
Declaration Syntax
C# Visual Basic Visual C++
public int AvailableBytesIn
Public AvailableBytesIn As Integer
public:
int AvailableBytesIn
Remarks
Generally you should set this to InputBuffer.Length before the first Inflate() or Deflate() call. The class will update this number as calls to Inflate/Deflate are made.


AvailableBytesOut Field

AvailableBytesOut Field
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► AvailableBytesOut
Keyoti RapidSpell Silverlight
The number of bytes available in the OutputBuffer, starting at NextOut.
Declaration Syntax
C# Visual Basic Visual C++
public int AvailableBytesOut
Public AvailableBytesOut As Integer
public:
int AvailableBytesOut
Remarks
Generally you should set this to OutputBuffer.Length before the first Inflate() or Deflate() call. The class will update this number as calls to Inflate/Deflate are made.


CompressLevel Field

CompressLevel Field
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► CompressLevel
Keyoti RapidSpell Silverlight
The compression level to use in this codec. Useful only in compression mode.
Declaration Syntax
C# Visual Basic Visual C++
public CompressionLevel CompressLevel
Public CompressLevel As CompressionLevel
public:
CompressionLevel CompressLevel


Deflate Method (flush)

Deflate Method (flush)
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► Deflate(FlushType)
Keyoti RapidSpell Silverlight
Deflate one batch of data.
Declaration Syntax
C# Visual Basic Visual C++
public int Deflate(
    FlushType flush
)
Public Function Deflate ( _
    flush As FlushType _
) As Integer
public:
int Deflate(
    FlushType flush
)
Parameters
flush (FlushType)
whether to flush all data as you deflate. Generally you will want to use Z_NO_FLUSH here, in a series of calls to Deflate(), and then call EndDeflate() to flush everything.
Return Value
Z_OK if all goes well.
Remarks
You must have set InputBuffer and OutputBuffer before calling this method.
Examples
CopyC#
private void DeflateBuffer(CompressionLevel level)
{
    int bufferSize = 1024;
    byte[] buffer = new byte[bufferSize];
    ZlibCodec compressor = new ZlibCodec();

    Console.WriteLine("\n============================================");
    Console.WriteLine("Size of Buffer to Deflate: {0} bytes.", UncompressedBytes.Length);
    MemoryStream ms = new MemoryStream();

    int rc = compressor.InitializeDeflate(level);

    compressor.InputBuffer = UncompressedBytes;
    compressor.NextIn = 0;
    compressor.AvailableBytesIn = UncompressedBytes.Length;

    compressor.OutputBuffer = buffer;

    // pass 1: deflate
    do
    {
        compressor.NextOut = 0;
        compressor.AvailableBytesOut = buffer.Length;
        rc = compressor.Deflate(FlushType.None);

        if (rc != ZlibConstants.Z_OK && rc != ZlibConstants.Z_STREAM_END)
            throw new Exception("deflating: " + compressor.Message);

        ms.Write(compressor.OutputBuffer, 0, buffer.Length - compressor.AvailableBytesOut);
    }
    while (compressor.AvailableBytesIn > 0 || compressor.AvailableBytesOut == 0);

    // pass 2: finish and flush
    do
    {
        compressor.NextOut = 0;
        compressor.AvailableBytesOut = buffer.Length;
        rc = compressor.Deflate(FlushType.Finish);

        if (rc != ZlibConstants.Z_STREAM_END && rc != ZlibConstants.Z_OK)
            throw new Exception("deflating: " + compressor.Message);

        if (buffer.Length - compressor.AvailableBytesOut > 0)
            ms.Write(buffer, 0, buffer.Length - compressor.AvailableBytesOut);
    }
    while (compressor.AvailableBytesIn > 0 || compressor.AvailableBytesOut == 0);

    compressor.EndDeflate();

    ms.Seek(0, SeekOrigin.Begin);
    CompressedBytes = new byte[compressor.TotalBytesOut];
    ms.Read(CompressedBytes, 0, CompressedBytes.Length);
}


EndDeflate Method

EndDeflate Method
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► EndDeflate()()()
Keyoti RapidSpell Silverlight
End a deflation session.
Declaration Syntax
C# Visual Basic Visual C++
public int EndDeflate()
Public Function EndDeflate As Integer
public:
int EndDeflate()
Return Value
Z_OK if all goes well.
Remarks
Call this after making a series of one or more calls to Deflate(). All buffers are flushed.


EndInflate Method

EndInflate Method
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► EndInflate()()()
Keyoti RapidSpell Silverlight
Ends an inflation session.
Declaration Syntax
C# Visual Basic Visual C++
public int EndInflate()
Public Function EndInflate As Integer
public:
int EndInflate()
Return Value
Z_OK if everything goes well.
Remarks
Call this after successively calling Inflate(). This will cause all buffers to be flushed. After calling this you cannot call Inflate() without a intervening call to one of the InitializeInflate() overloads.


Inflate Method (flush)

Inflate Method (flush)
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► Inflate(FlushType)
Keyoti RapidSpell Silverlight
Inflate the data in the InputBuffer, placing the result in the OutputBuffer.
Declaration Syntax
C# Visual Basic Visual C++
public int Inflate(
    FlushType flush
)
Public Function Inflate ( _
    flush As FlushType _
) As Integer
public:
int Inflate(
    FlushType flush
)
Parameters
flush (FlushType)
The flush to use when inflating.
Return Value
Z_OK if everything goes well.
Remarks
You must have set InputBuffer and OutputBuffer, NextIn and NextOut, and AvailableBytesIn and AvailableBytesOut before calling this method.
Examples
CopyC#
private void InflateBuffer()
{
    int bufferSize = 1024;
    byte[] buffer = new byte[bufferSize];
    ZlibCodec decompressor = new ZlibCodec();

    Console.WriteLine("\n============================================");
    Console.WriteLine("Size of Buffer to Inflate: {0} bytes.", CompressedBytes.Length);
    MemoryStream ms = new MemoryStream(DecompressedBytes);

    int rc = decompressor.InitializeInflate();

    decompressor.InputBuffer = CompressedBytes;
    decompressor.NextIn = 0;
    decompressor.AvailableBytesIn = CompressedBytes.Length;

    decompressor.OutputBuffer = buffer;

    // pass 1: inflate
    do
    {
        decompressor.NextOut = 0;
        decompressor.AvailableBytesOut = buffer.Length;
        rc = decompressor.Inflate(FlushType.None);

        if (rc != ZlibConstants.Z_OK && rc != ZlibConstants.Z_STREAM_END)
            throw new Exception("inflating: " + decompressor.Message);

        ms.Write(decompressor.OutputBuffer, 0, buffer.Length - decompressor.AvailableBytesOut);
    }
    while (decompressor.AvailableBytesIn > 0 || decompressor.AvailableBytesOut == 0);

    // pass 2: finish and flush
    do
    {
        decompressor.NextOut = 0;
        decompressor.AvailableBytesOut = buffer.Length;
        rc = decompressor.Inflate(FlushType.Finish);

        if (rc != ZlibConstants.Z_STREAM_END && rc != ZlibConstants.Z_OK)
            throw new Exception("inflating: " + decompressor.Message);

        if (buffer.Length - decompressor.AvailableBytesOut > 0)
            ms.Write(buffer, 0, buffer.Length - decompressor.AvailableBytesOut);
    }
    while (decompressor.AvailableBytesIn > 0 || decompressor.AvailableBytesOut == 0);

    decompressor.EndInflate();
}


InitializeDeflate Method

InitializeDeflate Method
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► InitializeDeflate()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | InitializeDeflate()()() | Initialize the ZlibCodec for deflation operation.
 | InitializeDeflate(CompressionLevel) | Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel.
 | InitializeDeflate(CompressionLevel, Boolean) | Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel, and the explicit flag governing whether to emit an RFC1950 header byte pair.
 | InitializeDeflate(CompressionLevel, Int32) | Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel, and the specified number of window bits.
 | InitializeDeflate(CompressionLevel, Int32, Boolean) | Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel, the specified number of window bits, and the explicit flag governing whether to emit an RFC1950 header byte pair.


InitializeDeflate Method

InitializeDeflate Method
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► InitializeDeflate()()()
Keyoti RapidSpell Silverlight
Initialize the ZlibCodec for deflation operation.
Declaration Syntax
C# Visual Basic Visual C++
public int InitializeDeflate()
Public Function InitializeDeflate As Integer
public:
int InitializeDeflate()
Return Value
Z_OK if all goes well. You generally don't need to check the return code.
Remarks
The codec will use the MAX window bits and the default level of compression.
Examples
CopyC#
int bufferSize = 40000;
byte[] CompressedBytes = new byte[bufferSize];
byte[] DecompressedBytes = new byte[bufferSize];

ZlibCodec compressor = new ZlibCodec();

compressor.InitializeDeflate(CompressionLevel.Default);

compressor.InputBuffer = System.Text.ASCIIEncoding.ASCII.GetBytes(TextToCompress);
compressor.NextIn = 0;
compressor.AvailableBytesIn = compressor.InputBuffer.Length;

compressor.OutputBuffer = CompressedBytes;
compressor.NextOut = 0;
compressor.AvailableBytesOut = CompressedBytes.Length;

while (compressor.TotalBytesIn != TextToCompress.Length && compressor.TotalBytesOut < bufferSize)
{
  compressor.Deflate(FlushType.None);
}

while (true)
{
  int rc= compressor.Deflate(FlushType.Finish);
  if (rc == ZlibConstants.Z_STREAM_END) break;
}

compressor.EndDeflate();


InitializeDeflate Method (level)

InitializeDeflate Method (level)
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► InitializeDeflate(CompressionLevel)
Keyoti RapidSpell Silverlight
Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel.
Declaration Syntax
C# Visual Basic Visual C++
public int InitializeDeflate(
    CompressionLevel level
)
Public Function InitializeDeflate ( _
    level As CompressionLevel _
) As Integer
public:
int InitializeDeflate(
    CompressionLevel level
)
Parameters
level (CompressionLevel)
The compression level for the codec.
Return Value
Z_OK if all goes well.
Remarks
The codec will use the maximum window bits (15) and the specified CompressionLevel. It will emit a ZLIB stream as it compresses.


InitializeDeflate Method (level, wantRfc1950Header)

InitializeDeflate Method (level, wantRfc1950Header)
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► InitializeDeflate(CompressionLevel, Boolean)
Keyoti RapidSpell Silverlight
Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel, and the explicit flag governing whether to emit an RFC1950 header byte pair.
Declaration Syntax
C# Visual Basic Visual C++
public int InitializeDeflate(
    CompressionLevel level,
    bool wantRfc1950Header
)
Public Function InitializeDeflate ( _
    level As CompressionLevel, _
    wantRfc1950Header As Boolean _
) As Integer
public:
int InitializeDeflate(
    CompressionLevel level,
    bool wantRfc1950Header
)
Parameters
level (CompressionLevel)
The compression level for the codec.
wantRfc1950Header (Boolean)
whether to emit an initial RFC1950 byte pair in the compressed stream.
Return Value
Z_OK if all goes well.
Remarks
The codec will use the maximum window bits (15) and the specified CompressionLevel. If you want to generate a zlib stream, you should specify true for wantRfc1950Header. In this case, the library will emit a ZLIB header, as defined in RFC 1950, in the compressed stream.


InitializeDeflate Method (level, bits)

InitializeDeflate Method (level, bits)
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► InitializeDeflate(CompressionLevel, Int32)
Keyoti RapidSpell Silverlight
Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel, and the specified number of window bits.
Declaration Syntax
C# Visual Basic Visual C++
public int InitializeDeflate(
    CompressionLevel level,
    int bits
)
Public Function InitializeDeflate ( _
    level As CompressionLevel, _
    bits As Integer _
) As Integer
public:
int InitializeDeflate(
    CompressionLevel level,
    int bits
)
Parameters
level (CompressionLevel)
The compression level for the codec.
bits (Int32)
the number of window bits to use. If you don't know what this means, don't use this method.
Return Value
Z_OK if all goes well.
Remarks
The codec will use the specified number of window bits and the specified CompressionLevel.


InitializeDeflate Method (level, bits, wantRfc1950Header)

InitializeDeflate Method (level, bits, wantRfc1950Header)
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► InitializeDeflate(CompressionLevel, Int32, Boolean)
Keyoti RapidSpell Silverlight
Initialize the ZlibCodec for deflation operation, using the specified CompressionLevel, the specified number of window bits, and the explicit flag governing whether to emit an RFC1950 header byte pair.
Declaration Syntax
C# Visual Basic Visual C++
public int InitializeDeflate(
    CompressionLevel level,
    int bits,
    bool wantRfc1950Header
)
Public Function InitializeDeflate ( _
    level As CompressionLevel, _
    bits As Integer, _
    wantRfc1950Header As Boolean _
) As Integer
public:
int InitializeDeflate(
    CompressionLevel level,
    int bits,
    bool wantRfc1950Header
)
Parameters
level (CompressionLevel)
The compression level for the codec.
bits (Int32)
the number of window bits to use. If you don't know what this means, don't use this method.
wantRfc1950Header (Boolean)
whether to emit an initial RFC1950 byte pair in the compressed stream.
Return Value
Z_OK if all goes well.


InitializeInflate Method

InitializeInflate Method
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► InitializeInflate()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | InitializeInflate()()() | Initialize the inflation state.
 | InitializeInflate(Boolean) | Initialize the inflation state with an explicit flag to govern the handling of RFC1950 header bytes.
 | InitializeInflate(Int32) | Initialize the ZlibCodec for inflation, with the specified number of window bits.
 | InitializeInflate(Int32, Boolean) | Initialize the inflation state with an explicit flag to govern the handling of RFC1950 header bytes.


InitializeInflate Method

InitializeInflate Method
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► InitializeInflate()()()
Keyoti RapidSpell Silverlight
Initialize the inflation state.
Declaration Syntax
C# Visual Basic Visual C++
public int InitializeInflate()
Public Function InitializeInflate As Integer
public:
int InitializeInflate()
Return Value
Z_OK if everything goes well.
Remarks
It is not necessary to call this before using the ZlibCodec to inflate data; It is implicitly called when you call the constructor.


InitializeInflate Method (expectRfc1950Header)

InitializeInflate Method (expectRfc1950Header)
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► InitializeInflate(Boolean)
Keyoti RapidSpell Silverlight
Initialize the inflation state with an explicit flag to govern the handling of RFC1950 header bytes.
Declaration Syntax
C# Visual Basic Visual C++
public int InitializeInflate(
    bool expectRfc1950Header
)
Public Function InitializeInflate ( _
    expectRfc1950Header As Boolean _
) As Integer
public:
int InitializeInflate(
    bool expectRfc1950Header
)
Parameters
expectRfc1950Header (Boolean)
whether to expect an RFC1950 header byte pair when reading the stream of data to be inflated.
Return Value
Z_OK if everything goes well.
Remarks
By default, the ZLIB header defined in RFC 1950 is expected. If you want to read a zlib stream you should specify true for expectRfc1950Header. If you have a deflate stream, you will want to specify false. It is only necessary to invoke this initializer explicitly if you want to specify false.


InitializeInflate Method (windowBits)

InitializeInflate Method (windowBits)
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► InitializeInflate(Int32)
Keyoti RapidSpell Silverlight
Initialize the ZlibCodec for inflation, with the specified number of window bits.
Declaration Syntax
C# Visual Basic Visual C++
public int InitializeInflate(
    int windowBits
)
Public Function InitializeInflate ( _
    windowBits As Integer _
) As Integer
public:
int InitializeInflate(
    int windowBits
)
Parameters
windowBits (Int32)
The number of window bits to use. If you need to ask what that is, then you shouldn't be calling this initializer.
Return Value
Z_OK if all goes well.


InitializeInflate Method (windowBits, expectRfc1950Header)

InitializeInflate Method (windowBits, expectRfc1950Header)
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► InitializeInflate(Int32, Boolean)
Keyoti RapidSpell Silverlight
Initialize the inflation state with an explicit flag to govern the handling of RFC1950 header bytes.
Declaration Syntax
C# Visual Basic Visual C++
public int InitializeInflate(
    int windowBits,
    bool expectRfc1950Header
)
Public Function InitializeInflate ( _
    windowBits As Integer, _
    expectRfc1950Header As Boolean _
) As Integer
public:
int InitializeInflate(
    int windowBits,
    bool expectRfc1950Header
)
Parameters
windowBits (Int32)
The number of window bits to use. If you need to ask what that is, then you shouldn't be calling this initializer.
expectRfc1950Header (Boolean)
whether to expect an RFC1950 header byte pair when reading the stream of data to be inflated.
Return Value
Z_OK if everything goes well.
Remarks
If you want to read a zlib stream you should specify true for expectRfc1950Header. In this case, the library will expect to find a ZLIB header, as defined in RFC 1950, in the compressed stream. If you will be reading a DEFLATE or GZIP stream, which does not have such a header, you will want to specify false.


InputBuffer Field

InputBuffer Field
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► InputBuffer
Keyoti RapidSpell Silverlight
The buffer from which data is taken.
Declaration Syntax
C# Visual Basic Visual C++
public byte[] InputBuffer
Public InputBuffer As Byte()
public:
array<unsigned char>^ InputBuffer


Message Field

Message Field
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► Message
Keyoti RapidSpell Silverlight
used for diagnostics, when something goes wrong!
Declaration Syntax
C# Visual Basic Visual C++
public string Message
Public Message As String
public:
String^ Message


NextIn Field

NextIn Field
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► NextIn
Keyoti RapidSpell Silverlight
An index into the InputBuffer array, indicating where to start reading.
Declaration Syntax
C# Visual Basic Visual C++
public int NextIn
Public NextIn As Integer
public:
int NextIn


NextOut Field

NextOut Field
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► NextOut
Keyoti RapidSpell Silverlight
An index into the OutputBuffer array, indicating where to start writing.
Declaration Syntax
C# Visual Basic Visual C++
public int NextOut
Public NextOut As Integer
public:
int NextOut


OutputBuffer Field

OutputBuffer Field
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► OutputBuffer
Keyoti RapidSpell Silverlight
Buffer to store output data.
Declaration Syntax
C# Visual Basic Visual C++
public byte[] OutputBuffer
Public OutputBuffer As Byte()
public:
array<unsigned char>^ OutputBuffer


ResetDeflate Method

ResetDeflate Method
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► ResetDeflate()()()
Keyoti RapidSpell Silverlight
Reset a codec for another deflation session.
Declaration Syntax
C# Visual Basic Visual C++
public void ResetDeflate()
Public Sub ResetDeflate
public:
void ResetDeflate()
Return Value
Z_OK if all goes well.
Remarks
Call this to reset the deflation state. For example if a thread is deflating non-consecutive blocks, you can call Reset() after the Deflate(Sync) of the first block and before the next Deflate(None) of the second block.


SetDeflateParams Method (level, strategy)

SetDeflateParams Method (level, strategy)
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► SetDeflateParams(CompressionLevel, CompressionStrategy)
Keyoti RapidSpell Silverlight
Set the CompressionStrategy and CompressionLevel for a deflation session.
Declaration Syntax
C# Visual Basic Visual C++
public int SetDeflateParams(
    CompressionLevel level,
    CompressionStrategy strategy
)
Public Function SetDeflateParams ( _
    level As CompressionLevel, _
    strategy As CompressionStrategy _
) As Integer
public:
int SetDeflateParams(
    CompressionLevel level,
    CompressionStrategy strategy
)
Parameters
level (CompressionLevel)
the level of compression to use.
strategy (CompressionStrategy)
the strategy to use for compression.
Return Value
Z_OK if all goes well.


SetDictionary Method (dictionary)

SetDictionary Method (dictionary)
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► SetDictionary(array<Byte>[]()[])
Keyoti RapidSpell Silverlight
Set the dictionary to be used for either Inflation or Deflation.
Declaration Syntax
C# Visual Basic Visual C++
public int SetDictionary(
    byte[] dictionary
)
Public Function SetDictionary ( _
    dictionary As Byte() _
) As Integer
public:
int SetDictionary(
    array<unsigned char>^ dictionary
)
Parameters
dictionary (array< Byte >[]()[])
The dictionary bytes to use.
Return Value
Z_OK if all goes well.


Strategy Field

Strategy Field
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► Strategy
Keyoti RapidSpell Silverlight
The compression strategy to use.
Declaration Syntax
C# Visual Basic Visual C++
public CompressionStrategy Strategy
Public Strategy As CompressionStrategy
public:
CompressionStrategy Strategy
Remarks
This is only effective in compression. The theory offered by ZLIB is that different strategies could potentially produce significant differences in compression behavior for different data sets. Unfortunately I don't have any good recommendations for how to set it differently. When I tested changing the strategy I got minimally different compression performance. It's best to leave this property alone if you don't have a good feel for it. Or, you may want to produce a test harness that runs through the different strategy options and evaluates them on different file types. If you do that, let me know your results.


SyncInflate Method

SyncInflate Method
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► SyncInflate()()()
Keyoti RapidSpell Silverlight
I don't know what this does!
Declaration Syntax
C# Visual Basic Visual C++
public int SyncInflate()
Public Function SyncInflate As Integer
public:
int SyncInflate()
Return Value
Z_OK if everything goes well.


TotalBytesIn Field

TotalBytesIn Field
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► TotalBytesIn
Keyoti RapidSpell Silverlight
Total number of bytes read so far, through all calls to Inflate()/Deflate().
Declaration Syntax
C# Visual Basic Visual C++
public long TotalBytesIn
Public TotalBytesIn As Long
public:
long long TotalBytesIn


TotalBytesOut Field

TotalBytesOut Field
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► TotalBytesOut
Keyoti RapidSpell Silverlight
Total number of bytes written to the output so far, through all calls to Inflate()/Deflate().
Declaration Syntax
C# Visual Basic Visual C++
public long TotalBytesOut
Public TotalBytesOut As Long
public:
long long TotalBytesOut


WindowBits Field

WindowBits Field
API ► Keyoti.RapidSpell.Compression ► ZlibCodec ► WindowBits
Keyoti RapidSpell Silverlight
The number of Window Bits to use.
Declaration Syntax
C# Visual Basic Visual C++
public int WindowBits
Public WindowBits As Integer
public:
int WindowBits
Remarks
This gauges the size of the sliding window, and hence the compression effectiveness as well as memory consumption. It's best to just leave this setting alone if you don't know what it is. The maximum value is 15 bits, which implies a 32k window.


ZlibConstants Class

ZlibConstants Class
API ► Keyoti.RapidSpell.Compression ► ZlibConstants
Keyoti RapidSpell Silverlight
A bunch of constants used in the Zlib interface.
Declaration Syntax
C# Visual Basic Visual C++
public static class ZlibConstants
Public NotInheritable Class ZlibConstants
public ref class ZlibConstants abstract sealed
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | WindowBitsDefault | The default number of window bits for the Deflate algorithm.
 | WindowBitsMax | The maximum number of window bits for the Deflate algorithm.
 | WorkingBufferSizeDefault | The size of the working buffer used in the ZlibCodec class. Defaults to 8192 bytes.
 | WorkingBufferSizeMin | The minimum size of the working buffer used in the ZlibCodec class. Currently it is 128 bytes.
 | Z_BUF_ERROR | There was an error with the working buffer.
 | Z_DATA_ERROR | There was an error with the data - not enough data, bad data, etc.
 | Z_NEED_DICT | The operation ended in need of a dictionary.
 | Z_OK | indicates everything is A-OK
 | Z_STREAM_END | Indicates that the last operation reached the end of the stream.
 | Z_STREAM_ERROR | There was an error with the stream - not enough data, not open and readable, etc.
Inheritance Hierarchy
Object
ZlibConstants


WindowBitsDefault Field

WindowBitsDefault Field
API ► Keyoti.RapidSpell.Compression ► ZlibConstants ► WindowBitsDefault
Keyoti RapidSpell Silverlight
The default number of window bits for the Deflate algorithm.
Declaration Syntax
C# Visual Basic Visual C++
public const int WindowBitsDefault
Public Const WindowBitsDefault As Integer
public:
literal int WindowBitsDefault


WindowBitsMax Field

WindowBitsMax Field
API ► Keyoti.RapidSpell.Compression ► ZlibConstants ► WindowBitsMax
Keyoti RapidSpell Silverlight
The maximum number of window bits for the Deflate algorithm.
Declaration Syntax
C# Visual Basic Visual C++
public const int WindowBitsMax
Public Const WindowBitsMax As Integer
public:
literal int WindowBitsMax


WorkingBufferSizeDefault Field

WorkingBufferSizeDefault Field
API ► Keyoti.RapidSpell.Compression ► ZlibConstants ► WorkingBufferSizeDefault
Keyoti RapidSpell Silverlight
The size of the working buffer used in the ZlibCodec class. Defaults to 8192 bytes.
Declaration Syntax
C# Visual Basic Visual C++
public const int WorkingBufferSizeDefault
Public Const WorkingBufferSizeDefault As Integer
public:
literal int WorkingBufferSizeDefault


WorkingBufferSizeMin Field

WorkingBufferSizeMin Field
API ► Keyoti.RapidSpell.Compression ► ZlibConstants ► WorkingBufferSizeMin
Keyoti RapidSpell Silverlight
The minimum size of the working buffer used in the ZlibCodec class. Currently it is 128 bytes.
Declaration Syntax
C# Visual Basic Visual C++
public const int WorkingBufferSizeMin
Public Const WorkingBufferSizeMin As Integer
public:
literal int WorkingBufferSizeMin


Z_BUF_ERROR Field

Z_BUF_ERROR Field
API ► Keyoti.RapidSpell.Compression ► ZlibConstants ► Z_BUF_ERROR
Keyoti RapidSpell Silverlight
There was an error with the working buffer.
Declaration Syntax
C# Visual Basic Visual C++
public const int Z_BUF_ERROR
Public Const Z_BUF_ERROR As Integer
public:
literal int Z_BUF_ERROR


Z_DATA_ERROR Field

Z_DATA_ERROR Field
API ► Keyoti.RapidSpell.Compression ► ZlibConstants ► Z_DATA_ERROR
Keyoti RapidSpell Silverlight
There was an error with the data - not enough data, bad data, etc.
Declaration Syntax
C# Visual Basic Visual C++
public const int Z_DATA_ERROR
Public Const Z_DATA_ERROR As Integer
public:
literal int Z_DATA_ERROR


Z_NEED_DICT Field

Z_NEED_DICT Field
API ► Keyoti.RapidSpell.Compression ► ZlibConstants ► Z_NEED_DICT
Keyoti RapidSpell Silverlight
The operation ended in need of a dictionary.
Declaration Syntax
C# Visual Basic Visual C++
public const int Z_NEED_DICT
Public Const Z_NEED_DICT As Integer
public:
literal int Z_NEED_DICT


Z_OK Field

Z_OK Field
API ► Keyoti.RapidSpell.Compression ► ZlibConstants ► Z_OK
Keyoti RapidSpell Silverlight
indicates everything is A-OK
Declaration Syntax
C# Visual Basic Visual C++
public const int Z_OK
Public Const Z_OK As Integer
public:
literal int Z_OK


Z_STREAM_END Field

Z_STREAM_END Field
API ► Keyoti.RapidSpell.Compression ► ZlibConstants ► Z_STREAM_END
Keyoti RapidSpell Silverlight
Indicates that the last operation reached the end of the stream.
Declaration Syntax
C# Visual Basic Visual C++
public const int Z_STREAM_END
Public Const Z_STREAM_END As Integer
public:
literal int Z_STREAM_END


Z_STREAM_ERROR Field

Z_STREAM_ERROR Field
API ► Keyoti.RapidSpell.Compression ► ZlibConstants ► Z_STREAM_ERROR
Keyoti RapidSpell Silverlight
There was an error with the stream - not enough data, not open and readable, etc.
Declaration Syntax
C# Visual Basic Visual C++
public const int Z_STREAM_ERROR
Public Const Z_STREAM_ERROR As Integer
public:
literal int Z_STREAM_ERROR


ZlibException Class

ZlibException Class
API ► Keyoti.RapidSpell.Compression ► ZlibException
Keyoti RapidSpell Silverlight
A general purpose exception class for exceptions in the Zlib library.
Declaration Syntax
C# Visual Basic Visual C++
public class ZlibException : Exception
Public Class ZlibException _
    Inherits Exception
public ref class ZlibException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZlibException()()() | The ZlibException class captures exception information generated by the Zlib library.
 | ZlibException(String) | This ctor collects a message attached to the exception.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | ZlibException


ZlibException Constructor

ZlibException Constructor
API ► Keyoti.RapidSpell.Compression ► ZlibException ► ZlibException()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | ZlibException()()() | The ZlibException class captures exception information generated by the Zlib library.
 | ZlibException(String) | This ctor collects a message attached to the exception.


ZlibException Constructor

ZlibException Constructor
API ► Keyoti.RapidSpell.Compression ► ZlibException ► ZlibException()()()
Keyoti RapidSpell Silverlight
The ZlibException class captures exception information generated by the Zlib library.
Declaration Syntax
C# Visual Basic Visual C++
public ZlibException()
Public Sub New
public:
ZlibException()


ZlibException Constructor (s)

ZlibException Constructor (s)
API ► Keyoti.RapidSpell.Compression ► ZlibException ► ZlibException(String)
Keyoti RapidSpell Silverlight
This ctor collects a message attached to the exception.
Declaration Syntax
C# Visual Basic Visual C++
public ZlibException(
    string s
)
Public Sub New ( _
    s As String _
)
public:
ZlibException(
    String^ s
)
Parameters
s (String)


ZlibStream Class

ZlibStream Class
API ► Keyoti.RapidSpell.Compression ► ZlibStream
Keyoti RapidSpell Silverlight
Represents a Zlib stream for compression or decompression.
Declaration Syntax
C# Visual Basic Visual C++
public class ZlibStream : Stream
Public Class ZlibStream _
    Inherits Stream
public ref class ZlibStream : public Stream
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZlibStream(Stream, CompressionMode) | Create a ZlibStream using the specified CompressionMode.
 | ZlibStream(Stream, CompressionMode, CompressionLevel) | Create a ZlibStream using the specified CompressionMode and the specified CompressionLevel.
 | ZlibStream(Stream, CompressionMode, Boolean) | Create a ZlibStream using the specified CompressionMode, and explicitly specify whether the captive stream should be left open after Deflation or Inflation.
 | ZlibStream(Stream, CompressionMode, CompressionLevel, Boolean) | Create a ZlibStream using the specified CompressionMode and the specified CompressionLevel, and explicitly specify whether the stream should be left open after Deflation or Inflation.
 | BeginRead(array<Byte>[]()[], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous read operation. (Inherited from Stream.)
 | BeginWrite(array<Byte>[]()[], Int32, Int32, AsyncCallback, Object) | HostProtectionAttribute. Begins an asynchronous write operation. (Inherited from Stream.)
 | BufferSize | The size of the working buffer for the compression codec.
 | CanRead | Indicates whether the stream can be read. (Overrides Stream.CanRead.)
 | CanSeek | Indicates whether the stream supports Seek operations. (Overrides Stream.CanSeek.)
 | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
 | CanWrite | Indicates whether the stream can be written. (Overrides Stream.CanWrite.)
 | Close()()() | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. (Inherited from Stream.)
 | CompressBuffer(array<Byte>[]()[]) | Compress a byte array into a new byte array using ZLIB.
 | CompressString(String) | Compress a string into a byte array using ZLIB.
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateWaitHandle()()() | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
 | Dispose(Boolean) | Dispose the stream. (Overrides Stream.Dispose(Boolean).)
 | Dispose()()() | Releases all resources used by the Stream. (Inherited from Stream.)
 | EndRead(IAsyncResult) | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
 | EndWrite(IAsyncResult) | Ends an asynchronous write operation. (Inherited from Stream.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Flush()()() | Flush the stream. (Overrides Stream.Flush()()().)
 | FlushMode | This property sets the flush behavior on the stream. Sorry, though, not sure exactly how to describe all the various settings.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | Length | Reading this property always throws a NotImplementedException. (Overrides Stream.Length.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Position | The position of the stream pointer. (Overrides Stream.Position.)
 | Read(array<Byte>[]()[], Int32, Int32) | Read data from the stream. (Overrides Stream.Read(array<Byte>[]()[], Int32, Int32).)
 | ReadByte()()() | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
 | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
 | Seek(Int64, SeekOrigin) | Calling this method always throws a NotImplementedException. (Overrides Stream.Seek(Int64, SeekOrigin).)
 | SetLength(Int64) | Calling this method always throws a NotImplementedException. (Overrides Stream.SetLength(Int64).)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalIn | Returns the total number of bytes input so far.
 | TotalOut | Returns the total number of bytes output so far.
 | UncompressBuffer(array<Byte>[]()[]) | Uncompress a ZLIB-compressed byte array into a byte array.
 | UncompressString(array<Byte>[]()[]) | Uncompress a ZLIB-compressed byte array into a single string.
 | Write(array<Byte>[]()[], Int32, Int32) | Write data to the stream. (Overrides Stream.Write(array<Byte>[]()[], Int32, Int32).)
 | WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
 | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Remarks

The ZlibStream is a Decorator on a Stream. It adds ZLIB compression or decompression to any stream.

Using this stream, applications can compress or decompress data via stream Read() and Write() operations. Either compresssion or decompression can occur through either reading or writing. The compression format used is ZLIB, which is documented in IETF RFC 1950, "ZLIB Compressed Data Format Specification version 3.3". This implementation of ZLIB always uses DEFLATE as the compression method. (see IETF RFC 1951, "DEFLATE Compressed Data Format Specification version 1.3.")

The ZLIB format allows for varying compression methods, window sizes, and dictionaries. This implementation always uses the DEFLATE compression method, a preset dictionary, and 15 window bits by default.

This class is similar to DeflateStream, except that it adds the RFC1950 header and trailer bytes to a compressed stream when compressing, or expects the RFC1950 header and trailer bytes when decompressing. It is also similar to the GZipStream.

Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Stream
 |  |  | ZlibStream
See Also
DeflateStream
GZipStream


ZlibStream Constructor

ZlibStream Constructor
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► ZlibStream()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | ZlibStream(Stream, CompressionMode) | Create a ZlibStream using the specified CompressionMode.
 | ZlibStream(Stream, CompressionMode, CompressionLevel) | Create a ZlibStream using the specified CompressionMode and the specified CompressionLevel.
 | ZlibStream(Stream, CompressionMode, Boolean) | Create a ZlibStream using the specified CompressionMode, and explicitly specify whether the captive stream should be left open after Deflation or Inflation.
 | ZlibStream(Stream, CompressionMode, CompressionLevel, Boolean) | Create a ZlibStream using the specified CompressionMode and the specified CompressionLevel, and explicitly specify whether the stream should be left open after Deflation or Inflation.


ZlibStream Constructor (stream, mode)

ZlibStream Constructor (stream, mode)
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► ZlibStream(Stream, CompressionMode)
Keyoti RapidSpell Silverlight
Create a ZlibStream using the specified CompressionMode.
Declaration Syntax
C# Visual Basic Visual C++
public ZlibStream(
    Stream stream,
    CompressionMode mode
)
Public Sub New ( _
    stream As Stream, _
    mode As CompressionMode _
)
public:
ZlibStream(
    Stream^ stream,
    CompressionMode mode
)
Parameters
stream (Stream)
The stream which will be read or written.
mode (CompressionMode)
Indicates whether the ZlibStream will compress or decompress.
Remarks

When mode is CompressionMode.Compress, the ZlibStream will use the default compression level. The "captive" stream will be closed when the ZlibStream is closed.

Examples
This example uses a ZlibStream to compress a file, and writes the compressed data to another file.
CopyC#
using (System.IO.Stream input = System.IO.File.OpenRead(fileToCompress))
{
    using (var raw = System.IO.File.Create(fileToCompress + ".zlib"))
    {
        using (Stream compressor = new ZlibStream(raw, CompressionMode.Compress))
        {
            byte[] buffer = new byte[WORKING_BUFFER_SIZE];
            int n;
            while ((n= input.Read(buffer, 0, buffer.Length)) != 0)
            {
                compressor.Write(buffer, 0, n);
            }
        }
    }
}
CopyVB.NET
Using input As Stream = File.OpenRead(fileToCompress)
    Using raw As FileStream = File.Create(fileToCompress & ".zlib")
    Using compressor As Stream = New ZlibStream(raw, CompressionMode.Compress)
        Dim buffer As Byte() = New Byte(4096) {}
        Dim n As Integer = -1
        Do While (n <> 0)
            If (n > 0) Then
                compressor.Write(buffer, 0, n)
            End If
            n = input.Read(buffer, 0, buffer.Length)
        Loop
    End Using
    End Using
End Using


ZlibStream Constructor (stream, mode, level)

ZlibStream Constructor (stream, mode, level)
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► ZlibStream(Stream, CompressionMode, CompressionLevel)
Keyoti RapidSpell Silverlight
Create a ZlibStream using the specified CompressionMode and the specified CompressionLevel.
Declaration Syntax
C# Visual Basic Visual C++
public ZlibStream(
    Stream stream,
    CompressionMode mode,
    CompressionLevel level
)
Public Sub New ( _
    stream As Stream, _
    mode As CompressionMode, _
    level As CompressionLevel _
)
public:
ZlibStream(
    Stream^ stream,
    CompressionMode mode,
    CompressionLevel level
)
Parameters
stream (Stream)
The stream to be read or written while deflating or inflating.
mode (CompressionMode)
Indicates whether the ZlibStream will compress or decompress.
level (CompressionLevel)
A tuning knob to trade speed for effectiveness.
Remarks

When mode is CompressionMode.Decompress, the level parameter is ignored. The "captive" stream will be closed when the ZlibStream is closed.

Examples
This example uses a ZlibStream to compress data from a file, and writes the compressed data to another file.
CopyC#
using (System.IO.Stream input = System.IO.File.OpenRead(fileToCompress))
{
    using (var raw = System.IO.File.Create(fileToCompress + ".zlib"))
    {
        using (Stream compressor = new ZlibStream(raw,
                                                  CompressionMode.Compress,
                                                  CompressionLevel.BestCompression))
        {
            byte[] buffer = new byte[WORKING_BUFFER_SIZE];
            int n;
            while ((n= input.Read(buffer, 0, buffer.Length)) != 0)
            {
                compressor.Write(buffer, 0, n);
            }
        }
    }
}
CopyVB.NET
Using input As Stream = File.OpenRead(fileToCompress)
    Using raw As FileStream = File.Create(fileToCompress & ".zlib")
        Using compressor As Stream = New ZlibStream(raw, CompressionMode.Compress, CompressionLevel.BestCompression)
            Dim buffer As Byte() = New Byte(4096) {}
            Dim n As Integer = -1
            Do While (n <> 0)
                If (n > 0) Then
                    compressor.Write(buffer, 0, n)
                End If
                n = input.Read(buffer, 0, buffer.Length)
            Loop
        End Using
    End Using
End Using


ZlibStream Constructor (stream, mode, level, leaveOpen)

ZlibStream Constructor (stream, mode, level, leaveOpen)
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► ZlibStream(Stream, CompressionMode, CompressionLevel, Boolean)
Keyoti RapidSpell Silverlight
Create a ZlibStream using the specified CompressionMode and the specified CompressionLevel, and explicitly specify whether the stream should be left open after Deflation or Inflation.
Declaration Syntax
C# Visual Basic Visual C++
public ZlibStream(
    Stream stream,
    CompressionMode mode,
    CompressionLevel level,
    bool leaveOpen
)
Public Sub New ( _
    stream As Stream, _
    mode As CompressionMode, _
    level As CompressionLevel, _
    leaveOpen As Boolean _
)
public:
ZlibStream(
    Stream^ stream,
    CompressionMode mode,
    CompressionLevel level,
    bool leaveOpen
)
Parameters
stream (Stream)
The stream which will be read or written.
mode (CompressionMode)
Indicates whether the ZlibStream will compress or decompress.
level (CompressionLevel)
A tuning knob to trade speed for effectiveness. This parameter is effective only when mode is CompressionMode.Compress.
leaveOpen (Boolean)
true if the application would like the stream to remain open after inflation/deflation.
Remarks

This constructor allows the application to request that the captive stream remain open after the deflation or inflation occurs. By default, after Close() is called on the stream, the captive stream is also closed. In some cases this is not desired, for example if the stream is a MemoryStream that will be re-read after compression. Specify true for the leaveOpen parameter to leave the stream open.

When mode is CompressionMode.Decompress, the level parameter is ignored.

Examples
This example shows how to use a ZlibStream to compress the data from a file, and store the result into another file. The filestream remains open to allow additional data to be written to it.
CopyC#
using (var output = System.IO.File.Create(fileToCompress + ".zlib"))
{
    using (System.IO.Stream input = System.IO.File.OpenRead(fileToCompress))
    {
        using (Stream compressor = new ZlibStream(output, CompressionMode.Compress, CompressionLevel.BestCompression, true))
        {
            byte[] buffer = new byte[WORKING_BUFFER_SIZE];
            int n;
            while ((n= input.Read(buffer, 0, buffer.Length)) != 0)
            {
                compressor.Write(buffer, 0, n);
            }
        }
    }
    // can write additional data to the output stream here
}
CopyVB.NET
Using output As FileStream = File.Create(fileToCompress & ".zlib")
    Using input As Stream = File.OpenRead(fileToCompress)
        Using compressor As Stream = New ZlibStream(output, CompressionMode.Compress, CompressionLevel.BestCompression, True)
            Dim buffer As Byte() = New Byte(4096) {}
            Dim n As Integer = -1
            Do While (n <> 0)
                If (n > 0) Then
                    compressor.Write(buffer, 0, n)
                End If
                n = input.Read(buffer, 0, buffer.Length)
            Loop
        End Using
    End Using
    ' can write additional data to the output stream here.
End Using


ZlibStream Constructor (stream, mode, leaveOpen)

ZlibStream Constructor (stream, mode, leaveOpen)
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► ZlibStream(Stream, CompressionMode, Boolean)
Keyoti RapidSpell Silverlight
Create a ZlibStream using the specified CompressionMode, and explicitly specify whether the captive stream should be left open after Deflation or Inflation.
Declaration Syntax
C# Visual Basic Visual C++
public ZlibStream(
    Stream stream,
    CompressionMode mode,
    bool leaveOpen
)
Public Sub New ( _
    stream As Stream, _
    mode As CompressionMode, _
    leaveOpen As Boolean _
)
public:
ZlibStream(
    Stream^ stream,
    CompressionMode mode,
    bool leaveOpen
)
Parameters
stream (Stream)
The stream which will be read or written. This is called the "captive" stream in other places in this documentation.
mode (CompressionMode)
Indicates whether the ZlibStream will compress or decompress.
leaveOpen (Boolean)
true if the application would like the stream to remain open after inflation/deflation.
Remarks

When mode is CompressionMode.Compress, the ZlibStream will use the default compression level.

This constructor allows the application to request that the captive stream remain open after the deflation or inflation occurs. By default, after Close() is called on the stream, the captive stream is also closed. In some cases this is not desired, for example if the stream is a MemoryStream that will be re-read after compression. Specify true for the leaveOpen parameter to leave the stream open.

See the other overloads of this constructor for example code.


BufferSize Property

BufferSize Property
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► BufferSize
Keyoti RapidSpell Silverlight
The size of the working buffer for the compression codec.
Declaration Syntax
C# Visual Basic Visual C++
public int BufferSize { get; set; }
Public Property BufferSize As Integer
public:
property int BufferSize {
    int get ();
    void set (int value);
}
Remarks

The working buffer is used for all stream operations. The default size is 1024 bytes. The minimum size is 128 bytes. You may get better performance with a larger buffer. Then again, you might not. You would have to test it.

Set this before the first call to Read() or Write() on the stream. If you try to set it afterwards, it will throw.


CanRead Property

CanRead Property
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► CanRead
Keyoti RapidSpell Silverlight
Indicates whether the stream can be read.
Declaration Syntax
C# Visual Basic Visual C++
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
public:
virtual property bool CanRead {
    bool get () override;
}
Remarks
The return value depends on whether the captive stream supports reading.


CanSeek Property

CanSeek Property
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► CanSeek
Keyoti RapidSpell Silverlight
Indicates whether the stream supports Seek operations.
Declaration Syntax
C# Visual Basic Visual C++
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
public:
virtual property bool CanSeek {
    bool get () override;
}
Remarks
Always returns false.


CanWrite Property

CanWrite Property
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► CanWrite
Keyoti RapidSpell Silverlight
Indicates whether the stream can be written.
Declaration Syntax
C# Visual Basic Visual C++
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
public:
virtual property bool CanWrite {
    bool get () override;
}
Remarks
The return value depends on whether the captive stream supports writing.


CompressBuffer Method (b)

CompressBuffer Method (b)
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► CompressBuffer(array<Byte>[]()[])
Keyoti RapidSpell Silverlight
Compress a byte array into a new byte array using ZLIB.
Declaration Syntax
C# Visual Basic Visual C++
public static byte[] CompressBuffer(
    byte[] b
)
Public Shared Function CompressBuffer ( _
    b As Byte() _
) As Byte()
public:
static array<unsigned char>^ CompressBuffer(
    array<unsigned char>^ b
)
Parameters
b (array< Byte >[]()[])
A buffer to compress.
Return Value
The data in compressed form
Remarks
Uncompress it with UncompressBuffer(array<Byte>[]()[]).
See Also
CompressString(String)
UncompressBuffer(array<Byte>[]()[])


CompressString Method (s)

CompressString Method (s)
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► CompressString(String)
Keyoti RapidSpell Silverlight
Compress a string into a byte array using ZLIB.
Declaration Syntax
C# Visual Basic Visual C++
public static byte[] CompressString(
    string s
)
Public Shared Function CompressString ( _
    s As String _
) As Byte()
public:
static array<unsigned char>^ CompressString(
    String^ s
)
Parameters
s (String)
A string to compress. The string will first be encoded using UTF8, then compressed.
Return Value
The string in compressed form
Remarks
Uncompress it with UncompressString(array<Byte>[]()[]).
See Also
UncompressString(array<Byte>[]()[])
CompressBuffer(array<Byte>[]()[])
CompressString(String)


Dispose Method (disposing)

Dispose Method (disposing)
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► Dispose(Boolean)
Keyoti RapidSpell Silverlight
Dispose the stream.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
Remarks
This may or may not result in a Close() call on the captive stream. See the constructors that have a leaveOpen parameter for more information.


Flush Method

Flush Method
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► Flush()()()
Keyoti RapidSpell Silverlight
Flush the stream.
Declaration Syntax
C# Visual Basic Visual C++
public override void Flush()
Public Overrides Sub Flush
public:
virtual void Flush() override


FlushMode Property

FlushMode Property
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► FlushMode
Keyoti RapidSpell Silverlight
This property sets the flush behavior on the stream. Sorry, though, not sure exactly how to describe all the various settings.
Declaration Syntax
C# Visual Basic Visual C++
public virtual FlushType FlushMode { get; set; }
Public Overridable Property FlushMode As FlushType
public:
virtual property FlushType FlushMode {
    FlushType get ();
    void set (FlushType value);
}


Length Property

Length Property
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► Length
Keyoti RapidSpell Silverlight
Reading this property always throws a NotImplementedException.
Declaration Syntax
C# Visual Basic Visual C++
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
public:
virtual property long long Length {
    long long get () override;
}


Position Property

Position Property
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► Position
Keyoti RapidSpell Silverlight
The position of the stream pointer.
Declaration Syntax
C# Visual Basic Visual C++
public override long Position { get; set; }
Public Overrides Property Position As Long
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}
Remarks
Setting this property always throws a NotImplementedException. Reading will return the total bytes written out, if used in writing, or the total bytes read in, if used in reading. The count may refer to compressed bytes or uncompressed bytes, depending on how you've used the stream.


Read Method (buffer, offset, count)

Read Method (buffer, offset, count)
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► Read(array<Byte>[]()[], Int32, Int32)
Keyoti RapidSpell Silverlight
Read data from the stream.
Declaration Syntax
C# Visual Basic Visual C++
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Function Read ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
) As Integer
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
Parameters
buffer (array< Byte >[]()[])
The buffer into which the read data should be placed.
offset (Int32)
the offset within that data array to put the first byte read.
count (Int32)
the number of bytes to read.
Remarks

If you wish to use the ZlibStream to compress data while reading, you can create a ZlibStream with CompressionMode.Compress, providing an uncompressed data stream. Then call Read() on that ZlibStream, and the data read will be compressed. If you wish to use the ZlibStream to decompress data while reading, you can create a ZlibStream with CompressionMode.Decompress, providing a readable compressed data stream. Then call Read() on that ZlibStream, and the data will be decompressed as it is read.

A ZlibStream can be used for Read() or Write(), but not both.


Seek Method (offset, origin)

Seek Method (offset, origin)
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► Seek(Int64, SeekOrigin)
Keyoti RapidSpell Silverlight
Calling this method always throws a NotImplementedException.
Declaration Syntax
C# Visual Basic Visual C++
public override long Seek(
    long offset,
    SeekOrigin origin
)
Public Overrides Function Seek ( _
    offset As Long, _
    origin As SeekOrigin _
) As Long
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
Parameters
offset (Int64)
origin (SeekOrigin)


SetLength Method (value)

SetLength Method (value)
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► SetLength(Int64)
Keyoti RapidSpell Silverlight
Calling this method always throws a NotImplementedException.
Declaration Syntax
C# Visual Basic Visual C++
public override void SetLength(
    long value
)
Public Overrides Sub SetLength ( _
    value As Long _
)
public:
virtual void SetLength(
    long long value
) override
Parameters
value (Int64)


TotalIn Property

TotalIn Property
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► TotalIn
Keyoti RapidSpell Silverlight
Returns the total number of bytes input so far.
Declaration Syntax
C# Visual Basic Visual C++
public virtual long TotalIn { get; }
Public Overridable ReadOnly Property TotalIn As Long
public:
virtual property long long TotalIn {
    long long get ();
}


TotalOut Property

TotalOut Property
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► TotalOut
Keyoti RapidSpell Silverlight
Returns the total number of bytes output so far.
Declaration Syntax
C# Visual Basic Visual C++
public virtual long TotalOut { get; }
Public Overridable ReadOnly Property TotalOut As Long
public:
virtual property long long TotalOut {
    long long get ();
}


UncompressBuffer Method (compressed)

UncompressBuffer Method (compressed)
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► UncompressBuffer(array<Byte>[]()[])
Keyoti RapidSpell Silverlight
Uncompress a ZLIB-compressed byte array into a byte array.
Declaration Syntax
C# Visual Basic Visual C++
public static byte[] UncompressBuffer(
    byte[] compressed
)
Public Shared Function UncompressBuffer ( _
    compressed As Byte() _
) As Byte()
public:
static array<unsigned char>^ UncompressBuffer(
    array<unsigned char>^ compressed
)
Parameters
compressed (array< Byte >[]()[])
A buffer containing ZLIB-compressed data.
Return Value
The data in uncompressed form
See Also
CompressBuffer(array<Byte>[]()[])
UncompressString(array<Byte>[]()[])


UncompressString Method (compressed)

UncompressString Method (compressed)
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► UncompressString(array<Byte>[]()[])
Keyoti RapidSpell Silverlight
Uncompress a ZLIB-compressed byte array into a single string.
Declaration Syntax
C# Visual Basic Visual C++
public static string UncompressString(
    byte[] compressed
)
Public Shared Function UncompressString ( _
    compressed As Byte() _
) As String
public:
static String^ UncompressString(
    array<unsigned char>^ compressed
)
Parameters
compressed (array< Byte >[]()[])
A buffer containing ZLIB-compressed data.
Return Value
The uncompressed string
See Also
CompressString(String)
UncompressBuffer(array<Byte>[]()[])


Write Method (buffer, offset, count)

Write Method (buffer, offset, count)
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► Write(array<Byte>[]()[], Int32, Int32)
Keyoti RapidSpell Silverlight
Write data to the stream.
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Write ( _
    buffer As Byte(), _
    offset As Integer, _
    count As Integer _
)
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
Parameters
buffer (array< Byte >[]()[])
The buffer holding data to write to the stream.
offset (Int32)
the offset within that data array to find the first byte to write.
count (Int32)
the number of bytes to write.
Remarks

If you wish to use the ZlibStream to compress data while writing, you can create a ZlibStream with CompressionMode.Compress, and a writable output stream. Then call Write() on that ZlibStream, providing uncompressed data as input. The data sent to the output stream will be the compressed form of the data written. If you wish to use the ZlibStream to decompress data while writing, you can create a ZlibStream with CompressionMode.Decompress, and a writable output stream. Then call Write() on that stream, providing previously compressed data. The data sent to the output stream will be the decompressed form of the data written.

A ZlibStream can be used for Read() or Write(), but not both.


Keyoti.RapidSpell.DialogViews Namespace

Keyoti.RapidSpell.DialogViews Namespace
API ► Keyoti.RapidSpell.DialogViews
Keyoti RapidSpell Silverlight
Dialog's view class namespace
Declaration Syntax
C# Visual Basic Visual C++
namespace Keyoti.RapidSpell.DialogViews
Namespace Keyoti.RapidSpell.DialogViews
namespace Keyoti.RapidSpell.DialogViews
Types
All Types Interfaces
Icon | Type | Description
 | IDialogView | Describes what a view used by RapidSpellDialog/RapidSpellGUIPresenter must implement.
 | IDialogViewEventHandler | Describes a class which can handle events from an IDialogView.
 | IDialogViewOptions | Describes an option editor form
 | IDialogViewUserDictionaryEdit | Describes a user dictionary editor window


IDialogView Interface

IDialogView Interface
API ► Keyoti.RapidSpell.DialogViews ► IDialogView
Keyoti RapidSpell Silverlight
Describes what a view used by RapidSpellDialog/RapidSpellGUIPresenter must implement.
Declaration Syntax
C# Visual Basic Visual C++
public interface IDialogView
Public Interface IDialogView
public interface class IDialogView
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddButtonEnabled | Whether the add button is enabled
 | AddButtonText | Add button text
 | AddButtonVisible | Whether the add button is visible
 | CancelButtonText | Cancel button text
 | ChangeAllButtonEnabled | Whether the change all button is enabled
 | ChangeAllButtonText | Change all button text
 | ChangeButtonEnabled | Whether the change button is enabled
 | ChangeButtonText | Change button text
 | Close()()() | Closes the form if open.
 | Dispose()()() | Disposes of unmanaged resources.
 | GetQueryCorrection()()() | Return the word from the query text box, as the user may have modified
 | IgnoreAllButtonEnabled | Whether the ignore all button is enabled
 | IgnoreAllButtonText | Ignore all button text
 | IgnoreButtonEnabled | Whether the ignore button is enabled
 | IgnoreButtonSelect()()() | Select the ignore button
 | IgnoreButtonText | Ignore button text
 | IsDisposed | Gets a value indicating whether the control has been disposed of.
 | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
 | NotInDictionaryLabelText | Label text indicating whether in dictionary or not
 | OptionsButtonText | Options button text
 | QueryTextBoxMultiline | Whether 'not in dictionary' text box is multiline or single line.
 | RegisterEvents(IDialogViewEventHandler) | Hook up view events to handler
 | SetQuery(String, String, String) | Specifies the spelling query
 | Show()()() | Show non modally
 | ShowDialog()()() | Show modally
 | ShowDialog(Object) | Show modally
 | ShowMessageBox(String, String, MessageBoxButtons, MessageBoxIcon) | Show a message box for the user
 | ShowOptionsButton | Whether to show the options button.
 | ShowUndoButton | Whether to show the undo button.
 | SuggestionFinderCheckBoxChecked | Whether the find suggestions checkbox is checked (may not be shown)
 | SuggestionFinderCheckBoxEnabled | Whether the suggestion finder checkbox is enabled
 | SuggestionFinderCheckBoxText | Suggestion finder checkbox text
 | SuggestionsLabelEnabled | Whether the suggestions label is enabled
 | SuggestionsLabelText | Suggestion label text
 | SuggestionsListClear()()() | Clear the suggestions list
 | SuggestionsListDeselect()()() | Deselect all items from the suggestions list
 | SuggestionsListEnabled | Whether the suggestions list is enabled
 | SuggestionsListItems | All the suggestion items
 | SuggestionsListSelectedItem | The selected suggestion item
 | Title | Window title
 | UIThreadInvoke(Delegate) | Invoke in the UI thread the delegate d
 | UIThreadInvoke(Delegate, array<Object>[]()[]) | Invoke in the UI thread the delegate d with parameters
 | UndoButtonEnabled | Whether the undo button is enabled
 | UndoButtonText | Undo button text
 | UnregisterEvents(IDialogViewEventHandler) | Remove view event subscriptions from handler
 | Visible | Gets or sets a value indicating whether the control is displayed.


AddButtonEnabled Property

AddButtonEnabled Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► AddButtonEnabled
Keyoti RapidSpell Silverlight
Whether the add button is enabled
Declaration Syntax
C# Visual Basic Visual C++
bool AddButtonEnabled { get; set; }
Property AddButtonEnabled As Boolean
property bool AddButtonEnabled {
    bool get ();
    void set (bool value);
}


AddButtonText Property

AddButtonText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► AddButtonText
Keyoti RapidSpell Silverlight
Add button text
Declaration Syntax
C# Visual Basic Visual C++
string AddButtonText { get; set; }
Property AddButtonText As String
property String^ AddButtonText {
    String^ get ();
    void set (String^ value);
}


AddButtonVisible Property

AddButtonVisible Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► AddButtonVisible
Keyoti RapidSpell Silverlight
Whether the add button is visible
Declaration Syntax
C# Visual Basic Visual C++
bool AddButtonVisible { get; set; }
Property AddButtonVisible As Boolean
property bool AddButtonVisible {
    bool get ();
    void set (bool value);
}


CancelButtonText Property

CancelButtonText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► CancelButtonText
Keyoti RapidSpell Silverlight
Cancel button text
Declaration Syntax
C# Visual Basic Visual C++
string CancelButtonText { get; set; }
Property CancelButtonText As String
property String^ CancelButtonText {
    String^ get ();
    void set (String^ value);
}


ChangeAllButtonEnabled Property

ChangeAllButtonEnabled Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► ChangeAllButtonEnabled
Keyoti RapidSpell Silverlight
Whether the change all button is enabled
Declaration Syntax
C# Visual Basic Visual C++
bool ChangeAllButtonEnabled { get; set; }
Property ChangeAllButtonEnabled As Boolean
property bool ChangeAllButtonEnabled {
    bool get ();
    void set (bool value);
}


ChangeAllButtonText Property

ChangeAllButtonText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► ChangeAllButtonText
Keyoti RapidSpell Silverlight
Change all button text
Declaration Syntax
C# Visual Basic Visual C++
string ChangeAllButtonText { get; set; }
Property ChangeAllButtonText As String
property String^ ChangeAllButtonText {
    String^ get ();
    void set (String^ value);
}


ChangeButtonEnabled Property

ChangeButtonEnabled Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► ChangeButtonEnabled
Keyoti RapidSpell Silverlight
Whether the change button is enabled
Declaration Syntax
C# Visual Basic Visual C++
bool ChangeButtonEnabled { get; set; }
Property ChangeButtonEnabled As Boolean
property bool ChangeButtonEnabled {
    bool get ();
    void set (bool value);
}


ChangeButtonText Property

ChangeButtonText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► ChangeButtonText
Keyoti RapidSpell Silverlight
Change button text
Declaration Syntax
C# Visual Basic Visual C++
string ChangeButtonText { get; set; }
Property ChangeButtonText As String
property String^ ChangeButtonText {
    String^ get ();
    void set (String^ value);
}


Close Method

Close Method
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► Close()()()
Keyoti RapidSpell Silverlight
Closes the form if open.
Declaration Syntax
C# Visual Basic Visual C++
void Close()
Sub Close
void Close()


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► Dispose()()()
Keyoti RapidSpell Silverlight
Disposes of unmanaged resources.
Declaration Syntax
C# Visual Basic Visual C++
void Dispose()
Sub Dispose
void Dispose()


GetQueryCorrection Method

GetQueryCorrection Method
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► GetQueryCorrection()()()
Keyoti RapidSpell Silverlight
Return the word from the query text box, as the user may have modified
Declaration Syntax
C# Visual Basic Visual C++
string GetQueryCorrection()
Function GetQueryCorrection As String
String^ GetQueryCorrection()


IgnoreAllButtonEnabled Property

IgnoreAllButtonEnabled Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► IgnoreAllButtonEnabled
Keyoti RapidSpell Silverlight
Whether the ignore all button is enabled
Declaration Syntax
C# Visual Basic Visual C++
bool IgnoreAllButtonEnabled { get; set; }
Property IgnoreAllButtonEnabled As Boolean
property bool IgnoreAllButtonEnabled {
    bool get ();
    void set (bool value);
}


IgnoreAllButtonText Property

IgnoreAllButtonText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► IgnoreAllButtonText
Keyoti RapidSpell Silverlight
Ignore all button text
Declaration Syntax
C# Visual Basic Visual C++
string IgnoreAllButtonText { get; set; }
Property IgnoreAllButtonText As String
property String^ IgnoreAllButtonText {
    String^ get ();
    void set (String^ value);
}


IgnoreButtonEnabled Property

IgnoreButtonEnabled Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► IgnoreButtonEnabled
Keyoti RapidSpell Silverlight
Whether the ignore button is enabled
Declaration Syntax
C# Visual Basic Visual C++
bool IgnoreButtonEnabled { get; set; }
Property IgnoreButtonEnabled As Boolean
property bool IgnoreButtonEnabled {
    bool get ();
    void set (bool value);
}


IgnoreButtonSelect Method

IgnoreButtonSelect Method
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► IgnoreButtonSelect()()()
Keyoti RapidSpell Silverlight
Select the ignore button
Declaration Syntax
C# Visual Basic Visual C++
void IgnoreButtonSelect()
Sub IgnoreButtonSelect
void IgnoreButtonSelect()


IgnoreButtonText Property

IgnoreButtonText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► IgnoreButtonText
Keyoti RapidSpell Silverlight
Ignore button text
Declaration Syntax
C# Visual Basic Visual C++
string IgnoreButtonText { get; set; }
Property IgnoreButtonText As String
property String^ IgnoreButtonText {
    String^ get ();
    void set (String^ value);
}


IsDisposed Property

IsDisposed Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► IsDisposed
Keyoti RapidSpell Silverlight
Gets a value indicating whether the control has been disposed of.
Declaration Syntax
C# Visual Basic Visual C++
bool IsDisposed { get; }
ReadOnly Property IsDisposed As Boolean
property bool IsDisposed {
    bool get ();
}


Location Property

Location Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► Location
Keyoti RapidSpell Silverlight
Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Declaration Syntax
C# Visual Basic Visual C++
Point Location { get; set; }
Property Location As Point
property Point Location {
    Point get ();
    void set (Point value);
}


NotInDictionaryLabelText Property

NotInDictionaryLabelText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► NotInDictionaryLabelText
Keyoti RapidSpell Silverlight
Label text indicating whether in dictionary or not
Declaration Syntax
C# Visual Basic Visual C++
string NotInDictionaryLabelText { get; set; }
Property NotInDictionaryLabelText As String
property String^ NotInDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}


OptionsButtonText Property

OptionsButtonText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► OptionsButtonText
Keyoti RapidSpell Silverlight
Options button text
Declaration Syntax
C# Visual Basic Visual C++
string OptionsButtonText { get; set; }
Property OptionsButtonText As String
property String^ OptionsButtonText {
    String^ get ();
    void set (String^ value);
}


QueryTextBoxMultiline Property

QueryTextBoxMultiline Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► QueryTextBoxMultiline
Keyoti RapidSpell Silverlight
Whether 'not in dictionary' text box is multiline or single line.
Declaration Syntax
C# Visual Basic Visual C++
bool QueryTextBoxMultiline { get; set; }
Property QueryTextBoxMultiline As Boolean
property bool QueryTextBoxMultiline {
    bool get ();
    void set (bool value);
}


RegisterEvents Method (handler)

RegisterEvents Method (handler)
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► RegisterEvents(IDialogViewEventHandler)
Keyoti RapidSpell Silverlight
Hook up view events to handler
Declaration Syntax
C# Visual Basic Visual C++
void RegisterEvents(
    IDialogViewEventHandler handler
)
Sub RegisterEvents ( _
    handler As IDialogViewEventHandler _
)
void RegisterEvents(
    IDialogViewEventHandler^ handler
)
Parameters
handler (IDialogViewEventHandler)


SetQuery Method (beforeSentence, word, afterSentence)

SetQuery Method (beforeSentence, word, afterSentence)
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► SetQuery(String, String, String)
Keyoti RapidSpell Silverlight
Specifies the spelling query
Declaration Syntax
C# Visual Basic Visual C++
void SetQuery(
    string beforeSentence,
    string word,
    string afterSentence
)
Sub SetQuery ( _
    beforeSentence As String, _
    word As String, _
    afterSentence As String _
)
void SetQuery(
    String^ beforeSentence,
    String^ word,
    String^ afterSentence
)
Parameters
beforeSentence (String)
The context sentence before the error
word (String)
The actual error
afterSentence (String)
The context sentence after the error


Show Method

Show Method
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► Show()()()
Keyoti RapidSpell Silverlight
Show non modally
Declaration Syntax
C# Visual Basic Visual C++
void Show()
Sub Show
void Show()


ShowDialog Method

ShowDialog Method
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► ShowDialog()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | ShowDialog()()() | Show modally
 | ShowDialog(Object) | Show modally


ShowDialog Method

ShowDialog Method
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► ShowDialog()()()
Keyoti RapidSpell Silverlight
Show modally
Declaration Syntax
C# Visual Basic Visual C++
DialogResult ShowDialog()
Function ShowDialog As DialogResult
DialogResult ShowDialog()


ShowDialog Method (owner)

ShowDialog Method (owner)
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► ShowDialog(Object)
Keyoti RapidSpell Silverlight
Show modally
Declaration Syntax
C# Visual Basic Visual C++
DialogResult ShowDialog(
    Object owner
)
Function ShowDialog ( _
    owner As Object _
) As DialogResult
DialogResult ShowDialog(
    Object^ owner
)
Parameters
owner (Object)
The owner window


ShowMessageBox Method (message, title, buttons, icon)

ShowMessageBox Method (message, title, buttons, icon)
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► ShowMessageBox(String, String, MessageBoxButtons, MessageBoxIcon)
Keyoti RapidSpell Silverlight
Show a message box for the user
Declaration Syntax
C# Visual Basic Visual C++
DialogResult ShowMessageBox(
    string message,
    string title,
    MessageBoxButtons buttons,
    MessageBoxIcon icon
)
Function ShowMessageBox ( _
    message As String, _
    title As String, _
    buttons As MessageBoxButtons, _
    icon As MessageBoxIcon _
) As DialogResult
DialogResult ShowMessageBox(
    String^ message,
    String^ title,
    MessageBoxButtons buttons,
    MessageBoxIcon icon
)
Parameters
message (String)
title (String)
buttons (MessageBoxButtons)
icon (MessageBoxIcon)


ShowOptionsButton Property

ShowOptionsButton Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► ShowOptionsButton
Keyoti RapidSpell Silverlight
Whether to show the options button.
Declaration Syntax
C# Visual Basic Visual C++
bool ShowOptionsButton { get; set; }
Property ShowOptionsButton As Boolean
property bool ShowOptionsButton {
    bool get ();
    void set (bool value);
}


ShowUndoButton Property

ShowUndoButton Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► ShowUndoButton
Keyoti RapidSpell Silverlight
Whether to show the undo button.
Declaration Syntax
C# Visual Basic Visual C++
bool ShowUndoButton { get; set; }
Property ShowUndoButton As Boolean
property bool ShowUndoButton {
    bool get ();
    void set (bool value);
}


SuggestionFinderCheckBoxChecked Property

SuggestionFinderCheckBoxChecked Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► SuggestionFinderCheckBoxChecked
Keyoti RapidSpell Silverlight
Whether the find suggestions checkbox is checked (may not be shown)
Declaration Syntax
C# Visual Basic Visual C++
bool SuggestionFinderCheckBoxChecked { get; set; }
Property SuggestionFinderCheckBoxChecked As Boolean
property bool SuggestionFinderCheckBoxChecked {
    bool get ();
    void set (bool value);
}


SuggestionFinderCheckBoxEnabled Property

SuggestionFinderCheckBoxEnabled Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► SuggestionFinderCheckBoxEnabled
Keyoti RapidSpell Silverlight
Whether the suggestion finder checkbox is enabled
Declaration Syntax
C# Visual Basic Visual C++
bool SuggestionFinderCheckBoxEnabled { get; set; }
Property SuggestionFinderCheckBoxEnabled As Boolean
property bool SuggestionFinderCheckBoxEnabled {
    bool get ();
    void set (bool value);
}


SuggestionFinderCheckBoxText Property

SuggestionFinderCheckBoxText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► SuggestionFinderCheckBoxText
Keyoti RapidSpell Silverlight
Suggestion finder checkbox text
Declaration Syntax
C# Visual Basic Visual C++
string SuggestionFinderCheckBoxText { get; set; }
Property SuggestionFinderCheckBoxText As String
property String^ SuggestionFinderCheckBoxText {
    String^ get ();
    void set (String^ value);
}


SuggestionsLabelEnabled Property

SuggestionsLabelEnabled Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► SuggestionsLabelEnabled
Keyoti RapidSpell Silverlight
Whether the suggestions label is enabled
Declaration Syntax
C# Visual Basic Visual C++
bool SuggestionsLabelEnabled { get; set; }
Property SuggestionsLabelEnabled As Boolean
property bool SuggestionsLabelEnabled {
    bool get ();
    void set (bool value);
}


SuggestionsLabelText Property

SuggestionsLabelText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► SuggestionsLabelText
Keyoti RapidSpell Silverlight
Suggestion label text
Declaration Syntax
C# Visual Basic Visual C++
string SuggestionsLabelText { get; set; }
Property SuggestionsLabelText As String
property String^ SuggestionsLabelText {
    String^ get ();
    void set (String^ value);
}


SuggestionsListClear Method

SuggestionsListClear Method
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► SuggestionsListClear()()()
Keyoti RapidSpell Silverlight
Clear the suggestions list
Declaration Syntax
C# Visual Basic Visual C++
void SuggestionsListClear()
Sub SuggestionsListClear
void SuggestionsListClear()


SuggestionsListDeselect Method

SuggestionsListDeselect Method
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► SuggestionsListDeselect()()()
Keyoti RapidSpell Silverlight
Deselect all items from the suggestions list
Declaration Syntax
C# Visual Basic Visual C++
void SuggestionsListDeselect()
Sub SuggestionsListDeselect
void SuggestionsListDeselect()


SuggestionsListEnabled Property

SuggestionsListEnabled Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► SuggestionsListEnabled
Keyoti RapidSpell Silverlight
Whether the suggestions list is enabled
Declaration Syntax
C# Visual Basic Visual C++
bool SuggestionsListEnabled { get; set; }
Property SuggestionsListEnabled As Boolean
property bool SuggestionsListEnabled {
    bool get ();
    void set (bool value);
}


SuggestionsListItems Property

SuggestionsListItems Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► SuggestionsListItems
Keyoti RapidSpell Silverlight
All the suggestion items
Declaration Syntax
C# Visual Basic Visual C++
Object SuggestionsListItems { get; set; }
Property SuggestionsListItems As Object
property Object^ SuggestionsListItems {
    Object^ get ();
    void set (Object^ value);
}


SuggestionsListSelectedItem Property

SuggestionsListSelectedItem Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► SuggestionsListSelectedItem
Keyoti RapidSpell Silverlight
The selected suggestion item
Declaration Syntax
C# Visual Basic Visual C++
string SuggestionsListSelectedItem { get; }
ReadOnly Property SuggestionsListSelectedItem As String
property String^ SuggestionsListSelectedItem {
    String^ get ();
}


Title Property

Title Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► Title
Keyoti RapidSpell Silverlight
Window title
Declaration Syntax
C# Visual Basic Visual C++
string Title { get; set; }
Property Title As String
property String^ Title {
    String^ get ();
    void set (String^ value);
}


UIThreadInvoke Method

UIThreadInvoke Method
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► UIThreadInvoke()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | UIThreadInvoke(Delegate) | Invoke in the UI thread the delegate d
 | UIThreadInvoke(Delegate, array<Object>[]()[]) | Invoke in the UI thread the delegate d with parameters


UIThreadInvoke Method (d)

UIThreadInvoke Method (d)
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► UIThreadInvoke(Delegate)
Keyoti RapidSpell Silverlight
Invoke in the UI thread the delegate d
Declaration Syntax
C# Visual Basic Visual C++
void UIThreadInvoke(
    Delegate d
)
Sub UIThreadInvoke ( _
    d As Delegate _
)
void UIThreadInvoke(
    Delegate^ d
)
Parameters
d (Delegate)


UIThreadInvoke Method (d, parameters)

UIThreadInvoke Method (d, parameters)
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► UIThreadInvoke(Delegate, array<Object>[]()[])
Keyoti RapidSpell Silverlight
Invoke in the UI thread the delegate d with parameters
Declaration Syntax
C# Visual Basic Visual C++
void UIThreadInvoke(
    Delegate d,
    Object[] parameters
)
Sub UIThreadInvoke ( _
    d As Delegate, _
    parameters As Object() _
)
void UIThreadInvoke(
    Delegate^ d,
    array<Object^>^ parameters
)
Parameters
d (Delegate)
parameters (array< Object >[]()[])


UndoButtonEnabled Property

UndoButtonEnabled Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► UndoButtonEnabled
Keyoti RapidSpell Silverlight
Whether the undo button is enabled
Declaration Syntax
C# Visual Basic Visual C++
bool UndoButtonEnabled { get; set; }
Property UndoButtonEnabled As Boolean
property bool UndoButtonEnabled {
    bool get ();
    void set (bool value);
}


UndoButtonText Property

UndoButtonText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► UndoButtonText
Keyoti RapidSpell Silverlight
Undo button text
Declaration Syntax
C# Visual Basic Visual C++
string UndoButtonText { get; set; }
Property UndoButtonText As String
property String^ UndoButtonText {
    String^ get ();
    void set (String^ value);
}


UnregisterEvents Method (handler)

UnregisterEvents Method (handler)
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► UnregisterEvents(IDialogViewEventHandler)
Keyoti RapidSpell Silverlight
Remove view event subscriptions from handler
Declaration Syntax
C# Visual Basic Visual C++
void UnregisterEvents(
    IDialogViewEventHandler handler
)
Sub UnregisterEvents ( _
    handler As IDialogViewEventHandler _
)
void UnregisterEvents(
    IDialogViewEventHandler^ handler
)
Parameters
handler (IDialogViewEventHandler)


Visible Property

Visible Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogView ► Visible
Keyoti RapidSpell Silverlight
Gets or sets a value indicating whether the control is displayed.
Declaration Syntax
C# Visual Basic Visual C++
bool Visible { get; set; }
Property Visible As Boolean
property bool Visible {
    bool get ();
    void set (bool value);
}


IDialogViewEventHandler Interface

IDialogViewEventHandler Interface
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewEventHandler
Keyoti RapidSpell Silverlight
Describes a class which can handle events from an IDialogView.
Declaration Syntax
C# Visual Basic Visual C++
public interface IDialogViewEventHandler
Public Interface IDialogViewEventHandler
public interface class IDialogViewEventHandler
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DialogView_AddButtonClick(Object, EventArgs) | The add button was clicked
 | DialogView_CancelButtonClick(Object, EventArgs) | The cancel button was clicked
 | DialogView_ChangeAllButtonClick(Object, EventArgs) | The change-all button was clicked
 | DialogView_ChangeButtonClick(Object, EventArgs) | The change button was clicked
 | DialogView_Closing(Object, CancelEventArgs) | The view is closing
 | DialogView_IgnoreAllButtonClick(Object, EventArgs) | The ignore all button was clicked
 | DialogView_IgnoreButtonClick(Object, EventArgs) | The ignore button was clicked
 | DialogView_Load(Object, EventArgs) | The view has loaded
 | DialogView_OptionsButtonClick(Object, EventArgs) | The options button was clicked
 | DialogView_QueryTextBoxEnter(Object, EventArgs) | Query textbox has been entered
 | DialogView_QueryTextBoxTextChanged(Object, EventArgs) | The text in the query textbox changed
 | DialogView_SuggestionsListDoubleClick(Object, EventArgs) | The user double clicked on a suggested item. Not mandatory to implement.
 | DialogView_UndoButtonClick(Object, EventArgs) | The undo button was clicked
 | DialogView_UserNeedsSuggestionsChanged(Object, EventArgs) | User has checked the "Find Suggestions" checkbox (if it exists).
Remarks
Call these methods when events occur in the IDialogView GUI, or hook them up as handlers directly.


DialogView_AddButtonClick Method (sender, e)

DialogView_AddButtonClick Method (sender, e)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewEventHandler ► DialogView_AddButtonClick(Object, EventArgs)
Keyoti RapidSpell Silverlight
The add button was clicked
Declaration Syntax
C# Visual Basic Visual C++
void DialogView_AddButtonClick(
    Object sender,
    EventArgs e
)
Sub DialogView_AddButtonClick ( _
    sender As Object, _
    e As EventArgs _
)
void DialogView_AddButtonClick(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


DialogView_CancelButtonClick Method (sender, e)

DialogView_CancelButtonClick Method (sender, e)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewEventHandler ► DialogView_CancelButtonClick(Object, EventArgs)
Keyoti RapidSpell Silverlight
The cancel button was clicked
Declaration Syntax
C# Visual Basic Visual C++
void DialogView_CancelButtonClick(
    Object sender,
    EventArgs e
)
Sub DialogView_CancelButtonClick ( _
    sender As Object, _
    e As EventArgs _
)
void DialogView_CancelButtonClick(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


DialogView_ChangeAllButtonClick Method (sender, e)

DialogView_ChangeAllButtonClick Method (sender, e)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewEventHandler ► DialogView_ChangeAllButtonClick(Object, EventArgs)
Keyoti RapidSpell Silverlight
The change-all button was clicked
Declaration Syntax
C# Visual Basic Visual C++
void DialogView_ChangeAllButtonClick(
    Object sender,
    EventArgs e
)
Sub DialogView_ChangeAllButtonClick ( _
    sender As Object, _
    e As EventArgs _
)
void DialogView_ChangeAllButtonClick(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


DialogView_ChangeButtonClick Method (sender, e)

DialogView_ChangeButtonClick Method (sender, e)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewEventHandler ► DialogView_ChangeButtonClick(Object, EventArgs)
Keyoti RapidSpell Silverlight
The change button was clicked
Declaration Syntax
C# Visual Basic Visual C++
void DialogView_ChangeButtonClick(
    Object sender,
    EventArgs e
)
Sub DialogView_ChangeButtonClick ( _
    sender As Object, _
    e As EventArgs _
)
void DialogView_ChangeButtonClick(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


DialogView_Closing Method (sender, e)

DialogView_Closing Method (sender, e)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewEventHandler ► DialogView_Closing(Object, CancelEventArgs)
Keyoti RapidSpell Silverlight
The view is closing
Declaration Syntax
C# Visual Basic Visual C++
void DialogView_Closing(
    Object sender,
    CancelEventArgs e
)
Sub DialogView_Closing ( _
    sender As Object, _
    e As CancelEventArgs _
)
void DialogView_Closing(
    Object^ sender,
    CancelEventArgs^ e
)
Parameters
sender (Object)
e (CancelEventArgs)


DialogView_IgnoreAllButtonClick Method (sender, e)

DialogView_IgnoreAllButtonClick Method (sender, e)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewEventHandler ► DialogView_IgnoreAllButtonClick(Object, EventArgs)
Keyoti RapidSpell Silverlight
The ignore all button was clicked
Declaration Syntax
C# Visual Basic Visual C++
void DialogView_IgnoreAllButtonClick(
    Object sender,
    EventArgs e
)
Sub DialogView_IgnoreAllButtonClick ( _
    sender As Object, _
    e As EventArgs _
)
void DialogView_IgnoreAllButtonClick(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


DialogView_IgnoreButtonClick Method (sender, e)

DialogView_IgnoreButtonClick Method (sender, e)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewEventHandler ► DialogView_IgnoreButtonClick(Object, EventArgs)
Keyoti RapidSpell Silverlight
The ignore button was clicked
Declaration Syntax
C# Visual Basic Visual C++
void DialogView_IgnoreButtonClick(
    Object sender,
    EventArgs e
)
Sub DialogView_IgnoreButtonClick ( _
    sender As Object, _
    e As EventArgs _
)
void DialogView_IgnoreButtonClick(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


DialogView_Load Method (sender, e)

DialogView_Load Method (sender, e)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewEventHandler ► DialogView_Load(Object, EventArgs)
Keyoti RapidSpell Silverlight
The view has loaded
Declaration Syntax
C# Visual Basic Visual C++
void DialogView_Load(
    Object sender,
    EventArgs e
)
Sub DialogView_Load ( _
    sender As Object, _
    e As EventArgs _
)
void DialogView_Load(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


DialogView_OptionsButtonClick Method (sender, e)

DialogView_OptionsButtonClick Method (sender, e)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewEventHandler ► DialogView_OptionsButtonClick(Object, EventArgs)
Keyoti RapidSpell Silverlight
The options button was clicked
Declaration Syntax
C# Visual Basic Visual C++
void DialogView_OptionsButtonClick(
    Object sender,
    EventArgs e
)
Sub DialogView_OptionsButtonClick ( _
    sender As Object, _
    e As EventArgs _
)
void DialogView_OptionsButtonClick(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


DialogView_QueryTextBoxEnter Method (sender, e)

DialogView_QueryTextBoxEnter Method (sender, e)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewEventHandler ► DialogView_QueryTextBoxEnter(Object, EventArgs)
Keyoti RapidSpell Silverlight
Query textbox has been entered
Declaration Syntax
C# Visual Basic Visual C++
void DialogView_QueryTextBoxEnter(
    Object sender,
    EventArgs e
)
Sub DialogView_QueryTextBoxEnter ( _
    sender As Object, _
    e As EventArgs _
)
void DialogView_QueryTextBoxEnter(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


DialogView_QueryTextBoxTextChanged Method (sender, e)

DialogView_QueryTextBoxTextChanged Method (sender, e)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewEventHandler ► DialogView_QueryTextBoxTextChanged(Object, EventArgs)
Keyoti RapidSpell Silverlight
The text in the query textbox changed
Declaration Syntax
C# Visual Basic Visual C++
void DialogView_QueryTextBoxTextChanged(
    Object sender,
    EventArgs e
)
Sub DialogView_QueryTextBoxTextChanged ( _
    sender As Object, _
    e As EventArgs _
)
void DialogView_QueryTextBoxTextChanged(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


DialogView_SuggestionsListDoubleClick Method (sender, e)

DialogView_SuggestionsListDoubleClick Method (sender, e)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewEventHandler ► DialogView_SuggestionsListDoubleClick(Object, EventArgs)
Keyoti RapidSpell Silverlight
The user double clicked on a suggested item. Not mandatory to implement.
Declaration Syntax
C# Visual Basic Visual C++
void DialogView_SuggestionsListDoubleClick(
    Object sender,
    EventArgs e
)
Sub DialogView_SuggestionsListDoubleClick ( _
    sender As Object, _
    e As EventArgs _
)
void DialogView_SuggestionsListDoubleClick(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


DialogView_UndoButtonClick Method (sender, e)

DialogView_UndoButtonClick Method (sender, e)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewEventHandler ► DialogView_UndoButtonClick(Object, EventArgs)
Keyoti RapidSpell Silverlight
The undo button was clicked
Declaration Syntax
C# Visual Basic Visual C++
void DialogView_UndoButtonClick(
    Object sender,
    EventArgs e
)
Sub DialogView_UndoButtonClick ( _
    sender As Object, _
    e As EventArgs _
)
void DialogView_UndoButtonClick(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


DialogView_UserNeedsSuggestionsChanged Method (sender, e)

DialogView_UserNeedsSuggestionsChanged Method (sender, e)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewEventHandler ► DialogView_UserNeedsSuggestionsChanged(Object, EventArgs)
Keyoti RapidSpell Silverlight
User has checked the "Find Suggestions" checkbox (if it exists).
Declaration Syntax
C# Visual Basic Visual C++
void DialogView_UserNeedsSuggestionsChanged(
    Object sender,
    EventArgs e
)
Sub DialogView_UserNeedsSuggestionsChanged ( _
    sender As Object, _
    e As EventArgs _
)
void DialogView_UserNeedsSuggestionsChanged(
    Object^ sender,
    EventArgs^ e
)
Parameters
sender (Object)
e (EventArgs)


IDialogViewOptions Interface

IDialogViewOptions Interface
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions
Keyoti RapidSpell Silverlight
Describes an option editor form
Declaration Syntax
C# Visual Basic Visual C++
public interface IDialogViewOptions
Public Interface IDialogViewOptions
public interface class IDialogViewOptions
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Dispose()()() | Free resources
 | EditUserDictionary | Fired when user wants to edit user dictionary
 | FinishDelegate | Called after the ChildWindow is closed, delegate is set internally by RapidSpell, form logic should call delegate when closing.
 | Options | The options to edit
 | OptionsFormAdvancedSettingsText | UI Text
 | OptionsFormAlwaysSuggestCorrectionsText | UI Text
 | OptionsFormBasicSettingsText | UI Text
 | OptionsFormCancelText | UI Text
 | OptionsFormCheckAsYouTypeText | UI Text
 | OptionsFormIgnoreImproperCaseText | UI Text
 | OptionsFormIgnoreInternetAddressesText | UI Text
 | OptionsFormIgnoreWordsInUppercaseText | UI Text
 | OptionsFormIgnoreWordsWithNumbersText | UI Text
 | OptionsFormOKText | UI Text
 | OptionsFormRecheckTextText | UI Text
 | OptionsFormSuggestFromMainDictionaryOnlyText | UI Text
 | OptionsFormTitleText | UI Text
 | OptionsFormUserDictionaryEditText | UI Text
 | RecheckDocumentRequest | Fired when user requests document recheck
 | ShowDialog(Object, Boolean, Boolean, Boolean) | Shows the window modally


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► Dispose()()()
Keyoti RapidSpell Silverlight
Free resources
Declaration Syntax
C# Visual Basic Visual C++
void Dispose()
Sub Dispose
void Dispose()


EditUserDictionary Event

EditUserDictionary Event
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► EditUserDictionary
Keyoti RapidSpell Silverlight
Fired when user wants to edit user dictionary
Declaration Syntax
C# Visual Basic Visual C++
event EventHandler EditUserDictionary
Event EditUserDictionary As EventHandler
 event EventHandler^ EditUserDictionary {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


FinishDelegate Property

FinishDelegate Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► FinishDelegate
Keyoti RapidSpell Silverlight
Called after the ChildWindow is closed, delegate is set internally by RapidSpell, form logic should call delegate when closing.
Declaration Syntax
C# Visual Basic Visual C++
ParameterizedThreadStart FinishDelegate { get; set; }
Property FinishDelegate As ParameterizedThreadStart
property ParameterizedThreadStart^ FinishDelegate {
    ParameterizedThreadStart^ get ();
    void set (ParameterizedThreadStart^ value);
}


Options Property

Options Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► Options
Keyoti RapidSpell Silverlight
The options to edit
Declaration Syntax
C# Visual Basic Visual C++
UserOptions Options { get; set; }
Property Options As UserOptions
property UserOptions^ Options {
    UserOptions^ get ();
    void set (UserOptions^ value);
}


OptionsFormAdvancedSettingsText Property

OptionsFormAdvancedSettingsText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► OptionsFormAdvancedSettingsText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
string OptionsFormAdvancedSettingsText { get; set; }
Property OptionsFormAdvancedSettingsText As String
property String^ OptionsFormAdvancedSettingsText {
    String^ get ();
    void set (String^ value);
}


OptionsFormAlwaysSuggestCorrectionsText Property

OptionsFormAlwaysSuggestCorrectionsText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► OptionsFormAlwaysSuggestCorrectionsText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
string OptionsFormAlwaysSuggestCorrectionsText { get; set; }
Property OptionsFormAlwaysSuggestCorrectionsText As String
property String^ OptionsFormAlwaysSuggestCorrectionsText {
    String^ get ();
    void set (String^ value);
}


OptionsFormBasicSettingsText Property

OptionsFormBasicSettingsText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► OptionsFormBasicSettingsText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
string OptionsFormBasicSettingsText { get; set; }
Property OptionsFormBasicSettingsText As String
property String^ OptionsFormBasicSettingsText {
    String^ get ();
    void set (String^ value);
}


OptionsFormCancelText Property

OptionsFormCancelText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► OptionsFormCancelText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
string OptionsFormCancelText { get; set; }
Property OptionsFormCancelText As String
property String^ OptionsFormCancelText {
    String^ get ();
    void set (String^ value);
}


OptionsFormCheckAsYouTypeText Property

OptionsFormCheckAsYouTypeText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► OptionsFormCheckAsYouTypeText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
string OptionsFormCheckAsYouTypeText { get; set; }
Property OptionsFormCheckAsYouTypeText As String
property String^ OptionsFormCheckAsYouTypeText {
    String^ get ();
    void set (String^ value);
}


OptionsFormIgnoreImproperCaseText Property

OptionsFormIgnoreImproperCaseText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► OptionsFormIgnoreImproperCaseText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
string OptionsFormIgnoreImproperCaseText { get; set; }
Property OptionsFormIgnoreImproperCaseText As String
property String^ OptionsFormIgnoreImproperCaseText {
    String^ get ();
    void set (String^ value);
}


OptionsFormIgnoreInternetAddressesText Property

OptionsFormIgnoreInternetAddressesText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► OptionsFormIgnoreInternetAddressesText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
string OptionsFormIgnoreInternetAddressesText { get; set; }
Property OptionsFormIgnoreInternetAddressesText As String
property String^ OptionsFormIgnoreInternetAddressesText {
    String^ get ();
    void set (String^ value);
}


OptionsFormIgnoreWordsInUppercaseText Property

OptionsFormIgnoreWordsInUppercaseText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► OptionsFormIgnoreWordsInUppercaseText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
string OptionsFormIgnoreWordsInUppercaseText { get; set; }
Property OptionsFormIgnoreWordsInUppercaseText As String
property String^ OptionsFormIgnoreWordsInUppercaseText {
    String^ get ();
    void set (String^ value);
}


OptionsFormIgnoreWordsWithNumbersText Property

OptionsFormIgnoreWordsWithNumbersText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► OptionsFormIgnoreWordsWithNumbersText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
string OptionsFormIgnoreWordsWithNumbersText { get; set; }
Property OptionsFormIgnoreWordsWithNumbersText As String
property String^ OptionsFormIgnoreWordsWithNumbersText {
    String^ get ();
    void set (String^ value);
}


OptionsFormOKText Property

OptionsFormOKText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► OptionsFormOKText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
string OptionsFormOKText { get; set; }
Property OptionsFormOKText As String
property String^ OptionsFormOKText {
    String^ get ();
    void set (String^ value);
}


OptionsFormRecheckTextText Property

OptionsFormRecheckTextText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► OptionsFormRecheckTextText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
string OptionsFormRecheckTextText { get; set; }
Property OptionsFormRecheckTextText As String
property String^ OptionsFormRecheckTextText {
    String^ get ();
    void set (String^ value);
}


OptionsFormSuggestFromMainDictionaryOnlyText Property

OptionsFormSuggestFromMainDictionaryOnlyText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► OptionsFormSuggestFromMainDictionaryOnlyText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
string OptionsFormSuggestFromMainDictionaryOnlyText { get; set; }
Property OptionsFormSuggestFromMainDictionaryOnlyText As String
property String^ OptionsFormSuggestFromMainDictionaryOnlyText {
    String^ get ();
    void set (String^ value);
}


OptionsFormTitleText Property

OptionsFormTitleText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► OptionsFormTitleText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
string OptionsFormTitleText { get; set; }
Property OptionsFormTitleText As String
property String^ OptionsFormTitleText {
    String^ get ();
    void set (String^ value);
}


OptionsFormUserDictionaryEditText Property

OptionsFormUserDictionaryEditText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► OptionsFormUserDictionaryEditText
Keyoti RapidSpell Silverlight
UI Text
Declaration Syntax
C# Visual Basic Visual C++
string OptionsFormUserDictionaryEditText { get; set; }
Property OptionsFormUserDictionaryEditText As String
property String^ OptionsFormUserDictionaryEditText {
    String^ get ();
    void set (String^ value);
}


RecheckDocumentRequest Event

RecheckDocumentRequest Event
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► RecheckDocumentRequest
Keyoti RapidSpell Silverlight
Fired when user requests document recheck
Declaration Syntax
C# Visual Basic Visual C++
event EventHandler RecheckDocumentRequest
Event RecheckDocumentRequest As EventHandler
 event EventHandler^ RecheckDocumentRequest {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


ShowDialog Method (owner, showCheckAsYouTypeOption, showFindSuggestionsOption, showUserDictionaryButton)

ShowDialog Method (owner, showCheckAsYouTypeOption, showFindSuggestionsOption, showUserDictionaryButton)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewOptions ► ShowDialog(Object, Boolean, Boolean, Boolean)
Keyoti RapidSpell Silverlight
Shows the window modally
Declaration Syntax
C# Visual Basic Visual C++
DialogResult ShowDialog(
    Object owner,
    bool showCheckAsYouTypeOption,
    bool showFindSuggestionsOption,
    bool showUserDictionaryButton
)
Function ShowDialog ( _
    owner As Object, _
    showCheckAsYouTypeOption As Boolean, _
    showFindSuggestionsOption As Boolean, _
    showUserDictionaryButton As Boolean _
) As DialogResult
DialogResult ShowDialog(
    Object^ owner,
    bool showCheckAsYouTypeOption,
    bool showFindSuggestionsOption,
    bool showUserDictionaryButton
)
Parameters
owner (Object)
showCheckAsYouTypeOption (Boolean)
showFindSuggestionsOption (Boolean)
showUserDictionaryButton (Boolean)


IDialogViewUserDictionaryEdit Interface

IDialogViewUserDictionaryEdit Interface
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionaryEdit
Keyoti RapidSpell Silverlight
Describes a user dictionary editor window
Declaration Syntax
C# Visual Basic Visual C++
public interface IDialogViewUserDictionaryEdit
Public Interface IDialogViewUserDictionaryEdit
public interface class IDialogViewUserDictionaryEdit
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddWord | Word is being added
 | Dispose()()() | Frees resources
 | FinishDelegate | Called after the ChildWindow is closed, delegate is set internally by RapidSpell, form logic should call delegate when closing.
 | RemoveWord | Word is being removed
 | ShowDialog(Object, ArrayList) | Shows the form modally
 | UserDictionaryFormAddText | UI text
 | UserDictionaryFormCancelText | UI text
 | UserDictionaryFormContentsText | UI text
 | UserDictionaryFormDeleteText | UI text
 | UserDictionaryFormDictionaryLabelText | UI text
 | UserDictionaryFormOKText | UI text
 | UserDictionaryFormTitleText | UI text
 | UserDictionaryFormWordLabelText | UI text


AddWord Event

AddWord Event
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionaryEdit ► AddWord
Keyoti RapidSpell Silverlight
Word is being added
Declaration Syntax
C# Visual Basic Visual C++
event UserDictionaryEditEventHandler AddWord
Event AddWord As UserDictionaryEditEventHandler
 event UserDictionaryEditEventHandler^ AddWord {
    void add (UserDictionaryEditEventHandler^ value);
    void remove (UserDictionaryEditEventHandler^ value);
}


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionaryEdit ► Dispose()()()
Keyoti RapidSpell Silverlight
Frees resources
Declaration Syntax
C# Visual Basic Visual C++
void Dispose()
Sub Dispose
void Dispose()


FinishDelegate Property

FinishDelegate Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionaryEdit ► FinishDelegate
Keyoti RapidSpell Silverlight
Called after the ChildWindow is closed, delegate is set internally by RapidSpell, form logic should call delegate when closing.
Declaration Syntax
C# Visual Basic Visual C++
ParameterizedThreadStart FinishDelegate { get; set; }
Property FinishDelegate As ParameterizedThreadStart
property ParameterizedThreadStart^ FinishDelegate {
    ParameterizedThreadStart^ get ();
    void set (ParameterizedThreadStart^ value);
}


RemoveWord Event

RemoveWord Event
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionaryEdit ► RemoveWord
Keyoti RapidSpell Silverlight
Word is being removed
Declaration Syntax
C# Visual Basic Visual C++
event UserDictionaryEditEventHandler RemoveWord
Event RemoveWord As UserDictionaryEditEventHandler
 event UserDictionaryEditEventHandler^ RemoveWord {
    void add (UserDictionaryEditEventHandler^ value);
    void remove (UserDictionaryEditEventHandler^ value);
}


ShowDialog Method (owner, userDictionaryContents)

ShowDialog Method (owner, userDictionaryContents)
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionaryEdit ► ShowDialog(Object, ArrayList)
Keyoti RapidSpell Silverlight
Shows the form modally
Declaration Syntax
C# Visual Basic Visual C++
DialogResult ShowDialog(
    Object owner,
    ArrayList userDictionaryContents
)
Function ShowDialog ( _
    owner As Object, _
    userDictionaryContents As ArrayList _
) As DialogResult
DialogResult ShowDialog(
    Object^ owner,
    ArrayList^ userDictionaryContents
)
Parameters
owner (Object)
userDictionaryContents (ArrayList)


UserDictionaryFormAddText Property

UserDictionaryFormAddText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionaryEdit ► UserDictionaryFormAddText
Keyoti RapidSpell Silverlight
UI text
Declaration Syntax
C# Visual Basic Visual C++
string UserDictionaryFormAddText { get; set; }
Property UserDictionaryFormAddText As String
property String^ UserDictionaryFormAddText {
    String^ get ();
    void set (String^ value);
}


UserDictionaryFormCancelText Property

UserDictionaryFormCancelText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionaryEdit ► UserDictionaryFormCancelText
Keyoti RapidSpell Silverlight
UI text
Declaration Syntax
C# Visual Basic Visual C++
string UserDictionaryFormCancelText { get; set; }
Property UserDictionaryFormCancelText As String
property String^ UserDictionaryFormCancelText {
    String^ get ();
    void set (String^ value);
}


UserDictionaryFormContentsText Property

UserDictionaryFormContentsText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionaryEdit ► UserDictionaryFormContentsText
Keyoti RapidSpell Silverlight
UI text
Declaration Syntax
C# Visual Basic Visual C++
string UserDictionaryFormContentsText { get; set; }
Property UserDictionaryFormContentsText As String
property String^ UserDictionaryFormContentsText {
    String^ get ();
    void set (String^ value);
}


UserDictionaryFormDeleteText Property

UserDictionaryFormDeleteText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionaryEdit ► UserDictionaryFormDeleteText
Keyoti RapidSpell Silverlight
UI text
Declaration Syntax
C# Visual Basic Visual C++
string UserDictionaryFormDeleteText { get; set; }
Property UserDictionaryFormDeleteText As String
property String^ UserDictionaryFormDeleteText {
    String^ get ();
    void set (String^ value);
}


UserDictionaryFormDictionaryLabelText Property

UserDictionaryFormDictionaryLabelText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionaryEdit ► UserDictionaryFormDictionaryLabelText
Keyoti RapidSpell Silverlight
UI text
Declaration Syntax
C# Visual Basic Visual C++
string UserDictionaryFormDictionaryLabelText { get; set; }
Property UserDictionaryFormDictionaryLabelText As String
property String^ UserDictionaryFormDictionaryLabelText {
    String^ get ();
    void set (String^ value);
}


UserDictionaryFormOKText Property

UserDictionaryFormOKText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionaryEdit ► UserDictionaryFormOKText
Keyoti RapidSpell Silverlight
UI text
Declaration Syntax
C# Visual Basic Visual C++
string UserDictionaryFormOKText { get; set; }
Property UserDictionaryFormOKText As String
property String^ UserDictionaryFormOKText {
    String^ get ();
    void set (String^ value);
}


UserDictionaryFormTitleText Property

UserDictionaryFormTitleText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionaryEdit ► UserDictionaryFormTitleText
Keyoti RapidSpell Silverlight
UI text
Declaration Syntax
C# Visual Basic Visual C++
string UserDictionaryFormTitleText { get; set; }
Property UserDictionaryFormTitleText As String
property String^ UserDictionaryFormTitleText {
    String^ get ();
    void set (String^ value);
}


UserDictionaryFormWordLabelText Property

UserDictionaryFormWordLabelText Property
API ► Keyoti.RapidSpell.DialogViews ► IDialogViewUserDictionaryEdit ► UserDictionaryFormWordLabelText
Keyoti RapidSpell Silverlight
UI text
Declaration Syntax
C# Visual Basic Visual C++
string UserDictionaryFormWordLabelText { get; set; }
Property UserDictionaryFormWordLabelText As String
property String^ UserDictionaryFormWordLabelText {
    String^ get ();
    void set (String^ value);
}


Keyoti.RapidSpell.Event Namespace

Keyoti.RapidSpell.Event Namespace
API ► Keyoti.RapidSpell.Event
Keyoti RapidSpell Silverlight
The namespace for events.

Events and delegates

Declaration Syntax
C# Visual Basic Visual C++
namespace Keyoti.RapidSpell.Event
Namespace Keyoti.RapidSpell.Event
namespace Keyoti.RapidSpell.Event
Types
All Types Classes Delegates
Icon | Type | Description
 | ChangeWordEventArgs | Holds data for the ChangeWord event.
 | CreateDialogViewEventArgs | Event args for create IDialogView event
 | CreateDialogViewEventHandler | EventHandler delegate
 | CreateDialogViewOptionsEventArgs | Event args for create IDialogViewOptions event
 | CreateDialogViewOptionsEventHandler | EventHandler delegate
 | CreateDialogViewUserDictionaryEditEventArgs | Event args for create IDialogViewUserDictionaryEdit event
 | CreateDialogViewUserDictionaryEditEventHandler | EventHandler delegate
 | CreateUserInterfaceFormPresenterEventArgs | Event args for create presenter event
 | CreateUserInterfaceFormPresenterEventHandler | EventHandler delegate
 | SpellCheckEventArgs | Args for the events fired when RapidSpellGUI,RapidSpellDialog or RapidSpellAYT starts or stops.
 | SpellCheckEventHandler | Spell check event handler delegate.
 | SpellContextMenuEventArgs | Args for the events fired when the spell checkers context menu is requested.
 | TextBoxSpellCheckEventArgs | Args for the events fired when spell checking multiple text boxes.
 | UserQueryEventArgs | Event args for user query event
 | UserQueryEventHandler | EventHandler delegate


ChangeWordEventArgs Class

ChangeWordEventArgs Class
API ► Keyoti.RapidSpell.Event ► ChangeWordEventArgs
Keyoti RapidSpell Silverlight
Holds data for the ChangeWord event.
Declaration Syntax
C# Visual Basic Visual C++
public class ChangeWordEventArgs : EventArgs
Public Class ChangeWordEventArgs _
    Inherits EventArgs
public ref class ChangeWordEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChangeWordEventArgs(String, String, Int32) | Creates a new ChangeWordEventArgs
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Index | The index of the word in the text
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewWord | The new word
 | OldWord | The word being replaced
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | ChangeWordEventArgs


ChangeWordEventArgs Constructor (oldWord, newWord, index)

ChangeWordEventArgs Constructor (oldWord, newWord, index)
API ► Keyoti.RapidSpell.Event ► ChangeWordEventArgs ► ChangeWordEventArgs(String, String, Int32)
Keyoti RapidSpell Silverlight
Creates a new ChangeWordEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public ChangeWordEventArgs(
    string oldWord,
    string newWord,
    int index
)
Public Sub New ( _
    oldWord As String, _
    newWord As String, _
    index As Integer _
)
public:
ChangeWordEventArgs(
    String^ oldWord,
    String^ newWord,
    int index
)
Parameters
oldWord (String)
newWord (String)
index (Int32)


Index Property

Index Property
API ► Keyoti.RapidSpell.Event ► ChangeWordEventArgs ► Index
Keyoti RapidSpell Silverlight
The index of the word in the text
Declaration Syntax
C# Visual Basic Visual C++
public int Index { get; }
Public ReadOnly Property Index As Integer
public:
property int Index {
    int get ();
}


NewWord Property

NewWord Property
API ► Keyoti.RapidSpell.Event ► ChangeWordEventArgs ► NewWord
Keyoti RapidSpell Silverlight
The new word
Declaration Syntax
C# Visual Basic Visual C++
public string NewWord { get; }
Public ReadOnly Property NewWord As String
public:
property String^ NewWord {
    String^ get ();
}


OldWord Property

OldWord Property
API ► Keyoti.RapidSpell.Event ► ChangeWordEventArgs ► OldWord
Keyoti RapidSpell Silverlight
The word being replaced
Declaration Syntax
C# Visual Basic Visual C++
public string OldWord { get; }
Public ReadOnly Property OldWord As String
public:
property String^ OldWord {
    String^ get ();
}


CreateDialogViewEventArgs Class

CreateDialogViewEventArgs Class
API ► Keyoti.RapidSpell.Event ► CreateDialogViewEventArgs
Keyoti RapidSpell Silverlight
Event args for create IDialogView event
Declaration Syntax
C# Visual Basic Visual C++
public class CreateDialogViewEventArgs : EventArgs
Public Class CreateDialogViewEventArgs _
    Inherits EventArgs
public ref class CreateDialogViewEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CreateDialogViewEventArgs(IDialogView) | New
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewView | The new view to use
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | CreateDialogViewEventArgs


CreateDialogViewEventArgs Constructor (newView)

CreateDialogViewEventArgs Constructor (newView)
API ► Keyoti.RapidSpell.Event ► CreateDialogViewEventArgs ► CreateDialogViewEventArgs(IDialogView)
Keyoti RapidSpell Silverlight
New
Declaration Syntax
C# Visual Basic Visual C++
public CreateDialogViewEventArgs(
    IDialogView newView
)
Public Sub New ( _
    newView As IDialogView _
)
public:
CreateDialogViewEventArgs(
    IDialogView^ newView
)
Parameters
newView (IDialogView)


NewView Property

NewView Property
API ► Keyoti.RapidSpell.Event ► CreateDialogViewEventArgs ► NewView
Keyoti RapidSpell Silverlight
The new view to use
Declaration Syntax
C# Visual Basic Visual C++
public IDialogView NewView { get; set; }
Public Property NewView As IDialogView
public:
property IDialogView^ NewView {
    IDialogView^ get ();
    void set (IDialogView^ value);
}


CreateDialogViewEventHandler Delegate

CreateDialogViewEventHandler Delegate
API ► Keyoti.RapidSpell.Event ► CreateDialogViewEventHandler
Keyoti RapidSpell Silverlight
EventHandler delegate
Declaration Syntax
C# Visual Basic Visual C++
public delegate void CreateDialogViewEventHandler(
    Object sender,
    CreateDialogViewEventArgs e
)
Public Delegate Sub CreateDialogViewEventHandler ( _
    sender As Object, _
    e As CreateDialogViewEventArgs _
)
public delegate void CreateDialogViewEventHandler(
    Object^ sender,
    CreateDialogViewEventArgs^ e
)
Parameters
sender (Object)
e (CreateDialogViewEventArgs)


CreateDialogViewOptionsEventArgs Class

CreateDialogViewOptionsEventArgs Class
API ► Keyoti.RapidSpell.Event ► CreateDialogViewOptionsEventArgs
Keyoti RapidSpell Silverlight
Event args for create IDialogViewOptions event
Declaration Syntax
C# Visual Basic Visual C++
public class CreateDialogViewOptionsEventArgs : EventArgs
Public Class CreateDialogViewOptionsEventArgs _
    Inherits EventArgs
public ref class CreateDialogViewOptionsEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CreateDialogViewOptionsEventArgs(IDialogViewOptions, UserOptions) | New
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewView | The new view to use
 | Options | The UserOptions instance in use by the view
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | CreateDialogViewOptionsEventArgs


CreateDialogViewOptionsEventArgs Constructor (newView, options)

CreateDialogViewOptionsEventArgs Constructor (newView, options)
API ► Keyoti.RapidSpell.Event ► CreateDialogViewOptionsEventArgs ► CreateDialogViewOptionsEventArgs(IDialogViewOptions, UserOptions)
Keyoti RapidSpell Silverlight
New
Declaration Syntax
C# Visual Basic Visual C++
public CreateDialogViewOptionsEventArgs(
    IDialogViewOptions newView,
    UserOptions options
)
Public Sub New ( _
    newView As IDialogViewOptions, _
    options As UserOptions _
)
public:
CreateDialogViewOptionsEventArgs(
    IDialogViewOptions^ newView,
    UserOptions^ options
)
Parameters
newView (IDialogViewOptions)
options (UserOptions)


NewView Property

NewView Property
API ► Keyoti.RapidSpell.Event ► CreateDialogViewOptionsEventArgs ► NewView
Keyoti RapidSpell Silverlight
The new view to use
Declaration Syntax
C# Visual Basic Visual C++
public IDialogViewOptions NewView { get; set; }
Public Property NewView As IDialogViewOptions
public:
property IDialogViewOptions^ NewView {
    IDialogViewOptions^ get ();
    void set (IDialogViewOptions^ value);
}


Options Property

Options Property
API ► Keyoti.RapidSpell.Event ► CreateDialogViewOptionsEventArgs ► Options
Keyoti RapidSpell Silverlight
The UserOptions instance in use by the view
Declaration Syntax
C# Visual Basic Visual C++
public UserOptions Options { get; }
Public ReadOnly Property Options As UserOptions
public:
property UserOptions^ Options {
    UserOptions^ get ();
}


CreateDialogViewOptionsEventHandler Delegate

CreateDialogViewOptionsEventHandler Delegate
API ► Keyoti.RapidSpell.Event ► CreateDialogViewOptionsEventHandler
Keyoti RapidSpell Silverlight
EventHandler delegate
Declaration Syntax
C# Visual Basic Visual C++
public delegate void CreateDialogViewOptionsEventHandler(
    Object sender,
    CreateDialogViewOptionsEventArgs e
)
Public Delegate Sub CreateDialogViewOptionsEventHandler ( _
    sender As Object, _
    e As CreateDialogViewOptionsEventArgs _
)
public delegate void CreateDialogViewOptionsEventHandler(
    Object^ sender,
    CreateDialogViewOptionsEventArgs^ e
)
Parameters
sender (Object)
e (CreateDialogViewOptionsEventArgs)


CreateDialogViewUserDictionaryEditEventArgs Class

CreateDialogViewUserDictionaryEditEventArgs Class
API ► Keyoti.RapidSpell.Event ► CreateDialogViewUserDictionaryEditEventArgs
Keyoti RapidSpell Silverlight
Event args for create IDialogViewUserDictionaryEdit event
Declaration Syntax
C# Visual Basic Visual C++
public class CreateDialogViewUserDictionaryEditEventArgs : EventArgs
Public Class CreateDialogViewUserDictionaryEditEventArgs _
    Inherits EventArgs
public ref class CreateDialogViewUserDictionaryEditEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CreateDialogViewUserDictionaryEditEventArgs(IDialogViewUserDictionaryEdit) | New
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewView | The view to use
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | CreateDialogViewUserDictionaryEditEventArgs


CreateDialogViewUserDictionaryEditEventArgs Constructor (newView)

CreateDialogViewUserDictionaryEditEventArgs Constructor (newView)
API ► Keyoti.RapidSpell.Event ► CreateDialogViewUserDictionaryEditEventArgs ► CreateDialogViewUserDictionaryEditEventArgs(IDialogViewUserDictionaryEdit)
Keyoti RapidSpell Silverlight
New
Declaration Syntax
C# Visual Basic Visual C++
public CreateDialogViewUserDictionaryEditEventArgs(
    IDialogViewUserDictionaryEdit newView
)
Public Sub New ( _
    newView As IDialogViewUserDictionaryEdit _
)
public:
CreateDialogViewUserDictionaryEditEventArgs(
    IDialogViewUserDictionaryEdit^ newView
)
Parameters
newView (IDialogViewUserDictionaryEdit)


NewView Property

NewView Property
API ► Keyoti.RapidSpell.Event ► CreateDialogViewUserDictionaryEditEventArgs ► NewView
Keyoti RapidSpell Silverlight
The view to use
Declaration Syntax
C# Visual Basic Visual C++
public IDialogViewUserDictionaryEdit NewView { get; set; }
Public Property NewView As IDialogViewUserDictionaryEdit
public:
property IDialogViewUserDictionaryEdit^ NewView {
    IDialogViewUserDictionaryEdit^ get ();
    void set (IDialogViewUserDictionaryEdit^ value);
}


CreateDialogViewUserDictionaryEditEventHandler Delegate

CreateDialogViewUserDictionaryEditEventHandler Delegate
API ► Keyoti.RapidSpell.Event ► CreateDialogViewUserDictionaryEditEventHandler
Keyoti RapidSpell Silverlight
EventHandler delegate
Declaration Syntax
C# Visual Basic Visual C++
public delegate void CreateDialogViewUserDictionaryEditEventHandler(
    Object sender,
    CreateDialogViewUserDictionaryEditEventArgs e
)
Public Delegate Sub CreateDialogViewUserDictionaryEditEventHandler ( _
    sender As Object, _
    e As CreateDialogViewUserDictionaryEditEventArgs _
)
public delegate void CreateDialogViewUserDictionaryEditEventHandler(
    Object^ sender,
    CreateDialogViewUserDictionaryEditEventArgs^ e
)
Parameters
sender (Object)
e (CreateDialogViewUserDictionaryEditEventArgs)


CreateUserInterfaceFormPresenterEventArgs Class

CreateUserInterfaceFormPresenterEventArgs Class
API ► Keyoti.RapidSpell.Event ► CreateUserInterfaceFormPresenterEventArgs
Keyoti RapidSpell Silverlight
Event args for create presenter event
Declaration Syntax
C# Visual Basic Visual C++
public class CreateUserInterfaceFormPresenterEventArgs : EventArgs
Public Class CreateUserInterfaceFormPresenterEventArgs _
    Inherits EventArgs
public ref class CreateUserInterfaceFormPresenterEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CreateUserInterfaceFormPresenterEventArgs(IUserInterfaceFormPresenter) | New
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewPresenter | The presenter to use
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | CreateUserInterfaceFormPresenterEventArgs


CreateUserInterfaceFormPresenterEventArgs Constructor (newPresenter)

CreateUserInterfaceFormPresenterEventArgs Constructor (newPresenter)
API ► Keyoti.RapidSpell.Event ► CreateUserInterfaceFormPresenterEventArgs ► CreateUserInterfaceFormPresenterEventArgs(IUserInterfaceFormPresenter)
Keyoti RapidSpell Silverlight
New
Declaration Syntax
C# Visual Basic Visual C++
public CreateUserInterfaceFormPresenterEventArgs(
    IUserInterfaceFormPresenter newPresenter
)
Public Sub New ( _
    newPresenter As IUserInterfaceFormPresenter _
)
public:
CreateUserInterfaceFormPresenterEventArgs(
    IUserInterfaceFormPresenter^ newPresenter
)
Parameters
newPresenter (IUserInterfaceFormPresenter)


NewPresenter Property

NewPresenter Property
API ► Keyoti.RapidSpell.Event ► CreateUserInterfaceFormPresenterEventArgs ► NewPresenter
Keyoti RapidSpell Silverlight
The presenter to use
Declaration Syntax
C# Visual Basic Visual C++
public IUserInterfaceFormPresenter NewPresenter { get; set; }
Public Property NewPresenter As IUserInterfaceFormPresenter
public:
property IUserInterfaceFormPresenter^ NewPresenter {
    IUserInterfaceFormPresenter^ get ();
    void set (IUserInterfaceFormPresenter^ value);
}


CreateUserInterfaceFormPresenterEventHandler Delegate

CreateUserInterfaceFormPresenterEventHandler Delegate
API ► Keyoti.RapidSpell.Event ► CreateUserInterfaceFormPresenterEventHandler
Keyoti RapidSpell Silverlight
EventHandler delegate
Declaration Syntax
C# Visual Basic Visual C++
public delegate void CreateUserInterfaceFormPresenterEventHandler(
    Object s,
    CreateUserInterfaceFormPresenterEventArgs e
)
Public Delegate Sub CreateUserInterfaceFormPresenterEventHandler ( _
    s As Object, _
    e As CreateUserInterfaceFormPresenterEventArgs _
)
public delegate void CreateUserInterfaceFormPresenterEventHandler(
    Object^ s,
    CreateUserInterfaceFormPresenterEventArgs^ e
)
Parameters
s (Object)
e (CreateUserInterfaceFormPresenterEventArgs)


SpellCheckEventArgs Class

SpellCheckEventArgs Class
API ► Keyoti.RapidSpell.Event ► SpellCheckEventArgs
Keyoti RapidSpell Silverlight
Args for the events fired when RapidSpellGUI,RapidSpellDialog or RapidSpellAYT starts or stops.
Declaration Syntax
C# Visual Basic Visual C++
public class SpellCheckEventArgs : EventArgs
Public Class SpellCheckEventArgs _
    Inherits EventArgs
public ref class SpellCheckEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SpellCheckEventArgs()()() |
 | SpellCheckEventArgs(Boolean) |
 | Cancelled | Whether the spell check was cancelled.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | SpellCheckEventArgs


SpellCheckEventArgs Constructor

SpellCheckEventArgs Constructor
API ► Keyoti.RapidSpell.Event ► SpellCheckEventArgs ► SpellCheckEventArgs()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | SpellCheckEventArgs()()() |
 | SpellCheckEventArgs(Boolean) |


SpellCheckEventArgs Constructor

SpellCheckEventArgs Constructor
API ► Keyoti.RapidSpell.Event ► SpellCheckEventArgs ► SpellCheckEventArgs()()()
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public SpellCheckEventArgs()
Public Sub New
public:
SpellCheckEventArgs()


SpellCheckEventArgs Constructor (cancelled)

SpellCheckEventArgs Constructor (cancelled)
API ► Keyoti.RapidSpell.Event ► SpellCheckEventArgs ► SpellCheckEventArgs(Boolean)
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public SpellCheckEventArgs(
    bool cancelled
)
Public Sub New ( _
    cancelled As Boolean _
)
public:
SpellCheckEventArgs(
    bool cancelled
)
Parameters
cancelled (Boolean)


Cancelled Property

Cancelled Property
API ► Keyoti.RapidSpell.Event ► SpellCheckEventArgs ► Cancelled
Keyoti RapidSpell Silverlight
Whether the spell check was cancelled.
Declaration Syntax
C# Visual Basic Visual C++
public bool Cancelled { get; }
Public ReadOnly Property Cancelled As Boolean
public:
property bool Cancelled {
    bool get ();
}


SpellCheckEventHandler Delegate

SpellCheckEventHandler Delegate
API ► Keyoti.RapidSpell.Event ► SpellCheckEventHandler
Keyoti RapidSpell Silverlight
Spell check event handler delegate.
Declaration Syntax
C# Visual Basic Visual C++
public delegate void SpellCheckEventHandler(
    Object sender,
    SpellCheckEventArgs e
)
Public Delegate Sub SpellCheckEventHandler ( _
    sender As Object, _
    e As SpellCheckEventArgs _
)
public delegate void SpellCheckEventHandler(
    Object^ sender,
    SpellCheckEventArgs^ e
)
Parameters
sender (Object)
e (SpellCheckEventArgs)


SpellContextMenuEventArgs Class

SpellContextMenuEventArgs Class
API ► Keyoti.RapidSpell.Event ► SpellContextMenuEventArgs
Keyoti RapidSpell Silverlight
Args for the events fired when the spell checkers context menu is requested.
Declaration Syntax
C# Visual Basic Visual C++
public class SpellContextMenuEventArgs : EventArgs
Public Class SpellContextMenuEventArgs _
    Inherits EventArgs
public ref class SpellContextMenuEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SpellContextMenuEventArgs(IList, Int32, Int32, Int32) | New
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MenuItems | List of menu items with suggestions, ignore and add options.
 | RightClickCharIndex | Character index where right click was made.
 | RightClickWordEnd | End index of word right clicked on.
 | RightClickWordStart | Start index of word right clicked on.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Contains menu items so that they maybe shown in a different menu/contextmenu.
Inheritance Hierarchy
Object
 | EventArgs
 |  | SpellContextMenuEventArgs


SpellContextMenuEventArgs Constructor (menuItems, charIndex, rwordStart, rwordEnd)

SpellContextMenuEventArgs Constructor (menuItems, charIndex, rwordStart, rwordEnd)
API ► Keyoti.RapidSpell.Event ► SpellContextMenuEventArgs ► SpellContextMenuEventArgs(IList, Int32, Int32, Int32)
Keyoti RapidSpell Silverlight
New
Declaration Syntax
C# Visual Basic Visual C++
public SpellContextMenuEventArgs(
    IList menuItems,
    int charIndex,
    int rwordStart,
    int rwordEnd
)
Public Sub New ( _
    menuItems As IList, _
    charIndex As Integer, _
    rwordStart As Integer, _
    rwordEnd As Integer _
)
public:
SpellContextMenuEventArgs(
    IList^ menuItems,
    int charIndex,
    int rwordStart,
    int rwordEnd
)
Parameters
menuItems (IList)
charIndex (Int32)
rwordStart (Int32)
rwordEnd (Int32)


MenuItems Property

MenuItems Property
API ► Keyoti.RapidSpell.Event ► SpellContextMenuEventArgs ► MenuItems
Keyoti RapidSpell Silverlight
List of menu items with suggestions, ignore and add options.
Declaration Syntax
C# Visual Basic Visual C++
public IList MenuItems { get; }
Public ReadOnly Property MenuItems As IList
public:
property IList^ MenuItems {
    IList^ get ();
}


RightClickCharIndex Property

RightClickCharIndex Property
API ► Keyoti.RapidSpell.Event ► SpellContextMenuEventArgs ► RightClickCharIndex
Keyoti RapidSpell Silverlight
Character index where right click was made.
Declaration Syntax
C# Visual Basic Visual C++
public int RightClickCharIndex { get; }
Public ReadOnly Property RightClickCharIndex As Integer
public:
property int RightClickCharIndex {
    int get ();
}


RightClickWordEnd Property

RightClickWordEnd Property
API ► Keyoti.RapidSpell.Event ► SpellContextMenuEventArgs ► RightClickWordEnd
Keyoti RapidSpell Silverlight
End index of word right clicked on.
Declaration Syntax
C# Visual Basic Visual C++
public int RightClickWordEnd { get; }
Public ReadOnly Property RightClickWordEnd As Integer
public:
property int RightClickWordEnd {
    int get ();
}


RightClickWordStart Property

RightClickWordStart Property
API ► Keyoti.RapidSpell.Event ► SpellContextMenuEventArgs ► RightClickWordStart
Keyoti RapidSpell Silverlight
Start index of word right clicked on.
Declaration Syntax
C# Visual Basic Visual C++
public int RightClickWordStart { get; }
Public ReadOnly Property RightClickWordStart As Integer
public:
property int RightClickWordStart {
    int get ();
}


TextBoxSpellCheckEventArgs Class

TextBoxSpellCheckEventArgs Class
API ► Keyoti.RapidSpell.Event ► TextBoxSpellCheckEventArgs
Keyoti RapidSpell Silverlight
Args for the events fired when spell checking multiple text boxes.
Declaration Syntax
C# Visual Basic Visual C++
public class TextBoxSpellCheckEventArgs : EventArgs
Public Class TextBoxSpellCheckEventArgs _
    Inherits EventArgs
public ref class TextBoxSpellCheckEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TextBoxSpellCheckEventArgs(Int32) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TextBoxIndex | The related text box index, this corresponds to the array of ISpellCheckableTextComponents that has been set for checking (0 for single text box checks).
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | TextBoxSpellCheckEventArgs


TextBoxSpellCheckEventArgs Constructor (textBoxIndex)

TextBoxSpellCheckEventArgs Constructor (textBoxIndex)
API ► Keyoti.RapidSpell.Event ► TextBoxSpellCheckEventArgs ► TextBoxSpellCheckEventArgs(Int32)
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public TextBoxSpellCheckEventArgs(
    int textBoxIndex
)
Public Sub New ( _
    textBoxIndex As Integer _
)
public:
TextBoxSpellCheckEventArgs(
    int textBoxIndex
)
Parameters
textBoxIndex (Int32)


TextBoxIndex Property

TextBoxIndex Property
API ► Keyoti.RapidSpell.Event ► TextBoxSpellCheckEventArgs ► TextBoxIndex
Keyoti RapidSpell Silverlight
The related text box index, this corresponds to the array of ISpellCheckableTextComponents that has been set for checking (0 for single text box checks).
Declaration Syntax
C# Visual Basic Visual C++
public int TextBoxIndex { get; }
Public ReadOnly Property TextBoxIndex As Integer
public:
property int TextBoxIndex {
    int get ();
}


UserQueryEventArgs Class

UserQueryEventArgs Class
API ► Keyoti.RapidSpell.Event ► UserQueryEventArgs
Keyoti RapidSpell Silverlight
Event args for user query event
Declaration Syntax
C# Visual Basic Visual C++
public class UserQueryEventArgs : EventArgs
Public Class UserQueryEventArgs _
    Inherits EventArgs
public ref class UserQueryEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserQueryEventArgs(BadWord, Object) | New
 | BadWord | The misspelling
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TextBox | The textbox being checked
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | UserQueryEventArgs


UserQueryEventArgs Constructor (theBadWord, textBox)

UserQueryEventArgs Constructor (theBadWord, textBox)
API ► Keyoti.RapidSpell.Event ► UserQueryEventArgs ► UserQueryEventArgs(BadWord, Object)
Keyoti RapidSpell Silverlight
New
Declaration Syntax
C# Visual Basic Visual C++
public UserQueryEventArgs(
    BadWord theBadWord,
    Object textBox
)
Public Sub New ( _
    theBadWord As BadWord, _
    textBox As Object _
)
public:
UserQueryEventArgs(
    BadWord^ theBadWord,
    Object^ textBox
)
Parameters
theBadWord (BadWord)
textBox (Object)


BadWord Property

BadWord Property
API ► Keyoti.RapidSpell.Event ► UserQueryEventArgs ► BadWord
Keyoti RapidSpell Silverlight
The misspelling
Declaration Syntax
C# Visual Basic Visual C++
public BadWord BadWord { get; set; }
Public Property BadWord As BadWord
public:
property BadWord^ BadWord {
    BadWord^ get ();
    void set (BadWord^ value);
}


TextBox Property

TextBox Property
API ► Keyoti.RapidSpell.Event ► UserQueryEventArgs ► TextBox
Keyoti RapidSpell Silverlight
The textbox being checked
Declaration Syntax
C# Visual Basic Visual C++
public Object TextBox { get; }
Public ReadOnly Property TextBox As Object
public:
property Object^ TextBox {
    Object^ get ();
}


UserQueryEventHandler Delegate

UserQueryEventHandler Delegate
API ► Keyoti.RapidSpell.Event ► UserQueryEventHandler
Keyoti RapidSpell Silverlight
EventHandler delegate
Declaration Syntax
C# Visual Basic Visual C++
public delegate void UserQueryEventHandler(
    Object s,
    UserQueryEventArgs e
)
Public Delegate Sub UserQueryEventHandler ( _
    s As Object, _
    e As UserQueryEventArgs _
)
public delegate void UserQueryEventHandler(
    Object^ s,
    UserQueryEventArgs^ e
)
Parameters
s (Object)
e (UserQueryEventArgs)


Keyoti.RapidSpell.FrameWorkSpecific Namespace

Keyoti.RapidSpell.FrameWorkSpecific Namespace
API ► Keyoti.RapidSpell.FrameWorkSpecific
Keyoti RapidSpell Silverlight
The namespace for RapidSpell Desktop .NET specific classes.

Misc

Declaration Syntax
C# Visual Basic Visual C++
namespace Keyoti.RapidSpell.FrameWorkSpecific
Namespace Keyoti.RapidSpell.FrameWorkSpecific
namespace Keyoti.RapidSpell.FrameWorkSpecific
Types
All Types Classes
Icon | Type | Description
 | AdvancedTextBoundary | A word parser, capable of working with XML documents.
 | SimpleTextBoundary | A simple word parser, for plain text.


AdvancedTextBoundary Class

AdvancedTextBoundary Class
API ► Keyoti.RapidSpell.FrameWorkSpecific ► AdvancedTextBoundary
Keyoti RapidSpell Silverlight
A word parser, capable of working with XML documents.
Declaration Syntax
C# Visual Basic Visual C++
public class AdvancedTextBoundary : SimpleTextBoundary
Public Class AdvancedTextBoundary _
    Inherits SimpleTextBoundary
public ref class AdvancedTextBoundary : public SimpleTextBoundary
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AdvancedTextBoundary()()() |
 | CheckLegalOffset(Int32, String, Boolean) | Throws an ArgumentOutOfRangeException if offset is out of bounds. (Inherited from SimpleTextBoundary.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | f_languageParsing | Language rules to use when parsing. (Inherited from SimpleTextBoundary.)
 | f_separateHyphenWords | Whether to simply treat hyphens as breaking chars. (Inherited from SimpleTextBoundary.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Following(Int32) | Returns the next breaking point in the text. (Overrides SimpleTextBoundary.Following(Int32).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IgnoreXML | Whether to ignore XML/HTML tags, should be set true for RichTextBox support, false by default.
 | isAtNonBreakingWhiteSpace(Int32, Boolean, Boolean) | Whether position is non-breaking white space (Overrides SimpleTextBoundary.isAtNonBreakingWhiteSpace(Int32, Boolean, Boolean).)
 | isAtNonBreakingWhiteSpace(Int32) | Whether the character at position is a nonbreaking whitespace. (Inherited from SimpleTextBoundary.)
 | isAtNonWhiteSpace(Int32) | Whether position is not whitespace. (Overrides SimpleTextBoundary.isAtNonWhiteSpace(Int32).)
 | isBetweenWordChars(Int32) | Whether the character at position is between nonbreaking white space or letters or digits. (Inherited from SimpleTextBoundary.)
 | isBetweenWordChars(Int32, Boolean, Boolean) | Whether the character at position is between nonbreaking white space or letters or digits. (Inherited from SimpleTextBoundary.)
 | IsBoundary(Int32) | Determines if character at offset is a boundary (Inherited from SimpleTextBoundary.)
 | IsBoundaryLeft(Int32) | Whether offset is a boundary to the left of text (Inherited from SimpleTextBoundary.)
 | IsBoundaryRight(Int32) | Whether offset is one place after the last character in a word. (Inherited from SimpleTextBoundary.)
 | IsStartOfSentence(Int32) | Whether the character at offset is the first letter or digit of the sentence. (Inherited from SimpleTextBoundary.)
 | LanguageParsing | The language parsing to be used. (Inherited from SimpleTextBoundary.)
 | Last()()() | Return the last boundary. The iterator's current position is set to the last boundary. (Inherited from SimpleTextBoundary.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Preceding(Int32) | this ignores xml tags butted between text. (Overrides SimpleTextBoundary.Preceding(Int32).)
 | SeparateHyphenWords | Whether to treat hyphenated (-) words as separate words, default is false. (Inherited from SimpleTextBoundary.)
 | SetText(String) | Sets the text to be analysed. (Overrides SimpleTextBoundary.SetText(String).)
 | TextIsStartOfTextBody | If known, whether the text to be set in SetText is the start of the text body. Affects sentence determination. (Inherited from SimpleTextBoundary.)
 | theText | The text being parsed. (Inherited from SimpleTextBoundary.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | V2Parser | Whether to use parser version 2 (Inherited from SimpleTextBoundary.)
Inheritance Hierarchy
Object
 | SimpleTextBoundary
 |  | AdvancedTextBoundary


AdvancedTextBoundary Constructor

AdvancedTextBoundary Constructor
API ► Keyoti.RapidSpell.FrameWorkSpecific ► AdvancedTextBoundary ► AdvancedTextBoundary()()()
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public AdvancedTextBoundary()
Public Sub New
public:
AdvancedTextBoundary()


Following Method (offset)

Following Method (offset)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► AdvancedTextBoundary ► Following(Int32)
Keyoti RapidSpell Silverlight
Returns the next breaking point in the text.
Declaration Syntax
C# Visual Basic Visual C++
public override int Following(
    int offset
)
Public Overrides Function Following ( _
    offset As Integer _
) As Integer
public:
virtual int Following(
    int offset
) override
Parameters
offset (Int32)


IgnoreXML Property

IgnoreXML Property
API ► Keyoti.RapidSpell.FrameWorkSpecific ► AdvancedTextBoundary ► IgnoreXML
Keyoti RapidSpell Silverlight
Whether to ignore XML/HTML tags, should be set true for RichTextBox support, false by default.
Declaration Syntax
C# Visual Basic Visual C++
public bool IgnoreXML { get; set; }
Public Property IgnoreXML As Boolean
public:
property bool IgnoreXML {
    bool get ();
    void set (bool value);
}


isAtNonBreakingWhiteSpace Method (position, previousIsIfThisIs, nextIsIfThisIs)

isAtNonBreakingWhiteSpace Method (position, previousIsIfThisIs, nextIsIfThisIs)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► AdvancedTextBoundary ► isAtNonBreakingWhiteSpace(Int32, Boolean, Boolean)
Keyoti RapidSpell Silverlight
Whether position is non-breaking white space
Declaration Syntax
C# Visual Basic Visual C++
protected override bool isAtNonBreakingWhiteSpace(
    int position,
    bool previousIsIfThisIs,
    bool nextIsIfThisIs
)
Protected Overrides Function isAtNonBreakingWhiteSpace ( _
    position As Integer, _
    previousIsIfThisIs As Boolean, _
    nextIsIfThisIs As Boolean _
) As Boolean
protected:
virtual bool isAtNonBreakingWhiteSpace(
    int position,
    bool previousIsIfThisIs,
    bool nextIsIfThisIs
) override
Parameters
position (Int32)
previousIsIfThisIs (Boolean)
nextIsIfThisIs (Boolean)


isAtNonWhiteSpace Method (position)

isAtNonWhiteSpace Method (position)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► AdvancedTextBoundary ► isAtNonWhiteSpace(Int32)
Keyoti RapidSpell Silverlight
Whether position is not whitespace.
Declaration Syntax
C# Visual Basic Visual C++
protected override bool isAtNonWhiteSpace(
    int position
)
Protected Overrides Function isAtNonWhiteSpace ( _
    position As Integer _
) As Boolean
protected:
virtual bool isAtNonWhiteSpace(
    int position
) override
Parameters
position (Int32)


Preceding Method (offset)

Preceding Method (offset)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► AdvancedTextBoundary ► Preceding(Int32)
Keyoti RapidSpell Silverlight
this ignores xml tags butted between text.
Declaration Syntax
C# Visual Basic Visual C++
public override int Preceding(
    int offset
)
Public Overrides Function Preceding ( _
    offset As Integer _
) As Integer
public:
virtual int Preceding(
    int offset
) override
Parameters
offset (Int32)


SetText Method (t)

SetText Method (t)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► AdvancedTextBoundary ► SetText(String)
Keyoti RapidSpell Silverlight
Sets the text to be analysed.
Declaration Syntax
C# Visual Basic Visual C++
public override void SetText(
    string t
)
Public Overrides Sub SetText ( _
    t As String _
)
public:
virtual void SetText(
    String^ t
) override
Parameters
t (String)


SimpleTextBoundary Class

SimpleTextBoundary Class
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary
Keyoti RapidSpell Silverlight
A simple word parser, for plain text.
Declaration Syntax
C# Visual Basic Visual C++
public class SimpleTextBoundary
Public Class SimpleTextBoundary
public ref class SimpleTextBoundary
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SimpleTextBoundary()()() |
 | breakChars | Characters that aren't letters or digits and do break words apart
 | CheckLegalOffset(Int32, String, Boolean) | Throws an ArgumentOutOfRangeException if offset is out of bounds.
 | ENGLISH | English text parsing.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | f_languageParsing | Language rules to use when parsing.
 | f_separateHyphenWords | Whether to simply treat hyphens as breaking chars.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Following(Int32) | Return the first boundary after the specified offset
 | FRENCH | French text parsing.
 | GERMAN | French text parsing.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | isAtNonBreakingWhiteSpace(Int32) | Whether the character at position is a nonbreaking whitespace.
 | isAtNonBreakingWhiteSpace(Int32, Boolean, Boolean) | Whether the character at position is a nonbreaking whitespace.
 | isAtNonWhiteSpace(Int32) | Returns whether the character at position is whitespace, this is contextually relevant.
 | isBetweenWordChars(Int32) | Whether the character at position is between nonbreaking white space or letters or digits.
 | isBetweenWordChars(Int32, Boolean, Boolean) | Whether the character at position is between nonbreaking white space or letters or digits.
 | IsBoundary(Int32) | Determines if character at offset is a boundary
 | IsBoundaryLeft(Int32) | Whether offset is a boundary to the left of text
 | IsBoundaryRight(Int32) | Whether offset is one place after the last character in a word.
 | IsStartOfSentence(Int32) | Whether the character at offset is the first letter or digit of the sentence.
 | LanguageParsing | The language parsing to be used.
 | Last()()() | Return the last boundary. The iterator's current position is set to the last boundary.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | noBreakButLookIntoChars | Characters that aren't letters or digits but do not break words apart, however the spell checker should consider words on either side as separate words
 | noBreakButLookIntoCharsLength | The number of chars in the noBreakButLookIntoChars field
 | noBreakChars | Characters that aren't letters or digits but do not break words apart
 | Preceding(Int32) | Return the first boundary before the specified offset
 | SeparateHyphenWords | Whether to treat hyphenated (-) words as separate words, default is false.
 | SetText(String) | Sets the text to be analysed.
 | TextIsStartOfTextBody | If known, whether the text to be set in SetText is the start of the text body. Affects sentence determination.
 | theText | The text being parsed.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | V2Parser | Whether to use parser version 2
Inheritance Hierarchy
Object
 | SimpleTextBoundary
 |  | AdvancedTextBoundary


SimpleTextBoundary Constructor

SimpleTextBoundary Constructor
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► SimpleTextBoundary()()()
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public SimpleTextBoundary()
Public Sub New
public:
SimpleTextBoundary()


breakChars Field

breakChars Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► breakChars
Keyoti RapidSpell Silverlight
Characters that aren't letters or digits and do break words apart
Declaration Syntax
C# Visual Basic Visual C++
public const string breakChars
Public Const breakChars As String
public:
literal String^ breakChars


CheckLegalOffset Method (offset, message, allowEnd)

CheckLegalOffset Method (offset, message, allowEnd)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► CheckLegalOffset(Int32, String, Boolean)
Keyoti RapidSpell Silverlight
Throws an ArgumentOutOfRangeException if offset is out of bounds.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void CheckLegalOffset(
    int offset,
    string message,
    bool allowEnd
)
Protected Overridable Sub CheckLegalOffset ( _
    offset As Integer, _
    message As String, _
    allowEnd As Boolean _
)
protected:
virtual void CheckLegalOffset(
    int offset,
    String^ message,
    bool allowEnd
)
Parameters
offset (Int32)
message (String)
allowEnd (Boolean)


ENGLISH Field

ENGLISH Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► ENGLISH
Keyoti RapidSpell Silverlight
English text parsing.
Declaration Syntax
C# Visual Basic Visual C++
public static int ENGLISH
Public Shared ENGLISH As Integer
public:
static int ENGLISH


f_languageParsing Field

f_languageParsing Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► f_languageParsing
Keyoti RapidSpell Silverlight
Language rules to use when parsing.
Declaration Syntax
C# Visual Basic Visual C++
protected int f_languageParsing
Protected f_languageParsing As Integer
protected:
int f_languageParsing


f_separateHyphenWords Field

f_separateHyphenWords Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► f_separateHyphenWords
Keyoti RapidSpell Silverlight
Whether to simply treat hyphens as breaking chars.
Declaration Syntax
C# Visual Basic Visual C++
protected bool f_separateHyphenWords
Protected f_separateHyphenWords As Boolean
protected:
bool f_separateHyphenWords


Following Method (offset)

Following Method (offset)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► Following(Int32)
Keyoti RapidSpell Silverlight
Return the first boundary after the specified offset
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Following(
    int offset
)
Public Overridable Function Following ( _
    offset As Integer _
) As Integer
public:
virtual int Following(
    int offset
)
Parameters
offset (Int32)
the offset to start
Return Value
int the first boundary after offset


FRENCH Field

FRENCH Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► FRENCH
Keyoti RapidSpell Silverlight
French text parsing.
Declaration Syntax
C# Visual Basic Visual C++
public static int FRENCH
Public Shared FRENCH As Integer
public:
static int FRENCH


GERMAN Field

GERMAN Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► GERMAN
Keyoti RapidSpell Silverlight
French text parsing.
Declaration Syntax
C# Visual Basic Visual C++
public static int GERMAN
Public Shared GERMAN As Integer
public:
static int GERMAN


isAtNonBreakingWhiteSpace Method

isAtNonBreakingWhiteSpace Method
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► isAtNonBreakingWhiteSpace()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | isAtNonBreakingWhiteSpace(Int32) | Whether the character at position is a nonbreaking whitespace.
 | isAtNonBreakingWhiteSpace(Int32, Boolean, Boolean) | Whether the character at position is a nonbreaking whitespace.


isAtNonBreakingWhiteSpace Method (position)

isAtNonBreakingWhiteSpace Method (position)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► isAtNonBreakingWhiteSpace(Int32)
Keyoti RapidSpell Silverlight
Whether the character at position is a nonbreaking whitespace.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual bool isAtNonBreakingWhiteSpace(
    int position
)
Protected Overridable Function isAtNonBreakingWhiteSpace ( _
    position As Integer _
) As Boolean
protected:
virtual bool isAtNonBreakingWhiteSpace(
    int position
)
Parameters
position (Int32)


isAtNonBreakingWhiteSpace Method (position, previousIsIfThisIs, nextIsIfThisIs)

isAtNonBreakingWhiteSpace Method (position, previousIsIfThisIs, nextIsIfThisIs)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► isAtNonBreakingWhiteSpace(Int32, Boolean, Boolean)
Keyoti RapidSpell Silverlight
Whether the character at position is a nonbreaking whitespace.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual bool isAtNonBreakingWhiteSpace(
    int position,
    bool previousIsIfThisIs,
    bool nextIsIfThisIs
)
Protected Overridable Function isAtNonBreakingWhiteSpace ( _
    position As Integer, _
    previousIsIfThisIs As Boolean, _
    nextIsIfThisIs As Boolean _
) As Boolean
protected:
virtual bool isAtNonBreakingWhiteSpace(
    int position,
    bool previousIsIfThisIs,
    bool nextIsIfThisIs
)
Parameters
position (Int32)
previousIsIfThisIs (Boolean)
nextIsIfThisIs (Boolean)


isAtNonWhiteSpace Method (position)

isAtNonWhiteSpace Method (position)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► isAtNonWhiteSpace(Int32)
Keyoti RapidSpell Silverlight
Returns whether the character at position is whitespace, this is contextually relevant.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual bool isAtNonWhiteSpace(
    int position
)
Protected Overridable Function isAtNonWhiteSpace ( _
    position As Integer _
) As Boolean
protected:
virtual bool isAtNonWhiteSpace(
    int position
)
Parameters
position (Int32)


isBetweenWordChars Method

isBetweenWordChars Method
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► isBetweenWordChars()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | isBetweenWordChars(Int32) | Whether the character at position is between nonbreaking white space or letters or digits.
 | isBetweenWordChars(Int32, Boolean, Boolean) | Whether the character at position is between nonbreaking white space or letters or digits.


isBetweenWordChars Method (position)

isBetweenWordChars Method (position)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► isBetweenWordChars(Int32)
Keyoti RapidSpell Silverlight
Whether the character at position is between nonbreaking white space or letters or digits.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual bool isBetweenWordChars(
    int position
)
Protected Overridable Function isBetweenWordChars ( _
    position As Integer _
) As Boolean
protected:
virtual bool isBetweenWordChars(
    int position
)
Parameters
position (Int32)


isBetweenWordChars Method (position, previousIsIfThisIs, nextIsIfThisIs)

isBetweenWordChars Method (position, previousIsIfThisIs, nextIsIfThisIs)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► isBetweenWordChars(Int32, Boolean, Boolean)
Keyoti RapidSpell Silverlight
Whether the character at position is between nonbreaking white space or letters or digits.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual bool isBetweenWordChars(
    int position,
    bool previousIsIfThisIs,
    bool nextIsIfThisIs
)
Protected Overridable Function isBetweenWordChars ( _
    position As Integer, _
    previousIsIfThisIs As Boolean, _
    nextIsIfThisIs As Boolean _
) As Boolean
protected:
virtual bool isBetweenWordChars(
    int position,
    bool previousIsIfThisIs,
    bool nextIsIfThisIs
)
Parameters
position (Int32)
previousIsIfThisIs (Boolean)
nextIsIfThisIs (Boolean)


IsBoundary Method (offset)

IsBoundary Method (offset)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► IsBoundary(Int32)
Keyoti RapidSpell Silverlight
Determines if character at offset is a boundary
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsBoundary(
    int offset
)
Public Overridable Function IsBoundary ( _
    offset As Integer _
) As Boolean
public:
virtual bool IsBoundary(
    int offset
)
Parameters
offset (Int32)


IsBoundaryLeft Method (offset)

IsBoundaryLeft Method (offset)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► IsBoundaryLeft(Int32)
Keyoti RapidSpell Silverlight
Whether offset is a boundary to the left of text
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsBoundaryLeft(
    int offset
)
Public Overridable Function IsBoundaryLeft ( _
    offset As Integer _
) As Boolean
public:
virtual bool IsBoundaryLeft(
    int offset
)
Parameters
offset (Int32)


IsBoundaryRight Method (offset)

IsBoundaryRight Method (offset)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► IsBoundaryRight(Int32)
Keyoti RapidSpell Silverlight
Whether offset is one place after the last character in a word.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsBoundaryRight(
    int offset
)
Public Overridable Function IsBoundaryRight ( _
    offset As Integer _
) As Boolean
public:
virtual bool IsBoundaryRight(
    int offset
)
Parameters
offset (Int32)


IsStartOfSentence Method (offset)

IsStartOfSentence Method (offset)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► IsStartOfSentence(Int32)
Keyoti RapidSpell Silverlight
Whether the character at offset is the first letter or digit of the sentence.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool IsStartOfSentence(
    int offset
)
Public Overridable Function IsStartOfSentence ( _
    offset As Integer _
) As Boolean
public:
virtual bool IsStartOfSentence(
    int offset
)
Parameters
offset (Int32)


LanguageParsing Property

LanguageParsing Property
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► LanguageParsing
Keyoti RapidSpell Silverlight
The language parsing to be used.
Declaration Syntax
C# Visual Basic Visual C++
public int LanguageParsing { get; set; }
Public Property LanguageParsing As Integer
public:
property int LanguageParsing {
    int get ();
    void set (int value);
}


Last Method

Last Method
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► Last()()()
Keyoti RapidSpell Silverlight
Return the last boundary. The iterator's current position is set to the last boundary.
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Last()
Public Overridable Function Last As Integer
public:
virtual int Last()


noBreakButLookIntoChars Field

noBreakButLookIntoChars Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► noBreakButLookIntoChars
Keyoti RapidSpell Silverlight
Characters that aren't letters or digits but do not break words apart, however the spell checker should consider words on either side as separate words
Declaration Syntax
C# Visual Basic Visual C++
public const string noBreakButLookIntoChars
Public Const noBreakButLookIntoChars As String
public:
literal String^ noBreakButLookIntoChars


noBreakButLookIntoCharsLength Field

noBreakButLookIntoCharsLength Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► noBreakButLookIntoCharsLength
Keyoti RapidSpell Silverlight
The number of chars in the noBreakButLookIntoChars field
Declaration Syntax
C# Visual Basic Visual C++
public const int noBreakButLookIntoCharsLength
Public Const noBreakButLookIntoCharsLength As Integer
public:
literal int noBreakButLookIntoCharsLength


noBreakChars Field

noBreakChars Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► noBreakChars
Keyoti RapidSpell Silverlight
Characters that aren't letters or digits but do not break words apart
Declaration Syntax
C# Visual Basic Visual C++
public static char[] noBreakChars
Public Shared noBreakChars As Char()
public:
static array<wchar_t>^ noBreakChars


Preceding Method (offset)

Preceding Method (offset)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► Preceding(Int32)
Keyoti RapidSpell Silverlight
Return the first boundary before the specified offset
Declaration Syntax
C# Visual Basic Visual C++
public virtual int Preceding(
    int offset
)
Public Overridable Function Preceding ( _
    offset As Integer _
) As Integer
public:
virtual int Preceding(
    int offset
)
Parameters
offset (Int32)
the offset to start
Return Value
int the first boundary after offset


SeparateHyphenWords Property

SeparateHyphenWords Property
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► SeparateHyphenWords
Keyoti RapidSpell Silverlight
Whether to treat hyphenated (-) words as separate words, default is false.
Declaration Syntax
C# Visual Basic Visual C++
public bool SeparateHyphenWords { get; set; }
Public Property SeparateHyphenWords As Boolean
public:
property bool SeparateHyphenWords {
    bool get ();
    void set (bool value);
}
Remarks
For eg. if this is true text like "cheap-deals" will be treated as two words "cheap" and "deals", otherwise this will be treated as one word "cheap-deals".


SetText Method (t)

SetText Method (t)
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► SetText(String)
Keyoti RapidSpell Silverlight
Sets the text to be analysed.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetText(
    string t
)
Public Overridable Sub SetText ( _
    t As String _
)
public:
virtual void SetText(
    String^ t
)
Parameters
t (String)


TextIsStartOfTextBody Property

TextIsStartOfTextBody Property
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► TextIsStartOfTextBody
Keyoti RapidSpell Silverlight
If known, whether the text to be set in SetText is the start of the text body. Affects sentence determination.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool TextIsStartOfTextBody { get; set; }
Public Overridable Property TextIsStartOfTextBody As Boolean
public:
virtual property bool TextIsStartOfTextBody {
    bool get ();
    void set (bool value);
}


theText Field

theText Field
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► theText
Keyoti RapidSpell Silverlight
The text being parsed.
Declaration Syntax
C# Visual Basic Visual C++
protected string theText
Protected theText As String
protected:
String^ theText


V2Parser Property

V2Parser Property
API ► Keyoti.RapidSpell.FrameWorkSpecific ► SimpleTextBoundary ► V2Parser
Keyoti RapidSpell Silverlight
Whether to use parser version 2
Declaration Syntax
C# Visual Basic Visual C++
public bool V2Parser { get; set; }
Public Property V2Parser As Boolean
public:
property bool V2Parser {
    bool get ();
    void set (bool value);
}


Keyoti.RapidSpell.Options Namespace

Keyoti.RapidSpell.Options Namespace
API ► Keyoti.RapidSpell.Options
Keyoti RapidSpell Silverlight
User options related classes
Declaration Syntax
C# Visual Basic Visual C++
namespace Keyoti.RapidSpell.Options
Namespace Keyoti.RapidSpell.Options
namespace Keyoti.RapidSpell.Options
Types
All Types Classes Enumerations Delegates
Icon | Type | Description
 | UserDictionaryEditEventArgs..::.EditType | Types of edit operations
 | NeedStreamEventArgs | Event args for NeedCustomStreamForLoading and NeedCustomStreamForSaving event.
 | UserOptions..::.NeedStreamEventHandler | Delegate for need stream events.
 | OptionsPresenter | The presenter for IDialogViewOptions
 | UserOptions..::.StorageType | The option storage location
 | UserDictionaryEditEventArgs | Event args for a user dictionary edit event (add word, remove)
 | UserDictionaryEditEventHandler | Event handler delegate
 | UserOptions | Holds/Loads/Saves user options.


NeedStreamEventArgs Class

NeedStreamEventArgs Class
API ► Keyoti.RapidSpell.Options ► NeedStreamEventArgs
Keyoti RapidSpell Silverlight
Event args for NeedCustomStreamForLoading and NeedCustomStreamForSaving event.
Declaration Syntax
C# Visual Basic Visual C++
public class NeedStreamEventArgs : EventArgs
Public Class NeedStreamEventArgs _
    Inherits EventArgs
public ref class NeedStreamEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NeedStreamEventArgs()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RequiredStream | Set the stream in this property when handling the event.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | NeedStreamEventArgs


NeedStreamEventArgs Constructor

NeedStreamEventArgs Constructor
API ► Keyoti.RapidSpell.Options ► NeedStreamEventArgs ► NeedStreamEventArgs()()()
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public NeedStreamEventArgs()
Public Sub New
public:
NeedStreamEventArgs()


RequiredStream Property

RequiredStream Property
API ► Keyoti.RapidSpell.Options ► NeedStreamEventArgs ► RequiredStream
Keyoti RapidSpell Silverlight
Set the stream in this property when handling the event.
Declaration Syntax
C# Visual Basic Visual C++
public Stream RequiredStream { get; set; }
Public Property RequiredStream As Stream
public:
property Stream^ RequiredStream {
    Stream^ get ();
    void set (Stream^ value);
}


OptionsPresenter Class

OptionsPresenter Class
API ► Keyoti.RapidSpell.Options ► OptionsPresenter
Keyoti RapidSpell Silverlight
The presenter for IDialogViewOptions
Declaration Syntax
C# Visual Basic Visual C++
public class OptionsPresenter
Public Class OptionsPresenter
public ref class OptionsPresenter
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OptionsPresenter()()() |
 | CreateDialogViewOptions | Fired when an IDialogViewOptions is required.
 | CreateDialogViewUserDictionaryEdit | Fired when an IDialogViewUserDictionaryEdit is required.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCreateDialogViewOptions(CreateDialogViewOptionsEventArgs) | Raises event
 | OnCreateDialogViewUserDictionaryEdit(CreateDialogViewUserDictionaryEditEventArgs) | Raises event
 | Show(Object, UserOptions, RapidSpellGUIPresenter) | Shows the form
 | ShowCheckAsYouTypeOption | Whether to show the "Check as you type" option
 | ShowFindSuggestionsOption | Whether to show the "Always find suggestions" option
 | ShowUserDictionaryButton | Whether to show the user dictionary button
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WordRemoved | Fired when a word is removed from user dictionary.
Inheritance Hierarchy
Object
OptionsPresenter


OptionsPresenter Constructor

OptionsPresenter Constructor
API ► Keyoti.RapidSpell.Options ► OptionsPresenter ► OptionsPresenter()()()
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public OptionsPresenter()
Public Sub New
public:
OptionsPresenter()


CreateDialogViewOptions Event

CreateDialogViewOptions Event
API ► Keyoti.RapidSpell.Options ► OptionsPresenter ► CreateDialogViewOptions
Keyoti RapidSpell Silverlight
Fired when an IDialogViewOptions is required.
Declaration Syntax
C# Visual Basic Visual C++
public event CreateDialogViewOptionsEventHandler CreateDialogViewOptions
Public Event CreateDialogViewOptions As CreateDialogViewOptionsEventHandler
public:
 event CreateDialogViewOptionsEventHandler^ CreateDialogViewOptions {
    void add (CreateDialogViewOptionsEventHandler^ value);
    void remove (CreateDialogViewOptionsEventHandler^ value);
}


CreateDialogViewUserDictionaryEdit Event

CreateDialogViewUserDictionaryEdit Event
API ► Keyoti.RapidSpell.Options ► OptionsPresenter ► CreateDialogViewUserDictionaryEdit
Keyoti RapidSpell Silverlight
Fired when an IDialogViewUserDictionaryEdit is required.
Declaration Syntax
C# Visual Basic Visual C++
public event CreateDialogViewUserDictionaryEditEventHandler CreateDialogViewUserDictionaryEdit
Public Event CreateDialogViewUserDictionaryEdit As CreateDialogViewUserDictionaryEditEventHandler
public:
 event CreateDialogViewUserDictionaryEditEventHandler^ CreateDialogViewUserDictionaryEdit {
    void add (CreateDialogViewUserDictionaryEditEventHandler^ value);
    void remove (CreateDialogViewUserDictionaryEditEventHandler^ value);
}


OnCreateDialogViewOptions Method (ev)

OnCreateDialogViewOptions Method (ev)
API ► Keyoti.RapidSpell.Options ► OptionsPresenter ► OnCreateDialogViewOptions(CreateDialogViewOptionsEventArgs)
Keyoti RapidSpell Silverlight
Raises event
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void OnCreateDialogViewOptions(
    CreateDialogViewOptionsEventArgs ev
)
Protected Overridable Sub OnCreateDialogViewOptions ( _
    ev As CreateDialogViewOptionsEventArgs _
)
protected:
virtual void OnCreateDialogViewOptions(
    CreateDialogViewOptionsEventArgs^ ev
)
Parameters
ev (CreateDialogViewOptionsEventArgs)


OnCreateDialogViewUserDictionaryEdit Method (ev)

OnCreateDialogViewUserDictionaryEdit Method (ev)
API ► Keyoti.RapidSpell.Options ► OptionsPresenter ► OnCreateDialogViewUserDictionaryEdit(CreateDialogViewUserDictionaryEditEventArgs)
Keyoti RapidSpell Silverlight
Raises event
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void OnCreateDialogViewUserDictionaryEdit(
    CreateDialogViewUserDictionaryEditEventArgs ev
)
Protected Overridable Sub OnCreateDialogViewUserDictionaryEdit ( _
    ev As CreateDialogViewUserDictionaryEditEventArgs _
)
protected:
virtual void OnCreateDialogViewUserDictionaryEdit(
    CreateDialogViewUserDictionaryEditEventArgs^ ev
)
Parameters
ev (CreateDialogViewUserDictionaryEditEventArgs)


Show Method (modalOwner, userOptions, presenter)

Show Method (modalOwner, userOptions, presenter)
API ► Keyoti.RapidSpell.Options ► OptionsPresenter ► Show(Object, UserOptions, RapidSpellGUIPresenter)
Keyoti RapidSpell Silverlight
Shows the form
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool Show(
    Object modalOwner,
    UserOptions userOptions,
    RapidSpellGUIPresenter presenter
)
Public Overridable Function Show ( _
    modalOwner As Object, _
    userOptions As UserOptions, _
    presenter As RapidSpellGUIPresenter _
) As Boolean
public:
virtual bool Show(
    Object^ modalOwner,
    UserOptions^ userOptions,
    RapidSpellGUIPresenter^ presenter
)
Parameters
modalOwner (Object)
userOptions (UserOptions)
presenter (RapidSpellGUIPresenter)


ShowCheckAsYouTypeOption Property

ShowCheckAsYouTypeOption Property
API ► Keyoti.RapidSpell.Options ► OptionsPresenter ► ShowCheckAsYouTypeOption
Keyoti RapidSpell Silverlight
Whether to show the "Check as you type" option
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowCheckAsYouTypeOption { get; set; }
Public Property ShowCheckAsYouTypeOption As Boolean
public:
property bool ShowCheckAsYouTypeOption {
    bool get ();
    void set (bool value);
}


ShowFindSuggestionsOption Property

ShowFindSuggestionsOption Property
API ► Keyoti.RapidSpell.Options ► OptionsPresenter ► ShowFindSuggestionsOption
Keyoti RapidSpell Silverlight
Whether to show the "Always find suggestions" option
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowFindSuggestionsOption { get; set; }
Public Property ShowFindSuggestionsOption As Boolean
public:
property bool ShowFindSuggestionsOption {
    bool get ();
    void set (bool value);
}


ShowUserDictionaryButton Property

ShowUserDictionaryButton Property
API ► Keyoti.RapidSpell.Options ► OptionsPresenter ► ShowUserDictionaryButton
Keyoti RapidSpell Silverlight
Whether to show the user dictionary button
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowUserDictionaryButton { get; set; }
Public Property ShowUserDictionaryButton As Boolean
public:
property bool ShowUserDictionaryButton {
    bool get ();
    void set (bool value);
}


WordRemoved Event

WordRemoved Event
API ► Keyoti.RapidSpell.Options ► OptionsPresenter ► WordRemoved
Keyoti RapidSpell Silverlight
Fired when a word is removed from user dictionary.
Declaration Syntax
C# Visual Basic Visual C++
public event WordRemovedEventHandler WordRemoved
Public Event WordRemoved As WordRemovedEventHandler
public:
 event WordRemovedEventHandler^ WordRemoved {
    void add (WordRemovedEventHandler^ value);
    void remove (WordRemovedEventHandler^ value);
}


UserDictionaryEditEventArgs Class

UserDictionaryEditEventArgs Class
API ► Keyoti.RapidSpell.Options ► UserDictionaryEditEventArgs
Keyoti RapidSpell Silverlight
Event args for a user dictionary edit event (add word, remove)
Declaration Syntax
C# Visual Basic Visual C++
public class UserDictionaryEditEventArgs
Public Class UserDictionaryEditEventArgs
public ref class UserDictionaryEditEventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserDictionaryEditEventArgs(UserDictionaryEditEventArgs..::.EditType, String) | New instance
 | Edit | The edit operation
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Word | The word in question
Inheritance Hierarchy
Object
UserDictionaryEditEventArgs


UserDictionaryEditEventArgs Constructor (edit, word)

UserDictionaryEditEventArgs Constructor (edit, word)
API ► Keyoti.RapidSpell.Options ► UserDictionaryEditEventArgs ► UserDictionaryEditEventArgs(UserDictionaryEditEventArgs..::.EditType, String)
Keyoti RapidSpell Silverlight
New instance
Declaration Syntax
C# Visual Basic Visual C++
public UserDictionaryEditEventArgs(
    UserDictionaryEditEventArgs..::.EditType edit,
    string word
)
Public Sub New ( _
    edit As UserDictionaryEditEventArgs..::.EditType, _
    word As String _
)
public:
UserDictionaryEditEventArgs(
    UserDictionaryEditEventArgs..::.EditType edit,
    String^ word
)
Parameters
edit (UserDictionaryEditEventArgs..::.EditType)
The operation
word (String)
The word


Edit Property

Edit Property
API ► Keyoti.RapidSpell.Options ► UserDictionaryEditEventArgs ► Edit
Keyoti RapidSpell Silverlight
The edit operation
Declaration Syntax
C# Visual Basic Visual C++
public UserDictionaryEditEventArgs..::.EditType Edit { get; set; }
Public Property Edit As UserDictionaryEditEventArgs..::.EditType
public:
property UserDictionaryEditEventArgs..::.EditType Edit {
    UserDictionaryEditEventArgs..::.EditType get ();
    void set (UserDictionaryEditEventArgs..::.EditType value);
}


Word Property

Word Property
API ► Keyoti.RapidSpell.Options ► UserDictionaryEditEventArgs ► Word
Keyoti RapidSpell Silverlight
The word in question
Declaration Syntax
C# Visual Basic Visual C++
public string Word { get; set; }
Public Property Word As String
public:
property String^ Word {
    String^ get ();
    void set (String^ value);
}


UserDictionaryEditEventArgs.EditType Enumeration

UserDictionaryEditEventArgs..::.EditType Enumeration
API ► Keyoti.RapidSpell.Options ► UserDictionaryEditEventArgs ► UserDictionaryEditEventArgs..::.EditType
Keyoti RapidSpell Silverlight
Types of edit operations
Declaration Syntax
C# Visual Basic Visual C++
public enum EditType
Public Enumeration EditType
public enum class EditType
Members
Member | Description
Add | Add a word
Remove | Remove a word


UserDictionaryEditEventHandler Delegate

UserDictionaryEditEventHandler Delegate
API ► Keyoti.RapidSpell.Options ► UserDictionaryEditEventHandler
Keyoti RapidSpell Silverlight
Event handler delegate
Declaration Syntax
C# Visual Basic Visual C++
public delegate void UserDictionaryEditEventHandler(
    Object s,
    UserDictionaryEditEventArgs e
)
Public Delegate Sub UserDictionaryEditEventHandler ( _
    s As Object, _
    e As UserDictionaryEditEventArgs _
)
public delegate void UserDictionaryEditEventHandler(
    Object^ s,
    UserDictionaryEditEventArgs^ e
)
Parameters
s (Object)
e (UserDictionaryEditEventArgs)


UserOptions Class

UserOptions Class
API ► Keyoti.RapidSpell.Options ► UserOptions
Keyoti RapidSpell Silverlight
Holds/Loads/Saves user options.
Declaration Syntax
C# Visual Basic Visual C++
public class UserOptions
Public Class UserOptions
public ref class UserOptions
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserOptions()()() |
 | AllowAnyCase | (User option)
 | AllowMixedCase | (User option)
 | ChangeMaintainsCheckValidity()()() | Whether any changes have caused the current spell check progress to be invalid (requiring reset of the spell checker).
 | CheckAsYouType | (User option) Check as you type option
 | Clone()()() | Returns a copy of this object
 | CustomStreamForLoading | The stream to use when loading options
 | CustomStreamForSaving | The stream to use when saving options
 | Delete()()() | Delete the user's settings
 | Enabled | Whether options are enabled
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindSuggestions | (User option)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IgnoreCapitalizedWords | (User option)
 | IgnoreURLsAndEmailAddresses | (User option)
 | IgnoreWordsWithDigits | (User option)
 | IncludeUserDictionaryInSuggestions | (User option)
 | Load()()() | Load the user's settings
 | Load(Stream) | Load the users settings from userOptionsStream
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NeedCustomStreamForLoading | Fired when a custom stream can be set to load the options from.
 | NeedCustomStreamForSaving | Fired when a custom stream can be set to save the options to.
 | OnRecheckDocumentRequest(EventArgs) | Raises recheck document event
 | OptionsHaveChanged()()() | Whether this and c are set with the same options.
 | OptionsSaved | Fired when the options are saved
 | RecheckDocumentRequest | Fired when the user requests the text to be rechecked
 | Save()()() | Save user's settings
 | Save(Stream) | Save user's settings to stream
 | SetUserOptions(Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Sets new settings
 | StorageLocation | Where the user's options are stored.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserDictionary | The user dictionary loaded for the user
 | UserOptionsFileName | The file name used to store the settings (by default in IsolatedStorage).
Inheritance Hierarchy
Object
UserOptions


UserOptions Constructor

UserOptions Constructor
API ► Keyoti.RapidSpell.Options ► UserOptions ► UserOptions()()()
Keyoti RapidSpell Silverlight
Declaration Syntax
C# Visual Basic Visual C++
public UserOptions()
Public Sub New
public:
UserOptions()


AllowAnyCase Property

AllowAnyCase Property
API ► Keyoti.RapidSpell.Options ► UserOptions ► AllowAnyCase
Keyoti RapidSpell Silverlight
(User option)
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowAnyCase { get; }
Public ReadOnly Property AllowAnyCase As Boolean
public:
property bool AllowAnyCase {
    bool get ();
}


AllowMixedCase Property

AllowMixedCase Property
API ► Keyoti.RapidSpell.Options ► UserOptions ► AllowMixedCase
Keyoti RapidSpell Silverlight
(User option)
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowMixedCase { get; }
Public ReadOnly Property AllowMixedCase As Boolean
public:
property bool AllowMixedCase {
    bool get ();
}


ChangeMaintainsCheckValidity Method

ChangeMaintainsCheckValidity Method
API ► Keyoti.RapidSpell.Options ► UserOptions ► ChangeMaintainsCheckValidity()()()
Keyoti RapidSpell Silverlight
Whether any changes have caused the current spell check progress to be invalid (requiring reset of the spell checker).
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool ChangeMaintainsCheckValidity()
Public Overridable Function ChangeMaintainsCheckValidity As Boolean
public:
virtual bool ChangeMaintainsCheckValidity()


CheckAsYouType Property

CheckAsYouType Property
API ► Keyoti.RapidSpell.Options ► UserOptions ► CheckAsYouType
Keyoti RapidSpell Silverlight
(User option) Check as you type option
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckAsYouType { get; }
Public ReadOnly Property CheckAsYouType As Boolean
public:
property bool CheckAsYouType {
    bool get ();
}


Clone Method

Clone Method
API ► Keyoti.RapidSpell.Options ► UserOptions ► Clone()()()
Keyoti RapidSpell Silverlight
Returns a copy of this object
Declaration Syntax
C# Visual Basic Visual C++
public virtual UserOptions Clone()
Public Overridable Function Clone As UserOptions
public:
virtual UserOptions^ Clone()


CustomStreamForLoading Property

CustomStreamForLoading Property
API ► Keyoti.RapidSpell.Options ► UserOptions ► CustomStreamForLoading
Keyoti RapidSpell Silverlight
The stream to use when loading options
Declaration Syntax
C# Visual Basic Visual C++
public Stream CustomStreamForLoading { get; set; }
Public Property CustomStreamForLoading As Stream
public:
property Stream^ CustomStreamForLoading {
    Stream^ get ();
    void set (Stream^ value);
}


CustomStreamForSaving Property

CustomStreamForSaving Property
API ► Keyoti.RapidSpell.Options ► UserOptions ► CustomStreamForSaving
Keyoti RapidSpell Silverlight
The stream to use when saving options
Declaration Syntax
C# Visual Basic Visual C++
public Stream CustomStreamForSaving { get; set; }
Public Property CustomStreamForSaving As Stream
public:
property Stream^ CustomStreamForSaving {
    Stream^ get ();
    void set (Stream^ value);
}


Delete Method

Delete Method
API ► Keyoti.RapidSpell.Options ► UserOptions ► Delete()()()
Keyoti RapidSpell Silverlight
Delete the user's settings
Declaration Syntax
C# Visual Basic Visual C++
public void Delete()
Public Sub Delete
public:
void Delete()


Enabled Property

Enabled Property
API ► Keyoti.RapidSpell.Options ► UserOptions ► Enabled
Keyoti RapidSpell Silverlight
Whether options are enabled
Declaration Syntax
C# Visual Basic Visual C++
public bool Enabled { get; set; }
Public Property Enabled As Boolean
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}


FindSuggestions Property

FindSuggestions Property
API ► Keyoti.RapidSpell.Options ► UserOptions ► FindSuggestions
Keyoti RapidSpell Silverlight
(User option)
Declaration Syntax
C# Visual Basic Visual C++
public bool FindSuggestions { get; }
Public ReadOnly Property FindSuggestions As Boolean
public:
property bool FindSuggestions {
    bool get ();
}


IgnoreCapitalizedWords Property

IgnoreCapitalizedWords Property
API ► Keyoti.RapidSpell.Options ► UserOptions ► IgnoreCapitalizedWords
Keyoti RapidSpell Silverlight
(User option)
Declaration Syntax
C# Visual Basic Visual C++
public bool IgnoreCapitalizedWords { get; }
Public ReadOnly Property IgnoreCapitalizedWords As Boolean
public:
property bool IgnoreCapitalizedWords {
    bool get ();
}


IgnoreURLsAndEmailAddresses Property

IgnoreURLsAndEmailAddresses Property
API ► Keyoti.RapidSpell.Options ► UserOptions ► IgnoreURLsAndEmailAddresses
Keyoti RapidSpell Silverlight
(User option)
Declaration Syntax
C# Visual Basic Visual C++
public bool IgnoreURLsAndEmailAddresses { get; }
Public ReadOnly Property IgnoreURLsAndEmailAddresses As Boolean
public:
property bool IgnoreURLsAndEmailAddresses {
    bool get ();
}


IgnoreWordsWithDigits Property

IgnoreWordsWithDigits Property
API ► Keyoti.RapidSpell.Options ► UserOptions ► IgnoreWordsWithDigits
Keyoti RapidSpell Silverlight
(User option)
Declaration Syntax
C# Visual Basic Visual C++
public bool IgnoreWordsWithDigits { get; }
Public ReadOnly Property IgnoreWordsWithDigits As Boolean
public:
property bool IgnoreWordsWithDigits {
    bool get ();
}


IncludeUserDictionaryInSuggestions Property

IncludeUserDictionaryInSuggestions Property
API ► Keyoti.RapidSpell.Options ► UserOptions ► IncludeUserDictionaryInSuggestions
Keyoti RapidSpell Silverlight
(User option)
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeUserDictionaryInSuggestions { get; }
Public ReadOnly Property IncludeUserDictionaryInSuggestions As Boolean
public:
property bool IncludeUserDictionaryInSuggestions {
    bool get ();
}


Load Method

Load Method
API ► Keyoti.RapidSpell.Options ► UserOptions ► Load()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | Load()()() | Load the user's settings
 | Load(Stream) | Load the users settings from userOptionsStream


Load Method

Load Method
API ► Keyoti.RapidSpell.Options ► UserOptions ► Load()()()
Keyoti RapidSpell Silverlight
Load the user's settings
Declaration Syntax
C# Visual Basic Visual C++
public void Load()
Public Sub Load
public:
void Load()


Load Method (userOptionsStream)

Load Method (userOptionsStream)
API ► Keyoti.RapidSpell.Options ► UserOptions ► Load(Stream)
Keyoti RapidSpell Silverlight
Load the users settings from userOptionsStream
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Load(
    Stream userOptionsStream
)
Public Overridable Sub Load ( _
    userOptionsStream As Stream _
)
public:
virtual void Load(
    Stream^ userOptionsStream
)
Parameters
userOptionsStream (Stream)
XML file stream containing options


NeedCustomStreamForLoading Event

NeedCustomStreamForLoading Event
API ► Keyoti.RapidSpell.Options ► UserOptions ► NeedCustomStreamForLoading
Keyoti RapidSpell Silverlight
Fired when a custom stream can be set to load the options from.
Declaration Syntax
C# Visual Basic Visual C++
public event UserOptions..::.NeedStreamEventHandler NeedCustomStreamForLoading
Public Event NeedCustomStreamForLoading As UserOptions..::.NeedStreamEventHandler
public:
 event UserOptions..::.NeedStreamEventHandler^ NeedCustomStreamForLoading {
    void add (UserOptions..::.NeedStreamEventHandler^ value);
    void remove (UserOptions..::.NeedStreamEventHandler^ value);
}


NeedCustomStreamForSaving Event

NeedCustomStreamForSaving Event
API ► Keyoti.RapidSpell.Options ► UserOptions ► NeedCustomStreamForSaving
Keyoti RapidSpell Silverlight
Fired when a custom stream can be set to save the options to.
Declaration Syntax
C# Visual Basic Visual C++
public event UserOptions..::.NeedStreamEventHandler NeedCustomStreamForSaving
Public Event NeedCustomStreamForSaving As UserOptions..::.NeedStreamEventHandler
public:
 event UserOptions..::.NeedStreamEventHandler^ NeedCustomStreamForSaving {
    void add (UserOptions..::.NeedStreamEventHandler^ value);
    void remove (UserOptions..::.NeedStreamEventHandler^ value);
}


OnRecheckDocumentRequest Method (e)

OnRecheckDocumentRequest Method (e)
API ► Keyoti.RapidSpell.Options ► UserOptions ► OnRecheckDocumentRequest(EventArgs)
Keyoti RapidSpell Silverlight
Raises recheck document event
Declaration Syntax
C# Visual Basic Visual C++
public void OnRecheckDocumentRequest(
    EventArgs e
)
Public Sub OnRecheckDocumentRequest ( _
    e As EventArgs _
)
public:
void OnRecheckDocumentRequest(
    EventArgs^ e
)
Parameters
e (EventArgs)


OptionsHaveChanged Method

OptionsHaveChanged Method
API ► Keyoti.RapidSpell.Options ► UserOptions ► OptionsHaveChanged()()()
Keyoti RapidSpell Silverlight
Whether this and c are set with the same options.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool OptionsHaveChanged()
Public Overridable Function OptionsHaveChanged As Boolean
public:
virtual bool OptionsHaveChanged()


OptionsSaved Event

OptionsSaved Event
API ► Keyoti.RapidSpell.Options ► UserOptions ► OptionsSaved
Keyoti RapidSpell Silverlight
Fired when the options are saved
Declaration Syntax
C# Visual Basic Visual C++
public event OptionsSavedEventHandler OptionsSaved
Public Event OptionsSaved As OptionsSavedEventHandler
public:
 event OptionsSavedEventHandler^ OptionsSaved {
    void add (OptionsSavedEventHandler^ value);
    void remove (OptionsSavedEventHandler^ value);
}


RecheckDocumentRequest Event

RecheckDocumentRequest Event
API ► Keyoti.RapidSpell.Options ► UserOptions ► RecheckDocumentRequest
Keyoti RapidSpell Silverlight
Fired when the user requests the text to be rechecked
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler RecheckDocumentRequest
Public Event RecheckDocumentRequest As EventHandler
public:
 event EventHandler^ RecheckDocumentRequest {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


Save Method

Save Method
API ► Keyoti.RapidSpell.Options ► UserOptions ► Save()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | Save()()() | Save user's settings
 | Save(Stream) | Save user's settings to stream


Save Method

Save Method
API ► Keyoti.RapidSpell.Options ► UserOptions ► Save()()()
Keyoti RapidSpell Silverlight
Save user's settings
Declaration Syntax
C# Visual Basic Visual C++
public void Save()
Public Sub Save
public:
void Save()


Save Method (stream)

Save Method (stream)
API ► Keyoti.RapidSpell.Options ► UserOptions ► Save(Stream)
Keyoti RapidSpell Silverlight
Save user's settings to stream
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Save(
    Stream stream
)
Public Overridable Sub Save ( _
    stream As Stream _
)
public:
virtual void Save(
    Stream^ stream
)
Parameters
stream (Stream)


SetUserOptions Method (checkAsYouType, includeUserDictionaryInSuggestions, ignoreWordsWithDigits, ignoreURLsAndEmailAddresses, ignoreCapitalizedWords, allowMixedCase, allowAnyCase, findSuggestions, isTrackPoint)

SetUserOptions Method (checkAsYouType, includeUserDictionaryInSuggestions, ignoreWordsWithDigits, ignoreURLsAndEmailAddresses, ignoreCapitalizedWords, allowMixedCase, allowAnyCase, findSuggestions, isTrackPoint)
API ► Keyoti.RapidSpell.Options ► UserOptions ► SetUserOptions(Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)
Keyoti RapidSpell Silverlight
Sets new settings
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetUserOptions(
    bool checkAsYouType,
    bool includeUserDictionaryInSuggestions,
    bool ignoreWordsWithDigits,
    bool ignoreURLsAndEmailAddresses,
    bool ignoreCapitalizedWords,
    bool allowMixedCase,
    bool allowAnyCase,
    bool findSuggestions,
    bool isTrackPoint
)
Public Overridable Sub SetUserOptions ( _
    checkAsYouType As Boolean, _
    includeUserDictionaryInSuggestions As Boolean, _
    ignoreWordsWithDigits As Boolean, _
    ignoreURLsAndEmailAddresses As Boolean, _
    ignoreCapitalizedWords As Boolean, _
    allowMixedCase As Boolean, _
    allowAnyCase As Boolean, _
    findSuggestions As Boolean, _
    isTrackPoint As Boolean _
)
public:
virtual void SetUserOptions(
    bool checkAsYouType,
    bool includeUserDictionaryInSuggestions,
    bool ignoreWordsWithDigits,
    bool ignoreURLsAndEmailAddresses,
    bool ignoreCapitalizedWords,
    bool allowMixedCase,
    bool allowAnyCase,
    bool findSuggestions,
    bool isTrackPoint
)
Parameters
checkAsYouType (Boolean)
includeUserDictionaryInSuggestions (Boolean)
ignoreWordsWithDigits (Boolean)
ignoreURLsAndEmailAddresses (Boolean)
ignoreCapitalizedWords (Boolean)
allowMixedCase (Boolean)
allowAnyCase (Boolean)
findSuggestions (Boolean)
isTrackPoint (Boolean)
Remarks
Set isTrackPoint to true in order to monitor changes from this point until Save is called. See OptionsSavedEventArgs for indicator for change since track point.


StorageLocation Property

StorageLocation Property
API ► Keyoti.RapidSpell.Options ► UserOptions ► StorageLocation
Keyoti RapidSpell Silverlight
Where the user's options are stored.
Declaration Syntax
C# Visual Basic Visual C++
public UserOptions..::.StorageType StorageLocation { get; set; }
Public Property StorageLocation As UserOptions..::.StorageType
public:
property UserOptions..::.StorageType StorageLocation {
    UserOptions..::.StorageType get ();
    void set (UserOptions..::.StorageType value);
}


UserDictionary Property

UserDictionary Property
API ► Keyoti.RapidSpell.Options ► UserOptions ► UserDictionary
Keyoti RapidSpell Silverlight
The user dictionary loaded for the user
Declaration Syntax
C# Visual Basic Visual C++
public UserDictionary UserDictionary { get; set; }
Public Property UserDictionary As UserDictionary
public:
property UserDictionary^ UserDictionary {
    UserDictionary^ get ();
    void set (UserDictionary^ value);
}


UserOptionsFileName Property

UserOptionsFileName Property
API ► Keyoti.RapidSpell.Options ► UserOptions ► UserOptionsFileName
Keyoti RapidSpell Silverlight
The file name used to store the settings (by default in IsolatedStorage).
Declaration Syntax
C# Visual Basic Visual C++
public string UserOptionsFileName { get; set; }
Public Property UserOptionsFileName As String
public:
property String^ UserOptionsFileName {
    String^ get ();
    void set (String^ value);
}
Remarks
Changing this can ensure different applications have unique user settings.


UserOptions.NeedStreamEventHandler Delegate

UserOptions..::.NeedStreamEventHandler Delegate
API ► Keyoti.RapidSpell.Options ► UserOptions ► UserOptions..::.NeedStreamEventHandler
Keyoti RapidSpell Silverlight
Delegate for need stream events.
Declaration Syntax
C# Visual Basic Visual C++
public delegate void NeedStreamEventHandler(
    Object sender,
    NeedStreamEventArgs e
)
Public Delegate Sub NeedStreamEventHandler ( _
    sender As Object, _
    e As NeedStreamEventArgs _
)
public delegate void NeedStreamEventHandler(
    Object^ sender,
    NeedStreamEventArgs^ e
)
Parameters
sender (Object)
e (NeedStreamEventArgs)


UserOptions.StorageType Enumeration

UserOptions..::.StorageType Enumeration
API ► Keyoti.RapidSpell.Options ► UserOptions ► UserOptions..::.StorageType
Keyoti RapidSpell Silverlight
The option storage location
Declaration Syntax
C# Visual Basic Visual C++
public enum StorageType
Public Enumeration StorageType
public enum class StorageType
Members
Member | Description
IsolatedStorage | The .NET isolated storage mechanism
Stream | A stream provided by the API user


MemberwiseClone Method

MemberwiseClone Method
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► MemberwiseClone()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object.


MemberwiseClone Method

MemberwiseClone Method
API ► Keyoti.RapidSpell.Compression ► GZipStream ► MemberwiseClone()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object.


BinarySearch Method

BinarySearch Method
API ► Keyoti.RapidSpell ► ArrayList ► BinarySearch()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | BinarySearch(String, IComparer) |
 | BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element.
 | BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element.
 | BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element.


IndexOf Method

IndexOf Method
API ► Keyoti.RapidSpell ► ArrayList ► IndexOf()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>).
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element.
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements.


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell.Compression ► GZipStream ► Dispose()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | Dispose(Boolean) | Dispose the stream. (Overrides Stream.Dispose(Boolean).)
 | Dispose()()() | Releases all resources used by the Stream.


MemberwiseClone Method

MemberwiseClone Method
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► MemberwiseClone()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object.


CopyTo Method

CopyTo Method
API ► Keyoti.RapidSpell ► ArrayList ► CopyTo()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array.
 | CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array.
 | CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array.


FindIndex Method

FindIndex Method
API ► Keyoti.RapidSpell ► ArrayList ► FindIndex()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>).
 | FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element.
 | FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements.


FindLastIndex Method

FindLastIndex Method
API ► Keyoti.RapidSpell ► ArrayList ► FindLastIndex()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>).
 | FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index.
 | FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index.


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell.Compression ► CrcCalculatorStream ► Dispose()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | Dispose()()() | Releases all resources used by the Stream.
 | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources.


ToArray Method

ToArray Method
API ► Keyoti.RapidSpell ► ArrayList ► ToArray()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | ToArray(Type) |
 | ToArray()()() | Copies the elements of the List<(Of <(T>)>) to a new array.


Sort Method

Sort Method
API ► Keyoti.RapidSpell ► ArrayList ► Sort()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer.
 | Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer.
 | Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer.
 | Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>).


GetRectFromCharacterIndex Method

GetRectFromCharacterIndex Method
API ► Keyoti.RapidSpell ► TextBoxEx ► GetRectFromCharacterIndex()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | GetRectFromCharacterIndex(Int32) |
 | GetRectFromCharacterIndex(Int32, Boolean) |


LastIndexOf Method

LastIndexOf Method
API ► Keyoti.RapidSpell ► ArrayList ► LastIndexOf()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>).
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index.
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index.


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► Dispose()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | Dispose(Boolean) | Dispose the stream. (Overrides Stream.Dispose(Boolean).)
 | Dispose()()() | Releases all resources used by the Stream.


Dispose Method

Dispose Method
API ► Keyoti.RapidSpell.Compression ► DeflateStream ► Dispose()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | Dispose(Boolean) | Dispose the stream. (Overrides Stream.Dispose(Boolean).)
 | Dispose()()() | Releases all resources used by the Stream.


MemberwiseClone Method

MemberwiseClone Method
API ► Keyoti.RapidSpell.Compression ► ZlibStream ► MemberwiseClone()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object.


isAtNonBreakingWhiteSpace Method

isAtNonBreakingWhiteSpace Method
API ► Keyoti.RapidSpell.FrameWorkSpecific ► AdvancedTextBoundary ► isAtNonBreakingWhiteSpace()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | isAtNonBreakingWhiteSpace(Int32, Boolean, Boolean) | Whether position is non-breaking white space (Overrides SimpleTextBoundary.isAtNonBreakingWhiteSpace(Int32, Boolean, Boolean).)
 | isAtNonBreakingWhiteSpace(Int32) | Whether the character at position is a nonbreaking whitespace.


Reverse Method

Reverse Method
API ► Keyoti.RapidSpell ► ArrayList ► Reverse()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>).
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range.


isBetweenWordChars Method

isBetweenWordChars Method
API ► Keyoti.RapidSpell.FrameWorkSpecific ► AdvancedTextBoundary ► isBetweenWordChars()()()
Keyoti RapidSpell Silverlight
Members
Icon | Member | Description
 | isBetweenWordChars(Int32) | Whether the character at position is between nonbreaking white space or letters or digits.
 | isBetweenWordChars(Int32, Boolean, Boolean) | Whether the character at position is between nonbreaking white space or letters or digits.