RapidSpell Web .NET Documentation: Terms & Conditions

Terms & Conditions

If you do not agree to these terms and conditions then you may not install, use, or distribute RapidSpell Web.

1. License and Ownership. RapidSpell Web is a licensed software product. RapidSpell Web, including its accompanying files and documentation, is owned and copyrighted by Keyoti Inc., © Copyright 2003-2013, all rights reserved. Keyoti Inc. grants the user in possession of an official receipt of purchase a nonexclusive license to download and use the software, for any lawful commercial or non-commercial purposes provided the terms of this agreement are met.
2. Development and Distribution. If you purchased a One Developer License Version then you may copy and use the RapidSpell Web distribution file (.zip) on any systems you use but for your development use only. If you purchased a multi developer license version then the number of developers specified in the license type are afforded the rights of a One Developer License. Development use is defined as one person having the ability to read or copy any of the files originally contained in the RapidSpell Web distribution file including (but not limited to) the .dll, .csc, .html, .gif, .jpg, .bat, and .txt files. You must take appropriate safeguards to protect this product from unauthorized access by others. If you purchased a Site License Version of RapidSpell Web, then you may provide copies of the RapidSpell Web distribution file (.zip) to anyone employed by your company whose primary work address is within a 100 mile (160 km) radius of your primary work address. These individuals then have license rights and responsibilities equivalent to the Developer License Version. In all cases the copies of the RapidSpell Web distribution file (.zip) must be unaltered and complete, including this license agreement and all copyright notices. The evaluation version must not be re-distributed in any form.
You may not reverse engineer, disassemble, decompile, or modify this software or its accompanying documentation in any way.
You may reproduce and redistribute a copy of the dll files as part of any .NET based software developed and licensed by you that itself uses RapidSpell Web provided
a) your software is installed on no more web-site domains or servers than specified by the license type purchased,
b) your software has clearly distinct and added functionality,
c) you are responsible for all technical support,
d) the RapidSpell Web application programming interfaces are not documented, exposed, or otherwise made available by your software,
e) attribution is given to Keyoti Inc. (http://www.keyoti.com) in any documentation or screen displays where other credits appear,
f) you do not allow recipients of your software to reverse engineer, disassemble, decompile, or copy portions from your software allowing them to gain separate access to RapidSpell Web or any parts of it. The source code samples included with this package and in the RapidSpell Web documentation may be freely used, modified, incorporated, and distributed without restriction as part of any software that uses RapidSpell Web itself,
g) your software is not used by software or web developers as part of their application, and
h) your software is not a software component, 'Web Control' or 'Server Control'.
3. Warranty Disclaimer and Limitation of Liability. RapidSpell Web is licensed to the user on an "AS IS" basis. Keyoti Inc. MAKES NO WARRANTIES, EITHER EXPRESSED OR IMPLIED, WITH RESPECT TO THIS SOFTWARE AND ITS ASSOCIATED FILES AND DOCUMENTATION, INCLUDING BUT NOT LIMITED TO ANY WARRANTY OF MERCHANTABILITY OR FITNESS FOR ANY PARTICULAR PURPOSE. KEYOTI INC. DOES NOT WARRANT THAT THE OPERATION OF THIS SOFTWARE WILL BE UNINTERRUPTED OR ERROR FREE, OR THAT DEFECTS WILL BE CORRECTED. You the user are solely responsible for determining the appropriateness of this software for your use and accept full responsibility for all risks associated with its use. Keyoti Inc. is not and will not be liable for any direct, indirect, special or incidental damages in any amount including loss of profits or interruption of business however caused, even if Keyoti Inc. has been advised of the possibility of such damages. Keyoti Inc. retains the right to, in its sole discretion, refund the purchase price of this software as a complete and final resolution to any dispute.
SPECIFIC DISCLAIMER FOR HIGH-RISK ACTIVITIES. The SOFTWARE is not designed or intended for use in high-risk activities including, without restricting the generality of the foregoing, on-line control of aircraft, air traffic, aircraft navigation or aircraft communications; or in the design, construction, operation or maintenance of any nuclear facility. Keyoti Inc. and its suppliers specifically disclaim any express or implied warranty of fitness for such purposes or any other purposes.
NO LIABILITY FOR CONSEQUENTIAL DAMAGES. To the maximum extent permitted by applicable laws, in no event shall Keyoti Inc. or its suppliers be liable for any damages whatsoever (including without limitation, damages for loss of business profits, business interruption, loss of information, or other pecuniary loss) arising out of the use of or inability to use this Keyoti Inc. product, even if Keyoti Inc. has been advised of the possibility of such damages. Because some states and jurisdictions do not allow the exclusion or limitation of liability for consequential or incidental damages, the above limitation may not apply to you.
4. Support and Source Code Licensing. Keyoti Inc. does provide formal customer support contracts for RapidSpell Web. We also make every effort to ensure the quality of our products, and questions, bug reports, and feature requests are encouraged, please use email. Due to resource limitations, it may not be possible to resolve all issues and no assurances can be given as to when or if problems will be addressed. Customers incorporating RapidSpell Web into software for deployment or sale are encouraged to purchase the Source Code License Version of RapidSpell Web which will enable self-support, debugging, and modifications or extensions to the base functionality (but not distribution of the source code itself).


RapidSpell Web .NET Documentation: Introduction

Keyoti Title Line

RapidSpell Web .NET v5.0.0

Thank you for purchasing RapidSpell Web, please keep up to date through our website keyoti.com and feel invited to post feedback. We also ask that you register your purchase so that we may offer you support and free upgrades from time to time, at https://keyoti.com/care/register

Overview

RapidSpell Web integrates automatically into web applications with minimal amounts of Javascript - which allows it to work easily with any page rendering technology (such as ASP.NET, MVC, AJAX, Razor, or just plain HTML files). RapidSpell also includes traditional ASP.NET server controls which can be used instead of the Javascript approach, to manually setup the spell check.

The UI provides all the usual features, add, change, change all, ignore, ignore all, options and smart suggestions. It interactively checks ASP.NET text controls, any HTML text box component such as <textarea> and <input type='text'> as well as 3rd party components. The spell checker UI features an advanced preview pane to interactively highlight errors (with no post back). The spell checker accepts manual corrections, and also supports user dictionaries (either one dictionary for all users or separate user dictionaries). The included non GUI component provides core spell checker functionality at the middleware level, which means it is suitable for server applications as well as any console application.

Common Uses

The Web Control component can check any HTML text component (e.g., <textarea>, <input type='text'> and 3rd Party) allowing for Internet/Intranet applications such as:

Email
Messaging
Online utilities (web page generators, order placement)
Data input

The non-GUI component provides core spell checking functionality, allowing it to be useful in any application, including:

Server applications
Console based applications

Requirements

The components were built to CLR 2.0/4.0 (.NET /2.0/3.0/3.5/4.0/4.5/4.6) specification. This product works in Edge, IE5+, Firefox1+, Chrome 1+, Opera6+, Mozilla 1.3+, Safari on the PC and IE5.5+, Firefox1+, Chrome 1+, and Safari 1.3+ on the Mac.


RapidSpell Web .NET Documentation: Release Notes

RapidSpell Web .NET Release Notes

General Upgrade Instructions

If you have copies of the RapidSpell scripts in your application, be sure to update the copies with the current version from our install directory.

5.0.0

Breaking Changes:

There are 4 breaking change sections below, please check them for their applicability to your project (if you need help just email support@keyoti.com). The changes relate to .NET 1 support, user options, popup window javascript function/variable naming and a new CSS block that must be added to your popup.aspx.

.NET 1 support dropped

The .NET 1 built DLLs are no longer distributed.

User options

A new feature is user options in the dialog spell checker, which give the user the ability to enable/disable spell check options such as ignore words with numbers, ignore uppercase, ignore improper case and ignore internet addresses. These options are stored in the user's cookie and will override any same setting made in code (such as with rapidSpell.setParameterValue(...)).

To disable this functionality call (for Javascript based usage):

rapidSpell.setParameterValue('default', 'EnableOptions', 'false');

or (for Server Control based usage), set EnableOptions to false in the RapidSpellWebLauncher controls.

Popup window variable and function names (small possibility you are affected)

To implement the new jQuery based dialog it was necessary to incorporate the popup window scripts on the main page. This necessitated renaming of some Javascript variables and functions, and HTML elements. Therefore if your code is reliant on the elements in our popup.aspx being named a certain way (eg. you have Javascript that references HTML elements from our RapidSpellWeb Control, or you have Javascript that calls our functions) then you will need to update references to the new names (in most cases the names have been prepended with "rsw_". If you are unsure, please send your ASPX page that holds the RapidSpellWeb control to support@keyoti.com and we will advise.

Example, you have a customized popup UI, with this code:

<FinishButton BorderWidth="" Font-Size="9pt" Font-Names="Verdana" Font-Bold="True" BorderColor=""
                        ForeColor="" BackColor="SkyBlue" Height="" Width="100px" CssClass="" type="button" value="Finish"
                        onclick="finish(true);" style="width:100px;font-family:Verdana;font-size:9pt;font-weight:bold;background-color:#87ceeb;"
                        ID="cancelButton"></FinishButton>

The ID of the cancel button has changed and should be updated to:

ID="rsw_cancelButton"

Other changes are:

changeSuggestions() => rsw_changeSuggestions()
ignoreCurrent() => rsw_ignoreCurrent()
ignoreAll() => rsw_ignoreAllInstances
change() => rsw_change()
changeAll() => rsw_changeAll()
addCurrent() => rsw_addCurrent()
undoChange() => rsw_undoChange()

Other function and variable names have changed, but it is expected that they have not been used publically. It is recommended that you retest any popup scripts that have been added, or send to us for our guidance.

Popup window requires new CSS block

To support the user options, a CSS style block must be added to the popup.aspx page (note that your popup page may be named a different name, it will be the ASPX page holding the <RapidSpellWeb> Server Control). Please add the following to the head tags.

<style type="text/css">

        body{overflow:hidden;
             font-family: sans-serif, arial, helvetica;

        }
        div{height:100%;}

        #rsw_documentTextPanel
        {
            border: 1px solid #aaa;
            border-radius: 3px;
        }
        #rsw_word, #suggestions
        {
            border: 1px solid #aaa;
            border-top-color: #a0a0a0;
        }
        #rsw_optionsDialog
        {
            font-size:.80em;
            display: none;
            position: absolute;
            margin-left: auto;
            margin-right: auto;
            margin-top: auto;
            margin-bottom: auto;
            left: 0;
            right: 0;
            top: 0;
            bottom: 0;
            width: 295px;
            height: 230px;
            z-index: 101;
            background-color: white;
            border: 1px solid #444;
            border-radius: 5px;
            padding: 8px;
        }
        #rsw_optionsDialog_Backing
        {
            display: none;
            position: absolute;
            margin-left: auto;
            margin-right: auto;
            margin-top: auto;
            margin-bottom: auto;
            left: 0;
            right: 0;
            top: 0;
            bottom: 0;
            width: 100%;
            height: 100%;
            background-color: rgba(100,100,100,.60);
            z-index: 100;
        }
        #rsw_optionsDialog > label
        {
            display: block;
            padding-bottom: 12px;

        }
        #rsw_optionsDialog > input
        {
            margin-right: 9px;
            margin-top:12px;
        }
        #rsw_optionsHeader
        {
            font-size: 1.2em;
            border-bottom: 1px solid #aaa;
        }
    </style>
Improvements
-Added WCF and ASMX Web Services for backend server calls. For MVC users this means there is now no dependence on ASPX Web Forms. It is also more lightweight.
-Spell check options dialog added.
-Added support for the context menu key on the keyboard, and enabled selection of suggestion menu items with keyboard.
-Edge browser support added.
-jQuery UI based dialog mode added (for Javascript based usage only).
-Modal mode improvement to use jQuery UI dialog (must enable with rapidSpell.dialog_setUseDivDialog(true);) (for Javascript based usage only)
-Smaller bug fixes

4.5.0

Improvements
-IE11 fix issue where clicking off of the top line would not focus cursor.
-Improve performance with certain larger text contents.
-Fix XSS issue with popup URL manipulation.
-Fix tabbing between fields in recent versions of Chrome.
-Support 'placeholder' HTML attribute in text boxes
-Images in rich HTML editors will now be hidden by default in the dialog spell checker text window, to allow them to be shown call rapidSpell.setParameterValue('default', 'HideImages', false);
-Added WCF support http://keyoti.com/support/default.aspx?g=posts&m=12809&#post12809
-Added ability to set textbox ids to check for inline, use rapidSpell.ayt_setupTextBoxes(false, idsToCheck);
-Smaller bug fixes

4.4.0

Improvements
-Spell checker can now look for elements to check by their class rsw_spellable. This allows textboxes to be checked by inclusively specifying them rather than excluding them.
-Address some XSS issues with dialog spell checker.
-Fix IE11 not tabbing to other textboxes.
-Small bug fixes

4.3.2

For rich editors (like TinyMCE, CKEditor etc) you may find that custom CSS styling that you may have used for the overlay is no longer required, as we have improved how the existing styling is copied in to the overlay.
Improvements
-Improve static overlay styling.
-Small bug fixes

4.3.1

Improvements
-Use web fonts within as-you-type text area, when specified in a CSS file
-Fix placement issue with static overlay

4.3.0

Improvements
-Added support for IE 11

4.2.1

Improvements
-Fix cursor problem in Chrome/FF

4.2.0

The static-mode (inline) overlay has changed from being absolutely positioned to temporarily setting the target textbox to display:none and inserting the overlay in the DOM before the target textbox - we recommend checking that this does not have detrimental effects on layout in your apps. Call rsw_absolutePositionStaticOverlay = true; in Javascript on the page to revert to old behavior.
Improvements
-Fix % width/height handling in as you type textboxes.
-Tablet browsers (Android etc) will switch to left click for context menu suggestions, to support touch.
-Fix bug in dialog with too many errors crashing popup
-Small bug fixes.

4.1.0

Improvements
-Make dictionary cache reload newer versions of a dictionary.
-Enable cross subdomain usage for dialog spell checker (see docs).
-Fix Chrome & Safari issue with textbox postback losing data.
-Small bug fixes.

4.0.0

Up until v4 everything was Server Control based (ie. ASP.NET server tags), nothing was Javascript based. During this period of time other technologies have been released, such as ASP.NET AJAX, JQuery, MVC, and MVC Razor - the trend has been for ASP.NET developers to be more Javascript aware. With multiple 'form factors' in use, it makes sense for RapidSpell Web v4 to become Javascript based, which has advantages;
-Usable with technologies that don't support runat='server' (MVC, straight HTML, ASP etc)
-Simpler usage, 99% automatic
-Smaller footprint on your application
-Simpler product development (less mirroring of properties)
We are including the Server Controls for developers who are not comfortable with Javascript and for backwards compatibility. As you develop new pages we urge you to try using the Javascript based methodology as we're sure you'll find it better.

Backwards Compatibility
-Is backwards compatible, no code changes required. To transition away from the control based usage please remove the controls and follow the Help instructions on JS based usage.
-"ShareDictionary" code from prior versions is ignored as it has been superseded by automatic caching.
Improvements
-As you type support added for Chrome and Safari browsers
-Inclusion of simpler, more flexible automatic setup scripts, which will spell check all textboxes unless otherwise indicated (see docs).
-Automatic dictionary caching, supports multiple dictionaries per app.
-Sentence capitalization correction added [IgnoreIncorrectSentenceCapitalization]
-Lowercase i correction (in English) [IgnoreInEnglishLowerCaseI]
-Filter suggestions that would make text longer than 'maxlength'
-Inline ignore all removes underlines in all text boxes and not just current
-Prevent pasting beyond 'maxlength'

3.8.0

Improvements
-Internet Explorer 9 support added
-Firefox 4 support added
-Autoclose popup window when user navigates away from main page.
Maintenance
-Fix cursor issues in RapidSpellWInlineTextBox
Backwards Compatibility

As v3.7.0

3.7.0

Improvements
-.NET 4 DLLs and VS 2010 demos included
Maintenance
-Fix issue with ALT code characters disappearing in RapidSpellWInlineTextBox with as-you-type if they were the last character entered.
-Fix for AJAX usage, properly deactivates any inline overlays on AJAX postbacks
Backwards Compatibility

As v3.6.0

3.6.0

Improvements
-Faster performance with large texts
Maintenance
-Fix occasional loss of characters in inline textbox in as-you-type mode
-Fix issue with image buttons in popup dialog
-Fix issue with certain characters copied from Word to the inline textbox
-Workaround Safari bug with multiple launchers
Backwards Compatibility

As v3.5.1

3.5.1

Maintenance
-Firefox 3 support with multiple RapidSpellWebLauncher controls
-Scrolling issue with as-you-type fix
-Performance issue with split word suggestions for long URLs
Backwards Compatibility

As v3.5.0

3.5.0

New Features
-Ignore All & Change All operations are now global (affect all textboxes during a check) in dialog spell checker. To revert to old behavior (local) please set GlobalIgnoreAll="false" and GlobalChangeAll="false" in the RapidSpellWeb control (popup page).
-Added consistent ClientSideObject interface for downlevel browsers rendering RapidSpellWInlineTextBox
-RapidSpellWInlineTextBox client side events can now also be hooked up using HTML attributes, "onblur", "oncontextmenu", "oncorrection", "onfocus", "onkeydown", "onkeypress", "onkeyup", "onmousedown", "onmouseup", "onpaste"
Fixes
-Various minor issues
Backwards Compatibility

As v3.4.2

3.4.2

New Features
-The as-you-type spell checker can now be set to not automatically check the text on page load, see RapidSpellWInline.CheckAsYouTypeOnPageLoad.
-English dictionaries updated.
Fixes
-Fixed minor issues with RapidSpellWInlineTextBox (as-you-type) controls relating to glitches under certain conditions.
Backwards Compatibility

As v3.4.1

3.4.1

New Features
-Improved as-you-type spell checking behavior under slow network conditions (text change reconciliation)
-Use of multiple RapidSpellWebMultiple controls on a page is now supported.
Fixes
-Fixed issue with IE and rich/html text boxes when spell checking text which is invalid HTML.
-Fixed compatibility issue with 'right click' suggestions and Mac Safari.
-Modified RapidSpellWInlineTextBox style handling so that setting Height/Width="" would allow a stylesheet to set these properties.
-Fixed ASP.NET AJAX issue with as-you-type and hidden textboxes
Backwards Compatibility

As v3.4.0

3.4.0

New Features
-Added new RapidSpellCheckerClient control, which provides AJAX based programmatic Javascript spell checking.
-Added RightClickForMenu property to RapidSpellWInline to switch context menu from left to right click (default = false / left).
-Added TextComponentInterface.Automatic which simplifies usage with rich/html textboxes.
-Added support for "ASP.NET AJAX" RTM 1.0.
-Added built-in support for GridView usage.
-Improved/simplified client side API usage of RapidSpellWebLauncher, RapidSpellWInlineTextBox and RapidSpellWInline (see userguide)
-Added RapidSpellWInline.ValidatorNeedsText event to allow validator usage with rich/html textboxes.
-Added properties for "No suggestions" and "Remove duplicate word" text.
-Allow .NET 2 users to use external stylesheets in addition to internal ones.
Fixes
-Corrected behavior of RapidSpellWInlineTextBox controls.
-Fixed design-time issue with RapidSpellWebMultiple control.
-Fixed rich/html text box issue with html entities in certain positions.
-Fixed RequiredFieldValidator usage with RapidSpellWInlineTextBox.
-Fixed Safari issue with .NET 2 web-sites.
Backwards Compatibility

v3.4.0 is designed to be backwardly compatible with v3.3.0, see 3.3.0 release below if upgrading from earlier versions.

** Due to broad changes to the client script registration procedure to accommodate ASP.NET AJAX it is highly recommended that applications using this control are checked for proper behavior after upgrading.

3.3.0

New Features
-Added ability to specify custom style-sheets for RapidSpellWInlineTextBox and RapidSpellWInline
-Added ShowAddButtonAlways property to RapidSpellWInline to override Add button hiding when UserDictionaryFile is not spec'd
-Enabled property in RapidSpellWInline/RapidSpellWebLauncher now automatically effects the button
-XML/HTML parser speed improved
-RapidSpellWeb and RapidSpellWebLauncher common code moved to JS files (.NET 1) and embedded scripts (.NET 2)
-Multiple text box 'as you type' style demo added
Fixes
-Strict mode browser rendering issue fixed
-RapidSpellWebMultiple & HTML display mode issue fixed
-Browser window resize during spell check issue fixed
Backwards Compatibility
IMPORTANT! .NET 1.x CLIENT FILES CHANGE:
Up until this release, client side script for RapidSpellWebLauncher and RapidSpellWeb controls was embedded into the HTML page. To improve performance the majority of this code has moved to Javascript files (.js) under the /Keyoti_RapidSpell_Web_Common directory. This virtual directory is setup by default when installing the control with the installer, however if you manually deploy the controls to a server by copying the DLLs etc. then you MUST do the following to avoid Javascript errors.

1. A virtual directory (eg. a directory under wwwroot) must exist called /Keyoti_RapidSpell_Web_Common. You can do this by simply creating a directory under your web-site root, so that URLs like http://yourURL/Keyoti_RapidSpell_Web_Common will map to this directory.

2. The contents of /Keyoti_RapidSpell_Web_Common from our install must be copied to the server, this includes a few .js files and HTML files.

The above is covered in the deployment section of the user guide PDF as well.

SharePoint (under .NET 1.x) users:
Due to the movement of client script to external files, you could experience issues with their new locations. If you have successfully been using RapidSpellWebLauncher (and therefore RapidSpellWeb) controls with SharePoint running under .NET 1.x you will need to do the following when deploying version 3.3.
i) Place the contents of the Keyoti_RapidSpell_Web_Common directory (located under our install folder) outside of SharePoint's control, so that it won't map their URLs.
ii) In RapidSpellWebLauncher and RapidSpellWeb set the new ClientFilesFolder property to the URL of the directory holding the Keyoti_RapidSpell_Web_Common files. Eg. if the client files are now located under http://machine/someDir/ then set this property to /someDir/
iii) Test - if it's setup wrong, you will see Javascript errors as soon as you run the page with RapidSpellWebLauncher in it.
v3.3.0 is designed to be backwardly compatible with v3.0.0, see 3.0.0 release below for more info.

3.2.0

New Features
-Retro-fit XmlHttpRequest server access for capable browsers
-Added 'Change All' functionality in RapidSpellWInline, see ShowChangeAllItem property
-Added support for HTML/Rich text boxes (including Dart's PowerWEB TextBox)
Fixes
-Worked around drop down menu shine-through browser bug with RapidSpellWInline
-Improved inline menu positioning around browser edges
Backwards Compatibility
v3.2.0 is designed to be backwardly compatible with v3.0.0, see 3.0.0 release below for more info.

3.1.0 - 3.1.1

New Features
-Support for Visual Studio 2005 / ASP.NET 2.0 added
Fixes
-Corrected RapidSpellWInline overlay positioning issue
-Corrected multiple text box & dialog checking error (3.1.1)
Backwards Compatibility
v3.1.0 is designed to be backwardly compatible with v3.0.0, see 3.0.0 release below for more info.

3.0.0

Major New Features
-RapidSpellWInline control added, which provides a new 'inline' highlighting interface.
-RapidSpellWInlineTextBox control added providing in-document highlighting in modern browsers.
-Validator behavior added, allowing text boxes to be validated for spelling before saving.
-Undo functionality added to traditional spell checker.
-Smooth multiple text box checking added to RapidSpellWebMultiple.
-Simpler license key usage.
-'Field being checked' text added (useful for multiple text boxes).
-Simpler multiple text box checking with grids and lists.
-Simple access to dictionary caching added.
-Added ability to ignore URLs and emails, as well as custom regex patterns.
Fixes In 3.0.0
-Setting IgnoreAll button to invisible now works.
Backwards Compatibility
We have made every effort to make v3.0.0 as compatible as possible with v2.
V3.0.0 is approximately 99% backwards compatible with v2.8.3 without any code changes required.
However, we urge all v2 users to consult the file 'V2-3 Upgrade Notes.html' for important information.
Fixes In 2.8.3
-Fixed bug related to IgnoreWordsWithDigits = false and suggestions (default value for IgnoreWordsWithDigits is true).

2.8.2

New Features
-Improved suggestions for short (<=3 char) words.
Fixes
-Updated Spanish translations.
-Fixed accented characters issue with Firefox
-*

*Use of RapidSpellWebMultiple with Safari browser (Mac). If you are using RapidSpellWebMultiple to check multiple text boxes (with one button) and you expect any of your users to use the Safari browser please read the following:

Due to a bug in Safari, we had to design a work-around to enable support for RapidSpellWebMultiple, to use this work-around, please place the file 'RapidSpellSafariHelper.html' in the same directory(s) where you have used RapidSpellWebLauncher. This work-around will only come into effect if you have specified the RSMultipleID property in RapidSpellWebLauncher (this is done automatically if you use the designer). This work-around does not affect performance or functionality.

Backwards Compatibility
v2.8.2 is designed to be backwardly compatible with v2.8.1.

2.8.1

New Features
-Firefox v1 browser support.
Fixes
-Fixed case-sensitivity bug that allowed dontSuggest words to be suggested.
Backwards Compatibility
v2.8.0 is designed to be backwardly compatible with v2.7.0.

2.8.0

New Features
-Portuguese LanguageType added, includes Portuguese GUI text.
-SSLFriendlyPage property added so that path to 'blank' html page is settable.
-AllowMixedCase property sets whether words in mixed case that do not appear exactly as such in dictionary will be reported as an error.
Fixes
-Under certain circumstances removing duplicate words causes incorrect word index offset for following words.
Backwards Compatibility
v2.8.0 is designed to be backwardly compatible with v2.7.0.

2.7.0

New Features
-Ignoring words with numbers is optional through new IgnoreWordsWithDigits property

-Addition of client side event listeners "StartedOnTextBoxListener" and "FinishedOnTextBoxListener" to RapidSpellWebMultiple make features such text box highlighting possible (see updated DynamicList.aspx demo)

-New server-side event "Finish" added to RapidSpellWebLauncher and RapidSpellWebMultiple controls, use with PostBackOnFinish=true to run server-side code when spell check is complete

-New demos added for the Repeater control and hiding/showing text boxes
Fixes
-Duplicate numbers are not reported as a duplicate error
-Problem fixed where overflow exceptions could occur when checking text with hundreds of XML tags unseparated by words
Backwards Compatibility
v2.7.0 is designed to be backwardly compatible with v2.6.1. Changes to default settings; RapidSpellWebLauncher.FinishListenerInformState now defaults to true - this should not have adverse effects on any existing Javascript functions. Eg; if FinishListener was "OnFinish" and the function was declared as "function OnFinish(){" the control will now (by default) call that function as "OnFinish(boolComplete)".

2.6.1

Backwards Compatibility
v2.6.1 is designed to be backwardly compatible with version 2.5 of RapidSpell Web. We have made changes to fundamental functionality (such as the way TextComponentName can be set). We recommend you retest your apps. with the new DLL, to ensure there are no problems, before deployment.
New Features In 2.6.0 & 2.6.1
-Filters added to remove scripting into preview pane

-Empty text boxes are ignored for efficiency

-Multiple text box in DataList example source added to demos

-Improved ease of use, setting text control to spell check is simpler, especially for situations involving data grids, lists, and user controls.

-New RapidSpellWebMultiple control makes checking multiple text boxes simple.

-Duplicate word detection; such as "this is is duplicated".

-Support for Opera and Safari browsers.

-Design Time improvements; more properties for setting style and text.

-'Preview Pane' now set-able to X%, allowing it to resize with pop-up window size (useful for users who wish to pull the popup bigger).

-Improved dictionaries; the UK, US & Combined English dictionaries have been increased to 110K words, Canadian and Australian dictionaries are now available, free of charge.
Fixes
-Minor bug in duplicate word detection caused duplicate words around misspellings to be reported incorrectly
-US dictionary missing in MSI installer package version

Older Versions

RapidSpell v2.5.0 features the following improvements over v2.4.0:
The popup window position is now set-able in RapidSpellWebLauncher.WindowX & RapidSpellWebLauncher.WindowY properties (set these to -1 if you want them not set).
Troubleshooting section added to user guide, covers common user dictionary problems and build errors in VisualStudio.
RapidSpell v2.4.0 features the following improvements over v2.3.0:
Modal dialog support for popup mode.
For multiple text box checking there is now the 'FinishClosesWindow' property to set whether the 'Finish' button should close the spell check or move onto the next text box.
RapidSpell v2.3.0 features the following improvements over v2.2.0:
Improved suggestions (anagram searching and split word suggestions)
Compound word support (for German)
Spell check finished and 'no spelling errors' messages made optional
Text correction Javascript event added (CorrectionNotifyListener property)
SSL mixed content warning fix
Certain international characters user dictionary fix
Documentation added for User Controls
DataGrid example added
Smoother multiple text box checking example added
RapidSpell v2.2.0 featured the following improvements over v2.1.0:
Built-in UI text for (French, German, Italian and Spanish)
Suggestions algorithm improvements
Image button support (in launcher control)
New Dict file support for runtime changeable dictionaries and customization
Decoupled spell checker engine, for parser customization
Hyphenation behavior improvements
RapidSpell v2.1.0 featured many improvements in the core spell checker over v1, including:
Improvement in word lookup check speed
Improvement in phonetic suggestions speed
New alternative 'hashing' suggestions method added, runs up to 40x faster than phonetic suggestions
New methods for behavior customization
More accurate dictionaries
3rd Party component support
HTML/XML compatibility
Multiple text box support
Improved design time support


RapidSpell Web .NET Documentation: The Dictionaries

RapidSpell can use two types of dictionary formats, 'Dict' files and 'MDict' assemblies. The RapidSpellMDict.dll assembly dictionaries are a convenient and simple format, whereas the 'Dict' files provide more advanced features, such as customization and runtime switching. Consult the 'DLL Main Dictionaries' and 'Dict File Main Dictionaries' sections below for more details.

Included are 3 dictionary assemblies, UK and US English dictionaries, each containing ~110K words, a combined UK and US dictionary containing ~115K words. Other English dictionaries are available on request, these include; 70K word US and UK, 150K word combined US+UK, 110K word Australian and Canadian. Please email support@keyoti.com

Keyoti offer a number of non-English dictionaries. Further details and evaluation versions are available at;

http://keyoti.com/products/rapidspell/dotNetWeb/dictionaries.html

User (Custom) Dictionaries / Add Button

To offer an "Add" function to the user, specify the UserDictionaryFile property in either spell checking control. If the file path specified is valid, the Add option will be enabled. If the file does not exist (but the path is valid) then the file will be created. The user dictionary is a simple UTF-8 text file with words listed one per line. The user dictionary is suited best to relatively short lists added to by the user. If a large list of custom words needs to be added, it is suggested that they are added to the main dictionary using Dict Manager.

DLL Main Dictionaries

When using Keyoti.RapidSpellMDict.DLL as the main dictionary, care must be taken as to which language will actually be loaded by the .NET runtime. If this DLL is loaded into the GAC then that version will be used and override any specific dictionary DLLs referenced in the project. Therefore it is essential that care be taken so that the desired Keyoti.RapidSpellMDict.DLL be used in the project.

Avoiding Redundant Space Usage

The Keyoti.RapidSpellMDict.DLL file must be referenced by your project, even if you are using a .Dict File based dictionary. Therefore, in order to save space you may prefer to download an 'empty' DLL dictionary, which will satisfy the reference requirement, and take up zero kilobytes;

http://keyoti.com/downloads/Empty-DT-Keyoti.RapidSpellMDictv3.zip

Dict File Main Dictionaries

RapidSpell has it's own proprietary dictionary format, these dictionaries are called Dict files. They have been developed to allow more flexibility than the existing dictionary format. The existing MDict.DLL format will continue to be supported, the advantages and disadvantages of the formats are outlined below:

Dict File;

Advantages
- Smaller file size
- Swappable during run-time (necessary for other languages)
- Customizable by developer

Disadvantages
- Not cacheable in GAC

MDict.DLL format;

Advantages
- Cacheable in GAC

Disadvantages
- Not runtime swappable
- Not customizable

If it is desirable to cache the dictionary in the GAC then the MDict.DLL format should be used, however for all other uses the new Dict File format is preferable.

Using Dict Files

The older MDict.DLL type file must reside in the same directory as the main RapidSpell DLL, it will be used if the DictFile property of RapidSpellWebLauncher/RapidSpellWInline is null (C#) or Nothing (VB.NET). To use a Dict file simply set the DictFile property to the file path of the Dict file to be used on the server.

Dictionary Customization

It is possible to customize the dictionaries and create new ones using the convenient Dict Manager tool included in RapidSpell Web, please load the tool and consult the help system provided in it for more details.

The Dict Manager tool included in RapidSpell Web

Programmatic Use Of Dict Manager
To use Dict Manager programmatically:
  • Reference DictManager.exe in your project (when you browse for the assembly, just change the file type to *.exe in the open dialog).
  • Create an instance: model = new DictManager.DictManagerModel();
  • Use any of the API calls:
    • CreateDict
    • LoadDict
    • AddWord
    • MergeDictFile
    • MergeTextFile
    • RemoveWord
    • LookUp
    • SaveDict
    • Creates a new dict file
    • Loads an existing dict file
    • Adds a word to current open dict file
    • Merges an existing dict file with the open dict file
    • Merges an existing text file with the open dict file
    • Removes a word from the dict file
    • Checks if a word is in the dict file
    • Saves the currently open dict file
  • Typical usages should be in the following order;
    • create or load
    • modifying operations
    • save.


RapidSpell Web .NET Documentation: Installation

Installation

There are two ways to use RapidSpell Web; as Javascript or as Server Controls. This help document provides information on both approaches, generally speaking the Javascript approach is simpler and less intrusive on the user web application, as it automatically configures around the text boxes on the page (unless told to ignore them).

Javascript Based Integration

  1. To use RapidSpell Web via Javascript, reference the appropriate DLLs for your .NET version:

    • .NET 4/4.5: Keyoti.RapidSpellWeb.ASP.NETv4.dll and Keyoti.RapidSpellMDict.dll
    • .NET 2: Keyoti.RapidSpellWeb.ASP.NETv2.dll and Keyoti.RapidSpellMDict.dll

  2. .NET 2 (3/3.5) users, please check for and delete RapidSpellService.svc from the copied Keyoti_RapidSpell_Web_Common if it is present.

  3. Create a Keyoti scripts folder within the web application, copy the files from the 'Keyoti_RapidSpell_Web_Common' folder and paste them to your new folder.

    (the 'Keyoti_RapidSpell_Web_Common' folder can be found under the product installation, typically; C:\Program Files (x86)\Keyoti Inc\RapidSpell Web .NET v4\Keyoti_RapidSpell_Web_Common)

  4. Drag the RapidSpell-AYT.js and RapidSpell-DIALOG.js file on to the page in Visual Studio and a 'script src' tag will automatically be added to the page.

Web Control Based Integration

To use RapidSpell Web Server Controls, you must reference the Keyoti.RapidSpellWeb.ASP.NETv4.dll (for .NET 4) or Keyoti.RapidSpellWeb.ASP.NETv2.dll (for .NET 2+) or Keyoti.RapidSpellWeb.dll (for .NET 1+) and Keyoti.RapidSpellMDict.dll, DLLs.

Note:
.NET 4 users should only add controls from, and reference Keyoti.RapidSpellWeb.ASP.NETv4.dll
.NET 2 & 3 users should only add controls from, and reference Keyoti.RapidSpellWeb.ASP.NETv2.dll

For Visual Studio 2002/2003

Simply add the RapidSpell Web assembly to your Toolbox (if not already present)
1. Select the "Components" tab in the Toolbox slider
2. Right click in the Toolbox area and click "Customize Toolbox..."/"Add Remove Items"
3. Find the RapidSpell.... controls in the list and check them
4. Click Ok. the RapidSpellWeb, RapidSpellWInline, RapidSpellWInlineHelper, RapidSpellWInlineTextBox , RapidSpellWebMultiple and RapidSpellWebLauncher controls have been added to your Toolbox and can be dragged onto forms.

For Visual Studio 2005/2008

Simply add the RapidSpell Web assembly to your Toolbox (if not already present)
1. Select the "Components" tab in the Toolbox slider
2. Right click in the Toolbox area and click "Choose Items"
3. Find the RapidSpell.... controls in the list and check them (ensure you select the controls in the Keyoti.RapidSpellWeb.ASP.NETv2 assembly!)
4. Click Ok. the RapidSpellWeb, RapidSpellWInline, RapidSpellWInlineHelper, RapidSpellWInlineTextBox , RapidSpellWebMultiple and RapidSpellWebLauncher controls have been added to your Toolbox and can be dragged onto forms.

For Visual Studio 2010/2012

Simply add the RapidSpell Web assembly to your Toolbox (if not already present)
1. Select the "Components" tab in the Toolbox slider
2. Right click in the Toolbox area and click "Choose Items"
3. Find the RapidSpell.... controls in the list and check them (ensure you select the controls in the Keyoti.RapidSpellWeb.ASP.NETv4 assembly!)
4. Click Ok. the RapidSpellWeb, RapidSpellWInline, RapidSpellWInlineHelper, RapidSpellWInlineTextBox , RapidSpellWebMultiple and RapidSpellWebLauncher controls have been added to your Toolbox and can be dragged onto forms.

For IIS (ASP.NET 1.x)

1. Copy Keyoti.RapidSpellWeb.dll and Keyoti.RapidSpellMDict.dll files in to the bin directory off your application root.
2. Add

<%@ Register TagPrefix="RapidSpellWeb" Namespace="Keyoti.RapidSpell" Assembly="Keyoti.RapidSpellWeb" %>

to the top of the aspx page where you will use the RapidSpell Web Control. It is vital that in development and deployment that you keep Keyoti.RapidSpellWeb.dll and Keyoti.RapidSpellMDict.dll in the same directory as each other.

For IIS (ASP.NET 2.0, 3.0, 3.5)

1. Copy Keyoti.RapidSpellWeb.ASP.NETv2.dll and Keyoti.RapidSpellMDict.dll files in to the bin directory off your application root.
2. Add

<%@ Register TagPrefix="RapidSpellWeb" Namespace="Keyoti.RapidSpell" Assembly="Keyoti.RapidSpellWeb.ASP.NETv2" %>

to the top of the aspx page where you will use the RapidSpell Web Control.

It is vital that in development and deployment that you keep Keyoti.RapidSpellWeb.ASP.NETv2.dll and Keyoti.RapidSpellMDict.dll in the same directory as each other.

For IIS (ASP.NET 4.0)

1. Copy Keyoti.RapidSpellWeb.ASP.NETv4.dll and Keyoti.RapidSpellMDict.dll files in to the bin directory off your application root.
2. Add

<%@ Register TagPrefix="RapidSpellWeb" Namespace="Keyoti.RapidSpell" Assembly="Keyoti.RapidSpellWeb.ASP.NETv4" %>

to the top of the aspx page where you will use the RapidSpell Web Control.

It is vital that in development and deployment that you keep Keyoti.RapidSpellWeb.ASP.NETv4.dll and Keyoti.RapidSpellMDict.dll in the same directory as each other.

SharePoint Tips

  • RapidSpell's client files are in a directory, by default this is /Keyoti_RapidSpell_Web_Common/ - however SharePoint's URL mapping may cause issues - therefore the files under Keyoti_RapidSpell_Web_Common need to be outside of SharePoint's control.
  • If URL mapping is causing problems you will see Javascript errors on the page holding any spell checker controls.
  • Find RSWIHELPER.ASPX (under the Keyoti_RapidSpell_Web_Common folder) and add the line
    <%@ Register TagPrefix="rapidspellweb" Namespace="Keyoti.RapidSpell" Assembly="Keyoti.RapidSpellWeb.ASP.NETv2, Version=4.1.13.415, Culture=neutral, PublicKeyToken=58d9fd2e9ec4dc0e" %>
    Please change the bold parts to match the assembly name used in your project and version number (available through explorer->properties->details)
  • Adding <script src="/Keyoti_RapidSpell_Web_Common/RapidSpell-AYT.js" ></script> to a master page will not work. It has to be added individually to every child page in Sharepoint to have any effect.


Quick Start - Dialog Usage

Quick Start - Dialog

Please follow these simple steps to quickly setup dialog spell checking in a web application. If you have any questions at all please contact us at support@keyoti.com

For MVC usage please see this page

Step 1
Step 2
Step 3
Step 4
Step 5
Step 6
Step 7

Step 1. Get your project ready (load or create it).

Step 2

Step 2. Reference the appropriate DLLs for your .NET version:

  • .NET 4/4.5:
    Keyoti.RapidSpellWeb.ASP.NETv4.dll and Keyoti.RapidSpellMDict.dll
  • .NET 2:
    Keyoti.RapidSpellWeb.ASP.NETv2.dll and Keyoti.RapidSpellMDict.dll

Step 3

Step 3. Drag a TextBox control onto your Form & set the TextMode property to Multiline.

Step 4

Step 4. Add the client files to a folder under the user web application:

Create a folder within the web application, copy the files from the 'Keyoti_RapidSpell_Web_Common' folder and then, from within the Solution Explorer, paste them to your new folder.

.NET 2 (3/3.5) users, please check for and delete RapidSpellService.svc from the copied Keyoti_RapidSpell_Web_Common if it is present.

(the 'Keyoti_RapidSpell_Web_Common' folder can be found under the product installation, typically;
C:\Program Files (x86)\Keyoti Inc\RapidSpell Web .NET v4\Keyoti_RapidSpell_Web_Common)

Step 5

Step 5. Add the 'script src' tag to the page:

To automatically add the script tag, drag RapidSpell-DIALOG.js from the Solution Explorer on to the page source. This will add the <script type="text/javascript" src="RapidSpell-DIALOG.js"></script> tag to the page with the correct path.

Step 6

Step 6. Trigger the spell check using Javascript.

E.g. In a button click handler;

<input type="button" onclick="rapidSpell.dialog_spellCheck()" value="Spell Check" />

or for a specific text box

<input type="button" onclick="rapidSpell.dialog_spellCheck(true, 'textBoxID')" value="Spell Check" />

Step 7

Step 7. Select the page with the text box as your start page, and run!

Note: To disable spell check on specific text boxes add the attribute nospell="true" to the text box.

Note: To remove the 'Add' option set the dictionary path to an empty string; rapidSpell.setParameterValue('default', 'UserDictionaryFile', '');


Quick Start - As You Type Usage

Quick Start - As You Type

Please follow these simple steps to quickly setup as you type spell checking in a web application. If you have any questions at all please contact us at support@keyoti.com

For MVC usage please see this page

Step 1
Step 2
Step 3
Step 4
Step 5
Step 6

Step 1. Get your project ready (load or create it).

Step 2

Step 2. Reference the appropriate DLLs for your .NET version:

  • .NET 4/4.5:
    Keyoti.RapidSpellWeb.ASP.NETv4.dll and Keyoti.RapidSpellMDict.dll
  • .NET 2:
    Keyoti.RapidSpellWeb.ASP.NETv2.dll and Keyoti.RapidSpellMDict.dll

Step 3

Step 3. Drag a TextBox control onto your Form & set the TextMode property to Multiline.

Step 4

Step 4. Add the client files to a folder under the user web application:

Create a folder within the web application, copy the files from the 'Keyoti_RapidSpell_Web_Common' folder and then, from within the Solution Explorer, paste them to your new folder.

.NET 2 (3/3.5) users, please check for and delete RapidSpellService.svc from the copied Keyoti_RapidSpell_Web_Common if it is present.

(the 'Keyoti_RapidSpell_Web_Common' folder can be found under the product installation, typically;
C:\Program Files (x86)\Keyoti Inc\RapidSpell Web .NET v4\Keyoti_RapidSpell_Web_Common)

Step 5

Step 5. Add the 'script src' tag to the page:

To automatically add the script tag, drag RapidSpell-AYT.js from the Solution Explorer on to the page source. This will add the <script type="text/javascript" src="RapidSpell-AYT.js"></script> tag to the page with the correct path.

Step 6

Step 6. Select the page with the text box as your start page, and run!

Note: To disable spell check on specific text boxes add the attribute nospell="true" to the text box.

Note: To remove the 'Add' option set the dictionary path to an empty string; rapidSpell.setParameterValue('default', 'UserDictionaryFile', '');


RapidSpell Web .NET Documentation: Deployment

Deployment

RapidSpell Web .NET, whether used with JS mode usage, or as Server Controls, is integrated with your web application. The RapidSpell DLLs are referenced by your project and should be included in the application's BIN folder.

As such there are no special deployment instructions, the DLLs and Keyoti_RapidSpell_Web_Common folder's client files, should deploy as part of the referencing web application.

If the project uses the WCF or ASMX services available in RapidSpell, then these also should require no additional configuration.

Note

If the RapidSpell DLLs have been installed in the GAC (on the target server), then your aspx pages must register the assembly using a full reference. This means the register tag in your aspx pages should contain the correct version, culture and public key.
Eg;

<%@ Register TagPrefix="RapidSpellWeb" Namespace="Keyoti.RapidSpell" Assembly="Keyoti.RapidSpellWeb, Version=3.0.0.0, Culture=neutral,
PublicKeyToken=58d9fd2e9ec4dc0e" %>

otherwise the ASP.NET runtime will not be able to find the assembly in the GAC, and they will need to be in the project's bin dir.


RapidSpell Web .NET Documentation: License Keys

License Keys

Upon purchase an 'activation key' would have been sent by email, please see the instructions in the file 'license-keys.txt' which outlines the use of activation keys, and the generation of 'deployment keys'.

Once you have generated deployment keys at http://www.keyoti.com/KeyMaker/main.aspx you should set the LicenseKey property of RapidSpellWeb or RapidSpellWInlineHelper Control, or in your web.config (see below). If the deployment keys are not correct then attempts to use the control on a remote server will result in alert messages.

Eg. LicenseKey property

<RapidSpellWeb:RapidSpellWeb id="rapidSpellWeb" runat="server" LicenseKey="1234567890123456789012345678901234567890"/>

Eg. web.config;

<appSettings><add key="Keyoti-RapidSpellWeb-LicenseKey" value="..."/></appSettings>

If you have more than one domain/servername (and therefore deployment key) for the app. you can easily specify up to 4 additional keys by adding a key called;

  • "Keyoti-RapidSpellWeb-LicenseKey2".
  • "Keyoti-RapidSpellWeb-LicenseKey3".
  • "Keyoti-RapidSpellWeb-LicenseKey4".
  • "Keyoti-RapidSpellWeb-LicenseKey5".

If you are using a multi-server development environment (eg. dev-server -> test-server -> productionserver) please see the 'Advanced' section for license key handling strategy.


RapidSpell Web .NET Documentation: Dialog Spell Checking

Dialog Spell Checking

The RapidSpell Web dialog based checker consists of code to launch a popup page with the RapidSpellWeb control in it.

The user is shown the spell checker page, which will iterate through all the misspelt words in the text, highlighting them in the 'preview pane' and allowing the user to ignore, change, add etc. When the text has been checked the user will be prompted that the spell check has finished, and upon clicking OK.


RapidSpell Web .NET Documentation: Inline Spell Checking

Inline Spell Checking

This style of spell checking is close to Windows 'as-you-type' spell checking. When the inline spell checker is setup (either through Javascript or through Server Controls), the text box will be spell checked either as the user types, or on the click of a button. Underlines will appear and the user has the option to right click on the errors and select a suggestion, Add (to their user dictionary) or Ignore All.

The spell check requests are made through AJAX calls and the server processes them via the RapidSpellWInlineHelper control which sits on an ASP.NET page (by default held in the same folder as the client files).


RapidSpell Web .NET Documentation: RapidSpellCheckerClient

RapidSpellCheckerClient

This control is a lightweight AJAX based client for the RapidSpellChecker class. Adding it to a form enables Javascript based spell checking of string objects - including the ability to;

- Asynchronous or synchronous operation

- Check text and obtain bad words and their locations and suggestions

- Add words to the user dictionary

- Modify checker settings on the client-side.

Please see the examples for more information.


RapidSpell Web .NET Documentation: RapidSpellChecker

RapidSpellChecker

Provides a model (business/logic) level spell checker API which can be used in a client-server environment and any applications where a client GUI does not exist. RapidSpellChecker has been benchmarked at checking 70,000 words/second on a standard 1GHz PC. User dictionaries can optionally be used, allowing words to be added. This component can be used in 2 different ways, in an iterative fashion or on a query by query basis. Please see the API docs for code level details.

Using RapidSpellChecker in an iterative manner provides complete textual correction of strings similar to a GUI based spell checker. A string is loaded into RapidSpellChecker and then successive calls to the NextBadWord() method move through the string allowing FindSuggestions() and ChangeBadWord(replacement) to be called to find spelling suggestions and optionally correct the misspelt words in the text, finally GetAmendedText() returns the corrected text.

Alternatively RapidSpellChecker may be used in a simple query by query basis, calls to LookUp(word) and FindSuggestions(word) methods allow bare bones spell checking functionality.

Key API Points

Key Methods
RapidSpellChecker() | - argumentless constructor
Check(text [, startPosition]) | - begins checking text
FindSuggestions(word) | - finds suggestions for word
LookUp(word) | - checks if word is in either main or user dictionaries
SetUserDictionary(file) | - allows you to define which file will be used as a user dictionary
IgnoreAll(word) | - ignores all future occurrences of word
AddWord(word) | - adds word to the user dictionary if it exists
NextBadWord() | - finds the next misspelt word in the text
ChangeBadWord(newWord) | - changes the misspelt word last identified by NextBadWord()
GetAmendedText() | - returns the corrected text

Query by Query Usage Sequence Diagram

Iterative Usage Sequence Diagram

See Examples section for more details.


About The Types Of Usage

About The Two Modes Of Usage (Javascript & Server Control)

Summary: use the Client Side Usage (Javascript) for any technology (Web Forms, ASP.NET AJAX, MVC, HTML, ASP). Use the Server Controls usage for Web Forms only if Client SIde Usage is not preferred.

In RapidSpell Web up to and including version 3, everything was Server Control based (ie. ASP.NET server tags), nothing was Javascript based. During this period of time other technologies have been released, such as ASP.NET AJAX, JQuery, MVC, and MVC Razor - the trend has been for ASP.NET developers to be more Javascript aware. With multiple 'form factors' in use, it makes sense for RapidSpell Web v4 to become Javascript based, which has advantages;

  • Usable with technologies that don't support runat='server' (MVC, straight HTML, ASP etc)
  • Simpler usage, 99% automatic
  • Smaller footprint on your application
  • Simpler product development (less mirroring of properties)
The disadvantages are that it breaks compatibility, and that it may not be appealing to non Javascript developers. For that reason we are including the Server Controls, and the examples section includes both modes of use.

The Javascript method and Server Controls are incompatible and must not both be used on the same page.


RapidSpell Web .NET Documentation: MVC Usage

MVC Usage

The examples in this Help documentation will by default use .ASPX Web Form pages to do the spell checking work. If this is not desired, it is possible to use WCF or ASMX Web Services to do the spell checking work on the server. jQuery is required for inline spell checking, and additionally jQuery UI is required for dialog mode checking.

Dialog Mode

To use WCF web services for dialog based spell checking (note that this is only supported with jQuery DIV based dialog windows):

  1. In Javascript, call rapidSpell.dialog_setUseDivDialog(true);
  2. Ensure the project references Keyoti.RapidSpellWeb.ASP.NETv4.DLL
  3. In the MVC project's RouteConfig class, add 2 ignore routes:
    routes.IgnoreRoute("{d}/{resource}.svc/{*pathInfo}");
    routes.IgnoreRoute("{d}/{resource}.svc");

Inline/as-you-type Mode

To use WCF web services for inline based spell checking:

  1. Include jQuery on the page.
  2. In Javascript, call rapidSpell.useAJAXWebService = true;
  3. Ensure the project references Keyoti.RapidSpellWeb.ASP.NETv4.DLL
  4. In the MVC project's RouteConfig class, add 2 ignore routes:
    routes.IgnoreRoute("{d}/{resource}.svc/{*pathInfo}");
    routes.IgnoreRoute("{d}/{resource}.svc");

ASMX .NET 2/3+

It is possible to use ASMX Web Services instead of WCF if required. To do that,reference Keyoti.RapidSpellWeb.ASP.NETv2.DLL and call (in Javascript):
rapidSpell.setServiceType('asmx');
Ensure the ignore routes (see above) are for .asmx instead of .svc.

Troubleshooting

If you get '500' server errors, please check:

  • If the project uses Keyoti.RapidSpellWeb.ASP.NETv2.DLL, then the page scripts must call rapidSpell.setServiceType('asmx'), in order to use the .NET 2 compatible Web Service.
  • That the memory usage on the machine is not up near 100%. It has been found that the web services shut down when overall system memory consumption is high (this is a 'feature' of IIS/IISExpress).
  • Use the F12 tool's Network tab, to record traffic to the Web Services. Inspect the response from the server for more detail about what is going wrong.

We don't want you to struggle, so please email support@keyoti.com if problems persist.


RapidSpell Web .NET Documentation: As You Type Spell Checking

As You Type Spell Checking

To enable as you type spell checking on a page with text-fields or text-areas (in HTML these are INPUT and TEXTAREA tags, in ASP.NET they are ASP:TEXTBOX tags)

  1. Add the RapidSpell client files to the project (per 'Installation').
  2. Drag RapidSpell-AYT.js from Solution Explorer into the page, this will add a <script src="RapidSpell-AYT.js"></script> tag to the page with the correct path.
  3. All textboxes (with their id attribute set) will now be as-you-type enabled.
<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
    <script src="/Keyoti_RapidSpell_Web_Common/RapidSpell-AYT.js"></script>
    <title></title>
</head>
<body>
    <form>
        <textarea id="text1" cols="20" rows="10">Helloo this is as testt</textarea>
        <textarea id="text2" cols="20" rows="10">and some more</textarea>
    </form>
</body>
</html>
Tip: If the window.onload is being set on the user page, this can block the as-you-type spell checker from initializing properly. It is suggested that either of the following is used;

1. Store the current onload handler and call it explicitly. Eg. if the current code is window.onload=myHandler; then change it to

<script type="text/javascript">
    var existingOnloadHandler = window.onload;
    window.onload=myHandler;
    function myHandler(){
        if(typeof(existingOnloadHandler)=='function') existingOnloadHandler();
        //...current code
    }
</script>

2. Or, assign the onload handler using window.addEventListener (IE9 and others) or window.attachEvent (IE8 down).

Enabling/Disabling spell check on specific text boxes

To disable for specific text boxes
  • Add the attribute nospell="true" to the text box.
  • Or, add the (client) ID of text box to the Javascript array rapidSpell.ayt_ignoreTextBoxIds,
    eg. either 1 of
    rapidSpell.ayt_ignoreTextBoxIds[rapidSpell.ayt_ignoreTextBoxIds.length] = 'textBox1'; //where textBox1 is the id attribute of a textbox
rapidSpell.ayt_ignoreTextBoxIds[rapidSpell.ayt_ignoreTextBoxIds.length] = '<%= textBox1.ClientID %>'; //where textBox1 is an asp:textbox tag.
To enable for specific text boxes
  • Set rapidSpell.ayt_findByClass=true;
  • Add the CSS class 'rsw_spellable' to textboxes that should be spell checked.
    Eg. <input type='text' class='rsw_spellable' .../>
    Eg. when there are other classes specified already <input type='text' class='myTextBox rsw_spellable' .../>

    • If no elements are marked with the class rsw_spellable, then nothing will be spell checked. If elements are marked with rsw_spellable but also set to be ignored in the above array, they will not be spell checked.

Modifying or removing the 'Add' option

Please see the user dictionary topic.

MVC usage (using WCF or ASMX web services without .aspx)

Please see the MVC Usage page.

Using a button to trigger spell check, instead of as the user types

In the HEAD of the page, add a Javascript block which calls rapidSpell.ayt_aytEnabled = false;

<script type="text/javascript">
    rapidSpell.ayt_aytEnabled = false;
</script>

Trigger the spell check using Javascript, eg. in a button click handler;

<input type="button" onclick="rapidSpell.ayt_spellCheck(document.getElementById('textBox1'))" value="Spell Check" />

Static mode

In this mode, the spell check is triggered by a button, and the underlines are overlayed in an uneditable box - when the user finishes spell checking the underlines disappear.

<script type="text/javascript">
    rapidSpell.ayt_aytEnabled = false;
    rapidSpell.ayt_staticMode = true;
</script>

Trigger the spell check using Javascript, eg. in a button click handler (in this call we pass 'this' so that the button's text can be changed to match spell check state);

<input type="button" onclick="rapidSpell.ayt_spellCheck(document.getElementById('textBox1'), this)" value="Spell Check" />

Changing UI text

To change the text used in alerts and the context menu, either set the GuiLanguage parameter or to change a specific text, call rapidSpell.ayt_setUIText(language, identifier, newText), eg;

<script type="text/javascript">
    rapidSpell.ayt_setUIText('ENGLISH', 'add', 'Add to dictionary');
</script>

The first argument specifies the language that is being changed (ie for the corresponding GuiLanguage parameter). The second argument specifies the label as follows:

ignore | Ignore once menu item text
ignoreAll | Ignore all menu item text
add | Add menu item text
edit | Edit menu item text (shown in static mode only)
changeAll | Change all menu item text
removeDuplicate | Remove duplicate menu item text
noSuggestions | 'No suggestions' menu item text
complete | Spell check complete


RapidSpell Web .NET Documentation: Dialog Spell Checking

Dialog Spell Checking

All text boxes (within a form on the page) will be spell checked, unless specifically indicated to be ignored

  1. Add the RapidSpell client files to the project (per 'Installation').
  2. Drag RapidSpell-DIALOG.js from Solution Explorer into the page, this will add a <script src="RapidSpell-DIALOG.js"></script> tag to the page with the correct path.
  3. All textboxes (that are inside a FORM element, and have their id attribute set) will be checked when the user triggers the spell check eg. in a button click handler;

    <input type="button" onclick="rapidSpell.dialog_spellCheck()" value="Spell Check" />
//or for a specific text box
<input type="button" onclick="rapidSpell.dialog_spellCheck(true, 'textBoxID1')" value="Spell Check" />
//or for a list of specific text boxes
<input type="button" onclick="rapidSpell.dialog_spellCheck(true, ['textBoxID1', 'textBoxID2', ...])" value="Spell Check" />

Disabling spell check on specific text boxes

  • Add the attribute nospell="true" to the text box.
  • Or, add the (client) ID of text box to the Javascript array rapidSpell.ayt_ignoreTextBoxIds,
    eg. either 1 of
    rapidSpell.dialog_ignoreTextBoxIds[rapidSpell.dialog_ignoreTextBoxIds.length] = 'textBox1'; //where textBox1 is the id attribute of a textbox
rapidSpell.dialog_ignoreTextBoxIds[rapidSpell.dialog_ignoreTextBoxIds.length] = '<%= textBox1.ClientID %>'; //where textBox1 is an asp:textbox tag.

Modifying or removing the 'Add' option

Please see the user dictionary topic.

MVC usage

Please see the MVC Usage page.

Using jQuery UI Dialog instead of a popup

In the Javascript for your page, call

rapidSpell.dialog_setUseDivDialog(true); //use false to deactivate
That will enable a DIV based dialog window, instead of a separate popup. The call to rapidSpell.dialog_setUseDivDialog checks if jQuery is currently loaded for the page (ie. your page already imports jQuery). If jQuery and/or jQuery UI is not present it will be loaded from CDN //code.jquery.com/jquery-1.11.3.min.js and //code.jquery.com/ui/1.11.4/jquery-ui.min.js. It is recommended (and to avoid using the CDN) that you please add jQuery and jQuery UI to your project and page, eg.
<link rel="stylesheet" href="/.../jquery-ui.css" />
<script src="/.../jquery-1.11.3.min.js"></script>
<script src="/.../jquery-ui.min.js"></script>

The jQuery UI Dialog mode uses an AJAX call to either WCF or ASMX based Web Service. The WCF service is used by default but this will only work with .NET 4 (project must reference Keyoti.RapidSpellWeb.ASP.NETv4.DLL). For Keyoti.RapidSpellWeb.ASP.NETv2.DLL, use the ASMX service by calling (in Javascript):

rapidSpell.setServiceType('asmx');

Modal mode

To display the spell check dialog modally, call

rapidSpell.dialog_setUseDivDialog(true);
rapidSpell.dialog_modal = true;

User options

There are several options available to the user via the "Options..." button in the dialog. Any changes to these options will override any settings specified in code. To disable the user options button (and any settings specified by the user), call

rapidSpell.setParameterValue('default', 'EnableOptions', false);

User options are stored in browser cookies and are not transferable to other devices as-is. Options apply to 'as you type' spell checking as well.

jQuery Dialog Troubleshooting

If you get '500' server errors, please check:

  • If the project uses Keyoti.RapidSpellWeb.ASP.NETv2.DLL, then the page scripts must call rapidSpell.setServiceType('asmx'), in order to use the .NET 2 compatible Web Service.
  • That the memory usage on the machine is not up near 100%. It has been found that the web services shut down when overall system memory consumption is high (this is a 'feature' of IIS/IISExpress).
  • Use the F12 tool's Network tab, to record traffic to the Web Services. Inspect the response from the server for more detail about what is going wrong.

We don't want you to struggle, so please email support@keyoti.com if problems persist.


RapidSpell Web .NET Documentation: User Dictionary

User Dictionary

Location and per user dictionaries

By default the user dictionary will be stored at ~/user-dictionary.txt (where ~/ means the web application root). However this should ideally be changed to give each user their own dictionary.

  • In Javascript, call rapidSpell.setParameterValue('default', 'UserDictionaryFile', newPath) - where newPath is a string with the user dictionary path.
  • To give each user their own dictionary (recommended) set the newPath based on the user's ID, eg. var newPath = "<%= currentUserObject.Id %>" (or similar).
  • The 'default' argument means change this parameter for all text boxes, but it can instead be the textbox object (not id) that the parameter should apply to, see 'Parameters'.

Disabling 'Add'

  • As above, set the dictionary path to an empty string; rapidSpell.setParameterValue('default', 'UserDictionaryFile', '');


RapidSpell Web .NET Documentation: 3rd Party Textboxes

3rd Party Textboxes

Static inline spell checking

As you type is not enabled for 3rd party or HTML editors. Generally, to use the static inline spell check, setup spell checking as usual but launch the spell check with rapidSpell.ayt_spellCheck('text box id'), where the text box id is the ID of the editable element - if this is not found the spell checker will look for an editable element.

Dialog spell checking

Generally, to use the dialog spell check, setup spell checking as usual but launch the spell check with rapidSpell.dialog_spellCheck('text box id'), where the text box id is the ID of the editable element - if this is not found the spell checker will look for an editable element.

Single CKEditor Example (inline & dialog modes)

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
    <title></title>
    <script src="/ckeditor_files/ckeditor.js" type="text/javascript"></script>
    <script src="/Keyoti_RapidSpell_Web_Common/RapidSpell-AYT.js" type="text/javascript"></script>
    <script src="/Keyoti_RapidSpell_Web_Common/RapidSpell-DIALOG.js" type="text/javascript"></script>

<script type="text/javascript">

    rapidSpell.ayt_staticMode = true;
    rapidSpell.ayt_aytEnabled = false;

    function spell(id, mode) {
        rapidSpell.setParameterValue('default', 'IgnoreXML', true);
        var ifr = document.getElementsByClassName('cke_wysiwyg_frame cke_reset')[0];
        ifr.setAttribute('id', id+'_ifr');
        ifr.id = id+'_ifr';

        if (mode == 'inline')
            rapidSpell.ayt_spellCheck(id + '_ifr')
        else {

            rapidSpell.dialog_spellCheck(true, id + '_ifr')
        }
    }

    window.onload = function () {
        CKEDITOR.replace('editor1');
    };
</script>
</head>
<body>
<form>
<textarea name="editor1"><p>Initial value.</p></textarea>
<input type="button" onclick="spell('editor1', 'inline')" value = 'Inline spell check' />
<input type=button onclick="spell('editor1', 'dialog')" value='Dialog spell check' />
</form>
</body>
</html>
The part in bold adds an id attribute to the CKEditor's iframe, to make it easier for the spell checker to access it.

Single TinyMCE Example (inline & dialog modes)

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
    <head id="Head1" runat="server">

    <!-- CDN hosted by Cachefly -->
    <script type="text/javascript" src="http://tinymce.cachefly.net/4.0/tinymce.min.js"></script>
    <script type="text/javascript" src="/Keyoti_RapidSpell_Web_Common/RapidSpell-AYT.js"></script>
    <script type="text/javascript" src="/Keyoti_RapidSpell_Web_Common/RapidSpell-DIALOG.js"></script>

    <script type="text/javascript">
        tinymce.init({
            height: 160,
            selector: 'textarea',
            toolbar: "insertfile undo redo | styleselect | bold italic | alignleft aligncenter alignright alignjustify | bullist numlist outdent indent | link image | mybutton1 mybutton2",
            setup: function (ed) {
                // Add a custom button for inline check
                ed.addButton('mybutton1', {
                    title: 'Inline spell check',
                    context: "tools",
                    image: '../images/abc.png',
                    onclick: function () {
                        rapidSpell.ayt_spellCheck('mytextbox_ifr');
                    }
                });
                // Add a custom button for dialog check
                ed.addButton('mybutton2', {
                    title: 'Dialog spell check',
                    context: "tools",
                    image: '../images/abc.png',
                    onclick: function () {
                        rapidSpell.setParameterValue(document.getElementById('mytextbox_ifr'), 'IgnoreXML', true);
                        rapidSpell.dialog_spellCheck(true, 'mytextbox_ifr');
                    }
                });
            }
        });
        rapidSpell.ayt_staticMode = true;
        rsw_absolutePositionStaticOverlay = true;

    </script>
    <title></title>
    <style type="text/css">
       .oldBrowserBox, .oldBrowserBox *
        {
           font-size: 11px !important;
           font-family:Verdana,Arial,Helvetica,sans-serif !important;
        }
</style>
</head>
<body>
        <textarea id='mytextbox' name="S1" ></textarea>
</body>
</html>

Multiple CKEditor Example (inline & dialog modes)

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
    <title></title>
    <script src="/ckeditor_files/ckeditor.js" type="text/javascript"></script>
    <script src="/Keyoti_RapidSpell_Web_Common/RapidSpell-AYT.js" type="text/javascript"></script>
    <script src="/Keyoti_RapidSpell_Web_Common/RapidSpell-DIALOG.js" type="text/javascript"></script>

<script type="text/javascript">
    //if you have jquery you can use $.inArray
    if (!Array.indexOf)
    {
      Array.indexOf = [].indexOf ?
          function (arr, obj, from) { return arr.indexOf(obj, from); }:
          function (arr, obj, from) { // (for IE6)
            var l = arr.length,
                i = from ? parseInt( (1*from) + (from<0 ? l:0), 10) : 0;
            i = i<0 ? 0 : i;
            for (; i<l; i++) {
              if (i in arr  &&  arr[i] === obj) { return i; }
            }
            return -1;
          };
    }

    var ckControls = ['editor1', 'editor2'];
    rapidSpell.ayt_staticMode = true;
     rapidSpell.ayt_aytEnabled = false;
    var inlineSpellMode=false;

    function spell(mode) {
        //give un-id'd textboxes an id
        var idsToCheck = [];
        var textareas = document.getElementsByTagName("textarea");
        var inputs = document.getElementsByTagName("input");
        for (var i = 0; i < textareas.length; i++){
            if(ckControls.indexOf(textareas[i].name)==-1)//not a CK textbox, so treat like a regular textarea
            {
                if (textareas[i].id == ''){
                          textareas[i].setAttribute('id', textareas[i].name+i);
                          textareas[i].id = textareas[i].name+i;
                }

                idsToCheck[idsToCheck.length] = textareas[i].id;
            }
        }
        for (var i = 0; i < inputs.length; i++){
            if(ckControls.indexOf(inputs[i].name)==-1)//not a CK textbox, so treat like a regular input
            {
                if (inputs[i].type == 'text' && inputs[i].id == ''){
                          inputs[i].setAttribute('id', inputs[i].name+i);
                          inputs[i].id = inputs[i].name+i;
                }

                if(inputs[i].type == 'text')
                    idsToCheck[idsToCheck.length] = inputs[i].id;
            }
        }

        var ifrs = document.getElementsByClassName('cke_wysiwyg_frame cke_reset');
        for(var i=0; i<ifrs.length; i++){
            var ifr = ifrs[i];
            ifr.setAttribute('id', i+'_ifr');
            ifr.id = i+'_ifr';
            rapidSpell.setParameterValue(ifr, 'IgnoreXML', true);
            idsToCheck[idsToCheck.length] = ifr.id;
        }

        if (mode == 'inline'){
            inlineSpellMode = !inlineSpellMode;
            if(inlineSpellMode)
                rapidSpell.ayt_setupTextBoxes(false, idsToCheck);
            rapidSpell.ayt_spellCheck();
        }else {

            rapidSpell.dialog_spellCheck(true, idsToCheck);
        }
    }

    window.onload = function () {
        for(var i=0; i<ckControls.length; i++){
            CKEDITOR.replace(ckControls[i]);
        }
    };

    </script>
    </head>
    <body>
    <form>
    <textarea name="editor1"><p>Initifal value.</p></textarea>
    <textarea name="editor2"><p>Subseequent value.</p></textarea>
    <textarea name="ta" >helllo worlkd</textarea>
    <input type="button" onclick="spell('inline')" value = 'Inline spell check' />
    <input type=button onclick="spell('dialog')" value='Dialog spell check' />

</form>
</body>
</html>
The part in bold adds an id attribute to the CKEditor's iframe, to make it easier for the spell checker to access it.

Multiple TinyMCE Example (inline & dialog modes)

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
    <head id="Head1" runat="server">

    <!-- CDN hosted by Cachefly -->
    <script type="text/javascript" src="http://tinymce.cachefly.net/4.0/tinymce.min.js"></script>
    <script type="text/javascript" src="/Keyoti_RapidSpell_Web_Common/RapidSpell-AYT.js"></script>
    <script type="text/javascript" src="/Keyoti_RapidSpell_Web_Common/RapidSpell-DIALOG.js"></script>

    <script type="text/javascript">
            rapidSpell.ayt_staticMode=true;
            rapidSpell.ayt_aytEnabled = false;
            rapidSpell.setParameterValue('default', 'IgnoreXML', true);

            tinymce.init({selector:'textarea'});

            function inlineCheck(){
                rapidSpell.ayt_setupTextBoxes(false, ['ta1_ifr', 'ta2_ifr']);
                rapidSpell.ayt_spellCheck();
            }
    </script>

    <style type="text/css">
           .oldBrowserBox, .oldBrowserBox *
            {
               font-size: 11px !important;
               font-family:Verdana,Arial,Helvetica,sans-serif !important;
            }
    </style>

    </head>
    <body>
    <textarea id="ta1">Helloo worldd...
    </textarea>
    <textarea id="ta2">niice to meet yuo.
    </textarea>
    <input type="button" onclick="inlineCheck()" value="Inline spell">
    <input type='button' onclick="rapidSpell.dialog_spellCheck(true, ['ta1_ifr', 'ta2_ifr'])" value="Dialog spell"/>
</body>
</html>

Custom text interface

In cases where the automatic text retrieval interface does not return the correct text to be spell checked, from the textbox, it is possible to define a custom interface. The custom interface is a simple class that gets and sets the text in the textbox.

For example, add the code below to the page - the getText function is called by the spell checker when text is needed to be spell checked, and the setText function is called by the spell checker when spell check has finished and the text needs to be set back in the textbox.

//textBoxId is the textbox to be spell checked
//mode is either 'dialog' or 'ayt', indicating the type of spell check occurring
rapidSpell.textInterfaceNeeded =  function (textBoxId, mode) {return new RSCustomInterface(textBoxId);}

function RSCustomInterface(tbElementName){
    this.tbName = tbElementName;
    this.getText = getText;
    this.setText = setText;
    function getText(){
        //return the text from the text component named this.tbName,
        //this may be HTML formatted text
        return document.getElementById(this.tbName).innerHTML;
    }
    function setText(text){
        //set the text in the text component to the text argument
        //this may be HTML formatted text

        document.getElementById(this.tbName).innerHTML = text;

    }
}


RapidSpell Web .NET Documentation: Parameters

Parameters

Operational settings

These settings relate to how RapidSpell operates, rather than how the spell checker processes text, call any of the following lines to set the parameter

  • rapidSpell.ayt_helperURL = "/path/rswihelper.aspx";
    specifies the URL where rswihelper.aspx resides, by default this is automatically determined.
  • rapidSpell.ayt_aytEnabled = true;
    whether to do as-you-type checking.
  • rapidSpell.ayt_staticMode = false;
    whether to do static, button operated overlays with underlines.
  • rapidSpell.ayt_recheckDelay = 500;
    how many milliseconds to wait after the user stops typing to do the spell check.
  • rapidSpell.dialog_popupURL = "/path/popup.aspx";
    specifies the URL where popup.aspx resides, by default this is automatically determined.
  • rapidSpell.dialog_modal = false;
    whether the popup will be modal.
  • rapidSpell.dialog_width = 370;
    popup width.
  • rapidSpell.dialog_height = 430;
    popup height.
  • rapidSpell.dialog_left = 100;
    X coordinate of the popup.
  • rapidSpell.dialog_top = 100;
    Y coordinate of the popup.

Spell checker settings

These settings affect user experience, such as how the spell checker processes text, dictionaries and appearance etc.

Setting parameter values for a specific text box on the page

Call rapidSpell.setParameterValue(textBox, parameterName, value);
where 'textBox' is the text box element object (as returned by document.getElementById(textBoxId)). This will set the parameter for spell checking on that text box only, all other text boxes will use the default parameter values.

Setting default parameter values for all text boxes on a page

In Javascript, call rapidSpell.setParameterValue('default', parameterName, value);

Parameters
  • UserDictionaryFile
    see example
  • SuggestionsMethod
    PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS (default)
  • SeparateHyphenWords
    whether to treat hyphenated (-) words as separate words, default is false.
  • IncludeUserDictionaryInSuggestions
    whether the user dictionary should be used in finding suggestions for misspelt words, default is false.
  • IgnoreXML
    whether to ignore XML/HTML tags, false by default.
  • IgnoreCapitalizedWords
    whether to ignore words with capital letters, false by default.
  • GuiLanguage
    the UI language "ENGLISH", "FRENCH", "SPANISH", "GERMAN", "ITALIAN", "PORTUGUESE", "DUTCH", or "POLISH".
  • LanguageParser
    parser for current dictionary "ENGLISH", "FRENCH", "SPANISH", "GERMAN", "ITALIAN", "PORTUGUESE", "DUTCH", or "POLISH".
  • AllowAnyCase
    Whether to allow words spelt with incorrect case, eg. "africa", instead of "Africa", this is more relaxed than AllowMixedCase, default is false.
  • IgnoreWordsWithDigits
    whether to ignore words with numbers in them (eg. A10 or 7-11), true by default.
  • ShowFinishedMessage
    whether to show the popup dialog at the end of the spell check.
  • ShowNoErrorsMessage
    whether to show the popup dialog stating there were no spelling errors.
  • AllowMixedCase
    whether to allow words spelt with mixed case, eg. "MIxEd", default is false.
  • WarnDuplicates
    whether to treat duplicate words as errors (eg. "this is is an error"), true by default.
  • DictFile
    main dictionary (.dict) file path on the server (optional).
  • ConsiderationRange
    the size factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anyting.
  • LookIntoHyphenatedText
    whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
  • CheckCompoundWords
    whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
  • EnableUndo
    whether to provide 'undo' functionality to the user
    when checking very large texts this may cause browser memory issues.
  • LeaveWindowOpenForUndo
    whether to leave the popup open after the last word so that the user can undo the last operation.
  • IgnoreURLsAndEmailAddresses
    whether to ignore URLs and email addresses, true by default.
  • IgnoreIncorrectSentenceCapitalization
    whether to ignore words starting sentences in lower case, false by default.
  • IgnoreInEnglishLowerCaseI
    whether to ignore lower case 'i' characters in text. Set to false (default) to flag as errors.
  • SuggestSplitWords
    whether to look for connected words in suggestions, true by default.
  • FindCapitalizedSuggestions
    whether to look for capitalized suggestions (when the error isn't capitalized), note this will slow FindSuggestions down by about 7 times.


RapidSpell Web .NET Documentation: Client Scripting With RapidSpell

Client Scripting With RapidSpell

The 'rapidSpell' object can be used to code against, it is created automatically when the page loads and does not need to be declared or created manually.

Inline spell checking

Text box scripting

Although inline spell checked text boxes are actually IFRAMEs (unless in static mode in which case they remain HTML text boxes), client scripting is the same; the onaction event handlers work and the .value property can be set.

Spell checker

Events

The spell checker fires certain events, which can be attached to via the addEventListener function, and removed from via removeEventListener(eventName, listenerFunction).

rapidSpell.addEventListener('ayt_textboxesinitialized', onInitialized);
rapidSpell.addEventListener('ayt_spellcheckfinish',  onFinish);
rapidSpell.addEventListener('ayt_correction',  onCorrection);
rapidSpell.addEventListener('ayt_contextmenushowing',  onMenuShowing);
rapidSpell.addEventListener('ayt_contextmenushown',  onMenuShown);
//Other events are; ayt_finished_initializing, contextmenu.

...

//called when the textboxes are ready for user input
function onInitialized() {...}

//called when spell check response comes from the server, the id of the textbox can be obtained
//from textbox.shadowTB.id (for non static mode)
function onFinish(textbox, complete, numberOfErrors){...}

//called when a correction is made the id of the textbox can be obtained from textbox.shadowTB.id
//(for non static mode), and data.errorWord has the error word, and data.replacement has the correction
function onCorrection(textbox, data) {...}

//called when the context menu is about to be shown
//contextMenu is the context menu object, it includes .x and .y fields with it's position
//activeTextbox is our internal class for the textbox, you might find something useful by browsing it's variables in your IDE
//event the mouse/keyboard user event that caused the menu to be shown
//spellingErrorElement is a span tag that is highlighting the error, usually it's the position of this where the menu should be shown
function onMenuShowing(contextMenu, activeTextbox, event, spellingErrorElement ){...}

//called when the context menu has been shown
function onMenuShown(contextMenu, activeTextbox, event, spellingErrorElement ){...}
Functions
  • rapidSpell.ayt_spellCheck(document.getElementById('TextBox1'), this) - spell check 'TextBox1' (this allows the spell checker to modify the button text)
  • rapidSpell.ayt_spellCheck() - spell check all text boxes (that are not setup to be ignored)
  • rapidSpell.ayt_setupTextBoxes(true) - call this when textboxes are added to or removed from the page (eg. with AJAX or DHTML)
  • rapidSpell.ayt_refreshUnderlines() - respell checks the text boxes, call this when changing spell check parameters
  • rapidSpell.setParameterValue() - see 'Parameters'
  • rapidSpell.getParameterValue() - see 'Parameters'
Fields
  • rapidSpell.ayt_helperURL - the URL of the page holding the RapidSpellWInlineHelper control, by default this is in the same folder as the RapidSpell-AYT.js script
  • rapidSpell.ayt_aytEnabled - whether to spell check as the user types (true)
  • rapidSpell.ayt_staticMode - whether to spell check statically (user cannot edit text) (false)
  • rapidSpell.ayt_recheckDelay - number of milliseconds user must pause (in as you type mode) before spell check occurs (500)
  • rapidSpell.ayt_ignoreTextBoxIds - array of text box ids to not spell check

Dialog spell checking

Spell checker

Events

The spell checker fires certain events, which can be attached to via the addEventListener function, and removed from via removeEventListener(eventName, listenerFunction).

rapidSpell.addEventListener('dialog_finishedcheckingtextbox', onFinish);
rapidSpell.addEventListener('dialog_correction',  onCorrection);
//Other events available are; dialog_finishedcheckingall, dialog_finishedcheckingtextbox, dialog_startedcheckingtextbox, dialog_correction, dialog_add

...

//called when spell check on a text box finishes, the id of the textbox can be obtained
//from textbox.id, complete indicates if it was completed or cancelled (false)
function onFinish(src, textbox, complete){...}

//called when a correction is made the id of the textbox can be obtained from textbox.id
//wordStart is where the error occurs in the text, oldWord is the error and newWord is the correction
function onCorrection(src, textbox, wordStart, oldWord, newWord) {...}
Functions
  • rapidSpell.dialog_spellCheck(true, textBoxID) - spell check text box with ID 'textBoxID'
  • rapidSpell.dialog_spellCheck(true) - spell check all text boxes *that are not setup to be ignored)
  • rapidSpell.setParameterValue() - see 'Parameters'
  • rapidSpell.getParameterValue() - see 'Parameters'
Fields
  • rapidSpell.dialog_popupURL - the URL of the page holding the RapidSpellWeb control, by default this is in the same folder as the RapidSpell-DIALOG.js script
  • rapidSpell.dialog_modal - modal popup
  • rapidSpell.dialog_width - width of the popup
  • rapidSpell.dialog_height - height of the popup
  • rapidSpell.dialog_left - X coord position of the popup
  • rapidSpell.dialog_top - Y coord position of the popup
  • rapidSpell.dialog_ignoreTextBoxIds - array of text box ids to not spell check


RapidSpell Web .NET Documentation: Customizing Dialog Layout

Customizing Dialog Layout

There are two ways to implement the dialog spell checker (using an ASPX popup page, or through a jQuery Dialog and AJAX call), and therefore two ways to customize the dialog:

For ASPX based dialog page

.ASPX based popup pages (housed in their own popup windows) are the default (and traditional) way to implement dialog spell checking.

It is possible to customize the layout of the spell checker using a HTML template mechanism. This is done by specifying the Layout.Html property with a string of HTML using special tags to indicate the position of the essential spell checker elements. The tags are <PreviewPane/>*, <AddButton/>, <IgnoreButton/>, <IgnoreAllButton/>, <UndoButton>, <FieldDisplayLabel/>, <ChangeButton/>, <ChangeAllButton/>, <FinishButton/>, <OptionsButton/>, <ChangeToLabel/>, <ChangeToBox/>*, <SuggestionsLabel/>, <SuggestionsBox/>* - tags marked with * are required for correct functionality.

Code Example With Customized Layout

Page containing the RapidSpellWeb control, note because this has different dimensions you should modify the dialog_width and dialog_height properties in the dialog parameters to 530 and 250 respectively, eg;
rapidSpell.dialog_width = 530; and rapidSpell.dialog_height = 250;
Call this in the page that launches the dialog spell check.

Put the code below into an ASPX page and point the spell checker to it using rapidSpell.dialog_popupURL='path_to_file.aspx';

<%@ Page Language="C#"%>
<%@ Register TagPrefix="RapidSpellWeb" Namespace="Keyoti.RapidSpell"
Assembly="Keyoti.RapidSpellWeb.ASP.NETv4" %>
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML//EN">
<html>
<body>
<Center>
<RapidSpellWeb:RapidSpellWeb id="rapidSpellWeb" runat="server">
    <ChangeToBox Style="font-size:9pt; width:200px"/>
    <SuggestionsBox Style="font-size:9pt; width:200px"/>
    <PreviewPaneStyle Width="200" Height="190"/>
    <Layout Html="
        <table border=0>
        <tr><td colspan=3 bgcolor='#eeeeee'><b>MyCo Spell Checking</b>
        </td></tr><tr><td>
        <PreviewPane/>
        </td><td>
        <ChangeToLabel/>
        <br>
        <ChangeToBox/>
        <br>
        <SuggestionsLabel/>
        <br>
        <SuggestionsBox/>
        </td><td>
        <table border=0><tr><td>
        <IgnoreButton/>
        </td></tr><tr><td>
        <IgnoreAllButton/>
        </td></tr><tr><td>
        <AddButton/>
        </td></tr><tr><td>
        <ChangeButton/>
        </td></tr><tr><td>
        <ChangeAllButton/>
        </td></tr><tr><td>
        <UndoButton/>
        </td></tr>
        <tr><td>
        <OptionsButton/>
        </td></tr>
        <tr><td>
        <FinishButton/>
        </td></tr></table>
        </td></tr></table>
    "/>
</RapidSpellWeb:RapidSpellWeb>
</center>
</body>
</html>

The only restriction is that the special tags must be on a line by themselves.

For jQuery Dialog

If the jQuery Dialog is used (ie. if rapidSpell.dialog_setUseDivDialog(true); is called on the page), then the custom dialog is implemented by adding the UI elements to the page where the spell checker is used. An example of this is in the MVC demo project, under the RapidSpell install directory.

Code Example With Customized Layout
    <script type="text/javascript">
        rapidSpell.dialog_setUseDivDialog(true);
        rapidSpell.dialog_default_width = 500;
        rapidSpell.dialog_default_height= 350;
    </script>

    <style type='text/css'>
        #rsw_documentTextPanel
        {
            border: 1px solid #aaa;
            border-radius: 3px;
        }
            #rsw_word, #rsw_suggestions
        {
            border: 1px solid #aaa;
            border-top-color: #a0a0a0;
        }
        #rsw_optionsDialog
        {

            display: none;
            position: absolute;
            margin-left: auto;
            margin-right: auto;
            margin-top: auto;
            margin-bottom: auto;
            left: 0;
            right: 0;
            top: 0;
            bottom: 0;
            width: 295px;
            height: 230px;
            z-index: 101;
            background-color: white;
            border: 1px solid #444;
            border-radius: 5px;
            padding: 8px;
        }
        #rsw_optionsDialog_Backing
        {
            display: none;
            position: absolute;
            margin-left: auto;
            margin-right: auto;
            margin-top: auto;
            margin-bottom: auto;
            left: 0;
            right: 0;
            top: 0;
            bottom: 0;
            width: 100%;
            height: 100%;
            background-color: rgba(100,100,100,.60);
            z-index: 100;
        }
        #rsw_optionsDialog > label
        {
            display: block;
            padding-bottom: 12px;

        }
        #rsw_optionsDialog > input
        {
            margin-right: 9px;
            margin-top:12px;
        }
        #rsw_optionsHeader
        {
            font-size: 1.2em;
            border-bottom: 1px solid #aaa;
        }

        #rsw_documentTextPanel
        {
            border: 1px solid #aaa;
            border-radius: 3px;

            text-align: justify;
            padding:4px;
            overflow-y:scroll;
            margin-bottom:4px;
        }

        .badWordHighlight{
            background-position: bottom;background-repeat: repeat-x;background-color: #ededff;

        }
        #rsw_documentTextPanel{

            height: 150px;
        }

        #rsw_changePanel{

            width: 200px;
            float:left;
        }

        #rsw_buttonPanel{
            width:250px;
            float:right;

        }

        #rsw_buttonPanel  div, #rsw_buttonPanel input{
            margin-right:0px;
            width:100px;
            font-size:9pt;
        }

        #rsw_optionsButton
        {
            font-size:9pt;
        }
         #rsw_dialog input, #rsw_dialog select {
            margin:4px;
         }

         #rsw_buttonPanel input{
            margin: 10px;
        }

        #rsw_dialog
        {
            font-family:'Segoe UI', Arial, sans-serif;
            font-size:10pt;
            padding:10px;
            z-index:500;
        }

        #rsw_word
        {
            width:197px;
        }

         #rsw_suggestions
        {
            width:200px;
        }
        </style>

        ....

    <div id="rsw_dialog" nospell="true" title="Custom Spell Check" style="display:none;">
        <form id="spellCheckerForm" onsubmit="rsw_change(); return false;">
            <div id="rsw_documentTextPanel">
            </div>
            <div id="rsw_changePanel">
                <label for="rsw_word"><span>Change To:</span></label>
                <input name="rsw_word" type="text" id="rsw_word" size="16" tabindex="4" />
                <label for="rsw_suggestions"><span>Suggestions:</span></label>
                <select name="rsw_suggestions" id="rsw_suggestions" size="6" onchange="rsw_changeSuggestions()" ondblclick="rsw_change()" tabindex="5">
                    <option value="No Suggestions.">No Suggestions.</option>
                </select>

            </div>
            <div id="rsw_buttonPanel">
                <div style="display: inline-block;">
                    <input type="button" value="Ignore" id="rsw_ignoreButton" onclick="rsw_ignoreCurrent()" tabindex="1"  name="rsw_ignoreButton" />
                    <input type="button" value="Ignore All" id="rsw_ignoreAllButton" onclick="    rsw_ignoreAllInstances()" tabindex="2"  name="rsw_ignoreAllButton" />
                    <input type="button" value="Add" id="rsw_addButton" onclick="rsw_addCurrent()" tabindex="3" name="rsw_addButton" />
                    <input type="button" value="Options..." id="rsw_optionsButton" onclick="rsw_showOptions()" tabindex="10" name="rsw_optionsButton" />
                </div>
                <div style="display: inline-block;">
                    <input type="button" value="Change" id="rsw_changeButton" onclick="    rsw_change()" tabindex="6" name="rsw_changeButton" />
                    <input type="button" value="Change All" id="rsw_changeAllButton" onclick="    rsw_changeAll()" tabindex="7"  name="rsw_changeAllButton" />
                    <input type="button" value="Undo" id="rsw_undoButton" onclick="    rsw_undoChange()" tabindex="8" name="rsw_undoButton" />
                    <input type="button" value="Finish" id="rsw_cancelButton" onclick="    rsw_finish(true)" tabindex="9"  name="rsw_cancelButton" />
                </div>

            </div>
        </form>
        <div id="rsw_optionsDialog">
            <h1 id="rsw_optionsHeader">Basic Settings</h1>
            <label>
                <input type="checkbox" id="IgnoreCapitalizedWords"/>Ignore words in UPPERCASE</label>
                <label><input type="checkbox" id="IgnoreWordsWithDigits"/>Ignore words with numbers</label>
                <label><input type="checkbox" id="IgnoreURLsAndEmailAddresses"/>Ignore internet addresses and emails</label>
                <label><input type="checkbox" id="IgnoreCase"/>Ignore improper case (eg. "australia", "tABle")'</label>
                <input type="button" value="OK" onclick="    rsw_saveOptions()"/>
                <input type="button" value="Cancel" onclick="    rsw_cancelOptions()"/></div>
        <div id="rsw_optionsDialog_Backing"></div>
    </div>

When a DIV with id=rsw_dialog is included on the page, it is assumed that this will contain all the necessary UI elements, and this will be used instead of generating new ones. In order to hide elements (such as buttons), it is recommended that they are hidden with display:none (CSS) rather than removed from the HTML markup (as this could cause Javascript errors).


RapidSpell Web .NET Documentation: AJAX & DHTML Type Usage

AJAX & DHTML Type Usage

Starting from the regular as you type setup. If textboxes on the page are being added/removed via Javascript (this covers DHTML and also ASP.NET AJAX type usage, eg TabContainer), then it is necessary to call a Javascript function in RapidSpell to make it rescan for active textboxes to spell check.

rapidSpell.ayt_setupTextBoxes(true);

Example using ASP.NET AJAX and TabContainer

On a page using a TabContainer add a client side event handler for the tab changed event

<script type="text/javascript">
        function tabContainer_TabChanged() {
            rapidSpell.ayt_setupTextBoxes(true);
        }
</script>

...

<asp:TabContainer ID="TabContainer1" runat="server" ActiveTabIndex="0" OnClientActiveTabChanged="tabContainer_TabChanged">

The spell checker will then refresh and underline the errors in the new textboxes.


RapidSpell Web .NET Documentation: Inline Validator

Inline Validator

In non-as-you-type spell checking scenarios it may be desirable to have the inline spell checker work as a validator. This can be configured with asp:CustomValidator as a client script validator.

Static mode validation

  1. Setup static mode checking per this topic.
  2. Add the validation function to a Javascript block.
    function validateSpelling(oSrc, args) {
    //Check if spell check already ran.
    for (var i = 0; i < rsw_scs.length; i++) {
        if (rsw_scs[i].textBoxID == oSrc.controltovalidate && rsw_scs[i].hasRun) {
            args.IsValid = true;
            return;
        }
    }

    var rapidSpellChecker = new RapidSpellCheckerClient(rapidSpell.ayt_helperURL);
    rapidSpellChecker.config = rsw_getConfigurationObject('default');
    var result = rapidSpellChecker.Check(args.Value);
    args.IsValid = result.numberOfErrors == 0;
}

    This will check if spell checking has been performed on the text box that is validating, and if not will check it for errors using the RapidSpellCheckerClient class.
  3. Add an asp:CustomValidator to the page for each text box.
    <asp:CustomValidator id="CustomValidator1"  runat="server" ControlToValidate="TextBox1" EnableClientScript='true'
             ErrorMessage="There are spelling errors and spell check hasn't been performed."
             ClientValidationFunction="validateSpelling">
            </asp:CustomValidator>
  4. Tip: it appears that generally (with or without RapidSpell) the .NET CustomValidator, when using a ClientValidationFunction, does not work in strict page mode (i.e.<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">) - please do conduct your own tests.


RapidSpell Web .NET Documentation: Dialog Validator

Dialog Validator

Using the dialog spell checker as a client-side validator.

  1. Setup dialog checking per this topic.
  2. Drag RapidSpell-AYT.js from Solution Explorer into the page, this will add a <script src="RapidSpell-AYT.js"></script> tag to the page with the correct path.
  3. Add the validation function to a Javascript block.
    rapidSpell.ayt_aytEnabled = false;//disable inline checking
rapidSpell.ayt_staticMode = true; //disable inline checking
function validateSpelling(oSrc, args) {
    //Check if spell check already ran.
    for (var i = 0; i < rsw_rapidSpellControls.length; i++) {
        if (rsTCInt[rsw_rapidSpellControls[i]].tbName == oSrc.controltovalidate && rsTCInt[rsw_rapidSpellControls[i]].hasRun) {
            args.IsValid = true;
            return;
        }
    }

    //we import RapidSpell-AYT.js to be able to use RapidSpellCheckerClient
    var rapidSpellChecker = new RapidSpellCheckerClient(rapidSpell.ayt_helperURL);
    rapidSpellChecker.config = rsw_getConfigurationObject('default');
    var result = rapidSpellChecker.Check(args.Value);
    args.IsValid = result.numberOfErrors == 0;
}

    This will check if spell checking has been performed on the text box that is validating, and if not will check it for errors using the RapidSpellCheckerClient class.
  4. Add an asp:CustomValidator to the page for each text box.
    <asp:CustomValidator id="CustomValidator1"  runat="server" ControlToValidate="TextBox1" EnableClientScript='true'
             ErrorMessage="There are spelling errors and spell check hasn't been performed."
             ClientValidationFunction="validateSpelling">
            </asp:CustomValidator>
  5. Tip: it appears that generally (with or without RapidSpell) the .NET CustomValidator, when using a ClientValidationFunction, does not work in strict page mode (i.e.<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">) - please do conduct your own tests.


RapidSpell Web .NET Documentation: AJAX Based Programmatic String Checking

AJAX Based Programmatic String Checking (RapidSpellCheckerClient)

The RapidSpellCheckerClient control can be used to programmatically check strings, in Javascript. If the control has been added to the page it will emit the required Javascript to setup an instance for use.

Setup

  1. Add the RapidSpell client files to the project (per 'Installation').
  2. Drag RapidSpell-AYT.js from Solution Explorer into the page, this will add a <script src="RapidSpell-AYT.js"></script> tag to the page with the correct path.
  3. Instantiate and configure the object.
    var rsc = new RapidSpellCheckerClient(rapidSpell.ayt_helperURL);
rsc.config = rsw_getConfigurationObject('default');

Asynchronously spell checking a string

Generally we recommend that spell checking be performed asynchronously, as this allows the UI to respond to user events. Asynchronous functions are non blocking, so the return is handled by a callback function. Using asynchronous functions can be awkward, so we also provide a synchronous version, below. This asynchronous method is available in browsers that support XmlHttpRequst (eg. IE, FF...) and also in older browsers which don't (eg Opera 6).

rsc.Check(textToCheck, display);

'display' is the name of a function that will handle the call back and process the result. See below.

Synchronously spell checking a string

This form is used to run the spell check synchronously. This will cause the UI to block while the browser waits for the response. Under good network conditions this should be acceptable. One warning about this synchronous method is that it is only available in browsers capable of XmlHttpRequest (AJAX calls). If the browser cannot process these then the asynchronous method should be used instead.

var result = rsc.Check(textToCheck);

Processing the result

The result is an object with the following properties.

originalText //The text that was spell checker
numberOfErrors //The number of spelling errors
errorPositionArray //An array of errors, with their positions and suggestions

errorPositionArray[n].start //Where the spelling error is in the original text
errorPositionArray[n].end //Where the spelling error ends
errorPositionArray[n].suggestions //Simple array of string suggestions

The result object, which is returned by Check in synchronous calls, or passed to the call-back function in asynchronous calls, can then be processed.

function display(result){
    var resultTB = document.getElementById("resultTB");

    resultTB.value = '"' + result.originalText + "\" has " + result.numberOfErrors + " errors\r\n\r\n";
    for(var e = 0; e<result.errorPositionArray.length; e++){
        resultTB.value += "Error "+e+": " + result.errorPositionArray[e].word + "\r\n";
        resultTB.value += "\tstart:"+result.errorPositionArray[e].start+"\r\n";
        resultTB.value += "\tend:"+result.errorPositionArray[e].end+"\r\n";
        resultTB.value += "\tsuggestions: " + (result.errorPositionArray[e].suggestions.length==0?"none":"") + "\r\n";
        for(var s = 0; s<result.errorPositionArray[e].suggestions.length; s++){
            resultTB.value += "\t\t" + result.errorPositionArray[e].suggestions[s] + "\r\n";
        }
        resultTB.value += "\r\n";
    }
}

Add a word to user dictionary

Adding to the user dictionary is always asynchronous and requires the UserDictionaryFile property to be set to a file path on the server where the dictionary will be stored.

rsc.AddWord(wordToAdd);

Setting properties

Spell check options can be set on the server through the Control properties or on the client side through the Javascript functions.

rsc.setParameterValue(optionName, value);

where optionName is the name as specified exactly in the Control serverside properties. Similarly property values can be obtained through

rsc.getParameterValue(optionName);

Please consult the product demos for a complete example, plus how to access parameter names programmatically.


RapidSpell Web .NET Documentation: Cross Subdomain Usage

Cross Subdomain Usage

If the popup.aspx page (the page holding the RapidSpellWeb control) is hosted on a different subdomain than the page that is being spell checked, then it will be necessary to add some document.domain calls in Javascript to allow the script to run across the subdomains. For example consider the situation where the popup.aspx runs under spell.host.tld, and the page is at host.tld

In the user page call the following Javascript (after the RapidSpell script import).

<script type='text/javascript'>
document.domain = 'host.tld';
rapidSpell.dialog_documentDomain = 'host.tld';
</script>

In both the blank.html file (under the scripts folder) and also the popup.aspx, located on spell.host.tld, add

<script type='text/javascript'>
document.domain = 'host.tld';
</script>

That should be all that is required, if you experience any difficulty please email support @ keyoti.com

Tip:

Content loading in iframes on the page (outside of the spell checker) will need to declare the same document.domain as the parent page. If an iframe does not initially load a page (or loads about:blank) try having it load a blank HTML page with document.domain set inside).


RapidSpell Web .NET Documentation: Simple Popup Spell Checking

Below are some use scenarios of the 6 spell checker components supplied, please refer to the API documentation for additional detail. These examples are from C# pages, however because they are tag based most of them are the same for VB.NET (please see the example Visual Studio projects for more code).

Simple Popup Spell Checking

To use RapidSpell Web to spell check a web page in popup mode, create a page holding the RapidSpellWeb Control, then add the RapidSpellWebLauncher Control to your existing page with the text element you want checked, referencing the page you created with RapidSpellWeb in the RapidSpellWebPage property.

Example, note this code is highly simplistic for demonstration purposes.

Code Example

Page containing the RapidSpellWeb control

<%@ Page Language="C#" %>
<%@ Register TagPrefix="RapidSpellWeb" Namespace="Keyoti.RapidSpell" Assembly="Keyoti.RapidSpellWeb" %>
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML//EN">
<html><head><title>Spell Check</title></head>
<body>
<center>
<form runat=server id="Form1" method="post">
    <RapidSpellWeb:RapidSpellWeb id="rapidSpellWeb" runat="server"/>
</form>
</center>
</body>
</html>

Code Example

Page containing the RapidSpellWebLauncher control, where the text element to be checked is.

<%@ Page Language="C#"%>
<%@ Register TagPrefix="RapidSpellWeb" Namespace="Keyoti.RapidSpell" Assembly="Keyoti.RapidSpellWeb" %>
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML//EN">
<HTML>
<BODY >
    <form runat=server id=Form1 method=post>
        <asp:textbox id="TextBox1" runat="server" Font-Size="9pt" Font-Names="Arial" Height="220px"
Width="469px" TextMode="MultiLine" Columns="60" Rows="14"></asp:textbox>
        <rapidspellweb:rapidspellweblauncher id="RapidSpellWebLauncher1"
runat="server" RapidSpellWebPage="PopUp.aspx" TextComponentName="TextBox1" >
</rapidspellweb:rapidspellweblauncher>
    </form>
</body>
</HTML>

The main page uses the control RapidSpellWebLauncher to create the check spelling button, it's properties specify which form element to check (TextComponentName), the URL of the page containing the RapidSpellWeb control (RapidSpellWebPage) and the mode (Mode). RapidSpellWebPage can be a relative or absolute URL.

User Options

There are several options available to the user via the "Options..." button in the dialog. Any changes to these options will override any settings specified in code. To disable the user options button (and any settings specified by the user), set the EnableOptions property in RapidSpellWebLauncher to false.

User options are stored in browser cookies and are not transferable to other devices as-is.


RapidSpell Web .NET Documentation: Simple Inline Spell Checking

Simple Inline Spell Checking

To use RapidSpellWInline to spell check a text box; add the control to the form with the text box, set the TextComponentID property to the ID of the text box, and set the RapidSpellWInlineHelperPage property to the URL of a page holding the RapidSpellWInlineHelper control (this page needs nothing other than the RapidSpellWInlineHelper control on it).

Code Example

<%@ Register TagPrefix="rapidspellweb" Namespace="Keyoti.RapidSpell" Assembly="Keyoti.RapidSpellWeb" %>
<%@ Page language="c#" AutoEventWireup="false" %>
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" >
<HTML>
    <body MS_POSITIONING="GridLayout">
        <form id="Form1" method="post" runat="server">
            <asp:TextBox id="TextBox1" style="Z-INDEX: 101; LEFT: 135px; POSITION: absolute; TOP: 32px" runat="server" Width="330px" TextMode="MultiLine" Height="162px"></asp:TextBox>
    <RapidSpellWeb:RapidSpellWInline id="RapidSpellWInline1" style="Z-INDEX: 102; LEFT: 366px; POSITION: absolute; TOP: 210px" runat="server" TextComponentID="TextBox1" RapidSpellWInlineHelperPage="rswihelper.aspx">
<Button BorderWidth="" BorderColor="" ForeColor="" BackColor="" Height="" Width="" CssClass="" type="button" value="Spell Check"
ID="RapidSpellWInline1__ctl0"></Button>
    </RapidSpellWeb:RapidSpellWInline>
        </form>
    </body>
</HTML>

Code Example (Helper page)

The code above requires a page holding RapidSpellWInlineHelper, create one called rswihelper.aspx containing the following;

<%@ Page language="c#" AutoEventWireup="false" validateRequest="false"%>
<%@ Register TagPrefix="rapidspellweb" Namespace="Keyoti.RapidSpell" Assembly="Keyoti.RapidSpellWeb" %>
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" >
<HTML>
    <body>
        <form id="Form1" method="post" runat="server">
        <RapidSpellWeb:RapidSpellWInlineHelper id="rswi1" runat="server"/>
        </form>
    </body>
</HTML>


RapidSpell Web .NET Documentation: Setting PopUp Style

Setting PopUp Style

It is very simple to define the style properties of elements as with any other .NET Web Control, eg;

Code Snippet Button Customization

<IgnoreButton
    Style="font-family:'Tahoma,Arial,Helvetica';font-size:10pt; border:1px
solid #b5bed6; background-color:#dddddd; width: 90px;"

onMouseOver="this.style.backgroundColor='#b5bed6';this.style.borderColor='#08246b';"
onMouseOut="this.style.backgroundColor='#dddddd';this.style.borderColor='#b5bed6';"

    />

This specifies the style using regular CSS syntax and also specifies onMouseOver/Out Javascript events to modify the style for an attractive effect. An alternative to setting the Style property is the CssClass property which can be used to specify a CSS class for the element.


RapidSpell Web .NET Documentation: Separate Page Spell Checking

Separate Page Spell Checking

To use RapidSpell Web to spell check a web page in separate mode, create a page holding the RapidSpellWeb control, then add the RapidSpellWebLauncher control to your existing page with the text element you want checked, referencing the page you created with RapidSpellWeb in the RapidSpellWebPage property.

Code Example From SpellCheckSeparatePage.aspx

Page containing the RapidSpellWeb control.

<%@ Page Language="C#"%>
<%@ Register TagPrefix="RapidSpellWeb" Namespace="Keyoti.RapidSpell"
Assembly="Keyoti.RapidSpellWeb" %>
<HTML>
    <BODY >
<RapidSpellWeb:RapidSpellWeb id="rapidSpellWeb" runat="server">
        <IgnoreButton
            Style="font-family:'Tahoma,Arial,Helvetica';font-size:10pt;
border:1px solid #b5bed6; background-color:#dddddd; width: 90px;"

onMouseOver="this.style.backgroundColor='#b5bed6';this.style.borderColor='#08246b';"

onMouseOut="this.style.backgroundColor='#dddddd';this.style.borderColor='#b5bed6';"

        />
        <IgnoreAllButton
            .... />
        <AddButton
            .... />
        <ChangeButton
            .... />
        <ChangeAllButton
            .... />
        <FinishButton
            .... />
        </RapidSpellWeb:RapidSpellWeb>
</BODY>
</HTML>

Code Example From exampleTextBox5-Separate.aspx

Page containing the RapidSpellWebLauncher control

<%@ Page Language="C#" %>
<%@ Register TagPrefix="RapidSpellWeb" Namespace="Keyoti.RapidSpell"
Assembly="Keyoti.RapidSpellWeb" %>
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML//EN">
<HTML>
    <BODY>

        //if this page is to show the text input box
        <% if(Request.Form.Get("fMessage") == null){ %>
        <form action='exampleTextBox1.aspx' method='post' name='myForm'>
        <input type='hidden' name='fMessage' value='complete'>
        //if showing the text box for the first time, no spell check performed

        <% if(Request.Form.Get("RSCallBack") == null){ %>

            <textarea name="sourceTextBox" wrap='true' cols='40' rows='10'>
                This is some sample text with daliberate spelling errars
            </textarea>

        <% } else { %>

            //spell check has been run, so show the corrected text
            <textarea name="sourceTextBox" wrap='true' cols='55' rows='10'>
                <%= Request.Form.Get("CorrectedText") %>
            </textarea>

        <% } %>
            <br>

            <RapidSpellWeb:RapidSpellWebLauncher id="rapidSpellWebLauncherSep"
                runat="server"
                TextComponentName="myForm.sourceTextBox"
                CallBack="exampleTextBox5-separate.aspx"
                Mode="separate"
                RapidSpellWebPage="SpellCheckSeparatePage.aspx" >
                <Button Style="font-family:'Tahoma,Arial'; border:1px solid
#b5bed6; background-color:#dddddd;"

onMouseOver="this.style.backgroundColor='#b5bed6';this.style.borderColor='#08246b';"

onMouseOut="this.style.backgroundColor='#dddddd';this.style.borderColor='#b5bed6';"

                    Value="Check Spelling Separate Page"
                />
            </RapidSpellWeb:RapidSpellWebLauncher>
        <input type='submit' Style="font-family:'Tahoma,Arial'; border:1px solid
#b5bed6; background-color:#dddddd;"
onMouseOut="this.style.backgroundColor='#dddddd';this.style.borderColor='#b5bed6';"
onMouseOver="this.style.backgroundColor='#b5bed6';this.style.borderColor='#08246b';"
>

        </form>
        <% } else { %>
        Text entered was:
    "<%=Request.Form.Get("sourceTextBox")%>"
        <% } %>
        </BODY>
</HTML>

In these pages the style of the buttons has been set through the properties of the controls. Note that the CallBack is set to the URL of the page the user should be directed to after they have finished checking the document, this page is called with the parameter CorrectedText which holds the text after the spell check.


RapidSpell Web .NET Documentation: Customizing RapidSpellWeb Layout

Customizing RapidSpellWeb Layout

It is possible to customize the layout of the spell checker using a HTML template mechanism. This is done by specifying the Layout.Html property with a string of HTML using special tags to indicate the position of the essential spell checker elements. The tags are <PreviewPane/>*, <AddButton/>, <IgnoreButton/>, <IgnoreAllButton/>, <UndoButton>, <FieldDisplayLabel/>, <ChangeButton/>, <ChangeAllButton/>, <FinishButton/>, <ChangeToLabel/>, <OptionsButton/>, <ChangeToBox/>*, <SuggestionsLabel/>, <SuggestionsBox/>* - tags marked with * are required for correct functionality.

Code Example With Customized Layout

Page containing the RapidSpellWeb control, note because this has different dimensions you should modify the WindowWidth and WindowHeight properties in the RapidSpellWebLauncher that launches this, to 530 and 250 respectively.

<%@ Page Language="C#"%>
<%@ Register TagPrefix="RapidSpellWeb" Namespace="Keyoti.RapidSpell"
Assembly="Keyoti.RapidSpellWeb" %>
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML//EN">
<html>
<head>
    <style type="text/css">

        body{overflow:hidden;
             font-family: sans-serif, arial, helvetica;

        }
        div{height:100%;}

        #rsw_documentTextPanel
        {
            border: 1px solid #aaa;
            border-radius: 3px;
        }
        #rsw_word, #suggestions
        {
            border: 1px solid #aaa;
            border-top-color: #a0a0a0;
        }
        #rsw_optionsDialog
        {
            font-size:.80em;
            display: none;
            position: absolute;
            margin-left: auto;
            margin-right: auto;
            margin-top: auto;
            margin-bottom: auto;
            left: 0;
            right: 0;
            top: 0;
            bottom: 0;
            width: 295px;
            height: 230px;
            z-index: 101;
            background-color: white;
            border: 1px solid #444;
            border-radius: 5px;
            padding: 8px;
        }
        #rsw_optionsDialog_Backing
        {
            display: none;
            position: absolute;
            margin-left: auto;
            margin-right: auto;
            margin-top: auto;
            margin-bottom: auto;
            left: 0;
            right: 0;
            top: 0;
            bottom: 0;
            width: 100%;
            height: 100%;
            background-color: rgba(100,100,100,.60);
            z-index: 100;
        }
        #rsw_optionsDialog > label
        {
            display: block;
            padding-bottom: 12px;

        }
        #rsw_optionsDialog > input
        {
            margin-right: 9px;
            margin-top:12px;
        }
        #rsw_optionsHeader
        {
            font-size: 1.2em;
            border-bottom: 1px solid #aaa;
        }
    </style>
</head>
<body>

<RapidSpellWeb:RapidSpellWeb id="rapidSpellWeb" runat="server">
    <ChangeToBox Style="font-size:9pt; width:200px"/>
    <SuggestionsBox Style="font-size:9pt; width:200px"/>
    <PreviewPaneStyle Width="200" Height="190"/>
    <Layout Html="
        <table border=0>
        <tr><td colspan=3 bgcolor='#eeeeee'><b>MyCo Spell Checking</b>
        </td></tr><tr><td>
        <PreviewPane/>
        </td><td>
        <ChangeToLabel/>
        <br>
        <ChangeToBox/>
        <br>
        <SuggestionsLabel/>
        <br>
        <SuggestionsBox/>
        </td><td>
        <table border=0><tr><td>
        <IgnoreButton/>
        </td></tr><tr><td>
        <IgnoreAllButton/>
        </td></tr><tr><td>
        <AddButton/>
        </td></tr><tr><td>
        <ChangeButton/>
        </td></tr><tr><td>
        <ChangeAllButton/>
        </td></tr>
        <tr><td>
        <OptionsButton/>
        </td></tr>
        <tr><td>
        <FinishButton/>
        </td></tr></table>
        </td></tr></table>
    "/>
</RapidSpellWeb:RapidSpellWeb>

</body>
</html>

The only restriction is that the special tags must be on a line by themselves.


RapidSpell Web .NET Documentation: Specifying User Dictionaries

Specifying User Dictionaries

Use of user dictionaries with RapidSpell Web can be on a one user dictionary for all users, or one user dictionary per user or one user dictionary per group basis. The user dictionary file path is specified in the UserDictionaryFile property of the RapidSpellWebLauncher/RapidSpellWInline control. This property specifies the file path to the user dictionary file on the server, and since this property can be specified simply and dynamically using a 'DataBind', the developer has total control over which dictionary file is used for a user. Therefore it is up to the developer to manage a user's session and retrieve the path to a particular user's/group's dictionary file, if required.

User dictionaries are simple text files, they contain a list of words, one per line, and are written to when the user clicks the 'Add' button. If the user dictionary file doesn't exist, it is created. If the user dictionary file cannot be accessed (due to an invalid path, or insufficient file access permission) then the 'Add' button is not displayed.

User Dictionary Strategy

It is often desirable to give each user their own user dictionary - in order to implement this it is clear that the application must use some sort of user session management (otherwise it is impossible to tell users apart). Given this general requirement it is simple to maintain separate user dictionaries for each user. By creating a directory for user dictionaries and making each dictionary file name dependant on a unique user identifier (perhaps their username, or a database key) each user is given their own file, and at run-time the UserDictionaryFile property can be set accordingly (using a DataBind, or accessing the property in codebehind).

Eg. your application has a user with username "joe_user" (for simplicity we will assume that user names cannot contain characters that are illegal in filenames). A directory off the application directory called "user-dictionaries" is created, the ASP_NET process has permission to write to it. All that is necessary is to set the UserDictionaryFile property;

[Code-behind]
RapidSpellWebLauncher.UserDictionaryFile = MapPath("user-dictionaries/" + userName + ".txt")
or
RapidSpellWInline.UserDictionaryFile = MapPath("user-dictionaries/" + userName + ".txt")

Code Example Using DataBind

Page containing the RapidSpellWebLauncher control

<%@ Register TagPrefix="RapidSpellWeb" Namespace="Keyoti.RapidSpell"
Assembly="Keyoti.RapidSpellWeb" %>
<%@ Page Language="C#" Debug="true"%>
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML//EN">
<HTML>
    <HEAD>
    <script language="C#" runat="server">
    //set the user dictionary file, this path could be obtained
    //dynamically if the user has their own file.
    String userDicFile = "C:\\Inetpub\\wwwroot\\rapidSpellWeb\\userDict.txt";
    //on page load, bind the data
    void Page_Load(Object sender, EventArgs e) {
        Page.DataBind();
    }
        </script>
    </HEAD>
    <BODY>
        <form runat="server" method='post' id="form1">
            <textarea id="sourceTextBox" name="sourceTextBox" wrap='true'
cols='40' rows='10'>This is some sample text with daliberate spelling errars</
textarea>
            <br>
            <RapidSpellWeb:RapidSpellWebLauncher
            id="rapidSpellWebLauncher" runat="server"
            TextComponentName="sourceTextBox"
            Mode="popup"
            UserDictionaryFile="<%# userDicFile %>"
            RapidSpellWebPage="PopUp.aspx"
            />

        </form>
    </BODY>
</HTML>

In this example the user dictionary is specified in the string userDicFile which is passed to the UserDictionaryFile property of the RapidSpellWebLauncher control using the <%# .... %> tags. The Page.DataBind() method is called when the page loads, which binds the value of userDicFile to the property UserDictionaryFile. The string was specified statically, but it could easily have come from a database, or session control object.


RapidSpell Web .NET Documentation: Using RapidSpell Web With 3rd Party Controls (Html Text Boxes)

Using RapidSpell Web With 3rd Party Controls (Html Text Boxes)

Automatic Setup

3rd Party Controls can be used with RapidSpell Web, to use with a rich/html text box simply set TextComponentInterface="Automatic" and TextComponentID / TextComponentName to the ID of the control. The automatic interface should then pickup the editable elements and work with them. This has been tested with popular text boxes, however it may be possible that it fails to find the editable element (resulting in the spell checker not working at all) - in which case follow the next section.

Manual Setup

First set IgnoreXML to true (this will mean HTML tags are ignored), set TextComponentInterface to the name of your Control (if not available the CustomInterface method should be used) and set TextComponentName to the ID of the Control. For example if you use Dart's PowerWEB TextBox and your web form code is;

<form id="Form1" name="Form1".....>
    .........
    <cc1:HtmlBox id="HtmlBox1" runat="server"></cc1:HtmlBox>
    .........
    .........
</form>

then you should set TextComponentName to "HtmlBox1" (the ID of the Control) and TextComponentInterface should be set to "PowerWEBTextBox". If your Html text box control isn't available in TextComponentInterface then you should contact the vendor and ask about RapidSpell Web support - it is possible to build custom support yourself, fairly simply (see below).

Please note, if you are using .NET 1.1 or higher you will need to add validateRequest='false' to the page directive in the page holding the RapidSpellWeb control (the popup) and the RapidSpellWInlineHelper control (for inline). Failure to do this will result in errors when spell checking text containing HTML.

Additionally, if you are using .NET 4 or higher you will need to add <httpRuntime requestValidationMode="2.0" /> in web.config under <system.web>

Code Example Using Html Text Boxes

Page containing the RapidSpellWebLauncher control

.......................
<form action='exampleTextBox6-3rdParty.aspx' method='post' name='myForm'
id='myForm' runat='server'>
    <cc1:HtmlBox id="HtmlBox1" runat="server"></cc1:HtmlBox>
    <RapidSpellWeb:RapidSpellWebLauncher id="rapidSpellWebLauncher"
runat="server"
        TextComponentName="HtmlBox1"
        Mode="popup"
        TextComponentInterface="PowerWEBTextBox"
        IgnoreXML="true"
        RapidSpellWebPage="RapidSpellCheckerPopUp.aspx">
    </RapidSpellWeb:RapidSpellWebLauncher>
</form>
.......................

To use RapidSpell Web with indirectly supported 3rd party controls it is necessary to write a custom Javascript interface which will perform two tasks for RapidSpell Web, it must get the text from the control and set text to the control. To enable the use of a custom interface the TextComponentInterface property should be set to "Custom", and a Javascript (ECMAscript) block should be written into the form containing RapidSpell Web.

As an example, a custom interface for the standard HTML text area will be built, to demonstrate the concepts.

Firstly the RapidSpellWebLauncher control's TextComponentInterface is set to Custom:

<RapidSpellWeb:RapidSpellWebLauncher id="rapidSpellWebLauncher" runat="server"
            TextComponentName="tA"
            Mode="popup"
            TextComponentInterface="Custom"
            RapidSpellWebPage="RapidSpellCheckerPopUp.aspx">

Next an interface must be written in Javascript, RapidSpell will expect a type RSCustomInterface to be defined, of the following structure:

    function RSCustomInterface(tbElementName){
        this.tbName = tbElementName;
        this.getText = getText;
        this.setText = setText;
        function getText(){
            //return the text from the text component named
this.tbName,
            //this may be HTML formatted text
            return .........
        }
        function setText(text){
            //set the text in the text component to the text argument
            //this may be HTML formatted text
            ........
        }
    }

The two functions, getText and setText must be written to the specifications of the 3rd party component, note that if they will return XML(HTML) formatted text that the RapidSpellWebLauncher property IgnoreXML should be set to true, otherwise the XML tags will be spell checked. In this example the interface will be interfacing with a regular HTML <textarea> in which the text contained is accessed using the format
document.formName.textAreaName.value
 getText and setText can then be written as;
        function getText(){
            return eval('document.form1.'+this.tbName+'.value');
        }
        function setText(text){
            eval('document.form1.'+this.tbName+'.value = text') ;
        }
which dynamically accesses the text box named in the this.tbName variable. When RapidSpell runs it instantiates an object of type RSCustomInterface using the Javascript line
var interfaceObjectName = new RSCustomInterface(_textComponentName);
where _textComponentName is specified by the property TextComponentName in RapidSpellWebLauncher.

For Html text boxes the Javascript text access method (how you get the innerHTML out of the text box) is dependant on the vendor, however it is usually easy to identify - Html text boxes tend to work by setting the 'design mode' to true on either, Iframe body tags, div tags or span tags. To identify your vendors method, run a 'view-source' in the browser, and look for an Iframe, div or span, and see if design mode is set on for the element. For Html text boxes the inner Html (which is what is required by getText and setText), is accessed through the innerHTML property, eg; document.all['mySpanTag'].innerHTML.

The full code, for a simple text box custom interface is;

<%@ Page Language="C#" Debug="true"%>
<%@ Register TagPrefix="RapidSpellWeb" Namespace="Keyoti.RapidSpell"
Assembly="Keyoti.RapidSpellWeb" %>
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML//EN">
<HTML>
    <HEAD>
        <script>
            function RSCustomInterface(tbElementName){
                this.tbName = tbElementName;
                this.getText = getText;
                this.setText = setText;
                function getText(){
                    return eval('document.myForm.'+this.tbName+'.value');
                }
                function setText(text){
                    eval('document.myForm.'+this.tbName+'.value = text') ;
                }
            }
        </script>
    </HEAD>
<BODY>
    <form runat=server>
        <textarea ID='tA'></textarea>
        <br>
        <RapidSpellWeb:RapidSpellWebLauncher id="rapidSpellWebLauncher"
runat="server"
                TextComponentName="tA"
                Mode="popup"
                TextComponentInterface="Custom"
                IgnoreXML="true"
                RapidSpellWebPage="RapidSpellCheckerPopUp.aspx">
        </RapidSpellWeb:RapidSpellWebLauncher>
    </form>
</BODY>
</HTML>


RapidSpell Web .NET Documentation: Multiple As You Type Checking

Multiple As You Type Checking

All that is required to check multiple text boxes in As You Type mode is to have a RapidSpellInline control with CheckAsYouType set to True for each RapidSpellInlineTextBox on your page. If you would like to hide each RapidSpellInline button set ShowButton to False.

Code Example

Page containing the RapidSpellInline and RapidSpellInlineTextBox controls

<%@ Page Language="VB" AutoEventWireup="false" %>
<%@ Register Assembly="Keyoti.RapidSpellWeb.ASP.NETv2" Namespace="Keyoti.RapidSpell" TagPrefix="RapidSpellWeb" %>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" >
<body>
    <form id="form1" runat="server">
    <div>
        <RapidSpellWeb:RapidSpellWInline ID="RapidSpellWInline1" runat="server" CheckAsYouType="True"
            RapidSpellWInlineHelperPage="helper.aspx" ShowButton="False" Style="z-index: 100;
            left: 386px; position: absolute; top: 12px" TextComponentID="RapidSpellWInlineTextBox1">
<Button type="button" BorderStyle="NotSet" BorderWidth="" BorderColor="" BackColor="" Enabled="True" Width="" CssClass="" TabIndex="0" ForeColor="" Height="" Value="Spell Check" ID="ctl00" runat="server"></Button>
</RapidSpellWeb:RapidSpellWInline>
        <RapidSpellWeb:RapidSpellWInline ID="RapidSpellWInline2" runat="server" CheckAsYouType="True"
            RapidSpellWInlineHelperPage="helper.aspx" ShowButton="False" Style="z-index: 101;
            left: 385px; position: absolute; top: 111px" TextComponentID="RapidSpellWInlineTextBox2">
<Button type="button" BorderStyle="NotSet" BorderWidth="" BorderColor="" BackColor="" Enabled="True" Width="" CssClass="" TabIndex="0" ForeColor="" Height="" Value="Spell Check" ID="ctl00" runat="server"></Button>
</RapidSpellWeb:RapidSpellWInline>
        <RapidSpellWeb:RapidSpellWInlineTextBox ID="RapidSpellWInlineTextBox1" runat="server"
            Style="z-index: 102; left: 389px; position: absolute; top: 60px" Width="359px"></RapidSpellWeb:RapidSpellWInlineTextBox>
        <RapidSpellWeb:RapidSpellWInlineTextBox ID="RapidSpellWInlineTextBox2" runat="server"
            Style="z-index: 104; left: 388px; position: absolute; top: 145px" Width="383px"></RapidSpellWeb:RapidSpellWInlineTextBox>

    </div>
    </form>
</body>
</html>


RapidSpell Web .NET Documentation: Spell Checking Multiple Text Boxes With One Button

Spell Checking Multiple Text Boxes With One Button

It is possible to check more than one text box on a Web Form with one button, using the RapidSpellWebMultiple control.

Code Example Multiple Text Boxes, One Button

Page containing the RapidSpellWebLauncher and RapidSpellWebMultiple controls

<%@ Page language="c#" AutoEventWireup="false" %>
<%@ Register TagPrefix="rapidspellweb" Namespace="Keyoti.RapidSpell"
Assembly="Keyoti.RapidSpellWeb" %>
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" >
<HTML>
    <body MS_POSITIONING="GridLayout">
        <form id="MultipleTextBoxes" method="post" runat="server">

            <asp:TextBox id="TextBox1" style="Z-INDEX: 100; LEFT: 21px;
POSITION: absolute; TOP: 65px" runat="server" TextMode="MultiLine" Width="404px"
Height="127px" Columns="40" Rows="4">This example demenstrates</asp:TextBox>

            <asp:Label id="Label1" style="Z-INDEX: 109; LEFT: 21px;
POSITION: absolute; TOP: 31px" runat="server" Font-Names="Arial">Multiple text
box checking with one button</asp:Label>

            <asp:TextBox id="TextBox2" style="Z-INDEX: 101; LEFT: 21px;
POSITION: absolute; TOP: 201px" runat="server" TextMode="MultiLine" Width="404px"
Height="127px" Columns="40" Rows="4">multiple textbox checking</asp:TextBox>

            <asp:TextBox id="TextBox3" style="Z-INDEX: 103; LEFT: 21px;
POSITION: absolute; TOP: 335px" runat="server" Width="259px" Columns="40">Any
combination of text boexs on a form</asp:TextBox>

            <rapidspellweb:RapidSpellWebLauncher
id="RapidSpellWebLauncher2" style="Z-INDEX: 104; LEFT: 435px; POSITION: absolute;
TOP: 213px" runat="server" TextComponentName="TextBox2"
RapidSpellWebPage="PopUp.aspx" CreatePopUpWindow="False"
PopUpWindowName="RapidSpellWebMultiple1_PopUpWin" ShowFinishedMessage="False"
ShowNoErrorsMessage="False" FinishedListener="RapidSpellWebMultiple1_NotifyDone"
ShowButton="False" RSMultipleID="RapidSpellWebMultiple1">
            </rapidspellweb:RapidSpellWebLauncher>

            <rapidspellweb:RapidSpellWebLauncher
id="RapidSpellWebLauncher3" style="Z-INDEX: 105; LEFT: 294px; POSITION: absolute;
TOP: 339px" runat="server" TextComponentName="TextBox3"
RapidSpellWebPage="PopUp.aspx" CreatePopUpWindow="False"
PopUpWindowName="RapidSpellWebMultiple1_PopUpWin" ShowFinishedMessage="False"
ShowNoErrorsMessage="False" FinishedListener="RapidSpellWebMultiple1_NotifyDone"
ShowButton="False" RSMultipleID="RapidSpellWebMultiple1">
            </rapidspellweb:RapidSpellWebLauncher>

            <rapidspellweb:RapidSpellWebLauncher
id="RapidSpellWebLauncher1" style="Z-INDEX: 107; LEFT: 438px; POSITION: absolute;
TOP: 75px" runat="server" TextComponentName="TextBox1"
RapidSpellWebPage="PopUp.aspx" CreatePopUpWindow="False"
PopUpWindowName="RapidSpellWebMultiple1_PopUpWin" ShowFinishedMessage="False"
ShowNoErrorsMessage="False" FinishedListener="RapidSpellWebMultiple1_NotifyDone"
ShowButton="False" RSMultipleID="RapidSpellWebMultiple1">
            </rapidspellweb:RapidSpellWebLauncher>

            <rapidspellweb:RapidSpellWebMultiple
id="RapidSpellWebMultiple1" style="Z-INDEX: 106; LEFT: 21px; POSITION: absolute;
TOP: 369px" runat="server"
RapidSpellWebLaunchers="RapidSpellWebLauncher1,RapidSpellWebLauncher2,RapidSpellWebLauncher3">
            </rapidspellweb:RapidSpellWebMultiple>

        </form>
    </body>
</HTML>

This code functions by hiding the buttons usually displayed by the RapidSpellWebLauncher control. The RapidSpellWebMultiple control is used to link all the RapidSpellWebLauncher/RapidSpellWInline controls, it renders as a button (or image) on the page and controls the firing of the hidden RapidSpellWebLauncher/RapidSpellWInline controls. The RapidSpellWebLaunchers property in RapidSpellWebMultiple is set to the IDs of the RapidSpellWebLauncher/RapidSpellWInline controls, comma delimited.


RapidSpell Web .NET Documentation: RapidSpellWebLauncher In A User Control

RapidSpellWebLauncher In A User Control

It may be desirable to package RapidSpellWebLauncher and other controls together into a single User Control, this makes component reuse even easier. For example a User Control could be created that contains RapidSpell Web and a text box, which would form a logical development unit.

Code Example User Control

UserControl.ascx (the user control)

<%@ Control Language="c#" AutoEventWireup="true" TargetSchema="http://
schemas.microsoft.com/intellisense/ie5"%>
<%@ Register TagPrefix="RapidSpellWeb" Namespace="Keyoti.RapidSpell"
Assembly="Keyoti.RapidSpellWeb" %>

<TABLE id="Table1" style="WIDTH: 499px; HEIGHT: 229px" cellSpacing="1"
cellPadding="2" width="499" align="left" border="0">
    <tr>
        <td colSpan="2">
<asp:TextBox id="TextBox1" runat="server" TextMode="MultiLine" Height="171px"
Width="363px" Columns="40" Rows="4"></asp:TextBox>
<br>
<RapidSpellWeb:RapidSpellWebLauncher id="RapidSpellWebLauncher1" runat="server"
TextComponentName="TextBox1" RapidSpellWebPage="PopUp.aspx">
</RapidSpellWeb:RapidSpellWebLauncher>
    </td></tr>
</TABLE>

This user control is now easily used on a regular aspx form.

<%@ Page Language="C#" %>
<%@ Register TagPrefix="Acme" TagName="SpellBox" Src="UserControl.ascx" %>

<html>
<body style="font: 10pt verdana">

    <h3>Html Text Box Spelling Control page</h3>
    <form id="frmMenu" runat=server>
        <Acme:SpellBox runat="server"/>
    </form>

</body>
</html>

The result is a form unit that is easily reusable.


RapidSpell Web .NET Documentation: SSL Usage

SSL Usage

RapidSpell Web is compatible with SSL web-sites. To use the controls over SSL the SSLFriendly property must be set to true in the RapidSpellWeb, RapidSpellWebLauncher and RapidSpellWInline controls - this requires a file called 'blank.html' in the Keyoti_RapidSpell_Web_Common virtual directory.

Code Example SSL Usage

Page containing the RapidSpellWeb control.

<%@ Page Language="C#" debug="false" validateRequest=false %>
<%@ Register TagPrefix="RapidSpellWeb" Namespace="Keyoti.RapidSpell"
Assembly="Keyoti.RapidSpellWeb" %>
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML//EN">
<html>
<title>Spell Check</title>
<body>

<RapidSpellWeb:RapidSpellWeb id="rapidSpellWeb" runat="server" SSLFriendly=true/>

</body>
</html>


RapidSpell Web .NET Documentation: Modal Dialog Usage

Modal Dialog Usage

When RapidSpell Web is used in popup mode the popup is by default non modal (user focus can go anywhere). To make the popup modal (user focus is limited to the spell checker) set the Modal property in RapidSpellWebLauncher to true.


RapidSpell Web .NET Documentation: PostBack To Server On Spell Check Finish

PostBack To Server On Spell Check Finish

RapidSpellWebLauncher and RapidSpellWebMultiple can post-back to the server when the spell check has completed, making it possible to read the updated text box on the server after corrections have been made. To enable this behavior set the PostBackOnFinish property to true; It is then appropriate to set a server-side listener:

Setting Server Side Finish Event in C#

RapidSpellWebMultiple1.Finish += new EventHandler(RapidSpellWebMultiple1_Finish);
....
private void RapidSpellWebMultiple1_Finish(object sender, System.EventArgs e)
{
    ....
}

Setting Server Side Finish Event in VB.NET

Private Sub SpellCheckFinished(ByVal sender As Object, ByVal e As EventArgs)
Handles RapidSpellWebMultiple1.Finish
   ....
End Sub

The RapidSpellWebLauncher control will post back to the server whenever spell check finishes (either through completion or cancellation), but will NOT post back when used in conjunction with RapidSpellWebMultiple.

The RapidSpellWebMultiple control will post back to the server when checking of all text boxes has been completed or checking has been cancelled.


RapidSpell Web .NET Documentation: Spell Checking DataGrid/List Controls

Spell Checking DataGrid/List Controls

This is as simple as multiple text box checking. To begin with place a RapidSpellWebLauncher or RapidSpellWInline control in the item template or edit item template (where ever the text box is). Configure the Control's properties as usual. If the spell checker is in the edit item template then you're done, if however the spell checker is in the item template then you probably want to use RapidSpellWebMultiple to check all textboxes at once. To do this add a RapidSpellWebMultiple, and set the RapidSpellWebLaunchers property to the ID of the DataGrid. This will cause RapidSpellWebMultiple to launch all RapidSpellWebLauncher or RapidSpellWInline controls it finds inside the control.

Code Example

<form id="DataGrid" method="post" runat="server">
            <asp:DataGrid id="MyDataGrid" style="Z-INDEX: 101; LEFT: 21px;
POSITION: absolute; TOP: 67px" runat="server" Width="521px" BorderColor="#999999"
BorderStyle="None" BorderWidth="1px" BackColor="White" CellPadding="3"
GridLines="Vertical" AutoGenerateColumns="false"
OnItemCreated="DataGrid_ItemCreated"
            >
                <Columns>
                    <asp:TemplateColumn HeaderText="Favourite Films">
                        <ItemTemplate>
                            <asp:TextBox id=TextBox1 runat="server"
Text='<%# DataBinder.Eval(Container.DataItem, "Favourite Films") %>'
Height="43px" TextMode="MultiLine" Rows="5" Columns="40" >
                            </asp:TextBox><BR>
                            <RapidSpellWeb:RapidSpellWebLauncher
id="RapidSpellWebLauncher" RSMultipleID="RapidSpellWebMultiple1" runat="server"
RapidSpellWebPage="PopUp.aspx" TextComponentName="TextBox1"
ShowButton="false"></RapidSpellWeb:RapidSpellWebLauncher>
                        </ItemTemplate>
                    </asp:TemplateColumn>
                </Columns>
            </asp:DataGrid>

    <rapidspellweb:RapidSpellWebMultiple id="RapidSpellWebMultiple1" style="ZINDEX:
105; LEFT: 722px; POSITION: absolute; TOP: 599px"
runat="server" RapidSpellWebLaunchers="MyDataGrid" ShowFinishedMessage="False"></
rapidspellweb:RapidSpellWebMultiple>
        </form>


RapidSpell Web .NET Documentation: Validators (Spell Checking Before Saving)

Validators (Spell Checking Before Saving)

It maybe desirable to have the spell checker check the contents of text boxes on the form for errors before proceeding. RapidSpellWebLauncher and RapidSpellWInline can act as Validator controls, in a manner very similar to the standard ASP.NET validators. When they are enabled as validators (by setting the Validator property to true) they will warn the user about any errors and demand that spell checking is at least performed. The user can leave spelling 'errors' in the text box (because some words, such as names, are not known by the spell checker, but are valid), but they must at least run the spell check if there are errors.

Set the AutoLaunchWhenTextInvalid property to true to have the spell check run automatically after the page posts back - note AutoLaunchWhenTextInvalid may not work with RapidSpellWebLauncher if popup blockers are being used in the visitors browser, since most popup blockers will block any popups that they cannot determine were caused by the user directly - RapidSpellWInline doesn't use popups and doesn't suffer from this.

Code Example

<form id="Form1" method="post" runat="server">
    <asp:textbox id="TextBox1" style="Z-INDEX: 100; LEFT: 123px; POSITION:
absolute; TOP: 115px" runat="server" Font-Size="11pt" Font-
Names="Tahoma,Verdana,Arial" Width="624px" Height="270px"
TextMode="MultiLine">This demonstratess how to use RapidSpellWInline as a
validator.</asp:textbox>

    <asp:button id="Button1" style="Z-INDEX: 103; LEFT: 579px; POSITION:
absolute; TOP: 401px" runat="server"
            Text="Save"></asp:button>

    <asp:validationsummary id="ValidationSummary1" style="Z-INDEX: 104; LEFT:
101px; POSITION: absolute; TOP: 458px" runat="server" Font-Size="9pt" Font-
Names="Arial"></asp:validationsummary>

    <RAPIDSPELLWEB:RAPIDSPELLWINLINE id="RapidSpellWInline1" style="Z-INDEX:
105; LEFT: 637px; POSITION: absolute; TOP: 401px" runat="server"
ButtonTextSpellMode="Edit" AutoLaunchWhenTextInvalid="True"
RapidSpellWInlineHelperPage="../rswihelper.aspx" TextComponentID="TextBox1"
Validator="True"></RAPIDSPELLWEB:RAPIDSPELLWINLINE>

</form>

In this example the user is queried to run a spell check if there are spelling errors in the box when the form is submitted.


RapidSpell Web .NET Documentation: Dynamic Control Creation

Dynamic Control Creation

It's perfectly acceptable to create any RapidSpell control in the Page_Load handler of a page, however care must be taken when adding the RapidSpell control to add it to the Form control (or any control beneath the Form) and not the page directly. This is because scripts registered by the control will not be added to the page if the control is outside the form.

Code Example (VB)

Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs)
Handles MyBase.Load
    Dim rs As New Keyoti.RapidSpell.RapidSpellWebLauncher
    rs.TextComponentName = "textBox1"
    rs.RapidSpellWebPage = "popup.aspx"
    FindControl("Form1").Controls.Add(rs)
End Sub


RapidSpell Web .NET Documentation: AJAX Based Programmatic String Checking (RapidSpellCheckerClient)

AJAX Based Programmatic String Checking (RapidSpellCheckerClient)

The RapidSpellCheckerClient control can be used to programmatically check strings, in Javascript. If the control has been added to the page it will emit the required Javascript to setup an instance for use.

Code Example: Obtaining An Instance

//Perform this anytime AFTER the page has loaded
var rsc = <%= RapidSpellCheckerClient1.ClientSideObject %>;

where RapidSpellCheckerClient1 is the Control ID.

Code Example: Asynchronously Spell Checking A String

Generally we recommend that spell checking be performed asynchronously, as this allows the UI to respond to user events. Asynchronous functions are non blocking, so the return is handled by a callback function. Using asynchronous functions can be awkward, so we also provide a synchronous version, below. This asynchronous method is available in browsers that support XmlHttpRequst (eg. IE, FF...) and also in older browsers which don't (eg Opera 6).

rsc.Check(textToCheck, display);

Display is the name of a function that will handle the call back and process the result. See below.

Code Example: Synchronously Spell Checking A String

This form is used to run the spell check synchronously. This will cause the UI to block while the browser waits for the response. Under good network conditions this should be acceptable. One warning about this synchronous method is that it is only available in browsers capable of XmlHttpRequest (AJAX calls). If the browser cannot process these then the asynchronous method should be used instead.

var result = rsc.Check(textToCheck);

Code Example: Processing The Result

The result is an object with the following properties.

originalText //The text that was spell checker
numberOfErrors //The number of spelling errors
errorPositionArray //An array of errors, with their positions and suggestions

errorPositionArray[n].start //Where the spelling error is in the original text
errorPositionArray[n].end //Where the spelling error ends
errorPositionArray[n].suggestions //Simple array of string suggestions

The result object, which is returned by Check in synchronous calls, or passed to the call-back function in asynchronous calls, can then be processed.

function display(result){
    var resultTB = document.getElementById("resultTB");

    resultTB.value = '"' + result.originalText + "\" has " + result.numberOfErrors + " errors\r\n\r\n";
    for(var e = 0; e<result.errorPositionArray.length; e++){
        resultTB.value += "Error "+e+": " + result.errorPositionArray[e].word + "\r\n";
        resultTB.value += "\tstart:"+result.errorPositionArray[e].start+"\r\n";
        resultTB.value += "\tend:"+result.errorPositionArray[e].end+"\r\n";
        resultTB.value += "\tsuggestions: " + (result.errorPositionArray[e].suggestions.length==0?"none":"") + "\r\n";
        for(var s = 0; s<result.errorPositionArray[e].suggestions.length; s++){
            resultTB.value += "\t\t" + result.errorPositionArray[e].suggestions[s] + "\r\n";
        }
        resultTB.value += "\r\n";
    }
}

Code Example: Add Word To User Dictionary

Adding to the user dictionary is always asynchronous and requires the UserDictionaryFile property to be set to a file path on the server where the dictionary will be stored.

rsc.AddWord(wordToAdd);

Code Example: Setting Properties

Spell check options can be set on the server through the Control properties or on the client side through the Javascript functions.

rsc.setParameterValue(optionName, value);

where optionName is the name as specified exactly in the Control serverside properties. Similarly property values can be obtained through

rsc.getParameterValue(optionName);

Please consult the product demos for a complete example, plus how to access parameter names programmatically.


RapidSpell Web .NET Documentation: Client Side API

Client Side API For RapidSpellWInline, RapidSpellWebLauncher & RapidSpellWInlineTextBox

The controls provide client-side objects which can be used to work with them in Javascript.

RapidSpellWInline

To access the Javascript object, add

var inline = <%= RapidSpellWInline1.ClientSideObject %>;

to the page inside a Javascript function (note, don't allow this to be called as the page loads, since it will probably appear before the control has rendered and therefore not be valid yet). This will set your 'inline' variable to the object instance, which can then be used to call the following;

textBoxID | - the ID of the text box being worked with
OnSpellButtonClicked() | - starts the spell check
tbInterface | - holds an instance of the TextComponentInterface, which provides getText()/setText() methods to work with the text in the text box
buttonID | - the ID of the button that the spell checker rendered
getParameterValue(parameterName) | - gets the value of the spell check parameter
setParameterValue(parameterName, value) - gets the value of the spell check parameter
- parameter names match exactly the control's property names (that control the spell check behavior), eg; UserDictionaryFile, DictFile, SuggestionsMethod, LanguageParser, SeparateHyphenWords, V2Parser, SuggestSplitWords, IncludeUserDictionaryInSuggestions, WarnDuplicates, IgnoreWordsWithDigits, CheckCompoundWords, LookIntoHyphenatedText, IgnoreXML, IgnoreCapitalizedWords, ConsiderationRange, IgnoreURLsAndEmailAddresses, AllowMixedCase.
showNoSpellingErrorsMesg | - true/false; whether to show the 'no errors' message
showAddMenuItem | - true/false; whether to show the add menu item
noSpellingErrorsText | - text shown when no errors are found
enterEditModeWhenNoErrors | - true/false; whether to auto switch back to edit mode when in static mode and no errors are left.
noSuggestionsText | - text used in 'no suggestions' menu item
ignoreAllText | - text used in 'ignore all' menu item.
showChangeAllItem | - true/false; whether to show the 'change all' menu item
changeAllText | - text used in 'change all' menu item (see above)
addText | - text used in 'add' menu item
editText | - text used in 'edit' menu item
removeDuplicateText | - text used in 'remove duplicate word' menu item
buttonTextSpellChecking | - button text during spell checking activation
buttonTextSpellMode | - button text during spell mode
buttonText | - button text during edit mode
changeButtonTextWithState | - true/false; whether to change the button state/text when spell checking
responseTimeout | - seconds before the spell check request times out
responseTimeoutMessage | - message shown to user after timeout
doubleClickSwitchesMode | - whether double clicking switches mode during static check
ignoreXML | - whether XML/HTML is to be ignored

RapidSpellWebLauncher

To access the Javascript object, add

var launcher = <%= RapidSpellWebLauncher1.ClientSideObject %>;

to the page inside a Javascript function (note, don't allow this to be called as the page loads, since it will probably appear before the control has rendered and therefore not be valid yet). This will set your 'launcher' variable to the object instance, which can then be used to call the following;

OnSpellButtonClicked() | - starts the spell check
tbInterface | - holds an instance of the TextComponentInterface, which provides getText()/setText() methods to work with the text in the text box
getParameterValue(parameterName) | - gets the value of the spell check parameter
setParameterValue(parameterName, value) | - gets the value of the spell check parameter
- parameter names match exactly the control's property names (that control the spell check behavior), eg; UserDictionaryFile, DictFile, SuggestionsMethod, LanguageParser, SeparateHyphenWords, V2Parser, SuggestSplitWords, IncludeUserDictionaryInSuggestions, WarnDuplicates, IgnoreWordsWithDigits, CheckCompoundWords, LookIntoHyphenatedText, IgnoreXML, IgnoreCapitalizedWords, ConsiderationRange, IgnoreURLsAndEmailAddresses, AllowMixedCase.

RapidSpellWInlineTextBox

To access the Javascript object, add

var inlineTB = <%= RapidSpellWInlineTextBox1.ClientSideObject %>;

to the page inside a Javascript function (note, don't allow this to be called as the page loads, since it will probably appear before the control has rendered and therefore not be valid yet). This will set your 'inlineTB' variable to the object instance, which can then be used to call the following;

GetText() | - gets the text in the textbox
SetText(text) | - sets the text in the textbox
OnKeyDown | - function to be called on event (see example below)
OnKeyUp | - function to be called on event (see example below)
OnKeyPress | - function to be called on event (see example below)
OnCorrection | - function to be called on event (see example below)
OnPaste | - function to be called on event (see example below)
OnContextMenu | - function to be called on event (see example below)
OnBlur | - function to be called on event (see example below)
OnFocus | - function to be called on event (see example below)
OnMouseDown | - function to be called on event (see example below)
OnMouseUp | - function to be called on event (see example below)
GetNumberOfErrors() | - gets the number of errors highlighted in the textbox
Focus() | - gives user focus to the text box
SetDisabled(disabled) | - disables the textbox
Select() | - selects the entire text

Javascript Example

This example works with RapidSpellWInline and RapidSpellWInlineTextBox to show all text box events, start the spell checker from a JS call, block specified characters from being typed and focus on demand.

<%@ Page language="c#" AutoEventWireup="false" %>
<%@ Register TagPrefix="rapidspellweb" Namespace="Keyoti.RapidSpell"
Assembly="Keyoti.RapidSpellWeb.ASP.NETv2" %>
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" >
<HTML>
    <HEAD>
        <script type="text/javascript">
            var inline;
            var tb1;
            var ot1;
            function RunSpell(){
                inline.OnSpellButtonClicked();
            }

            //called automatically when the textboxes have loaded.
            function RS_OnTextBoxesInitialized(){
                tb1 = <%= RapidSpellWInlineTextBox1.ClientSideObject %>;
                ot1 = document.getElementById('t1');

                inline = <%= RapidSpellWInline1.ClientSideObject %>;
                update();

                tb1.OnKeyDown = OnEvent;
                tb1.OnKeyUp = OnEvent;
                tb1.OnKeyPress = OnEvent;
                tb1.OnCorrection = OnEvent;
                tb1.OnPaste = OnEvent;
                tb1.OnContextMenu = OnEvent;
                tb1.OnBlur = OnEvent;
                tb1.OnFocus = OnEvent;
                tb1.OnMouseDown = OnEvent;
                tb1.OnMouseUp = OnEvent;
            }

            function dofocus(){
                tb1.Focus();
            }

            function update(){
                ot1.value = tb1.GetText();
            }

            function resetText(){
                tb1.SetText("The text has been reset.");
            }

            function OnEvent(source, e){

                if(e.type=="keypress"){
                    var chr;
                    if(e.charCode)//MOZ
                        chr = e.charCode;
                    else
                        chr = e.keyCode;

                    var blockChar = document.getElementById('blockChar').value;
                    if(blockChar == String.fromCharCode( chr ) ){

                        e.returnValue = false;
                        if(e.preventDefault){
                            e.preventDefault();
                            e.cancelBubble = true;
                        }
                    }

                }
                if(e!=null){
                    ot1.value = e.type+"\r\n" + ot1.value;

                    var mesg;
                    if(e.type=='correction'){
                        if( e.replacement != e.errorWord)
                            mesg = e.errorWord+" was changed to "+e.replacement+", ";
                        else
                            mesg = e.errorWord+" was ignored, ";

                        ot1.value = mesg+ "errors remaining = "+tb1.GetNumberOfErrors()+"\r\n" + ot1.value;
                    }
                }
            }
    </script>
</HEAD>
<body>
    <form runat="server">
        <RAPIDSPELLWEB:RAPIDSPELLWINLINETEXTBOX id="RapidSpellWInlineTextBox1" runat="server" ClientFilesFolder="/Keyoti_RapidSpell_Web_Common/"
            Font-Size="18pt" Font-Bold="True" Width="605px" Height="423px" TextMode="MultiLine">Thiss is a RapidSpellWInlineTextBox</RAPIDSPELLWEB:RAPIDSPELLWINLINETEXTBOX>
        <br>
        <input onclick="update()" type="button" value="Send text box text to text area">
        <br>
        <input onclick="resetText()" type="button" value="Reset text box text">
        <br>
        <input onclick="dofocus()" type="button" value="Get focus">
        <br>
        Block this character -> <input id="blockChar" type="text" size="4" value="+">
        <br>
        <input onclick="RunSpell()" type="button" value="Start spell">
        <br>
        <br>
        <textarea id="t1" rows="10" cols="40"></textarea>
        <br>
        <rapidspellweb:rapidspellwinline id="RapidSpellWInline1" runat="server" RapidSpellWInlineHelperPage="rswihelper.aspx"
            TextComponentID="RapidSpellWInlineTextBox1" ButtonText="Inline Ctrl">
            <Button BorderWidth="" BackColor="" ForeColor="" Height="" Width="" Enabled="True" BorderColor=""
                CssClass="" type="button" value="Inline Ctrl" ID="RapidSpellWInline1_RapidSpellWInline1__ctl0"></Button>
        </rapidspellweb:rapidspellwinline>
    </form>
</body>
</HTML>


RapidSpell Web .NET Documentation: Client Side Events

Client Side Events

RapidSpell Web provides an interface to the various events and functions present on the client side in Javascript (ECMAscript). This allows further behavior customization when the spell checker is used in popup mode. The current highlights are;

Notification of the spell check finished event
Notification that the user has corrected a word
Exposure of the Javascript function that launches the spell checking

FinishedListener - Finished Event

It is possible to determine when spell checking has finished (in pop up mode) by using the FinishedListener property of RapidSpellWebLauncher. This property can be set to the name of a JavaScript function in the main form, which will be called from the pop up when the user finishes checking the document (either by completing the check, closing the window, or by clicking the 'Finish' button). The function must not expect arguments, unless the FinishedListenerInformState is set true and be with in the scope of the whole page (if FinishedListenerInformState=true then the argument is true if spell check completed, false if cancelled).

For example;

...............
<script>
    function notifyDone(){
        alert('Finished event captured.');
    }
</script>
...............
<RapidSpellWeb:RapidSpellWebLauncher id="rapidSpellWebLauncher" runat="server"
    TextComponentName="myForm.sourceTextBox"
    TextComponentInterface="Standard"
    FinishedListener="notifyDone"
    Mode="popup"
    SeparateHyphenWords=true
    RapidSpellWebPage="RapidSpellCheckerPopUp.aspx"/>
...............

CorrectionNotifyListener - User Correction Event

To be notified every time that the user has corrected a word, set the CorrectionNotifyListener property of RapidSpellWebLauncher to the name part of a Javascript function present on the main page.

For example;

...............
<script>
    function OnCorrection(startIndex, oldWord, newWord){
        alert('Correction occurred to word at index '+startIndex+' old word
was '+oldWord+' replacement text is '+newWord);
    }
</script>
...............
<RapidSpellWeb:RapidSpellWebLauncher id="rapidSpellWebLauncher" runat="server"
    TextComponentName="myForm.sourceTextBox"
    TextComponentInterface="Standard"
    CorrectionNotifyListener="OnCorrection"
    Mode="popup"
    RapidSpellWebPage="RapidSpellCheckerPopUp.aspx"/>
...............


RapidSpell Web .NET Documentation: Server Side Non-GUI Spell Checker

Server Side Non-GUI Spell Checker

The RapidSpellChecker class is of particular use in non-GUI scenarios, however it can also be used with custom spell checker interfaces. Below is a very simple excerpt of how this component can be used, please consult the API documentation for further detail.

Code Example

C#
.........
    RapidSpellChecker c = new RapidSpellChecker("...license key...");
    BadWord badWord;
    ArrayList suggestions;

    //check some text.
    c.Check("This is sume text.");

    //iterate through all bad words in the text.
    while((badWord = c.NextBadWord())!=null){

        Console.WriteLine(badWord.GetWord() +
            "- is not spelt correctly. Suggestions:");

        try{
            //get suggestions for the current bad word.
            suggestions = c.FindSuggestions();

            //display all suggestions.
            for(int i=0; i<suggestions.Count; i++){
                Console.WriteLine(suggestions[i]);
            }

            //change the bad word in the text with "replacement".
            c.ChangeBadWord("replacement");

            } catch (NoCurrentBadWordException e){
                Console.WriteLine(e);
            }

    }
    Console.WriteLine(c.GetAmendedText());
.........

VB.NET

imports Microsoft.VisualBasic
imports System
Imports System.Collections
Imports Keyoti.RapidSpell

........

Dim c As RapidSpellChecker = New RapidSpellChecker("...license key...")

Dim badWord As BadWord

Dim suggestions As ArrayList

 'check some text.

c.Check("This is sume text.")

 'iterate through all bad words in the text.

badWord = c.NextBadWord()

while Not badWord Is Nothing

Console.WriteLine((badWord.GetWord + "- is not spelt correctly.
Suggestions:"))

Try

 'get suggestions for the current bad word.

suggestions = c.FindSuggestions

 'display all suggestions.

Dim i As Integer = 0

Do While (i < suggestions.Count)

Console.WriteLine(suggestions(i))

i = (i + 1)

Loop

 'change the bad word in the text with "replacement".

c.ChangeBadWord("replacement")

badWord = c.NextBadWord()

Catch e As NoCurrentBadWordException

Console.WriteLine(e)

End Try

End while

Console.WriteLine(c.GetAmendedText)

.........


RapidSpell Web .NET Documentation: License Keys In Multi Server Development Environments

License Keys In Multi Server Development Environments

It is common practice to use multiple servers in the development of web applications, for example, an application may go through a lifecycle;

developer machines ("localhost") -> single development test server ("devServer") -> QA server ("qaServer") -> production server ("prodServer")

The current licensing system allows keys for "devServer", "qaServer" and "prodServer" if they are accessed through non local browsers (note; 'devServer' and 'qaServer' keys will be provided free), and since it is not acceptable to change the "LicenseKey" property in source code for each server we suggest using the web.config file. Since each server should have a unique web.config file, storing the license keys in there makes sense.

Store the license key in the web.config in the <appSettings> section (if it doesn't exist, create it after the system.web section).

Eg;

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
    <system.web>
        ...........
    </system.web>
    <appSettings>
        <add key="Keyoti-RapidSpellWeb-LicenseKey" value="XYZXYZXYZ"/>
    </appSettings>
</configuration>

The key must be named "Keyoti-RapidSpellWeb-LicenseKey" or "Keyoti-RapidSpellWeb- LicenseKey2" if there are two keys for the server.

Now set each server's web.config accordingly, remember web.config files should not be deployed to a server with an application (because they are unique).


RapidSpell Web .NET Documentation: Suggestions Algorithm

Suggestions Algorithm

It is possible to choose the algorithm used to find suggestions for spelling errors, there are two algorithms on offer, 'hashing' (default) and 'phonetic'. Each algorithm has it's own advantages and disadvantages;

Hashing (default): Very fast, roughly 40 times faster than the phonetic algorithm, works best on typographic errors and common spelling mistakes. Similar to most spell checker suggestions.

Phonetic (Sounds like, English only): Slower, works well with genuine attempts to spell correctly, works poorly with typographic errors. Can appear to produce wild results, although results do sound like the word in question. Does not work with non English languages. Uncommon.

It is recommended that you choose the suggestions algorithm in line with your target audience. The phonetic algorithm, although appearing worse overall, is more suited for people who have not spoken English for very long, e.g. non native English speakers and children.


RapidSpell Web .NET Documentation: Consideration Range

Consideration Range

The hashing suggestion algorithm is very fast because it accurately cuts down the list of words to look at as possible suggestions. The default consideration range is 80, which provides optimal speed with a loss of only a fraction of possible suggestions. It is possible to set the consideration range through the RapidSpellWebLauncher control and RapidSpellChecker class. The relationship between speed, number of suggestions and consideration range is shown below.


RapidSpell Web .NET Documentation: Switching Language

Switching Language

It is possible to set the text used in the GUIs to one of several preset languages. Setting the GuiLanguage property in RapidSpellWebLauncher/RapidSpellWInline will change the text of the button and also pass on that value automatically to RapidSpellWeb. To customize button or label text, set the button value or label text properties accordingly, this will override the GuiLanguage set text. In VisualStudio, if the property has been changed and you want to reset the text to default, simply delete the entire field, this will reset the text to default. Due to RapidSpellWeb receiving it's GuiLanguage setting from RapidSpellWebLauncher, it is not possible for changes to GuiLanguage to be reflected in the RapidSpellWeb Control's appearance at design-time, this is a design-time only limitation, at run time the text will be in the chosen language.

To switch the UI and dictionary language set the RapidSpellWebLauncher/RapidSpellWInline properties GuiLanguage, LanguageParser and DictFile in either code-behind or a script block on the form.

Code Example Language Switcher

Using a select box to select the UI language and dictionary.

<%@ Register TagPrefix="rapidspellweb" Namespace="Keyoti.RapidSpell"
Assembly="Keyoti.RapidSpellWeb" %>
<%@ Page language="c#" AutoEventWireup="true" %>
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" >
<HTML>
    <script language="C#" runat="server">
    void LanguageChanged(object sender, EventArgs e){
        switch (LanguageList.SelectedItem.Value){
            case "English":
                RapidSpellWebLauncher1.GuiLanguage =
Keyoti.RapidSpell.LanguageType.ENGLISH;
                RapidSpellWebLauncher1.LanguageParser =
Keyoti.RapidSpell.LanguageType.ENGLISH;
                //Set dictionary file path on server here
                RapidSpellWebLauncher1.DictFile = "path\to\english.dict";
            break;
            case "Español":
                RapidSpellWebLauncher1.GuiLanguage =
Keyoti.RapidSpell.LanguageType.SPANISH;
                RapidSpellWebLauncher1.LanguageParser =
Keyoti.RapidSpell.LanguageType.SPANISH;
                //Set dictionary file path on server here
                RapidSpellWebLauncher1.DictFile = "path\to\spanish.dict";
            break;
            case "Français":
                RapidSpellWebLauncher1.GuiLanguage =
Keyoti.RapidSpell.LanguageType.FRENCH;
                RapidSpellWebLauncher1.LanguageParser =
Keyoti.RapidSpell.LanguageType.FRENCH;
                //Set dictionary file path on server here
                RapidSpellWebLauncher1.DictFile = "path\to\french.dict";
            break;
        }
    }
    </script>
    <body>
        <form id="Form1" method="post" runat="server">
            <asp:textbox id="TextBox1" runat="server" Width="288px"
TextMode="MultiLine" Height="216px"></asp:textbox>
            <rapidspellweb:rapidspellweblauncher
                id="RapidSpellWebLauncher1"
                runat="server"
                LookIntoHyphenatedText="True"
                LanguageParser="ENGLISH"
                RapidSpellWebPage="RapidSpellCheckerPopUp.aspx"
                TextComponentName="TextBox1" >
            </rapidspellweb:rapidspellweblauncher>
            <asp:DropDownList OnSelectedIndexChanged="LanguageChanged"
AutoPostBack="True" id="LanguageList" runat="server" Width="178px">
                <asp:ListItem Text="English" Value="English" selected />
                <asp:ListItem Text="Español" Value="Español" />
                <asp:ListItem Text="Français" Value="Français" />
            </asp:DropDownList>
        </form>
    </body>
</HTML>


RapidSpell Web .NET Documentation: TextComponentName Property Details

TextComponentName Property Details

The TextComponentName property in RapidSpellWebLauncher is designed to accept identifying strings to identify text controls (or html elements) in a multitude of ways (it automatically detects the method used), it is important to understand how it works if you plan to set this property beyond simply the Control ID of the text box.

There are 3 ways to set this property;

1. Control ID - the simplest way is to set this property to the server-side ID of the control to be spell checked. This comes with a caveat; because server-side Control IDs need only be unique with-in a 'naming container' (eg. page, DataList, DataGrid) and because the Control must be found via the FindControl method (which searches the naming container that the RapidSpellWebLauncher control is in) it is only possible to use the Control ID to specify the text box if the text box Control and the RapidSpellWebLauncher are in the same naming container.

2. Control ClientID - setting the TextComponentName to the ClientID of the text control is a good way to firmly identify the text Control to be spell checked. To do this it is usually best to set the TextComponentName property in code-behind or with a data-bind using the ClientID of the text Control.
eg.

rapidSpellWebLauncher.TextComponentName = textBox1.ClientID

This method can also be used when referring to traditional Html elements (such as <textarea> or <input type=text>), in this case the ID attribute of the tag is used to identify the element.
eg.

<textarea ID="textbox1">This is my text box</textarea>
.....
rapidSpellWebLauncher.TextComponentName = "textbox1"

The only warning with this method is to remember (as per good asp.net practice) that the ClientID property of a control is not properly defined until run-time (when the page loads in the browser), therefore the TextComponentName property should be set at run-time, also.

3. Javascript formName.textBoxName - traditionally in client side coding the . style was used to identify form elements.
eg.

<form name="mainForm">
<textarea name="textbox1"></textarea>
</form>
.....
TextComponentName = "mainForm.textbox1"

This method can still be used with RapidSpell Web, however in more complex cases (unusual Control IDs, DataGrids etc) it can be hardest to use.

Note: if the 'Custom' Javascript interface is being used for a text box interface then the tbElementName argument in RSCustomInterface(tbElementName) will be set according to the method used to identify the text box, as detailed below for each method;

1. Control ID - tbElementName will be set to the ClientID of the Control given by TextComponentName.
2. Control ClientID - tbElementName will be set to TextComponentName.
3. Javascript formName.textBoxName - tbElementName will be set to TextComponentName.


RapidSpell Web .NET Documentation: Performance Tips

Performance Tips

Performance can be maximized very readily;

Dictionary Caching

If the application uses only one main dictionary (i.e. there are no Dict Files being switched at runtime) then enabling caching will improve performance by roughly 50 to 100% (the exact amount depends on the amount of text being checked), as this will remove the need to reload the dictionary for each request. To do this set CacheDictionary to true in the RapidSpellWeb and RapidSpellWInlineHelper controls.

Parser

If V2Parser is set true in RapidSpellWebLauncher/RapidSpellWInline then there is an automatic 10- 20% performance hit, this is because although the V2Parser is more accurate, it is also slightly slower. We recommend the use of the V2Parser, but if performance is an issue this can be set to false. Note that V2Parser=true is needed for URL/Email ignoring.

Dict Files

Dict Files do load quicker than DLL dictionaries, therefore they are worth using if Dictionary Caching is disabled.


RapidSpell Web .NET Documentation: CAS (Code Access Security)

CAS (Code Access Security)

<IPermission
class="AspNetHostingPermission"
version="1"
Level="Low"
/>

<IPermission
class="FileIOPermission"
version="1"
Unrestricted="true"
/>

Note this is roughly equivalent to High or Medium trust. Write FileIOPermission is only required if using user dictionaries, and can be restricted to the directory where the file is written, read permission is required if Dict File dictionaries are being used.


RapidSpell Web .NET Documentation: Conclusion

Conclusion

Thank you for using the RapidSpell Web component, we hope that you experience much success with it. Keyoti is committed to improving all of it's products and truly values customer feedback of any kind. If you would like to contact us about any of our products please do so through our web site.

http://www.keyoti.com/contact.html

We thrive on suggestions for components, if you have a component wish please don't hesitate to get in touch, it may be the next thing we develop!


RapidSpell Web .NET Documentation: Troubleshooting

Troubleshooting

If you do run in to trouble, please consult the following for some tried and tested solutions to issues that have occured with RapidSpell Web .NET - also our KB is online at http://keyoti.com/kb.

Problem
Solution
User dictionary; the 'Add' button changes to 'Adding...' when it is clicked and nothing else happens.
This is an indicator that an exception occured during the control's attempt to write to the user dictionary. Double check that the ASP_NET process has permission to write to the file and folder specified for the user dictionary file. If unsure, try changing the path. Remember, just setting the user dictionary path to a relative path (eg. "userdict.txt") will result in a path off the Windows system folder, not the current web app folder, use HttpRequest.MapPath to map a virtual path.
Visual Studio fails to build the project sometimes and reports errors such as BC31011: Unable to load referenced library.
Although theoretically it is not required, the simplest solution to this problem is adding the RapidSpell DLLs to the GAC on the development machine. This is a workaround to an issue with the development environment, not RapidSpell.

To do this use GACUTIL (comes with the .NET framework) in the same folder as your DLLs:
gacutil /i Keyoti.RapidSpellWeb.dll
gacutil /i Keyoti.RapidSpellMDict.dll
and then re-add the references to the project.

A license error is shown.
Ensure that the LicenseKey property in RapidSpellWeb (the control in the popup, usually) is set. Ensure that the key has no white space or newlines in it.
Ensure that the key is a 'deployment key' generated through our website, not an 'activation key'.
Ensure that the page on the server is up to date and has the key set (this is often wrongly assumed).

If you are having other problems, you are free to participate in our support forum, or email us at support@keyoti.com


Knowledge Base

Open in a new window


Support Forum

Open in a new window


API Documentation

Keyoti RapidSpell Web .NET Help Docs
API Documentation
API Documentation
Keyoti RapidSpell Web .NET
RapidSpell Web .NET Control
Namespaces
Namespace | Description
Keyoti.RapidSpell | The core namespace for RapidSpell. Main namespace
Keyoti.RapidSpell.ASMX |
Keyoti.RapidSpell.Event | The namespace for events. Events
Keyoti.RapidSpell.fastJSON |
Keyoti.RapidSpell.WCF |

Send comments on this topic to support@keyoti.com

2003-2015 Keyoti Inc.


Keyoti.RapidSpell Namespace

Keyoti.RapidSpell Namespace
API Documentation ► Keyoti.RapidSpell
Keyoti RapidSpell Web .NET
The core namespace for RapidSpell.

Main namespace

Types
All Types Classes Interfaces Enumerations Delegates
Icon | Type | Description
 | BadWord | Represents a mis-spelt word in the text.
 | RapidSpellChecker..::..ChangeWordEventHandler | Change word event handler delegate.
 | CheckerEngineAdapter | Abstract base implementation of ICheckerEngine, override chosen members for desired functionality.
 | ClientFilesLocation | Where the client files should be obtained from.
 | DictionaryCache | Cache of loaded dictionaries.
 | ICheckerEngine | Defines the interface required for a class to be used as a checker engine
 | LanguageType | Enumeration of language types.
 | Layout | The template used to layout the RapidSpellWeb control.
 | LayoutBuilder | RapidSpell layout builder
 | UserDictionary..::..ListChangedEventArgs | Event args for ListChanged event
 | UserDictionary..::..ListChangedEventHandler | Event handler
 | UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation | Types of operation
 | NoCurrentBadWordException | Thrown if NextBadWord has not been run first and found a mis-spelled word.
 | PreviewPaneStyle | The 'preview pane' style, this defines the style of the inner frame that shows the document preview during spell checking.
 | RapidSpellChecker | Spell checker engine, checks a text string for spelling errors and makes suggested corrections.
 | RapidSpellCheckerClient | Javascript (AJAX) based text oriented spell checker object.
 | RapidSpellWeb | RapidSpell Web Control, this control is the actual dialog spell checker, called from RapidSpellWebLauncher.
 | RapidSpellWebLauncher | RapidSpell Web Launcher Control, shows a button that launches the spell checker.
 | RapidSpellWebLauncherCollection | A collection of RapidSpellWebLauncher/RapidSpellWInline IDs
 | RapidSpellWebMultiple | RapidSpell Web Multiple Control, shows a button that launches multiple RapidSpellWebLaunchers/RapidSpellWInlines consecutively.
 | RapidSpellWInline | RapidSpell Web Inline Control, shows a button that launches the inline highlight spell checker.
 | RapidSpellWInlineHelper | Control that must sit alone on a form, actually performs the spell check on the server for the RapidSpellWInline control.
 | RapidSpellWInlineTextBox | TextBox control with ability to shows spelling errors as underlines while in 'edit mode'.
 | RSButton | RapidSpell button
 | RSGenericBuilder | RapidSpell HTML element builder
 | RSLabel | RapidSpell label
 | RSSelect | RapidSpell select box
 | RSText | RapidSpell text box
 | ScriptProvider | Provides script include tags.
 | SpellingDictionary |
 | RapidSpellChecker..::..State | State of the spell checker
 | UserDictionary..::..StorageLocation | Location options for storage
 | Suggestion | Represents a suggestion.
 | SuggestionMenuActivationType | Specifies ways users can activate the suggestions menu.
 | TextComponentInterfaceType | Enumeration of possible text box interface types.
 | RapidSpellWeb..::..TextEventArgs |
 | RapidSpellWeb..::..TextEventHandler |
 | UndoableStateEventArgs | Args for the events fired when words are ignored.
 | UserDictionary | Represents the UserDictionary
 | ValidatorNeedsTextEventArgs | Event args.
 | ValidatorNeedsTextEventHandler | Event handler delegate for the ValidatorNeedsText event.
 | WordAddedEventArgs | Args for the events fired when words are added to the user dictionary.
 | WordAddedEventHandler | Handler delegate
 | WordChangedEventArgs | Args for the events fired when words are changed.
 | WordChangedEventHandler | Handler delegate
 | WordIgnoredEventArgs | Args for the events fired when words are ignored.
 | WordIgnoredEventHandler | Handler delegate
 | WordOccurrence | Represents a word in the text.
 | WordRemovedEventArgs | Args for the events fired when words are removed from the user dictionary.
 | WordRemovedEventHandler | Handler delegate


BadWord Class

BadWord Class
API Documentation ► Keyoti.RapidSpell ► BadWord
Keyoti RapidSpell Web .NET
Represents a mis-spelt word in the text.
Declaration Syntax
C# Visual Basic Visual C++ F#
public class BadWord : WordOccurrence
Public Class BadWord
    Inherits WordOccurrence
public ref class BadWord : public WordOccurrence
type BadWord =
    class
        inherit WordOccurrence
    end
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BadWord(String, Int32, Int32) | Constructs a BadWord (REASON_SPELLING) instance.
 | BadWord(String, Int32, Int32, Int32) | Constructs a BadWord instance.
 | caretEnd | End of word (Inherited from WordOccurrence.)
 | caretStart | Start of word (Inherited from WordOccurrence.)
 | Clone()()()() | Clones this instance
 | EndPosition | Gets the position of the end of this word in the main text. (Inherited from WordOccurrence.)
 | Equals(Object) | See base. (Overrides Object.Equals(Object).)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetEndPosition()()()() | Gets the position of the end of this word in the main text. (Inherited from WordOccurrence.)
 | GetHashCode()()()() | See base (Overrides Object.GetHashCode()()()().)
 | GetReason()()()() | Gets the reason that this is a bad word.
 | GetStartPosition()()()() | Gets the position of the start of this word in the main text. (Inherited from WordOccurrence.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetWord()()()() | Gets the String of this bad word. (Inherited from WordOccurrence.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Reason | Gets the reason that this is a bad word.
 | REASON_CAPITALIZATION | BadWord reason, incorrect capitalization.
 | REASON_DUPLICATE | BadWord reason, duplicate word occurrence.
 | REASON_SPELLING | BadWord reason, incorrect spelling.
 | Shift(Int32) | Moves the bad word position by delta
 | StartPosition | Gets the position of the start of this word in the main text. (Inherited from WordOccurrence.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Word | Gets the string of this bad word. (Inherited from WordOccurrence.)
Inheritance Hierarchy
Object
 | WordOccurrence
 |  | BadWord

Send comments on this topic to support@keyoti.com

2003-2015 Keyoti Inc.

Assembly: Keyoti.RapidSpellWeb (Module: Keyoti.RapidSpellWeb.dll) Version: 5.0.15.1116


BadWord Constructor

BadWord Constructor
API Documentation ► Keyoti.RapidSpell ► BadWord ► BadWord()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | BadWord(String, Int32, Int32) | Constructs a BadWord (REASON_SPELLING) instance.
 | BadWord(String, Int32, Int32, Int32) | Constructs a BadWord instance.


BadWord Constructor (word, caretStart, caretEnd)

BadWord Constructor (word, caretStart, caretEnd)
API Documentation ► Keyoti.RapidSpell ► BadWord ► BadWord(String, Int32, Int32)
Keyoti RapidSpell Web .NET
Constructs a BadWord (REASON_SPELLING) instance.
Declaration Syntax
C# Visual Basic Visual C++ F#
public BadWord(
    string word,
    int caretStart,
    int caretEnd
)
Public Sub New (
    word As String,
    caretStart As Integer,
    caretEnd As Integer
)
public:
BadWord(
    String^ word,
    int caretStart,
    int caretEnd
)
new :
        word : string *
        caretStart : int *
        caretEnd : int -> BadWord
Parameters
word (String)
the word String that is misspelt
caretStart (Int32)
the position in the original text
caretEnd (Int32)
the end position in the text


BadWord Constructor (word, caretStart, caretEnd, reason)

BadWord Constructor (word, caretStart, caretEnd, reason)
API Documentation ► Keyoti.RapidSpell ► BadWord ► BadWord(String, Int32, Int32, Int32)
Keyoti RapidSpell Web .NET
Constructs a BadWord instance.
Declaration Syntax
C# Visual Basic Visual C++ F#
public BadWord(
    string word,
    int caretStart,
    int caretEnd,
    int reason
)
Public Sub New (
    word As String,
    caretStart As Integer,
    caretEnd As Integer,
    reason As Integer
)
public:
BadWord(
    String^ word,
    int caretStart,
    int caretEnd,
    int reason
)
new :
        word : string *
        caretStart : int *
        caretEnd : int *
        reason : int -> BadWord
Parameters
word (String)
the word String that is misspelt
caretStart (Int32)
the position in the original text
caretEnd (Int32)
the end position in the text
reason (Int32)
the reason this is a bad word, either REASON_DUPLICATE or REASON_SPELLING


Clone Method

Clone Method
API Documentation ► Keyoti.RapidSpell ► BadWord ► Clone()()()()
Keyoti RapidSpell Web .NET
Clones this instance
Declaration Syntax
C# Visual Basic Visual C++ F#
public BadWord Clone()
Public Function Clone As BadWord
public:
BadWord^ Clone()
member Clone : unit -> BadWord
Return Value
BadWord


Equals Method (obj)

Equals Method (obj)
API Documentation ► Keyoti.RapidSpell ► BadWord ► Equals(Object)
Keyoti RapidSpell Web .NET
See base.
Declaration Syntax
C# Visual Basic Visual C++ F#
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
Parameters
obj (Object)
Return Value
Boolean


GetHashCode Method

GetHashCode Method
API Documentation ► Keyoti.RapidSpell ► BadWord ► GetHashCode()()()()
Keyoti RapidSpell Web .NET
See base
Declaration Syntax
C# Visual Basic Visual C++ F#
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
Return Value
Int32


GetReason Method

GetReason Method
API Documentation ► Keyoti.RapidSpell ► BadWord ► GetReason()()()()
Keyoti RapidSpell Web .NET
Gets the reason that this is a bad word.
Declaration Syntax
C# Visual Basic Visual C++ F#
public int GetReason()
Public Function GetReason As Integer
public:
int GetReason()
member GetReason : unit -> int
Return Value
Int32


Reason Property

Reason Property
API Documentation ► Keyoti.RapidSpell ► BadWord ► Reason
Keyoti RapidSpell Web .NET
Gets the reason that this is a bad word.
Declaration Syntax
C# Visual Basic Visual C++ F#
public int Reason { get; }
Public ReadOnly Property Reason As Integer
    Get
public:
property int Reason {
    int get ();
}
member Reason : int with get
Property Value
Int32


REASON_CAPITALIZATION Field

REASON_CAPITALIZATION Field
API Documentation ► Keyoti.RapidSpell ► BadWord ► REASON_CAPITALIZATION
Keyoti RapidSpell Web .NET
BadWord reason, incorrect capitalization.
Declaration Syntax
C# Visual Basic Visual C++ F#
public static int REASON_CAPITALIZATION
Public Shared REASON_CAPITALIZATION As Integer
public:
static int REASON_CAPITALIZATION
static val mutable REASON_CAPITALIZATION: int
Field Value
Int32


REASON_DUPLICATE Field

REASON_DUPLICATE Field
API Documentation ► Keyoti.RapidSpell ► BadWord ► REASON_DUPLICATE
Keyoti RapidSpell Web .NET
BadWord reason, duplicate word occurrence.
Declaration Syntax
C# Visual Basic Visual C++ F#
public static int REASON_DUPLICATE
Public Shared REASON_DUPLICATE As Integer
public:
static int REASON_DUPLICATE
static val mutable REASON_DUPLICATE: int
Field Value
Int32


REASON_SPELLING Field

REASON_SPELLING Field
API Documentation ► Keyoti.RapidSpell ► BadWord ► REASON_SPELLING
Keyoti RapidSpell Web .NET
BadWord reason, incorrect spelling.
Declaration Syntax
C# Visual Basic Visual C++ F#
public static int REASON_SPELLING
Public Shared REASON_SPELLING As Integer
public:
static int REASON_SPELLING
static val mutable REASON_SPELLING: int
Field Value
Int32


Shift Method (delta)

Shift Method (delta)
API Documentation ► Keyoti.RapidSpell ► BadWord ► Shift(Int32)
Keyoti RapidSpell Web .NET
Moves the bad word position by delta
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void Shift(
    int delta
)
Public Overridable Sub Shift (
    delta As Integer
)
public:
virtual void Shift(
    int delta
)
abstract Shift :
        delta : int -> unit
override Shift :
        delta : int -> unit
Parameters
delta (Int32)


CheckerEngineAdapter Class

CheckerEngineAdapter Class
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter
Keyoti RapidSpell Web .NET
Abstract base implementation of ICheckerEngine, override chosen members for desired functionality.
Declaration Syntax
C# Visual Basic Visual C++ F#
public abstract class CheckerEngineAdapter : ICheckerEngine
Public MustInherit Class CheckerEngineAdapter
    Implements ICheckerEngine
public ref class CheckerEngineAdapter abstract : ICheckerEngine
[<AbstractClassAttribute>]
type CheckerEngineAdapter =
    class
        interface ICheckerEngine
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CheckerEngineAdapter()()()() |
 | AddWord(String) | Adds a word to the user dictionary, if it exists.
 | AllowAnyCase | Whether to allow words spelt with any case, eg. "africa" instead of "Africa", this is more relaxed than AllowMixedCase.
 | AllowMixedCase | Whether to allow words spelt with mixed case, eg. "MIxEd"
 | ChangeBadWord(String) | Changes the current bad word to newWord in the text.
 | ChangeBadWord(BadWord, String) | Changes badWord to newWord in the text.
 | Check(String) | Checks the text for errors.
 | Check(String, Boolean) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
 | CheckCompoundWords | Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
 | CurrentBadWord | Gets the current bad word (last returned by NextBadWord).
 | DictFilePath | The file to be used as the main dictionary, if this is null then the RapidSpellMDict.DLL satellite assembly is used.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindCapitalizedSuggestions | Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
 | FindSuggestions()()()() | Returns an ArrayList of Strings that are suitable suggestions for the current bad word (that is, the one last returned by NextBadWord()).
 | FindSuggestions(String) | Returns an ArrayList of Strings that are suitable suggestions for word.
 | GetConsiderationRange()()()() | Gets the factor for words to consider for suggestions.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIgnoreCapitalizedWords()()()() | Gets whether to ignore words that start with capital letters.
 | GetIncludeUserDictionaryInSuggestions()()()() | Gets whether the user dictionary should be used in finding suggestions for misspelt words.
 | GetSuggestionsMethod()()()() | Sets the suggestions method, where method is an integer identifier.
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetUndoableStatePoint()()()() | Returns null as undo is not supported
 | IgnoreAll(String) | Marks word to be ignored in rest of the text.
 | IgnoreIncorrectSentenceCapitalization | Whether to ignore incorrect sentence capitalization.
 | IgnoreInEnglishLowerCaseI | Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
 | IgnoreList | The words to ignore, note this list is changed by IgnoreAll.
 | IgnoreURLsAndEmailAddresses | Whether to ignore URLs and email addresses (requires V2Parser=true)
 | IgnoreWordsWithDigits | Whether to ignore words with numbers in them (eg. A10 or 7-11).
 | IgnoreXML | Whether to ignore XML tags in the text.
 | LanguageParser | The type of language parsing to use.
 | LookIntoHyphenatedText | Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
 | LookUp(String) | Looks up word in the dictionary, returns true if it is in there.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NextBadWord()()()() | Gets the next bad word in the list that was identified by Check.
 | RevertToUndoableStatePoint(RapidSpellChecker..::..State) | Throws NotImplementedException
 | SetConsiderationRange(Int32) | Sets the breadth of the suggestions search.
 | SetDictFileStream(Stream, String, DateTime) | Passes a Dict file as a stream, to be used for the main dictionary.
 | SetIgnoreCapitalizedWords(Boolean) | Sets whether to ignore capitalized words.
 | SetIncludeUserDictionaryInSuggestions(Boolean) | Sets whether to include the user dictionary in suggestions taken from this engine.
 | SetOptionalContext(String, String) | Provides the engine with any helpful text around the text snippet which will be passed to the Check method. Implementation is not required.
 | SetPosition(Int32) | Sets the pointer position for the NextBadWord iterator.
 | SetSeparateHyphenWords(Boolean) | Sets whether to separate words with hyphens in them into separate words.
 | SetSuggestionsMethod(Int32) | Sets the suggestions method, where method is an integer identifier.
 | SetUserDictionary(UserDictionary) | Sets the UserDictionary object to be used as a user dictionary source.
 | SetUserDictionary(String) | Sets the UserDictionary file path to be used as a user dictionary source.
 | SuggestSplitWords | Whether to look for connected words in suggestions.
 | TextBoundary | The AdvancedTextBoundary class to use to parse words.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UnloadMainDictionary()()()() | Empties the main dictionary store.
 | userDictionary | The user dictionary, this should be null (C#) or nothing (VB.NET) if no user dictionary is being used.
 | V2Parser | Whether to use parser version 2
 | WarnDuplicates | Whether to treat duplicate words as errors (eg. "this is is an error").
 | WordAdded | Fires when a word is added
Remarks
None of the members contained in this class do anything.
Inheritance Hierarchy
Object
CheckerEngineAdapter


CheckerEngineAdapter Constructor

CheckerEngineAdapter Constructor
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► CheckerEngineAdapter()()()()
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
protected CheckerEngineAdapter()
Protected Sub New
protected:
CheckerEngineAdapter()
new : unit -> CheckerEngineAdapter


AddWord Method (word)

AddWord Method (word)
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► AddWord(String)
Keyoti RapidSpell Web .NET
Adds a word to the user dictionary, if it exists.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual bool AddWord(
    string word
)
Public Overridable Function AddWord (
    word As String
) As Boolean
public:
virtual bool AddWord(
    String^ word
)
abstract AddWord :
        word : string -> bool
override AddWord :
        word : string -> bool
Parameters
word (String)
Return Value
Boolean
This implementation always returns false.
Remarks
Should return true if the word was added successfully, false otherwise.


AllowAnyCase Property

AllowAnyCase Property
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► AllowAnyCase
Keyoti RapidSpell Web .NET
Whether to allow words spelt with any case, eg. "africa" instead of "Africa", this is more relaxed than AllowMixedCase.
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool AllowAnyCase { get; set; }
Public Property AllowAnyCase As Boolean
    Get
    Set
public:
virtual property bool AllowAnyCase {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract AllowAnyCase : bool with get, set
override AllowAnyCase : bool with get, set
Property Value
Boolean


AllowMixedCase Property

AllowMixedCase Property
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► AllowMixedCase
Keyoti RapidSpell Web .NET
Whether to allow words spelt with mixed case, eg. "MIxEd"
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual bool AllowMixedCase { get; set; }
Public Overridable Property AllowMixedCase As Boolean
    Get
    Set
public:
virtual property bool AllowMixedCase {
    bool get ();
    void set (bool value);
}
abstract AllowMixedCase : bool with get, set
override AllowMixedCase : bool with get, set
Property Value
Boolean


ChangeBadWord Method

ChangeBadWord Method
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► ChangeBadWord()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | ChangeBadWord(String) | Changes the current bad word to newWord in the text.
 | ChangeBadWord(BadWord, String) | Changes badWord to newWord in the text.


ChangeBadWord Method (badWord, newWord)

ChangeBadWord Method (badWord, newWord)
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► ChangeBadWord(BadWord, String)
Keyoti RapidSpell Web .NET
Changes badWord to newWord in the text.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void ChangeBadWord(
    BadWord badWord,
    string newWord
)
Public Overridable Sub ChangeBadWord (
    badWord As BadWord,
    newWord As String
)
public:
virtual void ChangeBadWord(
    BadWord^ badWord,
    String^ newWord
)
abstract ChangeBadWord :
        badWord : BadWord *
        newWord : string -> unit
override ChangeBadWord :
        badWord : BadWord *
        newWord : string -> unit
Parameters
badWord (BadWord)
the bad word to replace
newWord (String)
replaces the current misspelt word.
Return Value

void
Exceptions
Exception | Condition
ArgumentNullException | if newWord parameter is null.


ChangeBadWord Method (newWord)

ChangeBadWord Method (newWord)
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► ChangeBadWord(String)
Keyoti RapidSpell Web .NET
Changes the current bad word to newWord in the text.
Declaration Syntax
C# Visual Basic Visual C++ F#
public void ChangeBadWord(
    string newWord
)
Public Sub ChangeBadWord (
    newWord As String
)
public:
virtual void ChangeBadWord(
    String^ newWord
) sealed
abstract ChangeBadWord :
        newWord : string -> unit
override ChangeBadWord :
        newWord : string -> unit
Parameters
newWord (String)
replaces the current misspelt word.
Return Value

void
Exceptions
Exception | Condition
NoCurrentBadWordException | if nextBadWord() hasn't been run first AND found an erroneous word.
ArgumentNullException | if newWord parameter is null.


Check Method

Check Method
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► Check()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | Check(String) | Checks the text for errors.
 | Check(String, Boolean) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.


Check Method (text)

Check Method (text)
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► Check(String)
Keyoti RapidSpell Web .NET
Checks the text for errors.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void Check(
    string text
)
Public Overridable Sub Check (
    text As String
)
public:
virtual void Check(
    String^ text
)
abstract Check :
        text : string -> unit
override Check :
        text : string -> unit
Parameters
text (String)
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


Check Method (text, isStartOfTextBody)

Check Method (text, isStartOfTextBody)
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► Check(String, Boolean)
Keyoti RapidSpell Web .NET
Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
Declaration Syntax
C# Visual Basic Visual C++ F#
public void Check(
    string text,
    bool isStartOfTextBody
)
Public Sub Check (
    text As String,
    isStartOfTextBody As Boolean
)
public:
virtual void Check(
    String^ text,
    bool isStartOfTextBody
) sealed
abstract Check :
        text : string *
        isStartOfTextBody : bool -> unit
override Check :
        text : string *
        isStartOfTextBody : bool -> unit
Parameters
text (String)
to spell check.
isStartOfTextBody (Boolean)
whether the text being spell checked is at the start of the text body (eg. start of text box), this affects sentence capitalization determination.
Return Value

void
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


CheckCompoundWords Property

CheckCompoundWords Property
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► CheckCompoundWords
Keyoti RapidSpell Web .NET
Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual bool CheckCompoundWords { get; set; }
Public Overridable Property CheckCompoundWords As Boolean
    Get
    Set
public:
virtual property bool CheckCompoundWords {
    bool get ();
    void set (bool value);
}
abstract CheckCompoundWords : bool with get, set
override CheckCompoundWords : bool with get, set
Property Value
Boolean
Remarks
If this=false then LookUp("thesewordsarejoined") = false

If this=true then LookUp("thesewordsarejoined") = true

If this=false then LookUp("abcdef") = false

If this=true then LookUp("abcdef") = false

Setting this to true will degrade lookup performance


CurrentBadWord Property

CurrentBadWord Property
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► CurrentBadWord
Keyoti RapidSpell Web .NET
Gets the current bad word (last returned by NextBadWord).
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual BadWord CurrentBadWord { get; }
Public Overridable ReadOnly Property CurrentBadWord As BadWord
    Get
public:
virtual property BadWord^ CurrentBadWord {
    BadWord^ get ();
}
abstract CurrentBadWord : BadWord with get
override CurrentBadWord : BadWord with get
Property Value
BadWord


DictFilePath Property

DictFilePath Property
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► DictFilePath
Keyoti RapidSpell Web .NET
The file to be used as the main dictionary, if this is null then the RapidSpellMDict.DLL satellite assembly is used.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual string DictFilePath { get; set; }
Public Overridable Property DictFilePath As String
    Get
    Set
public:
virtual property String^ DictFilePath {
    String^ get ();
    void set (String^ value);
}
abstract DictFilePath : string with get, set
override DictFilePath : string with get, set
Return Value
String
This implementation always returns null.


FindCapitalizedSuggestions Property

FindCapitalizedSuggestions Property
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► FindCapitalizedSuggestions
Keyoti RapidSpell Web .NET
Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool FindCapitalizedSuggestions { get; set; }
Public Property FindCapitalizedSuggestions As Boolean
    Get
    Set
public:
virtual property bool FindCapitalizedSuggestions {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract FindCapitalizedSuggestions : bool with get, set
override FindCapitalizedSuggestions : bool with get, set
Property Value
Boolean


FindSuggestions Method

FindSuggestions Method
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► FindSuggestions()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | FindSuggestions()()()() | Returns an ArrayList of Strings that are suitable suggestions for the current bad word (that is, the one last returned by NextBadWord()).
 | FindSuggestions(String) | Returns an ArrayList of Strings that are suitable suggestions for word.


FindSuggestions Method

FindSuggestions Method
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► FindSuggestions()()()()
Keyoti RapidSpell Web .NET
Returns an ArrayList of Strings that are suitable suggestions for the current bad word (that is, the one last returned by NextBadWord()).
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual ArrayList FindSuggestions()
Public Overridable Function FindSuggestions As ArrayList
public:
virtual ArrayList^ FindSuggestions()
abstract FindSuggestions : unit -> ArrayList
override FindSuggestions : unit -> ArrayList
Return Value
ArrayList
An empty ArrayList
Remarks
If no suggestions can be found, this should return an empty ArrayList. This method should be thread safe if operating with RapidSpell Desktop.
Exceptions
Exception | Condition
NoCurrentBadWordException | If NextBadWord() hasn't been run first AND found an erroneous word.


FindSuggestions Method (word)

FindSuggestions Method (word)
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► FindSuggestions(String)
Keyoti RapidSpell Web .NET
Returns an ArrayList of Strings that are suitable suggestions for word.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual ArrayList FindSuggestions(
    string word
)
Public Overridable Function FindSuggestions (
    word As String
) As ArrayList
public:
virtual ArrayList^ FindSuggestions(
    String^ word
)
abstract FindSuggestions :
        word : string -> ArrayList
override FindSuggestions :
        word : string -> ArrayList
Parameters
word (String)
Return Value
ArrayList
An empty ArrayList
Remarks
If no suggestions can be found, this should return an empty ArrayList. This method should be thread safe if operating with RapidSpell Desktop.


GetConsiderationRange Method

GetConsiderationRange Method
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► GetConsiderationRange()()()()
Keyoti RapidSpell Web .NET
Gets the factor for words to consider for suggestions.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual int GetConsiderationRange()
Public Overridable Function GetConsiderationRange As Integer
public:
virtual int GetConsiderationRange()
abstract GetConsiderationRange : unit -> int
override GetConsiderationRange : unit -> int
Return Value
Int32
This implementation always returns 0.


GetIgnoreCapitalizedWords Method

GetIgnoreCapitalizedWords Method
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► GetIgnoreCapitalizedWords()()()()
Keyoti RapidSpell Web .NET
Gets whether to ignore words that start with capital letters.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual bool GetIgnoreCapitalizedWords()
Public Overridable Function GetIgnoreCapitalizedWords As Boolean
public:
virtual bool GetIgnoreCapitalizedWords()
abstract GetIgnoreCapitalizedWords : unit -> bool
override GetIgnoreCapitalizedWords : unit -> bool
Return Value
Boolean
This implementation always returns false.


GetIncludeUserDictionaryInSuggestions Method

GetIncludeUserDictionaryInSuggestions Method
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► GetIncludeUserDictionaryInSuggestions()()()()
Keyoti RapidSpell Web .NET
Gets whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual bool GetIncludeUserDictionaryInSuggestions()
Public Overridable Function GetIncludeUserDictionaryInSuggestions As Boolean
public:
virtual bool GetIncludeUserDictionaryInSuggestions()
abstract GetIncludeUserDictionaryInSuggestions : unit -> bool
override GetIncludeUserDictionaryInSuggestions : unit -> bool
Return Value
Boolean
This implementation always returns false.


GetSuggestionsMethod Method

GetSuggestionsMethod Method
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► GetSuggestionsMethod()()()()
Keyoti RapidSpell Web .NET
Sets the suggestions method, where method is an integer identifier.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual int GetSuggestionsMethod()
Public Overridable Function GetSuggestionsMethod As Integer
public:
virtual int GetSuggestionsMethod()
abstract GetSuggestionsMethod : unit -> int
override GetSuggestionsMethod : unit -> int
Return Value
Int32


GetUndoableStatePoint Method

GetUndoableStatePoint Method
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► GetUndoableStatePoint()()()()
Keyoti RapidSpell Web .NET
Returns null as undo is not supported
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual RapidSpellChecker..::..State GetUndoableStatePoint()
Public Overridable Function GetUndoableStatePoint As RapidSpellChecker..::..State
public:
virtual RapidSpellChecker..::..State^ GetUndoableStatePoint()
abstract GetUndoableStatePoint : unit -> RapidSpellChecker..::..State
override GetUndoableStatePoint : unit -> RapidSpellChecker..::..State
Return Value
RapidSpellChecker..::..State
Returns the current state, or null if not supporting undo.


IgnoreAll Method (word)

IgnoreAll Method (word)
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► IgnoreAll(String)
Keyoti RapidSpell Web .NET
Marks word to be ignored in rest of the text.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void IgnoreAll(
    string word
)
Public Overridable Sub IgnoreAll (
    word As String
)
public:
virtual void IgnoreAll(
    String^ word
)
abstract IgnoreAll :
        word : string -> unit
override IgnoreAll :
        word : string -> unit
Parameters
word (String)
to ignore
Return Value

void
Exceptions
Exception | Condition
ArgumentNullException | if word parameter is null.


IgnoreIncorrectSentenceCapitalization Property

IgnoreIncorrectSentenceCapitalization Property
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► IgnoreIncorrectSentenceCapitalization
Keyoti RapidSpell Web .NET
Whether to ignore incorrect sentence capitalization.
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool IgnoreIncorrectSentenceCapitalization { get; set; }
Public Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
public:
virtual property bool IgnoreIncorrectSentenceCapitalization {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreIncorrectSentenceCapitalization : bool with get, set
override IgnoreIncorrectSentenceCapitalization : bool with get, set
Property Value
Boolean


IgnoreInEnglishLowerCaseI Property

IgnoreInEnglishLowerCaseI Property
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► IgnoreInEnglishLowerCaseI
Keyoti RapidSpell Web .NET
Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool IgnoreInEnglishLowerCaseI { get; set; }
Public Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
public:
virtual property bool IgnoreInEnglishLowerCaseI {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreInEnglishLowerCaseI : bool with get, set
override IgnoreInEnglishLowerCaseI : bool with get, set
Property Value
Boolean


IgnoreList Property

IgnoreList Property
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► IgnoreList
Keyoti RapidSpell Web .NET
The words to ignore, note this list is changed by IgnoreAll.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual ArrayList IgnoreList { get; set; }
Public Overridable Property IgnoreList As ArrayList
    Get
    Set
public:
virtual property ArrayList^ IgnoreList {
    ArrayList^ get ();
    void set (ArrayList^ value);
}
abstract IgnoreList : ArrayList with get, set
override IgnoreList : ArrayList with get, set
Property Value
ArrayList


IgnoreURLsAndEmailAddresses Property

IgnoreURLsAndEmailAddresses Property
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► IgnoreURLsAndEmailAddresses
Keyoti RapidSpell Web .NET
Whether to ignore URLs and email addresses (requires V2Parser=true)
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual bool IgnoreURLsAndEmailAddresses { get; set; }
Public Overridable Property IgnoreURLsAndEmailAddresses As Boolean
    Get
    Set
public:
virtual property bool IgnoreURLsAndEmailAddresses {
    bool get ();
    void set (bool value);
}
abstract IgnoreURLsAndEmailAddresses : bool with get, set
override IgnoreURLsAndEmailAddresses : bool with get, set
Property Value
Boolean
Remarks
This will cause the following strings to be accepted as non-spelling errors;
"user@domain.com", "http://www.domain.com", "domain.co.uk" etc.


IgnoreWordsWithDigits Property

IgnoreWordsWithDigits Property
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► IgnoreWordsWithDigits
Keyoti RapidSpell Web .NET
Whether to ignore words with numbers in them (eg. A10 or 7-11).
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual bool IgnoreWordsWithDigits { get; set; }
Public Overridable Property IgnoreWordsWithDigits As Boolean
    Get
    Set
public:
virtual property bool IgnoreWordsWithDigits {
    bool get ();
    void set (bool value);
}
abstract IgnoreWordsWithDigits : bool with get, set
override IgnoreWordsWithDigits : bool with get, set
Property Value
Boolean


IgnoreXML Property

IgnoreXML Property
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► IgnoreXML
Keyoti RapidSpell Web .NET
Whether to ignore XML tags in the text.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual bool IgnoreXML { get; set; }
Public Overridable Property IgnoreXML As Boolean
    Get
    Set
public:
virtual property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
abstract IgnoreXML : bool with get, set
override IgnoreXML : bool with get, set
Return Value
Boolean
This property is always false.


LanguageParser Property

LanguageParser Property
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► LanguageParser
Keyoti RapidSpell Web .NET
The type of language parsing to use.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual LanguageType LanguageParser { get; set; }
Public Overridable Property LanguageParser As LanguageType
    Get
    Set
public:
virtual property LanguageType LanguageParser {
    LanguageType get ();
    void set (LanguageType value);
}
abstract LanguageParser : LanguageType with get, set
override LanguageParser : LanguageType with get, set
Return Value
LanguageType
This implementation always returns RapidSpellChecker.LanguageParserType.ENGLISH.
Remarks
Eg. If the dictionary is set to French, you should use the French parser.


LookIntoHyphenatedText Property

LookIntoHyphenatedText Property
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► LookIntoHyphenatedText
Keyoti RapidSpell Web .NET
Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual bool LookIntoHyphenatedText { get; set; }
Public Overridable Property LookIntoHyphenatedText As Boolean
    Get
    Set
public:
virtual property bool LookIntoHyphenatedText {
    bool get ();
    void set (bool value);
}
abstract LookIntoHyphenatedText : bool with get, set
override LookIntoHyphenatedText : bool with get, set
Property Value
Boolean
Remarks
Eg. "socio-economic" will be checked as "socio" and "economic".


LookUp Method (word)

LookUp Method (word)
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► LookUp(String)
Keyoti RapidSpell Web .NET
Looks up word in the dictionary, returns true if it is in there.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual bool LookUp(
    string word
)
Public Overridable Function LookUp (
    word As String
) As Boolean
public:
virtual bool LookUp(
    String^ word
)
abstract LookUp :
        word : string -> bool
override LookUp :
        word : string -> bool
Parameters
word (String)
Return Value
Boolean


NextBadWord Method

NextBadWord Method
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► NextBadWord()()()()
Keyoti RapidSpell Web .NET
Gets the next bad word in the list that was identified by Check.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual BadWord NextBadWord()
Public Overridable Function NextBadWord As BadWord
public:
virtual BadWord^ NextBadWord()
abstract NextBadWord : unit -> BadWord
override NextBadWord : unit -> BadWord
Return Value
BadWord
This implementation always returns null.
Remarks
Check must be called before this method.


RevertToUndoableStatePoint Method (state)

RevertToUndoableStatePoint Method (state)
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► RevertToUndoableStatePoint(RapidSpellChecker..::..State)
Keyoti RapidSpell Web .NET
Throws NotImplementedException
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void RevertToUndoableStatePoint(
    RapidSpellChecker..::..State state
)
Public Overridable Sub RevertToUndoableStatePoint (
    state As RapidSpellChecker..::..State
)
public:
virtual void RevertToUndoableStatePoint(
    RapidSpellChecker..::..State^ state
)
abstract RevertToUndoableStatePoint :
        state : RapidSpellChecker..::..State -> unit
override RevertToUndoableStatePoint :
        state : RapidSpellChecker..::..State -> unit
Parameters
state (RapidSpellChecker..::..State)


SetConsiderationRange Method (range)

SetConsiderationRange Method (range)
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetConsiderationRange(Int32)
Keyoti RapidSpell Web .NET
Sets the breadth of the suggestions search.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void SetConsiderationRange(
    int range
)
Public Overridable Sub SetConsiderationRange (
    range As Integer
)
public:
virtual void SetConsiderationRange(
    int range
)
abstract SetConsiderationRange :
        range : int -> unit
override SetConsiderationRange :
        range : int -> unit
Parameters
range (Int32)


SetDictFileStream Method (dictFileStream, id, modifiedDate)

SetDictFileStream Method (dictFileStream, id, modifiedDate)
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetDictFileStream(Stream, String, DateTime)
Keyoti RapidSpell Web .NET
Passes a Dict file as a stream, to be used for the main dictionary.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void SetDictFileStream(
    Stream dictFileStream,
    string id,
    DateTime modifiedDate
)
Public Overridable Sub SetDictFileStream (
    dictFileStream As Stream,
    id As String,
    modifiedDate As DateTime
)
public:
virtual void SetDictFileStream(
    Stream^ dictFileStream,
    String^ id,
    DateTime modifiedDate
)
abstract SetDictFileStream :
        dictFileStream : Stream *
        id : string *
        modifiedDate : DateTime -> unit
override SetDictFileStream :
        dictFileStream : Stream *
        id : string *
        modifiedDate : DateTime -> unit
Parameters
dictFileStream (Stream)
The stream containing the dictionary
id (String)
modifiedDate (DateTime)
Remarks
Note this method must be set before Check is called, and the stream position must be at beginning of Dict file. The stream is NOT closed by this method.


SetIgnoreCapitalizedWords Method (ignore)

SetIgnoreCapitalizedWords Method (ignore)
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetIgnoreCapitalizedWords(Boolean)
Keyoti RapidSpell Web .NET
Sets whether to ignore capitalized words.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void SetIgnoreCapitalizedWords(
    bool ignore
)
Public Overridable Sub SetIgnoreCapitalizedWords (
    ignore As Boolean
)
public:
virtual void SetIgnoreCapitalizedWords(
    bool ignore
)
abstract SetIgnoreCapitalizedWords :
        ignore : bool -> unit
override SetIgnoreCapitalizedWords :
        ignore : bool -> unit
Parameters
ignore (Boolean)


SetIncludeUserDictionaryInSuggestions Method (includeUserDictionaryInSuggestions)

SetIncludeUserDictionaryInSuggestions Method (includeUserDictionaryInSuggestions)
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetIncludeUserDictionaryInSuggestions(Boolean)
Keyoti RapidSpell Web .NET
Sets whether to include the user dictionary in suggestions taken from this engine.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void SetIncludeUserDictionaryInSuggestions(
    bool includeUserDictionaryInSuggestions
)
Public Overridable Sub SetIncludeUserDictionaryInSuggestions (
    includeUserDictionaryInSuggestions As Boolean
)
public:
virtual void SetIncludeUserDictionaryInSuggestions(
    bool includeUserDictionaryInSuggestions
)
abstract SetIncludeUserDictionaryInSuggestions :
        includeUserDictionaryInSuggestions : bool -> unit
override SetIncludeUserDictionaryInSuggestions :
        includeUserDictionaryInSuggestions : bool -> unit
Parameters
includeUserDictionaryInSuggestions (Boolean)


SetOptionalContext Method (beforeToCheckSnippet, afterToCheckSnippet)

SetOptionalContext Method (beforeToCheckSnippet, afterToCheckSnippet)
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetOptionalContext(String, String)
Keyoti RapidSpell Web .NET
Provides the engine with any helpful text around the text snippet which will be passed to the Check method. Implementation is not required.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void SetOptionalContext(
    string beforeToCheckSnippet,
    string afterToCheckSnippet
)
Public Overridable Sub SetOptionalContext (
    beforeToCheckSnippet As String,
    afterToCheckSnippet As String
)
public:
virtual void SetOptionalContext(
    String^ beforeToCheckSnippet,
    String^ afterToCheckSnippet
)
abstract SetOptionalContext :
        beforeToCheckSnippet : string *
        afterToCheckSnippet : string -> unit
override SetOptionalContext :
        beforeToCheckSnippet : string *
        afterToCheckSnippet : string -> unit
Parameters
beforeToCheckSnippet (String)
Any text before the to check snippet
afterToCheckSnippet (String)
Any text after the snippet
Remarks
Eg. if the document contains "This is an an example piece." and Check will be called on "an example piece", then the fact that 'an' is duplicated will not be detected. Therefore, by passing "This is an " to beforeToCheckSnippet the checker will be able to detect that an is duplicated.


SetPosition Method (pos)

SetPosition Method (pos)
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetPosition(Int32)
Keyoti RapidSpell Web .NET
Sets the pointer position for the NextBadWord iterator.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void SetPosition(
    int pos
)
Public Overridable Sub SetPosition (
    pos As Integer
)
public:
virtual void SetPosition(
    int pos
)
abstract SetPosition :
        pos : int -> unit
override SetPosition :
        pos : int -> unit
Parameters
pos (Int32)
Remarks
Further calls to NextBadWord will look for the next bad word from position pos. If position > the text length it is set to the text length. If position < 0, it is set to zero.


SetSeparateHyphenWords Method (separate)

SetSeparateHyphenWords Method (separate)
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetSeparateHyphenWords(Boolean)
Keyoti RapidSpell Web .NET
Sets whether to separate words with hyphens in them into separate words.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void SetSeparateHyphenWords(
    bool separate
)
Public Overridable Sub SetSeparateHyphenWords (
    separate As Boolean
)
public:
virtual void SetSeparateHyphenWords(
    bool separate
)
abstract SetSeparateHyphenWords :
        separate : bool -> unit
override SetSeparateHyphenWords :
        separate : bool -> unit
Parameters
separate (Boolean)


SetSuggestionsMethod Method (method)

SetSuggestionsMethod Method (method)
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetSuggestionsMethod(Int32)
Keyoti RapidSpell Web .NET
Sets the suggestions method, where method is an integer identifier.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void SetSuggestionsMethod(
    int method
)
Public Overridable Sub SetSuggestionsMethod (
    method As Integer
)
public:
virtual void SetSuggestionsMethod(
    int method
)
abstract SetSuggestionsMethod :
        method : int -> unit
override SetSuggestionsMethod :
        method : int -> unit
Parameters
method (Int32)


SetUserDictionary Method

SetUserDictionary Method
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetUserDictionary()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | SetUserDictionary(UserDictionary) | Sets the UserDictionary object to be used as a user dictionary source.
 | SetUserDictionary(String) | Sets the UserDictionary file path to be used as a user dictionary source.


SetUserDictionary Method (userDictionary)

SetUserDictionary Method (userDictionary)
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetUserDictionary(UserDictionary)
Keyoti RapidSpell Web .NET
Sets the UserDictionary object to be used as a user dictionary source.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void SetUserDictionary(
    UserDictionary userDictionary
)
Public Overridable Sub SetUserDictionary (
    userDictionary As UserDictionary
)
public:
virtual void SetUserDictionary(
    UserDictionary^ userDictionary
)
abstract SetUserDictionary :
        userDictionary : UserDictionary -> unit
override SetUserDictionary :
        userDictionary : UserDictionary -> unit
Parameters
userDictionary (UserDictionary)


SetUserDictionary Method (userDictionary)

SetUserDictionary Method (userDictionary)
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SetUserDictionary(String)
Keyoti RapidSpell Web .NET
Sets the UserDictionary file path to be used as a user dictionary source.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void SetUserDictionary(
    string userDictionary
)
Public Overridable Sub SetUserDictionary (
    userDictionary As String
)
public:
virtual void SetUserDictionary(
    String^ userDictionary
)
abstract SetUserDictionary :
        userDictionary : string -> unit
override SetUserDictionary :
        userDictionary : string -> unit
Parameters
userDictionary (String)


SuggestSplitWords Property

SuggestSplitWords Property
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► SuggestSplitWords
Keyoti RapidSpell Web .NET
Whether to look for connected words in suggestions.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual bool SuggestSplitWords { get; set; }
Public Overridable Property SuggestSplitWords As Boolean
    Get
    Set
public:
virtual property bool SuggestSplitWords {
    bool get ();
    void set (bool value);
}
abstract SuggestSplitWords : bool with get, set
override SuggestSplitWords : bool with get, set
Property Value
Boolean
Remarks
if this=true then suggestions may include joined words.

Eg; suggestions for "myhouse" will include "my house"


TextBoundary Property

TextBoundary Property
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► TextBoundary
Keyoti RapidSpell Web .NET
The AdvancedTextBoundary class to use to parse words.
Declaration Syntax
C# Visual Basic Visual C++ F#
public AdvancedTextBoundary TextBoundary { get; set; }
Public Property TextBoundary As AdvancedTextBoundary
    Get
    Set
public:
virtual property AdvancedTextBoundary^ TextBoundary {
    AdvancedTextBoundary^ get () sealed;
    void set (AdvancedTextBoundary^ value) sealed;
}
abstract TextBoundary : AdvancedTextBoundary with get, set
override TextBoundary : AdvancedTextBoundary with get, set
Property Value
AdvancedTextBoundary


UnloadMainDictionary Method

UnloadMainDictionary Method
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► UnloadMainDictionary()()()()
Keyoti RapidSpell Web .NET
Empties the main dictionary store.
Declaration Syntax
C# Visual Basic Visual C++ F#
public void UnloadMainDictionary()
Public Sub UnloadMainDictionary
public:
void UnloadMainDictionary()
member UnloadMainDictionary : unit -> unit


userDictionary Property

userDictionary Property
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► userDictionary
Keyoti RapidSpell Web .NET
The user dictionary, this should be null (C#) or nothing (VB.NET) if no user dictionary is being used.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual UserDictionary userDictionary { get; }
Public Overridable ReadOnly Property userDictionary As UserDictionary
    Get
public:
virtual property UserDictionary^ userDictionary {
    UserDictionary^ get ();
}
abstract userDictionary : UserDictionary with get
override userDictionary : UserDictionary with get
Return Value
UserDictionary
This implementation always returns null.


V2Parser Property

V2Parser Property
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► V2Parser
Keyoti RapidSpell Web .NET
Whether to use parser version 2
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual bool V2Parser { get; set; }
Public Overridable Property V2Parser As Boolean
    Get
    Set
public:
virtual property bool V2Parser {
    bool get ();
    void set (bool value);
}
abstract V2Parser : bool with get, set
override V2Parser : bool with get, set
Property Value
Boolean


WarnDuplicates Property

WarnDuplicates Property
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► WarnDuplicates
Keyoti RapidSpell Web .NET
Whether to treat duplicate words as errors (eg. "this is is an error").
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual bool WarnDuplicates { get; set; }
Public Overridable Property WarnDuplicates As Boolean
    Get
    Set
public:
virtual property bool WarnDuplicates {
    bool get ();
    void set (bool value);
}
abstract WarnDuplicates : bool with get, set
override WarnDuplicates : bool with get, set
Property Value
Boolean


WordAdded Event

WordAdded Event
API Documentation ► Keyoti.RapidSpell ► CheckerEngineAdapter ► WordAdded
Keyoti RapidSpell Web .NET
Fires when a word is added
Declaration Syntax
C# Visual Basic Visual C++ F#
public event WordAddedEventHandler WordAdded
Public Event WordAdded As WordAddedEventHandler
public:
 event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}
member WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>
Value
WordAddedEventHandler


ClientFilesLocation Enumeration

ClientFilesLocation Enumeration
API Documentation ► Keyoti.RapidSpell ► ClientFilesLocation
Keyoti RapidSpell Web .NET
Where the client files should be obtained from.
Declaration Syntax
C# Visual Basic Visual C++ F#
public enum ClientFilesLocation
Public Enumeration ClientFilesLocation
public enum class ClientFilesLocation
type ClientFilesLocation
Members
Member | Description
Internal | Stored in the control DLL (.NET 2 only).
External | Stored at URL specified by ClientFilesFolder property.


DictionaryCache Class

DictionaryCache Class
API Documentation ► Keyoti.RapidSpell ► DictionaryCache
Keyoti RapidSpell Web .NET
Cache of loaded dictionaries.
Declaration Syntax
C# Visual Basic Visual C++ F#
public class DictionaryCache
Public Class DictionaryCache
public ref class DictionaryCache
type DictionaryCache =  class end
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DictionaryCache()()()() |
 | AddDictionary(SpellingDictionary) | Adds a dictionary to the cache.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetDictionary(String, DateTime) | Gets a dictionary from the cache.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemoveAllDictionaries()()()() | Removes all dictionaries in the cache, they will be reloaded if needed later.
 | RemoveDictionary(String) | Removes a dictionary from the cache based on its filename.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
DictionaryCache


DictionaryCache Constructor

DictionaryCache Constructor
API Documentation ► Keyoti.RapidSpell ► DictionaryCache ► DictionaryCache()()()()
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public DictionaryCache()
Public Sub New
public:
DictionaryCache()
new : unit -> DictionaryCache


AddDictionary Method (dictionary)

AddDictionary Method (dictionary)
API Documentation ► Keyoti.RapidSpell ► DictionaryCache ► AddDictionary(SpellingDictionary)
Keyoti RapidSpell Web .NET
Adds a dictionary to the cache.
Declaration Syntax
C# Visual Basic Visual C++ F#
public static void AddDictionary(
    SpellingDictionary dictionary
)
Public Shared Sub AddDictionary (
    dictionary As SpellingDictionary
)
public:
static void AddDictionary(
    SpellingDictionary^ dictionary
)
static member AddDictionary :
        dictionary : SpellingDictionary -> unit
Parameters
dictionary (SpellingDictionary)


GetDictionary Method (path, lastModifiedDate)

GetDictionary Method (path, lastModifiedDate)
API Documentation ► Keyoti.RapidSpell ► DictionaryCache ► GetDictionary(String, DateTime)
Keyoti RapidSpell Web .NET
Gets a dictionary from the cache.
Declaration Syntax
C# Visual Basic Visual C++ F#
public static SpellingDictionary GetDictionary(
    string path,
    DateTime lastModifiedDate
)
Public Shared Function GetDictionary (
    path As String,
    lastModifiedDate As DateTime
) As SpellingDictionary
public:
static SpellingDictionary^ GetDictionary(
    String^ path,
    DateTime lastModifiedDate
)
static member GetDictionary :
        path : string *
        lastModifiedDate : DateTime -> SpellingDictionary
Parameters
path (String)
lastModifiedDate (DateTime)
Return Value
SpellingDictionary


RemoveAllDictionaries Method

RemoveAllDictionaries Method
API Documentation ► Keyoti.RapidSpell ► DictionaryCache ► RemoveAllDictionaries()()()()
Keyoti RapidSpell Web .NET
Removes all dictionaries in the cache, they will be reloaded if needed later.
Declaration Syntax
C# Visual Basic Visual C++ F#
public static void RemoveAllDictionaries()
Public Shared Sub RemoveAllDictionaries
public:
static void RemoveAllDictionaries()
static member RemoveAllDictionaries : unit -> unit


RemoveDictionary Method (path)

RemoveDictionary Method (path)
API Documentation ► Keyoti.RapidSpell ► DictionaryCache ► RemoveDictionary(String)
Keyoti RapidSpell Web .NET
Removes a dictionary from the cache based on its filename.
Declaration Syntax
C# Visual Basic Visual C++ F#
public static void RemoveDictionary(
    string path
)
Public Shared Sub RemoveDictionary (
    path As String
)
public:
static void RemoveDictionary(
    String^ path
)
static member RemoveDictionary :
        path : string -> unit
Parameters
path (String)
Path to the dictionary


ICheckerEngine Interface

ICheckerEngine Interface
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine
Keyoti RapidSpell Web .NET
Defines the interface required for a class to be used as a checker engine
Declaration Syntax
C# Visual Basic Visual C++ F#
public interface ICheckerEngine
Public Interface ICheckerEngine
public interface class ICheckerEngine
type ICheckerEngine =  interface end
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddWord(String) | Adds a word to the user dictionary, if it exists.
 | AllowAnyCase | Whether to allow words spelt with any case, eg. "africa" instead of "Africa", this is more relaxed than AllowMixedCase.
 | AllowMixedCase | Whether to allow words spelt with mixed case, eg. "MIxEd"
 | ChangeBadWord(String) | Changes the current bad word to newWord in the text.
 | ChangeBadWord(BadWord, String) | Changes badWord to newWord in the text.
 | Check(String) | Checks the text for errors.
 | Check(String, Boolean) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
 | CheckCompoundWords | Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
 | CurrentBadWord | Gets the current bad word (last returned by NextBadWord).
 | DictFilePath | The file to be used as the main dictionary, if this is null then the RapidSpellMDict.DLL satellite assembly is used.
 | FindCapitalizedSuggestions | Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
 | FindSuggestions()()()() | Returns an ArrayList of Strings that are suitable suggestions for the current bad word (that is, the one last returned by NextBadWord()).
 | FindSuggestions(String) | Returns an ArrayList of Strings that are suitable suggestions for word.
 | GetConsiderationRange()()()() | Gets the factor for words to consider for suggestions.
 | GetIgnoreCapitalizedWords()()()() | Gets whether to ignore words that start with capital letters.
 | GetIncludeUserDictionaryInSuggestions()()()() | Gets whether the user dictionary should be used in finding suggestions for misspelt words.
 | GetSuggestionsMethod()()()() | Gets the suggestions method, where method is an integer identifier.
 | GetUndoableStatePoint()()()() | Gets the state of the current run, which can be stored and used with RevertToUndoableStatePoint(RapidSpellChecker..::..State)
 | IgnoreAll(String) | Marks word to be ignored in rest of the text.
 | IgnoreIncorrectSentenceCapitalization | Whether to ignore incorrect sentence capitalization.
 | IgnoreInEnglishLowerCaseI | Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
 | IgnoreList | The words to ignore, note this list is changed by IgnoreAll.
 | IgnoreURLsAndEmailAddresses | Whether to ignore URLs and email addresses (requires V2Parser=true)
 | IgnoreWordsWithDigits | Whether to ignore words with numbers in them (eg. A10 or 7-11).
 | IgnoreXML | Whether to ignore XML tags in the text.
 | LanguageParser | The type of language parsing to use.
 | LookIntoHyphenatedText | Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
 | LookUp(String) | Looks up word in the dictionary, returns true if it is in there.
 | NextBadWord()()()() | Gets the next bad word in the list that was identified by Check.
 | RevertToUndoableStatePoint(RapidSpellChecker..::..State) | Reverts the state to that it was when GetUndoableStatePoint()()()() was called.
 | SetConsiderationRange(Int32) | Sets the breadth of the suggestions search.
 | SetDictFileStream(Stream, String, DateTime) | Passes a Dict file as a stream, to be used for the main dictionary.
 | SetIgnoreCapitalizedWords(Boolean) | Sets whether to ignore capitalized words.
 | SetIncludeUserDictionaryInSuggestions(Boolean) | Sets whether to include the user dictionary in suggestions taken from this engine.
 | SetOptionalContext(String, String) | Provides the engine with any helpful text around the text snippet which will be passed to the Check method. Implementation is not required.
 | SetPosition(Int32) | Sets the pointer position for the NextBadWord iterator.
 | SetSeparateHyphenWords(Boolean) | Sets whether to separate words with hyphens in them into separate words.
 | SetSuggestionsMethod(Int32) | Sets the suggestions method, where method is an integer identifier.
 | SetUserDictionary(UserDictionary) | Sets the UserDictionary object to be used as a user dictionary source.
 | SetUserDictionary(String) | Sets the UserDictionary file path to be used as a user dictionary source.
 | SuggestSplitWords | Whether to look for connected words in suggestions.
 | TextBoundary | The AdvancedTextBoundary class to use to parse words.
 | userDictionary | The user dictionary, this should be null (C#) or nothing (VB.NET) if no user dictionary is being used.
 | V2Parser | Whether to use parser version 2 (specific to RapidSpellChecker).
 | WarnDuplicates | Whether to treat duplicate words as errors (eg. "this is is an error").
Remarks
This is the interface which any checker engine must have, by implementing this interface any object can be used to parse text and identify 'bad words'. It is not necessary to functionally implement all members, for this reason an abstract empty implementation class is provided (CheckerEngineAdapter) which can be extended and overridden for desired functionality.


AddWord Method (word)

AddWord Method (word)
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► AddWord(String)
Keyoti RapidSpell Web .NET
Adds a word to the user dictionary, if it exists.
Declaration Syntax
C# Visual Basic Visual C++ F#
bool AddWord(
    string word
)
Function AddWord (
    word As String
) As Boolean
bool AddWord(
    String^ word
)
abstract AddWord :
        word : string -> bool
Parameters
word (String)
Return Value
Boolean
Remarks
Should return true if the word was added successfully, false otherwise.


AllowAnyCase Property

AllowAnyCase Property
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► AllowAnyCase
Keyoti RapidSpell Web .NET
Whether to allow words spelt with any case, eg. "africa" instead of "Africa", this is more relaxed than AllowMixedCase.
Declaration Syntax
C# Visual Basic Visual C++ F#
bool AllowAnyCase { get; set; }
Property AllowAnyCase As Boolean
    Get
    Set
property bool AllowAnyCase {
    bool get ();
    void set (bool value);
}
abstract AllowAnyCase : bool with get, set
Property Value
Boolean


AllowMixedCase Property

AllowMixedCase Property
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► AllowMixedCase
Keyoti RapidSpell Web .NET
Whether to allow words spelt with mixed case, eg. "MIxEd"
Declaration Syntax
C# Visual Basic Visual C++ F#
bool AllowMixedCase { get; set; }
Property AllowMixedCase As Boolean
    Get
    Set
property bool AllowMixedCase {
    bool get ();
    void set (bool value);
}
abstract AllowMixedCase : bool with get, set
Property Value
Boolean


ChangeBadWord Method

ChangeBadWord Method
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► ChangeBadWord()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | ChangeBadWord(String) | Changes the current bad word to newWord in the text.
 | ChangeBadWord(BadWord, String) | Changes badWord to newWord in the text.


ChangeBadWord Method (badWord, newWord)

ChangeBadWord Method (badWord, newWord)
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► ChangeBadWord(BadWord, String)
Keyoti RapidSpell Web .NET
Changes badWord to newWord in the text.
Declaration Syntax
C# Visual Basic Visual C++ F#
void ChangeBadWord(
    BadWord badWord,
    string newWord
)
Sub ChangeBadWord (
    badWord As BadWord,
    newWord As String
)
void ChangeBadWord(
    BadWord^ badWord,
    String^ newWord
)
abstract ChangeBadWord :
        badWord : BadWord *
        newWord : string -> unit
Parameters
badWord (BadWord)
the word to reaplce
newWord (String)
replaces the current misspelt word.
Return Value

void
Exceptions
Exception | Condition
ArgumentNullException | if newWord parameter is null.


ChangeBadWord Method (newWord)

ChangeBadWord Method (newWord)
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► ChangeBadWord(String)
Keyoti RapidSpell Web .NET
Changes the current bad word to newWord in the text.
Declaration Syntax
C# Visual Basic Visual C++ F#
void ChangeBadWord(
    string newWord
)
Sub ChangeBadWord (
    newWord As String
)
void ChangeBadWord(
    String^ newWord
)
abstract ChangeBadWord :
        newWord : string -> unit
Parameters
newWord (String)
replaces the current misspelt word.
Return Value

void
Exceptions
Exception | Condition
NoCurrentBadWordException | if nextBadWord() hasn't been run first AND found an erroneous word.
ArgumentNullException | if newWord parameter is null.


Check Method

Check Method
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► Check()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | Check(String) | Checks the text for errors.
 | Check(String, Boolean) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.


Check Method (text)

Check Method (text)
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► Check(String)
Keyoti RapidSpell Web .NET
Checks the text for errors.
Declaration Syntax
C# Visual Basic Visual C++ F#
void Check(
    string text
)
Sub Check (
    text As String
)
void Check(
    String^ text
)
abstract Check :
        text : string -> unit
Parameters
text (String)
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


Check Method (text, isStartOfTextBody)

Check Method (text, isStartOfTextBody)
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► Check(String, Boolean)
Keyoti RapidSpell Web .NET
Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
Declaration Syntax
C# Visual Basic Visual C++ F#
void Check(
    string text,
    bool isStartOfTextBody
)
Sub Check (
    text As String,
    isStartOfTextBody As Boolean
)
void Check(
    String^ text,
    bool isStartOfTextBody
)
abstract Check :
        text : string *
        isStartOfTextBody : bool -> unit
Parameters
text (String)
to spell check.
isStartOfTextBody (Boolean)
whether the text being spell checked is at the start of the text body (eg. start of text box), this affects sentence capitalization determination.
Return Value

void
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


CheckCompoundWords Property

CheckCompoundWords Property
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► CheckCompoundWords
Keyoti RapidSpell Web .NET
Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
Declaration Syntax
C# Visual Basic Visual C++ F#
bool CheckCompoundWords { get; set; }
Property CheckCompoundWords As Boolean
    Get
    Set
property bool CheckCompoundWords {
    bool get ();
    void set (bool value);
}
abstract CheckCompoundWords : bool with get, set
Property Value
Boolean
Remarks
If this=false then LookUp("thesewordsarejoined") = false

If this=true then LookUp("thesewordsarejoined") = true

If this=false then LookUp("abcdef") = false

If this=true then LookUp("abcdef") = false

Setting this to true will degrade lookup performance


CurrentBadWord Property

CurrentBadWord Property
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► CurrentBadWord
Keyoti RapidSpell Web .NET
Gets the current bad word (last returned by NextBadWord).
Declaration Syntax
C# Visual Basic Visual C++ F#
BadWord CurrentBadWord { get; }
ReadOnly Property CurrentBadWord As BadWord
    Get
property BadWord^ CurrentBadWord {
    BadWord^ get ();
}
abstract CurrentBadWord : BadWord with get
Property Value
BadWord


DictFilePath Property

DictFilePath Property
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► DictFilePath
Keyoti RapidSpell Web .NET
The file to be used as the main dictionary, if this is null then the RapidSpellMDict.DLL satellite assembly is used.
Declaration Syntax
C# Visual Basic Visual C++ F#
string DictFilePath { get; set; }
Property DictFilePath As String
    Get
    Set
property String^ DictFilePath {
    String^ get ();
    void set (String^ value);
}
abstract DictFilePath : string with get, set
Property Value
String


FindCapitalizedSuggestions Property

FindCapitalizedSuggestions Property
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► FindCapitalizedSuggestions
Keyoti RapidSpell Web .NET
Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
Declaration Syntax
C# Visual Basic Visual C++ F#
bool FindCapitalizedSuggestions { get; set; }
Property FindCapitalizedSuggestions As Boolean
    Get
    Set
property bool FindCapitalizedSuggestions {
    bool get ();
    void set (bool value);
}
abstract FindCapitalizedSuggestions : bool with get, set
Property Value
Boolean


FindSuggestions Method

FindSuggestions Method
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► FindSuggestions()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | FindSuggestions()()()() | Returns an ArrayList of Strings that are suitable suggestions for the current bad word (that is, the one last returned by NextBadWord()).
 | FindSuggestions(String) | Returns an ArrayList of Strings that are suitable suggestions for word.


FindSuggestions Method

FindSuggestions Method
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► FindSuggestions()()()()
Keyoti RapidSpell Web .NET
Returns an ArrayList of Strings that are suitable suggestions for the current bad word (that is, the one last returned by NextBadWord()).
Declaration Syntax
C# Visual Basic Visual C++ F#
ArrayList FindSuggestions()
Function FindSuggestions As ArrayList
ArrayList^ FindSuggestions()
abstract FindSuggestions : unit -> ArrayList
Return Value
ArrayList
Remarks
If no suggestions can be found, this should return an empty ArrayList. This method should be thread safe if operating with RapidSpell Desktop.
Exceptions
Exception | Condition
NoCurrentBadWordException | If NextBadWord() hasn't been run first AND found an erroneous word.


FindSuggestions Method (word)

FindSuggestions Method (word)
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► FindSuggestions(String)
Keyoti RapidSpell Web .NET
Returns an ArrayList of Strings that are suitable suggestions for word.
Declaration Syntax
C# Visual Basic Visual C++ F#
ArrayList FindSuggestions(
    string word
)
Function FindSuggestions (
    word As String
) As ArrayList
ArrayList^ FindSuggestions(
    String^ word
)
abstract FindSuggestions :
        word : string -> ArrayList
Parameters
word (String)
Return Value
ArrayList
Remarks
If no suggestions can be found, this should return an empty ArrayList. This method should be thread safe if operating with RapidSpell Desktop.


GetConsiderationRange Method

GetConsiderationRange Method
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► GetConsiderationRange()()()()
Keyoti RapidSpell Web .NET
Gets the factor for words to consider for suggestions.
Declaration Syntax
C# Visual Basic Visual C++ F#
int GetConsiderationRange()
Function GetConsiderationRange As Integer
int GetConsiderationRange()
abstract GetConsiderationRange : unit -> int
Return Value
Int32


GetIgnoreCapitalizedWords Method

GetIgnoreCapitalizedWords Method
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► GetIgnoreCapitalizedWords()()()()
Keyoti RapidSpell Web .NET
Gets whether to ignore words that start with capital letters.
Declaration Syntax
C# Visual Basic Visual C++ F#
bool GetIgnoreCapitalizedWords()
Function GetIgnoreCapitalizedWords As Boolean
bool GetIgnoreCapitalizedWords()
abstract GetIgnoreCapitalizedWords : unit -> bool
Return Value
Boolean


GetIncludeUserDictionaryInSuggestions Method

GetIncludeUserDictionaryInSuggestions Method
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► GetIncludeUserDictionaryInSuggestions()()()()
Keyoti RapidSpell Web .NET
Gets whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# Visual Basic Visual C++ F#
bool GetIncludeUserDictionaryInSuggestions()
Function GetIncludeUserDictionaryInSuggestions As Boolean
bool GetIncludeUserDictionaryInSuggestions()
abstract GetIncludeUserDictionaryInSuggestions : unit -> bool
Return Value
Boolean


GetSuggestionsMethod Method

GetSuggestionsMethod Method
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► GetSuggestionsMethod()()()()
Keyoti RapidSpell Web .NET
Gets the suggestions method, where method is an integer identifier.
Declaration Syntax
C# Visual Basic Visual C++ F#
int GetSuggestionsMethod()
Function GetSuggestionsMethod As Integer
int GetSuggestionsMethod()
abstract GetSuggestionsMethod : unit -> int
Return Value
Int32


GetUndoableStatePoint Method

GetUndoableStatePoint Method
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► GetUndoableStatePoint()()()()
Keyoti RapidSpell Web .NET
Gets the state of the current run, which can be stored and used with RevertToUndoableStatePoint(RapidSpellChecker..::..State)
Declaration Syntax
C# Visual Basic Visual C++ F#
RapidSpellChecker..::..State GetUndoableStatePoint()
Function GetUndoableStatePoint As RapidSpellChecker..::..State
RapidSpellChecker..::..State^ GetUndoableStatePoint()
abstract GetUndoableStatePoint : unit -> RapidSpellChecker..::..State
Return Value
RapidSpellChecker..::..State
Returns the current state, or null if not supporting undo.


IgnoreAll Method (word)

IgnoreAll Method (word)
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► IgnoreAll(String)
Keyoti RapidSpell Web .NET
Marks word to be ignored in rest of the text.
Declaration Syntax
C# Visual Basic Visual C++ F#
void IgnoreAll(
    string word
)
Sub IgnoreAll (
    word As String
)
void IgnoreAll(
    String^ word
)
abstract IgnoreAll :
        word : string -> unit
Parameters
word (String)
to ignore
Return Value

void
Exceptions
Exception | Condition
ArgumentNullException | if word parameter is null.


IgnoreIncorrectSentenceCapitalization Property

IgnoreIncorrectSentenceCapitalization Property
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► IgnoreIncorrectSentenceCapitalization
Keyoti RapidSpell Web .NET
Whether to ignore incorrect sentence capitalization.
Declaration Syntax
C# Visual Basic Visual C++ F#
bool IgnoreIncorrectSentenceCapitalization { get; set; }
Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
property bool IgnoreIncorrectSentenceCapitalization {
    bool get ();
    void set (bool value);
}
abstract IgnoreIncorrectSentenceCapitalization : bool with get, set
Property Value
Boolean


IgnoreInEnglishLowerCaseI Property

IgnoreInEnglishLowerCaseI Property
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► IgnoreInEnglishLowerCaseI
Keyoti RapidSpell Web .NET
Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
Declaration Syntax
C# Visual Basic Visual C++ F#
bool IgnoreInEnglishLowerCaseI { get; set; }
Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
property bool IgnoreInEnglishLowerCaseI {
    bool get ();
    void set (bool value);
}
abstract IgnoreInEnglishLowerCaseI : bool with get, set
Property Value
Boolean


IgnoreList Property

IgnoreList Property
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► IgnoreList
Keyoti RapidSpell Web .NET
The words to ignore, note this list is changed by IgnoreAll.
Declaration Syntax
C# Visual Basic Visual C++ F#
ArrayList IgnoreList { get; set; }
Property IgnoreList As ArrayList
    Get
    Set
property ArrayList^ IgnoreList {
    ArrayList^ get ();
    void set (ArrayList^ value);
}
abstract IgnoreList : ArrayList with get, set
Property Value
ArrayList


IgnoreURLsAndEmailAddresses Property

IgnoreURLsAndEmailAddresses Property
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► IgnoreURLsAndEmailAddresses
Keyoti RapidSpell Web .NET
Whether to ignore URLs and email addresses (requires V2Parser=true)
Declaration Syntax
C# Visual Basic Visual C++ F#
bool IgnoreURLsAndEmailAddresses { get; set; }
Property IgnoreURLsAndEmailAddresses As Boolean
    Get
    Set
property bool IgnoreURLsAndEmailAddresses {
    bool get ();
    void set (bool value);
}
abstract IgnoreURLsAndEmailAddresses : bool with get, set
Property Value
Boolean
Remarks
This will cause the following strings to be accepted as non-spelling errors;
"user@domain.com", "http://www.domain.com", "domain.co.uk" etc.


IgnoreWordsWithDigits Property

IgnoreWordsWithDigits Property
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► IgnoreWordsWithDigits
Keyoti RapidSpell Web .NET
Whether to ignore words with numbers in them (eg. A10 or 7-11).
Declaration Syntax
C# Visual Basic Visual C++ F#
bool IgnoreWordsWithDigits { get; set; }
Property IgnoreWordsWithDigits As Boolean
    Get
    Set
property bool IgnoreWordsWithDigits {
    bool get ();
    void set (bool value);
}
abstract IgnoreWordsWithDigits : bool with get, set
Property Value
Boolean


IgnoreXML Property

IgnoreXML Property
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► IgnoreXML
Keyoti RapidSpell Web .NET
Whether to ignore XML tags in the text.
Declaration Syntax
C# Visual Basic Visual C++ F#
bool IgnoreXML { get; set; }
Property IgnoreXML As Boolean
    Get
    Set
property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
abstract IgnoreXML : bool with get, set
Property Value
Boolean


LanguageParser Property

LanguageParser Property
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► LanguageParser
Keyoti RapidSpell Web .NET
The type of language parsing to use.
Declaration Syntax
C# Visual Basic Visual C++ F#
LanguageType LanguageParser { get; set; }
Property LanguageParser As LanguageType
    Get
    Set
property LanguageType LanguageParser {
    LanguageType get ();
    void set (LanguageType value);
}
abstract LanguageParser : LanguageType with get, set
Return Value
LanguageType
This implementation always returns ENGLISH.
Remarks
Eg. If the dictionary is set to French, you should use the French parser.


LookIntoHyphenatedText Property

LookIntoHyphenatedText Property
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► LookIntoHyphenatedText
Keyoti RapidSpell Web .NET
Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
Declaration Syntax
C# Visual Basic Visual C++ F#
bool LookIntoHyphenatedText { get; set; }
Property LookIntoHyphenatedText As Boolean
    Get
    Set
property bool LookIntoHyphenatedText {
    bool get ();
    void set (bool value);
}
abstract LookIntoHyphenatedText : bool with get, set
Property Value
Boolean
Remarks
Eg. "socio-economic" will be checked as "socio" and "economic".


LookUp Method (word)

LookUp Method (word)
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► LookUp(String)
Keyoti RapidSpell Web .NET
Looks up word in the dictionary, returns true if it is in there.
Declaration Syntax
C# Visual Basic Visual C++ F#
bool LookUp(
    string word
)
Function LookUp (
    word As String
) As Boolean
bool LookUp(
    String^ word
)
abstract LookUp :
        word : string -> bool
Parameters
word (String)
Return Value
Boolean


NextBadWord Method

NextBadWord Method
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► NextBadWord()()()()
Keyoti RapidSpell Web .NET
Gets the next bad word in the list that was identified by Check.
Declaration Syntax
C# Visual Basic Visual C++ F#
BadWord NextBadWord()
Function NextBadWord As BadWord
BadWord^ NextBadWord()
abstract NextBadWord : unit -> BadWord
Return Value
BadWord
The next BadWord object from the text, must return null (C#) or nothing (VB.NET) when no more bad words exist.
Remarks
Check must be called before this method.


RevertToUndoableStatePoint Method (state)

RevertToUndoableStatePoint Method (state)
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► RevertToUndoableStatePoint(RapidSpellChecker..::..State)
Keyoti RapidSpell Web .NET
Reverts the state to that it was when GetUndoableStatePoint()()()() was called.
Declaration Syntax
C# Visual Basic Visual C++ F#
void RevertToUndoableStatePoint(
    RapidSpellChecker..::..State state
)
Sub RevertToUndoableStatePoint (
    state As RapidSpellChecker..::..State
)
void RevertToUndoableStatePoint(
    RapidSpellChecker..::..State^ state
)
abstract RevertToUndoableStatePoint :
        state : RapidSpellChecker..::..State -> unit
Parameters
state (RapidSpellChecker..::..State)


SetConsiderationRange Method (range)

SetConsiderationRange Method (range)
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► SetConsiderationRange(Int32)
Keyoti RapidSpell Web .NET
Sets the breadth of the suggestions search.
Declaration Syntax
C# Visual Basic Visual C++ F#
void SetConsiderationRange(
    int range
)
Sub SetConsiderationRange (
    range As Integer
)
void SetConsiderationRange(
    int range
)
abstract SetConsiderationRange :
        range : int -> unit
Parameters
range (Int32)


SetDictFileStream Method (dictFileStream, id, modifiedDate)

SetDictFileStream Method (dictFileStream, id, modifiedDate)
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► SetDictFileStream(Stream, String, DateTime)
Keyoti RapidSpell Web .NET
Passes a Dict file as a stream, to be used for the main dictionary.
Declaration Syntax
C# Visual Basic Visual C++ F#
void SetDictFileStream(
    Stream dictFileStream,
    string id,
    DateTime modifiedDate
)
Sub SetDictFileStream (
    dictFileStream As Stream,
    id As String,
    modifiedDate As DateTime
)
void SetDictFileStream(
    Stream^ dictFileStream,
    String^ id,
    DateTime modifiedDate
)
abstract SetDictFileStream :
        dictFileStream : Stream *
        id : string *
        modifiedDate : DateTime -> unit
Parameters
dictFileStream (Stream)
The stream containing the dictionary
id (String)
When the dictionary was modified, use .Now to update the cache.
modifiedDate (DateTime)
Remarks
Note this method must be set before Check is called, and the stream position must be at beginning of Dict file. The stream is NOT closed by this method.


SetIgnoreCapitalizedWords Method (ignore)

SetIgnoreCapitalizedWords Method (ignore)
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► SetIgnoreCapitalizedWords(Boolean)
Keyoti RapidSpell Web .NET
Sets whether to ignore capitalized words.
Declaration Syntax
C# Visual Basic Visual C++ F#
void SetIgnoreCapitalizedWords(
    bool ignore
)
Sub SetIgnoreCapitalizedWords (
    ignore As Boolean
)
void SetIgnoreCapitalizedWords(
    bool ignore
)
abstract SetIgnoreCapitalizedWords :
        ignore : bool -> unit
Parameters
ignore (Boolean)


SetIncludeUserDictionaryInSuggestions Method (includeUserDictionaryInSuggestions)

SetIncludeUserDictionaryInSuggestions Method (includeUserDictionaryInSuggestions)
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► SetIncludeUserDictionaryInSuggestions(Boolean)
Keyoti RapidSpell Web .NET
Sets whether to include the user dictionary in suggestions taken from this engine.
Declaration Syntax
C# Visual Basic Visual C++ F#
void SetIncludeUserDictionaryInSuggestions(
    bool includeUserDictionaryInSuggestions
)
Sub SetIncludeUserDictionaryInSuggestions (
    includeUserDictionaryInSuggestions As Boolean
)
void SetIncludeUserDictionaryInSuggestions(
    bool includeUserDictionaryInSuggestions
)
abstract SetIncludeUserDictionaryInSuggestions :
        includeUserDictionaryInSuggestions : bool -> unit
Parameters
includeUserDictionaryInSuggestions (Boolean)


SetOptionalContext Method (beforeToCheckSnippet, afterToCheckSnippet)

SetOptionalContext Method (beforeToCheckSnippet, afterToCheckSnippet)
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► SetOptionalContext(String, String)
Keyoti RapidSpell Web .NET
Provides the engine with any helpful text around the text snippet which will be passed to the Check method. Implementation is not required.
Declaration Syntax
C# Visual Basic Visual C++ F#
void SetOptionalContext(
    string beforeToCheckSnippet,
    string afterToCheckSnippet
)
Sub SetOptionalContext (
    beforeToCheckSnippet As String,
    afterToCheckSnippet As String
)
void SetOptionalContext(
    String^ beforeToCheckSnippet,
    String^ afterToCheckSnippet
)
abstract SetOptionalContext :
        beforeToCheckSnippet : string *
        afterToCheckSnippet : string -> unit
Parameters
beforeToCheckSnippet (String)
Any text before the to check snippet
afterToCheckSnippet (String)
Any text after the snippet
Remarks
Eg. if the document contains "This is an an example piece." and Check will be called on "an example piece", then the fact that 'an' is duplicated will not be detected. Therefore, by passing "This is an " to beforeToCheckSnippet the checker will be able to detect that an is duplicated.


SetPosition Method (pos)

SetPosition Method (pos)
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► SetPosition(Int32)
Keyoti RapidSpell Web .NET
Sets the pointer position for the NextBadWord iterator.
Declaration Syntax
C# Visual Basic Visual C++ F#
void SetPosition(
    int pos
)
Sub SetPosition (
    pos As Integer
)
void SetPosition(
    int pos
)
abstract SetPosition :
        pos : int -> unit
Parameters
pos (Int32)
Remarks
Further calls to NextBadWord will look for the next bad word from position pos. If position > the text length it is set to the text length. If position < 0, it is set to zero.


SetSeparateHyphenWords Method (separate)

SetSeparateHyphenWords Method (separate)
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► SetSeparateHyphenWords(Boolean)
Keyoti RapidSpell Web .NET
Sets whether to separate words with hyphens in them into separate words.
Declaration Syntax
C# Visual Basic Visual C++ F#
void SetSeparateHyphenWords(
    bool separate
)
Sub SetSeparateHyphenWords (
    separate As Boolean
)
void SetSeparateHyphenWords(
    bool separate
)
abstract SetSeparateHyphenWords :
        separate : bool -> unit
Parameters
separate (Boolean)


SetSuggestionsMethod Method (method)

SetSuggestionsMethod Method (method)
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► SetSuggestionsMethod(Int32)
Keyoti RapidSpell Web .NET
Sets the suggestions method, where method is an integer identifier.
Declaration Syntax
C# Visual Basic Visual C++ F#
void SetSuggestionsMethod(
    int method
)
Sub SetSuggestionsMethod (
    method As Integer
)
void SetSuggestionsMethod(
    int method
)
abstract SetSuggestionsMethod :
        method : int -> unit
Parameters
method (Int32)


SetUserDictionary Method

SetUserDictionary Method
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► SetUserDictionary()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | SetUserDictionary(UserDictionary) | Sets the UserDictionary object to be used as a user dictionary source.
 | SetUserDictionary(String) | Sets the UserDictionary file path to be used as a user dictionary source.


SetUserDictionary Method (userDictionary)

SetUserDictionary Method (userDictionary)
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► SetUserDictionary(UserDictionary)
Keyoti RapidSpell Web .NET
Sets the UserDictionary object to be used as a user dictionary source.
Declaration Syntax
C# Visual Basic Visual C++ F#
void SetUserDictionary(
    UserDictionary userDictionary
)
Sub SetUserDictionary (
    userDictionary As UserDictionary
)
void SetUserDictionary(
    UserDictionary^ userDictionary
)
abstract SetUserDictionary :
        userDictionary : UserDictionary -> unit
Parameters
userDictionary (UserDictionary)


SetUserDictionary Method (userDictionary)

SetUserDictionary Method (userDictionary)
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► SetUserDictionary(String)
Keyoti RapidSpell Web .NET
Sets the UserDictionary file path to be used as a user dictionary source.
Declaration Syntax
C# Visual Basic Visual C++ F#
void SetUserDictionary(
    string userDictionary
)
Sub SetUserDictionary (
    userDictionary As String
)
void SetUserDictionary(
    String^ userDictionary
)
abstract SetUserDictionary :
        userDictionary : string -> unit
Parameters
userDictionary (String)


SuggestSplitWords Property

SuggestSplitWords Property
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► SuggestSplitWords
Keyoti RapidSpell Web .NET
Whether to look for connected words in suggestions.
Declaration Syntax
C# Visual Basic Visual C++ F#
bool SuggestSplitWords { get; set; }
Property SuggestSplitWords As Boolean
    Get
    Set
property bool SuggestSplitWords {
    bool get ();
    void set (bool value);
}
abstract SuggestSplitWords : bool with get, set
Property Value
Boolean
Remarks
if this=true then suggestions may include joined words.

Eg; suggestions for "myhouse" will include "my house"


TextBoundary Property

TextBoundary Property
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► TextBoundary
Keyoti RapidSpell Web .NET
The AdvancedTextBoundary class to use to parse words.
Declaration Syntax
C# Visual Basic Visual C++ F#
AdvancedTextBoundary TextBoundary { get; set; }
Property TextBoundary As AdvancedTextBoundary
    Get
    Set
property AdvancedTextBoundary^ TextBoundary {
    AdvancedTextBoundary^ get ();
    void set (AdvancedTextBoundary^ value);
}
abstract TextBoundary : AdvancedTextBoundary with get, set
Property Value
AdvancedTextBoundary


userDictionary Property

userDictionary Property
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► userDictionary
Keyoti RapidSpell Web .NET
The user dictionary, this should be null (C#) or nothing (VB.NET) if no user dictionary is being used.
Declaration Syntax
C# Visual Basic Visual C++ F#
UserDictionary userDictionary { get; }
ReadOnly Property userDictionary As UserDictionary
    Get
property UserDictionary^ userDictionary {
    UserDictionary^ get ();
}
abstract userDictionary : UserDictionary with get
Property Value
UserDictionary


V2Parser Property

V2Parser Property
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► V2Parser
Keyoti RapidSpell Web .NET
Whether to use parser version 2 (specific to RapidSpellChecker).
Declaration Syntax
C# Visual Basic Visual C++ F#
bool V2Parser { get; set; }
Property V2Parser As Boolean
    Get
    Set
property bool V2Parser {
    bool get ();
    void set (bool value);
}
abstract V2Parser : bool with get, set
Property Value
Boolean


WarnDuplicates Property

WarnDuplicates Property
API Documentation ► Keyoti.RapidSpell ► ICheckerEngine ► WarnDuplicates
Keyoti RapidSpell Web .NET
Whether to treat duplicate words as errors (eg. "this is is an error").
Declaration Syntax
C# Visual Basic Visual C++ F#
bool WarnDuplicates { get; set; }
Property WarnDuplicates As Boolean
    Get
    Set
property bool WarnDuplicates {
    bool get ();
    void set (bool value);
}
abstract WarnDuplicates : bool with get, set
Property Value
Boolean


LanguageType Enumeration

LanguageType Enumeration
API Documentation ► Keyoti.RapidSpell ► LanguageType
Keyoti RapidSpell Web .NET
Enumeration of language types.
Declaration Syntax
C# Visual Basic Visual C++ F#
public enum LanguageType
Public Enumeration LanguageType
public enum class LanguageType
type LanguageType
Members
Member | Description
ENGLISH | English.
DUTCH | Dutch.
FRENCH | French.
GERMAN | German.
ITALIAN | Italian.
PORTUGUESE | Portuguese.
SPANISH | Spanish.
POLISH | Polish.


Layout Class

Layout Class
API Documentation ► Keyoti.RapidSpell ► Layout
Keyoti RapidSpell Web .NET
The template used to layout the RapidSpellWeb control.
Declaration Syntax
C# Visual Basic Visual C++ F#
public class Layout
Public Class Layout
public ref class Layout
type Layout =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Layout()()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | Html | The Html template used to layout this control.
 | HtmlArray | The Html template used to layout this control as an array.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Remarks
Set Html in this object to define the layout, using the following layout identifiers; <PreviewPane/> <IgnoreButton/> <IgnoreAllButton/> <ChangeButton/> <ChangeAllButton/> <FinishButton/> <ChangeToLabel/> <ChangeToBox/> <SuggestionsLabel/> <SuggestionsBox/> <AddButton/> <UndoButton/> <FieldDisplayLabel/> These MUST be on lines by themselves, with no other characters.
Inheritance Hierarchy
Object
Layout


Layout Constructor

Layout Constructor
API Documentation ► Keyoti.RapidSpell ► Layout ► Layout()()()()
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public Layout()
Public Sub New
public:
Layout()
new : unit -> Layout


Html Property

Html Property
API Documentation ► Keyoti.RapidSpell ► Layout ► Html
Keyoti RapidSpell Web .NET
The Html template used to layout this control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string Html { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Html As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ Html {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member Html : string with get, set
Property Value
String


HtmlArray Property

HtmlArray Property
API Documentation ► Keyoti.RapidSpell ► Layout ► HtmlArray
Keyoti RapidSpell Web .NET
The Html template used to layout this control as an array.
Declaration Syntax
C# Visual Basic Visual C++ F#
public string[] HtmlArray { get; }
Public ReadOnly Property HtmlArray As String()
    Get
public:
property array<String^>^ HtmlArray {
    array<String^>^ get ();
}
member HtmlArray : string[] with get
Property Value
array< String >[]()[][]


LayoutBuilder Class

LayoutBuilder Class
API Documentation ► Keyoti.RapidSpell ► LayoutBuilder
Keyoti RapidSpell Web .NET
RapidSpell layout builder
Declaration Syntax
C# Visual Basic Visual C++ F#
public class LayoutBuilder : ControlBuilder
Public Class LayoutBuilder
    Inherits ControlBuilder
public ref class LayoutBuilder : public ControlBuilder
type LayoutBuilder =
    class
        inherit ControlBuilder
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LayoutBuilder()()()() |
 | AllowWhitespaceLiterals()()()() | Returns true (Overrides ControlBuilder.AllowWhitespaceLiterals()()()().)
 | AppendLiteralString(String) | Adds the specified literal content to a control. This method is called by the ASP.NET page framework. (Inherited from ControlBuilder.)
 | AppendSubBuilder(ControlBuilder) | Adds builders to the ControlBuilder object for any child controls that belong to the container control. (Inherited from ControlBuilder.)
 | BindingContainerBuilder | (Inherited from ControlBuilder.)
 | BindingContainerType | Gets the type of the binding container for the control that this builder creates. (Inherited from ControlBuilder.)
 | BuildObject()()()() | Builds a design-time instance of the control that is referred to by this ControlBuilder object. (Inherited from ControlBuilder.)
 | CloseControl()()()() | Called by the parser to inform the builder that the parsing of the control's opening and closing tags is complete. (Inherited from ControlBuilder.)
 | ComplexPropertyEntries | (Inherited from ControlBuilder.)
 | ControlType | Gets the Type for the control to be created. (Inherited from ControlBuilder.)
 | CurrentFilterResolutionService | Gets an IFilterResolutionService object that is used to manage device-filter related services when parsing and persisting controls in the designer. (Inherited from ControlBuilder.)
 | DeclareType | Gets the type that will be used by code generation to declare the control. (Inherited from ControlBuilder.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FChildrenAsProperties | Determines whether the control has a ParseChildrenAttribute with ChildrenAsProperties set to true. (Inherited from ControlBuilder.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FIsNonParserAccessor | Determines whether the control implements the IParserAccessor interface. (Inherited from ControlBuilder.)
 | GetChildControlType(String, IDictionary) | Returns null (Overrides ControlBuilder.GetChildControlType(String, IDictionary).)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectPersistData()()()() | Creates the ObjectPersistData object for this ControlBuilder object. (Inherited from ControlBuilder.)
 | GetResourceKey()()()() | Retrieves the resource key for this ControlBuilder object. (Inherited from ControlBuilder.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | HasAspCode | Gets a value indicating whether the control contains any code blocks. (Inherited from ControlBuilder.)
 | HasBody()()()() | Determines if a control has both an opening and closing tag. This method is called by the ASP.NET page framework. (Inherited from ControlBuilder.)
 | HtmlDecodeLiterals()()()() | Determines whether the literal string of an HTML control must be HTML decoded. This method is called by the ASP.NET page framework. (Inherited from ControlBuilder.)
 | ID | Gets or sets the identifier property for the control to be built. (Inherited from ControlBuilder.)
 | InDesigner | Returns whether the ControlBuilder is running in the designer. (Inherited from ControlBuilder.)
 | Init(TemplateParser, ControlBuilder, Type, String, String, IDictionary) | Initializes the ControlBuilder for use after it is instantiated. This method is called by the ASP.NET page framework. (Inherited from ControlBuilder.)
 | InPageTheme | Gets a Boolean value indicating whether this ControlBuilder object is used to generate page themes. (Inherited from ControlBuilder.)
 | ItemType | (Inherited from ControlBuilder.)
 | Localize | Gets a Boolean value indicating whether the control that is created by this ControlBuilder object is localized. (Inherited from ControlBuilder.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainerType | Gets the type of the naming container for the control that this builder creates. (Inherited from ControlBuilder.)
 | NeedsTagInnerText()()()() | Determines if the control builder needs to get its inner text. If so, the SetTagInnerText(String) method must be called. This method is called by the ASP.NET page framework. (Inherited from ControlBuilder.)
 | OnAppendToParentBuilder(ControlBuilder) | Notifies the ControlBuilder that it is being added to a parent control builder. (Inherited from ControlBuilder.)
 | PageVirtualPath | (Inherited from ControlBuilder.)
 | Parser | Gets the TemplateParser responsible for parsing the control. (Inherited from ControlBuilder.)
 | ProcessGeneratedCode(CodeCompileUnit, CodeTypeDeclaration, CodeTypeDeclaration, CodeMemberMethod, CodeMemberMethod) | Enables custom control builders to access the generated Code Document Object Model (CodeDom) and insert and modify code during the process of parsing and building controls. (Inherited from ControlBuilder.)
 | ServiceProvider | Gets the service object for this ControlBuilder object. (Inherited from ControlBuilder.)
 | SetResourceKey(String) | Sets the resource key for this ControlBuilder object. (Inherited from ControlBuilder.)
 | SetServiceProvider(IServiceProvider) | Sets the service object for this ControlBuilder object. (Inherited from ControlBuilder.)
 | SetTagInnerText(String) | Provides the ControlBuilder with the inner text of the control tag. (Inherited from ControlBuilder.)
 | SubBuilders | (Inherited from ControlBuilder.)
 | TagName | Gets the tag name for the control to be built. (Inherited from ControlBuilder.)
 | TemplatePropertyEntries | (Inherited from ControlBuilder.)
 | ThemeResolutionService | Gets an IThemeResolutionService object that is used in design time to manage control themes and skins. (Inherited from ControlBuilder.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ControlBuilder
 |  | LayoutBuilder


LayoutBuilder Constructor

LayoutBuilder Constructor
API Documentation ► Keyoti.RapidSpell ► LayoutBuilder ► LayoutBuilder()()()()
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public LayoutBuilder()
Public Sub New
public:
LayoutBuilder()
new : unit -> LayoutBuilder


AllowWhitespaceLiterals Method

AllowWhitespaceLiterals Method
API Documentation ► Keyoti.RapidSpell ► LayoutBuilder ► AllowWhitespaceLiterals()()()()
Keyoti RapidSpell Web .NET
Returns true
Declaration Syntax
C# Visual Basic Visual C++ F#
public override bool AllowWhitespaceLiterals()
Public Overrides Function AllowWhitespaceLiterals As Boolean
public:
virtual bool AllowWhitespaceLiterals() override
abstract AllowWhitespaceLiterals : unit -> bool
override AllowWhitespaceLiterals : unit -> bool
Return Value
Boolean


GetChildControlType Method (tagName, attributes)

GetChildControlType Method (tagName, attributes)
API Documentation ► Keyoti.RapidSpell ► LayoutBuilder ► GetChildControlType(String, IDictionary)
Keyoti RapidSpell Web .NET
Returns null
Declaration Syntax
C# Visual Basic Visual C++ F#
public override Type GetChildControlType(
    string tagName,
    IDictionary attributes
)
Public Overrides Function GetChildControlType (
    tagName As String,
    attributes As IDictionary
) As Type
public:
virtual Type^ GetChildControlType(
    String^ tagName,
    IDictionary^ attributes
) override
abstract GetChildControlType :
        tagName : string *
        attributes : IDictionary -> Type
override GetChildControlType :
        tagName : string *
        attributes : IDictionary -> Type
Parameters
tagName (String)
attributes (IDictionary)
Return Value
Type


NoCurrentBadWordException Class

NoCurrentBadWordException Class
API Documentation ► Keyoti.RapidSpell ► NoCurrentBadWordException
Keyoti RapidSpell Web .NET
Thrown if NextBadWord has not been run first and found a mis-spelled word.
Declaration Syntax
C# Visual Basic Visual C++ F#
[SerializableAttribute]
public class NoCurrentBadWordException : ApplicationException
<SerializableAttribute>
Public Class NoCurrentBadWordException
    Inherits ApplicationException
[SerializableAttribute]
public ref class NoCurrentBadWordException : public ApplicationException
[<SerializableAttribute>]
type NoCurrentBadWordException =
    class
        inherit ApplicationException
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NoCurrentBadWordException()()()() | Create a new instance with no message.
 | NoCurrentBadWordException(String) | Create a new instance with mesg as a message.
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | ApplicationException
 |  |  | NoCurrentBadWordException


NoCurrentBadWordException Constructor

NoCurrentBadWordException Constructor
API Documentation ► Keyoti.RapidSpell ► NoCurrentBadWordException ► NoCurrentBadWordException()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | NoCurrentBadWordException()()()() | Create a new instance with no message.
 | NoCurrentBadWordException(String) | Create a new instance with mesg as a message.


NoCurrentBadWordException Constructor

NoCurrentBadWordException Constructor
API Documentation ► Keyoti.RapidSpell ► NoCurrentBadWordException ► NoCurrentBadWordException()()()()
Keyoti RapidSpell Web .NET
Create a new instance with no message.
Declaration Syntax
C# Visual Basic Visual C++ F#
public NoCurrentBadWordException()
Public Sub New
public:
NoCurrentBadWordException()
new : unit -> NoCurrentBadWordException


NoCurrentBadWordException Constructor (mesg)

NoCurrentBadWordException Constructor (mesg)
API Documentation ► Keyoti.RapidSpell ► NoCurrentBadWordException ► NoCurrentBadWordException(String)
Keyoti RapidSpell Web .NET
Create a new instance with mesg as a message.
Declaration Syntax
C# Visual Basic Visual C++ F#
public NoCurrentBadWordException(
    string mesg
)
Public Sub New (
    mesg As String
)
public:
NoCurrentBadWordException(
    String^ mesg
)
new :
        mesg : string -> NoCurrentBadWordException
Parameters
mesg (String)


PreviewPaneStyle Class

PreviewPaneStyle Class
API Documentation ► Keyoti.RapidSpell ► PreviewPaneStyle
Keyoti RapidSpell Web .NET
The 'preview pane' style, this defines the style of the inner frame that shows the document preview during spell checking.
Declaration Syntax
C# Visual Basic Visual C++ F#
public class PreviewPaneStyle : Style
Public Class PreviewPaneStyle
    Inherits Style
public ref class PreviewPaneStyle : public Style
type PreviewPaneStyle =
    class
        inherit Style
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PreviewPaneStyle()()()() | Creates the style for the 'preview pane'
 | AddAttributesToRender(HtmlTextWriter, Page, ClientFilesLocation) | Adds HTML attributes and styles that need to be rendered to the specified System.Web.UI.HtmlTextWriter
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriter. This method is primarily used by control developers. (Inherited from Style.)
 | AddAttributesToRender(HtmlTextWriter, WebControl) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriter and Web server control. This method is primarily used by control developers. (Inherited from Style.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from Style.)
 | BadWordHighlightStyle | The CSS style string to be used to highlight the misspelt word, eg. "border-bottom: 1px solid red; background-color: #ddddff"
 | BorderColor | Gets or sets the border color of the Web server control. (Inherited from Style.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from Style.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from Style.)
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | colorToHTMLCode(Color) | Returns the Html hex code for a color.
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CopyFrom(Style) | Duplicates the style properties of the specified Style into the instance of the Style class that this method is called from. (Inherited from Style.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CssClass | Gets or sets the cascading style sheet (CSS) class rendered by the Web server control on the client. (Inherited from Style.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | FillStyleAttributes(CssStyleCollection, IUrlResolutionService) | Adds the specified object's style properties to a CssStyleCollection object. (Inherited from Style.)
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from Style.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from Style.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetStyleAttributes(IUrlResolutionService) | Retrieves the CssStyleCollection object for the specified IUrlResolutionService-implemented object. (Inherited from Style.)
 | GetStyleOfBody()()()() | Returns inline CSS for the body style.
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | Height | Gets or sets the height of the Web server control. (Inherited from Style.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | IsEmpty | A protected property. Gets a value indicating whether any style elements have been defined in the state bag. (Inherited from Style.)
 | IsTrackingViewState | Returns a value indicating whether any style elements have been defined in the state bag. (Inherited from Style.)
 | LoadViewState(Object) | Loads the previously saved state. (Inherited from Style.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeWith(Style) | Combines the style properties of the specified Style with the instance of the Style class that this method is called from. (Inherited from Style.)
 | RegisteredCssClass | Gets the cascading style sheet (CSS) class that is registered with the control. (Inherited from Style.)
 | Reset()()()() | Removes any defined style elements from the state bag. (Inherited from Style.)
 | SaveViewState()()()() | A protected method. Saves any state that has been modified after the TrackViewState()()()() method was invoked. (Inherited from Style.)
 | SetBit(Int32) | A protected internal method. Sets an internal bitmask field that indicates the style properties that are stored in the state bag. (Inherited from Style.)
 | SetDirty()()()() | Marks the Style so that its state will be recorded in view state. (Inherited from Style.)
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | TrackViewState()()()() | A protected method. Marks the beginning for tracking state changes on the control. Any changes made after tracking has begun will be tracked and saved as part of the control view state. (Inherited from Style.)
 | ViewState | Gets the state bag that holds the style elements. (Inherited from Style.)
 | Width | Gets or sets the width of the Web server control. (Inherited from Style.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Style
 |  |  |  | PreviewPaneStyle


PreviewPaneStyle Constructor

PreviewPaneStyle Constructor
API Documentation ► Keyoti.RapidSpell ► PreviewPaneStyle ► PreviewPaneStyle()()()()
Keyoti RapidSpell Web .NET
Creates the style for the 'preview pane'
Declaration Syntax
C# Visual Basic Visual C++ F#
public PreviewPaneStyle()
Public Sub New
public:
PreviewPaneStyle()
new : unit -> PreviewPaneStyle


AddAttributesToRender Method (writer, page, clientFileLocation)

AddAttributesToRender Method (writer, page, clientFileLocation)
API Documentation ► Keyoti.RapidSpell ► PreviewPaneStyle ► AddAttributesToRender(HtmlTextWriter, Page, ClientFilesLocation)
Keyoti RapidSpell Web .NET
Adds HTML attributes and styles that need to be rendered to the specified System.Web.UI.HtmlTextWriter
Declaration Syntax
C# Visual Basic Visual C++ F#
public void AddAttributesToRender(
    HtmlTextWriter writer,
    Page page,
    ClientFilesLocation clientFileLocation
)
Public Sub AddAttributesToRender (
    writer As HtmlTextWriter,
    page As Page,
    clientFileLocation As ClientFilesLocation
)
public:
void AddAttributesToRender(
    HtmlTextWriter^ writer,
    Page^ page,
    ClientFilesLocation clientFileLocation
)
member AddAttributesToRender :
        writer : HtmlTextWriter *
        page : Page *
        clientFileLocation : ClientFilesLocation -> unit
Parameters
writer (HtmlTextWriter)
page (Page)
clientFileLocation (ClientFilesLocation)


BadWordHighlightStyle Property

BadWordHighlightStyle Property
API Documentation ► Keyoti.RapidSpell ► PreviewPaneStyle ► BadWordHighlightStyle
Keyoti RapidSpell Web .NET
The CSS style string to be used to highlight the misspelt word, eg. "border-bottom: 1px solid red; background-color: #ddddff"
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string BadWordHighlightStyle { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property BadWordHighlightStyle As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ BadWordHighlightStyle {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member BadWordHighlightStyle : string with get, set
Property Value
String


colorToHTMLCode Method (c)

colorToHTMLCode Method (c)
API Documentation ► Keyoti.RapidSpell ► PreviewPaneStyle ► colorToHTMLCode(Color)
Keyoti RapidSpell Web .NET
Returns the Html hex code for a color.
Declaration Syntax
C# Visual Basic Visual C++ F#
public static string colorToHTMLCode(
    Color c
)
Public Shared Function colorToHTMLCode (
    c As Color
) As String
public:
static String^ colorToHTMLCode(
    Color c
)
static member colorToHTMLCode :
        c : Color -> string
Parameters
c (Color)
Return Value
String


GetStyleOfBody Method

GetStyleOfBody Method
API Documentation ► Keyoti.RapidSpell ► PreviewPaneStyle ► GetStyleOfBody()()()()
Keyoti RapidSpell Web .NET
Returns inline CSS for the body style.
Declaration Syntax
C# Visual Basic Visual C++ F#
public string GetStyleOfBody()
Public Function GetStyleOfBody As String
public:
String^ GetStyleOfBody()
member GetStyleOfBody : unit -> string
Return Value
String


RapidSpellChecker Class

RapidSpellChecker Class
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker
Keyoti RapidSpell Web .NET
Spell checker engine, checks a text string for spelling errors and makes suggested corrections.
Declaration Syntax
C# Visual Basic Visual C++ F#
public class RapidSpellChecker : ICheckerEngine
Public Class RapidSpellChecker
    Implements ICheckerEngine
public ref class RapidSpellChecker : ICheckerEngine
type RapidSpellChecker =
    class
        interface ICheckerEngine
    end
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RapidSpellChecker()()()() | Throws a licensing exception! Please use .ctor with license key.
 | RapidSpellChecker(String) | Creates a RapidSpellChecker, with no user dictionary.
 | AddIgnorePattern(String) | Adds a regex pattern to ignore (maximum of 20 can be added - IgnoreURLsAndEmailAddresses=true counts as 1).
 | AddWord(String) | Adds word to the user dictionary (if it has been specified).
 | AllowAnyCase | Whether to allow words spelt with incorrect case, eg. "africa", instead of "Africa", this is more relaxed than AllowMixedCase
 | AllowMixedCase | Whether to allow words spelt with mixed case, eg. "MIxEd" - also see AllowAnyCase.
 | ChangeAll(String) | Changes all instances of the current bad word to newWord in the text.
 | ChangeBadWord(String) | Changes the current bad word to newWord in the text.
 | ChangeBadWord(BadWord, String) | Changes badWord to newWord in the text.
 | ChangeWord | Change word event, fired when a word is changed.
 | Check(String) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
 | Check(String, Boolean) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
 | Check(String, Int32) | Checks text for spelling correctness, from startPosition in text, mis-spelt words can be accessed through NextBadWord.
 | Check(String, Int32, Boolean) | Checks text for spelling correctness, from startPosition in text, mis-spelt words can be accessed through NextBadWord.
 | CheckCompoundWords | Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
 | convertHtmlEntities(String) | Converts HTML entity codes to their Unicode characters
 | convertHtmlEntities(String, Boolean) | Converts HTML entity codes to their Unicode characters
 | CurrentBadWord | Gets the current bad word (last returned by NextBadWord).
 | DictFilePath |
 | Dispose(Boolean) | Disposes of resources.
 | Dispose()()()() | Clean up any resources being used.
 | dontSuggest | Don't suggest words in this array (swear words).
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Frees up resources. (Overrides Object.Finalize()()()().)
 | FindAnagrams(String, IList) | Finds anagrams of word and puts them in anagrams if not already present.
 | FindCapitalizedSuggestions | Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
 | FindCompoundWords(String, IList) | Finds the compound words in text and puts them in subwords, set subwords to null/nothing to just find if text has compound word formation.
 | FindSuggestions()()()() | Gets an enumeration of String suggestions for spelling of current bad word.
 | FindSuggestions(String) | Gets an enumeration of String suggestions for word.
 | FindSuggestions(String, Boolean) | Gets an enumeration of String suggestions for word.
 | GetAmendedText()()()() | Returns the original text sent to check() but with any alterations made through change
 | GetConsiderationRange()()()() | Gets the factor for words to consider for suggestions.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIgnoreCapitalizedWords()()()() | Gets whether to ignore words with capital letters.
 | GetIncludeUserDictionaryInSuggestions()()()() | Gets whether the user dictionary should be used in finding suggestions for misspelt words.
 | GetNextWord()()()() | Returns the next word in the text.
 | GetSeparateHyphenWords()()()() | Gets whether to treat hyphenated (-) words as separate words, default is false.
 | GetSuggestionsMethod()()()() | Gets the suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetUndoableStatePoint()()()() | Gets the state of the current run, which can be stored and used with RevertToUndoableStatePoint(RapidSpellChecker..::..State)
 | HASHING_SUGGESTIONS | Indicator for suggestion method (Hashing is default).
 | IgnoreAll(String) | Marks word to be ignored in rest of the text.
 | IgnoreIncorrectSentenceCapitalization | Whether to ignore incorrect sentence capitalization.
 | IgnoreInEnglishLowerCaseI | Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
 | IgnoreList | The words to ignore, note this list is changed by IgnoreAll.
 | IgnoreRtfCodes | Sets whether this should ignore Rtf (or any escaped) codes in the text.
 | IgnoreURLsAndEmailAddresses | Whether to ignore URLs and email addresses (requires V2Parser=true)
 | IgnoreWordsWithDigits | Whether to ignore words with numbers in them (eg. A10 or 7-11).
 | IgnoreXML | Whether to ignore XML/HTML tags, should be set true for RichTextBox support, false by default.
 | IsAllCaps(String) | Whether all chars in s are in upper case
 | IsStartsWithCap(String) | Whether first letter is a capital and rest are lower.
 | IsWord(Int32, Int32) | Whether the word defined by the parameters is a word or whitespace.
 | LanguageParser | The type of language parsing to use.
 | LicenseKey | The license key
 | LookIntoHyphenatedText | Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
 | LookUp(String) | Checks if query is in the main dictionary or user.
 | LookUpMainDictionary(String) | Checks if query is in the word dictionary. Returns true if doesnt start with a letter or apostrophe
 | LookUpUserDictionary(String) | Look up the query in the user dictionary if it exists.
 | MakeCap(String) | Capitalises first letter of word
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NextBadWord()()()() | Returns the next mis-spelt word in the text, as a BadWord object.
 | PHONETIC_SUGGESTIONS | Indicator for suggestion method (Hashing is default).
 | ReloadUserDictionary()()()() | Reloads the user dictionary.
 | RemoveIgnorePattern(String) | Removes a regex pattern to ignore (maximum of 20 can be added - IgnoreURLsAndEmailAddresses=true counts as 1).
 | RevertToUndoableStatePoint(RapidSpellChecker..::..State) | Reverts the state to what it was when GetUndoableStatePoint()()()() was called.
 | SetConsiderationRange(Int32) | Sets the factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anything.
 | SetDictFileStream(Stream, String, DateTime) | Passes a Dict file as a stream, to be used for the main dictionary.
 | SetIgnoreCapitalizedWords(Boolean) | Sets whether to ignore words with capital letters.
 | SetIncludeUserDictionaryInSuggestions(Boolean) | Sets whether the user dictionary should be used in finding suggestions for misspelt words.
 | SetOptionalContext(String, String) | Provides the engine with any helpful text around the text snippet which will be passed to the Check method.
 | SetPosition(Int32) | Sets the pointer position for the NextBadWord iterator.
 | SetSeparateHyphenWords(Boolean) | Sets whether to treat hyphenated (-) words as separate words, default is false.
 | SetSuggestionsMethod(Int32) | Sets the suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
 | SetUserDictionary(String) | Set the user dictionary to use.
 | SetUserDictionary(UserDictionary) | Set the user dictionary to use.
 | ShareDictionary | Obsolete. Whether to share the dictionary in memory across all instances of RapidSpellChecker (false by default).
 | SuggestSplitWords | Whether to look for connected words in suggestions.
 | TextBoundary | The AdvancedTextBoundary class to use to parse words.
 | theCurrentBadWord |
 | theText | The text being checked.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UnloadMainDictionary()()()() | Obsolete. Empties the main dictionary store.
 | userDictionary | The UserDictionary being used, may be null if no user dictionary is being used.
 | V2Parser | Whether to use parser version 2 - Set to false for backwards compatibility.
 | WarnDuplicates | Whether to treat duplicate words as errors (eg. "this is is an error").
 | WordAdded | Fired when word added to user dictionary
 | wordEnd | The end index of the current word being checked/parsed.
 | WordIgnored | Fired when word ignored
 | wordStart | The start index of the current word being checked/parsed.
Remarks
This is a non-GUI component, suitable for the business/logic layer of your application. You would use this component in web server based applications. This component can be used in 2 different ways. The most common usage, in an iterative fashion is detailed below, but it may also be used on a query by query basis. To use this component in an iterative way you must first call Check to set the text to check and then iterate through NextBadWord() to identify misspelt words. NextBadWord will return a BadWord object and internally locate the the misspelt word in the text, then you can call FindSuggestions which will return a ArrayList of suggestions as String objects. You may also call ChangeBadWord(replacement) to replace that current misspelt word in the text. NextBadWord() will return null when the text has been checked. GetAmendedText returns the current state of the text with corrections. Calling ChangeBadWord or FindSuggestions before NextBadWord has been called and returned a BadWord (i.e. not null) will result in a NoCurrentBadWordException
Remarks

The second way to use this component is simply to query words yourself using LookUp(word) to check if word is in the lexicon/dictionary and FindSuggestions(word) to find spelling suggestions for word.

Examples
Check some text, find suggestions and replace mis-spelt words with "replacement".
Copy image Copy
RapidSpellChecker c = new RapidSpellChecker();
BadWord badWord;
ArrayList suggestions;

 //check some text.
c.Check("This is sume text.");

//iterate through all bad words in the text.
while((badWord = c.NextBadWord())!=null){

    Console.WriteLine(badWord.GetWord() + "- is not spelt correctly. Suggestions:");

    try{
        //get suggestions for the current bad word.
        suggestions = c.FindSuggestions();

        //display all suggestions.
        for(int i=0; i<suggestions.Count; i++){
            Console.WriteLine(suggestions[i]);
        }

        //change the bad word in the text with "replacement".
        c.ChangeBadWord("replacement");

    } catch (NoCurrentBadWordException e){
        Console.WriteLine(e);
    }

}
Console.WriteLine(c.GetAmendedText());
Inheritance Hierarchy
Object
RapidSpellChecker


RapidSpellChecker Constructor

RapidSpellChecker Constructor
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► RapidSpellChecker()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | RapidSpellChecker()()()() | Throws a licensing exception! Please use .ctor with license key.
 | RapidSpellChecker(String) | Creates a RapidSpellChecker, with no user dictionary.


RapidSpellChecker Constructor

RapidSpellChecker Constructor
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► RapidSpellChecker()()()()
Keyoti RapidSpell Web .NET
Throws a licensing exception! Please use .ctor with license key.
Declaration Syntax
C# Visual Basic Visual C++ F#
public RapidSpellChecker()
Public Sub New
public:
RapidSpellChecker()
new : unit -> RapidSpellChecker
Exceptions
Exception | Condition
ApplicationException | If the dictionary cannot be read.


RapidSpellChecker Constructor (licenseKey)

RapidSpellChecker Constructor (licenseKey)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► RapidSpellChecker(String)
Keyoti RapidSpell Web .NET
Creates a RapidSpellChecker, with no user dictionary.
Declaration Syntax
C# Visual Basic Visual C++ F#
public RapidSpellChecker(
    string licenseKey
)
Public Sub New (
    licenseKey As String
)
public:
RapidSpellChecker(
    String^ licenseKey
)
new :
        licenseKey : string -> RapidSpellChecker
Parameters
licenseKey (String)
Exceptions
Exception | Condition
ApplicationException | If the dictionary cannot be read.


AddIgnorePattern Method (p)

AddIgnorePattern Method (p)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► AddIgnorePattern(String)
Keyoti RapidSpell Web .NET
Adds a regex pattern to ignore (maximum of 20 can be added - IgnoreURLsAndEmailAddresses=true counts as 1).
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void AddIgnorePattern(
    string p
)
Public Overridable Sub AddIgnorePattern (
    p As String
)
public:
virtual void AddIgnorePattern(
    String^ p
)
abstract AddIgnorePattern :
        p : string -> unit
override AddIgnorePattern :
        p : string -> unit
Parameters
p (String)
Remarks
Eg, to ignore email addresses either set IgnoreURLsAndEmailAddresses=true or AddIgnorePattern("^(?:[0-9a-zA-Z](?:[-.\w]*[0-9a-zA-Z])*@(?:[0-9a-zA-Z][-\w]*[0-9a-zA-Z]\.)+[a-zA-Z]{2,9})$").


AddWord Method (word)

AddWord Method (word)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► AddWord(String)
Keyoti RapidSpell Web .NET
Adds word to the user dictionary (if it has been specified).
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual bool AddWord(
    string word
)
Public Overridable Function AddWord (
    word As String
) As Boolean
public:
virtual bool AddWord(
    String^ word
)
abstract AddWord :
        word : string -> bool
override AddWord :
        word : string -> bool
Parameters
word (String)
String to add to user dictionary, if it is being used.
Return Value
Boolean
boolean true if the word was is now in the user dictionary, false if the word could not be added to the user dictionary.
Exceptions
Exception | Condition
ArgumentNullException | If word parameter is null.


AllowAnyCase Property

AllowAnyCase Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► AllowAnyCase
Keyoti RapidSpell Web .NET
Whether to allow words spelt with incorrect case, eg. "africa", instead of "Africa", this is more relaxed than AllowMixedCase
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool AllowAnyCase { get; set; }
Public Property AllowAnyCase As Boolean
    Get
    Set
public:
virtual property bool AllowAnyCase {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract AllowAnyCase : bool with get, set
override AllowAnyCase : bool with get, set
Property Value
Boolean


AllowMixedCase Property

AllowMixedCase Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► AllowMixedCase
Keyoti RapidSpell Web .NET
Whether to allow words spelt with mixed case, eg. "MIxEd" - also see AllowAnyCase.
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool AllowMixedCase { get; set; }
Public Property AllowMixedCase As Boolean
    Get
    Set
public:
virtual property bool AllowMixedCase {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract AllowMixedCase : bool with get, set
override AllowMixedCase : bool with get, set
Property Value
Boolean


ChangeAll Method (newWord)

ChangeAll Method (newWord)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► ChangeAll(String)
Keyoti RapidSpell Web .NET
Changes all instances of the current bad word to newWord in the text.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void ChangeAll(
    string newWord
)
Public Overridable Sub ChangeAll (
    newWord As String
)
public:
virtual void ChangeAll(
    String^ newWord
)
abstract ChangeAll :
        newWord : string -> unit
override ChangeAll :
        newWord : string -> unit
Parameters
newWord (String)
Exceptions
Exception | Condition
NoCurrentBadWordException | if nextBadWord() hasn't been run first AND found an erroneous word.
ArgumentNullException | if newWord parameter is null.


ChangeBadWord Method

ChangeBadWord Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► ChangeBadWord()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | ChangeBadWord(String) | Changes the current bad word to newWord in the text.
 | ChangeBadWord(BadWord, String) | Changes badWord to newWord in the text.


ChangeBadWord Method (badWord, newWord)

ChangeBadWord Method (badWord, newWord)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► ChangeBadWord(BadWord, String)
Keyoti RapidSpell Web .NET
Changes badWord to newWord in the text.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void ChangeBadWord(
    BadWord badWord,
    string newWord
)
Public Overridable Sub ChangeBadWord (
    badWord As BadWord,
    newWord As String
)
public:
virtual void ChangeBadWord(
    BadWord^ badWord,
    String^ newWord
)
abstract ChangeBadWord :
        badWord : BadWord *
        newWord : string -> unit
override ChangeBadWord :
        badWord : BadWord *
        newWord : string -> unit
Parameters
badWord (BadWord)
word to replace
newWord (String)
replaces the current misspelt word.
Return Value

void
Exceptions
Exception | Condition
ArgumentNullException | if newWord parameter is null.


ChangeBadWord Method (newWord)

ChangeBadWord Method (newWord)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► ChangeBadWord(String)
Keyoti RapidSpell Web .NET
Changes the current bad word to newWord in the text.
Declaration Syntax
C# Visual Basic Visual C++ F#
public void ChangeBadWord(
    string newWord
)
Public Sub ChangeBadWord (
    newWord As String
)
public:
virtual void ChangeBadWord(
    String^ newWord
) sealed
abstract ChangeBadWord :
        newWord : string -> unit
override ChangeBadWord :
        newWord : string -> unit
Parameters
newWord (String)
Replaces the current misspelt word.
Return Value

void
Exceptions
Exception | Condition
NoCurrentBadWordException | if nextBadWord() hasn't been run first AND found an erroneous word.
ArgumentNullException | if newWord parameter is null.


ChangeWord Event

ChangeWord Event
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► ChangeWord
Keyoti RapidSpell Web .NET
Change word event, fired when a word is changed.
Declaration Syntax
C# Visual Basic Visual C++ F#
public event RapidSpellChecker..::..ChangeWordEventHandler ChangeWord
Public Event ChangeWord As RapidSpellChecker..::..ChangeWordEventHandler
public:
 event RapidSpellChecker..::..ChangeWordEventHandler^ ChangeWord {
    void add (RapidSpellChecker..::..ChangeWordEventHandler^ value);
    void remove (RapidSpellChecker..::..ChangeWordEventHandler^ value);
}
member ChangeWord : IEvent<RapidSpellChecker..::..ChangeWordEventHandler,
    ChangeWordEventArgs>
Value
RapidSpellChecker..::..ChangeWordEventHandler


Check Method

Check Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► Check()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | Check(String) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
 | Check(String, Boolean) | Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
 | Check(String, Int32) | Checks text for spelling correctness, from startPosition in text, mis-spelt words can be accessed through NextBadWord.
 | Check(String, Int32, Boolean) | Checks text for spelling correctness, from startPosition in text, mis-spelt words can be accessed through NextBadWord.


Check Method (text)

Check Method (text)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► Check(String)
Keyoti RapidSpell Web .NET
Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
Declaration Syntax
C# Visual Basic Visual C++ F#
public void Check(
    string text
)
Public Sub Check (
    text As String
)
public:
virtual void Check(
    String^ text
) sealed
abstract Check :
        text : string -> unit
override Check :
        text : string -> unit
Parameters
text (String)
to spell check.
Return Value

void
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


Check Method (text, isStartOfTextBody)

Check Method (text, isStartOfTextBody)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► Check(String, Boolean)
Keyoti RapidSpell Web .NET
Checks text for spelling correctness, from beginning of text, mis-spelt words can be accessed through nextBadWord.
Declaration Syntax
C# Visual Basic Visual C++ F#
public void Check(
    string text,
    bool isStartOfTextBody
)
Public Sub Check (
    text As String,
    isStartOfTextBody As Boolean
)
public:
virtual void Check(
    String^ text,
    bool isStartOfTextBody
) sealed
abstract Check :
        text : string *
        isStartOfTextBody : bool -> unit
override Check :
        text : string *
        isStartOfTextBody : bool -> unit
Parameters
text (String)
to spell check.
isStartOfTextBody (Boolean)
whether the text being spell checked is at the start of the text body (eg. start of text box), this affects sentence capitalization determination.
Return Value

void
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


Check Method (text, startPosition)

Check Method (text, startPosition)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► Check(String, Int32)
Keyoti RapidSpell Web .NET
Checks text for spelling correctness, from startPosition in text, mis-spelt words can be accessed through NextBadWord.
Declaration Syntax
C# Visual Basic Visual C++ F#
public void Check(
    string text,
    int startPosition
)
Public Sub Check (
    text As String,
    startPosition As Integer
)
public:
void Check(
    String^ text,
    int startPosition
)
member Check :
        text : string *
        startPosition : int -> unit
Parameters
text (String)
the text to be checked
startPosition (Int32)
the position in the text to begin checking from
Return Value

void
Remarks
startPosition should be >=0 but if it is < 0 it is set = 0.
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


Check Method (text, startPosition, isStartOfTextBody)

Check Method (text, startPosition, isStartOfTextBody)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► Check(String, Int32, Boolean)
Keyoti RapidSpell Web .NET
Checks text for spelling correctness, from startPosition in text, mis-spelt words can be accessed through NextBadWord.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void Check(
    string text,
    int startPosition,
    bool isStartOfTextBody
)
Public Overridable Sub Check (
    text As String,
    startPosition As Integer,
    isStartOfTextBody As Boolean
)
public:
virtual void Check(
    String^ text,
    int startPosition,
    bool isStartOfTextBody
)
abstract Check :
        text : string *
        startPosition : int *
        isStartOfTextBody : bool -> unit
override Check :
        text : string *
        startPosition : int *
        isStartOfTextBody : bool -> unit
Parameters
text (String)
the text to be checked
startPosition (Int32)
the position in the text to begin checking from
isStartOfTextBody (Boolean)
whether the text being spell checked is at the start of the text body (eg. start of text box), this affects sentence capitalization determination.
Return Value

void
Remarks
startPosition should be >=0 but if it is < 0 it is set = 0.
Exceptions
Exception | Condition
ArgumentNullException | if text parameter is null.


CheckCompoundWords Property

CheckCompoundWords Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► CheckCompoundWords
Keyoti RapidSpell Web .NET
Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool CheckCompoundWords { get; set; }
Public Property CheckCompoundWords As Boolean
    Get
    Set
public:
virtual property bool CheckCompoundWords {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract CheckCompoundWords : bool with get, set
override CheckCompoundWords : bool with get, set
Property Value
Boolean
Remarks
If this=false then LookUp("thesewordsarejoined") = false

If this=true then LookUp("thesewordsarejoined") = true

If this=false then LookUp("abcdef") = false

If this=true then LookUp("abcdef") = false

Setting this to true will degrade lookup performance by a maximum of approx. 100[1-1/n] percent (where n is the number of letters in the word) for misspelt words. There is no preformance degredation for correctly spelt words. On average for texts with mostly correctly spelt words the performance degredation for the Check method is roughly 25%.


convertHtmlEntities Method

convertHtmlEntities Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► convertHtmlEntities()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | convertHtmlEntities(String) | Converts HTML entity codes to their Unicode characters
 | convertHtmlEntities(String, Boolean) | Converts HTML entity codes to their Unicode characters


convertHtmlEntities Method (text)

convertHtmlEntities Method (text)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► convertHtmlEntities(String)
Keyoti RapidSpell Web .NET
Converts HTML entity codes to their Unicode characters
Declaration Syntax
C# Visual Basic Visual C++ F#
public static string convertHtmlEntities(
    string text
)
Public Shared Function convertHtmlEntities (
    text As String
) As String
public:
static String^ convertHtmlEntities(
    String^ text
)
static member convertHtmlEntities :
        text : string -> string
Parameters
text (String)
Return Value
String


convertHtmlEntities Method (text, convertAMP)

convertHtmlEntities Method (text, convertAMP)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► convertHtmlEntities(String, Boolean)
Keyoti RapidSpell Web .NET
Converts HTML entity codes to their Unicode characters
Declaration Syntax
C# Visual Basic Visual C++ F#
public static string convertHtmlEntities(
    string text,
    bool convertAMP
)
Public Shared Function convertHtmlEntities (
    text As String,
    convertAMP As Boolean
) As String
public:
static String^ convertHtmlEntities(
    String^ text,
    bool convertAMP
)
static member convertHtmlEntities :
        text : string *
        convertAMP : bool -> string
Parameters
text (String)
The text containing the entities to convert.
convertAMP (Boolean)
Whether to convert &amp; entities to &
Return Value
String


CurrentBadWord Property

CurrentBadWord Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► CurrentBadWord
Keyoti RapidSpell Web .NET
Gets the current bad word (last returned by NextBadWord).
Declaration Syntax
C# Visual Basic Visual C++ F#
public BadWord CurrentBadWord { get; }
Public ReadOnly Property CurrentBadWord As BadWord
    Get
public:
virtual property BadWord^ CurrentBadWord {
    BadWord^ get () sealed;
}
abstract CurrentBadWord : BadWord with get
override CurrentBadWord : BadWord with get
Property Value
BadWord


DictFilePath Property

DictFilePath Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► DictFilePath
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public string DictFilePath { get; set; }
Public Property DictFilePath As String
    Get
    Set
public:
virtual property String^ DictFilePath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract DictFilePath : string with get, set
override DictFilePath : string with get, set
Property Value
String


Dispose Method

Dispose Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► Dispose()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | Dispose(Boolean) | Disposes of resources.
 | Dispose()()()() | Clean up any resources being used.


Dispose Method

Dispose Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► Dispose()()()()
Keyoti RapidSpell Web .NET
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void Dispose()
Public Overridable Sub Dispose
public:
virtual void Dispose()
abstract Dispose : unit -> unit
override Dispose : unit -> unit


Dispose Method (disposing)

Dispose Method (disposing)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► Dispose(Boolean)
Keyoti RapidSpell Web .NET
Disposes of resources.
Declaration Syntax
C# Visual Basic Visual C++ F#
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
Parameters
disposing (Boolean)


dontSuggest Field

dontSuggest Field
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► dontSuggest
Keyoti RapidSpell Web .NET
Don't suggest words in this array (swear words).
Declaration Syntax
C# Visual Basic Visual C++ F#
protected string[] dontSuggest
Protected dontSuggest As String()
protected:
array<String^>^ dontSuggest
val mutable dontSuggest: string[]
Field Value
array< String >[]()[][]


Finalize Method

Finalize Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► Finalize()()()()
Keyoti RapidSpell Web .NET
Frees up resources.
Declaration Syntax
C# Visual Basic Visual C++ F#
protected override void Finalize()
Protected Overrides Sub Finalize
protected:
virtual void Finalize() override
abstract Finalize : unit -> unit
override Finalize : unit -> unit


FindAnagrams Method (word, anagrams)

FindAnagrams Method (word, anagrams)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► FindAnagrams(String, IList)
Keyoti RapidSpell Web .NET
Finds anagrams of word and puts them in anagrams if not already present.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void FindAnagrams(
    string word,
    IList anagrams
)
Public Overridable Sub FindAnagrams (
    word As String,
    anagrams As IList
)
public:
virtual void FindAnagrams(
    String^ word,
    IList^ anagrams
)
abstract FindAnagrams :
        word : string *
        anagrams : IList -> unit
override FindAnagrams :
        word : string *
        anagrams : IList -> unit
Parameters
word (String)
The word to find anagrams of
anagrams (IList)
A list that anagrams will be added to.
Remarks
Exceptions
Exception | Condition
ArgumentNullException | if word is null/nothing


FindCapitalizedSuggestions Property

FindCapitalizedSuggestions Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► FindCapitalizedSuggestions
Keyoti RapidSpell Web .NET
Whether to look for capitalized suggestions, note this will slow FindSuggestions down by about 7 times.
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool FindCapitalizedSuggestions { get; set; }
Public Property FindCapitalizedSuggestions As Boolean
    Get
    Set
public:
virtual property bool FindCapitalizedSuggestions {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract FindCapitalizedSuggestions : bool with get, set
override FindCapitalizedSuggestions : bool with get, set
Property Value
Boolean


FindCompoundWords Method (text, subwords)

FindCompoundWords Method (text, subwords)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► FindCompoundWords(String, IList)
Keyoti RapidSpell Web .NET
Finds the compound words in text and puts them in subwords, set subwords to null/nothing to just find if text has compound word formation.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual bool FindCompoundWords(
    string text,
    IList subwords
)
Public Overridable Function FindCompoundWords (
    text As String,
    subwords As IList
) As Boolean
public:
virtual bool FindCompoundWords(
    String^ text,
    IList^ subwords
)
abstract FindCompoundWords :
        text : string *
        subwords : IList -> bool
override FindCompoundWords :
        text : string *
        subwords : IList -> bool
Parameters
text (String)
The text to find compound words in
subwords (IList)
A list that formative sub-words will be added to, can be null/nothing.
Return Value
Boolean
True if text is entirely formed from compound words, False if not.
Remarks
Only adds words to list if all are valid. In other words, this will not find all words that are part of text, but only the words that all make up text.

Eg. "catchmentarea" has words "catchment" and "area" but not "cat", "me" etc.

The order of the words in the list is the reverse of their order in text.
Exceptions
Exception | Condition
ArgumentNullException | if text is null


FindSuggestions Method

FindSuggestions Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► FindSuggestions()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | FindSuggestions()()()() | Gets an enumeration of String suggestions for spelling of current bad word.
 | FindSuggestions(String) | Gets an enumeration of String suggestions for word.
 | FindSuggestions(String, Boolean) | Gets an enumeration of String suggestions for word.


FindSuggestions Method

FindSuggestions Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► FindSuggestions()()()()
Keyoti RapidSpell Web .NET
Gets an enumeration of String suggestions for spelling of current bad word.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual ArrayList FindSuggestions()
Public Overridable Function FindSuggestions As ArrayList
public:
virtual ArrayList^ FindSuggestions()
abstract FindSuggestions : unit -> ArrayList
override FindSuggestions : unit -> ArrayList
Return Value
ArrayList
ArrayList of String suggestions for current bad word.
Exceptions
Exception | Condition
NoCurrentBadWordException | If NextBadWord() hasn't been run first AND found an erroneous word.


FindSuggestions Method (word)

FindSuggestions Method (word)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► FindSuggestions(String)
Keyoti RapidSpell Web .NET
Gets an enumeration of String suggestions for word.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual ArrayList FindSuggestions(
    string word
)
Public Overridable Function FindSuggestions (
    word As String
) As ArrayList
public:
virtual ArrayList^ FindSuggestions(
    String^ word
)
abstract FindSuggestions :
        word : string -> ArrayList
override FindSuggestions :
        word : string -> ArrayList
Parameters
word (String)
the word to check the spelling of.
Return Value
ArrayList
ArrayList of String suggestions for word.
Exceptions
Exception | Condition
ArgumentNullException | if word parameter is null.


FindSuggestions Method (word, searchLowerCase)

FindSuggestions Method (word, searchLowerCase)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► FindSuggestions(String, Boolean)
Keyoti RapidSpell Web .NET
Gets an enumeration of String suggestions for word.
Declaration Syntax
C# Visual Basic Visual C++ F#
protected virtual ArrayList FindSuggestions(
    string word,
    bool searchLowerCase
)
Protected Overridable Function FindSuggestions (
    word As String,
    searchLowerCase As Boolean
) As ArrayList
protected:
virtual ArrayList^ FindSuggestions(
    String^ word,
    bool searchLowerCase
)
abstract FindSuggestions :
        word : string *
        searchLowerCase : bool -> ArrayList
override FindSuggestions :
        word : string *
        searchLowerCase : bool -> ArrayList
Parameters
word (String)
the word to check the spelling of.
searchLowerCase (Boolean)
whether to return suggestions for word in a lower case form (if it's capitalized).
Return Value
ArrayList
ArrayList of String suggestions for word.
Exceptions
Exception | Condition
ArgumentNullException | if word parameter is null.


GetAmendedText Method

GetAmendedText Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► GetAmendedText()()()()
Keyoti RapidSpell Web .NET
Returns the original text sent to check() but with any alterations made through change
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual string GetAmendedText()
Public Overridable Function GetAmendedText As String
public:
virtual String^ GetAmendedText()
abstract GetAmendedText : unit -> string
override GetAmendedText : unit -> string
Return Value
String
String the text after corrections, null if there is no text.


GetConsiderationRange Method

GetConsiderationRange Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► GetConsiderationRange()()()()
Keyoti RapidSpell Web .NET
Gets the factor for words to consider for suggestions.
Declaration Syntax
C# Visual Basic Visual C++ F#
public int GetConsiderationRange()
Public Function GetConsiderationRange As Integer
public:
virtual int GetConsiderationRange() sealed
abstract GetConsiderationRange : unit -> int
override GetConsiderationRange : unit -> int
Return Value
Int32


GetIgnoreCapitalizedWords Method

GetIgnoreCapitalizedWords Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► GetIgnoreCapitalizedWords()()()()
Keyoti RapidSpell Web .NET
Gets whether to ignore words with capital letters.
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool GetIgnoreCapitalizedWords()
Public Function GetIgnoreCapitalizedWords As Boolean
public:
virtual bool GetIgnoreCapitalizedWords() sealed
abstract GetIgnoreCapitalizedWords : unit -> bool
override GetIgnoreCapitalizedWords : unit -> bool
Return Value
Boolean


GetIncludeUserDictionaryInSuggestions Method

GetIncludeUserDictionaryInSuggestions Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► GetIncludeUserDictionaryInSuggestions()()()()
Keyoti RapidSpell Web .NET
Gets whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool GetIncludeUserDictionaryInSuggestions()
Public Function GetIncludeUserDictionaryInSuggestions As Boolean
public:
virtual bool GetIncludeUserDictionaryInSuggestions() sealed
abstract GetIncludeUserDictionaryInSuggestions : unit -> bool
override GetIncludeUserDictionaryInSuggestions : unit -> bool
Return Value
Boolean


GetNextWord Method

GetNextWord Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► GetNextWord()()()()
Keyoti RapidSpell Web .NET
Returns the next word in the text.
Declaration Syntax
C# Visual Basic Visual C++ F#
protected internal virtual string GetNextWord()
Protected Friend Overridable Function GetNextWord As String
protected public:
virtual String^ GetNextWord()
abstract GetNextWord : unit -> string
override GetNextWord : unit -> string
Return Value
String
String the next word in the text


GetSeparateHyphenWords Method

GetSeparateHyphenWords Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► GetSeparateHyphenWords()()()()
Keyoti RapidSpell Web .NET
Gets whether to treat hyphenated (-) words as separate words, default is false.
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool GetSeparateHyphenWords()
Public Function GetSeparateHyphenWords As Boolean
public:
bool GetSeparateHyphenWords()
member GetSeparateHyphenWords : unit -> bool
Return Value
Boolean
Remarks
For eg. if this is true text like "cheap-deals" will be treated as two words "cheap" and "deals", otherwise this will be treated as one word "cheap-deals".


GetSuggestionsMethod Method

GetSuggestionsMethod Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► GetSuggestionsMethod()()()()
Keyoti RapidSpell Web .NET
Gets the suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual int GetSuggestionsMethod()
Public Overridable Function GetSuggestionsMethod As Integer
public:
virtual int GetSuggestionsMethod()
abstract GetSuggestionsMethod : unit -> int
override GetSuggestionsMethod : unit -> int
Return Value
Int32


GetUndoableStatePoint Method

GetUndoableStatePoint Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► GetUndoableStatePoint()()()()
Keyoti RapidSpell Web .NET
Gets the state of the current run, which can be stored and used with RevertToUndoableStatePoint(RapidSpellChecker..::..State)
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual RapidSpellChecker..::..State GetUndoableStatePoint()
Public Overridable Function GetUndoableStatePoint As RapidSpellChecker..::..State
public:
virtual RapidSpellChecker..::..State^ GetUndoableStatePoint()
abstract GetUndoableStatePoint : unit -> RapidSpellChecker..::..State
override GetUndoableStatePoint : unit -> RapidSpellChecker..::..State
Return Value
RapidSpellChecker..::..State
Returns the current state, or null if not supporting undo.


HASHING_SUGGESTIONS Field

HASHING_SUGGESTIONS Field
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► HASHING_SUGGESTIONS
Keyoti RapidSpell Web .NET
Indicator for suggestion method (Hashing is default).
Declaration Syntax
C# Visual Basic Visual C++ F#
public static int HASHING_SUGGESTIONS
Public Shared HASHING_SUGGESTIONS As Integer
public:
static int HASHING_SUGGESTIONS
static val mutable HASHING_SUGGESTIONS: int
Field Value
Int32


IgnoreAll Method (word)

IgnoreAll Method (word)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► IgnoreAll(String)
Keyoti RapidSpell Web .NET
Marks word to be ignored in rest of the text.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void IgnoreAll(
    string word
)
Public Overridable Sub IgnoreAll (
    word As String
)
public:
virtual void IgnoreAll(
    String^ word
)
abstract IgnoreAll :
        word : string -> unit
override IgnoreAll :
        word : string -> unit
Parameters
word (String)
to ignore
Return Value

void
Exceptions
Exception | Condition
ArgumentNullException | if word parameter is null.


IgnoreIncorrectSentenceCapitalization Property

IgnoreIncorrectSentenceCapitalization Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► IgnoreIncorrectSentenceCapitalization
Keyoti RapidSpell Web .NET
Whether to ignore incorrect sentence capitalization.
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool IgnoreIncorrectSentenceCapitalization { get; set; }
Public Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
public:
virtual property bool IgnoreIncorrectSentenceCapitalization {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreIncorrectSentenceCapitalization : bool with get, set
override IgnoreIncorrectSentenceCapitalization : bool with get, set
Property Value
Boolean


IgnoreInEnglishLowerCaseI Property

IgnoreInEnglishLowerCaseI Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► IgnoreInEnglishLowerCaseI
Keyoti RapidSpell Web .NET
Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool IgnoreInEnglishLowerCaseI { get; set; }
Public Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
public:
virtual property bool IgnoreInEnglishLowerCaseI {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreInEnglishLowerCaseI : bool with get, set
override IgnoreInEnglishLowerCaseI : bool with get, set
Property Value
Boolean


IgnoreList Property

IgnoreList Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► IgnoreList
Keyoti RapidSpell Web .NET
The words to ignore, note this list is changed by IgnoreAll.
Declaration Syntax
C# Visual Basic Visual C++ F#
public ArrayList IgnoreList { get; set; }
Public Property IgnoreList As ArrayList
    Get
    Set
public:
virtual property ArrayList^ IgnoreList {
    ArrayList^ get () sealed;
    void set (ArrayList^ value) sealed;
}
abstract IgnoreList : ArrayList with get, set
override IgnoreList : ArrayList with get, set
Property Value
ArrayList


IgnoreRtfCodes Property

IgnoreRtfCodes Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► IgnoreRtfCodes
Keyoti RapidSpell Web .NET
Sets whether this should ignore Rtf (or any escaped) codes in the text.
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool IgnoreRtfCodes { get; set; }
Public Property IgnoreRtfCodes As Boolean
    Get
    Set
public:
property bool IgnoreRtfCodes {
    bool get ();
    void set (bool value);
}
member IgnoreRtfCodes : bool with get, set
Property Value
Boolean


IgnoreURLsAndEmailAddresses Property

IgnoreURLsAndEmailAddresses Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► IgnoreURLsAndEmailAddresses
Keyoti RapidSpell Web .NET
Whether to ignore URLs and email addresses (requires V2Parser=true)
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool IgnoreURLsAndEmailAddresses { get; set; }
Public Property IgnoreURLsAndEmailAddresses As Boolean
    Get
    Set
public:
virtual property bool IgnoreURLsAndEmailAddresses {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreURLsAndEmailAddresses : bool with get, set
override IgnoreURLsAndEmailAddresses : bool with get, set
Property Value
Boolean
Remarks
This will cause the following strings to be accepted as non-spelling errors;
"user@domain.com", "http://www.domain.com", "domain.co.uk" etc.


IgnoreWordsWithDigits Property

IgnoreWordsWithDigits Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► IgnoreWordsWithDigits
Keyoti RapidSpell Web .NET
Whether to ignore words with numbers in them (eg. A10 or 7-11).
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool IgnoreWordsWithDigits { get; set; }
Public Property IgnoreWordsWithDigits As Boolean
    Get
    Set
public:
virtual property bool IgnoreWordsWithDigits {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreWordsWithDigits : bool with get, set
override IgnoreWordsWithDigits : bool with get, set
Property Value
Boolean


IgnoreXML Property

IgnoreXML Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► IgnoreXML
Keyoti RapidSpell Web .NET
Whether to ignore XML/HTML tags, should be set true for RichTextBox support, false by default.
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool IgnoreXML { get; set; }
Public Property IgnoreXML As Boolean
    Get
    Set
public:
virtual property bool IgnoreXML {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IgnoreXML : bool with get, set
override IgnoreXML : bool with get, set
Property Value
Boolean


IsAllCaps Method (s)

IsAllCaps Method (s)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► IsAllCaps(String)
Keyoti RapidSpell Web .NET
Whether all chars in s are in upper case
Declaration Syntax
C# Visual Basic Visual C++ F#
public static bool IsAllCaps(
    string s
)
Public Shared Function IsAllCaps (
    s As String
) As Boolean
public:
static bool IsAllCaps(
    String^ s
)
static member IsAllCaps :
        s : string -> bool
Parameters
s (String)
Return Value
Boolean


IsStartsWithCap Method (word)

IsStartsWithCap Method (word)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► IsStartsWithCap(String)
Keyoti RapidSpell Web .NET
Whether first letter is a capital and rest are lower.
Declaration Syntax
C# Visual Basic Visual C++ F#
public static bool IsStartsWithCap(
    string word
)
Public Shared Function IsStartsWithCap (
    word As String
) As Boolean
public:
static bool IsStartsWithCap(
    String^ word
)
static member IsStartsWithCap :
        word : string -> bool
Parameters
word (String)
Return Value
Boolean


IsWord Method (wordStart, wordEnd)

IsWord Method (wordStart, wordEnd)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► IsWord(Int32, Int32)
Keyoti RapidSpell Web .NET
Whether the word defined by the parameters is a word or whitespace.
Declaration Syntax
C# Visual Basic Visual C++ F#
protected internal virtual bool IsWord(
    int wordStart,
    int wordEnd
)
Protected Friend Overridable Function IsWord (
    wordStart As Integer,
    wordEnd As Integer
) As Boolean
protected public:
virtual bool IsWord(
    int wordStart,
    int wordEnd
)
abstract IsWord :
        wordStart : int *
        wordEnd : int -> bool
override IsWord :
        wordStart : int *
        wordEnd : int -> bool
Parameters
wordStart (Int32)
wordEnd (Int32)
Return Value
Boolean
True if is a word, false if whitespace.


LanguageParser Property

LanguageParser Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► LanguageParser
Keyoti RapidSpell Web .NET
The type of language parsing to use.
Declaration Syntax
C# Visual Basic Visual C++ F#
public LanguageType LanguageParser { get; set; }
Public Property LanguageParser As LanguageType
    Get
    Set
public:
virtual property LanguageType LanguageParser {
    LanguageType get () sealed;
    void set (LanguageType value) sealed;
}
abstract LanguageParser : LanguageType with get, set
override LanguageParser : LanguageType with get, set
Property Value
LanguageType
Remarks
Eg. If the dictionary is set to French, you should use the French parser.


LicenseKey Property

LicenseKey Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► LicenseKey
Keyoti RapidSpell Web .NET
The license key
Declaration Syntax
C# Visual Basic Visual C++ F#
public string LicenseKey { set; }
Public WriteOnly Property LicenseKey As String
    Set
public:
property String^ LicenseKey {
    void set (String^ value);
}
member LicenseKey : string with set
Property Value
String


LookIntoHyphenatedText Property

LookIntoHyphenatedText Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► LookIntoHyphenatedText
Keyoti RapidSpell Web .NET
Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool LookIntoHyphenatedText { get; set; }
Public Property LookIntoHyphenatedText As Boolean
    Get
    Set
public:
virtual property bool LookIntoHyphenatedText {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract LookIntoHyphenatedText : bool with get, set
override LookIntoHyphenatedText : bool with get, set
Property Value
Boolean
Remarks
Eg. "socio-economic" will be checked as "socio" and "economic".


LookUp Method (query)

LookUp Method (query)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► LookUp(String)
Keyoti RapidSpell Web .NET
Checks if query is in the main dictionary or user.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual bool LookUp(
    string query
)
Public Overridable Function LookUp (
    query As String
) As Boolean
public:
virtual bool LookUp(
    String^ query
)
abstract LookUp :
        query : string -> bool
override LookUp :
        query : string -> bool
Parameters
query (String)
the word to check spelling of
Return Value
Boolean
true if spelt correctly, false if not in dictionary
Remarks
This method is inconsiderate of the words in IgnoreList.
Exceptions
Exception | Condition
ArgumentNullException | if query parameter is null.


LookUpMainDictionary Method (query)

LookUpMainDictionary Method (query)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► LookUpMainDictionary(String)
Keyoti RapidSpell Web .NET
Checks if query is in the word dictionary. Returns true if doesnt start with a letter or apostrophe
Declaration Syntax
C# Visual Basic Visual C++ F#
protected virtual bool LookUpMainDictionary(
    string query
)
Protected Overridable Function LookUpMainDictionary (
    query As String
) As Boolean
protected:
virtual bool LookUpMainDictionary(
    String^ query
)
abstract LookUpMainDictionary :
        query : string -> bool
override LookUpMainDictionary :
        query : string -> bool
Parameters
query (String)
the word to check spelling of
Return Value
Boolean
boolean true if spelt correctly, false if not in dictionary


LookUpUserDictionary Method (query)

LookUpUserDictionary Method (query)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► LookUpUserDictionary(String)
Keyoti RapidSpell Web .NET
Look up the query in the user dictionary if it exists.
Declaration Syntax
C# Visual Basic Visual C++ F#
protected virtual bool LookUpUserDictionary(
    string query
)
Protected Overridable Function LookUpUserDictionary (
    query As String
) As Boolean
protected:
virtual bool LookUpUserDictionary(
    String^ query
)
abstract LookUpUserDictionary :
        query : string -> bool
override LookUpUserDictionary :
        query : string -> bool
Parameters
query (String)
Return Value
Boolean


MakeCap Method (word)

MakeCap Method (word)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► MakeCap(String)
Keyoti RapidSpell Web .NET
Capitalises first letter of word
Declaration Syntax
C# Visual Basic Visual C++ F#
public static string MakeCap(
    string word
)
Public Shared Function MakeCap (
    word As String
) As String
public:
static String^ MakeCap(
    String^ word
)
static member MakeCap :
        word : string -> string
Parameters
word (String)
Return Value
String


NextBadWord Method

NextBadWord Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► NextBadWord()()()()
Keyoti RapidSpell Web .NET
Returns the next mis-spelt word in the text, as a BadWord object.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual BadWord NextBadWord()
Public Overridable Function NextBadWord As BadWord
public:
virtual BadWord^ NextBadWord()
abstract NextBadWord : unit -> BadWord
override NextBadWord : unit -> BadWord
Return Value
BadWord
Keyoti.RapidSpell.BadWord or null if there are no more bad words.


PHONETIC_SUGGESTIONS Field

PHONETIC_SUGGESTIONS Field
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► PHONETIC_SUGGESTIONS
Keyoti RapidSpell Web .NET
Indicator for suggestion method (Hashing is default).
Declaration Syntax
C# Visual Basic Visual C++ F#
public static int PHONETIC_SUGGESTIONS
Public Shared PHONETIC_SUGGESTIONS As Integer
public:
static int PHONETIC_SUGGESTIONS
static val mutable PHONETIC_SUGGESTIONS: int
Field Value
Int32


ReloadUserDictionary Method

ReloadUserDictionary Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► ReloadUserDictionary()()()()
Keyoti RapidSpell Web .NET
Reloads the user dictionary.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void ReloadUserDictionary()
Public Overridable Sub ReloadUserDictionary
public:
virtual void ReloadUserDictionary()
abstract ReloadUserDictionary : unit -> unit
override ReloadUserDictionary : unit -> unit
Remarks
Call this when the user dictionary is changed externally


RemoveIgnorePattern Method (p)

RemoveIgnorePattern Method (p)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► RemoveIgnorePattern(String)
Keyoti RapidSpell Web .NET
Removes a regex pattern to ignore (maximum of 20 can be added - IgnoreURLsAndEmailAddresses=true counts as 1).
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void RemoveIgnorePattern(
    string p
)
Public Overridable Sub RemoveIgnorePattern (
    p As String
)
public:
virtual void RemoveIgnorePattern(
    String^ p
)
abstract RemoveIgnorePattern :
        p : string -> unit
override RemoveIgnorePattern :
        p : string -> unit
Parameters
p (String)


RevertToUndoableStatePoint Method (state)

RevertToUndoableStatePoint Method (state)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► RevertToUndoableStatePoint(RapidSpellChecker..::..State)
Keyoti RapidSpell Web .NET
Reverts the state to what it was when GetUndoableStatePoint()()()() was called.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void RevertToUndoableStatePoint(
    RapidSpellChecker..::..State state
)
Public Overridable Sub RevertToUndoableStatePoint (
    state As RapidSpellChecker..::..State
)
public:
virtual void RevertToUndoableStatePoint(
    RapidSpellChecker..::..State^ state
)
abstract RevertToUndoableStatePoint :
        state : RapidSpellChecker..::..State -> unit
override RevertToUndoableStatePoint :
        state : RapidSpellChecker..::..State -> unit
Parameters
state (RapidSpellChecker..::..State)


SetConsiderationRange Method (w)

SetConsiderationRange Method (w)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► SetConsiderationRange(Int32)
Keyoti RapidSpell Web .NET
Sets the factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anything.
Declaration Syntax
C# Visual Basic Visual C++ F#
public void SetConsiderationRange(
    int w
)
Public Sub SetConsiderationRange (
    w As Integer
)
public:
virtual void SetConsiderationRange(
    int w
) sealed
abstract SetConsiderationRange :
        w : int -> unit
override SetConsiderationRange :
        w : int -> unit
Parameters
w (Int32)


SetDictFileStream Method (dictFileStream, dictionaryID, modifiedDate)

SetDictFileStream Method (dictFileStream, dictionaryID, modifiedDate)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► SetDictFileStream(Stream, String, DateTime)
Keyoti RapidSpell Web .NET
Passes a Dict file as a stream, to be used for the main dictionary.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void SetDictFileStream(
    Stream dictFileStream,
    string dictionaryID,
    DateTime modifiedDate
)
Public Overridable Sub SetDictFileStream (
    dictFileStream As Stream,
    dictionaryID As String,
    modifiedDate As DateTime
)
public:
virtual void SetDictFileStream(
    Stream^ dictFileStream,
    String^ dictionaryID,
    DateTime modifiedDate
)
abstract SetDictFileStream :
        dictFileStream : Stream *
        dictionaryID : string *
        modifiedDate : DateTime -> unit
override SetDictFileStream :
        dictFileStream : Stream *
        dictionaryID : string *
        modifiedDate : DateTime -> unit
Parameters
dictFileStream (Stream)
The stream containing the dictionary
dictionaryID (String)
Any generated identity string which the spell checker can use to cache and identify this dictionary.
modifiedDate (DateTime)
The DateTime when this dictionary was modified, use Now to update the cache.
Remarks
Note this method must be set before Check is called, and the stream position must be at beginning of Dict file. The stream is NOT closed by this method.


SetIgnoreCapitalizedWords Method (v)

SetIgnoreCapitalizedWords Method (v)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► SetIgnoreCapitalizedWords(Boolean)
Keyoti RapidSpell Web .NET
Sets whether to ignore words with capital letters.
Declaration Syntax
C# Visual Basic Visual C++ F#
public void SetIgnoreCapitalizedWords(
    bool v
)
Public Sub SetIgnoreCapitalizedWords (
    v As Boolean
)
public:
virtual void SetIgnoreCapitalizedWords(
    bool v
) sealed
abstract SetIgnoreCapitalizedWords :
        v : bool -> unit
override SetIgnoreCapitalizedWords :
        v : bool -> unit
Parameters
v (Boolean)


SetIncludeUserDictionaryInSuggestions Method (v)

SetIncludeUserDictionaryInSuggestions Method (v)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► SetIncludeUserDictionaryInSuggestions(Boolean)
Keyoti RapidSpell Web .NET
Sets whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# Visual Basic Visual C++ F#
public void SetIncludeUserDictionaryInSuggestions(
    bool v
)
Public Sub SetIncludeUserDictionaryInSuggestions (
    v As Boolean
)
public:
virtual void SetIncludeUserDictionaryInSuggestions(
    bool v
) sealed
abstract SetIncludeUserDictionaryInSuggestions :
        v : bool -> unit
override SetIncludeUserDictionaryInSuggestions :
        v : bool -> unit
Parameters
v (Boolean)


SetOptionalContext Method (beforeToCheckSnippet, afterToCheckSnippet)

SetOptionalContext Method (beforeToCheckSnippet, afterToCheckSnippet)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► SetOptionalContext(String, String)
Keyoti RapidSpell Web .NET
Provides the engine with any helpful text around the text snippet which will be passed to the Check method.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void SetOptionalContext(
    string beforeToCheckSnippet,
    string afterToCheckSnippet
)
Public Overridable Sub SetOptionalContext (
    beforeToCheckSnippet As String,
    afterToCheckSnippet As String
)
public:
virtual void SetOptionalContext(
    String^ beforeToCheckSnippet,
    String^ afterToCheckSnippet
)
abstract SetOptionalContext :
        beforeToCheckSnippet : string *
        afterToCheckSnippet : string -> unit
override SetOptionalContext :
        beforeToCheckSnippet : string *
        afterToCheckSnippet : string -> unit
Parameters
beforeToCheckSnippet (String)
Any text before the to check snippet
afterToCheckSnippet (String)
Any text after the snippet
Remarks
Eg. if the document contains "This is an an example piece." and Check will be called on "an example piece", then the fact that 'an' is duplicated will not be detected. Therefore, by passing "This is an " to beforeToCheckSnippet the checker will be able to detect that an is duplicated.


SetPosition Method (pos)

SetPosition Method (pos)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► SetPosition(Int32)
Keyoti RapidSpell Web .NET
Sets the pointer position for the NextBadWord iterator.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void SetPosition(
    int pos
)
Public Overridable Sub SetPosition (
    pos As Integer
)
public:
virtual void SetPosition(
    int pos
)
abstract SetPosition :
        pos : int -> unit
override SetPosition :
        pos : int -> unit
Parameters
pos (Int32)
Remarks
Further calls to NextBadWord will look for the next bad word from position pos. If position > the text length it is set to the text length. If position < 0, it is set to zero.


SetSeparateHyphenWords Method (f)

SetSeparateHyphenWords Method (f)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► SetSeparateHyphenWords(Boolean)
Keyoti RapidSpell Web .NET
Sets whether to treat hyphenated (-) words as separate words, default is false.
Declaration Syntax
C# Visual Basic Visual C++ F#
public void SetSeparateHyphenWords(
    bool f
)
Public Sub SetSeparateHyphenWords (
    f As Boolean
)
public:
virtual void SetSeparateHyphenWords(
    bool f
) sealed
abstract SetSeparateHyphenWords :
        f : bool -> unit
override SetSeparateHyphenWords :
        f : bool -> unit
Parameters
f (Boolean)
Remarks
For eg. if this is true text like "cheap-deals" will be treated as two words "cheap" and "deals", otherwise this will be treated as one word "cheap-deals". Also see LookIntoHyphenatedText.


SetSuggestionsMethod Method (method)

SetSuggestionsMethod Method (method)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► SetSuggestionsMethod(Int32)
Keyoti RapidSpell Web .NET
Sets the suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
Declaration Syntax
C# Visual Basic Visual C++ F#
public void SetSuggestionsMethod(
    int method
)
Public Sub SetSuggestionsMethod (
    method As Integer
)
public:
virtual void SetSuggestionsMethod(
    int method
) sealed
abstract SetSuggestionsMethod :
        method : int -> unit
override SetSuggestionsMethod :
        method : int -> unit
Parameters
method (Int32)


SetUserDictionary Method

SetUserDictionary Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► SetUserDictionary()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | SetUserDictionary(String) | Set the user dictionary to use.
 | SetUserDictionary(UserDictionary) | Set the user dictionary to use.


SetUserDictionary Method (userDictionary)

SetUserDictionary Method (userDictionary)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► SetUserDictionary(UserDictionary)
Keyoti RapidSpell Web .NET
Set the user dictionary to use.
Declaration Syntax
C# Visual Basic Visual C++ F#
public void SetUserDictionary(
    UserDictionary userDictionary
)
Public Sub SetUserDictionary (
    userDictionary As UserDictionary
)
public:
virtual void SetUserDictionary(
    UserDictionary^ userDictionary
) sealed
abstract SetUserDictionary :
        userDictionary : UserDictionary -> unit
override SetUserDictionary :
        userDictionary : UserDictionary -> unit
Parameters
userDictionary (UserDictionary)
a UserDictionary object representing a user dictionary
Remarks
If the userDictionary can not be created/read it will be ignored
Exceptions
Exception | Condition
ArgumentNullException | if userDictionary is null.


SetUserDictionary Method (userDictionaryFile)

SetUserDictionary Method (userDictionaryFile)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► SetUserDictionary(String)
Keyoti RapidSpell Web .NET
Set the user dictionary to use.
Declaration Syntax
C# Visual Basic Visual C++ F#
public void SetUserDictionary(
    string userDictionaryFile
)
Public Sub SetUserDictionary (
    userDictionaryFile As String
)
public:
virtual void SetUserDictionary(
    String^ userDictionaryFile
) sealed
abstract SetUserDictionary :
        userDictionaryFile : string -> unit
override SetUserDictionary :
        userDictionaryFile : string -> unit
Parameters
userDictionaryFile (String)
a file to be used as a user dictionary
Remarks
If the userDictionary can not be created/read it will be ignored
Exceptions
Exception | Condition
ArgumentNullException | if userDictionaryFile is null


ShareDictionary Property

ShareDictionary Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► ShareDictionary
Keyoti RapidSpell Web .NET
Whether to share the dictionary in memory across all instances of RapidSpellChecker (false by default).
Declaration Syntax
C# Visual Basic Visual C++ F#
[ObsoleteAttribute("Unnecessary, all dictionaries are cached now in a superior manner.",
    false)]
public bool ShareDictionary { get; set; }
<ObsoleteAttribute("Unnecessary, all dictionaries are cached now in a superior manner.",
    false)>
Public Property ShareDictionary As Boolean
    Get
    Set
public:
[ObsoleteAttribute(L"Unnecessary, all dictionaries are cached now in a superior manner.",
    false)]
property bool ShareDictionary {
    bool get ();
    void set (bool value);
}
[<ObsoleteAttribute("Unnecessary, all dictionaries are cached now in a superior manner.",
    false)>]
member ShareDictionary : bool with get, set
Property Value
Boolean
Remarks
Setting this to true will lower memory usage if multiple instances of RapidSpellChecker are in use at once, but will mean that only one dictionary may be used at one time. This does not affect user dictionaries.

Note that all instances with this set to true should use the same dictionary. This property must be set before any spell checking begins.


SuggestSplitWords Property

SuggestSplitWords Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► SuggestSplitWords
Keyoti RapidSpell Web .NET
Whether to look for connected words in suggestions.
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool SuggestSplitWords { get; set; }
Public Property SuggestSplitWords As Boolean
    Get
    Set
public:
virtual property bool SuggestSplitWords {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract SuggestSplitWords : bool with get, set
override SuggestSplitWords : bool with get, set
Property Value
Boolean
Remarks
if this=true then suggestions may include joined words.

Eg; suggestions for "yourhouse" will include "yourhouse"

Setting this to true (default) has a slight performance impact.


TextBoundary Property

TextBoundary Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► TextBoundary
Keyoti RapidSpell Web .NET
The AdvancedTextBoundary class to use to parse words.
Declaration Syntax
C# Visual Basic Visual C++ F#
public AdvancedTextBoundary TextBoundary { get; set; }
Public Property TextBoundary As AdvancedTextBoundary
    Get
    Set
public:
virtual property AdvancedTextBoundary^ TextBoundary {
    AdvancedTextBoundary^ get () sealed;
    void set (AdvancedTextBoundary^ value) sealed;
}
abstract TextBoundary : AdvancedTextBoundary with get, set
override TextBoundary : AdvancedTextBoundary with get, set
Property Value
AdvancedTextBoundary


theCurrentBadWord Field

theCurrentBadWord Field
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► theCurrentBadWord
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
protected BadWord theCurrentBadWord
Protected theCurrentBadWord As BadWord
protected:
BadWord^ theCurrentBadWord
val mutable theCurrentBadWord: BadWord
Field Value
BadWord


theText Field

theText Field
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► theText
Keyoti RapidSpell Web .NET
The text being checked.
Declaration Syntax
C# Visual Basic Visual C++ F#
protected StringBuilder theText
Protected theText As StringBuilder
protected:
StringBuilder^ theText
val mutable theText: StringBuilder
Field Value
StringBuilder


UnloadMainDictionary Method

UnloadMainDictionary Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► UnloadMainDictionary()()()()
Keyoti RapidSpell Web .NET
Empties the main dictionary store.
Declaration Syntax
C# Visual Basic Visual C++ F#
[ObsoleteAttribute("No longer useful because of new dictionary caching.  See release notes.",
    true)]
public void UnloadMainDictionary()
<ObsoleteAttribute("No longer useful because of new dictionary caching.  See release notes.",
    true)>
Public Sub UnloadMainDictionary
public:
[ObsoleteAttribute(L"No longer useful because of new dictionary caching.  See release notes.",
    true)]
void UnloadMainDictionary()
[<ObsoleteAttribute("No longer useful because of new dictionary caching.  See release notes.",
    true)>]
member UnloadMainDictionary : unit -> unit


userDictionary Property

userDictionary Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► userDictionary
Keyoti RapidSpell Web .NET
The UserDictionary being used, may be null if no user dictionary is being used.
Declaration Syntax
C# Visual Basic Visual C++ F#
public UserDictionary userDictionary { get; set; }
Public Property userDictionary As UserDictionary
    Get
    Set
public:
virtual property UserDictionary^ userDictionary {
    UserDictionary^ get () sealed;
    void set (UserDictionary^ value) sealed;
}
abstract userDictionary : UserDictionary with get, set
override userDictionary : UserDictionary with get, set
Property Value
UserDictionary


V2Parser Property

V2Parser Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► V2Parser
Keyoti RapidSpell Web .NET
Whether to use parser version 2 - Set to false for backwards compatibility.
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool V2Parser { get; set; }
Public Property V2Parser As Boolean
    Get
    Set
public:
virtual property bool V2Parser {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract V2Parser : bool with get, set
override V2Parser : bool with get, set
Property Value
Boolean


WarnDuplicates Property

WarnDuplicates Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► WarnDuplicates
Keyoti RapidSpell Web .NET
Whether to treat duplicate words as errors (eg. "this is is an error").
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool WarnDuplicates { get; set; }
Public Property WarnDuplicates As Boolean
    Get
    Set
public:
virtual property bool WarnDuplicates {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract WarnDuplicates : bool with get, set
override WarnDuplicates : bool with get, set
Property Value
Boolean


WordAdded Event

WordAdded Event
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► WordAdded
Keyoti RapidSpell Web .NET
Fired when word added to user dictionary
Declaration Syntax
C# Visual Basic Visual C++ F#
public event WordAddedEventHandler WordAdded
Public Event WordAdded As WordAddedEventHandler
public:
 event WordAddedEventHandler^ WordAdded {
    void add (WordAddedEventHandler^ value);
    void remove (WordAddedEventHandler^ value);
}
member WordAdded : IEvent<WordAddedEventHandler,
    WordAddedEventArgs>
Value
WordAddedEventHandler


wordEnd Field

wordEnd Field
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► wordEnd
Keyoti RapidSpell Web .NET
The end index of the current word being checked/parsed.
Declaration Syntax
C# Visual Basic Visual C++ F#
protected int wordEnd
Protected wordEnd As Integer
protected:
int wordEnd
val mutable wordEnd: int
Field Value
Int32


WordIgnored Event

WordIgnored Event
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► WordIgnored
Keyoti RapidSpell Web .NET
Fired when word ignored
Declaration Syntax
C# Visual Basic Visual C++ F#
public event WordIgnoredEventHandler WordIgnored
Public Event WordIgnored As WordIgnoredEventHandler
public:
 event WordIgnoredEventHandler^ WordIgnored {
    void add (WordIgnoredEventHandler^ value);
    void remove (WordIgnoredEventHandler^ value);
}
member WordIgnored : IEvent<WordIgnoredEventHandler,
    WordIgnoredEventArgs>
Value
WordIgnoredEventHandler


wordStart Field

wordStart Field
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► wordStart
Keyoti RapidSpell Web .NET
The start index of the current word being checked/parsed.
Declaration Syntax
C# Visual Basic Visual C++ F#
protected int wordStart
Protected wordStart As Integer
protected:
int wordStart
val mutable wordStart: int
Field Value
Int32


RapidSpellChecker.ChangeWordEventHandler Delegate

RapidSpellChecker..::..ChangeWordEventHandler Delegate
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► RapidSpellChecker..::..ChangeWordEventHandler
Keyoti RapidSpell Web .NET
Change word event handler delegate.
Declaration Syntax
C# Visual Basic Visual C++ F#
public delegate void ChangeWordEventHandler(
    Object sender,
    ChangeWordEventArgs e
)
Public Delegate Sub ChangeWordEventHandler (
    sender As Object,
    e As ChangeWordEventArgs
)
public delegate void ChangeWordEventHandler(
    Object^ sender,
    ChangeWordEventArgs^ e
)
type ChangeWordEventHandler =
    delegate of
        sender : Object *
        e : ChangeWordEventArgs -> unit
Parameters
sender (Object)
e (ChangeWordEventArgs)


RapidSpellChecker.State Class

RapidSpellChecker..::..State Class
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker ► RapidSpellChecker..::..State
Keyoti RapidSpell Web .NET
State of the spell checker
Declaration Syntax
C# Visual Basic Visual C++ F#
public class State
Public Class State
public ref class State
type State =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RapidSpellChecker..::..State(Int32, String, BadWord) | New
 | CurrentBadWord | Current misspelling
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Position | Spell checkers position in text
 | PreviousWord | Word before current word
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
RapidSpellChecker..::..State


RapidSpellChecker.State Constructor (position, previousWord, currentBadWord)

RapidSpellChecker..::..State Constructor (position, previousWord, currentBadWord)
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker..::..State ► RapidSpellChecker..::..State(Int32, String, BadWord)
Keyoti RapidSpell Web .NET
New
Declaration Syntax
C# Visual Basic Visual C++ F#
public State(
    int position,
    string previousWord,
    BadWord currentBadWord
)
Public Sub New (
    position As Integer,
    previousWord As String,
    currentBadWord As BadWord
)
public:
State(
    int position,
    String^ previousWord,
    BadWord^ currentBadWord
)
new :
        position : int *
        previousWord : string *
        currentBadWord : BadWord -> State
Parameters
position (Int32)
previousWord (String)
currentBadWord (BadWord)


CurrentBadWord Property

CurrentBadWord Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker..::..State ► CurrentBadWord
Keyoti RapidSpell Web .NET
Current misspelling
Declaration Syntax
C# Visual Basic Visual C++ F#
public BadWord CurrentBadWord { get; set; }
Public Property CurrentBadWord As BadWord
    Get
    Set
public:
property BadWord^ CurrentBadWord {
    BadWord^ get ();
    void set (BadWord^ value);
}
member CurrentBadWord : BadWord with get, set
Property Value
BadWord


Position Property

Position Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker..::..State ► Position
Keyoti RapidSpell Web .NET
Spell checkers position in text
Declaration Syntax
C# Visual Basic Visual C++ F#
public int Position { get; set; }
Public Property Position As Integer
    Get
    Set
public:
property int Position {
    int get ();
    void set (int value);
}
member Position : int with get, set
Property Value
Int32


PreviousWord Property

PreviousWord Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellChecker..::..State ► PreviousWord
Keyoti RapidSpell Web .NET
Word before current word
Declaration Syntax
C# Visual Basic Visual C++ F#
public string PreviousWord { get; set; }
Public Property PreviousWord As String
    Get
    Set
public:
property String^ PreviousWord {
    String^ get ();
    void set (String^ value);
}
member PreviousWord : string with get, set
Property Value
String


RapidSpellCheckerClient Class

RapidSpellCheckerClient Class
API Documentation ► Keyoti.RapidSpell ► RapidSpellCheckerClient
Keyoti RapidSpell Web .NET
Javascript (AJAX) based text oriented spell checker object.
Declaration Syntax
C# Visual Basic Visual C++ F#
public class RapidSpellCheckerClient : WebControl
Public Class RapidSpellCheckerClient
    Inherits WebControl
public ref class RapidSpellCheckerClient : public WebControl
type RapidSpellCheckerClient =
    class
        inherit WebControl
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RapidSpellCheckerClient()()()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AllowMixedCase | Whether to allow words spelt with mixed case, eg. "MIxEd"
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BeginRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | CheckCompoundWords | Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearCachedClientID()()()() | (Inherited from Control.)
 | ClearChildControlState()()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClearEffectiveClientIDMode()()()() | (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDMode | (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientSideObject | The name of the Javascript variable holding an instance of the spell checker.
 | ConsiderationRange | The size factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anyting.
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataItemContainer | (Inherited from Control.)
 | DataKeysContainer | (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DictFile | (Optional) main dictionary (.dict) file on the server.
 | Dispose()()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Theming is currently disabled. Support to be added in later versions. (Overrides WebControl.EnableTheming.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EndRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | EnsureChildControls()()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
 | Focus()()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRouteUrl(Object) | (Inherited from Control.)
 | GetRouteUrl(String, Object) | (Inherited from Control.)
 | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
 | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetUniqueIDRelativeTo(Control) | (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | IgnoreCapitalizedWords | Whether to ignore words with capital letters.
 | IgnoreURLsAndEmailAddresses | Whether to ignore URLs and email addresses (requires V2Parser=true)
 | IgnoreWordsWithDigits | Whether to ignore words with numbers in them (eg. A10 or 7-11).
 | IgnoreXML | Whether to ignore XML/HTML tags, false by default.
 | IncludeUserDictionaryInSuggestions | Whether the user dictionary should be used in finding suggestions for misspelt words.
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | LanguageParser | The language parser to use, this should match the language of the main dictionary where possible.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LookIntoHyphenatedText | Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Emits the required Javascript (Overrides Control.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RapidSpellWInlineHelperPage | The URL of the page holding the RapidSpellWInlineHelper control.
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Render this control to the output parameter specified. (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderingCompatibility | (Inherited from Control.)
 | ResolveAdapter()()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | ResponseTimeout | Number of seconds to pass before a message is shown to the user reporting a time-out.
 | ResponseTimeoutMessage | The message shown to the user in the event that the spell check request times-out.
 | SaveControlState()()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()()() | Saves any state that was modified after the TrackViewState()()()() method was invoked. (Inherited from WebControl.)
 | SeparateHyphenWords | Whether to treat hyphenated (-) words as separate words, default is false.
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetTraceData(Object, Object) | (Inherited from Control.)
 | SetTraceData(Object, Object, Object) | (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | SuggestionsMethod | Suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
 | SuggestSplitWords | Whether to look for connected words in suggestions.
 | SupportsDisabledAttribute | (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TrackViewState()()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UserDictionaryFile | The user dictionary file on the server for the user.
 | ValidateRequestMode | (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateMode | (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WarnDuplicates | Whether to show duplicate words as errors (eg. "this is is an error").
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Remarks
When added to a form, creates a Javascript object which can be used for programmatic spell checking on the client side. See RapidSpellChecker class for serverside checking.
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | RapidSpellCheckerClient


RapidSpellCheckerClient Constructor

RapidSpellCheckerClient Constructor
API Documentation ► Keyoti.RapidSpell ► RapidSpellCheckerClient ► RapidSpellCheckerClient()()()()
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public RapidSpellCheckerClient()
Public Sub New
public:
RapidSpellCheckerClient()
new : unit -> RapidSpellCheckerClient


AllowMixedCase Property

AllowMixedCase Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellCheckerClient ► AllowMixedCase
Keyoti RapidSpell Web .NET
Whether to allow words spelt with mixed case, eg. "MIxEd"
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool AllowMixedCase { get; set; }
Public Property AllowMixedCase As Boolean
    Get
    Set
public:
property bool AllowMixedCase {
    bool get ();
    void set (bool value);
}
member AllowMixedCase : bool with get, set
Property Value
Boolean


CheckCompoundWords Property

CheckCompoundWords Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellCheckerClient ► CheckCompoundWords
Keyoti RapidSpell Web .NET
Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool CheckCompoundWords { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property CheckCompoundWords As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool CheckCompoundWords {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member CheckCompoundWords : bool with get, set
Property Value
Boolean
Remarks
If this=false then LookUp("thesewordsarejoined") = false

If this=true then LookUp("thesewordsarejoined") = true

If this=false then LookUp("abcdef") = false

If this=true then LookUp("abcdef") = false

Setting this to true will degrade lookup performance


ClientSideObject Property

ClientSideObject Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellCheckerClient ► ClientSideObject
Keyoti RapidSpell Web .NET
The name of the Javascript variable holding an instance of the spell checker.
Declaration Syntax
C# Visual Basic Visual C++ F#
public string ClientSideObject { get; }
Public ReadOnly Property ClientSideObject As String
    Get
public:
property String^ ClientSideObject {
    String^ get ();
}
member ClientSideObject : string with get
Property Value
String


ConsiderationRange Property

ConsiderationRange Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellCheckerClient ► ConsiderationRange
Keyoti RapidSpell Web .NET
The size factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anyting.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public int ConsiderationRange { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ConsiderationRange As Integer
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property int ConsiderationRange {
    int get ();
    void set (int value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ConsiderationRange : int with get, set
Property Value
Int32


DictFile Property

DictFile Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellCheckerClient ► DictFile
Keyoti RapidSpell Web .NET
(Optional) main dictionary (.dict) file on the server.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string DictFile { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property DictFile As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ DictFile {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member DictFile : string with get, set
Property Value
String
Remarks
This should be an absolute path.


EnableTheming Property

EnableTheming Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellCheckerClient ► EnableTheming
Keyoti RapidSpell Web .NET
Theming is currently disabled. Support to be added in later versions.
Declaration Syntax
C# Visual Basic Visual C++ F#
public override bool EnableTheming { get; }
Public Overrides ReadOnly Property EnableTheming As Boolean
    Get
public:
virtual property bool EnableTheming {
    bool get () override;
}
abstract EnableTheming : bool with get
override EnableTheming : bool with get
Property Value
Boolean


IgnoreCapitalizedWords Property

IgnoreCapitalizedWords Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellCheckerClient ► IgnoreCapitalizedWords
Keyoti RapidSpell Web .NET
Whether to ignore words with capital letters.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool IgnoreCapitalizedWords { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property IgnoreCapitalizedWords As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool IgnoreCapitalizedWords {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member IgnoreCapitalizedWords : bool with get, set
Property Value
Boolean


IgnoreURLsAndEmailAddresses Property

IgnoreURLsAndEmailAddresses Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellCheckerClient ► IgnoreURLsAndEmailAddresses
Keyoti RapidSpell Web .NET
Whether to ignore URLs and email addresses (requires V2Parser=true)
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool IgnoreURLsAndEmailAddresses { get; set; }
Public Property IgnoreURLsAndEmailAddresses As Boolean
    Get
    Set
public:
property bool IgnoreURLsAndEmailAddresses {
    bool get ();
    void set (bool value);
}
member IgnoreURLsAndEmailAddresses : bool with get, set
Property Value
Boolean
Remarks
This will cause the following strings to be accepted as non-spelling errors;
"user@domain.com", "http://www.domain.com", "domain.co.uk" etc.


IgnoreWordsWithDigits Property

IgnoreWordsWithDigits Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellCheckerClient ► IgnoreWordsWithDigits
Keyoti RapidSpell Web .NET
Whether to ignore words with numbers in them (eg. A10 or 7-11).
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool IgnoreWordsWithDigits { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property IgnoreWordsWithDigits As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool IgnoreWordsWithDigits {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member IgnoreWordsWithDigits : bool with get, set
Property Value
Boolean


IgnoreXML Property

IgnoreXML Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellCheckerClient ► IgnoreXML
Keyoti RapidSpell Web .NET
Whether to ignore XML/HTML tags, false by default.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool IgnoreXML { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property IgnoreXML As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member IgnoreXML : bool with get, set
Property Value
Boolean
Remarks
This identifies XML tags as anything in between < and > characters, there for it will cause undesirable effects in text such as "the sign for less than is < and the sign for greater than is >". Of course in HTML that should have been written as "the sign for less than is &lt; and the sign for greater than is &gt;" anyway, which would be fine.


IncludeUserDictionaryInSuggestions Property

IncludeUserDictionaryInSuggestions Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellCheckerClient ► IncludeUserDictionaryInSuggestions
Keyoti RapidSpell Web .NET
Whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool IncludeUserDictionaryInSuggestions { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property IncludeUserDictionaryInSuggestions As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool IncludeUserDictionaryInSuggestions {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member IncludeUserDictionaryInSuggestions : bool with get, set
Property Value
Boolean


LanguageParser Property

LanguageParser Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellCheckerClient ► LanguageParser
Keyoti RapidSpell Web .NET
The language parser to use, this should match the language of the main dictionary where possible.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public LanguageType LanguageParser { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property LanguageParser As LanguageType
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property LanguageType LanguageParser {
    LanguageType get ();
    void set (LanguageType value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member LanguageParser : LanguageType with get, set
Property Value
LanguageType
Remarks
This is used to give hints to the parser about how punctuation is used (eg. apostrophe is used differently in English and French).


LookIntoHyphenatedText Property

LookIntoHyphenatedText Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellCheckerClient ► LookIntoHyphenatedText
Keyoti RapidSpell Web .NET
Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool LookIntoHyphenatedText { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property LookIntoHyphenatedText As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool LookIntoHyphenatedText {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member LookIntoHyphenatedText : bool with get, set
Property Value
Boolean
Remarks
Eg. "socio-economic" will be checked as "socio" and "economic".


OnPreRender Method (e)

OnPreRender Method (e)
API Documentation ► Keyoti.RapidSpell ► RapidSpellCheckerClient ► OnPreRender(EventArgs)
Keyoti RapidSpell Web .NET
Emits the required Javascript
Declaration Syntax
C# Visual Basic Visual C++ F#
protected override void OnPreRender(
    EventArgs e
)
Protected Overrides Sub OnPreRender (
    e As EventArgs
)
protected:
virtual void OnPreRender(
    EventArgs^ e
) override
abstract OnPreRender :
        e : EventArgs -> unit
override OnPreRender :
        e : EventArgs -> unit
Parameters
e (EventArgs)


RapidSpellWInlineHelperPage Property

RapidSpellWInlineHelperPage Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellCheckerClient ► RapidSpellWInlineHelperPage
Keyoti RapidSpell Web .NET
The URL of the page holding the RapidSpellWInlineHelper control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string RapidSpellWInlineHelperPage { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property RapidSpellWInlineHelperPage As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ RapidSpellWInlineHelperPage {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member RapidSpellWInlineHelperPage : string with get, set
Property Value
String


Render Method (output)

Render Method (output)
API Documentation ► Keyoti.RapidSpell ► RapidSpellCheckerClient ► Render(HtmlTextWriter)
Keyoti RapidSpell Web .NET
Render this control to the output parameter specified.
Declaration Syntax
C# Visual Basic Visual C++ F#
protected override void Render(
    HtmlTextWriter output
)
Protected Overrides Sub Render (
    output As HtmlTextWriter
)
protected:
virtual void Render(
    HtmlTextWriter^ output
) override
abstract Render :
        output : HtmlTextWriter -> unit
override Render :
        output : HtmlTextWriter -> unit
Parameters
output (HtmlTextWriter)
The HTML writer to write out to


ResponseTimeout Property

ResponseTimeout Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellCheckerClient ► ResponseTimeout
Keyoti RapidSpell Web .NET
Number of seconds to pass before a message is shown to the user reporting a time-out.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public int ResponseTimeout { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ResponseTimeout As Integer
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property int ResponseTimeout {
    int get ();
    void set (int value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ResponseTimeout : int with get, set
Property Value
Int32


ResponseTimeoutMessage Property

ResponseTimeoutMessage Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellCheckerClient ► ResponseTimeoutMessage
Keyoti RapidSpell Web .NET
The message shown to the user in the event that the spell check request times-out.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string ResponseTimeoutMessage { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ResponseTimeoutMessage As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ ResponseTimeoutMessage {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ResponseTimeoutMessage : string with get, set
Property Value
String


SeparateHyphenWords Property

SeparateHyphenWords Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellCheckerClient ► SeparateHyphenWords
Keyoti RapidSpell Web .NET
Whether to treat hyphenated (-) words as separate words, default is false.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool SeparateHyphenWords { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property SeparateHyphenWords As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool SeparateHyphenWords {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member SeparateHyphenWords : bool with get, set
Property Value
Boolean
Remarks
For eg. if this is true text like "cheap-deals" will be treated as two words "cheap" and "deals", otherwise this will be treated as one word "cheap-deals".


SuggestionsMethod Property

SuggestionsMethod Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellCheckerClient ► SuggestionsMethod
Keyoti RapidSpell Web .NET
Suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string SuggestionsMethod { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property SuggestionsMethod As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ SuggestionsMethod {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member SuggestionsMethod : string with get, set
Property Value
String


SuggestSplitWords Property

SuggestSplitWords Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellCheckerClient ► SuggestSplitWords
Keyoti RapidSpell Web .NET
Whether to look for connected words in suggestions.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool SuggestSplitWords { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property SuggestSplitWords As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool SuggestSplitWords {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member SuggestSplitWords : bool with get, set
Property Value
Boolean
Remarks
if this=true then suggestions may include joined words.

Eg; suggestions for "myhouse" will include "my house"


UserDictionaryFile Property

UserDictionaryFile Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellCheckerClient ► UserDictionaryFile
Keyoti RapidSpell Web .NET
The user dictionary file on the server for the user.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string UserDictionaryFile { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property UserDictionaryFile As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ UserDictionaryFile {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member UserDictionaryFile : string with get, set
Property Value
String
Remarks
This should be an absolute path.


WarnDuplicates Property

WarnDuplicates Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellCheckerClient ► WarnDuplicates
Keyoti RapidSpell Web .NET
Whether to show duplicate words as errors (eg. "this is is an error").
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool WarnDuplicates { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property WarnDuplicates As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool WarnDuplicates {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member WarnDuplicates : bool with get, set
Property Value
Boolean


RapidSpellWeb Class

RapidSpellWeb Class
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb
Keyoti RapidSpell Web .NET
RapidSpell Web Control, this control is the actual dialog spell checker, called from RapidSpellWebLauncher.
Declaration Syntax
C# Visual Basic Visual C++ F#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class RapidSpellWeb : WebControl,
    INamingContainer
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Class RapidSpellWeb
    Inherits WebControl
    Implements INamingContainer
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public ref class RapidSpellWeb : public WebControl,
    INamingContainer
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
type RapidSpellWeb =
    class
        inherit WebControl
        interface INamingContainer
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RapidSpellWeb()()()() | Creates the RapidSpellWeb control
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddButton | The 'add' button, is only displayed if the user dictionary file is specified in the RapidSpellWebLauncher control.
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BeginRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | CacheDictionary | Whether to cache the main dictionary, this will result in large performance gains. WARNING, do not do this if using more than one dictionary across the application.
 | ChangeAllButton | The 'change all' button.
 | ChangeButton | The 'change' button.
 | ChangeToBox | The text box where the 'change to' word is displayed.
 | ChangeToLabel | The 'change to' text box label
 | CheckerEngine | The ICheckerEngine object to be used to check the text.
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearCachedClientID()()()() | (Inherited from Control.)
 | ClearChildControlState()()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClearEffectiveClientIDMode()()()() | (Inherited from Control.)
 | ClientFilesFolder | Where the client files are found, must be an absolute path to the directory containing the RapidSpell client files.
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDMode | (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataItemContainer | (Inherited from Control.)
 | DataKeysContainer | (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EffectiveClientFilesLocation | Where to look for client files.
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Theming is currently disabled. Support to be added in later versions. (Overrides WebControl.EnableTheming.)
 | EnableViewState | Viewstate is always disabled. (Overrides Control.EnableViewState.)
 | EndRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | EnsureChildControls()()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | FieldDisplayTextLabel | The field being checked label
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
 | FinishButton | The 'finish' button.
 | FinishedText | The text displayed when the spell check finishes.
 | Focus()()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRouteUrl(Object) | (Inherited from Control.)
 | GetRouteUrl(String, Object) | (Inherited from Control.)
 | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
 | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetUniqueIDRelativeTo(Control) | (Inherited from Control.)
 | GlobalChangeAll | Whether change all operations should be global.
 | GlobalIgnoreAll | Whether ignore all operations should be global.
 | GotText |
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | HideUserDictionaryErrors | When errors occur with the user dictionary, they are reported to the user if this==false.
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | IgnoreAllButton | The 'ignore all' button.
 | IgnoreButton | The 'ignore' button.
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLicenseValid(HttpRequest) | Whether there is a valid license key in the web.config for this request.
 | IsLiteralContent()()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Layout | The Html layout template used to layout this control.
 | LicenseKey | The license key for the spell checker.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NoErrorsText | The text displayed when the spell check finishes with no spelling errors.
 | NoSuggestionsText | The text displayed when the spell check has no suggestions.
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Register client scripts (Overrides Control.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | OptionsButton | The 'options' button.
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | PreviewPaneCSSLinkURL | The URL of the stylesheet to use in the preview pane.
 | PreviewPaneStyle | Thee 'preview pane' style, this defines the style of the inner frame that shows the document preview during spell checking.
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | RemoveDuplicateText | The text displayed when the spell check finds a duplicate word error.
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders this control. (Overrides WebControl.RenderContents(HtmlTextWriter).)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderForDesign(HtmlTextWriter) | Renders this control for the design surface.
 | RenderingCompatibility | (Inherited from Control.)
 | ResolveAdapter()()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()()() | Saves any state that was modified after the TrackViewState()()()() method was invoked. (Inherited from WebControl.)
 | ScriptFilterLevel | Script filter level; 0=none 15=all. Whether to filter scripting elements from the preview pane and at what level.
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetTraceData(Object, Object) | (Inherited from Control.)
 | SetTraceData(Object, Object, Object) | (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SSLFriendly | Whether to run in SSL friendly mode, setting this to true prevents mixed content warning messages in IE.
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | SuggestionsBox | The text box where the suggestions are displayed.
 | SuggestionsLabel | The suggestions box label
 | SupportsDisabledAttribute | (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TrackViewState()()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UndoButton | The 'undo' button.
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UserDictionary | A UserDictionary object to be used as a user dictionary.
 | ValidateRequestMode | (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateMode | (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | RapidSpellWeb


RapidSpellWeb Constructor

RapidSpellWeb Constructor
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► RapidSpellWeb()()()()
Keyoti RapidSpell Web .NET
Creates the RapidSpellWeb control
Declaration Syntax
C# Visual Basic Visual C++ F#
public RapidSpellWeb()
Public Sub New
public:
RapidSpellWeb()
new : unit -> RapidSpellWeb


AddButton Property

AddButton Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► AddButton
Keyoti RapidSpell Web .NET
The 'add' button, is only displayed if the user dictionary file is specified in the RapidSpellWebLauncher control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public RSButton AddButton { get; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property AddButton As RSButton
    Get
public:
[PersistenceModeAttribute(PersistenceMode::InnerProperty)]
property RSButton^ AddButton {
    RSButton^ get ();
}
[<PersistenceModeAttribute(PersistenceMode.InnerProperty)>]
member AddButton : RSButton with get
Property Value
RSButton


CacheDictionary Property

CacheDictionary Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► CacheDictionary
Keyoti RapidSpell Web .NET
Whether to cache the main dictionary, this will result in large performance gains. WARNING, do not do this if using more than one dictionary across the application.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool CacheDictionary { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property CacheDictionary As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool CacheDictionary {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member CacheDictionary : bool with get, set
Property Value
Boolean
Remarks
When this is set true the main dictionary instance is shared amongst all other instances of this control where this property is set true, therefore conflicts will occur if they have different dictionaries.


ChangeAllButton Property

ChangeAllButton Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► ChangeAllButton
Keyoti RapidSpell Web .NET
The 'change all' button.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public RSButton ChangeAllButton { get; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property ChangeAllButton As RSButton
    Get
public:
[PersistenceModeAttribute(PersistenceMode::InnerProperty)]
property RSButton^ ChangeAllButton {
    RSButton^ get ();
}
[<PersistenceModeAttribute(PersistenceMode.InnerProperty)>]
member ChangeAllButton : RSButton with get
Property Value
RSButton


ChangeButton Property

ChangeButton Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► ChangeButton
Keyoti RapidSpell Web .NET
The 'change' button.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public RSButton ChangeButton { get; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property ChangeButton As RSButton
    Get
public:
[PersistenceModeAttribute(PersistenceMode::InnerProperty)]
property RSButton^ ChangeButton {
    RSButton^ get ();
}
[<PersistenceModeAttribute(PersistenceMode.InnerProperty)>]
member ChangeButton : RSButton with get
Property Value
RSButton


ChangeToBox Property

ChangeToBox Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► ChangeToBox
Keyoti RapidSpell Web .NET
The text box where the 'change to' word is displayed.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public RSText ChangeToBox { get; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property ChangeToBox As RSText
    Get
public:
[PersistenceModeAttribute(PersistenceMode::InnerProperty)]
property RSText^ ChangeToBox {
    RSText^ get ();
}
[<PersistenceModeAttribute(PersistenceMode.InnerProperty)>]
member ChangeToBox : RSText with get
Property Value
RSText


ChangeToLabel Property

ChangeToLabel Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► ChangeToLabel
Keyoti RapidSpell Web .NET
The 'change to' text box label
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public RSLabel ChangeToLabel { get; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property ChangeToLabel As RSLabel
    Get
public:
[PersistenceModeAttribute(PersistenceMode::InnerProperty)]
property RSLabel^ ChangeToLabel {
    RSLabel^ get ();
}
[<PersistenceModeAttribute(PersistenceMode.InnerProperty)>]
member ChangeToLabel : RSLabel with get
Property Value
RSLabel


CheckerEngine Property

CheckerEngine Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► CheckerEngine
Keyoti RapidSpell Web .NET
The ICheckerEngine object to be used to check the text.
Declaration Syntax
C# Visual Basic Visual C++ F#
public ICheckerEngine CheckerEngine { get; set; }
Public Property CheckerEngine As ICheckerEngine
    Get
    Set
public:
property ICheckerEngine^ CheckerEngine {
    ICheckerEngine^ get ();
    void set (ICheckerEngine^ value);
}
member CheckerEngine : ICheckerEngine with get, set
Property Value
ICheckerEngine
Remarks
You should implement ICheckerEngine in your own class if you wish to customize parsing.


ClientFilesFolder Property

ClientFilesFolder Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► ClientFilesFolder
Keyoti RapidSpell Web .NET
Where the client files are found, must be an absolute path to the directory containing the RapidSpell client files.
Declaration Syntax
C# Visual Basic Visual C++ F#
public string ClientFilesFolder { get; set; }
Public Property ClientFilesFolder As String
    Get
    Set
public:
property String^ ClientFilesFolder {
    String^ get ();
    void set (String^ value);
}
member ClientFilesFolder : string with get, set
Property Value
String
Remarks
Default = /Keyoti_RapidSpell_Web_Common/


EffectiveClientFilesLocation Property

EffectiveClientFilesLocation Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► EffectiveClientFilesLocation
Keyoti RapidSpell Web .NET
Where to look for client files.
Declaration Syntax
C# Visual Basic Visual C++ F#
public ClientFilesLocation EffectiveClientFilesLocation { get; set; }
Public Property EffectiveClientFilesLocation As ClientFilesLocation
    Get
    Set
public:
property ClientFilesLocation EffectiveClientFilesLocation {
    ClientFilesLocation get ();
    void set (ClientFilesLocation value);
}
member EffectiveClientFilesLocation : ClientFilesLocation with get, set
Property Value
ClientFilesLocation


EnableTheming Property

EnableTheming Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► EnableTheming
Keyoti RapidSpell Web .NET
Theming is currently disabled. Support to be added in later versions.
Declaration Syntax
C# Visual Basic Visual C++ F#
public override bool EnableTheming { get; set; }
Public Overrides Property EnableTheming As Boolean
    Get
    Set
public:
virtual property bool EnableTheming {
    bool get () override;
    void set (bool value) override;
}
abstract EnableTheming : bool with get, set
override EnableTheming : bool with get, set
Property Value
Boolean


EnableViewState Property

EnableViewState Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► EnableViewState
Keyoti RapidSpell Web .NET
Viewstate is always disabled.
Declaration Syntax
C# Visual Basic Visual C++ F#
public override bool EnableViewState { get; }
Public Overrides ReadOnly Property EnableViewState As Boolean
    Get
public:
virtual property bool EnableViewState {
    bool get () override;
}
abstract EnableViewState : bool with get
override EnableViewState : bool with get
Property Value
Boolean


FieldDisplayTextLabel Property

FieldDisplayTextLabel Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► FieldDisplayTextLabel
Keyoti RapidSpell Web .NET
The field being checked label
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public RSLabel FieldDisplayTextLabel { get; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property FieldDisplayTextLabel As RSLabel
    Get
public:
[PersistenceModeAttribute(PersistenceMode::InnerProperty)]
property RSLabel^ FieldDisplayTextLabel {
    RSLabel^ get ();
}
[<PersistenceModeAttribute(PersistenceMode.InnerProperty)>]
member FieldDisplayTextLabel : RSLabel with get
Property Value
RSLabel


FinishButton Property

FinishButton Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► FinishButton
Keyoti RapidSpell Web .NET
The 'finish' button.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public RSButton FinishButton { get; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property FinishButton As RSButton
    Get
public:
[PersistenceModeAttribute(PersistenceMode::InnerProperty)]
property RSButton^ FinishButton {
    RSButton^ get ();
}
[<PersistenceModeAttribute(PersistenceMode.InnerProperty)>]
member FinishButton : RSButton with get
Property Value
RSButton


FinishedText Property

FinishedText Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► FinishedText
Keyoti RapidSpell Web .NET
The text displayed when the spell check finishes.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string FinishedText { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property FinishedText As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ FinishedText {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member FinishedText : string with get, set
Property Value
String


GlobalChangeAll Property

GlobalChangeAll Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► GlobalChangeAll
Keyoti RapidSpell Web .NET
Whether change all operations should be global.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool GlobalChangeAll { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property GlobalChangeAll As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool GlobalChangeAll {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member GlobalChangeAll : bool with get, set
Property Value
Boolean


GlobalIgnoreAll Property

GlobalIgnoreAll Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► GlobalIgnoreAll
Keyoti RapidSpell Web .NET
Whether ignore all operations should be global.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool GlobalIgnoreAll { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property GlobalIgnoreAll As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool GlobalIgnoreAll {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member GlobalIgnoreAll : bool with get, set
Property Value
Boolean


GotText Event

GotText Event
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► GotText
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public event RapidSpellWeb..::..TextEventHandler GotText
Public Event GotText As RapidSpellWeb..::..TextEventHandler
public:
 event RapidSpellWeb..::..TextEventHandler^ GotText {
    void add (RapidSpellWeb..::..TextEventHandler^ value);
    void remove (RapidSpellWeb..::..TextEventHandler^ value);
}
member GotText : IEvent<RapidSpellWeb..::..TextEventHandler,
    RapidSpellWeb..::..TextEventArgs>
Value
RapidSpellWeb..::..TextEventHandler


HideUserDictionaryErrors Property

HideUserDictionaryErrors Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► HideUserDictionaryErrors
Keyoti RapidSpell Web .NET
When errors occur with the user dictionary, they are reported to the user if this==false.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool HideUserDictionaryErrors { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property HideUserDictionaryErrors As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool HideUserDictionaryErrors {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member HideUserDictionaryErrors : bool with get, set
Property Value
Boolean


IgnoreAllButton Property

IgnoreAllButton Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► IgnoreAllButton
Keyoti RapidSpell Web .NET
The 'ignore all' button.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public RSButton IgnoreAllButton { get; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property IgnoreAllButton As RSButton
    Get
public:
[PersistenceModeAttribute(PersistenceMode::InnerProperty)]
property RSButton^ IgnoreAllButton {
    RSButton^ get ();
}
[<PersistenceModeAttribute(PersistenceMode.InnerProperty)>]
member IgnoreAllButton : RSButton with get
Property Value
RSButton


IgnoreButton Property

IgnoreButton Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► IgnoreButton
Keyoti RapidSpell Web .NET
The 'ignore' button.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public RSButton IgnoreButton { get; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property IgnoreButton As RSButton
    Get
public:
[PersistenceModeAttribute(PersistenceMode::InnerProperty)]
property RSButton^ IgnoreButton {
    RSButton^ get ();
}
[<PersistenceModeAttribute(PersistenceMode.InnerProperty)>]
member IgnoreButton : RSButton with get
Property Value
RSButton


IsLicenseValid Method (request)

IsLicenseValid Method (request)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► IsLicenseValid(HttpRequest)
Keyoti RapidSpell Web .NET
Whether there is a valid license key in the web.config for this request.
Declaration Syntax
C# Visual Basic Visual C++ F#
public static bool IsLicenseValid(
    HttpRequest request
)
Public Shared Function IsLicenseValid (
    request As HttpRequest
) As Boolean
public:
static bool IsLicenseValid(
    HttpRequest^ request
)
static member IsLicenseValid :
        request : HttpRequest -> bool
Parameters
request (HttpRequest)
Return Value
Boolean
True if licensed, false otherwise.


Layout Property

Layout Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► Layout
Keyoti RapidSpell Web .NET
The Html layout template used to layout this control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public Layout Layout { get; set; }
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Property Layout As Layout
    Get
    Set
public:
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
[PersistenceModeAttribute(PersistenceMode::InnerProperty)]
property Layout^ Layout {
    Layout^ get ();
    void set (Layout^ value);
}
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
[<PersistenceModeAttribute(PersistenceMode.InnerProperty)>]
member Layout : Layout with get, set
Property Value
Layout
Remarks
Typically the Layout.Html property is used


LicenseKey Property

LicenseKey Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► LicenseKey
Keyoti RapidSpell Web .NET
The license key for the spell checker.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string LicenseKey { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property LicenseKey As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ LicenseKey {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member LicenseKey : string with get, set
Property Value
String


NoErrorsText Property

NoErrorsText Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► NoErrorsText
Keyoti RapidSpell Web .NET
The text displayed when the spell check finishes with no spelling errors.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string NoErrorsText { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property NoErrorsText As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ NoErrorsText {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member NoErrorsText : string with get, set
Property Value
String


NoSuggestionsText Property

NoSuggestionsText Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► NoSuggestionsText
Keyoti RapidSpell Web .NET
The text displayed when the spell check has no suggestions.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string NoSuggestionsText { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property NoSuggestionsText As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ NoSuggestionsText {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member NoSuggestionsText : string with get, set
Property Value
String


OnPreRender Method (e)

OnPreRender Method (e)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► OnPreRender(EventArgs)
Keyoti RapidSpell Web .NET
Register client scripts
Declaration Syntax
C# Visual Basic Visual C++ F#
protected override void OnPreRender(
    EventArgs e
)
Protected Overrides Sub OnPreRender (
    e As EventArgs
)
protected:
virtual void OnPreRender(
    EventArgs^ e
) override
abstract OnPreRender :
        e : EventArgs -> unit
override OnPreRender :
        e : EventArgs -> unit
Parameters
e (EventArgs)


OptionsButton Property

OptionsButton Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► OptionsButton
Keyoti RapidSpell Web .NET
The 'options' button.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public RSButton OptionsButton { get; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property OptionsButton As RSButton
    Get
public:
[PersistenceModeAttribute(PersistenceMode::InnerProperty)]
property RSButton^ OptionsButton {
    RSButton^ get ();
}
[<PersistenceModeAttribute(PersistenceMode.InnerProperty)>]
member OptionsButton : RSButton with get
Property Value
RSButton


PreviewPaneCSSLinkURL Property

PreviewPaneCSSLinkURL Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► PreviewPaneCSSLinkURL
Keyoti RapidSpell Web .NET
The URL of the stylesheet to use in the preview pane.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string PreviewPaneCSSLinkURL { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property PreviewPaneCSSLinkURL As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ PreviewPaneCSSLinkURL {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member PreviewPaneCSSLinkURL : string with get, set
Property Value
String


PreviewPaneStyle Property

PreviewPaneStyle Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► PreviewPaneStyle
Keyoti RapidSpell Web .NET
Thee 'preview pane' style, this defines the style of the inner frame that shows the document preview during spell checking.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public PreviewPaneStyle PreviewPaneStyle { get; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property PreviewPaneStyle As PreviewPaneStyle
    Get
public:
[PersistenceModeAttribute(PersistenceMode::InnerProperty)]
property PreviewPaneStyle^ PreviewPaneStyle {
    PreviewPaneStyle^ get ();
}
[<PersistenceModeAttribute(PersistenceMode.InnerProperty)>]
member PreviewPaneStyle : PreviewPaneStyle with get
Property Value
PreviewPaneStyle
Remarks
This is an extension of the Style class.


RemoveDuplicateText Property

RemoveDuplicateText Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► RemoveDuplicateText
Keyoti RapidSpell Web .NET
The text displayed when the spell check finds a duplicate word error.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string RemoveDuplicateText { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property RemoveDuplicateText As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ RemoveDuplicateText {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member RemoveDuplicateText : string with get, set
Property Value
String


RenderContents Method (output)

RenderContents Method (output)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► RenderContents(HtmlTextWriter)
Keyoti RapidSpell Web .NET
Renders this control.
Declaration Syntax
C# Visual Basic Visual C++ F#
protected override void RenderContents(
    HtmlTextWriter output
)
Protected Overrides Sub RenderContents (
    output As HtmlTextWriter
)
protected:
virtual void RenderContents(
    HtmlTextWriter^ output
) override
abstract RenderContents :
        output : HtmlTextWriter -> unit
override RenderContents :
        output : HtmlTextWriter -> unit
Parameters
output (HtmlTextWriter)


RenderForDesign Method (output)

RenderForDesign Method (output)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► RenderForDesign(HtmlTextWriter)
Keyoti RapidSpell Web .NET
Renders this control for the design surface.
Declaration Syntax
C# Visual Basic Visual C++ F#
public void RenderForDesign(
    HtmlTextWriter output
)
Public Sub RenderForDesign (
    output As HtmlTextWriter
)
public:
void RenderForDesign(
    HtmlTextWriter^ output
)
member RenderForDesign :
        output : HtmlTextWriter -> unit
Parameters
output (HtmlTextWriter)


ScriptFilterLevel Property

ScriptFilterLevel Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► ScriptFilterLevel
Keyoti RapidSpell Web .NET
Script filter level; 0=none 15=all. Whether to filter scripting elements from the preview pane and at what level.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public int ScriptFilterLevel { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ScriptFilterLevel As Integer
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property int ScriptFilterLevel {
    int get ();
    void set (int value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ScriptFilterLevel : int with get, set
Property Value
Int32
Remarks
Levels;
0=remove nothing
15=remove all
1=remove script blocks
2=remove event handlers
4=remove javascript: urls
8=remove behaviours ">PUBLIC:XXX<"

Combinations can be formed by adding options, eg;
3=1 & 2 (remove script blocks & remove event handlers)
5=1 & 4 (remove script blocks & remove javascript: urls)
7=1 & 2 & 4 (remove script blocks & remove event handlers & remove javascript: urls)


SSLFriendly Property

SSLFriendly Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► SSLFriendly
Keyoti RapidSpell Web .NET
Whether to run in SSL friendly mode, setting this to true prevents mixed content warning messages in IE.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool SSLFriendly { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property SSLFriendly As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool SSLFriendly {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member SSLFriendly : bool with get, set
Property Value
Boolean
Remarks
Requires a file called 'blank.html' in the same folder as the RapidSpell checker page.


SuggestionsBox Property

SuggestionsBox Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► SuggestionsBox
Keyoti RapidSpell Web .NET
The text box where the suggestions are displayed.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public RSSelect SuggestionsBox { get; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property SuggestionsBox As RSSelect
    Get
public:
[PersistenceModeAttribute(PersistenceMode::InnerProperty)]
property RSSelect^ SuggestionsBox {
    RSSelect^ get ();
}
[<PersistenceModeAttribute(PersistenceMode.InnerProperty)>]
member SuggestionsBox : RSSelect with get
Property Value
RSSelect


SuggestionsLabel Property

SuggestionsLabel Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► SuggestionsLabel
Keyoti RapidSpell Web .NET
The suggestions box label
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public RSLabel SuggestionsLabel { get; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property SuggestionsLabel As RSLabel
    Get
public:
[PersistenceModeAttribute(PersistenceMode::InnerProperty)]
property RSLabel^ SuggestionsLabel {
    RSLabel^ get ();
}
[<PersistenceModeAttribute(PersistenceMode.InnerProperty)>]
member SuggestionsLabel : RSLabel with get
Property Value
RSLabel


UndoButton Property

UndoButton Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► UndoButton
Keyoti RapidSpell Web .NET
The 'undo' button.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public RSButton UndoButton { get; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property UndoButton As RSButton
    Get
public:
[PersistenceModeAttribute(PersistenceMode::InnerProperty)]
property RSButton^ UndoButton {
    RSButton^ get ();
}
[<PersistenceModeAttribute(PersistenceMode.InnerProperty)>]
member UndoButton : RSButton with get
Property Value
RSButton


UserDictionary Property

UserDictionary Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► UserDictionary
Keyoti RapidSpell Web .NET
A UserDictionary object to be used as a user dictionary.
Declaration Syntax
C# Visual Basic Visual C++ F#
public UserDictionary UserDictionary { get; set; }
Public Property UserDictionary As UserDictionary
    Get
    Set
public:
property UserDictionary^ UserDictionary {
    UserDictionary^ get ();
    void set (UserDictionary^ value);
}
member UserDictionary : UserDictionary with get, set
Property Value
UserDictionary


RapidSpellWeb.TextEventArgs Class

RapidSpellWeb..::..TextEventArgs Class
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► RapidSpellWeb..::..TextEventArgs
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public class TextEventArgs : EventArgs
Public Class TextEventArgs
    Inherits EventArgs
public ref class TextEventArgs : public EventArgs
type TextEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RapidSpellWeb..::..TextEventArgs(String) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Text |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | RapidSpellWeb..::..TextEventArgs


RapidSpellWeb.TextEventArgs Constructor (text)

RapidSpellWeb..::..TextEventArgs Constructor (text)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb..::..TextEventArgs ► RapidSpellWeb..::..TextEventArgs(String)
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public TextEventArgs(
    string text
)
Public Sub New (
    text As String
)
public:
TextEventArgs(
    String^ text
)
new :
        text : string -> TextEventArgs
Parameters
text (String)


Text Property

Text Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb..::..TextEventArgs ► Text
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set
Property Value
String


RapidSpellWeb.TextEventHandler Delegate

RapidSpellWeb..::..TextEventHandler Delegate
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► RapidSpellWeb..::..TextEventHandler
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public delegate void TextEventHandler(
    Object s,
    RapidSpellWeb..::..TextEventArgs e
)
Public Delegate Sub TextEventHandler (
    s As Object,
    e As RapidSpellWeb..::..TextEventArgs
)
public delegate void TextEventHandler(
    Object^ s,
    RapidSpellWeb..::..TextEventArgs^ e
)
type TextEventHandler =
    delegate of
        s : Object *
        e : RapidSpellWeb..::..TextEventArgs -> unit
Parameters
s (Object)
e (RapidSpellWeb..::..TextEventArgs)


RapidSpellWebLauncher Class

RapidSpellWebLauncher Class
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher
Keyoti RapidSpell Web .NET
RapidSpell Web Launcher Control, shows a button that launches the spell checker.
Declaration Syntax
C# Visual Basic Visual C++ F#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class RapidSpellWebLauncher : WebControl,
    INamingContainer, IPostBackEventHandler, IValidator
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Class RapidSpellWebLauncher
    Inherits WebControl
    Implements INamingContainer, IPostBackEventHandler, IValidator
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public ref class RapidSpellWebLauncher : public WebControl,
    INamingContainer, IPostBackEventHandler, IValidator
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
type RapidSpellWebLauncher =
    class
        inherit WebControl
        interface INamingContainer
        interface IPostBackEventHandler
        interface IValidator
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RapidSpellWebLauncher()()()() | Creates a RapidSpell Launcher
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AllowMixedCase | Whether to allow words spelt with mixed case, eg. "MIxEd".
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | AutoLaunchWhenTextInvalid | Whether to start the spell check automatically when Validator==true and text has errors. See same in RapidSpellWebMultiple also.
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BeginRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Button | The HtmlInputButton shown to the user, when clicked the spell checker starts.
 | ButtonImageMouseDown | The button image URL. This is for mouse down and is optional.
 | ButtonImageMouseOut | The button image URL. This is for mouse out (ie. not mouse over) and is optional.
 | ButtonImageMouseOver | The button image URL. This is for mouse over and is optional.
 | CallBack | The callBack URL or text box name.
 | CheckCompoundWords | Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
 | CheckTextBoxForErrors()()()() | Evaluates the text in the assigned text box for errors, this is called during validation. Returns true if there are errors, false if there are no errors or if the text box couldn't be accessed (see remarks).
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearCachedClientID()()()() | (Inherited from Control.)
 | ClearChildControlState()()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClearEffectiveClientIDMode()()()() | (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDMode | (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientSideObject | The name of the Javascript object variable representing the spell checker on the client side.
 | ConsiderationRange | The size factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anyting.
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CorrectionNotifyListener | [PopUp only] The name of a Javascript function on this page which should be called {with the prototype funcName(int start, string oldword, string newword)} when a correction is made.
 | CreateChildControls()()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreatePopUpWindow | Whether this control should create a pop-up window for the spell checker.
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataItemContainer | (Inherited from Control.)
 | DataKeysContainer | (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DictFile | (Optional) main dictionary (.dict) file on the server.
 | Dispose()()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Enabled state of the control. (Overrides WebControl.Enabled.)
 | EnableOptions | Whether to provide 'options' functionality to the user.
 | EnableTheming | Theming is currently disabled. Support to be added in later versions. (Overrides WebControl.EnableTheming.)
 | EnableUndo | Whether to provide 'undo' functionality to the user - when checking very large texts this may cause browser memory issues.
 | EnableViewState | Viewstate is always disabled. (Overrides Control.EnableViewState.)
 | EndRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | EnsureChildControls()()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorMessage | The error message to show the user when validation fails.
 | EscClientID | An escaped version of this ClientID suitable for use as Javascript variable names.
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | FieldDisplayText | (Optional) The text to display in the spell checker to inform the user which text field is being checked.
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
 | Finish | Fired when the spell check is finished AND PostBackOnFinish==true.
 | FinishClosesWindow | Whether to close the spell checker popup window when the 'Finish' button is clicked and CreatePopUpWindow==false.
 | FinishedListener | The name of a JavaScript function (without brackets) that should be called when pop up spell checking is finished (optional).
 | FinishedListenerInformState | Whether to inform the finished listener function of the way in which spell checking finished.
 | Focus()()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRouteUrl(Object) | (Inherited from Control.)
 | GetRouteUrl(String, Object) | (Inherited from Control.)
 | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
 | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetUniqueIDRelativeTo(Control) | (Inherited from Control.)
 | GuiLanguage | The UI language.
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | IgnoreCapitalizedWords | Whether to ignore words with capital letters.
 | IgnoreIncorrectSentenceCapitalization | Whether to ignore incorrect sentence capitalization.
 | IgnoreInEnglishLowerCaseI | Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
 | IgnoreURLsAndEmailAddresses | Whether to ignore URLs and email addresses (requires V2Parser=true)
 | IgnoreWordsWithDigits | Whether to ignore words with numbers in them (eg. A10 or 7-11).
 | IgnoreXML | Whether to ignore XML/HTML tags, false by default.
 | IncludeUserDictionaryInSuggestions | Whether the user dictionary should be used in finding suggestions for misspelt words.
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Whether the validator has identified an error or whether spell checking has already been forced by the validator.
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | LanguageParser | The language parser to use, this should match the language of the main dictionary where possible.
 | LicenseKey | Obsolete. Whether to show the popup dialog at the end of the spell check.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LookIntoHyphenatedText | Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | Modal | Whether the popup will be modal.
 | ModalHelperPage | The URL of the modal popup helper file (only has effect if Modal=true).
 | Mode | The mode to use RapidSpell Web in, can be "popup" or "separate".
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnFinish(EventArgs) | Called when the spell check is finished AND PostBackOnFinish==true.
 | OnInit(EventArgs) | Adds self to validators (Overrides Control.OnInit(EventArgs).)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | See Control.OnPreRender. (Overrides Control.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Removes self from validators (Overrides Control.OnUnload(EventArgs).)
 | OnValidatorNeedsText(ValidatorNeedsTextEventArgs) | Raises the ValidatorNeedsText event, allowing e.TextBoxText to be set with the text to validate.
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PopUpWindowName | If this control doesn't create a pop-up window for the spell checker (and is in popup mode) this specifies the name of an existing window to put the spell checker in.
 | PostBackOnFinish | Whether to post back to the server when the spell check finishes.
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(String) | Method of IPostBackEventHandler that raises change events.
 | RapidSpellWebPage | The URL of the page holding the RapidSpellWeb control.
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders this control. (Overrides WebControl.RenderContents(HtmlTextWriter).)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderForDesign(HtmlTextWriter) | Renders this control for the design surface.
 | RenderingCompatibility | (Inherited from Control.)
 | ResolveAdapter()()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | RSMultipleID | The ID of the RapidSpellWebMultiple control managing multi text box checking.
 | SaveControlState()()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()()() | Saves any state that was modified after the TrackViewState()()()() method was invoked. (Inherited from WebControl.)
 | SeparateHyphenWords | Whether to treat hyphenated (-) words as separate words, default is false.
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetTraceData(Object, Object) | (Inherited from Control.)
 | SetTraceData(Object, Object, Object) | (Inherited from Control.)
 | ShowButton | Whether to show the launcher button (set to false to hide button/images). The client-side code will be written regardless.
 | ShowFinishedMessage | Whether to show the popup dialog at the end of the spell check.
 | ShowNoErrorsMessage | Whether to show the popup dialog stating there were no spelling errors.
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SpellCheckText | The text displayed when the pop up is first opened.
 | SSLFriendly | Whether to run in SSL friendly mode, setting this to true prevents 'leaving secure site' warning messages in IE.
 | SSLFriendlyPage | The URL of the file to set in Iframes, this avoids SSL warnings.
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | SuggestionsMethod | Suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
 | SuggestSplitWords | Whether to look for connected words in suggestions.
 | SupportsDisabledAttribute | (Inherited from WebControl.)
 | SuppressWarnings | Whether to suppress any warning messages (eg. that textbox couldn't be found).
 | TabIndex | The tab order of the control. (Overrides WebControl.TabIndex.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TextComponentInterface | The text box interface to be used.
 | TextComponentName | The text component Control ID to be checked on the form.
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TrackViewState()()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UserDictionaryFile | The user dictionary file on the server for the user.
 | V2Parser | Whether to use parser version 2 - Set to false for backwards (pre v2.8) compatibility. This causes approx. 10-20% speed reduction for spelling error identification.
 | Validate()()()() | If Validator==true, this checks the text box for errors, and updates IsValid - note if there are errors but the spell check has already been forced this will set IsValid to true.
 | ValidateRequestMode | (Inherited from Control.)
 | Validator | Whether to work as a validator.
 | ValidatorNeedsText | Fired when the validator is attempting to access the text of the textbox specified by TextComponentID.
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateMode | (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WarnDuplicates | Whether to show duplicate words as errors (eg. "this is is an error").
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
 | WindowHeight | Sets the window height (in pixels), when used in Mode=popup.
 | WindowWidth | Sets the window width (in pixels), when used in Mode=popup.
 | WindowX | Sets the window X position (in pixels), when used in Mode=popup.
 | WindowY | Sets the window Y position (in pixels), when used in Mode=popup.
Remarks
The minimum requirements to use this control are that TextComponentName and RapidSpellWebPage properties are set.

Eg.

Copy image Copy
<RapidSpellWeb:RapidSpellWebLauncher id="rapidSpellWebLauncher3" runat="server"
                            TextComponentName="TextBox1"
                            RapidSpellWebPage="RapidSpellCheckerPopUp.aspx">
                 </RapidSpellWeb:RapidSpellWebLauncher>
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | RapidSpellWebLauncher


RapidSpellWebLauncher Constructor

RapidSpellWebLauncher Constructor
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► RapidSpellWebLauncher()()()()
Keyoti RapidSpell Web .NET
Creates a RapidSpell Launcher
Declaration Syntax
C# Visual Basic Visual C++ F#
public RapidSpellWebLauncher()
Public Sub New
public:
RapidSpellWebLauncher()
new : unit -> RapidSpellWebLauncher


AllowMixedCase Property

AllowMixedCase Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► AllowMixedCase
Keyoti RapidSpell Web .NET
Whether to allow words spelt with mixed case, eg. "MIxEd".
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool AllowMixedCase { get; set; }
Public Property AllowMixedCase As Boolean
    Get
    Set
public:
property bool AllowMixedCase {
    bool get ();
    void set (bool value);
}
member AllowMixedCase : bool with get, set
Property Value
Boolean
Remarks
Default==false


AutoLaunchWhenTextInvalid Property

AutoLaunchWhenTextInvalid Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► AutoLaunchWhenTextInvalid
Keyoti RapidSpell Web .NET
Whether to start the spell check automatically when Validator==true and text has errors. See same in RapidSpellWebMultiple also.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool AutoLaunchWhenTextInvalid { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property AutoLaunchWhenTextInvalid As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool AutoLaunchWhenTextInvalid {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member AutoLaunchWhenTextInvalid : bool with get, set
Property Value
Boolean


Button Property

Button Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► Button
Keyoti RapidSpell Web .NET
The HtmlInputButton shown to the user, when clicked the spell checker starts.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public RSButton Button { get; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property Button As RSButton
    Get
public:
[PersistenceModeAttribute(PersistenceMode::InnerProperty)]
property RSButton^ Button {
    RSButton^ get ();
}
[<PersistenceModeAttribute(PersistenceMode.InnerProperty)>]
member Button : RSButton with get
Property Value
RSButton


ButtonImageMouseDown Property

ButtonImageMouseDown Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► ButtonImageMouseDown
Keyoti RapidSpell Web .NET
The button image URL. This is for mouse down and is optional.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string ButtonImageMouseDown { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ButtonImageMouseDown As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ ButtonImageMouseDown {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ButtonImageMouseDown : string with get, set
Property Value
String
Remarks
Eg. /images/button.jpg


ButtonImageMouseOut Property

ButtonImageMouseOut Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► ButtonImageMouseOut
Keyoti RapidSpell Web .NET
The button image URL. This is for mouse out (ie. not mouse over) and is optional.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string ButtonImageMouseOut { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ButtonImageMouseOut As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ ButtonImageMouseOut {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ButtonImageMouseOut : string with get, set
Property Value
String
Remarks
Eg. /images/button.jpg


ButtonImageMouseOver Property

ButtonImageMouseOver Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► ButtonImageMouseOver
Keyoti RapidSpell Web .NET
The button image URL. This is for mouse over and is optional.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string ButtonImageMouseOver { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ButtonImageMouseOver As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ ButtonImageMouseOver {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ButtonImageMouseOver : string with get, set
Property Value
String
Remarks
Eg. /images/button.jpg


CallBack Property

CallBack Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► CallBack
Keyoti RapidSpell Web .NET
The callBack URL or text box name.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string CallBack { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property CallBack As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ CallBack {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member CallBack : string with get, set
Property Value
String
Remarks
If Mode=="popup" then this should be set to the form element name in the main window, using Javascript notation, relative to the document, e.g; myFormName.textAreaName If Mode=="separate" then this should be set to the URL of the page to send the form parameter "CorrectedText" to, this can of course be the original page.


CheckCompoundWords Property

CheckCompoundWords Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► CheckCompoundWords
Keyoti RapidSpell Web .NET
Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool CheckCompoundWords { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property CheckCompoundWords As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool CheckCompoundWords {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member CheckCompoundWords : bool with get, set
Property Value
Boolean
Remarks
If this=false then LookUp("thesewordsarejoined") = false

If this=true then LookUp("thesewordsarejoined") = true

If this=false then LookUp("abcdef") = false

If this=true then LookUp("abcdef") = false

Setting this to true will degrade lookup performance


CheckTextBoxForErrors Method

CheckTextBoxForErrors Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► CheckTextBoxForErrors()()()()
Keyoti RapidSpell Web .NET
Evaluates the text in the assigned text box for errors, this is called during validation. Returns true if there are errors, false if there are no errors or if the text box couldn't be accessed (see remarks).
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual bool CheckTextBoxForErrors()
Public Overridable Function CheckTextBoxForErrors As Boolean
public:
virtual bool CheckTextBoxForErrors()
abstract CheckTextBoxForErrors : unit -> bool
override CheckTextBoxForErrors : unit -> bool
Return Value
Boolean
Remarks
Access the text box using Parent.FindControl(TextComponentName), so the TextComponentName must be the ID of the text box and the text box and this control must be in the same naming container (eg. page, user control, grid item).


ClientSideObject Property

ClientSideObject Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► ClientSideObject
Keyoti RapidSpell Web .NET
The name of the Javascript object variable representing the spell checker on the client side.
Declaration Syntax
C# Visual Basic Visual C++ F#
public string ClientSideObject { get; }
Public ReadOnly Property ClientSideObject As String
    Get
public:
property String^ ClientSideObject {
    String^ get ();
}
member ClientSideObject : string with get
Property Value
String


ConsiderationRange Property

ConsiderationRange Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► ConsiderationRange
Keyoti RapidSpell Web .NET
The size factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anyting.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public int ConsiderationRange { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ConsiderationRange As Integer
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property int ConsiderationRange {
    int get ();
    void set (int value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ConsiderationRange : int with get, set
Property Value
Int32


CorrectionNotifyListener Property

CorrectionNotifyListener Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► CorrectionNotifyListener
Keyoti RapidSpell Web .NET
[PopUp only] The name of a Javascript function on this page which should be called {with the prototype funcName(int start, string oldword, string newword)} when a correction is made.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string CorrectionNotifyListener { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property CorrectionNotifyListener As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ CorrectionNotifyListener {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member CorrectionNotifyListener : string with get, set
Property Value
String
Remarks
Use this to receive notifications on which word was changed and what to, when it happens.


CreatePopUpWindow Property

CreatePopUpWindow Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► CreatePopUpWindow
Keyoti RapidSpell Web .NET
Whether this control should create a pop-up window for the spell checker.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool CreatePopUpWindow { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property CreatePopUpWindow As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool CreatePopUpWindow {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member CreatePopUpWindow : bool with get, set
Property Value
Boolean
Remarks
If this is set to false then PopUpWindowName must be specified as the name of an existing window in which to feed the spell checker.


DictFile Property

DictFile Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► DictFile
Keyoti RapidSpell Web .NET
(Optional) main dictionary (.dict) file on the server.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string DictFile { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property DictFile As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ DictFile {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member DictFile : string with get, set
Property Value
String
Remarks
This should be an absolute path.


Enabled Property

Enabled Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► Enabled
Keyoti RapidSpell Web .NET
Enabled state of the control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override bool Enabled { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property Enabled As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
virtual property bool Enabled {
    bool get () override;
    void set (bool value) override;
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
abstract Enabled : bool with get, set
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
override Enabled : bool with get, set
Property Value
Boolean


EnableOptions Property

EnableOptions Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► EnableOptions
Keyoti RapidSpell Web .NET
Whether to provide 'options' functionality to the user.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool EnableOptions { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property EnableOptions As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool EnableOptions {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member EnableOptions : bool with get, set
Property Value
Boolean


EnableTheming Property

EnableTheming Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► EnableTheming
Keyoti RapidSpell Web .NET
Theming is currently disabled. Support to be added in later versions.
Declaration Syntax
C# Visual Basic Visual C++ F#
public override bool EnableTheming { get; }
Public Overrides ReadOnly Property EnableTheming As Boolean
    Get
public:
virtual property bool EnableTheming {
    bool get () override;
}
abstract EnableTheming : bool with get
override EnableTheming : bool with get
Property Value
Boolean


EnableUndo Property

EnableUndo Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► EnableUndo
Keyoti RapidSpell Web .NET
Whether to provide 'undo' functionality to the user - when checking very large texts this may cause browser memory issues.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool EnableUndo { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property EnableUndo As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool EnableUndo {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member EnableUndo : bool with get, set
Property Value
Boolean


EnableViewState Property

EnableViewState Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► EnableViewState
Keyoti RapidSpell Web .NET
Viewstate is always disabled.
Declaration Syntax
C# Visual Basic Visual C++ F#
public override bool EnableViewState { get; }
Public Overrides ReadOnly Property EnableViewState As Boolean
    Get
public:
virtual property bool EnableViewState {
    bool get () override;
}
abstract EnableViewState : bool with get
override EnableViewState : bool with get
Property Value
Boolean


ErrorMessage Property

ErrorMessage Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► ErrorMessage
Keyoti RapidSpell Web .NET
The error message to show the user when validation fails.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string ErrorMessage { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ErrorMessage As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
virtual property String^ ErrorMessage {
    String^ get () sealed;
    void set (String^ value) sealed;
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
abstract ErrorMessage : string with get, set
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
override ErrorMessage : string with get, set
Property Value
String


EscClientID Property

EscClientID Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► EscClientID
Keyoti RapidSpell Web .NET
An escaped version of this ClientID suitable for use as Javascript variable names.
Declaration Syntax
C# Visual Basic Visual C++ F#
public string EscClientID { get; }
Public ReadOnly Property EscClientID As String
    Get
public:
property String^ EscClientID {
    String^ get ();
}
member EscClientID : string with get
Property Value
String


FieldDisplayText Property

FieldDisplayText Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► FieldDisplayText
Keyoti RapidSpell Web .NET
(Optional) The text to display in the spell checker to inform the user which text field is being checked.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string FieldDisplayText { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property FieldDisplayText As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ FieldDisplayText {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member FieldDisplayText : string with get, set
Property Value
String


Finish Event

Finish Event
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► Finish
Keyoti RapidSpell Web .NET
Fired when the spell check is finished AND PostBackOnFinish==true.
Declaration Syntax
C# Visual Basic Visual C++ F#
public event EventHandler Finish
Public Event Finish As EventHandler
public:
 event EventHandler^ Finish {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Finish : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


FinishClosesWindow Property

FinishClosesWindow Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► FinishClosesWindow
Keyoti RapidSpell Web .NET
Whether to close the spell checker popup window when the 'Finish' button is clicked and CreatePopUpWindow==false.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool FinishClosesWindow { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property FinishClosesWindow As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool FinishClosesWindow {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member FinishClosesWindow : bool with get, set
Property Value
Boolean
Remarks
When checking multiple text boxes if this is set to false the window will stay open spell checking will move onto the next text box, if this is set true (default) the window will close and spell checking will end.
When the Finish button is clicked the FinishedListener is called, regardless of the value of this property.
Note this only has effect when CreatePopUpWindow==false.


FinishedListener Property

FinishedListener Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► FinishedListener
Keyoti RapidSpell Web .NET
The name of a JavaScript function (without brackets) that should be called when pop up spell checking is finished (optional).
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string FinishedListener { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property FinishedListener As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ FinishedListener {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member FinishedListener : string with get, set
Property Value
String
Remarks
This is optional, and of use if you require client side (or indirectly server side) notification that the spell check has finished. The function named here will be called when the pop up spell check is finished by the user (or the window was closed), it must not have any arguments.


FinishedListenerInformState Property

FinishedListenerInformState Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► FinishedListenerInformState
Keyoti RapidSpell Web .NET
Whether to inform the finished listener function of the way in which spell checking finished.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool FinishedListenerInformState { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property FinishedListenerInformState As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool FinishedListenerInformState {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member FinishedListenerInformState : bool with get, set
Property Value
Boolean
Remarks
If set to true the finished listener will be called with one boolean argument (arg=true means spell check completed, false means cancelled).


GuiLanguage Property

GuiLanguage Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► GuiLanguage
Keyoti RapidSpell Web .NET
The UI language.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public LanguageType GuiLanguage { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property GuiLanguage As LanguageType
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property LanguageType GuiLanguage {
    LanguageType get ();
    void set (LanguageType value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member GuiLanguage : LanguageType with get, set
Property Value
LanguageType
Remarks
This is the language that all text on the UI should be in.


IgnoreCapitalizedWords Property

IgnoreCapitalizedWords Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► IgnoreCapitalizedWords
Keyoti RapidSpell Web .NET
Whether to ignore words with capital letters.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool IgnoreCapitalizedWords { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property IgnoreCapitalizedWords As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool IgnoreCapitalizedWords {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member IgnoreCapitalizedWords : bool with get, set
Property Value
Boolean


IgnoreIncorrectSentenceCapitalization Property

IgnoreIncorrectSentenceCapitalization Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► IgnoreIncorrectSentenceCapitalization
Keyoti RapidSpell Web .NET
Whether to ignore incorrect sentence capitalization.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool IgnoreIncorrectSentenceCapitalization { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool IgnoreIncorrectSentenceCapitalization {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member IgnoreIncorrectSentenceCapitalization : bool with get, set
Property Value
Boolean


IgnoreInEnglishLowerCaseI Property

IgnoreInEnglishLowerCaseI Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► IgnoreInEnglishLowerCaseI
Keyoti RapidSpell Web .NET
Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool IgnoreInEnglishLowerCaseI { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool IgnoreInEnglishLowerCaseI {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member IgnoreInEnglishLowerCaseI : bool with get, set
Property Value
Boolean


IgnoreURLsAndEmailAddresses Property

IgnoreURLsAndEmailAddresses Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► IgnoreURLsAndEmailAddresses
Keyoti RapidSpell Web .NET
Whether to ignore URLs and email addresses (requires V2Parser=true)
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool IgnoreURLsAndEmailAddresses { get; set; }
Public Property IgnoreURLsAndEmailAddresses As Boolean
    Get
    Set
public:
property bool IgnoreURLsAndEmailAddresses {
    bool get ();
    void set (bool value);
}
member IgnoreURLsAndEmailAddresses : bool with get, set
Property Value
Boolean
Remarks
This will cause the following strings to be accepted as non-spelling errors;
"user@domain.com", "http://www.domain.com", "domain.co.uk" etc.


IgnoreWordsWithDigits Property

IgnoreWordsWithDigits Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► IgnoreWordsWithDigits
Keyoti RapidSpell Web .NET
Whether to ignore words with numbers in them (eg. A10 or 7-11).
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool IgnoreWordsWithDigits { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property IgnoreWordsWithDigits As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool IgnoreWordsWithDigits {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member IgnoreWordsWithDigits : bool with get, set
Property Value
Boolean
Remarks
Default==true


IgnoreXML Property

IgnoreXML Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► IgnoreXML
Keyoti RapidSpell Web .NET
Whether to ignore XML/HTML tags, false by default.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool IgnoreXML { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property IgnoreXML As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member IgnoreXML : bool with get, set
Property Value
Boolean
Remarks
This identifies XML tags as anything in between < and > characters, there for it will cause undesirable effects in text such as "the sign for less than is < and the sign for greater than is >". Of course in HTML that should have been written as "the sign for less than is &lt; and the sign for greater than is &gt;" anyway, which would be fine.


IncludeUserDictionaryInSuggestions Property

IncludeUserDictionaryInSuggestions Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► IncludeUserDictionaryInSuggestions
Keyoti RapidSpell Web .NET
Whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool IncludeUserDictionaryInSuggestions { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property IncludeUserDictionaryInSuggestions As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool IncludeUserDictionaryInSuggestions {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member IncludeUserDictionaryInSuggestions : bool with get, set
Property Value
Boolean
Remarks
Default==false


IsValid Property

IsValid Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► IsValid
Keyoti RapidSpell Web .NET
Whether the validator has identified an error or whether spell checking has already been forced by the validator.
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool IsValid { get; set; }
Public Property IsValid As Boolean
    Get
    Set
public:
virtual property bool IsValid {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IsValid : bool with get, set
override IsValid : bool with get, set
Property Value
Boolean


LanguageParser Property

LanguageParser Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► LanguageParser
Keyoti RapidSpell Web .NET
The language parser to use, this should match the language of the main dictionary where possible.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public LanguageType LanguageParser { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property LanguageParser As LanguageType
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property LanguageType LanguageParser {
    LanguageType get ();
    void set (LanguageType value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member LanguageParser : LanguageType with get, set
Property Value
LanguageType
Remarks
This is used to give hints to the parser about how punctuation is used (eg. apostrophe is used differently in English and French).


LicenseKey Property

LicenseKey Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► LicenseKey
Keyoti RapidSpell Web .NET
Whether to show the popup dialog at the end of the spell check.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
[ObsoleteAttribute("LicenseKey is set in web.config or popup page only now.",
    false)]
public string LicenseKey { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
<ObsoleteAttribute("LicenseKey is set in web.config or popup page only now.",
    false)>
Public Property LicenseKey As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
[ObsoleteAttribute(L"LicenseKey is set in web.config or popup page only now.",
    false)]
property String^ LicenseKey {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
[<ObsoleteAttribute("LicenseKey is set in web.config or popup page only now.",
    false)>]
member LicenseKey : string with get, set
Property Value
String


LookIntoHyphenatedText Property

LookIntoHyphenatedText Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► LookIntoHyphenatedText
Keyoti RapidSpell Web .NET
Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool LookIntoHyphenatedText { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property LookIntoHyphenatedText As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool LookIntoHyphenatedText {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member LookIntoHyphenatedText : bool with get, set
Property Value
Boolean
Remarks
Eg. "socio-economic" will be checked as "socio" and "economic".


Modal Property

Modal Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► Modal
Keyoti RapidSpell Web .NET
Whether the popup will be modal.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool Modal { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Modal As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool Modal {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member Modal : bool with get, set
Property Value
Boolean
Remarks
IE only. Default=false.


ModalHelperPage Property

ModalHelperPage Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► ModalHelperPage
Keyoti RapidSpell Web .NET
The URL of the modal popup helper file (only has effect if Modal=true).
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string ModalHelperPage { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ModalHelperPage As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ ModalHelperPage {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ModalHelperPage : string with get, set
Property Value
String
Remarks
By default this points to the Keyoti_RapidSpell_Web_Common client files virtual directory.


Mode Property

Mode Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► Mode
Keyoti RapidSpell Web .NET
The mode to use RapidSpell Web in, can be "popup" or "separate".
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string Mode { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Mode As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ Mode {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member Mode : string with get, set
Property Value
String
Remarks
popup - opens a new window with the URL in RapidSpellWebPage property, and sets the spell checker to popup mode. separate - opens a new page in the same window with the URL in RapidSpellWebPage property, and sets the spell checker to separate mode.


OnFinish Method (e)

OnFinish Method (e)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► OnFinish(EventArgs)
Keyoti RapidSpell Web .NET
Called when the spell check is finished AND PostBackOnFinish==true.
Declaration Syntax
C# Visual Basic Visual C++ F#
protected virtual void OnFinish(
    EventArgs e
)
Protected Overridable Sub OnFinish (
    e As EventArgs
)
protected:
virtual void OnFinish(
    EventArgs^ e
)
abstract OnFinish :
        e : EventArgs -> unit
override OnFinish :
        e : EventArgs -> unit
Parameters
e (EventArgs)


OnInit Method (e)

OnInit Method (e)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► OnInit(EventArgs)
Keyoti RapidSpell Web .NET
Adds self to validators
Declaration Syntax
C# Visual Basic Visual C++ F#
protected override void OnInit(
    EventArgs e
)
Protected Overrides Sub OnInit (
    e As EventArgs
)
protected:
virtual void OnInit(
    EventArgs^ e
) override
abstract OnInit :
        e : EventArgs -> unit
override OnInit :
        e : EventArgs -> unit
Parameters
e (EventArgs)


OnPreRender Method (e)

OnPreRender Method (e)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► OnPreRender(EventArgs)
Keyoti RapidSpell Web .NET
See Control.OnPreRender.
Declaration Syntax
C# Visual Basic Visual C++ F#
protected override void OnPreRender(
    EventArgs e
)
Protected Overrides Sub OnPreRender (
    e As EventArgs
)
protected:
virtual void OnPreRender(
    EventArgs^ e
) override
abstract OnPreRender :
        e : EventArgs -> unit
override OnPreRender :
        e : EventArgs -> unit
Parameters
e (EventArgs)


OnUnload Method (e)

OnUnload Method (e)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► OnUnload(EventArgs)
Keyoti RapidSpell Web .NET
Removes self from validators
Declaration Syntax
C# Visual Basic Visual C++ F#
protected override void OnUnload(
    EventArgs e
)
Protected Overrides Sub OnUnload (
    e As EventArgs
)
protected:
virtual void OnUnload(
    EventArgs^ e
) override
abstract OnUnload :
        e : EventArgs -> unit
override OnUnload :
        e : EventArgs -> unit
Parameters
e (EventArgs)


OnValidatorNeedsText Method (e)

OnValidatorNeedsText Method (e)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► OnValidatorNeedsText(ValidatorNeedsTextEventArgs)
Keyoti RapidSpell Web .NET
Raises the ValidatorNeedsText event, allowing e.TextBoxText to be set with the text to validate.
Declaration Syntax
C# Visual Basic Visual C++ F#
protected virtual void OnValidatorNeedsText(
    ValidatorNeedsTextEventArgs e
)
Protected Overridable Sub OnValidatorNeedsText (
    e As ValidatorNeedsTextEventArgs
)
protected:
virtual void OnValidatorNeedsText(
    ValidatorNeedsTextEventArgs^ e
)
abstract OnValidatorNeedsText :
        e : ValidatorNeedsTextEventArgs -> unit
override OnValidatorNeedsText :
        e : ValidatorNeedsTextEventArgs -> unit
Parameters
e (ValidatorNeedsTextEventArgs)


PopUpWindowName Property

PopUpWindowName Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► PopUpWindowName
Keyoti RapidSpell Web .NET
If this control doesn't create a pop-up window for the spell checker (and is in popup mode) this specifies the name of an existing window to put the spell checker in.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string PopUpWindowName { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property PopUpWindowName As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ PopUpWindowName {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member PopUpWindowName : string with get, set
Property Value
String


PostBackOnFinish Property

PostBackOnFinish Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► PostBackOnFinish
Keyoti RapidSpell Web .NET
Whether to post back to the server when the spell check finishes.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool PostBackOnFinish { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property PostBackOnFinish As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool PostBackOnFinish {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member PostBackOnFinish : bool with get, set
Property Value
Boolean
Remarks


RaisePostBackEvent Method (eventArgument)

RaisePostBackEvent Method (eventArgument)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► RaisePostBackEvent(String)
Keyoti RapidSpell Web .NET
Method of IPostBackEventHandler that raises change events.
Declaration Syntax
C# Visual Basic Visual C++ F#
public void RaisePostBackEvent(
    string eventArgument
)
Public Sub RaisePostBackEvent (
    eventArgument As String
)
public:
virtual void RaisePostBackEvent(
    String^ eventArgument
) sealed
abstract RaisePostBackEvent :
        eventArgument : string -> unit
override RaisePostBackEvent :
        eventArgument : string -> unit
Parameters
eventArgument (String)


RapidSpellWebPage Property

RapidSpellWebPage Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► RapidSpellWebPage
Keyoti RapidSpell Web .NET
The URL of the page holding the RapidSpellWeb control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string RapidSpellWebPage { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property RapidSpellWebPage As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ RapidSpellWebPage {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member RapidSpellWebPage : string with get, set
Property Value
String


RenderContents Method (output)

RenderContents Method (output)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► RenderContents(HtmlTextWriter)
Keyoti RapidSpell Web .NET
Renders this control.
Declaration Syntax
C# Visual Basic Visual C++ F#
protected override void RenderContents(
    HtmlTextWriter output
)
Protected Overrides Sub RenderContents (
    output As HtmlTextWriter
)
protected:
virtual void RenderContents(
    HtmlTextWriter^ output
) override
abstract RenderContents :
        output : HtmlTextWriter -> unit
override RenderContents :
        output : HtmlTextWriter -> unit
Parameters
output (HtmlTextWriter)


RenderForDesign Method (output)

RenderForDesign Method (output)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► RenderForDesign(HtmlTextWriter)
Keyoti RapidSpell Web .NET
Renders this control for the design surface.
Declaration Syntax
C# Visual Basic Visual C++ F#
public void RenderForDesign(
    HtmlTextWriter output
)
Public Sub RenderForDesign (
    output As HtmlTextWriter
)
public:
void RenderForDesign(
    HtmlTextWriter^ output
)
member RenderForDesign :
        output : HtmlTextWriter -> unit
Parameters
output (HtmlTextWriter)


RSMultipleID Property

RSMultipleID Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► RSMultipleID
Keyoti RapidSpell Web .NET
The ID of the RapidSpellWebMultiple control managing multi text box checking.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string RSMultipleID { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property RSMultipleID As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ RSMultipleID {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member RSMultipleID : string with get, set
Property Value
String
Remarks
Setting this prevents certain properties that aren't relevant to multi mode checking from being set.


SeparateHyphenWords Property

SeparateHyphenWords Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► SeparateHyphenWords
Keyoti RapidSpell Web .NET
Whether to treat hyphenated (-) words as separate words, default is false.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool SeparateHyphenWords { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property SeparateHyphenWords As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool SeparateHyphenWords {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member SeparateHyphenWords : bool with get, set
Property Value
Boolean
Remarks
For eg. if this is true text like "cheap-deals" will be treated as two words "cheap" and "deals", otherwise this will be treated as one word "cheap-deals".


ShowButton Property

ShowButton Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► ShowButton
Keyoti RapidSpell Web .NET
Whether to show the launcher button (set to false to hide button/images). The client-side code will be written regardless.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool ShowButton { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ShowButton As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool ShowButton {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ShowButton : bool with get, set
Property Value
Boolean


ShowFinishedMessage Property

ShowFinishedMessage Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► ShowFinishedMessage
Keyoti RapidSpell Web .NET
Whether to show the popup dialog at the end of the spell check.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool ShowFinishedMessage { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ShowFinishedMessage As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool ShowFinishedMessage {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ShowFinishedMessage : bool with get, set
Property Value
Boolean


ShowNoErrorsMessage Property

ShowNoErrorsMessage Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► ShowNoErrorsMessage
Keyoti RapidSpell Web .NET
Whether to show the popup dialog stating there were no spelling errors.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool ShowNoErrorsMessage { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ShowNoErrorsMessage As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool ShowNoErrorsMessage {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ShowNoErrorsMessage : bool with get, set
Property Value
Boolean


SpellCheckText Property

SpellCheckText Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► SpellCheckText
Keyoti RapidSpell Web .NET
The text displayed when the pop up is first opened.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string SpellCheckText { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property SpellCheckText As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ SpellCheckText {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member SpellCheckText : string with get, set
Property Value
String


SSLFriendly Property

SSLFriendly Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► SSLFriendly
Keyoti RapidSpell Web .NET
Whether to run in SSL friendly mode, setting this to true prevents 'leaving secure site' warning messages in IE.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool SSLFriendly { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property SSLFriendly As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool SSLFriendly {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member SSLFriendly : bool with get, set
Property Value
Boolean
Remarks
Default=false


SSLFriendlyPage Property

SSLFriendlyPage Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► SSLFriendlyPage
Keyoti RapidSpell Web .NET
The URL of the file to set in Iframes, this avoids SSL warnings.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string SSLFriendlyPage { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property SSLFriendlyPage As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ SSLFriendlyPage {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member SSLFriendlyPage : string with get, set
Property Value
String
Remarks
By default this points to the Keyoti_RapidSpell_Web_Common client files virtual directory.


SuggestionsMethod Property

SuggestionsMethod Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► SuggestionsMethod
Keyoti RapidSpell Web .NET
Suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string SuggestionsMethod { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property SuggestionsMethod As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ SuggestionsMethod {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member SuggestionsMethod : string with get, set
Property Value
String


SuggestSplitWords Property

SuggestSplitWords Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► SuggestSplitWords
Keyoti RapidSpell Web .NET
Whether to look for connected words in suggestions.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool SuggestSplitWords { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property SuggestSplitWords As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool SuggestSplitWords {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member SuggestSplitWords : bool with get, set
Property Value
Boolean
Remarks
if this=true then suggestions may include joined words.

Eg; suggestions for "myhouse" will include "my house"

Default == true


SuppressWarnings Property

SuppressWarnings Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► SuppressWarnings
Keyoti RapidSpell Web .NET
Whether to suppress any warning messages (eg. that textbox couldn't be found).
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool SuppressWarnings { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property SuppressWarnings As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool SuppressWarnings {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member SuppressWarnings : bool with get, set
Property Value
Boolean


TabIndex Property

TabIndex Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► TabIndex
Keyoti RapidSpell Web .NET
The tab order of the control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override short TabIndex { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property TabIndex As Short
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
virtual property short TabIndex {
    short get () override;
    void set (short value) override;
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
abstract TabIndex : int16 with get, set
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
override TabIndex : int16 with get, set
Property Value
Int16


TextComponentInterface Property

TextComponentInterface Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► TextComponentInterface
Keyoti RapidSpell Web .NET
The text box interface to be used.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public TextComponentInterfaceType TextComponentInterface { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property TextComponentInterface As TextComponentInterfaceType
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property TextComponentInterfaceType TextComponentInterface {
    TextComponentInterfaceType get ();
    void set (TextComponentInterfaceType value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member TextComponentInterface : TextComponentInterfaceType with get, set
Property Value
TextComponentInterfaceType
Remarks
Use 'Automatic' for plain and most rich text boxes. Use 'Standard' for regular HTML text boxes (input type='text' and textarea). Use 'RichTextBox' for RichTextBox.com text boxes. Use 'Custom' to define your own interface.


TextComponentName Property

TextComponentName Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► TextComponentName
Keyoti RapidSpell Web .NET
The text component Control ID to be checked on the form.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string TextComponentName { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property TextComponentName As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ TextComponentName {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member TextComponentName : string with get, set
Property Value
String
Remarks

There are 3 ways to set this property;

1. Control ID - the simplest way is to set this property to the server-side ID of the control to be spell checked. This comes with a caveat; because server-side Control IDs need only be unique with-in a ‘naming container’ (eg. page, DataList, DataGrid) and because the Control must be found via the FindControl method (which searches the naming container that the RapidSpellWebLauncher control is in) it is only possible to use the Control ID to specify the text box if the text box Control and the RapidSpellWebLauncher are in the same naming container.

2. Control ClientID - setting the TextComponentName to the ClientID of the text control is a good way to firmly identify the text Control to be spell checked. To do this it is usually best to set the TextComponentName property in code-behind or with a data-bind using the ClientID of the text Control.

eg.
rapidSpellWebLauncher.TextComponentName = textBox1.ClientID

This method can also be used when referring to traditional Html elements (such as <textarea> or <input type=text>), in this case the ID attribute of the tag is used to identify the element.

eg.
<textarea ID="textbox1">This is my text box</textarea>
.....
rapidSpellWebLauncher.TextComponentName = "textbox"

The only warning with this method is to remember (as per good asp.net practice) that the ClientID property of a control is not properly defined until run-time (when the page loads in the browser), therefore the TextComponentName property should be set at run-time, also.

3. Javascript formName.textBoxName - traditionally in client side coding the <formName>.<textBoxName> style was used to identify form elements.

eg.
<form name="mainForm">
<textarea name="textbox1"></textarea<
</form>
.....
TextComponentName = "mainForm.textbox1"

This method can still be used with RapidSpell Web, however in more complex cases (unusual Control IDs, DataGrids etc) it can be hardest to use.

Note: if the "Custom" Javascript interface is being used for a text box interface then the tbElementName argument in RSCustomInterface(tbElementName) will be set according to the method used to identify the text box, as detailed below for each method;

1. Control ID - tbElementName will be set to the ClientID of the Control given by TextComponentName.
2. Control ClientID - tbElementName will be set to TextComponentName.
3. Javascript formName.textBoxName - tbElementName will be set to TextComponentName.


UserDictionaryFile Property

UserDictionaryFile Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► UserDictionaryFile
Keyoti RapidSpell Web .NET
The user dictionary file on the server for the user.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string UserDictionaryFile { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property UserDictionaryFile As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ UserDictionaryFile {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member UserDictionaryFile : string with get, set
Property Value
String
Remarks
This should be an absolute path.


V2Parser Property

V2Parser Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► V2Parser
Keyoti RapidSpell Web .NET
Whether to use parser version 2 - Set to false for backwards (pre v2.8) compatibility. This causes approx. 10-20% speed reduction for spelling error identification.
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool V2Parser { get; set; }
Public Property V2Parser As Boolean
    Get
    Set
public:
property bool V2Parser {
    bool get ();
    void set (bool value);
}
member V2Parser : bool with get, set
Property Value
Boolean


Validate Method

Validate Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► Validate()()()()
Keyoti RapidSpell Web .NET
If Validator==true, this checks the text box for errors, and updates IsValid - note if there are errors but the spell check has already been forced this will set IsValid to true.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void Validate()
Public Overridable Sub Validate
public:
virtual void Validate()
abstract Validate : unit -> unit
override Validate : unit -> unit


Validator Property

Validator Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► Validator
Keyoti RapidSpell Web .NET
Whether to work as a validator.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool Validator { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Validator As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool Validator {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member Validator : bool with get, set
Property Value
Boolean
Remarks
Simply set the Validator property true, and use as any other ASP.NET validator. When validation is performed on the server, if there are errors and the spell check hasn't already been performed then the validation warning will be shown. The user can leave spelling 'errors' in the text box (because some words, such as names, are not known by the spell checker, but are valid), but they must at least run the spell check if there are errors. Set the AutoLaunchWhenTextInvalid property to true to have the spell check launch automatically after the page posts back - however, understand that most pop-up blockers will block pop-up windows opened without direct user action.


ValidatorNeedsText Event

ValidatorNeedsText Event
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► ValidatorNeedsText
Keyoti RapidSpell Web .NET
Fired when the validator is attempting to access the text of the textbox specified by TextComponentID.
Declaration Syntax
C# Visual Basic Visual C++ F#
public event ValidatorNeedsTextEventHandler ValidatorNeedsText
Public Event ValidatorNeedsText As ValidatorNeedsTextEventHandler
public:
 event ValidatorNeedsTextEventHandler^ ValidatorNeedsText {
    void add (ValidatorNeedsTextEventHandler^ value);
    void remove (ValidatorNeedsTextEventHandler^ value);
}
member ValidatorNeedsText : IEvent<ValidatorNeedsTextEventHandler,
    ValidatorNeedsTextEventArgs>
Value
ValidatorNeedsTextEventHandler
Remarks
Handle this event to supply text to the validator. This is necessary usually with 3rd party controls that RapidSpellWInline does not know how to read the text of.


WarnDuplicates Property

WarnDuplicates Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► WarnDuplicates
Keyoti RapidSpell Web .NET
Whether to show duplicate words as errors (eg. "this is is an error").
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool WarnDuplicates { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property WarnDuplicates As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool WarnDuplicates {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member WarnDuplicates : bool with get, set
Property Value
Boolean


WindowHeight Property

WindowHeight Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► WindowHeight
Keyoti RapidSpell Web .NET
Sets the window height (in pixels), when used in Mode=popup.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public int WindowHeight { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property WindowHeight As Integer
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property int WindowHeight {
    int get ();
    void set (int value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member WindowHeight : int with get, set
Property Value
Int32


WindowWidth Property

WindowWidth Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► WindowWidth
Keyoti RapidSpell Web .NET
Sets the window width (in pixels), when used in Mode=popup.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public int WindowWidth { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property WindowWidth As Integer
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property int WindowWidth {
    int get ();
    void set (int value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member WindowWidth : int with get, set
Property Value
Int32


WindowX Property

WindowX Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► WindowX
Keyoti RapidSpell Web .NET
Sets the window X position (in pixels), when used in Mode=popup.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public int WindowX { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property WindowX As Integer
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property int WindowX {
    int get ();
    void set (int value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member WindowX : int with get, set
Property Value
Int32


WindowY Property

WindowY Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► WindowY
Keyoti RapidSpell Web .NET
Sets the window Y position (in pixels), when used in Mode=popup.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public int WindowY { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property WindowY As Integer
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property int WindowY {
    int get ();
    void set (int value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member WindowY : int with get, set
Property Value
Int32


RapidSpellWebLauncherCollection Class

RapidSpellWebLauncherCollection Class
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncherCollection
Keyoti RapidSpell Web .NET
A collection of RapidSpellWebLauncher/RapidSpellWInline IDs
Declaration Syntax
C# Visual Basic Visual C++ F#
public class RapidSpellWebLauncherCollection
Public Class RapidSpellWebLauncherCollection
public ref class RapidSpellWebLauncherCollection
type RapidSpellWebLauncherCollection =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RapidSpellWebLauncherCollection()()()() |
 | RapidSpellWebLauncherCollection(String) | Construct new object with launcher IDs in members, note these must be "ID,ID,ID"
 | Add(String) | Same as ArrayList.Add
 | Count | Same as ArrayList.Count
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() |
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | Item[([( Int32])]) | Indexer for ID in list
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(String) | Same as ArrayList.Remove
 | ToString()()()() | Turns this into a string representation, EXACTLY same format as used in RapidSpellWebLauncherCollection(string members) (Overrides Object.ToString()()()().)
Inheritance Hierarchy
Object
RapidSpellWebLauncherCollection


RapidSpellWebLauncherCollection Constructor

RapidSpellWebLauncherCollection Constructor
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncherCollection ► RapidSpellWebLauncherCollection()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | RapidSpellWebLauncherCollection()()()() |
 | RapidSpellWebLauncherCollection(String) | Construct new object with launcher IDs in members, note these must be "ID,ID,ID"


RapidSpellWebLauncherCollection Constructor

RapidSpellWebLauncherCollection Constructor
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncherCollection ► RapidSpellWebLauncherCollection()()()()
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public RapidSpellWebLauncherCollection()
Public Sub New
public:
RapidSpellWebLauncherCollection()
new : unit -> RapidSpellWebLauncherCollection


RapidSpellWebLauncherCollection Constructor (members)

RapidSpellWebLauncherCollection Constructor (members)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncherCollection ► RapidSpellWebLauncherCollection(String)
Keyoti RapidSpell Web .NET
Construct new object with launcher IDs in members, note these must be "ID,ID,ID"
Declaration Syntax
C# Visual Basic Visual C++ F#
public RapidSpellWebLauncherCollection(
    string members
)
Public Sub New (
    members As String
)
public:
RapidSpellWebLauncherCollection(
    String^ members
)
new :
        members : string -> RapidSpellWebLauncherCollection
Parameters
members (String)


Add Method (ID)

Add Method (ID)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncherCollection ► Add(String)
Keyoti RapidSpell Web .NET
Same as ArrayList.Add
Declaration Syntax
C# Visual Basic Visual C++ F#
public void Add(
    string ID
)
Public Sub Add (
    ID As String
)
public:
void Add(
    String^ ID
)
member Add :
        ID : string -> unit
Parameters
ID (String)


Count Property

Count Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncherCollection ► Count
Keyoti RapidSpell Web .NET
Same as ArrayList.Count
Declaration Syntax
C# Visual Basic Visual C++ F#
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
member Count : int with get
Property Value
Int32


GetEnumerator Method

GetEnumerator Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncherCollection ► GetEnumerator()()()()
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
IEnumerator^ GetEnumerator()
member GetEnumerator : unit -> IEnumerator
Return Value
IEnumerator


Item Property (index)

Item Property (index)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncherCollection ► Item[([( Int32])])
Keyoti RapidSpell Web .NET
Indexer for ID in list
Declaration Syntax
C# Visual Basic Visual C++ F#
public Object this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As Object
    Get
    Set
public:
property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}
member Item : Object with get, set
Parameters
index (Int32)
Property Value
Object


Remove Method (ID)

Remove Method (ID)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncherCollection ► Remove(String)
Keyoti RapidSpell Web .NET
Same as ArrayList.Remove
Declaration Syntax
C# Visual Basic Visual C++ F#
public void Remove(
    string ID
)
Public Sub Remove (
    ID As String
)
public:
void Remove(
    String^ ID
)
member Remove :
        ID : string -> unit
Parameters
ID (String)


ToString Method

ToString Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncherCollection ► ToString()()()()
Keyoti RapidSpell Web .NET
Turns this into a string representation, EXACTLY same format as used in RapidSpellWebLauncherCollection(string members)
Declaration Syntax
C# Visual Basic Visual C++ F#
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string
Return Value
String


RapidSpellWebMultiple Class

RapidSpellWebMultiple Class
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple
Keyoti RapidSpell Web .NET
RapidSpell Web Multiple Control, shows a button that launches multiple RapidSpellWebLaunchers/RapidSpellWInlines consecutively.
Declaration Syntax
C# Visual Basic Visual C++ F#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class RapidSpellWebMultiple : WebControl,
    INamingContainer, IPostBackEventHandler
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Class RapidSpellWebMultiple
    Inherits WebControl
    Implements INamingContainer, IPostBackEventHandler
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public ref class RapidSpellWebMultiple : public WebControl,
    INamingContainer, IPostBackEventHandler
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
type RapidSpellWebMultiple =
    class
        inherit WebControl
        interface INamingContainer
        interface IPostBackEventHandler
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RapidSpellWebMultiple()()()() | Creates a RapidSpellWebMultiple
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | AutoLaunchWhenTextInvalid | Whether to start the spell check automatically when constituent launchers are IsValid=false.
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BeginRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Button | The HtmlInputButton shown to the user, when clicked the spell checker starts.
 | ButtonImageMouseDown | The button image URL. This is for mouse down and is optional.
 | ButtonImageMouseOut | The button image URL. This is for mouse out (ie. not mouse over) and is optional.
 | ButtonImageMouseOver | The button image URL. This is for mouse over and is optional.
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearCachedClientID()()()() | (Inherited from Control.)
 | ClearChildControlState()()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClearEffectiveClientIDMode()()()() | (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDMode | (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | CloseWindowWhenFinished | Whether to close the popup at the end of the spell check.
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataItemContainer | (Inherited from Control.)
 | DataKeysContainer | (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Enabled state of the control. (Overrides WebControl.Enabled.)
 | EnableTheming | Theming is currently disabled. Support to be added in later versions. (Overrides WebControl.EnableTheming.)
 | EnableViewState | Viewstate is always disabled. (Overrides Control.EnableViewState.)
 | EndRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | EnsureChildControls()()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
 | Finish | Fired when the spell check is finished AND PostBackOnFinish==true.
 | FinishedListener | The name of a JavaScript function (without brackets) that should be called when pop up spell checking is finished (optional).
 | FinishedOnTextBoxListener | The name of a JavaScript function (without brackets) that should be called when spell checking is finished, per text box.
 | FinishedText | The text displayed when the spell check finishes.
 | Focus()()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetJSVars()()()() | Returns a Javascript variable string setting the controls collection to be checked. Intended for use with Atlas.
 | GetRouteUrl(Object) | (Inherited from Control.)
 | GetRouteUrl(String, Object) | (Inherited from Control.)
 | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
 | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetUniqueIDRelativeTo(Control) | (Inherited from Control.)
 | GuiLanguage | The UI language.
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | IgnoreEmptyTextBoxes | Whether to ignore text boxes that are empty.
 | IgnoreInvisibleLaunchers | Whether to ignore launchers which are not visible at the time of rendering
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnFinish(EventArgs) | Called when the spell check is finished AND PostBackOnFinish==true.
 | OnInit(EventArgs) | Called when the Init event occurs. (Overrides Control.OnInit(EventArgs).)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Overrides control prerender (Overrides Control.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PostBackOnFinish | Whether to post back to the server when the spell check finishes.
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostBackEvent(String) | Method of IPostBackEventHandler that raises change events.
 | RapidSpellWebLaunchers | The ID's of the RapidSpellWebLauncher/RapidSpellWinline controls to start when the button is clicked.
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders this control. (Overrides WebControl.RenderContents(HtmlTextWriter).)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderForDesign(HtmlTextWriter) | Renders this control for the design surface.
 | RenderingCompatibility | (Inherited from Control.)
 | ResolveAdapter()()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()()() | Saves any state that was modified after the TrackViewState()()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetTraceData(Object, Object) | (Inherited from Control.)
 | SetTraceData(Object, Object, Object) | (Inherited from Control.)
 | ShowButton | Whether to show the launcher button (set to false to hide button/images). The client-side code will be written regardless.
 | ShowFinishedMessage | Whether to show the popup dialog at the end of the spell check.
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SSLFriendly | Whether to run in SSL friendly mode, setting this to true prevents 'leaving secure site' warning messages in IE.
 | StartedOnTextBoxListener | The name of a JavaScript function (without brackets) that should be called when spell checking is started, per text box.
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | SupportsDisabledAttribute | (Inherited from WebControl.)
 | TabIndex | The tab order of the control. (Overrides WebControl.TabIndex.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TrackViewState()()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UseClientIdInJavascript | Whether to use the control's ClientId instead of Id property for the JS functions.
 | UseSmoothTransitions | Whether to transition between text boxes smoothly, set to false for v2 behavior.
 | ValidateRequestMode | (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateMode | (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
 | WindowHeight | Sets the window height (in pixels), when used in Mode=popup.
 | WindowWidth | Sets the window width (in pixels), when used in Mode=popup.
 | WindowX | Sets the window X position (in pixels), when used in Mode=popup.
 | WindowY | Sets the window Y position (in pixels), when used in Mode=popup.
Remarks
This control can be configured to launch any combination of RapidSpellWebLauncher and/or RapidSpellWInline through the RapidSpellWebLaunchers property.
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | RapidSpellWebMultiple


RapidSpellWebMultiple Constructor

RapidSpellWebMultiple Constructor
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► RapidSpellWebMultiple()()()()
Keyoti RapidSpell Web .NET
Creates a RapidSpellWebMultiple
Declaration Syntax
C# Visual Basic Visual C++ F#
public RapidSpellWebMultiple()
Public Sub New
public:
RapidSpellWebMultiple()
new : unit -> RapidSpellWebMultiple


AutoLaunchWhenTextInvalid Property

AutoLaunchWhenTextInvalid Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► AutoLaunchWhenTextInvalid
Keyoti RapidSpell Web .NET
Whether to start the spell check automatically when constituent launchers are IsValid=false.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool AutoLaunchWhenTextInvalid { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property AutoLaunchWhenTextInvalid As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool AutoLaunchWhenTextInvalid {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member AutoLaunchWhenTextInvalid : bool with get, set
Property Value
Boolean
Remarks
Simply set the Validator property in each RapidSpellWebLauncher to true, and assign the RapidSpellWebMultiple as usual. When validation is performed on the server, if there are errors and the spell check hasn't already been performed then the validation warning will be shown. The user can leave spelling 'errors' in the text box (because some words, such as names, are not known by the spell checker, but are valid), but they must at least run the spell check if there are errors. Set the AutoLaunchWhenTextInvalid property to true to have the spell check launch automatically after the page posts back - however, understand that most pop-up blockers will block pop-up windows opened without direct user action.


Button Property

Button Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► Button
Keyoti RapidSpell Web .NET
The HtmlInputButton shown to the user, when clicked the spell checker starts.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public RSButton Button { get; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property Button As RSButton
    Get
public:
[PersistenceModeAttribute(PersistenceMode::InnerProperty)]
property RSButton^ Button {
    RSButton^ get ();
}
[<PersistenceModeAttribute(PersistenceMode.InnerProperty)>]
member Button : RSButton with get
Property Value
RSButton


ButtonImageMouseDown Property

ButtonImageMouseDown Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► ButtonImageMouseDown
Keyoti RapidSpell Web .NET
The button image URL. This is for mouse down and is optional.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string ButtonImageMouseDown { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ButtonImageMouseDown As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ ButtonImageMouseDown {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ButtonImageMouseDown : string with get, set
Property Value
String


ButtonImageMouseOut Property

ButtonImageMouseOut Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► ButtonImageMouseOut
Keyoti RapidSpell Web .NET
The button image URL. This is for mouse out (ie. not mouse over) and is optional.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string ButtonImageMouseOut { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ButtonImageMouseOut As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ ButtonImageMouseOut {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ButtonImageMouseOut : string with get, set
Property Value
String


ButtonImageMouseOver Property

ButtonImageMouseOver Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► ButtonImageMouseOver
Keyoti RapidSpell Web .NET
The button image URL. This is for mouse over and is optional.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string ButtonImageMouseOver { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ButtonImageMouseOver As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ ButtonImageMouseOver {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ButtonImageMouseOver : string with get, set
Property Value
String


CloseWindowWhenFinished Property

CloseWindowWhenFinished Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► CloseWindowWhenFinished
Keyoti RapidSpell Web .NET
Whether to close the popup at the end of the spell check.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool CloseWindowWhenFinished { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property CloseWindowWhenFinished As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool CloseWindowWhenFinished {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member CloseWindowWhenFinished : bool with get, set
Property Value
Boolean


Enabled Property

Enabled Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► Enabled
Keyoti RapidSpell Web .NET
Enabled state of the control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override bool Enabled { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property Enabled As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
virtual property bool Enabled {
    bool get () override;
    void set (bool value) override;
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
abstract Enabled : bool with get, set
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
override Enabled : bool with get, set
Property Value
Boolean


EnableTheming Property

EnableTheming Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► EnableTheming
Keyoti RapidSpell Web .NET
Theming is currently disabled. Support to be added in later versions.
Declaration Syntax
C# Visual Basic Visual C++ F#
public override bool EnableTheming { get; }
Public Overrides ReadOnly Property EnableTheming As Boolean
    Get
public:
virtual property bool EnableTheming {
    bool get () override;
}
abstract EnableTheming : bool with get
override EnableTheming : bool with get
Property Value
Boolean


EnableViewState Property

EnableViewState Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► EnableViewState
Keyoti RapidSpell Web .NET
Viewstate is always disabled.
Declaration Syntax
C# Visual Basic Visual C++ F#
public override bool EnableViewState { get; }
Public Overrides ReadOnly Property EnableViewState As Boolean
    Get
public:
virtual property bool EnableViewState {
    bool get () override;
}
abstract EnableViewState : bool with get
override EnableViewState : bool with get
Property Value
Boolean


Finish Event

Finish Event
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► Finish
Keyoti RapidSpell Web .NET
Fired when the spell check is finished AND PostBackOnFinish==true.
Declaration Syntax
C# Visual Basic Visual C++ F#
public event EventHandler Finish
Public Event Finish As EventHandler
public:
 event EventHandler^ Finish {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member Finish : IEvent<EventHandler,
    EventArgs>
Value
EventHandler


FinishedListener Property

FinishedListener Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► FinishedListener
Keyoti RapidSpell Web .NET
The name of a JavaScript function (without brackets) that should be called when pop up spell checking is finished (optional).
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string FinishedListener { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property FinishedListener As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ FinishedListener {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member FinishedListener : string with get, set
Property Value
String
Remarks
This is optional, and of use if you require client side (or indirectly server side) notification that the spell check has finished. The function named here will be called when the pop up spell check is finished by the user (or the window was closed), it must not have any arguments.


FinishedOnTextBoxListener Property

FinishedOnTextBoxListener Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► FinishedOnTextBoxListener
Keyoti RapidSpell Web .NET
The name of a JavaScript function (without brackets) that should be called when spell checking is finished, per text box.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string FinishedOnTextBoxListener { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property FinishedOnTextBoxListener As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ FinishedOnTextBoxListener {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member FinishedOnTextBoxListener : string with get, set
Property Value
String
Remarks
This is optional, and of use if you require client side notification that the spell check has finished on each text box. The function named here must have one argument which will receive the text box object that was being checked.


FinishedText Property

FinishedText Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► FinishedText
Keyoti RapidSpell Web .NET
The text displayed when the spell check finishes.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string FinishedText { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property FinishedText As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ FinishedText {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member FinishedText : string with get, set
Property Value
String


GetJSVars Method

GetJSVars Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► GetJSVars()()()()
Keyoti RapidSpell Web .NET
Returns a Javascript variable string setting the controls collection to be checked. Intended for use with Atlas.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual string GetJSVars()
Public Overridable Function GetJSVars As String
public:
virtual String^ GetJSVars()
abstract GetJSVars : unit -> string
override GetJSVars : unit -> string
Return Value
String


GuiLanguage Property

GuiLanguage Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► GuiLanguage
Keyoti RapidSpell Web .NET
The UI language.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public LanguageType GuiLanguage { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property GuiLanguage As LanguageType
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property LanguageType GuiLanguage {
    LanguageType get ();
    void set (LanguageType value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member GuiLanguage : LanguageType with get, set
Property Value
LanguageType
Remarks
This is the language that all text on the UI should be in.


IgnoreEmptyTextBoxes Property

IgnoreEmptyTextBoxes Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► IgnoreEmptyTextBoxes
Keyoti RapidSpell Web .NET
Whether to ignore text boxes that are empty.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool IgnoreEmptyTextBoxes { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property IgnoreEmptyTextBoxes As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool IgnoreEmptyTextBoxes {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member IgnoreEmptyTextBoxes : bool with get, set
Property Value
Boolean


IgnoreInvisibleLaunchers Property

IgnoreInvisibleLaunchers Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► IgnoreInvisibleLaunchers
Keyoti RapidSpell Web .NET
Whether to ignore launchers which are not visible at the time of rendering
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool IgnoreInvisibleLaunchers { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property IgnoreInvisibleLaunchers As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool IgnoreInvisibleLaunchers {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member IgnoreInvisibleLaunchers : bool with get, set
Property Value
Boolean


OnFinish Method (e)

OnFinish Method (e)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► OnFinish(EventArgs)
Keyoti RapidSpell Web .NET
Called when the spell check is finished AND PostBackOnFinish==true.
Declaration Syntax
C# Visual Basic Visual C++ F#
protected virtual void OnFinish(
    EventArgs e
)
Protected Overridable Sub OnFinish (
    e As EventArgs
)
protected:
virtual void OnFinish(
    EventArgs^ e
)
abstract OnFinish :
        e : EventArgs -> unit
override OnFinish :
        e : EventArgs -> unit
Parameters
e (EventArgs)


OnInit Method (e)

OnInit Method (e)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► OnInit(EventArgs)
Keyoti RapidSpell Web .NET
Called when the Init event occurs.
Declaration Syntax
C# Visual Basic Visual C++ F#
protected override void OnInit(
    EventArgs e
)
Protected Overrides Sub OnInit (
    e As EventArgs
)
protected:
virtual void OnInit(
    EventArgs^ e
) override
abstract OnInit :
        e : EventArgs -> unit
override OnInit :
        e : EventArgs -> unit
Parameters
e (EventArgs)


OnPreRender Method (e)

OnPreRender Method (e)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► OnPreRender(EventArgs)
Keyoti RapidSpell Web .NET
Overrides control prerender
Declaration Syntax
C# Visual Basic Visual C++ F#
protected override void OnPreRender(
    EventArgs e
)
Protected Overrides Sub OnPreRender (
    e As EventArgs
)
protected:
virtual void OnPreRender(
    EventArgs^ e
) override
abstract OnPreRender :
        e : EventArgs -> unit
override OnPreRender :
        e : EventArgs -> unit
Parameters
e (EventArgs)


PostBackOnFinish Property

PostBackOnFinish Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► PostBackOnFinish
Keyoti RapidSpell Web .NET
Whether to post back to the server when the spell check finishes.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool PostBackOnFinish { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property PostBackOnFinish As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool PostBackOnFinish {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member PostBackOnFinish : bool with get, set
Property Value
Boolean
Remarks


RaisePostBackEvent Method (eventArgument)

RaisePostBackEvent Method (eventArgument)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► RaisePostBackEvent(String)
Keyoti RapidSpell Web .NET
Method of IPostBackEventHandler that raises change events.
Declaration Syntax
C# Visual Basic Visual C++ F#
public void RaisePostBackEvent(
    string eventArgument
)
Public Sub RaisePostBackEvent (
    eventArgument As String
)
public:
virtual void RaisePostBackEvent(
    String^ eventArgument
) sealed
abstract RaisePostBackEvent :
        eventArgument : string -> unit
override RaisePostBackEvent :
        eventArgument : string -> unit
Parameters
eventArgument (String)


RapidSpellWebLaunchers Property

RapidSpellWebLaunchers Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► RapidSpellWebLaunchers
Keyoti RapidSpell Web .NET
The ID's of the RapidSpellWebLauncher/RapidSpellWinline controls to start when the button is clicked.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public RapidSpellWebLauncherCollection RapidSpellWebLaunchers { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property RapidSpellWebLaunchers As RapidSpellWebLauncherCollection
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property RapidSpellWebLauncherCollection^ RapidSpellWebLaunchers {
    RapidSpellWebLauncherCollection^ get ();
    void set (RapidSpellWebLauncherCollection^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member RapidSpellWebLaunchers : RapidSpellWebLauncherCollection with get, set
Property Value
RapidSpellWebLauncherCollection
Remarks
This can also be set to the ID of a container control with RapidSpellWebLauncher/RapidSpellWinline controls inside it, eg. a DataGrid


RenderContents Method (output)

RenderContents Method (output)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► RenderContents(HtmlTextWriter)
Keyoti RapidSpell Web .NET
Renders this control.
Declaration Syntax
C# Visual Basic Visual C++ F#
protected override void RenderContents(
    HtmlTextWriter output
)
Protected Overrides Sub RenderContents (
    output As HtmlTextWriter
)
protected:
virtual void RenderContents(
    HtmlTextWriter^ output
) override
abstract RenderContents :
        output : HtmlTextWriter -> unit
override RenderContents :
        output : HtmlTextWriter -> unit
Parameters
output (HtmlTextWriter)


RenderForDesign Method (output)

RenderForDesign Method (output)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► RenderForDesign(HtmlTextWriter)
Keyoti RapidSpell Web .NET
Renders this control for the design surface.
Declaration Syntax
C# Visual Basic Visual C++ F#
public void RenderForDesign(
    HtmlTextWriter output
)
Public Sub RenderForDesign (
    output As HtmlTextWriter
)
public:
void RenderForDesign(
    HtmlTextWriter^ output
)
member RenderForDesign :
        output : HtmlTextWriter -> unit
Parameters
output (HtmlTextWriter)


ShowButton Property

ShowButton Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► ShowButton
Keyoti RapidSpell Web .NET
Whether to show the launcher button (set to false to hide button/images). The client-side code will be written regardless.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool ShowButton { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ShowButton As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool ShowButton {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ShowButton : bool with get, set
Property Value
Boolean


ShowFinishedMessage Property

ShowFinishedMessage Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► ShowFinishedMessage
Keyoti RapidSpell Web .NET
Whether to show the popup dialog at the end of the spell check.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool ShowFinishedMessage { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ShowFinishedMessage As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool ShowFinishedMessage {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ShowFinishedMessage : bool with get, set
Property Value
Boolean


SSLFriendly Property

SSLFriendly Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► SSLFriendly
Keyoti RapidSpell Web .NET
Whether to run in SSL friendly mode, setting this to true prevents 'leaving secure site' warning messages in IE.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool SSLFriendly { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property SSLFriendly As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool SSLFriendly {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member SSLFriendly : bool with get, set
Property Value
Boolean
Remarks
Requires a file called 'blank.html' in the same folder as the RapidSpellWeLauncher page.


StartedOnTextBoxListener Property

StartedOnTextBoxListener Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► StartedOnTextBoxListener
Keyoti RapidSpell Web .NET
The name of a JavaScript function (without brackets) that should be called when spell checking is started, per text box.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string StartedOnTextBoxListener { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property StartedOnTextBoxListener As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ StartedOnTextBoxListener {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member StartedOnTextBoxListener : string with get, set
Property Value
String
Remarks
This is optional, and of use if you require client side notification that the spell check has started on each text box. The function named here must have one argument which will receive the text box object that is being checked.


TabIndex Property

TabIndex Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► TabIndex
Keyoti RapidSpell Web .NET
The tab order of the control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override short TabIndex { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property TabIndex As Short
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
virtual property short TabIndex {
    short get () override;
    void set (short value) override;
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
abstract TabIndex : int16 with get, set
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
override TabIndex : int16 with get, set
Property Value
Int16


UseClientIdInJavascript Property

UseClientIdInJavascript Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► UseClientIdInJavascript
Keyoti RapidSpell Web .NET
Whether to use the control's ClientId instead of Id property for the JS functions.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool UseClientIdInJavascript { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property UseClientIdInJavascript As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool UseClientIdInJavascript {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member UseClientIdInJavascript : bool with get, set
Property Value
Boolean
Remarks
Ideally this should be true, but is false for backwards compatibility. It affects the name of the JS function used to start the spell checker.


UseSmoothTransitions Property

UseSmoothTransitions Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► UseSmoothTransitions
Keyoti RapidSpell Web .NET
Whether to transition between text boxes smoothly, set to false for v2 behavior.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool UseSmoothTransitions { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property UseSmoothTransitions As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool UseSmoothTransitions {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member UseSmoothTransitions : bool with get, set
Property Value
Boolean


WindowHeight Property

WindowHeight Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► WindowHeight
Keyoti RapidSpell Web .NET
Sets the window height (in pixels), when used in Mode=popup.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public int WindowHeight { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property WindowHeight As Integer
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property int WindowHeight {
    int get ();
    void set (int value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member WindowHeight : int with get, set
Property Value
Int32


WindowWidth Property

WindowWidth Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► WindowWidth
Keyoti RapidSpell Web .NET
Sets the window width (in pixels), when used in Mode=popup.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public int WindowWidth { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property WindowWidth As Integer
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property int WindowWidth {
    int get ();
    void set (int value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member WindowWidth : int with get, set
Property Value
Int32


WindowX Property

WindowX Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► WindowX
Keyoti RapidSpell Web .NET
Sets the window X position (in pixels), when used in Mode=popup.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public int WindowX { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property WindowX As Integer
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property int WindowX {
    int get ();
    void set (int value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member WindowX : int with get, set
Property Value
Int32


WindowY Property

WindowY Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► WindowY
Keyoti RapidSpell Web .NET
Sets the window Y position (in pixels), when used in Mode=popup.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public int WindowY { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property WindowY As Integer
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property int WindowY {
    int get ();
    void set (int value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member WindowY : int with get, set
Property Value
Int32


RapidSpellWInline Class

RapidSpellWInline Class
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline
Keyoti RapidSpell Web .NET
RapidSpell Web Inline Control, shows a button that launches the inline highlight spell checker.
Declaration Syntax
C# Visual Basic Visual C++ F#
public class RapidSpellWInline : WebControl,
    IValidator, INamingContainer
Public Class RapidSpellWInline
    Inherits WebControl
    Implements IValidator, INamingContainer
public ref class RapidSpellWInline : public WebControl,
    IValidator, INamingContainer
type RapidSpellWInline =
    class
        inherit WebControl
        interface IValidator
        interface INamingContainer
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RapidSpellWInline()()()() | Creates a new instance
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddMenuText | The text used for the Add menu item.
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | AllowMixedCase | Whether to allow words spelt with mixed case, eg. "MIxEd"
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AsYouTypeDelay | Number of milliseconds to wait after user stops typing before rechecking.
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | AutoLaunchWhenTextInvalid | Whether to start the spell check automatically when Validator==true and text has errors. See same in RapidSpellWebMultiple also.
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BeginRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | Button | The HtmlInputButton shown to the user, when clicked the spell checker starts.
 | ButtonText | The start text used for the button.
 | ButtonTextSpellChecking | The text used for the button while it is transitioning to 'spell mode'.
 | ButtonTextSpellMode | The text used for the button while it is in 'spell mode'.
 | ChangeAllText | The text used for the Change All sub menu item (only shown if ShowChangeAllItem == true).
 | ChangeButtonTextWithState | Whether to change the button state/text when in spell check mode.
 | CheckAsYouType | Whether to spell check as the user types.
 | CheckAsYouTypeOnPageLoad | Whether to run the spell check automatically when the page loads.
 | CheckCompoundWords | Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
 | CheckTextBoxForErrors()()()() | Evaluates the text in the assigned text box for errors, this is called during validation. Returns true if there are errors, false if there are no errors or if the text box couldn't be accessed (see remarks).
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearCachedClientID()()()() | (Inherited from Control.)
 | ClearChildControlState()()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClearEffectiveClientIDMode()()()() | (Inherited from Control.)
 | ClientFilesFolder | Where the client files are found, must be an absolute path to the directory containing the RapidSpell client files.
 | ClientFilesLocation | Whether to use the internal client files, or external files (for customization).
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDMode | (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientSideObject | The name of the Javascript object variable representing the spell checker on the client side.
 | ConsiderationRange | The size factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anyting.
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CopyComputedStyleToOverlay | Whether to copy the computed style of the target text box to the overlay DIV.
 | CreateChildControls()()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | CssClassStaticOverlay | The CSS class given to the static-mode overlay DIV element which holds spelling errors in front of the text box.
 | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataItemContainer | (Inherited from Control.)
 | DataKeysContainer | (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | DictFile | (Optional) main dictionary (.dict) file on the server.
 | Dispose()()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | DoPreRender()()()() |
 | DoubleClickSwitchesMode | Whether to change a static text box from checking to editing on double-click
 | EditMenuText | The text used for the Edit... menu item.
 | Enabled | Enabled state of the control. (Overrides WebControl.Enabled.)
 | EnableTheming | Theming is currently disabled. Support to be added in later versions. (Overrides WebControl.EnableTheming.)
 | EnableViewState | Viewstate is always disabled. (Overrides Control.EnableViewState.)
 | EndRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | EnsureChildControls()()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | EnterEditModeWhenNoMoreErrors | Whether to automatically change a static text box from checking to editing when there are no more errors remaining.
 | EnterStaticSpellCheckListener | The name of a JavaScript function (without brackets) that should be called when the text box is overlayed with the static spell check layer.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorMessage | The error message to show the user when validation fails.
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
 | FinishedListener | The name of a JavaScript function (without brackets) that should be called when spell checking is finished (optional).
 | Focus()()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRouteUrl(Object) | (Inherited from Control.)
 | GetRouteUrl(String, Object) | (Inherited from Control.)
 | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
 | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetUniqueIDRelativeTo(Control) | (Inherited from Control.)
 | GuiLanguage | The UI language.
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | HideAddItemAlways | Whether to always hide the Add menu item - regardless of whether a user dictionary is specified.
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | IgnoreAllMenuText | The text used for the Ignore All menu item.
 | IgnoreCapitalizedWords | Whether to ignore words with capital letters.
 | IgnoreIncorrectSentenceCapitalization | Whether to ignore incorrect sentence capitalization.
 | IgnoreInEnglishLowerCaseI | Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
 | IgnoreURLsAndEmailAddresses | Whether to ignore URLs and email addresses (requires V2Parser=true)
 | IgnoreWordsWithDigits | Whether to ignore words with numbers in them (eg. A10 or 7-11).
 | IgnoreXML | Whether to ignore XML/HTML tags, false by default.
 | IncludeUserDictionaryInSuggestions | Whether the user dictionary should be used in finding suggestions for misspelt words.
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsValid | Whether the validator has identified an error or whether spell checking has already been forced by the validator.
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | LanguageParser | The language parser to use, this should match the language of the main dictionary where possible.
 | LeaveStaticSpellCheckListener | The name of a JavaScript function (without brackets) that should be called when the text box switches from the static spell check to edit mode.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | LookIntoHyphenatedText | Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | NoSpellErrorsText | The text used for the no spelling errors message.
 | NoSuggestionsMenuText | The text used for the No Suggestions menu item.
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Registers required scripts. (Overrides Control.OnInit(EventArgs).)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Renders required client script (Overrides Control.OnPreRender(EventArgs).)
 | OnUnload(EventArgs) | On p (Overrides Control.OnUnload(EventArgs).)
 | OnValidatorNeedsText(ValidatorNeedsTextEventArgs) | Raises the ValidatorNeedsText event, allowing e.TextBoxText to be set with the text to validate.
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RapidSpellWInlineHelperPage | The URL of the page holding the RapidSpellWInlineHelper control.
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | RemoveDuplicateMenuText | The text used for the Remove Duplicate Words menu item.
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Render this control to the output parameter specified. (Overrides WebControl.RenderContents(HtmlTextWriter).)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the end of this tag (Overrides WebControl.RenderEndTag(HtmlTextWriter).)
 | RenderForDesign(HtmlTextWriter) | Renders this control for the design surface.
 | RenderingCompatibility | (Inherited from Control.)
 | ResolveAdapter()()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | ResponseTimeout | Number of seconds to pass before a message is shown to the user reporting a time-out.
 | ResponseTimeoutMessage | The message shown to the user in the event that the spell check request times-out.
 | RightClickForMenu | Whether to show the spelling context menu on right click instead of left click.
 | RSMultipleID | The ID of the RapidSpellWebMultiple control managing multi text box checking.
 | RunSpellCheckFunctionJS | The Javascript function that should be registered on the page in order to run the spell check when the page loads.
 | SaveControlState()()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()()() | Saves any state that was modified after the TrackViewState()()()() method was invoked. (Inherited from WebControl.)
 | SeparateHyphenWords | Whether to treat hyphenated (-) words as separate words, default is false.
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetTraceData(Object, Object) | (Inherited from Control.)
 | SetTraceData(Object, Object, Object) | (Inherited from Control.)
 | ShowAddItemAlways | Whether to always show the Add menu item - regardless of whether a user dictionary is specified.
 | ShowButton | Whether to show the launcher button (set to false to hide button/images). The client-side code will be written regardless.
 | ShowChangeAllItem | Whether to show the Change All sub menu item.
 | ShowIgnoreAllMenuItem | Whether to show the Ignore All menu item.
 | ShowNoErrorsMessage | Whether to show the launcher button (set to false to hide button/images). The client-side code will be written regardless.
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | SSLFriendlyPage | The URL of the file to set in Iframes, this avoids SSL warnings.
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | SuggestionsMethod | Suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
 | SuggestSplitWords | Whether to look for connected words in suggestions.
 | SupportsDisabledAttribute | (Inherited from WebControl.)
 | SuppressWarnings | Whether to suppress any warning messages (eg. that textbox couldn't be found).
 | TabIndex | The tab order of the control. (Overrides WebControl.TabIndex.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | TextComponentID | The server/client (automatically detected) ID of the text box to work with.
 | TextComponentInterface | The text box interface to be used.
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TrackViewState()()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UserDictionaryFile | The user dictionary file on the server for the user.
 | UseXMLHTTPWhenAvailable | Whether to use XMLHttpRequest (when it's available) to communicate with the server - typically this is best set true.
 | V2Parser | Whether to use parser version 2 - Set to false for backwards (pre v2.8) compatibility. This causes approx. 10-20% speed reduction for spelling error identification.
 | Validate()()()() | If Validator==true, this checks the text box for errors, and updates IsValid - note if there are errors but the spell check has already been forced this will set IsValid to true.
 | ValidateRequestMode | (Inherited from Control.)
 | Validator | Whether to work as a validator.
 | ValidatorNeedsText | Fired when the validator is attempting to access the text of the textbox specified by TextComponentID.
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateMode | (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | WarnDuplicates | Whether to show duplicate words as errors (eg. "this is is an error").
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Remarks
The minimum requirements to use this control are that TextComponentID and RapidSpellWInlineHelperPage properties are set.

Eg.

Copy image Copy
<RapidSpellWeb:RapidSpellWInline id="rapidSpellWInline1" runat="server"
                            TextComponentID="TextBox1"
                            RapidSpellWInlineHelperPage="rswiHelper.aspx">
                 </RapidSpellWeb:RapidSpellWInline>
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | RapidSpellWInline


RapidSpellWInline Constructor

RapidSpellWInline Constructor
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► RapidSpellWInline()()()()
Keyoti RapidSpell Web .NET
Creates a new instance
Declaration Syntax
C# Visual Basic Visual C++ F#
public RapidSpellWInline()
Public Sub New
public:
RapidSpellWInline()
new : unit -> RapidSpellWInline


AddMenuText Property

AddMenuText Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► AddMenuText
Keyoti RapidSpell Web .NET
The text used for the Add menu item.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string AddMenuText { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property AddMenuText As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ AddMenuText {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member AddMenuText : string with get, set
Property Value
String


AllowMixedCase Property

AllowMixedCase Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► AllowMixedCase
Keyoti RapidSpell Web .NET
Whether to allow words spelt with mixed case, eg. "MIxEd"
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool AllowMixedCase { get; set; }
Public Property AllowMixedCase As Boolean
    Get
    Set
public:
property bool AllowMixedCase {
    bool get ();
    void set (bool value);
}
member AllowMixedCase : bool with get, set
Property Value
Boolean


AsYouTypeDelay Property

AsYouTypeDelay Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► AsYouTypeDelay
Keyoti RapidSpell Web .NET
Number of milliseconds to wait after user stops typing before rechecking.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public int AsYouTypeDelay { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property AsYouTypeDelay As Integer
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property int AsYouTypeDelay {
    int get ();
    void set (int value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member AsYouTypeDelay : int with get, set
Property Value
Int32


AutoLaunchWhenTextInvalid Property

AutoLaunchWhenTextInvalid Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► AutoLaunchWhenTextInvalid
Keyoti RapidSpell Web .NET
Whether to start the spell check automatically when Validator==true and text has errors. See same in RapidSpellWebMultiple also.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool AutoLaunchWhenTextInvalid { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property AutoLaunchWhenTextInvalid As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool AutoLaunchWhenTextInvalid {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member AutoLaunchWhenTextInvalid : bool with get, set
Property Value
Boolean


Button Property

Button Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► Button
Keyoti RapidSpell Web .NET
The HtmlInputButton shown to the user, when clicked the spell checker starts.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public RSButton Button { get; }
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property Button As RSButton
    Get
public:
[PersistenceModeAttribute(PersistenceMode::InnerProperty)]
property RSButton^ Button {
    RSButton^ get ();
}
[<PersistenceModeAttribute(PersistenceMode.InnerProperty)>]
member Button : RSButton with get
Property Value
RSButton


ButtonText Property

ButtonText Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► ButtonText
Keyoti RapidSpell Web .NET
The start text used for the button.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string ButtonText { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ButtonText As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ ButtonText {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ButtonText : string with get, set
Property Value
String


ButtonTextSpellChecking Property

ButtonTextSpellChecking Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► ButtonTextSpellChecking
Keyoti RapidSpell Web .NET
The text used for the button while it is transitioning to 'spell mode'.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string ButtonTextSpellChecking { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ButtonTextSpellChecking As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ ButtonTextSpellChecking {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ButtonTextSpellChecking : string with get, set
Property Value
String


ButtonTextSpellMode Property

ButtonTextSpellMode Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► ButtonTextSpellMode
Keyoti RapidSpell Web .NET
The text used for the button while it is in 'spell mode'.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string ButtonTextSpellMode { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ButtonTextSpellMode As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ ButtonTextSpellMode {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ButtonTextSpellMode : string with get, set
Property Value
String


ChangeAllText Property

ChangeAllText Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► ChangeAllText
Keyoti RapidSpell Web .NET
The text used for the Change All sub menu item (only shown if ShowChangeAllItem == true).
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string ChangeAllText { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ChangeAllText As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ ChangeAllText {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ChangeAllText : string with get, set
Property Value
String


ChangeButtonTextWithState Property

ChangeButtonTextWithState Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► ChangeButtonTextWithState
Keyoti RapidSpell Web .NET
Whether to change the button state/text when in spell check mode.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool ChangeButtonTextWithState { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ChangeButtonTextWithState As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool ChangeButtonTextWithState {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ChangeButtonTextWithState : bool with get, set
Property Value
Boolean


CheckAsYouType Property

CheckAsYouType Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► CheckAsYouType
Keyoti RapidSpell Web .NET
Whether to spell check as the user types.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool CheckAsYouType { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property CheckAsYouType As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool CheckAsYouType {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member CheckAsYouType : bool with get, set
Property Value
Boolean


CheckAsYouTypeOnPageLoad Property

CheckAsYouTypeOnPageLoad Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► CheckAsYouTypeOnPageLoad
Keyoti RapidSpell Web .NET
Whether to run the spell check automatically when the page loads.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool CheckAsYouTypeOnPageLoad { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property CheckAsYouTypeOnPageLoad As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool CheckAsYouTypeOnPageLoad {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member CheckAsYouTypeOnPageLoad : bool with get, set
Property Value
Boolean


CheckCompoundWords Property

CheckCompoundWords Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► CheckCompoundWords
Keyoti RapidSpell Web .NET
Whether to check for compound words, setting this to true is essential for languages such as German which allow for compound words.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool CheckCompoundWords { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property CheckCompoundWords As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool CheckCompoundWords {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member CheckCompoundWords : bool with get, set
Property Value
Boolean
Remarks
If this=false then LookUp("thesewordsarejoined") = false

If this=true then LookUp("thesewordsarejoined") = true

If this=false then LookUp("abcdef") = false

If this=true then LookUp("abcdef") = false

Setting this to true will degrade lookup performance


CheckTextBoxForErrors Method

CheckTextBoxForErrors Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► CheckTextBoxForErrors()()()()
Keyoti RapidSpell Web .NET
Evaluates the text in the assigned text box for errors, this is called during validation. Returns true if there are errors, false if there are no errors or if the text box couldn't be accessed (see remarks).
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual bool CheckTextBoxForErrors()
Public Overridable Function CheckTextBoxForErrors As Boolean
public:
virtual bool CheckTextBoxForErrors()
abstract CheckTextBoxForErrors : unit -> bool
override CheckTextBoxForErrors : unit -> bool
Return Value
Boolean
Remarks
Access the text box using Parent.FindControl(TextComponentID), so the TextComponentID must be the ID of the text box and the text box and this control must be in the same naming container (eg. page, user control, grid item).

This method fires the ValidatorNeedsText event, which allows you to pass the text to check.


ClientFilesFolder Property

ClientFilesFolder Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► ClientFilesFolder
Keyoti RapidSpell Web .NET
Where the client files are found, must be an absolute path to the directory containing the RapidSpell client files.
Declaration Syntax
C# Visual Basic Visual C++ F#
public string ClientFilesFolder { get; set; }
Public Property ClientFilesFolder As String
    Get
    Set
public:
property String^ ClientFilesFolder {
    String^ get ();
    void set (String^ value);
}
member ClientFilesFolder : string with get, set
Property Value
String
Remarks
Default = /Keyoti_RapidSpell_Web_Common/


ClientFilesLocation Property

ClientFilesLocation Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► ClientFilesLocation
Keyoti RapidSpell Web .NET
Whether to use the internal client files, or external files (for customization).
Declaration Syntax
C# Visual Basic Visual C++ F#
public ClientFilesLocation ClientFilesLocation { get; set; }
Public Property ClientFilesLocation As ClientFilesLocation
    Get
    Set
public:
property ClientFilesLocation ClientFilesLocation {
    ClientFilesLocation get ();
    void set (ClientFilesLocation value);
}
member ClientFilesLocation : ClientFilesLocation with get, set
Property Value
ClientFilesLocation
Remarks
Default = Internal


ClientSideObject Property

ClientSideObject Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► ClientSideObject
Keyoti RapidSpell Web .NET
The name of the Javascript object variable representing the spell checker on the client side.
Declaration Syntax
C# Visual Basic Visual C++ F#
public string ClientSideObject { get; }
Public ReadOnly Property ClientSideObject As String
    Get
public:
property String^ ClientSideObject {
    String^ get ();
}
member ClientSideObject : string with get
Property Value
String


ConsiderationRange Property

ConsiderationRange Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► ConsiderationRange
Keyoti RapidSpell Web .NET
The size factor for words to consider for suggestions, lower values are faster but consider less words for suggestions. Default is 80. If w <= 1 this method won't do anyting.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public int ConsiderationRange { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ConsiderationRange As Integer
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property int ConsiderationRange {
    int get ();
    void set (int value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ConsiderationRange : int with get, set
Property Value
Int32


CopyComputedStyleToOverlay Property

CopyComputedStyleToOverlay Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► CopyComputedStyleToOverlay
Keyoti RapidSpell Web .NET
Whether to copy the computed style of the target text box to the overlay DIV.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool CopyComputedStyleToOverlay { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property CopyComputedStyleToOverlay As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool CopyComputedStyleToOverlay {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member CopyComputedStyleToOverlay : bool with get, set
Property Value
Boolean


CssClassStaticOverlay Property

CssClassStaticOverlay Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► CssClassStaticOverlay
Keyoti RapidSpell Web .NET
The CSS class given to the static-mode overlay DIV element which holds spelling errors in front of the text box.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string CssClassStaticOverlay { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property CssClassStaticOverlay As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ CssClassStaticOverlay {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member CssClassStaticOverlay : string with get, set
Property Value
String
Remarks
Typical properties would are;
                OVERFLOW: scroll;
                border:1px solid #7F9DB9;
                padding: 2px;
                Z-INDEX: 900;

                Leave empty for default.


DictFile Property

DictFile Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► DictFile
Keyoti RapidSpell Web .NET
(Optional) main dictionary (.dict) file on the server.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string DictFile { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property DictFile As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ DictFile {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member DictFile : string with get, set
Property Value
String
Remarks
This should be an absolute path.


DoPreRender Method

DoPreRender Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► DoPreRender()()()()
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public void DoPreRender()
Public Sub DoPreRender
public:
void DoPreRender()
member DoPreRender : unit -> unit


DoubleClickSwitchesMode Property

DoubleClickSwitchesMode Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► DoubleClickSwitchesMode
Keyoti RapidSpell Web .NET
Whether to change a static text box from checking to editing on double-click
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool DoubleClickSwitchesMode { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property DoubleClickSwitchesMode As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool DoubleClickSwitchesMode {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member DoubleClickSwitchesMode : bool with get, set
Property Value
Boolean


EditMenuText Property

EditMenuText Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► EditMenuText
Keyoti RapidSpell Web .NET
The text used for the Edit... menu item.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string EditMenuText { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property EditMenuText As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ EditMenuText {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member EditMenuText : string with get, set
Property Value
String


Enabled Property

Enabled Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► Enabled
Keyoti RapidSpell Web .NET
Enabled state of the control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override bool Enabled { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property Enabled As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
virtual property bool Enabled {
    bool get () override;
    void set (bool value) override;
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
abstract Enabled : bool with get, set
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
override Enabled : bool with get, set
Property Value
Boolean


EnableTheming Property

EnableTheming Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► EnableTheming
Keyoti RapidSpell Web .NET
Theming is currently disabled. Support to be added in later versions.
Declaration Syntax
C# Visual Basic Visual C++ F#
public override bool EnableTheming { get; }
Public Overrides ReadOnly Property EnableTheming As Boolean
    Get
public:
virtual property bool EnableTheming {
    bool get () override;
}
abstract EnableTheming : bool with get
override EnableTheming : bool with get
Property Value
Boolean


EnableViewState Property

EnableViewState Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► EnableViewState
Keyoti RapidSpell Web .NET
Viewstate is always disabled.
Declaration Syntax
C# Visual Basic Visual C++ F#
public override bool EnableViewState { get; }
Public Overrides ReadOnly Property EnableViewState As Boolean
    Get
public:
virtual property bool EnableViewState {
    bool get () override;
}
abstract EnableViewState : bool with get
override EnableViewState : bool with get
Property Value
Boolean


EnterEditModeWhenNoMoreErrors Property

EnterEditModeWhenNoMoreErrors Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► EnterEditModeWhenNoMoreErrors
Keyoti RapidSpell Web .NET
Whether to automatically change a static text box from checking to editing when there are no more errors remaining.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool EnterEditModeWhenNoMoreErrors { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property EnterEditModeWhenNoMoreErrors As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool EnterEditModeWhenNoMoreErrors {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member EnterEditModeWhenNoMoreErrors : bool with get, set
Property Value
Boolean


EnterStaticSpellCheckListener Property

EnterStaticSpellCheckListener Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► EnterStaticSpellCheckListener
Keyoti RapidSpell Web .NET
The name of a JavaScript function (without brackets) that should be called when the text box is overlayed with the static spell check layer.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string EnterStaticSpellCheckListener { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property EnterStaticSpellCheckListener As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ EnterStaticSpellCheckListener {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member EnterStaticSpellCheckListener : string with get, set
Property Value
String
Remarks
This is optional, and of use client side. The function named here will be called when the pop up spell check is finished by the user (or the window was closed), it must not have any arguments.


ErrorMessage Property

ErrorMessage Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► ErrorMessage
Keyoti RapidSpell Web .NET
The error message to show the user when validation fails.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string ErrorMessage { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ErrorMessage As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
virtual property String^ ErrorMessage {
    String^ get () sealed;
    void set (String^ value) sealed;
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
abstract ErrorMessage : string with get, set
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
override ErrorMessage : string with get, set
Property Value
String


FinishedListener Property

FinishedListener Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► FinishedListener
Keyoti RapidSpell Web .NET
The name of a JavaScript function (without brackets) that should be called when spell checking is finished (optional).
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string FinishedListener { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property FinishedListener As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ FinishedListener {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member FinishedListener : string with get, set
Property Value
String
Remarks
This is optional, and of use if you require client side (or indirectly server side) notification that the spell check has finished. The function named here will be called when the pop up spell check is finished by the user (or the window was closed), it must not have any arguments.


GuiLanguage Property

GuiLanguage Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► GuiLanguage
Keyoti RapidSpell Web .NET
The UI language.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public LanguageType GuiLanguage { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property GuiLanguage As LanguageType
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property LanguageType GuiLanguage {
    LanguageType get ();
    void set (LanguageType value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member GuiLanguage : LanguageType with get, set
Property Value
LanguageType
Remarks
This is the language that all text on the UI should be in.


HideAddItemAlways Property

HideAddItemAlways Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► HideAddItemAlways
Keyoti RapidSpell Web .NET
Whether to always hide the Add menu item - regardless of whether a user dictionary is specified.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool HideAddItemAlways { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property HideAddItemAlways As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool HideAddItemAlways {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member HideAddItemAlways : bool with get, set
Property Value
Boolean


IgnoreAllMenuText Property

IgnoreAllMenuText Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► IgnoreAllMenuText
Keyoti RapidSpell Web .NET
The text used for the Ignore All menu item.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string IgnoreAllMenuText { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property IgnoreAllMenuText As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ IgnoreAllMenuText {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member IgnoreAllMenuText : string with get, set
Property Value
String


IgnoreCapitalizedWords Property

IgnoreCapitalizedWords Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► IgnoreCapitalizedWords
Keyoti RapidSpell Web .NET
Whether to ignore words with capital letters.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool IgnoreCapitalizedWords { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property IgnoreCapitalizedWords As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool IgnoreCapitalizedWords {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member IgnoreCapitalizedWords : bool with get, set
Property Value
Boolean


IgnoreIncorrectSentenceCapitalization Property

IgnoreIncorrectSentenceCapitalization Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► IgnoreIncorrectSentenceCapitalization
Keyoti RapidSpell Web .NET
Whether to ignore incorrect sentence capitalization.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool IgnoreIncorrectSentenceCapitalization { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property IgnoreIncorrectSentenceCapitalization As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool IgnoreIncorrectSentenceCapitalization {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member IgnoreIncorrectSentenceCapitalization : bool with get, set
Property Value
Boolean


IgnoreInEnglishLowerCaseI Property

IgnoreInEnglishLowerCaseI Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► IgnoreInEnglishLowerCaseI
Keyoti RapidSpell Web .NET
Whether to ignore lower case 'i' characters in text. Set to false to flag as errors.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool IgnoreInEnglishLowerCaseI { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property IgnoreInEnglishLowerCaseI As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool IgnoreInEnglishLowerCaseI {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member IgnoreInEnglishLowerCaseI : bool with get, set
Property Value
Boolean


IgnoreURLsAndEmailAddresses Property

IgnoreURLsAndEmailAddresses Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► IgnoreURLsAndEmailAddresses
Keyoti RapidSpell Web .NET
Whether to ignore URLs and email addresses (requires V2Parser=true)
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool IgnoreURLsAndEmailAddresses { get; set; }
Public Property IgnoreURLsAndEmailAddresses As Boolean
    Get
    Set
public:
property bool IgnoreURLsAndEmailAddresses {
    bool get ();
    void set (bool value);
}
member IgnoreURLsAndEmailAddresses : bool with get, set
Property Value
Boolean
Remarks
This will cause the following strings to be accepted as non-spelling errors;
"user@domain.com", "http://www.domain.com", "domain.co.uk" etc.


IgnoreWordsWithDigits Property

IgnoreWordsWithDigits Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► IgnoreWordsWithDigits
Keyoti RapidSpell Web .NET
Whether to ignore words with numbers in them (eg. A10 or 7-11).
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool IgnoreWordsWithDigits { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property IgnoreWordsWithDigits As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool IgnoreWordsWithDigits {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member IgnoreWordsWithDigits : bool with get, set
Property Value
Boolean


IgnoreXML Property

IgnoreXML Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► IgnoreXML
Keyoti RapidSpell Web .NET
Whether to ignore XML/HTML tags, false by default.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool IgnoreXML { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property IgnoreXML As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool IgnoreXML {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member IgnoreXML : bool with get, set
Property Value
Boolean
Remarks
This identifies XML tags as anything in between < and > characters, there for it will cause undesirable effects in text such as "the sign for less than is < and the sign for greater than is >". Of course in HTML that should have been written as "the sign for less than is &lt; and the sign for greater than is &gt;" anyway, which would be fine.


IncludeUserDictionaryInSuggestions Property

IncludeUserDictionaryInSuggestions Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► IncludeUserDictionaryInSuggestions
Keyoti RapidSpell Web .NET
Whether the user dictionary should be used in finding suggestions for misspelt words.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool IncludeUserDictionaryInSuggestions { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property IncludeUserDictionaryInSuggestions As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool IncludeUserDictionaryInSuggestions {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member IncludeUserDictionaryInSuggestions : bool with get, set
Property Value
Boolean


IsValid Property

IsValid Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► IsValid
Keyoti RapidSpell Web .NET
Whether the validator has identified an error or whether spell checking has already been forced by the validator.
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool IsValid { get; set; }
Public Property IsValid As Boolean
    Get
    Set
public:
virtual property bool IsValid {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract IsValid : bool with get, set
override IsValid : bool with get, set
Property Value
Boolean


LanguageParser Property

LanguageParser Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► LanguageParser
Keyoti RapidSpell Web .NET
The language parser to use, this should match the language of the main dictionary where possible.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public LanguageType LanguageParser { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property LanguageParser As LanguageType
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property LanguageType LanguageParser {
    LanguageType get ();
    void set (LanguageType value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member LanguageParser : LanguageType with get, set
Property Value
LanguageType
Remarks
This is used to give hints to the parser about how punctuation is used (eg. apostrophe is used differently in English and French).


LeaveStaticSpellCheckListener Property

LeaveStaticSpellCheckListener Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► LeaveStaticSpellCheckListener
Keyoti RapidSpell Web .NET
The name of a JavaScript function (without brackets) that should be called when the text box switches from the static spell check to edit mode.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string LeaveStaticSpellCheckListener { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property LeaveStaticSpellCheckListener As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ LeaveStaticSpellCheckListener {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member LeaveStaticSpellCheckListener : string with get, set
Property Value
String
Remarks
This is optional, and of use client side. The function named here will be called when the pop up spell check is finished by the user (or the window was closed), it must not have any arguments.


LookIntoHyphenatedText Property

LookIntoHyphenatedText Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► LookIntoHyphenatedText
Keyoti RapidSpell Web .NET
Whether to 'look into' text with hyphens (-), if the word has hyphens in it and LookIntoHyphenatedText is set true (default), the parts of the text around the hyphens will be checked individually.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool LookIntoHyphenatedText { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property LookIntoHyphenatedText As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool LookIntoHyphenatedText {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member LookIntoHyphenatedText : bool with get, set
Property Value
Boolean
Remarks
Eg. "socio-economic" will be checked as "socio" and "economic".


NoSpellErrorsText Property

NoSpellErrorsText Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► NoSpellErrorsText
Keyoti RapidSpell Web .NET
The text used for the no spelling errors message.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string NoSpellErrorsText { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property NoSpellErrorsText As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ NoSpellErrorsText {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member NoSpellErrorsText : string with get, set
Property Value
String


NoSuggestionsMenuText Property

NoSuggestionsMenuText Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► NoSuggestionsMenuText
Keyoti RapidSpell Web .NET
The text used for the No Suggestions menu item.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string NoSuggestionsMenuText { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property NoSuggestionsMenuText As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ NoSuggestionsMenuText {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member NoSuggestionsMenuText : string with get, set
Property Value
String


OnInit Method (e)

OnInit Method (e)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► OnInit(EventArgs)
Keyoti RapidSpell Web .NET
Registers required scripts.
Declaration Syntax
C# Visual Basic Visual C++ F#
protected override void OnInit(
    EventArgs e
)
Protected Overrides Sub OnInit (
    e As EventArgs
)
protected:
virtual void OnInit(
    EventArgs^ e
) override
abstract OnInit :
        e : EventArgs -> unit
override OnInit :
        e : EventArgs -> unit
Parameters
e (EventArgs)


OnPreRender Method (e)

OnPreRender Method (e)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► OnPreRender(EventArgs)
Keyoti RapidSpell Web .NET
Renders required client script
Declaration Syntax
C# Visual Basic Visual C++ F#
protected override void OnPreRender(
    EventArgs e
)
Protected Overrides Sub OnPreRender (
    e As EventArgs
)
protected:
virtual void OnPreRender(
    EventArgs^ e
) override
abstract OnPreRender :
        e : EventArgs -> unit
override OnPreRender :
        e : EventArgs -> unit
Parameters
e (EventArgs)


OnUnload Method (e)

OnUnload Method (e)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► OnUnload(EventArgs)
Keyoti RapidSpell Web .NET
On p
Declaration Syntax
C# Visual Basic Visual C++ F#
protected override void OnUnload(
    EventArgs e
)
Protected Overrides Sub OnUnload (
    e As EventArgs
)
protected:
virtual void OnUnload(
    EventArgs^ e
) override
abstract OnUnload :
        e : EventArgs -> unit
override OnUnload :
        e : EventArgs -> unit
Parameters
e (EventArgs)


OnValidatorNeedsText Method (e)

OnValidatorNeedsText Method (e)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► OnValidatorNeedsText(ValidatorNeedsTextEventArgs)
Keyoti RapidSpell Web .NET
Raises the ValidatorNeedsText event, allowing e.TextBoxText to be set with the text to validate.
Declaration Syntax
C# Visual Basic Visual C++ F#
protected virtual void OnValidatorNeedsText(
    ValidatorNeedsTextEventArgs e
)
Protected Overridable Sub OnValidatorNeedsText (
    e As ValidatorNeedsTextEventArgs
)
protected:
virtual void OnValidatorNeedsText(
    ValidatorNeedsTextEventArgs^ e
)
abstract OnValidatorNeedsText :
        e : ValidatorNeedsTextEventArgs -> unit
override OnValidatorNeedsText :
        e : ValidatorNeedsTextEventArgs -> unit
Parameters
e (ValidatorNeedsTextEventArgs)


RapidSpellWInlineHelperPage Property

RapidSpellWInlineHelperPage Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► RapidSpellWInlineHelperPage
Keyoti RapidSpell Web .NET
The URL of the page holding the RapidSpellWInlineHelper control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string RapidSpellWInlineHelperPage { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property RapidSpellWInlineHelperPage As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ RapidSpellWInlineHelperPage {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member RapidSpellWInlineHelperPage : string with get, set
Property Value
String


RemoveDuplicateMenuText Property

RemoveDuplicateMenuText Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► RemoveDuplicateMenuText
Keyoti RapidSpell Web .NET
The text used for the Remove Duplicate Words menu item.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string RemoveDuplicateMenuText { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property RemoveDuplicateMenuText As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ RemoveDuplicateMenuText {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member RemoveDuplicateMenuText : string with get, set
Property Value
String


RenderContents Method (output)

RenderContents Method (output)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► RenderContents(HtmlTextWriter)
Keyoti RapidSpell Web .NET
Render this control to the output parameter specified.
Declaration Syntax
C# Visual Basic Visual C++ F#
protected override void RenderContents(
    HtmlTextWriter output
)
Protected Overrides Sub RenderContents (
    output As HtmlTextWriter
)
protected:
virtual void RenderContents(
    HtmlTextWriter^ output
) override
abstract RenderContents :
        output : HtmlTextWriter -> unit
override RenderContents :
        output : HtmlTextWriter -> unit
Parameters
output (HtmlTextWriter)
The HTML writer to write out to


RenderEndTag Method (writer)

RenderEndTag Method (writer)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► RenderEndTag(HtmlTextWriter)
Keyoti RapidSpell Web .NET
Renders the end of this tag
Declaration Syntax
C# Visual Basic Visual C++ F#
public override void RenderEndTag(
    HtmlTextWriter writer
)
Public Overrides Sub RenderEndTag (
    writer As HtmlTextWriter
)
public:
virtual void RenderEndTag(
    HtmlTextWriter^ writer
) override
abstract RenderEndTag :
        writer : HtmlTextWriter -> unit
override RenderEndTag :
        writer : HtmlTextWriter -> unit
Parameters
writer (HtmlTextWriter)


RenderForDesign Method (output)

RenderForDesign Method (output)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► RenderForDesign(HtmlTextWriter)
Keyoti RapidSpell Web .NET
Renders this control for the design surface.
Declaration Syntax
C# Visual Basic Visual C++ F#
public void RenderForDesign(
    HtmlTextWriter output
)
Public Sub RenderForDesign (
    output As HtmlTextWriter
)
public:
void RenderForDesign(
    HtmlTextWriter^ output
)
member RenderForDesign :
        output : HtmlTextWriter -> unit
Parameters
output (HtmlTextWriter)


ResponseTimeout Property

ResponseTimeout Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► ResponseTimeout
Keyoti RapidSpell Web .NET
Number of seconds to pass before a message is shown to the user reporting a time-out.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public int ResponseTimeout { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ResponseTimeout As Integer
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property int ResponseTimeout {
    int get ();
    void set (int value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ResponseTimeout : int with get, set
Property Value
Int32


ResponseTimeoutMessage Property

ResponseTimeoutMessage Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► ResponseTimeoutMessage
Keyoti RapidSpell Web .NET
The message shown to the user in the event that the spell check request times-out.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string ResponseTimeoutMessage { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ResponseTimeoutMessage As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ ResponseTimeoutMessage {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ResponseTimeoutMessage : string with get, set
Property Value
String


RightClickForMenu Property

RightClickForMenu Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► RightClickForMenu
Keyoti RapidSpell Web .NET
Whether to show the spelling context menu on right click instead of left click.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool RightClickForMenu { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property RightClickForMenu As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool RightClickForMenu {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member RightClickForMenu : bool with get, set
Property Value
Boolean


RSMultipleID Property

RSMultipleID Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► RSMultipleID
Keyoti RapidSpell Web .NET
The ID of the RapidSpellWebMultiple control managing multi text box checking.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string RSMultipleID { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property RSMultipleID As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ RSMultipleID {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member RSMultipleID : string with get, set
Property Value
String
Remarks
Setting this prevents certain properties that aren't relevant to multi mode checking from being set.


RunSpellCheckFunctionJS Property

RunSpellCheckFunctionJS Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► RunSpellCheckFunctionJS
Keyoti RapidSpell Web .NET
The Javascript function that should be registered on the page in order to run the spell check when the page loads.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual string RunSpellCheckFunctionJS { get; }
Public Overridable ReadOnly Property RunSpellCheckFunctionJS As String
    Get
public:
virtual property String^ RunSpellCheckFunctionJS {
    String^ get ();
}
abstract RunSpellCheckFunctionJS : string with get
override RunSpellCheckFunctionJS : string with get
Property Value
String


SeparateHyphenWords Property

SeparateHyphenWords Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► SeparateHyphenWords
Keyoti RapidSpell Web .NET
Whether to treat hyphenated (-) words as separate words, default is false.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool SeparateHyphenWords { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property SeparateHyphenWords As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool SeparateHyphenWords {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member SeparateHyphenWords : bool with get, set
Property Value
Boolean
Remarks
For eg. if this is true text like "cheap-deals" will be treated as two words "cheap" and "deals", otherwise this will be treated as one word "cheap-deals".


ShowAddItemAlways Property

ShowAddItemAlways Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► ShowAddItemAlways
Keyoti RapidSpell Web .NET
Whether to always show the Add menu item - regardless of whether a user dictionary is specified.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool ShowAddItemAlways { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ShowAddItemAlways As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool ShowAddItemAlways {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ShowAddItemAlways : bool with get, set
Property Value
Boolean
Remarks
This needs to be set true if RapidSpellWInlineHelper has a UserDictionary class override.


ShowButton Property

ShowButton Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► ShowButton
Keyoti RapidSpell Web .NET
Whether to show the launcher button (set to false to hide button/images). The client-side code will be written regardless.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool ShowButton { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ShowButton As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool ShowButton {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ShowButton : bool with get, set
Property Value
Boolean


ShowChangeAllItem Property

ShowChangeAllItem Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► ShowChangeAllItem
Keyoti RapidSpell Web .NET
Whether to show the Change All sub menu item.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool ShowChangeAllItem { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ShowChangeAllItem As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool ShowChangeAllItem {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ShowChangeAllItem : bool with get, set
Property Value
Boolean


ShowIgnoreAllMenuItem Property

ShowIgnoreAllMenuItem Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► ShowIgnoreAllMenuItem
Keyoti RapidSpell Web .NET
Whether to show the Ignore All menu item.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool ShowIgnoreAllMenuItem { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ShowIgnoreAllMenuItem As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool ShowIgnoreAllMenuItem {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ShowIgnoreAllMenuItem : bool with get, set
Property Value
Boolean


ShowNoErrorsMessage Property

ShowNoErrorsMessage Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► ShowNoErrorsMessage
Keyoti RapidSpell Web .NET
Whether to show the launcher button (set to false to hide button/images). The client-side code will be written regardless.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool ShowNoErrorsMessage { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ShowNoErrorsMessage As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool ShowNoErrorsMessage {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ShowNoErrorsMessage : bool with get, set
Property Value
Boolean


SSLFriendlyPage Property

SSLFriendlyPage Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► SSLFriendlyPage
Keyoti RapidSpell Web .NET
The URL of the file to set in Iframes, this avoids SSL warnings.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string SSLFriendlyPage { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property SSLFriendlyPage As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ SSLFriendlyPage {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member SSLFriendlyPage : string with get, set
Property Value
String
Remarks
Defaults to blank.html, which can be obtained from the RapidSpellDemo folder in the distribution zip.


SuggestionsMethod Property

SuggestionsMethod Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► SuggestionsMethod
Keyoti RapidSpell Web .NET
Suggestions method to use. Either PHONETIC_SUGGESTIONS or HASHING_SUGGESTIONS
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string SuggestionsMethod { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property SuggestionsMethod As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ SuggestionsMethod {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member SuggestionsMethod : string with get, set
Property Value
String


SuggestSplitWords Property

SuggestSplitWords Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► SuggestSplitWords
Keyoti RapidSpell Web .NET
Whether to look for connected words in suggestions.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool SuggestSplitWords { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property SuggestSplitWords As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool SuggestSplitWords {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member SuggestSplitWords : bool with get, set
Property Value
Boolean
Remarks
if this=true then suggestions may include joined words.

Eg; suggestions for "myhouse" will include "my house"


SuppressWarnings Property

SuppressWarnings Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► SuppressWarnings
Keyoti RapidSpell Web .NET
Whether to suppress any warning messages (eg. that textbox couldn't be found).
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool SuppressWarnings { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property SuppressWarnings As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool SuppressWarnings {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member SuppressWarnings : bool with get, set
Property Value
Boolean


TabIndex Property

TabIndex Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► TabIndex
Keyoti RapidSpell Web .NET
The tab order of the control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override short TabIndex { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property TabIndex As Short
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
virtual property short TabIndex {
    short get () override;
    void set (short value) override;
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
abstract TabIndex : int16 with get, set
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
override TabIndex : int16 with get, set
Property Value
Int16


TextComponentID Property

TextComponentID Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► TextComponentID
Keyoti RapidSpell Web .NET
The server/client (automatically detected) ID of the text box to work with.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string TextComponentID { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property TextComponentID As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ TextComponentID {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member TextComponentID : string with get, set
Property Value
String
Remarks

There are 2 ways to set this property;

1. Control ID - the simplest way is to set this property to the server-side ID of the control to be spell checked. This comes with a caveat; because server-side Control IDs need only be unique with-in a ‘naming container’ (eg. page, DataList, DataGrid) and because the Control must be found via the FindControl method (which searches the naming container that the RapidSpellWebLauncher control is in) it is only possible to use the Control ID to specify the text box if the text box Control and the RapidSpellWebLauncher are in the same naming container.

2. Control ClientID - setting the TextComponentName to the ClientID of the text control is a good way to firmly identify the text Control to be spell checked. To do this it is usually best to set the TextComponentName property in code-behind or with a data-bind using the ClientID of the text Control.

eg.
rapidSpellWebLauncher.TextComponentName = textBox1.ClientID

This method can also be used when referring to traditional Html elements (such as <textarea> or <input type=text>), in this case the ID attribute of the tag is used to identify the element.

eg.
<textarea ID=”textbox1”>This is my text box</textarea>
.....
rapidSpellWebLauncher.TextComponentName = “textbox1”

The only warning with this method is to remember (as per good asp.net practice) that the ClientID property of a control is not properly defined until run-time (when the page loads in the browser), therefore the TextComponentName property should be set at run-time, also.

This method can still be used with RapidSpell Web, however in more complex cases (unusual Control IDs, DataGrids etc) it can be hardest to use.

Note: if the “Custom” Javascript interface is being used for a text box interface then the tbElementName argument in RSCustomInterface(tbElementName) will be set according to the method used to identify the text box, as detailed below for each method;

1. Control ID - tbElementName will be set to the ClientID of the Control given by TextComponentName.
2. Control ClientID - tbElementName will be set to TextComponentName.
3. Javascript formName.textBoxName - tbElementName will be set to TextComponentName.


TextComponentInterface Property

TextComponentInterface Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► TextComponentInterface
Keyoti RapidSpell Web .NET
The text box interface to be used.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public TextComponentInterfaceType TextComponentInterface { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property TextComponentInterface As TextComponentInterfaceType
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property TextComponentInterfaceType TextComponentInterface {
    TextComponentInterfaceType get ();
    void set (TextComponentInterfaceType value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member TextComponentInterface : TextComponentInterfaceType with get, set
Property Value
TextComponentInterfaceType
Remarks
Use 'Automatic' for plain and most rich text boxes. Use 'Standard' for regular HTML text boxes (input type='text' and textarea). Use 'RichTextBox' for RichTextBox.com text boxes. Use 'Custom' to define your own interface.


UserDictionaryFile Property

UserDictionaryFile Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► UserDictionaryFile
Keyoti RapidSpell Web .NET
The user dictionary file on the server for the user.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string UserDictionaryFile { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property UserDictionaryFile As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ UserDictionaryFile {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member UserDictionaryFile : string with get, set
Property Value
String
Remarks
This should be an absolute path.


UseXMLHTTPWhenAvailable Property

UseXMLHTTPWhenAvailable Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► UseXMLHTTPWhenAvailable
Keyoti RapidSpell Web .NET
Whether to use XMLHttpRequest (when it's available) to communicate with the server - typically this is best set true.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual bool UseXMLHTTPWhenAvailable { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property UseXMLHTTPWhenAvailable As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
virtual property bool UseXMLHTTPWhenAvailable {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
abstract UseXMLHTTPWhenAvailable : bool with get, set
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
override UseXMLHTTPWhenAvailable : bool with get, set
Property Value
Boolean


V2Parser Property

V2Parser Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► V2Parser
Keyoti RapidSpell Web .NET
Whether to use parser version 2 - Set to false for backwards (pre v2.8) compatibility. This causes approx. 10-20% speed reduction for spelling error identification.
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool V2Parser { get; set; }
Public Property V2Parser As Boolean
    Get
    Set
public:
property bool V2Parser {
    bool get ();
    void set (bool value);
}
member V2Parser : bool with get, set
Property Value
Boolean


Validate Method

Validate Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► Validate()()()()
Keyoti RapidSpell Web .NET
If Validator==true, this checks the text box for errors, and updates IsValid - note if there are errors but the spell check has already been forced this will set IsValid to true.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void Validate()
Public Overridable Sub Validate
public:
virtual void Validate()
abstract Validate : unit -> unit
override Validate : unit -> unit


Validator Property

Validator Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► Validator
Keyoti RapidSpell Web .NET
Whether to work as a validator.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool Validator { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Validator As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool Validator {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member Validator : bool with get, set
Property Value
Boolean
Remarks
Simply set the Validator property true, and use as any other ASP.NET validator. When validation is performed on the server, if there are errors and the spell check hasn't already been performed then the validation warning will be shown. The user can leave spelling 'errors' in the text box (because some words, such as names, are not known by the spell checker, but are valid), but they must at least run the spell check if there are errors. Set the AutoLaunchWhenTextInvalid property to true to have the spell check run automatically after the page posts back - unlike the RapidSpellWebLauncher example, there are no popup blocker concerns with this behavior.


ValidatorNeedsText Event

ValidatorNeedsText Event
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► ValidatorNeedsText
Keyoti RapidSpell Web .NET
Fired when the validator is attempting to access the text of the textbox specified by TextComponentID.
Declaration Syntax
C# Visual Basic Visual C++ F#
public event ValidatorNeedsTextEventHandler ValidatorNeedsText
Public Event ValidatorNeedsText As ValidatorNeedsTextEventHandler
public:
 event ValidatorNeedsTextEventHandler^ ValidatorNeedsText {
    void add (ValidatorNeedsTextEventHandler^ value);
    void remove (ValidatorNeedsTextEventHandler^ value);
}
member ValidatorNeedsText : IEvent<ValidatorNeedsTextEventHandler,
    ValidatorNeedsTextEventArgs>
Value
ValidatorNeedsTextEventHandler
Remarks
Handle this event to supply text to the validator. This is necessary usually with 3rd party controls that RapidSpellWInline does not know how to read the text of.


WarnDuplicates Property

WarnDuplicates Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► WarnDuplicates
Keyoti RapidSpell Web .NET
Whether to show duplicate words as errors (eg. "this is is an error").
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool WarnDuplicates { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property WarnDuplicates As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool WarnDuplicates {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member WarnDuplicates : bool with get, set
Property Value
Boolean


RapidSpellWInlineHelper Class

RapidSpellWInlineHelper Class
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineHelper
Keyoti RapidSpell Web .NET
Control that must sit alone on a form, actually performs the spell check on the server for the RapidSpellWInline control.
Declaration Syntax
C# Visual Basic Visual C++ F#
public class RapidSpellWInlineHelper : WebControl
Public Class RapidSpellWInlineHelper
    Inherits WebControl
public ref class RapidSpellWInlineHelper : public WebControl
type RapidSpellWInlineHelper =
    class
        inherit WebControl
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RapidSpellWInlineHelper()()()() |
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriterTag. This method is used primarily by control developers. (Inherited from WebControl.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BeginRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BlockWordAdding | Whether to block add word requests.
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | CacheDictionary | Whether to cache the main dictionary, this will result in large performance gains. WARNING, do not do this if using more than one dictionary across the application.
 | CheckerEngine | The ICheckerEngine object to be used to check the text.
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearCachedClientID()()()() | (Inherited from Control.)
 | ClearChildControlState()()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClearEffectiveClientIDMode()()()() | (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDMode | (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from WebControl.)
 | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataItemContainer | (Inherited from Control.)
 | DataKeysContainer | (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Theming is currently disabled. Support to be added in later versions. (Overrides WebControl.EnableTheming.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EndRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | EnsureChildControls()()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
 | Focus()()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | GetDesignModeState()()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRouteUrl(Object) | (Inherited from Control.)
 | GetRouteUrl(String, Object) | (Inherited from Control.)
 | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
 | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetUniqueIDRelativeTo(Control) | (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | LicenseKey | Whether to show the popup dialog at the end of the spell check.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Render this control to the output parameter specified. (Overrides WebControl.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderingCompatibility | (Inherited from Control.)
 | ResolveAdapter()()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()()() | Saves any state that was modified after the TrackViewState()()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetDictFilePath(String) | Sets the dict file, file path to use for the main dictionary - overrides any value coming from the RapidSpellWInline control.
 | SetGUILanguage(LanguageType) | Sets the GUI language - overrides any value coming from the RapidSpellWInline control.
 | SetLanguageParser(LanguageType) | Sets the language parser - overrides any value coming from the RapidSpellWInline control.
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetTraceData(Object, Object) | (Inherited from Control.)
 | SetTraceData(Object, Object, Object) | (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | SuggestionMenuActivation | How the user will activate the suggestions menu.
 | SupportsDisabledAttribute | (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HtmlTextWriterTag value that corresponds to this Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TrackViewState()()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | UserDictionary | UserDictionary object.
 | ValidateRequestMode | (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateMode | (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | RapidSpellWInlineHelper


RapidSpellWInlineHelper Constructor

RapidSpellWInlineHelper Constructor
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineHelper ► RapidSpellWInlineHelper()()()()
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public RapidSpellWInlineHelper()
Public Sub New
public:
RapidSpellWInlineHelper()
new : unit -> RapidSpellWInlineHelper


BlockWordAdding Property

BlockWordAdding Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineHelper ► BlockWordAdding
Keyoti RapidSpell Web .NET
Whether to block add word requests.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool BlockWordAdding { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property BlockWordAdding As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool BlockWordAdding {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member BlockWordAdding : bool with get, set
Property Value
Boolean


CacheDictionary Property

CacheDictionary Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineHelper ► CacheDictionary
Keyoti RapidSpell Web .NET
Whether to cache the main dictionary, this will result in large performance gains. WARNING, do not do this if using more than one dictionary across the application.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool CacheDictionary { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property CacheDictionary As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool CacheDictionary {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member CacheDictionary : bool with get, set
Property Value
Boolean
Remarks
When this is set true the main dictionary instance is shared amongst all other instances of this control where this property is set true, therefore conflicts will occur if they have different dictionaries.


CheckerEngine Property

CheckerEngine Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineHelper ► CheckerEngine
Keyoti RapidSpell Web .NET
The ICheckerEngine object to be used to check the text.
Declaration Syntax
C# Visual Basic Visual C++ F#
public ICheckerEngine CheckerEngine { get; set; }
Public Property CheckerEngine As ICheckerEngine
    Get
    Set
public:
property ICheckerEngine^ CheckerEngine {
    ICheckerEngine^ get ();
    void set (ICheckerEngine^ value);
}
member CheckerEngine : ICheckerEngine with get, set
Property Value
ICheckerEngine
Remarks
You should implement ICheckerEngine in your own class if you wish to customize parsing.


EnableTheming Property

EnableTheming Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineHelper ► EnableTheming
Keyoti RapidSpell Web .NET
Theming is currently disabled. Support to be added in later versions.
Declaration Syntax
C# Visual Basic Visual C++ F#
public override bool EnableTheming { get; }
Public Overrides ReadOnly Property EnableTheming As Boolean
    Get
public:
virtual property bool EnableTheming {
    bool get () override;
}
abstract EnableTheming : bool with get
override EnableTheming : bool with get
Property Value
Boolean


LicenseKey Property

LicenseKey Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineHelper ► LicenseKey
Keyoti RapidSpell Web .NET
Whether to show the popup dialog at the end of the spell check.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string LicenseKey { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property LicenseKey As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ LicenseKey {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member LicenseKey : string with get, set
Property Value
String


Render Method (output)

Render Method (output)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineHelper ► Render(HtmlTextWriter)
Keyoti RapidSpell Web .NET
Render this control to the output parameter specified.
Declaration Syntax
C# Visual Basic Visual C++ F#
protected override void Render(
    HtmlTextWriter output
)
Protected Overrides Sub Render (
    output As HtmlTextWriter
)
protected:
virtual void Render(
    HtmlTextWriter^ output
) override
abstract Render :
        output : HtmlTextWriter -> unit
override Render :
        output : HtmlTextWriter -> unit
Parameters
output (HtmlTextWriter)
The HTML writer to write out to


SetDictFilePath Method (dictFilePath)

SetDictFilePath Method (dictFilePath)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineHelper ► SetDictFilePath(String)
Keyoti RapidSpell Web .NET
Sets the dict file, file path to use for the main dictionary - overrides any value coming from the RapidSpellWInline control.
Declaration Syntax
C# Visual Basic Visual C++ F#
public void SetDictFilePath(
    string dictFilePath
)
Public Sub SetDictFilePath (
    dictFilePath As String
)
public:
void SetDictFilePath(
    String^ dictFilePath
)
member SetDictFilePath :
        dictFilePath : string -> unit
Parameters
dictFilePath (String)


SetGUILanguage Method (l)

SetGUILanguage Method (l)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineHelper ► SetGUILanguage(LanguageType)
Keyoti RapidSpell Web .NET
Sets the GUI language - overrides any value coming from the RapidSpellWInline control.
Declaration Syntax
C# Visual Basic Visual C++ F#
public void SetGUILanguage(
    LanguageType l
)
Public Sub SetGUILanguage (
    l As LanguageType
)
public:
void SetGUILanguage(
    LanguageType l
)
member SetGUILanguage :
        l : LanguageType -> unit
Parameters
l (LanguageType)


SetLanguageParser Method (l)

SetLanguageParser Method (l)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineHelper ► SetLanguageParser(LanguageType)
Keyoti RapidSpell Web .NET
Sets the language parser - overrides any value coming from the RapidSpellWInline control.
Declaration Syntax
C# Visual Basic Visual C++ F#
public void SetLanguageParser(
    LanguageType l
)
Public Sub SetLanguageParser (
    l As LanguageType
)
public:
void SetLanguageParser(
    LanguageType l
)
member SetLanguageParser :
        l : LanguageType -> unit
Parameters
l (LanguageType)


SuggestionMenuActivation Property

SuggestionMenuActivation Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineHelper ► SuggestionMenuActivation
Keyoti RapidSpell Web .NET
How the user will activate the suggestions menu.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public SuggestionMenuActivationType SuggestionMenuActivation { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property SuggestionMenuActivation As SuggestionMenuActivationType
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property SuggestionMenuActivationType SuggestionMenuActivation {
    SuggestionMenuActivationType get ();
    void set (SuggestionMenuActivationType value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member SuggestionMenuActivation : SuggestionMenuActivationType with get, set
Property Value
SuggestionMenuActivationType


UserDictionary Property

UserDictionary Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineHelper ► UserDictionary
Keyoti RapidSpell Web .NET
UserDictionary object.
Declaration Syntax
C# Visual Basic Visual C++ F#
public UserDictionary UserDictionary { get; set; }
Public Property UserDictionary As UserDictionary
    Get
    Set
public:
property UserDictionary^ UserDictionary {
    UserDictionary^ get ();
    void set (UserDictionary^ value);
}
member UserDictionary : UserDictionary with get, set
Property Value
UserDictionary


RapidSpellWInlineTextBox Class

RapidSpellWInlineTextBox Class
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineTextBox
Keyoti RapidSpell Web .NET
TextBox control with ability to shows spelling errors as underlines while in 'edit mode'.
Declaration Syntax
C# Visual Basic Visual C++ F#
public class RapidSpellWInlineTextBox : TextBox
Public Class RapidSpellWInlineTextBox
    Inherits TextBox
public ref class RapidSpellWInlineTextBox : public TextBox
type RapidSpellWInlineTextBox =
    class
        inherit TextBox
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RapidSpellWInlineTextBox()()()() | Creates a new instance.
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriter instance. (Inherited from TextBox.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Overridden to allow only literal controls to be added as the Text property. (Inherited from TextBox.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | AutoCompleteType | Gets or sets a value that indicates the AutoComplete behavior of the TextBox control (Inherited from TextBox.)
 | AutoPostBack | Gets or sets a value that indicates whether an automatic postback to the server occurs when the TextBox control loses focus. (Inherited from TextBox.)
 | BackColor | Gets or sets the background color of the Web server control. (Inherited from WebControl.)
 | BeginRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web control. (Inherited from WebControl.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from WebControl.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from WebControl.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | CausesValidation | Gets or sets a value indicating whether validation is performed when the TextBox control is set to validate when a postback occurs. (Inherited from TextBox.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearCachedClientID()()()() | (Inherited from Control.)
 | ClearChildControlState()()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClearEffectiveClientIDMode()()()() | (Inherited from Control.)
 | ClientFilesFolder | Where the client files are found, must be an absolute path to the directory containing the RapidSpell client files.
 | ClientFilesLocation | Whether to use the internal client files, or external files (for customization).
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDMode | (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | ClientSideObject | The name of the Javascript object variable representing the spell checker on the client side.
 | colorToHTMLCode(Color) | Returns the Html hex code for a color.
 | Columns | Gets or sets the display width of the text box in characters. (Inherited from TextBox.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | CSS class name applied to the Control (Overrides WebControl.CssClass.)
 | CssSheetURL | The URL of a CSS style-sheet that should be applied to the inside of the text box.
 | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataItemContainer | (Inherited from Control.)
 | DataKeysContainer | (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EndRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | EnsureChildControls()()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
 | Focus()()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Inherited from WebControl.)
 | ForceDownLevelOnly | Whether to force the control to work as if the client browser is 'down-level'.
 | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from WebControl.)
 | Frameborder | The frameborder to use, use '1' for older bevel style. (0)
 | GetDesignModeState()()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRouteUrl(Object) | (Inherited from Control.)
 | GetRouteUrl(String, Object) | (Inherited from Control.)
 | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
 | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetUniqueIDRelativeTo(Control) | (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Inherited from WebControl.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsDownLevel | Whether the control is running for a 'down level' (old) browser and therefore reduced functionality.
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
 | LoadPostData(String, NameValueCollection) | Processes the postback data for the TextBox control. (Inherited from TextBox.)
 | LoadViewState(Object) | Restores view-state information from a previous request that was saved with the SaveViewState()()()() method. (Inherited from WebControl.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MaxLength | Gets or sets the maximum number of characters allowed in the text box. (Inherited from TextBox.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Called when control Init (Overrides Control.OnInit(EventArgs).)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Called during the pre-render page cycle. (Overrides TextBox.OnPreRender(EventArgs).)
 | OnTextChanged(EventArgs) | Raises the TextChanged event. This allows you to handle the event directly. (Inherited from TextBox.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()()() | Invokes the OnTextChanged(EventArgs) method when the posted data for the TextBox control has changed. (Inherited from TextBox.)
 | ReadOnly | Gets or sets a value indicating whether the contents of the TextBox control can be changed. (Inherited from TextBox.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control (Overrides TextBox.Render(HtmlTextWriter).)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderingCompatibility | (Inherited from Control.)
 | ResolveAdapter()()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | Rows | Gets or sets the number of rows displayed in a multiline text box. (Inherited from TextBox.)
 | SaveControlState()()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()()() | Saves the changes to the text box view state since the time the page was posted back to the server. (Inherited from TextBox.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetTraceData(Object, Object) | (Inherited from Control.)
 | SetTraceData(Object, Object, Object) | (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | SupportsDisabledAttribute | (Inherited from WebControl.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HTML tag for the text box control. This property is protected. (Inherited from TextBox.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Text | Gets or sets the text content of the TextBox control. (Inherited from TextBox.)
 | TextChanged | Occurs when the content of the text box changes between posts to the server. (Inherited from TextBox.)
 | TextMode | Gets or sets the behavior mode (single-line, multiline, or password) of the TextBox control. (Inherited from TextBox.)
 | TextXHTML | The Text in the text box, as XHTML (HTML).
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TrackViewState()()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ValidateRequestMode | (Inherited from Control.)
 | ValidationGroup | Gets or sets the group of controls for which the TextBox control causes validation when it posts back to the server. (Inherited from TextBox.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateMode | (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Inherited from WebControl.)
 | Wrap | Gets or sets a value indicating whether the text content wraps within a multiline text box. (Inherited from TextBox.)
Remarks
Renders as standard ASP.NET TextBox when output to browsers other than IE 5.5+, Mozilla 1.4+ (FF, NS7.1+)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | TextBox
 |  |  |  | RapidSpellWInlineTextBox


RapidSpellWInlineTextBox Constructor

RapidSpellWInlineTextBox Constructor
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineTextBox ► RapidSpellWInlineTextBox()()()()
Keyoti RapidSpell Web .NET
Creates a new instance.
Declaration Syntax
C# Visual Basic Visual C++ F#
public RapidSpellWInlineTextBox()
Public Sub New
public:
RapidSpellWInlineTextBox()
new : unit -> RapidSpellWInlineTextBox


ClientFilesFolder Property

ClientFilesFolder Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineTextBox ► ClientFilesFolder
Keyoti RapidSpell Web .NET
Where the client files are found, must be an absolute path to the directory containing the RapidSpell client files.
Declaration Syntax
C# Visual Basic Visual C++ F#
public string ClientFilesFolder { get; set; }
Public Property ClientFilesFolder As String
    Get
    Set
public:
property String^ ClientFilesFolder {
    String^ get ();
    void set (String^ value);
}
member ClientFilesFolder : string with get, set
Property Value
String
Remarks
Default = /Keyoti_RapidSpell_Web_Common/


ClientFilesLocation Property

ClientFilesLocation Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineTextBox ► ClientFilesLocation
Keyoti RapidSpell Web .NET
Whether to use the internal client files, or external files (for customization).
Declaration Syntax
C# Visual Basic Visual C++ F#
public ClientFilesLocation ClientFilesLocation { get; set; }
Public Property ClientFilesLocation As ClientFilesLocation
    Get
    Set
public:
property ClientFilesLocation ClientFilesLocation {
    ClientFilesLocation get ();
    void set (ClientFilesLocation value);
}
member ClientFilesLocation : ClientFilesLocation with get, set
Property Value
ClientFilesLocation
Remarks
Default = Internal


ClientSideObject Property

ClientSideObject Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineTextBox ► ClientSideObject
Keyoti RapidSpell Web .NET
The name of the Javascript object variable representing the spell checker on the client side.
Declaration Syntax
C# Visual Basic Visual C++ F#
public string ClientSideObject { get; }
Public ReadOnly Property ClientSideObject As String
    Get
public:
property String^ ClientSideObject {
    String^ get ();
}
member ClientSideObject : string with get
Property Value
String


colorToHTMLCode Method (c)

colorToHTMLCode Method (c)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineTextBox ► colorToHTMLCode(Color)
Keyoti RapidSpell Web .NET
Returns the Html hex code for a color.
Declaration Syntax
C# Visual Basic Visual C++ F#
public static string colorToHTMLCode(
    Color c
)
Public Shared Function colorToHTMLCode (
    c As Color
) As String
public:
static String^ colorToHTMLCode(
    Color c
)
static member colorToHTMLCode :
        c : Color -> string
Parameters
c (Color)
Return Value
String


CssClass Property

CssClass Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineTextBox ► CssClass
Keyoti RapidSpell Web .NET
CSS class name applied to the Control
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override string CssClass { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property CssClass As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
virtual property String^ CssClass {
    String^ get () override;
    void set (String^ value) override;
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
abstract CssClass : string with get, set
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
override CssClass : string with get, set
Property Value
String
Remarks
CSSSheetURL must be set inorder for this to have effect inside the control.


CssSheetURL Property

CssSheetURL Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineTextBox ► CssSheetURL
Keyoti RapidSpell Web .NET
The URL of a CSS style-sheet that should be applied to the inside of the text box.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual string CssSheetURL { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property CssSheetURL As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
virtual property String^ CssSheetURL {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
abstract CssSheetURL : string with get, set
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
override CssSheetURL : string with get, set
Property Value
String
Remarks
Only the style of the inside of the text box is affected by this style-sheet. Properties such as border should be modified by sheets applicable to the main page.


ForceDownLevelOnly Property

ForceDownLevelOnly Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineTextBox ► ForceDownLevelOnly
Keyoti RapidSpell Web .NET
Whether to force the control to work as if the client browser is 'down-level'.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public virtual bool ForceDownLevelOnly { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overridable Property ForceDownLevelOnly As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
virtual property bool ForceDownLevelOnly {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
abstract ForceDownLevelOnly : bool with get, set
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
override ForceDownLevelOnly : bool with get, set
Property Value
Boolean
Remarks
This is useful for testing web-site behaviour with all browser types.


Frameborder Property

Frameborder Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineTextBox ► Frameborder
Keyoti RapidSpell Web .NET
The frameborder to use, use '1' for older bevel style. (0)
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public int Frameborder { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Frameborder As Integer
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property int Frameborder {
    int get ();
    void set (int value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member Frameborder : int with get, set
Property Value
Int32


IsDownLevel Property

IsDownLevel Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineTextBox ► IsDownLevel
Keyoti RapidSpell Web .NET
Whether the control is running for a 'down level' (old) browser and therefore reduced functionality.
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool IsDownLevel { get; }
Public ReadOnly Property IsDownLevel As Boolean
    Get
public:
property bool IsDownLevel {
    bool get ();
}
member IsDownLevel : bool with get
Property Value
Boolean
Remarks
This returns true for older browsers and/or when ForceDownLevelOnly is set true, and/or TextMode==Pass-word.


OnInit Method (e)

OnInit Method (e)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineTextBox ► OnInit(EventArgs)
Keyoti RapidSpell Web .NET
Called when control Init
Declaration Syntax
C# Visual Basic Visual C++ F#
protected override void OnInit(
    EventArgs e
)
Protected Overrides Sub OnInit (
    e As EventArgs
)
protected:
virtual void OnInit(
    EventArgs^ e
) override
abstract OnInit :
        e : EventArgs -> unit
override OnInit :
        e : EventArgs -> unit
Parameters
e (EventArgs)


OnPreRender Method (e)

OnPreRender Method (e)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineTextBox ► OnPreRender(EventArgs)
Keyoti RapidSpell Web .NET
Called during the pre-render page cycle.
Declaration Syntax
C# Visual Basic Visual C++ F#
protected override void OnPreRender(
    EventArgs e
)
Protected Overrides Sub OnPreRender (
    e As EventArgs
)
protected:
virtual void OnPreRender(
    EventArgs^ e
) override
abstract OnPreRender :
        e : EventArgs -> unit
override OnPreRender :
        e : EventArgs -> unit
Parameters
e (EventArgs)


Render Method (output)

Render Method (output)
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineTextBox ► Render(HtmlTextWriter)
Keyoti RapidSpell Web .NET
Renders the control
Declaration Syntax
C# Visual Basic Visual C++ F#
protected override void Render(
    HtmlTextWriter output
)
Protected Overrides Sub Render (
    output As HtmlTextWriter
)
protected:
virtual void Render(
    HtmlTextWriter^ output
) override
abstract Render :
        output : HtmlTextWriter -> unit
override Render :
        output : HtmlTextWriter -> unit
Parameters
output (HtmlTextWriter)


TextXHTML Property

TextXHTML Property
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineTextBox ► TextXHTML
Keyoti RapidSpell Web .NET
The Text in the text box, as XHTML (HTML).
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string TextXHTML { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property TextXHTML As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ TextXHTML {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member TextXHTML : string with get, set
Property Value
String
Remarks
Use this property to pass HTML entities such as bullets and other special chars to the text box.


RSButton Class

RSButton Class
API Documentation ► Keyoti.RapidSpell ► RSButton
Keyoti RapidSpell Web .NET
RapidSpell button
Declaration Syntax
C# Visual Basic Visual C++ F#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class RSButton : Control
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Class RSButton
    Inherits Control
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public ref class RSButton : public Control
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
type RSButton =
    class
        inherit Control
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RSButton(String) | Initializes a new instance of the RSButton class using the specified button type
 | RSButton()()()() | Initializes a new instance of the RSButton class using the specified button type
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | The runtime attributes.
 | BackColor | Gets or sets the background color of the Web server control.
 | BeginRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web server control.
 | BorderStyle | Gets or sets the border style of the Web server control.
 | BorderWidth | Gets or sets the border width of the Web server control.
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearCachedClientID()()()() | (Inherited from Control.)
 | ClearChildControlState()()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClearEffectiveClientIDMode()()()() | (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDMode | (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CssClass | The CssClass of this control.
 | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataItemContainer | (Inherited from Control.)
 | DataKeysContainer | (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Enabled state of the control.
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from Control.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EndRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | EnsureChildControls()()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
 | Focus()()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control.
 | ForeColor | Gets or sets the foreground color of the Web server control.
 | GetDesignModeState()()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRouteUrl(Object) | (Inherited from Control.)
 | GetRouteUrl(String, Object) | (Inherited from Control.)
 | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
 | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetUniqueIDRelativeTo(Control) | (Inherited from Control.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control.
 | ID | The ID of the control (Overrides Control.ID.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | ImageMouseDown | The button image URL. This is for mouse down and is optional.
 | ImageMouseOut | The button image URL. This is for mouse out (ie. not mouse over) and is optional.
 | ImageMouseOver | The button image URL. This is for mouse over and is optional.
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | The button text.
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | onclick | The button client-side onclick handler.
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control. (Overrides Control.Render(HtmlTextWriter).)
 | RenderAttributes(HtmlTextWriter) | Internal use.
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderingCompatibility | (Inherited from Control.)
 | ResolveAdapter()()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | runat | Internal use.
 | SaveControlState()()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetTraceData(Object, Object) | (Inherited from Control.)
 | SetTraceData(Object, Object, Object) | (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | style | The button client-side style handler.
 | TabIndex | The button tab index.
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TrackViewState()()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | type | The button text.
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ValidateRequestMode | (Inherited from Control.)
 | Value | The button text.
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateMode | (Inherited from Control.)
 | Visible | Whether to render this control (Overrides Control.Visible.)
 | Width | Gets or sets the width of the Web server control.
Inheritance Hierarchy
Object
 | Control
 |  | RSButton


RSButton Constructor

RSButton Constructor
API Documentation ► Keyoti.RapidSpell ► RSButton ► RSButton()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | RSButton(String) | Initializes a new instance of the RSButton class using the specified button type
 | RSButton()()()() | Initializes a new instance of the RSButton class using the specified button type


RSButton Constructor

RSButton Constructor
API Documentation ► Keyoti.RapidSpell ► RSButton ► RSButton()()()()
Keyoti RapidSpell Web .NET
Initializes a new instance of the RSButton class using the specified button type
Declaration Syntax
C# Visual Basic Visual C++ F#
public RSButton()
Public Sub New
public:
RSButton()
new : unit -> RSButton


RSButton Constructor (type)

RSButton Constructor (type)
API Documentation ► Keyoti.RapidSpell ► RSButton ► RSButton(String)
Keyoti RapidSpell Web .NET
Initializes a new instance of the RSButton class using the specified button type
Declaration Syntax
C# Visual Basic Visual C++ F#
public RSButton(
    string type
)
Public Sub New (
    type As String
)
public:
RSButton(
    String^ type
)
new :
        type : string -> RSButton
Parameters
type (String)


Attributes Property

Attributes Property
API Documentation ► Keyoti.RapidSpell ► RSButton ► Attributes
Keyoti RapidSpell Web .NET
The runtime attributes.
Declaration Syntax
C# Visual Basic Visual C++ F#
public AttributeCollection Attributes { get; }
Public ReadOnly Property Attributes As AttributeCollection
    Get
public:
property AttributeCollection^ Attributes {
    AttributeCollection^ get ();
}
member Attributes : AttributeCollection with get
Property Value
AttributeCollection


BackColor Property

BackColor Property
API Documentation ► Keyoti.RapidSpell ► RSButton ► BackColor
Keyoti RapidSpell Web .NET
Gets or sets the background color of the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Color BackColor { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property BackColor As Color
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property Color BackColor {
    Color get ();
    void set (Color value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member BackColor : Color with get, set
Property Value
Color


BorderColor Property

BorderColor Property
API Documentation ► Keyoti.RapidSpell ► RSButton ► BorderColor
Keyoti RapidSpell Web .NET
Gets or sets the border color of the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Color BorderColor { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property BorderColor As Color
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property Color BorderColor {
    Color get ();
    void set (Color value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member BorderColor : Color with get, set
Property Value
Color


BorderStyle Property

BorderStyle Property
API Documentation ► Keyoti.RapidSpell ► RSButton ► BorderStyle
Keyoti RapidSpell Web .NET
Gets or sets the border style of the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public BorderStyle BorderStyle { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property BorderStyle As BorderStyle
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property BorderStyle BorderStyle {
    BorderStyle get ();
    void set (BorderStyle value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member BorderStyle : BorderStyle with get, set
Property Value
BorderStyle


BorderWidth Property

BorderWidth Property
API Documentation ► Keyoti.RapidSpell ► RSButton ► BorderWidth
Keyoti RapidSpell Web .NET
Gets or sets the border width of the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Unit BorderWidth { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property BorderWidth As Unit
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property Unit BorderWidth {
    Unit get ();
    void set (Unit value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member BorderWidth : Unit with get, set
Property Value
Unit


CssClass Property

CssClass Property
API Documentation ► Keyoti.RapidSpell ► RSButton ► CssClass
Keyoti RapidSpell Web .NET
The CssClass of this control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string CssClass { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property CssClass As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ CssClass {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member CssClass : string with get, set
Property Value
String


Enabled Property

Enabled Property
API Documentation ► Keyoti.RapidSpell ► RSButton ► Enabled
Keyoti RapidSpell Web .NET
Enabled state of the control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public bool Enabled { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Enabled As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property bool Enabled {
    bool get ();
    void set (bool value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member Enabled : bool with get, set
Property Value
Boolean


Font Property

Font Property
API Documentation ► Keyoti.RapidSpell ► RSButton ► Font
Keyoti RapidSpell Web .NET
Gets the font properties associated with the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public FontInfo Font { get; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public ReadOnly Property Font As FontInfo
    Get
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property FontInfo^ Font {
    FontInfo^ get ();
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member Font : FontInfo with get
Property Value
FontInfo


ForeColor Property

ForeColor Property
API Documentation ► Keyoti.RapidSpell ► RSButton ► ForeColor
Keyoti RapidSpell Web .NET
Gets or sets the foreground color of the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Color ForeColor { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ForeColor As Color
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property Color ForeColor {
    Color get ();
    void set (Color value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ForeColor : Color with get, set
Property Value
Color


Height Property

Height Property
API Documentation ► Keyoti.RapidSpell ► RSButton ► Height
Keyoti RapidSpell Web .NET
Gets or sets the height of the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Unit Height { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Height As Unit
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property Unit Height {
    Unit get ();
    void set (Unit value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member Height : Unit with get, set
Property Value
Unit


ID Property

ID Property
API Documentation ► Keyoti.RapidSpell ► RSButton ► ID
Keyoti RapidSpell Web .NET
The ID of the control
Declaration Syntax
C# Visual Basic Visual C++ F#
public override string ID { get; set; }
Public Overrides Property ID As String
    Get
    Set
public:
virtual property String^ ID {
    String^ get () override;
    void set (String^ value) override;
}
abstract ID : string with get, set
override ID : string with get, set
Property Value
String


ImageMouseDown Property

ImageMouseDown Property
API Documentation ► Keyoti.RapidSpell ► RSButton ► ImageMouseDown
Keyoti RapidSpell Web .NET
The button image URL. This is for mouse down and is optional.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string ImageMouseDown { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ImageMouseDown As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ ImageMouseDown {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ImageMouseDown : string with get, set
Property Value
String


ImageMouseOut Property

ImageMouseOut Property
API Documentation ► Keyoti.RapidSpell ► RSButton ► ImageMouseOut
Keyoti RapidSpell Web .NET
The button image URL. This is for mouse out (ie. not mouse over) and is optional.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string ImageMouseOut { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ImageMouseOut As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ ImageMouseOut {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ImageMouseOut : string with get, set
Property Value
String


ImageMouseOver Property

ImageMouseOver Property
API Documentation ► Keyoti.RapidSpell ► RSButton ► ImageMouseOver
Keyoti RapidSpell Web .NET
The button image URL. This is for mouse over and is optional.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string ImageMouseOver { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ImageMouseOver As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ ImageMouseOver {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ImageMouseOver : string with get, set
Property Value
String


Name Property

Name Property
API Documentation ► Keyoti.RapidSpell ► RSButton ► Name
Keyoti RapidSpell Web .NET
The button text.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string Name { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Name As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ Name {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member Name : string with get, set
Property Value
String


onclick Property

onclick Property
API Documentation ► Keyoti.RapidSpell ► RSButton ► onclick
Keyoti RapidSpell Web .NET
The button client-side onclick handler.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string onclick { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property onclick As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ onclick {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member onclick : string with get, set
Property Value
String


Render Method (output)

Render Method (output)
API Documentation ► Keyoti.RapidSpell ► RSButton ► Render(HtmlTextWriter)
Keyoti RapidSpell Web .NET
Renders the control.
Declaration Syntax
C# Visual Basic Visual C++ F#
protected override void Render(
    HtmlTextWriter output
)
Protected Overrides Sub Render (
    output As HtmlTextWriter
)
protected:
virtual void Render(
    HtmlTextWriter^ output
) override
abstract Render :
        output : HtmlTextWriter -> unit
override Render :
        output : HtmlTextWriter -> unit
Parameters
output (HtmlTextWriter)


RenderAttributes Method (writer)

RenderAttributes Method (writer)
API Documentation ► Keyoti.RapidSpell ► RSButton ► RenderAttributes(HtmlTextWriter)
Keyoti RapidSpell Web .NET
Internal use.
Declaration Syntax
C# Visual Basic Visual C++ F#
protected virtual void RenderAttributes(
    HtmlTextWriter writer
)
Protected Overridable Sub RenderAttributes (
    writer As HtmlTextWriter
)
protected:
virtual void RenderAttributes(
    HtmlTextWriter^ writer
)
abstract RenderAttributes :
        writer : HtmlTextWriter -> unit
override RenderAttributes :
        writer : HtmlTextWriter -> unit
Parameters
writer (HtmlTextWriter)


runat Property

runat Property
API Documentation ► Keyoti.RapidSpell ► RSButton ► runat
Keyoti RapidSpell Web .NET
Internal use.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string runat { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property runat As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ runat {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member runat : string with get, set
Property Value
String


style Property

style Property
API Documentation ► Keyoti.RapidSpell ► RSButton ► style
Keyoti RapidSpell Web .NET
The button client-side style handler.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string style { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property style As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ style {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member style : string with get, set
Property Value
String


TabIndex Property

TabIndex Property
API Documentation ► Keyoti.RapidSpell ► RSButton ► TabIndex
Keyoti RapidSpell Web .NET
The button tab index.
Declaration Syntax
C# Visual Basic Visual C++ F#
public short TabIndex { get; set; }
Public Property TabIndex As Short
    Get
    Set
public:
property short TabIndex {
    short get ();
    void set (short value);
}
member TabIndex : int16 with get, set
Property Value
Int16


type Property

type Property
API Documentation ► Keyoti.RapidSpell ► RSButton ► type
Keyoti RapidSpell Web .NET
The button text.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string type { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property type As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ type {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member type : string with get, set
Property Value
String


Value Property

Value Property
API Documentation ► Keyoti.RapidSpell ► RSButton ► Value
Keyoti RapidSpell Web .NET
The button text.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string Value { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Value As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ Value {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member Value : string with get, set
Property Value
String


Visible Property

Visible Property
API Documentation ► Keyoti.RapidSpell ► RSButton ► Visible
Keyoti RapidSpell Web .NET
Whether to render this control
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override bool Visible { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property Visible As Boolean
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
virtual property bool Visible {
    bool get () override;
    void set (bool value) override;
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
abstract Visible : bool with get, set
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
override Visible : bool with get, set
Property Value
Boolean


Width Property

Width Property
API Documentation ► Keyoti.RapidSpell ► RSButton ► Width
Keyoti RapidSpell Web .NET
Gets or sets the width of the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Unit Width { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Width As Unit
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property Unit Width {
    Unit get ();
    void set (Unit value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member Width : Unit with get, set
Property Value
Unit


RSGenericBuilder Class

RSGenericBuilder Class
API Documentation ► Keyoti.RapidSpell ► RSGenericBuilder
Keyoti RapidSpell Web .NET
RapidSpell HTML element builder
Declaration Syntax
C# Visual Basic Visual C++ F#
public class RSGenericBuilder : ControlBuilder
Public Class RSGenericBuilder
    Inherits ControlBuilder
public ref class RSGenericBuilder : public ControlBuilder
type RSGenericBuilder =
    class
        inherit ControlBuilder
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RSGenericBuilder()()()() |
 | AllowWhitespaceLiterals()()()() | Returns true (Overrides ControlBuilder.AllowWhitespaceLiterals()()()().)
 | AppendLiteralString(String) | Ignores literals between rows. (Overrides ControlBuilder.AppendLiteralString(String).)
 | AppendSubBuilder(ControlBuilder) | Adds builders to the ControlBuilder object for any child controls that belong to the container control. (Inherited from ControlBuilder.)
 | BindingContainerBuilder | (Inherited from ControlBuilder.)
 | BindingContainerType | Gets the type of the binding container for the control that this builder creates. (Inherited from ControlBuilder.)
 | BuildObject()()()() | Builds a design-time instance of the control that is referred to by this ControlBuilder object. (Inherited from ControlBuilder.)
 | CloseControl()()()() | Called by the parser to inform the builder that the parsing of the control's opening and closing tags is complete. (Inherited from ControlBuilder.)
 | ComplexPropertyEntries | (Inherited from ControlBuilder.)
 | ControlType | Gets the Type for the control to be created. (Inherited from ControlBuilder.)
 | CurrentFilterResolutionService | Gets an IFilterResolutionService object that is used to manage device-filter related services when parsing and persisting controls in the designer. (Inherited from ControlBuilder.)
 | DeclareType | Gets the type that will be used by code generation to declare the control. (Inherited from ControlBuilder.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FChildrenAsProperties | Determines whether the control has a ParseChildrenAttribute with ChildrenAsProperties set to true. (Inherited from ControlBuilder.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FIsNonParserAccessor | Determines whether the control implements the IParserAccessor interface. (Inherited from ControlBuilder.)
 | GetChildControlType(String, IDictionary) | Returns null (Overrides ControlBuilder.GetChildControlType(String, IDictionary).)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectPersistData()()()() | Creates the ObjectPersistData object for this ControlBuilder object. (Inherited from ControlBuilder.)
 | GetResourceKey()()()() | Retrieves the resource key for this ControlBuilder object. (Inherited from ControlBuilder.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | HasAspCode | Gets a value indicating whether the control contains any code blocks. (Inherited from ControlBuilder.)
 | HasBody()()()() | Determines if a control has both an opening and closing tag. This method is called by the ASP.NET page framework. (Inherited from ControlBuilder.)
 | HtmlDecodeLiterals()()()() | Determines whether the literal string of an HTML control must be HTML decoded. This method is called by the ASP.NET page framework. (Inherited from ControlBuilder.)
 | ID | Gets or sets the identifier property for the control to be built. (Inherited from ControlBuilder.)
 | InDesigner | Returns whether the ControlBuilder is running in the designer. (Inherited from ControlBuilder.)
 | Init(TemplateParser, ControlBuilder, Type, String, String, IDictionary) | Initializes the ControlBuilder for use after it is instantiated. This method is called by the ASP.NET page framework. (Inherited from ControlBuilder.)
 | InPageTheme | Gets a Boolean value indicating whether this ControlBuilder object is used to generate page themes. (Inherited from ControlBuilder.)
 | ItemType | (Inherited from ControlBuilder.)
 | Localize | Gets a Boolean value indicating whether the control that is created by this ControlBuilder object is localized. (Inherited from ControlBuilder.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamingContainerType | Gets the type of the naming container for the control that this builder creates. (Inherited from ControlBuilder.)
 | NeedsTagInnerText()()()() | Determines if the control builder needs to get its inner text. If so, the SetTagInnerText(String) method must be called. This method is called by the ASP.NET page framework. (Inherited from ControlBuilder.)
 | OnAppendToParentBuilder(ControlBuilder) | Notifies the ControlBuilder that it is being added to a parent control builder. (Inherited from ControlBuilder.)
 | PageVirtualPath | (Inherited from ControlBuilder.)
 | Parser | Gets the TemplateParser responsible for parsing the control. (Inherited from ControlBuilder.)
 | ProcessGeneratedCode(CodeCompileUnit, CodeTypeDeclaration, CodeTypeDeclaration, CodeMemberMethod, CodeMemberMethod) | Enables custom control builders to access the generated Code Document Object Model (CodeDom) and insert and modify code during the process of parsing and building controls. (Inherited from ControlBuilder.)
 | ServiceProvider | Gets the service object for this ControlBuilder object. (Inherited from ControlBuilder.)
 | SetResourceKey(String) | Sets the resource key for this ControlBuilder object. (Inherited from ControlBuilder.)
 | SetServiceProvider(IServiceProvider) | Sets the service object for this ControlBuilder object. (Inherited from ControlBuilder.)
 | SetTagInnerText(String) | Provides the ControlBuilder with the inner text of the control tag. (Inherited from ControlBuilder.)
 | SubBuilders | (Inherited from ControlBuilder.)
 | TagName | Gets the tag name for the control to be built. (Inherited from ControlBuilder.)
 | TemplatePropertyEntries | (Inherited from ControlBuilder.)
 | ThemeResolutionService | Gets an IThemeResolutionService object that is used in design time to manage control themes and skins. (Inherited from ControlBuilder.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ControlBuilder
 |  | RSGenericBuilder


RSGenericBuilder Constructor

RSGenericBuilder Constructor
API Documentation ► Keyoti.RapidSpell ► RSGenericBuilder ► RSGenericBuilder()()()()
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public RSGenericBuilder()
Public Sub New
public:
RSGenericBuilder()
new : unit -> RSGenericBuilder


AllowWhitespaceLiterals Method

AllowWhitespaceLiterals Method
API Documentation ► Keyoti.RapidSpell ► RSGenericBuilder ► AllowWhitespaceLiterals()()()()
Keyoti RapidSpell Web .NET
Returns true
Declaration Syntax
C# Visual Basic Visual C++ F#
public override bool AllowWhitespaceLiterals()
Public Overrides Function AllowWhitespaceLiterals As Boolean
public:
virtual bool AllowWhitespaceLiterals() override
abstract AllowWhitespaceLiterals : unit -> bool
override AllowWhitespaceLiterals : unit -> bool
Return Value
Boolean


AppendLiteralString Method (s)

AppendLiteralString Method (s)
API Documentation ► Keyoti.RapidSpell ► RSGenericBuilder ► AppendLiteralString(String)
Keyoti RapidSpell Web .NET
Ignores literals between rows.
Declaration Syntax
C# Visual Basic Visual C++ F#
public override void AppendLiteralString(
    string s
)
Public Overrides Sub AppendLiteralString (
    s As String
)
public:
virtual void AppendLiteralString(
    String^ s
) override
abstract AppendLiteralString :
        s : string -> unit
override AppendLiteralString :
        s : string -> unit
Parameters
s (String)


GetChildControlType Method (tagName, attributes)

GetChildControlType Method (tagName, attributes)
API Documentation ► Keyoti.RapidSpell ► RSGenericBuilder ► GetChildControlType(String, IDictionary)
Keyoti RapidSpell Web .NET
Returns null
Declaration Syntax
C# Visual Basic Visual C++ F#
public override Type GetChildControlType(
    string tagName,
    IDictionary attributes
)
Public Overrides Function GetChildControlType (
    tagName As String,
    attributes As IDictionary
) As Type
public:
virtual Type^ GetChildControlType(
    String^ tagName,
    IDictionary^ attributes
) override
abstract GetChildControlType :
        tagName : string *
        attributes : IDictionary -> Type
override GetChildControlType :
        tagName : string *
        attributes : IDictionary -> Type
Parameters
tagName (String)
attributes (IDictionary)
Return Value
Type


RSLabel Class

RSLabel Class
API Documentation ► Keyoti.RapidSpell ► RSLabel
Keyoti RapidSpell Web .NET
RapidSpell label
Declaration Syntax
C# Visual Basic Visual C++ F#
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class RSLabel : Label
<TypeConverterAttribute(GetType(ExpandableObjectConverter))>
Public Class RSLabel
    Inherits Label
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public ref class RSLabel : public Label
[<TypeConverterAttribute(typeof(ExpandableObjectConverter))>]
type RSLabel =
    class
        inherit Label
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RSLabel()()()() | Initializes a new instance of the RSLabel
 | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from WebControl.)
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddAttributesToRender(HtmlTextWriter) | Adds the HTML attributes and styles of a Label control to render to the specified output stream. (Inherited from Label.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the control that an element was parsed and adds the element to the Label control. (Inherited from Label.)
 | ApplyStyle(Style) | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from WebControl.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AssociatedControlID | Gets or sets the identifier for a server control that the Label control is associated with. (Inherited from Label.)
 | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from WebControl.)
 | BackColor | Gets or sets the background color of the Web server control. (Overrides WebControl.BackColor.)
 | BeginRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web server control. (Overrides WebControl.BorderColor.)
 | BorderStyle | Gets or sets the border style of the Web server control. (Overrides WebControl.BorderStyle.)
 | BorderWidth | Gets or sets the border width of the Web server control. (Overrides WebControl.BorderWidth.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearCachedClientID()()()() | (Inherited from Control.)
 | ClearChildControlState()()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClearEffectiveClientIDMode()()()() | (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDMode | (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from WebControl.)
 | ControlStyleCreated | Gets a value indicating whether a Style object has been created for the ControlStyle property. This property is primarily used by control developers. (Inherited from WebControl.)
 | CopyBaseAttributes(WebControl) | Copies the properties not encapsulated by the Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from WebControl.)
 | CreateChildControls()()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateControlStyle()()()() | Creates the style object that is used internally by the WebControl class to implement all style related properties. This method is used primarily by control developers. (Inherited from WebControl.)
 | CssClass | The CssClass of this control. (Overrides WebControl.CssClass.)
 | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataItemContainer | (Inherited from Control.)
 | DataKeysContainer | (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from WebControl.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from WebControl.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EndRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | EnsureChildControls()()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
 | Focus()()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control. (Overrides WebControl.Font.)
 | ForeColor | Gets or sets the foreground color of the Web server control. (Overrides WebControl.ForeColor.)
 | GetDesignModeState()()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRouteUrl(Object) | (Inherited from Control.)
 | GetRouteUrl(String, Object) | (Inherited from Control.)
 | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
 | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetUniqueIDRelativeTo(Control) | (Inherited from Control.)
 | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from WebControl.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control. (Overrides WebControl.Height.)
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsEnabled | Gets a value indicating whether the control is enabled. (Inherited from WebControl.)
 | IsLiteralContent()()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
 | LoadViewState(Object) | Loads the previously saved state for the control. (Inherited from Label.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeStyle(Style) | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from WebControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control to the specified HTML writer. (Inherited from WebControl.)
 | RenderBeginTag(HtmlTextWriter) | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderContents(HtmlTextWriter) | Renders the contents of the Label into the specified writer. (Inherited from Label.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from WebControl.)
 | RenderingCompatibility | (Inherited from Control.)
 | ResolveAdapter()()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()()() | Saves any state that was modified after the TrackViewState()()()() method was invoked. (Inherited from WebControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetTraceData(Object, Object) | (Inherited from Control.)
 | SetTraceData(Object, Object, Object) | (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from WebControl.)
 | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from WebControl.)
 | SupportsDisabledAttribute | (Inherited from Label.)
 | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from WebControl.)
 | TagKey | Gets the HTML tag that is used to render the Label control. (Inherited from Label.)
 | TagName | Gets the name of the control tag. This property is used primarily by control developers. (Inherited from WebControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Text | The label text. (Overrides Label.Text.)
 | ToolTip | Gets or sets the text displayed when the mouse pointer hovers over the Web server control. (Inherited from WebControl.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TrackViewState()()()() | Causes the control to track changes to its view state so they can be stored in the object's ViewState property. (Inherited from WebControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ValidateRequestMode | (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | ViewStateMode | (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control. (Overrides WebControl.Width.)
Inheritance Hierarchy
Object
 | Control
 |  | WebControl
 |  |  | Label
 |  |  |  | RSLabel


RSLabel Constructor

RSLabel Constructor
API Documentation ► Keyoti.RapidSpell ► RSLabel ► RSLabel()()()()
Keyoti RapidSpell Web .NET
Initializes a new instance of the RSLabel
Declaration Syntax
C# Visual Basic Visual C++ F#
public RSLabel()
Public Sub New
public:
RSLabel()
new : unit -> RSLabel


BackColor Property

BackColor Property
API Documentation ► Keyoti.RapidSpell ► RSLabel ► BackColor
Keyoti RapidSpell Web .NET
Gets or sets the background color of the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override Color BackColor { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property BackColor As Color
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
virtual property Color BackColor {
    Color get () override;
    void set (Color value) override;
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
abstract BackColor : Color with get, set
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
override BackColor : Color with get, set
Property Value
Color


BorderColor Property

BorderColor Property
API Documentation ► Keyoti.RapidSpell ► RSLabel ► BorderColor
Keyoti RapidSpell Web .NET
Gets or sets the border color of the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override Color BorderColor { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property BorderColor As Color
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
virtual property Color BorderColor {
    Color get () override;
    void set (Color value) override;
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
abstract BorderColor : Color with get, set
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
override BorderColor : Color with get, set
Property Value
Color


BorderStyle Property

BorderStyle Property
API Documentation ► Keyoti.RapidSpell ► RSLabel ► BorderStyle
Keyoti RapidSpell Web .NET
Gets or sets the border style of the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override BorderStyle BorderStyle { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property BorderStyle As BorderStyle
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
virtual property BorderStyle BorderStyle {
    BorderStyle get () override;
    void set (BorderStyle value) override;
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
abstract BorderStyle : BorderStyle with get, set
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
override BorderStyle : BorderStyle with get, set
Property Value
BorderStyle


BorderWidth Property

BorderWidth Property
API Documentation ► Keyoti.RapidSpell ► RSLabel ► BorderWidth
Keyoti RapidSpell Web .NET
Gets or sets the border width of the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override Unit BorderWidth { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property BorderWidth As Unit
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
virtual property Unit BorderWidth {
    Unit get () override;
    void set (Unit value) override;
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
abstract BorderWidth : Unit with get, set
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
override BorderWidth : Unit with get, set
Property Value
Unit


CssClass Property

CssClass Property
API Documentation ► Keyoti.RapidSpell ► RSLabel ► CssClass
Keyoti RapidSpell Web .NET
The CssClass of this control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override string CssClass { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property CssClass As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
virtual property String^ CssClass {
    String^ get () override;
    void set (String^ value) override;
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
abstract CssClass : string with get, set
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
override CssClass : string with get, set
Property Value
String


Font Property

Font Property
API Documentation ► Keyoti.RapidSpell ► RSLabel ► Font
Keyoti RapidSpell Web .NET
Gets the font properties associated with the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override FontInfo Font { get; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides ReadOnly Property Font As FontInfo
    Get
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
virtual property FontInfo^ Font {
    FontInfo^ get () override;
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
abstract Font : FontInfo with get
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
override Font : FontInfo with get
Property Value
FontInfo


ForeColor Property

ForeColor Property
API Documentation ► Keyoti.RapidSpell ► RSLabel ► ForeColor
Keyoti RapidSpell Web .NET
Gets or sets the foreground color of the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override Color ForeColor { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property ForeColor As Color
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
virtual property Color ForeColor {
    Color get () override;
    void set (Color value) override;
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
abstract ForeColor : Color with get, set
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
override ForeColor : Color with get, set
Property Value
Color


Height Property

Height Property
API Documentation ► Keyoti.RapidSpell ► RSLabel ► Height
Keyoti RapidSpell Web .NET
Gets or sets the height of the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override Unit Height { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property Height As Unit
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
virtual property Unit Height {
    Unit get () override;
    void set (Unit value) override;
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
abstract Height : Unit with get, set
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
override Height : Unit with get, set
Property Value
Unit


Text Property

Text Property
API Documentation ► Keyoti.RapidSpell ► RSLabel ► Text
Keyoti RapidSpell Web .NET
The label text.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override string Text { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property Text As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
virtual property String^ Text {
    String^ get () override;
    void set (String^ value) override;
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
abstract Text : string with get, set
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
override Text : string with get, set
Property Value
String


Width Property

Width Property
API Documentation ► Keyoti.RapidSpell ► RSLabel ► Width
Keyoti RapidSpell Web .NET
Gets or sets the width of the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override Unit Width { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property Width As Unit
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
virtual property Unit Width {
    Unit get () override;
    void set (Unit value) override;
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
abstract Width : Unit with get, set
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
override Width : Unit with get, set
Property Value
Unit


RSSelect Class

RSSelect Class
API Documentation ► Keyoti.RapidSpell ► RSSelect
Keyoti RapidSpell Web .NET
RapidSpell select box
Declaration Syntax
C# Visual Basic Visual C++ F#
public class RSSelect : HtmlSelect
Public Class RSSelect
    Inherits HtmlSelect
public ref class RSSelect : public HtmlSelect
type RSSelect =
    class
        inherit HtmlSelect
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RSSelect()()()() |
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Adds a parsed child control to the HtmlSelect control. (Inherited from HtmlSelect.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets a collection of all attribute name and value pairs expressed on a server control tag within the ASP.NET page. (Inherited from HtmlControl.)
 | BackColor | Gets or sets the background color of the Web server control.
 | BeginRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web server control.
 | BorderStyle | Gets or sets the border style of the Web server control.
 | BorderWidth | Gets or sets the border width of the Web server control.
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearCachedClientID()()()() | (Inherited from Control.)
 | ClearChildControlState()()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClearEffectiveClientIDMode()()()() | (Inherited from Control.)
 | ClearSelection()()()() | Clears the list selection of the HtmlSelect control and sets the Selected property of all items to false. (Inherited from HtmlSelect.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDMode | (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()()() | Creates an EmptyControlCollection object for the HtmlSelect control. (Inherited from HtmlSelect.)
 | CssClass | The CssClass of this control.
 | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataItemContainer | (Inherited from Control.)
 | DataKeysContainer | (Inherited from Control.)
 | DataMember | Gets or sets the set of data to bind to the HtmlSelect control from a DataSource property with multiple sets of data. (Inherited from HtmlSelect.)
 | DataSource | Gets or sets the source of information to bind to the HtmlSelect control. (Inherited from HtmlSelect.)
 | DataSourceID | Gets or sets the ID property of the data source control that the HtmlSelect control should use to retrieve its data source. (Inherited from HtmlSelect.)
 | DataTextField | Gets or sets the field from the data source to bind to the Text property of each item in the HtmlSelect control. (Inherited from HtmlSelect.)
 | DataValueField | Gets or sets the field from the data source to bind to the Value property of each item in the HtmlSelect control. (Inherited from HtmlSelect.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Disabled | Gets or sets a value indicating whether the HTML server control is disabled. (Inherited from HtmlControl.)
 | Dispose()()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from Control.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EndRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | EnsureChildControls()()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureDataBound()()()() | Verifies that the HtmlSelect control requires data binding and that a valid data source control is specified before calling the DataBind()()()() method. (Inherited from HtmlSelect.)
 | EnsureID()()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
 | Focus()()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control.
 | ForeColor | Gets or sets the foreground color of the Web server control.
 | GetAttribute(String) | Gets the value of the named attribute on the HtmlControl control. (Inherited from HtmlControl.)
 | GetData()()()() | Gets an IEnumerable object that represents the data source that is bound to the HtmlSelect control. (Inherited from HtmlSelect.)
 | GetDesignModeState()()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRouteUrl(Object) | (Inherited from Control.)
 | GetRouteUrl(String, Object) | (Inherited from Control.)
 | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
 | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetUniqueIDRelativeTo(Control) | (Inherited from Control.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control.
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | InnerHtml | Gets or sets the content between the opening and closing tags of the control without automatically converting special characters to their equivalent HTML entities. This property is not supported for this control. (Inherited from HtmlSelect.)
 | InnerText | Gets or sets the content between the opening and closing tags of the control with automatic conversion of special characters to their equivalent HTML entities. This property is not supported for this control. (Inherited from HtmlSelect.)
 | IsBoundUsingDataSourceID | Gets a value indicating whether a DataSourceID property is defined for the HtmlSelect control. (Inherited from HtmlSelect.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Items | Gets a collection that contains the items listed in an HtmlSelect control. (Inherited from HtmlSelect.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
 | LoadPostData(String, NameValueCollection) | Processes the postback data for the HtmlSelect control. (Inherited from HtmlSelect.)
 | LoadViewState(Object) | Restores the HtmlSelect control's view state information from a previous page request that was saved by the SaveViewState()()()() method. (Inherited from HtmlSelect.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Multiple | Gets or sets a value indicating whether multiple items can be selected concurrently in the HtmlSelect control. (Inherited from HtmlSelect.)
 | Name | Gets or sets the unique identifier name associated with the HtmlSelect control. (Inherited from HtmlSelect.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event of an HtmlSelect control. (Inherited from HtmlSelect.)
 | OnDataPropertyChanged()()()() | Invoked when the DataSource, DataMember, or DataSourceID property is changed. (Inherited from HtmlSelect.)
 | OnDataSourceViewChanged(Object, EventArgs) | Invoked when the DataSource, DataMember, or DataSourceID property is changed. (Inherited from HtmlSelect.)
 | OnInit(EventArgs) | Raises the Init event for the HtmlSelect control. (Inherited from HtmlSelect.)
 | OnLoad(EventArgs) | Raises the Load event for the HtmlSelect control. (Inherited from HtmlSelect.)
 | OnPreRender(EventArgs) | Raises the PreRender event for the HtmlSelect control. (Inherited from HtmlSelect.)
 | OnServerChange(EventArgs) | Raises the ServerChange event of the HtmlSelect control. This allows you to provide a custom handler for the event. (Inherited from HtmlSelect.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()()() | Calls the OnServerChange(EventArgs) method to signal the HtmlSelect control that the state of the control has changed. (Inherited from HtmlSelect.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control. (Overrides HtmlContainerControl.Render(HtmlTextWriter).)
 | RenderAttributes(HtmlTextWriter) | Renders the HtmlSelect control's attributes to the specified HtmlTextWriter object. (Inherited from HtmlSelect.)
 | RenderBeginTag(HtmlTextWriter) | Renders the opening HTML tag of the control into the specified HtmlTextWriter object. (Inherited from HtmlControl.)
 | RenderChildren(HtmlTextWriter) | Renders the HtmlSelect control's child controls to the specified HtmlTextWriter object. (Inherited from HtmlSelect.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderEndTag(HtmlTextWriter) | Renders the closing tag for the HtmlContainerControl control to the specified HtmlTextWriter object. (Inherited from HtmlContainerControl.)
 | RenderingCompatibility | (Inherited from Control.)
 | RequiresDataBinding | Gets or sets a value indicating whether the HtmlSelect control needs to bind to its specified data source. (Inherited from HtmlSelect.)
 | ResolveAdapter()()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()()() | Saves any HtmlSelect control view state changes that have occurred since the page was posted back to the server. (Inherited from HtmlSelect.)
 | Select(array<Int32>[]()[][]) | Selects multiple items of the HtmlSelect control's Items collection. (Inherited from HtmlSelect.)
 | SelectedIndex | Gets or sets the ordinal index of the selected item in an HtmlSelect control. (Inherited from HtmlSelect.)
 | SelectedIndices | Gets a collection that contains the zero-based indexes of all currently selected items in the HtmlSelect control. (Inherited from HtmlSelect.)
 | ServerChange | Occurs when the selected items in the HtmlSelect control change between posts to the server. (Inherited from HtmlSelect.)
 | SetAttribute(String, String) | Sets the value of the named attribute on the HtmlControl control. (Inherited from HtmlControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetTraceData(Object, Object) | (Inherited from Control.)
 | SetTraceData(Object, Object, Object) | (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | Size | Gets or sets the height (in rows) of the HtmlSelect control. (Inherited from HtmlSelect.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | Style | Gets a collection of all cascading style sheet (CSS) properties applied to a specified HTML server control in the ASP.NET file. (Inherited from HtmlControl.)
 | TabIndex | The button tab index.
 | TagName | Gets the element name of a tag that contains a runat=server attribute and value pair. (Inherited from HtmlControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TrackViewState()()()() | Tracks view state changes to the HtmlSelect control so the changes can be stored in the control's StateBag object. This object is accessible through the ViewState property. (Inherited from HtmlSelect.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ValidateRequestMode | (Inherited from Control.)
 | Value | Gets the value of the selected item in the HtmlSelect control or sets the SelectedIndex property of the control to the index of the first item in the list with the specified value. (Inherited from HtmlSelect.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the HtmlControl view state is case-sensitive. (Inherited from HtmlControl.)
 | ViewStateMode | (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control.
Inheritance Hierarchy
Object
 | Control
 |  | HtmlControl
 |  |  | HtmlContainerControl
 |  |  |  | HtmlSelect
 |  |  |  |  | RSSelect


RSSelect Constructor

RSSelect Constructor
API Documentation ► Keyoti.RapidSpell ► RSSelect ► RSSelect()()()()
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public RSSelect()
Public Sub New
public:
RSSelect()
new : unit -> RSSelect


BackColor Property

BackColor Property
API Documentation ► Keyoti.RapidSpell ► RSSelect ► BackColor
Keyoti RapidSpell Web .NET
Gets or sets the background color of the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Color BackColor { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property BackColor As Color
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property Color BackColor {
    Color get ();
    void set (Color value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member BackColor : Color with get, set
Property Value
Color


BorderColor Property

BorderColor Property
API Documentation ► Keyoti.RapidSpell ► RSSelect ► BorderColor
Keyoti RapidSpell Web .NET
Gets or sets the border color of the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Color BorderColor { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property BorderColor As Color
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property Color BorderColor {
    Color get ();
    void set (Color value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member BorderColor : Color with get, set
Property Value
Color


BorderStyle Property

BorderStyle Property
API Documentation ► Keyoti.RapidSpell ► RSSelect ► BorderStyle
Keyoti RapidSpell Web .NET
Gets or sets the border style of the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public BorderStyle BorderStyle { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property BorderStyle As BorderStyle
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property BorderStyle BorderStyle {
    BorderStyle get ();
    void set (BorderStyle value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member BorderStyle : BorderStyle with get, set
Property Value
BorderStyle


BorderWidth Property

BorderWidth Property
API Documentation ► Keyoti.RapidSpell ► RSSelect ► BorderWidth
Keyoti RapidSpell Web .NET
Gets or sets the border width of the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Unit BorderWidth { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property BorderWidth As Unit
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property Unit BorderWidth {
    Unit get ();
    void set (Unit value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member BorderWidth : Unit with get, set
Property Value
Unit


CssClass Property

CssClass Property
API Documentation ► Keyoti.RapidSpell ► RSSelect ► CssClass
Keyoti RapidSpell Web .NET
The CssClass of this control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string CssClass { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property CssClass As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ CssClass {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member CssClass : string with get, set
Property Value
String


Font Property

Font Property
API Documentation ► Keyoti.RapidSpell ► RSSelect ► Font
Keyoti RapidSpell Web .NET
Gets the font properties associated with the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public FontInfo Font { get; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public ReadOnly Property Font As FontInfo
    Get
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property FontInfo^ Font {
    FontInfo^ get ();
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member Font : FontInfo with get
Property Value
FontInfo


ForeColor Property

ForeColor Property
API Documentation ► Keyoti.RapidSpell ► RSSelect ► ForeColor
Keyoti RapidSpell Web .NET
Gets or sets the foreground color of the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Color ForeColor { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ForeColor As Color
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property Color ForeColor {
    Color get ();
    void set (Color value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ForeColor : Color with get, set
Property Value
Color


Height Property

Height Property
API Documentation ► Keyoti.RapidSpell ► RSSelect ► Height
Keyoti RapidSpell Web .NET
Gets or sets the height of the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Unit Height { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Height As Unit
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property Unit Height {
    Unit get ();
    void set (Unit value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member Height : Unit with get, set
Property Value
Unit


Render Method (output)

Render Method (output)
API Documentation ► Keyoti.RapidSpell ► RSSelect ► Render(HtmlTextWriter)
Keyoti RapidSpell Web .NET
Renders the control.
Declaration Syntax
C# Visual Basic Visual C++ F#
protected override void Render(
    HtmlTextWriter output
)
Protected Overrides Sub Render (
    output As HtmlTextWriter
)
protected:
virtual void Render(
    HtmlTextWriter^ output
) override
abstract Render :
        output : HtmlTextWriter -> unit
override Render :
        output : HtmlTextWriter -> unit
Parameters
output (HtmlTextWriter)


TabIndex Property

TabIndex Property
API Documentation ► Keyoti.RapidSpell ► RSSelect ► TabIndex
Keyoti RapidSpell Web .NET
The button tab index.
Declaration Syntax
C# Visual Basic Visual C++ F#
public short TabIndex { get; set; }
Public Property TabIndex As Short
    Get
    Set
public:
property short TabIndex {
    short get ();
    void set (short value);
}
member TabIndex : int16 with get, set
Property Value
Int16


Width Property

Width Property
API Documentation ► Keyoti.RapidSpell ► RSSelect ► Width
Keyoti RapidSpell Web .NET
Gets or sets the width of the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Unit Width { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Width As Unit
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property Unit Width {
    Unit get ();
    void set (Unit value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member Width : Unit with get, set
Property Value
Unit


RSText Class

RSText Class
API Documentation ► Keyoti.RapidSpell ► RSText
Keyoti RapidSpell Web .NET
RapidSpell text box
Declaration Syntax
C# Visual Basic Visual C++ F#
public class RSText : HtmlInputText
Public Class RSText
    Inherits HtmlInputText
public ref class RSText : public HtmlInputText
type RSText =
    class
        inherit HtmlInputText
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RSText(String) | Initializes a new instance of the RSText class using the specified button type
 | RSText()()()() | Initializes a new instance of the RSButton class, of type=button
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | Attributes | Gets a collection of all attribute name and value pairs expressed on a server control tag within the ASP.NET page. (Inherited from HtmlControl.)
 | BackColor | Gets or sets the background color of the Web server control.
 | BeginRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BorderColor | Gets or sets the border color of the Web server control.
 | BorderStyle | Gets or sets the border style of the Web server control.
 | BorderWidth | Gets or sets the border width of the Web server control.
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearCachedClientID()()()() | (Inherited from Control.)
 | ClearChildControlState()()()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()()()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()()()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClearEffectiveClientIDMode()()()() | (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDMode | (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()()()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()()()() | (Inherited from HtmlControl.)
 | CssClass | The CssClass of this control.
 | DataBind()()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()()()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataItemContainer | (Inherited from Control.)
 | DataKeysContainer | (Inherited from Control.)
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Disabled | Gets or sets a value indicating whether the HTML server control is disabled. (Inherited from HtmlControl.)
 | Dispose()()()() | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from Control.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EndRenderTracing(TextWriter, Object) | (Inherited from Control.)
 | EnsureChildControls()()()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()()()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method. (Inherited from Control.)
 | Focus()()()() | Sets input focus to a control. (Inherited from Control.)
 | Font | Gets the font properties associated with the Web server control.
 | ForeColor | Gets or sets the foreground color of the Web server control.
 | GetAttribute(String) | Gets the value of the named attribute on the HtmlControl control. (Inherited from HtmlControl.)
 | GetDesignModeState()()()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRouteUrl(Object) | (Inherited from Control.)
 | GetRouteUrl(String, Object) | (Inherited from Control.)
 | GetRouteUrl(RouteValueDictionary) | (Inherited from Control.)
 | GetRouteUrl(String, RouteValueDictionary) | (Inherited from Control.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetUniqueIDRelativeTo(Control) | (Inherited from Control.)
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()()()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()()()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the Web server control.
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsLiteralContent()()()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()()()() method. (Inherited from Control.)
 | LoadPostData(String, NameValueCollection) | Processes the postback data for the HtmlInputText control. (Inherited from HtmlInputText.)
 | LoadViewState(Object) | Restores view-state information from a previous page request that was saved by the SaveViewState()()()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | MaxLength | Gets or sets the maximum number of characters that can be entered in the text box. (Inherited from HtmlInputText.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the unique identifier name for the HtmlInputControl control. (Inherited from HtmlInputControl.)
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnPreRender(EventArgs) | Raises the PreRender event. (Inherited from HtmlInputText.)
 | OnServerChange(EventArgs) | Raises the ServerChange event. (Inherited from HtmlInputText.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RaisePostDataChangedEvent()()()() | Calls the OnServerChange(EventArgs) method to signal the HtmlInputText control that the state of the control has changed. (Inherited from HtmlInputText.)
 | RemovedControl(Control) | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
 | Render(HtmlTextWriter) | Renders the control. (Overrides HtmlControl.Render(HtmlTextWriter).)
 | RenderAttributes(HtmlTextWriter) | Renders the HtmlInputText control's attributes to the specified HtmlTextWriter object. (Inherited from HtmlInputText.)
 | RenderBeginTag(HtmlTextWriter) | Renders the opening HTML tag of the control into the specified HtmlTextWriter object. (Inherited from HtmlControl.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderingCompatibility | (Inherited from Control.)
 | ResolveAdapter()()()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()()()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SaveViewState()()()() | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | ServerChange | Occurs when the Value property is changed on the server. (Inherited from HtmlInputText.)
 | SetAttribute(String, String) | Sets the value of the named attribute on the HtmlControl control. (Inherited from HtmlControl.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | SetTraceData(Object, Object) | (Inherited from Control.)
 | SetTraceData(Object, Object, Object) | (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | Size | Gets or sets the width of the text box. (Inherited from HtmlInputText.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | Style | Gets a collection of all cascading style sheet (CSS) properties applied to a specified HTML server control in the ASP.NET file. (Inherited from HtmlControl.)
 | TabIndex | The button tab index.
 | TagName | Gets the element name of a tag that contains a runat=server attribute and value pair. (Inherited from HtmlControl.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TrackViewState()()()() | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
 | Type | Gets the type of an HtmlInputControl. (Inherited from HtmlInputControl.)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ValidateRequestMode | (Inherited from Control.)
 | Value | The button text. (Overrides HtmlInputText.Value.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the HtmlControl view state is case-sensitive. (Inherited from HtmlControl.)
 | ViewStateMode | (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Gets or sets the width of the Web server control.
Inheritance Hierarchy
Object
 | Control
 |  | HtmlControl
 |  |  | HtmlInputControl
 |  |  |  | HtmlInputText
 |  |  |  |  | RSText


RSText Constructor

RSText Constructor
API Documentation ► Keyoti.RapidSpell ► RSText ► RSText()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | RSText(String) | Initializes a new instance of the RSText class using the specified button type
 | RSText()()()() | Initializes a new instance of the RSButton class, of type=button


RSText Constructor

RSText Constructor
API Documentation ► Keyoti.RapidSpell ► RSText ► RSText()()()()
Keyoti RapidSpell Web .NET
Initializes a new instance of the RSButton class, of type=button
Declaration Syntax
C# Visual Basic Visual C++ F#
public RSText()
Public Sub New
public:
RSText()
new : unit -> RSText


RSText Constructor (type)

RSText Constructor (type)
API Documentation ► Keyoti.RapidSpell ► RSText ► RSText(String)
Keyoti RapidSpell Web .NET
Initializes a new instance of the RSText class using the specified button type
Declaration Syntax
C# Visual Basic Visual C++ F#
public RSText(
    string type
)
Public Sub New (
    type As String
)
public:
RSText(
    String^ type
)
new :
        type : string -> RSText
Parameters
type (String)


BackColor Property

BackColor Property
API Documentation ► Keyoti.RapidSpell ► RSText ► BackColor
Keyoti RapidSpell Web .NET
Gets or sets the background color of the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Color BackColor { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property BackColor As Color
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property Color BackColor {
    Color get ();
    void set (Color value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member BackColor : Color with get, set
Property Value
Color


BorderColor Property

BorderColor Property
API Documentation ► Keyoti.RapidSpell ► RSText ► BorderColor
Keyoti RapidSpell Web .NET
Gets or sets the border color of the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Color BorderColor { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property BorderColor As Color
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property Color BorderColor {
    Color get ();
    void set (Color value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member BorderColor : Color with get, set
Property Value
Color


BorderStyle Property

BorderStyle Property
API Documentation ► Keyoti.RapidSpell ► RSText ► BorderStyle
Keyoti RapidSpell Web .NET
Gets or sets the border style of the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public BorderStyle BorderStyle { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property BorderStyle As BorderStyle
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property BorderStyle BorderStyle {
    BorderStyle get ();
    void set (BorderStyle value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member BorderStyle : BorderStyle with get, set
Property Value
BorderStyle


BorderWidth Property

BorderWidth Property
API Documentation ► Keyoti.RapidSpell ► RSText ► BorderWidth
Keyoti RapidSpell Web .NET
Gets or sets the border width of the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Unit BorderWidth { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property BorderWidth As Unit
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property Unit BorderWidth {
    Unit get ();
    void set (Unit value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member BorderWidth : Unit with get, set
Property Value
Unit


CssClass Property

CssClass Property
API Documentation ► Keyoti.RapidSpell ► RSText ► CssClass
Keyoti RapidSpell Web .NET
The CssClass of this control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public string CssClass { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property CssClass As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property String^ CssClass {
    String^ get ();
    void set (String^ value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member CssClass : string with get, set
Property Value
String


Font Property

Font Property
API Documentation ► Keyoti.RapidSpell ► RSText ► Font
Keyoti RapidSpell Web .NET
Gets the font properties associated with the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public FontInfo Font { get; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public ReadOnly Property Font As FontInfo
    Get
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property FontInfo^ Font {
    FontInfo^ get ();
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member Font : FontInfo with get
Property Value
FontInfo


ForeColor Property

ForeColor Property
API Documentation ► Keyoti.RapidSpell ► RSText ► ForeColor
Keyoti RapidSpell Web .NET
Gets or sets the foreground color of the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Color ForeColor { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property ForeColor As Color
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property Color ForeColor {
    Color get ();
    void set (Color value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member ForeColor : Color with get, set
Property Value
Color


Height Property

Height Property
API Documentation ► Keyoti.RapidSpell ► RSText ► Height
Keyoti RapidSpell Web .NET
Gets or sets the height of the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Unit Height { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Height As Unit
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property Unit Height {
    Unit get ();
    void set (Unit value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member Height : Unit with get, set
Property Value
Unit


Render Method (output)

Render Method (output)
API Documentation ► Keyoti.RapidSpell ► RSText ► Render(HtmlTextWriter)
Keyoti RapidSpell Web .NET
Renders the control.
Declaration Syntax
C# Visual Basic Visual C++ F#
protected override void Render(
    HtmlTextWriter output
)
Protected Overrides Sub Render (
    output As HtmlTextWriter
)
protected:
virtual void Render(
    HtmlTextWriter^ output
) override
abstract Render :
        output : HtmlTextWriter -> unit
override Render :
        output : HtmlTextWriter -> unit
Parameters
output (HtmlTextWriter)


TabIndex Property

TabIndex Property
API Documentation ► Keyoti.RapidSpell ► RSText ► TabIndex
Keyoti RapidSpell Web .NET
The button tab index.
Declaration Syntax
C# Visual Basic Visual C++ F#
public short TabIndex { get; set; }
Public Property TabIndex As Short
    Get
    Set
public:
property short TabIndex {
    short get ();
    void set (short value);
}
member TabIndex : int16 with get, set
Property Value
Int16


Value Property

Value Property
API Documentation ► Keyoti.RapidSpell ► RSText ► Value
Keyoti RapidSpell Web .NET
The button text.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public override string Value { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Overrides Property Value As String
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
virtual property String^ Value {
    String^ get () override;
    void set (String^ value) override;
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
abstract Value : string with get, set
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
override Value : string with get, set
Property Value
String


Width Property

Width Property
API Documentation ► Keyoti.RapidSpell ► RSText ► Width
Keyoti RapidSpell Web .NET
Gets or sets the width of the Web server control.
Declaration Syntax
C# Visual Basic Visual C++ F#
[PersistenceModeAttribute(PersistenceMode.Attribute)]
public Unit Width { get; set; }
<PersistenceModeAttribute(PersistenceMode.Attribute)>
Public Property Width As Unit
    Get
    Set
public:
[PersistenceModeAttribute(PersistenceMode::Attribute)]
property Unit Width {
    Unit get ();
    void set (Unit value);
}
[<PersistenceModeAttribute(PersistenceMode.Attribute)>]
member Width : Unit with get, set
Property Value
Unit


ScriptProvider Class

ScriptProvider Class
API Documentation ► Keyoti.RapidSpell ► ScriptProvider
Keyoti RapidSpell Web .NET
Provides script include tags.
Declaration Syntax
C# Visual Basic Visual C++ F#
public class ScriptProvider
Public Class ScriptProvider
public ref class ScriptProvider
type ScriptProvider =  class end
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ScriptProvider()()()() |
 | AutoAYTIncludes(Page) |
 | AutoDialogIncludes(Page) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
ScriptProvider


ScriptProvider Constructor

ScriptProvider Constructor
API Documentation ► Keyoti.RapidSpell ► ScriptProvider ► ScriptProvider()()()()
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public ScriptProvider()
Public Sub New
public:
ScriptProvider()
new : unit -> ScriptProvider


AutoAYTIncludes Method (page)

AutoAYTIncludes Method (page)
API Documentation ► Keyoti.RapidSpell ► ScriptProvider ► AutoAYTIncludes(Page)
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public static string AutoAYTIncludes(
    Page page
)
Public Shared Function AutoAYTIncludes (
    page As Page
) As String
public:
static String^ AutoAYTIncludes(
    Page^ page
)
static member AutoAYTIncludes :
        page : Page -> string
Parameters
page (Page)
Return Value
String


AutoDialogIncludes Method (page)

AutoDialogIncludes Method (page)
API Documentation ► Keyoti.RapidSpell ► ScriptProvider ► AutoDialogIncludes(Page)
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public static string AutoDialogIncludes(
    Page page
)
Public Shared Function AutoDialogIncludes (
    page As Page
) As String
public:
static String^ AutoDialogIncludes(
    Page^ page
)
static member AutoDialogIncludes :
        page : Page -> string
Parameters
page (Page)
Return Value
String


SpellingDictionary Class

SpellingDictionary Class
API Documentation ► Keyoti.RapidSpell ► SpellingDictionary
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public class SpellingDictionary
Public Class SpellingDictionary
public ref class SpellingDictionary
type SpellingDictionary =  class end
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | LastModified |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Path |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
SpellingDictionary


LastModified Property

LastModified Property
API Documentation ► Keyoti.RapidSpell ► SpellingDictionary ► LastModified
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public DateTime LastModified { get; }
Public ReadOnly Property LastModified As DateTime
    Get
public:
property DateTime LastModified {
    DateTime get ();
}
member LastModified : DateTime with get
Property Value
DateTime


Path Property

Path Property
API Documentation ► Keyoti.RapidSpell ► SpellingDictionary ► Path
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public string Path { get; }
Public ReadOnly Property Path As String
    Get
public:
property String^ Path {
    String^ get ();
}
member Path : string with get
Property Value
String


Suggestion Class

Suggestion Class
API Documentation ► Keyoti.RapidSpell ► Suggestion
Keyoti RapidSpell Web .NET
Represents a suggestion.
Declaration Syntax
C# Visual Basic Visual C++ F#
public class Suggestion
Public Class Suggestion
public ref class Suggestion
type Suggestion =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Suggestion(String, Int32) | Creates an instance
 | Contains(ArrayList, Suggestion) | Returns true if suggestion is in list.
 | Contains(ArrayList, String) | Returns true if suggestion is in list.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Score | The score 0-1000 of how suitable suggestion is. -1 if unknown
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Word | The suggested word.
Inheritance Hierarchy
Object
Suggestion


Suggestion Constructor (word, score)

Suggestion Constructor (word, score)
API Documentation ► Keyoti.RapidSpell ► Suggestion ► Suggestion(String, Int32)
Keyoti RapidSpell Web .NET
Creates an instance
Declaration Syntax
C# Visual Basic Visual C++ F#
public Suggestion(
    string word,
    int score
)
Public Sub New (
    word As String,
    score As Integer
)
public:
Suggestion(
    String^ word,
    int score
)
new :
        word : string *
        score : int -> Suggestion
Parameters
word (String)
The suggested word
score (Int32)
The score 0-1000 of how suitable suggestion is.


Contains Method

Contains Method
API Documentation ► Keyoti.RapidSpell ► Suggestion ► Contains()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | Contains(ArrayList, Suggestion) | Returns true if suggestion is in list.
 | Contains(ArrayList, String) | Returns true if suggestion is in list.


Contains Method (list, suggestion)

Contains Method (list, suggestion)
API Documentation ► Keyoti.RapidSpell ► Suggestion ► Contains(ArrayList, Suggestion)
Keyoti RapidSpell Web .NET
Returns true if suggestion is in list.
Declaration Syntax
C# Visual Basic Visual C++ F#
public static bool Contains(
    ArrayList list,
    Suggestion suggestion
)
Public Shared Function Contains (
    list As ArrayList,
    suggestion As Suggestion
) As Boolean
public:
static bool Contains(
    ArrayList^ list,
    Suggestion^ suggestion
)
static member Contains :
        list : ArrayList *
        suggestion : Suggestion -> bool
Parameters
list (ArrayList)
suggestion (Suggestion)
Return Value
Boolean


Contains Method (list, suggestion)

Contains Method (list, suggestion)
API Documentation ► Keyoti.RapidSpell ► Suggestion ► Contains(ArrayList, String)
Keyoti RapidSpell Web .NET
Returns true if suggestion is in list.
Declaration Syntax
C# Visual Basic Visual C++ F#
public static bool Contains(
    ArrayList list,
    string suggestion
)
Public Shared Function Contains (
    list As ArrayList,
    suggestion As String
) As Boolean
public:
static bool Contains(
    ArrayList^ list,
    String^ suggestion
)
static member Contains :
        list : ArrayList *
        suggestion : string -> bool
Parameters
list (ArrayList)
suggestion (String)
Return Value
Boolean


Score Property

Score Property
API Documentation ► Keyoti.RapidSpell ► Suggestion ► Score
Keyoti RapidSpell Web .NET
The score 0-1000 of how suitable suggestion is. -1 if unknown
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual int Score { get; set; }
Public Overridable Property Score As Integer
    Get
    Set
public:
virtual property int Score {
    int get ();
    void set (int value);
}
abstract Score : int with get, set
override Score : int with get, set
Property Value
Int32


Word Property

Word Property
API Documentation ► Keyoti.RapidSpell ► Suggestion ► Word
Keyoti RapidSpell Web .NET
The suggested word.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual string Word { get; set; }
Public Overridable Property Word As String
    Get
    Set
public:
virtual property String^ Word {
    String^ get ();
    void set (String^ value);
}
abstract Word : string with get, set
override Word : string with get, set
Property Value
String


SuggestionMenuActivationType Enumeration

SuggestionMenuActivationType Enumeration
API Documentation ► Keyoti.RapidSpell ► SuggestionMenuActivationType
Keyoti RapidSpell Web .NET
Specifies ways users can activate the suggestions menu.
Declaration Syntax
C# Visual Basic Visual C++ F#
public enum SuggestionMenuActivationType
Public Enumeration SuggestionMenuActivationType
public enum class SuggestionMenuActivationType
type SuggestionMenuActivationType
Members
Member | Description
SingleClick | Activate suggestions menu with single click
DoubleClick | Activate suggestions menu with double click


TextComponentInterfaceType Enumeration

TextComponentInterfaceType Enumeration
API Documentation ► Keyoti.RapidSpell ► TextComponentInterfaceType
Keyoti RapidSpell Web .NET
Enumeration of possible text box interface types.
Declaration Syntax
C# Visual Basic Visual C++ F#
public enum TextComponentInterfaceType
Public Enumeration TextComponentInterfaceType
public enum class TextComponentInterfaceType
type TextComponentInterfaceType
Members
Member | Description
Automatic | Use 'Automatic' to automatically work with plain and most rich text boxes.
Standard | Use 'Standard' for regular HTML text boxes (input type='text' and textarea).
PowerWEBTextBox | Use 'PowerWEBTextBox' for Dart PowerWEB text boxes.
EasyWebEdit | Use 'EasyWebEdit' for EasyWebEdit.net text boxes.
RichTextBox | Use 'RichTextBox' for RichTextBox.com text boxes.
RadEditor | Use 'RadEditor' for Telerik RadEditor text boxes.
Custom | Use 'Custom' to define your own interface.


UndoableStateEventArgs Class

UndoableStateEventArgs Class
API Documentation ► Keyoti.RapidSpell ► UndoableStateEventArgs
Keyoti RapidSpell Web .NET
Args for the events fired when words are ignored.
Declaration Syntax
C# Visual Basic Visual C++ F#
public class UndoableStateEventArgs : EventArgs
Public Class UndoableStateEventArgs
    Inherits EventArgs
public ref class UndoableStateEventArgs : public EventArgs
type UndoableStateEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UndoableStateEventArgs(RapidSpellChecker..::..State) | New
 | BadWord | The word involved.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UndoableState | The state of RapidSpellChecker
 | word | The bad word
Inheritance Hierarchy
Object
 | EventArgs
 |  | UndoableStateEventArgs
 |  |  | WordAddedEventArgs
 |  |  | WordChangedEventArgs
 |  |  | WordIgnoredEventArgs


UndoableStateEventArgs Constructor (undoableState)

UndoableStateEventArgs Constructor (undoableState)
API Documentation ► Keyoti.RapidSpell ► UndoableStateEventArgs ► UndoableStateEventArgs(RapidSpellChecker..::..State)
Keyoti RapidSpell Web .NET
New
Declaration Syntax
C# Visual Basic Visual C++ F#
public UndoableStateEventArgs(
    RapidSpellChecker..::..State undoableState
)
Public Sub New (
    undoableState As RapidSpellChecker..::..State
)
public:
UndoableStateEventArgs(
    RapidSpellChecker..::..State^ undoableState
)
new :
        undoableState : RapidSpellChecker..::..State -> UndoableStateEventArgs
Parameters
undoableState (RapidSpellChecker..::..State)


BadWord Property

BadWord Property
API Documentation ► Keyoti.RapidSpell ► UndoableStateEventArgs ► BadWord
Keyoti RapidSpell Web .NET
The word involved.
Declaration Syntax
C# Visual Basic Visual C++ F#
public BadWord BadWord { get; }
Public ReadOnly Property BadWord As BadWord
    Get
public:
property BadWord^ BadWord {
    BadWord^ get ();
}
member BadWord : BadWord with get
Property Value
BadWord


UndoableState Property

UndoableState Property
API Documentation ► Keyoti.RapidSpell ► UndoableStateEventArgs ► UndoableState
Keyoti RapidSpell Web .NET
The state of RapidSpellChecker
Declaration Syntax
C# Visual Basic Visual C++ F#
public RapidSpellChecker..::..State UndoableState { get; set; }
Public Property UndoableState As RapidSpellChecker..::..State
    Get
    Set
public:
property RapidSpellChecker..::..State^ UndoableState {
    RapidSpellChecker..::..State^ get ();
    void set (RapidSpellChecker..::..State^ value);
}
member UndoableState : RapidSpellChecker..::..State with get, set
Property Value
RapidSpellChecker..::..State


word Field

word Field
API Documentation ► Keyoti.RapidSpell ► UndoableStateEventArgs ► word
Keyoti RapidSpell Web .NET
The bad word
Declaration Syntax
C# Visual Basic Visual C++ F#
protected BadWord word
Protected word As BadWord
protected:
BadWord^ word
val mutable word: BadWord
Field Value
BadWord


UserDictionary Class

UserDictionary Class
API Documentation ► Keyoti.RapidSpell ► UserDictionary
Keyoti RapidSpell Web .NET
Represents the UserDictionary
Declaration Syntax
C# Visual Basic Visual C++ F#
public class UserDictionary
Public Class UserDictionary
public ref class UserDictionary
type UserDictionary =  class end
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserDictionary(String) | Construct a UserDictionary based on the userDictionaryFile, which does not have to exist.
 | UserDictionary()()()() | Constructs an invalid UserDictionary
 | UserDictionary(String, Int32) | Construct a UserDictionary based on the userDictionaryFile, which does not have to exist.
 | AddWord(String) | Tries to add word to this dictionary
 | dictFile | The file containing the dictionary
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | IsValid()()()() | Returns whether the dictionary file is valid.
 | ListChanged | Notifies handlers that the word list has changed.
 | Location | Where to store the user dictionary
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnListChanged(UserDictionary..::..ListChangedEventArgs) | Raises ListChanged
 | ReadAll(ArrayList) | Read the dictionary word list into list.
 | ReloadDictionary()()()() | Loads the dictionary into an internal collection.
 | RemoveWord(String) | Tries to remove word from this dictionary
 | SaveList(ArrayList) | Replaces the contents of the file with newList.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
UserDictionary


UserDictionary Constructor

UserDictionary Constructor
API Documentation ► Keyoti.RapidSpell ► UserDictionary ► UserDictionary()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | UserDictionary(String) | Construct a UserDictionary based on the userDictionaryFile, which does not have to exist.
 | UserDictionary()()()() | Constructs an invalid UserDictionary
 | UserDictionary(String, Int32) | Construct a UserDictionary based on the userDictionaryFile, which does not have to exist.


UserDictionary Constructor

UserDictionary Constructor
API Documentation ► Keyoti.RapidSpell ► UserDictionary ► UserDictionary()()()()
Keyoti RapidSpell Web .NET
Constructs an invalid UserDictionary
Declaration Syntax
C# Visual Basic Visual C++ F#
public UserDictionary()
Public Sub New
public:
UserDictionary()
new : unit -> UserDictionary


UserDictionary Constructor (userDictionaryFile)

UserDictionary Constructor (userDictionaryFile)
API Documentation ► Keyoti.RapidSpell ► UserDictionary ► UserDictionary(String)
Keyoti RapidSpell Web .NET
Construct a UserDictionary based on the userDictionaryFile, which does not have to exist.
Declaration Syntax
C# Visual Basic Visual C++ F#
public UserDictionary(
    string userDictionaryFile
)
Public Sub New (
    userDictionaryFile As String
)
public:
UserDictionary(
    String^ userDictionaryFile
)
new :
        userDictionaryFile : string -> UserDictionary
Parameters
userDictionaryFile (String)
the file used for a user dictionary.
Remarks
User dictionary is limited to 5,000 words.


UserDictionary Constructor (userDictionaryFile, wordLimit)

UserDictionary Constructor (userDictionaryFile, wordLimit)
API Documentation ► Keyoti.RapidSpell ► UserDictionary ► UserDictionary(String, Int32)
Keyoti RapidSpell Web .NET
Construct a UserDictionary based on the userDictionaryFile, which does not have to exist.
Declaration Syntax
C# Visual Basic Visual C++ F#
public UserDictionary(
    string userDictionaryFile,
    int wordLimit
)
Public Sub New (
    userDictionaryFile As String,
    wordLimit As Integer
)
public:
UserDictionary(
    String^ userDictionaryFile,
    int wordLimit
)
new :
        userDictionaryFile : string *
        wordLimit : int -> UserDictionary
Parameters
userDictionaryFile (String)
the file used for a user dictionary.
wordLimit (Int32)
number of words user dictionary is limited to (150,000 max). If wordLimit is <=0 it will be set to 150,000.


AddWord Method (word)

AddWord Method (word)
API Documentation ► Keyoti.RapidSpell ► UserDictionary ► AddWord(String)
Keyoti RapidSpell Web .NET
Tries to add word to this dictionary
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual bool AddWord(
    string word
)
Public Overridable Function AddWord (
    word As String
) As Boolean
public:
virtual bool AddWord(
    String^ word
)
abstract AddWord :
        word : string -> bool
override AddWord :
        word : string -> bool
Parameters
word (String)
String containing the new word
Return Value
Boolean
true if added successfully, false otherwise.


dictFile Field

dictFile Field
API Documentation ► Keyoti.RapidSpell ► UserDictionary ► dictFile
Keyoti RapidSpell Web .NET
The file containing the dictionary
Declaration Syntax
C# Visual Basic Visual C++ F#
public string dictFile
Public dictFile As String
public:
String^ dictFile
val mutable dictFile: string
Field Value
String


IsValid Method

IsValid Method
API Documentation ► Keyoti.RapidSpell ► UserDictionary ► IsValid()()()()
Keyoti RapidSpell Web .NET
Returns whether the dictionary file is valid.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual bool IsValid()
Public Overridable Function IsValid As Boolean
public:
virtual bool IsValid()
abstract IsValid : unit -> bool
override IsValid : unit -> bool
Return Value
Boolean


ListChanged Event

ListChanged Event
API Documentation ► Keyoti.RapidSpell ► UserDictionary ► ListChanged
Keyoti RapidSpell Web .NET
Notifies handlers that the word list has changed.
Declaration Syntax
C# Visual Basic Visual C++ F#
public event UserDictionary..::..ListChangedEventHandler ListChanged
Public Event ListChanged As UserDictionary..::..ListChangedEventHandler
public:
 event UserDictionary..::..ListChangedEventHandler^ ListChanged {
    void add (UserDictionary..::..ListChangedEventHandler^ value);
    void remove (UserDictionary..::..ListChangedEventHandler^ value);
}
member ListChanged : IEvent<UserDictionary..::..ListChangedEventHandler,
    UserDictionary..::..ListChangedEventArgs>
Value
UserDictionary..::..ListChangedEventHandler


Location Property

Location Property
API Documentation ► Keyoti.RapidSpell ► UserDictionary ► Location
Keyoti RapidSpell Web .NET
Where to store the user dictionary
Declaration Syntax
C# Visual Basic Visual C++ F#
public UserDictionary..::..StorageLocation Location { get; set; }
Public Property Location As UserDictionary..::..StorageLocation
    Get
    Set
public:
property UserDictionary..::..StorageLocation Location {
    UserDictionary..::..StorageLocation get ();
    void set (UserDictionary..::..StorageLocation value);
}
member Location : UserDictionary..::..StorageLocation with get, set
Property Value
UserDictionary..::..StorageLocation


OnListChanged Method (e)

OnListChanged Method (e)
API Documentation ► Keyoti.RapidSpell ► UserDictionary ► OnListChanged(UserDictionary..::..ListChangedEventArgs)
Keyoti RapidSpell Web .NET
Raises ListChanged
Declaration Syntax
C# Visual Basic Visual C++ F#
protected virtual void OnListChanged(
    UserDictionary..::..ListChangedEventArgs e
)
Protected Overridable Sub OnListChanged (
    e As UserDictionary..::..ListChangedEventArgs
)
protected:
virtual void OnListChanged(
    UserDictionary..::..ListChangedEventArgs^ e
)
abstract OnListChanged :
        e : UserDictionary..::..ListChangedEventArgs -> unit
override OnListChanged :
        e : UserDictionary..::..ListChangedEventArgs -> unit
Parameters
e (UserDictionary..::..ListChangedEventArgs)


ReadAll Method (list)

ReadAll Method (list)
API Documentation ► Keyoti.RapidSpell ► UserDictionary ► ReadAll(ArrayList)
Keyoti RapidSpell Web .NET
Read the dictionary word list into list.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual int ReadAll(
    ArrayList list
)
Public Overridable Function ReadAll (
    list As ArrayList
) As Integer
public:
virtual int ReadAll(
    ArrayList^ list
)
abstract ReadAll :
        list : ArrayList -> int
override ReadAll :
        list : ArrayList -> int
Parameters
list (ArrayList)
the String array that the word list will be read into.
Return Value
Int32
number of words in list.


ReloadDictionary Method

ReloadDictionary Method
API Documentation ► Keyoti.RapidSpell ► UserDictionary ► ReloadDictionary()()()()
Keyoti RapidSpell Web .NET
Loads the dictionary into an internal collection.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual bool ReloadDictionary()
Public Overridable Function ReloadDictionary As Boolean
public:
virtual bool ReloadDictionary()
abstract ReloadDictionary : unit -> bool
override ReloadDictionary : unit -> bool
Return Value
Boolean
Whether the dictionary was reloaded successfully.
Remarks
The user dictionary can be changed externally (eg. by a different control), and this method is called when that happens to cause the internal collection to be updated.


RemoveWord Method (word)

RemoveWord Method (word)
API Documentation ► Keyoti.RapidSpell ► UserDictionary ► RemoveWord(String)
Keyoti RapidSpell Web .NET
Tries to remove word from this dictionary
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual bool RemoveWord(
    string word
)
Public Overridable Function RemoveWord (
    word As String
) As Boolean
public:
virtual bool RemoveWord(
    String^ word
)
abstract RemoveWord :
        word : string -> bool
override RemoveWord :
        word : string -> bool
Parameters
word (String)
String containing the new word
Return Value
Boolean
true if added successfully, false otherwise.


SaveList Method (newList)

SaveList Method (newList)
API Documentation ► Keyoti.RapidSpell ► UserDictionary ► SaveList(ArrayList)
Keyoti RapidSpell Web .NET
Replaces the contents of the file with newList.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual void SaveList(
    ArrayList newList
)
Public Overridable Sub SaveList (
    newList As ArrayList
)
public:
virtual void SaveList(
    ArrayList^ newList
)
abstract SaveList :
        newList : ArrayList -> unit
override SaveList :
        newList : ArrayList -> unit
Parameters
newList (ArrayList)


UserDictionary.ListChangedEventArgs Class

UserDictionary..::..ListChangedEventArgs Class
API Documentation ► Keyoti.RapidSpell ► UserDictionary ► UserDictionary..::..ListChangedEventArgs
Keyoti RapidSpell Web .NET
Event args for ListChanged event
Declaration Syntax
C# Visual Basic Visual C++ F#
public class ListChangedEventArgs : EventArgs
Public Class ListChangedEventArgs
    Inherits EventArgs
public ref class ListChangedEventArgs : public EventArgs
type ListChangedEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserDictionary..::..ListChangedEventArgs(UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation, String) | New
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Operation | The type of operation
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Word | The word that was added or removed, may be null for ListSave.
Inheritance Hierarchy
Object
 | EventArgs
 |  | UserDictionary..::..ListChangedEventArgs


UserDictionary.ListChangedEventArgs Constructor (op, word)

UserDictionary..::..ListChangedEventArgs Constructor (op, word)
API Documentation ► Keyoti.RapidSpell ► UserDictionary..::..ListChangedEventArgs ► UserDictionary..::..ListChangedEventArgs(UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation, String)
Keyoti RapidSpell Web .NET
New
Declaration Syntax
C# Visual Basic Visual C++ F#
public ListChangedEventArgs(
    UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation op,
    string word
)
Public Sub New (
    op As UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation,
    word As String
)
public:
ListChangedEventArgs(
    UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation op,
    String^ word
)
new :
        op : UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation *
        word : string -> ListChangedEventArgs
Parameters
op (UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation)
word (String)


Operation Property

Operation Property
API Documentation ► Keyoti.RapidSpell ► UserDictionary..::..ListChangedEventArgs ► Operation
Keyoti RapidSpell Web .NET
The type of operation
Declaration Syntax
C# Visual Basic Visual C++ F#
public UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation Operation { get; }
Public ReadOnly Property Operation As UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation
    Get
public:
property UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation Operation {
    UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation get ();
}
member Operation : UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation with get
Property Value
UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation


Word Property

Word Property
API Documentation ► Keyoti.RapidSpell ► UserDictionary..::..ListChangedEventArgs ► Word
Keyoti RapidSpell Web .NET
The word that was added or removed, may be null for ListSave.
Declaration Syntax
C# Visual Basic Visual C++ F#
public string Word { get; }
Public ReadOnly Property Word As String
    Get
public:
property String^ Word {
    String^ get ();
}
member Word : string with get
Property Value
String


UserDictionary.ListChangedEventArgs.ListChangeOperation Enumeration

UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation Enumeration
API Documentation ► Keyoti.RapidSpell ► UserDictionary..::..ListChangedEventArgs ► UserDictionary..::..ListChangedEventArgs..::..ListChangeOperation
Keyoti RapidSpell Web .NET
Types of operation
Declaration Syntax
C# Visual Basic Visual C++ F#
public enum ListChangeOperation
Public Enumeration ListChangeOperation
public enum class ListChangeOperation
type ListChangeOperation
Members
Member | Description
WordAdd | Word added.
WordRemove | Word removed
ListSave | List saved


UserDictionary.ListChangedEventHandler Delegate

UserDictionary..::..ListChangedEventHandler Delegate
API Documentation ► Keyoti.RapidSpell ► UserDictionary ► UserDictionary..::..ListChangedEventHandler
Keyoti RapidSpell Web .NET
Event handler
Declaration Syntax
C# Visual Basic Visual C++ F#
public delegate void ListChangedEventHandler(
    Object s,
    UserDictionary..::..ListChangedEventArgs e
)
Public Delegate Sub ListChangedEventHandler (
    s As Object,
    e As UserDictionary..::..ListChangedEventArgs
)
public delegate void ListChangedEventHandler(
    Object^ s,
    UserDictionary..::..ListChangedEventArgs^ e
)
type ListChangedEventHandler =
    delegate of
        s : Object *
        e : UserDictionary..::..ListChangedEventArgs -> unit
Parameters
s (Object)
e (UserDictionary..::..ListChangedEventArgs)


UserDictionary.StorageLocation Enumeration

UserDictionary..::..StorageLocation Enumeration
API Documentation ► Keyoti.RapidSpell ► UserDictionary ► UserDictionary..::..StorageLocation
Keyoti RapidSpell Web .NET
Location options for storage
Declaration Syntax
C# Visual Basic Visual C++ F#
public enum StorageLocation
Public Enumeration StorageLocation
public enum class StorageLocation
type StorageLocation
Members
Member | Description
File | File based
IsolatedStorage | IsolatedStorage based.


ValidatorNeedsTextEventArgs Class

ValidatorNeedsTextEventArgs Class
API Documentation ► Keyoti.RapidSpell ► ValidatorNeedsTextEventArgs
Keyoti RapidSpell Web .NET
Event args.
Declaration Syntax
C# Visual Basic Visual C++ F#
public class ValidatorNeedsTextEventArgs : EventArgs
Public Class ValidatorNeedsTextEventArgs
    Inherits EventArgs
public ref class ValidatorNeedsTextEventArgs : public EventArgs
type ValidatorNeedsTextEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ValidatorNeedsTextEventArgs(String, String) | Creates a new instance
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TextBoxText | The text to validate.
 | TextComponentID | The TextComponentID set for the RapidSpellWInline.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | ValidatorNeedsTextEventArgs


ValidatorNeedsTextEventArgs Constructor (textBoxText, textComponentID)

ValidatorNeedsTextEventArgs Constructor (textBoxText, textComponentID)
API Documentation ► Keyoti.RapidSpell ► ValidatorNeedsTextEventArgs ► ValidatorNeedsTextEventArgs(String, String)
Keyoti RapidSpell Web .NET
Creates a new instance
Declaration Syntax
C# Visual Basic Visual C++ F#
public ValidatorNeedsTextEventArgs(
    string textBoxText,
    string textComponentID
)
Public Sub New (
    textBoxText As String,
    textComponentID As String
)
public:
ValidatorNeedsTextEventArgs(
    String^ textBoxText,
    String^ textComponentID
)
new :
        textBoxText : string *
        textComponentID : string -> ValidatorNeedsTextEventArgs
Parameters
textBoxText (String)
The text in the textbox if known
textComponentID (String)
The ID of the textbox if known


TextBoxText Property

TextBoxText Property
API Documentation ► Keyoti.RapidSpell ► ValidatorNeedsTextEventArgs ► TextBoxText
Keyoti RapidSpell Web .NET
The text to validate.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual string TextBoxText { get; set; }
Public Overridable Property TextBoxText As String
    Get
    Set
public:
virtual property String^ TextBoxText {
    String^ get ();
    void set (String^ value);
}
abstract TextBoxText : string with get, set
override TextBoxText : string with get, set
Property Value
String


TextComponentID Property

TextComponentID Property
API Documentation ► Keyoti.RapidSpell ► ValidatorNeedsTextEventArgs ► TextComponentID
Keyoti RapidSpell Web .NET
The TextComponentID set for the RapidSpellWInline.
Declaration Syntax
C# Visual Basic Visual C++ F#
public virtual string TextComponentID { get; }
Public Overridable ReadOnly Property TextComponentID As String
    Get
public:
virtual property String^ TextComponentID {
    String^ get ();
}
abstract TextComponentID : string with get
override TextComponentID : string with get
Property Value
String


ValidatorNeedsTextEventHandler Delegate

ValidatorNeedsTextEventHandler Delegate
API Documentation ► Keyoti.RapidSpell ► ValidatorNeedsTextEventHandler
Keyoti RapidSpell Web .NET
Event handler delegate for the ValidatorNeedsText event.
Declaration Syntax
C# Visual Basic Visual C++ F#
public delegate void ValidatorNeedsTextEventHandler(
    Object sender,
    ValidatorNeedsTextEventArgs e
)
Public Delegate Sub ValidatorNeedsTextEventHandler (
    sender As Object,
    e As ValidatorNeedsTextEventArgs
)
public delegate void ValidatorNeedsTextEventHandler(
    Object^ sender,
    ValidatorNeedsTextEventArgs^ e
)
type ValidatorNeedsTextEventHandler =
    delegate of
        sender : Object *
        e : ValidatorNeedsTextEventArgs -> unit
Parameters
sender (Object)
e (ValidatorNeedsTextEventArgs)


WordAddedEventArgs Class

WordAddedEventArgs Class
API Documentation ► Keyoti.RapidSpell ► WordAddedEventArgs
Keyoti RapidSpell Web .NET
Args for the events fired when words are added to the user dictionary.
Declaration Syntax
C# Visual Basic Visual C++ F#
public class WordAddedEventArgs : UndoableStateEventArgs
Public Class WordAddedEventArgs
    Inherits UndoableStateEventArgs
public ref class WordAddedEventArgs : public UndoableStateEventArgs
type WordAddedEventArgs =
    class
        inherit UndoableStateEventArgs
    end
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WordAddedEventArgs(BadWord, RapidSpellChecker..::..State, Object) |
 | BadWord | The word involved. (Inherited from UndoableStateEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TextBox | The current text box, if known.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UndoableState | The state of RapidSpellChecker (Inherited from UndoableStateEventArgs.)
 | word | The bad word (Inherited from UndoableStateEventArgs.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | UndoableStateEventArgs
 |  |  | WordAddedEventArgs


WordAddedEventArgs Constructor (word, undoableState, textBox)

WordAddedEventArgs Constructor (word, undoableState, textBox)
API Documentation ► Keyoti.RapidSpell ► WordAddedEventArgs ► WordAddedEventArgs(BadWord, RapidSpellChecker..::..State, Object)
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public WordAddedEventArgs(
    BadWord word,
    RapidSpellChecker..::..State undoableState,
    Object textBox
)
Public Sub New (
    word As BadWord,
    undoableState As RapidSpellChecker..::..State,
    textBox As Object
)
public:
WordAddedEventArgs(
    BadWord^ word,
    RapidSpellChecker..::..State^ undoableState,
    Object^ textBox
)
new :
        word : BadWord *
        undoableState : RapidSpellChecker..::..State *
        textBox : Object -> WordAddedEventArgs
Parameters
word (BadWord)
undoableState (RapidSpellChecker..::..State)
textBox (Object)


TextBox Property

TextBox Property
API Documentation ► Keyoti.RapidSpell ► WordAddedEventArgs ► TextBox
Keyoti RapidSpell Web .NET
The current text box, if known.
Declaration Syntax
C# Visual Basic Visual C++ F#
public Object TextBox { get; }
Public ReadOnly Property TextBox As Object
    Get
public:
property Object^ TextBox {
    Object^ get ();
}
member TextBox : Object with get
Property Value
Object


WordAddedEventHandler Delegate

WordAddedEventHandler Delegate
API Documentation ► Keyoti.RapidSpell ► WordAddedEventHandler
Keyoti RapidSpell Web .NET
Handler delegate
Declaration Syntax
C# Visual Basic Visual C++ F#
public delegate void WordAddedEventHandler(
    Object sender,
    WordAddedEventArgs e
)
Public Delegate Sub WordAddedEventHandler (
    sender As Object,
    e As WordAddedEventArgs
)
public delegate void WordAddedEventHandler(
    Object^ sender,
    WordAddedEventArgs^ e
)
type WordAddedEventHandler =
    delegate of
        sender : Object *
        e : WordAddedEventArgs -> unit
Parameters
sender (Object)
e (WordAddedEventArgs)


WordChangedEventArgs Class

WordChangedEventArgs Class
API Documentation ► Keyoti.RapidSpell ► WordChangedEventArgs
Keyoti RapidSpell Web .NET
Args for the events fired when words are changed.
Declaration Syntax
C# Visual Basic Visual C++ F#
public class WordChangedEventArgs : UndoableStateEventArgs
Public Class WordChangedEventArgs
    Inherits UndoableStateEventArgs
public ref class WordChangedEventArgs : public UndoableStateEventArgs
type WordChangedEventArgs =
    class
        inherit UndoableStateEventArgs
    end
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WordChangedEventArgs(Boolean, BadWord, String, RapidSpellChecker..::..State, ArrayList, Int32, Object) |
 | All | Whether all instances of the word were changed.
 | BadWord | The word involved. (Inherited from UndoableStateEventArgs.)
 | ChangeIndices | List of ints pointing to locations in the text where other instances of the word were changed, if there were any, null/nothing otherwise
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Replacement | The replacement word.
 | TextBox | The current text box, if known.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UndoableState | The state of RapidSpellChecker (Inherited from UndoableStateEventArgs.)
 | word | The bad word (Inherited from UndoableStateEventArgs.)
 | WrappedChangeDelta | The change to indices caused by wrapped text changes
Inheritance Hierarchy
Object
 | EventArgs
 |  | UndoableStateEventArgs
 |  |  | WordChangedEventArgs


WordChangedEventArgs Constructor (all, badWord, replacement, undoableState, changeIndices, wrappedChangeDelta, textBox)

WordChangedEventArgs Constructor (all, badWord, replacement, undoableState, changeIndices, wrappedChangeDelta, textBox)
API Documentation ► Keyoti.RapidSpell ► WordChangedEventArgs ► WordChangedEventArgs(Boolean, BadWord, String, RapidSpellChecker..::..State, ArrayList, Int32, Object)
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public WordChangedEventArgs(
    bool all,
    BadWord badWord,
    string replacement,
    RapidSpellChecker..::..State undoableState,
    ArrayList changeIndices,
    int wrappedChangeDelta,
    Object textBox
)
Public Sub New (
    all As Boolean,
    badWord As BadWord,
    replacement As String,
    undoableState As RapidSpellChecker..::..State,
    changeIndices As ArrayList,
    wrappedChangeDelta As Integer,
    textBox As Object
)
public:
WordChangedEventArgs(
    bool all,
    BadWord^ badWord,
    String^ replacement,
    RapidSpellChecker..::..State^ undoableState,
    ArrayList^ changeIndices,
    int wrappedChangeDelta,
    Object^ textBox
)
new :
        all : bool *
        badWord : BadWord *
        replacement : string *
        undoableState : RapidSpellChecker..::..State *
        changeIndices : ArrayList *
        wrappedChangeDelta : int *
        textBox : Object -> WordChangedEventArgs
Parameters
all (Boolean)
badWord (BadWord)
replacement (String)
undoableState (RapidSpellChecker..::..State)
changeIndices (ArrayList)
wrappedChangeDelta (Int32)
textBox (Object)


All Property

All Property
API Documentation ► Keyoti.RapidSpell ► WordChangedEventArgs ► All
Keyoti RapidSpell Web .NET
Whether all instances of the word were changed.
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool All { get; }
Public ReadOnly Property All As Boolean
    Get
public:
property bool All {
    bool get ();
}
member All : bool with get
Property Value
Boolean


ChangeIndices Property

ChangeIndices Property
API Documentation ► Keyoti.RapidSpell ► WordChangedEventArgs ► ChangeIndices
Keyoti RapidSpell Web .NET
List of ints pointing to locations in the text where other instances of the word were changed, if there were any, null/nothing otherwise
Declaration Syntax
C# Visual Basic Visual C++ F#
public ArrayList ChangeIndices { get; }
Public ReadOnly Property ChangeIndices As ArrayList
    Get
public:
property ArrayList^ ChangeIndices {
    ArrayList^ get ();
}
member ChangeIndices : ArrayList with get
Property Value
ArrayList


Replacement Property

Replacement Property
API Documentation ► Keyoti.RapidSpell ► WordChangedEventArgs ► Replacement
Keyoti RapidSpell Web .NET
The replacement word.
Declaration Syntax
C# Visual Basic Visual C++ F#
public string Replacement { get; }
Public ReadOnly Property Replacement As String
    Get
public:
property String^ Replacement {
    String^ get ();
}
member Replacement : string with get
Property Value
String


TextBox Property

TextBox Property
API Documentation ► Keyoti.RapidSpell ► WordChangedEventArgs ► TextBox
Keyoti RapidSpell Web .NET
The current text box, if known.
Declaration Syntax
C# Visual Basic Visual C++ F#
public Object TextBox { get; }
Public ReadOnly Property TextBox As Object
    Get
public:
property Object^ TextBox {
    Object^ get ();
}
member TextBox : Object with get
Property Value
Object


WrappedChangeDelta Property

WrappedChangeDelta Property
API Documentation ► Keyoti.RapidSpell ► WordChangedEventArgs ► WrappedChangeDelta
Keyoti RapidSpell Web .NET
The change to indices caused by wrapped text changes
Declaration Syntax
C# Visual Basic Visual C++ F#
public int WrappedChangeDelta { get; }
Public ReadOnly Property WrappedChangeDelta As Integer
    Get
public:
property int WrappedChangeDelta {
    int get ();
}
member WrappedChangeDelta : int with get
Property Value
Int32


WordChangedEventHandler Delegate

WordChangedEventHandler Delegate
API Documentation ► Keyoti.RapidSpell ► WordChangedEventHandler
Keyoti RapidSpell Web .NET
Handler delegate
Declaration Syntax
C# Visual Basic Visual C++ F#
public delegate void WordChangedEventHandler(
    Object sender,
    WordChangedEventArgs e
)
Public Delegate Sub WordChangedEventHandler (
    sender As Object,
    e As WordChangedEventArgs
)
public delegate void WordChangedEventHandler(
    Object^ sender,
    WordChangedEventArgs^ e
)
type WordChangedEventHandler =
    delegate of
        sender : Object *
        e : WordChangedEventArgs -> unit
Parameters
sender (Object)
e (WordChangedEventArgs)


WordIgnoredEventArgs Class

WordIgnoredEventArgs Class
API Documentation ► Keyoti.RapidSpell ► WordIgnoredEventArgs
Keyoti RapidSpell Web .NET
Args for the events fired when words are ignored.
Declaration Syntax
C# Visual Basic Visual C++ F#
public class WordIgnoredEventArgs : UndoableStateEventArgs
Public Class WordIgnoredEventArgs
    Inherits UndoableStateEventArgs
public ref class WordIgnoredEventArgs : public UndoableStateEventArgs
type WordIgnoredEventArgs =
    class
        inherit UndoableStateEventArgs
    end
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WordIgnoredEventArgs(Boolean, BadWord, Object, RapidSpellChecker..::..State) |
 | All | Whether all instances of the word were ignored.
 | BadWord | The word involved. (Inherited from UndoableStateEventArgs.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TextBox | The text box object in which the operation was performed, if known.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UndoableState | The state of RapidSpellChecker (Inherited from UndoableStateEventArgs.)
 | word | The bad word (Inherited from UndoableStateEventArgs.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | UndoableStateEventArgs
 |  |  | WordIgnoredEventArgs


WordIgnoredEventArgs Constructor (all, badWord, textBox, undoableState)

WordIgnoredEventArgs Constructor (all, badWord, textBox, undoableState)
API Documentation ► Keyoti.RapidSpell ► WordIgnoredEventArgs ► WordIgnoredEventArgs(Boolean, BadWord, Object, RapidSpellChecker..::..State)
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public WordIgnoredEventArgs(
    bool all,
    BadWord badWord,
    Object textBox,
    RapidSpellChecker..::..State undoableState
)
Public Sub New (
    all As Boolean,
    badWord As BadWord,
    textBox As Object,
    undoableState As RapidSpellChecker..::..State
)
public:
WordIgnoredEventArgs(
    bool all,
    BadWord^ badWord,
    Object^ textBox,
    RapidSpellChecker..::..State^ undoableState
)
new :
        all : bool *
        badWord : BadWord *
        textBox : Object *
        undoableState : RapidSpellChecker..::..State -> WordIgnoredEventArgs
Parameters
all (Boolean)
badWord (BadWord)
textBox (Object)
undoableState (RapidSpellChecker..::..State)


All Property

All Property
API Documentation ► Keyoti.RapidSpell ► WordIgnoredEventArgs ► All
Keyoti RapidSpell Web .NET
Whether all instances of the word were ignored.
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool All { get; }
Public ReadOnly Property All As Boolean
    Get
public:
property bool All {
    bool get ();
}
member All : bool with get
Property Value
Boolean


TextBox Property

TextBox Property
API Documentation ► Keyoti.RapidSpell ► WordIgnoredEventArgs ► TextBox
Keyoti RapidSpell Web .NET
The text box object in which the operation was performed, if known.
Declaration Syntax
C# Visual Basic Visual C++ F#
public Object TextBox { get; }
Public ReadOnly Property TextBox As Object
    Get
public:
property Object^ TextBox {
    Object^ get ();
}
member TextBox : Object with get
Property Value
Object
Remarks
This is null when the event originates in RapidSpellChecker


WordIgnoredEventHandler Delegate

WordIgnoredEventHandler Delegate
API Documentation ► Keyoti.RapidSpell ► WordIgnoredEventHandler
Keyoti RapidSpell Web .NET
Handler delegate
Declaration Syntax
C# Visual Basic Visual C++ F#
public delegate void WordIgnoredEventHandler(
    Object sender,
    WordIgnoredEventArgs e
)
Public Delegate Sub WordIgnoredEventHandler (
    sender As Object,
    e As WordIgnoredEventArgs
)
public delegate void WordIgnoredEventHandler(
    Object^ sender,
    WordIgnoredEventArgs^ e
)
type WordIgnoredEventHandler =
    delegate of
        sender : Object *
        e : WordIgnoredEventArgs -> unit
Parameters
sender (Object)
e (WordIgnoredEventArgs)


WordOccurrence Class

WordOccurrence Class
API Documentation ► Keyoti.RapidSpell ► WordOccurrence
Keyoti RapidSpell Web .NET
Represents a word in the text.
Declaration Syntax
C# Visual Basic Visual C++ F#
public class WordOccurrence
Public Class WordOccurrence
public ref class WordOccurrence
type WordOccurrence =  class end
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WordOccurrence(String, Int32, Int32) | Constructs a BadWord instance.
 | caretEnd | End of word
 | caretStart | Start of word
 | EndPosition | Gets the position of the end of this word in the main text.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetEndPosition()()()() | Gets the position of the end of this word in the main text.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStartPosition()()()() | Gets the position of the start of this word in the main text.
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GetWord()()()() | Gets the String of this bad word.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | StartPosition | Gets the position of the start of this word in the main text.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Word | Gets the string of this bad word.
Inheritance Hierarchy
Object
 | WordOccurrence
 |  | BadWord


WordOccurrence Constructor (word, caretStart, caretEnd)

WordOccurrence Constructor (word, caretStart, caretEnd)
API Documentation ► Keyoti.RapidSpell ► WordOccurrence ► WordOccurrence(String, Int32, Int32)
Keyoti RapidSpell Web .NET
Constructs a BadWord instance.
Declaration Syntax
C# Visual Basic Visual C++ F#
public WordOccurrence(
    string word,
    int caretStart,
    int caretEnd
)
Public Sub New (
    word As String,
    caretStart As Integer,
    caretEnd As Integer
)
public:
WordOccurrence(
    String^ word,
    int caretStart,
    int caretEnd
)
new :
        word : string *
        caretStart : int *
        caretEnd : int -> WordOccurrence
Parameters
word (String)
the word String that is misspelt
caretStart (Int32)
the position in the original text
caretEnd (Int32)
the end position in the text


caretEnd Field

caretEnd Field
API Documentation ► Keyoti.RapidSpell ► WordOccurrence ► caretEnd
Keyoti RapidSpell Web .NET
End of word
Declaration Syntax
C# Visual Basic Visual C++ F#
protected int caretEnd
Protected caretEnd As Integer
protected:
int caretEnd
val mutable caretEnd: int
Field Value
Int32


caretStart Field

caretStart Field
API Documentation ► Keyoti.RapidSpell ► WordOccurrence ► caretStart
Keyoti RapidSpell Web .NET
Start of word
Declaration Syntax
C# Visual Basic Visual C++ F#
protected int caretStart
Protected caretStart As Integer
protected:
int caretStart
val mutable caretStart: int
Field Value
Int32


EndPosition Property

EndPosition Property
API Documentation ► Keyoti.RapidSpell ► WordOccurrence ► EndPosition
Keyoti RapidSpell Web .NET
Gets the position of the end of this word in the main text.
Declaration Syntax
C# Visual Basic Visual C++ F#
public int EndPosition { get; set; }
Public Property EndPosition As Integer
    Get
    Set
public:
property int EndPosition {
    int get ();
    void set (int value);
}
member EndPosition : int with get, set
Property Value
Int32


GetEndPosition Method

GetEndPosition Method
API Documentation ► Keyoti.RapidSpell ► WordOccurrence ► GetEndPosition()()()()
Keyoti RapidSpell Web .NET
Gets the position of the end of this word in the main text.
Declaration Syntax
C# Visual Basic Visual C++ F#
public int GetEndPosition()
Public Function GetEndPosition As Integer
public:
int GetEndPosition()
member GetEndPosition : unit -> int
Return Value
Int32
int position in the text where this word ends


GetStartPosition Method

GetStartPosition Method
API Documentation ► Keyoti.RapidSpell ► WordOccurrence ► GetStartPosition()()()()
Keyoti RapidSpell Web .NET
Gets the position of the start of this word in the main text.
Declaration Syntax
C# Visual Basic Visual C++ F#
public int GetStartPosition()
Public Function GetStartPosition As Integer
public:
int GetStartPosition()
member GetStartPosition : unit -> int
Return Value
Int32
int position in the text where this word starts.


GetWord Method

GetWord Method
API Documentation ► Keyoti.RapidSpell ► WordOccurrence ► GetWord()()()()
Keyoti RapidSpell Web .NET
Gets the String of this bad word.
Declaration Syntax
C# Visual Basic Visual C++ F#
public string GetWord()
Public Function GetWord As String
public:
String^ GetWord()
member GetWord : unit -> string
Return Value
String
String in this BadWord


StartPosition Property

StartPosition Property
API Documentation ► Keyoti.RapidSpell ► WordOccurrence ► StartPosition
Keyoti RapidSpell Web .NET
Gets the position of the start of this word in the main text.
Declaration Syntax
C# Visual Basic Visual C++ F#
public int StartPosition { get; set; }
Public Property StartPosition As Integer
    Get
    Set
public:
property int StartPosition {
    int get ();
    void set (int value);
}
member StartPosition : int with get, set
Property Value
Int32


Word Property

Word Property
API Documentation ► Keyoti.RapidSpell ► WordOccurrence ► Word
Keyoti RapidSpell Web .NET
Gets the string of this bad word.
Declaration Syntax
C# Visual Basic Visual C++ F#
public string Word { get; set; }
Public Property Word As String
    Get
    Set
public:
property String^ Word {
    String^ get ();
    void set (String^ value);
}
member Word : string with get, set
Property Value
String


WordRemovedEventArgs Class

WordRemovedEventArgs Class
API Documentation ► Keyoti.RapidSpell ► WordRemovedEventArgs
Keyoti RapidSpell Web .NET
Args for the events fired when words are removed from the user dictionary.
Declaration Syntax
C# Visual Basic Visual C++ F#
public class WordRemovedEventArgs : EventArgs
Public Class WordRemovedEventArgs
    Inherits EventArgs
public ref class WordRemovedEventArgs : public EventArgs
type WordRemovedEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WordRemovedEventArgs(String) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Word | The word that was removed
Inheritance Hierarchy
Object
 | EventArgs
 |  | WordRemovedEventArgs


WordRemovedEventArgs Constructor (word)

WordRemovedEventArgs Constructor (word)
API Documentation ► Keyoti.RapidSpell ► WordRemovedEventArgs ► WordRemovedEventArgs(String)
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public WordRemovedEventArgs(
    string word
)
Public Sub New (
    word As String
)
public:
WordRemovedEventArgs(
    String^ word
)
new :
        word : string -> WordRemovedEventArgs
Parameters
word (String)


Word Property

Word Property
API Documentation ► Keyoti.RapidSpell ► WordRemovedEventArgs ► Word
Keyoti RapidSpell Web .NET
The word that was removed
Declaration Syntax
C# Visual Basic Visual C++ F#
public string Word { get; }
Public ReadOnly Property Word As String
    Get
public:
property String^ Word {
    String^ get ();
}
member Word : string with get
Property Value
String


WordRemovedEventHandler Delegate

WordRemovedEventHandler Delegate
API Documentation ► Keyoti.RapidSpell ► WordRemovedEventHandler
Keyoti RapidSpell Web .NET
Handler delegate
Declaration Syntax
C# Visual Basic Visual C++ F#
public delegate void WordRemovedEventHandler(
    Object sender,
    WordRemovedEventArgs e
)
Public Delegate Sub WordRemovedEventHandler (
    sender As Object,
    e As WordRemovedEventArgs
)
public delegate void WordRemovedEventHandler(
    Object^ sender,
    WordRemovedEventArgs^ e
)
type WordRemovedEventHandler =
    delegate of
        sender : Object *
        e : WordRemovedEventArgs -> unit
Parameters
sender (Object)
e (WordRemovedEventArgs)


Keyoti.RapidSpell.ASMX Namespace

Keyoti.RapidSpell.ASMX Namespace
API Documentation ► Keyoti.RapidSpell.ASMX
Keyoti RapidSpell Web .NET
Types
All Types Classes
Icon | Type | Description
 | AddWordData |
 | BoolWrapper |
 | InlineService |


AddWordData Class

AddWordData Class
API Documentation ► Keyoti.RapidSpell.ASMX ► AddWordData
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public class AddWordData
Public Class AddWordData
public ref class AddWordData
type AddWordData =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AddWordData()()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | GuiLanguage |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UserDictionaryFile |
 | Word |
Inheritance Hierarchy
Object
AddWordData


AddWordData Constructor

AddWordData Constructor
API Documentation ► Keyoti.RapidSpell.ASMX ► AddWordData ► AddWordData()()()()
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public AddWordData()
Public Sub New
public:
AddWordData()
new : unit -> AddWordData


GuiLanguage Property

GuiLanguage Property
API Documentation ► Keyoti.RapidSpell.ASMX ► AddWordData ► GuiLanguage
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public string GuiLanguage { get; set; }
Public Property GuiLanguage As String
    Get
    Set
public:
property String^ GuiLanguage {
    String^ get ();
    void set (String^ value);
}
member GuiLanguage : string with get, set
Property Value
String


UserDictionaryFile Property

UserDictionaryFile Property
API Documentation ► Keyoti.RapidSpell.ASMX ► AddWordData ► UserDictionaryFile
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public string UserDictionaryFile { get; set; }
Public Property UserDictionaryFile As String
    Get
    Set
public:
property String^ UserDictionaryFile {
    String^ get ();
    void set (String^ value);
}
member UserDictionaryFile : string with get, set
Property Value
String


Word Property

Word Property
API Documentation ► Keyoti.RapidSpell.ASMX ► AddWordData ► Word
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public string Word { get; set; }
Public Property Word As String
    Get
    Set
public:
property String^ Word {
    String^ get ();
    void set (String^ value);
}
member Word : string with get, set
Property Value
String


BoolWrapper Class

BoolWrapper Class
API Documentation ► Keyoti.RapidSpell.ASMX ► BoolWrapper
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public class BoolWrapper
Public Class BoolWrapper
public ref class BoolWrapper
type BoolWrapper =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BoolWrapper()()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | value |
Inheritance Hierarchy
Object
BoolWrapper


BoolWrapper Constructor

BoolWrapper Constructor
API Documentation ► Keyoti.RapidSpell.ASMX ► BoolWrapper ► BoolWrapper()()()()
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public BoolWrapper()
Public Sub New
public:
BoolWrapper()
new : unit -> BoolWrapper


value Property

value Property
API Documentation ► Keyoti.RapidSpell.ASMX ► BoolWrapper ► value
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool value { get; set; }
Public Property value As Boolean
    Get
    Set
public:
property bool value {
    bool get ();
    void set (bool value);
}
member value : bool with get, set
Property Value
Boolean


InlineService Class

InlineService Class
API Documentation ► Keyoti.RapidSpell.ASMX ► InlineService
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public class InlineService : WebService
Public Class InlineService
    Inherits WebService
public ref class InlineService : public WebService
type InlineService =
    class
        inherit WebService
    end
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InlineService()()()() |
 | AddWord(String) |
 | Application | Gets the application object for the current HTTP request. (Inherited from WebService.)
 | CheckMulti(String) |
 | Container | Gets the container for the component. (Inherited from MarshalByValueComponent.)
 | Context | Gets the ASP.NET HttpContext for the current request, which encapsulates all HTTP-specific context used by the HTTP server to process Web requests. (Inherited from WebService.)
 | DesignMode | Gets a value indicating whether the component is currently in design mode. (Inherited from MarshalByValueComponent.)
 | Dispose()()()() | Releases all resources used by the MarshalByValueComponent. (Inherited from MarshalByValueComponent.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources. (Inherited from MarshalByValueComponent.)
 | Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from MarshalByValueComponent.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this component. (Inherited from MarshalByValueComponent.)
 | Finalize()()()() | (Inherited from MarshalByValueComponent.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetService(Type) | Gets the implementer of the IServiceProvider. (Inherited from MarshalByValueComponent.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemoteAddress |
 | Server | Gets the HttpServerUtility for the current request. (Inherited from WebService.)
 | ServerAddress |
 | ServerName |
 | Session | Gets the HttpSessionState instance for the current request. (Inherited from WebService.)
 | Site | Gets or sets the site of the component. (Inherited from MarshalByValueComponent.)
 | SoapVersion | Gets the version of the SOAP protocol used to make the SOAP request to the XML Web service. (Inherited from WebService.)
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from MarshalByValueComponent.)
 | User | Gets the ASP.NET server User object. Can be used to authenticate whether a user is authorized to execute the request. (Inherited from WebService.)
Inheritance Hierarchy
Object
 | MarshalByValueComponent
 |  | WebService
 |  |  | InlineService


InlineService Constructor

InlineService Constructor
API Documentation ► Keyoti.RapidSpell.ASMX ► InlineService ► InlineService()()()()
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public InlineService()
Public Sub New
public:
InlineService()
new : unit -> InlineService


AddWord Method (data)

AddWord Method (data)
API Documentation ► Keyoti.RapidSpell.ASMX ► InlineService ► AddWord(String)
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public string AddWord(
    string data
)
Public Function AddWord (
    data As String
) As String
public:
String^ AddWord(
    String^ data
)
member AddWord :
        data : string -> string
Parameters
data (String)
Return Value
String


CheckMulti Method (data)

CheckMulti Method (data)
API Documentation ► Keyoti.RapidSpell.ASMX ► InlineService ► CheckMulti(String)
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public string CheckMulti(
    string data
)
Public Function CheckMulti (
    data As String
) As String
public:
String^ CheckMulti(
    String^ data
)
member CheckMulti :
        data : string -> string
Parameters
data (String)
Return Value
String


RemoteAddress Property

RemoteAddress Property
API Documentation ► Keyoti.RapidSpell.ASMX ► InlineService ► RemoteAddress
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public string RemoteAddress { get; }
Public ReadOnly Property RemoteAddress As String
    Get
public:
property String^ RemoteAddress {
    String^ get ();
}
member RemoteAddress : string with get
Property Value
String


ServerAddress Property

ServerAddress Property
API Documentation ► Keyoti.RapidSpell.ASMX ► InlineService ► ServerAddress
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public string ServerAddress { get; }
Public ReadOnly Property ServerAddress As String
    Get
public:
property String^ ServerAddress {
    String^ get ();
}
member ServerAddress : string with get
Property Value
String


ServerName Property

ServerName Property
API Documentation ► Keyoti.RapidSpell.ASMX ► InlineService ► ServerName
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public string ServerName { get; }
Public ReadOnly Property ServerName As String
    Get
public:
property String^ ServerName {
    String^ get ();
}
member ServerName : string with get
Property Value
String


Keyoti.RapidSpell.Event Namespace

Keyoti.RapidSpell.Event Namespace
API Documentation ► Keyoti.RapidSpell.Event
Keyoti RapidSpell Web .NET
The namespace for events.

Events

Types
All Types Classes
Icon | Type | Description
 | ChangeWordEventArgs | Holds data for the ChangeWord event.


ChangeWordEventArgs Class

ChangeWordEventArgs Class
API Documentation ► Keyoti.RapidSpell.Event ► ChangeWordEventArgs
Keyoti RapidSpell Web .NET
Holds data for the ChangeWord event.
Declaration Syntax
C# Visual Basic Visual C++ F#
public class ChangeWordEventArgs : EventArgs
Public Class ChangeWordEventArgs
    Inherits EventArgs
public ref class ChangeWordEventArgs : public EventArgs
type ChangeWordEventArgs =
    class
        inherit EventArgs
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChangeWordEventArgs(String, String, Int32) | Creates a new ChangeWordEventArgs
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | Index | The index of the word in the text
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewWord | The new word
 | OldWord | The word being replaced
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | ChangeWordEventArgs


ChangeWordEventArgs Constructor (oldWord, newWord, index)

ChangeWordEventArgs Constructor (oldWord, newWord, index)
API Documentation ► Keyoti.RapidSpell.Event ► ChangeWordEventArgs ► ChangeWordEventArgs(String, String, Int32)
Keyoti RapidSpell Web .NET
Creates a new ChangeWordEventArgs
Declaration Syntax
C# Visual Basic Visual C++ F#
public ChangeWordEventArgs(
    string oldWord,
    string newWord,
    int index
)
Public Sub New (
    oldWord As String,
    newWord As String,
    index As Integer
)
public:
ChangeWordEventArgs(
    String^ oldWord,
    String^ newWord,
    int index
)
new :
        oldWord : string *
        newWord : string *
        index : int -> ChangeWordEventArgs
Parameters
oldWord (String)
newWord (String)
index (Int32)


Index Property

Index Property
API Documentation ► Keyoti.RapidSpell.Event ► ChangeWordEventArgs ► Index
Keyoti RapidSpell Web .NET
The index of the word in the text
Declaration Syntax
C# Visual Basic Visual C++ F#
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
public:
property int Index {
    int get ();
}
member Index : int with get
Property Value
Int32


NewWord Property

NewWord Property
API Documentation ► Keyoti.RapidSpell.Event ► ChangeWordEventArgs ► NewWord
Keyoti RapidSpell Web .NET
The new word
Declaration Syntax
C# Visual Basic Visual C++ F#
public string NewWord { get; }
Public ReadOnly Property NewWord As String
    Get
public:
property String^ NewWord {
    String^ get ();
}
member NewWord : string with get
Property Value
String


OldWord Property

OldWord Property
API Documentation ► Keyoti.RapidSpell.Event ► ChangeWordEventArgs ► OldWord
Keyoti RapidSpell Web .NET
The word being replaced
Declaration Syntax
C# Visual Basic Visual C++ F#
public string OldWord { get; }
Public ReadOnly Property OldWord As String
    Get
public:
property String^ OldWord {
    String^ get ();
}
member OldWord : string with get
Property Value
String


Keyoti.RapidSpell.fastJSON Namespace

Keyoti.RapidSpell.fastJSON Namespace
API Documentation ► Keyoti.RapidSpell.fastJSON
Keyoti RapidSpell Web .NET
Types
All Types Classes Delegates
Icon | Type | Description
 | DatasetSchema |
 | Deserialize |
 | JSON |
 | JSONParameters |
 | SafeDictionary<(Of <(<'TKey, TValue>)>)> |
 | Serialize |


DatasetSchema Class

DatasetSchema Class
API Documentation ► Keyoti.RapidSpell.fastJSON ► DatasetSchema
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public sealed class DatasetSchema
Public NotInheritable Class DatasetSchema
public ref class DatasetSchema sealed
[<SealedAttribute>]
type DatasetSchema =  class end
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DatasetSchema()()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | Info |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
DatasetSchema


DatasetSchema Constructor

DatasetSchema Constructor
API Documentation ► Keyoti.RapidSpell.fastJSON ► DatasetSchema ► DatasetSchema()()()()
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public DatasetSchema()
Public Sub New
public:
DatasetSchema()
new : unit -> DatasetSchema


Info Field

Info Field
API Documentation ► Keyoti.RapidSpell.fastJSON ► DatasetSchema ► Info
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public List<string> Info
Public Info As List(Of String)
public:
List<String^>^ Info
val mutable Info: List<string>
Field Value
List <(Of <(<' String >)>)>


Name Field

Name Field
API Documentation ► Keyoti.RapidSpell.fastJSON ► DatasetSchema ► Name
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public string Name
Public Name As String
public:
String^ Name
val mutable Name: string
Field Value
String


Deserialize Delegate

Deserialize Delegate
API Documentation ► Keyoti.RapidSpell.fastJSON ► Deserialize
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public delegate Object Deserialize(
    string data
)
Public Delegate Function Deserialize (
    data As String
) As Object
public delegate Object^ Deserialize(
    String^ data
)
type Deserialize =
    delegate of
        data : string -> Object
Parameters
data (String)
Return Value
Object


JSON Class

JSON Class
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSON
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public static class JSON
Public NotInheritable Class JSON
public ref class JSON abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type JSON =  class end
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Beautify(String) | Create a human readable string from the json
 | ClearReflectionCache()()()() | Clear the internal reflection cache so you can start from new (you will loose performance)
 | DeepCopy(Object) | Deep copy an object i.e. clone to a new object
 | DeepCopy<(Of <<'(T>)>>)(T) |
 | FillObject(Object, String) | Fill a given object with the json represenation
 | Parameters | Globally set-able parameters for controlling the serializer
 | Parse(String) | Parse a json string and generate a Dictionary<string,object> or List<object> structure
 | RegisterCustomType(Type, Serialize, Deserialize) | Register custom type handlers for your own types not natively handled by fastJSON
 | ToJSON(Object) | Create a json representation for an object
 | ToJSON(Object, JSONParameters) | Create a json representation for an object with parameter override on this call
 | ToNiceJSON(Object, JSONParameters) | Create a formatted json string (beautified) from an object
 | ToObject<(Of <<'(T>)>>)(String) | Create a typed generic object from the json
 | ToObject<(Of <<'(T>)>>)(String, JSONParameters) | Create a typed generic object from the json with parameter override on this call
 | ToObject(String) | Create an object from the json
 | ToObject(String, JSONParameters) | Create an object from the json with parameter override on this call
 | ToObject(String, Type) | Create an object of type from the json
Inheritance Hierarchy
Object
JSON


Beautify Method (input)

Beautify Method (input)
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSON ► Beautify(String)
Keyoti RapidSpell Web .NET
Create a human readable string from the json
Declaration Syntax
C# Visual Basic Visual C++ F#
public static string Beautify(
    string input
)
Public Shared Function Beautify (
    input As String
) As String
public:
static String^ Beautify(
    String^ input
)
static member Beautify :
        input : string -> string
Parameters
input (String)
Return Value
String


ClearReflectionCache Method

ClearReflectionCache Method
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSON ► ClearReflectionCache()()()()
Keyoti RapidSpell Web .NET
Clear the internal reflection cache so you can start from new (you will loose performance)
Declaration Syntax
C# Visual Basic Visual C++ F#
public static void ClearReflectionCache()
Public Shared Sub ClearReflectionCache
public:
static void ClearReflectionCache()
static member ClearReflectionCache : unit -> unit


DeepCopy Method

DeepCopy Method
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSON ► DeepCopy()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | DeepCopy(Object) | Deep copy an object i.e. clone to a new object
 | DeepCopy<(Of <<'(T>)>>)(T) |


DeepCopy Method (obj)

DeepCopy Method (obj)
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSON ► DeepCopy(Object)
Keyoti RapidSpell Web .NET
Deep copy an object i.e. clone to a new object
Declaration Syntax
C# Visual Basic Visual C++ F#
public static Object DeepCopy(
    Object obj
)
Public Shared Function DeepCopy (
    obj As Object
) As Object
public:
static Object^ DeepCopy(
    Object^ obj
)
static member DeepCopy :
        obj : Object -> Object
Parameters
obj (Object)
Return Value
Object


DeepCopy Method (obj)

DeepCopy<(Of <(<'T>)>)> Method (obj)
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSON ► DeepCopy<(Of <<'(T>)>>)(T)
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public static T DeepCopy<T>(
    T obj
)

Public Shared Function DeepCopy(Of T) (
    obj As T
) As T
public:
generic<typename T>
static T DeepCopy(
    T obj
)
static member DeepCopy :
        obj : 'T -> 'T
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:Keyoti.RapidSpell.fastJSON.JSON.DeepCopy``1(``0)"]

Parameters
obj (T)
Return Value
T


FillObject Method (input, json)

FillObject Method (input, json)
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSON ► FillObject(Object, String)
Keyoti RapidSpell Web .NET
Fill a given object with the json represenation
Declaration Syntax
C# Visual Basic Visual C++ F#
public static Object FillObject(
    Object input,
    string json
)
Public Shared Function FillObject (
    input As Object,
    json As String
) As Object
public:
static Object^ FillObject(
    Object^ input,
    String^ json
)
static member FillObject :
        input : Object *
        json : string -> Object
Parameters
input (Object)
json (String)
Return Value
Object


Parameters Field

Parameters Field
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSON ► Parameters
Keyoti RapidSpell Web .NET
Globally set-able parameters for controlling the serializer
Declaration Syntax
C# Visual Basic Visual C++ F#
public static JSONParameters Parameters
Public Shared Parameters As JSONParameters
public:
static JSONParameters^ Parameters
static val mutable Parameters: JSONParameters
Field Value
JSONParameters


Parse Method (json)

Parse Method (json)
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSON ► Parse(String)
Keyoti RapidSpell Web .NET
Parse a json string and generate a Dictionary<string,object> or List<object> structure
Declaration Syntax
C# Visual Basic Visual C++ F#
public static Object Parse(
    string json
)
Public Shared Function Parse (
    json As String
) As Object
public:
static Object^ Parse(
    String^ json
)
static member Parse :
        json : string -> Object
Parameters
json (String)
Return Value
Object


RegisterCustomType Method (type, serializer, deserializer)

RegisterCustomType Method (type, serializer, deserializer)
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSON ► RegisterCustomType(Type, Serialize, Deserialize)
Keyoti RapidSpell Web .NET
Register custom type handlers for your own types not natively handled by fastJSON
Declaration Syntax
C# Visual Basic Visual C++ F#
public static void RegisterCustomType(
    Type type,
    Serialize serializer,
    Deserialize deserializer
)
Public Shared Sub RegisterCustomType (
    type As Type,
    serializer As Serialize,
    deserializer As Deserialize
)
public:
static void RegisterCustomType(
    Type^ type,
    Serialize^ serializer,
    Deserialize^ deserializer
)
static member RegisterCustomType :
        type : Type *
        serializer : Serialize *
        deserializer : Deserialize -> unit
Parameters
type (Type)
serializer (Serialize)
deserializer (Deserialize)


ToJSON Method

ToJSON Method
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSON ► ToJSON()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | ToJSON(Object) | Create a json representation for an object
 | ToJSON(Object, JSONParameters) | Create a json representation for an object with parameter override on this call


ToJSON Method (obj)

ToJSON Method (obj)
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSON ► ToJSON(Object)
Keyoti RapidSpell Web .NET
Create a json representation for an object
Declaration Syntax
C# Visual Basic Visual C++ F#
public static string ToJSON(
    Object obj
)
Public Shared Function ToJSON (
    obj As Object
) As String
public:
static String^ ToJSON(
    Object^ obj
)
static member ToJSON :
        obj : Object -> string
Parameters
obj (Object)
Return Value
String


ToJSON Method (obj, param)

ToJSON Method (obj, param)
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSON ► ToJSON(Object, JSONParameters)
Keyoti RapidSpell Web .NET
Create a json representation for an object with parameter override on this call
Declaration Syntax
C# Visual Basic Visual C++ F#
public static string ToJSON(
    Object obj,
    JSONParameters param
)
Public Shared Function ToJSON (
    obj As Object,
    param As JSONParameters
) As String
public:
static String^ ToJSON(
    Object^ obj,
    JSONParameters^ param
)
static member ToJSON :
        obj : Object *
        param : JSONParameters -> string
Parameters
obj (Object)
param (JSONParameters)
Return Value
String


ToNiceJSON Method (obj, param)

ToNiceJSON Method (obj, param)
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSON ► ToNiceJSON(Object, JSONParameters)
Keyoti RapidSpell Web .NET
Create a formatted json string (beautified) from an object
Declaration Syntax
C# Visual Basic Visual C++ F#
public static string ToNiceJSON(
    Object obj,
    JSONParameters param
)
Public Shared Function ToNiceJSON (
    obj As Object,
    param As JSONParameters
) As String
public:
static String^ ToNiceJSON(
    Object^ obj,
    JSONParameters^ param
)
static member ToNiceJSON :
        obj : Object *
        param : JSONParameters -> string
Parameters
obj (Object)
param (JSONParameters)
Return Value
String


ToObject Method

ToObject Method
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSON ► ToObject()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | ToObject<(Of <<'(T>)>>)(String) | Create a typed generic object from the json
 | ToObject<(Of <<'(T>)>>)(String, JSONParameters) | Create a typed generic object from the json with parameter override on this call
 | ToObject(String) | Create an object from the json
 | ToObject(String, JSONParameters) | Create an object from the json with parameter override on this call
 | ToObject(String, Type) | Create an object of type from the json


ToObject Method (json)

ToObject<(Of <(<'T>)>)> Method (json)
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSON ► ToObject<(Of <<'(T>)>>)(String)
Keyoti RapidSpell Web .NET
Create a typed generic object from the json
Declaration Syntax
C# Visual Basic Visual C++ F#
public static T ToObject<T>(
    string json
)

Public Shared Function ToObject(Of T) (
    json As String
) As T
public:
generic<typename T>
static T ToObject(
    String^ json
)
static member ToObject :
        json : string -> 'T
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:Keyoti.RapidSpell.fastJSON.JSON.ToObject``1(System.String)"]

Parameters
json (String)
Return Value
T


ToObject Method (json)

ToObject Method (json)
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSON ► ToObject(String)
Keyoti RapidSpell Web .NET
Create an object from the json
Declaration Syntax
C# Visual Basic Visual C++ F#
public static Object ToObject(
    string json
)
Public Shared Function ToObject (
    json As String
) As Object
public:
static Object^ ToObject(
    String^ json
)
static member ToObject :
        json : string -> Object
Parameters
json (String)
Return Value
Object


ToObject Method (json, param)

ToObject<(Of <(<'T>)>)> Method (json, param)
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSON ► ToObject<(Of <<'(T>)>>)(String, JSONParameters)
Keyoti RapidSpell Web .NET
Create a typed generic object from the json with parameter override on this call
Declaration Syntax
C# Visual Basic Visual C++ F#
public static T ToObject<T>(
    string json,
    JSONParameters param
)

Public Shared Function ToObject(Of T) (
    json As String,
    param As JSONParameters
) As T
public:
generic<typename T>
static T ToObject(
    String^ json,
    JSONParameters^ param
)
static member ToObject :
        json : string *
        param : JSONParameters -> 'T
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:Keyoti.RapidSpell.fastJSON.JSON.ToObject``1(System.String,Keyoti.RapidSpell.fastJSON.JSONParameters)"]

Parameters
json (String)
param (JSONParameters)
Return Value
T


ToObject Method (json, param)

ToObject Method (json, param)
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSON ► ToObject(String, JSONParameters)
Keyoti RapidSpell Web .NET
Create an object from the json with parameter override on this call
Declaration Syntax
C# Visual Basic Visual C++ F#
public static Object ToObject(
    string json,
    JSONParameters param
)
Public Shared Function ToObject (
    json As String,
    param As JSONParameters
) As Object
public:
static Object^ ToObject(
    String^ json,
    JSONParameters^ param
)
static member ToObject :
        json : string *
        param : JSONParameters -> Object
Parameters
json (String)
param (JSONParameters)
Return Value
Object


ToObject Method (json, type)

ToObject Method (json, type)
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSON ► ToObject(String, Type)
Keyoti RapidSpell Web .NET
Create an object of type from the json
Declaration Syntax
C# Visual Basic Visual C++ F#
public static Object ToObject(
    string json,
    Type type
)
Public Shared Function ToObject (
    json As String,
    type As Type
) As Object
public:
static Object^ ToObject(
    String^ json,
    Type^ type
)
static member ToObject :
        json : string *
        type : Type -> Object
Parameters
json (String)
type (Type)
Return Value
Object


JSONParameters Class

JSONParameters Class
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSONParameters
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public sealed class JSONParameters
Public NotInheritable Class JSONParameters
public ref class JSONParameters sealed
[<SealedAttribute>]
type JSONParameters =  class end
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | JSONParameters()()()() |
 | DateTimeMilliseconds | Serialize DateTime milliseconds i.e. yyyy-MM-dd HH:mm:ss.nnn (default = false)
 | EnableAnonymousTypes | Anonymous types have read only properties
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FixValues()()()() |
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | IgnoreAttributes | Ignore attributes to check for (default : XmlIgnoreAttribute)
 | IgnoreCaseOnDeserialize | Obsolete. Ignore case when processing json and deserializing
 | InlineCircularReferences | Inline circular or already seen objects instead of replacement with $i (default = False)
 | KVStyleStringDictionary | Output string key dictionaries as "k"/"v" format (default = False)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParametricConstructorOverride | If you have parametric and no default constructor for you classes (default = False) IMPORTANT NOTE : If True then all initial values within the class will be ignored and will be not set
 | SerializeNullValues | Serialize null values to the output (default = True)
 | SerializerMaxDepth | Maximum depth for circular references in inline mode (default = 20)
 | SerializeToLowerCaseNames | Save property/field names as lowercase (default = false)
 | ShowReadOnlyProperties | Show the readonly properties of types in the output (default = False)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UseEscapedUnicode | Use escaped unicode i.e. \uXXXX format for non ASCII characters (default = True)
 | UseExtensions | Enable fastJSON extensions $types, $type, $map (default = True)
 | UseFastGuid | Use the fast GUID format (default = True)
 | UseOptimizedDatasetSchema | Use the optimized fast Dataset Schema format (default = True)
 | UseUTCDateTime | Use the UTC date format (default = True)
 | UseValuesOfEnums | Output Enum values instead of names (default = False)
 | UsingGlobalTypes | Use the $types extension to optimise the output json (default = True)
Inheritance Hierarchy
Object
JSONParameters


JSONParameters Constructor

JSONParameters Constructor
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSONParameters ► JSONParameters()()()()
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public JSONParameters()
Public Sub New
public:
JSONParameters()
new : unit -> JSONParameters


DateTimeMilliseconds Field

DateTimeMilliseconds Field
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSONParameters ► DateTimeMilliseconds
Keyoti RapidSpell Web .NET
Serialize DateTime milliseconds i.e. yyyy-MM-dd HH:mm:ss.nnn (default = false)
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool DateTimeMilliseconds
Public DateTimeMilliseconds As Boolean
public:
bool DateTimeMilliseconds
val mutable DateTimeMilliseconds: bool
Field Value
Boolean


EnableAnonymousTypes Field

EnableAnonymousTypes Field
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSONParameters ► EnableAnonymousTypes
Keyoti RapidSpell Web .NET
Anonymous types have read only properties
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool EnableAnonymousTypes
Public EnableAnonymousTypes As Boolean
public:
bool EnableAnonymousTypes
val mutable EnableAnonymousTypes: bool
Field Value
Boolean


FixValues Method

FixValues Method
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSONParameters ► FixValues()()()()
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public void FixValues()
Public Sub FixValues
public:
void FixValues()
member FixValues : unit -> unit


IgnoreAttributes Field

IgnoreAttributes Field
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSONParameters ► IgnoreAttributes
Keyoti RapidSpell Web .NET
Ignore attributes to check for (default : XmlIgnoreAttribute)
Declaration Syntax
C# Visual Basic Visual C++ F#
public List<Type> IgnoreAttributes
Public IgnoreAttributes As List(Of Type)
public:
List<Type^>^ IgnoreAttributes
val mutable IgnoreAttributes: List<Type>
Field Value
List <(Of <(<' Type >)>)>


IgnoreCaseOnDeserialize Field

IgnoreCaseOnDeserialize Field
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSONParameters ► IgnoreCaseOnDeserialize
Keyoti RapidSpell Web .NET
Ignore case when processing json and deserializing
Declaration Syntax
C# Visual Basic Visual C++ F#
[ObsoleteAttribute("Not needed anymore and will always match")]
public bool IgnoreCaseOnDeserialize
<ObsoleteAttribute("Not needed anymore and will always match")>
Public IgnoreCaseOnDeserialize As Boolean
public:
[ObsoleteAttribute(L"Not needed anymore and will always match")]
bool IgnoreCaseOnDeserialize
[<ObsoleteAttribute("Not needed anymore and will always match")>]
val mutable IgnoreCaseOnDeserialize: bool
Field Value
Boolean


InlineCircularReferences Field

InlineCircularReferences Field
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSONParameters ► InlineCircularReferences
Keyoti RapidSpell Web .NET
Inline circular or already seen objects instead of replacement with $i (default = False)
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool InlineCircularReferences
Public InlineCircularReferences As Boolean
public:
bool InlineCircularReferences
val mutable InlineCircularReferences: bool
Field Value
Boolean


KVStyleStringDictionary Field

KVStyleStringDictionary Field
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSONParameters ► KVStyleStringDictionary
Keyoti RapidSpell Web .NET
Output string key dictionaries as "k"/"v" format (default = False)
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool KVStyleStringDictionary
Public KVStyleStringDictionary As Boolean
public:
bool KVStyleStringDictionary
val mutable KVStyleStringDictionary: bool
Field Value
Boolean


ParametricConstructorOverride Field

ParametricConstructorOverride Field
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSONParameters ► ParametricConstructorOverride
Keyoti RapidSpell Web .NET
If you have parametric and no default constructor for you classes (default = False) IMPORTANT NOTE : If True then all initial values within the class will be ignored and will be not set
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool ParametricConstructorOverride
Public ParametricConstructorOverride As Boolean
public:
bool ParametricConstructorOverride
val mutable ParametricConstructorOverride: bool
Field Value
Boolean


SerializeNullValues Field

SerializeNullValues Field
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSONParameters ► SerializeNullValues
Keyoti RapidSpell Web .NET
Serialize null values to the output (default = True)
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool SerializeNullValues
Public SerializeNullValues As Boolean
public:
bool SerializeNullValues
val mutable SerializeNullValues: bool
Field Value
Boolean


SerializerMaxDepth Field

SerializerMaxDepth Field
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSONParameters ► SerializerMaxDepth
Keyoti RapidSpell Web .NET
Maximum depth for circular references in inline mode (default = 20)
Declaration Syntax
C# Visual Basic Visual C++ F#
public byte SerializerMaxDepth
Public SerializerMaxDepth As Byte
public:
unsigned char SerializerMaxDepth
val mutable SerializerMaxDepth: byte
Field Value
Byte


SerializeToLowerCaseNames Field

SerializeToLowerCaseNames Field
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSONParameters ► SerializeToLowerCaseNames
Keyoti RapidSpell Web .NET
Save property/field names as lowercase (default = false)
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool SerializeToLowerCaseNames
Public SerializeToLowerCaseNames As Boolean
public:
bool SerializeToLowerCaseNames
val mutable SerializeToLowerCaseNames: bool
Field Value
Boolean


ShowReadOnlyProperties Field

ShowReadOnlyProperties Field
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSONParameters ► ShowReadOnlyProperties
Keyoti RapidSpell Web .NET
Show the readonly properties of types in the output (default = False)
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool ShowReadOnlyProperties
Public ShowReadOnlyProperties As Boolean
public:
bool ShowReadOnlyProperties
val mutable ShowReadOnlyProperties: bool
Field Value
Boolean


UseEscapedUnicode Field

UseEscapedUnicode Field
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSONParameters ► UseEscapedUnicode
Keyoti RapidSpell Web .NET
Use escaped unicode i.e. \uXXXX format for non ASCII characters (default = True)
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool UseEscapedUnicode
Public UseEscapedUnicode As Boolean
public:
bool UseEscapedUnicode
val mutable UseEscapedUnicode: bool
Field Value
Boolean


UseExtensions Field

UseExtensions Field
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSONParameters ► UseExtensions
Keyoti RapidSpell Web .NET
Enable fastJSON extensions $types, $type, $map (default = True)
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool UseExtensions
Public UseExtensions As Boolean
public:
bool UseExtensions
val mutable UseExtensions: bool
Field Value
Boolean


UseFastGuid Field

UseFastGuid Field
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSONParameters ► UseFastGuid
Keyoti RapidSpell Web .NET
Use the fast GUID format (default = True)
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool UseFastGuid
Public UseFastGuid As Boolean
public:
bool UseFastGuid
val mutable UseFastGuid: bool
Field Value
Boolean


UseOptimizedDatasetSchema Field

UseOptimizedDatasetSchema Field
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSONParameters ► UseOptimizedDatasetSchema
Keyoti RapidSpell Web .NET
Use the optimized fast Dataset Schema format (default = True)
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool UseOptimizedDatasetSchema
Public UseOptimizedDatasetSchema As Boolean
public:
bool UseOptimizedDatasetSchema
val mutable UseOptimizedDatasetSchema: bool
Field Value
Boolean


UseUTCDateTime Field

UseUTCDateTime Field
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSONParameters ► UseUTCDateTime
Keyoti RapidSpell Web .NET
Use the UTC date format (default = True)
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool UseUTCDateTime
Public UseUTCDateTime As Boolean
public:
bool UseUTCDateTime
val mutable UseUTCDateTime: bool
Field Value
Boolean


UseValuesOfEnums Field

UseValuesOfEnums Field
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSONParameters ► UseValuesOfEnums
Keyoti RapidSpell Web .NET
Output Enum values instead of names (default = False)
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool UseValuesOfEnums
Public UseValuesOfEnums As Boolean
public:
bool UseValuesOfEnums
val mutable UseValuesOfEnums: bool
Field Value
Boolean


UsingGlobalTypes Field

UsingGlobalTypes Field
API Documentation ► Keyoti.RapidSpell.fastJSON ► JSONParameters ► UsingGlobalTypes
Keyoti RapidSpell Web .NET
Use the $types extension to optimise the output json (default = True)
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool UsingGlobalTypes
Public UsingGlobalTypes As Boolean
public:
bool UsingGlobalTypes
val mutable UsingGlobalTypes: bool
Field Value
Boolean


SafeDictionary(TKey, TValue) Class

SafeDictionary<(Of <(<'TKey, TValue>)>)> Class
API Documentation ► Keyoti.RapidSpell.fastJSON ► SafeDictionary<(Of <(<'TKey, TValue>)>)>
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public sealed class SafeDictionary<TKey, TValue>

Public NotInheritable Class SafeDictionary(Of TKey, TValue)
generic<typename TKey, typename TValue>
public ref class SafeDictionary sealed
[<SealedAttribute>]
type SafeDictionary<'TKey, 'TValue> =  class end
Generic Template Parameters
TKey

[Missing <typeparam name="TKey"/> documentation for "T:Keyoti.RapidSpell.fastJSON.SafeDictionary`2"]

TValue

[Missing <typeparam name="TValue"/> documentation for "T:Keyoti.RapidSpell.fastJSON.SafeDictionary`2"]

Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SafeDictionary<(Of <(<'TKey, TValue>)>)>(Int32) |
 | SafeDictionary<(Of <(<'TKey, TValue>)>)>()()()() |
 | Add(TKey, TValue) |
 | Count |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | Item[([( TKey])]) |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TryGetValue(TKey, TValue%) |
Inheritance Hierarchy
Object
SafeDictionary<(Of <(<'TKey, TValue>)>)>


SafeDictionary(TKey, TValue) Constructor

SafeDictionary<(Of <(<'TKey, TValue>)>)> Constructor
API Documentation ► Keyoti.RapidSpell.fastJSON ► SafeDictionary<(Of <(<'TKey, TValue>)>)> ► SafeDictionary<(Of <(<'TKey, TValue>)>)>()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | SafeDictionary<(Of <(<'TKey, TValue>)>)>(Int32) |
 | SafeDictionary<(Of <(<'TKey, TValue>)>)>()()()() |


SafeDictionary(TKey, TValue) Constructor

SafeDictionary<(Of <(<'TKey, TValue>)>)> Constructor
API Documentation ► Keyoti.RapidSpell.fastJSON ► SafeDictionary<(Of <(<'TKey, TValue>)>)> ► SafeDictionary<(Of <(<'TKey, TValue>)>)>()()()()
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public SafeDictionary()
Public Sub New
public:
SafeDictionary()
new : unit -> SafeDictionary


SafeDictionary(TKey, TValue) Constructor (capacity)

SafeDictionary<(Of <(<'TKey, TValue>)>)> Constructor (capacity)
API Documentation ► Keyoti.RapidSpell.fastJSON ► SafeDictionary<(Of <(<'TKey, TValue>)>)> ► SafeDictionary<(Of <(<'TKey, TValue>)>)>(Int32)
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public SafeDictionary(
    int capacity
)
Public Sub New (
    capacity As Integer
)
public:
SafeDictionary(
    int capacity
)
new :
        capacity : int -> SafeDictionary
Parameters
capacity (Int32)


Add Method (key, value)

Add Method (key, value)
API Documentation ► Keyoti.RapidSpell.fastJSON ► SafeDictionary<(Of <(<'TKey, TValue>)>)> ► Add(TKey, TValue)
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public void Add(
    TKey key,
    TValue value
)
Public Sub Add (
    key As TKey,
    value As TValue
)
public:
void Add(
    TKey key,
    TValue value
)
member Add :
        key : 'TKey *
        value : 'TValue -> unit
Parameters
key (TKey)
value (TValue)


Count Property

Count Property
API Documentation ► Keyoti.RapidSpell.fastJSON ► SafeDictionary<(Of <(<'TKey, TValue>)>)> ► Count
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
member Count : int with get
Property Value
Int32


Item Property (key)

Item Property (key)
API Documentation ► Keyoti.RapidSpell.fastJSON ► SafeDictionary<(Of <(<'TKey, TValue>)>)> ► Item[([( TKey])])
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public TValue this[
    TKey key
] { get; set; }
Public Default Property Item (
    key As TKey
) As TValue
    Get
    Set
public:
property TValue default[TKey key] {
    TValue get (TKey key);
    void set (TKey key, TValue value);
}
member Item : 'TValue with get, set
Parameters
key (TKey)
Property Value
TValue


TryGetValue Method (key, value)

TryGetValue Method (key, value)
API Documentation ► Keyoti.RapidSpell.fastJSON ► SafeDictionary<(Of <(<'TKey, TValue>)>)> ► TryGetValue(TKey, TValue%)
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool TryGetValue(
    TKey key,
    out TValue value
)
Public Function TryGetValue (
    key As TKey,
    <OutAttribute> ByRef value As TValue
) As Boolean
public:
bool TryGetValue(
    TKey key,
    [OutAttribute] TValue% value
)
member TryGetValue :
        key : 'TKey *
        value : 'TValue byref -> bool
Parameters
key (TKey)
value (TValue %)
Return Value
Boolean


Serialize Delegate

Serialize Delegate
API Documentation ► Keyoti.RapidSpell.fastJSON ► Serialize
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public delegate string Serialize(
    Object data
)
Public Delegate Function Serialize (
    data As Object
) As String
public delegate String^ Serialize(
    Object^ data
)
type Serialize =
    delegate of
        data : Object -> string
Parameters
data (Object)
Return Value
String


Keyoti.RapidSpell.WCF Namespace

Keyoti.RapidSpell.WCF Namespace
API Documentation ► Keyoti.RapidSpell.WCF
Keyoti RapidSpell Web .NET
Types
All Types Classes Interfaces
Icon | Type | Description
 | BadWordWrapper |
 | CheckMultiResponseWrapper |
 | CheckResponseWrapper |
 | IInlineService |
 | InlineService |
 | InlineServiceCore |
 | ParameterCollection |
 | SpellParameter |


BadWordWrapper Class

BadWordWrapper Class
API Documentation ► Keyoti.RapidSpell.WCF ► BadWordWrapper
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public class BadWordWrapper
Public Class BadWordWrapper
public ref class BadWordWrapper
type BadWordWrapper =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BadWordWrapper()()()() |
 | end |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exception |
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | start |
 | suggestions |
 | text |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
BadWordWrapper


BadWordWrapper Constructor

BadWordWrapper Constructor
API Documentation ► Keyoti.RapidSpell.WCF ► BadWordWrapper ► BadWordWrapper()()()()
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public BadWordWrapper()
Public Sub New
public:
BadWordWrapper()
new : unit -> BadWordWrapper


end Property

end Property
API Documentation ► Keyoti.RapidSpell.WCF ► BadWordWrapper ► end
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public int end { get; set; }
Public Property end As Integer
    Get
    Set
public:
property int end {
    int get ();
    void set (int value);
}
member end : int with get, set
Property Value
Int32


Exception Property

Exception Property
API Documentation ► Keyoti.RapidSpell.WCF ► BadWordWrapper ► Exception
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public string Exception { get; set; }
Public Property Exception As String
    Get
    Set
public:
property String^ Exception {
    String^ get ();
    void set (String^ value);
}
member Exception : string with get, set
Property Value
String


start Property

start Property
API Documentation ► Keyoti.RapidSpell.WCF ► BadWordWrapper ► start
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public int start { get; set; }
Public Property start As Integer
    Get
    Set
public:
property int start {
    int get ();
    void set (int value);
}
member start : int with get, set
Property Value
Int32


suggestions Property

suggestions Property
API Documentation ► Keyoti.RapidSpell.WCF ► BadWordWrapper ► suggestions
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public string[] suggestions { get; set; }
Public Property suggestions As String()
    Get
    Set
public:
property array<String^>^ suggestions {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member suggestions : string[] with get, set
Property Value
array< String >[]()[][]


text Property

text Property
API Documentation ► Keyoti.RapidSpell.WCF ► BadWordWrapper ► text
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public string text { get; set; }
Public Property text As String
    Get
    Set
public:
property String^ text {
    String^ get ();
    void set (String^ value);
}
member text : string with get, set
Property Value
String


CheckMultiResponseWrapper Class

CheckMultiResponseWrapper Class
API Documentation ► Keyoti.RapidSpell.WCF ► CheckMultiResponseWrapper
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public class CheckMultiResponseWrapper
Public Class CheckMultiResponseWrapper
public ref class CheckMultiResponseWrapper
type CheckMultiResponseWrapper =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CheckMultiResponseWrapper()()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | exception |
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | value |
Inheritance Hierarchy
Object
CheckMultiResponseWrapper


CheckMultiResponseWrapper Constructor

CheckMultiResponseWrapper Constructor
API Documentation ► Keyoti.RapidSpell.WCF ► CheckMultiResponseWrapper ► CheckMultiResponseWrapper()()()()
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public CheckMultiResponseWrapper()
Public Sub New
public:
CheckMultiResponseWrapper()
new : unit -> CheckMultiResponseWrapper


exception Property

exception Property
API Documentation ► Keyoti.RapidSpell.WCF ► CheckMultiResponseWrapper ► exception
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public string exception { get; set; }
Public Property exception As String
    Get
    Set
public:
property String^ exception {
    String^ get ();
    void set (String^ value);
}
member exception : string with get, set
Property Value
String


value Property

value Property
API Documentation ► Keyoti.RapidSpell.WCF ► CheckMultiResponseWrapper ► value
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public BadWordWrapper[][] value { get; set; }
Public Property value As BadWordWrapper()()
    Get
    Set
public:
property array<array<BadWordWrapper^>^>^ value {
    array<array<BadWordWrapper^>^>^ get ();
    void set (array<array<BadWordWrapper^>^>^ value);
}
member value : BadWordWrapper[][] with get, set
Property Value
array<array< BadWordWrapper >[]()[][]>[]()[][]


CheckResponseWrapper Class

CheckResponseWrapper Class
API Documentation ► Keyoti.RapidSpell.WCF ► CheckResponseWrapper
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public class CheckResponseWrapper
Public Class CheckResponseWrapper
public ref class CheckResponseWrapper
type CheckResponseWrapper =  class end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CheckResponseWrapper()()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exception |
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | value |
Inheritance Hierarchy
Object
CheckResponseWrapper


CheckResponseWrapper Constructor

CheckResponseWrapper Constructor
API Documentation ► Keyoti.RapidSpell.WCF ► CheckResponseWrapper ► CheckResponseWrapper()()()()
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public CheckResponseWrapper()
Public Sub New
public:
CheckResponseWrapper()
new : unit -> CheckResponseWrapper


Exception Property

Exception Property
API Documentation ► Keyoti.RapidSpell.WCF ► CheckResponseWrapper ► Exception
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public string Exception { get; set; }
Public Property Exception As String
    Get
    Set
public:
property String^ Exception {
    String^ get ();
    void set (String^ value);
}
member Exception : string with get, set
Property Value
String


value Property

value Property
API Documentation ► Keyoti.RapidSpell.WCF ► CheckResponseWrapper ► value
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public string value { get; set; }
Public Property value As String
    Get
    Set
public:
property String^ value {
    String^ get ();
    void set (String^ value);
}
member value : string with get, set
Property Value
String


IInlineService Interface

IInlineService Interface
API Documentation ► Keyoti.RapidSpell.WCF ► IInlineService
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public interface IInlineService
Public Interface IInlineService
public interface class IInlineService
type IInlineService =  interface end
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddWord(String, String, String) |
 | Check(String, ParameterCollection) |
 | CheckMulti(array<ParameterCollection>[]()[][]) |


AddWord Method (Word, GuiLanguage, UserDictionaryFile)

AddWord Method (Word, GuiLanguage, UserDictionaryFile)
API Documentation ► Keyoti.RapidSpell.WCF ► IInlineService ► AddWord(String, String, String)
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
bool AddWord(
    string Word,
    string GuiLanguage,
    string UserDictionaryFile
)
Function AddWord (
    Word As String,
    GuiLanguage As String,
    UserDictionaryFile As String
) As Boolean
bool AddWord(
    String^ Word,
    String^ GuiLanguage,
    String^ UserDictionaryFile
)
abstract AddWord :
        Word : string *
        GuiLanguage : string *
        UserDictionaryFile : string -> bool
Parameters
Word (String)
GuiLanguage (String)
UserDictionaryFile (String)
Return Value
Boolean


Check Method (textToCheck, parameters)

Check Method (textToCheck, parameters)
API Documentation ► Keyoti.RapidSpell.WCF ► IInlineService ► Check(String, ParameterCollection)
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
CheckResponseWrapper Check(
    string textToCheck,
    ParameterCollection parameters
)
Function Check (
    textToCheck As String,
    parameters As ParameterCollection
) As CheckResponseWrapper
CheckResponseWrapper^ Check(
    String^ textToCheck,
    ParameterCollection^ parameters
)
abstract Check :
        textToCheck : string *
        parameters : ParameterCollection -> CheckResponseWrapper
Parameters
textToCheck (String)
parameters (ParameterCollection)
Return Value
CheckResponseWrapper


CheckMulti Method (parametersArray)

CheckMulti Method (parametersArray)
API Documentation ► Keyoti.RapidSpell.WCF ► IInlineService ► CheckMulti(array<ParameterCollection>[]()[][])
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
CheckMultiResponseWrapper CheckMulti(
    ParameterCollection[] parametersArray
)
Function CheckMulti (
    parametersArray As ParameterCollection()
) As CheckMultiResponseWrapper
CheckMultiResponseWrapper^ CheckMulti(
    array<ParameterCollection^>^ parametersArray
)
abstract CheckMulti :
        parametersArray : ParameterCollection[] -> CheckMultiResponseWrapper
Parameters
parametersArray (array< ParameterCollection >[]()[][])
Return Value
CheckMultiResponseWrapper


InlineService Class

InlineService Class
API Documentation ► Keyoti.RapidSpell.WCF ► InlineService
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public class InlineService : IInlineService
Public Class InlineService
    Implements IInlineService
public ref class InlineService : IInlineService
type InlineService =
    class
        interface IInlineService
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InlineService()()()() |
 | AddWord(String, String, String) |
 | Check(String, ParameterCollection) |
 | CheckMulti(array<ParameterCollection>[]()[][]) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetAllCookiesFromHeader(String, String) |
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ServerAddress |
 | ServerName |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
InlineService


InlineService Constructor

InlineService Constructor
API Documentation ► Keyoti.RapidSpell.WCF ► InlineService ► InlineService()()()()
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public InlineService()
Public Sub New
public:
InlineService()
new : unit -> InlineService


AddWord Method (Word, GuiLanguage, UserDictionaryFile)

AddWord Method (Word, GuiLanguage, UserDictionaryFile)
API Documentation ► Keyoti.RapidSpell.WCF ► InlineService ► AddWord(String, String, String)
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public bool AddWord(
    string Word,
    string GuiLanguage,
    string UserDictionaryFile
)
Public Function AddWord (
    Word As String,
    GuiLanguage As String,
    UserDictionaryFile As String
) As Boolean
public:
virtual bool AddWord(
    String^ Word,
    String^ GuiLanguage,
    String^ UserDictionaryFile
) sealed
abstract AddWord :
        Word : string *
        GuiLanguage : string *
        UserDictionaryFile : string -> bool
override AddWord :
        Word : string *
        GuiLanguage : string *
        UserDictionaryFile : string -> bool
Parameters
Word (String)
GuiLanguage (String)
UserDictionaryFile (String)
Return Value
Boolean


Check Method (textToCheck, parameters)

Check Method (textToCheck, parameters)
API Documentation ► Keyoti.RapidSpell.WCF ► InlineService ► Check(String, ParameterCollection)
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public CheckResponseWrapper Check(
    string textToCheck,
    ParameterCollection parameters
)
Public Function Check (
    textToCheck As String,
    parameters As ParameterCollection
) As CheckResponseWrapper
public:
virtual CheckResponseWrapper^ Check(
    String^ textToCheck,
    ParameterCollection^ parameters
) sealed
abstract Check :
        textToCheck : string *
        parameters : ParameterCollection -> CheckResponseWrapper
override Check :
        textToCheck : string *
        parameters : ParameterCollection -> CheckResponseWrapper
Parameters
textToCheck (String)
parameters (ParameterCollection)
Return Value
CheckResponseWrapper


CheckMulti Method (parametersArray)

CheckMulti Method (parametersArray)
API Documentation ► Keyoti.RapidSpell.WCF ► InlineService ► CheckMulti(array<ParameterCollection>[]()[][])
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public CheckMultiResponseWrapper CheckMulti(
    ParameterCollection[] parametersArray
)
Public Function CheckMulti (
    parametersArray As ParameterCollection()
) As CheckMultiResponseWrapper
public:
virtual CheckMultiResponseWrapper^ CheckMulti(
    array<ParameterCollection^>^ parametersArray
) sealed
abstract CheckMulti :
        parametersArray : ParameterCollection[] -> CheckMultiResponseWrapper
override CheckMulti :
        parametersArray : ParameterCollection[] -> CheckMultiResponseWrapper
Parameters
parametersArray (array< ParameterCollection >[]()[][])
Return Value
CheckMultiResponseWrapper


GetAllCookiesFromHeader Method (strHeader, strHost)

GetAllCookiesFromHeader Method (strHeader, strHost)
API Documentation ► Keyoti.RapidSpell.WCF ► InlineService ► GetAllCookiesFromHeader(String, String)
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public static HttpCookieCollection GetAllCookiesFromHeader(
    string strHeader,
    string strHost
)
Public Shared Function GetAllCookiesFromHeader (
    strHeader As String,
    strHost As String
) As HttpCookieCollection
public:
static HttpCookieCollection^ GetAllCookiesFromHeader(
    String^ strHeader,
    String^ strHost
)
static member GetAllCookiesFromHeader :
        strHeader : string *
        strHost : string -> HttpCookieCollection
Parameters
strHeader (String)
strHost (String)
Return Value
HttpCookieCollection


ServerAddress Property

ServerAddress Property
API Documentation ► Keyoti.RapidSpell.WCF ► InlineService ► ServerAddress
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public string ServerAddress { get; }
Public ReadOnly Property ServerAddress As String
    Get
public:
property String^ ServerAddress {
    String^ get ();
}
member ServerAddress : string with get
Property Value
String


ServerName Property

ServerName Property
API Documentation ► Keyoti.RapidSpell.WCF ► InlineService ► ServerName
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public string ServerName { get; }
Public ReadOnly Property ServerName As String
    Get
public:
property String^ ServerName {
    String^ get ();
}
member ServerName : string with get
Property Value
String


InlineServiceCore Class

InlineServiceCore Class
API Documentation ► Keyoti.RapidSpell.WCF ► InlineServiceCore
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public class InlineServiceCore
Public Class InlineServiceCore
public ref class InlineServiceCore
type InlineServiceCore =  class end
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | InlineServiceCore()()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
InlineServiceCore


InlineServiceCore Constructor

InlineServiceCore Constructor
API Documentation ► Keyoti.RapidSpell.WCF ► InlineServiceCore ► InlineServiceCore()()()()
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public InlineServiceCore()
Public Sub New
public:
InlineServiceCore()
new : unit -> InlineServiceCore


ParameterCollection Class

ParameterCollection Class
API Documentation ► Keyoti.RapidSpell.WCF ► ParameterCollection
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public class ParameterCollection : List<SpellParameter>
Public Class ParameterCollection
    Inherits List(Of SpellParameter)
public ref class ParameterCollection : public List<SpellParameter^>
type ParameterCollection =
    class
        inherit List<SpellParameter>
    end
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ParameterCollection(Int32) | New
 | Add(T) | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | AddRange(IEnumerable<(Of <<'(T>)>>)) | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | AsReadOnly()()()() | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | Clear()()()() | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | Contains(T) | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | ConvertAll<(Of <<'(TOutput>)>>)(Converter<(Of <<'(T, TOutput>)>>)) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(Predicate<(Of <<'(T>)>>)) | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | Find(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | FindAll(Predicate<(Of <<'(T>)>>)) | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | FindLast(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | ForEach(Action<(Of <<'(T>)>>)) | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRange(Int32, Int32) | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | Insert(Int32, T) | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | InsertRange(Int32, IEnumerable<(Of <<'(T>)>>)) | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | Item[([( Int32])]) | Gets a result.
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | RemoveAll(Predicate<(Of <<'(T>)>>)) | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | RemoveRange(Int32, Int32) | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | ToArray()()()() | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TrimExcess()()()() | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
 | TrueForAll(Predicate<(Of <<'(T>)>>)) | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<' SpellParameter >)>)>.)
Inheritance Hierarchy
Object
 | List <(Of <(<' SpellParameter >)>)>
 |  | ParameterCollection


ParameterCollection Constructor (capacity)

ParameterCollection Constructor (capacity)
API Documentation ► Keyoti.RapidSpell.WCF ► ParameterCollection ► ParameterCollection(Int32)
Keyoti RapidSpell Web .NET
New
Declaration Syntax
C# Visual Basic Visual C++ F#
public ParameterCollection(
    int capacity
)
Public Sub New (
    capacity As Integer
)
public:
ParameterCollection(
    int capacity
)
new :
        capacity : int -> ParameterCollection
Parameters
capacity (Int32)


Item Property (index)

Item Property (index)
API Documentation ► Keyoti.RapidSpell.WCF ► ParameterCollection ► Item[([( Int32])])
Keyoti RapidSpell Web .NET
Gets a result.
Declaration Syntax
C# Visual Basic Visual C++ F#
public SpellParameter this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As SpellParameter
    Get
    Set
public:
property SpellParameter^ default[int index] {
    SpellParameter^ get (int index);
    void set (int index, SpellParameter^ value);
}
member Item : SpellParameter with get, set
Parameters
index (Int32)
The result number, 0 based.
Property Value
SpellParameter


SpellParameter Class

SpellParameter Class
API Documentation ► Keyoti.RapidSpell.WCF ► SpellParameter
Keyoti RapidSpell Web .NET
Declaration Syntax
C# Visual Basic Visual C++ F#
public class SpellParameter
Public Class SpellParameter
public ref class SpellParameter
type SpellParameter =  class end
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParameterName | The param name.
 | ParameterValue | The param value.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
SpellParameter


ParameterName Property

ParameterName Property
API Documentation ► Keyoti.RapidSpell.WCF ► SpellParameter ► ParameterName
Keyoti RapidSpell Web .NET
The param name.
Declaration Syntax
C# Visual Basic Visual C++ F#
public string ParameterName { get; set; }
Public Property ParameterName As String
    Get
    Set
public:
property String^ ParameterName {
    String^ get ();
    void set (String^ value);
}
member ParameterName : string with get, set
Property Value
String


ParameterValue Property

ParameterValue Property
API Documentation ► Keyoti.RapidSpell.WCF ► SpellParameter ► ParameterValue
Keyoti RapidSpell Web .NET
The param value.
Declaration Syntax
C# Visual Basic Visual C++ F#
public string ParameterValue { get; set; }
Public Property ParameterValue As String
    Get
    Set
public:
property String^ ParameterValue {
    String^ get ();
    void set (String^ value);
}
member ParameterValue : string with get, set
Property Value
String


GetRouteUrl Method

GetRouteUrl Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► GetRouteUrl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | GetRouteUrl(Object) |
 | GetRouteUrl(String, Object) |
 | GetRouteUrl(RouteValueDictionary) |
 | GetRouteUrl(String, RouteValueDictionary) |


GetRouteUrl Method

GetRouteUrl Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► GetRouteUrl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | GetRouteUrl(Object) |
 | GetRouteUrl(String, Object) |
 | GetRouteUrl(RouteValueDictionary) |
 | GetRouteUrl(String, RouteValueDictionary) |


RenderControl Method

RenderControl Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineHelper ► RenderControl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.


RenderControl Method

RenderControl Method
API Documentation ► Keyoti.RapidSpell ► RSSelect ► RenderControl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.


LastIndexOf Method

LastIndexOf Method
API Documentation ► Keyoti.RapidSpell.WCF ► ParameterCollection ► LastIndexOf()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>.
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index.
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index.


Sort Method

Sort Method
API Documentation ► Keyoti.RapidSpell.WCF ► ParameterCollection ► Sort()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer.
 | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer.
 | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer.
 | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>.


SetTraceData Method

SetTraceData Method
API Documentation ► Keyoti.RapidSpell ► RSSelect ► SetTraceData()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | SetTraceData(Object, Object) |
 | SetTraceData(Object, Object, Object) |


Dispose Method

Dispose Method
API Documentation ► Keyoti.RapidSpell.ASMX ► InlineService ► Dispose()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | Dispose()()()() | Releases all resources used by the MarshalByValueComponent.
 | Dispose(Boolean) | Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.


DataBind Method

DataBind Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► DataBind()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | DataBind()()()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.


RenderControl Method

RenderControl Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineTextBox ► RenderControl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.


RenderControl Method

RenderControl Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► RenderControl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.


GetRouteUrl Method

GetRouteUrl Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellCheckerClient ► GetRouteUrl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | GetRouteUrl(Object) |
 | GetRouteUrl(String, Object) |
 | GetRouteUrl(RouteValueDictionary) |
 | GetRouteUrl(String, RouteValueDictionary) |


RenderControl Method

RenderControl Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► RenderControl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.


DataBind Method

DataBind Method
API Documentation ► Keyoti.RapidSpell ► RSText ► DataBind()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | DataBind()()()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.


SetTraceData Method

SetTraceData Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellCheckerClient ► SetTraceData()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | SetTraceData(Object, Object) |
 | SetTraceData(Object, Object, Object) |


GetRouteUrl Method

GetRouteUrl Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► GetRouteUrl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | GetRouteUrl(Object) |
 | GetRouteUrl(String, Object) |
 | GetRouteUrl(RouteValueDictionary) |
 | GetRouteUrl(String, RouteValueDictionary) |


SetTraceData Method

SetTraceData Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineTextBox ► SetTraceData()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | SetTraceData(Object, Object) |
 | SetTraceData(Object, Object, Object) |


FindControl Method

FindControl Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► FindControl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method.


RenderControl Method

RenderControl Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellCheckerClient ► RenderControl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.


FindControl Method

FindControl Method
API Documentation ► Keyoti.RapidSpell ► RSText ► FindControl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method.


GetRouteUrl Method

GetRouteUrl Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineHelper ► GetRouteUrl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | GetRouteUrl(Object) |
 | GetRouteUrl(String, Object) |
 | GetRouteUrl(RouteValueDictionary) |
 | GetRouteUrl(String, RouteValueDictionary) |


SetTraceData Method

SetTraceData Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► SetTraceData()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | SetTraceData(Object, Object) |
 | SetTraceData(Object, Object, Object) |


DataBind Method

DataBind Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineHelper ► DataBind()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | DataBind()()()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.


SetTraceData Method

SetTraceData Method
API Documentation ► Keyoti.RapidSpell ► RSText ► SetTraceData()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | SetTraceData(Object, Object) |
 | SetTraceData(Object, Object, Object) |


FindControl Method

FindControl Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► FindControl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method.


IndexOf Method

IndexOf Method
API Documentation ► Keyoti.RapidSpell.WCF ► ParameterCollection ► IndexOf()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>.
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element.
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements.


DataBind Method

DataBind Method
API Documentation ► Keyoti.RapidSpell ► RSLabel ► DataBind()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | DataBind()()()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.


GetRouteUrl Method

GetRouteUrl Method
API Documentation ► Keyoti.RapidSpell ► RSSelect ► GetRouteUrl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | GetRouteUrl(Object) |
 | GetRouteUrl(String, Object) |
 | GetRouteUrl(RouteValueDictionary) |
 | GetRouteUrl(String, RouteValueDictionary) |


FindIndex Method

FindIndex Method
API Documentation ► Keyoti.RapidSpell.WCF ► ParameterCollection ► FindIndex()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>.
 | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element.
 | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements.


AddAttributesToRender Method

AddAttributesToRender Method
API Documentation ► Keyoti.RapidSpell ► PreviewPaneStyle ► AddAttributesToRender()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | AddAttributesToRender(HtmlTextWriter, Page, ClientFilesLocation) | Adds HTML attributes and styles that need to be rendered to the specified System.Web.UI.HtmlTextWriter
 | AddAttributesToRender(HtmlTextWriter) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriter. This method is primarily used by control developers.
 | AddAttributesToRender(HtmlTextWriter, WebControl) | Adds HTML attributes and styles that need to be rendered to the specified HtmlTextWriter and Web server control. This method is primarily used by control developers.


Reverse Method

Reverse Method
API Documentation ► Keyoti.RapidSpell.WCF ► ParameterCollection ► Reverse()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>.
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range.


SetTraceData Method

SetTraceData Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► SetTraceData()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | SetTraceData(Object, Object) |
 | SetTraceData(Object, Object, Object) |


GetRouteUrl Method

GetRouteUrl Method
API Documentation ► Keyoti.RapidSpell ► RSButton ► GetRouteUrl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | GetRouteUrl(Object) |
 | GetRouteUrl(String, Object) |
 | GetRouteUrl(RouteValueDictionary) |
 | GetRouteUrl(String, RouteValueDictionary) |


GetRouteUrl Method

GetRouteUrl Method
API Documentation ► Keyoti.RapidSpell ► RSLabel ► GetRouteUrl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | GetRouteUrl(Object) |
 | GetRouteUrl(String, Object) |
 | GetRouteUrl(RouteValueDictionary) |
 | GetRouteUrl(String, RouteValueDictionary) |


FindControl Method

FindControl Method
API Documentation ► Keyoti.RapidSpell ► RSSelect ► FindControl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method.


BinarySearch Method

BinarySearch Method
API Documentation ► Keyoti.RapidSpell.WCF ► ParameterCollection ► BinarySearch()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element.
 | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element.
 | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element.


SetTraceData Method

SetTraceData Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► SetTraceData()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | SetTraceData(Object, Object) |
 | SetTraceData(Object, Object, Object) |


Dispose Method

Dispose Method
API Documentation ► Keyoti.RapidSpell ► PreviewPaneStyle ► Dispose()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | Dispose()()()() | Releases all resources used by the Component.
 | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources.


FindControl Method

FindControl Method
API Documentation ► Keyoti.RapidSpell ► RSLabel ► FindControl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method.


FindControl Method

FindControl Method
API Documentation ► Keyoti.RapidSpell ► RSButton ► FindControl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method.


DataBind Method

DataBind Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWeb ► DataBind()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | DataBind()()()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.


DataBind Method

DataBind Method
API Documentation ► Keyoti.RapidSpell ► RSSelect ► DataBind()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | DataBind()()()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.


GetRouteUrl Method

GetRouteUrl Method
API Documentation ► Keyoti.RapidSpell ► RSText ► GetRouteUrl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | GetRouteUrl(Object) |
 | GetRouteUrl(String, Object) |
 | GetRouteUrl(RouteValueDictionary) |
 | GetRouteUrl(String, RouteValueDictionary) |


DataBind Method

DataBind Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineTextBox ► DataBind()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | DataBind()()()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.


SetTraceData Method

SetTraceData Method
API Documentation ► Keyoti.RapidSpell ► RSLabel ► SetTraceData()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | SetTraceData(Object, Object) |
 | SetTraceData(Object, Object, Object) |


SetTraceData Method

SetTraceData Method
API Documentation ► Keyoti.RapidSpell ► RSButton ► SetTraceData()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | SetTraceData(Object, Object) |
 | SetTraceData(Object, Object, Object) |


DataBind Method

DataBind Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► DataBind()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | DataBind()()()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.


SetTraceData Method

SetTraceData Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineHelper ► SetTraceData()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | SetTraceData(Object, Object) |
 | SetTraceData(Object, Object, Object) |


RenderControl Method

RenderControl Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► RenderControl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.


FindControl Method

FindControl Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineHelper ► FindControl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method.


RenderControl Method

RenderControl Method
API Documentation ► Keyoti.RapidSpell ► RSButton ► RenderControl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.


DataBind Method

DataBind Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellCheckerClient ► DataBind()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | DataBind()()()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.


RenderControl Method

RenderControl Method
API Documentation ► Keyoti.RapidSpell ► RSLabel ► RenderControl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.


RenderControl Method

RenderControl Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► RenderControl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.


RenderControl Method

RenderControl Method
API Documentation ► Keyoti.RapidSpell ► RSText ► RenderControl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.


FindControl Method

FindControl Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineTextBox ► FindControl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method.


GetRouteUrl Method

GetRouteUrl Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInlineTextBox ► GetRouteUrl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | GetRouteUrl(Object) |
 | GetRouteUrl(String, Object) |
 | GetRouteUrl(RouteValueDictionary) |
 | GetRouteUrl(String, RouteValueDictionary) |


FindLastIndex Method

FindLastIndex Method
API Documentation ► Keyoti.RapidSpell.WCF ► ParameterCollection ► FindLastIndex()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>.
 | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index.
 | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index.


FindControl Method

FindControl Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebLauncher ► FindControl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method.


SetTraceData Method

SetTraceData Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► SetTraceData()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | SetTraceData(Object, Object) |
 | SetTraceData(Object, Object, Object) |


MemberwiseClone Method

MemberwiseClone Method
API Documentation ► Keyoti.RapidSpell ► PreviewPaneStyle ► MemberwiseClone()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.


GetRouteUrl Method

GetRouteUrl Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► GetRouteUrl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | GetRouteUrl(Object) |
 | GetRouteUrl(String, Object) |
 | GetRouteUrl(RouteValueDictionary) |
 | GetRouteUrl(String, RouteValueDictionary) |


CopyTo Method

CopyTo Method
API Documentation ► Keyoti.RapidSpell.WCF ► ParameterCollection ► CopyTo()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array.
 | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array.
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array.


DataBind Method

DataBind Method
API Documentation ► Keyoti.RapidSpell ► RSButton ► DataBind()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | DataBind()()()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.


DataBind Method

DataBind Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWebMultiple ► DataBind()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | DataBind()()()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.


FindControl Method

FindControl Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellWInline ► FindControl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method.


FindControl Method

FindControl Method
API Documentation ► Keyoti.RapidSpell ► RapidSpellCheckerClient ► FindControl()()()()
Keyoti RapidSpell Web .NET
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()()() method.


RapidSpell Web .NET Documentation: Client Side Events

Client Side Events

RapidSpell Web provides an interface to the various events and functions present on the client side in Javascript (ECMAscript). This allows further behaviour customization when the spell checker is used in popup mode. The current highlights are;

Notification of the spell check finished event
Notification that the user has corrected a word
Exposure of the Javascript function that launches the spell checking

FinishedListener - Finished Event

It is possible to determine when spell checking has finished (in pop up mode) by using the FinishedListener property of RapidSpellWebLauncher. This property can be set to the name of a JavaScript function in the main form, which will be called from the pop up when the user finishes checking the document (either by completing the check, closing the window, or by clicking the 'Finish' button). The function must not expect arguments, unless the FinishedListenerInformState is set true and be with in the scope of the whole page (if FinishedListenerInformState=true then the argument is true if spell check completed, false if cancelled).

For example;

...............
<script>
    function notifyDone(){
        alert('Finished event captured.');
    }
</script>
...............
<RapidSpellWeb:RapidSpellWebLauncher id="rapidSpellWebLauncher" runat="server"
    TextComponentName="myForm.sourceTextBox"
    TextComponentInterface="Standard"
    FinishedListener="notifyDone"
    Mode="popup"
    SeparateHyphenWords=true
    RapidSpellWebPage="RapidSpellCheckerPopUp.aspx"/>
...............

CorrectionNotifyListener - User Correction Event

To be notified every time that the user has corrected a word, set the CorrectionNotifyListener property of RapidSpellWebLauncher to the name part of a Javascript function present on the main page.

For example;

...............
<script>
    function OnCorrection(startIndex, oldWord, newWord, textboxId){
        alert('Correction occured to word at index '+startIndex+' old word
was '+oldWord+' replacement text is '+newWord+' and it happened in textbox '+textboxId);
    }
</script>
...............
<RapidSpellWeb:RapidSpellWebLauncher id="rapidSpellWebLauncher" runat="server"
    TextComponentName="myForm.sourceTextBox"
    TextComponentInterface="Standard"
    CorrectionNotifyListener="OnCorrection"
    Mode="popup"
    RapidSpellWebPage="RapidSpellCheckerPopUp.aspx"/>
...............